Help - Search - Members - Calendar
Full Version: Installing FastCube
Fast Reports forum > Fast Reports Products > FastCube

The "Install.txt" file that comes with FastCube for Delphi XE2 is pretty terse, so I have some questions.

First, here is the text concerning FastCube's packages:

FastCube includes several packages, divided into runtime and design-time
parts. Design-time packages have 'dcl' prefix in the package name. Each
package has a number, corresponding to the Delphi version. For example,
dclfrod7.dpk is a design-time package for Delphi7. Here is a list of
runtime packages used by FastCube1 ('*' denotes a Delphi version (d7, d10)):

fc*.dpk - FastCube, main package

Design-time packages are:

dclfc*.dpk - FastCube

WHY are there separate design-time and run-time packages? I'm not familiar with this. For most components, I install, it goes on the component palette, I use it in design and it appears in the finished app. So, why are there separate packages?

Does this imply that there is something that will need to be provided in the app's distribution?


Step 3. Copy runtime packages to system folder
3.1. copy the following files from the Delphi_dir\Projects\Bpl folder
to the Windows\System32 folder (or Windows\System for Win9x/Me):
- fc*.bpl (* = your delphi version)

Putting things into the Windows system folder makes me nervous!
What is that all about?
Will users of the finished app have to do that as well?

Finally, a question about FastCube in general:

Is it required that the data to be displayed must be delivered by a TDataSource? Can the data just be supplied by a routine I provide, such as an event handler or other routine?



1. Delphi allows applications to be built with run-time packages. This is for those application. You don't need to care about this - you have a recompile application to simplify installation process
2. Don't be nervous about windows system folder - this is for older versions of delphi. Recent delphi does not do this, so you can skip it too. But those files needs to be somewhere in the PATH
3. FastCube 1 can load data only from a TDataSet descendant. This will change in FastCube 2 but not earlier.

Best regards,
Oleg Pryalkov.
OK, so I can skip the start of the "Install.txt" file and go directly to "Recompiling FastCube packages"?

And when you say, "you have a recompile application to simplify installation process", I assume you are referring to the file "recompile.exe"?

If so, then that's good. When running "recompile.exe", I see that the first popup labelled "1. Select the compiler" doesn't show the choice after one is chosen. That's OK? (The title bar says, "FastCune 1.9 recompile wizard (1.3)".)

After clicking "Compile" I get this message:

Can not find folder with library files:
C:\Program Files (x86)\FastReports\Fast Cube Embarcadero

Indeed, in that directory there exists folders for "LibD16" and "LibD16x64" but not "LibD-1064632320".

What should I do next?

(Thank you!)

1. run recompile.exe
2. select any compiler (not RAD Studio XE2)
3. close recompile.exe
4. run recompile.exe
5. select RAD Studio XE2
6. compile.

Best regards,
Oleg Pryalkov.
Thank you -- getting closer!

But if I run "recompile.exe" and choose EITHER of these:

Embarcadero RAD Studio XE2 x34 (Delphi, C++)
Embarcadero RAD Studio XE2 x64 (Delphi, C++)

and click "Compile", this message is displayed:

Cannot create file "C:\Program Files (x86)\FastReports\FastCube
Embarcadero edition\run.bat". Access is denied.

I also tried logging in as Administrator and running "recompile.exe", but received the same error.

What should I try next?

A little more progress: I had tried logging out and logging in as Administrator, but that produced the same error. Now I tried right-clicking on "recompile.exe" and choosing "Run as administrator". And that worked!

BUT ...

After clicking "Compile", this dialog was displayed:

Recompiled files are in the
"C:\Program Files (x86)\FastReports\FastCube Embarcadero
edition\LibD16x64" folder.
Be sure that your Delphi/BCB Library path is set up correctly.

That SOUNDS good, but what does that "Be sure..." line imply? Is everything OK, or is telling me about an error? And what is it mean (in this case) about having the path set "correctly"? "Correctly" for what?

In addition, the following message appear at the bottom of the recompile dialog:

delphi16x64 error: fcd16.dpk(115) Fatal: F1026 File not found: 'fcCustomFormat.dcu'
fcd16.dpk not compiled!

That sounds bad!

But what do I do about it?


For FastCube Embarcadero edition use update from our site:

Best regards,
Oleg Pryalkov.
OK, I downloaded the patch and successfully installed the FastCube components into Delphi XE2 (yay-yay!!!!)

As a first project, I'm trying to replicate the example at the start of the "FastCube 1.0 Programmer manual".

Page 8 has an illustration showing the placed components named "fcCube1" and "fcSlice1", the default names. I changed the default names instead to the names "froCube1" and "froSlice1" as shown in the text on page 8 and the sample code on page 9. (Perhaps either the text or the illustration needs a revision?)

I set TTable and froCube1 as instructed.

Before adding the "FormCreate" code, I tried running (F9) the project.

It runs but the labeling on the grid is all in Russian! (I checked, and I did indeed set the language as English in the recompile.exe tool.)

Let's proceed ...

Page 9 shows code for the form's Create event. Problems:
1) The default name of the form's create event is "FormCreate", not "Create" as shown on page 9.
2) The argument is "Sender: TObject", rather than what is shown on page 9: "AOwner: TComponent".
Example needs revision?

I tried running, got some errors, but eventually figured out that the "USES" statement needs "fcTypes". That should be mentioned in the example.

But then I got this message when trying to compile:

[DCC Error] Unit2.pas(36): E2250 There is no overloaded version of "AddFieldTo" that can be called with these arguments

That message appeared for all five of the uses of the "AddFieldTo" call specified in the Programmer's manual, page 9.
Did you perhaps change the call but not the sample code in the manual?

I looked at one of your sample projects and it seems that the AddFieldTo call now has another argument, and in the sample it looks like a name string now appears twice, so I made that change in the five calls in the sample code from the manual.

Now it compiles and runs, but as soon as it attempts the line "froCube1.Active := True" we get this message:

Debugger Exception Notification
Project Project1.exe raised exception class EDBEngineError with message 'Network initialization failed.
Permission denied.
Directory: C:\'.

The old DBDEMOS database using BDE is just too troublesome to be using in demos any more!

So, I threw out the TTable and replaced it with a TClientDataSet, and then used a right-click and "Load from MyBase Table" to fill it with data from an XML file.

I tried to make some changes in the FormCreate code accordingly (as best as I can, given that I'm just starting out with FastCube). But when I run the program, all I get is a an empty grid. The labels on that grid are now at runtime in English, but there is no way to do anything or set anything. I suppose it has something to do with setting the names correctly, but since I'm just starting out I'm not at all sure how to revise those arguments, especially since the arguments shown in the Programmer's manual are out of date.

In short, this is all very frustrating. The installation was messy, and I keep running into roadblocks.

I don't know whether to press on or give up. I would hate to spend time trying to set up and access creaky old DBDEMOS databases just to do a sample project, but I have no instructions or samples on how to do anything else.


Thank you.


1. See updated documentation from
2. See example and step by step instruction in

Best regards,
Oleg Pryalkov.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.