IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> FastReport-mono - Demo - Object not found Error (Error 404)
Synaptris
post Oct 20 2012, 11:07 AM
Post #1


Newbie
*

Group: Members
Posts: 2
Joined: 20-October 12
Member No.: 56675



Hi
We have installed the mono on OpenSUSE Linux Version 12.2.

We had installed successfully installed the following packages:
the Apache web server
the runtime Mono
mod_mono
xsp server (implements ASP.NET-pages functionality)

After this, we tried executing sample HelloWorld aspx pages and it executes successfully.

But while trying to executing the FastReport demos, we are encountering the following issues:

1. While executing the demos in the folder Demos/C#/Web/Default.aspx, we are getting "Object not found" error (Error 404).
(We had also provided the permissions 777 to the entire Fast-Reports folder and its sub-folders & files).


2. We are getting the following error while executing "mono Demo.exe" from command line:
====================================================================
Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.XplatUI ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.GDIPlus ---> System.DllNotFoundException: gdiplus.dll
at (wrapper managed-to-native) System.Drawing.GDIPlus:GdiplusStartup (ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&)
at System.Drawing.GDIPlus..cctor () [0x00000] in <filename unknown>:0
--- End of inner exception stack trace ---
at System.Drawing.Graphics.FromHdcInternal (IntPtr hdc) [0x00000] in <filename unknown>:0
at System.Windows.Forms.XplatUIX11.SetDisplay (IntPtr display_handle) [0x00000] in <filename unknown>:0
at System.Windows.Forms.XplatUIX11..ctor () [0x00000] in <filename unknown>:0
at System.Windows.Forms.XplatUIX11.GetInstance () [0x00000] in <filename unknown>:0
at System.Windows.Forms.XplatUI..cctor () [0x00000] in <filename unknown>:0
--- End of inner exception stack trace ---
at System.Windows.Forms.Application.EnableVisualStyles () [0x00000] in <filename unknown>:0
at Demo.Program.Main () [0x00000] in <filename unknown>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.XplatUI ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.GDIPlus ---> System.DllNotFoundException: gdiplus.dll
at (wrapper managed-to-native) System.Drawing.GDIPlus:GdiplusStartup (ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&)
at System.Drawing.GDIPlus..cctor () [0x00000] in <filename unknown>:0
--- End of inner exception stack trace ---
at System.Drawing.Graphics.FromHdcInternal (IntPtr hdc) [0x00000] in <filename unknown>:0
at System.Windows.Forms.XplatUIX11.SetDisplay (IntPtr display_handle) [0x00000] in <filename unknown>:0
at System.Windows.Forms.XplatUIX11..ctor () [0x00000] in <filename unknown>:0
at System.Windows.Forms.XplatUIX11.GetInstance () [0x00000] in <filename unknown>:0
at System.Windows.Forms.XplatUI..cctor () [0x00000] in <filename unknown>:0
--- End of inner exception stack trace ---
at System.Windows.Forms.Application.EnableVisualStyles () [0x00000] in <filename unknown>:0
at Demo.Program.Main () [0x00000] in <filename unknown>:0
================================================================================
==================

Can you help me to address the above issues so that we can have it working in our environment?

Appreciate your immediate help.

regards
Param
Go to the top of the page
 
+Quote Post
alman
post Oct 24 2012, 05:43 AM
Post #2


Advanced Member
***

Group: FR Team
Posts: 38
Joined: 8-April 05
Member No.: 1908



I think that you have installed Framework 4.0, but you should install Framework 2.0 too.

Go to the top of the page
 
+Quote Post
Synaptris
post Oct 24 2012, 12:38 PM
Post #3


Newbie
*

Group: Members
Posts: 2
Joined: 20-October 12
Member No.: 56675



Thanks for the response.
I have installed Framework 2.0 Only.

regards
Param
Go to the top of the page
 
+Quote Post
alman
post Oct 29 2012, 05:38 AM
Post #4


Advanced Member
***

Group: FR Team
Posts: 38
Joined: 8-April 05
Member No.: 1908



Sorry for response delay.

It seems that some dll are missing. Here is useful link: http://www.mono-project.com/DllNotFoundException

We have tested FR.Mono under Suse Linux , Ubuntu Linux, Mac OS X and Windows and we cannot reproduce that error. What operating system are you using?

Could you create a simple WinWorms project, see what is going on, and tell us?


Sincerely,
Aleksey
Go to the top of the page
 
+Quote Post
Bohatyaor
post Apr 26 2016, 05:18 AM
Post #5


Newbie
*

Group: Members
Posts: 1
Joined: 26-April 16
Member No.: 62317



An exception was thrown by the type initializer for System.Windows.Forms.XplatUI ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.GDIPlus ---> System.DllNotFoundException: gdiplus.dll???


--------------------
Go to the top of the page
 
+Quote Post
Max123
post May 19 2016, 06:56 AM
Post #6


Newbie
*

Group: Members
Posts: 1
Joined: 19-May 16
Member No.: 62399



I anticipate that you accept installed Framework 4.0, but you should install Framework 2.0 too.


--------------------
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Time is now: 20th June 2019 - 01:07 PM