frxXX

Namespaces
Name | Description
frx2DBarcodesPresets | Represents namespace frx2DBarcodesPresets.
frxAggregate | Represents namespace frxAggregate.
frxAnaliticGeometry | Represents namespace frxAnaliticGeometry.
frxBarcod | Represents namespace frxBarcod.
frxBarcode | Represents namespace frxBarcode.
frxBarcode2D | Represents namespace frxBarcode2D.
frxBarcode2DBase | Represents namespace frxBarcode2DBase.
frxBarcodeAztec | Represents namespace frxBarcodeAztec.
frxBarcodeDataMatrix | Represents namespace frxBarcodeDataMatrix.
frxBarcodeMaxiCode | Represents namespace frxBarcodeMaxiCode.
frxBarcodePDF417 | Represents namespace frxBarcodePDF417.
frxBarcodeProperties | Represents namespace frxBarcodeProperties.
frxBarcodeQR | Represents namespace frxBarcodeQR.
frxBarcodOneCode | Represents namespace frxBarcodOneCode.
frxBaseForm | This unit contains classes of the base dialog form used for every form in FastReport. This form handles save and load state, HIDPI messages, localization messages.
frxCellularTextObject | Represents namespace frxCellularTextObject.
frxChBox | Represents namespace frxChBox.
frxClass | Main FastReport unit. This unit contains base classes of report objects and report class itself. To use FastReport components this unit should be included in uses clause.
frxCodeUtils | Represents namespace frxCodeUtils.
frxCollections | Represents namespace frxCollections.
frxComCtrls | Represents namespace frxComCtrls.
frxCross | Represents namespace frxCross.
frxCrypt | Represents namespace frxCrypt.
frxCtrls | Represents namespace frxCtrls.
frxCustomEditors | Represents namespace frxCustomEditors.
frxDataTree | Represents namespace frxDataTree.
frxDCtrl | Represents namespace frxDCtrl.
frxDelphiMaxiCode | Represents namespace frxDelphiMaxiCode.
frxDelphiZXIngAztecCode | Represents namespace frxDelphiZXIngAztecCode.
frxDelphiZXIngCode | Represents namespace frxDelphiZXIngCode.
frxDelphiZXingQRCode | Represents namespace frxDelphiZXingQRCode.
frxDesgn | Represents namespace frxDesgn.
frxDesgnCtrls | Represents namespace frxDesgnCtrls.
frxDesgnEditors | Represents namespace frxDesgnEditors.
frxDialogForm | Represents namespace frxDialogForm.
frxDMPClass | Represents namespace frxDMPClass.
frxDMPExport | Represents namespace frxDMPExport.
frxDock | Represents namespace frxDock.
frxDPIAwareBaseControls | Represents namespace frxDPIAwareBaseControls.
frxDPIAwareInt | Represents namespace frxDPIAwareInt.
frxDsgnIntf | Represents namespace frxDsgnIntf.
frxEngine | Represents namespace frxEngine.
frxERSIShapeDBFImport | Represents namespace frxERSIShapeDBFImport.
frxERSIShapeFileFormat | Represents namespace frxERSIShapeFileFormat.
frxFileUtils | Represents namespace frxFileUtils.
frxGauge | Represents namespace frxGauge.
frxGaugeDialogControl | Represents namespace frxGaugeDialogControl.
frxGaugePanel | Represents namespace frxGaugePanel.
frxGaugeView | Represents namespace frxGaugeView.
frxGPXFileFormat | Represents namespace frxGPXFileFormat.
frxGradient | Represents namespace frxGradient.
frxGraphicControls | Represents namespace frxGraphicControls.
frxGraphicUtils | Represents namespace frxGraphicUtils.
frxGS1Databar | Represents namespace frxGS1Databar.
frxGS1Databar_Helper | Represents namespace frxGS1Databar_Helper.
frxGS1Helper | Represents namespace frxGS1Helper.
frxGZip | Represents namespace frxGZip.
frxInPlaceClipboards | Represents namespace frxInPlaceClipboards.
frxInPlaceEditors | Represents namespace frxInPlaceEditors.
frxInsp | Represents namespace frxInsp.
frxIOTransportDialog | Represents namespace frxIOTransportDialog.
frxIOTransportIntf | Represents namespace frxIOTransportIntf.
frxMap | Represents namespace frxMap.
frxMapGeodataLayer | Represents namespace frxMapGeodataLayer.
frxMapHelpers | Represents namespace frxMapHelpers.
frxMapInteractiveLayer | Represents namespace frxMapInteractiveLayer.
frxMapLayer | Represents namespace frxMapLayer.
frxMapLayerTags | Represents namespace frxMapLayerTags.
frxMapRanges | Represents namespace frxMapRanges.
frxMapShape | Represents namespace frxMapShape.
frxMapShapeTags | Represents namespace frxMapShapeTags.
frxmd5 |
frxNetUtils | Represents namespace frxNetUtils.
frxOLE | Represents namespace frxOLE.
frxOSMFileFormat | Represents namespace frxOSMFileFormat.
frxPictureCache | Represents namespace frxPictureCache.
frxPlatformServices | Represents namespace frxPlatformServices.
frxPolygonTemplate | Represents namespace frxPolygonTemplate.
frxPopupForm | Represents namespace frxPopupForm.
frxPreview | Represents namespace frxPreview.
frxPreviewPages | Represents namespace frxPreviewPages.
frxPreviewPageSettings | Represents namespace frxPreviewPageSettings.
frxPrinter | Represents namespace frxPrinter.
frxQRCodeSwissPreset | Represents namespace frxQRCodeSwissPreset.
frxReportTree | Represents namespace frxReportTree.
frxRes | Represents namespace frxRes.
frxRich | Represents namespace frxRich.
frxRichEdit | Represents namespace frxRichEdit.
frxServerUtils | Represents namespace frxServerUtils.
frxStorage | Represents namespace frxStorage.
frxSynMemo | Represents namespace frxSynMemo.
frxTableObject | This unit contains classes of Table report object.
frxThreading | Represents namespace frxThreading.
frxUnicodeCtrls | Represents namespace frxUnicodeCtrls.
frxUnicodeUtils | Represents namespace frxUnicodeUtils.
frxUtils | The unit contains additional helper function used by other FastReports units like type conversions, CRC calculation, image draw and others.
frxVariables | Represents namespace frxVariables.
frxVectorCanvas | Represents namespace frxVectorCanvas.
frxXML | Represents namespace frxXML.
frxXMLSerializer | Represents namespace frxXMLSerializer.
frxZipCode | Represents namespace frxZipCode.
frxZLib | Represents namespace frxZLib.
Top
Powered by Fast Reports Inc.


frx2DBarcodesPresets Namespace

Summary

Represents namespace frx2DBarcodesPresets.

Classes
Name | Description
TfrxObjectDataPreset | Represents type TfrxObjectDataPreset.
Top
Routines
Name | Description
frxBarcode2DPresetList | Represents method frxBarcode2DPresetList.
Top


frx2DBarcodesPresets Classes

Classes
Name | Description
TfrxObjectDataPreset | Represents type TfrxObjectDataPreset.
Top


TfrxObjectDataPreset Class

Summary

Represents type TfrxObjectDataPreset.

Namespace: frx2DBarcodesPresets
Inheritance Hierarchy
TInterfacedPersistent
frx2DBarcodesPresets.TfrxObjectDataPreset
Syntax
Delphi
type
 TfrxObjectDataPreset = class(TInterfacedPersistent, IStringClassNameContainer)
 end;

The TfrxObjectDataPreset type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponent) | Initializes a new instance of the TfrxObjectDataPreset class.
Destroy | Represents the destructor of the TfrxObjectDataPreset class.
Top
Properties
Show:
Name | Description
DataObject | Represents property DataObject.
PresetClass | Represents property PresetClass.
Top
Methods
Show:
Name | Description
ClearPreset | Represents method ClearPreset.
GetData(TfrxReport) | Represents method GetData(TfrxReport).
GetDataObject | Represents method GetDataObject.
GetPresetClass | Represents method GetPresetClass.
GetSupportedClasses | Represents method GetSupportedClasses.
IsHasPresetData | Represents method IsHasPresetData.
SetPresetClass(TfrxStringClassName) | Represents method SetPresetClass(TfrxStringClassName).
Top
Fields
Show:
Name | Description
FDataObject | Represents field FDataObject.
FOwner | Represents field FOwner.
Top
See Also

Reference

  • frx2DBarcodesPresets


TfrxObjectDataPreset Constructors

Constructors
Name | Description
Create(TfrxComponent) | Initializes a new instance of the TfrxObjectDataPreset class.
Destroy | Represents the destructor of the TfrxObjectDataPreset class.
Top


TfrxObjectDataPreset.Create(TfrxComponent) Constructor

Summary

Initializes a new instance of the TfrxObjectDataPreset class.

Namespace: frx2DBarcodesPresets
Syntax
Delphi
public
 constructor Create(AOwner: TfrxComponent);

Parameters

AOwner
Type: TfrxComponent

See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


TfrxObjectDataPreset.Destroy Destructor

Summary

Represents the destructor of the TfrxObjectDataPreset class.

Namespace: frx2DBarcodesPresets
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


TfrxObjectDataPreset Properties

Properties
Name | Description
DataObject | Represents property DataObject.
PresetClass | Represents property PresetClass.
Top


TfrxObjectDataPreset.DataObject Property

Summary

Represents property DataObject.

Namespace: frx2DBarcodesPresets
Syntax
Delphi
published
 property DataObject: TfrxCustomObjectPreset read GetDataObject;

Property Value

Type: TfrxCustomObjectPreset

See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


TfrxObjectDataPreset.PresetClass Property

Summary

Represents property PresetClass.

Namespace: frx2DBarcodesPresets
Syntax
Delphi
published
 property PresetClass: TfrxStringClassName read GetPresetClass write SetPresetClass;

Property Value

Type: TfrxStringClassName

See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


TfrxObjectDataPreset Methods

Methods
Name | Description
ClearPreset | Represents method ClearPreset.
GetData(TfrxReport) | Represents method GetData(TfrxReport).
GetDataObject | Represents method GetDataObject.
GetPresetClass | Represents method GetPresetClass.
GetSupportedClasses | Represents method GetSupportedClasses.
IsHasPresetData | Represents method IsHasPresetData.
SetPresetClass(TfrxStringClassName) | Represents method SetPresetClass(TfrxStringClassName).
Top


TfrxObjectDataPreset.ClearPreset Method

Summary

Represents method ClearPreset.

Namespace: frx2DBarcodesPresets
Syntax
Delphi
private
 procedure ClearPreset;
See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


TfrxObjectDataPreset.GetData(TfrxReport) Method

Summary

Represents method GetData(TfrxReport).

Namespace: frx2DBarcodesPresets
Syntax
Delphi
public
 function GetData(aReport: TfrxReport): String; virtual;

Parameters

aReport
Type: TfrxReport

Return Value

Type: String

See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


TfrxObjectDataPreset.GetDataObject Method

Summary

Represents method GetDataObject.

Namespace: frx2DBarcodesPresets
Syntax
Delphi
private
 function GetDataObject: TfrxCustomObjectPreset;

Return Value

Type: TfrxCustomObjectPreset

See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


TfrxObjectDataPreset.GetPresetClass Method

Summary

Represents method GetPresetClass.

Namespace: frx2DBarcodesPresets
Syntax
Delphi
private
 function GetPresetClass: TfrxStringClassName;

Return Value

Type: TfrxStringClassName

See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


TfrxObjectDataPreset.GetSupportedClasses Method

Summary

Represents method GetSupportedClasses.

Namespace: frx2DBarcodesPresets
Syntax
Delphi
private
 function GetSupportedClasses: TList;

Return Value

Type: TList

Implements

IStringClassNameContainer.GetSupportedClasses
See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


TfrxObjectDataPreset.IsHasPresetData Method

Summary

Represents method IsHasPresetData.

Namespace: frx2DBarcodesPresets
Syntax
Delphi
public
 function IsHasPresetData: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


TfrxObjectDataPreset.SetPresetClass(TfrxStringClassName) Method

Summary

Represents method SetPresetClass(TfrxStringClassName).

Namespace: frx2DBarcodesPresets
Syntax
Delphi
private
 procedure SetPresetClass(const Value: TfrxStringClassName);

Parameters

Value
Type: TfrxStringClassName

See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


TfrxObjectDataPreset Fields

Fields
Name | Description
FDataObject | Represents field FDataObject.
FOwner | Represents field FOwner.
Top


TfrxObjectDataPreset.FDataObject Field

Summary

Represents field FDataObject.

Namespace: frx2DBarcodesPresets
Syntax
Delphi
private
 FDataObject: TfrxCustomObjectPreset;

Field Value

Type: TfrxCustomObjectPreset

See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


TfrxObjectDataPreset.FOwner Field

Summary

Represents field FOwner.

Namespace: frx2DBarcodesPresets
Syntax
Delphi
private
 FOwner: TfrxComponent;

Field Value

Type: TfrxComponent

See Also

Reference

  • TfrxObjectDataPreset
  • frx2DBarcodesPresets


frx2DBarcodesPresets Routines

Routines
Name | Description
frxBarcode2DPresetList | Represents method frxBarcode2DPresetList.
Top


frxBarcode2DPresetList Method

Summary

Represents method frxBarcode2DPresetList.

Namespace: frx2DBarcodesPresets
Syntax
Delphi
 function frxBarcode2DPresetList: TList;

Return Value

Type: TList

See Also

Reference

  • frx2DBarcodesPresets


frxAggregate Namespace

Summary

Represents namespace frxAggregate.

Classes
Name | Description
TfrxAggregateItem | Represents type TfrxAggregateItem.
TfrxAggregateList | Represents type TfrxAggregateList.
Top
Enumerations
Name | Description
TfrxAggregateFunction | Represents type TfrxAggregateFunction.
Top


frxAggregate Classes

Classes
Name | Description
TfrxAggregateItem | Represents type TfrxAggregateItem.
TfrxAggregateList | Represents type TfrxAggregateList.
Top


TfrxAggregateItem Class

Summary

Represents type TfrxAggregateItem.

Namespace: frxAggregate
Inheritance Hierarchy
TObject
frxAggregate.TfrxAggregateItem
Syntax
Delphi
type
 TfrxAggregateItem = class(TObject)
 end;

The TfrxAggregateItem type exposes the following members.

Methods
Show:
Name | Description
Calc | Represents method Calc.
DeleteValue | Represents method DeleteValue.
EndKeep | Represents method EndKeep.
Reset | Represents method Reset.
RestoreValue | Represents method RestoreValue.
SaveValue | Represents method SaveValue.
StartKeep | Represents method StartKeep.
Value | Represents method Value.
Top
Fields
Show:
Name | Description
FAggregateFunction | Represents field FAggregateFunction.
FBand | Represents field FBand.
FCountInvisibleBands | Represents field FCountInvisibleBands.
FDontReset | Represents field FDontReset.
FExpression | Represents field FExpression.
FIsPageFooter | Represents field FIsPageFooter.
FItemsArray | Represents field FItemsArray.
FItemsCount | Represents field FItemsCount.
FItemsCountArray | Represents field FItemsCountArray.
FItemsValue | Represents field FItemsValue.
FKeeping | Represents field FKeeping.
FLastCount | Represents field FLastCount.
FLastValue | Represents field FLastValue.
FMemoName | Represents field FMemoName.
FOriginalName | Represents field FOriginalName.
FParentBand | Represents field FParentBand.
FReport | Represents field FReport.
FSavedCount | Represents field FSavedCount.
FSavedValue | Represents field FSavedValue.
FTempItemsCount | Represents field FTempItemsCount.
FTempItemsValue | Represents field FTempItemsValue.
FVColumn | Represents field FVColumn.
Top
See Also

Reference

  • frxAggregate


TfrxAggregateItem Methods

Methods
Name | Description
Calc | Represents method Calc.
DeleteValue | Represents method DeleteValue.
EndKeep | Represents method EndKeep.
Reset | Represents method Reset.
RestoreValue | Represents method RestoreValue.
SaveValue | Represents method SaveValue.
StartKeep | Represents method StartKeep.
Value | Represents method Value.
Top


TfrxAggregateItem.Calc Method

Summary

Represents method Calc.

Namespace: frxAggregate
Syntax
Delphi
public
 procedure Calc;
See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.DeleteValue Method

Summary

Represents method DeleteValue.

Namespace: frxAggregate
Syntax
Delphi
public
 procedure DeleteValue;
See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.EndKeep Method

Summary

Represents method EndKeep.

Namespace: frxAggregate
Syntax
Delphi
public
 procedure EndKeep;
See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.Reset Method

Summary

Represents method Reset.

Namespace: frxAggregate
Syntax
Delphi
public
 procedure Reset;
See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.RestoreValue Method

Summary

Represents method RestoreValue.

Namespace: frxAggregate
Syntax
Delphi
public
 procedure RestoreValue;
See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.SaveValue Method

Summary

Represents method SaveValue.

Namespace: frxAggregate
Syntax
Delphi
public
 procedure SaveValue;
See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.StartKeep Method

Summary

Represents method StartKeep.

Namespace: frxAggregate
Syntax
Delphi
public
 procedure StartKeep;
See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.Value Method

Summary

Represents method Value.

Namespace: frxAggregate
Syntax
Delphi
public
 function Value: Variant;

Return Value

Type: Variant

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem Fields

Fields
Name | Description
FAggregateFunction | Represents field FAggregateFunction.
FBand | Represents field FBand.
FCountInvisibleBands | Represents field FCountInvisibleBands.
FDontReset | Represents field FDontReset.
FExpression | Represents field FExpression.
FIsPageFooter | Represents field FIsPageFooter.
FItemsArray | Represents field FItemsArray.
FItemsCount | Represents field FItemsCount.
FItemsCountArray | Represents field FItemsCountArray.
FItemsValue | Represents field FItemsValue.
FKeeping | Represents field FKeeping.
FLastCount | Represents field FLastCount.
FLastValue | Represents field FLastValue.
FMemoName | Represents field FMemoName.
FOriginalName | Represents field FOriginalName.
FParentBand | Represents field FParentBand.
FReport | Represents field FReport.
FSavedCount | Represents field FSavedCount.
FSavedValue | Represents field FSavedValue.
FTempItemsCount | Represents field FTempItemsCount.
FTempItemsValue | Represents field FTempItemsValue.
FVColumn | Represents field FVColumn.
Top


TfrxAggregateItem.FAggregateFunction Field

Summary

Represents field FAggregateFunction.

Namespace: frxAggregate
Syntax
Delphi
private
 FAggregateFunction: TfrxAggregateFunction;

Field Value

Type: TfrxAggregateFunction

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FBand Field

Summary

Represents field FBand.

Namespace: frxAggregate
Syntax
Delphi
private
 FBand: TfrxDataBand;

Field Value

Type: TfrxDataBand

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FCountInvisibleBands Field

Summary

Represents field FCountInvisibleBands.

Namespace: frxAggregate
Syntax
Delphi
private
 FCountInvisibleBands: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FDontReset Field

Summary

Represents field FDontReset.

Namespace: frxAggregate
Syntax
Delphi
private
 FDontReset: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FExpression Field

Summary

Represents field FExpression.

Namespace: frxAggregate
Syntax
Delphi
private
 FExpression: String;

Field Value

Type: String

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FIsPageFooter Field

Summary

Represents field FIsPageFooter.

Namespace: frxAggregate
Syntax
Delphi
private
 FIsPageFooter: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FItemsArray Field

Summary

Represents field FItemsArray.

Namespace: frxAggregate
Syntax
Delphi
private
 FItemsArray: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FItemsCount Field

Summary

Represents field FItemsCount.

Namespace: frxAggregate
Syntax
Delphi
private
 FItemsCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FItemsCountArray Field

Summary

Represents field FItemsCountArray.

Namespace: frxAggregate
Syntax
Delphi
private
 FItemsCountArray: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FItemsValue Field

Summary

Represents field FItemsValue.

Namespace: frxAggregate
Syntax
Delphi
private
 FItemsValue: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FKeeping Field

Summary

Represents field FKeeping.

Namespace: frxAggregate
Syntax
Delphi
private
 FKeeping: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FLastCount Field

Summary

Represents field FLastCount.

Namespace: frxAggregate
Syntax
Delphi
private
 FLastCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FLastValue Field

Summary

Represents field FLastValue.

Namespace: frxAggregate
Syntax
Delphi
private
 FLastValue: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FMemoName Field

Summary

Represents field FMemoName.

Namespace: frxAggregate
Syntax
Delphi
private
 FMemoName: String;

Field Value

Type: String

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FOriginalName Field

Summary

Represents field FOriginalName.

Namespace: frxAggregate
Syntax
Delphi
private
 FOriginalName: String;

Field Value

Type: String

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FParentBand Field

Summary

Represents field FParentBand.

Namespace: frxAggregate
Syntax
Delphi
private
 FParentBand: TfrxBand;

Field Value

Type: TfrxBand

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FReport Field

Summary

Represents field FReport.

Namespace: frxAggregate
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FSavedCount Field

Summary

Represents field FSavedCount.

Namespace: frxAggregate
Syntax
Delphi
private
 FSavedCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FSavedValue Field

Summary

Represents field FSavedValue.

Namespace: frxAggregate
Syntax
Delphi
private
 FSavedValue: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FTempItemsCount Field

Summary

Represents field FTempItemsCount.

Namespace: frxAggregate
Syntax
Delphi
private
 FTempItemsCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FTempItemsValue Field

Summary

Represents field FTempItemsValue.

Namespace: frxAggregate
Syntax
Delphi
private
 FTempItemsValue: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateItem.FVColumn Field

Summary

Represents field FVColumn.

Namespace: frxAggregate
Syntax
Delphi
private
 FVColumn: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxAggregateItem
  • frxAggregate


TfrxAggregateList Class

Summary

Represents type TfrxAggregateList.

Namespace: frxAggregate
Inheritance Hierarchy
TObject
frxAggregate.TfrxAggregateList
Syntax
Delphi
type
 TfrxAggregateList = class(TObject)
 end;

The TfrxAggregateList type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport) | Initializes a new instance of the TfrxAggregateList class.
Destroy | Represents the destructor of the TfrxAggregateList class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
AddItems(TfrxReportPage) | Represents method AddItems(TfrxReportPage).
AddValue(TfrxBand,Integer) | Represents method AddValue(TfrxBand,Integer).
Clear | Represents method Clear.
ClearValues | Represents method ClearValues.
DeleteValue(TfrxBand) | Represents method DeleteValue(TfrxBand).
EndKeep | Represents method EndKeep.
FindAggregates(TfrxCustomMemoView,TfrxDataBand) | Represents method FindAggregates(TfrxCustomMemoView,TfrxDataBand).
GetItem(Integer) | Represents method GetItem(Integer).
GetValue(TfrxBand,Integer,String,String,TfrxBand,Integer) | Overloaded. Represents method GetValue(TfrxBand,Integer,String,String,TfrxBand,Integer).
GetValue(TfrxBand,String,Integer) | Overloaded. Represents method GetValue(TfrxBand,String,Integer).
ParseName(String,TfrxAggregateFunction,String,TfrxDataBand,Boolean,Boolean) | Represents method ParseName(String,TfrxAggregateFunction,String,TfrxDataBand,Boolean,Boolean).
Reset(TfrxBand) | Represents method Reset(TfrxBand).
RestoreValue(TfrxBand) | Represents method RestoreValue(TfrxBand).
SaveValue(TfrxBand) | Represents method SaveValue(TfrxBand).
StartKeep | Represents method StartKeep.
Top
Fields
Show:
Name | Description
FList | Represents field FList.
FReport | Represents field FReport.
Top
See Also

Reference

  • frxAggregate


TfrxAggregateList Constructors

Constructors
Name | Description
Create(TfrxReport) | Initializes a new instance of the TfrxAggregateList class.
Destroy | Represents the destructor of the TfrxAggregateList class.
Top


TfrxAggregateList.Create(TfrxReport) Constructor

Summary

Initializes a new instance of the TfrxAggregateList class.

Namespace: frxAggregate
Syntax
Delphi
public
 constructor Create(AReport: TfrxReport);

Parameters

AReport
Type: TfrxReport

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.Destroy Destructor

Summary

Represents the destructor of the TfrxAggregateList class.

Namespace: frxAggregate
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxAggregateList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxAggregate
Syntax
Delphi
private
 property Items[Index: Integer]: TfrxAggregateItem read GetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxAggregateItem

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList Methods

Methods
Name | Description
AddItems(TfrxReportPage) | Represents method AddItems(TfrxReportPage).
AddValue(TfrxBand,Integer) | Represents method AddValue(TfrxBand,Integer).
Clear | Represents method Clear.
ClearValues | Represents method ClearValues.
DeleteValue(TfrxBand) | Represents method DeleteValue(TfrxBand).
EndKeep | Represents method EndKeep.
FindAggregates(TfrxCustomMemoView,TfrxDataBand) | Represents method FindAggregates(TfrxCustomMemoView,TfrxDataBand).
GetItem(Integer) | Represents method GetItem(Integer).
GetValue(TfrxBand,Integer,String,String,TfrxBand,Integer) | Overloaded. Represents method GetValue(TfrxBand,Integer,String,String,TfrxBand,Integer).
GetValue(TfrxBand,String,Integer) | Overloaded. Represents method GetValue(TfrxBand,String,Integer).
ParseName(String,TfrxAggregateFunction,String,TfrxDataBand,Boolean,Boolean) | Represents method ParseName(String,TfrxAggregateFunction,String,TfrxDataBand,Boolean,Boolean).
Reset(TfrxBand) | Represents method Reset(TfrxBand).
RestoreValue(TfrxBand) | Represents method RestoreValue(TfrxBand).
SaveValue(TfrxBand) | Represents method SaveValue(TfrxBand).
StartKeep | Represents method StartKeep.
Top


TfrxAggregateList.AddItems(TfrxReportPage) Method

Summary

Represents method AddItems(TfrxReportPage).

Namespace: frxAggregate
Syntax
Delphi
public
 procedure AddItems(Page: TfrxReportPage);

Parameters

Page
Type: TfrxReportPage

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.AddValue(TfrxBand,Integer) Method

Summary

Represents method AddValue(TfrxBand,Integer).

Namespace: frxAggregate
Syntax
Delphi
public
 procedure AddValue(Band: TfrxBand; VColumn: Integer = 0);

Parameters

Band
Type: TfrxBand

VColumn
Type: Integer

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.Clear Method

Summary

Represents method Clear.

Namespace: frxAggregate
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.ClearValues Method

Summary

Represents method ClearValues.

Namespace: frxAggregate
Syntax
Delphi
public
 procedure ClearValues;
See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.DeleteValue(TfrxBand) Method

Summary

Represents method DeleteValue(TfrxBand).

Namespace: frxAggregate
Syntax
Delphi
public
 procedure DeleteValue(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.EndKeep Method

Summary

Represents method EndKeep.

Namespace: frxAggregate
Syntax
Delphi
public
 procedure EndKeep;
See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.FindAggregates(TfrxCustomMemoView,TfrxDataBand) Method

Summary

Represents method FindAggregates(TfrxCustomMemoView,TfrxDataBand).

Namespace: frxAggregate
Syntax
Delphi
private
 procedure FindAggregates(Memo: TfrxCustomMemoView; DataBand: TfrxDataBand);

Parameters

Memo
Type: TfrxCustomMemoView

DataBand
Type: TfrxDataBand

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxAggregate
Syntax
Delphi
private
 function GetItem(Index: Integer): TfrxAggregateItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxAggregateItem

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.GetValue(TfrxBand,Integer,String,String,TfrxBand,Integer) Method

Summary

Represents method GetValue(TfrxBand,Integer,String,String,TfrxBand,Integer).

Namespace: frxAggregate
Syntax
Delphi
public
 function GetValue(ParentBand: TfrxBand; VColumn: Integer;
 const Name, Expression: String; Band: TfrxBand; Flags: Integer): Variant; overload;

Parameters

ParentBand
Type: TfrxBand

VColumn
Type: Integer

Name
Type: String

Expression
Type: String

Band
Type: TfrxBand

Flags
Type: Integer

Return Value

Type: Variant

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.GetValue(TfrxBand,String,Integer) Method

Summary

Represents method GetValue(TfrxBand,String,Integer).

Namespace: frxAggregate
Syntax
Delphi
public
 function GetValue(ParentBand: TfrxBand; const ComplexName: String;
 VColumn: Integer = 0): Variant; overload;

Parameters

ParentBand
Type: TfrxBand

ComplexName
Type: String

VColumn
Type: Integer

Return Value

Type: Variant

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.ParseName(String,TfrxAggregateFunction,String,TfrxDataBand,Boolean,Boolean) Method

Summary

Represents method ParseName(String,TfrxAggregateFunction,String,TfrxDataBand,Boolean,Boolean).

Namespace: frxAggregate
Syntax
Delphi
private
 procedure ParseName(const ComplexName: String; var Func: TfrxAggregateFunction;
 var Expr: String; var Band: TfrxDataBand; var CountInvisible, DontReset: Boolean);

Parameters

ComplexName
Type: String

Func
Type: TfrxAggregateFunction

Expr
Type: String

Band
Type: TfrxDataBand

CountInvisible
Type: Boolean

DontReset
Type: Boolean

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.Reset(TfrxBand) Method

Summary

Represents method Reset(TfrxBand).

Namespace: frxAggregate
Syntax
Delphi
public
 procedure Reset(ParentBand: TfrxBand);

Parameters

ParentBand
Type: TfrxBand

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.RestoreValue(TfrxBand) Method

Summary

Represents method RestoreValue(TfrxBand).

Namespace: frxAggregate
Syntax
Delphi
public
 procedure RestoreValue(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.SaveValue(TfrxBand) Method

Summary

Represents method SaveValue(TfrxBand).

Namespace: frxAggregate
Syntax
Delphi
public
 procedure SaveValue(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.StartKeep Method

Summary

Represents method StartKeep.

Namespace: frxAggregate
Syntax
Delphi
public
 procedure StartKeep;
See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList Fields

Fields
Name | Description
FList | Represents field FList.
FReport | Represents field FReport.
Top


TfrxAggregateList.FList Field

Summary

Represents field FList.

Namespace: frxAggregate
Syntax
Delphi
private
 FList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


TfrxAggregateList.FReport Field

Summary

Represents field FReport.

Namespace: frxAggregate
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxAggregateList
  • frxAggregate


frxAggregate Enumerations

Enumerations
Name | Description
TfrxAggregateFunction | Represents type TfrxAggregateFunction.
Top


TfrxAggregateFunction Enumeration

Summary

Represents type TfrxAggregateFunction.

Namespace: frxAggregate
Syntax
Delphi
type
 TfrxAggregateFunction = (agSum, agAvg, agMin, agMax, agCount);

The TfrxAggregateFunction type exposes the following members.

Members
Show:
Name | Description
agAvg | Represents constant agAvg.
agCount | Represents constant agCount.
agMax | Represents constant agMax.
agMin | Represents constant agMin.
agSum | Represents constant agSum.
Top
See Also

Reference

  • frxAggregate


frxAnaliticGeometry Namespace

Summary

Represents namespace frxAnaliticGeometry.

Classes
Name | Description
TMinDistance | Represents type TMinDistance.
Top
Records
Name | Description
TCircle | Represents type TCircle.
TDoublePoint | Represents type TDoublePoint.
TDoubleRect | Represents type TDoubleRect.
TSegment | Represents type TSegment.
Top
Types
Name | Description
TDoubleArray | Represents an array of the Double type.
TDoublePointArray | Represents an array of the TDoublePoint type.
TDoublePointMatrix | Represents an array of the TDoublePointArray type.
TPointArray | Represents an array of the TPoint type.
Top
Constants
Name | Description
MinSelectDistance | Represents constant MinSelectDistance.
Unknown | Represents constant Unknown.
Top
Routines
Name | Description
Boundary(Extended,Extended,Extended) | Represents method Boundary(Extended,Extended,Extended).
CenterRect(TfrxRect) | Represents method CenterRect(TfrxRect).
Circle(Extended,Extended,Extended) | Represents method Circle(Extended,Extended,Extended).
ConstrainedDR(TDoubleRect,Double,Double) | Represents method ConstrainedDR(TDoubleRect,Double,Double).
Distance(TDoublePoint,TfrxPoint) | Overloaded. Represents method Distance(TDoublePoint,TfrxPoint).
Distance(TfrxPoint,Extended,Extended) | Overloaded. Represents method Distance(TfrxPoint,Extended,Extended).
Distance(TfrxPoint,TfrxPoint) | Overloaded. Represents method Distance(TfrxPoint,TfrxPoint).
Distance(TPoint,Extended,Extended) | Overloaded. Represents method Distance(TPoint,Extended,Extended).
DistanceDiamond(TDoubleRect,TfrxPoint) | Represents method DistanceDiamond(TDoubleRect,TfrxPoint).
DistanceEllipse(TDoubleRect,TfrxPoint) | Represents method DistanceEllipse(TDoubleRect,TfrxPoint).
DistanceMultiPoint(TDoublePointMatrix,TfrxPoint) | Represents method DistanceMultiPoint(TDoublePointMatrix,TfrxPoint).
DistanceMultiPolygon(TDoublePointMatrix,TfrxPoint) | Represents method DistanceMultiPolygon(TDoublePointMatrix,TfrxPoint).
DistanceMultiPolyline(TDoublePointMatrix,TfrxPoint) | Represents method DistanceMultiPolyline(TDoublePointMatrix,TfrxPoint).
DistancePicture(TDoubleRect,TfrxPoint) | Represents method DistancePicture(TDoubleRect,TfrxPoint).
DistancePolygon(TDoublePointArray,TfrxPoint) | Represents method DistancePolygon(TDoublePointArray,TfrxPoint).
DistancePolyline(TDoublePointArray,TfrxPoint) | Represents method DistancePolyline(TDoublePointArray,TfrxPoint).
DistanceRect(TDoubleRect,TfrxPoint) | Represents method DistanceRect(TDoubleRect,TfrxPoint).
DistanceSegment(TSegment,TfrxPoint) | Represents method DistanceSegment(TSegment,TfrxPoint).
DistanceTemplate(TDoublePointArray,TfrxPoint) | Represents method DistanceTemplate(TDoublePointArray,TfrxPoint).
DoublePoint(Extended,Extended) | Overloaded. Represents method DoublePoint(Extended,Extended).
DoublePoint(TfrxPoint) | Overloaded. Represents method DoublePoint(TfrxPoint).
DoublePoint(TPoint) | Overloaded. Represents method DoublePoint(TPoint).
DoubleRect(Double,Double,Double,Double) | Overloaded. Represents method DoubleRect(Double,Double,Double,Double).
DoubleRect(TfrxPoint,TfrxPoint) | Overloaded. Represents method DoubleRect(TfrxPoint,TfrxPoint).
DoubleRect(TRect) | Overloaded. Represents method DoubleRect(TRect).
DoubleRectExpand(TDoubleRect,Double) | Overloaded. Represents method DoubleRectExpand(TDoubleRect,Double).
DoubleRectExpand(TDoubleRect,Double,Double) | Overloaded. Represents method DoubleRectExpand(TDoubleRect,Double,Double).
ExpandRect(TfrxRect,Extended,Extended) | Overloaded. Represents method ExpandRect(TfrxRect,Extended,Extended).
ExpandRect(TfrxRect,TDoublePoint) | Overloaded. Represents method ExpandRect(TfrxRect,TDoublePoint).
ExpandRect(TfrxRect,TfrxRect) | Overloaded. Represents method ExpandRect(TfrxRect,TfrxRect).
frxCanonicalRect(Extended,Extended,Extended,Extended) | Overloaded. Represents method frxCanonicalRect(Extended,Extended,Extended,Extended).
frxCanonicalRect(TDoubleRect) | Overloaded. Represents method frxCanonicalRect(TDoubleRect).
InitRect(TfrxRect,TDoublePoint) | Represents method InitRect(TfrxRect,TDoublePoint).
IntersectionEllipse(TDoubleRect,TfrxPoint) | Represents method IntersectionEllipse(TDoubleRect,TfrxPoint).
IsEqual(TDoublePoint,TDoublePoint) | Represents method IsEqual(TDoublePoint,TDoublePoint).
IsInside(Extended,Extended,Extended) | Represents method IsInside(Extended,Extended,Extended).
IsInsideDiamond(TDoubleRect,TfrxPoint) | Represents method IsInsideDiamond(TDoubleRect,TfrxPoint).
IsInsideEllipse(TDoubleRect,TfrxPoint) | Represents method IsInsideEllipse(TDoubleRect,TfrxPoint).
IsInsideMultiPolygon(TDoublePointMatrix,TfrxPoint) | Represents method IsInsideMultiPolygon(TDoublePointMatrix,TfrxPoint).
IsInsideMultiPolyline(TDoublePointMatrix,TfrxPoint) | Represents method IsInsideMultiPolyline(TDoublePointMatrix,TfrxPoint).
IsInsidePolygon(TDoublePointArray,TfrxPoint) | Represents method IsInsidePolygon(TDoublePointArray,TfrxPoint).
IsInsidePolyline(TDoublePointArray,TfrxPoint) | Represents method IsInsidePolyline(TDoublePointArray,TfrxPoint).
IsInsideRect(TDoubleRect,TfrxPoint) | Represents method IsInsideRect(TDoubleRect,TfrxPoint).
IsPointInPolygon(Extended,Extended,TPointArray) | Represents method IsPointInPolygon(Extended,Extended,TPointArray).
IsPointInRect(TfrxPoint,TfrxRect) | Represents method IsPointInRect(TfrxPoint,TfrxRect).
IsSegmentsIntersect(TSegment,TSegment) | Represents method IsSegmentsIntersect(TSegment,TSegment).
RectHeight(TfrxRect) | Represents method RectHeight(TfrxRect).
RectWidth(TfrxRect) | Overloaded. Represents method RectWidth(TfrxRect).
RectWidth(TRect) | Overloaded. Represents method RectWidth(TRect).
Segment(Extended,Extended,Extended,Extended) | Overloaded. Represents method Segment(Extended,Extended,Extended,Extended).
Segment(TDoublePoint,TDoublePoint) | Overloaded. Represents method Segment(TDoublePoint,TDoublePoint).
Segment(TfrxPoint,TfrxPoint) | Overloaded. Represents method Segment(TfrxPoint,TfrxPoint).
Segment(TPoint,TPoint) | Overloaded. Represents method Segment(TPoint,TPoint).
ToFrxPoint(TPoint) | Represents method ToFrxPoint(TPoint).
ToPoint(Extended,Extended) | Overloaded. Represents method ToPoint(Extended,Extended).
ToPoint(TfrxPoint) | Overloaded. Represents method ToPoint(TfrxPoint).
ToRect(TDoubleRect) | Represents method ToRect(TDoubleRect).
Top


frxAnaliticGeometry Classes

Classes
Name | Description
TMinDistance | Represents type TMinDistance.
Top


TMinDistance Class

Summary

Represents type TMinDistance.

Namespace: frxAnaliticGeometry
Inheritance Hierarchy
TObject
frxAnaliticGeometry.TMinDistance
Syntax
Delphi
type
 TMinDistance = class
 end;

The TMinDistance type exposes the following members.

Constructors
Show:
Name | Description
Create(Extended) | Initializes a new instance of the TMinDistance class.
Top
Properties
Show:
Name | Description
Index | Represents property Index.
Top
Methods
Show:
Name | Description
Add(Extended,Integer) | Represents method Add(Extended,Integer).
Init(Extended) | Represents method Init(Extended).
IsNear | Represents method IsNear.
IsZero | Represents method IsZero.
Top
Fields
Show:
Name | Description
FIndex | Represents field FIndex.
FTreshold | Represents field FTreshold.
FValue | Represents field FValue.
Top
See Also

Reference

  • frxAnaliticGeometry


TMinDistance Constructors

Constructors
Name | Description
Create(Extended) | Initializes a new instance of the TMinDistance class.
Top


TMinDistance.Create(Extended) Constructor

Summary

Initializes a new instance of the TMinDistance class.

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 constructor Create(ATreshold: Extended = 0.0);

Parameters

ATreshold
Type: Extended

See Also

Reference

  • TMinDistance
  • frxAnaliticGeometry


TMinDistance Properties

Properties
Name | Description
Index | Represents property Index.
Top


TMinDistance.Index Property

Summary

Represents property Index.

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 property Index: Integer read FIndex;

Property Value

Type: Integer

See Also

Reference

  • TMinDistance
  • frxAnaliticGeometry


TMinDistance Methods

Methods
Name | Description
Add(Extended,Integer) | Represents method Add(Extended,Integer).
Init(Extended) | Represents method Init(Extended).
IsNear | Represents method IsNear.
IsZero | Represents method IsZero.
Top


TMinDistance.Add(Extended,Integer) Method

Summary

Represents method Add(Extended,Integer).

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 procedure Add(AValue: Extended; AIndex: Integer);

Parameters

AValue
Type: Extended

AIndex
Type: Integer

See Also

Reference

  • TMinDistance
  • frxAnaliticGeometry


TMinDistance.Init(Extended) Method

Summary

Represents method Init(Extended).

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 procedure Init(ATreshold: Extended);

Parameters

ATreshold
Type: Extended

See Also

Reference

  • TMinDistance
  • frxAnaliticGeometry


TMinDistance.IsNear Method

Summary

Represents method IsNear.

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 function IsNear: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TMinDistance
  • frxAnaliticGeometry


TMinDistance.IsZero Method

Summary

Represents method IsZero.

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 function IsZero: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TMinDistance
  • frxAnaliticGeometry


TMinDistance Fields

Fields
Name | Description
FIndex | Represents field FIndex.
FTreshold | Represents field FTreshold.
FValue | Represents field FValue.
Top


TMinDistance.FIndex Field

Summary

Represents field FIndex.

Namespace: frxAnaliticGeometry
Syntax
Delphi
protected
 FIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TMinDistance
  • frxAnaliticGeometry


TMinDistance.FTreshold Field

Summary

Represents field FTreshold.

Namespace: frxAnaliticGeometry
Syntax
Delphi
protected
 FTreshold: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMinDistance
  • frxAnaliticGeometry


TMinDistance.FValue Field

Summary

Represents field FValue.

Namespace: frxAnaliticGeometry
Syntax
Delphi
protected
 FValue: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMinDistance
  • frxAnaliticGeometry


frxAnaliticGeometry Records

Records
Name | Description
TCircle | Represents type TCircle.
TDoublePoint | Represents type TDoublePoint.
TDoubleRect | Represents type TDoubleRect.
TSegment | Represents type TSegment.
Top


TCircle Record

Summary

Represents type TCircle.

Namespace: frxAnaliticGeometry
Syntax
Delphi
type
 TCircle = record
 end;

The TCircle type exposes the following members.

Fields
Show:
Name | Description
Radius | Represents field Radius.
X | Represents field X.
Y | Represents field Y.
Top
See Also

Reference

  • frxAnaliticGeometry


TCircle Fields

Fields
Name | Description
Radius | Represents field Radius.
X | Represents field X.
Y | Represents field Y.
Top


TCircle.Radius Field

Summary

Represents field Radius.

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 X, Y, Radius: Extended;

Field Value

Type: Extended

See Also

Reference

  • TCircle
  • frxAnaliticGeometry


TCircle.X Field

Summary

Represents field X.

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 X, Y, Radius: Extended;

Field Value

Type: Extended

See Also

Reference

  • TCircle
  • frxAnaliticGeometry


TCircle.Y Field

Summary

Represents field Y.

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 X, Y, Radius: Extended;

Field Value

Type: Extended

See Also

Reference

  • TCircle
  • frxAnaliticGeometry


TDoublePoint Record

Summary

Represents type TDoublePoint.

Namespace: frxAnaliticGeometry
Syntax
Delphi
type
 TDoublePoint = record
 end;

The TDoublePoint type exposes the following members.

Fields
Show:
Name | Description
X | Represents field X.
Y | Represents field Y.
Top
See Also

Reference

  • frxAnaliticGeometry


TDoublePoint Fields

Fields
Name | Description
X | Represents field X.
Y | Represents field Y.
Top


TDoublePoint.X Field

Summary

Represents field X.

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 X, Y: Double;

Field Value

Type: Double

See Also

Reference

  • TDoublePoint
  • frxAnaliticGeometry


TDoublePoint.Y Field

Summary

Represents field Y.

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 X, Y: Double;

Field Value

Type: Double

See Also

Reference

  • TDoublePoint
  • frxAnaliticGeometry


TDoubleRect Record

Summary

Represents type TDoubleRect.

Namespace: frxAnaliticGeometry
Syntax
Delphi
type
 TDoubleRect = record
 case Integer of
 0: (Left, Top, Right, Bottom: Double);
 1: (TopLeft, BottomRight: TDoublePoint);
 end;

The TDoubleRect type exposes the following members.

Fields
Show:
Name | Description
Bottom | Represents field Bottom.
BottomRight | Represents field BottomRight.
Left | Represents field Left.
Right | Represents field Right.
Top | Represents field Top.
TopLeft | Represents field TopLeft.
Top
See Also

Reference

  • frxAnaliticGeometry


TDoubleRect Fields

Fields
Name | Description
Bottom | Represents field Bottom.
BottomRight | Represents field BottomRight.
Left | Represents field Left.
Right | Represents field Right.
Top | Represents field Top.
TopLeft | Represents field TopLeft.
Top


TDoubleRect.Bottom Field

Summary

Represents field Bottom.

Namespace: frxAnaliticGeometry
Syntax
Delphi
Left, Top, Right, Bottom: Double

Field Value

Type: Double

See Also

Reference

  • TDoubleRect
  • frxAnaliticGeometry


TDoubleRect.BottomRight Field

Summary

Represents field BottomRight.

Namespace: frxAnaliticGeometry
Syntax
Delphi
TopLeft, BottomRight: TDoublePoint

Field Value

Type: TDoublePoint

See Also

Reference

  • TDoubleRect
  • frxAnaliticGeometry


TDoubleRect.Left Field

Summary

Represents field Left.

Namespace: frxAnaliticGeometry
Syntax
Delphi
Left, Top, Right, Bottom: Double

Field Value

Type: Double

See Also

Reference

  • TDoubleRect
  • frxAnaliticGeometry


TDoubleRect.Right Field

Summary

Represents field Right.

Namespace: frxAnaliticGeometry
Syntax
Delphi
Left, Top, Right, Bottom: Double

Field Value

Type: Double

See Also

Reference

  • TDoubleRect
  • frxAnaliticGeometry


TDoubleRect.Top Field

Summary

Represents field Top.

Namespace: frxAnaliticGeometry
Syntax
Delphi
Left, Top, Right, Bottom: Double

Field Value

Type: Double

See Also

Reference

  • TDoubleRect
  • frxAnaliticGeometry


TDoubleRect.TopLeft Field

Summary

Represents field TopLeft.

Namespace: frxAnaliticGeometry
Syntax
Delphi
TopLeft, BottomRight: TDoublePoint

Field Value

Type: TDoublePoint

See Also

Reference

  • TDoubleRect
  • frxAnaliticGeometry


TSegment Record

Summary

Represents type TSegment.

Namespace: frxAnaliticGeometry
Syntax
Delphi
type
 TSegment = record
 end;

The TSegment type exposes the following members.

Fields
Show:
Name | Description
First | Represents field First.
Second | Represents field Second.
Top
See Also

Reference

  • frxAnaliticGeometry


TSegment Fields

Fields
Name | Description
First | Represents field First.
Second | Represents field Second.
Top


TSegment.First Field

Summary

Represents field First.

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 First, Second: TfrxPoint;

Field Value

Type: TfrxPoint

See Also

Reference

  • TSegment
  • frxAnaliticGeometry


TSegment.Second Field

Summary

Represents field Second.

Namespace: frxAnaliticGeometry
Syntax
Delphi
public
 First, Second: TfrxPoint;

Field Value

Type: TfrxPoint

See Also

Reference

  • TSegment
  • frxAnaliticGeometry


frxAnaliticGeometry Types

Types
Name | Description
TDoubleArray | Represents an array of the Double type.
TDoublePointArray | Represents an array of the TDoublePoint type.
TDoublePointMatrix | Represents an array of the TDoublePointArray type.
TPointArray | Represents an array of the TPoint type.
Top


TDoubleArray Type

Summary

Represents an array of the Double type.

Namespace: frxAnaliticGeometry
Syntax
Delphi
type
 TDoubleArray = array of Double;
See Also

Reference

  • frxAnaliticGeometry


TDoublePointArray Type

Summary

Represents an array of the TDoublePoint type.

Namespace: frxAnaliticGeometry
Syntax
Delphi
type
 TDoublePointArray = array of TDoublePoint;
See Also

Reference

  • frxAnaliticGeometry


TDoublePointMatrix Type

Summary

Represents an array of the TDoublePointArray type.

Namespace: frxAnaliticGeometry
Syntax
Delphi
type
 TDoublePointMatrix = array of TDoublePointArray;
See Also

Reference

  • frxAnaliticGeometry


TPointArray Type

Summary

Represents an array of the TPoint type.

Namespace: frxAnaliticGeometry
Syntax
Delphi
type
 TPointArray = array of TPoint;
See Also

Reference

  • frxAnaliticGeometry


frxAnaliticGeometry Constants

Constants
Name | Description
MinSelectDistance | Represents constant MinSelectDistance.
Unknown | Represents constant Unknown.
Top


MinSelectDistance Constant

Summary

Represents constant MinSelectDistance.

Namespace: frxAnaliticGeometry
Syntax
Delphi
 MinSelectDistance = 8;

Value

Type: ShortInt

See Also

Reference

  • frxAnaliticGeometry


Unknown Constant

Summary

Represents constant Unknown.

Namespace: frxAnaliticGeometry
Syntax
Delphi
 Unknown = -1;

Value

Type: ShortInt

See Also

Reference

  • frxAnaliticGeometry


frxAnaliticGeometry Routines

Routines
Name | Description
Boundary(Extended,Extended,Extended) | Represents method Boundary(Extended,Extended,Extended).
CenterRect(TfrxRect) | Represents method CenterRect(TfrxRect).
Circle(Extended,Extended,Extended) | Represents method Circle(Extended,Extended,Extended).
ConstrainedDR(TDoubleRect,Double,Double) | Represents method ConstrainedDR(TDoubleRect,Double,Double).
Distance(TDoublePoint,TfrxPoint) | Overloaded. Represents method Distance(TDoublePoint,TfrxPoint).
Distance(TfrxPoint,Extended,Extended) | Overloaded. Represents method Distance(TfrxPoint,Extended,Extended).
Distance(TfrxPoint,TfrxPoint) | Overloaded. Represents method Distance(TfrxPoint,TfrxPoint).
Distance(TPoint,Extended,Extended) | Overloaded. Represents method Distance(TPoint,Extended,Extended).
DistanceDiamond(TDoubleRect,TfrxPoint) | Represents method DistanceDiamond(TDoubleRect,TfrxPoint).
DistanceEllipse(TDoubleRect,TfrxPoint) | Represents method DistanceEllipse(TDoubleRect,TfrxPoint).
DistanceMultiPoint(TDoublePointMatrix,TfrxPoint) | Represents method DistanceMultiPoint(TDoublePointMatrix,TfrxPoint).
DistanceMultiPolygon(TDoublePointMatrix,TfrxPoint) | Represents method DistanceMultiPolygon(TDoublePointMatrix,TfrxPoint).
DistanceMultiPolyline(TDoublePointMatrix,TfrxPoint) | Represents method DistanceMultiPolyline(TDoublePointMatrix,TfrxPoint).
DistancePicture(TDoubleRect,TfrxPoint) | Represents method DistancePicture(TDoubleRect,TfrxPoint).
DistancePolygon(TDoublePointArray,TfrxPoint) | Represents method DistancePolygon(TDoublePointArray,TfrxPoint).
DistancePolyline(TDoublePointArray,TfrxPoint) | Represents method DistancePolyline(TDoublePointArray,TfrxPoint).
DistanceRect(TDoubleRect,TfrxPoint) | Represents method DistanceRect(TDoubleRect,TfrxPoint).
DistanceSegment(TSegment,TfrxPoint) | Represents method DistanceSegment(TSegment,TfrxPoint).
DistanceTemplate(TDoublePointArray,TfrxPoint) | Represents method DistanceTemplate(TDoublePointArray,TfrxPoint).
DoublePoint(Extended,Extended) | Overloaded. Represents method DoublePoint(Extended,Extended).
DoublePoint(TfrxPoint) | Overloaded. Represents method DoublePoint(TfrxPoint).
DoublePoint(TPoint) | Overloaded. Represents method DoublePoint(TPoint).
DoubleRect(Double,Double,Double,Double) | Overloaded. Represents method DoubleRect(Double,Double,Double,Double).
DoubleRect(TfrxPoint,TfrxPoint) | Overloaded. Represents method DoubleRect(TfrxPoint,TfrxPoint).
DoubleRect(TRect) | Overloaded. Represents method DoubleRect(TRect).
DoubleRectExpand(TDoubleRect,Double) | Overloaded. Represents method DoubleRectExpand(TDoubleRect,Double).
DoubleRectExpand(TDoubleRect,Double,Double) | Overloaded. Represents method DoubleRectExpand(TDoubleRect,Double,Double).
ExpandRect(TfrxRect,Extended,Extended) | Overloaded. Represents method ExpandRect(TfrxRect,Extended,Extended).
ExpandRect(TfrxRect,TDoublePoint) | Overloaded. Represents method ExpandRect(TfrxRect,TDoublePoint).
ExpandRect(TfrxRect,TfrxRect) | Overloaded. Represents method ExpandRect(TfrxRect,TfrxRect).
frxCanonicalRect(Extended,Extended,Extended,Extended) | Overloaded. Represents method frxCanonicalRect(Extended,Extended,Extended,Extended).
frxCanonicalRect(TDoubleRect) | Overloaded. Represents method frxCanonicalRect(TDoubleRect).
InitRect(TfrxRect,TDoublePoint) | Represents method InitRect(TfrxRect,TDoublePoint).
IntersectionEllipse(TDoubleRect,TfrxPoint) | Represents method IntersectionEllipse(TDoubleRect,TfrxPoint).
IsEqual(TDoublePoint,TDoublePoint) | Represents method IsEqual(TDoublePoint,TDoublePoint).
IsInside(Extended,Extended,Extended) | Represents method IsInside(Extended,Extended,Extended).
IsInsideDiamond(TDoubleRect,TfrxPoint) | Represents method IsInsideDiamond(TDoubleRect,TfrxPoint).
IsInsideEllipse(TDoubleRect,TfrxPoint) | Represents method IsInsideEllipse(TDoubleRect,TfrxPoint).
IsInsideMultiPolygon(TDoublePointMatrix,TfrxPoint) | Represents method IsInsideMultiPolygon(TDoublePointMatrix,TfrxPoint).
IsInsideMultiPolyline(TDoublePointMatrix,TfrxPoint) | Represents method IsInsideMultiPolyline(TDoublePointMatrix,TfrxPoint).
IsInsidePolygon(TDoublePointArray,TfrxPoint) | Represents method IsInsidePolygon(TDoublePointArray,TfrxPoint).
IsInsidePolyline(TDoublePointArray,TfrxPoint) | Represents method IsInsidePolyline(TDoublePointArray,TfrxPoint).
IsInsideRect(TDoubleRect,TfrxPoint) | Represents method IsInsideRect(TDoubleRect,TfrxPoint).
IsPointInPolygon(Extended,Extended,TPointArray) | Represents method IsPointInPolygon(Extended,Extended,TPointArray).
IsPointInRect(TfrxPoint,TfrxRect) | Represents method IsPointInRect(TfrxPoint,TfrxRect).
IsSegmentsIntersect(TSegment,TSegment) | Represents method IsSegmentsIntersect(TSegment,TSegment).
RectHeight(TfrxRect) | Represents method RectHeight(TfrxRect).
RectWidth(TfrxRect) | Overloaded. Represents method RectWidth(TfrxRect).
RectWidth(TRect) | Overloaded. Represents method RectWidth(TRect).
Segment(Extended,Extended,Extended,Extended) | Overloaded. Represents method Segment(Extended,Extended,Extended,Extended).
Segment(TDoublePoint,TDoublePoint) | Overloaded. Represents method Segment(TDoublePoint,TDoublePoint).
Segment(TfrxPoint,TfrxPoint) | Overloaded. Represents method Segment(TfrxPoint,TfrxPoint).
Segment(TPoint,TPoint) | Overloaded. Represents method Segment(TPoint,TPoint).
ToFrxPoint(TPoint) | Represents method ToFrxPoint(TPoint).
ToPoint(Extended,Extended) | Overloaded. Represents method ToPoint(Extended,Extended).
ToPoint(TfrxPoint) | Overloaded. Represents method ToPoint(TfrxPoint).
ToRect(TDoubleRect) | Represents method ToRect(TDoubleRect).
Top


Boundary(Extended,Extended,Extended) Method

Summary

Represents method Boundary(Extended,Extended,Extended).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function Boundary(Value, MinValue, MaxValue: Extended): Extended;

Parameters

Value
Type: Extended

MinValue
Type: Extended

MaxValue
Type: Extended

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


CenterRect(TfrxRect) Method

Summary

Represents method CenterRect(TfrxRect).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function CenterRect(R: TfrxRect): TfrxPoint;

Parameters

R
Type: TfrxRect

Return Value

Type: TfrxPoint

See Also

Reference

  • frxAnaliticGeometry


Circle(Extended,Extended,Extended) Method

Summary

Represents method Circle(Extended,Extended,Extended).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function Circle(X, Y, Radius: Extended): TCircle;

Parameters

X
Type: Extended

Y
Type: Extended

Radius
Type: Extended

Return Value

Type: TCircle

See Also

Reference

  • frxAnaliticGeometry


ConstrainedDR(TDoubleRect,Double,Double) Method

Summary

Represents method ConstrainedDR(TDoubleRect,Double,Double).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function ConstrainedDR(DR: TDoubleRect; ConstrainWidth, ConstrainHeight: Double): TDoubleRect;

Parameters

DR
Type: TDoubleRect

ConstrainWidth
Type: Double

ConstrainHeight
Type: Double

Return Value

Type: TDoubleRect

See Also

Reference

  • frxAnaliticGeometry


Distance(TDoublePoint,TfrxPoint) Method

Summary

Represents method Distance(TDoublePoint,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function Distance(P1: TDoublePoint; P2: TfrxPoint): Extended; overload;

Parameters

P1
Type: TDoublePoint

P2
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


Distance(TfrxPoint,Extended,Extended) Method

Summary

Represents method Distance(TfrxPoint,Extended,Extended).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function Distance(P: TfrxPoint; X, Y: Extended): Extended; overload;

Parameters

P
Type: TfrxPoint

X
Type: Extended

Y
Type: Extended

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


Distance(TfrxPoint,TfrxPoint) Method

Summary

Represents method Distance(TfrxPoint,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function Distance(P1, P2: TfrxPoint): Extended; overload;

Parameters

P1
Type: TfrxPoint

P2
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


Distance(TPoint,Extended,Extended) Method

Summary

Represents method Distance(TPoint,Extended,Extended).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function Distance(P: TPoint; X, Y: Extended): Extended; overload;

Parameters

P
Type: TPoint

X
Type: Extended

Y
Type: Extended

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


DistanceDiamond(TDoubleRect,TfrxPoint) Method

Summary

Represents method DistanceDiamond(TDoubleRect,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DistanceDiamond(Rect: TDoubleRect; P: TfrxPoint): Extended;

Parameters

Rect
Type: TDoubleRect

P
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


DistanceEllipse(TDoubleRect,TfrxPoint) Method

Summary

Represents method DistanceEllipse(TDoubleRect,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DistanceEllipse(Rect: TDoubleRect; P: TfrxPoint): Extended;

Parameters

Rect
Type: TDoubleRect

P
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


DistanceMultiPoint(TDoublePointMatrix,TfrxPoint) Method

Summary

Represents method DistanceMultiPoint(TDoublePointMatrix,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DistanceMultiPoint(Matrix: TDoublePointMatrix; P: TfrxPoint): Extended;

Parameters

Matrix
Type: TDoublePointMatrix

P
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


DistanceMultiPolygon(TDoublePointMatrix,TfrxPoint) Method

Summary

Represents method DistanceMultiPolygon(TDoublePointMatrix,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DistanceMultiPolygon(Matrix: TDoublePointMatrix; P: TfrxPoint): Extended;

Parameters

Matrix
Type: TDoublePointMatrix

P
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


DistanceMultiPolyline(TDoublePointMatrix,TfrxPoint) Method

Summary

Represents method DistanceMultiPolyline(TDoublePointMatrix,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DistanceMultiPolyline(Matrix: TDoublePointMatrix; P: TfrxPoint): Extended;

Parameters

Matrix
Type: TDoublePointMatrix

P
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


DistancePicture(TDoubleRect,TfrxPoint) Method

Summary

Represents method DistancePicture(TDoubleRect,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DistancePicture(Rect: TDoubleRect; P: TfrxPoint): Extended;

Parameters

Rect
Type: TDoubleRect

P
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


DistancePolygon(TDoublePointArray,TfrxPoint) Method

Summary

Represents method DistancePolygon(TDoublePointArray,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DistancePolygon(Poly: TDoublePointArray; P: TfrxPoint): Extended;

Parameters

Poly
Type: TDoublePointArray

P
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


DistancePolyline(TDoublePointArray,TfrxPoint) Method

Summary

Represents method DistancePolyline(TDoublePointArray,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DistancePolyline(Poly: TDoublePointArray; P: TfrxPoint): Extended;

Parameters

Poly
Type: TDoublePointArray

P
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


DistanceRect(TDoubleRect,TfrxPoint) Method

Summary

Represents method DistanceRect(TDoubleRect,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DistanceRect(Rect: TDoubleRect; P: TfrxPoint): Extended;

Parameters

Rect
Type: TDoubleRect

P
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


DistanceSegment(TSegment,TfrxPoint) Method

Summary

Represents method DistanceSegment(TSegment,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DistanceSegment(Segment: TSegment; P: TfrxPoint): Extended;

Parameters

Segment
Type: TSegment

P
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


DistanceTemplate(TDoublePointArray,TfrxPoint) Method

Summary

Represents method DistanceTemplate(TDoublePointArray,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DistanceTemplate(Poly: TDoublePointArray; P: TfrxPoint): Extended;

Parameters

Poly
Type: TDoublePointArray

P
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


DoublePoint(Extended,Extended) Method

Summary

Represents method DoublePoint(Extended,Extended).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DoublePoint(X, Y: Extended): TDoublePoint; overload;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: TDoublePoint

See Also

Reference

  • frxAnaliticGeometry


DoublePoint(TfrxPoint) Method

Summary

Represents method DoublePoint(TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DoublePoint(P: TfrxPoint): TDoublePoint; overload;

Parameters

P
Type: TfrxPoint

Return Value

Type: TDoublePoint

See Also

Reference

  • frxAnaliticGeometry


DoublePoint(TPoint) Method

Summary

Represents method DoublePoint(TPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DoublePoint(P: TPoint): TDoublePoint; overload;

Parameters

P
Type: TPoint

Return Value

Type: TDoublePoint

See Also

Reference

  • frxAnaliticGeometry


DoubleRect(Double,Double,Double,Double) Method

Summary

Represents method DoubleRect(Double,Double,Double,Double).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DoubleRect(Left, Top, Right, Bottom: Double): TDoubleRect; overload;

Parameters

Left
Type: Double

Top
Type: Double

Right
Type: Double

Bottom
Type: Double

Return Value

Type: TDoubleRect

See Also

Reference

  • frxAnaliticGeometry


DoubleRect(TfrxPoint,TfrxPoint) Method

Summary

Represents method DoubleRect(TfrxPoint,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DoubleRect(TL, BR: TfrxPoint): TDoubleRect; overload;

Parameters

TL
Type: TfrxPoint

BR
Type: TfrxPoint

Return Value

Type: TDoubleRect

See Also

Reference

  • frxAnaliticGeometry


DoubleRect(TRect) Method

Summary

Represents method DoubleRect(TRect).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DoubleRect(R: TRect): TDoubleRect; overload;

Parameters

R
Type: TRect

Return Value

Type: TDoubleRect

See Also

Reference

  • frxAnaliticGeometry


DoubleRectExpand(TDoubleRect,Double) Method

Summary

Represents method DoubleRectExpand(TDoubleRect,Double).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DoubleRectExpand(DR: TDoubleRect; d: Double): TDoubleRect; overload;

Parameters

DR
Type: TDoubleRect

d
Type: Double

Return Value

Type: TDoubleRect

See Also

Reference

  • frxAnaliticGeometry


DoubleRectExpand(TDoubleRect,Double,Double) Method

Summary

Represents method DoubleRectExpand(TDoubleRect,Double,Double).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function DoubleRectExpand(DR: TDoubleRect; dX, dY: Double): TDoubleRect; overload;

Parameters

DR
Type: TDoubleRect

dX
Type: Double

dY
Type: Double

Return Value

Type: TDoubleRect

See Also

Reference

  • frxAnaliticGeometry


ExpandRect(TfrxRect,Extended,Extended) Method

Summary

Represents method ExpandRect(TfrxRect,Extended,Extended).

Namespace: frxAnaliticGeometry
Syntax
Delphi
procedure ExpandRect(var R: TfrxRect; X, Y: Extended); overload;

Parameters

R
Type: TfrxRect

X
Type: Extended

Y
Type: Extended

See Also

Reference

  • frxAnaliticGeometry


ExpandRect(TfrxRect,TDoublePoint) Method

Summary

Represents method ExpandRect(TfrxRect,TDoublePoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
procedure ExpandRect(var R: TfrxRect; DP: TDoublePoint); overload;

Parameters

R
Type: TfrxRect

DP
Type: TDoublePoint

See Also

Reference

  • frxAnaliticGeometry


ExpandRect(TfrxRect,TfrxRect) Method

Summary

Represents method ExpandRect(TfrxRect,TfrxRect).

Namespace: frxAnaliticGeometry
Syntax
Delphi
procedure ExpandRect(var R: TfrxRect; R1: TfrxRect); overload;

Parameters

R
Type: TfrxRect

R1
Type: TfrxRect

See Also

Reference

  • frxAnaliticGeometry


frxCanonicalRect(Extended,Extended,Extended,Extended) Method

Summary

Represents method frxCanonicalRect(Extended,Extended,Extended,Extended).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function frxCanonicalRect(ALeft, ATop, ARight, ABottom: Extended): TfrxRect; overload;

Parameters

ALeft
Type: Extended

ATop
Type: Extended

ARight
Type: Extended

ABottom
Type: Extended

Return Value

Type: TfrxRect

See Also

Reference

  • frxAnaliticGeometry


frxCanonicalRect(TDoubleRect) Method

Summary

Represents method frxCanonicalRect(TDoubleRect).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function frxCanonicalRect(DR: TDoubleRect): TfrxRect; overload;

Parameters

DR
Type: TDoubleRect

Return Value

Type: TfrxRect

See Also

Reference

  • frxAnaliticGeometry


InitRect(TfrxRect,TDoublePoint) Method

Summary

Represents method InitRect(TfrxRect,TDoublePoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
procedure InitRect(var R: TfrxRect; DP: TDoublePoint);

Parameters

R
Type: TfrxRect

DP
Type: TDoublePoint

See Also

Reference

  • frxAnaliticGeometry


IntersectionEllipse(TDoubleRect,TfrxPoint) Method

Summary

Represents method IntersectionEllipse(TDoubleRect,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IntersectionEllipse(Rect: TDoubleRect; P: TfrxPoint): TfrxPoint;

Parameters

Rect
Type: TDoubleRect

P
Type: TfrxPoint

Return Value

Type: TfrxPoint

See Also

Reference

  • frxAnaliticGeometry


IsEqual(TDoublePoint,TDoublePoint) Method

Summary

Represents method IsEqual(TDoublePoint,TDoublePoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IsEqual(P1, P2: TDoublePoint): Boolean;

Parameters

P1
Type: TDoublePoint

P2
Type: TDoublePoint

Return Value

Type: Boolean

See Also

Reference

  • frxAnaliticGeometry


IsInside(Extended,Extended,Extended) Method

Summary

Represents method IsInside(Extended,Extended,Extended).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IsInside(Value, Start, Finish: Extended): Boolean;

Parameters

Value
Type: Extended

Start
Type: Extended

Finish
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • frxAnaliticGeometry


IsInsideDiamond(TDoubleRect,TfrxPoint) Method

Summary

Represents method IsInsideDiamond(TDoubleRect,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IsInsideDiamond(R: TDoubleRect; P: TfrxPoint): Boolean;

Parameters

R
Type: TDoubleRect

P
Type: TfrxPoint

Return Value

Type: Boolean

See Also

Reference

  • frxAnaliticGeometry


IsInsideEllipse(TDoubleRect,TfrxPoint) Method

Summary

Represents method IsInsideEllipse(TDoubleRect,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IsInsideEllipse(R: TDoubleRect; P: TfrxPoint): Boolean;

Parameters

R
Type: TDoubleRect

P
Type: TfrxPoint

Return Value

Type: Boolean

See Also

Reference

  • frxAnaliticGeometry


IsInsideMultiPolygon(TDoublePointMatrix,TfrxPoint) Method

Summary

Represents method IsInsideMultiPolygon(TDoublePointMatrix,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IsInsideMultiPolygon(Matrix: TDoublePointMatrix; P: TfrxPoint): Boolean;

Parameters

Matrix
Type: TDoublePointMatrix

P
Type: TfrxPoint

Return Value

Type: Boolean

See Also

Reference

  • frxAnaliticGeometry


IsInsideMultiPolyline(TDoublePointMatrix,TfrxPoint) Method

Summary

Represents method IsInsideMultiPolyline(TDoublePointMatrix,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IsInsideMultiPolyline(Matrix: TDoublePointMatrix; P: TfrxPoint): Boolean;

Parameters

Matrix
Type: TDoublePointMatrix

P
Type: TfrxPoint

Return Value

Type: Boolean

See Also

Reference

  • frxAnaliticGeometry


IsInsidePolygon(TDoublePointArray,TfrxPoint) Method

Summary

Represents method IsInsidePolygon(TDoublePointArray,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IsInsidePolygon(Poly: TDoublePointArray; P: TfrxPoint): Boolean;

Parameters

Poly
Type: TDoublePointArray

P
Type: TfrxPoint

Return Value

Type: Boolean

See Also

Reference

  • frxAnaliticGeometry


IsInsidePolyline(TDoublePointArray,TfrxPoint) Method

Summary

Represents method IsInsidePolyline(TDoublePointArray,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IsInsidePolyline(Poly: TDoublePointArray; P: TfrxPoint): Boolean;

Parameters

Poly
Type: TDoublePointArray

P
Type: TfrxPoint

Return Value

Type: Boolean

See Also

Reference

  • frxAnaliticGeometry


IsInsideRect(TDoubleRect,TfrxPoint) Method

Summary

Represents method IsInsideRect(TDoubleRect,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IsInsideRect(R: TDoubleRect; P: TfrxPoint): Boolean;

Parameters

R
Type: TDoubleRect

P
Type: TfrxPoint

Return Value

Type: Boolean

See Also

Reference

  • frxAnaliticGeometry


IsPointInPolygon(Extended,Extended,TPointArray) Method

Summary

Represents method IsPointInPolygon(Extended,Extended,TPointArray).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IsPointInPolygon(x, y: Extended; PolyPoints: TPointArray): Boolean;

Parameters

x
Type: Extended

y
Type: Extended

PolyPoints
Type: TPointArray

Return Value

Type: Boolean

See Also

Reference

  • frxAnaliticGeometry


IsPointInRect(TfrxPoint,TfrxRect) Method

Summary

Represents method IsPointInRect(TfrxPoint,TfrxRect).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IsPointInRect(P: TfrxPoint; R: TfrxRect): Boolean;

Parameters

P
Type: TfrxPoint

R
Type: TfrxRect

Return Value

Type: Boolean

See Also

Reference

  • frxAnaliticGeometry


IsSegmentsIntersect(TSegment,TSegment) Method

Summary

Represents method IsSegmentsIntersect(TSegment,TSegment).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function IsSegmentsIntersect(S1, S2: TSegment): Boolean;

Parameters

S1
Type: TSegment

S2
Type: TSegment

Return Value

Type: Boolean

See Also

Reference

  • frxAnaliticGeometry


RectHeight(TfrxRect) Method

Summary

Represents method RectHeight(TfrxRect).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function RectHeight(R: TfrxRect): Extended;

Parameters

R
Type: TfrxRect

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


RectWidth(TfrxRect) Method

Summary

Represents method RectWidth(TfrxRect).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function RectWidth(R: TfrxRect): Extended; overload;

Parameters

R
Type: TfrxRect

Return Value

Type: Extended

See Also

Reference

  • frxAnaliticGeometry


RectWidth(TRect) Method

Summary

Represents method RectWidth(TRect).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function RectWidth(R: TRect): Integer; overload;

Parameters

R
Type: TRect

Return Value

Type: Integer

See Also

Reference

  • frxAnaliticGeometry


Segment(Extended,Extended,Extended,Extended) Method

Summary

Represents method Segment(Extended,Extended,Extended,Extended).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function Segment(x1, y1, x2, y2: Extended): TSegment; overload;

Parameters

x1
Type: Extended

y1
Type: Extended

x2
Type: Extended

y2
Type: Extended

Return Value

Type: TSegment

See Also

Reference

  • frxAnaliticGeometry


Segment(TDoublePoint,TDoublePoint) Method

Summary

Represents method Segment(TDoublePoint,TDoublePoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function Segment(P1, P2: TDoublePoint): TSegment; overload;

Parameters

P1
Type: TDoublePoint

P2
Type: TDoublePoint

Return Value

Type: TSegment

See Also

Reference

  • frxAnaliticGeometry


Segment(TfrxPoint,TfrxPoint) Method

Summary

Represents method Segment(TfrxPoint,TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function Segment(P1, P2: TfrxPoint): TSegment; overload;

Parameters

P1
Type: TfrxPoint

P2
Type: TfrxPoint

Return Value

Type: TSegment

See Also

Reference

  • frxAnaliticGeometry


Segment(TPoint,TPoint) Method

Summary

Represents method Segment(TPoint,TPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function Segment(P1, P2: TPoint): TSegment; overload;

Parameters

P1
Type: TPoint

P2
Type: TPoint

Return Value

Type: TSegment

See Also

Reference

  • frxAnaliticGeometry


ToFrxPoint(TPoint) Method

Summary

Represents method ToFrxPoint(TPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function ToFrxPoint(Point: TPoint): TfrxPoint;

Parameters

Point
Type: TPoint

Return Value

Type: TfrxPoint

See Also

Reference

  • frxAnaliticGeometry


ToPoint(Extended,Extended) Method

Summary

Represents method ToPoint(Extended,Extended).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function ToPoint(X, Y: Extended): TPoint; overload;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: TPoint

See Also

Reference

  • frxAnaliticGeometry


ToPoint(TfrxPoint) Method

Summary

Represents method ToPoint(TfrxPoint).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function ToPoint(frxPoint: TfrxPoint): TPoint; overload;

Parameters

frxPoint
Type: TfrxPoint

Return Value

Type: TPoint

See Also

Reference

  • frxAnaliticGeometry


ToRect(TDoubleRect) Method

Summary

Represents method ToRect(TDoubleRect).

Namespace: frxAnaliticGeometry
Syntax
Delphi
function ToRect(DR: TDoubleRect): TRect;

Parameters

DR
Type: TDoubleRect

Return Value

Type: TRect

See Also

Reference

  • frxAnaliticGeometry


frxBarcod Namespace

Summary

Represents namespace frxBarcod.

Classes
Name | Description
TfrxBarcode | Represents type TfrxBarcode.
Top
Records
Name | Description
TBCdata | Represents type TBCdata.
Top
Enumerations
Name | Description
TfrxBarcodeType | Type of the barcode.
TfrxBarLineType | Represents type TfrxBarLineType.
TfrxCheckSumMethod | Represents type TfrxCheckSumMethod.
Top
Constants
Name | Description
BCdata | Represents constant BCdata.
Top


frxBarcod Classes

Classes
Name | Description
TfrxBarcode | Represents type TfrxBarcode.
Top


TfrxBarcode Class

Summary

Represents type TfrxBarcode.

Namespace: frxBarcod
Inheritance Hierarchy
TComponent
frxBarcod.TfrxBarcode
Syntax
Delphi
type
 TfrxBarcode = class(TComponent)
 end;

The TfrxBarcode type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBarcode class.
Destroy | Represents the destructor of the TfrxBarcode class.
Top
Properties
Show:
Name | Description
Angle | Represents property Angle.
Checksum | Represents property Checksum.
CheckSumMethod | Represents property CheckSumMethod.
Color | Represents property Color.
ColorBar | Represents property ColorBar.
Font | Represents property Font.
Height | Represents property Height.
Modul | Represents property Modul.
Ratio | Represents property Ratio.
Text | Represents property Text.
Typ | Represents property Typ.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Code_128 | Represents method Code_128.
Code_2_5_industrial | Represents method Code_2_5_industrial.
Code_2_5_interleaved | Represents method Code_2_5_interleaved.
Code_2_5_matrix | Represents method Code_2_5_matrix.
Code_39 | Represents method Code_39.
Code_39Extended | Represents method Code_39Extended.
Code_93 | Represents method Code_93.
Code_93Extended | Represents method Code_93Extended.
Code_Codabar | Represents method Code_Codabar.
Code_EAN13 | Represents method Code_EAN13.
Code_EAN8 | Represents method Code_EAN8.
Code_MSI | Represents method Code_MSI.
Code_Pharmacode | Represents method Code_Pharmacode.
Code_PostNet | Represents method Code_PostNet.
Code_Supp2 | Represents method Code_Supp2.
Code_Supp5 | Represents method Code_Supp5.
Code_UPC_A | Represents method Code_UPC_A.
Code_UPC_E0 | Represents method Code_UPC_E0.
Code_UPC_E1 | Represents method Code_UPC_E1.
Code_USPSIntelligentMail | Represents method Code_USPSIntelligentMail.
DoCheckSumming(AnsiString) | Represents method DoCheckSumming(AnsiString).
DoLines(AnsiString,TCanvas,Integer) | Represents method DoLines(AnsiString,TCanvas,Integer).
DrawBarcode(TCanvas,TRect,Boolean,Extended,Extended,Boolean) | Represents method DrawBarcode(TCanvas,TRect,Boolean,Extended,Extended,Boolean).
GetWidth | Represents method GetWidth.
MakeData | Represents method MakeData.
MakeModules | Represents method MakeModules.
OneBarProps(AnsiChar,Integer,TfrxBarLineType) | Represents method OneBarProps(AnsiChar,Integer,TfrxBarLineType).
SetLen(Byte) | Represents method SetLen(Byte).
SetTyp(TfrxBarcodeType) | Represents method SetTyp(TfrxBarcodeType).
Top
Fields
Show:
Name | Description
FAngle | Represents field FAngle.
FCheckSum | Represents field FCheckSum.
FCheckSumMethod | Represents field FCheckSumMethod.
FColor | Represents field FColor.
FColorBar | Represents field FColorBar.
FFont | Represents field FFont.
FHeight | Represents field FHeight.
FLeft | Represents field FLeft.
FModul | Represents field FModul.
FRatio | Represents field FRatio.
FText | Represents field FText.
FTop | Represents field FTop.
FTyp | Represents field FTyp.
modules | Represents field modules.
Top
See Also

Reference

  • frxBarcod


TfrxBarcode Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBarcode class.
Destroy | Represents the destructor of the TfrxBarcode class.
Top


TfrxBarcode.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxBarcode class.

Namespace: frxBarcod
Syntax
Delphi
public
 constructor Create(Owner:TComponent); override;

Parameters

Owner
Type: TComponent

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Destroy Destructor

Summary

Represents the destructor of the TfrxBarcode class.

Namespace: frxBarcod
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode Properties

Properties
Name | Description
Angle | Represents property Angle.
Checksum | Represents property Checksum.
CheckSumMethod | Represents property CheckSumMethod.
Color | Represents property Color.
ColorBar | Represents property ColorBar.
Font | Represents property Font.
Height | Represents property Height.
Modul | Represents property Modul.
Ratio | Represents property Ratio.
Text | Represents property Text.
Typ | Represents property Typ.
Width | Represents property Width.
Top


TfrxBarcode.Angle Property

Summary

Represents property Angle.

Namespace: frxBarcod
Syntax
Delphi
published
 property Angle :double read FAngle write FAngle;

Property Value

Type: double

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Checksum Property

Summary

Represents property Checksum.

Namespace: frxBarcod
Syntax
Delphi
published
 property Checksum:boolean read FCheckSum write FCheckSum;

Property Value

Type: boolean

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.CheckSumMethod Property

Summary

Represents property CheckSumMethod.

Namespace: frxBarcod
Syntax
Delphi
published
 property CheckSumMethod:TfrxCheckSumMethod read FCheckSumMethod write FCheckSumMethod;

Property Value

Type: TfrxCheckSumMethod

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Color Property

Summary

Represents property Color.

Namespace: frxBarcod
Syntax
Delphi
published
 property Color:TColor read FColor write FColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.ColorBar Property

Summary

Represents property ColorBar.

Namespace: frxBarcod
Syntax
Delphi
published
 property ColorBar:TColor read FColorBar write FColorBar;

Property Value

Type: TColor

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Font Property

Summary

Represents property Font.

Namespace: frxBarcod
Syntax
Delphi
published
 property Font: TFont read FFont write FFont;

Property Value

Type: TFont

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Height Property

Summary

Represents property Height.

Namespace: frxBarcod
Syntax
Delphi
published
 property Height: Integer read FHeight write FHeight;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Modul Property

Summary

Represents property Modul.

Namespace: frxBarcod
Syntax
Delphi
published
 property Modul : integer read FModul write FModul;

Property Value

Type: integer

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Ratio Property

Summary

Represents property Ratio.

Namespace: frxBarcod
Syntax
Delphi
published
 property Ratio : Double read FRatio write FRatio;

Property Value

Type: Double

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Text Property

Summary

Represents property Text.

Namespace: frxBarcod
Syntax
Delphi
published
 property Text : AnsiString read FText write FText;

Property Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Typ Property

Summary

Represents property Typ.

Namespace: frxBarcod
Syntax
Delphi
published
 property Typ : TfrxBarcodeType read FTyp write SetTyp;

Property Value

Type: TfrxBarcodeType

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Width Property

Summary

Represents property Width.

Namespace: frxBarcod
Syntax
Delphi
published
 property Width : integer read GetWidth;

Property Value

Type: integer

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Code_128 | Represents method Code_128.
Code_2_5_industrial | Represents method Code_2_5_industrial.
Code_2_5_interleaved | Represents method Code_2_5_interleaved.
Code_2_5_matrix | Represents method Code_2_5_matrix.
Code_39 | Represents method Code_39.
Code_39Extended | Represents method Code_39Extended.
Code_93 | Represents method Code_93.
Code_93Extended | Represents method Code_93Extended.
Code_Codabar | Represents method Code_Codabar.
Code_EAN13 | Represents method Code_EAN13.
Code_EAN8 | Represents method Code_EAN8.
Code_MSI | Represents method Code_MSI.
Code_Pharmacode | Represents method Code_Pharmacode.
Code_PostNet | Represents method Code_PostNet.
Code_Supp2 | Represents method Code_Supp2.
Code_Supp5 | Represents method Code_Supp5.
Code_UPC_A | Represents method Code_UPC_A.
Code_UPC_E0 | Represents method Code_UPC_E0.
Code_UPC_E1 | Represents method Code_UPC_E1.
Code_USPSIntelligentMail | Represents method Code_USPSIntelligentMail.
DoCheckSumming(AnsiString) | Represents method DoCheckSumming(AnsiString).
DoLines(AnsiString,TCanvas,Integer) | Represents method DoLines(AnsiString,TCanvas,Integer).
DrawBarcode(TCanvas,TRect,Boolean,Extended,Extended,Boolean) | Represents method DrawBarcode(TCanvas,TRect,Boolean,Extended,Extended,Boolean).
GetWidth | Represents method GetWidth.
MakeData | Represents method MakeData.
MakeModules | Represents method MakeModules.
OneBarProps(AnsiChar,Integer,TfrxBarLineType) | Represents method OneBarProps(AnsiChar,Integer,TfrxBarLineType).
SetLen(Byte) | Represents method SetLen(Byte).
SetTyp(TfrxBarcodeType) | Represents method SetTyp(TfrxBarcodeType).
Top


TfrxBarcode.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxBarcod
Syntax
Delphi
public
 procedure Assign(Source: TPersistent);override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_128 Method

Summary

Represents method Code_128.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_128: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_2_5_industrial Method

Summary

Represents method Code_2_5_industrial.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_2_5_industrial: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_2_5_interleaved Method

Summary

Represents method Code_2_5_interleaved.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_2_5_interleaved: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_2_5_matrix Method

Summary

Represents method Code_2_5_matrix.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_2_5_matrix: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_39 Method

Summary

Represents method Code_39.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_39: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_39Extended Method

Summary

Represents method Code_39Extended.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_39Extended: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_93 Method

Summary

Represents method Code_93.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_93: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_93Extended Method

Summary

Represents method Code_93Extended.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_93Extended: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_Codabar Method

Summary

Represents method Code_Codabar.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_Codabar: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_EAN13 Method

Summary

Represents method Code_EAN13.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_EAN13: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_EAN8 Method

Summary

Represents method Code_EAN8.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_EAN8: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_MSI Method

Summary

Represents method Code_MSI.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_MSI: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_Pharmacode Method

Summary

Represents method Code_Pharmacode.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_Pharmacode: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_PostNet Method

Summary

Represents method Code_PostNet.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_PostNet: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_Supp2 Method

Summary

Represents method Code_Supp2.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_Supp2: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_Supp5 Method

Summary

Represents method Code_Supp5.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_Supp5: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_UPC_A Method

Summary

Represents method Code_UPC_A.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_UPC_A: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_UPC_E0 Method

Summary

Represents method Code_UPC_E0.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_UPC_E0: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_UPC_E1 Method

Summary

Represents method Code_UPC_E1.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_UPC_E1: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.Code_USPSIntelligentMail Method

Summary

Represents method Code_USPSIntelligentMail.

Namespace: frxBarcod
Syntax
Delphi
private
 function Code_USPSIntelligentMail: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.DoCheckSumming(AnsiString) Method

Summary

Represents method DoCheckSumming(AnsiString).

Namespace: frxBarcod
Syntax
Delphi
private
 function DoCheckSumming(const data : AnsiString):AnsiString;

Parameters

data
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.DoLines(AnsiString,TCanvas,Integer) Method

Summary

Represents method DoLines(AnsiString,TCanvas,Integer).

Namespace: frxBarcod
Syntax
Delphi
private
 procedure DoLines(data: AnsiString; Canvas: TCanvas; Offset: Integer);

Parameters

data
Type: AnsiString

Canvas
Type: TCanvas

Offset
Type: Integer

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.DrawBarcode(TCanvas,TRect,Boolean,Extended,Extended,Boolean) Method

Summary

Represents method DrawBarcode(TCanvas,TRect,Boolean,Extended,Extended,Boolean).

Namespace: frxBarcod
Syntax
Delphi
public
 procedure DrawBarcode(Canvas: TCanvas; ARect: TRect; ShowText: Boolean; aScaleDPIX, aScaleDPIY: Extended; DirectToEMF: Boolean = false);

Parameters

Canvas
Type: TCanvas

ARect
Type: TRect

ShowText
Type: Boolean

aScaleDPIX
Type: Extended

aScaleDPIY
Type: Extended

DirectToEMF
Type: Boolean

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.GetWidth Method

Summary

Represents method GetWidth.

Namespace: frxBarcod
Syntax
Delphi
private
 function GetWidth : integer;

Return Value

Type: integer

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.MakeData Method

Summary

Represents method MakeData.

Namespace: frxBarcod
Syntax
Delphi
private
 function MakeData : AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.MakeModules Method

Summary

Represents method MakeModules.

Namespace: frxBarcod
Syntax
Delphi
private
 procedure MakeModules;
See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.OneBarProps(AnsiChar,Integer,TfrxBarLineType) Method

Summary

Represents method OneBarProps(AnsiChar,Integer,TfrxBarLineType).

Namespace: frxBarcod
Syntax
Delphi
private
 procedure OneBarProps(code: AnsiChar; var Width: Integer; var lt: TfrxBarLineType);

Parameters

code
Type: AnsiChar

Width
Type: Integer

lt
Type: TfrxBarLineType

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.SetLen(Byte) Method

Summary

Represents method SetLen(Byte).

Namespace: frxBarcod
Syntax
Delphi
private
 function SetLen(pI: Byte): AnsiString;

Parameters

pI
Type: Byte

Return Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.SetTyp(TfrxBarcodeType) Method

Summary

Represents method SetTyp(TfrxBarcodeType).

Namespace: frxBarcod
Syntax
Delphi
private
 procedure SetTyp(const Value: TfrxBarcodeType);

Parameters

Value
Type: TfrxBarcodeType

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode Fields

Fields
Name | Description
FAngle | Represents field FAngle.
FCheckSum | Represents field FCheckSum.
FCheckSumMethod | Represents field FCheckSumMethod.
FColor | Represents field FColor.
FColorBar | Represents field FColorBar.
FFont | Represents field FFont.
FHeight | Represents field FHeight.
FLeft | Represents field FLeft.
FModul | Represents field FModul.
FRatio | Represents field FRatio.
FText | Represents field FText.
FTop | Represents field FTop.
FTyp | Represents field FTyp.
modules | Represents field modules.
Top


TfrxBarcode.FAngle Field

Summary

Represents field FAngle.

Namespace: frxBarcod
Syntax
Delphi
private
 FAngle: Double;

Field Value

Type: Double

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.FCheckSum Field

Summary

Represents field FCheckSum.

Namespace: frxBarcod
Syntax
Delphi
private
 FCheckSum: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.FCheckSumMethod Field

Summary

Represents field FCheckSumMethod.

Namespace: frxBarcod
Syntax
Delphi
private
 FCheckSumMethod: TfrxCheckSumMethod;

Field Value

Type: TfrxCheckSumMethod

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.FColor Field

Summary

Represents field FColor.

Namespace: frxBarcod
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.FColorBar Field

Summary

Represents field FColorBar.

Namespace: frxBarcod
Syntax
Delphi
private
 FColorBar: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.FFont Field

Summary

Represents field FFont.

Namespace: frxBarcod
Syntax
Delphi
private
 FFont: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.FHeight Field

Summary

Represents field FHeight.

Namespace: frxBarcod
Syntax
Delphi
private
 FHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.FLeft Field

Summary

Represents field FLeft.

Namespace: frxBarcod
Syntax
Delphi
private
 FLeft: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.FModul Field

Summary

Represents field FModul.

Namespace: frxBarcod
Syntax
Delphi
private
 FModul: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.FRatio Field

Summary

Represents field FRatio.

Namespace: frxBarcod
Syntax
Delphi
private
 FRatio: Double;

Field Value

Type: Double

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.FText Field

Summary

Represents field FText.

Namespace: frxBarcod
Syntax
Delphi
private
 FText: AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.FTop Field

Summary

Represents field FTop.

Namespace: frxBarcod
Syntax
Delphi
private
 FTop: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.FTyp Field

Summary

Represents field FTyp.

Namespace: frxBarcod
Syntax
Delphi
private
 FTyp: TfrxBarcodeType;

Field Value

Type: TfrxBarcodeType

See Also

Reference

  • TfrxBarcode
  • frxBarcod


TfrxBarcode.modules Field

Summary

Represents field modules.

Namespace: frxBarcod
Syntax
Delphi
private
 modules: array[0..3] of ShortInt;

Field Value

Type: array[0..3] of ShortInt

See Also

Reference

  • TfrxBarcode
  • frxBarcod


frxBarcod Records

Records
Name | Description
TBCdata | Represents type TBCdata.
Top


TBCdata Record

Summary

Represents type TBCdata.

Namespace: frxBarcod
Syntax
Delphi
type
 TBCdata = packed record
 end;

The TBCdata type exposes the following members.

Fields
Show:
Name | Description
Name | Represents field Name.
num | Represents field num.
Top
See Also

Reference

  • frxBarcod


TBCdata Fields

Fields
Name | Description
Name | Represents field Name.
num | Represents field num.
Top


TBCdata.Name Field

Summary

Represents field Name.

Namespace: frxBarcod
Syntax
Delphi
public
 Name:AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TBCdata
  • frxBarcod


TBCdata.num Field

Summary

Represents field num.

Namespace: frxBarcod
Syntax
Delphi
public
 num :Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBCdata
  • frxBarcod


frxBarcod Enumerations

Enumerations
Name | Description
TfrxBarcodeType | Type of the barcode.
TfrxBarLineType | Represents type TfrxBarLineType.
TfrxCheckSumMethod | Represents type TfrxCheckSumMethod.
Top


TfrxBarcodeType Enumeration

Summary

Type of the barcode.

Namespace: frxBarcod
Syntax
Delphi
type
 TfrxBarcodeType =
 (
 bcCode_2_5_interleaved,
 bcCode_2_5_industrial,
 bcCode_2_5_matrix,
 bcCode39,
 bcCode39Extended,
 bcCode128,
 bcCode128A,
 bcCode128B,
 bcCode128C,
 bcCode93,
 bcCode93Extended,
 bcCodeMSI,
 bcCodePostNet,
 bcCodeCodabar,
 bcCodeEAN8,
 bcCodeEAN13,
 bcCodeUPC_A,
 bcCodeUPC_E0,
 bcCodeUPC_E1,
 bcCodeUPC_Supp2,
 bcCodeUPC_Supp5,
 bcCodeEAN128,
 bcCodeEAN128A,
 bcCodeEAN128B,
 bcCodeEAN128C,
 bcCodeUSPSIntelligentMail,
 bcGS1Code128,
 bcPharmacode
 );

The TfrxBarcodeType type exposes the following members.

Members
Show:
Name | Description
bcCode128 | Represents constant bcCode128.
bcCode128A | Represents constant bcCode128A.
bcCode128B | Represents constant bcCode128B.
bcCode128C | Represents constant bcCode128C.
bcCode39 | Represents constant bcCode39.
bcCode39Extended | Represents constant bcCode39Extended.
bcCode93 | Represents constant bcCode93.
bcCode93Extended | Represents constant bcCode93Extended.
bcCodeCodabar | Represents constant bcCodeCodabar.
bcCodeEAN128 | Represents constant bcCodeEAN128.
bcCodeEAN128A | Represents constant bcCodeEAN128A.
bcCodeEAN128B | Represents constant bcCodeEAN128B.
bcCodeEAN128C | Represents constant bcCodeEAN128C.
bcCodeEAN13 | Represents constant bcCodeEAN13.
bcCodeEAN8 | Represents constant bcCodeEAN8.
bcCodeMSI | Represents constant bcCodeMSI.
bcCodePostNet | Represents constant bcCodePostNet.
bcCodeUPC_A | Represents constant bcCodeUPC_A.
bcCodeUPC_E0 | Represents constant bcCodeUPC_E0.
bcCodeUPC_E1 | Represents constant bcCodeUPC_E1.
bcCodeUPC_Supp2 | Represents constant bcCodeUPC_Supp2.
bcCodeUPC_Supp5 | Represents constant bcCodeUPC_Supp5.
bcCodeUSPSIntelligentMail | Represents constant bcCodeUSPSIntelligentMail.
bcCode_2_5_industrial | Represents constant bcCode_2_5_industrial.
bcCode_2_5_interleaved | Represents constant bcCode_2_5_interleaved.
bcCode_2_5_matrix | Represents constant bcCode_2_5_matrix.
bcGS1Code128 | Represents constant bcGS1Code128.
bcPharmacode | Represents constant bcPharmacode.
Top
See Also

Reference

  • frxBarcod


TfrxBarLineType Enumeration

Summary

Represents type TfrxBarLineType.

Namespace: frxBarcod
Syntax
Delphi
type
 TfrxBarLineType = (white, black, black_half,
 black_track, black_ascend, black_descend);

The TfrxBarLineType type exposes the following members.

Members
Show:
Name | Description
black | Represents constant black.
black_ascend | Represents constant black_ascend.
black_descend | Represents constant black_descend.
black_half | Represents constant black_half.
black_track | Represents constant black_track.
white | Represents constant white.
Top
See Also

Reference

  • frxBarcod


TfrxCheckSumMethod Enumeration

Summary

Represents type TfrxCheckSumMethod.

Namespace: frxBarcod
Syntax
Delphi
type
 TfrxCheckSumMethod =
 (
 csmNone,
 csmModulo10
 );

The TfrxCheckSumMethod type exposes the following members.

Members
Show:
Name | Description
csmModulo10 | Represents constant csmModulo10.
csmNone | Represents constant csmNone.
Top
See Also

Reference

  • frxBarcod


frxBarcod Constants

Constants
Name | Description
BCdata | Represents constant BCdata.
Top


BCdata Constant

Summary

Represents constant BCdata.

Namespace: frxBarcod
Syntax
Delphi
 BCdata:array[bcCode_2_5_interleaved..bcPharmacode] of TBCdata =
 (
 (Name:'2_5_interleaved'; num:True),
 (Name:'2_5_industrial'; num:True),
 (Name:'2_5_matrix'; num:True),
 (Name:'Code39'; num:False),
 (Name:'Code39 Extended'; num:False),
 (Name:'Code128'; num:False),
 (Name:'Code128A'; num:False),
 (Name:'Code128B'; num:False),
 (Name:'Code128C'; num:True),
 (Name:'Code93'; num:False),
 (Name:'Code93 Extended'; num:False),
 (Name:'MSI'; num:True),
 (Name:'PostNet'; num:True),
 (Name:'Codebar'; num:False),
 (Name:'EAN8'; num:True),
 (Name:'EAN13'; num:True),
 (Name:'UPC_A'; num:True),
 (Name:'UPC_E0'; num:True),
 (Name:'UPC_E1'; num:True),
 (Name:'UPC Supp2'; num:True),
 (Name:'UPC Supp5'; num:True),
 (Name:'EAN128'; num:False),
 (Name:'EAN128A'; num:False),
 (Name:'EAN128B'; num:False),
 (Name:'EAN128C'; num:True),
 (Name:'USPS Intelligent Mail'; num:True),
 (Name:'GS1 Code128'; num:False),
 (Name:'Pharmacode'; num:True)
 );

Value

Type: array[bcCode_2_5_interleaved..bcPharmacode] of TBCdata

See Also

Reference

  • frxBarcod


frxBarcode Namespace

Summary

Represents namespace frxBarcode.

Classes
Name | Description
TfrxBarCodeObject | The TfrxBarCodeObject allows the use of the BarCode component in your report. TfrxBarCodeObject is an empty component. It is used for adding the frxBarCode.pas file to the "uses" list. The main component is TfrxBarCodeView.
TfrxBarCodeView | The TfrxBarCodeView component represents a barcode. it shows the Text property value as a barcode. It can also show a barcode from the DB field (you should set DataSet, DataField properties) or from an expression (Expression property).
Top


frxBarcode Classes

Classes
Name | Description
TfrxBarCodeObject | The TfrxBarCodeObject allows the use of the BarCode component in your report. TfrxBarCodeObject is an empty component. It is used for adding the frxBarCode.pas file to the "uses" list. The main component is TfrxBarCodeView.
TfrxBarCodeView | The TfrxBarCodeView component represents a barcode. it shows the Text property value as a barcode. It can also show a barcode from the DB field (you should set DataSet, DataField properties) or from an expression (Expression property).
Top


TfrxBarCodeObject Class

Summary

The TfrxBarCodeObject allows the use of the BarCode component in your report. TfrxBarCodeObject is an empty component. It is used for adding the frxBarCode.pas file to the "uses" list. The main component is TfrxBarCodeView.

Namespace: frxBarcode
Inheritance Hierarchy
TComponent
frxBarcode.TfrxBarCodeObject
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxBarCodeObject = class(TComponent);
See Also

Reference

  • frxBarcode


TfrxBarCodeView Class

Summary

The TfrxBarCodeView component represents a barcode. it shows the Text property value as a barcode. It can also show a barcode from the DB field (you should set DataSet, DataField properties) or from an expression (Expression property).

Namespace: frxBarcode
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxBarcode.TfrxBarCodeView
Syntax
Delphi
type
 TfrxBarCodeView = class(TfrxView)
 end;

The TfrxBarCodeView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBarCodeView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Overrides TfrxComponent.DesignCreate(TComponent,Word).)
Destroy | Represents the destructor of the TfrxBarCodeView class. (Overrides TfrxView.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
AutoSize | Represents property AutoSize.
BarCode | Reference to internal TfrxBarCode object.
BarType | Type of the barcode.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Represents property BrushStyle.
CalcCheckSum | Determines if a checksum calc is required.
Color | Represents property Color.
ColorBar | Represents property ColorBar.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Expression | Value of the expression is printed as a barcode.
Fill | Represents property Fill.
FillType | Represents property FillType.
Font | Represents property Font.
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
HAlign | Determines how the Left property will be changed depending on the barcode width. Valid values are: haLeft - don't change Left; haRight - change Left so right edge is locked; haCenter - change Left so center is locked.
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Represents property Processing.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
Rotation | Rotation of the barcode, in degrees.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
ShowText | Determines if we show the barcode text.
TagStr | Represents property TagStr.
TestLine | Represents property TestLine.
Text | Text of the barcode.
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Represents property URL.
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
WideBarRatio | Represents property WideBarRatio.
Width | Represents property Width. (Inherited from TfrxView.)
Zoom | Zoom of the barcode, can be non-integer.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BcFontChanged(TObject) | Represents method BcFontChanged(TObject).
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColorBar | Represents method GetColorBar.
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Overrides TfrxView.GetExportBounds.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Overrides TfrxReportComponent.GetRealBounds.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Overrides TfrxView.GetVectorGraphic(Boolean).)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetColorBar(TColor) | Represents method SetColorBar(TColor).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetText(String) | Represents method SetText(String).
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FAutoSize | Represents field FAutoSize.
FBarCode | Represents field FBarCode.
FBarType | Represents field FBarType.
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCalcCheckSum | Represents field FCalcCheckSum.
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FExportExpance | Represents field FExportExpance.
FExpression | Represents field FExpression.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHAlign | Represents field FHAlign.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FMacroLoaded | Represents field FMacroLoaded.
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FRotation | Represents field FRotation.
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FShowText | Represents field FShowText.
FTestLine | Represents field FTestLine.
FText | Represents field FText.
FVC | Represents field FVC. (Inherited from TfrxView.)
FWideBarRatio | Represents field FWideBarRatio.
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
FZoom | Represents field FZoom.
Top
See Also

Reference

  • frxBarcode


TfrxBarCodeView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBarCodeView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Overrides TfrxComponent.DesignCreate(TComponent,Word).)
Destroy | Represents the destructor of the TfrxBarCodeView class. (Overrides TfrxView.Destroy.)
Top


TfrxBarCodeView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxBarCodeView class.

Namespace: frxBarcode
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxView.Create(TComponent)
See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.DesignCreate(TComponent,Word) Constructor

Summary

Constructor uses by the report designer when create new report object.

Namespace: frxBarcode
Syntax
Delphi
public
 constructor DesignCreate(AOwner: TComponent; Flags: Word); override;

Parameters

AOwner
Type: TComponent

Component owner.

Flags
Type: Word

Addition creation parameter depends on component class.

Overrides

TfrxComponent.DesignCreate(TComponent,Word)
See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.Destroy Destructor

Summary

Represents the destructor of the TfrxBarCodeView class.

Namespace: frxBarcode
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxView.Destroy
See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView Properties

Properties
Name | Description
AutoSize | Represents property AutoSize.
BarCode | Reference to internal TfrxBarCode object.
BarType | Type of the barcode.
BrushStyle | Represents property BrushStyle.
CalcCheckSum | Determines if a checksum calc is required.
Color | Represents property Color.
ColorBar | Represents property ColorBar.
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Expression | Value of the expression is printed as a barcode.
Fill | Represents property Fill.
FillType | Represents property FillType.
Font | Represents property Font.
Frame | Represents property Frame.
HAlign | Determines how the Left property will be changed depending on the barcode width. Valid values are: haLeft - don't change Left; haRight - change Left so right edge is locked; haCenter - change Left so center is locked.
Processing | Represents property Processing.
Rotation | Rotation of the barcode, in degrees.
ShowText | Determines if we show the barcode text.
TagStr | Represents property TagStr.
TestLine | Represents property TestLine.
Text | Text of the barcode.
URL | Represents property URL.
WideBarRatio | Represents property WideBarRatio.
Zoom | Zoom of the barcode, can be non-integer.
Top


TfrxBarCodeView.AutoSize Property

Summary

Represents property AutoSize.

Namespace: frxBarcode
Syntax
Delphi
published
 property AutoSize: Boolean read FAutoSize write FAutoSize default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.BarCode Property

Summary

Reference to internal TfrxBarCode object.

Namespace: frxBarcode
Syntax
Delphi
public
 property BarCode: TfrxBarCode read FBarCode;

Property Value

Type: TfrxBarCode

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.BarType Property

Summary

Type of the barcode.

Namespace: frxBarcode
Syntax
Delphi
published
 property BarType: TfrxBarcodeType read FBarType write FBarType;

Property Value

Type: TfrxBarcodeType

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.BrushStyle Property

Summary

Represents property BrushStyle.

Namespace: frxBarcode
Syntax
Delphi
published
 property BrushStyle;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.CalcCheckSum Property

Summary

Determines if a checksum calc is required.

Namespace: frxBarcode
Syntax
Delphi
published
 property CalcCheckSum: Boolean read FCalcCheckSum write FCalcCheckSum default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.Color Property

Summary

Represents property Color.

Namespace: frxBarcode
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.ColorBar Property

Summary

Represents property ColorBar.

Namespace: frxBarcode
Syntax
Delphi
published
 property ColorBar: TColor read GetColorBar write SetColorBar;

Property Value

Type: TColor

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.Cursor Property

Summary

Represents property Cursor.

Namespace: frxBarcode
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.DataField Property

Summary

Represents property DataField.

Namespace: frxBarcode
Syntax
Delphi
published
 property DataField;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.DataSet Property

Summary

Represents property DataSet.

Namespace: frxBarcode
Syntax
Delphi
published
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxBarcode
Syntax
Delphi
published
 property DataSetName;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.Expression Property

Summary

Value of the expression is printed as a barcode.

Namespace: frxBarcode
Syntax
Delphi
published
 property Expression: String read FExpression write FExpression;

Property Value

Type: String

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.Fill Property

Summary

Represents property Fill.

Namespace: frxBarcode
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FillType Property

Summary

Represents property FillType.

Namespace: frxBarcode
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.Font Property

Summary

Represents property Font.

Namespace: frxBarcode
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.Frame Property

Summary

Represents property Frame.

Namespace: frxBarcode
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.HAlign Property

Summary

Determines how the Left property will be changed depending on the barcode width. Valid values are:
haLeft - don't change Left;
haRight - change Left so right edge is locked;
haCenter - change Left so center is locked.

Namespace: frxBarcode
Syntax
Delphi
published
 property HAlign: TfrxHAlign read FHAlign write FHAlign default haLeft;

Property Value

Type: TfrxHAlign

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.Processing Property

Summary

Represents property Processing.

Namespace: frxBarcode
Syntax
Delphi
published
 property Processing;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.Rotation Property

Summary

Rotation of the barcode, in degrees.

Namespace: frxBarcode
Syntax
Delphi
published
 property Rotation: Integer read FRotation write FRotation;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.ShowText Property

Summary

Determines if we show the barcode text.

Namespace: frxBarcode
Syntax
Delphi
published
 property ShowText: Boolean read FShowText write FShowText default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.TagStr Property

Summary

Represents property TagStr.

Namespace: frxBarcode
Syntax
Delphi
published
 property TagStr;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.TestLine Property

Summary

Represents property TestLine.

Namespace: frxBarcode
Syntax
Delphi
published
 property TestLine: Boolean read FTestLine write FTestLine;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.Text Property

Summary

Text of the barcode.

Namespace: frxBarcode
Syntax
Delphi
published
 property Text: String read FText write SetText;

Property Value

Type: String

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.URL Property

Summary

Represents property URL.

Namespace: frxBarcode
Syntax
Delphi
published
 property URL;

Property Value

Type: Void

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.WideBarRatio Property

Summary

Represents property WideBarRatio.

Namespace: frxBarcode
Syntax
Delphi
published
 property WideBarRatio: Extended read FWideBarRatio write FWideBarRatio;

Property Value

Type: Extended

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.Zoom Property

Summary

Zoom of the barcode, can be non-integer.

Namespace: frxBarcode
Syntax
Delphi
published
 property Zoom: Extended read FZoom write FZoom;

Property Value

Type: Extended

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView Methods

Methods
Name | Description
BcFontChanged(TObject) | Represents method BcFontChanged(TObject).
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
GetColorBar | Represents method GetColorBar.
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetExportBounds | Returns object bounds for export filtes. (Overrides TfrxView.GetExportBounds.)
GetRealBounds | Deprecated. Returns real size of object. (Overrides TfrxReportComponent.GetRealBounds.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Overrides TfrxView.GetVectorGraphic(Boolean).)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SetColorBar(TColor) | Represents method SetColorBar(TColor).
SetText(String) | Represents method SetText(String).
Top


TfrxBarCodeView.BcFontChanged(TObject) Method

Summary

Represents method BcFontChanged(TObject).

Namespace: frxBarcode
Syntax
Delphi
private
 procedure BcFontChanged(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxBarcode
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.GetColorBar Method

Summary

Represents method GetColorBar.

Namespace: frxBarcode
Syntax
Delphi
public
 function GetColorBar: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxBarcode
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxBarcode
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.GetExportBounds Method

Summary

Returns object bounds for export filtes.

Namespace: frxBarcode
Syntax
Delphi
public
 function GetExportBounds: TfrxRect; override;

Return Value

Type: TfrxRect

Overrides

TfrxView.GetExportBounds
See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.GetRealBounds Method

Summary

Deprecated. Returns real size of object.

Namespace: frxBarcode
Syntax
Delphi
public
 function GetRealBounds: TfrxRect; override;

Return Value

Type: TfrxRect

Overrides

TfrxReportComponent.GetRealBounds
See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.GetVectorGraphic(Boolean) Method

Summary

Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it.

Namespace: frxBarcode
Syntax
Delphi
public
 function GetVectorGraphic(DrawFill: Boolean = False): TGraphic; override;

Parameters

DrawFill
Type: Boolean

If True , object draws fill on result vector image.

Return Value

Type: TGraphic

Overrides

TfrxView.GetVectorGraphic(Boolean)
See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) Method

Summary

Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call.

Namespace: frxBarcode
Syntax
Delphi
public
 function LoadContentFromDictionary(aReport: TfrxReport; aItem: TfrxMacrosItem): Boolean; override;

Parameters

aReport
Type: TfrxReport

Reference to the report object.

aItem
Type: TfrxMacrosItem

TfrxMacrosItem which stores processed data for current object.

Return Value

Type: Boolean

Overrides

TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem)
See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) Method

Summary

The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from
PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary.

Namespace: frxBarcode
Syntax
Delphi
public
 procedure ProcessDictionary(aItem: TfrxMacrosItem; aReport: TfrxReport; PostProcessor: TfrxPostProcessor); override;

Parameters

aItem
Type: TfrxMacrosItem

aReport
Type: TfrxReport

PostProcessor
Type: TfrxPostProcessor

Overrides

TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor)
See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor) Method

Summary

This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object.

Namespace: frxBarcode
Syntax
Delphi
public
 procedure SaveContentToDictionary(aReport: TfrxReport; PostProcessor: TfrxPostProcessor); override;

Parameters

aReport
Type: TfrxReport

Reference to the report object.

PostProcessor
Type: TfrxPostProcessor

Reference to TfrxPostProcessor instance of post processing manager.

Overrides

TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor)
See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.SetColorBar(TColor) Method

Summary

Represents method SetColorBar(TColor).

Namespace: frxBarcode
Syntax
Delphi
public
 procedure SetColorBar(c: TColor);

Parameters

c
Type: TColor

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.SetText(String) Method

Summary

Represents method SetText(String).

Namespace: frxBarcode
Syntax
Delphi
public
 procedure SetText(Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView Fields

Fields
Name | Description
FAutoSize | Represents field FAutoSize.
FBarCode | Represents field FBarCode.
FBarType | Represents field FBarType.
FCalcCheckSum | Represents field FCalcCheckSum.
FExportExpance | Represents field FExportExpance.
FExpression | Represents field FExpression.
FHAlign | Represents field FHAlign.
FMacroLoaded | Represents field FMacroLoaded.
FRotation | Represents field FRotation.
FShowText | Represents field FShowText.
FTestLine | Represents field FTestLine.
FText | Represents field FText.
FWideBarRatio | Represents field FWideBarRatio.
FZoom | Represents field FZoom.
Top


TfrxBarCodeView.FAutoSize Field

Summary

Represents field FAutoSize.

Namespace: frxBarcode
Syntax
Delphi
private
 FAutoSize: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FBarCode Field

Summary

Represents field FBarCode.

Namespace: frxBarcode
Syntax
Delphi
private
 FBarCode: TfrxBarCode;

Field Value

Type: TfrxBarCode

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FBarType Field

Summary

Represents field FBarType.

Namespace: frxBarcode
Syntax
Delphi
private
 FBarType: TfrxBarcodeType;

Field Value

Type: TfrxBarcodeType

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FCalcCheckSum Field

Summary

Represents field FCalcCheckSum.

Namespace: frxBarcode
Syntax
Delphi
private
 FCalcCheckSum: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FExportExpance Field

Summary

Represents field FExportExpance.

Namespace: frxBarcode
Syntax
Delphi
private
 FExportExpance: integer;

Field Value

Type: integer

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FExpression Field

Summary

Represents field FExpression.

Namespace: frxBarcode
Syntax
Delphi
private
 FExpression: String;

Field Value

Type: String

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FHAlign Field

Summary

Represents field FHAlign.

Namespace: frxBarcode
Syntax
Delphi
private
 FHAlign: TfrxHAlign;

Field Value

Type: TfrxHAlign

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FMacroLoaded Field

Summary

Represents field FMacroLoaded.

Namespace: frxBarcode
Syntax
Delphi
private
 FMacroLoaded: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FRotation Field

Summary

Represents field FRotation.

Namespace: frxBarcode
Syntax
Delphi
private
 FRotation: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FShowText Field

Summary

Represents field FShowText.

Namespace: frxBarcode
Syntax
Delphi
private
 FShowText: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FTestLine Field

Summary

Represents field FTestLine.

Namespace: frxBarcode
Syntax
Delphi
private
 FTestLine: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FText Field

Summary

Represents field FText.

Namespace: frxBarcode
Syntax
Delphi
private
 FText: String;

Field Value

Type: String

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FWideBarRatio Field

Summary

Represents field FWideBarRatio.

Namespace: frxBarcode
Syntax
Delphi
private
 FWideBarRatio: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


TfrxBarCodeView.FZoom Field

Summary

Represents field FZoom.

Namespace: frxBarcode
Syntax
Delphi
private
 FZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxBarCodeView
  • frxBarcode


frxBarcode2D Namespace

Summary

Represents namespace frxBarcode2D.

Classes
Name | Description
TfrxBarcode2DView | Represents type TfrxBarcode2DView.
Top
Enumerations
Name | Description
TfrxBarcode2DType | Represents type TfrxBarcode2DType.
Top


frxBarcode2D Classes

Classes
Name | Description
TfrxBarcode2DView | Represents type TfrxBarcode2DView.
Top


TfrxBarcode2DView Class

Summary

Represents type TfrxBarcode2DView.

Namespace: frxBarcode2D
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxBarcode2D.TfrxBarcode2DView
Syntax
Delphi
type
 TfrxBarcode2DView = class(TfrxStretcheable, IInspectedProperties)
 end;

The TfrxBarcode2DView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBarcode2DView class. (Overrides TfrxStretcheable.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Overrides TfrxComponent.DesignCreate(TComponent,Word).)
Destroy | Represents the destructor of the TfrxBarcode2DView class. (Overrides TfrxView.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
AutoSize | Represents property AutoSize.
BarProperties | Represents property BarProperties.
BarType | Represents property BarType.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Represents property BrushStyle.
CanShrink | True if object can shrink height base on its content. (Inherited from TfrxStretcheable.)
Color | Represents property Color.
ColorBar | Represents property ColorBar.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
ErrorText | Represents property ErrorText.
Expression | Represents property Expression.
ExpressionPreset | Represents property ExpressionPreset.
Fill | Represents property Fill.
FillType | Object fill type. (Inherited from TfrxView.)
Font | Represents property Font.
FontScaled | Represents property FontScaled.
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
HAlign | Represents property HAlign.
Height | Represents property Height. (Inherited from TfrxView.)
HexData | Represents property HexData.
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Represents property Processing.
QuietZone | Represents property QuietZone.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
Rotation | Represents property Rotation.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
ShowText | Represents property ShowText.
StretchMode | Object's stretch mode. (Inherited from TfrxStretcheable.)
TagStr | Represents property TagStr.
Text | Represents property Text.
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Represents property URL.
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Zoom | Represents property Zoom.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
CalcAddSize | Represents method CalcAddSize.
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxStretcheable.CalcHeight.)
CalcSize | Represents method CalcSize.
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxStretcheable.DrawPart.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColorBar | Represents method GetColorBar.
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDataPreset | Represents method GetDataPreset.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetErrorText | Represents method GetErrorText.
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetFontScaled | Represents method GetFontScaled.
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetHexData | Represents method GetHexData.
GetProperies | Represents method GetProperies.
GetQuietZone | Represents method GetQuietZone.
GetRealBounds | Deprecated. Returns real size of object. (Overrides TfrxReportComponent.GetRealBounds.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetRotation | Represents method GetRotation.
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Overrides TfrxView.GetScaleFactor(Extended,Extended).)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetShowText | Represents method GetShowText.
GetText | Represents method GetText.
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Overrides TfrxView.GetVectorGraphic(Boolean).)
GetZoom | Represents method GetZoom.
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Inherited from TfrxStretcheable.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object. (Inherited from TfrxStretcheable.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
ReadPreset(TReader) | Represents method ReadPreset(TReader).
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBarType(TfrxBarcode2DType) | Represents method SetBarType(TfrxBarcode2DType).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetColorBar(TColor) | Represents method SetColorBar(TColor).
SetErrorText(String) | Represents method SetErrorText(String).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetHexData(String) | Represents method SetHexData(String).
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetProp(TfrxBarcode2DProperties) | Represents method SetProp(TfrxBarcode2DProperties).
SetQuietZone(Integer) | Represents method SetQuietZone(Integer).
SetRotation(Integer) | Represents method SetRotation(Integer).
SetShowText(Boolean) | Represents method SetShowText(Boolean).
SetText(String) | Represents method SetText(String).
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
SetZoom(Extended) | Represents method SetZoom(Extended).
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
WritePreset(TWriter) | Represents method WritePreset(TWriter).
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FAutoSize | Represents field FAutoSize.
FBarCode | Represents field FBarCode.
FBarType | Represents field FBarType.
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FExpression | Represents field FExpression.
FExpressionPreset | Represents field FExpressionPreset.
FExtPropList | Represents field FExtPropList.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHAlign | Represents field FHAlign.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FMacroLoaded | Represents field FMacroLoaded.
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FProp | Represents field FProp.
FSavedTop | Internal use only. Stores original top during shift operation. (Inherited from TfrxStretcheable.)
FSaveHeight | Internal use only. Stores object Height during stretch operation. (Inherited from TfrxStretcheable.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxBarcode2D


TfrxBarcode2DView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBarcode2DView class. (Overrides TfrxStretcheable.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Overrides TfrxComponent.DesignCreate(TComponent,Word).)
Destroy | Represents the destructor of the TfrxBarcode2DView class. (Overrides TfrxView.Destroy.)
Top


TfrxBarcode2DView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxBarcode2DView class.

Namespace: frxBarcode2D
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxStretcheable.Create(TComponent)
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.DesignCreate(TComponent,Word) Constructor

Summary

Constructor uses by the report designer when create new report object.

Namespace: frxBarcode2D
Syntax
Delphi
public
 constructor DesignCreate(AOwner: TComponent; Flags: Word); override;

Parameters

AOwner
Type: TComponent

Component owner.

Flags
Type: Word

Addition creation parameter depends on component class.

Overrides

TfrxComponent.DesignCreate(TComponent,Word)
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.Destroy Destructor

Summary

Represents the destructor of the TfrxBarcode2DView class.

Namespace: frxBarcode2D
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxView.Destroy
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView Properties

Properties
Name | Description
AutoSize | Represents property AutoSize.
BarProperties | Represents property BarProperties.
BarType | Represents property BarType.
BrushStyle | Represents property BrushStyle.
Color | Represents property Color.
ColorBar | Represents property ColorBar.
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
ErrorText | Represents property ErrorText.
Expression | Represents property Expression.
ExpressionPreset | Represents property ExpressionPreset.
Fill | Represents property Fill.
Font | Represents property Font.
FontScaled | Represents property FontScaled.
Frame | Represents property Frame.
HAlign | Represents property HAlign.
HexData | Represents property HexData.
Processing | Represents property Processing.
QuietZone | Represents property QuietZone.
Rotation | Represents property Rotation.
ShowText | Represents property ShowText.
TagStr | Represents property TagStr.
Text | Represents property Text.
URL | Represents property URL.
Zoom | Represents property Zoom.
Top


TfrxBarcode2DView.AutoSize Property

Summary

Represents property AutoSize.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property AutoSize: Boolean read FAutoSize write FAutoSize default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.BarProperties Property

Summary

Represents property BarProperties.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property BarProperties: TfrxBarcode2DProperties read FProp write SetProp;

Property Value

Type: TfrxBarcode2DProperties

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.BarType Property

Summary

Represents property BarType.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property BarType: TfrxBarcode2DType read FBarType write SetBarType;

Property Value

Type: TfrxBarcode2DType

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.BrushStyle Property

Summary

Represents property BrushStyle.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property BrushStyle;

Property Value

Type: Void

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.Color Property

Summary

Represents property Color.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.ColorBar Property

Summary

Represents property ColorBar.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property ColorBar: TColor read GetColorBar write SetColorBar;

Property Value

Type: TColor

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.Cursor Property

Summary

Represents property Cursor.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.DataField Property

Summary

Represents property DataField.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property DataField;

Property Value

Type: Void

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.DataSet Property

Summary

Represents property DataSet.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property DataSetName;

Property Value

Type: Void

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.ErrorText Property

Summary

Represents property ErrorText.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property ErrorText: String read GetErrorText write SetErrorText;

Property Value

Type: String

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.Expression Property

Summary

Represents property Expression.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property Expression: String read FExpression write FExpression;

Property Value

Type: String

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.ExpressionPreset Property

Summary

Represents property ExpressionPreset.

Namespace: frxBarcode2D
Syntax
Delphi
public
 property ExpressionPreset: TfrxObjectDataPreset read FExpressionPreset;

Property Value

Type: TfrxObjectDataPreset

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.Fill Property

Summary

Represents property Fill.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.Font Property

Summary

Represents property Font.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.FontScaled Property

Summary

Represents property FontScaled.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property FontScaled: Boolean read GetFontScaled write SetFontScaled;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.Frame Property

Summary

Represents property Frame.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.HAlign Property

Summary

Represents property HAlign.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property HAlign: TfrxHAlign read FHAlign write FHAlign default haLeft;

Property Value

Type: TfrxHAlign

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.HexData Property

Summary

Represents property HexData.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property HexData: String read GetHexData write SetHexData;

Property Value

Type: String

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.Processing Property

Summary

Represents property Processing.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property Processing;

Property Value

Type: Void

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.QuietZone Property

Summary

Represents property QuietZone.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property QuietZone: Integer read GetQuietZone write SetQuietZone;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.Rotation Property

Summary

Represents property Rotation.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property Rotation: Integer read GetRotation write SetRotation;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.ShowText Property

Summary

Represents property ShowText.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property ShowText: Boolean read GetShowText write SetShowText;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.TagStr Property

Summary

Represents property TagStr.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property TagStr;

Property Value

Type: Void

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.Text Property

Summary

Represents property Text.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property Text: String read GetText write SetText stored False;

Property Value

Type: String

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.URL Property

Summary

Represents property URL.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property URL;

Property Value

Type: Void

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.Zoom Property

Summary

Represents property Zoom.

Namespace: frxBarcode2D
Syntax
Delphi
published
 property Zoom: Extended read GetZoom write SetZoom;

Property Value

Type: Extended

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView Methods

Methods
Name | Description
CalcAddSize | Represents method CalcAddSize.
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxStretcheable.CalcHeight.)
CalcSize | Represents method CalcSize.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxStretcheable.DrawPart.)
GetColorBar | Represents method GetColorBar.
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDataPreset | Represents method GetDataPreset.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetErrorText | Represents method GetErrorText.
GetFontScaled | Represents method GetFontScaled.
GetHexData | Represents method GetHexData.
GetProperies | Represents method GetProperies.
GetQuietZone | Represents method GetQuietZone.
GetRealBounds | Deprecated. Returns real size of object. (Overrides TfrxReportComponent.GetRealBounds.)
GetRotation | Represents method GetRotation.
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Overrides TfrxView.GetScaleFactor(Extended,Extended).)
GetShowText | Represents method GetShowText.
GetText | Represents method GetText.
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Overrides TfrxView.GetVectorGraphic(Boolean).)
GetZoom | Represents method GetZoom.
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
ReadPreset(TReader) | Represents method ReadPreset(TReader).
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SetBarType(TfrxBarcode2DType) | Represents method SetBarType(TfrxBarcode2DType).
SetColorBar(TColor) | Represents method SetColorBar(TColor).
SetErrorText(String) | Represents method SetErrorText(String).
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetHexData(String) | Represents method SetHexData(String).
SetProp(TfrxBarcode2DProperties) | Represents method SetProp(TfrxBarcode2DProperties).
SetQuietZone(Integer) | Represents method SetQuietZone(Integer).
SetRotation(Integer) | Represents method SetRotation(Integer).
SetShowText(Boolean) | Represents method SetShowText(Boolean).
SetText(String) | Represents method SetText(String).
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
SetZoom(Extended) | Represents method SetZoom(Extended).
WritePreset(TWriter) | Represents method WritePreset(TWriter).
Top


TfrxBarcode2DView.CalcAddSize Method

Summary

Represents method CalcAddSize.

Namespace: frxBarcode2D
Syntax
Delphi
private
 function CalcAddSize: TfrxPoint;

Return Value

Type: TfrxPoint

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.CalcHeight Method

Summary

Calculates and returns the object's height according to the data placed in it.

Namespace: frxBarcode2D
Syntax
Delphi
public
 function CalcHeight: Extended; override;

Return Value

Type: Extended

Overrides

TfrxStretcheable.CalcHeight
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.CalcSize Method

Summary

Represents method CalcSize.

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure CalcSize;
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxBarcode2D
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxBarcode2D
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX,
 OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.DrawPart Method

Summary

Objects part drawing function , if the object is splittable.

Namespace: frxBarcode2D
Syntax
Delphi
public
 function DrawPart: Extended; override;

Return Value

Type: Extended

Overrides

TfrxStretcheable.DrawPart
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetColorBar Method

Summary

Represents method GetColorBar.

Namespace: frxBarcode2D
Syntax
Delphi
private
 function GetColorBar: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxBarcode2D
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetDataPreset Method

Summary

Represents method GetDataPreset.

Namespace: frxBarcode2D
Syntax
Delphi
private
 function GetDataPreset: TfrxObjectDataPreset; virtual;

Return Value

Type: TfrxObjectDataPreset

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxBarcode2D
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetErrorText Method

Summary

Represents method GetErrorText.

Namespace: frxBarcode2D
Syntax
Delphi
private
 function GetErrorText: String;

Return Value

Type: String

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetFontScaled Method

Summary

Represents method GetFontScaled.

Namespace: frxBarcode2D
Syntax
Delphi
private
 function GetFontScaled: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetHexData Method

Summary

Represents method GetHexData.

Namespace: frxBarcode2D
Syntax
Delphi
private
 function GetHexData: String;

Return Value

Type: String

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetProperies Method

Summary

Represents method GetProperies.

Namespace: frxBarcode2D
Syntax
Delphi
protected
 function GetProperies: TfrxExtPropList;

Return Value

Type: TfrxExtPropList

Implements

IInspectedProperties.GetProperies
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetQuietZone Method

Summary

Represents method GetQuietZone.

Namespace: frxBarcode2D
Syntax
Delphi
private
 function GetQuietZone: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetRealBounds Method

Summary

Deprecated. Returns real size of object.

Namespace: frxBarcode2D
Syntax
Delphi
public
 function GetRealBounds: TfrxRect; override;

Return Value

Type: TfrxRect

Overrides

TfrxReportComponent.GetRealBounds
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetRotation Method

Summary

Represents method GetRotation.

Namespace: frxBarcode2D
Syntax
Delphi
private
 function GetRotation: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetScaleFactor(Extended,Extended) Method

Summary

Deprecated. Used to get scale factor of object content for export filters.

Namespace: frxBarcode2D
Syntax
Delphi
public
 procedure GetScaleFactor(var ScaleX: Extended; var ScaleY: Extended); override;

Parameters

ScaleX
Type: Extended

ScaleY
Type: Extended

Overrides

TfrxView.GetScaleFactor(Extended,Extended)
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetShowText Method

Summary

Represents method GetShowText.

Namespace: frxBarcode2D
Syntax
Delphi
private
 function GetShowText: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetText Method

Summary

Represents method GetText.

Namespace: frxBarcode2D
Syntax
Delphi
private
 function GetText: String;

Return Value

Type: String

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetVectorGraphic(Boolean) Method

Summary

Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it.

Namespace: frxBarcode2D
Syntax
Delphi
public
 function GetVectorGraphic(DrawFill: Boolean = False): TGraphic; override;

Parameters

DrawFill
Type: Boolean

If True , object draws fill on result vector image.

Return Value

Type: TGraphic

Overrides

TfrxView.GetVectorGraphic(Boolean)
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.GetZoom Method

Summary

Represents method GetZoom.

Namespace: frxBarcode2D
Syntax
Delphi
private
 function GetZoom: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) Method

Summary

Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call.

Namespace: frxBarcode2D
Syntax
Delphi
public
 function LoadContentFromDictionary(aReport: TfrxReport; aItem: TfrxMacrosItem): Boolean; override;

Parameters

aReport
Type: TfrxReport

Reference to the report object.

aItem
Type: TfrxMacrosItem

TfrxMacrosItem which stores processed data for current object.

Return Value

Type: Boolean

Overrides

TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem)
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) Method

Summary

The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from
PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary.

Namespace: frxBarcode2D
Syntax
Delphi
public
 procedure ProcessDictionary(aItem: TfrxMacrosItem; aReport: TfrxReport; PostProcessor: TfrxPostProcessor); override;

Parameters

aItem
Type: TfrxMacrosItem

aReport
Type: TfrxReport

PostProcessor
Type: TfrxPostProcessor

Overrides

TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor)
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.ReadPreset(TReader) Method

Summary

Represents method ReadPreset(TReader).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure ReadPreset(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor) Method

Summary

This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object.

Namespace: frxBarcode2D
Syntax
Delphi
public
 procedure SaveContentToDictionary(aReport: TfrxReport; PostProcessor: TfrxPostProcessor); override;

Parameters

aReport
Type: TfrxReport

Reference to the report object.

PostProcessor
Type: TfrxPostProcessor

Reference to TfrxPostProcessor instance of post processing manager.

Overrides

TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor)
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetBarType(TfrxBarcode2DType) Method

Summary

Represents method SetBarType(TfrxBarcode2DType).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure SetBarType(v: TfrxBarcode2DType);

Parameters

v
Type: TfrxBarcode2DType

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetColorBar(TColor) Method

Summary

Represents method SetColorBar(TColor).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure SetColorBar(c: TColor);

Parameters

c
Type: TColor

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetErrorText(String) Method

Summary

Represents method SetErrorText(String).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure SetErrorText(v: String);

Parameters

v
Type: String

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetFontScaled(Boolean) Method

Summary

Represents method SetFontScaled(Boolean).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure SetFontScaled(v: Boolean);

Parameters

v
Type: Boolean

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetHeight(Extended) Method

Summary

Represents method SetHeight(Extended).

Namespace: frxBarcode2D
Syntax
Delphi
protected
 procedure SetHeight(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetHeight(Extended)
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetHexData(String) Method

Summary

Represents method SetHexData(String).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure SetHexData(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetProp(TfrxBarcode2DProperties) Method

Summary

Represents method SetProp(TfrxBarcode2DProperties).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure SetProp(v: TfrxBarcode2DProperties);

Parameters

v
Type: TfrxBarcode2DProperties

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetQuietZone(Integer) Method

Summary

Represents method SetQuietZone(Integer).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure SetQuietZone(v: Integer);

Parameters

v
Type: Integer

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetRotation(Integer) Method

Summary

Represents method SetRotation(Integer).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure SetRotation(v: Integer);

Parameters

v
Type: Integer

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetShowText(Boolean) Method

Summary

Represents method SetShowText(Boolean).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure SetShowText(v: Boolean);

Parameters

v
Type: Boolean

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetText(String) Method

Summary

Represents method SetText(String).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure SetText(v: String);

Parameters

v
Type: String

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetWidth(Extended) Method

Summary

Represents method SetWidth(Extended).

Namespace: frxBarcode2D
Syntax
Delphi
protected
 procedure SetWidth(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetWidth(Extended)
See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.SetZoom(Extended) Method

Summary

Represents method SetZoom(Extended).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure SetZoom(z: Extended);

Parameters

z
Type: Extended

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.WritePreset(TWriter) Method

Summary

Represents method WritePreset(TWriter).

Namespace: frxBarcode2D
Syntax
Delphi
private
 procedure WritePreset(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView Fields

Fields
Name | Description
FAutoSize | Represents field FAutoSize.
FBarCode | Represents field FBarCode.
FBarType | Represents field FBarType.
FExpression | Represents field FExpression.
FExpressionPreset | Represents field FExpressionPreset.
FExtPropList | Represents field FExtPropList.
FHAlign | Represents field FHAlign.
FMacroLoaded | Represents field FMacroLoaded.
FProp | Represents field FProp.
Top


TfrxBarcode2DView.FAutoSize Field

Summary

Represents field FAutoSize.

Namespace: frxBarcode2D
Syntax
Delphi
private
 FAutoSize: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.FBarCode Field

Summary

Represents field FBarCode.

Namespace: frxBarcode2D
Syntax
Delphi
private
 FBarCode: TfrxBarcode2DBase;

Field Value

Type: TfrxBarcode2DBase

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.FBarType Field

Summary

Represents field FBarType.

Namespace: frxBarcode2D
Syntax
Delphi
private
 FBarType: TfrxBarcode2DType;

Field Value

Type: TfrxBarcode2DType

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.FExpression Field

Summary

Represents field FExpression.

Namespace: frxBarcode2D
Syntax
Delphi
private
 FExpression: String;

Field Value

Type: String

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.FExpressionPreset Field

Summary

Represents field FExpressionPreset.

Namespace: frxBarcode2D
Syntax
Delphi
private
 FExpressionPreset: TfrxObjectDataPreset;

Field Value

Type: TfrxObjectDataPreset

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.FExtPropList Field

Summary

Represents field FExtPropList.

Namespace: frxBarcode2D
Syntax
Delphi
private
 FExtPropList: TfrxExtPropList;

Field Value

Type: TfrxExtPropList

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.FHAlign Field

Summary

Represents field FHAlign.

Namespace: frxBarcode2D
Syntax
Delphi
private
 FHAlign: TfrxHAlign;

Field Value

Type: TfrxHAlign

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.FMacroLoaded Field

Summary

Represents field FMacroLoaded.

Namespace: frxBarcode2D
Syntax
Delphi
private
 FMacroLoaded: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


TfrxBarcode2DView.FProp Field

Summary

Represents field FProp.

Namespace: frxBarcode2D
Syntax
Delphi
private
 FProp: TfrxBarcode2DProperties;

Field Value

Type: TfrxBarcode2DProperties

See Also

Reference

  • TfrxBarcode2DView
  • frxBarcode2D


frxBarcode2D Enumerations

Enumerations
Name | Description
TfrxBarcode2DType | Represents type TfrxBarcode2DType.
Top


TfrxBarcode2DType Enumeration

Summary

Represents type TfrxBarcode2DType.

Namespace: frxBarcode2D
Syntax
Delphi
type
 TfrxBarcode2DType = (bcCodePDF417, bcCodeDataMatrix, bcCodeQR, bcCodeAztec, bcCodeMaxiCode, bcGS1DatabarE, bcGS1DatabarES);

The TfrxBarcode2DType type exposes the following members.

Members
Show:
Name | Description
bcCodeAztec | Represents constant bcCodeAztec.
bcCodeDataMatrix | Represents constant bcCodeDataMatrix.
bcCodeMaxiCode | Represents constant bcCodeMaxiCode.
bcCodePDF417 | Represents constant bcCodePDF417.
bcCodeQR | Represents constant bcCodeQR.
bcGS1DatabarE | Represents constant bcGS1DatabarE.
bcGS1DatabarES | Represents constant bcGS1DatabarES.
Top
See Also

Reference

  • frxBarcode2D


frxBarcode2DBase Namespace

Summary

Represents namespace frxBarcode2DBase.

Classes
Name | Description
TfrxBarcode2DBase |
TfrxBarcode2DBaseWithOutUnion | Represents type TfrxBarcode2DBaseWithOutUnion.
TfrxBarcode2DBaseWithUnion | Represents type TfrxBarcode2DBaseWithUnion.
Top
Types
Name | Description
T2DBooleanArray | Represents an array of the type.
Top
Constants
Name | Description
cbDefaultText | Represents constant cbDefaultText.
Top


frxBarcode2DBase Classes

Classes
Name | Description
TfrxBarcode2DBase |
TfrxBarcode2DBaseWithOutUnion | Represents type TfrxBarcode2DBaseWithOutUnion.
TfrxBarcode2DBaseWithUnion | Represents type TfrxBarcode2DBaseWithUnion.
Top


TfrxBarcode2DBase Class

Namespace: frxBarcode2DBase
Inheritance Hierarchy
TObject
frxBarcode2DBase.TfrxBarcode2DBase
frxBarcode2DBase.TfrxBarcode2DBaseWithOutUnion
frxBarcode2DBase.TfrxBarcode2DBaseWithUnion
Syntax
Delphi
type
 TfrxBarcode2DBase = class(TObject)
 end;

The TfrxBarcode2DBase type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxBarcode2DBase class.
Destroy | Represents the destructor of the TfrxBarcode2DBase class.
Top
Properties
Show:
Name | Description
Color | Represents property Color.
ColorBar | Represents property ColorBar.
ErrorText | Represents property ErrorText.
Font | Represents property Font.
FontScaled | Represents property FontScaled.
Height | Represents property Height.
PixelHeight | Represents property PixelHeight.
PixelWidth | Represents property PixelWidth.
QuietZone | Represents property QuietZone.
Rotation | Represents property Rotation.
ShowText | Represents property ShowText.
Text | Represents property Text.
Width | Represents property Width.
Zoom | Represents property Zoom.
Top
Methods
Show:
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase).
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer).
FillRect(TCanvas,TRect) | Represents method FillRect(TCanvas,TRect).
GetFooterHeight | Represents method GetFooterHeight.
GetHeight | Represents method GetHeight.
GetWidth | Represents method GetWidth.
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).
IsScaled | Represents method IsScaled.
SetColor(TColor) | Represents method SetColor(TColor).
SetColorBar(TColor) | Represents method SetColorBar(TColor).
SetErrorText(String) | Represents method SetErrorText(String).
SetFont(TFont) | Represents method SetFont(TFont).
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean).
SetHeight(Integer) | Represents method SetHeight(Integer).
SetRotation(Integer) | Represents method SetRotation(Integer).
SetShowText(Boolean) | Represents method SetShowText(Boolean).
SetText(String) | Represents method SetText(String).
SetZoom(Extended) | Represents method SetZoom(Extended).
Top
Fields
Show:
Name | Description
FColor | Represents field FColor.
FColorBar | Represents field FColorBar.
FErrorText | Represents field FErrorText.
FFont | Represents field FFont.
FFontScaled | Represents field FFontScaled.
FHeight | Represents field FHeight.
FPixelHeight | Represents field FPixelHeight.
FPixelWidth | Represents field FPixelWidth.
FQuietZone | Represents field FQuietZone.
FRotation | Represents field FRotation.
FShowText | Represents field FShowText.
FText | Represents field FText.
FWidth | Represents field FWidth.
FZoom | Represents field FZoom.
Top
See Also

Reference

  • frxBarcode2DBase


TfrxBarcode2DBase Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxBarcode2DBase class.
Destroy | Represents the destructor of the TfrxBarcode2DBase class.
Top


TfrxBarcode2DBase.Create Constructor

Summary

Initializes a new instance of the TfrxBarcode2DBase class.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 constructor Create; virtual;
See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.Destroy Destructor

Summary

Represents the destructor of the TfrxBarcode2DBase class.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase Properties

Properties
Name | Description
Color | Represents property Color.
ColorBar | Represents property ColorBar.
ErrorText | Represents property ErrorText.
Font | Represents property Font.
FontScaled | Represents property FontScaled.
Height | Represents property Height.
PixelHeight | Represents property PixelHeight.
PixelWidth | Represents property PixelWidth.
QuietZone | Represents property QuietZone.
Rotation | Represents property Rotation.
ShowText | Represents property ShowText.
Text | Represents property Text.
Width | Represents property Width.
Zoom | Represents property Zoom.
Top


TfrxBarcode2DBase.Color Property

Summary

Represents property Color.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property Color: TColor read FColor write SetColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.ColorBar Property

Summary

Represents property ColorBar.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property ColorBar: TColor read FColorBar write SetColorBar;

Property Value

Type: TColor

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.ErrorText Property

Summary

Represents property ErrorText.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property ErrorText: String read FErrorText write SetErrorText;

Property Value

Type: String

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.Font Property

Summary

Represents property Font.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property Font: TFont read FFont write SetFont;

Property Value

Type: TFont

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FontScaled Property

Summary

Represents property FontScaled.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property FontScaled: Boolean read FFontScaled write SetFontScaled;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.Height Property

Summary

Represents property Height.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property Height: Integer read GetHeight write SetHeight;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.PixelHeight Property

Summary

Represents property PixelHeight.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property PixelHeight: Integer read FPixelHeight write FPixelHeight;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.PixelWidth Property

Summary

Represents property PixelWidth.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property PixelWidth: Integer read FPixelWidth write FPixelWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.QuietZone Property

Summary

Represents property QuietZone.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property QuietZone: Integer read FQuietZone write FQuietZone;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.Rotation Property

Summary

Represents property Rotation.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property Rotation: Integer read FRotation write SetRotation;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.ShowText Property

Summary

Represents property ShowText.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property ShowText: Boolean read FShowText write SetShowText;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.Text Property

Summary

Represents property Text.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property Text: String read FText write SetText;

Property Value

Type: String

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.Width Property

Summary

Represents property Width.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property Width: Integer read GetWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.Zoom Property

Summary

Represents property Zoom.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 property Zoom: Extended read FZoom write SetZoom;

Property Value

Type: Extended

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase Methods

Methods
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase).
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer).
FillRect(TCanvas,TRect) | Represents method FillRect(TCanvas,TRect).
GetFooterHeight | Represents method GetFooterHeight.
GetHeight | Represents method GetHeight.
GetWidth | Represents method GetWidth.
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).
IsScaled | Represents method IsScaled.
SetColor(TColor) | Represents method SetColor(TColor).
SetColorBar(TColor) | Represents method SetColorBar(TColor).
SetErrorText(String) | Represents method SetErrorText(String).
SetFont(TFont) | Represents method SetFont(TFont).
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean).
SetHeight(Integer) | Represents method SetHeight(Integer).
SetRotation(Integer) | Represents method SetRotation(Integer).
SetShowText(Boolean) | Represents method SetShowText(Boolean).
SetText(String) | Represents method SetText(String).
SetZoom(Extended) | Represents method SetZoom(Extended).
Top


TfrxBarcode2DBase.Assign(TfrxBarcode2DBase) Method

Summary

Represents method Assign(TfrxBarcode2DBase).

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 procedure Assign(src: TfrxBarcode2DBase); virtual;

Parameters

src
Type: TfrxBarcode2DBase

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) Method

Summary

Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer).

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 procedure Draw2DBarcode(var g: TCanvas; scalex, scaley: Extended;
 x, y: Integer); virtual;

Parameters

g
Type: TCanvas

scalex
Type: Extended

scaley
Type: Extended

x
Type: Integer

y
Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FillRect(TCanvas,TRect) Method

Summary

Represents method FillRect(TCanvas,TRect).

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 procedure FillRect(Canv: TCanvas; Rect: TRect);

Parameters

Canv
Type: TCanvas

Rect
Type: TRect

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.GetFooterHeight Method

Summary

Represents method GetFooterHeight.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 function GetFooterHeight: Integer; virtual;

Return Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.GetHeight Method

Summary

Represents method GetHeight.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 function GetHeight: Integer; virtual;

Return Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.GetWidth Method

Summary

Represents method GetWidth.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 function GetWidth: Integer; virtual;

Return Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) Method

Summary

Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 procedure InternalDraw(aCanvas: TCanvas; scalex, scaley: Extended;
 x, y, footerHeight, dx, dy, paddingX, paddingY: Integer;
 kx, ky: Extended); virtual;

Parameters

aCanvas
Type: TCanvas

scalex
Type: Extended

scaley
Type: Extended

x
Type: Integer

y
Type: Integer

footerHeight
Type: Integer

dx
Type: Integer

dy
Type: Integer

paddingX
Type: Integer

paddingY
Type: Integer

kx
Type: Extended

ky
Type: Extended

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.IsScaled Method

Summary

Represents method IsScaled.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 function IsScaled: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 procedure SetColor(v: TColor); virtual;

Parameters

v
Type: TColor

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.SetColorBar(TColor) Method

Summary

Represents method SetColorBar(TColor).

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 procedure SetColorBar(v: TColor); virtual;

Parameters

v
Type: TColor

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.SetErrorText(String) Method

Summary

Represents method SetErrorText(String).

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 procedure SetErrorText(v: String); virtual;

Parameters

v
Type: String

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.SetFont(TFont) Method

Summary

Represents method SetFont(TFont).

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 procedure SetFont(v: TFont); virtual;

Parameters

v
Type: TFont

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.SetFontScaled(Boolean) Method

Summary

Represents method SetFontScaled(Boolean).

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 procedure SetFontScaled(v: Boolean); virtual;

Parameters

v
Type: Boolean

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.SetHeight(Integer) Method

Summary

Represents method SetHeight(Integer).

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 procedure SetHeight(const Value: Integer); virtual;

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.SetRotation(Integer) Method

Summary

Represents method SetRotation(Integer).

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 procedure SetRotation(v: Integer); virtual;

Parameters

v
Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.SetShowText(Boolean) Method

Summary

Represents method SetShowText(Boolean).

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 procedure SetShowText(v: Boolean); virtual;

Parameters

v
Type: Boolean

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.SetText(String) Method

Summary

Represents method SetText(String).

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 procedure SetText(v: String); virtual;

Parameters

v
Type: String

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.SetZoom(Extended) Method

Summary

Represents method SetZoom(Extended).

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 procedure SetZoom(v: Extended); virtual;

Parameters

v
Type: Extended

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase Fields

Fields
Name | Description
FColor | Represents field FColor.
FColorBar | Represents field FColorBar.
FErrorText | Represents field FErrorText.
FFont | Represents field FFont.
FFontScaled | Represents field FFontScaled.
FHeight | Represents field FHeight.
FPixelHeight | Represents field FPixelHeight.
FPixelWidth | Represents field FPixelWidth.
FQuietZone | Represents field FQuietZone.
FRotation | Represents field FRotation.
FShowText | Represents field FShowText.
FText | Represents field FText.
FWidth | Represents field FWidth.
FZoom | Represents field FZoom.
Top


TfrxBarcode2DBase.FColor Field

Summary

Represents field FColor.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FColorBar Field

Summary

Represents field FColorBar.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FColorBar: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FErrorText Field

Summary

Represents field FErrorText.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FErrorText: String;

Field Value

Type: String

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FFont Field

Summary

Represents field FFont.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FFont: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FFontScaled Field

Summary

Represents field FFontScaled.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FFontScaled: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FHeight Field

Summary

Represents field FHeight.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FPixelHeight Field

Summary

Represents field FPixelHeight.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FPixelHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FPixelWidth Field

Summary

Represents field FPixelWidth.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FPixelWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FQuietZone Field

Summary

Represents field FQuietZone.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FQuietZone: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FRotation Field

Summary

Represents field FRotation.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FRotation: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FShowText Field

Summary

Represents field FShowText.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FShowText: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FText Field

Summary

Represents field FText.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FText: String;

Field Value

Type: String

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FWidth Field

Summary

Represents field FWidth.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBase.FZoom Field

Summary

Represents field FZoom.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxBarcode2DBase
  • frxBarcode2DBase


TfrxBarcode2DBaseWithOutUnion Class

Summary

Represents type TfrxBarcode2DBaseWithOutUnion.

Namespace: frxBarcode2DBase
Inheritance Hierarchy
TObject
frxBarcode2DBase.TfrxBarcode2DBase
frxBarcode2DBase.TfrxBarcode2DBaseWithOutUnion
frxBarcodeMaxiCode.TfrxBarcodeMaxiCode
Syntax
Delphi
type
 TfrxBarcode2DBaseWithOutUnion = class(TfrxBarcode2DBase)
 end;

The TfrxBarcode2DBaseWithOutUnion type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxBarcode2DBaseWithOutUnion class. (Overrides TfrxBarcode2DBase.Create.)
Destroy | Represents the destructor of the TfrxBarcode2DBaseWithOutUnion class. (Overrides TfrxBarcode2DBase.Destroy.)
Top
Properties
Show:
Name | Description
Color | Represents property Color. (Inherited from TfrxBarcode2DBase.)
ColorBar | Represents property ColorBar. (Inherited from TfrxBarcode2DBase.)
ErrorText | Represents property ErrorText. (Inherited from TfrxBarcode2DBase.)
Font | Represents property Font. (Inherited from TfrxBarcode2DBase.)
FontScaled | Represents property FontScaled. (Inherited from TfrxBarcode2DBase.)
Height | Represents property Height. (Inherited from TfrxBarcode2DBase.)
PixelHeight | Represents property PixelHeight. (Inherited from TfrxBarcode2DBase.)
PixelWidth | Represents property PixelWidth. (Inherited from TfrxBarcode2DBase.)
QuietZone | Represents property QuietZone. (Inherited from TfrxBarcode2DBase.)
Rotation | Represents property Rotation. (Inherited from TfrxBarcode2DBase.)
ShowText | Represents property ShowText. (Inherited from TfrxBarcode2DBase.)
Text | Represents property Text. (Inherited from TfrxBarcode2DBase.)
Width | Represents property Width. (Inherited from TfrxBarcode2DBase.)
Zoom | Represents property Zoom. (Inherited from TfrxBarcode2DBase.)
Top
Methods
Show:
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Inherited from TfrxBarcode2DBase.)
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer). (Inherited from TfrxBarcode2DBase.)
FillRect(TCanvas,TRect) | Represents method FillRect(TCanvas,TRect). (Inherited from TfrxBarcode2DBase.)
GetFooterHeight | Represents method GetFooterHeight. (Inherited from TfrxBarcode2DBase.)
GetHeight | Represents method GetHeight. (Inherited from TfrxBarcode2DBase.)
GetWidth | Represents method GetWidth. (Inherited from TfrxBarcode2DBase.)
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended). (Overrides TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).)
IsScaled | Represents method IsScaled. (Inherited from TfrxBarcode2DBase.)
SetColor(TColor) | Represents method SetColor(TColor). (Inherited from TfrxBarcode2DBase.)
SetColorBar(TColor) | Represents method SetColorBar(TColor). (Inherited from TfrxBarcode2DBase.)
SetErrorText(String) | Represents method SetErrorText(String). (Inherited from TfrxBarcode2DBase.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxBarcode2DBase.)
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean). (Inherited from TfrxBarcode2DBase.)
SetHeight(Integer) | Represents method SetHeight(Integer). (Inherited from TfrxBarcode2DBase.)
SetRotation(Integer) | Represents method SetRotation(Integer). (Inherited from TfrxBarcode2DBase.)
SetShowText(Boolean) | Represents method SetShowText(Boolean). (Inherited from TfrxBarcode2DBase.)
SetText(String) | Represents method SetText(String). (Inherited from TfrxBarcode2DBase.)
SetZoom(Extended) | Represents method SetZoom(Extended). (Inherited from TfrxBarcode2DBase.)
Top
Fields
Show:
Name | Description
FColor | Represents field FColor. (Inherited from TfrxBarcode2DBase.)
FColorBar | Represents field FColorBar. (Inherited from TfrxBarcode2DBase.)
FErrorText | Represents field FErrorText. (Inherited from TfrxBarcode2DBase.)
FFont | Represents field FFont. (Inherited from TfrxBarcode2DBase.)
FFontScaled | Represents field FFontScaled. (Inherited from TfrxBarcode2DBase.)
FHeight | Represents field FHeight. (Inherited from TfrxBarcode2DBase.)
FImage | Represents field FImage.
FPixelHeight | Represents field FPixelHeight. (Inherited from TfrxBarcode2DBase.)
FPixelWidth | Represents field FPixelWidth. (Inherited from TfrxBarcode2DBase.)
FQuietZone | Represents field FQuietZone. (Inherited from TfrxBarcode2DBase.)
FRotation | Represents field FRotation. (Inherited from TfrxBarcode2DBase.)
FShowText | Represents field FShowText. (Inherited from TfrxBarcode2DBase.)
FText | Represents field FText. (Inherited from TfrxBarcode2DBase.)
FWidth | Represents field FWidth. (Inherited from TfrxBarcode2DBase.)
FZoom | Represents field FZoom. (Inherited from TfrxBarcode2DBase.)
Top
See Also

Reference

  • frxBarcode2DBase


TfrxBarcode2DBaseWithOutUnion Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxBarcode2DBaseWithOutUnion class. (Overrides TfrxBarcode2DBase.Create.)
Destroy | Represents the destructor of the TfrxBarcode2DBaseWithOutUnion class. (Overrides TfrxBarcode2DBase.Destroy.)
Top


TfrxBarcode2DBaseWithOutUnion.Create Constructor

Summary

Initializes a new instance of the TfrxBarcode2DBaseWithOutUnion class.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 constructor Create; override;

Overrides

TfrxBarcode2DBase.Create
See Also

Reference

  • TfrxBarcode2DBaseWithOutUnion
  • frxBarcode2DBase


TfrxBarcode2DBaseWithOutUnion.Destroy Destructor

Summary

Represents the destructor of the TfrxBarcode2DBaseWithOutUnion class.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxBarcode2DBase.Destroy
See Also

Reference

  • TfrxBarcode2DBaseWithOutUnion
  • frxBarcode2DBase


TfrxBarcode2DBaseWithOutUnion Methods

Methods
Name | Description
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended). (Overrides TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).)
Top


TfrxBarcode2DBaseWithOutUnion.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) Method

Summary

Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 procedure InternalDraw(aCanvas: TCanvas; scalex, scaley: Extended;
 x, y, footerHeight, dx, dy, paddingX, paddingY: Integer;
 kx, ky: Extended); override;

Parameters

aCanvas
Type: TCanvas

scalex
Type: Extended

scaley
Type: Extended

x
Type: Integer

y
Type: Integer

footerHeight
Type: Integer

dx
Type: Integer

dy
Type: Integer

paddingX
Type: Integer

paddingY
Type: Integer

kx
Type: Extended

ky
Type: Extended

Overrides

TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended)
See Also

Reference

  • TfrxBarcode2DBaseWithOutUnion
  • frxBarcode2DBase


TfrxBarcode2DBaseWithOutUnion Fields

Fields
Name | Description
FImage | Represents field FImage.
Top


TfrxBarcode2DBaseWithOutUnion.FImage Field

Summary

Represents field FImage.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FImage: array of Byte;

Field Value

Type: array of Byte

See Also

Reference

  • TfrxBarcode2DBaseWithOutUnion
  • frxBarcode2DBase


TfrxBarcode2DBaseWithUnion Class

Summary

Represents type TfrxBarcode2DBaseWithUnion.

Namespace: frxBarcode2DBase
Inheritance Hierarchy
TObject
frxBarcode2DBase.TfrxBarcode2DBase
frxBarcode2DBase.TfrxBarcode2DBaseWithUnion
frxBarcodeAztec.TfrxBarcodeAztec
frxBarcodeDataMatrix.TfrxBarcodeDataMatrix
frxBarcodePDF417.TfrxBarcodePDF417
frxBarcodeQR.TfrxBarcodeQR
frxGS1Databar.TfrxGS1Databar
Syntax
Delphi
type
 TfrxBarcode2DBaseWithUnion = class(TfrxBarcode2DBase)
 end;

The TfrxBarcode2DBaseWithUnion type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxBarcode2DBaseWithUnion class. (Overrides TfrxBarcode2DBase.Create.)
Destroy | Represents the destructor of the TfrxBarcode2DBaseWithUnion class. (Overrides TfrxBarcode2DBase.Destroy.)
Top
Properties
Show:
Name | Description
Color | Represents property Color. (Inherited from TfrxBarcode2DBase.)
ColorBar | Represents property ColorBar. (Inherited from TfrxBarcode2DBase.)
ErrorText | Represents property ErrorText. (Inherited from TfrxBarcode2DBase.)
Font | Represents property Font. (Inherited from TfrxBarcode2DBase.)
FontScaled | Represents property FontScaled. (Inherited from TfrxBarcode2DBase.)
Height | Represents property Height. (Inherited from TfrxBarcode2DBase.)
PixelHeight | Represents property PixelHeight. (Inherited from TfrxBarcode2DBase.)
PixelWidth | Represents property PixelWidth. (Inherited from TfrxBarcode2DBase.)
QuietZone | Represents property QuietZone. (Inherited from TfrxBarcode2DBase.)
Rotation | Represents property Rotation. (Inherited from TfrxBarcode2DBase.)
ShowText | Represents property ShowText. (Inherited from TfrxBarcode2DBase.)
Text | Represents property Text. (Inherited from TfrxBarcode2DBase.)
Width | Represents property Width. (Inherited from TfrxBarcode2DBase.)
Zoom | Represents property Zoom. (Inherited from TfrxBarcode2DBase.)
Top
Methods
Show:
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Inherited from TfrxBarcode2DBase.)
ClearFigures | Represents method ClearFigures.
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer). (Inherited from TfrxBarcode2DBase.)
FillRect(TCanvas,TRect) | Represents method FillRect(TCanvas,TRect). (Inherited from TfrxBarcode2DBase.)
FVectorPrimitivesAdd(Integer,Integer,Integer,Integer) | Represents method FVectorPrimitivesAdd(Integer,Integer,Integer,Integer).
GetFooterHeight | Represents method GetFooterHeight. (Inherited from TfrxBarcode2DBase.)
GetHeight | Represents method GetHeight. (Inherited from TfrxBarcode2DBase.)
GetWidth | Represents method GetWidth. (Inherited from TfrxBarcode2DBase.)
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended). (Overrides TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).)
IsScaled | Represents method IsScaled. (Inherited from TfrxBarcode2DBase.)
SetColor(TColor) | Represents method SetColor(TColor). (Inherited from TfrxBarcode2DBase.)
SetColorBar(TColor) | Represents method SetColorBar(TColor). (Inherited from TfrxBarcode2DBase.)
SetErrorText(String) | Represents method SetErrorText(String). (Inherited from TfrxBarcode2DBase.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxBarcode2DBase.)
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean). (Inherited from TfrxBarcode2DBase.)
SetHeight(Integer) | Represents method SetHeight(Integer). (Inherited from TfrxBarcode2DBase.)
SetRotation(Integer) | Represents method SetRotation(Integer). (Inherited from TfrxBarcode2DBase.)
SetShowText(Boolean) | Represents method SetShowText(Boolean). (Inherited from TfrxBarcode2DBase.)
SetText(String) | Represents method SetText(String). (Inherited from TfrxBarcode2DBase.)
SetZoom(Extended) | Represents method SetZoom(Extended). (Inherited from TfrxBarcode2DBase.)
T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte) | Represents method T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte).
Top
Fields
Show:
Name | Description
DotsL | Represents field DotsL.
DotsR | Represents field DotsR.
FColor | Represents field FColor. (Inherited from TfrxBarcode2DBase.)
FColorBar | Represents field FColorBar. (Inherited from TfrxBarcode2DBase.)
FErrorText | Represents field FErrorText. (Inherited from TfrxBarcode2DBase.)
FFont | Represents field FFont. (Inherited from TfrxBarcode2DBase.)
FFontScaled | Represents field FFontScaled. (Inherited from TfrxBarcode2DBase.)
FHeight | Represents field FHeight. (Inherited from TfrxBarcode2DBase.)
FPixelHeight | Represents field FPixelHeight. (Inherited from TfrxBarcode2DBase.)
FPixelWidth | Represents field FPixelWidth. (Inherited from TfrxBarcode2DBase.)
FQuietZone | Represents field FQuietZone. (Inherited from TfrxBarcode2DBase.)
FRotation | Represents field FRotation. (Inherited from TfrxBarcode2DBase.)
FShowText | Represents field FShowText. (Inherited from TfrxBarcode2DBase.)
FText | Represents field FText. (Inherited from TfrxBarcode2DBase.)
FVectorPrimitives | Represents field FVectorPrimitives.
FWidth | Represents field FWidth. (Inherited from TfrxBarcode2DBase.)
FZoom | Represents field FZoom. (Inherited from TfrxBarcode2DBase.)
Top
See Also

Reference

  • frxBarcode2DBase


TfrxBarcode2DBaseWithUnion Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxBarcode2DBaseWithUnion class. (Overrides TfrxBarcode2DBase.Create.)
Destroy | Represents the destructor of the TfrxBarcode2DBaseWithUnion class. (Overrides TfrxBarcode2DBase.Destroy.)
Top


TfrxBarcode2DBaseWithUnion.Create Constructor

Summary

Initializes a new instance of the TfrxBarcode2DBaseWithUnion class.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 constructor Create; override;

Overrides

TfrxBarcode2DBase.Create
See Also

Reference

  • TfrxBarcode2DBaseWithUnion
  • frxBarcode2DBase


TfrxBarcode2DBaseWithUnion.Destroy Destructor

Summary

Represents the destructor of the TfrxBarcode2DBaseWithUnion class.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxBarcode2DBase.Destroy
See Also

Reference

  • TfrxBarcode2DBaseWithUnion
  • frxBarcode2DBase


TfrxBarcode2DBaseWithUnion Methods

Methods
Name | Description
ClearFigures | Represents method ClearFigures.
FVectorPrimitivesAdd(Integer,Integer,Integer,Integer) | Represents method FVectorPrimitivesAdd(Integer,Integer,Integer,Integer).
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended). (Overrides TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).)
T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte) | Represents method T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte).
Top


TfrxBarcode2DBaseWithUnion.ClearFigures Method

Summary

Represents method ClearFigures.

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 procedure ClearFigures();
See Also

Reference

  • TfrxBarcode2DBaseWithUnion
  • frxBarcode2DBase


TfrxBarcode2DBaseWithUnion.FVectorPrimitivesAdd(Integer,Integer,Integer,Integer) Method

Summary

Represents method FVectorPrimitivesAdd(Integer,Integer,Integer,Integer).

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 procedure FVectorPrimitivesAdd(ALeft, ATop, AWidth, AHeight: Integer);

Parameters

ALeft
Type: Integer

ATop
Type: Integer

AWidth
Type: Integer

AHeight
Type: Integer

See Also

Reference

  • TfrxBarcode2DBaseWithUnion
  • frxBarcode2DBase


TfrxBarcode2DBaseWithUnion.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) Method

Summary

Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 procedure InternalDraw(aCanvas: TCanvas; scalex, scaley: Extended;
 x, y, footerHeight, dx, dy, paddingX, paddingY: Integer;
 kx, ky: Extended); override;

Parameters

aCanvas
Type: TCanvas

scalex
Type: Extended

scaley
Type: Extended

x
Type: Integer

y
Type: Integer

footerHeight
Type: Integer

dx
Type: Integer

dy
Type: Integer

paddingX
Type: Integer

paddingY
Type: Integer

kx
Type: Extended

ky
Type: Extended

Overrides

TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended)
See Also

Reference

  • TfrxBarcode2DBaseWithUnion
  • frxBarcode2DBase


TfrxBarcode2DBaseWithUnion.T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte) Method

Summary

Represents method T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte).

Namespace: frxBarcode2DBase
Syntax
Delphi
public
 procedure T2DBooleanArrayToVectorPrimitives(GlArr: T2DBooleanArray; x, y: Byte; QuietZone: Byte = 0);

Parameters

GlArr
Type: T2DBooleanArray

x
Type: Byte

y
Type: Byte

QuietZone
Type: Byte

See Also

Reference

  • TfrxBarcode2DBaseWithUnion
  • frxBarcode2DBase


TfrxBarcode2DBaseWithUnion Fields

Fields
Name | Description
DotsL | Represents field DotsL.
DotsR | Represents field DotsR.
FVectorPrimitives | Represents field FVectorPrimitives.
Top


TfrxBarcode2DBaseWithUnion.DotsL Field

Summary

Represents field DotsL.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 DotsR, DotsL: array of Byte;

Field Value

Type: array of Byte

See Also

Reference

  • TfrxBarcode2DBaseWithUnion
  • frxBarcode2DBase


TfrxBarcode2DBaseWithUnion.DotsR Field

Summary

Represents field DotsR.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 DotsR, DotsL: array of Byte;

Field Value

Type: array of Byte

See Also

Reference

  • TfrxBarcode2DBaseWithUnion
  • frxBarcode2DBase


TfrxBarcode2DBaseWithUnion.FVectorPrimitives Field

Summary

Represents field FVectorPrimitives.

Namespace: frxBarcode2DBase
Syntax
Delphi
protected
 FVectorPrimitives: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxBarcode2DBaseWithUnion
  • frxBarcode2DBase


frxBarcode2DBase Types

Types
Name | Description
T2DBooleanArray | Represents an array of the type.
Top


T2DBooleanArray Type

Summary

Represents an array of the type.

Namespace: frxBarcode2DBase
Syntax
Delphi
type
 T2DBooleanArray = array of array of Boolean;
See Also

Reference

  • frxBarcode2DBase


frxBarcode2DBase Constants

Constants
Name | Description
cbDefaultText | Represents constant cbDefaultText.
Top


cbDefaultText Constant

Summary

Represents constant cbDefaultText.

Namespace: frxBarcode2DBase
Syntax
Delphi
 cbDefaultText = '12345678';

Value

Type: string

See Also

Reference

  • frxBarcode2DBase


frxBarcodeAztec Namespace

Summary

Represents namespace frxBarcodeAztec.

Classes
Name | Description
TfrxBarcodeAztec | Represents type TfrxBarcodeAztec.
Top


frxBarcodeAztec Classes

Classes
Name | Description
TfrxBarcodeAztec | Represents type TfrxBarcodeAztec.
Top


TfrxBarcodeAztec Class

Summary

Represents type TfrxBarcodeAztec.

Namespace: frxBarcodeAztec
Inheritance Hierarchy
TObject
frxBarcode2DBase.TfrxBarcode2DBase
frxBarcode2DBase.TfrxBarcode2DBaseWithUnion
frxBarcodeAztec.TfrxBarcodeAztec
Syntax
Delphi
type
 TfrxBarcodeAztec = class(TfrxBarcode2DBaseWithUnion)
 end;

The TfrxBarcodeAztec type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxBarcodeAztec class. (Overrides TfrxBarcode2DBaseWithUnion.Create.)
Destroy | Represents the destructor of the TfrxBarcodeAztec class. (Overrides TfrxBarcode2DBaseWithUnion.Destroy.)
Top
Properties
Show:
Name | Description
Color | Represents property Color. (Inherited from TfrxBarcode2DBase.)
ColorBar | Represents property ColorBar. (Inherited from TfrxBarcode2DBase.)
ErrorText | Represents property ErrorText. (Inherited from TfrxBarcode2DBase.)
Font | Represents property Font. (Inherited from TfrxBarcode2DBase.)
FontScaled | Represents property FontScaled. (Inherited from TfrxBarcode2DBase.)
Height | Represents property Height. (Inherited from TfrxBarcode2DBase.)
MinECCPercent | Represents property MinECCPercent.
PixelHeight | Represents property PixelHeight. (Inherited from TfrxBarcode2DBase.)
PixelSize | Represents property PixelSize.
PixelWidth | Represents property PixelWidth. (Inherited from TfrxBarcode2DBase.)
QuietZone | Represents property QuietZone. (Inherited from TfrxBarcode2DBase.)
Rotation | Represents property Rotation. (Inherited from TfrxBarcode2DBase.)
ShowText | Represents property ShowText. (Inherited from TfrxBarcode2DBase.)
Text | Represents property Text. (Inherited from TfrxBarcode2DBase.)
Width | Represents property Width. (Inherited from TfrxBarcode2DBase.)
Zoom | Represents property Zoom. (Inherited from TfrxBarcode2DBase.)
Top
Methods
Show:
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
ClearFigures | Represents method ClearFigures. (Inherited from TfrxBarcode2DBaseWithUnion.)
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer). (Inherited from TfrxBarcode2DBase.)
FillRect(TCanvas,TRect) | Represents method FillRect(TCanvas,TRect). (Inherited from TfrxBarcode2DBase.)
FVectorPrimitivesAdd(Integer,Integer,Integer,Integer) | Represents method FVectorPrimitivesAdd(Integer,Integer,Integer,Integer). (Inherited from TfrxBarcode2DBaseWithUnion.)
Generate | Represents method Generate.
GetFooterHeight | Represents method GetFooterHeight. (Inherited from TfrxBarcode2DBase.)
GetHeight | Represents method GetHeight. (Inherited from TfrxBarcode2DBase.)
GetMinECCPercent | Represents method GetMinECCPercent.
GetPixelSize | Represents method GetPixelSize.
GetWidth | Represents method GetWidth. (Inherited from TfrxBarcode2DBase.)
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended). (Overrides TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).)
IsScaled | Represents method IsScaled. (Inherited from TfrxBarcode2DBase.)
SetColor(TColor) | Represents method SetColor(TColor). (Inherited from TfrxBarcode2DBase.)
SetColorBar(TColor) | Represents method SetColorBar(TColor). (Inherited from TfrxBarcode2DBase.)
SetErrorText(String) | Represents method SetErrorText(String). (Inherited from TfrxBarcode2DBase.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxBarcode2DBase.)
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean). (Inherited from TfrxBarcode2DBase.)
SetHeight(Integer) | Represents method SetHeight(Integer). (Inherited from TfrxBarcode2DBase.)
SetMinECCPercent(integer) | Represents method SetMinECCPercent(integer).
SetPixelSize(integer) | Represents method SetPixelSize(integer).
SetRotation(Integer) | Represents method SetRotation(Integer). (Inherited from TfrxBarcode2DBase.)
SetShowText(Boolean) | Represents method SetShowText(Boolean). (Inherited from TfrxBarcode2DBase.)
SetText(string) | Represents method SetText(string). (Overrides TfrxBarcode2DBase.SetText(String).)
SetZoom(Extended) | Represents method SetZoom(Extended). (Inherited from TfrxBarcode2DBase.)
T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte) | Represents method T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte). (Inherited from TfrxBarcode2DBaseWithUnion.)
Top
Fields
Show:
Name | Description
DotsL | Represents field DotsL. (Inherited from TfrxBarcode2DBaseWithUnion.)
DotsR | Represents field DotsR. (Inherited from TfrxBarcode2DBaseWithUnion.)
FAztecEncoder | Represents field FAztecEncoder.
FColor | Represents field FColor. (Inherited from TfrxBarcode2DBase.)
FColorBar | Represents field FColorBar. (Inherited from TfrxBarcode2DBase.)
FErrorText | Represents field FErrorText. (Inherited from TfrxBarcode2DBase.)
FFont | Represents field FFont. (Inherited from TfrxBarcode2DBase.)
FFontScaled | Represents field FFontScaled. (Inherited from TfrxBarcode2DBase.)
FHeight | Represents field FHeight. (Inherited from TfrxBarcode2DBase.)
FPixelHeight | Represents field FPixelHeight. (Inherited from TfrxBarcode2DBase.)
FPixelWidth | Represents field FPixelWidth. (Inherited from TfrxBarcode2DBase.)
FQuietZone | Represents field FQuietZone. (Inherited from TfrxBarcode2DBase.)
FRotation | Represents field FRotation. (Inherited from TfrxBarcode2DBase.)
FShowText | Represents field FShowText. (Inherited from TfrxBarcode2DBase.)
FText | Represents field FText. (Inherited from TfrxBarcode2DBase.)
FVectorPrimitives | Represents field FVectorPrimitives. (Inherited from TfrxBarcode2DBaseWithUnion.)
FWidth | Represents field FWidth. (Inherited from TfrxBarcode2DBase.)
FZoom | Represents field FZoom. (Inherited from TfrxBarcode2DBase.)
Top
See Also

Reference

  • frxBarcodeAztec


TfrxBarcodeAztec Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxBarcodeAztec class. (Overrides TfrxBarcode2DBaseWithUnion.Create.)
Destroy | Represents the destructor of the TfrxBarcodeAztec class. (Overrides TfrxBarcode2DBaseWithUnion.Destroy.)
Top


TfrxBarcodeAztec.Create Constructor

Summary

Initializes a new instance of the TfrxBarcodeAztec class.

Namespace: frxBarcodeAztec
Syntax
Delphi
public
 constructor Create; override;

Overrides

TfrxBarcode2DBaseWithUnion.Create
See Also

Reference

  • TfrxBarcodeAztec
  • frxBarcodeAztec


TfrxBarcodeAztec.Destroy Destructor

Summary

Represents the destructor of the TfrxBarcodeAztec class.

Namespace: frxBarcodeAztec
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxBarcode2DBaseWithUnion.Destroy
See Also

Reference

  • TfrxBarcodeAztec
  • frxBarcodeAztec


TfrxBarcodeAztec Properties

Properties
Name | Description
MinECCPercent | Represents property MinECCPercent.
PixelSize | Represents property PixelSize.
Top


TfrxBarcodeAztec.MinECCPercent Property

Summary

Represents property MinECCPercent.

Namespace: frxBarcodeAztec
Syntax
Delphi
published
 property MinECCPercent: integer read GetMinECCPercent
 write SetMinECCPercent;

Property Value

Type: integer

See Also

Reference

  • TfrxBarcodeAztec
  • frxBarcodeAztec


TfrxBarcodeAztec.PixelSize Property

Summary

Represents property PixelSize.

Namespace: frxBarcodeAztec
Syntax
Delphi
published
 property PixelSize: integer read GetPixelSize write SetPixelSize;

Property Value

Type: integer

See Also

Reference

  • TfrxBarcodeAztec
  • frxBarcodeAztec


TfrxBarcodeAztec Methods

Methods
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
Generate | Represents method Generate.
GetMinECCPercent | Represents method GetMinECCPercent.
GetPixelSize | Represents method GetPixelSize.
SetMinECCPercent(integer) | Represents method SetMinECCPercent(integer).
SetPixelSize(integer) | Represents method SetPixelSize(integer).
SetText(string) | Represents method SetText(string). (Overrides TfrxBarcode2DBase.SetText(String).)
Top


TfrxBarcodeAztec.Assign(TfrxBarcode2DBase) Method

Summary

Represents method Assign(TfrxBarcode2DBase).

Namespace: frxBarcodeAztec
Syntax
Delphi
public
 procedure Assign(src: TfrxBarcode2DBase); override;

Parameters

src
Type: TfrxBarcode2DBase

Overrides

TfrxBarcode2DBase.Assign(TfrxBarcode2DBase)
See Also

Reference

  • TfrxBarcodeAztec
  • frxBarcodeAztec


TfrxBarcodeAztec.Generate Method

Summary

Represents method Generate.

Namespace: frxBarcodeAztec
Syntax
Delphi
protected
 procedure Generate;
See Also

Reference

  • TfrxBarcodeAztec
  • frxBarcodeAztec


TfrxBarcodeAztec.GetMinECCPercent Method

Summary

Represents method GetMinECCPercent.

Namespace: frxBarcodeAztec
Syntax
Delphi
private
 function GetMinECCPercent: integer;

Return Value

Type: integer

See Also

Reference

  • TfrxBarcodeAztec
  • frxBarcodeAztec


TfrxBarcodeAztec.GetPixelSize Method

Summary

Represents method GetPixelSize.

Namespace: frxBarcodeAztec
Syntax
Delphi
private
 function GetPixelSize: integer;

Return Value

Type: integer

See Also

Reference

  • TfrxBarcodeAztec
  • frxBarcodeAztec


TfrxBarcodeAztec.SetMinECCPercent(integer) Method

Summary

Represents method SetMinECCPercent(integer).

Namespace: frxBarcodeAztec
Syntax
Delphi
private
 procedure SetMinECCPercent(const Value: integer);

Parameters

Value
Type: integer

See Also

Reference

  • TfrxBarcodeAztec
  • frxBarcodeAztec


TfrxBarcodeAztec.SetPixelSize(integer) Method

Summary

Represents method SetPixelSize(integer).

Namespace: frxBarcodeAztec
Syntax
Delphi
private
 procedure SetPixelSize(const Value: integer);

Parameters

Value
Type: integer

See Also

Reference

  • TfrxBarcodeAztec
  • frxBarcodeAztec


TfrxBarcodeAztec.SetText(string) Method

Summary

Represents method SetText(string).

Namespace: frxBarcodeAztec
Syntax
Delphi
protected
 procedure SetText(v: string); override;

Parameters

v
Type: string

Overrides

TfrxBarcode2DBase.SetText(String)
See Also

Reference

  • TfrxBarcodeAztec
  • frxBarcodeAztec


TfrxBarcodeAztec Fields

Fields
Name | Description
FAztecEncoder | Represents field FAztecEncoder.
Top


TfrxBarcodeAztec.FAztecEncoder Field

Summary

Represents field FAztecEncoder.

Namespace: frxBarcodeAztec
Syntax
Delphi
protected
 FAztecEncoder: TAztecEncoder;

Field Value

Type: TAztecEncoder

See Also

Reference

  • TfrxBarcodeAztec
  • frxBarcodeAztec


frxBarcodeDataMatrix Namespace

Summary

Represents namespace frxBarcodeDataMatrix.

Classes
Name | Description
TfrxBarcodeDataMatrix | Represents type TfrxBarcodeDataMatrix.
Top
Records
Name | Description
DmParams | Represents type DmParams.
SizeF | Represents type SizeF.
Top
Enumerations
Name | Description
DatamatrixEncoding | Represents type DatamatrixEncoding.
DatamatrixSymbolSize | Represents type DatamatrixSymbolSize.
Top
Types
Name | Description
TInts | Represents an array of the integer type.
Top
Constants
Name | Description
alog | Represents constant alog.
cbDefaultText | Represents constant cbDefaultText.
dmSizes | Represents constant dmSizes.
log | Represents constant log.
poly10 | Represents constant poly10.
poly11 | Represents constant poly11.
poly12 | Represents constant poly12.
poly14 | Represents constant poly14.
poly18 | Represents constant poly18.
poly20 | Represents constant poly20.
poly24 | Represents constant poly24.
poly28 | Represents constant poly28.
poly36 | Represents constant poly36.
poly42 | Represents constant poly42.
poly48 | Represents constant poly48.
poly5 | Represents constant poly5.
poly56 | Represents constant poly56.
poly62 | Represents constant poly62.
poly68 | Represents constant poly68.
poly7 | Represents constant poly7.
_x12 | Represents constant _x12.
Top
Routines
Name | Description
GenerateECC(byte[],integer,integer,integer) | Represents method GenerateECC(byte[],integer,integer,integer).
Top


frxBarcodeDataMatrix Classes

Classes
Name | Description
TfrxBarcodeDataMatrix | Represents type TfrxBarcodeDataMatrix.
Top


TfrxBarcodeDataMatrix Class

Summary

Represents type TfrxBarcodeDataMatrix.

Namespace: frxBarcodeDataMatrix
Inheritance Hierarchy
TObject
frxBarcode2DBase.TfrxBarcode2DBase
frxBarcode2DBase.TfrxBarcode2DBaseWithUnion
frxBarcodeDataMatrix.TfrxBarcodeDataMatrix
Syntax
Delphi
type
TfrxBarcodeDataMatrix = class( TfrxBarcode2DBaseWithUnion )
end;

The TfrxBarcodeDataMatrix type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxBarcodeDataMatrix class. (Overrides TfrxBarcode2DBaseWithUnion.Create.)
Destroy | Represents the destructor of the TfrxBarcodeDataMatrix class. (Overrides TfrxBarcode2DBaseWithUnion.Destroy.)
Top
Properties
Show:
Name | Description
CodePage | Represents property CodePage.
Color | Represents property Color. (Inherited from TfrxBarcode2DBase.)
ColorBar | Represents property ColorBar. (Inherited from TfrxBarcode2DBase.)
Encoding | Represents property Encoding.
ErrorText | Represents property ErrorText. (Inherited from TfrxBarcode2DBase.)
Font | Represents property Font. (Inherited from TfrxBarcode2DBase.)
FontScaled | Represents property FontScaled. (Inherited from TfrxBarcode2DBase.)
GS1Rule | Represents property GS1Rule.
Height | Represents property Height. (Inherited from TfrxBarcode2DBase.)
PixelHeight | Represents property PixelHeight. (Inherited from TfrxBarcode2DBase.)
PixelSize | Represents property PixelSize.
PixelWidth | Represents property PixelWidth. (Inherited from TfrxBarcode2DBase.)
QuietZone | Represents property QuietZone. (Inherited from TfrxBarcode2DBase.)
Rotation | Represents property Rotation. (Inherited from TfrxBarcode2DBase.)
ShowText | Represents property ShowText. (Inherited from TfrxBarcode2DBase.)
SymbolSize | Represents property SymbolSize.
Text | Represents property Text. (Inherited from TfrxBarcode2DBase.)
Width | Represents property Width. (Inherited from TfrxBarcode2DBase.)
Zoom | Represents property Zoom. (Inherited from TfrxBarcode2DBase.)
Top
Methods
Show:
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
ClearFigures | Represents method ClearFigures. (Inherited from TfrxBarcode2DBaseWithUnion.)
Draw(byte[],integer,DmParams) | Represents method Draw(byte[],integer,DmParams).
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer). (Inherited from TfrxBarcode2DBase.)
Ecc200 | Represents method Ecc200.
FillRect(TCanvas,TRect) | Represents method FillRect(TCanvas,TRect). (Inherited from TfrxBarcode2DBase.)
FVectorPrimitivesAdd(Integer,Integer,Integer,Integer) | Represents method FVectorPrimitivesAdd(Integer,Integer,Integer,Integer). (Inherited from TfrxBarcode2DBaseWithUnion.)
Generate(byte[],integer,integer) | Overloaded. Represents method Generate(byte[],integer,integer).
Generate(string) | Overloaded. Represents method Generate(string).
GetEncodation(byte[],integer,integer,byte[],integer,integer,boolean) | Represents method GetEncodation(byte[],integer,integer,byte[],integer,integer,boolean).
GetFooterHeight | Represents method GetFooterHeight. (Inherited from TfrxBarcode2DBase.)
GetHeight | Represents method GetHeight. (Inherited from TfrxBarcode2DBase.)
GetPixelSize | Represents method GetPixelSize.
GetWidth | Represents method GetWidth. (Inherited from TfrxBarcode2DBase.)
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended). (Overrides TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).)
IsScaled | Represents method IsScaled. (Inherited from TfrxBarcode2DBase.)
SetBit(integer,integer) | Represents method SetBit(integer,integer).
SetCodePage(integer) | Represents method SetCodePage(integer).
SetColor(TColor) | Represents method SetColor(TColor). (Inherited from TfrxBarcode2DBase.)
SetColorBar(TColor) | Represents method SetColorBar(TColor). (Inherited from TfrxBarcode2DBase.)
SetEncoding(DatamatrixEncoding) | Represents method SetEncoding(DatamatrixEncoding).
SetErrorText(String) | Represents method SetErrorText(String). (Inherited from TfrxBarcode2DBase.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxBarcode2DBase.)
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean). (Inherited from TfrxBarcode2DBase.)
SetGS1Rule(Boolean) | Represents method SetGS1Rule(Boolean).
SetHeight(Integer) | Represents method SetHeight(Integer). (Inherited from TfrxBarcode2DBase.)
SetPixelSize(integer) | Represents method SetPixelSize(integer).
SetRotation(Integer) | Represents method SetRotation(Integer). (Inherited from TfrxBarcode2DBase.)
SetShowText(Boolean) | Represents method SetShowText(Boolean). (Inherited from TfrxBarcode2DBase.)
SetSymbolSize(DatamatrixSymbolSize) | Represents method SetSymbolSize(DatamatrixSymbolSize).
SetText(string) | Represents method SetText(string). (Overrides TfrxBarcode2DBase.SetText(String).)
SetZoom(Extended) | Represents method SetZoom(Extended). (Inherited from TfrxBarcode2DBase.)
T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte) | Represents method T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte). (Inherited from TfrxBarcode2DBaseWithUnion.)
Top
Fields
Show:
Name | Description
ArrOB | Represents field ArrOB.
DotsL | Represents field DotsL. (Inherited from TfrxBarcode2DBaseWithUnion.)
DotsR | Represents field DotsR. (Inherited from TfrxBarcode2DBaseWithUnion.)
FCodePage | Represents field FCodePage.
FColor | Represents field FColor. (Inherited from TfrxBarcode2DBase.)
FColorBar | Represents field FColorBar. (Inherited from TfrxBarcode2DBase.)
FEncoding | Represents field FEncoding.
FErrorText | Represents field FErrorText. (Inherited from TfrxBarcode2DBase.)
FFont | Represents field FFont. (Inherited from TfrxBarcode2DBase.)
FFontScaled | Represents field FFontScaled. (Inherited from TfrxBarcode2DBase.)
FGS1Rule | Represents field FGS1Rule.
FHeight | Represents field FHeight. (Inherited from TfrxBarcode2DBase.)
FPixelHeight | Represents field FPixelHeight. (Inherited from TfrxBarcode2DBase.)
FPixelWidth | Represents field FPixelWidth. (Inherited from TfrxBarcode2DBase.)
FPlace | Represents field FPlace.
FQuietZone | Represents field FQuietZone. (Inherited from TfrxBarcode2DBase.)
FRotation | Represents field FRotation. (Inherited from TfrxBarcode2DBase.)
FShowText | Represents field FShowText. (Inherited from TfrxBarcode2DBase.)
FSymbolSize | Represents field FSymbolSize.
FText | Represents field FText. (Inherited from TfrxBarcode2DBase.)
FVectorPrimitives | Represents field FVectorPrimitives. (Inherited from TfrxBarcode2DBaseWithUnion.)
FWidth | Represents field FWidth. (Inherited from TfrxBarcode2DBase.)
FZoom | Represents field FZoom. (Inherited from TfrxBarcode2DBase.)
Top
See Also

Reference

  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxBarcodeDataMatrix class. (Overrides TfrxBarcode2DBaseWithUnion.Create.)
Destroy | Represents the destructor of the TfrxBarcodeDataMatrix class. (Overrides TfrxBarcode2DBaseWithUnion.Destroy.)
Top


TfrxBarcodeDataMatrix.Create Constructor

Summary

Initializes a new instance of the TfrxBarcodeDataMatrix class.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
public
 constructor Create; override;

Overrides

TfrxBarcode2DBaseWithUnion.Create
See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.Destroy Destructor

Summary

Represents the destructor of the TfrxBarcodeDataMatrix class.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxBarcode2DBaseWithUnion.Destroy
See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix Properties

Properties
Name | Description
CodePage | Represents property CodePage.
Encoding | Represents property Encoding.
GS1Rule | Represents property GS1Rule.
PixelSize | Represents property PixelSize.
SymbolSize | Represents property SymbolSize.
Top


TfrxBarcodeDataMatrix.CodePage Property

Summary

Represents property CodePage.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
published
 property CodePage : integer read FCodePage write SetCodePage;

Property Value

Type: integer

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.Encoding Property

Summary

Represents property Encoding.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
published
 property Encoding : DatamatrixEncoding read FEncoding write SetEncoding;

Property Value

Type: DatamatrixEncoding

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.GS1Rule Property

Summary

Represents property GS1Rule.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
published
 property GS1Rule : Boolean read FGS1Rule write SetGS1Rule;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.PixelSize Property

Summary

Represents property PixelSize.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
published
 property PixelSize : integer read GetPixelSize write SetPixelSize;

Property Value

Type: integer

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.SymbolSize Property

Summary

Represents property SymbolSize.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
published
 property SymbolSize : DatamatrixSymbolSize read FSymbolSize write SetSymbolSize;

Property Value

Type: DatamatrixSymbolSize

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix Methods

Methods
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
Draw(byte[],integer,DmParams) | Represents method Draw(byte[],integer,DmParams).
Ecc200 | Represents method Ecc200.
Generate(byte[],integer,integer) | Overloaded. Represents method Generate(byte[],integer,integer).
Generate(string) | Overloaded. Represents method Generate(string).
GetEncodation(byte[],integer,integer,byte[],integer,integer,boolean) | Represents method GetEncodation(byte[],integer,integer,byte[],integer,integer,boolean).
GetPixelSize | Represents method GetPixelSize.
SetBit(integer,integer) | Represents method SetBit(integer,integer).
SetCodePage(integer) | Represents method SetCodePage(integer).
SetEncoding(DatamatrixEncoding) | Represents method SetEncoding(DatamatrixEncoding).
SetGS1Rule(Boolean) | Represents method SetGS1Rule(Boolean).
SetPixelSize(integer) | Represents method SetPixelSize(integer).
SetSymbolSize(DatamatrixSymbolSize) | Represents method SetSymbolSize(DatamatrixSymbolSize).
SetText(string) | Represents method SetText(string). (Overrides TfrxBarcode2DBase.SetText(String).)
Top


TfrxBarcodeDataMatrix.Assign(TfrxBarcode2DBase) Method

Summary

Represents method Assign(TfrxBarcode2DBase).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
public
 procedure Assign(src: TfrxBarcode2DBase);override;

Parameters

src
Type: TfrxBarcode2DBase

Overrides

TfrxBarcode2DBase.Assign(TfrxBarcode2DBase)
See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.Draw(byte[],integer,DmParams) Method

Summary

Represents method Draw(byte[],integer,DmParams).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 procedure Draw(var data : array of byte; dataSize : integer; const dm: DmParams);

Parameters

data
Type: array of byte

dataSize
Type: integer

dm
Type: DmParams

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.Ecc200 Method

Summary

Represents method Ecc200.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 procedure Ecc200;
See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.Generate(byte[],integer,integer) Method

Summary

Represents method Generate(byte[],integer,integer).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 procedure Generate( var text: array of byte; textOffset, textSize : integer); overload;

Parameters

text
Type: array of byte

textOffset
Type: integer

textSize
Type: integer

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.Generate(string) Method

Summary

Represents method Generate(string).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 procedure Generate(var text : string); overload;

Parameters

text
Type: string

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.GetEncodation(byte[],integer,integer,byte[],integer,integer,boolean) Method

Summary

Represents method GetEncodation(byte[],integer,integer,byte[],integer,integer,boolean).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 function GetEncodation(var Text : array of byte; textOffset, textSize : integer; var data : array of byte;
 dataOffset, dataSize : integer; firstMatch : boolean) : integer;

Parameters

Text
Type: array of byte

textOffset
Type: integer

textSize
Type: integer

data
Type: array of byte

dataOffset
Type: integer

dataSize
Type: integer

firstMatch
Type: boolean

Return Value

Type: integer

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.GetPixelSize Method

Summary

Represents method GetPixelSize.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 function GetPixelSize : integer;

Return Value

Type: integer

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.SetBit(integer,integer) Method

Summary

Represents method SetBit(integer,integer).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 procedure SetBit(x, y : integer);

Parameters

x
Type: integer

y
Type: integer

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.SetCodePage(integer) Method

Summary

Represents method SetCodePage(integer).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 procedure SetCodePage( cp : integer );

Parameters

cp
Type: integer

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.SetEncoding(DatamatrixEncoding) Method

Summary

Represents method SetEncoding(DatamatrixEncoding).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 procedure SetEncoding( v : DatamatrixEncoding);

Parameters

v
Type: DatamatrixEncoding

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.SetGS1Rule(Boolean) Method

Summary

Represents method SetGS1Rule(Boolean).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 procedure SetGS1Rule(b: Boolean);

Parameters

b
Type: Boolean

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.SetPixelSize(integer) Method

Summary

Represents method SetPixelSize(integer).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 procedure SetPixelSize(v : integer);

Parameters

v
Type: integer

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.SetSymbolSize(DatamatrixSymbolSize) Method

Summary

Represents method SetSymbolSize(DatamatrixSymbolSize).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 procedure SetSymbolSize( s : DatamatrixSymbolSize);

Parameters

s
Type: DatamatrixSymbolSize

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.SetText(string) Method

Summary

Represents method SetText(string).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
protected
 procedure SetText(v : string); override;

Parameters

v
Type: string

Overrides

TfrxBarcode2DBase.SetText(String)
See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix Fields

Fields
Name | Description
ArrOB | Represents field ArrOB.
FCodePage | Represents field FCodePage.
FEncoding | Represents field FEncoding.
FGS1Rule | Represents field FGS1Rule.
FPlace | Represents field FPlace.
FSymbolSize | Represents field FSymbolSize.
Top


TfrxBarcodeDataMatrix.ArrOB Field

Summary

Represents field ArrOB.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 ArrOB: T2DBooleanArray;

Field Value

Type: T2DBooleanArray

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.FCodePage Field

Summary

Represents field FCodePage.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 FCodePage : integer;

Field Value

Type: integer

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.FEncoding Field

Summary

Represents field FEncoding.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 FEncoding : DatamatrixEncoding;

Field Value

Type: DatamatrixEncoding

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.FGS1Rule Field

Summary

Represents field FGS1Rule.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 FGS1Rule : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.FPlace Field

Summary

Represents field FPlace.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 FPlace : TInts;

Field Value

Type: TInts

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


TfrxBarcodeDataMatrix.FSymbolSize Field

Summary

Represents field FSymbolSize.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
private
 FSymbolSize : DatamatrixSymbolSize;

Field Value

Type: DatamatrixSymbolSize

See Also

Reference

  • TfrxBarcodeDataMatrix
  • frxBarcodeDataMatrix


frxBarcodeDataMatrix Records

Records
Name | Description
DmParams | Represents type DmParams.
SizeF | Represents type SizeF.
Top


DmParams Record

Summary

Represents type DmParams.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
type
DmParams = record
end;

The DmParams type exposes the following members.

Fields
Show:
Name | Description
dataBlock | Represents field dataBlock.
dataSize | Represents field dataSize.
errorBlock | Represents field errorBlock.
height | Represents field height.
heightSection | Represents field heightSection.
width | Represents field width.
widthSection | Represents field widthSection.
Top
See Also

Reference

  • frxBarcodeDataMatrix


DmParams Fields

Fields
Name | Description
dataBlock | Represents field dataBlock.
dataSize | Represents field dataSize.
errorBlock | Represents field errorBlock.
height | Represents field height.
heightSection | Represents field heightSection.
width | Represents field width.
widthSection | Represents field widthSection.
Top


DmParams.dataBlock Field

Summary

Represents field dataBlock.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
public
 height,
 width,
 heightSection,
 widthSection,
 dataSize,
 dataBlock,
 errorBlock : integer;

Field Value

Type: integer

See Also

Reference

  • DmParams
  • frxBarcodeDataMatrix


DmParams.dataSize Field

Summary

Represents field dataSize.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
public
 height,
 width,
 heightSection,
 widthSection,
 dataSize,
 dataBlock,
 errorBlock : integer;

Field Value

Type: integer

See Also

Reference

  • DmParams
  • frxBarcodeDataMatrix


DmParams.errorBlock Field

Summary

Represents field errorBlock.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
public
 height,
 width,
 heightSection,
 widthSection,
 dataSize,
 dataBlock,
 errorBlock : integer;

Field Value

Type: integer

See Also

Reference

  • DmParams
  • frxBarcodeDataMatrix


DmParams.height Field

Summary

Represents field height.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
public
 height,
 width,
 heightSection,
 widthSection,
 dataSize,
 dataBlock,
 errorBlock : integer;

Field Value

Type: integer

See Also

Reference

  • DmParams
  • frxBarcodeDataMatrix


DmParams.heightSection Field

Summary

Represents field heightSection.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
public
 height,
 width,
 heightSection,
 widthSection,
 dataSize,
 dataBlock,
 errorBlock : integer;

Field Value

Type: integer

See Also

Reference

  • DmParams
  • frxBarcodeDataMatrix


DmParams.width Field

Summary

Represents field width.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
public
 height,
 width,
 heightSection,
 widthSection,
 dataSize,
 dataBlock,
 errorBlock : integer;

Field Value

Type: integer

See Also

Reference

  • DmParams
  • frxBarcodeDataMatrix


DmParams.widthSection Field

Summary

Represents field widthSection.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
public
 height,
 width,
 heightSection,
 widthSection,
 dataSize,
 dataBlock,
 errorBlock : integer;

Field Value

Type: integer

See Also

Reference

  • DmParams
  • frxBarcodeDataMatrix


SizeF Record

Summary

Represents type SizeF.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
type
 SizeF = record
 end;

The SizeF type exposes the following members.

Fields
Show:
Name | Description
height | Represents field height.
width | Represents field width.
Top
See Also

Reference

  • frxBarcodeDataMatrix


SizeF Fields

Fields
Name | Description
height | Represents field height.
width | Represents field width.
Top


SizeF.height Field

Summary

Represents field height.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
public
 height : extended;

Field Value

Type: extended

See Also

Reference

  • SizeF
  • frxBarcodeDataMatrix


SizeF.width Field

Summary

Represents field width.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
public
 width : extended;

Field Value

Type: extended

See Also

Reference

  • SizeF
  • frxBarcodeDataMatrix


frxBarcodeDataMatrix Enumerations

Enumerations
Name | Description
DatamatrixEncoding | Represents type DatamatrixEncoding.
DatamatrixSymbolSize | Represents type DatamatrixSymbolSize.
Top


DatamatrixEncoding Enumeration

Summary

Represents type DatamatrixEncoding.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
type
DatamatrixEncoding =
(
 Auto,
 Ascii,
 C40,
 Txt,
 Base256,
 X12,
 Edifact
);

The DatamatrixEncoding type exposes the following members.

Members
Show:
Name | Description
Ascii | Represents constant Ascii.
Auto | Represents constant Auto.
Base256 | Represents constant Base256.
C40 | Represents constant C40.
Edifact | Represents constant Edifact.
Txt | Represents constant Txt.
X12 | Represents constant X12.
Top
See Also

Reference

  • frxBarcodeDataMatrix


DatamatrixSymbolSize Enumeration

Summary

Represents type DatamatrixSymbolSize.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
type
DatamatrixSymbolSize =
(
 AutoSize,
 Size10x10,
 Size12x12,
 Size8x18,
 Size14x14,
 Size8x32,
 Size16x16,
 Size12x26,
 Size18x18,
 Size20x20,
 Size12x36,
 Size22x22,
 Size16x36,
 Size24x24,
 Size26x26,
 Size16x48,
 Size32x32,
 Size36x36,
 Size40x40,
 Size44x44,
 Size48x48,
 Size52x52,
 Size64x64,
 Size72x72,
 Size80x80,
 Size88x88,
 Size96x96,
 Size104x104,
 Size120x120,
 Size132x132,
 Size144x144
);

The DatamatrixSymbolSize type exposes the following members.

Members
Show:
Name | Description
AutoSize | Represents constant AutoSize.
Size104x104 | Represents constant Size104x104.
Size10x10 | Represents constant Size10x10.
Size120x120 | Represents constant Size120x120.
Size12x12 | Represents constant Size12x12.
Size12x26 | Represents constant Size12x26.
Size12x36 | Represents constant Size12x36.
Size132x132 | Represents constant Size132x132.
Size144x144 | Represents constant Size144x144.
Size14x14 | Represents constant Size14x14.
Size16x16 | Represents constant Size16x16.
Size16x36 | Represents constant Size16x36.
Size16x48 | Represents constant Size16x48.
Size18x18 | Represents constant Size18x18.
Size20x20 | Represents constant Size20x20.
Size22x22 | Represents constant Size22x22.
Size24x24 | Represents constant Size24x24.
Size26x26 | Represents constant Size26x26.
Size32x32 | Represents constant Size32x32.
Size36x36 | Represents constant Size36x36.
Size40x40 | Represents constant Size40x40.
Size44x44 | Represents constant Size44x44.
Size48x48 | Represents constant Size48x48.
Size52x52 | Represents constant Size52x52.
Size64x64 | Represents constant Size64x64.
Size72x72 | Represents constant Size72x72.
Size80x80 | Represents constant Size80x80.
Size88x88 | Represents constant Size88x88.
Size8x18 | Represents constant Size8x18.
Size8x32 | Represents constant Size8x32.
Size96x96 | Represents constant Size96x96.
Top
See Also

Reference

  • frxBarcodeDataMatrix


frxBarcodeDataMatrix Types

Types
Name | Description
TInts | Represents an array of the integer type.
Top


TInts Type

Summary

Represents an array of the integer type.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
type
 TInts = array of integer;
See Also

Reference

  • frxBarcodeDataMatrix


frxBarcodeDataMatrix Constants

Constants
Name | Description
alog | Represents constant alog.
cbDefaultText | Represents constant cbDefaultText.
dmSizes | Represents constant dmSizes.
log | Represents constant log.
poly10 | Represents constant poly10.
poly11 | Represents constant poly11.
poly12 | Represents constant poly12.
poly14 | Represents constant poly14.
poly18 | Represents constant poly18.
poly20 | Represents constant poly20.
poly24 | Represents constant poly24.
poly28 | Represents constant poly28.
poly36 | Represents constant poly36.
poly42 | Represents constant poly42.
poly48 | Represents constant poly48.
poly5 | Represents constant poly5.
poly56 | Represents constant poly56.
poly62 | Represents constant poly62.
poly68 | Represents constant poly68.
poly7 | Represents constant poly7.
_x12 | Represents constant _x12.
Top


alog Constant

Summary

Represents constant alog.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 alog : array[0..255] of integer =
 ( 1, 2, 4, 8, 16, 32, 64, 128, 45, 90, 180, 69, 138, 57, 114, 228,
 229, 231, 227, 235, 251, 219, 155, 27, 54, 108, 216, 157, 23, 46, 92, 184,
 93, 186, 89, 178, 73, 146, 9, 18, 36, 72, 144, 13, 26, 52, 104, 208,
 141, 55, 110, 220, 149, 7, 14, 28, 56, 112, 224, 237, 247, 195, 171, 123,
 246, 193, 175, 115, 230, 225, 239, 243, 203, 187, 91, 182, 65, 130, 41, 82,
 164, 101, 202, 185, 95, 190, 81, 162, 105, 210, 137, 63, 126, 252, 213, 135,
 35, 70, 140, 53, 106, 212, 133, 39, 78, 156, 21, 42, 84, 168, 125, 250,
 217, 159, 19, 38, 76, 152, 29, 58, 116, 232, 253, 215, 131, 43, 86, 172,
 117, 234, 249, 223, 147, 11, 22, 44, 88, 176, 77, 154, 25, 50, 100, 200,
 189, 87, 174, 113, 226, 233, 255, 211, 139, 59, 118, 236, 245, 199, 163, 107,
 214, 129, 47, 94, 188, 85, 170, 121, 242, 201, 191, 83, 166, 97, 194, 169,
 127, 254, 209, 143, 51, 102, 204, 181, 71, 142, 49, 98, 196, 165, 103, 206,
 177, 79, 158, 17, 34, 68, 136, 61, 122, 244, 197, 167, 99, 198, 161, 111,
 222, 145, 15, 30, 60, 120, 240, 205, 183, 67, 134, 33, 66, 132, 37, 74,
 148, 5, 10, 20, 40, 80, 160, 109, 218, 153, 31, 62, 124, 248, 221, 151,
 3, 6, 12, 24, 48, 96, 192, 173, 119, 238, 241, 207, 179, 75, 150, 1 );

Value

Type: array[0..255] of integer

See Also

Reference

  • frxBarcodeDataMatrix


cbDefaultText Constant

Summary

Represents constant cbDefaultText.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 cbDefaultText = '12345678';

Value

Type: string

See Also

Reference

  • frxBarcodeDataMatrix


dmSizes Constant

Summary

Represents constant dmSizes.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 dmSizes : array[Size10x10..Size144x144] of DmParams =
 (
 ( height: 10; width: 10; heightSection: 10; widthSection: 10; dataSize: 3; dataBlock: 3; errorBlock: 5 ),
 ( height: 12; width: 12; heightSection: 12; widthSection: 12; dataSize: 5; dataBlock: 5; errorBlock: 7 ),
 ( height: 8; width: 18; heightSection: 8; widthSection: 18; dataSize: 5; dataBlock: 5; errorBlock: 7 ),
 ( height: 14; width: 14; heightSection: 14; widthSection: 14; dataSize: 8; dataBlock: 8; errorBlock:10 ),
 ( height: 8; width: 32; heightSection: 8; widthSection: 16; dataSize:10; dataBlock:10; errorBlock:11 ),
 ( height: 16; width: 16; heightSection: 16; widthSection: 16; dataSize:12; dataBlock:12; errorBlock:12 ),
 ( height: 12; width: 26; heightSection: 12; widthSection: 26; dataSize:16; dataBlock:16; errorBlock:14 ),
 ( height: 18; width: 18; heightSection: 18; widthSection: 18; dataSize:18; dataBlock:18; errorBlock:14 ),
 ( height: 20; width: 20; heightSection: 20; widthSection: 20; dataSize:22; dataBlock:22; errorBlock:18 ),
 ( height: 12; width: 36; heightSection: 12; widthSection: 18; dataSize:22; dataBlock:22; errorBlock:18 ),
 ( height: 22; width: 22; heightSection: 22; widthSection: 22; dataSize:30; dataBlock:30; errorBlock:20 ),
 ( height: 16; width: 36; heightSection: 16; widthSection: 18; dataSize:32; dataBlock:32; errorBlock:24 ),
 ( height: 24; width: 24; heightSection: 24; widthSection: 24; dataSize:36; dataBlock:36; errorBlock:24 ),
 ( height: 26; width: 26; heightSection: 26; widthSection: 26; dataSize:44; dataBlock:44; errorBlock:28 ),
 ( height: 16; width: 48; heightSection: 16; widthSection: 24; dataSize:49; dataBlock:49; errorBlock:28 ),
 ( height: 32; width: 32; heightSection: 16; widthSection: 16; dataSize:62; dataBlock:62; errorBlock:36 ),
 ( height: 36; width: 36; heightSection: 18; widthSection: 18; dataSize:86; dataBlock:86; errorBlock:42 ),
 ( height: 40; width: 40; heightSection: 20; widthSection: 20; dataSize:114; dataBlock:114; errorBlock: 48 ),
 ( height: 44; width: 44; heightSection: 22; widthSection: 22; dataSize:144; dataBlock:144; errorBlock: 56 ),
 ( height: 48; width: 48; heightSection: 24; widthSection: 24; dataSize:174; dataBlock:174; errorBlock: 68 ),
 ( height: 52; width: 52; heightSection: 26; widthSection: 26; dataSize:204; dataBlock:102; errorBlock: 42 ),
 ( height: 64; width: 64; heightSection: 16; widthSection: 16; dataSize:280; dataBlock:140; errorBlock: 56 ),
 ( height: 72; width: 72; heightSection: 18; widthSection: 18; dataSize:368; dataBlock:92; errorBlock: 36 ),
 ( height: 80; width: 80; heightSection: 20; widthSection: 20; dataSize:456; dataBlock:114; errorBlock: 48 ),
 ( height: 88; width: 88; heightSection: 22; widthSection: 22; dataSize:576; dataBlock:144; errorBlock: 56 ),
 ( height: 96; width: 96; heightSection: 24; widthSection: 24; dataSize:696; dataBlock:174; errorBlock: 68 ),
 ( height:104; width:104; heightSection: 26; widthSection: 26; dataSize:816; dataBlock:136; errorBlock: 56 ),
 ( height:120; width:120; heightSection: 20; widthSection: 20; dataSize:1050; dataBlock:175; errorBlock: 68 ),
 ( height:132; width:132; heightSection: 22; widthSection: 22; dataSize:1304; dataBlock:163; errorBlock: 62 ),
 ( height:144; width:144; heightSection: 24; widthSection: 24; dataSize:1558; dataBlock:156; errorBlock: 62 )
);

Value

Type: array[Size10x10..Size144x144] of DmParams

See Also

Reference

  • frxBarcodeDataMatrix


log Constant

Summary

Represents constant log.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 log : array[0..255] of integer =
 ( 0, 255, 1, 240, 2, 225, 241, 53, 3, 38, 226, 133, 242, 43, 54, 210,
 4, 195, 39, 114, 227, 106, 134, 28, 243, 140, 44, 23, 55, 118, 211, 234,
 5, 219, 196, 96, 40, 222, 115, 103, 228, 78, 107, 125, 135, 8, 29, 162,
 244, 186, 141, 180, 45, 99, 24, 49, 56, 13, 119, 153, 212, 199, 235, 91,
 6, 76, 220, 217, 197, 11, 97, 184, 41, 36, 223, 253, 116, 138, 104, 193,
 229, 86, 79, 171, 108, 165, 126, 145, 136, 34, 9, 74, 30, 32, 163, 84,
 245, 173, 187, 204, 142, 81, 181, 190, 46, 88, 100, 159, 25, 231, 50, 207,
 57, 147, 14, 67, 120, 128, 154, 248, 213, 167, 200, 63, 236, 110, 92, 176,
 7, 161, 77, 124, 221, 102, 218, 95, 198, 90, 12, 152, 98, 48, 185, 179,
 42, 209, 37, 132, 224, 52, 254, 239, 117, 233, 139, 22, 105, 27, 194, 113,
 230, 206, 87, 158, 80, 189, 172, 203, 109, 175, 166, 62, 127, 247, 146, 66,
 137, 192, 35, 252, 10, 183, 75, 216, 31, 83, 33, 73, 164, 144, 85, 170,
 246, 65, 174, 61, 188, 202, 205, 157, 143, 169, 82, 72, 182, 215, 191, 251,
 47, 178, 89, 151, 101, 94, 160, 123, 26, 112, 232, 21, 51, 238, 208, 131,
 58, 69, 148, 18, 15, 16, 68, 17, 121, 149, 129, 19, 155, 59, 249, 70,
 214, 250, 168, 71, 201, 156, 64, 60, 237, 130, 111, 20, 93, 122, 177, 150 );

Value

Type: array[0..255] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly10 Constant

Summary

Represents constant poly10.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly10 : array[0..9] of integer = ( 28, 24, 185, 166, 223, 248, 116, 255, 110, 61 );

Value

Type: array[0..9] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly11 Constant

Summary

Represents constant poly11.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly11 : array[0..10] of integer = ( 175, 138, 205, 12, 194, 168, 39, 245, 60, 97, 120 );

Value

Type: array[0..10] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly12 Constant

Summary

Represents constant poly12.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly12 : array[0..11] of integer = ( 41, 153, 158, 91, 61, 42, 142, 213, 97, 178, 100, 242 );

Value

Type: array[0..11] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly14 Constant

Summary

Represents constant poly14.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly14 : array[0..13] of integer = ( 156, 97, 192, 252, 95, 9, 157, 119, 138, 45, 18, 186, 83, 185 );

Value

Type: array[0..13] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly18 Constant

Summary

Represents constant poly18.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly18 : array[0..17] of integer = ( 83, 195, 100, 39, 188, 75, 66, 61, 241, 213, 109, 129, 94, 254, 225, 48, 90, 188 );

Value

Type: array[0..17] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly20 Constant

Summary

Represents constant poly20.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly20 : array[0..19] of integer = ( 15, 195, 244, 9, 233, 71, 168, 2, 188, 160, 153, 145, 253, 79,
 108, 82, 27, 174, 186, 172 );

Value

Type: array[0..19] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly24 Constant

Summary

Represents constant poly24.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly24 : array[0..23] of integer = ( 52, 190, 88, 205, 109, 39, 176, 21, 155, 197, 251, 223, 155, 21, 5, 172,
 254, 124, 12, 181, 184, 96, 50, 193 );

Value

Type: array[0..23] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly28 Constant

Summary

Represents constant poly28.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly28 : array[0..27] of integer = ( 211, 231, 43, 97, 71, 96, 103, 174, 37, 151, 170, 53, 75, 34, 249, 121,
 17, 138, 110, 213, 141, 136, 120, 151, 233, 168, 93, 255 );

Value

Type: array[0..27] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly36 Constant

Summary

Represents constant poly36.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly36 : array[0..35] of integer = ( 245, 127, 242, 218, 130, 250, 162, 181, 102, 120, 84, 179, 220, 251, 80, 182,
 229, 18, 2, 4, 68, 33, 101, 137, 95, 119, 115, 44, 175, 184, 59, 25,
 225, 98, 81, 112 );

Value

Type: array[0..35] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly42 Constant

Summary

Represents constant poly42.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly42 : array[0..41] of integer = ( 77, 193, 137, 31, 19, 38, 22, 153, 247, 105, 122, 2, 245, 133, 242, 8,
 175, 95, 100, 9, 167, 105, 214, 111, 57, 121, 21, 1, 253, 57, 54, 101,
 248, 202, 69, 50, 150, 177, 226, 5, 9, 5 );

Value

Type: array[0..41] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly48 Constant

Summary

Represents constant poly48.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly48 : array[0..47] of integer = ( 245, 132, 172, 223, 96, 32, 117, 22, 238, 133, 238, 231, 205, 188, 237, 87,
 191, 106, 16, 147, 118, 23, 37, 90, 170, 205, 131, 88, 120, 100, 66, 138,
 186, 240, 82, 44, 176, 87, 187, 147, 160, 175, 69, 213, 92, 253, 225, 19 );

Value

Type: array[0..47] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly5 Constant

Summary

Represents constant poly5.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly5 : array[0..4] of integer = ( 228, 48, 15, 111, 62 );

Value

Type: array[0..4] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly56 Constant

Summary

Represents constant poly56.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly56 : array[0..55] of integer = ( 175, 9, 223, 238, 12, 17, 220, 208, 100, 29, 175, 170, 230, 192, 215, 235,
 150, 159, 36, 223, 38, 200, 132, 54, 228, 146, 218, 234, 117, 203, 29, 232,
 144, 238, 22, 150, 201, 117, 62, 207, 164, 13, 137, 245, 127, 67, 247, 28,
 155, 43, 203, 107, 233, 53, 143, 46 );

Value

Type: array[0..55] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly62 Constant

Summary

Represents constant poly62.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly62 : array[0..61] of integer = ( 242, 93, 169, 50, 144, 210, 39, 118, 202, 188, 201, 189, 143, 108, 196, 37,
 185, 112, 134, 230, 245, 63, 197, 190, 250, 106, 185, 221, 175, 64, 114, 71,
 161, 44, 147, 6, 27, 218, 51, 63, 87, 10, 40, 130, 188, 17, 163, 31,
 176, 170, 4, 107, 232, 7, 94, 166, 224, 124, 86, 47, 11, 204 );

Value

Type: array[0..61] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly68 Constant

Summary

Represents constant poly68.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly68 : array[0..67] of integer = ( 220, 228, 173, 89, 251, 149, 159, 56, 89, 33, 147, 244, 154, 36, 73, 127,
 213, 136, 248, 180, 234, 197, 158, 177, 68, 122, 93, 213, 15, 160, 227, 236,
 66, 139, 153, 185, 202, 167, 179, 25, 220, 232, 96, 210, 231, 136, 223, 239,
 181, 241, 59, 52, 172, 25, 49, 232, 211, 189, 64, 54, 108, 153, 132, 63,
 96, 103, 82, 186 );

Value

Type: array[0..67] of integer

See Also

Reference

  • frxBarcodeDataMatrix


poly7 Constant

Summary

Represents constant poly7.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 poly7 : array[0..6] of integer = ( 23, 68, 144, 134, 240, 92, 254 );

Value

Type: array[0..6] of integer

See Also

Reference

  • frxBarcodeDataMatrix


_x12 Constant

Summary

Represents constant _x12.

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
 _x12 = #13 + '*> 0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ';

Value

Type: string

See Also

Reference

  • frxBarcodeDataMatrix


frxBarcodeDataMatrix Routines

Routines
Name | Description
GenerateECC(byte[],integer,integer,integer) | Represents method GenerateECC(byte[],integer,integer,integer).
Top


GenerateECC(byte[],integer,integer,integer) Method

Summary

Represents method GenerateECC(byte[],integer,integer,integer).

Namespace: frxBarcodeDataMatrix
Syntax
Delphi
procedure GenerateECC(var wd : array of byte; nd, datablock, nc : integer );

Parameters

wd
Type: array of byte

nd
Type: integer

datablock
Type: integer

nc
Type: integer

See Also

Reference

  • frxBarcodeDataMatrix


frxBarcodeMaxiCode Namespace

Summary

Represents namespace frxBarcodeMaxiCode.

Classes
Name | Description
TfrxBarcodeMaxiCode | Represents type TfrxBarcodeMaxiCode.
Top


frxBarcodeMaxiCode Classes

Classes
Name | Description
TfrxBarcodeMaxiCode | Represents type TfrxBarcodeMaxiCode.
Top


TfrxBarcodeMaxiCode Class

Summary

Represents type TfrxBarcodeMaxiCode.

Namespace: frxBarcodeMaxiCode
Inheritance Hierarchy
TObject
frxBarcode2DBase.TfrxBarcode2DBase
frxBarcode2DBase.TfrxBarcode2DBaseWithOutUnion
frxBarcodeMaxiCode.TfrxBarcodeMaxiCode
Syntax
Delphi
type
 TfrxBarcodeMaxiCode = class(TfrxBarcode2DBaseWithOutUnion)
 end;

The TfrxBarcodeMaxiCode type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxBarcodeMaxiCode class. (Overrides TfrxBarcode2DBaseWithOutUnion.Create.)
Destroy | Represents the destructor of the TfrxBarcodeMaxiCode class. (Overrides TfrxBarcode2DBaseWithOutUnion.Destroy.)
Top
Properties
Show:
Name | Description
Color | Represents property Color. (Inherited from TfrxBarcode2DBase.)
ColorBar | Represents property ColorBar. (Inherited from TfrxBarcode2DBase.)
ErrorText | Represents property ErrorText. (Inherited from TfrxBarcode2DBase.)
Font | Represents property Font. (Inherited from TfrxBarcode2DBase.)
FontScaled | Represents property FontScaled. (Inherited from TfrxBarcode2DBase.)
Height | Represents property Height. (Inherited from TfrxBarcode2DBase.)
Mode | Represents property Mode.
PixelHeight | Represents property PixelHeight. (Inherited from TfrxBarcode2DBase.)
PixelWidth | Represents property PixelWidth. (Inherited from TfrxBarcode2DBase.)
QuietZone | Represents property QuietZone. (Inherited from TfrxBarcode2DBase.)
Rotation | Represents property Rotation. (Inherited from TfrxBarcode2DBase.)
ShowText | Represents property ShowText. (Inherited from TfrxBarcode2DBase.)
Text | Represents property Text. (Inherited from TfrxBarcode2DBase.)
Width | Represents property Width. (Inherited from TfrxBarcode2DBase.)
Zoom | Represents property Zoom. (Inherited from TfrxBarcode2DBase.)
Top
Methods
Show:
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer). (Inherited from TfrxBarcode2DBase.)
FillRect(TCanvas,TRect) | Represents method FillRect(TCanvas,TRect). (Inherited from TfrxBarcode2DBase.)
Generate | Represents method Generate.
GetFooterHeight | Represents method GetFooterHeight. (Inherited from TfrxBarcode2DBase.)
GetHeight | Represents method GetHeight. (Inherited from TfrxBarcode2DBase.)
GetMode | Represents method GetMode.
GetWidth | Represents method GetWidth. (Inherited from TfrxBarcode2DBase.)
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended). (Overrides TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).)
IsScaled | Represents method IsScaled. (Inherited from TfrxBarcode2DBase.)
SetColor(TColor) | Represents method SetColor(TColor). (Inherited from TfrxBarcode2DBase.)
SetColorBar(TColor) | Represents method SetColorBar(TColor). (Inherited from TfrxBarcode2DBase.)
SetErrorText(String) | Represents method SetErrorText(String). (Inherited from TfrxBarcode2DBase.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxBarcode2DBase.)
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean). (Inherited from TfrxBarcode2DBase.)
SetHeight(Integer) | Represents method SetHeight(Integer). (Inherited from TfrxBarcode2DBase.)
SetMode(Integer) | Represents method SetMode(Integer).
SetRotation(Integer) | Represents method SetRotation(Integer). (Inherited from TfrxBarcode2DBase.)
SetShowText(Boolean) | Represents method SetShowText(Boolean). (Inherited from TfrxBarcode2DBase.)
SetText(String) | Represents method SetText(String). (Overrides TfrxBarcode2DBase.SetText(String).)
SetZoom(Extended) | Represents method SetZoom(Extended). (Inherited from TfrxBarcode2DBase.)
Top
Fields
Show:
Name | Description
FColor | Represents field FColor. (Inherited from TfrxBarcode2DBase.)
FColorBar | Represents field FColorBar. (Inherited from TfrxBarcode2DBase.)
FErrorText | Represents field FErrorText. (Inherited from TfrxBarcode2DBase.)
FFont | Represents field FFont. (Inherited from TfrxBarcode2DBase.)
FFontScaled | Represents field FFontScaled. (Inherited from TfrxBarcode2DBase.)
FHeight | Represents field FHeight. (Inherited from TfrxBarcode2DBase.)
FImage | Represents field FImage. (Inherited from TfrxBarcode2DBaseWithOutUnion.)
FMaxiCodeEncoder | Represents field FMaxiCodeEncoder.
FPixelHeight | Represents field FPixelHeight. (Inherited from TfrxBarcode2DBase.)
FPixelWidth | Represents field FPixelWidth. (Inherited from TfrxBarcode2DBase.)
FQuietZone | Represents field FQuietZone. (Inherited from TfrxBarcode2DBase.)
FRotation | Represents field FRotation. (Inherited from TfrxBarcode2DBase.)
FShowText | Represents field FShowText. (Inherited from TfrxBarcode2DBase.)
FText | Represents field FText. (Inherited from TfrxBarcode2DBase.)
FWidth | Represents field FWidth. (Inherited from TfrxBarcode2DBase.)
FZoom | Represents field FZoom. (Inherited from TfrxBarcode2DBase.)
Top
See Also

Reference

  • frxBarcodeMaxiCode


TfrxBarcodeMaxiCode Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxBarcodeMaxiCode class. (Overrides TfrxBarcode2DBaseWithOutUnion.Create.)
Destroy | Represents the destructor of the TfrxBarcodeMaxiCode class. (Overrides TfrxBarcode2DBaseWithOutUnion.Destroy.)
Top


TfrxBarcodeMaxiCode.Create Constructor

Summary

Initializes a new instance of the TfrxBarcodeMaxiCode class.

Namespace: frxBarcodeMaxiCode
Syntax
Delphi
public
 constructor Create; override;

Overrides

TfrxBarcode2DBaseWithOutUnion.Create
See Also

Reference

  • TfrxBarcodeMaxiCode
  • frxBarcodeMaxiCode


TfrxBarcodeMaxiCode.Destroy Destructor

Summary

Represents the destructor of the TfrxBarcodeMaxiCode class.

Namespace: frxBarcodeMaxiCode
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxBarcode2DBaseWithOutUnion.Destroy
See Also

Reference

  • TfrxBarcodeMaxiCode
  • frxBarcodeMaxiCode


TfrxBarcodeMaxiCode Properties

Properties
Name | Description
Mode | Represents property Mode.
Top


TfrxBarcodeMaxiCode.Mode Property

Summary

Represents property Mode.

Namespace: frxBarcodeMaxiCode
Syntax
Delphi
published
 property Mode: Integer read GetMode write SetMode;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcodeMaxiCode
  • frxBarcodeMaxiCode


TfrxBarcodeMaxiCode Methods

Methods
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
Generate | Represents method Generate.
GetMode | Represents method GetMode.
SetMode(Integer) | Represents method SetMode(Integer).
SetText(String) | Represents method SetText(String). (Overrides TfrxBarcode2DBase.SetText(String).)
Top


TfrxBarcodeMaxiCode.Assign(TfrxBarcode2DBase) Method

Summary

Represents method Assign(TfrxBarcode2DBase).

Namespace: frxBarcodeMaxiCode
Syntax
Delphi
public
 procedure Assign(src: TfrxBarcode2DBase); override;

Parameters

src
Type: TfrxBarcode2DBase

Overrides

TfrxBarcode2DBase.Assign(TfrxBarcode2DBase)
See Also

Reference

  • TfrxBarcodeMaxiCode
  • frxBarcodeMaxiCode


TfrxBarcodeMaxiCode.Generate Method

Summary

Represents method Generate.

Namespace: frxBarcodeMaxiCode
Syntax
Delphi
protected
 procedure Generate;
See Also

Reference

  • TfrxBarcodeMaxiCode
  • frxBarcodeMaxiCode


TfrxBarcodeMaxiCode.GetMode Method

Summary

Represents method GetMode.

Namespace: frxBarcodeMaxiCode
Syntax
Delphi
private
 function GetMode: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxBarcodeMaxiCode
  • frxBarcodeMaxiCode


TfrxBarcodeMaxiCode.SetMode(Integer) Method

Summary

Represents method SetMode(Integer).

Namespace: frxBarcodeMaxiCode
Syntax
Delphi
private
 procedure SetMode(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxBarcodeMaxiCode
  • frxBarcodeMaxiCode


TfrxBarcodeMaxiCode.SetText(String) Method

Summary

Represents method SetText(String).

Namespace: frxBarcodeMaxiCode
Syntax
Delphi
protected
 procedure SetText(v: String); override;

Parameters

v
Type: String

Overrides

TfrxBarcode2DBase.SetText(String)
See Also

Reference

  • TfrxBarcodeMaxiCode
  • frxBarcodeMaxiCode


TfrxBarcodeMaxiCode Fields

Fields
Name | Description
FMaxiCodeEncoder | Represents field FMaxiCodeEncoder.
Top


TfrxBarcodeMaxiCode.FMaxiCodeEncoder Field

Summary

Represents field FMaxiCodeEncoder.

Namespace: frxBarcodeMaxiCode
Syntax
Delphi
protected
 FMaxiCodeEncoder: TMaxiCodeEncoder;

Field Value

Type: TMaxiCodeEncoder

See Also

Reference

  • TfrxBarcodeMaxiCode
  • frxBarcodeMaxiCode


frxBarcodePDF417 Namespace

Summary

Represents namespace frxBarcodePDF417.

Classes
Name | Description
Segment | Represents type Segment.
TfrxBarcodePDF417 | Generates the 2D PDF417 barcode.
TSegmentList | Represents type TSegmentList.
Top
Enumerations
Name | Description
PDF417CompactionMode |
PDF417ErrorCorrection |
Top
Types
Name | Description
PInt | Represents a pointer type to TInt.
TInt | Represents an array of the integer type.
Top
Constants
Name | Description
ABSOLUTE_MAX_TEXT_SIZE | Represents constant ABSOLUTE_MAX_TEXT_SIZE.
AL | Represents constant AL.
ALPHA | Represents constant ALPHA.
BYTESHIFT | Represents constant BYTESHIFT.
BYTE_MODE | Represents constant BYTE_MODE.
BYTE_MODE_6 | Represents constant BYTE_MODE_6.
CLUSTERS | Represents constant CLUSTERS.
ERRLVL0 | Represents constant ERRLVL0.
ERRLVL1 | Represents constant ERRLVL1.
ERRLVL2 | Represents constant ERRLVL2.
ERRLVL3 | Represents constant ERRLVL3.
ERRLVL4 | Represents constant ERRLVL4.
ERRLVL5 | Represents constant ERRLVL5.
ERRLVL6 | Represents constant ERRLVL6.
ERRLVL7 | Represents constant ERRLVL7.
ERRLVL8 | Represents constant ERRLVL8.
ERROR_LEVEL | Represents constant ERROR_LEVEL.
ISBYTE | Represents constant ISBYTE.
LL | Represents constant LL.
LOWER | Represents constant LOWER.
MACRO_LAST_SEGMENT | Represents constant MACRO_LAST_SEGMENT.
MACRO_SEGMENT_ID | Represents constant MACRO_SEGMENT_ID.
MAX_DATA_CODEWORDS | Represents constant MAX_DATA_CODEWORDS.
MIXED | Represents constant MIXED.
MIXED_SET | Represents constant MIXED_SET.
ML | Represents constant ML.
NUMERIC_MODE | Represents constant NUMERIC_MODE.
PAL | Represents constant PAL.
PL | Represents constant PL.
PS | Represents constant PS.
PUNCTUATION | Represents constant PUNCTUATION.
PUNCTUATION_SET | Represents constant PUNCTUATION_SET.
SPACE | Represents constant SPACE.
START_CODE_SIZE | Represents constant START_CODE_SIZE.
START_PATTERN | Represents constant START_PATTERN.
STOP_PATTERN | Represents constant STOP_PATTERN.
STOP_SIZE | Represents constant STOP_SIZE.
TEXT_MODE | Represents constant TEXT_MODE.
_AS | Represents constant _AS.
_MOD | Represents constant _MOD.
Top


frxBarcodePDF417 Classes

Classes
Name | Description
Segment | Represents type Segment.
TfrxBarcodePDF417 | Generates the 2D PDF417 barcode.
TSegmentList | Represents type TSegmentList.
Top


Segment Class

Summary

Represents type Segment.

Namespace: frxBarcodePDF417
Inheritance Hierarchy
TObject
frxBarcodePDF417.Segment
Syntax
Delphi
type
 Segment = class
 end;

The Segment type exposes the following members.

Constructors
Show:
Name | Description
Create(char,integer,integer) | Initializes a new instance of the Segment class.
Top
Fields
Show:
Name | Description
_end | Represents field _end.
_start | Represents field _start.
_type | Represents field _type.
Top
See Also

Reference

  • frxBarcodePDF417


Segment Constructors

Constructors
Name | Description
Create(char,integer,integer) | Initializes a new instance of the Segment class.
Top


Segment.Create(char,integer,integer) Constructor

Summary

Initializes a new instance of the Segment class.

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 constructor Create( _t : char; _s, _e : integer);

Parameters

_t
Type: char

_s
Type: integer

_e
Type: integer

See Also

Reference

  • Segment
  • frxBarcodePDF417


Segment Fields

Fields
Name | Description
_end | Represents field _end.
_start | Represents field _start.
_type | Represents field _type.
Top


Segment._end Field

Summary

Represents field _end.

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 _start,
 _end : integer;

Field Value

Type: integer

See Also

Reference

  • Segment
  • frxBarcodePDF417


Segment._start Field

Summary

Represents field _start.

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 _start,
 _end : integer;

Field Value

Type: integer

See Also

Reference

  • Segment
  • frxBarcodePDF417


Segment._type Field

Summary

Represents field _type.

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 _type : char;

Field Value

Type: char

See Also

Reference

  • Segment
  • frxBarcodePDF417


TfrxBarcodePDF417 Class

Summary

Generates the 2D PDF417 barcode.

Namespace: frxBarcodePDF417
Inheritance Hierarchy
TObject
frxBarcode2DBase.TfrxBarcode2DBase
frxBarcode2DBase.TfrxBarcode2DBaseWithUnion
frxBarcodePDF417.TfrxBarcodePDF417
Syntax
Delphi
type
 TfrxBarcodePDF417 = class(TfrxBarcode2DBaseWithUnion)
 end;

The TfrxBarcodePDF417 type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxBarcodePDF417 class. (Overrides TfrxBarcode2DBaseWithUnion.Create.)
Destroy | Represents the destructor of the TfrxBarcodePDF417 class. (Overrides TfrxBarcode2DBaseWithUnion.Destroy.)
Top
Properties
Show:
Name | Description
AspectRatio |
CodePage |
Color | Represents property Color. (Inherited from TfrxBarcode2DBase.)
ColorBar | Represents property ColorBar. (Inherited from TfrxBarcode2DBase.)
Columns |
CompactionMode |
ErrorCorrection |
ErrorText | Represents property ErrorText. (Inherited from TfrxBarcode2DBase.)
Font | Represents property Font. (Inherited from TfrxBarcode2DBase.)
FontScaled | Represents property FontScaled. (Inherited from TfrxBarcode2DBase.)
Height | Represents property Height. (Inherited from TfrxBarcode2DBase.)
PixelHeight | Represents property PixelHeight. (Inherited from TfrxBarcode2DBase.)
PixelWidth | Represents property PixelWidth. (Inherited from TfrxBarcode2DBase.)
QuietZone | Represents property QuietZone. (Inherited from TfrxBarcode2DBase.)
Rotation | Represents property Rotation. (Inherited from TfrxBarcode2DBase.)
Rows |
ShowText | Represents property ShowText. (Inherited from TfrxBarcode2DBase.)
Text | Represents property Text. (Inherited from TfrxBarcode2DBase.)
Width | Represents property Width. (Inherited from TfrxBarcode2DBase.)
Zoom | Represents property Zoom. (Inherited from TfrxBarcode2DBase.)
Top
Methods
Show:
Name | Description
Assemble | Represents method Assemble.
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
BasicNumberCompaction(byte[],integer,integer) | Overloaded. Represents method BasicNumberCompaction(byte[],integer,integer).
BreakString | Represents method BreakString.
ByteCompaction(integer,integer) | Represents method ByteCompaction(integer,integer).
ByteCompaction6(integer) | Represents method ByteCompaction6(integer).
CalculateErrorCorrection(integer) | Represents method CalculateErrorCorrection(integer).
CheckSegmentType(Segment,char) | Represents method CheckSegmentType(Segment,char).
ClearFigures | Represents method ClearFigures. (Inherited from TfrxBarcode2DBaseWithUnion.)
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer). (Inherited from TfrxBarcode2DBase.)
FillRect(TCanvas,TRect) | Represents method FillRect(TCanvas,TRect). (Inherited from TfrxBarcode2DBase.)
FVectorPrimitivesAdd(Integer,Integer,Integer,Integer) | Represents method FVectorPrimitivesAdd(Integer,Integer,Integer,Integer). (Inherited from TfrxBarcode2DBaseWithUnion.)
GetFooterHeight | Represents method GetFooterHeight. (Inherited from TfrxBarcode2DBase.)
GetHeight | Represents method GetHeight. (Inherited from TfrxBarcode2DBase.)
GetMaxSquare | Represents method GetMaxSquare.
GetSegmentLength(Segment) | Represents method GetSegmentLength(Segment).
GetTextTypeAndValue(byte[],integer,integer) | Overloaded. Represents method GetTextTypeAndValue(byte[],integer,integer).
GetTextTypeAndValue(integer,integer) | Overloaded. Represents method GetTextTypeAndValue(integer,integer).
GetWidth | Represents method GetWidth. (Inherited from TfrxBarcode2DBase.)
Initialize | Represents method Initialize.
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended). (Overrides TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).)
IsScaled | Represents method IsScaled. (Inherited from TfrxBarcode2DBase.)
MaxPossibleErrorLevel(integer) | Represents method MaxPossibleErrorLevel(integer).
NumberCompaction(byte[],integer,integer) | Overloaded. Represents method NumberCompaction(byte[],integer,integer).
NumberCompaction(integer,integer) | Overloaded. Represents method NumberCompaction(integer,integer).
OutCodeword(integer) | Represents method OutCodeword(integer).
OutCodeword17(integer) | Represents method OutCodeword17(integer).
OutCodeword18(integer) | Represents method OutCodeword18(integer).
OutPaintCode | Represents method OutPaintCode.
OutStartPattern | Represents method OutStartPattern.
OutStopPattern | Represents method OutStopPattern.
PaintCode | Represents method PaintCode.
SetAspectRatio(extended) | Represents method SetAspectRatio(extended).
SetCodePage(integer) | Represents method SetCodePage(integer).
SetColor(TColor) | Represents method SetColor(TColor). (Inherited from TfrxBarcode2DBase.)
SetColorBar(TColor) | Represents method SetColorBar(TColor). (Inherited from TfrxBarcode2DBase.)
SetColumns(integer) | Represents method SetColumns(integer).
SetCompactionMode(PDF417CompactionMode) | Represents method SetCompactionMode(PDF417CompactionMode).
SetErrorCorrection(PDF417ErrorCorrection) | Represents method SetErrorCorrection(PDF417ErrorCorrection).
SetErrorText(String) | Represents method SetErrorText(String). (Inherited from TfrxBarcode2DBase.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxBarcode2DBase.)
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean). (Inherited from TfrxBarcode2DBase.)
SetHeight(Integer) | Represents method SetHeight(Integer). (Inherited from TfrxBarcode2DBase.)
SetRotation(Integer) | Represents method SetRotation(Integer). (Inherited from TfrxBarcode2DBase.)
SetRows(integer) | Represents method SetRows(integer).
SetShowText(Boolean) | Represents method SetShowText(Boolean). (Inherited from TfrxBarcode2DBase.)
SetText(string) | Represents method SetText(string). (Overrides TfrxBarcode2DBase.SetText(String).)
SetZoom(Extended) | Represents method SetZoom(Extended). (Inherited from TfrxBarcode2DBase.)
T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte) | Represents method T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte). (Inherited from TfrxBarcode2DBaseWithUnion.)
TextCompaction(byte[],integer,integer) | Overloaded. Represents method TextCompaction(byte[],integer,integer).
TextCompaction(integer,integer) | Overloaded. Represents method TextCompaction(integer,integer).
Top
Fields
Show:
Name | Description
arrOB | Represents field arrOB.
bitPtr | Represents field bitPtr.
bytes | Represents field bytes.
codeColumns | Represents field codeColumns.
codewords | Represents field codewords.
cwPtr | Represents field cwPtr.
DotsL | Represents field DotsL. (Inherited from TfrxBarcode2DBaseWithUnion.)
DotsR | Represents field DotsR. (Inherited from TfrxBarcode2DBaseWithUnion.)
errorLevel | Represents field errorLevel.
FAspectRatio | Represents field FAspectRatio.
FCodePage | Represents field FCodePage.
FColor | Represents field FColor. (Inherited from TfrxBarcode2DBase.)
FColorBar | Represents field FColorBar. (Inherited from TfrxBarcode2DBase.)
FColumns | Represents field FColumns.
FCompactionMode | Represents field FCompactionMode.
FErrorCorrection | Represents field FErrorCorrection.
FErrorText | Represents field FErrorText. (Inherited from TfrxBarcode2DBase.)
FFont | Represents field FFont. (Inherited from TfrxBarcode2DBase.)
FFontScaled | Represents field FFontScaled. (Inherited from TfrxBarcode2DBase.)
FHeight | Represents field FHeight. (Inherited from TfrxBarcode2DBase.)
FImage | Represents field FImage.
FPixelHeight | Represents field FPixelHeight. (Inherited from TfrxBarcode2DBase.)
FPixelWidth | Represents field FPixelWidth. (Inherited from TfrxBarcode2DBase.)
FQuietZone | Represents field FQuietZone. (Inherited from TfrxBarcode2DBase.)
FRotation | Represents field FRotation. (Inherited from TfrxBarcode2DBase.)
FRows | Represents field FRows.
FShowText | Represents field FShowText. (Inherited from TfrxBarcode2DBase.)
FText | Represents field FText. (Inherited from TfrxBarcode2DBase.)
FVectorPrimitives | Represents field FVectorPrimitives. (Inherited from TfrxBarcode2DBaseWithUnion.)
FWidth | Represents field FWidth. (Inherited from TfrxBarcode2DBase.)
FZoom | Represents field FZoom. (Inherited from TfrxBarcode2DBase.)
lenCodewords | Represents field lenCodewords.
segmentList | Represents field segmentList.
Top
Examples

This example shows how to configure the BarcodeObject to display PDF417 barcode.

Code
BarcodeObject barcode;
...
barcode.Barcode = new BarcodePDF417();
(barcode.Barcode as BarcodePDF417).CompactionMode = PDF417CompactionMode.Text;

See Also

Reference

  • frxBarcodePDF417


TfrxBarcodePDF417 Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxBarcodePDF417 class. (Overrides TfrxBarcode2DBaseWithUnion.Create.)
Destroy | Represents the destructor of the TfrxBarcodePDF417 class. (Overrides TfrxBarcode2DBaseWithUnion.Destroy.)
Top


TfrxBarcodePDF417.Create Constructor

Summary

Initializes a new instance of the TfrxBarcodePDF417 class.

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 constructor Create; override;

Overrides

TfrxBarcode2DBaseWithUnion.Create
See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.Destroy Destructor

Summary

Represents the destructor of the TfrxBarcodePDF417 class.

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxBarcode2DBaseWithUnion.Destroy
See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417 Properties

Properties
Name | Description
AspectRatio |
CodePage |
Columns |
CompactionMode |
ErrorCorrection |
Rows |
Top


TfrxBarcodePDF417.AspectRatio Property

Namespace: frxBarcodePDF417
Syntax
Delphi
published
 property AspectRatio : extended read FAspectRatio write SetAspectRatio;

Property Value

Type: extended

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.CodePage Property

Namespace: frxBarcodePDF417
Syntax
Delphi
published
 property CodePage : integer read FCodePage write SetCodePage;

Property Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.Columns Property

Namespace: frxBarcodePDF417
Syntax
Delphi
published
 property Columns : integer read FColumns write SetColumns;

Property Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.CompactionMode Property

Namespace: frxBarcodePDF417
Syntax
Delphi
published
 property CompactionMode : PDF417CompactionMode read FCompactionMode write SetCompactionMode;

Property Value

Type: PDF417CompactionMode

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.ErrorCorrection Property

Namespace: frxBarcodePDF417
Syntax
Delphi
published
 property ErrorCorrection : PDF417ErrorCorrection read FErrorCorrection write SetErrorCorrection;

Property Value

Type: PDF417ErrorCorrection

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.Rows Property

Namespace: frxBarcodePDF417
Syntax
Delphi
published
 property Rows : integer read FRows write SetRows;

Property Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417 Methods

Methods
Name | Description
Assemble | Represents method Assemble.
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
BasicNumberCompaction(byte[],integer,integer) | Overloaded. Represents method BasicNumberCompaction(byte[],integer,integer).
BreakString | Represents method BreakString.
ByteCompaction(integer,integer) | Represents method ByteCompaction(integer,integer).
ByteCompaction6(integer) | Represents method ByteCompaction6(integer).
CalculateErrorCorrection(integer) | Represents method CalculateErrorCorrection(integer).
CheckSegmentType(Segment,char) | Represents method CheckSegmentType(Segment,char).
GetMaxSquare | Represents method GetMaxSquare.
GetSegmentLength(Segment) | Represents method GetSegmentLength(Segment).
GetTextTypeAndValue(byte[],integer,integer) | Overloaded. Represents method GetTextTypeAndValue(byte[],integer,integer).
GetTextTypeAndValue(integer,integer) | Overloaded. Represents method GetTextTypeAndValue(integer,integer).
Initialize | Represents method Initialize.
MaxPossibleErrorLevel(integer) | Represents method MaxPossibleErrorLevel(integer).
NumberCompaction(byte[],integer,integer) | Overloaded. Represents method NumberCompaction(byte[],integer,integer).
NumberCompaction(integer,integer) | Overloaded. Represents method NumberCompaction(integer,integer).
OutCodeword(integer) | Represents method OutCodeword(integer).
OutCodeword17(integer) | Represents method OutCodeword17(integer).
OutCodeword18(integer) | Represents method OutCodeword18(integer).
OutPaintCode | Represents method OutPaintCode.
OutStartPattern | Represents method OutStartPattern.
OutStopPattern | Represents method OutStopPattern.
PaintCode | Represents method PaintCode.
SetAspectRatio(extended) | Represents method SetAspectRatio(extended).
SetCodePage(integer) | Represents method SetCodePage(integer).
SetColumns(integer) | Represents method SetColumns(integer).
SetCompactionMode(PDF417CompactionMode) | Represents method SetCompactionMode(PDF417CompactionMode).
SetErrorCorrection(PDF417ErrorCorrection) | Represents method SetErrorCorrection(PDF417ErrorCorrection).
SetRows(integer) | Represents method SetRows(integer).
SetText(string) | Represents method SetText(string). (Overrides TfrxBarcode2DBase.SetText(String).)
TextCompaction(byte[],integer,integer) | Overloaded. Represents method TextCompaction(byte[],integer,integer).
TextCompaction(integer,integer) | Overloaded. Represents method TextCompaction(integer,integer).
Top


TfrxBarcodePDF417.Assemble Method

Summary

Represents method Assemble.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure Assemble;
See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.Assign(TfrxBarcode2DBase) Method

Summary

Represents method Assign(TfrxBarcode2DBase).

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 procedure Assign( source : TfrxBarcode2DBase ); override;

Parameters

source
Type: TfrxBarcode2DBase

Overrides

TfrxBarcode2DBase.Assign(TfrxBarcode2DBase)
See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.BasicNumberCompaction(byte[],integer,integer) Method

Summary

Represents method BasicNumberCompaction(byte[],integer,integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure BasicNumberCompaction(var input : array of byte; start, length : integer); overload;

Parameters

input
Type: array of byte

start
Type: integer

length
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.BreakString Method

Summary

Represents method BreakString.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure BreakString;
See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.ByteCompaction(integer,integer) Method

Summary

Represents method ByteCompaction(integer,integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure ByteCompaction( start, length : integer);

Parameters

start
Type: integer

length
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.ByteCompaction6(integer) Method

Summary

Represents method ByteCompaction6(integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure ByteCompaction6( start : integer );

Parameters

start
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.CalculateErrorCorrection(integer) Method

Summary

Represents method CalculateErrorCorrection(integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure CalculateErrorCorrection(dest : integer);

Parameters

dest
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.CheckSegmentType(Segment,char) Method

Summary

Represents method CheckSegmentType(Segment,char).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 function CheckSegmentType( var segm : Segment; typ : char) : boolean;

Parameters

segm
Type: Segment

typ
Type: char

Return Value

Type: boolean

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.GetMaxSquare Method

Summary

Represents method GetMaxSquare.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 function GetMaxSquare : integer;

Return Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.GetSegmentLength(Segment) Method

Summary

Represents method GetSegmentLength(Segment).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 function GetSegmentLength( var segm : Segment ) : integer;

Parameters

segm
Type: Segment

Return Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.GetTextTypeAndValue(byte[],integer,integer) Method

Summary

Represents method GetTextTypeAndValue(byte[],integer,integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 function GetTextTypeAndValue( var input : array of byte; maxLength, idx : integer ) : integer; overload;

Parameters

input
Type: array of byte

maxLength
Type: integer

idx
Type: integer

Return Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.GetTextTypeAndValue(integer,integer) Method

Summary

Represents method GetTextTypeAndValue(integer,integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 function GetTextTypeAndValue(maxLength, idx : integer) : integer; overload;

Parameters

maxLength
Type: integer

idx
Type: integer

Return Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.Initialize Method

Summary

Represents method Initialize.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure Initialize;
See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.MaxPossibleErrorLevel(integer) Method

Summary

Represents method MaxPossibleErrorLevel(integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 function MaxPossibleErrorLevel( remain: integer) : integer;

Parameters

remain
Type: integer

Return Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.NumberCompaction(byte[],integer,integer) Method

Summary

Represents method NumberCompaction(byte[],integer,integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure NumberCompaction(var input : array of byte; start,length : integer); overload;

Parameters

input
Type: array of byte

start
Type: integer

length
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.NumberCompaction(integer,integer) Method

Summary

Represents method NumberCompaction(integer,integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure NumberCompaction( start, length : integer); overload;

Parameters

start
Type: integer

length
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.OutCodeword(integer) Method

Summary

Represents method OutCodeword(integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure OutCodeword( codeword : integer );

Parameters

codeword
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.OutCodeword17(integer) Method

Summary

Represents method OutCodeword17(integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure OutCodeword17( codeword : integer);

Parameters

codeword
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.OutCodeword18(integer) Method

Summary

Represents method OutCodeword18(integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure OutCodeword18( codeword : integer);

Parameters

codeword
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.OutPaintCode Method

Summary

Represents method OutPaintCode.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure OutPaintCode;
See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.OutStartPattern Method

Summary

Represents method OutStartPattern.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure OutStartPattern;
See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.OutStopPattern Method

Summary

Represents method OutStopPattern.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure OutStopPattern;
See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.PaintCode Method

Summary

Represents method PaintCode.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure PaintCode;
See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.SetAspectRatio(extended) Method

Summary

Represents method SetAspectRatio(extended).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure SetAspectRatio(v : extended);

Parameters

v
Type: extended

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.SetCodePage(integer) Method

Summary

Represents method SetCodePage(integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure SetCodePage(v : integer);

Parameters

v
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.SetColumns(integer) Method

Summary

Represents method SetColumns(integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure SetColumns(v : integer);

Parameters

v
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.SetCompactionMode(PDF417CompactionMode) Method

Summary

Represents method SetCompactionMode(PDF417CompactionMode).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure SetCompactionMode(v : PDF417CompactionMode);

Parameters

v
Type: PDF417CompactionMode

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.SetErrorCorrection(PDF417ErrorCorrection) Method

Summary

Represents method SetErrorCorrection(PDF417ErrorCorrection).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure SetErrorCorrection(v : PDF417ErrorCorrection);

Parameters

v
Type: PDF417ErrorCorrection

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.SetRows(integer) Method

Summary

Represents method SetRows(integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure SetRows(v : integer);

Parameters

v
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.SetText(string) Method

Summary

Represents method SetText(string).

Namespace: frxBarcodePDF417
Syntax
Delphi
protected
 procedure SetText(v : string); override;

Parameters

v
Type: string

Overrides

TfrxBarcode2DBase.SetText(String)
See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.TextCompaction(byte[],integer,integer) Method

Summary

Represents method TextCompaction(byte[],integer,integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure TextCompaction(var input : array of byte; start, length : integer); overload;

Parameters

input
Type: array of byte

start
Type: integer

length
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.TextCompaction(integer,integer) Method

Summary

Represents method TextCompaction(integer,integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 procedure TextCompaction( start, length : integer); overload;

Parameters

start
Type: integer

length
Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417 Fields

Fields
Name | Description
arrOB | Represents field arrOB.
bitPtr | Represents field bitPtr.
bytes | Represents field bytes.
codeColumns | Represents field codeColumns.
codewords | Represents field codewords.
cwPtr | Represents field cwPtr.
errorLevel | Represents field errorLevel.
FAspectRatio | Represents field FAspectRatio.
FCodePage | Represents field FCodePage.
FColumns | Represents field FColumns.
FCompactionMode | Represents field FCompactionMode.
FErrorCorrection | Represents field FErrorCorrection.
FImage | Represents field FImage.
FRows | Represents field FRows.
lenCodewords | Represents field lenCodewords.
segmentList | Represents field segmentList.
Top


TfrxBarcodePDF417.arrOB Field

Summary

Represents field arrOB.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 arrOB: T2DBooleanArray;

Field Value

Type: T2DBooleanArray

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.bitPtr Field

Summary

Represents field bitPtr.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 FCodePage,
 bitPtr,
 cwPtr : integer;

Field Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.bytes Field

Summary

Represents field bytes.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 bytes : array of byte;

Field Value

Type: array of byte

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.codeColumns Field

Summary

Represents field codeColumns.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 codeColumns,
 FRows,
 FColumns : integer;

Field Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.codewords Field

Summary

Represents field codewords.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 codewords : array[0 .. MAX_DATA_CODEWORDS + 1] of integer;

Field Value

Type: array[0 .. MAX_DATA_CODEWORDS + 1] of integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.cwPtr Field

Summary

Represents field cwPtr.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 FCodePage,
 bitPtr,
 cwPtr : integer;

Field Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.errorLevel Field

Summary

Represents field errorLevel.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 lenCodewords,
 errorLevel : integer;

Field Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.FAspectRatio Field

Summary

Represents field FAspectRatio.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 FAspectRatio : extended;

Field Value

Type: extended

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.FCodePage Field

Summary

Represents field FCodePage.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 FCodePage,
 bitPtr,
 cwPtr : integer;

Field Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.FColumns Field

Summary

Represents field FColumns.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 codeColumns,
 FRows,
 FColumns : integer;

Field Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.FCompactionMode Field

Summary

Represents field FCompactionMode.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 FCompactionMode : PDF417CompactionMode;

Field Value

Type: PDF417CompactionMode

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.FErrorCorrection Field

Summary

Represents field FErrorCorrection.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 FErrorCorrection : PDF417ErrorCorrection;

Field Value

Type: PDF417ErrorCorrection

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.FImage Field

Summary

Represents field FImage.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 FImage: array of Byte;

Field Value

Type: array of Byte

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.FRows Field

Summary

Represents field FRows.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 codeColumns,
 FRows,
 FColumns : integer;

Field Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.lenCodewords Field

Summary

Represents field lenCodewords.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 lenCodewords,
 errorLevel : integer;

Field Value

Type: integer

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TfrxBarcodePDF417.segmentList Field

Summary

Represents field segmentList.

Namespace: frxBarcodePDF417
Syntax
Delphi
private
 segmentList : TSegmentList;

Field Value

Type: TSegmentList

See Also

Reference

  • TfrxBarcodePDF417
  • frxBarcodePDF417


TSegmentList Class

Summary

Represents type TSegmentList.

Namespace: frxBarcodePDF417
Inheritance Hierarchy
TObject
frxBarcodePDF417.TSegmentList
Syntax
Delphi
type
 TSegmentList = class(TObject)
 end;

The TSegmentList type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TSegmentList class.
Destroy | Represents the destructor of the TSegmentList class.
Top
Methods
Show:
Name | Description
Add(char,integer,integer) | Represents method Add(char,integer,integer).
Get(integer) | Represents method Get(integer).
Remove(integer) | Represents method Remove(integer).
Size | Represents method Size.
Top
Fields
Show:
Name | Description
List | Represents field List.
Top
See Also

Reference

  • frxBarcodePDF417


TSegmentList Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TSegmentList class.
Destroy | Represents the destructor of the TSegmentList class.
Top


TSegmentList.Create Constructor

Summary

Initializes a new instance of the TSegmentList class.

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TSegmentList
  • frxBarcodePDF417


TSegmentList.Destroy Destructor

Summary

Represents the destructor of the TSegmentList class.

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TSegmentList
  • frxBarcodePDF417


TSegmentList Methods

Methods
Name | Description
Add(char,integer,integer) | Represents method Add(char,integer,integer).
Get(integer) | Represents method Get(integer).
Remove(integer) | Represents method Remove(integer).
Size | Represents method Size.
Top


TSegmentList.Add(char,integer,integer) Method

Summary

Represents method Add(char,integer,integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 procedure Add(_type: char; _start,_end : integer);

Parameters

_type
Type: char

_start
Type: integer

_end
Type: integer

See Also

Reference

  • TSegmentList
  • frxBarcodePDF417


TSegmentList.Get(integer) Method

Summary

Represents method Get(integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 function Get(idx : integer) : Segment;

Parameters

idx
Type: integer

Return Value

Type: Segment

See Also

Reference

  • TSegmentList
  • frxBarcodePDF417


TSegmentList.Remove(integer) Method

Summary

Represents method Remove(integer).

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 procedure Remove( idx : integer);

Parameters

idx
Type: integer

See Also

Reference

  • TSegmentList
  • frxBarcodePDF417


TSegmentList.Size Method

Summary

Represents method Size.

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 function Size : integer;

Return Value

Type: integer

See Also

Reference

  • TSegmentList
  • frxBarcodePDF417


TSegmentList Fields

Fields
Name | Description
List | Represents field List.
Top


TSegmentList.List Field

Summary

Represents field List.

Namespace: frxBarcodePDF417
Syntax
Delphi
public
 List : TList;

Field Value

Type: TList

See Also

Reference

  • TSegmentList
  • frxBarcodePDF417


frxBarcodePDF417 Enumerations

Enumerations
Name | Description
PDF417CompactionMode |
PDF417ErrorCorrection |
Top


PDF417CompactionMode Enumeration

Namespace: frxBarcodePDF417
Syntax
Delphi
type
 PDF417CompactionMode =
 (
 AutoCompaction,
 TextComp,
 Numeric,
 Binary
 );

The PDF417CompactionMode type exposes the following members.

Members
Show:
Name | Description
AutoCompaction | Represents constant AutoCompaction.
Binary | Represents constant Binary.
Numeric | Represents constant Numeric.
TextComp | Represents constant TextComp.
Top
See Also

Reference

  • frxBarcodePDF417


PDF417ErrorCorrection Enumeration

Namespace: frxBarcodePDF417
Syntax
Delphi
type
 PDF417ErrorCorrection =
 (
 AutoCorr,
 Level0,
 Level1,
 Level2,
 Level3,
 Level4,
 Level5,
 Level6,
 Level7,
 Level8
 );

The PDF417ErrorCorrection type exposes the following members.

Members
Show:
Name | Description
AutoCorr | Represents constant AutoCorr.
Level0 | Represents constant Level0.
Level1 | Represents constant Level1.
Level2 | Represents constant Level2.
Level3 | Represents constant Level3.
Level4 | Represents constant Level4.
Level5 | Represents constant Level5.
Level6 | Represents constant Level6.
Level7 | Represents constant Level7.
Level8 | Represents constant Level8.
Top
See Also

Reference

  • frxBarcodePDF417


frxBarcodePDF417 Types

Types
Name | Description
PInt | Represents a pointer type to TInt.
TInt | Represents an array of the integer type.
Top


PInt Type

Summary

Represents a pointer type to TInt.

Namespace: frxBarcodePDF417
Syntax
Delphi
type
 PInt = ^TInt;
See Also

Reference

  • frxBarcodePDF417


TInt Type

Summary

Represents an array of the integer type.

Namespace: frxBarcodePDF417
Syntax
Delphi
type
 TInt = array of integer;
See Also

Reference

  • frxBarcodePDF417


frxBarcodePDF417 Constants

Constants
Name | Description
ABSOLUTE_MAX_TEXT_SIZE | Represents constant ABSOLUTE_MAX_TEXT_SIZE.
AL | Represents constant AL.
ALPHA | Represents constant ALPHA.
BYTESHIFT | Represents constant BYTESHIFT.
BYTE_MODE | Represents constant BYTE_MODE.
BYTE_MODE_6 | Represents constant BYTE_MODE_6.
CLUSTERS | Represents constant CLUSTERS.
ERRLVL0 | Represents constant ERRLVL0.
ERRLVL1 | Represents constant ERRLVL1.
ERRLVL2 | Represents constant ERRLVL2.
ERRLVL3 | Represents constant ERRLVL3.
ERRLVL4 | Represents constant ERRLVL4.
ERRLVL5 | Represents constant ERRLVL5.
ERRLVL6 | Represents constant ERRLVL6.
ERRLVL7 | Represents constant ERRLVL7.
ERRLVL8 | Represents constant ERRLVL8.
ERROR_LEVEL | Represents constant ERROR_LEVEL.
ISBYTE | Represents constant ISBYTE.
LL | Represents constant LL.
LOWER | Represents constant LOWER.
MACRO_LAST_SEGMENT | Represents constant MACRO_LAST_SEGMENT.
MACRO_SEGMENT_ID | Represents constant MACRO_SEGMENT_ID.
MAX_DATA_CODEWORDS | Represents constant MAX_DATA_CODEWORDS.
MIXED | Represents constant MIXED.
MIXED_SET | Represents constant MIXED_SET.
ML | Represents constant ML.
NUMERIC_MODE | Represents constant NUMERIC_MODE.
PAL | Represents constant PAL.
PL | Represents constant PL.
PS | Represents constant PS.
PUNCTUATION | Represents constant PUNCTUATION.
PUNCTUATION_SET | Represents constant PUNCTUATION_SET.
SPACE | Represents constant SPACE.
START_CODE_SIZE | Represents constant START_CODE_SIZE.
START_PATTERN | Represents constant START_PATTERN.
STOP_PATTERN | Represents constant STOP_PATTERN.
STOP_SIZE | Represents constant STOP_SIZE.
TEXT_MODE | Represents constant TEXT_MODE.
_AS | Represents constant _AS.
_MOD | Represents constant _MOD.
Top


ABSOLUTE_MAX_TEXT_SIZE Constant

Summary

Represents constant ABSOLUTE_MAX_TEXT_SIZE.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ABSOLUTE_MAX_TEXT_SIZE = 5420;

Value

Type: SmallInt

See Also

Reference

  • frxBarcodePDF417


AL Constant

Summary

Represents constant AL.

Namespace: frxBarcodePDF417
Syntax
Delphi
 AL = 28;

Value

Type: ShortInt

See Also

Reference

  • frxBarcodePDF417


ALPHA Constant

Summary

Represents constant ALPHA.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ALPHA = $10000;

Value

Type: Integer

See Also

Reference

  • frxBarcodePDF417


BYTESHIFT Constant

Summary

Represents constant BYTESHIFT.

Namespace: frxBarcodePDF417
Syntax
Delphi
 BYTESHIFT = 913;

Value

Type: SmallInt

See Also

Reference

  • frxBarcodePDF417


BYTE_MODE Constant

Summary

Represents constant BYTE_MODE.

Namespace: frxBarcodePDF417
Syntax
Delphi
 BYTE_MODE = 901;

Value

Type: SmallInt

See Also

Reference

  • frxBarcodePDF417


BYTE_MODE_6 Constant

Summary

Represents constant BYTE_MODE_6.

Namespace: frxBarcodePDF417
Syntax
Delphi
 BYTE_MODE_6 = 924;

Value

Type: SmallInt

See Also

Reference

  • frxBarcodePDF417


CLUSTERS Constant

Summary

Represents constant CLUSTERS.

Namespace: frxBarcodePDF417
Syntax
Delphi
 CLUSTERS : array[0..2,0..928] of integer =
 (
 (
 $1d5c0, $1eaf0, $1f57c, $1d4e0, $1ea78, $1f53e, $1a8c0, $1d470,
 $1a860, $15040, $1a830, $15020, $1adc0, $1d6f0, $1eb7c, $1ace0,
 $1d678, $1eb3e, $158c0, $1ac70, $15860, $15dc0, $1aef0, $1d77c,
 $15ce0, $1ae78, $1d73e, $15c70, $1ae3c, $15ef0, $1af7c, $15e78,
 $1af3e, $15f7c, $1f5fa, $1d2e0, $1e978, $1f4be, $1a4c0, $1d270,
 $1e93c, $1a460, $1d238, $14840, $1a430, $1d21c, $14820, $1a418,
 $14810, $1a6e0, $1d378, $1e9be, $14cc0, $1a670, $1d33c, $14c60,
 $1a638, $1d31e, $14c30, $1a61c, $14ee0, $1a778, $1d3be, $14e70,
 $1a73c, $14e38, $1a71e, $14f78, $1a7be, $14f3c, $14f1e, $1a2c0,
 $1d170, $1e8bc, $1a260, $1d138, $1e89e, $14440, $1a230, $1d11c,
 $14420, $1a218, $14410, $14408, $146c0, $1a370, $1d1bc, $14660,
 $1a338, $1d19e, $14630, $1a31c, $14618, $1460c, $14770, $1a3bc,
 $14738, $1a39e, $1471c, $147bc, $1a160, $1d0b8, $1e85e, $14240,
 $1a130, $1d09c, $14220, $1a118, $1d08e, $14210, $1a10c, $14208,
 $1a106, $14360, $1a1b8, $1d0de, $14330, $1a19c, $14318, $1a18e,
 $1430c, $14306, $1a1de, $1438e, $14140, $1a0b0, $1d05c, $14120,
 $1a098, $1d04e, $14110, $1a08c, $14108, $1a086, $14104, $141b0,
 $14198, $1418c, $140a0, $1d02e, $1a04c, $1a046, $14082, $1cae0,
 $1e578, $1f2be, $194c0, $1ca70, $1e53c, $19460, $1ca38, $1e51e,
 $12840, $19430, $12820, $196e0, $1cb78, $1e5be, $12cc0, $19670,
 $1cb3c, $12c60, $19638, $12c30, $12c18, $12ee0, $19778, $1cbbe,
 $12e70, $1973c, $12e38, $12e1c, $12f78, $197be, $12f3c, $12fbe,
 $1dac0, $1ed70, $1f6bc, $1da60, $1ed38, $1f69e, $1b440, $1da30,
 $1ed1c, $1b420, $1da18, $1ed0e, $1b410, $1da0c, $192c0, $1c970,
 $1e4bc, $1b6c0, $19260, $1c938, $1e49e, $1b660, $1db38, $1ed9e,
 $16c40, $12420, $19218, $1c90e, $16c20, $1b618, $16c10, $126c0,
 $19370, $1c9bc, $16ec0, $12660, $19338, $1c99e, $16e60, $1b738,
 $1db9e, $16e30, $12618, $16e18, $12770, $193bc, $16f70, $12738,
 $1939e, $16f38, $1b79e, $16f1c, $127bc, $16fbc, $1279e, $16f9e,
 $1d960, $1ecb8, $1f65e, $1b240, $1d930, $1ec9c, $1b220, $1d918,
 $1ec8e, $1b210, $1d90c, $1b208, $1b204, $19160, $1c8b8, $1e45e,
 $1b360, $19130, $1c89c, $16640, $12220, $1d99c, $1c88e, $16620,
 $12210, $1910c, $16610, $1b30c, $19106, $12204, $12360, $191b8,
 $1c8de, $16760, $12330, $1919c, $16730, $1b39c, $1918e, $16718,
 $1230c, $12306, $123b8, $191de, $167b8, $1239c, $1679c, $1238e,
 $1678e, $167de, $1b140, $1d8b0, $1ec5c, $1b120, $1d898, $1ec4e,
 $1b110, $1d88c, $1b108, $1d886, $1b104, $1b102, $12140, $190b0,
 $1c85c, $16340, $12120, $19098, $1c84e, $16320, $1b198, $1d8ce,
 $16310, $12108, $19086, $16308, $1b186, $16304, $121b0, $190dc,
 $163b0, $12198, $190ce, $16398, $1b1ce, $1638c, $12186, $16386,
 $163dc, $163ce, $1b0a0, $1d858, $1ec2e, $1b090, $1d84c, $1b088,
 $1d846, $1b084, $1b082, $120a0, $19058, $1c82e, $161a0, $12090,
 $1904c, $16190, $1b0cc, $19046, $16188, $12084, $16184, $12082,
 $120d8, $161d8, $161cc, $161c6, $1d82c, $1d826, $1b042, $1902c,
 $12048, $160c8, $160c4, $160c2, $18ac0, $1c570, $1e2bc, $18a60,
 $1c538, $11440, $18a30, $1c51c, $11420, $18a18, $11410, $11408,
 $116c0, $18b70, $1c5bc, $11660, $18b38, $1c59e, $11630, $18b1c,
 $11618, $1160c, $11770, $18bbc, $11738, $18b9e, $1171c, $117bc,
 $1179e, $1cd60, $1e6b8, $1f35e, $19a40, $1cd30, $1e69c, $19a20,
 $1cd18, $1e68e, $19a10, $1cd0c, $19a08, $1cd06, $18960, $1c4b8,
 $1e25e, $19b60, $18930, $1c49c, $13640, $11220, $1cd9c, $1c48e,
 $13620, $19b18, $1890c, $13610, $11208, $13608, $11360, $189b8,
 $1c4de, $13760, $11330, $1cdde, $13730, $19b9c, $1898e, $13718,
 $1130c, $1370c, $113b8, $189de, $137b8, $1139c, $1379c, $1138e,
 $113de, $137de, $1dd40, $1eeb0, $1f75c, $1dd20, $1ee98, $1f74e,
 $1dd10, $1ee8c, $1dd08, $1ee86, $1dd04, $19940, $1ccb0, $1e65c,
 $1bb40, $19920, $1eedc, $1e64e, $1bb20, $1dd98, $1eece, $1bb10,
 $19908, $1cc86, $1bb08, $1dd86, $19902, $11140, $188b0, $1c45c,
 $13340, $11120, $18898, $1c44e, $17740, $13320, $19998, $1ccce,
 $17720, $1bb98, $1ddce, $18886, $17710, $13308, $19986, $17708,
 $11102, $111b0, $188dc, $133b0, $11198, $188ce, $177b0, $13398,
 $199ce, $17798, $1bbce, $11186, $13386, $111dc, $133dc, $111ce,
 $177dc, $133ce, $1dca0, $1ee58, $1f72e, $1dc90, $1ee4c, $1dc88,
 $1ee46, $1dc84, $1dc82, $198a0, $1cc58, $1e62e, $1b9a0, $19890,
 $1ee6e, $1b990, $1dccc, $1cc46, $1b988, $19884, $1b984, $19882,
 $1b982, $110a0, $18858, $1c42e, $131a0, $11090, $1884c, $173a0,
 $13190, $198cc, $18846, $17390, $1b9cc, $11084, $17388, $13184,
 $11082, $13182, $110d8, $1886e, $131d8, $110cc, $173d8, $131cc,
 $110c6, $173cc, $131c6, $110ee, $173ee, $1dc50, $1ee2c, $1dc48,
 $1ee26, $1dc44, $1dc42, $19850, $1cc2c, $1b8d0, $19848, $1cc26,
 $1b8c8, $1dc66, $1b8c4, $19842, $1b8c2, $11050, $1882c, $130d0,
 $11048, $18826, $171d0, $130c8, $19866, $171c8, $1b8e6, $11042,
 $171c4, $130c2, $171c2, $130ec, $171ec, $171e6, $1ee16, $1dc22,
 $1cc16, $19824, $19822, $11028, $13068, $170e8, $11022, $13062,
 $18560, $10a40, $18530, $10a20, $18518, $1c28e, $10a10, $1850c,
 $10a08, $18506, $10b60, $185b8, $1c2de, $10b30, $1859c, $10b18,
 $1858e, $10b0c, $10b06, $10bb8, $185de, $10b9c, $10b8e, $10bde,
 $18d40, $1c6b0, $1e35c, $18d20, $1c698, $18d10, $1c68c, $18d08,
 $1c686, $18d04, $10940, $184b0, $1c25c, $11b40, $10920, $1c6dc,
 $1c24e, $11b20, $18d98, $1c6ce, $11b10, $10908, $18486, $11b08,
 $18d86, $10902, $109b0, $184dc, $11bb0, $10998, $184ce, $11b98,
 $18dce, $11b8c, $10986, $109dc, $11bdc, $109ce, $11bce, $1cea0,
 $1e758, $1f3ae, $1ce90, $1e74c, $1ce88, $1e746, $1ce84, $1ce82,
 $18ca0, $1c658, $19da0, $18c90, $1c64c, $19d90, $1cecc, $1c646,
 $19d88, $18c84, $19d84, $18c82, $19d82, $108a0, $18458, $119a0,
 $10890, $1c66e, $13ba0, $11990, $18ccc, $18446, $13b90, $19dcc,
 $10884, $13b88, $11984, $10882, $11982, $108d8, $1846e, $119d8,
 $108cc, $13bd8, $119cc, $108c6, $13bcc, $119c6, $108ee, $119ee,
 $13bee, $1ef50, $1f7ac, $1ef48, $1f7a6, $1ef44, $1ef42, $1ce50,
 $1e72c, $1ded0, $1ef6c, $1e726, $1dec8, $1ef66, $1dec4, $1ce42,
 $1dec2, $18c50, $1c62c, $19cd0, $18c48, $1c626, $1bdd0, $19cc8,
 $1ce66, $1bdc8, $1dee6, $18c42, $1bdc4, $19cc2, $1bdc2, $10850,
 $1842c, $118d0, $10848, $18426, $139d0, $118c8, $18c66, $17bd0,
 $139c8, $19ce6, $10842, $17bc8, $1bde6, $118c2, $17bc4, $1086c,
 $118ec, $10866, $139ec, $118e6, $17bec, $139e6, $17be6, $1ef28,
 $1f796, $1ef24, $1ef22, $1ce28, $1e716, $1de68, $1ef36, $1de64,
 $1ce22, $1de62, $18c28, $1c616, $19c68, $18c24, $1bce8, $19c64,
 $18c22, $1bce4, $19c62, $1bce2, $10828, $18416, $11868, $18c36,
 $138e8, $11864, $10822, $179e8, $138e4, $11862, $179e4, $138e2,
 $179e2, $11876, $179f6, $1ef12, $1de34, $1de32, $19c34, $1bc74,
 $1bc72, $11834, $13874, $178f4, $178f2, $10540, $10520, $18298,
 $10510, $10508, $10504, $105b0, $10598, $1058c, $10586, $105dc,
 $105ce, $186a0, $18690, $1c34c, $18688, $1c346, $18684, $18682,
 $104a0, $18258, $10da0, $186d8, $1824c, $10d90, $186cc, $10d88,
 $186c6, $10d84, $10482, $10d82, $104d8, $1826e, $10dd8, $186ee,
 $10dcc, $104c6, $10dc6, $104ee, $10dee, $1c750, $1c748, $1c744,
 $1c742, $18650, $18ed0, $1c76c, $1c326, $18ec8, $1c766, $18ec4,
 $18642, $18ec2, $10450, $10cd0, $10448, $18226, $11dd0, $10cc8,
 $10444, $11dc8, $10cc4, $10442, $11dc4, $10cc2, $1046c, $10cec,
 $10466, $11dec, $10ce6, $11de6, $1e7a8, $1e7a4, $1e7a2, $1c728,
 $1cf68, $1e7b6, $1cf64, $1c722, $1cf62, $18628, $1c316, $18e68,
 $1c736, $19ee8, $18e64, $18622, $19ee4, $18e62, $19ee2, $10428,
 $18216, $10c68, $18636, $11ce8, $10c64, $10422, $13de8, $11ce4,
 $10c62, $13de4, $11ce2, $10436, $10c76, $11cf6, $13df6, $1f7d4,
 $1f7d2, $1e794, $1efb4, $1e792, $1efb2, $1c714, $1cf34, $1c712,
 $1df74, $1cf32, $1df72, $18614, $18e34, $18612, $19e74, $18e32,
 $1bef4
 ),
 (
 $1f560, $1fab8, $1ea40, $1f530, $1fa9c, $1ea20, $1f518, $1fa8e,
 $1ea10, $1f50c, $1ea08, $1f506, $1ea04, $1eb60, $1f5b8, $1fade,
 $1d640, $1eb30, $1f59c, $1d620, $1eb18, $1f58e, $1d610, $1eb0c,
 $1d608, $1eb06, $1d604, $1d760, $1ebb8, $1f5de, $1ae40, $1d730,
 $1eb9c, $1ae20, $1d718, $1eb8e, $1ae10, $1d70c, $1ae08, $1d706,
 $1ae04, $1af60, $1d7b8, $1ebde, $15e40, $1af30, $1d79c, $15e20,
 $1af18, $1d78e, $15e10, $1af0c, $15e08, $1af06, $15f60, $1afb8,
 $1d7de, $15f30, $1af9c, $15f18, $1af8e, $15f0c, $15fb8, $1afde,
 $15f9c, $15f8e, $1e940, $1f4b0, $1fa5c, $1e920, $1f498, $1fa4e,
 $1e910, $1f48c, $1e908, $1f486, $1e904, $1e902, $1d340, $1e9b0,
 $1f4dc, $1d320, $1e998, $1f4ce, $1d310, $1e98c, $1d308, $1e986,
 $1d304, $1d302, $1a740, $1d3b0, $1e9dc, $1a720, $1d398, $1e9ce,
 $1a710, $1d38c, $1a708, $1d386, $1a704, $1a702, $14f40, $1a7b0,
 $1d3dc, $14f20, $1a798, $1d3ce, $14f10, $1a78c, $14f08, $1a786,
 $14f04, $14fb0, $1a7dc, $14f98, $1a7ce, $14f8c, $14f86, $14fdc,
 $14fce, $1e8a0, $1f458, $1fa2e, $1e890, $1f44c, $1e888, $1f446,
 $1e884, $1e882, $1d1a0, $1e8d8, $1f46e, $1d190, $1e8cc, $1d188,
 $1e8c6, $1d184, $1d182, $1a3a0, $1d1d8, $1e8ee, $1a390, $1d1cc,
 $1a388, $1d1c6, $1a384, $1a382, $147a0, $1a3d8, $1d1ee, $14790,
 $1a3cc, $14788, $1a3c6, $14784, $14782, $147d8, $1a3ee, $147cc,
 $147c6, $147ee, $1e850, $1f42c, $1e848, $1f426, $1e844, $1e842,
 $1d0d0, $1e86c, $1d0c8, $1e866, $1d0c4, $1d0c2, $1a1d0, $1d0ec,
 $1a1c8, $1d0e6, $1a1c4, $1a1c2, $143d0, $1a1ec, $143c8, $1a1e6,
 $143c4, $143c2, $143ec, $143e6, $1e828, $1f416, $1e824, $1e822,
 $1d068, $1e836, $1d064, $1d062, $1a0e8, $1d076, $1a0e4, $1a0e2,
 $141e8, $1a0f6, $141e4, $141e2, $1e814, $1e812, $1d034, $1d032,
 $1a074, $1a072, $1e540, $1f2b0, $1f95c, $1e520, $1f298, $1f94e,
 $1e510, $1f28c, $1e508, $1f286, $1e504, $1e502, $1cb40, $1e5b0,
 $1f2dc, $1cb20, $1e598, $1f2ce, $1cb10, $1e58c, $1cb08, $1e586,
 $1cb04, $1cb02, $19740, $1cbb0, $1e5dc, $19720, $1cb98, $1e5ce,
 $19710, $1cb8c, $19708, $1cb86, $19704, $19702, $12f40, $197b0,
 $1cbdc, $12f20, $19798, $1cbce, $12f10, $1978c, $12f08, $19786,
 $12f04, $12fb0, $197dc, $12f98, $197ce, $12f8c, $12f86, $12fdc,
 $12fce, $1f6a0, $1fb58, $16bf0, $1f690, $1fb4c, $169f8, $1f688,
 $1fb46, $168fc, $1f684, $1f682, $1e4a0, $1f258, $1f92e, $1eda0,
 $1e490, $1fb6e, $1ed90, $1f6cc, $1f246, $1ed88, $1e484, $1ed84,
 $1e482, $1ed82, $1c9a0, $1e4d8, $1f26e, $1dba0, $1c990, $1e4cc,
 $1db90, $1edcc, $1e4c6, $1db88, $1c984, $1db84, $1c982, $1db82,
 $193a0, $1c9d8, $1e4ee, $1b7a0, $19390, $1c9cc, $1b790, $1dbcc,
 $1c9c6, $1b788, $19384, $1b784, $19382, $1b782, $127a0, $193d8,
 $1c9ee, $16fa0, $12790, $193cc, $16f90, $1b7cc, $193c6, $16f88,
 $12784, $16f84, $12782, $127d8, $193ee, $16fd8, $127cc, $16fcc,
 $127c6, $16fc6, $127ee, $1f650, $1fb2c, $165f8, $1f648, $1fb26,
 $164fc, $1f644, $1647e, $1f642, $1e450, $1f22c, $1ecd0, $1e448,
 $1f226, $1ecc8, $1f666, $1ecc4, $1e442, $1ecc2, $1c8d0, $1e46c,
 $1d9d0, $1c8c8, $1e466, $1d9c8, $1ece6, $1d9c4, $1c8c2, $1d9c2,
 $191d0, $1c8ec, $1b3d0, $191c8, $1c8e6, $1b3c8, $1d9e6, $1b3c4,
 $191c2, $1b3c2, $123d0, $191ec, $167d0, $123c8, $191e6, $167c8,
 $1b3e6, $167c4, $123c2, $167c2, $123ec, $167ec, $123e6, $167e6,
 $1f628, $1fb16, $162fc, $1f624, $1627e, $1f622, $1e428, $1f216,
 $1ec68, $1f636, $1ec64, $1e422, $1ec62, $1c868, $1e436, $1d8e8,
 $1c864, $1d8e4, $1c862, $1d8e2, $190e8, $1c876, $1b1e8, $1d8f6,
 $1b1e4, $190e2, $1b1e2, $121e8, $190f6, $163e8, $121e4, $163e4,
 $121e2, $163e2, $121f6, $163f6, $1f614, $1617e, $1f612, $1e414,
 $1ec34, $1e412, $1ec32, $1c834, $1d874, $1c832, $1d872, $19074,
 $1b0f4, $19072, $1b0f2, $120f4, $161f4, $120f2, $161f2, $1f60a,
 $1e40a, $1ec1a, $1c81a, $1d83a, $1903a, $1b07a, $1e2a0, $1f158,
 $1f8ae, $1e290, $1f14c, $1e288, $1f146, $1e284, $1e282, $1c5a0,
 $1e2d8, $1f16e, $1c590, $1e2cc, $1c588, $1e2c6, $1c584, $1c582,
 $18ba0, $1c5d8, $1e2ee, $18b90, $1c5cc, $18b88, $1c5c6, $18b84,
 $18b82, $117a0, $18bd8, $1c5ee, $11790, $18bcc, $11788, $18bc6,
 $11784, $11782, $117d8, $18bee, $117cc, $117c6, $117ee, $1f350,
 $1f9ac, $135f8, $1f348, $1f9a6, $134fc, $1f344, $1347e, $1f342,
 $1e250, $1f12c, $1e6d0, $1e248, $1f126, $1e6c8, $1f366, $1e6c4,
 $1e242, $1e6c2, $1c4d0, $1e26c, $1cdd0, $1c4c8, $1e266, $1cdc8,
 $1e6e6, $1cdc4, $1c4c2, $1cdc2, $189d0, $1c4ec, $19bd0, $189c8,
 $1c4e6, $19bc8, $1cde6, $19bc4, $189c2, $19bc2, $113d0, $189ec,
 $137d0, $113c8, $189e6, $137c8, $19be6, $137c4, $113c2, $137c2,
 $113ec, $137ec, $113e6, $137e6, $1fba8, $175f0, $1bafc, $1fba4,
 $174f8, $1ba7e, $1fba2, $1747c, $1743e, $1f328, $1f996, $132fc,
 $1f768, $1fbb6, $176fc, $1327e, $1f764, $1f322, $1767e, $1f762,
 $1e228, $1f116, $1e668, $1e224, $1eee8, $1f776, $1e222, $1eee4,
 $1e662, $1eee2, $1c468, $1e236, $1cce8, $1c464, $1dde8, $1cce4,
 $1c462, $1dde4, $1cce2, $1dde2, $188e8, $1c476, $199e8, $188e4,
 $1bbe8, $199e4, $188e2, $1bbe4, $199e2, $1bbe2, $111e8, $188f6,
 $133e8, $111e4, $177e8, $133e4, $111e2, $177e4, $133e2, $177e2,
 $111f6, $133f6, $1fb94, $172f8, $1b97e, $1fb92, $1727c, $1723e,
 $1f314, $1317e, $1f734, $1f312, $1737e, $1f732, $1e214, $1e634,
 $1e212, $1ee74, $1e632, $1ee72, $1c434, $1cc74, $1c432, $1dcf4,
 $1cc72, $1dcf2, $18874, $198f4, $18872, $1b9f4, $198f2, $1b9f2,
 $110f4, $131f4, $110f2, $173f4, $131f2, $173f2, $1fb8a, $1717c,
 $1713e, $1f30a, $1f71a, $1e20a, $1e61a, $1ee3a, $1c41a, $1cc3a,
 $1dc7a, $1883a, $1987a, $1b8fa, $1107a, $130fa, $171fa, $170be,
 $1e150, $1f0ac, $1e148, $1f0a6, $1e144, $1e142, $1c2d0, $1e16c,
 $1c2c8, $1e166, $1c2c4, $1c2c2, $185d0, $1c2ec, $185c8, $1c2e6,
 $185c4, $185c2, $10bd0, $185ec, $10bc8, $185e6, $10bc4, $10bc2,
 $10bec, $10be6, $1f1a8, $1f8d6, $11afc, $1f1a4, $11a7e, $1f1a2,
 $1e128, $1f096, $1e368, $1e124, $1e364, $1e122, $1e362, $1c268,
 $1e136, $1c6e8, $1c264, $1c6e4, $1c262, $1c6e2, $184e8, $1c276,
 $18de8, $184e4, $18de4, $184e2, $18de2, $109e8, $184f6, $11be8,
 $109e4, $11be4, $109e2, $11be2, $109f6, $11bf6, $1f9d4, $13af8,
 $19d7e, $1f9d2, $13a7c, $13a3e, $1f194, $1197e, $1f3b4, $1f192,
 $13b7e, $1f3b2, $1e114, $1e334, $1e112, $1e774, $1e332, $1e772,
 $1c234, $1c674, $1c232, $1cef4, $1c672, $1cef2, $18474, $18cf4,
 $18472, $19df4, $18cf2, $19df2, $108f4, $119f4, $108f2, $13bf4,
 $119f2, $13bf2, $17af0, $1bd7c, $17a78, $1bd3e, $17a3c, $17a1e,
 $1f9ca, $1397c, $1fbda, $17b7c, $1393e, $17b3e, $1f18a, $1f39a,
 $1f7ba, $1e10a, $1e31a, $1e73a, $1ef7a, $1c21a, $1c63a, $1ce7a,
 $1defa, $1843a, $18c7a, $19cfa, $1bdfa, $1087a, $118fa, $139fa,
 $17978, $1bcbe, $1793c, $1791e, $138be, $179be, $178bc, $1789e,
 $1785e, $1e0a8, $1e0a4, $1e0a2, $1c168, $1e0b6, $1c164, $1c162,
 $182e8, $1c176, $182e4, $182e2, $105e8, $182f6, $105e4, $105e2,
 $105f6, $1f0d4, $10d7e, $1f0d2, $1e094, $1e1b4, $1e092, $1e1b2,
 $1c134, $1c374, $1c132, $1c372, $18274, $186f4, $18272, $186f2,
 $104f4, $10df4, $104f2, $10df2, $1f8ea, $11d7c, $11d3e, $1f0ca,
 $1f1da, $1e08a, $1e19a, $1e3ba, $1c11a, $1c33a, $1c77a, $1823a,
 $1867a, $18efa, $1047a, $10cfa, $11dfa, $13d78, $19ebe, $13d3c,
 $13d1e, $11cbe, $13dbe, $17d70, $1bebc, $17d38, $1be9e, $17d1c,
 $17d0e, $13cbc, $17dbc, $13c9e, $17d9e, $17cb8, $1be5e, $17c9c,
 $17c8e, $13c5e, $17cde, $17c5c, $17c4e, $17c2e, $1c0b4, $1c0b2,
 $18174, $18172, $102f4, $102f2, $1e0da, $1c09a, $1c1ba, $1813a,
 $1837a, $1027a, $106fa, $10ebe, $11ebc, $11e9e, $13eb8, $19f5e,
 $13e9c, $13e8e, $11e5e, $13ede, $17eb0, $1bf5c, $17e98, $1bf4e,
 $17e8c, $17e86, $13e5c, $17edc, $13e4e, $17ece, $17e58, $1bf2e,
 $17e4c, $17e46, $13e2e, $17e6e, $17e2c, $17e26, $10f5e, $11f5c,
 $11f4e, $13f58, $19fae, $13f4c, $13f46, $11f2e, $13f6e, $13f2c,
 $13f26
 ),
 (
 $1abe0, $1d5f8, $153c0, $1a9f0, $1d4fc, $151e0, $1a8f8, $1d47e,
 $150f0, $1a87c, $15078, $1fad0, $15be0, $1adf8, $1fac8, $159f0,
 $1acfc, $1fac4, $158f8, $1ac7e, $1fac2, $1587c, $1f5d0, $1faec,
 $15df8, $1f5c8, $1fae6, $15cfc, $1f5c4, $15c7e, $1f5c2, $1ebd0,
 $1f5ec, $1ebc8, $1f5e6, $1ebc4, $1ebc2, $1d7d0, $1ebec, $1d7c8,
 $1ebe6, $1d7c4, $1d7c2, $1afd0, $1d7ec, $1afc8, $1d7e6, $1afc4,
 $14bc0, $1a5f0, $1d2fc, $149e0, $1a4f8, $1d27e, $148f0, $1a47c,
 $14878, $1a43e, $1483c, $1fa68, $14df0, $1a6fc, $1fa64, $14cf8,
 $1a67e, $1fa62, $14c7c, $14c3e, $1f4e8, $1fa76, $14efc, $1f4e4,
 $14e7e, $1f4e2, $1e9e8, $1f4f6, $1e9e4, $1e9e2, $1d3e8, $1e9f6,
 $1d3e4, $1d3e2, $1a7e8, $1d3f6, $1a7e4, $1a7e2, $145e0, $1a2f8,
 $1d17e, $144f0, $1a27c, $14478, $1a23e, $1443c, $1441e, $1fa34,
 $146f8, $1a37e, $1fa32, $1467c, $1463e, $1f474, $1477e, $1f472,
 $1e8f4, $1e8f2, $1d1f4, $1d1f2, $1a3f4, $1a3f2, $142f0, $1a17c,
 $14278, $1a13e, $1423c, $1421e, $1fa1a, $1437c, $1433e, $1f43a,
 $1e87a, $1d0fa, $14178, $1a0be, $1413c, $1411e, $141be, $140bc,
 $1409e, $12bc0, $195f0, $1cafc, $129e0, $194f8, $1ca7e, $128f0,
 $1947c, $12878, $1943e, $1283c, $1f968, $12df0, $196fc, $1f964,
 $12cf8, $1967e, $1f962, $12c7c, $12c3e, $1f2e8, $1f976, $12efc,
 $1f2e4, $12e7e, $1f2e2, $1e5e8, $1f2f6, $1e5e4, $1e5e2, $1cbe8,
 $1e5f6, $1cbe4, $1cbe2, $197e8, $1cbf6, $197e4, $197e2, $1b5e0,
 $1daf8, $1ed7e, $169c0, $1b4f0, $1da7c, $168e0, $1b478, $1da3e,
 $16870, $1b43c, $16838, $1b41e, $1681c, $125e0, $192f8, $1c97e,
 $16de0, $124f0, $1927c, $16cf0, $1b67c, $1923e, $16c78, $1243c,
 $16c3c, $1241e, $16c1e, $1f934, $126f8, $1937e, $1fb74, $1f932,
 $16ef8, $1267c, $1fb72, $16e7c, $1263e, $16e3e, $1f274, $1277e,
 $1f6f4, $1f272, $16f7e, $1f6f2, $1e4f4, $1edf4, $1e4f2, $1edf2,
 $1c9f4, $1dbf4, $1c9f2, $1dbf2, $193f4, $193f2, $165c0, $1b2f0,
 $1d97c, $164e0, $1b278, $1d93e, $16470, $1b23c, $16438, $1b21e,
 $1641c, $1640e, $122f0, $1917c, $166f0, $12278, $1913e, $16678,
 $1b33e, $1663c, $1221e, $1661e, $1f91a, $1237c, $1fb3a, $1677c,
 $1233e, $1673e, $1f23a, $1f67a, $1e47a, $1ecfa, $1c8fa, $1d9fa,
 $191fa, $162e0, $1b178, $1d8be, $16270, $1b13c, $16238, $1b11e,
 $1621c, $1620e, $12178, $190be, $16378, $1213c, $1633c, $1211e,
 $1631e, $121be, $163be, $16170, $1b0bc, $16138, $1b09e, $1611c,
 $1610e, $120bc, $161bc, $1209e, $1619e, $160b8, $1b05e, $1609c,
 $1608e, $1205e, $160de, $1605c, $1604e, $115e0, $18af8, $1c57e,
 $114f0, $18a7c, $11478, $18a3e, $1143c, $1141e, $1f8b4, $116f8,
 $18b7e, $1f8b2, $1167c, $1163e, $1f174, $1177e, $1f172, $1e2f4,
 $1e2f2, $1c5f4, $1c5f2, $18bf4, $18bf2, $135c0, $19af0, $1cd7c,
 $134e0, $19a78, $1cd3e, $13470, $19a3c, $13438, $19a1e, $1341c,
 $1340e, $112f0, $1897c, $136f0, $11278, $1893e, $13678, $19b3e,
 $1363c, $1121e, $1361e, $1f89a, $1137c, $1f9ba, $1377c, $1133e,
 $1373e, $1f13a, $1f37a, $1e27a, $1e6fa, $1c4fa, $1cdfa, $189fa,
 $1bae0, $1dd78, $1eebe, $174c0, $1ba70, $1dd3c, $17460, $1ba38,
 $1dd1e, $17430, $1ba1c, $17418, $1ba0e, $1740c, $132e0, $19978,
 $1ccbe, $176e0, $13270, $1993c, $17670, $1bb3c, $1991e, $17638,
 $1321c, $1761c, $1320e, $1760e, $11178, $188be, $13378, $1113c,
 $17778, $1333c, $1111e, $1773c, $1331e, $1771e, $111be, $133be,
 $177be, $172c0, $1b970, $1dcbc, $17260, $1b938, $1dc9e, $17230,
 $1b91c, $17218, $1b90e, $1720c, $17206, $13170, $198bc, $17370,
 $13138, $1989e, $17338, $1b99e, $1731c, $1310e, $1730e, $110bc,
 $131bc, $1109e, $173bc, $1319e, $1739e, $17160, $1b8b8, $1dc5e,
 $17130, $1b89c, $17118, $1b88e, $1710c, $17106, $130b8, $1985e,
 $171b8, $1309c, $1719c, $1308e, $1718e, $1105e, $130de, $171de,
 $170b0, $1b85c, $17098, $1b84e, $1708c, $17086, $1305c, $170dc,
 $1304e, $170ce, $17058, $1b82e, $1704c, $17046, $1302e, $1706e,
 $1702c, $17026, $10af0, $1857c, $10a78, $1853e, $10a3c, $10a1e,
 $10b7c, $10b3e, $1f0ba, $1e17a, $1c2fa, $185fa, $11ae0, $18d78,
 $1c6be, $11a70, $18d3c, $11a38, $18d1e, $11a1c, $11a0e, $10978,
 $184be, $11b78, $1093c, $11b3c, $1091e, $11b1e, $109be, $11bbe,
 $13ac0, $19d70, $1cebc, $13a60, $19d38, $1ce9e, $13a30, $19d1c,
 $13a18, $19d0e, $13a0c, $13a06, $11970, $18cbc, $13b70, $11938,
 $18c9e, $13b38, $1191c, $13b1c, $1190e, $13b0e, $108bc, $119bc,
 $1089e, $13bbc, $1199e, $13b9e, $1bd60, $1deb8, $1ef5e, $17a40,
 $1bd30, $1de9c, $17a20, $1bd18, $1de8e, $17a10, $1bd0c, $17a08,
 $1bd06, $17a04, $13960, $19cb8, $1ce5e, $17b60, $13930, $19c9c,
 $17b30, $1bd9c, $19c8e, $17b18, $1390c, $17b0c, $13906, $17b06,
 $118b8, $18c5e, $139b8, $1189c, $17bb8, $1399c, $1188e, $17b9c,
 $1398e, $17b8e, $1085e, $118de, $139de, $17bde, $17940, $1bcb0,
 $1de5c, $17920, $1bc98, $1de4e, $17910, $1bc8c, $17908, $1bc86,
 $17904, $17902, $138b0, $19c5c, $179b0, $13898, $19c4e, $17998,
 $1bcce, $1798c, $13886, $17986, $1185c, $138dc, $1184e, $179dc,
 $138ce, $179ce, $178a0, $1bc58, $1de2e, $17890, $1bc4c, $17888,
 $1bc46, $17884, $17882, $13858, $19c2e, $178d8, $1384c, $178cc,
 $13846, $178c6, $1182e, $1386e, $178ee, $17850, $1bc2c, $17848,
 $1bc26, $17844, $17842, $1382c, $1786c, $13826, $17866, $17828,
 $1bc16, $17824, $17822, $13816, $17836, $10578, $182be, $1053c,
 $1051e, $105be, $10d70, $186bc, $10d38, $1869e, $10d1c, $10d0e,
 $104bc, $10dbc, $1049e, $10d9e, $11d60, $18eb8, $1c75e, $11d30,
 $18e9c, $11d18, $18e8e, $11d0c, $11d06, $10cb8, $1865e, $11db8,
 $10c9c, $11d9c, $10c8e, $11d8e, $1045e, $10cde, $11dde, $13d40,
 $19eb0, $1cf5c, $13d20, $19e98, $1cf4e, $13d10, $19e8c, $13d08,
 $19e86, $13d04, $13d02, $11cb0, $18e5c, $13db0, $11c98, $18e4e,
 $13d98, $19ece, $13d8c, $11c86, $13d86, $10c5c, $11cdc, $10c4e,
 $13ddc, $11cce, $13dce, $1bea0, $1df58, $1efae, $1be90, $1df4c,
 $1be88, $1df46, $1be84, $1be82, $13ca0, $19e58, $1cf2e, $17da0,
 $13c90, $19e4c, $17d90, $1becc, $19e46, $17d88, $13c84, $17d84,
 $13c82, $17d82, $11c58, $18e2e, $13cd8, $11c4c, $17dd8, $13ccc,
 $11c46, $17dcc, $13cc6, $17dc6, $10c2e, $11c6e, $13cee, $17dee,
 $1be50, $1df2c, $1be48, $1df26, $1be44, $1be42, $13c50, $19e2c,
 $17cd0, $13c48, $19e26, $17cc8, $1be66, $17cc4, $13c42, $17cc2,
 $11c2c, $13c6c, $11c26, $17cec, $13c66, $17ce6, $1be28, $1df16,
 $1be24, $1be22, $13c28, $19e16, $17c68, $13c24, $17c64, $13c22,
 $17c62, $11c16, $13c36, $17c76, $1be14, $1be12, $13c14, $17c34,
 $13c12, $17c32, $102bc, $1029e, $106b8, $1835e, $1069c, $1068e,
 $1025e, $106de, $10eb0, $1875c, $10e98, $1874e, $10e8c, $10e86,
 $1065c, $10edc, $1064e, $10ece, $11ea0, $18f58, $1c7ae, $11e90,
 $18f4c, $11e88, $18f46, $11e84, $11e82, $10e58, $1872e, $11ed8,
 $18f6e, $11ecc, $10e46, $11ec6, $1062e, $10e6e, $11eee, $19f50,
 $1cfac, $19f48, $1cfa6, $19f44, $19f42, $11e50, $18f2c, $13ed0,
 $19f6c, $18f26, $13ec8, $11e44, $13ec4, $11e42, $13ec2, $10e2c,
 $11e6c, $10e26, $13eec, $11e66, $13ee6, $1dfa8, $1efd6, $1dfa4,
 $1dfa2, $19f28, $1cf96, $1bf68, $19f24, $1bf64, $19f22, $1bf62,
 $11e28, $18f16, $13e68, $11e24, $17ee8, $13e64, $11e22, $17ee4,
 $13e62, $17ee2, $10e16, $11e36, $13e76, $17ef6, $1df94, $1df92,
 $19f14, $1bf34, $19f12, $1bf32, $11e14, $13e34, $11e12, $17e74,
 $13e32, $17e72, $1df8a, $19f0a, $1bf1a, $11e0a, $13e1a, $17e3a,
 $1035c, $1034e, $10758, $183ae, $1074c, $10746, $1032e, $1076e,
 $10f50, $187ac, $10f48, $187a6, $10f44, $10f42, $1072c, $10f6c,
 $10726, $10f66, $18fa8, $1c7d6, $18fa4, $18fa2, $10f28, $18796,
 $11f68, $18fb6, $11f64, $10f22, $11f62, $10716, $10f36, $11f76,
 $1cfd4, $1cfd2, $18f94, $19fb4, $18f92, $19fb2, $10f14, $11f34,
 $10f12, $13f74, $11f32, $13f72, $1cfca, $18f8a, $19f9a, $10f0a,
 $11f1a, $13f3a, $103ac, $103a6, $107a8, $183d6, $107a4, $107a2,
 $10396, $107b6, $187d4, $187d2, $10794, $10fb4, $10792, $10fb2,
 $1c7ea
 ));

Value

Type: array[0..2,0..928] of integer

See Also

Reference

  • frxBarcodePDF417


ERRLVL0 Constant

Summary

Represents constant ERRLVL0.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ERRLVL0 : array[0..1] of integer = ( 27, 917 );

Value

Type: array[0..1] of integer

See Also

Reference

  • frxBarcodePDF417


ERRLVL1 Constant

Summary

Represents constant ERRLVL1.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ERRLVL1 : array[0..3] of integer = ( 522, 568, 723, 809 );

Value

Type: array[0..3] of integer

See Also

Reference

  • frxBarcodePDF417


ERRLVL2 Constant

Summary

Represents constant ERRLVL2.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ERRLVL2 : array[0..7] of integer = ( 237, 308, 436, 284, 646, 653, 428, 379 );

Value

Type: array[0..7] of integer

See Also

Reference

  • frxBarcodePDF417


ERRLVL3 Constant

Summary

Represents constant ERRLVL3.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ERRLVL3: array[0..15] of integer = ( 274, 562, 232, 755, 599, 524, 801, 132, 295, 116, 442, 428, 295, 42, 176, 65 );

Value

Type: array[0..15] of integer

See Also

Reference

  • frxBarcodePDF417


ERRLVL4 Constant

Summary

Represents constant ERRLVL4.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ERRLVL4 : array[0..31] of integer = ( 361, 575, 922, 525, 176, 586, 640, 321, 536, 742, 677, 742, 687, 284, 193, 517,
 273, 494, 263, 147, 593, 800, 571, 320, 803, 133, 231, 390, 685, 330, 63, 410 );

Value

Type: array[0..31] of integer

See Also

Reference

  • frxBarcodePDF417


ERRLVL5 Constant

Summary

Represents constant ERRLVL5.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ERRLVL5 : array[0..63] of integer = (
 539, 422, 6, 93, 862, 771, 453, 106, 610, 287, 107, 505, 733, 877, 381, 612,
 723, 476, 462, 172, 430, 609, 858, 822, 543, 376, 511, 400, 672, 762, 283, 184,
 440, 35, 519, 31, 460, 594, 225, 535, 517, 352, 605, 158, 651, 201, 488, 502,
 648, 733, 717, 83, 404, 97, 280, 771, 840, 629, 4, 381, 843, 623, 264, 543 );

Value

Type: array[0..63] of integer

See Also

Reference

  • frxBarcodePDF417


ERRLVL6 Constant

Summary

Represents constant ERRLVL6.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ERRLVL6 : array[0..127] of integer = (
 521, 310, 864, 547, 858, 580, 296, 379, 53, 779, 897, 444, 400, 925, 749, 415,
 822, 93, 217, 208, 928, 244, 583, 620, 246, 148, 447, 631, 292, 908, 490, 704,
 516, 258, 457, 907, 594, 723, 674, 292, 272, 96, 684, 432, 686, 606, 860, 569,
 193, 219, 129, 186, 236, 287, 192, 775, 278, 173, 40, 379, 712, 463, 646, 776,
 171, 491, 297, 763, 156, 732, 95, 270, 447, 90, 507, 48, 228, 821, 808, 898,
 784, 663, 627, 378, 382, 262, 380, 602, 754, 336, 89, 614, 87, 432, 670, 616,
 157, 374, 242, 726, 600, 269, 375, 898, 845, 454, 354, 130, 814, 587, 804, 34,
 211, 330, 539, 297, 827, 865, 37, 517, 834, 315, 550, 86, 801, 4, 108, 539 );

Value

Type: array[0..127] of integer

See Also

Reference

  • frxBarcodePDF417


ERRLVL7 Constant

Summary

Represents constant ERRLVL7.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ERRLVL7 : array[0..255] of integer = (
 524, 894, 75, 766, 882, 857, 74, 204, 82, 586, 708, 250, 905, 786, 138, 720,
 858, 194, 311, 913, 275, 190, 375, 850, 438, 733, 194, 280, 201, 280, 828, 757,
 710, 814, 919, 89, 68, 569, 11, 204, 796, 605, 540, 913, 801, 700, 799, 137,
 439, 418, 592, 668, 353, 859, 370, 694, 325, 240, 216, 257, 284, 549, 209, 884,
 315, 70, 329, 793, 490, 274, 877, 162, 749, 812, 684, 461, 334, 376, 849, 521,
 307, 291, 803, 712, 19, 358, 399, 908, 103, 511, 51, 8, 517, 225, 289, 470,
 637, 731, 66, 255, 917, 269, 463, 830, 730, 433, 848, 585, 136, 538, 906, 90,
 2, 290, 743, 199, 655, 903, 329, 49, 802, 580, 355, 588, 188, 462, 10, 134,
 628, 320, 479, 130, 739, 71, 263, 318, 374, 601, 192, 605, 142, 673, 687, 234,
 722, 384, 177, 752, 607, 640, 455, 193, 689, 707, 805, 641, 48, 60, 732, 621,
 895, 544, 261, 852, 655, 309, 697, 755, 756, 60, 231, 773, 434, 421, 726, 528,
 503, 118, 49, 795, 32, 144, 500, 238, 836, 394, 280, 566, 319, 9, 647, 550,
 73, 914, 342, 126, 32, 681, 331, 792, 620, 60, 609, 441, 180, 791, 893, 754,
 605, 383, 228, 749, 760, 213, 54, 297, 134, 54, 834, 299, 922, 191, 910, 532,
 609, 829, 189, 20, 167, 29, 872, 449, 83, 402, 41, 656, 505, 579, 481, 173,
 404, 251, 688, 95, 497, 555, 642, 543, 307, 159, 924, 558, 648, 55, 497, 10 );

Value

Type: array[0..255] of integer

See Also

Reference

  • frxBarcodePDF417


ERRLVL8 Constant

Summary

Represents constant ERRLVL8.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ERRLVL8 : array[0..511] of integer = (
 352, 77, 373, 504, 35, 599, 428, 207, 409, 574, 118, 498, 285, 380, 350, 492,
 197, 265, 920, 155, 914, 299, 229, 643, 294, 871, 306, 88, 87, 193, 352, 781,
 846, 75, 327, 520, 435, 543, 203, 666, 249, 346, 781, 621, 640, 268, 794, 534,
 539, 781, 408, 390, 644, 102, 476, 499, 290, 632, 545, 37, 858, 916, 552, 41,
 542, 289, 122, 272, 383, 800, 485, 98, 752, 472, 761, 107, 784, 860, 658, 741,
 290, 204, 681, 407, 855, 85, 99, 62, 482, 180, 20, 297, 451, 593, 913, 142,
 808, 684, 287, 536, 561, 76, 653, 899, 729, 567, 744, 390, 513, 192, 516, 258,
 240, 518, 794, 395, 768, 848, 51, 610, 384, 168, 190, 826, 328, 596, 786, 303,
 570, 381, 415, 641, 156, 237, 151, 429, 531, 207, 676, 710, 89, 168, 304, 402,
 40, 708, 575, 162, 864, 229, 65, 861, 841, 512, 164, 477, 221, 92, 358, 785,
 288, 357, 850, 836, 827, 736, 707, 94, 8, 494, 114, 521, 2, 499, 851, 543,
 152, 729, 771, 95, 248, 361, 578, 323, 856, 797, 289, 51, 684, 466, 533, 820,
 669, 45, 902, 452, 167, 342, 244, 173, 35, 463, 651, 51, 699, 591, 452, 578,
 37, 124, 298, 332, 552, 43, 427, 119, 662, 777, 475, 850, 764, 364, 578, 911,
 283, 711, 472, 420, 245, 288, 594, 394, 511, 327, 589, 777, 699, 688, 43, 408,
 842, 383, 721, 521, 560, 644, 714, 559, 62, 145, 873, 663, 713, 159, 672, 729,
 624, 59, 193, 417, 158, 209, 563, 564, 343, 693, 109, 608, 563, 365, 181, 772,
 677, 310, 248, 353, 708, 410, 579, 870, 617, 841, 632, 860, 289, 536, 35, 777,
 618, 586, 424, 833, 77, 597, 346, 269, 757, 632, 695, 751, 331, 247, 184, 45,
 787, 680, 18, 66, 407, 369, 54, 492, 228, 613, 830, 922, 437, 519, 644, 905,
 789, 420, 305, 441, 207, 300, 892, 827, 141, 537, 381, 662, 513, 56, 252, 341,
 242, 797, 838, 837, 720, 224, 307, 631, 61, 87, 560, 310, 756, 665, 397, 808,
 851, 309, 473, 795, 378, 31, 647, 915, 459, 806, 590, 731, 425, 216, 548, 249,
 321, 881, 699, 535, 673, 782, 210, 815, 905, 303, 843, 922, 281, 73, 469, 791,
 660, 162, 498, 308, 155, 422, 907, 817, 187, 62, 16, 425, 535, 336, 286, 437,
 375, 273, 610, 296, 183, 923, 116, 667, 751, 353, 62, 366, 691, 379, 687, 842,
 37, 357, 720, 742, 330, 5, 39, 923, 311, 424, 242, 749, 321, 54, 669, 316,
 342, 299, 534, 105, 667, 488, 640, 672, 576, 540, 316, 486, 721, 610, 46, 656,
 447, 171, 616, 464, 190, 531, 297, 321, 762, 752, 533, 175, 134, 14, 381, 433,
 717, 45, 111, 20, 596, 284, 736, 138, 646, 411, 877, 669, 141, 919, 45, 780,
 407, 164, 332, 899, 165, 726, 600, 325, 498, 655, 357, 752, 768, 223, 849, 647,
 63, 310, 863, 251, 366, 304, 282, 738, 675, 410, 389, 244, 31, 121, 303, 263 );

Value

Type: array[0..511] of integer

See Also

Reference

  • frxBarcodePDF417


ERROR_LEVEL Constant

Summary

Represents constant ERROR_LEVEL.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ERROR_LEVEL : array[0..8] of PInt = ( @ERRLVL0, @ERRLVL1, @ERRLVL2, @ERRLVL3, @ERRLVL4, @ERRLVL5, @ERRLVL6, @ERRLVL7, @ERRLVL8 );

Value

Type: array[0..8] of PInt

See Also

Reference

  • frxBarcodePDF417


ISBYTE Constant

Summary

Represents constant ISBYTE.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ISBYTE = $100000;

Value

Type: Integer

See Also

Reference

  • frxBarcodePDF417


LL Constant

Summary

Represents constant LL.

Namespace: frxBarcodePDF417
Syntax
Delphi
 LL = 27;

Value

Type: ShortInt

See Also

Reference

  • frxBarcodePDF417


LOWER Constant

Summary

Represents constant LOWER.

Namespace: frxBarcodePDF417
Syntax
Delphi
 LOWER = $20000;

Value

Type: Integer

See Also

Reference

  • frxBarcodePDF417


MACRO_LAST_SEGMENT Constant

Summary

Represents constant MACRO_LAST_SEGMENT.

Namespace: frxBarcodePDF417
Syntax
Delphi
 MACRO_LAST_SEGMENT = 922;

Value

Type: SmallInt

See Also

Reference

  • frxBarcodePDF417


MACRO_SEGMENT_ID Constant

Summary

Represents constant MACRO_SEGMENT_ID.

Namespace: frxBarcodePDF417
Syntax
Delphi
 MACRO_SEGMENT_ID = 928;

Value

Type: SmallInt

See Also

Reference

  • frxBarcodePDF417


MAX_DATA_CODEWORDS Constant

Summary

Represents constant MAX_DATA_CODEWORDS.

Namespace: frxBarcodePDF417
Syntax
Delphi
 MAX_DATA_CODEWORDS = 926;

Value

Type: SmallInt

See Also

Reference

  • frxBarcodePDF417


MIXED Constant

Summary

Represents constant MIXED.

Namespace: frxBarcodePDF417
Syntax
Delphi
 MIXED = $40000;

Value

Type: Integer

See Also

Reference

  • frxBarcodePDF417


MIXED_SET Constant

Summary

Represents constant MIXED_SET.

Namespace: frxBarcodePDF417
Syntax
Delphi
 MIXED_SET = '0123456789&'#13#9',:#-.$/+%*=^';

Value

Type: string

See Also

Reference

  • frxBarcodePDF417


ML Constant

Summary

Represents constant ML.

Namespace: frxBarcodePDF417
Syntax
Delphi
 ML = 28;

Value

Type: ShortInt

See Also

Reference

  • frxBarcodePDF417


NUMERIC_MODE Constant

Summary

Represents constant NUMERIC_MODE.

Namespace: frxBarcodePDF417
Syntax
Delphi
 NUMERIC_MODE = 902;

Value

Type: SmallInt

See Also

Reference

  • frxBarcodePDF417


PAL Constant

Summary

Represents constant PAL.

Namespace: frxBarcodePDF417
Syntax
Delphi
 PAL = 29;

Value

Type: ShortInt

See Also

Reference

  • frxBarcodePDF417


PL Constant

Summary

Represents constant PL.

Namespace: frxBarcodePDF417
Syntax
Delphi
 PL = 25;

Value

Type: ShortInt

See Also

Reference

  • frxBarcodePDF417


PS Constant

Summary

Represents constant PS.

Namespace: frxBarcodePDF417
Syntax
Delphi
 PS = 29;

Value

Type: ShortInt

See Also

Reference

  • frxBarcodePDF417


PUNCTUATION Constant

Summary

Represents constant PUNCTUATION.

Namespace: frxBarcodePDF417
Syntax
Delphi
 PUNCTUATION = $80000;

Value

Type: Integer

See Also

Reference

  • frxBarcodePDF417


PUNCTUATION_SET Constant

Summary

Represents constant PUNCTUATION_SET.

Namespace: frxBarcodePDF417
Syntax
Delphi
 PUNCTUATION_SET = ';<>@[\]_`~!'#13#9',:'#10'-.$/"|*()?{}''';

Value

Type: string

See Also

Reference

  • frxBarcodePDF417


SPACE Constant

Summary

Represents constant SPACE.

Namespace: frxBarcodePDF417
Syntax
Delphi
 SPACE = 26;

Value

Type: ShortInt

See Also

Reference

  • frxBarcodePDF417


START_CODE_SIZE Constant

Summary

Represents constant START_CODE_SIZE.

Namespace: frxBarcodePDF417
Syntax
Delphi
 START_CODE_SIZE = 17;

Value

Type: ShortInt

See Also

Reference

  • frxBarcodePDF417


START_PATTERN Constant

Summary

Represents constant START_PATTERN.

Namespace: frxBarcodePDF417
Syntax
Delphi
 START_PATTERN = $1fea8;

Value

Type: Integer

See Also

Reference

  • frxBarcodePDF417


STOP_PATTERN Constant

Summary

Represents constant STOP_PATTERN.

Namespace: frxBarcodePDF417
Syntax
Delphi
 STOP_PATTERN = $3fa29;

Value

Type: Integer

See Also

Reference

  • frxBarcodePDF417


STOP_SIZE Constant

Summary

Represents constant STOP_SIZE.

Namespace: frxBarcodePDF417
Syntax
Delphi
 STOP_SIZE = 18;

Value

Type: ShortInt

See Also

Reference

  • frxBarcodePDF417


TEXT_MODE Constant

Summary

Represents constant TEXT_MODE.

Namespace: frxBarcodePDF417
Syntax
Delphi
 TEXT_MODE = 900;

Value

Type: SmallInt

See Also

Reference

  • frxBarcodePDF417


_AS Constant

Summary

Represents constant _AS.

Namespace: frxBarcodePDF417
Syntax
Delphi
 _AS = 27;

Value

Type: ShortInt

See Also

Reference

  • frxBarcodePDF417


_MOD Constant

Summary

Represents constant _MOD.

Namespace: frxBarcodePDF417
Syntax
Delphi
 _MOD = 929;

Value

Type: SmallInt

See Also

Reference

  • frxBarcodePDF417


frxBarcodeProperties Namespace

Summary

Represents namespace frxBarcodeProperties.

Classes
Name | Description
TfrxAztecProperties | Represents type TfrxAztecProperties.
TfrxBarcode2DProperties | Represents type TfrxBarcode2DProperties.
TfrxDataMatrixProperties | Represents type TfrxDataMatrixProperties.
TfrxGS1DatabarEProperties | Represents type TfrxGS1DatabarEProperties.
TfrxGS1DatabarESProperties | Represents type TfrxGS1DatabarESProperties.
TfrxGS1DatabarProperties | Represents type TfrxGS1DatabarProperties.
TfrxMaxiCodeProperties | Represents type TfrxMaxiCodeProperties.
TfrxPDF417Properties | Represents type TfrxPDF417Properties.
TfrxQRProperties | Represents type TfrxQRProperties.
Top


frxBarcodeProperties Classes

Classes
Name | Description
TfrxAztecProperties | Represents type TfrxAztecProperties.
TfrxBarcode2DProperties | Represents type TfrxBarcode2DProperties.
TfrxDataMatrixProperties | Represents type TfrxDataMatrixProperties.
TfrxGS1DatabarEProperties | Represents type TfrxGS1DatabarEProperties.
TfrxGS1DatabarESProperties | Represents type TfrxGS1DatabarESProperties.
TfrxGS1DatabarProperties | Represents type TfrxGS1DatabarProperties.
TfrxMaxiCodeProperties | Represents type TfrxMaxiCodeProperties.
TfrxPDF417Properties | Represents type TfrxPDF417Properties.
TfrxQRProperties | Represents type TfrxQRProperties.
Top


TfrxAztecProperties Class

Summary

Represents type TfrxAztecProperties.

Namespace: frxBarcodeProperties
Inheritance Hierarchy
TPersistent
frxBarcodeProperties.TfrxBarcode2DProperties
frxBarcodeProperties.TfrxAztecProperties
Syntax
Delphi
type
 TfrxAztecProperties = class(TfrxBarcode2DProperties)
 end;

The TfrxAztecProperties type exposes the following members.

Properties
Show:
Name | Description
MinECCPercent | Represents property MinECCPercent.
PixelSize | Represents property PixelSize.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxBarcode2DProperties.Assign(TPersistent).)
Changed | Represents method Changed. (Inherited from TfrxBarcode2DProperties.)
GetMinECCPercent | Represents method GetMinECCPercent.
GetPixelSize | Represents method GetPixelSize.
SetMinECCPercent(integer) | Represents method SetMinECCPercent(integer).
SetPixelSize(integer) | Represents method SetPixelSize(integer).
SetWhose(TObject) | Represents method SetWhose(TObject). (Inherited from TfrxBarcode2DProperties.)
Top
Fields
Show:
Name | Description
FWhose | Represents field FWhose. (Inherited from TfrxBarcode2DProperties.)
Top
See Also

Reference

  • frxBarcodeProperties


TfrxAztecProperties Properties

Properties
Name | Description
MinECCPercent | Represents property MinECCPercent.
PixelSize | Represents property PixelSize.
Top


TfrxAztecProperties.MinECCPercent Property

Summary

Represents property MinECCPercent.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property MinECCPercent: integer read GetMinECCPercent
 write SetMinECCPercent;

Property Value

Type: integer

See Also

Reference

  • TfrxAztecProperties
  • frxBarcodeProperties


TfrxAztecProperties.PixelSize Property

Summary

Represents property PixelSize.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property PixelSize: integer read GetPixelSize write SetPixelSize;

Property Value

Type: integer

See Also

Reference

  • TfrxAztecProperties
  • frxBarcodeProperties


TfrxAztecProperties Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxBarcode2DProperties.Assign(TPersistent).)
GetMinECCPercent | Represents method GetMinECCPercent.
GetPixelSize | Represents method GetPixelSize.
SetMinECCPercent(integer) | Represents method SetMinECCPercent(integer).
SetPixelSize(integer) | Represents method SetPixelSize(integer).
Top


TfrxAztecProperties.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxBarcodeProperties
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TfrxBarcode2DProperties.Assign(TPersistent)
See Also

Reference

  • TfrxAztecProperties
  • frxBarcodeProperties


TfrxAztecProperties.GetMinECCPercent Method

Summary

Represents method GetMinECCPercent.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetMinECCPercent: integer;

Return Value

Type: integer

See Also

Reference

  • TfrxAztecProperties
  • frxBarcodeProperties


TfrxAztecProperties.GetPixelSize Method

Summary

Represents method GetPixelSize.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetPixelSize: integer;

Return Value

Type: integer

See Also

Reference

  • TfrxAztecProperties
  • frxBarcodeProperties


TfrxAztecProperties.SetMinECCPercent(integer) Method

Summary

Represents method SetMinECCPercent(integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetMinECCPercent(const Value: integer);

Parameters

Value
Type: integer

See Also

Reference

  • TfrxAztecProperties
  • frxBarcodeProperties


TfrxAztecProperties.SetPixelSize(integer) Method

Summary

Represents method SetPixelSize(integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetPixelSize(const Value: integer);

Parameters

Value
Type: integer

See Also

Reference

  • TfrxAztecProperties
  • frxBarcodeProperties


TfrxBarcode2DProperties Class

Summary

Represents type TfrxBarcode2DProperties.

Namespace: frxBarcodeProperties
Inheritance Hierarchy
TPersistent
frxBarcodeProperties.TfrxBarcode2DProperties
frxBarcodeProperties.TfrxAztecProperties
frxBarcodeProperties.TfrxDataMatrixProperties
frxBarcodeProperties.TfrxGS1DatabarProperties
frxBarcodeProperties.TfrxMaxiCodeProperties
frxBarcodeProperties.TfrxPDF417Properties
frxBarcodeProperties.TfrxQRProperties
Syntax
Delphi
type
 TfrxBarcode2DProperties = class(TPersistent)
 end;

The TfrxBarcode2DProperties type exposes the following members.

Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Changed | Represents method Changed.
SetWhose(TObject) | Represents method SetWhose(TObject).
Top
Fields
Show:
Name | Description
FOnChange | Represents field FOnChange.
FWhose | Represents field FWhose.
Top
See Also

Reference

  • frxBarcodeProperties


TfrxBarcode2DProperties Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Changed | Represents method Changed.
SetWhose(TObject) | Represents method SetWhose(TObject).
Top


TfrxBarcode2DProperties.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxBarcodeProperties
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override; abstract;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxBarcode2DProperties
  • frxBarcodeProperties


TfrxBarcode2DProperties.Changed Method

Summary

Represents method Changed.

Namespace: frxBarcodeProperties
Syntax
Delphi
public
 procedure Changed;
See Also

Reference

  • TfrxBarcode2DProperties
  • frxBarcodeProperties


TfrxBarcode2DProperties.SetWhose(TObject) Method

Summary

Represents method SetWhose(TObject).

Namespace: frxBarcodeProperties
Syntax
Delphi
public
 procedure SetWhose(w: TObject);

Parameters

w
Type: TObject

See Also

Reference

  • TfrxBarcode2DProperties
  • frxBarcodeProperties


TfrxBarcode2DProperties Fields

Fields
Name | Description
FOnChange | Represents field FOnChange.
FWhose | Represents field FWhose.
Top


TfrxBarcode2DProperties.FOnChange Field

Summary

Represents field FOnChange.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 FOnChange: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxBarcode2DProperties
  • frxBarcodeProperties


TfrxBarcode2DProperties.FWhose Field

Summary

Represents field FWhose.

Namespace: frxBarcodeProperties
Syntax
Delphi
public
 FWhose: TObject;

Field Value

Type: TObject

See Also

Reference

  • TfrxBarcode2DProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties Class

Summary

Represents type TfrxDataMatrixProperties.

Namespace: frxBarcodeProperties
Inheritance Hierarchy
TPersistent
frxBarcodeProperties.TfrxBarcode2DProperties
frxBarcodeProperties.TfrxDataMatrixProperties
Syntax
Delphi
type
 TfrxDataMatrixProperties = class(TfrxBarcode2DProperties)
 end;

The TfrxDataMatrixProperties type exposes the following members.

Properties
Show:
Name | Description
CodePage | Represents property CodePage.
Encoding | Represents property Encoding.
GS1Rule | Represents property GS1Rule.
PixelSize | Represents property PixelSize.
SymbolSize | Represents property SymbolSize.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxBarcode2DProperties.Assign(TPersistent).)
Changed | Represents method Changed. (Inherited from TfrxBarcode2DProperties.)
GetCodePage | Represents method GetCodePage.
GetEncoding | Represents method GetEncoding.
GetGS1Rule | Represents method GetGS1Rule.
GetPixelSize | Represents method GetPixelSize.
GetSymbolSize | Represents method GetSymbolSize.
SetCodePage(Integer) | Represents method SetCodePage(Integer).
SetEncoding(DatamatrixEncoding) | Represents method SetEncoding(DatamatrixEncoding).
SetGS1Rule(Boolean) | Represents method SetGS1Rule(Boolean).
SetPixelSize(Integer) | Represents method SetPixelSize(Integer).
SetSymbolSize(DatamatrixSymbolSize) | Represents method SetSymbolSize(DatamatrixSymbolSize).
SetWhose(TObject) | Represents method SetWhose(TObject). (Inherited from TfrxBarcode2DProperties.)
Top
Fields
Show:
Name | Description
FWhose | Represents field FWhose. (Inherited from TfrxBarcode2DProperties.)
Top
See Also

Reference

  • frxBarcodeProperties


TfrxDataMatrixProperties Properties

Properties
Name | Description
CodePage | Represents property CodePage.
Encoding | Represents property Encoding.
GS1Rule | Represents property GS1Rule.
PixelSize | Represents property PixelSize.
SymbolSize | Represents property SymbolSize.
Top


TfrxDataMatrixProperties.CodePage Property

Summary

Represents property CodePage.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property CodePage: Integer read GetCodePage write SetCodePage;

Property Value

Type: Integer

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.Encoding Property

Summary

Represents property Encoding.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property Encoding: DatamatrixEncoding read GetEncoding write SetEncoding;

Property Value

Type: DatamatrixEncoding

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.GS1Rule Property

Summary

Represents property GS1Rule.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property GS1Rule: Boolean read GetGS1Rule write SetGS1Rule;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.PixelSize Property

Summary

Represents property PixelSize.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property PixelSize: Integer read GetPixelSize write SetPixelSize;

Property Value

Type: Integer

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.SymbolSize Property

Summary

Represents property SymbolSize.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property SymbolSize: DatamatrixSymbolSize read GetSymbolSize
 write SetSymbolSize;

Property Value

Type: DatamatrixSymbolSize

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxBarcode2DProperties.Assign(TPersistent).)
GetCodePage | Represents method GetCodePage.
GetEncoding | Represents method GetEncoding.
GetGS1Rule | Represents method GetGS1Rule.
GetPixelSize | Represents method GetPixelSize.
GetSymbolSize | Represents method GetSymbolSize.
SetCodePage(Integer) | Represents method SetCodePage(Integer).
SetEncoding(DatamatrixEncoding) | Represents method SetEncoding(DatamatrixEncoding).
SetGS1Rule(Boolean) | Represents method SetGS1Rule(Boolean).
SetPixelSize(Integer) | Represents method SetPixelSize(Integer).
SetSymbolSize(DatamatrixSymbolSize) | Represents method SetSymbolSize(DatamatrixSymbolSize).
Top


TfrxDataMatrixProperties.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxBarcodeProperties
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TfrxBarcode2DProperties.Assign(TPersistent)
See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.GetCodePage Method

Summary

Represents method GetCodePage.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetCodePage: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.GetEncoding Method

Summary

Represents method GetEncoding.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetEncoding: DatamatrixEncoding;

Return Value

Type: DatamatrixEncoding

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.GetGS1Rule Method

Summary

Represents method GetGS1Rule.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetGS1Rule: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.GetPixelSize Method

Summary

Represents method GetPixelSize.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetPixelSize: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.GetSymbolSize Method

Summary

Represents method GetSymbolSize.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetSymbolSize: DatamatrixSymbolSize;

Return Value

Type: DatamatrixSymbolSize

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.SetCodePage(Integer) Method

Summary

Represents method SetCodePage(Integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetCodePage(v: Integer);

Parameters

v
Type: Integer

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.SetEncoding(DatamatrixEncoding) Method

Summary

Represents method SetEncoding(DatamatrixEncoding).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetEncoding(v: DatamatrixEncoding);

Parameters

v
Type: DatamatrixEncoding

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.SetGS1Rule(Boolean) Method

Summary

Represents method SetGS1Rule(Boolean).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetGS1Rule(b: Boolean);

Parameters

b
Type: Boolean

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.SetPixelSize(Integer) Method

Summary

Represents method SetPixelSize(Integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetPixelSize(v: Integer);

Parameters

v
Type: Integer

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxDataMatrixProperties.SetSymbolSize(DatamatrixSymbolSize) Method

Summary

Represents method SetSymbolSize(DatamatrixSymbolSize).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetSymbolSize(v: DatamatrixSymbolSize);

Parameters

v
Type: DatamatrixSymbolSize

See Also

Reference

  • TfrxDataMatrixProperties
  • frxBarcodeProperties


TfrxGS1DatabarEProperties Class

Summary

Represents type TfrxGS1DatabarEProperties.

Namespace: frxBarcodeProperties
Inheritance Hierarchy
TPersistent
frxBarcodeProperties.TfrxBarcode2DProperties
frxBarcodeProperties.TfrxGS1DatabarProperties
frxBarcodeProperties.TfrxGS1DatabarEProperties
Syntax
Delphi
type
 TfrxGS1DatabarEProperties = class(TfrxGS1DatabarProperties)
 end;

The TfrxGS1DatabarEProperties type exposes the following members.

Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxGS1DatabarProperties.Assign(TPersistent).)
Changed | Represents method Changed. (Inherited from TfrxBarcode2DProperties.)
SetWhose(TObject) | Represents method SetWhose(TObject). (Inherited from TfrxBarcode2DProperties.)
Top
Fields
Show:
Name | Description
FWhose | Represents field FWhose. (Inherited from TfrxBarcode2DProperties.)
Top
See Also

Reference

  • frxBarcodeProperties


TfrxGS1DatabarEProperties Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxGS1DatabarProperties.Assign(TPersistent).)
Top


TfrxGS1DatabarEProperties.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxBarcodeProperties
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TfrxGS1DatabarProperties.Assign(TPersistent)
See Also

Reference

  • TfrxGS1DatabarEProperties
  • frxBarcodeProperties


TfrxGS1DatabarESProperties Class

Summary

Represents type TfrxGS1DatabarESProperties.

Namespace: frxBarcodeProperties
Inheritance Hierarchy
TPersistent
frxBarcodeProperties.TfrxBarcode2DProperties
frxBarcodeProperties.TfrxGS1DatabarProperties
frxBarcodeProperties.TfrxGS1DatabarESProperties
Syntax
Delphi
type
 TfrxGS1DatabarESProperties = class(TfrxGS1DatabarProperties)
 end;

The TfrxGS1DatabarESProperties type exposes the following members.

Properties
Show:
Name | Description
Columns | Represents property Columns.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxGS1DatabarProperties.Assign(TPersistent).)
Changed | Represents method Changed. (Inherited from TfrxBarcode2DProperties.)
GetColumns | Represents method GetColumns.
SetColumns(Integer) | Represents method SetColumns(Integer).
SetWhose(TObject) | Represents method SetWhose(TObject). (Inherited from TfrxBarcode2DProperties.)
Top
Fields
Show:
Name | Description
FWhose | Represents field FWhose. (Inherited from TfrxBarcode2DProperties.)
Top
See Also

Reference

  • frxBarcodeProperties


TfrxGS1DatabarESProperties Properties

Properties
Name | Description
Columns | Represents property Columns.
Top


TfrxGS1DatabarESProperties.Columns Property

Summary

Represents property Columns.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property Columns: Integer read GetColumns write SetColumns;

Property Value

Type: Integer

See Also

Reference

  • TfrxGS1DatabarESProperties
  • frxBarcodeProperties


TfrxGS1DatabarESProperties Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxGS1DatabarProperties.Assign(TPersistent).)
GetColumns | Represents method GetColumns.
SetColumns(Integer) | Represents method SetColumns(Integer).
Top


TfrxGS1DatabarESProperties.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxBarcodeProperties
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TfrxGS1DatabarProperties.Assign(TPersistent)
See Also

Reference

  • TfrxGS1DatabarESProperties
  • frxBarcodeProperties


TfrxGS1DatabarESProperties.GetColumns Method

Summary

Represents method GetColumns.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetColumns(): Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxGS1DatabarESProperties
  • frxBarcodeProperties


TfrxGS1DatabarESProperties.SetColumns(Integer) Method

Summary

Represents method SetColumns(Integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetColumns(Col: Integer);

Parameters

Col
Type: Integer

See Also

Reference

  • TfrxGS1DatabarESProperties
  • frxBarcodeProperties


TfrxGS1DatabarProperties Class

Summary

Represents type TfrxGS1DatabarProperties.

Namespace: frxBarcodeProperties
Inheritance Hierarchy
TPersistent
frxBarcodeProperties.TfrxBarcode2DProperties
frxBarcodeProperties.TfrxGS1DatabarProperties
frxBarcodeProperties.TfrxGS1DatabarEProperties
frxBarcodeProperties.TfrxGS1DatabarESProperties
Syntax
Delphi
type
 TfrxGS1DatabarProperties = class(TfrxBarcode2DProperties)
 end;

The TfrxGS1DatabarProperties type exposes the following members.

Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxBarcode2DProperties.Assign(TPersistent).)
Changed | Represents method Changed. (Inherited from TfrxBarcode2DProperties.)
SetWhose(TObject) | Represents method SetWhose(TObject). (Inherited from TfrxBarcode2DProperties.)
Top
Fields
Show:
Name | Description
FWhose | Represents field FWhose. (Inherited from TfrxBarcode2DProperties.)
Top
See Also

Reference

  • frxBarcodeProperties


TfrxGS1DatabarProperties Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxBarcode2DProperties.Assign(TPersistent).)
Top


TfrxGS1DatabarProperties.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxBarcodeProperties
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TfrxBarcode2DProperties.Assign(TPersistent)
See Also

Reference

  • TfrxGS1DatabarProperties
  • frxBarcodeProperties


TfrxMaxiCodeProperties Class

Summary

Represents type TfrxMaxiCodeProperties.

Namespace: frxBarcodeProperties
Inheritance Hierarchy
TPersistent
frxBarcodeProperties.TfrxBarcode2DProperties
frxBarcodeProperties.TfrxMaxiCodeProperties
Syntax
Delphi
type
 TfrxMaxiCodeProperties = class(TfrxBarcode2DProperties)
 end;

The TfrxMaxiCodeProperties type exposes the following members.

Properties
Show:
Name | Description
Mode | Represents property Mode.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxBarcode2DProperties.Assign(TPersistent).)
Changed | Represents method Changed. (Inherited from TfrxBarcode2DProperties.)
GetMode | Represents method GetMode.
SetMode(Integer) | Represents method SetMode(Integer).
SetWhose(TObject) | Represents method SetWhose(TObject). (Inherited from TfrxBarcode2DProperties.)
Top
Fields
Show:
Name | Description
FWhose | Represents field FWhose. (Inherited from TfrxBarcode2DProperties.)
Top
See Also

Reference

  • frxBarcodeProperties


TfrxMaxiCodeProperties Properties

Properties
Name | Description
Mode | Represents property Mode.
Top


TfrxMaxiCodeProperties.Mode Property

Summary

Represents property Mode.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property Mode: Integer read GetMode write SetMode;

Property Value

Type: Integer

See Also

Reference

  • TfrxMaxiCodeProperties
  • frxBarcodeProperties


TfrxMaxiCodeProperties Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxBarcode2DProperties.Assign(TPersistent).)
GetMode | Represents method GetMode.
SetMode(Integer) | Represents method SetMode(Integer).
Top


TfrxMaxiCodeProperties.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxBarcodeProperties
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TfrxBarcode2DProperties.Assign(TPersistent)
See Also

Reference

  • TfrxMaxiCodeProperties
  • frxBarcodeProperties


TfrxMaxiCodeProperties.GetMode Method

Summary

Represents method GetMode.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetMode: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxMaxiCodeProperties
  • frxBarcodeProperties


TfrxMaxiCodeProperties.SetMode(Integer) Method

Summary

Represents method SetMode(Integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetMode(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxMaxiCodeProperties
  • frxBarcodeProperties


TfrxPDF417Properties Class

Summary

Represents type TfrxPDF417Properties.

Namespace: frxBarcodeProperties
Inheritance Hierarchy
TPersistent
frxBarcodeProperties.TfrxBarcode2DProperties
frxBarcodeProperties.TfrxPDF417Properties
Syntax
Delphi
type
 TfrxPDF417Properties = class(TfrxBarcode2DProperties)
 end;

The TfrxPDF417Properties type exposes the following members.

Properties
Show:
Name | Description
AspectRatio | Represents property AspectRatio.
CodePage | Represents property CodePage.
Columns | Represents property Columns.
CompactionMode | Represents property CompactionMode.
ErrorCorrection | Represents property ErrorCorrection.
PixelHeight | Represents property PixelHeight.
PixelWidth | Represents property PixelWidth.
Rows | Represents property Rows.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxBarcode2DProperties.Assign(TPersistent).)
Changed | Represents method Changed. (Inherited from TfrxBarcode2DProperties.)
GetAspectRatio | Represents method GetAspectRatio.
GetCodePage | Represents method GetCodePage.
GetColumns | Represents method GetColumns.
GetCompactionMode | Represents method GetCompactionMode.
GetErrorCorrection | Represents method GetErrorCorrection.
GetPixelHeight | Represents method GetPixelHeight.
GetPixelWidth | Represents method GetPixelWidth.
GetRows | Represents method GetRows.
SetAspectRatio(Extended) | Represents method SetAspectRatio(Extended).
SetCodePage(Integer) | Represents method SetCodePage(Integer).
SetColumns(Integer) | Represents method SetColumns(Integer).
SetCompactionMode(PDF417CompactionMode) | Represents method SetCompactionMode(PDF417CompactionMode).
SetErrorCorrection(PDF417ErrorCorrection) | Represents method SetErrorCorrection(PDF417ErrorCorrection).
SetPixelHeight(Integer) | Represents method SetPixelHeight(Integer).
SetPixelWidth(Integer) | Represents method SetPixelWidth(Integer).
SetRows(Integer) | Represents method SetRows(Integer).
SetWhose(TObject) | Represents method SetWhose(TObject). (Inherited from TfrxBarcode2DProperties.)
Top
Fields
Show:
Name | Description
FWhose | Represents field FWhose. (Inherited from TfrxBarcode2DProperties.)
Top
See Also

Reference

  • frxBarcodeProperties


TfrxPDF417Properties Properties

Properties
Name | Description
AspectRatio | Represents property AspectRatio.
CodePage | Represents property CodePage.
Columns | Represents property Columns.
CompactionMode | Represents property CompactionMode.
ErrorCorrection | Represents property ErrorCorrection.
PixelHeight | Represents property PixelHeight.
PixelWidth | Represents property PixelWidth.
Rows | Represents property Rows.
Top


TfrxPDF417Properties.AspectRatio Property

Summary

Represents property AspectRatio.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property AspectRatio: Extended read GetAspectRatio write SetAspectRatio;

Property Value

Type: Extended

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.CodePage Property

Summary

Represents property CodePage.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property CodePage: Integer read GetCodePage write SetCodePage;

Property Value

Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.Columns Property

Summary

Represents property Columns.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property Columns: Integer read GetColumns write SetColumns;

Property Value

Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.CompactionMode Property

Summary

Represents property CompactionMode.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property CompactionMode: PDF417CompactionMode read GetCompactionMode
 write SetCompactionMode;

Property Value

Type: PDF417CompactionMode

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.ErrorCorrection Property

Summary

Represents property ErrorCorrection.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property ErrorCorrection: PDF417ErrorCorrection read GetErrorCorrection
 write SetErrorCorrection;

Property Value

Type: PDF417ErrorCorrection

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.PixelHeight Property

Summary

Represents property PixelHeight.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property PixelHeight: Integer read GetPixelHeight write SetPixelHeight;

Property Value

Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.PixelWidth Property

Summary

Represents property PixelWidth.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property PixelWidth: Integer read GetPixelWidth write SetPixelWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.Rows Property

Summary

Represents property Rows.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property Rows: Integer read GetRows write SetRows;

Property Value

Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxBarcode2DProperties.Assign(TPersistent).)
GetAspectRatio | Represents method GetAspectRatio.
GetCodePage | Represents method GetCodePage.
GetColumns | Represents method GetColumns.
GetCompactionMode | Represents method GetCompactionMode.
GetErrorCorrection | Represents method GetErrorCorrection.
GetPixelHeight | Represents method GetPixelHeight.
GetPixelWidth | Represents method GetPixelWidth.
GetRows | Represents method GetRows.
SetAspectRatio(Extended) | Represents method SetAspectRatio(Extended).
SetCodePage(Integer) | Represents method SetCodePage(Integer).
SetColumns(Integer) | Represents method SetColumns(Integer).
SetCompactionMode(PDF417CompactionMode) | Represents method SetCompactionMode(PDF417CompactionMode).
SetErrorCorrection(PDF417ErrorCorrection) | Represents method SetErrorCorrection(PDF417ErrorCorrection).
SetPixelHeight(Integer) | Represents method SetPixelHeight(Integer).
SetPixelWidth(Integer) | Represents method SetPixelWidth(Integer).
SetRows(Integer) | Represents method SetRows(Integer).
Top


TfrxPDF417Properties.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxBarcodeProperties
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TfrxBarcode2DProperties.Assign(TPersistent)
See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.GetAspectRatio Method

Summary

Represents method GetAspectRatio.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetAspectRatio: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.GetCodePage Method

Summary

Represents method GetCodePage.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetCodePage: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.GetColumns Method

Summary

Represents method GetColumns.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetColumns: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.GetCompactionMode Method

Summary

Represents method GetCompactionMode.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetCompactionMode: PDF417CompactionMode;

Return Value

Type: PDF417CompactionMode

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.GetErrorCorrection Method

Summary

Represents method GetErrorCorrection.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetErrorCorrection: PDF417ErrorCorrection;

Return Value

Type: PDF417ErrorCorrection

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.GetPixelHeight Method

Summary

Represents method GetPixelHeight.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetPixelHeight: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.GetPixelWidth Method

Summary

Represents method GetPixelWidth.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetPixelWidth: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.GetRows Method

Summary

Represents method GetRows.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetRows: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.SetAspectRatio(Extended) Method

Summary

Represents method SetAspectRatio(Extended).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetAspectRatio(v: Extended);

Parameters

v
Type: Extended

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.SetCodePage(Integer) Method

Summary

Represents method SetCodePage(Integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetCodePage(v: Integer);

Parameters

v
Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.SetColumns(Integer) Method

Summary

Represents method SetColumns(Integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetColumns(v: Integer);

Parameters

v
Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.SetCompactionMode(PDF417CompactionMode) Method

Summary

Represents method SetCompactionMode(PDF417CompactionMode).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetCompactionMode(v: PDF417CompactionMode);

Parameters

v
Type: PDF417CompactionMode

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.SetErrorCorrection(PDF417ErrorCorrection) Method

Summary

Represents method SetErrorCorrection(PDF417ErrorCorrection).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetErrorCorrection(v: PDF417ErrorCorrection);

Parameters

v
Type: PDF417ErrorCorrection

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.SetPixelHeight(Integer) Method

Summary

Represents method SetPixelHeight(Integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetPixelHeight(v: Integer);

Parameters

v
Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.SetPixelWidth(Integer) Method

Summary

Represents method SetPixelWidth(Integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetPixelWidth(v: Integer);

Parameters

v
Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxPDF417Properties.SetRows(Integer) Method

Summary

Represents method SetRows(Integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetRows(v: Integer);

Parameters

v
Type: Integer

See Also

Reference

  • TfrxPDF417Properties
  • frxBarcodeProperties


TfrxQRProperties Class

Summary

Represents type TfrxQRProperties.

Namespace: frxBarcodeProperties
Inheritance Hierarchy
TPersistent
frxBarcodeProperties.TfrxBarcode2DProperties
frxBarcodeProperties.TfrxQRProperties
Syntax
Delphi
type
 TfrxQRProperties = class(TfrxBarcode2DProperties)
 end;

The TfrxQRProperties type exposes the following members.

Properties
Show:
Name | Description
CodePage | Represents property CodePage.
Encoding | Represents property Encoding.
ErrorLevels | Represents property ErrorLevels.
Logo | Represents property Logo.
PixelSize | Represents property PixelSize.
QuietZone | Represents property QuietZone.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxBarcode2DProperties.Assign(TPersistent).)
Changed | Represents method Changed. (Inherited from TfrxBarcode2DProperties.)
GetCodePage | Represents method GetCodePage.
GetEncoding | Represents method GetEncoding.
GetErrorLevels | Represents method GetErrorLevels.
GetLogo | Represents method GetLogo.
GetPixelSize | Represents method GetPixelSize.
GetQuietZone | Represents method GetQuietZone.
SetCodePage(Longint) | Represents method SetCodePage(Longint).
SetEncoding(TQRCodeEncoding) | Represents method SetEncoding(TQRCodeEncoding).
SetErrorLevels(TQRErrorLevels) | Represents method SetErrorLevels(TQRErrorLevels).
SetPixelSize(Integer) | Represents method SetPixelSize(Integer).
SetQuietZone(Integer) | Represents method SetQuietZone(Integer).
SetWhose(TObject) | Represents method SetWhose(TObject). (Inherited from TfrxBarcode2DProperties.)
Top
Fields
Show:
Name | Description
FWhose | Represents field FWhose. (Inherited from TfrxBarcode2DProperties.)
Top
See Also

Reference

  • frxBarcodeProperties


TfrxQRProperties Properties

Properties
Name | Description
CodePage | Represents property CodePage.
Encoding | Represents property Encoding.
ErrorLevels | Represents property ErrorLevels.
Logo | Represents property Logo.
PixelSize | Represents property PixelSize.
QuietZone | Represents property QuietZone.
Top


TfrxQRProperties.CodePage Property

Summary

Represents property CodePage.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property CodePage: Longint read GetCodePage write SetCodePage;

Property Value

Type: Longint

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.Encoding Property

Summary

Represents property Encoding.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property Encoding: TQRCodeEncoding read GetEncoding write SetEncoding;

Property Value

Type: TQRCodeEncoding

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.ErrorLevels Property

Summary

Represents property ErrorLevels.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property ErrorLevels: TQRErrorLevels read GetErrorLevels
 write SetErrorLevels;

Property Value

Type: TQRErrorLevels

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.Logo Property

Summary

Represents property Logo.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property Logo: TfrxBarcodeLogo read GetLogo;

Property Value

Type: TfrxBarcodeLogo

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.PixelSize Property

Summary

Represents property PixelSize.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property PixelSize: Integer read GetPixelSize write SetPixelSize;

Property Value

Type: Integer

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.QuietZone Property

Summary

Represents property QuietZone.

Namespace: frxBarcodeProperties
Syntax
Delphi
published
 property QuietZone: Integer read GetQuietZone write SetQuietZone;

Property Value

Type: Integer

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TfrxBarcode2DProperties.Assign(TPersistent).)
GetCodePage | Represents method GetCodePage.
GetEncoding | Represents method GetEncoding.
GetErrorLevels | Represents method GetErrorLevels.
GetLogo | Represents method GetLogo.
GetPixelSize | Represents method GetPixelSize.
GetQuietZone | Represents method GetQuietZone.
SetCodePage(Longint) | Represents method SetCodePage(Longint).
SetEncoding(TQRCodeEncoding) | Represents method SetEncoding(TQRCodeEncoding).
SetErrorLevels(TQRErrorLevels) | Represents method SetErrorLevels(TQRErrorLevels).
SetPixelSize(Integer) | Represents method SetPixelSize(Integer).
SetQuietZone(Integer) | Represents method SetQuietZone(Integer).
Top


TfrxQRProperties.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxBarcodeProperties
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TfrxBarcode2DProperties.Assign(TPersistent)
See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.GetCodePage Method

Summary

Represents method GetCodePage.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetCodePage: Longint;

Return Value

Type: Longint

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.GetEncoding Method

Summary

Represents method GetEncoding.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetEncoding: TQRCodeEncoding;

Return Value

Type: TQRCodeEncoding

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.GetErrorLevels Method

Summary

Represents method GetErrorLevels.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetErrorLevels: TQRErrorLevels;

Return Value

Type: TQRErrorLevels

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.GetLogo Method

Summary

Represents method GetLogo.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetLogo: TfrxBarcodeLogo;

Return Value

Type: TfrxBarcodeLogo

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.GetPixelSize Method

Summary

Represents method GetPixelSize.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetPixelSize: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.GetQuietZone Method

Summary

Represents method GetQuietZone.

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 function GetQuietZone: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.SetCodePage(Longint) Method

Summary

Represents method SetCodePage(Longint).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetCodePage(const Value: Longint);

Parameters

Value
Type: Longint

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.SetEncoding(TQRCodeEncoding) Method

Summary

Represents method SetEncoding(TQRCodeEncoding).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetEncoding(const Value: TQRCodeEncoding);

Parameters

Value
Type: TQRCodeEncoding

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.SetErrorLevels(TQRErrorLevels) Method

Summary

Represents method SetErrorLevels(TQRErrorLevels).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetErrorLevels(const Value: TQRErrorLevels);

Parameters

Value
Type: TQRErrorLevels

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.SetPixelSize(Integer) Method

Summary

Represents method SetPixelSize(Integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetPixelSize(v: Integer);

Parameters

v
Type: Integer

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


TfrxQRProperties.SetQuietZone(Integer) Method

Summary

Represents method SetQuietZone(Integer).

Namespace: frxBarcodeProperties
Syntax
Delphi
private
 procedure SetQuietZone(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxQRProperties
  • frxBarcodeProperties


frxBarcodeQR Namespace

Summary

Represents namespace frxBarcodeQR.

Classes
Name | Description
TfrxBarcodeLogo | Represents type TfrxBarcodeLogo.
TfrxBarcodeQR | Represents type TfrxBarcodeQR.
Top


frxBarcodeQR Classes

Classes
Name | Description
TfrxBarcodeLogo | Represents type TfrxBarcodeLogo.
TfrxBarcodeQR | Represents type TfrxBarcodeQR.
Top


TfrxBarcodeLogo Class

Summary

Represents type TfrxBarcodeLogo.

Namespace: frxBarcodeQR
Inheritance Hierarchy
TPersistent
frxBarcodeQR.TfrxBarcodeLogo
Syntax
Delphi
type
 TfrxBarcodeLogo = class(TPersistent)
 end;

The TfrxBarcodeLogo type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxBarcodeLogo class.
Destroy | Represents the destructor of the TfrxBarcodeLogo class.
Top
Properties
Show:
Name | Description
Height | Represents property Height.
Logo | Represents property Logo.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Draw(TRect,Extended,Extended,TCanvas,Extended) | Represents method Draw(TRect,Extended,Extended,TCanvas,Extended).
GetLogo | Represents method GetLogo.
GetLogoInst | Represents method GetLogoInst.
SetLogo(TPicture) | Represents method SetLogo(TPicture).
Top
Fields
Show:
Name | Description
FHeight | Represents field FHeight.
FLogo | Represents field FLogo.
FWidth | Represents field FWidth.
Top
See Also

Reference

  • frxBarcodeQR


TfrxBarcodeLogo Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxBarcodeLogo class.
Destroy | Represents the destructor of the TfrxBarcodeLogo class.
Top


TfrxBarcodeLogo.Create Constructor

Summary

Initializes a new instance of the TfrxBarcodeLogo class.

Namespace: frxBarcodeQR
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeLogo.Destroy Destructor

Summary

Represents the destructor of the TfrxBarcodeLogo class.

Namespace: frxBarcodeQR
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeLogo Properties

Properties
Name | Description
Height | Represents property Height.
Logo | Represents property Logo.
Width | Represents property Width.
Top


TfrxBarcodeLogo.Height Property

Summary

Represents property Height.

Namespace: frxBarcodeQR
Syntax
Delphi
published
 property Height: Integer read FHeight write FHeight;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeLogo.Logo Property

Summary

Represents property Logo.

Namespace: frxBarcodeQR
Syntax
Delphi
published
 property Logo: TPicture read GetLogo write SetLogo;

Property Value

Type: TPicture

See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeLogo.Width Property

Summary

Represents property Width.

Namespace: frxBarcodeQR
Syntax
Delphi
published
 property Width: Integer read FWidth write FWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeLogo Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Draw(TRect,Extended,Extended,TCanvas,Extended) | Represents method Draw(TRect,Extended,Extended,TCanvas,Extended).
GetLogo | Represents method GetLogo.
GetLogoInst | Represents method GetLogoInst.
SetLogo(TPicture) | Represents method SetLogo(TPicture).
Top


TfrxBarcodeLogo.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxBarcodeQR
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeLogo.Draw(TRect,Extended,Extended,TCanvas,Extended) Method

Summary

Represents method Draw(TRect,Extended,Extended,TCanvas,Extended).

Namespace: frxBarcodeQR
Syntax
Delphi
public
 procedure Draw(DrawRect: TRect; ScaleX, ScaleY: Extended; Canvas: TCanvas; Zoom: Extended);

Parameters

DrawRect
Type: TRect

ScaleX
Type: Extended

ScaleY
Type: Extended

Canvas
Type: TCanvas

Zoom
Type: Extended

See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeLogo.GetLogo Method

Summary

Represents method GetLogo.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 function GetLogo: TPicture;

Return Value

Type: TPicture

See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeLogo.GetLogoInst Method

Summary

Represents method GetLogoInst.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 function GetLogoInst: TPicture;

Return Value

Type: TPicture

See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeLogo.SetLogo(TPicture) Method

Summary

Represents method SetLogo(TPicture).

Namespace: frxBarcodeQR
Syntax
Delphi
private
 procedure SetLogo(const Value: TPicture);

Parameters

Value
Type: TPicture

See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeLogo Fields

Fields
Name | Description
FHeight | Represents field FHeight.
FLogo | Represents field FLogo.
FWidth | Represents field FWidth.
Top


TfrxBarcodeLogo.FHeight Field

Summary

Represents field FHeight.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 FHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeLogo.FLogo Field

Summary

Represents field FLogo.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 FLogo: TPicture;

Field Value

Type: TPicture

See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeLogo.FWidth Field

Summary

Represents field FWidth.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 FWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBarcodeLogo
  • frxBarcodeQR


TfrxBarcodeQR Class

Summary

Represents type TfrxBarcodeQR.

Namespace: frxBarcodeQR
Inheritance Hierarchy
TObject
frxBarcode2DBase.TfrxBarcode2DBase
frxBarcode2DBase.TfrxBarcode2DBaseWithUnion
frxBarcodeQR.TfrxBarcodeQR
Syntax
Delphi
type
 TfrxBarcodeQR = class( TfrxBarcode2DBaseWithUnion )
 end;

The TfrxBarcodeQR type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxBarcodeQR class. (Overrides TfrxBarcode2DBaseWithUnion.Create.)
Destroy | Represents the destructor of the TfrxBarcodeQR class. (Overrides TfrxBarcode2DBaseWithUnion.Destroy.)
Top
Properties
Show:
Name | Description
Codepage | Represents property Codepage.
Color | Represents property Color. (Inherited from TfrxBarcode2DBase.)
ColorBar | Represents property ColorBar. (Inherited from TfrxBarcode2DBase.)
Encoding | Represents property Encoding.
ErrorLevels | Represents property ErrorLevels.
ErrorText | Represents property ErrorText. (Inherited from TfrxBarcode2DBase.)
Font | Represents property Font. (Inherited from TfrxBarcode2DBase.)
FontScaled | Represents property FontScaled. (Inherited from TfrxBarcode2DBase.)
Height | Represents property Height. (Inherited from TfrxBarcode2DBase.)
Logo | Represents property Logo.
PixelHeight | Represents property PixelHeight. (Inherited from TfrxBarcode2DBase.)
PixelSize | Represents property PixelSize.
PixelWidth | Represents property PixelWidth. (Inherited from TfrxBarcode2DBase.)
QuietZone | Represents property QuietZone.
Rotation | Represents property Rotation. (Inherited from TfrxBarcode2DBase.)
ShowText | Represents property ShowText. (Inherited from TfrxBarcode2DBase.)
Text | Represents property Text. (Inherited from TfrxBarcode2DBase.)
Width | Represents property Width. (Inherited from TfrxBarcode2DBase.)
Zoom | Represents property Zoom. (Inherited from TfrxBarcode2DBase.)
Top
Methods
Show:
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
ClearFigures | Represents method ClearFigures. (Inherited from TfrxBarcode2DBaseWithUnion.)
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer). (Overrides TfrxBarcode2DBase.Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer).)
FillRect(TCanvas,TRect) | Represents method FillRect(TCanvas,TRect). (Inherited from TfrxBarcode2DBase.)
FVectorPrimitivesAdd(Integer,Integer,Integer,Integer) | Represents method FVectorPrimitivesAdd(Integer,Integer,Integer,Integer). (Inherited from TfrxBarcode2DBaseWithUnion.)
Generate | Represents method Generate.
GetCodepage | Represents method GetCodepage.
GetEncoding | Represents method GetEncoding.
GetErrorLevels | Represents method GetErrorLevels.
GetFooterHeight | Represents method GetFooterHeight. (Inherited from TfrxBarcode2DBase.)
GetHeight | Represents method GetHeight. (Inherited from TfrxBarcode2DBase.)
GetPixelSize | Represents method GetPixelSize.
GetQuietZone | Represents method GetQuietZone.
GetWidth | Represents method GetWidth. (Inherited from TfrxBarcode2DBase.)
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended). (Overrides TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).)
IsScaled | Represents method IsScaled. (Inherited from TfrxBarcode2DBase.)
SetCodepage(Longint) | Represents method SetCodepage(Longint).
SetColor(TColor) | Represents method SetColor(TColor). (Inherited from TfrxBarcode2DBase.)
SetColorBar(TColor) | Represents method SetColorBar(TColor). (Inherited from TfrxBarcode2DBase.)
SetEncoding(TQRCodeEncoding) | Represents method SetEncoding(TQRCodeEncoding).
SetErrorLevels(TQRErrorLevels) | Represents method SetErrorLevels(TQRErrorLevels).
SetErrorText(String) | Represents method SetErrorText(String). (Inherited from TfrxBarcode2DBase.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxBarcode2DBase.)
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean). (Inherited from TfrxBarcode2DBase.)
SetHeight(Integer) | Represents method SetHeight(Integer). (Inherited from TfrxBarcode2DBase.)
SetPixelSize(integer) | Represents method SetPixelSize(integer).
SetQuietZone(Integer) | Represents method SetQuietZone(Integer).
SetRotation(Integer) | Represents method SetRotation(Integer). (Inherited from TfrxBarcode2DBase.)
SetShowText(Boolean) | Represents method SetShowText(Boolean). (Inherited from TfrxBarcode2DBase.)
SetText(string) | Represents method SetText(string). (Overrides TfrxBarcode2DBase.SetText(String).)
SetZoom(Extended) | Represents method SetZoom(Extended). (Inherited from TfrxBarcode2DBase.)
T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte) | Represents method T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte). (Inherited from TfrxBarcode2DBaseWithUnion.)
Top
Fields
Show:
Name | Description
DotsL | Represents field DotsL. (Inherited from TfrxBarcode2DBaseWithUnion.)
DotsR | Represents field DotsR. (Inherited from TfrxBarcode2DBaseWithUnion.)
FColor | Represents field FColor. (Inherited from TfrxBarcode2DBase.)
FColorBar | Represents field FColorBar. (Inherited from TfrxBarcode2DBase.)
FDelphiZXingQRCode | Represents field FDelphiZXingQRCode.
FErrorText | Represents field FErrorText. (Inherited from TfrxBarcode2DBase.)
FFont | Represents field FFont. (Inherited from TfrxBarcode2DBase.)
FFontScaled | Represents field FFontScaled. (Inherited from TfrxBarcode2DBase.)
FHeight | Represents field FHeight. (Inherited from TfrxBarcode2DBase.)
FLogo | Represents field FLogo.
FPixelHeight | Represents field FPixelHeight. (Inherited from TfrxBarcode2DBase.)
FPixelWidth | Represents field FPixelWidth. (Inherited from TfrxBarcode2DBase.)
FQuietZone | Represents field FQuietZone. (Inherited from TfrxBarcode2DBase.)
FRotation | Represents field FRotation. (Inherited from TfrxBarcode2DBase.)
FShowText | Represents field FShowText. (Inherited from TfrxBarcode2DBase.)
FText | Represents field FText. (Inherited from TfrxBarcode2DBase.)
FVectorPrimitives | Represents field FVectorPrimitives. (Inherited from TfrxBarcode2DBaseWithUnion.)
FWidth | Represents field FWidth. (Inherited from TfrxBarcode2DBase.)
FZoom | Represents field FZoom. (Inherited from TfrxBarcode2DBase.)
Top
See Also

Reference

  • frxBarcodeQR


TfrxBarcodeQR Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxBarcodeQR class. (Overrides TfrxBarcode2DBaseWithUnion.Create.)
Destroy | Represents the destructor of the TfrxBarcodeQR class. (Overrides TfrxBarcode2DBaseWithUnion.Destroy.)
Top


TfrxBarcodeQR.Create Constructor

Summary

Initializes a new instance of the TfrxBarcodeQR class.

Namespace: frxBarcodeQR
Syntax
Delphi
public
 constructor Create; override;

Overrides

TfrxBarcode2DBaseWithUnion.Create
See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.Destroy Destructor

Summary

Represents the destructor of the TfrxBarcodeQR class.

Namespace: frxBarcodeQR
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxBarcode2DBaseWithUnion.Destroy
See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR Properties

Properties
Name | Description
Codepage | Represents property Codepage.
Encoding | Represents property Encoding.
ErrorLevels | Represents property ErrorLevels.
Logo | Represents property Logo.
PixelSize | Represents property PixelSize.
QuietZone | Represents property QuietZone.
Top


TfrxBarcodeQR.Codepage Property

Summary

Represents property Codepage.

Namespace: frxBarcodeQR
Syntax
Delphi
published
 property Codepage : Longint read GetCodepage write SetCodepage;

Property Value

Type: Longint

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.Encoding Property

Summary

Represents property Encoding.

Namespace: frxBarcodeQR
Syntax
Delphi
published
 property Encoding: TQRCodeEncoding read GetEncoding write SetEncoding;

Property Value

Type: TQRCodeEncoding

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.ErrorLevels Property

Summary

Represents property ErrorLevels.

Namespace: frxBarcodeQR
Syntax
Delphi
published
 property ErrorLevels: TQRErrorLevels read GetErrorLevels write SetErrorLevels;

Property Value

Type: TQRErrorLevels

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.Logo Property

Summary

Represents property Logo.

Namespace: frxBarcodeQR
Syntax
Delphi
published
 property Logo: TfrxBarcodeLogo read FLogo;

Property Value

Type: TfrxBarcodeLogo

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.PixelSize Property

Summary

Represents property PixelSize.

Namespace: frxBarcodeQR
Syntax
Delphi
published
 property PixelSize : integer read GetPixelSize write SetPixelSize;

Property Value

Type: integer

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.QuietZone Property

Summary

Represents property QuietZone.

Namespace: frxBarcodeQR
Syntax
Delphi
published
 property QuietZone: Integer read GetQuietZone write SetQuietZone;

Property Value

Type: Integer

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR Methods

Methods
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer). (Overrides TfrxBarcode2DBase.Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer).)
Generate | Represents method Generate.
GetCodepage | Represents method GetCodepage.
GetEncoding | Represents method GetEncoding.
GetErrorLevels | Represents method GetErrorLevels.
GetPixelSize | Represents method GetPixelSize.
GetQuietZone | Represents method GetQuietZone.
SetCodepage(Longint) | Represents method SetCodepage(Longint).
SetEncoding(TQRCodeEncoding) | Represents method SetEncoding(TQRCodeEncoding).
SetErrorLevels(TQRErrorLevels) | Represents method SetErrorLevels(TQRErrorLevels).
SetPixelSize(integer) | Represents method SetPixelSize(integer).
SetQuietZone(Integer) | Represents method SetQuietZone(Integer).
SetText(string) | Represents method SetText(string). (Overrides TfrxBarcode2DBase.SetText(String).)
Top


TfrxBarcodeQR.Assign(TfrxBarcode2DBase) Method

Summary

Represents method Assign(TfrxBarcode2DBase).

Namespace: frxBarcodeQR
Syntax
Delphi
public
 procedure Assign(src: TfrxBarcode2DBase);override;

Parameters

src
Type: TfrxBarcode2DBase

Overrides

TfrxBarcode2DBase.Assign(TfrxBarcode2DBase)
See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) Method

Summary

Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer).

Namespace: frxBarcodeQR
Syntax
Delphi
public
 procedure Draw2DBarcode(var g: TCanvas; scalex, scaley: Extended;
 x, y: Integer); override;

Parameters

g
Type: TCanvas

scalex
Type: Extended

scaley
Type: Extended

x
Type: Integer

y
Type: Integer

Overrides

TfrxBarcode2DBase.Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer)
See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.Generate Method

Summary

Represents method Generate.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 procedure Generate();
See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.GetCodepage Method

Summary

Represents method GetCodepage.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 function GetCodepage: Longint;

Return Value

Type: Longint

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.GetEncoding Method

Summary

Represents method GetEncoding.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 function GetEncoding: TQRCodeEncoding;

Return Value

Type: TQRCodeEncoding

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.GetErrorLevels Method

Summary

Represents method GetErrorLevels.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 function GetErrorLevels: TQRErrorLevels;

Return Value

Type: TQRErrorLevels

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.GetPixelSize Method

Summary

Represents method GetPixelSize.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 function GetPixelSize : integer;

Return Value

Type: integer

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.GetQuietZone Method

Summary

Represents method GetQuietZone.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 function GetQuietZone: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.SetCodepage(Longint) Method

Summary

Represents method SetCodepage(Longint).

Namespace: frxBarcodeQR
Syntax
Delphi
private
 procedure SetCodepage(const Value: Longint);

Parameters

Value
Type: Longint

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.SetEncoding(TQRCodeEncoding) Method

Summary

Represents method SetEncoding(TQRCodeEncoding).

Namespace: frxBarcodeQR
Syntax
Delphi
private
 procedure SetEncoding(const Value: TQRCodeEncoding);

Parameters

Value
Type: TQRCodeEncoding

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.SetErrorLevels(TQRErrorLevels) Method

Summary

Represents method SetErrorLevels(TQRErrorLevels).

Namespace: frxBarcodeQR
Syntax
Delphi
private
 procedure SetErrorLevels(const Value: TQRErrorLevels);

Parameters

Value
Type: TQRErrorLevels

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.SetPixelSize(integer) Method

Summary

Represents method SetPixelSize(integer).

Namespace: frxBarcodeQR
Syntax
Delphi
private
 procedure SetPixelSize(v : integer);

Parameters

v
Type: integer

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.SetQuietZone(Integer) Method

Summary

Represents method SetQuietZone(Integer).

Namespace: frxBarcodeQR
Syntax
Delphi
private
 procedure SetQuietZone(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.SetText(string) Method

Summary

Represents method SetText(string).

Namespace: frxBarcodeQR
Syntax
Delphi
protected
 procedure SetText( v : string ); override;

Parameters

v
Type: string

Overrides

TfrxBarcode2DBase.SetText(String)
See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR Fields

Fields
Name | Description
FDelphiZXingQRCode | Represents field FDelphiZXingQRCode.
FLogo | Represents field FLogo.
Top


TfrxBarcodeQR.FDelphiZXingQRCode Field

Summary

Represents field FDelphiZXingQRCode.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 FDelphiZXingQRCode: TDelphiZXingQRCode;

Field Value

Type: TDelphiZXingQRCode

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


TfrxBarcodeQR.FLogo Field

Summary

Represents field FLogo.

Namespace: frxBarcodeQR
Syntax
Delphi
private
 FLogo: TfrxBarcodeLogo;

Field Value

Type: TfrxBarcodeLogo

See Also

Reference

  • TfrxBarcodeQR
  • frxBarcodeQR


frxBarcodOneCode Namespace

Summary

Represents namespace frxBarcodOneCode.

Classes
Name | Description
TOneCode | Represents type TOneCode.
Top
Types
Name | Description
TLongIntArray | Represents an array of the LongInt type.
Top


frxBarcodOneCode Classes

Classes
Name | Description
TOneCode | Represents type TOneCode.
Top


TOneCode Class

Summary

Represents type TOneCode.

Namespace: frxBarcodOneCode
Inheritance Hierarchy
TObject
frxBarcodOneCode.TOneCode
Syntax
Delphi
type
 TOneCode = class
 end;

The TOneCode type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TOneCode class.
Top
Methods
Show:
Name | Description
AnsiToInt(AnsiString) | Represents method AnsiToInt(AnsiString).
Bars(AnsiString) | Represents method Bars(AnsiString).
OneCodeInfo(LongInt) | Represents method OneCodeInfo(LongInt).
OneCodeInitializeNof13Table(TLongIntArray,LongInt,LongInt) | Represents method OneCodeInitializeNof13Table(TLongIntArray,LongInt,LongInt).
OneCodeMathAdd(TLongIntArray,LongInt,LongInt) | Represents method OneCodeMathAdd(TLongIntArray,LongInt,LongInt).
OneCodeMathDivide(AnsiString) | Represents method OneCodeMathDivide(AnsiString).
OneCodeMathFcs(TLongIntArray) | Represents method OneCodeMathFcs(TLongIntArray).
OneCodeMathMultiply(TLongIntArray,LongInt,LongInt) | Represents method OneCodeMathMultiply(TLongIntArray,LongInt,LongInt).
OneCodeMathReverse(LongInt) | Represents method OneCodeMathReverse(LongInt).
PadLeft(AnsiString,Integer,AnsiChar) | Represents method PadLeft(AnsiString,Integer,AnsiChar).
Substring(AnsiString,Integer,Integer) | Represents method Substring(AnsiString,Integer,Integer).
TrimOff(AnsiString,AnsiString) | Represents method TrimOff(AnsiString,AnsiString).
TrimStart(AnsiString,AnsiChar) | Represents method TrimStart(AnsiString,AnsiChar).
Top
Fields
Show:
Name | Description
codewordArray | Represents field codewordArray.
entries2Of13 | Represents field entries2Of13.
entries5Of13 | Represents field entries5Of13.
table2Of13 | Represents field table2Of13.
table5Of13 | Represents field table5Of13.
Top
See Also

Reference

  • frxBarcodOneCode


TOneCode Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TOneCode class.
Top


TOneCode.Create Constructor

Summary

Initializes a new instance of the TOneCode class.

Namespace: frxBarcodOneCode
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode Methods

Methods
Name | Description
AnsiToInt(AnsiString) | Represents method AnsiToInt(AnsiString).
Bars(AnsiString) | Represents method Bars(AnsiString).
OneCodeInfo(LongInt) | Represents method OneCodeInfo(LongInt).
OneCodeInitializeNof13Table(TLongIntArray,LongInt,LongInt) | Represents method OneCodeInitializeNof13Table(TLongIntArray,LongInt,LongInt).
OneCodeMathAdd(TLongIntArray,LongInt,LongInt) | Represents method OneCodeMathAdd(TLongIntArray,LongInt,LongInt).
OneCodeMathDivide(AnsiString) | Represents method OneCodeMathDivide(AnsiString).
OneCodeMathFcs(TLongIntArray) | Represents method OneCodeMathFcs(TLongIntArray).
OneCodeMathMultiply(TLongIntArray,LongInt,LongInt) | Represents method OneCodeMathMultiply(TLongIntArray,LongInt,LongInt).
OneCodeMathReverse(LongInt) | Represents method OneCodeMathReverse(LongInt).
PadLeft(AnsiString,Integer,AnsiChar) | Represents method PadLeft(AnsiString,Integer,AnsiChar).
Substring(AnsiString,Integer,Integer) | Represents method Substring(AnsiString,Integer,Integer).
TrimOff(AnsiString,AnsiString) | Represents method TrimOff(AnsiString,AnsiString).
TrimStart(AnsiString,AnsiChar) | Represents method TrimStart(AnsiString,AnsiChar).
Top


TOneCode.AnsiToInt(AnsiString) Method

Summary

Represents method AnsiToInt(AnsiString).

Namespace: frxBarcodOneCode
Syntax
Delphi
private
 function AnsiToInt(str: AnsiString): Integer;

Parameters

str
Type: AnsiString

Return Value

Type: Integer

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.Bars(AnsiString) Method

Summary

Represents method Bars(AnsiString).

Namespace: frxBarcodOneCode
Syntax
Delphi
public
 function Bars(source: AnsiString): AnsiString;

Parameters

source
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.OneCodeInfo(LongInt) Method

Summary

Represents method OneCodeInfo(LongInt).

Namespace: frxBarcodOneCode
Syntax
Delphi
protected
 function OneCodeInfo(topic: LongInt): TLongIntArray;

Parameters

topic
Type: LongInt

Return Value

Type: TLongIntArray

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.OneCodeInitializeNof13Table(TLongIntArray,LongInt,LongInt) Method

Summary

Represents method OneCodeInitializeNof13Table(TLongIntArray,LongInt,LongInt).

Namespace: frxBarcodOneCode
Syntax
Delphi
protected
 function OneCodeInitializeNof13Table(ai: TLongIntArray; i, j: LongInt): Boolean;

Parameters

ai
Type: TLongIntArray

i
Type: LongInt

j
Type: LongInt

Return Value

Type: Boolean

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.OneCodeMathAdd(TLongIntArray,LongInt,LongInt) Method

Summary

Represents method OneCodeMathAdd(TLongIntArray,LongInt,LongInt).

Namespace: frxBarcodOneCode
Syntax
Delphi
protected
 function OneCodeMathAdd(bytearray: TLongIntArray; i, j: LongInt): Boolean;

Parameters

bytearray
Type: TLongIntArray

i
Type: LongInt

j
Type: LongInt

Return Value

Type: Boolean

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.OneCodeMathDivide(AnsiString) Method

Summary

Represents method OneCodeMathDivide(AnsiString).

Namespace: frxBarcodOneCode
Syntax
Delphi
protected
 function OneCodeMathDivide(v: AnsiString): Boolean;

Parameters

v
Type: AnsiString

Return Value

Type: Boolean

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.OneCodeMathFcs(TLongIntArray) Method

Summary

Represents method OneCodeMathFcs(TLongIntArray).

Namespace: frxBarcodOneCode
Syntax
Delphi
protected
 function OneCodeMathFcs(bytearray: TLongIntArray): LongInt;

Parameters

bytearray
Type: TLongIntArray

Return Value

Type: LongInt

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.OneCodeMathMultiply(TLongIntArray,LongInt,LongInt) Method

Summary

Represents method OneCodeMathMultiply(TLongIntArray,LongInt,LongInt).

Namespace: frxBarcodOneCode
Syntax
Delphi
protected
 function OneCodeMathMultiply(bytearray: TLongIntArray; i, j: LongInt): Boolean;

Parameters

bytearray
Type: TLongIntArray

i
Type: LongInt

j
Type: LongInt

Return Value

Type: Boolean

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.OneCodeMathReverse(LongInt) Method

Summary

Represents method OneCodeMathReverse(LongInt).

Namespace: frxBarcodOneCode
Syntax
Delphi
protected
 function OneCodeMathReverse(i: LongInt): LongInt;

Parameters

i
Type: LongInt

Return Value

Type: LongInt

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.PadLeft(AnsiString,Integer,AnsiChar) Method

Summary

Represents method PadLeft(AnsiString,Integer,AnsiChar).

Namespace: frxBarcodOneCode
Syntax
Delphi
private
 function PadLeft(str: AnsiString; TotalWidth: Integer;
 PaddingChar: AnsiChar): AnsiString;

Parameters

str
Type: AnsiString

TotalWidth
Type: Integer

PaddingChar
Type: AnsiChar

Return Value

Type: AnsiString

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.Substring(AnsiString,Integer,Integer) Method

Summary

Represents method Substring(AnsiString,Integer,Integer).

Namespace: frxBarcodOneCode
Syntax
Delphi
private
 function Substring(str: AnsiString; startIndex: Integer;
 len: Integer = -1): AnsiString;

Parameters

str
Type: AnsiString

startIndex
Type: Integer

len
Type: Integer

Return Value

Type: AnsiString

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.TrimOff(AnsiString,AnsiString) Method

Summary

Represents method TrimOff(AnsiString,AnsiString).

Namespace: frxBarcodOneCode
Syntax
Delphi
private
 function TrimOff(source, bad: AnsiString): AnsiString;

Parameters

source
Type: AnsiString

bad
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.TrimStart(AnsiString,AnsiChar) Method

Summary

Represents method TrimStart(AnsiString,AnsiChar).

Namespace: frxBarcodOneCode
Syntax
Delphi
private
 function TrimStart(str: AnsiString; TrimChar: AnsiChar): AnsiString;

Parameters

str
Type: AnsiString

TrimChar
Type: AnsiChar

Return Value

Type: AnsiString

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode Fields

Fields
Name | Description
codewordArray | Represents field codewordArray.
entries2Of13 | Represents field entries2Of13.
entries5Of13 | Represents field entries5Of13.
table2Of13 | Represents field table2Of13.
table5Of13 | Represents field table5Of13.
Top


TOneCode.codewordArray Field

Summary

Represents field codewordArray.

Namespace: frxBarcodOneCode
Syntax
Delphi
protected
 codewordArray: array[0..9, 0..1] of Int64;

Field Value

Type: array[0..9, 0..1] of Int64

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.entries2Of13 Field

Summary

Represents field entries2Of13.

Namespace: frxBarcodOneCode
Syntax
Delphi
protected
 entries2Of13: Int64;

Field Value

Type: Int64

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.entries5Of13 Field

Summary

Represents field entries5Of13.

Namespace: frxBarcodOneCode
Syntax
Delphi
protected
 entries5Of13: Int64;

Field Value

Type: Int64

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.table2Of13 Field

Summary

Represents field table2Of13.

Namespace: frxBarcodOneCode
Syntax
Delphi
protected
 table2Of13: TLongIntArray;

Field Value

Type: TLongIntArray

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


TOneCode.table5Of13 Field

Summary

Represents field table5Of13.

Namespace: frxBarcodOneCode
Syntax
Delphi
protected
 table5Of13: TLongIntArray;

Field Value

Type: TLongIntArray

See Also

Reference

  • TOneCode
  • frxBarcodOneCode


frxBarcodOneCode Types

Types
Name | Description
TLongIntArray | Represents an array of the LongInt type.
Top


TLongIntArray Type

Summary

Represents an array of the LongInt type.

Namespace: frxBarcodOneCode
Syntax
Delphi
type
 TLongIntArray = array of LongInt;
See Also

Reference

  • frxBarcodOneCode


frxBaseForm Namespace

Summary

This unit contains classes of the base dialog form used for every form in FastReport. This form handles save and load state, HIDPI messages, localization messages.

Classes
Name | Description
TfrxBaseForm | The base class for dialog forms used in FastReport. This class handles save and load state, HIDPI messages,localization messages.
TfrxBaseLoadSavePrefForm | The base class for the forms which should save position and sized by default to setting storage(registry).
TfrxMessageObject | This class used to pass messages of the form. internal use only.
Top
Enumerations
Name | Description
TfrxPreferencesAction | This enumeration defines action of preference state. It used to save/load/restore form state.
TfrxPreferencesLoadEvent | Defines when form should apply saved preference settings.
TfrxPreferencesType | Type of the form settings which should be processed by current form.
Top
Types
Name | Description
TfrxPreferencesTypes | Set of preference types.
Top


frxBaseForm Classes

Classes
Name | Description
TfrxBaseForm | The base class for dialog forms used in FastReport. This class handles save and load state, HIDPI messages,localization messages.
TfrxBaseLoadSavePrefForm | The base class for the forms which should save position and sized by default to setting storage(registry).
TfrxMessageObject | This class used to pass messages of the form. internal use only.
Top


TfrxBaseForm Class

Summary

The base class for dialog forms used in FastReport. This class handles save and load state, HIDPI messages,localization messages.

Namespace: frxBaseForm
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxBaseForm.TfrxBaseLoadSavePrefForm
frxClass.TfrxCustomDesigner
frxDataTree.TfrxDataTreeForm
frxDialogForm.TfrxDialogForm
frxInsp.TfrxObjectInspector
frxMapLayerTags.TMapLayerTagsForm
frxMapShapeTags.TMapShapeTagsForm
frxPopupForm.TfrxPopupForm
frxPreview.TfrxPreviewForm
frxPreviewPageSettings.TfrxPageSettingsForm
frxReportTree.TfrxReportTreeForm
Syntax
Delphi
type
 TfrxBaseForm = class(TForm)
 end;

The TfrxBaseForm type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseForm class.
Top
Properties
Show:
Name | Description
CurrentFormPPI | Returns current PPI value of the form.
IsPPIChanging | Represents property IsPPIChanging.
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction.
AfterPPIChange | Represents method AfterPPIChange.
AfterPPIMessage | Represents method AfterPPIMessage.
BeforeDestruction | Represents method BeforeDestruction.
BeforePPIChange | Represents method BeforePPIChange.
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer).
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean).
DoClose(TCloseAction) | Represents method DoClose(TCloseAction).
DoShow | Represents method DoShow.
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer).
FormShowAfterLoad | Represents method FormShowAfterLoad.
FormShowBeforeLoad | Represents method FormShowBeforeLoad.
GetAvailablePreferences | Represents method GetAvailablePreferences.
GetCurrentFormPPI | Represents method GetCurrentFormPPI.
GetFormSectionName | Represents method GetFormSectionName.
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object.
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array.
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject).
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter.
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form.
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter.
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject).
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject).
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer).
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms.
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form.
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method.
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources.
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage).
Top
Fields
Show:
Name | Description
FCurrentFormPPI | Represents field FCurrentFormPPI.
FHostedControls | Represents field FHostedControls.
FIsPPIChanging | Represents field FIsPPIChanging.
FNeedUpdatePPI | Represents field FNeedUpdatePPI.
FPreferences | Represents field FPreferences.
FPrefEvent | Represents field FPrefEvent.
FPrefIsLoaded | Represents field FPrefIsLoaded.
FPrefIsLocked | Represents field FPrefIsLocked.
FPrefIsSaved | Represents field FPrefIsSaved.
FSavedPPI | Represents field FSavedPPI.
FShowed | Represents field FShowed.
FUpdatingPPI | Represents field FUpdatingPPI.
Top
See Also

Reference

  • frxBaseForm


TfrxBaseForm Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseForm class.
Top


TfrxBaseForm.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxBaseForm class.

Namespace: frxBaseForm
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm Properties

Properties
Name | Description
CurrentFormPPI | Returns current PPI value of the form.
IsPPIChanging | Represents property IsPPIChanging.
Top


TfrxBaseForm.CurrentFormPPI Property

Summary

Returns current PPI value of the form.

Namespace: frxBaseForm
Syntax
Delphi
public
 property CurrentFormPPI: Integer read GetCurrentFormPPI;

Property Value

Type: Integer

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.IsPPIChanging Property

Summary

Represents property IsPPIChanging.

Namespace: frxBaseForm
Syntax
Delphi
public
 property IsPPIChanging: Boolean read FIsPPIChanging;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm Methods

Methods
Name | Description
AfterConstruction | Represents method AfterConstruction.
AfterPPIChange | Represents method AfterPPIChange.
AfterPPIMessage | Represents method AfterPPIMessage.
BeforeDestruction | Represents method BeforeDestruction.
BeforePPIChange | Represents method BeforePPIChange.
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer).
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean).
DoClose(TCloseAction) | Represents method DoClose(TCloseAction).
DoShow | Represents method DoShow.
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer).
FormShowAfterLoad | Represents method FormShowAfterLoad.
FormShowBeforeLoad | Represents method FormShowBeforeLoad.
GetAvailablePreferences | Represents method GetAvailablePreferences.
GetCurrentFormPPI | Represents method GetCurrentFormPPI.
GetFormSectionName | Represents method GetFormSectionName.
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object.
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array.
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject).
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter.
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form.
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter.
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject).
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject).
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer).
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms.
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form.
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method.
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources.
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage).
Top


TfrxBaseForm.AfterConstruction Method

Summary

Represents method AfterConstruction.

Namespace: frxBaseForm
Syntax
Delphi
public
 procedure AfterConstruction; override;
See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.AfterPPIChange Method

Summary

Represents method AfterPPIChange.

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure AfterPPIChange; virtual;
See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.AfterPPIMessage Method

Summary

Represents method AfterPPIMessage.

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure AfterPPIMessage; virtual;
See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.BeforeDestruction Method

Summary

Represents method BeforeDestruction.

Namespace: frxBaseForm
Syntax
Delphi
public
 procedure BeforeDestruction; override;
See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.BeforePPIChange Method

Summary

Represents method BeforePPIChange.

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure BeforePPIChange; virtual;
See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.ChangeScale(Integer,Integer) Method

Summary

Represents method ChangeScale(Integer,Integer).

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure ChangeScale(M, D: Integer); overload; override;

Parameters

M
Type: Integer

D
Type: Integer

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.ChangeScale(Integer,Integer,Boolean) Method

Summary

Represents method ChangeScale(Integer,Integer,Boolean).

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure ChangeScale(M, D: Integer; isDpiChange: Boolean); overload; override;

Parameters

M
Type: Integer

D
Type: Integer

isDpiChange
Type: Boolean

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.DoClose(TCloseAction) Method

Summary

Represents method DoClose(TCloseAction).

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure DoClose(var Action: TCloseAction); override;

Parameters

Action
Type: TCloseAction

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.DoShow Method

Summary

Represents method DoShow.

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure DoShow; override;
See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.DoUpdateFormPPI(Integer) Method

Summary

Represents method DoUpdateFormPPI(Integer).

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure DoUpdateFormPPI(aNewPPI: Integer);

Parameters

aNewPPI
Type: Integer

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FormShowAfterLoad Method

Summary

Represents method FormShowAfterLoad.

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure FormShowAfterLoad; virtual;
See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FormShowBeforeLoad Method

Summary

Represents method FormShowBeforeLoad.

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure FormShowBeforeLoad; virtual;
See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.GetAvailablePreferences Method

Summary

Represents method GetAvailablePreferences.

Namespace: frxBaseForm
Syntax
Delphi
protected
 function GetAvailablePreferences: TfrxPreferencesTypes; virtual;

Return Value

Type: TfrxPreferencesTypes

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.GetCurrentFormPPI Method

Summary

Represents method GetCurrentFormPPI.

Namespace: frxBaseForm
Syntax
Delphi
private
 function GetCurrentFormPPI: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.GetFormSectionName Method

Summary

Represents method GetFormSectionName.

Namespace: frxBaseForm
Syntax
Delphi
protected
 function GetFormSectionName: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.GetPreferencesStorage(Boolean) Method

Summary

This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object.

Namespace: frxBaseForm
Syntax
Delphi
public
 function GetPreferencesStorage(aDefault: Boolean): TObject; virtual;

Parameters

aDefault
Type: Boolean

Return Value

Type: TObject

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.HostControls(TWinControl) Method

Summary

Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array.

Namespace: frxBaseForm
Syntax
Delphi
public
 procedure HostControls(Host: TWinControl); virtual;

Parameters

Host
Type: TWinControl

Host control for form objects.

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.LoadFormPreferences(TObject,TObject) Method

Summary

Represents method LoadFormPreferences(TObject,TObject).

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure LoadFormPreferences(PreferencesStorage: TObject; DefPreferencesStorage: TObject); virtual;

Parameters

PreferencesStorage
Type: TObject

DefPreferencesStorage
Type: TObject

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) Method

Summary

Loads form settings from storage object with using preference type parameter.

Namespace: frxBaseForm
Syntax
Delphi
public
 procedure LoadFormPrefType(PreferencesStorage: TObject; DefPreferencesStorage: TObject; PrefTyp: TfrxPreferencesTypes);

Parameters

PreferencesStorage
Type: TObject

Reference to a storage object.

DefPreferencesStorage
Type: TObject

Reference to a storage object with default settings.

PrefTyp
Type: TfrxPreferencesTypes

Settings type.

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.ProcessPreferences(TfrxPreferencesAction) Method

Summary

This method used to process preference action(load/save/restore) with default type for current form.

Namespace: frxBaseForm
Syntax
Delphi
public
 procedure ProcessPreferences(aPrefArction: TfrxPreferencesAction); overload;

Parameters

aPrefArction
Type: TfrxPreferencesAction

Preference action type.

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) Method

Summary

This method used to process preference action(load/save/restore) with non-default type which passed as a parameter.

Namespace: frxBaseForm
Syntax
Delphi
public
 procedure ProcessPreferences(aPrefArction: TfrxPreferencesAction; PrefTyp: TfrxPreferencesTypes); overload;

Parameters

aPrefArction
Type: TfrxPreferencesAction

Preference action type.

PrefTyp
Type: TfrxPreferencesTypes

Preference types.

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.ResetFormPreferences(TObject) Method

Summary

Represents method ResetFormPreferences(TObject).

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure ResetFormPreferences(PreferencesStorage: TObject); virtual;

Parameters

PreferencesStorage
Type: TObject

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.SaveFormPreferences(TObject,TObject) Method

Summary

Represents method SaveFormPreferences(TObject,TObject).

Namespace: frxBaseForm
Syntax
Delphi
protected
 procedure SaveFormPreferences(PreferencesStorage: TObject; DefPreferencesStorage: TObject); virtual;

Parameters

PreferencesStorage
Type: TObject

DefPreferencesStorage
Type: TObject

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) Method

Summary

Saves form settings to storage object with using preference type parameter.

Namespace: frxBaseForm
Syntax
Delphi
public
 procedure SaveFormPrefType(PreferencesStorage: TObject; DefPreferencesStorage: TObject; PrefTyp: TfrxPreferencesTypes);

Parameters

PreferencesStorage
Type: TObject

Reference to a storage object.

DefPreferencesStorage
Type: TObject

Reference to a storage object with default settings.

PrefTyp
Type: TfrxPreferencesTypes

Settings type.

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.ScaleForPPI(Integer) Method

Summary

Represents method ScaleForPPI(Integer).

Namespace: frxBaseForm
Syntax
Delphi
public
 procedure ScaleForPPI(NewPPI: Integer); override;

Parameters

NewPPI
Type: Integer

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.SendPPIMessage(TWinControl,Integer) Method

Summary

Sends PPI message to a form or a control and all child dock forms.

Namespace: frxBaseForm
Syntax
Delphi
public
 procedure SendPPIMessage(aWinControl:TWinControl; aNewPPI: Integer);

Parameters

aWinControl
Type: TWinControl

Control that should receive message.

aNewPPI
Type: Integer

New PPI value.

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.UnhostControls(TModalResult) Method

Summary

Returns back all moved by HostControls function controls back to owner form and pass modal result to the form.

Namespace: frxBaseForm
Syntax
Delphi
public
 procedure UnhostControls(AModalResult: TModalResult); virtual;

Parameters

AModalResult
Type: TModalResult

Modal result of an action.

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.UpdateFormPPI(Integer) Method

Summary

Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method.

Namespace: frxBaseForm
Syntax
Delphi
public
 procedure UpdateFormPPI(aNewPPI: Integer); virtual;

Parameters

aNewPPI
Type: Integer

New PPI value.

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.UpdateResouces Method

Summary

Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources.

Namespace: frxBaseForm
Syntax
Delphi
public
 procedure UpdateResouces; virtual;
See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.WMDpiChanged(TMessage) Method

Summary

Represents method WMDpiChanged(TMessage).

Namespace: frxBaseForm
Syntax
Delphi
private
 procedure WMDpiChanged(var Message: TMessage); message FRX_WM_DPICHANGED;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm Fields

Fields
Name | Description
FCurrentFormPPI | Represents field FCurrentFormPPI.
FHostedControls | Represents field FHostedControls.
FIsPPIChanging | Represents field FIsPPIChanging.
FNeedUpdatePPI | Represents field FNeedUpdatePPI.
FPreferences | Represents field FPreferences.
FPrefEvent | Represents field FPrefEvent.
FPrefIsLoaded | Represents field FPrefIsLoaded.
FPrefIsLocked | Represents field FPrefIsLocked.
FPrefIsSaved | Represents field FPrefIsSaved.
FSavedPPI | Represents field FSavedPPI.
FShowed | Represents field FShowed.
FUpdatingPPI | Represents field FUpdatingPPI.
Top


TfrxBaseForm.FCurrentFormPPI Field

Summary

Represents field FCurrentFormPPI.

Namespace: frxBaseForm
Syntax
Delphi
private
 FCurrentFormPPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FHostedControls Field

Summary

Represents field FHostedControls.

Namespace: frxBaseForm
Syntax
Delphi
protected
 FHostedControls: array of TControl;

Field Value

Type: array of TControl

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FIsPPIChanging Field

Summary

Represents field FIsPPIChanging.

Namespace: frxBaseForm
Syntax
Delphi
private
 FIsPPIChanging: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FNeedUpdatePPI Field

Summary

Represents field FNeedUpdatePPI.

Namespace: frxBaseForm
Syntax
Delphi
private
 FNeedUpdatePPI: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FPreferences Field

Summary

Represents field FPreferences.

Namespace: frxBaseForm
Syntax
Delphi
private
 FPreferences: TfrxPreferencesTypes;

Field Value

Type: TfrxPreferencesTypes

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FPrefEvent Field

Summary

Represents field FPrefEvent.

Namespace: frxBaseForm
Syntax
Delphi
protected
 FPrefEvent: TfrxPreferencesLoadEvent;

Field Value

Type: TfrxPreferencesLoadEvent

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FPrefIsLoaded Field

Summary

Represents field FPrefIsLoaded.

Namespace: frxBaseForm
Syntax
Delphi
private
 FPrefIsLoaded: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FPrefIsLocked Field

Summary

Represents field FPrefIsLocked.

Namespace: frxBaseForm
Syntax
Delphi
private
 FPrefIsLocked: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FPrefIsSaved Field

Summary

Represents field FPrefIsSaved.

Namespace: frxBaseForm
Syntax
Delphi
private
 FPrefIsSaved: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FSavedPPI Field

Summary

Represents field FSavedPPI.

Namespace: frxBaseForm
Syntax
Delphi
private
 FSavedPPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FShowed Field

Summary

Represents field FShowed.

Namespace: frxBaseForm
Syntax
Delphi
private
 FShowed: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseForm.FUpdatingPPI Field

Summary

Represents field FUpdatingPPI.

Namespace: frxBaseForm
Syntax
Delphi
private
 FUpdatingPPI: TfrxMessageObject;

Field Value

Type: TfrxMessageObject

See Also

Reference

  • TfrxBaseForm
  • frxBaseForm


TfrxBaseLoadSavePrefForm Class

Summary

The base class for the forms which should save position and sized by default to setting storage(registry).

Namespace: frxBaseForm
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxBaseForm.TfrxBaseLoadSavePrefForm
Syntax
Delphi
type
 TfrxBaseLoadSavePrefForm = class(TfrxBaseForm)
 end;

The TfrxBaseLoadSavePrefForm type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseForm class. (Inherited from TfrxBaseForm.)
Top
Properties
Show:
Name | Description
CurrentFormPPI | Returns current PPI value of the form. (Inherited from TfrxBaseForm.)
IsPPIChanging | Represents property IsPPIChanging. (Inherited from TfrxBaseForm.)
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseForm.)
AfterPPIChange | Represents method AfterPPIChange. (Inherited from TfrxBaseForm.)
AfterPPIMessage | Represents method AfterPPIMessage. (Inherited from TfrxBaseForm.)
BeforeDestruction | Represents method BeforeDestruction. (Inherited from TfrxBaseForm.)
BeforePPIChange | Represents method BeforePPIChange. (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer). (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean). (Inherited from TfrxBaseForm.)
DoClose(TCloseAction) | Represents method DoClose(TCloseAction). (Inherited from TfrxBaseForm.)
DoShow | Represents method DoShow. (Inherited from TfrxBaseForm.)
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer). (Inherited from TfrxBaseForm.)
FormShowAfterLoad | Represents method FormShowAfterLoad. (Inherited from TfrxBaseForm.)
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Inherited from TfrxBaseForm.)
GetAvailablePreferences | Represents method GetAvailablePreferences. (Overrides TfrxBaseForm.GetAvailablePreferences.)
GetFormSectionName | Represents method GetFormSectionName. (Inherited from TfrxBaseForm.)
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Inherited from TfrxBaseForm.)
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Inherited from TfrxBaseForm.)
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter. (Inherited from TfrxBaseForm.)
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Inherited from TfrxBaseForm.)
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxBaseForm.)
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms. (Inherited from TfrxBaseForm.)
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form. (Inherited from TfrxBaseForm.)
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Inherited from TfrxBaseForm.)
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Inherited from TfrxBaseForm.)
Top
Fields
Show:
Name | Description
FHostedControls | Represents field FHostedControls. (Inherited from TfrxBaseForm.)
FPrefEvent | Represents field FPrefEvent. (Inherited from TfrxBaseForm.)
Top
See Also

Reference

  • frxBaseForm


TfrxBaseLoadSavePrefForm Methods

Methods
Name | Description
GetAvailablePreferences | Represents method GetAvailablePreferences. (Overrides TfrxBaseForm.GetAvailablePreferences.)
Top


TfrxBaseLoadSavePrefForm.GetAvailablePreferences Method

Summary

Represents method GetAvailablePreferences.

Namespace: frxBaseForm
Syntax
Delphi
protected
 function GetAvailablePreferences: TfrxPreferencesTypes; override;

Return Value

Type: TfrxPreferencesTypes

Overrides

TfrxBaseForm.GetAvailablePreferences
See Also

Reference

  • TfrxBaseLoadSavePrefForm
  • frxBaseForm


TfrxMessageObject Class

Summary

This class used to pass messages of the form. internal use only.

Namespace: frxBaseForm
Inheritance Hierarchy
TObject
frxBaseForm.TfrxMessageObject
Syntax
Delphi
type
 TfrxMessageObject = class(TObject)
 end;

The TfrxMessageObject type exposes the following members.

Fields
Show:
Name | Description
FormRect | Represents field FormRect.
Msg | Represents field Msg.
WParam | Represents field WParam.
Top
See Also

Reference

  • frxBaseForm


TfrxMessageObject Fields

Fields
Name | Description
FormRect | Represents field FormRect.
Msg | Represents field Msg.
WParam | Represents field WParam.
Top


TfrxMessageObject.FormRect Field

Summary

Represents field FormRect.

Namespace: frxBaseForm
Syntax
Delphi
public
 FormRect: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxMessageObject
  • frxBaseForm


TfrxMessageObject.Msg Field

Summary

Represents field Msg.

Namespace: frxBaseForm
Syntax
Delphi
public
 Msg: Cardinal;

Field Value

Type: Cardinal

See Also

Reference

  • TfrxMessageObject
  • frxBaseForm


TfrxMessageObject.WParam Field

Summary

Represents field WParam.

Namespace: frxBaseForm
Syntax
Delphi
public
 WParam: WPARAM;

Field Value

Type: WPARAM

See Also

Reference

  • TfrxMessageObject
  • frxBaseForm


frxBaseForm Enumerations

Enumerations
Name | Description
TfrxPreferencesAction | This enumeration defines action of preference state. It used to save/load/restore form state.
TfrxPreferencesLoadEvent | Defines when form should apply saved preference settings.
TfrxPreferencesType | Type of the form settings which should be processed by current form.
Top


TfrxPreferencesAction Enumeration

Summary

This enumeration defines action of preference state. It used to save/load/restore form state.

Namespace: frxBaseForm
Syntax
Delphi
type
 TfrxPreferencesAction = (
 frPaLoad,
 frPaSave,
 frPaRestore);

The TfrxPreferencesAction type exposes the following members.

Members
Show:
Name | Description
frPaLoad | Loads preference setting for the form.
frPaRestore | Reset preference setting for the form to default.
frPaSave | Saves preference setting for the form.
Top
See Also

Reference

  • frxBaseForm


TfrxPreferencesLoadEvent Enumeration

Summary

Defines when form should apply saved preference settings.

Namespace: frxBaseForm
Syntax
Delphi
type
 TfrxPreferencesLoadEvent = (
 peAtCreate,
 peAtShowOnce,
 peAtShow);

The TfrxPreferencesLoadEvent type exposes the following members.

Members
Show:
Name | Description
peAtCreate | At form creation.
peAtShow | When form shows(applies every time form shows).
peAtShowOnce | When form shows. Only at first show.
Top
See Also

Reference

  • frxBaseForm


TfrxPreferencesType Enumeration

Summary

Type of the form settings which should be processed by current form.

Namespace: frxBaseForm
Syntax
Delphi
type
 TfrxPreferencesType = (
 frPtFormPos,
 frPtFormSize,
 frPtFormVisibility,
 frPtFormDockInfo,
 frPtFormDockPos,
 frPtFormDockSize,
 frPtFormCustom);

The TfrxPreferencesType type exposes the following members.

Members
Show:
Name | Description
frPtFormCustom | Custom settings(used for controls state).
frPtFormDockInfo | Dock information of the form.
frPtFormDockPos | Dock position of the form.
frPtFormDockSize | Dock size of the form.
frPtFormPos | Position of the form.
frPtFormSize | Form size.
frPtFormVisibility | Form visibility at start.
Top
See Also

Reference

  • frxBaseForm


frxBaseForm Types

Types
Name | Description
TfrxPreferencesTypes | Set of preference types.
Top


TfrxPreferencesTypes Type

Summary

Set of preference types.

Namespace: frxBaseForm
Syntax
Delphi
type
 TfrxPreferencesTypes = set of TfrxPreferencesType;
See Also

Reference

  • frxBaseForm


frxCellularTextObject Namespace

Summary

Represents namespace frxCellularTextObject.

Classes
Name | Description
TfrxCellularText | The CellularText report object class. A report objects of this class automatically breaks text to table cell where each symbol of the text place in sperate cell. It supports align and text wrapping.
TfrxReportCellularTextObject | The TfrxReportCellularTextObject allows use of the CellularText component in a report. TfrxReportCellularTextObject is an empty component. It is used to add CellularText unit to uses clause of an application.
Top


frxCellularTextObject Classes

Classes
Name | Description
TfrxCellularText | The CellularText report object class. A report objects of this class automatically breaks text to table cell where each symbol of the text place in sperate cell. It supports align and text wrapping.
TfrxReportCellularTextObject | The TfrxReportCellularTextObject allows use of the CellularText component in a report. TfrxReportCellularTextObject is an empty component. It is used to add CellularText unit to uses clause of an application.
Top


TfrxCellularText Class

Summary

The CellularText report object class. A report objects of this class automatically breaks text to table cell where each symbol of the text place in sperate cell. It supports align and text wrapping.

Namespace: frxCellularTextObject
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxClass.TfrxCustomMemoView
frxCellularTextObject.TfrxCellularText
Syntax
Delphi
type
 TfrxCellularText = class(TfrxCustomMemoView)
 end;

The TfrxCellularText type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCellularText class. (Overrides TfrxCustomMemoView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowExpressions | Represents property AllowExpressions.
AllowHTMLTags | Determines if the object may contain HTML-tags inside the text. The following tags are supported: <b> - bold; <i> - italic; <u> - underline; <sub> - bottom index; <sup> - top index; <font color> - font color. Default value is False. (Inherited from TfrxCustomMemoView.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
AnsiText | Text of the object in ANSI format based on current Locale settings. (Inherited from TfrxCustomMemoView.)
AutoWidth | Determines if the text object should handle its width automatically. (Inherited from TfrxCustomMemoView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Represents property BrushStyle.
CanShrink | True if object can shrink height base on its content. (Inherited from TfrxStretcheable.)
CellHeight | Height of the cell.
CellWidth | Width of the cell.
CharSpacing | Character spacing, in pixels. Default value is 0. (Inherited from TfrxCustomMemoView.)
Clipped | Determines whether to clip the text on object's bounds. (Inherited from TfrxCustomMemoView.)
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor. (Inherited from TfrxCustomMemoView.)
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DisplayFormat | Represents property DisplayFormat.
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Duplicates | Determines how to process repeated values. Default value is dmShow. (Inherited from TfrxCustomMemoView.)
ExpressionDelimiters | Represents property ExpressionDelimiters.
Fill | Represents property Fill.
FillType | Represents property FillType.
FirstParaBreak | Internal use. Determines first paragraph break if object where split. (Inherited from TfrxCustomMemoView.)
FlowTo | Link to the "Text" object that will be used for displaying the textthat not fit in this object. The linked object should have the samefont settings as the main object. You also should place the linkedobject after the main object. (Inherited from TfrxCustomMemoView.)
Font | Represents property Font.
Formats | Collection of Formats. The object can hold several formats for each expression inside an object. (Inherited from TfrxCustomMemoView.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GapX | Gap between text and left and right edges of object, in pixels. Default value is 2. (Inherited from TfrxCustomMemoView.)
GapY | Gap between text and top and bottom edges of object, in pixels. Default value is 1. (Inherited from TfrxCustomMemoView.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
HAlign | Represents property HAlign.
Height | Represents property Height. (Inherited from TfrxView.)
HideZeros | Represents property HideZeros.
Highlight | Represents property Highlight.
Highlights | Collection of Highlights. The object can hold several highlights which serves different conditions. (Inherited from TfrxCustomMemoView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
HorzSpacing | Horizontal spacing between cells.
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LastParaBreak | Internal use. Determines last paragraph break if object where split. (Inherited from TfrxCustomMemoView.)
Left | Represents property Left. (Inherited from TfrxView.)
Lines | Text lines of the object. (Inherited from TfrxCustomMemoView.)
LineSpacing | Spacing between text lines, in pixels. Default value is 2. (Inherited from TfrxCustomMemoView.)
Memo | Represents property Memo.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
ParagraphGap | Paragraph gap, in pixels. Default value is 0. (Inherited from TfrxCustomMemoView.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont.
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
Rotation | Determines the text rotation, in degrees. Valid values are 0..360. (Inherited from TfrxCustomMemoView.)
RTLReading | Represents property RTLReading.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StretchMode | Object's stretch mode. (Inherited from TfrxStretcheable.)
Style | Represents property Style.
SuppressRepeated | Represents property SuppressRepeated.
TagStr | Represents property TagStr. (Inherited from TfrxCustomMemoView.)
Text | Text of the object. (Inherited from TfrxCustomMemoView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Underlines | Deprecated(See UnderlinesTextMode property). Determines whether to show underlines under each text string. Default value is False. (Inherited from TfrxCustomMemoView.)
UnderlinesTextMode | Determines how to show underlines in text object. Default value is ulmNone. (Inherited from TfrxCustomMemoView.)
URL | Represents property URL. (Inherited from TfrxCustomMemoView.)
UseDefaultCharset | Represents property UseDefaultCharset.
VAlign | Represents property VAlign.
Value | Stores value of Format operation(for single expression or DataSet only) with respect of its type. (Inherited from TfrxCustomMemoView.)
VertSpacing | Vertical spacing between cells.
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
WordBreak | Determines whether to break russian words. Default value is False. (Inherited from TfrxCustomMemoView.)
WordWrap | Represents property WordWrap.
Wysiwyg | Determines whether to use printer canvas to arrange the text more accurately. If set to False, you cannot use the "width align" mode. (Inherited from TfrxCustomMemoView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxView.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
ApplyHighlight(TfrxHighlight) | Apply Highlight to object. (Inherited from TfrxCustomMemoView.)
ApplyPreviewHighlight | Apply active highlight for object in prepared report. (Inherited from TfrxCustomMemoView.)
ApplyStyle(TfrxStyleItem) | Applies the given style to the object. (Inherited from TfrxCustomMemoView.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Overrides TfrxView.BeginDraw(TCanvas,Extended,Extended,Extended,Extended).)
BuildTable(TfrxTableObject) | Represents method BuildTable(TfrxTableObject).
CalcAndFormat(WideString,TfrxFormat) | Represents method CalcAndFormat(WideString,TfrxFormat). (Inherited from TfrxCustomMemoView.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxCustomMemoView.CalcHeight.)
CalcTextRect(Extended,Extended,Extended,Extended) | Represents method CalcTextRect(Extended,Extended,Extended,Extended). (Inherited from TfrxCustomMemoView.)
CalcWidth | Calculates and returns the object's width, in pixels. (Inherited from TfrxCustomMemoView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxCustomMemoView.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxCustomMemoView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxCustomMemoView.DrawPart.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawText | Represents method DrawText. (Inherited from TfrxCustomMemoView.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Overrides TfrxComponent.ExportInternal(TfrxCustomExportFilter).)
ExtractMacros(TfrxPostProcessor) | Extract macros from the object text and replaces them with values. (Inherited from TfrxCustomMemoView.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
FormatData(Variant,TfrxFormat) | Formats the value passed in the "Value" parameter and returns the result as a string. This method is used format settings stored in the DisplayFormat property. If AFormat parameter is set, it is used for formatting instead of DisplayFormat property. (Inherited from TfrxCustomMemoView.)
GetCellHeight | Represents method GetCellHeight.
GetCellWidth | Represents method GetCellWidth.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Overrides TfrxReportComponent.GetComponentText.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxCustomMemoView.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Inherited from TfrxStretcheable.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object. (Overrides TfrxStretcheable.InitPart.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Overrides TfrxView.IsPostProcessAllowed.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
Loaded | Represents method Loaded. (Overrides TfrxCustomMemoView.Loaded.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxView.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.ReadNestedProperty(TfrxXMLItem).)
ReducedAngle | Normalize angle to 360 degrees. (Inherited from TfrxCustomMemoView.)
ResetSuppress | Deprecated. Reset suppressed values. (Inherited from TfrxCustomMemoView.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCellHeight(Extended) | Represents method SetCellHeight(Extended).
SetCellWidth(Extended) | Represents method SetCellWidth(Extended).
SetDrawParams(TCanvas,Extended,Extended,Extended,Extended) | Represents method SetDrawParams(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxCustomMemoView.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Overrides TfrxComponent.UpdateBounds.)
UpdateSize | Represents method UpdateSize.
WrapText(TWideStrings,Integer) | Represents method WrapText(TWideStrings,Integer).
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.WriteNestedProperties(TfrxXMLItem,TPersistent).)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FCellHeight | Represents field FCellHeight.
FCellWidth | Represents field FCellWidth.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCopyNo | Represents field FCopyNo. (Inherited from TfrxCustomMemoView.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FHorzSpacing | Represents field FHorzSpacing.
FLastValue | Represents field FLastValue. (Inherited from TfrxCustomMemoView.)
FMacroIndex | Represents field FMacroIndex. (Inherited from TfrxCustomMemoView.)
FMacroLine | Represents field FMacroLine. (Inherited from TfrxCustomMemoView.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintScale | Represents field FPrintScale. (Inherited from TfrxCustomMemoView.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FSavedTop | Internal use only. Stores original top during shift operation. (Inherited from TfrxStretcheable.)
FSaveHeight | Internal use only. Stores object Height during stretch operation. (Inherited from TfrxStretcheable.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FTextRect | Represents field FTextRect. (Inherited from TfrxCustomMemoView.)
FTotalPages | Represents field FTotalPages. (Inherited from TfrxCustomMemoView.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FVertSpacing | Represents field FVertSpacing.
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxCellularTextObject


TfrxCellularText Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCellularText class. (Overrides TfrxCustomMemoView.Create(TComponent).)
Top


TfrxCellularText.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCellularText class.

Namespace: frxCellularTextObject
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomMemoView.Create(TComponent)
See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText Properties

Properties
Name | Description
AllowExpressions | Represents property AllowExpressions.
BrushStyle | Represents property BrushStyle.
CellHeight | Height of the cell.
CellWidth | Width of the cell.
Color | Represents property Color.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
DisplayFormat | Represents property DisplayFormat.
ExpressionDelimiters | Represents property ExpressionDelimiters.
Fill | Represents property Fill.
FillType | Represents property FillType.
Font | Represents property Font.
Frame | Represents property Frame.
HAlign | Represents property HAlign.
HideZeros | Represents property HideZeros.
Highlight | Represents property Highlight.
HorzSpacing | Horizontal spacing between cells.
Memo | Represents property Memo.
ParentFont | Represents property ParentFont.
RTLReading | Represents property RTLReading.
Style | Represents property Style.
SuppressRepeated | Represents property SuppressRepeated.
UseDefaultCharset | Represents property UseDefaultCharset.
VAlign | Represents property VAlign.
VertSpacing | Vertical spacing between cells.
WordWrap | Represents property WordWrap.
Top


TfrxCellularText.AllowExpressions Property

Summary

Represents property AllowExpressions.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property AllowExpressions;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.BrushStyle Property

Summary

Represents property BrushStyle.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property BrushStyle;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.CellHeight Property

Summary

Height of the cell.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property CellHeight: Extended read FCellHeight write SetCellHeight;

Property Value

Type: Extended

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.CellWidth Property

Summary

Width of the cell.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property CellWidth: Extended read FCellWidth write SetCellWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.Color Property

Summary

Represents property Color.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.DataField Property

Summary

Represents property DataField.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property DataField;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.DataSet Property

Summary

Represents property DataSet.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property DataSetName;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.DisplayFormat Property

Summary

Represents property DisplayFormat.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property DisplayFormat;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.ExpressionDelimiters Property

Summary

Represents property ExpressionDelimiters.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property ExpressionDelimiters;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.Fill Property

Summary

Represents property Fill.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.FillType Property

Summary

Represents property FillType.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.Font Property

Summary

Represents property Font.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.Frame Property

Summary

Represents property Frame.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.HAlign Property

Summary

Represents property HAlign.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property HAlign;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.HideZeros Property

Summary

Represents property HideZeros.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property HideZeros;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.Highlight Property

Summary

Represents property Highlight.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property Highlight;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.HorzSpacing Property

Summary

Horizontal spacing between cells.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property HorzSpacing: Extended read FHorzSpacing write FHorzSpacing;

Property Value

Type: Extended

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.Memo Property

Summary

Represents property Memo.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property Memo;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.ParentFont Property

Summary

Represents property ParentFont.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property ParentFont;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.RTLReading Property

Summary

Represents property RTLReading.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property RTLReading;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.Style Property

Summary

Represents property Style.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property Style;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.SuppressRepeated Property

Summary

Represents property SuppressRepeated.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property SuppressRepeated;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.UseDefaultCharset Property

Summary

Represents property UseDefaultCharset.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property UseDefaultCharset;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.VAlign Property

Summary

Represents property VAlign.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property VAlign;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.VertSpacing Property

Summary

Vertical spacing between cells.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property VertSpacing: Extended read FVertSpacing write FVertSpacing;

Property Value

Type: Extended

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.WordWrap Property

Summary

Represents property WordWrap.

Namespace: frxCellularTextObject
Syntax
Delphi
published
 property WordWrap;

Property Value

Type: Void

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText Methods

Methods
Name | Description
BuildTable(TfrxTableObject) | Represents method BuildTable(TfrxTableObject).
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxCustomMemoView.CalcHeight.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxCustomMemoView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxCustomMemoView.DrawPart.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Overrides TfrxComponent.ExportInternal(TfrxCustomExportFilter).)
GetCellHeight | Represents method GetCellHeight.
GetCellWidth | Represents method GetCellWidth.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxCustomMemoView.GetDescription.)
Loaded | Represents method Loaded. (Overrides TfrxCustomMemoView.Loaded.)
SetCellHeight(Extended) | Represents method SetCellHeight(Extended).
SetCellWidth(Extended) | Represents method SetCellWidth(Extended).
UpdateBounds | Used to validate object real bounds. (Overrides TfrxComponent.UpdateBounds.)
UpdateSize | Represents method UpdateSize.
WrapText(TWideStrings,Integer) | Represents method WrapText(TWideStrings,Integer).
Top


TfrxCellularText.BuildTable(TfrxTableObject) Method

Summary

Represents method BuildTable(TfrxTableObject).

Namespace: frxCellularTextObject
Syntax
Delphi
private
 procedure BuildTable(aTable: TfrxTableObject);

Parameters

aTable
Type: TfrxTableObject

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.CalcHeight Method

Summary

Calculates and returns the object's height according to the data placed in it.

Namespace: frxCellularTextObject
Syntax
Delphi
public
 function CalcHeight: Extended; override;

Return Value

Type: Extended

Overrides

TfrxCustomMemoView.CalcHeight
See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxCellularTextObject
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxCustomMemoView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.DrawPart Method

Summary

Objects part drawing function , if the object is splittable.

Namespace: frxCellularTextObject
Syntax
Delphi
public
 function DrawPart: Extended; override;

Return Value

Type: Extended

Overrides

TfrxCustomMemoView.DrawPart
See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.ExportInternal(TfrxCustomExportFilter) Method

Summary

Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call.

Namespace: frxCellularTextObject
Syntax
Delphi
public
 function ExportInternal(Filter: TfrxCustomExportFilter): Boolean; override;

Parameters

Filter
Type: TfrxCustomExportFilter

Return Value

Type: Boolean

Overrides

TfrxComponent.ExportInternal(TfrxCustomExportFilter)
See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.GetCellHeight Method

Summary

Represents method GetCellHeight.

Namespace: frxCellularTextObject
Syntax
Delphi
private
 function GetCellHeight: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.GetCellWidth Method

Summary

Represents method GetCellWidth.

Namespace: frxCellularTextObject
Syntax
Delphi
private
 function GetCellWidth: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxCellularTextObject
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxCustomMemoView.GetDescription
See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.Loaded Method

Summary

Represents method Loaded.

Namespace: frxCellularTextObject
Syntax
Delphi
protected
 procedure Loaded; override;

Overrides

TfrxCustomMemoView.Loaded
See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.SetCellHeight(Extended) Method

Summary

Represents method SetCellHeight(Extended).

Namespace: frxCellularTextObject
Syntax
Delphi
private
 procedure SetCellHeight(Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.SetCellWidth(Extended) Method

Summary

Represents method SetCellWidth(Extended).

Namespace: frxCellularTextObject
Syntax
Delphi
private
 procedure SetCellWidth(Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.UpdateBounds Method

Summary

Used to validate object real bounds.

Namespace: frxCellularTextObject
Syntax
Delphi
public
 procedure UpdateBounds; override;

Overrides

TfrxComponent.UpdateBounds
See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.UpdateSize Method

Summary

Represents method UpdateSize.

Namespace: frxCellularTextObject
Syntax
Delphi
protected
 procedure UpdateSize;
See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.WrapText(TWideStrings,Integer) Method

Summary

Represents method WrapText(TWideStrings,Integer).

Namespace: frxCellularTextObject
Syntax
Delphi
private
 procedure WrapText(sLines: TWideStrings; ColumnCount: Integer);

Parameters

sLines
Type: TWideStrings

ColumnCount
Type: Integer

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText Fields

Fields
Name | Description
FCellHeight | Represents field FCellHeight.
FCellWidth | Represents field FCellWidth.
FHorzSpacing | Represents field FHorzSpacing.
FVertSpacing | Represents field FVertSpacing.
Top


TfrxCellularText.FCellHeight Field

Summary

Represents field FCellHeight.

Namespace: frxCellularTextObject
Syntax
Delphi
private
 FCellHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.FCellWidth Field

Summary

Represents field FCellWidth.

Namespace: frxCellularTextObject
Syntax
Delphi
private
 FCellWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.FHorzSpacing Field

Summary

Represents field FHorzSpacing.

Namespace: frxCellularTextObject
Syntax
Delphi
private
 FHorzSpacing: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxCellularText.FVertSpacing Field

Summary

Represents field FVertSpacing.

Namespace: frxCellularTextObject
Syntax
Delphi
private
 FVertSpacing: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCellularText
  • frxCellularTextObject


TfrxReportCellularTextObject Class

Summary

The TfrxReportCellularTextObject allows use of the CellularText component in a report. TfrxReportCellularTextObject is an empty component. It is used to add CellularText unit to uses clause of an application.

Namespace: frxCellularTextObject
Inheritance Hierarchy
TComponent
frxCellularTextObject.TfrxReportCellularTextObject
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxReportCellularTextObject = class(TComponent)
 end;
See Also

Reference

  • frxCellularTextObject


frxChBox Namespace

Summary

Represents namespace frxChBox.

Classes
Name | Description
TfrxCheckBoxObject | The TfrxCheckBoxObject allows the use of the CheckBox component in your report. TfrxCheckBoxObject is an empty component. It is used to add the frxChBox.pas file to the "uses" list. The main component is TfrxCheckBoxView.
TfrxCheckBoxView | The TfrxCheckBoxView component represents a box containing a mark - check or cross. Component shows the check if Checked property value is True. Also it can show a check from the DB field (you should set DataSet, DataField properties) or from an expression(Expression property).
Top
Enumerations
Name | Description
TfrxCheckStyle | Checked style of the checkbox - cross, check, crossline, plus.
TfrxUncheckStyle | UnChecked style of the checkbox - empty, cross, crossline, minus.
Top


frxChBox Classes

Classes
Name | Description
TfrxCheckBoxObject | The TfrxCheckBoxObject allows the use of the CheckBox component in your report. TfrxCheckBoxObject is an empty component. It is used to add the frxChBox.pas file to the "uses" list. The main component is TfrxCheckBoxView.
TfrxCheckBoxView | The TfrxCheckBoxView component represents a box containing a mark - check or cross. Component shows the check if Checked property value is True. Also it can show a check from the DB field (you should set DataSet, DataField properties) or from an expression(Expression property).
Top


TfrxCheckBoxObject Class

Summary

The TfrxCheckBoxObject allows the use of the CheckBox component in your
report. TfrxCheckBoxObject is an empty component. It is used to add the
frxChBox.pas file to the "uses" list. The main component is
TfrxCheckBoxView.

Namespace: frxChBox
Inheritance Hierarchy
TComponent
frxChBox.TfrxCheckBoxObject
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxCheckBoxObject = class(TComponent)
 end;
See Also

Reference

  • frxChBox


TfrxCheckBoxView Class

Summary

The TfrxCheckBoxView component represents a box containing a mark - check or cross. Component shows the check if Checked property value is True. Also it can show a check from the DB field (you should set DataSet, DataField properties) or from an expression(Expression property).

Namespace: frxChBox
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxChBox.TfrxCheckBoxView
Syntax
Delphi
type
 TfrxCheckBoxView = class(TfrxView)
 end;

The TfrxCheckBoxView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCheckBoxView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Represents property BrushStyle.
CheckColor | Color of the check.
Checked | Determines whether to show the check.
CheckStyle | Checked style of the check.
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Expression | Value of the expression determines whether to show the check.
Fill | Represents property Fill.
FillType | Represents property FillType.
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
TagStr | Represents property TagStr.
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
UncheckStyle | Unchecked style of the check.
URL | Represents property URL.
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawCheck(TRect) | Represents method DrawCheck(TRect).
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FCheckColor | Represents field FCheckColor.
FChecked | Represents field FChecked.
FCheckStyle | Represents field FCheckStyle.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FExpression | Represents field FExpression.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FUncheckStyle | Represents field FUncheckStyle.
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxChBox


TfrxCheckBoxView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCheckBoxView class. (Overrides TfrxView.Create(TComponent).)
Top


TfrxCheckBoxView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCheckBoxView class.

Namespace: frxChBox
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxView.Create(TComponent)
See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView Properties

Properties
Name | Description
BrushStyle | Represents property BrushStyle.
CheckColor | Color of the check.
Checked | Determines whether to show the check.
CheckStyle | Checked style of the check.
Color | Represents property Color.
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Expression | Value of the expression determines whether to show the check.
Fill | Represents property Fill.
FillType | Represents property FillType.
Frame | Represents property Frame.
TagStr | Represents property TagStr.
UncheckStyle | Unchecked style of the check.
URL | Represents property URL.
Top


TfrxCheckBoxView.BrushStyle Property

Summary

Represents property BrushStyle.

Namespace: frxChBox
Syntax
Delphi
published
 property BrushStyle;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.CheckColor Property

Summary

Color of the check.

Namespace: frxChBox
Syntax
Delphi
published
 property CheckColor: TColor read FCheckColor write FCheckColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.Checked Property

Summary

Determines whether to show the check.

Namespace: frxChBox
Syntax
Delphi
published
 property Checked: Boolean read FChecked write FChecked default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.CheckStyle Property

Summary

Checked style of the check.

Namespace: frxChBox
Syntax
Delphi
published
 property CheckStyle: TfrxCheckStyle read FCheckStyle write FCheckStyle;

Property Value

Type: TfrxCheckStyle

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.Color Property

Summary

Represents property Color.

Namespace: frxChBox
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.Cursor Property

Summary

Represents property Cursor.

Namespace: frxChBox
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.DataField Property

Summary

Represents property DataField.

Namespace: frxChBox
Syntax
Delphi
published
 property DataField;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.DataSet Property

Summary

Represents property DataSet.

Namespace: frxChBox
Syntax
Delphi
published
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxChBox
Syntax
Delphi
published
 property DataSetName;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.Expression Property

Summary

Value of the expression determines whether to show the check.

Namespace: frxChBox
Syntax
Delphi
published
 property Expression: String read FExpression write FExpression;

Property Value

Type: String

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.Fill Property

Summary

Represents property Fill.

Namespace: frxChBox
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.FillType Property

Summary

Represents property FillType.

Namespace: frxChBox
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.Frame Property

Summary

Represents property Frame.

Namespace: frxChBox
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.TagStr Property

Summary

Represents property TagStr.

Namespace: frxChBox
Syntax
Delphi
published
 property TagStr;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.UncheckStyle Property

Summary

Unchecked style of the check.

Namespace: frxChBox
Syntax
Delphi
published
 property UncheckStyle: TfrxUncheckStyle read FUncheckStyle write FUncheckStyle default usEmpty;

Property Value

Type: TfrxUncheckStyle

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.URL Property

Summary

Represents property URL.

Namespace: frxChBox
Syntax
Delphi
published
 property URL;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView Methods

Methods
Name | Description
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawCheck(TRect) | Represents method DrawCheck(TRect).
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
Top


TfrxCheckBoxView.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxChBox
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxChBox
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.DrawCheck(TRect) Method

Summary

Represents method DrawCheck(TRect).

Namespace: frxChBox
Syntax
Delphi
private
 procedure DrawCheck(ARect: TRect);

Parameters

ARect
Type: TRect

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxChBox
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxChBox
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView Fields

Fields
Name | Description
FCheckColor | Represents field FCheckColor.
FChecked | Represents field FChecked.
FCheckStyle | Represents field FCheckStyle.
FExpression | Represents field FExpression.
FUncheckStyle | Represents field FUncheckStyle.
Top


TfrxCheckBoxView.FCheckColor Field

Summary

Represents field FCheckColor.

Namespace: frxChBox
Syntax
Delphi
private
 FCheckColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.FChecked Field

Summary

Represents field FChecked.

Namespace: frxChBox
Syntax
Delphi
private
 FChecked: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.FCheckStyle Field

Summary

Represents field FCheckStyle.

Namespace: frxChBox
Syntax
Delphi
private
 FCheckStyle: TfrxCheckStyle;

Field Value

Type: TfrxCheckStyle

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.FExpression Field

Summary

Represents field FExpression.

Namespace: frxChBox
Syntax
Delphi
private
 FExpression: String;

Field Value

Type: String

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


TfrxCheckBoxView.FUncheckStyle Field

Summary

Represents field FUncheckStyle.

Namespace: frxChBox
Syntax
Delphi
private
 FUncheckStyle: TfrxUncheckStyle;

Field Value

Type: TfrxUncheckStyle

See Also

Reference

  • TfrxCheckBoxView
  • frxChBox


frxChBox Enumerations

Enumerations
Name | Description
TfrxCheckStyle | Checked style of the checkbox - cross, check, crossline, plus.
TfrxUncheckStyle | UnChecked style of the checkbox - empty, cross, crossline, minus.
Top


TfrxCheckStyle Enumeration

Summary

Checked style of the checkbox - cross, check, crossline, plus.

Namespace: frxChBox
Syntax
Delphi
type
 TfrxCheckStyle = (csCross, csCheck, csLineCross, csPlus);

The TfrxCheckStyle type exposes the following members.

Members
Show:
Name | Description
csCheck | Represents constant csCheck.
csCross | Represents constant csCross.
csLineCross | Represents constant csLineCross.
csPlus | Represents constant csPlus.
Top
See Also

Reference

  • frxChBox


TfrxUncheckStyle Enumeration

Summary

UnChecked style of the checkbox - empty, cross, crossline, minus.

Namespace: frxChBox
Syntax
Delphi
type
 TfrxUncheckStyle = (usEmpty, usCross, usLineCross, usMinus);

The TfrxUncheckStyle type exposes the following members.

Members
Show:
Name | Description
usCross | Represents constant usCross.
usEmpty | Represents constant usEmpty.
usLineCross | Represents constant usLineCross.
usMinus | Represents constant usMinus.
Top
See Also

Reference

  • frxChBox


frxClass Namespace

Summary

Main FastReport unit. This unit contains base classes of report objects and report class itself. To use FastReport components this unit should be included in uses clause.

Classes
Name | Description
EDuplicateName | Duplicate name exception class.
EExportTerminated | Export termination exception class.
TfrxBand | The TfrxBand is the base class for all bands. Band allows creation of a report area, which has a specific behaviour according to type.
TfrxBaseDelayedCommand | The base abstract class which implements IfrxDelayedCommand interface. It used as a base for all report commands. All commands stored in the command list in the report component.
TfrxBasePrepareReportCommand | This class is a base for all prepare report commands.
TfrxBindableFieldProps | Reserved.
TfrxBrushFill | Represents standard brush fill class for all report objects.
TfrxChild | The TfrxChild class represents a "Child" band. This kind of band is linked to the parent band via its "Child" property and displayed after it.
TfrxCloseQueryEvent | Represents type TfrxCloseQueryEvent.
TfrxColumnFooter | The TfrxColumnFooter class represents a "Column footer" band. This kind of band is displayed at the bottom of each column.
TfrxColumnHeader | The TfrxColumnHeader class represents a "Column header" band. This kind of band is displayed at the top of each column.
TfrxComponent | TfrxComponent is the basic class for all FastReport components. Objects of this type have such parameters as "coordinates", "size", "font", "visibility" and lists of subordinate objects. The class also contains methods, which allow saving/restoring object's state to/from the stream.
TfrxComponentEditorsClasses | This class represents collection of registered component InPlace editors for each type of components.
TfrxComponentEditorsList | This class used to store component InPlace editors for current instance of TfrxComponent.
TfrxComponentEditorsManager | This class controls group of InPlace editors registered for specified object type. Methods description are the same as for TfrxInPlaceEditor class.
TfrxComponentEditorsRegItem | This class represents registration item of InPlace editor in editors list.
TfrxContentChangedEvent | Represents type TfrxContentChangedEvent.
TfrxCustomCompressor | The TfrxCustomCompressor class is the base class for compressors that allows compression/decompression of the FR3 and FP3 files.
TfrxCustomCrypter | Represents type TfrxCustomCrypter.
TfrxCustomDatabase | The base class for DB engine components such as TfrxXXXDatabase. Used internally in reports.
TfrxCustomDBDataSet | The TfrxDBDataSet component is designed for connecting to the DB components, which are based on TDataSet, such as "TTable" and "TQuery". Such functions as navigation in the data source and referring to fields are performed automatically, which means that a programmer does not have to worry about it.
TfrxCustomDesigner | The TfrxCustomDesigner class is the base class for the report designer.
TfrxCustomEngine | The TfrxCustomEngine class is the base class for report engine. Instance of this class is stored in the TfrxReport.Engine property.
TfrxCustomExportFilter | The TfrxCustomExportFilter is the base class for all export filters.
TfrxCustomFill | Base abstract class for representation of object fills interface. Every object fill should inherit from this class.
TfrxCustomIOTransport | The TfrxCustomIOTransport class is the base class for all IO (input/output filters). It represents Base adapter interface for file or stream IO operations. Transport filters can be used in the report designer (save/open operations), report preview (save/open operations) and export filters. It possible to create one class of transport filter which encapsulates work with some IO protocol(for example save/load from cloud) and use this class where it's necessary(Designer, Preview, Exports) by setting up Visibility property.
TfrxCustomLineView | The TfrxCustomLineView class is the base class for "Line" and "Dot-matrix line" objects.
TfrxCustomMemoView | The TfrxCustomMemoView class is the base class for the "Text", "System text" and "Dot-matrix text" objects. This object represents a rectangular area with the multiline text inside.
TfrxCustomObjectPreset | Represents type TfrxCustomObjectPreset.
TfrxCustomOutline | This object represents the "Report tree" control element in a preview window. Instance of this class is stored in the TfrxReport.PreviewPages.Outline property.
TfrxCustomPreview | The TfrxCustomPreview class is the base class for TfrxPreview class.
TfrxCustomPreviewPages | The TfrxCustomPreviewPages class is the base class for pages of a prepared report. Instance of this class is stored in the TfrxReport.PreviewPages property.
TfrxCustomWizard | The TfrxCustomWizard class is the basic class for any wizards. Wizards are called from the designer's menu "File|New...". Wizard should be registered via frxWizards.Register method, defined in the frxDsgnIntf unit.
TfrxDataBand | The TfrxDataBand class is the base class for all data-bands. Data-band is a band connected to a dataset. Data-band is displayed as many times as there are records in the dataset.
TfrxDataBand4 | The TfrxDataBand4 represents a "4th data level" band.
TfrxDataBand5 | The TfrxDataBand5 represents a "5th data level" band.
TfrxDataBand6 | The TfrxDataBand6 represents a "6th data level" band.
TfrxDataPage | The TfrxDataPage represents a datamodule.
TfrxDataSet | The TfrxDataSet class is used for navigation of a dataset. It is base class for TfrxDBDataSet, TfrxUserDataSet components.
TfrxDataSetItem | The TfrxDataSetItem class represents a dataset in the report dataset's list. Dataset's list is contained in the TfrxReportDataSets class.
TfrxDBComponents | Represents type TfrxDBComponents.
TfrxDelayedCommandManager | The TfrxDelayedCommandManager class is used as storage and manager for commands which implements IfrxDelayedCommand interface.
TfrxDetailData | The TfrxDetailData represents a "Detail data" band.
TfrxDialogComponent | The TfrxDialogComponent class is the basic one for writing non-visual components, which can be placed on a dialog form in a report.
TfrxDialogControl | The "TfrxDialogControl" class is the basic one for writing common control, which can be placed on a dialogue form in a report. The class contains a large number of general properties and events shared with most of the common controls.
TfrxDialogPage | The TfrxDialogPage class represents a dialogue form that may contain non-visual and visual controls such as "TfrxBDETable", "Button", etc.
TfrxEngineOptions | The TfrxEngineOptions class represents a set of properties related to the FastReport engine. Instance of this class is stored in the TfrxReport.EngineOptions.
TfrxEventObject | Class uses in DragDrop events. It helps to determinate when object event was called from another object editor. Check TfrxInPlaceBandEditor.DoCustomDragDrop.
TfrxExpressionCache | The TfrxReportOptions class represents an expression cache. The instance of this class used in the report object to store most used expressions and link them with script items. It significantly increases expression calculation (like aggregate functions) in a huge reports because syntax parsing of expressions called only once.
TfrxExtPropList | Represents type TfrxExtPropList.
TfrxFillGaps | Encapsulate data for fill gaps. Band objects use it as a gap parameter for fill object.
TfrxFooter | The TfrxFooter class represents a "Footer" band. This kind of band is a footer for all data-bands.
TfrxFormat | The constructor. Do not call it directly because an instance of this class is stored in the TfrxCustomMemoView.DisplayFormat.
TfrxFormatCollection | Collection of TfrxFormat. An object can hold several formats which serves different expressions.
TfrxFR2Events | Represents type TfrxFR2Events.
TfrxFrame | The TfrxFrame class represents a frame. Almost all Frx visual objects have a frame.
TfrxFrameLine | The TfrxFrameLine class represents the parameters of one line of the frame.
TfrxGlassFill | Represents type TfrxGlassFill.
TfrxGlobalDataSetList | This class represents global list of datasets. Every ancestor of TfrxDataSet registers in this list during construction and removes when destroy.
TfrxGradientFill | Represents standard gradient fill class for all report objects.
TfrxGroupFooter | The TfrxGroupFooter class represents a "Group footer" band. This kind of band is displayed at the bottom of each group.
TfrxGroupHeader | The TfrxGroupHeader class represents a "Group header" band. This kind of band is displayed at the top of each group.
TfrxHeader | The TfrxHeader class represents a "Header" band. This kind of band is a header for all data-bands.
TfrxHighlight | The TfrxHighlight class holds the conditional highlight settings. The conditional highlight is used in the TfrxMemoView object and allows changing the font and color settings depending on some condition.
TfrxHighlightCollection | Collection of TfrxHighlight. Each object can hold several highlights which serves different conditions.
TfrxHyperlink | This class encapsulates data for hyperlinks. Some report objects may have hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page.
TfrxInPlaceEditor | The base class for InPlace editors. With InPlace editors programmers may extend functionality of the report designer and the report preview. This class handles mouse events, drag and drop, clipboard and custom draw. It can be used to create custom in place editor for the report designer, override copy/paste behaviour for selected object and draws custom editors.
TfrxIOTransportFile | The class is the base IO transport filter class for all file operations. IO filters which work directly with files use this class as ancestor.
TfrxKeyEvent | Represents type TfrxKeyEvent.
TfrxKeyPressEvent | Represents type TfrxKeyPressEvent.
TfrxLineView | The TfrxLineView class represents the "Line" object. It can show a horizontal, vertical or diagonal line.
TfrxLoadFromCommand | This class implements realization of deferred LoadFrom command.
TfrxLoadFromFileCommand | This class implements realization of deferred LoadFromFile command.
TfrxLoadFromStreamCommand | This class implements realization of deferred LoadFromStream command.
TfrxMacrosItem | Internal class used by data processing engine. Stores values for post processor.
TfrxMasterData | The TfrxMasterData represents a "Master data" band.
TfrxMemoView | The TfrxMemoView class represents the "Text" object that can show multiline text in a rectangular area.
TfrxMouseEnterViewEvent | Represents type TfrxMouseEnterViewEvent.
TfrxMouseEvent | Represents type TfrxMouseEvent.
TfrxMouseLeaveViewEvent | Represents type TfrxMouseLeaveViewEvent.
TfrxMouseMoveEvent | Represents type TfrxMouseMoveEvent.
TfrxNode | This class represents tree node which used to emulate tree structure of directories and files in IO transports.
TfrxNotifyEvent | Represents type TfrxNotifyEvent.
TfrxNullBand | Represents type TfrxNullBand.
TfrxObjectProcessing | This class encapsulate data for object processing engine.
TfrxObjectsNotifyList | Standard list with Notify event. Used as helper to detect added/deleted objects.
TfrxOverlay | The TfrxOverlay class represents an "Overlay" band. This kind of band is printed on each page as a bottom layer.
TfrxPage | The TfrxPage class is the base class for report design pages such as TfrxReportPage, TfrxDialogPage, TfrxDMPPage.
TfrxPageFooter | The TfrxPageFooter class represents a "Page footer" band. This kind of band is displayed at the bottom of each page.
TfrxPageHeader | The TfrxPageHeader class represents a "Page header" band. This kind of band is displayed at the top of each page.
TfrxPictureView | The TfrxPictureView class represents the "Picture" object. It can show a picture in the PNG, BMP, JPEG, ICO, WMF, EMF formats.
TfrxPostProcessor | This class used as post-process data dictionary. It controls behaviour of post-processed objects and stores data and expressions of these objects. Used by the report engine for delay expression calculation in selected objects.
TfrxPrepareReportCommand | This class implements realization of deferred PrepareReport command.
TfrxPreviewClickEvent | Represents type TfrxPreviewClickEvent.
TfrxPreviewOptions | The TfrxPreviewOptions class represents a set of properties, relating to the report preview. Instance of this class is stored in the TfrxReport.PreviewOptions.
TfrxPreviewPagesList | The TfrxPreviewPagesList class represents list of TfrxCustomPreviewPages. Each TfrxReport instance can have several TfrxCustomPreviewPages instances. This class used to manage all preview pages in the report component.
TfrxPrintOptions | The TfrxPrintOptions class represents a set of properties, which relate to the report printing. Instance of this class is stored in the TfrxReport.PrintOptions.
TfrxRefreshReportCommand | This class implements realization of deferred RefreshReport command.
TfrxReport | The TfrxReport component is the main one. One TfrxReport component contains one report. In design-time, double-clicking the component calls the report designer. The component has all necessary properties and methods for report loading and saving, design and viewing.
TfrxReportComponent | Objects of this type can be placed into a report. The class contains the "Draw" method for object's painting, as well as "BeforePrint/GetData/AfterPrint" methods, which are called as soon as a report runs.
TfrxReportDataSets | The TfrxReportDataSets class represents the report dataset's list. Instance of this class is stored in the TfrxReport.Datasets property.
TfrxReportOptions | The TfrxReportOptions class represents a set of properties relating to the report. Instance of this class is stored in the TfrxReport.ReportOptions.
TfrxReportPage | The TfrxReportPage class represents a report design page that may contain bands and other objects such as "Text", "Picture", etc.
TfrxReportSummary | The TfrxReportSummary class represents a "Report summary" band. This kind of band is displayed at the end of the report.
TfrxReportTitle | The TfrxReportTitle class represents a "Report title" band. This kind of band is displayed at the top of the report.
TfrxRunDialogsEvent | Represents type TfrxRunDialogsEvent.
TfrxSaveToCompressedFilter | The class represents compressed file transport filter.
TfrxSelectedObjectsList | This class implements list of selected report objects in the report designer and in the report preview. For the report designer it encapsulates second list for the object inspector.
TfrxShapeView | The TfrxShapeView class represents the "Shape" object. It can show one of the following shapes: rectangle, ellipse, rounded rectangle, triangle, diamond.
TfrxShowReportCommand | This class implements realization of deferred ShowReport command.
TfrxStretcheable | The TfrxStretcheable class is the basic one for writing components, which modify their height depending on the data placed in them. Objects of the given class can be not only stretched, but they can also be "broken" into pieces in cases when an object does not find room on the page. At the same time, the object is displayed piecemeal until all its data is displayed.
TfrxStringClassName | Represents type TfrxStringClassName.
TfrxStyleItem | The TfrxStyleItem represents a style. Style is an element, which possesses a name and properties, and determines design attributes, i.e. color, font and frame. The style determines the way a report object should be designed. The objects such as TfrxMemoView have the Style property, which is a property intended to set the style name. When applying a value to this property, the style design attributes are copied to the object.
TfrxStyles | The TfrxStyles class represents a set of styles. It comprises methods for performing such set operations as reading, saving, adding, deleting, as well as searching for a style. The set of styles file has FS3 extension by default.
TfrxStyleSheet | The TfrxStyleSheet class represents a styles' library. It has methods for the library reading/saving, as well as adding, deleting, and style sets' searching.
TfrxSubdetailData | The TfrxSubDetailData represents a "Subdetail data" band.
TfrxSubreport | The TfrxSubreport class represents the "Subreport" object. Object is linked to a report page that stores the objects of subreport. When running a report, as soon as the "Subreport" object is encountered, the report, allocated to the subreport design page, will be displayed. After that, basic report creation will continue.
TfrxSysMemoView | The TfrxSysMemoView represents the "System text" object. This object can show system variables, aggregate values or text line.
TfrxUserDataSet | The TfrxUserDataSet component allows constructing reports, which are not connected to DB data, but do receive data from other sources (for example, array, file, etc.). A programmer should only provide navigation in such source (define OnFirst, OnNext, OnPrior, OnCheckEOF events). Data receiving is performed not via this component, but using other ways (for example, via the "TfrxReport.OnGetValue" event). In most cases you can only set the navigation range by setting RangeBegin, RangeEnd, RangeEndCount properties. The current position can be obtained via RecNo property.
TfrxView | The TfrxView class is the basic one for most components, which can be placed on a report design page. An object of this type has parameters such as "Frame" and "Color" and also can be connected to the data source. Practically all FastReport standard objects are inherited from this class.
Top
Records
Name | Description
TfrxDispatchMessage | Used with FRX_OWNER_DESTROY_MESSAGE.
TfrxInteractiveEventsParams | Represents type TfrxInteractiveEventsParams.
TfrxPoint | float point.
TfrxPreviewIntEventParams | Used to pass parameters from preview workspace to preview pages. Stores addition information event.
TfrxRect | Rect with float values.
Top
Interfaces
Name | Description
IfrxDelayedCommand | This interface declares deferred command abstraction.
IInspectedProperties | Represents type IInspectedProperties.
IStringClassNameContainer | Represents type IStringClassNameContainer.
Top
Enumerations
Name | Description
frxClass. | Represents type .
TfrxAddPageAction | Sets behaviour of TfrxPreviewPages.AddPage method.
TfrxAlign | The alignment of the object relative to its parent.
TfrxAnchorsKind | Object anchors type.
TfrxComponentEditorVisibilityState | Visibility of InPlace editors.
TfrxCopyPasteType | Copy paste format for inPlace editors.
TfrxDesignerRestriction | A set of flags, which inhibit specific operations in the designer.
TfrxDesignTool | Type of the report designer tools.
TfrxDuplexMode | Mode of the duplex printing.
TfrxDuplicateMerge | Flags which is controlling duplicated behaviour.
TfrxFieldType | Field type.
TfrxFillType | Fill types of report objects.
TfrxFilterAccess | Access type of IO filters.
TfrxFilterVisibleState | These flags used in IO transports to define visibility of IO transport filter. By default each transport filter component registers in global list and these flags helps to sort items of the global list.
TfrxFormatKind | Kind of the formatting.
TfrxFrameStyle | Style of the frame line.
TfrxFrameType | Type of the frame line.
TfrxGlassFillOrientation | Orientation type of glass fill.
TfrxGradientStyle | Gradient fill styles.
TfrxGridType | Grid type in the report designer.
TfrxHAlign | The horizontal alignment of the text in the "Text" object.
TfrxHyperlinkKind | Type of hyperlinks supported by report objects.
TfrxInheriteMode | The inherit mode type.
TfrxInteractiveEventSender | Type of interactive event sender.
TfrxInteractiveHighlightEvent | Reserved.
TfrxIOTransportStream | Supported stream type for current IO transport filter.
TfrxMirrorControlMode | Mirror mode. Determinate how engine align controls and content base on original layout.
TfrxMouseIntEvents | Type of mouse interactive events supported by report objects.
TfrxPreviewButton | Buttons that can be displayed in the preview window.
TfrxPrintMode | The print mode.
TfrxPrintOnType | Reserved for future use.
TfrxPrintPages | Pages to print.
TfrxProcessAtMode | Controls when to process expression calculation(for some TfrxView objects).
TfrxProgressType | The kind of action in the OnProgressXXX event: run a report, export, print.
TfrxRangeBegin | The navigation start point.
TfrxRangeEnd | The endpoint of navigation.
TfrxRestriction | Flags, used to restrict some object operations in the designer.
TfrxScrollerOrientation | Represent scrollbar orientation.
TfrxSerializeState | Controls serialization state (Not used yet).
TfrxShapeKind | Kind of shape.
TfrxShiftEngine | Determine how container shifts its child object.
TfrxShiftMode | Shift mode of the object. Behaviour depends on what type of TfrxShiftEngine selected in parent container.
TfrxSilentMode | Represents type TfrxSilentMode.
TfrxStretchMode | Stretch mode of the text objects.
TfrxToNRowsMode | This flags used in a child band to complete data band upto specified number of rows (fill the space with an empty rows). If data band has less number of rows, the empty row will be printed.
TfrxUnderlinesTextMode | Underlines text mode for "Text" object.
TfrxVAlign | The vertical alignment of the text in the "Text" object.
TfrxVisibilityType | Visibility of object in the result report.
TfrxZoomMode | Zoom mode of the preview window.
Top
Delegates
Name | Description
TfrxAfterDisconnectEvent | Occurs when the report engine close connection to database for internal database components.
TfrxBeforeConnectEvent | Occurs when the report engine establish connection to database for internal database components.
TfrxBeforePrintEvent | This event is fired each time before printing an report's object.
TfrxCheckEOFEvent | This event's handler must return the Eof = True parameter, if the end of the data set is reached.
TfrxClickObjectEvent | Occurs when report is previewed in the preview window and user click on object.
TfrxEditConnectionEvent | Occurs when user edit connection in the report wizard.
TfrxGetBlobValueEvent | This event is fired when an unknown variable (VarName) is met and IsBlobField event returns True(BLOB type). AssignTo parameter contains an object in which data should be loaded (TWideStrings for "Text" object).
TfrxGetCustomDataEvent | This event fires when engine loads report XML file and file contains XML item <FrxCustomData>(i.e. store user data inside XML file). All child nodes in this item ignores by serializer. XMLItem contains all the custom user data.
TfrxGetScriptValueEvent | Represents type TfrxGetScriptValueEvent.
TfrxGetValueEvent | This event is fired when an unknown variable (VarName) is met. An event handler must return the value of this variable in the Value parameter.
TfrxIsBlobFieldEvent | An event fires when engine checks type of an assigned field. The result tells report engine how to interpret the field with name 'FileldName'. Returns True if it's a BLOB field. In this case OnGetBlobValue event will fire.
TfrxLoadDetailTemplateEvent | Occurs when a report object loads detail report. The event handler must load the report template (given by TemplateName parameter) into Report object with using parameters of AHyperlink.
TfrxLoadEvent | Represents type TfrxLoadEvent.
TfrxLoadTemplateEvent | Occurs when a report is an inherited report. The event handler must load the report template (given by TemplateName parameter) into Report object.
TfrxManualBuildEvent | If the handler of this event is allocated, then the FastReport engine is blocked and you thus would have to construct a report manually.
TfrxMouseEnterEvent | Occurs when report is previewed in the preview window and mouse pointer enters object rect area.
TfrxMouseLeaveEvent | Occurs when report is previewed in the preview window and mouse pointer leaves object rect area.
TfrxMouseOverObjectEvent | Occurs when report is previewed in the preview window and user moves the mouse over the object.
TfrxNewGetValueEvent | This event is fired when an unknown variable (VarName) is met. An event handler must return the value of this variable in the Value parameter. New event has a Sender parameter and pass a report objects which calls an event.
TfrxNodeChanging | Notification of Tree node item. Used to notify about changes of item(Add/Remove).
TfrxObjectsNotifyEvent | List notification event.
TfrxOnFinishInPlaceEdit | Used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor.
TfrxPrintPageEvent | Occurs when a report is an inherited report. The event handler must load the report template (given by TemplateName parameter) into Report object.
TfrxProgressEvent | This event is fired when performing some continues operation (print, export, run report). The event handler may display a dialog window with progress bar. Progress parameter is the page number which is currently being processed.
TfrxRunDialogEvent | Occurs when report dialog page is previewed.
TfrxSaveCustomDataEvent | This event fires when serializer saves report template to XML(i.e. store user data inside XML file). If event is set, serializer creates <FrxCustomData> node and pass it as a parameter. Programmer may use this node to create child nodes with custom data.
TfrxSetConnectionEvent | Occurs when user set ConnectionNeme property. Internal use.
TfrxUserFunctionEvent | This event is fired when calling a function (MethodName), added with the help of the TfrxReport.AddFunction method. The event handler should return a value of the function.
Top
Types
Name | Description
frxInteger | Represents an alias of the NativeInt type.
SYSINT | Represents an alias of the Integer type.
TfrxAnchors | Set of object anchors.
TfrxBandClass | Represents type TfrxBandClass.
TfrxComponentClass | Represents type TfrxComponentClass.
TfrxComponentEditorVisibility | Represents type TfrxComponentEditorVisibility.
TfrxComponentStyle | Styles on report component.
TfrxCompressorClass | Represents type TfrxCompressorClass.
TfrxCrypterClass | Represents type TfrxCrypterClass.
TfrxCustomIOTransportClass | Represents type TfrxCustomIOTransportClass.
TfrxCustomObjectPresetClass | Represents type TfrxCustomObjectPresetClass.
TfrxDesignerClass | Represents type TfrxDesignerClass.
TfrxFilterVisibility | Set of flags used in IO transports to define visibility of IO transport filter.
TfrxFrameTypes | Type of the frame line.
TfrxInPlaceEditorClass | Represents type TfrxInPlaceEditorClass.
TfrxIOTransportStreams | Set of flags for supported stream types by IO transport filter.
TfrxMirrorControlModes | Set of mirror modes.
TfrxPreviewButtons | Set of buttons that can be displayed in the preview window.
TfrxPrintOnTypes | Represents type TfrxPrintOnTypes.
TfrxRectArray | Represents an array of the TRect type.
TfrxRestrictions | Set of flags, which restrict some object operations in the designer.
TfrxVisibilityTypes | Visibility of object in the result report.
TfrxWizardClass | Represents type TfrxWizardClass.
Top
Variables
Name | Description
frxCharset | Represents variable frxCharset.
frxCompressorClass | Represents variable frxCompressorClass.
frxCrypterClass | Represents variable frxCrypterClass.
frxCS | Represents variable frxCS.
frxDefaultIODialogTransportClass | Represents variable frxDefaultIODialogTransportClass.
frxDefaultIOTransportClass | Represents variable frxDefaultIOTransportClass.
frxDefaultTempFilterClass | Represents variable frxDefaultTempFilterClass.
frxDesignerClass | Represents variable frxDesignerClass.
frxDotMatrixExport | Represents variable frxDotMatrixExport.
frxFR2Events | Represents variable frxFR2Events.
frxGlobalVariables | The global variables list available to all reports.
frxGUIThreadID | Represents variable frxGUIThreadID.
Top
Constants
Name | Description
BND_COUNT | Represents constant BND_COUNT.
clTransparent | Default transparent color value.
crFormat | Cursor represents format sign.
crHand | Cursor represents hand sign.
crZoom | Cursor represents zoom sign.
DEF_REG_CONNECTIONS | Represents constant DEF_REG_CONNECTIONS.
fr01cm | Used to convert Pixels to millimeters.
fr01in | Used to convert Pixels to 0.X inches.
fr1CharX | Used to convert Pixels to char width(dot-matrix report).
fr1CharY | Used to convert Pixels to char height(dot-matrix report).
fr1cm | Used to convert Pixels to centimeters.
fr1in | Used to convert Pixels to inches.
frxBands | Represents constant frxBands.
frx_DefaultPPI | Represents default pixel per inch value.
FRX_OWNER_DESTROY_MESSAGE | Internal message. Used for synchronization between report component and Engine ShiftTree item. Sends when component destroying.
FR_VERSION | Represents constant FR_VERSION.
WM_CREATEHANDLE | Internal message. Sends to window controls during creation to synchronize creation of window control with main GDI thread.
WM_DESTROYHANDLE | Internal message. Sends to window controls during destroy to synchronize destroying of window control with main GDI thread.
Top
Routines
Name | Description
frxCreateFill(TfrxFillType) | Represents method frxCreateFill(TfrxFillType).
frxFindDataSet(TfrxDataSet,String,TComponent) | This function searches for a DataSet on specified owner.
frxGetDataSetList(TStrings) | Represents method frxGetDataSetList(TStrings).
frxGetFillType(TfrxCustomFill) | Represents method frxGetFillType(TfrxCustomFill).
frxGetInPlaceEditor(TfrxComponentEditorsList,TfrxComponent) | Represents method frxGetInPlaceEditor(TfrxComponentEditorsList,TfrxComponent).
frxParentForm | Function returns a global form that may be useful for some add-in controls.
frxRegEditorsClasses | Represents method frxRegEditorsClasses.
rePadding(TComponent) | Represents method rePadding(TComponent).
Top


frxClass Classes

Classes
Name | Description
EDuplicateName | Duplicate name exception class.
EExportTerminated | Export termination exception class.
TfrxBand | The TfrxBand is the base class for all bands. Band allows creation of a report area, which has a specific behaviour according to type.
TfrxBaseDelayedCommand | The base abstract class which implements IfrxDelayedCommand interface. It used as a base for all report commands. All commands stored in the command list in the report component.
TfrxBasePrepareReportCommand | This class is a base for all prepare report commands.
TfrxBindableFieldProps | Reserved.
TfrxBrushFill | Represents standard brush fill class for all report objects.
TfrxChild | The TfrxChild class represents a "Child" band. This kind of band is linked to the parent band via its "Child" property and displayed after it.
TfrxCloseQueryEvent | Represents type TfrxCloseQueryEvent.
TfrxColumnFooter | The TfrxColumnFooter class represents a "Column footer" band. This kind of band is displayed at the bottom of each column.
TfrxColumnHeader | The TfrxColumnHeader class represents a "Column header" band. This kind of band is displayed at the top of each column.
TfrxComponent | TfrxComponent is the basic class for all FastReport components. Objects of this type have such parameters as "coordinates", "size", "font", "visibility" and lists of subordinate objects. The class also contains methods, which allow saving/restoring object's state to/from the stream.
TfrxComponentEditorsClasses | This class represents collection of registered component InPlace editors for each type of components.
TfrxComponentEditorsList | This class used to store component InPlace editors for current instance of TfrxComponent.
TfrxComponentEditorsManager | This class controls group of InPlace editors registered for specified object type. Methods description are the same as for TfrxInPlaceEditor class.
TfrxComponentEditorsRegItem | This class represents registration item of InPlace editor in editors list.
TfrxContentChangedEvent | Represents type TfrxContentChangedEvent.
TfrxCustomCompressor | The TfrxCustomCompressor class is the base class for compressors that allows compression/decompression of the FR3 and FP3 files.
TfrxCustomCrypter | Represents type TfrxCustomCrypter.
TfrxCustomDatabase | The base class for DB engine components such as TfrxXXXDatabase. Used internally in reports.
TfrxCustomDBDataSet | The TfrxDBDataSet component is designed for connecting to the DB components, which are based on TDataSet, such as "TTable" and "TQuery". Such functions as navigation in the data source and referring to fields are performed automatically, which means that a programmer does not have to worry about it.
TfrxCustomDesigner | The TfrxCustomDesigner class is the base class for the report designer.
TfrxCustomEngine | The TfrxCustomEngine class is the base class for report engine. Instance of this class is stored in the TfrxReport.Engine property.
TfrxCustomExportFilter | The TfrxCustomExportFilter is the base class for all export filters.
TfrxCustomFill | Base abstract class for representation of object fills interface. Every object fill should inherit from this class.
TfrxCustomIOTransport | The TfrxCustomIOTransport class is the base class for all IO (input/output filters). It represents Base adapter interface for file or stream IO operations. Transport filters can be used in the report designer (save/open operations), report preview (save/open operations) and export filters. It possible to create one class of transport filter which encapsulates work with some IO protocol(for example save/load from cloud) and use this class where it's necessary(Designer, Preview, Exports) by setting up Visibility property.
TfrxCustomLineView | The TfrxCustomLineView class is the base class for "Line" and "Dot-matrix line" objects.
TfrxCustomMemoView | The TfrxCustomMemoView class is the base class for the "Text", "System text" and "Dot-matrix text" objects. This object represents a rectangular area with the multiline text inside.
TfrxCustomObjectPreset | Represents type TfrxCustomObjectPreset.
TfrxCustomOutline | This object represents the "Report tree" control element in a preview window. Instance of this class is stored in the TfrxReport.PreviewPages.Outline property.
TfrxCustomPreview | The TfrxCustomPreview class is the base class for TfrxPreview class.
TfrxCustomPreviewPages | The TfrxCustomPreviewPages class is the base class for pages of a prepared report. Instance of this class is stored in the TfrxReport.PreviewPages property.
TfrxCustomWizard | The TfrxCustomWizard class is the basic class for any wizards. Wizards are called from the designer's menu "File|New...". Wizard should be registered via frxWizards.Register method, defined in the frxDsgnIntf unit.
TfrxDataBand | The TfrxDataBand class is the base class for all data-bands. Data-band is a band connected to a dataset. Data-band is displayed as many times as there are records in the dataset.
TfrxDataBand4 | The TfrxDataBand4 represents a "4th data level" band.
TfrxDataBand5 | The TfrxDataBand5 represents a "5th data level" band.
TfrxDataBand6 | The TfrxDataBand6 represents a "6th data level" band.
TfrxDataPage | The TfrxDataPage represents a datamodule.
TfrxDataSet | The TfrxDataSet class is used for navigation of a dataset. It is base class for TfrxDBDataSet, TfrxUserDataSet components.
TfrxDataSetItem | The TfrxDataSetItem class represents a dataset in the report dataset's list. Dataset's list is contained in the TfrxReportDataSets class.
TfrxDBComponents | Represents type TfrxDBComponents.
TfrxDelayedCommandManager | The TfrxDelayedCommandManager class is used as storage and manager for commands which implements IfrxDelayedCommand interface.
TfrxDetailData | The TfrxDetailData represents a "Detail data" band.
TfrxDialogComponent | The TfrxDialogComponent class is the basic one for writing non-visual components, which can be placed on a dialog form in a report.
TfrxDialogControl | The "TfrxDialogControl" class is the basic one for writing common control, which can be placed on a dialogue form in a report. The class contains a large number of general properties and events shared with most of the common controls.
TfrxDialogPage | The TfrxDialogPage class represents a dialogue form that may contain non-visual and visual controls such as "TfrxBDETable", "Button", etc.
TfrxEngineOptions | The TfrxEngineOptions class represents a set of properties related to the FastReport engine. Instance of this class is stored in the TfrxReport.EngineOptions.
TfrxEventObject | Class uses in DragDrop events. It helps to determinate when object event was called from another object editor. Check TfrxInPlaceBandEditor.DoCustomDragDrop.
TfrxExpressionCache | The TfrxReportOptions class represents an expression cache. The instance of this class used in the report object to store most used expressions and link them with script items. It significantly increases expression calculation (like aggregate functions) in a huge reports because syntax parsing of expressions called only once.
TfrxExtPropList | Represents type TfrxExtPropList.
TfrxFillGaps | Encapsulate data for fill gaps. Band objects use it as a gap parameter for fill object.
TfrxFooter | The TfrxFooter class represents a "Footer" band. This kind of band is a footer for all data-bands.
TfrxFormat | The constructor. Do not call it directly because an instance of this class is stored in the TfrxCustomMemoView.DisplayFormat.
TfrxFormatCollection | Collection of TfrxFormat. An object can hold several formats which serves different expressions.
TfrxFR2Events | Represents type TfrxFR2Events.
TfrxFrame | The TfrxFrame class represents a frame. Almost all Frx visual objects have a frame.
TfrxFrameLine | The TfrxFrameLine class represents the parameters of one line of the frame.
TfrxGlassFill | Represents type TfrxGlassFill.
TfrxGlobalDataSetList | This class represents global list of datasets. Every ancestor of TfrxDataSet registers in this list during construction and removes when destroy.
TfrxGradientFill | Represents standard gradient fill class for all report objects.
TfrxGroupFooter | The TfrxGroupFooter class represents a "Group footer" band. This kind of band is displayed at the bottom of each group.
TfrxGroupHeader | The TfrxGroupHeader class represents a "Group header" band. This kind of band is displayed at the top of each group.
TfrxHeader | The TfrxHeader class represents a "Header" band. This kind of band is a header for all data-bands.
TfrxHighlight | The TfrxHighlight class holds the conditional highlight settings. The conditional highlight is used in the TfrxMemoView object and allows changing the font and color settings depending on some condition.
TfrxHighlightCollection | Collection of TfrxHighlight. Each object can hold several highlights which serves different conditions.
TfrxHyperlink | This class encapsulates data for hyperlinks. Some report objects may have hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page.
TfrxInPlaceEditor | The base class for InPlace editors. With InPlace editors programmers may extend functionality of the report designer and the report preview. This class handles mouse events, drag and drop, clipboard and custom draw. It can be used to create custom in place editor for the report designer, override copy/paste behaviour for selected object and draws custom editors.
TfrxIOTransportFile | The class is the base IO transport filter class for all file operations. IO filters which work directly with files use this class as ancestor.
TfrxKeyEvent | Represents type TfrxKeyEvent.
TfrxKeyPressEvent | Represents type TfrxKeyPressEvent.
TfrxLineView | The TfrxLineView class represents the "Line" object. It can show a horizontal, vertical or diagonal line.
TfrxLoadFromCommand | This class implements realization of deferred LoadFrom command.
TfrxLoadFromFileCommand | This class implements realization of deferred LoadFromFile command.
TfrxLoadFromStreamCommand | This class implements realization of deferred LoadFromStream command.
TfrxMacrosItem | Internal class used by data processing engine. Stores values for post processor.
TfrxMasterData | The TfrxMasterData represents a "Master data" band.
TfrxMemoView | The TfrxMemoView class represents the "Text" object that can show multiline text in a rectangular area.
TfrxMouseEnterViewEvent | Represents type TfrxMouseEnterViewEvent.
TfrxMouseEvent | Represents type TfrxMouseEvent.
TfrxMouseLeaveViewEvent | Represents type TfrxMouseLeaveViewEvent.
TfrxMouseMoveEvent | Represents type TfrxMouseMoveEvent.
TfrxNode | This class represents tree node which used to emulate tree structure of directories and files in IO transports.
TfrxNotifyEvent | Represents type TfrxNotifyEvent.
TfrxNullBand | Represents type TfrxNullBand.
TfrxObjectProcessing | This class encapsulate data for object processing engine.
TfrxObjectsNotifyList | Standard list with Notify event. Used as helper to detect added/deleted objects.
TfrxOverlay | The TfrxOverlay class represents an "Overlay" band. This kind of band is printed on each page as a bottom layer.
TfrxPage | The TfrxPage class is the base class for report design pages such as TfrxReportPage, TfrxDialogPage, TfrxDMPPage.
TfrxPageFooter | The TfrxPageFooter class represents a "Page footer" band. This kind of band is displayed at the bottom of each page.
TfrxPageHeader | The TfrxPageHeader class represents a "Page header" band. This kind of band is displayed at the top of each page.
TfrxPictureView | The TfrxPictureView class represents the "Picture" object. It can show a picture in the PNG, BMP, JPEG, ICO, WMF, EMF formats.
TfrxPostProcessor | This class used as post-process data dictionary. It controls behaviour of post-processed objects and stores data and expressions of these objects. Used by the report engine for delay expression calculation in selected objects.
TfrxPrepareReportCommand | This class implements realization of deferred PrepareReport command.
TfrxPreviewClickEvent | Represents type TfrxPreviewClickEvent.
TfrxPreviewOptions | The TfrxPreviewOptions class represents a set of properties, relating to the report preview. Instance of this class is stored in the TfrxReport.PreviewOptions.
TfrxPreviewPagesList | The TfrxPreviewPagesList class represents list of TfrxCustomPreviewPages. Each TfrxReport instance can have several TfrxCustomPreviewPages instances. This class used to manage all preview pages in the report component.
TfrxPrintOptions | The TfrxPrintOptions class represents a set of properties, which relate to the report printing. Instance of this class is stored in the TfrxReport.PrintOptions.
TfrxRefreshReportCommand | This class implements realization of deferred RefreshReport command.
TfrxReport | The TfrxReport component is the main one. One TfrxReport component contains one report. In design-time, double-clicking the component calls the report designer. The component has all necessary properties and methods for report loading and saving, design and viewing.
TfrxReportComponent | Objects of this type can be placed into a report. The class contains the "Draw" method for object's painting, as well as "BeforePrint/GetData/AfterPrint" methods, which are called as soon as a report runs.
TfrxReportDataSets | The TfrxReportDataSets class represents the report dataset's list. Instance of this class is stored in the TfrxReport.Datasets property.
TfrxReportOptions | The TfrxReportOptions class represents a set of properties relating to the report. Instance of this class is stored in the TfrxReport.ReportOptions.
TfrxReportPage | The TfrxReportPage class represents a report design page that may contain bands and other objects such as "Text", "Picture", etc.
TfrxReportSummary | The TfrxReportSummary class represents a "Report summary" band. This kind of band is displayed at the end of the report.
TfrxReportTitle | The TfrxReportTitle class represents a "Report title" band. This kind of band is displayed at the top of the report.
TfrxRunDialogsEvent | Represents type TfrxRunDialogsEvent.
TfrxSaveToCompressedFilter | The class represents compressed file transport filter.
TfrxSelectedObjectsList | This class implements list of selected report objects in the report designer and in the report preview. For the report designer it encapsulates second list for the object inspector.
TfrxShapeView | The TfrxShapeView class represents the "Shape" object. It can show one of the following shapes: rectangle, ellipse, rounded rectangle, triangle, diamond.
TfrxShowReportCommand | This class implements realization of deferred ShowReport command.
TfrxStretcheable | The TfrxStretcheable class is the basic one for writing components, which modify their height depending on the data placed in them. Objects of the given class can be not only stretched, but they can also be "broken" into pieces in cases when an object does not find room on the page. At the same time, the object is displayed piecemeal until all its data is displayed.
TfrxStringClassName | Represents type TfrxStringClassName.
TfrxStyleItem | The TfrxStyleItem represents a style. Style is an element, which possesses a name and properties, and determines design attributes, i.e. color, font and frame. The style determines the way a report object should be designed. The objects such as TfrxMemoView have the Style property, which is a property intended to set the style name. When applying a value to this property, the style design attributes are copied to the object.
TfrxStyles | The TfrxStyles class represents a set of styles. It comprises methods for performing such set operations as reading, saving, adding, deleting, as well as searching for a style. The set of styles file has FS3 extension by default.
TfrxStyleSheet | The TfrxStyleSheet class represents a styles' library. It has methods for the library reading/saving, as well as adding, deleting, and style sets' searching.
TfrxSubdetailData | The TfrxSubDetailData represents a "Subdetail data" band.
TfrxSubreport | The TfrxSubreport class represents the "Subreport" object. Object is linked to a report page that stores the objects of subreport. When running a report, as soon as the "Subreport" object is encountered, the report, allocated to the subreport design page, will be displayed. After that, basic report creation will continue.
TfrxSysMemoView | The TfrxSysMemoView represents the "System text" object. This object can show system variables, aggregate values or text line.
TfrxUserDataSet | The TfrxUserDataSet component allows constructing reports, which are not connected to DB data, but do receive data from other sources (for example, array, file, etc.). A programmer should only provide navigation in such source (define OnFirst, OnNext, OnPrior, OnCheckEOF events). Data receiving is performed not via this component, but using other ways (for example, via the "TfrxReport.OnGetValue" event). In most cases you can only set the navigation range by setting RangeBegin, RangeEnd, RangeEndCount properties. The current position can be obtained via RecNo property.
TfrxView | The TfrxView class is the basic one for most components, which can be placed on a report design page. An object of this type has parameters such as "Frame" and "Color" and also can be connected to the data source. Practically all FastReport standard objects are inherited from this class.
Top


EDuplicateName Class

Summary

Duplicate name exception class.

Namespace: frxClass
Inheritance Hierarchy
Exception
frxClass.EDuplicateName
Syntax
Delphi
type
 EDuplicateName = class(Exception);
See Also

Reference

  • frxClass


EExportTerminated Class

Summary

Export termination exception class.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.EExportTerminated
Syntax
Delphi
type
 EExportTerminated = class(TObject);
See Also

Reference

  • frxClass


TfrxBand Class

Summary

The TfrxBand is the base class for all bands. Band allows creation of a report area, which has a specific behaviour according to type.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxChild
frxClass.TfrxColumnFooter
frxClass.TfrxColumnHeader
frxClass.TfrxDataBand
frxClass.TfrxFooter
frxClass.TfrxGroupFooter
frxClass.TfrxGroupHeader
frxClass.TfrxHeader
frxClass.TfrxNullBand
frxClass.TfrxOverlay
frxClass.TfrxPageFooter
frxClass.TfrxPageHeader
frxClass.TfrxReportSummary
frxClass.TfrxReportTitle
Syntax
Delphi
type
 TfrxBand = class(TfrxReportComponent)
 end;

The TfrxBand type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxBand class. (Overrides TfrxReportComponent.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode.
AllowSplit | Determines whether the band contents may be splitted if band does not find a room in the page. Only "Text", "Line" and "RichText" objects may be split. Default value is False.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer.
BandName | Returns name of the band based on its ClassName (It's not similar to Name property).
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Link to a child band that will be shown after this band.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object.
FillGap | Reference to an object winch stores fill gaps settings.
FillType | Band fill type.
Font | Represents property Font.
Frame | Reference to band Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height.
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show a child band on the same page as a parent band. If child band does not find a room on the page, it will be carried to the next page along with its parent band. Default value is False.
Left | Represents property Left.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height.
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint.
OnBeforePrint | Represents property OnBeforePrint.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point).
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True).
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont.
PrintChildIfInvisible | Determines whether to show child band if this band is invisible. Default value is False.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions.
ShiftEngine | Determine how band shifts its child object.
StartNewPage | Determines whether to form a new output page before printing this band. Default value is False.
Stretched | Determines whether the band can stretch depending on size of its objects. To use this property, band should contain stretchable objects such as "Text", "Picture", "RichText". Default value is False.
Top | Represents property Top.
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band.
Visible | Represents property Visible.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array.
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame.
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame.
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandName | Represents method GetBandName.
GetBandTitleColor | Represents method GetBandTitleColor.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetChild(TfrxChild) | Represents method SetChild(TfrxChild).
SetFill(TfrxCustomFill) | Represents method SetFill(TfrxCustomFill).
SetFillType(TfrxFillType) | Represents method SetFillType(TfrxFillType).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetFrame(TfrxFrame) | Represents method SetFrame(TfrxFrame).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVertical(Boolean) | Represents method SetVertical(Boolean).
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAllowSplit | Represents field FAllowSplit.
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBandDesignHeader | Represents field FBandDesignHeader.
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FChild | Represents field FChild.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFill | Represents field FFill.
FFillgap | Represents field FFillgap.
FFillMemo | Represents field FFillMemo.
FFillType | Represents field FFillType.
FFooter | Represents field FFooter.
FFrame | Represents field FFrame.
FGroup | Represents field FGroup.
FHasVBands | Whether the band should show vertical bands.
FHeader | Represents field FHeader.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FKeepChild | Represents field FKeepChild.
FLineN | Used for <Line>.
FLineThrough | Used for <Line#>.
FOnAfterCalcHeight | Represents field FOnAfterCalcHeight.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FOutlineText | Represents field FOutlineText.
FOverflow | Represents field FOverflow.
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintChildIfInvisible | Represents field FPrintChildIfInvisible.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftEngine | Represents field FShiftEngine.
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStartNewPage | Represents field FStartNewPage.
FStretched | Represents field FStretched.
FStretchedHeight | Height of the band after stretch.
FSubBands | List of sub bands.
FVertical | Represents field FVertical.
Top
See Also

Reference

  • frxClass


TfrxBand Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
Destroy | Represents the destructor of the TfrxBand class. (Overrides TfrxReportComponent.Destroy.)
Top


TfrxBand.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxBand class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxReportComponent.Create(TComponent)
See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Destroy Destructor

Summary

Represents the destructor of the TfrxBand class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxReportComponent.Destroy
See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand Properties

Properties
Name | Description
AllowMirrorMode | Represents property AllowMirrorMode.
AllowSplit | Determines whether the band contents may be splitted if band does not find a room in the page. Only "Text", "Line" and "RichText" objects may be split. Default value is False.
BandDesignHeader | Returns band header height if band caption enabled in the report designer.
BandName | Returns name of the band based on its ClassName (It's not similar to Name property).
Child | Link to a child band that will be shown after this band.
Fill | Reference to a band fill object.
FillGap | Reference to an object winch stores fill gaps settings.
FillType | Band fill type.
Font | Represents property Font.
Frame | Reference to band Frame.
Height | Represents property Height.
KeepChild | Determines whether to show a child band on the same page as a parent band. If child band does not find a room on the page, it will be carried to the next page along with its parent band. Default value is False.
Left | Represents property Left.
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height.
OnAfterPrint | Represents property OnAfterPrint.
OnBeforePrint | Represents property OnBeforePrint.
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point).
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True).
ParentFont | Represents property ParentFont.
PrintChildIfInvisible | Determines whether to show child band if this band is invisible. Default value is False.
Restrictions | Represents property Restrictions.
ShiftEngine | Determine how band shifts its child object.
StartNewPage | Determines whether to form a new output page before printing this band. Default value is False.
Stretched | Determines whether the band can stretch depending on size of its objects. To use this property, band should contain stretchable objects such as "Text", "Picture", "RichText". Default value is False.
Top | Represents property Top.
Vertical | Determines if the band is a vertical band.
Visible | Represents property Visible.
Width | Represents property Width.
Top


TfrxBand.AllowMirrorMode Property

Summary

Represents property AllowMirrorMode.

Namespace: frxClass
Syntax
Delphi
published
 property AllowMirrorMode;

Property Value

Type: Void

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.AllowSplit Property

Summary

Determines whether the band contents may be splitted if band does not find a room in the page. Only "Text", "Line" and "RichText" objects may be split. Default value is False.

Namespace: frxClass
Syntax
Delphi
public
 property AllowSplit: Boolean read FAllowSplit write FAllowSplit default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.BandDesignHeader Property

Summary

Returns band header height if band caption enabled in the report designer.

Namespace: frxClass
Syntax
Delphi
public
 property BandDesignHeader: Extended read FBandDesignHeader write FBandDesignHeader;

Property Value

Type: Extended

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.BandName Property

Summary

Returns name of the band based on its ClassName (It's not similar to Name property).

Namespace: frxClass
Syntax
Delphi
public
 property BandName: String read GetBandName;

Property Value

Type: String

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Child Property

Summary

Link to a child band that will be shown after this band.

Namespace: frxClass
Syntax
Delphi
public
 property Child: TfrxChild read FChild write SetChild;

Property Value

Type: TfrxChild

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Fill Property

Summary

Reference to a band fill object.

Namespace: frxClass
Syntax
Delphi
published
 property Fill: TfrxCustomFill read FFill write SetFill;

Property Value

Type: TfrxCustomFill

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FillGap Property

Summary

Reference to an object winch stores fill gaps settings.

Namespace: frxClass
Syntax
Delphi
published
 property FillGap: TfrxFillGaps read FFillGap;

Property Value

Type: TfrxFillGaps

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FillType Property

Summary

Band fill type.

Namespace: frxClass
Syntax
Delphi
published
 property FillType: TfrxFillType read FFillType write SetFillType;

Property Value

Type: TfrxFillType

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Font Property

Summary

Represents property Font.

Namespace: frxClass
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Frame Property

Summary

Reference to band Frame.

Namespace: frxClass
Syntax
Delphi
published
 property Frame: TfrxFrame read FFrame write SetFrame;

Property Value

Type: TfrxFrame

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Height Property

Summary

Represents property Height.

Namespace: frxClass
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.KeepChild Property

Summary

Determines whether to show a child band on the same page as a parent band. If child band does not find a room on the page, it will be carried to the next page along with its parent band. Default value is False.

Namespace: frxClass
Syntax
Delphi
public
 property KeepChild: Boolean read FKeepChild write FKeepChild default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Left Property

Summary

Represents property Left.

Namespace: frxClass
Syntax
Delphi
published
 property Left;

Property Value

Type: Void

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.OnAfterCalcHeight Property

Summary

Name of the script procedure that will be called after calculating the band's height.

Namespace: frxClass
Syntax
Delphi
published
 property OnAfterCalcHeight: TfrxNotifyEvent read FOnAfterCalcHeight
 write FOnAfterCalcHeight;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.OnAfterPrint Property

Summary

Represents property OnAfterPrint.

Namespace: frxClass
Syntax
Delphi
published
 property OnAfterPrint;

Property Value

Type: Void

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.OnBeforePrint Property

Summary

Represents property OnBeforePrint.

Namespace: frxClass
Syntax
Delphi
published
 property OnBeforePrint;

Property Value

Type: Void

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.OutlineText Property

Summary

"Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node.
All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point).

Namespace: frxClass
Syntax
Delphi
public
 property OutlineText: String read FOutlineText write FOutlineText;

Property Value

Type: String

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Overflow Property

Summary

Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True).

Namespace: frxClass
Syntax
Delphi
public
 property Overflow: Boolean read FOverflow write FOverflow;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.ParentFont Property

Summary

Represents property ParentFont.

Namespace: frxClass
Syntax
Delphi
published
 property ParentFont;

Property Value

Type: Void

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.PrintChildIfInvisible Property

Summary

Determines whether to show child band if this band is invisible. Default value is False.

Namespace: frxClass
Syntax
Delphi
public
 property PrintChildIfInvisible: Boolean read FPrintChildIfInvisible
 write FPrintChildIfInvisible default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Restrictions Property

Summary

Represents property Restrictions.

Namespace: frxClass
Syntax
Delphi
published
 property Restrictions;

Property Value

Type: Void

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.ShiftEngine Property

Summary

Determine how band shifts its child object.

Namespace: frxClass
Syntax
Delphi
public
 property ShiftEngine: TfrxShiftEngine read FShiftEngine write FShiftEngine default seTree;

Property Value

Type: TfrxShiftEngine

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.StartNewPage Property

Summary

Determines whether to form a new output page before printing this band. Default value is False.

Namespace: frxClass
Syntax
Delphi
public
 property StartNewPage: Boolean read FStartNewPage write FStartNewPage default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Stretched Property

Summary

Determines whether the band can stretch depending on size of its objects. To use this property, band should contain stretchable objects such as "Text", "Picture", "RichText". Default value is False.

Namespace: frxClass
Syntax
Delphi
public
 property Stretched: Boolean read FStretched write FStretched default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Top Property

Summary

Represents property Top.

Namespace: frxClass
Syntax
Delphi
published
 property Top;

Property Value

Type: Void

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Vertical Property

Summary

Determines if the band is a vertical band.

Namespace: frxClass
Syntax
Delphi
published
 property Vertical: Boolean read FVertical write SetVertical default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Visible Property

Summary

Represents property Visible.

Namespace: frxClass
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Width Property

Summary

Represents property Width.

Namespace: frxClass
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand Methods

Methods
Name | Description
BandNumber | Returns band index from frxBands array.
CreateFillMemo | Creates background object which represent band fill and frame.
DisposeFillMemo | Frees background object which represent band fill and frame.
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
GetBandName | Represents method GetBandName.
GetBandTitleColor | Represents method GetBandTitleColor.
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
SetChild(TfrxChild) | Represents method SetChild(TfrxChild).
SetFill(TfrxCustomFill) | Represents method SetFill(TfrxCustomFill).
SetFillType(TfrxFillType) | Represents method SetFillType(TfrxFillType).
SetFrame(TfrxFrame) | Represents method SetFrame(TfrxFrame).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVertical(Boolean) | Represents method SetVertical(Boolean).
Top


TfrxBand.BandNumber Method

Summary

Returns band index from frxBands array.

Namespace: frxClass
Syntax
Delphi
public
 function BandNumber: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.CreateFillMemo Method

Summary

Creates background object which represent band fill and frame.

Namespace: frxClass
Syntax
Delphi
public
 procedure CreateFillMemo();
See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.DisposeFillMemo Method

Summary

Frees background object which represent band fill and frame.

Namespace: frxClass
Syntax
Delphi
public
 procedure DisposeFillMemo();
See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.GetBandName Method

Summary

Represents method GetBandName.

Namespace: frxClass
Syntax
Delphi
private
 function GetBandName: String;

Return Value

Type: String

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.GetBandTitleColor Method

Summary

Represents method GetBandTitleColor.

Namespace: frxClass
Syntax
Delphi
protected
 function GetBandTitleColor: TColor; virtual;

Return Value

Type: TColor

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.GetContainedComponent(Extended,Extended,TfrxComponent) Method

Summary

Returns top-most object which contain point at passed coordinates

Namespace: frxClass
Syntax
Delphi
public
 function GetContainedComponent(X, Y: Extended; IsCanContain: TfrxComponent = nil): TfrxComponent; override;

Parameters

X
Type: Extended

X coordinate.

Y
Type: Extended

Y coordinate.

IsCanContain
Type: TfrxComponent

Child Component. If IsCanContain = nil - returns top-most object, otherwise IsCanContain <> nil - return top-most object which can accept IsCanContain component as child.

Return Value

Type: TfrxComponent

Found component or nil.

Overrides

TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent)
See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.IsContain(Extended,Extended) Method

Summary

Detects if point is inside an object coordinates.

Namespace: frxClass
Syntax
Delphi
public
 function IsContain(X, Y: Extended): Boolean; override;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

Overrides

TfrxComponent.IsContain(Extended,Extended)
See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: frxClass
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.SetChild(TfrxChild) Method

Summary

Represents method SetChild(TfrxChild).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetChild(Value: TfrxChild);

Parameters

Value
Type: TfrxChild

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.SetFill(TfrxCustomFill) Method

Summary

Represents method SetFill(TfrxCustomFill).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFill(const Value: TfrxCustomFill);

Parameters

Value
Type: TfrxCustomFill

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.SetFillType(TfrxFillType) Method

Summary

Represents method SetFillType(TfrxFillType).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFillType(const Value: TfrxFillType);

Parameters

Value
Type: TfrxFillType

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.SetFrame(TfrxFrame) Method

Summary

Represents method SetFrame(TfrxFrame).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFrame(const Value: TfrxFrame);

Parameters

Value
Type: TfrxFrame

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.SetHeight(Extended) Method

Summary

Represents method SetHeight(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetHeight(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetHeight(Extended)
See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.SetLeft(Extended) Method

Summary

Represents method SetLeft(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetLeft(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetLeft(Extended)
See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.SetTop(Extended) Method

Summary

Represents method SetTop(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetTop(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetTop(Extended)
See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.SetVertical(Boolean) Method

Summary

Represents method SetVertical(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetVertical(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand Fields

Fields
Name | Description
FAllowSplit | Represents field FAllowSplit.
FBandDesignHeader | Represents field FBandDesignHeader.
FChild | Represents field FChild.
FFill | Represents field FFill.
FFillgap | Represents field FFillgap.
FFillMemo | Represents field FFillMemo.
FFillType | Represents field FFillType.
FFooter | Represents field FFooter.
FFrame | Represents field FFrame.
FGroup | Represents field FGroup.
FHasVBands | Whether the band should show vertical bands.
FHeader | Represents field FHeader.
FKeepChild | Represents field FKeepChild.
FLineN | Used for <Line>.
FLineThrough | Used for <Line#>.
FOnAfterCalcHeight | Represents field FOnAfterCalcHeight.
FOutlineText | Represents field FOutlineText.
FOverflow | Represents field FOverflow.
FPrintChildIfInvisible | Represents field FPrintChildIfInvisible.
FShiftEngine | Represents field FShiftEngine.
FStartNewPage | Represents field FStartNewPage.
FStretched | Represents field FStretched.
FStretchedHeight | Height of the band after stretch.
FSubBands | List of sub bands.
FVertical | Represents field FVertical.
Top


TfrxBand.FAllowSplit Field

Summary

Represents field FAllowSplit.

Namespace: frxClass
Syntax
Delphi
private
 FAllowSplit: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FBandDesignHeader Field

Summary

Represents field FBandDesignHeader.

Namespace: frxClass
Syntax
Delphi
private
 FBandDesignHeader: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FChild Field

Summary

Represents field FChild.

Namespace: frxClass
Syntax
Delphi
private
 FChild: TfrxChild;

Field Value

Type: TfrxChild

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FFill Field

Summary

Represents field FFill.

Namespace: frxClass
Syntax
Delphi
private
 FFill: TfrxCustomFill;

Field Value

Type: TfrxCustomFill

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FFillgap Field

Summary

Represents field FFillgap.

Namespace: frxClass
Syntax
Delphi
private
 FFillgap: TfrxFillGaps;

Field Value

Type: TfrxFillGaps

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FFillMemo Field

Summary

Represents field FFillMemo.

Namespace: frxClass
Syntax
Delphi
private
 FFillMemo: TfrxMemoView;

Field Value

Type: TfrxMemoView

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FFillType Field

Summary

Represents field FFillType.

Namespace: frxClass
Syntax
Delphi
private
 FFillType: TfrxFillType;

Field Value

Type: TfrxFillType

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FFooter Field

Summary

Represents field FFooter.

Namespace: frxClass
Syntax
Delphi
public
 FHeader, FFooter, FGroup: TfrxBand;

Field Value

Type: TfrxBand

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FFrame Field

Summary

Represents field FFrame.

Namespace: frxClass
Syntax
Delphi
private
 FFrame: TfrxFrame;

Field Value

Type: TfrxFrame

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FGroup Field

Summary

Represents field FGroup.

Namespace: frxClass
Syntax
Delphi
public
 FHeader, FFooter, FGroup: TfrxBand;

Field Value

Type: TfrxBand

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FHasVBands Field

Summary

Whether the band should show vertical bands.

Namespace: frxClass
Syntax
Delphi
public
 FHasVBands: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FHeader Field

Summary

Represents field FHeader.

Namespace: frxClass
Syntax
Delphi
public
 FHeader, FFooter, FGroup: TfrxBand;

Field Value

Type: TfrxBand

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FKeepChild Field

Summary

Represents field FKeepChild.

Namespace: frxClass
Syntax
Delphi
private
 FKeepChild: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FLineN Field

Summary

Used for <Line>.

Namespace: frxClass
Syntax
Delphi
public
 FLineN: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FLineThrough Field

Summary

Used for <Line#>.

Namespace: frxClass
Syntax
Delphi
public
 FLineThrough: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FOnAfterCalcHeight Field

Summary

Represents field FOnAfterCalcHeight.

Namespace: frxClass
Syntax
Delphi
private
 FOnAfterCalcHeight: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FOutlineText Field

Summary

Represents field FOutlineText.

Namespace: frxClass
Syntax
Delphi
private
 FOutlineText: String;

Field Value

Type: String

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FOverflow Field

Summary

Represents field FOverflow.

Namespace: frxClass
Syntax
Delphi
private
 FOverflow: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FPrintChildIfInvisible Field

Summary

Represents field FPrintChildIfInvisible.

Namespace: frxClass
Syntax
Delphi
private
 FPrintChildIfInvisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FShiftEngine Field

Summary

Represents field FShiftEngine.

Namespace: frxClass
Syntax
Delphi
private
 FShiftEngine: TfrxShiftEngine;

Field Value

Type: TfrxShiftEngine

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FStartNewPage Field

Summary

Represents field FStartNewPage.

Namespace: frxClass
Syntax
Delphi
private
 FStartNewPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FStretched Field

Summary

Represents field FStretched.

Namespace: frxClass
Syntax
Delphi
private
 FStretched: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FStretchedHeight Field

Summary

Height of the band after stretch.

Namespace: frxClass
Syntax
Delphi
public
 FStretchedHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FSubBands Field

Summary

List of sub bands.

Namespace: frxClass
Syntax
Delphi
public
 FSubBands: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBand.FVertical Field

Summary

Represents field FVertical.

Namespace: frxClass
Syntax
Delphi
private
 FVertical: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBand
  • frxClass


TfrxBaseDelayedCommand Class

Summary

The base abstract class which implements IfrxDelayedCommand interface. It used as a base for all report commands. All commands stored in the command list in the report component.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxBaseDelayedCommand
frxClass.TfrxBasePrepareReportCommand
frxClass.TfrxLoadFromCommand
frxClass.TfrxLoadFromFileCommand
frxClass.TfrxLoadFromStreamCommand
Syntax
Delphi
type
 TfrxBaseDelayedCommand = class(TPersistent, IfrxDelayedCommand)
 end;

The TfrxBaseDelayedCommand type exposes the following members.

Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction.
GetInstance | Get command instance.
GetName | Get symbolic name of current command instance.
QueryInterface(TGUID,Void) | Represents method QueryInterface(TGUID,Void).
Run | Runs command.
_AddRef | Represents method _AddRef.
_Release | Represents method _Release.
Top
Fields
Show:
Name | Description
FRefCount | Represents field FRefCount.
Top
See Also

Reference

  • frxClass


TfrxBaseDelayedCommand Methods

Methods
Name | Description
AfterConstruction | Represents method AfterConstruction.
GetInstance | Get command instance.
GetName | Get symbolic name of current command instance.
QueryInterface(TGUID,Void) | Represents method QueryInterface(TGUID,Void).
Run | Runs command.
_AddRef | Represents method _AddRef.
_Release | Represents method _Release.
Top


TfrxBaseDelayedCommand.AfterConstruction Method

Summary

Represents method AfterConstruction.

Namespace: frxClass
Syntax
Delphi
public
 procedure AfterConstruction; override;
See Also

Reference

  • TfrxBaseDelayedCommand
  • frxClass


TfrxBaseDelayedCommand.GetInstance Method

Summary

Get command instance.

Namespace: frxClass
Syntax
Delphi
public
 function GetInstance: TObject;

Return Value

Type: TObject

Implements

IfrxDelayedCommand.GetInstance
See Also

Reference

  • TfrxBaseDelayedCommand
  • frxClass


TfrxBaseDelayedCommand.GetName Method

Summary

Get symbolic name of current command instance.

Namespace: frxClass
Syntax
Delphi
public
 function GetName: String;

Return Value

Type: String

Implements

IfrxDelayedCommand.GetName
See Also

Reference

  • TfrxBaseDelayedCommand
  • frxClass


TfrxBaseDelayedCommand.QueryInterface(TGUID,Void) Method

Summary

Represents method QueryInterface(TGUID,Void).

Namespace: frxClass
Syntax
Delphi
public
 function QueryInterface(const IID: TGUID; out Obj): HResult; virtual; stdcall;

Parameters

IID
Type: TGUID

Obj
Type: System.Void

Return Value

Type: HResult

See Also

Reference

  • TfrxBaseDelayedCommand
  • frxClass


TfrxBaseDelayedCommand.Run Method

Summary

Runs command.

Namespace: frxClass
Syntax
Delphi
public
 procedure Run; virtual; abstract;

Implements

IfrxDelayedCommand.Run
See Also

Reference

  • TfrxBaseDelayedCommand
  • frxClass


TfrxBaseDelayedCommand._AddRef Method

Summary

Represents method _AddRef.

Namespace: frxClass
Syntax
Delphi
protected
 function _AddRef: Integer; stdcall;

Return Value

Type: Integer

See Also

Reference

  • TfrxBaseDelayedCommand
  • frxClass


TfrxBaseDelayedCommand._Release Method

Summary

Represents method _Release.

Namespace: frxClass
Syntax
Delphi
protected
 function _Release: Integer; stdcall;

Return Value

Type: Integer

See Also

Reference

  • TfrxBaseDelayedCommand
  • frxClass


TfrxBaseDelayedCommand Fields

Fields
Name | Description
FRefCount | Represents field FRefCount.
Top


TfrxBaseDelayedCommand.FRefCount Field

Summary

Represents field FRefCount.

Namespace: frxClass
Syntax
Delphi
private
 FRefCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBaseDelayedCommand
  • frxClass


TfrxBasePrepareReportCommand Class

Summary

This class is a base for all prepare report commands.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxBaseDelayedCommand
frxClass.TfrxBasePrepareReportCommand
frxClass.TfrxPrepareReportCommand
frxClass.TfrxRefreshReportCommand
frxClass.TfrxShowReportCommand
Syntax
Delphi
type
 TfrxBasePrepareReportCommand = class(TfrxBaseDelayedCommand)
 end;

The TfrxBasePrepareReportCommand type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport,Boolean) | Command constructor.
Destroy | Represents the destructor of the TfrxBasePrepareReportCommand class.
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseDelayedCommand.)
GetInstance | Get command instance. (Inherited from TfrxBaseDelayedCommand.)
GetName | Get symbolic name of current command instance. (Inherited from TfrxBaseDelayedCommand.)
QueryInterface(TGUID,Void) | Represents method QueryInterface(TGUID,Void). (Inherited from TfrxBaseDelayedCommand.)
Run | Runs command. (Overrides TfrxBaseDelayedCommand.Run.)
_AddRef | Represents method _AddRef. (Inherited from TfrxBaseDelayedCommand.)
_Release | Represents method _Release. (Inherited from TfrxBaseDelayedCommand.)
Top
Fields
Show:
Name | Description
FClearLast | Represents field FClearLast.
FEngineOptions | Represents field FEngineOptions.
FReport | Represents field FReport.
Top
See Also

Reference

  • frxClass


TfrxBasePrepareReportCommand Constructors

Constructors
Name | Description
Create(TfrxReport,Boolean) | Command constructor.
Destroy | Represents the destructor of the TfrxBasePrepareReportCommand class.
Top


TfrxBasePrepareReportCommand.Create(TfrxReport,Boolean) Constructor

Summary

Command constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AReport: TfrxReport; ClearLast: Boolean);

Parameters

AReport
Type: TfrxReport

Reference to a report component.

ClearLast
Type: Boolean

Clears previous report. Parameter of PrepareReport method.

See Also

Reference

  • TfrxBasePrepareReportCommand
  • frxClass


TfrxBasePrepareReportCommand.Destroy Destructor

Summary

Represents the destructor of the TfrxBasePrepareReportCommand class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxBasePrepareReportCommand
  • frxClass


TfrxBasePrepareReportCommand Methods

Methods
Name | Description
Run | Runs command. (Overrides TfrxBaseDelayedCommand.Run.)
Top


TfrxBasePrepareReportCommand.Run Method

Summary

Runs command.

Namespace: frxClass
Syntax
Delphi
public
 procedure Run; override;

Overrides

TfrxBaseDelayedCommand.Run
See Also

Reference

  • TfrxBasePrepareReportCommand
  • frxClass


TfrxBasePrepareReportCommand Fields

Fields
Name | Description
FClearLast | Represents field FClearLast.
FEngineOptions | Represents field FEngineOptions.
FReport | Represents field FReport.
Top


TfrxBasePrepareReportCommand.FClearLast Field

Summary

Represents field FClearLast.

Namespace: frxClass
Syntax
Delphi
private
 FClearLast: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBasePrepareReportCommand
  • frxClass


TfrxBasePrepareReportCommand.FEngineOptions Field

Summary

Represents field FEngineOptions.

Namespace: frxClass
Syntax
Delphi
private
 FEngineOptions: TfrxEngineOptions;

Field Value

Type: TfrxEngineOptions

See Also

Reference

  • TfrxBasePrepareReportCommand
  • frxClass


TfrxBasePrepareReportCommand.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxBasePrepareReportCommand
  • frxClass


TfrxBindableFieldProps Class

Summary

Reserved.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxBindableFieldProps
Syntax
Delphi
type
 TfrxBindableFieldProps = class(TPersistent)
 end;
See Also

Reference

  • frxClass


TfrxBrushFill Class

Summary

Represents standard brush fill class for all report objects.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxCustomFill
frxClass.TfrxBrushFill
Syntax
Delphi
type
 TfrxBrushFill = class(TfrxCustomFill)
 end;

The TfrxBrushFill type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxBrushFill class.
Top
Properties
Show:
Name | Description
BackColor | Background color.
ForeColor | Fore color for hatch brush.
Style | Brush styles.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Diff(TfrxCustomFill,String) | Returns XML string with serialized comparison of stored data between two objects( Self and AFill). (Overrides TfrxCustomFill.Diff(TfrxCustomFill,String).)
Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) | Draw fill on a canvas. (Overrides TfrxCustomFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended).)
Top
Fields
Show:
Name | Description
FBackColor | Represents field FBackColor.
FForeColor | Represents field FForeColor.
FStyle | Represents field FStyle.
Top
See Also

Reference

  • frxClass


TfrxBrushFill Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxBrushFill class.
Top


TfrxBrushFill.Create Constructor

Summary

Initializes a new instance of the TfrxBrushFill class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxBrushFill
  • frxClass


TfrxBrushFill Properties

Properties
Name | Description
BackColor | Background color.
ForeColor | Fore color for hatch brush.
Style | Brush styles.
Top


TfrxBrushFill.BackColor Property

Summary

Background color.

Namespace: frxClass
Syntax
Delphi
published
 property BackColor: TColor read FBackColor write FBackColor default clNone;

Property Value

Type: TColor

See Also

Reference

  • TfrxBrushFill
  • frxClass


TfrxBrushFill.ForeColor Property

Summary

Fore color for hatch brush.

Namespace: frxClass
Syntax
Delphi
published
 property ForeColor: TColor read FForeColor write FForeColor default clBlack;

Property Value

Type: TColor

See Also

Reference

  • TfrxBrushFill
  • frxClass


TfrxBrushFill.Style Property

Summary

Brush styles.

Namespace: frxClass
Syntax
Delphi
published
 property Style: TBrushStyle read FStyle write FStyle default bsSolid;

Property Value

Type: TBrushStyle

See Also

Reference

  • TfrxBrushFill
  • frxClass


TfrxBrushFill Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Diff(TfrxCustomFill,String) | Returns XML string with serialized comparison of stored data between two objects( Self and AFill). (Overrides TfrxCustomFill.Diff(TfrxCustomFill,String).)
Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) | Draw fill on a canvas. (Overrides TfrxCustomFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended).)
Top


TfrxBrushFill.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxBrushFill
  • frxClass


TfrxBrushFill.Diff(TfrxCustomFill,String) Method

Summary

Returns XML string with serialized comparison of stored data between two objects( Self and AFill).

Namespace: frxClass
Syntax
Delphi
public
 function Diff(AFill: TfrxCustomFill; const Add: String): String; override;

Parameters

AFill
Type: TfrxCustomFill

Add
Type: String

Return Value

Type: String

Overrides

TfrxCustomFill.Diff(TfrxCustomFill,String)
See Also

Reference

  • TfrxBrushFill
  • frxClass


TfrxBrushFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) Method

Summary

Draw fill on a canvas.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(ACanvas: TCanvas; X, Y, X1, Y1: Integer; ScaleX, ScaleY: Extended); override;

Parameters

ACanvas
Type: TCanvas

Source canvas.

X
Type: Integer

Start X coordinate of draw area.

Y
Type: Integer

Start Y coordinate of draw area.

X1
Type: Integer

End X coordinate of draw area.

Y1
Type: Integer

End Y coordinate of draw area.

ScaleX
Type: Extended

X scale factor.

ScaleY
Type: Extended

Y scale factor.

Overrides

TfrxCustomFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended)
See Also

Reference

  • TfrxBrushFill
  • frxClass


TfrxBrushFill Fields

Fields
Name | Description
FBackColor | Represents field FBackColor.
FForeColor | Represents field FForeColor.
FStyle | Represents field FStyle.
Top


TfrxBrushFill.FBackColor Field

Summary

Represents field FBackColor.

Namespace: frxClass
Syntax
Delphi
private
 FBackColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxBrushFill
  • frxClass


TfrxBrushFill.FForeColor Field

Summary

Represents field FForeColor.

Namespace: frxClass
Syntax
Delphi
private
 FForeColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxBrushFill
  • frxClass


TfrxBrushFill.FStyle Field

Summary

Represents field FStyle.

Namespace: frxClass
Syntax
Delphi
private
 FStyle: TBrushStyle;

Field Value

Type: TBrushStyle

See Also

Reference

  • TfrxBrushFill
  • frxClass


TfrxChild Class

Summary

The TfrxChild class represents a "Child" band. This kind of band is linked to the parent band via its "Child" property and displayed after it.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxChild
Syntax
Delphi
type
 TfrxChild = class(TfrxBand)
 end;

The TfrxChild type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Represents property KeepChild.
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point). (Inherited from TfrxBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Represents property StartNewPage.
Stretched | Represents property Stretched.
ToNRows | Row count used for ToNRowsMode. The value depends on TfrxToNRowsMode flag.
ToNRowsMode | This flags used in a child band to complete data band upto specified number of rows (fill the space with an empty rows). If data band has less number of rows, the empty row will be printed.
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
FToNRows | Represents field FToNRows.
FToNRowsMode | Represents field FToNRowsMode.
Top
See Also

Reference

  • frxClass


TfrxChild Properties

Properties
Name | Description
AllowSplit | Represents property AllowSplit.
Child | Represents property Child.
KeepChild | Represents property KeepChild.
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Represents property StartNewPage.
Stretched | Represents property Stretched.
ToNRows | Row count used for ToNRowsMode. The value depends on TfrxToNRowsMode flag.
ToNRowsMode | This flags used in a child band to complete data band upto specified number of rows (fill the space with an empty rows). If data band has less number of rows, the empty row will be printed.
Top


TfrxChild.AllowSplit Property

Summary

Represents property AllowSplit.

Namespace: frxClass
Syntax
Delphi
published
 property AllowSplit;

Property Value

Type: Void

See Also

Reference

  • TfrxChild
  • frxClass


TfrxChild.Child Property

Summary

Represents property Child.

Namespace: frxClass
Syntax
Delphi
published
 property Child;

Property Value

Type: Void

See Also

Reference

  • TfrxChild
  • frxClass


TfrxChild.KeepChild Property

Summary

Represents property KeepChild.

Namespace: frxClass
Syntax
Delphi
published
 property KeepChild;

Property Value

Type: Void

See Also

Reference

  • TfrxChild
  • frxClass


TfrxChild.PrintChildIfInvisible Property

Summary

Represents property PrintChildIfInvisible.

Namespace: frxClass
Syntax
Delphi
published
 property PrintChildIfInvisible;

Property Value

Type: Void

See Also

Reference

  • TfrxChild
  • frxClass


TfrxChild.ShiftEngine Property

Summary

Represents property ShiftEngine.

Namespace: frxClass
Syntax
Delphi
published
 property ShiftEngine;

Property Value

Type: Void

See Also

Reference

  • TfrxChild
  • frxClass


TfrxChild.StartNewPage Property

Summary

Represents property StartNewPage.

Namespace: frxClass
Syntax
Delphi
published
 property StartNewPage;

Property Value

Type: Void

See Also

Reference

  • TfrxChild
  • frxClass


TfrxChild.Stretched Property

Summary

Represents property Stretched.

Namespace: frxClass
Syntax
Delphi
published
 property Stretched;

Property Value

Type: Void

See Also

Reference

  • TfrxChild
  • frxClass


TfrxChild.ToNRows Property

Summary

Row count used for ToNRowsMode. The value depends on TfrxToNRowsMode flag.

Namespace: frxClass
Syntax
Delphi
published
 property ToNRows: Integer read FToNRows write FToNRows;

Property Value

Type: Integer

See Also

Reference

  • TfrxChild
  • frxClass


TfrxChild.ToNRowsMode Property

Summary

This flags used in a child band to complete data band upto specified number of rows (fill the space with an empty rows). If data band has less number of rows, the empty row will be printed.

Namespace: frxClass
Syntax
Delphi
published
 property ToNRowsMode: TfrxToNRowsMode read FToNRowsMode write FToNRowsMode;

Property Value

Type: TfrxToNRowsMode

See Also

Reference

  • TfrxChild
  • frxClass


TfrxChild Fields

Fields
Name | Description
FToNRows | Represents field FToNRows.
FToNRowsMode | Represents field FToNRowsMode.
Top


TfrxChild.FToNRows Field

Summary

Represents field FToNRows.

Namespace: frxClass
Syntax
Delphi
private
 FToNRows: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxChild
  • frxClass


TfrxChild.FToNRowsMode Field

Summary

Represents field FToNRowsMode.

Namespace: frxClass
Syntax
Delphi
private
 FToNRowsMode: TfrxToNRowsMode;

Field Value

Type: TfrxToNRowsMode

See Also

Reference

  • TfrxChild
  • frxClass


TfrxCloseQueryEvent Class

Summary

Represents type TfrxCloseQueryEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxCloseQueryEvent = type String;
See Also

Reference

  • frxClass


TfrxColumnFooter Class

Summary

The TfrxColumnFooter class represents a "Column footer" band. This kind of band is displayed at the bottom of each column.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxColumnFooter
Syntax
Delphi
type
 TfrxColumnFooter = class(TfrxBand)
 end;

The TfrxColumnFooter type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Determines whether the band contents may be splitted if band does not find a room in the page. Only "Text", "Line" and "RichText" objects may be split. Default value is False. (Inherited from TfrxBand.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Link to a child band that will be shown after this band. (Inherited from TfrxBand.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show a child band on the same page as a parent band. If child band does not find a room on the page, it will be carried to the next page along with its parent band. Default value is False. (Inherited from TfrxBand.)
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point). (Inherited from TfrxBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Determines whether to show child band if this band is invisible. Default value is False. (Inherited from TfrxBand.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Determine how band shifts its child object. (Inherited from TfrxBand.)
StartNewPage | Determines whether to form a new output page before printing this band. Default value is False. (Inherited from TfrxBand.)
Stretched | Determines whether the band can stretch depending on size of its objects. To use this property, band should contain stretchable objects such as "Text", "Picture", "RichText". Default value is False. (Inherited from TfrxBand.)
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxColumnHeader Class

Summary

The TfrxColumnHeader class represents a "Column header" band. This kind of band is displayed at the top of each column.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxColumnHeader
Syntax
Delphi
type
 TfrxColumnHeader = class(TfrxBand)
 end;

The TfrxColumnHeader type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Determines whether the band contents may be splitted if band does not find a room in the page. Only "Text", "Line" and "RichText" objects may be split. Default value is False. (Inherited from TfrxBand.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show a child band on the same page as a parent band. If child band does not find a room on the page, it will be carried to the next page along with its parent band. Default value is False. (Inherited from TfrxBand.)
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point). (Inherited from TfrxBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Determines whether to show child band if this band is invisible. Default value is False. (Inherited from TfrxBand.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Determines whether to form a new output page before printing this band. Default value is False. (Inherited from TfrxBand.)
Stretched | Represents property Stretched.
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxColumnHeader Properties

Properties
Name | Description
Child | Represents property Child.
ShiftEngine | Represents property ShiftEngine.
Stretched | Represents property Stretched.
Top


TfrxColumnHeader.Child Property

Summary

Represents property Child.

Namespace: frxClass
Syntax
Delphi
published
 property Child;

Property Value

Type: Void

See Also

Reference

  • TfrxColumnHeader
  • frxClass


TfrxColumnHeader.ShiftEngine Property

Summary

Represents property ShiftEngine.

Namespace: frxClass
Syntax
Delphi
published
 property ShiftEngine;

Property Value

Type: Void

See Also

Reference

  • TfrxColumnHeader
  • frxClass


TfrxColumnHeader.Stretched Property

Summary

Represents property Stretched.

Namespace: frxClass
Syntax
Delphi
published
 property Stretched;

Property Value

Type: Void

See Also

Reference

  • TfrxColumnHeader
  • frxClass


TfrxComponent Class

Summary

TfrxComponent is the basic class for all FastReport components. Objects of this type have such parameters as "coordinates", "size", "font", "visibility" and lists of subordinate objects. The class also contains methods, which allow saving/restoring object's state to/from the stream.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxPage
frxClass.TfrxReport
frxClass.TfrxReportComponent
frxMapLayer.TfrxCustomLayer
frxTableObject.TfrxTableRowColumnBase
Syntax
Delphi
type
 TfrxComponent = class(TComponent)
 end;

The TfrxComponent type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxComponent class.
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object.
Destroy | Represents the destructor of the TfrxComponent class.
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels.
AbsTop | Object's Y absolute coordinate, in pixels.
AllObjects | The list of all subordinate objects.
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized.
Anchors | Anchors relative to parent container (Default left, top).
BaseName | Base name of the report object. Used for generation of unique names.
ContainerObjects | Deprecated. Used to support old cross tab behaviour.
Description | Object's description.
Font | Object's font.
frComponentStyle | Report object component styles.
GroupIndex | Represents property GroupIndex.
Height | Object's height, in pixels.
IndexTag | Not used.
IsAncestor | Returns True when object has an ancestor.
IsDesigning | The object in designing mode.
IsLoading | Object is loading.
IsPrinting | Object is printing.
IsSelected | Object selected in the report designer or report preview.
IsWriting | Object is in serialization state.
Left | Object's X coordinate (relatively to a parent, in pixels).
Objects | The list of child objects.
Page | Link to the report page, which the object belongs to.
Parent | Link to the parent object.
ParentFont | If "True", then uses the parent object font settings.
Report | Link to the report, which the object belongs to.
Restrictions | Set of flags, which restrict some object operations.
Top | Object's Y coordinate (relatively to a parent, in pixels).
TopParent | Returns topmost parent of the object.
Visible | Global visibility of the object in the result report.
Width | Object's width, in pixels.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary.
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's.
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set.
Assign(TPersistent) | Copies the state of Source object (ignores all child objects).
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects.
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary.
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build.
Clear | Creates a unique name for an object placed into the report.
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells.
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report.
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set.
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String).
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes).
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams).
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized.
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized.
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call.
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets.
FindObject(String) | Searches for an object with specified name among the child objects.
FontChanged(TObject) | Represents method FontChanged(TObject).
GetAbsLeft | Represents method GetAbsLeft.
GetAbsTop | Represents method GetAbsTop.
GetAllObjects | Represents method GetAllObjects.
GetChildOwner | Represents method GetChildOwner.
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent).
GetClientArea | Return client area of object.
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type.
GetContainerObjects | Represents method GetContainerObjects.
GetDescription | Get description of the report component. By default returns class name.
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText.
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them).
GetIsAncestor | Represents method GetIsAncestor.
GetIsLoading | Represents method GetIsLoading.
GetIsSelected | Represents method GetIsSelected.
GetPage | Represents method GetPage.
GetReport | Represents method GetReport.
GetRestrictions | Represents method GetRestrictions.
GetSortedObjects | Represents method GetSortedObjects.
GetTopParent | Represents method GetTopParent.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams).
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent).
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current.
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child.
IsAcceptControls | Represents method IsAcceptControls.
IsContain(Extended,Extended) | Detects if point is inside an object coordinates.
IsFontStored | Represents method IsFontStored.
IsHeightStored | Represents method IsHeightStored.
IsIndexTagStored | Represents method IsIndexTagStored.
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle.
IsLeftStored | Represents method IsLeftStored.
IsTopStored | Represents method IsTopStored.
IsWidthStored | Represents method IsWidthStored.
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream.
LockAnchorsUpdate | Represents method LockAnchorsUpdate.
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes).
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object.
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object.
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object.
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object.
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object.
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object.
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object.
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification).
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type.
OnPaste | Object receives message when users paste report object in the report designer. Old method.
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData).
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values.
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object.
SetFont(TFont) | Represents method SetFont(TFont).
SetHeight(Extended) | Represents method SetHeight(Extended).
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean).
SetLeft(Extended) | Represents method SetLeft(Extended).
SetName(TComponentName) | Represents method SetName(TComponentName).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent).
SetParentFont(Boolean) | Represents method SetParentFont(Boolean).
SetTop(Extended) | Represents method SetTop(Extended).
SetVisible(Boolean) | Represents method SetVisible(Boolean).
SetWidth(Extended) | Represents method SetWidth(Extended).
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod).
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate.
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended).
UpdateBounds | Used to validate object real bounds.
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData).
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName.
FAllObjects | Represents field FAllObjects.
FAllowMirrorMode | Represents field FAllowMirrorMode.
FAncestor | Represents field FAncestor.
FAncestorOnlyStream | Represents field FAncestorOnlyStream.
FAnchors | Represents field FAnchors.
FAnchorsUpdating | Represents field FAnchorsUpdating.
FBaseName | Represents field FBaseName.
FComponentEditors | Represents field FComponentEditors.
FComponentStyle | Represents field FComponentStyle.
FDescription | Represents field FDescription.
FFont | Represents field FFont.
FGroupIndex | Represents field FGroupIndex.
FHeight | Represents field FHeight.
FHighlighted | Represents field FHighlighted.
FIndexTag | Represents field FIndexTag.
FIsDesigning | Represents field FIsDesigning.
FIsLoading | Represents field FIsLoading.
FIsPrinting | Represents field FIsPrinting.
FIsWriting | Represents field FIsWriting.
FLeft | Represents field FLeft.
FMouseInView | Represents field FMouseInView.
FObjects | Represents field FObjects.
FOriginalBand | Represents field FOriginalBand.
FOriginalComponent | Represents field FOriginalComponent.
FOriginalRect | Represents field FOriginalRect.
FParent | Represents field FParent.
FParentFont | Represents field FParentFont.
FRestrictions | Represents field FRestrictions.
FSelectList | Represents field FSelectList.
FSerializedItem | Represents field FSerializedItem.
FSortedObjects | Represents field FSortedObjects.
FTop | Represents field FTop.
FVisible | Represents field FVisible.
FWidth | Represents field FWidth.
Top
See Also

Reference

  • frxClass


TfrxComponent Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxComponent class.
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object.
Destroy | Represents the destructor of the TfrxComponent class.
Top


TfrxComponent.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxComponent class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DesignCreate(TComponent,Word) Constructor

Summary

Constructor uses by the report designer when create new report object.

Namespace: frxClass
Syntax
Delphi
public
 constructor DesignCreate(AOwner: TComponent; Flags: Word); virtual;

Parameters

AOwner
Type: TComponent

Component owner.

Flags
Type: Word

Addition creation parameter depends on component class.

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Destroy Destructor

Summary

Represents the destructor of the TfrxComponent class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent Properties

Properties
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels.
AbsTop | Object's Y absolute coordinate, in pixels.
AllObjects | The list of all subordinate objects.
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized.
Anchors | Anchors relative to parent container (Default left, top).
BaseName | Base name of the report object. Used for generation of unique names.
ContainerObjects | Deprecated. Used to support old cross tab behaviour.
Description | Object's description.
Font | Object's font.
frComponentStyle | Report object component styles.
GroupIndex | Represents property GroupIndex.
Height | Object's height, in pixels.
IndexTag | Not used.
IsAncestor | Returns True when object has an ancestor.
IsDesigning | The object in designing mode.
IsLoading | Object is loading.
IsPrinting | Object is printing.
IsSelected | Object selected in the report designer or report preview.
IsWriting | Object is in serialization state.
Left | Object's X coordinate (relatively to a parent, in pixels).
Objects | The list of child objects.
Page | Link to the report page, which the object belongs to.
Parent | Link to the parent object.
ParentFont | If "True", then uses the parent object font settings.
Report | Link to the report, which the object belongs to.
Restrictions | Set of flags, which restrict some object operations.
Top | Object's Y coordinate (relatively to a parent, in pixels).
TopParent | Returns topmost parent of the object.
Visible | Global visibility of the object in the result report.
Width | Object's width, in pixels.
Top


TfrxComponent.AbsLeft Property

Summary

Object's X absolute coordinate, in pixels.

Namespace: frxClass
Syntax
Delphi
public
 property AbsLeft: Extended read GetAbsLeft;

Property Value

Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.AbsTop Property

Summary

Object's Y absolute coordinate, in pixels.

Namespace: frxClass
Syntax
Delphi
public
 property AbsTop: Extended read GetAbsTop;

Property Value

Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.AllObjects Property

Summary

The list of all subordinate objects.

Namespace: frxClass
Syntax
Delphi
public
 property AllObjects: TList read GetAllObjects;

Property Value

Type: TList

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.AllowMirrorMode Property

Summary

Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules.

Namespace: frxClass
Syntax
Delphi
public
 property AllowMirrorMode: Boolean read FAllowMirrorMode write FAllowMirrorMode default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.AncestorOnlyStream Property

Summary

Used when save object to XML. If this property set to true only values of ancestor object will be serialized.

Namespace: frxClass
Syntax
Delphi
public
 property AncestorOnlyStream: Boolean read FAncestorOnlyStream write FAncestorOnlyStream;

Property Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Anchors Property

Summary

Anchors relative to parent container (Default left, top).

Namespace: frxClass
Syntax
Delphi
public
 property Anchors: TfrxAnchors read FAnchors write SetAnchors default [fraLeft, fraTop];

Property Value

Type: TfrxAnchors

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.BaseName Property

Summary

Base name of the report object. Used for generation of unique names.

Namespace: frxClass
Syntax
Delphi
public
 property BaseName: String read FBaseName;

Property Value

Type: String

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.ContainerObjects Property

Summary

Deprecated. Used to support old cross tab behaviour.

Namespace: frxClass
Syntax
Delphi
public
 property ContainerObjects: TList read GetContainerObjects;

Property Value

Type: TList

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Description Property

Summary

Object's description.

Namespace: frxClass
Syntax
Delphi
public
 property Description: String read FDescription write FDescription;

Property Value

Type: String

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Font Property

Summary

Object's font.

Namespace: frxClass
Syntax
Delphi
public
 property Font: TFont read FFont write SetFont stored IsFontStored;

Property Value

Type: TFont

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.frComponentStyle Property

Summary

Report object component styles.

Namespace: frxClass
Syntax
Delphi
public
 property frComponentStyle: TfrxComponentStyle read FComponentStyle write FComponentStyle;

Property Value

Type: TfrxComponentStyle

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GroupIndex Property

Summary

Represents property GroupIndex.

Namespace: frxClass
Syntax
Delphi
public
 property GroupIndex: Integer read FGroupIndex write FGroupIndex default 0;

Property Value

Type: Integer

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Height Property

Summary

Object's height, in pixels.

Namespace: frxClass
Syntax
Delphi
public
 property Height: Extended read FHeight write SetHeight stored IsHeightStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IndexTag Property

Summary

Not used.

Namespace: frxClass
Syntax
Delphi
public
 property IndexTag: frxInteger read FIndexTag write FIndexTag stored IsIndexTagStored;

Property Value

Type: frxInteger

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsAncestor Property

Summary

Returns True when object has an ancestor.

Namespace: frxClass
Syntax
Delphi
public
 property IsAncestor: Boolean read GetIsAncestor;

Property Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsDesigning Property

Summary

The object in designing mode.

Namespace: frxClass
Syntax
Delphi
public
 property IsDesigning: Boolean read FIsDesigning write FIsDesigning;

Property Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsLoading Property

Summary

Object is loading.

Namespace: frxClass
Syntax
Delphi
public
 property IsLoading: Boolean read GetIsLoading write FIsLoading;

Property Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsPrinting Property

Summary

Object is printing.

Namespace: frxClass
Syntax
Delphi
public
 property IsPrinting: Boolean read FIsPrinting write FIsPrinting;

Property Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsSelected Property

Summary

Object selected in the report designer or report preview.

Namespace: frxClass
Syntax
Delphi
public
 property IsSelected: Boolean read GetIsSelected write SetIsSelected;

Property Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsWriting Property

Summary

Object is in serialization state.

Namespace: frxClass
Syntax
Delphi
public
 property IsWriting: Boolean read FIsWriting write FIsWriting;

Property Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Left Property

Summary

Object's X coordinate (relatively to a parent, in pixels).

Namespace: frxClass
Syntax
Delphi
public
 property Left: Extended read FLeft write SetLeft stored IsLeftStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Objects Property

Summary

The list of child objects.

Namespace: frxClass
Syntax
Delphi
public
 property Objects: TfrxObjectsNotifyList read FObjects;

Property Value

Type: TfrxObjectsNotifyList

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Page Property

Summary

Link to the report page, which the object belongs to.

Namespace: frxClass
Syntax
Delphi
public
 property Page: TfrxPage read GetPage;

Property Value

Type: TfrxPage

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Parent Property

Summary

Link to the parent object.

Namespace: frxClass
Syntax
Delphi
public
 property Parent: TfrxComponent read FParent write SetParent;

Property Value

Type: TfrxComponent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.ParentFont Property

Summary

If "True", then uses the parent object font settings.

Namespace: frxClass
Syntax
Delphi
public
 property ParentFont: Boolean read FParentFont write SetParentFont default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Report Property

Summary

Link to the report, which the object belongs to.

Namespace: frxClass
Syntax
Delphi
public
 property Report: TfrxReport read GetReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Restrictions Property

Summary

Set of flags, which restrict some object operations.

Namespace: frxClass
Syntax
Delphi
public
 property Restrictions: TfrxRestrictions read GetRestrictions write FRestrictions default [];

Property Value

Type: TfrxRestrictions

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Top Property

Summary

Object's Y coordinate (relatively to a parent, in pixels).

Namespace: frxClass
Syntax
Delphi
public
 property Top: Extended read FTop write SetTop stored IsTopStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.TopParent Property

Summary

Returns topmost parent of the object.

Namespace: frxClass
Syntax
Delphi
public
 property TopParent: TfrxComponent read GetTopParent;

Property Value

Type: TfrxComponent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Visible Property

Summary

Global visibility of the object in the result report.

Namespace: frxClass
Syntax
Delphi
public
 property Visible: Boolean read FVisible write SetVisible default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Width Property

Summary

Object's width, in pixels.

Namespace: frxClass
Syntax
Delphi
public
 property Width: Extended read FWidth write SetWidth stored IsWidthStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent Methods

Methods
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary.
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's.
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set.
Assign(TPersistent) | Copies the state of Source object (ignores all child objects).
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects.
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary.
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build.
Clear | Creates a unique name for an object placed into the report.
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells.
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report.
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set.
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String).
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes).
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams).
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized.
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized.
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call.
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets.
FindObject(String) | Searches for an object with specified name among the child objects.
FontChanged(TObject) | Represents method FontChanged(TObject).
GetAbsLeft | Represents method GetAbsLeft.
GetAbsTop | Represents method GetAbsTop.
GetAllObjects | Represents method GetAllObjects.
GetChildOwner | Represents method GetChildOwner.
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent).
GetClientArea | Return client area of object.
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type.
GetContainerObjects | Represents method GetContainerObjects.
GetDescription | Get description of the report component. By default returns class name.
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText.
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them).
GetIsAncestor | Represents method GetIsAncestor.
GetIsLoading | Represents method GetIsLoading.
GetIsSelected | Represents method GetIsSelected.
GetPage | Represents method GetPage.
GetReport | Represents method GetReport.
GetRestrictions | Represents method GetRestrictions.
GetSortedObjects | Represents method GetSortedObjects.
GetTopParent | Represents method GetTopParent.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams).
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent).
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current.
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child.
IsAcceptControls | Represents method IsAcceptControls.
IsContain(Extended,Extended) | Detects if point is inside an object coordinates.
IsFontStored | Represents method IsFontStored.
IsHeightStored | Represents method IsHeightStored.
IsIndexTagStored | Represents method IsIndexTagStored.
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle.
IsLeftStored | Represents method IsLeftStored.
IsTopStored | Represents method IsTopStored.
IsWidthStored | Represents method IsWidthStored.
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream.
LockAnchorsUpdate | Represents method LockAnchorsUpdate.
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes).
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object.
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object.
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object.
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object.
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object.
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object.
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object.
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification).
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type.
OnPaste | Object receives message when users paste report object in the report designer. Old method.
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData).
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values.
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object.
SetFont(TFont) | Represents method SetFont(TFont).
SetHeight(Extended) | Represents method SetHeight(Extended).
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean).
SetLeft(Extended) | Represents method SetLeft(Extended).
SetName(TComponentName) | Represents method SetName(TComponentName).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent).
SetParentFont(Boolean) | Represents method SetParentFont(Boolean).
SetTop(Extended) | Represents method SetTop(Extended).
SetVisible(Boolean) | Represents method SetVisible(Boolean).
SetWidth(Extended) | Represents method SetWidth(Extended).
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod).
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate.
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended).
UpdateBounds | Used to validate object real bounds.
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData).
Top


TfrxComponent.AddSourceObjects Method

Summary

Deprecated. Used only for cross tab object for saving nested objects to source object dictionary.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddSourceObjects; virtual;
See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.AlignChildren(Boolean,TfrxMirrorControlModes) Method

Summary

Align all child objects relative to the container based on mirror control modes and child objects Align's.

Namespace: frxClass
Syntax
Delphi
public
 procedure AlignChildren(IgnoreInvisible: Boolean = False; MirrorModes: TfrxMirrorControlModes = []); virtual;

Parameters

IgnoreInvisible
Type: Boolean

Ignore objects which's Visible property set to false.

MirrorModes
Type: TfrxMirrorControlModes

Mirror modes of top container.

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.AllDiff(TfrxComponent) Method

Summary

Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set.

Namespace: frxClass
Syntax
Delphi
public
 function AllDiff(AComponent: TfrxComponent): String;

Parameters

AComponent
Type: TfrxComponent

Return Value

Type: String

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Assign(TPersistent) Method

Summary

Copies the state of Source object (ignores all child objects).

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.AssignAll(TfrxComponent,Boolean) Method

Summary

Copies the state of Source object with all child objects.

Namespace: frxClass
Syntax
Delphi
public
 procedure AssignAll(Source: TfrxComponent; Streaming: Boolean = False);

Parameters

Source
Type: TfrxComponent

Streaming
Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.AssignAllWithOriginals(TfrxComponent,Boolean) Method

Summary

Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary.

Namespace: frxClass
Syntax
Delphi
public
 procedure AssignAllWithOriginals(Source: TfrxComponent; Streaming: Boolean = False);

Parameters

Source
Type: TfrxComponent

Streaming
Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.BeforeStartReport Method

Summary

Report engine call this method before start report preparation. Used to prepare objects before build.

Namespace: frxClass
Syntax
Delphi
public
 procedure BeforeStartReport; virtual;
See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Clear Method

Summary

Creates a unique name for an object placed into the report.

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear; virtual;
See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.ContainerAdd(TfrxComponent) Method

Summary

Deprecated. Used only for cross tab component. Adds internal child objects for cross cells.

Namespace: frxClass
Syntax
Delphi
public
 function ContainerAdd(Obj: TfrxComponent): Boolean; virtual;

Parameters

Obj
Type: TfrxComponent

Report object.

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.CreateUniqueName(TfrxReport) Method

Summary

Creates a unique name for an object placed into the report.

Namespace: frxClass
Syntax
Delphi
public
 procedure CreateUniqueName(DefaultReport: TfrxReport = nil);

Parameters

DefaultReport
Type: TfrxReport

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.Diff(TfrxComponent) Method

Summary

Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set.

Namespace: frxClass
Syntax
Delphi
public
 function Diff(AComponent: TfrxComponent): String; virtual;

Parameters

AComponent
Type: TfrxComponent

Return Value

Type: String

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DiffFont(TFont,TFont,String) Method

Summary

Represents method DiffFont(TFont,TFont,String).

Namespace: frxClass
Syntax
Delphi
protected
 function DiffFont(f1, f2: TFont; const Add: String): String;

Parameters

f1
Type: TFont

f2
Type: TFont

Add
Type: String

Return Value

Type: String

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) Method

Summary

Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
protected
 function DoDragDrop(Source: TObject; X, Y: Integer;
 var EventParams: TfrxInteractiveEventsParams): Boolean; virtual;

Parameters

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) Method

Summary

Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
protected
 function DoDragOver(Source: TObject; X, Y: Integer; State: TDragState;
 var Accept: Boolean; var EventParams: TfrxInteractiveEventsParams)
 : Boolean; virtual;

Parameters

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DoMirror(TfrxMirrorControlModes) Method

Summary

Represents method DoMirror(TfrxMirrorControlModes).

Namespace: frxClass
Syntax
Delphi
protected
 procedure DoMirror(MirrorModes: TfrxMirrorControlModes); virtual;

Parameters

MirrorModes
Type: TfrxMirrorControlModes

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DoMouseClick(Boolean,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
protected
 procedure DoMouseClick(Double: Boolean;
 var EventParams: TfrxInteractiveEventsParams); virtual;

Parameters

Double
Type: Boolean

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
protected
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams)
 : Boolean; virtual;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
protected
 procedure DoMouseEnter(aPreviousObject: TfrxComponent;
 var EventParams: TfrxInteractiveEventsParams); virtual;

Parameters

aPreviousObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
protected
 procedure DoMouseLeave(aNextObject: TfrxComponent;
 var EventParams: TfrxInteractiveEventsParams); virtual;

Parameters

aNextObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
protected
 procedure DoMouseMove(X, Y: Integer; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); virtual;

Parameters

X
Type: Integer

Y
Type: Integer

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
protected
 procedure DoMouseUp(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); virtual;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
protected
 function DoMouseWheel(Shift: TShiftState;
 WheelDelta: Integer; MousePos: TPoint;
 var EventParams: TfrxInteractiveEventsParams): Boolean; virtual;

Parameters

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) Method

Summary

Generates drag drop event for report object when drag and drop initialized.

Namespace: frxClass
Syntax
Delphi
public
 function DragDrop(Source: TObject; X, Y: Integer;
 var EventParams: TfrxInteractiveEventsParams): Boolean;

Parameters

Source
Type: TObject

The object being dropped.

X
Type: Integer

X coordinate

Y
Type: Integer

Y coordinate

EventParams
Type: TfrxInteractiveEventsParams

Structure with additional parameters.

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) Method

Summary

Generates drag over event for report object when drag and drop initialized.

Namespace: frxClass
Syntax
Delphi
public
 function DragOver(Source: TObject; X, Y: Integer; State: TDragState;
 var Accept: Boolean; var EventParams: TfrxInteractiveEventsParams)
 : Boolean;

Parameters

Source
Type: TObject

The object being dragged.

X
Type: Integer

X coordinate.

Y
Type: Integer

Y coordinate.

State
Type: TDragState

Indicates how the dragged object is moving in relation to the control.

Accept
Type: Boolean

Returns true when object can accept dragged object.

EventParams
Type: TfrxInteractiveEventsParams

Structure with additional parameters.

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.ExportInternal(TfrxCustomExportFilter) Method

Summary

Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call.

Namespace: frxClass
Syntax
Delphi
public
 function ExportInternal(Filter: TfrxCustomExportFilter): Boolean; virtual;

Parameters

Filter
Type: TfrxCustomExportFilter

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FindDataSet(TfrxDataSet,String) Method

Summary

Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets.

Namespace: frxClass
Syntax
Delphi
public
 function FindDataSet(DataSet: TfrxDataSet; const DSName: String): TfrxDataSet;

Parameters

DataSet
Type: TfrxDataSet

Dataset.

DSName
Type: String

Dataset name.

Return Value

Type: TfrxDataSet

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FindObject(String) Method

Summary

Searches for an object with specified name among the child objects.

Namespace: frxClass
Syntax
Delphi
public
 function FindObject(const AName: String): TfrxComponent; virtual;

Parameters

AName
Type: String

Return Value

Type: TfrxComponent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FontChanged(TObject) Method

Summary

Represents method FontChanged(TObject).

Namespace: frxClass
Syntax
Delphi
protected
 procedure FontChanged(Sender: TObject); virtual;

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetAbsLeft Method

Summary

Represents method GetAbsLeft.

Namespace: frxClass
Syntax
Delphi
private
 function GetAbsLeft: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetAbsTop Method

Summary

Represents method GetAbsTop.

Namespace: frxClass
Syntax
Delphi
private
 function GetAbsTop: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetAllObjects Method

Summary

Represents method GetAllObjects.

Namespace: frxClass
Syntax
Delphi
private
 function GetAllObjects: TList;

Return Value

Type: TList

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetChildOwner Method

Summary

Represents method GetChildOwner.

Namespace: frxClass
Syntax
Delphi
protected
 function GetChildOwner: TComponent; override;

Return Value

Type: TComponent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetChildren(TGetChildProc,TComponent) Method

Summary

Represents method GetChildren(TGetChildProc,TComponent).

Namespace: frxClass
Syntax
Delphi
protected
 procedure GetChildren(Proc: TGetChildProc; Root: TComponent); override;

Parameters

Proc
Type: TGetChildProc

Root
Type: TComponent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetClientArea Method

Summary

Return client area of object.

Namespace: frxClass
Syntax
Delphi
public
 function GetClientArea: TfrxRect; virtual;

Return Value

Type: TfrxRect

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent) Method

Summary

Returns top-most object which contain point at passed coordinates

Namespace: frxClass
Syntax
Delphi
public
 function GetContainedComponent(X, Y: Extended; IsCanContain: TfrxComponent = nil): TfrxComponent; virtual;

Parameters

X
Type: Extended

X coordinate.

Y
Type: Extended

Y coordinate.

IsCanContain
Type: TfrxComponent

Child Component. If IsCanContain = nil - returns top-most object, otherwise IsCanContain <> nil - return top-most object which can accept IsCanContain component as child.

Return Value

Type: TfrxComponent

Found component or nil.

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetContainedComponents(TfrxRect,TClass,TList,Boolean) Method

Summary

Returns objects inside rectangle area with class type inherit from specified class type.

Namespace: frxClass
Syntax
Delphi
public
 procedure GetContainedComponents(const aRect: TfrxRect; InheriteFrom: TClass; aComponents: TList; bSelectContainers: Boolean = False); virtual;

Parameters

aRect
Type: TfrxRect

Rectangle area.

InheriteFrom
Type: TClass

Class of objects which should be selected by function.

aComponents
Type: TList

Result List of components that suits function parameters.

bSelectContainers
Type: Boolean

Include containers into selection result.

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetContainerObjects Method

Summary

Represents method GetContainerObjects.

Namespace: frxClass
Syntax
Delphi
protected
 function GetContainerObjects: TList; virtual;

Return Value

Type: TList

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetDrawTextObject Method

Summary

Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText.

Namespace: frxClass
Syntax
Delphi
public
 function GetDrawTextObject: Pointer;

Return Value

Type: Pointer

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetGlobalReport Method

Summary

Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them).

Namespace: frxClass
Syntax
Delphi
public
 function GetGlobalReport: TfrxReport;

Return Value

Type: TfrxReport

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetIsAncestor Method

Summary

Represents method GetIsAncestor.

Namespace: frxClass
Syntax
Delphi
private
 function GetIsAncestor: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetIsLoading Method

Summary

Represents method GetIsLoading.

Namespace: frxClass
Syntax
Delphi
private
 function GetIsLoading: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetIsSelected Method

Summary

Represents method GetIsSelected.

Namespace: frxClass
Syntax
Delphi
private
 function GetIsSelected: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetPage Method

Summary

Represents method GetPage.

Namespace: frxClass
Syntax
Delphi
private
 function GetPage: TfrxPage;

Return Value

Type: TfrxPage

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetReport Method

Summary

Represents method GetReport.

Namespace: frxClass
Syntax
Delphi
private
 function GetReport: TfrxReport;

Return Value

Type: TfrxReport

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetRestrictions Method

Summary

Represents method GetRestrictions.

Namespace: frxClass
Syntax
Delphi
protected
 function GetRestrictions: TfrxRestrictions; virtual;

Return Value

Type: TfrxRestrictions

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetSortedObjects Method

Summary

Represents method GetSortedObjects.

Namespace: frxClass
Syntax
Delphi
private
 function GetSortedObjects: TStringList;

Return Value

Type: TStringList

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.GetTopParent Method

Summary

Represents method GetTopParent.

Namespace: frxClass
Syntax
Delphi
private
 function GetTopParent: TfrxComponent;

Return Value

Type: TfrxComponent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.InintComponentInPlaceEditor(TfrxInteractiveEventsParams) Method

Summary

Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
protected
 procedure InintComponentInPlaceEditor(var EventParams: TfrxInteractiveEventsParams);

Parameters

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.InternalDiff(TfrxComponent) Method

Summary

Represents method InternalDiff(TfrxComponent).

Namespace: frxClass
Syntax
Delphi
protected
 function InternalDiff(AComponent: TfrxComponent): String;

Parameters

AComponent
Type: TfrxComponent

Return Value

Type: String

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsAcceptAsChild(TfrxComponent) Method

Summary

Returns true when component in aParent can be accepted as parent for current.

Namespace: frxClass
Syntax
Delphi
public
 function IsAcceptAsChild(aParent: TfrxComponent): Boolean; virtual;

Parameters

aParent
Type: TfrxComponent

Component that supposedly should become a parent for current.

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsAcceptControl(TfrxComponent) Method

Summary

Returns true when component can accept component in aControl as child.

Namespace: frxClass
Syntax
Delphi
public
 function IsAcceptControl(aControl: TfrxComponent): Boolean; virtual;

Parameters

aControl
Type: TfrxComponent

Component that supposedly should become a child.

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsAcceptControls Method

Summary

Represents method IsAcceptControls.

Namespace: frxClass
Syntax
Delphi
public
 function IsAcceptControls: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsContain(Extended,Extended) Method

Summary

Detects if point is inside an object coordinates.

Namespace: frxClass
Syntax
Delphi
public
 function IsContain(X, Y: Extended): Boolean; virtual;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsFontStored Method

Summary

Represents method IsFontStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsFontStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsHeightStored Method

Summary

Represents method IsHeightStored.

Namespace: frxClass
Syntax
Delphi
protected
 function IsHeightStored: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsIndexTagStored Method

Summary

Represents method IsIndexTagStored.

Namespace: frxClass
Syntax
Delphi
protected
 function IsIndexTagStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsInRect(TfrxRect) Method

Summary

Returns True if part of object bounds is inside source rectangle.

Namespace: frxClass
Syntax
Delphi
public
 function IsInRect(const aRect: TfrxRect): Boolean; virtual;

Parameters

aRect
Type: TfrxRect

Source rectangle.

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsLeftStored Method

Summary

Represents method IsLeftStored.

Namespace: frxClass
Syntax
Delphi
protected
 function IsLeftStored: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsTopStored Method

Summary

Represents method IsTopStored.

Namespace: frxClass
Syntax
Delphi
protected
 function IsTopStored: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.IsWidthStored Method

Summary

Represents method IsWidthStored.

Namespace: frxClass
Syntax
Delphi
protected
 function IsWidthStored: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.LoadFromStream(TStream) Method

Summary

Loads object contents and all its child objects from the stream.

Namespace: frxClass
Syntax
Delphi
public
 procedure LoadFromStream(Stream: TStream); virtual;

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.LockAnchorsUpdate Method

Summary

Represents method LockAnchorsUpdate.

Namespace: frxClass
Syntax
Delphi
protected
 procedure LockAnchorsUpdate;
See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.MirrorContent(TfrxMirrorControlModes) Method

Summary

Represents method MirrorContent(TfrxMirrorControlModes).

Namespace: frxClass
Syntax
Delphi
protected
 procedure MirrorContent(MirrorModes: TfrxMirrorControlModes); virtual;

Parameters

MirrorModes
Type: TfrxMirrorControlModes

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.MouseClick(Boolean,TfrxInteractiveEventsParams) Method

Summary

Generates mouse click event for report object.

Namespace: frxClass
Syntax
Delphi
public
 procedure MouseClick(Double: Boolean;
 var EventParams: TfrxInteractiveEventsParams);

Parameters

Double
Type: Boolean

If True, it's a double click event.

EventParams
Type: TfrxInteractiveEventsParams

Structure with additional parameters.

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Generates mouse down event for report object.

Namespace: frxClass
Syntax
Delphi
public
 function MouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams)
 : Boolean;

Parameters

X
Type: Integer

X coordinate.

Y
Type: Integer

Y coordinate.

Button
Type: TMouseButton

Mouse button.

Shift
Type: TShiftState

Shift keys state.

EventParams
Type: TfrxInteractiveEventsParams

Structure with additional parameters.

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Generates mouse enter event for report object.

Namespace: frxClass
Syntax
Delphi
public
 procedure MouseEnter(aPreviousObject: TfrxComponent;
 var EventParams: TfrxInteractiveEventsParams);

Parameters

aPreviousObject
Type: TfrxComponent

Reference to previous object which was in focus(Can be nil).

EventParams
Type: TfrxInteractiveEventsParams

Structure with additional parameters.

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Generates mouse leave event for report object.

Namespace: frxClass
Syntax
Delphi
public
 procedure MouseLeave(X, Y: Integer; aNextObject: TfrxComponent;
 var EventParams: TfrxInteractiveEventsParams);

Parameters

X
Type: Integer

X coordinate.

Y
Type: Integer

Y coordinate.

aNextObject
Type: TfrxComponent

Reference to an object which should receive focus(Can be nil).

EventParams
Type: TfrxInteractiveEventsParams

Structure with additional parameters.

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Generates mouse move event for report object.

Namespace: frxClass
Syntax
Delphi
public
 procedure MouseMove(X, Y: Integer; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams);

Parameters

X
Type: Integer

X coordinate.

Y
Type: Integer

Y coordinate.

Shift
Type: TShiftState

Shift keys state.

EventParams
Type: TfrxInteractiveEventsParams

Structure with additional parameters.

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Generates mouse up event for report object.

Namespace: frxClass
Syntax
Delphi
public
 procedure MouseUp(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams);

Parameters

X
Type: Integer

X coordinate.

Y
Type: Integer

Y coordinate.

Button
Type: TMouseButton

Mouse button.

Shift
Type: TShiftState

Shift keys state.

EventParams
Type: TfrxInteractiveEventsParams

Structure with additional parameters.

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) Method

Summary

Generates mouse wheel event for report object.

Namespace: frxClass
Syntax
Delphi
public
 function MouseWheel(Shift: TShiftState;
 WheelDelta: Integer; MousePos: TPoint;
 var EventParams: TfrxInteractiveEventsParams): Boolean;

Parameters

Shift
Type: TShiftState

Shift keys state.

WheelDelta
Type: Integer

Delta of mouse wheel.

MousePos
Type: TPoint

Position of mouse cursor.

EventParams
Type: TfrxInteractiveEventsParams

Structure with additional parameters.

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.ObjectListNotify(Pointer,TListNotification) Method

Summary

Represents method ObjectListNotify(Pointer,TListNotification).

Namespace: frxClass
Syntax
Delphi
protected
 procedure ObjectListNotify(Ptr: Pointer; Action: TListNotification); virtual;

Parameters

Ptr
Type: Pointer

Action
Type: TListNotification

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.OnNotify(TObject) Method

Summary

The report engine notifies all objects after show band. Used only for Chart object with dtBandData type.

Namespace: frxClass
Syntax
Delphi
public
 procedure OnNotify(Sender: TObject); virtual;

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.OnPaste Method

Summary

Object receives message when users paste report object in the report designer. Old method.

Namespace: frxClass
Syntax
Delphi
public
 procedure OnPaste; virtual;
See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.ReadNestedProperty(TfrxXMLItem) Method

Summary

The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData).

Namespace: frxClass
Syntax
Delphi
public
 function ReadNestedProperty(Item: TfrxXmlItem): Boolean; virtual;

Parameters

Item
Type: TfrxXmlItem

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SaveToStream(TStream,Boolean,Boolean,Boolean) Method

Summary

Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveToStream(Stream: TStream; SaveChildren: Boolean = True;
 SaveDefaultValues: Boolean = False; Streaming: Boolean = False); virtual;

Parameters

Stream
Type: TStream

SaveChildren
Type: Boolean

SaveDefaultValues
Type: Boolean

Streaming
Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SetAnchors(TfrxAnchors) Method

Summary

Represents method SetAnchors(TfrxAnchors).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetAnchors(const Value: TfrxAnchors); virtual;

Parameters

Value
Type: TfrxAnchors

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SetBounds(Extended,Extended,Extended,Extended) Method

Summary

Sets coordinates and size of an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure SetBounds(ALeft, ATop, AWidth, AHeight: Extended);

Parameters

ALeft
Type: Extended

ATop
Type: Extended

AWidth
Type: Extended

AHeight
Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SetFont(TFont) Method

Summary

Represents method SetFont(TFont).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetFont(Value: TFont); virtual;

Parameters

Value
Type: TFont

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SetHeight(Extended) Method

Summary

Represents method SetHeight(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetHeight(Value: Extended); virtual;

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SetIsSelected(Boolean) Method

Summary

Represents method SetIsSelected(Boolean).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetIsSelected(const Value: Boolean); virtual;

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SetLeft(Extended) Method

Summary

Represents method SetLeft(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetLeft(Value: Extended); virtual;

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SetName(TComponentName) Method

Summary

Represents method SetName(TComponentName).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetName(const AName: TComponentName); override;

Parameters

AName
Type: TComponentName

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SetParent(TfrxComponent) Method

Summary

Represents method SetParent(TfrxComponent).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetParent(AParent: TfrxComponent); virtual;

Parameters

AParent
Type: TfrxComponent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SetParentFont(Boolean) Method

Summary

Represents method SetParentFont(Boolean).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetParentFont(const Value: Boolean); virtual;

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SetTop(Extended) Method

Summary

Represents method SetTop(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetTop(Value: Extended); virtual;

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SetVisible(Boolean) Method

Summary

Represents method SetVisible(Boolean).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetVisible(Value: Boolean); virtual;

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.SetWidth(Extended) Method

Summary

Represents method SetWidth(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetWidth(Value: Extended); virtual;

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.ThreadSynchronize(TThreadMethod) Method

Summary

Represents method ThreadSynchronize(TThreadMethod).

Namespace: frxClass
Syntax
Delphi
protected
 procedure ThreadSynchronize(Method: TThreadMethod);

Parameters

Method
Type: TThreadMethod

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.UnlockAnchorsUpdate Method

Summary

Represents method UnlockAnchorsUpdate.

Namespace: frxClass
Syntax
Delphi
protected
 procedure UnlockAnchorsUpdate;
See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.UpdateAnchors(Extended,Extended) Method

Summary

Represents method UpdateAnchors(Extended,Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure UpdateAnchors(DeltaX, Deltay: Extended); virtual;

Parameters

DeltaX
Type: Extended

Deltay
Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.UpdateBounds Method

Summary

Used to validate object real bounds.

Namespace: frxClass
Syntax
Delphi
public
 procedure UpdateBounds; virtual;
See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.WriteNestedProperties(TfrxXMLItem,TPersistent) Method

Summary

The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData).

Namespace: frxClass
Syntax
Delphi
public
 procedure WriteNestedProperties(Item: TfrxXmlItem; aAcenstor: TPersistent = nil); virtual;

Parameters

Item
Type: TfrxXmlItem

aAcenstor
Type: TPersistent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent Fields

Fields
Name | Description
FAliasName | Represents field FAliasName.
FAllObjects | Represents field FAllObjects.
FAllowMirrorMode | Represents field FAllowMirrorMode.
FAncestor | Represents field FAncestor.
FAncestorOnlyStream | Represents field FAncestorOnlyStream.
FAnchors | Represents field FAnchors.
FAnchorsUpdating | Represents field FAnchorsUpdating.
FBaseName | Represents field FBaseName.
FComponentEditors | Represents field FComponentEditors.
FComponentStyle | Represents field FComponentStyle.
FDescription | Represents field FDescription.
FFont | Represents field FFont.
FGroupIndex | Represents field FGroupIndex.
FHeight | Represents field FHeight.
FHighlighted | Represents field FHighlighted.
FIndexTag | Represents field FIndexTag.
FIsDesigning | Represents field FIsDesigning.
FIsLoading | Represents field FIsLoading.
FIsPrinting | Represents field FIsPrinting.
FIsWriting | Represents field FIsWriting.
FLeft | Represents field FLeft.
FMouseInView | Represents field FMouseInView.
FObjects | Represents field FObjects.
FOriginalBand | Represents field FOriginalBand.
FOriginalComponent | Represents field FOriginalComponent.
FOriginalRect | Represents field FOriginalRect.
FParent | Represents field FParent.
FParentFont | Represents field FParentFont.
FRestrictions | Represents field FRestrictions.
FSelectList | Represents field FSelectList.
FSerializedItem | Represents field FSerializedItem.
FSortedObjects | Represents field FSortedObjects.
FTop | Represents field FTop.
FVisible | Represents field FVisible.
FWidth | Represents field FWidth.
Top


TfrxComponent.FAliasName Field

Summary

Represents field FAliasName.

Namespace: frxClass
Syntax
Delphi
protected
 FAliasName: String;

Field Value

Type: String

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FAllObjects Field

Summary

Represents field FAllObjects.

Namespace: frxClass
Syntax
Delphi
private
 FAllObjects: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FAllowMirrorMode Field

Summary

Represents field FAllowMirrorMode.

Namespace: frxClass
Syntax
Delphi
private
 FAllowMirrorMode: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FAncestor Field

Summary

Represents field FAncestor.

Namespace: frxClass
Syntax
Delphi
protected
 FAncestor: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FAncestorOnlyStream Field

Summary

Represents field FAncestorOnlyStream.

Namespace: frxClass
Syntax
Delphi
private
 FAncestorOnlyStream: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FAnchors Field

Summary

Represents field FAnchors.

Namespace: frxClass
Syntax
Delphi
private
 FAnchors: TfrxAnchors;

Field Value

Type: TfrxAnchors

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FAnchorsUpdating Field

Summary

Represents field FAnchorsUpdating.

Namespace: frxClass
Syntax
Delphi
private
 FAnchorsUpdating: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FBaseName Field

Summary

Represents field FBaseName.

Namespace: frxClass
Syntax
Delphi
protected
 FBaseName: String;

Field Value

Type: String

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FComponentEditors Field

Summary

Represents field FComponentEditors.

Namespace: frxClass
Syntax
Delphi
protected
 FComponentEditors: TfrxComponentEditorsManager;

Field Value

Type: TfrxComponentEditorsManager

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FComponentStyle Field

Summary

Represents field FComponentStyle.

Namespace: frxClass
Syntax
Delphi
private
 FComponentStyle: TfrxComponentStyle;

Field Value

Type: TfrxComponentStyle

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FDescription Field

Summary

Represents field FDescription.

Namespace: frxClass
Syntax
Delphi
private
 FDescription: String;

Field Value

Type: String

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FFont Field

Summary

Represents field FFont.

Namespace: frxClass
Syntax
Delphi
private
 FFont: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FGroupIndex Field

Summary

Represents field FGroupIndex.

Namespace: frxClass
Syntax
Delphi
private
 FGroupIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FHeight Field

Summary

Represents field FHeight.

Namespace: frxClass
Syntax
Delphi
private
 FHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FHighlighted Field

Summary

Represents field FHighlighted.

Namespace: frxClass
Syntax
Delphi
protected
 FHighlighted: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FIndexTag Field

Summary

Represents field FIndexTag.

Namespace: frxClass
Syntax
Delphi
private
 FIndexTag: frxInteger;

Field Value

Type: frxInteger

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FIsDesigning Field

Summary

Represents field FIsDesigning.

Namespace: frxClass
Syntax
Delphi
private
 FIsDesigning: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FIsLoading Field

Summary

Represents field FIsLoading.

Namespace: frxClass
Syntax
Delphi
private
 FIsLoading: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FIsPrinting Field

Summary

Represents field FIsPrinting.

Namespace: frxClass
Syntax
Delphi
private
 FIsPrinting: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FIsWriting Field

Summary

Represents field FIsWriting.

Namespace: frxClass
Syntax
Delphi
private
 FIsWriting: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FLeft Field

Summary

Represents field FLeft.

Namespace: frxClass
Syntax
Delphi
private
 FLeft: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FMouseInView Field

Summary

Represents field FMouseInView.

Namespace: frxClass
Syntax
Delphi
private
 FMouseInView: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FObjects Field

Summary

Represents field FObjects.

Namespace: frxClass
Syntax
Delphi
private
 FObjects: TfrxObjectsNotifyList;

Field Value

Type: TfrxObjectsNotifyList

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FOriginalBand Field

Summary

Represents field FOriginalBand.

Namespace: frxClass
Syntax
Delphi
protected
 FOriginalBand: TfrxComponent;

Field Value

Type: TfrxComponent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FOriginalComponent Field

Summary

Represents field FOriginalComponent.

Namespace: frxClass
Syntax
Delphi
protected
 FOriginalComponent: TfrxComponent;

Field Value

Type: TfrxComponent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FOriginalRect Field

Summary

Represents field FOriginalRect.

Namespace: frxClass
Syntax
Delphi
protected
 FOriginalRect: TfrxRect;

Field Value

Type: TfrxRect

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FParent Field

Summary

Represents field FParent.

Namespace: frxClass
Syntax
Delphi
protected
 FParent: TfrxComponent;

Field Value

Type: TfrxComponent

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FParentFont Field

Summary

Represents field FParentFont.

Namespace: frxClass
Syntax
Delphi
private
 FParentFont: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FRestrictions Field

Summary

Represents field FRestrictions.

Namespace: frxClass
Syntax
Delphi
private
 FRestrictions: TfrxRestrictions;

Field Value

Type: TfrxRestrictions

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FSelectList Field

Summary

Represents field FSelectList.

Namespace: frxClass
Syntax
Delphi
private
 FSelectList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FSerializedItem Field

Summary

Represents field FSerializedItem.

Namespace: frxClass
Syntax
Delphi
protected
 FSerializedItem: TfrxXMLItem;

Field Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FSortedObjects Field

Summary

Represents field FSortedObjects.

Namespace: frxClass
Syntax
Delphi
private
 FSortedObjects: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FTop Field

Summary

Represents field FTop.

Namespace: frxClass
Syntax
Delphi
private
 FTop: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FVisible Field

Summary

Represents field FVisible.

Namespace: frxClass
Syntax
Delphi
private
 FVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponent.FWidth Field

Summary

Represents field FWidth.

Namespace: frxClass
Syntax
Delphi
private
 FWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxComponent
  • frxClass


TfrxComponentEditorsClasses Class

Summary

This class represents collection of registered component InPlace editors for each type of components.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxComponentEditorsClasses
Syntax
Delphi
type
 TfrxComponentEditorsClasses = class(TObject)
 end;

The TfrxComponentEditorsClasses type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxComponentEditorsClasses class.
Destroy | Represents the destructor of the TfrxComponentEditorsClasses class.
Top
Properties
Show:
Name | Description
EditorsClasses[Integer] | List of registered items.
Top
Methods
Show:
Name | Description
Count | Count of items.
CreateEditorsInstances(TfrxComponentEditorVisibilityState,TWinControl) | Creates new instances of InPlace editors specified in the collection.
GetEditors(Integer) | Represents method GetEditors(Integer).
IndexOf(String) | Returns item index by it's name.
LoadFromIni(TCustomIniFile) | Loads settings of editors visibility from Ini file.
PutEditors(Integer,TfrxComponentEditorsRegItem) | Represents method PutEditors(Integer,TfrxComponentEditorsRegItem).
Register(TfrxComponentClass,TfrxInPlaceEditorClass[],TfrxComponentEditorVisibility[]) | Registers new inPlcae editor class for specified component class.
SaveToIni(TCustomIniFile) | Saves settings of editors visibility to Ini file.
UnRegister(TfrxComponentClass) | Removes all registered editors for specified component class.
UnRegisterEditor(TfrxInPlaceEditorClass) | Removes all registered editors for specified editor class.
Top
Fields
Show:
Name | Description
FList | Represents field FList.
Top
See Also

Reference

  • frxClass


TfrxComponentEditorsClasses Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxComponentEditorsClasses class.
Destroy | Represents the destructor of the TfrxComponentEditorsClasses class.
Top


TfrxComponentEditorsClasses.Create Constructor

Summary

Initializes a new instance of the TfrxComponentEditorsClasses class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses.Destroy Destructor

Summary

Represents the destructor of the TfrxComponentEditorsClasses class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses Properties

Properties
Name | Description
EditorsClasses[Integer] | List of registered items.
Top


TfrxComponentEditorsClasses.EditorsClasses[Integer] Property

Summary

List of registered items.

Namespace: frxClass
Syntax
Delphi
public
 property EditorsClasses[Index: Integer]: TfrxComponentEditorsRegItem read GetEditors write PutEditors;

Parameters

Index
Type: Integer

Property Value

Type: TfrxComponentEditorsRegItem

See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses Methods

Methods
Name | Description
Count | Count of items.
CreateEditorsInstances(TfrxComponentEditorVisibilityState,TWinControl) | Creates new instances of InPlace editors specified in the collection.
GetEditors(Integer) | Represents method GetEditors(Integer).
IndexOf(String) | Returns item index by it's name.
LoadFromIni(TCustomIniFile) | Loads settings of editors visibility from Ini file.
PutEditors(Integer,TfrxComponentEditorsRegItem) | Represents method PutEditors(Integer,TfrxComponentEditorsRegItem).
Register(TfrxComponentClass,TfrxInPlaceEditorClass[],TfrxComponentEditorVisibility[]) | Registers new inPlcae editor class for specified component class.
SaveToIni(TCustomIniFile) | Saves settings of editors visibility to Ini file.
UnRegister(TfrxComponentClass) | Removes all registered editors for specified component class.
UnRegisterEditor(TfrxInPlaceEditorClass) | Removes all registered editors for specified editor class.
Top


TfrxComponentEditorsClasses.Count Method

Summary

Count of items.

Namespace: frxClass
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses.CreateEditorsInstances(TfrxComponentEditorVisibilityState,TWinControl) Method

Summary

Creates new instances of InPlace editors specified in the collection.

Namespace: frxClass
Syntax
Delphi
public
 function CreateEditorsInstances(aVisibility: TfrxComponentEditorVisibilityState; aOwner: TWinControl): TfrxComponentEditorsList;

Parameters

aVisibility
Type: TfrxComponentEditorVisibilityState

Visibility of an InPlcae editor.

aOwner
Type: TWinControl

Owner of editors controls.

Return Value

Type: TfrxComponentEditorsList

See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses.GetEditors(Integer) Method

Summary

Represents method GetEditors(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetEditors(Index: Integer): TfrxComponentEditorsRegItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxComponentEditorsRegItem

See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses.IndexOf(String) Method

Summary

Returns item index by it's name.

Namespace: frxClass
Syntax
Delphi
public
 function IndexOf(const s: String): Integer;

Parameters

s
Type: String

Item name.

Return Value

Type: Integer

See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses.LoadFromIni(TCustomIniFile) Method

Summary

Loads settings of editors visibility from Ini file.

Namespace: frxClass
Syntax
Delphi
public
 procedure LoadFromIni(IniFile: TCustomIniFile);

Parameters

IniFile
Type: TCustomIniFile

Reference to ini file.

See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses.PutEditors(Integer,TfrxComponentEditorsRegItem) Method

Summary

Represents method PutEditors(Integer,TfrxComponentEditorsRegItem).

Namespace: frxClass
Syntax
Delphi
private
 procedure PutEditors(Index: Integer;
 const Value: TfrxComponentEditorsRegItem);

Parameters

Index
Type: Integer

Value
Type: TfrxComponentEditorsRegItem

See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses.Register(TfrxComponentClass,TfrxInPlaceEditorClass[],TfrxComponentEditorVisibility[]) Method

Summary

Registers new inPlcae editor class for specified component class.

Namespace: frxClass
Syntax
Delphi
public
 procedure Register(ComponentClass: TfrxComponentClass; ComponentEditors: array of TfrxInPlaceEditorClass; EditorsVisibility: array of TfrxComponentEditorVisibility);

Parameters

ComponentClass
Type: TfrxComponentClass

Class of a component.

ComponentEditors
Type: array of TfrxInPlaceEditorClass

An open array of InPlace editor classes.

EditorsVisibility
Type: array of TfrxComponentEditorVisibility

An open array of visibility for each InPlace editor specified in ComponentEditors
parameter.

See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses.SaveToIni(TCustomIniFile) Method

Summary

Saves settings of editors visibility to Ini file.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveToIni(IniFile: TCustomIniFile);

Parameters

IniFile
Type: TCustomIniFile

Reference to ini file.

See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses.UnRegister(TfrxComponentClass) Method

Summary

Removes all registered editors for specified component class.

Namespace: frxClass
Syntax
Delphi
public
 procedure UnRegister(ComponentClass: TfrxComponentClass);

Parameters

ComponentClass
Type: TfrxComponentClass

Class of a component.

See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses.UnRegisterEditor(TfrxInPlaceEditorClass) Method

Summary

Removes all registered editors for specified editor class.

Namespace: frxClass
Syntax
Delphi
public
 procedure UnRegisterEditor(EditroClass: TfrxInPlaceEditorClass);

Parameters

EditroClass
Type: TfrxInPlaceEditorClass

lass of an editor.

See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsClasses Fields

Fields
Name | Description
FList | Represents field FList.
Top


TfrxComponentEditorsClasses.FList Field

Summary

Represents field FList.

Namespace: frxClass
Syntax
Delphi
private
 FList: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxComponentEditorsClasses
  • frxClass


TfrxComponentEditorsList Class

Summary

This class used to store component InPlace editors for current instance of TfrxComponent.

Namespace: frxClass
Inheritance Hierarchy
TStringList
frxClass.TfrxComponentEditorsList
Syntax
Delphi
type
 TfrxComponentEditorsList = class(TStringList)
 end;

The TfrxComponentEditorsList type exposes the following members.

Constructors
Show:
Name | Description
Create | Overloaded. Initializes a new instance of the TfrxComponentEditorsList class.
Destroy | Represents the destructor of the TfrxComponentEditorsList class.
Top
Properties
Show:
Name | Description
Editors[Integer] | Represents property Editors[Integer].
Top
Methods
Show:
Name | Description
CreateInstanceFromItem(TfrxComponentEditorsRegItem,TWinControl,TfrxComponentEditorVisibilityState) | Represents method CreateInstanceFromItem(TfrxComponentEditorsRegItem,TWinControl,TfrxComponentEditorVisibilityState).
GetEditors(Integer) | Represents method GetEditors(Integer).
PutEditors(Integer,TfrxComponentEditorsManager) | Represents method PutEditors(Integer,TfrxComponentEditorsManager).
Top
Fields
Show:
Name | Description
FEditorsInstances | Represents field FEditorsInstances.
Top
See Also

Reference

  • frxClass


TfrxComponentEditorsList Constructors

Constructors
Name | Description
Create | Overloaded. Initializes a new instance of the TfrxComponentEditorsList class.
Destroy | Represents the destructor of the TfrxComponentEditorsList class.
Top


TfrxComponentEditorsList.Create Constructor

Summary

Initializes a new instance of the TfrxComponentEditorsList class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create; overload;
See Also

Reference

  • TfrxComponentEditorsList
  • frxClass


TfrxComponentEditorsList.Destroy Destructor

Summary

Represents the destructor of the TfrxComponentEditorsList class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxComponentEditorsList
  • frxClass


TfrxComponentEditorsList Properties

Properties
Name | Description
Editors[Integer] | Represents property Editors[Integer].
Top


TfrxComponentEditorsList.Editors[Integer] Property

Summary

Represents property Editors[Integer].

Namespace: frxClass
Syntax
Delphi
public
 property Editors[Index: Integer]: TfrxComponentEditorsManager read GetEditors write PutEditors;

Parameters

Index
Type: Integer

Property Value

Type: TfrxComponentEditorsManager

See Also

Reference

  • TfrxComponentEditorsList
  • frxClass


TfrxComponentEditorsList Methods

Methods
Name | Description
CreateInstanceFromItem(TfrxComponentEditorsRegItem,TWinControl,TfrxComponentEditorVisibilityState) | Represents method CreateInstanceFromItem(TfrxComponentEditorsRegItem,TWinControl,TfrxComponentEditorVisibilityState).
GetEditors(Integer) | Represents method GetEditors(Integer).
PutEditors(Integer,TfrxComponentEditorsManager) | Represents method PutEditors(Integer,TfrxComponentEditorsManager).
Top


TfrxComponentEditorsList.CreateInstanceFromItem(TfrxComponentEditorsRegItem,TWinControl,TfrxComponentEditorVisibilityState) Method

Summary

Represents method CreateInstanceFromItem(TfrxComponentEditorsRegItem,TWinControl,TfrxComponentEditorVisibilityState).

Namespace: frxClass
Syntax
Delphi
public
 procedure CreateInstanceFromItem(aItem: TfrxComponentEditorsRegItem; aOwner: TWinControl; aVisibility: TfrxComponentEditorVisibilityState);

Parameters

aItem
Type: TfrxComponentEditorsRegItem

aOwner
Type: TWinControl

aVisibility
Type: TfrxComponentEditorVisibilityState

See Also

Reference

  • TfrxComponentEditorsList
  • frxClass


TfrxComponentEditorsList.GetEditors(Integer) Method

Summary

Represents method GetEditors(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetEditors(Index: Integer): TfrxComponentEditorsManager;

Parameters

Index
Type: Integer

Return Value

Type: TfrxComponentEditorsManager

See Also

Reference

  • TfrxComponentEditorsList
  • frxClass


TfrxComponentEditorsList.PutEditors(Integer,TfrxComponentEditorsManager) Method

Summary

Represents method PutEditors(Integer,TfrxComponentEditorsManager).

Namespace: frxClass
Syntax
Delphi
private
 procedure PutEditors(Index: Integer;
 const Value: TfrxComponentEditorsManager);

Parameters

Index
Type: Integer

Value
Type: TfrxComponentEditorsManager

See Also

Reference

  • TfrxComponentEditorsList
  • frxClass


TfrxComponentEditorsList Fields

Fields
Name | Description
FEditorsInstances | Represents field FEditorsInstances.
Top


TfrxComponentEditorsList.FEditorsInstances Field

Summary

Represents field FEditorsInstances.

Namespace: frxClass
Syntax
Delphi
private
 FEditorsInstances: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxComponentEditorsList
  • frxClass


TfrxComponentEditorsManager Class

Summary

This class controls group of InPlace editors registered for specified object type. Methods description are the same as for TfrxInPlaceEditor class.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxComponentEditorsManager
Syntax
Delphi
type
 TfrxComponentEditorsManager = class(TObject)
 end;

The TfrxComponentEditorsManager type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxComponentEditorsManager class.
Destroy | Represents the destructor of the TfrxComponentEditorsManager class.
Top
Properties
Show:
Name | Description
Component | Represents property Component.
Top
Methods
Show:
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | Represents method CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).
DrawCustomEditor(TCanvas,TRect) | Represents method DrawCustomEditor(TCanvas,TRect).
EditorsActiveRects(TfrxComponent) | Represents method EditorsActiveRects(TfrxComponent).
FinalizeUI(TfrxInteractiveEventsParams) | Represents method FinalizeUI(TfrxInteractiveEventsParams).
GetComponent | Represents method GetComponent.
InitializeUI(TfrxInteractiveEventsParams) | Represents method InitializeUI(TfrxInteractiveEventsParams).
IsContain(TRect,Extended,Extended) | Represents method IsContain(TRect,Extended,Extended).
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) | Represents method IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType).
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | Represents method PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).
SetClipboardObject(TPersistent) | Represents method SetClipboardObject(TPersistent).
SetComponent(TfrxComponent) | Represents method SetComponent(TfrxComponent).
SetOffset(Extended,Extended,Extended) | Represents method SetOffset(Extended,Extended,Extended).
Top
Fields
Show:
Name | Description
FComponentClass | Represents field FComponentClass.
FEditorsGlasses | Represents field FEditorsGlasses.
FOffsetX | Represents field FOffsetX.
FOffsetY | Represents field FOffsetY.
FScale | Represents field FScale.
Top
See Also

Reference

  • frxClass


TfrxComponentEditorsManager Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxComponentEditorsManager class.
Destroy | Represents the destructor of the TfrxComponentEditorsManager class.
Top


TfrxComponentEditorsManager.Create Constructor

Summary

Initializes a new instance of the TfrxComponentEditorsManager class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.Destroy Destructor

Summary

Represents the destructor of the TfrxComponentEditorsManager class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager Properties

Properties
Name | Description
Component | Represents property Component.
Top


TfrxComponentEditorsManager.Component Property

Summary

Represents property Component.

Namespace: frxClass
Syntax
Delphi
public
 property Component: TfrxComponent read GetComponent write SetComponent;

Property Value

Type: TfrxComponent

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager Methods

Methods
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | Represents method CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).
DrawCustomEditor(TCanvas,TRect) | Represents method DrawCustomEditor(TCanvas,TRect).
EditorsActiveRects(TfrxComponent) | Represents method EditorsActiveRects(TfrxComponent).
FinalizeUI(TfrxInteractiveEventsParams) | Represents method FinalizeUI(TfrxInteractiveEventsParams).
GetComponent | Represents method GetComponent.
InitializeUI(TfrxInteractiveEventsParams) | Represents method InitializeUI(TfrxInteractiveEventsParams).
IsContain(TRect,Extended,Extended) | Represents method IsContain(TRect,Extended,Extended).
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) | Represents method IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType).
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | Represents method PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).
SetClipboardObject(TPersistent) | Represents method SetClipboardObject(TPersistent).
SetComponent(TfrxComponent) | Represents method SetComponent(TfrxComponent).
SetOffset(Extended,Extended,Extended) | Represents method SetOffset(Extended,Extended,Extended).
Top


TfrxComponentEditorsManager.CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) Method

Summary

Represents method CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).

Namespace: frxClass
Syntax
Delphi
public
 procedure CopyContent(CopyFrom: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; Buffer: TStream; CopyAs: TfrxCopyPasteType = cptDefault);

Parameters

CopyFrom
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

Buffer
Type: TStream

CopyAs
Type: TfrxCopyPasteType

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) Method

Summary

Represents method DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
public
 function DoCustomDragDrop(Source: TObject; X, Y: Integer; var EventParams: TfrxInteractiveEventsParams): Boolean;

Parameters

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) Method

Summary

Represents method DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
public
 function DoCustomDragOver(Source: TObject; X, Y: Integer; State: TDragState; var Accept: Boolean; var EventParams: TfrxInteractiveEventsParams): Boolean;

Parameters

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
public
 function DoMouseMove(X, Y: Integer; Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean;

Parameters

X
Type: Integer

Y
Type: Integer

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
public
 function DoMouseUp(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
public
 function DoMouseWheel(Shift: TShiftState;
 WheelDelta: Integer; MousePos: TPoint; var EventParams: TfrxInteractiveEventsParams): Boolean;

Parameters

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.DrawCustomEditor(TCanvas,TRect) Method

Summary

Represents method DrawCustomEditor(TCanvas,TRect).

Namespace: frxClass
Syntax
Delphi
public
 procedure DrawCustomEditor(aCanvas: TCanvas; aRect: TRect);

Parameters

aCanvas
Type: TCanvas

aRect
Type: TRect

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.EditorsActiveRects(TfrxComponent) Method

Summary

Represents method EditorsActiveRects(TfrxComponent).

Namespace: frxClass
Syntax
Delphi
public
 function EditorsActiveRects(aComponent: TfrxComponent): TfrxRectArray;

Parameters

aComponent
Type: TfrxComponent

Return Value

Type: TfrxRectArray

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.FinalizeUI(TfrxInteractiveEventsParams) Method

Summary

Represents method FinalizeUI(TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
public
 procedure FinalizeUI(var EventParams: TfrxInteractiveEventsParams);

Parameters

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.GetComponent Method

Summary

Represents method GetComponent.

Namespace: frxClass
Syntax
Delphi
private
 function GetComponent: TfrxComponent;

Return Value

Type: TfrxComponent

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.InitializeUI(TfrxInteractiveEventsParams) Method

Summary

Represents method InitializeUI(TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
public
 procedure InitializeUI(var EventParams: TfrxInteractiveEventsParams);

Parameters

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.IsContain(TRect,Extended,Extended) Method

Summary

Represents method IsContain(TRect,Extended,Extended).

Namespace: frxClass
Syntax
Delphi
public
 function IsContain(ObjectRect: TRect; X, Y: Extended): Boolean;

Parameters

ObjectRect
Type: TRect

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) Method

Summary

Represents method IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType).

Namespace: frxClass
Syntax
Delphi
public
 function IsPasteAvailable(PasteTo: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; PasteAs: TfrxCopyPasteType = cptDefault): Boolean;

Parameters

PasteTo
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

PasteAs
Type: TfrxCopyPasteType

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) Method

Summary

Represents method PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).

Namespace: frxClass
Syntax
Delphi
public
 procedure PasteContent(PasteTo: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; Buffer: TStream; PasteAs: TfrxCopyPasteType = cptDefault);

Parameters

PasteTo
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

Buffer
Type: TStream

PasteAs
Type: TfrxCopyPasteType

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.SetClipboardObject(TPersistent) Method

Summary

Represents method SetClipboardObject(TPersistent).

Namespace: frxClass
Syntax
Delphi
public
 procedure SetClipboardObject(const aObject: TPersistent);

Parameters

aObject
Type: TPersistent

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.SetComponent(TfrxComponent) Method

Summary

Represents method SetComponent(TfrxComponent).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetComponent(const Value: TfrxComponent);

Parameters

Value
Type: TfrxComponent

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.SetOffset(Extended,Extended,Extended) Method

Summary

Represents method SetOffset(Extended,Extended,Extended).

Namespace: frxClass
Syntax
Delphi
public
 procedure SetOffset(aOffsetX, aOffsetY, aScale: Extended);

Parameters

aOffsetX
Type: Extended

aOffsetY
Type: Extended

aScale
Type: Extended

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager Fields

Fields
Name | Description
FComponentClass | Represents field FComponentClass.
FEditorsGlasses | Represents field FEditorsGlasses.
FOffsetX | Represents field FOffsetX.
FOffsetY | Represents field FOffsetY.
FScale | Represents field FScale.
Top


TfrxComponentEditorsManager.FComponentClass Field

Summary

Represents field FComponentClass.

Namespace: frxClass
Syntax
Delphi
private
 FComponentClass: TfrxComponentClass;

Field Value

Type: TfrxComponentClass

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.FEditorsGlasses Field

Summary

Represents field FEditorsGlasses.

Namespace: frxClass
Syntax
Delphi
private
 FEditorsGlasses: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.FOffsetX Field

Summary

Represents field FOffsetX.

Namespace: frxClass
Syntax
Delphi
private
 FOffsetX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.FOffsetY Field

Summary

Represents field FOffsetY.

Namespace: frxClass
Syntax
Delphi
private
 FOffsetY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsManager.FScale Field

Summary

Represents field FScale.

Namespace: frxClass
Syntax
Delphi
private
 FScale: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxComponentEditorsManager
  • frxClass


TfrxComponentEditorsRegItem Class

Summary

This class represents registration item of InPlace editor in editors list.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxComponentEditorsRegItem
Syntax
Delphi
type
 TfrxComponentEditorsRegItem = class(TObject)
 end;

The TfrxComponentEditorsRegItem type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxComponentEditorsRegItem class.
Destroy | Represents the destructor of the TfrxComponentEditorsRegItem class.
Top
Properties
Show:
Name | Description
ComponentClassName | Represents property ComponentClassName.
EditorClass[Integer] | Represents property EditorClass[Integer].
EditorVisibility[Integer] | Represents property EditorVisibility[Integer].
Top
Methods
Show:
Name | Description
Count | Represents method Count.
GetComponentClassName | Represents method GetComponentClassName.
GetEditorClass(Integer) | Represents method GetEditorClass(Integer).
GetEditorVisibility(Integer) | Represents method GetEditorVisibility(Integer).
SetEditorClass(Integer,TfrxInPlaceEditorClass) | Represents method SetEditorClass(Integer,TfrxInPlaceEditorClass).
SetEditorVisibility(Integer,TfrxComponentEditorVisibility) | Represents method SetEditorVisibility(Integer,TfrxComponentEditorVisibility).
Top
Fields
Show:
Name | Description
FComponentClass | Represents field FComponentClass.
FEditorsClasses | Represents field FEditorsClasses.
FEditorsVisibility | Represents field FEditorsVisibility.
Top
See Also

Reference

  • frxClass


TfrxComponentEditorsRegItem Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxComponentEditorsRegItem class.
Destroy | Represents the destructor of the TfrxComponentEditorsRegItem class.
Top


TfrxComponentEditorsRegItem.Create Constructor

Summary

Initializes a new instance of the TfrxComponentEditorsRegItem class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem.Destroy Destructor

Summary

Represents the destructor of the TfrxComponentEditorsRegItem class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem Properties

Properties
Name | Description
ComponentClassName | Represents property ComponentClassName.
EditorClass[Integer] | Represents property EditorClass[Integer].
EditorVisibility[Integer] | Represents property EditorVisibility[Integer].
Top


TfrxComponentEditorsRegItem.ComponentClassName Property

Summary

Represents property ComponentClassName.

Namespace: frxClass
Syntax
Delphi
public
 property ComponentClassName: String read GetComponentClassName;

Property Value

Type: String

See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem.EditorClass[Integer] Property

Summary

Represents property EditorClass[Integer].

Namespace: frxClass
Syntax
Delphi
public
 property EditorClass[Index: Integer]: TfrxInPlaceEditorClass read GetEditorClass write SetEditorClass;

Parameters

Index
Type: Integer

Property Value

Type: TfrxInPlaceEditorClass

See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem.EditorVisibility[Integer] Property

Summary

Represents property EditorVisibility[Integer].

Namespace: frxClass
Syntax
Delphi
public
 property EditorVisibility[Index: Integer]: TfrxComponentEditorVisibility read GetEditorVisibility write SetEditorVisibility;

Parameters

Index
Type: Integer

Property Value

Type: TfrxComponentEditorVisibility

See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem Methods

Methods
Name | Description
Count | Represents method Count.
GetComponentClassName | Represents method GetComponentClassName.
GetEditorClass(Integer) | Represents method GetEditorClass(Integer).
GetEditorVisibility(Integer) | Represents method GetEditorVisibility(Integer).
SetEditorClass(Integer,TfrxInPlaceEditorClass) | Represents method SetEditorClass(Integer,TfrxInPlaceEditorClass).
SetEditorVisibility(Integer,TfrxComponentEditorVisibility) | Represents method SetEditorVisibility(Integer,TfrxComponentEditorVisibility).
Top


TfrxComponentEditorsRegItem.Count Method

Summary

Represents method Count.

Namespace: frxClass
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem.GetComponentClassName Method

Summary

Represents method GetComponentClassName.

Namespace: frxClass
Syntax
Delphi
private
 function GetComponentClassName: String;

Return Value

Type: String

See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem.GetEditorClass(Integer) Method

Summary

Represents method GetEditorClass(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetEditorClass(Index: Integer): TfrxInPlaceEditorClass;

Parameters

Index
Type: Integer

Return Value

Type: TfrxInPlaceEditorClass

See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem.GetEditorVisibility(Integer) Method

Summary

Represents method GetEditorVisibility(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetEditorVisibility(Index: Integer): TfrxComponentEditorVisibility;

Parameters

Index
Type: Integer

Return Value

Type: TfrxComponentEditorVisibility

See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem.SetEditorClass(Integer,TfrxInPlaceEditorClass) Method

Summary

Represents method SetEditorClass(Integer,TfrxInPlaceEditorClass).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetEditorClass(Index: Integer;
 const Value: TfrxInPlaceEditorClass);

Parameters

Index
Type: Integer

Value
Type: TfrxInPlaceEditorClass

See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem.SetEditorVisibility(Integer,TfrxComponentEditorVisibility) Method

Summary

Represents method SetEditorVisibility(Integer,TfrxComponentEditorVisibility).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetEditorVisibility(Index: Integer;
 const Value: TfrxComponentEditorVisibility);

Parameters

Index
Type: Integer

Value
Type: TfrxComponentEditorVisibility

See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem Fields

Fields
Name | Description
FComponentClass | Represents field FComponentClass.
FEditorsClasses | Represents field FEditorsClasses.
FEditorsVisibility | Represents field FEditorsVisibility.
Top


TfrxComponentEditorsRegItem.FComponentClass Field

Summary

Represents field FComponentClass.

Namespace: frxClass
Syntax
Delphi
private
 FComponentClass: TfrxComponentClass;

Field Value

Type: TfrxComponentClass

See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem.FEditorsClasses Field

Summary

Represents field FEditorsClasses.

Namespace: frxClass
Syntax
Delphi
private
 FEditorsClasses: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxComponentEditorsRegItem.FEditorsVisibility Field

Summary

Represents field FEditorsVisibility.

Namespace: frxClass
Syntax
Delphi
private
 FEditorsVisibility: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxComponentEditorsRegItem
  • frxClass


TfrxContentChangedEvent Class

Summary

Represents type TfrxContentChangedEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxContentChangedEvent = type String;
See Also

Reference

  • frxClass


TfrxCustomCompressor Class

Summary

The TfrxCustomCompressor class is the base class for compressors that allows compression/decompression of the FR3 and FP3 files.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxCustomCompressor
frxGZip.TfrxGZipCompressor
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxCustomCompressor = class(TComponent)
 end;

The TfrxCustomCompressor type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomCompressor class.
Destroy | Represents the destructor of the TfrxCustomCompressor class.
Top
Properties
Show:
Name | Description
IsFR3File | Determines if there is compressed data is the FR3 file. FR3 file can be compressed using maximum compression.
Report | Reference to a report.
Stream | Stream used by compressing/decompressing operations.
Top
Methods
Show:
Name | Description
Compress(TStream) | Method will compress the data from the Stream property and save resulting data to a Dest stream.
CreateStream | Represents method CreateStream.
Decompress(TStream) | Method will decompress the data from a Source parameter and save resulting data to a stream defined in the Stream property.
SetIsFR3File(Boolean) | Represents method SetIsFR3File(Boolean).
Top
Fields
Show:
Name | Description
FFilter | Represents field FFilter.
FIsFR3File | Represents field FIsFR3File.
FOldCompressor | Represents field FOldCompressor.
FReport | Represents field FReport.
FStream | Represents field FStream.
FTempFile | Represents field FTempFile.
Top
See Also

Reference

  • frxClass


TfrxCustomCompressor Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomCompressor class.
Destroy | Represents the destructor of the TfrxCustomCompressor class.
Top


TfrxCustomCompressor.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomCompressor class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomCompressor class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor Properties

Properties
Name | Description
IsFR3File | Determines if there is compressed data is the FR3 file. FR3 file can be compressed using maximum compression.
Report | Reference to a report.
Stream | Stream used by compressing/decompressing operations.
Top


TfrxCustomCompressor.IsFR3File Property

Summary

Determines if there is compressed data is the FR3 file. FR3 file can be compressed using maximum compression.

Namespace: frxClass
Syntax
Delphi
public
 property IsFR3File: Boolean read FIsFR3File write SetIsFR3File;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor.Report Property

Summary

Reference to a report.

Namespace: frxClass
Syntax
Delphi
public
 property Report: TfrxReport read FReport write FReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor.Stream Property

Summary

Stream used by compressing/decompressing operations.

Namespace: frxClass
Syntax
Delphi
public
 property Stream: TStream read FStream write FStream;

Property Value

Type: TStream

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor Methods

Methods
Name | Description
Compress(TStream) | Method will compress the data from the Stream property and save resulting data to a Dest stream.
CreateStream | Represents method CreateStream.
Decompress(TStream) | Method will decompress the data from a Source parameter and save resulting data to a stream defined in the Stream property.
SetIsFR3File(Boolean) | Represents method SetIsFR3File(Boolean).
Top


TfrxCustomCompressor.Compress(TStream) Method

Summary

Method will compress the data from the Stream property and save resulting data to a Dest stream.

Namespace: frxClass
Syntax
Delphi
public
 procedure Compress(Dest: TStream); virtual; abstract;

Parameters

Dest
Type: TStream

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor.CreateStream Method

Summary

Represents method CreateStream.

Namespace: frxClass
Syntax
Delphi
public
 procedure CreateStream;
See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor.Decompress(TStream) Method

Summary

Method will decompress the data from a Source parameter and save resulting data to a stream defined in the Stream property.

Namespace: frxClass
Syntax
Delphi
public
 function Decompress(Source: TStream): Boolean; virtual; abstract;

Parameters

Source
Type: TStream

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor.SetIsFR3File(Boolean) Method

Summary

Represents method SetIsFR3File(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetIsFR3File(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor Fields

Fields
Name | Description
FFilter | Represents field FFilter.
FIsFR3File | Represents field FIsFR3File.
FOldCompressor | Represents field FOldCompressor.
FReport | Represents field FReport.
FStream | Represents field FStream.
FTempFile | Represents field FTempFile.
Top


TfrxCustomCompressor.FFilter Field

Summary

Represents field FFilter.

Namespace: frxClass
Syntax
Delphi
private
 FFilter: TfrxSaveToCompressedFilter;

Field Value

Type: TfrxSaveToCompressedFilter

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor.FIsFR3File Field

Summary

Represents field FIsFR3File.

Namespace: frxClass
Syntax
Delphi
private
 FIsFR3File: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor.FOldCompressor Field

Summary

Represents field FOldCompressor.

Namespace: frxClass
Syntax
Delphi
private
 FOldCompressor: TfrxCompressorClass;

Field Value

Type: TfrxCompressorClass

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor.FStream Field

Summary

Represents field FStream.

Namespace: frxClass
Syntax
Delphi
private
 FStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCompressor.FTempFile Field

Summary

Represents field FTempFile.

Namespace: frxClass
Syntax
Delphi
private
 FTempFile: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomCompressor
  • frxClass


TfrxCustomCrypter Class

Summary

Represents type TfrxCustomCrypter.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxCustomCrypter
frxCrypt.TfrxCrypt
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxCustomCrypter = class(TComponent)
 end;

The TfrxCustomCrypter type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomCrypter class.
Destroy | Represents the destructor of the TfrxCustomCrypter class.
Top
Properties
Show:
Name | Description
Stream | Represents property Stream.
Top
Methods
Show:
Name | Description
CreateStream | Represents method CreateStream.
Crypt(TStream,AnsiString) | Represents method Crypt(TStream,AnsiString).
Decrypt(TStream,AnsiString) | Represents method Decrypt(TStream,AnsiString).
Top
Fields
Show:
Name | Description
FStream | Represents field FStream.
Top
See Also

Reference

  • frxClass


TfrxCustomCrypter Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomCrypter class.
Destroy | Represents the destructor of the TfrxCustomCrypter class.
Top


TfrxCustomCrypter.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomCrypter class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxCustomCrypter
  • frxClass


TfrxCustomCrypter.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomCrypter class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCustomCrypter
  • frxClass


TfrxCustomCrypter Properties

Properties
Name | Description
Stream | Represents property Stream.
Top


TfrxCustomCrypter.Stream Property

Summary

Represents property Stream.

Namespace: frxClass
Syntax
Delphi
public
 property Stream: TStream read FStream write FStream;

Property Value

Type: TStream

See Also

Reference

  • TfrxCustomCrypter
  • frxClass


TfrxCustomCrypter Methods

Methods
Name | Description
CreateStream | Represents method CreateStream.
Crypt(TStream,AnsiString) | Represents method Crypt(TStream,AnsiString).
Decrypt(TStream,AnsiString) | Represents method Decrypt(TStream,AnsiString).
Top


TfrxCustomCrypter.CreateStream Method

Summary

Represents method CreateStream.

Namespace: frxClass
Syntax
Delphi
public
 procedure CreateStream;
See Also

Reference

  • TfrxCustomCrypter
  • frxClass


TfrxCustomCrypter.Crypt(TStream,AnsiString) Method

Summary

Represents method Crypt(TStream,AnsiString).

Namespace: frxClass
Syntax
Delphi
public
 procedure Crypt(Dest: TStream; const Key: AnsiString); virtual; abstract;

Parameters

Dest
Type: TStream

Key
Type: AnsiString

See Also

Reference

  • TfrxCustomCrypter
  • frxClass


TfrxCustomCrypter.Decrypt(TStream,AnsiString) Method

Summary

Represents method Decrypt(TStream,AnsiString).

Namespace: frxClass
Syntax
Delphi
public
 function Decrypt(Source: TStream; const Key: AnsiString): Boolean; virtual; abstract;

Parameters

Source
Type: TStream

Key
Type: AnsiString

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrypter
  • frxClass


TfrxCustomCrypter Fields

Fields
Name | Description
FStream | Represents field FStream.
Top


TfrxCustomCrypter.FStream Field

Summary

Represents field FStream.

Namespace: frxClass
Syntax
Delphi
private
 FStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TfrxCustomCrypter
  • frxClass


TfrxCustomDatabase Class

Summary

The base class for DB engine components such as TfrxXXXDatabase. Used internally in reports.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogComponent
frxClass.TfrxCustomDatabase
Syntax
Delphi
type
 TfrxCustomDatabase = class(TfrxDialogComponent)
 end;

The TfrxCustomDatabase type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDialogComponent class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Component | Link to the component itself. (Inherited from TfrxDialogComponent.)
Connected | Determines whether the connection is active.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
DatabaseName | The database name or connection string.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Font | Object's font. (Inherited from TfrxComponent.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
LoginPrompt | Determines whether to show the login dialog when connecting to a database. Default value is True.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Params | Parameters of the connection.
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Global visibility of the object in the result report. (Inherited from TfrxComponent.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterDisconnect | Represents method AfterDisconnect.
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeConnect(Boolean) | Represents method BeforeConnect(Boolean).
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxDialogComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
FromString(WideString) | Represents method FromString(WideString).
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetConnected | Represents method GetConnected.
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDatabaseName | Represents method GetDatabaseName.
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetLoginPrompt | Represents method GetLoginPrompt.
GetParams | Represents method GetParams.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetConnected(Boolean) | Represents method SetConnected(Boolean).
SetDatabaseName(String) | Represents method SetDatabaseName(String).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetLogin(String,String) | Sets the login and password required for database connection.
SetLoginPrompt(Boolean) | Represents method SetLoginPrompt(Boolean).
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParams(TStrings) | Represents method SetParams(TStrings).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
ToString | Converts connection settings to string.
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FImageIndex | Represents field FImageIndex. (Inherited from TfrxDialogComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxClass


TfrxCustomDatabase Properties

Properties
Name | Description
Connected | Determines whether the connection is active.
DatabaseName | The database name or connection string.
LoginPrompt | Determines whether to show the login dialog when connecting to a database. Default value is True.
Params | Parameters of the connection.
Top


TfrxCustomDatabase.Connected Property

Summary

Determines whether the connection is active.

Namespace: frxClass
Syntax
Delphi
public
 property Connected: Boolean read GetConnected write SetConnected default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.DatabaseName Property

Summary

The database name or connection string.

Namespace: frxClass
Syntax
Delphi
public
 property DatabaseName: String read GetDatabaseName write SetDatabaseName;

Property Value

Type: String

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.LoginPrompt Property

Summary

Determines whether to show the login dialog when connecting to a database. Default value is True.

Namespace: frxClass
Syntax
Delphi
public
 property LoginPrompt: Boolean read GetLoginPrompt write SetLoginPrompt default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.Params Property

Summary

Parameters of the connection.

Namespace: frxClass
Syntax
Delphi
public
 property Params: TStrings read GetParams write SetParams;

Property Value

Type: TStrings

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase Methods

Methods
Name | Description
AfterDisconnect | Represents method AfterDisconnect.
BeforeConnect(Boolean) | Represents method BeforeConnect(Boolean).
FromString(WideString) | Represents method FromString(WideString).
GetConnected | Represents method GetConnected.
GetDatabaseName | Represents method GetDatabaseName.
GetLoginPrompt | Represents method GetLoginPrompt.
GetParams | Represents method GetParams.
SetConnected(Boolean) | Represents method SetConnected(Boolean).
SetDatabaseName(String) | Represents method SetDatabaseName(String).
SetLogin(String,String) | Sets the login and password required for database connection.
SetLoginPrompt(Boolean) | Represents method SetLoginPrompt(Boolean).
SetParams(TStrings) | Represents method SetParams(TStrings).
ToString | Converts connection settings to string.
Top


TfrxCustomDatabase.AfterDisconnect Method

Summary

Represents method AfterDisconnect.

Namespace: frxClass
Syntax
Delphi
protected
 procedure AfterDisconnect;
See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.BeforeConnect(Boolean) Method

Summary

Represents method BeforeConnect(Boolean).

Namespace: frxClass
Syntax
Delphi
protected
 procedure BeforeConnect(var Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.FromString(WideString) Method

Summary

Represents method FromString(WideString).

Namespace: frxClass
Syntax
Delphi
public
 procedure FromString(const Connection: WideString); virtual;

Parameters

Connection
Type: WideString

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.GetConnected Method

Summary

Represents method GetConnected.

Namespace: frxClass
Syntax
Delphi
protected
 function GetConnected: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.GetDatabaseName Method

Summary

Represents method GetDatabaseName.

Namespace: frxClass
Syntax
Delphi
protected
 function GetDatabaseName: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.GetLoginPrompt Method

Summary

Represents method GetLoginPrompt.

Namespace: frxClass
Syntax
Delphi
protected
 function GetLoginPrompt: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.GetParams Method

Summary

Represents method GetParams.

Namespace: frxClass
Syntax
Delphi
protected
 function GetParams: TStrings; virtual;

Return Value

Type: TStrings

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.SetConnected(Boolean) Method

Summary

Represents method SetConnected(Boolean).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetConnected(Value: Boolean); virtual;

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.SetDatabaseName(String) Method

Summary

Represents method SetDatabaseName(String).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetDatabaseName(const Value: String); virtual;

Parameters

Value
Type: String

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.SetLogin(String,String) Method

Summary

Sets the login and password required for database connection.

Namespace: frxClass
Syntax
Delphi
public
 procedure SetLogin(const Login, Password: String); virtual;

Parameters

Login
Type: String

Password
Type: String

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.SetLoginPrompt(Boolean) Method

Summary

Represents method SetLoginPrompt(Boolean).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetLoginPrompt(Value: Boolean); virtual;

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.SetParams(TStrings) Method

Summary

Represents method SetParams(TStrings).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetParams(Value: TStrings); virtual;

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDatabase.ToString Method

Summary

Converts connection settings to string.

Namespace: frxClass
Syntax
Delphi
public
 function ToString: WideString; reintroduce; virtual;

Return Value

Type: WideString

See Also

Reference

  • TfrxCustomDatabase
  • frxClass


TfrxCustomDBDataSet Class

Summary

The TfrxDBDataSet component is designed for connecting to the DB components, which are based on TDataSet, such as "TTable" and "TQuery". Such functions as navigation in the data source and referring to fields are performed automatically, which means that a programmer does not have to worry about it.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogComponent
frxClass.TfrxDataSet
frxClass.TfrxCustomDBDataSet
Syntax
Delphi
type
 TfrxCustomDBDataSet = class(TfrxDataSet)
 end;

The TfrxCustomDBDataSet type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomDBDataSet class. (Overrides TfrxDataSet.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxCustomDBDataSet class. (Overrides TfrxDataSet.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
CloseDataSource | Represents property CloseDataSource.
Component | Link to the component itself. (Inherited from TfrxDialogComponent.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DisplayText[String] | Returns the field value as a string. (Inherited from TfrxDataSet.)
DisplayWidth[String] | Returns the size of a specified field. (Inherited from TfrxDataSet.)
Enabled | Defines, if the given component is available from the designer. (Inherited from TfrxDataSet.)
FieldAliases | List of field aliases.
Fields | Represents property Fields.
FieldType[String] | Returns the field type (Inherited from TfrxDataSet.)
Font | Object's font. (Inherited from TfrxComponent.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClose | Represents property OnClose.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnFirst | This event's handler must move the cursor to the beginning of the data set. (Inherited from TfrxDataSet.)
OnNext | This event's handler must move the cursor to the next record. (Inherited from TfrxDataSet.)
OnOpen | Represents property OnOpen.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPrior | This event's handler must move the cursor to the previous record. (Inherited from TfrxDataSet.)
OpenDataSource | Represents property OpenDataSource.
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
RangeBegin | The navigation start point. (Inherited from TfrxDataSet.)
RangeEnd | The endpoint of navigation. (Inherited from TfrxDataSet.)
RangeEndCount | A number of records in the data set, if the "RangeEnd" property = reCount. (Inherited from TfrxDataSet.)
RecNo | A current record number. The first record's number is "0". (Inherited from TfrxDataSet.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
ReportRef | Reference for the report owner if any. (Inherited from TfrxDataSet.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
UserName | A symbolic name, under which the dataset will be displayed in the designer. (Inherited from TfrxDataSet.)
Value[String] | Returns the field value as a variant. (Inherited from TfrxDataSet.)
Visible | Global visibility of the object in the result report. (Inherited from TfrxComponent.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
AssignBlobTo(String,TObject) | Assigns stream in Obj to BLOB field with fName name. (Inherited from TfrxDataSet.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Close | Closes the dataset. (Inherited from TfrxDataSet.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
ConvertAlias(String) | Represents method ConvertAlias(String).
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxDialogComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
Eof | Function returns True if end of the dataset is reached. (Inherited from TfrxDataSet.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FieldsCount | Returns the number of fields defined in the dataset. (Overrides TfrxDataSet.FieldsCount.)
Finalize | Finalizes DataSet after close. (Inherited from TfrxDataSet.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
First | Sets the cursor to the first record. (Inherited from TfrxDataSet.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetAlias(String) | Represents method GetAlias(String).
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDisplayText(String) | Represents method GetDisplayText(String). (Inherited from TfrxDataSet.)
GetDisplayWidth(String) | Represents method GetDisplayWidth(String). (Inherited from TfrxDataSet.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetFieldList(TStrings) | Returns list of dataset fields. (Inherited from TfrxDataSet.)
GetFieldType(String) | Represents method GetFieldType(String). (Inherited from TfrxDataSet.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetValue(String) | Represents method GetValue(String). (Inherited from TfrxDataSet.)
HasField(String) | Returns True if dataset has field with specified name. (Inherited from TfrxDataSet.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
Initialize | Initializes DataSet before open. (Inherited from TfrxDataSet.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsBlobField(String) | Returns True if dataset has BLOB field with specified name. (Inherited from TfrxDataSet.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHasMaster | Returns True if DataSet has master RecordSet. (Inherited from TfrxDataSet.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWideMemoBlobField(String) | Returns True if dataset has wide memo BLOB field with specified name. (Inherited from TfrxDataSet.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Next | Moves the cursor to the next record. (Inherited from TfrxDataSet.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
Open | Opens the dataset. (Inherited from TfrxDataSet.)
Prior | Moves the cursor to the previous record. This method is used only when printing groups. (Inherited from TfrxDataSet.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
RecordCount | Returns records count if DataSet supports it. (Inherited from TfrxDataSet.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFieldAliases(TStrings) | Represents method SetFieldAliases(TStrings).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetUserName(String) | Represents method SetUserName(String). (Inherited from TfrxDataSet.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Events
Show:
Name | Description
OnCheckEOF | This event's handler must return the Eof = True parameter, if the end of the data set is reached. (Inherited from TfrxDataSet.)
Top
Fields
Show:
Name | Description
FAliases | Represents field FAliases.
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFields | Represents field FFields.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FImageIndex | Represents field FImageIndex. (Inherited from TfrxDialogComponent.)
FInitialized | Represents field FInitialized. (Inherited from TfrxDataSet.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FRecNo | Represents field FRecNo. (Inherited from TfrxDataSet.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxClass


TfrxCustomDBDataSet Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomDBDataSet class. (Overrides TfrxDataSet.Create(TComponent).)
Destroy | Represents the destructor of the TfrxCustomDBDataSet class. (Overrides TfrxDataSet.Destroy.)
Top


TfrxCustomDBDataSet.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomDBDataSet class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDataSet.Create(TComponent)
See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomDBDataSet class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxDataSet.Destroy
See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet Properties

Properties
Name | Description
CloseDataSource | Represents property CloseDataSource.
FieldAliases | List of field aliases.
Fields | Represents property Fields.
OnClose | Represents property OnClose.
OnOpen | Represents property OnOpen.
OpenDataSource | Represents property OpenDataSource.
Top


TfrxCustomDBDataSet.CloseDataSource Property

Summary

Represents property CloseDataSource.

Namespace: frxClass
Syntax
Delphi
published
 property CloseDataSource;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet.FieldAliases Property

Summary

List of field aliases.

Namespace: frxClass
Syntax
Delphi
published
 property FieldAliases: TStrings read FAliases write SetFieldAliases;

Property Value

Type: TStrings

Examples

FieldName1=FieldAlias1
FieldName2=FieldAlias2

See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet.Fields Property

Summary

Represents property Fields.

Namespace: frxClass
Syntax
Delphi
protected
 property Fields: TStringList read FFields;

Property Value

Type: TStringList

See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet.OnClose Property

Summary

Represents property OnClose.

Namespace: frxClass
Syntax
Delphi
published
 property OnClose;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet.OnOpen Property

Summary

Represents property OnOpen.

Namespace: frxClass
Syntax
Delphi
published
 property OnOpen;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet.OpenDataSource Property

Summary

Represents property OpenDataSource.

Namespace: frxClass
Syntax
Delphi
published
 property OpenDataSource;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet Methods

Methods
Name | Description
ConvertAlias(String) | Represents method ConvertAlias(String).
FieldsCount | Returns the number of fields defined in the dataset. (Overrides TfrxDataSet.FieldsCount.)
GetAlias(String) | Represents method GetAlias(String).
SetFieldAliases(TStrings) | Represents method SetFieldAliases(TStrings).
Top


TfrxCustomDBDataSet.ConvertAlias(String) Method

Summary

Represents method ConvertAlias(String).

Namespace: frxClass
Syntax
Delphi
public
 function ConvertAlias(const fName: String): String;

Parameters

fName
Type: String

Return Value

Type: String

See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet.FieldsCount Method

Summary

Returns the number of fields defined in the dataset.

Namespace: frxClass
Syntax
Delphi
public
 function FieldsCount: Integer; override;

Return Value

Type: Integer

Overrides

TfrxDataSet.FieldsCount
See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet.GetAlias(String) Method

Summary

Represents method GetAlias(String).

Namespace: frxClass
Syntax
Delphi
public
 function GetAlias(const fName: String): String;

Parameters

fName
Type: String

Return Value

Type: String

See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet.SetFieldAliases(TStrings) Method

Summary

Represents method SetFieldAliases(TStrings).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFieldAliases(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet Fields

Fields
Name | Description
FAliases | Represents field FAliases.
FFields | Represents field FFields.
Top


TfrxCustomDBDataSet.FAliases Field

Summary

Represents field FAliases.

Namespace: frxClass
Syntax
Delphi
private
 FAliases: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDBDataSet.FFields Field

Summary

Represents field FFields.

Namespace: frxClass
Syntax
Delphi
private
 FFields: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxCustomDBDataSet
  • frxClass


TfrxCustomDesigner Class

Summary

The TfrxCustomDesigner class is the base class for the report designer.

Namespace: frxClass
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxClass.TfrxCustomDesigner
frxDesgn.TfrxDesignerForm
Syntax
Delphi
type
 TfrxCustomDesigner = class(TfrxBaseForm)
 end;

The TfrxCustomDesigner type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseForm class. (Inherited from TfrxBaseForm.)
CreateDesigner(TComponent,TfrxReport,Boolean) | The Report designer constructor.
Destroy | Represents the destructor of the TfrxCustomDesigner class.
Top
Properties
Show:
Name | Description
Code | The script of the report.
CurrentFormPPI | Returns current PPI value of the form. (Inherited from TfrxBaseForm.)
IsPPIChanging | Represents property IsPPIChanging. (Inherited from TfrxBaseForm.)
IsPreviewDesigner | Returns True if the designer was launched from the preview window.
MemoFontName | Default name of the font for memo text editor.
MemoFontSize | Default size of the font for memo text editor.
Modified | Determines whether the report was modified.
Objects | List of objects on the current report page, including the page itself.
Page | Reference to currently edited report page. May be nil if current page is "code editor".
ParentForm | Parent form for the report designer form.
Report | Reference to a report.
SelectedObjects | List of currently selected object.
UseObjectFont | If True , Memo editor will use font for editor from the report object settings.
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseForm.)
AfterPPIChange | Represents method AfterPPIChange. (Inherited from TfrxBaseForm.)
AfterPPIMessage | Represents method AfterPPIMessage. (Inherited from TfrxBaseForm.)
BeforeDestruction | Represents method BeforeDestruction. (Inherited from TfrxBaseForm.)
BeforePPIChange | Represents method BeforePPIChange. (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer). (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean). (Inherited from TfrxBaseForm.)
CheckOp(TfrxDesignerRestriction) | Used to check restriction of the report designer. Returns True when restriction flag is set in the report designer.
DisableInspectorUpdate | Locks object inspector updating.
DoClose(TCloseAction) | Represents method DoClose(TCloseAction). (Inherited from TfrxBaseForm.)
DoShow | Represents method DoShow. (Inherited from TfrxBaseForm.)
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer). (Inherited from TfrxBaseForm.)
EnableInspectorUpdate | Releases object inspector lock.
FormShowAfterLoad | Represents method FormShowAfterLoad. (Inherited from TfrxBaseForm.)
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Inherited from TfrxBaseForm.)
GetAvailablePreferences | Represents method GetAvailablePreferences. (Inherited from TfrxBaseForm.)
GetCode | Represents method GetCode.
GetDataSelectedAsExp | Returns a dataset expression from DataTree selection.
GetDefaultPreferences | Represents method GetDefaultPreferences.
GetFormSectionName | Represents method GetFormSectionName. (Inherited from TfrxBaseForm.)
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Overrides TfrxBaseForm.GetPreferencesStorage(Boolean).)
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Inherited from TfrxBaseForm.)
InsertExpression(String) | Method shows an "Insert expression" dialogue. It should return an expression string or an empty string if dialogue was canceled.
InternalCopy | This method processes clipboard copy behaviour.
InternalIsPasteAvailable | The methods checks if clipboard contains data available to paste in selected object. It serves copy/paste methods of InPlace editors.
InternalPaste | This method processes clipboard paste behaviour.
IsChangedExpression(String,String) | Method shows an "Insert expression" dialogue. It should return an expression string in out OutExpr parameter. Method returns True when expression was changed.
IsDataTree(TObject) | Checks if passed object is designer DataTree window. Used for drag and drop behaviour.
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
Lock | Locks any drawings in the designer window. Use this method when making any changes in the currently edited report.
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter. (Inherited from TfrxBaseForm.)
ReloadObjects(Boolean) | Reloads all report objects in the report designer.
ReloadPages(Integer) | Reloads all report's pages. Use this method if you add or delete a report page. The Index parameter defines which page should be made active.
ReloadReport | Reloads all report contents.
ReportDataEdit | Calls DataSets selection dialog.
ReportEditVariable | Calls report variables editor dialog.
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Inherited from TfrxBaseForm.)
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxBaseForm.)
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms. (Inherited from TfrxBaseForm.)
SetModified(Boolean) | Represents method SetModified(Boolean).
SetPage(TfrxPage) | Represents method SetPage(TfrxPage).
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form. (Inherited from TfrxBaseForm.)
UpdateDataTree | Updates the "Data Tree" tool window.
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Inherited from TfrxBaseForm.)
UpdateInspector | Updates object inspector.
UpdatePage | Updates the report designer workspace.
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Inherited from TfrxBaseForm.)
Top
Fields
Show:
Name | Description
FHostedControls | Represents field FHostedControls. (Inherited from TfrxBaseForm.)
FInspectorLock | Represents field FInspectorLock.
FIsPreviewDesigner | Represents field FIsPreviewDesigner.
FMemoFontName | Represents field FMemoFontName.
FMemoFontSize | Represents field FMemoFontSize.
FModified | Represents field FModified.
FObjects | Represents field FObjects.
FPage | Represents field FPage.
FParentForm | Represents field FParentForm.
FPrefEvent | Represents field FPrefEvent. (Inherited from TfrxBaseForm.)
FReport | Represents field FReport.
FSelectedObjects | Represents field FSelectedObjects.
FUseObjectFont | Represents field FUseObjectFont.
Top
See Also

Reference

  • frxClass


TfrxCustomDesigner Constructors

Constructors
Name | Description
CreateDesigner(TComponent,TfrxReport,Boolean) | The Report designer constructor.
Destroy | Represents the destructor of the TfrxCustomDesigner class.
Top


TfrxCustomDesigner.CreateDesigner(TComponent,TfrxReport,Boolean) Constructor

Summary

The Report designer constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor CreateDesigner(AOwner: TComponent; AReport: TfrxReport;
 APreviewDesigner: Boolean = False);

Parameters

AOwner
Type: TComponent

AReport
Type: TfrxReport

APreviewDesigner
Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomDesigner class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner Properties

Properties
Name | Description
Code | The script of the report.
IsPreviewDesigner | Returns True if the designer was launched from the preview window.
MemoFontName | Default name of the font for memo text editor.
MemoFontSize | Default size of the font for memo text editor.
Modified | Determines whether the report was modified.
Objects | List of objects on the current report page, including the page itself.
Page | Reference to currently edited report page. May be nil if current page is "code editor".
ParentForm | Parent form for the report designer form.
Report | Reference to a report.
SelectedObjects | List of currently selected object.
UseObjectFont | If True , Memo editor will use font for editor from the report object settings.
Top


TfrxCustomDesigner.Code Property

Summary

The script of the report.

Namespace: frxClass
Syntax
Delphi
public
 property Code: TStrings read GetCode;

Property Value

Type: TStrings

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.IsPreviewDesigner Property

Summary

Returns True if the designer was launched from the preview window.

Namespace: frxClass
Syntax
Delphi
public
 property IsPreviewDesigner: Boolean read FIsPreviewDesigner;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.MemoFontName Property

Summary

Default name of the font for memo text editor.

Namespace: frxClass
Syntax
Delphi
public
 property MemoFontName: String read FMemoFontName write FMemoFontName;

Property Value

Type: String

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.MemoFontSize Property

Summary

Default size of the font for memo text editor.

Namespace: frxClass
Syntax
Delphi
public
 property MemoFontSize: Integer read FMemoFontSize write FMemoFontSize;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.Modified Property

Summary

Determines whether the report was modified.

Namespace: frxClass
Syntax
Delphi
public
 property Modified: Boolean read FModified write SetModified;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.Objects Property

Summary

List of objects on the current report page, including the page itself.

Namespace: frxClass
Syntax
Delphi
public
 property Objects: TList read FObjects;

Property Value

Type: TList

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.Page Property

Summary

Reference to currently edited report page. May be nil if current page is "code editor".

Namespace: frxClass
Syntax
Delphi
public
 property Page: TfrxPage read FPage write SetPage;

Property Value

Type: TfrxPage

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.ParentForm Property

Summary

Parent form for the report designer form.

Namespace: frxClass
Syntax
Delphi
public
 property ParentForm: TForm read FParentForm write FParentForm;

Property Value

Type: TForm

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.Report Property

Summary

Reference to a report.

Namespace: frxClass
Syntax
Delphi
public
 property Report: TfrxReport read FReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.SelectedObjects Property

Summary

List of currently selected object.

Namespace: frxClass
Syntax
Delphi
public
 property SelectedObjects: TfrxSelectedObjectsList read FSelectedObjects;

Property Value

Type: TfrxSelectedObjectsList

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.UseObjectFont Property

Summary

If True , Memo editor will use font for editor from the report object settings.

Namespace: frxClass
Syntax
Delphi
public
 property UseObjectFont: Boolean read FUseObjectFont write FUseObjectFont;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner Methods

Methods
Name | Description
CheckOp(TfrxDesignerRestriction) | Used to check restriction of the report designer. Returns True when restriction flag is set in the report designer.
DisableInspectorUpdate | Locks object inspector updating.
EnableInspectorUpdate | Releases object inspector lock.
GetCode | Represents method GetCode.
GetDataSelectedAsExp | Returns a dataset expression from DataTree selection.
GetDefaultPreferences | Represents method GetDefaultPreferences.
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Overrides TfrxBaseForm.GetPreferencesStorage(Boolean).)
InsertExpression(String) | Method shows an "Insert expression" dialogue. It should return an expression string or an empty string if dialogue was canceled.
InternalCopy | This method processes clipboard copy behaviour.
InternalIsPasteAvailable | The methods checks if clipboard contains data available to paste in selected object. It serves copy/paste methods of InPlace editors.
InternalPaste | This method processes clipboard paste behaviour.
IsChangedExpression(String,String) | Method shows an "Insert expression" dialogue. It should return an expression string in out OutExpr parameter. Method returns True when expression was changed.
IsDataTree(TObject) | Checks if passed object is designer DataTree window. Used for drag and drop behaviour.
Lock | Locks any drawings in the designer window. Use this method when making any changes in the currently edited report.
ReloadObjects(Boolean) | Reloads all report objects in the report designer.
ReloadPages(Integer) | Reloads all report's pages. Use this method if you add or delete a report page. The Index parameter defines which page should be made active.
ReloadReport | Reloads all report contents.
ReportDataEdit | Calls DataSets selection dialog.
ReportEditVariable | Calls report variables editor dialog.
SetModified(Boolean) | Represents method SetModified(Boolean).
SetPage(TfrxPage) | Represents method SetPage(TfrxPage).
UpdateDataTree | Updates the "Data Tree" tool window.
UpdateInspector | Updates object inspector.
UpdatePage | Updates the report designer workspace.
Top


TfrxCustomDesigner.CheckOp(TfrxDesignerRestriction) Method

Summary

Used to check restriction of the report designer. Returns True when restriction flag is set in the report designer.

Namespace: frxClass
Syntax
Delphi
public
 function CheckOp(Op: TfrxDesignerRestriction): Boolean; virtual;

Parameters

Op
Type: TfrxDesignerRestriction

Restriction flag.

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.DisableInspectorUpdate Method

Summary

Locks object inspector updating.

Namespace: frxClass
Syntax
Delphi
public
 procedure DisableInspectorUpdate; virtual; abstract;
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.EnableInspectorUpdate Method

Summary

Releases object inspector lock.

Namespace: frxClass
Syntax
Delphi
public
 procedure EnableInspectorUpdate; virtual; abstract;
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.GetCode Method

Summary

Represents method GetCode.

Namespace: frxClass
Syntax
Delphi
protected
 function GetCode: TStrings; virtual; abstract;

Return Value

Type: TStrings

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.GetDataSelectedAsExp Method

Summary

Returns a dataset expression from DataTree selection.

Namespace: frxClass
Syntax
Delphi
public
 function GetDataSelectedAsExp: String; virtual; abstract;

Return Value

Type: String

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.GetDefaultPreferences Method

Summary

Represents method GetDefaultPreferences.

Namespace: frxClass
Syntax
Delphi
protected
 function GetDefaultPreferences: TObject; virtual;

Return Value

Type: TObject

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.GetPreferencesStorage(Boolean) Method

Summary

This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object.

Namespace: frxClass
Syntax
Delphi
public
 function GetPreferencesStorage(aDefault: Boolean): TObject; override;

Parameters

aDefault
Type: Boolean

Return Value

Type: TObject

Overrides

TfrxBaseForm.GetPreferencesStorage(Boolean)
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.InsertExpression(String) Method

Summary

Method shows an "Insert expression" dialogue. It should return an expression string or an empty string if dialogue was canceled.

Namespace: frxClass
Syntax
Delphi
public
 function InsertExpression(const Expr: String): String; virtual; abstract;

Parameters

Expr
Type: String

Return Value

Type: String

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.InternalCopy Method

Summary

This method processes clipboard copy behaviour.

Namespace: frxClass
Syntax
Delphi
public
 procedure InternalCopy; virtual; abstract;
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.InternalIsPasteAvailable Method

Summary

The methods checks if clipboard contains data available to paste in selected object. It serves copy/paste methods of InPlace editors.

Namespace: frxClass
Syntax
Delphi
public
 function InternalIsPasteAvailable: Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.InternalPaste Method

Summary

This method processes clipboard paste behaviour.

Namespace: frxClass
Syntax
Delphi
public
 procedure InternalPaste; virtual; abstract;
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.IsChangedExpression(String,String) Method

Summary

Method shows an "Insert expression" dialogue. It should return an expression string in out OutExpr parameter. Method returns True when expression was changed.

Namespace: frxClass
Syntax
Delphi
public
 function IsChangedExpression(const InExpr: String; out OutExpr: String): Boolean; virtual; abstract;

Parameters

InExpr
Type: String

OutExpr
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.IsDataTree(TObject) Method

Summary

Checks if passed object is designer DataTree window. Used for drag and drop behaviour.

Namespace: frxClass
Syntax
Delphi
public
 function IsDataTree(aObject: TObject): Boolean; virtual; abstract;

Parameters

aObject
Type: TObject

Reference to an object.

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.Lock Method

Summary

Locks any drawings in the designer window. Use this method when making any changes in the currently edited report.

Namespace: frxClass
Syntax
Delphi
public
 procedure Lock; virtual; abstract;
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.ReloadObjects(Boolean) Method

Summary

Reloads all report objects in the report designer.

Namespace: frxClass
Syntax
Delphi
public
 procedure ReloadObjects(ResetSelection: Boolean = True); virtual; abstract;

Parameters

ResetSelection
Type: Boolean

Reset objects selection in the report designer.

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.ReloadPages(Integer) Method

Summary

Reloads all report's pages. Use this method if you add or delete a report page. The Index parameter defines which page should be made active.

Namespace: frxClass
Syntax
Delphi
public
 procedure ReloadPages(Index: Integer); virtual; abstract;

Parameters

Index
Type: Integer

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.ReloadReport Method

Summary

Reloads all report contents.

Namespace: frxClass
Syntax
Delphi
public
 procedure ReloadReport; virtual; abstract;
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.ReportDataEdit Method

Summary

Calls DataSets selection dialog.

Namespace: frxClass
Syntax
Delphi
public
 procedure ReportDataEdit; virtual; abstract;
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.ReportEditVariable Method

Summary

Calls report variables editor dialog.

Namespace: frxClass
Syntax
Delphi
public
 procedure ReportEditVariable; virtual; abstract;
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.SetModified(Boolean) Method

Summary

Represents method SetModified(Boolean).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetModified(const Value: Boolean); virtual;

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.SetPage(TfrxPage) Method

Summary

Represents method SetPage(TfrxPage).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetPage(const Value: TfrxPage); virtual;

Parameters

Value
Type: TfrxPage

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.UpdateDataTree Method

Summary

Updates the "Data Tree" tool window.

Namespace: frxClass
Syntax
Delphi
public
 procedure UpdateDataTree; virtual; abstract;
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.UpdateInspector Method

Summary

Updates object inspector.

Namespace: frxClass
Syntax
Delphi
public
 procedure UpdateInspector; virtual; abstract;
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.UpdatePage Method

Summary

Updates the report designer workspace.

Namespace: frxClass
Syntax
Delphi
public
 procedure UpdatePage; virtual; abstract;
See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner Fields

Fields
Name | Description
FInspectorLock | Represents field FInspectorLock.
FIsPreviewDesigner | Represents field FIsPreviewDesigner.
FMemoFontName | Represents field FMemoFontName.
FMemoFontSize | Represents field FMemoFontSize.
FModified | Represents field FModified.
FObjects | Represents field FObjects.
FPage | Represents field FPage.
FParentForm | Represents field FParentForm.
FReport | Represents field FReport.
FSelectedObjects | Represents field FSelectedObjects.
FUseObjectFont | Represents field FUseObjectFont.
Top


TfrxCustomDesigner.FInspectorLock Field

Summary

Represents field FInspectorLock.

Namespace: frxClass
Syntax
Delphi
protected
 FInspectorLock: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.FIsPreviewDesigner Field

Summary

Represents field FIsPreviewDesigner.

Namespace: frxClass
Syntax
Delphi
private
 FIsPreviewDesigner: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.FMemoFontName Field

Summary

Represents field FMemoFontName.

Namespace: frxClass
Syntax
Delphi
private
 FMemoFontName: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.FMemoFontSize Field

Summary

Represents field FMemoFontSize.

Namespace: frxClass
Syntax
Delphi
private
 FMemoFontSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.FModified Field

Summary

Represents field FModified.

Namespace: frxClass
Syntax
Delphi
protected
 FModified: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.FObjects Field

Summary

Represents field FObjects.

Namespace: frxClass
Syntax
Delphi
protected
 FObjects: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.FPage Field

Summary

Represents field FPage.

Namespace: frxClass
Syntax
Delphi
protected
 FPage: TfrxPage;

Field Value

Type: TfrxPage

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.FParentForm Field

Summary

Represents field FParentForm.

Namespace: frxClass
Syntax
Delphi
private
 FParentForm: TForm;

Field Value

Type: TForm

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.FSelectedObjects Field

Summary

Represents field FSelectedObjects.

Namespace: frxClass
Syntax
Delphi
protected
 FSelectedObjects: TfrxSelectedObjectsList;

Field Value

Type: TfrxSelectedObjectsList

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomDesigner.FUseObjectFont Field

Summary

Represents field FUseObjectFont.

Namespace: frxClass
Syntax
Delphi
private
 FUseObjectFont: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomDesigner
  • frxClass


TfrxCustomEngine Class

Summary

The TfrxCustomEngine class is the base class for report engine. Instance of this class is stored in the TfrxReport.Engine property.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxCustomEngine
frxEngine.TfrxEngine
Syntax
Delphi
type
 TfrxCustomEngine = class(TPersistent)
 end;

The TfrxCustomEngine type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport) | Initializes a new instance of the TfrxCustomEngine class.
Destroy | Represents the destructor of the TfrxCustomEngine class.
Top
Properties
Show:
Name | Description
CurColumn | The number of the current column in a multi-columned report. A value can be assigned to this property.
CurLine | Current line number.
CurLineThrough | Current absolute line number (<Line#>).
CurTableColumn | Current column of the table.
CurTableRow | Current row of the table.
CurVColumn | The number of the current column in a cross-tab report.
CurX | The current shift of the coordinates on the X-axis. A value can be assigned to this property.
CurY | The current shift of the coordinates on the Y-axis. A value can be assigned to this property.
DoublePass | Equal to "True," if the report is a two-pass one. Analogous to Report.EngineOptions.DoublePass.
FinalPass | Equal to "True," if the last pass of the two-pass report is performed.
NotifyList | List with objects that receives a notifications from report engine.
PageHeight | Printable region's height, in pixels.
PageWidth | Printable region's width, in pixels.
PreviewPages | Reference to prepared report pages.
Report | Reference to a report component.
Running | True when dialog pages are running.
SecondScriptCall | Flag for the determination of repeat call of event (in some cases the event can be called repeatedly during grouping), if True then the script has already been operated.
StartDate | Time of report running. A counterpart of the <Date> system variable.
StartTime | Time of report running. A counterpart of the <Time> system variable.
TotalPages | A number of output pages in a report. A counterpart of the <TotalPages> system variable. The report should be a two-pass one, so that this variable can be used.
Top
Methods
Show:
Name | Description
BreakAllKeep | Breaks any keep operation currently active.
EndPage | Called when page printing is finished.
FooterHeight | Returns height of the footers.
FreeSpace | Returns height value of white space left on a page, in pixels.
GetAggregateValue(String,String,TfrxBand,Integer) | Returns value of aggregate function for an expression.
GetDoublePass | Represents method GetDoublePass.
GetPageHeight | Represents method GetPageHeight.
HeaderHeight(Boolean) | Represents method HeaderHeight(Boolean).
NewColumn | Creates a new column in a multicolumn report. After the last column, page break is automatically inserted.
NewPage | Creates a new page (page break).
PrepareShiftTree(TfrxReportComponent) | Builds a shift tree of child objects for current container.
ProcessObject(TfrxView) | Processed GetData for passed object. Used with paCustom flag.
Run(Boolean,Boolean,TfrxPage) | This method runs the report engine.
SetPreviewPages(TfrxCustomPreviewPages) | Represents method SetPreviewPages(TfrxCustomPreviewPages).
ShowBand(TfrxBand) | Overloaded. Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted.
ShowBand(TfrxBandClass) | Overloaded. Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted.
ShowBandByName(String) | Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted.
StopReport | Stops report preparation.
Stretch(TfrxReportComponent) | Performs stretch operation on passed container object.
UnStretch(TfrxReportComponent) | Returns back state of the container after stretch operation.
Top
Events
Show:
Name | Description
OnRunDialog | Occurs when report dialog page is previewed.
Top
Fields
Show:
Name | Description
FCurColumn | Represents field FCurColumn.
FCurLine | Represents field FCurLine.
FCurLineThrough | Represents field FCurLineThrough.
FCurTableColumn | Represents field FCurTableColumn.
FCurTableRow | Represents field FCurTableRow.
FCurVColumn | Represents field FCurVColumn.
FCurX | Represents field FCurX.
FCurY | Represents field FCurY.
FFinalPass | Represents field FFinalPass.
FNotifyList | Represents field FNotifyList.
FOnRunDialog | Represents field FOnRunDialog.
FPageHeight | Represents field FPageHeight.
FPageWidth | Represents field FPageWidth.
FPreviewPages | Represents field FPreviewPages.
FReport | Represents field FReport.
FRunning | Represents field FRunning.
FSecondScriptCall | Represents field FSecondScriptCall.
FStartDate | Represents field FStartDate.
FStartTime | Represents field FStartTime.
FTotalPages | Represents field FTotalPages.
Top
See Also

Reference

  • frxClass


TfrxCustomEngine Constructors

Constructors
Name | Description
Create(TfrxReport) | Initializes a new instance of the TfrxCustomEngine class.
Destroy | Represents the destructor of the TfrxCustomEngine class.
Top


TfrxCustomEngine.Create(TfrxReport) Constructor

Summary

Initializes a new instance of the TfrxCustomEngine class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AReport: TfrxReport); virtual;

Parameters

AReport
Type: TfrxReport

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomEngine class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine Properties

Properties
Name | Description
CurColumn | The number of the current column in a multi-columned report. A value can be assigned to this property.
CurLine | Current line number.
CurLineThrough | Current absolute line number (<Line#>).
CurTableColumn | Current column of the table.
CurTableRow | Current row of the table.
CurVColumn | The number of the current column in a cross-tab report.
CurX | The current shift of the coordinates on the X-axis. A value can be assigned to this property.
CurY | The current shift of the coordinates on the Y-axis. A value can be assigned to this property.
DoublePass | Equal to "True," if the report is a two-pass one. Analogous to Report.EngineOptions.DoublePass.
FinalPass | Equal to "True," if the last pass of the two-pass report is performed.
NotifyList | List with objects that receives a notifications from report engine.
PageHeight | Printable region's height, in pixels.
PageWidth | Printable region's width, in pixels.
PreviewPages | Reference to prepared report pages.
Report | Reference to a report component.
Running | True when dialog pages are running.
SecondScriptCall | Flag for the determination of repeat call of event (in some cases the event can be called repeatedly during grouping), if True then the script has already been operated.
StartDate | Time of report running. A counterpart of the <Date> system variable.
StartTime | Time of report running. A counterpart of the <Time> system variable.
TotalPages | A number of output pages in a report. A counterpart of the <TotalPages> system variable. The report should be a two-pass one, so that this variable can be used.
Top


TfrxCustomEngine.CurColumn Property

Summary

The number of the current column in a multi-columned report. A value can be assigned to this property.

Namespace: frxClass
Syntax
Delphi
published
 property CurColumn: Integer read FCurColumn write FCurColumn;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.CurLine Property

Summary

Current line number.

Namespace: frxClass
Syntax
Delphi
public
 property CurLine: Integer read FCurLine write FCurLine;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.CurLineThrough Property

Summary

Current absolute line number (<Line#>).

Namespace: frxClass
Syntax
Delphi
public
 property CurLineThrough: Integer read FCurLineThrough write FCurLineThrough;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.CurTableColumn Property

Summary

Current column of the table.

Namespace: frxClass
Syntax
Delphi
public
 property CurTableColumn: Integer read FCurTableColumn write FCurTableColumn;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.CurTableRow Property

Summary

Current row of the table.

Namespace: frxClass
Syntax
Delphi
public
 property CurTableRow: Integer read FCurTableRow write FCurTableRow;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.CurVColumn Property

Summary

The number of the current column in a cross-tab report.

Namespace: frxClass
Syntax
Delphi
published
 property CurVColumn: Integer read FCurVColumn write FCurVColumn;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.CurX Property

Summary

The current shift of the coordinates on the X-axis. A value can be assigned to this property.

Namespace: frxClass
Syntax
Delphi
published
 property CurX: Extended read FCurX write FCurX;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.CurY Property

Summary

The current shift of the coordinates on the Y-axis. A value can be assigned to this property.

Namespace: frxClass
Syntax
Delphi
published
 property CurY: Extended read FCurY write FCurY;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.DoublePass Property

Summary

Equal to "True," if the report is a two-pass one. Analogous to Report.EngineOptions.DoublePass.

Namespace: frxClass
Syntax
Delphi
published
 property DoublePass: Boolean read GetDoublePass;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FinalPass Property

Summary

Equal to "True," if the last pass of the two-pass report is performed.

Namespace: frxClass
Syntax
Delphi
published
 property FinalPass: Boolean read FFinalPass write FFinalPass;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.NotifyList Property

Summary

List with objects that receives a notifications from report engine.

Namespace: frxClass
Syntax
Delphi
public
 property NotifyList: TList read FNotifyList;

Property Value

Type: TList

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.PageHeight Property

Summary

Printable region's height, in pixels.

Namespace: frxClass
Syntax
Delphi
published
 property PageHeight: Extended read GetPageHeight write FPageHeight;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.PageWidth Property

Summary

Printable region's width, in pixels.

Namespace: frxClass
Syntax
Delphi
published
 property PageWidth: Extended read FPageWidth write FPageWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.PreviewPages Property

Summary

Reference to prepared report pages.

Namespace: frxClass
Syntax
Delphi
public
 property PreviewPages: TfrxCustomPreviewPages read FPreviewPages write SetPreviewPages;

Property Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.Report Property

Summary

Reference to a report component.

Namespace: frxClass
Syntax
Delphi
public
 property Report: TfrxReport read FReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.Running Property

Summary

True when dialog pages are running.

Namespace: frxClass
Syntax
Delphi
public
 property Running: Boolean read FRunning write FRunning;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.SecondScriptCall Property

Summary

Flag for the determination of repeat call of event (in some cases the event can be called repeatedly during grouping), if True then the script has already been operated.

Namespace: frxClass
Syntax
Delphi
published
 property SecondScriptCall: Boolean read FSecondScriptCall write FSecondScriptCall;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.StartDate Property

Summary

Time of report running. A counterpart of the <Date> system variable.

Namespace: frxClass
Syntax
Delphi
published
 property StartDate: TDateTime read FStartDate write FStartDate;

Property Value

Type: TDateTime

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.StartTime Property

Summary

Time of report running. A counterpart of the <Time> system variable.

Namespace: frxClass
Syntax
Delphi
published
 property StartTime: TDateTime read FStartTime write FStartTime;

Property Value

Type: TDateTime

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.TotalPages Property

Summary

A number of output pages in a report. A counterpart of the <TotalPages> system variable. The report should be a two-pass one, so that this variable can be used.

Namespace: frxClass
Syntax
Delphi
published
 property TotalPages: Integer read FTotalPages write FTotalPages;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine Methods

Methods
Name | Description
BreakAllKeep | Breaks any keep operation currently active.
EndPage | Called when page printing is finished.
FooterHeight | Returns height of the footers.
FreeSpace | Returns height value of white space left on a page, in pixels.
GetAggregateValue(String,String,TfrxBand,Integer) | Returns value of aggregate function for an expression.
GetDoublePass | Represents method GetDoublePass.
GetPageHeight | Represents method GetPageHeight.
HeaderHeight(Boolean) | Represents method HeaderHeight(Boolean).
NewColumn | Creates a new column in a multicolumn report. After the last column, page break is automatically inserted.
NewPage | Creates a new page (page break).
PrepareShiftTree(TfrxReportComponent) | Builds a shift tree of child objects for current container.
ProcessObject(TfrxView) | Processed GetData for passed object. Used with paCustom flag.
Run(Boolean,Boolean,TfrxPage) | This method runs the report engine.
SetPreviewPages(TfrxCustomPreviewPages) | Represents method SetPreviewPages(TfrxCustomPreviewPages).
ShowBand(TfrxBand) | Overloaded. Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted.
ShowBand(TfrxBandClass) | Overloaded. Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted.
ShowBandByName(String) | Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted.
StopReport | Stops report preparation.
Stretch(TfrxReportComponent) | Performs stretch operation on passed container object.
UnStretch(TfrxReportComponent) | Returns back state of the container after stretch operation.
Top


TfrxCustomEngine.BreakAllKeep Method

Summary

Breaks any keep operation currently active.

Namespace: frxClass
Syntax
Delphi
public
 procedure BreakAllKeep; virtual;
See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.EndPage Method

Summary

Called when page printing is finished.

Namespace: frxClass
Syntax
Delphi
public
 procedure EndPage; virtual; abstract;
See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FooterHeight Method

Summary

Returns height of the footers.

Namespace: frxClass
Syntax
Delphi
public
 function FooterHeight: Extended; virtual; abstract;

Return Value

Type: Extended

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FreeSpace Method

Summary

Returns height value of white space left on a page, in pixels.

Namespace: frxClass
Syntax
Delphi
public
 function FreeSpace: Extended; virtual; abstract;

Return Value

Type: Extended

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.GetAggregateValue(String,String,TfrxBand,Integer) Method

Summary

Returns value of aggregate function for an expression.

Namespace: frxClass
Syntax
Delphi
public
 function GetAggregateValue(const Name, Expression: String;
 Band: TfrxBand; Flags: Integer): Variant; virtual; abstract;

Parameters

Name
Type: String

Method name (aggregate name).

Expression
Type: String

Expression.

Band
Type: TfrxBand

Band reference.

Flags
Type: Integer

Flag.

Return Value

Type: Variant

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.GetDoublePass Method

Summary

Represents method GetDoublePass.

Namespace: frxClass
Syntax
Delphi
private
 function GetDoublePass: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.GetPageHeight Method

Summary

Represents method GetPageHeight.

Namespace: frxClass
Syntax
Delphi
protected
 function GetPageHeight: Extended; virtual;

Return Value

Type: Extended

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.HeaderHeight(Boolean) Method

Summary

Represents method HeaderHeight(Boolean).

Namespace: frxClass
Syntax
Delphi
public
 function HeaderHeight(AddReprintOnNewPage: Boolean = False): Extended; virtual; abstract;

Parameters

AddReprintOnNewPage
Type: Boolean

Return Value

Type: Extended

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.NewColumn Method

Summary

Creates a new column in a multicolumn report. After the last column, page break is automatically inserted.

Namespace: frxClass
Syntax
Delphi
public
 procedure NewColumn; virtual; abstract;
See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.NewPage Method

Summary

Creates a new page (page break).

Namespace: frxClass
Syntax
Delphi
public
 procedure NewPage; virtual; abstract;
See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.PrepareShiftTree(TfrxReportComponent) Method

Summary

Builds a shift tree of child objects for current container.

Namespace: frxClass
Syntax
Delphi
public
 procedure PrepareShiftTree(Container: TfrxReportComponent); virtual; abstract;

Parameters

Container
Type: TfrxReportComponent

Objects container.

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.ProcessObject(TfrxView) Method

Summary

Processed GetData for passed object. Used with paCustom flag.

Namespace: frxClass
Syntax
Delphi
public
 procedure ProcessObject(ReportObject: TfrxView); virtual; abstract;

Parameters

ReportObject
Type: TfrxView

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.Run(Boolean,Boolean,TfrxPage) Method

Summary

This method runs the report engine.

Namespace: frxClass
Syntax
Delphi
public
 function Run(ARunDialogs: Boolean;
 AClearLast: Boolean = False; APage: TfrxPage = nil): Boolean; virtual; abstract;

Parameters

ARunDialogs
Type: Boolean

If True, Processes report dialog pages.

AClearLast
Type: Boolean

Clears last result from prepared pages.

APage
Type: TfrxPage

Reference to a page(if nil, prepares all).

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.SetPreviewPages(TfrxCustomPreviewPages) Method

Summary

Represents method SetPreviewPages(TfrxCustomPreviewPages).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetPreviewPages(const Value: TfrxCustomPreviewPages);

Parameters

Value
Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.ShowBand(TfrxBand) Method

Summary

Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted.

Namespace: frxClass
Syntax
Delphi
public
 function ShowBand(Band: TfrxBand): TfrxBand; overload; virtual; abstract;

Parameters

Band
Type: TfrxBand

Return Value

Type: TfrxBand

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.ShowBand(TfrxBandClass) Method

Summary

Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted.

Namespace: frxClass
Syntax
Delphi
public
 procedure ShowBand(Band: TfrxBandClass); overload; virtual; abstract;

Parameters

Band
Type: TfrxBandClass

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.ShowBandByName(String) Method

Summary

Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted.

Namespace: frxClass
Syntax
Delphi
public
 procedure ShowBandByName(const BandName: String);

Parameters

BandName
Type: String

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.StopReport Method

Summary

Stops report preparation.

Namespace: frxClass
Syntax
Delphi
public
 procedure StopReport;
See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.Stretch(TfrxReportComponent) Method

Summary

Performs stretch operation on passed container object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Stretch(Band: TfrxReportComponent); virtual; abstract;

Parameters

Band
Type: TfrxReportComponent

Container object.

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.UnStretch(TfrxReportComponent) Method

Summary

Returns back state of the container after stretch operation.

Namespace: frxClass
Syntax
Delphi
public
 procedure UnStretch(Band: TfrxReportComponent); virtual; abstract;

Parameters

Band
Type: TfrxReportComponent

Container object.

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine Events

Events
Name | Description
OnRunDialog | Occurs when report dialog page is previewed.
Top


TfrxCustomEngine.OnRunDialog Event

Summary

Occurs when report dialog page is previewed.

Namespace: frxClass
Syntax
Delphi
public
 property OnRunDialog: TfrxRunDialogEvent read FOnRunDialog write FOnRunDialog;

Value

Type: TfrxRunDialogEvent

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine Fields

Fields
Name | Description
FCurColumn | Represents field FCurColumn.
FCurLine | Represents field FCurLine.
FCurLineThrough | Represents field FCurLineThrough.
FCurTableColumn | Represents field FCurTableColumn.
FCurTableRow | Represents field FCurTableRow.
FCurVColumn | Represents field FCurVColumn.
FCurX | Represents field FCurX.
FCurY | Represents field FCurY.
FFinalPass | Represents field FFinalPass.
FNotifyList | Represents field FNotifyList.
FOnRunDialog | Represents field FOnRunDialog.
FPageHeight | Represents field FPageHeight.
FPageWidth | Represents field FPageWidth.
FPreviewPages | Represents field FPreviewPages.
FReport | Represents field FReport.
FRunning | Represents field FRunning.
FSecondScriptCall | Represents field FSecondScriptCall.
FStartDate | Represents field FStartDate.
FStartTime | Represents field FStartTime.
FTotalPages | Represents field FTotalPages.
Top


TfrxCustomEngine.FCurColumn Field

Summary

Represents field FCurColumn.

Namespace: frxClass
Syntax
Delphi
private
 FCurColumn: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FCurLine Field

Summary

Represents field FCurLine.

Namespace: frxClass
Syntax
Delphi
private
 FCurLine: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FCurLineThrough Field

Summary

Represents field FCurLineThrough.

Namespace: frxClass
Syntax
Delphi
private
 FCurLineThrough: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FCurTableColumn Field

Summary

Represents field FCurTableColumn.

Namespace: frxClass
Syntax
Delphi
private
 FCurTableColumn: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FCurTableRow Field

Summary

Represents field FCurTableRow.

Namespace: frxClass
Syntax
Delphi
private
 FCurTableRow: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FCurVColumn Field

Summary

Represents field FCurVColumn.

Namespace: frxClass
Syntax
Delphi
private
 FCurVColumn: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FCurX Field

Summary

Represents field FCurX.

Namespace: frxClass
Syntax
Delphi
protected
 FCurX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FCurY Field

Summary

Represents field FCurY.

Namespace: frxClass
Syntax
Delphi
protected
 FCurY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FFinalPass Field

Summary

Represents field FFinalPass.

Namespace: frxClass
Syntax
Delphi
private
 FFinalPass: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FNotifyList Field

Summary

Represents field FNotifyList.

Namespace: frxClass
Syntax
Delphi
private
 FNotifyList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FOnRunDialog Field

Summary

Represents field FOnRunDialog.

Namespace: frxClass
Syntax
Delphi
private
 FOnRunDialog: TfrxRunDialogEvent;

Field Value

Type: TfrxRunDialogEvent

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FPageHeight Field

Summary

Represents field FPageHeight.

Namespace: frxClass
Syntax
Delphi
private
 FPageHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FPageWidth Field

Summary

Represents field FPageWidth.

Namespace: frxClass
Syntax
Delphi
private
 FPageWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FPreviewPages Field

Summary

Represents field FPreviewPages.

Namespace: frxClass
Syntax
Delphi
private
 FPreviewPages: TfrxCustomPreviewPages;

Field Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FRunning Field

Summary

Represents field FRunning.

Namespace: frxClass
Syntax
Delphi
private
 FRunning: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FSecondScriptCall Field

Summary

Represents field FSecondScriptCall.

Namespace: frxClass
Syntax
Delphi
private
 FSecondScriptCall: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FStartDate Field

Summary

Represents field FStartDate.

Namespace: frxClass
Syntax
Delphi
private
 FStartDate: TDateTime;

Field Value

Type: TDateTime

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FStartTime Field

Summary

Represents field FStartTime.

Namespace: frxClass
Syntax
Delphi
private
 FStartTime: TDateTime;

Field Value

Type: TDateTime

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomEngine.FTotalPages Field

Summary

Represents field FTotalPages.

Namespace: frxClass
Syntax
Delphi
private
 FTotalPages: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomEngine
  • frxClass


TfrxCustomExportFilter Class

Summary

The TfrxCustomExportFilter is the base class for all export filters.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxCustomExportFilter
frxDMPExport.TfrxDotMatrixExport
Syntax
Delphi
type
 TfrxCustomExportFilter = class(TComponent)
 end;

The TfrxCustomExportFilter type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomExportFilter class.
CreateNoRegister | This constructor creates component without registration in global list so the filter will be hidden for preview. Thread safe constructor.
Destroy | Represents the destructor of the TfrxCustomExportFilter class.
Top
Properties
Show:
Name | Description
CreationTime | Creation time of the document.
CurPage | If this property is True, only current page will be exported(in case the export was called from the preview window).
DataOnly | If True, the export engine exports only data bands objects.
DefaultExt | Default extension of export filter result.
DefaultIOTransport | Default transport filter used for file operations in current export filter.
DefaultPath | Default path of export result.
ExportNotPrintable | If True, the report engine exports all objects with Printable flag set to False.
ExportTitle | Title of export filter.
FileName | Default file name for export result.
Files | List of files generated by export filter.
FilterDesc | Default description of export filter.
IOTransport | Represents property IOTransport.
OnBeforeExport | This event fires before export starts.
OnBeginExport | This event fires when export filter is being exported.
OpenAfterExport | If True, document will be opened by default viewer.
OverwritePrompt | Represents property OverwritePrompt.
PageNumbers | List of page numbers to export, for example '1-3,5,12'. If this property is empty (by default), all pages will be exported.
Report | Reference to a report.
ShowDialog | Determines if export settings dialogue is shown. Default value is True.
ShowProgress | Shows dialog with export progress.
SlaveExport | Internal use.
Stream | Reference to a stream used to save export filter result.
SuppressPageHeadersFooters | Suppress page Headers and page Footers during export.
UseFileCache | Use a file cache for temporary operations.
Top
Methods
Show:
Name | Description
AfterFinish | Represents method AfterFinish.
BeforeStart | Represents method BeforeStart.
BeginClip(TfrxView) | Begin clip operation.
CreateDefaultIOTransport | Method created default instance of transport filter for current class of export filter.
DoFinish | Method is called after finishing the export.
DoStart | Method is called before export starts. To continue export, this method should return True.
EndClip |
ExportObject(TfrxComponent) | Method is called when exporting the object. Bands are exported too.
Finish | Represents method Finish.
FinishPage(TfrxReportPage,Integer) | Method is called after finishing a page. Page is the reference to a page, Index is the page index in the prepared report.
GetDefaultIOTransport | Represents method GetDefaultIOTransport.
GetDescription | Description of the export filter. This value is displayed in the preview window.
IsProcessInternal | Returns True when filter export can process internal objects in other objects.
SetDefaultIOTransport(TfrxCustomIOTransport) | Represents method SetDefaultIOTransport(TfrxCustomIOTransport).
SetFileName(String) | Represents method SetFileName(String).
ShowModal | Method should show the export settings dialog and return mrOk value if dialog was accepted. This method is not called if ShowDialog property is False.
Start | Represents method Start.
StartPage(TfrxReportPage,Integer) | Method is called before exporting a page. Page is the reference to a page, Index is the page index in the prepared report.
Top
Fields
Show:
Name | Description
FCreationTime | Represents field FCreationTime.
FCurPage | Represents field FCurPage.
FDataOnly | Represents field FDataOnly.
FDefaultExt | Represents field FDefaultExt.
FDefaultIOTransport | Represents field FDefaultIOTransport.
FDefaultPath | Represents field FDefaultPath.
FExportNotPrintable | Represents field FExportNotPrintable.
FFIles | Represents field FFIles.
FFilterDesc | Represents field FFilterDesc.
FIOTransport | Represents field FIOTransport.
FName | Represents field FName.
FNoRegister | Represents field FNoRegister.
FOnBeforeExport | Represents field FOnBeforeExport.
FOnBeginExport | Represents field FOnBeginExport.
FOpenAfterExport | Represents field FOpenAfterExport.
FOverwritePrompt | Represents field FOverwritePrompt.
FPageNumbers | Represents field FPageNumbers.
FReport | Represents field FReport.
FShowDialog | Represents field FShowDialog.
FShowProgress | Represents field FShowProgress.
FSlaveExport | Represents field FSlaveExport.
FStream | Represents field FStream.
FSuppressPageHeadersFooters | Represents field FSuppressPageHeadersFooters.
FTitle | Represents field FTitle.
FUseFileCache | Represents field FUseFileCache.
Top
See Also

Reference

  • frxClass


TfrxCustomExportFilter Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomExportFilter class.
CreateNoRegister | This constructor creates component without registration in global list so the filter will be hidden for preview. Thread safe constructor.
Destroy | Represents the destructor of the TfrxCustomExportFilter class.
Top


TfrxCustomExportFilter.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomExportFilter class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.CreateNoRegister Constructor

Summary

This constructor creates component without registration in global list so the filter will be hidden for preview. Thread safe constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor CreateNoRegister;
See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomExportFilter class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter Properties

Properties
Name | Description
CreationTime | Creation time of the document.
CurPage | If this property is True, only current page will be exported(in case the export was called from the preview window).
DataOnly | If True, the export engine exports only data bands objects.
DefaultExt | Default extension of export filter result.
DefaultIOTransport | Default transport filter used for file operations in current export filter.
DefaultPath | Default path of export result.
ExportNotPrintable | If True, the report engine exports all objects with Printable flag set to False.
ExportTitle | Title of export filter.
FileName | Default file name for export result.
Files | List of files generated by export filter.
FilterDesc | Default description of export filter.
IOTransport | Represents property IOTransport.
OnBeforeExport | This event fires before export starts.
OnBeginExport | This event fires when export filter is being exported.
OpenAfterExport | If True, document will be opened by default viewer.
OverwritePrompt | Represents property OverwritePrompt.
PageNumbers | List of page numbers to export, for example '1-3,5,12'. If this property is empty (by default), all pages will be exported.
Report | Reference to a report.
ShowDialog | Determines if export settings dialogue is shown. Default value is True.
ShowProgress | Shows dialog with export progress.
SlaveExport | Internal use.
Stream | Reference to a stream used to save export filter result.
SuppressPageHeadersFooters | Suppress page Headers and page Footers during export.
UseFileCache | Use a file cache for temporary operations.
Top


TfrxCustomExportFilter.CreationTime Property

Summary

Creation time of the document.

Namespace: frxClass
Syntax
Delphi
published
 property CreationTime: TDateTime read FCreationTime write FCreationTime;

Property Value

Type: TDateTime

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.CurPage Property

Summary

If this property is True, only current page will be exported(in case the export was called from the preview window).

Namespace: frxClass
Syntax
Delphi
public
 property CurPage: Boolean read FCurPage write FCurPage;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.DataOnly Property

Summary

If True, the export engine exports only data bands objects.

Namespace: frxClass
Syntax
Delphi
published
 property DataOnly: Boolean read FDataOnly write FDataOnly;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.DefaultExt Property

Summary

Default extension of export filter result.

Namespace: frxClass
Syntax
Delphi
public
 property DefaultExt: String read FDefaultExt write FDefaultExt;

Property Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.DefaultIOTransport Property

Summary

Default transport filter used for file operations in current export filter.

Namespace: frxClass
Syntax
Delphi
public
 property DefaultIOTransport: TfrxCustomIOTransport read GetDefaultIOTransport write SetDefaultIOTransport;

Property Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.DefaultPath Property

Summary

Default path of export result.

Namespace: frxClass
Syntax
Delphi
published
 property DefaultPath: String read FDefaultPath write FDefaultPath;

Property Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.ExportNotPrintable Property

Summary

If True, the report engine exports all objects with Printable flag set to False.

Namespace: frxClass
Syntax
Delphi
published
 property ExportNotPrintable: Boolean read FExportNotPrintable write FExportNotPrintable default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.ExportTitle Property

Summary

Title of export filter.

Namespace: frxClass
Syntax
Delphi
public
 property ExportTitle: String read FTitle write FTitle;

Property Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FileName Property

Summary

Default file name for export result.

Namespace: frxClass
Syntax
Delphi
published
 property FileName: String read FName write SetFileName;

Property Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.Files Property

Summary

List of files generated by export filter.

Namespace: frxClass
Syntax
Delphi
public
 property Files: TStrings read FFiles write FFiles;

Property Value

Type: TStrings

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FilterDesc Property

Summary

Default description of export filter.

Namespace: frxClass
Syntax
Delphi
public
 property FilterDesc: String read FFilterDesc write FFilterDesc;

Property Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.IOTransport Property

Summary

Represents property IOTransport.

Namespace: frxClass
Syntax
Delphi
published
 property IOTransport: TfrxCustomIOTransport read FIOTransport write FIOTransport;

Property Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.OnBeforeExport Property

Summary

This event fires before export starts.

Namespace: frxClass
Syntax
Delphi
published
 property OnBeforeExport: TNotifyEvent read FOnBeforeExport write FOnBeforeExport;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.OnBeginExport Property

Summary

This event fires when export filter is being exported.

Namespace: frxClass
Syntax
Delphi
published
 property OnBeginExport: TNotifyEvent read FOnBeginExport write FOnBeginExport;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.OpenAfterExport Property

Summary

If True, document will be opened by default viewer.

Namespace: frxClass
Syntax
Delphi
public
 property OpenAfterExport: Boolean read FOpenAfterExport write FOpenAfterExport;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.OverwritePrompt Property

Summary

Represents property OverwritePrompt.

Namespace: frxClass
Syntax
Delphi
published
 property OverwritePrompt: Boolean read FOverwritePrompt write FOverwritePrompt;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.PageNumbers Property

Summary

List of page numbers to export, for example '1-3,5,12'. If this property is empty (by default), all pages will be exported.

Namespace: frxClass
Syntax
Delphi
public
 property PageNumbers: String read FPageNumbers write FPageNumbers;

Property Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.Report Property

Summary

Reference to a report.

Namespace: frxClass
Syntax
Delphi
public
 property Report: TfrxReport read FReport write FReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.ShowDialog Property

Summary

Determines if export settings dialogue is shown. Default value is True.

Namespace: frxClass
Syntax
Delphi
published
 property ShowDialog: Boolean read FShowDialog write FShowDialog default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.ShowProgress Property

Summary

Shows dialog with export progress.

Namespace: frxClass
Syntax
Delphi
published
 property ShowProgress: Boolean read FShowProgress write FShowProgress;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.SlaveExport Property

Summary

Internal use.

Namespace: frxClass
Syntax
Delphi
public
 property SlaveExport: Boolean read FSlaveExport write FSlaveExport;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.Stream Property

Summary

Reference to a stream used to save export filter result.

Namespace: frxClass
Syntax
Delphi
public
 property Stream: TStream read FStream write FStream;

Property Value

Type: TStream

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.SuppressPageHeadersFooters Property

Summary

Suppress page Headers and page Footers during export.

Namespace: frxClass
Syntax
Delphi
public
 property SuppressPageHeadersFooters: Boolean read FSuppressPageHeadersFooters
 write FSuppressPageHeadersFooters;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.UseFileCache Property

Summary

Use a file cache for temporary operations.

Namespace: frxClass
Syntax
Delphi
published
 property UseFileCache: Boolean read FUseFileCache write FUseFileCache;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter Methods

Methods
Name | Description
AfterFinish | Represents method AfterFinish.
BeforeStart | Represents method BeforeStart.
BeginClip(TfrxView) | Begin clip operation.
CreateDefaultIOTransport | Method created default instance of transport filter for current class of export filter.
DoFinish | Method is called after finishing the export.
DoStart | Method is called before export starts. To continue export, this method should return True.
EndClip |
ExportObject(TfrxComponent) | Method is called when exporting the object. Bands are exported too.
Finish | Represents method Finish.
FinishPage(TfrxReportPage,Integer) | Method is called after finishing a page. Page is the reference to a page, Index is the page index in the prepared report.
GetDefaultIOTransport | Represents method GetDefaultIOTransport.
GetDescription | Description of the export filter. This value is displayed in the preview window.
IsProcessInternal | Returns True when filter export can process internal objects in other objects.
SetDefaultIOTransport(TfrxCustomIOTransport) | Represents method SetDefaultIOTransport(TfrxCustomIOTransport).
SetFileName(String) | Represents method SetFileName(String).
ShowModal | Method should show the export settings dialog and return mrOk value if dialog was accepted. This method is not called if ShowDialog property is False.
Start | Represents method Start.
StartPage(TfrxReportPage,Integer) | Method is called before exporting a page. Page is the reference to a page, Index is the page index in the prepared report.
Top


TfrxCustomExportFilter.AfterFinish Method

Summary

Represents method AfterFinish.

Namespace: frxClass
Syntax
Delphi
protected
 procedure AfterFinish; virtual;
See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.BeforeStart Method

Summary

Represents method BeforeStart.

Namespace: frxClass
Syntax
Delphi
protected
 procedure BeforeStart; virtual;
See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.BeginClip(TfrxView) Method

Summary

Begin clip operation.

Namespace: frxClass
Syntax
Delphi
public
 procedure BeginClip(Obj: TfrxView); virtual;

Parameters

Obj
Type: TfrxView

Rect of this object use as a clip rect.

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.CreateDefaultIOTransport Method

Summary

Method created default instance of transport filter for current class of export filter.

Namespace: frxClass
Syntax
Delphi
public
 function CreateDefaultIOTransport: TfrxCustomIOTransport; virtual;

Return Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.DoFinish Method

Summary

Method is called after finishing the export.

Namespace: frxClass
Syntax
Delphi
public
 procedure DoFinish;
See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.DoStart Method

Summary

Method is called before export starts. To continue export, this method should return True.

Namespace: frxClass
Syntax
Delphi
public
 function DoStart: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.EndClip Method

Namespace: frxClass
Syntax
Delphi
public
 procedure EndClip; virtual;
Exceptions
Stop clip operation.
See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.ExportObject(TfrxComponent) Method

Summary

Method is called when exporting the object. Bands are exported too.

Namespace: frxClass
Syntax
Delphi
public
 procedure ExportObject(Obj: TfrxComponent); virtual; abstract;

Parameters

Obj
Type: TfrxComponent

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.Finish Method

Summary

Represents method Finish.

Namespace: frxClass
Syntax
Delphi
protected
 procedure Finish; virtual;
See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FinishPage(TfrxReportPage,Integer) Method

Summary

Method is called after finishing a page. Page is the reference to a page, Index is the page index in the prepared report.

Namespace: frxClass
Syntax
Delphi
public
 procedure FinishPage(Page: TfrxReportPage; Index: Integer); virtual;

Parameters

Page
Type: TfrxReportPage

Index
Type: Integer

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.GetDefaultIOTransport Method

Summary

Represents method GetDefaultIOTransport.

Namespace: frxClass
Syntax
Delphi
private
 function GetDefaultIOTransport: TfrxCustomIOTransport;

Return Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.GetDescription Method

Summary

Description of the export filter. This value is displayed in the preview window.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.IsProcessInternal Method

Summary

Returns True when filter export can process internal objects in other objects.

Namespace: frxClass
Syntax
Delphi
public
 function IsProcessInternal: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.SetDefaultIOTransport(TfrxCustomIOTransport) Method

Summary

Represents method SetDefaultIOTransport(TfrxCustomIOTransport).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDefaultIOTransport(const Value: TfrxCustomIOTransport);

Parameters

Value
Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.SetFileName(String) Method

Summary

Represents method SetFileName(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFileName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.ShowModal Method

Summary

Method should show the export settings dialog and return mrOk value if dialog was accepted. This method is not called if ShowDialog property is False.

Namespace: frxClass
Syntax
Delphi
public
 function ShowModal: TModalResult; virtual;

Return Value

Type: TModalResult

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.Start Method

Summary

Represents method Start.

Namespace: frxClass
Syntax
Delphi
protected
 function Start: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.StartPage(TfrxReportPage,Integer) Method

Summary

Method is called before exporting a page. Page is the reference to a page, Index is the page index in the prepared report.

Namespace: frxClass
Syntax
Delphi
public
 procedure StartPage(Page: TfrxReportPage; Index: Integer); virtual;

Parameters

Page
Type: TfrxReportPage

Index
Type: Integer

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter Fields

Fields
Name | Description
FCreationTime | Represents field FCreationTime.
FCurPage | Represents field FCurPage.
FDataOnly | Represents field FDataOnly.
FDefaultExt | Represents field FDefaultExt.
FDefaultIOTransport | Represents field FDefaultIOTransport.
FDefaultPath | Represents field FDefaultPath.
FExportNotPrintable | Represents field FExportNotPrintable.
FFIles | Represents field FFIles.
FFilterDesc | Represents field FFilterDesc.
FIOTransport | Represents field FIOTransport.
FName | Represents field FName.
FNoRegister | Represents field FNoRegister.
FOnBeforeExport | Represents field FOnBeforeExport.
FOnBeginExport | Represents field FOnBeginExport.
FOpenAfterExport | Represents field FOpenAfterExport.
FOverwritePrompt | Represents field FOverwritePrompt.
FPageNumbers | Represents field FPageNumbers.
FReport | Represents field FReport.
FShowDialog | Represents field FShowDialog.
FShowProgress | Represents field FShowProgress.
FSlaveExport | Represents field FSlaveExport.
FStream | Represents field FStream.
FSuppressPageHeadersFooters | Represents field FSuppressPageHeadersFooters.
FTitle | Represents field FTitle.
FUseFileCache | Represents field FUseFileCache.
Top


TfrxCustomExportFilter.FCreationTime Field

Summary

Represents field FCreationTime.

Namespace: frxClass
Syntax
Delphi
private
 FCreationTime: TDateTime;

Field Value

Type: TDateTime

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FCurPage Field

Summary

Represents field FCurPage.

Namespace: frxClass
Syntax
Delphi
private
 FCurPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FDataOnly Field

Summary

Represents field FDataOnly.

Namespace: frxClass
Syntax
Delphi
private
 FDataOnly: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FDefaultExt Field

Summary

Represents field FDefaultExt.

Namespace: frxClass
Syntax
Delphi
private
 FDefaultExt: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FDefaultIOTransport Field

Summary

Represents field FDefaultIOTransport.

Namespace: frxClass
Syntax
Delphi
protected
 FDefaultIOTransport: TfrxCustomIOTransport;

Field Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FDefaultPath Field

Summary

Represents field FDefaultPath.

Namespace: frxClass
Syntax
Delphi
private
 FDefaultPath: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FExportNotPrintable Field

Summary

Represents field FExportNotPrintable.

Namespace: frxClass
Syntax
Delphi
private
 FExportNotPrintable: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FFIles Field

Summary

Represents field FFIles.

Namespace: frxClass
Syntax
Delphi
private
 FFIles: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FFilterDesc Field

Summary

Represents field FFilterDesc.

Namespace: frxClass
Syntax
Delphi
private
 FFilterDesc: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FIOTransport Field

Summary

Represents field FIOTransport.

Namespace: frxClass
Syntax
Delphi
private
 FIOTransport: TfrxCustomIOTransport;

Field Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FName Field

Summary

Represents field FName.

Namespace: frxClass
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FNoRegister Field

Summary

Represents field FNoRegister.

Namespace: frxClass
Syntax
Delphi
private
 FNoRegister: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FOnBeforeExport Field

Summary

Represents field FOnBeforeExport.

Namespace: frxClass
Syntax
Delphi
private
 FOnBeforeExport: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FOnBeginExport Field

Summary

Represents field FOnBeginExport.

Namespace: frxClass
Syntax
Delphi
private
 FOnBeginExport: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FOpenAfterExport Field

Summary

Represents field FOpenAfterExport.

Namespace: frxClass
Syntax
Delphi
private
 FOpenAfterExport: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FOverwritePrompt Field

Summary

Represents field FOverwritePrompt.

Namespace: frxClass
Syntax
Delphi
private
 FOverwritePrompt: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FPageNumbers Field

Summary

Represents field FPageNumbers.

Namespace: frxClass
Syntax
Delphi
private
 FPageNumbers: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FShowDialog Field

Summary

Represents field FShowDialog.

Namespace: frxClass
Syntax
Delphi
private
 FShowDialog: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FShowProgress Field

Summary

Represents field FShowProgress.

Namespace: frxClass
Syntax
Delphi
private
 FShowProgress: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FSlaveExport Field

Summary

Represents field FSlaveExport.

Namespace: frxClass
Syntax
Delphi
private
 FSlaveExport: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FStream Field

Summary

Represents field FStream.

Namespace: frxClass
Syntax
Delphi
private
 FStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FSuppressPageHeadersFooters Field

Summary

Represents field FSuppressPageHeadersFooters.

Namespace: frxClass
Syntax
Delphi
private
 FSuppressPageHeadersFooters: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FTitle Field

Summary

Represents field FTitle.

Namespace: frxClass
Syntax
Delphi
private
 FTitle: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomExportFilter.FUseFileCache Field

Summary

Represents field FUseFileCache.

Namespace: frxClass
Syntax
Delphi
private
 FUseFileCache: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomExportFilter
  • frxClass


TfrxCustomFill Class

Summary

Base abstract class for representation of object fills interface. Every object fill should inherit from this class.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxCustomFill
frxClass.TfrxBrushFill
frxClass.TfrxGlassFill
frxClass.TfrxGradientFill
Syntax
Delphi
type
 TfrxCustomFill = class(TPersistent)
 end;

The TfrxCustomFill type exposes the following members.

Methods
Show:
Name | Description
Diff(TfrxCustomFill,String) | Returns XML string with serialized comparison of stored data between two objects( Self and AFill).
Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) | Draw fill on a canvas.
Top
See Also

Reference

  • frxClass


TfrxCustomFill Methods

Methods
Name | Description
Diff(TfrxCustomFill,String) | Returns XML string with serialized comparison of stored data between two objects( Self and AFill).
Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) | Draw fill on a canvas.
Top


TfrxCustomFill.Diff(TfrxCustomFill,String) Method

Summary

Returns XML string with serialized comparison of stored data between two objects( Self and AFill).

Namespace: frxClass
Syntax
Delphi
public
 function Diff(AFill: TfrxCustomFill; const Add: String): String; virtual; abstract;

Parameters

AFill
Type: TfrxCustomFill

Add
Type: String

Return Value

Type: String

See Also

Reference

  • TfrxCustomFill
  • frxClass


TfrxCustomFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) Method

Summary

Draw fill on a canvas.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(ACanvas: TCanvas; X, Y, X1, Y1: Integer; ScaleX, ScaleY: Extended); virtual; abstract;

Parameters

ACanvas
Type: TCanvas

Source canvas.

X
Type: Integer

Start X coordinate of draw area.

Y
Type: Integer

Start Y coordinate of draw area.

X1
Type: Integer

End X coordinate of draw area.

Y1
Type: Integer

End Y coordinate of draw area.

ScaleX
Type: Extended

X scale factor.

ScaleY
Type: Extended

Y scale factor.

See Also

Reference

  • TfrxCustomFill
  • frxClass


TfrxCustomIOTransport Class

Summary

The TfrxCustomIOTransport class is the base class for all IO (input/output filters). It represents Base adapter interface for file or stream IO operations. Transport filters can be used in the report designer (save/open operations), report preview (save/open operations) and export filters. It possible to create one class of transport filter which encapsulates work with some IO protocol(for example save/load from cloud) and use this class where it's necessary(Designer, Preview, Exports) by setting up Visibility property.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxCustomIOTransport
frxClass.TfrxIOTransportFile
Syntax
Delphi
type
 TfrxCustomIOTransport = class(TComponent)
 end;

The TfrxCustomIOTransport type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomIOTransport class.
CreateNoRegister | This constructor creates component without registration in global list so the filter will be hidden for preview or report designer.
Destroy | Represents the destructor of the TfrxCustomIOTransport class.
Top
Properties
Show:
Name | Description
BasePath | Base path used in transport filter.
CreatedFrom | This flag shows where the current instance of the filter was created from.
CurrentContainer | Name of the current container.
DefaultExt | Default extension used in transport filter.
DefaultPath | Default path used in transport filter.
ExtDescription | Description for default extension used in transport filter.
FileName | File name for current filter.
FilterAccess | Access type of IO filter.
FilterString | Description of filter instance.
InternalFilter | Represents property InternalFilter.
OverwritePrompt | Represents property OverwritePrompt.
Report | Reference to a report component.
RootNode | Root node of the filter.
ShowDialog | Whether to display a print dialogue. Default value is True.
SupportedStreams | Supported stream type for current IO transport filter.
TempFilter | Returns reference to transport filter instance for temporary operations.
Visibility | These flags used in IO transports to define visibility of IO transport filter. By default each transport filter component registers in global list and these flags helps to sort items of the global list.
Top
Methods
Show:
Name | Description
AddContainer(TfrxNode) | Represents method AddContainer(TfrxNode).
AllInOneContainer | Returns true when physically all stream belongs to one container(zip archive).
AssignFilter(TfrxCustomIOTransport) | This method assigns properties of other transport filter to current.
AssignSharedProperties(TfrxCustomIOTransport) | This method assigns shared properties(like tokens) of other transport filter to current.
CloseAllStreams | The method closes all opened streams.
CloseFilter | This method can be called to close a filter. It uses to make finalization like close connection and streams.
CopyStreamsNames(TStrings,Boolean) | It copies names of steams in current transport to TStrings passed as a parameter.
CreateContainer(String,Boolean) | Creates a structure node represents a container or directory.
CreateFilterClone(TfrxFilterVisibleState) | Copy constructor.
CreateTempContainer | Creates a structure node represents a temporary container or directory.
DeleteContainer(String) | Deletes a structure node represents a container or directory.
DoCreateStream(String,String) | Represents method DoCreateStream(String,String).
DoFilterProcessStream(TStream,TObject) | This method call before loading from stream is started. Can be used to make a preparation of stream data before loading.
FreeStream(TStream,String) | Closes an opened stream by reference or name.
FreeTempContainer | Destroy a structure node represents a temporary container or directory.
GetCurrentContainer | Represents method GetCurrentContainer.
GetDescription | Represents method GetDescription.
GetFileNode | Returns nearest file node in current container.
GetFilterString | Represents method GetFilterString.
GetInternalFilter | Represents method GetInternalFilter.
GetNodeFromPath(String,Boolean,Boolean) | Represents method GetNodeFromPath(String,Boolean,Boolean).
GetStream(String) | Returns stream by name of a node or a file.
GetTempFilter | Represents method GetTempFilter.
GetVisibility | Represents method GetVisibility.
InitFromExport(TfrxCustomExportFilter) | Initialization of transport filter based on export filter settings(like file name and file extension).
LoadClosedStreams | Reloads all closed streams and open them again.
LoadStreamsList(TStrings) | Loads and opens steams from the list.
OpenFilter | This method can be called to open filter. It uses to make preparation like set connection or show user dialogs. It returns true when initialization was processed.
RemoveContainer(TfrxNode) | Represents method RemoveContainer(TfrxNode).
SetCurrentContainer(String) | Represents method SetCurrentContainer(String).
SetInternalFilter(TfrxCustomIOTransport) | Represents method SetInternalFilter(TfrxCustomIOTransport).
SetTempFilter(TfrxCustomIOTransport) | Represents method SetTempFilter(TfrxCustomIOTransport).
SetVisibility(TfrxFilterVisibility) | Represents method SetVisibility(TfrxFilterVisibility).
Top
Fields
Show:
Name | Description
FBasePath | Represents field FBasePath.
FClosedLoadLock | Represents field FClosedLoadLock.
FCreatedFrom | Represents field FCreatedFrom.
FCurNode | Represents field FCurNode.
FDefaultExt | Represents field FDefaultExt.
FDefaultPath | Represents field FDefaultPath.
FDirTree | Represents field FDirTree.
FExtDescription | Represents field FExtDescription.
FFileName | Represents field FFileName.
FFilterAccess | Represents field FFilterAccess.
FFilterString | Represents field FFilterString.
FFreeStream | Represents field FFreeStream.
FInternalFilter | Represents field FInternalFilter.
FNoRegister | Represents field FNoRegister.
FOriginalCopy | Represents field FOriginalCopy.
FOverwritePrompt | Represents field FOverwritePrompt.
FReport | Represents field FReport.
FShowDialog | Represents field FShowDialog.
FSupportedStreams | Represents field FSupportedStreams.
FTempFilter | Represents field FTempFilter.
FVisibility | Represents field FVisibility.
Top
See Also

Reference

  • frxClass


TfrxCustomIOTransport Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomIOTransport class.
CreateNoRegister | This constructor creates component without registration in global list so the filter will be hidden for preview or report designer.
Destroy | Represents the destructor of the TfrxCustomIOTransport class.
Top


TfrxCustomIOTransport.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomIOTransport class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.CreateNoRegister Constructor

Summary

This constructor creates component without registration in global list so the filter will be hidden for preview or report designer.

Namespace: frxClass
Syntax
Delphi
public
 constructor CreateNoRegister;
See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomIOTransport class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport Properties

Properties
Name | Description
BasePath | Base path used in transport filter.
CreatedFrom | This flag shows where the current instance of the filter was created from.
CurrentContainer | Name of the current container.
DefaultExt | Default extension used in transport filter.
DefaultPath | Default path used in transport filter.
ExtDescription | Description for default extension used in transport filter.
FileName | File name for current filter.
FilterAccess | Access type of IO filter.
FilterString | Description of filter instance.
InternalFilter | Represents property InternalFilter.
OverwritePrompt | Represents property OverwritePrompt.
Report | Reference to a report component.
RootNode | Root node of the filter.
ShowDialog | Whether to display a print dialogue. Default value is True.
SupportedStreams | Supported stream type for current IO transport filter.
TempFilter | Returns reference to transport filter instance for temporary operations.
Visibility | These flags used in IO transports to define visibility of IO transport filter. By default each transport filter component registers in global list and these flags helps to sort items of the global list.
Top


TfrxCustomIOTransport.BasePath Property

Summary

Base path used in transport filter.

Namespace: frxClass
Syntax
Delphi
public
 property BasePath: String read FBasePath write FBasePath;

Property Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.CreatedFrom Property

Summary

This flag shows where the current instance of the filter was created from.

Namespace: frxClass
Syntax
Delphi
public
 property CreatedFrom: TfrxFilterVisibleState read FCreatedFrom write FCreatedFrom;

Property Value

Type: TfrxFilterVisibleState

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.CurrentContainer Property

Summary

Name of the current container.

Namespace: frxClass
Syntax
Delphi
public
 property CurrentContainer: String read GetCurrentContainer write SetCurrentContainer;

Property Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.DefaultExt Property

Summary

Default extension used in transport filter.

Namespace: frxClass
Syntax
Delphi
public
 property DefaultExt: String read FDefaultExt write FDefaultExt;

Property Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.DefaultPath Property

Summary

Default path used in transport filter.

Namespace: frxClass
Syntax
Delphi
public
 property DefaultPath: String read FDefaultPath write FDefaultPath;

Property Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.ExtDescription Property

Summary

Description for default extension used in transport filter.

Namespace: frxClass
Syntax
Delphi
public
 property ExtDescription: String read FExtDescription write FExtDescription;

Property Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FileName Property

Summary

File name for current filter.

Namespace: frxClass
Syntax
Delphi
public
 property FileName: String read FFileName write FFileName;

Property Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FilterAccess Property

Summary

Access type of IO filter.

Namespace: frxClass
Syntax
Delphi
public
 property FilterAccess: TfrxFilterAccess read FFilterAccess write FFilterAccess;

Property Value

Type: TfrxFilterAccess

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FilterString Property

Summary

Description of filter instance.

Namespace: frxClass
Syntax
Delphi
public
 property FilterString: String read GetFilterString write FFilterString;

Property Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.InternalFilter Property

Summary

Represents property InternalFilter.

Namespace: frxClass
Syntax
Delphi
protected
 property InternalFilter: TfrxCustomIOTransport read GetInternalFilter write SetInternalFilter;

Property Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.OverwritePrompt Property

Summary

Represents property OverwritePrompt.

Namespace: frxClass
Syntax
Delphi
public
 property OverwritePrompt: Boolean read FOverwritePrompt write FOverwritePrompt;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.Report Property

Summary

Reference to a report component.

Namespace: frxClass
Syntax
Delphi
public
 property Report: TfrxReport read FReport write FReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.RootNode Property

Summary

Root node of the filter.

Namespace: frxClass
Syntax
Delphi
public
 property RootNode: TfrxNode read FDirTree;

Property Value

Type: TfrxNode

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.ShowDialog Property

Summary

Whether to display a print dialogue. Default value is True.

Namespace: frxClass
Syntax
Delphi
public
 property ShowDialog: Boolean read FShowDialog write FShowDialog;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.SupportedStreams Property

Summary

Supported stream type for current IO transport filter.

Namespace: frxClass
Syntax
Delphi
public
 property SupportedStreams: TfrxIOTransportStreams read FSupportedStreams write FSupportedStreams;

Property Value

Type: TfrxIOTransportStreams

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.TempFilter Property

Summary

Returns reference to transport filter instance for temporary operations.

Namespace: frxClass
Syntax
Delphi
public
 property TempFilter: TfrxCustomIOTransport read GetTempFilter write SetTempFilter;

Property Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.Visibility Property

Summary

These flags used in IO transports to define visibility of IO transport filter. By default each transport filter component registers in global list and these flags helps to sort items of the global list.

Namespace: frxClass
Syntax
Delphi
public
 property Visibility: TfrxFilterVisibility read GetVisibility write SetVisibility;

Property Value

Type: TfrxFilterVisibility

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport Methods

Methods
Name | Description
AddContainer(TfrxNode) | Represents method AddContainer(TfrxNode).
AllInOneContainer | Returns true when physically all stream belongs to one container(zip archive).
AssignFilter(TfrxCustomIOTransport) | This method assigns properties of other transport filter to current.
AssignSharedProperties(TfrxCustomIOTransport) | This method assigns shared properties(like tokens) of other transport filter to current.
CloseAllStreams | The method closes all opened streams.
CloseFilter | This method can be called to close a filter. It uses to make finalization like close connection and streams.
CopyStreamsNames(TStrings,Boolean) | It copies names of steams in current transport to TStrings passed as a parameter.
CreateContainer(String,Boolean) | Creates a structure node represents a container or directory.
CreateFilterClone(TfrxFilterVisibleState) | Copy constructor.
CreateTempContainer | Creates a structure node represents a temporary container or directory.
DeleteContainer(String) | Deletes a structure node represents a container or directory.
DoCreateStream(String,String) | Represents method DoCreateStream(String,String).
DoFilterProcessStream(TStream,TObject) | This method call before loading from stream is started. Can be used to make a preparation of stream data before loading.
FreeStream(TStream,String) | Closes an opened stream by reference or name.
FreeTempContainer | Destroy a structure node represents a temporary container or directory.
GetCurrentContainer | Represents method GetCurrentContainer.
GetDescription | Represents method GetDescription.
GetFileNode | Returns nearest file node in current container.
GetFilterString | Represents method GetFilterString.
GetInternalFilter | Represents method GetInternalFilter.
GetNodeFromPath(String,Boolean,Boolean) | Represents method GetNodeFromPath(String,Boolean,Boolean).
GetStream(String) | Returns stream by name of a node or a file.
GetTempFilter | Represents method GetTempFilter.
GetVisibility | Represents method GetVisibility.
InitFromExport(TfrxCustomExportFilter) | Initialization of transport filter based on export filter settings(like file name and file extension).
LoadClosedStreams | Reloads all closed streams and open them again.
LoadStreamsList(TStrings) | Loads and opens steams from the list.
OpenFilter | This method can be called to open filter. It uses to make preparation like set connection or show user dialogs. It returns true when initialization was processed.
RemoveContainer(TfrxNode) | Represents method RemoveContainer(TfrxNode).
SetCurrentContainer(String) | Represents method SetCurrentContainer(String).
SetInternalFilter(TfrxCustomIOTransport) | Represents method SetInternalFilter(TfrxCustomIOTransport).
SetTempFilter(TfrxCustomIOTransport) | Represents method SetTempFilter(TfrxCustomIOTransport).
SetVisibility(TfrxFilterVisibility) | Represents method SetVisibility(TfrxFilterVisibility).
Top


TfrxCustomIOTransport.AddContainer(TfrxNode) Method

Summary

Represents method AddContainer(TfrxNode).

Namespace: frxClass
Syntax
Delphi
protected
 function AddContainer(Item: TfrxNode): Boolean; virtual;

Parameters

Item
Type: TfrxNode

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.AllInOneContainer Method

Summary

Returns true when physically all stream belongs to one container(zip archive).

Namespace: frxClass
Syntax
Delphi
public
 function AllInOneContainer: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.AssignFilter(TfrxCustomIOTransport) Method

Summary

This method assigns properties of other transport filter to current.

Namespace: frxClass
Syntax
Delphi
public
 procedure AssignFilter(Source: TfrxCustomIOTransport); virtual;

Parameters

Source
Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.AssignSharedProperties(TfrxCustomIOTransport) Method

Summary

This method assigns shared properties(like tokens) of other transport filter to current.

Namespace: frxClass
Syntax
Delphi
public
 procedure AssignSharedProperties(Source: TfrxCustomIOTransport); virtual;

Parameters

Source
Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.CloseAllStreams Method

Summary

The method closes all opened streams.

Namespace: frxClass
Syntax
Delphi
public
 procedure CloseAllStreams;
See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.CloseFilter Method

Summary

This method can be called to close a filter. It uses to make finalization like close connection and streams.

Namespace: frxClass
Syntax
Delphi
public
 procedure CloseFilter; virtual;
See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.CopyStreamsNames(TStrings,Boolean) Method

Summary

It copies names of steams in current transport to TStrings passed as a parameter.

Namespace: frxClass
Syntax
Delphi
public
 procedure CopyStreamsNames(aStrings: TStrings; OpenedOnly: Boolean = False);

Parameters

aStrings
Type: TStrings

List to copy into.

OpenedOnly
Type: Boolean

Copy only names of open streams.

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.CreateContainer(String,Boolean) Method

Summary

Creates a structure node represents a container or directory.

Namespace: frxClass
Syntax
Delphi
public
 procedure CreateContainer(const cName: String; bSetCurrent: Boolean = False);

Parameters

cName
Type: String

Name of a container.

bSetCurrent
Type: Boolean

Set this container as current.

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.CreateFilterClone(TfrxFilterVisibleState) Method

Summary

Copy constructor.

Namespace: frxClass
Syntax
Delphi
public
 function CreateFilterClone(CreatedFrom: TfrxFilterVisibleState): TfrxCustomIOTransport;

Parameters

CreatedFrom
Type: TfrxFilterVisibleState

Instance to copy from.

Return Value

Type: TfrxCustomIOTransport

New copy of filter.

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.CreateTempContainer Method

Summary

Creates a structure node represents a temporary container or directory.

Namespace: frxClass
Syntax
Delphi
public
 procedure CreateTempContainer; virtual;
See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.DeleteContainer(String) Method

Summary

Deletes a structure node represents a container or directory.

Namespace: frxClass
Syntax
Delphi
public
 procedure DeleteContainer(const cName: String);

Parameters

cName
Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.DoCreateStream(String,String) Method

Summary

Represents method DoCreateStream(String,String).

Namespace: frxClass
Syntax
Delphi
protected
 function DoCreateStream(var aFullFilePath: String; aFileName: String): TStream; virtual;

Parameters

aFullFilePath
Type: String

aFileName
Type: String

Return Value

Type: TStream

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.DoFilterProcessStream(TStream,TObject) Method

Summary

This method call before loading from stream is started. Can be used to make a preparation of stream data before loading.

Namespace: frxClass
Syntax
Delphi
public
 function DoFilterProcessStream(aStream: TStream; ProcesssingObject: TObject): Boolean; virtual;

Parameters

aStream
Type: TStream

ProcesssingObject
Type: TObject

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FreeStream(TStream,String) Method

Summary

Closes an opened stream by reference or name.

Namespace: frxClass
Syntax
Delphi
public
 procedure FreeStream(aStream: TStream; const aFileName: String = ''); virtual;

Parameters

aStream
Type: TStream

Reference to opened stream.

aFileName
Type: String

Stream or file name.

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FreeTempContainer Method

Summary

Destroy a structure node represents a temporary container or directory.

Namespace: frxClass
Syntax
Delphi
public
 procedure FreeTempContainer; virtual;
See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.GetCurrentContainer Method

Summary

Represents method GetCurrentContainer.

Namespace: frxClass
Syntax
Delphi
private
 function GetCurrentContainer: String;

Return Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.GetDescription Method

Summary

Represents method GetDescription.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.GetFileNode Method

Summary

Returns nearest file node in current container.

Namespace: frxClass
Syntax
Delphi
public
 function GetFileNode: TfrxNode;

Return Value

Type: TfrxNode

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.GetFilterString Method

Summary

Represents method GetFilterString.

Namespace: frxClass
Syntax
Delphi
protected
 function GetFilterString: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.GetInternalFilter Method

Summary

Represents method GetInternalFilter.

Namespace: frxClass
Syntax
Delphi
private
 function GetInternalFilter: TfrxCustomIOTransport;

Return Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.GetNodeFromPath(String,Boolean,Boolean) Method

Summary

Represents method GetNodeFromPath(String,Boolean,Boolean).

Namespace: frxClass
Syntax
Delphi
protected
 function GetNodeFromPath(aPath: String; bCreateNodes: Boolean = False; bLastNodeAsFile: Boolean = False): TfrxNode;

Parameters

aPath
Type: String

bCreateNodes
Type: Boolean

bLastNodeAsFile
Type: Boolean

Return Value

Type: TfrxNode

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.GetStream(String) Method

Summary

Returns stream by name of a node or a file.

Namespace: frxClass
Syntax
Delphi
public
 function GetStream(aFileName: String = ''): TStream; virtual;

Parameters

aFileName
Type: String

File or node name.

Return Value

Type: TStream

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.GetTempFilter Method

Summary

Represents method GetTempFilter.

Namespace: frxClass
Syntax
Delphi
private
 function GetTempFilter: TfrxCustomIOTransport;

Return Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.GetVisibility Method

Summary

Represents method GetVisibility.

Namespace: frxClass
Syntax
Delphi
protected
 function GetVisibility: TfrxFilterVisibility; virtual;

Return Value

Type: TfrxFilterVisibility

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.InitFromExport(TfrxCustomExportFilter) Method

Summary

Initialization of transport filter based on export filter settings(like file name and file extension).

Namespace: frxClass
Syntax
Delphi
public
 procedure InitFromExport(ExportFilter: TfrxCustomExportFilter);

Parameters

ExportFilter
Type: TfrxCustomExportFilter

Instance of an export filter.

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.LoadClosedStreams Method

Summary

Reloads all closed streams and open them again.

Namespace: frxClass
Syntax
Delphi
public
 procedure LoadClosedStreams;
See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.LoadStreamsList(TStrings) Method

Summary

Loads and opens steams from the list.

Namespace: frxClass
Syntax
Delphi
public
 procedure LoadStreamsList(aStrings: TStrings);

Parameters

aStrings
Type: TStrings

List with steam names.

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.OpenFilter Method

Summary

This method can be called to open filter. It uses to make preparation like set connection or show user dialogs. It returns true when initialization was processed.

Namespace: frxClass
Syntax
Delphi
public
 function OpenFilter: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.RemoveContainer(TfrxNode) Method

Summary

Represents method RemoveContainer(TfrxNode).

Namespace: frxClass
Syntax
Delphi
protected
 function RemoveContainer(Item: TfrxNode): Boolean; virtual;

Parameters

Item
Type: TfrxNode

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.SetCurrentContainer(String) Method

Summary

Represents method SetCurrentContainer(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetCurrentContainer(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.SetInternalFilter(TfrxCustomIOTransport) Method

Summary

Represents method SetInternalFilter(TfrxCustomIOTransport).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetInternalFilter(const Value: TfrxCustomIOTransport);

Parameters

Value
Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.SetTempFilter(TfrxCustomIOTransport) Method

Summary

Represents method SetTempFilter(TfrxCustomIOTransport).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetTempFilter(const Value: TfrxCustomIOTransport);

Parameters

Value
Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.SetVisibility(TfrxFilterVisibility) Method

Summary

Represents method SetVisibility(TfrxFilterVisibility).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetVisibility(const Value: TfrxFilterVisibility); virtual;

Parameters

Value
Type: TfrxFilterVisibility

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport Fields

Fields
Name | Description
FBasePath | Represents field FBasePath.
FClosedLoadLock | Represents field FClosedLoadLock.
FCreatedFrom | Represents field FCreatedFrom.
FCurNode | Represents field FCurNode.
FDefaultExt | Represents field FDefaultExt.
FDefaultPath | Represents field FDefaultPath.
FDirTree | Represents field FDirTree.
FExtDescription | Represents field FExtDescription.
FFileName | Represents field FFileName.
FFilterAccess | Represents field FFilterAccess.
FFilterString | Represents field FFilterString.
FFreeStream | Represents field FFreeStream.
FInternalFilter | Represents field FInternalFilter.
FNoRegister | Represents field FNoRegister.
FOriginalCopy | Represents field FOriginalCopy.
FOverwritePrompt | Represents field FOverwritePrompt.
FReport | Represents field FReport.
FShowDialog | Represents field FShowDialog.
FSupportedStreams | Represents field FSupportedStreams.
FTempFilter | Represents field FTempFilter.
FVisibility | Represents field FVisibility.
Top


TfrxCustomIOTransport.FBasePath Field

Summary

Represents field FBasePath.

Namespace: frxClass
Syntax
Delphi
private
 FBasePath: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FClosedLoadLock Field

Summary

Represents field FClosedLoadLock.

Namespace: frxClass
Syntax
Delphi
protected
 FClosedLoadLock: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FCreatedFrom Field

Summary

Represents field FCreatedFrom.

Namespace: frxClass
Syntax
Delphi
protected
 FCreatedFrom: TfrxFilterVisibleState;

Field Value

Type: TfrxFilterVisibleState

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FCurNode Field

Summary

Represents field FCurNode.

Namespace: frxClass
Syntax
Delphi
private
 FCurNode: TfrxNode;

Field Value

Type: TfrxNode

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FDefaultExt Field

Summary

Represents field FDefaultExt.

Namespace: frxClass
Syntax
Delphi
private
 FDefaultExt: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FDefaultPath Field

Summary

Represents field FDefaultPath.

Namespace: frxClass
Syntax
Delphi
private
 FDefaultPath: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FDirTree Field

Summary

Represents field FDirTree.

Namespace: frxClass
Syntax
Delphi
protected
 FDirTree: TfrxNode;

Field Value

Type: TfrxNode

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FExtDescription Field

Summary

Represents field FExtDescription.

Namespace: frxClass
Syntax
Delphi
private
 FExtDescription: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FFileName Field

Summary

Represents field FFileName.

Namespace: frxClass
Syntax
Delphi
private
 FFileName: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FFilterAccess Field

Summary

Represents field FFilterAccess.

Namespace: frxClass
Syntax
Delphi
private
 FFilterAccess: TfrxFilterAccess;

Field Value

Type: TfrxFilterAccess

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FFilterString Field

Summary

Represents field FFilterString.

Namespace: frxClass
Syntax
Delphi
private
 FFilterString: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FFreeStream Field

Summary

Represents field FFreeStream.

Namespace: frxClass
Syntax
Delphi
protected
 FFreeStream: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FInternalFilter Field

Summary

Represents field FInternalFilter.

Namespace: frxClass
Syntax
Delphi
protected
 FInternalFilter: TfrxCustomIOTransport;

Field Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FNoRegister Field

Summary

Represents field FNoRegister.

Namespace: frxClass
Syntax
Delphi
protected
 FNoRegister: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FOriginalCopy Field

Summary

Represents field FOriginalCopy.

Namespace: frxClass
Syntax
Delphi
protected
 FOriginalCopy: TfrxCustomIOTransport;

Field Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FOverwritePrompt Field

Summary

Represents field FOverwritePrompt.

Namespace: frxClass
Syntax
Delphi
private
 FOverwritePrompt: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FShowDialog Field

Summary

Represents field FShowDialog.

Namespace: frxClass
Syntax
Delphi
private
 FShowDialog: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FSupportedStreams Field

Summary

Represents field FSupportedStreams.

Namespace: frxClass
Syntax
Delphi
protected
 FSupportedStreams: TfrxIOTransportStreams;

Field Value

Type: TfrxIOTransportStreams

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FTempFilter Field

Summary

Represents field FTempFilter.

Namespace: frxClass
Syntax
Delphi
private
 FTempFilter: TfrxCustomIOTransport;

Field Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomIOTransport.FVisibility Field

Summary

Represents field FVisibility.

Namespace: frxClass
Syntax
Delphi
protected
 FVisibility: TfrxFilterVisibility;

Field Value

Type: TfrxFilterVisibility

See Also

Reference

  • TfrxCustomIOTransport
  • frxClass


TfrxCustomLineView Class

Summary

The TfrxCustomLineView class is the base class for "Line" and "Dot-matrix line" objects.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxClass.TfrxCustomLineView
frxClass.TfrxLineView
frxDMPClass.TfrxDMPLineView
Syntax
Delphi
type
 TfrxCustomLineView = class(TfrxStretcheable)
 end;

The TfrxCustomLineView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomLineView class. (Overrides TfrxStretcheable.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Overrides TfrxComponent.DesignCreate(TComponent,Word).)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
ArrowEnd | Determines whether to draw an arrow in the end of line.
ArrowLength | The length of arrow.
ArrowSolid | Determines whether to draw a solid arrow.
ArrowStart | Determines if an arrow is used at the start and end of the line.
ArrowWidth | The width of arrow.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
CanShrink | True if object can shrink height base on its content. (Inherited from TfrxStretcheable.)
Color | Color of the shape.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Object's cursor (in the preview mode). (Inherited from TfrxView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Diagonal | Determines if the line is diagonal.
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Object's frame. (Inherited from TfrxView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StretchMode | Object's stretch mode. (Inherited from TfrxStretcheable.)
TagStr | Represents property TagStr.
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Inherited from TfrxStretcheable.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawArrow(Extended,Extended,Extended,Extended) | Represents method DrawArrow(Extended,Extended,Extended,Extended).
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawDiagonalLine | Represents method DrawDiagonalLine.
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable. (Inherited from TfrxStretcheable.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxReportComponent.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Overrides TfrxView.GetVectorGraphic(Boolean).)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Inherited from TfrxStretcheable.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object. (Inherited from TfrxStretcheable.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Overrides TfrxComponent.IsInRect(TfrxRect).)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FArrowEnd | Represents field FArrowEnd.
FArrowLength | Represents field FArrowLength.
FArrowSolid | Represents field FArrowSolid.
FArrowStart | Represents field FArrowStart.
FArrowWidth | Represents field FArrowWidth.
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FColor | Represents field FColor.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDiagonal | Represents field FDiagonal.
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FSavedTop | Internal use only. Stores original top during shift operation. (Inherited from TfrxStretcheable.)
FSaveHeight | Internal use only. Stores object Height during stretch operation. (Inherited from TfrxStretcheable.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxClass


TfrxCustomLineView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomLineView class. (Overrides TfrxStretcheable.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Overrides TfrxComponent.DesignCreate(TComponent,Word).)
Top


TfrxCustomLineView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomLineView class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxStretcheable.Create(TComponent)
See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.DesignCreate(TComponent,Word) Constructor

Summary

Constructor uses by the report designer when create new report object.

Namespace: frxClass
Syntax
Delphi
public
 constructor DesignCreate(AOwner: TComponent; Flags: Word); override;

Parameters

AOwner
Type: TComponent

Component owner.

Flags
Type: Word

Addition creation parameter depends on component class.

Overrides

TfrxComponent.DesignCreate(TComponent,Word)
See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView Properties

Properties
Name | Description
ArrowEnd | Determines whether to draw an arrow in the end of line.
ArrowLength | The length of arrow.
ArrowSolid | Determines whether to draw a solid arrow.
ArrowStart | Determines if an arrow is used at the start and end of the line.
ArrowWidth | The width of arrow.
Color | Color of the shape.
Diagonal | Determines if the line is diagonal.
TagStr | Represents property TagStr.
Top


TfrxCustomLineView.ArrowEnd Property

Summary

Determines whether to draw an arrow in the end of line.

Namespace: frxClass
Syntax
Delphi
public
 property ArrowEnd: Boolean read FArrowEnd write FArrowEnd default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.ArrowLength Property

Summary

The length of arrow.

Namespace: frxClass
Syntax
Delphi
public
 property ArrowLength: Integer read FArrowLength write FArrowLength default 20;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.ArrowSolid Property

Summary

Determines whether to draw a solid arrow.

Namespace: frxClass
Syntax
Delphi
public
 property ArrowSolid: Boolean read FArrowSolid write FArrowSolid default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.ArrowStart Property

Summary

Determines if an arrow is used at the start and end of the line.

Namespace: frxClass
Syntax
Delphi
public
 property ArrowStart: Boolean read FArrowStart write FArrowStart default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.ArrowWidth Property

Summary

The width of arrow.

Namespace: frxClass
Syntax
Delphi
public
 property ArrowWidth: Integer read FArrowWidth write FArrowWidth default 5;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.Color Property

Summary

Color of the shape.

Namespace: frxClass
Syntax
Delphi
published
 property Color: TColor read FColor write FColor default clNone;

Property Value

Type: TColor

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.Diagonal Property

Summary

Determines if the line is diagonal.

Namespace: frxClass
Syntax
Delphi
public
 property Diagonal: Boolean read FDiagonal write FDiagonal default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.TagStr Property

Summary

Represents property TagStr.

Namespace: frxClass
Syntax
Delphi
published
 property TagStr;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView Methods

Methods
Name | Description
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawArrow(Extended,Extended,Extended,Extended) | Represents method DrawArrow(Extended,Extended,Extended,Extended).
DrawDiagonalLine | Represents method DrawDiagonalLine.
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Overrides TfrxView.GetVectorGraphic(Boolean).)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Overrides TfrxComponent.IsInRect(TfrxRect).)
Top


TfrxCustomLineView.Diff(TfrxComponent) Method

Summary

Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set.

Namespace: frxClass
Syntax
Delphi
public
 function Diff(AComponent: TfrxComponent): String; override;

Parameters

AComponent
Type: TfrxComponent

Return Value

Type: String

Overrides

TfrxView.Diff(TfrxComponent)
See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.DrawArrow(Extended,Extended,Extended,Extended) Method

Summary

Represents method DrawArrow(Extended,Extended,Extended,Extended).

Namespace: frxClass
Syntax
Delphi
private
 procedure DrawArrow(x1, y1, x2, y2: Extended);

Parameters

x1
Type: Extended

y1
Type: Extended

x2
Type: Extended

y2
Type: Extended

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.DrawDiagonalLine Method

Summary

Represents method DrawDiagonalLine.

Namespace: frxClass
Syntax
Delphi
private
 procedure DrawDiagonalLine;
See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.GetVectorGraphic(Boolean) Method

Summary

Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it.

Namespace: frxClass
Syntax
Delphi
public
 function GetVectorGraphic(DrawFill: Boolean = False): TGraphic; override;

Parameters

DrawFill
Type: Boolean

If True , object draws fill on result vector image.

Return Value

Type: TGraphic

Overrides

TfrxView.GetVectorGraphic(Boolean)
See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.IsContain(Extended,Extended) Method

Summary

Detects if point is inside an object coordinates.

Namespace: frxClass
Syntax
Delphi
public
 function IsContain(X, Y: Extended): Boolean; override;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

Overrides

TfrxComponent.IsContain(Extended,Extended)
See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.IsInRect(TfrxRect) Method

Summary

Returns True if part of object bounds is inside source rectangle.

Namespace: frxClass
Syntax
Delphi
public
 function IsInRect(const aRect: TfrxRect): Boolean; override;

Parameters

aRect
Type: TfrxRect

Source rectangle.

Return Value

Type: Boolean

Overrides

TfrxComponent.IsInRect(TfrxRect)
See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView Fields

Fields
Name | Description
FArrowEnd | Represents field FArrowEnd.
FArrowLength | Represents field FArrowLength.
FArrowSolid | Represents field FArrowSolid.
FArrowStart | Represents field FArrowStart.
FArrowWidth | Represents field FArrowWidth.
FColor | Represents field FColor.
FDiagonal | Represents field FDiagonal.
Top


TfrxCustomLineView.FArrowEnd Field

Summary

Represents field FArrowEnd.

Namespace: frxClass
Syntax
Delphi
private
 FArrowEnd: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.FArrowLength Field

Summary

Represents field FArrowLength.

Namespace: frxClass
Syntax
Delphi
private
 FArrowLength: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.FArrowSolid Field

Summary

Represents field FArrowSolid.

Namespace: frxClass
Syntax
Delphi
private
 FArrowSolid: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.FArrowStart Field

Summary

Represents field FArrowStart.

Namespace: frxClass
Syntax
Delphi
private
 FArrowStart: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.FArrowWidth Field

Summary

Represents field FArrowWidth.

Namespace: frxClass
Syntax
Delphi
private
 FArrowWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.FColor Field

Summary

Represents field FColor.

Namespace: frxClass
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomLineView.FDiagonal Field

Summary

Represents field FDiagonal.

Namespace: frxClass
Syntax
Delphi
private
 FDiagonal: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomLineView
  • frxClass


TfrxCustomMemoView Class

Summary

The TfrxCustomMemoView class is the base class for the "Text", "System text" and "Dot-matrix text" objects. This object represents a rectangular area with the multiline text inside.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxClass.TfrxCustomMemoView
frxCellularTextObject.TfrxCellularText
frxClass.TfrxMemoView
frxClass.TfrxSysMemoView
frxDMPClass.TfrxDMPMemoView
frxTableObject.TfrxTableCell
Syntax
Delphi
type
 TfrxCustomMemoView = class(TfrxStretcheable)
 end;

The TfrxCustomMemoView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomMemoView class. (Overrides TfrxStretcheable.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxCustomMemoView class. (Overrides TfrxView.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowExpressions | Determines if the object may contain expressions inside the text. Expressions are enclosed in the square brackets (by default). The ExpressionDelimiters defines which symbols to use for detecting the expression. Default value is True.
AllowHTMLTags | Determines if the object may contain HTML-tags inside the text. The following tags are supported: <b> - bold; <i> - italic; <u> - underline; <sub> - bottom index; <sup> - top index; <font color> - font color. Default value is False.
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
AnsiText | Text of the object in ANSI format based on current Locale settings.
AutoWidth | Determines if the text object should handle its width automatically.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
CanShrink | True if object can shrink height base on its content. (Inherited from TfrxStretcheable.)
CharSpacing | Character spacing, in pixels. Default value is 0.
Clipped | Determines whether to clip the text on object's bounds.
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor.
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DisplayFormat | Deprecated(Check Formats property). Format settings. Used for formatting expression's values or DB fields which object is linked to.
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Duplicates | Determines how to process repeated values. Default value is dmShow.
ExpressionDelimiters | Set of symbols, designating the expression. Default value is '[,]'. The comma divides opening and closing symbols. There is one limitation however: the opening and closing symbols cannot be similar, so '%,%' will not work. One can set several symbols, for example '<%,%>'.
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
FirstParaBreak | Internal use. Determines first paragraph break if object where split.
FlowTo | Link to the "Text" object that will be used for displaying the textthat not fit in this object. The linked object should have the samefont settings as the main object. You also should place the linkedobject after the main object.
Font | Object's font. (Inherited from TfrxComponent.)
Formats | Collection of Formats. The object can hold several formats for each expression inside an object.
Frame | Object's frame. (Inherited from TfrxView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GapX | Gap between text and left and right edges of object, in pixels. Default value is 2.
GapY | Gap between text and top and bottom edges of object, in pixels. Default value is 1.
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
HAlign | The horizontal text alignment.
Height | Represents property Height. (Inherited from TfrxView.)
HideZeros | Determines whether to show the zero values of expressions or DB fields. Default value is True.
Highlight | Deprecated(see Highlights property). Conditional highlight settings. The hightlight allows changing the appearance of the object depending on some condition.
Highlights | Collection of Highlights. The object can hold several highlights which serves different conditions.
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LastParaBreak | Internal use. Determines last paragraph break if object where split.
Left | Represents property Left. (Inherited from TfrxView.)
Lines | Text lines of the object.
LineSpacing | Spacing between text lines, in pixels. Default value is 2.
Memo | Text lines of the object.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
ParagraphGap | Paragraph gap, in pixels. Default value is 0.
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
Rotation | Determines the text rotation, in degrees. Valid values are 0..360.
RTLReading | Used to print text right-to-left for far-east languages.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StretchMode | Object's stretch mode. (Inherited from TfrxStretcheable.)
Style | Name of the object's style. Styles are stored in the TfrxReport.Styles.
SuppressRepeated | Deprecated(See Duplicates property). Determines if it hides repeated values. Default value is False.
TagStr | Represents property TagStr.
Text | Text of the object.
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Underlines | Deprecated(See UnderlinesTextMode property). Determines whether to show underlines under each text string. Default value is False.
UnderlinesTextMode | Determines how to show underlines in text object. Default value is ulmNone.
URL | Represents property URL.
UseDefaultCharset | Use Unicode during export even if Font Charset is selected.
VAlign | The vertical text alignment.
Value | Stores value of Format operation(for single expression or DataSet only) with respect of its type.
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
WordBreak | Determines whether to break russian words. Default value is False.
WordWrap | Determines whether the text object inserts soft carriage returns so text wraps at the right margin. Default value is True.
Wysiwyg | Determines whether to use printer canvas to arrange the text more accurately. If set to False, you cannot use the "width align" mode.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AdjustCalcHeight | Represents method AdjustCalcHeight.
AdjustCalcWidth | Represents method AdjustCalcWidth.
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxView.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
ApplyHighlight(TfrxHighlight) | Apply Highlight to object.
ApplyPreviewHighlight | Apply active highlight for object in prepared report.
ApplyStyle(TfrxStyleItem) | Applies the given style to the object.
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Overrides TfrxView.BeginDraw(TCanvas,Extended,Extended,Extended,Extended).)
CalcAndFormat(WideString,TfrxFormat) | Represents method CalcAndFormat(WideString,TfrxFormat).
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxStretcheable.CalcHeight.)
CalcTextRect(Extended,Extended,Extended,Extended) | Represents method CalcTextRect(Extended,Extended,Extended,Extended).
CalcWidth | Calculates and returns the object's width, in pixels.
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxStretcheable.DrawPart.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawText | Represents method DrawText.
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
ExtractMacros(TfrxPostProcessor) | Extract macros from the object text and replaces them with values.
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
FormatData(Variant,TfrxFormat) | Formats the value passed in the "Value" parameter and returns the result as a string. This method is used format settings stored in the DisplayFormat property. If AFormat parameter is set, it is used for formatting instead of DisplayFormat property.
GetAnsiText | Represents method GetAnsiText.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Overrides TfrxReportComponent.GetComponentText.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDisplayFormat | Represents method GetDisplayFormat.
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetHighlight | Represents method GetHighlight.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetText | Represents method GetText.
GetUnderlines | Represents method GetUnderlines.
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Inherited from TfrxStretcheable.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object. (Overrides TfrxStretcheable.InitPart.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsCharSpacingStored | Represents method IsCharSpacingStored.
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsDisplayFormatStored | Represents method IsDisplayFormatStored.
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsExprDelimitersStored | Represents method IsExprDelimitersStored.
IsGapXStored | Represents method IsGapXStored.
IsGapYStored | Represents method IsGapYStored.
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsHighlightStored | Represents method IsHighlightStored.
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsLineSpacingStored | Represents method IsLineSpacingStored.
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsParagraphGapStored | Represents method IsParagraphGapStored.
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Overrides TfrxView.IsPostProcessAllowed.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
Loaded | Represents method Loaded.
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxView.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
ReadFormats(TReader) | Represents method ReadFormats(TReader).
ReadHighlights(TReader) | Represents method ReadHighlights(TReader).
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.ReadNestedProperty(TfrxXMLItem).)
ReducedAngle | Normalize angle to 360 degrees.
ResetSuppress | Deprecated. Reset suppressed values.
RestorePreHighlightState | Represents method RestorePreHighlightState.
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SavePreHighlightState | Represents method SavePreHighlightState.
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetAnsiText(AnsiString) | Represents method SetAnsiText(AnsiString).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetDisplayFormat(TfrxFormat) | Represents method SetDisplayFormat(TfrxFormat).
SetDrawParams(TCanvas,Extended,Extended,Extended,Extended) | Represents method SetDrawParams(TCanvas,Extended,Extended,Extended,Extended).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetHighlight(TfrxHighlight) | Represents method SetHighlight(TfrxHighlight).
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetMemo(TWideStrings) | Represents method SetMemo(TWideStrings).
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetRotation(Integer) | Represents method SetRotation(Integer).
SetStyle(String) | Represents method SetStyle(String).
SetText(WideString) | Represents method SetText(WideString).
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetUnderlines(Boolean) | Represents method SetUnderlines(Boolean).
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WrapText(Boolean,TWideStrings) | Breaks the text so all strings would fit in the object's width, and returns the resulting text.
WriteFormats(TWriter) | Represents method WriteFormats(TWriter).
WriteHighlights(TWriter) | Represents method WriteHighlights(TWriter).
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.WriteNestedProperties(TfrxXMLItem,TPersistent).)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAllowExpressions | Represents field FAllowExpressions.
FAllowHTMLTags | Represents field FAllowHTMLTags.
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FAutoWidth | Represents field FAutoWidth.
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FCharSpacing | Represents field FCharSpacing.
FClipped | Represents field FClipped.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCopyNo | Represents field FCopyNo.
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDuplicates | Represents field FDuplicates.
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FExpressionDelimiters | Represents field FExpressionDelimiters.
FFirstParaBreak | Represents field FFirstParaBreak.
FFlowTo | Represents field FFlowTo.
FFormats | Represents field FFormats.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FGapX | Represents field FGapX.
FGapY | Represents field FGapY.
FHAlign | Represents field FHAlign.
FHideZeros | Represents field FHideZeros.
FHighlightActivated | Represents field FHighlightActivated.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FHighlights | Represents field FHighlights.
FLastParaBreak | Represents field FLastParaBreak.
FLastValue | Represents field FLastValue.
FLineSpacing | Represents field FLineSpacing.
FMacroIndex | Represents field FMacroIndex.
FMacroLine | Represents field FMacroLine.
FMacroLoaded | Represents field FMacroLoaded.
FMemo | Represents field FMemo.
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParagraphGap | Represents field FParagraphGap.
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPartMemo | Represents field FPartMemo.
FPrintScale | Represents field FPrintScale.
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FRotation | Represents field FRotation.
FRTLReading | Represents field FRTLReading.
FSavedTop | Internal use only. Stores original top during shift operation. (Inherited from TfrxStretcheable.)
FSaveHeight | Internal use only. Stores object Height during stretch operation. (Inherited from TfrxStretcheable.)
FScaledRect | Represents field FScaledRect.
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStyle | Represents field FStyle.
FSuppressRepeated | Represents field FSuppressRepeated.
FTempFill | Represents field FTempFill.
FTempFont | Represents field FTempFont.
FTempFrame | Represents field FTempFrame.
FTempMemo | Represents field FTempMemo.
FTempVisible | Represents field FTempVisible.
FTextRect | Represents field FTextRect.
FTotalPages | Represents field FTotalPages.
FUnderlinesTextMode | Represents field FUnderlinesTextMode.
FUseDefaultCharset | Represents field FUseDefaultCharset.
FVAlign | Represents field FVAlign.
FValue | Represents field FValue.
FVC | Represents field FVC. (Inherited from TfrxView.)
FWordBreak | Represents field FWordBreak.
FWordWrap | Represents field FWordWrap.
FWysiwyg | Represents field FWysiwyg.
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxClass


TfrxCustomMemoView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomMemoView class. (Overrides TfrxStretcheable.Create(TComponent).)
Destroy | Represents the destructor of the TfrxCustomMemoView class. (Overrides TfrxView.Destroy.)
Top


TfrxCustomMemoView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomMemoView class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxStretcheable.Create(TComponent)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomMemoView class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxView.Destroy
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView Properties

Properties
Name | Description
AllowExpressions | Determines if the object may contain expressions inside the text. Expressions are enclosed in the square brackets (by default). The ExpressionDelimiters defines which symbols to use for detecting the expression. Default value is True.
AllowHTMLTags | Determines if the object may contain HTML-tags inside the text. The following tags are supported: <b> - bold; <i> - italic; <u> - underline; <sub> - bottom index; <sup> - top index; <font color> - font color. Default value is False.
AnsiText | Text of the object in ANSI format based on current Locale settings.
AutoWidth | Determines if the text object should handle its width automatically.
CharSpacing | Character spacing, in pixels. Default value is 0.
Clipped | Determines whether to clip the text on object's bounds.
Cursor | Represents property Cursor.
DisplayFormat | Deprecated(Check Formats property). Format settings. Used for formatting expression's values or DB fields which object is linked to.
Duplicates | Determines how to process repeated values. Default value is dmShow.
ExpressionDelimiters | Set of symbols, designating the expression. Default value is '[,]'. The comma divides opening and closing symbols. There is one limitation however: the opening and closing symbols cannot be similar, so '%,%' will not work. One can set several symbols, for example '<%,%>'.
FirstParaBreak | Internal use. Determines first paragraph break if object where split.
FlowTo | Link to the "Text" object that will be used for displaying the textthat not fit in this object. The linked object should have the samefont settings as the main object. You also should place the linkedobject after the main object.
Formats | Collection of Formats. The object can hold several formats for each expression inside an object.
GapX | Gap between text and left and right edges of object, in pixels. Default value is 2.
GapY | Gap between text and top and bottom edges of object, in pixels. Default value is 1.
HAlign | The horizontal text alignment.
HideZeros | Determines whether to show the zero values of expressions or DB fields. Default value is True.
Highlight | Deprecated(see Highlights property). Conditional highlight settings. The hightlight allows changing the appearance of the object depending on some condition.
Highlights | Collection of Highlights. The object can hold several highlights which serves different conditions.
LastParaBreak | Internal use. Determines last paragraph break if object where split.
Lines | Text lines of the object.
LineSpacing | Spacing between text lines, in pixels. Default value is 2.
Memo | Text lines of the object.
ParagraphGap | Paragraph gap, in pixels. Default value is 0.
Rotation | Determines the text rotation, in degrees. Valid values are 0..360.
RTLReading | Used to print text right-to-left for far-east languages.
Style | Name of the object's style. Styles are stored in the TfrxReport.Styles.
SuppressRepeated | Deprecated(See Duplicates property). Determines if it hides repeated values. Default value is False.
TagStr | Represents property TagStr.
Text | Text of the object.
Underlines | Deprecated(See UnderlinesTextMode property). Determines whether to show underlines under each text string. Default value is False.
UnderlinesTextMode | Determines how to show underlines in text object. Default value is ulmNone.
URL | Represents property URL.
UseDefaultCharset | Use Unicode during export even if Font Charset is selected.
VAlign | The vertical text alignment.
Value | Stores value of Format operation(for single expression or DataSet only) with respect of its type.
WordBreak | Determines whether to break russian words. Default value is False.
WordWrap | Determines whether the text object inserts soft carriage returns so text wraps at the right margin. Default value is True.
Wysiwyg | Determines whether to use printer canvas to arrange the text more accurately. If set to False, you cannot use the "width align" mode.
Top


TfrxCustomMemoView.AllowExpressions Property

Summary

Determines if the object may contain expressions inside the text. Expressions are enclosed in the square brackets (by default). The ExpressionDelimiters defines which symbols to use for detecting the expression. Default value is True.

Namespace: frxClass
Syntax
Delphi
public
 property AllowExpressions: Boolean read FAllowExpressions write FAllowExpressions default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.AllowHTMLTags Property

Summary

Determines if the object may contain HTML-tags inside the text.
The following tags are supported:
<b> - bold;
<i> - italic;
<u> - underline;
<sub> - bottom index;
<sup> - top index;
<font color> - font color.
Default value is False.

Namespace: frxClass
Syntax
Delphi
public
 property AllowHTMLTags: Boolean read FAllowHTMLTags write FAllowHTMLTags default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.AnsiText Property

Summary

Text of the object in ANSI format based on current Locale settings.

Namespace: frxClass
Syntax
Delphi
public
 property AnsiText: AnsiString read GetAnsiText write SetAnsiText;

Property Value

Type: AnsiString

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.AutoWidth Property

Summary

Determines if the text object should handle its width automatically.

Namespace: frxClass
Syntax
Delphi
public
 property AutoWidth: Boolean read FAutoWidth write FAutoWidth default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.CharSpacing Property

Summary

Character spacing, in pixels. Default value is 0.

Namespace: frxClass
Syntax
Delphi
public
 property CharSpacing: Extended read FCharSpacing write FCharSpacing stored IsCharSpacingStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Clipped Property

Summary

Determines whether to clip the text on object's bounds.

Namespace: frxClass
Syntax
Delphi
public
 property Clipped: Boolean read FClipped write FClipped default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Cursor Property

Summary

Represents property Cursor.

Namespace: frxClass
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.DisplayFormat Property

Summary

Deprecated(Check Formats property). Format settings. Used for formatting expression's values
or DB fields which object is linked to.

Namespace: frxClass
Syntax
Delphi
public
 property DisplayFormat: TfrxFormat read GetDisplayFormat write SetDisplayFormat stored IsDisplayFormatStored;

Property Value

Type: TfrxFormat

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Duplicates Property

Summary

Determines how to process repeated values. Default value is dmShow.

Namespace: frxClass
Syntax
Delphi
public
 property Duplicates: TfrxDuplicateMerge read FDuplicates write FDuplicates default dmShow;

Property Value

Type: TfrxDuplicateMerge

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.ExpressionDelimiters Property

Summary

Set of symbols, designating the expression. Default value is '[,]'. The comma divides opening and closing symbols. There is one limitation however: the opening and closing symbols cannot be similar, so '%,%' will not work. One can set several symbols, for example '<%,%>'.

Namespace: frxClass
Syntax
Delphi
public
 property ExpressionDelimiters: String read FExpressionDelimiters
 write FExpressionDelimiters stored IsExprDelimitersStored;

Property Value

Type: String

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FirstParaBreak Property

Summary

Internal use. Determines first paragraph break if object where split.

Namespace: frxClass
Syntax
Delphi
published
 property FirstParaBreak: Boolean read FFirstParaBreak write FFirstParaBreak default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FlowTo Property

Summary

Link to the "Text" object that will be used for displaying the textthat not fit in this object. The linked object should have the samefont settings as the main object. You also should place the linkedobject after the main object.

Namespace: frxClass
Syntax
Delphi
public
 property FlowTo: TfrxCustomMemoView read FFlowTo write FFlowTo;

Property Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Formats Property

Summary

Collection of Formats. The object can hold several formats for each expression inside an object.

Namespace: frxClass
Syntax
Delphi
public
 property Formats: TfrxFormatCollection read FFormats;

Property Value

Type: TfrxFormatCollection

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.GapX Property

Summary

Gap between text and left and right edges of object, in pixels. Default value is 2.

Namespace: frxClass
Syntax
Delphi
public
 property GapX: Extended read FGapX write FGapX stored IsGapXStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.GapY Property

Summary

Gap between text and top and bottom edges of object, in pixels. Default value is 1.

Namespace: frxClass
Syntax
Delphi
public
 property GapY: Extended read FGapY write FGapY stored IsGapYStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.HAlign Property

Summary

The horizontal text alignment.

Namespace: frxClass
Syntax
Delphi
public
 property HAlign: TfrxHAlign read FHAlign write FHAlign default haLeft;

Property Value

Type: TfrxHAlign

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.HideZeros Property

Summary

Determines whether to show the zero values of expressions or DB fields. Default value is True.

Namespace: frxClass
Syntax
Delphi
public
 property HideZeros: Boolean read FHideZeros write FHideZeros default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Highlight Property

Summary

Deprecated(see Highlights property). Conditional highlight settings. The hightlight allows
changing the appearance of the object depending on some condition.

Namespace: frxClass
Syntax
Delphi
public
 property Highlight: TfrxHighlight read GetHighlight write SetHighlight stored IsHighlightStored;

Property Value

Type: TfrxHighlight

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Highlights Property

Summary

Collection of Highlights. The object can hold several highlights which serves different conditions.

Namespace: frxClass
Syntax
Delphi
public
 property Highlights: TfrxHighlightCollection read FHighlights;

Property Value

Type: TfrxHighlightCollection

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.LastParaBreak Property

Summary

Internal use. Determines last paragraph break if object where split.

Namespace: frxClass
Syntax
Delphi
published
 property LastParaBreak: Boolean read FLastParaBreak write FLastParaBreak default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Lines Property

Summary

Text lines of the object.

Namespace: frxClass
Syntax
Delphi
public
 property Lines: TWideStrings read FMemo write SetMemo;

Property Value

Type: TWideStrings

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.LineSpacing Property

Summary

Spacing between text lines, in pixels. Default value is 2.

Namespace: frxClass
Syntax
Delphi
public
 property LineSpacing: Extended read FLineSpacing write FLineSpacing stored IsLineSpacingStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Memo Property

Summary

Text lines of the object.

Namespace: frxClass
Syntax
Delphi
public
 property Memo: TWideStrings read FMemo write SetMemo;

Property Value

Type: TWideStrings

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.ParagraphGap Property

Summary

Paragraph gap, in pixels. Default value is 0.

Namespace: frxClass
Syntax
Delphi
public
 property ParagraphGap: Extended read FParagraphGap write FParagraphGap stored IsParagraphGapStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Rotation Property

Summary

Determines the text rotation, in degrees. Valid values are 0..360.

Namespace: frxClass
Syntax
Delphi
public
 property Rotation: Integer read FRotation write SetRotation default 0;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.RTLReading Property

Summary

Used to print text right-to-left for far-east languages.

Namespace: frxClass
Syntax
Delphi
public
 property RTLReading: Boolean read FRTLReading write FRTLReading default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Style Property

Summary

Name of the object's style. Styles are stored in the TfrxReport.Styles.

Namespace: frxClass
Syntax
Delphi
public
 property Style: String read FStyle write SetStyle;

Property Value

Type: String

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.SuppressRepeated Property

Summary

Deprecated(See Duplicates property). Determines if it hides repeated values. Default value is False.

Namespace: frxClass
Syntax
Delphi
public
 property SuppressRepeated: Boolean read FSuppressRepeated write FSuppressRepeated default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.TagStr Property

Summary

Represents property TagStr.

Namespace: frxClass
Syntax
Delphi
published
 property TagStr;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Text Property

Summary

Text of the object.

Namespace: frxClass
Syntax
Delphi
public
 property Text: WideString read GetText write SetText;

Property Value

Type: WideString

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Underlines Property

Summary

Deprecated(See UnderlinesTextMode property). Determines whether to show underlines under each text string. Default value is False.

Namespace: frxClass
Syntax
Delphi
public
 property Underlines: Boolean read GetUnderlines write SetUnderlines default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.UnderlinesTextMode Property

Summary

Determines how to show underlines in text object. Default value is ulmNone.

Namespace: frxClass
Syntax
Delphi
public
 property UnderlinesTextMode: TfrxUnderlinesTextMode read FUnderlinesTextMode write FUnderlinesTextMode default ulmNone;

Property Value

Type: TfrxUnderlinesTextMode

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.URL Property

Summary

Represents property URL.

Namespace: frxClass
Syntax
Delphi
published
 property URL;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.UseDefaultCharset Property

Summary

Use Unicode during export even if Font Charset is selected.

Namespace: frxClass
Syntax
Delphi
public
 property UseDefaultCharset: Boolean read FUseDefaultCharset write FUseDefaultCharset default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.VAlign Property

Summary

The vertical text alignment.

Namespace: frxClass
Syntax
Delphi
public
 property VAlign: TfrxVAlign read FVAlign write FVAlign default vaTop;

Property Value

Type: TfrxVAlign

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Value Property

Summary

Stores value of Format operation(for single expression or DataSet only) with respect of its type.

Namespace: frxClass
Syntax
Delphi
public
 property Value: Variant read FValue write FValue;

Property Value

Type: Variant

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.WordBreak Property

Summary

Determines whether to break russian words. Default value is False.

Namespace: frxClass
Syntax
Delphi
public
 property WordBreak: Boolean read FWordBreak write FWordBreak default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.WordWrap Property

Summary

Determines whether the text object inserts soft carriage returns so text wraps at the right margin. Default value is True.

Namespace: frxClass
Syntax
Delphi
public
 property WordWrap: Boolean read FWordWrap write FWordWrap default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Wysiwyg Property

Summary

Determines whether to use printer canvas to arrange the text more accurately. If set to False, you cannot use the "width align" mode.

Namespace: frxClass
Syntax
Delphi
public
 property Wysiwyg: Boolean read FWysiwyg write FWysiwyg default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView Methods

Methods
Name | Description
AdjustCalcHeight | Represents method AdjustCalcHeight.
AdjustCalcWidth | Represents method AdjustCalcWidth.
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxView.AfterPrint.)
ApplyHighlight(TfrxHighlight) | Apply Highlight to object.
ApplyPreviewHighlight | Apply active highlight for object in prepared report.
ApplyStyle(TfrxStyleItem) | Applies the given style to the object.
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Overrides TfrxView.BeginDraw(TCanvas,Extended,Extended,Extended,Extended).)
CalcAndFormat(WideString,TfrxFormat) | Represents method CalcAndFormat(WideString,TfrxFormat).
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxStretcheable.CalcHeight.)
CalcTextRect(Extended,Extended,Extended,Extended) | Represents method CalcTextRect(Extended,Extended,Extended,Extended).
CalcWidth | Calculates and returns the object's width, in pixels.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxStretcheable.DrawPart.)
DrawText | Represents method DrawText.
ExtractMacros(TfrxPostProcessor) | Extract macros from the object text and replaces them with values.
FormatData(Variant,TfrxFormat) | Formats the value passed in the "Value" parameter and returns the result as a string. This method is used format settings stored in the DisplayFormat property. If AFormat parameter is set, it is used for formatting instead of DisplayFormat property.
GetAnsiText | Represents method GetAnsiText.
GetComponentText | Returns text of the report object. Used in export filters. (Overrides TfrxReportComponent.GetComponentText.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDisplayFormat | Represents method GetDisplayFormat.
GetHighlight | Represents method GetHighlight.
GetText | Represents method GetText.
GetUnderlines | Represents method GetUnderlines.
InitPart | Initialize part of Splittable object. (Overrides TfrxStretcheable.InitPart.)
IsCharSpacingStored | Represents method IsCharSpacingStored.
IsDisplayFormatStored | Represents method IsDisplayFormatStored.
IsExprDelimitersStored | Represents method IsExprDelimitersStored.
IsGapXStored | Represents method IsGapXStored.
IsGapYStored | Represents method IsGapYStored.
IsHighlightStored | Represents method IsHighlightStored.
IsLineSpacingStored | Represents method IsLineSpacingStored.
IsParagraphGapStored | Represents method IsParagraphGapStored.
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Overrides TfrxView.IsPostProcessAllowed.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
Loaded | Represents method Loaded.
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxView.MirrorContent(TfrxMirrorControlModes).)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
ReadFormats(TReader) | Represents method ReadFormats(TReader).
ReadHighlights(TReader) | Represents method ReadHighlights(TReader).
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.ReadNestedProperty(TfrxXMLItem).)
ReducedAngle | Normalize angle to 360 degrees.
ResetSuppress | Deprecated. Reset suppressed values.
RestorePreHighlightState | Represents method RestorePreHighlightState.
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SavePreHighlightState | Represents method SavePreHighlightState.
SetAnsiText(AnsiString) | Represents method SetAnsiText(AnsiString).
SetDisplayFormat(TfrxFormat) | Represents method SetDisplayFormat(TfrxFormat).
SetDrawParams(TCanvas,Extended,Extended,Extended,Extended) | Represents method SetDrawParams(TCanvas,Extended,Extended,Extended,Extended).
SetHighlight(TfrxHighlight) | Represents method SetHighlight(TfrxHighlight).
SetMemo(TWideStrings) | Represents method SetMemo(TWideStrings).
SetRotation(Integer) | Represents method SetRotation(Integer).
SetStyle(String) | Represents method SetStyle(String).
SetText(WideString) | Represents method SetText(WideString).
SetUnderlines(Boolean) | Represents method SetUnderlines(Boolean).
WrapText(Boolean,TWideStrings) | Breaks the text so all strings would fit in the object's width, and returns the resulting text.
WriteFormats(TWriter) | Represents method WriteFormats(TWriter).
WriteHighlights(TWriter) | Represents method WriteHighlights(TWriter).
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.WriteNestedProperties(TfrxXMLItem,TPersistent).)
Top


TfrxCustomMemoView.AdjustCalcHeight Method

Summary

Represents method AdjustCalcHeight.

Namespace: frxClass
Syntax
Delphi
private
 function AdjustCalcHeight: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.AdjustCalcWidth Method

Summary

Represents method AdjustCalcWidth.

Namespace: frxClass
Syntax
Delphi
private
 function AdjustCalcWidth: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.AfterPrint Method

Summary

The report engine calls this method after object was prepared and placed to preview pages.

Namespace: frxClass
Syntax
Delphi
public
 procedure AfterPrint; override;

Overrides

TfrxView.AfterPrint
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.ApplyHighlight(TfrxHighlight) Method

Summary

Apply Highlight to object.

Namespace: frxClass
Syntax
Delphi
public
 procedure ApplyHighlight(AHighlight: TfrxHighlight);

Parameters

AHighlight
Type: TfrxHighlight

Highlight.

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.ApplyPreviewHighlight Method

Summary

Apply active highlight for object in prepared report.

Namespace: frxClass
Syntax
Delphi
public
 procedure ApplyPreviewHighlight;
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.ApplyStyle(TfrxStyleItem) Method

Summary

Applies the given style to the object.

Namespace: frxClass
Syntax
Delphi
public
 procedure ApplyStyle(Style: TfrxStyleItem);

Parameters

Style
Type: TfrxStyleItem

Style.

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.BeforePrint Method

Summary

The report engine calls this method before prepare object and place it to preview pages.

Namespace: frxClass
Syntax
Delphi
public
 procedure BeforePrint; override;

Overrides

TfrxView.BeforePrint
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.BeginDraw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure BeginDraw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

ScaleX
Type: Extended

ScaleY
Type: Extended

OffsetX
Type: Extended

OffsetY
Type: Extended

Overrides

TfrxView.BeginDraw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.CalcAndFormat(WideString,TfrxFormat) Method

Summary

Represents method CalcAndFormat(WideString,TfrxFormat).

Namespace: frxClass
Syntax
Delphi
protected
 function CalcAndFormat(const Expr: WideString; Format: TfrxFormat): WideString;

Parameters

Expr
Type: WideString

Format
Type: TfrxFormat

Return Value

Type: WideString

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.CalcHeight Method

Summary

Calculates and returns the object's height according to the data placed in it.

Namespace: frxClass
Syntax
Delphi
public
 function CalcHeight: Extended; override;

Return Value

Type: Extended

Overrides

TfrxStretcheable.CalcHeight
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.CalcTextRect(Extended,Extended,Extended,Extended) Method

Summary

Represents method CalcTextRect(Extended,Extended,Extended,Extended).

Namespace: frxClass
Syntax
Delphi
protected
 function CalcTextRect(OffsetX, OffsetY, ScaleX, ScaleY: Extended): TRect;

Parameters

OffsetX
Type: Extended

OffsetY
Type: Extended

ScaleX
Type: Extended

ScaleY
Type: Extended

Return Value

Type: TRect

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.CalcWidth Method

Summary

Calculates and returns the object's width, in pixels.

Namespace: frxClass
Syntax
Delphi
public
 function CalcWidth: Extended; virtual;

Return Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxClass
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Diff(TfrxComponent) Method

Summary

Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set.

Namespace: frxClass
Syntax
Delphi
public
 function Diff(AComponent: TfrxComponent): String; override;

Parameters

AComponent
Type: TfrxComponent

Return Value

Type: String

Overrides

TfrxView.Diff(TfrxComponent)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
public
 procedure DoMouseEnter(aPreviousObject: TfrxComponent; var EventParams: TfrxInteractiveEventsParams); override;

Parameters

aPreviousObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).

Namespace: frxClass
Syntax
Delphi
public
 procedure DoMouseLeave(aNextObject: TfrxComponent; var EventParams: TfrxInteractiveEventsParams); override;

Parameters

aNextObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.DrawPart Method

Summary

Objects part drawing function , if the object is splittable.

Namespace: frxClass
Syntax
Delphi
public
 function DrawPart: Extended; override;

Return Value

Type: Extended

Overrides

TfrxStretcheable.DrawPart
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.DrawText Method

Summary

Represents method DrawText.

Namespace: frxClass
Syntax
Delphi
protected
 procedure DrawText;
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.ExtractMacros(TfrxPostProcessor) Method

Summary

Extract macros from the object text and replaces them with values.

Namespace: frxClass
Syntax
Delphi
public
 procedure ExtractMacros(Dictionary: TfrxPostProcessor = nil);

Parameters

Dictionary
Type: TfrxPostProcessor

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FormatData(Variant,TfrxFormat) Method

Summary

Formats the value passed in the "Value" parameter and returns the result as a string. This method is used format settings stored in the DisplayFormat property. If AFormat parameter is set, it is used for formatting instead of DisplayFormat property.

Namespace: frxClass
Syntax
Delphi
public
 function FormatData(const Value: Variant; AFormat: TfrxFormat = nil): WideString;

Parameters

Value
Type: Variant

AFormat
Type: TfrxFormat

Return Value

Type: WideString

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.GetAnsiText Method

Summary

Represents method GetAnsiText.

Namespace: frxClass
Syntax
Delphi
private
 function GetAnsiText: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.GetComponentText Method

Summary

Returns text of the report object. Used in export filters.

Namespace: frxClass
Syntax
Delphi
public
 function GetComponentText: String; override;

Return Value

Type: String

Overrides

TfrxReportComponent.GetComponentText
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxClass
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.GetDisplayFormat Method

Summary

Represents method GetDisplayFormat.

Namespace: frxClass
Syntax
Delphi
private
 function GetDisplayFormat: TfrxFormat;

Return Value

Type: TfrxFormat

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.GetHighlight Method

Summary

Represents method GetHighlight.

Namespace: frxClass
Syntax
Delphi
private
 function GetHighlight: TfrxHighlight;

Return Value

Type: TfrxHighlight

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.GetText Method

Summary

Represents method GetText.

Namespace: frxClass
Syntax
Delphi
private
 function GetText: WideString;

Return Value

Type: WideString

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.GetUnderlines Method

Summary

Represents method GetUnderlines.

Namespace: frxClass
Syntax
Delphi
private
 function GetUnderlines: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.InitPart Method

Summary

Initialize part of Splittable object.

Namespace: frxClass
Syntax
Delphi
public
 procedure InitPart; override;

Overrides

TfrxStretcheable.InitPart
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.IsCharSpacingStored Method

Summary

Represents method IsCharSpacingStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsCharSpacingStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.IsDisplayFormatStored Method

Summary

Represents method IsDisplayFormatStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsDisplayFormatStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.IsExprDelimitersStored Method

Summary

Represents method IsExprDelimitersStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsExprDelimitersStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.IsGapXStored Method

Summary

Represents method IsGapXStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsGapXStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.IsGapYStored Method

Summary

Represents method IsGapYStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsGapYStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.IsHighlightStored Method

Summary

Represents method IsHighlightStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsHighlightStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.IsLineSpacingStored Method

Summary

Represents method IsLineSpacingStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsLineSpacingStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.IsParagraphGapStored Method

Summary

Represents method IsParagraphGapStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsParagraphGapStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.IsPostProcessAllowed Method

Summary

Return True when post processing for current object is enabled (Default ProcessAt <> paDefault).

Namespace: frxClass
Syntax
Delphi
public
 function IsPostProcessAllowed: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxView.IsPostProcessAllowed
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) Method

Summary

Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call.

Namespace: frxClass
Syntax
Delphi
public
 function LoadContentFromDictionary(aReport: TfrxReport; aItem: TfrxMacrosItem): Boolean; override;

Parameters

aReport
Type: TfrxReport

Reference to the report object.

aItem
Type: TfrxMacrosItem

TfrxMacrosItem which stores processed data for current object.

Return Value

Type: Boolean

Overrides

TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Loaded Method

Summary

Represents method Loaded.

Namespace: frxClass
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.MirrorContent(TfrxMirrorControlModes) Method

Summary

Represents method MirrorContent(TfrxMirrorControlModes).

Namespace: frxClass
Syntax
Delphi
public
 procedure MirrorContent(MirrorModes: TfrxMirrorControlModes); override;

Parameters

MirrorModes
Type: TfrxMirrorControlModes

Overrides

TfrxView.MirrorContent(TfrxMirrorControlModes)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: frxClass
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

Overrides

TfrxView.Notification(TComponent,TOperation)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) Method

Summary

The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from
PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary.

Namespace: frxClass
Syntax
Delphi
public
 procedure ProcessDictionary(aItem: TfrxMacrosItem; aReport: TfrxReport; PostProcessor: TfrxPostProcessor); override;

Parameters

aItem
Type: TfrxMacrosItem

aReport
Type: TfrxReport

PostProcessor
Type: TfrxPostProcessor

Overrides

TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.ReadFormats(TReader) Method

Summary

Represents method ReadFormats(TReader).

Namespace: frxClass
Syntax
Delphi
private
 procedure ReadFormats(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.ReadHighlights(TReader) Method

Summary

Represents method ReadHighlights(TReader).

Namespace: frxClass
Syntax
Delphi
private
 procedure ReadHighlights(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.ReadNestedProperty(TfrxXMLItem) Method

Summary

The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData).

Namespace: frxClass
Syntax
Delphi
public
 function ReadNestedProperty(Item: TfrxXmlItem): Boolean; override;

Parameters

Item
Type: TfrxXmlItem

Return Value

Type: Boolean

Overrides

TfrxComponent.ReadNestedProperty(TfrxXMLItem)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.ReducedAngle Method

Summary

Normalize angle to 360 degrees.

Namespace: frxClass
Syntax
Delphi
public
 function ReducedAngle: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.ResetSuppress Method

Summary

Deprecated. Reset suppressed values.

Namespace: frxClass
Syntax
Delphi
public
 procedure ResetSuppress;
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.RestorePreHighlightState Method

Summary

Represents method RestorePreHighlightState.

Namespace: frxClass
Syntax
Delphi
private
 procedure RestorePreHighlightState;
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor) Method

Summary

This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveContentToDictionary(aReport: TfrxReport; PostProcessor: TfrxPostProcessor); override;

Parameters

aReport
Type: TfrxReport

Reference to the report object.

PostProcessor
Type: TfrxPostProcessor

Reference to TfrxPostProcessor instance of post processing manager.

Overrides

TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.SavePreHighlightState Method

Summary

Represents method SavePreHighlightState.

Namespace: frxClass
Syntax
Delphi
private
 procedure SavePreHighlightState;
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.SetAnsiText(AnsiString) Method

Summary

Represents method SetAnsiText(AnsiString).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetAnsiText(const Value: AnsiString);

Parameters

Value
Type: AnsiString

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.SetDisplayFormat(TfrxFormat) Method

Summary

Represents method SetDisplayFormat(TfrxFormat).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDisplayFormat(const Value: TfrxFormat);

Parameters

Value
Type: TfrxFormat

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.SetDrawParams(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

Represents method SetDrawParams(TCanvas,Extended,Extended,Extended,Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetDrawParams(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended);

Parameters

Canvas
Type: TCanvas

ScaleX
Type: Extended

ScaleY
Type: Extended

OffsetX
Type: Extended

OffsetY
Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.SetHighlight(TfrxHighlight) Method

Summary

Represents method SetHighlight(TfrxHighlight).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetHighlight(const Value: TfrxHighlight);

Parameters

Value
Type: TfrxHighlight

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.SetMemo(TWideStrings) Method

Summary

Represents method SetMemo(TWideStrings).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetMemo(const Value: TWideStrings);

Parameters

Value
Type: TWideStrings

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.SetRotation(Integer) Method

Summary

Represents method SetRotation(Integer).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetRotation(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.SetStyle(String) Method

Summary

Represents method SetStyle(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetStyle(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.SetText(WideString) Method

Summary

Represents method SetText(WideString).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetText(const Value: WideString);

Parameters

Value
Type: WideString

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.SetUnderlines(Boolean) Method

Summary

Represents method SetUnderlines(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetUnderlines(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.WrapText(Boolean,TWideStrings) Method

Summary

Breaks the text so all strings would fit in the object's width, and returns the resulting text.

Namespace: frxClass
Syntax
Delphi
public
 function WrapText(WrapWords: Boolean; aParaText: TWideStrings = nil): WideString;

Parameters

WrapWords
Type: Boolean

Wrap words if possible.

aParaText
Type: TWideStrings

If not nil , holds result of function in TWideStrings with paragraph marks.

Return Value

Type: WideString

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.WriteFormats(TWriter) Method

Summary

Represents method WriteFormats(TWriter).

Namespace: frxClass
Syntax
Delphi
private
 procedure WriteFormats(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.WriteHighlights(TWriter) Method

Summary

Represents method WriteHighlights(TWriter).

Namespace: frxClass
Syntax
Delphi
private
 procedure WriteHighlights(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.WriteNestedProperties(TfrxXMLItem,TPersistent) Method

Summary

The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData).

Namespace: frxClass
Syntax
Delphi
public
 procedure WriteNestedProperties(Item: TfrxXmlItem; aAcenstor: TPersistent = nil); override;

Parameters

Item
Type: TfrxXmlItem

aAcenstor
Type: TPersistent

Overrides

TfrxComponent.WriteNestedProperties(TfrxXMLItem,TPersistent)
See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView Fields

Fields
Name | Description
FAllowExpressions | Represents field FAllowExpressions.
FAllowHTMLTags | Represents field FAllowHTMLTags.
FAutoWidth | Represents field FAutoWidth.
FCharSpacing | Represents field FCharSpacing.
FClipped | Represents field FClipped.
FCopyNo | Represents field FCopyNo.
FDuplicates | Represents field FDuplicates.
FExpressionDelimiters | Represents field FExpressionDelimiters.
FFirstParaBreak | Represents field FFirstParaBreak.
FFlowTo | Represents field FFlowTo.
FFormats | Represents field FFormats.
FGapX | Represents field FGapX.
FGapY | Represents field FGapY.
FHAlign | Represents field FHAlign.
FHideZeros | Represents field FHideZeros.
FHighlightActivated | Represents field FHighlightActivated.
FHighlights | Represents field FHighlights.
FLastParaBreak | Represents field FLastParaBreak.
FLastValue | Represents field FLastValue.
FLineSpacing | Represents field FLineSpacing.
FMacroIndex | Represents field FMacroIndex.
FMacroLine | Represents field FMacroLine.
FMacroLoaded | Represents field FMacroLoaded.
FMemo | Represents field FMemo.
FParagraphGap | Represents field FParagraphGap.
FPartMemo | Represents field FPartMemo.
FPrintScale | Represents field FPrintScale.
FRotation | Represents field FRotation.
FRTLReading | Represents field FRTLReading.
FScaledRect | Represents field FScaledRect.
FStyle | Represents field FStyle.
FSuppressRepeated | Represents field FSuppressRepeated.
FTempFill | Represents field FTempFill.
FTempFont | Represents field FTempFont.
FTempFrame | Represents field FTempFrame.
FTempMemo | Represents field FTempMemo.
FTempVisible | Represents field FTempVisible.
FTextRect | Represents field FTextRect.
FTotalPages | Represents field FTotalPages.
FUnderlinesTextMode | Represents field FUnderlinesTextMode.
FUseDefaultCharset | Represents field FUseDefaultCharset.
FVAlign | Represents field FVAlign.
FValue | Represents field FValue.
FWordBreak | Represents field FWordBreak.
FWordWrap | Represents field FWordWrap.
FWysiwyg | Represents field FWysiwyg.
Top


TfrxCustomMemoView.FAllowExpressions Field

Summary

Represents field FAllowExpressions.

Namespace: frxClass
Syntax
Delphi
private
 FAllowExpressions: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FAllowHTMLTags Field

Summary

Represents field FAllowHTMLTags.

Namespace: frxClass
Syntax
Delphi
private
 FAllowHTMLTags: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FAutoWidth Field

Summary

Represents field FAutoWidth.

Namespace: frxClass
Syntax
Delphi
private
 FAutoWidth: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FCharSpacing Field

Summary

Represents field FCharSpacing.

Namespace: frxClass
Syntax
Delphi
private
 FCharSpacing: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FClipped Field

Summary

Represents field FClipped.

Namespace: frxClass
Syntax
Delphi
private
 FClipped: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FCopyNo Field

Summary

Represents field FCopyNo.

Namespace: frxClass
Syntax
Delphi
protected
 FCopyNo: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FDuplicates Field

Summary

Represents field FDuplicates.

Namespace: frxClass
Syntax
Delphi
private
 FDuplicates: TfrxDuplicateMerge;

Field Value

Type: TfrxDuplicateMerge

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FExpressionDelimiters Field

Summary

Represents field FExpressionDelimiters.

Namespace: frxClass
Syntax
Delphi
private
 FExpressionDelimiters: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FFirstParaBreak Field

Summary

Represents field FFirstParaBreak.

Namespace: frxClass
Syntax
Delphi
private
 FFirstParaBreak: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FFlowTo Field

Summary

Represents field FFlowTo.

Namespace: frxClass
Syntax
Delphi
private
 FFlowTo: TfrxCustomMemoView;

Field Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FFormats Field

Summary

Represents field FFormats.

Namespace: frxClass
Syntax
Delphi
private
 FFormats: TfrxFormatCollection;

Field Value

Type: TfrxFormatCollection

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FGapX Field

Summary

Represents field FGapX.

Namespace: frxClass
Syntax
Delphi
private
 FGapX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FGapY Field

Summary

Represents field FGapY.

Namespace: frxClass
Syntax
Delphi
private
 FGapY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FHAlign Field

Summary

Represents field FHAlign.

Namespace: frxClass
Syntax
Delphi
private
 FHAlign: TfrxHAlign;

Field Value

Type: TfrxHAlign

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FHideZeros Field

Summary

Represents field FHideZeros.

Namespace: frxClass
Syntax
Delphi
private
 FHideZeros: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FHighlightActivated Field

Summary

Represents field FHighlightActivated.

Namespace: frxClass
Syntax
Delphi
private
 FHighlightActivated: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FHighlights Field

Summary

Represents field FHighlights.

Namespace: frxClass
Syntax
Delphi
private
 FHighlights: TfrxHighlightCollection;

Field Value

Type: TfrxHighlightCollection

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FLastParaBreak Field

Summary

Represents field FLastParaBreak.

Namespace: frxClass
Syntax
Delphi
private
 FLastParaBreak: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FLastValue Field

Summary

Represents field FLastValue.

Namespace: frxClass
Syntax
Delphi
protected
 FLastValue: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FLineSpacing Field

Summary

Represents field FLineSpacing.

Namespace: frxClass
Syntax
Delphi
private
 FLineSpacing: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FMacroIndex Field

Summary

Represents field FMacroIndex.

Namespace: frxClass
Syntax
Delphi
protected
 FMacroIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FMacroLine Field

Summary

Represents field FMacroLine.

Namespace: frxClass
Syntax
Delphi
protected
 FMacroLine: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FMacroLoaded Field

Summary

Represents field FMacroLoaded.

Namespace: frxClass
Syntax
Delphi
private
 FMacroLoaded: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FMemo Field

Summary

Represents field FMemo.

Namespace: frxClass
Syntax
Delphi
private
 FMemo: TWideStrings;

Field Value

Type: TWideStrings

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FParagraphGap Field

Summary

Represents field FParagraphGap.

Namespace: frxClass
Syntax
Delphi
private
 FParagraphGap: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FPartMemo Field

Summary

Represents field FPartMemo.

Namespace: frxClass
Syntax
Delphi
private
 FPartMemo: WideString;

Field Value

Type: WideString

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FPrintScale Field

Summary

Represents field FPrintScale.

Namespace: frxClass
Syntax
Delphi
protected
 FPrintScale: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FRotation Field

Summary

Represents field FRotation.

Namespace: frxClass
Syntax
Delphi
private
 FRotation: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FRTLReading Field

Summary

Represents field FRTLReading.

Namespace: frxClass
Syntax
Delphi
private
 FRTLReading: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FScaledRect Field

Summary

Represents field FScaledRect.

Namespace: frxClass
Syntax
Delphi
private
 FScaledRect: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FStyle Field

Summary

Represents field FStyle.

Namespace: frxClass
Syntax
Delphi
private
 FStyle: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FSuppressRepeated Field

Summary

Represents field FSuppressRepeated.

Namespace: frxClass
Syntax
Delphi
private
 FSuppressRepeated: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FTempFill Field

Summary

Represents field FTempFill.

Namespace: frxClass
Syntax
Delphi
private
 FTempFill: TfrxCustomFill;

Field Value

Type: TfrxCustomFill

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FTempFont Field

Summary

Represents field FTempFont.

Namespace: frxClass
Syntax
Delphi
private
 FTempFont: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FTempFrame Field

Summary

Represents field FTempFrame.

Namespace: frxClass
Syntax
Delphi
private
 FTempFrame: TfrxFrame;

Field Value

Type: TfrxFrame

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FTempMemo Field

Summary

Represents field FTempMemo.

Namespace: frxClass
Syntax
Delphi
private
 FTempMemo: WideString;

Field Value

Type: WideString

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FTempVisible Field

Summary

Represents field FTempVisible.

Namespace: frxClass
Syntax
Delphi
private
 FTempVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FTextRect Field

Summary

Represents field FTextRect.

Namespace: frxClass
Syntax
Delphi
protected
 FTextRect: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FTotalPages Field

Summary

Represents field FTotalPages.

Namespace: frxClass
Syntax
Delphi
protected
 FTotalPages: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FUnderlinesTextMode Field

Summary

Represents field FUnderlinesTextMode.

Namespace: frxClass
Syntax
Delphi
private
 FUnderlinesTextMode: TfrxUnderlinesTextMode;

Field Value

Type: TfrxUnderlinesTextMode

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FUseDefaultCharset Field

Summary

Represents field FUseDefaultCharset.

Namespace: frxClass
Syntax
Delphi
private
 FUseDefaultCharset: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FVAlign Field

Summary

Represents field FVAlign.

Namespace: frxClass
Syntax
Delphi
private
 FVAlign: TfrxVAlign;

Field Value

Type: TfrxVAlign

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FValue Field

Summary

Represents field FValue.

Namespace: frxClass
Syntax
Delphi
private
 FValue: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FWordBreak Field

Summary

Represents field FWordBreak.

Namespace: frxClass
Syntax
Delphi
private
 FWordBreak: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FWordWrap Field

Summary

Represents field FWordWrap.

Namespace: frxClass
Syntax
Delphi
private
 FWordWrap: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomMemoView.FWysiwyg Field

Summary

Represents field FWysiwyg.

Namespace: frxClass
Syntax
Delphi
private
 FWysiwyg: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomMemoView
  • frxClass


TfrxCustomObjectPreset Class

Summary

Represents type TfrxCustomObjectPreset.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxCustomObjectPreset
frxQRCodeSwissPreset.TfrxSwissPaymentPreset
Syntax
Delphi
type
 TfrxCustomObjectPreset = class(TPersistent)
 end;

The TfrxCustomObjectPreset type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxCustomObjectPreset class.
Top
Methods
Show:
Name | Description
ApplySettings(TfrxComponent) | Represents method ApplySettings(TfrxComponent).
GetData(TfrxReport) | Represents method GetData(TfrxReport).
Top
See Also

Reference

  • frxClass


TfrxCustomObjectPreset Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxCustomObjectPreset class.
Top


TfrxCustomObjectPreset.Create Constructor

Summary

Initializes a new instance of the TfrxCustomObjectPreset class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create; virtual;
See Also

Reference

  • TfrxCustomObjectPreset
  • frxClass


TfrxCustomObjectPreset Methods

Methods
Name | Description
ApplySettings(TfrxComponent) | Represents method ApplySettings(TfrxComponent).
GetData(TfrxReport) | Represents method GetData(TfrxReport).
Top


TfrxCustomObjectPreset.ApplySettings(TfrxComponent) Method

Summary

Represents method ApplySettings(TfrxComponent).

Namespace: frxClass
Syntax
Delphi
public
 procedure ApplySettings(aComponent: TfrxComponent); virtual; abstract;

Parameters

aComponent
Type: TfrxComponent

See Also

Reference

  • TfrxCustomObjectPreset
  • frxClass


TfrxCustomObjectPreset.GetData(TfrxReport) Method

Summary

Represents method GetData(TfrxReport).

Namespace: frxClass
Syntax
Delphi
public
 function GetData(aReport: TfrxReport): String; virtual; abstract;

Parameters

aReport
Type: TfrxReport

Return Value

Type: String

See Also

Reference

  • TfrxCustomObjectPreset
  • frxClass


TfrxCustomOutline Class

Summary

This object represents the "Report tree" control element in a preview window. Instance of this class is stored in the TfrxReport.PreviewPages.Outline property.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxCustomOutline
frxPreviewPages.TfrxOutline
Syntax
Delphi
type
 TfrxCustomOutline = class(TPersistent)
 end;

The TfrxCustomOutline type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomPreviewPages) | Initializes a new instance of the TfrxCustomOutline class.
Top
Properties
Show:
Name | Description
Count | Represents property Count.
CurItem | Represents property CurItem.
PreviewPages | Represents property PreviewPages.
Top
Methods
Show:
Name | Description
AddItem(String,Integer) | Adds an element with the "Text" name to the current tree position. The current report's page and the Top position on the page are associated with the element.
DeleteItems(TfrxXMLItem) | Represents method DeleteItems(TfrxXMLItem).
Engine | Represents method Engine.
GetCount | Represents method GetCount.
GetCurPosition | Represents method GetCurPosition.
GetItem(Integer,String,Integer,Integer) | Represents method GetItem(Integer,String,Integer,Integer).
LevelDown(Integer) | Represents method LevelDown(Integer).
LevelRoot | Shifts the current position in the tree to the root level.
LevelUp | Shifts the current position in the tree on one level up.
ShiftItems(TfrxXMLItem,Integer) | Represents method ShiftItems(TfrxXMLItem,Integer).
Top
Fields
Show:
Name | Description
FCurItem | Represents field FCurItem.
FPreviewPages | Represents field FPreviewPages.
Top
See Also

Reference

  • frxClass


TfrxCustomOutline Constructors

Constructors
Name | Description
Create(TfrxCustomPreviewPages) | Initializes a new instance of the TfrxCustomOutline class.
Top


TfrxCustomOutline.Create(TfrxCustomPreviewPages) Constructor

Summary

Initializes a new instance of the TfrxCustomOutline class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(APreviewPages: TfrxCustomPreviewPages); virtual;

Parameters

APreviewPages
Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline Properties

Properties
Name | Description
Count | Represents property Count.
CurItem | Represents property CurItem.
PreviewPages | Represents property PreviewPages.
Top


TfrxCustomOutline.Count Property

Summary

Represents property Count.

Namespace: frxClass
Syntax
Delphi
public
 property Count: Integer read GetCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline.CurItem Property

Summary

Represents property CurItem.

Namespace: frxClass
Syntax
Delphi
public
 property CurItem: TfrxXMLItem read FCurItem write FCurItem;

Property Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline.PreviewPages Property

Summary

Represents property PreviewPages.

Namespace: frxClass
Syntax
Delphi
public
 property PreviewPages: TfrxCustomPreviewPages read FPreviewPages;

Property Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline Methods

Methods
Name | Description
AddItem(String,Integer) | Adds an element with the "Text" name to the current tree position. The current report's page and the Top position on the page are associated with the element.
DeleteItems(TfrxXMLItem) | Represents method DeleteItems(TfrxXMLItem).
Engine | Represents method Engine.
GetCount | Represents method GetCount.
GetCurPosition | Represents method GetCurPosition.
GetItem(Integer,String,Integer,Integer) | Represents method GetItem(Integer,String,Integer,Integer).
LevelDown(Integer) | Represents method LevelDown(Integer).
LevelRoot | Shifts the current position in the tree to the root level.
LevelUp | Shifts the current position in the tree on one level up.
ShiftItems(TfrxXMLItem,Integer) | Represents method ShiftItems(TfrxXMLItem,Integer).
Top


TfrxCustomOutline.AddItem(String,Integer) Method

Summary

Adds an element with the "Text" name to the current tree position. The current report's page and the Top position on the page are associated with the element.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddItem(const Text: String; Top: Integer); virtual; abstract;

Parameters

Text
Type: String

Top
Type: Integer

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline.DeleteItems(TfrxXMLItem) Method

Summary

Represents method DeleteItems(TfrxXMLItem).

Namespace: frxClass
Syntax
Delphi
public
 procedure DeleteItems(From: TfrxXMLItem); virtual; abstract;

Parameters

From
Type: TfrxXMLItem

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline.Engine Method

Summary

Represents method Engine.

Namespace: frxClass
Syntax
Delphi
public
 function Engine: TfrxCustomEngine;

Return Value

Type: TfrxCustomEngine

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline.GetCount Method

Summary

Represents method GetCount.

Namespace: frxClass
Syntax
Delphi
protected
 function GetCount: Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline.GetCurPosition Method

Summary

Represents method GetCurPosition.

Namespace: frxClass
Syntax
Delphi
public
 function GetCurPosition: TfrxXMLItem; virtual; abstract;

Return Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline.GetItem(Integer,String,Integer,Integer) Method

Summary

Represents method GetItem(Integer,String,Integer,Integer).

Namespace: frxClass
Syntax
Delphi
public
 procedure GetItem(Index: Integer; var Text: String;
 var Page, Top: Integer); virtual; abstract;

Parameters

Index
Type: Integer

Text
Type: String

Page
Type: Integer

Top
Type: Integer

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline.LevelDown(Integer) Method

Summary

Represents method LevelDown(Integer).

Namespace: frxClass
Syntax
Delphi
public
 procedure LevelDown(Index: Integer); virtual; abstract;

Parameters

Index
Type: Integer

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline.LevelRoot Method

Summary

Shifts the current position in the tree to the root level.

Namespace: frxClass
Syntax
Delphi
public
 procedure LevelRoot; virtual; abstract;
See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline.LevelUp Method

Summary

Shifts the current position in the tree on one level up.

Namespace: frxClass
Syntax
Delphi
public
 procedure LevelUp; virtual; abstract;
See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline.ShiftItems(TfrxXMLItem,Integer) Method

Summary

Represents method ShiftItems(TfrxXMLItem,Integer).

Namespace: frxClass
Syntax
Delphi
public
 procedure ShiftItems(From: TfrxXMLItem; NewTop: Integer); virtual; abstract;

Parameters

From
Type: TfrxXMLItem

NewTop
Type: Integer

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline Fields

Fields
Name | Description
FCurItem | Represents field FCurItem.
FPreviewPages | Represents field FPreviewPages.
Top


TfrxCustomOutline.FCurItem Field

Summary

Represents field FCurItem.

Namespace: frxClass
Syntax
Delphi
private
 FCurItem: TfrxXMLItem;

Field Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomOutline.FPreviewPages Field

Summary

Represents field FPreviewPages.

Namespace: frxClass
Syntax
Delphi
private
 FPreviewPages: TfrxCustomPreviewPages;

Field Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxCustomOutline
  • frxClass


TfrxCustomPreview Class

Summary

The TfrxCustomPreview class is the base class for TfrxPreview class.

Namespace: frxClass
Inheritance Hierarchy
TCustomControl
frxClass.TfrxCustomPreview
frxPreview.TfrxPreview
Syntax
Delphi
type
 TfrxCustomPreview = class(TCustomControl)
 end;

The TfrxCustomPreview type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomPreview class.
Destroy | Represents the destructor of the TfrxCustomPreview class.
Top
Properties
Show:
Name | Description
PreviewPages | Reference to an active preview pages object.
Report | Reference to an active report object.
UseReportHints | If True, shows hints of the report objects. Default True.
Top
Methods
Show:
Name | Description
AddPreviewTab(TfrxReport,String,String,Boolean,String) | Creates a new tab in the preview window linked with passed report object.
AddPreviewTabOrSwitch(TfrxReport,String,String,Boolean,String) | Creates or switch to a new tab in the preview window linked with passed report object.
DoFinishInPlace(TObject,Boolean,Boolean) | Represents method DoFinishInPlace(TObject,Boolean,Boolean).
GetPreviewPages | Represents method GetPreviewPages.
GetReport | Represents method GetReport.
HasTab(String) | Overloaded. Checks if preview has Tab with giving name.
HasTab(TfrxReport) | Overloaded. Checks if preview has Tab with giving report object.
HasVisibleTabs | Returns True when report preview has visible tabs.
Init(TfrxReport,TfrxCustomPreviewPages) | Initializes report preview with giving report and preview pages.
InternalCopy | Copies content for selected objects to clipboard. This method uses InPlace editors to process copy behaviour of the selected objects.
InternalIsPasteAvailable | This method checks if paste is available for selected objects from clipboard. It uses InPlace editors to process copy-paste behaviour of the selected objects.
InternalOnProgress(TfrxReport,TfrxProgressType,Integer) | The report engine calls this method to update action progress at current report(preparation, export, print).
InternalOnProgressStart(TfrxReport,TfrxProgressType,Integer) | The report engine calls this method when starts some action at current report(preparation, export, print).
InternalOnProgressStop(TfrxReport,TfrxProgressType,Integer) | The report engine calls this method when stops some action at current report(preparation, export, print).
InternalPaste | Pastes content to selected objects from clipboard. This method uses InPlace editors to process paste behaviour of the selected objects.
Lock | Locks report preview for any update and draw operations.
PreviewPagesChanged | Called when active preview pages was changed.
RefreshReport | Rebuilds a report for current active preview pages.
RemoveTab(Integer) | Closes and removes Tab from report preview.
SetDefaultEventParams(TfrxInteractiveEventsParams) | This method initialize TfrxInteractiveEventsParams structure with default values.
SwitchToTab(String) | Overloaded. Switches to Tab by giving name.
SwitchToTab(TfrxReport) | Overloaded. Switches to Tab by giving report.
UnInit(TfrxReport) | Uninitializes report preview for passed report component.
Unlock(Boolean) | Unlock report preview.
Top
Fields
Show:
Name | Description
FInPlaceditorsList | Represents field FInPlaceditorsList.
FPreviewForm | Represents field FPreviewForm.
FSelectionList | Represents field FSelectionList.
FUseReportHints | Represents field FUseReportHints.
Top
See Also

Reference

  • frxClass


TfrxCustomPreview Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomPreview class.
Destroy | Represents the destructor of the TfrxCustomPreview class.
Top


TfrxCustomPreview.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomPreview class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomPreview class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview Properties

Properties
Name | Description
PreviewPages | Reference to an active preview pages object.
Report | Reference to an active report object.
UseReportHints | If True, shows hints of the report objects. Default True.
Top


TfrxCustomPreview.PreviewPages Property

Summary

Reference to an active preview pages object.

Namespace: frxClass
Syntax
Delphi
public
 property PreviewPages: TfrxCustomPreviewPages read GetPreviewPages;

Property Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.Report Property

Summary

Reference to an active report object.

Namespace: frxClass
Syntax
Delphi
public
 property Report: TfrxReport read GetReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.UseReportHints Property

Summary

If True, shows hints of the report objects. Default True.

Namespace: frxClass
Syntax
Delphi
public
 property UseReportHints: Boolean read FUseReportHints write FUseReportHints;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview Methods

Methods
Name | Description
AddPreviewTab(TfrxReport,String,String,Boolean,String) | Creates a new tab in the preview window linked with passed report object.
AddPreviewTabOrSwitch(TfrxReport,String,String,Boolean,String) | Creates or switch to a new tab in the preview window linked with passed report object.
DoFinishInPlace(TObject,Boolean,Boolean) | Represents method DoFinishInPlace(TObject,Boolean,Boolean).
GetPreviewPages | Represents method GetPreviewPages.
GetReport | Represents method GetReport.
HasTab(String) | Overloaded. Checks if preview has Tab with giving name.
HasTab(TfrxReport) | Overloaded. Checks if preview has Tab with giving report object.
HasVisibleTabs | Returns True when report preview has visible tabs.
Init(TfrxReport,TfrxCustomPreviewPages) | Initializes report preview with giving report and preview pages.
InternalCopy | Copies content for selected objects to clipboard. This method uses InPlace editors to process copy behaviour of the selected objects.
InternalIsPasteAvailable | This method checks if paste is available for selected objects from clipboard. It uses InPlace editors to process copy-paste behaviour of the selected objects.
InternalOnProgress(TfrxReport,TfrxProgressType,Integer) | The report engine calls this method to update action progress at current report(preparation, export, print).
InternalOnProgressStart(TfrxReport,TfrxProgressType,Integer) | The report engine calls this method when starts some action at current report(preparation, export, print).
InternalOnProgressStop(TfrxReport,TfrxProgressType,Integer) | The report engine calls this method when stops some action at current report(preparation, export, print).
InternalPaste | Pastes content to selected objects from clipboard. This method uses InPlace editors to process paste behaviour of the selected objects.
Lock | Locks report preview for any update and draw operations.
PreviewPagesChanged | Called when active preview pages was changed.
RefreshReport | Rebuilds a report for current active preview pages.
RemoveTab(Integer) | Closes and removes Tab from report preview.
SetDefaultEventParams(TfrxInteractiveEventsParams) | This method initialize TfrxInteractiveEventsParams structure with default values.
SwitchToTab(String) | Overloaded. Switches to Tab by giving name.
SwitchToTab(TfrxReport) | Overloaded. Switches to Tab by giving report.
UnInit(TfrxReport) | Uninitializes report preview for passed report component.
Unlock(Boolean) | Unlock report preview.
Top


TfrxCustomPreview.AddPreviewTab(TfrxReport,String,String,Boolean,String) Method

Summary

Creates a new tab in the preview window linked with passed report object.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddPreviewTab(AReport: TfrxReport; const TabName: String; const TabCaption: String = ''; FreeObjects: Boolean = True; aDetailPage: String = ''); virtual; abstract;

Parameters

AReport
Type: TfrxReport

Reference to a report component.

TabName
Type: String

Name of the Tab.

TabCaption
Type: String

Caption of the Tab.

FreeObjects
Type: Boolean

If True, report object which is belong to the Tab object will be freed.

aDetailPage
Type: String

Name of Detail page.

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.AddPreviewTabOrSwitch(TfrxReport,String,String,Boolean,String) Method

Summary

Creates or switch to a new tab in the preview window linked with passed report object.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddPreviewTabOrSwitch(AReport: TfrxReport; const TabName: String; const TabCaption: String = ''; FreeObjects: Boolean = True; aDetailPage: String = ''); virtual; abstract;

Parameters

AReport
Type: TfrxReport

Reference to a report component.

TabName
Type: String

Name of the Tab.

TabCaption
Type: String

Caption of the Tab.

FreeObjects
Type: Boolean

Creates a new tab in the preview window linked with passed report object.

aDetailPage
Type: String

Name of Detail page.

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.DoFinishInPlace(TObject,Boolean,Boolean) Method

Summary

Represents method DoFinishInPlace(TObject,Boolean,Boolean).

Namespace: frxClass
Syntax
Delphi
protected
 procedure DoFinishInPlace(Sender: TObject; Refresh, Modified: Boolean); virtual;

Parameters

Sender
Type: TObject

Refresh
Type: Boolean

Modified
Type: Boolean

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.GetPreviewPages Method

Summary

Represents method GetPreviewPages.

Namespace: frxClass
Syntax
Delphi
protected
 function GetPreviewPages: TfrxCustomPreviewPages; virtual;

Return Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.GetReport Method

Summary

Represents method GetReport.

Namespace: frxClass
Syntax
Delphi
protected
 function GetReport: TfrxReport; virtual;

Return Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.HasTab(String) Method

Summary

Checks if preview has Tab with giving name.

Namespace: frxClass
Syntax
Delphi
public
 function HasTab(const TabName: String): Boolean; overload; virtual; abstract;

Parameters

TabName
Type: String

Name of the Tab.

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.HasTab(TfrxReport) Method

Summary

Checks if preview has Tab with giving report object.

Namespace: frxClass
Syntax
Delphi
public
 function HasTab(const aReport: TfrxReport): Boolean; overload; virtual; abstract;

Parameters

aReport
Type: TfrxReport

Reference to a report component.

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.HasVisibleTabs Method

Summary

Returns True when report preview has visible tabs.

Namespace: frxClass
Syntax
Delphi
public
 function HasVisibleTabs: Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.Init(TfrxReport,TfrxCustomPreviewPages) Method

Summary

Initializes report preview with giving report and preview pages.

Namespace: frxClass
Syntax
Delphi
public
 function Init(aReport: TfrxReport; aPrevPages: TfrxCustomPreviewPages): Boolean; virtual; abstract;

Parameters

aReport
Type: TfrxReport

Reference to a report component.

aPrevPages
Type: TfrxCustomPreviewPages

Reference to preview pages object.

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.InternalCopy Method

Summary

Copies content for selected objects to clipboard. This method uses InPlace editors to process copy behaviour of the selected objects.

Namespace: frxClass
Syntax
Delphi
public
 procedure InternalCopy; virtual;
See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.InternalIsPasteAvailable Method

Summary

This method checks if paste is available for selected objects from clipboard. It uses InPlace editors to process copy-paste behaviour of the selected objects.

Namespace: frxClass
Syntax
Delphi
public
 function InternalIsPasteAvailable: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.InternalOnProgress(TfrxReport,TfrxProgressType,Integer) Method

Summary

The report engine calls this method to update action progress at current report(preparation, export, print).

Namespace: frxClass
Syntax
Delphi
public
 procedure InternalOnProgress(Sender: TfrxReport;
 ProgressType: TfrxProgressType; Progress: Integer); virtual; abstract;

Parameters

Sender
Type: TfrxReport

Sender object.

ProgressType
Type: TfrxProgressType

Type of progress

Progress
Type: Integer

Progress value.

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.InternalOnProgressStart(TfrxReport,TfrxProgressType,Integer) Method

Summary

The report engine calls this method when starts some action at current report(preparation, export, print).

Namespace: frxClass
Syntax
Delphi
public
 procedure InternalOnProgressStart(Sender: TfrxReport;
 ProgressType: TfrxProgressType; Progress: Integer); virtual; abstract;

Parameters

Sender
Type: TfrxReport

Sender object.

ProgressType
Type: TfrxProgressType

Type of progress.

Progress
Type: Integer

Progress value.

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.InternalOnProgressStop(TfrxReport,TfrxProgressType,Integer) Method

Summary

The report engine calls this method when stops some action at current report(preparation, export, print).

Namespace: frxClass
Syntax
Delphi
public
 procedure InternalOnProgressStop(Sender: TfrxReport;
 ProgressType: TfrxProgressType; Progress: Integer); virtual; abstract;

Parameters

Sender
Type: TfrxReport

Sender object.

ProgressType
Type: TfrxProgressType

Type of progress

Progress
Type: Integer

Progress value.

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.InternalPaste Method

Summary

Pastes content to selected objects from clipboard. This method uses InPlace editors to process paste behaviour of the selected objects.

Namespace: frxClass
Syntax
Delphi
public
 procedure InternalPaste; virtual;
See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.Lock Method

Summary

Locks report preview for any update and draw operations.

Namespace: frxClass
Syntax
Delphi
public
 function Lock: Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.PreviewPagesChanged Method

Summary

Called when active preview pages was changed.

Namespace: frxClass
Syntax
Delphi
public
 procedure PreviewPagesChanged; virtual; abstract;
See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.RefreshReport Method

Summary

Rebuilds a report for current active preview pages.

Namespace: frxClass
Syntax
Delphi
public
 procedure RefreshReport; virtual; abstract;
See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.RemoveTab(Integer) Method

Summary

Closes and removes Tab from report preview.

Namespace: frxClass
Syntax
Delphi
public
 procedure RemoveTab(TabIndex: Integer); virtual; abstract;

Parameters

TabIndex
Type: Integer

Index of the Tab.

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.SetDefaultEventParams(TfrxInteractiveEventsParams) Method

Summary

This method initialize TfrxInteractiveEventsParams structure with default values.

Namespace: frxClass
Syntax
Delphi
public
 procedure SetDefaultEventParams(var EventParams: TfrxInteractiveEventsParams); virtual;

Parameters

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.SwitchToTab(String) Method

Summary

Switches to Tab by giving name.

Namespace: frxClass
Syntax
Delphi
public
 procedure SwitchToTab(const TabName: String); overload; virtual; abstract;

Parameters

TabName
Type: String

Name of the Tab.

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.SwitchToTab(TfrxReport) Method

Summary

Switches to Tab by giving report.

Namespace: frxClass
Syntax
Delphi
public
 procedure SwitchToTab(const aReport: TfrxReport); overload; virtual; abstract;

Parameters

aReport
Type: TfrxReport

Reference to a report component.

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.UnInit(TfrxReport) Method

Summary

Uninitializes report preview for passed report component.

Namespace: frxClass
Syntax
Delphi
public
 procedure UnInit(aReport: TfrxReport); virtual; abstract;

Parameters

aReport
Type: TfrxReport

Reference to a report component.

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.Unlock(Boolean) Method

Summary

Unlock report preview.

Namespace: frxClass
Syntax
Delphi
public
 procedure Unlock(DoUpdate: Boolean = True); virtual; abstract;

Parameters

DoUpdate
Type: Boolean

Refresh after unlock.

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview Fields

Fields
Name | Description
FInPlaceditorsList | Represents field FInPlaceditorsList.
FPreviewForm | Represents field FPreviewForm.
FSelectionList | Represents field FSelectionList.
FUseReportHints | Represents field FUseReportHints.
Top


TfrxCustomPreview.FInPlaceditorsList Field

Summary

Represents field FInPlaceditorsList.

Namespace: frxClass
Syntax
Delphi
protected
 FInPlaceditorsList: TfrxComponentEditorsList;

Field Value

Type: TfrxComponentEditorsList

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.FPreviewForm Field

Summary

Represents field FPreviewForm.

Namespace: frxClass
Syntax
Delphi
protected
 FPreviewForm: TForm;

Field Value

Type: TForm

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.FSelectionList Field

Summary

Represents field FSelectionList.

Namespace: frxClass
Syntax
Delphi
protected
 FSelectionList: TfrxSelectedObjectsList;

Field Value

Type: TfrxSelectedObjectsList

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreview.FUseReportHints Field

Summary

Represents field FUseReportHints.

Namespace: frxClass
Syntax
Delphi
private
 FUseReportHints: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreview
  • frxClass


TfrxCustomPreviewPages Class

Summary

The TfrxCustomPreviewPages class is the base class for pages of a prepared report. Instance of this class is stored in the TfrxReport.PreviewPages property.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxCustomPreviewPages
frxPreviewPages.TfrxPreviewPages
Syntax
Delphi
type
 TfrxCustomPreviewPages = class(TObject)
 end;

The TfrxCustomPreviewPages type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport) | Default constructor.
Destroy | Represents the destructor of the TfrxCustomPreviewPages class.
Top
Properties
Show:
Name | Description
AddPageAction | This flag used by AddPage method. apWriteOver - writes over current page if it isn't last page (in case it's last page a new page will be added). apWriteOver - always adds new page.
Count | Number of pages in the prepared report.
CurPage | Current page number.
CurPreviewPage | Current previewed page number.
Engine | Reference to the report engine object.
FirstPage | First page number in composite report.
Outline | Link to the "Report outline" class.
PageSize[Integer] | List of page sizes in the prepared report.
Page[Integer] | List of pages in the prepared report.
PostProcessor | Post-process data dictionary object.
PrintCopyNo | Number of printed copy.
PrintScale | Scale for print output.
Report | Reference to a report object.
Top
Methods
Show:
Name | Description
AddEmptyPage(Integer) | Inserts an empty preview page at given position.
AddFrom(TfrxReport) | Creates a composite prepared report through concatenation of preview pages in to current preview pages.
AddObject(TfrxComponent) | This method adds an object to current preview page.
AddPage(TfrxReportPage) | This method adds new preview page or increases number of current preview page by 1 depends on AddPageAction flag.
AddPicture(TfrxPictureView) | Adds picture object to preview pages picture cache.
AddSourcePage(TfrxReportPage) | This method adds report template page to preview page objects dictionary.
AddToSourcePage(TfrxComponent) | This method adds report template object to preview page objects dictionary.
BandExists(TfrxBand) | Checks if band exist on current preview page.
BeginPass | The report engine call this method when start first pass of double pass report.
Clear | Clears a prepared report.
ClearFirstPassPages | Clears results of the first pass.
CutObjects(Integer) | Cuts objects from current serialized XML page by given XML node position to temporary cut-buffer.
DeleteAnchors(Integer) | Deletes all preview pages anchors starts at given position.
DeleteObjects(Integer) | Deletes serialized XML objects at given XML node position from current serialized preview page.
DeletePage(Integer) | Deletes preview page at given position.
DrawPage(Integer,TCanvas,Extended,Extended,Extended,Extended,Boolean) | Draws prepared page on Canvas.
Export(TfrxCustomExportFilter) | Exports a report.
Finish | Called by the report engine when report preparation finished.
FireMouseLeave | Fires mouse leave behaviour for preview pages objects.
GetAnchorCurPosition | Returns current anchor item position.
GetCount | Represents method GetCount.
GetCurPosition | Returns current XML node position in serialized preview page.
GetLastY(Extended) | Returns last Y position on preview page which is not occupied by band objects.
GetLogicalPageNo | Returns logical page number for current page.
GetLogicalTotalPages | Returns logical total pages count.
GetPage(Integer) | Represents method GetPage(Integer).
GetPageSize(Integer) | Represents method GetPageSize(Integer).
IncLogicalPageNumber | Updates logical page number variable.
Initialize | Initializes preview pages.
LoadFromFile(String,Boolean) | Loads a prepared report from a file.
LoadFromStream(TStream,Boolean) | Loads a prepared report from a stream. The AllowPartialLoading parameter allows to load large files partially for saving memory.
ModifyObject(TfrxComponent) | This method writes changes of report object on prepared report page to XML node with using objects data dictionary. Use this method to save changes made on object of prepared report. This method uses data dictionary and works much faster than ModifyPage method.
ModifyPage(Integer,TfrxReportPage) | This method writes changes of prepared page with all objects to serialized XML. Use this method to save all changes made on prepared page.
ObjectOver(Integer,Integer,Integer,TMouseButton,TShiftState,Extended,Extended,Extended,TfrxPreviewIntEventParams) | This method sends an interactive message to preview page or/and objects on that page.
PasteObjects(Extended,Extended) | Pastes cut objects from temporary buffer to current serialized XML page at given X, Y position on the preview page.
Print | Prints a report.
ResetLogicalPageNumber | Resets logical page number variable.
SaveToFile(String) | Saves a prepared report to a file.
SaveToFilter(TfrxCustomIOTransport,String) | Saves a prepared report by using IO transport class to get stream for a prepared pages.
SaveToStream(TStream) | Saves a prepared report to a stream.
ShiftAnchors(Integer,Integer) | Shifts all preview pages anchors starts at given position by new top position.
Top
Fields
Show:
Name | Description
FAddPageAction | Represents field FAddPageAction.
FCopyNo | Represents field FCopyNo.
FCurPage | Represents field FCurPage.
FCurPreviewPage | Represents field FCurPreviewPage.
FEngine | Represents field FEngine.
FFirstPage | Represents field FFirstPage.
FOutline | Represents field FOutline.
FPostProcessor | Represents field FPostProcessor.
FPrintScale | Represents field FPrintScale.
FReport | Represents field FReport.
Top
See Also

Reference

  • frxClass


TfrxCustomPreviewPages Constructors

Constructors
Name | Description
Create(TfrxReport) | Default constructor.
Destroy | Represents the destructor of the TfrxCustomPreviewPages class.
Top


TfrxCustomPreviewPages.Create(TfrxReport) Constructor

Summary

Default constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AReport: TfrxReport); virtual;

Parameters

AReport
Type: TfrxReport

Reference to an owner report component.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomPreviewPages class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages Properties

Properties
Name | Description
AddPageAction | This flag used by AddPage method. apWriteOver - writes over current page if it isn't last page (in case it's last page a new page will be added). apWriteOver - always adds new page.
Count | Number of pages in the prepared report.
CurPage | Current page number.
CurPreviewPage | Current previewed page number.
Engine | Reference to the report engine object.
FirstPage | First page number in composite report.
Outline | Link to the "Report outline" class.
PageSize[Integer] | List of page sizes in the prepared report.
Page[Integer] | List of pages in the prepared report.
PostProcessor | Post-process data dictionary object.
PrintCopyNo | Number of printed copy.
PrintScale | Scale for print output.
Report | Reference to a report object.
Top


TfrxCustomPreviewPages.AddPageAction Property

Summary

This flag used by AddPage method. apWriteOver - writes over current page if it isn't last page (in case it's last page a new page will be added). apWriteOver - always adds new page.

Namespace: frxClass
Syntax
Delphi
public
 property AddPageAction: TfrxAddPageAction read FAddPageAction write FAddPageAction;

Property Value

Type: TfrxAddPageAction

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.Count Property

Summary

Number of pages in the prepared report.

Namespace: frxClass
Syntax
Delphi
public
 property Count: Integer read GetCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.CurPage Property

Summary

Current page number.

Namespace: frxClass
Syntax
Delphi
public
 property CurPage: Integer read FCurPage write FCurPage;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.CurPreviewPage Property

Summary

Current previewed page number.

Namespace: frxClass
Syntax
Delphi
public
 property CurPreviewPage: Integer read FCurPreviewPage write FCurPreviewPage;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.Engine Property

Summary

Reference to the report engine object.

Namespace: frxClass
Syntax
Delphi
public
 property Engine: TfrxCustomEngine read FEngine write FEngine;

Property Value

Type: TfrxCustomEngine

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.FirstPage Property

Summary

First page number in composite report.

Namespace: frxClass
Syntax
Delphi
public
 property FirstPage: Integer read FFirstPage write FFirstPage;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.Outline Property

Summary

Link to the "Report outline" class.

Namespace: frxClass
Syntax
Delphi
public
 property Outline: TfrxCustomOutline read FOutline;

Property Value

Type: TfrxCustomOutline

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.PageSize[Integer] Property

Summary

List of page sizes in the prepared report.

Namespace: frxClass
Syntax
Delphi
public
 property PageSize[Index: Integer]: TPoint read GetPageSize;

Parameters

Index
Type: Integer

Property Value

Type: TPoint

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.Page[Integer] Property

Summary

List of pages in the prepared report.

Namespace: frxClass
Syntax
Delphi
public
 property Page[Index: Integer]: TfrxReportPage read GetPage;

Parameters

Index
Type: Integer

Property Value

Type: TfrxReportPage

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.PostProcessor Property

Summary

Post-process data dictionary object.

Namespace: frxClass
Syntax
Delphi
public
 property PostProcessor: TfrxPostProcessor read FPostProcessor;

Property Value

Type: TfrxPostProcessor

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.PrintCopyNo Property

Summary

Number of printed copy.

Namespace: frxClass
Syntax
Delphi
public
 property PrintCopyNo: Integer read FCopyNo;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.PrintScale Property

Summary

Scale for print output.

Namespace: frxClass
Syntax
Delphi
public
 property PrintScale: Extended read FPrintScale;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.Report Property

Summary

Reference to a report object.

Namespace: frxClass
Syntax
Delphi
public
 property Report: TfrxReport read FReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages Methods

Methods
Name | Description
AddEmptyPage(Integer) | Inserts an empty preview page at given position.
AddFrom(TfrxReport) | Creates a composite prepared report through concatenation of preview pages in to current preview pages.
AddObject(TfrxComponent) | This method adds an object to current preview page.
AddPage(TfrxReportPage) | This method adds new preview page or increases number of current preview page by 1 depends on AddPageAction flag.
AddPicture(TfrxPictureView) | Adds picture object to preview pages picture cache.
AddSourcePage(TfrxReportPage) | This method adds report template page to preview page objects dictionary.
AddToSourcePage(TfrxComponent) | This method adds report template object to preview page objects dictionary.
BandExists(TfrxBand) | Checks if band exist on current preview page.
BeginPass | The report engine call this method when start first pass of double pass report.
Clear | Clears a prepared report.
ClearFirstPassPages | Clears results of the first pass.
CutObjects(Integer) | Cuts objects from current serialized XML page by given XML node position to temporary cut-buffer.
DeleteAnchors(Integer) | Deletes all preview pages anchors starts at given position.
DeleteObjects(Integer) | Deletes serialized XML objects at given XML node position from current serialized preview page.
DeletePage(Integer) | Deletes preview page at given position.
DrawPage(Integer,TCanvas,Extended,Extended,Extended,Extended,Boolean) | Draws prepared page on Canvas.
Export(TfrxCustomExportFilter) | Exports a report.
Finish | Called by the report engine when report preparation finished.
FireMouseLeave | Fires mouse leave behaviour for preview pages objects.
GetAnchorCurPosition | Returns current anchor item position.
GetCount | Represents method GetCount.
GetCurPosition | Returns current XML node position in serialized preview page.
GetLastY(Extended) | Returns last Y position on preview page which is not occupied by band objects.
GetLogicalPageNo | Returns logical page number for current page.
GetLogicalTotalPages | Returns logical total pages count.
GetPage(Integer) | Represents method GetPage(Integer).
GetPageSize(Integer) | Represents method GetPageSize(Integer).
IncLogicalPageNumber | Updates logical page number variable.
Initialize | Initializes preview pages.
LoadFromFile(String,Boolean) | Loads a prepared report from a file.
LoadFromStream(TStream,Boolean) | Loads a prepared report from a stream. The AllowPartialLoading parameter allows to load large files partially for saving memory.
ModifyObject(TfrxComponent) | This method writes changes of report object on prepared report page to XML node with using objects data dictionary. Use this method to save changes made on object of prepared report. This method uses data dictionary and works much faster than ModifyPage method.
ModifyPage(Integer,TfrxReportPage) | This method writes changes of prepared page with all objects to serialized XML. Use this method to save all changes made on prepared page.
ObjectOver(Integer,Integer,Integer,TMouseButton,TShiftState,Extended,Extended,Extended,TfrxPreviewIntEventParams) | This method sends an interactive message to preview page or/and objects on that page.
PasteObjects(Extended,Extended) | Pastes cut objects from temporary buffer to current serialized XML page at given X, Y position on the preview page.
Print | Prints a report.
ResetLogicalPageNumber | Resets logical page number variable.
SaveToFile(String) | Saves a prepared report to a file.
SaveToFilter(TfrxCustomIOTransport,String) | Saves a prepared report by using IO transport class to get stream for a prepared pages.
SaveToStream(TStream) | Saves a prepared report to a stream.
ShiftAnchors(Integer,Integer) | Shifts all preview pages anchors starts at given position by new top position.
Top


TfrxCustomPreviewPages.AddEmptyPage(Integer) Method

Summary

Inserts an empty preview page at given position.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddEmptyPage(Index: Integer); virtual; abstract;

Parameters

Index
Type: Integer

Page index.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.AddFrom(TfrxReport) Method

Summary

Creates a composite prepared report through concatenation of preview pages in to current preview pages.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddFrom(Report: TfrxReport); virtual; abstract;

Parameters

Report
Type: TfrxReport

Source report.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.AddObject(TfrxComponent) Method

Summary

This method adds an object to current preview page.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddObject(Obj: TfrxComponent); virtual; abstract;

Parameters

Obj
Type: TfrxComponent

Reference to report object.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.AddPage(TfrxReportPage) Method

Summary

This method adds new preview page or increases number of current preview page by 1 depends on AddPageAction flag.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddPage(Page: TfrxReportPage); virtual; abstract;

Parameters

Page
Type: TfrxReportPage

Reference to report page.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.AddPicture(TfrxPictureView) Method

Summary

Adds picture object to preview pages picture cache.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddPicture(Picture: TfrxPictureView); virtual; abstract;

Parameters

Picture
Type: TfrxPictureView

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.AddSourcePage(TfrxReportPage) Method

Summary

This method adds report template page to preview page objects dictionary.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddSourcePage(Page: TfrxReportPage); virtual; abstract;

Parameters

Page
Type: TfrxReportPage

Reference to report template page.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.AddToSourcePage(TfrxComponent) Method

Summary

This method adds report template object to preview page objects dictionary.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddToSourcePage(Obj: TfrxComponent); virtual; abstract;

Parameters

Obj
Type: TfrxComponent

Report object.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.BandExists(TfrxBand) Method

Summary

Checks if band exist on current preview page.

Namespace: frxClass
Syntax
Delphi
public
 function BandExists(Band: TfrxBand): Boolean; virtual; abstract;

Parameters

Band
Type: TfrxBand

Reference to Band in a report template.

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.BeginPass Method

Summary

The report engine call this method when start first pass of double pass report.

Namespace: frxClass
Syntax
Delphi
public
 procedure BeginPass; virtual; abstract;
See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.Clear Method

Summary

Clears a prepared report.

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear; virtual; abstract;
See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.ClearFirstPassPages Method

Summary

Clears results of the first pass.

Namespace: frxClass
Syntax
Delphi
public
 procedure ClearFirstPassPages; virtual; abstract;
See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.CutObjects(Integer) Method

Summary

Cuts objects from current serialized XML page by given XML node position to temporary cut-buffer.

Namespace: frxClass
Syntax
Delphi
public
 procedure CutObjects(APosition: Integer); virtual; abstract;

Parameters

APosition
Type: Integer

Index of XML node in serialized preview page XML node.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.DeleteAnchors(Integer) Method

Summary

Deletes all preview pages anchors starts at given position.

Namespace: frxClass
Syntax
Delphi
public
 procedure DeleteAnchors(From: Integer); virtual; abstract;

Parameters

From
Type: Integer

Start item position.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.DeleteObjects(Integer) Method

Summary

Deletes serialized XML objects at given XML node position from current serialized preview page.

Namespace: frxClass
Syntax
Delphi
public
 procedure DeleteObjects(APosition: Integer); virtual; abstract;

Parameters

APosition
Type: Integer

XML node position.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.DeletePage(Integer) Method

Summary

Deletes preview page at given position.

Namespace: frxClass
Syntax
Delphi
public
 procedure DeletePage(Index: Integer); virtual; abstract;

Parameters

Index
Type: Integer

Page index.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.DrawPage(Integer,TCanvas,Extended,Extended,Extended,Extended,Boolean) Method

Summary

Draws prepared page on Canvas.

Namespace: frxClass
Syntax
Delphi
public
 procedure DrawPage(Index: Integer; Canvas: TCanvas; ScaleX, ScaleY,
 OffsetX, OffsetY: Extended; bHighlightEditable: Boolean = False); virtual; abstract;

Parameters

Index
Type: Integer

Index of page to draw.

Canvas
Type: TCanvas

Destination Canvas.

ScaleX
Type: Extended

Scale X.

ScaleY
Type: Extended

Scale Y.

OffsetX
Type: Extended

X offset.

OffsetY
Type: Extended

Y offset.

bHighlightEditable
Type: Boolean

Draws with highlight of editable objects.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.Export(TfrxCustomExportFilter) Method

Summary

Exports a report.

Namespace: frxClass
Syntax
Delphi
public
 function Export(Filter: TfrxCustomExportFilter): Boolean; virtual; abstract;

Parameters

Filter
Type: TfrxCustomExportFilter

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.Finish Method

Summary

Called by the report engine when report preparation finished.

Namespace: frxClass
Syntax
Delphi
public
 procedure Finish; virtual; abstract;
See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.FireMouseLeave Method

Summary

Fires mouse leave behaviour for preview pages objects.

Namespace: frxClass
Syntax
Delphi
public
 procedure FireMouseLeave; virtual;
See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.GetAnchorCurPosition Method

Summary

Returns current anchor item position.

Namespace: frxClass
Syntax
Delphi
public
 function GetAnchorCurPosition: Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.GetCount Method

Summary

Represents method GetCount.

Namespace: frxClass
Syntax
Delphi
protected
 function GetCount: Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.GetCurPosition Method

Summary

Returns current XML node position in serialized preview page.

Namespace: frxClass
Syntax
Delphi
public
 function GetCurPosition: Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.GetLastY(Extended) Method

Summary

Returns last Y position on preview page which is not occupied by band objects.

Namespace: frxClass
Syntax
Delphi
public
 function GetLastY(ColumnPosition: Extended = 0): Extended; virtual; abstract;

Parameters

ColumnPosition
Type: Extended

Column X position.

Return Value

Type: Extended

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.GetLogicalPageNo Method

Summary

Returns logical page number for current page.

Namespace: frxClass
Syntax
Delphi
public
 function GetLogicalPageNo: Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.GetLogicalTotalPages Method

Summary

Returns logical total pages count.

Namespace: frxClass
Syntax
Delphi
public
 function GetLogicalTotalPages: Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.GetPage(Integer) Method

Summary

Represents method GetPage(Integer).

Namespace: frxClass
Syntax
Delphi
protected
 function GetPage(Index: Integer): TfrxReportPage; virtual; abstract;

Parameters

Index
Type: Integer

Return Value

Type: TfrxReportPage

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.GetPageSize(Integer) Method

Summary

Represents method GetPageSize(Integer).

Namespace: frxClass
Syntax
Delphi
protected
 function GetPageSize(Index: Integer): TPoint; virtual; abstract;

Parameters

Index
Type: Integer

Return Value

Type: TPoint

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.IncLogicalPageNumber Method

Summary

Updates logical page number variable.

Namespace: frxClass
Syntax
Delphi
public
 procedure IncLogicalPageNumber; virtual; abstract;
See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.Initialize Method

Summary

Initializes preview pages.

Namespace: frxClass
Syntax
Delphi
public
 procedure Initialize; virtual; abstract;
See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.LoadFromFile(String,Boolean) Method

Summary

Loads a prepared report from a file.

Namespace: frxClass
Syntax
Delphi
public
 function LoadFromFile(const FileName: String;
 ExceptionIfNotFound: Boolean = False): Boolean; virtual; abstract;

Parameters

FileName
Type: String

ExceptionIfNotFound
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.LoadFromStream(TStream,Boolean) Method

Summary

Loads a prepared report from a stream. The AllowPartialLoading parameter allows to load large files partially for saving memory.

Namespace: frxClass
Syntax
Delphi
public
 procedure LoadFromStream(Stream: TStream;
 AllowPartialLoading: Boolean = False); virtual; abstract;

Parameters

Stream
Type: TStream

AllowPartialLoading
Type: Boolean

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.ModifyObject(TfrxComponent) Method

Summary

This method writes changes of report object on prepared report page to XML node with using objects data dictionary. Use this method to save changes made on object of prepared report. This method uses data dictionary and works much faster than ModifyPage method.

Namespace: frxClass
Syntax
Delphi
public
 procedure ModifyObject(Component: TfrxComponent); virtual; abstract;

Parameters

Component
Type: TfrxComponent

Reference to modified prepared report object.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.ModifyPage(Integer,TfrxReportPage) Method

Summary

This method writes changes of prepared page with all objects to serialized XML. Use this method to save all changes made on prepared page.

Namespace: frxClass
Syntax
Delphi
public
 procedure ModifyPage(Index: Integer; Page: TfrxReportPage); virtual; abstract;

Parameters

Index
Type: Integer

Page index in prepared report.

Page
Type: TfrxReportPage

Reference to modified page object.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.ObjectOver(Integer,Integer,Integer,TMouseButton,TShiftState,Extended,Extended,Extended,TfrxPreviewIntEventParams) Method

Summary

This method sends an interactive message to preview page or/and objects on that page.

Namespace: frxClass
Syntax
Delphi
public
 procedure ObjectOver(Index: Integer; X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; Scale, OffsetX, OffsetY: Extended;
 var EventParams: TfrxPreviewIntEventParams); virtual; abstract;

Parameters

Index
Type: Integer

Page index of the page.

X
Type: Integer

X coordinate relative to parent preview workspace view(mouse coordinates).

Y
Type: Integer

Y coordinate relative to parent preview workspace view(mouse coordinates).

Button
Type: TMouseButton

Mouse button.

Shift
Type: TShiftState

Shift button.

Scale
Type: Extended

Current scale of preview window.

OffsetX
Type: Extended

Horizontal offset (start of draw area based on horizontal scroll).

OffsetY
Type: Extended

Vertical offset (start of draw area based on vertical scroll).

EventParams
Type: TfrxPreviewIntEventParams

Structure used for additional event parameters (like event type). Also stores return value.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.PasteObjects(Extended,Extended) Method

Summary

Pastes cut objects from temporary buffer to current serialized XML page at given X, Y position on the preview page.

Namespace: frxClass
Syntax
Delphi
public
 procedure PasteObjects(X, Y: Extended); virtual; abstract;

Parameters

X
Type: Extended

X coordinate (column position).

Y
Type: Extended

Y coordinate (band position).

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.Print Method

Summary

Prints a report.

Namespace: frxClass
Syntax
Delphi
public
 function Print: Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.ResetLogicalPageNumber Method

Summary

Resets logical page number variable.

Namespace: frxClass
Syntax
Delphi
public
 procedure ResetLogicalPageNumber; virtual; abstract;
See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.SaveToFile(String) Method

Summary

Saves a prepared report to a file.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveToFile(const FileName: String); virtual; abstract;

Parameters

FileName
Type: String

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.SaveToFilter(TfrxCustomIOTransport,String) Method

Summary

Saves a prepared report by using IO transport class to get stream for a prepared pages.

Namespace: frxClass
Syntax
Delphi
public
 function SaveToFilter(Filter: TfrxCustomIOTransport; const FileName: String): Boolean; virtual; abstract;

Parameters

Filter
Type: TfrxCustomIOTransport

IO transport filter instance.

FileName
Type: String

Name of the prepared file.

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.SaveToStream(TStream) Method

Summary

Saves a prepared report to a stream.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveToStream(Stream: TStream); virtual; abstract;

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.ShiftAnchors(Integer,Integer) Method

Summary

Shifts all preview pages anchors starts at given position by new top position.

Namespace: frxClass
Syntax
Delphi
public
 procedure ShiftAnchors(From, NewTop: Integer); virtual; abstract;

Parameters

From
Type: Integer

Start item position.

NewTop
Type: Integer

New top position.

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages Fields

Fields
Name | Description
FAddPageAction | Represents field FAddPageAction.
FCopyNo | Represents field FCopyNo.
FCurPage | Represents field FCurPage.
FCurPreviewPage | Represents field FCurPreviewPage.
FEngine | Represents field FEngine.
FFirstPage | Represents field FFirstPage.
FOutline | Represents field FOutline.
FPostProcessor | Represents field FPostProcessor.
FPrintScale | Represents field FPrintScale.
FReport | Represents field FReport.
Top


TfrxCustomPreviewPages.FAddPageAction Field

Summary

Represents field FAddPageAction.

Namespace: frxClass
Syntax
Delphi
private
 FAddPageAction: TfrxAddPageAction;

Field Value

Type: TfrxAddPageAction

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.FCopyNo Field

Summary

Represents field FCopyNo.

Namespace: frxClass
Syntax
Delphi
protected
 FCopyNo: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.FCurPage Field

Summary

Represents field FCurPage.

Namespace: frxClass
Syntax
Delphi
private
 FCurPage: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.FCurPreviewPage Field

Summary

Represents field FCurPreviewPage.

Namespace: frxClass
Syntax
Delphi
private
 FCurPreviewPage: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.FEngine Field

Summary

Represents field FEngine.

Namespace: frxClass
Syntax
Delphi
private
 FEngine: TfrxCustomEngine;

Field Value

Type: TfrxCustomEngine

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.FFirstPage Field

Summary

Represents field FFirstPage.

Namespace: frxClass
Syntax
Delphi
private
 FFirstPage: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.FOutline Field

Summary

Represents field FOutline.

Namespace: frxClass
Syntax
Delphi
private
 FOutline: TfrxCustomOutline;

Field Value

Type: TfrxCustomOutline

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.FPostProcessor Field

Summary

Represents field FPostProcessor.

Namespace: frxClass
Syntax
Delphi
protected
 FPostProcessor: TfrxPostProcessor;

Field Value

Type: TfrxPostProcessor

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.FPrintScale Field

Summary

Represents field FPrintScale.

Namespace: frxClass
Syntax
Delphi
protected
 FPrintScale: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomPreviewPages.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomPreviewPages
  • frxClass


TfrxCustomWizard Class

Summary

The TfrxCustomWizard class is the basic class for any wizards. Wizards are called from the designer's menu "File|New...". Wizard should be registered via frxWizards.Register method, defined in the frxDsgnIntf unit.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxCustomWizard
Syntax
Delphi
type
 TfrxCustomWizard = class(TComponent)
 end;

The TfrxCustomWizard type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomWizard class.
Top
Properties
Show:
Name | Description
Designer | Reference to the report designer.
Report | Reference to the report.
Top
Methods
Show:
Name | Description
Execute | Method is called when running the wizard; it must return "True," if the wizard finished working successfully and brought any changes to the report.
GetDescription | Returns the wizard description.
Top
Fields
Show:
Name | Description
FDesigner | Represents field FDesigner.
FReport | Represents field FReport.
Top
See Also

Reference

  • frxClass


TfrxCustomWizard Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomWizard class.
Top


TfrxCustomWizard.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomWizard class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxCustomWizard
  • frxClass


TfrxCustomWizard Properties

Properties
Name | Description
Designer | Reference to the report designer.
Report | Reference to the report.
Top


TfrxCustomWizard.Designer Property

Summary

Reference to the report designer.

Namespace: frxClass
Syntax
Delphi
public
 property Designer: TfrxCustomDesigner read FDesigner;

Property Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxCustomWizard
  • frxClass


TfrxCustomWizard.Report Property

Summary

Reference to the report.

Namespace: frxClass
Syntax
Delphi
public
 property Report: TfrxReport read FReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomWizard
  • frxClass


TfrxCustomWizard Methods

Methods
Name | Description
Execute | Method is called when running the wizard; it must return "True," if the wizard finished working successfully and brought any changes to the report.
GetDescription | Returns the wizard description.
Top


TfrxCustomWizard.Execute Method

Summary

Method is called when running the wizard; it must return "True," if the wizard finished working successfully and brought any changes to the report.

Namespace: frxClass
Syntax
Delphi
public
 function Execute: Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomWizard
  • frxClass


TfrxCustomWizard.GetDescription Method

Summary

Returns the wizard description.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxCustomWizard
  • frxClass


TfrxCustomWizard Fields

Fields
Name | Description
FDesigner | Represents field FDesigner.
FReport | Represents field FReport.
Top


TfrxCustomWizard.FDesigner Field

Summary

Represents field FDesigner.

Namespace: frxClass
Syntax
Delphi
private
 FDesigner: TfrxCustomDesigner;

Field Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxCustomWizard
  • frxClass


TfrxCustomWizard.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxCustomWizard
  • frxClass


TfrxDataBand Class

Summary

The TfrxDataBand class is the base class for all data-bands. Data-band is a band connected to a dataset. Data-band is displayed as many times as there are records in the dataset.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxDataBand
frxClass.TfrxDataBand4
frxClass.TfrxDataBand5
frxClass.TfrxDataBand6
frxClass.TfrxDetailData
frxClass.TfrxMasterData
frxClass.TfrxSubdetailData
Syntax
Delphi
type
 TfrxDataBand = class(TfrxBand)
 end;

The TfrxDataBand type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataBand class. (Overrides TfrxBand.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxDataBand class. (Overrides TfrxBand.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child.
ColumnGap | Gap between band's columns, in pixels.
Columns | The "Columns" property, available in all data-bands, allows to set number of columns for a particular band and not for the whole page. Thus, displaying of data will be not "from the top to the bottom, then from the left to the right," but "from left to right, then from top to bottom". You also should set ColumnWidth and ColumnGap properties.
ColumnWidth | Width of the band's column, in pixels.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
CurColumn | Current column of the band.
DataSet | Dataset for a band.
DataSetName | Dataset name for a band. This property duplicates the DataSet property.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Filter | An expression used to manage visibility of a band record. if result of this expression is True, band will be shown.
Font | Represents property Font. (Inherited from TfrxBand.)
FooterAfterEach | Determines whether to show band footer after each record. Default value is False. By default the footer is displayed after printing all dataset records.
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False.
KeepFooter | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False.
KeepHeader | Determines whether to show band header on the same page as the banditself. If header does not find room on the page, it will be carriedto the next page. Default value is False.
KeepTogether | Determines whether to print the band together with all its subbands on the same page. Default value is False.
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnMasterDetail | Name of the script procedure that will be called before the band will check if any subbands are empty.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | Represents property OutlineText.
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
PrintIfDetailEmpty | Determines whether to print the band if all its subbands are empty. Default value is False.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
RowCount | Allows printing the band N times. This property is used if the band is NOT connected to the dataset.
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Represents property StartNewPage.
Stretched | Represents property Stretched.
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
VirtualDataSet | Represents property VirtualDataSet.
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Overrides TfrxBand.GetBandTitleColor.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDataSetName | Represents method GetDataSetName.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxBand.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxBand.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCurColumn(Integer) | Represents method SetCurColumn(Integer).
SetDataSet(TfrxDataSet) | Represents method SetDataSet(TfrxDataSet).
SetDataSetName(String) | Represents method SetDataSetName(String).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetRowCount(Integer) | Represents method SetRowCount(Integer).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FColumnGap | Represents field FColumnGap.
FColumns | Represents field FColumns.
FColumnWidth | Represents field FColumnWidth.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurColumn | Represents field FCurColumn.
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
FFilter | Represents field FFilter.
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FFooterAfterEach | Represents field FFooterAfterEach.
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FKeepFooter | Represents field FKeepFooter.
FKeepHeader | Represents field FKeepHeader.
FKeepTogether | Represents field FKeepTogether.
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FMaxY | Represents field FMaxY.
FOnMasterDetail | Represents field FOnMasterDetail.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintIfDetailEmpty | Represents field FPrintIfDetailEmpty.
FRowCount | Represents field FRowCount.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
FVirtualDataSet | Represents field FVirtualDataSet.
Top
See Also

Reference

  • frxClass


TfrxDataBand Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataBand class. (Overrides TfrxBand.Create(TComponent).)
Destroy | Represents the destructor of the TfrxDataBand class. (Overrides TfrxBand.Destroy.)
Top


TfrxDataBand.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDataBand class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxBand.Create(TComponent)
See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.Destroy Destructor

Summary

Represents the destructor of the TfrxDataBand class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxBand.Destroy
See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand Properties

Properties
Name | Description
AllowSplit | Represents property AllowSplit.
Child | Represents property Child.
ColumnGap | Gap between band's columns, in pixels.
Columns | The "Columns" property, available in all data-bands, allows to set number of columns for a particular band and not for the whole page. Thus, displaying of data will be not "from the top to the bottom, then from the left to the right," but "from left to right, then from top to bottom". You also should set ColumnWidth and ColumnGap properties.
ColumnWidth | Width of the band's column, in pixels.
CurColumn | Current column of the band.
DataSet | Dataset for a band.
DataSetName | Dataset name for a band. This property duplicates the DataSet property.
Filter | An expression used to manage visibility of a band record. if result of this expression is True, band will be shown.
FooterAfterEach | Determines whether to show band footer after each record. Default value is False. By default the footer is displayed after printing all dataset records.
KeepChild | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False.
KeepFooter | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False.
KeepHeader | Determines whether to show band header on the same page as the banditself. If header does not find room on the page, it will be carriedto the next page. Default value is False.
KeepTogether | Determines whether to print the band together with all its subbands on the same page. Default value is False.
OnMasterDetail | Name of the script procedure that will be called before the band will check if any subbands are empty.
OutlineText | Represents property OutlineText.
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
PrintIfDetailEmpty | Determines whether to print the band if all its subbands are empty. Default value is False.
RowCount | Allows printing the band N times. This property is used if the band is NOT connected to the dataset.
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Represents property StartNewPage.
Stretched | Represents property Stretched.
VirtualDataSet | Represents property VirtualDataSet.
Top


TfrxDataBand.AllowSplit Property

Summary

Represents property AllowSplit.

Namespace: frxClass
Syntax
Delphi
published
 property AllowSplit;

Property Value

Type: Void

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.Child Property

Summary

Represents property Child.

Namespace: frxClass
Syntax
Delphi
published
 property Child;

Property Value

Type: Void

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.ColumnGap Property

Summary

Gap between band's columns, in pixels.

Namespace: frxClass
Syntax
Delphi
published
 property ColumnGap: Extended read FColumnGap write FColumnGap;

Property Value

Type: Extended

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.Columns Property

Summary

The "Columns" property, available in all data-bands, allows to set number of columns for a particular band and not for the whole page. Thus, displaying of data will be not "from the top to the bottom, then from the left to the right," but "from left to right, then from top to bottom". You also should set ColumnWidth and ColumnGap properties.

Namespace: frxClass
Syntax
Delphi
published
 property Columns: Integer read FColumns write FColumns default 0;

Property Value

Type: Integer

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.ColumnWidth Property

Summary

Width of the band's column, in pixels.

Namespace: frxClass
Syntax
Delphi
published
 property ColumnWidth: Extended read FColumnWidth write FColumnWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.CurColumn Property

Summary

Current column of the band.

Namespace: frxClass
Syntax
Delphi
public
 property CurColumn: Integer read FCurColumn write SetCurColumn;

Property Value

Type: Integer

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.DataSet Property

Summary

Dataset for a band.

Namespace: frxClass
Syntax
Delphi
published
 property DataSet: TfrxDataSet read FDataSet write SetDataSet;

Property Value

Type: TfrxDataSet

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.DataSetName Property

Summary

Dataset name for a band. This property duplicates the DataSet property.

Namespace: frxClass
Syntax
Delphi
published
 property DataSetName: String read GetDataSetName write SetDataSetName;

Property Value

Type: String

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.Filter Property

Summary

An expression used to manage visibility of a band record. if result of this expression is True, band will be shown.

Namespace: frxClass
Syntax
Delphi
published
 property Filter: String read FFilter write FFilter;

Property Value

Type: String

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FooterAfterEach Property

Summary

Determines whether to show band footer after each record. Default value is False. By default the footer is displayed after printing all dataset records.

Namespace: frxClass
Syntax
Delphi
published
 property FooterAfterEach: Boolean read FFooterAfterEach write FFooterAfterEach default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.KeepChild Property

Summary

Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property KeepChild;

Property Value

Type: Void

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.KeepFooter Property

Summary

Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property KeepFooter: Boolean read FKeepFooter write FKeepFooter default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.KeepHeader Property

Summary

Determines whether to show band header on the same page as the banditself. If header does not find room on the page, it will be carriedto the next page. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property KeepHeader: Boolean read FKeepHeader write FKeepHeader default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.KeepTogether Property

Summary

Determines whether to print the band together with all its subbands on the same page. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property KeepTogether: Boolean read FKeepTogether write FKeepTogether default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.OnMasterDetail Property

Summary

Name of the script procedure that will be called before the band will check if any subbands are empty.

Namespace: frxClass
Syntax
Delphi
published
 property OnMasterDetail: TfrxNotifyEvent read FOnMasterDetail write FOnMasterDetail;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.OutlineText Property

Summary

Represents property OutlineText.

Namespace: frxClass
Syntax
Delphi
published
 property OutlineText;

Property Value

Type: Void

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.PrintChildIfInvisible Property

Summary

Represents property PrintChildIfInvisible.

Namespace: frxClass
Syntax
Delphi
published
 property PrintChildIfInvisible;

Property Value

Type: Void

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.PrintIfDetailEmpty Property

Summary

Determines whether to print the band if all its subbands are empty. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property PrintIfDetailEmpty: Boolean read FPrintIfDetailEmpty
 write FPrintIfDetailEmpty default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.RowCount Property

Summary

Allows printing the band N times. This property is used if the band is NOT connected to the dataset.

Namespace: frxClass
Syntax
Delphi
published
 property RowCount: Integer read FRowCount write SetRowCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.ShiftEngine Property

Summary

Represents property ShiftEngine.

Namespace: frxClass
Syntax
Delphi
published
 property ShiftEngine;

Property Value

Type: Void

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.StartNewPage Property

Summary

Represents property StartNewPage.

Namespace: frxClass
Syntax
Delphi
published
 property StartNewPage;

Property Value

Type: Void

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.Stretched Property

Summary

Represents property Stretched.

Namespace: frxClass
Syntax
Delphi
published
 property Stretched;

Property Value

Type: Void

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.VirtualDataSet Property

Summary

Represents property VirtualDataSet.

Namespace: frxClass
Syntax
Delphi
public
 property VirtualDataSet: TfrxUserDataSet read FVirtualDataSet;

Property Value

Type: TfrxUserDataSet

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand Methods

Methods
Name | Description
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended).)
GetBandTitleColor | Represents method GetBandTitleColor. (Overrides TfrxBand.GetBandTitleColor.)
GetDataSetName | Represents method GetDataSetName.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxBand.GetDescription.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxBand.Notification(TComponent,TOperation).)
SetCurColumn(Integer) | Represents method SetCurColumn(Integer).
SetDataSet(TfrxDataSet) | Represents method SetDataSet(TfrxDataSet).
SetDataSetName(String) | Represents method SetDataSetName(String).
SetRowCount(Integer) | Represents method SetRowCount(Integer).
Top


TfrxDataBand.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.GetBandTitleColor Method

Summary

Represents method GetBandTitleColor.

Namespace: frxClass
Syntax
Delphi
protected
 function GetBandTitleColor: TColor; override;

Return Value

Type: TColor

Overrides

TfrxBand.GetBandTitleColor
See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.GetDataSetName Method

Summary

Represents method GetDataSetName.

Namespace: frxClass
Syntax
Delphi
private
 function GetDataSetName: String;

Return Value

Type: String

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxBand.GetDescription
See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: frxClass
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

Overrides

TfrxBand.Notification(TComponent,TOperation)
See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.SetCurColumn(Integer) Method

Summary

Represents method SetCurColumn(Integer).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetCurColumn(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.SetDataSet(TfrxDataSet) Method

Summary

Represents method SetDataSet(TfrxDataSet).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDataSet(const Value: TfrxDataSet);

Parameters

Value
Type: TfrxDataSet

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.SetDataSetName(String) Method

Summary

Represents method SetDataSetName(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDataSetName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.SetRowCount(Integer) Method

Summary

Represents method SetRowCount(Integer).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetRowCount(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand Fields

Fields
Name | Description
FColumnGap | Represents field FColumnGap.
FColumns | Represents field FColumns.
FColumnWidth | Represents field FColumnWidth.
FCurColumn | Represents field FCurColumn.
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
FFilter | Represents field FFilter.
FFooterAfterEach | Represents field FFooterAfterEach.
FKeepFooter | Represents field FKeepFooter.
FKeepHeader | Represents field FKeepHeader.
FKeepTogether | Represents field FKeepTogether.
FMaxY | Represents field FMaxY.
FOnMasterDetail | Represents field FOnMasterDetail.
FPrintIfDetailEmpty | Represents field FPrintIfDetailEmpty.
FRowCount | Represents field FRowCount.
FVirtualDataSet | Represents field FVirtualDataSet.
Top


TfrxDataBand.FColumnGap Field

Summary

Represents field FColumnGap.

Namespace: frxClass
Syntax
Delphi
private
 FColumnGap: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FColumns Field

Summary

Represents field FColumns.

Namespace: frxClass
Syntax
Delphi
private
 FColumns: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FColumnWidth Field

Summary

Represents field FColumnWidth.

Namespace: frxClass
Syntax
Delphi
private
 FColumnWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FCurColumn Field

Summary

Represents field FCurColumn.

Namespace: frxClass
Syntax
Delphi
private
 FCurColumn: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FDataSet Field

Summary

Represents field FDataSet.

Namespace: frxClass
Syntax
Delphi
private
 FDataSet: TfrxDataSet;

Field Value

Type: TfrxDataSet

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FDataSetName Field

Summary

Represents field FDataSetName.

Namespace: frxClass
Syntax
Delphi
private
 FDataSetName: String;

Field Value

Type: String

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FFilter Field

Summary

Represents field FFilter.

Namespace: frxClass
Syntax
Delphi
private
 FFilter: String;

Field Value

Type: String

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FFooterAfterEach Field

Summary

Represents field FFooterAfterEach.

Namespace: frxClass
Syntax
Delphi
private
 FFooterAfterEach: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FKeepFooter Field

Summary

Represents field FKeepFooter.

Namespace: frxClass
Syntax
Delphi
private
 FKeepFooter: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FKeepHeader Field

Summary

Represents field FKeepHeader.

Namespace: frxClass
Syntax
Delphi
private
 FKeepHeader: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FKeepTogether Field

Summary

Represents field FKeepTogether.

Namespace: frxClass
Syntax
Delphi
private
 FKeepTogether: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FMaxY Field

Summary

Represents field FMaxY.

Namespace: frxClass
Syntax
Delphi
public
 FMaxY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FOnMasterDetail Field

Summary

Represents field FOnMasterDetail.

Namespace: frxClass
Syntax
Delphi
private
 FOnMasterDetail: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FPrintIfDetailEmpty Field

Summary

Represents field FPrintIfDetailEmpty.

Namespace: frxClass
Syntax
Delphi
private
 FPrintIfDetailEmpty: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FRowCount Field

Summary

Represents field FRowCount.

Namespace: frxClass
Syntax
Delphi
private
 FRowCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand.FVirtualDataSet Field

Summary

Represents field FVirtualDataSet.

Namespace: frxClass
Syntax
Delphi
private
 FVirtualDataSet: TfrxUserDataSet;

Field Value

Type: TfrxUserDataSet

See Also

Reference

  • TfrxDataBand
  • frxClass


TfrxDataBand4 Class

Summary

The TfrxDataBand4 represents a "4th data level" band.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxDataBand
frxClass.TfrxDataBand4
Syntax
Delphi
type
 TfrxDataBand4 = class(TfrxDataBand)
 end;

The TfrxDataBand4 type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataBand class. (Overrides TfrxBand.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit. (Inherited from TfrxDataBand.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child. (Inherited from TfrxDataBand.)
ColumnGap | Gap between band's columns, in pixels. (Inherited from TfrxDataBand.)
Columns | The "Columns" property, available in all data-bands, allows to set number of columns for a particular band and not for the whole page. Thus, displaying of data will be not "from the top to the bottom, then from the left to the right," but "from left to right, then from top to bottom". You also should set ColumnWidth and ColumnGap properties. (Inherited from TfrxDataBand.)
ColumnWidth | Width of the band's column, in pixels. (Inherited from TfrxDataBand.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
CurColumn | Current column of the band. (Inherited from TfrxDataBand.)
DataSet | Dataset for a band. (Inherited from TfrxDataBand.)
DataSetName | Dataset name for a band. This property duplicates the DataSet property. (Inherited from TfrxDataBand.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Filter | An expression used to manage visibility of a band record. if result of this expression is True, band will be shown. (Inherited from TfrxDataBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
FooterAfterEach | Determines whether to show band footer after each record. Default value is False. By default the footer is displayed after printing all dataset records. (Inherited from TfrxDataBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False. (Inherited from TfrxDataBand.)
KeepFooter | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False. (Inherited from TfrxDataBand.)
KeepHeader | Determines whether to show band header on the same page as the banditself. If header does not find room on the page, it will be carriedto the next page. Default value is False. (Inherited from TfrxDataBand.)
KeepTogether | Determines whether to print the band together with all its subbands on the same page. Default value is False. (Inherited from TfrxDataBand.)
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnMasterDetail | Name of the script procedure that will be called before the band will check if any subbands are empty. (Inherited from TfrxDataBand.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | Represents property OutlineText. (Inherited from TfrxDataBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible. (Inherited from TfrxDataBand.)
PrintIfDetailEmpty | Determines whether to print the band if all its subbands are empty. Default value is False. (Inherited from TfrxDataBand.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
RowCount | Allows printing the band N times. This property is used if the band is NOT connected to the dataset. (Inherited from TfrxDataBand.)
ShiftEngine | Represents property ShiftEngine. (Inherited from TfrxDataBand.)
StartNewPage | Represents property StartNewPage. (Inherited from TfrxDataBand.)
Stretched | Represents property Stretched. (Inherited from TfrxDataBand.)
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
VirtualDataSet | Represents property VirtualDataSet. (Inherited from TfrxDataBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Overrides TfrxBand.GetBandTitleColor.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxBand.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxBand.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FMaxY | Represents field FMaxY. (Inherited from TfrxDataBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxDataBand5 Class

Summary

The TfrxDataBand5 represents a "5th data level" band.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxDataBand
frxClass.TfrxDataBand5
Syntax
Delphi
type
 TfrxDataBand5 = class(TfrxDataBand)
 end;

The TfrxDataBand5 type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataBand class. (Overrides TfrxBand.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit. (Inherited from TfrxDataBand.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child. (Inherited from TfrxDataBand.)
ColumnGap | Gap between band's columns, in pixels. (Inherited from TfrxDataBand.)
Columns | The "Columns" property, available in all data-bands, allows to set number of columns for a particular band and not for the whole page. Thus, displaying of data will be not "from the top to the bottom, then from the left to the right," but "from left to right, then from top to bottom". You also should set ColumnWidth and ColumnGap properties. (Inherited from TfrxDataBand.)
ColumnWidth | Width of the band's column, in pixels. (Inherited from TfrxDataBand.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
CurColumn | Current column of the band. (Inherited from TfrxDataBand.)
DataSet | Dataset for a band. (Inherited from TfrxDataBand.)
DataSetName | Dataset name for a band. This property duplicates the DataSet property. (Inherited from TfrxDataBand.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Filter | An expression used to manage visibility of a band record. if result of this expression is True, band will be shown. (Inherited from TfrxDataBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
FooterAfterEach | Determines whether to show band footer after each record. Default value is False. By default the footer is displayed after printing all dataset records. (Inherited from TfrxDataBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False. (Inherited from TfrxDataBand.)
KeepFooter | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False. (Inherited from TfrxDataBand.)
KeepHeader | Determines whether to show band header on the same page as the banditself. If header does not find room on the page, it will be carriedto the next page. Default value is False. (Inherited from TfrxDataBand.)
KeepTogether | Determines whether to print the band together with all its subbands on the same page. Default value is False. (Inherited from TfrxDataBand.)
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnMasterDetail | Name of the script procedure that will be called before the band will check if any subbands are empty. (Inherited from TfrxDataBand.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | Represents property OutlineText. (Inherited from TfrxDataBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible. (Inherited from TfrxDataBand.)
PrintIfDetailEmpty | Determines whether to print the band if all its subbands are empty. Default value is False. (Inherited from TfrxDataBand.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
RowCount | Allows printing the band N times. This property is used if the band is NOT connected to the dataset. (Inherited from TfrxDataBand.)
ShiftEngine | Represents property ShiftEngine. (Inherited from TfrxDataBand.)
StartNewPage | Represents property StartNewPage. (Inherited from TfrxDataBand.)
Stretched | Represents property Stretched. (Inherited from TfrxDataBand.)
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
VirtualDataSet | Represents property VirtualDataSet. (Inherited from TfrxDataBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Overrides TfrxBand.GetBandTitleColor.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxBand.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxBand.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FMaxY | Represents field FMaxY. (Inherited from TfrxDataBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxDataBand6 Class

Summary

The TfrxDataBand6 represents a "6th data level" band.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxDataBand
frxClass.TfrxDataBand6
Syntax
Delphi
type
 TfrxDataBand6 = class(TfrxDataBand)
 end;

The TfrxDataBand6 type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataBand class. (Overrides TfrxBand.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit. (Inherited from TfrxDataBand.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child. (Inherited from TfrxDataBand.)
ColumnGap | Gap between band's columns, in pixels. (Inherited from TfrxDataBand.)
Columns | The "Columns" property, available in all data-bands, allows to set number of columns for a particular band and not for the whole page. Thus, displaying of data will be not "from the top to the bottom, then from the left to the right," but "from left to right, then from top to bottom". You also should set ColumnWidth and ColumnGap properties. (Inherited from TfrxDataBand.)
ColumnWidth | Width of the band's column, in pixels. (Inherited from TfrxDataBand.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
CurColumn | Current column of the band. (Inherited from TfrxDataBand.)
DataSet | Dataset for a band. (Inherited from TfrxDataBand.)
DataSetName | Dataset name for a band. This property duplicates the DataSet property. (Inherited from TfrxDataBand.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Filter | An expression used to manage visibility of a band record. if result of this expression is True, band will be shown. (Inherited from TfrxDataBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
FooterAfterEach | Determines whether to show band footer after each record. Default value is False. By default the footer is displayed after printing all dataset records. (Inherited from TfrxDataBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False. (Inherited from TfrxDataBand.)
KeepFooter | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False. (Inherited from TfrxDataBand.)
KeepHeader | Determines whether to show band header on the same page as the banditself. If header does not find room on the page, it will be carriedto the next page. Default value is False. (Inherited from TfrxDataBand.)
KeepTogether | Determines whether to print the band together with all its subbands on the same page. Default value is False. (Inherited from TfrxDataBand.)
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnMasterDetail | Name of the script procedure that will be called before the band will check if any subbands are empty. (Inherited from TfrxDataBand.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | Represents property OutlineText. (Inherited from TfrxDataBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible. (Inherited from TfrxDataBand.)
PrintIfDetailEmpty | Determines whether to print the band if all its subbands are empty. Default value is False. (Inherited from TfrxDataBand.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
RowCount | Allows printing the band N times. This property is used if the band is NOT connected to the dataset. (Inherited from TfrxDataBand.)
ShiftEngine | Represents property ShiftEngine. (Inherited from TfrxDataBand.)
StartNewPage | Represents property StartNewPage. (Inherited from TfrxDataBand.)
Stretched | Represents property Stretched. (Inherited from TfrxDataBand.)
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
VirtualDataSet | Represents property VirtualDataSet. (Inherited from TfrxDataBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Overrides TfrxBand.GetBandTitleColor.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxBand.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxBand.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FMaxY | Represents field FMaxY. (Inherited from TfrxDataBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxDataPage Class

Summary

The TfrxDataPage represents a datamodule.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxPage
frxClass.TfrxDataPage
Syntax
Delphi
type
 TfrxDataPage = class(TfrxPage)
 end;

The TfrxDataPage type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataPage class. (Overrides TfrxPage.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Object's description. (Inherited from TfrxComponent.)
Font | Represents property Font. (Inherited from TfrxPage.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height.
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left.
Objects | The list of child objects. (Inherited from TfrxComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Top | Represents property Top.
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxPage.)
Width | Represents property Width.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | Represents method Draw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxPage.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
Top
See Also

Reference

  • frxClass


TfrxDataPage Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataPage class. (Overrides TfrxPage.Create(TComponent).)
Top


TfrxDataPage.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDataPage class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxPage.Create(TComponent)
See Also

Reference

  • TfrxDataPage
  • frxClass


TfrxDataPage Properties

Properties
Name | Description
Height | Represents property Height.
Left | Represents property Left.
Top | Represents property Top.
Width | Represents property Width.
Top


TfrxDataPage.Height Property

Summary

Represents property Height.

Namespace: frxClass
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TfrxDataPage
  • frxClass


TfrxDataPage.Left Property

Summary

Represents property Left.

Namespace: frxClass
Syntax
Delphi
published
 property Left;

Property Value

Type: Void

See Also

Reference

  • TfrxDataPage
  • frxClass


TfrxDataPage.Top Property

Summary

Represents property Top.

Namespace: frxClass
Syntax
Delphi
published
 property Top;

Property Value

Type: Void

See Also

Reference

  • TfrxDataPage
  • frxClass


TfrxDataPage.Width Property

Summary

Represents property Width.

Namespace: frxClass
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TfrxDataPage
  • frxClass


TfrxDataPage Methods

Methods
Name | Description
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
Top


TfrxDataPage.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxDataPage
  • frxClass


TfrxDataSet Class

Summary

The TfrxDataSet class is used for navigation of a dataset. It is base class for TfrxDBDataSet, TfrxUserDataSet components.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogComponent
frxClass.TfrxDataSet
frxClass.TfrxCustomDBDataSet
frxClass.TfrxUserDataSet
Syntax
Delphi
type
 TfrxDataSet = class(TfrxDialogComponent)
 end;

The TfrxDataSet type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataSet class. (Overrides TfrxDialogComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxDataSet class. (Overrides TfrxDialogComponent.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
CloseDataSource | Close a data set after report construction is completed.
Component | Link to the component itself. (Inherited from TfrxDialogComponent.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DisplayText[String] | Returns the field value as a string.
DisplayWidth[String] | Returns the size of a specified field.
Enabled | Defines, if the given component is available from the designer.
FieldType[String] | Returns the field type
Font | Object's font. (Inherited from TfrxComponent.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClose | An event occurs when closing a data set.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnFirst | This event's handler must move the cursor to the beginning of the data set.
OnNext | This event's handler must move the cursor to the next record.
OnOpen | An event occurs when opening a data set.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPrior | This event's handler must move the cursor to the previous record.
OpenDataSource | Open a data set before report construction is started.
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
RangeBegin | The navigation start point.
RangeEnd | The endpoint of navigation.
RangeEndCount | A number of records in the data set, if the "RangeEnd" property = reCount.
RecNo | A current record number. The first record's number is "0".
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
ReportRef | Reference for the report owner if any.
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
UserName | A symbolic name, under which the dataset will be displayed in the designer.
Value[String] | Returns the field value as a variant.
Visible | Global visibility of the object in the result report. (Inherited from TfrxComponent.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
AssignBlobTo(String,TObject) | Assigns stream in Obj to BLOB field with fName name.
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Close | Closes the dataset.
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxDialogComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
Eof | Function returns True if end of the dataset is reached.
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FieldsCount | Returns the number of fields defined in the dataset.
Finalize | Finalizes DataSet after close.
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
First | Sets the cursor to the first record.
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDisplayText(String) | Represents method GetDisplayText(String).
GetDisplayWidth(String) | Represents method GetDisplayWidth(String).
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetFieldList(TStrings) | Returns list of dataset fields.
GetFieldType(String) | Represents method GetFieldType(String).
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetValue(String) | Represents method GetValue(String).
HasField(String) | Returns True if dataset has field with specified name.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
Initialize | Initializes DataSet before open.
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsBlobField(String) | Returns True if dataset has BLOB field with specified name.
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHasMaster | Returns True if DataSet has master RecordSet.
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWideMemoBlobField(String) | Returns True if dataset has wide memo BLOB field with specified name.
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Next | Moves the cursor to the next record.
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
Open | Opens the dataset.
Prior | Moves the cursor to the previous record. This method is used only when printing groups.
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
RecordCount | Returns records count if DataSet supports it.
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetUserName(String) | Represents method SetUserName(String).
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Events
Show:
Name | Description
OnCheckEOF | This event's handler must return the Eof = True parameter, if the end of the data set is reached.
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCloseDataSource | Represents field FCloseDataSource.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FEnabled | Represents field FEnabled.
FEof | Represents field FEof.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FImageIndex | Represents field FImageIndex. (Inherited from TfrxDialogComponent.)
FInitialized | Represents field FInitialized.
FOnCheckEOF | Represents field FOnCheckEOF.
FOnClose | Represents field FOnClose.
FOnFirst | Represents field FOnFirst.
FOnNext | Represents field FOnNext.
FOnOpen | Represents field FOnOpen.
FOnPrior | Represents field FOnPrior.
FOpenDataSource | Represents field FOpenDataSource.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FRangeBegin | Represents field FRangeBegin.
FRangeEnd | Represents field FRangeEnd.
FRangeEndCount | Represents field FRangeEndCount.
FRecNo | Represents field FRecNo.
FReportRef | Represents field FReportRef.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FUserName | Represents field FUserName.
Top
See Also

Reference

  • frxClass


TfrxDataSet Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataSet class. (Overrides TfrxDialogComponent.Create(TComponent).)
Destroy | Represents the destructor of the TfrxDataSet class. (Overrides TfrxDialogComponent.Destroy.)
Top


TfrxDataSet.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDataSet class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogComponent.Create(TComponent)
See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.Destroy Destructor

Summary

Represents the destructor of the TfrxDataSet class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxDialogComponent.Destroy
See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet Properties

Properties
Name | Description
CloseDataSource | Close a data set after report construction is completed.
DisplayText[String] | Returns the field value as a string.
DisplayWidth[String] | Returns the size of a specified field.
Enabled | Defines, if the given component is available from the designer.
FieldType[String] | Returns the field type
OnClose | An event occurs when closing a data set.
OnFirst | This event's handler must move the cursor to the beginning of the data set.
OnNext | This event's handler must move the cursor to the next record.
OnOpen | An event occurs when opening a data set.
OnPrior | This event's handler must move the cursor to the previous record.
OpenDataSource | Open a data set before report construction is started.
RangeBegin | The navigation start point.
RangeEnd | The endpoint of navigation.
RangeEndCount | A number of records in the data set, if the "RangeEnd" property = reCount.
RecNo | A current record number. The first record's number is "0".
ReportRef | Reference for the report owner if any.
UserName | A symbolic name, under which the dataset will be displayed in the designer.
Value[String] | Returns the field value as a variant.
Top


TfrxDataSet.CloseDataSource Property

Summary

Close a data set after report construction is completed.

Namespace: frxClass
Syntax
Delphi
public
 property CloseDataSource: Boolean read FCloseDataSource write FCloseDataSource;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.DisplayText[String] Property

Summary

Returns the field value as a string.

Namespace: frxClass
Syntax
Delphi
public
 property DisplayText[Index: String]: WideString read GetDisplayText;

Parameters

Index
Type: String

Property Value

Type: WideString

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.DisplayWidth[String] Property

Summary

Returns the size of a specified field.

Namespace: frxClass
Syntax
Delphi
public
 property DisplayWidth[Index: String]: Integer read GetDisplayWidth;

Parameters

Index
Type: String

Property Value

Type: Integer

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.Enabled Property

Summary

Defines, if the given component is available from the designer.

Namespace: frxClass
Syntax
Delphi
published
 property Enabled: Boolean read FEnabled write FEnabled default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FieldType[String] Property

Summary

Returns the field type

Namespace: frxClass
Syntax
Delphi
public
 property FieldType[Index: String]: TfrxFieldType read GetFieldType;

Parameters

Index
Type: String

Property Value

Type: TfrxFieldType

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.OnClose Property

Summary

An event occurs when closing a data set.

Namespace: frxClass
Syntax
Delphi
public
 property OnClose: TNotifyEvent read FOnClose write FOnClose;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.OnFirst Property

Summary

This event's handler must move the cursor to the beginning of the data set.

Namespace: frxClass
Syntax
Delphi
published
 property OnFirst: TNotifyEvent read FOnFirst write FOnFirst;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.OnNext Property

Summary

This event's handler must move the cursor to the next record.

Namespace: frxClass
Syntax
Delphi
published
 property OnNext: TNotifyEvent read FOnNext write FOnNext;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.OnOpen Property

Summary

An event occurs when opening a data set.

Namespace: frxClass
Syntax
Delphi
public
 property OnOpen: TNotifyEvent read FOnOpen write FOnOpen;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.OnPrior Property

Summary

This event's handler must move the cursor to the previous record.

Namespace: frxClass
Syntax
Delphi
published
 property OnPrior: TNotifyEvent read FOnPrior write FOnPrior;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.OpenDataSource Property

Summary

Open a data set before report construction is started.

Namespace: frxClass
Syntax
Delphi
public
 property OpenDataSource: Boolean read FOpenDataSource write FOpenDataSource default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.RangeBegin Property

Summary

The navigation start point.

Namespace: frxClass
Syntax
Delphi
published
 property RangeBegin: TfrxRangeBegin read FRangeBegin write FRangeBegin default rbFirst;

Property Value

Type: TfrxRangeBegin

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.RangeEnd Property

Summary

The endpoint of navigation.

Namespace: frxClass
Syntax
Delphi
published
 property RangeEnd: TfrxRangeEnd read FRangeEnd write FRangeEnd default reLast;

Property Value

Type: TfrxRangeEnd

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.RangeEndCount Property

Summary

A number of records in the data set, if the "RangeEnd" property = reCount.

Namespace: frxClass
Syntax
Delphi
published
 property RangeEndCount: Integer read FRangeEndCount write FRangeEndCount default 0;

Property Value

Type: Integer

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.RecNo Property

Summary

A current record number. The first record's number is "0".

Namespace: frxClass
Syntax
Delphi
public
 property RecNo: Integer read FRecNo;

Property Value

Type: Integer

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.ReportRef Property

Summary

Reference for the report owner if any.

Namespace: frxClass
Syntax
Delphi
public
 property ReportRef: TfrxReport read FReportRef write FReportRef;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.UserName Property

Summary

A symbolic name, under which the dataset will be displayed in the designer.

Namespace: frxClass
Syntax
Delphi
published
 property UserName: String read FUserName write SetUserName;

Property Value

Type: String

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.Value[String] Property

Summary

Returns the field value as a variant.

Namespace: frxClass
Syntax
Delphi
public
 property Value[Index: String]: Variant read GetValue;

Parameters

Index
Type: String

Property Value

Type: Variant

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet Methods

Methods
Name | Description
AssignBlobTo(String,TObject) | Assigns stream in Obj to BLOB field with fName name.
Close | Closes the dataset.
Eof | Function returns True if end of the dataset is reached.
FieldsCount | Returns the number of fields defined in the dataset.
Finalize | Finalizes DataSet after close.
First | Sets the cursor to the first record.
GetDisplayText(String) | Represents method GetDisplayText(String).
GetDisplayWidth(String) | Represents method GetDisplayWidth(String).
GetFieldList(TStrings) | Returns list of dataset fields.
GetFieldType(String) | Represents method GetFieldType(String).
GetValue(String) | Represents method GetValue(String).
HasField(String) | Returns True if dataset has field with specified name.
Initialize | Initializes DataSet before open.
IsBlobField(String) | Returns True if dataset has BLOB field with specified name.
IsHasMaster | Returns True if DataSet has master RecordSet.
IsWideMemoBlobField(String) | Returns True if dataset has wide memo BLOB field with specified name.
Next | Moves the cursor to the next record.
Open | Opens the dataset.
Prior | Moves the cursor to the previous record. This method is used only when printing groups.
RecordCount | Returns records count if DataSet supports it.
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetUserName(String) | Represents method SetUserName(String).
Top


TfrxDataSet.AssignBlobTo(String,TObject) Method

Summary

Assigns stream in Obj to BLOB field with fName name.

Namespace: frxClass
Syntax
Delphi
public
 procedure AssignBlobTo(const fName: String; Obj: TObject); virtual;

Parameters

fName
Type: String

Name of the BLOB field.

Obj
Type: TObject

Object serialized to blob (supports TStream successors).

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.Close Method

Summary

Closes the dataset.

Namespace: frxClass
Syntax
Delphi
public
 procedure Close; virtual;
See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.Eof Method

Summary

Function returns True if end of the dataset is reached.

Namespace: frxClass
Syntax
Delphi
public
 function Eof: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FieldsCount Method

Summary

Returns the number of fields defined in the dataset.

Namespace: frxClass
Syntax
Delphi
public
 function FieldsCount: Integer; virtual;

Return Value

Type: Integer

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.Finalize Method

Summary

Finalizes DataSet after close.

Namespace: frxClass
Syntax
Delphi
public
 procedure Finalize; virtual;
See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.First Method

Summary

Sets the cursor to the first record.

Namespace: frxClass
Syntax
Delphi
public
 procedure First; virtual;
See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.GetDisplayText(String) Method

Summary

Represents method GetDisplayText(String).

Namespace: frxClass
Syntax
Delphi
protected
 function GetDisplayText(Index: String): WideString; virtual;

Parameters

Index
Type: String

Return Value

Type: WideString

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.GetDisplayWidth(String) Method

Summary

Represents method GetDisplayWidth(String).

Namespace: frxClass
Syntax
Delphi
protected
 function GetDisplayWidth(Index: String): Integer; virtual;

Parameters

Index
Type: String

Return Value

Type: Integer

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.GetFieldList(TStrings) Method

Summary

Returns list of dataset fields.

Namespace: frxClass
Syntax
Delphi
public
 procedure GetFieldList(List: TStrings); virtual;

Parameters

List
Type: TStrings

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.GetFieldType(String) Method

Summary

Represents method GetFieldType(String).

Namespace: frxClass
Syntax
Delphi
protected
 function GetFieldType(Index: String): TfrxFieldType; virtual;

Parameters

Index
Type: String

Return Value

Type: TfrxFieldType

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.GetValue(String) Method

Summary

Represents method GetValue(String).

Namespace: frxClass
Syntax
Delphi
protected
 function GetValue(Index: String): Variant; virtual;

Parameters

Index
Type: String

Return Value

Type: Variant

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.HasField(String) Method

Summary

Returns True if dataset has field with specified name.

Namespace: frxClass
Syntax
Delphi
public
 function HasField(const fName: String): Boolean;

Parameters

fName
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.Initialize Method

Summary

Initializes DataSet before open.

Namespace: frxClass
Syntax
Delphi
public
 procedure Initialize; virtual;
See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.IsBlobField(String) Method

Summary

Returns True if dataset has BLOB field with specified name.

Namespace: frxClass
Syntax
Delphi
public
 function IsBlobField(const fName: String): Boolean; virtual;

Parameters

fName
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.IsHasMaster Method

Summary

Returns True if DataSet has master RecordSet.

Namespace: frxClass
Syntax
Delphi
public
 function IsHasMaster: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.IsWideMemoBlobField(String) Method

Summary

Returns True if dataset has wide memo BLOB field with specified name.

Namespace: frxClass
Syntax
Delphi
public
 function IsWideMemoBlobField(const fName: String): Boolean; virtual;

Parameters

fName
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.Next Method

Summary

Moves the cursor to the next record.

Namespace: frxClass
Syntax
Delphi
public
 procedure Next; virtual;
See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.Open Method

Summary

Opens the dataset.

Namespace: frxClass
Syntax
Delphi
public
 procedure Open; virtual;
See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.Prior Method

Summary

Moves the cursor to the previous record. This method is used only when printing groups.

Namespace: frxClass
Syntax
Delphi
public
 procedure Prior; virtual;
See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.RecordCount Method

Summary

Returns records count if DataSet supports it.

Namespace: frxClass
Syntax
Delphi
public
 function RecordCount: Integer; virtual;

Return Value

Type: Integer

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.SetName(TComponentName) Method

Summary

Represents method SetName(TComponentName).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetName(const NewName: TComponentName); override;

Parameters

NewName
Type: TComponentName

Overrides

TfrxComponent.SetName(TComponentName)
See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.SetUserName(String) Method

Summary

Represents method SetUserName(String).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetUserName(const Value: String); virtual;

Parameters

Value
Type: String

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet Events

Events
Name | Description
OnCheckEOF | This event's handler must return the Eof = True parameter, if the end of the data set is reached.
Top


TfrxDataSet.OnCheckEOF Event

Summary

This event's handler must return the Eof = True parameter, if the end of the data set is reached.

Namespace: frxClass
Syntax
Delphi
published
 property OnCheckEOF: TfrxCheckEOFEvent read FOnCheckEOF write FOnCheckEOF;

Value

Type: TfrxCheckEOFEvent

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet Fields

Fields
Name | Description
FCloseDataSource | Represents field FCloseDataSource.
FEnabled | Represents field FEnabled.
FEof | Represents field FEof.
FInitialized | Represents field FInitialized.
FOnCheckEOF | Represents field FOnCheckEOF.
FOnClose | Represents field FOnClose.
FOnFirst | Represents field FOnFirst.
FOnNext | Represents field FOnNext.
FOnOpen | Represents field FOnOpen.
FOnPrior | Represents field FOnPrior.
FOpenDataSource | Represents field FOpenDataSource.
FRangeBegin | Represents field FRangeBegin.
FRangeEnd | Represents field FRangeEnd.
FRangeEndCount | Represents field FRangeEndCount.
FRecNo | Represents field FRecNo.
FReportRef | Represents field FReportRef.
FUserName | Represents field FUserName.
Top


TfrxDataSet.FCloseDataSource Field

Summary

Represents field FCloseDataSource.

Namespace: frxClass
Syntax
Delphi
private
 FCloseDataSource: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FEnabled Field

Summary

Represents field FEnabled.

Namespace: frxClass
Syntax
Delphi
private
 FEnabled: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FEof Field

Summary

Represents field FEof.

Namespace: frxClass
Syntax
Delphi
private
 FEof: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FInitialized Field

Summary

Represents field FInitialized.

Namespace: frxClass
Syntax
Delphi
protected
 FInitialized: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FOnCheckEOF Field

Summary

Represents field FOnCheckEOF.

Namespace: frxClass
Syntax
Delphi
private
 FOnCheckEOF: TfrxCheckEOFEvent;

Field Value

Type: TfrxCheckEOFEvent

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FOnClose Field

Summary

Represents field FOnClose.

Namespace: frxClass
Syntax
Delphi
private
 FOnClose: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FOnFirst Field

Summary

Represents field FOnFirst.

Namespace: frxClass
Syntax
Delphi
private
 FOnFirst: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FOnNext Field

Summary

Represents field FOnNext.

Namespace: frxClass
Syntax
Delphi
private
 FOnNext: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FOnOpen Field

Summary

Represents field FOnOpen.

Namespace: frxClass
Syntax
Delphi
private
 FOnOpen: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FOnPrior Field

Summary

Represents field FOnPrior.

Namespace: frxClass
Syntax
Delphi
private
 FOnPrior: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FOpenDataSource Field

Summary

Represents field FOpenDataSource.

Namespace: frxClass
Syntax
Delphi
private
 FOpenDataSource: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FRangeBegin Field

Summary

Represents field FRangeBegin.

Namespace: frxClass
Syntax
Delphi
private
 FRangeBegin: TfrxRangeBegin;

Field Value

Type: TfrxRangeBegin

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FRangeEnd Field

Summary

Represents field FRangeEnd.

Namespace: frxClass
Syntax
Delphi
private
 FRangeEnd: TfrxRangeEnd;

Field Value

Type: TfrxRangeEnd

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FRangeEndCount Field

Summary

Represents field FRangeEndCount.

Namespace: frxClass
Syntax
Delphi
private
 FRangeEndCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FRecNo Field

Summary

Represents field FRecNo.

Namespace: frxClass
Syntax
Delphi
protected
 FRecNo: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FReportRef Field

Summary

Represents field FReportRef.

Namespace: frxClass
Syntax
Delphi
private
 FReportRef: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSet.FUserName Field

Summary

Represents field FUserName.

Namespace: frxClass
Syntax
Delphi
private
 FUserName: String;

Field Value

Type: String

See Also

Reference

  • TfrxDataSet
  • frxClass


TfrxDataSetItem Class

Summary

The TfrxDataSetItem class represents a dataset in the report dataset's list. Dataset's list is contained in the TfrxReportDataSets class.

Namespace: frxClass
Inheritance Hierarchy
TCollectionItem
frxClass.TfrxDataSetItem
Syntax
Delphi
type
 TfrxDataSetItem = class(TCollectionItem)
 end;

The TfrxDataSetItem type exposes the following members.

Properties
Show:
Name | Description
DataSet | Reference to the dataset.
DataSetName | Name of the dataset. This property duplicates the DataSet property.
Top
Methods
Show:
Name | Description
GetDataSetName | Represents method GetDataSetName.
SetDataSet(TfrxDataSet) | Represents method SetDataSet(TfrxDataSet).
SetDataSetName(String) | Represents method SetDataSetName(String).
Top
Fields
Show:
Name | Description
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
Top
See Also

Reference

  • frxClass


TfrxDataSetItem Properties

Properties
Name | Description
DataSet | Reference to the dataset.
DataSetName | Name of the dataset. This property duplicates the DataSet property.
Top


TfrxDataSetItem.DataSet Property

Summary

Reference to the dataset.

Namespace: frxClass
Syntax
Delphi
published
 property DataSet: TfrxDataSet read FDataSet write SetDataSet;

Property Value

Type: TfrxDataSet

See Also

Reference

  • TfrxDataSetItem
  • frxClass


TfrxDataSetItem.DataSetName Property

Summary

Name of the dataset. This property duplicates the DataSet property.

Namespace: frxClass
Syntax
Delphi
published
 property DataSetName: String read GetDataSetName write SetDataSetName;

Property Value

Type: String

See Also

Reference

  • TfrxDataSetItem
  • frxClass


TfrxDataSetItem Methods

Methods
Name | Description
GetDataSetName | Represents method GetDataSetName.
SetDataSet(TfrxDataSet) | Represents method SetDataSet(TfrxDataSet).
SetDataSetName(String) | Represents method SetDataSetName(String).
Top


TfrxDataSetItem.GetDataSetName Method

Summary

Represents method GetDataSetName.

Namespace: frxClass
Syntax
Delphi
private
 function GetDataSetName: String;

Return Value

Type: String

See Also

Reference

  • TfrxDataSetItem
  • frxClass


TfrxDataSetItem.SetDataSet(TfrxDataSet) Method

Summary

Represents method SetDataSet(TfrxDataSet).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDataSet(const Value: TfrxDataSet);

Parameters

Value
Type: TfrxDataSet

See Also

Reference

  • TfrxDataSetItem
  • frxClass


TfrxDataSetItem.SetDataSetName(String) Method

Summary

Represents method SetDataSetName(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDataSetName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxDataSetItem
  • frxClass


TfrxDataSetItem Fields

Fields
Name | Description
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
Top


TfrxDataSetItem.FDataSet Field

Summary

Represents field FDataSet.

Namespace: frxClass
Syntax
Delphi
private
 FDataSet: TfrxDataSet;

Field Value

Type: TfrxDataSet

See Also

Reference

  • TfrxDataSetItem
  • frxClass


TfrxDataSetItem.FDataSetName Field

Summary

Represents field FDataSetName.

Namespace: frxClass
Syntax
Delphi
private
 FDataSetName: String;

Field Value

Type: String

See Also

Reference

  • TfrxDataSetItem
  • frxClass


TfrxDBComponents Class

Summary

Represents type TfrxDBComponents.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxDBComponents
Syntax
Delphi
type
 TfrxDBComponents = class(TComponent)
 end;

The TfrxDBComponents type exposes the following members.

Methods
Show:
Name | Description
GetDescription | Represents method GetDescription.
Top
See Also

Reference

  • frxClass


TfrxDBComponents Methods

Methods
Name | Description
GetDescription | Represents method GetDescription.
Top


TfrxDBComponents.GetDescription Method

Summary

Represents method GetDescription.

Namespace: frxClass
Syntax
Delphi
public
 function GetDescription: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxDBComponents
  • frxClass


TfrxDelayedCommandManager Class

Summary

The TfrxDelayedCommandManager class is used as storage and manager for commands which implements
IfrxDelayedCommand interface.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxDelayedCommandManager
Syntax
Delphi
type
 TfrxDelayedCommandManager = class
 end;

The TfrxDelayedCommandManager type exposes the following members.

Constructors
Show:
Name | Description
Create | Constructor.
Destroy | Represents the destructor of the TfrxDelayedCommandManager class.
Top
Properties
Show:
Name | Description
IsRunning | The current state of manager. It's True if manager runs some commands.
Top
Methods
Show:
Name | Description
AddCommand(IfrxDelayedCommand) | Adds new command to the deferred commands list.
Clear | Clears all deferred commands in the list.
RunAll | Run all commands in the list one by one.
Top
Fields
Show:
Name | Description
FCommands | Represents field FCommands.
FIsRunning | Represents field FIsRunning.
Top
See Also

Reference

  • frxClass


TfrxDelayedCommandManager Constructors

Constructors
Name | Description
Create | Constructor.
Destroy | Represents the destructor of the TfrxDelayedCommandManager class.
Top


TfrxDelayedCommandManager.Create Constructor

Summary

Constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxDelayedCommandManager
  • frxClass


TfrxDelayedCommandManager.Destroy Destructor

Summary

Represents the destructor of the TfrxDelayedCommandManager class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxDelayedCommandManager
  • frxClass


TfrxDelayedCommandManager Properties

Properties
Name | Description
IsRunning | The current state of manager. It's True if manager runs some commands.
Top


TfrxDelayedCommandManager.IsRunning Property

Summary

The current state of manager. It's True if manager runs some commands.

Namespace: frxClass
Syntax
Delphi
public
 property IsRunning: Boolean read FIsRunning;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDelayedCommandManager
  • frxClass


TfrxDelayedCommandManager Methods

Methods
Name | Description
AddCommand(IfrxDelayedCommand) | Adds new command to the deferred commands list.
Clear | Clears all deferred commands in the list.
RunAll | Run all commands in the list one by one.
Top


TfrxDelayedCommandManager.AddCommand(IfrxDelayedCommand) Method

Summary

Adds new command to the deferred commands list.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddCommand(Cmd: IfrxDelayedCommand);

Parameters

Cmd
Type: IfrxDelayedCommand

Object which implements
IfrxDelayedCommand interface.

See Also

Reference

  • TfrxDelayedCommandManager
  • frxClass


TfrxDelayedCommandManager.Clear Method

Summary

Clears all deferred commands in the list.

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxDelayedCommandManager
  • frxClass


TfrxDelayedCommandManager.RunAll Method

Summary

Run all commands in the list one by one.

Namespace: frxClass
Syntax
Delphi
public
 procedure RunAll;
See Also

Reference

  • TfrxDelayedCommandManager
  • frxClass


TfrxDelayedCommandManager Fields

Fields
Name | Description
FCommands | Represents field FCommands.
FIsRunning | Represents field FIsRunning.
Top


TfrxDelayedCommandManager.FCommands Field

Summary

Represents field FCommands.

Namespace: frxClass
Syntax
Delphi
private
 FCommands: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxDelayedCommandManager
  • frxClass


TfrxDelayedCommandManager.FIsRunning Field

Summary

Represents field FIsRunning.

Namespace: frxClass
Syntax
Delphi
private
 FIsRunning: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDelayedCommandManager
  • frxClass


TfrxDetailData Class

Summary

The TfrxDetailData represents a "Detail data" band.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxDataBand
frxClass.TfrxDetailData
Syntax
Delphi
type
 TfrxDetailData = class(TfrxDataBand)
 end;

The TfrxDetailData type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataBand class. (Overrides TfrxBand.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit. (Inherited from TfrxDataBand.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child. (Inherited from TfrxDataBand.)
ColumnGap | Gap between band's columns, in pixels. (Inherited from TfrxDataBand.)
Columns | The "Columns" property, available in all data-bands, allows to set number of columns for a particular band and not for the whole page. Thus, displaying of data will be not "from the top to the bottom, then from the left to the right," but "from left to right, then from top to bottom". You also should set ColumnWidth and ColumnGap properties. (Inherited from TfrxDataBand.)
ColumnWidth | Width of the band's column, in pixels. (Inherited from TfrxDataBand.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
CurColumn | Current column of the band. (Inherited from TfrxDataBand.)
DataSet | Dataset for a band. (Inherited from TfrxDataBand.)
DataSetName | Dataset name for a band. This property duplicates the DataSet property. (Inherited from TfrxDataBand.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Filter | An expression used to manage visibility of a band record. if result of this expression is True, band will be shown. (Inherited from TfrxDataBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
FooterAfterEach | Determines whether to show band footer after each record. Default value is False. By default the footer is displayed after printing all dataset records. (Inherited from TfrxDataBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False. (Inherited from TfrxDataBand.)
KeepFooter | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False. (Inherited from TfrxDataBand.)
KeepHeader | Determines whether to show band header on the same page as the banditself. If header does not find room on the page, it will be carriedto the next page. Default value is False. (Inherited from TfrxDataBand.)
KeepTogether | Determines whether to print the band together with all its subbands on the same page. Default value is False. (Inherited from TfrxDataBand.)
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnMasterDetail | Name of the script procedure that will be called before the band will check if any subbands are empty. (Inherited from TfrxDataBand.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | Represents property OutlineText. (Inherited from TfrxDataBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible. (Inherited from TfrxDataBand.)
PrintIfDetailEmpty | Determines whether to print the band if all its subbands are empty. Default value is False. (Inherited from TfrxDataBand.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
RowCount | Allows printing the band N times. This property is used if the band is NOT connected to the dataset. (Inherited from TfrxDataBand.)
ShiftEngine | Represents property ShiftEngine. (Inherited from TfrxDataBand.)
StartNewPage | Represents property StartNewPage. (Inherited from TfrxDataBand.)
Stretched | Represents property Stretched. (Inherited from TfrxDataBand.)
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
VirtualDataSet | Represents property VirtualDataSet. (Inherited from TfrxDataBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Overrides TfrxBand.GetBandTitleColor.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxBand.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxBand.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FMaxY | Represents field FMaxY. (Inherited from TfrxDataBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxDialogComponent Class

Summary

The TfrxDialogComponent class is the basic one for writing non-visual components, which can be placed on a dialog form in a report.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogComponent
frxClass.TfrxCustomDatabase
frxClass.TfrxDataSet
Syntax
Delphi
type
 TfrxDialogComponent = class(TfrxReportComponent)
 end;

The TfrxDialogComponent type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDialogComponent class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxDialogComponent class. (Overrides TfrxReportComponent.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Component | Link to the component itself.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Font | Object's font. (Inherited from TfrxComponent.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Global visibility of the object in the result report. (Inherited from TfrxComponent.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadLeft(TReader) | Represents method ReadLeft(TReader).
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
ReadTop(TReader) | Represents method ReadTop(TReader).
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteLeft(TWriter) | Represents method WriteLeft(TWriter).
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
WriteTop(TWriter) | Represents method WriteTop(TWriter).
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponent | Represents field FComponent.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FImageIndex | Represents field FImageIndex.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxClass


TfrxDialogComponent Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDialogComponent class. (Overrides TfrxReportComponent.Create(TComponent).)
Destroy | Represents the destructor of the TfrxDialogComponent class. (Overrides TfrxReportComponent.Destroy.)
Top


TfrxDialogComponent.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDialogComponent class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxReportComponent.Create(TComponent)
See Also

Reference

  • TfrxDialogComponent
  • frxClass


TfrxDialogComponent.Destroy Destructor

Summary

Represents the destructor of the TfrxDialogComponent class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxReportComponent.Destroy
See Also

Reference

  • TfrxDialogComponent
  • frxClass


TfrxDialogComponent Properties

Properties
Name | Description
Component | Link to the component itself.
Top


TfrxDialogComponent.Component Property

Summary

Link to the component itself.

Namespace: frxClass
Syntax
Delphi
public
 property Component: TComponent read FComponent write FComponent;

Property Value

Type: TComponent

See Also

Reference

  • TfrxDialogComponent
  • frxClass


TfrxDialogComponent Methods

Methods
Name | Description
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
ReadLeft(TReader) | Represents method ReadLeft(TReader).
ReadTop(TReader) | Represents method ReadTop(TReader).
WriteLeft(TWriter) | Represents method WriteLeft(TWriter).
WriteTop(TWriter) | Represents method WriteTop(TWriter).
Top


TfrxDialogComponent.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxClass
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxDialogComponent
  • frxClass


TfrxDialogComponent.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxDialogComponent
  • frxClass


TfrxDialogComponent.ReadLeft(TReader) Method

Summary

Represents method ReadLeft(TReader).

Namespace: frxClass
Syntax
Delphi
private
 procedure ReadLeft(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxDialogComponent
  • frxClass


TfrxDialogComponent.ReadTop(TReader) Method

Summary

Represents method ReadTop(TReader).

Namespace: frxClass
Syntax
Delphi
private
 procedure ReadTop(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxDialogComponent
  • frxClass


TfrxDialogComponent.WriteLeft(TWriter) Method

Summary

Represents method WriteLeft(TWriter).

Namespace: frxClass
Syntax
Delphi
private
 procedure WriteLeft(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TfrxDialogComponent
  • frxClass


TfrxDialogComponent.WriteTop(TWriter) Method

Summary

Represents method WriteTop(TWriter).

Namespace: frxClass
Syntax
Delphi
private
 procedure WriteTop(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TfrxDialogComponent
  • frxClass


TfrxDialogComponent Fields

Fields
Name | Description
FComponent | Represents field FComponent.
FImageIndex | Represents field FImageIndex.
Top


TfrxDialogComponent.FComponent Field

Summary

Represents field FComponent.

Namespace: frxClass
Syntax
Delphi
private
 FComponent: TComponent;

Field Value

Type: TComponent

See Also

Reference

  • TfrxDialogComponent
  • frxClass


TfrxDialogComponent.FImageIndex Field

Summary

Represents field FImageIndex.

Namespace: frxClass
Syntax
Delphi
protected
 FImageIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDialogComponent
  • frxClass


TfrxDialogControl Class

Summary

The "TfrxDialogControl" class is the basic one for writing common control, which can be placed on a dialogue form in a report. The class contains a large number of general properties and events shared with most of the common controls.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxBevelControl
frxDCtrl.TfrxBitBtnControl
frxDCtrl.TfrxButtonControl
frxDCtrl.TfrxCheckBoxControl
frxDCtrl.TfrxCheckListBoxControl
frxDCtrl.TfrxComboBoxControl
frxDCtrl.TfrxCustomEditControl
frxDCtrl.TfrxDateEditControl
frxDCtrl.TfrxGroupBoxControl
frxDCtrl.TfrxImageControl
frxDCtrl.TfrxLabelControl
frxDCtrl.TfrxListBoxControl
frxDCtrl.TfrxPageControl
frxDCtrl.TfrxPanelControl
frxDCtrl.TfrxRadioButtonControl
frxDCtrl.TfrxSpeedButtonControl
frxDCtrl.TfrxTabSheet
frxGaugeDialogControl.TfrxBaseGaugeControl
Syntax
Delphi
type
 TfrxDialogControl = class(TfrxReportComponent)
 end;

The TfrxDialogControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDialogControl class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxDialogControl class. (Overrides TfrxReportComponent.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control.
Color | Color of the control.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled.
Font | Represents property Font.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex.
Height | Represents property Height.
Hint | Contains the text string that can appear when the user moves the mouse over the control.
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control.
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | The name of the script routine that will be called if user clicks the control.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | The name of the script routine that will be called if user double clicks the control.
OnEnter | The name of the script routine that will be called if control gets the focus.
OnExit | The name of the script routine that will be called if user pressed a key.
OnKeyDown | The name of the script routine that will be called if user pressed a key.
OnKeyPress | The name of the script routine that will be called if user pressed a key.
OnKeyUp | The name of the script routine that will be called if user released a key.
OnMouseDown | The name of the script routine that will be called if user pressed a mouse button.
OnMouseMove | The name of the script routine that will be called if user moved a mouse over control.
OnMouseUp | The name of the script routine that will be called if user released a mouse button.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint.
TabStop | Determines if the user can tab to a control.
Top | Represents property Top.
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates.
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDestroyControl | Represents method DoDestroyControl.
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoInitControl | Represents method DoInitControl.
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoOnClick(TObject) | Represents method DoOnClick(TObject).
DoOnDblClick(TObject) | Represents method DoOnDblClick(TObject).
DoOnEnter(TObject) | Represents method DoOnEnter(TObject).
DoOnExit(TObject) | Represents method DoOnExit(TObject).
DoOnKeyDown(TObject,Word,TShiftState) | Represents method DoOnKeyDown(TObject,Word,TShiftState).
DoOnKeyPress(TObject,Char) | Represents method DoOnKeyPress(TObject,Char).
DoOnKeyUp(TObject,Word,TShiftState) | Represents method DoOnKeyUp(TObject,Word,TShiftState).
DoOnMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method DoOnMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
DoOnMouseMove(TObject,TShiftState,Integer,Integer) | Represents method DoOnMouseMove(TObject,TShiftState,Integer,Integer).
DoOnMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method DoOnMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer).
DoOnMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean) | Represents method DoOnMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean).
DoSetParent | Represents method DoSetParent.
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetCaption | Represents method GetCaption.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColor | Represents method GetColor.
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset.
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetEnabled | Represents method GetEnabled.
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetHint | Represents method GetHint.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight.
GetScaledControlLeft | Represents method GetScaledControlLeft.
GetScaledControlTop | Represents method GetScaledControlTop.
GetScaledControlWidth | Represents method GetScaledControlWidth.
GetShowHint | Represents method GetShowHint.
GetTabStop | Represents method GetTabStop.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl).
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCaption(String) | Represents method SetCaption(String).
SetColor(TColor) | Represents method SetColor(TColor).
SetEnabled(Boolean) | Represents method SetEnabled(Boolean).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetHint(String) | Represents method SetHint(String).
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetShowHint(Boolean) | Represents method SetShowHint(Boolean).
SetTabStop(Boolean) | Represents method SetTabStop(Boolean).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer).
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FControl | Represents field FControl.
FCurrentPPI | Represents field FCurrentPPI.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOnActivate | Represents field FOnActivate.
FOnClick | Represents field FOnClick.
FOnDblClick | Represents field FOnDblClick.
FOnEnter | Represents field FOnEnter.
FOnExit | Represents field FOnExit.
FOnKeyDown | Represents field FOnKeyDown.
FOnKeyPress | Represents field FOnKeyPress.
FOnKeyUp | Represents field FOnKeyUp.
FOnMouseDown | Represents field FOnMouseDown.
FOnMouseMove | Represents field FOnMouseMove.
FOnMouseUp | Represents field FOnMouseUp.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxClass


TfrxDialogControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDialogControl class. (Overrides TfrxReportComponent.Create(TComponent).)
Destroy | Represents the destructor of the TfrxDialogControl class. (Overrides TfrxReportComponent.Destroy.)
Top


TfrxDialogControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDialogControl class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxReportComponent.Create(TComponent)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Destroy Destructor

Summary

Represents the destructor of the TfrxDialogControl class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxReportComponent.Destroy
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl Properties

Properties
Name | Description
Anchors | Represents property Anchors.
Caption | Caption of the control.
Color | Color of the control.
Control | Link to the control itself.
Enabled | Determines if the control is enabled.
Font | Represents property Font.
GroupIndex | Represents property GroupIndex.
Height | Represents property Height.
Hint | Contains the text string that can appear when the user moves the mouse over the control.
Left | Represents property Left.
OnActivate | The name of the script routine that will be called if user activate control.
OnClick | The name of the script routine that will be called if user clicks the control.
OnDblClick | The name of the script routine that will be called if user double clicks the control.
OnEnter | The name of the script routine that will be called if control gets the focus.
OnExit | The name of the script routine that will be called if user pressed a key.
OnKeyDown | The name of the script routine that will be called if user pressed a key.
OnKeyPress | The name of the script routine that will be called if user pressed a key.
OnKeyUp | The name of the script routine that will be called if user released a key.
OnMouseDown | The name of the script routine that will be called if user pressed a mouse button.
OnMouseMove | The name of the script routine that will be called if user moved a mouse over control.
OnMouseUp | The name of the script routine that will be called if user released a mouse button.
ParentFont | Represents property ParentFont.
ShowHint | Show/hide hint.
TabStop | Determines if the user can tab to a control.
Top | Represents property Top.
Visible | Represents property Visible.
Width | Represents property Width.
Top


TfrxDialogControl.Anchors Property

Summary

Represents property Anchors.

Namespace: frxClass
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Caption Property

Summary

Caption of the control.

Namespace: frxClass
Syntax
Delphi
public
 property Caption: String read GetCaption write SetCaption;

Property Value

Type: String

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Color Property

Summary

Color of the control.

Namespace: frxClass
Syntax
Delphi
public
 property Color: TColor read GetColor write SetColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Control Property

Summary

Link to the control itself.

Namespace: frxClass
Syntax
Delphi
public
 property Control: TControl read FControl write FControl;

Property Value

Type: TControl

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Enabled Property

Summary

Determines if the control is enabled.

Namespace: frxClass
Syntax
Delphi
published
 property Enabled: Boolean read GetEnabled write SetEnabled default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Font Property

Summary

Represents property Font.

Namespace: frxClass
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.GroupIndex Property

Summary

Represents property GroupIndex.

Namespace: frxClass
Syntax
Delphi
published
 property GroupIndex;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Height Property

Summary

Represents property Height.

Namespace: frxClass
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Hint Property

Summary

Contains the text string that can appear when the user moves the mouse over the control.

Namespace: frxClass
Syntax
Delphi
published
 property Hint: String read GetHint write SetHint;

Property Value

Type: String

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Left Property

Summary

Represents property Left.

Namespace: frxClass
Syntax
Delphi
published
 property Left;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.OnActivate Property

Summary

The name of the script routine that will be called if user activate control.

Namespace: frxClass
Syntax
Delphi
public
 property OnActivate: TNotifyEvent read FOnActivate write FOnActivate;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.OnClick Property

Summary

The name of the script routine that will be called if user clicks the control.

Namespace: frxClass
Syntax
Delphi
public
 property OnClick: TfrxNotifyEvent read FOnClick write FOnClick;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.OnDblClick Property

Summary

The name of the script routine that will be called if user double clicks the control.

Namespace: frxClass
Syntax
Delphi
public
 property OnDblClick: TfrxNotifyEvent read FOnDblClick write FOnDblClick;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.OnEnter Property

Summary

The name of the script routine that will be called if control gets the focus.

Namespace: frxClass
Syntax
Delphi
public
 property OnEnter: TfrxNotifyEvent read FOnEnter write FOnEnter;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.OnExit Property

Summary

The name of the script routine that will be called if user pressed a key.

Namespace: frxClass
Syntax
Delphi
public
 property OnExit: TfrxNotifyEvent read FOnExit write FOnExit;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.OnKeyDown Property

Summary

The name of the script routine that will be called if user pressed a key.

Namespace: frxClass
Syntax
Delphi
public
 property OnKeyDown: TfrxKeyEvent read FOnKeyDown write FOnKeyDown;

Property Value

Type: TfrxKeyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.OnKeyPress Property

Summary

The name of the script routine that will be called if user pressed a key.

Namespace: frxClass
Syntax
Delphi
public
 property OnKeyPress: TfrxKeyPressEvent read FOnKeyPress write FOnKeyPress;

Property Value

Type: TfrxKeyPressEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.OnKeyUp Property

Summary

The name of the script routine that will be called if user released a key.

Namespace: frxClass
Syntax
Delphi
public
 property OnKeyUp: TfrxKeyEvent read FOnKeyUp write FOnKeyUp;

Property Value

Type: TfrxKeyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.OnMouseDown Property

Summary

The name of the script routine that will be called if user pressed a mouse button.

Namespace: frxClass
Syntax
Delphi
public
 property OnMouseDown: TfrxMouseEvent read FOnMouseDown write FOnMouseDown;

Property Value

Type: TfrxMouseEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.OnMouseMove Property

Summary

The name of the script routine that will be called if user moved a mouse over control.

Namespace: frxClass
Syntax
Delphi
public
 property OnMouseMove: TfrxMouseMoveEvent read FOnMouseMove write FOnMouseMove;

Property Value

Type: TfrxMouseMoveEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.OnMouseUp Property

Summary

The name of the script routine that will be called if user released a mouse button.

Namespace: frxClass
Syntax
Delphi
public
 property OnMouseUp: TfrxMouseEvent read FOnMouseUp write FOnMouseUp;

Property Value

Type: TfrxMouseEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.ParentFont Property

Summary

Represents property ParentFont.

Namespace: frxClass
Syntax
Delphi
published
 property ParentFont;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.ShowHint Property

Summary

Show/hide hint.

Namespace: frxClass
Syntax
Delphi
published
 property ShowHint: Boolean read GetShowHint write SetShowHint;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.TabStop Property

Summary

Determines if the user can tab to a control.

Namespace: frxClass
Syntax
Delphi
public
 property TabStop: Boolean read GetTabStop write SetTabStop default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Top Property

Summary

Represents property Top.

Namespace: frxClass
Syntax
Delphi
published
 property Top;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Visible Property

Summary

Represents property Visible.

Namespace: frxClass
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Width Property

Summary

Represents property Width.

Namespace: frxClass
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl Methods

Methods
Name | Description
CorrectControlCoordinates | Represents method CorrectControlCoordinates.
DoDestroyControl | Represents method DoDestroyControl.
DoInitControl | Represents method DoInitControl.
DoOnClick(TObject) | Represents method DoOnClick(TObject).
DoOnDblClick(TObject) | Represents method DoOnDblClick(TObject).
DoOnEnter(TObject) | Represents method DoOnEnter(TObject).
DoOnExit(TObject) | Represents method DoOnExit(TObject).
DoOnKeyDown(TObject,Word,TShiftState) | Represents method DoOnKeyDown(TObject,Word,TShiftState).
DoOnKeyPress(TObject,Char) | Represents method DoOnKeyPress(TObject,Char).
DoOnKeyUp(TObject,Word,TShiftState) | Represents method DoOnKeyUp(TObject,Word,TShiftState).
DoOnMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method DoOnMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
DoOnMouseMove(TObject,TShiftState,Integer,Integer) | Represents method DoOnMouseMove(TObject,TShiftState,Integer,Integer).
DoOnMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method DoOnMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer).
DoOnMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean) | Represents method DoOnMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean).
DoSetParent | Represents method DoSetParent.
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetCaption | Represents method GetCaption.
GetColor | Represents method GetColor.
GetCoordinateOffset | Represents method GetCoordinateOffset.
GetEnabled | Represents method GetEnabled.
GetHint | Represents method GetHint.
GetScaledControlHeight | Represents method GetScaledControlHeight.
GetScaledControlLeft | Represents method GetScaledControlLeft.
GetScaledControlTop | Represents method GetScaledControlTop.
GetScaledControlWidth | Represents method GetScaledControlWidth.
GetShowHint | Represents method GetShowHint.
GetTabStop | Represents method GetTabStop.
InitControl(TControl) | Represents method InitControl(TControl).
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetCaption(String) | Represents method SetCaption(String).
SetColor(TColor) | Represents method SetColor(TColor).
SetEnabled(Boolean) | Represents method SetEnabled(Boolean).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetHint(String) | Represents method SetHint(String).
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetShowHint(Boolean) | Represents method SetShowHint(Boolean).
SetTabStop(Boolean) | Represents method SetTabStop(Boolean).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer).
Top


TfrxDialogControl.CorrectControlCoordinates Method

Summary

Represents method CorrectControlCoordinates.

Namespace: frxClass
Syntax
Delphi
protected
 procedure CorrectControlCoordinates; virtual;
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoDestroyControl Method

Summary

Represents method DoDestroyControl.

Namespace: frxClass
Syntax
Delphi
private
 procedure DoDestroyControl;
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoInitControl Method

Summary

Represents method DoInitControl.

Namespace: frxClass
Syntax
Delphi
private
 procedure DoInitControl;
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoOnClick(TObject) Method

Summary

Represents method DoOnClick(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoOnDblClick(TObject) Method

Summary

Represents method DoOnDblClick(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnDblClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoOnEnter(TObject) Method

Summary

Represents method DoOnEnter(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnEnter(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoOnExit(TObject) Method

Summary

Represents method DoOnExit(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnExit(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoOnKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method DoOnKeyDown(TObject,Word,TShiftState).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoOnKeyPress(TObject,Char) Method

Summary

Represents method DoOnKeyPress(TObject,Char).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnKeyPress(Sender: TObject; var Key: Char);

Parameters

Sender
Type: TObject

Key
Type: Char

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoOnKeyUp(TObject,Word,TShiftState) Method

Summary

Represents method DoOnKeyUp(TObject,Word,TShiftState).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnKeyUp(Sender: TObject; var Key: Word; Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoOnMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method DoOnMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnMouseDown(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoOnMouseMove(TObject,TShiftState,Integer,Integer) Method

Summary

Represents method DoOnMouseMove(TObject,TShiftState,Integer,Integer).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoOnMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method DoOnMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnMouseUp(Sender: TObject; Button: TMouseButton; Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoOnMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean) Method

Summary

Represents method DoOnMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnMouseWheel(Sender: TObject; Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

Handled
Type: Boolean

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.DoSetParent Method

Summary

Represents method DoSetParent.

Namespace: frxClass
Syntax
Delphi
private
 procedure DoSetParent;
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FontChanged(TObject) Method

Summary

Represents method FontChanged(TObject).

Namespace: frxClass
Syntax
Delphi
protected
 procedure FontChanged(Sender: TObject); override;

Parameters

Sender
Type: TObject

Overrides

TfrxComponent.FontChanged(TObject)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.GetCaption Method

Summary

Represents method GetCaption.

Namespace: frxClass
Syntax
Delphi
private
 function GetCaption: String;

Return Value

Type: String

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.GetColor Method

Summary

Represents method GetColor.

Namespace: frxClass
Syntax
Delphi
private
 function GetColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.GetCoordinateOffset Method

Summary

Represents method GetCoordinateOffset.

Namespace: frxClass
Syntax
Delphi
protected
 function GetCoordinateOffset: TPoint; virtual;

Return Value

Type: TPoint

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.GetEnabled Method

Summary

Represents method GetEnabled.

Namespace: frxClass
Syntax
Delphi
private
 function GetEnabled: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.GetHint Method

Summary

Represents method GetHint.

Namespace: frxClass
Syntax
Delphi
private
 function GetHint: String;

Return Value

Type: String

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.GetScaledControlHeight Method

Summary

Represents method GetScaledControlHeight.

Namespace: frxClass
Syntax
Delphi
protected
 function GetScaledControlHeight: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.GetScaledControlLeft Method

Summary

Represents method GetScaledControlLeft.

Namespace: frxClass
Syntax
Delphi
protected
 function GetScaledControlLeft: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.GetScaledControlTop Method

Summary

Represents method GetScaledControlTop.

Namespace: frxClass
Syntax
Delphi
protected
 function GetScaledControlTop: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.GetScaledControlWidth Method

Summary

Represents method GetScaledControlWidth.

Namespace: frxClass
Syntax
Delphi
protected
 function GetScaledControlWidth: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.GetShowHint Method

Summary

Represents method GetShowHint.

Namespace: frxClass
Syntax
Delphi
private
 function GetShowHint: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.GetTabStop Method

Summary

Represents method GetTabStop.

Namespace: frxClass
Syntax
Delphi
private
 function GetTabStop: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.InitControl(TControl) Method

Summary

Represents method InitControl(TControl).

Namespace: frxClass
Syntax
Delphi
protected
 procedure InitControl(AControl: TControl);

Parameters

AControl
Type: TControl

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.IsAcceptAsChild(TfrxComponent) Method

Summary

Returns true when component in aParent can be accepted as parent for current.

Namespace: frxClass
Syntax
Delphi
public
 function IsAcceptAsChild(aParent: TfrxComponent): Boolean; override;

Parameters

aParent
Type: TfrxComponent

Component that supposedly should become a parent for current.

Return Value

Type: Boolean

Overrides

TfrxComponent.IsAcceptAsChild(TfrxComponent)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.IsAcceptControls Method

Summary

Represents method IsAcceptControls.

Namespace: frxClass
Syntax
Delphi
public
 function IsAcceptControls: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxComponent.IsAcceptControls
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.IsOwnerDraw Method

Summary

Returns True when parent container should draw child.

Namespace: frxClass
Syntax
Delphi
public
 function IsOwnerDraw: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxReportComponent.IsOwnerDraw
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetAnchors(TfrxAnchors) Method

Summary

Represents method SetAnchors(TfrxAnchors).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetAnchors(const Value: TfrxAnchors); override;

Parameters

Value
Type: TfrxAnchors

Overrides

TfrxComponent.SetAnchors(TfrxAnchors)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetCaption(String) Method

Summary

Represents method SetCaption(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetCaption(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetEnabled(Boolean) Method

Summary

Represents method SetEnabled(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetEnabled(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetHeight(Extended) Method

Summary

Represents method SetHeight(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetHeight(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetHeight(Extended)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetHint(String) Method

Summary

Represents method SetHint(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetHint(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetLeft(Extended) Method

Summary

Represents method SetLeft(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetLeft(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetLeft(Extended)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetName(TComponentName) Method

Summary

Represents method SetName(TComponentName).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetName(const AName: TComponentName); override;

Parameters

AName
Type: TComponentName

Overrides

TfrxComponent.SetName(TComponentName)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetParent(TfrxComponent) Method

Summary

Represents method SetParent(TfrxComponent).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetParent(AParent: TfrxComponent); override;

Parameters

AParent
Type: TfrxComponent

Overrides

TfrxComponent.SetParent(TfrxComponent)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetParentFont(Boolean) Method

Summary

Represents method SetParentFont(Boolean).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetParentFont(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TfrxComponent.SetParentFont(Boolean)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetShowHint(Boolean) Method

Summary

Represents method SetShowHint(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetShowHint(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetTabStop(Boolean) Method

Summary

Represents method SetTabStop(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetTabStop(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetTop(Extended) Method

Summary

Represents method SetTop(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetTop(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetTop(Extended)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetVisible(Boolean) Method

Summary

Represents method SetVisible(Boolean).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetVisible(Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TfrxComponent.SetVisible(Boolean)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.SetWidth(Extended) Method

Summary

Represents method SetWidth(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetWidth(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetWidth(Extended)
See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.UpdateControlPPI(Integer) Method

Summary

Represents method UpdateControlPPI(Integer).

Namespace: frxClass
Syntax
Delphi
protected
 procedure UpdateControlPPI(aNewPPI: Integer); virtual;

Parameters

aNewPPI
Type: Integer

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl Fields

Fields
Name | Description
FControl | Represents field FControl.
FCurrentPPI | Represents field FCurrentPPI.
FOnActivate | Represents field FOnActivate.
FOnClick | Represents field FOnClick.
FOnDblClick | Represents field FOnDblClick.
FOnEnter | Represents field FOnEnter.
FOnExit | Represents field FOnExit.
FOnKeyDown | Represents field FOnKeyDown.
FOnKeyPress | Represents field FOnKeyPress.
FOnKeyUp | Represents field FOnKeyUp.
FOnMouseDown | Represents field FOnMouseDown.
FOnMouseMove | Represents field FOnMouseMove.
FOnMouseUp | Represents field FOnMouseUp.
Top


TfrxDialogControl.FControl Field

Summary

Represents field FControl.

Namespace: frxClass
Syntax
Delphi
private
 FControl: TControl;

Field Value

Type: TControl

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FCurrentPPI Field

Summary

Represents field FCurrentPPI.

Namespace: frxClass
Syntax
Delphi
protected
 FCurrentPPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FOnActivate Field

Summary

Represents field FOnActivate.

Namespace: frxClass
Syntax
Delphi
private
 FOnActivate: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FOnClick Field

Summary

Represents field FOnClick.

Namespace: frxClass
Syntax
Delphi
private
 FOnClick: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FOnDblClick Field

Summary

Represents field FOnDblClick.

Namespace: frxClass
Syntax
Delphi
private
 FOnDblClick: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FOnEnter Field

Summary

Represents field FOnEnter.

Namespace: frxClass
Syntax
Delphi
private
 FOnEnter: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FOnExit Field

Summary

Represents field FOnExit.

Namespace: frxClass
Syntax
Delphi
private
 FOnExit: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FOnKeyDown Field

Summary

Represents field FOnKeyDown.

Namespace: frxClass
Syntax
Delphi
private
 FOnKeyDown: TfrxKeyEvent;

Field Value

Type: TfrxKeyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FOnKeyPress Field

Summary

Represents field FOnKeyPress.

Namespace: frxClass
Syntax
Delphi
private
 FOnKeyPress: TfrxKeyPressEvent;

Field Value

Type: TfrxKeyPressEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FOnKeyUp Field

Summary

Represents field FOnKeyUp.

Namespace: frxClass
Syntax
Delphi
private
 FOnKeyUp: TfrxKeyEvent;

Field Value

Type: TfrxKeyEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FOnMouseDown Field

Summary

Represents field FOnMouseDown.

Namespace: frxClass
Syntax
Delphi
private
 FOnMouseDown: TfrxMouseEvent;

Field Value

Type: TfrxMouseEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FOnMouseMove Field

Summary

Represents field FOnMouseMove.

Namespace: frxClass
Syntax
Delphi
private
 FOnMouseMove: TfrxMouseMoveEvent;

Field Value

Type: TfrxMouseMoveEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogControl.FOnMouseUp Field

Summary

Represents field FOnMouseUp.

Namespace: frxClass
Syntax
Delphi
private
 FOnMouseUp: TfrxMouseEvent;

Field Value

Type: TfrxMouseEvent

See Also

Reference

  • TfrxDialogControl
  • frxClass


TfrxDialogPage Class

Summary

The TfrxDialogPage class represents a dialogue form that may contain non-visual and visual controls such as "TfrxBDETable", "Button", etc.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxPage
frxClass.TfrxDialogPage
Syntax
Delphi
type
 TfrxDialogPage = class(TfrxPage)
 end;

The TfrxDialogPage type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDialogPage class. (Overrides TfrxPage.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxDialogPage class. (Overrides TfrxComponent.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BorderStyle | The style of the window.
Caption | The caption of the window.
ClientHeight | Height of client area.
ClientWidth | Width of client area.
Color | The color of the window.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Object's description. (Inherited from TfrxComponent.)
DialogForm | Link to TForm object.
DoubleBuffered | Enable double buffering for dialog form.
Font | Represents property Font. (Inherited from TfrxPage.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height.
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left.
ModalResult | Modal result of the form.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | Name of the script procedure that will be called on dialogue form activation.
OnClick | Name of the script procedure that will be called on click on the form.
OnCloseQuery | Name of the script procedure that will be called on closing the form. The event handler should return True to allow closing.
OnDeactivate | Name of the script procedure that will be called on deactivating the form.
OnHide | Name of the script procedure that will be called on hiding the form.
OnKeyDown | Name of the script procedure that will be called on pressing a key.
OnKeyPress | Name of the script procedure that will be called on pressing a key.
OnKeyUp | Name of the script procedure that will be called on releasing a key.
OnResize | Name of the script procedure that will be called on resizing the form.
OnShow | Name of the script procedure that will be called on showing the form.
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
Position | The initial position of the window.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Scaled | Represents property Scaled.
Top | Represents property Top.
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxPage.)
Width | Represents property Width.
WindowState | Initial state of the window.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoInitialize | Represents method DoInitialize.
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoModify(TObject) | Represents method DoModify(TObject).
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoOnActivate(TObject) | Represents method DoOnActivate(TObject).
DoOnClick(TObject) | Represents method DoOnClick(TObject).
DoOnCloseQuery(TObject,Boolean) | Represents method DoOnCloseQuery(TObject,Boolean).
DoOnDeactivate(TObject) | Represents method DoOnDeactivate(TObject).
DoOnHide(TObject) | Represents method DoOnHide(TObject).
DoOnKeyDown(TObject,Word,TShiftState) | Represents method DoOnKeyDown(TObject,Word,TShiftState).
DoOnKeyPress(TObject,Char) | Represents method DoOnKeyPress(TObject,Char).
DoOnKeyUp(TObject,Word,TShiftState) | Represents method DoOnKeyUp(TObject,Word,TShiftState).
DoOnMouseMove(TObject,TShiftState,Integer,Integer) | Represents method DoOnMouseMove(TObject,TShiftState,Integer,Integer).
DoOnResize(TObject) | Represents method DoOnResize(TObject).
DoOnShow(TObject) | Represents method DoOnShow(TObject).
DoShowModal | Represents method DoShowModal.
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | Represents method Draw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxPage.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetClientHeight | Represents method GetClientHeight.
GetClientWidth | Represents method GetClientWidth.
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDoubleBuffered | Represents method GetDoubleBuffered.
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetModalResult | Represents method GetModalResult.
GetPPIScale | Represents method GetPPIScale.
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetScaled | Represents method GetScaled.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
Initialize | Initialize dialog page.
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsClientSizeStored | Represents method IsClientSizeStored.
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBorderStyle(TFormBorderStyle) | Represents method SetBorderStyle(TFormBorderStyle).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCaption(String) | Represents method SetCaption(String).
SetClientHeight(Extended) | Represents method SetClientHeight(Extended).
SetClientWidth(Extended) | Represents method SetClientWidth(Extended).
SetColor(TColor) | Represents method SetColor(TColor).
SetDoubleBuffered(Boolean) | Represents method SetDoubleBuffered(Boolean).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetModalResult(TModalResult) | Represents method SetModalResult(TModalResult).
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetScaled(Boolean) | Represents method SetScaled(Boolean).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ShowModal | Show dialog page as Modal form.
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlsCoords | Used to validate coordinates of some child objects. FreePacal only.
UpdateDialogPPI(Integer) | Dialog page receives this message when user changes PPI of the screen or move dialog form to a screen with different PPI.
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FBorderStyle | Represents field FBorderStyle.
FCaption | Represents field FCaption.
FClientHeight | Represents field FClientHeight.
FClientWidth | Represents field FClientWidth.
FColor | Represents field FColor.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI.
FForm | Represents field FForm.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOnActivate | Represents field FOnActivate.
FOnClick | Represents field FOnClick.
FOnCloseQuery | Represents field FOnCloseQuery.
FOnDeactivate | Represents field FOnDeactivate.
FOnHide | Represents field FOnHide.
FOnKeyDown | Represents field FOnKeyDown.
FOnKeyPress | Represents field FOnKeyPress.
FOnKeyUp | Represents field FOnKeyUp.
FOnResize | Represents field FOnResize.
FOnShow | Represents field FOnShow.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPosition | Represents field FPosition.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FWindowState | Represents field FWindowState.
Top
See Also

Reference

  • frxClass


TfrxDialogPage Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDialogPage class. (Overrides TfrxPage.Create(TComponent).)
Destroy | Represents the destructor of the TfrxDialogPage class. (Overrides TfrxComponent.Destroy.)
Top


TfrxDialogPage.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDialogPage class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxPage.Create(TComponent)
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.Destroy Destructor

Summary

Represents the destructor of the TfrxDialogPage class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxComponent.Destroy
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage Properties

Properties
Name | Description
BorderStyle | The style of the window.
Caption | The caption of the window.
ClientHeight | Height of client area.
ClientWidth | Width of client area.
Color | The color of the window.
DialogForm | Link to TForm object.
DoubleBuffered | Enable double buffering for dialog form.
Height | Represents property Height.
Left | Represents property Left.
ModalResult | Modal result of the form.
OnActivate | Name of the script procedure that will be called on dialogue form activation.
OnClick | Name of the script procedure that will be called on click on the form.
OnCloseQuery | Name of the script procedure that will be called on closing the form. The event handler should return True to allow closing.
OnDeactivate | Name of the script procedure that will be called on deactivating the form.
OnHide | Name of the script procedure that will be called on hiding the form.
OnKeyDown | Name of the script procedure that will be called on pressing a key.
OnKeyPress | Name of the script procedure that will be called on pressing a key.
OnKeyUp | Name of the script procedure that will be called on releasing a key.
OnResize | Name of the script procedure that will be called on resizing the form.
OnShow | Name of the script procedure that will be called on showing the form.
Position | The initial position of the window.
Scaled | Represents property Scaled.
Top | Represents property Top.
Width | Represents property Width.
WindowState | Initial state of the window.
Top


TfrxDialogPage.BorderStyle Property

Summary

The style of the window.

Namespace: frxClass
Syntax
Delphi
published
 property BorderStyle: TFormBorderStyle read FBorderStyle write SetBorderStyle default bsSizeable;

Property Value

Type: TFormBorderStyle

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.Caption Property

Summary

The caption of the window.

Namespace: frxClass
Syntax
Delphi
published
 property Caption: String read FCaption write SetCaption;

Property Value

Type: String

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.ClientHeight Property

Summary

Height of client area.

Namespace: frxClass
Syntax
Delphi
published
 property ClientHeight: Extended read GetClientHeight write SetClientHeight stored IsClientSizeStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.ClientWidth Property

Summary

Width of client area.

Namespace: frxClass
Syntax
Delphi
published
 property ClientWidth: Extended read GetClientWidth write SetClientWidth stored IsClientSizeStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.Color Property

Summary

The color of the window.

Namespace: frxClass
Syntax
Delphi
published
 property Color: TColor read FColor write SetColor default clBtnFace;

Property Value

Type: TColor

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DialogForm Property

Summary

Link to TForm object.

Namespace: frxClass
Syntax
Delphi
public
 property DialogForm: TForm read FForm;

Property Value

Type: TForm

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoubleBuffered Property

Summary

Enable double buffering for dialog form.

Namespace: frxClass
Syntax
Delphi
published
 property DoubleBuffered: Boolean read GetDoubleBuffered write SetDoubleBuffered;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.Height Property

Summary

Represents property Height.

Namespace: frxClass
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.Left Property

Summary

Represents property Left.

Namespace: frxClass
Syntax
Delphi
published
 property Left;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.ModalResult Property

Summary

Modal result of the form.

Namespace: frxClass
Syntax
Delphi
public
 property ModalResult: TModalResult read GetModalResult write SetModalResult;

Property Value

Type: TModalResult

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.OnActivate Property

Summary

Name of the script procedure that will be called on dialogue form activation.

Namespace: frxClass
Syntax
Delphi
published
 property OnActivate: TfrxNotifyEvent read FOnActivate write FOnActivate;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.OnClick Property

Summary

Name of the script procedure that will be called on click on the form.

Namespace: frxClass
Syntax
Delphi
published
 property OnClick: TfrxNotifyEvent read FOnClick write FOnClick;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.OnCloseQuery Property

Summary

Name of the script procedure that will be called on closing the form. The event handler should return True to allow closing.

Namespace: frxClass
Syntax
Delphi
published
 property OnCloseQuery: TfrxCloseQueryEvent read FOnCloseQuery write FOnCloseQuery;

Property Value

Type: TfrxCloseQueryEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.OnDeactivate Property

Summary

Name of the script procedure that will be called on deactivating the form.

Namespace: frxClass
Syntax
Delphi
published
 property OnDeactivate: TfrxNotifyEvent read FOnDeactivate write FOnDeactivate;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.OnHide Property

Summary

Name of the script procedure that will be called on hiding the form.

Namespace: frxClass
Syntax
Delphi
published
 property OnHide: TfrxNotifyEvent read FOnHide write FOnHide;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.OnKeyDown Property

Summary

Name of the script procedure that will be called on pressing a key.

Namespace: frxClass
Syntax
Delphi
published
 property OnKeyDown: TfrxKeyEvent read FOnKeyDown write FOnKeyDown;

Property Value

Type: TfrxKeyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.OnKeyPress Property

Summary

Name of the script procedure that will be called on pressing a key.

Namespace: frxClass
Syntax
Delphi
published
 property OnKeyPress: TfrxKeyPressEvent read FOnKeyPress write FOnKeyPress;

Property Value

Type: TfrxKeyPressEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.OnKeyUp Property

Summary

Name of the script procedure that will be called on releasing a key.

Namespace: frxClass
Syntax
Delphi
published
 property OnKeyUp: TfrxKeyEvent read FOnKeyUp write FOnKeyUp;

Property Value

Type: TfrxKeyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.OnResize Property

Summary

Name of the script procedure that will be called on resizing the form.

Namespace: frxClass
Syntax
Delphi
published
 property OnResize: TfrxNotifyEvent read FOnResize write FOnResize;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.OnShow Property

Summary

Name of the script procedure that will be called on showing the form.

Namespace: frxClass
Syntax
Delphi
published
 property OnShow: TfrxNotifyEvent read FOnShow write FOnShow;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.Position Property

Summary

The initial position of the window.

Namespace: frxClass
Syntax
Delphi
published
 property Position: TPosition read FPosition write FPosition default poScreenCenter;

Property Value

Type: TPosition

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.Scaled Property

Summary

Represents property Scaled.

Namespace: frxClass
Syntax
Delphi
published
 property Scaled: Boolean read GetScaled write SetScaled;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.Top Property

Summary

Represents property Top.

Namespace: frxClass
Syntax
Delphi
published
 property Top;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.Width Property

Summary

Represents property Width.

Namespace: frxClass
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.WindowState Property

Summary

Initial state of the window.

Namespace: frxClass
Syntax
Delphi
published
 property WindowState: TWindowState read FWindowState write FWindowState default wsNormal;

Property Value

Type: TWindowState

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage Methods

Methods
Name | Description
DoInitialize | Represents method DoInitialize.
DoModify(TObject) | Represents method DoModify(TObject).
DoOnActivate(TObject) | Represents method DoOnActivate(TObject).
DoOnClick(TObject) | Represents method DoOnClick(TObject).
DoOnCloseQuery(TObject,Boolean) | Represents method DoOnCloseQuery(TObject,Boolean).
DoOnDeactivate(TObject) | Represents method DoOnDeactivate(TObject).
DoOnHide(TObject) | Represents method DoOnHide(TObject).
DoOnKeyDown(TObject,Word,TShiftState) | Represents method DoOnKeyDown(TObject,Word,TShiftState).
DoOnKeyPress(TObject,Char) | Represents method DoOnKeyPress(TObject,Char).
DoOnKeyUp(TObject,Word,TShiftState) | Represents method DoOnKeyUp(TObject,Word,TShiftState).
DoOnMouseMove(TObject,TShiftState,Integer,Integer) | Represents method DoOnMouseMove(TObject,TShiftState,Integer,Integer).
DoOnResize(TObject) | Represents method DoOnResize(TObject).
DoOnShow(TObject) | Represents method DoOnShow(TObject).
DoShowModal | Represents method DoShowModal.
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetClientHeight | Represents method GetClientHeight.
GetClientWidth | Represents method GetClientWidth.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDoubleBuffered | Represents method GetDoubleBuffered.
GetModalResult | Represents method GetModalResult.
GetPPIScale | Represents method GetPPIScale.
GetScaled | Represents method GetScaled.
Initialize | Initialize dialog page.
IsClientSizeStored | Represents method IsClientSizeStored.
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
SetBorderStyle(TFormBorderStyle) | Represents method SetBorderStyle(TFormBorderStyle).
SetCaption(String) | Represents method SetCaption(String).
SetClientHeight(Extended) | Represents method SetClientHeight(Extended).
SetClientWidth(Extended) | Represents method SetClientWidth(Extended).
SetColor(TColor) | Represents method SetColor(TColor).
SetDoubleBuffered(Boolean) | Represents method SetDoubleBuffered(Boolean).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetModalResult(TModalResult) | Represents method SetModalResult(TModalResult).
SetScaled(Boolean) | Represents method SetScaled(Boolean).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ShowModal | Show dialog page as Modal form.
UpdateControlsCoords | Used to validate coordinates of some child objects. FreePacal only.
UpdateDialogPPI(Integer) | Dialog page receives this message when user changes PPI of the screen or move dialog form to a screen with different PPI.
Top


TfrxDialogPage.DoInitialize Method

Summary

Represents method DoInitialize.

Namespace: frxClass
Syntax
Delphi
private
 procedure DoInitialize;
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoModify(TObject) Method

Summary

Represents method DoModify(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoModify(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoOnActivate(TObject) Method

Summary

Represents method DoOnActivate(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnActivate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoOnClick(TObject) Method

Summary

Represents method DoOnClick(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoOnCloseQuery(TObject,Boolean) Method

Summary

Represents method DoOnCloseQuery(TObject,Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnCloseQuery(Sender: TObject; var CanClose: Boolean);

Parameters

Sender
Type: TObject

CanClose
Type: Boolean

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoOnDeactivate(TObject) Method

Summary

Represents method DoOnDeactivate(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnDeactivate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoOnHide(TObject) Method

Summary

Represents method DoOnHide(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnHide(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoOnKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method DoOnKeyDown(TObject,Word,TShiftState).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoOnKeyPress(TObject,Char) Method

Summary

Represents method DoOnKeyPress(TObject,Char).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnKeyPress(Sender: TObject; var Key: Char);

Parameters

Sender
Type: TObject

Key
Type: Char

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoOnKeyUp(TObject,Word,TShiftState) Method

Summary

Represents method DoOnKeyUp(TObject,Word,TShiftState).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnKeyUp(Sender: TObject; var Key: Word; Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoOnMouseMove(TObject,TShiftState,Integer,Integer) Method

Summary

Represents method DoOnMouseMove(TObject,TShiftState,Integer,Integer).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnMouseMove(Sender: TObject; Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoOnResize(TObject) Method

Summary

Represents method DoOnResize(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoOnShow(TObject) Method

Summary

Represents method DoOnShow(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure DoOnShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.DoShowModal Method

Summary

Represents method DoShowModal.

Namespace: frxClass
Syntax
Delphi
private
 procedure DoShowModal;
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FontChanged(TObject) Method

Summary

Represents method FontChanged(TObject).

Namespace: frxClass
Syntax
Delphi
protected
 procedure FontChanged(Sender: TObject); override;

Parameters

Sender
Type: TObject

Overrides

TfrxComponent.FontChanged(TObject)
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.GetClientHeight Method

Summary

Represents method GetClientHeight.

Namespace: frxClass
Syntax
Delphi
protected
 function GetClientHeight: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.GetClientWidth Method

Summary

Represents method GetClientWidth.

Namespace: frxClass
Syntax
Delphi
protected
 function GetClientWidth: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.GetDoubleBuffered Method

Summary

Represents method GetDoubleBuffered.

Namespace: frxClass
Syntax
Delphi
private
 function GetDoubleBuffered: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.GetModalResult Method

Summary

Represents method GetModalResult.

Namespace: frxClass
Syntax
Delphi
private
 function GetModalResult: TModalResult;

Return Value

Type: TModalResult

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.GetPPIScale Method

Summary

Represents method GetPPIScale.

Namespace: frxClass
Syntax
Delphi
protected
 function GetPPIScale: Single;

Return Value

Type: Single

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.GetScaled Method

Summary

Represents method GetScaled.

Namespace: frxClass
Syntax
Delphi
protected
 function GetScaled: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.Initialize Method

Summary

Initialize dialog page.

Namespace: frxClass
Syntax
Delphi
public
 procedure Initialize;
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.IsClientSizeStored Method

Summary

Represents method IsClientSizeStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsClientSizeStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.IsContain(Extended,Extended) Method

Summary

Detects if point is inside an object coordinates.

Namespace: frxClass
Syntax
Delphi
public
 function IsContain(X, Y: Extended): Boolean; override;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

Overrides

TfrxComponent.IsContain(Extended,Extended)
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.SetBorderStyle(TFormBorderStyle) Method

Summary

Represents method SetBorderStyle(TFormBorderStyle).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetBorderStyle(const Value: TFormBorderStyle);

Parameters

Value
Type: TFormBorderStyle

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.SetCaption(String) Method

Summary

Represents method SetCaption(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetCaption(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.SetClientHeight(Extended) Method

Summary

Represents method SetClientHeight(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetClientHeight(Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.SetClientWidth(Extended) Method

Summary

Represents method SetClientWidth(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetClientWidth(Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.SetDoubleBuffered(Boolean) Method

Summary

Represents method SetDoubleBuffered(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDoubleBuffered(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.SetHeight(Extended) Method

Summary

Represents method SetHeight(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetHeight(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetHeight(Extended)
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.SetLeft(Extended) Method

Summary

Represents method SetLeft(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetLeft(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetLeft(Extended)
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.SetModalResult(TModalResult) Method

Summary

Represents method SetModalResult(TModalResult).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetModalResult(const Value: TModalResult);

Parameters

Value
Type: TModalResult

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.SetScaled(Boolean) Method

Summary

Represents method SetScaled(Boolean).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetScaled(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.SetTop(Extended) Method

Summary

Represents method SetTop(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetTop(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetTop(Extended)
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.SetWidth(Extended) Method

Summary

Represents method SetWidth(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetWidth(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetWidth(Extended)
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.ShowModal Method

Summary

Show dialog page as Modal form.

Namespace: frxClass
Syntax
Delphi
public
 function ShowModal: TModalResult;

Return Value

Type: TModalResult

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.UpdateControlsCoords Method

Summary

Used to validate coordinates of some child objects. FreePacal only.

Namespace: frxClass
Syntax
Delphi
public
 procedure UpdateControlsCoords;
See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.UpdateDialogPPI(Integer) Method

Summary

Dialog page receives this message when user changes PPI of the screen or move dialog form to a screen with different PPI.

Namespace: frxClass
Syntax
Delphi
public
 procedure UpdateDialogPPI(aNewPPI: Integer); virtual;

Parameters

aNewPPI
Type: Integer

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage Fields

Fields
Name | Description
FBorderStyle | Represents field FBorderStyle.
FCaption | Represents field FCaption.
FClientHeight | Represents field FClientHeight.
FClientWidth | Represents field FClientWidth.
FColor | Represents field FColor.
FCurrentPPI | Represents field FCurrentPPI.
FForm | Represents field FForm.
FOnActivate | Represents field FOnActivate.
FOnClick | Represents field FOnClick.
FOnCloseQuery | Represents field FOnCloseQuery.
FOnDeactivate | Represents field FOnDeactivate.
FOnHide | Represents field FOnHide.
FOnKeyDown | Represents field FOnKeyDown.
FOnKeyPress | Represents field FOnKeyPress.
FOnKeyUp | Represents field FOnKeyUp.
FOnResize | Represents field FOnResize.
FOnShow | Represents field FOnShow.
FPosition | Represents field FPosition.
FWindowState | Represents field FWindowState.
Top


TfrxDialogPage.FBorderStyle Field

Summary

Represents field FBorderStyle.

Namespace: frxClass
Syntax
Delphi
private
 FBorderStyle: TFormBorderStyle;

Field Value

Type: TFormBorderStyle

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FCaption Field

Summary

Represents field FCaption.

Namespace: frxClass
Syntax
Delphi
private
 FCaption: String;

Field Value

Type: String

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FClientHeight Field

Summary

Represents field FClientHeight.

Namespace: frxClass
Syntax
Delphi
private
 FClientHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FClientWidth Field

Summary

Represents field FClientWidth.

Namespace: frxClass
Syntax
Delphi
private
 FClientWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FColor Field

Summary

Represents field FColor.

Namespace: frxClass
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FCurrentPPI Field

Summary

Represents field FCurrentPPI.

Namespace: frxClass
Syntax
Delphi
private
 FCurrentPPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FForm Field

Summary

Represents field FForm.

Namespace: frxClass
Syntax
Delphi
private
 FForm: TForm;

Field Value

Type: TForm

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FOnActivate Field

Summary

Represents field FOnActivate.

Namespace: frxClass
Syntax
Delphi
private
 FOnActivate: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FOnClick Field

Summary

Represents field FOnClick.

Namespace: frxClass
Syntax
Delphi
private
 FOnClick: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FOnCloseQuery Field

Summary

Represents field FOnCloseQuery.

Namespace: frxClass
Syntax
Delphi
private
 FOnCloseQuery: TfrxCloseQueryEvent;

Field Value

Type: TfrxCloseQueryEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FOnDeactivate Field

Summary

Represents field FOnDeactivate.

Namespace: frxClass
Syntax
Delphi
private
 FOnDeactivate: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FOnHide Field

Summary

Represents field FOnHide.

Namespace: frxClass
Syntax
Delphi
private
 FOnHide: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FOnKeyDown Field

Summary

Represents field FOnKeyDown.

Namespace: frxClass
Syntax
Delphi
private
 FOnKeyDown: TfrxKeyEvent;

Field Value

Type: TfrxKeyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FOnKeyPress Field

Summary

Represents field FOnKeyPress.

Namespace: frxClass
Syntax
Delphi
private
 FOnKeyPress: TfrxKeyPressEvent;

Field Value

Type: TfrxKeyPressEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FOnKeyUp Field

Summary

Represents field FOnKeyUp.

Namespace: frxClass
Syntax
Delphi
private
 FOnKeyUp: TfrxKeyEvent;

Field Value

Type: TfrxKeyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FOnResize Field

Summary

Represents field FOnResize.

Namespace: frxClass
Syntax
Delphi
private
 FOnResize: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FOnShow Field

Summary

Represents field FOnShow.

Namespace: frxClass
Syntax
Delphi
private
 FOnShow: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FPosition Field

Summary

Represents field FPosition.

Namespace: frxClass
Syntax
Delphi
private
 FPosition: TPosition;

Field Value

Type: TPosition

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxDialogPage.FWindowState Field

Summary

Represents field FWindowState.

Namespace: frxClass
Syntax
Delphi
private
 FWindowState: TWindowState;

Field Value

Type: TWindowState

See Also

Reference

  • TfrxDialogPage
  • frxClass


TfrxEngineOptions Class

Summary

The TfrxEngineOptions class represents a set of properties related to the FastReport engine. Instance of this class is stored in the TfrxReport.EngineOptions.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxEngineOptions
Syntax
Delphi
type
 TfrxEngineOptions = class(TPersistent)
 end;

The TfrxEngineOptions type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxEngineOptions class.
Top
Properties
Show:
Name | Description
ConvertNulls | Converts the "Null" value of the DB field into "0," "False," or empty string, depending on the field type. Default value is True.
DestroyForms | Determines whether to save the report to the temporary stream before run a report and restore it after report is finished. Default is True.
DoublePass | Makes a report a two-pass one. Default value is False.
EnableThreadSafe | Switch TfrxReport component in multi-thread mode. It disables unsafe routines like ProcessMessages cycle.
IgnoreDevByZero | Ignore all "Division by zero" exceptions inside expression calculation.
IgnoreExprError | Ignore all expression exceptions inside expression calculation.
MaxMemSize | The maximum size of memory in Mbytes, allocated to the report pages' cache. It becomes useful in cases when the "UseFileCache" property is equal to "True." If a report begins to occupy more memory during construction, caching of the constructed report pages into a temporary file is performed. This property is inexact and allows only approximate determination of the memory limit. Default value is 10.
NewSilentMode | Set behaviour of exceptions handling during report execution.
PrintIfEmpty | Defines, whether it is necessary to print a blank report (one which contains no data lines). Default value is True.
ReportThread | Deprecated. Not used.
SilentMode | Deprecated(See NewSilentMode). "Silent" mode. When errors occurred during loading or running report, no dialog windows will be shown. All errors will be contained in the TfrxReport.Errors property. This mode is useful for server applications. Default value is False.
TempDir | Specifies a path to the directory for storing temporary files.
UseFileCache | Defines, whether it is necessary to use report pages caching into a file (see the "MaxMemSize" property). Default value is False.
UseGlobalDataSetList | The property determines if its necessary to use the global list of DataSet or to use the list of EnabledDataSet collection of TfrxReport component. Default-True.
ZeroPrecisionValue | This property contains precision value for zero comparison operation in Text objects(used with HideZeros property). The value in Text object below precision value interpret as zero. Default is 1E-17.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Copies the contents from another object.
AssignThreadProps(TPersistent) | Copies properties responsible for multi-thread behaviour from another object.
Clear | Clears all properties and fills them by default values.
GetSilentMode | Represents method GetSilentMode.
SetSilentMode(Boolean) | Represents method SetSilentMode(Boolean).
Top
Fields
Show:
Name | Description
FConvertNulls | Represents field FConvertNulls.
FDestroyForms | Represents field FDestroyForms.
FDoublePass | Represents field FDoublePass.
FEnableThreadSafe | Represents field FEnableThreadSafe.
FIgnoreDevByZero | Represents field FIgnoreDevByZero.
FIgnoreExprError | Represents field FIgnoreExprError.
FMaxMemSize | Represents field FMaxMemSize.
FPrintIfEmpty | Represents field FPrintIfEmpty.
FReportThread | Represents field FReportThread.
FSilentMode | Represents field FSilentMode.
FTempDir | Represents field FTempDir.
FUseFileCache | Represents field FUseFileCache.
FUseGlobalDataSetList | Represents field FUseGlobalDataSetList.
FZeroPrecisionValue | Represents field FZeroPrecisionValue.
Top
See Also

Reference

  • frxClass


TfrxEngineOptions Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxEngineOptions class.
Top


TfrxEngineOptions.Create Constructor

Summary

Initializes a new instance of the TfrxEngineOptions class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions Properties

Properties
Name | Description
ConvertNulls | Converts the "Null" value of the DB field into "0," "False," or empty string, depending on the field type. Default value is True.
DestroyForms | Determines whether to save the report to the temporary stream before run a report and restore it after report is finished. Default is True.
DoublePass | Makes a report a two-pass one. Default value is False.
EnableThreadSafe | Switch TfrxReport component in multi-thread mode. It disables unsafe routines like ProcessMessages cycle.
IgnoreDevByZero | Ignore all "Division by zero" exceptions inside expression calculation.
IgnoreExprError | Ignore all expression exceptions inside expression calculation.
MaxMemSize | The maximum size of memory in Mbytes, allocated to the report pages' cache. It becomes useful in cases when the "UseFileCache" property is equal to "True." If a report begins to occupy more memory during construction, caching of the constructed report pages into a temporary file is performed. This property is inexact and allows only approximate determination of the memory limit. Default value is 10.
NewSilentMode | Set behaviour of exceptions handling during report execution.
PrintIfEmpty | Defines, whether it is necessary to print a blank report (one which contains no data lines). Default value is True.
ReportThread | Deprecated. Not used.
SilentMode | Deprecated(See NewSilentMode). "Silent" mode. When errors occurred during loading or running report, no dialog windows will be shown. All errors will be contained in the TfrxReport.Errors property. This mode is useful for server applications. Default value is False.
TempDir | Specifies a path to the directory for storing temporary files.
UseFileCache | Defines, whether it is necessary to use report pages caching into a file (see the "MaxMemSize" property). Default value is False.
UseGlobalDataSetList | The property determines if its necessary to use the global list of DataSet or to use the list of EnabledDataSet collection of TfrxReport component. Default-True.
ZeroPrecisionValue | This property contains precision value for zero comparison operation in Text objects(used with HideZeros property). The value in Text object below precision value interpret as zero. Default is 1E-17.
Top


TfrxEngineOptions.ConvertNulls Property

Summary

Converts the "Null" value of the DB field into "0," "False," or empty string, depending on the field type. Default value is True.

Namespace: frxClass
Syntax
Delphi
published
 property ConvertNulls: Boolean read FConvertNulls write FConvertNulls default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.DestroyForms Property

Summary

Determines whether to save the report to the temporary stream before run a report and restore it after report is finished. Default is True.

Namespace: frxClass
Syntax
Delphi
public
 property DestroyForms: Boolean read FDestroyForms write FDestroyForms;

Property Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.DoublePass Property

Summary

Makes a report a two-pass one. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property DoublePass: Boolean read FDoublePass write FDoublePass default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.EnableThreadSafe Property

Summary

Switch TfrxReport component in multi-thread mode. It disables unsafe routines like ProcessMessages cycle.

Namespace: frxClass
Syntax
Delphi
public
 property EnableThreadSafe: Boolean read FEnableThreadSafe write FEnableThreadSafe;

Property Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.IgnoreDevByZero Property

Summary

Ignore all "Division by zero" exceptions inside expression calculation.

Namespace: frxClass
Syntax
Delphi
published
 property IgnoreDevByZero: Boolean read FIgnoreDevByZero write FIgnoreDevByZero default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.IgnoreExprError Property

Summary

Ignore all expression exceptions inside expression calculation.

Namespace: frxClass
Syntax
Delphi
published
 property IgnoreExprError: Boolean read FIgnoreExprError write FIgnoreExprError default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.MaxMemSize Property

Summary

The maximum size of memory in Mbytes, allocated to the report pages' cache. It becomes useful in cases when the "UseFileCache" property is equal to "True." If a report begins to occupy more memory during construction, caching of the constructed report pages into a temporary file is performed. This property is inexact and allows only approximate determination of the memory limit. Default value is 10.

Namespace: frxClass
Syntax
Delphi
published
 property MaxMemSize: Integer read FMaxMemSize write FMaxMemSize default 10;

Property Value

Type: Integer

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.NewSilentMode Property

Summary

Set behaviour of exceptions handling during report execution.

Namespace: frxClass
Syntax
Delphi
published
 property NewSilentMode: TfrxSilentMode read FSilentMode write FSilentMode default simMessageBoxes;

Property Value

Type: TfrxSilentMode

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.PrintIfEmpty Property

Summary

Defines, whether it is necessary to print a blank report (one which contains no data lines). Default value is True.

Namespace: frxClass
Syntax
Delphi
published
 property PrintIfEmpty: Boolean read FPrintIfEmpty write FPrintIfEmpty default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.ReportThread Property

Summary

Deprecated. Not used.

Namespace: frxClass
Syntax
Delphi
public
 property ReportThread: TThread read FReportThread write FReportThread;

Property Value

Type: TThread

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.SilentMode Property

Summary

Deprecated(See NewSilentMode). "Silent" mode. When errors occurred during loading or
running report, no dialog windows will be shown. All errors will be
contained in the TfrxReport.Errors property. This mode is useful for
server applications. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property SilentMode: Boolean read GetSilentMode write SetSilentMode default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.TempDir Property

Summary

Specifies a path to the directory for storing temporary files.

Namespace: frxClass
Syntax
Delphi
published
 property TempDir: String read FTempDir write FTempDir;

Property Value

Type: String

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.UseFileCache Property

Summary

Defines, whether it is necessary to use report pages caching into a file (see the "MaxMemSize" property). Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property UseFileCache: Boolean read FUseFileCache write FUseFileCache default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.UseGlobalDataSetList Property

Summary

The property determines if its necessary to use the global list of DataSet or to use the list of EnabledDataSet collection of TfrxReport component. Default-True.

Namespace: frxClass
Syntax
Delphi
public
 property UseGlobalDataSetList: Boolean read FUseGlobalDataSetList write FUseGlobalDataSetList;

Property Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.ZeroPrecisionValue Property

Summary

This property contains precision value for zero comparison operation in Text objects(used with HideZeros property). The value in Text object below precision value interpret as zero. Default is 1E-17.

Namespace: frxClass
Syntax
Delphi
public
 property ZeroPrecisionValue: Extended read FZeroPrecisionValue write FZeroPrecisionValue;

Property Value

Type: Extended

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions Methods

Methods
Name | Description
Assign(TPersistent) | Copies the contents from another object.
AssignThreadProps(TPersistent) | Copies properties responsible for multi-thread behaviour from another object.
Clear | Clears all properties and fills them by default values.
GetSilentMode | Represents method GetSilentMode.
SetSilentMode(Boolean) | Represents method SetSilentMode(Boolean).
Top


TfrxEngineOptions.Assign(TPersistent) Method

Summary

Copies the contents from another object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.AssignThreadProps(TPersistent) Method

Summary

Copies properties responsible for multi-thread behaviour from another object.

Namespace: frxClass
Syntax
Delphi
public
 procedure AssignThreadProps(Source: TPersistent);

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.Clear Method

Summary

Clears all properties and fills them by default values.

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.GetSilentMode Method

Summary

Represents method GetSilentMode.

Namespace: frxClass
Syntax
Delphi
private
 function GetSilentMode: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.SetSilentMode(Boolean) Method

Summary

Represents method SetSilentMode(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetSilentMode(Mode: Boolean);

Parameters

Mode
Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions Fields

Fields
Name | Description
FConvertNulls | Represents field FConvertNulls.
FDestroyForms | Represents field FDestroyForms.
FDoublePass | Represents field FDoublePass.
FEnableThreadSafe | Represents field FEnableThreadSafe.
FIgnoreDevByZero | Represents field FIgnoreDevByZero.
FIgnoreExprError | Represents field FIgnoreExprError.
FMaxMemSize | Represents field FMaxMemSize.
FPrintIfEmpty | Represents field FPrintIfEmpty.
FReportThread | Represents field FReportThread.
FSilentMode | Represents field FSilentMode.
FTempDir | Represents field FTempDir.
FUseFileCache | Represents field FUseFileCache.
FUseGlobalDataSetList | Represents field FUseGlobalDataSetList.
FZeroPrecisionValue | Represents field FZeroPrecisionValue.
Top


TfrxEngineOptions.FConvertNulls Field

Summary

Represents field FConvertNulls.

Namespace: frxClass
Syntax
Delphi
private
 FConvertNulls: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FDestroyForms Field

Summary

Represents field FDestroyForms.

Namespace: frxClass
Syntax
Delphi
private
 FDestroyForms: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FDoublePass Field

Summary

Represents field FDoublePass.

Namespace: frxClass
Syntax
Delphi
private
 FDoublePass: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FEnableThreadSafe Field

Summary

Represents field FEnableThreadSafe.

Namespace: frxClass
Syntax
Delphi
private
 FEnableThreadSafe: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FIgnoreDevByZero Field

Summary

Represents field FIgnoreDevByZero.

Namespace: frxClass
Syntax
Delphi
private
 FIgnoreDevByZero: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FIgnoreExprError Field

Summary

Represents field FIgnoreExprError.

Namespace: frxClass
Syntax
Delphi
private
 FIgnoreExprError: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FMaxMemSize Field

Summary

Represents field FMaxMemSize.

Namespace: frxClass
Syntax
Delphi
private
 FMaxMemSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FPrintIfEmpty Field

Summary

Represents field FPrintIfEmpty.

Namespace: frxClass
Syntax
Delphi
private
 FPrintIfEmpty: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FReportThread Field

Summary

Represents field FReportThread.

Namespace: frxClass
Syntax
Delphi
private
 FReportThread: TThread;

Field Value

Type: TThread

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FSilentMode Field

Summary

Represents field FSilentMode.

Namespace: frxClass
Syntax
Delphi
private
 FSilentMode: TfrxSilentMode;

Field Value

Type: TfrxSilentMode

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FTempDir Field

Summary

Represents field FTempDir.

Namespace: frxClass
Syntax
Delphi
private
 FTempDir: String;

Field Value

Type: String

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FUseFileCache Field

Summary

Represents field FUseFileCache.

Namespace: frxClass
Syntax
Delphi
private
 FUseFileCache: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FUseGlobalDataSetList Field

Summary

Represents field FUseGlobalDataSetList.

Namespace: frxClass
Syntax
Delphi
private
 FUseGlobalDataSetList: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEngineOptions.FZeroPrecisionValue Field

Summary

Represents field FZeroPrecisionValue.

Namespace: frxClass
Syntax
Delphi
private
 FZeroPrecisionValue: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxEngineOptions
  • frxClass


TfrxEventObject Class

Summary

Class uses in DragDrop events. It helps to determinate when object event was called from another object editor. Check TfrxInPlaceBandEditor.DoCustomDragDrop.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxEventObject
Syntax
Delphi
type
 TfrxEventObject = class(TObject)
 end;

The TfrxEventObject type exposes the following members.

Fields
Show:
Name | Description
Index | Represents field Index.
Sender | Represents field Sender.
Top
See Also

Reference

  • frxClass


TfrxEventObject Fields

Fields
Name | Description
Index | Represents field Index.
Sender | Represents field Sender.
Top


TfrxEventObject.Index Field

Summary

Represents field Index.

Namespace: frxClass
Syntax
Delphi
public
 Index: NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • TfrxEventObject
  • frxClass


TfrxEventObject.Sender Field

Summary

Represents field Sender.

Namespace: frxClass
Syntax
Delphi
public
 Sender: TObject;

Field Value

Type: TObject

See Also

Reference

  • TfrxEventObject
  • frxClass


TfrxExpressionCache Class

Summary

The TfrxReportOptions class represents an expression cache. The instance of this class used in the report object to store most used expressions and link them with script items. It significantly increases expression calculation (like aggregate functions) in a huge reports because syntax parsing of expressions called only once.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxExpressionCache
Syntax
Delphi
type
 TfrxExpressionCache = class(TObject)
 end;

The TfrxExpressionCache type exposes the following members.

Constructors
Show:
Name | Description
Create(TfsScript) | Constructor winch receives default script object.
Destroy | Represents the destructor of the TfrxExpressionCache class.
Top
Properties
Show:
Name | Description
CaseSensitive | If True , then the expression will be catching subject to the letter list . It is necessary to use the same text with different letter list in expression.
Top
Methods
Show:
Name | Description
Calc(String,String,TfsScript) | Calculates an expression.
Clear | Clears expression cache.
GetCaseSensitive | Represents method GetCaseSensitive.
SetCaseSensitive(Boolean) | Represents method SetCaseSensitive(Boolean).
Top
Fields
Show:
Name | Description
FExpressions | Represents field FExpressions.
FMainScript | Represents field FMainScript.
FScript | Represents field FScript.
FScriptLanguage | Represents field FScriptLanguage.
Top
See Also

Reference

  • frxClass


TfrxExpressionCache Constructors

Constructors
Name | Description
Create(TfsScript) | Constructor winch receives default script object.
Destroy | Represents the destructor of the TfrxExpressionCache class.
Top


TfrxExpressionCache.Create(TfsScript) Constructor

Summary

Constructor winch receives default script object.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AScript: TfsScript);

Parameters

AScript
Type: TfsScript

Default script object.

See Also

Reference

  • TfrxExpressionCache
  • frxClass


TfrxExpressionCache.Destroy Destructor

Summary

Represents the destructor of the TfrxExpressionCache class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxExpressionCache
  • frxClass


TfrxExpressionCache Properties

Properties
Name | Description
CaseSensitive | If True , then the expression will be catching subject to the letter list . It is necessary to use the same text with different letter list in expression.
Top


TfrxExpressionCache.CaseSensitive Property

Summary

If True , then the expression will be catching subject to the letter list . It is necessary to use the same text with different letter list in expression.

Namespace: frxClass
Syntax
Delphi
public
 property CaseSensitive: Boolean read GetCaseSensitive write SetCaseSensitive;

Property Value

Type: Boolean

See Also

Reference

  • TfrxExpressionCache
  • frxClass


TfrxExpressionCache Methods

Methods
Name | Description
Calc(String,String,TfsScript) | Calculates an expression.
Clear | Clears expression cache.
GetCaseSensitive | Represents method GetCaseSensitive.
SetCaseSensitive(Boolean) | Represents method SetCaseSensitive(Boolean).
Top


TfrxExpressionCache.Calc(String,String,TfsScript) Method

Summary

Calculates an expression.

Namespace: frxClass
Syntax
Delphi
public
 function Calc(const Expression: String; var ErrorMsg: String;
 AScript: TfsScript): Variant;

Parameters

Expression
Type: String

Expression to calculate.

ErrorMsg
Type: String

Out. Contains error message if error occurred.

AScript
Type: TfsScript

Script object used to calculate an expression.

Return Value

Type: Variant

See Also

Reference

  • TfrxExpressionCache
  • frxClass


TfrxExpressionCache.Clear Method

Summary

Clears expression cache.

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxExpressionCache
  • frxClass


TfrxExpressionCache.GetCaseSensitive Method

Summary

Represents method GetCaseSensitive.

Namespace: frxClass
Syntax
Delphi
private
 function GetCaseSensitive: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxExpressionCache
  • frxClass


TfrxExpressionCache.SetCaseSensitive(Boolean) Method

Summary

Represents method SetCaseSensitive(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetCaseSensitive(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxExpressionCache
  • frxClass


TfrxExpressionCache Fields

Fields
Name | Description
FExpressions | Represents field FExpressions.
FMainScript | Represents field FMainScript.
FScript | Represents field FScript.
FScriptLanguage | Represents field FScriptLanguage.
Top


TfrxExpressionCache.FExpressions Field

Summary

Represents field FExpressions.

Namespace: frxClass
Syntax
Delphi
private
 FExpressions: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxExpressionCache
  • frxClass


TfrxExpressionCache.FMainScript Field

Summary

Represents field FMainScript.

Namespace: frxClass
Syntax
Delphi
private
 FMainScript: TfsScript;

Field Value

Type: TfsScript

See Also

Reference

  • TfrxExpressionCache
  • frxClass


TfrxExpressionCache.FScript Field

Summary

Represents field FScript.

Namespace: frxClass
Syntax
Delphi
private
 FScript: TfsScript;

Field Value

Type: TfsScript

See Also

Reference

  • TfrxExpressionCache
  • frxClass


TfrxExpressionCache.FScriptLanguage Field

Summary

Represents field FScriptLanguage.

Namespace: frxClass
Syntax
Delphi
private
 FScriptLanguage: String;

Field Value

Type: String

See Also

Reference

  • TfrxExpressionCache
  • frxClass


TfrxExtPropList Class

Summary

Represents type TfrxExtPropList.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxExtPropList
Syntax
Delphi
type
 TfrxExtPropList = class(TObject)
 end;

The TfrxExtPropList type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxExtPropList class.
Destroy | Represents the destructor of the TfrxExtPropList class.
Top
Properties
Show:
Name | Description
GetMethod[Integer] | Represents property GetMethod[Integer].
Name[Integer] | Represents property Name[Integer].
SetMethod[Integer] | Represents property SetMethod[Integer].
TypInfo[Integer] | Represents property TypInfo[Integer].
Top
Methods
Show:
Name | Description
AddProperty(ShortString,Pointer,Pointer,Pointer) | Represents method AddProperty(ShortString,Pointer,Pointer,Pointer).
ClearPropInfo | Represents method ClearPropInfo.
Count | Represents method Count.
GetGetMethod(Integer) | Represents method GetGetMethod(Integer).
GetName(Integer) | Represents method GetName(Integer).
GetSetMethod(Integer) | Represents method GetSetMethod(Integer).
GetTypInfo(Integer) | Represents method GetTypInfo(Integer).
SetGetMethod(Integer,Pointer) | Represents method SetGetMethod(Integer,Pointer).
SetName(Integer,String) | Represents method SetName(Integer,String).
SetSetMethod(Integer,Pointer) | Represents method SetSetMethod(Integer,Pointer).
SetTypInfo(Integer,Pointer) | Represents method SetTypInfo(Integer,Pointer).
Top
Fields
Show:
Name | Description
FPropInfos | Represents field FPropInfos.
Top
See Also

Reference

  • frxClass


TfrxExtPropList Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxExtPropList class.
Destroy | Represents the destructor of the TfrxExtPropList class.
Top


TfrxExtPropList.Create Constructor

Summary

Initializes a new instance of the TfrxExtPropList class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.Destroy Destructor

Summary

Represents the destructor of the TfrxExtPropList class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList Properties

Properties
Name | Description
GetMethod[Integer] | Represents property GetMethod[Integer].
Name[Integer] | Represents property Name[Integer].
SetMethod[Integer] | Represents property SetMethod[Integer].
TypInfo[Integer] | Represents property TypInfo[Integer].
Top


TfrxExtPropList.GetMethod[Integer] Property

Summary

Represents property GetMethod[Integer].

Namespace: frxClass
Syntax
Delphi
public
 property GetMethod[Index: Integer]: Pointer read GetGetMethod write SetGetMethod;

Parameters

Index
Type: Integer

Property Value

Type: Pointer

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.Name[Integer] Property

Summary

Represents property Name[Integer].

Namespace: frxClass
Syntax
Delphi
public
 property Name[Index: Integer]: String read GetName write SetName;

Parameters

Index
Type: Integer

Property Value

Type: String

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.SetMethod[Integer] Property

Summary

Represents property SetMethod[Integer].

Namespace: frxClass
Syntax
Delphi
public
 property SetMethod[Index: Integer]: Pointer read GetSetMethod write SetSetMethod;

Parameters

Index
Type: Integer

Property Value

Type: Pointer

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.TypInfo[Integer] Property

Summary

Represents property TypInfo[Integer].

Namespace: frxClass
Syntax
Delphi
public
 property TypInfo[Index: Integer]: Pointer read GetTypInfo write SetTypInfo;

Parameters

Index
Type: Integer

Property Value

Type: Pointer

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList Methods

Methods
Name | Description
AddProperty(ShortString,Pointer,Pointer,Pointer) | Represents method AddProperty(ShortString,Pointer,Pointer,Pointer).
ClearPropInfo | Represents method ClearPropInfo.
Count | Represents method Count.
GetGetMethod(Integer) | Represents method GetGetMethod(Integer).
GetName(Integer) | Represents method GetName(Integer).
GetSetMethod(Integer) | Represents method GetSetMethod(Integer).
GetTypInfo(Integer) | Represents method GetTypInfo(Integer).
SetGetMethod(Integer,Pointer) | Represents method SetGetMethod(Integer,Pointer).
SetName(Integer,String) | Represents method SetName(Integer,String).
SetSetMethod(Integer,Pointer) | Represents method SetSetMethod(Integer,Pointer).
SetTypInfo(Integer,Pointer) | Represents method SetTypInfo(Integer,Pointer).
Top


TfrxExtPropList.AddProperty(ShortString,Pointer,Pointer,Pointer) Method

Summary

Represents method AddProperty(ShortString,Pointer,Pointer,Pointer).

Namespace: frxClass
Syntax
Delphi
public
 procedure AddProperty(aName: ShortString; pTypInf, StaticGetMethod, StaticSetMethod: Pointer);

Parameters

aName
Type: ShortString

pTypInf
Type: Pointer

StaticGetMethod
Type: Pointer

StaticSetMethod
Type: Pointer

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.ClearPropInfo Method

Summary

Represents method ClearPropInfo.

Namespace: frxClass
Syntax
Delphi
private
 procedure ClearPropInfo;
See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.Count Method

Summary

Represents method Count.

Namespace: frxClass
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.GetGetMethod(Integer) Method

Summary

Represents method GetGetMethod(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetGetMethod(Index: Integer): Pointer;

Parameters

Index
Type: Integer

Return Value

Type: Pointer

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.GetName(Integer) Method

Summary

Represents method GetName(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetName(Index: Integer): String;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.GetSetMethod(Integer) Method

Summary

Represents method GetSetMethod(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetSetMethod(Index: Integer): Pointer;

Parameters

Index
Type: Integer

Return Value

Type: Pointer

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.GetTypInfo(Integer) Method

Summary

Represents method GetTypInfo(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetTypInfo(Index: Integer): Pointer;

Parameters

Index
Type: Integer

Return Value

Type: Pointer

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.SetGetMethod(Integer,Pointer) Method

Summary

Represents method SetGetMethod(Integer,Pointer).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetGetMethod(Index: Integer; const Value: Pointer);

Parameters

Index
Type: Integer

Value
Type: Pointer

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.SetName(Integer,String) Method

Summary

Represents method SetName(Integer,String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetName(Index: Integer; const Value: String);

Parameters

Index
Type: Integer

Value
Type: String

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.SetSetMethod(Integer,Pointer) Method

Summary

Represents method SetSetMethod(Integer,Pointer).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetSetMethod(Index: Integer; const Value: Pointer);

Parameters

Index
Type: Integer

Value
Type: Pointer

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList.SetTypInfo(Integer,Pointer) Method

Summary

Represents method SetTypInfo(Integer,Pointer).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetTypInfo(Index: Integer; const Value: Pointer);

Parameters

Index
Type: Integer

Value
Type: Pointer

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxExtPropList Fields

Fields
Name | Description
FPropInfos | Represents field FPropInfos.
Top


TfrxExtPropList.FPropInfos Field

Summary

Represents field FPropInfos.

Namespace: frxClass
Syntax
Delphi
published
 FPropInfos: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxExtPropList
  • frxClass


TfrxFillGaps Class

Summary

Encapsulate data for fill gaps. Band objects use it as a gap parameter for fill object.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxFillGaps
Syntax
Delphi
type
 TfrxFillGaps = class(TPersistent)
 end;

The TfrxFillGaps type exposes the following members.

Properties
Show:
Name | Description
Bottom | Bottom gap.
Left | Left gap.
Right | Right gap.
Top | Top gap.
Top
Fields
Show:
Name | Description
FBottom | Represents field FBottom.
FLeft | Represents field FLeft.
FRight | Represents field FRight.
FTop | Represents field FTop.
Top
See Also

Reference

  • frxClass


TfrxFillGaps Properties

Properties
Name | Description
Bottom | Bottom gap.
Left | Left gap.
Right | Right gap.
Top | Top gap.
Top


TfrxFillGaps.Bottom Property

Summary

Bottom gap.

Namespace: frxClass
Syntax
Delphi
published
 property Bottom: Integer read FBottom write FBottom;

Property Value

Type: Integer

See Also

Reference

  • TfrxFillGaps
  • frxClass


TfrxFillGaps.Left Property

Summary

Left gap.

Namespace: frxClass
Syntax
Delphi
published
 property Left: Integer read FLeft write FLeft;

Property Value

Type: Integer

See Also

Reference

  • TfrxFillGaps
  • frxClass


TfrxFillGaps.Right Property

Summary

Right gap.

Namespace: frxClass
Syntax
Delphi
published
 property Right: Integer read FRight write FRight;

Property Value

Type: Integer

See Also

Reference

  • TfrxFillGaps
  • frxClass


TfrxFillGaps.Top Property

Summary

Top gap.

Namespace: frxClass
Syntax
Delphi
published
 property Top: Integer read FTop write FTop;

Property Value

Type: Integer

See Also

Reference

  • TfrxFillGaps
  • frxClass


TfrxFillGaps Fields

Fields
Name | Description
FBottom | Represents field FBottom.
FLeft | Represents field FLeft.
FRight | Represents field FRight.
FTop | Represents field FTop.
Top


TfrxFillGaps.FBottom Field

Summary

Represents field FBottom.

Namespace: frxClass
Syntax
Delphi
private
 FBottom: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxFillGaps
  • frxClass


TfrxFillGaps.FLeft Field

Summary

Represents field FLeft.

Namespace: frxClass
Syntax
Delphi
private
 FLeft: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxFillGaps
  • frxClass


TfrxFillGaps.FRight Field

Summary

Represents field FRight.

Namespace: frxClass
Syntax
Delphi
private
 FRight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxFillGaps
  • frxClass


TfrxFillGaps.FTop Field

Summary

Represents field FTop.

Namespace: frxClass
Syntax
Delphi
private
 FTop: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxFillGaps
  • frxClass


TfrxFooter Class

Summary

The TfrxFooter class represents a "Footer" band. This kind of band is a footer for all data-bands.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxFooter
Syntax
Delphi
type
 TfrxFooter = class(TfrxBand)
 end;

The TfrxFooter type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Represents property KeepChild.
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point). (Inherited from TfrxBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Determines whether to form a new output page before printing this band. Default value is False. (Inherited from TfrxBand.)
Stretched | Represents property Stretched.
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxFooter Properties

Properties
Name | Description
AllowSplit | Represents property AllowSplit.
Child | Represents property Child.
KeepChild | Represents property KeepChild.
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
ShiftEngine | Represents property ShiftEngine.
Stretched | Represents property Stretched.
Top


TfrxFooter.AllowSplit Property

Summary

Represents property AllowSplit.

Namespace: frxClass
Syntax
Delphi
published
 property AllowSplit;

Property Value

Type: Void

See Also

Reference

  • TfrxFooter
  • frxClass


TfrxFooter.Child Property

Summary

Represents property Child.

Namespace: frxClass
Syntax
Delphi
published
 property Child;

Property Value

Type: Void

See Also

Reference

  • TfrxFooter
  • frxClass


TfrxFooter.KeepChild Property

Summary

Represents property KeepChild.

Namespace: frxClass
Syntax
Delphi
published
 property KeepChild;

Property Value

Type: Void

See Also

Reference

  • TfrxFooter
  • frxClass


TfrxFooter.PrintChildIfInvisible Property

Summary

Represents property PrintChildIfInvisible.

Namespace: frxClass
Syntax
Delphi
published
 property PrintChildIfInvisible;

Property Value

Type: Void

See Also

Reference

  • TfrxFooter
  • frxClass


TfrxFooter.ShiftEngine Property

Summary

Represents property ShiftEngine.

Namespace: frxClass
Syntax
Delphi
published
 property ShiftEngine;

Property Value

Type: Void

See Also

Reference

  • TfrxFooter
  • frxClass


TfrxFooter.Stretched Property

Summary

Represents property Stretched.

Namespace: frxClass
Syntax
Delphi
published
 property Stretched;

Property Value

Type: Void

See Also

Reference

  • TfrxFooter
  • frxClass


TfrxFormat Class

Summary

The constructor. Do not call it directly because an instance of this class is stored in the TfrxCustomMemoView.DisplayFormat.

Namespace: frxClass
Inheritance Hierarchy
TCollectionItem
frxClass.TfrxFormat
Syntax
Delphi
type
 TfrxFormat = class(TCollectionItem)
 end;

The TfrxFormat type exposes the following members.

Properties
Show:
Name Description
DecimalSeparator

Decimal separator symbol. This symbol is used when the Kind property is set to fkNumeric. If this property is empty, default separator is used.

FormatStr

Formatting string in every case is an argument for the function, with the help of which formatting is accomplished. Thus, for numerical formatting, such function would be the Delphi's Format function, for date/time it is the FormatDateTime function. One can get the possible values from the Delphi help system. Below are several values used in FastReport:
for the numerical formatting:
%g - a number with the minimal signs number after decimal point;
%2.2f - a number with the fixed number of signs after decimal point;
%2.2n - a number with bits delimiter;
%2.2m - a monetary format, accepted in the Windows OS, depending on the regional settings in the control panel.
for the date/time format:
dd.mm.yyyy - date of the 23.12.2003 type;
dd mmm yyyy - date of the 23 Nov. 2003 type;
dd mmmm yyyy - date of the 23 November 2003 type;
hh:mm - time of the 23:12 type;
hh:mm:ss - time of the 23:12:00 type;
dd mmmm yyyy, hh:mm - time and date of the 23 November 2003, 23:12 type.
As for formatting of the boolean type, the formatting string is presented as two values separated by comma. The first value corresponds to "False," the second one corresponds to "True".

Kind

Kind of formatting.

ThousandSeparator

Thousand separator symbol. It is used when numbers formatting (Kind property =fk Numeric).

Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
Fields
Show:
Name | Description
FDecimalSeparator | Represents field FDecimalSeparator.
FFormatStr | Represents field FFormatStr.
FKind | Represents field FKind.
FThousandSeparator | Represents field FThousandSeparator.
Top
See Also

Reference

  • frxClass


TfrxFormat Properties

Properties
Name Description
DecimalSeparator

Decimal separator symbol. This symbol is used when the Kind property is set to fkNumeric. If this property is empty, default separator is used.

FormatStr

Formatting string in every case is an argument for the function, with the help of which formatting is accomplished. Thus, for numerical formatting, such function would be the Delphi's Format function, for date/time it is the FormatDateTime function. One can get the possible values from the Delphi help system. Below are several values used in FastReport:
for the numerical formatting:
%g - a number with the minimal signs number after decimal point;
%2.2f - a number with the fixed number of signs after decimal point;
%2.2n - a number with bits delimiter;
%2.2m - a monetary format, accepted in the Windows OS, depending on the regional settings in the control panel.
for the date/time format:
dd.mm.yyyy - date of the 23.12.2003 type;
dd mmm yyyy - date of the 23 Nov. 2003 type;
dd mmmm yyyy - date of the 23 November 2003 type;
hh:mm - time of the 23:12 type;
hh:mm:ss - time of the 23:12:00 type;
dd mmmm yyyy, hh:mm - time and date of the 23 November 2003, 23:12 type.
As for formatting of the boolean type, the formatting string is presented as two values separated by comma. The first value corresponds to "False," the second one corresponds to "True".

Kind

Kind of formatting.

ThousandSeparator

Thousand separator symbol. It is used when numbers formatting (Kind property =fk Numeric).

Top


TfrxFormat.DecimalSeparator Property

Summary

Decimal separator symbol. This symbol is used when the Kind property is set to fkNumeric. If this property is empty, default separator is used.

Namespace: frxClass
Syntax
Delphi
published
 property DecimalSeparator: String read FDecimalSeparator write FDecimalSeparator;

Property Value

Type: String

See Also

Reference

  • TfrxFormat
  • frxClass


TfrxFormat.FormatStr Property

Summary

Formatting string in every case is an argument for the function, with the help of which formatting is accomplished. Thus, for numerical formatting, such function would be the Delphi's Format function, for date/time it is the FormatDateTime function. One can get the possible values from the Delphi help system. Below are several values used in FastReport:
for the numerical formatting:
%g - a number with the minimal signs number after decimal point;
%2.2f - a number with the fixed number of signs after decimal point;
%2.2n - a number with bits delimiter;
%2.2m - a monetary format, accepted in the Windows OS, depending on the regional settings in the control panel.
for the date/time format:
dd.mm.yyyy - date of the 23.12.2003 type;
dd mmm yyyy - date of the 23 Nov. 2003 type;
dd mmmm yyyy - date of the 23 November 2003 type;
hh:mm - time of the 23:12 type;
hh:mm:ss - time of the 23:12:00 type;
dd mmmm yyyy, hh:mm - time and date of the 23 November 2003, 23:12 type.
As for formatting of the boolean type, the formatting string is presented as two values separated by comma. The first value corresponds to "False," the second one corresponds to "True".

Namespace: frxClass
Syntax
Delphi
published
 property FormatStr: String read FFormatStr write FFormatStr;

Property Value

Type: String

See Also

Reference

  • TfrxFormat
  • frxClass


TfrxFormat.Kind Property

Summary

Kind of formatting.

Namespace: frxClass
Syntax
Delphi
published
 property Kind: TfrxFormatKind read FKind write FKind default fkText;

Property Value

Type: TfrxFormatKind

See Also

Reference

  • TfrxFormat
  • frxClass


TfrxFormat.ThousandSeparator Property

Summary

Thousand separator symbol. It is used when numbers formatting (Kind property =fk Numeric).

Namespace: frxClass
Syntax
Delphi
published
 property ThousandSeparator: String read FThousandSeparator write FThousandSeparator;

Property Value

Type: String

See Also

Reference

  • TfrxFormat
  • frxClass


TfrxFormat Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TfrxFormat.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxFormat
  • frxClass


TfrxFormat Fields

Fields
Name | Description
FDecimalSeparator | Represents field FDecimalSeparator.
FFormatStr | Represents field FFormatStr.
FKind | Represents field FKind.
FThousandSeparator | Represents field FThousandSeparator.
Top


TfrxFormat.FDecimalSeparator Field

Summary

Represents field FDecimalSeparator.

Namespace: frxClass
Syntax
Delphi
private
 FDecimalSeparator: String;

Field Value

Type: String

See Also

Reference

  • TfrxFormat
  • frxClass


TfrxFormat.FFormatStr Field

Summary

Represents field FFormatStr.

Namespace: frxClass
Syntax
Delphi
private
 FFormatStr: String;

Field Value

Type: String

See Also

Reference

  • TfrxFormat
  • frxClass


TfrxFormat.FKind Field

Summary

Represents field FKind.

Namespace: frxClass
Syntax
Delphi
private
 FKind: TfrxFormatKind;

Field Value

Type: TfrxFormatKind

See Also

Reference

  • TfrxFormat
  • frxClass


TfrxFormat.FThousandSeparator Field

Summary

Represents field FThousandSeparator.

Namespace: frxClass
Syntax
Delphi
private
 FThousandSeparator: String;

Field Value

Type: String

See Also

Reference

  • TfrxFormat
  • frxClass


TfrxFormatCollection Class

Summary

Collection of TfrxFormat. An object can hold several
formats which serves different expressions.

Namespace: frxClass
Inheritance Hierarchy
TCollection
frxClass.TfrxFormatCollection
Syntax
Delphi
type
 TfrxFormatCollection = class(TCollection)
 end;

The TfrxFormatCollection type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxFormatCollection class.
Top
Properties
Show:
Name | Description
Items[Integer] | Format items array.
Top
Methods
Show:
Name | Description
GetItem(Integer) | Represents method GetItem(Integer).
Top
See Also

Reference

  • frxClass


TfrxFormatCollection Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxFormatCollection class.
Top


TfrxFormatCollection.Create Constructor

Summary

Initializes a new instance of the TfrxFormatCollection class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxFormatCollection
  • frxClass


TfrxFormatCollection Properties

Properties
Name | Description
Items[Integer] | Format items array.
Top


TfrxFormatCollection.Items[Integer] Property

Summary

Format items array.

Namespace: frxClass
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxFormat read GetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxFormat

See Also

Reference

  • TfrxFormatCollection
  • frxClass


TfrxFormatCollection Methods

Methods
Name | Description
GetItem(Integer) | Represents method GetItem(Integer).
Top


TfrxFormatCollection.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetItem(Index: Integer): TfrxFormat;

Parameters

Index
Type: Integer

Return Value

Type: TfrxFormat

See Also

Reference

  • TfrxFormatCollection
  • frxClass


TfrxFR2Events Class

Summary

Represents type TfrxFR2Events.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxFR2Events
Syntax
Delphi
type
 TfrxFR2Events = class(TObject)
 end;

The TfrxFR2Events type exposes the following members.

Properties
Show:
Name | Description
Filter | Represents property Filter.
OnPrepareScript | Represents property OnPrepareScript.
Top
Events
Show:
Name | Description
OnGetScriptValue | Represents property OnGetScriptValue.
OnGetValue | Represents property OnGetValue.
OnLoad | Represents property OnLoad.
Top
Fields
Show:
Name | Description
FFilter | Represents field FFilter.
FOnGetScriptValue | Represents field FOnGetScriptValue.
FOnGetValue | Represents field FOnGetValue.
FOnLoad | Represents field FOnLoad.
FOnPrepareScript | Represents field FOnPrepareScript.
Top
See Also

Reference

  • frxClass


TfrxFR2Events Properties

Properties
Name | Description
Filter | Represents property Filter.
OnPrepareScript | Represents property OnPrepareScript.
Top


TfrxFR2Events.Filter Property

Summary

Represents property Filter.

Namespace: frxClass
Syntax
Delphi
public
 property Filter: String read FFilter write FFilter;

Property Value

Type: String

See Also

Reference

  • TfrxFR2Events
  • frxClass


TfrxFR2Events.OnPrepareScript Property

Summary

Represents property OnPrepareScript.

Namespace: frxClass
Syntax
Delphi
public
 property OnPrepareScript: TNotifyEvent read FOnPrepareScript write FOnPrepareScript;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxFR2Events
  • frxClass


TfrxFR2Events Events

Events
Name | Description
OnGetScriptValue | Represents property OnGetScriptValue.
OnGetValue | Represents property OnGetValue.
OnLoad | Represents property OnLoad.
Top


TfrxFR2Events.OnGetScriptValue Event

Summary

Represents property OnGetScriptValue.

Namespace: frxClass
Syntax
Delphi
public
 property OnGetScriptValue: TfrxGetScriptValueEvent read FOnGetScriptValue write FOnGetScriptValue;

Value

Type: TfrxGetScriptValueEvent

See Also

Reference

  • TfrxFR2Events
  • frxClass


TfrxFR2Events.OnGetValue Event

Summary

Represents property OnGetValue.

Namespace: frxClass
Syntax
Delphi
public
 property OnGetValue: TfrxGetValueEvent read FOnGetValue write FOnGetValue;

Value

Type: TfrxGetValueEvent

See Also

Reference

  • TfrxFR2Events
  • frxClass


TfrxFR2Events.OnLoad Event

Summary

Represents property OnLoad.

Namespace: frxClass
Syntax
Delphi
public
 property OnLoad: TfrxLoadEvent read FOnLoad write FOnLoad;

Value

Type: TfrxLoadEvent

See Also

Reference

  • TfrxFR2Events
  • frxClass


TfrxFR2Events Fields

Fields
Name | Description
FFilter | Represents field FFilter.
FOnGetScriptValue | Represents field FOnGetScriptValue.
FOnGetValue | Represents field FOnGetValue.
FOnLoad | Represents field FOnLoad.
FOnPrepareScript | Represents field FOnPrepareScript.
Top


TfrxFR2Events.FFilter Field

Summary

Represents field FFilter.

Namespace: frxClass
Syntax
Delphi
private
 FFilter: String;

Field Value

Type: String

See Also

Reference

  • TfrxFR2Events
  • frxClass


TfrxFR2Events.FOnGetScriptValue Field

Summary

Represents field FOnGetScriptValue.

Namespace: frxClass
Syntax
Delphi
private
 FOnGetScriptValue: TfrxGetScriptValueEvent;

Field Value

Type: TfrxGetScriptValueEvent

See Also

Reference

  • TfrxFR2Events
  • frxClass


TfrxFR2Events.FOnGetValue Field

Summary

Represents field FOnGetValue.

Namespace: frxClass
Syntax
Delphi
private
 FOnGetValue: TfrxGetValueEvent;

Field Value

Type: TfrxGetValueEvent

See Also

Reference

  • TfrxFR2Events
  • frxClass


TfrxFR2Events.FOnLoad Field

Summary

Represents field FOnLoad.

Namespace: frxClass
Syntax
Delphi
private
 FOnLoad: TfrxLoadEvent;

Field Value

Type: TfrxLoadEvent

See Also

Reference

  • TfrxFR2Events
  • frxClass


TfrxFR2Events.FOnPrepareScript Field

Summary

Represents field FOnPrepareScript.

Namespace: frxClass
Syntax
Delphi
private
 FOnPrepareScript: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxFR2Events
  • frxClass


TfrxFrame Class

Summary

The TfrxFrame class represents a frame. Almost all Frx visual objects have a frame.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxFrame
Syntax
Delphi
type
 TfrxFrame = class(TPersistent)
 end;

The TfrxFrame type exposes the following members.

Constructors
Show:
Name | Description
Create | Constructor.
Destroy | Represents the destructor of the TfrxFrame class.
Top
Properties
Show:
Name | Description
BottomLine | Bottom line of the frame.
Color | Color of frame.
DropShadow | Determines whether to draw a shadow.
LeftLine | Left line of the frame.
RightLine | Right line of the frame.
ShadowColor | Color of shadow.
ShadowWidth | Width of shadow.
Style | Style of frame.
TopLine | Top line of the frame.
Typ | Set of frame lines.
Width | Width of frame.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Assigns properties from other frame object.
Diff(TfrxFrame) | Returns XML string with serialized comparison of stored data between two objects( Self and AFrame).
Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) | Draws frame on a Canvas.
IsShadowWidthStored | Represents method IsShadowWidthStored.
IsTypStored | Represents method IsTypStored.
IsWidthStored | Represents method IsWidthStored.
SetBottomLine(TfrxFrameLine) | Represents method SetBottomLine(TfrxFrameLine).
SetColor(TColor) | Represents method SetColor(TColor).
SetLeftLine(TfrxFrameLine) | Represents method SetLeftLine(TfrxFrameLine).
SetRightLine(TfrxFrameLine) | Represents method SetRightLine(TfrxFrameLine).
SetStyle(TfrxFrameStyle) | Represents method SetStyle(TfrxFrameStyle).
SetTopLine(TfrxFrameLine) | Represents method SetTopLine(TfrxFrameLine).
SetWidth(Extended) | Represents method SetWidth(Extended).
Top
Fields
Show:
Name | Description
FBottomLine | Represents field FBottomLine.
FColor | Represents field FColor.
FDropShadow | Represents field FDropShadow.
FLeftLine | Represents field FLeftLine.
FRightLine | Represents field FRightLine.
FShadowColor | Represents field FShadowColor.
FShadowWidth | Represents field FShadowWidth.
FStyle | Represents field FStyle.
FTopLine | Represents field FTopLine.
FTyp | Represents field FTyp.
FWidth | Represents field FWidth.
Top
See Also

Reference

  • frxClass


TfrxFrame Constructors

Constructors
Name | Description
Create | Constructor.
Destroy | Represents the destructor of the TfrxFrame class.
Top


TfrxFrame.Create Constructor

Summary

Constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.Destroy Destructor

Summary

Represents the destructor of the TfrxFrame class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame Properties

Properties
Name | Description
BottomLine | Bottom line of the frame.
Color | Color of frame.
DropShadow | Determines whether to draw a shadow.
LeftLine | Left line of the frame.
RightLine | Right line of the frame.
ShadowColor | Color of shadow.
ShadowWidth | Width of shadow.
Style | Style of frame.
TopLine | Top line of the frame.
Typ | Set of frame lines.
Width | Width of frame.
Top


TfrxFrame.BottomLine Property

Summary

Bottom line of the frame.

Namespace: frxClass
Syntax
Delphi
published
 property BottomLine: TfrxFrameLine read FBottomLine write SetBottomLine;

Property Value

Type: TfrxFrameLine

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.Color Property

Summary

Color of frame.

Namespace: frxClass
Syntax
Delphi
published
 property Color: TColor read FColor write SetColor default clBlack;

Property Value

Type: TColor

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.DropShadow Property

Summary

Determines whether to draw a shadow.

Namespace: frxClass
Syntax
Delphi
published
 property DropShadow: Boolean read FDropShadow write FDropShadow default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.LeftLine Property

Summary

Left line of the frame.

Namespace: frxClass
Syntax
Delphi
published
 property LeftLine: TfrxFrameLine read FLeftLine write SetLeftLine;

Property Value

Type: TfrxFrameLine

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.RightLine Property

Summary

Right line of the frame.

Namespace: frxClass
Syntax
Delphi
published
 property RightLine: TfrxFrameLine read FRightLine write SetRightLine;

Property Value

Type: TfrxFrameLine

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.ShadowColor Property

Summary

Color of shadow.

Namespace: frxClass
Syntax
Delphi
published
 property ShadowColor: TColor read FShadowColor write FShadowColor default clBlack;

Property Value

Type: TColor

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.ShadowWidth Property

Summary

Width of shadow.

Namespace: frxClass
Syntax
Delphi
published
 property ShadowWidth: Extended read FShadowWidth write FShadowWidth stored IsShadowWidthStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.Style Property

Summary

Style of frame.

Namespace: frxClass
Syntax
Delphi
published
 property Style: TfrxFrameStyle read FStyle write SetStyle default fsSolid;

Property Value

Type: TfrxFrameStyle

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.TopLine Property

Summary

Top line of the frame.

Namespace: frxClass
Syntax
Delphi
published
 property TopLine: TfrxFrameLine read FTopLine write SetTopLine;

Property Value

Type: TfrxFrameLine

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.Typ Property

Summary

Set of frame lines.

Namespace: frxClass
Syntax
Delphi
published
 property Typ: TfrxFrameTypes read FTyp write FTyp stored IsTypStored;

Property Value

Type: TfrxFrameTypes

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.Width Property

Summary

Width of frame.

Namespace: frxClass
Syntax
Delphi
published
 property Width: Extended read FWidth write SetWidth stored IsWidthStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame Methods

Methods
Name | Description
Assign(TPersistent) | Assigns properties from other frame object.
Diff(TfrxFrame) | Returns XML string with serialized comparison of stored data between two objects( Self and AFrame).
Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) | Draws frame on a Canvas.
IsShadowWidthStored | Represents method IsShadowWidthStored.
IsTypStored | Represents method IsTypStored.
IsWidthStored | Represents method IsWidthStored.
SetBottomLine(TfrxFrameLine) | Represents method SetBottomLine(TfrxFrameLine).
SetColor(TColor) | Represents method SetColor(TColor).
SetLeftLine(TfrxFrameLine) | Represents method SetLeftLine(TfrxFrameLine).
SetRightLine(TfrxFrameLine) | Represents method SetRightLine(TfrxFrameLine).
SetStyle(TfrxFrameStyle) | Represents method SetStyle(TfrxFrameStyle).
SetTopLine(TfrxFrameLine) | Represents method SetTopLine(TfrxFrameLine).
SetWidth(Extended) | Represents method SetWidth(Extended).
Top


TfrxFrame.Assign(TPersistent) Method

Summary

Assigns properties from other frame object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.Diff(TfrxFrame) Method

Summary

Returns XML string with serialized comparison of stored data between two objects( Self and AFrame).

Namespace: frxClass
Syntax
Delphi
public
 function Diff(AFrame: TfrxFrame): String;

Parameters

AFrame
Type: TfrxFrame

Return Value

Type: String

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) Method

Summary

Draws frame on a Canvas.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; FX, FY, FX1, FY1: Integer; ScaleX, ScaleY: Extended);

Parameters

Canvas
Type: TCanvas

Source canvas.

FX
Type: Integer

X start coordinate.

FY
Type: Integer

Y start coordinate.

FX1
Type: Integer

X end coordinate.

FY1
Type: Integer

Y end coordinate.

ScaleX
Type: Extended

X scale factor.

ScaleY
Type: Extended

Y scale factor.

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.IsShadowWidthStored Method

Summary

Represents method IsShadowWidthStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsShadowWidthStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.IsTypStored Method

Summary

Represents method IsTypStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsTypStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.IsWidthStored Method

Summary

Represents method IsWidthStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsWidthStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.SetBottomLine(TfrxFrameLine) Method

Summary

Represents method SetBottomLine(TfrxFrameLine).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetBottomLine(const Value: TfrxFrameLine);

Parameters

Value
Type: TfrxFrameLine

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.SetLeftLine(TfrxFrameLine) Method

Summary

Represents method SetLeftLine(TfrxFrameLine).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetLeftLine(const Value: TfrxFrameLine);

Parameters

Value
Type: TfrxFrameLine

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.SetRightLine(TfrxFrameLine) Method

Summary

Represents method SetRightLine(TfrxFrameLine).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetRightLine(const Value: TfrxFrameLine);

Parameters

Value
Type: TfrxFrameLine

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.SetStyle(TfrxFrameStyle) Method

Summary

Represents method SetStyle(TfrxFrameStyle).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetStyle(const Value: TfrxFrameStyle);

Parameters

Value
Type: TfrxFrameStyle

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.SetTopLine(TfrxFrameLine) Method

Summary

Represents method SetTopLine(TfrxFrameLine).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetTopLine(const Value: TfrxFrameLine);

Parameters

Value
Type: TfrxFrameLine

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.SetWidth(Extended) Method

Summary

Represents method SetWidth(Extended).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetWidth(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame Fields

Fields
Name | Description
FBottomLine | Represents field FBottomLine.
FColor | Represents field FColor.
FDropShadow | Represents field FDropShadow.
FLeftLine | Represents field FLeftLine.
FRightLine | Represents field FRightLine.
FShadowColor | Represents field FShadowColor.
FShadowWidth | Represents field FShadowWidth.
FStyle | Represents field FStyle.
FTopLine | Represents field FTopLine.
FTyp | Represents field FTyp.
FWidth | Represents field FWidth.
Top


TfrxFrame.FBottomLine Field

Summary

Represents field FBottomLine.

Namespace: frxClass
Syntax
Delphi
private
 FBottomLine: TfrxFrameLine;

Field Value

Type: TfrxFrameLine

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.FColor Field

Summary

Represents field FColor.

Namespace: frxClass
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.FDropShadow Field

Summary

Represents field FDropShadow.

Namespace: frxClass
Syntax
Delphi
private
 FDropShadow: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.FLeftLine Field

Summary

Represents field FLeftLine.

Namespace: frxClass
Syntax
Delphi
private
 FLeftLine: TfrxFrameLine;

Field Value

Type: TfrxFrameLine

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.FRightLine Field

Summary

Represents field FRightLine.

Namespace: frxClass
Syntax
Delphi
private
 FRightLine: TfrxFrameLine;

Field Value

Type: TfrxFrameLine

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.FShadowColor Field

Summary

Represents field FShadowColor.

Namespace: frxClass
Syntax
Delphi
private
 FShadowColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.FShadowWidth Field

Summary

Represents field FShadowWidth.

Namespace: frxClass
Syntax
Delphi
private
 FShadowWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.FStyle Field

Summary

Represents field FStyle.

Namespace: frxClass
Syntax
Delphi
private
 FStyle: TfrxFrameStyle;

Field Value

Type: TfrxFrameStyle

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.FTopLine Field

Summary

Represents field FTopLine.

Namespace: frxClass
Syntax
Delphi
private
 FTopLine: TfrxFrameLine;

Field Value

Type: TfrxFrameLine

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.FTyp Field

Summary

Represents field FTyp.

Namespace: frxClass
Syntax
Delphi
private
 FTyp: TfrxFrameTypes;

Field Value

Type: TfrxFrameTypes

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrame.FWidth Field

Summary

Represents field FWidth.

Namespace: frxClass
Syntax
Delphi
private
 FWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxFrame
  • frxClass


TfrxFrameLine Class

Summary

The TfrxFrameLine class represents the parameters of one line of the frame.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxFrameLine
Syntax
Delphi
type
 TfrxFrameLine = class(TPersistent)
 end;

The TfrxFrameLine type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxFrame) | Initializes a new instance of the TfrxFrameLine class.
Top
Properties
Show:
Name | Description
Color | Color of the line.
Style | Style of the line.
Width | Width of the line.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Diff(TfrxFrameLine,String,Boolean,Boolean,Boolean) | Returns XML string with serialized comparison of stored data between two objects( Self and ALine).
IsColorStored | Represents method IsColorStored.
IsStyleStored | Represents method IsStyleStored.
IsWidthStored | Represents method IsWidthStored.
Top
Fields
Show:
Name | Description
FColor | Represents field FColor.
FFrame | Represents field FFrame.
FStyle | Represents field FStyle.
FWidth | Represents field FWidth.
Top
See Also

Reference

  • frxClass


TfrxFrameLine Constructors

Constructors
Name | Description
Create(TfrxFrame) | Initializes a new instance of the TfrxFrameLine class.
Top


TfrxFrameLine.Create(TfrxFrame) Constructor

Summary

Initializes a new instance of the TfrxFrameLine class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AFrame: TfrxFrame);

Parameters

AFrame
Type: TfrxFrame

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxFrameLine Properties

Properties
Name | Description
Color | Color of the line.
Style | Style of the line.
Width | Width of the line.
Top


TfrxFrameLine.Color Property

Summary

Color of the line.

Namespace: frxClass
Syntax
Delphi
published
 property Color: TColor read FColor write FColor stored IsColorStored;

Property Value

Type: TColor

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxFrameLine.Style Property

Summary

Style of the line.

Namespace: frxClass
Syntax
Delphi
published
 property Style: TfrxFrameStyle read FStyle write FStyle stored IsStyleStored;

Property Value

Type: TfrxFrameStyle

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxFrameLine.Width Property

Summary

Width of the line.

Namespace: frxClass
Syntax
Delphi
published
 property Width: Extended read FWidth write FWidth stored IsWidthStored;

Property Value

Type: Extended

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxFrameLine Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Diff(TfrxFrameLine,String,Boolean,Boolean,Boolean) | Returns XML string with serialized comparison of stored data between two objects( Self and ALine).
IsColorStored | Represents method IsColorStored.
IsStyleStored | Represents method IsStyleStored.
IsWidthStored | Represents method IsWidthStored.
Top


TfrxFrameLine.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxFrameLine.Diff(TfrxFrameLine,String,Boolean,Boolean,Boolean) Method

Summary

Returns XML string with serialized comparison of stored data between two objects( Self and ALine).

Namespace: frxClass
Syntax
Delphi
public
 function Diff(ALine: TfrxFrameLine; const LineName: String;
 ColorChanged, StyleChanged, WidthChanged: Boolean): String;

Parameters

ALine
Type: TfrxFrameLine

LineName
Type: String

ColorChanged
Type: Boolean

StyleChanged
Type: Boolean

WidthChanged
Type: Boolean

Return Value

Type: String

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxFrameLine.IsColorStored Method

Summary

Represents method IsColorStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsColorStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxFrameLine.IsStyleStored Method

Summary

Represents method IsStyleStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsStyleStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxFrameLine.IsWidthStored Method

Summary

Represents method IsWidthStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsWidthStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxFrameLine Fields

Fields
Name | Description
FColor | Represents field FColor.
FFrame | Represents field FFrame.
FStyle | Represents field FStyle.
FWidth | Represents field FWidth.
Top


TfrxFrameLine.FColor Field

Summary

Represents field FColor.

Namespace: frxClass
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxFrameLine.FFrame Field

Summary

Represents field FFrame.

Namespace: frxClass
Syntax
Delphi
private
 FFrame: TfrxFrame;

Field Value

Type: TfrxFrame

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxFrameLine.FStyle Field

Summary

Represents field FStyle.

Namespace: frxClass
Syntax
Delphi
private
 FStyle: TfrxFrameStyle;

Field Value

Type: TfrxFrameStyle

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxFrameLine.FWidth Field

Summary

Represents field FWidth.

Namespace: frxClass
Syntax
Delphi
private
 FWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxFrameLine
  • frxClass


TfrxGlassFill Class

Summary

Represents type TfrxGlassFill.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxCustomFill
frxClass.TfrxGlassFill
Syntax
Delphi
type
 TfrxGlassFill = class(TfrxCustomFill)
 end;

The TfrxGlassFill type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxGlassFill class.
Top
Properties
Show:
Name | Description
Blend | Blend value used in calculation of blend color. Value lays between 0.0 and 1.0. Highest value means more contrast.
Color | Base color.
Hatch | Draws hatch lines.
Orientation | Orientation type of glass fill.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
BlendColor | Represents method BlendColor.
Diff(TfrxCustomFill,String) | Returns XML string with serialized comparison of stored data between two objects( Self and AFill). (Overrides TfrxCustomFill.Diff(TfrxCustomFill,String).)
Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) | Draw fill on a canvas. (Overrides TfrxCustomFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended).)
GetColor | Represents method GetColor.
HatchColor | Represents method HatchColor.
Top
Fields
Show:
Name | Description
FBlend | Represents field FBlend.
FColor | Represents field FColor.
FHatch | Represents field FHatch.
FOrient | Represents field FOrient.
Top
See Also

Reference

  • frxClass


TfrxGlassFill Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxGlassFill class.
Top


TfrxGlassFill.Create Constructor

Summary

Initializes a new instance of the TfrxGlassFill class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill Properties

Properties
Name | Description
Blend | Blend value used in calculation of blend color. Value lays between 0.0 and 1.0. Highest value means more contrast.
Color | Base color.
Hatch | Draws hatch lines.
Orientation | Orientation type of glass fill.
Top


TfrxGlassFill.Blend Property

Summary

Blend value used in calculation of blend color. Value lays between 0.0 and 1.0. Highest value means more contrast.

Namespace: frxClass
Syntax
Delphi
published
 property Blend: Extended read FBlend write FBlend;

Property Value

Type: Extended

See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill.Color Property

Summary

Base color.

Namespace: frxClass
Syntax
Delphi
published
 property Color: TColor read FColor write FColor default clWhite;

Property Value

Type: TColor

See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill.Hatch Property

Summary

Draws hatch lines.

Namespace: frxClass
Syntax
Delphi
published
 property Hatch: Boolean read FHatch write FHatch default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill.Orientation Property

Summary

Orientation type of glass fill.

Namespace: frxClass
Syntax
Delphi
published
 property Orientation: TfrxGlassFillOrientation read FOrient write FOrient default foHorizontal;

Property Value

Type: TfrxGlassFillOrientation

See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
BlendColor | Represents method BlendColor.
Diff(TfrxCustomFill,String) | Returns XML string with serialized comparison of stored data between two objects( Self and AFill). (Overrides TfrxCustomFill.Diff(TfrxCustomFill,String).)
Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) | Draw fill on a canvas. (Overrides TfrxCustomFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended).)
GetColor | Represents method GetColor.
HatchColor | Represents method HatchColor.
Top


TfrxGlassFill.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill.BlendColor Method

Summary

Represents method BlendColor.

Namespace: frxClass
Syntax
Delphi
public
 function BlendColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill.Diff(TfrxCustomFill,String) Method

Summary

Returns XML string with serialized comparison of stored data between two objects( Self and AFill).

Namespace: frxClass
Syntax
Delphi
public
 function Diff(AFill: TfrxCustomFill; const Add: String): String; override;

Parameters

AFill
Type: TfrxCustomFill

Add
Type: String

Return Value

Type: String

Overrides

TfrxCustomFill.Diff(TfrxCustomFill,String)
See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) Method

Summary

Draw fill on a canvas.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(ACanvas: TCanvas; X, Y, X1, Y1: Integer; ScaleX, ScaleY: Extended); override;

Parameters

ACanvas
Type: TCanvas

Source canvas.

X
Type: Integer

Start X coordinate of draw area.

Y
Type: Integer

Start Y coordinate of draw area.

X1
Type: Integer

End X coordinate of draw area.

Y1
Type: Integer

End Y coordinate of draw area.

ScaleX
Type: Extended

X scale factor.

ScaleY
Type: Extended

Y scale factor.

Overrides

TfrxCustomFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended)
See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill.GetColor Method

Summary

Represents method GetColor.

Namespace: frxClass
Syntax
Delphi
public
 function GetColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill.HatchColor Method

Summary

Represents method HatchColor.

Namespace: frxClass
Syntax
Delphi
public
 function HatchColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill Fields

Fields
Name | Description
FBlend | Represents field FBlend.
FColor | Represents field FColor.
FHatch | Represents field FHatch.
FOrient | Represents field FOrient.
Top


TfrxGlassFill.FBlend Field

Summary

Represents field FBlend.

Namespace: frxClass
Syntax
Delphi
private
 FBlend: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill.FColor Field

Summary

Represents field FColor.

Namespace: frxClass
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill.FHatch Field

Summary

Represents field FHatch.

Namespace: frxClass
Syntax
Delphi
private
 FHatch: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlassFill.FOrient Field

Summary

Represents field FOrient.

Namespace: frxClass
Syntax
Delphi
private
 FOrient: TfrxGlassFillOrientation;

Field Value

Type: TfrxGlassFillOrientation

See Also

Reference

  • TfrxGlassFill
  • frxClass


TfrxGlobalDataSetList Class

Summary

This class represents global list of datasets. Every ancestor of TfrxDataSet registers in this list during construction and removes when destroy.

Namespace: frxClass
Inheritance Hierarchy
TList
frxClass.TfrxGlobalDataSetList
Syntax
Delphi
type
 TfrxGlobalDataSetList = class(TList)
 end;

The TfrxGlobalDataSetList type exposes the following members.

Constructors
Show:
Name | Description
Create | Default constructor.
Destroy | Represents the destructor of the TfrxGlobalDataSetList class.
Top
Methods
Show:
Name | Description
Lock | Enters in critical section.
Unlock | Leaves critical section.
Top
Fields
Show:
Name | Description
FCriticalSection | Represents field FCriticalSection.
Top
See Also

Reference

  • frxClass


TfrxGlobalDataSetList Constructors

Constructors
Name | Description
Create | Default constructor.
Destroy | Represents the destructor of the TfrxGlobalDataSetList class.
Top


TfrxGlobalDataSetList.Create Constructor

Summary

Default constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxGlobalDataSetList
  • frxClass


TfrxGlobalDataSetList.Destroy Destructor

Summary

Represents the destructor of the TfrxGlobalDataSetList class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxGlobalDataSetList
  • frxClass


TfrxGlobalDataSetList Methods

Methods
Name | Description
Lock | Enters in critical section.
Unlock | Leaves critical section.
Top


TfrxGlobalDataSetList.Lock Method

Summary

Enters in critical section.

Namespace: frxClass
Syntax
Delphi
public
 procedure Lock;
See Also

Reference

  • TfrxGlobalDataSetList
  • frxClass


TfrxGlobalDataSetList.Unlock Method

Summary

Leaves critical section.

Namespace: frxClass
Syntax
Delphi
public
 procedure Unlock;
See Also

Reference

  • TfrxGlobalDataSetList
  • frxClass


TfrxGlobalDataSetList Fields

Fields
Name | Description
FCriticalSection | Represents field FCriticalSection.
Top


TfrxGlobalDataSetList.FCriticalSection Field

Summary

Represents field FCriticalSection.

Namespace: frxClass
Syntax
Delphi
published
 FCriticalSection: TCriticalSection;

Field Value

Type: TCriticalSection

See Also

Reference

  • TfrxGlobalDataSetList
  • frxClass


TfrxGradientFill Class

Summary

Represents standard gradient fill class for all report objects.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxCustomFill
frxClass.TfrxGradientFill
Syntax
Delphi
type
 TfrxGradientFill = class(TfrxCustomFill)
 end;

The TfrxGradientFill type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxGradientFill class.
Top
Properties
Show:
Name | Description
EndColor | End color of the gradient.
GradientStyle | Style of the gradient fill.
StartColor | Begin color of the gradient.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Diff(TfrxCustomFill,String) | Returns XML string with serialized comparison of stored data between two objects( Self and AFill). (Overrides TfrxCustomFill.Diff(TfrxCustomFill,String).)
Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) | Draw fill on a canvas. (Overrides TfrxCustomFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended).)
GetColor | Represents method GetColor.
Top
Fields
Show:
Name | Description
FEndColor | Represents field FEndColor.
FGradientStyle | Represents field FGradientStyle.
FStartColor | Represents field FStartColor.
Top
See Also

Reference

  • frxClass


TfrxGradientFill Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxGradientFill class.
Top


TfrxGradientFill.Create Constructor

Summary

Initializes a new instance of the TfrxGradientFill class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxGradientFill
  • frxClass


TfrxGradientFill Properties

Properties
Name | Description
EndColor | End color of the gradient.
GradientStyle | Style of the gradient fill.
StartColor | Begin color of the gradient.
Top


TfrxGradientFill.EndColor Property

Summary

End color of the gradient.

Namespace: frxClass
Syntax
Delphi
published
 property EndColor: TColor read FEndColor write FEndColor default clBlack;

Property Value

Type: TColor

See Also

Reference

  • TfrxGradientFill
  • frxClass


TfrxGradientFill.GradientStyle Property

Summary

Style of the gradient fill.

Namespace: frxClass
Syntax
Delphi
published
 property GradientStyle: TfrxGradientStyle read FGradientStyle write FGradientStyle;

Property Value

Type: TfrxGradientStyle

See Also

Reference

  • TfrxGradientFill
  • frxClass


TfrxGradientFill.StartColor Property

Summary

Begin color of the gradient.

Namespace: frxClass
Syntax
Delphi
published
 property StartColor: TColor read FStartColor write FStartColor default clWhite;

Property Value

Type: TColor

See Also

Reference

  • TfrxGradientFill
  • frxClass


TfrxGradientFill Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Diff(TfrxCustomFill,String) | Returns XML string with serialized comparison of stored data between two objects( Self and AFill). (Overrides TfrxCustomFill.Diff(TfrxCustomFill,String).)
Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) | Draw fill on a canvas. (Overrides TfrxCustomFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended).)
GetColor | Represents method GetColor.
Top


TfrxGradientFill.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxGradientFill
  • frxClass


TfrxGradientFill.Diff(TfrxCustomFill,String) Method

Summary

Returns XML string with serialized comparison of stored data between two objects( Self and AFill).

Namespace: frxClass
Syntax
Delphi
public
 function Diff(AFill: TfrxCustomFill; const Add: String): String; override;

Parameters

AFill
Type: TfrxCustomFill

Add
Type: String

Return Value

Type: String

Overrides

TfrxCustomFill.Diff(TfrxCustomFill,String)
See Also

Reference

  • TfrxGradientFill
  • frxClass


TfrxGradientFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended) Method

Summary

Draw fill on a canvas.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(ACanvas: TCanvas; X, Y, X1, Y1: Integer; ScaleX, ScaleY: Extended); override;

Parameters

ACanvas
Type: TCanvas

Source canvas.

X
Type: Integer

Start X coordinate of draw area.

Y
Type: Integer

Start Y coordinate of draw area.

X1
Type: Integer

End X coordinate of draw area.

Y1
Type: Integer

End Y coordinate of draw area.

ScaleX
Type: Extended

X scale factor.

ScaleY
Type: Extended

Y scale factor.

Overrides

TfrxCustomFill.Draw(TCanvas,Integer,Integer,Integer,Integer,Extended,Extended)
See Also

Reference

  • TfrxGradientFill
  • frxClass


TfrxGradientFill.GetColor Method

Summary

Represents method GetColor.

Namespace: frxClass
Syntax
Delphi
public
 function GetColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxGradientFill
  • frxClass


TfrxGradientFill Fields

Fields
Name | Description
FEndColor | Represents field FEndColor.
FGradientStyle | Represents field FGradientStyle.
FStartColor | Represents field FStartColor.
Top


TfrxGradientFill.FEndColor Field

Summary

Represents field FEndColor.

Namespace: frxClass
Syntax
Delphi
private
 FEndColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxGradientFill
  • frxClass


TfrxGradientFill.FGradientStyle Field

Summary

Represents field FGradientStyle.

Namespace: frxClass
Syntax
Delphi
private
 FGradientStyle: TfrxGradientStyle;

Field Value

Type: TfrxGradientStyle

See Also

Reference

  • TfrxGradientFill
  • frxClass


TfrxGradientFill.FStartColor Field

Summary

Represents field FStartColor.

Namespace: frxClass
Syntax
Delphi
private
 FStartColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxGradientFill
  • frxClass


TfrxGroupFooter Class

Summary

The TfrxGroupFooter class represents a "Group footer" band. This kind of band is displayed at the bottom of each group.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxGroupFooter
Syntax
Delphi
type
 TfrxGroupFooter = class(TfrxBand)
 end;

The TfrxGroupFooter type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
HideIfSingleDataRecord | Determines whether to hide a footer if a group has only one data record.
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Represents property KeepChild.
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point). (Inherited from TfrxBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Determines whether to form a new output page before printing this band. Default value is False. (Inherited from TfrxBand.)
Stretched | Represents property Stretched.
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHideIfSingleDataRecord | Represents field FHideIfSingleDataRecord.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxGroupFooter Properties

Properties
Name | Description
AllowSplit | Represents property AllowSplit.
Child | Represents property Child.
HideIfSingleDataRecord | Determines whether to hide a footer if a group has only one data record.
KeepChild | Represents property KeepChild.
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
ShiftEngine | Represents property ShiftEngine.
Stretched | Represents property Stretched.
Top


TfrxGroupFooter.AllowSplit Property

Summary

Represents property AllowSplit.

Namespace: frxClass
Syntax
Delphi
published
 property AllowSplit;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupFooter
  • frxClass


TfrxGroupFooter.Child Property

Summary

Represents property Child.

Namespace: frxClass
Syntax
Delphi
published
 property Child;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupFooter
  • frxClass


TfrxGroupFooter.HideIfSingleDataRecord Property

Summary

Determines whether to hide a footer if a group has only one data record.

Namespace: frxClass
Syntax
Delphi
published
 property HideIfSingleDataRecord: Boolean read FHideIfSingleDataRecord
 write FHideIfSingleDataRecord default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxGroupFooter
  • frxClass


TfrxGroupFooter.KeepChild Property

Summary

Represents property KeepChild.

Namespace: frxClass
Syntax
Delphi
published
 property KeepChild;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupFooter
  • frxClass


TfrxGroupFooter.PrintChildIfInvisible Property

Summary

Represents property PrintChildIfInvisible.

Namespace: frxClass
Syntax
Delphi
published
 property PrintChildIfInvisible;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupFooter
  • frxClass


TfrxGroupFooter.ShiftEngine Property

Summary

Represents property ShiftEngine.

Namespace: frxClass
Syntax
Delphi
published
 property ShiftEngine;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupFooter
  • frxClass


TfrxGroupFooter.Stretched Property

Summary

Represents property Stretched.

Namespace: frxClass
Syntax
Delphi
published
 property Stretched;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupFooter
  • frxClass


TfrxGroupFooter Fields

Fields
Name | Description
FHideIfSingleDataRecord | Represents field FHideIfSingleDataRecord.
Top


TfrxGroupFooter.FHideIfSingleDataRecord Field

Summary

Represents field FHideIfSingleDataRecord.

Namespace: frxClass
Syntax
Delphi
private
 FHideIfSingleDataRecord: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxGroupFooter
  • frxClass


TfrxGroupHeader Class

Summary

The TfrxGroupHeader class represents a "Group header" band. This kind of band is displayed at the top of each group.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxGroupHeader
Syntax
Delphi
type
 TfrxGroupHeader = class(TfrxBand)
 end;

The TfrxGroupHeader type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child.
Condition | A special condition (DB field value or an expression); the band is displayed as soon as the condition's value is changed.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrillDown | Determines whether a group is drill-down group. It means you can click on the header in the preview window and group will expand or collapse.
DrillName | The name of a drill down group.
ExpandDrillDown | Determines whether to expand all groups at first run of report. See also DrillDown property.
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Represents property KeepChild.
KeepTogether | Determines whether to print a group on the same page. If the whole group does not find room on the page, it is transferred to a new page. Default value is False.
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | Represents property OutlineText.
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
ReprintOnNewPage | Determines whether is necessary to reprint a header on each new page.
ResetPageNumbers | Determines whether to reset the page numbers on when group starts. You should also set the StartNewPage property.
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Represents property ShiftEngine.
ShowChildIfDrillDown | Determines whether to show the child band of a collapsed group. See also DrillDown property.
ShowFooterIfDrillDown | Determines whether to show the footer of a collapsed group. See also DrillDown property.
StartNewPage | Represents property StartNewPage.
Stretched | Represents property Stretched.
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCondition | Represents field FCondition.
FDrillDown | Represents field FDrillDown.
FDrillName | Represents field FDrillName.
FExpandDrillDown | Represents field FExpandDrillDown.
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FKeepTogether | Represents field FKeepTogether.
FLastValue | Used to store previous value of group condition. Internal only.
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FReprintOnNewPage | Represents field FReprintOnNewPage.
FResetPageNumbers | Represents field FResetPageNumbers.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FShowChildIfDrillDown | Represents field FShowChildIfDrillDown.
FShowFooterIfDrillDown | Represents field FShowFooterIfDrillDown.
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxGroupHeader Properties

Properties
Name | Description
AllowSplit | Represents property AllowSplit.
Child | Represents property Child.
Condition | A special condition (DB field value or an expression); the band is displayed as soon as the condition's value is changed.
DrillDown | Determines whether a group is drill-down group. It means you can click on the header in the preview window and group will expand or collapse.
DrillName | The name of a drill down group.
ExpandDrillDown | Determines whether to expand all groups at first run of report. See also DrillDown property.
KeepChild | Represents property KeepChild.
KeepTogether | Determines whether to print a group on the same page. If the whole group does not find room on the page, it is transferred to a new page. Default value is False.
OutlineText | Represents property OutlineText.
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
ReprintOnNewPage | Determines whether is necessary to reprint a header on each new page.
ResetPageNumbers | Determines whether to reset the page numbers on when group starts. You should also set the StartNewPage property.
ShiftEngine | Represents property ShiftEngine.
ShowChildIfDrillDown | Determines whether to show the child band of a collapsed group. See also DrillDown property.
ShowFooterIfDrillDown | Determines whether to show the footer of a collapsed group. See also DrillDown property.
StartNewPage | Represents property StartNewPage.
Stretched | Represents property Stretched.
Top


TfrxGroupHeader.AllowSplit Property

Summary

Represents property AllowSplit.

Namespace: frxClass
Syntax
Delphi
published
 property AllowSplit;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.Child Property

Summary

Represents property Child.

Namespace: frxClass
Syntax
Delphi
published
 property Child;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.Condition Property

Summary

A special condition (DB field value or an expression); the band is displayed as soon as the condition's value is changed.

Namespace: frxClass
Syntax
Delphi
published
 property Condition: String read FCondition write FCondition;

Property Value

Type: String

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.DrillDown Property

Summary

Determines whether a group is drill-down group. It means you can click on the header in the preview window and group will expand or collapse.

Namespace: frxClass
Syntax
Delphi
published
 property DrillDown: Boolean read FDrillDown write FDrillDown default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.DrillName Property

Summary

The name of a drill down group.

Namespace: frxClass
Syntax
Delphi
published
 property DrillName: String read FDrillName write FDrillName;

Property Value

Type: String

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.ExpandDrillDown Property

Summary

Determines whether to expand all groups at first run of report. See also DrillDown property.

Namespace: frxClass
Syntax
Delphi
published
 property ExpandDrillDown: Boolean read FExpandDrillDown write FExpandDrillDown default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.KeepChild Property

Summary

Represents property KeepChild.

Namespace: frxClass
Syntax
Delphi
published
 property KeepChild;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.KeepTogether Property

Summary

Determines whether to print a group on the same page. If the whole group does not find room on the page, it is transferred to a new page. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property KeepTogether: Boolean read FKeepTogether write FKeepTogether default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.OutlineText Property

Summary

Represents property OutlineText.

Namespace: frxClass
Syntax
Delphi
published
 property OutlineText;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.PrintChildIfInvisible Property

Summary

Represents property PrintChildIfInvisible.

Namespace: frxClass
Syntax
Delphi
published
 property PrintChildIfInvisible;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.ReprintOnNewPage Property

Summary

Determines whether is necessary to reprint a header on each new page.

Namespace: frxClass
Syntax
Delphi
published
 property ReprintOnNewPage: Boolean read FReprintOnNewPage write FReprintOnNewPage default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.ResetPageNumbers Property

Summary

Determines whether to reset the page numbers on when group starts. You should also set the StartNewPage property.

Namespace: frxClass
Syntax
Delphi
published
 property ResetPageNumbers: Boolean read FResetPageNumbers write FResetPageNumbers default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.ShiftEngine Property

Summary

Represents property ShiftEngine.

Namespace: frxClass
Syntax
Delphi
published
 property ShiftEngine;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.ShowChildIfDrillDown Property

Summary

Determines whether to show the child band of a collapsed group. See also DrillDown property.

Namespace: frxClass
Syntax
Delphi
published
 property ShowChildIfDrillDown: Boolean read FShowChildIfDrillDown
 write FShowChildIfDrillDown default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.ShowFooterIfDrillDown Property

Summary

Determines whether to show the footer of a collapsed group. See also DrillDown property.

Namespace: frxClass
Syntax
Delphi
published
 property ShowFooterIfDrillDown: Boolean read FShowFooterIfDrillDown
 write FShowFooterIfDrillDown default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.StartNewPage Property

Summary

Represents property StartNewPage.

Namespace: frxClass
Syntax
Delphi
published
 property StartNewPage;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.Stretched Property

Summary

Represents property Stretched.

Namespace: frxClass
Syntax
Delphi
published
 property Stretched;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader Methods

Methods
Name | Description
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended).)
Top


TfrxGroupHeader.Diff(TfrxComponent) Method

Summary

Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set.

Namespace: frxClass
Syntax
Delphi
public
 function Diff(AComponent: TfrxComponent): String; override;

Parameters

AComponent
Type: TfrxComponent

Return Value

Type: String

Overrides

TfrxComponent.Diff(TfrxComponent)
See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader Fields

Fields
Name | Description
FCondition | Represents field FCondition.
FDrillDown | Represents field FDrillDown.
FDrillName | Represents field FDrillName.
FExpandDrillDown | Represents field FExpandDrillDown.
FKeepTogether | Represents field FKeepTogether.
FLastValue | Used to store previous value of group condition. Internal only.
FReprintOnNewPage | Represents field FReprintOnNewPage.
FResetPageNumbers | Represents field FResetPageNumbers.
FShowChildIfDrillDown | Represents field FShowChildIfDrillDown.
FShowFooterIfDrillDown | Represents field FShowFooterIfDrillDown.
Top


TfrxGroupHeader.FCondition Field

Summary

Represents field FCondition.

Namespace: frxClass
Syntax
Delphi
private
 FCondition: String;

Field Value

Type: String

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.FDrillDown Field

Summary

Represents field FDrillDown.

Namespace: frxClass
Syntax
Delphi
private
 FDrillDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.FDrillName Field

Summary

Represents field FDrillName.

Namespace: frxClass
Syntax
Delphi
private
 FDrillName: String;

Field Value

Type: String

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.FExpandDrillDown Field

Summary

Represents field FExpandDrillDown.

Namespace: frxClass
Syntax
Delphi
private
 FExpandDrillDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.FKeepTogether Field

Summary

Represents field FKeepTogether.

Namespace: frxClass
Syntax
Delphi
private
 FKeepTogether: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.FLastValue Field

Summary

Used to store previous value of group condition. Internal only.

Namespace: frxClass
Syntax
Delphi
public
 FLastValue: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.FReprintOnNewPage Field

Summary

Represents field FReprintOnNewPage.

Namespace: frxClass
Syntax
Delphi
private
 FReprintOnNewPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.FResetPageNumbers Field

Summary

Represents field FResetPageNumbers.

Namespace: frxClass
Syntax
Delphi
private
 FResetPageNumbers: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.FShowChildIfDrillDown Field

Summary

Represents field FShowChildIfDrillDown.

Namespace: frxClass
Syntax
Delphi
private
 FShowChildIfDrillDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxGroupHeader.FShowFooterIfDrillDown Field

Summary

Represents field FShowFooterIfDrillDown.

Namespace: frxClass
Syntax
Delphi
private
 FShowFooterIfDrillDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxGroupHeader
  • frxClass


TfrxHeader Class

Summary

The TfrxHeader class represents a "Header" band. This kind of band is a header for all data-bands.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxHeader
Syntax
Delphi
type
 TfrxHeader = class(TfrxBand)
 end;

The TfrxHeader type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Represents property KeepChild.
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point). (Inherited from TfrxBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
ReprintOnNewPage | Determines if it is necessary to reprint a header on each new page.
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Represents property StartNewPage.
Stretched | Represents property Stretched.
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FReprintOnNewPage | Represents field FReprintOnNewPage.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxHeader Properties

Properties
Name | Description
AllowSplit | Represents property AllowSplit.
Child | Represents property Child.
KeepChild | Represents property KeepChild.
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
ReprintOnNewPage | Determines if it is necessary to reprint a header on each new page.
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Represents property StartNewPage.
Stretched | Represents property Stretched.
Top


TfrxHeader.AllowSplit Property

Summary

Represents property AllowSplit.

Namespace: frxClass
Syntax
Delphi
published
 property AllowSplit;

Property Value

Type: Void

See Also

Reference

  • TfrxHeader
  • frxClass


TfrxHeader.Child Property

Summary

Represents property Child.

Namespace: frxClass
Syntax
Delphi
published
 property Child;

Property Value

Type: Void

See Also

Reference

  • TfrxHeader
  • frxClass


TfrxHeader.KeepChild Property

Summary

Represents property KeepChild.

Namespace: frxClass
Syntax
Delphi
published
 property KeepChild;

Property Value

Type: Void

See Also

Reference

  • TfrxHeader
  • frxClass


TfrxHeader.PrintChildIfInvisible Property

Summary

Represents property PrintChildIfInvisible.

Namespace: frxClass
Syntax
Delphi
published
 property PrintChildIfInvisible;

Property Value

Type: Void

See Also

Reference

  • TfrxHeader
  • frxClass


TfrxHeader.ReprintOnNewPage Property

Summary

Determines if it is necessary to reprint a header on each new page.

Namespace: frxClass
Syntax
Delphi
published
 property ReprintOnNewPage: Boolean read FReprintOnNewPage write FReprintOnNewPage default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxHeader
  • frxClass


TfrxHeader.ShiftEngine Property

Summary

Represents property ShiftEngine.

Namespace: frxClass
Syntax
Delphi
published
 property ShiftEngine;

Property Value

Type: Void

See Also

Reference

  • TfrxHeader
  • frxClass


TfrxHeader.StartNewPage Property

Summary

Represents property StartNewPage.

Namespace: frxClass
Syntax
Delphi
published
 property StartNewPage;

Property Value

Type: Void

See Also

Reference

  • TfrxHeader
  • frxClass


TfrxHeader.Stretched Property

Summary

Represents property Stretched.

Namespace: frxClass
Syntax
Delphi
published
 property Stretched;

Property Value

Type: Void

See Also

Reference

  • TfrxHeader
  • frxClass


TfrxHeader Fields

Fields
Name | Description
FReprintOnNewPage | Represents field FReprintOnNewPage.
Top


TfrxHeader.FReprintOnNewPage Field

Summary

Represents field FReprintOnNewPage.

Namespace: frxClass
Syntax
Delphi
private
 FReprintOnNewPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxHeader
  • frxClass


TfrxHighlight Class

Summary

The TfrxHighlight class holds the conditional highlight settings. The conditional highlight is used in the TfrxMemoView object and allows changing the font and color settings depending on some condition.

Namespace: frxClass
Inheritance Hierarchy
TCollectionItem
frxCollections.TfrxCollectionItem
frxClass.TfrxHighlight
Syntax
Delphi
type
 TfrxHighlight = class(TfrxCollectionItem)
 end;

The TfrxHighlight type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxHighlight class. (Overrides TfrxCollectionItem.Create(TCollection).)
Destroy | Represents the destructor of the TfrxHighlight class.
Top
Properties
Show:
Name | Description
Active | Highlight's font. Determines whether the highlight is active. When active, the TfrxMemoView object uses highlight settings.
ApplyFill | Deprecated. Apply Fill to the object.
ApplyFont | Deprecated. Apply font styles to the object.
ApplyFrame | Deprecated. Apply frame to the object.
Color | Highlight's color.
Condition | Highlight's condition. Contains any valid expression.
Fill | Highlight's Fill object.
FillType | Highlight's Fill type.
Font | Highlight's font.
Frame | Highlight's frame object.
InheritedName | Represents property InheritedName. (Inherited from TfrxCollectionItem.)
InteractiveType | Reserved.
IsInherited | Represents property IsInherited. (Inherited from TfrxCollectionItem.)
UniqueIndex | Represents property UniqueIndex. (Inherited from TfrxCollectionItem.)
Visible | Visibility of Highlight.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Copies all properties from other object.
CreateUniqueIName(TCollection) | Represents method CreateUniqueIName(TCollection). (Inherited from TfrxCollectionItem.)
GetColor | Represents method GetColor.
GetFillType | Represents method GetFillType.
GetInheritedName | Represents method GetInheritedName. (Inherited from TfrxCollectionItem.)
IsUniqueNameStored | True if instance should generate unique name before serialization. Used in inherit mechanism for unnamed collections. (Overrides TfrxCollectionItem.IsUniqueNameStored.)
SetColor(TColor) | Represents method SetColor(TColor).
SetFill(TfrxCustomFill) | Represents method SetFill(TfrxCustomFill).
SetFillType(TfrxFillType) | Represents method SetFillType(TfrxFillType).
SetFont(TFont) | Represents method SetFont(TFont).
SetFrame(TfrxFrame) | Represents method SetFrame(TfrxFrame).
SetInheritedName(String) | Represents method SetInheritedName(String). (Inherited from TfrxCollectionItem.)
Top
Fields
Show:
Name | Description
FActive | Represents field FActive.
FApplyFill | Represents field FApplyFill.
FApplyFont | Represents field FApplyFont.
FApplyFrame | Represents field FApplyFrame.
FCondition | Represents field FCondition.
FFill | Represents field FFill.
FFont | Represents field FFont.
FFrame | Represents field FFrame.
FInteractiveType | Represents field FInteractiveType.
FIsInherited | Represents field FIsInherited. (Inherited from TfrxCollectionItem.)
FUniqueIndex | Represents field FUniqueIndex. (Inherited from TfrxCollectionItem.)
FVisible | Represents field FVisible.
Top
See Also

Reference

  • frxClass


TfrxHighlight Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxHighlight class. (Overrides TfrxCollectionItem.Create(TCollection).)
Destroy | Represents the destructor of the TfrxHighlight class.
Top


TfrxHighlight.Create(TCollection) Constructor

Summary

Initializes a new instance of the TfrxHighlight class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(Collection: TCollection); override;

Parameters

Collection
Type: TCollection

Overrides

TfrxCollectionItem.Create(TCollection)
See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.Destroy Destructor

Summary

Represents the destructor of the TfrxHighlight class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight Properties

Properties
Name | Description
Active | Highlight's font. Determines whether the highlight is active. When active, the TfrxMemoView object uses highlight settings.
ApplyFill | Deprecated. Apply Fill to the object.
ApplyFont | Deprecated. Apply font styles to the object.
ApplyFrame | Deprecated. Apply frame to the object.
Color | Highlight's color.
Condition | Highlight's condition. Contains any valid expression.
Fill | Highlight's Fill object.
FillType | Highlight's Fill type.
Font | Highlight's font.
Frame | Highlight's frame object.
InteractiveType | Reserved.
Visible | Visibility of Highlight.
Top


TfrxHighlight.Active Property

Summary

Highlight's font. Determines whether the highlight is active. When active, the TfrxMemoView object uses highlight settings.

Namespace: frxClass
Syntax
Delphi
published
 property Active: Boolean read FActive write FActive stored False default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.ApplyFill Property

Summary

Deprecated. Apply Fill to the object.

Namespace: frxClass
Syntax
Delphi
published
 property ApplyFill: Boolean read FApplyFill write FApplyFill default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.ApplyFont Property

Summary

Deprecated. Apply font styles to the object.

Namespace: frxClass
Syntax
Delphi
published
 property ApplyFont: Boolean read FApplyFont write FApplyFont default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.ApplyFrame Property

Summary

Deprecated. Apply frame to the object.

Namespace: frxClass
Syntax
Delphi
published
 property ApplyFrame: Boolean read FApplyFrame write FApplyFrame default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.Color Property

Summary

Highlight's color.

Namespace: frxClass
Syntax
Delphi
published
 property Color: TColor read GetColor write SetColor stored False default clNone;

Property Value

Type: TColor

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.Condition Property

Summary

Highlight's condition. Contains any valid expression.

Namespace: frxClass
Syntax
Delphi
published
 property Condition: String read FCondition write FCondition;

Property Value

Type: String

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.Fill Property

Summary

Highlight's Fill object.

Namespace: frxClass
Syntax
Delphi
published
 property Fill: TfrxCustomFill read FFill write SetFill;

Property Value

Type: TfrxCustomFill

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.FillType Property

Summary

Highlight's Fill type.

Namespace: frxClass
Syntax
Delphi
published
 property FillType: TfrxFillType read GetFillType write SetFillType;

Property Value

Type: TfrxFillType

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.Font Property

Summary

Highlight's font.

Namespace: frxClass
Syntax
Delphi
published
 property Font: TFont read FFont write SetFont;

Property Value

Type: TFont

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.Frame Property

Summary

Highlight's frame object.

Namespace: frxClass
Syntax
Delphi
published
 property Frame: TfrxFrame read FFrame write SetFrame;

Property Value

Type: TfrxFrame

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.InteractiveType Property

Summary

Reserved.

Namespace: frxClass
Syntax
Delphi
published
 property InteractiveType: TfrxInteractiveHighlightEvent read FInteractiveType write FInteractiveType default ihNone;

Property Value

Type: TfrxInteractiveHighlightEvent

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.Visible Property

Summary

Visibility of Highlight.

Namespace: frxClass
Syntax
Delphi
published
 property Visible: Boolean read FVisible write FVisible default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight Methods

Methods
Name | Description
Assign(TPersistent) | Copies all properties from other object.
GetColor | Represents method GetColor.
GetFillType | Represents method GetFillType.
IsUniqueNameStored | True if instance should generate unique name before serialization. Used in inherit mechanism for unnamed collections. (Overrides TfrxCollectionItem.IsUniqueNameStored.)
SetColor(TColor) | Represents method SetColor(TColor).
SetFill(TfrxCustomFill) | Represents method SetFill(TfrxCustomFill).
SetFillType(TfrxFillType) | Represents method SetFillType(TfrxFillType).
SetFont(TFont) | Represents method SetFont(TFont).
SetFrame(TfrxFrame) | Represents method SetFrame(TfrxFrame).
Top


TfrxHighlight.Assign(TPersistent) Method

Summary

Copies all properties from other object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.GetColor Method

Summary

Represents method GetColor.

Namespace: frxClass
Syntax
Delphi
private
 function GetColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.GetFillType Method

Summary

Represents method GetFillType.

Namespace: frxClass
Syntax
Delphi
private
 function GetFillType: TfrxFillType;

Return Value

Type: TfrxFillType

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.IsUniqueNameStored Method

Summary

True if instance should generate unique name before serialization. Used in inherit mechanism for unnamed collections.

Namespace: frxClass
Syntax
Delphi
public
 function IsUniqueNameStored: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCollectionItem.IsUniqueNameStored
See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.SetFill(TfrxCustomFill) Method

Summary

Represents method SetFill(TfrxCustomFill).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFill(const Value: TfrxCustomFill);

Parameters

Value
Type: TfrxCustomFill

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.SetFillType(TfrxFillType) Method

Summary

Represents method SetFillType(TfrxFillType).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFillType(const Value: TfrxFillType);

Parameters

Value
Type: TfrxFillType

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.SetFont(TFont) Method

Summary

Represents method SetFont(TFont).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFont(const Value: TFont);

Parameters

Value
Type: TFont

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.SetFrame(TfrxFrame) Method

Summary

Represents method SetFrame(TfrxFrame).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFrame(const Value: TfrxFrame);

Parameters

Value
Type: TfrxFrame

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight Fields

Fields
Name | Description
FActive | Represents field FActive.
FApplyFill | Represents field FApplyFill.
FApplyFont | Represents field FApplyFont.
FApplyFrame | Represents field FApplyFrame.
FCondition | Represents field FCondition.
FFill | Represents field FFill.
FFont | Represents field FFont.
FFrame | Represents field FFrame.
FInteractiveType | Represents field FInteractiveType.
FVisible | Represents field FVisible.
Top


TfrxHighlight.FActive Field

Summary

Represents field FActive.

Namespace: frxClass
Syntax
Delphi
private
 FActive: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.FApplyFill Field

Summary

Represents field FApplyFill.

Namespace: frxClass
Syntax
Delphi
private
 FApplyFill: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.FApplyFont Field

Summary

Represents field FApplyFont.

Namespace: frxClass
Syntax
Delphi
private
 FApplyFont: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.FApplyFrame Field

Summary

Represents field FApplyFrame.

Namespace: frxClass
Syntax
Delphi
private
 FApplyFrame: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.FCondition Field

Summary

Represents field FCondition.

Namespace: frxClass
Syntax
Delphi
private
 FCondition: String;

Field Value

Type: String

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.FFill Field

Summary

Represents field FFill.

Namespace: frxClass
Syntax
Delphi
private
 FFill: TfrxCustomFill;

Field Value

Type: TfrxCustomFill

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.FFont Field

Summary

Represents field FFont.

Namespace: frxClass
Syntax
Delphi
private
 FFont: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.FFrame Field

Summary

Represents field FFrame.

Namespace: frxClass
Syntax
Delphi
private
 FFrame: TfrxFrame;

Field Value

Type: TfrxFrame

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.FInteractiveType Field

Summary

Represents field FInteractiveType.

Namespace: frxClass
Syntax
Delphi
private
 FInteractiveType: TfrxInteractiveHighlightEvent;

Field Value

Type: TfrxInteractiveHighlightEvent

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlight.FVisible Field

Summary

Represents field FVisible.

Namespace: frxClass
Syntax
Delphi
private
 FVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxHighlight
  • frxClass


TfrxHighlightCollection Class

Summary

Collection of TfrxHighlight. Each object can hold several highlights which serves different conditions.

Namespace: frxClass
Inheritance Hierarchy
TCollection
frxCollections.TfrxCollection
frxClass.TfrxHighlightCollection
Syntax
Delphi
type
 TfrxHighlightCollection = class(TfrxCollection)
 end;

The TfrxHighlightCollection type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxHighlightCollection class.
Top
Properties
Show:
Name | Description
Items[Integer] | TfrxHighlight items.
Top
Methods
Show:
Name | Description
DeserializeProperties(String,TObject,TfrxCollection) | Represents method DeserializeProperties(String,TObject,TfrxCollection). (Inherited from TfrxCollection.)
FindByName(String) | Represents method FindByName(String). (Inherited from TfrxCollection.)
GetItem(Integer) | Represents method GetItem(Integer).
SerializeProperties(TObject,TfrxCollection,TComponent) | Represents method SerializeProperties(TObject,TfrxCollection,TComponent). (Inherited from TfrxCollection.)
Top
See Also

Reference

  • frxClass


TfrxHighlightCollection Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxHighlightCollection class.
Top


TfrxHighlightCollection.Create Constructor

Summary

Initializes a new instance of the TfrxHighlightCollection class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxHighlightCollection
  • frxClass


TfrxHighlightCollection Properties

Properties
Name | Description
Items[Integer] | TfrxHighlight items.
Top


TfrxHighlightCollection.Items[Integer] Property

Summary

TfrxHighlight items.

Namespace: frxClass
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxHighlight read GetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxHighlight

See Also

Reference

  • TfrxHighlightCollection
  • frxClass


TfrxHighlightCollection Methods

Methods
Name | Description
GetItem(Integer) | Represents method GetItem(Integer).
Top


TfrxHighlightCollection.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetItem(Index: Integer): TfrxHighlight;

Parameters

Index
Type: Integer

Return Value

Type: TfrxHighlight

See Also

Reference

  • TfrxHighlightCollection
  • frxClass


TfrxHyperlink Class

Summary

This class encapsulates data for hyperlinks. Some report objects may have hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxHyperlink
Syntax
Delphi
type
 TfrxHyperlink = class(TPersistent)
 end;

The TfrxHyperlink type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxHyperlink class.
Top
Properties
Show:
Name | Description
DetailPage | Symbolic link to a detail page.
DetailReport | Symbolic link to a detail report.
Expression | Expression for variable declared in ReportVariable property. The report Engine calculates it in GetData method. May contain several expressions delimited with ValuesSeparator sign(Default ';') like <Expr1>;<Expr2>;<Expr3>.
Kind | Type of hyperlinks supported by report objects.
ReportVariable | Variable names in destination report which will be used to broadcast parameters of one report to another. May contain several variables delimited with ValuesSeparator sign(Default ';') like Var1;Var2;Var3.
TabCaption | Caption of the new report tab in the report preview.
Value | Default values for variables declared in ReportVariable property. May contain several variables delimited with ValuesSeparator sign(Default ';') like Val1;Val2;Val3.
ValuesSeparator | Separator sign. It used in expressions, variables and values as a delimiter. Default ';'.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
AssignVariables(TfrxReport) | Assigns values of variables declared in ReportVariable property to aReport object.
Diff(TfrxHyperlink,String) | Returns XML string with serialized comparison of stored data between two objects( Self and ALink).
IsEmpty | Returns True if data is not filled and properties have default values.
IsValuesSeparatorStored | Represents method IsValuesSeparatorStored.
Top
Fields
Show:
Name | Description
FDetailPage | Represents field FDetailPage.
FDetailReport | Represents field FDetailReport.
FExpression | Represents field FExpression.
FKind | Represents field FKind.
FReportVariable | Represents field FReportVariable.
FTabCaption | Represents field FTabCaption.
FValue | Represents field FValue.
FValuesSeparator | Represents field FValuesSeparator.
Top
See Also

Reference

  • frxClass


TfrxHyperlink Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxHyperlink class.
Top


TfrxHyperlink.Create Constructor

Summary

Initializes a new instance of the TfrxHyperlink class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink Properties

Properties
Name | Description
DetailPage | Symbolic link to a detail page.
DetailReport | Symbolic link to a detail report.
Expression | Expression for variable declared in ReportVariable property. The report Engine calculates it in GetData method. May contain several expressions delimited with ValuesSeparator sign(Default ';') like <Expr1>;<Expr2>;<Expr3>.
Kind | Type of hyperlinks supported by report objects.
ReportVariable | Variable names in destination report which will be used to broadcast parameters of one report to another. May contain several variables delimited with ValuesSeparator sign(Default ';') like Var1;Var2;Var3.
TabCaption | Caption of the new report tab in the report preview.
Value | Default values for variables declared in ReportVariable property. May contain several variables delimited with ValuesSeparator sign(Default ';') like Val1;Val2;Val3.
ValuesSeparator | Separator sign. It used in expressions, variables and values as a delimiter. Default ';'.
Top


TfrxHyperlink.DetailPage Property

Summary

Symbolic link to a detail page.

Namespace: frxClass
Syntax
Delphi
published
 property DetailPage: String read FDetailPage write FDetailPage;

Property Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.DetailReport Property

Summary

Symbolic link to a detail report.

Namespace: frxClass
Syntax
Delphi
published
 property DetailReport: String read FDetailReport write FDetailReport;

Property Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.Expression Property

Summary

Expression for variable declared in ReportVariable property. The report Engine calculates it in GetData method. May contain several expressions delimited with ValuesSeparator sign(Default ';') like <Expr1>;<Expr2>;<Expr3>.

Namespace: frxClass
Syntax
Delphi
published
 property Expression: String read FExpression write FExpression;

Property Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.Kind Property

Summary

Type of hyperlinks supported by report objects.

Namespace: frxClass
Syntax
Delphi
published
 property Kind: TfrxHyperlinkKind read FKind write FKind default hkURL;

Property Value

Type: TfrxHyperlinkKind

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.ReportVariable Property

Summary

Variable names in destination report which will be used to broadcast parameters of one report to another. May contain several variables delimited with ValuesSeparator sign(Default ';') like Var1;Var2;Var3.

Namespace: frxClass
Syntax
Delphi
published
 property ReportVariable: String read FReportVariable write FReportVariable;

Property Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.TabCaption Property

Summary

Caption of the new report tab in the report preview.

Namespace: frxClass
Syntax
Delphi
published
 property TabCaption: String read FTabCaption write FTabCaption;

Property Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.Value Property

Summary

Default values for variables declared in ReportVariable property. May contain several variables delimited with ValuesSeparator sign(Default ';') like Val1;Val2;Val3.

Namespace: frxClass
Syntax
Delphi
published
 property Value: String read FValue write FValue;

Property Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.ValuesSeparator Property

Summary

Separator sign. It used in expressions, variables and values as a delimiter. Default ';'.

Namespace: frxClass
Syntax
Delphi
published
 property ValuesSeparator: String read FValuesSeparator write FValuesSeparator stored IsValuesSeparatorStored;

Property Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
AssignVariables(TfrxReport) | Assigns values of variables declared in ReportVariable property to aReport object.
Diff(TfrxHyperlink,String) | Returns XML string with serialized comparison of stored data between two objects( Self and ALink).
IsEmpty | Returns True if data is not filled and properties have default values.
IsValuesSeparatorStored | Represents method IsValuesSeparatorStored.
Top


TfrxHyperlink.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.AssignVariables(TfrxReport) Method

Summary

Assigns values of variables declared in ReportVariable property to aReport object.

Namespace: frxClass
Syntax
Delphi
public
 procedure AssignVariables(aReport: TfrxReport);

Parameters

aReport
Type: TfrxReport

Report object.

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.Diff(TfrxHyperlink,String) Method

Summary

Returns XML string with serialized comparison of stored data between two objects( Self and ALink).

Namespace: frxClass
Syntax
Delphi
public
 function Diff(ALink: TfrxHyperlink; const Add: String): String;

Parameters

ALink
Type: TfrxHyperlink

Base object used to compare properties.

Add
Type: String

Additional XML text.

Return Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.IsEmpty Method

Summary

Returns True if data is not filled and properties have default values.

Namespace: frxClass
Syntax
Delphi
public
 function IsEmpty: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.IsValuesSeparatorStored Method

Summary

Represents method IsValuesSeparatorStored.

Namespace: frxClass
Syntax
Delphi
private
 function IsValuesSeparatorStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink Fields

Fields
Name | Description
FDetailPage | Represents field FDetailPage.
FDetailReport | Represents field FDetailReport.
FExpression | Represents field FExpression.
FKind | Represents field FKind.
FReportVariable | Represents field FReportVariable.
FTabCaption | Represents field FTabCaption.
FValue | Represents field FValue.
FValuesSeparator | Represents field FValuesSeparator.
Top


TfrxHyperlink.FDetailPage Field

Summary

Represents field FDetailPage.

Namespace: frxClass
Syntax
Delphi
private
 FDetailPage: String;

Field Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.FDetailReport Field

Summary

Represents field FDetailReport.

Namespace: frxClass
Syntax
Delphi
private
 FDetailReport: String;

Field Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.FExpression Field

Summary

Represents field FExpression.

Namespace: frxClass
Syntax
Delphi
private
 FExpression: String;

Field Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.FKind Field

Summary

Represents field FKind.

Namespace: frxClass
Syntax
Delphi
private
 FKind: TfrxHyperlinkKind;

Field Value

Type: TfrxHyperlinkKind

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.FReportVariable Field

Summary

Represents field FReportVariable.

Namespace: frxClass
Syntax
Delphi
private
 FReportVariable: String;

Field Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.FTabCaption Field

Summary

Represents field FTabCaption.

Namespace: frxClass
Syntax
Delphi
private
 FTabCaption: String;

Field Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.FValue Field

Summary

Represents field FValue.

Namespace: frxClass
Syntax
Delphi
private
 FValue: String;

Field Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxHyperlink.FValuesSeparator Field

Summary

Represents field FValuesSeparator.

Namespace: frxClass
Syntax
Delphi
private
 FValuesSeparator: String;

Field Value

Type: String

See Also

Reference

  • TfrxHyperlink
  • frxClass


TfrxInPlaceEditor Class

Summary

The base class for InPlace editors. With InPlace editors programmers may extend functionality of the report designer and the report preview. This class handles mouse events, drag and drop, clipboard and custom draw. It can be used to create custom in place editor for the report designer, override copy/paste behaviour for selected object and draws custom editors.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxInPlaceEditor
frxInPlaceClipboards.TfrxInPlaceBaseCopyPasteEditor
frxInPlaceClipboards.TfrxInPlacePictureCopyPasteEditor
frxInPlaceEditors.TfrxInPlaceBasePanelEditor
frxInPlaceEditors.TfrxInPlaceDataFiledEditor
frxInPlaceEditors.TfrxInPlaceMemoEditorBase
Syntax
Delphi
type
 TfrxInPlaceEditor = class(TObject)
 end;

The TfrxInPlaceEditor type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponentClass,TWinControl) | Default constructor.
Destroy | Represents the destructor of the TfrxInPlaceEditor class.
Top
Properties
Show:
Name | Description
ClipboardObject | Reference to a clipboard object.
Component | Reference to edited component.
Editors | Child editors for current editor class.
Locked | Editor is locked.
ParentComponent | Reference to a parent component.
Top
Methods
Show:
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) |
CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter.
DefaultContentType | Returns default content type supported by InPlcae editor.
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.
DoFinishInPlace(TObject,Boolean,Boolean) | Calls OnFinishInPlace event handler.
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class InPlace editor serves.
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.
DrawCustomEditor(TCanvas,TRect) | Draws object editor over object canvas.
EditInPlace(TComponent,TRect) | Represents method EditInPlace(TComponent,TRect).
EditInPlaceDone | This method should close in place editor and apply changes to edited object.
FillData | Not used.
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves.
GetActiveRect | Returns active work area of the editor.
HasCustomEditor | Not used.
HasInPlaceEditor | Not used.
InitializeUI(TfrxInteractiveEventsParams) | Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves.
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) |
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) |
PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) |
SetComponent(TfrxComponent) | Represents method SetComponent(TfrxComponent).
SetOffset(Extended,Extended,Extended) | Sets parameters used by the report preview or the report designer.
Top
Events
Show:
Name | Description
OnFinishInPlace | An event used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor.
Top
Fields
Show:
Name | Description
FClassRef | Represents field FClassRef.
FClipboardObject | Represents field FClipboardObject.
FComponent | Represents field FComponent.
FComponents | Represents field FComponents.
FDevicePPI | Represents field FDevicePPI.
FEditors | Represents field FEditors.
FLocked | Represents field FLocked.
FOffsetX | Represents field FOffsetX.
FOffsetY | Represents field FOffsetY.
FOnFinishInPlace | Represents field FOnFinishInPlace.
FOwner | Represents field FOwner.
FParentComponent | Represents field FParentComponent.
FScale | Represents field FScale.
Top
See Also

Reference

  • frxClass


TfrxInPlaceEditor Constructors

Constructors
Name | Description
Create(TfrxComponentClass,TWinControl) | Default constructor.
Destroy | Represents the destructor of the TfrxInPlaceEditor class.
Top


TfrxInPlaceEditor.Create(TfrxComponentClass,TWinControl) Constructor

Summary

Default constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(aClassRef: TfrxComponentClass; aOwner: TWinControl); virtual;

Parameters

aClassRef
Type: TfrxComponentClass

Class reference of report component used in the editor.

aOwner
Type: TWinControl

Widow control which owns editor(designer or preview).

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.Destroy Destructor

Summary

Represents the destructor of the TfrxInPlaceEditor class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor Properties

Properties
Name | Description
ClipboardObject | Reference to a clipboard object.
Component | Reference to edited component.
Editors | Child editors for current editor class.
Locked | Editor is locked.
ParentComponent | Reference to a parent component.
Top


TfrxInPlaceEditor.ClipboardObject Property

Summary

Reference to a clipboard object.

Namespace: frxClass
Syntax
Delphi
public
 property ClipboardObject: TPersistent read FClipboardObject write FClipboardObject;

Property Value

Type: TPersistent

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.Component Property

Summary

Reference to edited component.

Namespace: frxClass
Syntax
Delphi
public
 property Component: TfrxComponent read FComponent write SetComponent;

Property Value

Type: TfrxComponent

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.Editors Property

Summary

Child editors for current editor class.

Namespace: frxClass
Syntax
Delphi
public
 property Editors: TfrxComponentEditorsList read FEditors write FEditors;

Property Value

Type: TfrxComponentEditorsList

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.Locked Property

Summary

Editor is locked.

Namespace: frxClass
Syntax
Delphi
public
 property Locked: Boolean read FLocked;

Property Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.ParentComponent Property

Summary

Reference to a parent component.

Namespace: frxClass
Syntax
Delphi
public
 property ParentComponent: TComponent read FParentComponent write FParentComponent;

Property Value

Type: TComponent

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor Methods

Methods
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) |
CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter.
DefaultContentType | Returns default content type supported by InPlcae editor.
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.
DoFinishInPlace(TObject,Boolean,Boolean) | Calls OnFinishInPlace event handler.
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class InPlace editor serves.
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.
DrawCustomEditor(TCanvas,TRect) | Draws object editor over object canvas.
EditInPlace(TComponent,TRect) | Represents method EditInPlace(TComponent,TRect).
EditInPlaceDone | This method should close in place editor and apply changes to edited object.
FillData | Not used.
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves.
GetActiveRect | Returns active work area of the editor.
HasCustomEditor | Not used.
HasInPlaceEditor | Not used.
InitializeUI(TfrxInteractiveEventsParams) | Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves.
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) |
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) |
PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) |
SetComponent(TfrxComponent) | Represents method SetComponent(TfrxComponent).
SetOffset(Extended,Extended,Extended) | Sets parameters used by the report preview or the report designer.
Top


TfrxInPlaceEditor.CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) Method

Namespace: frxClass
Syntax
Delphi
public
 procedure CopyContent(CopyFrom: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; Buffer: TStream; CopyAs: TfrxCopyPasteType = cptDefault); virtual;

Parameters

CopyFrom
Type: TfrxComponent

Reference to an object used to copy from.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Buffer
Type: TStream

Temporary buffer for copy.

CopyAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) Method

Summary

This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter.

Namespace: frxClass
Syntax
Delphi
public
 procedure CopyGoupContent(CopyFrom: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; Buffer: TStream; CopyAs: TfrxCopyPasteType = cptDefault); virtual;

Parameters

CopyFrom
Type: TfrxComponent

Reference to an object used to copy from.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Buffer
Type: TStream

Temporary buffer for copy.

CopyAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.DefaultContentType Method

Summary

Returns default content type supported by InPlcae editor.

Namespace: frxClass
Syntax
Delphi
public
 function DefaultContentType: TfrxCopyPasteType; virtual;

Return Value

Type: TfrxCopyPasteType

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.

Namespace: frxClass
Syntax
Delphi
public
 function DoCustomDragDrop(Source: TObject; X, Y: Integer; var EventParams: TfrxInteractiveEventsParams): Boolean; virtual;

Parameters

Source
Type: TObject

Source object.

X
Type: Integer

Current mouse x coordinate.

Y
Type: Integer

Current mouse y coordinate.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.

Namespace: frxClass
Syntax
Delphi
public
 function DoCustomDragOver(Source: TObject; X, Y: Integer; State: TDragState; var Accept: Boolean; var EventParams: TfrxInteractiveEventsParams): Boolean; virtual;

Parameters

Source
Type: TObject

Source object.

X
Type: Integer

Current mouse x coordinate.

Y
Type: Integer

Current mouse y coordinate.

State
Type: TDragState

State of drag and drop operation.

Accept
Type: Boolean

Should return true when editor accepts drag and drop for current object.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.DoFinishInPlace(TObject,Boolean,Boolean) Method

Summary

Calls OnFinishInPlace event handler.

Namespace: frxClass
Syntax
Delphi
public
 procedure DoFinishInPlace(Sender: TObject; Refresh, Modified: Boolean); virtual;

Parameters

Sender
Type: TObject

Refresh
Type: Boolean

Modified
Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.

Namespace: frxClass
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean; virtual;

Parameters

X
Type: Integer

Current mouse x coordinate.

Y
Type: Integer

Current mouse y coordinate.

Button
Type: TMouseButton

Mouse button.

Shift
Type: TShiftState

Shift buttons states.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.

Namespace: frxClass
Syntax
Delphi
public
 function DoMouseMove(X, Y: Integer; Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean; virtual;

Parameters

X
Type: Integer

Current mouse x coordinate.

Y
Type: Integer

Current mouse y coordinate.

Shift
Type: TShiftState

Shift buttons states.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class InPlace editor serves.

Namespace: frxClass
Syntax
Delphi
public
 function DoMouseUp(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean; virtual;

Parameters

X
Type: Integer

Current mouse x coordinate.

Y
Type: Integer

Current mouse y coordinate.

Button
Type: TMouseButton

Mouse button.

Shift
Type: TShiftState

Shift buttons states.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.

Namespace: frxClass
Syntax
Delphi
public
 function DoMouseWheel(Shift: TShiftState;
 WheelDelta: Integer; MousePos: TPoint; var EventParams: TfrxInteractiveEventsParams): Boolean; virtual;

Parameters

Shift
Type: TShiftState

Shift buttons states.

WheelDelta
Type: Integer

Mouse wheel delta.

MousePos
Type: TPoint

Cursor position when event were fired.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.DrawCustomEditor(TCanvas,TRect) Method

Summary

Draws object editor over object canvas.

Namespace: frxClass
Syntax
Delphi
public
 procedure DrawCustomEditor(aCanvas: TCanvas; aRect: TRect); virtual;

Parameters

aCanvas
Type: TCanvas

Destination Canvas.

aRect
Type: TRect

Draw area.

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.EditInPlace(TComponent,TRect) Method

Summary

Represents method EditInPlace(TComponent,TRect).

Namespace: frxClass
Syntax
Delphi
public
 procedure EditInPlace(aParent: TComponent; aRect: TRect); virtual;

Parameters

aParent
Type: TComponent

aRect
Type: TRect

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.EditInPlaceDone Method

Summary

This method should close in place editor and apply changes to edited object.

Namespace: frxClass
Syntax
Delphi
public
 function EditInPlaceDone: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FillData Method

Summary

Not used.

Namespace: frxClass
Syntax
Delphi
public
 function FillData: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FinalizeUI(TfrxInteractiveEventsParams) Method

Summary

Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves.

Namespace: frxClass
Syntax
Delphi
public
 procedure FinalizeUI(var EventParams: TfrxInteractiveEventsParams); virtual;

Parameters

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.GetActiveRect Method

Summary

Returns active work area of the editor.

Namespace: frxClass
Syntax
Delphi
public
 function GetActiveRect: TRect; virtual;

Return Value

Type: TRect

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.HasCustomEditor Method

Summary

Not used.

Namespace: frxClass
Syntax
Delphi
public
 function HasCustomEditor: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.HasInPlaceEditor Method

Summary

Not used.

Namespace: frxClass
Syntax
Delphi
public
 function HasInPlaceEditor: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.InitializeUI(TfrxInteractiveEventsParams) Method

Summary

Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves.

Namespace: frxClass
Syntax
Delphi
public
 procedure InitializeUI(var EventParams: TfrxInteractiveEventsParams); virtual;

Parameters

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) Method

Namespace: frxClass
Syntax
Delphi
public
 function IsPasteAvailable(PasteTo: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; PasteAs: TfrxCopyPasteType = cptDefault): Boolean; virtual;

Parameters

PasteTo
Type: TfrxComponent

Reference to an object used to paste data.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

PasteAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) Method

Namespace: frxClass
Syntax
Delphi
public
 procedure PasteContent(PasteTo: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; Buffer: TStream; PasteAs: TfrxCopyPasteType = cptDefault); virtual;

Parameters

PasteTo
Type: TfrxComponent

Reference to an object used to paste data.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Buffer
Type: TStream

Temporary buffer for copy.

PasteAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) Method

Namespace: frxClass
Syntax
Delphi
public
 procedure PasteGoupContent(PasteTo: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; Buffer: TStream; PasteAs: TfrxCopyPasteType = cptDefault); virtual;

Parameters

PasteTo
Type: TfrxComponent

Reference to an object used to paste data.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Buffer
Type: TStream

Temporary buffer for copy.

PasteAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.SetComponent(TfrxComponent) Method

Summary

Represents method SetComponent(TfrxComponent).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetComponent(const Value: TfrxComponent);

Parameters

Value
Type: TfrxComponent

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.SetOffset(Extended,Extended,Extended) Method

Summary

Sets parameters used by the report preview or the report designer.

Namespace: frxClass
Syntax
Delphi
public
 procedure SetOffset(aOffsetX, aOffsetY, aScale: Extended);

Parameters

aOffsetX
Type: Extended

X offset of work area.

aOffsetY
Type: Extended

Y offset of work area.

aScale
Type: Extended

Scale of work area.

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor Events

Events
Name | Description
OnFinishInPlace | An event used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor.
Top


TfrxInPlaceEditor.OnFinishInPlace Event

Summary

An event used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor.

Namespace: frxClass
Syntax
Delphi
public
 property OnFinishInPlace: TfrxOnFinishInPlaceEdit read FOnFinishInPlace write FOnFinishInPlace;

Value

Type: TfrxOnFinishInPlaceEdit

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor Fields

Fields
Name | Description
FClassRef | Represents field FClassRef.
FClipboardObject | Represents field FClipboardObject.
FComponent | Represents field FComponent.
FComponents | Represents field FComponents.
FDevicePPI | Represents field FDevicePPI.
FEditors | Represents field FEditors.
FLocked | Represents field FLocked.
FOffsetX | Represents field FOffsetX.
FOffsetY | Represents field FOffsetY.
FOnFinishInPlace | Represents field FOnFinishInPlace.
FOwner | Represents field FOwner.
FParentComponent | Represents field FParentComponent.
FScale | Represents field FScale.
Top


TfrxInPlaceEditor.FClassRef Field

Summary

Represents field FClassRef.

Namespace: frxClass
Syntax
Delphi
protected
 FClassRef: TfrxComponentClass;

Field Value

Type: TfrxComponentClass

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FClipboardObject Field

Summary

Represents field FClipboardObject.

Namespace: frxClass
Syntax
Delphi
protected
 FClipboardObject: TPersistent;

Field Value

Type: TPersistent

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FComponent Field

Summary

Represents field FComponent.

Namespace: frxClass
Syntax
Delphi
protected
 FComponent: TfrxComponent;

Field Value

Type: TfrxComponent

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FComponents Field

Summary

Represents field FComponents.

Namespace: frxClass
Syntax
Delphi
protected
 FComponents: TfrxSelectedObjectsList;

Field Value

Type: TfrxSelectedObjectsList

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FDevicePPI Field

Summary

Represents field FDevicePPI.

Namespace: frxClass
Syntax
Delphi
protected
 FDevicePPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FEditors Field

Summary

Represents field FEditors.

Namespace: frxClass
Syntax
Delphi
protected
 FEditors: TfrxComponentEditorsList;

Field Value

Type: TfrxComponentEditorsList

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FLocked Field

Summary

Represents field FLocked.

Namespace: frxClass
Syntax
Delphi
protected
 FLocked: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FOffsetX Field

Summary

Represents field FOffsetX.

Namespace: frxClass
Syntax
Delphi
protected
 FOffsetX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FOffsetY Field

Summary

Represents field FOffsetY.

Namespace: frxClass
Syntax
Delphi
protected
 FOffsetY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FOnFinishInPlace Field

Summary

Represents field FOnFinishInPlace.

Namespace: frxClass
Syntax
Delphi
protected
 FOnFinishInPlace: TfrxOnFinishInPlaceEdit;

Field Value

Type: TfrxOnFinishInPlaceEdit

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FOwner Field

Summary

Represents field FOwner.

Namespace: frxClass
Syntax
Delphi
protected
 FOwner: TWinControl;

Field Value

Type: TWinControl

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FParentComponent Field

Summary

Represents field FParentComponent.

Namespace: frxClass
Syntax
Delphi
protected
 FParentComponent: TComponent;

Field Value

Type: TComponent

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxInPlaceEditor.FScale Field

Summary

Represents field FScale.

Namespace: frxClass
Syntax
Delphi
protected
 FScale: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxInPlaceEditor
  • frxClass


TfrxIOTransportFile Class

Summary

The class is the base IO transport filter class for all file operations. IO filters which work directly with files use this class as ancestor.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxCustomIOTransport
frxClass.TfrxIOTransportFile
frxClass.TfrxSaveToCompressedFilter
frxIOTransportDialog.TfrxIOTransportFileDialog
Syntax
Delphi
type
 TfrxIOTransportFile = class(TfrxCustomIOTransport)
 end;

The TfrxIOTransportFile type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxIOTransportFile class. (Overrides TfrxCustomIOTransport.Create(TComponent).)
CreateNoRegister | This constructor creates component without registration in global list so the filter will be hidden for preview or report designer. (Inherited from TfrxCustomIOTransport.)
Top
Properties
Show:
Name | Description
BasePath | Base path used in transport filter. (Inherited from TfrxCustomIOTransport.)
CreatedFrom | This flag shows where the current instance of the filter was created from. (Inherited from TfrxCustomIOTransport.)
CurrentContainer | Name of the current container. (Inherited from TfrxCustomIOTransport.)
DefaultExt | Default extension used in transport filter. (Inherited from TfrxCustomIOTransport.)
DefaultPath | Default path used in transport filter. (Inherited from TfrxCustomIOTransport.)
ExtDescription | Description for default extension used in transport filter. (Inherited from TfrxCustomIOTransport.)
FileName | File name for current filter. (Inherited from TfrxCustomIOTransport.)
FilterAccess | Access type of IO filter. (Inherited from TfrxCustomIOTransport.)
FilterString | Description of filter instance. (Inherited from TfrxCustomIOTransport.)
InternalFilter | Represents property InternalFilter. (Inherited from TfrxCustomIOTransport.)
OverwritePrompt | Represents property OverwritePrompt. (Inherited from TfrxCustomIOTransport.)
Report | Reference to a report component. (Inherited from TfrxCustomIOTransport.)
RootNode | Root node of the filter. (Inherited from TfrxCustomIOTransport.)
ShowDialog | Whether to display a print dialogue. Default value is True. (Inherited from TfrxCustomIOTransport.)
SupportedStreams | Supported stream type for current IO transport filter. (Inherited from TfrxCustomIOTransport.)
TempFilter | Returns reference to transport filter instance for temporary operations. (Inherited from TfrxCustomIOTransport.)
Visibility | These flags used in IO transports to define visibility of IO transport filter. By default each transport filter component registers in global list and these flags helps to sort items of the global list. (Inherited from TfrxCustomIOTransport.)
Top
Methods
Show:
Name | Description
AddContainer(TfrxNode) | Represents method AddContainer(TfrxNode). (Overrides TfrxCustomIOTransport.AddContainer(TfrxNode).)
AllInOneContainer | Returns true when physically all stream belongs to one container(zip archive). (Inherited from TfrxCustomIOTransport.)
AssignFilter(TfrxCustomIOTransport) | This method assigns properties of other transport filter to current. (Inherited from TfrxCustomIOTransport.)
AssignSharedProperties(TfrxCustomIOTransport) | This method assigns shared properties(like tokens) of other transport filter to current. (Inherited from TfrxCustomIOTransport.)
CloseAllStreams | The method closes all opened streams. (Inherited from TfrxCustomIOTransport.)
CloseFilter | This method can be called to close a filter. It uses to make finalization like close connection and streams. (Overrides TfrxCustomIOTransport.CloseFilter.)
CopyStreamsNames(TStrings,Boolean) | It copies names of steams in current transport to TStrings passed as a parameter. (Inherited from TfrxCustomIOTransport.)
CreateContainer(String,Boolean) | Creates a structure node represents a container or directory. (Inherited from TfrxCustomIOTransport.)
CreateFilterClone(TfrxFilterVisibleState) | Copy constructor. (Inherited from TfrxCustomIOTransport.)
CreateTempContainer | Creates a structure node represents a temporary container or directory. (Overrides TfrxCustomIOTransport.CreateTempContainer.)
DeleteContainer(String) | Deletes a structure node represents a container or directory. (Inherited from TfrxCustomIOTransport.)
DeleteFiles | Represents method DeleteFiles.
DoCreateStream(String,String) | Represents method DoCreateStream(String,String). (Overrides TfrxCustomIOTransport.DoCreateStream(String,String).)
DoFilterProcessStream(TStream,TObject) | This method call before loading from stream is started. Can be used to make a preparation of stream data before loading. (Inherited from TfrxCustomIOTransport.)
FreeStream(TStream,String) | Closes an opened stream by reference or name. (Inherited from TfrxCustomIOTransport.)
FreeTempContainer | Destroy a structure node represents a temporary container or directory. (Overrides TfrxCustomIOTransport.FreeTempContainer.)
GetDescription | Represents method GetDescription. (Overrides TfrxCustomIOTransport.GetDescription.)
GetFileNode | Returns nearest file node in current container. (Inherited from TfrxCustomIOTransport.)
GetFilterString | Represents method GetFilterString. (Inherited from TfrxCustomIOTransport.)
GetNodeFromPath(String,Boolean,Boolean) | Represents method GetNodeFromPath(String,Boolean,Boolean). (Inherited from TfrxCustomIOTransport.)
GetStream(String) | Returns stream by name of a node or a file. (Inherited from TfrxCustomIOTransport.)
GetVisibility | Represents method GetVisibility. (Inherited from TfrxCustomIOTransport.)
InitFromExport(TfrxCustomExportFilter) | Initialization of transport filter based on export filter settings(like file name and file extension). (Inherited from TfrxCustomIOTransport.)
LoadClosedStreams | Reloads all closed streams and open them again. (Inherited from TfrxCustomIOTransport.)
LoadStreamsList(TStrings) | Loads and opens steams from the list. (Inherited from TfrxCustomIOTransport.)
OpenFilter | This method can be called to open filter. It uses to make preparation like set connection or show user dialogs. It returns true when initialization was processed. (Overrides TfrxCustomIOTransport.OpenFilter.)
RemoveContainer(TfrxNode) | Represents method RemoveContainer(TfrxNode). (Inherited from TfrxCustomIOTransport.)
SetVisibility(TfrxFilterVisibility) | Represents method SetVisibility(TfrxFilterVisibility). (Overrides TfrxCustomIOTransport.SetVisibility(TfrxFilterVisibility).)
Top
Fields
Show:
Name | Description
FClosedLoadLock | Represents field FClosedLoadLock. (Inherited from TfrxCustomIOTransport.)
FCreatedFrom | Represents field FCreatedFrom. (Inherited from TfrxCustomIOTransport.)
FDirTree | Represents field FDirTree. (Inherited from TfrxCustomIOTransport.)
FFreeStream | Represents field FFreeStream. (Inherited from TfrxCustomIOTransport.)
FInternalFilter | Represents field FInternalFilter. (Inherited from TfrxCustomIOTransport.)
FNoRegister | Represents field FNoRegister. (Inherited from TfrxCustomIOTransport.)
FOriginalCopy | Represents field FOriginalCopy. (Inherited from TfrxCustomIOTransport.)
FSupportedStreams | Represents field FSupportedStreams. (Inherited from TfrxCustomIOTransport.)
FTempFolderCreated | Represents field FTempFolderCreated.
FVisibility | Represents field FVisibility. (Inherited from TfrxCustomIOTransport.)
Top
See Also

Reference

  • frxClass


TfrxIOTransportFile Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxIOTransportFile class. (Overrides TfrxCustomIOTransport.Create(TComponent).)
Top


TfrxIOTransportFile.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxIOTransportFile class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomIOTransport.Create(TComponent)
See Also

Reference

  • TfrxIOTransportFile
  • frxClass


TfrxIOTransportFile Methods

Methods
Name | Description
AddContainer(TfrxNode) | Represents method AddContainer(TfrxNode). (Overrides TfrxCustomIOTransport.AddContainer(TfrxNode).)
CloseFilter | This method can be called to close a filter. It uses to make finalization like close connection and streams. (Overrides TfrxCustomIOTransport.CloseFilter.)
CreateTempContainer | Creates a structure node represents a temporary container or directory. (Overrides TfrxCustomIOTransport.CreateTempContainer.)
DeleteFiles | Represents method DeleteFiles.
DoCreateStream(String,String) | Represents method DoCreateStream(String,String). (Overrides TfrxCustomIOTransport.DoCreateStream(String,String).)
FreeTempContainer | Destroy a structure node represents a temporary container or directory. (Overrides TfrxCustomIOTransport.FreeTempContainer.)
GetDescription | Represents method GetDescription. (Overrides TfrxCustomIOTransport.GetDescription.)
OpenFilter | This method can be called to open filter. It uses to make preparation like set connection or show user dialogs. It returns true when initialization was processed. (Overrides TfrxCustomIOTransport.OpenFilter.)
SetVisibility(TfrxFilterVisibility) | Represents method SetVisibility(TfrxFilterVisibility). (Overrides TfrxCustomIOTransport.SetVisibility(TfrxFilterVisibility).)
Top


TfrxIOTransportFile.AddContainer(TfrxNode) Method

Summary

Represents method AddContainer(TfrxNode).

Namespace: frxClass
Syntax
Delphi
protected
 function AddContainer(Item: TfrxNode): Boolean; override;

Parameters

Item
Type: TfrxNode

Return Value

Type: Boolean

Overrides

TfrxCustomIOTransport.AddContainer(TfrxNode)
See Also

Reference

  • TfrxIOTransportFile
  • frxClass


TfrxIOTransportFile.CloseFilter Method

Summary

This method can be called to close a filter. It uses to make finalization like close connection and streams.

Namespace: frxClass
Syntax
Delphi
public
 procedure CloseFilter; override;

Overrides

TfrxCustomIOTransport.CloseFilter
See Also

Reference

  • TfrxIOTransportFile
  • frxClass


TfrxIOTransportFile.CreateTempContainer Method

Summary

Creates a structure node represents a temporary container or directory.

Namespace: frxClass
Syntax
Delphi
public
 procedure CreateTempContainer; override;

Overrides

TfrxCustomIOTransport.CreateTempContainer
See Also

Reference

  • TfrxIOTransportFile
  • frxClass


TfrxIOTransportFile.DeleteFiles Method

Summary

Represents method DeleteFiles.

Namespace: frxClass
Syntax
Delphi
protected
 procedure DeleteFiles;
See Also

Reference

  • TfrxIOTransportFile
  • frxClass


TfrxIOTransportFile.DoCreateStream(String,String) Method

Summary

Represents method DoCreateStream(String,String).

Namespace: frxClass
Syntax
Delphi
public
 function DoCreateStream(var aFullFilePath: String; aFileName: String): TStream; override;

Parameters

aFullFilePath
Type: String

aFileName
Type: String

Return Value

Type: TStream

Overrides

TfrxCustomIOTransport.DoCreateStream(String,String)
See Also

Reference

  • TfrxIOTransportFile
  • frxClass


TfrxIOTransportFile.FreeTempContainer Method

Summary

Destroy a structure node represents a temporary container or directory.

Namespace: frxClass
Syntax
Delphi
public
 procedure FreeTempContainer; override;

Overrides

TfrxCustomIOTransport.FreeTempContainer
See Also

Reference

  • TfrxIOTransportFile
  • frxClass


TfrxIOTransportFile.GetDescription Method

Summary

Represents method GetDescription.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxCustomIOTransport.GetDescription
See Also

Reference

  • TfrxIOTransportFile
  • frxClass


TfrxIOTransportFile.OpenFilter Method

Summary

This method can be called to open filter. It uses to make preparation like set connection or show user dialogs. It returns true when initialization was processed.

Namespace: frxClass
Syntax
Delphi
public
 function OpenFilter: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCustomIOTransport.OpenFilter
See Also

Reference

  • TfrxIOTransportFile
  • frxClass


TfrxIOTransportFile.SetVisibility(TfrxFilterVisibility) Method

Summary

Represents method SetVisibility(TfrxFilterVisibility).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetVisibility(const Value: TfrxFilterVisibility); override;

Parameters

Value
Type: TfrxFilterVisibility

Overrides

TfrxCustomIOTransport.SetVisibility(TfrxFilterVisibility)
See Also

Reference

  • TfrxIOTransportFile
  • frxClass


TfrxIOTransportFile Fields

Fields
Name | Description
FTempFolderCreated | Represents field FTempFolderCreated.
Top


TfrxIOTransportFile.FTempFolderCreated Field

Summary

Represents field FTempFolderCreated.

Namespace: frxClass
Syntax
Delphi
private
 FTempFolderCreated: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxIOTransportFile
  • frxClass


TfrxKeyEvent Class

Summary

Represents type TfrxKeyEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxKeyEvent = type String;
See Also

Reference

  • frxClass


TfrxKeyPressEvent Class

Summary

Represents type TfrxKeyPressEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxKeyPressEvent = type String;
See Also

Reference

  • frxClass


TfrxLineView Class

Summary

The TfrxLineView class represents the "Line" object. It can show a horizontal, vertical or diagonal line.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxClass.TfrxCustomLineView
frxClass.TfrxLineView
Syntax
Delphi
type
 TfrxLineView = class(TfrxCustomLineView)
 end;

The TfrxLineView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomLineView class. (Overrides TfrxStretcheable.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Overrides TfrxComponent.DesignCreate(TComponent,Word).)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
ArrowEnd | Represents property ArrowEnd.
ArrowLength | Represents property ArrowLength.
ArrowSolid | Represents property ArrowSolid.
ArrowStart | Represents property ArrowStart.
ArrowWidth | Represents property ArrowWidth.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
CanShrink | True if object can shrink height base on its content. (Inherited from TfrxStretcheable.)
Color | Color of the shape. (Inherited from TfrxCustomLineView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Object's cursor (in the preview mode). (Inherited from TfrxView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Diagonal | Represents property Diagonal.
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StretchMode | Object's stretch mode. (Inherited from TfrxStretcheable.)
TagStr | Represents property TagStr. (Inherited from TfrxCustomLineView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Inherited from TfrxStretcheable.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable. (Inherited from TfrxStretcheable.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxReportComponent.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Overrides TfrxView.GetVectorGraphic(Boolean).)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Inherited from TfrxStretcheable.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object. (Inherited from TfrxStretcheable.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Overrides TfrxComponent.IsInRect(TfrxRect).)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FSavedTop | Internal use only. Stores original top during shift operation. (Inherited from TfrxStretcheable.)
FSaveHeight | Internal use only. Stores object Height during stretch operation. (Inherited from TfrxStretcheable.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxClass


TfrxLineView Properties

Properties
Name | Description
ArrowEnd | Represents property ArrowEnd.
ArrowLength | Represents property ArrowLength.
ArrowSolid | Represents property ArrowSolid.
ArrowStart | Represents property ArrowStart.
ArrowWidth | Represents property ArrowWidth.
Diagonal | Represents property Diagonal.
Frame | Represents property Frame.
Top


TfrxLineView.ArrowEnd Property

Summary

Represents property ArrowEnd.

Namespace: frxClass
Syntax
Delphi
published
 property ArrowEnd;

Property Value

Type: Void

See Also

Reference

  • TfrxLineView
  • frxClass


TfrxLineView.ArrowLength Property

Summary

Represents property ArrowLength.

Namespace: frxClass
Syntax
Delphi
published
 property ArrowLength;

Property Value

Type: Void

See Also

Reference

  • TfrxLineView
  • frxClass


TfrxLineView.ArrowSolid Property

Summary

Represents property ArrowSolid.

Namespace: frxClass
Syntax
Delphi
published
 property ArrowSolid;

Property Value

Type: Void

See Also

Reference

  • TfrxLineView
  • frxClass


TfrxLineView.ArrowStart Property

Summary

Represents property ArrowStart.

Namespace: frxClass
Syntax
Delphi
published
 property ArrowStart;

Property Value

Type: Void

See Also

Reference

  • TfrxLineView
  • frxClass


TfrxLineView.ArrowWidth Property

Summary

Represents property ArrowWidth.

Namespace: frxClass
Syntax
Delphi
published
 property ArrowWidth;

Property Value

Type: Void

See Also

Reference

  • TfrxLineView
  • frxClass


TfrxLineView.Diagonal Property

Summary

Represents property Diagonal.

Namespace: frxClass
Syntax
Delphi
published
 property Diagonal;

Property Value

Type: Void

See Also

Reference

  • TfrxLineView
  • frxClass


TfrxLineView.Frame Property

Summary

Represents property Frame.

Namespace: frxClass
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxLineView
  • frxClass


TfrxLineView Methods

Methods
Name | Description
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
Top


TfrxLineView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxLineView
  • frxClass


TfrxLoadFromCommand Class

Summary

This class implements realization of deferred LoadFrom command.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxBaseDelayedCommand
frxClass.TfrxLoadFromCommand
Syntax
Delphi
type
 TfrxLoadFromCommand = class(TfrxBaseDelayedCommand)
 end;

The TfrxLoadFromCommand type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport,TfrxCustomIOTransport,String) | LoadFrom command constructor.
Destroy | Represents the destructor of the TfrxLoadFromCommand class.
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseDelayedCommand.)
GetInstance | Get command instance. (Inherited from TfrxBaseDelayedCommand.)
GetName | Get symbolic name of current command instance. (Inherited from TfrxBaseDelayedCommand.)
QueryInterface(TGUID,Void) | Represents method QueryInterface(TGUID,Void). (Inherited from TfrxBaseDelayedCommand.)
Run | Runs command. (Overrides TfrxBaseDelayedCommand.Run.)
_AddRef | Represents method _AddRef. (Inherited from TfrxBaseDelayedCommand.)
_Release | Represents method _Release. (Inherited from TfrxBaseDelayedCommand.)
Top
Fields
Show:
Name | Description
FFileName | Represents field FFileName.
FReport | Represents field FReport.
FTransport | Represents field FTransport.
Top
See Also

Reference

  • frxClass


TfrxLoadFromCommand Constructors

Constructors
Name | Description
Create(TfrxReport,TfrxCustomIOTransport,String) | LoadFrom command constructor.
Destroy | Represents the destructor of the TfrxLoadFromCommand class.
Top


TfrxLoadFromCommand.Create(TfrxReport,TfrxCustomIOTransport,String) Constructor

Summary

LoadFrom command constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AReport: TfrxReport; Transport: TfrxCustomIOTransport; const FileName: String);

Parameters

AReport
Type: TfrxReport

Reference to a report component.

Transport
Type: TfrxCustomIOTransport

Reference to a IO transport used for file operations(command creates copy of it in constructor).

FileName
Type: String

File name.

See Also

Reference

  • TfrxLoadFromCommand
  • frxClass


TfrxLoadFromCommand.Destroy Destructor

Summary

Represents the destructor of the TfrxLoadFromCommand class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxLoadFromCommand
  • frxClass


TfrxLoadFromCommand Methods

Methods
Name | Description
Run | Runs command. (Overrides TfrxBaseDelayedCommand.Run.)
Top


TfrxLoadFromCommand.Run Method

Summary

Runs command.

Namespace: frxClass
Syntax
Delphi
public
 procedure Run; override;

Overrides

TfrxBaseDelayedCommand.Run
See Also

Reference

  • TfrxLoadFromCommand
  • frxClass


TfrxLoadFromCommand Fields

Fields
Name | Description
FFileName | Represents field FFileName.
FReport | Represents field FReport.
FTransport | Represents field FTransport.
Top


TfrxLoadFromCommand.FFileName Field

Summary

Represents field FFileName.

Namespace: frxClass
Syntax
Delphi
private
 FFileName: String;

Field Value

Type: String

See Also

Reference

  • TfrxLoadFromCommand
  • frxClass


TfrxLoadFromCommand.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxLoadFromCommand
  • frxClass


TfrxLoadFromCommand.FTransport Field

Summary

Represents field FTransport.

Namespace: frxClass
Syntax
Delphi
private
 FTransport: TfrxCustomIOTransport;

Field Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxLoadFromCommand
  • frxClass


TfrxLoadFromFileCommand Class

Summary

This class implements realization of deferred LoadFromFile command.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxBaseDelayedCommand
frxClass.TfrxLoadFromFileCommand
Syntax
Delphi
type
 TfrxLoadFromFileCommand = class(TfrxBaseDelayedCommand)
 end;

The TfrxLoadFromFileCommand type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport,String,Boolean) | LoadFromFile command constructor.
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseDelayedCommand.)
GetInstance | Get command instance. (Inherited from TfrxBaseDelayedCommand.)
GetName | Get symbolic name of current command instance. (Inherited from TfrxBaseDelayedCommand.)
QueryInterface(TGUID,Void) | Represents method QueryInterface(TGUID,Void). (Inherited from TfrxBaseDelayedCommand.)
Run | Runs command. (Overrides TfrxBaseDelayedCommand.Run.)
_AddRef | Represents method _AddRef. (Inherited from TfrxBaseDelayedCommand.)
_Release | Represents method _Release. (Inherited from TfrxBaseDelayedCommand.)
Top
Fields
Show:
Name | Description
FExceptionIfNotFound | Represents field FExceptionIfNotFound.
FFileName | Represents field FFileName.
FReport | Represents field FReport.
Top
See Also

Reference

  • frxClass


TfrxLoadFromFileCommand Constructors

Constructors
Name | Description
Create(TfrxReport,String,Boolean) | LoadFromFile command constructor.
Top


TfrxLoadFromFileCommand.Create(TfrxReport,String,Boolean) Constructor

Summary

LoadFromFile command constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AReport: TfrxReport; const FileName: String; ExceptionIfNotFound: Boolean);

Parameters

AReport
Type: TfrxReport

Reference to a report component.

FileName
Type: String

File name.

ExceptionIfNotFound
Type: Boolean

Generates exception if file now found. LoadFromFile parameter.

See Also

Reference

  • TfrxLoadFromFileCommand
  • frxClass


TfrxLoadFromFileCommand Methods

Methods
Name | Description
Run | Runs command. (Overrides TfrxBaseDelayedCommand.Run.)
Top


TfrxLoadFromFileCommand.Run Method

Summary

Runs command.

Namespace: frxClass
Syntax
Delphi
public
 procedure Run; override;

Overrides

TfrxBaseDelayedCommand.Run
See Also

Reference

  • TfrxLoadFromFileCommand
  • frxClass


TfrxLoadFromFileCommand Fields

Fields
Name | Description
FExceptionIfNotFound | Represents field FExceptionIfNotFound.
FFileName | Represents field FFileName.
FReport | Represents field FReport.
Top


TfrxLoadFromFileCommand.FExceptionIfNotFound Field

Summary

Represents field FExceptionIfNotFound.

Namespace: frxClass
Syntax
Delphi
private
 FExceptionIfNotFound: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxLoadFromFileCommand
  • frxClass


TfrxLoadFromFileCommand.FFileName Field

Summary

Represents field FFileName.

Namespace: frxClass
Syntax
Delphi
private
 FFileName: String;

Field Value

Type: String

See Also

Reference

  • TfrxLoadFromFileCommand
  • frxClass


TfrxLoadFromFileCommand.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxLoadFromFileCommand
  • frxClass


TfrxLoadFromStreamCommand Class

Summary

This class implements realization of deferred LoadFromStream command.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxBaseDelayedCommand
frxClass.TfrxLoadFromStreamCommand
Syntax
Delphi
type
 TfrxLoadFromStreamCommand = class(TfrxBaseDelayedCommand)
 end;

The TfrxLoadFromStreamCommand type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport,TStream) | LoadFromStream command constructor.
Destroy | Represents the destructor of the TfrxLoadFromStreamCommand class.
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseDelayedCommand.)
GetInstance | Get command instance. (Inherited from TfrxBaseDelayedCommand.)
GetName | Get symbolic name of current command instance. (Inherited from TfrxBaseDelayedCommand.)
QueryInterface(TGUID,Void) | Represents method QueryInterface(TGUID,Void). (Inherited from TfrxBaseDelayedCommand.)
Run | Runs command. (Overrides TfrxBaseDelayedCommand.Run.)
_AddRef | Represents method _AddRef. (Inherited from TfrxBaseDelayedCommand.)
_Release | Represents method _Release. (Inherited from TfrxBaseDelayedCommand.)
Top
Fields
Show:
Name | Description
FReport | Represents field FReport.
FStream | Represents field FStream.
Top
See Also

Reference

  • frxClass


TfrxLoadFromStreamCommand Constructors

Constructors
Name | Description
Create(TfrxReport,TStream) | LoadFromStream command constructor.
Destroy | Represents the destructor of the TfrxLoadFromStreamCommand class.
Top


TfrxLoadFromStreamCommand.Create(TfrxReport,TStream) Constructor

Summary

LoadFromStream command constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AReport: TfrxReport; Stream: TStream);

Parameters

AReport
Type: TfrxReport

Reference to a report component.

Stream
Type: TStream

Source stream(Command constructor creates a copy of in in memory).

See Also

Reference

  • TfrxLoadFromStreamCommand
  • frxClass


TfrxLoadFromStreamCommand.Destroy Destructor

Summary

Represents the destructor of the TfrxLoadFromStreamCommand class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxLoadFromStreamCommand
  • frxClass


TfrxLoadFromStreamCommand Methods

Methods
Name | Description
Run | Runs command. (Overrides TfrxBaseDelayedCommand.Run.)
Top


TfrxLoadFromStreamCommand.Run Method

Summary

Runs command.

Namespace: frxClass
Syntax
Delphi
public
 procedure Run; override;

Overrides

TfrxBaseDelayedCommand.Run
See Also

Reference

  • TfrxLoadFromStreamCommand
  • frxClass


TfrxLoadFromStreamCommand Fields

Fields
Name | Description
FReport | Represents field FReport.
FStream | Represents field FStream.
Top


TfrxLoadFromStreamCommand.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxLoadFromStreamCommand
  • frxClass


TfrxLoadFromStreamCommand.FStream Field

Summary

Represents field FStream.

Namespace: frxClass
Syntax
Delphi
private
 FStream: TMemoryStream;

Field Value

Type: TMemoryStream

See Also

Reference

  • TfrxLoadFromStreamCommand
  • frxClass


TfrxMacrosItem Class

Summary

Internal class used by data processing engine. Stores values for post processor.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxMacrosItem
Syntax
Delphi
type
 TfrxMacrosItem = class(TObject)
 end;

The TfrxMacrosItem type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxMacrosItem class.
Destroy | Represents the destructor of the TfrxMacrosItem class.
Top
Properties
Show:
Name | Description
Item[Integer] | Represents property Item[Integer].
Top
Methods
Show:
Name | Description
AddObject(WideString,TObject,Boolean) | Represents method AddObject(WideString,TObject,Boolean).
Count | Represents method Count.
GetItem(Integer) | Represents method GetItem(Integer).
SetItem(Integer,WideString) | Represents method SetItem(Integer,WideString).
Top
Fields
Show:
Name | Description
FBandName | Represents field FBandName.
FBaseComponent | Represents field FBaseComponent.
FComponent | Represents field FComponent.
FDataLevel | Represents field FDataLevel.
FGroupLevel | Represents field FGroupLevel.
FItems | Represents field FItems.
FLastIndex | Represents field FLastIndex.
FNeedReset | Represents field FNeedReset.
FParent | Represents field FParent.
FProcessAt | Represents field FProcessAt.
FSupressedValue | Represents field FSupressedValue.
Top
See Also

Reference

  • frxClass


TfrxMacrosItem Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxMacrosItem class.
Destroy | Represents the destructor of the TfrxMacrosItem class.
Top


TfrxMacrosItem.Create Constructor

Summary

Initializes a new instance of the TfrxMacrosItem class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.Destroy Destructor

Summary

Represents the destructor of the TfrxMacrosItem class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem Properties

Properties
Name | Description
Item[Integer] | Represents property Item[Integer].
Top


TfrxMacrosItem.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: frxClass
Syntax
Delphi
public
 property Item[Index: Integer]: WideString read GetItem write SetItem;

Parameters

Index
Type: Integer

Property Value

Type: WideString

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem Methods

Methods
Name | Description
AddObject(WideString,TObject,Boolean) | Represents method AddObject(WideString,TObject,Boolean).
Count | Represents method Count.
GetItem(Integer) | Represents method GetItem(Integer).
SetItem(Integer,WideString) | Represents method SetItem(Integer,WideString).
Top


TfrxMacrosItem.AddObject(WideString,TObject,Boolean) Method

Summary

Represents method AddObject(WideString,TObject,Boolean).

Namespace: frxClass
Syntax
Delphi
public
 function AddObject(const S: WideString; AObject: TObject; bSupressed: Boolean = false): Integer;

Parameters

S
Type: WideString

AObject
Type: TObject

bSupressed
Type: Boolean

Return Value

Type: Integer

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.Count Method

Summary

Represents method Count.

Namespace: frxClass
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetItem(Index: Integer): WideString;

Parameters

Index
Type: Integer

Return Value

Type: WideString

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.SetItem(Integer,WideString) Method

Summary

Represents method SetItem(Integer,WideString).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetItem(Index: Integer; const Value: WideString);

Parameters

Index
Type: Integer

Value
Type: WideString

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem Fields

Fields
Name | Description
FBandName | Represents field FBandName.
FBaseComponent | Represents field FBaseComponent.
FComponent | Represents field FComponent.
FDataLevel | Represents field FDataLevel.
FGroupLevel | Represents field FGroupLevel.
FItems | Represents field FItems.
FLastIndex | Represents field FLastIndex.
FNeedReset | Represents field FNeedReset.
FParent | Represents field FParent.
FProcessAt | Represents field FProcessAt.
FSupressedValue | Represents field FSupressedValue.
Top


TfrxMacrosItem.FBandName Field

Summary

Represents field FBandName.

Namespace: frxClass
Syntax
Delphi
private
 FBandName: String;

Field Value

Type: String

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.FBaseComponent Field

Summary

Represents field FBaseComponent.

Namespace: frxClass
Syntax
Delphi
private
 FBaseComponent: TfrxComponent;

Field Value

Type: TfrxComponent

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.FComponent Field

Summary

Represents field FComponent.

Namespace: frxClass
Syntax
Delphi
private
 FComponent: TfrxComponent;

Field Value

Type: TfrxComponent

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.FDataLevel Field

Summary

Represents field FDataLevel.

Namespace: frxClass
Syntax
Delphi
private
 FDataLevel: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.FGroupLevel Field

Summary

Represents field FGroupLevel.

Namespace: frxClass
Syntax
Delphi
private
 FGroupLevel: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.FItems Field

Summary

Represents field FItems.

Namespace: frxClass
Syntax
Delphi
private
 FItems: TWideStrings;

Field Value

Type: TWideStrings

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.FLastIndex Field

Summary

Represents field FLastIndex.

Namespace: frxClass
Syntax
Delphi
private
 FLastIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.FNeedReset Field

Summary

Represents field FNeedReset.

Namespace: frxClass
Syntax
Delphi
private
 FNeedReset: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.FParent Field

Summary

Represents field FParent.

Namespace: frxClass
Syntax
Delphi
private
 FParent: TfrxPostProcessor;

Field Value

Type: TfrxPostProcessor

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.FProcessAt Field

Summary

Represents field FProcessAt.

Namespace: frxClass
Syntax
Delphi
private
 FProcessAt: TfrxProcessAtMode;

Field Value

Type: TfrxProcessAtMode

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMacrosItem.FSupressedValue Field

Summary

Represents field FSupressedValue.

Namespace: frxClass
Syntax
Delphi
private
 FSupressedValue: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxMacrosItem
  • frxClass


TfrxMasterData Class

Summary

The TfrxMasterData represents a "Master data" band.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxDataBand
frxClass.TfrxMasterData
Syntax
Delphi
type
 TfrxMasterData = class(TfrxDataBand)
 end;

The TfrxMasterData type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataBand class. (Overrides TfrxBand.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit. (Inherited from TfrxDataBand.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child. (Inherited from TfrxDataBand.)
ColumnGap | Gap between band's columns, in pixels. (Inherited from TfrxDataBand.)
Columns | The "Columns" property, available in all data-bands, allows to set number of columns for a particular band and not for the whole page. Thus, displaying of data will be not "from the top to the bottom, then from the left to the right," but "from left to right, then from top to bottom". You also should set ColumnWidth and ColumnGap properties. (Inherited from TfrxDataBand.)
ColumnWidth | Width of the band's column, in pixels. (Inherited from TfrxDataBand.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
CurColumn | Current column of the band. (Inherited from TfrxDataBand.)
DataSet | Dataset for a band. (Inherited from TfrxDataBand.)
DataSetName | Dataset name for a band. This property duplicates the DataSet property. (Inherited from TfrxDataBand.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Filter | An expression used to manage visibility of a band record. if result of this expression is True, band will be shown. (Inherited from TfrxDataBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
FooterAfterEach | Determines whether to show band footer after each record. Default value is False. By default the footer is displayed after printing all dataset records. (Inherited from TfrxDataBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False. (Inherited from TfrxDataBand.)
KeepFooter | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False. (Inherited from TfrxDataBand.)
KeepHeader | Determines whether to show band header on the same page as the banditself. If header does not find room on the page, it will be carriedto the next page. Default value is False. (Inherited from TfrxDataBand.)
KeepTogether | Determines whether to print the band together with all its subbands on the same page. Default value is False. (Inherited from TfrxDataBand.)
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnMasterDetail | Name of the script procedure that will be called before the band will check if any subbands are empty. (Inherited from TfrxDataBand.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | Represents property OutlineText. (Inherited from TfrxDataBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible. (Inherited from TfrxDataBand.)
PrintIfDetailEmpty | Determines whether to print the band if all its subbands are empty. Default value is False. (Inherited from TfrxDataBand.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
RowCount | Allows printing the band N times. This property is used if the band is NOT connected to the dataset. (Inherited from TfrxDataBand.)
ShiftEngine | Represents property ShiftEngine. (Inherited from TfrxDataBand.)
StartNewPage | Represents property StartNewPage. (Inherited from TfrxDataBand.)
Stretched | Represents property Stretched. (Inherited from TfrxDataBand.)
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
VirtualDataSet | Represents property VirtualDataSet. (Inherited from TfrxDataBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Overrides TfrxBand.GetBandTitleColor.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxBand.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxBand.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FMaxY | Represents field FMaxY. (Inherited from TfrxDataBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxMemoView Class

Summary

The TfrxMemoView class represents the "Text" object that can show multiline text in a rectangular area.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxClass.TfrxCustomMemoView
frxClass.TfrxMemoView
Syntax
Delphi
type
 TfrxMemoView = class(TfrxCustomMemoView)
 end;

The TfrxMemoView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomMemoView class. (Overrides TfrxStretcheable.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowExpressions | Represents property AllowExpressions.
AllowHTMLTags | Represents property AllowHTMLTags.
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
AnsiText | Text of the object in ANSI format based on current Locale settings. (Inherited from TfrxCustomMemoView.)
AutoWidth | Represents property AutoWidth.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Represents property BrushStyle.
CanShrink | True if object can shrink height base on its content. (Inherited from TfrxStretcheable.)
CharSpacing | Represents property CharSpacing.
Clipped | Represents property Clipped.
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor. (Inherited from TfrxCustomMemoView.)
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DisplayFormat | Represents property DisplayFormat.
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Duplicates | Represents property Duplicates.
ExpressionDelimiters | Represents property ExpressionDelimiters.
Fill | Represents property Fill.
FillType | Represents property FillType.
FirstParaBreak | Internal use. Determines first paragraph break if object where split. (Inherited from TfrxCustomMemoView.)
FlowTo | Represents property FlowTo.
Font | Represents property Font.
Formats | Collection of Formats. The object can hold several formats for each expression inside an object. (Inherited from TfrxCustomMemoView.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GapX | Represents property GapX.
GapY | Represents property GapY.
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
HAlign | Represents property HAlign.
Height | Represents property Height. (Inherited from TfrxView.)
HideZeros | Represents property HideZeros.
Highlight | Represents property Highlight.
Highlights | Collection of Highlights. The object can hold several highlights which serves different conditions. (Inherited from TfrxCustomMemoView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LastParaBreak | Internal use. Determines last paragraph break if object where split. (Inherited from TfrxCustomMemoView.)
Left | Represents property Left. (Inherited from TfrxView.)
Lines | Text lines of the object. (Inherited from TfrxCustomMemoView.)
LineSpacing | Represents property LineSpacing.
Memo | Represents property Memo.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
ParagraphGap | Represents property ParagraphGap.
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont.
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Represents property Processing.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
Rotation | Represents property Rotation.
RTLReading | Represents property RTLReading.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StretchMode | Object's stretch mode. (Inherited from TfrxStretcheable.)
Style | Represents property Style.
SuppressRepeated | Represents property SuppressRepeated.
TagStr | Represents property TagStr. (Inherited from TfrxCustomMemoView.)
Text | Text of the object. (Inherited from TfrxCustomMemoView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Underlines | Represents property Underlines.
UnderlinesTextMode | Represents property UnderlinesTextMode.
URL | Represents property URL. (Inherited from TfrxCustomMemoView.)
UseDefaultCharset | Represents property UseDefaultCharset.
VAlign | Represents property VAlign.
Value | Stores value of Format operation(for single expression or DataSet only) with respect of its type. (Inherited from TfrxCustomMemoView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
WordBreak | Represents property WordBreak.
WordWrap | Represents property WordWrap.
Wysiwyg | Represents property Wysiwyg.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxView.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
ApplyHighlight(TfrxHighlight) | Apply Highlight to object. (Inherited from TfrxCustomMemoView.)
ApplyPreviewHighlight | Apply active highlight for object in prepared report. (Inherited from TfrxCustomMemoView.)
ApplyStyle(TfrxStyleItem) | Applies the given style to the object. (Inherited from TfrxCustomMemoView.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Overrides TfrxView.BeginDraw(TCanvas,Extended,Extended,Extended,Extended).)
CalcAndFormat(WideString,TfrxFormat) | Represents method CalcAndFormat(WideString,TfrxFormat). (Inherited from TfrxCustomMemoView.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxStretcheable.CalcHeight.)
CalcTextRect(Extended,Extended,Extended,Extended) | Represents method CalcTextRect(Extended,Extended,Extended,Extended). (Inherited from TfrxCustomMemoView.)
CalcWidth | Calculates and returns the object's width, in pixels. (Inherited from TfrxCustomMemoView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxCustomMemoView.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxStretcheable.DrawPart.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawText | Represents method DrawText. (Inherited from TfrxCustomMemoView.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
ExtractMacros(TfrxPostProcessor) | Extract macros from the object text and replaces them with values. (Inherited from TfrxCustomMemoView.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
FormatData(Variant,TfrxFormat) | Formats the value passed in the "Value" parameter and returns the result as a string. This method is used format settings stored in the DisplayFormat property. If AFormat parameter is set, it is used for formatting instead of DisplayFormat property. (Inherited from TfrxCustomMemoView.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Overrides TfrxReportComponent.GetComponentText.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Inherited from TfrxStretcheable.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object. (Overrides TfrxStretcheable.InitPart.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Overrides TfrxView.IsPostProcessAllowed.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
Loaded | Represents method Loaded. (Inherited from TfrxCustomMemoView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxView.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.ReadNestedProperty(TfrxXMLItem).)
ReducedAngle | Normalize angle to 360 degrees. (Inherited from TfrxCustomMemoView.)
ResetSuppress | Deprecated. Reset suppressed values. (Inherited from TfrxCustomMemoView.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetDrawParams(TCanvas,Extended,Extended,Extended,Extended) | Represents method SetDrawParams(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxCustomMemoView.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WrapText(Boolean,TWideStrings) | Breaks the text so all strings would fit in the object's width, and returns the resulting text. (Inherited from TfrxCustomMemoView.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.WriteNestedProperties(TfrxXMLItem,TPersistent).)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCopyNo | Represents field FCopyNo. (Inherited from TfrxCustomMemoView.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLastValue | Represents field FLastValue. (Inherited from TfrxCustomMemoView.)
FMacroIndex | Represents field FMacroIndex. (Inherited from TfrxCustomMemoView.)
FMacroLine | Represents field FMacroLine. (Inherited from TfrxCustomMemoView.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintScale | Represents field FPrintScale. (Inherited from TfrxCustomMemoView.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FSavedTop | Internal use only. Stores original top during shift operation. (Inherited from TfrxStretcheable.)
FSaveHeight | Internal use only. Stores object Height during stretch operation. (Inherited from TfrxStretcheable.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FTextRect | Represents field FTextRect. (Inherited from TfrxCustomMemoView.)
FTotalPages | Represents field FTotalPages. (Inherited from TfrxCustomMemoView.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxClass


TfrxMemoView Properties

Properties
Name | Description
AllowExpressions | Represents property AllowExpressions.
AllowHTMLTags | Represents property AllowHTMLTags.
AutoWidth | Represents property AutoWidth.
BrushStyle | Represents property BrushStyle.
CharSpacing | Represents property CharSpacing.
Clipped | Represents property Clipped.
Color | Represents property Color.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
DisplayFormat | Represents property DisplayFormat.
Duplicates | Represents property Duplicates.
ExpressionDelimiters | Represents property ExpressionDelimiters.
Fill | Represents property Fill.
FillType | Represents property FillType.
FlowTo | Represents property FlowTo.
Font | Represents property Font.
Frame | Represents property Frame.
GapX | Represents property GapX.
GapY | Represents property GapY.
HAlign | Represents property HAlign.
HideZeros | Represents property HideZeros.
Highlight | Represents property Highlight.
LineSpacing | Represents property LineSpacing.
Memo | Represents property Memo.
ParagraphGap | Represents property ParagraphGap.
ParentFont | Represents property ParentFont.
Processing | Represents property Processing.
Rotation | Represents property Rotation.
RTLReading | Represents property RTLReading.
Style | Represents property Style.
SuppressRepeated | Represents property SuppressRepeated.
Underlines | Represents property Underlines.
UnderlinesTextMode | Represents property UnderlinesTextMode.
UseDefaultCharset | Represents property UseDefaultCharset.
VAlign | Represents property VAlign.
WordBreak | Represents property WordBreak.
WordWrap | Represents property WordWrap.
Wysiwyg | Represents property Wysiwyg.
Top


TfrxMemoView.AllowExpressions Property

Summary

Represents property AllowExpressions.

Namespace: frxClass
Syntax
Delphi
published
 property AllowExpressions;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.AllowHTMLTags Property

Summary

Represents property AllowHTMLTags.

Namespace: frxClass
Syntax
Delphi
published
 property AllowHTMLTags;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.AutoWidth Property

Summary

Represents property AutoWidth.

Namespace: frxClass
Syntax
Delphi
published
 property AutoWidth;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.BrushStyle Property

Summary

Represents property BrushStyle.

Namespace: frxClass
Syntax
Delphi
published
 property BrushStyle;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.CharSpacing Property

Summary

Represents property CharSpacing.

Namespace: frxClass
Syntax
Delphi
published
 property CharSpacing;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Clipped Property

Summary

Represents property Clipped.

Namespace: frxClass
Syntax
Delphi
published
 property Clipped;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Color Property

Summary

Represents property Color.

Namespace: frxClass
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.DataField Property

Summary

Represents property DataField.

Namespace: frxClass
Syntax
Delphi
published
 property DataField;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.DataSet Property

Summary

Represents property DataSet.

Namespace: frxClass
Syntax
Delphi
published
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxClass
Syntax
Delphi
published
 property DataSetName;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.DisplayFormat Property

Summary

Represents property DisplayFormat.

Namespace: frxClass
Syntax
Delphi
published
 property DisplayFormat;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Duplicates Property

Summary

Represents property Duplicates.

Namespace: frxClass
Syntax
Delphi
published
 property Duplicates;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.ExpressionDelimiters Property

Summary

Represents property ExpressionDelimiters.

Namespace: frxClass
Syntax
Delphi
published
 property ExpressionDelimiters;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Fill Property

Summary

Represents property Fill.

Namespace: frxClass
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.FillType Property

Summary

Represents property FillType.

Namespace: frxClass
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.FlowTo Property

Summary

Represents property FlowTo.

Namespace: frxClass
Syntax
Delphi
published
 property FlowTo;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Font Property

Summary

Represents property Font.

Namespace: frxClass
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Frame Property

Summary

Represents property Frame.

Namespace: frxClass
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.GapX Property

Summary

Represents property GapX.

Namespace: frxClass
Syntax
Delphi
published
 property GapX;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.GapY Property

Summary

Represents property GapY.

Namespace: frxClass
Syntax
Delphi
published
 property GapY;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.HAlign Property

Summary

Represents property HAlign.

Namespace: frxClass
Syntax
Delphi
published
 property HAlign;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.HideZeros Property

Summary

Represents property HideZeros.

Namespace: frxClass
Syntax
Delphi
published
 property HideZeros;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Highlight Property

Summary

Represents property Highlight.

Namespace: frxClass
Syntax
Delphi
published
 property Highlight;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.LineSpacing Property

Summary

Represents property LineSpacing.

Namespace: frxClass
Syntax
Delphi
published
 property LineSpacing;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Memo Property

Summary

Represents property Memo.

Namespace: frxClass
Syntax
Delphi
published
 property Memo;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.ParagraphGap Property

Summary

Represents property ParagraphGap.

Namespace: frxClass
Syntax
Delphi
published
 property ParagraphGap;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.ParentFont Property

Summary

Represents property ParentFont.

Namespace: frxClass
Syntax
Delphi
published
 property ParentFont;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Processing Property

Summary

Represents property Processing.

Namespace: frxClass
Syntax
Delphi
published
 property Processing;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Rotation Property

Summary

Represents property Rotation.

Namespace: frxClass
Syntax
Delphi
published
 property Rotation;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.RTLReading Property

Summary

Represents property RTLReading.

Namespace: frxClass
Syntax
Delphi
published
 property RTLReading;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Style Property

Summary

Represents property Style.

Namespace: frxClass
Syntax
Delphi
published
 property Style;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.SuppressRepeated Property

Summary

Represents property SuppressRepeated.

Namespace: frxClass
Syntax
Delphi
published
 property SuppressRepeated;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Underlines Property

Summary

Represents property Underlines.

Namespace: frxClass
Syntax
Delphi
published
 property Underlines;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.UnderlinesTextMode Property

Summary

Represents property UnderlinesTextMode.

Namespace: frxClass
Syntax
Delphi
published
 property UnderlinesTextMode;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.UseDefaultCharset Property

Summary

Represents property UseDefaultCharset.

Namespace: frxClass
Syntax
Delphi
published
 property UseDefaultCharset;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.VAlign Property

Summary

Represents property VAlign.

Namespace: frxClass
Syntax
Delphi
published
 property VAlign;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.WordBreak Property

Summary

Represents property WordBreak.

Namespace: frxClass
Syntax
Delphi
published
 property WordBreak;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.WordWrap Property

Summary

Represents property WordWrap.

Namespace: frxClass
Syntax
Delphi
published
 property WordWrap;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMemoView.Wysiwyg Property

Summary

Represents property Wysiwyg.

Namespace: frxClass
Syntax
Delphi
published
 property Wysiwyg;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoView
  • frxClass


TfrxMouseEnterViewEvent Class

Summary

Represents type TfrxMouseEnterViewEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxMouseEnterViewEvent = type String;
See Also

Reference

  • frxClass


TfrxMouseEvent Class

Summary

Represents type TfrxMouseEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxMouseEvent = type String;
See Also

Reference

  • frxClass


TfrxMouseLeaveViewEvent Class

Summary

Represents type TfrxMouseLeaveViewEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxMouseLeaveViewEvent = type String;
See Also

Reference

  • frxClass


TfrxMouseMoveEvent Class

Summary

Represents type TfrxMouseMoveEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxMouseMoveEvent = type String;
See Also

Reference

  • frxClass


TfrxNode Class

Summary

This class represents tree node which used to emulate tree structure of directories and files in IO transports.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxNode
Syntax
Delphi
type
 TfrxNode = class(TObject)
 end;

The TfrxNode type exposes the following members.

Constructors
Show:
Name | Description
Create | Default constructor.
Destroy | Represents the destructor of the TfrxNode class.
Top
Properties
Show:
Name | Description
Data | Node data.
FilesCount | Count of files(ObjectData assigned) in current item.
FilterAccess | Access type of IO filter.
Items[Integer] | List of all child nodes for current level.
Name | Name of the current node.
ObjectData | Node object. Usually stream.
OriginalName | Original name of a node. internal use.
Parent | Reference to a parent node.
Top
Methods
Show:
Name | Description
Add(String,TObject) | Adds new child node to current one.
Clear | Clears current node and destroys all child nodes with data(closes and free all opened streams).
Count | Returns count of nodes for current level.
Find(String,Boolean) | Overloaded. Searches for node by name.
Find(TObject,Boolean) | Overloaded. Searches for node by assigned object.
GetNode(Integer) | Represents method GetNode(Integer).
GetRoot | Returns Root tree node.
RemoveNode(TfrxNode) | Removes node.
SetName(String) | Represents method SetName(String).
SetObjectData(TObject) | Represents method SetObjectData(TObject).
SetOriginalName(String) | Represents method SetOriginalName(String).
UpdateFilesCount(Integer) | Represents method UpdateFilesCount(Integer).
Top
Events
Show:
Name | Description
OnAddItem | This event fires when child item added to current.
OnRemoveItem | This event fires when child item removed from current.
Top
Fields
Show:
Name | Description
FData | Represents field FData.
FFilesCount | Represents field FFilesCount.
FFilterAccess | Represents field FFilterAccess.
FName | Represents field FName.
FNodesList | Represents field FNodesList.
FObjectData | Represents field FObjectData.
FOnAddItem | Represents field FOnAddItem.
FOnRemoveItem | Represents field FOnRemoveItem.
FOriginalName | Represents field FOriginalName.
FOwnObject | Represents field FOwnObject.
FParent | Represents field FParent.
Top
See Also

Reference

  • frxClass


TfrxNode Constructors

Constructors
Name | Description
Create | Default constructor.
Destroy | Represents the destructor of the TfrxNode class.
Top


TfrxNode.Create Constructor

Summary

Default constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.Destroy Destructor

Summary

Represents the destructor of the TfrxNode class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode Properties

Properties
Name | Description
Data | Node data.
FilesCount | Count of files(ObjectData assigned) in current item.
FilterAccess | Access type of IO filter.
Items[Integer] | List of all child nodes for current level.
Name | Name of the current node.
ObjectData | Node object. Usually stream.
OriginalName | Original name of a node. internal use.
Parent | Reference to a parent node.
Top


TfrxNode.Data Property

Summary

Node data.

Namespace: frxClass
Syntax
Delphi
public
 property Data: Variant read FData write FData;

Property Value

Type: Variant

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.FilesCount Property

Summary

Count of files(ObjectData assigned) in current item.

Namespace: frxClass
Syntax
Delphi
public
 property FilesCount: Integer read FFilesCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.FilterAccess Property

Summary

Access type of IO filter.

Namespace: frxClass
Syntax
Delphi
public
 property FilterAccess: TfrxFilterAccess read FFilterAccess write FFilterAccess;

Property Value

Type: TfrxFilterAccess

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.Items[Integer] Property

Summary

List of all child nodes for current level.

Namespace: frxClass
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxNode read GetNode;

Parameters

Index
Type: Integer

Property Value

Type: TfrxNode

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.Name Property

Summary

Name of the current node.

Namespace: frxClass
Syntax
Delphi
public
 property Name: String read FName write SetName;

Property Value

Type: String

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.ObjectData Property

Summary

Node object. Usually stream.

Namespace: frxClass
Syntax
Delphi
public
 property ObjectData: TObject read FObjectData write SetObjectData;

Property Value

Type: TObject

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.OriginalName Property

Summary

Original name of a node. internal use.

Namespace: frxClass
Syntax
Delphi
public
 property OriginalName: String read FOriginalName write SetOriginalName;

Property Value

Type: String

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.Parent Property

Summary

Reference to a parent node.

Namespace: frxClass
Syntax
Delphi
public
 property Parent: TfrxNode read FParent;

Property Value

Type: TfrxNode

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode Methods

Methods
Name | Description
Add(String,TObject) | Adds new child node to current one.
Clear | Clears current node and destroys all child nodes with data(closes and free all opened streams).
Count | Returns count of nodes for current level.
Find(String,Boolean) | Overloaded. Searches for node by name.
Find(TObject,Boolean) | Overloaded. Searches for node by assigned object.
GetNode(Integer) | Represents method GetNode(Integer).
GetRoot | Returns Root tree node.
RemoveNode(TfrxNode) | Removes node.
SetName(String) | Represents method SetName(String).
SetObjectData(TObject) | Represents method SetObjectData(TObject).
SetOriginalName(String) | Represents method SetOriginalName(String).
UpdateFilesCount(Integer) | Represents method UpdateFilesCount(Integer).
Top


TfrxNode.Add(String,TObject) Method

Summary

Adds new child node to current one.

Namespace: frxClass
Syntax
Delphi
public
 function Add(const Name: String; aObject: TObject = nil): TfrxNode;

Parameters

Name
Type: String

Name of the child node.

aObject
Type: TObject

Object reference assigned to node(usually stream).

Return Value

Type: TfrxNode

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.Clear Method

Summary

Clears current node and destroys all child nodes with data(closes and free all opened streams).

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.Count Method

Summary

Returns count of nodes for current level.

Namespace: frxClass
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.Find(String,Boolean) Method

Summary

Searches for node by name.

Namespace: frxClass
Syntax
Delphi
public
 function Find(const Name: String; SearchInChilds: Boolean = False): TfrxNode; overload;

Parameters

Name
Type: String

Name of a node to search.

SearchInChilds
Type: Boolean

True if need to search in all child nodes.

Return Value

Type: TfrxNode

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.Find(TObject,Boolean) Method

Summary

Searches for node by assigned object.

Namespace: frxClass
Syntax
Delphi
public
 function Find(aObject: TObject; SearchInChilds: Boolean = False): TfrxNode; overload;

Parameters

aObject
Type: TObject

Reference to an object.

SearchInChilds
Type: Boolean

True if need to search in all child nodes.

Return Value

Type: TfrxNode

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.GetNode(Integer) Method

Summary

Represents method GetNode(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetNode(Index: Integer): TfrxNode;

Parameters

Index
Type: Integer

Return Value

Type: TfrxNode

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.GetRoot Method

Summary

Returns Root tree node.

Namespace: frxClass
Syntax
Delphi
public
 function GetRoot: TfrxNode;

Return Value

Type: TfrxNode

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.RemoveNode(TfrxNode) Method

Summary

Removes node.

Namespace: frxClass
Syntax
Delphi
public
 procedure RemoveNode(aNode: TfrxNode);

Parameters

aNode
Type: TfrxNode

Reference to a node.

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.SetName(String) Method

Summary

Represents method SetName(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.SetObjectData(TObject) Method

Summary

Represents method SetObjectData(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetObjectData(const Value: TObject);

Parameters

Value
Type: TObject

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.SetOriginalName(String) Method

Summary

Represents method SetOriginalName(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetOriginalName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.UpdateFilesCount(Integer) Method

Summary

Represents method UpdateFilesCount(Integer).

Namespace: frxClass
Syntax
Delphi
private
 procedure UpdateFilesCount(Count: Integer);

Parameters

Count
Type: Integer

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode Events

Events
Name | Description
OnAddItem | This event fires when child item added to current.
OnRemoveItem | This event fires when child item removed from current.
Top


TfrxNode.OnAddItem Event

Summary

This event fires when child item added to current.

Namespace: frxClass
Syntax
Delphi
public
 property OnAddItem: TfrxNodeChanging read FOnAddItem write FOnAddItem;

Value

Type: TfrxNodeChanging

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.OnRemoveItem Event

Summary

This event fires when child item removed from current.

Namespace: frxClass
Syntax
Delphi
public
 property OnRemoveItem: TfrxNodeChanging read FOnRemoveItem write FOnRemoveItem;

Value

Type: TfrxNodeChanging

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode Fields

Fields
Name | Description
FData | Represents field FData.
FFilesCount | Represents field FFilesCount.
FFilterAccess | Represents field FFilterAccess.
FName | Represents field FName.
FNodesList | Represents field FNodesList.
FObjectData | Represents field FObjectData.
FOnAddItem | Represents field FOnAddItem.
FOnRemoveItem | Represents field FOnRemoveItem.
FOriginalName | Represents field FOriginalName.
FOwnObject | Represents field FOwnObject.
FParent | Represents field FParent.
Top


TfrxNode.FData Field

Summary

Represents field FData.

Namespace: frxClass
Syntax
Delphi
private
 FData: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.FFilesCount Field

Summary

Represents field FFilesCount.

Namespace: frxClass
Syntax
Delphi
private
 FFilesCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.FFilterAccess Field

Summary

Represents field FFilterAccess.

Namespace: frxClass
Syntax
Delphi
private
 FFilterAccess: TfrxFilterAccess;

Field Value

Type: TfrxFilterAccess

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.FName Field

Summary

Represents field FName.

Namespace: frxClass
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.FNodesList Field

Summary

Represents field FNodesList.

Namespace: frxClass
Syntax
Delphi
private
 FNodesList: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.FObjectData Field

Summary

Represents field FObjectData.

Namespace: frxClass
Syntax
Delphi
private
 FObjectData: TObject;

Field Value

Type: TObject

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.FOnAddItem Field

Summary

Represents field FOnAddItem.

Namespace: frxClass
Syntax
Delphi
private
 FOnAddItem: TfrxNodeChanging;

Field Value

Type: TfrxNodeChanging

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.FOnRemoveItem Field

Summary

Represents field FOnRemoveItem.

Namespace: frxClass
Syntax
Delphi
private
 FOnRemoveItem: TfrxNodeChanging;

Field Value

Type: TfrxNodeChanging

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.FOriginalName Field

Summary

Represents field FOriginalName.

Namespace: frxClass
Syntax
Delphi
private
 FOriginalName: String;

Field Value

Type: String

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.FOwnObject Field

Summary

Represents field FOwnObject.

Namespace: frxClass
Syntax
Delphi
private
 FOwnObject: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNode.FParent Field

Summary

Represents field FParent.

Namespace: frxClass
Syntax
Delphi
private
 FParent: TfrxNode;

Field Value

Type: TfrxNode

See Also

Reference

  • TfrxNode
  • frxClass


TfrxNotifyEvent Class

Summary

Represents type TfrxNotifyEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxNotifyEvent = type String;
See Also

Reference

  • frxClass


TfrxNullBand Class

Summary

Represents type TfrxNullBand.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxNullBand
Syntax
Delphi
type
 TfrxNullBand = class(TfrxBand);

The TfrxNullBand type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Determines whether the band contents may be splitted if band does not find a room in the page. Only "Text", "Line" and "RichText" objects may be split. Default value is False. (Inherited from TfrxBand.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Link to a child band that will be shown after this band. (Inherited from TfrxBand.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show a child band on the same page as a parent band. If child band does not find a room on the page, it will be carried to the next page along with its parent band. Default value is False. (Inherited from TfrxBand.)
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point). (Inherited from TfrxBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Determines whether to show child band if this band is invisible. Default value is False. (Inherited from TfrxBand.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Determine how band shifts its child object. (Inherited from TfrxBand.)
StartNewPage | Determines whether to form a new output page before printing this band. Default value is False. (Inherited from TfrxBand.)
Stretched | Determines whether the band can stretch depending on size of its objects. To use this property, band should contain stretchable objects such as "Text", "Picture", "RichText". Default value is False. (Inherited from TfrxBand.)
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxObjectProcessing Class

Summary

This class encapsulate data for object processing engine.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxObjectProcessing
Syntax
Delphi
type
 TfrxObjectProcessing = class(TPersistent)
 end;

The TfrxObjectProcessing type exposes the following members.

Properties
Show:
Name | Description
GroupLevel | It represent level of nested group which will be used to calculate object data. This property used with paGroupFinished flag. Zero means all groups call data calculation for current object. The value above zero represents nested group level number.
ProcessAt | This property controls when to process expression calculation(for some TfrxView objects).
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
Fields
Show:
Name | Description
FGroupLevel | Represents field FGroupLevel.
FProcessAt | Represents field FProcessAt.
Top
See Also

Reference

  • frxClass


TfrxObjectProcessing Properties

Properties
Name | Description
GroupLevel | It represent level of nested group which will be used to calculate object data. This property used with paGroupFinished flag. Zero means all groups call data calculation for current object. The value above zero represents nested group level number.
ProcessAt | This property controls when to process expression calculation(for some TfrxView objects).
Top


TfrxObjectProcessing.GroupLevel Property

Summary

It represent level of nested group which will be used to calculate object data. This property used with paGroupFinished flag. Zero means all groups call data calculation for current object. The value above zero represents nested group level number.

Namespace: frxClass
Syntax
Delphi
published
 property GroupLevel: Integer read FGroupLevel write FGroupLevel default 0;

Property Value

Type: Integer

See Also

Reference

  • TfrxObjectProcessing
  • frxClass


TfrxObjectProcessing.ProcessAt Property

Summary

This property controls when to process expression calculation(for some TfrxView objects).

Namespace: frxClass
Syntax
Delphi
published
 property ProcessAt: TfrxProcessAtMode read FProcessAt write FProcessAt default paDefault;

Property Value

Type: TfrxProcessAtMode

See Also

Reference

  • TfrxObjectProcessing
  • frxClass


TfrxObjectProcessing Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TfrxObjectProcessing.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxObjectProcessing
  • frxClass


TfrxObjectProcessing Fields

Fields
Name | Description
FGroupLevel | Represents field FGroupLevel.
FProcessAt | Represents field FProcessAt.
Top


TfrxObjectProcessing.FGroupLevel Field

Summary

Represents field FGroupLevel.

Namespace: frxClass
Syntax
Delphi
private
 FGroupLevel: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxObjectProcessing
  • frxClass


TfrxObjectProcessing.FProcessAt Field

Summary

Represents field FProcessAt.

Namespace: frxClass
Syntax
Delphi
private
 FProcessAt: TfrxProcessAtMode;

Field Value

Type: TfrxProcessAtMode

See Also

Reference

  • TfrxObjectProcessing
  • frxClass


TfrxObjectsNotifyList Class

Summary

Standard list with Notify event. Used as helper to detect added/deleted objects.

Namespace: frxClass
Inheritance Hierarchy
TList
frxClass.TfrxObjectsNotifyList
Syntax
Delphi
type
 TfrxObjectsNotifyList = class(TList)
 end;

The TfrxObjectsNotifyList type exposes the following members.

Methods
Show:
Name | Description
Notify(Pointer,TListNotification) | Represents method Notify(Pointer,TListNotification).
Top
Events
Show:
Name | Description
OnNotifyList | List notification event.
Top
Fields
Show:
Name | Description
FOnNotifyList | Represents field FOnNotifyList.
Top
See Also

Reference

  • frxClass


TfrxObjectsNotifyList Methods

Methods
Name | Description
Notify(Pointer,TListNotification) | Represents method Notify(Pointer,TListNotification).
Top


TfrxObjectsNotifyList.Notify(Pointer,TListNotification) Method

Summary

Represents method Notify(Pointer,TListNotification).

Namespace: frxClass
Syntax
Delphi
protected
 procedure Notify(Ptr: Pointer; Action: TListNotification); override;

Parameters

Ptr
Type: Pointer

Action
Type: TListNotification

See Also

Reference

  • TfrxObjectsNotifyList
  • frxClass


TfrxObjectsNotifyList Events

Events
Name | Description
OnNotifyList | List notification event.
Top


TfrxObjectsNotifyList.OnNotifyList Event

Summary

List notification event.

Namespace: frxClass
Syntax
Delphi
public
 property OnNotifyList: TfrxObjectsNotifyEvent read FOnNotifyList write FOnNotifyList;

Value

Type: TfrxObjectsNotifyEvent

See Also

Reference

  • TfrxObjectsNotifyList
  • frxClass


TfrxObjectsNotifyList Fields

Fields
Name | Description
FOnNotifyList | Represents field FOnNotifyList.
Top


TfrxObjectsNotifyList.FOnNotifyList Field

Summary

Represents field FOnNotifyList.

Namespace: frxClass
Syntax
Delphi
private
 FOnNotifyList: TfrxObjectsNotifyEvent;

Field Value

Type: TfrxObjectsNotifyEvent

See Also

Reference

  • TfrxObjectsNotifyList
  • frxClass


TfrxOverlay Class

Summary

The TfrxOverlay class represents an "Overlay" band. This kind of band is printed on each page as a bottom layer.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxOverlay
Syntax
Delphi
type
 TfrxOverlay = class(TfrxBand)
 end;

The TfrxOverlay type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Determines whether the band contents may be splitted if band does not find a room in the page. Only "Text", "Line" and "RichText" objects may be split. Default value is False. (Inherited from TfrxBand.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Link to a child band that will be shown after this band. (Inherited from TfrxBand.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show a child band on the same page as a parent band. If child band does not find a room on the page, it will be carried to the next page along with its parent band. Default value is False. (Inherited from TfrxBand.)
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point). (Inherited from TfrxBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Determines whether to show child band if this band is invisible. Default value is False. (Inherited from TfrxBand.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
PrintOnTop | Determines whether to print this band on top of other bands.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Determine how band shifts its child object. (Inherited from TfrxBand.)
StartNewPage | Determines whether to form a new output page before printing this band. Default value is False. (Inherited from TfrxBand.)
Stretched | Determines whether the band can stretch depending on size of its objects. To use this property, band should contain stretchable objects such as "Text", "Picture", "RichText". Default value is False. (Inherited from TfrxBand.)
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintOnTop | Represents field FPrintOnTop.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxOverlay Properties

Properties
Name | Description
PrintOnTop | Determines whether to print this band on top of other bands.
Top


TfrxOverlay.PrintOnTop Property

Summary

Determines whether to print this band on top of other bands.

Namespace: frxClass
Syntax
Delphi
published
 property PrintOnTop: Boolean read FPrintOnTop write FPrintOnTop default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxOverlay
  • frxClass


TfrxOverlay Fields

Fields
Name | Description
FPrintOnTop | Represents field FPrintOnTop.
Top


TfrxOverlay.FPrintOnTop Field

Summary

Represents field FPrintOnTop.

Namespace: frxClass
Syntax
Delphi
private
 FPrintOnTop: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxOverlay
  • frxClass


TfrxPage Class

Summary

The TfrxPage class is the base class for report design pages such as TfrxReportPage, TfrxDialogPage, TfrxDMPPage.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxPage
frxClass.TfrxDataPage
frxClass.TfrxDialogPage
frxClass.TfrxReportPage
Syntax
Delphi
type
 TfrxPage = class(TfrxComponent)
 end;

The TfrxPage type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPage class. (Overrides TfrxComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Object's description. (Inherited from TfrxComponent.)
Font | Represents property Font.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible.
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | Represents method Draw(TCanvas,Extended,Extended,Extended,Extended).
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
Top
See Also

Reference

  • frxClass


TfrxPage Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPage class. (Overrides TfrxComponent.Create(TComponent).)
Top


TfrxPage.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxPage class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxComponent.Create(TComponent)
See Also

Reference

  • TfrxPage
  • frxClass


TfrxPage Properties

Properties
Name | Description
Font | Represents property Font.
Visible | Represents property Visible.
Top


TfrxPage.Font Property

Summary

Represents property Font.

Namespace: frxClass
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxPage
  • frxClass


TfrxPage.Visible Property

Summary

Represents property Visible.

Namespace: frxClass
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TfrxPage
  • frxClass


TfrxPage Methods

Methods
Name | Description
Draw(TCanvas,Extended,Extended,Extended,Extended) | Represents method Draw(TCanvas,Extended,Extended,Extended,Extended).
Top


TfrxPage.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

Represents method Draw(TCanvas,Extended,Extended,Extended,Extended).

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); virtual;

Parameters

Canvas
Type: TCanvas

ScaleX
Type: Extended

ScaleY
Type: Extended

OffsetX
Type: Extended

OffsetY
Type: Extended

See Also

Reference

  • TfrxPage
  • frxClass


TfrxPageFooter Class

Summary

The TfrxPageFooter class represents a "Page footer" band. This kind of band is displayed at the bottom of each page.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxPageFooter
Syntax
Delphi
type
 TfrxPageFooter = class(TfrxBand)
 end;

The TfrxPageFooter type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPageFooter class. (Overrides TfrxBand.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Determines whether the band contents may be splitted if band does not find a room in the page. Only "Text", "Line" and "RichText" objects may be split. Default value is False. (Inherited from TfrxBand.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Link to a child band that will be shown after this band. (Inherited from TfrxBand.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show a child band on the same page as a parent band. If child band does not find a room on the page, it will be carried to the next page along with its parent band. Default value is False. (Inherited from TfrxBand.)
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point). (Inherited from TfrxBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Determines whether to show child band if this band is invisible. Default value is False. (Inherited from TfrxBand.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
PrintOnFirstPage | Determines whether to print a band on the first page.
PrintOnLastPage | Determines whether to print a band on the last page.
PrintOnSinglePage | Determines whether to print a band on the page when it last and first page (i.e. single page).
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Determine how band shifts its child object. (Inherited from TfrxBand.)
StartNewPage | Determines whether to form a new output page before printing this band. Default value is False. (Inherited from TfrxBand.)
Stretched | Determines whether the band can stretch depending on size of its objects. To use this property, band should contain stretchable objects such as "Text", "Picture", "RichText". Default value is False. (Inherited from TfrxBand.)
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintOnFirstPage | Represents field FPrintOnFirstPage.
FPrintOnLastPage | Represents field FPrintOnLastPage.
FPrintOnSinglePage | Represents field FPrintOnSinglePage.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxPageFooter Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPageFooter class. (Overrides TfrxBand.Create(TComponent).)
Top


TfrxPageFooter.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxPageFooter class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxBand.Create(TComponent)
See Also

Reference

  • TfrxPageFooter
  • frxClass


TfrxPageFooter Properties

Properties
Name | Description
PrintOnFirstPage | Determines whether to print a band on the first page.
PrintOnLastPage | Determines whether to print a band on the last page.
PrintOnSinglePage | Determines whether to print a band on the page when it last and first page (i.e. single page).
Top


TfrxPageFooter.PrintOnFirstPage Property

Summary

Determines whether to print a band on the first page.

Namespace: frxClass
Syntax
Delphi
published
 property PrintOnFirstPage: Boolean read FPrintOnFirstPage write FPrintOnFirstPage default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPageFooter
  • frxClass


TfrxPageFooter.PrintOnLastPage Property

Summary

Determines whether to print a band on the last page.

Namespace: frxClass
Syntax
Delphi
published
 property PrintOnLastPage: Boolean read FPrintOnLastPage write FPrintOnLastPage default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPageFooter
  • frxClass


TfrxPageFooter.PrintOnSinglePage Property

Summary

Determines whether to print a band on the page when it last and first page (i.e. single page).

Namespace: frxClass
Syntax
Delphi
published
 property PrintOnSinglePage: Boolean read FPrintOnSinglePage write FPrintOnSinglePage default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPageFooter
  • frxClass


TfrxPageFooter Fields

Fields
Name | Description
FPrintOnFirstPage | Represents field FPrintOnFirstPage.
FPrintOnLastPage | Represents field FPrintOnLastPage.
FPrintOnSinglePage | Represents field FPrintOnSinglePage.
Top


TfrxPageFooter.FPrintOnFirstPage Field

Summary

Represents field FPrintOnFirstPage.

Namespace: frxClass
Syntax
Delphi
private
 FPrintOnFirstPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPageFooter
  • frxClass


TfrxPageFooter.FPrintOnLastPage Field

Summary

Represents field FPrintOnLastPage.

Namespace: frxClass
Syntax
Delphi
private
 FPrintOnLastPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPageFooter
  • frxClass


TfrxPageFooter.FPrintOnSinglePage Field

Summary

Represents field FPrintOnSinglePage.

Namespace: frxClass
Syntax
Delphi
private
 FPrintOnSinglePage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPageFooter
  • frxClass


TfrxPageHeader Class

Summary

The TfrxPageHeader class represents a "Page header" band. This kind of band is displayed at the top of each page.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxPageHeader
Syntax
Delphi
type
 TfrxPageHeader = class(TfrxBand)
 end;

The TfrxPageHeader type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPageHeader class. (Overrides TfrxBand.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Determines whether the band contents may be splitted if band does not find a room in the page. Only "Text", "Line" and "RichText" objects may be split. Default value is False. (Inherited from TfrxBand.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show a child band on the same page as a parent band. If child band does not find a room on the page, it will be carried to the next page along with its parent band. Default value is False. (Inherited from TfrxBand.)
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point). (Inherited from TfrxBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
PrintOnFirstPage | Determines whether to print a band on the first page.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Determines whether to form a new output page before printing this band. Default value is False. (Inherited from TfrxBand.)
Stretched | Represents property Stretched.
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintOnFirstPage | Represents field FPrintOnFirstPage.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxPageHeader Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPageHeader class. (Overrides TfrxBand.Create(TComponent).)
Top


TfrxPageHeader.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxPageHeader class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxBand.Create(TComponent)
See Also

Reference

  • TfrxPageHeader
  • frxClass


TfrxPageHeader Properties

Properties
Name | Description
Child | Represents property Child.
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
PrintOnFirstPage | Determines whether to print a band on the first page.
ShiftEngine | Represents property ShiftEngine.
Stretched | Represents property Stretched.
Top


TfrxPageHeader.Child Property

Summary

Represents property Child.

Namespace: frxClass
Syntax
Delphi
published
 property Child;

Property Value

Type: Void

See Also

Reference

  • TfrxPageHeader
  • frxClass


TfrxPageHeader.PrintChildIfInvisible Property

Summary

Represents property PrintChildIfInvisible.

Namespace: frxClass
Syntax
Delphi
published
 property PrintChildIfInvisible;

Property Value

Type: Void

See Also

Reference

  • TfrxPageHeader
  • frxClass


TfrxPageHeader.PrintOnFirstPage Property

Summary

Determines whether to print a band on the first page.

Namespace: frxClass
Syntax
Delphi
published
 property PrintOnFirstPage: Boolean read FPrintOnFirstPage write FPrintOnFirstPage default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPageHeader
  • frxClass


TfrxPageHeader.ShiftEngine Property

Summary

Represents property ShiftEngine.

Namespace: frxClass
Syntax
Delphi
published
 property ShiftEngine;

Property Value

Type: Void

See Also

Reference

  • TfrxPageHeader
  • frxClass


TfrxPageHeader.Stretched Property

Summary

Represents property Stretched.

Namespace: frxClass
Syntax
Delphi
published
 property Stretched;

Property Value

Type: Void

See Also

Reference

  • TfrxPageHeader
  • frxClass


TfrxPageHeader Fields

Fields
Name | Description
FPrintOnFirstPage | Represents field FPrintOnFirstPage.
Top


TfrxPageHeader.FPrintOnFirstPage Field

Summary

Represents field FPrintOnFirstPage.

Namespace: frxClass
Syntax
Delphi
private
 FPrintOnFirstPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPageHeader
  • frxClass


TfrxPictureView Class

Summary

The TfrxPictureView class represents the "Picture" object. It can show a picture in the PNG, BMP, JPEG, ICO, WMF, EMF formats.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxPictureView
Syntax
Delphi
type
 TfrxPictureView = class(TfrxView)
 end;

The TfrxPictureView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPictureView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxPictureView class. (Overrides TfrxView.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
AutoSize | Determines whether the picture should handle its size automatically. Default value is False.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
Center | Determines whether the image should be centered inside the object. Default value is False.
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
FileLink | File name or expression which contains a name of the picture file.
Fill | Represents property Fill.
FillType | Represents property FillType.
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
HightQuality | Activates drawing with better smooth.
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
ImageIndex | Internal use only. Index of image in a picture cache if image stored in a picture cache.
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsImageIndexStored | Internal use. Determines if images stored in a picture cache.
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPictureStored | Internal use. Determines if images stored in a picture object.
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepAspectRatio | Keep the original aspect ratio of the image when stretching the object. The Stretched property should also be set.
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
Picture | Reference to internal TPicture object that stores the image.
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
Stretched | Stretches the picture to fit the object bounds. Default value is True.
TagStr | Represents property TagStr.
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Transparent | Determines if picture has transparent parts or Alpha mask.
TransparentColor | Color of transparent parts.
URL | Represents property URL.
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Overrides TfrxView.IsEMFExportable.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LoadPictureFromStream(TStream,Boolean) | Load picture from stream.
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
PictureChanged(TObject) | Represents method PictureChanged(TObject).
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetAutoSize(Boolean) | Represents method SetAutoSize(Boolean).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetPicture(TPicture) | Represents method SetPicture(TPicture).
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetTransparent(Boolean) | Represents method SetTransparent(Boolean).
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FAutoSize | Represents field FAutoSize.
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FCenter | Represents field FCenter.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFileLink | Represents field FFileLink.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FHightQuality | Represents field FHightQuality.
FImageIndex | Represents field FImageIndex.
FIsImageIndexStored | Represents field FIsImageIndexStored.
FIsPictureStored | Represents field FIsPictureStored.
FKeepAspectRatio | Represents field FKeepAspectRatio.
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPicture | Represents field FPicture.
FPictureChanged | Represents field FPictureChanged.
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretched | Represents field FStretched.
FTransparent | Represents field FTransparent.
FTransparentColor | Represents field FTransparentColor.
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxClass


TfrxPictureView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPictureView class. (Overrides TfrxView.Create(TComponent).)
Destroy | Represents the destructor of the TfrxPictureView class. (Overrides TfrxView.Destroy.)
Top


TfrxPictureView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxPictureView class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxView.Create(TComponent)
See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.Destroy Destructor

Summary

Represents the destructor of the TfrxPictureView class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxView.Destroy
See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView Properties

Properties
Name | Description
AutoSize | Determines whether the picture should handle its size automatically. Default value is False.
Center | Determines whether the image should be centered inside the object. Default value is False.
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
FileLink | File name or expression which contains a name of the picture file.
Fill | Represents property Fill.
FillType | Represents property FillType.
Frame | Represents property Frame.
HightQuality | Activates drawing with better smooth.
ImageIndex | Internal use only. Index of image in a picture cache if image stored in a picture cache.
IsImageIndexStored | Internal use. Determines if images stored in a picture cache.
IsPictureStored | Internal use. Determines if images stored in a picture object.
KeepAspectRatio | Keep the original aspect ratio of the image when stretching the object. The Stretched property should also be set.
Picture | Reference to internal TPicture object that stores the image.
Stretched | Stretches the picture to fit the object bounds. Default value is True.
TagStr | Represents property TagStr.
Transparent | Determines if picture has transparent parts or Alpha mask.
TransparentColor | Color of transparent parts.
URL | Represents property URL.
Top


TfrxPictureView.AutoSize Property

Summary

Determines whether the picture should handle its size automatically. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property AutoSize: Boolean read FAutoSize write SetAutoSize default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.Center Property

Summary

Determines whether the image should be centered inside the object. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property Center: Boolean read FCenter write FCenter default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.Cursor Property

Summary

Represents property Cursor.

Namespace: frxClass
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.DataField Property

Summary

Represents property DataField.

Namespace: frxClass
Syntax
Delphi
published
 property DataField;

Property Value

Type: Void

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.DataSet Property

Summary

Represents property DataSet.

Namespace: frxClass
Syntax
Delphi
published
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxClass
Syntax
Delphi
published
 property DataSetName;

Property Value

Type: Void

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FileLink Property

Summary

File name or expression which contains a name of the picture file.

Namespace: frxClass
Syntax
Delphi
published
 property FileLink: String read FFileLink write FFileLink;

Property Value

Type: String

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.Fill Property

Summary

Represents property Fill.

Namespace: frxClass
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FillType Property

Summary

Represents property FillType.

Namespace: frxClass
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.Frame Property

Summary

Represents property Frame.

Namespace: frxClass
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.HightQuality Property

Summary

Activates drawing with better smooth.

Namespace: frxClass
Syntax
Delphi
published
 property HightQuality: Boolean read FHightQuality write FHightQuality;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.ImageIndex Property

Summary

Internal use only. Index of image in a picture cache if image stored in a picture cache.

Namespace: frxClass
Syntax
Delphi
published
 property ImageIndex: Integer read FImageIndex write FImageIndex stored FIsImageIndexStored;

Property Value

Type: Integer

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.IsImageIndexStored Property

Summary

Internal use. Determines if images stored in a picture cache.

Namespace: frxClass
Syntax
Delphi
public
 property IsImageIndexStored: Boolean read FIsImageIndexStored write FIsImageIndexStored;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.IsPictureStored Property

Summary

Internal use. Determines if images stored in a picture object.

Namespace: frxClass
Syntax
Delphi
public
 property IsPictureStored: Boolean read FIsPictureStored write FIsPictureStored;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.KeepAspectRatio Property

Summary

Keep the original aspect ratio of the image when stretching the object. The Stretched property should also be set.

Namespace: frxClass
Syntax
Delphi
published
 property KeepAspectRatio: Boolean read FKeepAspectRatio write FKeepAspectRatio default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.Picture Property

Summary

Reference to internal TPicture object that stores the image.

Namespace: frxClass
Syntax
Delphi
published
 property Picture: TPicture read FPicture write SetPicture stored FIsPictureStored;

Property Value

Type: TPicture

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.Stretched Property

Summary

Stretches the picture to fit the object bounds. Default value is True.

Namespace: frxClass
Syntax
Delphi
published
 property Stretched: Boolean read FStretched write FStretched default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.TagStr Property

Summary

Represents property TagStr.

Namespace: frxClass
Syntax
Delphi
published
 property TagStr;

Property Value

Type: Void

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.Transparent Property

Summary

Determines if picture has transparent parts or Alpha mask.

Namespace: frxClass
Syntax
Delphi
published
 property Transparent: Boolean read FTransparent write SetTransparent;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.TransparentColor Property

Summary

Color of transparent parts.

Namespace: frxClass
Syntax
Delphi
published
 property TransparentColor: TColor read FTransparentColor write FTransparentColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.URL Property

Summary

Represents property URL.

Namespace: frxClass
Syntax
Delphi
published
 property URL;

Property Value

Type: Void

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView Methods

Methods
Name | Description
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Overrides TfrxView.IsEMFExportable.)
LoadPictureFromStream(TStream,Boolean) | Load picture from stream.
PictureChanged(TObject) | Represents method PictureChanged(TObject).
SetAutoSize(Boolean) | Represents method SetAutoSize(Boolean).
SetPicture(TPicture) | Represents method SetPicture(TPicture).
SetTransparent(Boolean) | Represents method SetTransparent(Boolean).
Top


TfrxPictureView.Diff(TfrxComponent) Method

Summary

Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set.

Namespace: frxClass
Syntax
Delphi
public
 function Diff(AComponent: TfrxComponent):String; override;

Parameters

AComponent
Type: TfrxComponent

Return Value

Type: String

Overrides

TfrxView.Diff(TfrxComponent)
See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxClass
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.IsEMFExportable Method

Summary

Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported).

Namespace: frxClass
Syntax
Delphi
public
 function IsEMFExportable: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxView.IsEMFExportable
See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.LoadPictureFromStream(TStream,Boolean) Method

Summary

Load picture from stream.

Namespace: frxClass
Syntax
Delphi
public
 function LoadPictureFromStream(s: TStream; ResetStreamPos: Boolean = True): HResult; virtual;

Parameters

s
Type: TStream

ResetStreamPos
Type: Boolean

Return Value

Type: HResult

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.PictureChanged(TObject) Method

Summary

Represents method PictureChanged(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure PictureChanged(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.SetAutoSize(Boolean) Method

Summary

Represents method SetAutoSize(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetAutoSize(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.SetPicture(TPicture) Method

Summary

Represents method SetPicture(TPicture).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetPicture(const Value: TPicture);

Parameters

Value
Type: TPicture

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.SetTransparent(Boolean) Method

Summary

Represents method SetTransparent(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetTransparent(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView Fields

Fields
Name | Description
FAutoSize | Represents field FAutoSize.
FCenter | Represents field FCenter.
FFileLink | Represents field FFileLink.
FHightQuality | Represents field FHightQuality.
FImageIndex | Represents field FImageIndex.
FIsImageIndexStored | Represents field FIsImageIndexStored.
FIsPictureStored | Represents field FIsPictureStored.
FKeepAspectRatio | Represents field FKeepAspectRatio.
FPicture | Represents field FPicture.
FPictureChanged | Represents field FPictureChanged.
FStretched | Represents field FStretched.
FTransparent | Represents field FTransparent.
FTransparentColor | Represents field FTransparentColor.
Top


TfrxPictureView.FAutoSize Field

Summary

Represents field FAutoSize.

Namespace: frxClass
Syntax
Delphi
private
 FAutoSize: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FCenter Field

Summary

Represents field FCenter.

Namespace: frxClass
Syntax
Delphi
private
 FCenter: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FFileLink Field

Summary

Represents field FFileLink.

Namespace: frxClass
Syntax
Delphi
private
 FFileLink: String;

Field Value

Type: String

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FHightQuality Field

Summary

Represents field FHightQuality.

Namespace: frxClass
Syntax
Delphi
private
 FHightQuality: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FImageIndex Field

Summary

Represents field FImageIndex.

Namespace: frxClass
Syntax
Delphi
private
 FImageIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FIsImageIndexStored Field

Summary

Represents field FIsImageIndexStored.

Namespace: frxClass
Syntax
Delphi
private
 FIsImageIndexStored: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FIsPictureStored Field

Summary

Represents field FIsPictureStored.

Namespace: frxClass
Syntax
Delphi
private
 FIsPictureStored: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FKeepAspectRatio Field

Summary

Represents field FKeepAspectRatio.

Namespace: frxClass
Syntax
Delphi
private
 FKeepAspectRatio: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FPicture Field

Summary

Represents field FPicture.

Namespace: frxClass
Syntax
Delphi
private
 FPicture: TPicture;

Field Value

Type: TPicture

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FPictureChanged Field

Summary

Represents field FPictureChanged.

Namespace: frxClass
Syntax
Delphi
private
 FPictureChanged: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FStretched Field

Summary

Represents field FStretched.

Namespace: frxClass
Syntax
Delphi
private
 FStretched: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FTransparent Field

Summary

Represents field FTransparent.

Namespace: frxClass
Syntax
Delphi
private
 FTransparent: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPictureView.FTransparentColor Field

Summary

Represents field FTransparentColor.

Namespace: frxClass
Syntax
Delphi
private
 FTransparentColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxPictureView
  • frxClass


TfrxPostProcessor Class

Summary

This class used as post-process data dictionary. It controls behaviour of post-processed objects and stores data and expressions of these objects. Used by the report engine for delay expression calculation in selected objects.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxPostProcessor
Syntax
Delphi
type
 TfrxPostProcessor = class(TPersistent)
 end;

The TfrxPostProcessor type exposes the following members.

Constructors
Show:
Name | Description
Create | Default constructor.
Destroy | Represents the destructor of the TfrxPostProcessor class.
Top
Properties
Show:
Name | Description
Macroses | List of items in the dictionary.
Top
Methods
Show:
Name | Description
Add(String,String,WideString,TfrxProcessAtMode,TfrxComponent,Boolean,Boolean) | Adds new View component to the list for delayed calculation. Places an item to the list for future calculation.
Clear | Clears and destroys all items in dictionary list.
EnterData | Enters new data level.
EnterGroup | Enter new group level.
GetMacroList(String) | Returns list of items by name of object.
GetValue(Integer,Integer) | Not used
LeaveData | Leaves new data level.
LeaveGroup | Leaves current group level.
LoadFromXML(TfrxXMLItem) | Load dictionary from XML node.
LoadValue(TfrxComponent) | Loads value to component from dictionary.
ProcessExpressions(TfrxReport,TfrxBand,TfrxProcessAtMode) | Calculates an expression for items in the list. It called by the report engine when one of the events occurs. Removes objects from the processing list when appropriate event occurs.
ProcessObject(TfrxReport,TfrxComponent) | It calculates an expressions for selected view component.
ResetDuplicates(String) | Resets duplicates values in the list.
ResetSuppressed | Resets suppressed values in the list.
SaveToXML(TfrxXMLItem) | Save dictionary to XML node.
Top
Fields
Show:
Name | Description
FBands | Represents field FBands.
FDataLevel | Represents field FDataLevel.
FGroupLevel | Represents field FGroupLevel.
FMacroses | Represents field FMacroses.
FProcessing | Represents field FProcessing.
FProcessList | Represents field FProcessList.
Top
See Also

Reference

  • frxClass


TfrxPostProcessor Constructors

Constructors
Name | Description
Create | Default constructor.
Destroy | Represents the destructor of the TfrxPostProcessor class.
Top


TfrxPostProcessor.Create Constructor

Summary

Default constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.Destroy Destructor

Summary

Represents the destructor of the TfrxPostProcessor class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor Properties

Properties
Name | Description
Macroses | List of items in the dictionary.
Top


TfrxPostProcessor.Macroses Property

Summary

List of items in the dictionary.

Namespace: frxClass
Syntax
Delphi
public
 property Macroses: TStrings read FMacroses;

Property Value

Type: TStrings

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor Methods

Methods
Name | Description
Add(String,String,WideString,TfrxProcessAtMode,TfrxComponent,Boolean,Boolean) | Adds new View component to the list for delayed calculation. Places an item to the list for future calculation.
Clear | Clears and destroys all items in dictionary list.
EnterData | Enters new data level.
EnterGroup | Enter new group level.
GetMacroList(String) | Returns list of items by name of object.
GetValue(Integer,Integer) | Not used
LeaveData | Leaves new data level.
LeaveGroup | Leaves current group level.
LoadFromXML(TfrxXMLItem) | Load dictionary from XML node.
LoadValue(TfrxComponent) | Loads value to component from dictionary.
ProcessExpressions(TfrxReport,TfrxBand,TfrxProcessAtMode) | Calculates an expression for items in the list. It called by the report engine when one of the events occurs. Removes objects from the processing list when appropriate event occurs.
ProcessObject(TfrxReport,TfrxComponent) | It calculates an expressions for selected view component.
ResetDuplicates(String) | Resets duplicates values in the list.
ResetSuppressed | Resets suppressed values in the list.
SaveToXML(TfrxXMLItem) | Save dictionary to XML node.
Top


TfrxPostProcessor.Add(String,String,WideString,TfrxProcessAtMode,TfrxComponent,Boolean,Boolean) Method

Summary

Adds new View component to the list for delayed calculation. Places an item to the list for future calculation.

Namespace: frxClass
Syntax
Delphi
public
 function Add(const BandName: String; const Name: String; const Content: WideString; ProcessMode: TfrxProcessAtMode; aComponent: TfrxComponent; bSupressed: Boolean = false; bEmpty: Boolean = false): Integer;

Parameters

BandName
Type: String

Name of the parent band.

Name
Type: String

Item name(usually component name).

Content
Type: WideString

Content to be stored and calculated later(usually an expression).

ProcessMode
Type: TfrxProcessAtMode

Controls when to process expression calculation.

aComponent
Type: TfrxComponent

Reference to a view component.

bSupressed
Type: Boolean

process suppressed values.

bEmpty
Type: Boolean

Clear suppressed values.

Return Value

Type: Integer

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.Clear Method

Summary

Clears and destroys all items in dictionary list.

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.EnterData Method

Summary

Enters new data level.

Namespace: frxClass
Syntax
Delphi
public
 procedure EnterData;
See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.EnterGroup Method

Summary

Enter new group level.

Namespace: frxClass
Syntax
Delphi
public
 procedure EnterGroup;
See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.GetMacroList(String) Method

Summary

Returns list of items by name of object.

Namespace: frxClass
Syntax
Delphi
public
 function GetMacroList(const MacroName: String): TWideStrings;

Parameters

MacroName
Type: String

Object name.

Return Value

Type: TWideStrings

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.GetValue(Integer,Integer) Method

Summary

Not used

Namespace: frxClass
Syntax
Delphi
public
 function GetValue(const MacroIndex: Integer; const MacroLine: Integer): WideString;

Parameters

MacroIndex
Type: Integer

MacroLine
Type: Integer

Return Value

Type: WideString

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.LeaveData Method

Summary

Leaves new data level.

Namespace: frxClass
Syntax
Delphi
public
 procedure LeaveData;
See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.LeaveGroup Method

Summary

Leaves current group level.

Namespace: frxClass
Syntax
Delphi
public
 procedure LeaveGroup;
See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.LoadFromXML(TfrxXMLItem) Method

Summary

Load dictionary from XML node.

Namespace: frxClass
Syntax
Delphi
public
 procedure LoadFromXML(Item: TfrxXMLItem);

Parameters

Item
Type: TfrxXMLItem

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.LoadValue(TfrxComponent) Method

Summary

Loads value to component from dictionary.

Namespace: frxClass
Syntax
Delphi
public
 function LoadValue(aComponent: TfrxComponent): Boolean;

Parameters

aComponent
Type: TfrxComponent

Reference to view component.

Return Value

Type: Boolean

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.ProcessExpressions(TfrxReport,TfrxBand,TfrxProcessAtMode) Method

Summary

Calculates an expression for items in the list. It called by the report engine when one of the events occurs. Removes objects from the processing list when appropriate event occurs.

Namespace: frxClass
Syntax
Delphi
public
 procedure ProcessExpressions(AReport: TfrxReport; ABand: TfrxBand; ProcessMode: TfrxProcessAtMode);

Parameters

AReport
Type: TfrxReport

Reference to a report component.

ABand
Type: TfrxBand

Name of the band container being processed.

ProcessMode
Type: TfrxProcessAtMode

Mode that should be processed.

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.ProcessObject(TfrxReport,TfrxComponent) Method

Summary

It calculates an expressions for selected view component.

Namespace: frxClass
Syntax
Delphi
public
 procedure ProcessObject(AReport: TfrxReport; aComponent: TfrxComponent);

Parameters

AReport
Type: TfrxReport

Reference to a report component.

aComponent
Type: TfrxComponent

Reference to a view component.

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.ResetDuplicates(String) Method

Summary

Resets duplicates values in the list.

Namespace: frxClass
Syntax
Delphi
public
 procedure ResetDuplicates(const BandName: String = '');

Parameters

BandName
Type: String

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.ResetSuppressed Method

Summary

Resets suppressed values in the list.

Namespace: frxClass
Syntax
Delphi
public
 procedure ResetSuppressed;
See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.SaveToXML(TfrxXMLItem) Method

Summary

Save dictionary to XML node.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveToXML(Item: TfrxXMLItem);

Parameters

Item
Type: TfrxXMLItem

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor Fields

Fields
Name | Description
FBands | Represents field FBands.
FDataLevel | Represents field FDataLevel.
FGroupLevel | Represents field FGroupLevel.
FMacroses | Represents field FMacroses.
FProcessing | Represents field FProcessing.
FProcessList | Represents field FProcessList.
Top


TfrxPostProcessor.FBands Field

Summary

Represents field FBands.

Namespace: frxClass
Syntax
Delphi
private
 FBands: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.FDataLevel Field

Summary

Represents field FDataLevel.

Namespace: frxClass
Syntax
Delphi
private
 FDataLevel: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.FGroupLevel Field

Summary

Represents field FGroupLevel.

Namespace: frxClass
Syntax
Delphi
private
 FGroupLevel: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.FMacroses Field

Summary

Represents field FMacroses.

Namespace: frxClass
Syntax
Delphi
private
 FMacroses: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.FProcessing Field

Summary

Represents field FProcessing.

Namespace: frxClass
Syntax
Delphi
private
 FProcessing: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPostProcessor.FProcessList Field

Summary

Represents field FProcessList.

Namespace: frxClass
Syntax
Delphi
private
 FProcessList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxPostProcessor
  • frxClass


TfrxPrepareReportCommand Class

Summary

This class implements realization of deferred PrepareReport command.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxBaseDelayedCommand
frxClass.TfrxBasePrepareReportCommand
frxClass.TfrxPrepareReportCommand
Syntax
Delphi
type
 TfrxPrepareReportCommand = class(TfrxBasePrepareReportCommand)
 end;

The TfrxPrepareReportCommand type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport,Boolean) | Command constructor. (Inherited from TfrxBasePrepareReportCommand.)
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseDelayedCommand.)
GetInstance | Get command instance. (Inherited from TfrxBaseDelayedCommand.)
GetName | Get symbolic name of current command instance. (Inherited from TfrxBaseDelayedCommand.)
QueryInterface(TGUID,Void) | Represents method QueryInterface(TGUID,Void). (Inherited from TfrxBaseDelayedCommand.)
Run | Runs command. (Overrides TfrxBasePrepareReportCommand.Run.)
_AddRef | Represents method _AddRef. (Inherited from TfrxBaseDelayedCommand.)
_Release | Represents method _Release. (Inherited from TfrxBaseDelayedCommand.)
Top
See Also

Reference

  • frxClass


TfrxPrepareReportCommand Methods

Methods
Name | Description
Run | Runs command. (Overrides TfrxBasePrepareReportCommand.Run.)
Top


TfrxPrepareReportCommand.Run Method

Summary

Runs command.

Namespace: frxClass
Syntax
Delphi
public
 procedure Run; override;

Overrides

TfrxBasePrepareReportCommand.Run
See Also

Reference

  • TfrxPrepareReportCommand
  • frxClass


TfrxPreviewClickEvent Class

Summary

Represents type TfrxPreviewClickEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxPreviewClickEvent = type String;
See Also

Reference

  • frxClass


TfrxPreviewOptions Class

Summary

The TfrxPreviewOptions class represents a set of properties, relating to the report preview. Instance of this class is stored in the TfrxReport.PreviewOptions.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxPreviewOptions
Syntax
Delphi
type
 TfrxPreviewOptions = class(TPersistent)
 end;

The TfrxPreviewOptions type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxPreviewOptions class.
Top
Properties
Show:
Name | Description
AllowEdit | Enables or disables a finished report editing. Default value is True.
AllowPreviewEdit | Enables InPlace editors in the report preview. Allows user to edit prepared report text and other properties without the report designer.
Buttons | A set of buttons, which will be available in the preview window. You can combine any of these values. Default value is: all buttons.
DoubleBuffered | A double-buffer mode for the preview window. If enabled (by default), the preview window will not flicker during repainting, but the process speed will be reduced.
Maximized | Defines if the preview window is maximized. Default value is True.
MDIChild | Defines if the preview window is MDIChild (for MDI interface organizing). Default value is False.
Modal | Defines if the preview window is modal. Default value is True.
OutlineExpand | Determines whether to expand all outline items.
OutlineVisible | Defines if the panel with the report outline is visible. Default value is False.
OutlineWidth | Defines width of the panel with the report outline, in pixels. Default value is 120.
PagesInCache | Determines how many prepared pages are located in memory. Other stored as serialized XML and loads by request.
PictureCacheInFile | Activates the mode of caching all pictures in the file, saves memory while displaying the reports with a large quantity of pictures.
RTLPreview | Enables RTL page output in preview.
ShowCaptions | Defines if button captions are displayed. When enabling thisproperty, you should limit the number of the displayed buttons in theButtons property, since all the buttons will not find room on thescreen.
ThumbnailVisible | Defines if the panel with the report thumbnail is visible. Default value is False.
Zoom | Default scale of the report in the report preview.
ZoomMode | Default zooming mode.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Copies the contents from another object.
Clear | Clears all properties and fills them by default values.
Top
Fields
Show:
Name | Description
FAllowEdit | Represents field FAllowEdit.
FAllowPreviewEdit | Represents field FAllowPreviewEdit.
FButtons | Represents field FButtons.
FDoubleBuffered | Represents field FDoubleBuffered.
FMaximized | Represents field FMaximized.
FMDIChild | Represents field FMDIChild.
FModal | Represents field FModal.
FOutlineExpand | Represents field FOutlineExpand.
FOutlineVisible | Represents field FOutlineVisible.
FOutlineWidth | Represents field FOutlineWidth.
FPagesInCache | Represents field FPagesInCache.
FPictureCacheInFile | Represents field FPictureCacheInFile.
FRTLPreview | Represents field FRTLPreview.
FShowCaptions | Represents field FShowCaptions.
FThumbnailVisible | Represents field FThumbnailVisible.
FZoom | Represents field FZoom.
FZoomMode | Represents field FZoomMode.
Top
See Also

Reference

  • frxClass


TfrxPreviewOptions Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxPreviewOptions class.
Top


TfrxPreviewOptions.Create Constructor

Summary

Initializes a new instance of the TfrxPreviewOptions class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions Properties

Properties
Name | Description
AllowEdit | Enables or disables a finished report editing. Default value is True.
AllowPreviewEdit | Enables InPlace editors in the report preview. Allows user to edit prepared report text and other properties without the report designer.
Buttons | A set of buttons, which will be available in the preview window. You can combine any of these values. Default value is: all buttons.
DoubleBuffered | A double-buffer mode for the preview window. If enabled (by default), the preview window will not flicker during repainting, but the process speed will be reduced.
Maximized | Defines if the preview window is maximized. Default value is True.
MDIChild | Defines if the preview window is MDIChild (for MDI interface organizing). Default value is False.
Modal | Defines if the preview window is modal. Default value is True.
OutlineExpand | Determines whether to expand all outline items.
OutlineVisible | Defines if the panel with the report outline is visible. Default value is False.
OutlineWidth | Defines width of the panel with the report outline, in pixels. Default value is 120.
PagesInCache | Determines how many prepared pages are located in memory. Other stored as serialized XML and loads by request.
PictureCacheInFile | Activates the mode of caching all pictures in the file, saves memory while displaying the reports with a large quantity of pictures.
RTLPreview | Enables RTL page output in preview.
ShowCaptions | Defines if button captions are displayed. When enabling thisproperty, you should limit the number of the displayed buttons in theButtons property, since all the buttons will not find room on thescreen.
ThumbnailVisible | Defines if the panel with the report thumbnail is visible. Default value is False.
Zoom | Default scale of the report in the report preview.
ZoomMode | Default zooming mode.
Top


TfrxPreviewOptions.AllowEdit Property

Summary

Enables or disables a finished report editing. Default value is True.

Namespace: frxClass
Syntax
Delphi
published
 property AllowEdit: Boolean read FAllowEdit write FAllowEdit default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.AllowPreviewEdit Property

Summary

Enables InPlace editors in the report preview. Allows user to edit prepared report text and other properties without the report designer.

Namespace: frxClass
Syntax
Delphi
published
 property AllowPreviewEdit: Boolean read FAllowPreviewEdit write FAllowPreviewEdit default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.Buttons Property

Summary

A set of buttons, which will be available in the preview window. You can combine any of these values. Default value is: all buttons.

Namespace: frxClass
Syntax
Delphi
published
 property Buttons: TfrxPreviewButtons read FButtons write FButtons;

Property Value

Type: TfrxPreviewButtons

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.DoubleBuffered Property

Summary

A double-buffer mode for the preview window. If enabled (by default), the preview window will not flicker during repainting, but the process speed will be reduced.

Namespace: frxClass
Syntax
Delphi
published
 property DoubleBuffered: Boolean read FDoubleBuffered write FDoubleBuffered default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.Maximized Property

Summary

Defines if the preview window is maximized. Default value is True.

Namespace: frxClass
Syntax
Delphi
published
 property Maximized: Boolean read FMaximized write FMaximized default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.MDIChild Property

Summary

Defines if the preview window is MDIChild (for MDI interface organizing). Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property MDIChild: Boolean read FMDIChild write FMDIChild default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.Modal Property

Summary

Defines if the preview window is modal. Default value is True.

Namespace: frxClass
Syntax
Delphi
published
 property Modal: Boolean read FModal write FModal default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.OutlineExpand Property

Summary

Determines whether to expand all outline items.

Namespace: frxClass
Syntax
Delphi
published
 property OutlineExpand: Boolean read FOutlineExpand write FOutlineExpand default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.OutlineVisible Property

Summary

Defines if the panel with the report outline is visible. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property OutlineVisible: Boolean read FOutlineVisible write FOutlineVisible default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.OutlineWidth Property

Summary

Defines width of the panel with the report outline, in pixels. Default value is 120.

Namespace: frxClass
Syntax
Delphi
published
 property OutlineWidth: Integer read FOutlineWidth write FOutlineWidth default 120;

Property Value

Type: Integer

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.PagesInCache Property

Summary

Determines how many prepared pages are located in memory. Other stored as serialized XML and loads by request.

Namespace: frxClass
Syntax
Delphi
published
 property PagesInCache: Integer read FPagesInCache write FPagesInCache default 50;

Property Value

Type: Integer

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.PictureCacheInFile Property

Summary

Activates the mode of caching all pictures in the file, saves memory while displaying the reports with a large quantity of pictures.

Namespace: frxClass
Syntax
Delphi
published
 property PictureCacheInFile: Boolean read FPictureCacheInFile write FPictureCacheInFile default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.RTLPreview Property

Summary

Enables RTL page output in preview.

Namespace: frxClass
Syntax
Delphi
public
 property RTLPreview: Boolean read FRTLPreview write FRTLPreview;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.ShowCaptions Property

Summary

Defines if button captions are displayed. When enabling thisproperty, you should limit the number of the displayed buttons in theButtons property, since all the buttons will not find room on thescreen.

Namespace: frxClass
Syntax
Delphi
published
 property ShowCaptions: Boolean read FShowCaptions write FShowCaptions default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.ThumbnailVisible Property

Summary

Defines if the panel with the report thumbnail is visible. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property ThumbnailVisible: Boolean read FThumbnailVisible write FThumbnailVisible default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.Zoom Property

Summary

Default scale of the report in the report preview.

Namespace: frxClass
Syntax
Delphi
published
 property Zoom: Extended read FZoom write FZoom;

Property Value

Type: Extended

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.ZoomMode Property

Summary

Default zooming mode.

Namespace: frxClass
Syntax
Delphi
published
 property ZoomMode: TfrxZoomMode read FZoomMode write FZoomMode default zmDefault;

Property Value

Type: TfrxZoomMode

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions Methods

Methods
Name | Description
Assign(TPersistent) | Copies the contents from another object.
Clear | Clears all properties and fills them by default values.
Top


TfrxPreviewOptions.Assign(TPersistent) Method

Summary

Copies the contents from another object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.Clear Method

Summary

Clears all properties and fills them by default values.

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions Fields

Fields
Name | Description
FAllowEdit | Represents field FAllowEdit.
FAllowPreviewEdit | Represents field FAllowPreviewEdit.
FButtons | Represents field FButtons.
FDoubleBuffered | Represents field FDoubleBuffered.
FMaximized | Represents field FMaximized.
FMDIChild | Represents field FMDIChild.
FModal | Represents field FModal.
FOutlineExpand | Represents field FOutlineExpand.
FOutlineVisible | Represents field FOutlineVisible.
FOutlineWidth | Represents field FOutlineWidth.
FPagesInCache | Represents field FPagesInCache.
FPictureCacheInFile | Represents field FPictureCacheInFile.
FRTLPreview | Represents field FRTLPreview.
FShowCaptions | Represents field FShowCaptions.
FThumbnailVisible | Represents field FThumbnailVisible.
FZoom | Represents field FZoom.
FZoomMode | Represents field FZoomMode.
Top


TfrxPreviewOptions.FAllowEdit Field

Summary

Represents field FAllowEdit.

Namespace: frxClass
Syntax
Delphi
private
 FAllowEdit: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FAllowPreviewEdit Field

Summary

Represents field FAllowPreviewEdit.

Namespace: frxClass
Syntax
Delphi
private
 FAllowPreviewEdit: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FButtons Field

Summary

Represents field FButtons.

Namespace: frxClass
Syntax
Delphi
private
 FButtons: TfrxPreviewButtons;

Field Value

Type: TfrxPreviewButtons

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FDoubleBuffered Field

Summary

Represents field FDoubleBuffered.

Namespace: frxClass
Syntax
Delphi
private
 FDoubleBuffered: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FMaximized Field

Summary

Represents field FMaximized.

Namespace: frxClass
Syntax
Delphi
private
 FMaximized: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FMDIChild Field

Summary

Represents field FMDIChild.

Namespace: frxClass
Syntax
Delphi
private
 FMDIChild: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FModal Field

Summary

Represents field FModal.

Namespace: frxClass
Syntax
Delphi
private
 FModal: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FOutlineExpand Field

Summary

Represents field FOutlineExpand.

Namespace: frxClass
Syntax
Delphi
private
 FOutlineExpand: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FOutlineVisible Field

Summary

Represents field FOutlineVisible.

Namespace: frxClass
Syntax
Delphi
private
 FOutlineVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FOutlineWidth Field

Summary

Represents field FOutlineWidth.

Namespace: frxClass
Syntax
Delphi
private
 FOutlineWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FPagesInCache Field

Summary

Represents field FPagesInCache.

Namespace: frxClass
Syntax
Delphi
private
 FPagesInCache: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FPictureCacheInFile Field

Summary

Represents field FPictureCacheInFile.

Namespace: frxClass
Syntax
Delphi
private
 FPictureCacheInFile: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FRTLPreview Field

Summary

Represents field FRTLPreview.

Namespace: frxClass
Syntax
Delphi
private
 FRTLPreview: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FShowCaptions Field

Summary

Represents field FShowCaptions.

Namespace: frxClass
Syntax
Delphi
private
 FShowCaptions: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FThumbnailVisible Field

Summary

Represents field FThumbnailVisible.

Namespace: frxClass
Syntax
Delphi
private
 FThumbnailVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FZoom Field

Summary

Represents field FZoom.

Namespace: frxClass
Syntax
Delphi
private
 FZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewOptions.FZoomMode Field

Summary

Represents field FZoomMode.

Namespace: frxClass
Syntax
Delphi
private
 FZoomMode: TfrxZoomMode;

Field Value

Type: TfrxZoomMode

See Also

Reference

  • TfrxPreviewOptions
  • frxClass


TfrxPreviewPagesList Class

Summary

The TfrxPreviewPagesList class represents list of TfrxCustomPreviewPages. Each TfrxReport instance can have several TfrxCustomPreviewPages instances. This class used to manage all preview pages in the report component.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxPreviewPagesList
Syntax
Delphi
type
 TfrxPreviewPagesList = class
 end;

The TfrxPreviewPagesList type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport) | Constructor.
Destroy | Represents the destructor of the TfrxPreviewPagesList class.
Top
Properties
Show:
Name | Description
Current | Stores current active preview pages. TfrxReport uses this property for any operations with preview pages.
Main | Stores main preview pages. This pages could not be deleted by clear method, it frees at destruction.
Top
Methods
Show:
Name | Description
Add | Adds new instance of PreviewPages.
AddAsCurrent | Adds new instance of PreviewPages and set it active(current).
Clear | Clears and free all preview pages instances instead main.
Count | Returns count of preview pages in collection.
CurPagesChanged | Represents method CurPagesChanged.
Delete(Integer) | Overloaded. Delete instance of TfrxCustomPreviewPages from list by index.
Delete(TfrxCustomPreviewPages) | Overloaded. Delete instance of TfrxCustomPreviewPages from list.
GetCurrent | Represents method GetCurrent.
GetMain | Represents method GetMain.
SetCurrent(TfrxCustomPreviewPages) | Represents method SetCurrent(TfrxCustomPreviewPages).
SetCurrentIndex(Integer) | Represents method SetCurrentIndex(Integer).
SetMain(TfrxCustomPreviewPages) | Represents method SetMain(TfrxCustomPreviewPages).
Top
Fields
Show:
Name | Description
FCurrentIndex | Represents field FCurrentIndex.
FList | Represents field FList.
FReport | Represents field FReport.
Top
See Also

Reference

  • frxClass


TfrxPreviewPagesList Constructors

Constructors
Name | Description
Create(TfrxReport) | Constructor.
Destroy | Represents the destructor of the TfrxPreviewPagesList class.
Top


TfrxPreviewPagesList.Create(TfrxReport) Constructor

Summary

Constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(aReport: TfrxReport);

Parameters

aReport
Type: TfrxReport

The report component.

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.Destroy Destructor

Summary

Represents the destructor of the TfrxPreviewPagesList class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList Properties

Properties
Name | Description
Current | Stores current active preview pages. TfrxReport uses this property for any operations with preview pages.
Main | Stores main preview pages. This pages could not be deleted by clear method, it frees at destruction.
Top


TfrxPreviewPagesList.Current Property

Summary

Stores current active preview pages. TfrxReport uses this property for any operations with preview pages.

Namespace: frxClass
Syntax
Delphi
public
 property Current: TfrxCustomPreviewPages read GetCurrent write SetCurrent;

Property Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.Main Property

Summary

Stores main preview pages. This pages could not be deleted by clear method, it frees at destruction.

Namespace: frxClass
Syntax
Delphi
public
 property Main: TfrxCustomPreviewPages read GetMain write SetMain;

Property Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList Methods

Methods
Name | Description
Add | Adds new instance of PreviewPages.
AddAsCurrent | Adds new instance of PreviewPages and set it active(current).
Clear | Clears and free all preview pages instances instead main.
Count | Returns count of preview pages in collection.
CurPagesChanged | Represents method CurPagesChanged.
Delete(Integer) | Overloaded. Delete instance of TfrxCustomPreviewPages from list by index.
Delete(TfrxCustomPreviewPages) | Overloaded. Delete instance of TfrxCustomPreviewPages from list.
GetCurrent | Represents method GetCurrent.
GetMain | Represents method GetMain.
SetCurrent(TfrxCustomPreviewPages) | Represents method SetCurrent(TfrxCustomPreviewPages).
SetCurrentIndex(Integer) | Represents method SetCurrentIndex(Integer).
SetMain(TfrxCustomPreviewPages) | Represents method SetMain(TfrxCustomPreviewPages).
Top


TfrxPreviewPagesList.Add Method

Summary

Adds new instance of PreviewPages.

Namespace: frxClass
Syntax
Delphi
public
 function Add: TfrxCustomPreviewPages;

Return Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.AddAsCurrent Method

Summary

Adds new instance of PreviewPages and set it active(current).

Namespace: frxClass
Syntax
Delphi
public
 function AddAsCurrent: TfrxCustomPreviewPages;

Return Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.Clear Method

Summary

Clears and free all preview pages instances instead main.

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.Count Method

Summary

Returns count of preview pages in collection.

Namespace: frxClass
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.CurPagesChanged Method

Summary

Represents method CurPagesChanged.

Namespace: frxClass
Syntax
Delphi
private
 procedure CurPagesChanged;
See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.Delete(Integer) Method

Summary

Delete instance of TfrxCustomPreviewPages from list by index.

Namespace: frxClass
Syntax
Delphi
public
 procedure Delete(Index: Integer); overload;

Parameters

Index
Type: Integer

Index in list to delete.

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.Delete(TfrxCustomPreviewPages) Method

Summary

Delete instance of TfrxCustomPreviewPages from list.

Namespace: frxClass
Syntax
Delphi
public
 procedure Delete(aPages: TfrxCustomPreviewPages); overload;

Parameters

aPages
Type: TfrxCustomPreviewPages

Reference to instance that should be deleted.

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.GetCurrent Method

Summary

Represents method GetCurrent.

Namespace: frxClass
Syntax
Delphi
private
 function GetCurrent: TfrxCustomPreviewPages;

Return Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.GetMain Method

Summary

Represents method GetMain.

Namespace: frxClass
Syntax
Delphi
private
 function GetMain: TfrxCustomPreviewPages;

Return Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.SetCurrent(TfrxCustomPreviewPages) Method

Summary

Represents method SetCurrent(TfrxCustomPreviewPages).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetCurrent(const Value: TfrxCustomPreviewPages);

Parameters

Value
Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.SetCurrentIndex(Integer) Method

Summary

Represents method SetCurrentIndex(Integer).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetCurrentIndex(Index: Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.SetMain(TfrxCustomPreviewPages) Method

Summary

Represents method SetMain(TfrxCustomPreviewPages).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetMain(const Value: TfrxCustomPreviewPages);

Parameters

Value
Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList Fields

Fields
Name | Description
FCurrentIndex | Represents field FCurrentIndex.
FList | Represents field FList.
FReport | Represents field FReport.
Top


TfrxPreviewPagesList.FCurrentIndex Field

Summary

Represents field FCurrentIndex.

Namespace: frxClass
Syntax
Delphi
private
 FCurrentIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.FList Field

Summary

Represents field FList.

Namespace: frxClass
Syntax
Delphi
private
 FList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPreviewPagesList.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxPreviewPagesList
  • frxClass


TfrxPrintOptions Class

Summary

The TfrxPrintOptions class represents a set of properties, which relate to the report printing. Instance of this class is stored in the TfrxReport.PrintOptions.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxPrintOptions
Syntax
Delphi
type
 TfrxPrintOptions = class(TPersistent)
 end;

The TfrxPrintOptions type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxPrintOptions class.
Top
Properties
Show:
Name | Description
Collate | Whether to collate the copies. Default value is True.
Copies | The number of the printable copies by default. Default value is 1.
Duplex | Global duplex settings. Set only after prepare report.
PageNumbers | Page numbers, which are to be printed. For example, "1,3,5-12,17-".
Printer | Printer name.
PrintMode | The print mode: default; split large page on several smaller pages; join several small pages on a large page; print a page on a specified paper size (use scaling).
PrintOnSheet | The paper size to print a report on. Used if PrintMode is not pmDefault. One of DMBIN_XXX values defined in the Windows.pas.
PrintPages | Defines the pages to be printed. The following values are available: ppAll - all; ppOdd - odd; ppEven - even.
PrnOutFileName | File name of printed output when prints to a file.
Reverse | Determines whether to print pages in reverse order.
ShowDialog | Whether to display a print dialogue. Default value is True.
SplicingLine | Size of slicing line used for some Print modes.
SwapPageSize | Not used.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Copies the contents from another object.
Clear | Clears all properties and fills them by default values.
Top
Fields
Show:
Name | Description
FCollate | Represents field FCollate.
FCopies | Represents field FCopies.
FDuplex | Represents field FDuplex.
FPageNumbers | Represents field FPageNumbers.
FPagesOnSheet | Represents field FPagesOnSheet.
FPrinter | Represents field FPrinter.
FPrintMode | Represents field FPrintMode.
FPrintOnSheet | Represents field FPrintOnSheet.
FPrintPages | Represents field FPrintPages.
FPrnOutFileName | Represents field FPrnOutFileName.
FReverse | Represents field FReverse.
FShowDialog | Represents field FShowDialog.
FSplicingLine | Represents field FSplicingLine.
FSwapPageSize | Represents field FSwapPageSize.
Top
See Also

Reference

  • frxClass


TfrxPrintOptions Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxPrintOptions class.
Top


TfrxPrintOptions.Create Constructor

Summary

Initializes a new instance of the TfrxPrintOptions class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions Properties

Properties
Name | Description
Collate | Whether to collate the copies. Default value is True.
Copies | The number of the printable copies by default. Default value is 1.
Duplex | Global duplex settings. Set only after prepare report.
PageNumbers | Page numbers, which are to be printed. For example, "1,3,5-12,17-".
Printer | Printer name.
PrintMode | The print mode: default; split large page on several smaller pages; join several small pages on a large page; print a page on a specified paper size (use scaling).
PrintOnSheet | The paper size to print a report on. Used if PrintMode is not pmDefault. One of DMBIN_XXX values defined in the Windows.pas.
PrintPages | Defines the pages to be printed. The following values are available: ppAll - all; ppOdd - odd; ppEven - even.
PrnOutFileName | File name of printed output when prints to a file.
Reverse | Determines whether to print pages in reverse order.
ShowDialog | Whether to display a print dialogue. Default value is True.
SplicingLine | Size of slicing line used for some Print modes.
SwapPageSize | Not used.
Top


TfrxPrintOptions.Collate Property

Summary

Whether to collate the copies. Default value is True.

Namespace: frxClass
Syntax
Delphi
published
 property Collate: Boolean read FCollate write FCollate default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.Copies Property

Summary

The number of the printable copies by default. Default value is 1.

Namespace: frxClass
Syntax
Delphi
published
 property Copies: Integer read FCopies write FCopies default 1;

Property Value

Type: Integer

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.Duplex Property

Summary

Global duplex settings. Set only after prepare report.

Namespace: frxClass
Syntax
Delphi
public
 property Duplex: TfrxDuplexMode read FDuplex write FDuplex;

Property Value

Type: TfrxDuplexMode

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.PageNumbers Property

Summary

Page numbers, which are to be printed. For example, "1,3,5-12,17-".

Namespace: frxClass
Syntax
Delphi
published
 property PageNumbers: String read FPageNumbers write FPageNumbers;

Property Value

Type: String

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.Printer Property

Summary

Printer name.

Namespace: frxClass
Syntax
Delphi
published
 property Printer: String read FPrinter write FPrinter;

Property Value

Type: String

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.PrintMode Property

Summary

The print mode: default; split large page on several smaller pages; join several small pages on a large page; print a page on a specified paper size (use scaling).

Namespace: frxClass
Syntax
Delphi
published
 property PrintMode: TfrxPrintMode read FPrintMode write FPrintMode default pmDefault;

Property Value

Type: TfrxPrintMode

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.PrintOnSheet Property

Summary

The paper size to print a report on. Used if PrintMode is not pmDefault. One of DMBIN_XXX values defined in the Windows.pas.

Namespace: frxClass
Syntax
Delphi
published
 property PrintOnSheet: Integer read FPrintOnSheet write FPrintOnSheet;

Property Value

Type: Integer

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.PrintPages Property

Summary

Defines the pages to be printed. The following values are available:
ppAll - all;
ppOdd - odd;
ppEven - even.

Namespace: frxClass
Syntax
Delphi
published
 property PrintPages: TfrxPrintPages read FPrintPages write FPrintPages default ppAll;

Property Value

Type: TfrxPrintPages

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.PrnOutFileName Property

Summary

File name of printed output when prints to a file.

Namespace: frxClass
Syntax
Delphi
public
 property PrnOutFileName: String read FPrnOutFileName write FPrnOutFileName;

Property Value

Type: String

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.Reverse Property

Summary

Determines whether to print pages in reverse order.

Namespace: frxClass
Syntax
Delphi
published
 property Reverse: Boolean read FReverse write FReverse default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.ShowDialog Property

Summary

Whether to display a print dialogue. Default value is True.

Namespace: frxClass
Syntax
Delphi
published
 property ShowDialog: Boolean read FShowDialog write FShowDialog default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.SplicingLine Property

Summary

Size of slicing line used for some Print modes.

Namespace: frxClass
Syntax
Delphi
public
 property SplicingLine: Integer read FSplicingLine write FSplicingLine default 3;

Property Value

Type: Integer

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.SwapPageSize Property

Summary

Not used.

Namespace: frxClass
Syntax
Delphi
published
 property SwapPageSize: Boolean read FSwapPageSize write FSwapPageSize stored False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions Methods

Methods
Name | Description
Assign(TPersistent) | Copies the contents from another object.
Clear | Clears all properties and fills them by default values.
Top


TfrxPrintOptions.Assign(TPersistent) Method

Summary

Copies the contents from another object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.Clear Method

Summary

Clears all properties and fills them by default values.

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions Fields

Fields
Name | Description
FCollate | Represents field FCollate.
FCopies | Represents field FCopies.
FDuplex | Represents field FDuplex.
FPageNumbers | Represents field FPageNumbers.
FPagesOnSheet | Represents field FPagesOnSheet.
FPrinter | Represents field FPrinter.
FPrintMode | Represents field FPrintMode.
FPrintOnSheet | Represents field FPrintOnSheet.
FPrintPages | Represents field FPrintPages.
FPrnOutFileName | Represents field FPrnOutFileName.
FReverse | Represents field FReverse.
FShowDialog | Represents field FShowDialog.
FSplicingLine | Represents field FSplicingLine.
FSwapPageSize | Represents field FSwapPageSize.
Top


TfrxPrintOptions.FCollate Field

Summary

Represents field FCollate.

Namespace: frxClass
Syntax
Delphi
private
 FCollate: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FCopies Field

Summary

Represents field FCopies.

Namespace: frxClass
Syntax
Delphi
private
 FCopies: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FDuplex Field

Summary

Represents field FDuplex.

Namespace: frxClass
Syntax
Delphi
private
 FDuplex: TfrxDuplexMode;

Field Value

Type: TfrxDuplexMode

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FPageNumbers Field

Summary

Represents field FPageNumbers.

Namespace: frxClass
Syntax
Delphi
private
 FPageNumbers: String;

Field Value

Type: String

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FPagesOnSheet Field

Summary

Represents field FPagesOnSheet.

Namespace: frxClass
Syntax
Delphi
private
 FPagesOnSheet: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FPrinter Field

Summary

Represents field FPrinter.

Namespace: frxClass
Syntax
Delphi
private
 FPrinter: String;

Field Value

Type: String

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FPrintMode Field

Summary

Represents field FPrintMode.

Namespace: frxClass
Syntax
Delphi
private
 FPrintMode: TfrxPrintMode;

Field Value

Type: TfrxPrintMode

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FPrintOnSheet Field

Summary

Represents field FPrintOnSheet.

Namespace: frxClass
Syntax
Delphi
private
 FPrintOnSheet: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FPrintPages Field

Summary

Represents field FPrintPages.

Namespace: frxClass
Syntax
Delphi
private
 FPrintPages: TfrxPrintPages;

Field Value

Type: TfrxPrintPages

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FPrnOutFileName Field

Summary

Represents field FPrnOutFileName.

Namespace: frxClass
Syntax
Delphi
private
 FPrnOutFileName: String;

Field Value

Type: String

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FReverse Field

Summary

Represents field FReverse.

Namespace: frxClass
Syntax
Delphi
private
 FReverse: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FShowDialog Field

Summary

Represents field FShowDialog.

Namespace: frxClass
Syntax
Delphi
private
 FShowDialog: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FSplicingLine Field

Summary

Represents field FSplicingLine.

Namespace: frxClass
Syntax
Delphi
private
 FSplicingLine: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxPrintOptions.FSwapPageSize Field

Summary

Represents field FSwapPageSize.

Namespace: frxClass
Syntax
Delphi
private
 FSwapPageSize: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPrintOptions
  • frxClass


TfrxRefreshReportCommand Class

Summary

This class implements realization of deferred RefreshReport command.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxBaseDelayedCommand
frxClass.TfrxBasePrepareReportCommand
frxClass.TfrxRefreshReportCommand
Syntax
Delphi
type
 TfrxRefreshReportCommand = class(TfrxBasePrepareReportCommand)
 end;

The TfrxRefreshReportCommand type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport,Boolean) | Command constructor. (Inherited from TfrxBasePrepareReportCommand.)
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseDelayedCommand.)
GetInstance | Get command instance. (Inherited from TfrxBaseDelayedCommand.)
GetName | Get symbolic name of current command instance. (Inherited from TfrxBaseDelayedCommand.)
QueryInterface(TGUID,Void) | Represents method QueryInterface(TGUID,Void). (Inherited from TfrxBaseDelayedCommand.)
Run | Runs command. (Overrides TfrxBasePrepareReportCommand.Run.)
_AddRef | Represents method _AddRef. (Inherited from TfrxBaseDelayedCommand.)
_Release | Represents method _Release. (Inherited from TfrxBaseDelayedCommand.)
Top
See Also

Reference

  • frxClass


TfrxRefreshReportCommand Methods

Methods
Name | Description
Run | Runs command. (Overrides TfrxBasePrepareReportCommand.Run.)
Top


TfrxRefreshReportCommand.Run Method

Summary

Runs command.

Namespace: frxClass
Syntax
Delphi
public
 procedure Run; override;

Overrides

TfrxBasePrepareReportCommand.Run
See Also

Reference

  • TfrxRefreshReportCommand
  • frxClass


TfrxReport Class

Summary

The TfrxReport component is the main one. One TfrxReport component contains one report. In design-time, double-clicking the component calls the report designer. The component has all necessary properties and methods for report loading and saving, design and viewing.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReport
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxReport = class(TfrxComponent)
 end;

The TfrxReport type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxReport class. (Overrides TfrxComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxReport class. (Overrides TfrxComponent.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
CaseSensitiveExpressions | If True , then the expression will be catching subject to the letter list . It is necessary to use the same text with different letter list in expression.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
CurObject | Reference to a current processed object by report engine. The engine sets it before process report object.
DataSet | Dataset for a report. If this property is set, the report will be printed as many times as many records in the dataset.
DataSetName | The same as DataSet property but contains symbolic link to a DataSet.
DataSets | The list of data sets available for the report.
Description | Object's description. (Inherited from TfrxComponent.)
Designer | A link to the report designer (actual when the designer is enabled).
DotMatrixReport | Defines whether the report is dot-matrix. When setting this property to True, the report may contain dot-matrix pages (TfrxDMPPage) and objects. Don't set this property directly. Use the "File|New..." menu item to create dot-matrix reports.
DrillState | The list with drill down states names. Groups names in this list are expanded. To collapse or expand groups remove or add group name to the list.
EnabledDataSets | The list of enabled data sets available for the report. When EngineOptions.UseGlobalDataSetList is True, th report component uses this list instead of Global.
Engine | A link to the report engine. It is useful in cases when it is necessary to operate a process of the report construction from a code.
EngineOptions | A set of properties related to the FastReport engine.
Errors | The list of errors, occurring during one or another operation.
FileName | Defines a report file name; it is displayed in the designer. The LoadFromFile method fills this property.
Font | Object's font. (Inherited from TfrxComponent.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
IndexTag | Not used. (Inherited from TfrxComponent.)
IniFile | A file name or a name of the registry key for storing the FastReport environment settings.
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
LocalValue | Current value used for <Value> variable inside expressions.
MainPreviewPages | Reference to main preview pages instance of finished report belongs to the report.
Modified | This property indicates that report was modified by the report designer.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OldStyleProgress | Shows legacy progress message window. Do not use it.
OnAfterPrintReport | Occurs after printing a report.
OnAfterScriptCompile | Occurs after script compilation and before the report engine stars report preparation.
OnBeginDoc | Occurs when running a report.
OnClosePreview | Occurs when preview form closed.
OnEndDoc | Occurs after finishing a report.
OnPreview | Occurs before displaying a preview window.
OnPrintReport | Occurs before printing a report.
OnReportPrint | Occurs when papered report being printed.
OnRunDialogs | Name of the script procedure which will be called when report dialog page is previewed.
OnStartReport | Name of the script procedure which will be called when report starts.
OnStopReport | Name of the script procedure which will be called when report finishes.
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
PagesCount | Number of pages in a report template.
Pages[Integer] | The list of report pages. The pages of the "dialogue form" type are also included in this list.
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
ParentReport | The name of a base report. Used if you inherit the report from a base.
Preview | A link to the "TfrxPreview" component, in which the finished report should be displayed. If this property is blank, a report is displayed in the standard preview window.
PreviewForm | Current preview from if preview for is open.
PreviewOptions | A set of properties, relating to the report preview.
PreviewPages | A link to current pages of a finished report. It is used in all operations, which are connected with a finished report (printing, saving, export, etc.).
PreviewPagesList | List of preview pages generated by current instance of the report. This class used to manage all previewpages in the report component.
PrintOptions | A set of properties, which relate to the report printing.
Reloading | True when report is reloading(When component loads report).
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
ReportOptions | Defines a set of properties relating to the report.
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Script | The "TfsScript" component, linked to the report. By using this link, you can add your variables, classes, functions, which can be used in a report script in the future. See more in the FastScript developer's manual.
ScriptLanguage | Script language used in a report. The following values are valid: PascalScript, C++Script, BasicScript, JScript.
ScriptText | Script text.
SelfValue | Current value used for <Self> variable inside expressions.
ShowProgress | Set to True when need progress message to be shown.
StoreInDFM | Set to False when do not need to save report to DFM.
Styles | Report style. See more about operating with styles in the FastReport programmer's manual.
Terminated | Indicates that report was terminated during preparation. Set it to true manually will cause exit from the report preparation state. The termination is not instant.
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Variables | The list of report variables. See more about operating with variables in the FastReport programmer's manual.
Version | Represents property Version.
Visible | Global visibility of the object in the result report. (Inherited from TfrxComponent.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
XMLSerializer | Reference to active XML serializer instance.
Top
Methods
Show:
Name | Description
AddFunction(String,String,String) | Adds a user function to the list of the functions available in the report. See the FastReport developer's manual about this method.
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
AncestorNotFound(TReader,string,TPersistentClass,TComponent) | Represents method AncestorNotFound(TReader,string,TPersistentClass,TComponent).
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Calc(String,TfsScript) | Calculates the "Expr" expression and returns the result.
CallMethod(TObject,TClass,String,Variant) | Represents method CallMethod(TObject,TClass,String,Variant).
CheckDataPage | This method checks for DataPage in current report and if it's not exist, creates one.
Clear | Creates a unique name for an object placed into the report. (Overrides TfrxComponent.Clear.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DesignPreviewPage | Calls designer for set report editing (deletes bands, blocks inlay code e.t.c).
DesignReport(Boolean,Boolean) | Overloaded. Calls the report designer. The designer component must be included into your project (to perform this, you can either place the "TfrxDesigner" component on the form , or include the "frxDesgn" unit into the "Uses" list). The Modal parameter determines whether the designer should be modal. The MDIChild parameter allows to make a designer window a MDI child window.
DesignReport(IUnknown,TObject) | Overloaded. Serves IDE report designer.
DesignReportInPanel(TWinControl) | Shows designer in specified panel.
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoAfterPrint(TfrxReportComponent) | Serves AfterPrint event.
DoBeforePrint(TfrxReportComponent) | Serves BeforePrint event.
DoClear | Represents method DoClear.
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoGetAncestor(String,TPersistent) | Represents method DoGetAncestor(String,TPersistent).
DoGetValue(String,Variant) | Represents method DoGetValue(String,Variant).
DoLoadFromStream | Represents method DoLoadFromStream.
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxView,TfrxComponent,TfrxInteractiveEventsParams) | Serves MouseEnter script event.
DoMouseLeave(TfrxView,Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Serves MouseLeave script event.
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(TfrxView,Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Serves MouseUp script event.
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoNotifyEvent(TObject,String,Boolean) | Script Notify event handler.
DoParamEvent(String,Variant,Boolean) | Script parameterized event handler.
DoPreviewClick(TfrxView,TMouseButton,TShiftState,Boolean,TfrxInteractiveEventsParams,Boolean) | Serves PreviewClick event.
DoUserFunction(TObject,TClass,String,Variant) | Represents method DoUserFunction(TObject,TClass,String,Variant).
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Export(TfrxCustomExportFilter) | Exports a report using the specified export filter.
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object by name in the current report template. (Overrides TfrxComponent.FindObject(String).)
FixUpParentReport | Represents method FixUpParentReport.
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetActiveDataSetList(TStrings) | Fill list with active datasets.
GetAlias(TfrxDataSet) | Returns an alias for the given data set. Dataset should be included in the TfrxReport.Datasets.
GetApplicationFolder | This function returns path to application executable.
GetCaseSensitive | Represents method GetCaseSensitive.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetDataset(String) | Returns the data set on its alias name. Dataset should be included in the TfrxReport.Datasets.
GetDatasetAndField(String,TfrxDataSet,String) | Retrieves dataset and field name from an expression like DSName."field name".
GetDataSetList(TStrings,Boolean) | Returns the list of the data sets available in the report in the "List" parameter. The second parameter specifies whether it is necessary to return only the data sets, connected with DB data.
GetDataSetName | Represents method GetDataSetName.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetIniFile | Returns the ini-file instance that stores all the designer settings. It may be either ini-file or registry, depending on IniFile property value.
GetLocalValue | Represents method GetLocalValue.
GetMainPreviewPages | Represents method GetMainPreviewPages.
GetPages(Integer) | Represents method GetPages(Integer).
GetPagesCount | Represents method GetPagesCount.
GetPreviewPages | Represents method GetPreviewPages.
GetReportDrawText | Returns reference to current DrawText object. For thread safe saferty each report instance has own DrawText instance.
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetScriptText | Represents method GetScriptText.
GetScriptValue(TObject,TClass,String,Variant) | Represents method GetScriptValue(TObject,TClass,String,Variant).
GetSelfValue | Represents method GetSelfValue.
InheritFromTemplate(String,TfrxInheriteMode) | The current loaded template inherits from the specified . The first parameter is the name of the parent template, the second one is an inheritance mode: derive inheritance dialogue, delete duplicates , rename duplicates .
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
InternalOnProgress(TfrxProgressType,Integer) | The report engine calls it when some work over report is in progress(preparation, print, export).
InternalOnProgressStart(TfrxProgressType) | The report engine calls it when start some work over report(preparation, print, export).
InternalOnProgressStop(TfrxProgressType) | The report engine calls it when some work over report is in finished(preparation, print, export).
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsReportActionRunning | Returns True when report is preparing or script routine is executing(interactive event).
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromFile(String,Boolean) | Loads a report from a file with given name. If the second parameter is equal to "True," and the file was not found, an exception will be generated. It returns "True," if the file is loaded successfully.
LoadFromFilter(TfrxCustomIOTransport,String) | Loads a report from using IO transport class to get stream of a report.
LoadFromStream(TStream) | Loads a report from the stream. (Overrides TfrxComponent.LoadFromStream(TStream).)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
OnTimer(TObject) | Represents method OnTimer(TObject).
PreparePage(TfrxPage) | Prepares specified report template page in current report.
PrepareReport(Boolean) | Starts a report without a preview window. The parameter assignment is the same as in the "ShowReport" method. If a report is constructed successfully, this function returns "True."
PrepareScript(TfrxReport) | Prepares script engine for work. It compiles script code, adds report objects and user functions to script engine.
PreviewPagesChanged | Represents method PreviewPagesChanged.
Print | Prints a report using printer settings from a PrintOptions property.
ProcessIOTransport(TfrxCustomIOTransport,String,TfrxFilterAccess) | Loads or saves report by using IO transport.
ReadDatasets(TReader) | Represents method ReadDatasets(TReader).
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.ReadNestedProperty(TfrxXMLItem).)
ReadStyle(TReader) | Represents method ReadStyle(TReader).
ReadVariables(TReader) | Represents method ReadVariables(TReader).
RefreshActivePreviewedReport | This method rebuilds current active preview pages.
RestoreScriptObjectsRef | Represents method RestoreScriptObjectsRef.
RunDelayedCommands | Runs all deferred report commands (prepare report, export, print). Used in single thread application. When the report component builds a report and receives another PrepareReport or Export command it puts it in deferred commands list and run a command only after current action is complete.
SaveToFile(String) | Saves a report to a file with given name.
SaveToFilter(TfrxCustomIOTransport,String) | Saves a report from using IO transport class to get stream of a report.
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves a report to the stream. SaveChildren, SaveDefaultValues, UseGetAncestor parameters are not used. (Overrides TfrxComponent.SaveToStream(TStream,Boolean,Boolean,Boolean).)
SelectPrinter | Selects a printer specified in PrintOptions.Printer property.
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCaseSensitive(Boolean) | Represents method SetCaseSensitive(Boolean).
SetDataSet(TfrxDataSet) | Represents method SetDataSet(TfrxDataSet).
SetDataSetName(String) | Represents method SetDataSetName(String).
SetEngineOptions(TfrxEngineOptions) | Represents method SetEngineOptions(TfrxEngineOptions).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetLocalValue(Variant) | Represents method SetLocalValue(Variant).
SetMainPreviewPages(TfrxCustomPreviewPages) | Represents method SetMainPreviewPages(TfrxCustomPreviewPages).
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetParentReport(String) | Represents method SetParentReport(String).
SetPreview(TfrxCustomPreview) | Represents method SetPreview(TfrxCustomPreview).
SetPreviewOptions(TfrxPreviewOptions) | Represents method SetPreviewOptions(TfrxPreviewOptions).
SetPreviewPages(TfrxCustomPreviewPages) | Represents method SetPreviewPages(TfrxCustomPreviewPages).
SetPrintOptions(TfrxPrintOptions) | Represents method SetPrintOptions(TfrxPrintOptions).
SetProgressMessage(String,Boolean,Boolean) | Sets a message to progress bar window if it's active or for status bar text in the report preview.
SetReportOptions(TfrxReportOptions) | Represents method SetReportOptions(TfrxReportOptions).
SetScriptText(TStrings) | Represents method SetScriptText(TStrings).
SetScriptValue(TObject,TClass,String,Variant) | Represents method SetScriptValue(TObject,TClass,String,Variant).
SetScriptVar(String,TObject) | Represents method SetScriptVar(String,TObject).
SetSelfValue(TfrxView) | Represents method SetSelfValue(TfrxView).
SetStyles(TfrxStyles) | Represents method SetStyles(TfrxStyles).
SetTerminated(Boolean) | Represents method SetTerminated(Boolean).
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVersion(String) | Represents method SetVersion(String).
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShowPreparedReport | Displays the report, which was previously built via the "PrepareReport" call.
ShowReport(Boolean) | Starts a report and displays a result in the preview window. If the "ClearLastReport" parameter is equal to "False," then a report will be added to the previously constructed one, otherwise the previously constructed report is cleared (by default).
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateGlobalScritVars | Represents method UpdateGlobalScritVars.
WriteDatasets(TWriter) | Represents method WriteDatasets(TWriter).
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.WriteNestedProperties(TfrxXMLItem,TPersistent).)
WriteStyle(TWriter) | Represents method WriteStyle(TWriter).
WriteVariables(TWriter) | Represents method WriteVariables(TWriter).
Top
Events
Show:
Name | Description
OnAfterDisconnect | Occurs when the report engine close connection to database for internaldatabase components.
OnAfterPrint | When starting a report. It occurs after handling each object.
OnBeforeConnect | Occurs when the report engine establish connection to database forinternal database components.
OnBeforePrint | When starting a report. It occurs before handling each object.
OnClickObject | When previewing a report in the preview window. Occurs when clicking the object.
OnDblClickObject | When previewing a report in the preview window. Occurs when double clicking the object.
OnEditConnection | Occurs when user edit connection in the report wizard.
OnGetCustomData | This event fires when engine loads report XML file and file contains XML item <FrxCustomData>(i.e. store user data inside XML file).All child nodes in this item ignores by serializer. XMLItem contains all the custom user data.
OnGetValue | When starting a report. Occurs when an unknown variable is met. An event handler must return the value of this variable.
OnLoadDetailTemplate | Occurs when a report object loads detail report. The event handler must load the report template (given by TemplateName parameter) into Report object with using parameters of AHyperlink.
OnLoadTemplate | Occurs when a report is an inherited report. The event handler must load the report template (given by TemplateName parameter) into Report object.
OnManualBuild | When starting a report. If the handler of this event is allocated, then the FastReport engine is blocked and you thus would have to construct a report manually.
OnMouseEnter | Occurs when report is previewed in the preview window and mouse pointerenters object rect area.
OnMouseLeave | Occurs when report is previewed in the preview window and mouse pointerleaves object rect area.
OnMouseOverObject | When report is previewed in the preview window. Occurs when mouse cursor passes over the object.
OnNewGetValue | When starting a report. Occurs when an unknown variable is met. An event handler must return the value of this variable.
OnPrintPage | Occurs when printing a report page. The CopyNo parameter determines which copy is printing now (if user choose to print several copies).
OnProgress | This event is fired when performing some continuous operations (print, export, run report). The event handler may display a dialog window with progress bar. Progress parameter is a page number which is currently being processed.
OnProgressStart | This event is fired at start of some continuous operation (print, export, run report). The event handler may display a dialog window with progress bar. Progress parameter is a page number which is currently processed.
OnProgressStop | This event is fired at stop of some continuous operation (print, export, run report). The event handler may display a dialog window with progress bar. Progress parameter is a page number which is currently processed.
OnSaveCustomData | This event fires when serializer saves report template to XML(i.e.store user data inside XML file). If event is set, serializer creates <FrxCustomData> node and pass it as a parameter. Programmer may use this node to create child nodes with custom data.
OnSetConnection | Occurs when user set ConnectionNeme property. Internal use.
OnUserFunction | Occurs when calling a function, added with the help of the "AddFunction" method.
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCommandManager | Represents field FCommandManager.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurObject | Represents field FCurObject.
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
FDataSets | Represents field FDataSets.
FDesigner | Represents field FDesigner.
FDotMatrixReport | Represents field FDotMatrixReport.
FDrawText | Represents field FDrawText.
FDrillState | Represents field FDrillState.
FEnabledDataSets | Represents field FEnabledDataSets.
FEngine | Represents field FEngine.
FEngineOptions | Represents field FEngineOptions.
FErrors | Represents field FErrors.
FExpressionCache | Represents field FExpressionCache.
FFakeScriptText | Represents field FFakeScriptText.
FFileName | Represents field FFileName.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FIniFile | Represents field FIniFile.
FIsScriptObjectsAdded | Represents field FIsScriptObjectsAdded.
FLoadStream | Represents field FLoadStream.
FLocalValue | Represents field FLocalValue.
FModified | Represents field FModified.
FOldStyleProgress | Represents field FOldStyleProgress.
FOnAfterDisconnect | Represents field FOnAfterDisconnect.
FOnAfterPrint | Represents field FOnAfterPrint.
FOnAfterPrintReport | Represents field FOnAfterPrintReport.
FOnAfterScriptCompile | Represents field FOnAfterScriptCompile.
FOnBeforeConnect | Represents field FOnBeforeConnect.
FOnBeforePrint | Represents field FOnBeforePrint.
FOnBeginDoc | Represents field FOnBeginDoc.
FOnClickObject | Represents field FOnClickObject.
FOnClosePreview | Represents field FOnClosePreview.
FOnDblClickObject | Represents field FOnDblClickObject.
FOnEditConnection | Represents field FOnEditConnection.
FOnEndDoc | Represents field FOnEndDoc.
FOnGetCustomDataEvent | Represents field FOnGetCustomDataEvent.
FOnGetValue | Represents field FOnGetValue.
FOnLoadDetailTemplate | Represents field FOnLoadDetailTemplate.
FOnLoadTemplate | Represents field FOnLoadTemplate.
FOnManualBuild | Represents field FOnManualBuild.
FOnMouseEnter | Represents field FOnMouseEnter.
FOnMouseLeave | Represents field FOnMouseLeave.
FOnMouseOverObject | Represents field FOnMouseOverObject.
FOnNewGetValue | Represents field FOnNewGetValue.
FOnPreview | Represents field FOnPreview.
FOnPrintPage | Represents field FOnPrintPage.
FOnPrintReport | Represents field FOnPrintReport.
FOnProgress | Represents field FOnProgress.
FOnProgressStart | Represents field FOnProgressStart.
FOnProgressStop | Represents field FOnProgressStop.
FOnReportPrint | Represents field FOnReportPrint.
FOnRunDialogs | Represents field FOnRunDialogs.
FOnSaveCustomDataEvent | Represents field FOnSaveCustomDataEvent.
FOnSetConnection | Represents field FOnSetConnection.
FOnStartReport | Represents field FOnStartReport.
FOnStopReport | Represents field FOnStopReport.
FOnUserFunction | Represents field FOnUserFunction.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FParentForm | Represents field FParentForm.
FParentReport | Represents field FParentReport.
FParentReportObject | Represents field FParentReportObject.
FPreparing | Represents field FPreparing.
FPreview | Represents field FPreview.
FPreviewForm | Represents field FPreviewForm.
FPreviewOptions | Represents field FPreviewOptions.
FPreviewPagesList | Represents field FPreviewPagesList.
FPrintOptions | Represents field FPrintOptions.
FProgress | Represents field FProgress.
FReloading | Represents field FReloading.
FReportOptions | Represents field FReportOptions.
FSaveParentScript | Represents field FSaveParentScript.
FScript | Represents field FScript.
FScriptLanguage | Represents field FScriptLanguage.
FScriptText | Represents field FScriptText.
FSelfValue | Represents field FSelfValue.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShowProgress | Represents field FShowProgress.
FStoreInDFM | Represents field FStoreInDFM.
FStreamLoaded | Represents field FStreamLoaded.
FStyles | Represents field FStyles.
FSysVariables | Represents field FSysVariables.
FTerminated | Represents field FTerminated.
FTimer | Represents field FTimer.
FVariables | Represents field FVariables.
FVersion | Represents field FVersion.
FXMLSerializer | Represents field FXMLSerializer.
Top
See Also

Reference

  • frxClass


TfrxReport Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxReport class. (Overrides TfrxComponent.Create(TComponent).)
Destroy | Represents the destructor of the TfrxReport class. (Overrides TfrxComponent.Destroy.)
Top


TfrxReport.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxReport class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxComponent.Create(TComponent)
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Destroy Destructor

Summary

Represents the destructor of the TfrxReport class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxComponent.Destroy
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport Properties

Properties
Name | Description
CaseSensitiveExpressions | If True , then the expression will be catching subject to the letter list . It is necessary to use the same text with different letter list in expression.
CurObject | Reference to a current processed object by report engine. The engine sets it before process report object.
DataSet | Dataset for a report. If this property is set, the report will be printed as many times as many records in the dataset.
DataSetName | The same as DataSet property but contains symbolic link to a DataSet.
DataSets | The list of data sets available for the report.
Designer | A link to the report designer (actual when the designer is enabled).
DotMatrixReport | Defines whether the report is dot-matrix. When setting this property to True, the report may contain dot-matrix pages (TfrxDMPPage) and objects. Don't set this property directly. Use the "File|New..." menu item to create dot-matrix reports.
DrillState | The list with drill down states names. Groups names in this list are expanded. To collapse or expand groups remove or add group name to the list.
EnabledDataSets | The list of enabled data sets available for the report. When EngineOptions.UseGlobalDataSetList is True, th report component uses this list instead of Global.
Engine | A link to the report engine. It is useful in cases when it is necessary to operate a process of the report construction from a code.
EngineOptions | A set of properties related to the FastReport engine.
Errors | The list of errors, occurring during one or another operation.
FileName | Defines a report file name; it is displayed in the designer. The LoadFromFile method fills this property.
IniFile | A file name or a name of the registry key for storing the FastReport environment settings.
LocalValue | Current value used for <Value> variable inside expressions.
MainPreviewPages | Reference to main preview pages instance of finished report belongs to the report.
Modified | This property indicates that report was modified by the report designer.
OldStyleProgress | Shows legacy progress message window. Do not use it.
OnAfterPrintReport | Occurs after printing a report.
OnAfterScriptCompile | Occurs after script compilation and before the report engine stars report preparation.
OnBeginDoc | Occurs when running a report.
OnClosePreview | Occurs when preview form closed.
OnEndDoc | Occurs after finishing a report.
OnPreview | Occurs before displaying a preview window.
OnPrintReport | Occurs before printing a report.
OnReportPrint | Occurs when papered report being printed.
OnRunDialogs | Name of the script procedure which will be called when report dialog page is previewed.
OnStartReport | Name of the script procedure which will be called when report starts.
OnStopReport | Name of the script procedure which will be called when report finishes.
PagesCount | Number of pages in a report template.
Pages[Integer] | The list of report pages. The pages of the "dialogue form" type are also included in this list.
ParentReport | The name of a base report. Used if you inherit the report from a base.
Preview | A link to the "TfrxPreview" component, in which the finished report should be displayed. If this property is blank, a report is displayed in the standard preview window.
PreviewForm | Current preview from if preview for is open.
PreviewOptions | A set of properties, relating to the report preview.
PreviewPages | A link to current pages of a finished report. It is used in all operations, which are connected with a finished report (printing, saving, export, etc.).
PreviewPagesList | List of preview pages generated by current instance of the report. This class used to manage all previewpages in the report component.
PrintOptions | A set of properties, which relate to the report printing.
Reloading | True when report is reloading(When component loads report).
ReportOptions | Defines a set of properties relating to the report.
Script | The "TfsScript" component, linked to the report. By using this link, you can add your variables, classes, functions, which can be used in a report script in the future. See more in the FastScript developer's manual.
ScriptLanguage | Script language used in a report. The following values are valid: PascalScript, C++Script, BasicScript, JScript.
ScriptText | Script text.
SelfValue | Current value used for <Self> variable inside expressions.
ShowProgress | Set to True when need progress message to be shown.
StoreInDFM | Set to False when do not need to save report to DFM.
Styles | Report style. See more about operating with styles in the FastReport programmer's manual.
Terminated | Indicates that report was terminated during preparation. Set it to true manually will cause exit from the report preparation state. The termination is not instant.
Variables | The list of report variables. See more about operating with variables in the FastReport programmer's manual.
Version | Represents property Version.
XMLSerializer | Reference to active XML serializer instance.
Top


TfrxReport.CaseSensitiveExpressions Property

Summary

If True , then the expression will be catching subject to the letter list . It is necessary to use the same text with different letter list in expression.

Namespace: frxClass
Syntax
Delphi
public
 property CaseSensitiveExpressions: Boolean read GetCaseSensitive write SetCaseSensitive;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.CurObject Property

Summary

Reference to a current processed object by report engine. The engine sets it before process report object.

Namespace: frxClass
Syntax
Delphi
public
 property CurObject: String read FCurObject write FCurObject;

Property Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DataSet Property

Summary

Dataset for a report. If this property is set, the report will be printed as many times as many records in the dataset.

Namespace: frxClass
Syntax
Delphi
published
 property DataSet: TfrxDataSet read FDataSet write SetDataSet;

Property Value

Type: TfrxDataSet

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DataSetName Property

Summary

The same as DataSet property but contains symbolic link to a DataSet.

Namespace: frxClass
Syntax
Delphi
published
 property DataSetName: String read GetDataSetName write SetDataSetName;

Property Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DataSets Property

Summary

The list of data sets available for the report.

Namespace: frxClass
Syntax
Delphi
public
 property DataSets: TfrxReportDataSets read FDataSets;

Property Value

Type: TfrxReportDataSets

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Designer Property

Summary

A link to the report designer (actual when the designer is enabled).

Namespace: frxClass
Syntax
Delphi
public
 property Designer: TfrxCustomDesigner read FDesigner write FDesigner;

Property Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DotMatrixReport Property

Summary

Defines whether the report is dot-matrix. When setting this property to True, the report may contain dot-matrix pages (TfrxDMPPage) and objects. Don't set this property directly. Use the "File|New..." menu item to create dot-matrix reports.

Namespace: frxClass
Syntax
Delphi
published
 property DotMatrixReport: Boolean read FDotMatrixReport write FDotMatrixReport;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DrillState Property

Summary

The list with drill down states names. Groups names in this list are expanded. To collapse or expand groups remove or add group name to the list.

Namespace: frxClass
Syntax
Delphi
public
 property DrillState: TStrings read FDrillState;

Property Value

Type: TStrings

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.EnabledDataSets Property

Summary

The list of enabled data sets available for the report. When EngineOptions.UseGlobalDataSetList is True, th report component uses this list instead of Global.

Namespace: frxClass
Syntax
Delphi
public
 property EnabledDataSets: TfrxReportDataSets read FEnabledDataSets;

Property Value

Type: TfrxReportDataSets

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Engine Property

Summary

A link to the report engine. It is useful in cases when it is necessary to operate a process of the report construction from a code.

Namespace: frxClass
Syntax
Delphi
public
 property Engine: TfrxCustomEngine read FEngine;

Property Value

Type: TfrxCustomEngine

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.EngineOptions Property

Summary

A set of properties related to the FastReport engine.

Namespace: frxClass
Syntax
Delphi
published
 property EngineOptions: TfrxEngineOptions read FEngineOptions write SetEngineOptions;

Property Value

Type: TfrxEngineOptions

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Errors Property

Summary

The list of errors, occurring during one or another operation.

Namespace: frxClass
Syntax
Delphi
public
 property Errors: TStrings read FErrors;

Property Value

Type: TStrings

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FileName Property

Summary

Defines a report file name; it is displayed in the designer. The LoadFromFile method fills this property.

Namespace: frxClass
Syntax
Delphi
public
 property FileName: String read FFileName write FFileName;

Property Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.IniFile Property

Summary

A file name or a name of the registry key for storing the FastReport environment settings.

Namespace: frxClass
Syntax
Delphi
published
 property IniFile: String read FIniFile write FIniFile;

Property Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.LocalValue Property

Summary

Current value used for <Value> variable inside expressions.

Namespace: frxClass
Syntax
Delphi
public
 property LocalValue: Variant read GetLocalValue write SetLocalValue;

Property Value

Type: Variant

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.MainPreviewPages Property

Summary

Reference to main preview pages instance of finished report belongs to the report.

Namespace: frxClass
Syntax
Delphi
public
 property MainPreviewPages: TfrxCustomPreviewPages read GetMainPreviewPages write SetMainPreviewPages;

Property Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Modified Property

Summary

This property indicates that report was modified by the report designer.

Namespace: frxClass
Syntax
Delphi
public
 property Modified: Boolean read FModified write FModified;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OldStyleProgress Property

Summary

Shows legacy progress message window. Do not use it.

Namespace: frxClass
Syntax
Delphi
published
 property OldStyleProgress: Boolean read FOldStyleProgress write FOldStyleProgress default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnAfterPrintReport Property

Summary

Occurs after printing a report.

Namespace: frxClass
Syntax
Delphi
published
 property OnAfterPrintReport: TNotifyEvent read FOnAfterPrintReport write FOnAfterPrintReport;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnAfterScriptCompile Property

Summary

Occurs after script compilation and before the report engine stars report preparation.

Namespace: frxClass
Syntax
Delphi
published
 property OnAfterScriptCompile: TNotifyEvent read FOnAfterScriptCompile write FOnAfterScriptCompile;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnBeginDoc Property

Summary

Occurs when running a report.

Namespace: frxClass
Syntax
Delphi
published
 property OnBeginDoc: TNotifyEvent read FOnBeginDoc write FOnBeginDoc;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnClosePreview Property

Summary

Occurs when preview form closed.

Namespace: frxClass
Syntax
Delphi
published
 property OnClosePreview: TNotifyEvent read FOnClosePreview write FOnClosePreview;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnEndDoc Property

Summary

Occurs after finishing a report.

Namespace: frxClass
Syntax
Delphi
published
 property OnEndDoc: TNotifyEvent read FOnEndDoc write FOnEndDoc;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnPreview Property

Summary

Occurs before displaying a preview window.

Namespace: frxClass
Syntax
Delphi
published
 property OnPreview: TNotifyEvent read FOnPreview write FOnPreview;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnPrintReport Property

Summary

Occurs before printing a report.

Namespace: frxClass
Syntax
Delphi
published
 property OnPrintReport: TNotifyEvent read FOnPrintReport write FOnPrintReport;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnReportPrint Property

Summary

Occurs when papered report being printed.

Namespace: frxClass
Syntax
Delphi
published
 property OnReportPrint: TfrxNotifyEvent read FOnReportPrint write FOnReportPrint;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnRunDialogs Property

Summary

Name of the script procedure which will be called when report dialog page is previewed.

Namespace: frxClass
Syntax
Delphi
published
 property OnRunDialogs: TfrxRunDialogsEvent read FOnRunDialogs write FOnRunDialogs;

Property Value

Type: TfrxRunDialogsEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnStartReport Property

Summary

Name of the script procedure which will be called when report starts.

Namespace: frxClass
Syntax
Delphi
published
 property OnStartReport: TfrxNotifyEvent read FOnStartReport write FOnStartReport;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnStopReport Property

Summary

Name of the script procedure which will be called when report finishes.

Namespace: frxClass
Syntax
Delphi
published
 property OnStopReport: TfrxNotifyEvent read FOnStopReport write FOnStopReport;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.PagesCount Property

Summary

Number of pages in a report template.

Namespace: frxClass
Syntax
Delphi
public
 property PagesCount: Integer read GetPagesCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Pages[Integer] Property

Summary

The list of report pages. The pages of the "dialogue form" type are also included in this list.

Namespace: frxClass
Syntax
Delphi
public
 property Pages[Index: Integer]: TfrxPage read GetPages;

Parameters

Index
Type: Integer

Property Value

Type: TfrxPage

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.ParentReport Property

Summary

The name of a base report. Used if you inherit the report from a base.

Namespace: frxClass
Syntax
Delphi
published
 property ParentReport: String read FParentReport write SetParentReport;

Property Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Preview Property

Summary

A link to the "TfrxPreview" component, in which the finished report should be displayed. If this property is blank, a report is displayed in the standard preview window.

Namespace: frxClass
Syntax
Delphi
published
 property Preview: TfrxCustomPreview read FPreview write SetPreview;

Property Value

Type: TfrxCustomPreview

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.PreviewForm Property

Summary

Current preview from if preview for is open.

Namespace: frxClass
Syntax
Delphi
public
 property PreviewForm: TForm read FPreviewForm;

Property Value

Type: TForm

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.PreviewOptions Property

Summary

A set of properties, relating to the report preview.

Namespace: frxClass
Syntax
Delphi
published
 property PreviewOptions: TfrxPreviewOptions read FPreviewOptions write SetPreviewOptions;

Property Value

Type: TfrxPreviewOptions

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.PreviewPages Property

Summary

A link to current pages of a finished report. It is used in all operations, which are connected with a finished report (printing, saving, export, etc.).

Namespace: frxClass
Syntax
Delphi
public
 property PreviewPages: TfrxCustomPreviewPages read GetPreviewPages write SetPreviewPages;

Property Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.PreviewPagesList Property

Summary

List of preview pages generated by current instance of the report. This class used to manage all previewpages in the report component.

Namespace: frxClass
Syntax
Delphi
public
 property PreviewPagesList: TfrxPreviewPagesList read FPreviewPagesList;

Property Value

Type: TfrxPreviewPagesList

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.PrintOptions Property

Summary

A set of properties, which relate to the report printing.

Namespace: frxClass
Syntax
Delphi
published
 property PrintOptions: TfrxPrintOptions read FPrintOptions write SetPrintOptions;

Property Value

Type: TfrxPrintOptions

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Reloading Property

Summary

True when report is reloading(When component loads report).

Namespace: frxClass
Syntax
Delphi
public
 property Reloading: Boolean read FReloading write FReloading;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.ReportOptions Property

Summary

Defines a set of properties relating to the report.

Namespace: frxClass
Syntax
Delphi
published
 property ReportOptions: TfrxReportOptions read FReportOptions write SetReportOptions;

Property Value

Type: TfrxReportOptions

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Script Property

Summary

The "TfsScript" component, linked to the report. By using this link, you can add your variables, classes, functions, which can be used in a report script in the future. See more in the FastScript developer's manual.

Namespace: frxClass
Syntax
Delphi
public
 property Script: TfsScript read FScript;

Property Value

Type: TfsScript

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.ScriptLanguage Property

Summary

Script language used in a report. The following values are valid: PascalScript, C++Script, BasicScript, JScript.

Namespace: frxClass
Syntax
Delphi
published
 property ScriptLanguage: String read FScriptLanguage write FScriptLanguage;

Property Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.ScriptText Property

Summary

Script text.

Namespace: frxClass
Syntax
Delphi
published
 property ScriptText: TStrings read GetScriptText write SetScriptText;

Property Value

Type: TStrings

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SelfValue Property

Summary

Current value used for <Self> variable inside expressions.

Namespace: frxClass
Syntax
Delphi
public
 property SelfValue: TfrxView read GetSelfValue write SetSelfValue;

Property Value

Type: TfrxView

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.ShowProgress Property

Summary

Set to True when need progress message to be shown.

Namespace: frxClass
Syntax
Delphi
published
 property ShowProgress: Boolean read FShowProgress write FShowProgress default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.StoreInDFM Property

Summary

Set to False when do not need to save report to DFM.

Namespace: frxClass
Syntax
Delphi
published
 property StoreInDFM: Boolean read FStoreInDFM write FStoreInDFM default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Styles Property

Summary

Report style. See more about operating with styles in the FastReport programmer's manual.

Namespace: frxClass
Syntax
Delphi
public
 property Styles: TfrxStyles read FStyles write SetStyles;

Property Value

Type: TfrxStyles

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Terminated Property

Summary

Indicates that report was terminated during preparation. Set it to true manually will cause exit from the report preparation state. The termination is not instant.

Namespace: frxClass
Syntax
Delphi
public
 property Terminated: Boolean read FTerminated write SetTerminated;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Variables Property

Summary

The list of report variables. See more about operating with variables in the FastReport programmer's manual.

Namespace: frxClass
Syntax
Delphi
public
 property Variables: TfrxVariables read FVariables;

Property Value

Type: TfrxVariables

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Version Property

Summary

Represents property Version.

Namespace: frxClass
Syntax
Delphi
published
 property Version: String read FVersion write SetVersion;

Property Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.XMLSerializer Property

Summary

Reference to active XML serializer instance.

Namespace: frxClass
Syntax
Delphi
public
 property XMLSerializer: TObject read FXMLSerializer;

Property Value

Type: TObject

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport Methods

Methods
Name | Description
AddFunction(String,String,String) | Adds a user function to the list of the functions available in the report. See the FastReport developer's manual about this method.
AncestorNotFound(TReader,string,TPersistentClass,TComponent) | Represents method AncestorNotFound(TReader,string,TPersistentClass,TComponent).
Calc(String,TfsScript) | Calculates the "Expr" expression and returns the result.
CallMethod(TObject,TClass,String,Variant) | Represents method CallMethod(TObject,TClass,String,Variant).
CheckDataPage | This method checks for DataPage in current report and if it's not exist, creates one.
Clear | Creates a unique name for an object placed into the report. (Overrides TfrxComponent.Clear.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DesignPreviewPage | Calls designer for set report editing (deletes bands, blocks inlay code e.t.c).
DesignReport(Boolean,Boolean) | Overloaded. Calls the report designer. The designer component must be included into your project (to perform this, you can either place the "TfrxDesigner" component on the form , or include the "frxDesgn" unit into the "Uses" list). The Modal parameter determines whether the designer should be modal. The MDIChild parameter allows to make a designer window a MDI child window.
DesignReport(IUnknown,TObject) | Overloaded. Serves IDE report designer.
DesignReportInPanel(TWinControl) | Shows designer in specified panel.
DoAfterPrint(TfrxReportComponent) | Serves AfterPrint event.
DoBeforePrint(TfrxReportComponent) | Serves BeforePrint event.
DoClear | Represents method DoClear.
DoGetAncestor(String,TPersistent) | Represents method DoGetAncestor(String,TPersistent).
DoGetValue(String,Variant) | Represents method DoGetValue(String,Variant).
DoLoadFromStream | Represents method DoLoadFromStream.
DoMouseEnter(TfrxView,TfrxComponent,TfrxInteractiveEventsParams) | Serves MouseEnter script event.
DoMouseLeave(TfrxView,Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Serves MouseLeave script event.
DoMouseUp(TfrxView,Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Serves MouseUp script event.
DoNotifyEvent(TObject,String,Boolean) | Script Notify event handler.
DoParamEvent(String,Variant,Boolean) | Script parameterized event handler.
DoPreviewClick(TfrxView,TMouseButton,TShiftState,Boolean,TfrxInteractiveEventsParams,Boolean) | Serves PreviewClick event.
DoUserFunction(TObject,TClass,String,Variant) | Represents method DoUserFunction(TObject,TClass,String,Variant).
Export(TfrxCustomExportFilter) | Exports a report using the specified export filter.
FindObject(String) | Searches for an object by name in the current report template. (Overrides TfrxComponent.FindObject(String).)
FixUpParentReport | Represents method FixUpParentReport.
GetActiveDataSetList(TStrings) | Fill list with active datasets.
GetAlias(TfrxDataSet) | Returns an alias for the given data set. Dataset should be included in the TfrxReport.Datasets.
GetApplicationFolder | This function returns path to application executable.
GetCaseSensitive | Represents method GetCaseSensitive.
GetDataset(String) | Returns the data set on its alias name. Dataset should be included in the TfrxReport.Datasets.
GetDatasetAndField(String,TfrxDataSet,String) | Retrieves dataset and field name from an expression like DSName."field name".
GetDataSetList(TStrings,Boolean) | Returns the list of the data sets available in the report in the "List" parameter. The second parameter specifies whether it is necessary to return only the data sets, connected with DB data.
GetDataSetName | Represents method GetDataSetName.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetIniFile | Returns the ini-file instance that stores all the designer settings. It may be either ini-file or registry, depending on IniFile property value.
GetLocalValue | Represents method GetLocalValue.
GetMainPreviewPages | Represents method GetMainPreviewPages.
GetPages(Integer) | Represents method GetPages(Integer).
GetPagesCount | Represents method GetPagesCount.
GetPreviewPages | Represents method GetPreviewPages.
GetReportDrawText | Returns reference to current DrawText object. For thread safe saferty each report instance has own DrawText instance.
GetScriptText | Represents method GetScriptText.
GetScriptValue(TObject,TClass,String,Variant) | Represents method GetScriptValue(TObject,TClass,String,Variant).
GetSelfValue | Represents method GetSelfValue.
InheritFromTemplate(String,TfrxInheriteMode) | The current loaded template inherits from the specified . The first parameter is the name of the parent template, the second one is an inheritance mode: derive inheritance dialogue, delete duplicates , rename duplicates .
InternalOnProgress(TfrxProgressType,Integer) | The report engine calls it when some work over report is in progress(preparation, print, export).
InternalOnProgressStart(TfrxProgressType) | The report engine calls it when start some work over report(preparation, print, export).
InternalOnProgressStop(TfrxProgressType) | The report engine calls it when some work over report is in finished(preparation, print, export).
IsReportActionRunning | Returns True when report is preparing or script routine is executing(interactive event).
LoadFromFile(String,Boolean) | Loads a report from a file with given name. If the second parameter is equal to "True," and the file was not found, an exception will be generated. It returns "True," if the file is loaded successfully.
LoadFromFilter(TfrxCustomIOTransport,String) | Loads a report from using IO transport class to get stream of a report.
LoadFromStream(TStream) | Loads a report from the stream. (Overrides TfrxComponent.LoadFromStream(TStream).)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
OnTimer(TObject) | Represents method OnTimer(TObject).
PreparePage(TfrxPage) | Prepares specified report template page in current report.
PrepareReport(Boolean) | Starts a report without a preview window. The parameter assignment is the same as in the "ShowReport" method. If a report is constructed successfully, this function returns "True."
PrepareScript(TfrxReport) | Prepares script engine for work. It compiles script code, adds report objects and user functions to script engine.
PreviewPagesChanged | Represents method PreviewPagesChanged.
Print | Prints a report using printer settings from a PrintOptions property.
ProcessIOTransport(TfrxCustomIOTransport,String,TfrxFilterAccess) | Loads or saves report by using IO transport.
ReadDatasets(TReader) | Represents method ReadDatasets(TReader).
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.ReadNestedProperty(TfrxXMLItem).)
ReadStyle(TReader) | Represents method ReadStyle(TReader).
ReadVariables(TReader) | Represents method ReadVariables(TReader).
RefreshActivePreviewedReport | This method rebuilds current active preview pages.
RestoreScriptObjectsRef | Represents method RestoreScriptObjectsRef.
RunDelayedCommands | Runs all deferred report commands (prepare report, export, print). Used in single thread application. When the report component builds a report and receives another PrepareReport or Export command it puts it in deferred commands list and run a command only after current action is complete.
SaveToFile(String) | Saves a report to a file with given name.
SaveToFilter(TfrxCustomIOTransport,String) | Saves a report from using IO transport class to get stream of a report.
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves a report to the stream. SaveChildren, SaveDefaultValues, UseGetAncestor parameters are not used. (Overrides TfrxComponent.SaveToStream(TStream,Boolean,Boolean,Boolean).)
SelectPrinter | Selects a printer specified in PrintOptions.Printer property.
SetCaseSensitive(Boolean) | Represents method SetCaseSensitive(Boolean).
SetDataSet(TfrxDataSet) | Represents method SetDataSet(TfrxDataSet).
SetDataSetName(String) | Represents method SetDataSetName(String).
SetEngineOptions(TfrxEngineOptions) | Represents method SetEngineOptions(TfrxEngineOptions).
SetLocalValue(Variant) | Represents method SetLocalValue(Variant).
SetMainPreviewPages(TfrxCustomPreviewPages) | Represents method SetMainPreviewPages(TfrxCustomPreviewPages).
SetParentReport(String) | Represents method SetParentReport(String).
SetPreview(TfrxCustomPreview) | Represents method SetPreview(TfrxCustomPreview).
SetPreviewOptions(TfrxPreviewOptions) | Represents method SetPreviewOptions(TfrxPreviewOptions).
SetPreviewPages(TfrxCustomPreviewPages) | Represents method SetPreviewPages(TfrxCustomPreviewPages).
SetPrintOptions(TfrxPrintOptions) | Represents method SetPrintOptions(TfrxPrintOptions).
SetProgressMessage(String,Boolean,Boolean) | Sets a message to progress bar window if it's active or for status bar text in the report preview.
SetReportOptions(TfrxReportOptions) | Represents method SetReportOptions(TfrxReportOptions).
SetScriptText(TStrings) | Represents method SetScriptText(TStrings).
SetScriptValue(TObject,TClass,String,Variant) | Represents method SetScriptValue(TObject,TClass,String,Variant).
SetScriptVar(String,TObject) | Represents method SetScriptVar(String,TObject).
SetSelfValue(TfrxView) | Represents method SetSelfValue(TfrxView).
SetStyles(TfrxStyles) | Represents method SetStyles(TfrxStyles).
SetTerminated(Boolean) | Represents method SetTerminated(Boolean).
SetVersion(String) | Represents method SetVersion(String).
ShowPreparedReport | Displays the report, which was previously built via the "PrepareReport" call.
ShowReport(Boolean) | Starts a report and displays a result in the preview window. If the "ClearLastReport" parameter is equal to "False," then a report will be added to the previously constructed one, otherwise the previously constructed report is cleared (by default).
UpdateGlobalScritVars | Represents method UpdateGlobalScritVars.
WriteDatasets(TWriter) | Represents method WriteDatasets(TWriter).
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.WriteNestedProperties(TfrxXMLItem,TPersistent).)
WriteStyle(TWriter) | Represents method WriteStyle(TWriter).
WriteVariables(TWriter) | Represents method WriteVariables(TWriter).
Top


TfrxReport.AddFunction(String,String,String) Method

Summary

Adds a user function to the list of the functions available in the report. See the FastReport developer's manual about this method.

Namespace: frxClass
Syntax
Delphi
public
 procedure AddFunction(const FuncName: String; const Category: String = '';
 const Description: String = '');

Parameters

FuncName
Type: String

Function name with parameters ('function MyFunc(s: String):String').

Category
Type: String

Function category.

Description
Type: String

Description of function behaviour.

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.AncestorNotFound(TReader,string,TPersistentClass,TComponent) Method

Summary

Represents method AncestorNotFound(TReader,string,TPersistentClass,TComponent).

Namespace: frxClass
Syntax
Delphi
private
 procedure AncestorNotFound(Reader: TReader; const ComponentName: string;
 ComponentClass: TPersistentClass; var Component: TComponent);

Parameters

Reader
Type: TReader

ComponentName
Type: string

ComponentClass
Type: TPersistentClass

Component
Type: TComponent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Calc(String,TfsScript) Method

Summary

Calculates the "Expr" expression and returns the result.

Namespace: frxClass
Syntax
Delphi
public
 function Calc(const Expr: String; AScript: TfsScript = nil): Variant;

Parameters

Expr
Type: String

AScript
Type: TfsScript

Return Value

Type: Variant

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.CallMethod(TObject,TClass,String,Variant) Method

Summary

Represents method CallMethod(TObject,TClass,String,Variant).

Namespace: frxClass
Syntax
Delphi
private
 function CallMethod(Instance: TObject; ClassType: TClass;
 const MethodName: String; var Params: Variant): Variant;

Parameters

Instance
Type: TObject

ClassType
Type: TClass

MethodName
Type: String

Params
Type: Variant

Return Value

Type: Variant

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.CheckDataPage Method

Summary

This method checks for DataPage in current report and if it's not exist, creates one.

Namespace: frxClass
Syntax
Delphi
public
 procedure CheckDataPage;
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Clear Method

Summary

Creates a unique name for an object placed into the report.

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TfrxComponent.Clear
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxClass
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DesignPreviewPage Method

Summary

Calls designer for set report editing (deletes bands, blocks inlay code e.t.c).

Namespace: frxClass
Syntax
Delphi
public
 function DesignPreviewPage: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DesignReport(Boolean,Boolean) Method

Summary

Calls the report designer. The designer component must be included into your project (to perform this, you can either place the "TfrxDesigner" component on the form , or include the "frxDesgn" unit into the "Uses" list). The Modal parameter determines whether the designer should be modal. The MDIChild parameter allows to make a designer window a MDI child window.

Namespace: frxClass
Syntax
Delphi
public
 procedure DesignReport(Modal: Boolean = True; MDIChild: Boolean = False); overload; stdcall;

Parameters

Modal
Type: Boolean

Show as modal form.

MDIChild
Type: Boolean

Shows as MDI child form.

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DesignReport(IUnknown,TObject) Method

Summary

Serves IDE report designer.

Namespace: frxClass
Syntax
Delphi
public
 procedure DesignReport(IDesigner: IUnknown; Editor: TObject); overload;

Parameters

IDesigner
Type: IUnknown

Editor
Type: TObject

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DesignReportInPanel(TWinControl) Method

Summary

Shows designer in specified panel.

Namespace: frxClass
Syntax
Delphi
public
 procedure DesignReportInPanel(Panel: TWinControl);

Parameters

Panel
Type: TWinControl

Parent panel.

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoAfterPrint(TfrxReportComponent) Method

Summary

Serves AfterPrint event.

Namespace: frxClass
Syntax
Delphi
public
 procedure DoAfterPrint(c: TfrxReportComponent);

Parameters

c
Type: TfrxReportComponent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoBeforePrint(TfrxReportComponent) Method

Summary

Serves BeforePrint event.

Namespace: frxClass
Syntax
Delphi
public
 procedure DoBeforePrint(c: TfrxReportComponent);

Parameters

c
Type: TfrxReportComponent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoClear Method

Summary

Represents method DoClear.

Namespace: frxClass
Syntax
Delphi
private
 procedure DoClear;
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoGetAncestor(String,TPersistent) Method

Summary

Represents method DoGetAncestor(String,TPersistent).

Namespace: frxClass
Syntax
Delphi
protected
 procedure DoGetAncestor(const Name: String; var Ancestor: TPersistent);

Parameters

Name
Type: String

Ancestor
Type: TPersistent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoGetValue(String,Variant) Method

Summary

Represents method DoGetValue(String,Variant).

Namespace: frxClass
Syntax
Delphi
private
 function DoGetValue(const Expr: String; var Value: Variant): Boolean;

Parameters

Expr
Type: String

Value
Type: Variant

Return Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoLoadFromStream Method

Summary

Represents method DoLoadFromStream.

Namespace: frxClass
Syntax
Delphi
private
 procedure DoLoadFromStream;
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoMouseEnter(TfrxView,TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Serves MouseEnter script event.

Namespace: frxClass
Syntax
Delphi
public
 procedure DoMouseEnter(Sender: TfrxView; aPreviousObject: TfrxComponent; var EventParams: TfrxInteractiveEventsParams); reintroduce;

Parameters

Sender
Type: TfrxView

aPreviousObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoMouseLeave(TfrxView,Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Serves MouseLeave script event.

Namespace: frxClass
Syntax
Delphi
public
 procedure DoMouseLeave(Sender: TfrxView; X, Y: Integer; aNextObject: TfrxComponent; var EventParams: TfrxInteractiveEventsParams); reintroduce;

Parameters

Sender
Type: TfrxView

X
Type: Integer

Y
Type: Integer

aNextObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoMouseUp(TfrxView,Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Serves MouseUp script event.

Namespace: frxClass
Syntax
Delphi
public
 procedure DoMouseUp(Sender: TfrxView; X, Y: Integer; Button: TMouseButton; Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams); reintroduce;

Parameters

Sender
Type: TfrxView

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoNotifyEvent(TObject,String,Boolean) Method

Summary

Script Notify event handler.

Namespace: frxClass
Syntax
Delphi
public
 procedure DoNotifyEvent(Obj: TObject; const EventName: String;
 RunAlways: Boolean = False);

Parameters

Obj
Type: TObject

EventName
Type: String

RunAlways
Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoParamEvent(String,Variant,Boolean) Method

Summary

Script parameterized event handler.

Namespace: frxClass
Syntax
Delphi
public
 procedure DoParamEvent(const EventName: String; var Params: Variant;
 RunAlways: Boolean = False);

Parameters

EventName
Type: String

Params
Type: Variant

RunAlways
Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoPreviewClick(TfrxView,TMouseButton,TShiftState,Boolean,TfrxInteractiveEventsParams,Boolean) Method

Summary

Serves PreviewClick event.

Namespace: frxClass
Syntax
Delphi
public
 procedure DoPreviewClick(v: TfrxView; Button: TMouseButton;
 Shift: TShiftState; var Modified: Boolean; var EventParams: TfrxInteractiveEventsParams; DblClick: Boolean = False);

Parameters

v
Type: TfrxView

Button
Type: TMouseButton

Shift
Type: TShiftState

Modified
Type: Boolean

EventParams
Type: TfrxInteractiveEventsParams

DblClick
Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.DoUserFunction(TObject,TClass,String,Variant) Method

Summary

Represents method DoUserFunction(TObject,TClass,String,Variant).

Namespace: frxClass
Syntax
Delphi
private
 function DoUserFunction(Instance: TObject; ClassType: TClass;
 const MethodName: String; var Params: Variant): Variant;

Parameters

Instance
Type: TObject

ClassType
Type: TClass

MethodName
Type: String

Params
Type: Variant

Return Value

Type: Variant

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Export(TfrxCustomExportFilter) Method

Summary

Exports a report using the specified export filter.

Namespace: frxClass
Syntax
Delphi
public
 function Export(Filter: TfrxCustomExportFilter): Boolean;

Parameters

Filter
Type: TfrxCustomExportFilter

Export filter instance.

Return Value

Type: Boolean

Remarks

When the report component builds a report and receives another PrepareReport or Export command it puts it in deferred commands list and run a command only after current action is complete. Used in single-threaded application for synchronization with ProcessMessages actions.

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FindObject(String) Method

Summary

Searches for an object by name in the current report template.

Namespace: frxClass
Syntax
Delphi
public
 function FindObject(const AName: String): TfrxComponent; override;

Parameters

AName
Type: String

Object name.

Return Value

Type: TfrxComponent

Overrides

TfrxComponent.FindObject(String)
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FixUpParentReport Method

Summary

Represents method FixUpParentReport.

Namespace: frxClass
Syntax
Delphi
private
 procedure FixUpParentReport;
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetActiveDataSetList(TStrings) Method

Summary

Fill list with active datasets.

Namespace: frxClass
Syntax
Delphi
public
 procedure GetActiveDataSetList(List: TStrings);

Parameters

List
Type: TStrings

Out list.

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetAlias(TfrxDataSet) Method

Summary

Returns an alias for the given data set. Dataset should be included in the TfrxReport.Datasets.

Namespace: frxClass
Syntax
Delphi
public
 function GetAlias(DataSet: TfrxDataSet): String;

Parameters

DataSet
Type: TfrxDataSet

Return Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetApplicationFolder Method

Summary

This function returns path to application executable.

Namespace: frxClass
Syntax
Delphi
public
 function GetApplicationFolder: String;

Return Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetCaseSensitive Method

Summary

Represents method GetCaseSensitive.

Namespace: frxClass
Syntax
Delphi
private
 function GetCaseSensitive: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetDataset(String) Method

Summary

Returns the data set on its alias name. Dataset should be included in the TfrxReport.Datasets.

Namespace: frxClass
Syntax
Delphi
public
 function GetDataset(const Alias: String): TfrxDataset;

Parameters

Alias
Type: String

Return Value

Type: TfrxDataset

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetDatasetAndField(String,TfrxDataSet,String) Method

Summary

Retrieves dataset and field name from an expression like DSName."field name".

Namespace: frxClass
Syntax
Delphi
public
 procedure GetDatasetAndField(const ComplexName: String;
 var Dataset: TfrxDataset; var Field: String);

Parameters

ComplexName
Type: String

Name of dataset and field.

Dataset
Type: TfrxDataset

Our dataset reference.

Field
Type: String

Our field reference.

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetDataSetList(TStrings,Boolean) Method

Summary

Returns the list of the data sets available in the report in the "List" parameter. The second parameter specifies whether it is necessary to return only the data sets, connected with DB data.

Namespace: frxClass
Syntax
Delphi
public
 procedure GetDataSetList(List: TStrings; OnlyDB: Boolean = False);

Parameters

List
Type: TStrings

OnlyDB
Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetDataSetName Method

Summary

Represents method GetDataSetName.

Namespace: frxClass
Syntax
Delphi
private
 function GetDataSetName: String;

Return Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetIniFile Method

Summary

Returns the ini-file instance that stores all the designer settings. It may be either ini-file or registry, depending on IniFile property value.

Namespace: frxClass
Syntax
Delphi
public
 function GetIniFile: TCustomIniFile;

Return Value

Type: TCustomIniFile

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetLocalValue Method

Summary

Represents method GetLocalValue.

Namespace: frxClass
Syntax
Delphi
private
 function GetLocalValue: Variant;

Return Value

Type: Variant

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetMainPreviewPages Method

Summary

Represents method GetMainPreviewPages.

Namespace: frxClass
Syntax
Delphi
private
 function GetMainPreviewPages: TfrxCustomPreviewPages;

Return Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetPages(Integer) Method

Summary

Represents method GetPages(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetPages(Index: Integer): TfrxPage;

Parameters

Index
Type: Integer

Return Value

Type: TfrxPage

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetPagesCount Method

Summary

Represents method GetPagesCount.

Namespace: frxClass
Syntax
Delphi
private
 function GetPagesCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetPreviewPages Method

Summary

Represents method GetPreviewPages.

Namespace: frxClass
Syntax
Delphi
private
 function GetPreviewPages: TfrxCustomPreviewPages;

Return Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetReportDrawText Method

Summary

Returns reference to current DrawText object. For thread safe saferty each report instance has own DrawText instance.

Namespace: frxClass
Syntax
Delphi
public
 function GetReportDrawText: Pointer;

Return Value

Type: Pointer

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetScriptText Method

Summary

Represents method GetScriptText.

Namespace: frxClass
Syntax
Delphi
private
 function GetScriptText: TStrings;

Return Value

Type: TStrings

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetScriptValue(TObject,TClass,String,Variant) Method

Summary

Represents method GetScriptValue(TObject,TClass,String,Variant).

Namespace: frxClass
Syntax
Delphi
private
 function GetScriptValue(Instance: TObject; ClassType: TClass;
 const MethodName: String; var Params: Variant): Variant;

Parameters

Instance
Type: TObject

ClassType
Type: TClass

MethodName
Type: String

Params
Type: Variant

Return Value

Type: Variant

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.GetSelfValue Method

Summary

Represents method GetSelfValue.

Namespace: frxClass
Syntax
Delphi
private
 function GetSelfValue: TfrxView;

Return Value

Type: TfrxView

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.InheritFromTemplate(String,TfrxInheriteMode) Method

Summary

The current loaded template inherits from the specified . The first parameter is the name of the parent template, the second one is an inheritance mode: derive inheritance dialogue, delete duplicates , rename duplicates .

Namespace: frxClass
Syntax
Delphi
public
 function InheritFromTemplate(const templName: String; InheriteMode: TfrxInheriteMode = imDefault): Boolean;

Parameters

templName
Type: String

InheriteMode
Type: TfrxInheriteMode

Return Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.InternalOnProgress(TfrxProgressType,Integer) Method

Summary

The report engine calls it when some work over report is in progress(preparation, print, export).

Namespace: frxClass
Syntax
Delphi
public
 procedure InternalOnProgress(ProgressType: TfrxProgressType; Progress: Integer); virtual;

Parameters

ProgressType
Type: TfrxProgressType

Progress
Type: Integer

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.InternalOnProgressStart(TfrxProgressType) Method

Summary

The report engine calls it when start some work over report(preparation, print, export).

Namespace: frxClass
Syntax
Delphi
public
 procedure InternalOnProgressStart(ProgressType: TfrxProgressType); virtual;

Parameters

ProgressType
Type: TfrxProgressType

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.InternalOnProgressStop(TfrxProgressType) Method

Summary

The report engine calls it when some work over report is in finished(preparation, print, export).

Namespace: frxClass
Syntax
Delphi
public
 procedure InternalOnProgressStop(ProgressType: TfrxProgressType); virtual;

Parameters

ProgressType
Type: TfrxProgressType

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.IsReportActionRunning Method

Summary

Returns True when report is preparing or script routine is executing(interactive event).

Namespace: frxClass
Syntax
Delphi
public
 function IsReportActionRunning: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.LoadFromFile(String,Boolean) Method

Summary

Loads a report from a file with given name. If the second parameter is equal to "True," and the file was not found, an exception will be generated. It returns "True," if the file is loaded successfully.

Namespace: frxClass
Syntax
Delphi
public
 function LoadFromFile(const FileName: String;
 ExceptionIfNotFound: Boolean = False): Boolean;

Parameters

FileName
Type: String

Name of the file.

ExceptionIfNotFound
Type: Boolean

If true, function generates an exception if file does not exist.

Return Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.LoadFromFilter(TfrxCustomIOTransport,String) Method

Summary

Loads a report from using IO transport class to get stream of a report.

Namespace: frxClass
Syntax
Delphi
public
 function LoadFromFilter(Filter: TfrxCustomIOTransport; const FileName: String): Boolean;

Parameters

Filter
Type: TfrxCustomIOTransport

IO filter transport instance used to get a stream data.

FileName
Type: String

Name used if filter doesn't return any name.

Return Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.LoadFromStream(TStream) Method

Summary

Loads a report from the stream.

Namespace: frxClass
Syntax
Delphi
public
 procedure LoadFromStream(Stream: TStream); override;

Parameters

Stream
Type: TStream

Source stream.

Overrides

TfrxComponent.LoadFromStream(TStream)
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: frxClass
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnTimer(TObject) Method

Summary

Represents method OnTimer(TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure OnTimer(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.PreparePage(TfrxPage) Method

Summary

Prepares specified report template page in current report.

Namespace: frxClass
Syntax
Delphi
public
 function PreparePage(APage: TfrxPage): Boolean;

Parameters

APage
Type: TfrxPage

A report template page.

Return Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.PrepareReport(Boolean) Method

Summary

Starts a report without a preview window. The parameter assignment is the same as in the "ShowReport" method. If a report is constructed successfully, this function returns "True."

Namespace: frxClass
Syntax
Delphi
public
 function PrepareReport(ClearLastReport: Boolean = True): Boolean;

Parameters

ClearLastReport
Type: Boolean

If True, clears previous prepared report result.

Return Value

Type: Boolean

Remarks

When the report component builds a report and receives another PrepareReport or Export command it puts it in deferred commands list and run a command only after current action is complete. Used in single-threaded application for synchronization with ProcessMessages actions.

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.PrepareScript(TfrxReport) Method

Summary

Prepares script engine for work. It compiles script code, adds report objects and user functions to script engine.

Namespace: frxClass
Syntax
Delphi
public
 function PrepareScript(ActiveReport: TfrxReport = nil): Boolean;

Parameters

ActiveReport
Type: TfrxReport

Reference to report component(by default nil).

Return Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.PreviewPagesChanged Method

Summary

Represents method PreviewPagesChanged.

Namespace: frxClass
Syntax
Delphi
protected
 procedure PreviewPagesChanged;
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.Print Method

Summary

Prints a report using printer settings from a PrintOptions property.

Namespace: frxClass
Syntax
Delphi
public
 function Print: Boolean; stdcall;

Return Value

Type: Boolean

Remarks

When the report component builds a report and receives another PrepareReport or Export command it puts it in deferred commands list and run a command only after current action is complete. Used in single-threaded application for synchronization with ProcessMessages actions.

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.ProcessIOTransport(TfrxCustomIOTransport,String,TfrxFilterAccess) Method

Summary

Loads or saves report by using IO transport.

Namespace: frxClass
Syntax
Delphi
public
 function ProcessIOTransport(Filter: TfrxCustomIOTransport; const FileName: String; fAccess: TfrxFilterAccess): Boolean;

Parameters

Filter
Type: TfrxCustomIOTransport

IO transport used to get stream for save and load operations.

FileName
Type: String

File name used to identify stream if IO filter doesn't have name.

fAccess
Type: TfrxFilterAccess

Access type of file operation, read or write.

Return Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.ReadDatasets(TReader) Method

Summary

Represents method ReadDatasets(TReader).

Namespace: frxClass
Syntax
Delphi
private
 procedure ReadDatasets(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.ReadNestedProperty(TfrxXMLItem) Method

Summary

The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData).

Namespace: frxClass
Syntax
Delphi
public
 function ReadNestedProperty(Item: TfrxXmlItem): Boolean; override;

Parameters

Item
Type: TfrxXmlItem

Return Value

Type: Boolean

Overrides

TfrxComponent.ReadNestedProperty(TfrxXMLItem)
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.ReadStyle(TReader) Method

Summary

Represents method ReadStyle(TReader).

Namespace: frxClass
Syntax
Delphi
private
 procedure ReadStyle(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.ReadVariables(TReader) Method

Summary

Represents method ReadVariables(TReader).

Namespace: frxClass
Syntax
Delphi
private
 procedure ReadVariables(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.RefreshActivePreviewedReport Method

Summary

This method rebuilds current active preview pages.

Namespace: frxClass
Syntax
Delphi
public
 procedure RefreshActivePreviewedReport;
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.RestoreScriptObjectsRef Method

Summary

Represents method RestoreScriptObjectsRef.

Namespace: frxClass
Syntax
Delphi
private
 procedure RestoreScriptObjectsRef;
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.RunDelayedCommands Method

Summary

Runs all deferred report commands (prepare report, export, print). Used in single thread application. When the report component builds a report and receives another PrepareReport or Export command it puts it in deferred commands list and run a command only after current action is complete.

Namespace: frxClass
Syntax
Delphi
public
 procedure RunDelayedCommands;
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SaveToFile(String) Method

Summary

Saves a report to a file with given name.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveToFile(const FileName: String);

Parameters

FileName
Type: String

Name of a file.

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SaveToFilter(TfrxCustomIOTransport,String) Method

Summary

Saves a report from using IO transport class to get stream of a report.

Namespace: frxClass
Syntax
Delphi
public
 function SaveToFilter(Filter: TfrxCustomIOTransport; const FileName: String): Boolean;

Parameters

Filter
Type: TfrxCustomIOTransport

IO filter transport instance used to get a stream data.

FileName
Type: String

File name used to identify stream if IO filter doesn't have name.

Return Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SaveToStream(TStream,Boolean,Boolean,Boolean) Method

Summary

Saves a report to the stream. SaveChildren, SaveDefaultValues, UseGetAncestor parameters are not used.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveToStream(Stream: TStream; SaveChildren: Boolean = True;
 SaveDefaultValues: Boolean = False; UseGetAncestor: Boolean = False); override;

Parameters

Stream
Type: TStream

Source stream.

SaveChildren
Type: Boolean

Not used.

SaveDefaultValues
Type: Boolean

Not used.

UseGetAncestor
Type: Boolean

Overrides

TfrxComponent.SaveToStream(TStream,Boolean,Boolean,Boolean)
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SelectPrinter Method

Summary

Selects a printer specified in PrintOptions.Printer property.

Namespace: frxClass
Syntax
Delphi
public
 procedure SelectPrinter;
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetCaseSensitive(Boolean) Method

Summary

Represents method SetCaseSensitive(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetCaseSensitive(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetDataSet(TfrxDataSet) Method

Summary

Represents method SetDataSet(TfrxDataSet).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDataSet(const Value: TfrxDataSet);

Parameters

Value
Type: TfrxDataSet

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetDataSetName(String) Method

Summary

Represents method SetDataSetName(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDataSetName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetEngineOptions(TfrxEngineOptions) Method

Summary

Represents method SetEngineOptions(TfrxEngineOptions).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetEngineOptions(const Value: TfrxEngineOptions);

Parameters

Value
Type: TfrxEngineOptions

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetLocalValue(Variant) Method

Summary

Represents method SetLocalValue(Variant).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetLocalValue(const Value: Variant);

Parameters

Value
Type: Variant

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetMainPreviewPages(TfrxCustomPreviewPages) Method

Summary

Represents method SetMainPreviewPages(TfrxCustomPreviewPages).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetMainPreviewPages(const Value: TfrxCustomPreviewPages);

Parameters

Value
Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetParentReport(String) Method

Summary

Represents method SetParentReport(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetParentReport(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetPreview(TfrxCustomPreview) Method

Summary

Represents method SetPreview(TfrxCustomPreview).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetPreview(const Value: TfrxCustomPreview);

Parameters

Value
Type: TfrxCustomPreview

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetPreviewOptions(TfrxPreviewOptions) Method

Summary

Represents method SetPreviewOptions(TfrxPreviewOptions).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetPreviewOptions(const Value: TfrxPreviewOptions);

Parameters

Value
Type: TfrxPreviewOptions

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetPreviewPages(TfrxCustomPreviewPages) Method

Summary

Represents method SetPreviewPages(TfrxCustomPreviewPages).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetPreviewPages(const Value: TfrxCustomPreviewPages);

Parameters

Value
Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetPrintOptions(TfrxPrintOptions) Method

Summary

Represents method SetPrintOptions(TfrxPrintOptions).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetPrintOptions(const Value: TfrxPrintOptions);

Parameters

Value
Type: TfrxPrintOptions

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetProgressMessage(String,Boolean,Boolean) Method

Summary

Sets a message to progress bar window if it's active or for status bar text in the report preview.

Namespace: frxClass
Syntax
Delphi
public
 procedure SetProgressMessage(const Value: String; Ishint: Boolean = False; bHandleMessage: Boolean = True);

Parameters

Value
Type: String

Message text.

Ishint
Type: Boolean

Set as hint.

bHandleMessage
Type: Boolean

Use HandleMessage for main thread GUI synchronization.

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetReportOptions(TfrxReportOptions) Method

Summary

Represents method SetReportOptions(TfrxReportOptions).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetReportOptions(const Value: TfrxReportOptions);

Parameters

Value
Type: TfrxReportOptions

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetScriptText(TStrings) Method

Summary

Represents method SetScriptText(TStrings).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetScriptText(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetScriptValue(TObject,TClass,String,Variant) Method

Summary

Represents method SetScriptValue(TObject,TClass,String,Variant).

Namespace: frxClass
Syntax
Delphi
private
 function SetScriptValue(Instance: TObject; ClassType: TClass;
 const MethodName: String; var Params: Variant): Variant;

Parameters

Instance
Type: TObject

ClassType
Type: TClass

MethodName
Type: String

Params
Type: Variant

Return Value

Type: Variant

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetScriptVar(String,TObject) Method

Summary

Represents method SetScriptVar(String,TObject).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetScriptVar(const vName: String; Obj: TObject);

Parameters

vName
Type: String

Obj
Type: TObject

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetSelfValue(TfrxView) Method

Summary

Represents method SetSelfValue(TfrxView).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetSelfValue(const Value: TfrxView);

Parameters

Value
Type: TfrxView

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetStyles(TfrxStyles) Method

Summary

Represents method SetStyles(TfrxStyles).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetStyles(const Value: TfrxStyles);

Parameters

Value
Type: TfrxStyles

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetTerminated(Boolean) Method

Summary

Represents method SetTerminated(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetTerminated(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.SetVersion(String) Method

Summary

Represents method SetVersion(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetVersion(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.ShowPreparedReport Method

Summary

Displays the report, which was previously built via the "PrepareReport" call.

Namespace: frxClass
Syntax
Delphi
public
 procedure ShowPreparedReport; stdcall;
Remarks

When the report component builds a report and receives another PrepareReport or Export command it puts it in deferred commands list and run a command only after current action is complete. Used in single-threaded application for synchronization with ProcessMessages actions.

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.ShowReport(Boolean) Method

Summary

Starts a report and displays a result in the preview window. If the "ClearLastReport" parameter is equal to "False," then a report will be added to the previously constructed one, otherwise the previously constructed report is cleared (by default).

Namespace: frxClass
Syntax
Delphi
public
 procedure ShowReport(ClearLastReport: Boolean = True); stdcall;

Parameters

ClearLastReport
Type: Boolean

Clear previous result.

Remarks

When the report component builds a report and receives another PrepareReport or Export command it puts it in deferred commands list and run a command only after current action is complete. Used in single-threaded application for synchronization with ProcessMessages actions.

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.UpdateGlobalScritVars Method

Summary

Represents method UpdateGlobalScritVars.

Namespace: frxClass
Syntax
Delphi
private
 procedure UpdateGlobalScritVars;
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.WriteDatasets(TWriter) Method

Summary

Represents method WriteDatasets(TWriter).

Namespace: frxClass
Syntax
Delphi
private
 procedure WriteDatasets(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.WriteNestedProperties(TfrxXMLItem,TPersistent) Method

Summary

The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData).

Namespace: frxClass
Syntax
Delphi
public
 procedure WriteNestedProperties(Item: TfrxXmlItem; aAcenstor: TPersistent = nil); override;

Parameters

Item
Type: TfrxXmlItem

aAcenstor
Type: TPersistent

Overrides

TfrxComponent.WriteNestedProperties(TfrxXMLItem,TPersistent)
See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.WriteStyle(TWriter) Method

Summary

Represents method WriteStyle(TWriter).

Namespace: frxClass
Syntax
Delphi
private
 procedure WriteStyle(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.WriteVariables(TWriter) Method

Summary

Represents method WriteVariables(TWriter).

Namespace: frxClass
Syntax
Delphi
private
 procedure WriteVariables(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport Events

Events
Name | Description
OnAfterDisconnect | Occurs when the report engine close connection to database for internaldatabase components.
OnAfterPrint | When starting a report. It occurs after handling each object.
OnBeforeConnect | Occurs when the report engine establish connection to database forinternal database components.
OnBeforePrint | When starting a report. It occurs before handling each object.
OnClickObject | When previewing a report in the preview window. Occurs when clicking the object.
OnDblClickObject | When previewing a report in the preview window. Occurs when double clicking the object.
OnEditConnection | Occurs when user edit connection in the report wizard.
OnGetCustomData | This event fires when engine loads report XML file and file contains XML item <FrxCustomData>(i.e. store user data inside XML file).All child nodes in this item ignores by serializer. XMLItem contains all the custom user data.
OnGetValue | When starting a report. Occurs when an unknown variable is met. An event handler must return the value of this variable.
OnLoadDetailTemplate | Occurs when a report object loads detail report. The event handler must load the report template (given by TemplateName parameter) into Report object with using parameters of AHyperlink.
OnLoadTemplate | Occurs when a report is an inherited report. The event handler must load the report template (given by TemplateName parameter) into Report object.
OnManualBuild | When starting a report. If the handler of this event is allocated, then the FastReport engine is blocked and you thus would have to construct a report manually.
OnMouseEnter | Occurs when report is previewed in the preview window and mouse pointerenters object rect area.
OnMouseLeave | Occurs when report is previewed in the preview window and mouse pointerleaves object rect area.
OnMouseOverObject | When report is previewed in the preview window. Occurs when mouse cursor passes over the object.
OnNewGetValue | When starting a report. Occurs when an unknown variable is met. An event handler must return the value of this variable.
OnPrintPage | Occurs when printing a report page. The CopyNo parameter determines which copy is printing now (if user choose to print several copies).
OnProgress | This event is fired when performing some continuous operations (print, export, run report). The event handler may display a dialog window with progress bar. Progress parameter is a page number which is currently being processed.
OnProgressStart | This event is fired at start of some continuous operation (print, export, run report). The event handler may display a dialog window with progress bar. Progress parameter is a page number which is currently processed.
OnProgressStop | This event is fired at stop of some continuous operation (print, export, run report). The event handler may display a dialog window with progress bar. Progress parameter is a page number which is currently processed.
OnSaveCustomData | This event fires when serializer saves report template to XML(i.e.store user data inside XML file). If event is set, serializer creates <FrxCustomData> node and pass it as a parameter. Programmer may use this node to create child nodes with custom data.
OnSetConnection | Occurs when user set ConnectionNeme property. Internal use.
OnUserFunction | Occurs when calling a function, added with the help of the "AddFunction" method.
Top


TfrxReport.OnAfterDisconnect Event

Summary

Occurs when the report engine close connection to database for internaldatabase components.

Namespace: frxClass
Syntax
Delphi
published
 property OnAfterDisconnect: TfrxAfterDisconnectEvent read FOnAfterDisconnect write FOnAfterDisconnect;

Value

Type: TfrxAfterDisconnectEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnAfterPrint Event

Summary

When starting a report. It occurs after handling each object.

Namespace: frxClass
Syntax
Delphi
published
 property OnAfterPrint: TfrxBeforePrintEvent read FOnAfterPrint write FOnAfterPrint;

Value

Type: TfrxBeforePrintEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnBeforeConnect Event

Summary

Occurs when the report engine establish connection to database forinternal database components.

Namespace: frxClass
Syntax
Delphi
published
 property OnBeforeConnect: TfrxBeforeConnectEvent read FOnBeforeConnect write FOnBeforeConnect;

Value

Type: TfrxBeforeConnectEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnBeforePrint Event

Summary

When starting a report. It occurs before handling each object.

Namespace: frxClass
Syntax
Delphi
published
 property OnBeforePrint: TfrxBeforePrintEvent read FOnBeforePrint write FOnBeforePrint;

Value

Type: TfrxBeforePrintEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnClickObject Event

Summary

When previewing a report in the preview window. Occurs when clicking the object.

Namespace: frxClass
Syntax
Delphi
published
 property OnClickObject: TfrxClickObjectEvent read FOnClickObject write FOnClickObject;

Value

Type: TfrxClickObjectEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnDblClickObject Event

Summary

When previewing a report in the preview window. Occurs when double clicking the object.

Namespace: frxClass
Syntax
Delphi
published
 property OnDblClickObject: TfrxClickObjectEvent read FOnDblClickObject write FOnDblClickObject;

Value

Type: TfrxClickObjectEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnEditConnection Event

Summary

Occurs when user edit connection in the report wizard.

Namespace: frxClass
Syntax
Delphi
public
 property OnEditConnection: TfrxEditConnectionEvent read FOnEditConnection write FOnEditConnection;

Value

Type: TfrxEditConnectionEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnGetCustomData Event

Summary

This event fires when engine loads report XML file and file contains XML item <FrxCustomData>(i.e. store user data inside XML file).All child nodes in this item ignores by
serializer. XMLItem contains all the custom user data.

Namespace: frxClass
Syntax
Delphi
published
 property OnGetCustomData: TfrxGetCustomDataEvent read FOnGetCustomDataEvent write FOnGetCustomDataEvent;

Value

Type: TfrxGetCustomDataEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnGetValue Event

Summary

When starting a report. Occurs when an unknown variable is met. An event handler must return the value of this variable.

Namespace: frxClass
Syntax
Delphi
published
 property OnGetValue: TfrxGetValueEvent read FOnGetValue write FOnGetValue;

Value

Type: TfrxGetValueEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnLoadDetailTemplate Event

Summary

Occurs when a report object loads detail report. The event handler must load the report template (given by TemplateName parameter) into Report object with using parameters of AHyperlink.

Namespace: frxClass
Syntax
Delphi
published
 property OnLoadDetailTemplate: TfrxLoadDetailTemplateEvent read FOnLoadDetailTemplate write FOnLoadDetailTemplate;

Value

Type: TfrxLoadDetailTemplateEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnLoadTemplate Event

Summary

Occurs when a report is an inherited report. The event handler must load the report template (given by TemplateName parameter) into Report object.

Namespace: frxClass
Syntax
Delphi
published
 property OnLoadTemplate: TfrxLoadTemplateEvent read FOnLoadTemplate write FOnLoadTemplate;

Value

Type: TfrxLoadTemplateEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnManualBuild Event

Summary

When starting a report. If the handler of this event is allocated, then the FastReport engine is blocked and you thus would have to construct a report manually.

Namespace: frxClass
Syntax
Delphi
published
 property OnManualBuild: TfrxManualBuildEvent read FOnManualBuild write FOnManualBuild;

Value

Type: TfrxManualBuildEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnMouseEnter Event

Summary

Occurs when report is previewed in the preview window and mouse pointerenters object rect area.

Namespace: frxClass
Syntax
Delphi
published
 property OnMouseEnter: TfrxMouseEnterEvent read FOnMouseEnter write FOnMouseEnter;

Value

Type: TfrxMouseEnterEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnMouseLeave Event

Summary

Occurs when report is previewed in the preview window and mouse pointerleaves object rect area.

Namespace: frxClass
Syntax
Delphi
published
 property OnMouseLeave: TfrxMouseLeaveEvent read FOnMouseLeave write FOnMouseLeave;

Value

Type: TfrxMouseLeaveEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnMouseOverObject Event

Summary

When report is previewed in the preview window. Occurs when mouse cursor passes over the object.

Namespace: frxClass
Syntax
Delphi
published
 property OnMouseOverObject: TfrxMouseOverObjectEvent read FOnMouseOverObject
 write FOnMouseOverObject;

Value

Type: TfrxMouseOverObjectEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnNewGetValue Event

Summary

When starting a report. Occurs when an unknown variable is met. An event handler must return the value of this variable.

Namespace: frxClass
Syntax
Delphi
published
 property OnNewGetValue: TfrxNewGetValueEvent read FOnNewGetValue write FOnNewGetValue;

Value

Type: TfrxNewGetValueEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnPrintPage Event

Summary

Occurs when printing a report page. The CopyNo parameter determines which copy is printing now (if user choose to print several copies).

Namespace: frxClass
Syntax
Delphi
published
 property OnPrintPage: TfrxPrintPageEvent read FOnPrintPage write FOnPrintPage;

Value

Type: TfrxPrintPageEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnProgress Event

Summary

This event is fired when performing some continuous operations (print, export, run report). The event handler may display a dialog window with progress bar. Progress parameter is a page number which is currently being processed.

Namespace: frxClass
Syntax
Delphi
published
 property OnProgress: TfrxProgressEvent read FOnProgress write FOnProgress;

Value

Type: TfrxProgressEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnProgressStart Event

Summary

This event is fired at start of some continuous operation (print, export, run report). The event handler may display a dialog window with progress bar. Progress parameter is a page number which is currently processed.

Namespace: frxClass
Syntax
Delphi
published
 property OnProgressStart: TfrxProgressEvent read FOnProgressStart write FOnProgressStart;

Value

Type: TfrxProgressEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnProgressStop Event

Summary

This event is fired at stop of some continuous operation (print, export, run report). The event handler may display a dialog window with progress bar. Progress parameter is a page number which is currently processed.

Namespace: frxClass
Syntax
Delphi
published
 property OnProgressStop: TfrxProgressEvent read FOnProgressStop write FOnProgressStop;

Value

Type: TfrxProgressEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnSaveCustomData Event

Summary

This event fires when serializer saves report template to XML(i.e.store user data inside XML file). If event is set, serializer creates <FrxCustomData> node and pass it as a parameter. Programmer may use this node to create child nodes with custom data.

Namespace: frxClass
Syntax
Delphi
published
 property OnSaveCustomData: TfrxSaveCustomDataEvent read FOnSaveCustomDataEvent write FOnSaveCustomDataEvent;

Value

Type: TfrxSaveCustomDataEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnSetConnection Event

Summary

Occurs when user set ConnectionNeme property. Internal use.

Namespace: frxClass
Syntax
Delphi
public
 property OnSetConnection: TfrxSetConnectionEvent read FOnSetConnection write FOnSetConnection;

Value

Type: TfrxSetConnectionEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.OnUserFunction Event

Summary

Occurs when calling a function, added with the help of the "AddFunction" method.

Namespace: frxClass
Syntax
Delphi
published
 property OnUserFunction: TfrxUserFunctionEvent read FOnUserFunction write FOnUserFunction;

Value

Type: TfrxUserFunctionEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport Fields

Fields
Name | Description
FCommandManager | Represents field FCommandManager.
FCurObject | Represents field FCurObject.
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
FDataSets | Represents field FDataSets.
FDesigner | Represents field FDesigner.
FDotMatrixReport | Represents field FDotMatrixReport.
FDrawText | Represents field FDrawText.
FDrillState | Represents field FDrillState.
FEnabledDataSets | Represents field FEnabledDataSets.
FEngine | Represents field FEngine.
FEngineOptions | Represents field FEngineOptions.
FErrors | Represents field FErrors.
FExpressionCache | Represents field FExpressionCache.
FFakeScriptText | Represents field FFakeScriptText.
FFileName | Represents field FFileName.
FIniFile | Represents field FIniFile.
FIsScriptObjectsAdded | Represents field FIsScriptObjectsAdded.
FLoadStream | Represents field FLoadStream.
FLocalValue | Represents field FLocalValue.
FModified | Represents field FModified.
FOldStyleProgress | Represents field FOldStyleProgress.
FOnAfterDisconnect | Represents field FOnAfterDisconnect.
FOnAfterPrint | Represents field FOnAfterPrint.
FOnAfterPrintReport | Represents field FOnAfterPrintReport.
FOnAfterScriptCompile | Represents field FOnAfterScriptCompile.
FOnBeforeConnect | Represents field FOnBeforeConnect.
FOnBeforePrint | Represents field FOnBeforePrint.
FOnBeginDoc | Represents field FOnBeginDoc.
FOnClickObject | Represents field FOnClickObject.
FOnClosePreview | Represents field FOnClosePreview.
FOnDblClickObject | Represents field FOnDblClickObject.
FOnEditConnection | Represents field FOnEditConnection.
FOnEndDoc | Represents field FOnEndDoc.
FOnGetCustomDataEvent | Represents field FOnGetCustomDataEvent.
FOnGetValue | Represents field FOnGetValue.
FOnLoadDetailTemplate | Represents field FOnLoadDetailTemplate.
FOnLoadTemplate | Represents field FOnLoadTemplate.
FOnManualBuild | Represents field FOnManualBuild.
FOnMouseEnter | Represents field FOnMouseEnter.
FOnMouseLeave | Represents field FOnMouseLeave.
FOnMouseOverObject | Represents field FOnMouseOverObject.
FOnNewGetValue | Represents field FOnNewGetValue.
FOnPreview | Represents field FOnPreview.
FOnPrintPage | Represents field FOnPrintPage.
FOnPrintReport | Represents field FOnPrintReport.
FOnProgress | Represents field FOnProgress.
FOnProgressStart | Represents field FOnProgressStart.
FOnProgressStop | Represents field FOnProgressStop.
FOnReportPrint | Represents field FOnReportPrint.
FOnRunDialogs | Represents field FOnRunDialogs.
FOnSaveCustomDataEvent | Represents field FOnSaveCustomDataEvent.
FOnSetConnection | Represents field FOnSetConnection.
FOnStartReport | Represents field FOnStartReport.
FOnStopReport | Represents field FOnStopReport.
FOnUserFunction | Represents field FOnUserFunction.
FParentForm | Represents field FParentForm.
FParentReport | Represents field FParentReport.
FParentReportObject | Represents field FParentReportObject.
FPreparing | Represents field FPreparing.
FPreview | Represents field FPreview.
FPreviewForm | Represents field FPreviewForm.
FPreviewOptions | Represents field FPreviewOptions.
FPreviewPagesList | Represents field FPreviewPagesList.
FPrintOptions | Represents field FPrintOptions.
FProgress | Represents field FProgress.
FReloading | Represents field FReloading.
FReportOptions | Represents field FReportOptions.
FSaveParentScript | Represents field FSaveParentScript.
FScript | Represents field FScript.
FScriptLanguage | Represents field FScriptLanguage.
FScriptText | Represents field FScriptText.
FSelfValue | Represents field FSelfValue.
FShowProgress | Represents field FShowProgress.
FStoreInDFM | Represents field FStoreInDFM.
FStreamLoaded | Represents field FStreamLoaded.
FStyles | Represents field FStyles.
FSysVariables | Represents field FSysVariables.
FTerminated | Represents field FTerminated.
FTimer | Represents field FTimer.
FVariables | Represents field FVariables.
FVersion | Represents field FVersion.
FXMLSerializer | Represents field FXMLSerializer.
Top


TfrxReport.FCommandManager Field

Summary

Represents field FCommandManager.

Namespace: frxClass
Syntax
Delphi
private
 FCommandManager: TfrxDelayedCommandManager;

Field Value

Type: TfrxDelayedCommandManager

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FCurObject Field

Summary

Represents field FCurObject.

Namespace: frxClass
Syntax
Delphi
private
 FCurObject: String;

Field Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FDataSet Field

Summary

Represents field FDataSet.

Namespace: frxClass
Syntax
Delphi
private
 FDataSet: TfrxDataSet;

Field Value

Type: TfrxDataSet

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FDataSetName Field

Summary

Represents field FDataSetName.

Namespace: frxClass
Syntax
Delphi
private
 FDataSetName: String;

Field Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FDataSets Field

Summary

Represents field FDataSets.

Namespace: frxClass
Syntax
Delphi
private
 FDataSets: TfrxReportDatasets;

Field Value

Type: TfrxReportDatasets

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FDesigner Field

Summary

Represents field FDesigner.

Namespace: frxClass
Syntax
Delphi
private
 FDesigner: TfrxCustomDesigner;

Field Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FDotMatrixReport Field

Summary

Represents field FDotMatrixReport.

Namespace: frxClass
Syntax
Delphi
private
 FDotMatrixReport: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FDrawText Field

Summary

Represents field FDrawText.

Namespace: frxClass
Syntax
Delphi
private
 FDrawText: Pointer;

Field Value

Type: Pointer

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FDrillState Field

Summary

Represents field FDrillState.

Namespace: frxClass
Syntax
Delphi
private
 FDrillState: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FEnabledDataSets Field

Summary

Represents field FEnabledDataSets.

Namespace: frxClass
Syntax
Delphi
private
 FEnabledDataSets: TfrxReportDataSets;

Field Value

Type: TfrxReportDataSets

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FEngine Field

Summary

Represents field FEngine.

Namespace: frxClass
Syntax
Delphi
private
 FEngine: TfrxCustomEngine;

Field Value

Type: TfrxCustomEngine

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FEngineOptions Field

Summary

Represents field FEngineOptions.

Namespace: frxClass
Syntax
Delphi
private
 FEngineOptions: TfrxEngineOptions;

Field Value

Type: TfrxEngineOptions

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FErrors Field

Summary

Represents field FErrors.

Namespace: frxClass
Syntax
Delphi
private
 FErrors: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FExpressionCache Field

Summary

Represents field FExpressionCache.

Namespace: frxClass
Syntax
Delphi
private
 FExpressionCache: TfrxExpressionCache;

Field Value

Type: TfrxExpressionCache

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FFakeScriptText Field

Summary

Represents field FFakeScriptText.

Namespace: frxClass
Syntax
Delphi
private
 FFakeScriptText: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FFileName Field

Summary

Represents field FFileName.

Namespace: frxClass
Syntax
Delphi
private
 FFileName: String;

Field Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FIniFile Field

Summary

Represents field FIniFile.

Namespace: frxClass
Syntax
Delphi
private
 FIniFile: String;

Field Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FIsScriptObjectsAdded Field

Summary

Represents field FIsScriptObjectsAdded.

Namespace: frxClass
Syntax
Delphi
private
 FIsScriptObjectsAdded: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FLoadStream Field

Summary

Represents field FLoadStream.

Namespace: frxClass
Syntax
Delphi
private
 FLoadStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FLocalValue Field

Summary

Represents field FLocalValue.

Namespace: frxClass
Syntax
Delphi
private
 FLocalValue: TfsCustomVariable;

Field Value

Type: TfsCustomVariable

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FModified Field

Summary

Represents field FModified.

Namespace: frxClass
Syntax
Delphi
private
 FModified: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOldStyleProgress Field

Summary

Represents field FOldStyleProgress.

Namespace: frxClass
Syntax
Delphi
private
 FOldStyleProgress: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnAfterDisconnect Field

Summary

Represents field FOnAfterDisconnect.

Namespace: frxClass
Syntax
Delphi
private
 FOnAfterDisconnect: TfrxAfterDisconnectEvent;

Field Value

Type: TfrxAfterDisconnectEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnAfterPrint Field

Summary

Represents field FOnAfterPrint.

Namespace: frxClass
Syntax
Delphi
private
 FOnAfterPrint: TfrxBeforePrintEvent;

Field Value

Type: TfrxBeforePrintEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnAfterPrintReport Field

Summary

Represents field FOnAfterPrintReport.

Namespace: frxClass
Syntax
Delphi
private
 FOnAfterPrintReport: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnAfterScriptCompile Field

Summary

Represents field FOnAfterScriptCompile.

Namespace: frxClass
Syntax
Delphi
private
 FOnAfterScriptCompile: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnBeforeConnect Field

Summary

Represents field FOnBeforeConnect.

Namespace: frxClass
Syntax
Delphi
private
 FOnBeforeConnect: TfrxBeforeConnectEvent;

Field Value

Type: TfrxBeforeConnectEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnBeforePrint Field

Summary

Represents field FOnBeforePrint.

Namespace: frxClass
Syntax
Delphi
private
 FOnBeforePrint: TfrxBeforePrintEvent;

Field Value

Type: TfrxBeforePrintEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnBeginDoc Field

Summary

Represents field FOnBeginDoc.

Namespace: frxClass
Syntax
Delphi
private
 FOnBeginDoc: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnClickObject Field

Summary

Represents field FOnClickObject.

Namespace: frxClass
Syntax
Delphi
private
 FOnClickObject: TfrxClickObjectEvent;

Field Value

Type: TfrxClickObjectEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnClosePreview Field

Summary

Represents field FOnClosePreview.

Namespace: frxClass
Syntax
Delphi
private
 FOnClosePreview: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnDblClickObject Field

Summary

Represents field FOnDblClickObject.

Namespace: frxClass
Syntax
Delphi
private
 FOnDblClickObject: TfrxClickObjectEvent;

Field Value

Type: TfrxClickObjectEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnEditConnection Field

Summary

Represents field FOnEditConnection.

Namespace: frxClass
Syntax
Delphi
private
 FOnEditConnection: TfrxEditConnectionEvent;

Field Value

Type: TfrxEditConnectionEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnEndDoc Field

Summary

Represents field FOnEndDoc.

Namespace: frxClass
Syntax
Delphi
private
 FOnEndDoc: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnGetCustomDataEvent Field

Summary

Represents field FOnGetCustomDataEvent.

Namespace: frxClass
Syntax
Delphi
private
 FOnGetCustomDataEvent: TfrxGetCustomDataEvent;

Field Value

Type: TfrxGetCustomDataEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnGetValue Field

Summary

Represents field FOnGetValue.

Namespace: frxClass
Syntax
Delphi
private
 FOnGetValue: TfrxGetValueEvent;

Field Value

Type: TfrxGetValueEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnLoadDetailTemplate Field

Summary

Represents field FOnLoadDetailTemplate.

Namespace: frxClass
Syntax
Delphi
private
 FOnLoadDetailTemplate: TfrxLoadDetailTemplateEvent;

Field Value

Type: TfrxLoadDetailTemplateEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnLoadTemplate Field

Summary

Represents field FOnLoadTemplate.

Namespace: frxClass
Syntax
Delphi
private
 FOnLoadTemplate: TfrxLoadTemplateEvent;

Field Value

Type: TfrxLoadTemplateEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnManualBuild Field

Summary

Represents field FOnManualBuild.

Namespace: frxClass
Syntax
Delphi
private
 FOnManualBuild: TfrxManualBuildEvent;

Field Value

Type: TfrxManualBuildEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnMouseEnter Field

Summary

Represents field FOnMouseEnter.

Namespace: frxClass
Syntax
Delphi
private
 FOnMouseEnter: TfrxMouseEnterEvent;

Field Value

Type: TfrxMouseEnterEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnMouseLeave Field

Summary

Represents field FOnMouseLeave.

Namespace: frxClass
Syntax
Delphi
private
 FOnMouseLeave: TfrxMouseLeaveEvent;

Field Value

Type: TfrxMouseLeaveEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnMouseOverObject Field

Summary

Represents field FOnMouseOverObject.

Namespace: frxClass
Syntax
Delphi
private
 FOnMouseOverObject: TfrxMouseOverObjectEvent;

Field Value

Type: TfrxMouseOverObjectEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnNewGetValue Field

Summary

Represents field FOnNewGetValue.

Namespace: frxClass
Syntax
Delphi
private
 FOnNewGetValue: TfrxNewGetValueEvent;

Field Value

Type: TfrxNewGetValueEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnPreview Field

Summary

Represents field FOnPreview.

Namespace: frxClass
Syntax
Delphi
private
 FOnPreview: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnPrintPage Field

Summary

Represents field FOnPrintPage.

Namespace: frxClass
Syntax
Delphi
private
 FOnPrintPage: TfrxPrintPageEvent;

Field Value

Type: TfrxPrintPageEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnPrintReport Field

Summary

Represents field FOnPrintReport.

Namespace: frxClass
Syntax
Delphi
private
 FOnPrintReport: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnProgress Field

Summary

Represents field FOnProgress.

Namespace: frxClass
Syntax
Delphi
private
 FOnProgress: TfrxProgressEvent;

Field Value

Type: TfrxProgressEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnProgressStart Field

Summary

Represents field FOnProgressStart.

Namespace: frxClass
Syntax
Delphi
private
 FOnProgressStart: TfrxProgressEvent;

Field Value

Type: TfrxProgressEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnProgressStop Field

Summary

Represents field FOnProgressStop.

Namespace: frxClass
Syntax
Delphi
private
 FOnProgressStop: TfrxProgressEvent;

Field Value

Type: TfrxProgressEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnReportPrint Field

Summary

Represents field FOnReportPrint.

Namespace: frxClass
Syntax
Delphi
private
 FOnReportPrint: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnRunDialogs Field

Summary

Represents field FOnRunDialogs.

Namespace: frxClass
Syntax
Delphi
private
 FOnRunDialogs: TfrxRunDialogsEvent;

Field Value

Type: TfrxRunDialogsEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnSaveCustomDataEvent Field

Summary

Represents field FOnSaveCustomDataEvent.

Namespace: frxClass
Syntax
Delphi
private
 FOnSaveCustomDataEvent: TfrxSaveCustomDataEvent;

Field Value

Type: TfrxSaveCustomDataEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnSetConnection Field

Summary

Represents field FOnSetConnection.

Namespace: frxClass
Syntax
Delphi
private
 FOnSetConnection: TfrxSetConnectionEvent;

Field Value

Type: TfrxSetConnectionEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnStartReport Field

Summary

Represents field FOnStartReport.

Namespace: frxClass
Syntax
Delphi
private
 FOnStartReport: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnStopReport Field

Summary

Represents field FOnStopReport.

Namespace: frxClass
Syntax
Delphi
private
 FOnStopReport: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FOnUserFunction Field

Summary

Represents field FOnUserFunction.

Namespace: frxClass
Syntax
Delphi
private
 FOnUserFunction: TfrxUserFunctionEvent;

Field Value

Type: TfrxUserFunctionEvent

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FParentForm Field

Summary

Represents field FParentForm.

Namespace: frxClass
Syntax
Delphi
private
 FParentForm: TForm;

Field Value

Type: TForm

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FParentReport Field

Summary

Represents field FParentReport.

Namespace: frxClass
Syntax
Delphi
private
 FParentReport: String;

Field Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FParentReportObject Field

Summary

Represents field FParentReportObject.

Namespace: frxClass
Syntax
Delphi
private
 FParentReportObject: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FPreparing Field

Summary

Represents field FPreparing.

Namespace: frxClass
Syntax
Delphi
private
 FPreparing: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FPreview Field

Summary

Represents field FPreview.

Namespace: frxClass
Syntax
Delphi
private
 FPreview: TfrxCustomPreview;

Field Value

Type: TfrxCustomPreview

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FPreviewForm Field

Summary

Represents field FPreviewForm.

Namespace: frxClass
Syntax
Delphi
private
 FPreviewForm: TForm;

Field Value

Type: TForm

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FPreviewOptions Field

Summary

Represents field FPreviewOptions.

Namespace: frxClass
Syntax
Delphi
private
 FPreviewOptions: TfrxPreviewOptions;

Field Value

Type: TfrxPreviewOptions

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FPreviewPagesList Field

Summary

Represents field FPreviewPagesList.

Namespace: frxClass
Syntax
Delphi
private
 FPreviewPagesList: TfrxPreviewPagesList;

Field Value

Type: TfrxPreviewPagesList

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FPrintOptions Field

Summary

Represents field FPrintOptions.

Namespace: frxClass
Syntax
Delphi
private
 FPrintOptions: TfrxPrintOptions;

Field Value

Type: TfrxPrintOptions

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FProgress Field

Summary

Represents field FProgress.

Namespace: frxClass
Syntax
Delphi
private
 FProgress: TfrxProgress;

Field Value

Type: TfrxProgress

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FReloading Field

Summary

Represents field FReloading.

Namespace: frxClass
Syntax
Delphi
private
 FReloading: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FReportOptions Field

Summary

Represents field FReportOptions.

Namespace: frxClass
Syntax
Delphi
private
 FReportOptions: TfrxReportOptions;

Field Value

Type: TfrxReportOptions

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FSaveParentScript Field

Summary

Represents field FSaveParentScript.

Namespace: frxClass
Syntax
Delphi
private
 FSaveParentScript: TfsScript;

Field Value

Type: TfsScript

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FScript Field

Summary

Represents field FScript.

Namespace: frxClass
Syntax
Delphi
private
 FScript: TfsScript;

Field Value

Type: TfsScript

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FScriptLanguage Field

Summary

Represents field FScriptLanguage.

Namespace: frxClass
Syntax
Delphi
private
 FScriptLanguage: String;

Field Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FScriptText Field

Summary

Represents field FScriptText.

Namespace: frxClass
Syntax
Delphi
private
 FScriptText: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FSelfValue Field

Summary

Represents field FSelfValue.

Namespace: frxClass
Syntax
Delphi
private
 FSelfValue: TfsCustomVariable;

Field Value

Type: TfsCustomVariable

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FShowProgress Field

Summary

Represents field FShowProgress.

Namespace: frxClass
Syntax
Delphi
private
 FShowProgress: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FStoreInDFM Field

Summary

Represents field FStoreInDFM.

Namespace: frxClass
Syntax
Delphi
private
 FStoreInDFM: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FStreamLoaded Field

Summary

Represents field FStreamLoaded.

Namespace: frxClass
Syntax
Delphi
private
 FStreamLoaded: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FStyles Field

Summary

Represents field FStyles.

Namespace: frxClass
Syntax
Delphi
private
 FStyles: TfrxStyles;

Field Value

Type: TfrxStyles

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FSysVariables Field

Summary

Represents field FSysVariables.

Namespace: frxClass
Syntax
Delphi
private
 FSysVariables: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FTerminated Field

Summary

Represents field FTerminated.

Namespace: frxClass
Syntax
Delphi
private
 FTerminated: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FTimer Field

Summary

Represents field FTimer.

Namespace: frxClass
Syntax
Delphi
private
 FTimer: TTimer;

Field Value

Type: TTimer

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FVariables Field

Summary

Represents field FVariables.

Namespace: frxClass
Syntax
Delphi
private
 FVariables: TfrxVariables;

Field Value

Type: TfrxVariables

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FVersion Field

Summary

Represents field FVersion.

Namespace: frxClass
Syntax
Delphi
private
 FVersion: String;

Field Value

Type: String

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReport.FXMLSerializer Field

Summary

Represents field FXMLSerializer.

Namespace: frxClass
Syntax
Delphi
private
 FXMLSerializer: TObject;

Field Value

Type: TObject

See Also

Reference

  • TfrxReport
  • frxClass


TfrxReportComponent Class

Summary

Objects of this type can be placed into a report. The class contains the "Draw" method for object's painting, as well as "BeforePrint/GetData/AfterPrint" methods, which are called as soon as a report runs.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxDialogComponent
frxClass.TfrxDialogControl
frxClass.TfrxView
Syntax
Delphi
type
 TfrxReportComponent = class(TfrxComponent)
 end;

The TfrxReportComponent type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxReportComponent class. (Overrides TfrxComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxReportComponent class. (Overrides TfrxComponent.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description.
Font | Object's font. (Inherited from TfrxComponent.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
IndexTag | Represents property IndexTag.
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | The name of the script routine that will be called after the object gets data.
OnAfterPrint | The name of the script routine that will be called after the object is handled.
OnBeforePrint | The name of the script routine that will be called before the object is handled.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object).
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window.
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window.
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PrintOn | Reserved for future use.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Global visibility of the object in the result report. (Inherited from TfrxComponent.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages.
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages.
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object.
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented.
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight.
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer.
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented.
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters.
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions.
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object.
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight.
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child.
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOnAfterData | Represents field FOnAfterData.
FOnAfterPrint | Represents field FOnAfterPrint.
FOnBeforePrint | Represents field FOnBeforePrint.
FOnContentChanged | Represents field FOnContentChanged.
FOnPreviewClick | Represents field FOnPreviewClick.
FOnPreviewDblClick | Represents field FOnPreviewDblClick.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only.
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintOn | Represents field FPrintOn.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only.
Top
See Also

Reference

  • frxClass


TfrxReportComponent Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxReportComponent class. (Overrides TfrxComponent.Create(TComponent).)
Destroy | Represents the destructor of the TfrxReportComponent class. (Overrides TfrxComponent.Destroy.)
Top


TfrxReportComponent.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxReportComponent class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxComponent.Create(TComponent)
See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.Destroy Destructor

Summary

Represents the destructor of the TfrxReportComponent class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxComponent.Destroy
See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent Properties

Properties
Name | Description
Description | Represents property Description.
IndexTag | Represents property IndexTag.
OnAfterData | The name of the script routine that will be called after the object gets data.
OnAfterPrint | The name of the script routine that will be called after the object is handled.
OnBeforePrint | The name of the script routine that will be called before the object is handled.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object).
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window.
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window.
PrintOn | Reserved for future use.
Top


TfrxReportComponent.Description Property

Summary

Represents property Description.

Namespace: frxClass
Syntax
Delphi
published
 property Description;

Property Value

Type: Void

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.IndexTag Property

Summary

Represents property IndexTag.

Namespace: frxClass
Syntax
Delphi
published
 property IndexTag;

Property Value

Type: Void

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.OnAfterData Property

Summary

The name of the script routine that will be called after the object gets data.

Namespace: frxClass
Syntax
Delphi
public
 property OnAfterData: TfrxNotifyEvent read FOnAfterData write FOnAfterData;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.OnAfterPrint Property

Summary

The name of the script routine that will be called after the object is handled.

Namespace: frxClass
Syntax
Delphi
public
 property OnAfterPrint: TfrxNotifyEvent read FOnAfterPrint write FOnAfterPrint;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.OnBeforePrint Property

Summary

The name of the script routine that will be called before the object is handled.

Namespace: frxClass
Syntax
Delphi
public
 property OnBeforePrint: TfrxNotifyEvent read FOnBeforePrint write FOnBeforePrint;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.OnContentChanged Property

Summary

The name of the script routine that will be called if content of object was changes(for example text in "Text" object).

Namespace: frxClass
Syntax
Delphi
public
 property OnContentChanged: TfrxContentChangedEvent read FOnContentChanged write FOnContentChanged;

Property Value

Type: TfrxContentChangedEvent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.OnPreviewClick Property

Summary

The name of the script routine that will be called if user clicks on the object in the preview window.

Namespace: frxClass
Syntax
Delphi
public
 property OnPreviewClick: TfrxPreviewClickEvent read FOnPreviewClick write FOnPreviewClick;

Property Value

Type: TfrxPreviewClickEvent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.OnPreviewDblClick Property

Summary

The name of the script routine that will be called if user double clicks on the object in the preview window.

Namespace: frxClass
Syntax
Delphi
public
 property OnPreviewDblClick: TfrxPreviewClickEvent read FOnPreviewDblClick write FOnPreviewDblClick;

Property Value

Type: TfrxPreviewClickEvent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.PrintOn Property

Summary

Reserved for future use.

Namespace: frxClass
Syntax
Delphi
public
 property PrintOn: TfrxPrintOnTypes read FPrintOn write FPrintOn;

Property Value

Type: TfrxPrintOnTypes

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent Methods

Methods
Name | Description
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages.
BeforePrint | The report engine calls this method before prepare object and place it to preview pages.
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object.
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented.
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight.
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer.
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented.
GetComponentText | Returns text of the report object. Used in export filters.
GetData | The report engine calls this method to get Data inside object or calculate expressions.
GetRealBounds | Deprecated. Returns real size of object.
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages.
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight.
IsOwnerDraw | Returns True when parent container should draw child.
Top


TfrxReportComponent.AfterPrint Method

Summary

The report engine calls this method after object was prepared and placed to preview pages.

Namespace: frxClass
Syntax
Delphi
public
 procedure AfterPrint; virtual;
See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.BeforePrint Method

Summary

The report engine calls this method before prepare object and place it to preview pages.

Namespace: frxClass
Syntax
Delphi
public
 procedure BeforePrint; virtual;
See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended);
 virtual; abstract;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) Method

Summary

Reserved. Not implemented.

Namespace: frxClass
Syntax
Delphi
public
 procedure DrawChilds(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended; Highlighted: Boolean; IsDesigning: Boolean);
 virtual;

Parameters

Canvas
Type: TCanvas

ScaleX
Type: Extended

ScaleY
Type: Extended

OffsetX
Type: Extended

OffsetY
Type: Extended

Highlighted
Type: Boolean

IsDesigning
Type: Boolean

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) Method

Summary

Draws selection highlight.

Namespace: frxClass
Syntax
Delphi
public
 procedure DrawHighlight(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended; hlColor: TColor = clNone); virtual;

Parameters

Canvas
Type: TCanvas

Canvas to draw.

ScaleX
Type: Extended

X scale factor.

ScaleY
Type: Extended

Y scale factor.

OffsetX
Type: Extended

X offset.

OffsetY
Type: Extended

X offset.

hlColor
Type: TColor

Highlight color.

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.DrawSizeBox(TCanvas,Extended,Boolean) Method

Summary

Draws size boxes around report objects in the report designer.

Namespace: frxClass
Syntax
Delphi
protected
 procedure DrawSizeBox(aCanvas: TCanvas; aScale: Extended; bForceDraw: Boolean = False); virtual;

Parameters

aCanvas
Type: TCanvas

aScale
Type: Extended

bForceDraw
Type: Boolean

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) Method

Summary

Reserved. Not implemented.

Namespace: frxClass
Syntax
Delphi
public
 procedure DrawWithChilds(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended; Highlighted: Boolean; IsDesigning: Boolean);

Parameters

Canvas
Type: TCanvas

ScaleX
Type: Extended

ScaleY
Type: Extended

OffsetX
Type: Extended

OffsetY
Type: Extended

Highlighted
Type: Boolean

IsDesigning
Type: Boolean

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.GetComponentText Method

Summary

Returns text of the report object. Used in export filters.

Namespace: frxClass
Syntax
Delphi
public
 function GetComponentText: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxClass
Syntax
Delphi
public
 procedure GetData; virtual;
See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.GetRealBounds Method

Summary

Deprecated. Returns real size of object.

Namespace: frxClass
Syntax
Delphi
public
 function GetRealBounds: TfrxRect; virtual;

Return Value

Type: TfrxRect

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.GetSaveToComponent Method

Summary

Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages.

Namespace: frxClass
Syntax
Delphi
public
 function GetSaveToComponent: TfrxReportComponent; virtual;

Return Value

Type: TfrxReportComponent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) Method

Summary

Used from the report designer and preview calls Draw/DrawHighlight.

Namespace: frxClass
Syntax
Delphi
public
 procedure InteractiveDraw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended; Highlighted: Boolean = False; hlColor: TColor = clNone);

Parameters

Canvas
Type: TCanvas

Canvas to draw object.

ScaleX
Type: Extended

X Scale factor.

ScaleY
Type: Extended

Y Scale factor.

OffsetX
Type: Extended

X Offset.

OffsetY
Type: Extended

Y Offset.

Highlighted
Type: Boolean

Force DrawHighlight call.

hlColor
Type: TColor

Highlight color.

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.IsOwnerDraw Method

Summary

Returns True when parent container should draw child.

Namespace: frxClass
Syntax
Delphi
public
 function IsOwnerDraw: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent Fields

Fields
Name | Description
FOnAfterData | Represents field FOnAfterData.
FOnAfterPrint | Represents field FOnAfterPrint.
FOnBeforePrint | Represents field FOnBeforePrint.
FOnContentChanged | Represents field FOnContentChanged.
FOnPreviewClick | Represents field FOnPreviewClick.
FOnPreviewDblClick | Represents field FOnPreviewDblClick.
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only.
FPrintOn | Represents field FPrintOn.
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only.
Top


TfrxReportComponent.FOnAfterData Field

Summary

Represents field FOnAfterData.

Namespace: frxClass
Syntax
Delphi
private
 FOnAfterData: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.FOnAfterPrint Field

Summary

Represents field FOnAfterPrint.

Namespace: frxClass
Syntax
Delphi
private
 FOnAfterPrint: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.FOnBeforePrint Field

Summary

Represents field FOnBeforePrint.

Namespace: frxClass
Syntax
Delphi
private
 FOnBeforePrint: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.FOnContentChanged Field

Summary

Represents field FOnContentChanged.

Namespace: frxClass
Syntax
Delphi
private
 FOnContentChanged: TfrxContentChangedEvent;

Field Value

Type: TfrxContentChangedEvent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.FOnPreviewClick Field

Summary

Represents field FOnPreviewClick.

Namespace: frxClass
Syntax
Delphi
private
 FOnPreviewClick: TfrxPreviewClickEvent;

Field Value

Type: TfrxPreviewClickEvent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.FOnPreviewDblClick Field

Summary

Represents field FOnPreviewDblClick.

Namespace: frxClass
Syntax
Delphi
private
 FOnPreviewDblClick: TfrxPreviewClickEvent;

Field Value

Type: TfrxPreviewClickEvent

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.FOriginalObjectsCount Field

Summary

Used for TfrxSubReport.PrintOnParent. Internal use only.

Namespace: frxClass
Syntax
Delphi
public
 FOriginalObjectsCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.FPrintOn Field

Summary

Represents field FPrintOn.

Namespace: frxClass
Syntax
Delphi
private
 FPrintOn: TfrxPrintOnTypes;

Field Value

Type: TfrxPrintOnTypes

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportComponent.FShiftObject Field

Summary

Used in new shift mechanism, stores shift tree or list. Internal use only.

Namespace: frxClass
Syntax
Delphi
public
 FShiftObject: TObject;

Field Value

Type: TObject

See Also

Reference

  • TfrxReportComponent
  • frxClass


TfrxReportDataSets Class

Summary

The TfrxReportDataSets class represents the report dataset's list. Instance of this class is stored in the TfrxReport.Datasets property.

Namespace: frxClass
Inheritance Hierarchy
TCollection
frxClass.TfrxReportDataSets
Syntax
Delphi
type
 TfrxReportDataSets = class(TCollection)
 end;

The TfrxReportDataSets type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport) | Creates the class instance. Do not use this method directly, because instance of this class is stored in the TfrxReport.Datasets property.
Top
Properties
Show:
Name | Description
Items[Integer] | List of elements.
Top
Methods
Show:
Name | Description
Add(TfrxDataSet) | Adds an element to the list.
Delete(String) | Overloaded. Delete an element in the list.
Finalize | Finalize all datasets in the list.
Find(String) | Overloaded. Finds an element in the list.
Find(TfrxDataSet) | Overloaded. Finds an element in the list.
GetItem(Integer) | Represents method GetItem(Integer).
Initialize | Initializes dataset list.
Top
Fields
Show:
Name | Description
FReport | Represents field FReport.
Top
See Also

Reference

  • frxClass


TfrxReportDataSets Constructors

Constructors
Name | Description
Create(TfrxReport) | Creates the class instance. Do not use this method directly, because instance of this class is stored in the TfrxReport.Datasets property.
Top


TfrxReportDataSets.Create(TfrxReport) Constructor

Summary

Creates the class instance. Do not use this method directly, because instance of this class is stored in the TfrxReport.Datasets property.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AReport: TfrxReport);

Parameters

AReport
Type: TfrxReport

See Also

Reference

  • TfrxReportDataSets
  • frxClass


TfrxReportDataSets Properties

Properties
Name | Description
Items[Integer] | List of elements.
Top


TfrxReportDataSets.Items[Integer] Property

Summary

List of elements.

Namespace: frxClass
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxDataSetItem read GetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxDataSetItem

See Also

Reference

  • TfrxReportDataSets
  • frxClass


TfrxReportDataSets Methods

Methods
Name | Description
Add(TfrxDataSet) | Adds an element to the list.
Delete(String) | Overloaded. Delete an element in the list.
Finalize | Finalize all datasets in the list.
Find(String) | Overloaded. Finds an element in the list.
Find(TfrxDataSet) | Overloaded. Finds an element in the list.
GetItem(Integer) | Represents method GetItem(Integer).
Initialize | Initializes dataset list.
Top


TfrxReportDataSets.Add(TfrxDataSet) Method

Summary

Adds an element to the list.

Namespace: frxClass
Syntax
Delphi
public
 procedure Add(ds: TfrxDataSet);

Parameters

ds
Type: TfrxDataSet

See Also

Reference

  • TfrxReportDataSets
  • frxClass


TfrxReportDataSets.Delete(String) Method

Summary

Delete an element in the list.

Namespace: frxClass
Syntax
Delphi
public
 procedure Delete(const Name: String); overload;

Parameters

Name
Type: String

See Also

Reference

  • TfrxReportDataSets
  • frxClass


TfrxReportDataSets.Finalize Method

Summary

Finalize all datasets in the list.

Namespace: frxClass
Syntax
Delphi
public
 procedure Finalize;
See Also

Reference

  • TfrxReportDataSets
  • frxClass


TfrxReportDataSets.Find(String) Method

Summary

Finds an element in the list.

Namespace: frxClass
Syntax
Delphi
public
 function Find(const Name: String): TfrxDataSetItem; overload;

Parameters

Name
Type: String

Return Value

Type: TfrxDataSetItem

See Also

Reference

  • TfrxReportDataSets
  • frxClass


TfrxReportDataSets.Find(TfrxDataSet) Method

Summary

Finds an element in the list.

Namespace: frxClass
Syntax
Delphi
public
 function Find(ds: TfrxDataSet): TfrxDataSetItem; overload;

Parameters

ds
Type: TfrxDataSet

Return Value

Type: TfrxDataSetItem

See Also

Reference

  • TfrxReportDataSets
  • frxClass


TfrxReportDataSets.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetItem(Index: Integer): TfrxDataSetItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxDataSetItem

See Also

Reference

  • TfrxReportDataSets
  • frxClass


TfrxReportDataSets.Initialize Method

Summary

Initializes dataset list.

Namespace: frxClass
Syntax
Delphi
public
 procedure Initialize;
See Also

Reference

  • TfrxReportDataSets
  • frxClass


TfrxReportDataSets Fields

Fields
Name | Description
FReport | Represents field FReport.
Top


TfrxReportDataSets.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxReportDataSets
  • frxClass


TfrxReportOptions Class

Summary

The TfrxReportOptions class represents a set of properties relating to the report. Instance of this class is stored in the TfrxReport.ReportOptions.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxReportOptions
Syntax
Delphi
type
 TfrxReportOptions = class(TPersistent)
 end;

The TfrxReportOptions type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxReportOptions class.
Destroy | Represents the destructor of the TfrxReportOptions class.
Top
Properties
Show:
Name | Description
Author | Report author.
Compressed | Determines whether to compress a report file. The gzip compression is used. You must put the TfrxGZipCompressor component onto your form.
ConnectionName | Not used.
CreateDate | Report creation date.
Description | Report description.
HiddenPassword | Allows to set password which will be used for report in LoadFrom method without showing dialog to user.
Info | Represents property Info.
InitString | Dot-matrix printer init string. Used only in dot-matrix reports.
LastChange | The date the report was last modified.
Name | Report name.
Password | Report password. If this property is not blank, a password is required when opening a report.
Picture | Report picture.
PrevPassword | Stores previous used password.
VersionBuild | Properties, which detect the number of a version.
VersionMajor | Properties, which detect the number of a version.
VersionMinor | Properties, which detect the number of a version.
VersionRelease | Properties, which detect the number of a version.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Copies the contents from another object.
CheckPassword | If HiddenPassword is not set, shows password dialog and check password inputted by user. Otherwise uses HiddenPassword as a user defined password.
Clear | Clears all properties and fills them by default values.
SetConnectionName(String) | Represents method SetConnectionName(String).
SetDescription(TStrings) | Represents method SetDescription(TStrings).
SetPicture(TPicture) | Represents method SetPicture(TPicture).
Top
Fields
Show:
Name | Description
FAuthor | Represents field FAuthor.
FCompressed | Represents field FCompressed.
FConnectionName | Represents field FConnectionName.
FCreateDate | Represents field FCreateDate.
FDescription | Represents field FDescription.
FHiddenPassword | Represents field FHiddenPassword.
FInfo | Represents field FInfo.
FInitString | Represents field FInitString.
FLastChange | Represents field FLastChange.
FName | Represents field FName.
FPassword | Represents field FPassword.
FPicture | Represents field FPicture.
FPrevPassword | Represents field FPrevPassword.
FReport | Represents field FReport.
FVersionBuild | Represents field FVersionBuild.
FVersionMajor | Represents field FVersionMajor.
FVersionMinor | Represents field FVersionMinor.
FVersionRelease | Represents field FVersionRelease.
Top
See Also

Reference

  • frxClass


TfrxReportOptions Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxReportOptions class.
Destroy | Represents the destructor of the TfrxReportOptions class.
Top


TfrxReportOptions.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxReportOptions class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent);

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.Destroy Destructor

Summary

Represents the destructor of the TfrxReportOptions class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions Properties

Properties
Name | Description
Author | Report author.
Compressed | Determines whether to compress a report file. The gzip compression is used. You must put the TfrxGZipCompressor component onto your form.
ConnectionName | Not used.
CreateDate | Report creation date.
Description | Report description.
HiddenPassword | Allows to set password which will be used for report in LoadFrom method without showing dialog to user.
Info | Represents property Info.
InitString | Dot-matrix printer init string. Used only in dot-matrix reports.
LastChange | The date the report was last modified.
Name | Report name.
Password | Report password. If this property is not blank, a password is required when opening a report.
Picture | Report picture.
PrevPassword | Stores previous used password.
VersionBuild | Properties, which detect the number of a version.
VersionMajor | Properties, which detect the number of a version.
VersionMinor | Properties, which detect the number of a version.
VersionRelease | Properties, which detect the number of a version.
Top


TfrxReportOptions.Author Property

Summary

Report author.

Namespace: frxClass
Syntax
Delphi
published
 property Author: String read FAuthor write FAuthor;

Property Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.Compressed Property

Summary

Determines whether to compress a report file. The gzip compression is used. You must put the TfrxGZipCompressor component onto your form.

Namespace: frxClass
Syntax
Delphi
published
 property Compressed: Boolean read FCompressed write FCompressed default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.ConnectionName Property

Summary

Not used.

Namespace: frxClass
Syntax
Delphi
published
 property ConnectionName: String read FConnectionName write SetConnectionName;

Property Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.CreateDate Property

Summary

Report creation date.

Namespace: frxClass
Syntax
Delphi
published
 property CreateDate: TDateTime read FCreateDate write FCreateDate;

Property Value

Type: TDateTime

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.Description Property

Summary

Report description.

Namespace: frxClass
Syntax
Delphi
published
 property Description: TStrings read FDescription write SetDescription;

Property Value

Type: TStrings

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.HiddenPassword Property

Summary

Allows to set password which will be used for report in LoadFrom method without showing dialog to user.

Namespace: frxClass
Syntax
Delphi
public
 property HiddenPassword: String read FHiddenPassword write FHiddenPassword;

Property Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.Info Property

Summary

Represents property Info.

Namespace: frxClass
Syntax
Delphi
public
 property Info: Boolean read FInfo write FInfo;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.InitString Property

Summary

Dot-matrix printer init string. Used only in dot-matrix reports.

Namespace: frxClass
Syntax
Delphi
published
 property InitString: String read FInitString write FInitString;

Property Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.LastChange Property

Summary

The date the report was last modified.

Namespace: frxClass
Syntax
Delphi
published
 property LastChange: TDateTime read FLastChange write FLastChange;

Property Value

Type: TDateTime

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.Name Property

Summary

Report name.

Namespace: frxClass
Syntax
Delphi
published
 property Name: String read FName write FName;

Property Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.Password Property

Summary

Report password. If this property is not blank, a password is required when opening a report.

Namespace: frxClass
Syntax
Delphi
published
 property Password: String read FPassword write FPassword;

Property Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.Picture Property

Summary

Report picture.

Namespace: frxClass
Syntax
Delphi
published
 property Picture: TPicture read FPicture write SetPicture;

Property Value

Type: TPicture

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.PrevPassword Property

Summary

Stores previous used password.

Namespace: frxClass
Syntax
Delphi
public
 property PrevPassword: String write FPrevPassword;

Property Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.VersionBuild Property

Summary

Properties, which detect the number of a version.

Namespace: frxClass
Syntax
Delphi
published
 property VersionBuild: String read FVersionBuild write FVersionBuild;

Property Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.VersionMajor Property

Summary

Properties, which detect the number of a version.

Namespace: frxClass
Syntax
Delphi
published
 property VersionMajor: String read FVersionMajor write FVersionMajor;

Property Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.VersionMinor Property

Summary

Properties, which detect the number of a version.

Namespace: frxClass
Syntax
Delphi
published
 property VersionMinor: String read FVersionMinor write FVersionMinor;

Property Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.VersionRelease Property

Summary

Properties, which detect the number of a version.

Namespace: frxClass
Syntax
Delphi
published
 property VersionRelease: String read FVersionRelease write FVersionRelease;

Property Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions Methods

Methods
Name | Description
Assign(TPersistent) | Copies the contents from another object.
CheckPassword | If HiddenPassword is not set, shows password dialog and check password inputted by user. Otherwise uses HiddenPassword as a user defined password.
Clear | Clears all properties and fills them by default values.
SetConnectionName(String) | Represents method SetConnectionName(String).
SetDescription(TStrings) | Represents method SetDescription(TStrings).
SetPicture(TPicture) | Represents method SetPicture(TPicture).
Top


TfrxReportOptions.Assign(TPersistent) Method

Summary

Copies the contents from another object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.CheckPassword Method

Summary

If HiddenPassword is not set, shows password dialog and check password inputted by user. Otherwise uses HiddenPassword as a user defined password.

Namespace: frxClass
Syntax
Delphi
public
 function CheckPassword: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.Clear Method

Summary

Clears all properties and fills them by default values.

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.SetConnectionName(String) Method

Summary

Represents method SetConnectionName(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetConnectionName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.SetDescription(TStrings) Method

Summary

Represents method SetDescription(TStrings).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDescription(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.SetPicture(TPicture) Method

Summary

Represents method SetPicture(TPicture).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetPicture(const Value: TPicture);

Parameters

Value
Type: TPicture

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions Fields

Fields
Name | Description
FAuthor | Represents field FAuthor.
FCompressed | Represents field FCompressed.
FConnectionName | Represents field FConnectionName.
FCreateDate | Represents field FCreateDate.
FDescription | Represents field FDescription.
FHiddenPassword | Represents field FHiddenPassword.
FInfo | Represents field FInfo.
FInitString | Represents field FInitString.
FLastChange | Represents field FLastChange.
FName | Represents field FName.
FPassword | Represents field FPassword.
FPicture | Represents field FPicture.
FPrevPassword | Represents field FPrevPassword.
FReport | Represents field FReport.
FVersionBuild | Represents field FVersionBuild.
FVersionMajor | Represents field FVersionMajor.
FVersionMinor | Represents field FVersionMinor.
FVersionRelease | Represents field FVersionRelease.
Top


TfrxReportOptions.FAuthor Field

Summary

Represents field FAuthor.

Namespace: frxClass
Syntax
Delphi
private
 FAuthor: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FCompressed Field

Summary

Represents field FCompressed.

Namespace: frxClass
Syntax
Delphi
private
 FCompressed: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FConnectionName Field

Summary

Represents field FConnectionName.

Namespace: frxClass
Syntax
Delphi
private
 FConnectionName: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FCreateDate Field

Summary

Represents field FCreateDate.

Namespace: frxClass
Syntax
Delphi
private
 FCreateDate: TDateTime;

Field Value

Type: TDateTime

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FDescription Field

Summary

Represents field FDescription.

Namespace: frxClass
Syntax
Delphi
private
 FDescription: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FHiddenPassword Field

Summary

Represents field FHiddenPassword.

Namespace: frxClass
Syntax
Delphi
private
 FHiddenPassword: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FInfo Field

Summary

Represents field FInfo.

Namespace: frxClass
Syntax
Delphi
private
 FInfo: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FInitString Field

Summary

Represents field FInitString.

Namespace: frxClass
Syntax
Delphi
private
 FInitString: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FLastChange Field

Summary

Represents field FLastChange.

Namespace: frxClass
Syntax
Delphi
private
 FLastChange: TDateTime;

Field Value

Type: TDateTime

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FName Field

Summary

Represents field FName.

Namespace: frxClass
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FPassword Field

Summary

Represents field FPassword.

Namespace: frxClass
Syntax
Delphi
private
 FPassword: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FPicture Field

Summary

Represents field FPicture.

Namespace: frxClass
Syntax
Delphi
private
 FPicture: TPicture;

Field Value

Type: TPicture

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FPrevPassword Field

Summary

Represents field FPrevPassword.

Namespace: frxClass
Syntax
Delphi
private
 FPrevPassword: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FVersionBuild Field

Summary

Represents field FVersionBuild.

Namespace: frxClass
Syntax
Delphi
private
 FVersionBuild: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FVersionMajor Field

Summary

Represents field FVersionMajor.

Namespace: frxClass
Syntax
Delphi
private
 FVersionMajor: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FVersionMinor Field

Summary

Represents field FVersionMinor.

Namespace: frxClass
Syntax
Delphi
private
 FVersionMinor: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportOptions.FVersionRelease Field

Summary

Represents field FVersionRelease.

Namespace: frxClass
Syntax
Delphi
private
 FVersionRelease: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportOptions
  • frxClass


TfrxReportPage Class

Summary

The TfrxReportPage class represents a report design page that may contain bands and other objects such as "Text", "Picture", etc.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxPage
frxClass.TfrxReportPage
frxDMPClass.TfrxDMPPage
Syntax
Delphi
type
 TfrxReportPage = class(TfrxPage)
 end;

The TfrxReportPage type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Overloaded. Initializes a new instance of the TfrxReportPage class. (Overrides TfrxPage.Create(TComponent).)
CreateInPreview(TComponent,TfrxReport) | Overloaded. Constructor used in preview pages/
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxReportPage class. (Overrides TfrxComponent.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BackPicture | The page's background picture. It is printed on each page.
BackPicturePrintable | If the property is equal to True, the background page layout will be printed.
BackPictureStretched | Stretches background picture to page size.
BackPictureVisible | If the property is equal to True , then the background page layout will be displayed while preview.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Bin | Paper tray for the first report page. One of the DMBIN_XXX values, defined in the Windows.pas file.
BinOtherPages | Paper tray for report pages, except first page. One of the DMBIN_XXX values, defined in the Windows.pas file.
BottomMargin | Bottom margin, in millimeters.
Color | Color of the page.
ColumnPositions | Column starting positions, in millimeters.
Columns | Number of columns on a page. If this value is greather than 1, the printing will be performed in several columns. You also should set the column width in the ColumnWidth property.
ColumnWidth | Width of a column, in millimeters.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
DataSet | Dataset for the report page. If this property is not empty, the page will be printed as many times as there are records in the dataset.
DataSetName | Name of the dataset for the report page. This property duplicates the DataSet property.
Description | Object's description. (Inherited from TfrxComponent.)
Duplex | Duplex mode.
EndlessHeight | If this property is True, the page height will grow depending on number of data records on it.
EndlessWidth | If this property is True, the page width will grow depending on number of data records on it.
Font | Represents property Font. (Inherited from TfrxPage.)
Frame | Frame of the page.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
HGuides | Horizontal guide lines. Used only in the designer.
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LargeDesignHeight | If this property is True, the page will have large height in the designer. It is useful if you have many bands in the page.
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
LeftMargin | Left margin, in millimeters.
MirrorMargins | Determines whether is necessary to switch left and right margins when printing even pages. Default value is False.
MirrorMode | Set of Mirror modes for current page. Determinate how engine align controls and content base on original layout.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterPrint | Name of the script procedure that will be called after printing the page.
OnBeforePrint | Name of the script procedure that will be called before printing the page.
OnManualBuild | Name of the script procedure that represents an event handler. If the handler of this event is allocated, then the FastReport engine is blocked and you thus would have to construct a report manually.
Orientation | The paper orientation.
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node.
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
PageCount | The count of printed pages is similar to RowCout of the TfrxDataBand.
PaperHeight | The paper height, in millimeters.
PaperSize | The paper size. One of the values DMPAPER_xx, defined in the Windows.pas file (for example, DMPAPER_A4). When changing this property, other properties (PaperWidth, PaperHeight) changed too. If you set the DMPAPER_USER paper size, you should set PaperWidth, PaperHeight also.
PaperWidth | The paper width, in millimeters.
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
ParentReport | parent report for current page.
PrintIfEmpty | Determines whether to print a page if all its databands are connected to empty datasets. Default value is True.
PrintOnPreviousPage | Allows to print pages, beginning from blank space of the previous page. This option is used when a report template consists of several pages or when printing batch (composite) reports.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
ResetPageNumbers | If this property is True, the report engine reset logical page number when start printing current report template page.
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
RightMargin | Right margin, in millimeters.
ShowTitleOnPreviousPage | Determines whether to print the "Report title" when PrintOnPreviousPage set to true and previous page already has "Report title" band.
SubReport | Reference to a Subreport object.
TitleBeforeHeader | Determines whether to print the "Report title" band before "Page header" band. Default value is True.
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopMargin | Top margin, in millimeters.
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
VGuides | Vertical guide lines. Used only in the designer.
Visible | Represents property Visible. (Inherited from TfrxPage.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Overrides TfrxComponent.AlignChildren(Boolean,TfrxMirrorControlModes).)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ClearGuides | Clears all guide lines. Guide lines are used only in the designer.
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | Represents method Draw(TCanvas,Extended,Extended,Extended,Extended). (Overrides TfrxPage.Draw(TCanvas,Extended,Extended,Extended,Extended).)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindBand(TfrxBandClass) | Search for band of the specified class on the page.
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBackPicture | Represents method GetBackPicture.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColor | Represents method GetColor.
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetDataSetName | Represents method GetDataSetName.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetFrame | Represents method GetFrame.
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsSubReport | Returns True, if the report design page is linked to the "Subreport" object.
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBackPicture(TPicture) | Represents method SetBackPicture(TPicture).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetColor(TColor) | Represents method SetColor(TColor).
SetColumnPositions(TStrings) | Represents method SetColumnPositions(TStrings).
SetColumns(Integer) | Represents method SetColumns(Integer).
SetDataSet(TfrxDataSet) | Represents method SetDataSet(TfrxDataSet).
SetDataSetName(String) | Represents method SetDataSetName(String).
SetDefaults | Sets default page size and margins.
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetFrame(TfrxFrame) | Represents method SetFrame(TfrxFrame).
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetHGuides(TStrings) | Represents method SetHGuides(TStrings).
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetOrientation(TPrinterOrientation) | Represents method SetOrientation(TPrinterOrientation).
SetPageCount(Integer) | Represents method SetPageCount(Integer).
SetPaperHeight(Extended) | Represents method SetPaperHeight(Extended).
SetPaperSize(Integer) | Represents method SetPaperSize(Integer).
SetPaperWidth(Extended) | Represents method SetPaperWidth(Extended).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetSizeAndDimensions(Integer,Extended,Extended) | Sets the paper size and dimensions.
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVGuides(TStrings) | Represents method SetVGuides(TStrings).
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateDimensions | Represents method UpdateDimensions.
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBackPicture | Represents field FBackPicture.
FBackPicturePrintable | Represents field FBackPicturePrintable.
FBackPictureStretched | Represents field FBackPictureStretched.
FBackPictureVisible | Represents field FBackPictureVisible.
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FBin | Represents field FBin.
FBinOtherPages | Represents field FBinOtherPages.
FBottomMargin | Represents field FBottomMargin.
FColumnPositions | Represents field FColumnPositions.
FColumns | Represents field FColumns.
FColumnWidth | Represents field FColumnWidth.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
FDuplex | Represents field FDuplex.
FEndlessHeight | Represents field FEndlessHeight.
FEndlessWidth | Represents field FEndlessWidth.
FHGuides | Represents field FHGuides.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLargeDesignHeight | Represents field FLargeDesignHeight.
FLeftMargin | Represents field FLeftMargin.
FMirrorMargins | Represents field FMirrorMargins.
FMirrorMode | Represents field FMirrorMode.
FOnAfterPrint | Represents field FOnAfterPrint.
FOnBeforePrint | Represents field FOnBeforePrint.
FOnManualBuild | Represents field FOnManualBuild.
FOrientation | Represents field FOrientation.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FOutlineText | Represents field FOutlineText.
FPageCount | Represents field FPageCount.
FPaperHeight | Represents field FPaperHeight.
FPaperSize | Represents field FPaperSize.
FPaperWidth | Represents field FPaperWidth.
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintIfEmpty | Represents field FPrintIfEmpty.
FPrintOnPreviousPage | Represents field FPrintOnPreviousPage.
FReport | Represents field FReport.
FResetPageNumbers | Represents field FResetPageNumbers.
FRightMargin | Represents field FRightMargin.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShowTitleOnPreviousPage | Represents field FShowTitleOnPreviousPage.
FSubBands | List of master bands.
FSubReport | Represents field FSubReport.
FTitleBeforeHeader | Represents field FTitleBeforeHeader.
FTopMargin | Represents field FTopMargin.
FVGuides | Represents field FVGuides.
FVSubBands | List of vertical master bands.
Top
See Also

Reference

  • frxClass


TfrxReportPage Constructors

Constructors
Name | Description
Create(TComponent) | Overloaded. Initializes a new instance of the TfrxReportPage class. (Overrides TfrxPage.Create(TComponent).)
CreateInPreview(TComponent,TfrxReport) | Overloaded. Constructor used in preview pages/
Destroy | Represents the destructor of the TfrxReportPage class. (Overrides TfrxComponent.Destroy.)
Top


TfrxReportPage.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxReportPage class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); overload; override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxPage.Create(TComponent)
See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.CreateInPreview(TComponent,TfrxReport) Constructor

Summary

Constructor used in preview pages/

Namespace: frxClass
Syntax
Delphi
public
 constructor CreateInPreview(AOwner: TComponent; AReport: TfrxReport); overload;

Parameters

AOwner
Type: TComponent

Owner component.

AReport
Type: TfrxReport

Parent report for this page.

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.Destroy Destructor

Summary

Represents the destructor of the TfrxReportPage class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxComponent.Destroy
See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage Properties

Properties
Name | Description
BackPicture | The page's background picture. It is printed on each page.
BackPicturePrintable | If the property is equal to True, the background page layout will be printed.
BackPictureStretched | Stretches background picture to page size.
BackPictureVisible | If the property is equal to True , then the background page layout will be displayed while preview.
Bin | Paper tray for the first report page. One of the DMBIN_XXX values, defined in the Windows.pas file.
BinOtherPages | Paper tray for report pages, except first page. One of the DMBIN_XXX values, defined in the Windows.pas file.
BottomMargin | Bottom margin, in millimeters.
Color | Color of the page.
ColumnPositions | Column starting positions, in millimeters.
Columns | Number of columns on a page. If this value is greather than 1, the printing will be performed in several columns. You also should set the column width in the ColumnWidth property.
ColumnWidth | Width of a column, in millimeters.
DataSet | Dataset for the report page. If this property is not empty, the page will be printed as many times as there are records in the dataset.
DataSetName | Name of the dataset for the report page. This property duplicates the DataSet property.
Duplex | Duplex mode.
EndlessHeight | If this property is True, the page height will grow depending on number of data records on it.
EndlessWidth | If this property is True, the page width will grow depending on number of data records on it.
Frame | Frame of the page.
HGuides | Horizontal guide lines. Used only in the designer.
LargeDesignHeight | If this property is True, the page will have large height in the designer. It is useful if you have many bands in the page.
LeftMargin | Left margin, in millimeters.
MirrorMargins | Determines whether is necessary to switch left and right margins when printing even pages. Default value is False.
MirrorMode | Set of Mirror modes for current page. Determinate how engine align controls and content base on original layout.
OnAfterPrint | Name of the script procedure that will be called after printing the page.
OnBeforePrint | Name of the script procedure that will be called before printing the page.
OnManualBuild | Name of the script procedure that represents an event handler. If the handler of this event is allocated, then the FastReport engine is blocked and you thus would have to construct a report manually.
Orientation | The paper orientation.
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node.
PageCount | The count of printed pages is similar to RowCout of the TfrxDataBand.
PaperHeight | The paper height, in millimeters.
PaperSize | The paper size. One of the values DMPAPER_xx, defined in the Windows.pas file (for example, DMPAPER_A4). When changing this property, other properties (PaperWidth, PaperHeight) changed too. If you set the DMPAPER_USER paper size, you should set PaperWidth, PaperHeight also.
PaperWidth | The paper width, in millimeters.
ParentReport | parent report for current page.
PrintIfEmpty | Determines whether to print a page if all its databands are connected to empty datasets. Default value is True.
PrintOnPreviousPage | Allows to print pages, beginning from blank space of the previous page. This option is used when a report template consists of several pages or when printing batch (composite) reports.
ResetPageNumbers | If this property is True, the report engine reset logical page number when start printing current report template page.
RightMargin | Right margin, in millimeters.
ShowTitleOnPreviousPage | Determines whether to print the "Report title" when PrintOnPreviousPage set to true and previous page already has "Report title" band.
SubReport | Reference to a Subreport object.
TitleBeforeHeader | Determines whether to print the "Report title" band before "Page header" band. Default value is True.
TopMargin | Top margin, in millimeters.
VGuides | Vertical guide lines. Used only in the designer.
Top


TfrxReportPage.BackPicture Property

Summary

The page's background picture. It is printed on each page.

Namespace: frxClass
Syntax
Delphi
published
 property BackPicture: TPicture read GetBackPicture write SetBackPicture;

Property Value

Type: TPicture

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.BackPicturePrintable Property

Summary

If the property is equal to True, the background page layout will be printed.

Namespace: frxClass
Syntax
Delphi
published
 property BackPicturePrintable: Boolean read FBackPicturePrintable write FBackPicturePrintable default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.BackPictureStretched Property

Summary

Stretches background picture to page size.

Namespace: frxClass
Syntax
Delphi
published
 property BackPictureStretched: Boolean read FBackPictureStretched write FBackPictureStretched default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.BackPictureVisible Property

Summary

If the property is equal to True , then the background page layout will be displayed while preview.

Namespace: frxClass
Syntax
Delphi
published
 property BackPictureVisible: Boolean read FBackPictureVisible write FBackPictureVisible default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.Bin Property

Summary

Paper tray for the first report page. One of the DMBIN_XXX values, defined in the Windows.pas file.

Namespace: frxClass
Syntax
Delphi
published
 property Bin: Integer read FBin write FBin default DMBIN_AUTO;

Property Value

Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.BinOtherPages Property

Summary

Paper tray for report pages, except first page. One of the DMBIN_XXX values, defined in the Windows.pas file.

Namespace: frxClass
Syntax
Delphi
published
 property BinOtherPages: Integer read FBinOtherPages write FBinOtherPages
 default DMBIN_AUTO;

Property Value

Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.BottomMargin Property

Summary

Bottom margin, in millimeters.

Namespace: frxClass
Syntax
Delphi
published
 property BottomMargin: Extended read FBottomMargin write FBottomMargin;

Property Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.Color Property

Summary

Color of the page.

Namespace: frxClass
Syntax
Delphi
published
 property Color: TColor read GetColor write SetColor default clNone;

Property Value

Type: TColor

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.ColumnPositions Property

Summary

Column starting positions, in millimeters.

Namespace: frxClass
Syntax
Delphi
published
 property ColumnPositions: TStrings read FColumnPositions write SetColumnPositions;

Property Value

Type: TStrings

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.Columns Property

Summary

Number of columns on a page. If this value is greather than 1, the printing will be performed in several columns. You also should set the column width in the ColumnWidth property.

Namespace: frxClass
Syntax
Delphi
published
 property Columns: Integer read FColumns write SetColumns default 0;

Property Value

Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.ColumnWidth Property

Summary

Width of a column, in millimeters.

Namespace: frxClass
Syntax
Delphi
published
 property ColumnWidth: Extended read FColumnWidth write FColumnWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.DataSet Property

Summary

Dataset for the report page. If this property is not empty, the page will be printed as many times as there are records in the dataset.

Namespace: frxClass
Syntax
Delphi
published
 property DataSet: TfrxDataSet read FDataSet write SetDataSet;

Property Value

Type: TfrxDataSet

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.DataSetName Property

Summary

Name of the dataset for the report page. This property duplicates the DataSet property.

Namespace: frxClass
Syntax
Delphi
published
 property DataSetName: String read GetDataSetName write SetDataSetName;

Property Value

Type: String

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.Duplex Property

Summary

Duplex mode.

Namespace: frxClass
Syntax
Delphi
published
 property Duplex: TfrxDuplexMode read FDuplex write FDuplex default dmNone;

Property Value

Type: TfrxDuplexMode

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.EndlessHeight Property

Summary

If this property is True, the page height will grow depending on number of data records on it.

Namespace: frxClass
Syntax
Delphi
published
 property EndlessHeight: Boolean read FEndlessHeight write FEndlessHeight default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.EndlessWidth Property

Summary

If this property is True, the page width will grow depending on number of data records on it.

Namespace: frxClass
Syntax
Delphi
published
 property EndlessWidth: Boolean read FEndlessWidth write FEndlessWidth default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.Frame Property

Summary

Frame of the page.

Namespace: frxClass
Syntax
Delphi
published
 property Frame: TfrxFrame read GetFrame write SetFrame;

Property Value

Type: TfrxFrame

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.HGuides Property

Summary

Horizontal guide lines. Used only in the designer.

Namespace: frxClass
Syntax
Delphi
published
 property HGuides: TStrings read FHGuides write SetHGuides;

Property Value

Type: TStrings

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.LargeDesignHeight Property

Summary

If this property is True, the page will have large height in the designer. It is useful if you have many bands in the page.

Namespace: frxClass
Syntax
Delphi
published
 property LargeDesignHeight: Boolean read FLargeDesignHeight
 write FLargeDesignHeight default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.LeftMargin Property

Summary

Left margin, in millimeters.

Namespace: frxClass
Syntax
Delphi
published
 property LeftMargin: Extended read FLeftMargin write FLeftMargin;

Property Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.MirrorMargins Property

Summary

Determines whether is necessary to switch left and right margins when printing even pages. Default value is False.

Namespace: frxClass
Syntax
Delphi
published
 property MirrorMargins: Boolean read FMirrorMargins write FMirrorMargins
 default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.MirrorMode Property

Summary

Set of Mirror modes for current page. Determinate how engine align controls and content base on original layout.

Namespace: frxClass
Syntax
Delphi
published
 property MirrorMode: TfrxMirrorControlModes read FMirrorMode write FMirrorMode;

Property Value

Type: TfrxMirrorControlModes

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.OnAfterPrint Property

Summary

Name of the script procedure that will be called after printing the page.

Namespace: frxClass
Syntax
Delphi
published
 property OnAfterPrint: TfrxNotifyEvent read FOnAfterPrint write FOnAfterPrint;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.OnBeforePrint Property

Summary

Name of the script procedure that will be called before printing the page.

Namespace: frxClass
Syntax
Delphi
published
 property OnBeforePrint: TfrxNotifyEvent read FOnBeforePrint write FOnBeforePrint;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.OnManualBuild Property

Summary

Name of the script procedure that represents an event handler. If the handler of this event is allocated, then the FastReport engine is blocked and you thus would have to construct a report manually.

Namespace: frxClass
Syntax
Delphi
published
 property OnManualBuild: TfrxNotifyEvent read FOnManualBuild write FOnManualBuild;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.Orientation Property

Summary

The paper orientation.

Namespace: frxClass
Syntax
Delphi
published
 property Orientation: TPrinterOrientation read FOrientation
 write SetOrientation default poPortrait;

Property Value

Type: TPrinterOrientation

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.OutlineText Property

Summary

"Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node.

Namespace: frxClass
Syntax
Delphi
published
 property OutlineText: String read FOutlineText write FOutlineText;

Property Value

Type: String

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.PageCount Property

Summary

The count of printed pages is similar to RowCout of the TfrxDataBand.

Namespace: frxClass
Syntax
Delphi
published
 property PageCount: Integer read FPageCount write SetPageCount default 1;

Property Value

Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.PaperHeight Property

Summary

The paper height, in millimeters.

Namespace: frxClass
Syntax
Delphi
published
 property PaperHeight: Extended read FPaperHeight write SetPaperHeight;

Property Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.PaperSize Property

Summary

The paper size. One of the values DMPAPER_xx, defined in the Windows.pas file (for example, DMPAPER_A4). When changing this property, other properties (PaperWidth, PaperHeight) changed too. If you set the DMPAPER_USER paper size, you should set PaperWidth, PaperHeight also.

Namespace: frxClass
Syntax
Delphi
published
 property PaperSize: Integer read FPaperSize write SetPaperSize;

Property Value

Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.PaperWidth Property

Summary

The paper width, in millimeters.

Namespace: frxClass
Syntax
Delphi
published
 property PaperWidth: Extended read FPaperWidth write SetPaperWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.ParentReport Property

Summary

parent report for current page.

Namespace: frxClass
Syntax
Delphi
public
 property ParentReport: TfrxReport read FReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.PrintIfEmpty Property

Summary

Determines whether to print a page if all its databands are connected to empty datasets. Default value is True.

Namespace: frxClass
Syntax
Delphi
published
 property PrintIfEmpty: Boolean read FPrintIfEmpty write FPrintIfEmpty default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.PrintOnPreviousPage Property

Summary

Allows to print pages, beginning from blank space of the previous page. This option is used when a report template consists of several pages or when printing batch (composite) reports.

Namespace: frxClass
Syntax
Delphi
published
 property PrintOnPreviousPage: Boolean read FPrintOnPreviousPage
 write FPrintOnPreviousPage default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.ResetPageNumbers Property

Summary

If this property is True, the report engine reset logical page number when start printing current report template page.

Namespace: frxClass
Syntax
Delphi
published
 property ResetPageNumbers: Boolean read FResetPageNumbers
 write FResetPageNumbers default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.RightMargin Property

Summary

Right margin, in millimeters.

Namespace: frxClass
Syntax
Delphi
published
 property RightMargin: Extended read FRightMargin write FRightMargin;

Property Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.ShowTitleOnPreviousPage Property

Summary

Determines whether to print the "Report title" when PrintOnPreviousPage set to true and previous page already has "Report title" band.

Namespace: frxClass
Syntax
Delphi
published
 property ShowTitleOnPreviousPage: Boolean read FShowTitleOnPreviousPage
 write FShowTitleOnPreviousPage default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SubReport Property

Summary

Reference to a Subreport object.

Namespace: frxClass
Syntax
Delphi
public
 property SubReport: TfrxSubreport read FSubReport;

Property Value

Type: TfrxSubreport

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.TitleBeforeHeader Property

Summary

Determines whether to print the "Report title" band before "Page header" band. Default value is True.

Namespace: frxClass
Syntax
Delphi
published
 property TitleBeforeHeader: Boolean read FTitleBeforeHeader
 write FTitleBeforeHeader default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.TopMargin Property

Summary

Top margin, in millimeters.

Namespace: frxClass
Syntax
Delphi
published
 property TopMargin: Extended read FTopMargin write FTopMargin;

Property Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.VGuides Property

Summary

Vertical guide lines. Used only in the designer.

Namespace: frxClass
Syntax
Delphi
published
 property VGuides: TStrings read FVGuides write SetVGuides;

Property Value

Type: TStrings

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage Methods

Methods
Name | Description
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Overrides TfrxComponent.AlignChildren(Boolean,TfrxMirrorControlModes).)
ClearGuides | Clears all guide lines. Guide lines are used only in the designer.
Draw(TCanvas,Extended,Extended,Extended,Extended) | Represents method Draw(TCanvas,Extended,Extended,Extended,Extended). (Overrides TfrxPage.Draw(TCanvas,Extended,Extended,Extended,Extended).)
FindBand(TfrxBandClass) | Search for band of the specified class on the page.
GetBackPicture | Represents method GetBackPicture.
GetColor | Represents method GetColor.
GetDataSetName | Represents method GetDataSetName.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetFrame | Represents method GetFrame.
IsSubReport | Returns True, if the report design page is linked to the "Subreport" object.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
SetBackPicture(TPicture) | Represents method SetBackPicture(TPicture).
SetColor(TColor) | Represents method SetColor(TColor).
SetColumnPositions(TStrings) | Represents method SetColumnPositions(TStrings).
SetColumns(Integer) | Represents method SetColumns(Integer).
SetDataSet(TfrxDataSet) | Represents method SetDataSet(TfrxDataSet).
SetDataSetName(String) | Represents method SetDataSetName(String).
SetDefaults | Sets default page size and margins.
SetFrame(TfrxFrame) | Represents method SetFrame(TfrxFrame).
SetHGuides(TStrings) | Represents method SetHGuides(TStrings).
SetOrientation(TPrinterOrientation) | Represents method SetOrientation(TPrinterOrientation).
SetPageCount(Integer) | Represents method SetPageCount(Integer).
SetPaperHeight(Extended) | Represents method SetPaperHeight(Extended).
SetPaperSize(Integer) | Represents method SetPaperSize(Integer).
SetPaperWidth(Extended) | Represents method SetPaperWidth(Extended).
SetSizeAndDimensions(Integer,Extended,Extended) | Sets the paper size and dimensions.
SetVGuides(TStrings) | Represents method SetVGuides(TStrings).
UpdateDimensions | Represents method UpdateDimensions.
Top


TfrxReportPage.AlignChildren(Boolean,TfrxMirrorControlModes) Method

Summary

Align all child objects relative to the container based on mirror control modes and child objects Align's.

Namespace: frxClass
Syntax
Delphi
public
 procedure AlignChildren(IgnoreInvisible: Boolean = False; MirrorModes: TfrxMirrorControlModes = []); override;

Parameters

IgnoreInvisible
Type: Boolean

Ignore objects which's Visible property set to false.

MirrorModes
Type: TfrxMirrorControlModes

Mirror modes of top container.

Overrides

TfrxComponent.AlignChildren(Boolean,TfrxMirrorControlModes)
See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.ClearGuides Method

Summary

Clears all guide lines. Guide lines are used only in the designer.

Namespace: frxClass
Syntax
Delphi
public
 procedure ClearGuides;
See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

Represents method Draw(TCanvas,Extended,Extended,Extended,Extended).

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

ScaleX
Type: Extended

ScaleY
Type: Extended

OffsetX
Type: Extended

OffsetY
Type: Extended

Overrides

TfrxPage.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FindBand(TfrxBandClass) Method

Summary

Search for band of the specified class on the page.

Namespace: frxClass
Syntax
Delphi
public
 function FindBand(Band: TfrxBandClass): TfrxBand;

Parameters

Band
Type: TfrxBandClass

Class of the band to search for.

Return Value

Type: TfrxBand

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.GetBackPicture Method

Summary

Represents method GetBackPicture.

Namespace: frxClass
Syntax
Delphi
private
 function GetBackPicture: TPicture;

Return Value

Type: TPicture

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.GetColor Method

Summary

Represents method GetColor.

Namespace: frxClass
Syntax
Delphi
private
 function GetColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.GetDataSetName Method

Summary

Represents method GetDataSetName.

Namespace: frxClass
Syntax
Delphi
private
 function GetDataSetName: String;

Return Value

Type: String

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.GetFrame Method

Summary

Represents method GetFrame.

Namespace: frxClass
Syntax
Delphi
private
 function GetFrame: TfrxFrame;

Return Value

Type: TfrxFrame

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.IsSubReport Method

Summary

Returns True, if the report design page is linked to the "Subreport" object.

Namespace: frxClass
Syntax
Delphi
public
 function IsSubReport: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: frxClass
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetBackPicture(TPicture) Method

Summary

Represents method SetBackPicture(TPicture).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetBackPicture(const Value: TPicture);

Parameters

Value
Type: TPicture

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetColumnPositions(TStrings) Method

Summary

Represents method SetColumnPositions(TStrings).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetColumnPositions(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetColumns(Integer) Method

Summary

Represents method SetColumns(Integer).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetColumns(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetDataSet(TfrxDataSet) Method

Summary

Represents method SetDataSet(TfrxDataSet).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDataSet(const Value: TfrxDataSet);

Parameters

Value
Type: TfrxDataSet

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetDataSetName(String) Method

Summary

Represents method SetDataSetName(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDataSetName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetDefaults Method

Summary

Sets default page size and margins.

Namespace: frxClass
Syntax
Delphi
public
 procedure SetDefaults; virtual;
See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetFrame(TfrxFrame) Method

Summary

Represents method SetFrame(TfrxFrame).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFrame(const Value: TfrxFrame);

Parameters

Value
Type: TfrxFrame

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetHGuides(TStrings) Method

Summary

Represents method SetHGuides(TStrings).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetHGuides(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetOrientation(TPrinterOrientation) Method

Summary

Represents method SetOrientation(TPrinterOrientation).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetOrientation(Value: TPrinterOrientation);

Parameters

Value
Type: TPrinterOrientation

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetPageCount(Integer) Method

Summary

Represents method SetPageCount(Integer).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetPageCount(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetPaperHeight(Extended) Method

Summary

Represents method SetPaperHeight(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetPaperHeight(const Value: Extended); virtual;

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetPaperSize(Integer) Method

Summary

Represents method SetPaperSize(Integer).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetPaperSize(const Value: Integer); virtual;

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetPaperWidth(Extended) Method

Summary

Represents method SetPaperWidth(Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure SetPaperWidth(const Value: Extended); virtual;

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetSizeAndDimensions(Integer,Extended,Extended) Method

Summary

Sets the paper size and dimensions.

Namespace: frxClass
Syntax
Delphi
public
 procedure SetSizeAndDimensions(ASize: Integer; AWidth, AHeight: Extended);

Parameters

ASize
Type: Integer

AWidth
Type: Extended

AHeight
Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.SetVGuides(TStrings) Method

Summary

Represents method SetVGuides(TStrings).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetVGuides(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.UpdateDimensions Method

Summary

Represents method UpdateDimensions.

Namespace: frxClass
Syntax
Delphi
protected
 procedure UpdateDimensions;
See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage Fields

Fields
Name | Description
FBackPicture | Represents field FBackPicture.
FBackPicturePrintable | Represents field FBackPicturePrintable.
FBackPictureStretched | Represents field FBackPictureStretched.
FBackPictureVisible | Represents field FBackPictureVisible.
FBin | Represents field FBin.
FBinOtherPages | Represents field FBinOtherPages.
FBottomMargin | Represents field FBottomMargin.
FColumnPositions | Represents field FColumnPositions.
FColumns | Represents field FColumns.
FColumnWidth | Represents field FColumnWidth.
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
FDuplex | Represents field FDuplex.
FEndlessHeight | Represents field FEndlessHeight.
FEndlessWidth | Represents field FEndlessWidth.
FHGuides | Represents field FHGuides.
FLargeDesignHeight | Represents field FLargeDesignHeight.
FLeftMargin | Represents field FLeftMargin.
FMirrorMargins | Represents field FMirrorMargins.
FMirrorMode | Represents field FMirrorMode.
FOnAfterPrint | Represents field FOnAfterPrint.
FOnBeforePrint | Represents field FOnBeforePrint.
FOnManualBuild | Represents field FOnManualBuild.
FOrientation | Represents field FOrientation.
FOutlineText | Represents field FOutlineText.
FPageCount | Represents field FPageCount.
FPaperHeight | Represents field FPaperHeight.
FPaperSize | Represents field FPaperSize.
FPaperWidth | Represents field FPaperWidth.
FPrintIfEmpty | Represents field FPrintIfEmpty.
FPrintOnPreviousPage | Represents field FPrintOnPreviousPage.
FReport | Represents field FReport.
FResetPageNumbers | Represents field FResetPageNumbers.
FRightMargin | Represents field FRightMargin.
FShowTitleOnPreviousPage | Represents field FShowTitleOnPreviousPage.
FSubBands | List of master bands.
FSubReport | Represents field FSubReport.
FTitleBeforeHeader | Represents field FTitleBeforeHeader.
FTopMargin | Represents field FTopMargin.
FVGuides | Represents field FVGuides.
FVSubBands | List of vertical master bands.
Top


TfrxReportPage.FBackPicture Field

Summary

Represents field FBackPicture.

Namespace: frxClass
Syntax
Delphi
private
 FBackPicture: TfrxPictureView;

Field Value

Type: TfrxPictureView

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FBackPicturePrintable Field

Summary

Represents field FBackPicturePrintable.

Namespace: frxClass
Syntax
Delphi
private
 FBackPicturePrintable: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FBackPictureStretched Field

Summary

Represents field FBackPictureStretched.

Namespace: frxClass
Syntax
Delphi
private
 FBackPictureStretched: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FBackPictureVisible Field

Summary

Represents field FBackPictureVisible.

Namespace: frxClass
Syntax
Delphi
private
 FBackPictureVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FBin Field

Summary

Represents field FBin.

Namespace: frxClass
Syntax
Delphi
private
 FBin: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FBinOtherPages Field

Summary

Represents field FBinOtherPages.

Namespace: frxClass
Syntax
Delphi
private
 FBinOtherPages: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FBottomMargin Field

Summary

Represents field FBottomMargin.

Namespace: frxClass
Syntax
Delphi
private
 FBottomMargin: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FColumnPositions Field

Summary

Represents field FColumnPositions.

Namespace: frxClass
Syntax
Delphi
private
 FColumnPositions: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FColumns Field

Summary

Represents field FColumns.

Namespace: frxClass
Syntax
Delphi
private
 FColumns: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FColumnWidth Field

Summary

Represents field FColumnWidth.

Namespace: frxClass
Syntax
Delphi
private
 FColumnWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FDataSet Field

Summary

Represents field FDataSet.

Namespace: frxClass
Syntax
Delphi
private
 FDataSet: TfrxDataSet;

Field Value

Type: TfrxDataSet

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FDataSetName Field

Summary

Represents field FDataSetName.

Namespace: frxClass
Syntax
Delphi
private
 FDataSetName: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FDuplex Field

Summary

Represents field FDuplex.

Namespace: frxClass
Syntax
Delphi
private
 FDuplex: TfrxDuplexMode;

Field Value

Type: TfrxDuplexMode

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FEndlessHeight Field

Summary

Represents field FEndlessHeight.

Namespace: frxClass
Syntax
Delphi
private
 FEndlessHeight: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FEndlessWidth Field

Summary

Represents field FEndlessWidth.

Namespace: frxClass
Syntax
Delphi
private
 FEndlessWidth: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FHGuides Field

Summary

Represents field FHGuides.

Namespace: frxClass
Syntax
Delphi
private
 FHGuides: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FLargeDesignHeight Field

Summary

Represents field FLargeDesignHeight.

Namespace: frxClass
Syntax
Delphi
private
 FLargeDesignHeight: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FLeftMargin Field

Summary

Represents field FLeftMargin.

Namespace: frxClass
Syntax
Delphi
private
 FLeftMargin: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FMirrorMargins Field

Summary

Represents field FMirrorMargins.

Namespace: frxClass
Syntax
Delphi
private
 FMirrorMargins: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FMirrorMode Field

Summary

Represents field FMirrorMode.

Namespace: frxClass
Syntax
Delphi
private
 FMirrorMode: TfrxMirrorControlModes;

Field Value

Type: TfrxMirrorControlModes

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FOnAfterPrint Field

Summary

Represents field FOnAfterPrint.

Namespace: frxClass
Syntax
Delphi
private
 FOnAfterPrint: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FOnBeforePrint Field

Summary

Represents field FOnBeforePrint.

Namespace: frxClass
Syntax
Delphi
private
 FOnBeforePrint: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FOnManualBuild Field

Summary

Represents field FOnManualBuild.

Namespace: frxClass
Syntax
Delphi
private
 FOnManualBuild: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FOrientation Field

Summary

Represents field FOrientation.

Namespace: frxClass
Syntax
Delphi
private
 FOrientation: TPrinterOrientation;

Field Value

Type: TPrinterOrientation

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FOutlineText Field

Summary

Represents field FOutlineText.

Namespace: frxClass
Syntax
Delphi
private
 FOutlineText: String;

Field Value

Type: String

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FPageCount Field

Summary

Represents field FPageCount.

Namespace: frxClass
Syntax
Delphi
private
 FPageCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FPaperHeight Field

Summary

Represents field FPaperHeight.

Namespace: frxClass
Syntax
Delphi
protected
 FPaperHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FPaperSize Field

Summary

Represents field FPaperSize.

Namespace: frxClass
Syntax
Delphi
protected
 FPaperSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FPaperWidth Field

Summary

Represents field FPaperWidth.

Namespace: frxClass
Syntax
Delphi
protected
 FPaperWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FPrintIfEmpty Field

Summary

Represents field FPrintIfEmpty.

Namespace: frxClass
Syntax
Delphi
private
 FPrintIfEmpty: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FPrintOnPreviousPage Field

Summary

Represents field FPrintOnPreviousPage.

Namespace: frxClass
Syntax
Delphi
private
 FPrintOnPreviousPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FResetPageNumbers Field

Summary

Represents field FResetPageNumbers.

Namespace: frxClass
Syntax
Delphi
private
 FResetPageNumbers: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FRightMargin Field

Summary

Represents field FRightMargin.

Namespace: frxClass
Syntax
Delphi
private
 FRightMargin: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FShowTitleOnPreviousPage Field

Summary

Represents field FShowTitleOnPreviousPage.

Namespace: frxClass
Syntax
Delphi
private
 FShowTitleOnPreviousPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FSubBands Field

Summary

List of master bands.

Namespace: frxClass
Syntax
Delphi
public
 FSubBands: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FSubReport Field

Summary

Represents field FSubReport.

Namespace: frxClass
Syntax
Delphi
private
 FSubReport: TfrxSubreport;

Field Value

Type: TfrxSubreport

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FTitleBeforeHeader Field

Summary

Represents field FTitleBeforeHeader.

Namespace: frxClass
Syntax
Delphi
private
 FTitleBeforeHeader: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FTopMargin Field

Summary

Represents field FTopMargin.

Namespace: frxClass
Syntax
Delphi
private
 FTopMargin: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FVGuides Field

Summary

Represents field FVGuides.

Namespace: frxClass
Syntax
Delphi
private
 FVGuides: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportPage.FVSubBands Field

Summary

List of vertical master bands.

Namespace: frxClass
Syntax
Delphi
public
 FVSubBands: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxReportPage
  • frxClass


TfrxReportSummary Class

Summary

The TfrxReportSummary class represents a "Report summary" band. This kind of band is displayed at the end of the report.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxReportSummary
Syntax
Delphi
type
 TfrxReportSummary = class(TfrxBand)
 end;

The TfrxReportSummary type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Represents property KeepChild.
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point). (Inherited from TfrxBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintAtBottom | Determines if summary band should print at bottom of the page.
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Represents property StartNewPage.
Stretched | Represents property Stretched.
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintAtBottom | Represents field FPrintAtBottom.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxReportSummary Properties

Properties
Name | Description
AllowSplit | Represents property AllowSplit.
Child | Represents property Child.
KeepChild | Represents property KeepChild.
PrintAtBottom | Determines if summary band should print at bottom of the page.
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Represents property StartNewPage.
Stretched | Represents property Stretched.
Top


TfrxReportSummary.AllowSplit Property

Summary

Represents property AllowSplit.

Namespace: frxClass
Syntax
Delphi
published
 property AllowSplit;

Property Value

Type: Void

See Also

Reference

  • TfrxReportSummary
  • frxClass


TfrxReportSummary.Child Property

Summary

Represents property Child.

Namespace: frxClass
Syntax
Delphi
published
 property Child;

Property Value

Type: Void

See Also

Reference

  • TfrxReportSummary
  • frxClass


TfrxReportSummary.KeepChild Property

Summary

Represents property KeepChild.

Namespace: frxClass
Syntax
Delphi
published
 property KeepChild;

Property Value

Type: Void

See Also

Reference

  • TfrxReportSummary
  • frxClass


TfrxReportSummary.PrintAtBottom Property

Summary

Determines if summary band should print at bottom of the page.

Namespace: frxClass
Syntax
Delphi
published
 property PrintAtBottom: Boolean read FPrintAtBottom write FPrintAtBottom default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxReportSummary
  • frxClass


TfrxReportSummary.PrintChildIfInvisible Property

Summary

Represents property PrintChildIfInvisible.

Namespace: frxClass
Syntax
Delphi
published
 property PrintChildIfInvisible;

Property Value

Type: Void

See Also

Reference

  • TfrxReportSummary
  • frxClass


TfrxReportSummary.ShiftEngine Property

Summary

Represents property ShiftEngine.

Namespace: frxClass
Syntax
Delphi
published
 property ShiftEngine;

Property Value

Type: Void

See Also

Reference

  • TfrxReportSummary
  • frxClass


TfrxReportSummary.StartNewPage Property

Summary

Represents property StartNewPage.

Namespace: frxClass
Syntax
Delphi
published
 property StartNewPage;

Property Value

Type: Void

See Also

Reference

  • TfrxReportSummary
  • frxClass


TfrxReportSummary.Stretched Property

Summary

Represents property Stretched.

Namespace: frxClass
Syntax
Delphi
published
 property Stretched;

Property Value

Type: Void

See Also

Reference

  • TfrxReportSummary
  • frxClass


TfrxReportSummary Fields

Fields
Name | Description
FPrintAtBottom | Represents field FPrintAtBottom.
Top


TfrxReportSummary.FPrintAtBottom Field

Summary

Represents field FPrintAtBottom.

Namespace: frxClass
Syntax
Delphi
private
 FPrintAtBottom: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportSummary
  • frxClass


TfrxReportTitle Class

Summary

The TfrxReportTitle class represents a "Report title" band. This kind of band is displayed at the top of the report.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxReportTitle
Syntax
Delphi
type
 TfrxReportTitle = class(TfrxBand)
 end;

The TfrxReportTitle type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBand class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Represents property KeepChild.
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. All bands have the "OutlineText" property, into which a line-expression can be put, and this in turn helps to automatically create a tree. The expression will be calculated when forming a report, and its value will be added to the tree when printing the band. Thus, elements' hierarchy in the tree is similar to the bands' hierarchy in a report. That means, that in the tree there will be main and subordinate elements, corresponding to main and subordinate bands in a report (a report with two levels of data or with groups can exemplify the point). (Inherited from TfrxBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Represents property StartNewPage.
Stretched | Represents property Stretched.
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Inherited from TfrxBand.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxBand.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxReportTitle Properties

Properties
Name | Description
AllowSplit | Represents property AllowSplit.
Child | Represents property Child.
KeepChild | Represents property KeepChild.
PrintChildIfInvisible | Represents property PrintChildIfInvisible.
ShiftEngine | Represents property ShiftEngine.
StartNewPage | Represents property StartNewPage.
Stretched | Represents property Stretched.
Top


TfrxReportTitle.AllowSplit Property

Summary

Represents property AllowSplit.

Namespace: frxClass
Syntax
Delphi
published
 property AllowSplit;

Property Value

Type: Void

See Also

Reference

  • TfrxReportTitle
  • frxClass


TfrxReportTitle.Child Property

Summary

Represents property Child.

Namespace: frxClass
Syntax
Delphi
published
 property Child;

Property Value

Type: Void

See Also

Reference

  • TfrxReportTitle
  • frxClass


TfrxReportTitle.KeepChild Property

Summary

Represents property KeepChild.

Namespace: frxClass
Syntax
Delphi
published
 property KeepChild;

Property Value

Type: Void

See Also

Reference

  • TfrxReportTitle
  • frxClass


TfrxReportTitle.PrintChildIfInvisible Property

Summary

Represents property PrintChildIfInvisible.

Namespace: frxClass
Syntax
Delphi
published
 property PrintChildIfInvisible;

Property Value

Type: Void

See Also

Reference

  • TfrxReportTitle
  • frxClass


TfrxReportTitle.ShiftEngine Property

Summary

Represents property ShiftEngine.

Namespace: frxClass
Syntax
Delphi
published
 property ShiftEngine;

Property Value

Type: Void

See Also

Reference

  • TfrxReportTitle
  • frxClass


TfrxReportTitle.StartNewPage Property

Summary

Represents property StartNewPage.

Namespace: frxClass
Syntax
Delphi
published
 property StartNewPage;

Property Value

Type: Void

See Also

Reference

  • TfrxReportTitle
  • frxClass


TfrxReportTitle.Stretched Property

Summary

Represents property Stretched.

Namespace: frxClass
Syntax
Delphi
published
 property Stretched;

Property Value

Type: Void

See Also

Reference

  • TfrxReportTitle
  • frxClass


TfrxRunDialogsEvent Class

Summary

Represents type TfrxRunDialogsEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxRunDialogsEvent = type String;
See Also

Reference

  • frxClass


TfrxSaveToCompressedFilter Class

Summary

The class represents compressed file transport filter.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxCustomIOTransport
frxClass.TfrxIOTransportFile
frxClass.TfrxSaveToCompressedFilter
Syntax
Delphi
type
 TfrxSaveToCompressedFilter = class(TfrxIOTransportFile)
 end;

The TfrxSaveToCompressedFilter type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxSaveToCompressedFilter class. (Overrides TfrxIOTransportFile.Create(TComponent).)
CreateNoRegister | This constructor creates component without registration in global list so the filter will be hidden for preview or report designer. (Inherited from TfrxCustomIOTransport.)
Top
Properties
Show:
Name | Description
BasePath | Base path used in transport filter. (Inherited from TfrxCustomIOTransport.)
CreatedFrom | This flag shows where the current instance of the filter was created from. (Inherited from TfrxCustomIOTransport.)
CurrentContainer | Name of the current container. (Inherited from TfrxCustomIOTransport.)
DefaultExt | Default extension used in transport filter. (Inherited from TfrxCustomIOTransport.)
DefaultPath | Default path used in transport filter. (Inherited from TfrxCustomIOTransport.)
ExtDescription | Description for default extension used in transport filter. (Inherited from TfrxCustomIOTransport.)
FileName | File name for current filter. (Inherited from TfrxCustomIOTransport.)
FilterAccess | Access type of IO filter. (Inherited from TfrxCustomIOTransport.)
FilterString | Description of filter instance. (Inherited from TfrxCustomIOTransport.)
InternalFilter | Represents property InternalFilter. (Inherited from TfrxCustomIOTransport.)
IsFR3File | True when it's an report template file.
OverwritePrompt | Represents property OverwritePrompt. (Inherited from TfrxCustomIOTransport.)
Report | Reference to a report component. (Inherited from TfrxCustomIOTransport.)
RootNode | Root node of the filter. (Inherited from TfrxCustomIOTransport.)
ShowDialog | Whether to display a print dialogue. Default value is True. (Inherited from TfrxCustomIOTransport.)
SupportedStreams | Supported stream type for current IO transport filter. (Inherited from TfrxCustomIOTransport.)
TempFilter | Returns reference to transport filter instance for temporary operations. (Inherited from TfrxCustomIOTransport.)
Visibility | These flags used in IO transports to define visibility of IO transport filter. By default each transport filter component registers in global list and these flags helps to sort items of the global list. (Inherited from TfrxCustomIOTransport.)
Top
Methods
Show:
Name | Description
AddContainer(TfrxNode) | Represents method AddContainer(TfrxNode). (Overrides TfrxCustomIOTransport.AddContainer(TfrxNode).)
AllInOneContainer | Returns true when physically all stream belongs to one container(zip archive). (Inherited from TfrxCustomIOTransport.)
AssignFilter(TfrxCustomIOTransport) | This method assigns properties of other transport filter to current. (Inherited from TfrxCustomIOTransport.)
AssignSharedProperties(TfrxCustomIOTransport) | This method assigns shared properties(like tokens) of other transport filter to current. (Inherited from TfrxCustomIOTransport.)
CloseAllStreams | The method closes all opened streams. (Inherited from TfrxCustomIOTransport.)
CloseFilter | This method can be called to close a filter. It uses to make finalization like close connection and streams. (Overrides TfrxCustomIOTransport.CloseFilter.)
CopyStreamsNames(TStrings,Boolean) | It copies names of steams in current transport to TStrings passed as a parameter. (Inherited from TfrxCustomIOTransport.)
CreateContainer(String,Boolean) | Creates a structure node represents a container or directory. (Inherited from TfrxCustomIOTransport.)
CreateFilterClone(TfrxFilterVisibleState) | Copy constructor. (Inherited from TfrxCustomIOTransport.)
CreateTempContainer | Creates a structure node represents a temporary container or directory. (Overrides TfrxCustomIOTransport.CreateTempContainer.)
DeleteContainer(String) | Deletes a structure node represents a container or directory. (Inherited from TfrxCustomIOTransport.)
DeleteFiles | Represents method DeleteFiles. (Inherited from TfrxIOTransportFile.)
DoCreateStream(String,String) | Represents method DoCreateStream(String,String). (Overrides TfrxCustomIOTransport.DoCreateStream(String,String).)
DoFilterProcessStream(TStream,TObject) | This method call before loading from stream is started. Can be used to make a preparation of stream data before loading. (Inherited from TfrxCustomIOTransport.)
FreeStream(TStream,String) | Closes an opened stream by reference or name. (Inherited from TfrxCustomIOTransport.)
FreeTempContainer | Destroy a structure node represents a temporary container or directory. (Overrides TfrxCustomIOTransport.FreeTempContainer.)
GetDescription | Represents method GetDescription. (Overrides TfrxIOTransportFile.GetDescription.)
GetFileNode | Returns nearest file node in current container. (Inherited from TfrxCustomIOTransport.)
GetFilterString | Represents method GetFilterString. (Overrides TfrxCustomIOTransport.GetFilterString.)
GetNodeFromPath(String,Boolean,Boolean) | Represents method GetNodeFromPath(String,Boolean,Boolean). (Inherited from TfrxCustomIOTransport.)
GetStream(String) | Returns stream by name of a node or a file. (Inherited from TfrxCustomIOTransport.)
GetVisibility | Represents method GetVisibility. (Inherited from TfrxCustomIOTransport.)
InitFromExport(TfrxCustomExportFilter) | Initialization of transport filter based on export filter settings(like file name and file extension). (Inherited from TfrxCustomIOTransport.)
LoadClosedStreams | Reloads all closed streams and open them again. (Inherited from TfrxCustomIOTransport.)
LoadStreamsList(TStrings) | Loads and opens steams from the list. (Inherited from TfrxCustomIOTransport.)
OpenFilter | This method can be called to open filter. It uses to make preparation like set connection or show user dialogs. It returns true when initialization was processed. (Overrides TfrxIOTransportFile.OpenFilter.)
RemoveContainer(TfrxNode) | Represents method RemoveContainer(TfrxNode). (Inherited from TfrxCustomIOTransport.)
SetIsFR3File(Boolean) | Represents method SetIsFR3File(Boolean).
SetVisibility(TfrxFilterVisibility) | Represents method SetVisibility(TfrxFilterVisibility). (Overrides TfrxCustomIOTransport.SetVisibility(TfrxFilterVisibility).)
Top
Fields
Show:
Name | Description
FClosedLoadLock | Represents field FClosedLoadLock. (Inherited from TfrxCustomIOTransport.)
FCreatedFrom | Represents field FCreatedFrom. (Inherited from TfrxCustomIOTransport.)
FDirTree | Represents field FDirTree. (Inherited from TfrxCustomIOTransport.)
FFreeStream | Represents field FFreeStream. (Inherited from TfrxCustomIOTransport.)
FInternalFilter | Represents field FInternalFilter. (Inherited from TfrxCustomIOTransport.)
FIsFR3File | Represents field FIsFR3File.
FNoRegister | Represents field FNoRegister. (Inherited from TfrxCustomIOTransport.)
FOriginalCopy | Represents field FOriginalCopy. (Inherited from TfrxCustomIOTransport.)
FSupportedStreams | Represents field FSupportedStreams. (Inherited from TfrxCustomIOTransport.)
FVisibility | Represents field FVisibility. (Inherited from TfrxCustomIOTransport.)
Top
See Also

Reference

  • frxClass


TfrxSaveToCompressedFilter Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxSaveToCompressedFilter class. (Overrides TfrxIOTransportFile.Create(TComponent).)
Top


TfrxSaveToCompressedFilter.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxSaveToCompressedFilter class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxIOTransportFile.Create(TComponent)
See Also

Reference

  • TfrxSaveToCompressedFilter
  • frxClass


TfrxSaveToCompressedFilter Properties

Properties
Name | Description
IsFR3File | True when it's an report template file.
Top


TfrxSaveToCompressedFilter.IsFR3File Property

Summary

True when it's an report template file.

Namespace: frxClass
Syntax
Delphi
public
 property IsFR3File: Boolean read FIsFR3File write SetIsFR3File;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSaveToCompressedFilter
  • frxClass


TfrxSaveToCompressedFilter Methods

Methods
Name | Description
GetDescription | Represents method GetDescription. (Overrides TfrxIOTransportFile.GetDescription.)
GetFilterString | Represents method GetFilterString. (Overrides TfrxCustomIOTransport.GetFilterString.)
OpenFilter | This method can be called to open filter. It uses to make preparation like set connection or show user dialogs. It returns true when initialization was processed. (Overrides TfrxIOTransportFile.OpenFilter.)
SetIsFR3File(Boolean) | Represents method SetIsFR3File(Boolean).
Top


TfrxSaveToCompressedFilter.GetDescription Method

Summary

Represents method GetDescription.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxIOTransportFile.GetDescription
See Also

Reference

  • TfrxSaveToCompressedFilter
  • frxClass


TfrxSaveToCompressedFilter.GetFilterString Method

Summary

Represents method GetFilterString.

Namespace: frxClass
Syntax
Delphi
protected
 function GetFilterString: String; override;

Return Value

Type: String

Overrides

TfrxCustomIOTransport.GetFilterString
See Also

Reference

  • TfrxSaveToCompressedFilter
  • frxClass


TfrxSaveToCompressedFilter.OpenFilter Method

Summary

This method can be called to open filter. It uses to make preparation like set connection or show user dialogs. It returns true when initialization was processed.

Namespace: frxClass
Syntax
Delphi
public
 function OpenFilter: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxIOTransportFile.OpenFilter
See Also

Reference

  • TfrxSaveToCompressedFilter
  • frxClass


TfrxSaveToCompressedFilter.SetIsFR3File(Boolean) Method

Summary

Represents method SetIsFR3File(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetIsFR3File(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxSaveToCompressedFilter
  • frxClass


TfrxSaveToCompressedFilter Fields

Fields
Name | Description
FIsFR3File | Represents field FIsFR3File.
Top


TfrxSaveToCompressedFilter.FIsFR3File Field

Summary

Represents field FIsFR3File.

Namespace: frxClass
Syntax
Delphi
private
 FIsFR3File: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSaveToCompressedFilter
  • frxClass


TfrxSelectedObjectsList Class

Summary

This class implements list of selected report objects in the report designer and in the report preview. For the report designer it encapsulates second list for the object inspector.

Namespace: frxClass
Inheritance Hierarchy
TList
frxClass.TfrxSelectedObjectsList
Syntax
Delphi
type
 TfrxSelectedObjectsList = class(TList)
 end;

The TfrxSelectedObjectsList type exposes the following members.

Constructors
Show:
Name | Description
Create | List constructor.
Destroy | Represents the destructor of the TfrxSelectedObjectsList class.
Top
Properties
Show:
Name | Description
InspSelectedObjects | Reference to the object inspector list. It used by the object inspector. In the report designer selected objects and object inspector selection may vary.
Updated | State of the lists. It's updating when it's True.
Top
Methods
Show:
Name | Description
ClearInspectorList | Clears only object inspector list.
Notify(Pointer,TListNotification) | Represents method Notify(Pointer,TListNotification).
Top
Fields
Show:
Name | Description
FInspSelectedObjects | Represents field FInspSelectedObjects.
FUpdated | Represents field FUpdated.
Top
See Also

Reference

  • frxClass


TfrxSelectedObjectsList Constructors

Constructors
Name | Description
Create | List constructor.
Destroy | Represents the destructor of the TfrxSelectedObjectsList class.
Top


TfrxSelectedObjectsList.Create Constructor

Summary

List constructor.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxSelectedObjectsList
  • frxClass


TfrxSelectedObjectsList.Destroy Destructor

Summary

Represents the destructor of the TfrxSelectedObjectsList class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxSelectedObjectsList
  • frxClass


TfrxSelectedObjectsList Properties

Properties
Name | Description
InspSelectedObjects | Reference to the object inspector list. It used by the object inspector. In the report designer selected objects and object inspector selection may vary.
Updated | State of the lists. It's updating when it's True.
Top


TfrxSelectedObjectsList.InspSelectedObjects Property

Summary

Reference to the object inspector list. It used by the object inspector. In the report designer selected objects and object inspector selection may vary.

Namespace: frxClass
Syntax
Delphi
public
 property InspSelectedObjects: TList read FInspSelectedObjects;

Property Value

Type: TList

See Also

Reference

  • TfrxSelectedObjectsList
  • frxClass


TfrxSelectedObjectsList.Updated Property

Summary

State of the lists. It's updating when it's True.

Namespace: frxClass
Syntax
Delphi
public
 property Updated: Boolean read FUpdated write FUpdated;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSelectedObjectsList
  • frxClass


TfrxSelectedObjectsList Methods

Methods
Name | Description
ClearInspectorList | Clears only object inspector list.
Notify(Pointer,TListNotification) | Represents method Notify(Pointer,TListNotification).
Top


TfrxSelectedObjectsList.ClearInspectorList Method

Summary

Clears only object inspector list.

Namespace: frxClass
Syntax
Delphi
public
 procedure ClearInspectorList;
See Also

Reference

  • TfrxSelectedObjectsList
  • frxClass


TfrxSelectedObjectsList.Notify(Pointer,TListNotification) Method

Summary

Represents method Notify(Pointer,TListNotification).

Namespace: frxClass
Syntax
Delphi
protected
 procedure Notify(Ptr: Pointer; Action: TListNotification); override;

Parameters

Ptr
Type: Pointer

Action
Type: TListNotification

See Also

Reference

  • TfrxSelectedObjectsList
  • frxClass


TfrxSelectedObjectsList Fields

Fields
Name | Description
FInspSelectedObjects | Represents field FInspSelectedObjects.
FUpdated | Represents field FUpdated.
Top


TfrxSelectedObjectsList.FInspSelectedObjects Field

Summary

Represents field FInspSelectedObjects.

Namespace: frxClass
Syntax
Delphi
private
 FInspSelectedObjects: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxSelectedObjectsList
  • frxClass


TfrxSelectedObjectsList.FUpdated Field

Summary

Represents field FUpdated.

Namespace: frxClass
Syntax
Delphi
private
 FUpdated: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSelectedObjectsList
  • frxClass


TfrxShapeView Class

Summary

The TfrxShapeView class represents the "Shape" object. It can show one of the following shapes: rectangle, ellipse, rounded rectangle, triangle, diamond.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxShapeView
Syntax
Delphi
type
 TfrxShapeView = class(TfrxView)
 end;

The TfrxShapeView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxShapeView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Overrides TfrxComponent.DesignCreate(TComponent,Word).)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor.
Curve | Curvature of the round rectangle edges.
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Represents property Fill.
FillType | Represents property FillType.
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
Shape | Kind of shape.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
TagStr | Represents property TagStr.
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Represents property URL.
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxReportComponent.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurve | Represents field FCurve.
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShape | Represents field FShape.
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxClass


TfrxShapeView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxShapeView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Overrides TfrxComponent.DesignCreate(TComponent,Word).)
Top


TfrxShapeView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxShapeView class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxView.Create(TComponent)
See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView.DesignCreate(TComponent,Word) Constructor

Summary

Constructor uses by the report designer when create new report object.

Namespace: frxClass
Syntax
Delphi
public
 constructor DesignCreate(AOwner: TComponent; Flags: Word); override;

Parameters

AOwner
Type: TComponent

Component owner.

Flags
Type: Word

Addition creation parameter depends on component class.

Overrides

TfrxComponent.DesignCreate(TComponent,Word)
See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView Properties

Properties
Name | Description
Color | Represents property Color.
Cursor | Represents property Cursor.
Curve | Curvature of the round rectangle edges.
Fill | Represents property Fill.
FillType | Represents property FillType.
Frame | Represents property Frame.
Shape | Kind of shape.
TagStr | Represents property TagStr.
URL | Represents property URL.
Top


TfrxShapeView.Color Property

Summary

Represents property Color.

Namespace: frxClass
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView.Cursor Property

Summary

Represents property Cursor.

Namespace: frxClass
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView.Curve Property

Summary

Curvature of the round rectangle edges.

Namespace: frxClass
Syntax
Delphi
published
 property Curve: Integer read FCurve write FCurve default 0;

Property Value

Type: Integer

See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView.Fill Property

Summary

Represents property Fill.

Namespace: frxClass
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView.FillType Property

Summary

Represents property FillType.

Namespace: frxClass
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView.Frame Property

Summary

Represents property Frame.

Namespace: frxClass
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView.Shape Property

Summary

Kind of shape.

Namespace: frxClass
Syntax
Delphi
published
 property Shape: TfrxShapeKind read FShape write FShape default skRectangle;

Property Value

Type: TfrxShapeKind

See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView.TagStr Property

Summary

Represents property TagStr.

Namespace: frxClass
Syntax
Delphi
published
 property TagStr;

Property Value

Type: Void

See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView.URL Property

Summary

Represents property URL.

Namespace: frxClass
Syntax
Delphi
published
 property URL;

Property Value

Type: Void

See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView Methods

Methods
Name | Description
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
Top


TfrxShapeView.Diff(TfrxComponent) Method

Summary

Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set.

Namespace: frxClass
Syntax
Delphi
public
 function Diff(AComponent: TfrxComponent): String; override;

Parameters

AComponent
Type: TfrxComponent

Return Value

Type: String

Overrides

TfrxView.Diff(TfrxComponent)
See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView Fields

Fields
Name | Description
FCurve | Represents field FCurve.
FShape | Represents field FShape.
Top


TfrxShapeView.FCurve Field

Summary

Represents field FCurve.

Namespace: frxClass
Syntax
Delphi
private
 FCurve: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShapeView.FShape Field

Summary

Represents field FShape.

Namespace: frxClass
Syntax
Delphi
private
 FShape: TfrxShapeKind;

Field Value

Type: TfrxShapeKind

See Also

Reference

  • TfrxShapeView
  • frxClass


TfrxShowReportCommand Class

Summary

This class implements realization of deferred ShowReport command.

Namespace: frxClass
Inheritance Hierarchy
TPersistent
frxClass.TfrxBaseDelayedCommand
frxClass.TfrxBasePrepareReportCommand
frxClass.TfrxShowReportCommand
Syntax
Delphi
type
 TfrxShowReportCommand = class(TfrxBasePrepareReportCommand)
 end;

The TfrxShowReportCommand type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport,Boolean) | Command constructor. (Inherited from TfrxBasePrepareReportCommand.)
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseDelayedCommand.)
GetInstance | Get command instance. (Inherited from TfrxBaseDelayedCommand.)
GetName | Get symbolic name of current command instance. (Inherited from TfrxBaseDelayedCommand.)
QueryInterface(TGUID,Void) | Represents method QueryInterface(TGUID,Void). (Inherited from TfrxBaseDelayedCommand.)
Run | Runs command. (Overrides TfrxBasePrepareReportCommand.Run.)
_AddRef | Represents method _AddRef. (Inherited from TfrxBaseDelayedCommand.)
_Release | Represents method _Release. (Inherited from TfrxBaseDelayedCommand.)
Top
See Also

Reference

  • frxClass


TfrxShowReportCommand Methods

Methods
Name | Description
Run | Runs command. (Overrides TfrxBasePrepareReportCommand.Run.)
Top


TfrxShowReportCommand.Run Method

Summary

Runs command.

Namespace: frxClass
Syntax
Delphi
public
 procedure Run; override;

Overrides

TfrxBasePrepareReportCommand.Run
See Also

Reference

  • TfrxShowReportCommand
  • frxClass


TfrxStretcheable Class

Summary

The TfrxStretcheable class is the basic one for writing components, which modify their height depending on the data placed in them. Objects of the given class can be not only stretched, but they can also be "broken" into pieces in cases when an object does not find room on the page. At the same time, the object is displayed piecemeal until all its data is displayed.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxBarcode2D.TfrxBarcode2DView
frxClass.TfrxCustomLineView
frxClass.TfrxCustomMemoView
frxRich.TfrxRichView
frxTableObject.TfrxTableObject
Syntax
Delphi
type
 TfrxStretcheable = class(TfrxView)
 end;

The TfrxStretcheable type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxStretcheable class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
CanShrink | True if object can shrink height base on its content.
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Object's cursor (in the preview mode). (Inherited from TfrxView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Object's frame. (Inherited from TfrxView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StretchMode | Object's stretch mode.
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
CalcHeight | Calculates and returns the object's height according to the data placed in it.
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable.
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxReportComponent.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object.
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanShrink | Represents field FCanShrink.
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FSavedTop | Internal use only. Stores original top during shift operation.
FSaveHeight | Internal use only. Stores object Height during stretch operation.
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchMode | Represents field FStretchMode.
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxClass


TfrxStretcheable Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxStretcheable class. (Overrides TfrxView.Create(TComponent).)
Top


TfrxStretcheable.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxStretcheable class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxView.Create(TComponent)
See Also

Reference

  • TfrxStretcheable
  • frxClass


TfrxStretcheable Properties

Properties
Name | Description
CanShrink | True if object can shrink height base on its content.
StretchMode | Object's stretch mode.
Top


TfrxStretcheable.CanShrink Property

Summary

True if object can shrink height base on its content.

Namespace: frxClass
Syntax
Delphi
published
 property CanShrink: Boolean read FCanShrink write FCanShrink default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxStretcheable
  • frxClass


TfrxStretcheable.StretchMode Property

Summary

Object's stretch mode.

Namespace: frxClass
Syntax
Delphi
published
 property StretchMode: TfrxStretchMode read FStretchMode write FStretchMode
 default smDontStretch;

Property Value

Type: TfrxStretchMode

See Also

Reference

  • TfrxStretcheable
  • frxClass


TfrxStretcheable Methods

Methods
Name | Description
CalcHeight | Calculates and returns the object's height according to the data placed in it.
DrawPart | Objects part drawing function , if the object is splittable.
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page.
InitPart | Initialize part of Splittable object.
Top


TfrxStretcheable.CalcHeight Method

Summary

Calculates and returns the object's height according to the data placed in it.

Namespace: frxClass
Syntax
Delphi
public
 function CalcHeight: Extended; virtual;

Return Value

Type: Extended

See Also

Reference

  • TfrxStretcheable
  • frxClass


TfrxStretcheable.DrawPart Method

Summary

Objects part drawing function , if the object is splittable.

Namespace: frxClass
Syntax
Delphi
public
 function DrawPart: Extended; virtual;

Return Value

Type: Extended

See Also

Reference

  • TfrxStretcheable
  • frxClass


TfrxStretcheable.HasNextDataPart(Extended) Method

Summary

Returns True if object has a part to draw on a new page.

Namespace: frxClass
Syntax
Delphi
public
 function HasNextDataPart(aFreeSpace: Extended): Boolean; virtual;

Parameters

aFreeSpace
Type: Extended

Free space on current page.

Return Value

Type: Boolean

See Also

Reference

  • TfrxStretcheable
  • frxClass


TfrxStretcheable.InitPart Method

Summary

Initialize part of Splittable object.

Namespace: frxClass
Syntax
Delphi
public
 procedure InitPart; virtual;
See Also

Reference

  • TfrxStretcheable
  • frxClass


TfrxStretcheable Fields

Fields
Name | Description
FCanShrink | Represents field FCanShrink.
FSavedTop | Internal use only. Stores original top during shift operation.
FSaveHeight | Internal use only. Stores object Height during stretch operation.
FStretchMode | Represents field FStretchMode.
Top


TfrxStretcheable.FCanShrink Field

Summary

Represents field FCanShrink.

Namespace: frxClass
Syntax
Delphi
private
 FCanShrink: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxStretcheable
  • frxClass


TfrxStretcheable.FSavedTop Field

Summary

Internal use only. Stores original top during shift operation.

Namespace: frxClass
Syntax
Delphi
public
 FSavedTop: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxStretcheable
  • frxClass


TfrxStretcheable.FSaveHeight Field

Summary

Internal use only. Stores object Height during stretch operation.

Namespace: frxClass
Syntax
Delphi
public
 FSaveHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxStretcheable
  • frxClass


TfrxStretcheable.FStretchMode Field

Summary

Represents field FStretchMode.

Namespace: frxClass
Syntax
Delphi
private
 FStretchMode: TfrxStretchMode;

Field Value

Type: TfrxStretchMode

See Also

Reference

  • TfrxStretcheable
  • frxClass


TfrxStringClassName Class

Summary

Represents type TfrxStringClassName.

Namespace: frxClass
Syntax
Delphi
type
 TfrxStringClassName = type String;
See Also

Reference

  • frxClass


TfrxStyleItem Class

Summary

The TfrxStyleItem represents a style. Style is an element, which possesses a name and properties, and determines design attributes, i.e. color, font and frame. The style determines the way a report object should be designed. The objects such as TfrxMemoView have the Style property, which is a property intended to set the style name. When applying a value to this property, the style design attributes are copied to the object.

Namespace: frxClass
Inheritance Hierarchy
TCollectionItem
frxCollections.TfrxCollectionItem
frxClass.TfrxStyleItem
Syntax
Delphi
type
 TfrxStyleItem = class(TfrxCollectionItem)
 end;

The TfrxStyleItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxStyleItem class. (Overrides TfrxCollectionItem.Create(TCollection).)
Destroy | Represents the destructor of the TfrxStyleItem class.
Top
Properties
Show:
Name | Description
ApplyFill | Apply fill from the style to an object.
ApplyFont | Apply font from the style to an object.
ApplyFrame | Apply frame from the style to an object.
Color | Deprecated. Background color.
Fill | Reference to Fill object.
FillType | Fill type.
Font | Font settings.
Frame | Frame settings.
InheritedName | Represents property InheritedName. (Inherited from TfrxCollectionItem.)
IsInherited | Represents property IsInherited. (Inherited from TfrxCollectionItem.)
Name | Style name.
UniqueIndex | Represents property UniqueIndex. (Inherited from TfrxCollectionItem.)
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
CreateUniqueIName(TCollection) | Represents method CreateUniqueIName(TCollection). (Inherited from TfrxCollectionItem.)
CreateUniqueName | Creates an unique name of style.
GetColor | Represents method GetColor.
GetFillType | Represents method GetFillType.
GetInheritedName | Represents method GetInheritedName. (Overrides TfrxCollectionItem.GetInheritedName.)
IsUniqueNameStored | Represents method IsUniqueNameStored. (Inherited from TfrxCollectionItem.)
SetColor(TColor) | Represents method SetColor(TColor).
SetFill(TfrxCustomFill) | Represents method SetFill(TfrxCustomFill).
SetFillType(TfrxFillType) | Represents method SetFillType(TfrxFillType).
SetFont(TFont) | Represents method SetFont(TFont).
SetFrame(TfrxFrame) | Represents method SetFrame(TfrxFrame).
SetInheritedName(String) | Represents method SetInheritedName(String). (Inherited from TfrxCollectionItem.)
SetName(String) | Represents method SetName(String).
Top
Fields
Show:
Name | Description
FApplyFill | Represents field FApplyFill.
FApplyFont | Represents field FApplyFont.
FApplyFrame | Represents field FApplyFrame.
FFill | Represents field FFill.
FFont | Represents field FFont.
FFrame | Represents field FFrame.
FIsInherited | Represents field FIsInherited. (Inherited from TfrxCollectionItem.)
FName | Represents field FName.
FUniqueIndex | Represents field FUniqueIndex. (Inherited from TfrxCollectionItem.)
Top
See Also

Reference

  • frxClass


TfrxStyleItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxStyleItem class. (Overrides TfrxCollectionItem.Create(TCollection).)
Destroy | Represents the destructor of the TfrxStyleItem class.
Top


TfrxStyleItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TfrxStyleItem class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(Collection: TCollection); override;

Parameters

Collection
Type: TCollection

Overrides

TfrxCollectionItem.Create(TCollection)
See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.Destroy Destructor

Summary

Represents the destructor of the TfrxStyleItem class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem Properties

Properties
Name | Description
ApplyFill | Apply fill from the style to an object.
ApplyFont | Apply font from the style to an object.
ApplyFrame | Apply frame from the style to an object.
Color | Deprecated. Background color.
Fill | Reference to Fill object.
FillType | Fill type.
Font | Font settings.
Frame | Frame settings.
Name | Style name.
Top


TfrxStyleItem.ApplyFill Property

Summary

Apply fill from the style to an object.

Namespace: frxClass
Syntax
Delphi
published
 property ApplyFill: Boolean read FApplyFill write FApplyFill default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.ApplyFont Property

Summary

Apply font from the style to an object.

Namespace: frxClass
Syntax
Delphi
published
 property ApplyFont: Boolean read FApplyFont write FApplyFont default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.ApplyFrame Property

Summary

Apply frame from the style to an object.

Namespace: frxClass
Syntax
Delphi
published
 property ApplyFrame: Boolean read FApplyFrame write FApplyFrame default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.Color Property

Summary

Deprecated. Background color.

Namespace: frxClass
Syntax
Delphi
published
 property Color: TColor read GetColor write SetColor stored False;

Property Value

Type: TColor

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.Fill Property

Summary

Reference to Fill object.

Namespace: frxClass
Syntax
Delphi
published
 property Fill: TfrxCustomFill read FFill write SetFill;

Property Value

Type: TfrxCustomFill

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.FillType Property

Summary

Fill type.

Namespace: frxClass
Syntax
Delphi
published
 property FillType: TfrxFillType read GetFillType write SetFillType default ftBrush;

Property Value

Type: TfrxFillType

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.Font Property

Summary

Font settings.

Namespace: frxClass
Syntax
Delphi
published
 property Font: TFont read FFont write SetFont;

Property Value

Type: TFont

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.Frame Property

Summary

Frame settings.

Namespace: frxClass
Syntax
Delphi
published
 property Frame: TfrxFrame read FFrame write SetFrame;

Property Value

Type: TfrxFrame

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.Name Property

Summary

Style name.

Namespace: frxClass
Syntax
Delphi
published
 property Name: String read FName write SetName;

Property Value

Type: String

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
CreateUniqueName | Creates an unique name of style.
GetColor | Represents method GetColor.
GetFillType | Represents method GetFillType.
GetInheritedName | Represents method GetInheritedName. (Overrides TfrxCollectionItem.GetInheritedName.)
SetColor(TColor) | Represents method SetColor(TColor).
SetFill(TfrxCustomFill) | Represents method SetFill(TfrxCustomFill).
SetFillType(TfrxFillType) | Represents method SetFillType(TfrxFillType).
SetFont(TFont) | Represents method SetFont(TFont).
SetFrame(TfrxFrame) | Represents method SetFrame(TfrxFrame).
SetName(String) | Represents method SetName(String).
Top


TfrxStyleItem.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxClass
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.CreateUniqueName Method

Summary

Creates an unique name of style.

Namespace: frxClass
Syntax
Delphi
public
 procedure CreateUniqueName;
See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.GetColor Method

Summary

Represents method GetColor.

Namespace: frxClass
Syntax
Delphi
private
 function GetColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.GetFillType Method

Summary

Represents method GetFillType.

Namespace: frxClass
Syntax
Delphi
private
 function GetFillType: TfrxFillType;

Return Value

Type: TfrxFillType

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.GetInheritedName Method

Summary

Represents method GetInheritedName.

Namespace: frxClass
Syntax
Delphi
protected
 function GetInheritedName: String; override;

Return Value

Type: String

Overrides

TfrxCollectionItem.GetInheritedName
See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.SetFill(TfrxCustomFill) Method

Summary

Represents method SetFill(TfrxCustomFill).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFill(const Value: TfrxCustomFill);

Parameters

Value
Type: TfrxCustomFill

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.SetFillType(TfrxFillType) Method

Summary

Represents method SetFillType(TfrxFillType).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFillType(const Value: TfrxFillType);

Parameters

Value
Type: TfrxFillType

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.SetFont(TFont) Method

Summary

Represents method SetFont(TFont).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFont(const Value: TFont);

Parameters

Value
Type: TFont

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.SetFrame(TfrxFrame) Method

Summary

Represents method SetFrame(TfrxFrame).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFrame(const Value: TfrxFrame);

Parameters

Value
Type: TfrxFrame

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.SetName(String) Method

Summary

Represents method SetName(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem Fields

Fields
Name | Description
FApplyFill | Represents field FApplyFill.
FApplyFont | Represents field FApplyFont.
FApplyFrame | Represents field FApplyFrame.
FFill | Represents field FFill.
FFont | Represents field FFont.
FFrame | Represents field FFrame.
FName | Represents field FName.
Top


TfrxStyleItem.FApplyFill Field

Summary

Represents field FApplyFill.

Namespace: frxClass
Syntax
Delphi
private
 FApplyFill: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.FApplyFont Field

Summary

Represents field FApplyFont.

Namespace: frxClass
Syntax
Delphi
private
 FApplyFont: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.FApplyFrame Field

Summary

Represents field FApplyFrame.

Namespace: frxClass
Syntax
Delphi
private
 FApplyFrame: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.FFill Field

Summary

Represents field FFill.

Namespace: frxClass
Syntax
Delphi
private
 FFill: TfrxCustomFill;

Field Value

Type: TfrxCustomFill

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.FFont Field

Summary

Represents field FFont.

Namespace: frxClass
Syntax
Delphi
private
 FFont: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.FFrame Field

Summary

Represents field FFrame.

Namespace: frxClass
Syntax
Delphi
private
 FFrame: TfrxFrame;

Field Value

Type: TfrxFrame

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyleItem.FName Field

Summary

Represents field FName.

Namespace: frxClass
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxStyleItem
  • frxClass


TfrxStyles Class

Summary

The TfrxStyles class represents a set of styles. It comprises methods for performing such set operations as reading, saving, adding, deleting, as well as searching for a style. The set of styles file has FS3 extension by default.

Namespace: frxClass
Inheritance Hierarchy
TCollection
frxCollections.TfrxCollection
frxClass.TfrxStyles
Syntax
Delphi
type
 TfrxStyles = class(TfrxCollection)
 end;

The TfrxStyles type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport) | Creates the styles set. One can specify "nil" instead of "AReport," however in this case a user would be unable to use the "Apply" method.
Top
Properties
Show:
Name | Description
Items[Integer] | List of styles in the set.
Name | A set's name.
Top
Methods
Show:
Name | Description
Add | Adds a new style.
Apply | Applies a set to a report.
DeserializeProperties(String,TObject,TfrxCollection) | Represents method DeserializeProperties(String,TObject,TfrxCollection). (Inherited from TfrxCollection.)
Find(String) | Returns the style with the given name.
FindByName(String) | Represents method FindByName(String). (Inherited from TfrxCollection.)
GetItem(Integer) | Represents method GetItem(Integer).
GetList(TStrings) | Returns the list of the styles names.
LoadFromFile(String) | Reads a set from a file.
LoadFromStream(TStream) | Reads a set from a stream.
LoadFromXMLItem(TfrxXMLItem,Boolean) | Reads a set from a XML item.
SaveToFile(String) | Saves a set to a file.
SaveToStream(TStream) | Saves a set to a stream.
SaveToXMLItem(TfrxXMLItem) | Saves a set to a XML item.
SerializeProperties(TObject,TfrxCollection,TComponent) | Represents method SerializeProperties(TObject,TfrxCollection,TComponent). (Inherited from TfrxCollection.)
Top
Fields
Show:
Name | Description
FName | Represents field FName.
FReport | Represents field FReport.
Top
See Also

Reference

  • frxClass


TfrxStyles Constructors

Constructors
Name | Description
Create(TfrxReport) | Creates the styles set. One can specify "nil" instead of "AReport," however in this case a user would be unable to use the "Apply" method.
Top


TfrxStyles.Create(TfrxReport) Constructor

Summary

Creates the styles set. One can specify "nil" instead of "AReport," however in this case a user would be unable to use the "Apply" method.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AReport: TfrxReport);

Parameters

AReport
Type: TfrxReport

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles Properties

Properties
Name | Description
Items[Integer] | List of styles in the set.
Name | A set's name.
Top


TfrxStyles.Items[Integer] Property

Summary

List of styles in the set.

Namespace: frxClass
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxStyleItem read GetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxStyleItem

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles.Name Property

Summary

A set's name.

Namespace: frxClass
Syntax
Delphi
public
 property Name: String read FName write FName;

Property Value

Type: String

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles Methods

Methods
Name | Description
Add | Adds a new style.
Apply | Applies a set to a report.
Find(String) | Returns the style with the given name.
GetItem(Integer) | Represents method GetItem(Integer).
GetList(TStrings) | Returns the list of the styles names.
LoadFromFile(String) | Reads a set from a file.
LoadFromStream(TStream) | Reads a set from a stream.
LoadFromXMLItem(TfrxXMLItem,Boolean) | Reads a set from a XML item.
SaveToFile(String) | Saves a set to a file.
SaveToStream(TStream) | Saves a set to a stream.
SaveToXMLItem(TfrxXMLItem) | Saves a set to a XML item.
Top


TfrxStyles.Add Method

Summary

Adds a new style.

Namespace: frxClass
Syntax
Delphi
public
 function Add: TfrxStyleItem;

Return Value

Type: TfrxStyleItem

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles.Apply Method

Summary

Applies a set to a report.

Namespace: frxClass
Syntax
Delphi
public
 procedure Apply;
See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles.Find(String) Method

Summary

Returns the style with the given name.

Namespace: frxClass
Syntax
Delphi
public
 function Find(const Name: String): TfrxStyleItem;

Parameters

Name
Type: String

Return Value

Type: TfrxStyleItem

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetItem(Index: Integer): TfrxStyleItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxStyleItem

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles.GetList(TStrings) Method

Summary

Returns the list of the styles names.

Namespace: frxClass
Syntax
Delphi
public
 procedure GetList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles.LoadFromFile(String) Method

Summary

Reads a set from a file.

Namespace: frxClass
Syntax
Delphi
public
 procedure LoadFromFile(const FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles.LoadFromStream(TStream) Method

Summary

Reads a set from a stream.

Namespace: frxClass
Syntax
Delphi
public
 procedure LoadFromStream(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles.LoadFromXMLItem(TfrxXMLItem,Boolean) Method

Summary

Reads a set from a XML item.

Namespace: frxClass
Syntax
Delphi
public
 procedure LoadFromXMLItem(Item: TfrxXMLItem; OldXMLFormat: Boolean = True);

Parameters

Item
Type: TfrxXMLItem

OldXMLFormat
Type: Boolean

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles.SaveToFile(String) Method

Summary

Saves a set to a file.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveToFile(const FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles.SaveToStream(TStream) Method

Summary

Saves a set to a stream.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveToStream(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles.SaveToXMLItem(TfrxXMLItem) Method

Summary

Saves a set to a XML item.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveToXMLItem(Item: TfrxXMLItem);

Parameters

Item
Type: TfrxXMLItem

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles Fields

Fields
Name | Description
FName | Represents field FName.
FReport | Represents field FReport.
Top


TfrxStyles.FName Field

Summary

Represents field FName.

Namespace: frxClass
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyles.FReport Field

Summary

Represents field FReport.

Namespace: frxClass
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxStyles
  • frxClass


TfrxStyleSheet Class

Summary

The TfrxStyleSheet class represents a styles' library. It has methods for the library reading/saving, as well as adding, deleting, and style sets' searching.

Namespace: frxClass
Inheritance Hierarchy
TObject
frxClass.TfrxStyleSheet
Syntax
Delphi
type
 TfrxStyleSheet = class(TObject)
 end;

The TfrxStyleSheet type exposes the following members.

Constructors
Show:
Name | Description
Create | Constructs a library.
Destroy | Represents the destructor of the TfrxStyleSheet class.
Top
Properties
Show:
Name | Description
Items[Integer] | The list of styles' sets.
Top
Methods
Show:
Name | Description
Add | Adds a new set of styles to the library.
Clear | Clears a library.
Count | Returns a number of styles' sets in the library.
Delete(Integer) | Deletes a set with certain number.
Find(String) | Returns a set with the set name.
GetItems(Integer) | Represents method GetItems(Integer).
GetList(TStrings) | Returns the list of the names of styles' sets.
IndexOf(String) | Returns a set number with the given name.
LoadFromFile(String) | Loads a library from a file.
LoadFromStream(TStream) | Loads a library from a stream.
SaveToFile(String) | Saves a library to a file.
SaveToStream(TStream) | Saves a library to a stream.
Top
Fields
Show:
Name | Description
FItems | Represents field FItems.
Top
See Also

Reference

  • frxClass


TfrxStyleSheet Constructors

Constructors
Name | Description
Create | Constructs a library.
Destroy | Represents the destructor of the TfrxStyleSheet class.
Top


TfrxStyleSheet.Create Constructor

Summary

Constructs a library.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet.Destroy Destructor

Summary

Represents the destructor of the TfrxStyleSheet class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet Properties

Properties
Name | Description
Items[Integer] | The list of styles' sets.
Top


TfrxStyleSheet.Items[Integer] Property

Summary

The list of styles' sets.

Namespace: frxClass
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxStyles read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxStyles

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet Methods

Methods
Name | Description
Add | Adds a new set of styles to the library.
Clear | Clears a library.
Count | Returns a number of styles' sets in the library.
Delete(Integer) | Deletes a set with certain number.
Find(String) | Returns a set with the set name.
GetItems(Integer) | Represents method GetItems(Integer).
GetList(TStrings) | Returns the list of the names of styles' sets.
IndexOf(String) | Returns a set number with the given name.
LoadFromFile(String) | Loads a library from a file.
LoadFromStream(TStream) | Loads a library from a stream.
SaveToFile(String) | Saves a library to a file.
SaveToStream(TStream) | Saves a library to a stream.
Top


TfrxStyleSheet.Add Method

Summary

Adds a new set of styles to the library.

Namespace: frxClass
Syntax
Delphi
public
 function Add: TfrxStyles;

Return Value

Type: TfrxStyles

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet.Clear Method

Summary

Clears a library.

Namespace: frxClass
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet.Count Method

Summary

Returns a number of styles' sets in the library.

Namespace: frxClass
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet.Delete(Integer) Method

Summary

Deletes a set with certain number.

Namespace: frxClass
Syntax
Delphi
public
 procedure Delete(Index: Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet.Find(String) Method

Summary

Returns a set with the set name.

Namespace: frxClass
Syntax
Delphi
public
 function Find(const Name: String): TfrxStyles;

Parameters

Name
Type: String

Return Value

Type: TfrxStyles

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxClass
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxStyles;

Parameters

Index
Type: Integer

Return Value

Type: TfrxStyles

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet.GetList(TStrings) Method

Summary

Returns the list of the names of styles' sets.

Namespace: frxClass
Syntax
Delphi
public
 procedure GetList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet.IndexOf(String) Method

Summary

Returns a set number with the given name.

Namespace: frxClass
Syntax
Delphi
public
 function IndexOf(const Name: String): Integer;

Parameters

Name
Type: String

Return Value

Type: Integer

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet.LoadFromFile(String) Method

Summary

Loads a library from a file.

Namespace: frxClass
Syntax
Delphi
public
 procedure LoadFromFile(const FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet.LoadFromStream(TStream) Method

Summary

Loads a library from a stream.

Namespace: frxClass
Syntax
Delphi
public
 procedure LoadFromStream(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet.SaveToFile(String) Method

Summary

Saves a library to a file.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveToFile(const FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet.SaveToStream(TStream) Method

Summary

Saves a library to a stream.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveToStream(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxStyleSheet Fields

Fields
Name | Description
FItems | Represents field FItems.
Top


TfrxStyleSheet.FItems Field

Summary

Represents field FItems.

Namespace: frxClass
Syntax
Delphi
private
 FItems: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxStyleSheet
  • frxClass


TfrxSubdetailData Class

Summary

The TfrxSubDetailData represents a "Subdetail data" band.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxBand
frxClass.TfrxDataBand
frxClass.TfrxSubdetailData
Syntax
Delphi
type
 TfrxSubdetailData = class(TfrxDataBand)
 end;

The TfrxSubdetailData type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataBand class. (Overrides TfrxBand.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxBand.)
AllowSplit | Represents property AllowSplit. (Inherited from TfrxDataBand.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BandDesignHeader | Returns band header height if band caption enabled in the report designer. (Inherited from TfrxBand.)
BandName | Returns name of the band based on its ClassName (It's not similar to Name property). (Inherited from TfrxBand.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Child | Represents property Child. (Inherited from TfrxDataBand.)
ColumnGap | Gap between band's columns, in pixels. (Inherited from TfrxDataBand.)
Columns | The "Columns" property, available in all data-bands, allows to set number of columns for a particular band and not for the whole page. Thus, displaying of data will be not "from the top to the bottom, then from the left to the right," but "from left to right, then from top to bottom". You also should set ColumnWidth and ColumnGap properties. (Inherited from TfrxDataBand.)
ColumnWidth | Width of the band's column, in pixels. (Inherited from TfrxDataBand.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
CurColumn | Current column of the band. (Inherited from TfrxDataBand.)
DataSet | Dataset for a band. (Inherited from TfrxDataBand.)
DataSetName | Dataset name for a band. This property duplicates the DataSet property. (Inherited from TfrxDataBand.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Fill | Reference to a band fill object. (Inherited from TfrxBand.)
FillGap | Reference to an object winch stores fill gaps settings. (Inherited from TfrxBand.)
FillType | Band fill type. (Inherited from TfrxBand.)
Filter | An expression used to manage visibility of a band record. if result of this expression is True, band will be shown. (Inherited from TfrxDataBand.)
Font | Represents property Font. (Inherited from TfrxBand.)
FooterAfterEach | Determines whether to show band footer after each record. Default value is False. By default the footer is displayed after printing all dataset records. (Inherited from TfrxDataBand.)
Frame | Reference to band Frame. (Inherited from TfrxBand.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height. (Inherited from TfrxBand.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepChild | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False. (Inherited from TfrxDataBand.)
KeepFooter | Determines whether to show band footer on the same page as the band itself. If footer does not find room on the page, it will be carried to the next page along with last record of its parent band. Default value is False. (Inherited from TfrxDataBand.)
KeepHeader | Determines whether to show band header on the same page as the banditself. If header does not find room on the page, it will be carriedto the next page. Default value is False. (Inherited from TfrxDataBand.)
KeepTogether | Determines whether to print the band together with all its subbands on the same page. Default value is False. (Inherited from TfrxDataBand.)
Left | Represents property Left. (Inherited from TfrxBand.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterCalcHeight | Name of the script procedure that will be called after calculating the band's height. (Inherited from TfrxBand.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxBand.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxBand.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnMasterDetail | Name of the script procedure that will be called before the band will check if any subbands are empty. (Inherited from TfrxDataBand.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OutlineText | Represents property OutlineText. (Inherited from TfrxDataBand.)
Overflow | Returns True if band was reprinted on a new page (only for "Group header" or "Header" bands with ReprintOnNewPage property set to True). (Inherited from TfrxBand.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxBand.)
PrintChildIfInvisible | Represents property PrintChildIfInvisible. (Inherited from TfrxDataBand.)
PrintIfDetailEmpty | Determines whether to print the band if all its subbands are empty. Default value is False. (Inherited from TfrxDataBand.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxBand.)
RowCount | Allows printing the band N times. This property is used if the band is NOT connected to the dataset. (Inherited from TfrxDataBand.)
ShiftEngine | Represents property ShiftEngine. (Inherited from TfrxDataBand.)
StartNewPage | Represents property StartNewPage. (Inherited from TfrxDataBand.)
Stretched | Represents property Stretched. (Inherited from TfrxDataBand.)
Top | Represents property Top. (Inherited from TfrxBand.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Vertical | Determines if the band is a vertical band. (Inherited from TfrxBand.)
VirtualDataSet | Represents property VirtualDataSet. (Inherited from TfrxDataBand.)
Visible | Represents property Visible. (Inherited from TfrxBand.)
Width | Represents property Width. (Inherited from TfrxBand.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BandNumber | Returns band index from frxBands array. (Inherited from TfrxBand.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateFillMemo | Creates background object which represent band fill and frame. (Inherited from TfrxBand.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisposeFillMemo | Frees background object which represent band fill and frame. (Inherited from TfrxBand.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxBand.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBandTitleColor | Represents method GetBandTitleColor. (Overrides TfrxBand.GetBandTitleColor.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxBand.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxBand.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFooter | Represents field FFooter. (Inherited from TfrxBand.)
FGroup | Represents field FGroup. (Inherited from TfrxBand.)
FHasVBands | Whether the band should show vertical bands. (Inherited from TfrxBand.)
FHeader | Represents field FHeader. (Inherited from TfrxBand.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLineN | Used for <Line>. (Inherited from TfrxBand.)
FLineThrough | Used for <Line#>. (Inherited from TfrxBand.)
FMaxY | Represents field FMaxY. (Inherited from TfrxDataBand.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStretchedHeight | Height of the band after stretch. (Inherited from TfrxBand.)
FSubBands | List of sub bands. (Inherited from TfrxBand.)
Top
See Also

Reference

  • frxClass


TfrxSubreport Class

Summary

The TfrxSubreport class represents the "Subreport" object. Object is linked to a report page that stores the objects of subreport. When running a report, as soon as the "Subreport" object is encountered, the report, allocated to the subreport design page, will be displayed. After that, basic report creation will continue.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxSubreport
Syntax
Delphi
type
 TfrxSubreport = class(TfrxView)
 end;

The TfrxSubreport type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxSubreport class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxSubreport class. (Overrides TfrxView.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Object's cursor (in the preview mode). (Inherited from TfrxView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Object's frame. (Inherited from TfrxView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Reference to a report page that stores the objects of subreport.
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
PrintOnParent | Determines whether the subreport contents should be printed on a parent band (which contains the "subreport" object). Default value is False. In this case the subreport's objects are printed as a separate bands and do not affect the parent band.
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxReportComponent.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetPage(TfrxReportPage) | Represents method SetPage(TfrxReportPage).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FPage | Represents field FPage.
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintOnParent | Represents field FPrintOnParent.
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxClass


TfrxSubreport Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxSubreport class. (Overrides TfrxView.Create(TComponent).)
Destroy | Represents the destructor of the TfrxSubreport class. (Overrides TfrxView.Destroy.)
Top


TfrxSubreport.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxSubreport class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxView.Create(TComponent)
See Also

Reference

  • TfrxSubreport
  • frxClass


TfrxSubreport.Destroy Destructor

Summary

Represents the destructor of the TfrxSubreport class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxView.Destroy
See Also

Reference

  • TfrxSubreport
  • frxClass


TfrxSubreport Properties

Properties
Name | Description
Page | Reference to a report page that stores the objects of subreport.
PrintOnParent | Determines whether the subreport contents should be printed on a parent band (which contains the "subreport" object). Default value is False. In this case the subreport's objects are printed as a separate bands and do not affect the parent band.
Top


TfrxSubreport.Page Property

Summary

Reference to a report page that stores the objects of subreport.

Namespace: frxClass
Syntax
Delphi
published
 property Page: TfrxReportPage read FPage write SetPage;

Property Value

Type: TfrxReportPage

See Also

Reference

  • TfrxSubreport
  • frxClass


TfrxSubreport.PrintOnParent Property

Summary

Determines whether the subreport contents should be printed on a parent band (which contains the "subreport" object). Default value is False. In this case the subreport's objects are printed as a
separate bands and do not affect the parent band.

Namespace: frxClass
Syntax
Delphi
published
 property PrintOnParent: Boolean read FPrintOnParent write FPrintOnParent
 default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSubreport
  • frxClass


TfrxSubreport Methods

Methods
Name | Description
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
SetPage(TfrxReportPage) | Represents method SetPage(TfrxReportPage).
Top


TfrxSubreport.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxSubreport
  • frxClass


TfrxSubreport.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxSubreport
  • frxClass


TfrxSubreport.SetPage(TfrxReportPage) Method

Summary

Represents method SetPage(TfrxReportPage).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetPage(const Value: TfrxReportPage);

Parameters

Value
Type: TfrxReportPage

See Also

Reference

  • TfrxSubreport
  • frxClass


TfrxSubreport Fields

Fields
Name | Description
FPage | Represents field FPage.
FPrintOnParent | Represents field FPrintOnParent.
Top


TfrxSubreport.FPage Field

Summary

Represents field FPage.

Namespace: frxClass
Syntax
Delphi
private
 FPage: TfrxReportPage;

Field Value

Type: TfrxReportPage

See Also

Reference

  • TfrxSubreport
  • frxClass


TfrxSubreport.FPrintOnParent Field

Summary

Represents field FPrintOnParent.

Namespace: frxClass
Syntax
Delphi
private
 FPrintOnParent: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSubreport
  • frxClass


TfrxSysMemoView Class

Summary

The TfrxSysMemoView represents the "System text" object. This object can show system variables, aggregate values or text line.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxClass.TfrxCustomMemoView
frxClass.TfrxSysMemoView
Syntax
Delphi
type
 TfrxSysMemoView = class(TfrxCustomMemoView)
 end;

The TfrxSysMemoView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomMemoView class. (Overrides TfrxStretcheable.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowExpressions | Determines if the object may contain expressions inside the text. Expressions are enclosed in the square brackets (by default). The ExpressionDelimiters defines which symbols to use for detecting the expression. Default value is True. (Inherited from TfrxCustomMemoView.)
AllowHTMLTags | Determines if the object may contain HTML-tags inside the text. The following tags are supported: <b> - bold; <i> - italic; <u> - underline; <sub> - bottom index; <sup> - top index; <font color> - font color. Default value is False. (Inherited from TfrxCustomMemoView.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
AnsiText | Text of the object in ANSI format based on current Locale settings. (Inherited from TfrxCustomMemoView.)
AutoWidth | Represents property AutoWidth.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
CanShrink | True if object can shrink height base on its content. (Inherited from TfrxStretcheable.)
CharSpacing | Represents property CharSpacing.
Clipped | Determines whether to clip the text on object's bounds. (Inherited from TfrxCustomMemoView.)
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor. (Inherited from TfrxCustomMemoView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DisplayFormat | Represents property DisplayFormat.
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Duplicates | Represents property Duplicates.
ExpressionDelimiters | Set of symbols, designating the expression. Default value is '[,]'. The comma divides opening and closing symbols. There is one limitation however: the opening and closing symbols cannot be similar, so '%,%' will not work. One can set several symbols, for example '<%,%>'. (Inherited from TfrxCustomMemoView.)
Fill | Represents property Fill.
FillType | Represents property FillType.
FirstParaBreak | Internal use. Determines first paragraph break if object where split. (Inherited from TfrxCustomMemoView.)
FlowTo | Link to the "Text" object that will be used for displaying the textthat not fit in this object. The linked object should have the samefont settings as the main object. You also should place the linkedobject after the main object. (Inherited from TfrxCustomMemoView.)
Font | Represents property Font.
Formats | Collection of Formats. The object can hold several formats for each expression inside an object. (Inherited from TfrxCustomMemoView.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GapX | Represents property GapX.
GapY | Represents property GapY.
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
HAlign | Represents property HAlign.
Height | Represents property Height. (Inherited from TfrxView.)
HideZeros | Represents property HideZeros.
Highlight | Represents property Highlight.
Highlights | Collection of Highlights. The object can hold several highlights which serves different conditions. (Inherited from TfrxCustomMemoView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LastParaBreak | Internal use. Determines last paragraph break if object where split. (Inherited from TfrxCustomMemoView.)
Left | Represents property Left. (Inherited from TfrxView.)
Lines | Text lines of the object. (Inherited from TfrxCustomMemoView.)
LineSpacing | Spacing between text lines, in pixels. Default value is 2. (Inherited from TfrxCustomMemoView.)
Memo | Represents property Memo.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
ParagraphGap | Paragraph gap, in pixels. Default value is 0. (Inherited from TfrxCustomMemoView.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont.
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Represents property Processing.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
Rotation | Represents property Rotation.
RTLReading | Represents property RTLReading.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StretchMode | Object's stretch mode. (Inherited from TfrxStretcheable.)
Style | Represents property Style.
SuppressRepeated | Represents property SuppressRepeated.
TagStr | Represents property TagStr. (Inherited from TfrxCustomMemoView.)
Text | Text of the object. (Inherited from TfrxCustomMemoView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Underlines | Deprecated(See UnderlinesTextMode property). Determines whether to show underlines under each text string. Default value is False. (Inherited from TfrxCustomMemoView.)
UnderlinesTextMode | Determines how to show underlines in text object. Default value is ulmNone. (Inherited from TfrxCustomMemoView.)
URL | Represents property URL. (Inherited from TfrxCustomMemoView.)
UseDefaultCharset | Use Unicode during export even if Font Charset is selected. (Inherited from TfrxCustomMemoView.)
VAlign | Represents property VAlign.
Value | Stores value of Format operation(for single expression or DataSet only) with respect of its type. (Inherited from TfrxCustomMemoView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
WordBreak | Determines whether to break russian words. Default value is False. (Inherited from TfrxCustomMemoView.)
WordWrap | Represents property WordWrap.
Wysiwyg | Determines whether to use printer canvas to arrange the text more accurately. If set to False, you cannot use the "width align" mode. (Inherited from TfrxCustomMemoView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxView.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
ApplyHighlight(TfrxHighlight) | Apply Highlight to object. (Inherited from TfrxCustomMemoView.)
ApplyPreviewHighlight | Apply active highlight for object in prepared report. (Inherited from TfrxCustomMemoView.)
ApplyStyle(TfrxStyleItem) | Applies the given style to the object. (Inherited from TfrxCustomMemoView.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Overrides TfrxView.BeginDraw(TCanvas,Extended,Extended,Extended,Extended).)
CalcAndFormat(WideString,TfrxFormat) | Represents method CalcAndFormat(WideString,TfrxFormat). (Inherited from TfrxCustomMemoView.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxStretcheable.CalcHeight.)
CalcTextRect(Extended,Extended,Extended,Extended) | Represents method CalcTextRect(Extended,Extended,Extended,Extended). (Inherited from TfrxCustomMemoView.)
CalcWidth | Calculates and returns the object's width, in pixels. (Inherited from TfrxCustomMemoView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxCustomMemoView.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxStretcheable.DrawPart.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawText | Represents method DrawText. (Inherited from TfrxCustomMemoView.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
ExtractMacros(TfrxPostProcessor) | Extract macros from the object text and replaces them with values. (Inherited from TfrxCustomMemoView.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
FormatData(Variant,TfrxFormat) | Formats the value passed in the "Value" parameter and returns the result as a string. This method is used format settings stored in the DisplayFormat property. If AFormat parameter is set, it is used for formatting instead of DisplayFormat property. (Inherited from TfrxCustomMemoView.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Overrides TfrxReportComponent.GetComponentText.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxCustomMemoView.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Inherited from TfrxStretcheable.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object. (Overrides TfrxStretcheable.InitPart.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Overrides TfrxView.IsPostProcessAllowed.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
Loaded | Represents method Loaded. (Inherited from TfrxCustomMemoView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxView.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.ReadNestedProperty(TfrxXMLItem).)
ReducedAngle | Normalize angle to 360 degrees. (Inherited from TfrxCustomMemoView.)
ResetSuppress | Deprecated. Reset suppressed values. (Inherited from TfrxCustomMemoView.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetDrawParams(TCanvas,Extended,Extended,Extended,Extended) | Represents method SetDrawParams(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxCustomMemoView.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WrapText(Boolean,TWideStrings) | Breaks the text so all strings would fit in the object's width, and returns the resulting text. (Inherited from TfrxCustomMemoView.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.WriteNestedProperties(TfrxXMLItem,TPersistent).)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCopyNo | Represents field FCopyNo. (Inherited from TfrxCustomMemoView.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLastValue | Represents field FLastValue. (Inherited from TfrxCustomMemoView.)
FMacroIndex | Represents field FMacroIndex. (Inherited from TfrxCustomMemoView.)
FMacroLine | Represents field FMacroLine. (Inherited from TfrxCustomMemoView.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintScale | Represents field FPrintScale. (Inherited from TfrxCustomMemoView.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FSavedTop | Internal use only. Stores original top during shift operation. (Inherited from TfrxStretcheable.)
FSaveHeight | Internal use only. Stores object Height during stretch operation. (Inherited from TfrxStretcheable.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FTextRect | Represents field FTextRect. (Inherited from TfrxCustomMemoView.)
FTotalPages | Represents field FTotalPages. (Inherited from TfrxCustomMemoView.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxClass


TfrxSysMemoView Properties

Properties
Name | Description
AutoWidth | Represents property AutoWidth.
CharSpacing | Represents property CharSpacing.
Color | Represents property Color.
DisplayFormat | Represents property DisplayFormat.
Duplicates | Represents property Duplicates.
Fill | Represents property Fill.
FillType | Represents property FillType.
Font | Represents property Font.
Frame | Represents property Frame.
GapX | Represents property GapX.
GapY | Represents property GapY.
HAlign | Represents property HAlign.
HideZeros | Represents property HideZeros.
Highlight | Represents property Highlight.
Memo | Represents property Memo.
ParentFont | Represents property ParentFont.
Processing | Represents property Processing.
Rotation | Represents property Rotation.
RTLReading | Represents property RTLReading.
Style | Represents property Style.
SuppressRepeated | Represents property SuppressRepeated.
VAlign | Represents property VAlign.
WordWrap | Represents property WordWrap.
Top


TfrxSysMemoView.AutoWidth Property

Summary

Represents property AutoWidth.

Namespace: frxClass
Syntax
Delphi
published
 property AutoWidth;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.CharSpacing Property

Summary

Represents property CharSpacing.

Namespace: frxClass
Syntax
Delphi
published
 property CharSpacing;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.Color Property

Summary

Represents property Color.

Namespace: frxClass
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.DisplayFormat Property

Summary

Represents property DisplayFormat.

Namespace: frxClass
Syntax
Delphi
published
 property DisplayFormat;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.Duplicates Property

Summary

Represents property Duplicates.

Namespace: frxClass
Syntax
Delphi
published
 property Duplicates;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.Fill Property

Summary

Represents property Fill.

Namespace: frxClass
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.FillType Property

Summary

Represents property FillType.

Namespace: frxClass
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.Font Property

Summary

Represents property Font.

Namespace: frxClass
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.Frame Property

Summary

Represents property Frame.

Namespace: frxClass
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.GapX Property

Summary

Represents property GapX.

Namespace: frxClass
Syntax
Delphi
published
 property GapX;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.GapY Property

Summary

Represents property GapY.

Namespace: frxClass
Syntax
Delphi
published
 property GapY;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.HAlign Property

Summary

Represents property HAlign.

Namespace: frxClass
Syntax
Delphi
published
 property HAlign;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.HideZeros Property

Summary

Represents property HideZeros.

Namespace: frxClass
Syntax
Delphi
published
 property HideZeros;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.Highlight Property

Summary

Represents property Highlight.

Namespace: frxClass
Syntax
Delphi
published
 property Highlight;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.Memo Property

Summary

Represents property Memo.

Namespace: frxClass
Syntax
Delphi
published
 property Memo;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.ParentFont Property

Summary

Represents property ParentFont.

Namespace: frxClass
Syntax
Delphi
published
 property ParentFont;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.Processing Property

Summary

Represents property Processing.

Namespace: frxClass
Syntax
Delphi
published
 property Processing;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.Rotation Property

Summary

Represents property Rotation.

Namespace: frxClass
Syntax
Delphi
published
 property Rotation;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.RTLReading Property

Summary

Represents property RTLReading.

Namespace: frxClass
Syntax
Delphi
published
 property RTLReading;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.Style Property

Summary

Represents property Style.

Namespace: frxClass
Syntax
Delphi
published
 property Style;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.SuppressRepeated Property

Summary

Represents property SuppressRepeated.

Namespace: frxClass
Syntax
Delphi
published
 property SuppressRepeated;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.VAlign Property

Summary

Represents property VAlign.

Namespace: frxClass
Syntax
Delphi
published
 property VAlign;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView.WordWrap Property

Summary

Represents property WordWrap.

Namespace: frxClass
Syntax
Delphi
published
 property WordWrap;

Property Value

Type: Void

See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxSysMemoView Methods

Methods
Name | Description
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxCustomMemoView.GetDescription.)
Top


TfrxSysMemoView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxCustomMemoView.GetDescription
See Also

Reference

  • TfrxSysMemoView
  • frxClass


TfrxUserDataSet Class

Summary

The TfrxUserDataSet component allows constructing reports, which are not connected to DB data, but do receive data from other sources (for example, array, file, etc.). A programmer should only provide navigation in such source (define OnFirst, OnNext, OnPrior, OnCheckEOF events). Data receiving is performed not via this component, but using other ways (for example, via the "TfrxReport.OnGetValue" event). In most cases you can only set the navigation range by setting RangeBegin, RangeEnd, RangeEndCount properties. The current position can be obtained via RecNo property.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogComponent
frxClass.TfrxDataSet
frxClass.TfrxUserDataSet
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxUserDataSet = class(TfrxDataset)
 end;

The TfrxUserDataSet type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxUserDataSet class. (Overrides TfrxDataSet.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxUserDataSet class. (Overrides TfrxDataSet.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
CloseDataSource | Close a data set after report construction is completed. (Inherited from TfrxDataSet.)
Component | Link to the component itself. (Inherited from TfrxDialogComponent.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DisplayText[String] | Returns the field value as a string. (Inherited from TfrxDataSet.)
DisplayWidth[String] | Returns the size of a specified field. (Inherited from TfrxDataSet.)
Enabled | Defines, if the given component is available from the designer. (Inherited from TfrxDataSet.)
Fields | List of the fields. These names used in the report designer "Data tree".
FieldType[String] | Returns the field type (Inherited from TfrxDataSet.)
Font | Object's font. (Inherited from TfrxComponent.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClose | An event occurs when closing a data set. (Inherited from TfrxDataSet.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnFirst | This event's handler must move the cursor to the beginning of the data set. (Inherited from TfrxDataSet.)
OnNext | This event's handler must move the cursor to the next record. (Inherited from TfrxDataSet.)
OnOpen | An event occurs when opening a data set. (Inherited from TfrxDataSet.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPrior | This event's handler must move the cursor to the previous record. (Inherited from TfrxDataSet.)
OpenDataSource | Open a data set before report construction is started. (Inherited from TfrxDataSet.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
RangeBegin | The navigation start point. (Inherited from TfrxDataSet.)
RangeEnd | The endpoint of navigation. (Inherited from TfrxDataSet.)
RangeEndCount | A number of records in the data set, if the "RangeEnd" property = reCount. (Inherited from TfrxDataSet.)
RecNo | A current record number. The first record's number is "0". (Inherited from TfrxDataSet.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
ReportRef | Reference for the report owner if any. (Inherited from TfrxDataSet.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
UserName | A symbolic name, under which the dataset will be displayed in the designer. (Inherited from TfrxDataSet.)
Value[String] | Returns the field value as a variant. (Inherited from TfrxDataSet.)
Visible | Global visibility of the object in the result report. (Inherited from TfrxComponent.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
AssignBlobTo(String,TObject) | Assigns stream in Obj to BLOB field with fName name. (Overrides TfrxDataSet.AssignBlobTo(String,TObject).)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Close | Closes the dataset. (Inherited from TfrxDataSet.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxDialogComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
Eof | Function returns True if end of the dataset is reached. (Inherited from TfrxDataSet.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FieldsCount | Returns the number of fields defined in the dataset. (Overrides TfrxDataSet.FieldsCount.)
Finalize | Finalizes DataSet after close. (Inherited from TfrxDataSet.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
First | Sets the cursor to the first record. (Inherited from TfrxDataSet.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDisplayText(String) | Represents method GetDisplayText(String). (Overrides TfrxDataSet.GetDisplayText(String).)
GetDisplayWidth(String) | Represents method GetDisplayWidth(String). (Inherited from TfrxDataSet.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetFieldList(TStrings) | Returns list of dataset fields. (Overrides TfrxDataSet.GetFieldList(TStrings).)
GetFieldType(String) | Represents method GetFieldType(String). (Inherited from TfrxDataSet.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetValue(String) | Represents method GetValue(String). (Overrides TfrxDataSet.GetValue(String).)
HasField(String) | Returns True if dataset has field with specified name. (Inherited from TfrxDataSet.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
Initialize | Initializes DataSet before open. (Inherited from TfrxDataSet.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsBlobField(String) | Returns True if dataset has BLOB field with specified name. (Overrides TfrxDataSet.IsBlobField(String).)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHasMaster | Returns True if DataSet has master RecordSet. (Inherited from TfrxDataSet.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWideMemoBlobField(String) | Returns True if dataset has wide memo BLOB field with specified name. (Inherited from TfrxDataSet.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Next | Moves the cursor to the next record. (Inherited from TfrxDataSet.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
Open | Opens the dataset. (Inherited from TfrxDataSet.)
Prior | Moves the cursor to the previous record. This method is used only when printing groups. (Inherited from TfrxDataSet.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
RecordCount | Returns records count if DataSet supports it. (Inherited from TfrxDataSet.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFields(TStrings) | Represents method SetFields(TStrings).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetUserName(String) | Represents method SetUserName(String). (Inherited from TfrxDataSet.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Events
Show:
Name | Description
OnCheckEOF | This event's handler must return the Eof = True parameter, if the end of the data set is reached. (Inherited from TfrxDataSet.)
OnGetBlobValue | This event is fired when an unknown variable (VarName) is met and IsBlobField event returns True(BLOB type). AssignTo parameter contains an object in which data should be loaded (TWideStrings for "Text"object).
OnGetValue | This event is fired when an unknown variable (VarName) is met. An eventhandler must return the value of this variable in the Value parameter.
OnIsBlobField | An event fires when engine checks type of an assigned field. The result tells report engine how to interpret the field with name 'FileldName'.Returns True if it's a BLOB field. In this case OnGetBlobValue event will fire.
OnNewGetValue | This event is fired when an unknown variable (VarName) is met. An event handler must return the value of this variable in the Value parameter.New event has a Sender parameter and pass a report objects which calls an event.
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFields | Represents field FFields.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FImageIndex | Represents field FImageIndex. (Inherited from TfrxDialogComponent.)
FInitialized | Represents field FInitialized. (Inherited from TfrxDataSet.)
FOnGetBlobValue | Represents field FOnGetBlobValue.
FOnGetValue | Represents field FOnGetValue.
FOnIsBlobField | Represents field FOnIsBlobField.
FOnNewGetValue | Represents field FOnNewGetValue.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FRecNo | Represents field FRecNo. (Inherited from TfrxDataSet.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxClass


TfrxUserDataSet Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxUserDataSet class. (Overrides TfrxDataSet.Create(TComponent).)
Destroy | Represents the destructor of the TfrxUserDataSet class. (Overrides TfrxDataSet.Destroy.)
Top


TfrxUserDataSet.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxUserDataSet class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDataSet.Create(TComponent)
See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.Destroy Destructor

Summary

Represents the destructor of the TfrxUserDataSet class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxDataSet.Destroy
See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet Properties

Properties
Name | Description
Fields | List of the fields. These names used in the report designer "Data tree".
Top


TfrxUserDataSet.Fields Property

Summary

List of the fields. These names used in the report designer "Data tree".

Namespace: frxClass
Syntax
Delphi
published
 property Fields: TStrings read FFields write SetFields;

Property Value

Type: TStrings

See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet Methods

Methods
Name | Description
AssignBlobTo(String,TObject) | Assigns stream in Obj to BLOB field with fName name. (Overrides TfrxDataSet.AssignBlobTo(String,TObject).)
FieldsCount | Returns the number of fields defined in the dataset. (Overrides TfrxDataSet.FieldsCount.)
GetDisplayText(String) | Represents method GetDisplayText(String). (Overrides TfrxDataSet.GetDisplayText(String).)
GetFieldList(TStrings) | Returns list of dataset fields. (Overrides TfrxDataSet.GetFieldList(TStrings).)
GetValue(String) | Represents method GetValue(String). (Overrides TfrxDataSet.GetValue(String).)
IsBlobField(String) | Returns True if dataset has BLOB field with specified name. (Overrides TfrxDataSet.IsBlobField(String).)
SetFields(TStrings) | Represents method SetFields(TStrings).
Top


TfrxUserDataSet.AssignBlobTo(String,TObject) Method

Summary

Assigns stream in Obj to BLOB field with fName name.

Namespace: frxClass
Syntax
Delphi
public
 procedure AssignBlobTo(const FieldName: String; Obj: TObject); override;

Parameters

FieldName
Type: String

Obj
Type: TObject

Object serialized to blob (supports TStream successors).

fName

Name of the BLOB field.

Overrides

TfrxDataSet.AssignBlobTo(String,TObject)
See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.FieldsCount Method

Summary

Returns the number of fields defined in the dataset.

Namespace: frxClass
Syntax
Delphi
public
 function FieldsCount: Integer; override;

Return Value

Type: Integer

Overrides

TfrxDataSet.FieldsCount
See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.GetDisplayText(String) Method

Summary

Represents method GetDisplayText(String).

Namespace: frxClass
Syntax
Delphi
protected
 function GetDisplayText(Index: String): WideString; override;

Parameters

Index
Type: String

Return Value

Type: WideString

Overrides

TfrxDataSet.GetDisplayText(String)
See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.GetFieldList(TStrings) Method

Summary

Returns list of dataset fields.

Namespace: frxClass
Syntax
Delphi
public
 procedure GetFieldList(List: TStrings); override;

Parameters

List
Type: TStrings

Overrides

TfrxDataSet.GetFieldList(TStrings)
See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.GetValue(String) Method

Summary

Represents method GetValue(String).

Namespace: frxClass
Syntax
Delphi
protected
 function GetValue(Index: String): Variant; override;

Parameters

Index
Type: String

Return Value

Type: Variant

Overrides

TfrxDataSet.GetValue(String)
See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.IsBlobField(String) Method

Summary

Returns True if dataset has BLOB field with specified name.

Namespace: frxClass
Syntax
Delphi
public
 function IsBlobField(const FieldName: String): Boolean; override;

Parameters

FieldName
Type: String

Return Value

Type: Boolean

Overrides

TfrxDataSet.IsBlobField(String)
See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.SetFields(TStrings) Method

Summary

Represents method SetFields(TStrings).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFields(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet Events

Events
Name | Description
OnGetBlobValue | This event is fired when an unknown variable (VarName) is met and IsBlobField event returns True(BLOB type). AssignTo parameter contains an object in which data should be loaded (TWideStrings for "Text"object).
OnGetValue | This event is fired when an unknown variable (VarName) is met. An eventhandler must return the value of this variable in the Value parameter.
OnIsBlobField | An event fires when engine checks type of an assigned field. The result tells report engine how to interpret the field with name 'FileldName'.Returns True if it's a BLOB field. In this case OnGetBlobValue event will fire.
OnNewGetValue | This event is fired when an unknown variable (VarName) is met. An event handler must return the value of this variable in the Value parameter.New event has a Sender parameter and pass a report objects which calls an event.
Top


TfrxUserDataSet.OnGetBlobValue Event

Summary

This event is fired when an unknown variable (VarName) is met and IsBlobField event returns True(BLOB type). AssignTo parameter contains an object in which data should be loaded (TWideStrings for "Text"object).

Namespace: frxClass
Syntax
Delphi
published
 property OnGetBlobValue: TfrxGetBlobValueEvent read FOnGetBlobValue write FOnGetBlobValue;

Value

Type: TfrxGetBlobValueEvent

See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.OnGetValue Event

Summary

This event is fired when an unknown variable (VarName) is met. An eventhandler must return the value of this variable in the Value parameter.

Namespace: frxClass
Syntax
Delphi
published
 property OnGetValue: TfrxGetValueEvent read FOnGetValue write FOnGetValue;

Value

Type: TfrxGetValueEvent

See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.OnIsBlobField Event

Summary

An event fires when engine checks type of an assigned field. The result tells report engine how to interpret the field with name 'FileldName'.Returns True if it's a BLOB field. In this case OnGetBlobValue event will fire.

Namespace: frxClass
Syntax
Delphi
published
 property OnIsBlobField: TfrxIsBlobFieldEvent read FOnIsBlobField write FOnIsBlobField;

Value

Type: TfrxIsBlobFieldEvent

See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.OnNewGetValue Event

Summary

This event is fired when an unknown variable (VarName) is met. An event handler must return the value of this variable in the Value parameter.New event has a Sender parameter and pass a report objects which calls an event.

Namespace: frxClass
Syntax
Delphi
published
 property OnNewGetValue: TfrxNewGetValueEvent read FOnNewGetValue write FOnNewGetValue;

Value

Type: TfrxNewGetValueEvent

See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet Fields

Fields
Name | Description
FFields | Represents field FFields.
FOnGetBlobValue | Represents field FOnGetBlobValue.
FOnGetValue | Represents field FOnGetValue.
FOnIsBlobField | Represents field FOnIsBlobField.
FOnNewGetValue | Represents field FOnNewGetValue.
Top


TfrxUserDataSet.FFields Field

Summary

Represents field FFields.

Namespace: frxClass
Syntax
Delphi
private
 FFields: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.FOnGetBlobValue Field

Summary

Represents field FOnGetBlobValue.

Namespace: frxClass
Syntax
Delphi
private
 FOnGetBlobValue: TfrxGetBlobValueEvent;

Field Value

Type: TfrxGetBlobValueEvent

See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.FOnGetValue Field

Summary

Represents field FOnGetValue.

Namespace: frxClass
Syntax
Delphi
private
 FOnGetValue: TfrxGetValueEvent;

Field Value

Type: TfrxGetValueEvent

See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.FOnIsBlobField Field

Summary

Represents field FOnIsBlobField.

Namespace: frxClass
Syntax
Delphi
private
 FOnIsBlobField : TfrxIsBlobFieldEvent;

Field Value

Type: TfrxIsBlobFieldEvent

See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxUserDataSet.FOnNewGetValue Field

Summary

Represents field FOnNewGetValue.

Namespace: frxClass
Syntax
Delphi
private
 FOnNewGetValue: TfrxNewGetValueEvent;

Field Value

Type: TfrxNewGetValueEvent

See Also

Reference

  • TfrxUserDataSet
  • frxClass


TfrxView Class

Summary

The TfrxView class is the basic one for most components, which can be placed on a report design page. An object of this type has parameters such as "Frame" and "Color" and also can be connected to the data source. Practically all FastReport standard objects are inherited from this class.

Namespace: frxClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxBarcode.TfrxBarCodeView
frxChBox.TfrxCheckBoxView
frxClass.TfrxPictureView
frxClass.TfrxShapeView
frxClass.TfrxStretcheable
frxClass.TfrxSubreport
frxCross.TfrxCustomCrossView
frxDMPClass.TfrxDMPCommand
frxGaugeView.TfrxBaseGaugeView
frxGradient.TfrxGradientView
frxMap.TfrxMapView
frxOLE.TfrxOLEView
frxTableObject.TfrxHackView
frxZipCode.TfrxZipCodeView
Syntax
Delphi
type
 TfrxView = class(TfrxReportComponent)
 end;

The TfrxView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxView class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxView class. (Overrides TfrxReportComponent.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent.
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode.
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property).
Color | Object's filling color (deprecated check Fill property).
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Object's cursor (in the preview mode).
DataField | Data field's name, which the object is connected to.
DataSet | Data source, which the object is connected to.
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object.
Fill | Reference to fill instance based on FillType.
FillType | Object fill type.
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Object's frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex.
Height | Represents property Height.
Hint | The hint, shows when hold mouse pointer at object.
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page.
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData.
OnAfterPrint | Represents property OnAfterPrint.
OnBeforePrint | Represents property OnBeforePrint.
OnContentChanged | Represents property OnContentChanged.
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object.
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area.
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area.
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object.
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object.
OnPreviewClick | Represents property OnPreviewClick.
OnPreviewDblClick | Represents property OnPreviewDblClick.
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object.
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property).
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one
ShowHint | Show/hide hint.
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs.
Top | Represents property Top.
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs.
Visibility | Visibility of object in the result report.
Visible | Represents property Visible.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended).
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground.
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects.
DrawFrame | Represents method DrawFrame.
DrawFrameEdges | Represents method DrawFrameEdges.
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer).
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String).
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetBrushStyle | Represents method GetBrushStyle.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColor | Represents method GetColor.
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxReportComponent.GetData.)
GetDataSetName | Represents method GetDataSetName.
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes.
GetFillType | Represents method GetFillType.
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetPrintable | Represents method GetPrintable.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters.
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended).
GetVectorCanvas | Returns TVectorCanvas used for export engine.
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField.
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported).
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault).
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call.
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary.
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object.
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetBrushStyle(TBrushStyle) | Represents method SetBrushStyle(TBrushStyle).
SetColor(TColor) | Represents method SetColor(TColor).
SetDataSet(TfrxDataSet) | Represents method SetDataSet(TfrxDataSet).
SetDataSetName(String) | Represents method SetDataSetName(String).
SetFill(TfrxCustomFill) | Represents method SetFill(TfrxCustomFill).
SetFillType(TfrxFillType) | Represents method SetFillType(TfrxFillType).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetFrame(TfrxFrame) | Represents method SetFrame(TfrxFrame).
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetHyperLink(TfrxHyperlink) | Represents method SetHyperLink(TfrxHyperlink).
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetPrintable(Boolean) | Represents method SetPrintable(Boolean).
SetProcessing(TfrxObjectProcessing) | Represents method SetProcessing(TfrxObjectProcessing).
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetURL(String) | Represents method SetURL(String).
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows.
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAlign | Represents field FAlign.
FAllowVectorExport | Represents field FAllowVectorExport.
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCursor | Represents field FCursor.
FDataField | Represents field FDataField.
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
FDrawAsMask | Represents field FDrawAsMask.
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile.
FDX | Represents field FDX.
FDY | Represents field FDY.
FFill | Represents field FFill.
FFrame | Represents field FFrame.
FFrameWidth | Represents field FFrameWidth.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FHint | Represents field FHint.
FHyperlink | Represents field FHyperlink.
FObjAsMetafile | Represents field FObjAsMetafile.
FOffsetX | Represents field FOffsetX.
FOffsetY | Represents field FOffsetY.
FOnMouseDown | Represents field FOnMouseDown.
FOnMouseEnter | Represents field FOnMouseEnter.
FOnMouseLeave | Represents field FOnMouseLeave.
FOnMouseMove | Represents field FOnMouseMove.
FOnMouseUp | Represents field FOnMouseUp.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPlainText | Represents field FPlainText.
FProcessing | Represents field FProcessing.
FScaleX | Represents field FScaleX.
FScaleY | Represents field FScaleY.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftMode | Represents field FShiftMode.
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FShowHint | Represents field FShowHint.
FTagStr | Represents field FTagStr.
FTempHyperlink | Represents field FTempHyperlink.
FTempTag | Represents field FTempTag.
FURL | Represents field FURL.
FVC | Represents field FVC.
FVisibility | Represents field FVisibility.
FX | Represents field FX.
FX1 | Represents field FX1.
FY | Represents field FY.
FY1 | Represents field FY1.
Top
See Also

Reference

  • frxClass


TfrxView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxView class. (Overrides TfrxReportComponent.Create(TComponent).)
Destroy | Represents the destructor of the TfrxView class. (Overrides TfrxReportComponent.Destroy.)
Top


TfrxView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxView class.

Namespace: frxClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxReportComponent.Create(TComponent)
See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Destroy Destructor

Summary

Represents the destructor of the TfrxView class.

Namespace: frxClass
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxReportComponent.Destroy
See Also

Reference

  • TfrxView
  • frxClass


TfrxView Properties

Properties
Name | Description
Align | Object's aligning relatively to its parent.
AllowMirrorMode | Represents property AllowMirrorMode.
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it.
Anchors | Represents property Anchors.
BrushStyle | Object's filling style (deprecated check Fill property).
Color | Object's filling color (deprecated check Fill property).
Cursor | Object's cursor (in the preview mode).
DataField | Data field's name, which the object is connected to.
DataSet | Data source, which the object is connected to.
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property.
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object.
Fill | Reference to fill instance based on FillType.
FillType | Object fill type.
Frame | Object's frame.
GroupIndex | Represents property GroupIndex.
Height | Represents property Height.
Hint | The hint, shows when hold mouse pointer at object.
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page.
Left | Represents property Left.
OnAfterData | Represents property OnAfterData.
OnAfterPrint | Represents property OnAfterPrint.
OnBeforePrint | Represents property OnBeforePrint.
OnContentChanged | Represents property OnContentChanged.
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object.
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area.
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area.
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object.
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object.
OnPreviewClick | Represents property OnPreviewClick.
OnPreviewDblClick | Represents property OnPreviewDblClick.
PlainText | Used in export matrix to get a plain text of object.
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property).
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects.
Restrictions | Represents property Restrictions.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one
ShowHint | Show/hide hint.
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs.
Top | Represents property Top.
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs.
Visibility | Visibility of object in the result report.
Visible | Represents property Visible.
Width | Represents property Width.
Top


TfrxView.Align Property

Summary

Object's aligning relatively to its parent.

Namespace: frxClass
Syntax
Delphi
published
 property Align: TfrxAlign read FAlign write FAlign default baNone;

Property Value

Type: TfrxAlign

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.AllowMirrorMode Property

Summary

Represents property AllowMirrorMode.

Namespace: frxClass
Syntax
Delphi
published
 property AllowMirrorMode;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.AllowVectorExport Property

Summary

This object can be exported through vector graphic processor(meta file) if object and export filter supports it.

Namespace: frxClass
Syntax
Delphi
published
 property AllowVectorExport: Boolean read FAllowVectorExport write FAllowVectorExport;

Property Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Anchors Property

Summary

Represents property Anchors.

Namespace: frxClass
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.BrushStyle Property

Summary

Object's filling style (deprecated check Fill property).

Namespace: frxClass
Syntax
Delphi
public
 property BrushStyle: TBrushStyle read GetBrushStyle write SetBrushStyle stored False;

Property Value

Type: TBrushStyle

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Color Property

Summary

Object's filling color (deprecated check Fill property).

Namespace: frxClass
Syntax
Delphi
public
 property Color: TColor read GetColor write SetColor stored False;

Property Value

Type: TColor

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Cursor Property

Summary

Object's cursor (in the preview mode).

Namespace: frxClass
Syntax
Delphi
public
 property Cursor: TCursor read FCursor write FCursor default crDefault;

Property Value

Type: TCursor

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.DataField Property

Summary

Data field's name, which the object is connected to.

Namespace: frxClass
Syntax
Delphi
public
 property DataField: String read FDataField write FDataField;

Property Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.DataSet Property

Summary

Data source, which the object is connected to.

Namespace: frxClass
Syntax
Delphi
public
 property DataSet: TfrxDataSet read FDataSet write SetDataSet;

Property Value

Type: TfrxDataSet

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.DataSetName Property

Summary

Name of data source, which the object is connected to. This property duplicates the DataSet property.

Namespace: frxClass
Syntax
Delphi
public
 property DataSetName: String read GetDataSetName write SetDataSetName;

Property Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.DrawAsMask Property

Summary

Internal use. The export engine uses it to generate transparency mask of object.

Namespace: frxClass
Syntax
Delphi
public
 property DrawAsMask: Boolean read FDrawAsMask write FDrawAsMask;

Property Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Fill Property

Summary

Reference to fill instance based on FillType.

Namespace: frxClass
Syntax
Delphi
public
 property Fill: TfrxCustomFill read FFill write SetFill;

Property Value

Type: TfrxCustomFill

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FillType Property

Summary

Object fill type.

Namespace: frxClass
Syntax
Delphi
public
 property FillType: TfrxFillType read GetFillType write SetFillType default ftBrush;

Property Value

Type: TfrxFillType

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Frame Property

Summary

Object's frame.

Namespace: frxClass
Syntax
Delphi
public
 property Frame: TfrxFrame read FFrame write SetFrame;

Property Value

Type: TfrxFrame

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.GroupIndex Property

Summary

Represents property GroupIndex.

Namespace: frxClass
Syntax
Delphi
published
 property GroupIndex;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Height Property

Summary

Represents property Height.

Namespace: frxClass
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Hint Property

Summary

The hint, shows when hold mouse pointer at object.

Namespace: frxClass
Syntax
Delphi
published
 property Hint: String read FHint write FHint;

Property Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Hyperlink Property

Summary

The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page.

Namespace: frxClass
Syntax
Delphi
published
 property Hyperlink: TfrxHyperlink read FHyperlink write SetHyperLink;

Property Value

Type: TfrxHyperlink

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Left Property

Summary

Represents property Left.

Namespace: frxClass
Syntax
Delphi
published
 property Left;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.OnAfterData Property

Summary

Represents property OnAfterData.

Namespace: frxClass
Syntax
Delphi
published
 property OnAfterData;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.OnAfterPrint Property

Summary

Represents property OnAfterPrint.

Namespace: frxClass
Syntax
Delphi
published
 property OnAfterPrint;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.OnBeforePrint Property

Summary

Represents property OnBeforePrint.

Namespace: frxClass
Syntax
Delphi
published
 property OnBeforePrint;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.OnContentChanged Property

Summary

Represents property OnContentChanged.

Namespace: frxClass
Syntax
Delphi
published
 property OnContentChanged;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.OnMouseDown Property

Summary

The name of the script routine that will be called when user push mouse button in the report preview on current object.

Namespace: frxClass
Syntax
Delphi
published
 property OnMouseDown: TfrxMouseEvent read FOnMouseDown write FOnMouseDown;

Property Value

Type: TfrxMouseEvent

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.OnMouseEnter Property

Summary

The name of the script routine that will be called when mouse cursor in the report preview enters object area.

Namespace: frxClass
Syntax
Delphi
published
 property OnMouseEnter: TfrxMouseEnterViewEvent read FOnMouseEnter write FOnMouseEnter;

Property Value

Type: TfrxMouseEnterViewEvent

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.OnMouseLeave Property

Summary

The name of the script routine that will be called when mouse cursor in the report preview leaves object area.

Namespace: frxClass
Syntax
Delphi
published
 property OnMouseLeave: TfrxMouseLeaveViewEvent read FOnMouseLeave write FOnMouseLeave;

Property Value

Type: TfrxMouseLeaveViewEvent

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.OnMouseMove Property

Summary

The name of the script routine that will be called when user move mouse pointer in the report preview over current object.

Namespace: frxClass
Syntax
Delphi
published
 property OnMouseMove: TfrxMouseMoveEvent read FOnMouseMove write FOnMouseMove;

Property Value

Type: TfrxMouseMoveEvent

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.OnMouseUp Property

Summary

The name of the script routine that will be called when user release mouse button in the report preview on current object.

Namespace: frxClass
Syntax
Delphi
published
 property OnMouseUp: TfrxMouseEvent read FOnMouseUp write FOnMouseUp;

Property Value

Type: TfrxMouseEvent

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.OnPreviewClick Property

Summary

Represents property OnPreviewClick.

Namespace: frxClass
Syntax
Delphi
published
 property OnPreviewClick;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.OnPreviewDblClick Property

Summary

Represents property OnPreviewDblClick.

Namespace: frxClass
Syntax
Delphi
published
 property OnPreviewDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.PlainText Property

Summary

Used in export matrix to get a plain text of object.

Namespace: frxClass
Syntax
Delphi
public
 property PlainText: Boolean read FPlainText write FPlainText;

Property Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Printable Property

Summary

Defines whether the given object should be printed out (Deprecated check Visibility property).

Namespace: frxClass
Syntax
Delphi
published
 property Printable: Boolean read GetPrintable write SetPrintable stored False default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Processing Property

Summary

Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects.

Namespace: frxClass
Syntax
Delphi
public
 property Processing: TfrxObjectProcessing read FProcessing write SetProcessing;

Property Value

Type: TfrxObjectProcessing

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Restrictions Property

Summary

Represents property Restrictions.

Namespace: frxClass
Syntax
Delphi
published
 property Restrictions;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.ShiftMode Property

Summary

The mode of object's shifting in cases when a stretchable object is placed over the given one

Namespace: frxClass
Syntax
Delphi
published
 property ShiftMode: TfrxShiftMode read FShiftMode write FShiftMode default smAlways;

Property Value

Type: TfrxShiftMode

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.ShowHint Property

Summary

Show/hide hint.

Namespace: frxClass
Syntax
Delphi
published
 property ShowHint: Boolean read FShowHint write FShowHint default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.TagStr Property

Summary

The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs.

Namespace: frxClass
Syntax
Delphi
public
 property TagStr: String read FTagStr write FTagStr;

Property Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Top Property

Summary

Represents property Top.

Namespace: frxClass
Syntax
Delphi
published
 property Top;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.URL Property

Summary

Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this
object in the preview window. The property may contain string like:
- '@number' - jumps to specified page number;/n
- '#name' - jumps to specified anchor;/n
- 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n
The property may contain an expression in square brakets which will be calculated when report runs.

Namespace: frxClass
Syntax
Delphi
public
 property URL: String read FURL write SetURL stored False;

Property Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Visibility Property

Summary

Visibility of object in the result report.

Namespace: frxClass
Syntax
Delphi
published
 property Visibility: TfrxVisibilityTypes read FVisibility write FVisibility default [vsPreview, vsExport, vsPrint];

Property Value

Type: TfrxVisibilityTypes

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Visible Property

Summary

Represents property Visible.

Namespace: frxClass
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Width Property

Summary

Represents property Width.

Namespace: frxClass
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TfrxView
  • frxClass


TfrxView Methods

Methods
Name | Description
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended).
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground.
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects.
DrawFrame | Represents method DrawFrame.
DrawFrameEdges | Represents method DrawFrameEdges.
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer).
ExpandVariables(String) | Represents method ExpandVariables(String).
GetBrushStyle | Represents method GetBrushStyle.
GetColor | Represents method GetColor.
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxReportComponent.GetData.)
GetDataSetName | Represents method GetDataSetName.
GetExportBounds | Returns object bounds for export filtes.
GetFillType | Represents method GetFillType.
GetPrintable | Represents method GetPrintable.
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters.
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended).
GetVectorCanvas | Returns TVectorCanvas used for export engine.
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it.
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsDataField | Returns True when report object has assigned DataSet and DataField.
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported).
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault).
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call.
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary.
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object.
SetBrushStyle(TBrushStyle) | Represents method SetBrushStyle(TBrushStyle).
SetColor(TColor) | Represents method SetColor(TColor).
SetDataSet(TfrxDataSet) | Represents method SetDataSet(TfrxDataSet).
SetDataSetName(String) | Represents method SetDataSetName(String).
SetFill(TfrxCustomFill) | Represents method SetFill(TfrxCustomFill).
SetFillType(TfrxFillType) | Represents method SetFillType(TfrxFillType).
SetFrame(TfrxFrame) | Represents method SetFrame(TfrxFrame).
SetHyperLink(TfrxHyperlink) | Represents method SetHyperLink(TfrxHyperlink).
SetPrintable(Boolean) | Represents method SetPrintable(Boolean).
SetProcessing(TfrxObjectProcessing) | Represents method SetProcessing(TfrxObjectProcessing).
SetURL(String) | Represents method SetURL(String).
ShadowSize | Calculates size of dropped shadows.
Top


TfrxView.AfterPrint Method

Summary

The report engine calls this method after object was prepared and placed to preview pages.

Namespace: frxClass
Syntax
Delphi
public
 procedure AfterPrint; override;

Overrides

TfrxReportComponent.AfterPrint
See Also

Reference

  • TfrxView
  • frxClass


TfrxView.BeforePrint Method

Summary

The report engine calls this method before prepare object and place it to preview pages.

Namespace: frxClass
Syntax
Delphi
public
 procedure BeforePrint; override;

Overrides

TfrxReportComponent.BeforePrint
See Also

Reference

  • TfrxView
  • frxClass


TfrxView.BeginDraw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure BeginDraw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); virtual;

Parameters

Canvas
Type: TCanvas

ScaleX
Type: Extended

ScaleY
Type: Extended

OffsetX
Type: Extended

OffsetY
Type: Extended

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Diff(TfrxComponent) Method

Summary

Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set.

Namespace: frxClass
Syntax
Delphi
public
 function Diff(AComponent: TfrxComponent): String; override;

Parameters

AComponent
Type: TfrxComponent

Return Value

Type: String

Overrides

TfrxComponent.Diff(TfrxComponent)
See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxClass
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxView
  • frxClass


TfrxView.DrawBackground Method

Summary

Represents method DrawBackground.

Namespace: frxClass
Syntax
Delphi
protected
 procedure DrawBackground; virtual;
See Also

Reference

  • TfrxView
  • frxClass


TfrxView.DrawClipped(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects.

Namespace: frxClass
Syntax
Delphi
public
 procedure DrawClipped(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); virtual;

Parameters

Canvas
Type: TCanvas

ScaleX
Type: Extended

ScaleY
Type: Extended

OffsetX
Type: Extended

OffsetY
Type: Extended

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.DrawFrame Method

Summary

Represents method DrawFrame.

Namespace: frxClass
Syntax
Delphi
protected
 procedure DrawFrame; virtual;
See Also

Reference

  • TfrxView
  • frxClass


TfrxView.DrawFrameEdges Method

Summary

Represents method DrawFrameEdges.

Namespace: frxClass
Syntax
Delphi
protected
 procedure DrawFrameEdges;
See Also

Reference

  • TfrxView
  • frxClass


TfrxView.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) Method

Summary

Draws selection highlight.

Namespace: frxClass
Syntax
Delphi
public
 procedure DrawHighlight(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended; hlColor: TColor = clNone); override;

Parameters

Canvas
Type: TCanvas

Canvas to draw.

ScaleX
Type: Extended

X scale factor.

ScaleY
Type: Extended

Y scale factor.

OffsetX
Type: Extended

X offset.

OffsetY
Type: Extended

X offset.

hlColor
Type: TColor

Highlight color.

Overrides

TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor)
See Also

Reference

  • TfrxView
  • frxClass


TfrxView.DrawLine(Integer,Integer,Integer,Integer,Integer) Method

Summary

Represents method DrawLine(Integer,Integer,Integer,Integer,Integer).

Namespace: frxClass
Syntax
Delphi
protected
 procedure DrawLine(x, y, x1, y1, w: Integer);

Parameters

x
Type: Integer

y
Type: Integer

x1
Type: Integer

y1
Type: Integer

w
Type: Integer

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.ExpandVariables(String) Method

Summary

Represents method ExpandVariables(String).

Namespace: frxClass
Syntax
Delphi
protected
 procedure ExpandVariables(var Expr: String);

Parameters

Expr
Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.GetBrushStyle Method

Summary

Represents method GetBrushStyle.

Namespace: frxClass
Syntax
Delphi
private
 function GetBrushStyle: TBrushStyle;

Return Value

Type: TBrushStyle

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.GetColor Method

Summary

Represents method GetColor.

Namespace: frxClass
Syntax
Delphi
private
 function GetColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxClass
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxReportComponent.GetData
See Also

Reference

  • TfrxView
  • frxClass


TfrxView.GetDataSetName Method

Summary

Represents method GetDataSetName.

Namespace: frxClass
Syntax
Delphi
private
 function GetDataSetName: String;

Return Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.GetExportBounds Method

Summary

Returns object bounds for export filtes.

Namespace: frxClass
Syntax
Delphi
public
 function GetExportBounds: TfrxRect; virtual;

Return Value

Type: TfrxRect

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.GetFillType Method

Summary

Represents method GetFillType.

Namespace: frxClass
Syntax
Delphi
private
 function GetFillType: TfrxFillType;

Return Value

Type: TfrxFillType

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.GetPrintable Method

Summary

Represents method GetPrintable.

Namespace: frxClass
Syntax
Delphi
private
 function GetPrintable: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.GetScaleFactor(Extended,Extended) Method

Summary

Deprecated. Used to get scale factor of object content for export filters.

Namespace: frxClass
Syntax
Delphi
public
 procedure GetScaleFactor(var ScaleX: Extended; var ScaleY: Extended); virtual;

Parameters

ScaleX
Type: Extended

ScaleY
Type: Extended

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.GetScreenScale(Extended,Extended) Method

Summary

Represents method GetScreenScale(Extended,Extended).

Namespace: frxClass
Syntax
Delphi
protected
 procedure GetScreenScale(var aScaleX, aScaleY: Extended);

Parameters

aScaleX
Type: Extended

aScaleY
Type: Extended

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.GetVectorCanvas Method

Summary

Returns TVectorCanvas used for export engine.

Namespace: frxClass
Syntax
Delphi
public
 function GetVectorCanvas: TVectorCanvas; virtual;

Return Value

Type: TVectorCanvas

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.GetVectorGraphic(Boolean) Method

Summary

Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it.

Namespace: frxClass
Syntax
Delphi
public
 function GetVectorGraphic(DrawFill: Boolean = False): TGraphic; virtual;

Parameters

DrawFill
Type: Boolean

If True , object draws fill on result vector image.

Return Value

Type: TGraphic

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.IsAcceptAsChild(TfrxComponent) Method

Summary

Returns true when component in aParent can be accepted as parent for current.

Namespace: frxClass
Syntax
Delphi
public
 function IsAcceptAsChild(aParent: TfrxComponent): Boolean; override;

Parameters

aParent
Type: TfrxComponent

Component that supposedly should become a parent for current.

Return Value

Type: Boolean

Overrides

TfrxComponent.IsAcceptAsChild(TfrxComponent)
See Also

Reference

  • TfrxView
  • frxClass


TfrxView.IsDataField Method

Summary

Returns True when report object has assigned DataSet and DataField.

Namespace: frxClass
Syntax
Delphi
public
 function IsDataField: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.IsEMFExportable Method

Summary

Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported).

Namespace: frxClass
Syntax
Delphi
public
 function IsEMFExportable: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.IsPostProcessAllowed Method

Summary

Return True when post processing for current object is enabled (Default ProcessAt <> paDefault).

Namespace: frxClass
Syntax
Delphi
public
 function IsPostProcessAllowed: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) Method

Summary

Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call.

Namespace: frxClass
Syntax
Delphi
public
 function LoadContentFromDictionary(aReport: TfrxReport; aItem: TfrxMacrosItem): Boolean; virtual;

Parameters

aReport
Type: TfrxReport

Reference to the report object.

aItem
Type: TfrxMacrosItem

TfrxMacrosItem which stores processed data for current object.

Return Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.MirrorContent(TfrxMirrorControlModes) Method

Summary

Represents method MirrorContent(TfrxMirrorControlModes).

Namespace: frxClass
Syntax
Delphi
public
 procedure MirrorContent(MirrorModes: TfrxMirrorControlModes); override;

Parameters

MirrorModes
Type: TfrxMirrorControlModes

Overrides

TfrxComponent.MirrorContent(TfrxMirrorControlModes)
See Also

Reference

  • TfrxView
  • frxClass


TfrxView.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: frxClass
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) Method

Summary

The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from
PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary.

Namespace: frxClass
Syntax
Delphi
public
 procedure ProcessDictionary(aItem: TfrxMacrosItem; aReport: TfrxReport; PostProcessor: TfrxPostProcessor); virtual;

Parameters

aItem
Type: TfrxMacrosItem

aReport
Type: TfrxReport

PostProcessor
Type: TfrxPostProcessor

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor) Method

Summary

This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object.

Namespace: frxClass
Syntax
Delphi
public
 procedure SaveContentToDictionary(aReport: TfrxReport; PostProcessor: TfrxPostProcessor); virtual;

Parameters

aReport
Type: TfrxReport

Reference to the report object.

PostProcessor
Type: TfrxPostProcessor

Reference to TfrxPostProcessor instance of post processing manager.

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.SetBrushStyle(TBrushStyle) Method

Summary

Represents method SetBrushStyle(TBrushStyle).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetBrushStyle(const Value: TBrushStyle);

Parameters

Value
Type: TBrushStyle

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.SetDataSet(TfrxDataSet) Method

Summary

Represents method SetDataSet(TfrxDataSet).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDataSet(const Value: TfrxDataSet);

Parameters

Value
Type: TfrxDataSet

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.SetDataSetName(String) Method

Summary

Represents method SetDataSetName(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetDataSetName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.SetFill(TfrxCustomFill) Method

Summary

Represents method SetFill(TfrxCustomFill).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFill(const Value: TfrxCustomFill);

Parameters

Value
Type: TfrxCustomFill

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.SetFillType(TfrxFillType) Method

Summary

Represents method SetFillType(TfrxFillType).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFillType(const Value: TfrxFillType);

Parameters

Value
Type: TfrxFillType

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.SetFrame(TfrxFrame) Method

Summary

Represents method SetFrame(TfrxFrame).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetFrame(const Value: TfrxFrame);

Parameters

Value
Type: TfrxFrame

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.SetHyperLink(TfrxHyperlink) Method

Summary

Represents method SetHyperLink(TfrxHyperlink).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetHyperLink(const Value: TfrxHyperlink);

Parameters

Value
Type: TfrxHyperlink

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.SetPrintable(Boolean) Method

Summary

Represents method SetPrintable(Boolean).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetPrintable(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.SetProcessing(TfrxObjectProcessing) Method

Summary

Represents method SetProcessing(TfrxObjectProcessing).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetProcessing(const Value: TfrxObjectProcessing);

Parameters

Value
Type: TfrxObjectProcessing

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.SetURL(String) Method

Summary

Represents method SetURL(String).

Namespace: frxClass
Syntax
Delphi
private
 procedure SetURL(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.ShadowSize Method

Summary

Calculates size of dropped shadows.

Namespace: frxClass
Syntax
Delphi
public
 function ShadowSize: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxView
  • frxClass


TfrxView Fields

Fields
Name | Description
FAlign | Represents field FAlign.
FAllowVectorExport | Represents field FAllowVectorExport.
FCanvas | Represents field FCanvas.
FCursor | Represents field FCursor.
FDataField | Represents field FDataField.
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
FDrawAsMask | Represents field FDrawAsMask.
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile.
FDX | Represents field FDX.
FDY | Represents field FDY.
FFill | Represents field FFill.
FFrame | Represents field FFrame.
FFrameWidth | Represents field FFrameWidth.
FHint | Represents field FHint.
FHyperlink | Represents field FHyperlink.
FObjAsMetafile | Represents field FObjAsMetafile.
FOffsetX | Represents field FOffsetX.
FOffsetY | Represents field FOffsetY.
FOnMouseDown | Represents field FOnMouseDown.
FOnMouseEnter | Represents field FOnMouseEnter.
FOnMouseLeave | Represents field FOnMouseLeave.
FOnMouseMove | Represents field FOnMouseMove.
FOnMouseUp | Represents field FOnMouseUp.
FPlainText | Represents field FPlainText.
FProcessing | Represents field FProcessing.
FScaleX | Represents field FScaleX.
FScaleY | Represents field FScaleY.
FShiftMode | Represents field FShiftMode.
FShowHint | Represents field FShowHint.
FTagStr | Represents field FTagStr.
FTempHyperlink | Represents field FTempHyperlink.
FTempTag | Represents field FTempTag.
FURL | Represents field FURL.
FVC | Represents field FVC.
FVisibility | Represents field FVisibility.
FX | Represents field FX.
FX1 | Represents field FX1.
FY | Represents field FY.
FY1 | Represents field FY1.
Top


TfrxView.FAlign Field

Summary

Represents field FAlign.

Namespace: frxClass
Syntax
Delphi
private
 FAlign: TfrxAlign;

Field Value

Type: TfrxAlign

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FAllowVectorExport Field

Summary

Represents field FAllowVectorExport.

Namespace: frxClass
Syntax
Delphi
private
 FAllowVectorExport: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FCanvas Field

Summary

Represents field FCanvas.

Namespace: frxClass
Syntax
Delphi
protected
 FCanvas: TCanvas;

Field Value

Type: TCanvas

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FCursor Field

Summary

Represents field FCursor.

Namespace: frxClass
Syntax
Delphi
private
 FCursor: TCursor;

Field Value

Type: TCursor

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FDataField Field

Summary

Represents field FDataField.

Namespace: frxClass
Syntax
Delphi
private
 FDataField: String;

Field Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FDataSet Field

Summary

Represents field FDataSet.

Namespace: frxClass
Syntax
Delphi
private
 FDataSet: TfrxDataSet;

Field Value

Type: TfrxDataSet

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FDataSetName Field

Summary

Represents field FDataSetName.

Namespace: frxClass
Syntax
Delphi
private
 FDataSetName: String;

Field Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FDrawAsMask Field

Summary

Represents field FDrawAsMask.

Namespace: frxClass
Syntax
Delphi
private
 FDrawAsMask: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FDrawFillOnMetaFile Field

Summary

Represents field FDrawFillOnMetaFile.

Namespace: frxClass
Syntax
Delphi
protected
 FDrawFillOnMetaFile: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FDX Field

Summary

Represents field FDX.

Namespace: frxClass
Syntax
Delphi
protected
 FDX: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FDY Field

Summary

Represents field FDY.

Namespace: frxClass
Syntax
Delphi
protected
 FDY: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FFill Field

Summary

Represents field FFill.

Namespace: frxClass
Syntax
Delphi
private
 FFill: TfrxCustomFill;

Field Value

Type: TfrxCustomFill

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FFrame Field

Summary

Represents field FFrame.

Namespace: frxClass
Syntax
Delphi
private
 FFrame: TfrxFrame;

Field Value

Type: TfrxFrame

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FFrameWidth Field

Summary

Represents field FFrameWidth.

Namespace: frxClass
Syntax
Delphi
protected
 FFrameWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FHint Field

Summary

Represents field FHint.

Namespace: frxClass
Syntax
Delphi
private
 FHint: String;

Field Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FHyperlink Field

Summary

Represents field FHyperlink.

Namespace: frxClass
Syntax
Delphi
private
 FHyperlink: TfrxHyperlink;

Field Value

Type: TfrxHyperlink

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FObjAsMetafile Field

Summary

Represents field FObjAsMetafile.

Namespace: frxClass
Syntax
Delphi
protected
 FObjAsMetafile: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FOffsetX Field

Summary

Represents field FOffsetX.

Namespace: frxClass
Syntax
Delphi
protected
 FOffsetX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FOffsetY Field

Summary

Represents field FOffsetY.

Namespace: frxClass
Syntax
Delphi
protected
 FOffsetY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FOnMouseDown Field

Summary

Represents field FOnMouseDown.

Namespace: frxClass
Syntax
Delphi
private
 FOnMouseDown: TfrxMouseEvent;

Field Value

Type: TfrxMouseEvent

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FOnMouseEnter Field

Summary

Represents field FOnMouseEnter.

Namespace: frxClass
Syntax
Delphi
private
 FOnMouseEnter: TfrxMouseEnterViewEvent;

Field Value

Type: TfrxMouseEnterViewEvent

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FOnMouseLeave Field

Summary

Represents field FOnMouseLeave.

Namespace: frxClass
Syntax
Delphi
private
 FOnMouseLeave: TfrxMouseLeaveViewEvent;

Field Value

Type: TfrxMouseLeaveViewEvent

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FOnMouseMove Field

Summary

Represents field FOnMouseMove.

Namespace: frxClass
Syntax
Delphi
private
 FOnMouseMove: TfrxMouseMoveEvent;

Field Value

Type: TfrxMouseMoveEvent

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FOnMouseUp Field

Summary

Represents field FOnMouseUp.

Namespace: frxClass
Syntax
Delphi
private
 FOnMouseUp: TfrxMouseEvent;

Field Value

Type: TfrxMouseEvent

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FPlainText Field

Summary

Represents field FPlainText.

Namespace: frxClass
Syntax
Delphi
private
 FPlainText: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FProcessing Field

Summary

Represents field FProcessing.

Namespace: frxClass
Syntax
Delphi
protected
 FProcessing: TfrxObjectProcessing;

Field Value

Type: TfrxObjectProcessing

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FScaleX Field

Summary

Represents field FScaleX.

Namespace: frxClass
Syntax
Delphi
protected
 FScaleX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FScaleY Field

Summary

Represents field FScaleY.

Namespace: frxClass
Syntax
Delphi
protected
 FScaleY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FShiftMode Field

Summary

Represents field FShiftMode.

Namespace: frxClass
Syntax
Delphi
private
 FShiftMode: TfrxShiftMode;

Field Value

Type: TfrxShiftMode

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FShowHint Field

Summary

Represents field FShowHint.

Namespace: frxClass
Syntax
Delphi
private
 FShowHint: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FTagStr Field

Summary

Represents field FTagStr.

Namespace: frxClass
Syntax
Delphi
private
 FTagStr: String;

Field Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FTempHyperlink Field

Summary

Represents field FTempHyperlink.

Namespace: frxClass
Syntax
Delphi
private
 FTempHyperlink: String;

Field Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FTempTag Field

Summary

Represents field FTempTag.

Namespace: frxClass
Syntax
Delphi
private
 FTempTag: String;

Field Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FURL Field

Summary

Represents field FURL.

Namespace: frxClass
Syntax
Delphi
private
 FURL: String;

Field Value

Type: String

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FVC Field

Summary

Represents field FVC.

Namespace: frxClass
Syntax
Delphi
protected
 FVC: TVectorCanvas;

Field Value

Type: TVectorCanvas

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FVisibility Field

Summary

Represents field FVisibility.

Namespace: frxClass
Syntax
Delphi
private
 FVisibility: TfrxVisibilityTypes;

Field Value

Type: TfrxVisibilityTypes

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FX Field

Summary

Represents field FX.

Namespace: frxClass
Syntax
Delphi
protected
 FX: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FX1 Field

Summary

Represents field FX1.

Namespace: frxClass
Syntax
Delphi
protected
 FX1: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FY Field

Summary

Represents field FY.

Namespace: frxClass
Syntax
Delphi
protected
 FY: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxView
  • frxClass


TfrxView.FY1 Field

Summary

Represents field FY1.

Namespace: frxClass
Syntax
Delphi
protected
 FY1: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxView
  • frxClass


frxClass Records

Records
Name | Description
TfrxDispatchMessage | Used with FRX_OWNER_DESTROY_MESSAGE.
TfrxInteractiveEventsParams | Represents type TfrxInteractiveEventsParams.
TfrxPoint | float point.
TfrxPreviewIntEventParams | Used to pass parameters from preview workspace to preview pages. Stores addition information event.
TfrxRect | Rect with float values.
Top


TfrxDispatchMessage Record

Summary

Used with FRX_OWNER_DESTROY_MESSAGE.

Namespace: frxClass
Syntax
Delphi
type
 TfrxDispatchMessage = record
 end;

The TfrxDispatchMessage type exposes the following members.

Fields
Show:
Name | Description
MsgID | Represents field MsgID.
Sender | Represents field Sender.
Top
See Also

Reference

  • frxClass


TfrxDispatchMessage Fields

Fields
Name | Description
MsgID | Represents field MsgID.
Sender | Represents field Sender.
Top


TfrxDispatchMessage.MsgID Field

Summary

Represents field MsgID.

Namespace: frxClass
Syntax
Delphi
public
 MsgID: Word;

Field Value

Type: Word

See Also

Reference

  • TfrxDispatchMessage
  • frxClass


TfrxDispatchMessage.Sender Field

Summary

Represents field Sender.

Namespace: frxClass
Syntax
Delphi
public
 Sender: TObject;

Field Value

Type: TObject

See Also

Reference

  • TfrxDispatchMessage
  • frxClass


TfrxInteractiveEventsParams Record

Summary

Represents type TfrxInteractiveEventsParams.

Namespace: frxClass
Syntax
Delphi
type
 TfrxInteractiveEventsParams = packed record
 end;

The TfrxInteractiveEventsParams type exposes the following members.

Fields
Show:
Name | Description
DevicePPI | Represents field DevicePPI.
EditMode | Represents field EditMode.
EditorsList | Represents field EditorsList.
EditRestricted | Represents field EditRestricted.
EventSender | Represents field EventSender.
FireParentEvent | Represents field FireParentEvent.
GridAlign | Represents field GridAlign.
GridType | Represents field GridType.
GridX | Represents field GridX.
GridY | Represents field GridY.
Modified | Represents field Modified.
OffsetX | Represents field OffsetX.
OffsetY | Represents field OffsetY.
OnFinish | Represents field OnFinish.
PopupVisible | Represents field PopupVisible.
Refresh | Represents field Refresh.
Scale | Represents field Scale.
SelectionList | Represents field SelectionList.
Sender | Represents field Sender.
Top
See Also

Reference

  • frxClass


TfrxInteractiveEventsParams Fields

Fields
Name | Description
DevicePPI | Represents field DevicePPI.
EditMode | Represents field EditMode.
EditorsList | Represents field EditorsList.
EditRestricted | Represents field EditRestricted.
EventSender | Represents field EventSender.
FireParentEvent | Represents field FireParentEvent.
GridAlign | Represents field GridAlign.
GridType | Represents field GridType.
GridX | Represents field GridX.
GridY | Represents field GridY.
Modified | Represents field Modified.
OffsetX | Represents field OffsetX.
OffsetY | Represents field OffsetY.
OnFinish | Represents field OnFinish.
PopupVisible | Represents field PopupVisible.
Refresh | Represents field Refresh.
Scale | Represents field Scale.
SelectionList | Represents field SelectionList.
Sender | Represents field Sender.
Top


TfrxInteractiveEventsParams.DevicePPI Field

Summary

Represents field DevicePPI.

Namespace: frxClass
Syntax
Delphi
public
 DevicePPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.EditMode Field

Summary

Represents field EditMode.

Namespace: frxClass
Syntax
Delphi
public
 EditMode: TfrxDesignTool;

Field Value

Type: TfrxDesignTool

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.EditorsList Field

Summary

Represents field EditorsList.

Namespace: frxClass
Syntax
Delphi
public
 EditorsList: TfrxComponentEditorsList;

Field Value

Type: TfrxComponentEditorsList

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.EditRestricted Field

Summary

Represents field EditRestricted.

Namespace: frxClass
Syntax
Delphi
public
 EditRestricted: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.EventSender Field

Summary

Represents field EventSender.

Namespace: frxClass
Syntax
Delphi
public
 EventSender: TfrxInteractiveEventSender;

Field Value

Type: TfrxInteractiveEventSender

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.FireParentEvent Field

Summary

Represents field FireParentEvent.

Namespace: frxClass
Syntax
Delphi
public
 FireParentEvent: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.GridAlign Field

Summary

Represents field GridAlign.

Namespace: frxClass
Syntax
Delphi
public
 GridAlign: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.GridType Field

Summary

Represents field GridType.

Namespace: frxClass
Syntax
Delphi
public
 GridType: TfrxGridType;

Field Value

Type: TfrxGridType

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.GridX Field

Summary

Represents field GridX.

Namespace: frxClass
Syntax
Delphi
public
 GridX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.GridY Field

Summary

Represents field GridY.

Namespace: frxClass
Syntax
Delphi
public
 GridY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.Modified Field

Summary

Represents field Modified.

Namespace: frxClass
Syntax
Delphi
public
 Refresh, Modified: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.OffsetX Field

Summary

Represents field OffsetX.

Namespace: frxClass
Syntax
Delphi
public
 OffsetX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.OffsetY Field

Summary

Represents field OffsetY.

Namespace: frxClass
Syntax
Delphi
public
 OffsetY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.OnFinish Field

Summary

Represents field OnFinish.

Namespace: frxClass
Syntax
Delphi
public
 OnFinish: TfrxOnFinishInPlaceEdit;

Field Value

Type: TfrxOnFinishInPlaceEdit

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.PopupVisible Field

Summary

Represents field PopupVisible.

Namespace: frxClass
Syntax
Delphi
public
 PopupVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.Refresh Field

Summary

Represents field Refresh.

Namespace: frxClass
Syntax
Delphi
public
 Refresh, Modified: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.Scale Field

Summary

Represents field Scale.

Namespace: frxClass
Syntax
Delphi
public
 Scale: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.SelectionList Field

Summary

Represents field SelectionList.

Namespace: frxClass
Syntax
Delphi
public
 SelectionList: TfrxSelectedObjectsList;

Field Value

Type: TfrxSelectedObjectsList

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxInteractiveEventsParams.Sender Field

Summary

Represents field Sender.

Namespace: frxClass
Syntax
Delphi
public
 Sender: TObject;

Field Value

Type: TObject

See Also

Reference

  • TfrxInteractiveEventsParams
  • frxClass


TfrxPoint Record

Summary

float point.

Namespace: frxClass
Syntax
Delphi
type
 TfrxPoint = packed record
 end;

The TfrxPoint type exposes the following members.

Fields
Show:
Name | Description
X | Represents field X.
Y | Represents field Y.
Top
See Also

Reference

  • frxClass


TfrxPoint Fields

Fields
Name | Description
X | Represents field X.
Y | Represents field Y.
Top


TfrxPoint.X Field

Summary

Represents field X.

Namespace: frxClass
Syntax
Delphi
public
 X, Y: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxPoint
  • frxClass


TfrxPoint.Y Field

Summary

Represents field Y.

Namespace: frxClass
Syntax
Delphi
public
 X, Y: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxPoint
  • frxClass


TfrxPreviewIntEventParams Record

Summary

Used to pass parameters from preview workspace to preview pages. Stores addition information event.

Namespace: frxClass
Syntax
Delphi
type
 TfrxPreviewIntEventParams = packed record
 end;

The TfrxPreviewIntEventParams type exposes the following members.

Fields
Show:
Name | Description
Accept | Return parameter for drag and drop event. If True, drag and drop accepts.
Cursor | Current cursor. PreviewPages, Editors, or report objects may change it.
EditMode | Selected tool. Preview supports only dtHand and dtEditor.
MouseEventType | Interactive event type.
MousePos | Mouse position for mouse wheel events.
RetResult | Return value. If True, event processed by preview pages, otherwise default preview behaviour will execute.
Sender | Reference to Sender (Preview control).
State | State of Drag and Drop event if it was generated.
WheelDelta | Mouse wheel delta for mouse wheel events.
Top
See Also

Reference

  • frxClass


TfrxPreviewIntEventParams Fields

Fields
Name | Description
Accept | Return parameter for drag and drop event. If True, drag and drop accepts.
Cursor | Current cursor. PreviewPages, Editors, or report objects may change it.
EditMode | Selected tool. Preview supports only dtHand and dtEditor.
MouseEventType | Interactive event type.
MousePos | Mouse position for mouse wheel events.
RetResult | Return value. If True, event processed by preview pages, otherwise default preview behaviour will execute.
Sender | Reference to Sender (Preview control).
State | State of Drag and Drop event if it was generated.
WheelDelta | Mouse wheel delta for mouse wheel events.
Top


TfrxPreviewIntEventParams.Accept Field

Summary

Return parameter for drag and drop event. If True, drag and drop accepts.

Namespace: frxClass
Syntax
Delphi
public
 Accept: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewIntEventParams
  • frxClass


TfrxPreviewIntEventParams.Cursor Field

Summary

Current cursor. PreviewPages, Editors, or report objects may change it.

Namespace: frxClass
Syntax
Delphi
public
 Cursor: TCursor;

Field Value

Type: TCursor

See Also

Reference

  • TfrxPreviewIntEventParams
  • frxClass


TfrxPreviewIntEventParams.EditMode Field

Summary

Selected tool. Preview supports only dtHand and dtEditor.

Namespace: frxClass
Syntax
Delphi
public
 EditMode: TfrxDesignTool;

Field Value

Type: TfrxDesignTool

See Also

Reference

  • TfrxPreviewIntEventParams
  • frxClass


TfrxPreviewIntEventParams.MouseEventType Field

Summary

Interactive event type.

Namespace: frxClass
Syntax
Delphi
public
 MouseEventType: TfrxMouseIntEvents;

Field Value

Type: TfrxMouseIntEvents

See Also

Reference

  • TfrxPreviewIntEventParams
  • frxClass


TfrxPreviewIntEventParams.MousePos Field

Summary

Mouse position for mouse wheel events.

Namespace: frxClass
Syntax
Delphi
public
 MousePos: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxPreviewIntEventParams
  • frxClass


TfrxPreviewIntEventParams.RetResult Field

Summary

Return value. If True, event processed by preview pages, otherwise default preview behaviour will execute.

Namespace: frxClass
Syntax
Delphi
public
 RetResult: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewIntEventParams
  • frxClass


TfrxPreviewIntEventParams.Sender Field

Summary

Reference to Sender (Preview control).

Namespace: frxClass
Syntax
Delphi
public
 Sender: TObject;

Field Value

Type: TObject

See Also

Reference

  • TfrxPreviewIntEventParams
  • frxClass


TfrxPreviewIntEventParams.State Field

Summary

State of Drag and Drop event if it was generated.

Namespace: frxClass
Syntax
Delphi
public
 State: TDragState;

Field Value

Type: TDragState

See Also

Reference

  • TfrxPreviewIntEventParams
  • frxClass


TfrxPreviewIntEventParams.WheelDelta Field

Summary

Mouse wheel delta for mouse wheel events.

Namespace: frxClass
Syntax
Delphi
public
 WheelDelta: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewIntEventParams
  • frxClass


TfrxRect Record

Summary

Rect with float values.

Namespace: frxClass
Syntax
Delphi
type
 TfrxRect = packed record
 end;

The TfrxRect type exposes the following members.

Fields
Show:
Name | Description
Bottom | Represents field Bottom.
Left | Represents field Left.
Right | Represents field Right.
Top | Represents field Top.
Top
See Also

Reference

  • frxClass


TfrxRect Fields

Fields
Name | Description
Bottom | Represents field Bottom.
Left | Represents field Left.
Right | Represents field Right.
Top | Represents field Top.
Top


TfrxRect.Bottom Field

Summary

Represents field Bottom.

Namespace: frxClass
Syntax
Delphi
public
 Left, Top, Right, Bottom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRect
  • frxClass


TfrxRect.Left Field

Summary

Represents field Left.

Namespace: frxClass
Syntax
Delphi
public
 Left, Top, Right, Bottom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRect
  • frxClass


TfrxRect.Right Field

Summary

Represents field Right.

Namespace: frxClass
Syntax
Delphi
public
 Left, Top, Right, Bottom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRect
  • frxClass


TfrxRect.Top Field

Summary

Represents field Top.

Namespace: frxClass
Syntax
Delphi
public
 Left, Top, Right, Bottom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRect
  • frxClass


frxClass Interfaces

Interfaces
Name | Description
IfrxDelayedCommand | This interface declares deferred command abstraction.
IInspectedProperties | Represents type IInspectedProperties.
IStringClassNameContainer | Represents type IStringClassNameContainer.
Top


IfrxDelayedCommand Interface

Summary

This interface declares deferred command abstraction.

Namespace: frxClass
Inheritance Hierarchy
IInterface
frxClass.IfrxDelayedCommand
frxClass.TfrxBaseDelayedCommand
Syntax
Delphi
type
 IfrxDelayedCommand = interface ['{3A04A39B-B516-42A5-A597-53F99F0EDB7B}']
 end;

The IfrxDelayedCommand type exposes the following members.

Methods
Show:
Name | Description
GetInstance | Get command instance.
GetName | Get symbolic name of current command instance.
Run | Runs command.
Top
See Also

Reference

  • frxClass


IfrxDelayedCommand Methods

Methods
Name | Description
GetInstance | Get command instance.
GetName | Get symbolic name of current command instance.
Run | Runs command.
Top


IfrxDelayedCommand.GetInstance Method

Summary

Get command instance.

Namespace: frxClass
Syntax
Delphi
public
 function GetInstance: TObject;

Return Value

Type: TObject

See Also

Reference

  • IfrxDelayedCommand
  • frxClass


IfrxDelayedCommand.GetName Method

Summary

Get symbolic name of current command instance.

Namespace: frxClass
Syntax
Delphi
public
 function GetName: String;

Return Value

Type: String

See Also

Reference

  • IfrxDelayedCommand
  • frxClass


IfrxDelayedCommand.Run Method

Summary

Runs command.

Namespace: frxClass
Syntax
Delphi
public
 procedure Run;
See Also

Reference

  • IfrxDelayedCommand
  • frxClass


IInspectedProperties Interface

Summary

Represents type IInspectedProperties.

Namespace: frxClass
Inheritance Hierarchy
IInterface
frxClass.IInspectedProperties
frxBarcode2D.TfrxBarcode2DView
Syntax
Delphi
type
 IInspectedProperties = interface
 ['{BDBE0326-DA24-4FB8-ADA0-2F740AB6C199}']
 end;

The IInspectedProperties type exposes the following members.

Methods
Show:
Name | Description
GetProperies | Represents method GetProperies.
Top
See Also

Reference

  • frxClass


IInspectedProperties Methods

Methods
Name | Description
GetProperies | Represents method GetProperies.
Top


IInspectedProperties.GetProperies Method

Summary

Represents method GetProperies.

Namespace: frxClass
Syntax
Delphi
public
 function GetProperies: TfrxExtPropList;

Return Value

Type: TfrxExtPropList

See Also

Reference

  • IInspectedProperties
  • frxClass


IStringClassNameContainer Interface

Summary

Represents type IStringClassNameContainer.

Namespace: frxClass
Inheritance Hierarchy
IInterface
frxClass.IStringClassNameContainer
frx2DBarcodesPresets.TfrxObjectDataPreset
Syntax
Delphi
type
 IStringClassNameContainer = interface
 ['{97FFA69C-C491-458E-98A7-EFDCFFE05465}']
 end;

The IStringClassNameContainer type exposes the following members.

Methods
Show:
Name | Description
GetSupportedClasses | Represents method GetSupportedClasses.
Top
See Also

Reference

  • frxClass


IStringClassNameContainer Methods

Methods
Name | Description
GetSupportedClasses | Represents method GetSupportedClasses.
Top


IStringClassNameContainer.GetSupportedClasses Method

Summary

Represents method GetSupportedClasses.

Namespace: frxClass
Syntax
Delphi
public
 function GetSupportedClasses: TList;

Return Value

Type: TList

See Also

Reference

  • IStringClassNameContainer
  • frxClass


frxClass Enumerations

Enumerations
Name | Description
frxClass. | Represents type .
TfrxAddPageAction | Sets behaviour of TfrxPreviewPages.AddPage method.
TfrxAlign | The alignment of the object relative to its parent.
TfrxAnchorsKind | Object anchors type.
TfrxComponentEditorVisibilityState | Visibility of InPlace editors.
TfrxCopyPasteType | Copy paste format for inPlace editors.
TfrxDesignerRestriction | A set of flags, which inhibit specific operations in the designer.
TfrxDesignTool | Type of the report designer tools.
TfrxDuplexMode | Mode of the duplex printing.
TfrxDuplicateMerge | Flags which is controlling duplicated behaviour.
TfrxFieldType | Field type.
TfrxFillType | Fill types of report objects.
TfrxFilterAccess | Access type of IO filters.
TfrxFilterVisibleState | These flags used in IO transports to define visibility of IO transport filter. By default each transport filter component registers in global list and these flags helps to sort items of the global list.
TfrxFormatKind | Kind of the formatting.
TfrxFrameStyle | Style of the frame line.
TfrxFrameType | Type of the frame line.
TfrxGlassFillOrientation | Orientation type of glass fill.
TfrxGradientStyle | Gradient fill styles.
TfrxGridType | Grid type in the report designer.
TfrxHAlign | The horizontal alignment of the text in the "Text" object.
TfrxHyperlinkKind | Type of hyperlinks supported by report objects.
TfrxInheriteMode | The inherit mode type.
TfrxInteractiveEventSender | Type of interactive event sender.
TfrxInteractiveHighlightEvent | Reserved.
TfrxIOTransportStream | Supported stream type for current IO transport filter.
TfrxMirrorControlMode | Mirror mode. Determinate how engine align controls and content base on original layout.
TfrxMouseIntEvents | Type of mouse interactive events supported by report objects.
TfrxPreviewButton | Buttons that can be displayed in the preview window.
TfrxPrintMode | The print mode.
TfrxPrintOnType | Reserved for future use.
TfrxPrintPages | Pages to print.
TfrxProcessAtMode | Controls when to process expression calculation(for some TfrxView objects).
TfrxProgressType | The kind of action in the OnProgressXXX event: run a report, export, print.
TfrxRangeBegin | The navigation start point.
TfrxRangeEnd | The endpoint of navigation.
TfrxRestriction | Flags, used to restrict some object operations in the designer.
TfrxScrollerOrientation | Represent scrollbar orientation.
TfrxSerializeState | Controls serialization state (Not used yet).
TfrxShapeKind | Kind of shape.
TfrxShiftEngine | Determine how container shifts its child object.
TfrxShiftMode | Shift mode of the object. Behaviour depends on what type of TfrxShiftEngine selected in parent container.
TfrxSilentMode | Represents type TfrxSilentMode.
TfrxStretchMode | Stretch mode of the text objects.
TfrxToNRowsMode | This flags used in a child band to complete data band upto specified number of rows (fill the space with an empty rows). If data band has less number of rows, the empty row will be printed.
TfrxUnderlinesTextMode | Underlines text mode for "Text" object.
TfrxVAlign | The vertical alignment of the text in the "Text" object.
TfrxVisibilityType | Visibility of object in the result report.
TfrxZoomMode | Zoom mode of the preview window.
Top


Enumeration

Summary

Represents type .

Namespace: frxClass
See Also

Reference

  • frxClass


TfrxAddPageAction Enumeration

Summary

Sets behaviour of TfrxPreviewPages.AddPage method.

Namespace: frxClass
Syntax
Delphi
type
 TfrxAddPageAction = (
 apWriteOver,
 apAdd);

The TfrxAddPageAction type exposes the following members.

Members
Show:
Name | Description
apAdd | Always add new page.
apWriteOver | Write over current page if it isn't last page.
Top
See Also

Reference

  • frxClass


TfrxAlign Enumeration

Summary

The alignment of the object relative to its parent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxAlign = (
 baNone,
 baLeft,
 baRight,
 baCenter,
 baWidth,
 baBottom,
 baClient,
 baHidden);

The TfrxAlign type exposes the following members.

Members
Show:
Name | Description
baBottom | Aligned to bottom.
baCenter | Aligned to center.
baClient | Aligned to parent sizes.
baHidden | Objects ignored(invisible) in align mechanism.
baLeft | Aligned to left.
baNone | No align.
baRight | Aligned to right.
baWidth | Aligned to width of parent container.
Top
See Also

Reference

  • frxClass


TfrxAnchorsKind Enumeration

Summary

Object anchors type.

Namespace: frxClass
Syntax
Delphi
type
 TfrxAnchorsKind = (
 fraLeft,
 fraTop,
 fraRight,
 fraBottom);

The TfrxAnchorsKind type exposes the following members.

Members
Show:
Name | Description
fraBottom | Bottom.
fraLeft | Left.
fraRight | Right.
fraTop | Top.
Top
See Also

Reference

  • frxClass


TfrxComponentEditorVisibilityState Enumeration

Summary

Visibility of InPlace editors.

Namespace: frxClass
Syntax
Delphi
type
 TfrxComponentEditorVisibilityState = (
 evPreview,
 evDesigner);

The TfrxComponentEditorVisibilityState type exposes the following members.

Members
Show:
Name | Description
evDesigner | Visible only in the report designer.
evPreview | Visible only in the report preview.
Top
See Also

Reference

  • frxClass


TfrxCopyPasteType Enumeration

Summary

Copy paste format for inPlace editors.

Namespace: frxClass
Syntax
Delphi
type
 TfrxCopyPasteType = (
 cptDefault,
 cptText,
 cptImage,
 cptNative);

The TfrxCopyPasteType type exposes the following members.

Members
Show:
Name | Description
cptDefault | Default.
cptImage | Image.
cptNative | Native control format.
cptText | Text.
Top
See Also

Reference

  • frxClass


TfrxDesignerRestriction Enumeration

Summary

A set of flags, which inhibit specific operations in the designer.

Namespace: frxClass
Syntax
Delphi
type
 TfrxDesignerRestriction =
 (
 drDontInsertObject,
 drDontDeletePage,
 drDontCreatePage,
 drDontChangePageOptions,
 drDontCreateReport,
 drDontLoadReport,
 drDontSaveReport,
 drDontPreviewReport,
 drDontEditVariables,
 drDontChangeReportOptions,
 drDontEditReportData,
 drDontShowRecentFiles,
 drDontEditReportScript,
 drDontEditInternalDatasets);

The TfrxDesignerRestriction type exposes the following members.

Members
Show:
Name | Description
drDontChangePageOptions | Forbids modifying page's properties.
drDontChangeReportOptions | Forbids modifying the report's properties.
drDontCreatePage | Forbids creation of new pages.
drDontCreateReport | Forbids creation of a new report.
drDontDeletePage | Forbids deletion of pages.
drDontEditInternalDatasets | Forbids changes in internal DataSets(DataPage).
drDontEditReportData | Forbids Report|Data... menu.
drDontEditReportScript | Forbids changes in report script.
drDontEditVariables | Forbids editing of variables.
drDontInsertObject | Forbids insertion of objects.
drDontLoadReport | Forbids report's loading.
drDontPreviewReport | Forbids report's preview.
drDontSaveReport | Forbids report's saving.
drDontShowRecentFiles | Forbids display of recent file list.
Top
See Also

Reference

  • frxClass


TfrxDesignTool Enumeration

Summary

Type of the report designer tools.

Namespace: frxClass
Syntax
Delphi
type
 TfrxDesignTool = (
 dtSelect,
 dtHand,
 dtZoom,
 dtText,
 dtFormat,
 dtEditor);

The TfrxDesignTool type exposes the following members.

Members
Show:
Name | Description
dtEditor | Editor.
dtFormat | Format copy tool.
dtHand | Move hand.
dtSelect | Selection.
dtText | InPlace text editor.
dtZoom | Zoom.
Top
See Also

Reference

  • frxClass


TfrxDuplexMode Enumeration

Summary

Mode of the duplex printing.

Namespace: frxClass
Syntax
Delphi
type
 TfrxDuplexMode = (dmNone, dmVertical, dmHorizontal, dmSimplex);

The TfrxDuplexMode type exposes the following members.

Members
Show:
Name | Description
dmHorizontal | Represents constant dmHorizontal.
dmNone | Represents constant dmNone.
dmSimplex | Represents constant dmSimplex.
dmVertical | Represents constant dmVertical.
Top
See Also

Reference

  • frxClass


TfrxDuplicateMerge Enumeration

Summary

Flags which is controlling duplicated behaviour.

Namespace: frxClass
Syntax
Delphi
type
 TfrxDuplicateMerge = (
 dmShow,
 dmHide,
 dmClear,
 dmMerge);

The TfrxDuplicateMerge type exposes the following members.

Members
Show:
Name | Description
dmClear | Clear all duplicated values.
dmHide | Hide objects with duplicated values.
dmMerge | Merge all duplicated objects to one.
dmShow | Show all duplicates. Default.
Top
See Also

Reference

  • frxClass


TfrxFieldType Enumeration

Summary

Field type.

Namespace: frxClass
Syntax
Delphi
type
 TfrxFieldType = (
 fftNumeric,
 fftString,
 fftBoolean,
 fftDateTime);

The TfrxFieldType type exposes the following members.

Members
Show:
Name | Description
fftBoolean | Boolean.
fftDateTime | Data time.
fftNumeric | Numeric.
fftString | Text.
Top
See Also

Reference

  • frxClass


TfrxFillType Enumeration

Summary

Fill types of report objects.

Namespace: frxClass
Syntax
Delphi
type
 TfrxFillType = (
 ftBrush,
 ftGradient,
 ftGlass);

The TfrxFillType type exposes the following members.

Members
Show:
Name | Description
ftBrush | Brush fill.
ftGlass | Glass fill.
ftGradient | Gradient fill.
Top
See Also

Reference

  • frxClass


TfrxFilterAccess Enumeration

Summary

Access type of IO filters.

Namespace: frxClass
Syntax
Delphi
type
 TfrxFilterAccess = (
 faRead,
 faWrite);

The TfrxFilterAccess type exposes the following members.

Members
Show:
Name | Description
faRead | Read only.
faWrite | Write.
Top
See Also

Reference

  • frxClass


TfrxFilterVisibleState Enumeration

Summary

These flags used in IO transports to define visibility of IO transport filter. By default each transport filter component registers in global list and these flags helps to sort items of the global list.

Namespace: frxClass
Syntax
Delphi
type
 TfrxFilterVisibleState = (
 fvDesigner,
 fvPreview,
 fvExport,
 fvDesignerFileFilter,
 fvPreviewFileFilter,
 fvExportFileFilter,
 fvOther);

The TfrxFilterVisibleState type exposes the following members.

Members
Show:
Name | Description
fvDesigner | Filter available from the report designer in "File" -> "Save as" and "Open" submenu.
fvDesignerFileFilter | Filter available from the report designer as a filter option (drop down list) in standard Save and Open dialogs.
fvExport | Filter available from an export filter dialog.
fvExportFileFilter | Filter available from an export as a filter option (drop down list) in standard Save and Open dialogs.
fvOther | Reserved.
fvPreview | Filter available from the report preview in "File" -> "Save as" and "Open" submenu.
fvPreviewFileFilter | Filter available from the report preview as a filter option (drop down list) in standard Save and Open dialogs.
Top
See Also

Reference

  • frxClass


TfrxFormatKind Enumeration

Summary

Kind of the formatting.

Namespace: frxClass
Syntax
Delphi
type
 TfrxFormatKind = (
 fkText,
 fkNumeric,
 fkDateTime,
 fkBoolean);

The TfrxFormatKind type exposes the following members.

Members
Show:
Name Description
fkBoolean

Boolean format.

fkDateTime

Date time format.

dd.mm.yyyy - date of the 23.12.2003 type;
dd mmm yyyy - dateof the 23 Nov. 2003 type;
dd mmmm yyyy - date of the 23 November 2003 type;
hh:mm - time of the 23:12 type;
hh:mm:ss - time of the 23:12:00 type;
dd mmmm yyyy, hh:mm -time and date of the 23 November 2003, 23:12 type

fkNumeric

Numeric format.

%g - a number with the minimal signs number after decimal point;
%2.2f - a number with the fixed number of signs after decimal point;
%2.2n - a number with bits delimiter;
%2.2m - a monetary format, accepted in the Windows OS, depending on the regional settings in the control panel.

fkText

Text format.

Top
See Also

Reference

  • frxClass


TfrxFrameStyle Enumeration

Summary

Style of the frame line.

Namespace: frxClass
Syntax
Delphi
type
 TfrxFrameStyle = (
 fsSolid,
 fsDash,
 fsDot,
 fsDashDot,
 fsDashDotDot,
 fsDouble,
 fsAltDot,
 fsSquare);

The TfrxFrameStyle type exposes the following members.

Members
Show:
Name | Description
fsAltDot | Alternative dots style.
fsDash | Dash style.
fsDashDot | Dash dot style.
fsDashDotDot | Dash dot dot style.
fsDot | Dot style.
fsDouble | Double line style.
fsSolid | Solid line.
fsSquare | Squares instead of dots.
Top
See Also

Reference

  • frxClass


TfrxFrameType Enumeration

Summary

Type of the frame line.

Namespace: frxClass
Syntax
Delphi
type
 TfrxFrameType = (
 ftLeft,
 ftRight,
 ftTop,
 ftBottom);

The TfrxFrameType type exposes the following members.

Members
Show:
Name | Description
ftBottom | Bottom frame.
ftLeft | Left frame.
ftRight | Right frame.
ftTop | Top frame.
Top
See Also

Reference

  • frxClass


TfrxGlassFillOrientation Enumeration

Summary

Orientation type of glass fill.

Namespace: frxClass
Syntax
Delphi
type
 TfrxGlassFillOrientation = (
 foVertical,
 foHorizontal,
 foVerticalMirror,
 foHorizontalMirror);

The TfrxGlassFillOrientation type exposes the following members.

Members
Show:
Name | Description
foHorizontal | Horizontal.
foHorizontalMirror | Horizontal mirrored.
foVertical | Vertical.
foVerticalMirror | Vertical mirrored.
Top
See Also

Reference

  • frxClass


TfrxGradientStyle Enumeration

Summary

Gradient fill styles.

Namespace: frxClass
Syntax
Delphi
type
 TfrxGradientStyle = (
 gsHorizontal,
 gsVertical,
 gsElliptic,
 gsRectangle,
 gsVertCenter,
 gsHorizCenter);

The TfrxGradientStyle type exposes the following members.

Members
Show:
Name | Description
gsElliptic | Elliptic gradient.
gsHorizCenter | Horizontal centered gradient.
gsHorizontal | Horizontal gradient.
gsRectangle | Rectangle gradient.
gsVertCenter | Vertical centered gradient.
gsVertical | Vertical gradient.
Top
See Also

Reference

  • frxClass


TfrxGridType Enumeration

Summary

Grid type in the report designer.

Namespace: frxClass
Syntax
Delphi
type
 TfrxGridType = (gt1pt, gt1cm, gt1in, gtDialog, gtChar, gtNone);

The TfrxGridType type exposes the following members.

Members
Show:
Name | Description
gt1cm | Represents constant gt1cm.
gt1in | Represents constant gt1in.
gt1pt | Represents constant gt1pt.
gtChar | Represents constant gtChar.
gtDialog | Represents constant gtDialog.
gtNone | Represents constant gtNone.
Top
See Also

Reference

  • frxClass


TfrxHAlign Enumeration

Summary

The horizontal alignment of the text in the "Text" object.

Namespace: frxClass
Syntax
Delphi
type
 TfrxHAlign = (haLeft, haRight, haCenter, haBlock);

The TfrxHAlign type exposes the following members.

Members
Show:
Name | Description
haBlock | Represents constant haBlock.
haCenter | Represents constant haCenter.
haLeft | Represents constant haLeft.
haRight | Represents constant haRight.
Top
See Also

Reference

  • frxClass


TfrxHyperlinkKind Enumeration

Summary

Type of hyperlinks supported by report objects.

Namespace: frxClass
Syntax
Delphi
type
 TfrxHyperlinkKind = (
 hkURL,
 hkAnchor,
 hkPageNumber,
 hkDetailReport,
 hkDetailPage,
 hkCustom,
 hkNone);

The TfrxHyperlinkKind type exposes the following members.

Members
Show:
Name | Description
hkAnchor | Anchor to position inside prepared report.
hkCustom | Reserved.
hkDetailPage | Reference to detail page.
hkDetailReport | Link to detail report.
hkNone | Disabled.
hkPageNumber | Link to a page number in prepared report.
hkURL | hyper link to HTTP.
Top
See Also

Reference

  • frxClass


TfrxInheriteMode Enumeration

Summary

The inherit mode type.

Namespace: frxClass
Syntax
Delphi
type
 TfrxInheriteMode = (
 imDefault,
 imDelete,
 imRename);

The TfrxInheriteMode type exposes the following members.

Members
Show:
Name | Description
imDefault | Shows inherit dialog.
imDelete | Delete duplicates.
imRename | Rename duplicates
Top
See Also

Reference

  • frxClass


TfrxInteractiveEventSender Enumeration

Summary

Type of interactive event sender.

Namespace: frxClass
Syntax
Delphi
type
 TfrxInteractiveEventSender = (
 esDesigner,
 esPreview);

The TfrxInteractiveEventSender type exposes the following members.

Members
Show:
Name | Description
esDesigner | The report designer.
esPreview | The report preview.
Top
See Also

Reference

  • frxClass


TfrxInteractiveHighlightEvent Enumeration

Summary

Reserved.

Namespace: frxClass
Syntax
Delphi
type
 TfrxInteractiveHighlightEvent = (ihNone, ihClick, ihEnter, ieLeave);

The TfrxInteractiveHighlightEvent type exposes the following members.

Members
Show:
Name | Description
ieLeave | Represents constant ieLeave.
ihClick | Represents constant ihClick.
ihEnter | Represents constant ihEnter.
ihNone | Represents constant ihNone.
Top
See Also

Reference

  • frxClass


TfrxIOTransportStream Enumeration

Summary

Supported stream type for current IO transport filter.

Namespace: frxClass
Syntax
Delphi
type
 TfrxIOTransportStream = (
 tsIORead,
 tsIOWrite);

The TfrxIOTransportStream type exposes the following members.

Members
Show:
Name | Description
tsIORead | IO filter supports Read operations.
tsIOWrite | IO filter supports Write operations.
Top
See Also

Reference

  • frxClass


TfrxMirrorControlMode Enumeration

Summary

Mirror mode. Determinate how engine align controls and content base on original layout.

Namespace: frxClass
Syntax
Delphi
type
 TfrxMirrorControlMode = (
 mcmRTLBands,
 mcmRTLObjects,
 mcmRTLAppearance,
 mcmRTLContent,
 mcmRTLSpecial,
 mcmBTTBands,
 mcmBTTObjects,
 mcmBTTAppearance,
 mcmBTTContent,
 mcmBTTSpecial,
 mcmOnlyAllowed);

The TfrxMirrorControlMode type exposes the following members.

Members
Show:
Name | Description
mcmBTTAppearance | Mirror appearance from Top to Bottom.
mcmBTTBands | Mirror bands positions from Top to Bottom.
mcmBTTContent | Mirror content of objects from Top to Bottom.
mcmBTTObjects | Mirror objects positions from Top to Bottom.
mcmBTTSpecial | Reserved.
mcmOnlyAllowed | Apply mirror mode setting only for objects which have AllowMirrorMode property set to true.
mcmRTLAppearance | Mirror appearance from right to left.
mcmRTLBands | Mirror bands positions(page columns) from right to left.
mcmRTLContent | Mirror content of objects from right to left.
mcmRTLObjects | Mirror objects positions from right to left.
mcmRTLSpecial | Sets RTLReading flag of "Text" object.
Top
See Also

Reference

  • frxClass


TfrxMouseIntEvents Enumeration

Summary

Type of mouse interactive events supported by report objects.

Namespace: frxClass
Syntax
Delphi
type
 TfrxMouseIntEvents = (
 meClick,
 meDbClick,
 meMouseMove,
 meMouseUp,
 meMouseDown,
 meDragOver,
 meDragDrop,
 meMouseWheel);

The TfrxMouseIntEvents type exposes the following members.

Members
Show:
Name | Description
meClick | Click on object.
meDbClick | Double click on object.
meDragDrop | Drop something on object.
meDragOver | Drag something over on object.
meMouseDown | Mouse down.
meMouseMove | Mouse moved over object.
meMouseUp | Mouse up.
meMouseWheel | Mouse wheel event.
Top
See Also

Reference

  • frxClass


TfrxPreviewButton Enumeration

Summary

Buttons that can be displayed in the preview window.

Namespace: frxClass
Syntax
Delphi
type
 TfrxPreviewButton = (
 pbPrint,
 pbLoad,
 pbSave,
 pbExport,
 pbZoom,
 pbFind,
 pbOutline,
 pbPageSetup,
 pbTools,
 pbEdit,
 pbNavigator,
 pbExportQuick,
 pbNoClose,
 pbNoFullScreen,
 pbNoEmail,
 pbCopy,
 pbPaste,
 pbSelection,
 pbInplaceEdit);

The TfrxPreviewButton type exposes the following members.

Members
Show:
Name | Description
pbCopy | Copy in context menu.
pbEdit | Edit button. Calls report designer for preview page.
pbExport | Export button.
pbExportQuick | Quick export button.
pbFind | Find.
pbInplaceEdit | Allows InPlace editor in the report preview. Enables "Highlight editable text" button.
pbLoad | Load.
pbNavigator | Page navigator.
pbNoClose | Disables close button.
pbNoEmail | Disables e-mail export button.
pbNoFullScreen | Disables full screen mode.
pbOutline | Outline button.
pbPageSetup | Page setup button.
pbPaste | Paste in context menu.
pbPrint | Print button.
pbSave | Save button.
pbSelection | Enables selection in the report preview (Shift + left mouse button).
pbTools | Deprecated. Not used.
pbZoom | Zoom buttons.
Top
See Also

Reference

  • frxClass


TfrxPrintMode Enumeration

Summary

The print mode.

Namespace: frxClass
Syntax
Delphi
type
 TfrxPrintMode = (
 pmDefault,
 pmSplit,
 pmJoin,
 pmScale);

The TfrxPrintMode type exposes the following members.

Members
Show:
Name | Description
pmDefault | Default mode.
pmJoin | Join several small pages on a large page.
pmScale | Print a page on a specified paper size (use scaling).
pmSplit | Split large page on several smaller pages.
Top
See Also

Reference

  • frxClass


TfrxPrintOnType Enumeration

Summary

Reserved for future use.

Namespace: frxClass
Syntax
Delphi
type
 TfrxPrintOnType = (ptFirstPage, ptLastPage, ptOddPages, ptEvenPages, ptRepeatedBand);

The TfrxPrintOnType type exposes the following members.

Members
Show:
Name | Description
ptEvenPages | Represents constant ptEvenPages.
ptFirstPage | Represents constant ptFirstPage.
ptLastPage | Represents constant ptLastPage.
ptOddPages | Represents constant ptOddPages.
ptRepeatedBand | Represents constant ptRepeatedBand.
Top
See Also

Reference

  • frxClass


TfrxPrintPages Enumeration

Summary

Pages to print.

Namespace: frxClass
Syntax
Delphi
type
 TfrxPrintPages = (
 ppAll,
 ppOdd,
 ppEven);

The TfrxPrintPages type exposes the following members.

Members
Show:
Name | Description
ppAll | All pages.
ppEven | Only even pages.
ppOdd | Only odd pages.
Top
See Also

Reference

  • frxClass


TfrxProcessAtMode Enumeration

Summary

Controls when to process expression calculation(for some TfrxView objects).

Namespace: frxClass
Syntax
Delphi
type
 TfrxProcessAtMode = (
 paDefault,
 paReportFinished,
 paReportPageFinished,
 paPageFinished,
 paColumnFinished,
 paDataFinished,
 paGroupFinished,
 paCustom);

The TfrxProcessAtMode type exposes the following members.

Members
Show:
Name | Description
paColumnFinished | Processes when column finished.
paCustom | Processes by user from script code.
paDataFinished | Processes when data finished.
paDefault | By Default. When engine processes object.
paGroupFinished | Processes when group finished.
paPageFinished | Processes when page finished.
paReportFinished | Processes when report finished.
paReportPageFinished | Processes when report page finished.
Top
See Also

Reference

  • frxClass


TfrxProgressType Enumeration

Summary

The kind of action in the OnProgressXXX event: run a report, export, print.

Namespace: frxClass
Syntax
Delphi
type
 TfrxProgressType = (
 ptRunning,
 ptExporting,
 ptPrinting);

The TfrxProgressType type exposes the following members.

Members
Show:
Name | Description
ptExporting | Export state.
ptPrinting | Printing state.
ptRunning | Report preparing state.
Top
See Also

Reference

  • frxClass


TfrxRangeBegin Enumeration

Summary

The navigation start point.

Namespace: frxClass
Syntax
Delphi
type
 TfrxRangeBegin = (
 rbFirst,
 rbCurrent);

The TfrxRangeBegin type exposes the following members.

Members
Show:
Name | Description
rbCurrent | From the beginning of the data.
rbFirst | From the current record.
Top
See Also

Reference

  • frxClass


TfrxRangeEnd Enumeration

Summary

The endpoint of navigation.

Namespace: frxClass
Syntax
Delphi
type
 TfrxRangeEnd = (
 reLast,
 reCurrent,
 reCount);

The TfrxRangeEnd type exposes the following members.

Members
Show:
Name | Description
reCount | By the number of records set in the "RangeEndCount" property.
reCurrent | Till the current record
reLast | Till the end of the data
Top
See Also

Reference

  • frxClass


TfrxRestriction Enumeration

Summary

Flags, used to restrict some object operations in the designer.

Namespace: frxClass
Syntax
Delphi
type
 TfrxRestriction = (rfDontModify, rfDontSize, rfDontMove, rfDontDelete, rfDontEdit, rfDontEditInPreview, rfDontCopy);

The TfrxRestriction type exposes the following members.

Members
Show:
Name | Description
rfDontCopy | Represents constant rfDontCopy.
rfDontDelete | Represents constant rfDontDelete.
rfDontEdit | Represents constant rfDontEdit.
rfDontEditInPreview | Represents constant rfDontEditInPreview.
rfDontModify | Represents constant rfDontModify.
rfDontMove | Represents constant rfDontMove.
rfDontSize | Represents constant rfDontSize.
Top
See Also

Reference

  • frxClass


TfrxScrollerOrientation Enumeration

Summary

Represent scrollbar orientation.

Namespace: frxClass
Syntax
Delphi
type
 TfrxScrollerOrientation = (
 frsHorizontal,
 frsVertical);

The TfrxScrollerOrientation type exposes the following members.

Members
Show:
Name | Description
frsHorizontal | Horizontal.
frsVertical | Vertical.
Top
See Also

Reference

  • frxClass


TfrxSerializeState Enumeration

Summary

Controls serialization state (Not used yet).

Namespace: frxClass
Syntax
Delphi
type
 TfrxSerializeState = (
 ssTemplate,
 ssPreviewPages);

The TfrxSerializeState type exposes the following members.

Members
Show:
Name | Description
ssPreviewPages | Object serializes to a prepared report.
ssTemplate | Object serializes to a report template.
Top
See Also

Reference

  • frxClass


TfrxShapeKind Enumeration

Summary

Kind of shape.

Namespace: frxClass
Syntax
Delphi
type
 TfrxShapeKind = (
 skRectangle,
 skRoundRectangle,
 skEllipse,
 skTriangle,
 skDiamond,
 skDiagonal1,
 skDiagonal2);

The TfrxShapeKind type exposes the following members.

Members
Show:
Name | Description
skDiagonal1 | Diagonal line from bottom left to top right.
skDiagonal2 | Diagonal line from top left to bottom right.
skDiamond | Diamond.
skEllipse | Ellipse.
skRectangle | Rectangle.
skRoundRectangle | Rectangle with round corners.
skTriangle | Triangle.
Top
See Also

Reference

  • frxClass


TfrxShiftEngine Enumeration

Summary

Determine how container shifts its child object.

Namespace: frxClass
Syntax
Delphi
type
 TfrxShiftEngine = (
 seLinear,
 seTree,
 seDontShift);

The TfrxShiftEngine type exposes the following members.

Members
Show:
Name | Description
seDontShift | Shift mechanism disabled. May increase speed.
seLinear | Linear shift mechanism used.
seTree | Tree shift mechanism used. Default.
Top
See Also

Reference

  • frxClass


TfrxShiftMode Enumeration

Summary

Shift mode of the object. Behaviour depends on what type of TfrxShiftEngine selected in parent container.

Namespace: frxClass
Syntax
Delphi
type
 TfrxShiftMode = (
 smDontShift,
 smAlways,
 smWhenOverlapped);

The TfrxShiftMode type exposes the following members.

Members
Show:
Name | Description
smAlways | Shift the object if the above objects are stretching(for seLinear shifts even if there is no overlying objects).
smDontShift | Don't shift the object.
smWhenOverlapped | Shift the object if it is overlapped by the above objects(for seLinear consider vertical space between objects).
Top
See Also

Reference

  • frxClass


TfrxSilentMode Enumeration

Summary

Represents type TfrxSilentMode.

Namespace: frxClass
Syntax
Delphi
type
 TfrxSilentMode = (simMessageBoxes, simSilent, simReThrow);

The TfrxSilentMode type exposes the following members.

Members
Show:
Name | Description
simMessageBoxes | Represents constant simMessageBoxes.
simReThrow | Represents constant simReThrow.
simSilent | Represents constant simSilent.
Top
See Also

Reference

  • frxClass


TfrxStretchMode Enumeration

Summary

Stretch mode of the text objects.

Namespace: frxClass
Syntax
Delphi
type
 TfrxStretchMode = (
 smDontStretch,
 smActualHeight,
 smMaxHeight);

The TfrxStretchMode type exposes the following members.

Members
Show:
Name | Description
smActualHeight | Don't stretch the object.
smDontStretch | Stretch the object so all text would fit.
smMaxHeight | Stretch the object to the max height of the parent band.
Top
See Also

Reference

  • frxClass


TfrxToNRowsMode Enumeration

Summary

This flags used in a child band to complete data band upto specified number of rows (fill the space with an empty rows). If data band has less number of rows, the empty row will be printed.

Namespace: frxClass
Syntax
Delphi
type
 TfrxToNRowsMode = (
 rmCount,
 rmAddToCount,
 rmTillPageEnds);

The TfrxToNRowsMode type exposes the following members.

Members
Show:
Name | Description
rmAddToCount | It adds N rows to current Data band.
rmCount | It prints rows until reaches N records count.
rmTillPageEnds | It fills page with "Child" band till the end of the page reached.
Top
See Also

Reference

  • frxClass


TfrxUnderlinesTextMode Enumeration

Summary

Underlines text mode for "Text" object.

Namespace: frxClass
Syntax
Delphi
type
 TfrxUnderlinesTextMode = (
 ulmNone,
 ulmUnderlinesAll,
 ulmUnderlinesText,
 ulmUnderlinesTextAndEmptyLines);

The TfrxUnderlinesTextMode type exposes the following members.

Members
Show:
Name | Description
ulmNone | Disabled.
ulmUnderlinesAll | Underline whole object.
ulmUnderlinesText | Underline only lines with text.
ulmUnderlinesTextAndEmptyLines | Underline text lines and empty lines.
Top
See Also

Reference

  • frxClass


TfrxVAlign Enumeration

Summary

The vertical alignment of the text in the "Text" object.

Namespace: frxClass
Syntax
Delphi
type
 TfrxVAlign = (vaTop, vaBottom, vaCenter);

The TfrxVAlign type exposes the following members.

Members
Show:
Name | Description
vaBottom | Represents constant vaBottom.
vaCenter | Represents constant vaCenter.
vaTop | Represents constant vaTop.
Top
See Also

Reference

  • frxClass


TfrxVisibilityType Enumeration

Summary

Visibility of object in the result report.

Namespace: frxClass
Syntax
Delphi
type
 TfrxVisibilityType = (
 vsPreview,
 vsExport,
 vsPrint);

The TfrxVisibilityType type exposes the following members.

Members
Show:
Name | Description
vsExport | Objects visible for exports.
vsPreview | Objects visible for preview.
vsPrint | Objects visible for printing.
Top
See Also

Reference

  • frxClass


TfrxZoomMode Enumeration

Summary

Zoom mode of the preview window.

Namespace: frxClass
Syntax
Delphi
type
 TfrxZoomMode = (
 zmDefault,
 zmWholePage,
 zmPageWidth,
 zmManyPages);

The TfrxZoomMode type exposes the following members.

Members
Show:
Name | Description
zmDefault | Default mode.
zmManyPages | Fit several pages.
zmPageWidth | Fit page by its width.
zmWholePage | Fit whole page.
Top
See Also

Reference

  • frxClass


frxClass Delegates

Delegates
Name | Description
TfrxAfterDisconnectEvent | Occurs when the report engine close connection to database for internal database components.
TfrxBeforeConnectEvent | Occurs when the report engine establish connection to database for internal database components.
TfrxBeforePrintEvent | This event is fired each time before printing an report's object.
TfrxCheckEOFEvent | This event's handler must return the Eof = True parameter, if the end of the data set is reached.
TfrxClickObjectEvent | Occurs when report is previewed in the preview window and user click on object.
TfrxEditConnectionEvent | Occurs when user edit connection in the report wizard.
TfrxGetBlobValueEvent | This event is fired when an unknown variable (VarName) is met and IsBlobField event returns True(BLOB type). AssignTo parameter contains an object in which data should be loaded (TWideStrings for "Text" object).
TfrxGetCustomDataEvent | This event fires when engine loads report XML file and file contains XML item <FrxCustomData>(i.e. store user data inside XML file). All child nodes in this item ignores by serializer. XMLItem contains all the custom user data.
TfrxGetScriptValueEvent | Represents type TfrxGetScriptValueEvent.
TfrxGetValueEvent | This event is fired when an unknown variable (VarName) is met. An event handler must return the value of this variable in the Value parameter.
TfrxIsBlobFieldEvent | An event fires when engine checks type of an assigned field. The result tells report engine how to interpret the field with name 'FileldName'. Returns True if it's a BLOB field. In this case OnGetBlobValue event will fire.
TfrxLoadDetailTemplateEvent | Occurs when a report object loads detail report. The event handler must load the report template (given by TemplateName parameter) into Report object with using parameters of AHyperlink.
TfrxLoadEvent | Represents type TfrxLoadEvent.
TfrxLoadTemplateEvent | Occurs when a report is an inherited report. The event handler must load the report template (given by TemplateName parameter) into Report object.
TfrxManualBuildEvent | If the handler of this event is allocated, then the FastReport engine is blocked and you thus would have to construct a report manually.
TfrxMouseEnterEvent | Occurs when report is previewed in the preview window and mouse pointer enters object rect area.
TfrxMouseLeaveEvent | Occurs when report is previewed in the preview window and mouse pointer leaves object rect area.
TfrxMouseOverObjectEvent | Occurs when report is previewed in the preview window and user moves the mouse over the object.
TfrxNewGetValueEvent | This event is fired when an unknown variable (VarName) is met. An event handler must return the value of this variable in the Value parameter. New event has a Sender parameter and pass a report objects which calls an event.
TfrxNodeChanging | Notification of Tree node item. Used to notify about changes of item(Add/Remove).
TfrxObjectsNotifyEvent | List notification event.
TfrxOnFinishInPlaceEdit | Used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor.
TfrxPrintPageEvent | Occurs when a report is an inherited report. The event handler must load the report template (given by TemplateName parameter) into Report object.
TfrxProgressEvent | This event is fired when performing some continues operation (print, export, run report). The event handler may display a dialog window with progress bar. Progress parameter is the page number which is currently being processed.
TfrxRunDialogEvent | Occurs when report dialog page is previewed.
TfrxSaveCustomDataEvent | This event fires when serializer saves report template to XML(i.e. store user data inside XML file). If event is set, serializer creates <FrxCustomData> node and pass it as a parameter. Programmer may use this node to create child nodes with custom data.
TfrxSetConnectionEvent | Occurs when user set ConnectionNeme property. Internal use.
TfrxUserFunctionEvent | This event is fired when calling a function (MethodName), added with the help of the TfrxReport.AddFunction method. The event handler should return a value of the function.
Top


TfrxAfterDisconnectEvent Delegate

Summary

Occurs when the report engine close connection to database for internal database components.

Namespace: frxClass
Syntax
Delphi
type
 TfrxAfterDisconnectEvent = procedure(Sender: TfrxCustomDatabase) of object;
See Also

Reference

  • frxClass


TfrxBeforeConnectEvent Delegate

Summary

Occurs when the report engine establish connection to database for internal database components.

Namespace: frxClass
Syntax
Delphi
type
 TfrxBeforeConnectEvent = procedure(Sender: TfrxCustomDatabase; var Connected: Boolean) of object;
See Also

Reference

  • frxClass


TfrxBeforePrintEvent Delegate

Summary

This event is fired each time before printing an report's object.

Namespace: frxClass
Syntax
Delphi
type
 TfrxBeforePrintEvent = procedure(Sender: TfrxReportComponent) of object;
See Also

Reference

  • frxClass


TfrxCheckEOFEvent Delegate

Summary

This event's handler must return the Eof = True parameter, if the end of the data set is reached.

Namespace: frxClass
Syntax
Delphi
type
 TfrxCheckEOFEvent = procedure(Sender: TObject; var Eof: Boolean) of object;
See Also

Reference

  • frxClass


TfrxClickObjectEvent Delegate

Summary

Occurs when report is previewed in the preview window and user click on object.

Namespace: frxClass
Syntax
Delphi
type
 TfrxClickObjectEvent = procedure(Sender: TfrxView;
 Button: TMouseButton; Shift: TShiftState; var Modified: Boolean) of object;
See Also

Reference

  • frxClass


TfrxEditConnectionEvent Delegate

Summary

Occurs when user edit connection in the report wizard.

Namespace: frxClass
Syntax
Delphi
type
 TfrxEditConnectionEvent = function(const ConnString: String): String of object;
See Also

Reference

  • frxClass


TfrxGetBlobValueEvent Delegate

Summary

This event is fired when an unknown variable (VarName) is met and IsBlobField event returns True(BLOB type). AssignTo parameter contains an object in which data should be
loaded (TWideStrings for "Text" object).

Namespace: frxClass
Syntax
Delphi
type
 TfrxGetBlobValueEvent = procedure(Sender: TObject; const FileldName: String; AssignTo: TObject) of object;
See Also

Reference

  • frxClass


TfrxGetCustomDataEvent Delegate

Summary

This event fires when engine loads report XML file and file contains XML item <FrxCustomData>(i.e. store user data inside XML file). All child nodes in this item ignores by
serializer. XMLItem contains all the custom user data.

Namespace: frxClass
Syntax
Delphi
type
 TfrxGetCustomDataEvent = procedure(XMLItem: TfrxXMLItem) of object;
See Also

Reference

  • frxClass


TfrxGetScriptValueEvent Delegate

Summary

Represents type TfrxGetScriptValueEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxGetScriptValueEvent = function(var Params: Variant): Variant of object;
See Also

Reference

  • frxClass


TfrxGetValueEvent Delegate

Summary

This event is fired when an unknown variable (VarName) is met. An event handler must return the value of this variable in the Value parameter.

Namespace: frxClass
Syntax
Delphi
type
 TfrxGetValueEvent = procedure(const VarName: String; var Value: Variant) of object;
See Also

Reference

  • frxClass


TfrxIsBlobFieldEvent Delegate

Summary

An event fires when engine checks type of an assigned field. The result tells report engine how to interpret the field with name 'FileldName'. Returns True if it's a BLOB field. In this case OnGetBlobValue event will fire.

Namespace: frxClass
Syntax
Delphi
type
 TfrxIsBlobFieldEvent = function(Sender: TObject; const FileldName: String): Boolean of object;
See Also

Reference

  • frxClass


TfrxLoadDetailTemplateEvent Delegate

Summary

Occurs when a report object loads detail report. The event handler must load the report template (given by TemplateName parameter) into Report object with using parameters of AHyperlink.

Namespace: frxClass
Syntax
Delphi
type
 TfrxLoadDetailTemplateEvent = function(Report :TfrxReport; const TemplateName :String; const AHyperlink :TfrxHyperlink): Boolean of object;
See Also

Reference

  • frxClass


TfrxLoadEvent Delegate

Summary

Represents type TfrxLoadEvent.

Namespace: frxClass
Syntax
Delphi
type
 TfrxLoadEvent = function(Sender: TfrxReport; Stream: TStream): Boolean of object;
See Also

Reference

  • frxClass


TfrxLoadTemplateEvent Delegate

Summary

Occurs when a report is an inherited report. The event handler must load the report template (given by TemplateName parameter) into Report object.

Namespace: frxClass
Syntax
Delphi
type
 TfrxLoadTemplateEvent = procedure(Report: TfrxReport; const TemplateName: String) of object;
See Also

Reference

  • frxClass


TfrxManualBuildEvent Delegate

Summary

If the handler of this event is allocated, then the FastReport engine is blocked and you thus would have to construct a report manually.

Namespace: frxClass
Syntax
Delphi
type
 TfrxManualBuildEvent = procedure(Page: TfrxPage) of object;
See Also

Reference

  • frxClass


TfrxMouseEnterEvent Delegate

Summary

Occurs when report is previewed in the preview window and mouse pointer enters object rect area.

Namespace: frxClass
Syntax
Delphi
type
 TfrxMouseEnterEvent = procedure(Sender: TfrxView) of object;
See Also

Reference

  • frxClass


TfrxMouseLeaveEvent Delegate

Summary

Occurs when report is previewed in the preview window and mouse pointer leaves object rect area.

Namespace: frxClass
Syntax
Delphi
type
 TfrxMouseLeaveEvent = procedure(Sender: TfrxView) of object;
See Also

Reference

  • frxClass


TfrxMouseOverObjectEvent Delegate

Summary

Occurs when report is previewed in the preview window and user moves the mouse over the object.

Namespace: frxClass
Syntax
Delphi
type
 TfrxMouseOverObjectEvent = procedure(Sender: TfrxView) of object;
See Also

Reference

  • frxClass


TfrxNewGetValueEvent Delegate

Summary

This event is fired when an unknown variable (VarName) is met. An event handler must return the value of this variable in the Value parameter. New event has a Sender parameter and pass a report objects which calls an event.

Namespace: frxClass
Syntax
Delphi
type
 TfrxNewGetValueEvent = procedure(Sender: TObject; const VarName: String; var Value: Variant) of object;
See Also

Reference

  • frxClass


TfrxNodeChanging Delegate

Summary

Notification of Tree node item. Used to notify about changes of item(Add/Remove).

Namespace: frxClass
Syntax
Delphi
type
 TfrxNodeChanging = procedure(const Name: String; bUseRemoveList: Boolean = False; aObject: TObject = nil) of object;
See Also

Reference

  • frxClass


TfrxObjectsNotifyEvent Delegate

Summary

List notification event.

Namespace: frxClass
Syntax
Delphi
type
 TfrxObjectsNotifyEvent = procedure(Ptr: Pointer; Action: TListNotification) of object;
See Also

Reference

  • frxClass


TfrxOnFinishInPlaceEdit Delegate

Summary

Used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor.

Namespace: frxClass
Syntax
Delphi
type
 TfrxOnFinishInPlaceEdit = procedure(Sender: TObject; Refresh, Modified: Boolean) of object;
See Also

Reference

  • frxClass


TfrxPrintPageEvent Delegate

Summary

Occurs when a report is an inherited report. The event handler must load the report template (given by TemplateName parameter) into Report object.

Namespace: frxClass
Syntax
Delphi
type
 TfrxPrintPageEvent = procedure(Page: TfrxReportPage; CopyNo: Integer) of object;
See Also

Reference

  • frxClass


TfrxProgressEvent Delegate

Summary

This event is fired when performing some continues operation (print, export, run report). The event handler may display a dialog window with progress bar. Progress parameter is the page number which is currently being processed.

Namespace: frxClass
Syntax
Delphi
type
 TfrxProgressEvent = procedure(Sender: TfrxReport;
 ProgressType: TfrxProgressType; Progress: Integer) of object;
See Also

Reference

  • frxClass


TfrxRunDialogEvent Delegate

Summary

Occurs when report dialog page is previewed.

Namespace: frxClass
Syntax
Delphi
type
 TfrxRunDialogEvent = procedure(Page: TfrxDialogPage) of object;
See Also

Reference

  • frxClass


TfrxSaveCustomDataEvent Delegate

Summary

This event fires when serializer saves report template to XML(i.e. store user data inside XML file). If event is set, serializer creates <FrxCustomData> node and pass it as a parameter. Programmer may use this node to create child nodes with custom data.

Namespace: frxClass
Syntax
Delphi
type
 TfrxSaveCustomDataEvent = procedure(XMLItem: TfrxXMLItem) of object;
See Also

Reference

  • frxClass


TfrxSetConnectionEvent Delegate

Summary

Occurs when user set ConnectionNeme property. Internal use.

Namespace: frxClass
Syntax
Delphi
type
 TfrxSetConnectionEvent = procedure(const ConnString: String) of object;
See Also

Reference

  • frxClass


TfrxUserFunctionEvent Delegate

Summary

This event is fired when calling a function (MethodName), added with the help of the TfrxReport.AddFunction method. The event handler should return a value of the function.

Namespace: frxClass
Syntax
Delphi
type
 TfrxUserFunctionEvent = function(const MethodName: String;
 var Params: Variant): Variant of object;
See Also

Reference

  • frxClass


frxClass Types

Types
Name | Description
frxInteger | Represents an alias of the NativeInt type.
SYSINT | Represents an alias of the Integer type.
TfrxAnchors | Set of object anchors.
TfrxBandClass | Represents type TfrxBandClass.
TfrxComponentClass | Represents type TfrxComponentClass.
TfrxComponentEditorVisibility | Represents type TfrxComponentEditorVisibility.
TfrxComponentStyle | Styles on report component.
TfrxCompressorClass | Represents type TfrxCompressorClass.
TfrxCrypterClass | Represents type TfrxCrypterClass.
TfrxCustomIOTransportClass | Represents type TfrxCustomIOTransportClass.
TfrxCustomObjectPresetClass | Represents type TfrxCustomObjectPresetClass.
TfrxDesignerClass | Represents type TfrxDesignerClass.
TfrxFilterVisibility | Set of flags used in IO transports to define visibility of IO transport filter.
TfrxFrameTypes | Type of the frame line.
TfrxInPlaceEditorClass | Represents type TfrxInPlaceEditorClass.
TfrxIOTransportStreams | Set of flags for supported stream types by IO transport filter.
TfrxMirrorControlModes | Set of mirror modes.
TfrxPreviewButtons | Set of buttons that can be displayed in the preview window.
TfrxPrintOnTypes | Represents type TfrxPrintOnTypes.
TfrxRectArray | Represents an array of the TRect type.
TfrxRestrictions | Set of flags, which restrict some object operations in the designer.
TfrxVisibilityTypes | Visibility of object in the result report.
TfrxWizardClass | Represents type TfrxWizardClass.
Top


frxInteger Type

Summary

Represents an alias of the NativeInt type.

Namespace: frxClass
Syntax
Delphi
type
 frxInteger = NativeInt;
See Also

Reference

  • frxClass


SYSINT Type

Summary

Represents an alias of the Integer type.

Namespace: frxClass
Syntax
Delphi
type
 SYSINT = Integer;
See Also

Reference

  • frxClass


TfrxAnchors Type

Summary

Set of object anchors.

Namespace: frxClass
Syntax
Delphi
type
 TfrxAnchors = set of TfrxAnchorsKind;
See Also

Reference

  • frxClass


TfrxBandClass Type

Summary

Represents type TfrxBandClass.

Namespace: frxClass
Syntax
Delphi
type
 TfrxBandClass = class of TfrxBand;
See Also

Reference

  • frxClass


TfrxComponentClass Type

Summary

Represents type TfrxComponentClass.

Namespace: frxClass
Syntax
Delphi
type
 TfrxComponentClass = class of TfrxComponent;
See Also

Reference

  • frxClass


TfrxComponentEditorVisibility Type

Summary

Represents type TfrxComponentEditorVisibility.

Namespace: frxClass
Syntax
Delphi
type
 TfrxComponentEditorVisibility = set of TfrxComponentEditorVisibilityState;
See Also

Reference

  • frxClass


TfrxComponentStyle Type

Summary

Styles on report component.

Namespace: frxClass
Syntax
Delphi
type
 TfrxComponentStyle = set of (
 csContainer,
 csPreviewVisible,
 csDefaultDiff,
 csHandlesNestedProperties,
 csContained,
 csAcceptsFrxComponents,
 csObjectsContainer);

The TfrxComponentStyle type exposes the following members.

Members
Show:
Name | Description
csAcceptsFrxComponents | Report component may contain another report component, i.e. can be as parent container for others.
csContained | Report component can be child of another parent report container.
csContainer | Deprecated. used only for cross tabs object. Use csObjectsContainer instead.
csDefaultDiff | Use default RTTI serialization when object saves to prepared report(Default serialization to prepared report).
csHandlesNestedProperties | Determinates how to serialize internal non published composite objects. When flag is set composite object saves as new XML node.
csObjectsContainer | Report component is a object container. Flag used in default Copy/Paste buffer for containers like Table.
csPreviewVisible | Report component visible in the report preview(prepared report).
Top
See Also

Reference

  • frxClass


TfrxCompressorClass Type

Summary

Represents type TfrxCompressorClass.

Namespace: frxClass
Syntax
Delphi
type
 TfrxCompressorClass = class of TfrxCustomCompressor;
See Also

Reference

  • frxClass


TfrxCrypterClass Type

Summary

Represents type TfrxCrypterClass.

Namespace: frxClass
Syntax
Delphi
type
 TfrxCrypterClass = class of TfrxCustomCrypter;
See Also

Reference

  • frxClass


TfrxCustomIOTransportClass Type

Summary

Represents type TfrxCustomIOTransportClass.

Namespace: frxClass
Syntax
Delphi
type
 TfrxCustomIOTransportClass = class of TfrxCustomIOTransport;
See Also

Reference

  • frxClass


TfrxCustomObjectPresetClass Type

Summary

Represents type TfrxCustomObjectPresetClass.

Namespace: frxClass
Syntax
Delphi
type
 TfrxCustomObjectPresetClass = class of TfrxCustomObjectPreset;
See Also

Reference

  • frxClass


TfrxDesignerClass Type

Summary

Represents type TfrxDesignerClass.

Namespace: frxClass
Syntax
Delphi
type
 TfrxDesignerClass = class of TfrxCustomDesigner;
See Also

Reference

  • frxClass


TfrxFilterVisibility Type

Summary

Set of flags used in IO transports to define visibility of IO transport filter.

Namespace: frxClass
Syntax
Delphi
type
 TfrxFilterVisibility = set of TfrxFilterVisibleState;
See Also

Reference

  • frxClass


TfrxFrameTypes Type

Summary

Type of the frame line.

Namespace: frxClass
Syntax
Delphi
type
 TfrxFrameTypes = set of TfrxFrameType;
See Also

Reference

  • frxClass


TfrxInPlaceEditorClass Type

Summary

Represents type TfrxInPlaceEditorClass.

Namespace: frxClass
Syntax
Delphi
type
 TfrxInPlaceEditorClass = class of TfrxInPlaceEditor;
See Also

Reference

  • frxClass


TfrxIOTransportStreams Type

Summary

Set of flags for supported stream types by IO transport filter.

Namespace: frxClass
Syntax
Delphi
type
 TfrxIOTransportStreams = set of TfrxIOTransportStream;
See Also

Reference

  • frxClass


TfrxMirrorControlModes Type

Summary

Set of mirror modes.

Namespace: frxClass
Syntax
Delphi
type
 TfrxMirrorControlModes = set of TfrxMirrorControlMode;
See Also

Reference

  • frxClass


TfrxPreviewButtons Type

Summary

Set of buttons that can be displayed in the preview window.

Namespace: frxClass
Syntax
Delphi
type
 TfrxPreviewButtons = set of TfrxPreviewButton;
See Also

Reference

  • frxClass


TfrxPrintOnTypes Type

Summary

Represents type TfrxPrintOnTypes.

Namespace: frxClass
Syntax
Delphi
type
 TfrxPrintOnTypes = set of TfrxPrintOnType;
See Also

Reference

  • frxClass


TfrxRectArray Type

Summary

Represents an array of the TRect type.

Namespace: frxClass
Syntax
Delphi
type
 TfrxRectArray = array of TRect;
See Also

Reference

  • frxClass


TfrxRestrictions Type

Summary

Set of flags, which restrict some object operations in the designer.

Namespace: frxClass
Syntax
Delphi
type
 TfrxRestrictions = set of TfrxRestriction;
See Also

Reference

  • frxClass


TfrxVisibilityTypes Type

Summary

Visibility of object in the result report.

Namespace: frxClass
Syntax
Delphi
type
 TfrxVisibilityTypes = set of TfrxVisibilityType;
See Also

Reference

  • frxClass


TfrxWizardClass Type

Summary

Represents type TfrxWizardClass.

Namespace: frxClass
Syntax
Delphi
type
 TfrxWizardClass = class of TfrxCustomWizard;
See Also

Reference

  • frxClass


frxClass Variables

Variables
Name | Description
frxCharset | Represents variable frxCharset.
frxCompressorClass | Represents variable frxCompressorClass.
frxCrypterClass | Represents variable frxCrypterClass.
frxCS | Represents variable frxCS.
frxDefaultIODialogTransportClass | Represents variable frxDefaultIODialogTransportClass.
frxDefaultIOTransportClass | Represents variable frxDefaultIOTransportClass.
frxDefaultTempFilterClass | Represents variable frxDefaultTempFilterClass.
frxDesignerClass | Represents variable frxDesignerClass.
frxDotMatrixExport | Represents variable frxDotMatrixExport.
frxFR2Events | Represents variable frxFR2Events.
frxGlobalVariables | The global variables list available to all reports.
frxGUIThreadID | Represents variable frxGUIThreadID.
Top


frxCharset Variable

Summary

Represents variable frxCharset.

Namespace: frxClass
Syntax
Delphi
frxCharset: Integer = DEFAULT_CHARSET;

Value

Type: Integer

See Also

Reference

  • frxClass


frxCompressorClass Variable

Summary

Represents variable frxCompressorClass.

Namespace: frxClass
Syntax
Delphi
frxCompressorClass: TfrxCompressorClass;

Value

Type: TfrxCompressorClass

See Also

Reference

  • frxClass


frxCrypterClass Variable

Summary

Represents variable frxCrypterClass.

Namespace: frxClass
Syntax
Delphi
frxCrypterClass: TfrxCrypterClass;

Value

Type: TfrxCrypterClass

See Also

Reference

  • frxClass


frxCS Variable

Summary

Represents variable frxCS.

Namespace: frxClass
Syntax
Delphi
frxCS: TCriticalSection;

Value

Type: TCriticalSection

See Also

Reference

  • frxClass


frxDefaultIODialogTransportClass Variable

Summary

Represents variable frxDefaultIODialogTransportClass.

Namespace: frxClass
Syntax
Delphi
frxDefaultIODialogTransportClass: TfrxCustomIOTransportClass = nil;

Value

Type: TfrxCustomIOTransportClass

See Also

Reference

  • frxClass


frxDefaultIOTransportClass Variable

Summary

Represents variable frxDefaultIOTransportClass.

Namespace: frxClass
Syntax
Delphi
frxDefaultIOTransportClass: TfrxCustomIOTransportClass = nil;

Value

Type: TfrxCustomIOTransportClass

See Also

Reference

  • frxClass


frxDefaultTempFilterClass Variable

Summary

Represents variable frxDefaultTempFilterClass.

Namespace: frxClass
Syntax
Delphi
frxDefaultTempFilterClass: TfrxCustomIOTransportClass = nil;

Value

Type: TfrxCustomIOTransportClass

See Also

Reference

  • frxClass


frxDesignerClass Variable

Summary

Represents variable frxDesignerClass.

Namespace: frxClass
Syntax
Delphi
frxDesignerClass: TfrxDesignerClass;

Value

Type: TfrxDesignerClass

See Also

Reference

  • frxClass


frxDotMatrixExport Variable

Summary

Represents variable frxDotMatrixExport.

Namespace: frxClass
Syntax
Delphi
frxDotMatrixExport: TfrxCustomExportFilter;

Value

Type: TfrxCustomExportFilter

See Also

Reference

  • frxClass


frxFR2Events Variable

Summary

Represents variable frxFR2Events.

Namespace: frxClass
Syntax
Delphi
frxFR2Events: TfrxFR2Events;

Value

Type: TfrxFR2Events

See Also

Reference

  • frxClass


frxGlobalVariables Variable

Summary

The global variables list available to all reports.

Namespace: frxClass
Syntax
Delphi
frxGlobalVariables: TfrxVariables;

Value

Type: TfrxVariables

See Also

Reference

  • frxClass


frxGUIThreadID Variable

Summary

Represents variable frxGUIThreadID.

Namespace: frxClass
Syntax
Delphi
frxGUIThreadID: Cardinal;

Value

Type: Cardinal

See Also

Reference

  • frxClass


frxClass Constants

Constants
Name | Description
BND_COUNT | Represents constant BND_COUNT.
clTransparent | Default transparent color value.
crFormat | Cursor represents format sign.
crHand | Cursor represents hand sign.
crZoom | Cursor represents zoom sign.
DEF_REG_CONNECTIONS | Represents constant DEF_REG_CONNECTIONS.
fr01cm | Used to convert Pixels to millimeters.
fr01in | Used to convert Pixels to 0.X inches.
fr1CharX | Used to convert Pixels to char width(dot-matrix report).
fr1CharY | Used to convert Pixels to char height(dot-matrix report).
fr1cm | Used to convert Pixels to centimeters.
fr1in | Used to convert Pixels to inches.
frxBands | Represents constant frxBands.
frx_DefaultPPI | Represents default pixel per inch value.
FRX_OWNER_DESTROY_MESSAGE | Internal message. Used for synchronization between report component and Engine ShiftTree item. Sends when component destroying.
FR_VERSION | Represents constant FR_VERSION.
WM_CREATEHANDLE | Internal message. Sends to window controls during creation to synchronize creation of window control with main GDI thread.
WM_DESTROYHANDLE | Internal message. Sends to window controls during destroy to synchronize destroying of window control with main GDI thread.
Top


BND_COUNT Constant

Summary

Represents constant BND_COUNT.

Namespace: frxClass
Syntax
Delphi
 BND_COUNT = 18;

Value

Type: ShortInt

See Also

Reference

  • frxClass


clTransparent Constant

Summary

Default transparent color value.

Namespace: frxClass
Syntax
Delphi
 clTransparent: TColor = clNone;

Value

Type: TColor

See Also

Reference

  • frxClass


crFormat Constant

Summary

Cursor represents format sign.

Namespace: frxClass
Syntax
Delphi
 crFormat: Integer = 152;

Value

Type: Integer

See Also

Reference

  • frxClass


crHand Constant

Summary

Cursor represents hand sign.

Namespace: frxClass
Syntax
Delphi
 crHand: Integer = 150;

Value

Type: Integer

See Also

Reference

  • frxClass


crZoom Constant

Summary

Cursor represents zoom sign.

Namespace: frxClass
Syntax
Delphi
 crZoom: Integer = 151;

Value

Type: Integer

See Also

Reference

  • frxClass


DEF_REG_CONNECTIONS Constant

Summary

Represents constant DEF_REG_CONNECTIONS.

Namespace: frxClass
Syntax
Delphi
 DEF_REG_CONNECTIONS: String = '\Software\Fast Reports\Connections';

Value

Type: String

See Also

Reference

  • frxClass


fr01cm Constant

Summary

Used to convert Pixels to millimeters.

Namespace: frxClass
Syntax
Delphi
 fr01cm: Extended = 3.77953;

Value

Type: Extended

See Also

Reference

  • frxClass


fr01in Constant

Summary

Used to convert Pixels to 0.X inches.

Namespace: frxClass
Syntax
Delphi
 fr01in: Extended = 9.6;

Value

Type: Extended

See Also

Reference

  • frxClass


fr1CharX Constant

Summary

Used to convert Pixels to char width(dot-matrix report).

Namespace: frxClass
Syntax
Delphi
 fr1CharX: Extended = 9.6;

Value

Type: Extended

See Also

Reference

  • frxClass


fr1CharY Constant

Summary

Used to convert Pixels to char height(dot-matrix report).

Namespace: frxClass
Syntax
Delphi
 fr1CharY: Integer = 17;

Value

Type: Integer

See Also

Reference

  • frxClass


fr1cm Constant

Summary

Used to convert Pixels to centimeters.

Namespace: frxClass
Syntax
Delphi
 fr1cm: Extended = 37.7953;

Value

Type: Extended

See Also

Reference

  • frxClass


fr1in Constant

Summary

Used to convert Pixels to inches.

Namespace: frxClass
Syntax
Delphi
 fr1in: Integer = 96;

Value

Type: Integer

See Also

Reference

  • frxClass


frxBands Constant

Summary

Represents constant frxBands.

Namespace: frxClass
Syntax
Delphi
 frxBands: array[0..BND_COUNT - 1] of TfrxComponentClass =
 (TfrxReportTitle, TfrxReportSummary, TfrxPageHeader, TfrxPageFooter,
 TfrxHeader, TfrxFooter, TfrxMasterData, TfrxDetailData, TfrxSubdetailData,
 TfrxDataBand4, TfrxDataBand5, TfrxDataBand6, TfrxGroupHeader, TfrxGroupFooter,
 TfrxChild, TfrxColumnHeader, TfrxColumnFooter, TfrxOverlay);

Value

Type: array[0..BND_COUNT - 1] of TfrxComponentClass

See Also

Reference

  • frxClass


frx_DefaultPPI Constant

Summary

Represents default pixel per inch value.

Namespace: frxClass
Syntax
Delphi
 frx_DefaultPPI: Integer = 96;

Value

Type: Integer

See Also

Reference

  • frxClass


FRX_OWNER_DESTROY_MESSAGE Constant

Summary

Internal message. Used for synchronization between report component and Engine ShiftTree item. Sends when component destroying.

Namespace: frxClass
Syntax
Delphi
 FRX_OWNER_DESTROY_MESSAGE = $D001;

Value

Type: Word

See Also

Reference

  • frxClass


FR_VERSION Constant

Summary

Represents constant FR_VERSION.

Namespace: frxClass
Syntax
Delphi
 FR_VERSION = '6.8.0';

Value

Type: string

See Also

Reference

  • frxClass


WM_CREATEHANDLE Constant

Summary

Internal message. Sends to window controls during creation to synchronize creation of window control with main GDI thread.

Namespace: frxClass
Syntax
Delphi
 WM_CREATEHANDLE = WM_USER + 1;

Value

Type: Void

See Also

Reference

  • frxClass


WM_DESTROYHANDLE Constant

Summary

Internal message. Sends to window controls during destroy to synchronize destroying of window control with main GDI thread.

Namespace: frxClass
Syntax
Delphi
 WM_DESTROYHANDLE = WM_USER + 2;

Value

Type: Void

See Also

Reference

  • frxClass


frxClass Routines

Routines
Name | Description
frxCreateFill(TfrxFillType) | Represents method frxCreateFill(TfrxFillType).
frxFindDataSet(TfrxDataSet,String,TComponent) | This function searches for a DataSet on specified owner.
frxGetDataSetList(TStrings) | Represents method frxGetDataSetList(TStrings).
frxGetFillType(TfrxCustomFill) | Represents method frxGetFillType(TfrxCustomFill).
frxGetInPlaceEditor(TfrxComponentEditorsList,TfrxComponent) | Represents method frxGetInPlaceEditor(TfrxComponentEditorsList,TfrxComponent).
frxParentForm | Function returns a global form that may be useful for some add-in controls.
frxRegEditorsClasses | Represents method frxRegEditorsClasses.
rePadding(TComponent) | Represents method rePadding(TComponent).
Top


frxCreateFill(TfrxFillType) Method

Summary

Represents method frxCreateFill(TfrxFillType).

Namespace: frxClass
Syntax
Delphi
function frxCreateFill(const Value: TfrxFillType): TfrxCustomFill;

Parameters

Value
Type: TfrxFillType

Return Value

Type: TfrxCustomFill

See Also

Reference

  • frxClass


frxFindDataSet(TfrxDataSet,String,TComponent) Method

Summary

This function searches for a DataSet on specified owner.

Namespace: frxClass
Syntax
Delphi
function frxFindDataSet(DataSet: TfrxDataSet; const Name: String;
 Owner: TComponent): TfrxDataSet;

Parameters

DataSet
Type: TfrxDataSet

Name
Type: String

Owner
Type: TComponent

Return Value

Type: TfrxDataSet

See Also

Reference

  • frxClass


frxGetDataSetList(TStrings) Method

Summary

Represents method frxGetDataSetList(TStrings).

Namespace: frxClass
Syntax
Delphi
procedure frxGetDataSetList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • frxClass


frxGetFillType(TfrxCustomFill) Method

Summary

Represents method frxGetFillType(TfrxCustomFill).

Namespace: frxClass
Syntax
Delphi
function frxGetFillType(const Value: TfrxCustomFill): TfrxFillType;

Parameters

Value
Type: TfrxCustomFill

Return Value

Type: TfrxFillType

See Also

Reference

  • frxClass


frxGetInPlaceEditor(TfrxComponentEditorsList,TfrxComponent) Method

Summary

Represents method frxGetInPlaceEditor(TfrxComponentEditorsList,TfrxComponent).

Namespace: frxClass
Syntax
Delphi
function frxGetInPlaceEditor(aList: TfrxComponentEditorsList; aComponent: TfrxComponent): TfrxComponentEditorsManager;

Parameters

aList
Type: TfrxComponentEditorsList

aComponent
Type: TfrxComponent

Return Value

Type: TfrxComponentEditorsManager

See Also

Reference

  • frxClass


frxParentForm Method

Summary

Function returns a global form that may be useful for some add-in controls.

Namespace: frxClass
Syntax
Delphi
function frxParentForm: TForm;

Return Value

Type: TForm

See Also

Reference

  • frxClass


frxRegEditorsClasses Method

Summary

Represents method frxRegEditorsClasses.

Namespace: frxClass
Syntax
Delphi
function frxRegEditorsClasses: TfrxComponentEditorsClasses;

Return Value

Type: TfrxComponentEditorsClasses

See Also

Reference

  • frxClass


rePadding(TComponent) Method

Summary

Represents method rePadding(TComponent).

Namespace: frxClass
Syntax
Delphi
procedure rePadding(MForm: TComponent);

Parameters

MForm
Type: TComponent

See Also

Reference

  • frxClass


frxCodeUtils Namespace

Summary

Represents namespace frxCodeUtils.

Routines
Name | Description
frxAddCodeRes | Represents method frxAddCodeRes.
frxAddEvent(TStrings,String,PTypeInfo,String) | Represents method frxAddEvent(TStrings,String,PTypeInfo,String).
frxEmptyCode(TStrings,String) | Represents method frxEmptyCode(TStrings,String).
frxGetEventHandlersList(TStrings,String,PTypeInfo,TStrings) | Represents method frxGetEventHandlersList(TStrings,String,PTypeInfo,TStrings).
frxLocateEventHandler(TStrings,String,String) | Represents method frxLocateEventHandler(TStrings,String,String).
frxLocateMainProc(TStrings,String) | Represents method frxLocateMainProc(TStrings,String).
Top


frxCodeUtils Routines

Routines
Name | Description
frxAddCodeRes | Represents method frxAddCodeRes.
frxAddEvent(TStrings,String,PTypeInfo,String) | Represents method frxAddEvent(TStrings,String,PTypeInfo,String).
frxEmptyCode(TStrings,String) | Represents method frxEmptyCode(TStrings,String).
frxGetEventHandlersList(TStrings,String,PTypeInfo,TStrings) | Represents method frxGetEventHandlersList(TStrings,String,PTypeInfo,TStrings).
frxLocateEventHandler(TStrings,String,String) | Represents method frxLocateEventHandler(TStrings,String,String).
frxLocateMainProc(TStrings,String) | Represents method frxLocateMainProc(TStrings,String).
Top


frxAddCodeRes Method

Summary

Represents method frxAddCodeRes.

Namespace: frxCodeUtils
Syntax
Delphi
procedure frxAddCodeRes;
See Also

Reference

  • frxCodeUtils


frxAddEvent(TStrings,String,PTypeInfo,String) Method

Summary

Represents method frxAddEvent(TStrings,String,PTypeInfo,String).

Namespace: frxCodeUtils
Syntax
Delphi
function frxAddEvent(Code: TStrings; const Language: String;
 EventType: PTypeInfo; const EventName: String): Integer;

Parameters

Code
Type: TStrings

Language
Type: String

EventType
Type: PTypeInfo

EventName
Type: String

Return Value

Type: Integer

See Also

Reference

  • frxCodeUtils


frxEmptyCode(TStrings,String) Method

Summary

Represents method frxEmptyCode(TStrings,String).

Namespace: frxCodeUtils
Syntax
Delphi
procedure frxEmptyCode(Code: TStrings; const Language: String);

Parameters

Code
Type: TStrings

Language
Type: String

See Also

Reference

  • frxCodeUtils


frxGetEventHandlersList(TStrings,String,PTypeInfo,TStrings) Method

Summary

Represents method frxGetEventHandlersList(TStrings,String,PTypeInfo,TStrings).

Namespace: frxCodeUtils
Syntax
Delphi
procedure frxGetEventHandlersList(Code: TStrings; const Language: String;
 EventType: PTypeInfo; List: TStrings);

Parameters

Code
Type: TStrings

Language
Type: String

EventType
Type: PTypeInfo

List
Type: TStrings

See Also

Reference

  • frxCodeUtils


frxLocateEventHandler(TStrings,String,String) Method

Summary

Represents method frxLocateEventHandler(TStrings,String,String).

Namespace: frxCodeUtils
Syntax
Delphi
function frxLocateEventHandler(Code: TStrings; const Language,
 EventName: String): Integer;

Parameters

Code
Type: TStrings

Language
Type: String

EventName
Type: String

Return Value

Type: Integer

See Also

Reference

  • frxCodeUtils


frxLocateMainProc(TStrings,String) Method

Summary

Represents method frxLocateMainProc(TStrings,String).

Namespace: frxCodeUtils
Syntax
Delphi
function frxLocateMainProc(Code: TStrings; const Language: String): Integer;

Parameters

Code
Type: TStrings

Language
Type: String

Return Value

Type: Integer

See Also

Reference

  • frxCodeUtils


frxCollections Namespace

Summary

Represents namespace frxCollections.

Classes
Name | Description
TfrxCollection | Represents type TfrxCollection.
TfrxCollectionItem | Represents type TfrxCollectionItem.
Top


frxCollections Classes

Classes
Name | Description
TfrxCollection | Represents type TfrxCollection.
TfrxCollectionItem | Represents type TfrxCollectionItem.
Top


TfrxCollection Class

Summary

Represents type TfrxCollection.

Namespace: frxCollections
Inheritance Hierarchy
TCollection
frxCollections.TfrxCollection
frxClass.TfrxHighlightCollection
frxClass.TfrxStyles
frxVariables.TfrxVariables
Syntax
Delphi
type
 TfrxCollection = class(TCollection)
 end;

The TfrxCollection type exposes the following members.

Methods
Show:
Name | Description
DeserializeProperties(String,TObject,TfrxCollection) | Represents method DeserializeProperties(String,TObject,TfrxCollection).
FindByName(String) | Represents method FindByName(String).
SerializeProperties(TObject,TfrxCollection,TComponent) | Represents method SerializeProperties(TObject,TfrxCollection,TComponent).
Top
See Also

Reference

  • frxCollections


TfrxCollection Methods

Methods
Name | Description
DeserializeProperties(String,TObject,TfrxCollection) | Represents method DeserializeProperties(String,TObject,TfrxCollection).
FindByName(String) | Represents method FindByName(String).
SerializeProperties(TObject,TfrxCollection,TComponent) | Represents method SerializeProperties(TObject,TfrxCollection,TComponent).
Top


TfrxCollection.DeserializeProperties(String,TObject,TfrxCollection) Method

Summary

Represents method DeserializeProperties(String,TObject,TfrxCollection).

Namespace: frxCollections
Syntax
Delphi
public
 procedure DeserializeProperties(PropName: String; Reader: TObject; Ancestor: TfrxCollection); virtual;

Parameters

PropName
Type: String

Reader
Type: TObject

Ancestor
Type: TfrxCollection

See Also

Reference

  • TfrxCollection
  • frxCollections


TfrxCollection.FindByName(String) Method

Summary

Represents method FindByName(String).

Namespace: frxCollections
Syntax
Delphi
public
 function FindByName(Name: String): TfrxCollectionItem; virtual;

Parameters

Name
Type: String

Return Value

Type: TfrxCollectionItem

See Also

Reference

  • TfrxCollection
  • frxCollections


TfrxCollection.SerializeProperties(TObject,TfrxCollection,TComponent) Method

Summary

Represents method SerializeProperties(TObject,TfrxCollection,TComponent).

Namespace: frxCollections
Syntax
Delphi
public
 procedure SerializeProperties(Writer: TObject; Ancestor: TfrxCollection; Owner: TComponent); virtual;

Parameters

Writer
Type: TObject

Ancestor
Type: TfrxCollection

Owner
Type: TComponent

See Also

Reference

  • TfrxCollection
  • frxCollections


TfrxCollectionItem Class

Summary

Represents type TfrxCollectionItem.

Namespace: frxCollections
Inheritance Hierarchy
TCollectionItem
frxCollections.TfrxCollectionItem
frxClass.TfrxHighlight
frxClass.TfrxStyleItem
frxVariables.TfrxVariable
Syntax
Delphi
type
 TfrxCollectionItem = class(TCollectionItem)
 end;

The TfrxCollectionItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxCollectionItem class.
Top
Properties
Show:
Name | Description
InheritedName | Represents property InheritedName.
IsInherited | Represents property IsInherited.
UniqueIndex | Represents property UniqueIndex.
Top
Methods
Show:
Name | Description
CreateUniqueIName(TCollection) | Represents method CreateUniqueIName(TCollection).
GetInheritedName | Represents method GetInheritedName.
IsUniqueNameStored | Represents method IsUniqueNameStored.
SetInheritedName(String) | Represents method SetInheritedName(String).
Top
Fields
Show:
Name | Description
FIsInherited | Represents field FIsInherited.
FUniqueIndex | Represents field FUniqueIndex.
Top
See Also

Reference

  • frxCollections


TfrxCollectionItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxCollectionItem class.
Top


TfrxCollectionItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TfrxCollectionItem class.

Namespace: frxCollections
Syntax
Delphi
public
 constructor Create(ACollection: TCollection); override;

Parameters

ACollection
Type: TCollection

See Also

Reference

  • TfrxCollectionItem
  • frxCollections


TfrxCollectionItem Properties

Properties
Name | Description
InheritedName | Represents property InheritedName.
IsInherited | Represents property IsInherited.
UniqueIndex | Represents property UniqueIndex.
Top


TfrxCollectionItem.InheritedName Property

Summary

Represents property InheritedName.

Namespace: frxCollections
Syntax
Delphi
public
 property InheritedName: String read GetInheritedName write SetInheritedName;

Property Value

Type: String

See Also

Reference

  • TfrxCollectionItem
  • frxCollections


TfrxCollectionItem.IsInherited Property

Summary

Represents property IsInherited.

Namespace: frxCollections
Syntax
Delphi
public
 property IsInherited: Boolean read FIsInherited write FIsInherited;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCollectionItem
  • frxCollections


TfrxCollectionItem.UniqueIndex Property

Summary

Represents property UniqueIndex.

Namespace: frxCollections
Syntax
Delphi
public
 property UniqueIndex: Integer read FUniqueIndex write FUniqueIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxCollectionItem
  • frxCollections


TfrxCollectionItem Methods

Methods
Name | Description
CreateUniqueIName(TCollection) | Represents method CreateUniqueIName(TCollection).
GetInheritedName | Represents method GetInheritedName.
IsUniqueNameStored | Represents method IsUniqueNameStored.
SetInheritedName(String) | Represents method SetInheritedName(String).
Top


TfrxCollectionItem.CreateUniqueIName(TCollection) Method

Summary

Represents method CreateUniqueIName(TCollection).

Namespace: frxCollections
Syntax
Delphi
public
 procedure CreateUniqueIName(ACollection: TCollection);

Parameters

ACollection
Type: TCollection

See Also

Reference

  • TfrxCollectionItem
  • frxCollections


TfrxCollectionItem.GetInheritedName Method

Summary

Represents method GetInheritedName.

Namespace: frxCollections
Syntax
Delphi
protected
 function GetInheritedName: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxCollectionItem
  • frxCollections


TfrxCollectionItem.IsUniqueNameStored Method

Summary

Represents method IsUniqueNameStored.

Namespace: frxCollections
Syntax
Delphi
public
 function IsUniqueNameStored: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCollectionItem
  • frxCollections


TfrxCollectionItem.SetInheritedName(String) Method

Summary

Represents method SetInheritedName(String).

Namespace: frxCollections
Syntax
Delphi
protected
 procedure SetInheritedName(const Value: String); virtual;

Parameters

Value
Type: String

See Also

Reference

  • TfrxCollectionItem
  • frxCollections


TfrxCollectionItem Fields

Fields
Name | Description
FIsInherited | Represents field FIsInherited.
FUniqueIndex | Represents field FUniqueIndex.
Top


TfrxCollectionItem.FIsInherited Field

Summary

Represents field FIsInherited.

Namespace: frxCollections
Syntax
Delphi
protected
 FIsInherited: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCollectionItem
  • frxCollections


TfrxCollectionItem.FUniqueIndex Field

Summary

Represents field FUniqueIndex.

Namespace: frxCollections
Syntax
Delphi
protected
 FUniqueIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCollectionItem
  • frxCollections


frxComCtrls Namespace

Summary

Represents namespace frxComCtrls.

Classes
Name | Description
TfrxDataNode | Represents type TfrxDataNode.
TfrxToolPanel | Represents type TfrxToolPanel.
TfrxToolPanelButton | Represents type TfrxToolPanelButton.
TfrxToolPanelCustomButton | Represents type TfrxToolPanelCustomButton.
TfrxToolPanelSeparator | Represents type TfrxToolPanelSeparator.
TfrxTreeNode | Represents type TfrxTreeNode.
TfrxTreeNodes | Represents type TfrxTreeNodes.
TfrxTreePanel | Represents type TfrxTreePanel.
TfrxTreeView | Represents type TfrxTreeView.
Top
Enumerations
Name | Description
TfrxFilterAlign | Represents type TfrxFilterAlign.
TfrxToolAlign | Represents type TfrxToolAlign.
TfrxToolButttonKind | Represents type TfrxToolButttonKind.
TfrxToolButttonStyle | Represents type TfrxToolButttonStyle.
Top
Delegates
Name | Description
TfrxTVFilterCompareEvent | Represents type TfrxTVFilterCompareEvent.
Top
Types
Name | Description
TfrxTreeNodeClass | Represents type TfrxTreeNodeClass.
Top


frxComCtrls Classes

Classes
Name | Description
TfrxDataNode | Represents type TfrxDataNode.
TfrxToolPanel | Represents type TfrxToolPanel.
TfrxToolPanelButton | Represents type TfrxToolPanelButton.
TfrxToolPanelCustomButton | Represents type TfrxToolPanelCustomButton.
TfrxToolPanelSeparator | Represents type TfrxToolPanelSeparator.
TfrxTreeNode | Represents type TfrxTreeNode.
TfrxTreeNodes | Represents type TfrxTreeNodes.
TfrxTreePanel | Represents type TfrxTreePanel.
TfrxTreeView | Represents type TfrxTreeView.
Top


TfrxDataNode Class

Summary

Represents type TfrxDataNode.

Namespace: frxComCtrls
Inheritance Hierarchy
TObject
frxComCtrls.TfrxDataNode
Syntax
Delphi
type
 TfrxDataNode = class(TObject)
 end;

The TfrxDataNode type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TfrxDataNode class.
Top
Methods
Show:
Name | Description
Clear | Represents method Clear.
Top
Fields
Show:
Name | Description
FData | Represents field FData.
FFirstChild | Represents field FFirstChild.
FImageIndex | Represents field FImageIndex.
FLSibling | Represents field FLSibling.
FOriginalNode | Represents field FOriginalNode.
FParent | Represents field FParent.
FRSibling | Represents field FRSibling.
FSelectedIndex | Represents field FSelectedIndex.
FText | Represents field FText.
Top
See Also

Reference

  • frxComCtrls


TfrxDataNode Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TfrxDataNode class.
Top


TfrxDataNode.Destroy Destructor

Summary

Represents the destructor of the TfrxDataNode class.

Namespace: frxComCtrls
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxDataNode
  • frxComCtrls


TfrxDataNode Methods

Methods
Name | Description
Clear | Represents method Clear.
Top


TfrxDataNode.Clear Method

Summary

Represents method Clear.

Namespace: frxComCtrls
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxDataNode
  • frxComCtrls


TfrxDataNode Fields

Fields
Name | Description
FData | Represents field FData.
FFirstChild | Represents field FFirstChild.
FImageIndex | Represents field FImageIndex.
FLSibling | Represents field FLSibling.
FOriginalNode | Represents field FOriginalNode.
FParent | Represents field FParent.
FRSibling | Represents field FRSibling.
FSelectedIndex | Represents field FSelectedIndex.
FText | Represents field FText.
Top


TfrxDataNode.FData Field

Summary

Represents field FData.

Namespace: frxComCtrls
Syntax
Delphi
private
 FData: TObject;

Field Value

Type: TObject

See Also

Reference

  • TfrxDataNode
  • frxComCtrls


TfrxDataNode.FFirstChild Field

Summary

Represents field FFirstChild.

Namespace: frxComCtrls
Syntax
Delphi
private
 FFirstChild: TfrxDataNode;

Field Value

Type: TfrxDataNode

See Also

Reference

  • TfrxDataNode
  • frxComCtrls


TfrxDataNode.FImageIndex Field

Summary

Represents field FImageIndex.

Namespace: frxComCtrls
Syntax
Delphi
private
 FImageIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDataNode
  • frxComCtrls


TfrxDataNode.FLSibling Field

Summary

Represents field FLSibling.

Namespace: frxComCtrls
Syntax
Delphi
private
 FLSibling: TfrxDataNode;

Field Value

Type: TfrxDataNode

See Also

Reference

  • TfrxDataNode
  • frxComCtrls


TfrxDataNode.FOriginalNode Field

Summary

Represents field FOriginalNode.

Namespace: frxComCtrls
Syntax
Delphi
private
 FOriginalNode: TTreeNode;

Field Value

Type: TTreeNode

See Also

Reference

  • TfrxDataNode
  • frxComCtrls


TfrxDataNode.FParent Field

Summary

Represents field FParent.

Namespace: frxComCtrls
Syntax
Delphi
private
 FParent: TfrxDataNode;

Field Value

Type: TfrxDataNode

See Also

Reference

  • TfrxDataNode
  • frxComCtrls


TfrxDataNode.FRSibling Field

Summary

Represents field FRSibling.

Namespace: frxComCtrls
Syntax
Delphi
private
 FRSibling: TfrxDataNode;

Field Value

Type: TfrxDataNode

See Also

Reference

  • TfrxDataNode
  • frxComCtrls


TfrxDataNode.FSelectedIndex Field

Summary

Represents field FSelectedIndex.

Namespace: frxComCtrls
Syntax
Delphi
private
 FSelectedIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDataNode
  • frxComCtrls


TfrxDataNode.FText Field

Summary

Represents field FText.

Namespace: frxComCtrls
Syntax
Delphi
private
 FText: String;

Field Value

Type: String

See Also

Reference

  • TfrxDataNode
  • frxComCtrls


TfrxToolPanel Class

Summary

Represents type TfrxToolPanel.

Namespace: frxComCtrls
Inheritance Hierarchy
TCustomPanel
frxDPIAwareBaseControls.TfrxDPIAwareBasePanel
frxDPIAwareBaseControls.TfrxDPIAwarePanel
frxComCtrls.TfrxToolPanel
Syntax
Delphi
type
 TfrxToolPanel = class(TfrxDPIAwarePanel)
 end;

The TfrxToolPanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxToolPanel class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Destroy | Represents the destructor of the TfrxToolPanel class.
Top
Properties
Show:
Name | Description
Align | Represents property Align. (Inherited from TfrxDPIAwarePanel.)
Alignment | Represents property Alignment. (Inherited from TfrxDPIAwarePanel.)
Anchors | Represents property Anchors. (Inherited from TfrxDPIAwarePanel.)
AutoSize | Represents property AutoSize. (Inherited from TfrxDPIAwarePanel.)
BevelInner | Represents property BevelInner. (Inherited from TfrxDPIAwarePanel.)
BevelKind | Represents property BevelKind. (Inherited from TfrxDPIAwarePanel.)
BevelOuter | Represents property BevelOuter. (Inherited from TfrxDPIAwarePanel.)
BevelWidth | Represents property BevelWidth. (Inherited from TfrxDPIAwarePanel.)
BiDiMode | Represents property BiDiMode. (Inherited from TfrxDPIAwarePanel.)
BorderStyle | Represents property BorderStyle. (Inherited from TfrxDPIAwarePanel.)
BorderWidth | Represents property BorderWidth. (Inherited from TfrxDPIAwarePanel.)
Caption | Represents property Caption. (Inherited from TfrxDPIAwarePanel.)
Color | Represents property Color. (Inherited from TfrxDPIAwarePanel.)
Constraints | Represents property Constraints. (Inherited from TfrxDPIAwarePanel.)
Ctl3D | Represents property Ctl3D. (Inherited from TfrxDPIAwarePanel.)
CurrentPPI | Represents property CurrentPPI. (Inherited from TfrxDPIAwareBasePanel.)
DockManager | Represents property DockManager. (Inherited from TfrxDPIAwarePanel.)
DockSite | Represents property DockSite. (Inherited from TfrxDPIAwarePanel.)
DragCursor | Represents property DragCursor. (Inherited from TfrxDPIAwarePanel.)
DragKind | Represents property DragKind. (Inherited from TfrxDPIAwarePanel.)
DragMode | Represents property DragMode. (Inherited from TfrxDPIAwarePanel.)
Enabled | Represents property Enabled. (Inherited from TfrxDPIAwarePanel.)
Font | Represents property Font. (Inherited from TfrxDPIAwarePanel.)
FullRepaint | Represents property FullRepaint. (Inherited from TfrxDPIAwarePanel.)
ImageList | Represents property ImageList.
Locked | Represents property Locked. (Inherited from TfrxDPIAwarePanel.)
OnBtnClick | Represents property OnBtnClick.
OnCanResize | Represents property OnCanResize. (Inherited from TfrxDPIAwarePanel.)
OnClick | Represents property OnClick. (Inherited from TfrxDPIAwarePanel.)
OnConstrainedResize | Represents property OnConstrainedResize. (Inherited from TfrxDPIAwarePanel.)
OnContextPopup | Represents property OnContextPopup. (Inherited from TfrxDPIAwarePanel.)
OnDblClick | Represents property OnDblClick. (Inherited from TfrxDPIAwarePanel.)
OnDockDrop | Represents property OnDockDrop. (Inherited from TfrxDPIAwarePanel.)
OnDockOver | Represents property OnDockOver. (Inherited from TfrxDPIAwarePanel.)
OnDragDrop | Represents property OnDragDrop. (Inherited from TfrxDPIAwarePanel.)
OnDragOver | Represents property OnDragOver. (Inherited from TfrxDPIAwarePanel.)
OnEndDock | Represents property OnEndDock. (Inherited from TfrxDPIAwarePanel.)
OnEndDrag | Represents property OnEndDrag. (Inherited from TfrxDPIAwarePanel.)
OnEnter | Represents property OnEnter. (Inherited from TfrxDPIAwarePanel.)
OnExit | Represents property OnExit. (Inherited from TfrxDPIAwarePanel.)
OnGetSiteInfo | Represents property OnGetSiteInfo. (Inherited from TfrxDPIAwarePanel.)
OnMouseDown | Represents property OnMouseDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseMove | Represents property OnMouseMove. (Inherited from TfrxDPIAwarePanel.)
OnMouseUp | Represents property OnMouseUp. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheel | Represents property OnMouseWheel. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelDown | Represents property OnMouseWheelDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelUp | Represents property OnMouseWheelUp. (Inherited from TfrxDPIAwarePanel.)
OnResize | Represents property OnResize. (Inherited from TfrxDPIAwarePanel.)
OnStartDock | Represents property OnStartDock. (Inherited from TfrxDPIAwarePanel.)
OnStartDrag | Represents property OnStartDrag. (Inherited from TfrxDPIAwarePanel.)
OnUnDock | Represents property OnUnDock. (Inherited from TfrxDPIAwarePanel.)
ParentBackground | Represents property ParentBackground. (Inherited from TfrxDPIAwarePanel.)
ParentBiDiMode | Represents property ParentBiDiMode. (Inherited from TfrxDPIAwarePanel.)
ParentColor | Represents property ParentColor. (Inherited from TfrxDPIAwarePanel.)
ParentCtl3D | Represents property ParentCtl3D. (Inherited from TfrxDPIAwarePanel.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDPIAwarePanel.)
ParentShowHint | Represents property ParentShowHint. (Inherited from TfrxDPIAwarePanel.)
PopupMenu | Represents property PopupMenu. (Inherited from TfrxDPIAwarePanel.)
ShowHint | Represents property ShowHint. (Inherited from TfrxDPIAwarePanel.)
TabOrder | Represents property TabOrder. (Inherited from TfrxDPIAwarePanel.)
TabStop | Represents property TabStop. (Inherited from TfrxDPIAwarePanel.)
UseDockManager | Represents property UseDockManager. (Inherited from TfrxDPIAwarePanel.)
Visible | Represents property Visible. (Inherited from TfrxDPIAwarePanel.)
Top
Methods
Show:
Name | Description
AddButton(Integer,String,NativeInt,TfrxToolButttonStyle,Integer) | Represents method AddButton(Integer,String,NativeInt,TfrxToolButttonStyle,Integer).
AddCustomButton(TfrxToolButttonKind) | Represents method AddCustomButton(TfrxToolButttonKind).
CalcButtonsWidth | Represents method CalcButtonsWidth.
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Inherited from TfrxDPIAwareBasePanel.)
GetArrowWidth | Represents method GetArrowWidth.
GetReleativeScale | Represents method GetReleativeScale. (Inherited from TfrxDPIAwareBasePanel.)
GetScale | Represents method GetScale. (Inherited from TfrxDPIAwareBasePanel.)
Paint | Represents method Paint.
RealignButtons | Represents method RealignButtons.
ResetRadioGroup(Integer) | Represents method ResetRadioGroup(Integer).
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxDPIAwareBasePanel.)
SetBounds(integer,integer,integer,integer) | Represents method SetBounds(integer,integer,integer,integer).
SetImageList(TCustomImageList) | Represents method SetImageList(TCustomImageList).
Top
Fields
Show:
Name | Description
FButtons | Represents field FButtons.
FImageList | Represents field FImageList.
FOnBtnClick | Represents field FOnBtnClick.
Top
See Also

Reference

  • frxComCtrls


TfrxToolPanel Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxToolPanel class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Destroy | Represents the destructor of the TfrxToolPanel class.
Top


TfrxToolPanel.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxToolPanel class.

Namespace: frxComCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDPIAwareBasePanel.Create(TComponent)
See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel.Destroy Destructor

Summary

Represents the destructor of the TfrxToolPanel class.

Namespace: frxComCtrls
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel Properties

Properties
Name | Description
ImageList | Represents property ImageList.
OnBtnClick | Represents property OnBtnClick.
Top


TfrxToolPanel.ImageList Property

Summary

Represents property ImageList.

Namespace: frxComCtrls
Syntax
Delphi
public
 property ImageList: TCustomImageList read FImageList write SetImageList;

Property Value

Type: TCustomImageList

See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel.OnBtnClick Property

Summary

Represents property OnBtnClick.

Namespace: frxComCtrls
Syntax
Delphi
public
 property OnBtnClick: TNotifyEvent read FOnBtnClick write FOnBtnClick;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel Methods

Methods
Name | Description
AddButton(Integer,String,NativeInt,TfrxToolButttonStyle,Integer) | Represents method AddButton(Integer,String,NativeInt,TfrxToolButttonStyle,Integer).
AddCustomButton(TfrxToolButttonKind) | Represents method AddCustomButton(TfrxToolButttonKind).
CalcButtonsWidth | Represents method CalcButtonsWidth.
GetArrowWidth | Represents method GetArrowWidth.
Paint | Represents method Paint.
RealignButtons | Represents method RealignButtons.
ResetRadioGroup(Integer) | Represents method ResetRadioGroup(Integer).
SetBounds(integer,integer,integer,integer) | Represents method SetBounds(integer,integer,integer,integer).
SetImageList(TCustomImageList) | Represents method SetImageList(TCustomImageList).
Top


TfrxToolPanel.AddButton(Integer,String,NativeInt,TfrxToolButttonStyle,Integer) Method

Summary

Represents method AddButton(Integer,String,NativeInt,TfrxToolButttonStyle,Integer).

Namespace: frxComCtrls
Syntax
Delphi
public
 function AddButton(ImageIndex: Integer; HintText: String = ''; Tag: NativeInt = -1; ButtonStyle: TfrxToolButttonStyle = fbsButton; Group: Integer = -1): TfrxToolPanelButton;

Parameters

ImageIndex
Type: Integer

HintText
Type: String

Tag
Type: NativeInt

ButtonStyle
Type: TfrxToolButttonStyle

Group
Type: Integer

Return Value

Type: TfrxToolPanelButton

See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel.AddCustomButton(TfrxToolButttonKind) Method

Summary

Represents method AddCustomButton(TfrxToolButttonKind).

Namespace: frxComCtrls
Syntax
Delphi
public
 function AddCustomButton(aKind: TfrxToolButttonKind): TfrxToolPanelCustomButton;

Parameters

aKind
Type: TfrxToolButttonKind

Return Value

Type: TfrxToolPanelCustomButton

See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel.CalcButtonsWidth Method

Summary

Represents method CalcButtonsWidth.

Namespace: frxComCtrls
Syntax
Delphi
protected
 function CalcButtonsWidth: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel.GetArrowWidth Method

Summary

Represents method GetArrowWidth.

Namespace: frxComCtrls
Syntax
Delphi
public
 function GetArrowWidth: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel.Paint Method

Summary

Represents method Paint.

Namespace: frxComCtrls
Syntax
Delphi
public
 procedure Paint; override;
See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel.RealignButtons Method

Summary

Represents method RealignButtons.

Namespace: frxComCtrls
Syntax
Delphi
public
 procedure RealignButtons;
See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel.ResetRadioGroup(Integer) Method

Summary

Represents method ResetRadioGroup(Integer).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure ResetRadioGroup(GroupIndex: Integer);

Parameters

GroupIndex
Type: Integer

See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel.SetBounds(integer,integer,integer,integer) Method

Summary

Represents method SetBounds(integer,integer,integer,integer).

Namespace: frxComCtrls
Syntax
Delphi
public
 procedure SetBounds(aLeft, aTop, aWidth, aHeight: integer); override;

Parameters

aLeft
Type: integer

aTop
Type: integer

aWidth
Type: integer

aHeight
Type: integer

See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel.SetImageList(TCustomImageList) Method

Summary

Represents method SetImageList(TCustomImageList).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetImageList(const Value: TCustomImageList);

Parameters

Value
Type: TCustomImageList

See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel Fields

Fields
Name | Description
FButtons | Represents field FButtons.
FImageList | Represents field FImageList.
FOnBtnClick | Represents field FOnBtnClick.
Top


TfrxToolPanel.FButtons Field

Summary

Represents field FButtons.

Namespace: frxComCtrls
Syntax
Delphi
private
 FButtons: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel.FImageList Field

Summary

Represents field FImageList.

Namespace: frxComCtrls
Syntax
Delphi
private
 FImageList: TCustomImageList;

Field Value

Type: TCustomImageList

See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanel.FOnBtnClick Field

Summary

Represents field FOnBtnClick.

Namespace: frxComCtrls
Syntax
Delphi
private
 FOnBtnClick: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxToolPanel
  • frxComCtrls


TfrxToolPanelButton Class

Summary

Represents type TfrxToolPanelButton.

Namespace: frxComCtrls
Inheritance Hierarchy
TGraphicControl
frxComCtrls.TfrxToolPanelCustomButton
frxComCtrls.TfrxToolPanelButton
Syntax
Delphi
type
 TfrxToolPanelButton = class(TfrxToolPanelCustomButton)
 end;

The TfrxToolPanelButton type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxToolPanelButton class. (Overrides TfrxToolPanelCustomButton.Create(TComponent).)
Top
Properties
Show:
Name | Description
ButtonStyle | Represents property ButtonStyle.
ImageIndex | Represents property ImageIndex.
IsDown | Represents property IsDown.
Top
Methods
Show:
Name | Description
CMMouseEnter(TMessage) | Represents method CMMouseEnter(TMessage).
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage).
GetArrowWidth | Represents method GetArrowWidth.
GetParentPanel | Represents method GetParentPanel.
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
SetBounds(Integer,Integer,Integer,Integer) | Represents method SetBounds(Integer,Integer,Integer,Integer).
SetButtonStyle(TfrxToolButttonStyle) | Represents method SetButtonStyle(TfrxToolButttonStyle).
SetIsDown(Boolean) | Represents method SetIsDown(Boolean).
Top
Fields
Show:
Name | Description
FButtonStyle | Represents field FButtonStyle.
FGroup | Represents field FGroup.
FImageIndex | Represents field FImageIndex.
FIsActive | Represents field FIsActive.
FIsDown | Represents field FIsDown.
Top
See Also

Reference

  • frxComCtrls


TfrxToolPanelButton Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxToolPanelButton class. (Overrides TfrxToolPanelCustomButton.Create(TComponent).)
Top


TfrxToolPanelButton.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxToolPanelButton class.

Namespace: frxComCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxToolPanelCustomButton.Create(TComponent)
See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton Properties

Properties
Name | Description
ButtonStyle | Represents property ButtonStyle.
ImageIndex | Represents property ImageIndex.
IsDown | Represents property IsDown.
Top


TfrxToolPanelButton.ButtonStyle Property

Summary

Represents property ButtonStyle.

Namespace: frxComCtrls
Syntax
Delphi
public
 property ButtonStyle: TfrxToolButttonStyle read FButtonStyle write SetButtonStyle;

Property Value

Type: TfrxToolButttonStyle

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.ImageIndex Property

Summary

Represents property ImageIndex.

Namespace: frxComCtrls
Syntax
Delphi
public
 property ImageIndex: Integer read FImageIndex write FImageIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.IsDown Property

Summary

Represents property IsDown.

Namespace: frxComCtrls
Syntax
Delphi
public
 property IsDown: Boolean read FIsDown write SetIsDown;

Property Value

Type: Boolean

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton Methods

Methods
Name | Description
CMMouseEnter(TMessage) | Represents method CMMouseEnter(TMessage).
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage).
GetArrowWidth | Represents method GetArrowWidth.
GetParentPanel | Represents method GetParentPanel.
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
SetBounds(Integer,Integer,Integer,Integer) | Represents method SetBounds(Integer,Integer,Integer,Integer).
SetButtonStyle(TfrxToolButttonStyle) | Represents method SetButtonStyle(TfrxToolButttonStyle).
SetIsDown(Boolean) | Represents method SetIsDown(Boolean).
Top


TfrxToolPanelButton.CMMouseEnter(TMessage) Method

Summary

Represents method CMMouseEnter(TMessage).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure CMMouseEnter(var Message: TMessage); message CM_MOUSEENTER;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.CMMouseLeave(TMessage) Method

Summary

Represents method CMMouseLeave(TMessage).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure CMMouseLeave(var Message: TMessage); message CM_MOUSELEAVE;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.GetArrowWidth Method

Summary

Represents method GetArrowWidth.

Namespace: frxComCtrls
Syntax
Delphi
protected
 function GetArrowWidth: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.GetParentPanel Method

Summary

Represents method GetParentPanel.

Namespace: frxComCtrls
Syntax
Delphi
private
 function GetParentPanel: TfrxToolPanel;

Return Value

Type: TfrxToolPanel

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.MouseDown(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure MouseDown(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.Paint Method

Summary

Represents method Paint.

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure Paint; override;
See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.SetBounds(Integer,Integer,Integer,Integer) Method

Summary

Represents method SetBounds(Integer,Integer,Integer,Integer).

Namespace: frxComCtrls
Syntax
Delphi
public
 procedure SetBounds(ALeft, ATop, AWidth, AHeight: Integer); override;

Parameters

ALeft
Type: Integer

ATop
Type: Integer

AWidth
Type: Integer

AHeight
Type: Integer

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.SetButtonStyle(TfrxToolButttonStyle) Method

Summary

Represents method SetButtonStyle(TfrxToolButttonStyle).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetButtonStyle(const Value: TfrxToolButttonStyle);

Parameters

Value
Type: TfrxToolButttonStyle

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.SetIsDown(Boolean) Method

Summary

Represents method SetIsDown(Boolean).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetIsDown(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton Fields

Fields
Name | Description
FButtonStyle | Represents field FButtonStyle.
FGroup | Represents field FGroup.
FImageIndex | Represents field FImageIndex.
FIsActive | Represents field FIsActive.
FIsDown | Represents field FIsDown.
Top


TfrxToolPanelButton.FButtonStyle Field

Summary

Represents field FButtonStyle.

Namespace: frxComCtrls
Syntax
Delphi
private
 FButtonStyle: TfrxToolButttonStyle;

Field Value

Type: TfrxToolButttonStyle

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.FGroup Field

Summary

Represents field FGroup.

Namespace: frxComCtrls
Syntax
Delphi
private
 FGroup: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.FImageIndex Field

Summary

Represents field FImageIndex.

Namespace: frxComCtrls
Syntax
Delphi
private
 FImageIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.FIsActive Field

Summary

Represents field FIsActive.

Namespace: frxComCtrls
Syntax
Delphi
private
 FIsActive: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelButton.FIsDown Field

Summary

Represents field FIsDown.

Namespace: frxComCtrls
Syntax
Delphi
private
 FIsDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxToolPanelButton
  • frxComCtrls


TfrxToolPanelCustomButton Class

Summary

Represents type TfrxToolPanelCustomButton.

Namespace: frxComCtrls
Inheritance Hierarchy
TGraphicControl
frxComCtrls.TfrxToolPanelCustomButton
frxComCtrls.TfrxToolPanelButton
frxComCtrls.TfrxToolPanelSeparator
Syntax
Delphi
type
 TfrxToolPanelCustomButton = class(TGraphicControl)
 end;

The TfrxToolPanelCustomButton type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxToolPanelCustomButton class.
Top
See Also

Reference

  • frxComCtrls


TfrxToolPanelCustomButton Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxToolPanelCustomButton class.
Top


TfrxToolPanelCustomButton.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxToolPanelCustomButton class.

Namespace: frxComCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxToolPanelCustomButton
  • frxComCtrls


TfrxToolPanelSeparator Class

Summary

Represents type TfrxToolPanelSeparator.

Namespace: frxComCtrls
Inheritance Hierarchy
TGraphicControl
frxComCtrls.TfrxToolPanelCustomButton
frxComCtrls.TfrxToolPanelSeparator
Syntax
Delphi
type
 TfrxToolPanelSeparator = class(TfrxToolPanelCustomButton)
 end;

The TfrxToolPanelSeparator type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxToolPanelSeparator class. (Overrides TfrxToolPanelCustomButton.Create(TComponent).)
Top
Methods
Show:
Name | Description
Paint | Represents method Paint.
Top
See Also

Reference

  • frxComCtrls


TfrxToolPanelSeparator Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxToolPanelSeparator class. (Overrides TfrxToolPanelCustomButton.Create(TComponent).)
Top


TfrxToolPanelSeparator.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxToolPanelSeparator class.

Namespace: frxComCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxToolPanelCustomButton.Create(TComponent)
See Also

Reference

  • TfrxToolPanelSeparator
  • frxComCtrls


TfrxToolPanelSeparator Methods

Methods
Name | Description
Paint | Represents method Paint.
Top


TfrxToolPanelSeparator.Paint Method

Summary

Represents method Paint.

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure Paint; override;
See Also

Reference

  • TfrxToolPanelSeparator
  • frxComCtrls


TfrxTreeNode Class

Summary

Represents type TfrxTreeNode.

Namespace: frxComCtrls
Inheritance Hierarchy
TTreeNode
frxComCtrls.TfrxTreeNode
Syntax
Delphi
type
 TfrxTreeNode = class(TTreeNode)
 end;

The TfrxTreeNode type exposes the following members.

Constructors
Show:
Name | Description
CreateWithData(TTreeNodes,TfrxDataNode) | Overloaded. Initializes a new instance of the TfrxTreeNode class.
Destroy | Represents the destructor of the TfrxTreeNode class.
Top
Methods
Show:
Name | Description
MoveTo(TTreeNode,TNodeAttachMode) | Represents method MoveTo(TTreeNode,TNodeAttachMode).
Top
Fields
Show:
Name | Description
FDataNode | Represents field FDataNode.
FNeedFixUp | Represents field FNeedFixUp.
Top
See Also

Reference

  • frxComCtrls


TfrxTreeNode Constructors

Constructors
Name | Description
CreateWithData(TTreeNodes,TfrxDataNode) | Overloaded. Initializes a new instance of the TfrxTreeNode class.
Destroy | Represents the destructor of the TfrxTreeNode class.
Top


TfrxTreeNode.CreateWithData(TTreeNodes,TfrxDataNode) Constructor

Summary

Initializes a new instance of the TfrxTreeNode class.

Namespace: frxComCtrls
Syntax
Delphi
public
 constructor CreateWithData(AOwner: TTreeNodes; aDataNode: TfrxDataNode); overload;

Parameters

AOwner
Type: TTreeNodes

aDataNode
Type: TfrxDataNode

See Also

Reference

  • TfrxTreeNode
  • frxComCtrls


TfrxTreeNode.Destroy Destructor

Summary

Represents the destructor of the TfrxTreeNode class.

Namespace: frxComCtrls
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxTreeNode
  • frxComCtrls


TfrxTreeNode Methods

Methods
Name | Description
MoveTo(TTreeNode,TNodeAttachMode) | Represents method MoveTo(TTreeNode,TNodeAttachMode).
Top


TfrxTreeNode.MoveTo(TTreeNode,TNodeAttachMode) Method

Summary

Represents method MoveTo(TTreeNode,TNodeAttachMode).

Namespace: frxComCtrls
Syntax
Delphi
public
 procedure MoveTo(Destination: TTreeNode; Mode: TNodeAttachMode); override;

Parameters

Destination
Type: TTreeNode

Mode
Type: TNodeAttachMode

See Also

Reference

  • TfrxTreeNode
  • frxComCtrls


TfrxTreeNode Fields

Fields
Name | Description
FDataNode | Represents field FDataNode.
FNeedFixUp | Represents field FNeedFixUp.
Top


TfrxTreeNode.FDataNode Field

Summary

Represents field FDataNode.

Namespace: frxComCtrls
Syntax
Delphi
private
 FDataNode: TfrxDataNode;

Field Value

Type: TfrxDataNode

See Also

Reference

  • TfrxTreeNode
  • frxComCtrls


TfrxTreeNode.FNeedFixUp Field

Summary

Represents field FNeedFixUp.

Namespace: frxComCtrls
Syntax
Delphi
private
 FNeedFixUp: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTreeNode
  • frxComCtrls


TfrxTreeNodes Class

Summary

Represents type TfrxTreeNodes.

Namespace: frxComCtrls
Inheritance Hierarchy
TTreeNodes
frxComCtrls.TfrxTreeNodes
Syntax
Delphi
type
 TfrxTreeNodes = class(TTreeNodes)
 end;

The TfrxTreeNodes type exposes the following members.

Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Top
See Also

Reference

  • frxComCtrls


TfrxTreeNodes Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Top


TfrxTreeNodes.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxComCtrls
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxTreeNodes
  • frxComCtrls


TfrxTreeNodes.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxTreeNodes
  • frxComCtrls


TfrxTreePanel Class

Summary

Represents type TfrxTreePanel.

Namespace: frxComCtrls
Inheritance Hierarchy
TCustomPanel
frxDPIAwareBaseControls.TfrxDPIAwareBasePanel
frxDPIAwareBaseControls.TfrxDPIAwarePanel
frxComCtrls.TfrxTreePanel
Syntax
Delphi
type
 TfrxTreePanel = class(TfrxDPIAwarePanel)
 end;

The TfrxTreePanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTreePanel class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Destroy | Represents the destructor of the TfrxTreePanel class.
Top
Properties
Show:
Name | Description
Align | Represents property Align. (Inherited from TfrxDPIAwarePanel.)
Alignment | Represents property Alignment. (Inherited from TfrxDPIAwarePanel.)
Anchors | Represents property Anchors. (Inherited from TfrxDPIAwarePanel.)
AutoSize | Represents property AutoSize. (Inherited from TfrxDPIAwarePanel.)
BevelInner | Represents property BevelInner. (Inherited from TfrxDPIAwarePanel.)
BevelKind | Represents property BevelKind. (Inherited from TfrxDPIAwarePanel.)
BevelOuter | Represents property BevelOuter. (Inherited from TfrxDPIAwarePanel.)
BevelWidth | Represents property BevelWidth. (Inherited from TfrxDPIAwarePanel.)
BiDiMode | Represents property BiDiMode. (Inherited from TfrxDPIAwarePanel.)
BorderStyle | Represents property BorderStyle. (Inherited from TfrxDPIAwarePanel.)
BorderWidth | Represents property BorderWidth. (Inherited from TfrxDPIAwarePanel.)
Caption | Represents property Caption. (Inherited from TfrxDPIAwarePanel.)
Color | Represents property Color. (Inherited from TfrxDPIAwarePanel.)
Constraints | Represents property Constraints. (Inherited from TfrxDPIAwarePanel.)
Ctl3D | Represents property Ctl3D. (Inherited from TfrxDPIAwarePanel.)
CurrentPPI | Represents property CurrentPPI. (Inherited from TfrxDPIAwareBasePanel.)
DockManager | Represents property DockManager. (Inherited from TfrxDPIAwarePanel.)
DockSite | Represents property DockSite. (Inherited from TfrxDPIAwarePanel.)
DragCursor | Represents property DragCursor. (Inherited from TfrxDPIAwarePanel.)
DragKind | Represents property DragKind. (Inherited from TfrxDPIAwarePanel.)
DragMode | Represents property DragMode. (Inherited from TfrxDPIAwarePanel.)
Enabled | Represents property Enabled. (Inherited from TfrxDPIAwarePanel.)
FileterMaxWidth | Represents property FileterMaxWidth.
FileterMinWidth | Represents property FileterMinWidth.
FilterActiveImageIndex | Represents property FilterActiveImageIndex.
FilterAlign | Represents property FilterAlign.
FilterColor | Represents property FilterColor.
FilterEdit | Represents property FilterEdit.
FilterUnactiveImageIndex | Represents property FilterUnactiveImageIndex.
FilterVisible | Represents property FilterVisible.
Font | Represents property Font. (Inherited from TfrxDPIAwarePanel.)
FullRepaint | Represents property FullRepaint. (Inherited from TfrxDPIAwarePanel.)
Locked | Represents property Locked. (Inherited from TfrxDPIAwarePanel.)
OnCanResize | Represents property OnCanResize. (Inherited from TfrxDPIAwarePanel.)
OnClick | Represents property OnClick. (Inherited from TfrxDPIAwarePanel.)
OnConstrainedResize | Represents property OnConstrainedResize. (Inherited from TfrxDPIAwarePanel.)
OnContextPopup | Represents property OnContextPopup. (Inherited from TfrxDPIAwarePanel.)
OnDblClick | Represents property OnDblClick. (Inherited from TfrxDPIAwarePanel.)
OnDockDrop | Represents property OnDockDrop. (Inherited from TfrxDPIAwarePanel.)
OnDockOver | Represents property OnDockOver. (Inherited from TfrxDPIAwarePanel.)
OnDragDrop | Represents property OnDragDrop. (Inherited from TfrxDPIAwarePanel.)
OnDragOver | Represents property OnDragOver. (Inherited from TfrxDPIAwarePanel.)
OnEndDock | Represents property OnEndDock. (Inherited from TfrxDPIAwarePanel.)
OnEndDrag | Represents property OnEndDrag. (Inherited from TfrxDPIAwarePanel.)
OnEnter | Represents property OnEnter. (Inherited from TfrxDPIAwarePanel.)
OnExit | Represents property OnExit. (Inherited from TfrxDPIAwarePanel.)
OnGetSiteInfo | Represents property OnGetSiteInfo. (Inherited from TfrxDPIAwarePanel.)
OnMouseDown | Represents property OnMouseDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseMove | Represents property OnMouseMove. (Inherited from TfrxDPIAwarePanel.)
OnMouseUp | Represents property OnMouseUp. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheel | Represents property OnMouseWheel. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelDown | Represents property OnMouseWheelDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelUp | Represents property OnMouseWheelUp. (Inherited from TfrxDPIAwarePanel.)
OnResize | Represents property OnResize. (Inherited from TfrxDPIAwarePanel.)
OnStartDock | Represents property OnStartDock. (Inherited from TfrxDPIAwarePanel.)
OnStartDrag | Represents property OnStartDrag. (Inherited from TfrxDPIAwarePanel.)
OnUnDock | Represents property OnUnDock. (Inherited from TfrxDPIAwarePanel.)
ParentBackground | Represents property ParentBackground. (Inherited from TfrxDPIAwarePanel.)
ParentBiDiMode | Represents property ParentBiDiMode. (Inherited from TfrxDPIAwarePanel.)
ParentColor | Represents property ParentColor. (Inherited from TfrxDPIAwarePanel.)
ParentCtl3D | Represents property ParentCtl3D. (Inherited from TfrxDPIAwarePanel.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDPIAwarePanel.)
ParentShowHint | Represents property ParentShowHint. (Inherited from TfrxDPIAwarePanel.)
PopupMenu | Represents property PopupMenu. (Inherited from TfrxDPIAwarePanel.)
ShowHint | Represents property ShowHint. (Inherited from TfrxDPIAwarePanel.)
TabOrder | Represents property TabOrder. (Inherited from TfrxDPIAwarePanel.)
TabStop | Represents property TabStop. (Inherited from TfrxDPIAwarePanel.)
ToolImageList | Represents property ToolImageList.
ToolPanel | Represents property ToolPanel.
ToolPanelAlign | Represents property ToolPanelAlign.
ToolVisible | Represents property ToolVisible.
TreeView | Represents property TreeView.
UseDockManager | Represents property UseDockManager. (Inherited from TfrxDPIAwarePanel.)
Visible | Represents property Visible. (Inherited from TfrxDPIAwarePanel.)
Top
Methods
Show:
Name | Description
CalcButtonsWidth | Represents method CalcButtonsWidth.
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Overrides TfrxDPIAwareBasePanel.DoPPIChanged(Integer).)
EditChange(TObject) | Represents method EditChange(TObject).
ExpandButtonClick(TObject) | Represents method ExpandButtonClick(TObject).
GetFilterColor | Represents method GetFilterColor.
GetFilterVisible | Represents method GetFilterVisible.
GetImageList | Represents method GetImageList.
GetReleativeScale | Represents method GetReleativeScale. (Inherited from TfrxDPIAwareBasePanel.)
GetScale | Represents method GetScale. (Inherited from TfrxDPIAwareBasePanel.)
GetToolVisible | Represents method GetToolVisible.
Resize | Represents method Resize.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxDPIAwareBasePanel.)
SetFileterMaxWidth(Integer) | Represents method SetFileterMaxWidth(Integer).
SetFileterMinWidth(Integer) | Represents method SetFileterMinWidth(Integer).
SetFilterActiveImageIndex(Integer) | Represents method SetFilterActiveImageIndex(Integer).
SetFilterAlign(TfrxFilterAlign) | Represents method SetFilterAlign(TfrxFilterAlign).
SetFilterColor(TColor) | Represents method SetFilterColor(TColor).
SetFilterUnactiveImageIndex(Integer) | Represents method SetFilterUnactiveImageIndex(Integer).
SetFilterVisible(Boolean) | Represents method SetFilterVisible(Boolean).
SetImageList(TCustomImageList) | Represents method SetImageList(TCustomImageList).
SetParent(TWinControl) | Represents method SetParent(TWinControl).
SetToolPanelAlign(TfrxToolAlign) | Represents method SetToolPanelAlign(TfrxToolAlign).
SetToolVisible(Boolean) | Represents method SetToolVisible(Boolean).
UpdateSize | Represents method UpdateSize.
Top
Fields
Show:
Name | Description
FFileterMaxWidth | Represents field FFileterMaxWidth.
FFileterMinWidth | Represents field FFileterMinWidth.
FFilter | Represents field FFilter.
FFilterActiveImageIndex | Represents field FFilterActiveImageIndex.
FFilterAlign | Represents field FFilterAlign.
FFilterUnactiveImageIndex | Represents field FFilterUnactiveImageIndex.
FPanel | Represents field FPanel.
FToolPanel | Represents field FToolPanel.
FToolPanelAlign | Represents field FToolPanelAlign.
FTreeView | Represents field FTreeView.
Top
See Also

Reference

  • frxComCtrls


TfrxTreePanel Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTreePanel class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Destroy | Represents the destructor of the TfrxTreePanel class.
Top


TfrxTreePanel.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxTreePanel class.

Namespace: frxComCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDPIAwareBasePanel.Create(TComponent)
See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.Destroy Destructor

Summary

Represents the destructor of the TfrxTreePanel class.

Namespace: frxComCtrls
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel Properties

Properties
Name | Description
FileterMaxWidth | Represents property FileterMaxWidth.
FileterMinWidth | Represents property FileterMinWidth.
FilterActiveImageIndex | Represents property FilterActiveImageIndex.
FilterAlign | Represents property FilterAlign.
FilterColor | Represents property FilterColor.
FilterEdit | Represents property FilterEdit.
FilterUnactiveImageIndex | Represents property FilterUnactiveImageIndex.
FilterVisible | Represents property FilterVisible.
ToolImageList | Represents property ToolImageList.
ToolPanel | Represents property ToolPanel.
ToolPanelAlign | Represents property ToolPanelAlign.
ToolVisible | Represents property ToolVisible.
TreeView | Represents property TreeView.
Top


TfrxTreePanel.FileterMaxWidth Property

Summary

Represents property FileterMaxWidth.

Namespace: frxComCtrls
Syntax
Delphi
public
 property FileterMaxWidth: Integer read FFileterMaxWidth write SetFileterMaxWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FileterMinWidth Property

Summary

Represents property FileterMinWidth.

Namespace: frxComCtrls
Syntax
Delphi
public
 property FileterMinWidth: Integer read FFileterMinWidth write SetFileterMinWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FilterActiveImageIndex Property

Summary

Represents property FilterActiveImageIndex.

Namespace: frxComCtrls
Syntax
Delphi
public
 property FilterActiveImageIndex: Integer read FFilterActiveImageIndex write SetFilterActiveImageIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FilterAlign Property

Summary

Represents property FilterAlign.

Namespace: frxComCtrls
Syntax
Delphi
public
 property FilterAlign: TfrxFilterAlign read FFilterAlign write SetFilterAlign;

Property Value

Type: TfrxFilterAlign

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FilterColor Property

Summary

Represents property FilterColor.

Namespace: frxComCtrls
Syntax
Delphi
public
 property FilterColor: TColor read GetFilterColor write SetFilterColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FilterEdit Property

Summary

Represents property FilterEdit.

Namespace: frxComCtrls
Syntax
Delphi
public
 property FilterEdit: TfrxFilterEdit read FFilter;

Property Value

Type: TfrxFilterEdit

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FilterUnactiveImageIndex Property

Summary

Represents property FilterUnactiveImageIndex.

Namespace: frxComCtrls
Syntax
Delphi
public
 property FilterUnactiveImageIndex: Integer read FFilterUnactiveImageIndex write SetFilterUnactiveImageIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FilterVisible Property

Summary

Represents property FilterVisible.

Namespace: frxComCtrls
Syntax
Delphi
public
 property FilterVisible: Boolean read GetFilterVisible write SetFilterVisible;

Property Value

Type: Boolean

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.ToolImageList Property

Summary

Represents property ToolImageList.

Namespace: frxComCtrls
Syntax
Delphi
public
 property ToolImageList: TCustomImageList read GetImageList write SetImageList;

Property Value

Type: TCustomImageList

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.ToolPanel Property

Summary

Represents property ToolPanel.

Namespace: frxComCtrls
Syntax
Delphi
public
 property ToolPanel: TfrxToolPanel read FToolPanel;

Property Value

Type: TfrxToolPanel

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.ToolPanelAlign Property

Summary

Represents property ToolPanelAlign.

Namespace: frxComCtrls
Syntax
Delphi
public
 property ToolPanelAlign: TfrxToolAlign read FToolPanelAlign write SetToolPanelAlign;

Property Value

Type: TfrxToolAlign

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.ToolVisible Property

Summary

Represents property ToolVisible.

Namespace: frxComCtrls
Syntax
Delphi
public
 property ToolVisible: Boolean read GetToolVisible write SetToolVisible;

Property Value

Type: Boolean

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.TreeView Property

Summary

Represents property TreeView.

Namespace: frxComCtrls
Syntax
Delphi
public
 property TreeView: TfrxTreeView read FTreeView;

Property Value

Type: TfrxTreeView

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel Methods

Methods
Name | Description
CalcButtonsWidth | Represents method CalcButtonsWidth.
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Overrides TfrxDPIAwareBasePanel.DoPPIChanged(Integer).)
EditChange(TObject) | Represents method EditChange(TObject).
ExpandButtonClick(TObject) | Represents method ExpandButtonClick(TObject).
GetFilterColor | Represents method GetFilterColor.
GetFilterVisible | Represents method GetFilterVisible.
GetImageList | Represents method GetImageList.
GetToolVisible | Represents method GetToolVisible.
Resize | Represents method Resize.
SetFileterMaxWidth(Integer) | Represents method SetFileterMaxWidth(Integer).
SetFileterMinWidth(Integer) | Represents method SetFileterMinWidth(Integer).
SetFilterActiveImageIndex(Integer) | Represents method SetFilterActiveImageIndex(Integer).
SetFilterAlign(TfrxFilterAlign) | Represents method SetFilterAlign(TfrxFilterAlign).
SetFilterColor(TColor) | Represents method SetFilterColor(TColor).
SetFilterUnactiveImageIndex(Integer) | Represents method SetFilterUnactiveImageIndex(Integer).
SetFilterVisible(Boolean) | Represents method SetFilterVisible(Boolean).
SetImageList(TCustomImageList) | Represents method SetImageList(TCustomImageList).
SetParent(TWinControl) | Represents method SetParent(TWinControl).
SetToolPanelAlign(TfrxToolAlign) | Represents method SetToolPanelAlign(TfrxToolAlign).
SetToolVisible(Boolean) | Represents method SetToolVisible(Boolean).
UpdateSize | Represents method UpdateSize.
Top


TfrxTreePanel.CalcButtonsWidth Method

Summary

Represents method CalcButtonsWidth.

Namespace: frxComCtrls
Syntax
Delphi
protected
 function CalcButtonsWidth: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.DoPPIChanged(Integer) Method

Summary

Represents method DoPPIChanged(Integer).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure DoPPIChanged(aNewPPI: Integer); override;

Parameters

aNewPPI
Type: Integer

Overrides

TfrxDPIAwareBasePanel.DoPPIChanged(Integer)
See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.EditChange(TObject) Method

Summary

Represents method EditChange(TObject).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure EditChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.ExpandButtonClick(TObject) Method

Summary

Represents method ExpandButtonClick(TObject).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure ExpandButtonClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.GetFilterColor Method

Summary

Represents method GetFilterColor.

Namespace: frxComCtrls
Syntax
Delphi
private
 function GetFilterColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.GetFilterVisible Method

Summary

Represents method GetFilterVisible.

Namespace: frxComCtrls
Syntax
Delphi
private
 function GetFilterVisible: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.GetImageList Method

Summary

Represents method GetImageList.

Namespace: frxComCtrls
Syntax
Delphi
private
 function GetImageList: TCustomImageList;

Return Value

Type: TCustomImageList

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.GetToolVisible Method

Summary

Represents method GetToolVisible.

Namespace: frxComCtrls
Syntax
Delphi
private
 function GetToolVisible: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.Resize Method

Summary

Represents method Resize.

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure Resize; override;
See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.SetFileterMaxWidth(Integer) Method

Summary

Represents method SetFileterMaxWidth(Integer).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetFileterMaxWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.SetFileterMinWidth(Integer) Method

Summary

Represents method SetFileterMinWidth(Integer).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetFileterMinWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.SetFilterActiveImageIndex(Integer) Method

Summary

Represents method SetFilterActiveImageIndex(Integer).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetFilterActiveImageIndex(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.SetFilterAlign(TfrxFilterAlign) Method

Summary

Represents method SetFilterAlign(TfrxFilterAlign).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetFilterAlign(const Value: TfrxFilterAlign);

Parameters

Value
Type: TfrxFilterAlign

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.SetFilterColor(TColor) Method

Summary

Represents method SetFilterColor(TColor).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetFilterColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.SetFilterUnactiveImageIndex(Integer) Method

Summary

Represents method SetFilterUnactiveImageIndex(Integer).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetFilterUnactiveImageIndex(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.SetFilterVisible(Boolean) Method

Summary

Represents method SetFilterVisible(Boolean).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetFilterVisible(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.SetImageList(TCustomImageList) Method

Summary

Represents method SetImageList(TCustomImageList).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetImageList(const Value: TCustomImageList);

Parameters

Value
Type: TCustomImageList

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.SetParent(TWinControl) Method

Summary

Represents method SetParent(TWinControl).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure SetParent(AParent: TWinControl); override;

Parameters

AParent
Type: TWinControl

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.SetToolPanelAlign(TfrxToolAlign) Method

Summary

Represents method SetToolPanelAlign(TfrxToolAlign).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetToolPanelAlign(const Value: TfrxToolAlign);

Parameters

Value
Type: TfrxToolAlign

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.SetToolVisible(Boolean) Method

Summary

Represents method SetToolVisible(Boolean).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetToolVisible(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.UpdateSize Method

Summary

Represents method UpdateSize.

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure UpdateSize;
See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel Fields

Fields
Name | Description
FFileterMaxWidth | Represents field FFileterMaxWidth.
FFileterMinWidth | Represents field FFileterMinWidth.
FFilter | Represents field FFilter.
FFilterActiveImageIndex | Represents field FFilterActiveImageIndex.
FFilterAlign | Represents field FFilterAlign.
FFilterUnactiveImageIndex | Represents field FFilterUnactiveImageIndex.
FPanel | Represents field FPanel.
FToolPanel | Represents field FToolPanel.
FToolPanelAlign | Represents field FToolPanelAlign.
FTreeView | Represents field FTreeView.
Top


TfrxTreePanel.FFileterMaxWidth Field

Summary

Represents field FFileterMaxWidth.

Namespace: frxComCtrls
Syntax
Delphi
private
 FFileterMaxWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FFileterMinWidth Field

Summary

Represents field FFileterMinWidth.

Namespace: frxComCtrls
Syntax
Delphi
private
 FFileterMinWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FFilter Field

Summary

Represents field FFilter.

Namespace: frxComCtrls
Syntax
Delphi
private
 FFilter: TfrxFilterEdit;

Field Value

Type: TfrxFilterEdit

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FFilterActiveImageIndex Field

Summary

Represents field FFilterActiveImageIndex.

Namespace: frxComCtrls
Syntax
Delphi
private
 FFilterActiveImageIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FFilterAlign Field

Summary

Represents field FFilterAlign.

Namespace: frxComCtrls
Syntax
Delphi
private
 FFilterAlign: TfrxFilterAlign;

Field Value

Type: TfrxFilterAlign

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FFilterUnactiveImageIndex Field

Summary

Represents field FFilterUnactiveImageIndex.

Namespace: frxComCtrls
Syntax
Delphi
private
 FFilterUnactiveImageIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FPanel Field

Summary

Represents field FPanel.

Namespace: frxComCtrls
Syntax
Delphi
private
 FPanel: TfrxDPIAwarePanel;

Field Value

Type: TfrxDPIAwarePanel

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FToolPanel Field

Summary

Represents field FToolPanel.

Namespace: frxComCtrls
Syntax
Delphi
private
 FToolPanel: TfrxToolPanel;

Field Value

Type: TfrxToolPanel

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FToolPanelAlign Field

Summary

Represents field FToolPanelAlign.

Namespace: frxComCtrls
Syntax
Delphi
private
 FToolPanelAlign: TfrxToolAlign;

Field Value

Type: TfrxToolAlign

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreePanel.FTreeView Field

Summary

Represents field FTreeView.

Namespace: frxComCtrls
Syntax
Delphi
private
 FTreeView: TfrxTreeView;

Field Value

Type: TfrxTreeView

See Also

Reference

  • TfrxTreePanel
  • frxComCtrls


TfrxTreeView Class

Summary

Represents type TfrxTreeView.

Namespace: frxComCtrls
Inheritance Hierarchy
TTreeView
frxComCtrls.TfrxTreeView
Syntax
Delphi
type
 TfrxTreeView = class(TTreeView)
 end;

The TfrxTreeView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTreeView class.
Destroy | Represents the destructor of the TfrxTreeView class.
Top
Properties
Show:
Name | Description
DrawExpandButton | Represents property DrawExpandButton.
ExpandButtonAlign | Represents property ExpandButtonAlign.
ExpandButtonState | Represents property ExpandButtonState.
ExpandLevel | Represents property ExpandLevel.
OnEdited | Represents property OnEdited.
OnExpandButtonClick | Represents property OnExpandButtonClick.
Top
Methods
Show:
Name | Description
Added(TTreeNode) | Represents method Added(TTreeNode).
CanChange(TTreeNode) | Represents method CanChange(TTreeNode).
CanCollapse(TTreeNode) | Represents method CanCollapse(TTreeNode).
Change(TTreeNode) | Represents method Change(TTreeNode).
CreateNode | Represents method CreateNode.
CreateNodes | Represents method CreateNodes.
CustomDraw(TRect,TCustomDrawStage) | Represents method CustomDraw(TRect,TCustomDrawStage).
CustomDrawItem(TTreeNode,TCustomDrawState,TCustomDrawStage,Boolean) | Represents method CustomDrawItem(TTreeNode,TCustomDrawState,TCustomDrawStage,Boolean).
Delete(TTreeNode) | Represents method Delete(TTreeNode).
DestroyWnd | Represents method DestroyWnd.
DoEdit(TObject,TTreeNode,string) | Represents method DoEdit(TObject,TTreeNode,string).
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer).
DrawArrow | Represents method DrawArrow.
Filter(string) | Represents method Filter(string).
InvalidateExpandButton(Boolean) | Represents method InvalidateExpandButton(Boolean).
IsCustomDrawn(TCustomDrawTarget,TCustomDrawStage) | Represents method IsCustomDrawn(TCustomDrawTarget,TCustomDrawStage).
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
ResetFilter | Represents method ResetFilter.
Resize | Represents method Resize.
SetDrawExpandButton(Boolean) | Represents method SetDrawExpandButton(Boolean).
SetExpandButtonAlign(TfrxToolAlign) | Represents method SetExpandButtonAlign(TfrxToolAlign).
SetExpandButtonState(Boolean) | Represents method SetExpandButtonState(Boolean).
UpdateExpandButton | Represents method UpdateExpandButton.
UpdateFilter | Represents method UpdateFilter.
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage).
WMHScroll(TWMHScroll) | Represents method WMHScroll(TWMHScroll).
WMMouseWheel(TWMMouseWheel) | Represents method WMMouseWheel(TWMMouseWheel).
WMVScroll(TWMVScroll) | Represents method WMVScroll(TWMVScroll).
Top
Events
Show:
Name | Description
OnFilterCompare | Represents property OnFilterCompare.
Top
Fields
Show:
Name | Description
FCurrentPPI | Represents field FCurrentPPI.
FDrawExpandButton | Represents field FDrawExpandButton.
FExpandButtonActive | Represents field FExpandButtonActive.
FExpandButtonAlign | Represents field FExpandButtonAlign.
FExpandButtonRect | Represents field FExpandButtonRect.
FExpandButtonState | Represents field FExpandButtonState.
FExpandButtonWidth | Represents field FExpandButtonWidth.
FExpandLevel | Represents field FExpandLevel.
FIsUpdating | Represents field FIsUpdating.
FLastFilter | Represents field FLastFilter.
FOnEditedNew | Represents field FOnEditedNew.
FOnExpandButtonClick | Represents field FOnExpandButtonClick.
FOnFilterCompare | Represents field FOnFilterCompare.
FRootNode | Represents field FRootNode.
Top
See Also

Reference

  • frxComCtrls


TfrxTreeView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTreeView class.
Destroy | Represents the destructor of the TfrxTreeView class.
Top


TfrxTreeView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxTreeView class.

Namespace: frxComCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.Destroy Destructor

Summary

Represents the destructor of the TfrxTreeView class.

Namespace: frxComCtrls
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView Properties

Properties
Name | Description
DrawExpandButton | Represents property DrawExpandButton.
ExpandButtonAlign | Represents property ExpandButtonAlign.
ExpandButtonState | Represents property ExpandButtonState.
ExpandLevel | Represents property ExpandLevel.
OnEdited | Represents property OnEdited.
OnExpandButtonClick | Represents property OnExpandButtonClick.
Top


TfrxTreeView.DrawExpandButton Property

Summary

Represents property DrawExpandButton.

Namespace: frxComCtrls
Syntax
Delphi
public
 property DrawExpandButton: Boolean read FDrawExpandButton write SetDrawExpandButton;

Property Value

Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.ExpandButtonAlign Property

Summary

Represents property ExpandButtonAlign.

Namespace: frxComCtrls
Syntax
Delphi
public
 property ExpandButtonAlign: TfrxToolAlign read FExpandButtonAlign write SetExpandButtonAlign;

Property Value

Type: TfrxToolAlign

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.ExpandButtonState Property

Summary

Represents property ExpandButtonState.

Namespace: frxComCtrls
Syntax
Delphi
public
 property ExpandButtonState: Boolean read FExpandButtonState write SetExpandButtonState;

Property Value

Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.ExpandLevel Property

Summary

Represents property ExpandLevel.

Namespace: frxComCtrls
Syntax
Delphi
public
 property ExpandLevel: Integer read FExpandLevel write FExpandLevel;

Property Value

Type: Integer

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.OnEdited Property

Summary

Represents property OnEdited.

Namespace: frxComCtrls
Syntax
Delphi
published
 property OnEdited: TTVEditedEvent read FOnEditedNew write FOnEditedNew;

Property Value

Type: TTVEditedEvent

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.OnExpandButtonClick Property

Summary

Represents property OnExpandButtonClick.

Namespace: frxComCtrls
Syntax
Delphi
published
 property OnExpandButtonClick: TNotifyEvent read FOnExpandButtonClick write FOnExpandButtonClick;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView Methods

Methods
Name | Description
Added(TTreeNode) | Represents method Added(TTreeNode).
CanChange(TTreeNode) | Represents method CanChange(TTreeNode).
CanCollapse(TTreeNode) | Represents method CanCollapse(TTreeNode).
Change(TTreeNode) | Represents method Change(TTreeNode).
CreateNode | Represents method CreateNode.
CreateNodes | Represents method CreateNodes.
CustomDraw(TRect,TCustomDrawStage) | Represents method CustomDraw(TRect,TCustomDrawStage).
CustomDrawItem(TTreeNode,TCustomDrawState,TCustomDrawStage,Boolean) | Represents method CustomDrawItem(TTreeNode,TCustomDrawState,TCustomDrawStage,Boolean).
Delete(TTreeNode) | Represents method Delete(TTreeNode).
DestroyWnd | Represents method DestroyWnd.
DoEdit(TObject,TTreeNode,string) | Represents method DoEdit(TObject,TTreeNode,string).
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer).
DrawArrow | Represents method DrawArrow.
Filter(string) | Represents method Filter(string).
InvalidateExpandButton(Boolean) | Represents method InvalidateExpandButton(Boolean).
IsCustomDrawn(TCustomDrawTarget,TCustomDrawStage) | Represents method IsCustomDrawn(TCustomDrawTarget,TCustomDrawStage).
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
ResetFilter | Represents method ResetFilter.
Resize | Represents method Resize.
SetDrawExpandButton(Boolean) | Represents method SetDrawExpandButton(Boolean).
SetExpandButtonAlign(TfrxToolAlign) | Represents method SetExpandButtonAlign(TfrxToolAlign).
SetExpandButtonState(Boolean) | Represents method SetExpandButtonState(Boolean).
UpdateExpandButton | Represents method UpdateExpandButton.
UpdateFilter | Represents method UpdateFilter.
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage).
WMHScroll(TWMHScroll) | Represents method WMHScroll(TWMHScroll).
WMMouseWheel(TWMMouseWheel) | Represents method WMMouseWheel(TWMMouseWheel).
WMVScroll(TWMVScroll) | Represents method WMVScroll(TWMVScroll).
Top


TfrxTreeView.Added(TTreeNode) Method

Summary

Represents method Added(TTreeNode).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure Added(Node: TTreeNode); override;

Parameters

Node
Type: TTreeNode

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.CanChange(TTreeNode) Method

Summary

Represents method CanChange(TTreeNode).

Namespace: frxComCtrls
Syntax
Delphi
protected
 function CanChange(Node: TTreeNode): Boolean; override;

Parameters

Node
Type: TTreeNode

Return Value

Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.CanCollapse(TTreeNode) Method

Summary

Represents method CanCollapse(TTreeNode).

Namespace: frxComCtrls
Syntax
Delphi
protected
 function CanCollapse(Node: TTreeNode): Boolean; override;

Parameters

Node
Type: TTreeNode

Return Value

Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.Change(TTreeNode) Method

Summary

Represents method Change(TTreeNode).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure Change(Node: TTreeNode); override;

Parameters

Node
Type: TTreeNode

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.CreateNode Method

Summary

Represents method CreateNode.

Namespace: frxComCtrls
Syntax
Delphi
protected
 function CreateNode: TTreeNode; override;

Return Value

Type: TTreeNode

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.CreateNodes Method

Summary

Represents method CreateNodes.

Namespace: frxComCtrls
Syntax
Delphi
protected
 function CreateNodes: TTreeNodes; override;

Return Value

Type: TTreeNodes

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.CustomDraw(TRect,TCustomDrawStage) Method

Summary

Represents method CustomDraw(TRect,TCustomDrawStage).

Namespace: frxComCtrls
Syntax
Delphi
protected
 function CustomDraw(const ARect: TRect; Stage: TCustomDrawStage): Boolean; override;

Parameters

ARect
Type: TRect

Stage
Type: TCustomDrawStage

Return Value

Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.CustomDrawItem(TTreeNode,TCustomDrawState,TCustomDrawStage,Boolean) Method

Summary

Represents method CustomDrawItem(TTreeNode,TCustomDrawState,TCustomDrawStage,Boolean).

Namespace: frxComCtrls
Syntax
Delphi
protected
 function CustomDrawItem(Node: TTreeNode; State: TCustomDrawState;
 Stage: TCustomDrawStage; var PaintImages: Boolean): Boolean; override;

Parameters

Node
Type: TTreeNode

State
Type: TCustomDrawState

Stage
Type: TCustomDrawStage

PaintImages
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.Delete(TTreeNode) Method

Summary

Represents method Delete(TTreeNode).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure Delete(Node: TTreeNode); override;

Parameters

Node
Type: TTreeNode

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.DestroyWnd Method

Summary

Represents method DestroyWnd.

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure DestroyWnd; override;
See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.DoEdit(TObject,TTreeNode,string) Method

Summary

Represents method DoEdit(TObject,TTreeNode,string).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure DoEdit(Sender: TObject; Node: TTreeNode; var S: string);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

S
Type: string

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.DoPPIChanged(Integer) Method

Summary

Represents method DoPPIChanged(Integer).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure DoPPIChanged(aNewPPI: Integer); virtual;

Parameters

aNewPPI
Type: Integer

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.DrawArrow Method

Summary

Represents method DrawArrow.

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure DrawArrow;
See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.Filter(string) Method

Summary

Represents method Filter(string).

Namespace: frxComCtrls
Syntax
Delphi
public
 procedure Filter(const aFilter: string);

Parameters

aFilter
Type: string

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.InvalidateExpandButton(Boolean) Method

Summary

Represents method InvalidateExpandButton(Boolean).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure InvalidateExpandButton(HideButton: Boolean = False);

Parameters

HideButton
Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.IsCustomDrawn(TCustomDrawTarget,TCustomDrawStage) Method

Summary

Represents method IsCustomDrawn(TCustomDrawTarget,TCustomDrawStage).

Namespace: frxComCtrls
Syntax
Delphi
protected
 function IsCustomDrawn(Target: TCustomDrawTarget; Stage: TCustomDrawStage): Boolean; override;

Parameters

Target
Type: TCustomDrawTarget

Stage
Type: TCustomDrawStage

Return Value

Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.MouseDown(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure MouseDown(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.MouseMove(TShiftState,Integer,Integer) Method

Summary

Represents method MouseMove(TShiftState,Integer,Integer).

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;

Parameters

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.ResetFilter Method

Summary

Represents method ResetFilter.

Namespace: frxComCtrls
Syntax
Delphi
public
 procedure ResetFilter;
See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.Resize Method

Summary

Represents method Resize.

Namespace: frxComCtrls
Syntax
Delphi
protected
 procedure Resize; override;
See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.SetDrawExpandButton(Boolean) Method

Summary

Represents method SetDrawExpandButton(Boolean).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetDrawExpandButton(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.SetExpandButtonAlign(TfrxToolAlign) Method

Summary

Represents method SetExpandButtonAlign(TfrxToolAlign).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetExpandButtonAlign(const Value: TfrxToolAlign);

Parameters

Value
Type: TfrxToolAlign

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.SetExpandButtonState(Boolean) Method

Summary

Represents method SetExpandButtonState(Boolean).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure SetExpandButtonState(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.UpdateExpandButton Method

Summary

Represents method UpdateExpandButton.

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure UpdateExpandButton;
See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.UpdateFilter Method

Summary

Represents method UpdateFilter.

Namespace: frxComCtrls
Syntax
Delphi
public
 procedure UpdateFilter;
See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.WMDpiChanged(TMessage) Method

Summary

Represents method WMDpiChanged(TMessage).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure WMDpiChanged(var Message: TMessage); message FRX_WM_DPICHANGED_AFTERPARENT;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.WMHScroll(TWMHScroll) Method

Summary

Represents method WMHScroll(TWMHScroll).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure WMHScroll(var Message: TWMHScroll); message WM_HSCROLL;

Parameters

Message
Type: TWMHScroll

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.WMMouseWheel(TWMMouseWheel) Method

Summary

Represents method WMMouseWheel(TWMMouseWheel).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure WMMouseWheel(var Message: TWMMouseWheel); message WM_MOUSEWHEEL;

Parameters

Message
Type: TWMMouseWheel

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.WMVScroll(TWMVScroll) Method

Summary

Represents method WMVScroll(TWMVScroll).

Namespace: frxComCtrls
Syntax
Delphi
private
 procedure WMVScroll(var Message: TWMVScroll); message WM_VSCROLL;

Parameters

Message
Type: TWMVScroll

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView Events

Events
Name | Description
OnFilterCompare | Represents property OnFilterCompare.
Top


TfrxTreeView.OnFilterCompare Event

Summary

Represents property OnFilterCompare.

Namespace: frxComCtrls
Syntax
Delphi
published
 property OnFilterCompare: TfrxTVFilterCompareEvent read FOnFilterCompare write FOnFilterCompare;

Value

Type: TfrxTVFilterCompareEvent

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView Fields

Fields
Name | Description
FCurrentPPI | Represents field FCurrentPPI.
FDrawExpandButton | Represents field FDrawExpandButton.
FExpandButtonActive | Represents field FExpandButtonActive.
FExpandButtonAlign | Represents field FExpandButtonAlign.
FExpandButtonRect | Represents field FExpandButtonRect.
FExpandButtonState | Represents field FExpandButtonState.
FExpandButtonWidth | Represents field FExpandButtonWidth.
FExpandLevel | Represents field FExpandLevel.
FIsUpdating | Represents field FIsUpdating.
FLastFilter | Represents field FLastFilter.
FOnEditedNew | Represents field FOnEditedNew.
FOnExpandButtonClick | Represents field FOnExpandButtonClick.
FOnFilterCompare | Represents field FOnFilterCompare.
FRootNode | Represents field FRootNode.
Top


TfrxTreeView.FCurrentPPI Field

Summary

Represents field FCurrentPPI.

Namespace: frxComCtrls
Syntax
Delphi
private
 FCurrentPPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FDrawExpandButton Field

Summary

Represents field FDrawExpandButton.

Namespace: frxComCtrls
Syntax
Delphi
private
 FDrawExpandButton: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FExpandButtonActive Field

Summary

Represents field FExpandButtonActive.

Namespace: frxComCtrls
Syntax
Delphi
private
 FExpandButtonActive: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FExpandButtonAlign Field

Summary

Represents field FExpandButtonAlign.

Namespace: frxComCtrls
Syntax
Delphi
private
 FExpandButtonAlign: TfrxToolAlign;

Field Value

Type: TfrxToolAlign

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FExpandButtonRect Field

Summary

Represents field FExpandButtonRect.

Namespace: frxComCtrls
Syntax
Delphi
private
 FExpandButtonRect: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FExpandButtonState Field

Summary

Represents field FExpandButtonState.

Namespace: frxComCtrls
Syntax
Delphi
private
 FExpandButtonState: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FExpandButtonWidth Field

Summary

Represents field FExpandButtonWidth.

Namespace: frxComCtrls
Syntax
Delphi
private
 FExpandButtonWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FExpandLevel Field

Summary

Represents field FExpandLevel.

Namespace: frxComCtrls
Syntax
Delphi
private
 FExpandLevel: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FIsUpdating Field

Summary

Represents field FIsUpdating.

Namespace: frxComCtrls
Syntax
Delphi
private
 FIsUpdating: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FLastFilter Field

Summary

Represents field FLastFilter.

Namespace: frxComCtrls
Syntax
Delphi
private
 FLastFilter: String;

Field Value

Type: String

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FOnEditedNew Field

Summary

Represents field FOnEditedNew.

Namespace: frxComCtrls
Syntax
Delphi
private
 FOnEditedNew: TTVEditedEvent;

Field Value

Type: TTVEditedEvent

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FOnExpandButtonClick Field

Summary

Represents field FOnExpandButtonClick.

Namespace: frxComCtrls
Syntax
Delphi
private
 FOnExpandButtonClick: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FOnFilterCompare Field

Summary

Represents field FOnFilterCompare.

Namespace: frxComCtrls
Syntax
Delphi
private
 FOnFilterCompare: TfrxTVFilterCompareEvent;

Field Value

Type: TfrxTVFilterCompareEvent

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


TfrxTreeView.FRootNode Field

Summary

Represents field FRootNode.

Namespace: frxComCtrls
Syntax
Delphi
private
 FRootNode: TfrxDataNode;

Field Value

Type: TfrxDataNode

See Also

Reference

  • TfrxTreeView
  • frxComCtrls


frxComCtrls Enumerations

Enumerations
Name | Description
TfrxFilterAlign | Represents type TfrxFilterAlign.
TfrxToolAlign | Represents type TfrxToolAlign.
TfrxToolButttonKind | Represents type TfrxToolButttonKind.
TfrxToolButttonStyle | Represents type TfrxToolButttonStyle.
Top


TfrxFilterAlign Enumeration

Summary

Represents type TfrxFilterAlign.

Namespace: frxComCtrls
Syntax
Delphi
type
 TfrxFilterAlign = (fraLeft, fraRight, fraWidth);

The TfrxFilterAlign type exposes the following members.

Members
Show:
Name | Description
fraLeft | Represents constant fraLeft.
fraRight | Represents constant fraRight.
fraWidth | Represents constant fraWidth.
Top
See Also

Reference

  • frxComCtrls


TfrxToolAlign Enumeration

Summary

Represents type TfrxToolAlign.

Namespace: frxComCtrls
Syntax
Delphi
type
 TfrxToolAlign = (ftaTop, ftaBottom);

The TfrxToolAlign type exposes the following members.

Members
Show:
Name | Description
ftaBottom | Represents constant ftaBottom.
ftaTop | Represents constant ftaTop.
Top
See Also

Reference

  • frxComCtrls


TfrxToolButttonKind Enumeration

Summary

Represents type TfrxToolButttonKind.

Namespace: frxComCtrls
Syntax
Delphi
type
 TfrxToolButttonKind = (fbkButton, fbkSeparator);

The TfrxToolButttonKind type exposes the following members.

Members
Show:
Name | Description
fbkButton | Represents constant fbkButton.
fbkSeparator | Represents constant fbkSeparator.
Top
See Also

Reference

  • frxComCtrls


TfrxToolButttonStyle Enumeration

Summary

Represents type TfrxToolButttonStyle.

Namespace: frxComCtrls
Syntax
Delphi
type
 TfrxToolButttonStyle = (fbsButton, fbsCheckButton, fbsRadioButton, fbsDropDownButton);

The TfrxToolButttonStyle type exposes the following members.

Members
Show:
Name | Description
fbsButton | Represents constant fbsButton.
fbsCheckButton | Represents constant fbsCheckButton.
fbsDropDownButton | Represents constant fbsDropDownButton.
fbsRadioButton | Represents constant fbsRadioButton.
Top
See Also

Reference

  • frxComCtrls


frxComCtrls Delegates

Delegates
Name | Description
TfrxTVFilterCompareEvent | Represents type TfrxTVFilterCompareEvent.
Top


TfrxTVFilterCompareEvent Delegate

Summary

Represents type TfrxTVFilterCompareEvent.

Namespace: frxComCtrls
Syntax
Delphi
type
 TfrxTVFilterCompareEvent = function(Sender: TObject; Node: TTreeNode; const aFilter: string): Boolean of object;
See Also

Reference

  • frxComCtrls


frxComCtrls Types

Types
Name | Description
TfrxTreeNodeClass | Represents type TfrxTreeNodeClass.
Top


TfrxTreeNodeClass Type

Summary

Represents type TfrxTreeNodeClass.

Namespace: frxComCtrls
Syntax
Delphi
type
 TfrxTreeNodeClass = class of TfrxTreeNode;
See Also

Reference

  • frxComCtrls


frxCross Namespace

Summary

Represents namespace frxCross.

Classes
Name | Description
TfrxCalcHeightEvent | Represents type TfrxCalcHeightEvent.
TfrxCalcWidthEvent | Represents type TfrxCalcWidthEvent.
TfrxCrossColumn | Represents type TfrxCrossColumn.
TfrxCrossColumnHeader | Represents type TfrxCrossColumnHeader.
TfrxCrossColumns | Represents type TfrxCrossColumns.
TfrxCrossCorner | Represents type TfrxCrossCorner.
TfrxCrossHeader | Represents type TfrxCrossHeader.
TfrxCrossObject | The TfrxCrossObject lets you use the Cross-tab component in your report. TfrxCrossObject is an empty component. It is used to add the frxCross.pas file to the "uses" list. The main component is TfrxCrossView and TfrxDBCrossView.
TfrxCrossRow | Represents type TfrxCrossRow.
TfrxCrossRowHeader | Represents type TfrxCrossRowHeader.
TfrxCrossRows | Represents type TfrxCrossRows.
TfrxCrossView | The TfrxCrossView component shows a cross-table. The component can show non-DB data, you should fill it using AddValue method in the OnBeforePrint event.
TfrxCustomCrossView | The TfrxCustomCrossView component is the base class for TfrxCrossView, TfrxDBCrossView components.
TfrxCutBandItem | Represents type TfrxCutBandItem.
TfrxCutBands | Represents type TfrxCutBands.
TfrxDBCrossView | The TfrxDBCrossView component shows a cross-table from the DB data. You should connect it to the dataset (DataSet property) and fill in the CellFields, ColumnFields, RowFields properties.
TfrxGridLineItem | Represents type TfrxGridLineItem.
TfrxGridLines | Represents type TfrxGridLines.
TfrxIndexCollection | Represents type TfrxIndexCollection.
TfrxIndexItem | Represents type TfrxIndexItem.
TfrxPrintCellEvent | Represents type TfrxPrintCellEvent.
TfrxPrintHeaderEvent | Represents type TfrxPrintHeaderEvent.
Top
Records
Name | Description
TfrxCrossCell | Represents type TfrxCrossCell.
Top
Enumerations
Name | Description
TfrxCrossEditGrid | Represents type TfrxCrossEditGrid.
TfrxCrossFunction | Type of aggregate function used in the crosstab cells.
TfrxCrossSortOrder | Sort order of cross header values.
Top
Delegates
Name | Description
TfrxOnCalcHeightEvent | Represents type TfrxOnCalcHeightEvent.
TfrxOnCalcWidthEvent | Represents type TfrxOnCalcWidthEvent.
TfrxOnPrintCellEvent | Represents type TfrxOnPrintCellEvent.
TfrxOnPrintHeaderEvent | Represents type TfrxOnPrintHeaderEvent.
Top
Types
Name | Description
PfrCrossCell | Represents a pointer type to TfrxCrossCell.
TfrxSortArray | Represents an array of the TfrxCrossSortOrder type.
TfrxVariantArray | Represents an array of the Variant type.
Top


frxCross Classes

Classes
Name | Description
TfrxCalcHeightEvent | Represents type TfrxCalcHeightEvent.
TfrxCalcWidthEvent | Represents type TfrxCalcWidthEvent.
TfrxCrossColumn | Represents type TfrxCrossColumn.
TfrxCrossColumnHeader | Represents type TfrxCrossColumnHeader.
TfrxCrossColumns | Represents type TfrxCrossColumns.
TfrxCrossCorner | Represents type TfrxCrossCorner.
TfrxCrossHeader | Represents type TfrxCrossHeader.
TfrxCrossObject | The TfrxCrossObject lets you use the Cross-tab component in your report. TfrxCrossObject is an empty component. It is used to add the frxCross.pas file to the "uses" list. The main component is TfrxCrossView and TfrxDBCrossView.
TfrxCrossRow | Represents type TfrxCrossRow.
TfrxCrossRowHeader | Represents type TfrxCrossRowHeader.
TfrxCrossRows | Represents type TfrxCrossRows.
TfrxCrossView | The TfrxCrossView component shows a cross-table. The component can show non-DB data, you should fill it using AddValue method in the OnBeforePrint event.
TfrxCustomCrossView | The TfrxCustomCrossView component is the base class for TfrxCrossView, TfrxDBCrossView components.
TfrxCutBandItem | Represents type TfrxCutBandItem.
TfrxCutBands | Represents type TfrxCutBands.
TfrxDBCrossView | The TfrxDBCrossView component shows a cross-table from the DB data. You should connect it to the dataset (DataSet property) and fill in the CellFields, ColumnFields, RowFields properties.
TfrxGridLineItem | Represents type TfrxGridLineItem.
TfrxGridLines | Represents type TfrxGridLines.
TfrxIndexCollection | Represents type TfrxIndexCollection.
TfrxIndexItem | Represents type TfrxIndexItem.
TfrxPrintCellEvent | Represents type TfrxPrintCellEvent.
TfrxPrintHeaderEvent | Represents type TfrxPrintHeaderEvent.
Top


TfrxCalcHeightEvent Class

Summary

Represents type TfrxCalcHeightEvent.

Namespace: frxCross
Syntax
Delphi
type
 TfrxCalcHeightEvent = type String;
See Also

Reference

  • frxCross


TfrxCalcWidthEvent Class

Summary

Represents type TfrxCalcWidthEvent.

Namespace: frxCross
Syntax
Delphi
type
 TfrxCalcWidthEvent = type String;
See Also

Reference

  • frxCross


TfrxCrossColumn Class

Summary

Represents type TfrxCrossColumn.

Namespace: frxCross
Inheritance Hierarchy
TCollectionItem
frxCross.TfrxIndexItem
frxCross.TfrxCrossColumn
Syntax
Delphi
type
 TfrxCrossColumn = class(TfrxIndexItem)
 end;

The TfrxCrossColumn type exposes the following members.

Properties
Show:
Name | Description
CellIndex | Represents property CellIndex.
Indexes | Represents property Indexes. (Inherited from TfrxIndexItem.)
Top
Fields
Show:
Name | Description
FCellIndex | Represents field FCellIndex.
Top
See Also

Reference

  • frxCross


TfrxCrossColumn Properties

Properties
Name | Description
CellIndex | Represents property CellIndex.
Top


TfrxCrossColumn.CellIndex Property

Summary

Represents property CellIndex.

Namespace: frxCross
Syntax
Delphi
public
 property CellIndex: Integer read FCellIndex write FCellIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxCrossColumn
  • frxCross


TfrxCrossColumn Fields

Fields
Name | Description
FCellIndex | Represents field FCellIndex.
Top


TfrxCrossColumn.FCellIndex Field

Summary

Represents field FCellIndex.

Namespace: frxCross
Syntax
Delphi
private
 FCellIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCrossColumn
  • frxCross


TfrxCrossColumnHeader Class

Summary

Represents type TfrxCrossColumnHeader.

Namespace: frxCross
Inheritance Hierarchy
TObject
frxCross.TfrxCrossHeader
frxCross.TfrxCrossColumnHeader
frxCross.TfrxCrossCorner
Syntax
Delphi
type
 TfrxCrossColumnHeader = class(TfrxCrossHeader)
 end;

The TfrxCrossColumnHeader type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer) | Initializes a new instance of the TfrxCrossHeader class. (Inherited from TfrxCrossHeader.)
Top
Properties
Show:
Name | Description
Bounds | Represents property Bounds. (Inherited from TfrxCrossHeader.)
Count | Represents property Count. (Inherited from TfrxCrossHeader.)
DefaultHeight | Represents property DefaultHeight. (Inherited from TfrxCrossHeader.)
HasCellHeaders | Represents property HasCellHeaders. (Inherited from TfrxCrossHeader.)
Height | Represents property Height. (Inherited from TfrxCrossHeader.)
IsTotal | Represents property IsTotal. (Inherited from TfrxCrossHeader.)
Items[Integer] | Represents property Items[Integer]. (Inherited from TfrxCrossHeader.)
Level | Represents property Level. (Inherited from TfrxCrossHeader.)
Memo | Represents property Memo. (Inherited from TfrxCrossHeader.)
Parent | Represents property Parent. (Inherited from TfrxCrossHeader.)
Value | Represents property Value. (Inherited from TfrxCrossHeader.)
Visible | Represents property Visible. (Inherited from TfrxCrossHeader.)
Width | Represents property Width. (Inherited from TfrxCrossHeader.)
Top
Methods
Show:
Name | Description
AllItems | Represents method AllItems. (Inherited from TfrxCrossHeader.)
CalcBounds | Represents method CalcBounds. (Overrides TfrxCrossHeader.CalcBounds.)
CalcSizes(Integer,Integer,Boolean) | Represents method CalcSizes(Integer,Integer,Boolean). (Overrides TfrxCrossHeader.CalcSizes(Integer,Integer,Boolean).)
Find(Variant) | Represents method Find(Variant). (Inherited from TfrxCrossHeader.)
GetIndexes | Represents method GetIndexes. (Inherited from TfrxCrossHeader.)
GetValues | Represents method GetValues. (Inherited from TfrxCrossHeader.)
IndexItems | Represents method IndexItems. (Inherited from TfrxCrossHeader.)
TerminalItems | Represents method TerminalItems. (Inherited from TfrxCrossHeader.)
Top
Fields
Show:
Name | Description
FCorner | Represents field FCorner.
Top
See Also

Reference

  • frxCross


TfrxCrossColumnHeader Methods

Methods
Name | Description
CalcBounds | Represents method CalcBounds. (Overrides TfrxCrossHeader.CalcBounds.)
CalcSizes(Integer,Integer,Boolean) | Represents method CalcSizes(Integer,Integer,Boolean). (Overrides TfrxCrossHeader.CalcSizes(Integer,Integer,Boolean).)
Top


TfrxCrossColumnHeader.CalcBounds Method

Summary

Represents method CalcBounds.

Namespace: frxCross
Syntax
Delphi
public
 procedure CalcBounds; override;

Overrides

TfrxCrossHeader.CalcBounds
See Also

Reference

  • TfrxCrossColumnHeader
  • frxCross


TfrxCrossColumnHeader.CalcSizes(Integer,Integer,Boolean) Method

Summary

Represents method CalcSizes(Integer,Integer,Boolean).

Namespace: frxCross
Syntax
Delphi
public
 procedure CalcSizes(MaxWidth, MinWidth: Integer; AutoSize: Boolean); override;

Parameters

MaxWidth
Type: Integer

MinWidth
Type: Integer

AutoSize
Type: Boolean

Overrides

TfrxCrossHeader.CalcSizes(Integer,Integer,Boolean)
See Also

Reference

  • TfrxCrossColumnHeader
  • frxCross


TfrxCrossColumnHeader Fields

Fields
Name | Description
FCorner | Represents field FCorner.
Top


TfrxCrossColumnHeader.FCorner Field

Summary

Represents field FCorner.

Namespace: frxCross
Syntax
Delphi
private
 FCorner: TfrxCrossHeader;

Field Value

Type: TfrxCrossHeader

See Also

Reference

  • TfrxCrossColumnHeader
  • frxCross


TfrxCrossColumns Class

Summary

Represents type TfrxCrossColumns.

Namespace: frxCross
Inheritance Hierarchy
TCollection
frxCross.TfrxIndexCollection
frxCross.TfrxCrossColumns
Syntax
Delphi
type
 TfrxCrossColumns = class(TfrxIndexCollection)
 end;

The TfrxCrossColumns type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxCrossColumns class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Column(Variant[]) | Represents method Column(Variant[]).
Find(Variant[],Integer) | Represents method Find(Variant[],Integer). (Inherited from TfrxIndexCollection.)
GetItems(Integer) | Represents method GetItems(Integer).
InsertItem(Integer,Variant[]) | Represents method InsertItem(Integer,Variant[]). (Overrides TfrxIndexCollection.InsertItem(Integer,Variant[]).)
Top
See Also

Reference

  • frxCross


TfrxCrossColumns Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxCrossColumns class.
Top


TfrxCrossColumns.Create Constructor

Summary

Initializes a new instance of the TfrxCrossColumns class.

Namespace: frxCross
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxCrossColumns
  • frxCross


TfrxCrossColumns Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxCrossColumns.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxCross
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxCrossColumn read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCrossColumn

See Also

Reference

  • TfrxCrossColumns
  • frxCross


TfrxCrossColumns Methods

Methods
Name | Description
Column(Variant[]) | Represents method Column(Variant[]).
GetItems(Integer) | Represents method GetItems(Integer).
InsertItem(Integer,Variant[]) | Represents method InsertItem(Integer,Variant[]). (Overrides TfrxIndexCollection.InsertItem(Integer,Variant[]).)
Top


TfrxCrossColumns.Column(Variant[]) Method

Summary

Represents method Column(Variant[]).

Namespace: frxCross
Syntax
Delphi
public
 function Column(const Indexes: array of Variant): TfrxCrossColumn;

Parameters

Indexes
Type: array of Variant

Return Value

Type: TfrxCrossColumn

See Also

Reference

  • TfrxCrossColumns
  • frxCross


TfrxCrossColumns.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxCrossColumn;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCrossColumn

See Also

Reference

  • TfrxCrossColumns
  • frxCross


TfrxCrossColumns.InsertItem(Integer,Variant[]) Method

Summary

Represents method InsertItem(Integer,Variant[]).

Namespace: frxCross
Syntax
Delphi
public
 function InsertItem(Index: Integer; const Indexes: array of Variant): TfrxIndexItem; override;

Parameters

Index
Type: Integer

Indexes
Type: array of Variant

Return Value

Type: TfrxIndexItem

Overrides

TfrxIndexCollection.InsertItem(Integer,Variant[])
See Also

Reference

  • TfrxCrossColumns
  • frxCross


TfrxCrossCorner Class

Summary

Represents type TfrxCrossCorner.

Namespace: frxCross
Inheritance Hierarchy
TObject
frxCross.TfrxCrossHeader
frxCross.TfrxCrossColumnHeader
frxCross.TfrxCrossCorner
Syntax
Delphi
type
 TfrxCrossCorner = class(TfrxCrossColumnHeader)
 end;

The TfrxCrossCorner type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer) | Initializes a new instance of the TfrxCrossHeader class. (Inherited from TfrxCrossHeader.)
Top
Properties
Show:
Name | Description
Bounds | Represents property Bounds. (Inherited from TfrxCrossHeader.)
Count | Represents property Count. (Inherited from TfrxCrossHeader.)
DefaultHeight | Represents property DefaultHeight. (Inherited from TfrxCrossHeader.)
HasCellHeaders | Represents property HasCellHeaders. (Inherited from TfrxCrossHeader.)
Height | Represents property Height. (Inherited from TfrxCrossHeader.)
IsTotal | Represents property IsTotal. (Inherited from TfrxCrossHeader.)
Items[Integer] | Represents property Items[Integer]. (Inherited from TfrxCrossHeader.)
Level | Represents property Level. (Inherited from TfrxCrossHeader.)
Memo | Represents property Memo. (Inherited from TfrxCrossHeader.)
Parent | Represents property Parent. (Inherited from TfrxCrossHeader.)
Value | Represents property Value. (Inherited from TfrxCrossHeader.)
Visible | Represents property Visible. (Inherited from TfrxCrossHeader.)
Width | Represents property Width. (Inherited from TfrxCrossHeader.)
Top
Methods
Show:
Name | Description
AllItems | Represents method AllItems. (Inherited from TfrxCrossHeader.)
CalcBounds | Represents method CalcBounds. (Overrides TfrxCrossHeader.CalcBounds.)
CalcSizes(Integer,Integer,Boolean) | Represents method CalcSizes(Integer,Integer,Boolean). (Overrides TfrxCrossHeader.CalcSizes(Integer,Integer,Boolean).)
Find(Variant) | Represents method Find(Variant). (Inherited from TfrxCrossHeader.)
GetIndexes | Represents method GetIndexes. (Inherited from TfrxCrossHeader.)
GetValues | Represents method GetValues. (Inherited from TfrxCrossHeader.)
IndexItems | Represents method IndexItems. (Inherited from TfrxCrossHeader.)
TerminalItems | Represents method TerminalItems. (Inherited from TfrxCrossHeader.)
Top
See Also

Reference

  • frxCross


TfrxCrossHeader Class

Summary

Represents type TfrxCrossHeader.

Namespace: frxCross
Inheritance Hierarchy
TObject
frxCross.TfrxCrossHeader
frxCross.TfrxCrossColumnHeader
frxCross.TfrxCrossRowHeader
Syntax
Delphi
type
 TfrxCrossHeader = class(TObject)
 end;

The TfrxCrossHeader type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer) | Initializes a new instance of the TfrxCrossHeader class.
Destroy | Represents the destructor of the TfrxCrossHeader class.
Top
Properties
Show:
Name | Description
Bounds | Represents property Bounds.
Count | Represents property Count.
DefaultHeight | Represents property DefaultHeight.
HasCellHeaders | Represents property HasCellHeaders.
Height | Represents property Height.
IsTotal | Represents property IsTotal.
Items[Integer] | Represents property Items[Integer].
Level | Represents property Level.
Memo | Represents property Memo.
Parent | Represents property Parent.
Value | Represents property Value.
Visible | Represents property Visible.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
AddCellHeader(TList,Integer,Integer) | Represents method AddCellHeader(TList,Integer,Integer).
AddChild(TfrxCustomMemoView) | Represents method AddChild(TfrxCustomMemoView).
AddFuncValues(Variant[],Variant[],TfrxCrossFunction[]) | Represents method AddFuncValues(Variant[],Variant[],TfrxCrossFunction[]).
AddValues(Variant[],Boolean) | Represents method AddValues(Variant[],Boolean).
AllItems | Represents method AllItems.
CalcBounds | Represents method CalcBounds.
CalcSizes(Integer,Integer,Boolean) | Represents method CalcSizes(Integer,Integer,Boolean).
Find(Variant) | Represents method Find(Variant).
GetCount | Represents method GetCount.
GetHeight | Represents method GetHeight.
GetIndexes | Represents method GetIndexes.
GetItems(Integer) | Represents method GetItems(Integer).
GetLevel | Represents method GetLevel.
GetValues | Represents method GetValues.
GetWidth | Represents method GetWidth.
IndexItems | Represents method IndexItems.
Reset(TfrxCrossFunction[]) | Represents method Reset(TfrxCrossFunction[]).
TerminalItems | Represents method TerminalItems.
Top
Fields
Show:
Name | Description
FBounds | Represents field FBounds.
FCellIndex | Represents field FCellIndex.
FCellLevels | Represents field FCellLevels.
FCounts | Represents field FCounts.
FDefaultHeight | Represents field FDefaultHeight.
FFuncValues | Represents field FFuncValues.
FHasCellHeaders | Represents field FHasCellHeaders.
FIndex | Represents field FIndex.
FIsCellHeader | Represents field FIsCellHeader.
FIsIndex | Represents field FIsIndex.
FIsTotal | Represents field FIsTotal.
FItems | Represents field FItems.
FLevelsCount | Represents field FLevelsCount.
FMemo | Represents field FMemo.
FMemos | Represents field FMemos.
FNoLevels | Represents field FNoLevels.
FParent | Represents field FParent.
FRecalcSizes | Represents field FRecalcSizes.
FSize | Represents field FSize.
FTotalIndex | Represents field FTotalIndex.
FTotalMemos | Represents field FTotalMemos.
FValue | Represents field FValue.
FVisible | Represents field FVisible.
Top
See Also

Reference

  • frxCross


TfrxCrossHeader Constructors

Constructors
Name | Description
Create(Integer) | Initializes a new instance of the TfrxCrossHeader class.
Destroy | Represents the destructor of the TfrxCrossHeader class.
Top


TfrxCrossHeader.Create(Integer) Constructor

Summary

Initializes a new instance of the TfrxCrossHeader class.

Namespace: frxCross
Syntax
Delphi
public
 constructor Create(CellLevels: Integer);

Parameters

CellLevels
Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.Destroy Destructor

Summary

Represents the destructor of the TfrxCrossHeader class.

Namespace: frxCross
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader Properties

Properties
Name | Description
Bounds | Represents property Bounds.
Count | Represents property Count.
DefaultHeight | Represents property DefaultHeight.
HasCellHeaders | Represents property HasCellHeaders.
Height | Represents property Height.
IsTotal | Represents property IsTotal.
Items[Integer] | Represents property Items[Integer].
Level | Represents property Level.
Memo | Represents property Memo.
Parent | Represents property Parent.
Value | Represents property Value.
Visible | Represents property Visible.
Width | Represents property Width.
Top


TfrxCrossHeader.Bounds Property

Summary

Represents property Bounds.

Namespace: frxCross
Syntax
Delphi
public
 property Bounds: TfrxRect read FBounds write FBounds;

Property Value

Type: TfrxRect

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.Count Property

Summary

Represents property Count.

Namespace: frxCross
Syntax
Delphi
public
 property Count: Integer read GetCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.DefaultHeight Property

Summary

Represents property DefaultHeight.

Namespace: frxCross
Syntax
Delphi
public
 property DefaultHeight: Integer read FDefaultHeight write FDefaultHeight;

Property Value

Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.HasCellHeaders Property

Summary

Represents property HasCellHeaders.

Namespace: frxCross
Syntax
Delphi
public
 property HasCellHeaders: Boolean read FHasCellHeaders write FHasCellHeaders;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.Height Property

Summary

Represents property Height.

Namespace: frxCross
Syntax
Delphi
public
 property Height: Extended read GetHeight;

Property Value

Type: Extended

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.IsTotal Property

Summary

Represents property IsTotal.

Namespace: frxCross
Syntax
Delphi
public
 property IsTotal: Boolean read FIsTotal;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxCross
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxCrossHeader read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCrossHeader

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.Level Property

Summary

Represents property Level.

Namespace: frxCross
Syntax
Delphi
public
 property Level: Integer read GetLevel;

Property Value

Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.Memo Property

Summary

Represents property Memo.

Namespace: frxCross
Syntax
Delphi
public
 property Memo: TfrxCustomMemoView read FMemo;

Property Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.Parent Property

Summary

Represents property Parent.

Namespace: frxCross
Syntax
Delphi
public
 property Parent: TfrxCrossHeader read FParent;

Property Value

Type: TfrxCrossHeader

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.Value Property

Summary

Represents property Value.

Namespace: frxCross
Syntax
Delphi
public
 property Value: Variant read FValue write FValue;

Property Value

Type: Variant

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.Visible Property

Summary

Represents property Visible.

Namespace: frxCross
Syntax
Delphi
public
 property Visible: Boolean read FVisible write FVisible;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.Width Property

Summary

Represents property Width.

Namespace: frxCross
Syntax
Delphi
public
 property Width: Extended read GetWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader Methods

Methods
Name | Description
AddCellHeader(TList,Integer,Integer) | Represents method AddCellHeader(TList,Integer,Integer).
AddChild(TfrxCustomMemoView) | Represents method AddChild(TfrxCustomMemoView).
AddFuncValues(Variant[],Variant[],TfrxCrossFunction[]) | Represents method AddFuncValues(Variant[],Variant[],TfrxCrossFunction[]).
AddValues(Variant[],Boolean) | Represents method AddValues(Variant[],Boolean).
AllItems | Represents method AllItems.
CalcBounds | Represents method CalcBounds.
CalcSizes(Integer,Integer,Boolean) | Represents method CalcSizes(Integer,Integer,Boolean).
Find(Variant) | Represents method Find(Variant).
GetCount | Represents method GetCount.
GetHeight | Represents method GetHeight.
GetIndexes | Represents method GetIndexes.
GetItems(Integer) | Represents method GetItems(Integer).
GetLevel | Represents method GetLevel.
GetValues | Represents method GetValues.
GetWidth | Represents method GetWidth.
IndexItems | Represents method IndexItems.
Reset(TfrxCrossFunction[]) | Represents method Reset(TfrxCrossFunction[]).
TerminalItems | Represents method TerminalItems.
Top


TfrxCrossHeader.AddCellHeader(TList,Integer,Integer) Method

Summary

Represents method AddCellHeader(TList,Integer,Integer).

Namespace: frxCross
Syntax
Delphi
private
 function AddCellHeader(Memos: TList; Index, CellIndex: Integer): TfrxCrossHeader;

Parameters

Memos
Type: TList

Index
Type: Integer

CellIndex
Type: Integer

Return Value

Type: TfrxCrossHeader

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.AddChild(TfrxCustomMemoView) Method

Summary

Represents method AddChild(TfrxCustomMemoView).

Namespace: frxCross
Syntax
Delphi
private
 function AddChild(Memo: TfrxCustomMemoView): TfrxCrossHeader;

Parameters

Memo
Type: TfrxCustomMemoView

Return Value

Type: TfrxCrossHeader

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.AddFuncValues(Variant[],Variant[],TfrxCrossFunction[]) Method

Summary

Represents method AddFuncValues(Variant[],Variant[],TfrxCrossFunction[]).

Namespace: frxCross
Syntax
Delphi
private
 procedure AddFuncValues(const Values, Counts: array of Variant;
 const CellFunctions: array of TfrxCrossFunction);

Parameters

Values
Type: array of Variant

Counts
Type: array of Variant

CellFunctions
Type: array of TfrxCrossFunction

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.AddValues(Variant[],Boolean) Method

Summary

Represents method AddValues(Variant[],Boolean).

Namespace: frxCross
Syntax
Delphi
private
 procedure AddValues(const Values: array of Variant; Unsorted: Boolean);

Parameters

Values
Type: array of Variant

Unsorted
Type: Boolean

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.AllItems Method

Summary

Represents method AllItems.

Namespace: frxCross
Syntax
Delphi
public
 function AllItems: TList;

Return Value

Type: TList

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.CalcBounds Method

Summary

Represents method CalcBounds.

Namespace: frxCross
Syntax
Delphi
public
 procedure CalcBounds; virtual; abstract;
See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.CalcSizes(Integer,Integer,Boolean) Method

Summary

Represents method CalcSizes(Integer,Integer,Boolean).

Namespace: frxCross
Syntax
Delphi
public
 procedure CalcSizes(MaxWidth, MinWidth: Integer; AutoSize: Boolean); virtual; abstract;

Parameters

MaxWidth
Type: Integer

MinWidth
Type: Integer

AutoSize
Type: Boolean

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.Find(Variant) Method

Summary

Represents method Find(Variant).

Namespace: frxCross
Syntax
Delphi
public
 function Find(Value: Variant): Integer;

Parameters

Value
Type: Variant

Return Value

Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.GetCount Method

Summary

Represents method GetCount.

Namespace: frxCross
Syntax
Delphi
private
 function GetCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.GetHeight Method

Summary

Represents method GetHeight.

Namespace: frxCross
Syntax
Delphi
private
 function GetHeight: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.GetIndexes Method

Summary

Represents method GetIndexes.

Namespace: frxCross
Syntax
Delphi
public
 function GetIndexes: Variant;

Return Value

Type: Variant

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxCrossHeader;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCrossHeader

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.GetLevel Method

Summary

Represents method GetLevel.

Namespace: frxCross
Syntax
Delphi
private
 function GetLevel: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.GetValues Method

Summary

Represents method GetValues.

Namespace: frxCross
Syntax
Delphi
public
 function GetValues: Variant;

Return Value

Type: Variant

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.GetWidth Method

Summary

Represents method GetWidth.

Namespace: frxCross
Syntax
Delphi
private
 function GetWidth: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.IndexItems Method

Summary

Represents method IndexItems.

Namespace: frxCross
Syntax
Delphi
public
 function IndexItems: TList;

Return Value

Type: TList

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.Reset(TfrxCrossFunction[]) Method

Summary

Represents method Reset(TfrxCrossFunction[]).

Namespace: frxCross
Syntax
Delphi
private
 procedure Reset(const CellFunctions: array of TfrxCrossFunction);

Parameters

CellFunctions
Type: array of TfrxCrossFunction

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.TerminalItems Method

Summary

Represents method TerminalItems.

Namespace: frxCross
Syntax
Delphi
public
 function TerminalItems: TList;

Return Value

Type: TList

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader Fields

Fields
Name | Description
FBounds | Represents field FBounds.
FCellIndex | Represents field FCellIndex.
FCellLevels | Represents field FCellLevels.
FCounts | Represents field FCounts.
FDefaultHeight | Represents field FDefaultHeight.
FFuncValues | Represents field FFuncValues.
FHasCellHeaders | Represents field FHasCellHeaders.
FIndex | Represents field FIndex.
FIsCellHeader | Represents field FIsCellHeader.
FIsIndex | Represents field FIsIndex.
FIsTotal | Represents field FIsTotal.
FItems | Represents field FItems.
FLevelsCount | Represents field FLevelsCount.
FMemo | Represents field FMemo.
FMemos | Represents field FMemos.
FNoLevels | Represents field FNoLevels.
FParent | Represents field FParent.
FRecalcSizes | Represents field FRecalcSizes.
FSize | Represents field FSize.
FTotalIndex | Represents field FTotalIndex.
FTotalMemos | Represents field FTotalMemos.
FValue | Represents field FValue.
FVisible | Represents field FVisible.
Top


TfrxCrossHeader.FBounds Field

Summary

Represents field FBounds.

Namespace: frxCross
Syntax
Delphi
private
 FBounds: TfrxRect;

Field Value

Type: TfrxRect

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FCellIndex Field

Summary

Represents field FCellIndex.

Namespace: frxCross
Syntax
Delphi
private
 FCellIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FCellLevels Field

Summary

Represents field FCellLevels.

Namespace: frxCross
Syntax
Delphi
private
 FCellLevels: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FCounts Field

Summary

Represents field FCounts.

Namespace: frxCross
Syntax
Delphi
private
 FCounts: TfrxVariantArray;

Field Value

Type: TfrxVariantArray

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FDefaultHeight Field

Summary

Represents field FDefaultHeight.

Namespace: frxCross
Syntax
Delphi
private
 FDefaultHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FFuncValues Field

Summary

Represents field FFuncValues.

Namespace: frxCross
Syntax
Delphi
private
 FFuncValues: TfrxVariantArray;

Field Value

Type: TfrxVariantArray

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FHasCellHeaders Field

Summary

Represents field FHasCellHeaders.

Namespace: frxCross
Syntax
Delphi
private
 FHasCellHeaders: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FIndex Field

Summary

Represents field FIndex.

Namespace: frxCross
Syntax
Delphi
private
 FIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FIsCellHeader Field

Summary

Represents field FIsCellHeader.

Namespace: frxCross
Syntax
Delphi
private
 FIsCellHeader: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FIsIndex Field

Summary

Represents field FIsIndex.

Namespace: frxCross
Syntax
Delphi
private
 FIsIndex: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FIsTotal Field

Summary

Represents field FIsTotal.

Namespace: frxCross
Syntax
Delphi
private
 FIsTotal: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FItems Field

Summary

Represents field FItems.

Namespace: frxCross
Syntax
Delphi
private
 FItems: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FLevelsCount Field

Summary

Represents field FLevelsCount.

Namespace: frxCross
Syntax
Delphi
private
 FLevelsCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FMemo Field

Summary

Represents field FMemo.

Namespace: frxCross
Syntax
Delphi
private
 FMemo: TfrxCustomMemoView;

Field Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FMemos Field

Summary

Represents field FMemos.

Namespace: frxCross
Syntax
Delphi
private
 FMemos: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FNoLevels Field

Summary

Represents field FNoLevels.

Namespace: frxCross
Syntax
Delphi
private
 FNoLevels: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FParent Field

Summary

Represents field FParent.

Namespace: frxCross
Syntax
Delphi
private
 FParent: TfrxCrossHeader;

Field Value

Type: TfrxCrossHeader

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FRecalcSizes Field

Summary

Represents field FRecalcSizes.

Namespace: frxCross
Syntax
Delphi
private
 FRecalcSizes: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FSize Field

Summary

Represents field FSize.

Namespace: frxCross
Syntax
Delphi
private
 FSize: TfrxPoint;

Field Value

Type: TfrxPoint

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FTotalIndex Field

Summary

Represents field FTotalIndex.

Namespace: frxCross
Syntax
Delphi
private
 FTotalIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FTotalMemos Field

Summary

Represents field FTotalMemos.

Namespace: frxCross
Syntax
Delphi
private
 FTotalMemos: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FValue Field

Summary

Represents field FValue.

Namespace: frxCross
Syntax
Delphi
private
 FValue: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossHeader.FVisible Field

Summary

Represents field FVisible.

Namespace: frxCross
Syntax
Delphi
private
 FVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCrossHeader
  • frxCross


TfrxCrossObject Class

Summary

The TfrxCrossObject lets you use the Cross-tab component in your report. TfrxCrossObject is an empty component. It is used to add the frxCross.pas file to the "uses" list. The main component is TfrxCrossView and TfrxDBCrossView.

Namespace: frxCross
Inheritance Hierarchy
TComponent
frxCross.TfrxCrossObject
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxCrossObject = class(TComponent);
See Also

Reference

  • frxCross


TfrxCrossRow Class

Summary

Represents type TfrxCrossRow.

Namespace: frxCross
Inheritance Hierarchy
TCollectionItem
frxCross.TfrxIndexItem
frxCross.TfrxCrossRow
Syntax
Delphi
type
 TfrxCrossRow = class(TfrxIndexItem)
 end;

The TfrxCrossRow type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxCrossRow class.
Destroy | Represents the destructor of the TfrxCrossRow class. (Overrides TfrxIndexItem.Destroy.)
Top
Properties
Show:
Name | Description
Indexes | Represents property Indexes. (Inherited from TfrxIndexItem.)
Top
Methods
Show:
Name | Description
CreateCell(Integer) | Represents method CreateCell(Integer).
GetCell(Integer) | Represents method GetCell(Integer).
GetCellValue(Integer,Integer) | Represents method GetCellValue(Integer,Integer).
SetCellValue(Integer,Integer,Variant) | Represents method SetCellValue(Integer,Integer,Variant).
Top
Fields
Show:
Name | Description
FCellLevels | Represents field FCellLevels.
FCells | Represents field FCells.
Top
See Also

Reference

  • frxCross


TfrxCrossRow Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxCrossRow class.
Destroy | Represents the destructor of the TfrxCrossRow class. (Overrides TfrxIndexItem.Destroy.)
Top


TfrxCrossRow.Create(TCollection) Constructor

Summary

Initializes a new instance of the TfrxCrossRow class.

Namespace: frxCross
Syntax
Delphi
public
 constructor Create(Collection: TCollection); override;

Parameters

Collection
Type: TCollection

See Also

Reference

  • TfrxCrossRow
  • frxCross


TfrxCrossRow.Destroy Destructor

Summary

Represents the destructor of the TfrxCrossRow class.

Namespace: frxCross
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxIndexItem.Destroy
See Also

Reference

  • TfrxCrossRow
  • frxCross


TfrxCrossRow Methods

Methods
Name | Description
CreateCell(Integer) | Represents method CreateCell(Integer).
GetCell(Integer) | Represents method GetCell(Integer).
GetCellValue(Integer,Integer) | Represents method GetCellValue(Integer,Integer).
SetCellValue(Integer,Integer,Variant) | Represents method SetCellValue(Integer,Integer,Variant).
Top


TfrxCrossRow.CreateCell(Integer) Method

Summary

Represents method CreateCell(Integer).

Namespace: frxCross
Syntax
Delphi
private
 procedure CreateCell(Index: Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TfrxCrossRow
  • frxCross


TfrxCrossRow.GetCell(Integer) Method

Summary

Represents method GetCell(Integer).

Namespace: frxCross
Syntax
Delphi
public
 function GetCell(Index: Integer): PfrCrossCell;

Parameters

Index
Type: Integer

Return Value

Type: PfrCrossCell

See Also

Reference

  • TfrxCrossRow
  • frxCross


TfrxCrossRow.GetCellValue(Integer,Integer) Method

Summary

Represents method GetCellValue(Integer,Integer).

Namespace: frxCross
Syntax
Delphi
public
 function GetCellValue(Index1, Index2: Integer): Variant;

Parameters

Index1
Type: Integer

Index2
Type: Integer

Return Value

Type: Variant

See Also

Reference

  • TfrxCrossRow
  • frxCross


TfrxCrossRow.SetCellValue(Integer,Integer,Variant) Method

Summary

Represents method SetCellValue(Integer,Integer,Variant).

Namespace: frxCross
Syntax
Delphi
public
 procedure SetCellValue(Index1, Index2: Integer; const Value: Variant);

Parameters

Index1
Type: Integer

Index2
Type: Integer

Value
Type: Variant

See Also

Reference

  • TfrxCrossRow
  • frxCross


TfrxCrossRow Fields

Fields
Name | Description
FCellLevels | Represents field FCellLevels.
FCells | Represents field FCells.
Top


TfrxCrossRow.FCellLevels Field

Summary

Represents field FCellLevels.

Namespace: frxCross
Syntax
Delphi
private
 FCellLevels: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCrossRow
  • frxCross


TfrxCrossRow.FCells Field

Summary

Represents field FCells.

Namespace: frxCross
Syntax
Delphi
private
 FCells: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCrossRow
  • frxCross


TfrxCrossRowHeader Class

Summary

Represents type TfrxCrossRowHeader.

Namespace: frxCross
Inheritance Hierarchy
TObject
frxCross.TfrxCrossHeader
frxCross.TfrxCrossRowHeader
Syntax
Delphi
type
 TfrxCrossRowHeader = class(TfrxCrossHeader)
 end;

The TfrxCrossRowHeader type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer) | Initializes a new instance of the TfrxCrossHeader class. (Inherited from TfrxCrossHeader.)
Top
Properties
Show:
Name | Description
Bounds | Represents property Bounds. (Inherited from TfrxCrossHeader.)
Count | Represents property Count. (Inherited from TfrxCrossHeader.)
DefaultHeight | Represents property DefaultHeight. (Inherited from TfrxCrossHeader.)
HasCellHeaders | Represents property HasCellHeaders. (Inherited from TfrxCrossHeader.)
Height | Represents property Height. (Inherited from TfrxCrossHeader.)
IsTotal | Represents property IsTotal. (Inherited from TfrxCrossHeader.)
Items[Integer] | Represents property Items[Integer]. (Inherited from TfrxCrossHeader.)
Level | Represents property Level. (Inherited from TfrxCrossHeader.)
Memo | Represents property Memo. (Inherited from TfrxCrossHeader.)
Parent | Represents property Parent. (Inherited from TfrxCrossHeader.)
Value | Represents property Value. (Inherited from TfrxCrossHeader.)
Visible | Represents property Visible. (Inherited from TfrxCrossHeader.)
Width | Represents property Width. (Inherited from TfrxCrossHeader.)
Top
Methods
Show:
Name | Description
AllItems | Represents method AllItems. (Inherited from TfrxCrossHeader.)
CalcBounds | Represents method CalcBounds. (Overrides TfrxCrossHeader.CalcBounds.)
CalcSizes(Integer,Integer,Boolean) | Represents method CalcSizes(Integer,Integer,Boolean). (Overrides TfrxCrossHeader.CalcSizes(Integer,Integer,Boolean).)
Find(Variant) | Represents method Find(Variant). (Inherited from TfrxCrossHeader.)
GetIndexes | Represents method GetIndexes. (Inherited from TfrxCrossHeader.)
GetValues | Represents method GetValues. (Inherited from TfrxCrossHeader.)
IndexItems | Represents method IndexItems. (Inherited from TfrxCrossHeader.)
TerminalItems | Represents method TerminalItems. (Inherited from TfrxCrossHeader.)
Top
Fields
Show:
Name | Description
FCorner | Represents field FCorner.
Top
See Also

Reference

  • frxCross


TfrxCrossRowHeader Methods

Methods
Name | Description
CalcBounds | Represents method CalcBounds. (Overrides TfrxCrossHeader.CalcBounds.)
CalcSizes(Integer,Integer,Boolean) | Represents method CalcSizes(Integer,Integer,Boolean). (Overrides TfrxCrossHeader.CalcSizes(Integer,Integer,Boolean).)
Top


TfrxCrossRowHeader.CalcBounds Method

Summary

Represents method CalcBounds.

Namespace: frxCross
Syntax
Delphi
public
 procedure CalcBounds; override;

Overrides

TfrxCrossHeader.CalcBounds
See Also

Reference

  • TfrxCrossRowHeader
  • frxCross


TfrxCrossRowHeader.CalcSizes(Integer,Integer,Boolean) Method

Summary

Represents method CalcSizes(Integer,Integer,Boolean).

Namespace: frxCross
Syntax
Delphi
public
 procedure CalcSizes(MaxWidth, MinWidth: Integer; AutoSize: Boolean); override;

Parameters

MaxWidth
Type: Integer

MinWidth
Type: Integer

AutoSize
Type: Boolean

Overrides

TfrxCrossHeader.CalcSizes(Integer,Integer,Boolean)
See Also

Reference

  • TfrxCrossRowHeader
  • frxCross


TfrxCrossRowHeader Fields

Fields
Name | Description
FCorner | Represents field FCorner.
Top


TfrxCrossRowHeader.FCorner Field

Summary

Represents field FCorner.

Namespace: frxCross
Syntax
Delphi
private
 FCorner: TfrxCrossHeader;

Field Value

Type: TfrxCrossHeader

See Also

Reference

  • TfrxCrossRowHeader
  • frxCross


TfrxCrossRows Class

Summary

Represents type TfrxCrossRows.

Namespace: frxCross
Inheritance Hierarchy
TCollection
frxCross.TfrxIndexCollection
frxCross.TfrxCrossRows
Syntax
Delphi
type
 TfrxCrossRows = class(TfrxIndexCollection)
 end;

The TfrxCrossRows type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxCrossRows class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Find(Variant[],Integer) | Represents method Find(Variant[],Integer). (Inherited from TfrxIndexCollection.)
GetItems(Integer) | Represents method GetItems(Integer).
InsertItem(Integer,Variant[]) | Represents method InsertItem(Integer,Variant[]). (Overrides TfrxIndexCollection.InsertItem(Integer,Variant[]).)
Row(Variant[]) | Represents method Row(Variant[]).
Top
Fields
Show:
Name | Description
FCellLevels | Represents field FCellLevels.
Top
See Also

Reference

  • frxCross


TfrxCrossRows Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxCrossRows class.
Top


TfrxCrossRows.Create Constructor

Summary

Initializes a new instance of the TfrxCrossRows class.

Namespace: frxCross
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxCrossRows
  • frxCross


TfrxCrossRows Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxCrossRows.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxCross
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxCrossRow read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCrossRow

See Also

Reference

  • TfrxCrossRows
  • frxCross


TfrxCrossRows Methods

Methods
Name | Description
GetItems(Integer) | Represents method GetItems(Integer).
InsertItem(Integer,Variant[]) | Represents method InsertItem(Integer,Variant[]). (Overrides TfrxIndexCollection.InsertItem(Integer,Variant[]).)
Row(Variant[]) | Represents method Row(Variant[]).
Top


TfrxCrossRows.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxCrossRow;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCrossRow

See Also

Reference

  • TfrxCrossRows
  • frxCross


TfrxCrossRows.InsertItem(Integer,Variant[]) Method

Summary

Represents method InsertItem(Integer,Variant[]).

Namespace: frxCross
Syntax
Delphi
public
 function InsertItem(Index: Integer; const Indexes: array of Variant): TfrxIndexItem; override;

Parameters

Index
Type: Integer

Indexes
Type: array of Variant

Return Value

Type: TfrxIndexItem

Overrides

TfrxIndexCollection.InsertItem(Integer,Variant[])
See Also

Reference

  • TfrxCrossRows
  • frxCross


TfrxCrossRows.Row(Variant[]) Method

Summary

Represents method Row(Variant[]).

Namespace: frxCross
Syntax
Delphi
public
 function Row(const Indexes: array of Variant): TfrxCrossRow;

Parameters

Indexes
Type: array of Variant

Return Value

Type: TfrxCrossRow

See Also

Reference

  • TfrxCrossRows
  • frxCross


TfrxCrossRows Fields

Fields
Name | Description
FCellLevels | Represents field FCellLevels.
Top


TfrxCrossRows.FCellLevels Field

Summary

Represents field FCellLevels.

Namespace: frxCross
Syntax
Delphi
private
 FCellLevels: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCrossRows
  • frxCross


TfrxCrossView Class

Summary

The TfrxCrossView component shows a cross-table. The component can show non-DB data, you should fill it using AddValue method in the OnBeforePrint event.

Namespace: frxCross
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxCross.TfrxCustomCrossView
frxCross.TfrxCrossView
Syntax
Delphi
type
 TfrxCrossView = class(TfrxCustomCrossView)
 end;

The TfrxCrossView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomCrossView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AddHeight | Represents property AddHeight. (Inherited from TfrxCustomCrossView.)
AddWidth | Represents property AddWidth. (Inherited from TfrxCustomCrossView.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowDuplicates | Represents property AllowDuplicates. (Inherited from TfrxCustomCrossView.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
AutoSize | Represents property AutoSize. (Inherited from TfrxCustomCrossView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Border | Determines whether the cross-table should have an outer border. Default value is True. (Inherited from TfrxCustomCrossView.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
CellFields | Represents property CellFields. (Inherited from TfrxCustomCrossView.)
CellFunctions[Integer] | Aggregate functions for each cell level. (Inherited from TfrxCustomCrossView.)
CellHeaderMemos[Integer] | Represents property CellHeaderMemos[Integer]. (Inherited from TfrxCustomCrossView.)
CellLevels | Number of levels of cross-tab cell. (Inherited from TfrxCustomCrossView.)
CellMemos[Integer] | Array of Text objects that represents each level of cell. First array element has 0 index. (Inherited from TfrxCustomCrossView.)
ClearBeforePrint | Represents property ClearBeforePrint. (Inherited from TfrxCustomCrossView.)
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ColumnFields | Represents property ColumnFields. (Inherited from TfrxCustomCrossView.)
ColumnHeader | Represents property ColumnHeader. (Inherited from TfrxCustomCrossView.)
ColumnLevels | Number of levels in the column header. (Inherited from TfrxCustomCrossView.)
ColumnMemos[Integer] | Array of Text objects that represents each level of column header. First array element has 0 index. (Inherited from TfrxCustomCrossView.)
ColumnSort[Integer] | Sort order for each level of column header. (Inherited from TfrxCustomCrossView.)
ColumnTotalMemos[Integer] | Array of Text objects that represents each total cell of column header. First array element has 0 index and is represents the grand total. (Inherited from TfrxCustomCrossView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Corner | Represents property Corner. (Inherited from TfrxCustomCrossView.)
CornerMemos[Integer] | Array of Text objects that represents the table header. The first array element has 0 index and is represents the top left corner, the second represents all columns header, CornerMemos[2..RowLevels+2] are row levels headers. (Inherited from TfrxCustomCrossView.)
Cursor | Object's cursor (in the preview mode). (Inherited from TfrxView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
DefHeight | Default height of each row. If this property is 0 (default), the height of each row is calculated automatically. (Inherited from TfrxCustomCrossView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DotMatrix | Represents property DotMatrix. (Inherited from TfrxCustomCrossView.)
DownThenAcross | Determines how the big table will break across pages. If this property is False (default), the table will break across then down. (Inherited from TfrxCustomCrossView.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Object's frame. (Inherited from TfrxView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GapX | The left indent of the text in the cross-tab cells. (Inherited from TfrxCustomCrossView.)
GapY | The top indent of the text in the cross-tab cells. (Inherited from TfrxCustomCrossView.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
JoinEqualCells | Determines whether to join several side-by-side cells with equal values into one wide cell. (Inherited from TfrxCustomCrossView.)
KeepRowsTogether | Represents property KeepRowsTogether. (Inherited from TfrxCustomCrossView.)
KeepTogether | Represents property KeepTogether. (Inherited from TfrxCustomCrossView.)
Left | Represents property Left. (Inherited from TfrxView.)
MaxWidth | The maximum width of the cross-tab column. If this property is 0 (default), the width is calculated automatically. (Inherited from TfrxCustomCrossView.)
MinWidth | The minimum width of the cross-tab column. If this property is 0 (default), the width is calculated automatically. (Inherited from TfrxCustomCrossView.)
NextCross | The next cross-tab object that will be rendered side-by-side. (Inherited from TfrxCustomCrossView.)
NextCrossGap | The gap between two side-by-side crosses (see NextCross). (Inherited from TfrxCustomCrossView.)
NoColumns | Represents property NoColumns. (Inherited from TfrxCustomCrossView.)
NoRows | Represents property NoRows. (Inherited from TfrxCustomCrossView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnCalcHeight | Name of the script procedure that will run when calculating a height of each row. (Inherited from TfrxCustomCrossView.)
OnCalcWidth | Name of the script procedure that will run when calculating a width of each column. (Inherited from TfrxCustomCrossView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
OnPrintCell | Name of the script procedure that will run before printing each cell of the cross-table. (Inherited from TfrxCustomCrossView.)
OnPrintColumnHeader | Name of the script procedure that will run before printing eachelement of the column header. (Inherited from TfrxCustomCrossView.)
OnPrintRowHeader | Name of the script procedure that will run before printing each element of the row header. (Inherited from TfrxCustomCrossView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainCells | Determines whether to print cell levels stacked (default) or side-by-side. (Inherited from TfrxCustomCrossView.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
RepeatHeaders | Determines whether cross-tab should repeat column and row headers on each new page. Default value is True. (Inherited from TfrxCustomCrossView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
RowFields | Represents property RowFields. (Inherited from TfrxCustomCrossView.)
RowHeader | Represents property RowHeader. (Inherited from TfrxCustomCrossView.)
RowLevels | Number of levels in the row header. (Inherited from TfrxCustomCrossView.)
RowMemos[Integer] | Array of Text objects that represents each level of row header. First array element has 0 index. (Inherited from TfrxCustomCrossView.)
RowSort[Integer] | Sort order for each level of row header. (Inherited from TfrxCustomCrossView.)
RowTotalMemos[Integer] | Array of Text objects that represents each total cell of row header. First array element has 0 index and is represents the grand total. (Inherited from TfrxCustomCrossView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowCellBreak | Represents property ShowCellBreak. (Inherited from TfrxCustomCrossView.)
ShowColumnHeader | Determines whether to show column header or not. Default value is True. (Inherited from TfrxCustomCrossView.)
ShowColumnTotal | Determines if column total is shown. Default value is True. (Inherited from TfrxCustomCrossView.)
ShowCorner | Determines whether to show top-left corner elements (table headers). (Inherited from TfrxCustomCrossView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
ShowRowHeader | Determines if row header is shown. Default value is True. (Inherited from TfrxCustomCrossView.)
ShowRowTotal | Determines if row total is shown. Default value is True. (Inherited from TfrxCustomCrossView.)
ShowTitle | Represents property ShowTitle. (Inherited from TfrxCustomCrossView.)
SuppressNullRecords | Represents property SuppressNullRecords. (Inherited from TfrxCustomCrossView.)
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Overrides TfrxComponent.AddSourceObjects.)
AddValue(Variant[],Variant[],Variant[]) | Method adds a value into cross-table. Use this method to fill in the TfrxCrossView object. (Inherited from TfrxCustomCrossView.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
ApplyStyle(TfrxStyles) | Represents method ApplyStyle(TfrxStyles). (Inherited from TfrxCustomCrossView.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Overrides TfrxComponent.BeforeStartReport.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
BeginMatrix | Represents method BeginMatrix. (Inherited from TfrxCustomCrossView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ColCount | Returns a number of columns in the cross. (Inherited from TfrxCustomCrossView.)
ColumnHeaderHeight | Represents method ColumnHeaderHeight. (Inherited from TfrxCustomCrossView.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Overrides TfrxComponent.ContainerAdd(TfrxComponent).)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxCustomCrossView.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawCross(TCanvas,Extended,Extended,Extended,Extended) | Represents method DrawCross(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxCustomCrossView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
EndMatrix | Represents method EndMatrix. (Inherited from TfrxCustomCrossView.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FillMatrix | Represents method FillMatrix. (Inherited from TfrxCustomCrossView.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColumnIndexes(Integer) | Represents method GetColumnIndexes(Integer). (Inherited from TfrxCustomCrossView.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Overrides TfrxComponent.GetContainerObjects.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetRowIndexes(Integer) | Represents method GetRowIndexes(Integer). (Inherited from TfrxCustomCrossView.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetStyle(TfrxStyles) | Represents method GetStyle(TfrxStyles). (Inherited from TfrxCustomCrossView.)
GetValue(Integer,Integer,Integer) | Represents method GetValue(Integer,Integer,Integer). (Inherited from TfrxCustomCrossView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxView.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsCrossValid | Represents method IsCrossValid. (Overrides TfrxCustomCrossView.IsCrossValid.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsGrandTotalColumn(Integer) | Returns True if specified column is grand total column. (Inherited from TfrxCustomCrossView.)
IsGrandTotalRow(Integer) | Returns True if specified row is grand total row. (Inherited from TfrxCustomCrossView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsTotalColumn(Integer) | Returns True if specified column is total column. (Inherited from TfrxCustomCrossView.)
IsTotalRow(Integer) | Returns True if specified row is total row. (Inherited from TfrxCustomCrossView.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
RowCount | Returns a number of rows in the cross. (Inherited from TfrxCustomCrossView.)
RowHeaderWidth | Represents method RowHeaderWidth. (Inherited from TfrxCustomCrossView.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCellLevels(Integer) | Represents method SetCellLevels(Integer). (Overrides TfrxCustomCrossView.SetCellLevels(Integer).)
SetColumnLevels(Integer) | Represents method SetColumnLevels(Integer). (Overrides TfrxCustomCrossView.SetColumnLevels(Integer).)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetRowLevels(Integer) | Represents method SetRowLevels(Integer). (Overrides TfrxCustomCrossView.SetRowLevels(Integer).)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Events
Show:
Name | Description
OnBeforeCalcHeight | Represents property OnBeforeCalcHeight. (Inherited from TfrxCustomCrossView.)
OnBeforeCalcWidth | Represents property OnBeforeCalcWidth. (Inherited from TfrxCustomCrossView.)
OnBeforePrintCell | Represents property OnBeforePrintCell. (Inherited from TfrxCustomCrossView.)
OnBeforePrintColumnHeader | Represents property OnBeforePrintColumnHeader. (Inherited from TfrxCustomCrossView.)
OnBeforePrintRowHeader | Represents property OnBeforePrintRowHeader. (Inherited from TfrxCustomCrossView.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxCross


TfrxCrossView Methods

Methods
Name | Description
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
IsCrossValid | Represents method IsCrossValid. (Overrides TfrxCustomCrossView.IsCrossValid.)
SetCellLevels(Integer) | Represents method SetCellLevels(Integer). (Overrides TfrxCustomCrossView.SetCellLevels(Integer).)
SetColumnLevels(Integer) | Represents method SetColumnLevels(Integer). (Overrides TfrxCustomCrossView.SetColumnLevels(Integer).)
SetRowLevels(Integer) | Represents method SetRowLevels(Integer). (Overrides TfrxCustomCrossView.SetRowLevels(Integer).)
Top


TfrxCrossView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxCross
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxCrossView
  • frxCross


TfrxCrossView.IsCrossValid Method

Summary

Represents method IsCrossValid.

Namespace: frxCross
Syntax
Delphi
public
 function IsCrossValid: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCustomCrossView.IsCrossValid
See Also

Reference

  • TfrxCrossView
  • frxCross


TfrxCrossView.SetCellLevels(Integer) Method

Summary

Represents method SetCellLevels(Integer).

Namespace: frxCross
Syntax
Delphi
protected
 procedure SetCellLevels(const Value: Integer); override;

Parameters

Value
Type: Integer

Overrides

TfrxCustomCrossView.SetCellLevels(Integer)
See Also

Reference

  • TfrxCrossView
  • frxCross


TfrxCrossView.SetColumnLevels(Integer) Method

Summary

Represents method SetColumnLevels(Integer).

Namespace: frxCross
Syntax
Delphi
protected
 procedure SetColumnLevels(const Value: Integer); override;

Parameters

Value
Type: Integer

Overrides

TfrxCustomCrossView.SetColumnLevels(Integer)
See Also

Reference

  • TfrxCrossView
  • frxCross


TfrxCrossView.SetRowLevels(Integer) Method

Summary

Represents method SetRowLevels(Integer).

Namespace: frxCross
Syntax
Delphi
protected
 procedure SetRowLevels(const Value: Integer); override;

Parameters

Value
Type: Integer

Overrides

TfrxCustomCrossView.SetRowLevels(Integer)
See Also

Reference

  • TfrxCrossView
  • frxCross


TfrxCustomCrossView Class

Summary

The TfrxCustomCrossView component is the base class for TfrxCrossView, TfrxDBCrossView components.

Namespace: frxCross
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxCross.TfrxCustomCrossView
frxCross.TfrxCrossView
frxCross.TfrxDBCrossView
Syntax
Delphi
type
 TfrxCustomCrossView = class(TfrxView)
 end;

The TfrxCustomCrossView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomCrossView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxCustomCrossView class. (Overrides TfrxView.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AddHeight | Represents property AddHeight.
AddWidth | Represents property AddWidth.
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowDuplicates | Represents property AllowDuplicates.
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
AutoSize | Represents property AutoSize.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Border | Determines whether the cross-table should have an outer border. Default value is True.
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
CellFields | Represents property CellFields.
CellFunctions[Integer] | Aggregate functions for each cell level.
CellHeaderMemos[Integer] | Represents property CellHeaderMemos[Integer].
CellLevels | Number of levels of cross-tab cell.
CellMemos[Integer] | Array of Text objects that represents each level of cell. First array element has 0 index.
ClearBeforePrint | Represents property ClearBeforePrint.
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ColumnFields | Represents property ColumnFields.
ColumnHeader | Represents property ColumnHeader.
ColumnLevels | Number of levels in the column header.
ColumnMemos[Integer] | Array of Text objects that represents each level of column header. First array element has 0 index.
ColumnSort[Integer] | Sort order for each level of column header.
ColumnTotalMemos[Integer] | Array of Text objects that represents each total cell of column header. First array element has 0 index and is represents the grand total.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Corner | Represents property Corner.
CornerMemos[Integer] | Array of Text objects that represents the table header. The first array element has 0 index and is represents the top left corner, the second represents all columns header, CornerMemos[2..RowLevels+2] are row levels headers.
Cursor | Object's cursor (in the preview mode). (Inherited from TfrxView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
DefHeight | Default height of each row. If this property is 0 (default), the height of each row is calculated automatically.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DotMatrix | Represents property DotMatrix.
DownThenAcross | Determines how the big table will break across pages. If this property is False (default), the table will break across then down.
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Object's frame. (Inherited from TfrxView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GapX | The left indent of the text in the cross-tab cells.
GapY | The top indent of the text in the cross-tab cells.
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
JoinEqualCells | Determines whether to join several side-by-side cells with equal values into one wide cell.
KeepRowsTogether | Represents property KeepRowsTogether.
KeepTogether | Represents property KeepTogether.
Left | Represents property Left. (Inherited from TfrxView.)
MaxWidth | The maximum width of the cross-tab column. If this property is 0 (default), the width is calculated automatically.
MinWidth | The minimum width of the cross-tab column. If this property is 0 (default), the width is calculated automatically.
NextCross | The next cross-tab object that will be rendered side-by-side.
NextCrossGap | The gap between two side-by-side crosses (see NextCross).
NoColumns | Represents property NoColumns.
NoRows | Represents property NoRows.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnCalcHeight | Name of the script procedure that will run when calculating a height of each row.
OnCalcWidth | Name of the script procedure that will run when calculating a width of each column.
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
OnPrintCell | Name of the script procedure that will run before printing each cell of the cross-table.
OnPrintColumnHeader | Name of the script procedure that will run before printing eachelement of the column header.
OnPrintRowHeader | Name of the script procedure that will run before printing each element of the row header.
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainCells | Determines whether to print cell levels stacked (default) or side-by-side.
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
RepeatHeaders | Determines whether cross-tab should repeat column and row headers on each new page. Default value is True.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
RowFields | Represents property RowFields.
RowHeader | Represents property RowHeader.
RowLevels | Number of levels in the row header.
RowMemos[Integer] | Array of Text objects that represents each level of row header. First array element has 0 index.
RowSort[Integer] | Sort order for each level of row header.
RowTotalMemos[Integer] | Array of Text objects that represents each total cell of row header. First array element has 0 index and is represents the grand total.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowCellBreak | Represents property ShowCellBreak.
ShowColumnHeader | Determines whether to show column header or not. Default value is True.
ShowColumnTotal | Determines if column total is shown. Default value is True.
ShowCorner | Determines whether to show top-left corner elements (table headers).
ShowHint | Show/hide hint. (Inherited from TfrxView.)
ShowRowHeader | Determines if row header is shown. Default value is True.
ShowRowTotal | Determines if row total is shown. Default value is True.
ShowTitle | Represents property ShowTitle.
SuppressNullRecords | Represents property SuppressNullRecords.
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Overrides TfrxComponent.AddSourceObjects.)
AddValue(Variant[],Variant[],Variant[]) | Method adds a value into cross-table. Use this method to fill in the TfrxCrossView object.
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
ApplyStyle(TfrxStyles) | Represents method ApplyStyle(TfrxStyles).
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Overrides TfrxComponent.BeforeStartReport.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
BeginMatrix | Represents method BeginMatrix.
BuildColumnBands | Represents method BuildColumnBands.
BuildRowBands | Represents method BuildRowBands.
CalcBounds(Extended,Extended) | Represents method CalcBounds(Extended,Extended).
CalcTotal(TfrxCrossHeader,TfrxIndexCollection) | Represents method CalcTotal(TfrxCrossHeader,TfrxIndexCollection).
CalcTotals | Represents method CalcTotals.
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ClearMatrix | Represents method ClearMatrix.
ClearMemos | Represents method ClearMemos.
ColCount | Returns a number of columns in the cross.
ColumnHeaderHeight | Represents method ColumnHeaderHeight.
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Overrides TfrxComponent.ContainerAdd(TfrxComponent).)
CorrectDMPBounds(TfrxCustomMemoView) | Represents method CorrectDMPBounds(TfrxCustomMemoView).
CreateCellHeaderMemos(Integer) | Represents method CreateCellHeaderMemos(Integer).
CreateCellMemos(Integer) | Represents method CreateCellMemos(Integer).
CreateColumnMemos(Integer) | Represents method CreateColumnMemos(Integer).
CreateCornerMemos(Integer) | Represents method CreateCornerMemos(Integer).
CreateHeader(TfrxCrossHeader,TfrxIndexCollection,TList,Boolean) | Represents method CreateHeader(TfrxCrossHeader,TfrxIndexCollection,TList,Boolean).
CreateHeaders | Represents method CreateHeaders.
CreateMemo(TfrxComponent) | Represents method CreateMemo(TfrxComponent).
CreateRowMemos(Integer) | Represents method CreateRowMemos(Integer).
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoCalcHeight(Integer,Extended) | Represents method DoCalcHeight(Integer,Extended).
DoCalcWidth(Integer,Extended) | Represents method DoCalcWidth(Integer,Extended).
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
DoOnCell(TfrxCustomMemoView,Integer,Integer,Integer,Variant) | Represents method DoOnCell(TfrxCustomMemoView,Integer,Integer,Integer,Variant).
DoOnColumnHeader(TfrxCustomMemoView,TfrxCrossHeader) | Represents method DoOnColumnHeader(TfrxCustomMemoView,TfrxCrossHeader).
DoOnRowHeader(TfrxCustomMemoView,TfrxCrossHeader) | Represents method DoOnRowHeader(TfrxCustomMemoView,TfrxCrossHeader).
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawCross(TCanvas,Extended,Extended,Extended,Extended) | Represents method DrawCross(TCanvas,Extended,Extended,Extended,Extended).
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
EndMatrix | Represents method EndMatrix.
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FillMatrix | Represents method FillMatrix.
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetCellFunctions(Integer) | Represents method GetCellFunctions(Integer).
GetCellHeaderMemos(Integer) | Represents method GetCellHeaderMemos(Integer).
GetCellMemos(Integer) | Represents method GetCellMemos(Integer).
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColumnIndexes(Integer) | Represents method GetColumnIndexes(Integer).
GetColumnMemos(Integer) | Represents method GetColumnMemos(Integer).
GetColumnSort(Integer) | Represents method GetColumnSort(Integer).
GetColumnTotalMemos(Integer) | Represents method GetColumnTotalMemos(Integer).
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Overrides TfrxComponent.GetContainerObjects.)
GetCornerMemos(Integer) | Represents method GetCornerMemos(Integer).
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetNestedObjects | Represents method GetNestedObjects.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetRowIndexes(Integer) | Represents method GetRowIndexes(Integer).
GetRowMemos(Integer) | Represents method GetRowMemos(Integer).
GetRowSort(Integer) | Represents method GetRowSort(Integer).
GetRowTotalMemos(Integer) | Represents method GetRowTotalMemos(Integer).
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetStyle(TfrxStyles) | Represents method GetStyle(TfrxStyles).
GetValue(Integer,Integer,Integer) | Represents method GetValue(Integer,Integer,Integer).
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitMatrix | Represents method InitMatrix.
InitMemos(Boolean) | Represents method InitMemos(Boolean).
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxView.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsCrossValid | Represents method IsCrossValid.
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsGrandTotalColumn(Integer) | Returns True if specified column is grand total column.
IsGrandTotalRow(Integer) | Returns True if specified row is grand total row.
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsTotalColumn(Integer) | Returns True if specified column is total column.
IsTotalRow(Integer) | Returns True if specified row is total row.
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadMemos(TStream) | Represents method ReadMemos(TStream).
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
RenderMatrix | Represents method RenderMatrix.
RowCount | Returns a number of rows in the cross.
RowHeaderWidth | Represents method RowHeaderWidth.
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCellFields(TStrings) | Represents method SetCellFields(TStrings).
SetCellFunctions(Integer,TfrxCrossFunction) | Represents method SetCellFunctions(Integer,TfrxCrossFunction).
SetCellLevels(Integer) | Represents method SetCellLevels(Integer).
SetColumnFields(TStrings) | Represents method SetColumnFields(TStrings).
SetColumnLevels(Integer) | Represents method SetColumnLevels(Integer).
SetColumnSort(Integer,TfrxCrossSortOrder) | Represents method SetColumnSort(Integer,TfrxCrossSortOrder).
SetDotMatrix(Boolean) | Represents method SetDotMatrix(Boolean).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetRowFields(TStrings) | Represents method SetRowFields(TStrings).
SetRowLevels(Integer) | Represents method SetRowLevels(Integer).
SetRowSort(Integer,TfrxCrossSortOrder) | Represents method SetRowSort(Integer,TfrxCrossSortOrder).
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetupOriginalComponent(TfrxComponent,TfrxComponent) | Represents method SetupOriginalComponent(TfrxComponent,TfrxComponent).
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateVisibility | Represents method UpdateVisibility.
WriteMemos(TStream) | Represents method WriteMemos(TStream).
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Events
Show:
Name | Description
OnBeforeCalcHeight | Represents property OnBeforeCalcHeight.
OnBeforeCalcWidth | Represents property OnBeforeCalcWidth.
OnBeforePrintCell | Represents property OnBeforePrintCell.
OnBeforePrintColumnHeader | Represents property OnBeforePrintColumnHeader.
OnBeforePrintRowHeader | Represents property OnBeforePrintRowHeader.
Top
Fields
Show:
Name | Description
FAddHeight | Represents field FAddHeight.
FAddWidth | Represents field FAddWidth.
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAllMemos | Represents field FAllMemos.
FAllowDuplicates | Represents field FAllowDuplicates.
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FAutoSize | Represents field FAutoSize.
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FBorder | Represents field FBorder.
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FCellFields | Represents field FCellFields.
FCellFunctions | Represents field FCellFunctions.
FCellHeaderMemos | Represents field FCellHeaderMemos.
FCellLevels | Represents field FCellLevels.
FCellMemos | Represents field FCellMemos.
FClearBeforePrint | Represents field FClearBeforePrint.
FColumnBands | Represents field FColumnBands.
FColumnFields | Represents field FColumnFields.
FColumnHeader | Represents field FColumnHeader.
FColumnLevels | Represents field FColumnLevels.
FColumnMemos | Represents field FColumnMemos.
FColumns | Represents field FColumns.
FColumnSort | Represents field FColumnSort.
FColumnTotalMemos | Represents field FColumnTotalMemos.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCorner | Represents field FCorner.
FCornerMemos | Represents field FCornerMemos.
FDefHeight | Represents field FDefHeight.
FDotMatrix | Represents field FDotMatrix.
FDownThenAcross | Represents field FDownThenAcross.
FDragActive | Represents field FDragActive.
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFirstMousePos | Represents field FFirstMousePos.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FGapX | Represents field FGapX.
FGapY | Represents field FGapY.
FGridUsed | Represents field FGridUsed.
FGridX | Represents field FGridX.
FGridY | Represents field FGridY.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FJoinEqualCells | Represents field FJoinEqualCells.
FKeepRowsTogether | Represents field FKeepRowsTogether.
FKeepTogether | Represents field FKeepTogether.
FLastMousePos | Represents field FLastMousePos.
FMaxWidth | Represents field FMaxWidth.
FMinWidth | Represents field FMinWidth.
FMouseDown | Represents field FMouseDown.
FMovingObjects | Represents field FMovingObjects.
FNextCross | Represents field FNextCross.
FNextCrossGap | Represents field FNextCrossGap.
FNoColumns | Represents field FNoColumns.
FNoRows | Represents field FNoRows.
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOnBeforeCalcHeight | Represents field FOnBeforeCalcHeight.
FOnBeforeCalcWidth | Represents field FOnBeforeCalcWidth.
FOnBeforePrintCell | Represents field FOnBeforePrintCell.
FOnBeforePrintColumnHeader | Represents field FOnBeforePrintColumnHeader.
FOnBeforePrintRowHeader | Represents field FOnBeforePrintRowHeader.
FOnCalcHeight | Represents field FOnCalcHeight.
FOnCalcWidth | Represents field FOnCalcWidth.
FOnPrintCell | Represents field FOnPrintCell.
FOnPrintColumnHeader | Represents field FOnPrintColumnHeader.
FOnPrintRowHeader | Represents field FOnPrintRowHeader.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPlainCells | Represents field FPlainCells.
FPrevCrossLastPage | Represents field FPrevCrossLastPage.
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FRepeatHeaders | Represents field FRepeatHeaders.
FRowBands | Represents field FRowBands.
FRowFields | Represents field FRowFields.
FRowHeader | Represents field FRowHeader.
FRowLevels | Represents field FRowLevels.
FRowMemos | Represents field FRowMemos.
FRows | Represents field FRows.
FRowSort | Represents field FRowSort.
FRowTotalMemos | Represents field FRowTotalMemos.
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FShowCellBreak | Represents field FShowCellBreak.
FShowColumnHeader | Represents field FShowColumnHeader.
FShowColumnTotal | Represents field FShowColumnTotal.
FShowCorner | Represents field FShowCorner.
FShowMoveArrow | Represents field FShowMoveArrow.
FShowRowHeader | Represents field FShowRowHeader.
FShowRowTotal | Represents field FShowRowTotal.
FShowTitle | Represents field FShowTitle.
FSuppressNullRecords | Represents field FSuppressNullRecords.
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxCross


TfrxCustomCrossView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomCrossView class. (Overrides TfrxView.Create(TComponent).)
Destroy | Represents the destructor of the TfrxCustomCrossView class. (Overrides TfrxView.Destroy.)
Top


TfrxCustomCrossView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomCrossView class.

Namespace: frxCross
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxView.Create(TComponent)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomCrossView class.

Namespace: frxCross
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxView.Destroy
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView Properties

Properties
Name | Description
AddHeight | Represents property AddHeight.
AddWidth | Represents property AddWidth.
AllowDuplicates | Represents property AllowDuplicates.
AutoSize | Represents property AutoSize.
Border | Determines whether the cross-table should have an outer border. Default value is True.
CellFields | Represents property CellFields.
CellFunctions[Integer] | Aggregate functions for each cell level.
CellHeaderMemos[Integer] | Represents property CellHeaderMemos[Integer].
CellLevels | Number of levels of cross-tab cell.
CellMemos[Integer] | Array of Text objects that represents each level of cell. First array element has 0 index.
ClearBeforePrint | Represents property ClearBeforePrint.
ColumnFields | Represents property ColumnFields.
ColumnHeader | Represents property ColumnHeader.
ColumnLevels | Number of levels in the column header.
ColumnMemos[Integer] | Array of Text objects that represents each level of column header. First array element has 0 index.
ColumnSort[Integer] | Sort order for each level of column header.
ColumnTotalMemos[Integer] | Array of Text objects that represents each total cell of column header. First array element has 0 index and is represents the grand total.
Corner | Represents property Corner.
CornerMemos[Integer] | Array of Text objects that represents the table header. The first array element has 0 index and is represents the top left corner, the second represents all columns header, CornerMemos[2..RowLevels+2] are row levels headers.
DefHeight | Default height of each row. If this property is 0 (default), the height of each row is calculated automatically.
DotMatrix | Represents property DotMatrix.
DownThenAcross | Determines how the big table will break across pages. If this property is False (default), the table will break across then down.
GapX | The left indent of the text in the cross-tab cells.
GapY | The top indent of the text in the cross-tab cells.
JoinEqualCells | Determines whether to join several side-by-side cells with equal values into one wide cell.
KeepRowsTogether | Represents property KeepRowsTogether.
KeepTogether | Represents property KeepTogether.
MaxWidth | The maximum width of the cross-tab column. If this property is 0 (default), the width is calculated automatically.
MinWidth | The minimum width of the cross-tab column. If this property is 0 (default), the width is calculated automatically.
NextCross | The next cross-tab object that will be rendered side-by-side.
NextCrossGap | The gap between two side-by-side crosses (see NextCross).
NoColumns | Represents property NoColumns.
NoRows | Represents property NoRows.
OnCalcHeight | Name of the script procedure that will run when calculating a height of each row.
OnCalcWidth | Name of the script procedure that will run when calculating a width of each column.
OnPrintCell | Name of the script procedure that will run before printing each cell of the cross-table.
OnPrintColumnHeader | Name of the script procedure that will run before printing eachelement of the column header.
OnPrintRowHeader | Name of the script procedure that will run before printing each element of the row header.
PlainCells | Determines whether to print cell levels stacked (default) or side-by-side.
RepeatHeaders | Determines whether cross-tab should repeat column and row headers on each new page. Default value is True.
RowFields | Represents property RowFields.
RowHeader | Represents property RowHeader.
RowLevels | Number of levels in the row header.
RowMemos[Integer] | Array of Text objects that represents each level of row header. First array element has 0 index.
RowSort[Integer] | Sort order for each level of row header.
RowTotalMemos[Integer] | Array of Text objects that represents each total cell of row header. First array element has 0 index and is represents the grand total.
ShowCellBreak | Represents property ShowCellBreak.
ShowColumnHeader | Determines whether to show column header or not. Default value is True.
ShowColumnTotal | Determines if column total is shown. Default value is True.
ShowCorner | Determines whether to show top-left corner elements (table headers).
ShowRowHeader | Determines if row header is shown. Default value is True.
ShowRowTotal | Determines if row total is shown. Default value is True.
ShowTitle | Represents property ShowTitle.
SuppressNullRecords | Represents property SuppressNullRecords.
Top


TfrxCustomCrossView.AddHeight Property

Summary

Represents property AddHeight.

Namespace: frxCross
Syntax
Delphi
published
 property AddHeight: Extended read FAddHeight write FAddHeight;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.AddWidth Property

Summary

Represents property AddWidth.

Namespace: frxCross
Syntax
Delphi
published
 property AddWidth: Extended read FAddWidth write FAddWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.AllowDuplicates Property

Summary

Represents property AllowDuplicates.

Namespace: frxCross
Syntax
Delphi
published
 property AllowDuplicates: Boolean read FAllowDuplicates write FAllowDuplicates default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.AutoSize Property

Summary

Represents property AutoSize.

Namespace: frxCross
Syntax
Delphi
published
 property AutoSize: Boolean read FAutoSize write FAutoSize default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.Border Property

Summary

Determines whether the cross-table should have an outer border. Default value is True.

Namespace: frxCross
Syntax
Delphi
published
 property Border: Boolean read FBorder write FBorder default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CellFields Property

Summary

Represents property CellFields.

Namespace: frxCross
Syntax
Delphi
public
 property CellFields: TStrings read FCellFields write SetCellFields;

Property Value

Type: TStrings

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CellFunctions[Integer] Property

Summary

Aggregate functions for each cell level.

Namespace: frxCross
Syntax
Delphi
public
 property CellFunctions[Index: Integer]: TfrxCrossFunction read GetCellFunctions
 write SetCellFunctions;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCrossFunction

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CellHeaderMemos[Integer] Property

Summary

Represents property CellHeaderMemos[Integer].

Namespace: frxCross
Syntax
Delphi
public
 property CellHeaderMemos[Index: Integer]: TfrxCustomMemoView read GetCellHeaderMemos;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CellLevels Property

Summary

Number of levels of cross-tab cell.

Namespace: frxCross
Syntax
Delphi
published
 property CellLevels: Integer read FCellLevels write SetCellLevels default 1;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CellMemos[Integer] Property

Summary

Array of Text objects that represents each level of cell. First array element has 0 index.

Namespace: frxCross
Syntax
Delphi
public
 property CellMemos[Index: Integer]: TfrxCustomMemoView read GetCellMemos;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ClearBeforePrint Property

Summary

Represents property ClearBeforePrint.

Namespace: frxCross
Syntax
Delphi
public
 property ClearBeforePrint: Boolean read FClearBeforePrint write FClearBeforePrint;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ColumnFields Property

Summary

Represents property ColumnFields.

Namespace: frxCross
Syntax
Delphi
public
 property ColumnFields: TStrings read FColumnFields write SetColumnFields;

Property Value

Type: TStrings

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ColumnHeader Property

Summary

Represents property ColumnHeader.

Namespace: frxCross
Syntax
Delphi
public
 property ColumnHeader: TfrxCrossColumnHeader read FColumnHeader;

Property Value

Type: TfrxCrossColumnHeader

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ColumnLevels Property

Summary

Number of levels in the column header.

Namespace: frxCross
Syntax
Delphi
published
 property ColumnLevels: Integer read FColumnLevels write SetColumnLevels default 1;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ColumnMemos[Integer] Property

Summary

Array of Text objects that represents each level of column header. First array element has 0 index.

Namespace: frxCross
Syntax
Delphi
public
 property ColumnMemos[Index: Integer]: TfrxCustomMemoView read GetColumnMemos;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ColumnSort[Integer] Property

Summary

Sort order for each level of column header.

Namespace: frxCross
Syntax
Delphi
public
 property ColumnSort[Index: Integer]: TfrxCrossSortOrder read GetColumnSort
 write SetColumnSort;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCrossSortOrder

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ColumnTotalMemos[Integer] Property

Summary

Array of Text objects that represents each total cell of column header. First array element has 0 index and is represents the grand total.

Namespace: frxCross
Syntax
Delphi
public
 property ColumnTotalMemos[Index: Integer]: TfrxCustomMemoView read GetColumnTotalMemos;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.Corner Property

Summary

Represents property Corner.

Namespace: frxCross
Syntax
Delphi
public
 property Corner: TfrxCrossCorner read FCorner;

Property Value

Type: TfrxCrossCorner

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CornerMemos[Integer] Property

Summary

Array of Text objects that represents the table header. The first array element has 0 index and is represents the top left corner, the second represents all columns header, CornerMemos[2..RowLevels+2] are row levels headers.

Namespace: frxCross
Syntax
Delphi
public
 property CornerMemos[Index: Integer]: TfrxCustomMemoView read GetCornerMemos;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DefHeight Property

Summary

Default height of each row. If this property is 0 (default), the height of each row is calculated automatically.

Namespace: frxCross
Syntax
Delphi
published
 property DefHeight: Integer read FDefHeight write FDefHeight default 0;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DotMatrix Property

Summary

Represents property DotMatrix.

Namespace: frxCross
Syntax
Delphi
public
 property DotMatrix: Boolean read FDotMatrix;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DownThenAcross Property

Summary

Determines how the big table will break across pages. If this property is False (default), the table will break across then down.

Namespace: frxCross
Syntax
Delphi
published
 property DownThenAcross: Boolean read FDownThenAcross write FDownThenAcross;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GapX Property

Summary

The left indent of the text in the cross-tab cells.

Namespace: frxCross
Syntax
Delphi
published
 property GapX: Integer read FGapX write FGapX default 3;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GapY Property

Summary

The top indent of the text in the cross-tab cells.

Namespace: frxCross
Syntax
Delphi
published
 property GapY: Integer read FGapY write FGapY default 3;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.JoinEqualCells Property

Summary

Determines whether to join several side-by-side cells with equal values into one wide cell.

Namespace: frxCross
Syntax
Delphi
published
 property JoinEqualCells: Boolean read FJoinEqualCells write FJoinEqualCells default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.KeepRowsTogether Property

Summary

Represents property KeepRowsTogether.

Namespace: frxCross
Syntax
Delphi
published
 property KeepRowsTogether: Boolean read FKeepRowsTogether write FKeepRowsTogether default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.KeepTogether Property

Summary

Represents property KeepTogether.

Namespace: frxCross
Syntax
Delphi
published
 property KeepTogether: Boolean read FKeepTogether write FKeepTogether default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.MaxWidth Property

Summary

The maximum width of the cross-tab column. If this property is 0 (default), the width is calculated automatically.

Namespace: frxCross
Syntax
Delphi
published
 property MaxWidth: Integer read FMaxWidth write FMaxWidth default 200;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.MinWidth Property

Summary

The minimum width of the cross-tab column. If this property is 0 (default), the width is calculated automatically.

Namespace: frxCross
Syntax
Delphi
published
 property MinWidth: Integer read FMinWidth write FMinWidth default 0;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.NextCross Property

Summary

The next cross-tab object that will be rendered side-by-side.

Namespace: frxCross
Syntax
Delphi
published
 property NextCross: TfrxCustomCrossView read FNextCross write FNextCross;

Property Value

Type: TfrxCustomCrossView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.NextCrossGap Property

Summary

The gap between two side-by-side crosses (see NextCross).

Namespace: frxCross
Syntax
Delphi
published
 property NextCrossGap: Extended read FNextCrossGap write FNextCrossGap;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.NoColumns Property

Summary

Represents property NoColumns.

Namespace: frxCross
Syntax
Delphi
public
 property NoColumns: Boolean read FNoColumns;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.NoRows Property

Summary

Represents property NoRows.

Namespace: frxCross
Syntax
Delphi
public
 property NoRows: Boolean read FNoRows;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.OnCalcHeight Property

Summary

Name of the script procedure that will run when calculating a height of each row.

Namespace: frxCross
Syntax
Delphi
published
 property OnCalcHeight: TfrxCalcHeightEvent read FOnCalcHeight write FOnCalcHeight;

Property Value

Type: TfrxCalcHeightEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.OnCalcWidth Property

Summary

Name of the script procedure that will run when calculating a width of each column.

Namespace: frxCross
Syntax
Delphi
published
 property OnCalcWidth: TfrxCalcWidthEvent read FOnCalcWidth write FOnCalcWidth;

Property Value

Type: TfrxCalcWidthEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.OnPrintCell Property

Summary

Name of the script procedure that will run before printing each cell of the cross-table.

Namespace: frxCross
Syntax
Delphi
published
 property OnPrintCell: TfrxPrintCellEvent read FOnPrintCell write FOnPrintCell;

Property Value

Type: TfrxPrintCellEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.OnPrintColumnHeader Property

Summary

Name of the script procedure that will run before printing eachelement of the column header.

Namespace: frxCross
Syntax
Delphi
published
 property OnPrintColumnHeader: TfrxPrintHeaderEvent
 read FOnPrintColumnHeader write FOnPrintColumnHeader;

Property Value

Type: TfrxPrintHeaderEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.OnPrintRowHeader Property

Summary

Name of the script procedure that will run before printing each element of the row header.

Namespace: frxCross
Syntax
Delphi
published
 property OnPrintRowHeader: TfrxPrintHeaderEvent
 read FOnPrintRowHeader write FOnPrintRowHeader;

Property Value

Type: TfrxPrintHeaderEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.PlainCells Property

Summary

Determines whether to print cell levels stacked (default) or side-by-side.

Namespace: frxCross
Syntax
Delphi
published
 property PlainCells: Boolean read FPlainCells write FPlainCells default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.RepeatHeaders Property

Summary

Determines whether cross-tab should repeat column and row headers on each new page. Default value is True.

Namespace: frxCross
Syntax
Delphi
published
 property RepeatHeaders: Boolean read FRepeatHeaders write FRepeatHeaders default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.RowFields Property

Summary

Represents property RowFields.

Namespace: frxCross
Syntax
Delphi
public
 property RowFields: TStrings read FRowFields write SetRowFields;

Property Value

Type: TStrings

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.RowHeader Property

Summary

Represents property RowHeader.

Namespace: frxCross
Syntax
Delphi
public
 property RowHeader: TfrxCrossRowHeader read FRowHeader;

Property Value

Type: TfrxCrossRowHeader

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.RowLevels Property

Summary

Number of levels in the row header.

Namespace: frxCross
Syntax
Delphi
published
 property RowLevels: Integer read FRowLevels write SetRowLevels default 1;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.RowMemos[Integer] Property

Summary

Array of Text objects that represents each level of row header. First array element has 0 index.

Namespace: frxCross
Syntax
Delphi
public
 property RowMemos[Index: Integer]: TfrxCustomMemoView read GetRowMemos;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.RowSort[Integer] Property

Summary

Sort order for each level of row header.

Namespace: frxCross
Syntax
Delphi
public
 property RowSort[Index: Integer]: TfrxCrossSortOrder read GetRowSort
 write SetRowSort;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCrossSortOrder

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.RowTotalMemos[Integer] Property

Summary

Array of Text objects that represents each total cell of row header. First array element has 0 index and is represents the grand total.

Namespace: frxCross
Syntax
Delphi
public
 property RowTotalMemos[Index: Integer]: TfrxCustomMemoView read GetRowTotalMemos;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ShowCellBreak Property

Summary

Represents property ShowCellBreak.

Namespace: frxCross
Syntax
Delphi
published
 property ShowCellBreak: Boolean read FShowCellBreak write FShowCellBreak default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ShowColumnHeader Property

Summary

Determines whether to show column header or not. Default value is True.

Namespace: frxCross
Syntax
Delphi
published
 property ShowColumnHeader: Boolean read FShowColumnHeader write FShowColumnHeader default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ShowColumnTotal Property

Summary

Determines if column total is shown. Default value is True.

Namespace: frxCross
Syntax
Delphi
published
 property ShowColumnTotal: Boolean read FShowColumnTotal write FShowColumnTotal default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ShowCorner Property

Summary

Determines whether to show top-left corner elements (table headers).

Namespace: frxCross
Syntax
Delphi
published
 property ShowCorner: Boolean read FShowCorner write FShowCorner default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ShowRowHeader Property

Summary

Determines if row header is shown. Default value is True.

Namespace: frxCross
Syntax
Delphi
published
 property ShowRowHeader: Boolean read FShowRowHeader write FShowRowHeader default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ShowRowTotal Property

Summary

Determines if row total is shown. Default value is True.

Namespace: frxCross
Syntax
Delphi
published
 property ShowRowTotal: Boolean read FShowRowTotal write FShowRowTotal default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ShowTitle Property

Summary

Represents property ShowTitle.

Namespace: frxCross
Syntax
Delphi
published
 property ShowTitle: Boolean read FShowTitle write FShowTitle default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.SuppressNullRecords Property

Summary

Represents property SuppressNullRecords.

Namespace: frxCross
Syntax
Delphi
published
 property SuppressNullRecords: Boolean read FSuppressNullRecords write FSuppressNullRecords default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView Methods

Methods
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Overrides TfrxComponent.AddSourceObjects.)
AddValue(Variant[],Variant[],Variant[]) | Method adds a value into cross-table. Use this method to fill in the TfrxCrossView object.
ApplyStyle(TfrxStyles) | Represents method ApplyStyle(TfrxStyles).
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Overrides TfrxComponent.BeforeStartReport.)
BeginMatrix | Represents method BeginMatrix.
BuildColumnBands | Represents method BuildColumnBands.
BuildRowBands | Represents method BuildRowBands.
CalcBounds(Extended,Extended) | Represents method CalcBounds(Extended,Extended).
CalcTotal(TfrxCrossHeader,TfrxIndexCollection) | Represents method CalcTotal(TfrxCrossHeader,TfrxIndexCollection).
CalcTotals | Represents method CalcTotals.
ClearMatrix | Represents method ClearMatrix.
ClearMemos | Represents method ClearMemos.
ColCount | Returns a number of columns in the cross.
ColumnHeaderHeight | Represents method ColumnHeaderHeight.
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Overrides TfrxComponent.ContainerAdd(TfrxComponent).)
CorrectDMPBounds(TfrxCustomMemoView) | Represents method CorrectDMPBounds(TfrxCustomMemoView).
CreateCellHeaderMemos(Integer) | Represents method CreateCellHeaderMemos(Integer).
CreateCellMemos(Integer) | Represents method CreateCellMemos(Integer).
CreateColumnMemos(Integer) | Represents method CreateColumnMemos(Integer).
CreateCornerMemos(Integer) | Represents method CreateCornerMemos(Integer).
CreateHeader(TfrxCrossHeader,TfrxIndexCollection,TList,Boolean) | Represents method CreateHeader(TfrxCrossHeader,TfrxIndexCollection,TList,Boolean).
CreateHeaders | Represents method CreateHeaders.
CreateMemo(TfrxComponent) | Represents method CreateMemo(TfrxComponent).
CreateRowMemos(Integer) | Represents method CreateRowMemos(Integer).
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DoCalcHeight(Integer,Extended) | Represents method DoCalcHeight(Integer,Extended).
DoCalcWidth(Integer,Extended) | Represents method DoCalcWidth(Integer,Extended).
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
DoOnCell(TfrxCustomMemoView,Integer,Integer,Integer,Variant) | Represents method DoOnCell(TfrxCustomMemoView,Integer,Integer,Integer,Variant).
DoOnColumnHeader(TfrxCustomMemoView,TfrxCrossHeader) | Represents method DoOnColumnHeader(TfrxCustomMemoView,TfrxCrossHeader).
DoOnRowHeader(TfrxCustomMemoView,TfrxCrossHeader) | Represents method DoOnRowHeader(TfrxCustomMemoView,TfrxCrossHeader).
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawCross(TCanvas,Extended,Extended,Extended,Extended) | Represents method DrawCross(TCanvas,Extended,Extended,Extended,Extended).
EndMatrix | Represents method EndMatrix.
FillMatrix | Represents method FillMatrix.
GetCellFunctions(Integer) | Represents method GetCellFunctions(Integer).
GetCellHeaderMemos(Integer) | Represents method GetCellHeaderMemos(Integer).
GetCellMemos(Integer) | Represents method GetCellMemos(Integer).
GetColumnIndexes(Integer) | Represents method GetColumnIndexes(Integer).
GetColumnMemos(Integer) | Represents method GetColumnMemos(Integer).
GetColumnSort(Integer) | Represents method GetColumnSort(Integer).
GetColumnTotalMemos(Integer) | Represents method GetColumnTotalMemos(Integer).
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainerObjects | Represents method GetContainerObjects. (Overrides TfrxComponent.GetContainerObjects.)
GetCornerMemos(Integer) | Represents method GetCornerMemos(Integer).
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetNestedObjects | Represents method GetNestedObjects.
GetRowIndexes(Integer) | Represents method GetRowIndexes(Integer).
GetRowMemos(Integer) | Represents method GetRowMemos(Integer).
GetRowSort(Integer) | Represents method GetRowSort(Integer).
GetRowTotalMemos(Integer) | Represents method GetRowTotalMemos(Integer).
GetStyle(TfrxStyles) | Represents method GetStyle(TfrxStyles).
GetValue(Integer,Integer,Integer) | Represents method GetValue(Integer,Integer,Integer).
InitMatrix | Represents method InitMatrix.
InitMemos(Boolean) | Represents method InitMemos(Boolean).
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxView.IsAcceptAsChild(TfrxComponent).)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsCrossValid | Represents method IsCrossValid.
IsGrandTotalColumn(Integer) | Returns True if specified column is grand total column.
IsGrandTotalRow(Integer) | Returns True if specified row is grand total row.
IsTotalColumn(Integer) | Returns True if specified column is total column.
IsTotalRow(Integer) | Returns True if specified row is total row.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ReadMemos(TStream) | Represents method ReadMemos(TStream).
RenderMatrix | Represents method RenderMatrix.
RowCount | Returns a number of rows in the cross.
RowHeaderWidth | Represents method RowHeaderWidth.
SetCellFields(TStrings) | Represents method SetCellFields(TStrings).
SetCellFunctions(Integer,TfrxCrossFunction) | Represents method SetCellFunctions(Integer,TfrxCrossFunction).
SetCellLevels(Integer) | Represents method SetCellLevels(Integer).
SetColumnFields(TStrings) | Represents method SetColumnFields(TStrings).
SetColumnLevels(Integer) | Represents method SetColumnLevels(Integer).
SetColumnSort(Integer,TfrxCrossSortOrder) | Represents method SetColumnSort(Integer,TfrxCrossSortOrder).
SetDotMatrix(Boolean) | Represents method SetDotMatrix(Boolean).
SetRowFields(TStrings) | Represents method SetRowFields(TStrings).
SetRowLevels(Integer) | Represents method SetRowLevels(Integer).
SetRowSort(Integer,TfrxCrossSortOrder) | Represents method SetRowSort(Integer,TfrxCrossSortOrder).
SetupOriginalComponent(TfrxComponent,TfrxComponent) | Represents method SetupOriginalComponent(TfrxComponent,TfrxComponent).
UpdateVisibility | Represents method UpdateVisibility.
WriteMemos(TStream) | Represents method WriteMemos(TStream).
Top


TfrxCustomCrossView.AddSourceObjects Method

Summary

Deprecated. Used only for cross tab object for saving nested objects to source object dictionary.

Namespace: frxCross
Syntax
Delphi
public
 procedure AddSourceObjects; override;

Overrides

TfrxComponent.AddSourceObjects
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.AddValue(Variant[],Variant[],Variant[]) Method

Summary

Method adds a value into cross-table. Use this method to fill in the TfrxCrossView object.

Namespace: frxCross
Syntax
Delphi
public
 procedure AddValue(const Rows, Columns, Cells: array of Variant);

Parameters

Rows
Type: array of Variant

Columns
Type: array of Variant

Cells
Type: array of Variant

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ApplyStyle(TfrxStyles) Method

Summary

Represents method ApplyStyle(TfrxStyles).

Namespace: frxCross
Syntax
Delphi
public
 procedure ApplyStyle(Style: TfrxStyles);

Parameters

Style
Type: TfrxStyles

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.BeforePrint Method

Summary

The report engine calls this method before prepare object and place it to preview pages.

Namespace: frxCross
Syntax
Delphi
public
 procedure BeforePrint; override;

Overrides

TfrxView.BeforePrint
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.BeforeStartReport Method

Summary

Report engine call this method before start report preparation. Used to prepare objects before build.

Namespace: frxCross
Syntax
Delphi
public
 procedure BeforeStartReport; override;

Overrides

TfrxComponent.BeforeStartReport
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.BeginMatrix Method

Summary

Represents method BeginMatrix.

Namespace: frxCross
Syntax
Delphi
public
 procedure BeginMatrix;
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.BuildColumnBands Method

Summary

Represents method BuildColumnBands.

Namespace: frxCross
Syntax
Delphi
private
 procedure BuildColumnBands;
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.BuildRowBands Method

Summary

Represents method BuildRowBands.

Namespace: frxCross
Syntax
Delphi
private
 procedure BuildRowBands;
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CalcBounds(Extended,Extended) Method

Summary

Represents method CalcBounds(Extended,Extended).

Namespace: frxCross
Syntax
Delphi
private
 procedure CalcBounds(addWidth, addHeight: Extended);

Parameters

addWidth
Type: Extended

addHeight
Type: Extended

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CalcTotal(TfrxCrossHeader,TfrxIndexCollection) Method

Summary

Represents method CalcTotal(TfrxCrossHeader,TfrxIndexCollection).

Namespace: frxCross
Syntax
Delphi
private
 procedure CalcTotal(Header: TfrxCrossHeader; Source: TfrxIndexCollection);

Parameters

Header
Type: TfrxCrossHeader

Source
Type: TfrxIndexCollection

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CalcTotals Method

Summary

Represents method CalcTotals.

Namespace: frxCross
Syntax
Delphi
private
 procedure CalcTotals;
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ClearMatrix Method

Summary

Represents method ClearMatrix.

Namespace: frxCross
Syntax
Delphi
private
 procedure ClearMatrix;
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ClearMemos Method

Summary

Represents method ClearMemos.

Namespace: frxCross
Syntax
Delphi
private
 procedure ClearMemos;
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ColCount Method

Summary

Returns a number of columns in the cross.

Namespace: frxCross
Syntax
Delphi
public
 function ColCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ColumnHeaderHeight Method

Summary

Represents method ColumnHeaderHeight.

Namespace: frxCross
Syntax
Delphi
public
 function ColumnHeaderHeight: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ContainerAdd(TfrxComponent) Method

Summary

Deprecated. Used only for cross tab component. Adds internal child objects for cross cells.

Namespace: frxCross
Syntax
Delphi
public
 function ContainerAdd(Obj: TfrxComponent): Boolean; override;

Parameters

Obj
Type: TfrxComponent

Report object.

Return Value

Type: Boolean

Overrides

TfrxComponent.ContainerAdd(TfrxComponent)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CorrectDMPBounds(TfrxCustomMemoView) Method

Summary

Represents method CorrectDMPBounds(TfrxCustomMemoView).

Namespace: frxCross
Syntax
Delphi
private
 procedure CorrectDMPBounds(Memo: TfrxCustomMemoView);

Parameters

Memo
Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CreateCellHeaderMemos(Integer) Method

Summary

Represents method CreateCellHeaderMemos(Integer).

Namespace: frxCross
Syntax
Delphi
private
 procedure CreateCellHeaderMemos(NewCount: Integer);

Parameters

NewCount
Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CreateCellMemos(Integer) Method

Summary

Represents method CreateCellMemos(Integer).

Namespace: frxCross
Syntax
Delphi
private
 procedure CreateCellMemos(NewCount: Integer);

Parameters

NewCount
Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CreateColumnMemos(Integer) Method

Summary

Represents method CreateColumnMemos(Integer).

Namespace: frxCross
Syntax
Delphi
private
 procedure CreateColumnMemos(NewCount: Integer);

Parameters

NewCount
Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CreateCornerMemos(Integer) Method

Summary

Represents method CreateCornerMemos(Integer).

Namespace: frxCross
Syntax
Delphi
private
 procedure CreateCornerMemos(NewCount: Integer);

Parameters

NewCount
Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CreateHeader(TfrxCrossHeader,TfrxIndexCollection,TList,Boolean) Method

Summary

Represents method CreateHeader(TfrxCrossHeader,TfrxIndexCollection,TList,Boolean).

Namespace: frxCross
Syntax
Delphi
private
 procedure CreateHeader(Header: TfrxCrossHeader; Source: TfrxIndexCollection;
 Totals: TList; TotalVisible: Boolean);

Parameters

Header
Type: TfrxCrossHeader

Source
Type: TfrxIndexCollection

Totals
Type: TList

TotalVisible
Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CreateHeaders Method

Summary

Represents method CreateHeaders.

Namespace: frxCross
Syntax
Delphi
private
 procedure CreateHeaders;
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CreateMemo(TfrxComponent) Method

Summary

Represents method CreateMemo(TfrxComponent).

Namespace: frxCross
Syntax
Delphi
private
 function CreateMemo(Parent: TfrxComponent): TfrxCustomMemoView;

Parameters

Parent
Type: TfrxComponent

Return Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.CreateRowMemos(Integer) Method

Summary

Represents method CreateRowMemos(Integer).

Namespace: frxCross
Syntax
Delphi
private
 procedure CreateRowMemos(NewCount: Integer);

Parameters

NewCount
Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxCross
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoCalcHeight(Integer,Extended) Method

Summary

Represents method DoCalcHeight(Integer,Extended).

Namespace: frxCross
Syntax
Delphi
private
 procedure DoCalcHeight(Row: Integer; var Height: Extended);

Parameters

Row
Type: Integer

Height
Type: Extended

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoCalcWidth(Integer,Extended) Method

Summary

Represents method DoCalcWidth(Integer,Extended).

Namespace: frxCross
Syntax
Delphi
private
 procedure DoCalcWidth(Column: Integer; var Width: Extended);

Parameters

Column
Type: Integer

Width
Type: Extended

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) Method

Summary

Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).

Namespace: frxCross
Syntax
Delphi
public
 function DoDragDrop(Source: TObject; X, Y: Integer; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) Method

Summary

Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).

Namespace: frxCross
Syntax
Delphi
public
 function DoDragOver(Source: TObject; X, Y: Integer; State: TDragState; var Accept: Boolean; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxCross
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).

Namespace: frxCross
Syntax
Delphi
public
 procedure DoMouseEnter(aPreviousObject: TfrxComponent; var EventParams: TfrxInteractiveEventsParams); override;

Parameters

aPreviousObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).

Namespace: frxCross
Syntax
Delphi
public
 procedure DoMouseLeave(aNextObject: TfrxComponent; var EventParams: TfrxInteractiveEventsParams); override;

Parameters

aNextObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxCross
Syntax
Delphi
public
 procedure DoMouseMove(X, Y: Integer;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxCross
Syntax
Delphi
public
 procedure DoMouseUp(X, Y: Integer; Button: TMouseButton; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).

Namespace: frxCross
Syntax
Delphi
public
 function DoMouseWheel(Shift: TShiftState;
 WheelDelta: Integer; MousePos: TPoint;
 var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoOnCell(TfrxCustomMemoView,Integer,Integer,Integer,Variant) Method

Summary

Represents method DoOnCell(TfrxCustomMemoView,Integer,Integer,Integer,Variant).

Namespace: frxCross
Syntax
Delphi
private
 procedure DoOnCell(Memo: TfrxCustomMemoView; Row, Column, Cell: Integer;
 const Value: Variant);

Parameters

Memo
Type: TfrxCustomMemoView

Row
Type: Integer

Column
Type: Integer

Cell
Type: Integer

Value
Type: Variant

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoOnColumnHeader(TfrxCustomMemoView,TfrxCrossHeader) Method

Summary

Represents method DoOnColumnHeader(TfrxCustomMemoView,TfrxCrossHeader).

Namespace: frxCross
Syntax
Delphi
private
 procedure DoOnColumnHeader(Memo: TfrxCustomMemoView; Header: TfrxCrossHeader);

Parameters

Memo
Type: TfrxCustomMemoView

Header
Type: TfrxCrossHeader

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DoOnRowHeader(TfrxCustomMemoView,TfrxCrossHeader) Method

Summary

Represents method DoOnRowHeader(TfrxCustomMemoView,TfrxCrossHeader).

Namespace: frxCross
Syntax
Delphi
private
 procedure DoOnRowHeader(Memo: TfrxCustomMemoView; Header: TfrxCrossHeader);

Parameters

Memo
Type: TfrxCustomMemoView

Header
Type: TfrxCrossHeader

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxCross
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.DrawCross(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

Represents method DrawCross(TCanvas,Extended,Extended,Extended,Extended).

Namespace: frxCross
Syntax
Delphi
public
 function DrawCross(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended): TfrxPoint;

Parameters

Canvas
Type: TCanvas

ScaleX
Type: Extended

ScaleY
Type: Extended

OffsetX
Type: Extended

OffsetY
Type: Extended

Return Value

Type: TfrxPoint

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.EndMatrix Method

Summary

Represents method EndMatrix.

Namespace: frxCross
Syntax
Delphi
public
 procedure EndMatrix;
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FillMatrix Method

Summary

Represents method FillMatrix.

Namespace: frxCross
Syntax
Delphi
public
 procedure FillMatrix; virtual;
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetCellFunctions(Integer) Method

Summary

Represents method GetCellFunctions(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetCellFunctions(Index: Integer): TfrxCrossFunction;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCrossFunction

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetCellHeaderMemos(Integer) Method

Summary

Represents method GetCellHeaderMemos(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetCellHeaderMemos(Index: Integer): TfrxCustomMemoView;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetCellMemos(Integer) Method

Summary

Represents method GetCellMemos(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetCellMemos(Index: Integer): TfrxCustomMemoView;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetColumnIndexes(Integer) Method

Summary

Represents method GetColumnIndexes(Integer).

Namespace: frxCross
Syntax
Delphi
public
 function GetColumnIndexes(AColumn: Integer): Variant;

Parameters

AColumn
Type: Integer

Return Value

Type: Variant

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetColumnMemos(Integer) Method

Summary

Represents method GetColumnMemos(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetColumnMemos(Index: Integer): TfrxCustomMemoView;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetColumnSort(Integer) Method

Summary

Represents method GetColumnSort(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetColumnSort(Index: Integer): TfrxCrossSortOrder;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCrossSortOrder

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetColumnTotalMemos(Integer) Method

Summary

Represents method GetColumnTotalMemos(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetColumnTotalMemos(Index: Integer): TfrxCustomMemoView;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetContainedComponent(Extended,Extended,TfrxComponent) Method

Summary

Returns top-most object which contain point at passed coordinates

Namespace: frxCross
Syntax
Delphi
public
 function GetContainedComponent(X, Y: Extended; IsCanContain: TfrxComponent = nil): TfrxComponent; override;

Parameters

X
Type: Extended

X coordinate.

Y
Type: Extended

Y coordinate.

IsCanContain
Type: TfrxComponent

Child Component. If IsCanContain = nil - returns top-most object, otherwise IsCanContain <> nil - return top-most object which can accept IsCanContain component as child.

Return Value

Type: TfrxComponent

Found component or nil.

Overrides

TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetContainerObjects Method

Summary

Represents method GetContainerObjects.

Namespace: frxCross
Syntax
Delphi
protected
 function GetContainerObjects: TList; override;

Return Value

Type: TList

Overrides

TfrxComponent.GetContainerObjects
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetCornerMemos(Integer) Method

Summary

Represents method GetCornerMemos(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetCornerMemos(Index: Integer): TfrxCustomMemoView;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxCross
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetNestedObjects Method

Summary

Represents method GetNestedObjects.

Namespace: frxCross
Syntax
Delphi
private
 function GetNestedObjects: TList;

Return Value

Type: TList

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetRowIndexes(Integer) Method

Summary

Represents method GetRowIndexes(Integer).

Namespace: frxCross
Syntax
Delphi
public
 function GetRowIndexes(ARow: Integer): Variant;

Parameters

ARow
Type: Integer

Return Value

Type: Variant

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetRowMemos(Integer) Method

Summary

Represents method GetRowMemos(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetRowMemos(Index: Integer): TfrxCustomMemoView;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetRowSort(Integer) Method

Summary

Represents method GetRowSort(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetRowSort(Index: Integer): TfrxCrossSortOrder;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCrossSortOrder

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetRowTotalMemos(Integer) Method

Summary

Represents method GetRowTotalMemos(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetRowTotalMemos(Index: Integer): TfrxCustomMemoView;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCustomMemoView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetStyle(TfrxStyles) Method

Summary

Represents method GetStyle(TfrxStyles).

Namespace: frxCross
Syntax
Delphi
public
 procedure GetStyle(Style: TfrxStyles);

Parameters

Style
Type: TfrxStyles

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.GetValue(Integer,Integer,Integer) Method

Summary

Represents method GetValue(Integer,Integer,Integer).

Namespace: frxCross
Syntax
Delphi
public
 function GetValue(ARow, AColumn, ACell: Integer): Variant;

Parameters

ARow
Type: Integer

AColumn
Type: Integer

ACell
Type: Integer

Return Value

Type: Variant

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.InitMatrix Method

Summary

Represents method InitMatrix.

Namespace: frxCross
Syntax
Delphi
private
 procedure InitMatrix;
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.InitMemos(Boolean) Method

Summary

Represents method InitMemos(Boolean).

Namespace: frxCross
Syntax
Delphi
private
 procedure InitMemos(AddToScript: Boolean);

Parameters

AddToScript
Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.IsAcceptAsChild(TfrxComponent) Method

Summary

Returns true when component in aParent can be accepted as parent for current.

Namespace: frxCross
Syntax
Delphi
public
 function IsAcceptAsChild(aParent: TfrxComponent): Boolean; override;

Parameters

aParent
Type: TfrxComponent

Component that supposedly should become a parent for current.

Return Value

Type: Boolean

Overrides

TfrxView.IsAcceptAsChild(TfrxComponent)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.IsContain(Extended,Extended) Method

Summary

Detects if point is inside an object coordinates.

Namespace: frxCross
Syntax
Delphi
public
 function IsContain(X, Y: Extended): Boolean; override;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

Overrides

TfrxComponent.IsContain(Extended,Extended)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.IsCrossValid Method

Summary

Represents method IsCrossValid.

Namespace: frxCross
Syntax
Delphi
public
 function IsCrossValid: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.IsGrandTotalColumn(Integer) Method

Summary

Returns True if specified column is grand total column.

Namespace: frxCross
Syntax
Delphi
public
 function IsGrandTotalColumn(Index: Integer): Boolean;

Parameters

Index
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.IsGrandTotalRow(Integer) Method

Summary

Returns True if specified row is grand total row.

Namespace: frxCross
Syntax
Delphi
public
 function IsGrandTotalRow(Index: Integer): Boolean;

Parameters

Index
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.IsTotalColumn(Integer) Method

Summary

Returns True if specified column is total column.

Namespace: frxCross
Syntax
Delphi
public
 function IsTotalColumn(Index: Integer): Boolean;

Parameters

Index
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.IsTotalRow(Integer) Method

Summary

Returns True if specified row is total row.

Namespace: frxCross
Syntax
Delphi
public
 function IsTotalRow(Index: Integer): Boolean;

Parameters

Index
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: frxCross
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

Overrides

TfrxView.Notification(TComponent,TOperation)
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.ReadMemos(TStream) Method

Summary

Represents method ReadMemos(TStream).

Namespace: frxCross
Syntax
Delphi
private
 procedure ReadMemos(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.RenderMatrix Method

Summary

Represents method RenderMatrix.

Namespace: frxCross
Syntax
Delphi
private
 procedure RenderMatrix;
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.RowCount Method

Summary

Returns a number of rows in the cross.

Namespace: frxCross
Syntax
Delphi
public
 function RowCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.RowHeaderWidth Method

Summary

Represents method RowHeaderWidth.

Namespace: frxCross
Syntax
Delphi
public
 function RowHeaderWidth: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.SetCellFields(TStrings) Method

Summary

Represents method SetCellFields(TStrings).

Namespace: frxCross
Syntax
Delphi
private
 procedure SetCellFields(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.SetCellFunctions(Integer,TfrxCrossFunction) Method

Summary

Represents method SetCellFunctions(Integer,TfrxCrossFunction).

Namespace: frxCross
Syntax
Delphi
private
 procedure SetCellFunctions(Index: Integer; const Value: TfrxCrossFunction);

Parameters

Index
Type: Integer

Value
Type: TfrxCrossFunction

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.SetCellLevels(Integer) Method

Summary

Represents method SetCellLevels(Integer).

Namespace: frxCross
Syntax
Delphi
protected
 procedure SetCellLevels(const Value: Integer); virtual;

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.SetColumnFields(TStrings) Method

Summary

Represents method SetColumnFields(TStrings).

Namespace: frxCross
Syntax
Delphi
private
 procedure SetColumnFields(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.SetColumnLevels(Integer) Method

Summary

Represents method SetColumnLevels(Integer).

Namespace: frxCross
Syntax
Delphi
protected
 procedure SetColumnLevels(const Value: Integer); virtual;

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.SetColumnSort(Integer,TfrxCrossSortOrder) Method

Summary

Represents method SetColumnSort(Integer,TfrxCrossSortOrder).

Namespace: frxCross
Syntax
Delphi
private
 procedure SetColumnSort(Index: Integer; Value: TfrxCrossSortOrder);

Parameters

Index
Type: Integer

Value
Type: TfrxCrossSortOrder

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.SetDotMatrix(Boolean) Method

Summary

Represents method SetDotMatrix(Boolean).

Namespace: frxCross
Syntax
Delphi
private
 procedure SetDotMatrix(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.SetRowFields(TStrings) Method

Summary

Represents method SetRowFields(TStrings).

Namespace: frxCross
Syntax
Delphi
private
 procedure SetRowFields(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.SetRowLevels(Integer) Method

Summary

Represents method SetRowLevels(Integer).

Namespace: frxCross
Syntax
Delphi
protected
 procedure SetRowLevels(const Value: Integer); virtual;

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.SetRowSort(Integer,TfrxCrossSortOrder) Method

Summary

Represents method SetRowSort(Integer,TfrxCrossSortOrder).

Namespace: frxCross
Syntax
Delphi
private
 procedure SetRowSort(Index: Integer; Value: TfrxCrossSortOrder);

Parameters

Index
Type: Integer

Value
Type: TfrxCrossSortOrder

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.SetupOriginalComponent(TfrxComponent,TfrxComponent) Method

Summary

Represents method SetupOriginalComponent(TfrxComponent,TfrxComponent).

Namespace: frxCross
Syntax
Delphi
private
 procedure SetupOriginalComponent(Obj1, Obj2: TfrxComponent);

Parameters

Obj1
Type: TfrxComponent

Obj2
Type: TfrxComponent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.UpdateVisibility Method

Summary

Represents method UpdateVisibility.

Namespace: frxCross
Syntax
Delphi
private
 procedure UpdateVisibility;
See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.WriteMemos(TStream) Method

Summary

Represents method WriteMemos(TStream).

Namespace: frxCross
Syntax
Delphi
private
 procedure WriteMemos(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView Events

Events
Name | Description
OnBeforeCalcHeight | Represents property OnBeforeCalcHeight.
OnBeforeCalcWidth | Represents property OnBeforeCalcWidth.
OnBeforePrintCell | Represents property OnBeforePrintCell.
OnBeforePrintColumnHeader | Represents property OnBeforePrintColumnHeader.
OnBeforePrintRowHeader | Represents property OnBeforePrintRowHeader.
Top


TfrxCustomCrossView.OnBeforeCalcHeight Event

Summary

Represents property OnBeforeCalcHeight.

Namespace: frxCross
Syntax
Delphi
public
 property OnBeforeCalcHeight: TfrxOnCalcHeightEvent
 read FOnBeforeCalcHeight write FOnBeforeCalcHeight;

Value

Type: TfrxOnCalcHeightEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.OnBeforeCalcWidth Event

Summary

Represents property OnBeforeCalcWidth.

Namespace: frxCross
Syntax
Delphi
public
 property OnBeforeCalcWidth: TfrxOnCalcWidthEvent
 read FOnBeforeCalcWidth write FOnBeforeCalcWidth;

Value

Type: TfrxOnCalcWidthEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.OnBeforePrintCell Event

Summary

Represents property OnBeforePrintCell.

Namespace: frxCross
Syntax
Delphi
public
 property OnBeforePrintCell: TfrxOnPrintCellEvent
 read FOnBeforePrintCell write FOnBeforePrintCell;

Value

Type: TfrxOnPrintCellEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.OnBeforePrintColumnHeader Event

Summary

Represents property OnBeforePrintColumnHeader.

Namespace: frxCross
Syntax
Delphi
public
 property OnBeforePrintColumnHeader: TfrxOnPrintHeaderEvent
 read FOnBeforePrintColumnHeader write FOnBeforePrintColumnHeader;

Value

Type: TfrxOnPrintHeaderEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.OnBeforePrintRowHeader Event

Summary

Represents property OnBeforePrintRowHeader.

Namespace: frxCross
Syntax
Delphi
public
 property OnBeforePrintRowHeader: TfrxOnPrintHeaderEvent
 read FOnBeforePrintRowHeader write FOnBeforePrintRowHeader;

Value

Type: TfrxOnPrintHeaderEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView Fields

Fields
Name | Description
FAddHeight | Represents field FAddHeight.
FAddWidth | Represents field FAddWidth.
FAllMemos | Represents field FAllMemos.
FAllowDuplicates | Represents field FAllowDuplicates.
FAutoSize | Represents field FAutoSize.
FBorder | Represents field FBorder.
FCellFields | Represents field FCellFields.
FCellFunctions | Represents field FCellFunctions.
FCellHeaderMemos | Represents field FCellHeaderMemos.
FCellLevels | Represents field FCellLevels.
FCellMemos | Represents field FCellMemos.
FClearBeforePrint | Represents field FClearBeforePrint.
FColumnBands | Represents field FColumnBands.
FColumnFields | Represents field FColumnFields.
FColumnHeader | Represents field FColumnHeader.
FColumnLevels | Represents field FColumnLevels.
FColumnMemos | Represents field FColumnMemos.
FColumns | Represents field FColumns.
FColumnSort | Represents field FColumnSort.
FColumnTotalMemos | Represents field FColumnTotalMemos.
FCorner | Represents field FCorner.
FCornerMemos | Represents field FCornerMemos.
FDefHeight | Represents field FDefHeight.
FDotMatrix | Represents field FDotMatrix.
FDownThenAcross | Represents field FDownThenAcross.
FDragActive | Represents field FDragActive.
FFirstMousePos | Represents field FFirstMousePos.
FGapX | Represents field FGapX.
FGapY | Represents field FGapY.
FGridUsed | Represents field FGridUsed.
FGridX | Represents field FGridX.
FGridY | Represents field FGridY.
FJoinEqualCells | Represents field FJoinEqualCells.
FKeepRowsTogether | Represents field FKeepRowsTogether.
FKeepTogether | Represents field FKeepTogether.
FLastMousePos | Represents field FLastMousePos.
FMaxWidth | Represents field FMaxWidth.
FMinWidth | Represents field FMinWidth.
FMouseDown | Represents field FMouseDown.
FMovingObjects | Represents field FMovingObjects.
FNextCross | Represents field FNextCross.
FNextCrossGap | Represents field FNextCrossGap.
FNoColumns | Represents field FNoColumns.
FNoRows | Represents field FNoRows.
FOnBeforeCalcHeight | Represents field FOnBeforeCalcHeight.
FOnBeforeCalcWidth | Represents field FOnBeforeCalcWidth.
FOnBeforePrintCell | Represents field FOnBeforePrintCell.
FOnBeforePrintColumnHeader | Represents field FOnBeforePrintColumnHeader.
FOnBeforePrintRowHeader | Represents field FOnBeforePrintRowHeader.
FOnCalcHeight | Represents field FOnCalcHeight.
FOnCalcWidth | Represents field FOnCalcWidth.
FOnPrintCell | Represents field FOnPrintCell.
FOnPrintColumnHeader | Represents field FOnPrintColumnHeader.
FOnPrintRowHeader | Represents field FOnPrintRowHeader.
FPlainCells | Represents field FPlainCells.
FPrevCrossLastPage | Represents field FPrevCrossLastPage.
FRepeatHeaders | Represents field FRepeatHeaders.
FRowBands | Represents field FRowBands.
FRowFields | Represents field FRowFields.
FRowHeader | Represents field FRowHeader.
FRowLevels | Represents field FRowLevels.
FRowMemos | Represents field FRowMemos.
FRows | Represents field FRows.
FRowSort | Represents field FRowSort.
FRowTotalMemos | Represents field FRowTotalMemos.
FShowCellBreak | Represents field FShowCellBreak.
FShowColumnHeader | Represents field FShowColumnHeader.
FShowColumnTotal | Represents field FShowColumnTotal.
FShowCorner | Represents field FShowCorner.
FShowMoveArrow | Represents field FShowMoveArrow.
FShowRowHeader | Represents field FShowRowHeader.
FShowRowTotal | Represents field FShowRowTotal.
FShowTitle | Represents field FShowTitle.
FSuppressNullRecords | Represents field FSuppressNullRecords.
Top


TfrxCustomCrossView.FAddHeight Field

Summary

Represents field FAddHeight.

Namespace: frxCross
Syntax
Delphi
private
 FAddHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FAddWidth Field

Summary

Represents field FAddWidth.

Namespace: frxCross
Syntax
Delphi
private
 FAddWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FAllMemos Field

Summary

Represents field FAllMemos.

Namespace: frxCross
Syntax
Delphi
private
 FAllMemos: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FAllowDuplicates Field

Summary

Represents field FAllowDuplicates.

Namespace: frxCross
Syntax
Delphi
private
 FAllowDuplicates: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FAutoSize Field

Summary

Represents field FAutoSize.

Namespace: frxCross
Syntax
Delphi
private
 FAutoSize: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FBorder Field

Summary

Represents field FBorder.

Namespace: frxCross
Syntax
Delphi
private
 FBorder: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FCellFields Field

Summary

Represents field FCellFields.

Namespace: frxCross
Syntax
Delphi
private
 FCellFields: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FCellFunctions Field

Summary

Represents field FCellFunctions.

Namespace: frxCross
Syntax
Delphi
private
 FCellFunctions: array[0..63] of TfrxCrossFunction;

Field Value

Type: array[0..63] of TfrxCrossFunction

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FCellHeaderMemos Field

Summary

Represents field FCellHeaderMemos.

Namespace: frxCross
Syntax
Delphi
private
 FCellHeaderMemos: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FCellLevels Field

Summary

Represents field FCellLevels.

Namespace: frxCross
Syntax
Delphi
private
 FCellLevels: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FCellMemos Field

Summary

Represents field FCellMemos.

Namespace: frxCross
Syntax
Delphi
private
 FCellMemos: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FClearBeforePrint Field

Summary

Represents field FClearBeforePrint.

Namespace: frxCross
Syntax
Delphi
private
 FClearBeforePrint: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FColumnBands Field

Summary

Represents field FColumnBands.

Namespace: frxCross
Syntax
Delphi
private
 FColumnBands: TfrxCutBands;

Field Value

Type: TfrxCutBands

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FColumnFields Field

Summary

Represents field FColumnFields.

Namespace: frxCross
Syntax
Delphi
private
 FColumnFields: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FColumnHeader Field

Summary

Represents field FColumnHeader.

Namespace: frxCross
Syntax
Delphi
private
 FColumnHeader: TfrxCrossColumnHeader;

Field Value

Type: TfrxCrossColumnHeader

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FColumnLevels Field

Summary

Represents field FColumnLevels.

Namespace: frxCross
Syntax
Delphi
private
 FColumnLevels: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FColumnMemos Field

Summary

Represents field FColumnMemos.

Namespace: frxCross
Syntax
Delphi
private
 FColumnMemos: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FColumns Field

Summary

Represents field FColumns.

Namespace: frxCross
Syntax
Delphi
private
 FColumns: TfrxCrossColumns;

Field Value

Type: TfrxCrossColumns

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FColumnSort Field

Summary

Represents field FColumnSort.

Namespace: frxCross
Syntax
Delphi
private
 FColumnSort: TfrxSortArray;

Field Value

Type: TfrxSortArray

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FColumnTotalMemos Field

Summary

Represents field FColumnTotalMemos.

Namespace: frxCross
Syntax
Delphi
private
 FColumnTotalMemos: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FCorner Field

Summary

Represents field FCorner.

Namespace: frxCross
Syntax
Delphi
private
 FCorner: TfrxCrossCorner;

Field Value

Type: TfrxCrossCorner

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FCornerMemos Field

Summary

Represents field FCornerMemos.

Namespace: frxCross
Syntax
Delphi
private
 FCornerMemos: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FDefHeight Field

Summary

Represents field FDefHeight.

Namespace: frxCross
Syntax
Delphi
private
 FDefHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FDotMatrix Field

Summary

Represents field FDotMatrix.

Namespace: frxCross
Syntax
Delphi
private
 FDotMatrix: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FDownThenAcross Field

Summary

Represents field FDownThenAcross.

Namespace: frxCross
Syntax
Delphi
private
 FDownThenAcross: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FDragActive Field

Summary

Represents field FDragActive.

Namespace: frxCross
Syntax
Delphi
private
 FDragActive: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FFirstMousePos Field

Summary

Represents field FFirstMousePos.

Namespace: frxCross
Syntax
Delphi
private
 FFirstMousePos: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FGapX Field

Summary

Represents field FGapX.

Namespace: frxCross
Syntax
Delphi
private
 FGapX: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FGapY Field

Summary

Represents field FGapY.

Namespace: frxCross
Syntax
Delphi
private
 FGapY: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FGridUsed Field

Summary

Represents field FGridUsed.

Namespace: frxCross
Syntax
Delphi
private
 FGridUsed: TfrxGridLines;

Field Value

Type: TfrxGridLines

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FGridX Field

Summary

Represents field FGridX.

Namespace: frxCross
Syntax
Delphi
private
 FGridX: TfrxGridLines;

Field Value

Type: TfrxGridLines

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FGridY Field

Summary

Represents field FGridY.

Namespace: frxCross
Syntax
Delphi
private
 FGridY: TfrxGridLines;

Field Value

Type: TfrxGridLines

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FJoinEqualCells Field

Summary

Represents field FJoinEqualCells.

Namespace: frxCross
Syntax
Delphi
private
 FJoinEqualCells: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FKeepRowsTogether Field

Summary

Represents field FKeepRowsTogether.

Namespace: frxCross
Syntax
Delphi
private
 FKeepRowsTogether: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FKeepTogether Field

Summary

Represents field FKeepTogether.

Namespace: frxCross
Syntax
Delphi
private
 FKeepTogether: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FLastMousePos Field

Summary

Represents field FLastMousePos.

Namespace: frxCross
Syntax
Delphi
private
 FLastMousePos: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FMaxWidth Field

Summary

Represents field FMaxWidth.

Namespace: frxCross
Syntax
Delphi
private
 FMaxWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FMinWidth Field

Summary

Represents field FMinWidth.

Namespace: frxCross
Syntax
Delphi
private
 FMinWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FMouseDown Field

Summary

Represents field FMouseDown.

Namespace: frxCross
Syntax
Delphi
private
 FMouseDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FMovingObjects Field

Summary

Represents field FMovingObjects.

Namespace: frxCross
Syntax
Delphi
private
 FMovingObjects: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FNextCross Field

Summary

Represents field FNextCross.

Namespace: frxCross
Syntax
Delphi
private
 FNextCross: TfrxCustomCrossView;

Field Value

Type: TfrxCustomCrossView

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FNextCrossGap Field

Summary

Represents field FNextCrossGap.

Namespace: frxCross
Syntax
Delphi
private
 FNextCrossGap: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FNoColumns Field

Summary

Represents field FNoColumns.

Namespace: frxCross
Syntax
Delphi
private
 FNoColumns: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FNoRows Field

Summary

Represents field FNoRows.

Namespace: frxCross
Syntax
Delphi
private
 FNoRows: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FOnBeforeCalcHeight Field

Summary

Represents field FOnBeforeCalcHeight.

Namespace: frxCross
Syntax
Delphi
private
 FOnBeforeCalcHeight: TfrxOnCalcHeightEvent;

Field Value

Type: TfrxOnCalcHeightEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FOnBeforeCalcWidth Field

Summary

Represents field FOnBeforeCalcWidth.

Namespace: frxCross
Syntax
Delphi
private
 FOnBeforeCalcWidth: TfrxOnCalcWidthEvent;

Field Value

Type: TfrxOnCalcWidthEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FOnBeforePrintCell Field

Summary

Represents field FOnBeforePrintCell.

Namespace: frxCross
Syntax
Delphi
private
 FOnBeforePrintCell: TfrxOnPrintCellEvent;

Field Value

Type: TfrxOnPrintCellEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FOnBeforePrintColumnHeader Field

Summary

Represents field FOnBeforePrintColumnHeader.

Namespace: frxCross
Syntax
Delphi
private
 FOnBeforePrintColumnHeader: TfrxOnPrintHeaderEvent;

Field Value

Type: TfrxOnPrintHeaderEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FOnBeforePrintRowHeader Field

Summary

Represents field FOnBeforePrintRowHeader.

Namespace: frxCross
Syntax
Delphi
private
 FOnBeforePrintRowHeader: TfrxOnPrintHeaderEvent;

Field Value

Type: TfrxOnPrintHeaderEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FOnCalcHeight Field

Summary

Represents field FOnCalcHeight.

Namespace: frxCross
Syntax
Delphi
private
 FOnCalcHeight: TfrxCalcHeightEvent;

Field Value

Type: TfrxCalcHeightEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FOnCalcWidth Field

Summary

Represents field FOnCalcWidth.

Namespace: frxCross
Syntax
Delphi
private
 FOnCalcWidth: TfrxCalcWidthEvent;

Field Value

Type: TfrxCalcWidthEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FOnPrintCell Field

Summary

Represents field FOnPrintCell.

Namespace: frxCross
Syntax
Delphi
private
 FOnPrintCell: TfrxPrintCellEvent;

Field Value

Type: TfrxPrintCellEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FOnPrintColumnHeader Field

Summary

Represents field FOnPrintColumnHeader.

Namespace: frxCross
Syntax
Delphi
private
 FOnPrintColumnHeader: TfrxPrintHeaderEvent;

Field Value

Type: TfrxPrintHeaderEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FOnPrintRowHeader Field

Summary

Represents field FOnPrintRowHeader.

Namespace: frxCross
Syntax
Delphi
private
 FOnPrintRowHeader: TfrxPrintHeaderEvent;

Field Value

Type: TfrxPrintHeaderEvent

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FPlainCells Field

Summary

Represents field FPlainCells.

Namespace: frxCross
Syntax
Delphi
private
 FPlainCells: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FPrevCrossLastPage Field

Summary

Represents field FPrevCrossLastPage.

Namespace: frxCross
Syntax
Delphi
private
 FPrevCrossLastPage: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FRepeatHeaders Field

Summary

Represents field FRepeatHeaders.

Namespace: frxCross
Syntax
Delphi
private
 FRepeatHeaders: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FRowBands Field

Summary

Represents field FRowBands.

Namespace: frxCross
Syntax
Delphi
private
 FRowBands: TfrxCutBands;

Field Value

Type: TfrxCutBands

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FRowFields Field

Summary

Represents field FRowFields.

Namespace: frxCross
Syntax
Delphi
private
 FRowFields: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FRowHeader Field

Summary

Represents field FRowHeader.

Namespace: frxCross
Syntax
Delphi
private
 FRowHeader: TfrxCrossRowHeader;

Field Value

Type: TfrxCrossRowHeader

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FRowLevels Field

Summary

Represents field FRowLevels.

Namespace: frxCross
Syntax
Delphi
private
 FRowLevels: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FRowMemos Field

Summary

Represents field FRowMemos.

Namespace: frxCross
Syntax
Delphi
private
 FRowMemos: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FRows Field

Summary

Represents field FRows.

Namespace: frxCross
Syntax
Delphi
private
 FRows: TfrxCrossRows;

Field Value

Type: TfrxCrossRows

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FRowSort Field

Summary

Represents field FRowSort.

Namespace: frxCross
Syntax
Delphi
private
 FRowSort: TfrxSortArray;

Field Value

Type: TfrxSortArray

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FRowTotalMemos Field

Summary

Represents field FRowTotalMemos.

Namespace: frxCross
Syntax
Delphi
private
 FRowTotalMemos: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FShowCellBreak Field

Summary

Represents field FShowCellBreak.

Namespace: frxCross
Syntax
Delphi
private
 FShowCellBreak: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FShowColumnHeader Field

Summary

Represents field FShowColumnHeader.

Namespace: frxCross
Syntax
Delphi
private
 FShowColumnHeader: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FShowColumnTotal Field

Summary

Represents field FShowColumnTotal.

Namespace: frxCross
Syntax
Delphi
private
 FShowColumnTotal: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FShowCorner Field

Summary

Represents field FShowCorner.

Namespace: frxCross
Syntax
Delphi
private
 FShowCorner: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FShowMoveArrow Field

Summary

Represents field FShowMoveArrow.

Namespace: frxCross
Syntax
Delphi
private
 FShowMoveArrow: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FShowRowHeader Field

Summary

Represents field FShowRowHeader.

Namespace: frxCross
Syntax
Delphi
private
 FShowRowHeader: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FShowRowTotal Field

Summary

Represents field FShowRowTotal.

Namespace: frxCross
Syntax
Delphi
private
 FShowRowTotal: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FShowTitle Field

Summary

Represents field FShowTitle.

Namespace: frxCross
Syntax
Delphi
private
 FShowTitle: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCustomCrossView.FSuppressNullRecords Field

Summary

Represents field FSuppressNullRecords.

Namespace: frxCross
Syntax
Delphi
private
 FSuppressNullRecords: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomCrossView
  • frxCross


TfrxCutBandItem Class

Summary

Represents type TfrxCutBandItem.

Namespace: frxCross
Inheritance Hierarchy
TCollectionItem
frxCross.TfrxCutBandItem
Syntax
Delphi
type
 TfrxCutBandItem = class(TCollectionItem)
 end;

The TfrxCutBandItem type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TfrxCutBandItem class.
Top
Fields
Show:
Name | Description
Band | Represents field Band.
FromIndex | Represents field FromIndex.
ToIndex | Represents field ToIndex.
Top
See Also

Reference

  • frxCross


TfrxCutBandItem Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TfrxCutBandItem class.
Top


TfrxCutBandItem.Destroy Destructor

Summary

Represents the destructor of the TfrxCutBandItem class.

Namespace: frxCross
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCutBandItem
  • frxCross


TfrxCutBandItem Fields

Fields
Name | Description
Band | Represents field Band.
FromIndex | Represents field FromIndex.
ToIndex | Represents field ToIndex.
Top


TfrxCutBandItem.Band Field

Summary

Represents field Band.

Namespace: frxCross
Syntax
Delphi
public
 Band: TfrxBand;

Field Value

Type: TfrxBand

See Also

Reference

  • TfrxCutBandItem
  • frxCross


TfrxCutBandItem.FromIndex Field

Summary

Represents field FromIndex.

Namespace: frxCross
Syntax
Delphi
public
 FromIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCutBandItem
  • frxCross


TfrxCutBandItem.ToIndex Field

Summary

Represents field ToIndex.

Namespace: frxCross
Syntax
Delphi
public
 ToIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCutBandItem
  • frxCross


TfrxCutBands Class

Summary

Represents type TfrxCutBands.

Namespace: frxCross
Inheritance Hierarchy
TCollection
frxCross.TfrxCutBands
Syntax
Delphi
type
 TfrxCutBands = class(TCollection)
 end;

The TfrxCutBands type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxCutBands class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add(TfrxBand,Integer,Integer) | Represents method Add(TfrxBand,Integer,Integer).
GetItems(Integer) | Represents method GetItems(Integer).
Top
See Also

Reference

  • frxCross


TfrxCutBands Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxCutBands class.
Top


TfrxCutBands.Create Constructor

Summary

Initializes a new instance of the TfrxCutBands class.

Namespace: frxCross
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxCutBands
  • frxCross


TfrxCutBands Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxCutBands.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxCross
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxCutBandItem read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCutBandItem

See Also

Reference

  • TfrxCutBands
  • frxCross


TfrxCutBands Methods

Methods
Name | Description
Add(TfrxBand,Integer,Integer) | Represents method Add(TfrxBand,Integer,Integer).
GetItems(Integer) | Represents method GetItems(Integer).
Top


TfrxCutBands.Add(TfrxBand,Integer,Integer) Method

Summary

Represents method Add(TfrxBand,Integer,Integer).

Namespace: frxCross
Syntax
Delphi
public
 procedure Add(ABand: TfrxBand; AFromIndex, AToIndex: Integer);

Parameters

ABand
Type: TfrxBand

AFromIndex
Type: Integer

AToIndex
Type: Integer

See Also

Reference

  • TfrxCutBands
  • frxCross


TfrxCutBands.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxCutBandItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCutBandItem

See Also

Reference

  • TfrxCutBands
  • frxCross


TfrxDBCrossView Class

Summary

The TfrxDBCrossView component shows a cross-table from the DB data. You should connect it to the dataset (DataSet property) and fill in the CellFields, ColumnFields, RowFields properties.

Namespace: frxCross
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxCross.TfrxCustomCrossView
frxCross.TfrxDBCrossView
Syntax
Delphi
type
 TfrxDBCrossView = class(TfrxCustomCrossView)
 end;

The TfrxDBCrossView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomCrossView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AddHeight | Represents property AddHeight. (Inherited from TfrxCustomCrossView.)
AddWidth | Represents property AddWidth. (Inherited from TfrxCustomCrossView.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowDuplicates | Represents property AllowDuplicates. (Inherited from TfrxCustomCrossView.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
AutoSize | Represents property AutoSize. (Inherited from TfrxCustomCrossView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Border | Determines whether the cross-table should have an outer border. Default value is True. (Inherited from TfrxCustomCrossView.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
CellFields | List of DB fields representing each level of the cell.
CellFunctions[Integer] | Aggregate functions for each cell level. (Inherited from TfrxCustomCrossView.)
CellHeaderMemos[Integer] | Represents property CellHeaderMemos[Integer]. (Inherited from TfrxCustomCrossView.)
CellLevels | Number of levels of cross-tab cell. (Inherited from TfrxCustomCrossView.)
CellMemos[Integer] | Array of Text objects that represents each level of cell. First array element has 0 index. (Inherited from TfrxCustomCrossView.)
ClearBeforePrint | Represents property ClearBeforePrint. (Inherited from TfrxCustomCrossView.)
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ColumnFields | List of DB fields representing each level of the column header.
ColumnHeader | Represents property ColumnHeader. (Inherited from TfrxCustomCrossView.)
ColumnLevels | Number of levels in the column header. (Inherited from TfrxCustomCrossView.)
ColumnMemos[Integer] | Array of Text objects that represents each level of column header. First array element has 0 index. (Inherited from TfrxCustomCrossView.)
ColumnSort[Integer] | Sort order for each level of column header. (Inherited from TfrxCustomCrossView.)
ColumnTotalMemos[Integer] | Array of Text objects that represents each total cell of column header. First array element has 0 index and is represents the grand total. (Inherited from TfrxCustomCrossView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Corner | Represents property Corner. (Inherited from TfrxCustomCrossView.)
CornerMemos[Integer] | Array of Text objects that represents the table header. The first array element has 0 index and is represents the top left corner, the second represents all columns header, CornerMemos[2..RowLevels+2] are row levels headers. (Inherited from TfrxCustomCrossView.)
Cursor | Object's cursor (in the preview mode). (Inherited from TfrxView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
DefHeight | Default height of each row. If this property is 0 (default), the height of each row is calculated automatically. (Inherited from TfrxCustomCrossView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DotMatrix | Represents property DotMatrix. (Inherited from TfrxCustomCrossView.)
DownThenAcross | Determines how the big table will break across pages. If this property is False (default), the table will break across then down. (Inherited from TfrxCustomCrossView.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Object's frame. (Inherited from TfrxView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GapX | The left indent of the text in the cross-tab cells. (Inherited from TfrxCustomCrossView.)
GapY | The top indent of the text in the cross-tab cells. (Inherited from TfrxCustomCrossView.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
JoinEqualCells | Determines whether to join several side-by-side cells with equal values into one wide cell. (Inherited from TfrxCustomCrossView.)
KeepRowsTogether | Represents property KeepRowsTogether. (Inherited from TfrxCustomCrossView.)
KeepTogether | Represents property KeepTogether. (Inherited from TfrxCustomCrossView.)
Left | Represents property Left. (Inherited from TfrxView.)
MaxWidth | The maximum width of the cross-tab column. If this property is 0 (default), the width is calculated automatically. (Inherited from TfrxCustomCrossView.)
MinWidth | The minimum width of the cross-tab column. If this property is 0 (default), the width is calculated automatically. (Inherited from TfrxCustomCrossView.)
NextCross | The next cross-tab object that will be rendered side-by-side. (Inherited from TfrxCustomCrossView.)
NextCrossGap | The gap between two side-by-side crosses (see NextCross). (Inherited from TfrxCustomCrossView.)
NoColumns | Represents property NoColumns. (Inherited from TfrxCustomCrossView.)
NoRows | Represents property NoRows. (Inherited from TfrxCustomCrossView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnCalcHeight | Name of the script procedure that will run when calculating a height of each row. (Inherited from TfrxCustomCrossView.)
OnCalcWidth | Name of the script procedure that will run when calculating a width of each column. (Inherited from TfrxCustomCrossView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
OnPrintCell | Name of the script procedure that will run before printing each cell of the cross-table. (Inherited from TfrxCustomCrossView.)
OnPrintColumnHeader | Name of the script procedure that will run before printing eachelement of the column header. (Inherited from TfrxCustomCrossView.)
OnPrintRowHeader | Name of the script procedure that will run before printing each element of the row header. (Inherited from TfrxCustomCrossView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainCells | Determines whether to print cell levels stacked (default) or side-by-side. (Inherited from TfrxCustomCrossView.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
RepeatHeaders | Determines whether cross-tab should repeat column and row headers on each new page. Default value is True. (Inherited from TfrxCustomCrossView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
RowFields | Represents property RowFields.
RowHeader | Represents property RowHeader. (Inherited from TfrxCustomCrossView.)
RowLevels | Number of levels in the row header. (Inherited from TfrxCustomCrossView.)
RowMemos[Integer] | Array of Text objects that represents each level of row header. First array element has 0 index. (Inherited from TfrxCustomCrossView.)
RowSort[Integer] | Sort order for each level of row header. (Inherited from TfrxCustomCrossView.)
RowTotalMemos[Integer] | Array of Text objects that represents each total cell of row header. First array element has 0 index and is represents the grand total. (Inherited from TfrxCustomCrossView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowCellBreak | Represents property ShowCellBreak. (Inherited from TfrxCustomCrossView.)
ShowColumnHeader | Determines whether to show column header or not. Default value is True. (Inherited from TfrxCustomCrossView.)
ShowColumnTotal | Determines if column total is shown. Default value is True. (Inherited from TfrxCustomCrossView.)
ShowCorner | Determines whether to show top-left corner elements (table headers). (Inherited from TfrxCustomCrossView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
ShowRowHeader | Determines if row header is shown. Default value is True. (Inherited from TfrxCustomCrossView.)
ShowRowTotal | Determines if row total is shown. Default value is True. (Inherited from TfrxCustomCrossView.)
ShowTitle | Represents property ShowTitle. (Inherited from TfrxCustomCrossView.)
SuppressNullRecords | Represents property SuppressNullRecords. (Inherited from TfrxCustomCrossView.)
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Overrides TfrxComponent.AddSourceObjects.)
AddValue(Variant[],Variant[],Variant[]) | Method adds a value into cross-table. Use this method to fill in the TfrxCrossView object. (Inherited from TfrxCustomCrossView.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
ApplyStyle(TfrxStyles) | Represents method ApplyStyle(TfrxStyles). (Inherited from TfrxCustomCrossView.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Overrides TfrxComponent.BeforeStartReport.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
BeginMatrix | Represents method BeginMatrix. (Inherited from TfrxCustomCrossView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ColCount | Returns a number of columns in the cross. (Inherited from TfrxCustomCrossView.)
ColumnHeaderHeight | Represents method ColumnHeaderHeight. (Inherited from TfrxCustomCrossView.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Overrides TfrxComponent.ContainerAdd(TfrxComponent).)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxCustomCrossView.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawCross(TCanvas,Extended,Extended,Extended,Extended) | Represents method DrawCross(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxCustomCrossView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
EndMatrix | Represents method EndMatrix. (Inherited from TfrxCustomCrossView.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FillMatrix | Represents method FillMatrix. (Overrides TfrxCustomCrossView.FillMatrix.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColumnIndexes(Integer) | Represents method GetColumnIndexes(Integer). (Inherited from TfrxCustomCrossView.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Overrides TfrxComponent.GetContainerObjects.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetRowIndexes(Integer) | Represents method GetRowIndexes(Integer). (Inherited from TfrxCustomCrossView.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetStyle(TfrxStyles) | Represents method GetStyle(TfrxStyles). (Inherited from TfrxCustomCrossView.)
GetValue(Integer,Integer,Integer) | Represents method GetValue(Integer,Integer,Integer). (Inherited from TfrxCustomCrossView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxView.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsCrossValid | Represents method IsCrossValid. (Overrides TfrxCustomCrossView.IsCrossValid.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsGrandTotalColumn(Integer) | Returns True if specified column is grand total column. (Inherited from TfrxCustomCrossView.)
IsGrandTotalRow(Integer) | Returns True if specified row is grand total row. (Inherited from TfrxCustomCrossView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsTotalColumn(Integer) | Returns True if specified column is total column. (Inherited from TfrxCustomCrossView.)
IsTotalRow(Integer) | Returns True if specified row is total row. (Inherited from TfrxCustomCrossView.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
RowCount | Returns a number of rows in the cross. (Inherited from TfrxCustomCrossView.)
RowHeaderWidth | Represents method RowHeaderWidth. (Inherited from TfrxCustomCrossView.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCellLevels(Integer) | Represents method SetCellLevels(Integer). (Inherited from TfrxCustomCrossView.)
SetColumnLevels(Integer) | Represents method SetColumnLevels(Integer). (Inherited from TfrxCustomCrossView.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetRowLevels(Integer) | Represents method SetRowLevels(Integer). (Inherited from TfrxCustomCrossView.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Events
Show:
Name | Description
OnBeforeCalcHeight | Represents property OnBeforeCalcHeight. (Inherited from TfrxCustomCrossView.)
OnBeforeCalcWidth | Represents property OnBeforeCalcWidth. (Inherited from TfrxCustomCrossView.)
OnBeforePrintCell | Represents property OnBeforePrintCell. (Inherited from TfrxCustomCrossView.)
OnBeforePrintColumnHeader | Represents property OnBeforePrintColumnHeader. (Inherited from TfrxCustomCrossView.)
OnBeforePrintRowHeader | Represents property OnBeforePrintRowHeader. (Inherited from TfrxCustomCrossView.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxCross


TfrxDBCrossView Properties

Properties
Name | Description
CellFields | List of DB fields representing each level of the cell.
ColumnFields | List of DB fields representing each level of the column header.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
RowFields | Represents property RowFields.
Top


TfrxDBCrossView.CellFields Property

Summary

List of DB fields representing each level of the cell.

Namespace: frxCross
Syntax
Delphi
published
 property CellFields;

Property Value

Type: Void

See Also

Reference

  • TfrxDBCrossView
  • frxCross


TfrxDBCrossView.ColumnFields Property

Summary

List of DB fields representing each level of the column header.

Namespace: frxCross
Syntax
Delphi
published
 property ColumnFields;

Property Value

Type: Void

See Also

Reference

  • TfrxDBCrossView
  • frxCross


TfrxDBCrossView.DataSet Property

Summary

Represents property DataSet.

Namespace: frxCross
Syntax
Delphi
published
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxDBCrossView
  • frxCross


TfrxDBCrossView.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxCross
Syntax
Delphi
published
 property DataSetName;

Property Value

Type: Void

See Also

Reference

  • TfrxDBCrossView
  • frxCross


TfrxDBCrossView.RowFields Property

Summary

Represents property RowFields.

Namespace: frxCross
Syntax
Delphi
published
 property RowFields;

Property Value

Type: Void

See Also

Reference

  • TfrxDBCrossView
  • frxCross


TfrxDBCrossView Methods

Methods
Name | Description
FillMatrix | Represents method FillMatrix. (Overrides TfrxCustomCrossView.FillMatrix.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
IsCrossValid | Represents method IsCrossValid. (Overrides TfrxCustomCrossView.IsCrossValid.)
Top


TfrxDBCrossView.FillMatrix Method

Summary

Represents method FillMatrix.

Namespace: frxCross
Syntax
Delphi
public
 procedure FillMatrix; override;

Overrides

TfrxCustomCrossView.FillMatrix
See Also

Reference

  • TfrxDBCrossView
  • frxCross


TfrxDBCrossView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxCross
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxDBCrossView
  • frxCross


TfrxDBCrossView.IsCrossValid Method

Summary

Represents method IsCrossValid.

Namespace: frxCross
Syntax
Delphi
public
 function IsCrossValid: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCustomCrossView.IsCrossValid
See Also

Reference

  • TfrxDBCrossView
  • frxCross


TfrxGridLineItem Class

Summary

Represents type TfrxGridLineItem.

Namespace: frxCross
Inheritance Hierarchy
TCollectionItem
frxCross.TfrxGridLineItem
Syntax
Delphi
type
 TfrxGridLineItem = class(TCollectionItem)
 end;

The TfrxGridLineItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxGridLineItem class.
Destroy | Represents the destructor of the TfrxGridLineItem class.
Top
Fields
Show:
Name | Description
Coord | Represents field Coord.
Objects | Represents field Objects.
Top
See Also

Reference

  • frxCross


TfrxGridLineItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxGridLineItem class.
Destroy | Represents the destructor of the TfrxGridLineItem class.
Top


TfrxGridLineItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TfrxGridLineItem class.

Namespace: frxCross
Syntax
Delphi
public
 constructor Create(Collection: TCollection); override;

Parameters

Collection
Type: TCollection

See Also

Reference

  • TfrxGridLineItem
  • frxCross


TfrxGridLineItem.Destroy Destructor

Summary

Represents the destructor of the TfrxGridLineItem class.

Namespace: frxCross
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxGridLineItem
  • frxCross


TfrxGridLineItem Fields

Fields
Name | Description
Coord | Represents field Coord.
Objects | Represents field Objects.
Top


TfrxGridLineItem.Coord Field

Summary

Represents field Coord.

Namespace: frxCross
Syntax
Delphi
public
 Coord: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxGridLineItem
  • frxCross


TfrxGridLineItem.Objects Field

Summary

Represents field Objects.

Namespace: frxCross
Syntax
Delphi
public
 Objects: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxGridLineItem
  • frxCross


TfrxGridLines Class

Summary

Represents type TfrxGridLines.

Namespace: frxCross
Inheritance Hierarchy
TCollection
frxCross.TfrxGridLines
Syntax
Delphi
type
 TfrxGridLines = class(TCollection)
 end;

The TfrxGridLines type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxGridLines class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add(TObject,Extended) | Represents method Add(TObject,Extended).
GetItems(Integer) | Represents method GetItems(Integer).
Top
See Also

Reference

  • frxCross


TfrxGridLines Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxGridLines class.
Top


TfrxGridLines.Create Constructor

Summary

Initializes a new instance of the TfrxGridLines class.

Namespace: frxCross
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxGridLines
  • frxCross


TfrxGridLines Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxGridLines.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxCross
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxGridLineItem read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxGridLineItem

See Also

Reference

  • TfrxGridLines
  • frxCross


TfrxGridLines Methods

Methods
Name | Description
Add(TObject,Extended) | Represents method Add(TObject,Extended).
GetItems(Integer) | Represents method GetItems(Integer).
Top


TfrxGridLines.Add(TObject,Extended) Method

Summary

Represents method Add(TObject,Extended).

Namespace: frxCross
Syntax
Delphi
public
 procedure Add(AObj: TObject; ACoord: Extended);

Parameters

AObj
Type: TObject

ACoord
Type: Extended

See Also

Reference

  • TfrxGridLines
  • frxCross


TfrxGridLines.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxGridLineItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxGridLineItem

See Also

Reference

  • TfrxGridLines
  • frxCross


TfrxIndexCollection Class

Summary

Represents type TfrxIndexCollection.

Namespace: frxCross
Inheritance Hierarchy
TCollection
frxCross.TfrxIndexCollection
frxCross.TfrxCrossColumns
frxCross.TfrxCrossRows
Syntax
Delphi
type
 TfrxIndexCollection = class(TCollection)
 end;

The TfrxIndexCollection type exposes the following members.

Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Find(Variant[],Integer) | Represents method Find(Variant[],Integer).
GetItems(Integer) | Represents method GetItems(Integer).
InsertItem(Integer,Variant[]) | Represents method InsertItem(Integer,Variant[]).
Top
Fields
Show:
Name | Description
FIndexesCount | Represents field FIndexesCount.
FSortOrder | Represents field FSortOrder.
Top
See Also

Reference

  • frxCross


TfrxIndexCollection Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxIndexCollection.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxCross
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxIndexItem read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxIndexItem

See Also

Reference

  • TfrxIndexCollection
  • frxCross


TfrxIndexCollection Methods

Methods
Name | Description
Find(Variant[],Integer) | Represents method Find(Variant[],Integer).
GetItems(Integer) | Represents method GetItems(Integer).
InsertItem(Integer,Variant[]) | Represents method InsertItem(Integer,Variant[]).
Top


TfrxIndexCollection.Find(Variant[],Integer) Method

Summary

Represents method Find(Variant[],Integer).

Namespace: frxCross
Syntax
Delphi
public
 function Find(const Indexes: array of Variant; var Index: Integer): Boolean;

Parameters

Indexes
Type: array of Variant

Index
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxIndexCollection
  • frxCross


TfrxIndexCollection.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxCross
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxIndexItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxIndexItem

See Also

Reference

  • TfrxIndexCollection
  • frxCross


TfrxIndexCollection.InsertItem(Integer,Variant[]) Method

Summary

Represents method InsertItem(Integer,Variant[]).

Namespace: frxCross
Syntax
Delphi
public
 function InsertItem(Index: Integer; const Indexes: array of Variant): TfrxIndexItem; virtual;

Parameters

Index
Type: Integer

Indexes
Type: array of Variant

Return Value

Type: TfrxIndexItem

See Also

Reference

  • TfrxIndexCollection
  • frxCross


TfrxIndexCollection Fields

Fields
Name | Description
FIndexesCount | Represents field FIndexesCount.
FSortOrder | Represents field FSortOrder.
Top


TfrxIndexCollection.FIndexesCount Field

Summary

Represents field FIndexesCount.

Namespace: frxCross
Syntax
Delphi
private
 FIndexesCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxIndexCollection
  • frxCross


TfrxIndexCollection.FSortOrder Field

Summary

Represents field FSortOrder.

Namespace: frxCross
Syntax
Delphi
private
 FSortOrder: TfrxSortArray;

Field Value

Type: TfrxSortArray

See Also

Reference

  • TfrxIndexCollection
  • frxCross


TfrxIndexItem Class

Summary

Represents type TfrxIndexItem.

Namespace: frxCross
Inheritance Hierarchy
TCollectionItem
frxCross.TfrxIndexItem
frxCross.TfrxCrossColumn
frxCross.TfrxCrossRow
Syntax
Delphi
type
 TfrxIndexItem = class(TCollectionItem)
 end;

The TfrxIndexItem type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TfrxIndexItem class.
Top
Properties
Show:
Name | Description
Indexes | Represents property Indexes.
Top
Fields
Show:
Name | Description
FIndexes | Represents field FIndexes.
Top
See Also

Reference

  • frxCross


TfrxIndexItem Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TfrxIndexItem class.
Top


TfrxIndexItem.Destroy Destructor

Summary

Represents the destructor of the TfrxIndexItem class.

Namespace: frxCross
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxIndexItem
  • frxCross


TfrxIndexItem Properties

Properties
Name | Description
Indexes | Represents property Indexes.
Top


TfrxIndexItem.Indexes Property

Summary

Represents property Indexes.

Namespace: frxCross
Syntax
Delphi
public
 property Indexes: TfrxVariantArray read FIndexes write FIndexes;

Property Value

Type: TfrxVariantArray

See Also

Reference

  • TfrxIndexItem
  • frxCross


TfrxIndexItem Fields

Fields
Name | Description
FIndexes | Represents field FIndexes.
Top


TfrxIndexItem.FIndexes Field

Summary

Represents field FIndexes.

Namespace: frxCross
Syntax
Delphi
private
 FIndexes: TfrxVariantArray;

Field Value

Type: TfrxVariantArray

See Also

Reference

  • TfrxIndexItem
  • frxCross


TfrxPrintCellEvent Class

Summary

Represents type TfrxPrintCellEvent.

Namespace: frxCross
Syntax
Delphi
type
 TfrxPrintCellEvent = type String;
See Also

Reference

  • frxCross


TfrxPrintHeaderEvent Class

Summary

Represents type TfrxPrintHeaderEvent.

Namespace: frxCross
Syntax
Delphi
type
 TfrxPrintHeaderEvent = type String;
See Also

Reference

  • frxCross


frxCross Records

Records
Name | Description
TfrxCrossCell | Represents type TfrxCrossCell.
Top


TfrxCrossCell Record

Summary

Represents type TfrxCrossCell.

Namespace: frxCross
Syntax
Delphi
type
 TfrxCrossCell = packed record
 end;

The TfrxCrossCell type exposes the following members.

Fields
Show:
Name | Description
Count | Represents field Count.
Next | Represents field Next.
Value | Represents field Value.
Top
See Also

Reference

  • frxCross


TfrxCrossCell Fields

Fields
Name | Description
Count | Represents field Count.
Next | Represents field Next.
Value | Represents field Value.
Top


TfrxCrossCell.Count Field

Summary

Represents field Count.

Namespace: frxCross
Syntax
Delphi
public
 Count: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCrossCell
  • frxCross


TfrxCrossCell.Next Field

Summary

Represents field Next.

Namespace: frxCross
Syntax
Delphi
public
 Next: PfrCrossCell;

Field Value

Type: PfrCrossCell

See Also

Reference

  • TfrxCrossCell
  • frxCross


TfrxCrossCell.Value Field

Summary

Represents field Value.

Namespace: frxCross
Syntax
Delphi
public
 Value: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxCrossCell
  • frxCross


frxCross Enumerations

Enumerations
Name | Description
TfrxCrossEditGrid | Represents type TfrxCrossEditGrid.
TfrxCrossFunction | Type of aggregate function used in the crosstab cells.
TfrxCrossSortOrder | Sort order of cross header values.
Top


TfrxCrossEditGrid Enumeration

Summary

Represents type TfrxCrossEditGrid.

Namespace: frxCross
Syntax
Delphi
type
 TfrxCrossEditGrid = (seLeftTop, seLeftBottom, seRightTop, seRightBottom);

The TfrxCrossEditGrid type exposes the following members.

Members
Show:
Name | Description
seLeftBottom | Represents constant seLeftBottom.
seLeftTop | Represents constant seLeftTop.
seRightBottom | Represents constant seRightBottom.
seRightTop | Represents constant seRightTop.
Top
See Also

Reference

  • frxCross


TfrxCrossFunction Enumeration

Summary

Type of aggregate function used in the crosstab cells.

Namespace: frxCross
Syntax
Delphi
type
 TfrxCrossFunction = (cfNone, cfSum, cfMin, cfMax, cfAvg, cfCount);

The TfrxCrossFunction type exposes the following members.

Members
Show:
Name | Description
cfAvg | Represents constant cfAvg.
cfCount | Represents constant cfCount.
cfMax | Represents constant cfMax.
cfMin | Represents constant cfMin.
cfNone | Represents constant cfNone.
cfSum | Represents constant cfSum.
Top
See Also

Reference

  • frxCross


TfrxCrossSortOrder Enumeration

Summary

Sort order of cross header values.

Namespace: frxCross
Syntax
Delphi
type
 TfrxCrossSortOrder = (soAscending, soDescending, soNone, soGrouping);

The TfrxCrossSortOrder type exposes the following members.

Members
Show:
Name | Description
soAscending | Represents constant soAscending.
soDescending | Represents constant soDescending.
soGrouping | Represents constant soGrouping.
soNone | Represents constant soNone.
Top
See Also

Reference

  • frxCross


frxCross Delegates

Delegates
Name | Description
TfrxOnCalcHeightEvent | Represents type TfrxOnCalcHeightEvent.
TfrxOnCalcWidthEvent | Represents type TfrxOnCalcWidthEvent.
TfrxOnPrintCellEvent | Represents type TfrxOnPrintCellEvent.
TfrxOnPrintHeaderEvent | Represents type TfrxOnPrintHeaderEvent.
Top


TfrxOnCalcHeightEvent Delegate

Summary

Represents type TfrxOnCalcHeightEvent.

Namespace: frxCross
Syntax
Delphi
type
 TfrxOnCalcHeightEvent = procedure (RowIndex: Integer;
 const RowValues: Variant; var Height: Extended) of object;
See Also

Reference

  • frxCross


TfrxOnCalcWidthEvent Delegate

Summary

Represents type TfrxOnCalcWidthEvent.

Namespace: frxCross
Syntax
Delphi
type
 TfrxOnCalcWidthEvent = procedure (ColumnIndex: Integer;
 const ColumnValues: Variant; var Width: Extended) of object;
See Also

Reference

  • frxCross


TfrxOnPrintCellEvent Delegate

Summary

Represents type TfrxOnPrintCellEvent.

Namespace: frxCross
Syntax
Delphi
type
 TfrxOnPrintCellEvent = procedure (Memo: TfrxCustomMemoView;
 RowIndex, ColumnIndex, CellIndex: Integer;
 const RowValues, ColumnValues, Value: Variant) of object;
See Also

Reference

  • frxCross


TfrxOnPrintHeaderEvent Delegate

Summary

Represents type TfrxOnPrintHeaderEvent.

Namespace: frxCross
Syntax
Delphi
type
 TfrxOnPrintHeaderEvent = procedure (Memo: TfrxCustomMemoView;
 const HeaderIndexes, HeaderValues, Value: Variant) of object;
See Also

Reference

  • frxCross


frxCross Types

Types
Name | Description
PfrCrossCell | Represents a pointer type to TfrxCrossCell.
TfrxSortArray | Represents an array of the TfrxCrossSortOrder type.
TfrxVariantArray | Represents an array of the Variant type.
Top


PfrCrossCell Type

Summary

Represents a pointer type to TfrxCrossCell.

Namespace: frxCross
Syntax
Delphi
type
 PfrCrossCell = ^TfrxCrossCell;
See Also

Reference

  • frxCross


TfrxSortArray Type

Summary

Represents an array of the TfrxCrossSortOrder type.

Namespace: frxCross
Syntax
Delphi
type
 TfrxSortArray = array [0..63] of TfrxCrossSortOrder;
See Also

Reference

  • frxCross


TfrxVariantArray Type

Summary

Represents an array of the Variant type.

Namespace: frxCross
Syntax
Delphi
type
 TfrxVariantArray = array of Variant;
See Also

Reference

  • frxCross


frxCrypt Namespace

Summary

Represents namespace frxCrypt.

Classes
Name | Description
TfrxCrypt | Represents type TfrxCrypt.
Top
Routines
Name | Description
frxCryptStream(TStream,TStream,AnsiString) | Represents method frxCryptStream(TStream,TStream,AnsiString).
frxDecryptStream(TStream,TStream,AnsiString) | Represents method frxDecryptStream(TStream,TStream,AnsiString).
Top


frxCrypt Classes

Classes
Name | Description
TfrxCrypt | Represents type TfrxCrypt.
Top


TfrxCrypt Class

Summary

Represents type TfrxCrypt.

Namespace: frxCrypt
Inheritance Hierarchy
TComponent
frxClass.TfrxCustomCrypter
frxCrypt.TfrxCrypt
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxCrypt = class(TfrxCustomCrypter)
 end;

The TfrxCrypt type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomCrypter class. (Inherited from TfrxCustomCrypter.)
Top
Properties
Show:
Name | Description
Stream | Represents property Stream. (Inherited from TfrxCustomCrypter.)
Top
Methods
Show:
Name | Description
AskKey(AnsiString) | Represents method AskKey(AnsiString).
CreateStream | Represents method CreateStream. (Inherited from TfrxCustomCrypter.)
Crypt(TStream,AnsiString) | Represents method Crypt(TStream,AnsiString). (Overrides TfrxCustomCrypter.Crypt(TStream,AnsiString).)
Decrypt(TStream,AnsiString) | Represents method Decrypt(TStream,AnsiString). (Overrides TfrxCustomCrypter.Decrypt(TStream,AnsiString).)
Top
See Also

Reference

  • frxCrypt


TfrxCrypt Methods

Methods
Name | Description
AskKey(AnsiString) | Represents method AskKey(AnsiString).
Crypt(TStream,AnsiString) | Represents method Crypt(TStream,AnsiString). (Overrides TfrxCustomCrypter.Crypt(TStream,AnsiString).)
Decrypt(TStream,AnsiString) | Represents method Decrypt(TStream,AnsiString). (Overrides TfrxCustomCrypter.Decrypt(TStream,AnsiString).)
Top


TfrxCrypt.AskKey(AnsiString) Method

Summary

Represents method AskKey(AnsiString).

Namespace: frxCrypt
Syntax
Delphi
private
 function AskKey(const Key: AnsiString): AnsiString;

Parameters

Key
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • TfrxCrypt
  • frxCrypt


TfrxCrypt.Crypt(TStream,AnsiString) Method

Summary

Represents method Crypt(TStream,AnsiString).

Namespace: frxCrypt
Syntax
Delphi
public
 procedure Crypt(Dest: TStream; const Key: AnsiString); override;

Parameters

Dest
Type: TStream

Key
Type: AnsiString

Overrides

TfrxCustomCrypter.Crypt(TStream,AnsiString)
See Also

Reference

  • TfrxCrypt
  • frxCrypt


TfrxCrypt.Decrypt(TStream,AnsiString) Method

Summary

Represents method Decrypt(TStream,AnsiString).

Namespace: frxCrypt
Syntax
Delphi
public
 function Decrypt(Source: TStream; const Key: AnsiString): Boolean; override;

Parameters

Source
Type: TStream

Key
Type: AnsiString

Return Value

Type: Boolean

Overrides

TfrxCustomCrypter.Decrypt(TStream,AnsiString)
See Also

Reference

  • TfrxCrypt
  • frxCrypt


frxCrypt Routines

Routines
Name | Description
frxCryptStream(TStream,TStream,AnsiString) | Represents method frxCryptStream(TStream,TStream,AnsiString).
frxDecryptStream(TStream,TStream,AnsiString) | Represents method frxDecryptStream(TStream,TStream,AnsiString).
Top


frxCryptStream(TStream,TStream,AnsiString) Method

Summary

Represents method frxCryptStream(TStream,TStream,AnsiString).

Namespace: frxCrypt
Syntax
Delphi
procedure frxCryptStream(Source, Dest: TStream; const Key: AnsiString);

Parameters

Source
Type: TStream

Dest
Type: TStream

Key
Type: AnsiString

See Also

Reference

  • frxCrypt


frxDecryptStream(TStream,TStream,AnsiString) Method

Summary

Represents method frxDecryptStream(TStream,TStream,AnsiString).

Namespace: frxCrypt
Syntax
Delphi
procedure frxDecryptStream(Source, Dest: TStream; const Key: AnsiString);

Parameters

Source
Type: TStream

Dest
Type: TStream

Key
Type: AnsiString

See Also

Reference

  • frxCrypt


frxCtrls Namespace

Summary

Represents namespace frxCtrls.

Classes
Name | Description
TfrxComboBox | Represents type TfrxComboBox.
TfrxComboEdit | Represents type TfrxComboEdit.
TfrxCustomComboBox | Represents type TfrxCustomComboBox.
TfrxCustomFilterEdit | Represents type TfrxCustomFilterEdit.
TfrxFilterEdit | Represents type TfrxFilterEdit.
TfrxFontComboBox | Represents type TfrxFontComboBox.
TfrxFontPreview | Represents type TfrxFontPreview.
TfrxScrollWin | Represents type TfrxScrollWin.
Top
Delegates
Name | Description
TfrxScrollMaxChangeEvent | Represents type TfrxScrollMaxChangeEvent.
TfrxScrollPosChangeEvent | Represents type TfrxScrollPosChangeEvent.
Top
Routines
Name | Description
frxBlend(TColor,TColor,Integer) | Represents method frxBlend(TColor,TColor,Integer).
Top


frxCtrls Classes

Classes
Name | Description
TfrxComboBox | Represents type TfrxComboBox.
TfrxComboEdit | Represents type TfrxComboEdit.
TfrxCustomComboBox | Represents type TfrxCustomComboBox.
TfrxCustomFilterEdit | Represents type TfrxCustomFilterEdit.
TfrxFilterEdit | Represents type TfrxFilterEdit.
TfrxFontComboBox | Represents type TfrxFontComboBox.
TfrxFontPreview | Represents type TfrxFontPreview.
TfrxScrollWin | Represents type TfrxScrollWin.
Top


TfrxComboBox Class

Summary

Represents type TfrxComboBox.

Namespace: frxCtrls
Inheritance Hierarchy
TCustomComboBox
frxCtrls.TfrxCustomComboBox
frxCtrls.TfrxComboBox
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxComboBox = class(TfrxCustomComboBox)
 end;

The TfrxComboBox type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomComboBox class. (Inherited from TfrxCustomComboBox.)
Top
Properties
Show:
Name | Description
Anchors | Represents property Anchors.
BiDiMode | Represents property BiDiMode.
Color | Represents property Color.
Constraints | Represents property Constraints.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
DropDownCount | Represents property DropDownCount.
Enabled | Represents property Enabled.
Font | Represents property Font.
ItemHeight | Represents property ItemHeight.
ItemIndex | Represents property ItemIndex.
Items | Represents property Items.
ListWidth | Represents property ListWidth.
MaxLength | Represents property MaxLength.
OnChange | Represents property OnChange.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnDrawItem | Represents property OnDrawItem.
OnDropDown | Represents property OnDropDown.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentColor | Represents property ParentColor.
ParentFont | Represents property ParentFont.
ParentShowHint | Represents property ParentShowHint.
PopupMenu | Represents property PopupMenu.
ReadOnly | Represents property ReadOnly.
ShowHint | Represents property ShowHint.
SolidBorder | Represents property SolidBorder. (Inherited from TfrxCustomComboBox.)
Sorted | Represents property Sorted.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Text | Represents property Text.
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
ComboWndProc(TMessage,HWnd,Pointer) | Represents method ComboWndProc(TMessage,HWnd,Pointer). (Inherited from TfrxCustomComboBox.)
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams). (Inherited from TfrxCustomComboBox.)
CreateWnd | Represents method CreateWnd. (Inherited from TfrxCustomComboBox.)
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Inherited from TfrxCustomComboBox.)
DrawImage(HDC,Integer,TRect) | Represents method DrawImage(HDC,Integer,TRect). (Inherited from TfrxCustomComboBox.)
GetScale | Represents method GetScale. (Inherited from TfrxCustomComboBox.)
KeyPress(Char) | Represents method KeyPress(Char). (Inherited from TfrxCustomComboBox.)
Resize | Represents method Resize. (Inherited from TfrxCustomComboBox.)
WndProc(TMessage) | Represents method WndProc(TMessage). (Inherited from TfrxCustomComboBox.)
Top
See Also

Reference

  • frxCtrls


TfrxComboBox Properties

Properties
Name | Description
Anchors | Represents property Anchors.
BiDiMode | Represents property BiDiMode.
Color | Represents property Color.
Constraints | Represents property Constraints.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
DropDownCount | Represents property DropDownCount.
Enabled | Represents property Enabled.
Font | Represents property Font.
ItemHeight | Represents property ItemHeight.
ItemIndex | Represents property ItemIndex.
Items | Represents property Items.
ListWidth | Represents property ListWidth.
MaxLength | Represents property MaxLength.
OnChange | Represents property OnChange.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnDrawItem | Represents property OnDrawItem.
OnDropDown | Represents property OnDropDown.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentColor | Represents property ParentColor.
ParentFont | Represents property ParentFont.
ParentShowHint | Represents property ParentShowHint.
PopupMenu | Represents property PopupMenu.
ReadOnly | Represents property ReadOnly.
ShowHint | Represents property ShowHint.
Sorted | Represents property Sorted.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Text | Represents property Text.
Visible | Represents property Visible.
Top


TfrxComboBox.Anchors Property

Summary

Represents property Anchors.

Namespace: frxCtrls
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.BiDiMode Property

Summary

Represents property BiDiMode.

Namespace: frxCtrls
Syntax
Delphi
published
 property BiDiMode;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.Color Property

Summary

Represents property Color.

Namespace: frxCtrls
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.Constraints Property

Summary

Represents property Constraints.

Namespace: frxCtrls
Syntax
Delphi
published
 property Constraints;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.DragCursor Property

Summary

Represents property DragCursor.

Namespace: frxCtrls
Syntax
Delphi
published
 property DragCursor;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.DragKind Property

Summary

Represents property DragKind.

Namespace: frxCtrls
Syntax
Delphi
published
 property DragKind;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.DragMode Property

Summary

Represents property DragMode.

Namespace: frxCtrls
Syntax
Delphi
published
 property DragMode;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.DropDownCount Property

Summary

Represents property DropDownCount.

Namespace: frxCtrls
Syntax
Delphi
published
 property DropDownCount;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.Enabled Property

Summary

Represents property Enabled.

Namespace: frxCtrls
Syntax
Delphi
published
 property Enabled;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.Font Property

Summary

Represents property Font.

Namespace: frxCtrls
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.ItemHeight Property

Summary

Represents property ItemHeight.

Namespace: frxCtrls
Syntax
Delphi
published
 property ItemHeight;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.ItemIndex Property

Summary

Represents property ItemIndex.

Namespace: frxCtrls
Syntax
Delphi
published
 property ItemIndex;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.Items Property

Summary

Represents property Items.

Namespace: frxCtrls
Syntax
Delphi
published
 property Items;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.ListWidth Property

Summary

Represents property ListWidth.

Namespace: frxCtrls
Syntax
Delphi
published
 property ListWidth;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.MaxLength Property

Summary

Represents property MaxLength.

Namespace: frxCtrls
Syntax
Delphi
published
 property MaxLength;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnChange Property

Summary

Represents property OnChange.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnChange;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnClick Property

Summary

Represents property OnClick.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnDragDrop Property

Summary

Represents property OnDragDrop.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDragDrop;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnDragOver Property

Summary

Represents property OnDragOver.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDragOver;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnDrawItem Property

Summary

Represents property OnDrawItem.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDrawItem;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnDropDown Property

Summary

Represents property OnDropDown.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDropDown;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnEndDock Property

Summary

Represents property OnEndDock.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnEndDock;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnEndDrag Property

Summary

Represents property OnEndDrag.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnEndDrag;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnExit Property

Summary

Represents property OnExit.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnStartDock Property

Summary

Represents property OnStartDock.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnStartDock;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.OnStartDrag Property

Summary

Represents property OnStartDrag.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnStartDrag;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.ParentBiDiMode Property

Summary

Represents property ParentBiDiMode.

Namespace: frxCtrls
Syntax
Delphi
published
 property ParentBiDiMode;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.ParentColor Property

Summary

Represents property ParentColor.

Namespace: frxCtrls
Syntax
Delphi
published
 property ParentColor;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.ParentFont Property

Summary

Represents property ParentFont.

Namespace: frxCtrls
Syntax
Delphi
published
 property ParentFont;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.ParentShowHint Property

Summary

Represents property ParentShowHint.

Namespace: frxCtrls
Syntax
Delphi
published
 property ParentShowHint;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: frxCtrls
Syntax
Delphi
published
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: frxCtrls
Syntax
Delphi
published
 property ReadOnly;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.ShowHint Property

Summary

Represents property ShowHint.

Namespace: frxCtrls
Syntax
Delphi
published
 property ShowHint;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.Sorted Property

Summary

Represents property Sorted.

Namespace: frxCtrls
Syntax
Delphi
published
 property Sorted;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.TabOrder Property

Summary

Represents property TabOrder.

Namespace: frxCtrls
Syntax
Delphi
published
 property TabOrder;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.TabStop Property

Summary

Represents property TabStop.

Namespace: frxCtrls
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.Text Property

Summary

Represents property Text.

Namespace: frxCtrls
Syntax
Delphi
published
 property Text;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboBox.Visible Property

Summary

Represents property Visible.

Namespace: frxCtrls
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBox
  • frxCtrls


TfrxComboEdit Class

Summary

Represents type TfrxComboEdit.

Namespace: frxCtrls
Inheritance Hierarchy
TComboBox
frxCtrls.TfrxComboEdit
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxComboEdit = class(TComboBox)
 end;

The TfrxComboEdit type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxComboEdit class.
Top
Properties
Show:
Name | Description
ButtonEnabled | Represents property ButtonEnabled.
ButtonHint | Represents property ButtonHint.
Glyph | Represents property Glyph.
OnButtonClick | Represents property OnButtonClick.
Top
Methods
Show:
Name | Description
ButtonClick(TObject) | Represents method ButtonClick(TObject).
CMEnabledChanged(TMessage) | Represents method CMEnabledChanged(TMessage).
CreateWnd | Represents method CreateWnd.
GetButtonHint | Represents method GetButtonHint.
GetGlyph | Represents method GetGlyph.
KeyPress(Char) | Represents method KeyPress(Char).
SetButtonEnabled(Boolean) | Represents method SetButtonEnabled(Boolean).
SetButtonHint(String) | Represents method SetButtonHint(String).
SetGlyph(TBitmap) | Represents method SetGlyph(TBitmap).
SetPos | Represents method SetPos.
WMSize(TWMSize) | Represents method WMSize(TWMSize).
Top
Fields
Show:
Name | Description
FButton | Represents field FButton.
FButtonEnabled | Represents field FButtonEnabled.
FOnButtonClick | Represents field FOnButtonClick.
FPanel | Represents field FPanel.
Top
See Also

Reference

  • frxCtrls


TfrxComboEdit Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxComboEdit class.
Top


TfrxComboEdit.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxComboEdit class.

Namespace: frxCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit Properties

Properties
Name | Description
ButtonEnabled | Represents property ButtonEnabled.
ButtonHint | Represents property ButtonHint.
Glyph | Represents property Glyph.
OnButtonClick | Represents property OnButtonClick.
Top


TfrxComboEdit.ButtonEnabled Property

Summary

Represents property ButtonEnabled.

Namespace: frxCtrls
Syntax
Delphi
published
 property ButtonEnabled: Boolean read FButtonEnabled write SetButtonEnabled default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.ButtonHint Property

Summary

Represents property ButtonHint.

Namespace: frxCtrls
Syntax
Delphi
published
 property ButtonHint: String read GetButtonHint write SetButtonHint;

Property Value

Type: String

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.Glyph Property

Summary

Represents property Glyph.

Namespace: frxCtrls
Syntax
Delphi
published
 property Glyph: TBitmap read GetGlyph write SetGlyph;

Property Value

Type: TBitmap

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.OnButtonClick Property

Summary

Represents property OnButtonClick.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnButtonClick: TNotifyEvent read FOnButtonClick write FOnButtonClick;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit Methods

Methods
Name | Description
ButtonClick(TObject) | Represents method ButtonClick(TObject).
CMEnabledChanged(TMessage) | Represents method CMEnabledChanged(TMessage).
CreateWnd | Represents method CreateWnd.
GetButtonHint | Represents method GetButtonHint.
GetGlyph | Represents method GetGlyph.
KeyPress(Char) | Represents method KeyPress(Char).
SetButtonEnabled(Boolean) | Represents method SetButtonEnabled(Boolean).
SetButtonHint(String) | Represents method SetButtonHint(String).
SetGlyph(TBitmap) | Represents method SetGlyph(TBitmap).
SetPos | Represents method SetPos.
WMSize(TWMSize) | Represents method WMSize(TWMSize).
Top


TfrxComboEdit.ButtonClick(TObject) Method

Summary

Represents method ButtonClick(TObject).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure ButtonClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.CMEnabledChanged(TMessage) Method

Summary

Represents method CMEnabledChanged(TMessage).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure CMEnabledChanged(var Message: TMessage); message CM_ENABLEDCHANGED;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.CreateWnd Method

Summary

Represents method CreateWnd.

Namespace: frxCtrls
Syntax
Delphi
public
 procedure CreateWnd; override;
See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.GetButtonHint Method

Summary

Represents method GetButtonHint.

Namespace: frxCtrls
Syntax
Delphi
private
 function GetButtonHint: String;

Return Value

Type: String

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.GetGlyph Method

Summary

Represents method GetGlyph.

Namespace: frxCtrls
Syntax
Delphi
private
 function GetGlyph: TBitmap;

Return Value

Type: TBitmap

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.KeyPress(Char) Method

Summary

Represents method KeyPress(Char).

Namespace: frxCtrls
Syntax
Delphi
public
 procedure KeyPress(var Key: Char); override;

Parameters

Key
Type: Char

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.SetButtonEnabled(Boolean) Method

Summary

Represents method SetButtonEnabled(Boolean).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetButtonEnabled(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.SetButtonHint(String) Method

Summary

Represents method SetButtonHint(String).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetButtonHint(Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.SetGlyph(TBitmap) Method

Summary

Represents method SetGlyph(TBitmap).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetGlyph(Value: TBitmap);

Parameters

Value
Type: TBitmap

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.SetPos Method

Summary

Represents method SetPos.

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetPos;
See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.WMSize(TWMSize) Method

Summary

Represents method WMSize(TWMSize).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure WMSize(var Message: TWMSize); message WM_SIZE;

Parameters

Message
Type: TWMSize

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit Fields

Fields
Name | Description
FButton | Represents field FButton.
FButtonEnabled | Represents field FButtonEnabled.
FOnButtonClick | Represents field FOnButtonClick.
FPanel | Represents field FPanel.
Top


TfrxComboEdit.FButton Field

Summary

Represents field FButton.

Namespace: frxCtrls
Syntax
Delphi
private
 FButton: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.FButtonEnabled Field

Summary

Represents field FButtonEnabled.

Namespace: frxCtrls
Syntax
Delphi
private
 FButtonEnabled: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.FOnButtonClick Field

Summary

Represents field FOnButtonClick.

Namespace: frxCtrls
Syntax
Delphi
private
 FOnButtonClick: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxComboEdit.FPanel Field

Summary

Represents field FPanel.

Namespace: frxCtrls
Syntax
Delphi
private
 FPanel: TWinControl;

Field Value

Type: TWinControl

See Also

Reference

  • TfrxComboEdit
  • frxCtrls


TfrxCustomComboBox Class

Summary

Represents type TfrxCustomComboBox.

Namespace: frxCtrls
Inheritance Hierarchy
TCustomComboBox
frxCtrls.TfrxCustomComboBox
frxCtrls.TfrxComboBox
frxCtrls.TfrxFontComboBox
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxCustomComboBox = class(TCustomComboBox)
 end;

The TfrxCustomComboBox type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomComboBox class.
Destroy | Represents the destructor of the TfrxCustomComboBox class.
Top
Properties
Show:
Name | Description
ListWidth | Represents property ListWidth.
ReadOnly | Represents property ReadOnly.
SolidBorder | Represents property SolidBorder.
Top
Methods
Show:
Name | Description
CMEnabledChanged(TMessage) | Represents method CMEnabledChanged(TMessage).
CMFontChanged(TMessage) | Represents method CMFontChanged(TMessage).
CMMouseEnter(TMessage) | Represents method CMMouseEnter(TMessage).
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage).
CNCommand(TWMCommand) | Represents method CNCommand(TWMCommand).
ComboWndProc(TMessage,HWnd,Pointer) | Represents method ComboWndProc(TMessage,HWnd,Pointer).
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams).
CreateWnd | Represents method CreateWnd.
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer).
DrawImage(HDC,Integer,TRect) | Represents method DrawImage(HDC,Integer,TRect).
GetListHeight | Represents method GetListHeight.
GetScale | Represents method GetScale.
GetSolidBorder | Represents method GetSolidBorder.
KeyPress(Char) | Represents method KeyPress(Char).
ListWndProc(TMessage) | Represents method ListWndProc(TMessage).
PaintBorder(HDC,Boolean) | Represents method PaintBorder(HDC,Boolean).
PaintButton(Integer) | Represents method PaintButton(Integer).
PaintDisabled | Represents method PaintDisabled.
Resize | Represents method Resize.
SetListWidth(Integer) | Represents method SetListWidth(Integer).
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean).
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage).
WMPaint(TWMPaint) | Represents method WMPaint(TWMPaint).
WndProc(TMessage) | Represents method WndProc(TMessage).
Top
Fields
Show:
Name | Description
FButtonWidth | Represents field FButtonWidth.
FChildHandle | Represents field FChildHandle.
FCurrentPPI | Represents field FCurrentPPI.
FDefListProc | Represents field FDefListProc.
FEditOffset | Represents field FEditOffset.
FListHandle | Represents field FListHandle.
FListInstance | Represents field FListInstance.
FListWidth | Represents field FListWidth.
FReadOnly | Represents field FReadOnly.
FSolidBorder | Represents field FSolidBorder.
FUpDropdown | Represents field FUpDropdown.
msMouseInControl | Represents field msMouseInControl.
Top
See Also

Reference

  • frxCtrls


TfrxCustomComboBox Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomComboBox class.
Destroy | Represents the destructor of the TfrxCustomComboBox class.
Top


TfrxCustomComboBox.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomComboBox class.

Namespace: frxCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomComboBox class.

Namespace: frxCtrls
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox Properties

Properties
Name | Description
ListWidth | Represents property ListWidth.
ReadOnly | Represents property ReadOnly.
SolidBorder | Represents property SolidBorder.
Top


TfrxCustomComboBox.ListWidth Property

Summary

Represents property ListWidth.

Namespace: frxCtrls
Syntax
Delphi
protected
 property ListWidth: Integer read FListWidth write SetListWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: frxCtrls
Syntax
Delphi
protected
 property ReadOnly: Boolean read FReadOnly write SetReadOnly default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.SolidBorder Property

Summary

Represents property SolidBorder.

Namespace: frxCtrls
Syntax
Delphi
protected
 property SolidBorder: Boolean read FSolidBorder;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox Methods

Methods
Name | Description
CMEnabledChanged(TMessage) | Represents method CMEnabledChanged(TMessage).
CMFontChanged(TMessage) | Represents method CMFontChanged(TMessage).
CMMouseEnter(TMessage) | Represents method CMMouseEnter(TMessage).
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage).
CNCommand(TWMCommand) | Represents method CNCommand(TWMCommand).
ComboWndProc(TMessage,HWnd,Pointer) | Represents method ComboWndProc(TMessage,HWnd,Pointer).
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams).
CreateWnd | Represents method CreateWnd.
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer).
DrawImage(HDC,Integer,TRect) | Represents method DrawImage(HDC,Integer,TRect).
GetListHeight | Represents method GetListHeight.
GetScale | Represents method GetScale.
GetSolidBorder | Represents method GetSolidBorder.
KeyPress(Char) | Represents method KeyPress(Char).
ListWndProc(TMessage) | Represents method ListWndProc(TMessage).
PaintBorder(HDC,Boolean) | Represents method PaintBorder(HDC,Boolean).
PaintButton(Integer) | Represents method PaintButton(Integer).
PaintDisabled | Represents method PaintDisabled.
Resize | Represents method Resize.
SetListWidth(Integer) | Represents method SetListWidth(Integer).
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean).
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage).
WMPaint(TWMPaint) | Represents method WMPaint(TWMPaint).
WndProc(TMessage) | Represents method WndProc(TMessage).
Top


TfrxCustomComboBox.CMEnabledChanged(TMessage) Method

Summary

Represents method CMEnabledChanged(TMessage).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure CMEnabledChanged(var Msg: TMessage); message CM_ENABLEDCHANGED;

Parameters

Msg
Type: TMessage

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.CMFontChanged(TMessage) Method

Summary

Represents method CMFontChanged(TMessage).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure CMFontChanged(var Message: TMessage); message CM_FONTCHANGED;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.CMMouseEnter(TMessage) Method

Summary

Represents method CMMouseEnter(TMessage).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure CMMouseEnter(var Message: TMessage); message CM_MOUSEENTER;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.CMMouseLeave(TMessage) Method

Summary

Represents method CMMouseLeave(TMessage).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure CMMouseLeave(var Message: TMessage); message CM_MOUSELEAVE;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.CNCommand(TWMCommand) Method

Summary

Represents method CNCommand(TWMCommand).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure CNCommand(var Message: TWMCommand); message CN_COMMAND;

Parameters

Message
Type: TWMCommand

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.ComboWndProc(TMessage,HWnd,Pointer) Method

Summary

Represents method ComboWndProc(TMessage,HWnd,Pointer).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure ComboWndProc(var Message: TMessage; ComboWnd: HWnd; ComboProc: Pointer); override;

Parameters

Message
Type: TMessage

ComboWnd
Type: HWnd

ComboProc
Type: Pointer

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.CreateParams(TCreateParams) Method

Summary

Represents method CreateParams(TCreateParams).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure CreateParams(var Params: TCreateParams); override;

Parameters

Params
Type: TCreateParams

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.CreateWnd Method

Summary

Represents method CreateWnd.

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure CreateWnd; override;
See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.DoPPIChanged(Integer) Method

Summary

Represents method DoPPIChanged(Integer).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure DoPPIChanged(aNewPPI: Integer); virtual;

Parameters

aNewPPI
Type: Integer

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.DrawImage(HDC,Integer,TRect) Method

Summary

Represents method DrawImage(HDC,Integer,TRect).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure DrawImage(DC: HDC; Index: Integer; R: TRect); dynamic;

Parameters

DC
Type: HDC

Index
Type: Integer

R
Type: TRect

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.GetListHeight Method

Summary

Represents method GetListHeight.

Namespace: frxCtrls
Syntax
Delphi
private
 function GetListHeight: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.GetScale Method

Summary

Represents method GetScale.

Namespace: frxCtrls
Syntax
Delphi
protected
 function GetScale: Single;

Return Value

Type: Single

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.GetSolidBorder Method

Summary

Represents method GetSolidBorder.

Namespace: frxCtrls
Syntax
Delphi
private
 function GetSolidBorder: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.KeyPress(Char) Method

Summary

Represents method KeyPress(Char).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure KeyPress(var Key: Char); override;

Parameters

Key
Type: Char

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.ListWndProc(TMessage) Method

Summary

Represents method ListWndProc(TMessage).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure ListWndProc(var Message: TMessage);

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.PaintBorder(HDC,Boolean) Method

Summary

Represents method PaintBorder(HDC,Boolean).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure PaintBorder(DC: HDC; const SolidBorder: Boolean);

Parameters

DC
Type: HDC

SolidBorder
Type: Boolean

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.PaintButton(Integer) Method

Summary

Represents method PaintButton(Integer).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure PaintButton(ButtonStyle: Integer);

Parameters

ButtonStyle
Type: Integer

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.PaintDisabled Method

Summary

Represents method PaintDisabled.

Namespace: frxCtrls
Syntax
Delphi
private
 procedure PaintDisabled;
See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.Resize Method

Summary

Represents method Resize.

Namespace: frxCtrls
Syntax
Delphi
public
 procedure Resize; override;
See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.SetListWidth(Integer) Method

Summary

Represents method SetListWidth(Integer).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetListWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.SetReadOnly(Boolean) Method

Summary

Represents method SetReadOnly(Boolean).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetReadOnly(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.WMDpiChanged(TMessage) Method

Summary

Represents method WMDpiChanged(TMessage).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure WMDpiChanged(var Message: TMessage); message FRX_WM_DPICHANGED_AFTERPARENT;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.WMPaint(TWMPaint) Method

Summary

Represents method WMPaint(TWMPaint).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure WMPaint(var Message: TWMPaint); message WM_PAINT;

Parameters

Message
Type: TWMPaint

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.WndProc(TMessage) Method

Summary

Represents method WndProc(TMessage).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure WndProc(var Message: TMessage); override;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox Fields

Fields
Name | Description
FButtonWidth | Represents field FButtonWidth.
FChildHandle | Represents field FChildHandle.
FCurrentPPI | Represents field FCurrentPPI.
FDefListProc | Represents field FDefListProc.
FEditOffset | Represents field FEditOffset.
FListHandle | Represents field FListHandle.
FListInstance | Represents field FListInstance.
FListWidth | Represents field FListWidth.
FReadOnly | Represents field FReadOnly.
FSolidBorder | Represents field FSolidBorder.
FUpDropdown | Represents field FUpDropdown.
msMouseInControl | Represents field msMouseInControl.
Top


TfrxCustomComboBox.FButtonWidth Field

Summary

Represents field FButtonWidth.

Namespace: frxCtrls
Syntax
Delphi
private
 FButtonWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.FChildHandle Field

Summary

Represents field FChildHandle.

Namespace: frxCtrls
Syntax
Delphi
private
 FChildHandle: HWND;

Field Value

Type: HWND

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.FCurrentPPI Field

Summary

Represents field FCurrentPPI.

Namespace: frxCtrls
Syntax
Delphi
private
 FCurrentPPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.FDefListProc Field

Summary

Represents field FDefListProc.

Namespace: frxCtrls
Syntax
Delphi
private
 FDefListProc: Pointer;

Field Value

Type: Pointer

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.FEditOffset Field

Summary

Represents field FEditOffset.

Namespace: frxCtrls
Syntax
Delphi
private
 FEditOffset: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.FListHandle Field

Summary

Represents field FListHandle.

Namespace: frxCtrls
Syntax
Delphi
private
 FListHandle: HWND;

Field Value

Type: HWND

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.FListInstance Field

Summary

Represents field FListInstance.

Namespace: frxCtrls
Syntax
Delphi
private
 FListInstance: Pointer;

Field Value

Type: Pointer

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.FListWidth Field

Summary

Represents field FListWidth.

Namespace: frxCtrls
Syntax
Delphi
private
 FListWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.FReadOnly Field

Summary

Represents field FReadOnly.

Namespace: frxCtrls
Syntax
Delphi
private
 FReadOnly: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.FSolidBorder Field

Summary

Represents field FSolidBorder.

Namespace: frxCtrls
Syntax
Delphi
private
 FSolidBorder: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.FUpDropdown Field

Summary

Represents field FUpDropdown.

Namespace: frxCtrls
Syntax
Delphi
private
 FUpDropdown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomComboBox.msMouseInControl Field

Summary

Represents field msMouseInControl.

Namespace: frxCtrls
Syntax
Delphi
private
 msMouseInControl: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomComboBox
  • frxCtrls


TfrxCustomFilterEdit Class

Summary

Represents type TfrxCustomFilterEdit.

Namespace: frxCtrls
Inheritance Hierarchy
TCustomPanel
frxDPIAwareBaseControls.TfrxDPIAwareBasePanel
frxCtrls.TfrxCustomFilterEdit
frxCtrls.TfrxFilterEdit
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxCustomFilterEdit = class(TfrxDPIAwareBasePanel)
 end;

The TfrxCustomFilterEdit type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomFilterEdit class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Destroy | Represents the destructor of the TfrxCustomFilterEdit class.
Top
Properties
Show:
Name | Description
BitmapActive | Represents property BitmapActive.
BitmapUnactive | Represents property BitmapUnactive.
CurrentPPI | Represents property CurrentPPI. (Inherited from TfrxDPIAwareBasePanel.)
EditControl | Represents property EditControl.
FilterColor | Represents property FilterColor.
OnFilterChanged | Represents property OnFilterChanged.
Top
Methods
Show:
Name | Description
CMMouseEnter(TMessage) | Represents method CMMouseEnter(TMessage).
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage).
DoFocus(TObject) | Represents method DoFocus(TObject).
DoLostFocus(TObject) | Represents method DoLostFocus(TObject).
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Inherited from TfrxDPIAwareBasePanel.)
DoTextChange(TObject) | Represents method DoTextChange(TObject).
GetReleativeScale | Represents method GetReleativeScale. (Inherited from TfrxDPIAwareBasePanel.)
GetScale | Represents method GetScale. (Inherited from TfrxDPIAwareBasePanel.)
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
PaintBorder | Represents method PaintBorder.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxDPIAwareBasePanel.)
SetFilterColor(TColor) | Represents method SetFilterColor(TColor).
UpdateSize | Represents method UpdateSize.
WMNCPaint(TWMNCPaint) | Represents method WMNCPaint(TWMNCPaint).
WMSize(TWMSize) | Represents method WMSize(TWMSize).
Top
Fields
Show:
Name | Description
FBitmapActive | Represents field FBitmapActive.
FBitmapUnactive | Represents field FBitmapUnactive.
FClearBtnActive | Represents field FClearBtnActive.
FEdit | Represents field FEdit.
FFilterColor | Represents field FFilterColor.
FFrameIsActive | Represents field FFrameIsActive.
FOnFilterChanged | Represents field FOnFilterChanged.
Top
See Also

Reference

  • frxCtrls


TfrxCustomFilterEdit Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomFilterEdit class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Destroy | Represents the destructor of the TfrxCustomFilterEdit class.
Top


TfrxCustomFilterEdit.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomFilterEdit class.

Namespace: frxCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDPIAwareBasePanel.Create(TComponent)
See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomFilterEdit class.

Namespace: frxCtrls
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit Properties

Properties
Name | Description
BitmapActive | Represents property BitmapActive.
BitmapUnactive | Represents property BitmapUnactive.
EditControl | Represents property EditControl.
FilterColor | Represents property FilterColor.
OnFilterChanged | Represents property OnFilterChanged.
Top


TfrxCustomFilterEdit.BitmapActive Property

Summary

Represents property BitmapActive.

Namespace: frxCtrls
Syntax
Delphi
public
 property BitmapActive: TBitmap read FBitmapActive;

Property Value

Type: TBitmap

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.BitmapUnactive Property

Summary

Represents property BitmapUnactive.

Namespace: frxCtrls
Syntax
Delphi
public
 property BitmapUnactive: TBitmap read FBitmapUnactive;

Property Value

Type: TBitmap

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.EditControl Property

Summary

Represents property EditControl.

Namespace: frxCtrls
Syntax
Delphi
public
 property EditControl: TEdit read FEdit;

Property Value

Type: TEdit

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.FilterColor Property

Summary

Represents property FilterColor.

Namespace: frxCtrls
Syntax
Delphi
public
 property FilterColor: TColor read FFilterColor write SetFilterColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.OnFilterChanged Property

Summary

Represents property OnFilterChanged.

Namespace: frxCtrls
Syntax
Delphi
public
 property OnFilterChanged: TNotifyEvent read FOnFilterChanged write FOnFilterChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit Methods

Methods
Name | Description
CMMouseEnter(TMessage) | Represents method CMMouseEnter(TMessage).
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage).
DoFocus(TObject) | Represents method DoFocus(TObject).
DoLostFocus(TObject) | Represents method DoLostFocus(TObject).
DoTextChange(TObject) | Represents method DoTextChange(TObject).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
PaintBorder | Represents method PaintBorder.
SetFilterColor(TColor) | Represents method SetFilterColor(TColor).
UpdateSize | Represents method UpdateSize.
WMNCPaint(TWMNCPaint) | Represents method WMNCPaint(TWMNCPaint).
WMSize(TWMSize) | Represents method WMSize(TWMSize).
Top


TfrxCustomFilterEdit.CMMouseEnter(TMessage) Method

Summary

Represents method CMMouseEnter(TMessage).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure CMMouseEnter(var Message: TMessage); message CM_MOUSEENTER;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.CMMouseLeave(TMessage) Method

Summary

Represents method CMMouseLeave(TMessage).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure CMMouseLeave(var Message: TMessage); message CM_MOUSELEAVE;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.DoFocus(TObject) Method

Summary

Represents method DoFocus(TObject).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure DoFocus(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.DoLostFocus(TObject) Method

Summary

Represents method DoLostFocus(TObject).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure DoLostFocus(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.DoTextChange(TObject) Method

Summary

Represents method DoTextChange(TObject).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure DoTextChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.Paint Method

Summary

Represents method Paint.

Namespace: frxCtrls
Syntax
Delphi
public
 procedure Paint; override;
See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.PaintBorder Method

Summary

Represents method PaintBorder.

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure PaintBorder;
See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.SetFilterColor(TColor) Method

Summary

Represents method SetFilterColor(TColor).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetFilterColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.UpdateSize Method

Summary

Represents method UpdateSize.

Namespace: frxCtrls
Syntax
Delphi
private
 procedure UpdateSize;
See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.WMNCPaint(TWMNCPaint) Method

Summary

Represents method WMNCPaint(TWMNCPaint).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure WMNCPaint(var Message: TWMNCPaint); message WM_NCPAINT;

Parameters

Message
Type: TWMNCPaint

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.WMSize(TWMSize) Method

Summary

Represents method WMSize(TWMSize).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure WMSize(var Message: TWMSize); message WM_SIZE;

Parameters

Message
Type: TWMSize

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit Fields

Fields
Name | Description
FBitmapActive | Represents field FBitmapActive.
FBitmapUnactive | Represents field FBitmapUnactive.
FClearBtnActive | Represents field FClearBtnActive.
FEdit | Represents field FEdit.
FFilterColor | Represents field FFilterColor.
FFrameIsActive | Represents field FFrameIsActive.
FOnFilterChanged | Represents field FOnFilterChanged.
Top


TfrxCustomFilterEdit.FBitmapActive Field

Summary

Represents field FBitmapActive.

Namespace: frxCtrls
Syntax
Delphi
private
 FBitmapActive: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.FBitmapUnactive Field

Summary

Represents field FBitmapUnactive.

Namespace: frxCtrls
Syntax
Delphi
private
 FBitmapUnactive: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.FClearBtnActive Field

Summary

Represents field FClearBtnActive.

Namespace: frxCtrls
Syntax
Delphi
private
 FClearBtnActive: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.FEdit Field

Summary

Represents field FEdit.

Namespace: frxCtrls
Syntax
Delphi
private
 FEdit: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.FFilterColor Field

Summary

Represents field FFilterColor.

Namespace: frxCtrls
Syntax
Delphi
private
 FFilterColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.FFrameIsActive Field

Summary

Represents field FFrameIsActive.

Namespace: frxCtrls
Syntax
Delphi
private
 FFrameIsActive: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxCustomFilterEdit.FOnFilterChanged Field

Summary

Represents field FOnFilterChanged.

Namespace: frxCtrls
Syntax
Delphi
private
 FOnFilterChanged: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxCustomFilterEdit
  • frxCtrls


TfrxFilterEdit Class

Summary

Represents type TfrxFilterEdit.

Namespace: frxCtrls
Inheritance Hierarchy
TCustomPanel
frxDPIAwareBaseControls.TfrxDPIAwareBasePanel
frxCtrls.TfrxCustomFilterEdit
frxCtrls.TfrxFilterEdit
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxFilterEdit = class(TfrxCustomFilterEdit)
 end;

The TfrxFilterEdit type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomFilterEdit class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Top
Properties
Show:
Name | Description
Align | Represents property Align.
Alignment | Represents property Alignment.
Anchors | Represents property Anchors.
AutoSize | Represents property AutoSize.
BitmapActive | Represents property BitmapActive.
BitmapUnactive | Represents property BitmapUnactive.
Constraints | Represents property Constraints.
CurrentPPI | Represents property CurrentPPI. (Inherited from TfrxDPIAwareBasePanel.)
DockSite | Represents property DockSite.
DoubleBuffered | Represents property DoubleBuffered.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
EditControl | Represents property EditControl.
Enabled | Represents property Enabled.
FilterColor | Represents property FilterColor. (Inherited from TfrxCustomFilterEdit.)
FullRepaint | Represents property FullRepaint.
OnClick | Represents property OnClick.
OnConstrainedResize | Represents property OnConstrainedResize.
OnContextPopup | Represents property OnContextPopup.
OnDblClick | Represents property OnDblClick.
OnDockDrop | Represents property OnDockDrop.
OnDockOver | Represents property OnDockOver.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnFilterChanged | Represents property OnFilterChanged. (Inherited from TfrxCustomFilterEdit.)
OnGetSiteInfo | Represents property OnGetSiteInfo.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnResize | Represents property OnResize.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
OnUnDock | Represents property OnUnDock.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentShowHint | Represents property ParentShowHint.
PopupMenu | Represents property PopupMenu.
ShowHint | Represents property ShowHint.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
UseDockManager | Represents property UseDockManager.
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
CMMouseEnter(TMessage) | Represents method CMMouseEnter(TMessage). (Inherited from TfrxCustomFilterEdit.)
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage). (Inherited from TfrxCustomFilterEdit.)
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Inherited from TfrxDPIAwareBasePanel.)
GetReleativeScale | Represents method GetReleativeScale. (Inherited from TfrxDPIAwareBasePanel.)
GetScale | Represents method GetScale. (Inherited from TfrxDPIAwareBasePanel.)
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer). (Inherited from TfrxCustomFilterEdit.)
Paint | Represents method Paint. (Inherited from TfrxCustomFilterEdit.)
PaintBorder | Represents method PaintBorder. (Inherited from TfrxCustomFilterEdit.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxDPIAwareBasePanel.)
WMNCPaint(TWMNCPaint) | Represents method WMNCPaint(TWMNCPaint). (Inherited from TfrxCustomFilterEdit.)
WMSize(TWMSize) | Represents method WMSize(TWMSize). (Inherited from TfrxCustomFilterEdit.)
Top
See Also

Reference

  • frxCtrls


TfrxFilterEdit Properties

Properties
Name | Description
Align | Represents property Align.
Alignment | Represents property Alignment.
Anchors | Represents property Anchors.
AutoSize | Represents property AutoSize.
BitmapActive | Represents property BitmapActive.
BitmapUnactive | Represents property BitmapUnactive.
Constraints | Represents property Constraints.
DockSite | Represents property DockSite.
DoubleBuffered | Represents property DoubleBuffered.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
EditControl | Represents property EditControl.
Enabled | Represents property Enabled.
FullRepaint | Represents property FullRepaint.
OnClick | Represents property OnClick.
OnConstrainedResize | Represents property OnConstrainedResize.
OnContextPopup | Represents property OnContextPopup.
OnDblClick | Represents property OnDblClick.
OnDockDrop | Represents property OnDockDrop.
OnDockOver | Represents property OnDockOver.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnGetSiteInfo | Represents property OnGetSiteInfo.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnResize | Represents property OnResize.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
OnUnDock | Represents property OnUnDock.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentShowHint | Represents property ParentShowHint.
PopupMenu | Represents property PopupMenu.
ShowHint | Represents property ShowHint.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
UseDockManager | Represents property UseDockManager.
Visible | Represents property Visible.
Top


TfrxFilterEdit.Align Property

Summary

Represents property Align.

Namespace: frxCtrls
Syntax
Delphi
published
 property Align;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.Alignment Property

Summary

Represents property Alignment.

Namespace: frxCtrls
Syntax
Delphi
published
 property Alignment;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.Anchors Property

Summary

Represents property Anchors.

Namespace: frxCtrls
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.AutoSize Property

Summary

Represents property AutoSize.

Namespace: frxCtrls
Syntax
Delphi
published
 property AutoSize;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.BitmapActive Property

Summary

Represents property BitmapActive.

Namespace: frxCtrls
Syntax
Delphi
published
 property BitmapActive;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.BitmapUnactive Property

Summary

Represents property BitmapUnactive.

Namespace: frxCtrls
Syntax
Delphi
published
 property BitmapUnactive;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.Constraints Property

Summary

Represents property Constraints.

Namespace: frxCtrls
Syntax
Delphi
published
 property Constraints;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.DockSite Property

Summary

Represents property DockSite.

Namespace: frxCtrls
Syntax
Delphi
published
 property DockSite;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.DoubleBuffered Property

Summary

Represents property DoubleBuffered.

Namespace: frxCtrls
Syntax
Delphi
published
 property DoubleBuffered;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.DragCursor Property

Summary

Represents property DragCursor.

Namespace: frxCtrls
Syntax
Delphi
published
 property DragCursor;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.DragKind Property

Summary

Represents property DragKind.

Namespace: frxCtrls
Syntax
Delphi
published
 property DragKind;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.DragMode Property

Summary

Represents property DragMode.

Namespace: frxCtrls
Syntax
Delphi
published
 property DragMode;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.EditControl Property

Summary

Represents property EditControl.

Namespace: frxCtrls
Syntax
Delphi
published
 property EditControl;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.Enabled Property

Summary

Represents property Enabled.

Namespace: frxCtrls
Syntax
Delphi
published
 property Enabled;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.FullRepaint Property

Summary

Represents property FullRepaint.

Namespace: frxCtrls
Syntax
Delphi
published
 property FullRepaint;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnClick Property

Summary

Represents property OnClick.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnConstrainedResize Property

Summary

Represents property OnConstrainedResize.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnConstrainedResize;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnContextPopup Property

Summary

Represents property OnContextPopup.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnContextPopup;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnDockDrop Property

Summary

Represents property OnDockDrop.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDockDrop;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnDockOver Property

Summary

Represents property OnDockOver.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDockOver;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnDragDrop Property

Summary

Represents property OnDragDrop.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDragDrop;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnDragOver Property

Summary

Represents property OnDragOver.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDragOver;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnEndDock Property

Summary

Represents property OnEndDock.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnEndDock;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnEndDrag Property

Summary

Represents property OnEndDrag.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnEndDrag;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnExit Property

Summary

Represents property OnExit.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnGetSiteInfo Property

Summary

Represents property OnGetSiteInfo.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnGetSiteInfo;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnResize Property

Summary

Represents property OnResize.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnResize;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnStartDock Property

Summary

Represents property OnStartDock.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnStartDock;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnStartDrag Property

Summary

Represents property OnStartDrag.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnStartDrag;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.OnUnDock Property

Summary

Represents property OnUnDock.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnUnDock;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.ParentBiDiMode Property

Summary

Represents property ParentBiDiMode.

Namespace: frxCtrls
Syntax
Delphi
published
 property ParentBiDiMode;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.ParentShowHint Property

Summary

Represents property ParentShowHint.

Namespace: frxCtrls
Syntax
Delphi
published
 property ParentShowHint;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: frxCtrls
Syntax
Delphi
published
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.ShowHint Property

Summary

Represents property ShowHint.

Namespace: frxCtrls
Syntax
Delphi
published
 property ShowHint;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.TabOrder Property

Summary

Represents property TabOrder.

Namespace: frxCtrls
Syntax
Delphi
published
 property TabOrder;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.TabStop Property

Summary

Represents property TabStop.

Namespace: frxCtrls
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.UseDockManager Property

Summary

Represents property UseDockManager.

Namespace: frxCtrls
Syntax
Delphi
published
 property UseDockManager default True;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFilterEdit.Visible Property

Summary

Represents property Visible.

Namespace: frxCtrls
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TfrxFilterEdit
  • frxCtrls


TfrxFontComboBox Class

Summary

Represents type TfrxFontComboBox.

Namespace: frxCtrls
Inheritance Hierarchy
TCustomComboBox
frxCtrls.TfrxCustomComboBox
frxCtrls.TfrxFontComboBox
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxFontComboBox = class(TfrxCustomComboBox)
 end;

The TfrxFontComboBox type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxFontComboBox class. (Overrides TfrxCustomComboBox.Create(TComponent).)
Destroy | Represents the destructor of the TfrxFontComboBox class. (Overrides TfrxCustomComboBox.Destroy.)
Top
Properties
Show:
Name | Description
Anchors | Represents property Anchors.
BiDiMode | Represents property BiDiMode.
Color | Represents property Color.
Constraints | Represents property Constraints.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
DropDownCount | Represents property DropDownCount.
Enabled | Represents property Enabled.
Font | Represents property Font.
IniFile | Represents property IniFile.
ItemHeight | Represents property ItemHeight.
ListWidth | Represents property ListWidth. (Inherited from TfrxCustomComboBox.)
MRURegKey | Represents property MRURegKey.
OnChange | Represents property OnChange.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnDropDown | Represents property OnDropDown.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentColor | Represents property ParentColor.
ParentFont | Represents property ParentFont.
ParentShowHint | Represents property ParentShowHint.
PopupMenu | Represents property PopupMenu.
ReadOnly | Represents property ReadOnly. (Inherited from TfrxCustomComboBox.)
ShowHint | Represents property ShowHint.
ShowMRU | Represents property ShowMRU.
SolidBorder | Represents property SolidBorder. (Inherited from TfrxCustomComboBox.)
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Text | Represents property Text.
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
Click | Represents method Click.
CMFontChange(TMessage) | Represents method CMFontChange(TMessage).
CMFontChanged(TMessage) | Represents method CMFontChanged(TMessage).
CNCommand(TWMCommand) | Represents method CNCommand(TWMCommand).
ComboWndProc(TMessage,HWnd,Pointer) | Represents method ComboWndProc(TMessage,HWnd,Pointer). (Inherited from TfrxCustomComboBox.)
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams). (Inherited from TfrxCustomComboBox.)
CreateWnd | Represents method CreateWnd. (Inherited from TfrxCustomComboBox.)
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Overrides TfrxCustomComboBox.DoPPIChanged(Integer).)
DrawImage(HDC,Integer,TRect) | Represents method DrawImage(HDC,Integer,TRect). (Overrides TfrxCustomComboBox.DrawImage(HDC,Integer,TRect).)
DrawItem(Integer,TRect,TOwnerDrawState) | Represents method DrawItem(Integer,TRect,TOwnerDrawState).
GetScale | Represents method GetScale. (Inherited from TfrxCustomComboBox.)
Init | Represents method Init.
KeyPress(Char) | Represents method KeyPress(Char). (Inherited from TfrxCustomComboBox.)
Loaded | Represents method Loaded.
PopulateList | Represents method PopulateList.
Reset | Represents method Reset.
Resize | Represents method Resize. (Inherited from TfrxCustomComboBox.)
SetRegKey(String) | Represents method SetRegKey(String).
WndProc(TMessage) | Represents method WndProc(TMessage). (Inherited from TfrxCustomComboBox.)
Top
Fields
Show:
Name | Description
FDeviceBMP | Represents field FDeviceBMP.
FIni | Represents field FIni.
FOnClick | Represents field FOnClick.
FRegKey | Represents field FRegKey.
frFontViewForm | Represents field frFontViewForm.
FShowMRU | Represents field FShowMRU.
FTrueTypeBMP | Represents field FTrueTypeBMP.
FUpdate | Represents field FUpdate.
Numused | Represents field Numused.
Top
See Also

Reference

  • frxCtrls


TfrxFontComboBox Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxFontComboBox class. (Overrides TfrxCustomComboBox.Create(TComponent).)
Destroy | Represents the destructor of the TfrxFontComboBox class. (Overrides TfrxCustomComboBox.Destroy.)
Top


TfrxFontComboBox.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxFontComboBox class.

Namespace: frxCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomComboBox.Create(TComponent)
See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.Destroy Destructor

Summary

Represents the destructor of the TfrxFontComboBox class.

Namespace: frxCtrls
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxCustomComboBox.Destroy
See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox Properties

Properties
Name | Description
Anchors | Represents property Anchors.
BiDiMode | Represents property BiDiMode.
Color | Represents property Color.
Constraints | Represents property Constraints.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
DropDownCount | Represents property DropDownCount.
Enabled | Represents property Enabled.
Font | Represents property Font.
IniFile | Represents property IniFile.
ItemHeight | Represents property ItemHeight.
MRURegKey | Represents property MRURegKey.
OnChange | Represents property OnChange.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnDropDown | Represents property OnDropDown.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentColor | Represents property ParentColor.
ParentFont | Represents property ParentFont.
ParentShowHint | Represents property ParentShowHint.
PopupMenu | Represents property PopupMenu.
ShowHint | Represents property ShowHint.
ShowMRU | Represents property ShowMRU.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Text | Represents property Text.
Visible | Represents property Visible.
Top


TfrxFontComboBox.Anchors Property

Summary

Represents property Anchors.

Namespace: frxCtrls
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.BiDiMode Property

Summary

Represents property BiDiMode.

Namespace: frxCtrls
Syntax
Delphi
published
 property BiDiMode;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.Color Property

Summary

Represents property Color.

Namespace: frxCtrls
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.Constraints Property

Summary

Represents property Constraints.

Namespace: frxCtrls
Syntax
Delphi
published
 property Constraints;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.DragCursor Property

Summary

Represents property DragCursor.

Namespace: frxCtrls
Syntax
Delphi
published
 property DragCursor;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.DragKind Property

Summary

Represents property DragKind.

Namespace: frxCtrls
Syntax
Delphi
published
 property DragKind;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.DragMode Property

Summary

Represents property DragMode.

Namespace: frxCtrls
Syntax
Delphi
published
 property DragMode;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.DropDownCount Property

Summary

Represents property DropDownCount.

Namespace: frxCtrls
Syntax
Delphi
published
 property DropDownCount;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.Enabled Property

Summary

Represents property Enabled.

Namespace: frxCtrls
Syntax
Delphi
published
 property Enabled;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.Font Property

Summary

Represents property Font.

Namespace: frxCtrls
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.IniFile Property

Summary

Represents property IniFile.

Namespace: frxCtrls
Syntax
Delphi
public
 property IniFile: TCustomIniFile read FIni write FIni;

Property Value

Type: TCustomIniFile

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.ItemHeight Property

Summary

Represents property ItemHeight.

Namespace: frxCtrls
Syntax
Delphi
published
 property ItemHeight;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.MRURegKey Property

Summary

Represents property MRURegKey.

Namespace: frxCtrls
Syntax
Delphi
published
 property MRURegKey: String read FRegKey write SetRegKey;

Property Value

Type: String

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnChange Property

Summary

Represents property OnChange.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnChange;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnClick Property

Summary

Represents property OnClick.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnClick: TNotifyEvent read FOnClick write FOnClick;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnDragDrop Property

Summary

Represents property OnDragDrop.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDragDrop;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnDragOver Property

Summary

Represents property OnDragOver.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDragOver;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnDropDown Property

Summary

Represents property OnDropDown.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnDropDown;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnEndDock Property

Summary

Represents property OnEndDock.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnEndDock;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnEndDrag Property

Summary

Represents property OnEndDrag.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnEndDrag;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnExit Property

Summary

Represents property OnExit.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnStartDock Property

Summary

Represents property OnStartDock.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnStartDock;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.OnStartDrag Property

Summary

Represents property OnStartDrag.

Namespace: frxCtrls
Syntax
Delphi
published
 property OnStartDrag;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.ParentBiDiMode Property

Summary

Represents property ParentBiDiMode.

Namespace: frxCtrls
Syntax
Delphi
published
 property ParentBiDiMode;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.ParentColor Property

Summary

Represents property ParentColor.

Namespace: frxCtrls
Syntax
Delphi
published
 property ParentColor;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.ParentFont Property

Summary

Represents property ParentFont.

Namespace: frxCtrls
Syntax
Delphi
published
 property ParentFont;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.ParentShowHint Property

Summary

Represents property ParentShowHint.

Namespace: frxCtrls
Syntax
Delphi
published
 property ParentShowHint;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: frxCtrls
Syntax
Delphi
published
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.ShowHint Property

Summary

Represents property ShowHint.

Namespace: frxCtrls
Syntax
Delphi
published
 property ShowHint;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.ShowMRU Property

Summary

Represents property ShowMRU.

Namespace: frxCtrls
Syntax
Delphi
published
 property ShowMRU: Boolean read FShowMRU write FShowMRU default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.TabOrder Property

Summary

Represents property TabOrder.

Namespace: frxCtrls
Syntax
Delphi
published
 property TabOrder;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.TabStop Property

Summary

Represents property TabStop.

Namespace: frxCtrls
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.Text Property

Summary

Represents property Text.

Namespace: frxCtrls
Syntax
Delphi
published
 property Text;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.Visible Property

Summary

Represents property Visible.

Namespace: frxCtrls
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox Methods

Methods
Name | Description
Click | Represents method Click.
CMFontChange(TMessage) | Represents method CMFontChange(TMessage).
CMFontChanged(TMessage) | Represents method CMFontChanged(TMessage).
CNCommand(TWMCommand) | Represents method CNCommand(TWMCommand).
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Overrides TfrxCustomComboBox.DoPPIChanged(Integer).)
DrawImage(HDC,Integer,TRect) | Represents method DrawImage(HDC,Integer,TRect). (Overrides TfrxCustomComboBox.DrawImage(HDC,Integer,TRect).)
DrawItem(Integer,TRect,TOwnerDrawState) | Represents method DrawItem(Integer,TRect,TOwnerDrawState).
Init | Represents method Init.
Loaded | Represents method Loaded.
PopulateList | Represents method PopulateList.
Reset | Represents method Reset.
SetRegKey(String) | Represents method SetRegKey(String).
Top


TfrxFontComboBox.Click Method

Summary

Represents method Click.

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure Click; override;
See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.CMFontChange(TMessage) Method

Summary

Represents method CMFontChange(TMessage).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure CMFontChange(var Message: TMessage); message CM_FONTCHANGE;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.CMFontChanged(TMessage) Method

Summary

Represents method CMFontChanged(TMessage).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure CMFontChanged(var Message: TMessage); message CM_FONTCHANGED;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.CNCommand(TWMCommand) Method

Summary

Represents method CNCommand(TWMCommand).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure CNCommand(var Message: TWMCommand); message CN_COMMAND;

Parameters

Message
Type: TWMCommand

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.DoPPIChanged(Integer) Method

Summary

Represents method DoPPIChanged(Integer).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure DoPPIChanged(aNewPPI: Integer); override;

Parameters

aNewPPI
Type: Integer

Overrides

TfrxCustomComboBox.DoPPIChanged(Integer)
See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.DrawImage(HDC,Integer,TRect) Method

Summary

Represents method DrawImage(HDC,Integer,TRect).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure DrawImage(DC: HDC; Index: Integer; R: TRect); override;

Parameters

DC
Type: HDC

Index
Type: Integer

R
Type: TRect

Overrides

TfrxCustomComboBox.DrawImage(HDC,Integer,TRect)
See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.DrawItem(Integer,TRect,TOwnerDrawState) Method

Summary

Represents method DrawItem(Integer,TRect,TOwnerDrawState).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure DrawItem(Index: Integer; Rect: TRect; State: TOwnerDrawState); override;

Parameters

Index
Type: Integer

Rect
Type: TRect

State
Type: TOwnerDrawState

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.Init Method

Summary

Represents method Init.

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure Init;
See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.Loaded Method

Summary

Represents method Loaded.

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.PopulateList Method

Summary

Represents method PopulateList.

Namespace: frxCtrls
Syntax
Delphi
public
 procedure PopulateList; virtual;
See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.Reset Method

Summary

Represents method Reset.

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure Reset;
See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.SetRegKey(String) Method

Summary

Represents method SetRegKey(String).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetRegKey(Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox Fields

Fields
Name | Description
FDeviceBMP | Represents field FDeviceBMP.
FIni | Represents field FIni.
FOnClick | Represents field FOnClick.
FRegKey | Represents field FRegKey.
frFontViewForm | Represents field frFontViewForm.
FShowMRU | Represents field FShowMRU.
FTrueTypeBMP | Represents field FTrueTypeBMP.
FUpdate | Represents field FUpdate.
Numused | Represents field Numused.
Top


TfrxFontComboBox.FDeviceBMP Field

Summary

Represents field FDeviceBMP.

Namespace: frxCtrls
Syntax
Delphi
private
 FDeviceBMP: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.FIni Field

Summary

Represents field FIni.

Namespace: frxCtrls
Syntax
Delphi
private
 FIni: TCustomIniFile;

Field Value

Type: TCustomIniFile

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.FOnClick Field

Summary

Represents field FOnClick.

Namespace: frxCtrls
Syntax
Delphi
private
 FOnClick: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.FRegKey Field

Summary

Represents field FRegKey.

Namespace: frxCtrls
Syntax
Delphi
private
 FRegKey: String;

Field Value

Type: String

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.frFontViewForm Field

Summary

Represents field frFontViewForm.

Namespace: frxCtrls
Syntax
Delphi
private
 frFontViewForm: TfrxFontPreview;

Field Value

Type: TfrxFontPreview

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.FShowMRU Field

Summary

Represents field FShowMRU.

Namespace: frxCtrls
Syntax
Delphi
private
 FShowMRU: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.FTrueTypeBMP Field

Summary

Represents field FTrueTypeBMP.

Namespace: frxCtrls
Syntax
Delphi
private
 FTrueTypeBMP: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.FUpdate Field

Summary

Represents field FUpdate.

Namespace: frxCtrls
Syntax
Delphi
private
 FUpdate: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontComboBox.Numused Field

Summary

Represents field Numused.

Namespace: frxCtrls
Syntax
Delphi
private
 Numused: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxFontComboBox
  • frxCtrls


TfrxFontPreview Class

Summary

Represents type TfrxFontPreview.

Namespace: frxCtrls
Inheritance Hierarchy
TWinControl
frxCtrls.TfrxFontPreview
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxFontPreview = class(TWinControl)
 end;

The TfrxFontPreview type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxFontPreview class.
Destroy | Represents the destructor of the TfrxFontPreview class.
Top
Methods
Show:
Name | Description
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams).
SetDefaultFontSize(Integer) | Represents method SetDefaultFontSize(Integer).
Top
Fields
Show:
Name | Description
FPanel | Represents field FPanel.
Top
See Also

Reference

  • frxCtrls


TfrxFontPreview Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxFontPreview class.
Destroy | Represents the destructor of the TfrxFontPreview class.
Top


TfrxFontPreview.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxFontPreview class.

Namespace: frxCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxFontPreview
  • frxCtrls


TfrxFontPreview.Destroy Destructor

Summary

Represents the destructor of the TfrxFontPreview class.

Namespace: frxCtrls
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxFontPreview
  • frxCtrls


TfrxFontPreview Methods

Methods
Name | Description
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams).
SetDefaultFontSize(Integer) | Represents method SetDefaultFontSize(Integer).
Top


TfrxFontPreview.CreateParams(TCreateParams) Method

Summary

Represents method CreateParams(TCreateParams).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure CreateParams(var Params: TCreateParams); override;

Parameters

Params
Type: TCreateParams

See Also

Reference

  • TfrxFontPreview
  • frxCtrls


TfrxFontPreview.SetDefaultFontSize(Integer) Method

Summary

Represents method SetDefaultFontSize(Integer).

Namespace: frxCtrls
Syntax
Delphi
public
 procedure SetDefaultFontSize(aNewPPI: Integer);

Parameters

aNewPPI
Type: Integer

See Also

Reference

  • TfrxFontPreview
  • frxCtrls


TfrxFontPreview Fields

Fields
Name | Description
FPanel | Represents field FPanel.
Top


TfrxFontPreview.FPanel Field

Summary

Represents field FPanel.

Namespace: frxCtrls
Syntax
Delphi
private
 FPanel: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxFontPreview
  • frxCtrls


TfrxScrollWin Class

Summary

Represents type TfrxScrollWin.

Namespace: frxCtrls
Inheritance Hierarchy
TCustomControl
frxCtrls.TfrxScrollWin
frxPreview.TfrxPreviewWorkspace
frxSynMemo.TfrxSyntaxMemo
Syntax
Delphi
type
 TfrxScrollWin = class(TCustomControl)
 end;

The TfrxScrollWin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxScrollWin class.
Top
Properties
Show:
Name | Description
BevelKind | Represents property BevelKind.
BorderStyle | Represents property BorderStyle.
HideScrolls | Represents property HideScrolls.
HorzPage | Represents property HorzPage.
HorzPosition | Represents property HorzPosition.
HorzRange | Represents property HorzRange.
LargeChange | Represents property LargeChange.
SmallChange | Represents property SmallChange.
VertPage | Represents property VertPage.
VertPosition | Represents property VertPosition.
VertRange | Represents property VertRange.
Top
Methods
Show:
Name | Description
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams).
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer).
GetLongPosition(Integer,Word) | Represents method GetLongPosition(Integer,Word).
GetScale | Represents method GetScale.
GetScaledFontSize | Represents method GetScaledFontSize.
OnHScrollChange(TObject) | Represents method OnHScrollChange(TObject).
OnVScrollChange(TObject) | Represents method OnVScrollChange(TObject).
Paint | Represents method Paint.
SetBorderStyle(TBorderStyle) | Represents method SetBorderStyle(TBorderStyle).
SetHideScrolls(Boolean) | Represents method SetHideScrolls(Boolean).
SetHorzPage(Integer) | Represents method SetHorzPage(Integer).
SetHorzPosition(Integer) | Represents method SetHorzPosition(Integer).
SetHorzRange(Integer) | Represents method SetHorzRange(Integer).
SetPosition(Integer,Word) | Represents method SetPosition(Integer,Word).
SetScaledFontSize(Integer) | Represents method SetScaledFontSize(Integer).
SetVertPage(Integer) | Represents method SetVertPage(Integer).
SetVertPosition(Integer) | Represents method SetVertPosition(Integer).
SetVertRange(Integer) | Represents method SetVertRange(Integer).
UpdateScrollBar(Integer,Integer,Integer,Word) | Represents method UpdateScrollBar(Integer,Integer,Integer,Word).
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage).
WMEraseBackground(TMessage) | Represents method WMEraseBackground(TMessage).
WMGetDlgCode(TWMGetDlgCode) | Represents method WMGetDlgCode(TWMGetDlgCode).
WMHScroll(TWMHScroll) | Represents method WMHScroll(TWMHScroll).
WMVScroll(TWMVScroll) | Represents method WMVScroll(TWMVScroll).
Top
Events
Show:
Name | Description
OnScrollMaxChange | Represents property OnScrollMaxChange.
OnScrollPosChange | Represents property OnScrollPosChange.
Top
Fields
Show:
Name | Description
FBorderStyle | Represents field FBorderStyle.
FCurrentPPI | Represents field FCurrentPPI.
FHideScrolls | Represents field FHideScrolls.
FHorzPage | Represents field FHorzPage.
FHorzPosition | Represents field FHorzPosition.
FHorzRange | Represents field FHorzRange.
FLargeChange | Represents field FLargeChange.
FOnScrollMaxChange | Represents field FOnScrollMaxChange.
FOnScrollPosChange | Represents field FOnScrollPosChange.
FSmallChange | Represents field FSmallChange.
FVertPage | Represents field FVertPage.
FVertPosition | Represents field FVertPosition.
FVertRange | Represents field FVertRange.
Top
See Also

Reference

  • frxCtrls


TfrxScrollWin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxScrollWin class.
Top


TfrxScrollWin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxScrollWin class.

Namespace: frxCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin Properties

Properties
Name | Description
BevelKind | Represents property BevelKind.
BorderStyle | Represents property BorderStyle.
HideScrolls | Represents property HideScrolls.
HorzPage | Represents property HorzPage.
HorzPosition | Represents property HorzPosition.
HorzRange | Represents property HorzRange.
LargeChange | Represents property LargeChange.
SmallChange | Represents property SmallChange.
VertPage | Represents property VertPage.
VertPosition | Represents property VertPosition.
VertRange | Represents property VertRange.
Top


TfrxScrollWin.BevelKind Property

Summary

Represents property BevelKind.

Namespace: frxCtrls
Syntax
Delphi
public
 property BevelKind;

Property Value

Type: Void

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.BorderStyle Property

Summary

Represents property BorderStyle.

Namespace: frxCtrls
Syntax
Delphi
public
 property BorderStyle: TBorderStyle read FBorderStyle write SetBorderStyle;

Property Value

Type: TBorderStyle

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.HideScrolls Property

Summary

Represents property HideScrolls.

Namespace: frxCtrls
Syntax
Delphi
public
 property HideScrolls: Boolean read FHideScrolls write SetHideScrolls;

Property Value

Type: Boolean

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.HorzPage Property

Summary

Represents property HorzPage.

Namespace: frxCtrls
Syntax
Delphi
public
 property HorzPage: Integer read FHorzPage write SetHorzPage;

Property Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.HorzPosition Property

Summary

Represents property HorzPosition.

Namespace: frxCtrls
Syntax
Delphi
public
 property HorzPosition: Integer read FHorzPosition write SetHorzPosition;

Property Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.HorzRange Property

Summary

Represents property HorzRange.

Namespace: frxCtrls
Syntax
Delphi
public
 property HorzRange: Integer read FHorzRange write SetHorzRange;

Property Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.LargeChange Property

Summary

Represents property LargeChange.

Namespace: frxCtrls
Syntax
Delphi
public
 property LargeChange: Integer read FLargeChange write FLargeChange;

Property Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.SmallChange Property

Summary

Represents property SmallChange.

Namespace: frxCtrls
Syntax
Delphi
public
 property SmallChange: Integer read FSmallChange write FSmallChange;

Property Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.VertPage Property

Summary

Represents property VertPage.

Namespace: frxCtrls
Syntax
Delphi
public
 property VertPage: Integer read FVertPage write SetVertPage;

Property Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.VertPosition Property

Summary

Represents property VertPosition.

Namespace: frxCtrls
Syntax
Delphi
public
 property VertPosition: Integer read FVertPosition write SetVertPosition;

Property Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.VertRange Property

Summary

Represents property VertRange.

Namespace: frxCtrls
Syntax
Delphi
public
 property VertRange: Integer read FVertRange write SetVertRange;

Property Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin Methods

Methods
Name | Description
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams).
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer).
GetLongPosition(Integer,Word) | Represents method GetLongPosition(Integer,Word).
GetScale | Represents method GetScale.
GetScaledFontSize | Represents method GetScaledFontSize.
OnHScrollChange(TObject) | Represents method OnHScrollChange(TObject).
OnVScrollChange(TObject) | Represents method OnVScrollChange(TObject).
Paint | Represents method Paint.
SetBorderStyle(TBorderStyle) | Represents method SetBorderStyle(TBorderStyle).
SetHideScrolls(Boolean) | Represents method SetHideScrolls(Boolean).
SetHorzPage(Integer) | Represents method SetHorzPage(Integer).
SetHorzPosition(Integer) | Represents method SetHorzPosition(Integer).
SetHorzRange(Integer) | Represents method SetHorzRange(Integer).
SetPosition(Integer,Word) | Represents method SetPosition(Integer,Word).
SetScaledFontSize(Integer) | Represents method SetScaledFontSize(Integer).
SetVertPage(Integer) | Represents method SetVertPage(Integer).
SetVertPosition(Integer) | Represents method SetVertPosition(Integer).
SetVertRange(Integer) | Represents method SetVertRange(Integer).
UpdateScrollBar(Integer,Integer,Integer,Word) | Represents method UpdateScrollBar(Integer,Integer,Integer,Word).
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage).
WMEraseBackground(TMessage) | Represents method WMEraseBackground(TMessage).
WMGetDlgCode(TWMGetDlgCode) | Represents method WMGetDlgCode(TWMGetDlgCode).
WMHScroll(TWMHScroll) | Represents method WMHScroll(TWMHScroll).
WMVScroll(TWMVScroll) | Represents method WMVScroll(TWMVScroll).
Top


TfrxScrollWin.CreateParams(TCreateParams) Method

Summary

Represents method CreateParams(TCreateParams).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure CreateParams(var Params: TCreateParams); override;

Parameters

Params
Type: TCreateParams

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.DoPPIChanged(Integer) Method

Summary

Represents method DoPPIChanged(Integer).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure DoPPIChanged(aNewPPI: Integer); virtual;

Parameters

aNewPPI
Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.GetLongPosition(Integer,Word) Method

Summary

Represents method GetLongPosition(Integer,Word).

Namespace: frxCtrls
Syntax
Delphi
private
 function GetLongPosition(DefValue: Integer; Code: Word): Integer;

Parameters

DefValue
Type: Integer

Code
Type: Word

Return Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.GetScale Method

Summary

Represents method GetScale.

Namespace: frxCtrls
Syntax
Delphi
protected
 function GetScale: Single;

Return Value

Type: Single

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.GetScaledFontSize Method

Summary

Represents method GetScaledFontSize.

Namespace: frxCtrls
Syntax
Delphi
public
 function GetScaledFontSize: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.OnHScrollChange(TObject) Method

Summary

Represents method OnHScrollChange(TObject).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure OnHScrollChange(Sender: TObject); virtual;

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.OnVScrollChange(TObject) Method

Summary

Represents method OnVScrollChange(TObject).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure OnVScrollChange(Sender: TObject); virtual;

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.Paint Method

Summary

Represents method Paint.

Namespace: frxCtrls
Syntax
Delphi
public
 procedure Paint; override;
See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.SetBorderStyle(TBorderStyle) Method

Summary

Represents method SetBorderStyle(TBorderStyle).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetBorderStyle(const Value: TBorderStyle);

Parameters

Value
Type: TBorderStyle

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.SetHideScrolls(Boolean) Method

Summary

Represents method SetHideScrolls(Boolean).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetHideScrolls(b: Boolean);

Parameters

b
Type: Boolean

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.SetHorzPage(Integer) Method

Summary

Represents method SetHorzPage(Integer).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetHorzPage(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.SetHorzPosition(Integer) Method

Summary

Represents method SetHorzPosition(Integer).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetHorzPosition(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.SetHorzRange(Integer) Method

Summary

Represents method SetHorzRange(Integer).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetHorzRange(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.SetPosition(Integer,Word) Method

Summary

Represents method SetPosition(Integer,Word).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetPosition(Value: Integer; Code: Word);

Parameters

Value
Type: Integer

Code
Type: Word

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.SetScaledFontSize(Integer) Method

Summary

Represents method SetScaledFontSize(Integer).

Namespace: frxCtrls
Syntax
Delphi
public
 procedure SetScaledFontSize(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.SetVertPage(Integer) Method

Summary

Represents method SetVertPage(Integer).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetVertPage(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.SetVertPosition(Integer) Method

Summary

Represents method SetVertPosition(Integer).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetVertPosition(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.SetVertRange(Integer) Method

Summary

Represents method SetVertRange(Integer).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure SetVertRange(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.UpdateScrollBar(Integer,Integer,Integer,Word) Method

Summary

Represents method UpdateScrollBar(Integer,Integer,Integer,Word).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure UpdateScrollBar(Max, Page, Pos: Integer; Code: Word);

Parameters

Max
Type: Integer

Page
Type: Integer

Pos
Type: Integer

Code
Type: Word

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.WMDpiChanged(TMessage) Method

Summary

Represents method WMDpiChanged(TMessage).

Namespace: frxCtrls
Syntax
Delphi
protected
 procedure WMDpiChanged(var Message: TMessage); message FRX_WM_DPICHANGED_AFTERPARENT;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.WMEraseBackground(TMessage) Method

Summary

Represents method WMEraseBackground(TMessage).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure WMEraseBackground(var Message: TMessage); message WM_ERASEBKGND;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.WMGetDlgCode(TWMGetDlgCode) Method

Summary

Represents method WMGetDlgCode(TWMGetDlgCode).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure WMGetDlgCode(var Message: TWMGetDlgCode); message WM_GETDLGCODE;

Parameters

Message
Type: TWMGetDlgCode

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.WMHScroll(TWMHScroll) Method

Summary

Represents method WMHScroll(TWMHScroll).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure WMHScroll(var Message: TWMHScroll); message WM_HSCROLL;

Parameters

Message
Type: TWMHScroll

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.WMVScroll(TWMVScroll) Method

Summary

Represents method WMVScroll(TWMVScroll).

Namespace: frxCtrls
Syntax
Delphi
private
 procedure WMVScroll(var Message: TWMVScroll); message WM_VSCROLL;

Parameters

Message
Type: TWMVScroll

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin Events

Events
Name | Description
OnScrollMaxChange | Represents property OnScrollMaxChange.
OnScrollPosChange | Represents property OnScrollPosChange.
Top


TfrxScrollWin.OnScrollMaxChange Event

Summary

Represents property OnScrollMaxChange.

Namespace: frxCtrls
Syntax
Delphi
public
 property OnScrollMaxChange: TfrxScrollMaxChangeEvent read FOnScrollMaxChange write FOnScrollMaxChange;

Value

Type: TfrxScrollMaxChangeEvent

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.OnScrollPosChange Event

Summary

Represents property OnScrollPosChange.

Namespace: frxCtrls
Syntax
Delphi
public
 property OnScrollPosChange: TfrxScrollPosChangeEvent read FOnScrollPosChange write FOnScrollPosChange;

Value

Type: TfrxScrollPosChangeEvent

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin Fields

Fields
Name | Description
FBorderStyle | Represents field FBorderStyle.
FCurrentPPI | Represents field FCurrentPPI.
FHideScrolls | Represents field FHideScrolls.
FHorzPage | Represents field FHorzPage.
FHorzPosition | Represents field FHorzPosition.
FHorzRange | Represents field FHorzRange.
FLargeChange | Represents field FLargeChange.
FOnScrollMaxChange | Represents field FOnScrollMaxChange.
FOnScrollPosChange | Represents field FOnScrollPosChange.
FSmallChange | Represents field FSmallChange.
FVertPage | Represents field FVertPage.
FVertPosition | Represents field FVertPosition.
FVertRange | Represents field FVertRange.
Top


TfrxScrollWin.FBorderStyle Field

Summary

Represents field FBorderStyle.

Namespace: frxCtrls
Syntax
Delphi
private
 FBorderStyle: TBorderStyle;

Field Value

Type: TBorderStyle

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.FCurrentPPI Field

Summary

Represents field FCurrentPPI.

Namespace: frxCtrls
Syntax
Delphi
protected
 FCurrentPPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.FHideScrolls Field

Summary

Represents field FHideScrolls.

Namespace: frxCtrls
Syntax
Delphi
private
 FHideScrolls: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.FHorzPage Field

Summary

Represents field FHorzPage.

Namespace: frxCtrls
Syntax
Delphi
private
 FHorzPage: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.FHorzPosition Field

Summary

Represents field FHorzPosition.

Namespace: frxCtrls
Syntax
Delphi
private
 FHorzPosition: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.FHorzRange Field

Summary

Represents field FHorzRange.

Namespace: frxCtrls
Syntax
Delphi
private
 FHorzRange: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.FLargeChange Field

Summary

Represents field FLargeChange.

Namespace: frxCtrls
Syntax
Delphi
private
 FLargeChange: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.FOnScrollMaxChange Field

Summary

Represents field FOnScrollMaxChange.

Namespace: frxCtrls
Syntax
Delphi
private
 FOnScrollMaxChange: TfrxScrollMaxChangeEvent;

Field Value

Type: TfrxScrollMaxChangeEvent

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.FOnScrollPosChange Field

Summary

Represents field FOnScrollPosChange.

Namespace: frxCtrls
Syntax
Delphi
private
 FOnScrollPosChange: TfrxScrollPosChangeEvent;

Field Value

Type: TfrxScrollPosChangeEvent

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.FSmallChange Field

Summary

Represents field FSmallChange.

Namespace: frxCtrls
Syntax
Delphi
private
 FSmallChange: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.FVertPage Field

Summary

Represents field FVertPage.

Namespace: frxCtrls
Syntax
Delphi
private
 FVertPage: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.FVertPosition Field

Summary

Represents field FVertPosition.

Namespace: frxCtrls
Syntax
Delphi
private
 FVertPosition: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


TfrxScrollWin.FVertRange Field

Summary

Represents field FVertRange.

Namespace: frxCtrls
Syntax
Delphi
private
 FVertRange: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxScrollWin
  • frxCtrls


frxCtrls Delegates

Delegates
Name | Description
TfrxScrollMaxChangeEvent | Represents type TfrxScrollMaxChangeEvent.
TfrxScrollPosChangeEvent | Represents type TfrxScrollPosChangeEvent.
Top


TfrxScrollMaxChangeEvent Delegate

Summary

Represents type TfrxScrollMaxChangeEvent.

Namespace: frxCtrls
Syntax
Delphi
type
 TfrxScrollMaxChangeEvent = procedure(Sender: TObject; Orientation: TfrxScrollerOrientation; Value: Integer) of Object;
See Also

Reference

  • frxCtrls


TfrxScrollPosChangeEvent Delegate

Summary

Represents type TfrxScrollPosChangeEvent.

Namespace: frxCtrls
Syntax
Delphi
type
 TfrxScrollPosChangeEvent = procedure(Sender: TObject; Orientation: TfrxScrollerOrientation; var Value: Integer) of Object;
See Also

Reference

  • frxCtrls


frxCtrls Routines

Routines
Name | Description
frxBlend(TColor,TColor,Integer) | Represents method frxBlend(TColor,TColor,Integer).
Top


frxBlend(TColor,TColor,Integer) Method

Summary

Represents method frxBlend(TColor,TColor,Integer).

Namespace: frxCtrls
Syntax
Delphi
 function frxBlend(C1, C2: TColor; W1: Integer): TColor;

Parameters

C1
Type: TColor

C2
Type: TColor

W1
Type: Integer

Return Value

Type: TColor

See Also

Reference

  • frxCtrls


frxCustomEditors Namespace

Summary

Represents namespace frxCustomEditors.

Classes
Name | Description
TfrxCustomMemoEditor | Represents type TfrxCustomMemoEditor.
TfrxViewEditor | Represents type TfrxViewEditor.
Top


frxCustomEditors Classes

Classes
Name | Description
TfrxCustomMemoEditor | Represents type TfrxCustomMemoEditor.
TfrxViewEditor | Represents type TfrxViewEditor.
Top


TfrxCustomMemoEditor Class

Summary

Represents type TfrxCustomMemoEditor.

Namespace: frxCustomEditors
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxComponentEditor
frxCustomEditors.TfrxViewEditor
frxCustomEditors.TfrxCustomMemoEditor
Syntax
Delphi
type
 TfrxCustomMemoEditor = class(TfrxViewEditor)
 end;

The TfrxCustomMemoEditor type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponent,TfrxCustomDesigner,TMenu) | The constructor. (Inherited from TfrxComponentEditor.)
Top
Properties
Show:
Name | Description
Component | Link to the edited component. (Inherited from TfrxComponentEditor.)
Designer | Link to the designer. (Inherited from TfrxComponentEditor.)
Top
Methods
Show:
Name | Description
AddItem(String,Integer,Boolean) | Adds a menu item to the context menu of the edited component. (Inherited from TfrxComponentEditor.)
Edit | Method should perform necessary actions (for example, display a dialogue box) and returns "True," if the component's state was modified. (Inherited from TfrxComponentEditor.)
Execute(Integer,Boolean) | Method is called, when you select one of your items in the component's menu; response to the selected menu item should be described here. (Overrides TfrxViewEditor.Execute(Integer,Boolean).)
GetMenuItems | You should override this method if you need to add items in the component's context menu. Items should be added by AddItem method. (Overrides TfrxViewEditor.GetMenuItems.)
HasEditor | The "HasEditor" method should return "True" if your component has an editor. If it either returns "False" or you do not override this method, the editor will not be called. (Inherited from TfrxComponentEditor.)
Top
See Also

Reference

  • frxCustomEditors


TfrxCustomMemoEditor Methods

Methods
Name | Description
Execute(Integer,Boolean) | Method is called, when you select one of your items in the component's menu; response to the selected menu item should be described here. (Overrides TfrxViewEditor.Execute(Integer,Boolean).)
GetMenuItems | You should override this method if you need to add items in the component's context menu. Items should be added by AddItem method. (Overrides TfrxViewEditor.GetMenuItems.)
Top


TfrxCustomMemoEditor.Execute(Integer,Boolean) Method

Summary

Method is called, when you select one of your items in the component's menu; response to the selected menu item should be described here.

Namespace: frxCustomEditors
Syntax
Delphi
public
 function Execute(Tag: Integer; Checked: Boolean): Boolean; override;

Parameters

Tag
Type: Integer

Checked
Type: Boolean

Return Value

Type: Boolean

Overrides

TfrxViewEditor.Execute(Integer,Boolean)
See Also

Reference

  • TfrxCustomMemoEditor
  • frxCustomEditors


TfrxCustomMemoEditor.GetMenuItems Method

Summary

You should override this method if you need to add items in the component's context menu. Items should be added by AddItem method.

Namespace: frxCustomEditors
Syntax
Delphi
public
 procedure GetMenuItems; override;

Overrides

TfrxViewEditor.GetMenuItems
See Also

Reference

  • TfrxCustomMemoEditor
  • frxCustomEditors


TfrxViewEditor Class

Summary

Represents type TfrxViewEditor.

Namespace: frxCustomEditors
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxComponentEditor
frxCustomEditors.TfrxViewEditor
frxCustomEditors.TfrxCustomMemoEditor
Syntax
Delphi
type
 TfrxViewEditor = class(TfrxComponentEditor)
 end;

The TfrxViewEditor type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponent,TfrxCustomDesigner,TMenu) | The constructor. (Inherited from TfrxComponentEditor.)
Top
Properties
Show:
Name | Description
Component | Link to the edited component. (Inherited from TfrxComponentEditor.)
Designer | Link to the designer. (Inherited from TfrxComponentEditor.)
Top
Methods
Show:
Name | Description
AddItem(String,Integer,Boolean) | Adds a menu item to the context menu of the edited component. (Inherited from TfrxComponentEditor.)
Edit | Method should perform necessary actions (for example, display a dialogue box) and returns "True," if the component's state was modified. (Inherited from TfrxComponentEditor.)
Execute(Integer,Boolean) | Method is called, when you select one of your items in the component's menu; response to the selected menu item should be described here. (Overrides TfrxComponentEditor.Execute(Integer,Boolean).)
GetMenuItems | You should override this method if you need to add items in the component's context menu. Items should be added by AddItem method. (Overrides TfrxComponentEditor.GetMenuItems.)
HasEditor | The "HasEditor" method should return "True" if your component has an editor. If it either returns "False" or you do not override this method, the editor will not be called. (Inherited from TfrxComponentEditor.)
Top
See Also

Reference

  • frxCustomEditors


TfrxViewEditor Methods

Methods
Name | Description
Execute(Integer,Boolean) | Method is called, when you select one of your items in the component's menu; response to the selected menu item should be described here. (Overrides TfrxComponentEditor.Execute(Integer,Boolean).)
GetMenuItems | You should override this method if you need to add items in the component's context menu. Items should be added by AddItem method. (Overrides TfrxComponentEditor.GetMenuItems.)
Top


TfrxViewEditor.Execute(Integer,Boolean) Method

Summary

Method is called, when you select one of your items in the component's menu; response to the selected menu item should be described here.

Namespace: frxCustomEditors
Syntax
Delphi
public
 function Execute(Tag: Integer; Checked: Boolean): Boolean; override;

Parameters

Tag
Type: Integer

Checked
Type: Boolean

Return Value

Type: Boolean

Overrides

TfrxComponentEditor.Execute(Integer,Boolean)
See Also

Reference

  • TfrxViewEditor
  • frxCustomEditors


TfrxViewEditor.GetMenuItems Method

Summary

You should override this method if you need to add items in the component's context menu. Items should be added by AddItem method.

Namespace: frxCustomEditors
Syntax
Delphi
public
 procedure GetMenuItems; override;

Overrides

TfrxComponentEditor.GetMenuItems
See Also

Reference

  • TfrxViewEditor
  • frxCustomEditors


frxDataTree Namespace

Summary

Represents namespace frxDataTree.

Classes
Name | Description
TfrxDataTreeForm | Represents type TfrxDataTreeForm.
Top
Enumerations
Name | Description
TfrxDataTreeActions | Represents type TfrxDataTreeActions.
TfrxDataTreeFlag | Represents type TfrxDataTreeFlag.
TfrxDataTreeSortType | Represents type TfrxDataTreeSortType.
Top
Types
Name | Description
TfrxDataTreeFlags | Represents type TfrxDataTreeFlags.
Top


frxDataTree Classes

Classes
Name | Description
TfrxDataTreeForm | Represents type TfrxDataTreeForm.
Top


TfrxDataTreeForm Class

Summary

Represents type TfrxDataTreeForm.

Namespace: frxDataTree
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxDataTree.TfrxDataTreeForm
Syntax
Delphi
type
 TfrxDataTreeForm = class(TfrxBaseForm)
 end;

The TfrxDataTreeForm type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataTreeForm class. (Overrides TfrxBaseForm.Create(TComponent).)
Destroy | Represents the destructor of the TfrxDataTreeForm class.
Top
Properties
Show:
Name | Description
ClassesTree | Represents property ClassesTree.
CurrentFormPPI | Returns current PPI value of the form. (Inherited from TfrxBaseForm.)
DataTree | Represents property DataTree.
DataTreeFlags | Represents property DataTreeFlags.
DataTreeSortType | Represents property DataTreeSortType.
FunctionsTree | Represents property FunctionsTree.
IsPPIChanging | Represents property IsPPIChanging. (Inherited from TfrxBaseForm.)
MultiSelectAllowed | Represents property MultiSelectAllowed.
Report | Represents property Report.
VariablesTree | Represents property VariablesTree.
Top
Methods
Show:
Name | Description
ActiveDS | Represents method ActiveDS.
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseForm.)
AfterPPIChange | Represents method AfterPPIChange. (Inherited from TfrxBaseForm.)
AfterPPIMessage | Represents method AfterPPIMessage. (Inherited from TfrxBaseForm.)
BeforeDestruction | Represents method BeforeDestruction. (Inherited from TfrxBaseForm.)
BeforePPIChange | Represents method BeforePPIChange. (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer). (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean). (Inherited from TfrxBaseForm.)
CheclMultiSelection | Represents method CheclMultiSelection.
ClassesTreeCustomDrawItem(TCustomTreeView,TTreeNode,TCustomDrawState,Boolean) | Represents method ClassesTreeCustomDrawItem(TCustomTreeView,TTreeNode,TCustomDrawState,Boolean).
ClassesTreeExpanding(TObject,TTreeNode,Boolean) | Represents method ClassesTreeExpanding(TObject,TTreeNode,Boolean).
CollapseExpand(Boolean) | Represents method CollapseExpand(Boolean).
CreateClassesTreeView | Represents method CreateClassesTreeView.
CreateDataTreeView | Represents method CreateDataTreeView.
CreatefrxTreePanel(TfrxTreePanel,TfrxTreeView) | Represents method CreatefrxTreePanel(TfrxTreePanel,TfrxTreeView).
CreateFunctionsTreeView | Represents method CreateFunctionsTreeView.
CreateSortPopup | Represents method CreateSortPopup.
CreateVariablesTreeView | Represents method CreateVariablesTreeView.
DataTreeCustomDrawItem(TCustomTreeView,TTreeNode,TCustomDrawState,Boolean) | Represents method DataTreeCustomDrawItem(TCustomTreeView,TTreeNode,TCustomDrawState,Boolean).
DataTreeDblClick(TObject) | Represents method DataTreeDblClick(TObject).
DisableUpdate | Represents method DisableUpdate.
DoClose(TCloseAction) | Represents method DoClose(TCloseAction). (Inherited from TfrxBaseForm.)
DoShow | Represents method DoShow. (Inherited from TfrxBaseForm.)
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer). (Inherited from TfrxBaseForm.)
EnableUpdate | Represents method EnableUpdate.
FillClassesTree | Represents method FillClassesTree.
FillDataTree | Represents method FillDataTree.
FillFunctionsTree | Represents method FillFunctionsTree.
FillVariablesTree | Represents method FillVariablesTree.
FilterCompare(TObject,TTreeNode,string) | Represents method FilterCompare(TObject,TTreeNode,string).
FormResize(TObject) | Represents method FormResize(TObject).
FormShowAfterLoad | Represents method FormShowAfterLoad. (Inherited from TfrxBaseForm.)
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Inherited from TfrxBaseForm.)
FunctionsTreeChange(TObject,TTreeNode) | Represents method FunctionsTreeChange(TObject,TTreeNode).
GetActivePage | Represents method GetActivePage.
GetAvailablePreferences | Represents method GetAvailablePreferences. (Inherited from TfrxBaseForm.)
GetClassesTree | Represents method GetClassesTree.
GetCollapsedNodes | Represents method GetCollapsedNodes.
GetDataSet(Integer) | Represents method GetDataSet(Integer).
GetDataTree | Represents method GetDataTree.
GetFieldName(Integer) | Represents method GetFieldName(Integer).
GetFormSectionName | Represents method GetFormSectionName. (Inherited from TfrxBaseForm.)
GetFunctionsTree | Represents method GetFunctionsTree.
GetLastPosition | Represents method GetLastPosition.
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Inherited from TfrxBaseForm.)
GetSelectionCount | Represents method GetSelectionCount.
GetVariablesTree | Represents method GetVariablesTree.
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Inherited from TfrxBaseForm.)
IsDataField | Represents method IsDataField.
IsDataTree(TObject) | Represents method IsDataTree(TObject).
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.LoadFormPreferences(TObject,TObject).)
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter. (Inherited from TfrxBaseForm.)
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Inherited from TfrxBaseForm.)
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.SaveFormPreferences(TObject,TObject).)
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxBaseForm.)
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms. (Inherited from TfrxBaseForm.)
SetColor_(TColor) | Represents method SetColor_(TColor).
SetControlsParent(TWinControl) | Represents method SetControlsParent(TWinControl).
SetDataTreeFlags(TfrxDataTreeFlags) | Represents method SetDataTreeFlags(TfrxDataTreeFlags).
SetDataTreeSortType(TfrxDataTreeSortType) | Represents method SetDataTreeSortType(TfrxDataTreeSortType).
SetLastPosition(TPoint) | Represents method SetLastPosition(TPoint).
SetReport(TfrxReport) | Represents method SetReport(TfrxReport).
ShowTab(Integer) | Represents method ShowTab(Integer).
SortCBClick(TObject) | Represents method SortCBClick(TObject).
TabsChange(TObject) | Represents method TabsChange(TObject).
ToolOnClick(TObject) | Represents method ToolOnClick(TObject).
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form. (Inherited from TfrxBaseForm.)
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Overrides TfrxBaseForm.UpdateFormPPI(Integer).)
UpdateItems | Represents method UpdateItems.
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Inherited from TfrxBaseForm.)
UpdateSelection | Represents method UpdateSelection.
UpdateSize | Represents method UpdateSize.
Top
Fields
Show:
Name | Description
FActionBtnList | Represents field FActionBtnList.
FClassesPanel | Represents field FClassesPanel.
FClassesTree | Represents field FClassesTree.
FDataPanel | Represents field FDataPanel.
FDataTree | Represents field FDataTree.
FDataTreeFlags | Represents field FDataTreeFlags.
FDataTreeSortType | Represents field FDataTreeSortType.
FFirstTime | Represents field FFirstTime.
FFunctionsPanel | Represents field FFunctionsPanel.
FFunctionsTree | Represents field FFunctionsTree.
FHostedControls | Represents field FHostedControls. (Inherited from TfrxBaseForm.)
FImages | Represents field FImages.
FMultiSelectAllowed | Represents field FMultiSelectAllowed.
FPrefEvent | Represents field FPrefEvent. (Inherited from TfrxBaseForm.)
FReport | Represents field FReport.
FSortButton | Represents field FSortButton.
FSortPopUp | Represents field FSortPopUp.
FTabs | Represents field FTabs.
FunctionDescL | Represents field FunctionDescL.
FunctionNameL | Represents field FunctionNameL.
FunctionsPn | Represents field FunctionsPn.
FUpdateLocked | Represents field FUpdateLocked.
FUpdating | Represents field FUpdating.
FVariablesButton | Represents field FVariablesButton.
FVariablesPanel | Represents field FVariablesPanel.
FVariablesTree | Represents field FVariablesTree.
FXML | Represents field FXML.
HintPanel | Represents field HintPanel.
NoDataL | Represents field NoDataL.
NoDataPn | Represents field NoDataPn.
Splitter1 | Represents field Splitter1.
Top
See Also

Reference

  • frxDataTree


TfrxDataTreeForm Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDataTreeForm class. (Overrides TfrxBaseForm.Create(TComponent).)
Destroy | Represents the destructor of the TfrxDataTreeForm class.
Top


TfrxDataTreeForm.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDataTreeForm class.

Namespace: frxDataTree
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxBaseForm.Create(TComponent)
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.Destroy Destructor

Summary

Represents the destructor of the TfrxDataTreeForm class.

Namespace: frxDataTree
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm Properties

Properties
Name | Description
ClassesTree | Represents property ClassesTree.
DataTree | Represents property DataTree.
DataTreeFlags | Represents property DataTreeFlags.
DataTreeSortType | Represents property DataTreeSortType.
FunctionsTree | Represents property FunctionsTree.
MultiSelectAllowed | Represents property MultiSelectAllowed.
Report | Represents property Report.
VariablesTree | Represents property VariablesTree.
Top


TfrxDataTreeForm.ClassesTree Property

Summary

Represents property ClassesTree.

Namespace: frxDataTree
Syntax
Delphi
public
 property ClassesTree: TTreeView read GetClassesTree;

Property Value

Type: TTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.DataTree Property

Summary

Represents property DataTree.

Namespace: frxDataTree
Syntax
Delphi
public
 property DataTree: TTreeView read GetDataTree;

Property Value

Type: TTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.DataTreeFlags Property

Summary

Represents property DataTreeFlags.

Namespace: frxDataTree
Syntax
Delphi
public
 property DataTreeFlags: TfrxDataTreeFlags read FDataTreeFlags write SetDataTreeFlags;

Property Value

Type: TfrxDataTreeFlags

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.DataTreeSortType Property

Summary

Represents property DataTreeSortType.

Namespace: frxDataTree
Syntax
Delphi
public
 property DataTreeSortType: TfrxDataTreeSortType read FDataTreeSortType write SetDataTreeSortType;

Property Value

Type: TfrxDataTreeSortType

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FunctionsTree Property

Summary

Represents property FunctionsTree.

Namespace: frxDataTree
Syntax
Delphi
public
 property FunctionsTree: TTreeView read GetFunctionsTree;

Property Value

Type: TTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.MultiSelectAllowed Property

Summary

Represents property MultiSelectAllowed.

Namespace: frxDataTree
Syntax
Delphi
public
 property MultiSelectAllowed: Boolean read FMultiSelectAllowed write FMultiSelectAllowed;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.Report Property

Summary

Represents property Report.

Namespace: frxDataTree
Syntax
Delphi
public
 property Report: TfrxReport read FReport write SetReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.VariablesTree Property

Summary

Represents property VariablesTree.

Namespace: frxDataTree
Syntax
Delphi
public
 property VariablesTree: TTreeView read GetVariablesTree;

Property Value

Type: TTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm Methods

Methods
Name | Description
ActiveDS | Represents method ActiveDS.
CheclMultiSelection | Represents method CheclMultiSelection.
ClassesTreeCustomDrawItem(TCustomTreeView,TTreeNode,TCustomDrawState,Boolean) | Represents method ClassesTreeCustomDrawItem(TCustomTreeView,TTreeNode,TCustomDrawState,Boolean).
ClassesTreeExpanding(TObject,TTreeNode,Boolean) | Represents method ClassesTreeExpanding(TObject,TTreeNode,Boolean).
CollapseExpand(Boolean) | Represents method CollapseExpand(Boolean).
CreateClassesTreeView | Represents method CreateClassesTreeView.
CreateDataTreeView | Represents method CreateDataTreeView.
CreatefrxTreePanel(TfrxTreePanel,TfrxTreeView) | Represents method CreatefrxTreePanel(TfrxTreePanel,TfrxTreeView).
CreateFunctionsTreeView | Represents method CreateFunctionsTreeView.
CreateSortPopup | Represents method CreateSortPopup.
CreateVariablesTreeView | Represents method CreateVariablesTreeView.
DataTreeCustomDrawItem(TCustomTreeView,TTreeNode,TCustomDrawState,Boolean) | Represents method DataTreeCustomDrawItem(TCustomTreeView,TTreeNode,TCustomDrawState,Boolean).
DataTreeDblClick(TObject) | Represents method DataTreeDblClick(TObject).
DisableUpdate | Represents method DisableUpdate.
EnableUpdate | Represents method EnableUpdate.
FillClassesTree | Represents method FillClassesTree.
FillDataTree | Represents method FillDataTree.
FillFunctionsTree | Represents method FillFunctionsTree.
FillVariablesTree | Represents method FillVariablesTree.
FilterCompare(TObject,TTreeNode,string) | Represents method FilterCompare(TObject,TTreeNode,string).
FormResize(TObject) | Represents method FormResize(TObject).
FunctionsTreeChange(TObject,TTreeNode) | Represents method FunctionsTreeChange(TObject,TTreeNode).
GetActivePage | Represents method GetActivePage.
GetClassesTree | Represents method GetClassesTree.
GetCollapsedNodes | Represents method GetCollapsedNodes.
GetDataSet(Integer) | Represents method GetDataSet(Integer).
GetDataTree | Represents method GetDataTree.
GetFieldName(Integer) | Represents method GetFieldName(Integer).
GetFunctionsTree | Represents method GetFunctionsTree.
GetLastPosition | Represents method GetLastPosition.
GetSelectionCount | Represents method GetSelectionCount.
GetVariablesTree | Represents method GetVariablesTree.
IsDataField | Represents method IsDataField.
IsDataTree(TObject) | Represents method IsDataTree(TObject).
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.LoadFormPreferences(TObject,TObject).)
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.SaveFormPreferences(TObject,TObject).)
SetColor_(TColor) | Represents method SetColor_(TColor).
SetControlsParent(TWinControl) | Represents method SetControlsParent(TWinControl).
SetDataTreeFlags(TfrxDataTreeFlags) | Represents method SetDataTreeFlags(TfrxDataTreeFlags).
SetDataTreeSortType(TfrxDataTreeSortType) | Represents method SetDataTreeSortType(TfrxDataTreeSortType).
SetLastPosition(TPoint) | Represents method SetLastPosition(TPoint).
SetReport(TfrxReport) | Represents method SetReport(TfrxReport).
ShowTab(Integer) | Represents method ShowTab(Integer).
SortCBClick(TObject) | Represents method SortCBClick(TObject).
TabsChange(TObject) | Represents method TabsChange(TObject).
ToolOnClick(TObject) | Represents method ToolOnClick(TObject).
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Overrides TfrxBaseForm.UpdateFormPPI(Integer).)
UpdateItems | Represents method UpdateItems.
UpdateSelection | Represents method UpdateSelection.
UpdateSize | Represents method UpdateSize.
Top


TfrxDataTreeForm.ActiveDS Method

Summary

Represents method ActiveDS.

Namespace: frxDataTree
Syntax
Delphi
public
 function ActiveDS: String;

Return Value

Type: String

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.CheclMultiSelection Method

Summary

Represents method CheclMultiSelection.

Namespace: frxDataTree
Syntax
Delphi
public
 procedure CheclMultiSelection;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.ClassesTreeCustomDrawItem(TCustomTreeView,TTreeNode,TCustomDrawState,Boolean) Method

Summary

Represents method ClassesTreeCustomDrawItem(TCustomTreeView,TTreeNode,TCustomDrawState,Boolean).

Namespace: frxDataTree
Syntax
Delphi
published
 procedure ClassesTreeCustomDrawItem(Sender: TCustomTreeView;
 Node: TTreeNode; State: TCustomDrawState; var DefaultDraw: Boolean);

Parameters

Sender
Type: TCustomTreeView

Node
Type: TTreeNode

State
Type: TCustomDrawState

DefaultDraw
Type: Boolean

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.ClassesTreeExpanding(TObject,TTreeNode,Boolean) Method

Summary

Represents method ClassesTreeExpanding(TObject,TTreeNode,Boolean).

Namespace: frxDataTree
Syntax
Delphi
published
 procedure ClassesTreeExpanding(Sender: TObject; Node: TTreeNode;
 var AllowExpansion: Boolean);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

AllowExpansion
Type: Boolean

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.CollapseExpand(Boolean) Method

Summary

Represents method CollapseExpand(Boolean).

Namespace: frxDataTree
Syntax
Delphi
private
 procedure CollapseExpand(aExpand: Boolean = False);

Parameters

aExpand
Type: Boolean

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.CreateClassesTreeView Method

Summary

Represents method CreateClassesTreeView.

Namespace: frxDataTree
Syntax
Delphi
private
 procedure CreateClassesTreeView;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.CreateDataTreeView Method

Summary

Represents method CreateDataTreeView.

Namespace: frxDataTree
Syntax
Delphi
private
 procedure CreateDataTreeView;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.CreatefrxTreePanel(TfrxTreePanel,TfrxTreeView) Method

Summary

Represents method CreatefrxTreePanel(TfrxTreePanel,TfrxTreeView).

Namespace: frxDataTree
Syntax
Delphi
private
 procedure CreatefrxTreePanel(var TreePanel: TfrxTreePanel; var aTreeView: TfrxTreeView);

Parameters

TreePanel
Type: TfrxTreePanel

aTreeView
Type: TfrxTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.CreateFunctionsTreeView Method

Summary

Represents method CreateFunctionsTreeView.

Namespace: frxDataTree
Syntax
Delphi
private
 procedure CreateFunctionsTreeView;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.CreateSortPopup Method

Summary

Represents method CreateSortPopup.

Namespace: frxDataTree
Syntax
Delphi
private
 procedure CreateSortPopup;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.CreateVariablesTreeView Method

Summary

Represents method CreateVariablesTreeView.

Namespace: frxDataTree
Syntax
Delphi
private
 procedure CreateVariablesTreeView;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.DataTreeCustomDrawItem(TCustomTreeView,TTreeNode,TCustomDrawState,Boolean) Method

Summary

Represents method DataTreeCustomDrawItem(TCustomTreeView,TTreeNode,TCustomDrawState,Boolean).

Namespace: frxDataTree
Syntax
Delphi
published
 procedure DataTreeCustomDrawItem(Sender: TCustomTreeView;
 Node: TTreeNode; State: TCustomDrawState; var DefaultDraw: Boolean);

Parameters

Sender
Type: TCustomTreeView

Node
Type: TTreeNode

State
Type: TCustomDrawState

DefaultDraw
Type: Boolean

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.DataTreeDblClick(TObject) Method

Summary

Represents method DataTreeDblClick(TObject).

Namespace: frxDataTree
Syntax
Delphi
published
 procedure DataTreeDblClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.DisableUpdate Method

Summary

Represents method DisableUpdate.

Namespace: frxDataTree
Syntax
Delphi
public
 procedure DisableUpdate;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.EnableUpdate Method

Summary

Represents method EnableUpdate.

Namespace: frxDataTree
Syntax
Delphi
public
 procedure EnableUpdate;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FillClassesTree Method

Summary

Represents method FillClassesTree.

Namespace: frxDataTree
Syntax
Delphi
private
 procedure FillClassesTree;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FillDataTree Method

Summary

Represents method FillDataTree.

Namespace: frxDataTree
Syntax
Delphi
private
 procedure FillDataTree;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FillFunctionsTree Method

Summary

Represents method FillFunctionsTree.

Namespace: frxDataTree
Syntax
Delphi
private
 procedure FillFunctionsTree;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FillVariablesTree Method

Summary

Represents method FillVariablesTree.

Namespace: frxDataTree
Syntax
Delphi
private
 procedure FillVariablesTree;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FilterCompare(TObject,TTreeNode,string) Method

Summary

Represents method FilterCompare(TObject,TTreeNode,string).

Namespace: frxDataTree
Syntax
Delphi
private
 function FilterCompare(Sender: TObject; Node: TTreeNode; const aFilter: string): Boolean;

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

aFilter
Type: string

Return Value

Type: Boolean

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FormResize(TObject) Method

Summary

Represents method FormResize(TObject).

Namespace: frxDataTree
Syntax
Delphi
published
 procedure FormResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FunctionsTreeChange(TObject,TTreeNode) Method

Summary

Represents method FunctionsTreeChange(TObject,TTreeNode).

Namespace: frxDataTree
Syntax
Delphi
published
 procedure FunctionsTreeChange(Sender: TObject; Node: TTreeNode);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.GetActivePage Method

Summary

Represents method GetActivePage.

Namespace: frxDataTree
Syntax
Delphi
public
 function GetActivePage: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.GetClassesTree Method

Summary

Represents method GetClassesTree.

Namespace: frxDataTree
Syntax
Delphi
private
 function GetClassesTree: TTreeView;

Return Value

Type: TTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.GetCollapsedNodes Method

Summary

Represents method GetCollapsedNodes.

Namespace: frxDataTree
Syntax
Delphi
private
 function GetCollapsedNodes: String;

Return Value

Type: String

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.GetDataSet(Integer) Method

Summary

Represents method GetDataSet(Integer).

Namespace: frxDataTree
Syntax
Delphi
public
 function GetDataSet(SelectionIndex: Integer): TfrxDataSet;

Parameters

SelectionIndex
Type: Integer

Return Value

Type: TfrxDataSet

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.GetDataTree Method

Summary

Represents method GetDataTree.

Namespace: frxDataTree
Syntax
Delphi
private
 function GetDataTree: TTreeView;

Return Value

Type: TTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.GetFieldName(Integer) Method

Summary

Represents method GetFieldName(Integer).

Namespace: frxDataTree
Syntax
Delphi
public
 function GetFieldName(SelectionIndex: Integer = -1): String;

Parameters

SelectionIndex
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.GetFunctionsTree Method

Summary

Represents method GetFunctionsTree.

Namespace: frxDataTree
Syntax
Delphi
private
 function GetFunctionsTree: TTreeView;

Return Value

Type: TTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.GetLastPosition Method

Summary

Represents method GetLastPosition.

Namespace: frxDataTree
Syntax
Delphi
public
 function GetLastPosition: TPoint;

Return Value

Type: TPoint

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.GetSelectionCount Method

Summary

Represents method GetSelectionCount.

Namespace: frxDataTree
Syntax
Delphi
public
 function GetSelectionCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.GetVariablesTree Method

Summary

Represents method GetVariablesTree.

Namespace: frxDataTree
Syntax
Delphi
private
 function GetVariablesTree: TTreeView;

Return Value

Type: TTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.IsDataField Method

Summary

Represents method IsDataField.

Namespace: frxDataTree
Syntax
Delphi
public
 function IsDataField: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.IsDataTree(TObject) Method

Summary

Represents method IsDataTree(TObject).

Namespace: frxDataTree
Syntax
Delphi
public
 function IsDataTree(aSource: TObject): Boolean;

Parameters

aSource
Type: TObject

Return Value

Type: Boolean

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.LoadFormPreferences(TObject,TObject) Method

Summary

Represents method LoadFormPreferences(TObject,TObject).

Namespace: frxDataTree
Syntax
Delphi
public
 procedure LoadFormPreferences(PreferencesStorage: TObject; DefPreferencesStorage: TObject); override;

Parameters

PreferencesStorage
Type: TObject

DefPreferencesStorage
Type: TObject

Overrides

TfrxBaseForm.LoadFormPreferences(TObject,TObject)
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.SaveFormPreferences(TObject,TObject) Method

Summary

Represents method SaveFormPreferences(TObject,TObject).

Namespace: frxDataTree
Syntax
Delphi
public
 procedure SaveFormPreferences(PreferencesStorage: TObject; DefPreferencesStorage: TObject); override;

Parameters

PreferencesStorage
Type: TObject

DefPreferencesStorage
Type: TObject

Overrides

TfrxBaseForm.SaveFormPreferences(TObject,TObject)
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.SetColor_(TColor) Method

Summary

Represents method SetColor_(TColor).

Namespace: frxDataTree
Syntax
Delphi
public
 procedure SetColor_(AColor: TColor);

Parameters

AColor
Type: TColor

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.SetControlsParent(TWinControl) Method

Summary

Represents method SetControlsParent(TWinControl).

Namespace: frxDataTree
Syntax
Delphi
public
 procedure SetControlsParent(AParent: TWinControl);

Parameters

AParent
Type: TWinControl

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.SetDataTreeFlags(TfrxDataTreeFlags) Method

Summary

Represents method SetDataTreeFlags(TfrxDataTreeFlags).

Namespace: frxDataTree
Syntax
Delphi
private
 procedure SetDataTreeFlags(const Value: TfrxDataTreeFlags);

Parameters

Value
Type: TfrxDataTreeFlags

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.SetDataTreeSortType(TfrxDataTreeSortType) Method

Summary

Represents method SetDataTreeSortType(TfrxDataTreeSortType).

Namespace: frxDataTree
Syntax
Delphi
private
 procedure SetDataTreeSortType(const Value: TfrxDataTreeSortType);

Parameters

Value
Type: TfrxDataTreeSortType

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.SetLastPosition(TPoint) Method

Summary

Represents method SetLastPosition(TPoint).

Namespace: frxDataTree
Syntax
Delphi
public
 procedure SetLastPosition(p: TPoint);

Parameters

p
Type: TPoint

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.SetReport(TfrxReport) Method

Summary

Represents method SetReport(TfrxReport).

Namespace: frxDataTree
Syntax
Delphi
private
 procedure SetReport(const Value: TfrxReport);

Parameters

Value
Type: TfrxReport

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.ShowTab(Integer) Method

Summary

Represents method ShowTab(Integer).

Namespace: frxDataTree
Syntax
Delphi
public
 procedure ShowTab(Index: Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.SortCBClick(TObject) Method

Summary

Represents method SortCBClick(TObject).

Namespace: frxDataTree
Syntax
Delphi
published
 procedure SortCBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.TabsChange(TObject) Method

Summary

Represents method TabsChange(TObject).

Namespace: frxDataTree
Syntax
Delphi
private
 procedure TabsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.ToolOnClick(TObject) Method

Summary

Represents method ToolOnClick(TObject).

Namespace: frxDataTree
Syntax
Delphi
private
 procedure ToolOnClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.UpdateFormPPI(Integer) Method

Summary

Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method.

Namespace: frxDataTree
Syntax
Delphi
public
 procedure UpdateFormPPI(aNewPPI: Integer); override;

Parameters

aNewPPI
Type: Integer

New PPI value.

Overrides

TfrxBaseForm.UpdateFormPPI(Integer)
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.UpdateItems Method

Summary

Represents method UpdateItems.

Namespace: frxDataTree
Syntax
Delphi
public
 procedure UpdateItems;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.UpdateSelection Method

Summary

Represents method UpdateSelection.

Namespace: frxDataTree
Syntax
Delphi
public
 procedure UpdateSelection;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.UpdateSize Method

Summary

Represents method UpdateSize.

Namespace: frxDataTree
Syntax
Delphi
public
 procedure UpdateSize;
See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm Fields

Fields
Name | Description
FActionBtnList | Represents field FActionBtnList.
FClassesPanel | Represents field FClassesPanel.
FClassesTree | Represents field FClassesTree.
FDataPanel | Represents field FDataPanel.
FDataTree | Represents field FDataTree.
FDataTreeFlags | Represents field FDataTreeFlags.
FDataTreeSortType | Represents field FDataTreeSortType.
FFirstTime | Represents field FFirstTime.
FFunctionsPanel | Represents field FFunctionsPanel.
FFunctionsTree | Represents field FFunctionsTree.
FImages | Represents field FImages.
FMultiSelectAllowed | Represents field FMultiSelectAllowed.
FReport | Represents field FReport.
FSortButton | Represents field FSortButton.
FSortPopUp | Represents field FSortPopUp.
FTabs | Represents field FTabs.
FunctionDescL | Represents field FunctionDescL.
FunctionNameL | Represents field FunctionNameL.
FunctionsPn | Represents field FunctionsPn.
FUpdateLocked | Represents field FUpdateLocked.
FUpdating | Represents field FUpdating.
FVariablesButton | Represents field FVariablesButton.
FVariablesPanel | Represents field FVariablesPanel.
FVariablesTree | Represents field FVariablesTree.
FXML | Represents field FXML.
HintPanel | Represents field HintPanel.
NoDataL | Represents field NoDataL.
NoDataPn | Represents field NoDataPn.
Splitter1 | Represents field Splitter1.
Top


TfrxDataTreeForm.FActionBtnList Field

Summary

Represents field FActionBtnList.

Namespace: frxDataTree
Syntax
Delphi
private
 FActionBtnList: array[TfrxDataTreeFlag] of TfrxToolPanelButton;

Field Value

Type: array[TfrxDataTreeFlag] of TfrxToolPanelButton

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FClassesPanel Field

Summary

Represents field FClassesPanel.

Namespace: frxDataTree
Syntax
Delphi
private
 FClassesPanel: TfrxTreePanel;

Field Value

Type: TfrxTreePanel

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FClassesTree Field

Summary

Represents field FClassesTree.

Namespace: frxDataTree
Syntax
Delphi
private
 FClassesTree: TfrxTreeView;

Field Value

Type: TfrxTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FDataPanel Field

Summary

Represents field FDataPanel.

Namespace: frxDataTree
Syntax
Delphi
private
 FDataPanel: TfrxTreePanel;

Field Value

Type: TfrxTreePanel

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FDataTree Field

Summary

Represents field FDataTree.

Namespace: frxDataTree
Syntax
Delphi
private
 FDataTree: TfrxTreeView;

Field Value

Type: TfrxTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FDataTreeFlags Field

Summary

Represents field FDataTreeFlags.

Namespace: frxDataTree
Syntax
Delphi
private
 FDataTreeFlags: TfrxDataTreeFlags;

Field Value

Type: TfrxDataTreeFlags

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FDataTreeSortType Field

Summary

Represents field FDataTreeSortType.

Namespace: frxDataTree
Syntax
Delphi
private
 FDataTreeSortType: TfrxDataTreeSortType;

Field Value

Type: TfrxDataTreeSortType

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FFirstTime Field

Summary

Represents field FFirstTime.

Namespace: frxDataTree
Syntax
Delphi
private
 FFirstTime: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FFunctionsPanel Field

Summary

Represents field FFunctionsPanel.

Namespace: frxDataTree
Syntax
Delphi
private
 FFunctionsPanel: TfrxTreePanel;

Field Value

Type: TfrxTreePanel

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FFunctionsTree Field

Summary

Represents field FFunctionsTree.

Namespace: frxDataTree
Syntax
Delphi
private
 FFunctionsTree: TfrxTreeView;

Field Value

Type: TfrxTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FImages Field

Summary

Represents field FImages.

Namespace: frxDataTree
Syntax
Delphi
private
 FImages: TImageList;

Field Value

Type: TImageList

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FMultiSelectAllowed Field

Summary

Represents field FMultiSelectAllowed.

Namespace: frxDataTree
Syntax
Delphi
private
 FMultiSelectAllowed: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FReport Field

Summary

Represents field FReport.

Namespace: frxDataTree
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FSortButton Field

Summary

Represents field FSortButton.

Namespace: frxDataTree
Syntax
Delphi
private
 FSortButton: TfrxToolPanelButton;

Field Value

Type: TfrxToolPanelButton

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FSortPopUp Field

Summary

Represents field FSortPopUp.

Namespace: frxDataTree
Syntax
Delphi
private
 FSortPopUp: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FTabs Field

Summary

Represents field FTabs.

Namespace: frxDataTree
Syntax
Delphi
private
 FTabs: TTabSet;

Field Value

Type: TTabSet

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FunctionDescL Field

Summary

Represents field FunctionDescL.

Namespace: frxDataTree
Syntax
Delphi
published
 FunctionDescL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FunctionNameL Field

Summary

Represents field FunctionNameL.

Namespace: frxDataTree
Syntax
Delphi
published
 FunctionNameL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FunctionsPn Field

Summary

Represents field FunctionsPn.

Namespace: frxDataTree
Syntax
Delphi
published
 FunctionsPn: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FUpdateLocked Field

Summary

Represents field FUpdateLocked.

Namespace: frxDataTree
Syntax
Delphi
private
 FUpdateLocked: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FUpdating Field

Summary

Represents field FUpdating.

Namespace: frxDataTree
Syntax
Delphi
private
 FUpdating: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FVariablesButton Field

Summary

Represents field FVariablesButton.

Namespace: frxDataTree
Syntax
Delphi
private
 FVariablesButton: TfrxToolPanelButton;

Field Value

Type: TfrxToolPanelButton

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FVariablesPanel Field

Summary

Represents field FVariablesPanel.

Namespace: frxDataTree
Syntax
Delphi
private
 FVariablesPanel: TfrxTreePanel;

Field Value

Type: TfrxTreePanel

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FVariablesTree Field

Summary

Represents field FVariablesTree.

Namespace: frxDataTree
Syntax
Delphi
private
 FVariablesTree: TfrxTreeView;

Field Value

Type: TfrxTreeView

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.FXML Field

Summary

Represents field FXML.

Namespace: frxDataTree
Syntax
Delphi
private
 FXML: TfsXMLDocument;

Field Value

Type: TfsXMLDocument

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.HintPanel Field

Summary

Represents field HintPanel.

Namespace: frxDataTree
Syntax
Delphi
published
 HintPanel: TScrollBox;

Field Value

Type: TScrollBox

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.NoDataL Field

Summary

Represents field NoDataL.

Namespace: frxDataTree
Syntax
Delphi
published
 NoDataL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.NoDataPn Field

Summary

Represents field NoDataPn.

Namespace: frxDataTree
Syntax
Delphi
published
 NoDataPn: TScrollBox;

Field Value

Type: TScrollBox

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


TfrxDataTreeForm.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: frxDataTree
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TfrxDataTreeForm
  • frxDataTree


frxDataTree Enumerations

Enumerations
Name | Description
TfrxDataTreeActions | Represents type TfrxDataTreeActions.
TfrxDataTreeFlag | Represents type TfrxDataTreeFlag.
TfrxDataTreeSortType | Represents type TfrxDataTreeSortType.
Top


TfrxDataTreeActions Enumeration

Summary

Represents type TfrxDataTreeActions.

Namespace: frxDataTree
Syntax
Delphi
type
 TfrxDataTreeActions = (dtaNode = 0, dtaDataEdit = 53, dtaVariablesEdit = 52, dtaSortData = 60, dtaUnsorted = 127, dtaAscending = 125, dtaDescending = 126, dtaCollapse = 117, dtaExpand = 118, dtadtfInsCaption = 123, dtaInsField = 124);

The TfrxDataTreeActions type exposes the following members.

Members
Show:
Name | Description
dtaAscending | Represents constant dtaAscending.
dtaCollapse | Represents constant dtaCollapse.
dtaDataEdit | Represents constant dtaDataEdit.
dtaDescending | Represents constant dtaDescending.
dtadtfInsCaption | Represents constant dtadtfInsCaption.
dtaExpand | Represents constant dtaExpand.
dtaInsField | Represents constant dtaInsField.
dtaNode | Represents constant dtaNode.
dtaSortData | Represents constant dtaSortData.
dtaUnsorted | Represents constant dtaUnsorted.
dtaVariablesEdit | Represents constant dtaVariablesEdit.
Top
See Also

Reference

  • frxDataTree


TfrxDataTreeFlag Enumeration

Summary

Represents type TfrxDataTreeFlag.

Namespace: frxDataTree
Syntax
Delphi
type
 TfrxDataTreeFlag = (dtfInsField, dtfInsCaption);

The TfrxDataTreeFlag type exposes the following members.

Members
Show:
Name | Description
dtfInsCaption | Represents constant dtfInsCaption.
dtfInsField | Represents constant dtfInsField.
Top
See Also

Reference

  • frxDataTree


TfrxDataTreeSortType Enumeration

Summary

Represents type TfrxDataTreeSortType.

Namespace: frxDataTree
Syntax
Delphi
type
 TfrxDataTreeSortType = (dtsUnsorted, dtsAscending, dtsDescending);

The TfrxDataTreeSortType type exposes the following members.

Members
Show:
Name | Description
dtsAscending | Represents constant dtsAscending.
dtsDescending | Represents constant dtsDescending.
dtsUnsorted | Represents constant dtsUnsorted.
Top
See Also

Reference

  • frxDataTree


frxDataTree Types

Types
Name | Description
TfrxDataTreeFlags | Represents type TfrxDataTreeFlags.
Top


TfrxDataTreeFlags Type

Summary

Represents type TfrxDataTreeFlags.

Namespace: frxDataTree
Syntax
Delphi
type
 TfrxDataTreeFlags = set of TfrxDataTreeFlag;
See Also

Reference

  • frxDataTree


frxDCtrl Namespace

Summary

Represents namespace frxDCtrl.

Classes
Name | Description
TfrxBevelControl | The TfrxBevelControl component represents a TBevel adapter.
TfrxBitBtnControl | The TfrxBitBtnControl component represents a TBitBtn adapter.
TfrxButtonControl | The TfrxButtonControl component represents a TButton adapter.
TfrxCheckBoxControl | The TfrxCheckBoxControl component represents a TCheckBox adapter.
TfrxCheckListBoxControl | The TfrxCheckListBoxControl component represents a TCheckListBox adapter.
TfrxComboBoxControl | The TfrxComboBoxControl component represents a TComboBox adapter.
TfrxCustomEditControl | The TfrxCustomEditControl is the base class for TCustomEdit-based controls.
TfrxDateEditControl | The TfrxDateEditControl component represents a TDateTimePicker adapter.
TfrxDialogControls | The TfrxDialogControls lets you use the Frdialog controls in your report. TfrxDialogControls is an empty component. It is used to add the frxDCtrl.pas file to the "uses" list.
TfrxEditControl | The TfrxEditControl component represents a TEdit adapter.
TfrxGroupBoxControl | The TfrxGroupBoxControl component represents a TGroupBox adapter.
TfrxImageControl | The TfrxImageControl component represents a TImage adapter.
TfrxLabelControl | The TfrxLabelControl component represents a TLabel adapter.
TfrxListBoxControl | The TfrxListBoxControl component represents a TListBox adapter.
TfrxMaskEditControl | The TfrxMaskEditControl component represents a TMaskEdit adapter.
TfrxMemoControl | The TfrxMemoControl component represents a TMemo adapter.
TfrxOnChangingEvent | Represents type TfrxOnChangingEvent.
TfrxPageControl | Represents type TfrxPageControl.
TfrxPanelControl | The TfrxPanelControl component represents a TPanel adapter.
TfrxRadioButtonControl | The TfrxRadioButtonControl component represents a TRadioButton adapter.
TfrxSpeedButtonControl | The TfrxSpeedButtonControl component represents a TSpeedButton adapter.
TfrxTabSheet | Represents type TfrxTabSheet.
Top


frxDCtrl Classes

Classes
Name | Description
TfrxBevelControl | The TfrxBevelControl component represents a TBevel adapter.
TfrxBitBtnControl | The TfrxBitBtnControl component represents a TBitBtn adapter.
TfrxButtonControl | The TfrxButtonControl component represents a TButton adapter.
TfrxCheckBoxControl | The TfrxCheckBoxControl component represents a TCheckBox adapter.
TfrxCheckListBoxControl | The TfrxCheckListBoxControl component represents a TCheckListBox adapter.
TfrxComboBoxControl | The TfrxComboBoxControl component represents a TComboBox adapter.
TfrxCustomEditControl | The TfrxCustomEditControl is the base class for TCustomEdit-based controls.
TfrxDateEditControl | The TfrxDateEditControl component represents a TDateTimePicker adapter.
TfrxDialogControls | The TfrxDialogControls lets you use the Frdialog controls in your report. TfrxDialogControls is an empty component. It is used to add the frxDCtrl.pas file to the "uses" list.
TfrxEditControl | The TfrxEditControl component represents a TEdit adapter.
TfrxGroupBoxControl | The TfrxGroupBoxControl component represents a TGroupBox adapter.
TfrxImageControl | The TfrxImageControl component represents a TImage adapter.
TfrxLabelControl | The TfrxLabelControl component represents a TLabel adapter.
TfrxListBoxControl | The TfrxListBoxControl component represents a TListBox adapter.
TfrxMaskEditControl | The TfrxMaskEditControl component represents a TMaskEdit adapter.
TfrxMemoControl | The TfrxMemoControl component represents a TMemo adapter.
TfrxOnChangingEvent | Represents type TfrxOnChangingEvent.
TfrxPageControl | Represents type TfrxPageControl.
TfrxPanelControl | The TfrxPanelControl component represents a TPanel adapter.
TfrxRadioButtonControl | The TfrxRadioButtonControl component represents a TRadioButton adapter.
TfrxSpeedButtonControl | The TfrxSpeedButtonControl component represents a TSpeedButton adapter.
TfrxTabSheet | Represents type TfrxTabSheet.
Top


TfrxBevelControl Class

Summary

The TfrxBevelControl component represents a TBevel adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxBevelControl
Syntax
Delphi
type
 TfrxBevelControl = class(TfrxDialogControl)
 end;

The TfrxBevelControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBevelControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Bevel | Reference to internal TBevel object.
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
Color | Color of the control. (Inherited from TfrxDialogControl.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | The name of the script routine that will be called if user clicks the control. (Inherited from TfrxDialogControl.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | The name of the script routine that will be called if user double clicks the control. (Inherited from TfrxDialogControl.)
OnEnter | The name of the script routine that will be called if control gets the focus. (Inherited from TfrxDialogControl.)
OnExit | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyDown | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyPress | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyUp | The name of the script routine that will be called if user released a key. (Inherited from TfrxDialogControl.)
OnMouseDown | The name of the script routine that will be called if user pressed a mouse button. (Inherited from TfrxDialogControl.)
OnMouseMove | The name of the script routine that will be called if user moved a mouse over control. (Inherited from TfrxDialogControl.)
OnMouseUp | The name of the script routine that will be called if user released a mouse button. (Inherited from TfrxDialogControl.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Shape | Determines the shape of the bevel.
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
Style | Determines whether the bevel appears raised or lowered.
TabStop | Determines if the user can tab to a control. (Inherited from TfrxDialogControl.)
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetBevelShape | Represents method GetBevelShape.
GetBevelStyle | Represents method GetBevelStyle.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBevelShape(TBevelShape) | Represents method SetBevelShape(TBevelShape).
SetBevelStyle(TBevelStyle) | Represents method SetBevelStyle(TBevelStyle).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FBevel | Represents field FBevel.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxBevelControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBevelControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxBevelControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxBevelControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxBevelControl
  • frxDCtrl


TfrxBevelControl Properties

Properties
Name | Description
Bevel | Reference to internal TBevel object.
Shape | Determines the shape of the bevel.
Style | Determines whether the bevel appears raised or lowered.
Top


TfrxBevelControl.Bevel Property

Summary

Reference to internal TBevel object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property Bevel: TBevel read FBevel;

Property Value

Type: TBevel

See Also

Reference

  • TfrxBevelControl
  • frxDCtrl


TfrxBevelControl.Shape Property

Summary

Determines the shape of the bevel.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Shape: TBevelShape read GetBevelShape write SetBevelShape default bsBox;

Property Value

Type: TBevelShape

See Also

Reference

  • TfrxBevelControl
  • frxDCtrl


TfrxBevelControl.Style Property

Summary

Determines whether the bevel appears raised or lowered.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Style: TBevelStyle read GetBevelStyle write SetBevelStyle default bsLowered;

Property Value

Type: TBevelStyle

See Also

Reference

  • TfrxBevelControl
  • frxDCtrl


TfrxBevelControl Methods

Methods
Name | Description
GetBevelShape | Represents method GetBevelShape.
GetBevelStyle | Represents method GetBevelStyle.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
SetBevelShape(TBevelShape) | Represents method SetBevelShape(TBevelShape).
SetBevelStyle(TBevelStyle) | Represents method SetBevelStyle(TBevelStyle).
Top


TfrxBevelControl.GetBevelShape Method

Summary

Represents method GetBevelShape.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetBevelShape: TBevelShape;

Return Value

Type: TBevelShape

See Also

Reference

  • TfrxBevelControl
  • frxDCtrl


TfrxBevelControl.GetBevelStyle Method

Summary

Represents method GetBevelStyle.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetBevelStyle: TBevelStyle;

Return Value

Type: TBevelStyle

See Also

Reference

  • TfrxBevelControl
  • frxDCtrl


TfrxBevelControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxBevelControl
  • frxDCtrl


TfrxBevelControl.SetBevelShape(TBevelShape) Method

Summary

Represents method SetBevelShape(TBevelShape).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetBevelShape(const Value: TBevelShape);

Parameters

Value
Type: TBevelShape

See Also

Reference

  • TfrxBevelControl
  • frxDCtrl


TfrxBevelControl.SetBevelStyle(TBevelStyle) Method

Summary

Represents method SetBevelStyle(TBevelStyle).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetBevelStyle(const Value: TBevelStyle);

Parameters

Value
Type: TBevelStyle

See Also

Reference

  • TfrxBevelControl
  • frxDCtrl


TfrxBevelControl Fields

Fields
Name | Description
FBevel | Represents field FBevel.
Top


TfrxBevelControl.FBevel Field

Summary

Represents field FBevel.

Namespace: frxDCtrl
Syntax
Delphi
private
 FBevel: TBevel;

Field Value

Type: TBevel

See Also

Reference

  • TfrxBevelControl
  • frxDCtrl


TfrxBitBtnControl Class

Summary

The TfrxBitBtnControl component represents a TBitBtn adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxBitBtnControl
Syntax
Delphi
type
 TfrxBitBtnControl = class(TfrxDialogControl)
 end;

The TfrxBitBtnControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBitBtnControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BitBtn | Reference to internal TBitBtn object.
Caption | Represents property Caption.
Color | Color of the control. (Inherited from TfrxDialogControl.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
Glyph | Specifies the bitmap that appears on the selected bitmap button.
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Kind | Determines the kind of bitmap button.
Layout | Determines where the image appears on the bitmap button.
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Margin | Determines the number of pixels between the edge of the image (specified in the Glyph property) and the edge of the button.
ModalResult | Determines if and how the button closes its (modal) parent form.
NumGlyphs | Indicates the number of images that are in the graphic specified in the Glyph property for use on a bitmap button or speed button.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | The name of the script routine that will be called if user double clicks the control. (Inherited from TfrxDialogControl.)
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
Spacing | Determines where the image and text appear on a bitmap or speed button.
TabStop | Represents property TabStop.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
WordWrap | Specifies whether the label text wraps when it is too long for the width of the label.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetGlyph | Represents method GetGlyph.
GetKind | Represents method GetKind.
GetLayout | Represents method GetLayout.
GetMargin | Represents method GetMargin.
GetModalResult | Represents method GetModalResult.
GetNumGlyphs | Represents method GetNumGlyphs.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetSpacing | Represents method GetSpacing.
GetWordWrap | Represents method GetWordWrap.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetGlyph(TBitmap) | Represents method SetGlyph(TBitmap).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetKind(TBitBtnKind) | Represents method SetKind(TBitBtnKind).
SetLayout(TButtonLayout) | Represents method SetLayout(TButtonLayout).
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetMargin(Integer) | Represents method SetMargin(Integer).
SetModalResult(TModalResult) | Represents method SetModalResult(TModalResult).
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetNumGlyphs(Integer) | Represents method SetNumGlyphs(Integer).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetSpacing(Integer) | Represents method SetSpacing(Integer).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
SetWordWrap(Boolean) | Represents method SetWordWrap(Boolean).
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FBitBtn | Represents field FBitBtn.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxBitBtnControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBitBtnControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxBitBtnControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxBitBtnControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl Properties

Properties
Name | Description
BitBtn | Reference to internal TBitBtn object.
Caption | Represents property Caption.
Glyph | Specifies the bitmap that appears on the selected bitmap button.
Kind | Determines the kind of bitmap button.
Layout | Determines where the image appears on the bitmap button.
Margin | Determines the number of pixels between the edge of the image (specified in the Glyph property) and the edge of the button.
ModalResult | Determines if and how the button closes its (modal) parent form.
NumGlyphs | Indicates the number of images that are in the graphic specified in the Glyph property for use on a bitmap button or speed button.
OnClick | Represents property OnClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
Spacing | Determines where the image and text appear on a bitmap or speed button.
TabStop | Represents property TabStop.
WordWrap | Specifies whether the label text wraps when it is too long for the width of the label.
Top


TfrxBitBtnControl.BitBtn Property

Summary

Reference to internal TBitBtn object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property BitBtn: TBitBtn read FBitBtn;

Property Value

Type: TBitBtn

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.Caption Property

Summary

Represents property Caption.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Caption;

Property Value

Type: Void

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.Glyph Property

Summary

Specifies the bitmap that appears on the selected bitmap button.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Glyph: TBitmap read GetGlyph write SetGlyph;

Property Value

Type: TBitmap

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.Kind Property

Summary

Determines the kind of bitmap button.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Kind: TBitBtnKind read GetKind write SetKind default bkCustom;

Property Value

Type: TBitBtnKind

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.Layout Property

Summary

Determines where the image appears on the bitmap button.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Layout: TButtonLayout read GetLayout write SetLayout default blGlyphLeft;

Property Value

Type: TButtonLayout

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.Margin Property

Summary

Determines the number of pixels between the edge of the image (specified in the Glyph property) and the edge of the button.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Margin: Integer read GetMargin write SetMargin default -1;

Property Value

Type: Integer

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.ModalResult Property

Summary

Determines if and how the button closes its (modal) parent form.

Namespace: frxDCtrl
Syntax
Delphi
published
 property ModalResult: TModalResult read GetModalResult write SetModalResult default mrNone;

Property Value

Type: TModalResult

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.NumGlyphs Property

Summary

Indicates the number of images that are in the graphic specified in the Glyph property for use on a bitmap button or speed button.

Namespace: frxDCtrl
Syntax
Delphi
published
 property NumGlyphs: Integer read GetNumGlyphs write SetNumGlyphs default 1;

Property Value

Type: Integer

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.Spacing Property

Summary

Determines where the image and text appear on a bitmap or speed button.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Spacing: Integer read GetSpacing write SetSpacing default 4;

Property Value

Type: Integer

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.WordWrap Property

Summary

Specifies whether the label text wraps when it is too long for the width of the label.

Namespace: frxDCtrl
Syntax
Delphi
published
 property WordWrap: Boolean read GetWordWrap write SetWordWrap default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl Methods

Methods
Name | Description
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended).)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetGlyph | Represents method GetGlyph.
GetKind | Represents method GetKind.
GetLayout | Represents method GetLayout.
GetMargin | Represents method GetMargin.
GetModalResult | Represents method GetModalResult.
GetNumGlyphs | Represents method GetNumGlyphs.
GetSpacing | Represents method GetSpacing.
GetWordWrap | Represents method GetWordWrap.
SetGlyph(TBitmap) | Represents method SetGlyph(TBitmap).
SetKind(TBitBtnKind) | Represents method SetKind(TBitBtnKind).
SetLayout(TButtonLayout) | Represents method SetLayout(TButtonLayout).
SetMargin(Integer) | Represents method SetMargin(Integer).
SetModalResult(TModalResult) | Represents method SetModalResult(TModalResult).
SetNumGlyphs(Integer) | Represents method SetNumGlyphs(Integer).
SetSpacing(Integer) | Represents method SetSpacing(Integer).
SetWordWrap(Boolean) | Represents method SetWordWrap(Boolean).
Top


TfrxBitBtnControl.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxDCtrl
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.GetGlyph Method

Summary

Represents method GetGlyph.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetGlyph: TBitmap;

Return Value

Type: TBitmap

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.GetKind Method

Summary

Represents method GetKind.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetKind: TBitBtnKind;

Return Value

Type: TBitBtnKind

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.GetLayout Method

Summary

Represents method GetLayout.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetLayout: TButtonLayout;

Return Value

Type: TButtonLayout

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.GetMargin Method

Summary

Represents method GetMargin.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetMargin: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.GetModalResult Method

Summary

Represents method GetModalResult.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetModalResult: TModalResult;

Return Value

Type: TModalResult

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.GetNumGlyphs Method

Summary

Represents method GetNumGlyphs.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetNumGlyphs: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.GetSpacing Method

Summary

Represents method GetSpacing.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetSpacing: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.GetWordWrap Method

Summary

Represents method GetWordWrap.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetWordWrap: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.SetGlyph(TBitmap) Method

Summary

Represents method SetGlyph(TBitmap).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetGlyph(const Value: TBitmap);

Parameters

Value
Type: TBitmap

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.SetKind(TBitBtnKind) Method

Summary

Represents method SetKind(TBitBtnKind).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetKind(const Value: TBitBtnKind);

Parameters

Value
Type: TBitBtnKind

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.SetLayout(TButtonLayout) Method

Summary

Represents method SetLayout(TButtonLayout).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetLayout(const Value: TButtonLayout);

Parameters

Value
Type: TButtonLayout

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.SetMargin(Integer) Method

Summary

Represents method SetMargin(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetMargin(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.SetModalResult(TModalResult) Method

Summary

Represents method SetModalResult(TModalResult).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetModalResult(const Value: TModalResult);

Parameters

Value
Type: TModalResult

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.SetNumGlyphs(Integer) Method

Summary

Represents method SetNumGlyphs(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetNumGlyphs(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.SetSpacing(Integer) Method

Summary

Represents method SetSpacing(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetSpacing(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl.SetWordWrap(Boolean) Method

Summary

Represents method SetWordWrap(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetWordWrap(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxBitBtnControl Fields

Fields
Name | Description
FBitBtn | Represents field FBitBtn.
Top


TfrxBitBtnControl.FBitBtn Field

Summary

Represents field FBitBtn.

Namespace: frxDCtrl
Syntax
Delphi
private
 FBitBtn: TBitBtn;

Field Value

Type: TBitBtn

See Also

Reference

  • TfrxBitBtnControl
  • frxDCtrl


TfrxButtonControl Class

Summary

The TfrxButtonControl component represents a TButton adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxButtonControl
Syntax
Delphi
type
 TfrxButtonControl = class(TfrxDialogControl)
 end;

The TfrxButtonControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxButtonControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Button | Reference to internal TButton object.
Cancel | Determines whether the button's OnClick event handler executes when the Escape key is pressed.
Caption | Represents property Caption.
Color | Color of the control. (Inherited from TfrxDialogControl.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Default | Determines whether the button's OnClick event handler executes when the Enter key is pressed.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
ModalResult | Determines if and how the button closes its (modal) parent form.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | The name of the script routine that will be called if user double clicks the control. (Inherited from TfrxDialogControl.)
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Represents property TabStop.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
WordWrap | Specifies whether the label text wraps when it is too long for the width of the label.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetCancel | Represents method GetCancel.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDefault | Represents method GetDefault.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetModalResult | Represents method GetModalResult.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetWordWrap | Represents method GetWordWrap.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCancel(Boolean) | Represents method SetCancel(Boolean).
SetDefault(Boolean) | Represents method SetDefault(Boolean).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetModalResult(TModalResult) | Represents method SetModalResult(TModalResult).
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
SetWordWrap(Boolean) | Represents method SetWordWrap(Boolean).
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FButton | Represents field FButton.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxButtonControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxButtonControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxButtonControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxButtonControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl Properties

Properties
Name | Description
Button | Reference to internal TButton object.
Cancel | Determines whether the button's OnClick event handler executes when the Escape key is pressed.
Caption | Represents property Caption.
Default | Determines whether the button's OnClick event handler executes when the Enter key is pressed.
ModalResult | Determines if and how the button closes its (modal) parent form.
OnClick | Represents property OnClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
TabStop | Represents property TabStop.
WordWrap | Specifies whether the label text wraps when it is too long for the width of the label.
Top


TfrxButtonControl.Button Property

Summary

Reference to internal TButton object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property Button: TButton read FButton;

Property Value

Type: TButton

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.Cancel Property

Summary

Determines whether the button's OnClick event handler executes when the Escape key is pressed.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Cancel: Boolean read GetCancel write SetCancel default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.Caption Property

Summary

Represents property Caption.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Caption;

Property Value

Type: Void

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.Default Property

Summary

Determines whether the button's OnClick event handler executes when the Enter key is pressed.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Default: Boolean read GetDefault write SetDefault default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.ModalResult Property

Summary

Determines if and how the button closes its (modal) parent form.

Namespace: frxDCtrl
Syntax
Delphi
published
 property ModalResult: TModalResult read GetModalResult write SetModalResult default mrNone;

Property Value

Type: TModalResult

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.WordWrap Property

Summary

Specifies whether the label text wraps when it is too long for the width of the label.

Namespace: frxDCtrl
Syntax
Delphi
published
 property WordWrap: Boolean read GetWordWrap write SetWordWrap default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl Methods

Methods
Name | Description
GetCancel | Represents method GetCancel.
GetDefault | Represents method GetDefault.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetModalResult | Represents method GetModalResult.
GetWordWrap | Represents method GetWordWrap.
SetCancel(Boolean) | Represents method SetCancel(Boolean).
SetDefault(Boolean) | Represents method SetDefault(Boolean).
SetModalResult(TModalResult) | Represents method SetModalResult(TModalResult).
SetWordWrap(Boolean) | Represents method SetWordWrap(Boolean).
Top


TfrxButtonControl.GetCancel Method

Summary

Represents method GetCancel.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetCancel: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.GetDefault Method

Summary

Represents method GetDefault.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetDefault: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.GetModalResult Method

Summary

Represents method GetModalResult.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetModalResult: TModalResult;

Return Value

Type: TModalResult

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.GetWordWrap Method

Summary

Represents method GetWordWrap.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetWordWrap: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.SetCancel(Boolean) Method

Summary

Represents method SetCancel(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetCancel(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.SetDefault(Boolean) Method

Summary

Represents method SetDefault(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetDefault(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.SetModalResult(TModalResult) Method

Summary

Represents method SetModalResult(TModalResult).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetModalResult(const Value: TModalResult);

Parameters

Value
Type: TModalResult

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl.SetWordWrap(Boolean) Method

Summary

Represents method SetWordWrap(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetWordWrap(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxButtonControl Fields

Fields
Name | Description
FButton | Represents field FButton.
Top


TfrxButtonControl.FButton Field

Summary

Represents field FButton.

Namespace: frxDCtrl
Syntax
Delphi
private
 FButton: TButton;

Field Value

Type: TButton

See Also

Reference

  • TfrxButtonControl
  • frxDCtrl


TfrxCheckBoxControl Class

Summary

The TfrxCheckBoxControl component represents a TCheckBox adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxCheckBoxControl
Syntax
Delphi
type
 TfrxCheckBoxControl = class(TfrxDialogControl)
 end;

The TfrxCheckBoxControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCheckBoxControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Alignment | Controls the position of the check box's caption.
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowGrayed | Determines if the check box can be in a "grayed" state.
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Represents property Caption.
CheckBox | Reference to internal TCheckBox object.
Checked | Specifies lf the check box appears checked.
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | The name of the script routine that will be called if user double clicks the control. (Inherited from TfrxDialogControl.)
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
State | Indicates if the check box is selected, deselected, or grayed.
TabStop | Represents property TabStop.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
WordWrap | Specifies if the label text wraps when it is too long for the width of the label.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetAlignment | Represents method GetAlignment.
GetAllowGrayed | Represents method GetAllowGrayed.
GetChecked | Represents method GetChecked.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetState | Represents method GetState.
GetWordWrap | Represents method GetWordWrap.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAlignment(TAlignment) | Represents method SetAlignment(TAlignment).
SetAllowGrayed(Boolean) | Represents method SetAllowGrayed(Boolean).
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetChecked(Boolean) | Represents method SetChecked(Boolean).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetState(TCheckBoxState) | Represents method SetState(TCheckBoxState).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
SetWordWrap(Boolean) | Represents method SetWordWrap(Boolean).
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCheckBox | Represents field FCheckBox.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxCheckBoxControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCheckBoxControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxCheckBoxControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCheckBoxControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl Properties

Properties
Name | Description
Alignment | Controls the position of the check box's caption.
AllowGrayed | Determines if the check box can be in a "grayed" state.
Caption | Represents property Caption.
CheckBox | Reference to internal TCheckBox object.
Checked | Specifies lf the check box appears checked.
Color | Represents property Color.
OnClick | Represents property OnClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
State | Indicates if the check box is selected, deselected, or grayed.
TabStop | Represents property TabStop.
WordWrap | Specifies if the label text wraps when it is too long for the width of the label.
Top


TfrxCheckBoxControl.Alignment Property

Summary

Controls the position of the check box's caption.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Alignment: TAlignment read GetAlignment write SetAlignment
 default taRightJustify;

Property Value

Type: TAlignment

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.AllowGrayed Property

Summary

Determines if the check box can be in a "grayed" state.

Namespace: frxDCtrl
Syntax
Delphi
published
 property AllowGrayed: Boolean read GetAllowGrayed write SetAllowGrayed default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.Caption Property

Summary

Represents property Caption.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Caption;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.CheckBox Property

Summary

Reference to internal TCheckBox object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property CheckBox: TCheckBox read FCheckBox;

Property Value

Type: TCheckBox

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.Checked Property

Summary

Specifies lf the check box appears checked.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Checked: Boolean read GetChecked write SetChecked default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.Color Property

Summary

Represents property Color.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.State Property

Summary

Indicates if the check box is selected, deselected, or grayed.

Namespace: frxDCtrl
Syntax
Delphi
published
 property State: TCheckBoxState read GetState write SetState default cbUnchecked;

Property Value

Type: TCheckBoxState

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.WordWrap Property

Summary

Specifies if the label text wraps when it is too long for the width of the label.

Namespace: frxDCtrl
Syntax
Delphi
published
 property WordWrap: Boolean read GetWordWrap write SetWordWrap default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl Methods

Methods
Name | Description
GetAlignment | Represents method GetAlignment.
GetAllowGrayed | Represents method GetAllowGrayed.
GetChecked | Represents method GetChecked.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetState | Represents method GetState.
GetWordWrap | Represents method GetWordWrap.
SetAlignment(TAlignment) | Represents method SetAlignment(TAlignment).
SetAllowGrayed(Boolean) | Represents method SetAllowGrayed(Boolean).
SetChecked(Boolean) | Represents method SetChecked(Boolean).
SetState(TCheckBoxState) | Represents method SetState(TCheckBoxState).
SetWordWrap(Boolean) | Represents method SetWordWrap(Boolean).
Top


TfrxCheckBoxControl.GetAlignment Method

Summary

Represents method GetAlignment.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetAlignment: TAlignment;

Return Value

Type: TAlignment

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.GetAllowGrayed Method

Summary

Represents method GetAllowGrayed.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetAllowGrayed: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.GetChecked Method

Summary

Represents method GetChecked.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetChecked: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.GetState Method

Summary

Represents method GetState.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetState: TCheckBoxState;

Return Value

Type: TCheckBoxState

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.GetWordWrap Method

Summary

Represents method GetWordWrap.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetWordWrap: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.SetAlignment(TAlignment) Method

Summary

Represents method SetAlignment(TAlignment).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetAlignment(const Value: TAlignment);

Parameters

Value
Type: TAlignment

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.SetAllowGrayed(Boolean) Method

Summary

Represents method SetAllowGrayed(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetAllowGrayed(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.SetChecked(Boolean) Method

Summary

Represents method SetChecked(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetChecked(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.SetState(TCheckBoxState) Method

Summary

Represents method SetState(TCheckBoxState).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetState(const Value: TCheckBoxState);

Parameters

Value
Type: TCheckBoxState

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl.SetWordWrap(Boolean) Method

Summary

Represents method SetWordWrap(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetWordWrap(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckBoxControl Fields

Fields
Name | Description
FCheckBox | Represents field FCheckBox.
Top


TfrxCheckBoxControl.FCheckBox Field

Summary

Represents field FCheckBox.

Namespace: frxDCtrl
Syntax
Delphi
private
 FCheckBox: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TfrxCheckBoxControl
  • frxDCtrl


TfrxCheckListBoxControl Class

Summary

The TfrxCheckListBoxControl component represents a TCheckListBox adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxCheckListBoxControl
Syntax
Delphi
type
 TfrxCheckListBoxControl = class(TfrxDialogControl)
 end;

The TfrxCheckListBoxControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCheckListBoxControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowGrayed | Determines if the check box can be in a "grayed" state.
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
Checked[Integer] | Represents property Checked[Integer].
CheckListBox | Reference to internal TCheckListBox object.
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
ItemIndex | Represents property ItemIndex.
Items | Contains the strings that appear in the list box.
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
Sorted | Specifies if the items in a list box are arranged alphabetically.
State[Integer] | Represents property State[Integer].
TabStop | Represents property TabStop.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetAllowGrayed | Represents method GetAllowGrayed.
GetChecked(Integer) | Represents method GetChecked(Integer).
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetItemIndex | Represents method GetItemIndex.
GetItems | Represents method GetItems.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetSorted | Represents method GetSorted.
GetState(Integer) | Represents method GetState(Integer).
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAllowGrayed(Boolean) | Represents method SetAllowGrayed(Boolean).
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetChecked(Integer,Boolean) | Represents method SetChecked(Integer,Boolean).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetItemIndex(Integer) | Represents method SetItemIndex(Integer).
SetItems(TStrings) | Represents method SetItems(TStrings).
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetSorted(Boolean) | Represents method SetSorted(Boolean).
SetState(Integer,TCheckBoxState) | Represents method SetState(Integer,TCheckBoxState).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCheckListBox | Represents field FCheckListBox.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxCheckListBoxControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCheckListBoxControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxCheckListBoxControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCheckListBoxControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl Properties

Properties
Name | Description
AllowGrayed | Determines if the check box can be in a "grayed" state.
Checked[Integer] | Represents property Checked[Integer].
CheckListBox | Reference to internal TCheckListBox object.
Color | Represents property Color.
ItemIndex | Represents property ItemIndex.
Items | Contains the strings that appear in the list box.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
Sorted | Specifies if the items in a list box are arranged alphabetically.
State[Integer] | Represents property State[Integer].
TabStop | Represents property TabStop.
Top


TfrxCheckListBoxControl.AllowGrayed Property

Summary

Determines if the check box can be in a "grayed" state.

Namespace: frxDCtrl
Syntax
Delphi
published
 property AllowGrayed: Boolean read GetAllowGrayed write SetAllowGrayed default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.Checked[Integer] Property

Summary

Represents property Checked[Integer].

Namespace: frxDCtrl
Syntax
Delphi
public
 property Checked[Index: Integer]: Boolean read GetChecked write SetChecked;

Parameters

Index
Type: Integer

Property Value

Type: Boolean

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.CheckListBox Property

Summary

Reference to internal TCheckListBox object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property CheckListBox: TCheckListBox read FCheckListBox;

Property Value

Type: TCheckListBox

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.Color Property

Summary

Represents property Color.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.ItemIndex Property

Summary

Represents property ItemIndex.

Namespace: frxDCtrl
Syntax
Delphi
public
 property ItemIndex: Integer read GetItemIndex write SetItemIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.Items Property

Summary

Contains the strings that appear in the list box.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Items: TStrings read GetItems write SetItems;

Property Value

Type: TStrings

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.Sorted Property

Summary

Specifies if the items in a list box are arranged alphabetically.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Sorted: Boolean read GetSorted write SetSorted default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.State[Integer] Property

Summary

Represents property State[Integer].

Namespace: frxDCtrl
Syntax
Delphi
public
 property State[Index: Integer]: TCheckBoxState read GetState write SetState;

Parameters

Index
Type: Integer

Property Value

Type: TCheckBoxState

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl Methods

Methods
Name | Description
GetAllowGrayed | Represents method GetAllowGrayed.
GetChecked(Integer) | Represents method GetChecked(Integer).
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetItemIndex | Represents method GetItemIndex.
GetItems | Represents method GetItems.
GetSorted | Represents method GetSorted.
GetState(Integer) | Represents method GetState(Integer).
SetAllowGrayed(Boolean) | Represents method SetAllowGrayed(Boolean).
SetChecked(Integer,Boolean) | Represents method SetChecked(Integer,Boolean).
SetItemIndex(Integer) | Represents method SetItemIndex(Integer).
SetItems(TStrings) | Represents method SetItems(TStrings).
SetSorted(Boolean) | Represents method SetSorted(Boolean).
SetState(Integer,TCheckBoxState) | Represents method SetState(Integer,TCheckBoxState).
Top


TfrxCheckListBoxControl.GetAllowGrayed Method

Summary

Represents method GetAllowGrayed.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetAllowGrayed: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.GetChecked(Integer) Method

Summary

Represents method GetChecked(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetChecked(Index: Integer): Boolean;

Parameters

Index
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.GetItemIndex Method

Summary

Represents method GetItemIndex.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetItemIndex: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.GetItems Method

Summary

Represents method GetItems.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetItems: TStrings;

Return Value

Type: TStrings

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.GetSorted Method

Summary

Represents method GetSorted.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetSorted: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.GetState(Integer) Method

Summary

Represents method GetState(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetState(Index: Integer): TCheckBoxState;

Parameters

Index
Type: Integer

Return Value

Type: TCheckBoxState

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.SetAllowGrayed(Boolean) Method

Summary

Represents method SetAllowGrayed(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetAllowGrayed(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.SetChecked(Integer,Boolean) Method

Summary

Represents method SetChecked(Integer,Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetChecked(Index: Integer; const Value: Boolean);

Parameters

Index
Type: Integer

Value
Type: Boolean

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.SetItemIndex(Integer) Method

Summary

Represents method SetItemIndex(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetItemIndex(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.SetItems(TStrings) Method

Summary

Represents method SetItems(TStrings).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetItems(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.SetSorted(Boolean) Method

Summary

Represents method SetSorted(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetSorted(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl.SetState(Integer,TCheckBoxState) Method

Summary

Represents method SetState(Integer,TCheckBoxState).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetState(Index: Integer; const Value: TCheckBoxState);

Parameters

Index
Type: Integer

Value
Type: TCheckBoxState

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxCheckListBoxControl Fields

Fields
Name | Description
FCheckListBox | Represents field FCheckListBox.
Top


TfrxCheckListBoxControl.FCheckListBox Field

Summary

Represents field FCheckListBox.

Namespace: frxDCtrl
Syntax
Delphi
private
 FCheckListBox: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TfrxCheckListBoxControl
  • frxDCtrl


TfrxComboBoxControl Class

Summary

The TfrxComboBoxControl component represents a TComboBox adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxComboBoxControl
Syntax
Delphi
type
 TfrxComboBoxControl = class(TfrxDialogControl)
 end;

The TfrxComboBoxControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxComboBoxControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
CharCase | Represents property CharCase.
Color | Represents property Color.
ComboBox | Reference to internal TComboBox object.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
ItemIndex | Represents property ItemIndex.
Items | Contains the strings that appear in the combo box.
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnChange | Name of the script procedure that will be executed when the user changes the text displayed in the edit region.
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | The name of the script routine that will be called if user pressed a mouse button. (Inherited from TfrxDialogControl.)
OnMouseMove | The name of the script routine that will be called if user moved a mouse over control. (Inherited from TfrxDialogControl.)
OnMouseUp | The name of the script routine that will be called if user released a mouse button. (Inherited from TfrxDialogControl.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
Style | Determines the display style of the combo box.
TabStop | Represents property TabStop.
Text | Represents property Text.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoOnChange(TObject) | Represents method DoOnChange(TObject).
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetCharCase | Represents method GetCharCase.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetItemIndex | Represents method GetItemIndex.
GetItems | Represents method GetItems.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetStyle | Represents method GetStyle.
GetText | Represents method GetText.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCharCase(TEditCharCase) | Represents method SetCharCase(TEditCharCase).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetItemIndex(Integer) | Represents method SetItemIndex(Integer).
SetItems(TStrings) | Represents method SetItems(TStrings).
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetStyle(TComboBoxStyle) | Represents method SetStyle(TComboBoxStyle).
SetText(String) | Represents method SetText(String).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComboBox | Represents field FComboBox.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOnChange | Represents field FOnChange.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxComboBoxControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxComboBoxControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxComboBoxControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxComboBoxControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl Properties

Properties
Name | Description
CharCase | Represents property CharCase.
Color | Represents property Color.
ComboBox | Reference to internal TComboBox object.
ItemIndex | Represents property ItemIndex.
Items | Contains the strings that appear in the combo box.
OnChange | Name of the script procedure that will be executed when the user changes the text displayed in the edit region.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
Style | Determines the display style of the combo box.
TabStop | Represents property TabStop.
Text | Represents property Text.
Top


TfrxComboBoxControl.CharCase Property

Summary

Represents property CharCase.

Namespace: frxDCtrl
Syntax
Delphi
published
 property CharCase: TEditCharCase read GetCharCase write SetCharCase default ecNormal;

Property Value

Type: TEditCharCase

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.Color Property

Summary

Represents property Color.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.ComboBox Property

Summary

Reference to internal TComboBox object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property ComboBox: TComboBox read FComboBox;

Property Value

Type: TComboBox

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.ItemIndex Property

Summary

Represents property ItemIndex.

Namespace: frxDCtrl
Syntax
Delphi
published
 property ItemIndex: Integer read GetItemIndex write SetItemIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.Items Property

Summary

Contains the strings that appear in the combo box.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Items: TStrings read GetItems write SetItems;

Property Value

Type: TStrings

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.OnChange Property

Summary

Name of the script procedure that will be executed when the user changes the text displayed in the edit region.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnChange: TfrxNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.Style Property

Summary

Determines the display style of the combo box.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Style: TComboBoxStyle read GetStyle write SetStyle default csDropDown;

Property Value

Type: TComboBoxStyle

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.Text Property

Summary

Represents property Text.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Text: String read GetText write SetText;

Property Value

Type: String

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl Methods

Methods
Name | Description
DoOnChange(TObject) | Represents method DoOnChange(TObject).
GetCharCase | Represents method GetCharCase.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetItemIndex | Represents method GetItemIndex.
GetItems | Represents method GetItems.
GetStyle | Represents method GetStyle.
GetText | Represents method GetText.
SetCharCase(TEditCharCase) | Represents method SetCharCase(TEditCharCase).
SetItemIndex(Integer) | Represents method SetItemIndex(Integer).
SetItems(TStrings) | Represents method SetItems(TStrings).
SetStyle(TComboBoxStyle) | Represents method SetStyle(TComboBoxStyle).
SetText(String) | Represents method SetText(String).
Top


TfrxComboBoxControl.DoOnChange(TObject) Method

Summary

Represents method DoOnChange(TObject).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure DoOnChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.GetCharCase Method

Summary

Represents method GetCharCase.

Namespace: frxDCtrl
Syntax
Delphi
protected
 function GetCharCase: TEditCharCase; virtual;

Return Value

Type: TEditCharCase

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.GetItemIndex Method

Summary

Represents method GetItemIndex.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetItemIndex: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.GetItems Method

Summary

Represents method GetItems.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetItems: TStrings;

Return Value

Type: TStrings

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.GetStyle Method

Summary

Represents method GetStyle.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetStyle: TComboBoxStyle;

Return Value

Type: TComboBoxStyle

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.GetText Method

Summary

Represents method GetText.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetText: String;

Return Value

Type: String

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.SetCharCase(TEditCharCase) Method

Summary

Represents method SetCharCase(TEditCharCase).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetCharCase(const Value: TEditCharCase); virtual;

Parameters

Value
Type: TEditCharCase

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.SetItemIndex(Integer) Method

Summary

Represents method SetItemIndex(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetItemIndex(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.SetItems(TStrings) Method

Summary

Represents method SetItems(TStrings).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetItems(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.SetStyle(TComboBoxStyle) Method

Summary

Represents method SetStyle(TComboBoxStyle).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetStyle(const Value: TComboBoxStyle);

Parameters

Value
Type: TComboBoxStyle

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.SetText(String) Method

Summary

Represents method SetText(String).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetText(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl Fields

Fields
Name | Description
FComboBox | Represents field FComboBox.
FOnChange | Represents field FOnChange.
Top


TfrxComboBoxControl.FComboBox Field

Summary

Represents field FComboBox.

Namespace: frxDCtrl
Syntax
Delphi
private
 FComboBox: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxComboBoxControl.FOnChange Field

Summary

Represents field FOnChange.

Namespace: frxDCtrl
Syntax
Delphi
private
 FOnChange: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxComboBoxControl
  • frxDCtrl


TfrxCustomEditControl Class

Summary

The TfrxCustomEditControl is the base class for TCustomEdit-based controls.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxCustomEditControl
frxDCtrl.TfrxEditControl
frxDCtrl.TfrxMaskEditControl
frxDCtrl.TfrxMemoControl
Syntax
Delphi
type
 TfrxCustomEditControl = class(TfrxDialogControl)
 end;

The TfrxCustomEditControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomEditControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
CharCase | Represents property CharCase.
Color | Color of the control. (Inherited from TfrxDialogControl.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
MaxLength | Specifies the maximum number of characters the user can enter into the edit control.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnChange | Name of the script procedure that will be executed when the text for the edit control may have changed.
OnClick | The name of the script routine that will be called if user clicks the control. (Inherited from TfrxDialogControl.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | The name of the script routine that will be called if user double clicks the control. (Inherited from TfrxDialogControl.)
OnEnter | The name of the script routine that will be called if control gets the focus. (Inherited from TfrxDialogControl.)
OnExit | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyDown | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyPress | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyUp | The name of the script routine that will be called if user released a key. (Inherited from TfrxDialogControl.)
OnMouseDown | The name of the script routine that will be called if user pressed a mouse button. (Inherited from TfrxDialogControl.)
OnMouseMove | The name of the script routine that will be called if user moved a mouse over control. (Inherited from TfrxDialogControl.)
OnMouseUp | The name of the script routine that will be called if user released a mouse button. (Inherited from TfrxDialogControl.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PasswordChar | Indicates the character, if any, to display in place of the actual characters typed in the control.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
ReadOnly | Determines whether the user can change the text of the edit control.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Determines if the user can tab to a control. (Inherited from TfrxDialogControl.)
Text | Contains a text string associated with the control.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoOnChange(TObject) | Represents method DoOnChange(TObject).
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetCharCase | Represents method GetCharCase.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetMaxLength | Represents method GetMaxLength.
GetPasswordChar | Represents method GetPasswordChar.
GetReadOnly | Represents method GetReadOnly.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetText | Represents method GetText.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCharCase(TEditCharCase) | Represents method SetCharCase(TEditCharCase).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetMaxLength(Integer) | Represents method SetMaxLength(Integer).
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetPasswordChar(Char) | Represents method SetPasswordChar(Char).
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean).
SetText(String) | Represents method SetText(String).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FCustomEdit | Represents field FCustomEdit.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOnChange | Represents field FOnChange.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxCustomEditControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomEditControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxCustomEditControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomEditControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl Properties

Properties
Name | Description
CharCase | Represents property CharCase.
MaxLength | Specifies the maximum number of characters the user can enter into the edit control.
OnChange | Name of the script procedure that will be executed when the text for the edit control may have changed.
PasswordChar | Indicates the character, if any, to display in place of the actual characters typed in the control.
ReadOnly | Determines whether the user can change the text of the edit control.
Text | Contains a text string associated with the control.
Top


TfrxCustomEditControl.CharCase Property

Summary

Represents property CharCase.

Namespace: frxDCtrl
Syntax
Delphi
public
 property CharCase: TEditCharCase read GetCharCase write SetCharCase default ecNormal;

Property Value

Type: TEditCharCase

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.MaxLength Property

Summary

Specifies the maximum number of characters the user can enter into the edit control.

Namespace: frxDCtrl
Syntax
Delphi
public
 property MaxLength: Integer read GetMaxLength write SetMaxLength;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.OnChange Property

Summary

Name of the script procedure that will be executed when the text for the edit control may have changed.

Namespace: frxDCtrl
Syntax
Delphi
public
 property OnChange: TfrxNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.PasswordChar Property

Summary

Indicates the character, if any, to display in place of the actual characters typed in the control.

Namespace: frxDCtrl
Syntax
Delphi
public
 property PasswordChar: Char read GetPasswordChar write SetPasswordChar;

Property Value

Type: Char

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.ReadOnly Property

Summary

Determines whether the user can change the text of the edit control.

Namespace: frxDCtrl
Syntax
Delphi
public
 property ReadOnly: Boolean read GetReadOnly write SetReadOnly default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.Text Property

Summary

Contains a text string associated with the control.

Namespace: frxDCtrl
Syntax
Delphi
public
 property Text: String read GetText write SetText;

Property Value

Type: String

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl Methods

Methods
Name | Description
DoOnChange(TObject) | Represents method DoOnChange(TObject).
GetCharCase | Represents method GetCharCase.
GetMaxLength | Represents method GetMaxLength.
GetPasswordChar | Represents method GetPasswordChar.
GetReadOnly | Represents method GetReadOnly.
GetText | Represents method GetText.
SetCharCase(TEditCharCase) | Represents method SetCharCase(TEditCharCase).
SetMaxLength(Integer) | Represents method SetMaxLength(Integer).
SetPasswordChar(Char) | Represents method SetPasswordChar(Char).
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean).
SetText(String) | Represents method SetText(String).
Top


TfrxCustomEditControl.DoOnChange(TObject) Method

Summary

Represents method DoOnChange(TObject).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure DoOnChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.GetCharCase Method

Summary

Represents method GetCharCase.

Namespace: frxDCtrl
Syntax
Delphi
protected
 function GetCharCase: TEditCharCase; virtual;

Return Value

Type: TEditCharCase

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.GetMaxLength Method

Summary

Represents method GetMaxLength.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetMaxLength: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.GetPasswordChar Method

Summary

Represents method GetPasswordChar.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetPasswordChar: Char;

Return Value

Type: Char

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.GetReadOnly Method

Summary

Represents method GetReadOnly.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetReadOnly: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.GetText Method

Summary

Represents method GetText.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetText: String;

Return Value

Type: String

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.SetCharCase(TEditCharCase) Method

Summary

Represents method SetCharCase(TEditCharCase).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetCharCase(const Value: TEditCharCase); virtual;

Parameters

Value
Type: TEditCharCase

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.SetMaxLength(Integer) Method

Summary

Represents method SetMaxLength(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetMaxLength(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.SetPasswordChar(Char) Method

Summary

Represents method SetPasswordChar(Char).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetPasswordChar(const Value: Char);

Parameters

Value
Type: Char

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.SetReadOnly(Boolean) Method

Summary

Represents method SetReadOnly(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetReadOnly(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.SetText(String) Method

Summary

Represents method SetText(String).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetText(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl Fields

Fields
Name | Description
FCustomEdit | Represents field FCustomEdit.
FOnChange | Represents field FOnChange.
Top


TfrxCustomEditControl.FCustomEdit Field

Summary

Represents field FCustomEdit.

Namespace: frxDCtrl
Syntax
Delphi
protected
 FCustomEdit: TCustomEdit;

Field Value

Type: TCustomEdit

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxCustomEditControl.FOnChange Field

Summary

Represents field FOnChange.

Namespace: frxDCtrl
Syntax
Delphi
private
 FOnChange: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxCustomEditControl
  • frxDCtrl


TfrxDateEditControl Class

Summary

The TfrxDateEditControl component represents a TDateTimePicker adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxDateEditControl
Syntax
Delphi
type
 TfrxDateEditControl = class(TfrxDialogControl)
 end;

The TfrxDateEditControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDateEditControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Date | Indicates the date that is marked on the calendar.
DateEdit | Reference to internal TDateTimePicker object.
DateFormat | Specifies format in which the date is presented.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Kind | Represents property Kind.
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnChange | Name of the script procedure that will be executed when a date or time is entered.
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | The name of the script routine that will be called if user pressed a mouse button. (Inherited from TfrxDialogControl.)
OnMouseMove | The name of the script routine that will be called if user moved a mouse over control. (Inherited from TfrxDialogControl.)
OnMouseUp | The name of the script routine that will be called if user released a mouse button. (Inherited from TfrxDialogControl.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Represents property TabStop.
Time | Represents property Time.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
WeekNumbers | Represents property WeekNumbers.
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoOnChange(TObject) | Represents method DoOnChange(TObject).
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DropDown(TObject) | Represents method DropDown(TObject).
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDate | Represents method GetDate.
GetDateFormat | Represents method GetDateFormat.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetKind | Represents method GetKind.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetTime | Represents method GetTime.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetDate(TDate) | Represents method SetDate(TDate).
SetDateFormat(TDTDateFormat) | Represents method SetDateFormat(TDTDateFormat).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetKind(TDateTimeKind) | Represents method SetKind(TDateTimeKind).
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTime(TTime) | Represents method SetTime(TTime).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FDateEdit | Represents field FDateEdit.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOnChange | Represents field FOnChange.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FWeekNumbers | Represents field FWeekNumbers.
Top
See Also

Reference

  • frxDCtrl


TfrxDateEditControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDateEditControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxDateEditControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDateEditControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl Properties

Properties
Name | Description
Color | Represents property Color.
Date | Indicates the date that is marked on the calendar.
DateEdit | Reference to internal TDateTimePicker object.
DateFormat | Specifies format in which the date is presented.
Kind | Represents property Kind.
OnChange | Name of the script procedure that will be executed when a date or time is entered.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
TabStop | Represents property TabStop.
Time | Represents property Time.
WeekNumbers | Represents property WeekNumbers.
Top


TfrxDateEditControl.Color Property

Summary

Represents property Color.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.Date Property

Summary

Indicates the date that is marked on the calendar.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Date: TDate read GetDate write SetDate;

Property Value

Type: TDate

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.DateEdit Property

Summary

Reference to internal TDateTimePicker object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property DateEdit: TDateTimePicker read FDateEdit;

Property Value

Type: TDateTimePicker

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.DateFormat Property

Summary

Specifies format in which the date is presented.

Namespace: frxDCtrl
Syntax
Delphi
published
 property DateFormat: TDTDateFormat read GetDateFormat write SetDateFormat
 default dfShort;

Property Value

Type: TDTDateFormat

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.Kind Property

Summary

Represents property Kind.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Kind: TDateTimeKind read GetKind write SetKind default dtkDate;

Property Value

Type: TDateTimeKind

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.OnChange Property

Summary

Name of the script procedure that will be executed when a date or time is entered.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnChange: TfrxNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.Time Property

Summary

Represents property Time.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Time: TTime read GetTime write SetTime;

Property Value

Type: TTime

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.WeekNumbers Property

Summary

Represents property WeekNumbers.

Namespace: frxDCtrl
Syntax
Delphi
published
 property WeekNumbers: Boolean read FWeekNumbers write FWeekNumbers;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl Methods

Methods
Name | Description
DoOnChange(TObject) | Represents method DoOnChange(TObject).
DropDown(TObject) | Represents method DropDown(TObject).
GetDate | Represents method GetDate.
GetDateFormat | Represents method GetDateFormat.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetKind | Represents method GetKind.
GetTime | Represents method GetTime.
SetDate(TDate) | Represents method SetDate(TDate).
SetDateFormat(TDTDateFormat) | Represents method SetDateFormat(TDTDateFormat).
SetKind(TDateTimeKind) | Represents method SetKind(TDateTimeKind).
SetTime(TTime) | Represents method SetTime(TTime).
Top


TfrxDateEditControl.DoOnChange(TObject) Method

Summary

Represents method DoOnChange(TObject).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure DoOnChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.DropDown(TObject) Method

Summary

Represents method DropDown(TObject).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure DropDown(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.GetDate Method

Summary

Represents method GetDate.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetDate: TDate;

Return Value

Type: TDate

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.GetDateFormat Method

Summary

Represents method GetDateFormat.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetDateFormat: TDTDateFormat;

Return Value

Type: TDTDateFormat

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.GetKind Method

Summary

Represents method GetKind.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetKind: TDateTimeKind;

Return Value

Type: TDateTimeKind

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.GetTime Method

Summary

Represents method GetTime.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetTime: TTime;

Return Value

Type: TTime

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.SetDate(TDate) Method

Summary

Represents method SetDate(TDate).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetDate(const Value: TDate);

Parameters

Value
Type: TDate

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.SetDateFormat(TDTDateFormat) Method

Summary

Represents method SetDateFormat(TDTDateFormat).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetDateFormat(const Value: TDTDateFormat);

Parameters

Value
Type: TDTDateFormat

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.SetKind(TDateTimeKind) Method

Summary

Represents method SetKind(TDateTimeKind).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetKind(const Value: TDateTimeKind);

Parameters

Value
Type: TDateTimeKind

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.SetTime(TTime) Method

Summary

Represents method SetTime(TTime).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetTime(const Value: TTime);

Parameters

Value
Type: TTime

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl Fields

Fields
Name | Description
FDateEdit | Represents field FDateEdit.
FOnChange | Represents field FOnChange.
FWeekNumbers | Represents field FWeekNumbers.
Top


TfrxDateEditControl.FDateEdit Field

Summary

Represents field FDateEdit.

Namespace: frxDCtrl
Syntax
Delphi
private
 FDateEdit: TDateTimePicker;

Field Value

Type: TDateTimePicker

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.FOnChange Field

Summary

Represents field FOnChange.

Namespace: frxDCtrl
Syntax
Delphi
private
 FOnChange: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDateEditControl.FWeekNumbers Field

Summary

Represents field FWeekNumbers.

Namespace: frxDCtrl
Syntax
Delphi
private
 FWeekNumbers: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDateEditControl
  • frxDCtrl


TfrxDialogControls Class

Summary

The TfrxDialogControls lets you use the Frdialog controls in your report. TfrxDialogControls is an empty component. It is used to add the frxDCtrl.pas file to the "uses" list.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxDCtrl.TfrxDialogControls
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxDialogControls = class(TComponent)
 end;
See Also

Reference

  • frxDCtrl


TfrxEditControl Class

Summary

The TfrxEditControl component represents a TEdit adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxCustomEditControl
frxDCtrl.TfrxEditControl
Syntax
Delphi
type
 TfrxEditControl = class(TfrxCustomEditControl)
 end;

The TfrxEditControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxEditControl class. (Overrides TfrxCustomEditControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
CharCase | Represents property CharCase.
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Edit | Reference to internal TEdit object.
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
MaxLength | Represents property MaxLength.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnChange | Represents property OnChange.
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PasswordChar | Represents property PasswordChar.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
ReadOnly | Represents property ReadOnly.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Represents property TabStop.
Text | Represents property Text.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetCharCase | Represents method GetCharCase. (Overrides TfrxCustomEditControl.GetCharCase.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCharCase(TEditCharCase) | Represents method SetCharCase(TEditCharCase). (Overrides TfrxCustomEditControl.SetCharCase(TEditCharCase).)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FCustomEdit | Represents field FCustomEdit. (Inherited from TfrxCustomEditControl.)
FEdit | Represents field FEdit.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxEditControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxEditControl class. (Overrides TfrxCustomEditControl.Create(TComponent).)
Top


TfrxEditControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxEditControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomEditControl.Create(TComponent)
See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl Properties

Properties
Name | Description
CharCase | Represents property CharCase.
Color | Represents property Color.
Edit | Reference to internal TEdit object.
MaxLength | Represents property MaxLength.
OnChange | Represents property OnChange.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
PasswordChar | Represents property PasswordChar.
ReadOnly | Represents property ReadOnly.
TabStop | Represents property TabStop.
Text | Represents property Text.
Top


TfrxEditControl.CharCase Property

Summary

Represents property CharCase.

Namespace: frxDCtrl
Syntax
Delphi
published
 property CharCase;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.Color Property

Summary

Represents property Color.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.Edit Property

Summary

Reference to internal TEdit object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property Edit: TEdit read FEdit;

Property Value

Type: TEdit

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.MaxLength Property

Summary

Represents property MaxLength.

Namespace: frxDCtrl
Syntax
Delphi
published
 property MaxLength;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.OnChange Property

Summary

Represents property OnChange.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnChange;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.PasswordChar Property

Summary

Represents property PasswordChar.

Namespace: frxDCtrl
Syntax
Delphi
published
 property PasswordChar;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: frxDCtrl
Syntax
Delphi
published
 property ReadOnly;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.Text Property

Summary

Represents property Text.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Text;

Property Value

Type: Void

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl Methods

Methods
Name | Description
GetCharCase | Represents method GetCharCase. (Overrides TfrxCustomEditControl.GetCharCase.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
SetCharCase(TEditCharCase) | Represents method SetCharCase(TEditCharCase). (Overrides TfrxCustomEditControl.SetCharCase(TEditCharCase).)
Top


TfrxEditControl.GetCharCase Method

Summary

Represents method GetCharCase.

Namespace: frxDCtrl
Syntax
Delphi
protected
 function GetCharCase: TEditCharCase; override;

Return Value

Type: TEditCharCase

Overrides

TfrxCustomEditControl.GetCharCase
See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl.SetCharCase(TEditCharCase) Method

Summary

Represents method SetCharCase(TEditCharCase).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetCharCase(const Value: TEditCharCase); override;

Parameters

Value
Type: TEditCharCase

Overrides

TfrxCustomEditControl.SetCharCase(TEditCharCase)
See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxEditControl Fields

Fields
Name | Description
FEdit | Represents field FEdit.
Top


TfrxEditControl.FEdit Field

Summary

Represents field FEdit.

Namespace: frxDCtrl
Syntax
Delphi
private
 FEdit: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxEditControl
  • frxDCtrl


TfrxGroupBoxControl Class

Summary

The TfrxGroupBoxControl component represents a TGroupBox adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxGroupBoxControl
Syntax
Delphi
type
 TfrxGroupBoxControl = class(TfrxDialogControl)
 end;

The TfrxGroupBoxControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxGroupBoxControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Represents property Caption.
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupBox | Reference to internal TGroupBox object.
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyPress | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyUp | The name of the script routine that will be called if user released a key. (Inherited from TfrxDialogControl.)
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Determines if the user can tab to a control. (Inherited from TfrxDialogControl.)
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FGroupBox | Represents field FGroupBox.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxGroupBoxControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxGroupBoxControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxGroupBoxControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxGroupBoxControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl Properties

Properties
Name | Description
Caption | Represents property Caption.
Color | Represents property Color.
GroupBox | Reference to internal TGroupBox object.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
Top


TfrxGroupBoxControl.Caption Property

Summary

Represents property Caption.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Caption;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl.Color Property

Summary

Represents property Color.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl.GroupBox Property

Summary

Reference to internal TGroupBox object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property GroupBox: TGroupBox read FGroupBox;

Property Value

Type: TGroupBox

See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl Methods

Methods
Name | Description
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended).)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
Top


TfrxGroupBoxControl.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxDCtrl
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxGroupBoxControl Fields

Fields
Name | Description
FGroupBox | Represents field FGroupBox.
Top


TfrxGroupBoxControl.FGroupBox Field

Summary

Represents field FGroupBox.

Namespace: frxDCtrl
Syntax
Delphi
private
 FGroupBox: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TfrxGroupBoxControl
  • frxDCtrl


TfrxImageControl Class

Summary

The TfrxImageControl component represents a TImage adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxImageControl
Syntax
Delphi
type
 TfrxImageControl = class(TfrxDialogControl)
 end;

The TfrxImageControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxImageControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
AutoSize | Determines whether the image control resizes to accommodate the image it displays.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
Center | Indicates whether the image is centered in the image control.
Color | Color of the control. (Inherited from TfrxDialogControl.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
Image | Reference to internal TImage object.
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | The name of the script routine that will be called if control gets the focus. (Inherited from TfrxDialogControl.)
OnExit | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyDown | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyPress | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyUp | The name of the script routine that will be called if user released a key. (Inherited from TfrxDialogControl.)
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
Picture | Specifies the image that appears on the image control.
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
Stretch | Indicates whether the image should be changed so that it exactly fits the bounds of the image control.
TabStop | Determines if the user can tab to a control. (Inherited from TfrxDialogControl.)
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetAutoSize | Represents method GetAutoSize.
GetCenter | Represents method GetCenter.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetPicture | Represents method GetPicture.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetStretch | Represents method GetStretch.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetAutoSize(Boolean) | Represents method SetAutoSize(Boolean).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCenter(Boolean) | Represents method SetCenter(Boolean).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetPicture(TPicture) | Represents method SetPicture(TPicture).
SetStretch(Boolean) | Represents method SetStretch(Boolean).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FImage | Represents field FImage.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxImageControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxImageControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxImageControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxImageControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl Properties

Properties
Name | Description
AutoSize | Determines whether the image control resizes to accommodate the image it displays.
Center | Indicates whether the image is centered in the image control.
Image | Reference to internal TImage object.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
Picture | Specifies the image that appears on the image control.
Stretch | Indicates whether the image should be changed so that it exactly fits the bounds of the image control.
Top


TfrxImageControl.AutoSize Property

Summary

Determines whether the image control resizes to accommodate the image it displays.

Namespace: frxDCtrl
Syntax
Delphi
published
 property AutoSize: Boolean read GetAutoSize write SetAutoSize default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.Center Property

Summary

Indicates whether the image is centered in the image control.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Center: Boolean read GetCenter write SetCenter default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.Image Property

Summary

Reference to internal TImage object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property Image: TImage read FImage;

Property Value

Type: TImage

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.Picture Property

Summary

Specifies the image that appears on the image control.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Picture: TPicture read GetPicture write SetPicture;

Property Value

Type: TPicture

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.Stretch Property

Summary

Indicates whether the image should be changed so that it exactly fits the bounds of the image control.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Stretch: Boolean read GetStretch write SetStretch default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl Methods

Methods
Name | Description
GetAutoSize | Represents method GetAutoSize.
GetCenter | Represents method GetCenter.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetPicture | Represents method GetPicture.
GetStretch | Represents method GetStretch.
SetAutoSize(Boolean) | Represents method SetAutoSize(Boolean).
SetCenter(Boolean) | Represents method SetCenter(Boolean).
SetPicture(TPicture) | Represents method SetPicture(TPicture).
SetStretch(Boolean) | Represents method SetStretch(Boolean).
Top


TfrxImageControl.GetAutoSize Method

Summary

Represents method GetAutoSize.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetAutoSize: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.GetCenter Method

Summary

Represents method GetCenter.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetCenter: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.GetPicture Method

Summary

Represents method GetPicture.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetPicture: TPicture;

Return Value

Type: TPicture

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.GetStretch Method

Summary

Represents method GetStretch.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetStretch: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.SetAutoSize(Boolean) Method

Summary

Represents method SetAutoSize(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetAutoSize(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.SetCenter(Boolean) Method

Summary

Represents method SetCenter(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetCenter(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.SetPicture(TPicture) Method

Summary

Represents method SetPicture(TPicture).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetPicture(const Value: TPicture);

Parameters

Value
Type: TPicture

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl.SetStretch(Boolean) Method

Summary

Represents method SetStretch(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetStretch(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxImageControl Fields

Fields
Name | Description
FImage | Represents field FImage.
Top


TfrxImageControl.FImage Field

Summary

Represents field FImage.

Namespace: frxDCtrl
Syntax
Delphi
private
 FImage: TImage;

Field Value

Type: TImage

See Also

Reference

  • TfrxImageControl
  • frxDCtrl


TfrxLabelControl Class

Summary

The TfrxLabelControl component represents a TLabel adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxLabelControl
Syntax
Delphi
type
 TfrxLabelControl = class(TfrxDialogControl)
 end;

The TfrxLabelControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxLabelControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Alignment | Controls the horizontal placement of the text within the label.
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
AutoSize | Determines whether the size of the label automatically resizes to accommodate the text.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Represents property Caption.
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LabelCtl | Reference to internal TLabel object.
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | The name of the script routine that will be called if control gets the focus. (Inherited from TfrxDialogControl.)
OnExit | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyDown | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyPress | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyUp | The name of the script routine that will be called if user released a key. (Inherited from TfrxDialogControl.)
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Determines if the user can tab to a control. (Inherited from TfrxDialogControl.)
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
WordWrap | Specifies whether the label text wraps when it is too long for the width of the label.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Overrides TfrxComponent.BeforeStartReport.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetAlignment | Represents method GetAlignment.
GetAutoSize | Represents method GetAutoSize.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetWordWrap | Represents method GetWordWrap.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAlignment(TAlignment) | Represents method SetAlignment(TAlignment).
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetAutoSize(Boolean) | Represents method SetAutoSize(Boolean).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
SetWordWrap(Boolean) | Represents method SetWordWrap(Boolean).
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLabel | Represents field FLabel.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxLabelControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxLabelControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxLabelControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxLabelControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl Properties

Properties
Name | Description
Alignment | Controls the horizontal placement of the text within the label.
AutoSize | Determines whether the size of the label automatically resizes to accommodate the text.
Caption | Represents property Caption.
Color | Represents property Color.
LabelCtl | Reference to internal TLabel object.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
WordWrap | Specifies whether the label text wraps when it is too long for the width of the label.
Top


TfrxLabelControl.Alignment Property

Summary

Controls the horizontal placement of the text within the label.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Alignment: TAlignment read GetAlignment write SetAlignment
 default taLeftJustify;

Property Value

Type: TAlignment

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.AutoSize Property

Summary

Determines whether the size of the label automatically resizes to accommodate the text.

Namespace: frxDCtrl
Syntax
Delphi
published
 property AutoSize: Boolean read GetAutoSize write SetAutoSize default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.Caption Property

Summary

Represents property Caption.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Caption;

Property Value

Type: Void

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.Color Property

Summary

Represents property Color.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.LabelCtl Property

Summary

Reference to internal TLabel object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property LabelCtl: TLabel read FLabel;

Property Value

Type: TLabel

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.WordWrap Property

Summary

Specifies whether the label text wraps when it is too long for the width of the label.

Namespace: frxDCtrl
Syntax
Delphi
published
 property WordWrap: Boolean read GetWordWrap write SetWordWrap default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl Methods

Methods
Name | Description
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Overrides TfrxComponent.BeforeStartReport.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended).)
GetAlignment | Represents method GetAlignment.
GetAutoSize | Represents method GetAutoSize.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetWordWrap | Represents method GetWordWrap.
SetAlignment(TAlignment) | Represents method SetAlignment(TAlignment).
SetAutoSize(Boolean) | Represents method SetAutoSize(Boolean).
SetWordWrap(Boolean) | Represents method SetWordWrap(Boolean).
Top


TfrxLabelControl.BeforeStartReport Method

Summary

Report engine call this method before start report preparation. Used to prepare objects before build.

Namespace: frxDCtrl
Syntax
Delphi
public
 procedure BeforeStartReport; override;

Overrides

TfrxComponent.BeforeStartReport
See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxDCtrl
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.GetAlignment Method

Summary

Represents method GetAlignment.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetAlignment: TAlignment;

Return Value

Type: TAlignment

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.GetAutoSize Method

Summary

Represents method GetAutoSize.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetAutoSize: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.GetWordWrap Method

Summary

Represents method GetWordWrap.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetWordWrap: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.SetAlignment(TAlignment) Method

Summary

Represents method SetAlignment(TAlignment).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetAlignment(const Value: TAlignment);

Parameters

Value
Type: TAlignment

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.SetAutoSize(Boolean) Method

Summary

Represents method SetAutoSize(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetAutoSize(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl.SetWordWrap(Boolean) Method

Summary

Represents method SetWordWrap(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetWordWrap(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxLabelControl Fields

Fields
Name | Description
FLabel | Represents field FLabel.
Top


TfrxLabelControl.FLabel Field

Summary

Represents field FLabel.

Namespace: frxDCtrl
Syntax
Delphi
private
 FLabel: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxLabelControl
  • frxDCtrl


TfrxListBoxControl Class

Summary

The TfrxListBoxControl component represents a TListBox adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxListBoxControl
Syntax
Delphi
type
 TfrxListBoxControl = class(TfrxDialogControl)
 end;

The TfrxListBoxControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxListBoxControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
ItemIndex | Represents property ItemIndex.
Items | Contains the strings that appear in the list box.
Left | Represents property Left. (Inherited from TfrxDialogControl.)
ListBox | Reference to internal TListBox object.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Represents property TabStop.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetItemIndex | Represents method GetItemIndex.
GetItems | Represents method GetItems.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetItemIndex(Integer) | Represents method SetItemIndex(Integer).
SetItems(TStrings) | Represents method SetItems(TStrings).
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FListBox | Represents field FListBox.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxListBoxControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxListBoxControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxListBoxControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxListBoxControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl Properties

Properties
Name | Description
Color | Represents property Color.
ItemIndex | Represents property ItemIndex.
Items | Contains the strings that appear in the list box.
ListBox | Reference to internal TListBox object.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
TabStop | Represents property TabStop.
Top


TfrxListBoxControl.Color Property

Summary

Represents property Color.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.ItemIndex Property

Summary

Represents property ItemIndex.

Namespace: frxDCtrl
Syntax
Delphi
public
 property ItemIndex: Integer read GetItemIndex write SetItemIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.Items Property

Summary

Contains the strings that appear in the list box.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Items: TStrings read GetItems write SetItems;

Property Value

Type: TStrings

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.ListBox Property

Summary

Reference to internal TListBox object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property ListBox: TListBox read FListBox;

Property Value

Type: TListBox

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl Methods

Methods
Name | Description
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetItemIndex | Represents method GetItemIndex.
GetItems | Represents method GetItems.
SetItemIndex(Integer) | Represents method SetItemIndex(Integer).
SetItems(TStrings) | Represents method SetItems(TStrings).
Top


TfrxListBoxControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.GetItemIndex Method

Summary

Represents method GetItemIndex.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetItemIndex: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.GetItems Method

Summary

Represents method GetItems.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetItems: TStrings;

Return Value

Type: TStrings

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.SetItemIndex(Integer) Method

Summary

Represents method SetItemIndex(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetItemIndex(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl.SetItems(TStrings) Method

Summary

Represents method SetItems(TStrings).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetItems(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxListBoxControl Fields

Fields
Name | Description
FListBox | Represents field FListBox.
Top


TfrxListBoxControl.FListBox Field

Summary

Represents field FListBox.

Namespace: frxDCtrl
Syntax
Delphi
private
 FListBox: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TfrxListBoxControl
  • frxDCtrl


TfrxMaskEditControl Class

Summary

The TfrxMaskEditControl component represents a TMaskEdit adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxCustomEditControl
frxDCtrl.TfrxMaskEditControl
Syntax
Delphi
type
 TfrxMaskEditControl = class(TfrxCustomEditControl)
 end;

The TfrxMaskEditControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxMaskEditControl class. (Overrides TfrxCustomEditControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
CharCase | Represents property CharCase.
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
EditMask | Specifies the mask that represents what text is valid for the masked edit control.
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
MaskEdit | Reference to internal TMaskEdit object.
MaxLength | Represents property MaxLength.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnChange | Represents property OnChange.
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PasswordChar | Indicates the character, if any, to display in place of the actual characters typed in the control. (Inherited from TfrxCustomEditControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
ReadOnly | Represents property ReadOnly.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Represents property TabStop.
Text | Represents property Text.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetCharCase | Represents method GetCharCase. (Overrides TfrxCustomEditControl.GetCharCase.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetEditMask | Represents method GetEditMask.
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCharCase(TEditCharCase) | Represents method SetCharCase(TEditCharCase). (Overrides TfrxCustomEditControl.SetCharCase(TEditCharCase).)
SetEditMask(String) | Represents method SetEditMask(String).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FCustomEdit | Represents field FCustomEdit. (Inherited from TfrxCustomEditControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FMaskEdit | Represents field FMaskEdit.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxMaskEditControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxMaskEditControl class. (Overrides TfrxCustomEditControl.Create(TComponent).)
Top


TfrxMaskEditControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxMaskEditControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomEditControl.Create(TComponent)
See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl Properties

Properties
Name | Description
CharCase | Represents property CharCase.
Color | Represents property Color.
EditMask | Specifies the mask that represents what text is valid for the masked edit control.
MaskEdit | Reference to internal TMaskEdit object.
MaxLength | Represents property MaxLength.
OnChange | Represents property OnChange.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
ReadOnly | Represents property ReadOnly.
TabStop | Represents property TabStop.
Text | Represents property Text.
Top


TfrxMaskEditControl.CharCase Property

Summary

Represents property CharCase.

Namespace: frxDCtrl
Syntax
Delphi
published
 property CharCase;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.Color Property

Summary

Represents property Color.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.EditMask Property

Summary

Specifies the mask that represents what text is valid for the masked edit control.

Namespace: frxDCtrl
Syntax
Delphi
published
 property EditMask: String read GetEditMask write SetEditMask;

Property Value

Type: String

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.MaskEdit Property

Summary

Reference to internal TMaskEdit object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property MaskEdit: TMaskEdit read FMaskEdit;

Property Value

Type: TMaskEdit

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.MaxLength Property

Summary

Represents property MaxLength.

Namespace: frxDCtrl
Syntax
Delphi
published
 property MaxLength;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.OnChange Property

Summary

Represents property OnChange.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnChange;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: frxDCtrl
Syntax
Delphi
published
 property ReadOnly;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.Text Property

Summary

Represents property Text.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Text;

Property Value

Type: Void

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl Methods

Methods
Name | Description
GetCharCase | Represents method GetCharCase. (Overrides TfrxCustomEditControl.GetCharCase.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetEditMask | Represents method GetEditMask.
SetCharCase(TEditCharCase) | Represents method SetCharCase(TEditCharCase). (Overrides TfrxCustomEditControl.SetCharCase(TEditCharCase).)
SetEditMask(String) | Represents method SetEditMask(String).
Top


TfrxMaskEditControl.GetCharCase Method

Summary

Represents method GetCharCase.

Namespace: frxDCtrl
Syntax
Delphi
protected
 function GetCharCase: TEditCharCase; override;

Return Value

Type: TEditCharCase

Overrides

TfrxCustomEditControl.GetCharCase
See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.GetEditMask Method

Summary

Represents method GetEditMask.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetEditMask: String;

Return Value

Type: String

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.SetCharCase(TEditCharCase) Method

Summary

Represents method SetCharCase(TEditCharCase).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetCharCase(const Value: TEditCharCase); override;

Parameters

Value
Type: TEditCharCase

Overrides

TfrxCustomEditControl.SetCharCase(TEditCharCase)
See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl.SetEditMask(String) Method

Summary

Represents method SetEditMask(String).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetEditMask(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMaskEditControl Fields

Fields
Name | Description
FMaskEdit | Represents field FMaskEdit.
Top


TfrxMaskEditControl.FMaskEdit Field

Summary

Represents field FMaskEdit.

Namespace: frxDCtrl
Syntax
Delphi
private
 FMaskEdit: TMaskEdit;

Field Value

Type: TMaskEdit

See Also

Reference

  • TfrxMaskEditControl
  • frxDCtrl


TfrxMemoControl Class

Summary

The TfrxMemoControl component represents a TMemo adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxCustomEditControl
frxDCtrl.TfrxMemoControl
Syntax
Delphi
type
 TfrxMemoControl = class(TfrxCustomEditControl)
 end;

The TfrxMemoControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxMemoControl class. (Overrides TfrxCustomEditControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
CharCase | Represents property CharCase.
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Lines | Contains the individual lines of text in the memo control.
MaxLength | Represents property MaxLength.
Memo | Reference to internal TMemo object.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnChange | Represents property OnChange.
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PasswordChar | Indicates the character, if any, to display in place of the actual characters typed in the control. (Inherited from TfrxCustomEditControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
ReadOnly | Represents property ReadOnly.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ScrollBars | Represents property ScrollBars.
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Represents property TabStop.
Text | Contains a text string associated with the control. (Inherited from TfrxCustomEditControl.)
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
WordWrap | Specifies whether the label text wraps when it is too long for the width of the label.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetCharCase | Represents method GetCharCase. (Overrides TfrxCustomEditControl.GetCharCase.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetLines | Represents method GetLines.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetScrollStyle | Represents method GetScrollStyle.
GetWordWrap | Represents method GetWordWrap.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetCharCase(TEditCharCase) | Represents method SetCharCase(TEditCharCase). (Overrides TfrxCustomEditControl.SetCharCase(TEditCharCase).)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetLines(TStrings) | Represents method SetLines(TStrings).
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetScrollStyle(TScrollStyle) | Represents method SetScrollStyle(TScrollStyle).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
SetWordWrap(Boolean) | Represents method SetWordWrap(Boolean).
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FCustomEdit | Represents field FCustomEdit. (Inherited from TfrxCustomEditControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FMemo | Represents field FMemo.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxMemoControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxMemoControl class. (Overrides TfrxCustomEditControl.Create(TComponent).)
Top


TfrxMemoControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxMemoControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomEditControl.Create(TComponent)
See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl Properties

Properties
Name | Description
CharCase | Represents property CharCase.
Color | Represents property Color.
Lines | Contains the individual lines of text in the memo control.
MaxLength | Represents property MaxLength.
Memo | Reference to internal TMemo object.
OnChange | Represents property OnChange.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
ReadOnly | Represents property ReadOnly.
ScrollBars | Represents property ScrollBars.
TabStop | Represents property TabStop.
WordWrap | Specifies whether the label text wraps when it is too long for the width of the label.
Top


TfrxMemoControl.CharCase Property

Summary

Represents property CharCase.

Namespace: frxDCtrl
Syntax
Delphi
published
 property CharCase;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.Color Property

Summary

Represents property Color.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.Lines Property

Summary

Contains the individual lines of text in the memo control.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Lines: TStrings read GetLines write SetLines;

Property Value

Type: TStrings

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.MaxLength Property

Summary

Represents property MaxLength.

Namespace: frxDCtrl
Syntax
Delphi
published
 property MaxLength;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.Memo Property

Summary

Reference to internal TMemo object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property Memo: TMemo read FMemo;

Property Value

Type: TMemo

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.OnChange Property

Summary

Represents property OnChange.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnChange;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: frxDCtrl
Syntax
Delphi
published
 property ReadOnly;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.ScrollBars Property

Summary

Represents property ScrollBars.

Namespace: frxDCtrl
Syntax
Delphi
published
 property ScrollBars: TScrollStyle read GetScrollStyle write SetScrollStyle default ssNone;

Property Value

Type: TScrollStyle

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.WordWrap Property

Summary

Specifies whether the label text wraps when it is too long for the width of the label.

Namespace: frxDCtrl
Syntax
Delphi
published
 property WordWrap: Boolean read GetWordWrap write SetWordWrap default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl Methods

Methods
Name | Description
GetCharCase | Represents method GetCharCase. (Overrides TfrxCustomEditControl.GetCharCase.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetLines | Represents method GetLines.
GetScrollStyle | Represents method GetScrollStyle.
GetWordWrap | Represents method GetWordWrap.
SetCharCase(TEditCharCase) | Represents method SetCharCase(TEditCharCase). (Overrides TfrxCustomEditControl.SetCharCase(TEditCharCase).)
SetLines(TStrings) | Represents method SetLines(TStrings).
SetScrollStyle(TScrollStyle) | Represents method SetScrollStyle(TScrollStyle).
SetWordWrap(Boolean) | Represents method SetWordWrap(Boolean).
Top


TfrxMemoControl.GetCharCase Method

Summary

Represents method GetCharCase.

Namespace: frxDCtrl
Syntax
Delphi
protected
 function GetCharCase: TEditCharCase; override;

Return Value

Type: TEditCharCase

Overrides

TfrxCustomEditControl.GetCharCase
See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.GetLines Method

Summary

Represents method GetLines.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetLines: TStrings;

Return Value

Type: TStrings

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.GetScrollStyle Method

Summary

Represents method GetScrollStyle.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetScrollStyle: TScrollStyle;

Return Value

Type: TScrollStyle

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.GetWordWrap Method

Summary

Represents method GetWordWrap.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetWordWrap: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.SetCharCase(TEditCharCase) Method

Summary

Represents method SetCharCase(TEditCharCase).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetCharCase(const Value: TEditCharCase); override;

Parameters

Value
Type: TEditCharCase

Overrides

TfrxCustomEditControl.SetCharCase(TEditCharCase)
See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.SetLines(TStrings) Method

Summary

Represents method SetLines(TStrings).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetLines(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.SetScrollStyle(TScrollStyle) Method

Summary

Represents method SetScrollStyle(TScrollStyle).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetScrollStyle(const Value: TScrollStyle);

Parameters

Value
Type: TScrollStyle

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl.SetWordWrap(Boolean) Method

Summary

Represents method SetWordWrap(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetWordWrap(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxMemoControl Fields

Fields
Name | Description
FMemo | Represents field FMemo.
Top


TfrxMemoControl.FMemo Field

Summary

Represents field FMemo.

Namespace: frxDCtrl
Syntax
Delphi
private
 FMemo: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TfrxMemoControl
  • frxDCtrl


TfrxOnChangingEvent Class

Summary

Represents type TfrxOnChangingEvent.

Namespace: frxDCtrl
Syntax
Delphi
type
 TfrxOnChangingEvent = type String;
See Also

Reference

  • frxDCtrl


TfrxPageControl Class

Summary

Represents type TfrxPageControl.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxPageControl
Syntax
Delphi
type
 TfrxPageControl = class(TfrxDialogControl)
 end;

The TfrxPageControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPageControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
Color | Color of the control. (Inherited from TfrxDialogControl.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
HotTrack | Represents property HotTrack.
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
MultiLine | Represents property MultiLine.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnChange | Represents property OnChange.
OnChanging | Represents property OnChanging.
OnClick | The name of the script routine that will be called if user clicks the control. (Inherited from TfrxDialogControl.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | The name of the script routine that will be called if user double clicks the control. (Inherited from TfrxDialogControl.)
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyPress | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyUp | The name of the script routine that will be called if user released a key. (Inherited from TfrxDialogControl.)
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
PageControl | Represents property PageControl.
PageCount | Represents property PageCount.
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
RaggedRight | Represents property RaggedRight.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ScrollOpposite | Represents property ScrollOpposite.
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
Style | Represents property Style.
TabHeight | Represents property TabHeight.
TabIndex | Represents property TabIndex.
TabOrder | Represents property TabOrder.
TabPosition | Represents property TabPosition.
TabStop | Represents property TabStop.
TabWidth | Represents property TabWidth.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoOnChange(TObject) | Represents method DoOnChange(TObject).
DoOnChanging(TObject,Boolean) | Represents method DoOnChanging(TObject,Boolean).
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetHotTrack | Represents method GetHotTrack.
GetMultiLine | Represents method GetMultiLine.
GetPageCount | Represents method GetPageCount.
GetRaggedRight | Represents method GetRaggedRight.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetScrollOpposite | Represents method GetScrollOpposite.
GetStyle | Represents method GetStyle.
GetTabHeight | Represents method GetTabHeight.
GetTabIndex | Represents method GetTabIndex.
GetTabOrder | Represents method GetTabOrder.
GetTabPosition | Represents method GetTabPosition.
GetTabWidth | Represents method GetTabWidth.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Overrides TfrxComponent.IsAcceptControl(TfrxComponent).)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxDialogControl.SetHeight(Extended).)
SetHotTrack(Boolean) | Represents method SetHotTrack(Boolean).
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetMultiLine(Boolean) | Represents method SetMultiLine(Boolean).
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxDialogControl.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetRaggedRight(Boolean) | Represents method SetRaggedRight(Boolean).
SetScrollOpposite(Boolean) | Represents method SetScrollOpposite(Boolean).
SetStyle(TTabStyle) | Represents method SetStyle(TTabStyle).
SetTabHeight(Smallint) | Represents method SetTabHeight(Smallint).
SetTabIndex(Integer) | Represents method SetTabIndex(Integer).
SetTabOrder(Integer) | Represents method SetTabOrder(Integer).
SetTabPosition(TTabPosition) | Represents method SetTabPosition(TTabPosition).
SetTabWidth(Smallint) | Represents method SetTabWidth(Smallint).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxDialogControl.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
UpdateSize | Represents method UpdateSize.
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOnChange | Represents field FOnChange.
FOnChanging | Represents field FOnChanging.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FPageControl | Represents field FPageControl.
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxPageControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPageControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxPageControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxPageControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl Properties

Properties
Name | Description
HotTrack | Represents property HotTrack.
MultiLine | Represents property MultiLine.
OnChange | Represents property OnChange.
OnChanging | Represents property OnChanging.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
PageControl | Represents property PageControl.
PageCount | Represents property PageCount.
RaggedRight | Represents property RaggedRight.
ScrollOpposite | Represents property ScrollOpposite.
Style | Represents property Style.
TabHeight | Represents property TabHeight.
TabIndex | Represents property TabIndex.
TabOrder | Represents property TabOrder.
TabPosition | Represents property TabPosition.
TabStop | Represents property TabStop.
TabWidth | Represents property TabWidth.
Top


TfrxPageControl.HotTrack Property

Summary

Represents property HotTrack.

Namespace: frxDCtrl
Syntax
Delphi
published
 property HotTrack: Boolean read GetHotTrack write SetHotTrack default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.MultiLine Property

Summary

Represents property MultiLine.

Namespace: frxDCtrl
Syntax
Delphi
published
 property MultiLine: Boolean read GetMultiLine write SetMultiLine default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.OnChange Property

Summary

Represents property OnChange.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnChange: TfrxNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.OnChanging Property

Summary

Represents property OnChanging.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnChanging: TfrxOnChangingEvent read FOnChanging write FOnChanging;

Property Value

Type: TfrxOnChangingEvent

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.PageControl Property

Summary

Represents property PageControl.

Namespace: frxDCtrl
Syntax
Delphi
public
 property PageControl: TPageControl read FPageControl;

Property Value

Type: TPageControl

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.PageCount Property

Summary

Represents property PageCount.

Namespace: frxDCtrl
Syntax
Delphi
public
 property PageCount: Integer read GetPageCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.RaggedRight Property

Summary

Represents property RaggedRight.

Namespace: frxDCtrl
Syntax
Delphi
published
 property RaggedRight: Boolean read GetRaggedRight write SetRaggedRight default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.ScrollOpposite Property

Summary

Represents property ScrollOpposite.

Namespace: frxDCtrl
Syntax
Delphi
published
 property ScrollOpposite: Boolean read GetScrollOpposite
 write SetScrollOpposite default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.Style Property

Summary

Represents property Style.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Style: TTabStyle read GetStyle write SetStyle default tsTabs;

Property Value

Type: TTabStyle

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.TabHeight Property

Summary

Represents property TabHeight.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabHeight: Smallint read GetTabHeight write SetTabHeight default 0;

Property Value

Type: Smallint

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.TabIndex Property

Summary

Represents property TabIndex.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabIndex: Integer read GetTabIndex write SetTabIndex stored False;

Property Value

Type: Integer

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.TabOrder Property

Summary

Represents property TabOrder.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabOrder: Integer read GetTabOrder write SetTabOrder;

Property Value

Type: Integer

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.TabPosition Property

Summary

Represents property TabPosition.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabPosition: TTabPosition read GetTabPosition write SetTabPosition
 default tpTop;

Property Value

Type: TTabPosition

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.TabWidth Property

Summary

Represents property TabWidth.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabWidth: Smallint read GetTabWidth write SetTabWidth default 0;

Property Value

Type: Smallint

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl Methods

Methods
Name | Description
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoOnChange(TObject) | Represents method DoOnChange(TObject).
DoOnChanging(TObject,Boolean) | Represents method DoOnChanging(TObject,Boolean).
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended).)
GetHotTrack | Represents method GetHotTrack.
GetMultiLine | Represents method GetMultiLine.
GetPageCount | Represents method GetPageCount.
GetRaggedRight | Represents method GetRaggedRight.
GetScrollOpposite | Represents method GetScrollOpposite.
GetStyle | Represents method GetStyle.
GetTabHeight | Represents method GetTabHeight.
GetTabIndex | Represents method GetTabIndex.
GetTabOrder | Represents method GetTabOrder.
GetTabPosition | Represents method GetTabPosition.
GetTabWidth | Represents method GetTabWidth.
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Overrides TfrxComponent.IsAcceptControl(TfrxComponent).)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxDialogControl.SetHeight(Extended).)
SetHotTrack(Boolean) | Represents method SetHotTrack(Boolean).
SetMultiLine(Boolean) | Represents method SetMultiLine(Boolean).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxDialogControl.SetParent(TfrxComponent).)
SetRaggedRight(Boolean) | Represents method SetRaggedRight(Boolean).
SetScrollOpposite(Boolean) | Represents method SetScrollOpposite(Boolean).
SetStyle(TTabStyle) | Represents method SetStyle(TTabStyle).
SetTabHeight(Smallint) | Represents method SetTabHeight(Smallint).
SetTabIndex(Integer) | Represents method SetTabIndex(Integer).
SetTabOrder(Integer) | Represents method SetTabOrder(Integer).
SetTabPosition(TTabPosition) | Represents method SetTabPosition(TTabPosition).
SetTabWidth(Smallint) | Represents method SetTabWidth(Smallint).
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxDialogControl.SetWidth(Extended).)
UpdateSize | Represents method UpdateSize.
Top


TfrxPageControl.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxDCtrl
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams)
 : Boolean; override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.DoOnChange(TObject) Method

Summary

Represents method DoOnChange(TObject).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure DoOnChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.DoOnChanging(TObject,Boolean) Method

Summary

Represents method DoOnChanging(TObject,Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure DoOnChanging(Sender: TObject; var AllowChange: Boolean);

Parameters

Sender
Type: TObject

AllowChange
Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxDCtrl
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxDialogControl.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.GetHotTrack Method

Summary

Represents method GetHotTrack.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetHotTrack: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.GetMultiLine Method

Summary

Represents method GetMultiLine.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetMultiLine: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.GetPageCount Method

Summary

Represents method GetPageCount.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetPageCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.GetRaggedRight Method

Summary

Represents method GetRaggedRight.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetRaggedRight: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.GetScrollOpposite Method

Summary

Represents method GetScrollOpposite.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetScrollOpposite: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.GetStyle Method

Summary

Represents method GetStyle.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetStyle: TTabStyle;

Return Value

Type: TTabStyle

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.GetTabHeight Method

Summary

Represents method GetTabHeight.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetTabHeight: Smallint;

Return Value

Type: Smallint

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.GetTabIndex Method

Summary

Represents method GetTabIndex.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetTabIndex: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.GetTabOrder Method

Summary

Represents method GetTabOrder.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetTabOrder: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.GetTabPosition Method

Summary

Represents method GetTabPosition.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetTabPosition: TTabPosition;

Return Value

Type: TTabPosition

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.GetTabWidth Method

Summary

Represents method GetTabWidth.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetTabWidth: Smallint;

Return Value

Type: Smallint

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.IsAcceptControl(TfrxComponent) Method

Summary

Returns true when component can accept component in aControl as child.

Namespace: frxDCtrl
Syntax
Delphi
public
 function IsAcceptControl(aControl: TfrxComponent): Boolean; override;

Parameters

aControl
Type: TfrxComponent

Component that supposedly should become a child.

Return Value

Type: Boolean

Overrides

TfrxComponent.IsAcceptControl(TfrxComponent)
See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetHeight(Extended) Method

Summary

Represents method SetHeight(Extended).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetHeight(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxDialogControl.SetHeight(Extended)
See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetHotTrack(Boolean) Method

Summary

Represents method SetHotTrack(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetHotTrack(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetMultiLine(Boolean) Method

Summary

Represents method SetMultiLine(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetMultiLine(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetParent(TfrxComponent) Method

Summary

Represents method SetParent(TfrxComponent).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetParent(AParent: TfrxComponent); override;

Parameters

AParent
Type: TfrxComponent

Overrides

TfrxDialogControl.SetParent(TfrxComponent)
See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetRaggedRight(Boolean) Method

Summary

Represents method SetRaggedRight(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetRaggedRight(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetScrollOpposite(Boolean) Method

Summary

Represents method SetScrollOpposite(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetScrollOpposite(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetStyle(TTabStyle) Method

Summary

Represents method SetStyle(TTabStyle).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetStyle(const Value: TTabStyle);

Parameters

Value
Type: TTabStyle

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetTabHeight(Smallint) Method

Summary

Represents method SetTabHeight(Smallint).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetTabHeight(const Value: Smallint);

Parameters

Value
Type: Smallint

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetTabIndex(Integer) Method

Summary

Represents method SetTabIndex(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetTabIndex(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetTabOrder(Integer) Method

Summary

Represents method SetTabOrder(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetTabOrder(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetTabPosition(TTabPosition) Method

Summary

Represents method SetTabPosition(TTabPosition).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetTabPosition(const Value: TTabPosition);

Parameters

Value
Type: TTabPosition

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetTabWidth(Smallint) Method

Summary

Represents method SetTabWidth(Smallint).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetTabWidth(const Value: Smallint);

Parameters

Value
Type: Smallint

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.SetWidth(Extended) Method

Summary

Represents method SetWidth(Extended).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetWidth(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxDialogControl.SetWidth(Extended)
See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.UpdateSize Method

Summary

Represents method UpdateSize.

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure UpdateSize;
See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl Fields

Fields
Name | Description
FOnChange | Represents field FOnChange.
FOnChanging | Represents field FOnChanging.
FPageControl | Represents field FPageControl.
Top


TfrxPageControl.FOnChange Field

Summary

Represents field FOnChange.

Namespace: frxDCtrl
Syntax
Delphi
private
 FOnChange: TfrxNotifyEvent;

Field Value

Type: TfrxNotifyEvent

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.FOnChanging Field

Summary

Represents field FOnChanging.

Namespace: frxDCtrl
Syntax
Delphi
private
 FOnChanging: TfrxOnChangingEvent;

Field Value

Type: TfrxOnChangingEvent

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPageControl.FPageControl Field

Summary

Represents field FPageControl.

Namespace: frxDCtrl
Syntax
Delphi
private
 FPageControl: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TfrxPageControl
  • frxDCtrl


TfrxPanelControl Class

Summary

The TfrxPanelControl component represents a TPanel adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxPanelControl
Syntax
Delphi
type
 TfrxPanelControl = class(TfrxDialogControl)
 end;

The TfrxPanelControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPanelControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Alignment | Determines how caption is aligned within the panel.
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BevelInner | Determines the style of the inner bevel of a panel.
BevelOuter | Determines the style of the outer bevel of a panel.
BevelWidth | Determines the width, in pixels, of both the inner and outer bevels of a panel.
Caption | Represents property Caption.
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyPress | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyUp | The name of the script routine that will be called if user released a key. (Inherited from TfrxDialogControl.)
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Panel | Reference to internal TPanel object.
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Determines if the user can tab to a control. (Inherited from TfrxDialogControl.)
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetAlignment | Represents method GetAlignment.
GetBevelInner | Represents method GetBevelInner.
GetBevelOuter | Represents method GetBevelOuter.
GetBevelWidth | Represents method GetBevelWidth.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAlignment(TAlignment) | Represents method SetAlignment(TAlignment).
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBevelInner(TPanelBevel) | Represents method SetBevelInner(TPanelBevel).
SetBevelOuter(TPanelBevel) | Represents method SetBevelOuter(TPanelBevel).
SetBevelWidth(Integer) | Represents method SetBevelWidth(Integer).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FPanel | Represents field FPanel.
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxPanelControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPanelControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxPanelControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxPanelControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl Properties

Properties
Name | Description
Alignment | Determines how caption is aligned within the panel.
BevelInner | Determines the style of the inner bevel of a panel.
BevelOuter | Determines the style of the outer bevel of a panel.
BevelWidth | Determines the width, in pixels, of both the inner and outer bevels of a panel.
Caption | Represents property Caption.
Color | Represents property Color.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
Panel | Reference to internal TPanel object.
Top


TfrxPanelControl.Alignment Property

Summary

Determines how caption is aligned within the panel.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Alignment: TAlignment read GetAlignment write SetAlignment default taCenter;

Property Value

Type: TAlignment

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.BevelInner Property

Summary

Determines the style of the inner bevel of a panel.

Namespace: frxDCtrl
Syntax
Delphi
published
 property BevelInner: TPanelBevel read GetBevelInner write SetBevelInner default bvNone;

Property Value

Type: TPanelBevel

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.BevelOuter Property

Summary

Determines the style of the outer bevel of a panel.

Namespace: frxDCtrl
Syntax
Delphi
published
 property BevelOuter: TPanelBevel read GetBevelOuter write SetBevelOuter default bvRaised;

Property Value

Type: TPanelBevel

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.BevelWidth Property

Summary

Determines the width, in pixels, of both the inner and outer bevels of a panel.

Namespace: frxDCtrl
Syntax
Delphi
published
 property BevelWidth: Integer read GetBevelWidth write SetBevelWidth default 1;

Property Value

Type: Integer

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.Caption Property

Summary

Represents property Caption.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Caption;

Property Value

Type: Void

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.Color Property

Summary

Represents property Color.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.Panel Property

Summary

Reference to internal TPanel object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property Panel: TPanel read FPanel;

Property Value

Type: TPanel

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl Methods

Methods
Name | Description
GetAlignment | Represents method GetAlignment.
GetBevelInner | Represents method GetBevelInner.
GetBevelOuter | Represents method GetBevelOuter.
GetBevelWidth | Represents method GetBevelWidth.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
SetAlignment(TAlignment) | Represents method SetAlignment(TAlignment).
SetBevelInner(TPanelBevel) | Represents method SetBevelInner(TPanelBevel).
SetBevelOuter(TPanelBevel) | Represents method SetBevelOuter(TPanelBevel).
SetBevelWidth(Integer) | Represents method SetBevelWidth(Integer).
Top


TfrxPanelControl.GetAlignment Method

Summary

Represents method GetAlignment.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetAlignment: TAlignment;

Return Value

Type: TAlignment

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.GetBevelInner Method

Summary

Represents method GetBevelInner.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetBevelInner: TPanelBevel;

Return Value

Type: TPanelBevel

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.GetBevelOuter Method

Summary

Represents method GetBevelOuter.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetBevelOuter: TPanelBevel;

Return Value

Type: TPanelBevel

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.GetBevelWidth Method

Summary

Represents method GetBevelWidth.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetBevelWidth: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.SetAlignment(TAlignment) Method

Summary

Represents method SetAlignment(TAlignment).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetAlignment(const Value: TAlignment);

Parameters

Value
Type: TAlignment

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.SetBevelInner(TPanelBevel) Method

Summary

Represents method SetBevelInner(TPanelBevel).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetBevelInner(const Value: TPanelBevel);

Parameters

Value
Type: TPanelBevel

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.SetBevelOuter(TPanelBevel) Method

Summary

Represents method SetBevelOuter(TPanelBevel).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetBevelOuter(const Value: TPanelBevel);

Parameters

Value
Type: TPanelBevel

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl.SetBevelWidth(Integer) Method

Summary

Represents method SetBevelWidth(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetBevelWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxPanelControl Fields

Fields
Name | Description
FPanel | Represents field FPanel.
Top


TfrxPanelControl.FPanel Field

Summary

Represents field FPanel.

Namespace: frxDCtrl
Syntax
Delphi
private
 FPanel: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxPanelControl
  • frxDCtrl


TfrxRadioButtonControl Class

Summary

The TfrxRadioButtonControl component represents a TRadioButton adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxRadioButtonControl
Syntax
Delphi
type
 TfrxRadioButtonControl = class(TfrxDialogControl)
 end;

The TfrxRadioButtonControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxRadioButtonControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Alignment | Controls the position of the radio button's caption.
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Represents property Caption.
Checked | Determines if the option represented by the radio button is selected.
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
RadioButton | Reference to internal TRadioButton object.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Represents property TabStop.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
WordWrap | Specifies if the label text wraps when it is too long for the width of the label.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetAlignment | Represents method GetAlignment.
GetChecked | Represents method GetChecked.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetWordWrap | Represents method GetWordWrap.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAlignment(TAlignment) | Represents method SetAlignment(TAlignment).
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetChecked(Boolean) | Represents method SetChecked(Boolean).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
SetWordWrap(Boolean) | Represents method SetWordWrap(Boolean).
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FRadioButton | Represents field FRadioButton.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxDCtrl


TfrxRadioButtonControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxRadioButtonControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxRadioButtonControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxRadioButtonControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl Properties

Properties
Name | Description
Alignment | Controls the position of the radio button's caption.
Caption | Represents property Caption.
Checked | Determines if the option represented by the radio button is selected.
Color | Represents property Color.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
RadioButton | Reference to internal TRadioButton object.
TabStop | Represents property TabStop.
WordWrap | Specifies if the label text wraps when it is too long for the width of the label.
Top


TfrxRadioButtonControl.Alignment Property

Summary

Controls the position of the radio button's caption.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Alignment: TAlignment read GetAlignment write SetAlignment
 default taRightJustify;

Property Value

Type: TAlignment

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.Caption Property

Summary

Represents property Caption.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Caption;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.Checked Property

Summary

Determines if the option represented by the radio button is selected.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Checked: Boolean read GetChecked write SetChecked default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.Color Property

Summary

Represents property Color.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.RadioButton Property

Summary

Reference to internal TRadioButton object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property RadioButton: TRadioButton read FRadioButton;

Property Value

Type: TRadioButton

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.WordWrap Property

Summary

Specifies if the label text wraps when it is too long for the width of the label.

Namespace: frxDCtrl
Syntax
Delphi
published
 property WordWrap: Boolean read GetWordWrap write SetWordWrap default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl Methods

Methods
Name | Description
GetAlignment | Represents method GetAlignment.
GetChecked | Represents method GetChecked.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetWordWrap | Represents method GetWordWrap.
SetAlignment(TAlignment) | Represents method SetAlignment(TAlignment).
SetChecked(Boolean) | Represents method SetChecked(Boolean).
SetWordWrap(Boolean) | Represents method SetWordWrap(Boolean).
Top


TfrxRadioButtonControl.GetAlignment Method

Summary

Represents method GetAlignment.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetAlignment: TAlignment;

Return Value

Type: TAlignment

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.GetChecked Method

Summary

Represents method GetChecked.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetChecked: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.GetWordWrap Method

Summary

Represents method GetWordWrap.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetWordWrap: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.SetAlignment(TAlignment) Method

Summary

Represents method SetAlignment(TAlignment).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetAlignment(const Value: TAlignment);

Parameters

Value
Type: TAlignment

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.SetChecked(Boolean) Method

Summary

Represents method SetChecked(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetChecked(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl.SetWordWrap(Boolean) Method

Summary

Represents method SetWordWrap(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetWordWrap(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxRadioButtonControl Fields

Fields
Name | Description
FRadioButton | Represents field FRadioButton.
Top


TfrxRadioButtonControl.FRadioButton Field

Summary

Represents field FRadioButton.

Namespace: frxDCtrl
Syntax
Delphi
private
 FRadioButton: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TfrxRadioButtonControl
  • frxDCtrl


TfrxSpeedButtonControl Class

Summary

The TfrxSpeedButtonControl component represents a TSpeedButton adapter.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxSpeedButtonControl
Syntax
Delphi
type
 TfrxSpeedButtonControl = class(TfrxDialogControl)
 end;

The TfrxSpeedButtonControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxSpeedButtonControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowAllUp | Specifies if all speed buttons in the group that contains this speed button can be unselected at the same time.
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Represents property Caption.
Color | Color of the control. (Inherited from TfrxDialogControl.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Down | Specifies if the button is selected (down) or unselected (up).
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Flat | Determines if the button has a 3D border that provides a raised or lowered look.
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
Glyph | Specifies the bitmap that appears on the speed button.
GroupIndex | Allows speed buttons to work together as a group.
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Layout | Determines where the image or text appears on the speed button.
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Margin | Specifies the number of pixels between the edge of the button and the image or caption drawn on its surface.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | The name of the script routine that will be called if control gets the focus. (Inherited from TfrxDialogControl.)
OnExit | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyDown | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyPress | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyUp | The name of the script routine that will be called if user released a key. (Inherited from TfrxDialogControl.)
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
Spacing | Determines where the image and text appear on a speed button
SpeedButton | Reference to internal TSpeedButton object.
TabStop | Determines if the user can tab to a control. (Inherited from TfrxDialogControl.)
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetAllowAllUp | Represents method GetAllowAllUp.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDown | Represents method GetDown.
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetFlat | Represents method GetFlat.
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetGlyph | Represents method GetGlyph.
GetGroupIndex | Represents method GetGroupIndex.
GetLayout | Represents method GetLayout.
GetMargin | Represents method GetMargin.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetSpacing | Represents method GetSpacing.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAllowAllUp(Boolean) | Represents method SetAllowAllUp(Boolean).
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetDown(Boolean) | Represents method SetDown(Boolean).
SetFlat(Boolean) | Represents method SetFlat(Boolean).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetGlyph(TBitmap) | Represents method SetGlyph(TBitmap).
SetGroupIndex(Integer) | Represents method SetGroupIndex(Integer).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLayout(TButtonLayout) | Represents method SetLayout(TButtonLayout).
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetMargin(Integer) | Represents method SetMargin(Integer).
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetSpacing(Integer) | Represents method SetSpacing(Integer).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FSpeedButton | Represents field FSpeedButton.
Top
See Also

Reference

  • frxDCtrl


TfrxSpeedButtonControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxSpeedButtonControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxSpeedButtonControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxSpeedButtonControl class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl Properties

Properties
Name | Description
AllowAllUp | Specifies if all speed buttons in the group that contains this speed button can be unselected at the same time.
Caption | Represents property Caption.
Down | Specifies if the button is selected (down) or unselected (up).
Flat | Determines if the button has a 3D border that provides a raised or lowered look.
Glyph | Specifies the bitmap that appears on the speed button.
GroupIndex | Allows speed buttons to work together as a group.
Layout | Determines where the image or text appears on the speed button.
Margin | Specifies the number of pixels between the edge of the button and the image or caption drawn on its surface.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
Spacing | Determines where the image and text appear on a speed button
SpeedButton | Reference to internal TSpeedButton object.
Top


TfrxSpeedButtonControl.AllowAllUp Property

Summary

Specifies if all speed buttons in the group that contains this speed button can be unselected at the same time.

Namespace: frxDCtrl
Syntax
Delphi
published
 property AllowAllUp: Boolean read GetAllowAllUp write SetAllowAllUp default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.Caption Property

Summary

Represents property Caption.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Caption;

Property Value

Type: Void

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.Down Property

Summary

Specifies if the button is selected (down) or unselected (up).

Namespace: frxDCtrl
Syntax
Delphi
published
 property Down: Boolean read GetDown write SetDown default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.Flat Property

Summary

Determines if the button has a 3D border that provides a raised or lowered look.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Flat: Boolean read GetFlat write SetFlat default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.Glyph Property

Summary

Specifies the bitmap that appears on the speed button.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Glyph: TBitmap read GetGlyph write SetGlyph;

Property Value

Type: TBitmap

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.GroupIndex Property

Summary

Allows speed buttons to work together as a group.

Namespace: frxDCtrl
Syntax
Delphi
published
 property GroupIndex: Integer read GetGroupIndex write SetGroupIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.Layout Property

Summary

Determines where the image or text appears on the speed button.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Layout: TButtonLayout read GetLayout write SetLayout default blGlyphLeft;

Property Value

Type: TButtonLayout

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.Margin Property

Summary

Specifies the number of pixels between the edge of the button and the image or caption drawn on its surface.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Margin: Integer read GetMargin write SetMargin default -1;

Property Value

Type: Integer

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.Spacing Property

Summary

Determines where the image and text appear on a speed button

Namespace: frxDCtrl
Syntax
Delphi
published
 property Spacing: Integer read GetSpacing write SetSpacing default 4;

Property Value

Type: Integer

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.SpeedButton Property

Summary

Reference to internal TSpeedButton object.

Namespace: frxDCtrl
Syntax
Delphi
public
 property SpeedButton: TSpeedButton read FSpeedButton;

Property Value

Type: TSpeedButton

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl Methods

Methods
Name | Description
GetAllowAllUp | Represents method GetAllowAllUp.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDown | Represents method GetDown.
GetFlat | Represents method GetFlat.
GetGlyph | Represents method GetGlyph.
GetGroupIndex | Represents method GetGroupIndex.
GetLayout | Represents method GetLayout.
GetMargin | Represents method GetMargin.
GetSpacing | Represents method GetSpacing.
SetAllowAllUp(Boolean) | Represents method SetAllowAllUp(Boolean).
SetDown(Boolean) | Represents method SetDown(Boolean).
SetFlat(Boolean) | Represents method SetFlat(Boolean).
SetGlyph(TBitmap) | Represents method SetGlyph(TBitmap).
SetGroupIndex(Integer) | Represents method SetGroupIndex(Integer).
SetLayout(TButtonLayout) | Represents method SetLayout(TButtonLayout).
SetMargin(Integer) | Represents method SetMargin(Integer).
SetSpacing(Integer) | Represents method SetSpacing(Integer).
Top


TfrxSpeedButtonControl.GetAllowAllUp Method

Summary

Represents method GetAllowAllUp.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetAllowAllUp: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDCtrl
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.GetDown Method

Summary

Represents method GetDown.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetDown: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.GetFlat Method

Summary

Represents method GetFlat.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetFlat: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.GetGlyph Method

Summary

Represents method GetGlyph.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetGlyph: TBitmap;

Return Value

Type: TBitmap

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.GetGroupIndex Method

Summary

Represents method GetGroupIndex.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetGroupIndex: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.GetLayout Method

Summary

Represents method GetLayout.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetLayout: TButtonLayout;

Return Value

Type: TButtonLayout

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.GetMargin Method

Summary

Represents method GetMargin.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetMargin: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.GetSpacing Method

Summary

Represents method GetSpacing.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetSpacing: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.SetAllowAllUp(Boolean) Method

Summary

Represents method SetAllowAllUp(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetAllowAllUp(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.SetDown(Boolean) Method

Summary

Represents method SetDown(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetDown(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.SetFlat(Boolean) Method

Summary

Represents method SetFlat(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetFlat(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.SetGlyph(TBitmap) Method

Summary

Represents method SetGlyph(TBitmap).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetGlyph(const Value: TBitmap);

Parameters

Value
Type: TBitmap

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.SetGroupIndex(Integer) Method

Summary

Represents method SetGroupIndex(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetGroupIndex(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.SetLayout(TButtonLayout) Method

Summary

Represents method SetLayout(TButtonLayout).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetLayout(const Value: TButtonLayout);

Parameters

Value
Type: TButtonLayout

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.SetMargin(Integer) Method

Summary

Represents method SetMargin(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetMargin(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl.SetSpacing(Integer) Method

Summary

Represents method SetSpacing(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetSpacing(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxSpeedButtonControl Fields

Fields
Name | Description
FSpeedButton | Represents field FSpeedButton.
Top


TfrxSpeedButtonControl.FSpeedButton Field

Summary

Represents field FSpeedButton.

Namespace: frxDCtrl
Syntax
Delphi
private
 FSpeedButton: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TfrxSpeedButtonControl
  • frxDCtrl


TfrxTabSheet Class

Summary

Represents type TfrxTabSheet.

Namespace: frxDCtrl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxDCtrl.TfrxTabSheet
Syntax
Delphi
type
 TfrxTabSheet = class(TfrxDialogControl)
 end;

The TfrxTabSheet type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTabSheet class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BorderWidth | Represents property BorderWidth.
Caption | Represents property Caption.
Color | Color of the control. (Inherited from TfrxDialogControl.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Highlighted | Represents property Highlighted.
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
ImageIndex | Represents property ImageIndex.
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | The name of the script routine that will be called if user clicks the control. (Inherited from TfrxDialogControl.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | The name of the script routine that will be called if user double clicks the control. (Inherited from TfrxDialogControl.)
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyPress | The name of the script routine that will be called if user pressed a key. (Inherited from TfrxDialogControl.)
OnKeyUp | The name of the script routine that will be called if user released a key. (Inherited from TfrxDialogControl.)
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
PageIndex | Represents property PageIndex.
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabSheet | Represents property TabSheet.
TabStop | Represents property TabStop.
TabVisible | Represents property TabVisible.
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Overrides TfrxDialogControl.CorrectControlCoordinates.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoSetParent | Represents method DoSetParent.
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetBorderWidth | Represents method GetBorderWidth.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetHighlighted | Represents method GetHighlighted.
GetImageIndex | Represents method GetImageIndex.
GetPageIndex | Represents method GetPageIndex.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
GetTabVisible | Represents method GetTabVisible.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxDialogControl.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxDialogControl.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBorderWidth(Integer) | Represents method SetBorderWidth(Integer).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxDialogControl.SetHeight(Extended).)
SetHighlighted(Boolean) | Represents method SetHighlighted(Boolean).
SetImageIndex(Integer) | Represents method SetImageIndex(Integer).
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxDialogControl.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetPageIndex(Integer) | Represents method SetPageIndex(Integer).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxDialogControl.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTabVisible(Boolean) | Represents method SetTabVisible(Boolean).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxDialogControl.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxDialogControl.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
UpdateSize | Represents method UpdateSize.
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FTabSheet | Represents field FTabSheet.
Top
See Also

Reference

  • frxDCtrl


TfrxTabSheet Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTabSheet class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxTabSheet.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxTabSheet class.

Namespace: frxDCtrl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet Properties

Properties
Name | Description
BorderWidth | Represents property BorderWidth.
Caption | Represents property Caption.
Highlighted | Represents property Highlighted.
ImageIndex | Represents property ImageIndex.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
PageIndex | Represents property PageIndex.
TabSheet | Represents property TabSheet.
TabStop | Represents property TabStop.
TabVisible | Represents property TabVisible.
Top


TfrxTabSheet.BorderWidth Property

Summary

Represents property BorderWidth.

Namespace: frxDCtrl
Syntax
Delphi
published
 property BorderWidth: Integer read GetBorderWidth write SetBorderWidth ;

Property Value

Type: Integer

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.Caption Property

Summary

Represents property Caption.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Caption;

Property Value

Type: Void

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.Highlighted Property

Summary

Represents property Highlighted.

Namespace: frxDCtrl
Syntax
Delphi
published
 property Highlighted: Boolean read GetHighlighted write SetHighlighted default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.ImageIndex Property

Summary

Represents property ImageIndex.

Namespace: frxDCtrl
Syntax
Delphi
public
 property ImageIndex: Integer read GetImageIndex write SetImageIndex default 0;

Property Value

Type: Integer

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDCtrl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.PageIndex Property

Summary

Represents property PageIndex.

Namespace: frxDCtrl
Syntax
Delphi
published
 property PageIndex: Integer read GetPageIndex write SetPageIndex stored False;

Property Value

Type: Integer

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.TabSheet Property

Summary

Represents property TabSheet.

Namespace: frxDCtrl
Syntax
Delphi
public
 property TabSheet: TTabSheet read FTabSheet;

Property Value

Type: TTabSheet

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.TabVisible Property

Summary

Represents property TabVisible.

Namespace: frxDCtrl
Syntax
Delphi
published
 property TabVisible: Boolean read GetTabVisible write SetTabVisible default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet Methods

Methods
Name | Description
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Overrides TfrxDialogControl.CorrectControlCoordinates.)
DoSetParent | Represents method DoSetParent.
GetBorderWidth | Represents method GetBorderWidth.
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetHighlighted | Represents method GetHighlighted.
GetImageIndex | Represents method GetImageIndex.
GetPageIndex | Represents method GetPageIndex.
GetTabVisible | Represents method GetTabVisible.
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxDialogControl.IsAcceptAsChild(TfrxComponent).)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxDialogControl.IsOwnerDraw.)
SetBorderWidth(Integer) | Represents method SetBorderWidth(Integer).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxDialogControl.SetHeight(Extended).)
SetHighlighted(Boolean) | Represents method SetHighlighted(Boolean).
SetImageIndex(Integer) | Represents method SetImageIndex(Integer).
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxDialogControl.SetLeft(Extended).)
SetPageIndex(Integer) | Represents method SetPageIndex(Integer).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxDialogControl.SetParent(TfrxComponent).)
SetTabVisible(Boolean) | Represents method SetTabVisible(Boolean).
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxDialogControl.SetTop(Extended).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxDialogControl.SetWidth(Extended).)
UpdateSize | Represents method UpdateSize.
Top


TfrxTabSheet.CorrectControlCoordinates Method

Summary

Represents method CorrectControlCoordinates.

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure CorrectControlCoordinates; override;

Overrides

TfrxDialogControl.CorrectControlCoordinates
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.DoSetParent Method

Summary

Represents method DoSetParent.

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure DoSetParent;
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.GetBorderWidth Method

Summary

Represents method GetBorderWidth.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetBorderWidth: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.GetContainedComponent(Extended,Extended,TfrxComponent) Method

Summary

Returns top-most object which contain point at passed coordinates

Namespace: frxDCtrl
Syntax
Delphi
public
 function GetContainedComponent(X, Y: Extended; IsCanContain: TfrxComponent = nil): TfrxComponent; override;

Parameters

X
Type: Extended

X coordinate.

Y
Type: Extended

Y coordinate.

IsCanContain
Type: TfrxComponent

Child Component. If IsCanContain = nil - returns top-most object, otherwise IsCanContain <> nil - return top-most object which can accept IsCanContain component as child.

Return Value

Type: TfrxComponent

Found component or nil.

Overrides

TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent)
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.GetHighlighted Method

Summary

Represents method GetHighlighted.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetHighlighted: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.GetImageIndex Method

Summary

Represents method GetImageIndex.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetImageIndex: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.GetPageIndex Method

Summary

Represents method GetPageIndex.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetPageIndex: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.GetTabVisible Method

Summary

Represents method GetTabVisible.

Namespace: frxDCtrl
Syntax
Delphi
private
 function GetTabVisible: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.IsAcceptAsChild(TfrxComponent) Method

Summary

Returns true when component in aParent can be accepted as parent for current.

Namespace: frxDCtrl
Syntax
Delphi
public
 function IsAcceptAsChild(aParent: TfrxComponent): Boolean; override;

Parameters

aParent
Type: TfrxComponent

Component that supposedly should become a parent for current.

Return Value

Type: Boolean

Overrides

TfrxDialogControl.IsAcceptAsChild(TfrxComponent)
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.IsContain(Extended,Extended) Method

Summary

Detects if point is inside an object coordinates.

Namespace: frxDCtrl
Syntax
Delphi
public
 function IsContain(X, Y: Extended): Boolean; override;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

Overrides

TfrxComponent.IsContain(Extended,Extended)
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.IsOwnerDraw Method

Summary

Returns True when parent container should draw child.

Namespace: frxDCtrl
Syntax
Delphi
public
 function IsOwnerDraw: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxDialogControl.IsOwnerDraw
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.SetBorderWidth(Integer) Method

Summary

Represents method SetBorderWidth(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetBorderWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.SetHeight(Extended) Method

Summary

Represents method SetHeight(Extended).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetHeight(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxDialogControl.SetHeight(Extended)
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.SetHighlighted(Boolean) Method

Summary

Represents method SetHighlighted(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetHighlighted(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.SetImageIndex(Integer) Method

Summary

Represents method SetImageIndex(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetImageIndex(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.SetLeft(Extended) Method

Summary

Represents method SetLeft(Extended).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetLeft(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxDialogControl.SetLeft(Extended)
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.SetPageIndex(Integer) Method

Summary

Represents method SetPageIndex(Integer).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetPageIndex(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.SetParent(TfrxComponent) Method

Summary

Represents method SetParent(TfrxComponent).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetParent(AParent: TfrxComponent); override;

Parameters

AParent
Type: TfrxComponent

Overrides

TfrxDialogControl.SetParent(TfrxComponent)
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.SetTabVisible(Boolean) Method

Summary

Represents method SetTabVisible(Boolean).

Namespace: frxDCtrl
Syntax
Delphi
private
 procedure SetTabVisible(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.SetTop(Extended) Method

Summary

Represents method SetTop(Extended).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetTop(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxDialogControl.SetTop(Extended)
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.SetWidth(Extended) Method

Summary

Represents method SetWidth(Extended).

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure SetWidth(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxDialogControl.SetWidth(Extended)
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet.UpdateSize Method

Summary

Represents method UpdateSize.

Namespace: frxDCtrl
Syntax
Delphi
protected
 procedure UpdateSize;
See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


TfrxTabSheet Fields

Fields
Name | Description
FTabSheet | Represents field FTabSheet.
Top


TfrxTabSheet.FTabSheet Field

Summary

Represents field FTabSheet.

Namespace: frxDCtrl
Syntax
Delphi
private
 FTabSheet: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TfrxTabSheet
  • frxDCtrl


frxDelphiMaxiCode Namespace

Summary

Represents namespace frxDelphiMaxiCode.

Classes
Name | Description
TMaxicodeEncoder | Represents type TMaxicodeEncoder.
Top


frxDelphiMaxiCode Classes

Classes
Name | Description
TMaxicodeEncoder | Represents type TMaxicodeEncoder.
Top


TMaxicodeEncoder Class

Summary

Represents type TMaxicodeEncoder.

Namespace: frxDelphiMaxiCode
Inheritance Hierarchy
TObject
frxDelphiMaxiCode.TMaxicodeEncoder
Syntax
Delphi
type
 TMaxicodeEncoder = class
 end;

The TMaxicodeEncoder type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TMaxicodeEncoder class.
Destroy | Represents the destructor of the TMaxicodeEncoder class.
Top
Properties
Show:
Name | Description
Bitmap | Represents property Bitmap.
Data | Represents property Data.
IsBlack[integer,integer] | Represents property IsBlack[integer,integer].
Mode | Represents property Mode.
Top
Methods
Show:
Name | Description
GetIsBlack(integer,integer) | Represents method GetIsBlack(integer,integer).
GetScanLine(Integer) | Represents method GetScanLine(Integer).
Height | Represents method Height.
SetData(WideString) | Represents method SetData(WideString).
SetMode(Integer) | Represents method SetMode(Integer).
Update | Represents method Update.
Width | Represents method Width.
Top
Fields
Show:
Name | Description
FBitmap | Represents field FBitmap.
FData | Represents field FData.
FMode | Represents field FMode.
Top
See Also

Reference

  • frxDelphiMaxiCode


TMaxicodeEncoder Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TMaxicodeEncoder class.
Destroy | Represents the destructor of the TMaxicodeEncoder class.
Top


TMaxicodeEncoder.Create Constructor

Summary

Initializes a new instance of the TMaxicodeEncoder class.

Namespace: frxDelphiMaxiCode
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder.Destroy Destructor

Summary

Represents the destructor of the TMaxicodeEncoder class.

Namespace: frxDelphiMaxiCode
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder Properties

Properties
Name | Description
Bitmap | Represents property Bitmap.
Data | Represents property Data.
IsBlack[integer,integer] | Represents property IsBlack[integer,integer].
Mode | Represents property Mode.
Top


TMaxicodeEncoder.Bitmap Property

Summary

Represents property Bitmap.

Namespace: frxDelphiMaxiCode
Syntax
Delphi
public
 property Bitmap: TBitmap read FBitmap;

Property Value

Type: TBitmap

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder.Data Property

Summary

Represents property Data.

Namespace: frxDelphiMaxiCode
Syntax
Delphi
public
 property Data: WideString read FData write SetData;

Property Value

Type: WideString

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder.IsBlack[integer,integer] Property

Summary

Represents property IsBlack[integer,integer].

Namespace: frxDelphiMaxiCode
Syntax
Delphi
public
 property IsBlack[Row, Column: integer]: Boolean read GetIsBlack;

Parameters

Row
Type: integer

Column
Type: integer

Property Value

Type: Boolean

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder.Mode Property

Summary

Represents property Mode.

Namespace: frxDelphiMaxiCode
Syntax
Delphi
public
 property Mode: Integer read FMode write SetMode;

Property Value

Type: Integer

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder Methods

Methods
Name | Description
GetIsBlack(integer,integer) | Represents method GetIsBlack(integer,integer).
GetScanLine(Integer) | Represents method GetScanLine(Integer).
Height | Represents method Height.
SetData(WideString) | Represents method SetData(WideString).
SetMode(Integer) | Represents method SetMode(Integer).
Update | Represents method Update.
Width | Represents method Width.
Top


TMaxicodeEncoder.GetIsBlack(integer,integer) Method

Summary

Represents method GetIsBlack(integer,integer).

Namespace: frxDelphiMaxiCode
Syntax
Delphi
private
 function GetIsBlack(Row, Column: integer): Boolean;

Parameters

Row
Type: integer

Column
Type: integer

Return Value

Type: Boolean

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder.GetScanLine(Integer) Method

Summary

Represents method GetScanLine(Integer).

Namespace: frxDelphiMaxiCode
Syntax
Delphi
public
 function GetScanLine(Column: Integer): PByteArray;

Parameters

Column
Type: Integer

Return Value

Type: PByteArray

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder.Height Method

Summary

Represents method Height.

Namespace: frxDelphiMaxiCode
Syntax
Delphi
public
 function Height: Integer;

Return Value

Type: Integer

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder.SetData(WideString) Method

Summary

Represents method SetData(WideString).

Namespace: frxDelphiMaxiCode
Syntax
Delphi
private
 procedure SetData(const Value: WideString);

Parameters

Value
Type: WideString

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder.SetMode(Integer) Method

Summary

Represents method SetMode(Integer).

Namespace: frxDelphiMaxiCode
Syntax
Delphi
private
 procedure SetMode(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder.Update Method

Summary

Represents method Update.

Namespace: frxDelphiMaxiCode
Syntax
Delphi
protected
 procedure Update;
See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder.Width Method

Summary

Represents method Width.

Namespace: frxDelphiMaxiCode
Syntax
Delphi
public
 function Width: Integer;

Return Value

Type: Integer

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder Fields

Fields
Name | Description
FBitmap | Represents field FBitmap.
FData | Represents field FData.
FMode | Represents field FMode.
Top


TMaxicodeEncoder.FBitmap Field

Summary

Represents field FBitmap.

Namespace: frxDelphiMaxiCode
Syntax
Delphi
protected
 FBitmap: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder.FData Field

Summary

Represents field FData.

Namespace: frxDelphiMaxiCode
Syntax
Delphi
private
 FData: WideString;

Field Value

Type: WideString

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


TMaxicodeEncoder.FMode Field

Summary

Represents field FMode.

Namespace: frxDelphiMaxiCode
Syntax
Delphi
private
 FMode: Integer;

Field Value

Type: Integer

See Also

Reference

  • TMaxicodeEncoder
  • frxDelphiMaxiCode


frxDelphiZXIngAztecCode Namespace

Summary

Represents namespace frxDelphiZXIngAztecCode.

Classes
Name | Description
TAztecEncoder | Represents type TAztecEncoder.
Top
Constants
Name | Description
DEFAULT_EC_PERCENT | Represents constant DEFAULT_EC_PERCENT.
Top


frxDelphiZXIngAztecCode Classes

Classes
Name | Description
TAztecEncoder | Represents type TAztecEncoder.
Top


TAztecEncoder Class

Summary

Represents type TAztecEncoder.

Namespace: frxDelphiZXIngAztecCode
Inheritance Hierarchy
TObject
frxDelphiZXIngAztecCode.TAztecEncoder
Syntax
Delphi
type
 TAztecEncoder = class
 end;

The TAztecEncoder type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TAztecEncoder class.
Top
Properties
Show:
Name | Description
Data | Represents property Data.
IsBlack[integer,integer] | Represents property IsBlack[integer,integer].
MatrixSize | Represents property MatrixSize.
MinECCPercent | Represents property MinECCPercent.
Top
Methods
Show:
Name | Description
GetIsBlack(integer,integer) | Represents method GetIsBlack(integer,integer).
SetData(WideString) | Represents method SetData(WideString).
SetMinECCPercent(integer) | Represents method SetMinECCPercent(integer).
Update | Represents method Update.
Top
Fields
Show:
Name | Description
FData | Represents field FData.
FElements | Represents field FElements.
FMatrixSize | Represents field FMatrixSize.
FMinECCPercent | Represents field FMinECCPercent.
Top
See Also

Reference

  • frxDelphiZXIngAztecCode


TAztecEncoder Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TAztecEncoder class.
Top


TAztecEncoder.Create Constructor

Summary

Initializes a new instance of the TAztecEncoder class.

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


TAztecEncoder Properties

Properties
Name | Description
Data | Represents property Data.
IsBlack[integer,integer] | Represents property IsBlack[integer,integer].
MatrixSize | Represents property MatrixSize.
MinECCPercent | Represents property MinECCPercent.
Top


TAztecEncoder.Data Property

Summary

Represents property Data.

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
public
 property Data: WideString read FData write SetData;

Property Value

Type: WideString

See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


TAztecEncoder.IsBlack[integer,integer] Property

Summary

Represents property IsBlack[integer,integer].

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
public
 property IsBlack[Row, Column: integer]: Boolean read GetIsBlack;

Parameters

Row
Type: integer

Column
Type: integer

Property Value

Type: Boolean

See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


TAztecEncoder.MatrixSize Property

Summary

Represents property MatrixSize.

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
public
 property MatrixSize: integer read FMatrixSize;

Property Value

Type: integer

See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


TAztecEncoder.MinECCPercent Property

Summary

Represents property MinECCPercent.

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
public
 property MinECCPercent: integer read FMinECCPercent write SetMinECCPercent;

Property Value

Type: integer

See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


TAztecEncoder Methods

Methods
Name | Description
GetIsBlack(integer,integer) | Represents method GetIsBlack(integer,integer).
SetData(WideString) | Represents method SetData(WideString).
SetMinECCPercent(integer) | Represents method SetMinECCPercent(integer).
Update | Represents method Update.
Top


TAztecEncoder.GetIsBlack(integer,integer) Method

Summary

Represents method GetIsBlack(integer,integer).

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
private
 function GetIsBlack(Row, Column: integer): Boolean;

Parameters

Row
Type: integer

Column
Type: integer

Return Value

Type: Boolean

See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


TAztecEncoder.SetData(WideString) Method

Summary

Represents method SetData(WideString).

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
private
 procedure SetData(const Value: WideString);

Parameters

Value
Type: WideString

See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


TAztecEncoder.SetMinECCPercent(integer) Method

Summary

Represents method SetMinECCPercent(integer).

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
private
 procedure SetMinECCPercent(const Value: integer);

Parameters

Value
Type: integer

See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


TAztecEncoder.Update Method

Summary

Represents method Update.

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
protected
 procedure Update;
See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


TAztecEncoder Fields

Fields
Name | Description
FData | Represents field FData.
FElements | Represents field FElements.
FMatrixSize | Represents field FMatrixSize.
FMinECCPercent | Represents field FMinECCPercent.
Top


TAztecEncoder.FData Field

Summary

Represents field FData.

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
private
 FData: WideString;

Field Value

Type: WideString

See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


TAztecEncoder.FElements Field

Summary

Represents field FElements.

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
public
 FElements: T2DBooleanArray;

Field Value

Type: T2DBooleanArray

See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


TAztecEncoder.FMatrixSize Field

Summary

Represents field FMatrixSize.

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
private
 FMatrixSize: integer;

Field Value

Type: integer

See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


TAztecEncoder.FMinECCPercent Field

Summary

Represents field FMinECCPercent.

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
private
 FMinECCPercent: integer;

Field Value

Type: integer

See Also

Reference

  • TAztecEncoder
  • frxDelphiZXIngAztecCode


frxDelphiZXIngAztecCode Constants

Constants
Name | Description
DEFAULT_EC_PERCENT | Represents constant DEFAULT_EC_PERCENT.
Top


DEFAULT_EC_PERCENT Constant

Summary

Represents constant DEFAULT_EC_PERCENT.

Namespace: frxDelphiZXIngAztecCode
Syntax
Delphi
 DEFAULT_EC_PERCENT = 33;

Value

Type: ShortInt

See Also

Reference

  • frxDelphiZXIngAztecCode


frxDelphiZXIngCode Namespace

Summary

Represents namespace frxDelphiZXIngCode.

Classes
Name | Description
TBitArray | Represents type TBitArray.
TGenericGF | Represents type TGenericGF.
TGenericGFPoly | Represents type TGenericGFPoly.
TReedSolomonEncoder | Represents type TReedSolomonEncoder.
Top
Types
Name | Description
TByteArray | Represents an array of the Byte type.
TGenericGFPolyArray | Represents an array of the TGenericGFPoly type.
TIntegerArray | Represents an array of the Integer type.
Top
Routines
Name | Description
FreeAndSetBitArray(TBitArray,TBitArray) | Represents method FreeAndSetBitArray(TBitArray,TBitArray).
IfValue(Boolean,AnsiChar,AnsiChar) | Overloaded. Represents method IfValue(Boolean,AnsiChar,AnsiChar).
IfValue(Boolean,Integer,Integer) | Overloaded. Represents method IfValue(Boolean,Integer,Integer).
IfValue(Boolean,string,string) | Overloaded. Represents method IfValue(Boolean,string,string).
Top


frxDelphiZXingCode Classes

Classes
Name | Description
TBitArray | Represents type TBitArray.
TGenericGF | Represents type TGenericGF.
TGenericGFPoly | Represents type TGenericGFPoly.
TReedSolomonEncoder | Represents type TReedSolomonEncoder.
Top


TBitArray Class

Summary

Represents type TBitArray.

Namespace: frxDelphiZXIngCode
Inheritance Hierarchy
TObject
frxDelphiZXIngCode.TBitArray
Syntax
Delphi
type
 TBitArray = class
 end;

The TBitArray type exposes the following members.

Constructors
Show:
Name | Description
Create | Overloaded. Initializes a new instance of the TBitArray class.
Create(Integer) | Overloaded. Initializes a new instance of the TBitArray class.
Top
Properties
Show:
Name | Description
Item[Integer] | Represents property Item[Integer].
Size | Represents property Size.
Top
Methods
Show:
Name | Description
AppendBit(Boolean) | Represents method AppendBit(Boolean).
AppendBitArray(TBitArray) | Represents method AppendBitArray(TBitArray).
AppendBits(Integer,Integer) | Represents method AppendBits(Integer,Integer).
Clear | Represents method Clear.
EnsureCapacity(Integer) | Represents method EnsureCapacity(Integer).
Get(Integer) | Represents method Get(Integer).
GetSize | Represents method GetSize.
GetSizeInBytes | Represents method GetSizeInBytes.
SetBit(Integer) | Represents method SetBit(Integer).
SetItem(Integer,Boolean) | Represents method SetItem(Integer,Boolean).
ToBytes(Integer,TByteArray,Integer,Integer) | Represents method ToBytes(Integer,TByteArray,Integer,Integer).
ToString | Represents method ToString.
XorOperation(TBitArray) | Represents method XorOperation(TBitArray).
Top
Fields
Show:
Name | Description
Bits | Represents field Bits.
FSize | Represents field FSize.
Top
See Also

Reference

  • frxDelphiZXIngCode


TBitArray Constructors

Constructors
Name | Description
Create | Overloaded. Initializes a new instance of the TBitArray class.
Create(Integer) | Overloaded. Initializes a new instance of the TBitArray class.
Top


TBitArray.Create Constructor

Summary

Initializes a new instance of the TBitArray class.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 constructor Create; overload;
See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.Create(Integer) Constructor

Summary

Initializes a new instance of the TBitArray class.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 constructor Create(const Size: Integer); overload;

Parameters

Size
Type: Integer

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray Properties

Properties
Name | Description
Item[Integer] | Represents property Item[Integer].
Size | Represents property Size.
Top


TBitArray.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 property Item[i: Integer]: Boolean read Get write SetItem; default;

Parameters

i
Type: Integer

Property Value

Type: Boolean

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.Size Property

Summary

Represents property Size.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 property Size: Integer read FSize;

Property Value

Type: Integer

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray Methods

Methods
Name | Description
AppendBit(Boolean) | Represents method AppendBit(Boolean).
AppendBitArray(TBitArray) | Represents method AppendBitArray(TBitArray).
AppendBits(Integer,Integer) | Represents method AppendBits(Integer,Integer).
Clear | Represents method Clear.
EnsureCapacity(Integer) | Represents method EnsureCapacity(Integer).
Get(Integer) | Represents method Get(Integer).
GetSize | Represents method GetSize.
GetSizeInBytes | Represents method GetSizeInBytes.
SetBit(Integer) | Represents method SetBit(Integer).
SetItem(Integer,Boolean) | Represents method SetItem(Integer,Boolean).
ToBytes(Integer,TByteArray,Integer,Integer) | Represents method ToBytes(Integer,TByteArray,Integer,Integer).
ToString | Represents method ToString.
XorOperation(TBitArray) | Represents method XorOperation(TBitArray).
Top


TBitArray.AppendBit(Boolean) Method

Summary

Represents method AppendBit(Boolean).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 procedure AppendBit(Bit: Boolean);

Parameters

Bit
Type: Boolean

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.AppendBitArray(TBitArray) Method

Summary

Represents method AppendBitArray(TBitArray).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 procedure AppendBitArray(NewBitArray: TBitArray);

Parameters

NewBitArray
Type: TBitArray

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.AppendBits(Integer,Integer) Method

Summary

Represents method AppendBits(Integer,Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 procedure AppendBits(Value, NumBits: Integer);

Parameters

Value
Type: Integer

NumBits
Type: Integer

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.Clear Method

Summary

Represents method Clear.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.EnsureCapacity(Integer) Method

Summary

Represents method EnsureCapacity(Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
protected
 procedure EnsureCapacity(Size: Integer);

Parameters

Size
Type: Integer

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.Get(Integer) Method

Summary

Represents method Get(Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function Get(i: Integer): Boolean;

Parameters

i
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.GetSize Method

Summary

Represents method GetSize.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function GetSize: Integer;

Return Value

Type: Integer

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.GetSizeInBytes Method

Summary

Represents method GetSizeInBytes.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function GetSizeInBytes: Integer;

Return Value

Type: Integer

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.SetBit(Integer) Method

Summary

Represents method SetBit(Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 procedure SetBit(Index: Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.SetItem(Integer,Boolean) Method

Summary

Represents method SetItem(Integer,Boolean).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 procedure SetItem(i: Integer; const Value: Boolean);

Parameters

i
Type: Integer

Value
Type: Boolean

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.ToBytes(Integer,TByteArray,Integer,Integer) Method

Summary

Represents method ToBytes(Integer,TByteArray,Integer,Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 procedure ToBytes(BitOffset: Integer; Source: TByteArray;
 Offset, NumBytes: Integer);

Parameters

BitOffset
Type: Integer

Source
Type: TByteArray

Offset
Type: Integer

NumBytes
Type: Integer

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.ToString Method

Summary

Represents method ToString.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function ToString: string; override;

Return Value

Type: string

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.XorOperation(TBitArray) Method

Summary

Represents method XorOperation(TBitArray).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 procedure XorOperation(Other: TBitArray);

Parameters

Other
Type: TBitArray

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray Fields

Fields
Name | Description
Bits | Represents field Bits.
FSize | Represents field FSize.
Top


TBitArray.Bits Field

Summary

Represents field Bits.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 Bits: array of Integer;

Field Value

Type: array of Integer

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TBitArray.FSize Field

Summary

Represents field FSize.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TBitArray
  • frxDelphiZXIngCode


TGenericGF Class

Summary

Represents type TGenericGF.

Namespace: frxDelphiZXIngCode
Inheritance Hierarchy
TObject
frxDelphiZXIngCode.TGenericGF
Syntax
Delphi
type
 TGenericGF = class
 end;

The TGenericGF type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer,Integer,Integer) | Initializes a new instance of the TGenericGF class.
Destroy | Represents the destructor of the TGenericGF class.
Top
Methods
Show:
Name | Description
AddOrSubtract(Integer,Integer) | Represents method AddOrSubtract(Integer,Integer).
BuildMonomial(Integer,Integer) | Represents method BuildMonomial(Integer,Integer).
CheckInit | Represents method CheckInit.
CreateAztecData10 | Represents method CreateAztecData10.
CreateAztecData12 | Represents method CreateAztecData12.
CreateAztecData6 | Represents method CreateAztecData6.
CreateAztecData8 | Represents method CreateAztecData8.
CreateAztecParam | Represents method CreateAztecParam.
CreateMatrixField256 | Represents method CreateMatrixField256.
CreateMaxicodeField64 | Represents method CreateMaxicodeField64.
CreateQRCodeField256 | Represents method CreateQRCodeField256.
Exp(Integer) | Represents method Exp(Integer).
GetGeneratorBase | Represents method GetGeneratorBase.
GetZero | Represents method GetZero.
Initialize | Represents method Initialize.
Inverse(Integer) | Represents method Inverse(Integer).
Multiply(Integer,Integer) | Represents method Multiply(Integer,Integer).
Top
Fields
Show:
Name | Description
FExpTable | Represents field FExpTable.
FGeneratorBase | Represents field FGeneratorBase.
FInitialized | Represents field FInitialized.
FLogTable | Represents field FLogTable.
FOne | Represents field FOne.
FPolyList | Represents field FPolyList.
FPrimitive | Represents field FPrimitive.
FSize | Represents field FSize.
FZero | Represents field FZero.
Top
See Also

Reference

  • frxDelphiZXIngCode


TGenericGF Constructors

Constructors
Name | Description
Create(Integer,Integer,Integer) | Initializes a new instance of the TGenericGF class.
Destroy | Represents the destructor of the TGenericGF class.
Top


TGenericGF.Create(Integer,Integer,Integer) Constructor

Summary

Initializes a new instance of the TGenericGF class.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 constructor Create(Primitive, Size, B: Integer);

Parameters

Primitive
Type: Integer

Size
Type: Integer

B
Type: Integer

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.Destroy Destructor

Summary

Represents the destructor of the TGenericGF class.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF Methods

Methods
Name | Description
AddOrSubtract(Integer,Integer) | Represents method AddOrSubtract(Integer,Integer).
BuildMonomial(Integer,Integer) | Represents method BuildMonomial(Integer,Integer).
CheckInit | Represents method CheckInit.
CreateAztecData10 | Represents method CreateAztecData10.
CreateAztecData12 | Represents method CreateAztecData12.
CreateAztecData6 | Represents method CreateAztecData6.
CreateAztecData8 | Represents method CreateAztecData8.
CreateAztecParam | Represents method CreateAztecParam.
CreateMatrixField256 | Represents method CreateMatrixField256.
CreateMaxicodeField64 | Represents method CreateMaxicodeField64.
CreateQRCodeField256 | Represents method CreateQRCodeField256.
Exp(Integer) | Represents method Exp(Integer).
GetGeneratorBase | Represents method GetGeneratorBase.
GetZero | Represents method GetZero.
Initialize | Represents method Initialize.
Inverse(Integer) | Represents method Inverse(Integer).
Multiply(Integer,Integer) | Represents method Multiply(Integer,Integer).
Top


TGenericGF.AddOrSubtract(Integer,Integer) Method

Summary

Represents method AddOrSubtract(Integer,Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 class function AddOrSubtract(A, B: Integer): Integer;

Parameters

A
Type: Integer

B
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.BuildMonomial(Integer,Integer) Method

Summary

Represents method BuildMonomial(Integer,Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function BuildMonomial(Degree, Coefficient: Integer): TGenericGFPoly;

Parameters

Degree
Type: Integer

Coefficient
Type: Integer

Return Value

Type: TGenericGFPoly

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.CheckInit Method

Summary

Represents method CheckInit.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 procedure CheckInit;
See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.CreateAztecData10 Method

Summary

Represents method CreateAztecData10.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 class function CreateAztecData10: TGenericGF;

Return Value

Type: TGenericGF

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.CreateAztecData12 Method

Summary

Represents method CreateAztecData12.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 class function CreateAztecData12: TGenericGF;

Return Value

Type: TGenericGF

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.CreateAztecData6 Method

Summary

Represents method CreateAztecData6.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 class function CreateAztecData6: TGenericGF;

Return Value

Type: TGenericGF

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.CreateAztecData8 Method

Summary

Represents method CreateAztecData8.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 class function CreateAztecData8: TGenericGF;

Return Value

Type: TGenericGF

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.CreateAztecParam Method

Summary

Represents method CreateAztecParam.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 class function CreateAztecParam: TGenericGF;

Return Value

Type: TGenericGF

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.CreateMatrixField256 Method

Summary

Represents method CreateMatrixField256.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 class function CreateMatrixField256: TGenericGF;

Return Value

Type: TGenericGF

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.CreateMaxicodeField64 Method

Summary

Represents method CreateMaxicodeField64.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 class function CreateMaxicodeField64: TGenericGF;

Return Value

Type: TGenericGF

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.CreateQRCodeField256 Method

Summary

Represents method CreateQRCodeField256.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 class function CreateQRCodeField256: TGenericGF;

Return Value

Type: TGenericGF

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.Exp(Integer) Method

Summary

Represents method Exp(Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function Exp(A: Integer): Integer;

Parameters

A
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.GetGeneratorBase Method

Summary

Represents method GetGeneratorBase.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function GetGeneratorBase: Integer;

Return Value

Type: Integer

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.GetZero Method

Summary

Represents method GetZero.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function GetZero: TGenericGFPoly;

Return Value

Type: TGenericGFPoly

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.Initialize Method

Summary

Represents method Initialize.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 procedure Initialize;
See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.Inverse(Integer) Method

Summary

Represents method Inverse(Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function Inverse(A: Integer): Integer;

Parameters

A
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.Multiply(Integer,Integer) Method

Summary

Represents method Multiply(Integer,Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function Multiply(A, B: Integer): Integer;

Parameters

A
Type: Integer

B
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF Fields

Fields
Name | Description
FExpTable | Represents field FExpTable.
FGeneratorBase | Represents field FGeneratorBase.
FInitialized | Represents field FInitialized.
FLogTable | Represents field FLogTable.
FOne | Represents field FOne.
FPolyList | Represents field FPolyList.
FPrimitive | Represents field FPrimitive.
FSize | Represents field FSize.
FZero | Represents field FZero.
Top


TGenericGF.FExpTable Field

Summary

Represents field FExpTable.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FExpTable: TIntegerArray;

Field Value

Type: TIntegerArray

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.FGeneratorBase Field

Summary

Represents field FGeneratorBase.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FGeneratorBase: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.FInitialized Field

Summary

Represents field FInitialized.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FInitialized: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.FLogTable Field

Summary

Represents field FLogTable.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FLogTable: TIntegerArray;

Field Value

Type: TIntegerArray

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.FOne Field

Summary

Represents field FOne.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FOne: TGenericGFPoly;

Field Value

Type: TGenericGFPoly

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.FPolyList Field

Summary

Represents field FPolyList.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FPolyList: array of TGenericGFPoly;

Field Value

Type: array of TGenericGFPoly

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.FPrimitive Field

Summary

Represents field FPrimitive.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FPrimitive: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.FSize Field

Summary

Represents field FSize.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGF.FZero Field

Summary

Represents field FZero.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FZero: TGenericGFPoly;

Field Value

Type: TGenericGFPoly

See Also

Reference

  • TGenericGF
  • frxDelphiZXIngCode


TGenericGFPoly Class

Summary

Represents type TGenericGFPoly.

Namespace: frxDelphiZXIngCode
Inheritance Hierarchy
TObject
frxDelphiZXIngCode.TGenericGFPoly
Syntax
Delphi
type
 TGenericGFPoly = class
 end;

The TGenericGFPoly type exposes the following members.

Constructors
Show:
Name | Description
Create(TGenericGF,TIntegerArray) | Initializes a new instance of the TGenericGFPoly class.
Destroy | Represents the destructor of the TGenericGFPoly class.
Top
Methods
Show:
Name | Description
AddOrSubtract(TGenericGFPoly) | Represents method AddOrSubtract(TGenericGFPoly).
Coefficients | Represents method Coefficients.
Divide(TGenericGFPoly) | Represents method Divide(TGenericGFPoly).
GetCoefficient(Integer) | Represents method GetCoefficient(Integer).
GetCoefficients | Represents method GetCoefficients.
GetDegree | Represents method GetDegree.
IsZero | Represents method IsZero.
Multiply(TGenericGFPoly) | Represents method Multiply(TGenericGFPoly).
MultiplyByMonomial(Integer,Integer) | Represents method MultiplyByMonomial(Integer,Integer).
Top
Fields
Show:
Name | Description
FCoefficients | Represents field FCoefficients.
FField | Represents field FField.
Top
See Also

Reference

  • frxDelphiZXIngCode


TGenericGFPoly Constructors

Constructors
Name | Description
Create(TGenericGF,TIntegerArray) | Initializes a new instance of the TGenericGFPoly class.
Destroy | Represents the destructor of the TGenericGFPoly class.
Top


TGenericGFPoly.Create(TGenericGF,TIntegerArray) Constructor

Summary

Initializes a new instance of the TGenericGFPoly class.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 constructor Create(AField: TGenericGF; ACoefficients: TIntegerArray);

Parameters

AField
Type: TGenericGF

ACoefficients
Type: TIntegerArray

See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TGenericGFPoly.Destroy Destructor

Summary

Represents the destructor of the TGenericGFPoly class.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TGenericGFPoly Methods

Methods
Name | Description
AddOrSubtract(TGenericGFPoly) | Represents method AddOrSubtract(TGenericGFPoly).
Coefficients | Represents method Coefficients.
Divide(TGenericGFPoly) | Represents method Divide(TGenericGFPoly).
GetCoefficient(Integer) | Represents method GetCoefficient(Integer).
GetCoefficients | Represents method GetCoefficients.
GetDegree | Represents method GetDegree.
IsZero | Represents method IsZero.
Multiply(TGenericGFPoly) | Represents method Multiply(TGenericGFPoly).
MultiplyByMonomial(Integer,Integer) | Represents method MultiplyByMonomial(Integer,Integer).
Top


TGenericGFPoly.AddOrSubtract(TGenericGFPoly) Method

Summary

Represents method AddOrSubtract(TGenericGFPoly).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function AddOrSubtract(Other: TGenericGFPoly): TGenericGFPoly;

Parameters

Other
Type: TGenericGFPoly

Return Value

Type: TGenericGFPoly

See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TGenericGFPoly.Coefficients Method

Summary

Represents method Coefficients.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function Coefficients: TIntegerArray;

Return Value

Type: TIntegerArray

See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TGenericGFPoly.Divide(TGenericGFPoly) Method

Summary

Represents method Divide(TGenericGFPoly).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function Divide(Other: TGenericGFPoly): TGenericGFPolyArray;

Parameters

Other
Type: TGenericGFPoly

Return Value

Type: TGenericGFPolyArray

See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TGenericGFPoly.GetCoefficient(Integer) Method

Summary

Represents method GetCoefficient(Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function GetCoefficient(Degree: Integer): Integer;

Parameters

Degree
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TGenericGFPoly.GetCoefficients Method

Summary

Represents method GetCoefficients.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function GetCoefficients: TIntegerArray;

Return Value

Type: TIntegerArray

See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TGenericGFPoly.GetDegree Method

Summary

Represents method GetDegree.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function GetDegree: Integer;

Return Value

Type: Integer

See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TGenericGFPoly.IsZero Method

Summary

Represents method IsZero.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function IsZero: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TGenericGFPoly.Multiply(TGenericGFPoly) Method

Summary

Represents method Multiply(TGenericGFPoly).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function Multiply(Other: TGenericGFPoly): TGenericGFPoly;

Parameters

Other
Type: TGenericGFPoly

Return Value

Type: TGenericGFPoly

See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TGenericGFPoly.MultiplyByMonomial(Integer,Integer) Method

Summary

Represents method MultiplyByMonomial(Integer,Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function MultiplyByMonomial(Degree, Coefficient: Integer): TGenericGFPoly;

Parameters

Degree
Type: Integer

Coefficient
Type: Integer

Return Value

Type: TGenericGFPoly

See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TGenericGFPoly Fields

Fields
Name | Description
FCoefficients | Represents field FCoefficients.
FField | Represents field FField.
Top


TGenericGFPoly.FCoefficients Field

Summary

Represents field FCoefficients.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FCoefficients: TIntegerArray;

Field Value

Type: TIntegerArray

See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TGenericGFPoly.FField Field

Summary

Represents field FField.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FField: TGenericGF;

Field Value

Type: TGenericGF

See Also

Reference

  • TGenericGFPoly
  • frxDelphiZXIngCode


TReedSolomonEncoder Class

Summary

Represents type TReedSolomonEncoder.

Namespace: frxDelphiZXIngCode
Inheritance Hierarchy
TObject
frxDelphiZXIngCode.TReedSolomonEncoder
Syntax
Delphi
type
 TReedSolomonEncoder = class
 end;

The TReedSolomonEncoder type exposes the following members.

Constructors
Show:
Name | Description
Create(TGenericGF) | Initializes a new instance of the TReedSolomonEncoder class.
Destroy | Represents the destructor of the TReedSolomonEncoder class.
Top
Methods
Show:
Name | Description
BuildGenerator(Integer) | Represents method BuildGenerator(Integer).
Encode(TIntegerArray,Integer) | Represents method Encode(TIntegerArray,Integer).
Top
Fields
Show:
Name | Description
FCachedGenerators | Represents field FCachedGenerators.
FField | Represents field FField.
Top
See Also

Reference

  • frxDelphiZXIngCode


TReedSolomonEncoder Constructors

Constructors
Name | Description
Create(TGenericGF) | Initializes a new instance of the TReedSolomonEncoder class.
Destroy | Represents the destructor of the TReedSolomonEncoder class.
Top


TReedSolomonEncoder.Create(TGenericGF) Constructor

Summary

Initializes a new instance of the TReedSolomonEncoder class.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 constructor Create(AField: TGenericGF);

Parameters

AField
Type: TGenericGF

See Also

Reference

  • TReedSolomonEncoder
  • frxDelphiZXIngCode


TReedSolomonEncoder.Destroy Destructor

Summary

Represents the destructor of the TReedSolomonEncoder class.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TReedSolomonEncoder
  • frxDelphiZXIngCode


TReedSolomonEncoder Methods

Methods
Name | Description
BuildGenerator(Integer) | Represents method BuildGenerator(Integer).
Encode(TIntegerArray,Integer) | Represents method Encode(TIntegerArray,Integer).
Top


TReedSolomonEncoder.BuildGenerator(Integer) Method

Summary

Represents method BuildGenerator(Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 function BuildGenerator(Degree: Integer): TGenericGFPoly;

Parameters

Degree
Type: Integer

Return Value

Type: TGenericGFPoly

See Also

Reference

  • TReedSolomonEncoder
  • frxDelphiZXIngCode


TReedSolomonEncoder.Encode(TIntegerArray,Integer) Method

Summary

Represents method Encode(TIntegerArray,Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
public
 procedure Encode(ToEncode: TIntegerArray; ECBytes: Integer);

Parameters

ToEncode
Type: TIntegerArray

ECBytes
Type: Integer

See Also

Reference

  • TReedSolomonEncoder
  • frxDelphiZXIngCode


TReedSolomonEncoder Fields

Fields
Name | Description
FCachedGenerators | Represents field FCachedGenerators.
FField | Represents field FField.
Top


TReedSolomonEncoder.FCachedGenerators Field

Summary

Represents field FCachedGenerators.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FCachedGenerators: TObjectList;

Field Value

Type: TObjectList

See Also

Reference

  • TReedSolomonEncoder
  • frxDelphiZXIngCode


TReedSolomonEncoder.FField Field

Summary

Represents field FField.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
private
 FField: TGenericGF;

Field Value

Type: TGenericGF

See Also

Reference

  • TReedSolomonEncoder
  • frxDelphiZXIngCode


frxDelphiZXingCode Types

Types
Name | Description
TByteArray | Represents an array of the Byte type.
TGenericGFPolyArray | Represents an array of the TGenericGFPoly type.
TIntegerArray | Represents an array of the Integer type.
Top


TByteArray Type

Summary

Represents an array of the Byte type.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
type
 TByteArray = array of Byte;
See Also

Reference

  • frxDelphiZXIngCode


TGenericGFPolyArray Type

Summary

Represents an array of the TGenericGFPoly type.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
type
 TGenericGFPolyArray = array of TGenericGFPoly;
See Also

Reference

  • frxDelphiZXIngCode


TIntegerArray Type

Summary

Represents an array of the Integer type.

Namespace: frxDelphiZXIngCode
Syntax
Delphi
type
 TIntegerArray = array of Integer;
See Also

Reference

  • frxDelphiZXIngCode


frxDelphiZXingCode Routines

Routines
Name | Description
FreeAndSetBitArray(TBitArray,TBitArray) | Represents method FreeAndSetBitArray(TBitArray,TBitArray).
IfValue(Boolean,AnsiChar,AnsiChar) | Overloaded. Represents method IfValue(Boolean,AnsiChar,AnsiChar).
IfValue(Boolean,Integer,Integer) | Overloaded. Represents method IfValue(Boolean,Integer,Integer).
IfValue(Boolean,string,string) | Overloaded. Represents method IfValue(Boolean,string,string).
Top


FreeAndSetBitArray(TBitArray,TBitArray) Method

Summary

Represents method FreeAndSetBitArray(TBitArray,TBitArray).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
procedure FreeAndSetBitArray(var BitArray1: TBitArray; BitArray2: TBitArray);

Parameters

BitArray1
Type: TBitArray

BitArray2
Type: TBitArray

See Also

Reference

  • frxDelphiZXIngCode


IfValue(Boolean,AnsiChar,AnsiChar) Method

Summary

Represents method IfValue(Boolean,AnsiChar,AnsiChar).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
function IfValue(IsTrue: Boolean; TrueValue, FalseValue: AnsiChar)
 : AnsiChar; overload;

Parameters

IsTrue
Type: Boolean

TrueValue
Type: AnsiChar

FalseValue
Type: AnsiChar

Return Value

Type: AnsiChar

See Also

Reference

  • frxDelphiZXIngCode


IfValue(Boolean,Integer,Integer) Method

Summary

Represents method IfValue(Boolean,Integer,Integer).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
function IfValue(IsTrue: Boolean; TrueValue, FalseValue: Integer)
 : Integer; overload;

Parameters

IsTrue
Type: Boolean

TrueValue
Type: Integer

FalseValue
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • frxDelphiZXIngCode


IfValue(Boolean,string,string) Method

Summary

Represents method IfValue(Boolean,string,string).

Namespace: frxDelphiZXIngCode
Syntax
Delphi
function IfValue(IsTrue: Boolean; TrueValue, FalseValue: string)
 : string; overload;

Parameters

IsTrue
Type: Boolean

TrueValue
Type: string

FalseValue
Type: string

Return Value

Type: string

See Also

Reference

  • frxDelphiZXIngCode


frxDelphiZXingQRCode Namespace

Summary

Represents namespace frxDelphiZXingQRCode.

Classes
Name | Description
TDelphiZXingQRCode | Represents type TDelphiZXingQRCode.
TErrorCorrectionLevel | Represents type TErrorCorrectionLevel.
Top
Enumerations
Name | Description
TQRCodeEncoding | Represents type TQRCodeEncoding.
TQRErrorLevels | Represents type TQRErrorLevels.
Top


frxDelphiZXingQRCode Classes

Classes
Name | Description
TDelphiZXingQRCode | Represents type TDelphiZXingQRCode.
TErrorCorrectionLevel | Represents type TErrorCorrectionLevel.
Top


TDelphiZXingQRCode Class

Summary

Represents type TDelphiZXingQRCode.

Namespace: frxDelphiZXingQRCode
Inheritance Hierarchy
TObject
frxDelphiZXingQRCode.TDelphiZXingQRCode
Syntax
Delphi
type
 TDelphiZXingQRCode = class
 end;

The TDelphiZXingQRCode type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TDelphiZXingQRCode class.
Destroy | Represents the destructor of the TDelphiZXingQRCode class.
Top
Properties
Show:
Name | Description
CodePage | Represents property CodePage.
Columns | Represents property Columns.
Data | Represents property Data.
Encoding | Represents property Encoding.
ErrorLevels | Represents property ErrorLevels.
IsBlack[Integer,Integer] | Represents property IsBlack[Integer,Integer].
QuietZone | Represents property QuietZone.
Rows | Represents property Rows.
Top
Methods
Show:
Name | Description
GetIsBlack(Integer,Integer) | Represents method GetIsBlack(Integer,Integer).
SetCodePage(Longint) | Represents method SetCodePage(Longint).
SetData(WideString) | Represents method SetData(WideString).
SetEncoding(TQRCodeEncoding) | Represents method SetEncoding(TQRCodeEncoding).
SetErrorLevels(TQRErrorLevels) | Represents method SetErrorLevels(TQRErrorLevels).
SetQuietZone(Integer) | Represents method SetQuietZone(Integer).
Update | Represents method Update.
Top
Fields
Show:
Name | Description
FCodePage | Represents field FCodePage.
FColumns | Represents field FColumns.
FData | Represents field FData.
FElements | Represents field FElements.
FEncoding | Represents field FEncoding.
FErrorLevels | Represents field FErrorLevels.
FLevel | Represents field FLevel.
FQuietZone | Represents field FQuietZone.
FRows | Represents field FRows.
Top
See Also

Reference

  • frxDelphiZXingQRCode


TDelphiZXingQRCode Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TDelphiZXingQRCode class.
Destroy | Represents the destructor of the TDelphiZXingQRCode class.
Top


TDelphiZXingQRCode.Create Constructor

Summary

Initializes a new instance of the TDelphiZXingQRCode class.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.Destroy Destructor

Summary

Represents the destructor of the TDelphiZXingQRCode class.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode Properties

Properties
Name | Description
CodePage | Represents property CodePage.
Columns | Represents property Columns.
Data | Represents property Data.
Encoding | Represents property Encoding.
ErrorLevels | Represents property ErrorLevels.
IsBlack[Integer,Integer] | Represents property IsBlack[Integer,Integer].
QuietZone | Represents property QuietZone.
Rows | Represents property Rows.
Top


TDelphiZXingQRCode.CodePage Property

Summary

Represents property CodePage.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 property CodePage: Longint read FCodePage write SetCodePage;

Property Value

Type: Longint

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.Columns Property

Summary

Represents property Columns.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 property Columns: Integer read FColumns;

Property Value

Type: Integer

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.Data Property

Summary

Represents property Data.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 property Data: WideString read FData write SetData;

Property Value

Type: WideString

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.Encoding Property

Summary

Represents property Encoding.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 property Encoding: TQRCodeEncoding read FEncoding write SetEncoding;

Property Value

Type: TQRCodeEncoding

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.ErrorLevels Property

Summary

Represents property ErrorLevels.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 property ErrorLevels: TQRErrorLevels read FErrorLevels write SetErrorLevels;

Property Value

Type: TQRErrorLevels

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.IsBlack[Integer,Integer] Property

Summary

Represents property IsBlack[Integer,Integer].

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 property IsBlack[Row, Column: Integer]: Boolean read GetIsBlack;

Parameters

Row
Type: Integer

Column
Type: Integer

Property Value

Type: Boolean

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.QuietZone Property

Summary

Represents property QuietZone.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 property QuietZone: Integer read FQuietZone write SetQuietZone;

Property Value

Type: Integer

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.Rows Property

Summary

Represents property Rows.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 property Rows: Integer read FRows;

Property Value

Type: Integer

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode Methods

Methods
Name | Description
GetIsBlack(Integer,Integer) | Represents method GetIsBlack(Integer,Integer).
SetCodePage(Longint) | Represents method SetCodePage(Longint).
SetData(WideString) | Represents method SetData(WideString).
SetEncoding(TQRCodeEncoding) | Represents method SetEncoding(TQRCodeEncoding).
SetErrorLevels(TQRErrorLevels) | Represents method SetErrorLevels(TQRErrorLevels).
SetQuietZone(Integer) | Represents method SetQuietZone(Integer).
Update | Represents method Update.
Top


TDelphiZXingQRCode.GetIsBlack(Integer,Integer) Method

Summary

Represents method GetIsBlack(Integer,Integer).

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 function GetIsBlack(Row, Column: Integer): Boolean;

Parameters

Row
Type: Integer

Column
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.SetCodePage(Longint) Method

Summary

Represents method SetCodePage(Longint).

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
private
 procedure SetCodePage(const Value: Longint);

Parameters

Value
Type: Longint

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.SetData(WideString) Method

Summary

Represents method SetData(WideString).

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 procedure SetData(const NewData: WideString);

Parameters

NewData
Type: WideString

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.SetEncoding(TQRCodeEncoding) Method

Summary

Represents method SetEncoding(TQRCodeEncoding).

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 procedure SetEncoding(NewEncoding: TQRCodeEncoding);

Parameters

NewEncoding
Type: TQRCodeEncoding

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.SetErrorLevels(TQRErrorLevels) Method

Summary

Represents method SetErrorLevels(TQRErrorLevels).

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
private
 procedure SetErrorLevels(const Value: TQRErrorLevels);

Parameters

Value
Type: TQRErrorLevels

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.SetQuietZone(Integer) Method

Summary

Represents method SetQuietZone(Integer).

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 procedure SetQuietZone(NewQuietZone: Integer);

Parameters

NewQuietZone
Type: Integer

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.Update Method

Summary

Represents method Update.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 procedure Update;
See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode Fields

Fields
Name | Description
FCodePage | Represents field FCodePage.
FColumns | Represents field FColumns.
FData | Represents field FData.
FElements | Represents field FElements.
FEncoding | Represents field FEncoding.
FErrorLevels | Represents field FErrorLevels.
FLevel | Represents field FLevel.
FQuietZone | Represents field FQuietZone.
FRows | Represents field FRows.
Top


TDelphiZXingQRCode.FCodePage Field

Summary

Represents field FCodePage.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 FCodePage: Longint;

Field Value

Type: Longint

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.FColumns Field

Summary

Represents field FColumns.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 FColumns: Integer;

Field Value

Type: Integer

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.FData Field

Summary

Represents field FData.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 FData: WideString;

Field Value

Type: WideString

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.FElements Field

Summary

Represents field FElements.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 FElements: T2DBooleanArray;

Field Value

Type: T2DBooleanArray

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.FEncoding Field

Summary

Represents field FEncoding.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 FEncoding: TQRCodeEncoding;

Field Value

Type: TQRCodeEncoding

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.FErrorLevels Field

Summary

Represents field FErrorLevels.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 FErrorLevels: TQRErrorLevels;

Field Value

Type: TQRErrorLevels

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.FLevel Field

Summary

Represents field FLevel.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 FLevel: TErrorCorrectionLevel;

Field Value

Type: TErrorCorrectionLevel

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.FQuietZone Field

Summary

Represents field FQuietZone.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 FQuietZone: Integer;

Field Value

Type: Integer

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TDelphiZXingQRCode.FRows Field

Summary

Represents field FRows.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
protected
 FRows: Integer;

Field Value

Type: Integer

See Also

Reference

  • TDelphiZXingQRCode
  • frxDelphiZXingQRCode


TErrorCorrectionLevel Class

Summary

Represents type TErrorCorrectionLevel.

Namespace: frxDelphiZXingQRCode
Inheritance Hierarchy
TObject
frxDelphiZXingQRCode.TErrorCorrectionLevel
Syntax
Delphi
type
 TErrorCorrectionLevel = class
 end;

The TErrorCorrectionLevel type exposes the following members.

Properties
Show:
Name | Description
Bits | Represents property Bits.
Ordinal | Represents property Ordinal.
Top
Methods
Show:
Name | Description
Assign(TErrorCorrectionLevel) | Represents method Assign(TErrorCorrectionLevel).
Top
Fields
Show:
Name | Description
FBits | Represents field FBits.
FOrdinal | Represents field FOrdinal.
Top
See Also

Reference

  • frxDelphiZXingQRCode


TErrorCorrectionLevel Properties

Properties
Name | Description
Bits | Represents property Bits.
Ordinal | Represents property Ordinal.
Top


TErrorCorrectionLevel.Bits Property

Summary

Represents property Bits.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 property Bits: Integer read FBits write FBits;

Property Value

Type: Integer

See Also

Reference

  • TErrorCorrectionLevel
  • frxDelphiZXingQRCode


TErrorCorrectionLevel.Ordinal Property

Summary

Represents property Ordinal.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 property Ordinal: Integer read FOrdinal write FOrdinal;

Property Value

Type: Integer

See Also

Reference

  • TErrorCorrectionLevel
  • frxDelphiZXingQRCode


TErrorCorrectionLevel Methods

Methods
Name | Description
Assign(TErrorCorrectionLevel) | Represents method Assign(TErrorCorrectionLevel).
Top


TErrorCorrectionLevel.Assign(TErrorCorrectionLevel) Method

Summary

Represents method Assign(TErrorCorrectionLevel).

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
public
 procedure Assign(Source: TErrorCorrectionLevel);

Parameters

Source
Type: TErrorCorrectionLevel

See Also

Reference

  • TErrorCorrectionLevel
  • frxDelphiZXingQRCode


TErrorCorrectionLevel Fields

Fields
Name | Description
FBits | Represents field FBits.
FOrdinal | Represents field FOrdinal.
Top


TErrorCorrectionLevel.FBits Field

Summary

Represents field FBits.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
private
 FBits: Integer;

Field Value

Type: Integer

See Also

Reference

  • TErrorCorrectionLevel
  • frxDelphiZXingQRCode


TErrorCorrectionLevel.FOrdinal Field

Summary

Represents field FOrdinal.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
private
 FOrdinal: Integer;

Field Value

Type: Integer

See Also

Reference

  • TErrorCorrectionLevel
  • frxDelphiZXingQRCode


frxDelphiZXingQRCode Enumerations

Enumerations
Name | Description
TQRCodeEncoding | Represents type TQRCodeEncoding.
TQRErrorLevels | Represents type TQRErrorLevels.
Top


TQRCodeEncoding Enumeration

Summary

Represents type TQRCodeEncoding.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
type
 TQRCodeEncoding = (qrAuto, qrNumeric, qrAlphanumeric, qrISO88591, qrUTF8NoBOM, qrUTF8BOM, qrShift_JIS);

The TQRCodeEncoding type exposes the following members.

Members
Show:
Name | Description
qrAlphanumeric | Represents constant qrAlphanumeric.
qrAuto | Represents constant qrAuto.
qrISO88591 | Represents constant qrISO88591.
qrNumeric | Represents constant qrNumeric.
qrShift_JIS | Represents constant qrShift_JIS.
qrUTF8BOM | Represents constant qrUTF8BOM.
qrUTF8NoBOM | Represents constant qrUTF8NoBOM.
Top
See Also

Reference

  • frxDelphiZXingQRCode


TQRErrorLevels Enumeration

Summary

Represents type TQRErrorLevels.

Namespace: frxDelphiZXingQRCode
Syntax
Delphi
type
 TQRErrorLevels = (ecL, ecM, ecQ, ecH);

The TQRErrorLevels type exposes the following members.

Members
Show:
Name | Description
ecH | Represents constant ecH.
ecL | Represents constant ecL.
ecM | Represents constant ecM.
ecQ | Represents constant ecQ.
Top
See Also

Reference

  • frxDelphiZXingQRCode


frxDesgn Namespace

Summary

Represents namespace frxDesgn.

Classes
Name | Description
TfrxCustomSavePlugin | Represents type TfrxCustomSavePlugin.
TfrxDesigner | The TfrxDesigner component is a report designer. When using this component, you have the ability to design reports in your project at runtime. The component itself contains only a few designer settings; the designer itself is connected by adding the "frxDesgn" unit into the "Uses" list (this occurs automatically if you place the component on the form).
TfrxDesignerForm | Represents type TfrxDesignerForm.
TSampleFormat | Represents type TSampleFormat.
Top
Enumerations
Name | Description
TfrxDesignerUnits | Units used in the designer.
TfrxDesignerUpdateEvent | Represents type TfrxDesignerUpdateEvent.
Top
Delegates
Name | Description
TfrxAfterUpdateReportEvent | Represents type TfrxAfterUpdateReportEvent.
TfrxGetTemplateListEvent | The event occurs when user goes File|New... or Report|Options... menu items to choose the report template. Event handler must return a list of available templates in the List parameter.
TfrxLoadRecentReportEvent | Represents type TfrxLoadRecentReportEvent.
TfrxLoadReportEvent | The event occurs when loading a report. With the help of this event, you can manage report's loading from DB. Event handler must load a report and return True if operation was successful.
TfrxSaveReportEvent | The event occurs when saving a report. With the help of this event, you can manage process of report's saving in DB. Event handler must save a report and return True if operation was successful. SaveAs parameter is True in case the user selects "Save As..." menu item.
Top
Types
Name | Description
TfrxDesignerRestrictions | A set of flags, which inhibit specific operations in the designer.
Top
Variables
Name | Description
frxDesignerComp | Represents variable frxDesignerComp.
Top


frxDesgn Classes

Classes
Name | Description
TfrxCustomSavePlugin | Represents type TfrxCustomSavePlugin.
TfrxDesigner | The TfrxDesigner component is a report designer. When using this component, you have the ability to design reports in your project at runtime. The component itself contains only a few designer settings; the designer itself is connected by adding the "frxDesgn" unit into the "Uses" list (this occurs automatically if you place the component on the form).
TfrxDesignerForm | Represents type TfrxDesignerForm.
TSampleFormat | Represents type TSampleFormat.
Top


TfrxCustomSavePlugin Class

Summary

Represents type TfrxCustomSavePlugin.

Namespace: frxDesgn
Inheritance Hierarchy
TObject
frxDesgn.TfrxCustomSavePlugin
Syntax
Delphi
type
 TfrxCustomSavePlugin = class(TObject)
 end;

The TfrxCustomSavePlugin type exposes the following members.

Methods
Show:
Name | Description
Save(TfrxReport,String) | Represents method Save(TfrxReport,String).
Top
Fields
Show:
Name | Description
FileFilter | Represents field FileFilter.
Top
See Also

Reference

  • frxDesgn


TfrxCustomSavePlugin Methods

Methods
Name | Description
Save(TfrxReport,String) | Represents method Save(TfrxReport,String).
Top


TfrxCustomSavePlugin.Save(TfrxReport,String) Method

Summary

Represents method Save(TfrxReport,String).

Namespace: frxDesgn
Syntax
Delphi
public
 procedure Save(Report: TfrxReport; const FileName: String); virtual; abstract;

Parameters

Report
Type: TfrxReport

FileName
Type: String

See Also

Reference

  • TfrxCustomSavePlugin
  • frxDesgn


TfrxCustomSavePlugin Fields

Fields
Name | Description
FileFilter | Represents field FileFilter.
Top


TfrxCustomSavePlugin.FileFilter Field

Summary

Represents field FileFilter.

Namespace: frxDesgn
Syntax
Delphi
public
 FileFilter: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomSavePlugin
  • frxDesgn


TfrxDesigner Class

Summary

The TfrxDesigner component is a report designer. When using this component, you have the ability to design reports in your project at runtime. The component itself contains only a few designer settings; the designer itself is connected by adding the "frxDesgn" unit into the "Uses" list (this occurs automatically if you place the component on the form).

Namespace: frxDesgn
Inheritance Hierarchy
TComponent
frxDesgn.TfrxDesigner
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxDesigner = class(TComponent)
 end;

The TfrxDesigner type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDesigner class.
Destroy | Represents the destructor of the TfrxDesigner class.
Top
Properties
Show:
Name | Description
CloseQuery | Defines, if it is necessary to ask about report saving on designer closing.
DefaultBottomMargin | The default bottom margin for a new report page.
DefaultFont | The default font for a new "Text" object.
DefaultLeftMargin | The default left margin for a new report page.
DefaultOrientation | The default orientation for a new report page.
DefaultPaperSize | The default paper size for a new report page.
DefaultRightMargin | The default right margin for a new report page.
DefaultScriptLanguage | The default script language.
DefaultTopMargin | The default top margin for a new report page.
Gradient | The gradient fill for toolbars.
GradientEnd | The gradient fill for toolbars, end color.
GradientStart | The gradient fill for toolbars, start color.
MemoParentFont | Represents property MemoParentFont.
OnInsertObject | The event occurs when inserting a new object.
OnShow | The event occurs when the designer starts.
OnShowStartupScreen | The event occurs before displaying a designer window.
OpenDir | The name of a folder, from which the file is opened by default.
Restrictions | A set of flags, which forbids certain operations in the designer.
RTLLanguage | Determines whether to set the RTLReading property for a new "Text" object.
SaveDir | The name of a folder, where the file is saved to by default.
Standalone | Deprecated. Not used.
TemplateDir | The directory name that contains report templates.
TemplatesExt | Extension for report files (during changes you need to change a line with dialogue filter in resources as well).
Top
Methods
Show:
Name | Description
SetDefaultFont(TFont) | Represents method SetDefaultFont(TFont).
Top
Events
Show:
Name | Description
OnAfterUpdateReport | Represents property OnAfterUpdateReport.
OnGetTemplateList | The event occurs when user selects File|New... or Report|Options... menu items to choose the report template. Event handler must return a list of available templates in the List parameter.
OnLoadRecentReport | Represents property OnLoadRecentReport.
OnLoadReport | The event occurs when loading a report. With the help of this event, you can manage report's loading from DB.
OnSaveReport | The event occurs when saving a report. With the help of this event, you can manage process of report's saving in DB.
Top
Fields
Show:
Name | Description
FCloseQuery | Represents field FCloseQuery.
FDefaultBottomMargin | Represents field FDefaultBottomMargin.
FDefaultFont | Represents field FDefaultFont.
FDefaultLeftMargin | Represents field FDefaultLeftMargin.
FDefaultOrientation | Represents field FDefaultOrientation.
FDefaultPaperSize | Represents field FDefaultPaperSize.
FDefaultRightMargin | Represents field FDefaultRightMargin.
FDefaultScriptLanguage | Represents field FDefaultScriptLanguage.
FDefaultTopMargin | Represents field FDefaultTopMargin.
FGradient | Represents field FGradient.
FGradientEnd | Represents field FGradientEnd.
FGradientStart | Represents field FGradientStart.
FMemoParentFont | Represents field FMemoParentFont.
FOnAfterUpdateReport | Represents field FOnAfterUpdateReport.
FOnGetTemplateList | Represents field FOnGetTemplateList.
FOnInsertObject | Represents field FOnInsertObject.
FOnLoadRecentReport | Represents field FOnLoadRecentReport.
FOnLoadReport | Represents field FOnLoadReport.
FOnSaveReport | Represents field FOnSaveReport.
FOnShow | Represents field FOnShow.
FOnShowStartupScreen | Represents field FOnShowStartupScreen.
FOpenDir | Represents field FOpenDir.
FRestrictions | Represents field FRestrictions.
FRTLLanguage | Represents field FRTLLanguage.
FSaveDir | Represents field FSaveDir.
FStandalone | Represents field FStandalone.
FTemplateDir | Represents field FTemplateDir.
FTemplatesExt | Represents field FTemplatesExt.
Top
See Also

Reference

  • frxDesgn


TfrxDesigner Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDesigner class.
Destroy | Represents the destructor of the TfrxDesigner class.
Top


TfrxDesigner.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDesigner class.

Namespace: frxDesgn
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.Destroy Destructor

Summary

Represents the destructor of the TfrxDesigner class.

Namespace: frxDesgn
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner Properties

Properties
Name | Description
CloseQuery | Defines, if it is necessary to ask about report saving on designer closing.
DefaultBottomMargin | The default bottom margin for a new report page.
DefaultFont | The default font for a new "Text" object.
DefaultLeftMargin | The default left margin for a new report page.
DefaultOrientation | The default orientation for a new report page.
DefaultPaperSize | The default paper size for a new report page.
DefaultRightMargin | The default right margin for a new report page.
DefaultScriptLanguage | The default script language.
DefaultTopMargin | The default top margin for a new report page.
Gradient | The gradient fill for toolbars.
GradientEnd | The gradient fill for toolbars, end color.
GradientStart | The gradient fill for toolbars, start color.
MemoParentFont | Represents property MemoParentFont.
OnInsertObject | The event occurs when inserting a new object.
OnShow | The event occurs when the designer starts.
OnShowStartupScreen | The event occurs before displaying a designer window.
OpenDir | The name of a folder, from which the file is opened by default.
Restrictions | A set of flags, which forbids certain operations in the designer.
RTLLanguage | Determines whether to set the RTLReading property for a new "Text" object.
SaveDir | The name of a folder, where the file is saved to by default.
Standalone | Deprecated. Not used.
TemplateDir | The directory name that contains report templates.
TemplatesExt | Extension for report files (during changes you need to change a line with dialogue filter in resources as well).
Top


TfrxDesigner.CloseQuery Property

Summary

Defines, if it is necessary to ask about report saving on designer closing.

Namespace: frxDesgn
Syntax
Delphi
published
 property CloseQuery: Boolean read FCloseQuery write FCloseQuery default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.DefaultBottomMargin Property

Summary

The default bottom margin for a new report page.

Namespace: frxDesgn
Syntax
Delphi
published
 property DefaultBottomMargin: Extended read FDefaultBottomMargin write FDefaultBottomMargin;

Property Value

Type: Extended

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.DefaultFont Property

Summary

The default font for a new "Text" object.

Namespace: frxDesgn
Syntax
Delphi
published
 property DefaultFont: TFont read FDefaultFont write SetDefaultFont;

Property Value

Type: TFont

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.DefaultLeftMargin Property

Summary

The default left margin for a new report page.

Namespace: frxDesgn
Syntax
Delphi
published
 property DefaultLeftMargin: Extended read FDefaultLeftMargin write FDefaultLeftMargin;

Property Value

Type: Extended

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.DefaultOrientation Property

Summary

The default orientation for a new report page.

Namespace: frxDesgn
Syntax
Delphi
published
 property DefaultOrientation: TPrinterOrientation read FDefaultOrientation write FDefaultOrientation;

Property Value

Type: TPrinterOrientation

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.DefaultPaperSize Property

Summary

The default paper size for a new report page.

Namespace: frxDesgn
Syntax
Delphi
published
 property DefaultPaperSize: Integer read FDefaultPaperSize write FDefaultPaperSize;

Property Value

Type: Integer

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.DefaultRightMargin Property

Summary

The default right margin for a new report page.

Namespace: frxDesgn
Syntax
Delphi
published
 property DefaultRightMargin: Extended read FDefaultRightMargin write FDefaultRightMargin;

Property Value

Type: Extended

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.DefaultScriptLanguage Property

Summary

The default script language.

Namespace: frxDesgn
Syntax
Delphi
published
 property DefaultScriptLanguage: String read FDefaultScriptLanguage write FDefaultScriptLanguage;

Property Value

Type: String

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.DefaultTopMargin Property

Summary

The default top margin for a new report page.

Namespace: frxDesgn
Syntax
Delphi
published
 property DefaultTopMargin: Extended read FDefaultTopMargin write FDefaultTopMargin;

Property Value

Type: Extended

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.Gradient Property

Summary

The gradient fill for toolbars.

Namespace: frxDesgn
Syntax
Delphi
published
 property Gradient: Boolean read FGradient write FGradient default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.GradientEnd Property

Summary

The gradient fill for toolbars, end color.

Namespace: frxDesgn
Syntax
Delphi
published
 property GradientEnd: TColor read FGradientEnd write FGradientEnd;

Property Value

Type: TColor

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.GradientStart Property

Summary

The gradient fill for toolbars, start color.

Namespace: frxDesgn
Syntax
Delphi
published
 property GradientStart: TColor read FGradientStart write FGradientStart;

Property Value

Type: TColor

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.MemoParentFont Property

Summary

Represents property MemoParentFont.

Namespace: frxDesgn
Syntax
Delphi
published
 property MemoParentFont: Boolean read FMemoParentFont write FMemoParentFont;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.OnInsertObject Property

Summary

The event occurs when inserting a new object.

Namespace: frxDesgn
Syntax
Delphi
published
 property OnInsertObject: TNotifyEvent read FOnInsertObject write FOnInsertObject;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.OnShow Property

Summary

The event occurs when the designer starts.

Namespace: frxDesgn
Syntax
Delphi
published
 property OnShow: TNotifyEvent read FOnShow write FOnShow;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.OnShowStartupScreen Property

Summary

The event occurs before displaying a designer window.

Namespace: frxDesgn
Syntax
Delphi
published
 property OnShowStartupScreen: TNotifyEvent read FOnShowStartupScreen write FOnShowStartupScreen;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.OpenDir Property

Summary

The name of a folder, from which the file is opened by default.

Namespace: frxDesgn
Syntax
Delphi
published
 property OpenDir: String read FOpenDir write FOpenDir;

Property Value

Type: String

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.Restrictions Property

Summary

A set of flags, which forbids certain operations in the designer.

Namespace: frxDesgn
Syntax
Delphi
published
 property Restrictions: TfrxDesignerRestrictions read FRestrictions write FRestrictions;

Property Value

Type: TfrxDesignerRestrictions

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.RTLLanguage Property

Summary

Determines whether to set the RTLReading property for a new "Text" object.

Namespace: frxDesgn
Syntax
Delphi
published
 property RTLLanguage: Boolean read FRTLLanguage write FRTLLanguage;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.SaveDir Property

Summary

The name of a folder, where the file is saved to by default.

Namespace: frxDesgn
Syntax
Delphi
published
 property SaveDir: String read FSaveDir write FSaveDir;

Property Value

Type: String

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.Standalone Property

Summary

Deprecated. Not used.

Namespace: frxDesgn
Syntax
Delphi
published
 property Standalone: Boolean read FStandalone write FStandalone default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.TemplateDir Property

Summary

The directory name that contains report templates.

Namespace: frxDesgn
Syntax
Delphi
published
 property TemplateDir: String read FTemplateDir write FTemplateDir;

Property Value

Type: String

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.TemplatesExt Property

Summary

Extension for report files (during changes you need to change a line with dialogue filter in resources as well).

Namespace: frxDesgn
Syntax
Delphi
published
 property TemplatesExt: String read FTemplatesExt write FTemplatesExt;

Property Value

Type: String

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner Methods

Methods
Name | Description
SetDefaultFont(TFont) | Represents method SetDefaultFont(TFont).
Top


TfrxDesigner.SetDefaultFont(TFont) Method

Summary

Represents method SetDefaultFont(TFont).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetDefaultFont(const Value: TFont);

Parameters

Value
Type: TFont

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner Events

Events
Name | Description
OnAfterUpdateReport | Represents property OnAfterUpdateReport.
OnGetTemplateList | The event occurs when user selects File|New... or Report|Options... menu items to choose the report template. Event handler must return a list of available templates in the List parameter.
OnLoadRecentReport | Represents property OnLoadRecentReport.
OnLoadReport | The event occurs when loading a report. With the help of this event, you can manage report's loading from DB.
OnSaveReport | The event occurs when saving a report. With the help of this event, you can manage process of report's saving in DB.
Top


TfrxDesigner.OnAfterUpdateReport Event

Summary

Represents property OnAfterUpdateReport.

Namespace: frxDesgn
Syntax
Delphi
published
 property OnAfterUpdateReport: TfrxAfterUpdateReportEvent read FOnAfterUpdateReport write FOnAfterUpdateReport;

Value

Type: TfrxAfterUpdateReportEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.OnGetTemplateList Event

Summary

The event occurs when user selects File|New... or Report|Options... menu items to choose the report template. Event handler must return a list of available templates in the List parameter.

Namespace: frxDesgn
Syntax
Delphi
published
 property OnGetTemplateList: TfrxGetTemplateListEvent read FOnGetTemplateList write FOnGetTemplateList;

Value

Type: TfrxGetTemplateListEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.OnLoadRecentReport Event

Summary

Represents property OnLoadRecentReport.

Namespace: frxDesgn
Syntax
Delphi
published
 property OnLoadRecentReport: TfrxLoadRecentReportEvent read FOnLoadRecentReport write FOnLoadRecentReport;

Value

Type: TfrxLoadRecentReportEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.OnLoadReport Event

Summary

The event occurs when loading a report. With the help of this event, you can manage report's loading from DB.

Namespace: frxDesgn
Syntax
Delphi
published
 property OnLoadReport: TfrxLoadReportEvent read FOnLoadReport write FOnLoadReport;

Value

Type: TfrxLoadReportEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.OnSaveReport Event

Summary

The event occurs when saving a report. With the help of this event, you can manage process of report's saving in DB.

Namespace: frxDesgn
Syntax
Delphi
published
 property OnSaveReport: TfrxSaveReportEvent read FOnSaveReport write FOnSaveReport;

Value

Type: TfrxSaveReportEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner Fields

Fields
Name | Description
FCloseQuery | Represents field FCloseQuery.
FDefaultBottomMargin | Represents field FDefaultBottomMargin.
FDefaultFont | Represents field FDefaultFont.
FDefaultLeftMargin | Represents field FDefaultLeftMargin.
FDefaultOrientation | Represents field FDefaultOrientation.
FDefaultPaperSize | Represents field FDefaultPaperSize.
FDefaultRightMargin | Represents field FDefaultRightMargin.
FDefaultScriptLanguage | Represents field FDefaultScriptLanguage.
FDefaultTopMargin | Represents field FDefaultTopMargin.
FGradient | Represents field FGradient.
FGradientEnd | Represents field FGradientEnd.
FGradientStart | Represents field FGradientStart.
FMemoParentFont | Represents field FMemoParentFont.
FOnAfterUpdateReport | Represents field FOnAfterUpdateReport.
FOnGetTemplateList | Represents field FOnGetTemplateList.
FOnInsertObject | Represents field FOnInsertObject.
FOnLoadRecentReport | Represents field FOnLoadRecentReport.
FOnLoadReport | Represents field FOnLoadReport.
FOnSaveReport | Represents field FOnSaveReport.
FOnShow | Represents field FOnShow.
FOnShowStartupScreen | Represents field FOnShowStartupScreen.
FOpenDir | Represents field FOpenDir.
FRestrictions | Represents field FRestrictions.
FRTLLanguage | Represents field FRTLLanguage.
FSaveDir | Represents field FSaveDir.
FStandalone | Represents field FStandalone.
FTemplateDir | Represents field FTemplateDir.
FTemplatesExt | Represents field FTemplatesExt.
Top


TfrxDesigner.FCloseQuery Field

Summary

Represents field FCloseQuery.

Namespace: frxDesgn
Syntax
Delphi
private
 FCloseQuery: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FDefaultBottomMargin Field

Summary

Represents field FDefaultBottomMargin.

Namespace: frxDesgn
Syntax
Delphi
private
 FDefaultBottomMargin: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FDefaultFont Field

Summary

Represents field FDefaultFont.

Namespace: frxDesgn
Syntax
Delphi
private
 FDefaultFont: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FDefaultLeftMargin Field

Summary

Represents field FDefaultLeftMargin.

Namespace: frxDesgn
Syntax
Delphi
private
 FDefaultLeftMargin: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FDefaultOrientation Field

Summary

Represents field FDefaultOrientation.

Namespace: frxDesgn
Syntax
Delphi
private
 FDefaultOrientation: TPrinterOrientation;

Field Value

Type: TPrinterOrientation

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FDefaultPaperSize Field

Summary

Represents field FDefaultPaperSize.

Namespace: frxDesgn
Syntax
Delphi
private
 FDefaultPaperSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FDefaultRightMargin Field

Summary

Represents field FDefaultRightMargin.

Namespace: frxDesgn
Syntax
Delphi
private
 FDefaultRightMargin: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FDefaultScriptLanguage Field

Summary

Represents field FDefaultScriptLanguage.

Namespace: frxDesgn
Syntax
Delphi
private
 FDefaultScriptLanguage: String;

Field Value

Type: String

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FDefaultTopMargin Field

Summary

Represents field FDefaultTopMargin.

Namespace: frxDesgn
Syntax
Delphi
private
 FDefaultTopMargin: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FGradient Field

Summary

Represents field FGradient.

Namespace: frxDesgn
Syntax
Delphi
private
 FGradient: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FGradientEnd Field

Summary

Represents field FGradientEnd.

Namespace: frxDesgn
Syntax
Delphi
private
 FGradientEnd: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FGradientStart Field

Summary

Represents field FGradientStart.

Namespace: frxDesgn
Syntax
Delphi
private
 FGradientStart: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FMemoParentFont Field

Summary

Represents field FMemoParentFont.

Namespace: frxDesgn
Syntax
Delphi
private
 FMemoParentFont: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FOnAfterUpdateReport Field

Summary

Represents field FOnAfterUpdateReport.

Namespace: frxDesgn
Syntax
Delphi
private
 FOnAfterUpdateReport: TfrxAfterUpdateReportEvent;

Field Value

Type: TfrxAfterUpdateReportEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FOnGetTemplateList Field

Summary

Represents field FOnGetTemplateList.

Namespace: frxDesgn
Syntax
Delphi
private
 FOnGetTemplateList: TfrxGetTemplateListEvent;

Field Value

Type: TfrxGetTemplateListEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FOnInsertObject Field

Summary

Represents field FOnInsertObject.

Namespace: frxDesgn
Syntax
Delphi
private
 FOnInsertObject: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FOnLoadRecentReport Field

Summary

Represents field FOnLoadRecentReport.

Namespace: frxDesgn
Syntax
Delphi
private
 FOnLoadRecentReport: TfrxLoadRecentReportEvent;

Field Value

Type: TfrxLoadRecentReportEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FOnLoadReport Field

Summary

Represents field FOnLoadReport.

Namespace: frxDesgn
Syntax
Delphi
private
 FOnLoadReport: TfrxLoadReportEvent;

Field Value

Type: TfrxLoadReportEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FOnSaveReport Field

Summary

Represents field FOnSaveReport.

Namespace: frxDesgn
Syntax
Delphi
private
 FOnSaveReport: TfrxSaveReportEvent;

Field Value

Type: TfrxSaveReportEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FOnShow Field

Summary

Represents field FOnShow.

Namespace: frxDesgn
Syntax
Delphi
private
 FOnShow: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FOnShowStartupScreen Field

Summary

Represents field FOnShowStartupScreen.

Namespace: frxDesgn
Syntax
Delphi
private
 FOnShowStartupScreen: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FOpenDir Field

Summary

Represents field FOpenDir.

Namespace: frxDesgn
Syntax
Delphi
private
 FOpenDir: String;

Field Value

Type: String

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FRestrictions Field

Summary

Represents field FRestrictions.

Namespace: frxDesgn
Syntax
Delphi
private
 FRestrictions: TfrxDesignerRestrictions;

Field Value

Type: TfrxDesignerRestrictions

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FRTLLanguage Field

Summary

Represents field FRTLLanguage.

Namespace: frxDesgn
Syntax
Delphi
private
 FRTLLanguage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FSaveDir Field

Summary

Represents field FSaveDir.

Namespace: frxDesgn
Syntax
Delphi
private
 FSaveDir: String;

Field Value

Type: String

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FStandalone Field

Summary

Represents field FStandalone.

Namespace: frxDesgn
Syntax
Delphi
private
 FStandalone: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FTemplateDir Field

Summary

Represents field FTemplateDir.

Namespace: frxDesgn
Syntax
Delphi
private
 FTemplateDir: String;

Field Value

Type: String

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesigner.FTemplatesExt Field

Summary

Represents field FTemplatesExt.

Namespace: frxDesgn
Syntax
Delphi
private
 FTemplatesExt: String;

Field Value

Type: String

See Also

Reference

  • TfrxDesigner
  • frxDesgn


TfrxDesignerForm Class

Summary

Represents type TfrxDesignerForm.

Namespace: frxDesgn
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxClass.TfrxCustomDesigner
frxDesgn.TfrxDesignerForm
Syntax
Delphi
type
 TfrxDesignerForm = class(TfrxCustomDesigner)
 end;

The TfrxDesignerForm type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseForm class. (Inherited from TfrxBaseForm.)
CreateDesigner(TComponent,TfrxReport,Boolean) | The Report designer constructor. (Inherited from TfrxCustomDesigner.)
Destroy | Represents the destructor of the TfrxDesignerForm class. (Overrides TfrxCustomDesigner.Destroy.)
Top
Properties
Show:
Name | Description
Code | The script of the report. (Inherited from TfrxCustomDesigner.)
CodeWindow | Represents property CodeWindow.
CurrentFormPPI | Returns current PPI value of the form. (Inherited from TfrxBaseForm.)
DataTree | Represents property DataTree.
DropFields | Represents property DropFields.
EditAfterInsert | Represents property EditAfterInsert.
FillColor | Represents property FillColor.
GridAlign | Represents property GridAlign.
GridSize1 | Represents property GridSize1.
GridSize2 | Represents property GridSize2.
GridSize3 | Represents property GridSize3.
GridSize4 | Represents property GridSize4.
GuidesAsAnchor | Represents property GuidesAsAnchor.
Inspector | Represents property Inspector.
IsPPIChanging | Represents property IsPPIChanging. (Inherited from TfrxBaseForm.)
IsPreviewDesigner | Returns True if the designer was launched from the preview window. (Inherited from TfrxCustomDesigner.)
MemoFontName | Default name of the font for memo text editor. (Inherited from TfrxCustomDesigner.)
MemoFontSize | Default size of the font for memo text editor. (Inherited from TfrxCustomDesigner.)
Modified | Determines whether the report was modified. (Inherited from TfrxCustomDesigner.)
Objects | List of objects on the current report page, including the page itself. (Inherited from TfrxCustomDesigner.)
Page | Reference to currently edited report page. May be nil if current page is "code editor". (Inherited from TfrxCustomDesigner.)
ParentForm | Parent form for the report designer form. (Inherited from TfrxCustomDesigner.)
PictureCache | Represents property PictureCache.
RecentFiles | Represents property RecentFiles.
Report | Reference to a report. (Inherited from TfrxCustomDesigner.)
ReportTree | Represents property ReportTree.
SampleFormat | Represents property SampleFormat.
Scale | Represents property Scale.
SelectedObjects | List of currently selected object. (Inherited from TfrxCustomDesigner.)
ShowGrid | Represents property ShowGrid.
ShowGuides | Represents property ShowGuides.
ShowRulers | Represents property ShowRulers.
ShowStartup | Represents property ShowStartup.
StickToGuides | Represents property StickToGuides.
TemplatePath | Represents property TemplatePath.
ToolsColor | Represents property ToolsColor.
Units | Represents property Units.
UseObjectFont | If True , Memo editor will use font for editor from the report object settings. (Inherited from TfrxCustomDesigner.)
Workspace | Represents property Workspace.
WorkspaceColor | Represents property WorkspaceColor.
Top
Methods
Show:
Name | Description
AboutCmdExecute(TObject) | Represents method AboutCmdExecute(TObject).
Activate | Represents method Activate.
AddChildMIClick(TObject) | Represents method AddChildMIClick(TObject).
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseForm.)
AfterPPIChange | Represents method AfterPPIChange. (Overrides TfrxBaseForm.AfterPPIChange.)
AfterPPIMessage | Represents method AfterPPIMessage. (Overrides TfrxBaseForm.AfterPPIMessage.)
AlignBottomsBClick(TObject) | Represents method AlignBottomsBClick(TObject).
AlignHorzCentersBClick(TObject) | Represents method AlignHorzCentersBClick(TObject).
AlignLeftsBClick(TObject) | Represents method AlignLeftsBClick(TObject).
AlignRightsBClick(TObject) | Represents method AlignRightsBClick(TObject).
AlignTBCmdExecute(TObject) | Represents method AlignTBCmdExecute(TObject).
AlignToGridBClick(TObject) | Represents method AlignToGridBClick(TObject).
AlignTopsBClick(TObject) | Represents method AlignTopsBClick(TObject).
AlignVertCentersBClick(TObject) | Represents method AlignVertCentersBClick(TObject).
AskSave | Represents method AskSave.
AttachDialogFormEvents(Boolean) | Represents method AttachDialogFormEvents(Boolean).
BandsPopupPopup(TObject) | Represents method BandsPopupPopup(TObject).
BeforeDestruction | Represents method BeforeDestruction. (Inherited from TfrxBaseForm.)
BeforePPIChange | Represents method BeforePPIChange. (Overrides TfrxBaseForm.BeforePPIChange.)
BreakPointBClick(TObject) | Represents method BreakPointBClick(TObject).
BringToFrontCmdExecute(TObject) | Represents method BringToFrontCmdExecute(TObject).
CenterHorzBClick(TObject) | Represents method CenterHorzBClick(TObject).
CenterVertBClick(TObject) | Represents method CenterVertBClick(TObject).
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer). (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean). (Inherited from TfrxBaseForm.)
CheckOp(TfrxDesignerRestriction) | Used to check restriction of the report designer. Returns True when restriction flag is set in the report designer. (Overrides TfrxCustomDesigner.CheckOp(TfrxDesignerRestriction).)
CMDialogKey(TCMDialogKey) | Represents method CMDialogKey(TCMDialogKey).
CMStartup(TMessage) | Represents method CMStartup(TMessage).
CodeDockSiteDockOver(TObject,TDragDockObject,Integer,Integer,TDragState,Boolean) | Represents method CodeDockSiteDockOver(TObject,TDragDockObject,Integer,Integer,TDragState,Boolean).
CodeWindowDragDrop(TObject,TObject,Integer,Integer) | Represents method CodeWindowDragDrop(TObject,TObject,Integer,Integer).
CodeWindowDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method CodeWindowDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
ConnectionsMIClick(TObject) | Represents method ConnectionsMIClick(TObject).
CopyCmdExecute(TObject) | Represents method CopyCmdExecute(TObject).
CopyContentCmdExecute(TObject) | Represents method CopyContentCmdExecute(TObject).
CreateColorSelector(TToolButton) | Represents method CreateColorSelector(TToolButton).
CreateExtraToolbar | Represents method CreateExtraToolbar.
CreateLangMenu | Represents method CreateLangMenu.
CreateObjectsToolbar | Represents method CreateObjectsToolbar.
CreateToolWindows | Represents method CreateToolWindows.
CreateWorkspace | Represents method CreateWorkspace.
CutCmdExecute(TObject) | Represents method CutCmdExecute(TObject).
DataTreeTBCmdExecute(TObject) | Represents method DataTreeTBCmdExecute(TObject).
Deactivate | Represents method Deactivate.
DeleteCmdExecute(TObject) | Represents method DeleteCmdExecute(TObject).
DeleteGuidesCmdExecute(TObject) | Represents method DeleteGuidesCmdExecute(TObject).
DeletePageCmdExecute(TObject) | Represents method DeletePageCmdExecute(TObject).
DialogFormKeyDown(TObject,Word,TShiftState) | Represents method DialogFormKeyDown(TObject,Word,TShiftState).
DialogFormKeyPress(TObject,Char) | Represents method DialogFormKeyPress(TObject,Char).
DialogFormKeyUp(TObject,Word,TShiftState) | Represents method DialogFormKeyUp(TObject,Word,TShiftState).
DialogFormModify(TObject) | Represents method DialogFormModify(TObject).
DisableInspectorUpdate | Locks object inspector updating. (Overrides TfrxCustomDesigner.DisableInspectorUpdate.)
DoAfterUpdateReport(TfrxDesignerUpdateEvent) | Represents method DoAfterUpdateReport(TfrxDesignerUpdateEvent).
DoClose(TCloseAction) | Represents method DoClose(TCloseAction). (Inherited from TfrxBaseForm.)
Done | Represents method Done.
DoShow | Represents method DoShow. (Inherited from TfrxBaseForm.)
DoTopmosts(Boolean) | Represents method DoTopmosts(Boolean).
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer). (Inherited from TfrxBaseForm.)
EdConfigCmdExecute(TObject) | Represents method EdConfigCmdExecute(TObject).
EditCmdExecute(TObject) | Represents method EditCmdExecute(TObject).
EnableInspectorUpdate | Releases object inspector lock. (Overrides TfrxCustomDesigner.EnableInspectorUpdate.)
EvaluateBClick(TObject) | Represents method EvaluateBClick(TObject).
ExitCmdExecute(TObject) | Represents method ExitCmdExecute(TObject).
ExtraTBCmdExecute(TObject) | Represents method ExtraTBCmdExecute(TObject).
FillColorBClick(TObject) | Represents method FillColorBClick(TObject).
FillColorPopupMenuPopup(TObject) | Represents method FillColorPopupMenuPopup(TObject).
FindCmdExecute(TObject) | Represents method FindCmdExecute(TObject).
FindNextCmdExecute(TObject) | Represents method FindNextCmdExecute(TObject).
FindOrReplace(Boolean) | Represents method FindOrReplace(Boolean).
FindText | Represents method FindText.
FontColorBClick(TObject) | Represents method FontColorBClick(TObject).
FontColorPopupMenuPopup(TObject) | Represents method FontColorPopupMenuPopup(TObject).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCloseQuery(TObject,Boolean) | Represents method FormCloseQuery(TObject,Boolean).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
FormMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean) | Represents method FormMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean).
FormShow(TObject) | Represents method FormShow(TObject).
FormShowAfterLoad | Represents method FormShowAfterLoad. (Inherited from TfrxBaseForm.)
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Overrides TfrxBaseForm.FormShowBeforeLoad.)
FrameColorBClick(TObject) | Represents method FrameColorBClick(TObject).
FrameColorPopupMenuPopup(TObject) | Represents method FrameColorPopupMenuPopup(TObject).
FrameStyleBClick(TObject) | Represents method FrameStyleBClick(TObject).
FrameTBCmdExecute(TObject) | Represents method FrameTBCmdExecute(TObject).
GetAvailablePreferences | Represents method GetAvailablePreferences. (Overrides TfrxBaseForm.GetAvailablePreferences.)
GetCode | Represents method GetCode. (Overrides TfrxCustomDesigner.GetCode.)
GetDataSelectedAsExp | Returns a dataset expression from DataTree selection. (Overrides TfrxCustomDesigner.GetDataSelectedAsExp.)
GetDefaultObjectSize | Represents method GetDefaultObjectSize.
GetDefaultPreferences | Represents method GetDefaultPreferences. (Overrides TfrxCustomDesigner.GetDefaultPreferences.)
GetFormSectionName | Represents method GetFormSectionName. (Inherited from TfrxBaseForm.)
GetPageIndex | Represents method GetPageIndex.
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Overrides TfrxBaseForm.GetPreferencesStorage(Boolean).)
GetReportName | Represents method GetReportName.
GetTemplateList(TStrings) | Represents method GetTemplateList(TStrings).
GroupCmdExecute(TObject) | Represents method GroupCmdExecute(TObject).
HelpContentsCmdExecute(TObject) | Represents method HelpContentsCmdExecute(TObject).
HighlightBClick(TObject) | Represents method HighlightBClick(TObject).
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Overrides TfrxBaseForm.HostControls(TWinControl).)
Init | Represents method Init.
InitControls | Represents method InitControls.
InsertBandClick(TObject) | Represents method InsertBandClick(TObject).
InsertExpression(String) | Method shows an "Insert expression" dialogue. It should return an expression string or an empty string if dialogue was canceled. (Overrides TfrxCustomDesigner.InsertExpression(String).)
InspectorTBCmdExecute(TObject) | Represents method InspectorTBCmdExecute(TObject).
InternalCopy | This method processes clipboard copy behaviour. (Overrides TfrxCustomDesigner.InternalCopy.)
InternalIsPasteAvailable | The methods checks if clipboard contains data available to paste in selected object. It serves copy/paste methods of InPlace editors. (Overrides TfrxCustomDesigner.InternalIsPasteAvailable.)
InternalPaste | This method processes clipboard paste behaviour. (Overrides TfrxCustomDesigner.InternalPaste.)
IOTransport(TfrxCustomIOTransport,Boolean,Boolean) | Represents method IOTransport(TfrxCustomIOTransport,Boolean,Boolean).
IsChangedExpression(String,String) | Method shows an "Insert expression" dialogue. It should return an expression string in out OutExpr parameter. Method returns True when expression was changed. (Overrides TfrxCustomDesigner.IsChangedExpression(String,String).)
IsDataTree(TObject) | Checks if passed object is designer DataTree window. Used for drag and drop behaviour. (Overrides TfrxCustomDesigner.IsDataTree(TObject).)
LangCBClick(TObject) | Represents method LangCBClick(TObject).
LangSelectClick(TObject) | Represents method LangSelectClick(TObject).
LoadFile(String,Boolean) | Represents method LoadFile(String,Boolean).
LoadFilter(TfrxCustomIOTransport,String,Boolean) | Represents method LoadFilter(TfrxCustomIOTransport,String,Boolean).
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.LoadFormPreferences(TObject,TObject).)
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
Localize | Represents method Localize.
Lock | Locks any drawings in the designer window. Use this method when making any changes in the currently edited report. (Overrides TfrxCustomDesigner.Lock.)
mmToUnits(Extended,Boolean) | Represents method mmToUnits(Extended,Boolean).
NewDialogCmdExecute(TObject) | Represents method NewDialogCmdExecute(TObject).
NewItemCmdExecute(TObject) | Represents method NewItemCmdExecute(TObject).
NewPageCmdExecute(TObject) | Represents method NewPageCmdExecute(TObject).
NewReportCmdExecute(TObject) | Represents method NewReportCmdExecute(TObject).
NormalizeTopmosts | Represents method NormalizeTopmosts.
ObjectBandBClick(TObject) | Represents method ObjectBandBClick(TObject).
ObjectsButtonClick(TObject) | Represents method ObjectsButtonClick(TObject).
OnChangePosition(TObject) | Represents method OnChangePosition(TObject).
OnCodeChanged(TObject) | Represents method OnCodeChanged(TObject).
OnCodeCompletion(String,TfrxCompletionList) | Represents method OnCodeCompletion(String,TfrxCompletionList).
OnColorChanged(TObject) | Represents method OnColorChanged(TObject).
OnComponentMenuClick(TObject) | Represents method OnComponentMenuClick(TObject).
OnDataTreeDblClick(TObject) | Represents method OnDataTreeDblClick(TObject).
OnDisableDock(TObject,TDragDockObject) | Represents method OnDisableDock(TObject,TDragDockObject).
OnEditObject(TObject) | Represents method OnEditObject(TObject).
OnEnableDock(TObject,TObject,Integer,Integer) | Represents method OnEnableDock(TObject,TObject,Integer,Integer).
OnEnterWorkSpace(TObject) | Represents method OnEnterWorkSpace(TObject).
OnExtraToolClick(TObject) | Represents method OnExtraToolClick(TObject).
OnInsertObject(TObject) | Represents method OnInsertObject(TObject).
OnModify(TObject) | Represents method OnModify(TObject).
OnNotifyPosition(TfrxRect) | Represents method OnNotifyPosition(TfrxRect).
OnRunLine(TfsScript,String,String) | Represents method OnRunLine(TfsScript,String,String).
OnSaveFilterExecute(TObject) | Represents method OnSaveFilterExecute(TObject).
OnSelectionChanged(TObject) | Represents method OnSelectionChanged(TObject).
OnStyleChanged(TObject) | Represents method OnStyleChanged(TObject).
OpenCmdExecute(TObject) | Represents method OpenCmdExecute(TObject).
OpenRecentFile(TObject) | Represents method OpenRecentFile(TObject).
OpenScriptBClick(TObject) | Represents method OpenScriptBClick(TObject).
OptionsCmdExecute(TObject) | Represents method OptionsCmdExecute(TObject).
PagePopupPopup(TObject) | Represents method PagePopupPopup(TObject).
PageSettingsCmdExecute(TObject) | Represents method PageSettingsCmdExecute(TObject).
PasteCmdExecute(TObject) | Represents method PasteCmdExecute(TObject).
PreviewCmdExecute(TObject) | Represents method PreviewCmdExecute(TObject).
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter. (Inherited from TfrxBaseForm.)
ReadButtonImages | Represents method ReadButtonImages.
RedoCmdExecute(TObject) | Represents method RedoCmdExecute(TObject).
ReloadObjects(Boolean) | Reloads all report objects in the report designer. (Overrides TfrxCustomDesigner.ReloadObjects(Boolean).)
ReloadPages(Integer) | Reloads all report's pages. Use this method if you add or delete a report page. The Index parameter defines which page should be made active. (Overrides TfrxCustomDesigner.ReloadPages(Integer).)
ReloadReport | Reloads all report contents. (Overrides TfrxCustomDesigner.ReloadReport.)
ReplaceCmdExecute(TObject) | Represents method ReplaceCmdExecute(TObject).
ReportDataCmdExecute(TObject) | Represents method ReportDataCmdExecute(TObject).
ReportDataEdit | Calls DataSets selection dialog. (Overrides TfrxCustomDesigner.ReportDataEdit.)
ReportEditVariable | Calls report variables editor dialog. (Overrides TfrxCustomDesigner.ReportEditVariable.)
ReportOptionsCmdExecute(TObject) | Represents method ReportOptionsCmdExecute(TObject).
ReportStylesCmdExecute(TObject) | Represents method ReportStylesCmdExecute(TObject).
ReportTreeTBCmdExecute(TObject) | Represents method ReportTreeTBCmdExecute(TObject).
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Overrides TfrxBaseForm.ResetFormPreferences(TObject).)
RestorePagePosition | Represents method RestorePagePosition.
RestoreState(Boolean,Boolean) | Represents method RestoreState(Boolean,Boolean).
RestoreTopmosts | Represents method RestoreTopmosts.
RevertInheritedMIClick(TObject) | Represents method RevertInheritedMIClick(TObject).
RunScriptBClick(TObject) | Represents method RunScriptBClick(TObject).
RunToCursorBClick(TObject) | Represents method RunToCursorBClick(TObject).
SameHeightBClick(TObject) | Represents method SameHeightBClick(TObject).
SameWidthBClick(TObject) | Represents method SameWidthBClick(TObject).
SaveAsCmdExecute(TObject) | Represents method SaveAsCmdExecute(TObject).
SaveCmdExecute(TObject) | Represents method SaveCmdExecute(TObject).
SaveFile(Boolean,Boolean) | Represents method SaveFile(Boolean,Boolean).
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.SaveFormPreferences(TObject,TObject).)
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
SavePagePosition | Represents method SavePagePosition.
SaveScriptBClick(TObject) | Represents method SaveScriptBClick(TObject).
ScaleCBClick(TObject) | Represents method ScaleCBClick(TObject).
ScaleControls | Represents method ScaleControls.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxBaseForm.)
ScrollBoxMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean) | Represents method ScrollBoxMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean).
ScrollBoxMouseWheelDown(TObject,TShiftState,TPoint,Boolean) | Represents method ScrollBoxMouseWheelDown(TObject,TShiftState,TPoint,Boolean).
ScrollBoxMouseWheelUp(TObject,TShiftState,TPoint,Boolean) | Represents method ScrollBoxMouseWheelUp(TObject,TShiftState,TPoint,Boolean).
ScrollBoxResize(TObject) | Represents method ScrollBoxResize(TObject).
SelectAllCmdExecute(TObject) | Represents method SelectAllCmdExecute(TObject).
SelectAllOfTypeCmdExecute(TObject) | Represents method SelectAllOfTypeCmdExecute(TObject).
SelectToolBClick(TObject) | Represents method SelectToolBClick(TObject).
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms. (Inherited from TfrxBaseForm.)
SendToBackCmdExecute(TObject) | Represents method SendToBackCmdExecute(TObject).
SetChange | Represents method SetChange.
SetGridAlign(Boolean) | Represents method SetGridAlign(Boolean).
SetGridSize1(Extended) | Represents method SetGridSize1(Extended).
SetGridSize2(Extended) | Represents method SetGridSize2(Extended).
SetGridSize3(Extended) | Represents method SetGridSize3(Extended).
SetGridSize4(Extended) | Represents method SetGridSize4(Extended).
SetGuidesAsAnchor(Boolean) | Represents method SetGuidesAsAnchor(Boolean).
SetModified(Boolean) | Represents method SetModified(Boolean). (Overrides TfrxCustomDesigner.SetModified(Boolean).)
SetPage(TfrxPage) | Represents method SetPage(TfrxPage). (Overrides TfrxCustomDesigner.SetPage(TfrxPage).)
SetReportDefaults | Represents method SetReportDefaults.
SetScale(Extended) | Represents method SetScale(Extended).
SetShowGrid(Boolean) | Represents method SetShowGrid(Boolean).
SetShowGuides(Boolean) | Represents method SetShowGuides(Boolean).
SetShowRulers(Boolean) | Represents method SetShowRulers(Boolean).
SetStickToGuides(Boolean) | Represents method SetStickToGuides(Boolean).
SetToolsColor(TColor) | Represents method SetToolsColor(TColor).
SetUnits(TfrxDesignerUnits) | Represents method SetUnits(TfrxDesignerUnits).
SetWorkspaceColor(TColor) | Represents method SetWorkspaceColor(TColor).
ShowGridBClick(TObject) | Represents method ShowGridBClick(TObject).
ShowGuidesCmdExecute(TObject) | Represents method ShowGuidesCmdExecute(TObject).
ShowRulersCmdExecute(TObject) | Represents method ShowRulersCmdExecute(TObject).
SpaceHorzBClick(TObject) | Represents method SpaceHorzBClick(TObject).
SpaceVertBClick(TObject) | Represents method SpaceVertBClick(TObject).
StandardTBCmdExecute(TObject) | Represents method StandardTBCmdExecute(TObject).
StatusBarDblClick(TObject) | Represents method StatusBarDblClick(TObject).
StatusBarDrawPanel(TStatusBar,TStatusPanel,TRect) | Represents method StatusBarDrawPanel(TStatusBar,TStatusPanel,TRect).
StatusBarMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method StatusBarMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
StatusBarWndProc(TMessage) | Represents method StatusBarWndProc(TMessage).
StopScriptBClick(TObject) | Represents method StopScriptBClick(TObject).
SwitchToCodeWindow | Represents method SwitchToCodeWindow.
SwitchToolbar | Represents method SwitchToolbar.
TabChange(TObject) | Represents method TabChange(TObject).
TabChanging(TObject,Boolean) | Represents method TabChanging(TObject,Boolean).
TabDragDrop(TObject,TObject,Integer,Integer) | Represents method TabDragDrop(TObject,TObject,Integer,Integer).
TabDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method TabDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
TabMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method TabMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
TabMouseMove(TObject,TShiftState,Integer,Integer) | Represents method TabMouseMove(TObject,TShiftState,Integer,Integer).
TabMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method TabMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer).
TabOrderMIClick(TObject) | Represents method TabOrderMIClick(TObject).
TabSetChange(TObject,Integer,Boolean) | Represents method TabSetChange(TObject,Integer,Boolean).
TextTBCmdExecute(TObject) | Represents method TextTBCmdExecute(TObject).
TimerTimer(TObject) | Represents method TimerTimer(TObject).
ToolbarsCmdExecute(TObject) | Represents method ToolbarsCmdExecute(TObject).
ToolButtonClick(TObject) | Represents method ToolButtonClick(TObject).
TopRulerDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method TopRulerDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
UndoCmdExecute(TObject) | Represents method UndoCmdExecute(TObject).
UngroupCmdExecute(TObject) | Represents method UngroupCmdExecute(TObject).
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form. (Inherited from TfrxBaseForm.)
UnitsTomm(Extended,Boolean) | Represents method UnitsTomm(Extended,Boolean).
UnSetChange | Represents method UnSetChange.
UpdateCaption | Represents method UpdateCaption.
UpdateControls | Represents method UpdateControls.
UpdateDataTree | Updates the "Data Tree" tool window. (Overrides TfrxCustomDesigner.UpdateDataTree.)
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Overrides TfrxBaseForm.UpdateFormPPI(Integer).)
UpdateInspector | Updates object inspector. (Overrides TfrxCustomDesigner.UpdateInspector.)
UpdatePage | Updates the report designer workspace. (Overrides TfrxCustomDesigner.UpdatePage.)
UpdatePageDimensions | Represents method UpdatePageDimensions.
UpdateRecentFiles(String) | Represents method UpdateRecentFiles(String).
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Inherited from TfrxBaseForm.)
UpdateStyles | Represents method UpdateStyles.
UpdateSyntaxType | Represents method UpdateSyntaxType.
UpdateVirtualGuids(TObject,Extended) | Represents method UpdateVirtualGuids(TObject,Extended).
UpdateWatches | Represents method UpdateWatches.
UpdateWorkSpace(TObject) | Represents method UpdateWorkSpace(TObject).
VariablesCmdExecute(TObject) | Represents method VariablesCmdExecute(TObject).
WMActivateApp(TWMActivateApp) | Represents method WMActivateApp(TWMActivateApp).
WMEnable(TMessage) | Represents method WMEnable(TMessage).
WMSysCommand(TWMSysCommand) | Represents method WMSysCommand(TWMSysCommand).
Top
Fields
Show:
Name | Description
AboutCmd | Represents field AboutCmd.
AboutMI | Represents field AboutMI.
ActionList | Represents field ActionList.
AddChildMI | Represents field AddChildMI.
AlignBottomsB | Represents field AlignBottomsB.
AlignHorzCentersB | Represents field AlignHorzCentersB.
AlignLeftsB | Represents field AlignLeftsB.
AlignmentMI | Represents field AlignmentMI.
AlignRightsB | Represents field AlignRightsB.
AlignTB | Represents field AlignTB.
AlignTBCmd | Represents field AlignTBCmd.
AlignToGridB | Represents field AlignToGridB.
AlignTopsB | Represents field AlignTopsB.
AlignVertCentersB | Represents field AlignVertCentersB.
BackPanel | Represents field BackPanel.
BandsPopup | Represents field BandsPopup.
Bevel1 | Represents field Bevel1.
BoldB | Represents field BoldB.
BoldMI | Represents field BoldMI.
BreakPointB | Represents field BreakPointB.
BringToFrontCmd | Represents field BringToFrontCmd.
BringtoFrontMI | Represents field BringtoFrontMI.
BringtoFrontMI1 | Represents field BringtoFrontMI1.
CenterHorzB | Represents field CenterHorzB.
CenterVertB | Represents field CenterVertB.
ChildMI | Represents field ChildMI.
ChildMI1 | Represents field ChildMI1.
CodeDockSite | Represents field CodeDockSite.
CodePanel | Represents field CodePanel.
CodeTB | Represents field CodeTB.
ColumnFooterMI | Represents field ColumnFooterMI.
ColumnHeaderMI | Represents field ColumnHeaderMI.
CondensedMI | Represents field CondensedMI.
ConnectionsMI | Represents field ConnectionsMI.
CopyB | Represents field CopyB.
CopyCmd | Represents field CopyCmd.
CopyContent1 | Represents field CopyContent1.
CopyContent2 | Represents field CopyContent2.
CopyContentCmd | Represents field CopyContentCmd.
CopyMI | Represents field CopyMI.
CopyMI1 | Represents field CopyMI1.
CutB | Represents field CutB.
CutCmd | Represents field CutCmd.
CutMI | Represents field CutMI.
CutMI1 | Represents field CutMI1.
Data4levelMI | Represents field Data4levelMI.
Data5levelMI | Represents field Data5levelMI.
Data6levelMI | Represents field Data6levelMI.
DataTreeMI | Represents field DataTreeMI.
DataTreeTBCmd | Represents field DataTreeTBCmd.
DeleteCmd | Represents field DeleteCmd.
DeleteGuidesCmd | Represents field DeleteGuidesCmd.
DeleteGuidesMI | Represents field DeleteGuidesMI.
DeleteMI | Represents field DeleteMI.
DeleteMI1 | Represents field DeleteMI1.
DeletePageB | Represents field DeletePageB.
DeletePageCmd | Represents field DeletePageCmd.
DeletePageMI | Represents field DeletePageMI.
DeletePageMI1 | Represents field DeletePageMI1.
DetailDataMI | Represents field DetailDataMI.
DetailDataMI1 | Represents field DetailDataMI1.
DMPPopup | Represents field DMPPopup.
DockBottom | Represents field DockBottom.
DockTop | Represents field DockTop.
EdConfigCmd | Represents field EdConfigCmd.
EdConfigMI | Represents field EdConfigMI.
EditCmd | Represents field EditCmd.
EditMenu | Represents field EditMenu.
EditMI | Represents field EditMI.
EditMI1 | Represents field EditMI1.
EvaluateB | Represents field EvaluateB.
ExitCmd | Represents field ExitCmd.
ExitMI | Represents field ExitMI.
ExtraTBCmd | Represents field ExtraTBCmd.
ExtraToolsTB | Represents field ExtraToolsTB.
FBreakPoints | Represents field FBreakPoints.
FClipboard | Represents field FClipboard.
FCodeWindow | Represents field FCodeWindow.
FColor | Represents field FColor.
FCoord1 | Represents field FCoord1.
FCoord2 | Represents field FCoord2.
FCoord3 | Represents field FCoord3.
FDataTree | Represents field FDataTree.
FDialogForm | Represents field FDialogForm.
FDropFields | Represents field FDropFields.
FEditAfterInsert | Represents field FEditAfterInsert.
FFillColor | Represents field FFillColor.
FFilterList | Represents field FFilterList.
FFontColor | Represents field FFontColor.
FFrameColor | Represents field FFrameColor.
FGridAlign | Represents field FGridAlign.
FGridSize1 | Represents field FGridSize1.
FGridSize2 | Represents field FGridSize2.
FGridSize3 | Represents field FGridSize3.
FGridSize4 | Represents field FGridSize4.
FGuidesAsAnchor | Represents field FGuidesAsAnchor.
FHostedControls | Represents field FHostedControls. (Inherited from TfrxBaseForm.)
FileMenu | Represents field FileMenu.
FillColorB | Represents field FillColorB.
FillColorPopupMenu | Represents field FillColorPopupMenu.
FillEditB | Represents field FillEditB.
FindCmd | Represents field FindCmd.
FindMI | Represents field FindMI.
FindNextCmd | Represents field FindNextCmd.
FindNextMI | Represents field FindNextMI.
FInspector | Represents field FInspector.
FInspectorLock | Represents field FInspectorLock. (Inherited from TfrxCustomDesigner.)
FLineStyle | Represents field FLineStyle.
FLocalizedOI | Represents field FLocalizedOI.
FLockSelectionChanged | Represents field FLockSelectionChanged.
FModified | Represents field FModified. (Inherited from TfrxCustomDesigner.)
FModifiedBy | Represents field FModifiedBy.
FMouseDown | Represents field FMouseDown.
FObjects | Represents field FObjects. (Inherited from TfrxCustomDesigner.)
FOldDesignerComp | Represents field FOldDesignerComp.
FOldUnits | Represents field FOldUnits.
FontB | Represents field FontB.
FontColorB | Represents field FontColorB.
FontColorPopupMenu | Represents field FontColorPopupMenu.
FontNameCB | Represents field FontNameCB.
FontSizeCB | Represents field FontSizeCB.
FooterMI | Represents field FooterMI.
FooterMI1 | Represents field FooterMI1.
FormatToolB | Represents field FormatToolB.
FPage | Represents field FPage. (Inherited from TfrxCustomDesigner.)
FPagePositions | Represents field FPagePositions.
FPictureCache | Represents field FPictureCache.
FPrefEvent | Represents field FPrefEvent. (Inherited from TfrxBaseForm.)
FrameAllB | Represents field FrameAllB.
FrameBottomB | Represents field FrameBottomB.
FrameColorB | Represents field FrameColorB.
FrameColorPopupMenu | Represents field FrameColorPopupMenu.
FrameEditB | Represents field FrameEditB.
FrameLeftB | Represents field FrameLeftB.
FrameMI | Represents field FrameMI.
FrameNoB | Represents field FrameNoB.
FrameRightB | Represents field FrameRightB.
FrameStyleB | Represents field FrameStyleB.
FrameTB | Represents field FrameTB.
FrameTBCmd | Represents field FrameTBCmd.
FrameTopB | Represents field FrameTopB.
FrameWidthCB | Represents field FrameWidthCB.
FRecentFiles | Represents field FRecentFiles.
FRecentMenuIndex | Represents field FRecentMenuIndex.
FReportTree | Represents field FReportTree.
frTBPanel1 | Represents field frTBPanel1.
FSampleFormat | Represents field FSampleFormat.
FScale | Represents field FScale.
FScriptFirstTime | Represents field FScriptFirstTime.
FScriptRunning | Represents field FScriptRunning.
FScriptStep | Represents field FScriptStep.
FScriptStopped | Represents field FScriptStopped.
FSearchCase | Represents field FSearchCase.
FSearchIndex | Represents field FSearchIndex.
FSearchReplace | Represents field FSearchReplace.
FSearchReplaceText | Represents field FSearchReplaceText.
FSearchText | Represents field FSearchText.
FSelectedObjects | Represents field FSelectedObjects. (Inherited from TfrxCustomDesigner.)
FShowGrid | Represents field FShowGrid.
FShowGuides | Represents field FShowGuides.
FShowRulers | Represents field FShowRulers.
FShowStartup | Represents field FShowStartup.
FStatusBarOldWindowProc | Represents field FStatusBarOldWindowProc.
FStickToGuides | Represents field FStickToGuides.
FTabs | Represents field FTabs.
FTemplateExt | Represents field FTemplateExt.
FTemplatePath | Represents field FTemplatePath.
FToolsColor | Represents field FToolsColor.
FUndoBuffer | Represents field FUndoBuffer.
FUnits | Represents field FUnits.
FUnitsDblClicked | Represents field FUnitsDblClicked.
FUpdatingControls | Represents field FUpdatingControls.
FWatchList | Represents field FWatchList.
FWorkspace | Represents field FWorkspace.
FWorkspaceColor | Represents field FWorkspaceColor.
GroupB | Represents field GroupB.
GroupCmd | Represents field GroupCmd.
GroupFooterMI | Represents field GroupFooterMI.
GroupFooterMI1 | Represents field GroupFooterMI1.
GroupHeaderMI | Represents field GroupHeaderMI.
GroupHeaderMI1 | Represents field GroupHeaderMI1.
GroupMI | Represents field GroupMI.
HandToolB | Represents field HandToolB.
HeaderMI | Represents field HeaderMI.
HeaderMI1 | Represents field HeaderMI1.
HelpContentsCmd | Represents field HelpContentsCmd.
HelpContentsMI | Represents field HelpContentsMI.
HelpMenu | Represents field HelpMenu.
HighlightB | Represents field HighlightB.
InspectorMI | Represents field InspectorMI.
InspectorTBCmd | Represents field InspectorTBCmd.
ItalicB | Represents field ItalicB.
ItalicMI | Represents field ItalicMI.
LangCB | Represents field LangCB.
LangL | Represents field LangL.
LeftDockSite1 | Represents field LeftDockSite1.
LeftDockSite2 | Represents field LeftDockSite2.
LeftRuler | Represents field LeftRuler.
MainMenu | Represents field MainMenu.
MasterDataMI | Represents field MasterDataMI.
MasterDataMI1 | Represents field MasterDataMI1.
N1 | Represents field N1.
N12cpiMI | Represents field N12cpiMI.
N15cpiMI | Represents field N15cpiMI.
N2 | Represents field N2.
N3 | Represents field N3.
NewB | Represents field NewB.
NewDialogB | Represents field NewDialogB.
NewDialogCmd | Represents field NewDialogCmd.
NewDialogMI | Represents field NewDialogMI.
NewDialogMI1 | Represents field NewDialogMI1.
NewItemCmd | Represents field NewItemCmd.
NewMI | Represents field NewMI.
NewPageB | Represents field NewPageB.
NewPageCmd | Represents field NewPageCmd.
NewPageMI | Represents field NewPageMI.
NewPageMI1 | Represents field NewPageMI1.
NewReportCmd | Represents field NewReportCmd.
NewReportMI | Represents field NewReportMI.
ObjectBandB | Represents field ObjectBandB.
ObjectSelectB | Represents field ObjectSelectB.
ObjectsPopup | Represents field ObjectsPopup.
ObjectsTB1 | Represents field ObjectsTB1.
OpenB | Represents field OpenB.
OpenCmd | Represents field OpenCmd.
OpenDialog | Represents field OpenDialog.
OpenMI | Represents field OpenMI.
OpenScriptB | Represents field OpenScriptB.
OpenScriptDialog | Represents field OpenScriptDialog.
OptionsCmd | Represents field OptionsCmd.
OptionsMI | Represents field OptionsMI.
OverlayMI | Represents field OverlayMI.
PageFooterMI | Represents field PageFooterMI.
PageHeaderMI | Represents field PageHeaderMI.
PagePopup | Represents field PagePopup.
PageSettingsB | Represents field PageSettingsB.
PageSettingsCmd | Represents field PageSettingsCmd.
PageSettingsMI | Represents field PageSettingsMI.
PageSettingsMI1 | Represents field PageSettingsMI1.
Panel1 | Represents field Panel1.
PanelTB1 | Represents field PanelTB1.
PanelTB2 | Represents field PanelTB2.
PanelTB3 | Represents field PanelTB3.
PasteB | Represents field PasteB.
PasteCmd | Represents field PasteCmd.
PasteMI | Represents field PasteMI.
PasteMI1 | Represents field PasteMI1.
PreviewB | Represents field PreviewB.
PreviewCmd | Represents field PreviewCmd.
PreviewMI | Represents field PreviewMI.
R0MI | Represents field R0MI.
R180MI | Represents field R180MI.
R270MI | Represents field R270MI.
R45MI | Represents field R45MI.
R90MI | Represents field R90MI.
RedoB | Represents field RedoB.
RedoCmd | Represents field RedoCmd.
RedoMI | Represents field RedoMI.
ReplaceCmd | Represents field ReplaceCmd.
ReplaceMI | Represents field ReplaceMI.
ReportDataCmd | Represents field ReportDataCmd.
ReportDataMI | Represents field ReportDataMI.
ReportMenu | Represents field ReportMenu.
ReportOptionsCmd | Represents field ReportOptionsCmd.
ReportSettingsMI | Represents field ReportSettingsMI.
ReportStylesCmd | Represents field ReportStylesCmd.
ReportStylesMI | Represents field ReportStylesMI.
ReportSummaryMI | Represents field ReportSummaryMI.
ReportTitleMI | Represents field ReportTitleMI.
ReportTreeMI | Represents field ReportTreeMI.
ReportTreeTBCmd | Represents field ReportTreeTBCmd.
RevertInheritedChildMI | Represents field RevertInheritedChildMI.
RevertInheritedMI | Represents field RevertInheritedMI.
RightDockSite | Represents field RightDockSite.
RotateB | Represents field RotateB.
RotationPopup | Represents field RotationPopup.
RunScriptB | Represents field RunScriptB.
RunToCursorB | Represents field RunToCursorB.
SameHeightB | Represents field SameHeightB.
SameWidthB | Represents field SameWidthB.
SaveAsCmd | Represents field SaveAsCmd.
SaveAsMI | Represents field SaveAsMI.
SaveB | Represents field SaveB.
SaveCmd | Represents field SaveCmd.
SaveMI | Represents field SaveMI.
SaveScriptB | Represents field SaveScriptB.
SaveScriptDialog | Represents field SaveScriptDialog.
ScaleCB | Represents field ScaleCB.
ScrollBox | Represents field ScrollBox.
ScrollBoxPanel | Represents field ScrollBoxPanel.
SelectAllCmd | Represents field SelectAllCmd.
SelectAllMI | Represents field SelectAllMI.
SelectAllMI1 | Represents field SelectAllMI1.
SelectAllOfTypeCmd | Represents field SelectAllOfTypeCmd.
SelectAllOfTypeMI | Represents field SelectAllOfTypeMI.
SelectAllOfTypeOnPageMI | Represents field SelectAllOfTypeOnPageMI.
SendToBackCmd | Represents field SendToBackCmd.
SendtoBackMI | Represents field SendtoBackMI.
SendtoBackMI1 | Represents field SendtoBackMI1.
SepMI1 | Represents field SepMI1.
SepMI10 | Represents field SepMI10.
SepMI11 | Represents field SepMI11.
SepMI12 | Represents field SepMI12.
SepMI3 | Represents field SepMI3.
SepMI4 | Represents field SepMI4.
SepMI5 | Represents field SepMI5.
SepMI6 | Represents field SepMI6.
SepMI7 | Represents field SepMI7.
SepMI8 | Represents field SepMI8.
SepMI9 | Represents field SepMI9.
SepTB10 | Represents field SepTB10.
SepTB11 | Represents field SepTB11.
SepTB12 | Represents field SepTB12.
SepTB13 | Represents field SepTB13.
SepTB15 | Represents field SepTB15.
SepTB16 | Represents field SepTB16.
SepTB17 | Represents field SepTB17.
SepTB18 | Represents field SepTB18.
SepTB19 | Represents field SepTB19.
SepTB2 | Represents field SepTB2.
SepTB20 | Represents field SepTB20.
SepTB3 | Represents field SepTB3.
SepTB4 | Represents field SepTB4.
SepTB8 | Represents field SepTB8.
SepTB9 | Represents field SepTB9.
SetToGridB | Represents field SetToGridB.
ShowGridB | Represents field ShowGridB.
ShowGuidesCmd | Represents field ShowGuidesCmd.
ShowGuidesMI | Represents field ShowGuidesMI.
ShowRulersCmd | Represents field ShowRulersCmd.
ShowRulersMI | Represents field ShowRulersMI.
SpaceHorzB | Represents field SpaceHorzB.
SpaceVertB | Represents field SpaceVertB.
StandardMI | Represents field StandardMI.
StandardTB | Represents field StandardTB.
StandardTBCmd | Represents field StandardTBCmd.
StatusBar | Represents field StatusBar.
StepScriptB | Represents field StepScriptB.
StopScriptB | Represents field StopScriptB.
StyleCB | Represents field StyleCB.
SubdetailDataMI | Represents field SubdetailDataMI.
SubdetailDataMI1 | Represents field SubdetailDataMI1.
SubScriptMI | Represents field SubScriptMI.
SuperScriptMI | Represents field SuperScriptMI.
TabOrderMI | Represents field TabOrderMI.
TabPanel | Represents field TabPanel.
TabPopup | Represents field TabPopup.
TextAlignBlockB | Represents field TextAlignBlockB.
TextAlignBottomB | Represents field TextAlignBottomB.
TextAlignCenterB | Represents field TextAlignCenterB.
TextAlignLeftB | Represents field TextAlignLeftB.
TextAlignMiddleB | Represents field TextAlignMiddleB.
TextAlignRightB | Represents field TextAlignRightB.
TextAlignTopB | Represents field TextAlignTopB.
TextMI | Represents field TextMI.
TextTB | Represents field TextTB.
TextTBCmd | Represents field TextTBCmd.
TextToolB | Represents field TextToolB.
Timer | Represents field Timer.
ToolbarsCmd | Represents field ToolbarsCmd.
ToolbarsMI | Represents field ToolbarsMI.
ToolButton1 | Represents field ToolButton1.
ToolsMI | Represents field ToolsMI.
TopRuler | Represents field TopRuler.
UnderlineB | Represents field UnderlineB.
UnderlineMI | Represents field UnderlineMI.
UndoB | Represents field UndoB.
UndoCmd | Represents field UndoCmd.
UndoMI | Represents field UndoMI.
UngroupB | Represents field UngroupB.
UngroupCmd | Represents field UngroupCmd.
UngroupMI | Represents field UngroupMI.
VariablesCmd | Represents field VariablesCmd.
VariablesMI | Represents field VariablesMI.
VerticalbandsMI | Represents field VerticalbandsMI.
ViewMenu | Represents field ViewMenu.
WideMI | Represents field WideMI.
ZoomToolB | Represents field ZoomToolB.
Top
See Also

Reference

  • frxDesgn


TfrxDesignerForm Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TfrxDesignerForm class. (Overrides TfrxCustomDesigner.Destroy.)
Top


TfrxDesignerForm.Destroy Destructor

Summary

Represents the destructor of the TfrxDesignerForm class.

Namespace: frxDesgn
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxCustomDesigner.Destroy
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm Properties

Properties
Name | Description
CodeWindow | Represents property CodeWindow.
DataTree | Represents property DataTree.
DropFields | Represents property DropFields.
EditAfterInsert | Represents property EditAfterInsert.
FillColor | Represents property FillColor.
GridAlign | Represents property GridAlign.
GridSize1 | Represents property GridSize1.
GridSize2 | Represents property GridSize2.
GridSize3 | Represents property GridSize3.
GridSize4 | Represents property GridSize4.
GuidesAsAnchor | Represents property GuidesAsAnchor.
Inspector | Represents property Inspector.
PictureCache | Represents property PictureCache.
RecentFiles | Represents property RecentFiles.
ReportTree | Represents property ReportTree.
SampleFormat | Represents property SampleFormat.
Scale | Represents property Scale.
ShowGrid | Represents property ShowGrid.
ShowGuides | Represents property ShowGuides.
ShowRulers | Represents property ShowRulers.
ShowStartup | Represents property ShowStartup.
StickToGuides | Represents property StickToGuides.
TemplatePath | Represents property TemplatePath.
ToolsColor | Represents property ToolsColor.
Units | Represents property Units.
Workspace | Represents property Workspace.
WorkspaceColor | Represents property WorkspaceColor.
Top


TfrxDesignerForm.CodeWindow Property

Summary

Represents property CodeWindow.

Namespace: frxDesgn
Syntax
Delphi
public
 property CodeWindow: TfrxSyntaxMemo read FCodeWindow;

Property Value

Type: TfrxSyntaxMemo

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DataTree Property

Summary

Represents property DataTree.

Namespace: frxDesgn
Syntax
Delphi
public
 property DataTree: TfrxDataTreeForm read FDataTree;

Property Value

Type: TfrxDataTreeForm

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DropFields Property

Summary

Represents property DropFields.

Namespace: frxDesgn
Syntax
Delphi
public
 property DropFields: Boolean read FDropFields write FDropFields;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.EditAfterInsert Property

Summary

Represents property EditAfterInsert.

Namespace: frxDesgn
Syntax
Delphi
public
 property EditAfterInsert: Boolean read FEditAfterInsert write FEditAfterInsert;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FillColor Property

Summary

Represents property FillColor.

Namespace: frxDesgn
Syntax
Delphi
public
 property FillColor: TColor read FFillColor write FFillColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GridAlign Property

Summary

Represents property GridAlign.

Namespace: frxDesgn
Syntax
Delphi
public
 property GridAlign: Boolean read FGridAlign write SetGridAlign;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GridSize1 Property

Summary

Represents property GridSize1.

Namespace: frxDesgn
Syntax
Delphi
public
 property GridSize1: Extended read FGridSize1 write SetGridSize1;

Property Value

Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GridSize2 Property

Summary

Represents property GridSize2.

Namespace: frxDesgn
Syntax
Delphi
public
 property GridSize2: Extended read FGridSize2 write SetGridSize2;

Property Value

Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GridSize3 Property

Summary

Represents property GridSize3.

Namespace: frxDesgn
Syntax
Delphi
public
 property GridSize3: Extended read FGridSize3 write SetGridSize3;

Property Value

Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GridSize4 Property

Summary

Represents property GridSize4.

Namespace: frxDesgn
Syntax
Delphi
public
 property GridSize4: Extended read FGridSize4 write SetGridSize4;

Property Value

Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GuidesAsAnchor Property

Summary

Represents property GuidesAsAnchor.

Namespace: frxDesgn
Syntax
Delphi
public
 property GuidesAsAnchor: Boolean read FGuidesAsAnchor write SetGuidesAsAnchor;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Inspector Property

Summary

Represents property Inspector.

Namespace: frxDesgn
Syntax
Delphi
public
 property Inspector: TfrxObjectInspector read FInspector;

Property Value

Type: TfrxObjectInspector

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PictureCache Property

Summary

Represents property PictureCache.

Namespace: frxDesgn
Syntax
Delphi
public
 property PictureCache: TfrxPictureCache read FPictureCache;

Property Value

Type: TfrxPictureCache

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RecentFiles Property

Summary

Represents property RecentFiles.

Namespace: frxDesgn
Syntax
Delphi
public
 property RecentFiles: TStringList read FRecentFiles;

Property Value

Type: TStringList

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportTree Property

Summary

Represents property ReportTree.

Namespace: frxDesgn
Syntax
Delphi
public
 property ReportTree: TfrxReportTreeForm read FReportTree;

Property Value

Type: TfrxReportTreeForm

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SampleFormat Property

Summary

Represents property SampleFormat.

Namespace: frxDesgn
Syntax
Delphi
public
 property SampleFormat: TSampleFormat read FSampleFormat;

Property Value

Type: TSampleFormat

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Scale Property

Summary

Represents property Scale.

Namespace: frxDesgn
Syntax
Delphi
public
 property Scale: Extended read FScale write SetScale;

Property Value

Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ShowGrid Property

Summary

Represents property ShowGrid.

Namespace: frxDesgn
Syntax
Delphi
public
 property ShowGrid: Boolean read FShowGrid write SetShowGrid;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ShowGuides Property

Summary

Represents property ShowGuides.

Namespace: frxDesgn
Syntax
Delphi
public
 property ShowGuides: Boolean read FShowGuides write SetShowGuides;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ShowRulers Property

Summary

Represents property ShowRulers.

Namespace: frxDesgn
Syntax
Delphi
public
 property ShowRulers: Boolean read FShowRulers write SetShowRulers;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ShowStartup Property

Summary

Represents property ShowStartup.

Namespace: frxDesgn
Syntax
Delphi
public
 property ShowStartup: Boolean read FShowStartup write FShowStartup;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StickToGuides Property

Summary

Represents property StickToGuides.

Namespace: frxDesgn
Syntax
Delphi
public
 property StickToGuides: Boolean read FStickToGuides write SetStickToGuides;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TemplatePath Property

Summary

Represents property TemplatePath.

Namespace: frxDesgn
Syntax
Delphi
public
 property TemplatePath: String read FTemplatePath write FTemplatePath;

Property Value

Type: String

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ToolsColor Property

Summary

Represents property ToolsColor.

Namespace: frxDesgn
Syntax
Delphi
public
 property ToolsColor: TColor read FToolsColor write SetToolsColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Units Property

Summary

Represents property Units.

Namespace: frxDesgn
Syntax
Delphi
public
 property Units: TfrxDesignerUnits read FUnits write SetUnits;

Property Value

Type: TfrxDesignerUnits

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Workspace Property

Summary

Represents property Workspace.

Namespace: frxDesgn
Syntax
Delphi
public
 property Workspace: TfrxDesignerWorkspace read FWorkspace;

Property Value

Type: TfrxDesignerWorkspace

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.WorkspaceColor Property

Summary

Represents property WorkspaceColor.

Namespace: frxDesgn
Syntax
Delphi
public
 property WorkspaceColor: TColor read FWorkspaceColor write SetWorkspaceColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm Methods

Methods
Name | Description
AboutCmdExecute(TObject) | Represents method AboutCmdExecute(TObject).
Activate | Represents method Activate.
AddChildMIClick(TObject) | Represents method AddChildMIClick(TObject).
AfterPPIChange | Represents method AfterPPIChange. (Overrides TfrxBaseForm.AfterPPIChange.)
AfterPPIMessage | Represents method AfterPPIMessage. (Overrides TfrxBaseForm.AfterPPIMessage.)
AlignBottomsBClick(TObject) | Represents method AlignBottomsBClick(TObject).
AlignHorzCentersBClick(TObject) | Represents method AlignHorzCentersBClick(TObject).
AlignLeftsBClick(TObject) | Represents method AlignLeftsBClick(TObject).
AlignRightsBClick(TObject) | Represents method AlignRightsBClick(TObject).
AlignTBCmdExecute(TObject) | Represents method AlignTBCmdExecute(TObject).
AlignToGridBClick(TObject) | Represents method AlignToGridBClick(TObject).
AlignTopsBClick(TObject) | Represents method AlignTopsBClick(TObject).
AlignVertCentersBClick(TObject) | Represents method AlignVertCentersBClick(TObject).
AskSave | Represents method AskSave.
AttachDialogFormEvents(Boolean) | Represents method AttachDialogFormEvents(Boolean).
BandsPopupPopup(TObject) | Represents method BandsPopupPopup(TObject).
BeforePPIChange | Represents method BeforePPIChange. (Overrides TfrxBaseForm.BeforePPIChange.)
BreakPointBClick(TObject) | Represents method BreakPointBClick(TObject).
BringToFrontCmdExecute(TObject) | Represents method BringToFrontCmdExecute(TObject).
CenterHorzBClick(TObject) | Represents method CenterHorzBClick(TObject).
CenterVertBClick(TObject) | Represents method CenterVertBClick(TObject).
CheckOp(TfrxDesignerRestriction) | Used to check restriction of the report designer. Returns True when restriction flag is set in the report designer. (Overrides TfrxCustomDesigner.CheckOp(TfrxDesignerRestriction).)
CMDialogKey(TCMDialogKey) | Represents method CMDialogKey(TCMDialogKey).
CMStartup(TMessage) | Represents method CMStartup(TMessage).
CodeDockSiteDockOver(TObject,TDragDockObject,Integer,Integer,TDragState,Boolean) | Represents method CodeDockSiteDockOver(TObject,TDragDockObject,Integer,Integer,TDragState,Boolean).
CodeWindowDragDrop(TObject,TObject,Integer,Integer) | Represents method CodeWindowDragDrop(TObject,TObject,Integer,Integer).
CodeWindowDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method CodeWindowDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
ConnectionsMIClick(TObject) | Represents method ConnectionsMIClick(TObject).
CopyCmdExecute(TObject) | Represents method CopyCmdExecute(TObject).
CopyContentCmdExecute(TObject) | Represents method CopyContentCmdExecute(TObject).
CreateColorSelector(TToolButton) | Represents method CreateColorSelector(TToolButton).
CreateExtraToolbar | Represents method CreateExtraToolbar.
CreateLangMenu | Represents method CreateLangMenu.
CreateObjectsToolbar | Represents method CreateObjectsToolbar.
CreateToolWindows | Represents method CreateToolWindows.
CreateWorkspace | Represents method CreateWorkspace.
CutCmdExecute(TObject) | Represents method CutCmdExecute(TObject).
DataTreeTBCmdExecute(TObject) | Represents method DataTreeTBCmdExecute(TObject).
Deactivate | Represents method Deactivate.
DeleteCmdExecute(TObject) | Represents method DeleteCmdExecute(TObject).
DeleteGuidesCmdExecute(TObject) | Represents method DeleteGuidesCmdExecute(TObject).
DeletePageCmdExecute(TObject) | Represents method DeletePageCmdExecute(TObject).
DialogFormKeyDown(TObject,Word,TShiftState) | Represents method DialogFormKeyDown(TObject,Word,TShiftState).
DialogFormKeyPress(TObject,Char) | Represents method DialogFormKeyPress(TObject,Char).
DialogFormKeyUp(TObject,Word,TShiftState) | Represents method DialogFormKeyUp(TObject,Word,TShiftState).
DialogFormModify(TObject) | Represents method DialogFormModify(TObject).
DisableInspectorUpdate | Locks object inspector updating. (Overrides TfrxCustomDesigner.DisableInspectorUpdate.)
DoAfterUpdateReport(TfrxDesignerUpdateEvent) | Represents method DoAfterUpdateReport(TfrxDesignerUpdateEvent).
Done | Represents method Done.
DoTopmosts(Boolean) | Represents method DoTopmosts(Boolean).
EdConfigCmdExecute(TObject) | Represents method EdConfigCmdExecute(TObject).
EditCmdExecute(TObject) | Represents method EditCmdExecute(TObject).
EnableInspectorUpdate | Releases object inspector lock. (Overrides TfrxCustomDesigner.EnableInspectorUpdate.)
EvaluateBClick(TObject) | Represents method EvaluateBClick(TObject).
ExitCmdExecute(TObject) | Represents method ExitCmdExecute(TObject).
ExtraTBCmdExecute(TObject) | Represents method ExtraTBCmdExecute(TObject).
FillColorBClick(TObject) | Represents method FillColorBClick(TObject).
FillColorPopupMenuPopup(TObject) | Represents method FillColorPopupMenuPopup(TObject).
FindCmdExecute(TObject) | Represents method FindCmdExecute(TObject).
FindNextCmdExecute(TObject) | Represents method FindNextCmdExecute(TObject).
FindOrReplace(Boolean) | Represents method FindOrReplace(Boolean).
FindText | Represents method FindText.
FontColorBClick(TObject) | Represents method FontColorBClick(TObject).
FontColorPopupMenuPopup(TObject) | Represents method FontColorPopupMenuPopup(TObject).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCloseQuery(TObject,Boolean) | Represents method FormCloseQuery(TObject,Boolean).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
FormMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean) | Represents method FormMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean).
FormShow(TObject) | Represents method FormShow(TObject).
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Overrides TfrxBaseForm.FormShowBeforeLoad.)
FrameColorBClick(TObject) | Represents method FrameColorBClick(TObject).
FrameColorPopupMenuPopup(TObject) | Represents method FrameColorPopupMenuPopup(TObject).
FrameStyleBClick(TObject) | Represents method FrameStyleBClick(TObject).
FrameTBCmdExecute(TObject) | Represents method FrameTBCmdExecute(TObject).
GetAvailablePreferences | Represents method GetAvailablePreferences. (Overrides TfrxBaseForm.GetAvailablePreferences.)
GetCode | Represents method GetCode. (Overrides TfrxCustomDesigner.GetCode.)
GetDataSelectedAsExp | Returns a dataset expression from DataTree selection. (Overrides TfrxCustomDesigner.GetDataSelectedAsExp.)
GetDefaultObjectSize | Represents method GetDefaultObjectSize.
GetDefaultPreferences | Represents method GetDefaultPreferences. (Overrides TfrxCustomDesigner.GetDefaultPreferences.)
GetPageIndex | Represents method GetPageIndex.
GetReportName | Represents method GetReportName.
GetTemplateList(TStrings) | Represents method GetTemplateList(TStrings).
GroupCmdExecute(TObject) | Represents method GroupCmdExecute(TObject).
HelpContentsCmdExecute(TObject) | Represents method HelpContentsCmdExecute(TObject).
HighlightBClick(TObject) | Represents method HighlightBClick(TObject).
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Overrides TfrxBaseForm.HostControls(TWinControl).)
Init | Represents method Init.
InitControls | Represents method InitControls.
InsertBandClick(TObject) | Represents method InsertBandClick(TObject).
InsertExpression(String) | Method shows an "Insert expression" dialogue. It should return an expression string or an empty string if dialogue was canceled. (Overrides TfrxCustomDesigner.InsertExpression(String).)
InspectorTBCmdExecute(TObject) | Represents method InspectorTBCmdExecute(TObject).
InternalCopy | This method processes clipboard copy behaviour. (Overrides TfrxCustomDesigner.InternalCopy.)
InternalIsPasteAvailable | The methods checks if clipboard contains data available to paste in selected object. It serves copy/paste methods of InPlace editors. (Overrides TfrxCustomDesigner.InternalIsPasteAvailable.)
InternalPaste | This method processes clipboard paste behaviour. (Overrides TfrxCustomDesigner.InternalPaste.)
IOTransport(TfrxCustomIOTransport,Boolean,Boolean) | Represents method IOTransport(TfrxCustomIOTransport,Boolean,Boolean).
IsChangedExpression(String,String) | Method shows an "Insert expression" dialogue. It should return an expression string in out OutExpr parameter. Method returns True when expression was changed. (Overrides TfrxCustomDesigner.IsChangedExpression(String,String).)
IsDataTree(TObject) | Checks if passed object is designer DataTree window. Used for drag and drop behaviour. (Overrides TfrxCustomDesigner.IsDataTree(TObject).)
LangCBClick(TObject) | Represents method LangCBClick(TObject).
LangSelectClick(TObject) | Represents method LangSelectClick(TObject).
LoadFile(String,Boolean) | Represents method LoadFile(String,Boolean).
LoadFilter(TfrxCustomIOTransport,String,Boolean) | Represents method LoadFilter(TfrxCustomIOTransport,String,Boolean).
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.LoadFormPreferences(TObject,TObject).)
Localize | Represents method Localize.
Lock | Locks any drawings in the designer window. Use this method when making any changes in the currently edited report. (Overrides TfrxCustomDesigner.Lock.)
mmToUnits(Extended,Boolean) | Represents method mmToUnits(Extended,Boolean).
NewDialogCmdExecute(TObject) | Represents method NewDialogCmdExecute(TObject).
NewItemCmdExecute(TObject) | Represents method NewItemCmdExecute(TObject).
NewPageCmdExecute(TObject) | Represents method NewPageCmdExecute(TObject).
NewReportCmdExecute(TObject) | Represents method NewReportCmdExecute(TObject).
NormalizeTopmosts | Represents method NormalizeTopmosts.
ObjectBandBClick(TObject) | Represents method ObjectBandBClick(TObject).
ObjectsButtonClick(TObject) | Represents method ObjectsButtonClick(TObject).
OnChangePosition(TObject) | Represents method OnChangePosition(TObject).
OnCodeChanged(TObject) | Represents method OnCodeChanged(TObject).
OnCodeCompletion(String,TfrxCompletionList) | Represents method OnCodeCompletion(String,TfrxCompletionList).
OnColorChanged(TObject) | Represents method OnColorChanged(TObject).
OnComponentMenuClick(TObject) | Represents method OnComponentMenuClick(TObject).
OnDataTreeDblClick(TObject) | Represents method OnDataTreeDblClick(TObject).
OnDisableDock(TObject,TDragDockObject) | Represents method OnDisableDock(TObject,TDragDockObject).
OnEditObject(TObject) | Represents method OnEditObject(TObject).
OnEnableDock(TObject,TObject,Integer,Integer) | Represents method OnEnableDock(TObject,TObject,Integer,Integer).
OnEnterWorkSpace(TObject) | Represents method OnEnterWorkSpace(TObject).
OnExtraToolClick(TObject) | Represents method OnExtraToolClick(TObject).
OnInsertObject(TObject) | Represents method OnInsertObject(TObject).
OnModify(TObject) | Represents method OnModify(TObject).
OnNotifyPosition(TfrxRect) | Represents method OnNotifyPosition(TfrxRect).
OnRunLine(TfsScript,String,String) | Represents method OnRunLine(TfsScript,String,String).
OnSaveFilterExecute(TObject) | Represents method OnSaveFilterExecute(TObject).
OnSelectionChanged(TObject) | Represents method OnSelectionChanged(TObject).
OnStyleChanged(TObject) | Represents method OnStyleChanged(TObject).
OpenCmdExecute(TObject) | Represents method OpenCmdExecute(TObject).
OpenRecentFile(TObject) | Represents method OpenRecentFile(TObject).
OpenScriptBClick(TObject) | Represents method OpenScriptBClick(TObject).
OptionsCmdExecute(TObject) | Represents method OptionsCmdExecute(TObject).
PagePopupPopup(TObject) | Represents method PagePopupPopup(TObject).
PageSettingsCmdExecute(TObject) | Represents method PageSettingsCmdExecute(TObject).
PasteCmdExecute(TObject) | Represents method PasteCmdExecute(TObject).
PreviewCmdExecute(TObject) | Represents method PreviewCmdExecute(TObject).
ReadButtonImages | Represents method ReadButtonImages.
RedoCmdExecute(TObject) | Represents method RedoCmdExecute(TObject).
ReloadObjects(Boolean) | Reloads all report objects in the report designer. (Overrides TfrxCustomDesigner.ReloadObjects(Boolean).)
ReloadPages(Integer) | Reloads all report's pages. Use this method if you add or delete a report page. The Index parameter defines which page should be made active. (Overrides TfrxCustomDesigner.ReloadPages(Integer).)
ReloadReport | Reloads all report contents. (Overrides TfrxCustomDesigner.ReloadReport.)
ReplaceCmdExecute(TObject) | Represents method ReplaceCmdExecute(TObject).
ReportDataCmdExecute(TObject) | Represents method ReportDataCmdExecute(TObject).
ReportDataEdit | Calls DataSets selection dialog. (Overrides TfrxCustomDesigner.ReportDataEdit.)
ReportEditVariable | Calls report variables editor dialog. (Overrides TfrxCustomDesigner.ReportEditVariable.)
ReportOptionsCmdExecute(TObject) | Represents method ReportOptionsCmdExecute(TObject).
ReportStylesCmdExecute(TObject) | Represents method ReportStylesCmdExecute(TObject).
ReportTreeTBCmdExecute(TObject) | Represents method ReportTreeTBCmdExecute(TObject).
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Overrides TfrxBaseForm.ResetFormPreferences(TObject).)
RestorePagePosition | Represents method RestorePagePosition.
RestoreState(Boolean,Boolean) | Represents method RestoreState(Boolean,Boolean).
RestoreTopmosts | Represents method RestoreTopmosts.
RevertInheritedMIClick(TObject) | Represents method RevertInheritedMIClick(TObject).
RunScriptBClick(TObject) | Represents method RunScriptBClick(TObject).
RunToCursorBClick(TObject) | Represents method RunToCursorBClick(TObject).
SameHeightBClick(TObject) | Represents method SameHeightBClick(TObject).
SameWidthBClick(TObject) | Represents method SameWidthBClick(TObject).
SaveAsCmdExecute(TObject) | Represents method SaveAsCmdExecute(TObject).
SaveCmdExecute(TObject) | Represents method SaveCmdExecute(TObject).
SaveFile(Boolean,Boolean) | Represents method SaveFile(Boolean,Boolean).
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.SaveFormPreferences(TObject,TObject).)
SavePagePosition | Represents method SavePagePosition.
SaveScriptBClick(TObject) | Represents method SaveScriptBClick(TObject).
ScaleCBClick(TObject) | Represents method ScaleCBClick(TObject).
ScaleControls | Represents method ScaleControls.
ScrollBoxMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean) | Represents method ScrollBoxMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean).
ScrollBoxMouseWheelDown(TObject,TShiftState,TPoint,Boolean) | Represents method ScrollBoxMouseWheelDown(TObject,TShiftState,TPoint,Boolean).
ScrollBoxMouseWheelUp(TObject,TShiftState,TPoint,Boolean) | Represents method ScrollBoxMouseWheelUp(TObject,TShiftState,TPoint,Boolean).
ScrollBoxResize(TObject) | Represents method ScrollBoxResize(TObject).
SelectAllCmdExecute(TObject) | Represents method SelectAllCmdExecute(TObject).
SelectAllOfTypeCmdExecute(TObject) | Represents method SelectAllOfTypeCmdExecute(TObject).
SelectToolBClick(TObject) | Represents method SelectToolBClick(TObject).
SendToBackCmdExecute(TObject) | Represents method SendToBackCmdExecute(TObject).
SetChange | Represents method SetChange.
SetGridAlign(Boolean) | Represents method SetGridAlign(Boolean).
SetGridSize1(Extended) | Represents method SetGridSize1(Extended).
SetGridSize2(Extended) | Represents method SetGridSize2(Extended).
SetGridSize3(Extended) | Represents method SetGridSize3(Extended).
SetGridSize4(Extended) | Represents method SetGridSize4(Extended).
SetGuidesAsAnchor(Boolean) | Represents method SetGuidesAsAnchor(Boolean).
SetModified(Boolean) | Represents method SetModified(Boolean). (Overrides TfrxCustomDesigner.SetModified(Boolean).)
SetPage(TfrxPage) | Represents method SetPage(TfrxPage). (Overrides TfrxCustomDesigner.SetPage(TfrxPage).)
SetReportDefaults | Represents method SetReportDefaults.
SetScale(Extended) | Represents method SetScale(Extended).
SetShowGrid(Boolean) | Represents method SetShowGrid(Boolean).
SetShowGuides(Boolean) | Represents method SetShowGuides(Boolean).
SetShowRulers(Boolean) | Represents method SetShowRulers(Boolean).
SetStickToGuides(Boolean) | Represents method SetStickToGuides(Boolean).
SetToolsColor(TColor) | Represents method SetToolsColor(TColor).
SetUnits(TfrxDesignerUnits) | Represents method SetUnits(TfrxDesignerUnits).
SetWorkspaceColor(TColor) | Represents method SetWorkspaceColor(TColor).
ShowGridBClick(TObject) | Represents method ShowGridBClick(TObject).
ShowGuidesCmdExecute(TObject) | Represents method ShowGuidesCmdExecute(TObject).
ShowRulersCmdExecute(TObject) | Represents method ShowRulersCmdExecute(TObject).
SpaceHorzBClick(TObject) | Represents method SpaceHorzBClick(TObject).
SpaceVertBClick(TObject) | Represents method SpaceVertBClick(TObject).
StandardTBCmdExecute(TObject) | Represents method StandardTBCmdExecute(TObject).
StatusBarDblClick(TObject) | Represents method StatusBarDblClick(TObject).
StatusBarDrawPanel(TStatusBar,TStatusPanel,TRect) | Represents method StatusBarDrawPanel(TStatusBar,TStatusPanel,TRect).
StatusBarMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method StatusBarMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
StatusBarWndProc(TMessage) | Represents method StatusBarWndProc(TMessage).
StopScriptBClick(TObject) | Represents method StopScriptBClick(TObject).
SwitchToCodeWindow | Represents method SwitchToCodeWindow.
SwitchToolbar | Represents method SwitchToolbar.
TabChange(TObject) | Represents method TabChange(TObject).
TabChanging(TObject,Boolean) | Represents method TabChanging(TObject,Boolean).
TabDragDrop(TObject,TObject,Integer,Integer) | Represents method TabDragDrop(TObject,TObject,Integer,Integer).
TabDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method TabDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
TabMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method TabMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
TabMouseMove(TObject,TShiftState,Integer,Integer) | Represents method TabMouseMove(TObject,TShiftState,Integer,Integer).
TabMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method TabMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer).
TabOrderMIClick(TObject) | Represents method TabOrderMIClick(TObject).
TabSetChange(TObject,Integer,Boolean) | Represents method TabSetChange(TObject,Integer,Boolean).
TextTBCmdExecute(TObject) | Represents method TextTBCmdExecute(TObject).
TimerTimer(TObject) | Represents method TimerTimer(TObject).
ToolbarsCmdExecute(TObject) | Represents method ToolbarsCmdExecute(TObject).
ToolButtonClick(TObject) | Represents method ToolButtonClick(TObject).
TopRulerDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method TopRulerDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
UndoCmdExecute(TObject) | Represents method UndoCmdExecute(TObject).
UngroupCmdExecute(TObject) | Represents method UngroupCmdExecute(TObject).
UnitsTomm(Extended,Boolean) | Represents method UnitsTomm(Extended,Boolean).
UnSetChange | Represents method UnSetChange.
UpdateCaption | Represents method UpdateCaption.
UpdateControls | Represents method UpdateControls.
UpdateDataTree | Updates the "Data Tree" tool window. (Overrides TfrxCustomDesigner.UpdateDataTree.)
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Overrides TfrxBaseForm.UpdateFormPPI(Integer).)
UpdateInspector | Updates object inspector. (Overrides TfrxCustomDesigner.UpdateInspector.)
UpdatePage | Updates the report designer workspace. (Overrides TfrxCustomDesigner.UpdatePage.)
UpdatePageDimensions | Represents method UpdatePageDimensions.
UpdateRecentFiles(String) | Represents method UpdateRecentFiles(String).
UpdateStyles | Represents method UpdateStyles.
UpdateSyntaxType | Represents method UpdateSyntaxType.
UpdateVirtualGuids(TObject,Extended) | Represents method UpdateVirtualGuids(TObject,Extended).
UpdateWatches | Represents method UpdateWatches.
UpdateWorkSpace(TObject) | Represents method UpdateWorkSpace(TObject).
VariablesCmdExecute(TObject) | Represents method VariablesCmdExecute(TObject).
WMActivateApp(TWMActivateApp) | Represents method WMActivateApp(TWMActivateApp).
WMEnable(TMessage) | Represents method WMEnable(TMessage).
WMSysCommand(TWMSysCommand) | Represents method WMSysCommand(TWMSysCommand).
Top


TfrxDesignerForm.AboutCmdExecute(TObject) Method

Summary

Represents method AboutCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure AboutCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Activate Method

Summary

Represents method Activate.

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure Activate; override;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AddChildMIClick(TObject) Method

Summary

Represents method AddChildMIClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure AddChildMIClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AfterPPIChange Method

Summary

Represents method AfterPPIChange.

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure AfterPPIChange; override;

Overrides

TfrxBaseForm.AfterPPIChange
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AfterPPIMessage Method

Summary

Represents method AfterPPIMessage.

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure AfterPPIMessage; override;

Overrides

TfrxBaseForm.AfterPPIMessage
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignBottomsBClick(TObject) Method

Summary

Represents method AlignBottomsBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure AlignBottomsBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignHorzCentersBClick(TObject) Method

Summary

Represents method AlignHorzCentersBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure AlignHorzCentersBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignLeftsBClick(TObject) Method

Summary

Represents method AlignLeftsBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure AlignLeftsBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignRightsBClick(TObject) Method

Summary

Represents method AlignRightsBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure AlignRightsBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignTBCmdExecute(TObject) Method

Summary

Represents method AlignTBCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure AlignTBCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignToGridBClick(TObject) Method

Summary

Represents method AlignToGridBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure AlignToGridBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignTopsBClick(TObject) Method

Summary

Represents method AlignTopsBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure AlignTopsBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignVertCentersBClick(TObject) Method

Summary

Represents method AlignVertCentersBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure AlignVertCentersBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AskSave Method

Summary

Represents method AskSave.

Namespace: frxDesgn
Syntax
Delphi
private
 function AskSave: Word;

Return Value

Type: Word

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AttachDialogFormEvents(Boolean) Method

Summary

Represents method AttachDialogFormEvents(Boolean).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure AttachDialogFormEvents(Attach: Boolean);

Parameters

Attach
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.BandsPopupPopup(TObject) Method

Summary

Represents method BandsPopupPopup(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure BandsPopupPopup(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.BeforePPIChange Method

Summary

Represents method BeforePPIChange.

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure BeforePPIChange; override;

Overrides

TfrxBaseForm.BeforePPIChange
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.BreakPointBClick(TObject) Method

Summary

Represents method BreakPointBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure BreakPointBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.BringToFrontCmdExecute(TObject) Method

Summary

Represents method BringToFrontCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure BringToFrontCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CenterHorzBClick(TObject) Method

Summary

Represents method CenterHorzBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure CenterHorzBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CenterVertBClick(TObject) Method

Summary

Represents method CenterVertBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure CenterVertBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CheckOp(TfrxDesignerRestriction) Method

Summary

Used to check restriction of the report designer. Returns True when restriction flag is set in the report designer.

Namespace: frxDesgn
Syntax
Delphi
public
 function CheckOp(Op: TfrxDesignerRestriction): Boolean; override;

Parameters

Op
Type: TfrxDesignerRestriction

Restriction flag.

Return Value

Type: Boolean

Overrides

TfrxCustomDesigner.CheckOp(TfrxDesignerRestriction)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CMDialogKey(TCMDialogKey) Method

Summary

Represents method CMDialogKey(TCMDialogKey).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure CMDialogKey(var Message: TCMDialogKey); message CM_DIALOGKEY;

Parameters

Message
Type: TCMDialogKey

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CMStartup(TMessage) Method

Summary

Represents method CMStartup(TMessage).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure CMStartup(var Message: TMessage); message WM_USER + 1;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CodeDockSiteDockOver(TObject,TDragDockObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method CodeDockSiteDockOver(TObject,TDragDockObject,Integer,Integer,TDragState,Boolean).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure CodeDockSiteDockOver(Sender: TObject;
 Source: TDragDockObject; X, Y: Integer; State: TDragState;
 var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TDragDockObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CodeWindowDragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method CodeWindowDragDrop(TObject,TObject,Integer,Integer).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure CodeWindowDragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CodeWindowDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method CodeWindowDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure CodeWindowDragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ConnectionsMIClick(TObject) Method

Summary

Represents method ConnectionsMIClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ConnectionsMIClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CopyCmdExecute(TObject) Method

Summary

Represents method CopyCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure CopyCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CopyContentCmdExecute(TObject) Method

Summary

Represents method CopyContentCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure CopyContentCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CreateColorSelector(TToolButton) Method

Summary

Represents method CreateColorSelector(TToolButton).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure CreateColorSelector(Sender: TToolButton);

Parameters

Sender
Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CreateExtraToolbar Method

Summary

Represents method CreateExtraToolbar.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure CreateExtraToolbar;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CreateLangMenu Method

Summary

Represents method CreateLangMenu.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure CreateLangMenu;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CreateObjectsToolbar Method

Summary

Represents method CreateObjectsToolbar.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure CreateObjectsToolbar;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CreateToolWindows Method

Summary

Represents method CreateToolWindows.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure CreateToolWindows;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CreateWorkspace Method

Summary

Represents method CreateWorkspace.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure CreateWorkspace;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CutCmdExecute(TObject) Method

Summary

Represents method CutCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure CutCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DataTreeTBCmdExecute(TObject) Method

Summary

Represents method DataTreeTBCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure DataTreeTBCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Deactivate Method

Summary

Represents method Deactivate.

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure Deactivate; override;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DeleteCmdExecute(TObject) Method

Summary

Represents method DeleteCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure DeleteCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DeleteGuidesCmdExecute(TObject) Method

Summary

Represents method DeleteGuidesCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure DeleteGuidesCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DeletePageCmdExecute(TObject) Method

Summary

Represents method DeletePageCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure DeletePageCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DialogFormKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method DialogFormKeyDown(TObject,Word,TShiftState).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure DialogFormKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DialogFormKeyPress(TObject,Char) Method

Summary

Represents method DialogFormKeyPress(TObject,Char).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure DialogFormKeyPress(Sender: TObject; var Key: Char);

Parameters

Sender
Type: TObject

Key
Type: Char

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DialogFormKeyUp(TObject,Word,TShiftState) Method

Summary

Represents method DialogFormKeyUp(TObject,Word,TShiftState).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure DialogFormKeyUp(Sender: TObject; var Key: Word;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DialogFormModify(TObject) Method

Summary

Represents method DialogFormModify(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure DialogFormModify(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DisableInspectorUpdate Method

Summary

Locks object inspector updating.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure DisableInspectorUpdate; override;

Overrides

TfrxCustomDesigner.DisableInspectorUpdate
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DoAfterUpdateReport(TfrxDesignerUpdateEvent) Method

Summary

Represents method DoAfterUpdateReport(TfrxDesignerUpdateEvent).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure DoAfterUpdateReport(EventType: TfrxDesignerUpdateEvent);

Parameters

EventType
Type: TfrxDesignerUpdateEvent

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Done Method

Summary

Represents method Done.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure Done;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DoTopmosts(Boolean) Method

Summary

Represents method DoTopmosts(Boolean).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure DoTopmosts(Enable: Boolean);

Parameters

Enable
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.EdConfigCmdExecute(TObject) Method

Summary

Represents method EdConfigCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure EdConfigCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.EditCmdExecute(TObject) Method

Summary

Represents method EditCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure EditCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.EnableInspectorUpdate Method

Summary

Releases object inspector lock.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure EnableInspectorUpdate; override;

Overrides

TfrxCustomDesigner.EnableInspectorUpdate
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.EvaluateBClick(TObject) Method

Summary

Represents method EvaluateBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure EvaluateBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ExitCmdExecute(TObject) Method

Summary

Represents method ExitCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ExitCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ExtraTBCmdExecute(TObject) Method

Summary

Represents method ExtraTBCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ExtraTBCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FillColorBClick(TObject) Method

Summary

Represents method FillColorBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FillColorBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FillColorPopupMenuPopup(TObject) Method

Summary

Represents method FillColorPopupMenuPopup(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FillColorPopupMenuPopup(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FindCmdExecute(TObject) Method

Summary

Represents method FindCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FindCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FindNextCmdExecute(TObject) Method

Summary

Represents method FindNextCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FindNextCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FindOrReplace(Boolean) Method

Summary

Represents method FindOrReplace(Boolean).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure FindOrReplace(replace: Boolean);

Parameters

replace
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FindText Method

Summary

Represents method FindText.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure FindText;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FontColorBClick(TObject) Method

Summary

Represents method FontColorBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FontColorBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FontColorPopupMenuPopup(TObject) Method

Summary

Represents method FontColorPopupMenuPopup(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FontColorPopupMenuPopup(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FormCloseQuery(TObject,Boolean) Method

Summary

Represents method FormCloseQuery(TObject,Boolean).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FormCloseQuery(Sender: TObject; var CanClose: Boolean);

Parameters

Sender
Type: TObject

CanClose
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FormKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method FormKeyDown(TObject,Word,TShiftState).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FormKeyDown(Sender: TObject; var Key: Word;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FormMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean) Method

Summary

Represents method FormMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FormMouseWheel(Sender: TObject; Shift: TShiftState;
 WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

Handled
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FormShowBeforeLoad Method

Summary

Represents method FormShowBeforeLoad.

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure FormShowBeforeLoad; override;

Overrides

TfrxBaseForm.FormShowBeforeLoad
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameColorBClick(TObject) Method

Summary

Represents method FrameColorBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FrameColorBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameColorPopupMenuPopup(TObject) Method

Summary

Represents method FrameColorPopupMenuPopup(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FrameColorPopupMenuPopup(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameStyleBClick(TObject) Method

Summary

Represents method FrameStyleBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FrameStyleBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameTBCmdExecute(TObject) Method

Summary

Represents method FrameTBCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure FrameTBCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GetAvailablePreferences Method

Summary

Represents method GetAvailablePreferences.

Namespace: frxDesgn
Syntax
Delphi
protected
 function GetAvailablePreferences: TfrxPreferencesTypes; override;

Return Value

Type: TfrxPreferencesTypes

Overrides

TfrxBaseForm.GetAvailablePreferences
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GetCode Method

Summary

Represents method GetCode.

Namespace: frxDesgn
Syntax
Delphi
protected
 function GetCode: TStrings; override;

Return Value

Type: TStrings

Overrides

TfrxCustomDesigner.GetCode
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GetDataSelectedAsExp Method

Summary

Returns a dataset expression from DataTree selection.

Namespace: frxDesgn
Syntax
Delphi
public
 function GetDataSelectedAsExp: String; override;

Return Value

Type: String

Overrides

TfrxCustomDesigner.GetDataSelectedAsExp
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GetDefaultObjectSize Method

Summary

Represents method GetDefaultObjectSize.

Namespace: frxDesgn
Syntax
Delphi
public
 function GetDefaultObjectSize: TfrxPoint;

Return Value

Type: TfrxPoint

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GetDefaultPreferences Method

Summary

Represents method GetDefaultPreferences.

Namespace: frxDesgn
Syntax
Delphi
protected
 function GetDefaultPreferences: TObject; override;

Return Value

Type: TObject

Overrides

TfrxCustomDesigner.GetDefaultPreferences
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GetPageIndex Method

Summary

Represents method GetPageIndex.

Namespace: frxDesgn
Syntax
Delphi
private
 function GetPageIndex: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GetReportName Method

Summary

Represents method GetReportName.

Namespace: frxDesgn
Syntax
Delphi
private
 function GetReportName: String;

Return Value

Type: String

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GetTemplateList(TStrings) Method

Summary

Represents method GetTemplateList(TStrings).

Namespace: frxDesgn
Syntax
Delphi
public
 procedure GetTemplateList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GroupCmdExecute(TObject) Method

Summary

Represents method GroupCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure GroupCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.HelpContentsCmdExecute(TObject) Method

Summary

Represents method HelpContentsCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure HelpContentsCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.HighlightBClick(TObject) Method

Summary

Represents method HighlightBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure HighlightBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.HostControls(TWinControl) Method

Summary

Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure HostControls(Host: TWinControl); override;

Parameters

Host
Type: TWinControl

Host control for form objects.

Overrides

TfrxBaseForm.HostControls(TWinControl)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Init Method

Summary

Represents method Init.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure Init;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.InitControls Method

Summary

Represents method InitControls.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure InitControls;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.InsertBandClick(TObject) Method

Summary

Represents method InsertBandClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure InsertBandClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.InsertExpression(String) Method

Summary

Method shows an "Insert expression" dialogue. It should return an expression string or an empty string if dialogue was canceled.

Namespace: frxDesgn
Syntax
Delphi
public
 function InsertExpression(const Expr: String): String; override;

Parameters

Expr
Type: String

Return Value

Type: String

Overrides

TfrxCustomDesigner.InsertExpression(String)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.InspectorTBCmdExecute(TObject) Method

Summary

Represents method InspectorTBCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure InspectorTBCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.InternalCopy Method

Summary

This method processes clipboard copy behaviour.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure InternalCopy; override;

Overrides

TfrxCustomDesigner.InternalCopy
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.InternalIsPasteAvailable Method

Summary

The methods checks if clipboard contains data available to paste in selected object. It serves copy/paste methods of InPlace editors.

Namespace: frxDesgn
Syntax
Delphi
public
 function InternalIsPasteAvailable: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCustomDesigner.InternalIsPasteAvailable
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.InternalPaste Method

Summary

This method processes clipboard paste behaviour.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure InternalPaste; override;

Overrides

TfrxCustomDesigner.InternalPaste
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.IOTransport(TfrxCustomIOTransport,Boolean,Boolean) Method

Summary

Represents method IOTransport(TfrxCustomIOTransport,Boolean,Boolean).

Namespace: frxDesgn
Syntax
Delphi
public
 function IOTransport(aFilter: TfrxCustomIOTransport; SaveAs: Boolean; UseOnSaveEvent: Boolean): Boolean;

Parameters

aFilter
Type: TfrxCustomIOTransport

SaveAs
Type: Boolean

UseOnSaveEvent
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.IsChangedExpression(String,String) Method

Summary

Method shows an "Insert expression" dialogue. It should return an expression string in out OutExpr parameter. Method returns True when expression was changed.

Namespace: frxDesgn
Syntax
Delphi
public
 function IsChangedExpression(const InExpr: String; out OutExpr: String): Boolean; override;

Parameters

InExpr
Type: String

OutExpr
Type: String

Return Value

Type: Boolean

Overrides

TfrxCustomDesigner.IsChangedExpression(String,String)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.IsDataTree(TObject) Method

Summary

Checks if passed object is designer DataTree window. Used for drag and drop behaviour.

Namespace: frxDesgn
Syntax
Delphi
public
 function IsDataTree(aObject: TObject): Boolean; override;

Parameters

aObject
Type: TObject

Reference to an object.

Return Value

Type: Boolean

Overrides

TfrxCustomDesigner.IsDataTree(TObject)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.LangCBClick(TObject) Method

Summary

Represents method LangCBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure LangCBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.LangSelectClick(TObject) Method

Summary

Represents method LangSelectClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure LangSelectClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.LoadFile(String,Boolean) Method

Summary

Represents method LoadFile(String,Boolean).

Namespace: frxDesgn
Syntax
Delphi
public
 procedure LoadFile(FileName: String; UseOnLoadEvent: Boolean);

Parameters

FileName
Type: String

UseOnLoadEvent
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.LoadFilter(TfrxCustomIOTransport,String,Boolean) Method

Summary

Represents method LoadFilter(TfrxCustomIOTransport,String,Boolean).

Namespace: frxDesgn
Syntax
Delphi
public
 procedure LoadFilter(aFilter: TfrxCustomIOTransport; FileName: String; UseOnLoadEvent: Boolean);

Parameters

aFilter
Type: TfrxCustomIOTransport

FileName
Type: String

UseOnLoadEvent
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.LoadFormPreferences(TObject,TObject) Method

Summary

Represents method LoadFormPreferences(TObject,TObject).

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure LoadFormPreferences(PreferencesStorage: TObject; DefPreferencesStorage: TObject); override;

Parameters

PreferencesStorage
Type: TObject

DefPreferencesStorage
Type: TObject

Overrides

TfrxBaseForm.LoadFormPreferences(TObject,TObject)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Localize Method

Summary

Represents method Localize.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure Localize;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Lock Method

Summary

Locks any drawings in the designer window. Use this method when making any changes in the currently edited report.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure Lock; override;

Overrides

TfrxCustomDesigner.Lock
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.mmToUnits(Extended,Boolean) Method

Summary

Represents method mmToUnits(Extended,Boolean).

Namespace: frxDesgn
Syntax
Delphi
public
 function mmToUnits(mm: Extended; X: Boolean = True): Extended;

Parameters

mm
Type: Extended

X
Type: Boolean

Return Value

Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewDialogCmdExecute(TObject) Method

Summary

Represents method NewDialogCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure NewDialogCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewItemCmdExecute(TObject) Method

Summary

Represents method NewItemCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure NewItemCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewPageCmdExecute(TObject) Method

Summary

Represents method NewPageCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure NewPageCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewReportCmdExecute(TObject) Method

Summary

Represents method NewReportCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure NewReportCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NormalizeTopmosts Method

Summary

Represents method NormalizeTopmosts.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure NormalizeTopmosts;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ObjectBandBClick(TObject) Method

Summary

Represents method ObjectBandBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ObjectBandBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ObjectsButtonClick(TObject) Method

Summary

Represents method ObjectsButtonClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ObjectsButtonClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnChangePosition(TObject) Method

Summary

Represents method OnChangePosition(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnChangePosition(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnCodeChanged(TObject) Method

Summary

Represents method OnCodeChanged(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnCodeChanged(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnCodeCompletion(String,TfrxCompletionList) Method

Summary

Represents method OnCodeCompletion(String,TfrxCompletionList).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnCodeCompletion(const Name: String; List: TfrxCompletionList);

Parameters

Name
Type: String

List
Type: TfrxCompletionList

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnColorChanged(TObject) Method

Summary

Represents method OnColorChanged(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnColorChanged(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnComponentMenuClick(TObject) Method

Summary

Represents method OnComponentMenuClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnComponentMenuClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnDataTreeDblClick(TObject) Method

Summary

Represents method OnDataTreeDblClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnDataTreeDblClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnDisableDock(TObject,TDragDockObject) Method

Summary

Represents method OnDisableDock(TObject,TDragDockObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnDisableDock(Sender: TObject; var DragObject: TDragDockObject);

Parameters

Sender
Type: TObject

DragObject
Type: TDragDockObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnEditObject(TObject) Method

Summary

Represents method OnEditObject(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnEditObject(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnEnableDock(TObject,TObject,Integer,Integer) Method

Summary

Represents method OnEnableDock(TObject,TObject,Integer,Integer).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnEnableDock(Sender, Target: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Target
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnEnterWorkSpace(TObject) Method

Summary

Represents method OnEnterWorkSpace(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnEnterWorkSpace(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnExtraToolClick(TObject) Method

Summary

Represents method OnExtraToolClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnExtraToolClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnInsertObject(TObject) Method

Summary

Represents method OnInsertObject(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnInsertObject(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnModify(TObject) Method

Summary

Represents method OnModify(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnModify(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnNotifyPosition(TfrxRect) Method

Summary

Represents method OnNotifyPosition(TfrxRect).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnNotifyPosition(ARect: TfrxRect);

Parameters

ARect
Type: TfrxRect

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnRunLine(TfsScript,String,String) Method

Summary

Represents method OnRunLine(TfsScript,String,String).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnRunLine(Sender: TfsScript; const UnitName, SourcePos: String);

Parameters

Sender
Type: TfsScript

UnitName
Type: String

SourcePos
Type: String

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnSaveFilterExecute(TObject) Method

Summary

Represents method OnSaveFilterExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnSaveFilterExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnSelectionChanged(TObject) Method

Summary

Represents method OnSelectionChanged(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnSelectionChanged(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OnStyleChanged(TObject) Method

Summary

Represents method OnStyleChanged(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OnStyleChanged(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OpenCmdExecute(TObject) Method

Summary

Represents method OpenCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure OpenCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OpenRecentFile(TObject) Method

Summary

Represents method OpenRecentFile(TObject).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure OpenRecentFile(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OpenScriptBClick(TObject) Method

Summary

Represents method OpenScriptBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure OpenScriptBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OptionsCmdExecute(TObject) Method

Summary

Represents method OptionsCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure OptionsCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PagePopupPopup(TObject) Method

Summary

Represents method PagePopupPopup(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure PagePopupPopup(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PageSettingsCmdExecute(TObject) Method

Summary

Represents method PageSettingsCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure PageSettingsCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PasteCmdExecute(TObject) Method

Summary

Represents method PasteCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure PasteCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PreviewCmdExecute(TObject) Method

Summary

Represents method PreviewCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure PreviewCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReadButtonImages Method

Summary

Represents method ReadButtonImages.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure ReadButtonImages;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RedoCmdExecute(TObject) Method

Summary

Represents method RedoCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure RedoCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReloadObjects(Boolean) Method

Summary

Reloads all report objects in the report designer.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure ReloadObjects(ResetSelection: Boolean = True); override;

Parameters

ResetSelection
Type: Boolean

Reset objects selection in the report designer.

Overrides

TfrxCustomDesigner.ReloadObjects(Boolean)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReloadPages(Integer) Method

Summary

Reloads all report's pages. Use this method if you add or delete a report page. The Index parameter defines which page should be made active.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure ReloadPages(Index: Integer); override;

Parameters

Index
Type: Integer

Overrides

TfrxCustomDesigner.ReloadPages(Integer)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReloadReport Method

Summary

Reloads all report contents.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure ReloadReport; override;

Overrides

TfrxCustomDesigner.ReloadReport
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReplaceCmdExecute(TObject) Method

Summary

Represents method ReplaceCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ReplaceCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportDataCmdExecute(TObject) Method

Summary

Represents method ReportDataCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ReportDataCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportDataEdit Method

Summary

Calls DataSets selection dialog.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure ReportDataEdit; override;

Overrides

TfrxCustomDesigner.ReportDataEdit
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportEditVariable Method

Summary

Calls report variables editor dialog.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure ReportEditVariable; override;

Overrides

TfrxCustomDesigner.ReportEditVariable
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportOptionsCmdExecute(TObject) Method

Summary

Represents method ReportOptionsCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ReportOptionsCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportStylesCmdExecute(TObject) Method

Summary

Represents method ReportStylesCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ReportStylesCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportTreeTBCmdExecute(TObject) Method

Summary

Represents method ReportTreeTBCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ReportTreeTBCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ResetFormPreferences(TObject) Method

Summary

Represents method ResetFormPreferences(TObject).

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure ResetFormPreferences(PreferencesStorage: TObject); override;

Parameters

PreferencesStorage
Type: TObject

Overrides

TfrxBaseForm.ResetFormPreferences(TObject)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RestorePagePosition Method

Summary

Represents method RestorePagePosition.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure RestorePagePosition;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RestoreState(Boolean,Boolean) Method

Summary

Represents method RestoreState(Boolean,Boolean).

Namespace: frxDesgn
Syntax
Delphi
public
 procedure RestoreState(RestoreDefault: Boolean = False;
 RestoreMainForm: Boolean = False);

Parameters

RestoreDefault
Type: Boolean

RestoreMainForm
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RestoreTopmosts Method

Summary

Represents method RestoreTopmosts.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure RestoreTopmosts;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RevertInheritedMIClick(TObject) Method

Summary

Represents method RevertInheritedMIClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure RevertInheritedMIClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RunScriptBClick(TObject) Method

Summary

Represents method RunScriptBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure RunScriptBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RunToCursorBClick(TObject) Method

Summary

Represents method RunToCursorBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure RunToCursorBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SameHeightBClick(TObject) Method

Summary

Represents method SameHeightBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure SameHeightBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SameWidthBClick(TObject) Method

Summary

Represents method SameWidthBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure SameWidthBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SaveAsCmdExecute(TObject) Method

Summary

Represents method SaveAsCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure SaveAsCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SaveCmdExecute(TObject) Method

Summary

Represents method SaveCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure SaveCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SaveFile(Boolean,Boolean) Method

Summary

Represents method SaveFile(Boolean,Boolean).

Namespace: frxDesgn
Syntax
Delphi
public
 function SaveFile(SaveAs: Boolean; UseOnSaveEvent: Boolean): Boolean;

Parameters

SaveAs
Type: Boolean

UseOnSaveEvent
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SaveFormPreferences(TObject,TObject) Method

Summary

Represents method SaveFormPreferences(TObject,TObject).

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure SaveFormPreferences(PreferencesStorage: TObject; DefPreferencesStorage: TObject); override;

Parameters

PreferencesStorage
Type: TObject

DefPreferencesStorage
Type: TObject

Overrides

TfrxBaseForm.SaveFormPreferences(TObject,TObject)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SavePagePosition Method

Summary

Represents method SavePagePosition.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SavePagePosition;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SaveScriptBClick(TObject) Method

Summary

Represents method SaveScriptBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure SaveScriptBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ScaleCBClick(TObject) Method

Summary

Represents method ScaleCBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ScaleCBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ScaleControls Method

Summary

Represents method ScaleControls.

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure ScaleControls;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ScrollBoxMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean) Method

Summary

Represents method ScrollBoxMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean).

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure ScrollBoxMouseWheel(Sender: TObject; Shift: TShiftState;
 WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

Handled
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ScrollBoxMouseWheelDown(TObject,TShiftState,TPoint,Boolean) Method

Summary

Represents method ScrollBoxMouseWheelDown(TObject,TShiftState,TPoint,Boolean).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ScrollBoxMouseWheelDown(Sender: TObject; Shift: TShiftState;
 MousePos: TPoint; var Handled: Boolean);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

MousePos
Type: TPoint

Handled
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ScrollBoxMouseWheelUp(TObject,TShiftState,TPoint,Boolean) Method

Summary

Represents method ScrollBoxMouseWheelUp(TObject,TShiftState,TPoint,Boolean).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ScrollBoxMouseWheelUp(Sender: TObject; Shift: TShiftState;
 MousePos: TPoint; var Handled: Boolean);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

MousePos
Type: TPoint

Handled
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ScrollBoxResize(TObject) Method

Summary

Represents method ScrollBoxResize(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ScrollBoxResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SelectAllCmdExecute(TObject) Method

Summary

Represents method SelectAllCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure SelectAllCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SelectAllOfTypeCmdExecute(TObject) Method

Summary

Represents method SelectAllOfTypeCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure SelectAllOfTypeCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SelectToolBClick(TObject) Method

Summary

Represents method SelectToolBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure SelectToolBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SendToBackCmdExecute(TObject) Method

Summary

Represents method SendToBackCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure SendToBackCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetChange Method

Summary

Represents method SetChange.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetChange();
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetGridAlign(Boolean) Method

Summary

Represents method SetGridAlign(Boolean).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetGridAlign(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetGridSize1(Extended) Method

Summary

Represents method SetGridSize1(Extended).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetGridSize1(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetGridSize2(Extended) Method

Summary

Represents method SetGridSize2(Extended).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetGridSize2(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetGridSize3(Extended) Method

Summary

Represents method SetGridSize3(Extended).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetGridSize3(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetGridSize4(Extended) Method

Summary

Represents method SetGridSize4(Extended).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetGridSize4(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetGuidesAsAnchor(Boolean) Method

Summary

Represents method SetGuidesAsAnchor(Boolean).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetGuidesAsAnchor(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetModified(Boolean) Method

Summary

Represents method SetModified(Boolean).

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure SetModified(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TfrxCustomDesigner.SetModified(Boolean)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetPage(TfrxPage) Method

Summary

Represents method SetPage(TfrxPage).

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure SetPage(const Value: TfrxPage); override;

Parameters

Value
Type: TfrxPage

Overrides

TfrxCustomDesigner.SetPage(TfrxPage)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetReportDefaults Method

Summary

Represents method SetReportDefaults.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure SetReportDefaults;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetScale(Extended) Method

Summary

Represents method SetScale(Extended).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetScale(Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetShowGrid(Boolean) Method

Summary

Represents method SetShowGrid(Boolean).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetShowGrid(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetShowGuides(Boolean) Method

Summary

Represents method SetShowGuides(Boolean).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetShowGuides(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetShowRulers(Boolean) Method

Summary

Represents method SetShowRulers(Boolean).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetShowRulers(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetStickToGuides(Boolean) Method

Summary

Represents method SetStickToGuides(Boolean).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetStickToGuides(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetToolsColor(TColor) Method

Summary

Represents method SetToolsColor(TColor).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetToolsColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetUnits(TfrxDesignerUnits) Method

Summary

Represents method SetUnits(TfrxDesignerUnits).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetUnits(const Value: TfrxDesignerUnits);

Parameters

Value
Type: TfrxDesignerUnits

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetWorkspaceColor(TColor) Method

Summary

Represents method SetWorkspaceColor(TColor).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SetWorkspaceColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ShowGridBClick(TObject) Method

Summary

Represents method ShowGridBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ShowGridBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ShowGuidesCmdExecute(TObject) Method

Summary

Represents method ShowGuidesCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ShowGuidesCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ShowRulersCmdExecute(TObject) Method

Summary

Represents method ShowRulersCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ShowRulersCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SpaceHorzBClick(TObject) Method

Summary

Represents method SpaceHorzBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure SpaceHorzBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SpaceVertBClick(TObject) Method

Summary

Represents method SpaceVertBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure SpaceVertBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StandardTBCmdExecute(TObject) Method

Summary

Represents method StandardTBCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure StandardTBCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StatusBarDblClick(TObject) Method

Summary

Represents method StatusBarDblClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure StatusBarDblClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StatusBarDrawPanel(TStatusBar,TStatusPanel,TRect) Method

Summary

Represents method StatusBarDrawPanel(TStatusBar,TStatusPanel,TRect).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure StatusBarDrawPanel(StatusBar: TStatusBar;
 Panel: TStatusPanel; const ARect: TRect);

Parameters

StatusBar
Type: TStatusBar

Panel
Type: TStatusPanel

ARect
Type: TRect

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StatusBarMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method StatusBarMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure StatusBarMouseDown(Sender: TObject; Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StatusBarWndProc(TMessage) Method

Summary

Represents method StatusBarWndProc(TMessage).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure StatusBarWndProc(var Message: TMessage);

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StopScriptBClick(TObject) Method

Summary

Represents method StopScriptBClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure StopScriptBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SwitchToCodeWindow Method

Summary

Represents method SwitchToCodeWindow.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure SwitchToCodeWindow;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SwitchToolbar Method

Summary

Represents method SwitchToolbar.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure SwitchToolbar;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TabChange(TObject) Method

Summary

Represents method TabChange(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure TabChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TabChanging(TObject,Boolean) Method

Summary

Represents method TabChanging(TObject,Boolean).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure TabChanging(Sender: TObject; var AllowChange: Boolean);

Parameters

Sender
Type: TObject

AllowChange
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TabDragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method TabDragDrop(TObject,TObject,Integer,Integer).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure TabDragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TabDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method TabDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure TabDragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TabMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method TabMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure TabMouseDown(Sender: TObject; Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TabMouseMove(TObject,TShiftState,Integer,Integer) Method

Summary

Represents method TabMouseMove(TObject,TShiftState,Integer,Integer).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure TabMouseMove(Sender: TObject; Shift: TShiftState; X,
 Y: Integer);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TabMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method TabMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure TabMouseUp(Sender: TObject; Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TabOrderMIClick(TObject) Method

Summary

Represents method TabOrderMIClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure TabOrderMIClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TabSetChange(TObject,Integer,Boolean) Method

Summary

Represents method TabSetChange(TObject,Integer,Boolean).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure TabSetChange(Sender: TObject; NewTab: Integer;
 var AllowChange: Boolean);

Parameters

Sender
Type: TObject

NewTab
Type: Integer

AllowChange
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TextTBCmdExecute(TObject) Method

Summary

Represents method TextTBCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure TextTBCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TimerTimer(TObject) Method

Summary

Represents method TimerTimer(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure TimerTimer(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ToolbarsCmdExecute(TObject) Method

Summary

Represents method ToolbarsCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ToolbarsCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ToolButtonClick(TObject) Method

Summary

Represents method ToolButtonClick(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure ToolButtonClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TopRulerDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method TopRulerDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure TopRulerDragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UndoCmdExecute(TObject) Method

Summary

Represents method UndoCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure UndoCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UngroupCmdExecute(TObject) Method

Summary

Represents method UngroupCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure UngroupCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UnitsTomm(Extended,Boolean) Method

Summary

Represents method UnitsTomm(Extended,Boolean).

Namespace: frxDesgn
Syntax
Delphi
public
 function UnitsTomm(mm: Extended; X: Boolean = True): Extended;

Parameters

mm
Type: Extended

X
Type: Boolean

Return Value

Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UnSetChange Method

Summary

Represents method UnSetChange.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure UnSetChange();
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdateCaption Method

Summary

Represents method UpdateCaption.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure UpdateCaption;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdateControls Method

Summary

Represents method UpdateControls.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure UpdateControls;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdateDataTree Method

Summary

Updates the "Data Tree" tool window.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure UpdateDataTree; override;

Overrides

TfrxCustomDesigner.UpdateDataTree
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdateFormPPI(Integer) Method

Summary

Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure UpdateFormPPI(aNewPPI: Integer); override;

Parameters

aNewPPI
Type: Integer

New PPI value.

Overrides

TfrxBaseForm.UpdateFormPPI(Integer)
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdateInspector Method

Summary

Updates object inspector.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure UpdateInspector; override;

Overrides

TfrxCustomDesigner.UpdateInspector
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdatePage Method

Summary

Updates the report designer workspace.

Namespace: frxDesgn
Syntax
Delphi
public
 procedure UpdatePage; override;

Overrides

TfrxCustomDesigner.UpdatePage
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdatePageDimensions Method

Summary

Represents method UpdatePageDimensions.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure UpdatePageDimensions;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdateRecentFiles(String) Method

Summary

Represents method UpdateRecentFiles(String).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure UpdateRecentFiles(NewFile: String);

Parameters

NewFile
Type: String

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdateStyles Method

Summary

Represents method UpdateStyles.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure UpdateStyles;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdateSyntaxType Method

Summary

Represents method UpdateSyntaxType.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure UpdateSyntaxType;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdateVirtualGuids(TObject,Extended) Method

Summary

Represents method UpdateVirtualGuids(TObject,Extended).

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure UpdateVirtualGuids(Sender: TObject; Position: Extended);

Parameters

Sender
Type: TObject

Position
Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdateWatches Method

Summary

Represents method UpdateWatches.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure UpdateWatches;
See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UpdateWorkSpace(TObject) Method

Summary

Represents method UpdateWorkSpace(TObject).

Namespace: frxDesgn
Syntax
Delphi
protected
 procedure UpdateWorkSpace(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.VariablesCmdExecute(TObject) Method

Summary

Represents method VariablesCmdExecute(TObject).

Namespace: frxDesgn
Syntax
Delphi
published
 procedure VariablesCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.WMActivateApp(TWMActivateApp) Method

Summary

Represents method WMActivateApp(TWMActivateApp).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure WMActivateApp(var Message: TWMActivateApp); message WM_ACTIVATEAPP;

Parameters

Message
Type: TWMActivateApp

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.WMEnable(TMessage) Method

Summary

Represents method WMEnable(TMessage).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure WMEnable(var Message: TMessage); message WM_ENABLE;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.WMSysCommand(TWMSysCommand) Method

Summary

Represents method WMSysCommand(TWMSysCommand).

Namespace: frxDesgn
Syntax
Delphi
private
 procedure WMSysCommand(var Message: TWMSysCommand); message WM_SYSCOMMAND;

Parameters

Message
Type: TWMSysCommand

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm Fields

Fields
Name | Description
AboutCmd | Represents field AboutCmd.
AboutMI | Represents field AboutMI.
ActionList | Represents field ActionList.
AddChildMI | Represents field AddChildMI.
AlignBottomsB | Represents field AlignBottomsB.
AlignHorzCentersB | Represents field AlignHorzCentersB.
AlignLeftsB | Represents field AlignLeftsB.
AlignmentMI | Represents field AlignmentMI.
AlignRightsB | Represents field AlignRightsB.
AlignTB | Represents field AlignTB.
AlignTBCmd | Represents field AlignTBCmd.
AlignToGridB | Represents field AlignToGridB.
AlignTopsB | Represents field AlignTopsB.
AlignVertCentersB | Represents field AlignVertCentersB.
BackPanel | Represents field BackPanel.
BandsPopup | Represents field BandsPopup.
Bevel1 | Represents field Bevel1.
BoldB | Represents field BoldB.
BoldMI | Represents field BoldMI.
BreakPointB | Represents field BreakPointB.
BringToFrontCmd | Represents field BringToFrontCmd.
BringtoFrontMI | Represents field BringtoFrontMI.
BringtoFrontMI1 | Represents field BringtoFrontMI1.
CenterHorzB | Represents field CenterHorzB.
CenterVertB | Represents field CenterVertB.
ChildMI | Represents field ChildMI.
ChildMI1 | Represents field ChildMI1.
CodeDockSite | Represents field CodeDockSite.
CodePanel | Represents field CodePanel.
CodeTB | Represents field CodeTB.
ColumnFooterMI | Represents field ColumnFooterMI.
ColumnHeaderMI | Represents field ColumnHeaderMI.
CondensedMI | Represents field CondensedMI.
ConnectionsMI | Represents field ConnectionsMI.
CopyB | Represents field CopyB.
CopyCmd | Represents field CopyCmd.
CopyContent1 | Represents field CopyContent1.
CopyContent2 | Represents field CopyContent2.
CopyContentCmd | Represents field CopyContentCmd.
CopyMI | Represents field CopyMI.
CopyMI1 | Represents field CopyMI1.
CutB | Represents field CutB.
CutCmd | Represents field CutCmd.
CutMI | Represents field CutMI.
CutMI1 | Represents field CutMI1.
Data4levelMI | Represents field Data4levelMI.
Data5levelMI | Represents field Data5levelMI.
Data6levelMI | Represents field Data6levelMI.
DataTreeMI | Represents field DataTreeMI.
DataTreeTBCmd | Represents field DataTreeTBCmd.
DeleteCmd | Represents field DeleteCmd.
DeleteGuidesCmd | Represents field DeleteGuidesCmd.
DeleteGuidesMI | Represents field DeleteGuidesMI.
DeleteMI | Represents field DeleteMI.
DeleteMI1 | Represents field DeleteMI1.
DeletePageB | Represents field DeletePageB.
DeletePageCmd | Represents field DeletePageCmd.
DeletePageMI | Represents field DeletePageMI.
DeletePageMI1 | Represents field DeletePageMI1.
DetailDataMI | Represents field DetailDataMI.
DetailDataMI1 | Represents field DetailDataMI1.
DMPPopup | Represents field DMPPopup.
DockBottom | Represents field DockBottom.
DockTop | Represents field DockTop.
EdConfigCmd | Represents field EdConfigCmd.
EdConfigMI | Represents field EdConfigMI.
EditCmd | Represents field EditCmd.
EditMenu | Represents field EditMenu.
EditMI | Represents field EditMI.
EditMI1 | Represents field EditMI1.
EvaluateB | Represents field EvaluateB.
ExitCmd | Represents field ExitCmd.
ExitMI | Represents field ExitMI.
ExtraTBCmd | Represents field ExtraTBCmd.
ExtraToolsTB | Represents field ExtraToolsTB.
FBreakPoints | Represents field FBreakPoints.
FClipboard | Represents field FClipboard.
FCodeWindow | Represents field FCodeWindow.
FColor | Represents field FColor.
FCoord1 | Represents field FCoord1.
FCoord2 | Represents field FCoord2.
FCoord3 | Represents field FCoord3.
FDataTree | Represents field FDataTree.
FDialogForm | Represents field FDialogForm.
FDropFields | Represents field FDropFields.
FEditAfterInsert | Represents field FEditAfterInsert.
FFillColor | Represents field FFillColor.
FFilterList | Represents field FFilterList.
FFontColor | Represents field FFontColor.
FFrameColor | Represents field FFrameColor.
FGridAlign | Represents field FGridAlign.
FGridSize1 | Represents field FGridSize1.
FGridSize2 | Represents field FGridSize2.
FGridSize3 | Represents field FGridSize3.
FGridSize4 | Represents field FGridSize4.
FGuidesAsAnchor | Represents field FGuidesAsAnchor.
FileMenu | Represents field FileMenu.
FillColorB | Represents field FillColorB.
FillColorPopupMenu | Represents field FillColorPopupMenu.
FillEditB | Represents field FillEditB.
FindCmd | Represents field FindCmd.
FindMI | Represents field FindMI.
FindNextCmd | Represents field FindNextCmd.
FindNextMI | Represents field FindNextMI.
FInspector | Represents field FInspector.
FLineStyle | Represents field FLineStyle.
FLocalizedOI | Represents field FLocalizedOI.
FLockSelectionChanged | Represents field FLockSelectionChanged.
FModifiedBy | Represents field FModifiedBy.
FMouseDown | Represents field FMouseDown.
FOldDesignerComp | Represents field FOldDesignerComp.
FOldUnits | Represents field FOldUnits.
FontB | Represents field FontB.
FontColorB | Represents field FontColorB.
FontColorPopupMenu | Represents field FontColorPopupMenu.
FontNameCB | Represents field FontNameCB.
FontSizeCB | Represents field FontSizeCB.
FooterMI | Represents field FooterMI.
FooterMI1 | Represents field FooterMI1.
FormatToolB | Represents field FormatToolB.
FPagePositions | Represents field FPagePositions.
FPictureCache | Represents field FPictureCache.
FrameAllB | Represents field FrameAllB.
FrameBottomB | Represents field FrameBottomB.
FrameColorB | Represents field FrameColorB.
FrameColorPopupMenu | Represents field FrameColorPopupMenu.
FrameEditB | Represents field FrameEditB.
FrameLeftB | Represents field FrameLeftB.
FrameMI | Represents field FrameMI.
FrameNoB | Represents field FrameNoB.
FrameRightB | Represents field FrameRightB.
FrameStyleB | Represents field FrameStyleB.
FrameTB | Represents field FrameTB.
FrameTBCmd | Represents field FrameTBCmd.
FrameTopB | Represents field FrameTopB.
FrameWidthCB | Represents field FrameWidthCB.
FRecentFiles | Represents field FRecentFiles.
FRecentMenuIndex | Represents field FRecentMenuIndex.
FReportTree | Represents field FReportTree.
frTBPanel1 | Represents field frTBPanel1.
FSampleFormat | Represents field FSampleFormat.
FScale | Represents field FScale.
FScriptFirstTime | Represents field FScriptFirstTime.
FScriptRunning | Represents field FScriptRunning.
FScriptStep | Represents field FScriptStep.
FScriptStopped | Represents field FScriptStopped.
FSearchCase | Represents field FSearchCase.
FSearchIndex | Represents field FSearchIndex.
FSearchReplace | Represents field FSearchReplace.
FSearchReplaceText | Represents field FSearchReplaceText.
FSearchText | Represents field FSearchText.
FShowGrid | Represents field FShowGrid.
FShowGuides | Represents field FShowGuides.
FShowRulers | Represents field FShowRulers.
FShowStartup | Represents field FShowStartup.
FStatusBarOldWindowProc | Represents field FStatusBarOldWindowProc.
FStickToGuides | Represents field FStickToGuides.
FTabs | Represents field FTabs.
FTemplateExt | Represents field FTemplateExt.
FTemplatePath | Represents field FTemplatePath.
FToolsColor | Represents field FToolsColor.
FUndoBuffer | Represents field FUndoBuffer.
FUnits | Represents field FUnits.
FUnitsDblClicked | Represents field FUnitsDblClicked.
FUpdatingControls | Represents field FUpdatingControls.
FWatchList | Represents field FWatchList.
FWorkspace | Represents field FWorkspace.
FWorkspaceColor | Represents field FWorkspaceColor.
GroupB | Represents field GroupB.
GroupCmd | Represents field GroupCmd.
GroupFooterMI | Represents field GroupFooterMI.
GroupFooterMI1 | Represents field GroupFooterMI1.
GroupHeaderMI | Represents field GroupHeaderMI.
GroupHeaderMI1 | Represents field GroupHeaderMI1.
GroupMI | Represents field GroupMI.
HandToolB | Represents field HandToolB.
HeaderMI | Represents field HeaderMI.
HeaderMI1 | Represents field HeaderMI1.
HelpContentsCmd | Represents field HelpContentsCmd.
HelpContentsMI | Represents field HelpContentsMI.
HelpMenu | Represents field HelpMenu.
HighlightB | Represents field HighlightB.
InspectorMI | Represents field InspectorMI.
InspectorTBCmd | Represents field InspectorTBCmd.
ItalicB | Represents field ItalicB.
ItalicMI | Represents field ItalicMI.
LangCB | Represents field LangCB.
LangL | Represents field LangL.
LeftDockSite1 | Represents field LeftDockSite1.
LeftDockSite2 | Represents field LeftDockSite2.
LeftRuler | Represents field LeftRuler.
MainMenu | Represents field MainMenu.
MasterDataMI | Represents field MasterDataMI.
MasterDataMI1 | Represents field MasterDataMI1.
N1 | Represents field N1.
N12cpiMI | Represents field N12cpiMI.
N15cpiMI | Represents field N15cpiMI.
N2 | Represents field N2.
N3 | Represents field N3.
NewB | Represents field NewB.
NewDialogB | Represents field NewDialogB.
NewDialogCmd | Represents field NewDialogCmd.
NewDialogMI | Represents field NewDialogMI.
NewDialogMI1 | Represents field NewDialogMI1.
NewItemCmd | Represents field NewItemCmd.
NewMI | Represents field NewMI.
NewPageB | Represents field NewPageB.
NewPageCmd | Represents field NewPageCmd.
NewPageMI | Represents field NewPageMI.
NewPageMI1 | Represents field NewPageMI1.
NewReportCmd | Represents field NewReportCmd.
NewReportMI | Represents field NewReportMI.
ObjectBandB | Represents field ObjectBandB.
ObjectSelectB | Represents field ObjectSelectB.
ObjectsPopup | Represents field ObjectsPopup.
ObjectsTB1 | Represents field ObjectsTB1.
OpenB | Represents field OpenB.
OpenCmd | Represents field OpenCmd.
OpenDialog | Represents field OpenDialog.
OpenMI | Represents field OpenMI.
OpenScriptB | Represents field OpenScriptB.
OpenScriptDialog | Represents field OpenScriptDialog.
OptionsCmd | Represents field OptionsCmd.
OptionsMI | Represents field OptionsMI.
OverlayMI | Represents field OverlayMI.
PageFooterMI | Represents field PageFooterMI.
PageHeaderMI | Represents field PageHeaderMI.
PagePopup | Represents field PagePopup.
PageSettingsB | Represents field PageSettingsB.
PageSettingsCmd | Represents field PageSettingsCmd.
PageSettingsMI | Represents field PageSettingsMI.
PageSettingsMI1 | Represents field PageSettingsMI1.
Panel1 | Represents field Panel1.
PanelTB1 | Represents field PanelTB1.
PanelTB2 | Represents field PanelTB2.
PanelTB3 | Represents field PanelTB3.
PasteB | Represents field PasteB.
PasteCmd | Represents field PasteCmd.
PasteMI | Represents field PasteMI.
PasteMI1 | Represents field PasteMI1.
PreviewB | Represents field PreviewB.
PreviewCmd | Represents field PreviewCmd.
PreviewMI | Represents field PreviewMI.
R0MI | Represents field R0MI.
R180MI | Represents field R180MI.
R270MI | Represents field R270MI.
R45MI | Represents field R45MI.
R90MI | Represents field R90MI.
RedoB | Represents field RedoB.
RedoCmd | Represents field RedoCmd.
RedoMI | Represents field RedoMI.
ReplaceCmd | Represents field ReplaceCmd.
ReplaceMI | Represents field ReplaceMI.
ReportDataCmd | Represents field ReportDataCmd.
ReportDataMI | Represents field ReportDataMI.
ReportMenu | Represents field ReportMenu.
ReportOptionsCmd | Represents field ReportOptionsCmd.
ReportSettingsMI | Represents field ReportSettingsMI.
ReportStylesCmd | Represents field ReportStylesCmd.
ReportStylesMI | Represents field ReportStylesMI.
ReportSummaryMI | Represents field ReportSummaryMI.
ReportTitleMI | Represents field ReportTitleMI.
ReportTreeMI | Represents field ReportTreeMI.
ReportTreeTBCmd | Represents field ReportTreeTBCmd.
RevertInheritedChildMI | Represents field RevertInheritedChildMI.
RevertInheritedMI | Represents field RevertInheritedMI.
RightDockSite | Represents field RightDockSite.
RotateB | Represents field RotateB.
RotationPopup | Represents field RotationPopup.
RunScriptB | Represents field RunScriptB.
RunToCursorB | Represents field RunToCursorB.
SameHeightB | Represents field SameHeightB.
SameWidthB | Represents field SameWidthB.
SaveAsCmd | Represents field SaveAsCmd.
SaveAsMI | Represents field SaveAsMI.
SaveB | Represents field SaveB.
SaveCmd | Represents field SaveCmd.
SaveMI | Represents field SaveMI.
SaveScriptB | Represents field SaveScriptB.
SaveScriptDialog | Represents field SaveScriptDialog.
ScaleCB | Represents field ScaleCB.
ScrollBox | Represents field ScrollBox.
ScrollBoxPanel | Represents field ScrollBoxPanel.
SelectAllCmd | Represents field SelectAllCmd.
SelectAllMI | Represents field SelectAllMI.
SelectAllMI1 | Represents field SelectAllMI1.
SelectAllOfTypeCmd | Represents field SelectAllOfTypeCmd.
SelectAllOfTypeMI | Represents field SelectAllOfTypeMI.
SelectAllOfTypeOnPageMI | Represents field SelectAllOfTypeOnPageMI.
SendToBackCmd | Represents field SendToBackCmd.
SendtoBackMI | Represents field SendtoBackMI.
SendtoBackMI1 | Represents field SendtoBackMI1.
SepMI1 | Represents field SepMI1.
SepMI10 | Represents field SepMI10.
SepMI11 | Represents field SepMI11.
SepMI12 | Represents field SepMI12.
SepMI3 | Represents field SepMI3.
SepMI4 | Represents field SepMI4.
SepMI5 | Represents field SepMI5.
SepMI6 | Represents field SepMI6.
SepMI7 | Represents field SepMI7.
SepMI8 | Represents field SepMI8.
SepMI9 | Represents field SepMI9.
SepTB10 | Represents field SepTB10.
SepTB11 | Represents field SepTB11.
SepTB12 | Represents field SepTB12.
SepTB13 | Represents field SepTB13.
SepTB15 | Represents field SepTB15.
SepTB16 | Represents field SepTB16.
SepTB17 | Represents field SepTB17.
SepTB18 | Represents field SepTB18.
SepTB19 | Represents field SepTB19.
SepTB2 | Represents field SepTB2.
SepTB20 | Represents field SepTB20.
SepTB3 | Represents field SepTB3.
SepTB4 | Represents field SepTB4.
SepTB8 | Represents field SepTB8.
SepTB9 | Represents field SepTB9.
SetToGridB | Represents field SetToGridB.
ShowGridB | Represents field ShowGridB.
ShowGuidesCmd | Represents field ShowGuidesCmd.
ShowGuidesMI | Represents field ShowGuidesMI.
ShowRulersCmd | Represents field ShowRulersCmd.
ShowRulersMI | Represents field ShowRulersMI.
SpaceHorzB | Represents field SpaceHorzB.
SpaceVertB | Represents field SpaceVertB.
StandardMI | Represents field StandardMI.
StandardTB | Represents field StandardTB.
StandardTBCmd | Represents field StandardTBCmd.
StatusBar | Represents field StatusBar.
StepScriptB | Represents field StepScriptB.
StopScriptB | Represents field StopScriptB.
StyleCB | Represents field StyleCB.
SubdetailDataMI | Represents field SubdetailDataMI.
SubdetailDataMI1 | Represents field SubdetailDataMI1.
SubScriptMI | Represents field SubScriptMI.
SuperScriptMI | Represents field SuperScriptMI.
TabOrderMI | Represents field TabOrderMI.
TabPanel | Represents field TabPanel.
TabPopup | Represents field TabPopup.
TextAlignBlockB | Represents field TextAlignBlockB.
TextAlignBottomB | Represents field TextAlignBottomB.
TextAlignCenterB | Represents field TextAlignCenterB.
TextAlignLeftB | Represents field TextAlignLeftB.
TextAlignMiddleB | Represents field TextAlignMiddleB.
TextAlignRightB | Represents field TextAlignRightB.
TextAlignTopB | Represents field TextAlignTopB.
TextMI | Represents field TextMI.
TextTB | Represents field TextTB.
TextTBCmd | Represents field TextTBCmd.
TextToolB | Represents field TextToolB.
Timer | Represents field Timer.
ToolbarsCmd | Represents field ToolbarsCmd.
ToolbarsMI | Represents field ToolbarsMI.
ToolButton1 | Represents field ToolButton1.
ToolsMI | Represents field ToolsMI.
TopRuler | Represents field TopRuler.
UnderlineB | Represents field UnderlineB.
UnderlineMI | Represents field UnderlineMI.
UndoB | Represents field UndoB.
UndoCmd | Represents field UndoCmd.
UndoMI | Represents field UndoMI.
UngroupB | Represents field UngroupB.
UngroupCmd | Represents field UngroupCmd.
UngroupMI | Represents field UngroupMI.
VariablesCmd | Represents field VariablesCmd.
VariablesMI | Represents field VariablesMI.
VerticalbandsMI | Represents field VerticalbandsMI.
ViewMenu | Represents field ViewMenu.
WideMI | Represents field WideMI.
ZoomToolB | Represents field ZoomToolB.
Top


TfrxDesignerForm.AboutCmd Field

Summary

Represents field AboutCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 AboutCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AboutMI Field

Summary

Represents field AboutMI.

Namespace: frxDesgn
Syntax
Delphi
published
 AboutMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ActionList Field

Summary

Represents field ActionList.

Namespace: frxDesgn
Syntax
Delphi
published
 ActionList: TActionList;

Field Value

Type: TActionList

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AddChildMI Field

Summary

Represents field AddChildMI.

Namespace: frxDesgn
Syntax
Delphi
published
 AddChildMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignBottomsB Field

Summary

Represents field AlignBottomsB.

Namespace: frxDesgn
Syntax
Delphi
published
 AlignBottomsB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignHorzCentersB Field

Summary

Represents field AlignHorzCentersB.

Namespace: frxDesgn
Syntax
Delphi
published
 AlignHorzCentersB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignLeftsB Field

Summary

Represents field AlignLeftsB.

Namespace: frxDesgn
Syntax
Delphi
published
 AlignLeftsB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignmentMI Field

Summary

Represents field AlignmentMI.

Namespace: frxDesgn
Syntax
Delphi
published
 AlignmentMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignRightsB Field

Summary

Represents field AlignRightsB.

Namespace: frxDesgn
Syntax
Delphi
published
 AlignRightsB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignTB Field

Summary

Represents field AlignTB.

Namespace: frxDesgn
Syntax
Delphi
published
 AlignTB: TToolBar;

Field Value

Type: TToolBar

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignTBCmd Field

Summary

Represents field AlignTBCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 AlignTBCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignToGridB Field

Summary

Represents field AlignToGridB.

Namespace: frxDesgn
Syntax
Delphi
published
 AlignToGridB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignTopsB Field

Summary

Represents field AlignTopsB.

Namespace: frxDesgn
Syntax
Delphi
published
 AlignTopsB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.AlignVertCentersB Field

Summary

Represents field AlignVertCentersB.

Namespace: frxDesgn
Syntax
Delphi
published
 AlignVertCentersB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.BackPanel Field

Summary

Represents field BackPanel.

Namespace: frxDesgn
Syntax
Delphi
published
 BackPanel: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.BandsPopup Field

Summary

Represents field BandsPopup.

Namespace: frxDesgn
Syntax
Delphi
published
 BandsPopup: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Bevel1 Field

Summary

Represents field Bevel1.

Namespace: frxDesgn
Syntax
Delphi
published
 Bevel1: TBevel;

Field Value

Type: TBevel

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.BoldB Field

Summary

Represents field BoldB.

Namespace: frxDesgn
Syntax
Delphi
published
 BoldB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.BoldMI Field

Summary

Represents field BoldMI.

Namespace: frxDesgn
Syntax
Delphi
published
 BoldMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.BreakPointB Field

Summary

Represents field BreakPointB.

Namespace: frxDesgn
Syntax
Delphi
published
 BreakPointB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.BringToFrontCmd Field

Summary

Represents field BringToFrontCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 BringToFrontCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.BringtoFrontMI Field

Summary

Represents field BringtoFrontMI.

Namespace: frxDesgn
Syntax
Delphi
published
 BringtoFrontMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.BringtoFrontMI1 Field

Summary

Represents field BringtoFrontMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 BringtoFrontMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CenterHorzB Field

Summary

Represents field CenterHorzB.

Namespace: frxDesgn
Syntax
Delphi
published
 CenterHorzB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CenterVertB Field

Summary

Represents field CenterVertB.

Namespace: frxDesgn
Syntax
Delphi
published
 CenterVertB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ChildMI Field

Summary

Represents field ChildMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ChildMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ChildMI1 Field

Summary

Represents field ChildMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 ChildMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CodeDockSite Field

Summary

Represents field CodeDockSite.

Namespace: frxDesgn
Syntax
Delphi
published
 CodeDockSite: TfrxDockSite;

Field Value

Type: TfrxDockSite

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CodePanel Field

Summary

Represents field CodePanel.

Namespace: frxDesgn
Syntax
Delphi
published
 CodePanel: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CodeTB Field

Summary

Represents field CodeTB.

Namespace: frxDesgn
Syntax
Delphi
published
 CodeTB: TToolBar;

Field Value

Type: TToolBar

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ColumnFooterMI Field

Summary

Represents field ColumnFooterMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ColumnFooterMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ColumnHeaderMI Field

Summary

Represents field ColumnHeaderMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ColumnHeaderMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CondensedMI Field

Summary

Represents field CondensedMI.

Namespace: frxDesgn
Syntax
Delphi
published
 CondensedMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ConnectionsMI Field

Summary

Represents field ConnectionsMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ConnectionsMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CopyB Field

Summary

Represents field CopyB.

Namespace: frxDesgn
Syntax
Delphi
published
 CopyB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CopyCmd Field

Summary

Represents field CopyCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 CopyCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CopyContent1 Field

Summary

Represents field CopyContent1.

Namespace: frxDesgn
Syntax
Delphi
published
 CopyContent1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CopyContent2 Field

Summary

Represents field CopyContent2.

Namespace: frxDesgn
Syntax
Delphi
published
 CopyContent2: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CopyContentCmd Field

Summary

Represents field CopyContentCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 CopyContentCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CopyMI Field

Summary

Represents field CopyMI.

Namespace: frxDesgn
Syntax
Delphi
published
 CopyMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CopyMI1 Field

Summary

Represents field CopyMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 CopyMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CutB Field

Summary

Represents field CutB.

Namespace: frxDesgn
Syntax
Delphi
published
 CutB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CutCmd Field

Summary

Represents field CutCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 CutCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CutMI Field

Summary

Represents field CutMI.

Namespace: frxDesgn
Syntax
Delphi
published
 CutMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.CutMI1 Field

Summary

Represents field CutMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 CutMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Data4levelMI Field

Summary

Represents field Data4levelMI.

Namespace: frxDesgn
Syntax
Delphi
published
 Data4levelMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Data5levelMI Field

Summary

Represents field Data5levelMI.

Namespace: frxDesgn
Syntax
Delphi
published
 Data5levelMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Data6levelMI Field

Summary

Represents field Data6levelMI.

Namespace: frxDesgn
Syntax
Delphi
published
 Data6levelMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DataTreeMI Field

Summary

Represents field DataTreeMI.

Namespace: frxDesgn
Syntax
Delphi
published
 DataTreeMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DataTreeTBCmd Field

Summary

Represents field DataTreeTBCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 DataTreeTBCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DeleteCmd Field

Summary

Represents field DeleteCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 DeleteCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DeleteGuidesCmd Field

Summary

Represents field DeleteGuidesCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 DeleteGuidesCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DeleteGuidesMI Field

Summary

Represents field DeleteGuidesMI.

Namespace: frxDesgn
Syntax
Delphi
published
 DeleteGuidesMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DeleteMI Field

Summary

Represents field DeleteMI.

Namespace: frxDesgn
Syntax
Delphi
published
 DeleteMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DeleteMI1 Field

Summary

Represents field DeleteMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 DeleteMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DeletePageB Field

Summary

Represents field DeletePageB.

Namespace: frxDesgn
Syntax
Delphi
published
 DeletePageB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DeletePageCmd Field

Summary

Represents field DeletePageCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 DeletePageCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DeletePageMI Field

Summary

Represents field DeletePageMI.

Namespace: frxDesgn
Syntax
Delphi
published
 DeletePageMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DeletePageMI1 Field

Summary

Represents field DeletePageMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 DeletePageMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DetailDataMI Field

Summary

Represents field DetailDataMI.

Namespace: frxDesgn
Syntax
Delphi
published
 DetailDataMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DetailDataMI1 Field

Summary

Represents field DetailDataMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 DetailDataMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DMPPopup Field

Summary

Represents field DMPPopup.

Namespace: frxDesgn
Syntax
Delphi
published
 DMPPopup: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DockBottom Field

Summary

Represents field DockBottom.

Namespace: frxDesgn
Syntax
Delphi
published
 DockBottom: TControlBar;

Field Value

Type: TControlBar

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.DockTop Field

Summary

Represents field DockTop.

Namespace: frxDesgn
Syntax
Delphi
published
 DockTop: TControlBar;

Field Value

Type: TControlBar

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.EdConfigCmd Field

Summary

Represents field EdConfigCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 EdConfigCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.EdConfigMI Field

Summary

Represents field EdConfigMI.

Namespace: frxDesgn
Syntax
Delphi
published
 EdConfigMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.EditCmd Field

Summary

Represents field EditCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 EditCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.EditMenu Field

Summary

Represents field EditMenu.

Namespace: frxDesgn
Syntax
Delphi
published
 EditMenu: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.EditMI Field

Summary

Represents field EditMI.

Namespace: frxDesgn
Syntax
Delphi
published
 EditMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.EditMI1 Field

Summary

Represents field EditMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 EditMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.EvaluateB Field

Summary

Represents field EvaluateB.

Namespace: frxDesgn
Syntax
Delphi
published
 EvaluateB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ExitCmd Field

Summary

Represents field ExitCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 ExitCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ExitMI Field

Summary

Represents field ExitMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ExitMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ExtraTBCmd Field

Summary

Represents field ExtraTBCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 ExtraTBCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ExtraToolsTB Field

Summary

Represents field ExtraToolsTB.

Namespace: frxDesgn
Syntax
Delphi
published
 ExtraToolsTB: TToolBar;

Field Value

Type: TToolBar

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FBreakPoints Field

Summary

Represents field FBreakPoints.

Namespace: frxDesgn
Syntax
Delphi
private
 FBreakPoints: TfrxBreakPointsForm;

Field Value

Type: TfrxBreakPointsForm

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FClipboard Field

Summary

Represents field FClipboard.

Namespace: frxDesgn
Syntax
Delphi
private
 FClipboard: TfrxClipboard;

Field Value

Type: TfrxClipboard

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FCodeWindow Field

Summary

Represents field FCodeWindow.

Namespace: frxDesgn
Syntax
Delphi
private
 FCodeWindow: TfrxSyntaxMemo;

Field Value

Type: TfrxSyntaxMemo

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FColor Field

Summary

Represents field FColor.

Namespace: frxDesgn
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FCoord1 Field

Summary

Represents field FCoord1.

Namespace: frxDesgn
Syntax
Delphi
private
 FCoord1: String;

Field Value

Type: String

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FCoord2 Field

Summary

Represents field FCoord2.

Namespace: frxDesgn
Syntax
Delphi
private
 FCoord2: String;

Field Value

Type: String

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FCoord3 Field

Summary

Represents field FCoord3.

Namespace: frxDesgn
Syntax
Delphi
private
 FCoord3: String;

Field Value

Type: String

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FDataTree Field

Summary

Represents field FDataTree.

Namespace: frxDesgn
Syntax
Delphi
private
 FDataTree: TfrxDataTreeForm;

Field Value

Type: TfrxDataTreeForm

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FDialogForm Field

Summary

Represents field FDialogForm.

Namespace: frxDesgn
Syntax
Delphi
private
 FDialogForm: TfrxDialogForm;

Field Value

Type: TfrxDialogForm

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FDropFields Field

Summary

Represents field FDropFields.

Namespace: frxDesgn
Syntax
Delphi
private
 FDropFields: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FEditAfterInsert Field

Summary

Represents field FEditAfterInsert.

Namespace: frxDesgn
Syntax
Delphi
private
 FEditAfterInsert: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FFillColor Field

Summary

Represents field FFillColor.

Namespace: frxDesgn
Syntax
Delphi
private
 FFillColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FFilterList Field

Summary

Represents field FFilterList.

Namespace: frxDesgn
Syntax
Delphi
private
 FFilterList: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FFontColor Field

Summary

Represents field FFontColor.

Namespace: frxDesgn
Syntax
Delphi
private
 FFontColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FFrameColor Field

Summary

Represents field FFrameColor.

Namespace: frxDesgn
Syntax
Delphi
private
 FFrameColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FGridAlign Field

Summary

Represents field FGridAlign.

Namespace: frxDesgn
Syntax
Delphi
private
 FGridAlign: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FGridSize1 Field

Summary

Represents field FGridSize1.

Namespace: frxDesgn
Syntax
Delphi
private
 FGridSize1: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FGridSize2 Field

Summary

Represents field FGridSize2.

Namespace: frxDesgn
Syntax
Delphi
private
 FGridSize2: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FGridSize3 Field

Summary

Represents field FGridSize3.

Namespace: frxDesgn
Syntax
Delphi
private
 FGridSize3: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FGridSize4 Field

Summary

Represents field FGridSize4.

Namespace: frxDesgn
Syntax
Delphi
private
 FGridSize4: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FGuidesAsAnchor Field

Summary

Represents field FGuidesAsAnchor.

Namespace: frxDesgn
Syntax
Delphi
private
 FGuidesAsAnchor: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FileMenu Field

Summary

Represents field FileMenu.

Namespace: frxDesgn
Syntax
Delphi
published
 FileMenu: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FillColorB Field

Summary

Represents field FillColorB.

Namespace: frxDesgn
Syntax
Delphi
published
 FillColorB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FillColorPopupMenu Field

Summary

Represents field FillColorPopupMenu.

Namespace: frxDesgn
Syntax
Delphi
published
 FillColorPopupMenu: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FillEditB Field

Summary

Represents field FillEditB.

Namespace: frxDesgn
Syntax
Delphi
published
 FillEditB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FindCmd Field

Summary

Represents field FindCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 FindCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FindMI Field

Summary

Represents field FindMI.

Namespace: frxDesgn
Syntax
Delphi
published
 FindMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FindNextCmd Field

Summary

Represents field FindNextCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 FindNextCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FindNextMI Field

Summary

Represents field FindNextMI.

Namespace: frxDesgn
Syntax
Delphi
published
 FindNextMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FInspector Field

Summary

Represents field FInspector.

Namespace: frxDesgn
Syntax
Delphi
private
 FInspector: TfrxObjectInspector;

Field Value

Type: TfrxObjectInspector

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FLineStyle Field

Summary

Represents field FLineStyle.

Namespace: frxDesgn
Syntax
Delphi
private
 FLineStyle: TfrxFrameStyle;

Field Value

Type: TfrxFrameStyle

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FLocalizedOI Field

Summary

Represents field FLocalizedOI.

Namespace: frxDesgn
Syntax
Delphi
private
 FLocalizedOI: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FLockSelectionChanged Field

Summary

Represents field FLockSelectionChanged.

Namespace: frxDesgn
Syntax
Delphi
private
 FLockSelectionChanged: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FModifiedBy Field

Summary

Represents field FModifiedBy.

Namespace: frxDesgn
Syntax
Delphi
private
 FModifiedBy: TObject;

Field Value

Type: TObject

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FMouseDown Field

Summary

Represents field FMouseDown.

Namespace: frxDesgn
Syntax
Delphi
private
 FMouseDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FOldDesignerComp Field

Summary

Represents field FOldDesignerComp.

Namespace: frxDesgn
Syntax
Delphi
private
 FOldDesignerComp: TfrxDesigner;

Field Value

Type: TfrxDesigner

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FOldUnits Field

Summary

Represents field FOldUnits.

Namespace: frxDesgn
Syntax
Delphi
private
 FOldUnits: TfrxDesignerUnits;

Field Value

Type: TfrxDesignerUnits

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FontB Field

Summary

Represents field FontB.

Namespace: frxDesgn
Syntax
Delphi
published
 FontB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FontColorB Field

Summary

Represents field FontColorB.

Namespace: frxDesgn
Syntax
Delphi
published
 FontColorB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FontColorPopupMenu Field

Summary

Represents field FontColorPopupMenu.

Namespace: frxDesgn
Syntax
Delphi
published
 FontColorPopupMenu: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FontNameCB Field

Summary

Represents field FontNameCB.

Namespace: frxDesgn
Syntax
Delphi
published
 FontNameCB: TfrxFontComboBox;

Field Value

Type: TfrxFontComboBox

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FontSizeCB Field

Summary

Represents field FontSizeCB.

Namespace: frxDesgn
Syntax
Delphi
published
 FontSizeCB: TfrxComboBox;

Field Value

Type: TfrxComboBox

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FooterMI Field

Summary

Represents field FooterMI.

Namespace: frxDesgn
Syntax
Delphi
published
 FooterMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FooterMI1 Field

Summary

Represents field FooterMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 FooterMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FormatToolB Field

Summary

Represents field FormatToolB.

Namespace: frxDesgn
Syntax
Delphi
private
 FormatToolB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FPagePositions Field

Summary

Represents field FPagePositions.

Namespace: frxDesgn
Syntax
Delphi
private
 FPagePositions: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FPictureCache Field

Summary

Represents field FPictureCache.

Namespace: frxDesgn
Syntax
Delphi
private
 FPictureCache: TfrxPictureCache;

Field Value

Type: TfrxPictureCache

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameAllB Field

Summary

Represents field FrameAllB.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameAllB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameBottomB Field

Summary

Represents field FrameBottomB.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameBottomB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameColorB Field

Summary

Represents field FrameColorB.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameColorB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameColorPopupMenu Field

Summary

Represents field FrameColorPopupMenu.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameColorPopupMenu: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameEditB Field

Summary

Represents field FrameEditB.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameEditB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameLeftB Field

Summary

Represents field FrameLeftB.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameLeftB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameMI Field

Summary

Represents field FrameMI.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameNoB Field

Summary

Represents field FrameNoB.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameNoB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameRightB Field

Summary

Represents field FrameRightB.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameRightB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameStyleB Field

Summary

Represents field FrameStyleB.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameStyleB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameTB Field

Summary

Represents field FrameTB.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameTB: TToolBar;

Field Value

Type: TToolBar

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameTBCmd Field

Summary

Represents field FrameTBCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameTBCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameTopB Field

Summary

Represents field FrameTopB.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameTopB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FrameWidthCB Field

Summary

Represents field FrameWidthCB.

Namespace: frxDesgn
Syntax
Delphi
published
 FrameWidthCB: TfrxComboBox;

Field Value

Type: TfrxComboBox

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FRecentFiles Field

Summary

Represents field FRecentFiles.

Namespace: frxDesgn
Syntax
Delphi
private
 FRecentFiles: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FRecentMenuIndex Field

Summary

Represents field FRecentMenuIndex.

Namespace: frxDesgn
Syntax
Delphi
private
 FRecentMenuIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FReportTree Field

Summary

Represents field FReportTree.

Namespace: frxDesgn
Syntax
Delphi
private
 FReportTree: TfrxReportTreeForm;

Field Value

Type: TfrxReportTreeForm

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.frTBPanel1 Field

Summary

Represents field frTBPanel1.

Namespace: frxDesgn
Syntax
Delphi
published
 frTBPanel1: TfrxTBPanel;

Field Value

Type: TfrxTBPanel

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FSampleFormat Field

Summary

Represents field FSampleFormat.

Namespace: frxDesgn
Syntax
Delphi
private
 FSampleFormat: TSampleFormat;

Field Value

Type: TSampleFormat

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FScale Field

Summary

Represents field FScale.

Namespace: frxDesgn
Syntax
Delphi
private
 FScale: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FScriptFirstTime Field

Summary

Represents field FScriptFirstTime.

Namespace: frxDesgn
Syntax
Delphi
private
 FScriptFirstTime: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FScriptRunning Field

Summary

Represents field FScriptRunning.

Namespace: frxDesgn
Syntax
Delphi
private
 FScriptRunning: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FScriptStep Field

Summary

Represents field FScriptStep.

Namespace: frxDesgn
Syntax
Delphi
private
 FScriptStep: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FScriptStopped Field

Summary

Represents field FScriptStopped.

Namespace: frxDesgn
Syntax
Delphi
private
 FScriptStopped: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FSearchCase Field

Summary

Represents field FSearchCase.

Namespace: frxDesgn
Syntax
Delphi
private
 FSearchCase: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FSearchIndex Field

Summary

Represents field FSearchIndex.

Namespace: frxDesgn
Syntax
Delphi
private
 FSearchIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FSearchReplace Field

Summary

Represents field FSearchReplace.

Namespace: frxDesgn
Syntax
Delphi
private
 FSearchReplace: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FSearchReplaceText Field

Summary

Represents field FSearchReplaceText.

Namespace: frxDesgn
Syntax
Delphi
private
 FSearchReplaceText: String;

Field Value

Type: String

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FSearchText Field

Summary

Represents field FSearchText.

Namespace: frxDesgn
Syntax
Delphi
private
 FSearchText: String;

Field Value

Type: String

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FShowGrid Field

Summary

Represents field FShowGrid.

Namespace: frxDesgn
Syntax
Delphi
private
 FShowGrid: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FShowGuides Field

Summary

Represents field FShowGuides.

Namespace: frxDesgn
Syntax
Delphi
private
 FShowGuides: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FShowRulers Field

Summary

Represents field FShowRulers.

Namespace: frxDesgn
Syntax
Delphi
private
 FShowRulers: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FShowStartup Field

Summary

Represents field FShowStartup.

Namespace: frxDesgn
Syntax
Delphi
private
 FShowStartup: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FStatusBarOldWindowProc Field

Summary

Represents field FStatusBarOldWindowProc.

Namespace: frxDesgn
Syntax
Delphi
private
 FStatusBarOldWindowProc: TWndMethod;

Field Value

Type: TWndMethod

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FStickToGuides Field

Summary

Represents field FStickToGuides.

Namespace: frxDesgn
Syntax
Delphi
private
 FStickToGuides: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FTabs Field

Summary

Represents field FTabs.

Namespace: frxDesgn
Syntax
Delphi
private
 FTabs: TTabSet;

Field Value

Type: TTabSet

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FTemplateExt Field

Summary

Represents field FTemplateExt.

Namespace: frxDesgn
Syntax
Delphi
private
 FTemplateExt: String;

Field Value

Type: String

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FTemplatePath Field

Summary

Represents field FTemplatePath.

Namespace: frxDesgn
Syntax
Delphi
private
 FTemplatePath: String;

Field Value

Type: String

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FToolsColor Field

Summary

Represents field FToolsColor.

Namespace: frxDesgn
Syntax
Delphi
private
 FToolsColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FUndoBuffer Field

Summary

Represents field FUndoBuffer.

Namespace: frxDesgn
Syntax
Delphi
private
 FUndoBuffer: TfrxUndoBuffer;

Field Value

Type: TfrxUndoBuffer

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FUnits Field

Summary

Represents field FUnits.

Namespace: frxDesgn
Syntax
Delphi
private
 FUnits: TfrxDesignerUnits;

Field Value

Type: TfrxDesignerUnits

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FUnitsDblClicked Field

Summary

Represents field FUnitsDblClicked.

Namespace: frxDesgn
Syntax
Delphi
private
 FUnitsDblClicked: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FUpdatingControls Field

Summary

Represents field FUpdatingControls.

Namespace: frxDesgn
Syntax
Delphi
private
 FUpdatingControls: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FWatchList Field

Summary

Represents field FWatchList.

Namespace: frxDesgn
Syntax
Delphi
private
 FWatchList: TfrxWatchForm;

Field Value

Type: TfrxWatchForm

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FWorkspace Field

Summary

Represents field FWorkspace.

Namespace: frxDesgn
Syntax
Delphi
private
 FWorkspace: TfrxDesignerWorkspace;

Field Value

Type: TfrxDesignerWorkspace

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.FWorkspaceColor Field

Summary

Represents field FWorkspaceColor.

Namespace: frxDesgn
Syntax
Delphi
private
 FWorkspaceColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GroupB Field

Summary

Represents field GroupB.

Namespace: frxDesgn
Syntax
Delphi
published
 GroupB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GroupCmd Field

Summary

Represents field GroupCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 GroupCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GroupFooterMI Field

Summary

Represents field GroupFooterMI.

Namespace: frxDesgn
Syntax
Delphi
published
 GroupFooterMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GroupFooterMI1 Field

Summary

Represents field GroupFooterMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 GroupFooterMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GroupHeaderMI Field

Summary

Represents field GroupHeaderMI.

Namespace: frxDesgn
Syntax
Delphi
published
 GroupHeaderMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GroupHeaderMI1 Field

Summary

Represents field GroupHeaderMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 GroupHeaderMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.GroupMI Field

Summary

Represents field GroupMI.

Namespace: frxDesgn
Syntax
Delphi
published
 GroupMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.HandToolB Field

Summary

Represents field HandToolB.

Namespace: frxDesgn
Syntax
Delphi
private
 HandToolB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.HeaderMI Field

Summary

Represents field HeaderMI.

Namespace: frxDesgn
Syntax
Delphi
published
 HeaderMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.HeaderMI1 Field

Summary

Represents field HeaderMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 HeaderMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.HelpContentsCmd Field

Summary

Represents field HelpContentsCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 HelpContentsCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.HelpContentsMI Field

Summary

Represents field HelpContentsMI.

Namespace: frxDesgn
Syntax
Delphi
published
 HelpContentsMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.HelpMenu Field

Summary

Represents field HelpMenu.

Namespace: frxDesgn
Syntax
Delphi
published
 HelpMenu: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.HighlightB Field

Summary

Represents field HighlightB.

Namespace: frxDesgn
Syntax
Delphi
published
 HighlightB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.InspectorMI Field

Summary

Represents field InspectorMI.

Namespace: frxDesgn
Syntax
Delphi
published
 InspectorMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.InspectorTBCmd Field

Summary

Represents field InspectorTBCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 InspectorTBCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ItalicB Field

Summary

Represents field ItalicB.

Namespace: frxDesgn
Syntax
Delphi
published
 ItalicB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ItalicMI Field

Summary

Represents field ItalicMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ItalicMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.LangCB Field

Summary

Represents field LangCB.

Namespace: frxDesgn
Syntax
Delphi
published
 LangCB: TfrxComboBox;

Field Value

Type: TfrxComboBox

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.LangL Field

Summary

Represents field LangL.

Namespace: frxDesgn
Syntax
Delphi
published
 LangL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.LeftDockSite1 Field

Summary

Represents field LeftDockSite1.

Namespace: frxDesgn
Syntax
Delphi
published
 LeftDockSite1: TfrxDockSite;

Field Value

Type: TfrxDockSite

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.LeftDockSite2 Field

Summary

Represents field LeftDockSite2.

Namespace: frxDesgn
Syntax
Delphi
published
 LeftDockSite2: TfrxDockSite;

Field Value

Type: TfrxDockSite

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.LeftRuler Field

Summary

Represents field LeftRuler.

Namespace: frxDesgn
Syntax
Delphi
published
 LeftRuler: TfrxRuler;

Field Value

Type: TfrxRuler

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.MainMenu Field

Summary

Represents field MainMenu.

Namespace: frxDesgn
Syntax
Delphi
published
 MainMenu: TMainMenu;

Field Value

Type: TMainMenu

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.MasterDataMI Field

Summary

Represents field MasterDataMI.

Namespace: frxDesgn
Syntax
Delphi
published
 MasterDataMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.MasterDataMI1 Field

Summary

Represents field MasterDataMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 MasterDataMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.N1 Field

Summary

Represents field N1.

Namespace: frxDesgn
Syntax
Delphi
published
 N1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.N12cpiMI Field

Summary

Represents field N12cpiMI.

Namespace: frxDesgn
Syntax
Delphi
published
 N12cpiMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.N15cpiMI Field

Summary

Represents field N15cpiMI.

Namespace: frxDesgn
Syntax
Delphi
published
 N15cpiMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.N2 Field

Summary

Represents field N2.

Namespace: frxDesgn
Syntax
Delphi
published
 N2: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.N3 Field

Summary

Represents field N3.

Namespace: frxDesgn
Syntax
Delphi
published
 N3: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewB Field

Summary

Represents field NewB.

Namespace: frxDesgn
Syntax
Delphi
published
 NewB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewDialogB Field

Summary

Represents field NewDialogB.

Namespace: frxDesgn
Syntax
Delphi
published
 NewDialogB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewDialogCmd Field

Summary

Represents field NewDialogCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 NewDialogCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewDialogMI Field

Summary

Represents field NewDialogMI.

Namespace: frxDesgn
Syntax
Delphi
published
 NewDialogMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewDialogMI1 Field

Summary

Represents field NewDialogMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 NewDialogMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewItemCmd Field

Summary

Represents field NewItemCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 NewItemCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewMI Field

Summary

Represents field NewMI.

Namespace: frxDesgn
Syntax
Delphi
published
 NewMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewPageB Field

Summary

Represents field NewPageB.

Namespace: frxDesgn
Syntax
Delphi
published
 NewPageB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewPageCmd Field

Summary

Represents field NewPageCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 NewPageCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewPageMI Field

Summary

Represents field NewPageMI.

Namespace: frxDesgn
Syntax
Delphi
published
 NewPageMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewPageMI1 Field

Summary

Represents field NewPageMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 NewPageMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewReportCmd Field

Summary

Represents field NewReportCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 NewReportCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.NewReportMI Field

Summary

Represents field NewReportMI.

Namespace: frxDesgn
Syntax
Delphi
published
 NewReportMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ObjectBandB Field

Summary

Represents field ObjectBandB.

Namespace: frxDesgn
Syntax
Delphi
private
 ObjectBandB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ObjectSelectB Field

Summary

Represents field ObjectSelectB.

Namespace: frxDesgn
Syntax
Delphi
private
 ObjectSelectB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ObjectsPopup Field

Summary

Represents field ObjectsPopup.

Namespace: frxDesgn
Syntax
Delphi
published
 ObjectsPopup: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ObjectsTB1 Field

Summary

Represents field ObjectsTB1.

Namespace: frxDesgn
Syntax
Delphi
published
 ObjectsTB1: TToolBar;

Field Value

Type: TToolBar

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OpenB Field

Summary

Represents field OpenB.

Namespace: frxDesgn
Syntax
Delphi
published
 OpenB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OpenCmd Field

Summary

Represents field OpenCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 OpenCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OpenDialog Field

Summary

Represents field OpenDialog.

Namespace: frxDesgn
Syntax
Delphi
published
 OpenDialog: TOpenDialog;

Field Value

Type: TOpenDialog

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OpenMI Field

Summary

Represents field OpenMI.

Namespace: frxDesgn
Syntax
Delphi
published
 OpenMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OpenScriptB Field

Summary

Represents field OpenScriptB.

Namespace: frxDesgn
Syntax
Delphi
published
 OpenScriptB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OpenScriptDialog Field

Summary

Represents field OpenScriptDialog.

Namespace: frxDesgn
Syntax
Delphi
published
 OpenScriptDialog: TOpenDialog;

Field Value

Type: TOpenDialog

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OptionsCmd Field

Summary

Represents field OptionsCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 OptionsCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OptionsMI Field

Summary

Represents field OptionsMI.

Namespace: frxDesgn
Syntax
Delphi
published
 OptionsMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.OverlayMI Field

Summary

Represents field OverlayMI.

Namespace: frxDesgn
Syntax
Delphi
published
 OverlayMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PageFooterMI Field

Summary

Represents field PageFooterMI.

Namespace: frxDesgn
Syntax
Delphi
published
 PageFooterMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PageHeaderMI Field

Summary

Represents field PageHeaderMI.

Namespace: frxDesgn
Syntax
Delphi
published
 PageHeaderMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PagePopup Field

Summary

Represents field PagePopup.

Namespace: frxDesgn
Syntax
Delphi
published
 PagePopup: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PageSettingsB Field

Summary

Represents field PageSettingsB.

Namespace: frxDesgn
Syntax
Delphi
published
 PageSettingsB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PageSettingsCmd Field

Summary

Represents field PageSettingsCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 PageSettingsCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PageSettingsMI Field

Summary

Represents field PageSettingsMI.

Namespace: frxDesgn
Syntax
Delphi
published
 PageSettingsMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PageSettingsMI1 Field

Summary

Represents field PageSettingsMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 PageSettingsMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Panel1 Field

Summary

Represents field Panel1.

Namespace: frxDesgn
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PanelTB1 Field

Summary

Represents field PanelTB1.

Namespace: frxDesgn
Syntax
Delphi
published
 PanelTB1: TfrxTBPanel;

Field Value

Type: TfrxTBPanel

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PanelTB2 Field

Summary

Represents field PanelTB2.

Namespace: frxDesgn
Syntax
Delphi
published
 PanelTB2: TfrxTBPanel;

Field Value

Type: TfrxTBPanel

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PanelTB3 Field

Summary

Represents field PanelTB3.

Namespace: frxDesgn
Syntax
Delphi
published
 PanelTB3: TfrxTBPanel;

Field Value

Type: TfrxTBPanel

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PasteB Field

Summary

Represents field PasteB.

Namespace: frxDesgn
Syntax
Delphi
published
 PasteB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PasteCmd Field

Summary

Represents field PasteCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 PasteCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PasteMI Field

Summary

Represents field PasteMI.

Namespace: frxDesgn
Syntax
Delphi
published
 PasteMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PasteMI1 Field

Summary

Represents field PasteMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 PasteMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PreviewB Field

Summary

Represents field PreviewB.

Namespace: frxDesgn
Syntax
Delphi
published
 PreviewB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PreviewCmd Field

Summary

Represents field PreviewCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 PreviewCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.PreviewMI Field

Summary

Represents field PreviewMI.

Namespace: frxDesgn
Syntax
Delphi
published
 PreviewMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.R0MI Field

Summary

Represents field R0MI.

Namespace: frxDesgn
Syntax
Delphi
published
 R0MI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.R180MI Field

Summary

Represents field R180MI.

Namespace: frxDesgn
Syntax
Delphi
published
 R180MI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.R270MI Field

Summary

Represents field R270MI.

Namespace: frxDesgn
Syntax
Delphi
published
 R270MI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.R45MI Field

Summary

Represents field R45MI.

Namespace: frxDesgn
Syntax
Delphi
published
 R45MI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.R90MI Field

Summary

Represents field R90MI.

Namespace: frxDesgn
Syntax
Delphi
published
 R90MI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RedoB Field

Summary

Represents field RedoB.

Namespace: frxDesgn
Syntax
Delphi
published
 RedoB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RedoCmd Field

Summary

Represents field RedoCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 RedoCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RedoMI Field

Summary

Represents field RedoMI.

Namespace: frxDesgn
Syntax
Delphi
published
 RedoMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReplaceCmd Field

Summary

Represents field ReplaceCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 ReplaceCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReplaceMI Field

Summary

Represents field ReplaceMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ReplaceMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportDataCmd Field

Summary

Represents field ReportDataCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 ReportDataCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportDataMI Field

Summary

Represents field ReportDataMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ReportDataMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportMenu Field

Summary

Represents field ReportMenu.

Namespace: frxDesgn
Syntax
Delphi
published
 ReportMenu: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportOptionsCmd Field

Summary

Represents field ReportOptionsCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 ReportOptionsCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportSettingsMI Field

Summary

Represents field ReportSettingsMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ReportSettingsMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportStylesCmd Field

Summary

Represents field ReportStylesCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 ReportStylesCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportStylesMI Field

Summary

Represents field ReportStylesMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ReportStylesMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportSummaryMI Field

Summary

Represents field ReportSummaryMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ReportSummaryMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportTitleMI Field

Summary

Represents field ReportTitleMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ReportTitleMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportTreeMI Field

Summary

Represents field ReportTreeMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ReportTreeMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ReportTreeTBCmd Field

Summary

Represents field ReportTreeTBCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 ReportTreeTBCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RevertInheritedChildMI Field

Summary

Represents field RevertInheritedChildMI.

Namespace: frxDesgn
Syntax
Delphi
published
 RevertInheritedChildMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RevertInheritedMI Field

Summary

Represents field RevertInheritedMI.

Namespace: frxDesgn
Syntax
Delphi
published
 RevertInheritedMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RightDockSite Field

Summary

Represents field RightDockSite.

Namespace: frxDesgn
Syntax
Delphi
published
 RightDockSite: TfrxDockSite;

Field Value

Type: TfrxDockSite

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RotateB Field

Summary

Represents field RotateB.

Namespace: frxDesgn
Syntax
Delphi
published
 RotateB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RotationPopup Field

Summary

Represents field RotationPopup.

Namespace: frxDesgn
Syntax
Delphi
published
 RotationPopup: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RunScriptB Field

Summary

Represents field RunScriptB.

Namespace: frxDesgn
Syntax
Delphi
published
 RunScriptB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.RunToCursorB Field

Summary

Represents field RunToCursorB.

Namespace: frxDesgn
Syntax
Delphi
published
 RunToCursorB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SameHeightB Field

Summary

Represents field SameHeightB.

Namespace: frxDesgn
Syntax
Delphi
published
 SameHeightB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SameWidthB Field

Summary

Represents field SameWidthB.

Namespace: frxDesgn
Syntax
Delphi
published
 SameWidthB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SaveAsCmd Field

Summary

Represents field SaveAsCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 SaveAsCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SaveAsMI Field

Summary

Represents field SaveAsMI.

Namespace: frxDesgn
Syntax
Delphi
published
 SaveAsMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SaveB Field

Summary

Represents field SaveB.

Namespace: frxDesgn
Syntax
Delphi
published
 SaveB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SaveCmd Field

Summary

Represents field SaveCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 SaveCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SaveMI Field

Summary

Represents field SaveMI.

Namespace: frxDesgn
Syntax
Delphi
published
 SaveMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SaveScriptB Field

Summary

Represents field SaveScriptB.

Namespace: frxDesgn
Syntax
Delphi
published
 SaveScriptB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SaveScriptDialog Field

Summary

Represents field SaveScriptDialog.

Namespace: frxDesgn
Syntax
Delphi
published
 SaveScriptDialog: TSaveDialog;

Field Value

Type: TSaveDialog

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ScaleCB Field

Summary

Represents field ScaleCB.

Namespace: frxDesgn
Syntax
Delphi
published
 ScaleCB: TfrxComboBox;

Field Value

Type: TfrxComboBox

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ScrollBox Field

Summary

Represents field ScrollBox.

Namespace: frxDesgn
Syntax
Delphi
published
 ScrollBox: TfrxScrollBox;

Field Value

Type: TfrxScrollBox

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ScrollBoxPanel Field

Summary

Represents field ScrollBoxPanel.

Namespace: frxDesgn
Syntax
Delphi
published
 ScrollBoxPanel: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SelectAllCmd Field

Summary

Represents field SelectAllCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 SelectAllCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SelectAllMI Field

Summary

Represents field SelectAllMI.

Namespace: frxDesgn
Syntax
Delphi
published
 SelectAllMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SelectAllMI1 Field

Summary

Represents field SelectAllMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 SelectAllMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SelectAllOfTypeCmd Field

Summary

Represents field SelectAllOfTypeCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 SelectAllOfTypeCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SelectAllOfTypeMI Field

Summary

Represents field SelectAllOfTypeMI.

Namespace: frxDesgn
Syntax
Delphi
published
 SelectAllOfTypeMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SelectAllOfTypeOnPageMI Field

Summary

Represents field SelectAllOfTypeOnPageMI.

Namespace: frxDesgn
Syntax
Delphi
published
 SelectAllOfTypeOnPageMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SendToBackCmd Field

Summary

Represents field SendToBackCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 SendToBackCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SendtoBackMI Field

Summary

Represents field SendtoBackMI.

Namespace: frxDesgn
Syntax
Delphi
published
 SendtoBackMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SendtoBackMI1 Field

Summary

Represents field SendtoBackMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 SendtoBackMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepMI1 Field

Summary

Represents field SepMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 SepMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepMI10 Field

Summary

Represents field SepMI10.

Namespace: frxDesgn
Syntax
Delphi
published
 SepMI10: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepMI11 Field

Summary

Represents field SepMI11.

Namespace: frxDesgn
Syntax
Delphi
published
 SepMI11: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepMI12 Field

Summary

Represents field SepMI12.

Namespace: frxDesgn
Syntax
Delphi
published
 SepMI12: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepMI3 Field

Summary

Represents field SepMI3.

Namespace: frxDesgn
Syntax
Delphi
published
 SepMI3: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepMI4 Field

Summary

Represents field SepMI4.

Namespace: frxDesgn
Syntax
Delphi
published
 SepMI4: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepMI5 Field

Summary

Represents field SepMI5.

Namespace: frxDesgn
Syntax
Delphi
published
 SepMI5: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepMI6 Field

Summary

Represents field SepMI6.

Namespace: frxDesgn
Syntax
Delphi
published
 SepMI6: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepMI7 Field

Summary

Represents field SepMI7.

Namespace: frxDesgn
Syntax
Delphi
published
 SepMI7: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepMI8 Field

Summary

Represents field SepMI8.

Namespace: frxDesgn
Syntax
Delphi
published
 SepMI8: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepMI9 Field

Summary

Represents field SepMI9.

Namespace: frxDesgn
Syntax
Delphi
published
 SepMI9: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB10 Field

Summary

Represents field SepTB10.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB10: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB11 Field

Summary

Represents field SepTB11.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB11: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB12 Field

Summary

Represents field SepTB12.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB12: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB13 Field

Summary

Represents field SepTB13.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB13: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB15 Field

Summary

Represents field SepTB15.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB15: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB16 Field

Summary

Represents field SepTB16.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB16: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB17 Field

Summary

Represents field SepTB17.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB17: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB18 Field

Summary

Represents field SepTB18.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB18: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB19 Field

Summary

Represents field SepTB19.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB19: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB2 Field

Summary

Represents field SepTB2.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB2: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB20 Field

Summary

Represents field SepTB20.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB20: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB3 Field

Summary

Represents field SepTB3.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB3: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB4 Field

Summary

Represents field SepTB4.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB4: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB8 Field

Summary

Represents field SepTB8.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB8: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SepTB9 Field

Summary

Represents field SepTB9.

Namespace: frxDesgn
Syntax
Delphi
published
 SepTB9: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SetToGridB Field

Summary

Represents field SetToGridB.

Namespace: frxDesgn
Syntax
Delphi
published
 SetToGridB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ShowGridB Field

Summary

Represents field ShowGridB.

Namespace: frxDesgn
Syntax
Delphi
published
 ShowGridB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ShowGuidesCmd Field

Summary

Represents field ShowGuidesCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 ShowGuidesCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ShowGuidesMI Field

Summary

Represents field ShowGuidesMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ShowGuidesMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ShowRulersCmd Field

Summary

Represents field ShowRulersCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 ShowRulersCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ShowRulersMI Field

Summary

Represents field ShowRulersMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ShowRulersMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SpaceHorzB Field

Summary

Represents field SpaceHorzB.

Namespace: frxDesgn
Syntax
Delphi
published
 SpaceHorzB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SpaceVertB Field

Summary

Represents field SpaceVertB.

Namespace: frxDesgn
Syntax
Delphi
published
 SpaceVertB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StandardMI Field

Summary

Represents field StandardMI.

Namespace: frxDesgn
Syntax
Delphi
published
 StandardMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StandardTB Field

Summary

Represents field StandardTB.

Namespace: frxDesgn
Syntax
Delphi
published
 StandardTB: TToolBar;

Field Value

Type: TToolBar

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StandardTBCmd Field

Summary

Represents field StandardTBCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 StandardTBCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StatusBar Field

Summary

Represents field StatusBar.

Namespace: frxDesgn
Syntax
Delphi
published
 StatusBar: TStatusBar;

Field Value

Type: TStatusBar

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StepScriptB Field

Summary

Represents field StepScriptB.

Namespace: frxDesgn
Syntax
Delphi
published
 StepScriptB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StopScriptB Field

Summary

Represents field StopScriptB.

Namespace: frxDesgn
Syntax
Delphi
published
 StopScriptB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.StyleCB Field

Summary

Represents field StyleCB.

Namespace: frxDesgn
Syntax
Delphi
published
 StyleCB: TfrxComboBox;

Field Value

Type: TfrxComboBox

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SubdetailDataMI Field

Summary

Represents field SubdetailDataMI.

Namespace: frxDesgn
Syntax
Delphi
published
 SubdetailDataMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SubdetailDataMI1 Field

Summary

Represents field SubdetailDataMI1.

Namespace: frxDesgn
Syntax
Delphi
published
 SubdetailDataMI1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SubScriptMI Field

Summary

Represents field SubScriptMI.

Namespace: frxDesgn
Syntax
Delphi
published
 SubScriptMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.SuperScriptMI Field

Summary

Represents field SuperScriptMI.

Namespace: frxDesgn
Syntax
Delphi
published
 SuperScriptMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TabOrderMI Field

Summary

Represents field TabOrderMI.

Namespace: frxDesgn
Syntax
Delphi
published
 TabOrderMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TabPanel Field

Summary

Represents field TabPanel.

Namespace: frxDesgn
Syntax
Delphi
published
 TabPanel: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TabPopup Field

Summary

Represents field TabPopup.

Namespace: frxDesgn
Syntax
Delphi
published
 TabPopup: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TextAlignBlockB Field

Summary

Represents field TextAlignBlockB.

Namespace: frxDesgn
Syntax
Delphi
published
 TextAlignBlockB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TextAlignBottomB Field

Summary

Represents field TextAlignBottomB.

Namespace: frxDesgn
Syntax
Delphi
published
 TextAlignBottomB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TextAlignCenterB Field

Summary

Represents field TextAlignCenterB.

Namespace: frxDesgn
Syntax
Delphi
published
 TextAlignCenterB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TextAlignLeftB Field

Summary

Represents field TextAlignLeftB.

Namespace: frxDesgn
Syntax
Delphi
published
 TextAlignLeftB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TextAlignMiddleB Field

Summary

Represents field TextAlignMiddleB.

Namespace: frxDesgn
Syntax
Delphi
published
 TextAlignMiddleB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TextAlignRightB Field

Summary

Represents field TextAlignRightB.

Namespace: frxDesgn
Syntax
Delphi
published
 TextAlignRightB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TextAlignTopB Field

Summary

Represents field TextAlignTopB.

Namespace: frxDesgn
Syntax
Delphi
published
 TextAlignTopB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TextMI Field

Summary

Represents field TextMI.

Namespace: frxDesgn
Syntax
Delphi
published
 TextMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TextTB Field

Summary

Represents field TextTB.

Namespace: frxDesgn
Syntax
Delphi
published
 TextTB: TToolBar;

Field Value

Type: TToolBar

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TextTBCmd Field

Summary

Represents field TextTBCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 TextTBCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TextToolB Field

Summary

Represents field TextToolB.

Namespace: frxDesgn
Syntax
Delphi
private
 TextToolB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.Timer Field

Summary

Represents field Timer.

Namespace: frxDesgn
Syntax
Delphi
published
 Timer: TTimer;

Field Value

Type: TTimer

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ToolbarsCmd Field

Summary

Represents field ToolbarsCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 ToolbarsCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ToolbarsMI Field

Summary

Represents field ToolbarsMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ToolbarsMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ToolButton1 Field

Summary

Represents field ToolButton1.

Namespace: frxDesgn
Syntax
Delphi
published
 ToolButton1: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ToolsMI Field

Summary

Represents field ToolsMI.

Namespace: frxDesgn
Syntax
Delphi
published
 ToolsMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.TopRuler Field

Summary

Represents field TopRuler.

Namespace: frxDesgn
Syntax
Delphi
published
 TopRuler: TfrxRuler;

Field Value

Type: TfrxRuler

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UnderlineB Field

Summary

Represents field UnderlineB.

Namespace: frxDesgn
Syntax
Delphi
published
 UnderlineB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UnderlineMI Field

Summary

Represents field UnderlineMI.

Namespace: frxDesgn
Syntax
Delphi
published
 UnderlineMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UndoB Field

Summary

Represents field UndoB.

Namespace: frxDesgn
Syntax
Delphi
published
 UndoB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UndoCmd Field

Summary

Represents field UndoCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 UndoCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UndoMI Field

Summary

Represents field UndoMI.

Namespace: frxDesgn
Syntax
Delphi
published
 UndoMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UngroupB Field

Summary

Represents field UngroupB.

Namespace: frxDesgn
Syntax
Delphi
published
 UngroupB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UngroupCmd Field

Summary

Represents field UngroupCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 UngroupCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.UngroupMI Field

Summary

Represents field UngroupMI.

Namespace: frxDesgn
Syntax
Delphi
published
 UngroupMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.VariablesCmd Field

Summary

Represents field VariablesCmd.

Namespace: frxDesgn
Syntax
Delphi
published
 VariablesCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.VariablesMI Field

Summary

Represents field VariablesMI.

Namespace: frxDesgn
Syntax
Delphi
published
 VariablesMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.VerticalbandsMI Field

Summary

Represents field VerticalbandsMI.

Namespace: frxDesgn
Syntax
Delphi
published
 VerticalbandsMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ViewMenu Field

Summary

Represents field ViewMenu.

Namespace: frxDesgn
Syntax
Delphi
published
 ViewMenu: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.WideMI Field

Summary

Represents field WideMI.

Namespace: frxDesgn
Syntax
Delphi
published
 WideMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TfrxDesignerForm.ZoomToolB Field

Summary

Represents field ZoomToolB.

Namespace: frxDesgn
Syntax
Delphi
private
 ZoomToolB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxDesignerForm
  • frxDesgn


TSampleFormat Class

Summary

Represents type TSampleFormat.

Namespace: frxDesgn
Inheritance Hierarchy
TObject
frxDesgn.TSampleFormat
Syntax
Delphi
type
 TSampleFormat = class(TObject)
 end;

The TSampleFormat type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TSampleFormat class.
Destroy | Represents the destructor of the TSampleFormat class.
Top
Properties
Show:
Name | Description
Memo | Represents property Memo.
Top
Methods
Show:
Name | Description
ApplySample(TfrxCustomMemoView) | Represents method ApplySample(TfrxCustomMemoView).
Clear | Represents method Clear.
SetAsSample(TfrxCustomMemoView) | Represents method SetAsSample(TfrxCustomMemoView).
Top
Fields
Show:
Name | Description
FMemo | Represents field FMemo.
Top
See Also

Reference

  • frxDesgn


TSampleFormat Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TSampleFormat class.
Destroy | Represents the destructor of the TSampleFormat class.
Top


TSampleFormat.Create Constructor

Summary

Initializes a new instance of the TSampleFormat class.

Namespace: frxDesgn
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TSampleFormat
  • frxDesgn


TSampleFormat.Destroy Destructor

Summary

Represents the destructor of the TSampleFormat class.

Namespace: frxDesgn
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TSampleFormat
  • frxDesgn


TSampleFormat Properties

Properties
Name | Description
Memo | Represents property Memo.
Top


TSampleFormat.Memo Property

Summary

Represents property Memo.

Namespace: frxDesgn
Syntax
Delphi
public
 property Memo: TfrxCustomMemoView read FMemo;

Property Value

Type: TfrxCustomMemoView

See Also

Reference

  • TSampleFormat
  • frxDesgn


TSampleFormat Methods

Methods
Name | Description
ApplySample(TfrxCustomMemoView) | Represents method ApplySample(TfrxCustomMemoView).
Clear | Represents method Clear.
SetAsSample(TfrxCustomMemoView) | Represents method SetAsSample(TfrxCustomMemoView).
Top


TSampleFormat.ApplySample(TfrxCustomMemoView) Method

Summary

Represents method ApplySample(TfrxCustomMemoView).

Namespace: frxDesgn
Syntax
Delphi
public
 procedure ApplySample(Memo: TfrxCustomMemoView);

Parameters

Memo
Type: TfrxCustomMemoView

See Also

Reference

  • TSampleFormat
  • frxDesgn


TSampleFormat.Clear Method

Summary

Represents method Clear.

Namespace: frxDesgn
Syntax
Delphi
private
 procedure Clear;
See Also

Reference

  • TSampleFormat
  • frxDesgn


TSampleFormat.SetAsSample(TfrxCustomMemoView) Method

Summary

Represents method SetAsSample(TfrxCustomMemoView).

Namespace: frxDesgn
Syntax
Delphi
public
 procedure SetAsSample(Memo: TfrxCustomMemoView);

Parameters

Memo
Type: TfrxCustomMemoView

See Also

Reference

  • TSampleFormat
  • frxDesgn


TSampleFormat Fields

Fields
Name | Description
FMemo | Represents field FMemo.
Top


TSampleFormat.FMemo Field

Summary

Represents field FMemo.

Namespace: frxDesgn
Syntax
Delphi
private
 FMemo: TfrxCustomMemoView;

Field Value

Type: TfrxCustomMemoView

See Also

Reference

  • TSampleFormat
  • frxDesgn


frxDesgn Enumerations

Enumerations
Name | Description
TfrxDesignerUnits | Units used in the designer.
TfrxDesignerUpdateEvent | Represents type TfrxDesignerUpdateEvent.
Top


TfrxDesignerUnits Enumeration

Summary

Units used in the designer.

Namespace: frxDesgn
Syntax
Delphi
type
 TfrxDesignerUnits = (
 duCM,
 duInches,
 duPixels,
 duChars);

The TfrxDesignerUnits type exposes the following members.

Members
Show:
Name | Description
duChars | Chars(dot-matrix report).
duCM | Сentimeters.
duInches | Inches.
duPixels | Pixels.
Top
See Also

Reference

  • frxDesgn


TfrxDesignerUpdateEvent Enumeration

Summary

Represents type TfrxDesignerUpdateEvent.

Namespace: frxDesgn
Syntax
Delphi
type
 TfrxDesignerUpdateEvent = (fduLoadReport, fduSaveReport);

The TfrxDesignerUpdateEvent type exposes the following members.

Members
Show:
Name | Description
fduLoadReport | Represents constant fduLoadReport.
fduSaveReport | Represents constant fduSaveReport.
Top
See Also

Reference

  • frxDesgn


frxDesgn Delegates

Delegates
Name | Description
TfrxAfterUpdateReportEvent | Represents type TfrxAfterUpdateReportEvent.
TfrxGetTemplateListEvent | The event occurs when user goes File|New... or Report|Options... menu items to choose the report template. Event handler must return a list of available templates in the List parameter.
TfrxLoadRecentReportEvent | Represents type TfrxLoadRecentReportEvent.
TfrxLoadReportEvent | The event occurs when loading a report. With the help of this event, you can manage report's loading from DB. Event handler must load a report and return True if operation was successful.
TfrxSaveReportEvent | The event occurs when saving a report. With the help of this event, you can manage process of report's saving in DB. Event handler must save a report and return True if operation was successful. SaveAs parameter is True in case the user selects "Save As..." menu item.
Top


TfrxAfterUpdateReportEvent Delegate

Summary

Represents type TfrxAfterUpdateReportEvent.

Namespace: frxDesgn
Syntax
Delphi
type
 TfrxAfterUpdateReportEvent = procedure(Sender: TObject; EventType: TfrxDesignerUpdateEvent; Report: TfrxReport) of object;
See Also

Reference

  • frxDesgn


TfrxGetTemplateListEvent Delegate

Summary

The event occurs when user goes File|New... or Report|Options... menu items to choose the report template. Event handler must return a list of available templates in the List parameter.

Namespace: frxDesgn
Syntax
Delphi
type
 TfrxGetTemplateListEvent = procedure(List: TStrings) of object;
See Also

Reference

  • frxDesgn


TfrxLoadRecentReportEvent Delegate

Summary

Represents type TfrxLoadRecentReportEvent.

Namespace: frxDesgn
Syntax
Delphi
type
 TfrxLoadRecentReportEvent = function(Report: TfrxReport; FileName: String): Boolean of object;
See Also

Reference

  • frxDesgn


TfrxLoadReportEvent Delegate

Summary

The event occurs when loading a report. With the help of this event, you can manage report's loading from DB. Event handler must load a report and return True if operation was successful.

Namespace: frxDesgn
Syntax
Delphi
type
 TfrxLoadReportEvent = function(Report: TfrxReport): Boolean of object;
See Also

Reference

  • frxDesgn


TfrxSaveReportEvent Delegate

Summary

The event occurs when saving a report. With the help of this event, you can manage process of report's saving in DB. Event handler must save a report and return True if operation was successful. SaveAs parameter is True in case the user selects "Save As..." menu item.

Namespace: frxDesgn
Syntax
Delphi
type
 TfrxSaveReportEvent = function(Report: TfrxReport; SaveAs: Boolean): Boolean of object;
See Also

Reference

  • frxDesgn


frxDesgn Types

Types
Name | Description
TfrxDesignerRestrictions | A set of flags, which inhibit specific operations in the designer.
Top


TfrxDesignerRestrictions Type

Summary

A set of flags, which inhibit specific operations in the designer.

Namespace: frxDesgn
Syntax
Delphi
type
 TfrxDesignerRestrictions = set of TfrxDesignerRestriction;
See Also

Reference

  • frxDesgn


frxDesgn Variables

Variables
Name | Description
frxDesignerComp | Represents variable frxDesignerComp.
Top


frxDesignerComp Variable

Summary

Represents variable frxDesignerComp.

Namespace: frxDesgn
Syntax
Delphi
frxDesignerComp: TfrxDesigner;

Value

Type: TfrxDesigner

See Also

Reference

  • frxDesgn


frxDesgnCtrls Namespace

Summary

Represents namespace frxDesgnCtrls.

Classes
Name | Description
TfrxClipboard | Represents type TfrxClipboard.
TfrxColorComboBox | Represents type TfrxColorComboBox.
TfrxColorSelector | Represents type TfrxColorSelector.
TfrxCustomSelector | Represents type TfrxCustomSelector.
TfrxFrameSampleControl | Represents type TfrxFrameSampleControl.
TfrxLineSelector | Represents type TfrxLineSelector.
TfrxLineStyleControl | Represents type TfrxLineStyleControl.
TfrxRuler | Represents type TfrxRuler.
TfrxScrollBox | Represents type TfrxScrollBox.
TfrxUndoBuffer | Represents type TfrxUndoBuffer.
Top
Enumerations
Name | Description
TfrxRulerUnits | Represents type TfrxRulerUnits.
Top
Delegates
Name | Description
TfrxFrameLineClickedEvent | Represents type TfrxFrameLineClickedEvent.
TfrxUpdateVirtualLines | Represents type TfrxUpdateVirtualLines.
Top
Constants
Name | Description
ClipboardPrefix | Represents constant ClipboardPrefix.
Top


frxDesgnCtrls Classes

Classes
Name | Description
TfrxClipboard | Represents type TfrxClipboard.
TfrxColorComboBox | Represents type TfrxColorComboBox.
TfrxColorSelector | Represents type TfrxColorSelector.
TfrxCustomSelector | Represents type TfrxCustomSelector.
TfrxFrameSampleControl | Represents type TfrxFrameSampleControl.
TfrxLineSelector | Represents type TfrxLineSelector.
TfrxLineStyleControl | Represents type TfrxLineStyleControl.
TfrxRuler | Represents type TfrxRuler.
TfrxScrollBox | Represents type TfrxScrollBox.
TfrxUndoBuffer | Represents type TfrxUndoBuffer.
Top


TfrxClipboard Class

Summary

Represents type TfrxClipboard.

Namespace: frxDesgnCtrls
Inheritance Hierarchy
TObject
frxDesgnCtrls.TfrxClipboard
Syntax
Delphi
type
 TfrxClipboard = class(TObject)
 end;

The TfrxClipboard type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | Initializes a new instance of the TfrxClipboard class.
Top
Properties
Show:
Name | Description
PasteAvailable | Represents property PasteAvailable.
PictureCache | Represents property PictureCache.
Top
Methods
Show:
Name | Description
Copy | Represents method Copy.
GetPasteAvailable | Represents method GetPasteAvailable.
IsFrxPasteAvailable | Represents method IsFrxPasteAvailable.
Paste | Represents method Paste.
Top
Fields
Show:
Name | Description
FDesigner | Represents field FDesigner.
FPictureCache | Represents field FPictureCache.
Top
See Also

Reference

  • frxDesgnCtrls


TfrxClipboard Constructors

Constructors
Name | Description
Create(TfrxCustomDesigner) | Initializes a new instance of the TfrxClipboard class.
Top


TfrxClipboard.Create(TfrxCustomDesigner) Constructor

Summary

Initializes a new instance of the TfrxClipboard class.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 constructor Create(ADesigner: TfrxCustomDesigner);

Parameters

ADesigner
Type: TfrxCustomDesigner

See Also

Reference

  • TfrxClipboard
  • frxDesgnCtrls


TfrxClipboard Properties

Properties
Name | Description
PasteAvailable | Represents property PasteAvailable.
PictureCache | Represents property PictureCache.
Top


TfrxClipboard.PasteAvailable Property

Summary

Represents property PasteAvailable.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property PasteAvailable: Boolean read GetPasteAvailable;

Property Value

Type: Boolean

See Also

Reference

  • TfrxClipboard
  • frxDesgnCtrls


TfrxClipboard.PictureCache Property

Summary

Represents property PictureCache.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property PictureCache: TfrxPictureCache read FPictureCache write FPictureCache;

Property Value

Type: TfrxPictureCache

See Also

Reference

  • TfrxClipboard
  • frxDesgnCtrls


TfrxClipboard Methods

Methods
Name | Description
Copy | Represents method Copy.
GetPasteAvailable | Represents method GetPasteAvailable.
IsFrxPasteAvailable | Represents method IsFrxPasteAvailable.
Paste | Represents method Paste.
Top


TfrxClipboard.Copy Method

Summary

Represents method Copy.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure Copy;
See Also

Reference

  • TfrxClipboard
  • frxDesgnCtrls


TfrxClipboard.GetPasteAvailable Method

Summary

Represents method GetPasteAvailable.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 function GetPasteAvailable: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxClipboard
  • frxDesgnCtrls


TfrxClipboard.IsFrxPasteAvailable Method

Summary

Represents method IsFrxPasteAvailable.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 function IsFrxPasteAvailable: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxClipboard
  • frxDesgnCtrls


TfrxClipboard.Paste Method

Summary

Represents method Paste.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 function Paste: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxClipboard
  • frxDesgnCtrls


TfrxClipboard Fields

Fields
Name | Description
FDesigner | Represents field FDesigner.
FPictureCache | Represents field FPictureCache.
Top


TfrxClipboard.FDesigner Field

Summary

Represents field FDesigner.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FDesigner: TfrxCustomDesigner;

Field Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxClipboard
  • frxDesgnCtrls


TfrxClipboard.FPictureCache Field

Summary

Represents field FPictureCache.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FPictureCache: TfrxPictureCache;

Field Value

Type: TfrxPictureCache

See Also

Reference

  • TfrxClipboard
  • frxDesgnCtrls


TfrxColorComboBox Class

Summary

Represents type TfrxColorComboBox.

Namespace: frxDesgnCtrls
Inheritance Hierarchy
TCustomControl
frxDesgnCtrls.TfrxColorComboBox
Syntax
Delphi
type
 TfrxColorComboBox = class(TCustomControl)
 end;

The TfrxColorComboBox type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxColorComboBox class.
Top
Properties
Show:
Name | Description
Color | Represents property Color.
OnColorChanged | Represents property OnColorChanged.
ShowColorName | Represents property ShowColorName.
Top
Methods
Show:
Name | Description
ColorChanged(TObject) | Represents method ColorChanged(TObject).
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
SetBounds(Integer,Integer,Integer,Integer) | Represents method SetBounds(Integer,Integer,Integer,Integer).
SetColor(TColor) | Represents method SetColor(TColor).
SetEnabled(Boolean) | Represents method SetEnabled(Boolean).
SetShowColorName(Boolean) | Represents method SetShowColorName(Boolean).
Top
Fields
Show:
Name | Description
FBlockPopup | Represents field FBlockPopup.
FColor | Represents field FColor.
FCombo | Represents field FCombo.
FOnColorChanged | Represents field FOnColorChanged.
FShowColorName | Represents field FShowColorName.
Top
See Also

Reference

  • frxDesgnCtrls


TfrxColorComboBox Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxColorComboBox class.
Top


TfrxColorComboBox.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxColorComboBox class.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox Properties

Properties
Name | Description
Color | Represents property Color.
OnColorChanged | Represents property OnColorChanged.
ShowColorName | Represents property ShowColorName.
Top


TfrxColorComboBox.Color Property

Summary

Represents property Color.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property Color: TColor read FColor write SetColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.OnColorChanged Property

Summary

Represents property OnColorChanged.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property OnColorChanged: TNotifyEvent read FOnColorChanged write FOnColorChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.ShowColorName Property

Summary

Represents property ShowColorName.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property ShowColorName: Boolean read FShowColorName write SetShowColorName;

Property Value

Type: Boolean

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox Methods

Methods
Name | Description
ColorChanged(TObject) | Represents method ColorChanged(TObject).
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
SetBounds(Integer,Integer,Integer,Integer) | Represents method SetBounds(Integer,Integer,Integer,Integer).
SetColor(TColor) | Represents method SetColor(TColor).
SetEnabled(Boolean) | Represents method SetEnabled(Boolean).
SetShowColorName(Boolean) | Represents method SetShowColorName(Boolean).
Top


TfrxColorComboBox.ColorChanged(TObject) Method

Summary

Represents method ColorChanged(TObject).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure ColorChanged(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.MouseDown(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.Paint Method

Summary

Represents method Paint.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure Paint; override;
See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.SetBounds(Integer,Integer,Integer,Integer) Method

Summary

Represents method SetBounds(Integer,Integer,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure SetBounds(ALeft, ATop, AWidth, AHeight: Integer); override;

Parameters

ALeft
Type: Integer

ATop
Type: Integer

AWidth
Type: Integer

AHeight
Type: Integer

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure SetColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.SetEnabled(Boolean) Method

Summary

Represents method SetEnabled(Boolean).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure SetEnabled(Value: Boolean); override;

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.SetShowColorName(Boolean) Method

Summary

Represents method SetShowColorName(Boolean).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure SetShowColorName(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox Fields

Fields
Name | Description
FBlockPopup | Represents field FBlockPopup.
FColor | Represents field FColor.
FCombo | Represents field FCombo.
FOnColorChanged | Represents field FOnColorChanged.
FShowColorName | Represents field FShowColorName.
Top


TfrxColorComboBox.FBlockPopup Field

Summary

Represents field FBlockPopup.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FBlockPopup: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.FColor Field

Summary

Represents field FColor.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.FCombo Field

Summary

Represents field FCombo.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FCombo: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.FOnColorChanged Field

Summary

Represents field FOnColorChanged.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FOnColorChanged: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorComboBox.FShowColorName Field

Summary

Represents field FShowColorName.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FShowColorName: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxColorComboBox
  • frxDesgnCtrls


TfrxColorSelector Class

Summary

Represents type TfrxColorSelector.

Namespace: frxDesgnCtrls
Inheritance Hierarchy
TCustomPanel
frxDPIAwareBaseControls.TfrxDPIAwareBasePanel
frxDPIAwareBaseControls.TfrxDPIAwarePanel
frxDesgnCtrls.TfrxCustomSelector
frxDesgnCtrls.TfrxColorSelector
Syntax
Delphi
type
 TfrxColorSelector = class(TfrxCustomSelector)
 end;

The TfrxColorSelector type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxColorSelector class. (Overrides TfrxCustomSelector.Create(TComponent).)
Top
Properties
Show:
Name | Description
Align | Represents property Align. (Inherited from TfrxDPIAwarePanel.)
Alignment | Represents property Alignment. (Inherited from TfrxDPIAwarePanel.)
Anchors | Represents property Anchors. (Inherited from TfrxDPIAwarePanel.)
AutoSize | Represents property AutoSize. (Inherited from TfrxDPIAwarePanel.)
BevelInner | Represents property BevelInner. (Inherited from TfrxDPIAwarePanel.)
BevelKind | Represents property BevelKind. (Inherited from TfrxDPIAwarePanel.)
BevelOuter | Represents property BevelOuter. (Inherited from TfrxDPIAwarePanel.)
BevelWidth | Represents property BevelWidth. (Inherited from TfrxDPIAwarePanel.)
BiDiMode | Represents property BiDiMode. (Inherited from TfrxDPIAwarePanel.)
BorderStyle | Represents property BorderStyle. (Inherited from TfrxDPIAwarePanel.)
BorderWidth | Represents property BorderWidth. (Inherited from TfrxDPIAwarePanel.)
BtnCaption | Represents property BtnCaption.
Caption | Represents property Caption. (Inherited from TfrxDPIAwarePanel.)
Color | Represents property Color.
Constraints | Represents property Constraints. (Inherited from TfrxDPIAwarePanel.)
Ctl3D | Represents property Ctl3D. (Inherited from TfrxDPIAwarePanel.)
CurrentPPI | Represents property CurrentPPI. (Inherited from TfrxDPIAwareBasePanel.)
DockManager | Represents property DockManager. (Inherited from TfrxDPIAwarePanel.)
DockSite | Represents property DockSite. (Inherited from TfrxDPIAwarePanel.)
DragCursor | Represents property DragCursor. (Inherited from TfrxDPIAwarePanel.)
DragKind | Represents property DragKind. (Inherited from TfrxDPIAwarePanel.)
DragMode | Represents property DragMode. (Inherited from TfrxDPIAwarePanel.)
Enabled | Represents property Enabled. (Inherited from TfrxDPIAwarePanel.)
Font | Represents property Font. (Inherited from TfrxDPIAwarePanel.)
FullRepaint | Represents property FullRepaint. (Inherited from TfrxDPIAwarePanel.)
Locked | Represents property Locked. (Inherited from TfrxDPIAwarePanel.)
OnCanResize | Represents property OnCanResize. (Inherited from TfrxDPIAwarePanel.)
OnClick | Represents property OnClick. (Inherited from TfrxDPIAwarePanel.)
OnColorChanged | Represents property OnColorChanged.
OnConstrainedResize | Represents property OnConstrainedResize. (Inherited from TfrxDPIAwarePanel.)
OnContextPopup | Represents property OnContextPopup. (Inherited from TfrxDPIAwarePanel.)
OnDblClick | Represents property OnDblClick. (Inherited from TfrxDPIAwarePanel.)
OnDockDrop | Represents property OnDockDrop. (Inherited from TfrxDPIAwarePanel.)
OnDockOver | Represents property OnDockOver. (Inherited from TfrxDPIAwarePanel.)
OnDragDrop | Represents property OnDragDrop. (Inherited from TfrxDPIAwarePanel.)
OnDragOver | Represents property OnDragOver. (Inherited from TfrxDPIAwarePanel.)
OnEndDock | Represents property OnEndDock. (Inherited from TfrxDPIAwarePanel.)
OnEndDrag | Represents property OnEndDrag. (Inherited from TfrxDPIAwarePanel.)
OnEnter | Represents property OnEnter. (Inherited from TfrxDPIAwarePanel.)
OnExit | Represents property OnExit. (Inherited from TfrxDPIAwarePanel.)
OnGetSiteInfo | Represents property OnGetSiteInfo. (Inherited from TfrxDPIAwarePanel.)
OnMouseDown | Represents property OnMouseDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseMove | Represents property OnMouseMove. (Inherited from TfrxDPIAwarePanel.)
OnMouseUp | Represents property OnMouseUp. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheel | Represents property OnMouseWheel. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelDown | Represents property OnMouseWheelDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelUp | Represents property OnMouseWheelUp. (Inherited from TfrxDPIAwarePanel.)
OnResize | Represents property OnResize. (Inherited from TfrxDPIAwarePanel.)
OnStartDock | Represents property OnStartDock. (Inherited from TfrxDPIAwarePanel.)
OnStartDrag | Represents property OnStartDrag. (Inherited from TfrxDPIAwarePanel.)
OnUnDock | Represents property OnUnDock. (Inherited from TfrxDPIAwarePanel.)
ParentBackground | Represents property ParentBackground. (Inherited from TfrxDPIAwarePanel.)
ParentBiDiMode | Represents property ParentBiDiMode. (Inherited from TfrxDPIAwarePanel.)
ParentColor | Represents property ParentColor. (Inherited from TfrxDPIAwarePanel.)
ParentCtl3D | Represents property ParentCtl3D. (Inherited from TfrxDPIAwarePanel.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDPIAwarePanel.)
ParentShowHint | Represents property ParentShowHint. (Inherited from TfrxDPIAwarePanel.)
PopupMenu | Represents property PopupMenu. (Inherited from TfrxDPIAwarePanel.)
ShowHint | Represents property ShowHint. (Inherited from TfrxDPIAwarePanel.)
TabOrder | Represents property TabOrder. (Inherited from TfrxDPIAwarePanel.)
TabStop | Represents property TabStop. (Inherited from TfrxDPIAwarePanel.)
UseDockManager | Represents property UseDockManager. (Inherited from TfrxDPIAwarePanel.)
Visible | Represents property Visible. (Inherited from TfrxDPIAwarePanel.)
Top
Methods
Show:
Name | Description
CalcSize | Represents method CalcSize.
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Inherited from TfrxDPIAwareBasePanel.)
DrawEdge(Integer,Integer,Boolean) | Represents method DrawEdge(Integer,Integer,Boolean). (Overrides TfrxCustomSelector.DrawEdge(Integer,Integer,Boolean).)
GetReleativeScale | Represents method GetReleativeScale. (Inherited from TfrxDPIAwareBasePanel.)
GetScale | Represents method GetScale. (Inherited from TfrxDPIAwareBasePanel.)
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer). (Inherited from TfrxCustomSelector.)
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer). (Inherited from TfrxCustomSelector.)
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint. (Overrides TfrxCustomSelector.Paint.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxDPIAwareBasePanel.)
Top
Fields
Show:
Name | Description
FBtnCaption | Represents field FBtnCaption.
FButtonHeight | Represents field FButtonHeight.
FColor | Represents field FColor.
FColorCellSize | Represents field FColorCellSize.
FColorColumns | Represents field FColorColumns.
FColorRows | Represents field FColorRows.
FGap | Represents field FGap.
FOnColorChanged | Represents field FOnColorChanged.
Top
See Also

Reference

  • frxDesgnCtrls


TfrxColorSelector Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxColorSelector class. (Overrides TfrxCustomSelector.Create(TComponent).)
Top


TfrxColorSelector.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxColorSelector class.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomSelector.Create(TComponent)
See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector Properties

Properties
Name | Description
BtnCaption | Represents property BtnCaption.
Color | Represents property Color.
OnColorChanged | Represents property OnColorChanged.
Top


TfrxColorSelector.BtnCaption Property

Summary

Represents property BtnCaption.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property BtnCaption: String read FBtnCaption write FBtnCaption;

Property Value

Type: String

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector.Color Property

Summary

Represents property Color.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property Color: TColor read FColor write FColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector.OnColorChanged Property

Summary

Represents property OnColorChanged.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property OnColorChanged: TNotifyEvent read FOnColorChanged write FOnColorChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector Methods

Methods
Name | Description
CalcSize | Represents method CalcSize.
DrawEdge(Integer,Integer,Boolean) | Represents method DrawEdge(Integer,Integer,Boolean). (Overrides TfrxCustomSelector.DrawEdge(Integer,Integer,Boolean).)
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint. (Overrides TfrxCustomSelector.Paint.)
Top


TfrxColorSelector.CalcSize Method

Summary

Represents method CalcSize.

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 function CalcSize: TSize;

Return Value

Type: TSize

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector.DrawEdge(Integer,Integer,Boolean) Method

Summary

Represents method DrawEdge(Integer,Integer,Boolean).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure DrawEdge(X, Y: Integer; IsDown: Boolean); override;

Parameters

X
Type: Integer

Y
Type: Integer

IsDown
Type: Boolean

Overrides

TfrxCustomSelector.DrawEdge(Integer,Integer,Boolean)
See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector.Paint Method

Summary

Represents method Paint.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure Paint; override;

Overrides

TfrxCustomSelector.Paint
See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector Fields

Fields
Name | Description
FBtnCaption | Represents field FBtnCaption.
FButtonHeight | Represents field FButtonHeight.
FColor | Represents field FColor.
FColorCellSize | Represents field FColorCellSize.
FColorColumns | Represents field FColorColumns.
FColorRows | Represents field FColorRows.
FGap | Represents field FGap.
FOnColorChanged | Represents field FOnColorChanged.
Top


TfrxColorSelector.FBtnCaption Field

Summary

Represents field FBtnCaption.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FBtnCaption: String;

Field Value

Type: String

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector.FButtonHeight Field

Summary

Represents field FButtonHeight.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FButtonHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector.FColor Field

Summary

Represents field FColor.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector.FColorCellSize Field

Summary

Represents field FColorCellSize.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FColorCellSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector.FColorColumns Field

Summary

Represents field FColorColumns.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FColorColumns: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector.FColorRows Field

Summary

Represents field FColorRows.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FColorRows: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector.FGap Field

Summary

Represents field FGap.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FGap: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxColorSelector.FOnColorChanged Field

Summary

Represents field FOnColorChanged.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FOnColorChanged: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxColorSelector
  • frxDesgnCtrls


TfrxCustomSelector Class

Summary

Represents type TfrxCustomSelector.

Namespace: frxDesgnCtrls
Inheritance Hierarchy
TCustomPanel
frxDPIAwareBaseControls.TfrxDPIAwareBasePanel
frxDPIAwareBaseControls.TfrxDPIAwarePanel
frxDesgnCtrls.TfrxCustomSelector
frxDesgnCtrls.TfrxColorSelector
frxDesgnCtrls.TfrxLineSelector
Syntax
Delphi
type
 TfrxCustomSelector = class(TfrxDPIAwarePanel)
 end;

The TfrxCustomSelector type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomSelector class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Top
Properties
Show:
Name | Description
Align | Represents property Align. (Inherited from TfrxDPIAwarePanel.)
Alignment | Represents property Alignment. (Inherited from TfrxDPIAwarePanel.)
Anchors | Represents property Anchors. (Inherited from TfrxDPIAwarePanel.)
AutoSize | Represents property AutoSize. (Inherited from TfrxDPIAwarePanel.)
BevelInner | Represents property BevelInner. (Inherited from TfrxDPIAwarePanel.)
BevelKind | Represents property BevelKind. (Inherited from TfrxDPIAwarePanel.)
BevelOuter | Represents property BevelOuter. (Inherited from TfrxDPIAwarePanel.)
BevelWidth | Represents property BevelWidth. (Inherited from TfrxDPIAwarePanel.)
BiDiMode | Represents property BiDiMode. (Inherited from TfrxDPIAwarePanel.)
BorderStyle | Represents property BorderStyle. (Inherited from TfrxDPIAwarePanel.)
BorderWidth | Represents property BorderWidth. (Inherited from TfrxDPIAwarePanel.)
Caption | Represents property Caption. (Inherited from TfrxDPIAwarePanel.)
Color | Represents property Color. (Inherited from TfrxDPIAwarePanel.)
Constraints | Represents property Constraints. (Inherited from TfrxDPIAwarePanel.)
Ctl3D | Represents property Ctl3D. (Inherited from TfrxDPIAwarePanel.)
CurrentPPI | Represents property CurrentPPI. (Inherited from TfrxDPIAwareBasePanel.)
DockManager | Represents property DockManager. (Inherited from TfrxDPIAwarePanel.)
DockSite | Represents property DockSite. (Inherited from TfrxDPIAwarePanel.)
DragCursor | Represents property DragCursor. (Inherited from TfrxDPIAwarePanel.)
DragKind | Represents property DragKind. (Inherited from TfrxDPIAwarePanel.)
DragMode | Represents property DragMode. (Inherited from TfrxDPIAwarePanel.)
Enabled | Represents property Enabled. (Inherited from TfrxDPIAwarePanel.)
Font | Represents property Font. (Inherited from TfrxDPIAwarePanel.)
FullRepaint | Represents property FullRepaint. (Inherited from TfrxDPIAwarePanel.)
Locked | Represents property Locked. (Inherited from TfrxDPIAwarePanel.)
OnCanResize | Represents property OnCanResize. (Inherited from TfrxDPIAwarePanel.)
OnClick | Represents property OnClick. (Inherited from TfrxDPIAwarePanel.)
OnConstrainedResize | Represents property OnConstrainedResize. (Inherited from TfrxDPIAwarePanel.)
OnContextPopup | Represents property OnContextPopup. (Inherited from TfrxDPIAwarePanel.)
OnDblClick | Represents property OnDblClick. (Inherited from TfrxDPIAwarePanel.)
OnDockDrop | Represents property OnDockDrop. (Inherited from TfrxDPIAwarePanel.)
OnDockOver | Represents property OnDockOver. (Inherited from TfrxDPIAwarePanel.)
OnDragDrop | Represents property OnDragDrop. (Inherited from TfrxDPIAwarePanel.)
OnDragOver | Represents property OnDragOver. (Inherited from TfrxDPIAwarePanel.)
OnEndDock | Represents property OnEndDock. (Inherited from TfrxDPIAwarePanel.)
OnEndDrag | Represents property OnEndDrag. (Inherited from TfrxDPIAwarePanel.)
OnEnter | Represents property OnEnter. (Inherited from TfrxDPIAwarePanel.)
OnExit | Represents property OnExit. (Inherited from TfrxDPIAwarePanel.)
OnGetSiteInfo | Represents property OnGetSiteInfo. (Inherited from TfrxDPIAwarePanel.)
OnMouseDown | Represents property OnMouseDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseMove | Represents property OnMouseMove. (Inherited from TfrxDPIAwarePanel.)
OnMouseUp | Represents property OnMouseUp. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheel | Represents property OnMouseWheel. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelDown | Represents property OnMouseWheelDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelUp | Represents property OnMouseWheelUp. (Inherited from TfrxDPIAwarePanel.)
OnResize | Represents property OnResize. (Inherited from TfrxDPIAwarePanel.)
OnStartDock | Represents property OnStartDock. (Inherited from TfrxDPIAwarePanel.)
OnStartDrag | Represents property OnStartDrag. (Inherited from TfrxDPIAwarePanel.)
OnUnDock | Represents property OnUnDock. (Inherited from TfrxDPIAwarePanel.)
ParentBackground | Represents property ParentBackground. (Inherited from TfrxDPIAwarePanel.)
ParentBiDiMode | Represents property ParentBiDiMode. (Inherited from TfrxDPIAwarePanel.)
ParentColor | Represents property ParentColor. (Inherited from TfrxDPIAwarePanel.)
ParentCtl3D | Represents property ParentCtl3D. (Inherited from TfrxDPIAwarePanel.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDPIAwarePanel.)
ParentShowHint | Represents property ParentShowHint. (Inherited from TfrxDPIAwarePanel.)
PopupMenu | Represents property PopupMenu. (Inherited from TfrxDPIAwarePanel.)
ShowHint | Represents property ShowHint. (Inherited from TfrxDPIAwarePanel.)
TabOrder | Represents property TabOrder. (Inherited from TfrxDPIAwarePanel.)
TabStop | Represents property TabStop. (Inherited from TfrxDPIAwarePanel.)
UseDockManager | Represents property UseDockManager. (Inherited from TfrxDPIAwarePanel.)
Visible | Represents property Visible. (Inherited from TfrxDPIAwarePanel.)
Top
Methods
Show:
Name | Description
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Inherited from TfrxDPIAwareBasePanel.)
DrawEdge(Integer,Integer,Boolean) | Represents method DrawEdge(Integer,Integer,Boolean).
GetReleativeScale | Represents method GetReleativeScale. (Inherited from TfrxDPIAwareBasePanel.)
GetScale | Represents method GetScale. (Inherited from TfrxDPIAwareBasePanel.)
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
Paint | Represents method Paint.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxDPIAwareBasePanel.)
WMEraseBackground(TMessage) | Represents method WMEraseBackground(TMessage).
Top
Fields
Show:
Name | Description
FclHeight | Represents field FclHeight.
FclWidth | Represents field FclWidth.
Top
See Also

Reference

  • frxDesgnCtrls


TfrxCustomSelector Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomSelector class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Top


TfrxCustomSelector.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomSelector class.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDPIAwareBasePanel.Create(TComponent)
See Also

Reference

  • TfrxCustomSelector
  • frxDesgnCtrls


TfrxCustomSelector Methods

Methods
Name | Description
DrawEdge(Integer,Integer,Boolean) | Represents method DrawEdge(Integer,Integer,Boolean).
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
Paint | Represents method Paint.
WMEraseBackground(TMessage) | Represents method WMEraseBackground(TMessage).
Top


TfrxCustomSelector.DrawEdge(Integer,Integer,Boolean) Method

Summary

Represents method DrawEdge(Integer,Integer,Boolean).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure DrawEdge(X, Y: Integer; IsDown: Boolean); virtual; abstract;

Parameters

X
Type: Integer

Y
Type: Integer

IsDown
Type: Boolean

See Also

Reference

  • TfrxCustomSelector
  • frxDesgnCtrls


TfrxCustomSelector.MouseDown(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure MouseDown(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxCustomSelector
  • frxDesgnCtrls


TfrxCustomSelector.MouseMove(TShiftState,Integer,Integer) Method

Summary

Represents method MouseMove(TShiftState,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;

Parameters

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxCustomSelector
  • frxDesgnCtrls


TfrxCustomSelector.Paint Method

Summary

Represents method Paint.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure Paint; override;
See Also

Reference

  • TfrxCustomSelector
  • frxDesgnCtrls


TfrxCustomSelector.WMEraseBackground(TMessage) Method

Summary

Represents method WMEraseBackground(TMessage).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure WMEraseBackground(var Message: TMessage); message WM_ERASEBKGND;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxCustomSelector
  • frxDesgnCtrls


TfrxCustomSelector Fields

Fields
Name | Description
FclHeight | Represents field FclHeight.
FclWidth | Represents field FclWidth.
Top


TfrxCustomSelector.FclHeight Field

Summary

Represents field FclHeight.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FclHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomSelector
  • frxDesgnCtrls


TfrxCustomSelector.FclWidth Field

Summary

Represents field FclWidth.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FclWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomSelector
  • frxDesgnCtrls


TfrxFrameSampleControl Class

Summary

Represents type TfrxFrameSampleControl.

Namespace: frxDesgnCtrls
Inheritance Hierarchy
TCustomControl
frxDesgnCtrls.TfrxFrameSampleControl
Syntax
Delphi
type
 TfrxFrameSampleControl = class(TCustomControl)
 end;

The TfrxFrameSampleControl type exposes the following members.

Properties
Show:
Name | Description
Frame | Represents property Frame.
Top
Methods
Show:
Name | Description
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
Top
Events
Show:
Name | Description
OnFrameLineClicked | Represents property OnFrameLineClicked.
Top
Fields
Show:
Name | Description
FFrame | Represents field FFrame.
FOnFrameLineClicked | Represents field FOnFrameLineClicked.
Top
See Also

Reference

  • frxDesgnCtrls


TfrxFrameSampleControl Properties

Properties
Name | Description
Frame | Represents property Frame.
Top


TfrxFrameSampleControl.Frame Property

Summary

Represents property Frame.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property Frame: TfrxFrame read FFrame write FFrame;

Property Value

Type: TfrxFrame

See Also

Reference

  • TfrxFrameSampleControl
  • frxDesgnCtrls


TfrxFrameSampleControl Methods

Methods
Name | Description
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
Top


TfrxFrameSampleControl.MouseDown(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure MouseDown(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxFrameSampleControl
  • frxDesgnCtrls


TfrxFrameSampleControl.Paint Method

Summary

Represents method Paint.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure Paint; override;
See Also

Reference

  • TfrxFrameSampleControl
  • frxDesgnCtrls


TfrxFrameSampleControl Events

Events
Name | Description
OnFrameLineClicked | Represents property OnFrameLineClicked.
Top


TfrxFrameSampleControl.OnFrameLineClicked Event

Summary

Represents property OnFrameLineClicked.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property OnFrameLineClicked: TfrxFrameLineClickedEvent read FOnFrameLineClicked write FOnFrameLineClicked;

Value

Type: TfrxFrameLineClickedEvent

See Also

Reference

  • TfrxFrameSampleControl
  • frxDesgnCtrls


TfrxFrameSampleControl Fields

Fields
Name | Description
FFrame | Represents field FFrame.
FOnFrameLineClicked | Represents field FOnFrameLineClicked.
Top


TfrxFrameSampleControl.FFrame Field

Summary

Represents field FFrame.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FFrame: TfrxFrame;

Field Value

Type: TfrxFrame

See Also

Reference

  • TfrxFrameSampleControl
  • frxDesgnCtrls


TfrxFrameSampleControl.FOnFrameLineClicked Field

Summary

Represents field FOnFrameLineClicked.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FOnFrameLineClicked: TfrxFrameLineClickedEvent;

Field Value

Type: TfrxFrameLineClickedEvent

See Also

Reference

  • TfrxFrameSampleControl
  • frxDesgnCtrls


TfrxLineSelector Class

Summary

Represents type TfrxLineSelector.

Namespace: frxDesgnCtrls
Inheritance Hierarchy
TCustomPanel
frxDPIAwareBaseControls.TfrxDPIAwareBasePanel
frxDPIAwareBaseControls.TfrxDPIAwarePanel
frxDesgnCtrls.TfrxCustomSelector
frxDesgnCtrls.TfrxLineSelector
Syntax
Delphi
type
 TfrxLineSelector = class(TfrxCustomSelector)
 end;

The TfrxLineSelector type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxLineSelector class. (Overrides TfrxCustomSelector.Create(TComponent).)
Top
Properties
Show:
Name | Description
Align | Represents property Align. (Inherited from TfrxDPIAwarePanel.)
Alignment | Represents property Alignment. (Inherited from TfrxDPIAwarePanel.)
Anchors | Represents property Anchors. (Inherited from TfrxDPIAwarePanel.)
AutoSize | Represents property AutoSize. (Inherited from TfrxDPIAwarePanel.)
BevelInner | Represents property BevelInner. (Inherited from TfrxDPIAwarePanel.)
BevelKind | Represents property BevelKind. (Inherited from TfrxDPIAwarePanel.)
BevelOuter | Represents property BevelOuter. (Inherited from TfrxDPIAwarePanel.)
BevelWidth | Represents property BevelWidth. (Inherited from TfrxDPIAwarePanel.)
BiDiMode | Represents property BiDiMode. (Inherited from TfrxDPIAwarePanel.)
BorderStyle | Represents property BorderStyle. (Inherited from TfrxDPIAwarePanel.)
BorderWidth | Represents property BorderWidth. (Inherited from TfrxDPIAwarePanel.)
Caption | Represents property Caption. (Inherited from TfrxDPIAwarePanel.)
Color | Represents property Color. (Inherited from TfrxDPIAwarePanel.)
Constraints | Represents property Constraints. (Inherited from TfrxDPIAwarePanel.)
Ctl3D | Represents property Ctl3D. (Inherited from TfrxDPIAwarePanel.)
CurrentPPI | Represents property CurrentPPI. (Inherited from TfrxDPIAwareBasePanel.)
DockManager | Represents property DockManager. (Inherited from TfrxDPIAwarePanel.)
DockSite | Represents property DockSite. (Inherited from TfrxDPIAwarePanel.)
DragCursor | Represents property DragCursor. (Inherited from TfrxDPIAwarePanel.)
DragKind | Represents property DragKind. (Inherited from TfrxDPIAwarePanel.)
DragMode | Represents property DragMode. (Inherited from TfrxDPIAwarePanel.)
Enabled | Represents property Enabled. (Inherited from TfrxDPIAwarePanel.)
Font | Represents property Font. (Inherited from TfrxDPIAwarePanel.)
FullRepaint | Represents property FullRepaint. (Inherited from TfrxDPIAwarePanel.)
Locked | Represents property Locked. (Inherited from TfrxDPIAwarePanel.)
OnCanResize | Represents property OnCanResize. (Inherited from TfrxDPIAwarePanel.)
OnClick | Represents property OnClick. (Inherited from TfrxDPIAwarePanel.)
OnConstrainedResize | Represents property OnConstrainedResize. (Inherited from TfrxDPIAwarePanel.)
OnContextPopup | Represents property OnContextPopup. (Inherited from TfrxDPIAwarePanel.)
OnDblClick | Represents property OnDblClick. (Inherited from TfrxDPIAwarePanel.)
OnDockDrop | Represents property OnDockDrop. (Inherited from TfrxDPIAwarePanel.)
OnDockOver | Represents property OnDockOver. (Inherited from TfrxDPIAwarePanel.)
OnDragDrop | Represents property OnDragDrop. (Inherited from TfrxDPIAwarePanel.)
OnDragOver | Represents property OnDragOver. (Inherited from TfrxDPIAwarePanel.)
OnEndDock | Represents property OnEndDock. (Inherited from TfrxDPIAwarePanel.)
OnEndDrag | Represents property OnEndDrag. (Inherited from TfrxDPIAwarePanel.)
OnEnter | Represents property OnEnter. (Inherited from TfrxDPIAwarePanel.)
OnExit | Represents property OnExit. (Inherited from TfrxDPIAwarePanel.)
OnGetSiteInfo | Represents property OnGetSiteInfo. (Inherited from TfrxDPIAwarePanel.)
OnMouseDown | Represents property OnMouseDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseMove | Represents property OnMouseMove. (Inherited from TfrxDPIAwarePanel.)
OnMouseUp | Represents property OnMouseUp. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheel | Represents property OnMouseWheel. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelDown | Represents property OnMouseWheelDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelUp | Represents property OnMouseWheelUp. (Inherited from TfrxDPIAwarePanel.)
OnResize | Represents property OnResize. (Inherited from TfrxDPIAwarePanel.)
OnStartDock | Represents property OnStartDock. (Inherited from TfrxDPIAwarePanel.)
OnStartDrag | Represents property OnStartDrag. (Inherited from TfrxDPIAwarePanel.)
OnStyleChanged | Represents property OnStyleChanged.
OnUnDock | Represents property OnUnDock. (Inherited from TfrxDPIAwarePanel.)
ParentBackground | Represents property ParentBackground. (Inherited from TfrxDPIAwarePanel.)
ParentBiDiMode | Represents property ParentBiDiMode. (Inherited from TfrxDPIAwarePanel.)
ParentColor | Represents property ParentColor. (Inherited from TfrxDPIAwarePanel.)
ParentCtl3D | Represents property ParentCtl3D. (Inherited from TfrxDPIAwarePanel.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDPIAwarePanel.)
ParentShowHint | Represents property ParentShowHint. (Inherited from TfrxDPIAwarePanel.)
PopupMenu | Represents property PopupMenu. (Inherited from TfrxDPIAwarePanel.)
ShowHint | Represents property ShowHint. (Inherited from TfrxDPIAwarePanel.)
Style | Represents property Style.
TabOrder | Represents property TabOrder. (Inherited from TfrxDPIAwarePanel.)
TabStop | Represents property TabStop. (Inherited from TfrxDPIAwarePanel.)
UseDockManager | Represents property UseDockManager. (Inherited from TfrxDPIAwarePanel.)
Visible | Represents property Visible. (Inherited from TfrxDPIAwarePanel.)
Top
Methods
Show:
Name | Description
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Inherited from TfrxDPIAwareBasePanel.)
DrawEdge(Integer,Integer,Boolean) | Represents method DrawEdge(Integer,Integer,Boolean). (Overrides TfrxCustomSelector.DrawEdge(Integer,Integer,Boolean).)
GetReleativeScale | Represents method GetReleativeScale. (Inherited from TfrxDPIAwareBasePanel.)
GetScale | Represents method GetScale. (Inherited from TfrxDPIAwareBasePanel.)
GetScaledSize | Represents method GetScaledSize.
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer). (Inherited from TfrxCustomSelector.)
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer). (Inherited from TfrxCustomSelector.)
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint. (Overrides TfrxCustomSelector.Paint.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxDPIAwareBasePanel.)
Top
Fields
Show:
Name | Description
FOnStyleChanged | Represents field FOnStyleChanged.
FStyle | Represents field FStyle.
Top
See Also

Reference

  • frxDesgnCtrls


TfrxLineSelector Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxLineSelector class. (Overrides TfrxCustomSelector.Create(TComponent).)
Top


TfrxLineSelector.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxLineSelector class.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomSelector.Create(TComponent)
See Also

Reference

  • TfrxLineSelector
  • frxDesgnCtrls


TfrxLineSelector Properties

Properties
Name | Description
OnStyleChanged | Represents property OnStyleChanged.
Style | Represents property Style.
Top


TfrxLineSelector.OnStyleChanged Property

Summary

Represents property OnStyleChanged.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property OnStyleChanged: TNotifyEvent read FOnStyleChanged write FOnStyleChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxLineSelector
  • frxDesgnCtrls


TfrxLineSelector.Style Property

Summary

Represents property Style.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property Style: Byte read FStyle;

Property Value

Type: Byte

See Also

Reference

  • TfrxLineSelector
  • frxDesgnCtrls


TfrxLineSelector Methods

Methods
Name | Description
DrawEdge(Integer,Integer,Boolean) | Represents method DrawEdge(Integer,Integer,Boolean). (Overrides TfrxCustomSelector.DrawEdge(Integer,Integer,Boolean).)
GetScaledSize | Represents method GetScaledSize.
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint. (Overrides TfrxCustomSelector.Paint.)
Top


TfrxLineSelector.DrawEdge(Integer,Integer,Boolean) Method

Summary

Represents method DrawEdge(Integer,Integer,Boolean).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure DrawEdge(X, Y: Integer; IsDown: Boolean); override;

Parameters

X
Type: Integer

Y
Type: Integer

IsDown
Type: Boolean

Overrides

TfrxCustomSelector.DrawEdge(Integer,Integer,Boolean)
See Also

Reference

  • TfrxLineSelector
  • frxDesgnCtrls


TfrxLineSelector.GetScaledSize Method

Summary

Represents method GetScaledSize.

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 function GetScaledSize: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxLineSelector
  • frxDesgnCtrls


TfrxLineSelector.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxLineSelector
  • frxDesgnCtrls


TfrxLineSelector.Paint Method

Summary

Represents method Paint.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure Paint; override;

Overrides

TfrxCustomSelector.Paint
See Also

Reference

  • TfrxLineSelector
  • frxDesgnCtrls


TfrxLineSelector Fields

Fields
Name | Description
FOnStyleChanged | Represents field FOnStyleChanged.
FStyle | Represents field FStyle.
Top


TfrxLineSelector.FOnStyleChanged Field

Summary

Represents field FOnStyleChanged.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FOnStyleChanged: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxLineSelector
  • frxDesgnCtrls


TfrxLineSelector.FStyle Field

Summary

Represents field FStyle.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FStyle: Byte;

Field Value

Type: Byte

See Also

Reference

  • TfrxLineSelector
  • frxDesgnCtrls


TfrxLineStyleControl Class

Summary

Represents type TfrxLineStyleControl.

Namespace: frxDesgnCtrls
Inheritance Hierarchy
TCustomControl
frxDPIAwareBaseControls.TfrxDPIAwareCustomControl
frxDesgnCtrls.TfrxLineStyleControl
Syntax
Delphi
type
 TfrxLineStyleControl = class(TfrxDPIAwareCustomControl)
 end;

The TfrxLineStyleControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxLineStyleControl class. (Overrides TfrxDPIAwareCustomControl.Create(TComponent).)
Top
Properties
Show:
Name | Description
CurrentPPI | Represents property CurrentPPI. (Inherited from TfrxDPIAwareCustomControl.)
OnStyleChanged | Represents property OnStyleChanged.
Style | Represents property Style.
Top
Methods
Show:
Name | Description
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Inherited from TfrxDPIAwareCustomControl.)
GetReleativeScale | Represents method GetReleativeScale. (Inherited from TfrxDPIAwareCustomControl.)
GetScale | Represents method GetScale. (Inherited from TfrxDPIAwareCustomControl.)
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxDPIAwareCustomControl.)
SetStyle(TfrxFrameStyle) | Represents method SetStyle(TfrxFrameStyle).
WMEraseBackground(TMessage) | Represents method WMEraseBackground(TMessage).
Top
Fields
Show:
Name | Description
FOnStyleChanged | Represents field FOnStyleChanged.
FStyle | Represents field FStyle.
Top
See Also

Reference

  • frxDesgnCtrls


TfrxLineStyleControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxLineStyleControl class. (Overrides TfrxDPIAwareCustomControl.Create(TComponent).)
Top


TfrxLineStyleControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxLineStyleControl class.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDPIAwareCustomControl.Create(TComponent)
See Also

Reference

  • TfrxLineStyleControl
  • frxDesgnCtrls


TfrxLineStyleControl Properties

Properties
Name | Description
OnStyleChanged | Represents property OnStyleChanged.
Style | Represents property Style.
Top


TfrxLineStyleControl.OnStyleChanged Property

Summary

Represents property OnStyleChanged.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property OnStyleChanged: TNotifyEvent read FOnStyleChanged write FOnStyleChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxLineStyleControl
  • frxDesgnCtrls


TfrxLineStyleControl.Style Property

Summary

Represents property Style.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property Style: TfrxFrameStyle read FStyle write SetStyle;

Property Value

Type: TfrxFrameStyle

See Also

Reference

  • TfrxLineStyleControl
  • frxDesgnCtrls


TfrxLineStyleControl Methods

Methods
Name | Description
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
SetStyle(TfrxFrameStyle) | Represents method SetStyle(TfrxFrameStyle).
WMEraseBackground(TMessage) | Represents method WMEraseBackground(TMessage).
Top


TfrxLineStyleControl.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxLineStyleControl
  • frxDesgnCtrls


TfrxLineStyleControl.Paint Method

Summary

Represents method Paint.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure Paint; override;
See Also

Reference

  • TfrxLineStyleControl
  • frxDesgnCtrls


TfrxLineStyleControl.SetStyle(TfrxFrameStyle) Method

Summary

Represents method SetStyle(TfrxFrameStyle).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure SetStyle(const Value: TfrxFrameStyle);

Parameters

Value
Type: TfrxFrameStyle

See Also

Reference

  • TfrxLineStyleControl
  • frxDesgnCtrls


TfrxLineStyleControl.WMEraseBackground(TMessage) Method

Summary

Represents method WMEraseBackground(TMessage).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure WMEraseBackground(var Message: TMessage); message WM_ERASEBKGND;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxLineStyleControl
  • frxDesgnCtrls


TfrxLineStyleControl Fields

Fields
Name | Description
FOnStyleChanged | Represents field FOnStyleChanged.
FStyle | Represents field FStyle.
Top


TfrxLineStyleControl.FOnStyleChanged Field

Summary

Represents field FOnStyleChanged.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FOnStyleChanged: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxLineStyleControl
  • frxDesgnCtrls


TfrxLineStyleControl.FStyle Field

Summary

Represents field FStyle.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FStyle: TfrxFrameStyle;

Field Value

Type: TfrxFrameStyle

See Also

Reference

  • TfrxLineStyleControl
  • frxDesgnCtrls


TfrxRuler Class

Summary

Represents type TfrxRuler.

Namespace: frxDesgnCtrls
Inheritance Hierarchy
TCustomPanel
frxDPIAwareBaseControls.TfrxDPIAwareBasePanel
frxDPIAwareBaseControls.TfrxDPIAwarePanel
frxDesgnCtrls.TfrxRuler
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxRuler = class(TfrxDPIAwarePanel)
 end;

The TfrxRuler type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxRuler class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Top
Properties
Show:
Name | Description
Align | Represents property Align. (Inherited from TfrxDPIAwarePanel.)
Alignment | Represents property Alignment. (Inherited from TfrxDPIAwarePanel.)
Anchors | Represents property Anchors. (Inherited from TfrxDPIAwarePanel.)
AutoSize | Represents property AutoSize. (Inherited from TfrxDPIAwarePanel.)
BevelInner | Represents property BevelInner. (Inherited from TfrxDPIAwarePanel.)
BevelKind | Represents property BevelKind. (Inherited from TfrxDPIAwarePanel.)
BevelOuter | Represents property BevelOuter. (Inherited from TfrxDPIAwarePanel.)
BevelWidth | Represents property BevelWidth. (Inherited from TfrxDPIAwarePanel.)
BiDiMode | Represents property BiDiMode. (Inherited from TfrxDPIAwarePanel.)
BorderStyle | Represents property BorderStyle. (Inherited from TfrxDPIAwarePanel.)
BorderWidth | Represents property BorderWidth. (Inherited from TfrxDPIAwarePanel.)
Caption | Represents property Caption. (Inherited from TfrxDPIAwarePanel.)
Color | Represents property Color. (Inherited from TfrxDPIAwarePanel.)
Constraints | Represents property Constraints. (Inherited from TfrxDPIAwarePanel.)
Ctl3D | Represents property Ctl3D. (Inherited from TfrxDPIAwarePanel.)
CurrentPPI | Represents property CurrentPPI. (Inherited from TfrxDPIAwareBasePanel.)
DockManager | Represents property DockManager. (Inherited from TfrxDPIAwarePanel.)
DockSite | Represents property DockSite. (Inherited from TfrxDPIAwarePanel.)
DragCursor | Represents property DragCursor. (Inherited from TfrxDPIAwarePanel.)
DragKind | Represents property DragKind. (Inherited from TfrxDPIAwarePanel.)
DragMode | Represents property DragMode. (Inherited from TfrxDPIAwarePanel.)
Enabled | Represents property Enabled. (Inherited from TfrxDPIAwarePanel.)
Font | Represents property Font. (Inherited from TfrxDPIAwarePanel.)
FullRepaint | Represents property FullRepaint. (Inherited from TfrxDPIAwarePanel.)
Guides | Represents property Guides.
Locked | Represents property Locked. (Inherited from TfrxDPIAwarePanel.)
Offset | Represents property Offset.
OnCanResize | Represents property OnCanResize. (Inherited from TfrxDPIAwarePanel.)
OnClick | Represents property OnClick. (Inherited from TfrxDPIAwarePanel.)
OnConstrainedResize | Represents property OnConstrainedResize. (Inherited from TfrxDPIAwarePanel.)
OnContextPopup | Represents property OnContextPopup. (Inherited from TfrxDPIAwarePanel.)
OnDblClick | Represents property OnDblClick. (Inherited from TfrxDPIAwarePanel.)
OnDockDrop | Represents property OnDockDrop. (Inherited from TfrxDPIAwarePanel.)
OnDockOver | Represents property OnDockOver. (Inherited from TfrxDPIAwarePanel.)
OnDragDrop | Represents property OnDragDrop. (Inherited from TfrxDPIAwarePanel.)
OnDragOver | Represents property OnDragOver. (Inherited from TfrxDPIAwarePanel.)
OnEndDock | Represents property OnEndDock. (Inherited from TfrxDPIAwarePanel.)
OnEndDrag | Represents property OnEndDrag. (Inherited from TfrxDPIAwarePanel.)
OnEnter | Represents property OnEnter. (Inherited from TfrxDPIAwarePanel.)
OnExit | Represents property OnExit. (Inherited from TfrxDPIAwarePanel.)
OnGetSiteInfo | Represents property OnGetSiteInfo. (Inherited from TfrxDPIAwarePanel.)
OnMouseDown | Represents property OnMouseDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseMove | Represents property OnMouseMove. (Inherited from TfrxDPIAwarePanel.)
OnMouseUp | Represents property OnMouseUp. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheel | Represents property OnMouseWheel. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelDown | Represents property OnMouseWheelDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelUp | Represents property OnMouseWheelUp. (Inherited from TfrxDPIAwarePanel.)
OnPointerAdded | Represents property OnPointerAdded.
OnResize | Represents property OnResize. (Inherited from TfrxDPIAwarePanel.)
OnStartDock | Represents property OnStartDock. (Inherited from TfrxDPIAwarePanel.)
OnStartDrag | Represents property OnStartDrag. (Inherited from TfrxDPIAwarePanel.)
OnUnDock | Represents property OnUnDock. (Inherited from TfrxDPIAwarePanel.)
ParentBackground | Represents property ParentBackground. (Inherited from TfrxDPIAwarePanel.)
ParentBiDiMode | Represents property ParentBiDiMode. (Inherited from TfrxDPIAwarePanel.)
ParentColor | Represents property ParentColor. (Inherited from TfrxDPIAwarePanel.)
ParentCtl3D | Represents property ParentCtl3D. (Inherited from TfrxDPIAwarePanel.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDPIAwarePanel.)
ParentShowHint | Represents property ParentShowHint. (Inherited from TfrxDPIAwarePanel.)
PopupMenu | Represents property PopupMenu. (Inherited from TfrxDPIAwarePanel.)
Position | Represents property Position.
Scale | Represents property Scale.
ShowHint | Represents property ShowHint. (Inherited from TfrxDPIAwarePanel.)
Size | Represents property Size.
Start | Represents property Start.
TabOrder | Represents property TabOrder. (Inherited from TfrxDPIAwarePanel.)
TabStop | Represents property TabStop. (Inherited from TfrxDPIAwarePanel.)
Units | Represents property Units.
UseDockManager | Represents property UseDockManager. (Inherited from TfrxDPIAwarePanel.)
Visible | Represents property Visible. (Inherited from TfrxDPIAwarePanel.)
Top
Methods
Show:
Name | Description
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage).
DblClick | Represents method DblClick.
DoEndDrag(TObject,Integer,Integer) | Represents method DoEndDrag(TObject,Integer,Integer).
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Overrides TfrxDPIAwareBasePanel.DoPPIChanged(Integer).)
DrawArrow(TCanvas,Integer,TColor) | Represents method DrawArrow(TCanvas,Integer,TColor).
DrawHint(TCanvas,Integer,Extended) | Represents method DrawHint(TCanvas,Integer,Extended).
GetReleativeScale | Represents method GetReleativeScale. (Inherited from TfrxDPIAwareBasePanel.)
GetScale | Represents method GetScale. (Inherited from TfrxDPIAwareBasePanel.)
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseLeave | Represents method MouseLeave.
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxDPIAwareBasePanel.)
SetOffset(Integer) | Represents method SetOffset(Integer).
SetPosition(Extended) | Represents method SetPosition(Extended).
SetScale(Extended) | Represents method SetScale(Extended).
SetSize(Integer) | Represents method SetSize(Integer).
SetStart(Integer) | Represents method SetStart(Integer).
SetUnits(TfrxRulerUnits) | Represents method SetUnits(TfrxRulerUnits).
WMEraseBackground(TMessage) | Represents method WMEraseBackground(TMessage).
Top
Events
Show:
Name | Description
OnUpdateVirtualLines | Represents property OnUpdateVirtualLines.
Top
Fields
Show:
Name | Description
FGuides | Represents field FGuides.
FMouseDown | Represents field FMouseDown.
FOffset | Represents field FOffset.
FOnPointerAdded | Represents field FOnPointerAdded.
FOnUpdateVirtualLines | Represents field FOnUpdateVirtualLines.
FPosition | Represents field FPosition.
FScale | Represents field FScale.
FSize | Represents field FSize.
FStart | Represents field FStart.
FUnits | Represents field FUnits.
FVirtualGuid | Represents field FVirtualGuid.
Top
See Also

Reference

  • frxDesgnCtrls


TfrxRuler Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxRuler class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Top


TfrxRuler.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxRuler class.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDPIAwareBasePanel.Create(TComponent)
See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler Properties

Properties
Name | Description
Guides | Represents property Guides.
Offset | Represents property Offset.
OnPointerAdded | Represents property OnPointerAdded.
Position | Represents property Position.
Scale | Represents property Scale.
Size | Represents property Size.
Start | Represents property Start.
Units | Represents property Units.
Top


TfrxRuler.Guides Property

Summary

Represents property Guides.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property Guides: TStrings read FGuides write FGuides;

Property Value

Type: TStrings

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.Offset Property

Summary

Represents property Offset.

Namespace: frxDesgnCtrls
Syntax
Delphi
published
 property Offset: Integer read FOffset write SetOffset;

Property Value

Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.OnPointerAdded Property

Summary

Represents property OnPointerAdded.

Namespace: frxDesgnCtrls
Syntax
Delphi
published
 property OnPointerAdded: TNotifyEvent read FOnPointerAdded write FOnPointerAdded;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.Position Property

Summary

Represents property Position.

Namespace: frxDesgnCtrls
Syntax
Delphi
published
 property Position: Extended read FPosition write SetPosition;

Property Value

Type: Extended

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.Scale Property

Summary

Represents property Scale.

Namespace: frxDesgnCtrls
Syntax
Delphi
published
 property Scale: Extended read FScale write SetScale;

Property Value

Type: Extended

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.Size Property

Summary

Represents property Size.

Namespace: frxDesgnCtrls
Syntax
Delphi
published
 property Size: Integer read FSize write SetSize;

Property Value

Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.Start Property

Summary

Represents property Start.

Namespace: frxDesgnCtrls
Syntax
Delphi
published
 property Start: Integer read FStart write SetStart;

Property Value

Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.Units Property

Summary

Represents property Units.

Namespace: frxDesgnCtrls
Syntax
Delphi
published
 property Units: TfrxRulerUnits read FUnits write SetUnits default ruPixels;

Property Value

Type: TfrxRulerUnits

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler Methods

Methods
Name | Description
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage).
DblClick | Represents method DblClick.
DoEndDrag(TObject,Integer,Integer) | Represents method DoEndDrag(TObject,Integer,Integer).
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Overrides TfrxDPIAwareBasePanel.DoPPIChanged(Integer).)
DrawArrow(TCanvas,Integer,TColor) | Represents method DrawArrow(TCanvas,Integer,TColor).
DrawHint(TCanvas,Integer,Extended) | Represents method DrawHint(TCanvas,Integer,Extended).
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseLeave | Represents method MouseLeave.
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
SetOffset(Integer) | Represents method SetOffset(Integer).
SetPosition(Extended) | Represents method SetPosition(Extended).
SetScale(Extended) | Represents method SetScale(Extended).
SetSize(Integer) | Represents method SetSize(Integer).
SetStart(Integer) | Represents method SetStart(Integer).
SetUnits(TfrxRulerUnits) | Represents method SetUnits(TfrxRulerUnits).
WMEraseBackground(TMessage) | Represents method WMEraseBackground(TMessage).
Top


TfrxRuler.CMMouseLeave(TMessage) Method

Summary

Represents method CMMouseLeave(TMessage).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure CMMouseLeave(var Message: TMessage); message CM_MOUSELEAVE;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.DblClick Method

Summary

Represents method DblClick.

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure DblClick; override;
See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.DoEndDrag(TObject,Integer,Integer) Method

Summary

Represents method DoEndDrag(TObject,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure DoEndDrag(Target: TObject; X, Y: Integer); override;

Parameters

Target
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.DoPPIChanged(Integer) Method

Summary

Represents method DoPPIChanged(Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure DoPPIChanged(aNewPPI: Integer); override;

Parameters

aNewPPI
Type: Integer

Overrides

TfrxDPIAwareBasePanel.DoPPIChanged(Integer)
See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.DrawArrow(TCanvas,Integer,TColor) Method

Summary

Represents method DrawArrow(TCanvas,Integer,TColor).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure DrawArrow(aCanvas: TCanvas; aPos: Integer; BrushColor: TColor);

Parameters

aCanvas
Type: TCanvas

aPos
Type: Integer

BrushColor
Type: TColor

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.DrawHint(TCanvas,Integer,Extended) Method

Summary

Represents method DrawHint(TCanvas,Integer,Extended).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure DrawHint(aCanvas: TCanvas; aPos: Integer; Value: Extended);

Parameters

aCanvas
Type: TCanvas

aPos
Type: Integer

Value
Type: Extended

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.MouseDown(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure MouseDown(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.MouseLeave Method

Summary

Represents method MouseLeave.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure MouseLeave;
See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.MouseMove(TShiftState,Integer,Integer) Method

Summary

Represents method MouseMove(TShiftState,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;

Parameters

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.Paint Method

Summary

Represents method Paint.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure Paint; override;
See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.SetOffset(Integer) Method

Summary

Represents method SetOffset(Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure SetOffset(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.SetPosition(Extended) Method

Summary

Represents method SetPosition(Extended).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure SetPosition(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.SetScale(Extended) Method

Summary

Represents method SetScale(Extended).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure SetScale(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.SetSize(Integer) Method

Summary

Represents method SetSize(Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure SetSize(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.SetStart(Integer) Method

Summary

Represents method SetStart(Integer).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure SetStart(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.SetUnits(TfrxRulerUnits) Method

Summary

Represents method SetUnits(TfrxRulerUnits).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure SetUnits(const Value: TfrxRulerUnits);

Parameters

Value
Type: TfrxRulerUnits

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.WMEraseBackground(TMessage) Method

Summary

Represents method WMEraseBackground(TMessage).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure WMEraseBackground(var Message: TMessage); message WM_ERASEBKGND;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler Events

Events
Name | Description
OnUpdateVirtualLines | Represents property OnUpdateVirtualLines.
Top


TfrxRuler.OnUpdateVirtualLines Event

Summary

Represents property OnUpdateVirtualLines.

Namespace: frxDesgnCtrls
Syntax
Delphi
published
 property OnUpdateVirtualLines: TfrxUpdateVirtualLines read FOnUpdateVirtualLines write FOnUpdateVirtualLines;

Value

Type: TfrxUpdateVirtualLines

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler Fields

Fields
Name | Description
FGuides | Represents field FGuides.
FMouseDown | Represents field FMouseDown.
FOffset | Represents field FOffset.
FOnPointerAdded | Represents field FOnPointerAdded.
FOnUpdateVirtualLines | Represents field FOnUpdateVirtualLines.
FPosition | Represents field FPosition.
FScale | Represents field FScale.
FSize | Represents field FSize.
FStart | Represents field FStart.
FUnits | Represents field FUnits.
FVirtualGuid | Represents field FVirtualGuid.
Top


TfrxRuler.FGuides Field

Summary

Represents field FGuides.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FGuides: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.FMouseDown Field

Summary

Represents field FMouseDown.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FMouseDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.FOffset Field

Summary

Represents field FOffset.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FOffset: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.FOnPointerAdded Field

Summary

Represents field FOnPointerAdded.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FOnPointerAdded: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.FOnUpdateVirtualLines Field

Summary

Represents field FOnUpdateVirtualLines.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FOnUpdateVirtualLines: TfrxUpdateVirtualLines;

Field Value

Type: TfrxUpdateVirtualLines

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.FPosition Field

Summary

Represents field FPosition.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FPosition: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.FScale Field

Summary

Represents field FScale.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FScale: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.FSize Field

Summary

Represents field FSize.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.FStart Field

Summary

Represents field FStart.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FStart: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.FUnits Field

Summary

Represents field FUnits.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FUnits: TfrxRulerUnits;

Field Value

Type: TfrxRulerUnits

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxRuler.FVirtualGuid Field

Summary

Represents field FVirtualGuid.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FVirtualGuid: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRuler
  • frxDesgnCtrls


TfrxScrollBox Class

Summary

Represents type TfrxScrollBox.

Namespace: frxDesgnCtrls
Inheritance Hierarchy
TScrollBox
frxDesgnCtrls.TfrxScrollBox
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxScrollBox = class(TScrollBox)
 end;

The TfrxScrollBox type exposes the following members.

Methods
Show:
Name | Description
KeyDown(Word,TShiftState) | Represents method KeyDown(Word,TShiftState).
KeyPress(Char) | Represents method KeyPress(Char).
KeyUp(Word,TShiftState) | Represents method KeyUp(Word,TShiftState).
WMGetDlgCode(TWMGetDlgCode) | Represents method WMGetDlgCode(TWMGetDlgCode).
Top
See Also

Reference

  • frxDesgnCtrls


TfrxScrollBox Methods

Methods
Name | Description
KeyDown(Word,TShiftState) | Represents method KeyDown(Word,TShiftState).
KeyPress(Char) | Represents method KeyPress(Char).
KeyUp(Word,TShiftState) | Represents method KeyUp(Word,TShiftState).
WMGetDlgCode(TWMGetDlgCode) | Represents method WMGetDlgCode(TWMGetDlgCode).
Top


TfrxScrollBox.KeyDown(Word,TShiftState) Method

Summary

Represents method KeyDown(Word,TShiftState).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure KeyDown(var Key: Word; Shift: TShiftState); override;

Parameters

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxScrollBox
  • frxDesgnCtrls


TfrxScrollBox.KeyPress(Char) Method

Summary

Represents method KeyPress(Char).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure KeyPress(var Key: Char); override;

Parameters

Key
Type: Char

See Also

Reference

  • TfrxScrollBox
  • frxDesgnCtrls


TfrxScrollBox.KeyUp(Word,TShiftState) Method

Summary

Represents method KeyUp(Word,TShiftState).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure KeyUp(var Key: Word; Shift: TShiftState); override;

Parameters

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxScrollBox
  • frxDesgnCtrls


TfrxScrollBox.WMGetDlgCode(TWMGetDlgCode) Method

Summary

Represents method WMGetDlgCode(TWMGetDlgCode).

Namespace: frxDesgnCtrls
Syntax
Delphi
protected
 procedure WMGetDlgCode(var Message: TWMGetDlgCode); message WM_GETDLGCODE;

Parameters

Message
Type: TWMGetDlgCode

See Also

Reference

  • TfrxScrollBox
  • frxDesgnCtrls


TfrxUndoBuffer Class

Summary

Represents type TfrxUndoBuffer.

Namespace: frxDesgnCtrls
Inheritance Hierarchy
TObject
frxDesgnCtrls.TfrxUndoBuffer
Syntax
Delphi
type
 TfrxUndoBuffer = class(TObject)
 end;

The TfrxUndoBuffer type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxUndoBuffer class.
Destroy | Represents the destructor of the TfrxUndoBuffer class.
Top
Properties
Show:
Name | Description
PictureCache | Represents property PictureCache.
RedoCount | Represents property RedoCount.
UndoCount | Represents property UndoCount.
Top
Methods
Show:
Name | Description
AddRedo(TfrxComponent) | Represents method AddRedo(TfrxComponent).
AddUndo(TfrxComponent) | Represents method AddUndo(TfrxComponent).
ClearRedo | Represents method ClearRedo.
ClearUndo | Represents method ClearUndo.
GetRedo(TfrxComponent) | Represents method GetRedo(TfrxComponent).
GetRedoCount | Represents method GetRedoCount.
GetUndo(TfrxComponent) | Represents method GetUndo(TfrxComponent).
GetUndoCount | Represents method GetUndoCount.
RemoveLastUndo | Represents method RemoveLastUndo.
SetPictureFlag(TfrxComponent,Boolean) | Represents method SetPictureFlag(TfrxComponent,Boolean).
SetPictures(TfrxComponent) | Represents method SetPictures(TfrxComponent).
Top
Fields
Show:
Name | Description
FPictureCache | Represents field FPictureCache.
FRedo | Represents field FRedo.
FUndo | Represents field FUndo.
Top
See Also

Reference

  • frxDesgnCtrls


TfrxUndoBuffer Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxUndoBuffer class.
Destroy | Represents the destructor of the TfrxUndoBuffer class.
Top


TfrxUndoBuffer.Create Constructor

Summary

Initializes a new instance of the TfrxUndoBuffer class.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.Destroy Destructor

Summary

Represents the destructor of the TfrxUndoBuffer class.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer Properties

Properties
Name | Description
PictureCache | Represents property PictureCache.
RedoCount | Represents property RedoCount.
UndoCount | Represents property UndoCount.
Top


TfrxUndoBuffer.PictureCache Property

Summary

Represents property PictureCache.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property PictureCache: TfrxPictureCache read FPictureCache write FPictureCache;

Property Value

Type: TfrxPictureCache

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.RedoCount Property

Summary

Represents property RedoCount.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property RedoCount: Integer read GetRedoCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.UndoCount Property

Summary

Represents property UndoCount.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 property UndoCount: Integer read GetUndoCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer Methods

Methods
Name | Description
AddRedo(TfrxComponent) | Represents method AddRedo(TfrxComponent).
AddUndo(TfrxComponent) | Represents method AddUndo(TfrxComponent).
ClearRedo | Represents method ClearRedo.
ClearUndo | Represents method ClearUndo.
GetRedo(TfrxComponent) | Represents method GetRedo(TfrxComponent).
GetRedoCount | Represents method GetRedoCount.
GetUndo(TfrxComponent) | Represents method GetUndo(TfrxComponent).
GetUndoCount | Represents method GetUndoCount.
RemoveLastUndo | Represents method RemoveLastUndo.
SetPictureFlag(TfrxComponent,Boolean) | Represents method SetPictureFlag(TfrxComponent,Boolean).
SetPictures(TfrxComponent) | Represents method SetPictures(TfrxComponent).
Top


TfrxUndoBuffer.AddRedo(TfrxComponent) Method

Summary

Represents method AddRedo(TfrxComponent).

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure AddRedo(ReportComponent: TfrxComponent);

Parameters

ReportComponent
Type: TfrxComponent

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.AddUndo(TfrxComponent) Method

Summary

Represents method AddUndo(TfrxComponent).

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure AddUndo(ReportComponent: TfrxComponent);

Parameters

ReportComponent
Type: TfrxComponent

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.ClearRedo Method

Summary

Represents method ClearRedo.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure ClearRedo;
See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.ClearUndo Method

Summary

Represents method ClearUndo.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure ClearUndo;
See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.GetRedo(TfrxComponent) Method

Summary

Represents method GetRedo(TfrxComponent).

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure GetRedo(ReportComponent: TfrxComponent);

Parameters

ReportComponent
Type: TfrxComponent

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.GetRedoCount Method

Summary

Represents method GetRedoCount.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 function GetRedoCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.GetUndo(TfrxComponent) Method

Summary

Represents method GetUndo(TfrxComponent).

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure GetUndo(ReportComponent: TfrxComponent);

Parameters

ReportComponent
Type: TfrxComponent

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.GetUndoCount Method

Summary

Represents method GetUndoCount.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 function GetUndoCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.RemoveLastUndo Method

Summary

Represents method RemoveLastUndo.

Namespace: frxDesgnCtrls
Syntax
Delphi
public
 procedure RemoveLastUndo;
See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.SetPictureFlag(TfrxComponent,Boolean) Method

Summary

Represents method SetPictureFlag(TfrxComponent,Boolean).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure SetPictureFlag(ReportComponent: TfrxComponent; Flag: Boolean);

Parameters

ReportComponent
Type: TfrxComponent

Flag
Type: Boolean

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.SetPictures(TfrxComponent) Method

Summary

Represents method SetPictures(TfrxComponent).

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 procedure SetPictures(ReportComponent: TfrxComponent);

Parameters

ReportComponent
Type: TfrxComponent

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer Fields

Fields
Name | Description
FPictureCache | Represents field FPictureCache.
FRedo | Represents field FRedo.
FUndo | Represents field FUndo.
Top


TfrxUndoBuffer.FPictureCache Field

Summary

Represents field FPictureCache.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FPictureCache: TfrxPictureCache;

Field Value

Type: TfrxPictureCache

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.FRedo Field

Summary

Represents field FRedo.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FRedo: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


TfrxUndoBuffer.FUndo Field

Summary

Represents field FUndo.

Namespace: frxDesgnCtrls
Syntax
Delphi
private
 FUndo: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxUndoBuffer
  • frxDesgnCtrls


frxDesgnCtrls Enumerations

Enumerations
Name | Description
TfrxRulerUnits | Represents type TfrxRulerUnits.
Top


TfrxRulerUnits Enumeration

Summary

Represents type TfrxRulerUnits.

Namespace: frxDesgnCtrls
Syntax
Delphi
type
 TfrxRulerUnits = (ruCM, ruInches, ruPixels, ruChars);

The TfrxRulerUnits type exposes the following members.

Members
Show:
Name | Description
ruChars | Represents constant ruChars.
ruCM | Represents constant ruCM.
ruInches | Represents constant ruInches.
ruPixels | Represents constant ruPixels.
Top
See Also

Reference

  • frxDesgnCtrls


frxDesgnCtrls Delegates

Delegates
Name | Description
TfrxFrameLineClickedEvent | Represents type TfrxFrameLineClickedEvent.
TfrxUpdateVirtualLines | Represents type TfrxUpdateVirtualLines.
Top


TfrxFrameLineClickedEvent Delegate

Summary

Represents type TfrxFrameLineClickedEvent.

Namespace: frxDesgnCtrls
Syntax
Delphi
type
 TfrxFrameLineClickedEvent = procedure(Line: TfrxFrameType; state: Boolean) of object;
See Also

Reference

  • frxDesgnCtrls


TfrxUpdateVirtualLines Delegate

Summary

Represents type TfrxUpdateVirtualLines.

Namespace: frxDesgnCtrls
Syntax
Delphi
type
 TfrxUpdateVirtualLines = procedure (Sender: TObject; Position: Extended) of object;
See Also

Reference

  • frxDesgnCtrls


frxDesgnCtrls Constants

Constants
Name | Description
ClipboardPrefix | Represents constant ClipboardPrefix.
Top


ClipboardPrefix Constant

Summary

Represents constant ClipboardPrefix.

Namespace: frxDesgnCtrls
Syntax
Delphi
 ClipboardPrefix: String = '#FR3 clipboard#';

Value

Type: String

See Also

Reference

  • frxDesgnCtrls


frxDesgnEditors Namespace

Summary

Represents namespace frxDesgnEditors.


frxDialogForm Namespace

Summary

Represents namespace frxDialogForm.

Classes
Name | Description
TfrxDialogForm | Represents type TfrxDialogForm.
Top


frxDialogForm Classes

Classes
Name | Description
TfrxDialogForm | Represents type TfrxDialogForm.
Top


TfrxDialogForm Class

Summary

Represents type TfrxDialogForm.

Namespace: frxDialogForm
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxDialogForm.TfrxDialogForm
Syntax
Delphi
type
 TfrxDialogForm = class(TfrxBaseForm)
 end;

The TfrxDialogForm type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDialogForm class. (Overrides TfrxBaseForm.Create(TComponent).)
Top
Properties
Show:
Name | Description
CurrentFormPPI | Returns current PPI value of the form. (Inherited from TfrxBaseForm.)
IsPPIChanging | Represents property IsPPIChanging. (Inherited from TfrxBaseForm.)
OnModify | Represents property OnModify.
ThreadSafe | Represents property ThreadSafe.
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseForm.)
AfterPPIChange | Represents method AfterPPIChange. (Inherited from TfrxBaseForm.)
AfterPPIMessage | Represents method AfterPPIMessage. (Inherited from TfrxBaseForm.)
BeforeDestruction | Represents method BeforeDestruction. (Inherited from TfrxBaseForm.)
BeforePPIChange | Represents method BeforePPIChange. (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer). (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean). (Inherited from TfrxBaseForm.)
CreateHandle | Represents method CreateHandle.
CreateWnd | Represents method CreateWnd.
DestroyWindowHandle | Represents method DestroyWindowHandle.
DestroyWnd | Represents method DestroyWnd.
DoClose(TCloseAction) | Represents method DoClose(TCloseAction). (Inherited from TfrxBaseForm.)
DoCreateHandle | Represents method DoCreateHandle.
DoCreateWnd | Represents method DoCreateWnd.
DoDestroyWindowHandle | Represents method DoDestroyWindowHandle.
DoDestroyWnd | Represents method DoDestroyWnd.
DoShow | Represents method DoShow. (Inherited from TfrxBaseForm.)
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer). (Inherited from TfrxBaseForm.)
FormCloseQuery(TObject,Boolean) | Represents method FormCloseQuery(TObject,Boolean).
FormShowAfterLoad | Represents method FormShowAfterLoad. (Inherited from TfrxBaseForm.)
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Inherited from TfrxBaseForm.)
GetAvailablePreferences | Represents method GetAvailablePreferences. (Inherited from TfrxBaseForm.)
GetFormSectionName | Represents method GetFormSectionName. (Inherited from TfrxBaseForm.)
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Inherited from TfrxBaseForm.)
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Inherited from TfrxBaseForm.)
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter. (Inherited from TfrxBaseForm.)
ReadState(TReader) | Represents method ReadState(TReader).
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Inherited from TfrxBaseForm.)
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxBaseForm.)
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms. (Inherited from TfrxBaseForm.)
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form. (Inherited from TfrxBaseForm.)
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Overrides TfrxBaseForm.UpdateFormPPI(Integer).)
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Inherited from TfrxBaseForm.)
WMExitSizeMove(TMessage) | Represents method WMExitSizeMove(TMessage).
WMGetDlgCode(TWMGetDlgCode) | Represents method WMGetDlgCode(TWMGetDlgCode).
Top
Fields
Show:
Name | Description
FDialogPageControl | Represents field FDialogPageControl.
FHostedControls | Represents field FHostedControls. (Inherited from TfrxBaseForm.)
FOnModify | Represents field FOnModify.
FPrefEvent | Represents field FPrefEvent. (Inherited from TfrxBaseForm.)
FThreadSafe | Represents field FThreadSafe.
Top
See Also

Reference

  • frxDialogForm


TfrxDialogForm Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDialogForm class. (Overrides TfrxBaseForm.Create(TComponent).)
Top


TfrxDialogForm.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDialogForm class.

Namespace: frxDialogForm
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxBaseForm.Create(TComponent)
See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm Properties

Properties
Name | Description
OnModify | Represents property OnModify.
ThreadSafe | Represents property ThreadSafe.
Top


TfrxDialogForm.OnModify Property

Summary

Represents property OnModify.

Namespace: frxDialogForm
Syntax
Delphi
public
 property OnModify: TNotifyEvent read FOnModify write FOnModify;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.ThreadSafe Property

Summary

Represents property ThreadSafe.

Namespace: frxDialogForm
Syntax
Delphi
public
 property ThreadSafe: Boolean read FThreadSafe write FThreadSafe;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm Methods

Methods
Name | Description
CreateHandle | Represents method CreateHandle.
CreateWnd | Represents method CreateWnd.
DestroyWindowHandle | Represents method DestroyWindowHandle.
DestroyWnd | Represents method DestroyWnd.
DoCreateHandle | Represents method DoCreateHandle.
DoCreateWnd | Represents method DoCreateWnd.
DoDestroyWindowHandle | Represents method DoDestroyWindowHandle.
DoDestroyWnd | Represents method DoDestroyWnd.
FormCloseQuery(TObject,Boolean) | Represents method FormCloseQuery(TObject,Boolean).
ReadState(TReader) | Represents method ReadState(TReader).
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Overrides TfrxBaseForm.UpdateFormPPI(Integer).)
WMExitSizeMove(TMessage) | Represents method WMExitSizeMove(TMessage).
WMGetDlgCode(TWMGetDlgCode) | Represents method WMGetDlgCode(TWMGetDlgCode).
Top


TfrxDialogForm.CreateHandle Method

Summary

Represents method CreateHandle.

Namespace: frxDialogForm
Syntax
Delphi
protected
 procedure CreateHandle; override;
See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.CreateWnd Method

Summary

Represents method CreateWnd.

Namespace: frxDialogForm
Syntax
Delphi
protected
 procedure CreateWnd; override;
See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.DestroyWindowHandle Method

Summary

Represents method DestroyWindowHandle.

Namespace: frxDialogForm
Syntax
Delphi
protected
 procedure DestroyWindowHandle; override;
See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.DestroyWnd Method

Summary

Represents method DestroyWnd.

Namespace: frxDialogForm
Syntax
Delphi
protected
 procedure DestroyWnd; override;
See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.DoCreateHandle Method

Summary

Represents method DoCreateHandle.

Namespace: frxDialogForm
Syntax
Delphi
published
 procedure DoCreateHandle;
See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.DoCreateWnd Method

Summary

Represents method DoCreateWnd.

Namespace: frxDialogForm
Syntax
Delphi
published
 procedure DoCreateWnd;
See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.DoDestroyWindowHandle Method

Summary

Represents method DoDestroyWindowHandle.

Namespace: frxDialogForm
Syntax
Delphi
published
 procedure DoDestroyWindowHandle;
See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.DoDestroyWnd Method

Summary

Represents method DoDestroyWnd.

Namespace: frxDialogForm
Syntax
Delphi
published
 procedure DoDestroyWnd;
See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.FormCloseQuery(TObject,Boolean) Method

Summary

Represents method FormCloseQuery(TObject,Boolean).

Namespace: frxDialogForm
Syntax
Delphi
published
 procedure FormCloseQuery(Sender: TObject; var CanClose: Boolean);

Parameters

Sender
Type: TObject

CanClose
Type: Boolean

See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.ReadState(TReader) Method

Summary

Represents method ReadState(TReader).

Namespace: frxDialogForm
Syntax
Delphi
protected
 procedure ReadState(Reader: TReader); override;

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.UpdateFormPPI(Integer) Method

Summary

Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method.

Namespace: frxDialogForm
Syntax
Delphi
public
 procedure UpdateFormPPI(aNewPPI: Integer); override;

Parameters

aNewPPI
Type: Integer

New PPI value.

Overrides

TfrxBaseForm.UpdateFormPPI(Integer)
See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.WMExitSizeMove(TMessage) Method

Summary

Represents method WMExitSizeMove(TMessage).

Namespace: frxDialogForm
Syntax
Delphi
private
 procedure WMExitSizeMove(var Msg: TMessage); message WM_EXITSIZEMOVE;

Parameters

Msg
Type: TMessage

See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.WMGetDlgCode(TWMGetDlgCode) Method

Summary

Represents method WMGetDlgCode(TWMGetDlgCode).

Namespace: frxDialogForm
Syntax
Delphi
private
 procedure WMGetDlgCode(var Message: TWMGetDlgCode); message WM_GETDLGCODE;

Parameters

Message
Type: TWMGetDlgCode

See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm Fields

Fields
Name | Description
FDialogPageControl | Represents field FDialogPageControl.
FOnModify | Represents field FOnModify.
FThreadSafe | Represents field FThreadSafe.
Top


TfrxDialogForm.FDialogPageControl Field

Summary

Represents field FDialogPageControl.

Namespace: frxDialogForm
Syntax
Delphi
private
 FDialogPageControl: TComponent;

Field Value

Type: TComponent

See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.FOnModify Field

Summary

Represents field FOnModify.

Namespace: frxDialogForm
Syntax
Delphi
private
 FOnModify: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


TfrxDialogForm.FThreadSafe Field

Summary

Represents field FThreadSafe.

Namespace: frxDialogForm
Syntax
Delphi
private
 FThreadSafe: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDialogForm
  • frxDialogForm


frxDMPClass Namespace

Summary

Represents namespace frxDMPClass.

Classes
Name | Description
TfrxDMPCommand | The TfrxDMPCommand component can execute an ESC command in the dot-matrix mode.
TfrxDMPLineView | The TfrxDMPLineView is similar to TfrxLineView, but is intended for dot-matrix mode.
TfrxDMPMemoView | The TfrxDMPMemoView is similar to TfrxMemoView, but is intended for dot-matrix mode.
TfrxDMPPage | The TfrxDMPPage is similar to TfrxReportPage, but is intended for dot-matrix mode.
Top
Enumerations
Name | Description
TfrxDMPFontStyle | Dot-matrix font style.
Top
Types
Name | Description
TfrxDMPFontStyles | Represents type TfrxDMPFontStyles.
Top


frxDMPClass Classes

Classes
Name | Description
TfrxDMPCommand | The TfrxDMPCommand component can execute an ESC command in the dot-matrix mode.
TfrxDMPLineView | The TfrxDMPLineView is similar to TfrxLineView, but is intended for dot-matrix mode.
TfrxDMPMemoView | The TfrxDMPMemoView is similar to TfrxMemoView, but is intended for dot-matrix mode.
TfrxDMPPage | The TfrxDMPPage is similar to TfrxReportPage, but is intended for dot-matrix mode.
Top


TfrxDMPCommand Class

Summary

The TfrxDMPCommand component can execute an ESC command in the dot-matrix mode.

Namespace: frxDMPClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxDMPClass.TfrxDMPCommand
Syntax
Delphi
type
 TfrxDMPCommand = class(TfrxView)
 end;

The TfrxDMPCommand type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxView class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
Command | The ESC command. You can use two formats of command: 1B40 or #27#64.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Object's cursor (in the preview mode). (Inherited from TfrxView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Object's frame. (Inherited from TfrxView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxReportComponent.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
ToChr | Represents method ToChr.
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FCommand | Represents field FCommand.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxDMPClass


TfrxDMPCommand Properties

Properties
Name | Description
Command | The ESC command. You can use two formats of command: 1B40 or #27#64.
Top


TfrxDMPCommand.Command Property

Summary

The ESC command. You can use two formats of command: 1B40 or #27#64.

Namespace: frxDMPClass
Syntax
Delphi
published
 property Command: String read FCommand write FCommand;

Property Value

Type: String

See Also

Reference

  • TfrxDMPCommand
  • frxDMPClass


TfrxDMPCommand Methods

Methods
Name | Description
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
ToChr | Represents method ToChr.
Top


TfrxDMPCommand.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDMPClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxDMPCommand
  • frxDMPClass


TfrxDMPCommand.SetLeft(Extended) Method

Summary

Represents method SetLeft(Extended).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetLeft(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetLeft(Extended)
See Also

Reference

  • TfrxDMPCommand
  • frxDMPClass


TfrxDMPCommand.SetTop(Extended) Method

Summary

Represents method SetTop(Extended).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetTop(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetTop(Extended)
See Also

Reference

  • TfrxDMPCommand
  • frxDMPClass


TfrxDMPCommand.ToChr Method

Summary

Represents method ToChr.

Namespace: frxDMPClass
Syntax
Delphi
public
 function ToChr: String;

Return Value

Type: String

See Also

Reference

  • TfrxDMPCommand
  • frxDMPClass


TfrxDMPCommand Fields

Fields
Name | Description
FCommand | Represents field FCommand.
Top


TfrxDMPCommand.FCommand Field

Summary

Represents field FCommand.

Namespace: frxDMPClass
Syntax
Delphi
private
 FCommand: String;

Field Value

Type: String

See Also

Reference

  • TfrxDMPCommand
  • frxDMPClass


TfrxDMPLineView Class

Summary

The TfrxDMPLineView is similar to TfrxLineView, but is intended for dot-matrix mode.

Namespace: frxDMPClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxClass.TfrxCustomLineView
frxDMPClass.TfrxDMPLineView
Syntax
Delphi
type
 TfrxDMPLineView = class(TfrxCustomLineView)
 end;

The TfrxDMPLineView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomLineView class. (Overrides TfrxStretcheable.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Overrides TfrxComponent.DesignCreate(TComponent,Word).)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
ArrowEnd | Determines whether to draw an arrow in the end of line. (Inherited from TfrxCustomLineView.)
ArrowLength | The length of arrow. (Inherited from TfrxCustomLineView.)
ArrowSolid | Determines whether to draw a solid arrow. (Inherited from TfrxCustomLineView.)
ArrowStart | Determines if an arrow is used at the start and end of the line. (Inherited from TfrxCustomLineView.)
ArrowWidth | The width of arrow. (Inherited from TfrxCustomLineView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
CanShrink | True if object can shrink height base on its content. (Inherited from TfrxStretcheable.)
Color | Color of the shape. (Inherited from TfrxCustomLineView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Object's cursor (in the preview mode). (Inherited from TfrxView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Diagonal | Determines if the line is diagonal. (Inherited from TfrxCustomLineView.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
Font | Object's font. (Inherited from TfrxComponent.)
FontStyle | Dot-matrix font style.
Frame | Object's frame. (Inherited from TfrxView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont.
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StretchMode | Object's stretch mode. (Inherited from TfrxStretcheable.)
TagStr | Represents property TagStr. (Inherited from TfrxCustomLineView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Inherited from TfrxStretcheable.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable. (Inherited from TfrxStretcheable.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxReportComponent.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Overrides TfrxView.GetVectorGraphic(Boolean).)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Inherited from TfrxStretcheable.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object. (Inherited from TfrxStretcheable.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsFontStyleStored | Represents method IsFontStyleStored.
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Overrides TfrxComponent.IsInRect(TfrxRect).)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetFontStyle(TfrxDMPFontStyles) | Represents method SetFontStyle(TfrxDMPFontStyles).
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFontStyle | Represents field FFontStyle.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FSavedTop | Internal use only. Stores original top during shift operation. (Inherited from TfrxStretcheable.)
FSaveHeight | Internal use only. Stores object Height during stretch operation. (Inherited from TfrxStretcheable.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxDMPClass


TfrxDMPLineView Properties

Properties
Name | Description
FontStyle | Dot-matrix font style.
ParentFont | Represents property ParentFont.
Top


TfrxDMPLineView.FontStyle Property

Summary

Dot-matrix font style.

Namespace: frxDMPClass
Syntax
Delphi
published
 property FontStyle: TfrxDMPFontStyles read FFontStyle write SetFontStyle
 stored IsFontStyleStored;

Property Value

Type: TfrxDMPFontStyles

See Also

Reference

  • TfrxDMPLineView
  • frxDMPClass


TfrxDMPLineView.ParentFont Property

Summary

Represents property ParentFont.

Namespace: frxDMPClass
Syntax
Delphi
published
 property ParentFont;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPLineView
  • frxDMPClass


TfrxDMPLineView Methods

Methods
Name | Description
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
IsFontStyleStored | Represents method IsFontStyleStored.
SetFontStyle(TfrxDMPFontStyles) | Represents method SetFontStyle(TfrxDMPFontStyles).
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
Top


TfrxDMPLineView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDMPClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxDMPLineView
  • frxDMPClass


TfrxDMPLineView.IsFontStyleStored Method

Summary

Represents method IsFontStyleStored.

Namespace: frxDMPClass
Syntax
Delphi
private
 function IsFontStyleStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDMPLineView
  • frxDMPClass


TfrxDMPLineView.SetFontStyle(TfrxDMPFontStyles) Method

Summary

Represents method SetFontStyle(TfrxDMPFontStyles).

Namespace: frxDMPClass
Syntax
Delphi
private
 procedure SetFontStyle(const Value: TfrxDMPFontStyles);

Parameters

Value
Type: TfrxDMPFontStyles

See Also

Reference

  • TfrxDMPLineView
  • frxDMPClass


TfrxDMPLineView.SetLeft(Extended) Method

Summary

Represents method SetLeft(Extended).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetLeft(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetLeft(Extended)
See Also

Reference

  • TfrxDMPLineView
  • frxDMPClass


TfrxDMPLineView.SetParentFont(Boolean) Method

Summary

Represents method SetParentFont(Boolean).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetParentFont(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TfrxComponent.SetParentFont(Boolean)
See Also

Reference

  • TfrxDMPLineView
  • frxDMPClass


TfrxDMPLineView.SetTop(Extended) Method

Summary

Represents method SetTop(Extended).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetTop(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetTop(Extended)
See Also

Reference

  • TfrxDMPLineView
  • frxDMPClass


TfrxDMPLineView.SetWidth(Extended) Method

Summary

Represents method SetWidth(Extended).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetWidth(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetWidth(Extended)
See Also

Reference

  • TfrxDMPLineView
  • frxDMPClass


TfrxDMPLineView Fields

Fields
Name | Description
FFontStyle | Represents field FFontStyle.
Top


TfrxDMPLineView.FFontStyle Field

Summary

Represents field FFontStyle.

Namespace: frxDMPClass
Syntax
Delphi
private
 FFontStyle: TfrxDMPFontStyles;

Field Value

Type: TfrxDMPFontStyles

See Also

Reference

  • TfrxDMPLineView
  • frxDMPClass


TfrxDMPMemoView Class

Summary

The TfrxDMPMemoView is similar to TfrxMemoView, but is intended for dot-matrix mode.

Namespace: frxDMPClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxClass.TfrxCustomMemoView
frxDMPClass.TfrxDMPMemoView
Syntax
Delphi
type
 TfrxDMPMemoView = class(TfrxCustomMemoView)
 end;

The TfrxDMPMemoView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDMPMemoView class. (Overrides TfrxCustomMemoView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowExpressions | Represents property AllowExpressions.
AllowHTMLTags | Determines if the object may contain HTML-tags inside the text. The following tags are supported: <b> - bold; <i> - italic; <u> - underline; <sub> - bottom index; <sup> - top index; <font color> - font color. Default value is False. (Inherited from TfrxCustomMemoView.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
AnsiText | Text of the object in ANSI format based on current Locale settings. (Inherited from TfrxCustomMemoView.)
AutoWidth | Represents property AutoWidth.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
CanShrink | True if object can shrink height base on its content. (Inherited from TfrxStretcheable.)
CharSpacing | Character spacing, in pixels. Default value is 0. (Inherited from TfrxCustomMemoView.)
Clipped | Determines whether to clip the text on object's bounds. (Inherited from TfrxCustomMemoView.)
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor. (Inherited from TfrxCustomMemoView.)
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DisplayFormat | Represents property DisplayFormat.
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Duplicates | Determines how to process repeated values. Default value is dmShow. (Inherited from TfrxCustomMemoView.)
ExpressionDelimiters | Represents property ExpressionDelimiters.
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
FirstParaBreak | Internal use. Determines first paragraph break if object where split. (Inherited from TfrxCustomMemoView.)
FlowTo | Represents property FlowTo.
Font | Object's font. (Inherited from TfrxComponent.)
FontStyle | Dot-matrix font style.
Formats | Collection of Formats. The object can hold several formats for each expression inside an object. (Inherited from TfrxCustomMemoView.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GapX | Gap between text and left and right edges of object, in pixels. Default value is 2. (Inherited from TfrxCustomMemoView.)
GapY | Gap between text and top and bottom edges of object, in pixels. Default value is 1. (Inherited from TfrxCustomMemoView.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
HAlign | Represents property HAlign.
Height | Represents property Height. (Inherited from TfrxView.)
HideZeros | Represents property HideZeros.
Highlight | Deprecated(see Highlights property). Conditional highlight settings. The hightlight allows changing the appearance of the object depending on some condition. (Inherited from TfrxCustomMemoView.)
Highlights | Collection of Highlights. The object can hold several highlights which serves different conditions. (Inherited from TfrxCustomMemoView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LastParaBreak | Internal use. Determines last paragraph break if object where split. (Inherited from TfrxCustomMemoView.)
Left | Represents property Left. (Inherited from TfrxView.)
Lines | Text lines of the object. (Inherited from TfrxCustomMemoView.)
LineSpacing | Spacing between text lines, in pixels. Default value is 2. (Inherited from TfrxCustomMemoView.)
Memo | Represents property Memo.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
ParagraphGap | Paragraph gap, in pixels. Default value is 0. (Inherited from TfrxCustomMemoView.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont.
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
Rotation | Determines the text rotation, in degrees. Valid values are 0..360. (Inherited from TfrxCustomMemoView.)
RTLReading | Represents property RTLReading.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StretchMode | Object's stretch mode. (Inherited from TfrxStretcheable.)
Style | Name of the object's style. Styles are stored in the TfrxReport.Styles. (Inherited from TfrxCustomMemoView.)
SuppressRepeated | Represents property SuppressRepeated.
TagStr | Represents property TagStr. (Inherited from TfrxCustomMemoView.)
Text | Text of the object. (Inherited from TfrxCustomMemoView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
TruncOutboundText | It is used for cutting a text exceeding the bounds of objects if words transfer function is switched off.
Underlines | Deprecated(See UnderlinesTextMode property). Determines whether to show underlines under each text string. Default value is False. (Inherited from TfrxCustomMemoView.)
UnderlinesTextMode | Determines how to show underlines in text object. Default value is ulmNone. (Inherited from TfrxCustomMemoView.)
URL | Represents property URL. (Inherited from TfrxCustomMemoView.)
UseDefaultCharset | Use Unicode during export even if Font Charset is selected. (Inherited from TfrxCustomMemoView.)
VAlign | Represents property VAlign.
Value | Stores value of Format operation(for single expression or DataSet only) with respect of its type. (Inherited from TfrxCustomMemoView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
WordBreak | Determines whether to break russian words. Default value is False. (Inherited from TfrxCustomMemoView.)
WordWrap | Represents property WordWrap.
Wysiwyg | Determines whether to use printer canvas to arrange the text more accurately. If set to False, you cannot use the "width align" mode. (Inherited from TfrxCustomMemoView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxView.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
ApplyHighlight(TfrxHighlight) | Apply Highlight to object. (Inherited from TfrxCustomMemoView.)
ApplyPreviewHighlight | Apply active highlight for object in prepared report. (Inherited from TfrxCustomMemoView.)
ApplyStyle(TfrxStyleItem) | Applies the given style to the object. (Inherited from TfrxCustomMemoView.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Overrides TfrxView.BeginDraw(TCanvas,Extended,Extended,Extended,Extended).)
CalcAndFormat(WideString,TfrxFormat) | Represents method CalcAndFormat(WideString,TfrxFormat). (Inherited from TfrxCustomMemoView.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxCustomMemoView.CalcHeight.)
CalcTextRect(Extended,Extended,Extended,Extended) | Represents method CalcTextRect(Extended,Extended,Extended,Extended). (Inherited from TfrxCustomMemoView.)
CalcWidth | Calculates and returns the object's width, in pixels. (Overrides TfrxCustomMemoView.CalcWidth.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxCustomMemoView.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxView.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Overrides TfrxView.DrawFrame.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxStretcheable.DrawPart.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawText | Represents method DrawText. (Inherited from TfrxCustomMemoView.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
ExtractMacros(TfrxPostProcessor) | Extract macros from the object text and replaces them with values. (Inherited from TfrxCustomMemoView.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
FormatData(Variant,TfrxFormat) | Formats the value passed in the "Value" parameter and returns the result as a string. This method is used format settings stored in the DisplayFormat property. If AFormat parameter is set, it is used for formatting instead of DisplayFormat property. (Inherited from TfrxCustomMemoView.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Overrides TfrxReportComponent.GetComponentText.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxCustomMemoView.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetoutBoundText | Represents method GetoutBoundText.
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Inherited from TfrxStretcheable.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object. (Overrides TfrxStretcheable.InitPart.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Overrides TfrxView.IsEMFExportable.)
IsFontStyleStored | Represents method IsFontStyleStored.
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Overrides TfrxView.IsPostProcessAllowed.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
Loaded | Represents method Loaded. (Inherited from TfrxCustomMemoView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxView.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.ReadNestedProperty(TfrxXMLItem).)
ReducedAngle | Normalize angle to 360 degrees. (Inherited from TfrxCustomMemoView.)
ResetFontOptions | Represents method ResetFontOptions.
ResetSuppress | Deprecated. Reset suppressed values. (Inherited from TfrxCustomMemoView.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetBoundsDirect(Extended,Extended,Extended,Extended) | Represents method SetBoundsDirect(Extended,Extended,Extended,Extended).
SetDrawParams(TCanvas,Extended,Extended,Extended,Extended) | Represents method SetDrawParams(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxCustomMemoView.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetFontStyle(TfrxDMPFontStyles) | Represents method SetFontStyle(TfrxDMPFontStyles).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WrapText(Boolean,TWideStrings) | Breaks the text so all strings would fit in the object's width, and returns the resulting text. (Inherited from TfrxCustomMemoView.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.WriteNestedProperties(TfrxXMLItem,TPersistent).)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCopyNo | Represents field FCopyNo. (Inherited from TfrxCustomMemoView.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFontStyle | Represents field FFontStyle.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLastValue | Represents field FLastValue. (Inherited from TfrxCustomMemoView.)
FMacroIndex | Represents field FMacroIndex. (Inherited from TfrxCustomMemoView.)
FMacroLine | Represents field FMacroLine. (Inherited from TfrxCustomMemoView.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintScale | Represents field FPrintScale. (Inherited from TfrxCustomMemoView.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FSavedTop | Internal use only. Stores original top during shift operation. (Inherited from TfrxStretcheable.)
FSaveHeight | Internal use only. Stores object Height during stretch operation. (Inherited from TfrxStretcheable.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FTextRect | Represents field FTextRect. (Inherited from TfrxCustomMemoView.)
FTotalPages | Represents field FTotalPages. (Inherited from TfrxCustomMemoView.)
FTruncOutboundText | Represents field FTruncOutboundText.
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxDMPClass


TfrxDMPMemoView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDMPMemoView class. (Overrides TfrxCustomMemoView.Create(TComponent).)
Top


TfrxDMPMemoView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDMPMemoView class.

Namespace: frxDMPClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomMemoView.Create(TComponent)
See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView Properties

Properties
Name | Description
AllowExpressions | Represents property AllowExpressions.
AutoWidth | Represents property AutoWidth.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
DisplayFormat | Represents property DisplayFormat.
ExpressionDelimiters | Represents property ExpressionDelimiters.
FlowTo | Represents property FlowTo.
FontStyle | Dot-matrix font style.
Frame | Represents property Frame.
HAlign | Represents property HAlign.
HideZeros | Represents property HideZeros.
Memo | Represents property Memo.
ParentFont | Represents property ParentFont.
RTLReading | Represents property RTLReading.
SuppressRepeated | Represents property SuppressRepeated.
TruncOutboundText | It is used for cutting a text exceeding the bounds of objects if words transfer function is switched off.
VAlign | Represents property VAlign.
WordWrap | Represents property WordWrap.
Top


TfrxDMPMemoView.AllowExpressions Property

Summary

Represents property AllowExpressions.

Namespace: frxDMPClass
Syntax
Delphi
published
 property AllowExpressions;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.AutoWidth Property

Summary

Represents property AutoWidth.

Namespace: frxDMPClass
Syntax
Delphi
published
 property AutoWidth;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.DataField Property

Summary

Represents property DataField.

Namespace: frxDMPClass
Syntax
Delphi
published
 property DataField;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.DataSet Property

Summary

Represents property DataSet.

Namespace: frxDMPClass
Syntax
Delphi
published
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxDMPClass
Syntax
Delphi
published
 property DataSetName;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.DisplayFormat Property

Summary

Represents property DisplayFormat.

Namespace: frxDMPClass
Syntax
Delphi
published
 property DisplayFormat;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.ExpressionDelimiters Property

Summary

Represents property ExpressionDelimiters.

Namespace: frxDMPClass
Syntax
Delphi
published
 property ExpressionDelimiters;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.FlowTo Property

Summary

Represents property FlowTo.

Namespace: frxDMPClass
Syntax
Delphi
published
 property FlowTo;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.FontStyle Property

Summary

Dot-matrix font style.

Namespace: frxDMPClass
Syntax
Delphi
published
 property FontStyle: TfrxDMPFontStyles read FFontStyle write SetFontStyle
 stored IsFontStyleStored;

Property Value

Type: TfrxDMPFontStyles

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.Frame Property

Summary

Represents property Frame.

Namespace: frxDMPClass
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.HAlign Property

Summary

Represents property HAlign.

Namespace: frxDMPClass
Syntax
Delphi
published
 property HAlign;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.HideZeros Property

Summary

Represents property HideZeros.

Namespace: frxDMPClass
Syntax
Delphi
published
 property HideZeros;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.Memo Property

Summary

Represents property Memo.

Namespace: frxDMPClass
Syntax
Delphi
published
 property Memo;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.ParentFont Property

Summary

Represents property ParentFont.

Namespace: frxDMPClass
Syntax
Delphi
published
 property ParentFont;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.RTLReading Property

Summary

Represents property RTLReading.

Namespace: frxDMPClass
Syntax
Delphi
published
 property RTLReading;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.SuppressRepeated Property

Summary

Represents property SuppressRepeated.

Namespace: frxDMPClass
Syntax
Delphi
published
 property SuppressRepeated;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.TruncOutboundText Property

Summary

It is used for cutting a text exceeding the bounds of objects if words transfer function is switched off.

Namespace: frxDMPClass
Syntax
Delphi
published
 property TruncOutboundText: Boolean read FTruncOutboundText write FTruncOutboundText;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.VAlign Property

Summary

Represents property VAlign.

Namespace: frxDMPClass
Syntax
Delphi
published
 property VAlign;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.WordWrap Property

Summary

Represents property WordWrap.

Namespace: frxDMPClass
Syntax
Delphi
published
 property WordWrap;

Property Value

Type: Void

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView Methods

Methods
Name | Description
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxCustomMemoView.CalcHeight.)
CalcWidth | Calculates and returns the object's width, in pixels. (Overrides TfrxCustomMemoView.CalcWidth.)
DrawFrame | Represents method DrawFrame. (Overrides TfrxView.DrawFrame.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxCustomMemoView.GetDescription.)
GetoutBoundText | Represents method GetoutBoundText.
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Overrides TfrxView.IsEMFExportable.)
IsFontStyleStored | Represents method IsFontStyleStored.
ResetFontOptions | Represents method ResetFontOptions.
SetBoundsDirect(Extended,Extended,Extended,Extended) | Represents method SetBoundsDirect(Extended,Extended,Extended,Extended).
SetFontStyle(TfrxDMPFontStyles) | Represents method SetFontStyle(TfrxDMPFontStyles).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
Top


TfrxDMPMemoView.CalcHeight Method

Summary

Calculates and returns the object's height according to the data placed in it.

Namespace: frxDMPClass
Syntax
Delphi
public
 function CalcHeight: Extended; override;

Return Value

Type: Extended

Overrides

TfrxCustomMemoView.CalcHeight
See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.CalcWidth Method

Summary

Calculates and returns the object's width, in pixels.

Namespace: frxDMPClass
Syntax
Delphi
public
 function CalcWidth: Extended; override;

Return Value

Type: Extended

Overrides

TfrxCustomMemoView.CalcWidth
See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.DrawFrame Method

Summary

Represents method DrawFrame.

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure DrawFrame; override;

Overrides

TfrxView.DrawFrame
See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxDMPClass
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxCustomMemoView.GetDescription
See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.GetoutBoundText Method

Summary

Represents method GetoutBoundText.

Namespace: frxDMPClass
Syntax
Delphi
public
 function GetoutBoundText: String;

Return Value

Type: String

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.IsEMFExportable Method

Summary

Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported).

Namespace: frxDMPClass
Syntax
Delphi
public
 function IsEMFExportable: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxView.IsEMFExportable
See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.IsFontStyleStored Method

Summary

Represents method IsFontStyleStored.

Namespace: frxDMPClass
Syntax
Delphi
private
 function IsFontStyleStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.ResetFontOptions Method

Summary

Represents method ResetFontOptions.

Namespace: frxDMPClass
Syntax
Delphi
public
 procedure ResetFontOptions;
See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.SetBoundsDirect(Extended,Extended,Extended,Extended) Method

Summary

Represents method SetBoundsDirect(Extended,Extended,Extended,Extended).

Namespace: frxDMPClass
Syntax
Delphi
public
 procedure SetBoundsDirect(ALeft, ATop, AWidth, AHeight: Extended);

Parameters

ALeft
Type: Extended

ATop
Type: Extended

AWidth
Type: Extended

AHeight
Type: Extended

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.SetFontStyle(TfrxDMPFontStyles) Method

Summary

Represents method SetFontStyle(TfrxDMPFontStyles).

Namespace: frxDMPClass
Syntax
Delphi
private
 procedure SetFontStyle(const Value: TfrxDMPFontStyles);

Parameters

Value
Type: TfrxDMPFontStyles

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.SetHeight(Extended) Method

Summary

Represents method SetHeight(Extended).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetHeight(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetHeight(Extended)
See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.SetLeft(Extended) Method

Summary

Represents method SetLeft(Extended).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetLeft(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetLeft(Extended)
See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.SetParentFont(Boolean) Method

Summary

Represents method SetParentFont(Boolean).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetParentFont(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TfrxComponent.SetParentFont(Boolean)
See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.SetTop(Extended) Method

Summary

Represents method SetTop(Extended).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetTop(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetTop(Extended)
See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.SetWidth(Extended) Method

Summary

Represents method SetWidth(Extended).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetWidth(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetWidth(Extended)
See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView Fields

Fields
Name | Description
FFontStyle | Represents field FFontStyle.
FTruncOutboundText | Represents field FTruncOutboundText.
Top


TfrxDMPMemoView.FFontStyle Field

Summary

Represents field FFontStyle.

Namespace: frxDMPClass
Syntax
Delphi
private
 FFontStyle: TfrxDMPFontStyles;

Field Value

Type: TfrxDMPFontStyles

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPMemoView.FTruncOutboundText Field

Summary

Represents field FTruncOutboundText.

Namespace: frxDMPClass
Syntax
Delphi
private
 FTruncOutboundText: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDMPMemoView
  • frxDMPClass


TfrxDMPPage Class

Summary

The TfrxDMPPage is similar to TfrxReportPage, but is intended for dot-matrix mode.

Namespace: frxDMPClass
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxPage
frxClass.TfrxReportPage
frxDMPClass.TfrxDMPPage
Syntax
Delphi
type
 TfrxDMPPage = class(TfrxReportPage)
 end;

The TfrxDMPPage type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDMPPage class. (Overrides TfrxReportPage.Create(TComponent).)
CreateInPreview(TComponent,TfrxReport) | Overloaded. Constructor used in preview pages/ (Inherited from TfrxReportPage.)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BackPicture | The page's background picture. It is printed on each page. (Inherited from TfrxReportPage.)
BackPicturePrintable | If the property is equal to True, the background page layout will be printed. (Inherited from TfrxReportPage.)
BackPictureStretched | Stretches background picture to page size. (Inherited from TfrxReportPage.)
BackPictureVisible | If the property is equal to True , then the background page layout will be displayed while preview. (Inherited from TfrxReportPage.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Bin | Paper tray for the first report page. One of the DMBIN_XXX values, defined in the Windows.pas file. (Inherited from TfrxReportPage.)
BinOtherPages | Paper tray for report pages, except first page. One of the DMBIN_XXX values, defined in the Windows.pas file. (Inherited from TfrxReportPage.)
BottomMargin | Bottom margin, in millimeters. (Inherited from TfrxReportPage.)
Color | Color of the page. (Inherited from TfrxReportPage.)
ColumnPositions | Column starting positions, in millimeters. (Inherited from TfrxReportPage.)
Columns | Number of columns on a page. If this value is greather than 1, the printing will be performed in several columns. You also should set the column width in the ColumnWidth property. (Inherited from TfrxReportPage.)
ColumnWidth | Width of a column, in millimeters. (Inherited from TfrxReportPage.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
DataSet | Dataset for the report page. If this property is not empty, the page will be printed as many times as there are records in the dataset. (Inherited from TfrxReportPage.)
DataSetName | Name of the dataset for the report page. This property duplicates the DataSet property. (Inherited from TfrxReportPage.)
Description | Object's description. (Inherited from TfrxComponent.)
Duplex | Duplex mode. (Inherited from TfrxReportPage.)
EndlessHeight | If this property is True, the page height will grow depending on number of data records on it. (Inherited from TfrxReportPage.)
EndlessWidth | If this property is True, the page width will grow depending on number of data records on it. (Inherited from TfrxReportPage.)
Font | Represents property Font. (Inherited from TfrxPage.)
FontStyle | Dot-matrix font style.
Frame | Frame of the page. (Inherited from TfrxReportPage.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
HGuides | Horizontal guide lines. Used only in the designer. (Inherited from TfrxReportPage.)
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LargeDesignHeight | If this property is True, the page will have large height in the designer. It is useful if you have many bands in the page. (Inherited from TfrxReportPage.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
LeftMargin | Left margin, in millimeters. (Inherited from TfrxReportPage.)
MirrorMargins | Determines whether is necessary to switch left and right margins when printing even pages. Default value is False. (Inherited from TfrxReportPage.)
MirrorMode | Set of Mirror modes for current page. Determinate how engine align controls and content base on original layout. (Inherited from TfrxReportPage.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterPrint | Name of the script procedure that will be called after printing the page. (Inherited from TfrxReportPage.)
OnBeforePrint | Name of the script procedure that will be called before printing the page. (Inherited from TfrxReportPage.)
OnManualBuild | Name of the script procedure that represents an event handler. If the handler of this event is allocated, then the FastReport engine is blocked and you thus would have to construct a report manually. (Inherited from TfrxReportPage.)
Orientation | The paper orientation. (Inherited from TfrxReportPage.)
OutlineText | "Report outline" object represents the "Report outline" control element in a preview window. This element displays a treelike structure of a finished report. When clicking on any tree node, there is a jump to the page connected to this node. (Inherited from TfrxReportPage.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
PageCount | The count of printed pages is similar to RowCout of the TfrxDataBand. (Inherited from TfrxReportPage.)
PaperHeight | The paper height, in millimeters. (Inherited from TfrxReportPage.)
PaperSize | The paper size. One of the values DMPAPER_xx, defined in the Windows.pas file (for example, DMPAPER_A4). When changing this property, other properties (PaperWidth, PaperHeight) changed too. If you set the DMPAPER_USER paper size, you should set PaperWidth, PaperHeight also. (Inherited from TfrxReportPage.)
PaperWidth | The paper width, in millimeters. (Inherited from TfrxReportPage.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
ParentReport | parent report for current page. (Inherited from TfrxReportPage.)
PrintIfEmpty | Determines whether to print a page if all its databands are connected to empty datasets. Default value is True. (Inherited from TfrxReportPage.)
PrintOnPreviousPage | Allows to print pages, beginning from blank space of the previous page. This option is used when a report template consists of several pages or when printing batch (composite) reports. (Inherited from TfrxReportPage.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
ResetPageNumbers | If this property is True, the report engine reset logical page number when start printing current report template page. (Inherited from TfrxReportPage.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
RightMargin | Right margin, in millimeters. (Inherited from TfrxReportPage.)
ShowTitleOnPreviousPage | Determines whether to print the "Report title" when PrintOnPreviousPage set to true and previous page already has "Report title" band. (Inherited from TfrxReportPage.)
SubReport | Reference to a Subreport object. (Inherited from TfrxReportPage.)
TitleBeforeHeader | Determines whether to print the "Report title" band before "Page header" band. Default value is True. (Inherited from TfrxReportPage.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopMargin | Top margin, in millimeters. (Inherited from TfrxReportPage.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
VGuides | Vertical guide lines. Used only in the designer. (Inherited from TfrxReportPage.)
Visible | Represents property Visible. (Inherited from TfrxPage.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Overrides TfrxComponent.AlignChildren(Boolean,TfrxMirrorControlModes).)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ClearGuides | Clears all guide lines. Guide lines are used only in the designer. (Inherited from TfrxReportPage.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | Represents method Draw(TCanvas,Extended,Extended,Extended,Extended). (Overrides TfrxPage.Draw(TCanvas,Extended,Extended,Extended,Extended).)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindBand(TfrxBandClass) | Search for band of the specified class on the page. (Inherited from TfrxReportPage.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsSubReport | Returns True, if the report design page is linked to the "Subreport" object. (Inherited from TfrxReportPage.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxReportPage.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
ResetFontOptions | Represents method ResetFontOptions.
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetDefaults | Sets default page size and margins. (Overrides TfrxReportPage.SetDefaults.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetFontStyle(TfrxDMPFontStyles) | Represents method SetFontStyle(TfrxDMPFontStyles).
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetPaperHeight(Extended) | Represents method SetPaperHeight(Extended). (Overrides TfrxReportPage.SetPaperHeight(Extended).)
SetPaperSize(Integer) | Represents method SetPaperSize(Integer). (Overrides TfrxReportPage.SetPaperSize(Integer).)
SetPaperWidth(Extended) | Represents method SetPaperWidth(Extended). (Overrides TfrxReportPage.SetPaperWidth(Extended).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetSizeAndDimensions(Integer,Extended,Extended) | Sets the paper size and dimensions. (Inherited from TfrxReportPage.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateDimensions | Represents method UpdateDimensions. (Inherited from TfrxReportPage.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FFontStyle | Represents field FFontStyle.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FPaperHeight | Represents field FPaperHeight. (Inherited from TfrxReportPage.)
FPaperSize | Represents field FPaperSize. (Inherited from TfrxReportPage.)
FPaperWidth | Represents field FPaperWidth. (Inherited from TfrxReportPage.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FSubBands | List of master bands. (Inherited from TfrxReportPage.)
FVSubBands | List of vertical master bands. (Inherited from TfrxReportPage.)
Top
See Also

Reference

  • frxDMPClass


TfrxDMPPage Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDMPPage class. (Overrides TfrxReportPage.Create(TComponent).)
Top


TfrxDMPPage.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDMPPage class.

Namespace: frxDMPClass
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxReportPage.Create(TComponent)
See Also

Reference

  • TfrxDMPPage
  • frxDMPClass


TfrxDMPPage Properties

Properties
Name | Description
FontStyle | Dot-matrix font style.
Top


TfrxDMPPage.FontStyle Property

Summary

Dot-matrix font style.

Namespace: frxDMPClass
Syntax
Delphi
published
 property FontStyle: TfrxDMPFontStyles read FFontStyle write SetFontStyle;

Property Value

Type: TfrxDMPFontStyles

See Also

Reference

  • TfrxDMPPage
  • frxDMPClass


TfrxDMPPage Methods

Methods
Name | Description
ResetFontOptions | Represents method ResetFontOptions.
SetDefaults | Sets default page size and margins. (Overrides TfrxReportPage.SetDefaults.)
SetFontStyle(TfrxDMPFontStyles) | Represents method SetFontStyle(TfrxDMPFontStyles).
SetPaperHeight(Extended) | Represents method SetPaperHeight(Extended). (Overrides TfrxReportPage.SetPaperHeight(Extended).)
SetPaperSize(Integer) | Represents method SetPaperSize(Integer). (Overrides TfrxReportPage.SetPaperSize(Integer).)
SetPaperWidth(Extended) | Represents method SetPaperWidth(Extended). (Overrides TfrxReportPage.SetPaperWidth(Extended).)
Top


TfrxDMPPage.ResetFontOptions Method

Summary

Represents method ResetFontOptions.

Namespace: frxDMPClass
Syntax
Delphi
public
 procedure ResetFontOptions;
See Also

Reference

  • TfrxDMPPage
  • frxDMPClass


TfrxDMPPage.SetDefaults Method

Summary

Sets default page size and margins.

Namespace: frxDMPClass
Syntax
Delphi
public
 procedure SetDefaults; override;

Overrides

TfrxReportPage.SetDefaults
See Also

Reference

  • TfrxDMPPage
  • frxDMPClass


TfrxDMPPage.SetFontStyle(TfrxDMPFontStyles) Method

Summary

Represents method SetFontStyle(TfrxDMPFontStyles).

Namespace: frxDMPClass
Syntax
Delphi
private
 procedure SetFontStyle(const Value: TfrxDMPFontStyles);

Parameters

Value
Type: TfrxDMPFontStyles

See Also

Reference

  • TfrxDMPPage
  • frxDMPClass


TfrxDMPPage.SetPaperHeight(Extended) Method

Summary

Represents method SetPaperHeight(Extended).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetPaperHeight(const Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxReportPage.SetPaperHeight(Extended)
See Also

Reference

  • TfrxDMPPage
  • frxDMPClass


TfrxDMPPage.SetPaperSize(Integer) Method

Summary

Represents method SetPaperSize(Integer).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetPaperSize(const Value: Integer); override;

Parameters

Value
Type: Integer

Overrides

TfrxReportPage.SetPaperSize(Integer)
See Also

Reference

  • TfrxDMPPage
  • frxDMPClass


TfrxDMPPage.SetPaperWidth(Extended) Method

Summary

Represents method SetPaperWidth(Extended).

Namespace: frxDMPClass
Syntax
Delphi
protected
 procedure SetPaperWidth(const Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxReportPage.SetPaperWidth(Extended)
See Also

Reference

  • TfrxDMPPage
  • frxDMPClass


TfrxDMPPage Fields

Fields
Name | Description
FFontStyle | Represents field FFontStyle.
Top


TfrxDMPPage.FFontStyle Field

Summary

Represents field FFontStyle.

Namespace: frxDMPClass
Syntax
Delphi
private
 FFontStyle: TfrxDMPFontStyles;

Field Value

Type: TfrxDMPFontStyles

See Also

Reference

  • TfrxDMPPage
  • frxDMPClass


frxDMPClass Enumerations

Enumerations
Name | Description
TfrxDMPFontStyle | Dot-matrix font style.
Top


TfrxDMPFontStyle Enumeration

Summary

Dot-matrix font style.

Namespace: frxDMPClass
Syntax
Delphi
type
 TfrxDMPFontStyle = (fsxBold, fsxItalic, fsxUnderline, fsxSuperScript,
 fsxSubScript, fsxCondensed, fsxWide, fsx12cpi, fsx15cpi);

The TfrxDMPFontStyle type exposes the following members.

Members
Show:
Name | Description
fsx12cpi | Represents constant fsx12cpi.
fsx15cpi | Represents constant fsx15cpi.
fsxBold | Represents constant fsxBold.
fsxCondensed | Represents constant fsxCondensed.
fsxItalic | Represents constant fsxItalic.
fsxSubScript | Represents constant fsxSubScript.
fsxSuperScript | Represents constant fsxSuperScript.
fsxUnderline | Represents constant fsxUnderline.
fsxWide | Represents constant fsxWide.
Top
See Also

Reference

  • frxDMPClass


frxDMPClass Types

Types
Name | Description
TfrxDMPFontStyles | Represents type TfrxDMPFontStyles.
Top


TfrxDMPFontStyles Type

Summary

Represents type TfrxDMPFontStyles.

Namespace: frxDMPClass
Syntax
Delphi
type
 TfrxDMPFontStyles = set of TfrxDMPFontStyle;
See Also

Reference

  • frxDMPClass


frxDMPExport Namespace

Summary

Represents namespace frxDMPExport.

Classes
Name | Description
TfrxDMPExportDialog | Represents type TfrxDMPExportDialog.
TfrxDMPrinter | Represents type TfrxDMPrinter.
TfrxDMPrinters | Represents type TfrxDMPrinters.
TfrxDotMatrixExport | The TfrxDotMatrixExport component allows reports to print on a dot-matrix printer. Only reports designed specificly for the DMP mode, can be printed.
Top
Delegates
Name | Description
TfrxTranslateEvent | Represents type TfrxTranslateEvent.
Top
Variables
Name | Description
frxDMPrinters | Represents variable frxDMPrinters.
Top
Constants
Name | Description
cmd12cpiOff | Represents constant cmd12cpiOff.
cmd12cpiOn | Represents constant cmd12cpiOn.
cmd15cpiOff | Represents constant cmd15cpiOff.
cmd15cpiOn | Represents constant cmd15cpiOn.
cmdBoldOff | Represents constant cmdBoldOff.
cmdBoldOn | Represents constant cmdBoldOn.
cmdCondensedOff | Represents constant cmdCondensedOff.
cmdCondensedOn | Represents constant cmdCondensedOn.
cmdFormFeed | Represents constant cmdFormFeed.
cmdItalicOff | Represents constant cmdItalicOff.
cmdItalicOn | Represents constant cmdItalicOn.
cmdLandscape | Represents constant cmdLandscape.
cmdName | Represents constant cmdName.
cmdPortrait | Represents constant cmdPortrait.
cmdReset | Represents constant cmdReset.
cmdSubscriptOff | Represents constant cmdSubscriptOff.
cmdSubscriptOn | Represents constant cmdSubscriptOn.
cmdSuperscriptOff | Represents constant cmdSuperscriptOff.
cmdSuperscriptOn | Represents constant cmdSuperscriptOn.
cmdUnderlineOff | Represents constant cmdUnderlineOff.
cmdUnderlineOn | Represents constant cmdUnderlineOn.
cmdWideOff | Represents constant cmdWideOff.
cmdWideOn | Represents constant cmdWideOn.
CommandCount | Represents constant CommandCount.
CommandNames | Represents constant CommandNames.
Top


frxDMPExport Classes

Classes
Name | Description
TfrxDMPExportDialog | Represents type TfrxDMPExportDialog.
TfrxDMPrinter | Represents type TfrxDMPrinter.
TfrxDMPrinters | Represents type TfrxDMPrinters.
TfrxDotMatrixExport | The TfrxDotMatrixExport component allows reports to print on a dot-matrix printer. Only reports designed specificly for the DMP mode, can be printed.
Top


TfrxDMPExportDialog Class

Summary

Represents type TfrxDMPExportDialog.

Namespace: frxDMPExport
Inheritance Hierarchy
TForm
frxDMPExport.TfrxDMPExportDialog
Syntax
Delphi
type
 TfrxDMPExportDialog = class(TForm)
 end;

The TfrxDMPExportDialog type exposes the following members.

Methods
Show:
Name | Description
FormCreate(TObject) | Represents method FormCreate(TObject).
FormHide(TObject) | Represents method FormHide(TObject).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
PrinterCBClick(TObject) | Represents method PrinterCBClick(TObject).
PrinterCBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) | Represents method PrinterCBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).
RangeEEnter(TObject) | Represents method RangeEEnter(TObject).
Top
Fields
Show:
Name | Description
AllRB | Represents field AllRB.
Cancel | Represents field Cancel.
CopiesE | Represents field CopiesE.
CopiesL | Represents field CopiesL.
CopiesNL | Represents field CopiesNL.
CopiesUD | Represents field CopiesUD.
CurPageRB | Represents field CurPageRB.
DescrL | Represents field DescrL.
EscCB | Represents field EscCB.
EscL | Represents field EscL.
Image1 | Represents field Image1.
OemCB | Represents field OemCB.
OK | Represents field OK.
OldIndex | Represents field OldIndex.
OptionsL | Represents field OptionsL.
PageBreaksCB | Represents field PageBreaksCB.
PageNumbersRB | Represents field PageNumbersRB.
PagesL | Represents field PagesL.
PrinterCB | Represents field PrinterCB.
PrinterL | Represents field PrinterL.
PseudoCB | Represents field PseudoCB.
RangeE | Represents field RangeE.
SaveDialog1 | Represents field SaveDialog1.
SaveToFileCB | Represents field SaveToFileCB.
Top
See Also

Reference

  • frxDMPExport


TfrxDMPExportDialog Methods

Methods
Name | Description
FormCreate(TObject) | Represents method FormCreate(TObject).
FormHide(TObject) | Represents method FormHide(TObject).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
PrinterCBClick(TObject) | Represents method PrinterCBClick(TObject).
PrinterCBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) | Represents method PrinterCBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).
RangeEEnter(TObject) | Represents method RangeEEnter(TObject).
Top


TfrxDMPExportDialog.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: frxDMPExport
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.FormHide(TObject) Method

Summary

Represents method FormHide(TObject).

Namespace: frxDMPExport
Syntax
Delphi
published
 procedure FormHide(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.FormKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method FormKeyDown(TObject,Word,TShiftState).

Namespace: frxDMPExport
Syntax
Delphi
published
 procedure FormKeyDown(Sender: TObject; var Key: Word;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.PrinterCBClick(TObject) Method

Summary

Represents method PrinterCBClick(TObject).

Namespace: frxDMPExport
Syntax
Delphi
published
 procedure PrinterCBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.PrinterCBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) Method

Summary

Represents method PrinterCBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).

Namespace: frxDMPExport
Syntax
Delphi
published
 procedure PrinterCBDrawItem(Control: TWinControl; Index: Integer;
 ARect: TRect; State: TOwnerDrawState);

Parameters

Control
Type: TWinControl

Index
Type: Integer

ARect
Type: TRect

State
Type: TOwnerDrawState

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.RangeEEnter(TObject) Method

Summary

Represents method RangeEEnter(TObject).

Namespace: frxDMPExport
Syntax
Delphi
published
 procedure RangeEEnter(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog Fields

Fields
Name | Description
AllRB | Represents field AllRB.
Cancel | Represents field Cancel.
CopiesE | Represents field CopiesE.
CopiesL | Represents field CopiesL.
CopiesNL | Represents field CopiesNL.
CopiesUD | Represents field CopiesUD.
CurPageRB | Represents field CurPageRB.
DescrL | Represents field DescrL.
EscCB | Represents field EscCB.
EscL | Represents field EscL.
Image1 | Represents field Image1.
OemCB | Represents field OemCB.
OK | Represents field OK.
OldIndex | Represents field OldIndex.
OptionsL | Represents field OptionsL.
PageBreaksCB | Represents field PageBreaksCB.
PageNumbersRB | Represents field PageNumbersRB.
PagesL | Represents field PagesL.
PrinterCB | Represents field PrinterCB.
PrinterL | Represents field PrinterL.
PseudoCB | Represents field PseudoCB.
RangeE | Represents field RangeE.
SaveDialog1 | Represents field SaveDialog1.
SaveToFileCB | Represents field SaveToFileCB.
Top


TfrxDMPExportDialog.AllRB Field

Summary

Represents field AllRB.

Namespace: frxDMPExport
Syntax
Delphi
published
 AllRB: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.Cancel Field

Summary

Represents field Cancel.

Namespace: frxDMPExport
Syntax
Delphi
published
 Cancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.CopiesE Field

Summary

Represents field CopiesE.

Namespace: frxDMPExport
Syntax
Delphi
published
 CopiesE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.CopiesL Field

Summary

Represents field CopiesL.

Namespace: frxDMPExport
Syntax
Delphi
published
 CopiesL: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.CopiesNL Field

Summary

Represents field CopiesNL.

Namespace: frxDMPExport
Syntax
Delphi
published
 CopiesNL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.CopiesUD Field

Summary

Represents field CopiesUD.

Namespace: frxDMPExport
Syntax
Delphi
published
 CopiesUD: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.CurPageRB Field

Summary

Represents field CurPageRB.

Namespace: frxDMPExport
Syntax
Delphi
published
 CurPageRB: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.DescrL Field

Summary

Represents field DescrL.

Namespace: frxDMPExport
Syntax
Delphi
published
 DescrL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.EscCB Field

Summary

Represents field EscCB.

Namespace: frxDMPExport
Syntax
Delphi
published
 EscCB: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.EscL Field

Summary

Represents field EscL.

Namespace: frxDMPExport
Syntax
Delphi
published
 EscL: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.Image1 Field

Summary

Represents field Image1.

Namespace: frxDMPExport
Syntax
Delphi
published
 Image1: TImage;

Field Value

Type: TImage

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.OemCB Field

Summary

Represents field OemCB.

Namespace: frxDMPExport
Syntax
Delphi
published
 OemCB: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.OK Field

Summary

Represents field OK.

Namespace: frxDMPExport
Syntax
Delphi
published
 OK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.OldIndex Field

Summary

Represents field OldIndex.

Namespace: frxDMPExport
Syntax
Delphi
private
 OldIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.OptionsL Field

Summary

Represents field OptionsL.

Namespace: frxDMPExport
Syntax
Delphi
published
 OptionsL: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.PageBreaksCB Field

Summary

Represents field PageBreaksCB.

Namespace: frxDMPExport
Syntax
Delphi
published
 PageBreaksCB: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.PageNumbersRB Field

Summary

Represents field PageNumbersRB.

Namespace: frxDMPExport
Syntax
Delphi
published
 PageNumbersRB: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.PagesL Field

Summary

Represents field PagesL.

Namespace: frxDMPExport
Syntax
Delphi
published
 PagesL: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.PrinterCB Field

Summary

Represents field PrinterCB.

Namespace: frxDMPExport
Syntax
Delphi
published
 PrinterCB: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.PrinterL Field

Summary

Represents field PrinterL.

Namespace: frxDMPExport
Syntax
Delphi
published
 PrinterL: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.PseudoCB Field

Summary

Represents field PseudoCB.

Namespace: frxDMPExport
Syntax
Delphi
published
 PseudoCB: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.RangeE Field

Summary

Represents field RangeE.

Namespace: frxDMPExport
Syntax
Delphi
published
 RangeE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.SaveDialog1 Field

Summary

Represents field SaveDialog1.

Namespace: frxDMPExport
Syntax
Delphi
published
 SaveDialog1: TSaveDialog;

Field Value

Type: TSaveDialog

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPExportDialog.SaveToFileCB Field

Summary

Represents field SaveToFileCB.

Namespace: frxDMPExport
Syntax
Delphi
published
 SaveToFileCB: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TfrxDMPExportDialog
  • frxDMPExport


TfrxDMPrinter Class

Summary

Represents type TfrxDMPrinter.

Namespace: frxDMPExport
Inheritance Hierarchy
TCollectionItem
frxDMPExport.TfrxDMPrinter
Syntax
Delphi
type
 TfrxDMPrinter = class(TCollectionItem)
 end;

The TfrxDMPrinter type exposes the following members.

Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
Fields
Show:
Name | Description
Commands | Represents field Commands.
Top
See Also

Reference

  • frxDMPExport


TfrxDMPrinter Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TfrxDMPrinter.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxDMPExport
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxDMPrinter
  • frxDMPExport


TfrxDMPrinter Fields

Fields
Name | Description
Commands | Represents field Commands.
Top


TfrxDMPrinter.Commands Field

Summary

Represents field Commands.

Namespace: frxDMPExport
Syntax
Delphi
public
 Commands: array[1..CommandCount] of String;

Field Value

Type: array[1..CommandCount] of String

See Also

Reference

  • TfrxDMPrinter
  • frxDMPExport


TfrxDMPrinters Class

Summary

Represents type TfrxDMPrinters.

Namespace: frxDMPExport
Inheritance Hierarchy
TCollection
frxDMPExport.TfrxDMPrinters
Syntax
Delphi
type
 TfrxDMPrinters = class(TCollection)
 end;

The TfrxDMPrinters type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxDMPrinters class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add | Represents method Add.
GetItem(Integer) | Represents method GetItem(Integer).
ReadDefaultPrinters | Represents method ReadDefaultPrinters.
ReadExtPrinters | Represents method ReadExtPrinters.
ReadPrinters(TfrxXMLDocument) | Represents method ReadPrinters(TfrxXMLDocument).
Top
See Also

Reference

  • frxDMPExport


TfrxDMPrinters Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxDMPrinters class.
Top


TfrxDMPrinters.Create Constructor

Summary

Initializes a new instance of the TfrxDMPrinters class.

Namespace: frxDMPExport
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxDMPrinters
  • frxDMPExport


TfrxDMPrinters Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxDMPrinters.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxDMPExport
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxDMPrinter read GetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxDMPrinter

See Also

Reference

  • TfrxDMPrinters
  • frxDMPExport


TfrxDMPrinters Methods

Methods
Name | Description
Add | Represents method Add.
GetItem(Integer) | Represents method GetItem(Integer).
ReadDefaultPrinters | Represents method ReadDefaultPrinters.
ReadExtPrinters | Represents method ReadExtPrinters.
ReadPrinters(TfrxXMLDocument) | Represents method ReadPrinters(TfrxXMLDocument).
Top


TfrxDMPrinters.Add Method

Summary

Represents method Add.

Namespace: frxDMPExport
Syntax
Delphi
public
 function Add: TfrxDMPrinter;

Return Value

Type: TfrxDMPrinter

See Also

Reference

  • TfrxDMPrinters
  • frxDMPExport


TfrxDMPrinters.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxDMPExport
Syntax
Delphi
private
 function GetItem(Index: Integer): TfrxDMPrinter;

Parameters

Index
Type: Integer

Return Value

Type: TfrxDMPrinter

See Also

Reference

  • TfrxDMPrinters
  • frxDMPExport


TfrxDMPrinters.ReadDefaultPrinters Method

Summary

Represents method ReadDefaultPrinters.

Namespace: frxDMPExport
Syntax
Delphi
public
 procedure ReadDefaultPrinters;
See Also

Reference

  • TfrxDMPrinters
  • frxDMPExport


TfrxDMPrinters.ReadExtPrinters Method

Summary

Represents method ReadExtPrinters.

Namespace: frxDMPExport
Syntax
Delphi
public
 procedure ReadExtPrinters;
See Also

Reference

  • TfrxDMPrinters
  • frxDMPExport


TfrxDMPrinters.ReadPrinters(TfrxXMLDocument) Method

Summary

Represents method ReadPrinters(TfrxXMLDocument).

Namespace: frxDMPExport
Syntax
Delphi
public
 procedure ReadPrinters(x: TfrxXMLDocument);

Parameters

x
Type: TfrxXMLDocument

See Also

Reference

  • TfrxDMPrinters
  • frxDMPExport


TfrxDotMatrixExport Class

Summary

The TfrxDotMatrixExport component allows reports to print on a dot-matrix printer. Only reports designed specificly for the DMP mode, can be printed.

Namespace: frxDMPExport
Inheritance Hierarchy
TComponent
frxClass.TfrxCustomExportFilter
frxDMPExport.TfrxDotMatrixExport
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxDotMatrixExport = class(TfrxCustomExportFilter)
 end;

The TfrxDotMatrixExport type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDotMatrixExport class. (Overrides TfrxCustomExportFilter.Create(TComponent).)
CreateNoRegister | This constructor creates component without registration in global list so the filter will be hidden for preview. Thread safe constructor. (Inherited from TfrxCustomExportFilter.)
Destroy | Represents the destructor of the TfrxDotMatrixExport class. (Overrides TfrxCustomExportFilter.Destroy.)
Top
Properties
Show:
Name | Description
CreationTime | Creation time of the document. (Inherited from TfrxCustomExportFilter.)
CurPage | If this property is True, only current page will be exported(in case the export was called from the preview window). (Inherited from TfrxCustomExportFilter.)
CustomFrameSet | Set of symbols used for drawing frame elements. By default this property is empty and frames are printed using +-| symbols or pseudographic symbols. Each frame element is represented by the cross containing 4 lines. Each line has its own weight index: 1 8 4 The CustomFrameSet property should contain 15 symbols. For example, symbol CustomFrameSet[1] represents line number 1, symbol CustomFrameSet[2] represents line number 2, symbol CustomFrameSet[3] represents a combination of line 1 and 2, etc.
DataOnly | If True, the export engine exports only data bands objects. (Inherited from TfrxCustomExportFilter.)
DefaultExt | Default extension of export filter result. (Inherited from TfrxCustomExportFilter.)
DefaultIOTransport | Default transport filter used for file operations in current export filter. (Inherited from TfrxCustomExportFilter.)
DefaultPath | Default path of export result. (Inherited from TfrxCustomExportFilter.)
EscModel | Represents property EscModel.
ExportNotPrintable | If True, the report engine exports all objects with Printable flag set to False. (Inherited from TfrxCustomExportFilter.)
ExportTitle | Title of export filter. (Inherited from TfrxCustomExportFilter.)
FileName | Default file name for export result. (Inherited from TfrxCustomExportFilter.)
Files | List of files generated by export filter. (Inherited from TfrxCustomExportFilter.)
FilterDesc | Default description of export filter. (Inherited from TfrxCustomExportFilter.)
GraphicFrames | Determines if pseudographic frames are used or not.
InitString | The printer init string.
IOTransport | Represents property IOTransport. (Inherited from TfrxCustomExportFilter.)
OEMConvert | Determines whether to convert all strings to OEM character set or not. Default value is True.
OnBeforeExport | This event fires before export starts. (Inherited from TfrxCustomExportFilter.)
OnBeginExport | This event fires when export filter is being exported. (Inherited from TfrxCustomExportFilter.)
OpenAfterExport | If True, document will be opened by default viewer. (Inherited from TfrxCustomExportFilter.)
OverwritePrompt | Represents property OverwritePrompt. (Inherited from TfrxCustomExportFilter.)
PageBreaks | Use page break symbol.
PageNumbers | List of page numbers to export, for example '1-3,5,12'. If this property is empty (by default), all pages will be exported. (Inherited from TfrxCustomExportFilter.)
Report | Reference to a report. (Inherited from TfrxCustomExportFilter.)
SaveToFile | Determines whether to save export to file or to print it. If this property is True, you should also set the FileName property.
ShowDialog | Determines if export settings dialogue is shown. Default value is True. (Inherited from TfrxCustomExportFilter.)
ShowProgress | Shows dialog with export progress. (Inherited from TfrxCustomExportFilter.)
SlaveExport | Internal use. (Inherited from TfrxCustomExportFilter.)
Stream | Reference to a stream used to save export filter result. (Inherited from TfrxCustomExportFilter.)
SuppressPageHeadersFooters | Suppress page Headers and page Footers during export. (Inherited from TfrxCustomExportFilter.)
UseFileCache | Use a file cache for temporary operations. (Inherited from TfrxCustomExportFilter.)
UseIniSettings | Store settings in the report ini-file.
Top
Methods
Show:
Name | Description
AfterFinish | Represents method AfterFinish. (Inherited from TfrxCustomExportFilter.)
BeforeStart | Represents method BeforeStart. (Inherited from TfrxCustomExportFilter.)
BeginClip(TfrxView) | Begin clip operation. (Inherited from TfrxCustomExportFilter.)
CreateBuf(Integer,Integer) | Represents method CreateBuf(Integer,Integer).
CreateDefaultIOTransport | Method created default instance of transport filter for current class of export filter. (Inherited from TfrxCustomExportFilter.)
DoFinish | Method is called after finishing the export. (Inherited from TfrxCustomExportFilter.)
DoStart | Method is called before export starts. To continue export, this method should return True. (Inherited from TfrxCustomExportFilter.)
DrawFrame(Integer,Integer,Integer,Integer,Integer) | Represents method DrawFrame(Integer,Integer,Integer,Integer,Integer).
DrawMemo(Integer,Integer,Integer,Integer,TfrxDMPMemoView) | Represents method DrawMemo(Integer,Integer,Integer,Integer,TfrxDMPMemoView).
EndClip | (Inherited from TfrxCustomExportFilter.)
ExportObject(TfrxComponent) | Method is called when exporting the object. Bands are exported too. (Overrides TfrxCustomExportFilter.ExportObject(TfrxComponent).)
Finish | Represents method Finish. (Overrides TfrxCustomExportFilter.Finish.)
FinishPage(TfrxReportPage,Integer) | Method is called after finishing a page. Page is the reference to a page, Index is the page index in the prepared report. (Overrides TfrxCustomExportFilter.FinishPage(TfrxReportPage,Integer).)
FlushBuf | Represents method FlushBuf.
FormFeed | Represents method FormFeed.
FreeBuf | Represents method FreeBuf.
GetDescription | Description of the export filter. This value is displayed in the preview window. (Inherited from TfrxCustomExportFilter.)
GetTempFName | Represents method GetTempFName.
IntToStyle(Integer) | Represents method IntToStyle(Integer).
IsProcessInternal | Returns True when filter export can process internal objects in other objects. (Inherited from TfrxCustomExportFilter.)
Landscape | Represents method Landscape.
Portrait | Represents method Portrait.
Reset | Represents method Reset.
SetFrame(Integer,Integer,Byte) | Represents method SetFrame(Integer,Integer,Byte).
SetString(Integer,Integer,AnsiString) | Represents method SetString(Integer,Integer,AnsiString).
SetStyle(Integer,Integer,Integer) | Represents method SetStyle(Integer,Integer,Integer).
ShowModal | Method should show the export settings dialog and return mrOk value if dialog was accepted. This method is not called if ShowDialog property is False. (Overrides TfrxCustomExportFilter.ShowModal.)
SpoolFile(String) | Represents method SpoolFile(String).
Start | Represents method Start. (Overrides TfrxCustomExportFilter.Start.)
StartPage(TfrxReportPage,Integer) | Method is called before exporting a page. Page is the reference to a page, Index is the page index in the prepared report. (Overrides TfrxCustomExportFilter.StartPage(TfrxReportPage,Integer).)
StyleChange(Integer,Integer) | Represents method StyleChange(Integer,Integer).
StyleOff(Integer) | Represents method StyleOff(Integer).
StyleOn(Integer) | Represents method StyleOn(Integer).
StyleToInt(TfrxDMPFontStyles) | Represents method StyleToInt(TfrxDMPFontStyles).
WriteStr(AnsiString) | Represents method WriteStr(AnsiString).
WriteStrLn(AnsiString) | Represents method WriteStrLn(AnsiString).
Top
Events
Show:
Name | Description
OnTranslate | Represents property OnTranslate.
Top
Fields
Show:
Name | Description
FBufHeight | Represents field FBufHeight.
FBufWidth | Represents field FBufWidth.
FCharBuf | Represents field FCharBuf.
FCopies | Represents field FCopies.
FCustomFrameSet | Represents field FCustomFrameSet.
FDefaultIOTransport | Represents field FDefaultIOTransport. (Inherited from TfrxCustomExportFilter.)
FEscModel | Represents field FEscModel.
FFrameBuf | Represents field FFrameBuf.
FGraphicFrames | Represents field FGraphicFrames.
FMaxHeight | Represents field FMaxHeight.
FOEMConvert | Represents field FOEMConvert.
FOnTranslate | Represents field FOnTranslate.
FPageBreaks | Represents field FPageBreaks.
FPageStyle | Represents field FPageStyle.
FPrinterInitString | Represents field FPrinterInitString.
FSaveToFile | Represents field FSaveToFile.
FStream | Represents field FStream.
FStyleBuf | Represents field FStyleBuf.
FUseIniSettings | Represents field FUseIniSettings.
Top
See Also

Reference

  • frxDMPExport


TfrxDotMatrixExport Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDotMatrixExport class. (Overrides TfrxCustomExportFilter.Create(TComponent).)
Destroy | Represents the destructor of the TfrxDotMatrixExport class. (Overrides TfrxCustomExportFilter.Destroy.)
Top


TfrxDotMatrixExport.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDotMatrixExport class.

Namespace: frxDMPExport
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomExportFilter.Create(TComponent)
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.Destroy Destructor

Summary

Represents the destructor of the TfrxDotMatrixExport class.

Namespace: frxDMPExport
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxCustomExportFilter.Destroy
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport Properties

Properties
Name | Description
CustomFrameSet | Set of symbols used for drawing frame elements. By default this property is empty and frames are printed using +-| symbols or pseudographic symbols. Each frame element is represented by the cross containing 4 lines. Each line has its own weight index: 1 8 4 The CustomFrameSet property should contain 15 symbols. For example, symbol CustomFrameSet[1] represents line number 1, symbol CustomFrameSet[2] represents line number 2, symbol CustomFrameSet[3] represents a combination of line 1 and 2, etc.
EscModel | Represents property EscModel.
GraphicFrames | Determines if pseudographic frames are used or not.
InitString | The printer init string.
OEMConvert | Determines whether to convert all strings to OEM character set or not. Default value is True.
PageBreaks | Use page break symbol.
SaveToFile | Determines whether to save export to file or to print it. If this property is True, you should also set the FileName property.
UseIniSettings | Store settings in the report ini-file.
Top


TfrxDotMatrixExport.CustomFrameSet Property

Summary

Set of symbols used for drawing frame elements. By default this property is empty and frames are printed using +-| symbols or pseudographic symbols.
Each frame element is represented by the cross containing 4 lines. Each line has its own weight index:
1
8
4
The CustomFrameSet property should contain 15 symbols. For example, symbol CustomFrameSet[1] represents line number 1, symbol CustomFrameSet[2] represents line number 2, symbol CustomFrameSet[3] represents a combination of line 1 and 2, etc.

Namespace: frxDMPExport
Syntax
Delphi
published
 property CustomFrameSet: AnsiString read FCustomFrameSet write FCustomFrameSet;

Property Value

Type: AnsiString

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.EscModel Property

Summary

Represents property EscModel.

Namespace: frxDMPExport
Syntax
Delphi
published
 property EscModel: Integer read FEscModel write FEscModel;

Property Value

Type: Integer

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.GraphicFrames Property

Summary

Determines if pseudographic frames are used or not.

Namespace: frxDMPExport
Syntax
Delphi
published
 property GraphicFrames: Boolean read FGraphicFrames write FGraphicFrames;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.InitString Property

Summary

The printer init string.

Namespace: frxDMPExport
Syntax
Delphi
published
 property InitString: AnsiString read FPrinterInitString write FPrinterInitString;

Property Value

Type: AnsiString

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.OEMConvert Property

Summary

Determines whether to convert all strings to OEM character set or not. Default value is True.

Namespace: frxDMPExport
Syntax
Delphi
published
 property OEMConvert: Boolean read FOEMConvert write FOEMConvert default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.PageBreaks Property

Summary

Use page break symbol.

Namespace: frxDMPExport
Syntax
Delphi
published
 property PageBreaks: Boolean read FPageBreaks write FPageBreaks default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.SaveToFile Property

Summary

Determines whether to save export to file or to print it. If this property is True, you should also set the FileName property.

Namespace: frxDMPExport
Syntax
Delphi
published
 property SaveToFile: Boolean read FSaveToFile write FSaveToFile;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.UseIniSettings Property

Summary

Store settings in the report ini-file.

Namespace: frxDMPExport
Syntax
Delphi
published
 property UseIniSettings: Boolean read FUseIniSettings write FUseIniSettings;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport Methods

Methods
Name | Description
CreateBuf(Integer,Integer) | Represents method CreateBuf(Integer,Integer).
DrawFrame(Integer,Integer,Integer,Integer,Integer) | Represents method DrawFrame(Integer,Integer,Integer,Integer,Integer).
DrawMemo(Integer,Integer,Integer,Integer,TfrxDMPMemoView) | Represents method DrawMemo(Integer,Integer,Integer,Integer,TfrxDMPMemoView).
ExportObject(TfrxComponent) | Method is called when exporting the object. Bands are exported too. (Overrides TfrxCustomExportFilter.ExportObject(TfrxComponent).)
Finish | Represents method Finish. (Overrides TfrxCustomExportFilter.Finish.)
FinishPage(TfrxReportPage,Integer) | Method is called after finishing a page. Page is the reference to a page, Index is the page index in the prepared report. (Overrides TfrxCustomExportFilter.FinishPage(TfrxReportPage,Integer).)
FlushBuf | Represents method FlushBuf.
FormFeed | Represents method FormFeed.
FreeBuf | Represents method FreeBuf.
GetTempFName | Represents method GetTempFName.
IntToStyle(Integer) | Represents method IntToStyle(Integer).
Landscape | Represents method Landscape.
Portrait | Represents method Portrait.
Reset | Represents method Reset.
SetFrame(Integer,Integer,Byte) | Represents method SetFrame(Integer,Integer,Byte).
SetString(Integer,Integer,AnsiString) | Represents method SetString(Integer,Integer,AnsiString).
SetStyle(Integer,Integer,Integer) | Represents method SetStyle(Integer,Integer,Integer).
ShowModal | Method should show the export settings dialog and return mrOk value if dialog was accepted. This method is not called if ShowDialog property is False. (Overrides TfrxCustomExportFilter.ShowModal.)
SpoolFile(String) | Represents method SpoolFile(String).
Start | Represents method Start. (Overrides TfrxCustomExportFilter.Start.)
StartPage(TfrxReportPage,Integer) | Method is called before exporting a page. Page is the reference to a page, Index is the page index in the prepared report. (Overrides TfrxCustomExportFilter.StartPage(TfrxReportPage,Integer).)
StyleChange(Integer,Integer) | Represents method StyleChange(Integer,Integer).
StyleOff(Integer) | Represents method StyleOff(Integer).
StyleOn(Integer) | Represents method StyleOn(Integer).
StyleToInt(TfrxDMPFontStyles) | Represents method StyleToInt(TfrxDMPFontStyles).
WriteStr(AnsiString) | Represents method WriteStr(AnsiString).
WriteStrLn(AnsiString) | Represents method WriteStrLn(AnsiString).
Top


TfrxDotMatrixExport.CreateBuf(Integer,Integer) Method

Summary

Represents method CreateBuf(Integer,Integer).

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure CreateBuf(Width, Height: Integer);

Parameters

Width
Type: Integer

Height
Type: Integer

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.DrawFrame(Integer,Integer,Integer,Integer,Integer) Method

Summary

Represents method DrawFrame(Integer,Integer,Integer,Integer,Integer).

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure DrawFrame(x, y, dx, dy: Integer; Style: Integer);

Parameters

x
Type: Integer

y
Type: Integer

dx
Type: Integer

dy
Type: Integer

Style
Type: Integer

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.DrawMemo(Integer,Integer,Integer,Integer,TfrxDMPMemoView) Method

Summary

Represents method DrawMemo(Integer,Integer,Integer,Integer,TfrxDMPMemoView).

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure DrawMemo(x, y, dx, dy: Integer; Memo: TfrxDMPMemoView);

Parameters

x
Type: Integer

y
Type: Integer

dx
Type: Integer

dy
Type: Integer

Memo
Type: TfrxDMPMemoView

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.ExportObject(TfrxComponent) Method

Summary

Method is called when exporting the object. Bands are exported too.

Namespace: frxDMPExport
Syntax
Delphi
public
 procedure ExportObject(Obj: TfrxComponent); override;

Parameters

Obj
Type: TfrxComponent

Overrides

TfrxCustomExportFilter.ExportObject(TfrxComponent)
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.Finish Method

Summary

Represents method Finish.

Namespace: frxDMPExport
Syntax
Delphi
public
 procedure Finish; override;

Overrides

TfrxCustomExportFilter.Finish
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FinishPage(TfrxReportPage,Integer) Method

Summary

Method is called after finishing a page. Page is the reference to a page, Index is the page index in the prepared report.

Namespace: frxDMPExport
Syntax
Delphi
public
 procedure FinishPage(Page: TfrxReportPage; Index: Integer); override;

Parameters

Page
Type: TfrxReportPage

Index
Type: Integer

Overrides

TfrxCustomExportFilter.FinishPage(TfrxReportPage,Integer)
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FlushBuf Method

Summary

Represents method FlushBuf.

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure FlushBuf;
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FormFeed Method

Summary

Represents method FormFeed.

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure FormFeed;
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FreeBuf Method

Summary

Represents method FreeBuf.

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure FreeBuf;
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.GetTempFName Method

Summary

Represents method GetTempFName.

Namespace: frxDMPExport
Syntax
Delphi
private
 function GetTempFName: String;

Return Value

Type: String

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.IntToStyle(Integer) Method

Summary

Represents method IntToStyle(Integer).

Namespace: frxDMPExport
Syntax
Delphi
private
 function IntToStyle(i: Integer): TfrxDMPFontStyles;

Parameters

i
Type: Integer

Return Value

Type: TfrxDMPFontStyles

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.Landscape Method

Summary

Represents method Landscape.

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure Landscape;
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.Portrait Method

Summary

Represents method Portrait.

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure Portrait;
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.Reset Method

Summary

Represents method Reset.

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure Reset;
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.SetFrame(Integer,Integer,Byte) Method

Summary

Represents method SetFrame(Integer,Integer,Byte).

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure SetFrame(x, y: Integer; typ: Byte);

Parameters

x
Type: Integer

y
Type: Integer

typ
Type: Byte

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.SetString(Integer,Integer,AnsiString) Method

Summary

Represents method SetString(Integer,Integer,AnsiString).

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure SetString(x, y: Integer; s: AnsiString);

Parameters

x
Type: Integer

y
Type: Integer

s
Type: AnsiString

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.SetStyle(Integer,Integer,Integer) Method

Summary

Represents method SetStyle(Integer,Integer,Integer).

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure SetStyle(x, y, Style: Integer);

Parameters

x
Type: Integer

y
Type: Integer

Style
Type: Integer

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.ShowModal Method

Summary

Method should show the export settings dialog and return mrOk value if dialog was accepted. This method is not called if ShowDialog property is False.

Namespace: frxDMPExport
Syntax
Delphi
public
 function ShowModal: TModalResult; override;

Return Value

Type: TModalResult

Overrides

TfrxCustomExportFilter.ShowModal
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.SpoolFile(String) Method

Summary

Represents method SpoolFile(String).

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure SpoolFile(const FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.Start Method

Summary

Represents method Start.

Namespace: frxDMPExport
Syntax
Delphi
public
 function Start: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCustomExportFilter.Start
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.StartPage(TfrxReportPage,Integer) Method

Summary

Method is called before exporting a page. Page is the reference to a page, Index is the page index in the prepared report.

Namespace: frxDMPExport
Syntax
Delphi
public
 procedure StartPage(Page: TfrxReportPage; Index: Integer); override;

Parameters

Page
Type: TfrxReportPage

Index
Type: Integer

Overrides

TfrxCustomExportFilter.StartPage(TfrxReportPage,Integer)
See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.StyleChange(Integer,Integer) Method

Summary

Represents method StyleChange(Integer,Integer).

Namespace: frxDMPExport
Syntax
Delphi
private
 function StyleChange(OldStyle, NewStyle: Integer): String;

Parameters

OldStyle
Type: Integer

NewStyle
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.StyleOff(Integer) Method

Summary

Represents method StyleOff(Integer).

Namespace: frxDMPExport
Syntax
Delphi
private
 function StyleOff(Style: Integer): String;

Parameters

Style
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.StyleOn(Integer) Method

Summary

Represents method StyleOn(Integer).

Namespace: frxDMPExport
Syntax
Delphi
private
 function StyleOn(Style: Integer): String;

Parameters

Style
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.StyleToInt(TfrxDMPFontStyles) Method

Summary

Represents method StyleToInt(TfrxDMPFontStyles).

Namespace: frxDMPExport
Syntax
Delphi
private
 function StyleToInt(Style: TfrxDMPFontStyles): Integer;

Parameters

Style
Type: TfrxDMPFontStyles

Return Value

Type: Integer

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.WriteStr(AnsiString) Method

Summary

Represents method WriteStr(AnsiString).

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure WriteStr(const str: AnsiString);

Parameters

str
Type: AnsiString

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.WriteStrLn(AnsiString) Method

Summary

Represents method WriteStrLn(AnsiString).

Namespace: frxDMPExport
Syntax
Delphi
private
 procedure WriteStrLn(const str: AnsiString);

Parameters

str
Type: AnsiString

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport Events

Events
Name | Description
OnTranslate | Represents property OnTranslate.
Top


TfrxDotMatrixExport.OnTranslate Event

Summary

Represents property OnTranslate.

Namespace: frxDMPExport
Syntax
Delphi
published
 property OnTranslate: TfrxTranslateEvent read FOnTranslate write FOnTranslate;

Value

Type: TfrxTranslateEvent

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport Fields

Fields
Name | Description
FBufHeight | Represents field FBufHeight.
FBufWidth | Represents field FBufWidth.
FCharBuf | Represents field FCharBuf.
FCopies | Represents field FCopies.
FCustomFrameSet | Represents field FCustomFrameSet.
FEscModel | Represents field FEscModel.
FFrameBuf | Represents field FFrameBuf.
FGraphicFrames | Represents field FGraphicFrames.
FMaxHeight | Represents field FMaxHeight.
FOEMConvert | Represents field FOEMConvert.
FOnTranslate | Represents field FOnTranslate.
FPageBreaks | Represents field FPageBreaks.
FPageStyle | Represents field FPageStyle.
FPrinterInitString | Represents field FPrinterInitString.
FSaveToFile | Represents field FSaveToFile.
FStream | Represents field FStream.
FStyleBuf | Represents field FStyleBuf.
FUseIniSettings | Represents field FUseIniSettings.
Top


TfrxDotMatrixExport.FBufHeight Field

Summary

Represents field FBufHeight.

Namespace: frxDMPExport
Syntax
Delphi
private
 FBufHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FBufWidth Field

Summary

Represents field FBufWidth.

Namespace: frxDMPExport
Syntax
Delphi
private
 FBufWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FCharBuf Field

Summary

Represents field FCharBuf.

Namespace: frxDMPExport
Syntax
Delphi
private
 FCharBuf: array of AnsiChar;

Field Value

Type: array of AnsiChar

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FCopies Field

Summary

Represents field FCopies.

Namespace: frxDMPExport
Syntax
Delphi
private
 FCopies: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FCustomFrameSet Field

Summary

Represents field FCustomFrameSet.

Namespace: frxDMPExport
Syntax
Delphi
private
 FCustomFrameSet: AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FEscModel Field

Summary

Represents field FEscModel.

Namespace: frxDMPExport
Syntax
Delphi
private
 FEscModel: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FFrameBuf Field

Summary

Represents field FFrameBuf.

Namespace: frxDMPExport
Syntax
Delphi
private
 FFrameBuf: array of Byte;

Field Value

Type: array of Byte

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FGraphicFrames Field

Summary

Represents field FGraphicFrames.

Namespace: frxDMPExport
Syntax
Delphi
private
 FGraphicFrames: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FMaxHeight Field

Summary

Represents field FMaxHeight.

Namespace: frxDMPExport
Syntax
Delphi
private
 FMaxHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FOEMConvert Field

Summary

Represents field FOEMConvert.

Namespace: frxDMPExport
Syntax
Delphi
private
 FOEMConvert: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FOnTranslate Field

Summary

Represents field FOnTranslate.

Namespace: frxDMPExport
Syntax
Delphi
private
 FOnTranslate: TfrxTranslateEvent;

Field Value

Type: TfrxTranslateEvent

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FPageBreaks Field

Summary

Represents field FPageBreaks.

Namespace: frxDMPExport
Syntax
Delphi
private
 FPageBreaks: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FPageStyle Field

Summary

Represents field FPageStyle.

Namespace: frxDMPExport
Syntax
Delphi
private
 FPageStyle: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FPrinterInitString Field

Summary

Represents field FPrinterInitString.

Namespace: frxDMPExport
Syntax
Delphi
private
 FPrinterInitString: AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FSaveToFile Field

Summary

Represents field FSaveToFile.

Namespace: frxDMPExport
Syntax
Delphi
private
 FSaveToFile: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FStream Field

Summary

Represents field FStream.

Namespace: frxDMPExport
Syntax
Delphi
private
 FStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FStyleBuf Field

Summary

Represents field FStyleBuf.

Namespace: frxDMPExport
Syntax
Delphi
private
 FStyleBuf: array of Integer;

Field Value

Type: array of Integer

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


TfrxDotMatrixExport.FUseIniSettings Field

Summary

Represents field FUseIniSettings.

Namespace: frxDMPExport
Syntax
Delphi
private
 FUseIniSettings: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDotMatrixExport
  • frxDMPExport


frxDMPExport Delegates

Delegates
Name | Description
TfrxTranslateEvent | Represents type TfrxTranslateEvent.
Top


TfrxTranslateEvent Delegate

Summary

Represents type TfrxTranslateEvent.

Namespace: frxDMPExport
Syntax
Delphi
type
 TfrxTranslateEvent = procedure(Sender: TObject; var s: AnsiString) of object;
See Also

Reference

  • frxDMPExport


frxDMPExport Variables

Variables
Name | Description
frxDMPrinters | Represents variable frxDMPrinters.
Top


frxDMPrinters Variable

Summary

Represents variable frxDMPrinters.

Namespace: frxDMPExport
Syntax
Delphi
frxDMPrinters: TfrxDMPrinters;

Value

Type: TfrxDMPrinters

See Also

Reference

  • frxDMPExport


frxDMPExport Constants

Constants
Name | Description
cmd12cpiOff | Represents constant cmd12cpiOff.
cmd12cpiOn | Represents constant cmd12cpiOn.
cmd15cpiOff | Represents constant cmd15cpiOff.
cmd15cpiOn | Represents constant cmd15cpiOn.
cmdBoldOff | Represents constant cmdBoldOff.
cmdBoldOn | Represents constant cmdBoldOn.
cmdCondensedOff | Represents constant cmdCondensedOff.
cmdCondensedOn | Represents constant cmdCondensedOn.
cmdFormFeed | Represents constant cmdFormFeed.
cmdItalicOff | Represents constant cmdItalicOff.
cmdItalicOn | Represents constant cmdItalicOn.
cmdLandscape | Represents constant cmdLandscape.
cmdName | Represents constant cmdName.
cmdPortrait | Represents constant cmdPortrait.
cmdReset | Represents constant cmdReset.
cmdSubscriptOff | Represents constant cmdSubscriptOff.
cmdSubscriptOn | Represents constant cmdSubscriptOn.
cmdSuperscriptOff | Represents constant cmdSuperscriptOff.
cmdSuperscriptOn | Represents constant cmdSuperscriptOn.
cmdUnderlineOff | Represents constant cmdUnderlineOff.
cmdUnderlineOn | Represents constant cmdUnderlineOn.
cmdWideOff | Represents constant cmdWideOff.
cmdWideOn | Represents constant cmdWideOn.
CommandCount | Represents constant CommandCount.
CommandNames | Represents constant CommandNames.
Top


cmd12cpiOff Constant

Summary

Represents constant cmd12cpiOff.

Namespace: frxDMPExport
Syntax
Delphi
 cmd12cpiOff = 21;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmd12cpiOn Constant

Summary

Represents constant cmd12cpiOn.

Namespace: frxDMPExport
Syntax
Delphi
 cmd12cpiOn = 20;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmd15cpiOff Constant

Summary

Represents constant cmd15cpiOff.

Namespace: frxDMPExport
Syntax
Delphi
 cmd15cpiOff = 23;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmd15cpiOn Constant

Summary

Represents constant cmd15cpiOn.

Namespace: frxDMPExport
Syntax
Delphi
 cmd15cpiOn = 22;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdBoldOff Constant

Summary

Represents constant cmdBoldOff.

Namespace: frxDMPExport
Syntax
Delphi
 cmdBoldOff = 7;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdBoldOn Constant

Summary

Represents constant cmdBoldOn.

Namespace: frxDMPExport
Syntax
Delphi
 cmdBoldOn = 6;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdCondensedOff Constant

Summary

Represents constant cmdCondensedOff.

Namespace: frxDMPExport
Syntax
Delphi
 cmdCondensedOff = 17;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdCondensedOn Constant

Summary

Represents constant cmdCondensedOn.

Namespace: frxDMPExport
Syntax
Delphi
 cmdCondensedOn = 16;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdFormFeed Constant

Summary

Represents constant cmdFormFeed.

Namespace: frxDMPExport
Syntax
Delphi
 cmdFormFeed = 3;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdItalicOff Constant

Summary

Represents constant cmdItalicOff.

Namespace: frxDMPExport
Syntax
Delphi
 cmdItalicOff = 9;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdItalicOn Constant

Summary

Represents constant cmdItalicOn.

Namespace: frxDMPExport
Syntax
Delphi
 cmdItalicOn = 8;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdLandscape Constant

Summary

Represents constant cmdLandscape.

Namespace: frxDMPExport
Syntax
Delphi
 cmdLandscape = 4;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdName Constant

Summary

Represents constant cmdName.

Namespace: frxDMPExport
Syntax
Delphi
 cmdName = 1;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdPortrait Constant

Summary

Represents constant cmdPortrait.

Namespace: frxDMPExport
Syntax
Delphi
 cmdPortrait = 5;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdReset Constant

Summary

Represents constant cmdReset.

Namespace: frxDMPExport
Syntax
Delphi
 cmdReset = 2;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdSubscriptOff Constant

Summary

Represents constant cmdSubscriptOff.

Namespace: frxDMPExport
Syntax
Delphi
 cmdSubscriptOff = 15;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdSubscriptOn Constant

Summary

Represents constant cmdSubscriptOn.

Namespace: frxDMPExport
Syntax
Delphi
 cmdSubscriptOn = 14;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdSuperscriptOff Constant

Summary

Represents constant cmdSuperscriptOff.

Namespace: frxDMPExport
Syntax
Delphi
 cmdSuperscriptOff = 13;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdSuperscriptOn Constant

Summary

Represents constant cmdSuperscriptOn.

Namespace: frxDMPExport
Syntax
Delphi
 cmdSuperscriptOn = 12;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdUnderlineOff Constant

Summary

Represents constant cmdUnderlineOff.

Namespace: frxDMPExport
Syntax
Delphi
 cmdUnderlineOff = 11;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdUnderlineOn Constant

Summary

Represents constant cmdUnderlineOn.

Namespace: frxDMPExport
Syntax
Delphi
 cmdUnderlineOn = 10;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdWideOff Constant

Summary

Represents constant cmdWideOff.

Namespace: frxDMPExport
Syntax
Delphi
 cmdWideOff = 19;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


cmdWideOn Constant

Summary

Represents constant cmdWideOn.

Namespace: frxDMPExport
Syntax
Delphi
 cmdWideOn = 18;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


CommandCount Constant

Summary

Represents constant CommandCount.

Namespace: frxDMPExport
Syntax
Delphi
 CommandCount = 23;

Value

Type: ShortInt

See Also

Reference

  • frxDMPExport


CommandNames Constant

Summary

Represents constant CommandNames.

Namespace: frxDMPExport
Syntax
Delphi
 CommandNames: array[1..CommandCount] of String = (
 'Name', 'Reset', 'FormFeed', 'Landscape', 'Portrait',
 'BoldOn', 'BoldOff', 'ItalicOn', 'ItalicOff', 'UnderlineOn', 'UnderlineOff',
 'SuperscriptOn', 'SuperscriptOff', 'SubscriptOn', 'SubscriptOff',
 'CondensedOn', 'CondensedOff', 'WideOn', 'WideOff',
 'cpi12On', 'cpi12Off', 'cpi15On', 'cpi15Off');

Value

Type: array[1..CommandCount] of String

See Also

Reference

  • frxDMPExport


frxDock Namespace

Summary

Represents namespace frxDock.

Classes
Name | Description
TfrxDockSite | Represents type TfrxDockSite.
TfrxTBPanel | Represents type TfrxTBPanel.
Top
Routines
Name | Description
frxRestoreDock(TCustomIniFile,TfrxDockSite) | Represents method frxRestoreDock(TCustomIniFile,TfrxDockSite).
frxRestoreFormPosition(TCustomIniFile,TForm,Single) | Represents method frxRestoreFormPosition(TCustomIniFile,TForm,Single).
frxRestoreToolbarPosition(TCustomIniFile,TToolBar,Integer) | Represents method frxRestoreToolbarPosition(TCustomIniFile,TToolBar,Integer).
frxSaveDock(TCustomIniFile,TfrxDockSite,Single) | Represents method frxSaveDock(TCustomIniFile,TfrxDockSite,Single).
frxSaveFormPosition(TCustomIniFile,TForm,Single) | Represents method frxSaveFormPosition(TCustomIniFile,TForm,Single).
frxSaveToolbarPosition(TCustomIniFile,TToolBar,Single) | Represents method frxSaveToolbarPosition(TCustomIniFile,TToolBar,Single).
Top


frxDock Classes

Classes
Name | Description
TfrxDockSite | Represents type TfrxDockSite.
TfrxTBPanel | Represents type TfrxTBPanel.
Top


TfrxDockSite Class

Summary

Represents type TfrxDockSite.

Namespace: frxDock
Inheritance Hierarchy
TCustomPanel
frxDPIAwareBaseControls.TfrxDPIAwareBasePanel
frxDPIAwareBaseControls.TfrxDPIAwarePanel
frxDock.TfrxDockSite
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxDockSite = class(TfrxDPIAwarePanel)
 end;

The TfrxDockSite type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDockSite class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Top
Properties
Show:
Name | Description
Align | Represents property Align. (Inherited from TfrxDPIAwarePanel.)
Alignment | Represents property Alignment. (Inherited from TfrxDPIAwarePanel.)
Anchors | Represents property Anchors. (Inherited from TfrxDPIAwarePanel.)
AutoSize | Represents property AutoSize. (Inherited from TfrxDPIAwarePanel.)
BevelInner | Represents property BevelInner. (Inherited from TfrxDPIAwarePanel.)
BevelKind | Represents property BevelKind. (Inherited from TfrxDPIAwarePanel.)
BevelOuter | Represents property BevelOuter. (Inherited from TfrxDPIAwarePanel.)
BevelWidth | Represents property BevelWidth. (Inherited from TfrxDPIAwarePanel.)
BiDiMode | Represents property BiDiMode. (Inherited from TfrxDPIAwarePanel.)
BorderStyle | Represents property BorderStyle. (Inherited from TfrxDPIAwarePanel.)
BorderWidth | Represents property BorderWidth. (Inherited from TfrxDPIAwarePanel.)
Caption | Represents property Caption. (Inherited from TfrxDPIAwarePanel.)
Color | Represents property Color. (Inherited from TfrxDPIAwarePanel.)
Constraints | Represents property Constraints. (Inherited from TfrxDPIAwarePanel.)
Ctl3D | Represents property Ctl3D. (Inherited from TfrxDPIAwarePanel.)
CurrentPPI | Represents property CurrentPPI. (Inherited from TfrxDPIAwareBasePanel.)
DockManager | Represents property DockManager. (Inherited from TfrxDPIAwarePanel.)
DockSite | Represents property DockSite. (Inherited from TfrxDPIAwarePanel.)
DragCursor | Represents property DragCursor. (Inherited from TfrxDPIAwarePanel.)
DragKind | Represents property DragKind. (Inherited from TfrxDPIAwarePanel.)
DragMode | Represents property DragMode. (Inherited from TfrxDPIAwarePanel.)
Enabled | Represents property Enabled. (Inherited from TfrxDPIAwarePanel.)
Font | Represents property Font. (Inherited from TfrxDPIAwarePanel.)
FullRepaint | Represents property FullRepaint. (Inherited from TfrxDPIAwarePanel.)
Locked | Represents property Locked. (Inherited from TfrxDPIAwarePanel.)
OnCanResize | Represents property OnCanResize. (Inherited from TfrxDPIAwarePanel.)
OnClick | Represents property OnClick. (Inherited from TfrxDPIAwarePanel.)
OnConstrainedResize | Represents property OnConstrainedResize. (Inherited from TfrxDPIAwarePanel.)
OnContextPopup | Represents property OnContextPopup. (Inherited from TfrxDPIAwarePanel.)
OnDblClick | Represents property OnDblClick. (Inherited from TfrxDPIAwarePanel.)
OnDockDrop | Represents property OnDockDrop. (Inherited from TfrxDPIAwarePanel.)
OnDockOver | Represents property OnDockOver. (Inherited from TfrxDPIAwarePanel.)
OnDragDrop | Represents property OnDragDrop. (Inherited from TfrxDPIAwarePanel.)
OnDragOver | Represents property OnDragOver. (Inherited from TfrxDPIAwarePanel.)
OnEndDock | Represents property OnEndDock. (Inherited from TfrxDPIAwarePanel.)
OnEndDrag | Represents property OnEndDrag. (Inherited from TfrxDPIAwarePanel.)
OnEnter | Represents property OnEnter. (Inherited from TfrxDPIAwarePanel.)
OnExit | Represents property OnExit. (Inherited from TfrxDPIAwarePanel.)
OnGetSiteInfo | Represents property OnGetSiteInfo. (Inherited from TfrxDPIAwarePanel.)
OnMouseDown | Represents property OnMouseDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseMove | Represents property OnMouseMove. (Inherited from TfrxDPIAwarePanel.)
OnMouseUp | Represents property OnMouseUp. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheel | Represents property OnMouseWheel. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelDown | Represents property OnMouseWheelDown. (Inherited from TfrxDPIAwarePanel.)
OnMouseWheelUp | Represents property OnMouseWheelUp. (Inherited from TfrxDPIAwarePanel.)
OnResize | Represents property OnResize. (Inherited from TfrxDPIAwarePanel.)
OnStartDock | Represents property OnStartDock. (Inherited from TfrxDPIAwarePanel.)
OnStartDrag | Represents property OnStartDrag. (Inherited from TfrxDPIAwarePanel.)
OnUnDock | Represents property OnUnDock. (Inherited from TfrxDPIAwarePanel.)
ParentBackground | Represents property ParentBackground. (Inherited from TfrxDPIAwarePanel.)
ParentBiDiMode | Represents property ParentBiDiMode. (Inherited from TfrxDPIAwarePanel.)
ParentColor | Represents property ParentColor. (Inherited from TfrxDPIAwarePanel.)
ParentCtl3D | Represents property ParentCtl3D. (Inherited from TfrxDPIAwarePanel.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDPIAwarePanel.)
ParentShowHint | Represents property ParentShowHint. (Inherited from TfrxDPIAwarePanel.)
PopupMenu | Represents property PopupMenu. (Inherited from TfrxDPIAwarePanel.)
SavedSize | Represents property SavedSize.
ShowHint | Represents property ShowHint. (Inherited from TfrxDPIAwarePanel.)
TabOrder | Represents property TabOrder. (Inherited from TfrxDPIAwarePanel.)
TabStop | Represents property TabStop. (Inherited from TfrxDPIAwarePanel.)
TopParentWin | Represents property TopParentWin.
UseDockManager | Represents property UseDockManager. (Inherited from TfrxDPIAwarePanel.)
Visible | Represents property Visible. (Inherited from TfrxDPIAwarePanel.)
Top
Methods
Show:
Name | Description
DockDrop(TDragDockObject,Integer,Integer) | Represents method DockDrop(TDragDockObject,Integer,Integer).
DockOver(TDragDockObject,Integer,Integer,TDragState,Boolean) | Represents method DockOver(TDragDockObject,Integer,Integer,TDragState,Boolean).
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Overrides TfrxDPIAwareBasePanel.DoPPIChanged(Integer).)
DoUnDock(TWinControl,TControl) | Represents method DoUnDock(TWinControl,TControl).
GetReleativeScale | Represents method GetReleativeScale. (Inherited from TfrxDPIAwareBasePanel.)
GetScale | Represents method GetScale. (Inherited from TfrxDPIAwareBasePanel.)
ReloadDockedControl(string,TControl) | Represents method ReloadDockedControl(string,TControl).
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxDPIAwareBasePanel.)
SetBounds(Integer,Integer,Integer,Integer) | Represents method SetBounds(Integer,Integer,Integer,Integer).
SetParent(TWinControl) | Represents method SetParent(TWinControl).
UpdateAlign | Represents method UpdateAlign.
Top
Fields
Show:
Name | Description
FPanelSize | Represents field FPanelSize.
FSavedSize | Represents field FSavedSize.
FSplitter | Represents field FSplitter.
FTopParentWin | Represents field FTopParentWin.
Top
See Also

Reference

  • frxDock


TfrxDockSite Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDockSite class. (Overrides TfrxDPIAwareBasePanel.Create(TComponent).)
Top


TfrxDockSite.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDockSite class.

Namespace: frxDock
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDPIAwareBasePanel.Create(TComponent)
See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite Properties

Properties
Name | Description
SavedSize | Represents property SavedSize.
TopParentWin | Represents property TopParentWin.
Top


TfrxDockSite.SavedSize Property

Summary

Represents property SavedSize.

Namespace: frxDock
Syntax
Delphi
public
 property SavedSize: Integer read FSavedSize write FSavedSize;

Property Value

Type: Integer

See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite.TopParentWin Property

Summary

Represents property TopParentWin.

Namespace: frxDock
Syntax
Delphi
public
 property TopParentWin: TWinControl read FTopParentWin write FTopParentWin;

Property Value

Type: TWinControl

See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite Methods

Methods
Name | Description
DockDrop(TDragDockObject,Integer,Integer) | Represents method DockDrop(TDragDockObject,Integer,Integer).
DockOver(TDragDockObject,Integer,Integer,TDragState,Boolean) | Represents method DockOver(TDragDockObject,Integer,Integer,TDragState,Boolean).
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Overrides TfrxDPIAwareBasePanel.DoPPIChanged(Integer).)
DoUnDock(TWinControl,TControl) | Represents method DoUnDock(TWinControl,TControl).
ReloadDockedControl(string,TControl) | Represents method ReloadDockedControl(string,TControl).
SetBounds(Integer,Integer,Integer,Integer) | Represents method SetBounds(Integer,Integer,Integer,Integer).
SetParent(TWinControl) | Represents method SetParent(TWinControl).
UpdateAlign | Represents method UpdateAlign.
Top


TfrxDockSite.DockDrop(TDragDockObject,Integer,Integer) Method

Summary

Represents method DockDrop(TDragDockObject,Integer,Integer).

Namespace: frxDock
Syntax
Delphi
public
 procedure DockDrop(Source: TDragDockObject; X, Y: Integer); override;

Parameters

Source
Type: TDragDockObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite.DockOver(TDragDockObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method DockOver(TDragDockObject,Integer,Integer,TDragState,Boolean).

Namespace: frxDock
Syntax
Delphi
public
 procedure DockOver(Source: TDragDockObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean); override;

Parameters

Source
Type: TDragDockObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite.DoPPIChanged(Integer) Method

Summary

Represents method DoPPIChanged(Integer).

Namespace: frxDock
Syntax
Delphi
protected
 procedure DoPPIChanged(aNewPPI: Integer); override;

Parameters

aNewPPI
Type: Integer

Overrides

TfrxDPIAwareBasePanel.DoPPIChanged(Integer)
See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite.DoUnDock(TWinControl,TControl) Method

Summary

Represents method DoUnDock(TWinControl,TControl).

Namespace: frxDock
Syntax
Delphi
public
 function DoUnDock(NewTarget: TWinControl; Client: TControl
 ): Boolean; override;

Parameters

NewTarget
Type: TWinControl

Client
Type: TControl

Return Value

Type: Boolean

See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite.ReloadDockedControl(string,TControl) Method

Summary

Represents method ReloadDockedControl(string,TControl).

Namespace: frxDock
Syntax
Delphi
public
 procedure ReloadDockedControl(const AControlName: string;
 var AControl: TControl); override;

Parameters

AControlName
Type: string

AControl
Type: TControl

See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite.SetBounds(Integer,Integer,Integer,Integer) Method

Summary

Represents method SetBounds(Integer,Integer,Integer,Integer).

Namespace: frxDock
Syntax
Delphi
public
 procedure SetBounds(ALeft, ATop, AWidth, AHeight: Integer); override;

Parameters

ALeft
Type: Integer

ATop
Type: Integer

AWidth
Type: Integer

AHeight
Type: Integer

See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite.SetParent(TWinControl) Method

Summary

Represents method SetParent(TWinControl).

Namespace: frxDock
Syntax
Delphi
public
 procedure SetParent(AParent: TWinControl); override;

Parameters

AParent
Type: TWinControl

See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite.UpdateAlign Method

Summary

Represents method UpdateAlign.

Namespace: frxDock
Syntax
Delphi
public
 procedure UpdateAlign;
See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite Fields

Fields
Name | Description
FPanelSize | Represents field FPanelSize.
FSavedSize | Represents field FSavedSize.
FSplitter | Represents field FSplitter.
FTopParentWin | Represents field FTopParentWin.
Top


TfrxDockSite.FPanelSize Field

Summary

Represents field FPanelSize.

Namespace: frxDock
Syntax
Delphi
private
 FPanelSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite.FSavedSize Field

Summary

Represents field FSavedSize.

Namespace: frxDock
Syntax
Delphi
private
 FSavedSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite.FSplitter Field

Summary

Represents field FSplitter.

Namespace: frxDock
Syntax
Delphi
private
 FSplitter: TControl;

Field Value

Type: TControl

See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxDockSite.FTopParentWin Field

Summary

Represents field FTopParentWin.

Namespace: frxDock
Syntax
Delphi
private
 FTopParentWin: TWinControl;

Field Value

Type: TWinControl

See Also

Reference

  • TfrxDockSite
  • frxDock


TfrxTBPanel Class

Summary

Represents type TfrxTBPanel.

Namespace: frxDock
Inheritance Hierarchy
TPanel
frxDock.TfrxTBPanel
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxTBPanel = class(TPanel)
 end;

The TfrxTBPanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTBPanel class.
Top
Methods
Show:
Name | Description
Paint | Represents method Paint.
SetParent(TWinControl) | Represents method SetParent(TWinControl).
Top
See Also

Reference

  • frxDock


TfrxTBPanel Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTBPanel class.
Top


TfrxTBPanel.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxTBPanel class.

Namespace: frxDock
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxTBPanel
  • frxDock


TfrxTBPanel Methods

Methods
Name | Description
Paint | Represents method Paint.
SetParent(TWinControl) | Represents method SetParent(TWinControl).
Top


TfrxTBPanel.Paint Method

Summary

Represents method Paint.

Namespace: frxDock
Syntax
Delphi
public
 procedure Paint; override;
See Also

Reference

  • TfrxTBPanel
  • frxDock


TfrxTBPanel.SetParent(TWinControl) Method

Summary

Represents method SetParent(TWinControl).

Namespace: frxDock
Syntax
Delphi
protected
 procedure SetParent(AParent:TWinControl); override;

Parameters

AParent
Type: TWinControl

See Also

Reference

  • TfrxTBPanel
  • frxDock


frxDock Routines

Routines
Name | Description
frxRestoreDock(TCustomIniFile,TfrxDockSite) | Represents method frxRestoreDock(TCustomIniFile,TfrxDockSite).
frxRestoreFormPosition(TCustomIniFile,TForm,Single) | Represents method frxRestoreFormPosition(TCustomIniFile,TForm,Single).
frxRestoreToolbarPosition(TCustomIniFile,TToolBar,Integer) | Represents method frxRestoreToolbarPosition(TCustomIniFile,TToolBar,Integer).
frxSaveDock(TCustomIniFile,TfrxDockSite,Single) | Represents method frxSaveDock(TCustomIniFile,TfrxDockSite,Single).
frxSaveFormPosition(TCustomIniFile,TForm,Single) | Represents method frxSaveFormPosition(TCustomIniFile,TForm,Single).
frxSaveToolbarPosition(TCustomIniFile,TToolBar,Single) | Represents method frxSaveToolbarPosition(TCustomIniFile,TToolBar,Single).
Top


frxRestoreDock(TCustomIniFile,TfrxDockSite) Method

Summary

Represents method frxRestoreDock(TCustomIniFile,TfrxDockSite).

Namespace: frxDock
Syntax
Delphi
procedure frxRestoreDock(Ini: TCustomIniFile; d: TfrxDockSite);

Parameters

Ini
Type: TCustomIniFile

d
Type: TfrxDockSite

See Also

Reference

  • frxDock


frxRestoreFormPosition(TCustomIniFile,TForm,Single) Method

Summary

Represents method frxRestoreFormPosition(TCustomIniFile,TForm,Single).

Namespace: frxDock
Syntax
Delphi
procedure frxRestoreFormPosition(Ini: TCustomIniFile; f: TForm; FormPPIScale: Single);

Parameters

Ini
Type: TCustomIniFile

f
Type: TForm

FormPPIScale
Type: Single

See Also

Reference

  • frxDock


frxRestoreToolbarPosition(TCustomIniFile,TToolBar,Integer) Method

Summary

Represents method frxRestoreToolbarPosition(TCustomIniFile,TToolBar,Integer).

Namespace: frxDock
Syntax
Delphi
procedure frxRestoreToolbarPosition(Ini: TCustomIniFile; t: TToolBar; CurrentFormPPI: Integer);

Parameters

Ini
Type: TCustomIniFile

t
Type: TToolBar

CurrentFormPPI
Type: Integer

See Also

Reference

  • frxDock


frxSaveDock(TCustomIniFile,TfrxDockSite,Single) Method

Summary

Represents method frxSaveDock(TCustomIniFile,TfrxDockSite,Single).

Namespace: frxDock
Syntax
Delphi
procedure frxSaveDock(Ini: TCustomIniFile; d: TfrxDockSite; FormPPIScale: Single);

Parameters

Ini
Type: TCustomIniFile

d
Type: TfrxDockSite

FormPPIScale
Type: Single

See Also

Reference

  • frxDock


frxSaveFormPosition(TCustomIniFile,TForm,Single) Method

Summary

Represents method frxSaveFormPosition(TCustomIniFile,TForm,Single).

Namespace: frxDock
Syntax
Delphi
procedure frxSaveFormPosition(Ini: TCustomIniFile; f: TForm; FormPPIScale: Single);

Parameters

Ini
Type: TCustomIniFile

f
Type: TForm

FormPPIScale
Type: Single

See Also

Reference

  • frxDock


frxSaveToolbarPosition(TCustomIniFile,TToolBar,Single) Method

Summary

Represents method frxSaveToolbarPosition(TCustomIniFile,TToolBar,Single).

Namespace: frxDock
Syntax
Delphi
procedure frxSaveToolbarPosition(Ini: TCustomIniFile; t: TToolBar; FormPPIScale: Single);

Parameters

Ini
Type: TCustomIniFile

t
Type: TToolBar

FormPPIScale
Type: Single

See Also

Reference

  • frxDock


frxDPIAwareBaseControls Namespace

Summary

Represents namespace frxDPIAwareBaseControls.

Classes
Name | Description
TfrxDPIAwareBasePanel | Represents type TfrxDPIAwareBasePanel.
TfrxDPIAwareCustomControl | Represents type TfrxDPIAwareCustomControl.
TfrxDPIAwarePanel | Represents type TfrxDPIAwarePanel.
Top


frxDPIAwareBaseControls Classes

Classes
Name | Description
TfrxDPIAwareBasePanel | Represents type TfrxDPIAwareBasePanel.
TfrxDPIAwareCustomControl | Represents type TfrxDPIAwareCustomControl.
TfrxDPIAwarePanel | Represents type TfrxDPIAwarePanel.
Top


TfrxDPIAwareBasePanel Class

Summary

Represents type TfrxDPIAwareBasePanel.

Namespace: frxDPIAwareBaseControls
Inheritance Hierarchy
TCustomPanel
frxDPIAwareBaseControls.TfrxDPIAwareBasePanel
frxCtrls.TfrxCustomFilterEdit
frxDPIAwareBaseControls.TfrxDPIAwarePanel
Syntax
Delphi
type
 TfrxDPIAwareBasePanel = class(TCustomPanel)
 end;

The TfrxDPIAwareBasePanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDPIAwareBasePanel class.
Top
Properties
Show:
Name | Description
CurrentPPI | Represents property CurrentPPI.
Top
Methods
Show:
Name | Description
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer).
GetReleativeScale | Represents method GetReleativeScale.
GetScale | Represents method GetScale.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer).
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage).
Top
Fields
Show:
Name | Description
FCurrentPPI | Represents field FCurrentPPI.
Top
See Also

Reference

  • frxDPIAwareBaseControls


TfrxDPIAwareBasePanel Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDPIAwareBasePanel class.
Top


TfrxDPIAwareBasePanel.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDPIAwareBasePanel class.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxDPIAwareBasePanel
  • frxDPIAwareBaseControls


TfrxDPIAwareBasePanel Properties

Properties
Name | Description
CurrentPPI | Represents property CurrentPPI.
Top


TfrxDPIAwareBasePanel.CurrentPPI Property

Summary

Represents property CurrentPPI.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
public
 property CurrentPPI: Integer read FCurrentPPI write FCurrentPPI;

Property Value

Type: Integer

See Also

Reference

  • TfrxDPIAwareBasePanel
  • frxDPIAwareBaseControls


TfrxDPIAwareBasePanel Methods

Methods
Name | Description
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer).
GetReleativeScale | Represents method GetReleativeScale.
GetScale | Represents method GetScale.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer).
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage).
Top


TfrxDPIAwareBasePanel.DoPPIChanged(Integer) Method

Summary

Represents method DoPPIChanged(Integer).

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
protected
 procedure DoPPIChanged(aNewPPI: Integer); virtual;

Parameters

aNewPPI
Type: Integer

See Also

Reference

  • TfrxDPIAwareBasePanel
  • frxDPIAwareBaseControls


TfrxDPIAwareBasePanel.GetReleativeScale Method

Summary

Represents method GetReleativeScale.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
public
 function GetReleativeScale: Single;

Return Value

Type: Single

See Also

Reference

  • TfrxDPIAwareBasePanel
  • frxDPIAwareBaseControls


TfrxDPIAwareBasePanel.GetScale Method

Summary

Represents method GetScale.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
public
 function GetScale: Single;

Return Value

Type: Single

See Also

Reference

  • TfrxDPIAwareBasePanel
  • frxDPIAwareBaseControls


TfrxDPIAwareBasePanel.ScaleForPPI(Integer) Method

Summary

Represents method ScaleForPPI(Integer).

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
public
 procedure ScaleForPPI(NewPPI: Integer); override;

Parameters

NewPPI
Type: Integer

See Also

Reference

  • TfrxDPIAwareBasePanel
  • frxDPIAwareBaseControls


TfrxDPIAwareBasePanel.WMDpiChanged(TMessage) Method

Summary

Represents method WMDpiChanged(TMessage).

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
private
 procedure WMDpiChanged(var Message: TMessage); message FRX_WM_DPICHANGED_AFTERPARENT;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxDPIAwareBasePanel
  • frxDPIAwareBaseControls


TfrxDPIAwareBasePanel Fields

Fields
Name | Description
FCurrentPPI | Represents field FCurrentPPI.
Top


TfrxDPIAwareBasePanel.FCurrentPPI Field

Summary

Represents field FCurrentPPI.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
private
 FCurrentPPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDPIAwareBasePanel
  • frxDPIAwareBaseControls


TfrxDPIAwareCustomControl Class

Summary

Represents type TfrxDPIAwareCustomControl.

Namespace: frxDPIAwareBaseControls
Inheritance Hierarchy
TCustomControl
frxDPIAwareBaseControls.TfrxDPIAwareCustomControl
frxDesgnCtrls.TfrxLineStyleControl
Syntax
Delphi
type
 TfrxDPIAwareCustomControl = class(TCustomControl)
 end;

The TfrxDPIAwareCustomControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDPIAwareCustomControl class.
Top
Properties
Show:
Name | Description
CurrentPPI | Represents property CurrentPPI.
Top
Methods
Show:
Name | Description
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer).
GetReleativeScale | Represents method GetReleativeScale.
GetScale | Represents method GetScale.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer).
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage).
Top
Fields
Show:
Name | Description
FCurrentPPI | Represents field FCurrentPPI.
Top
See Also

Reference

  • frxDPIAwareBaseControls


TfrxDPIAwareCustomControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDPIAwareCustomControl class.
Top


TfrxDPIAwareCustomControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDPIAwareCustomControl class.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxDPIAwareCustomControl
  • frxDPIAwareBaseControls


TfrxDPIAwareCustomControl Properties

Properties
Name | Description
CurrentPPI | Represents property CurrentPPI.
Top


TfrxDPIAwareCustomControl.CurrentPPI Property

Summary

Represents property CurrentPPI.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
public
 property CurrentPPI: Integer read FCurrentPPI write FCurrentPPI;

Property Value

Type: Integer

See Also

Reference

  • TfrxDPIAwareCustomControl
  • frxDPIAwareBaseControls


TfrxDPIAwareCustomControl Methods

Methods
Name | Description
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer).
GetReleativeScale | Represents method GetReleativeScale.
GetScale | Represents method GetScale.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer).
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage).
Top


TfrxDPIAwareCustomControl.DoPPIChanged(Integer) Method

Summary

Represents method DoPPIChanged(Integer).

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
protected
 procedure DoPPIChanged(aNewPPI: Integer); virtual;

Parameters

aNewPPI
Type: Integer

See Also

Reference

  • TfrxDPIAwareCustomControl
  • frxDPIAwareBaseControls


TfrxDPIAwareCustomControl.GetReleativeScale Method

Summary

Represents method GetReleativeScale.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
public
 function GetReleativeScale: Single;

Return Value

Type: Single

See Also

Reference

  • TfrxDPIAwareCustomControl
  • frxDPIAwareBaseControls


TfrxDPIAwareCustomControl.GetScale Method

Summary

Represents method GetScale.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
public
 function GetScale: Single;

Return Value

Type: Single

See Also

Reference

  • TfrxDPIAwareCustomControl
  • frxDPIAwareBaseControls


TfrxDPIAwareCustomControl.ScaleForPPI(Integer) Method

Summary

Represents method ScaleForPPI(Integer).

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
public
 procedure ScaleForPPI(NewPPI: Integer); override;

Parameters

NewPPI
Type: Integer

See Also

Reference

  • TfrxDPIAwareCustomControl
  • frxDPIAwareBaseControls


TfrxDPIAwareCustomControl.WMDpiChanged(TMessage) Method

Summary

Represents method WMDpiChanged(TMessage).

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
private
 procedure WMDpiChanged(var Message: TMessage); message FRX_WM_DPICHANGED_AFTERPARENT;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxDPIAwareCustomControl
  • frxDPIAwareBaseControls


TfrxDPIAwareCustomControl Fields

Fields
Name | Description
FCurrentPPI | Represents field FCurrentPPI.
Top


TfrxDPIAwareCustomControl.FCurrentPPI Field

Summary

Represents field FCurrentPPI.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
private
 FCurrentPPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDPIAwareCustomControl
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel Class

Summary

Represents type TfrxDPIAwarePanel.

Namespace: frxDPIAwareBaseControls
Inheritance Hierarchy
TCustomPanel
frxDPIAwareBaseControls.TfrxDPIAwareBasePanel
frxDPIAwareBaseControls.TfrxDPIAwarePanel
frxComCtrls.TfrxToolPanel
frxComCtrls.TfrxTreePanel
frxDesgnCtrls.TfrxCustomSelector
frxDesgnCtrls.TfrxRuler
frxDock.TfrxDockSite
Syntax
Delphi
type
 TfrxDPIAwarePanel = class(TfrxDPIAwareBasePanel)
 end;

The TfrxDPIAwarePanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDPIAwareBasePanel class. (Inherited from TfrxDPIAwareBasePanel.)
Top
Properties
Show:
Name | Description
Align | Represents property Align.
Alignment | Represents property Alignment.
Anchors | Represents property Anchors.
AutoSize | Represents property AutoSize.
BevelInner | Represents property BevelInner.
BevelKind | Represents property BevelKind.
BevelOuter | Represents property BevelOuter.
BevelWidth | Represents property BevelWidth.
BiDiMode | Represents property BiDiMode.
BorderStyle | Represents property BorderStyle.
BorderWidth | Represents property BorderWidth.
Caption | Represents property Caption.
Color | Represents property Color.
Constraints | Represents property Constraints.
Ctl3D | Represents property Ctl3D.
CurrentPPI | Represents property CurrentPPI. (Inherited from TfrxDPIAwareBasePanel.)
DockManager | Represents property DockManager.
DockSite | Represents property DockSite.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
Enabled | Represents property Enabled.
Font | Represents property Font.
FullRepaint | Represents property FullRepaint.
Locked | Represents property Locked.
OnCanResize | Represents property OnCanResize.
OnClick | Represents property OnClick.
OnConstrainedResize | Represents property OnConstrainedResize.
OnContextPopup | Represents property OnContextPopup.
OnDblClick | Represents property OnDblClick.
OnDockDrop | Represents property OnDockDrop.
OnDockOver | Represents property OnDockOver.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnGetSiteInfo | Represents property OnGetSiteInfo.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnMouseWheel | Represents property OnMouseWheel.
OnMouseWheelDown | Represents property OnMouseWheelDown.
OnMouseWheelUp | Represents property OnMouseWheelUp.
OnResize | Represents property OnResize.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
OnUnDock | Represents property OnUnDock.
ParentBackground | Represents property ParentBackground.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentColor | Represents property ParentColor.
ParentCtl3D | Represents property ParentCtl3D.
ParentFont | Represents property ParentFont.
ParentShowHint | Represents property ParentShowHint.
PopupMenu | Represents property PopupMenu.
ShowHint | Represents property ShowHint.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
UseDockManager | Represents property UseDockManager.
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Inherited from TfrxDPIAwareBasePanel.)
GetReleativeScale | Represents method GetReleativeScale. (Inherited from TfrxDPIAwareBasePanel.)
GetScale | Represents method GetScale. (Inherited from TfrxDPIAwareBasePanel.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxDPIAwareBasePanel.)
Top
See Also

Reference

  • frxDPIAwareBaseControls


TfrxDPIAwarePanel Properties

Properties
Name | Description
Align | Represents property Align.
Alignment | Represents property Alignment.
Anchors | Represents property Anchors.
AutoSize | Represents property AutoSize.
BevelInner | Represents property BevelInner.
BevelKind | Represents property BevelKind.
BevelOuter | Represents property BevelOuter.
BevelWidth | Represents property BevelWidth.
BiDiMode | Represents property BiDiMode.
BorderStyle | Represents property BorderStyle.
BorderWidth | Represents property BorderWidth.
Caption | Represents property Caption.
Color | Represents property Color.
Constraints | Represents property Constraints.
Ctl3D | Represents property Ctl3D.
DockManager | Represents property DockManager.
DockSite | Represents property DockSite.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
Enabled | Represents property Enabled.
Font | Represents property Font.
FullRepaint | Represents property FullRepaint.
Locked | Represents property Locked.
OnCanResize | Represents property OnCanResize.
OnClick | Represents property OnClick.
OnConstrainedResize | Represents property OnConstrainedResize.
OnContextPopup | Represents property OnContextPopup.
OnDblClick | Represents property OnDblClick.
OnDockDrop | Represents property OnDockDrop.
OnDockOver | Represents property OnDockOver.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnGetSiteInfo | Represents property OnGetSiteInfo.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnMouseWheel | Represents property OnMouseWheel.
OnMouseWheelDown | Represents property OnMouseWheelDown.
OnMouseWheelUp | Represents property OnMouseWheelUp.
OnResize | Represents property OnResize.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
OnUnDock | Represents property OnUnDock.
ParentBackground | Represents property ParentBackground.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentColor | Represents property ParentColor.
ParentCtl3D | Represents property ParentCtl3D.
ParentFont | Represents property ParentFont.
ParentShowHint | Represents property ParentShowHint.
PopupMenu | Represents property PopupMenu.
ShowHint | Represents property ShowHint.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
UseDockManager | Represents property UseDockManager.
Visible | Represents property Visible.
Top


TfrxDPIAwarePanel.Align Property

Summary

Represents property Align.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property Align;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.Alignment Property

Summary

Represents property Alignment.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property Alignment;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.Anchors Property

Summary

Represents property Anchors.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.AutoSize Property

Summary

Represents property AutoSize.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property AutoSize;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.BevelInner Property

Summary

Represents property BevelInner.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property BevelInner;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.BevelKind Property

Summary

Represents property BevelKind.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property BevelKind;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.BevelOuter Property

Summary

Represents property BevelOuter.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property BevelOuter;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.BevelWidth Property

Summary

Represents property BevelWidth.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property BevelWidth;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.BiDiMode Property

Summary

Represents property BiDiMode.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property BiDiMode;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.BorderStyle Property

Summary

Represents property BorderStyle.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property BorderStyle;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.BorderWidth Property

Summary

Represents property BorderWidth.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property BorderWidth;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.Caption Property

Summary

Represents property Caption.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property Caption;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.Color Property

Summary

Represents property Color.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.Constraints Property

Summary

Represents property Constraints.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property Constraints;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.Ctl3D Property

Summary

Represents property Ctl3D.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property Ctl3D;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.DockManager Property

Summary

Represents property DockManager.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
public
 property DockManager;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.DockSite Property

Summary

Represents property DockSite.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property DockSite;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.DragCursor Property

Summary

Represents property DragCursor.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property DragCursor;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.DragKind Property

Summary

Represents property DragKind.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property DragKind;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.DragMode Property

Summary

Represents property DragMode.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property DragMode;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.Enabled Property

Summary

Represents property Enabled.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property Enabled;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.Font Property

Summary

Represents property Font.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.FullRepaint Property

Summary

Represents property FullRepaint.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property FullRepaint;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.Locked Property

Summary

Represents property Locked.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property Locked;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnCanResize Property

Summary

Represents property OnCanResize.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnCanResize;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnClick Property

Summary

Represents property OnClick.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnConstrainedResize Property

Summary

Represents property OnConstrainedResize.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnConstrainedResize;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnContextPopup Property

Summary

Represents property OnContextPopup.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnContextPopup;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnDockDrop Property

Summary

Represents property OnDockDrop.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnDockDrop;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnDockOver Property

Summary

Represents property OnDockOver.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnDockOver;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnDragDrop Property

Summary

Represents property OnDragDrop.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnDragDrop;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnDragOver Property

Summary

Represents property OnDragOver.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnDragOver;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnEndDock Property

Summary

Represents property OnEndDock.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnEndDock;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnEndDrag Property

Summary

Represents property OnEndDrag.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnEndDrag;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnExit Property

Summary

Represents property OnExit.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnGetSiteInfo Property

Summary

Represents property OnGetSiteInfo.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnGetSiteInfo;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnMouseWheel Property

Summary

Represents property OnMouseWheel.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnMouseWheel;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnMouseWheelDown Property

Summary

Represents property OnMouseWheelDown.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnMouseWheelDown;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnMouseWheelUp Property

Summary

Represents property OnMouseWheelUp.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnMouseWheelUp;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnResize Property

Summary

Represents property OnResize.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnResize;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnStartDock Property

Summary

Represents property OnStartDock.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnStartDock;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnStartDrag Property

Summary

Represents property OnStartDrag.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnStartDrag;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.OnUnDock Property

Summary

Represents property OnUnDock.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property OnUnDock;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.ParentBackground Property

Summary

Represents property ParentBackground.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property ParentBackground;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.ParentBiDiMode Property

Summary

Represents property ParentBiDiMode.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property ParentBiDiMode;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.ParentColor Property

Summary

Represents property ParentColor.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property ParentColor;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.ParentCtl3D Property

Summary

Represents property ParentCtl3D.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property ParentCtl3D;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.ParentFont Property

Summary

Represents property ParentFont.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property ParentFont;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.ParentShowHint Property

Summary

Represents property ParentShowHint.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property ParentShowHint;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.ShowHint Property

Summary

Represents property ShowHint.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property ShowHint;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.TabOrder Property

Summary

Represents property TabOrder.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property TabOrder;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.TabStop Property

Summary

Represents property TabStop.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.UseDockManager Property

Summary

Represents property UseDockManager.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property UseDockManager default True;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


TfrxDPIAwarePanel.Visible Property

Summary

Represents property Visible.

Namespace: frxDPIAwareBaseControls
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TfrxDPIAwarePanel
  • frxDPIAwareBaseControls


frxDPIAwareInt Namespace

Summary

Represents namespace frxDPIAwareInt.

Records
Name | Description
DPI_AWARENESS_CONTEXT_ | Represents type DPI_AWARENESS_CONTEXT_.
Top
Delegates
Name | Description
TfrxGetDpiForWindow | Represents type TfrxGetDpiForWindow.
TfrxGetThreadDpiAwarenessContext | Represents type TfrxGetThreadDpiAwarenessContext.
TfrxSetProcessDpiAwarenessContext | Represents type TfrxSetProcessDpiAwarenessContext.
TfrxSetThreadDpiAwarenessContext | Represents type TfrxSetThreadDpiAwarenessContext.
Top
Types
Name | Description
FRX_DPI_AWARENESS_CONTEXT | Represents a pointer type to DPI_AWARENESS_CONTEXT_.
Top
Constants
Name | Description
FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE | Represents constant FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE.
FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE_V2 | Represents constant FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE_V2.
FRX_DPI_AWARENESS_CONTEXT_SYSTEM_AWARE | Represents constant FRX_DPI_AWARENESS_CONTEXT_SYSTEM_AWARE.
FRX_DPI_AWARENESS_CONTEXT_UNAWARE | Represents constant FRX_DPI_AWARENESS_CONTEXT_UNAWARE.
FRX_DPI_AWARENESS_CONTEXT_UNAWARE_GDISCALED | Represents constant FRX_DPI_AWARENESS_CONTEXT_UNAWARE_GDISCALED.
FRX_WM_DPICHANGED | Represents constant FRX_WM_DPICHANGED.
FRX_WM_DPICHANGED_AFTERPARENT | Represents constant FRX_WM_DPICHANGED_AFTERPARENT.
Top
Routines
Name | Description
frxGetDpiForWindow(NativeInt) | Represents method frxGetDpiForWindow(NativeInt).
frxGetThreadDpiAwarenessContext | Represents method frxGetThreadDpiAwarenessContext.
frxSetProcessDpiAwarenessContext(FRX_DPI_AWARENESS_CONTEXT) | Represents method frxSetProcessDpiAwarenessContext(FRX_DPI_AWARENESS_CONTEXT).
frxSetThreadDpiAwarenessContext(FRX_DPI_AWARENESS_CONTEXT) | Represents method frxSetThreadDpiAwarenessContext(FRX_DPI_AWARENESS_CONTEXT).
Top


frxDPIAwareInt Records

Records
Name | Description
DPI_AWARENESS_CONTEXT_ | Represents type DPI_AWARENESS_CONTEXT_.
Top


DPI_AWARENESS_CONTEXT_ Record

Summary

Represents type DPI_AWARENESS_CONTEXT_.

Namespace: frxDPIAwareInt
Syntax
Delphi
type
 DPI_AWARENESS_CONTEXT_ = record
 end;

The DPI_AWARENESS_CONTEXT_ type exposes the following members.

Fields
Show:
Name | Description
unused_ | Represents field unused_.
Top
See Also

Reference

  • frxDPIAwareInt


DPI_AWARENESS_CONTEXT_ Fields

Fields
Name | Description
unused_ | Represents field unused_.
Top


DPI_AWARENESS_CONTEXT_.unused_ Field

Summary

Represents field unused_.

Namespace: frxDPIAwareInt
Syntax
Delphi
public
 unused_: Integer;

Field Value

Type: Integer

See Also

Reference

  • DPI_AWARENESS_CONTEXT_
  • frxDPIAwareInt


frxDPIAwareInt Delegates

Delegates
Name | Description
TfrxGetDpiForWindow | Represents type TfrxGetDpiForWindow.
TfrxGetThreadDpiAwarenessContext | Represents type TfrxGetThreadDpiAwarenessContext.
TfrxSetProcessDpiAwarenessContext | Represents type TfrxSetProcessDpiAwarenessContext.
TfrxSetThreadDpiAwarenessContext | Represents type TfrxSetThreadDpiAwarenessContext.
Top


TfrxGetDpiForWindow Delegate

Summary

Represents type TfrxGetDpiForWindow.

Namespace: frxDPIAwareInt
Syntax
Delphi
type
 TfrxGetDpiForWindow = function(hwnd: HWND): UINT; stdcall;
See Also

Reference

  • frxDPIAwareInt


TfrxGetThreadDpiAwarenessContext Delegate

Summary

Represents type TfrxGetThreadDpiAwarenessContext.

Namespace: frxDPIAwareInt
Syntax
Delphi
type
 TfrxGetThreadDpiAwarenessContext = function(): FRX_DPI_AWARENESS_CONTEXT; stdcall;
See Also

Reference

  • frxDPIAwareInt


TfrxSetProcessDpiAwarenessContext Delegate

Summary

Represents type TfrxSetProcessDpiAwarenessContext.

Namespace: frxDPIAwareInt
Syntax
Delphi
type
 TfrxSetProcessDpiAwarenessContext = function(value: FRX_DPI_AWARENESS_CONTEXT): BOOL; stdcall;
See Also

Reference

  • frxDPIAwareInt


TfrxSetThreadDpiAwarenessContext Delegate

Summary

Represents type TfrxSetThreadDpiAwarenessContext.

Namespace: frxDPIAwareInt
Syntax
Delphi
type
 TfrxSetThreadDpiAwarenessContext = function(value: FRX_DPI_AWARENESS_CONTEXT): BOOL; stdcall;
See Also

Reference

  • frxDPIAwareInt


frxDPIAwareInt Types

Types
Name | Description
FRX_DPI_AWARENESS_CONTEXT | Represents a pointer type to DPI_AWARENESS_CONTEXT_.
Top


FRX_DPI_AWARENESS_CONTEXT Type

Summary

Represents a pointer type to DPI_AWARENESS_CONTEXT_.

Namespace: frxDPIAwareInt
Syntax
Delphi
type
 FRX_DPI_AWARENESS_CONTEXT = ^DPI_AWARENESS_CONTEXT_;
See Also

Reference

  • frxDPIAwareInt


frxDPIAwareInt Constants

Constants
Name | Description
FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE | Represents constant FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE.
FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE_V2 | Represents constant FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE_V2.
FRX_DPI_AWARENESS_CONTEXT_SYSTEM_AWARE | Represents constant FRX_DPI_AWARENESS_CONTEXT_SYSTEM_AWARE.
FRX_DPI_AWARENESS_CONTEXT_UNAWARE | Represents constant FRX_DPI_AWARENESS_CONTEXT_UNAWARE.
FRX_DPI_AWARENESS_CONTEXT_UNAWARE_GDISCALED | Represents constant FRX_DPI_AWARENESS_CONTEXT_UNAWARE_GDISCALED.
FRX_WM_DPICHANGED | Represents constant FRX_WM_DPICHANGED.
FRX_WM_DPICHANGED_AFTERPARENT | Represents constant FRX_WM_DPICHANGED_AFTERPARENT.
Top


FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE Constant

Summary

Represents constant FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE.

Namespace: frxDPIAwareInt
Syntax
Delphi
 FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE: FRX_DPI_AWARENESS_CONTEXT = FRX_DPI_AWARENESS_CONTEXT(-3);

Value

Type: FRX_DPI_AWARENESS_CONTEXT

See Also

Reference

  • frxDPIAwareInt


FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE_V2 Constant

Summary

Represents constant FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE_V2.

Namespace: frxDPIAwareInt
Syntax
Delphi
 FRX_DPI_AWARENESS_CONTEXT_PER_MONITOR_AWARE_V2: FRX_DPI_AWARENESS_CONTEXT = FRX_DPI_AWARENESS_CONTEXT(-4);

Value

Type: FRX_DPI_AWARENESS_CONTEXT

See Also

Reference

  • frxDPIAwareInt


FRX_DPI_AWARENESS_CONTEXT_SYSTEM_AWARE Constant

Summary

Represents constant FRX_DPI_AWARENESS_CONTEXT_SYSTEM_AWARE.

Namespace: frxDPIAwareInt
Syntax
Delphi
 FRX_DPI_AWARENESS_CONTEXT_SYSTEM_AWARE: FRX_DPI_AWARENESS_CONTEXT = FRX_DPI_AWARENESS_CONTEXT(-2);

Value

Type: FRX_DPI_AWARENESS_CONTEXT

See Also

Reference

  • frxDPIAwareInt


FRX_DPI_AWARENESS_CONTEXT_UNAWARE Constant

Summary

Represents constant FRX_DPI_AWARENESS_CONTEXT_UNAWARE.

Namespace: frxDPIAwareInt
Syntax
Delphi
 FRX_DPI_AWARENESS_CONTEXT_UNAWARE: FRX_DPI_AWARENESS_CONTEXT = FRX_DPI_AWARENESS_CONTEXT(-1);

Value

Type: FRX_DPI_AWARENESS_CONTEXT

See Also

Reference

  • frxDPIAwareInt


FRX_DPI_AWARENESS_CONTEXT_UNAWARE_GDISCALED Constant

Summary

Represents constant FRX_DPI_AWARENESS_CONTEXT_UNAWARE_GDISCALED.

Namespace: frxDPIAwareInt
Syntax
Delphi
 FRX_DPI_AWARENESS_CONTEXT_UNAWARE_GDISCALED: FRX_DPI_AWARENESS_CONTEXT = FRX_DPI_AWARENESS_CONTEXT(-5);

Value

Type: FRX_DPI_AWARENESS_CONTEXT

See Also

Reference

  • frxDPIAwareInt


FRX_WM_DPICHANGED Constant

Summary

Represents constant FRX_WM_DPICHANGED.

Namespace: frxDPIAwareInt
Syntax
Delphi
 FRX_WM_DPICHANGED = $02E0;

Value

Type: SmallInt

See Also

Reference

  • frxDPIAwareInt


FRX_WM_DPICHANGED_AFTERPARENT Constant

Summary

Represents constant FRX_WM_DPICHANGED_AFTERPARENT.

Namespace: frxDPIAwareInt
Syntax
Delphi
 FRX_WM_DPICHANGED_AFTERPARENT = $02E3;

Value

Type: SmallInt

See Also

Reference

  • frxDPIAwareInt


frxDPIAwareInt Routines

Routines
Name | Description
frxGetDpiForWindow(NativeInt) | Represents method frxGetDpiForWindow(NativeInt).
frxGetThreadDpiAwarenessContext | Represents method frxGetThreadDpiAwarenessContext.
frxSetProcessDpiAwarenessContext(FRX_DPI_AWARENESS_CONTEXT) | Represents method frxSetProcessDpiAwarenessContext(FRX_DPI_AWARENESS_CONTEXT).
frxSetThreadDpiAwarenessContext(FRX_DPI_AWARENESS_CONTEXT) | Represents method frxSetThreadDpiAwarenessContext(FRX_DPI_AWARENESS_CONTEXT).
Top


frxGetDpiForWindow(NativeInt) Method

Summary

Represents method frxGetDpiForWindow(NativeInt).

Namespace: frxDPIAwareInt
Syntax
Delphi
function frxGetDpiForWindow(aHwnd: NativeInt): UINT;

Parameters

aHwnd
Type: NativeInt

Return Value

Type: UINT

See Also

Reference

  • frxDPIAwareInt


frxGetThreadDpiAwarenessContext Method

Summary

Represents method frxGetThreadDpiAwarenessContext.

Namespace: frxDPIAwareInt
Syntax
Delphi
function frxGetThreadDpiAwarenessContext: FRX_DPI_AWARENESS_CONTEXT;

Return Value

Type: FRX_DPI_AWARENESS_CONTEXT

See Also

Reference

  • frxDPIAwareInt


frxSetProcessDpiAwarenessContext(FRX_DPI_AWARENESS_CONTEXT) Method

Summary

Represents method frxSetProcessDpiAwarenessContext(FRX_DPI_AWARENESS_CONTEXT).

Namespace: frxDPIAwareInt
Syntax
Delphi
function frxSetProcessDpiAwarenessContext(value: FRX_DPI_AWARENESS_CONTEXT): LongBool;

Parameters

value
Type: FRX_DPI_AWARENESS_CONTEXT

Return Value

Type: LongBool

See Also

Reference

  • frxDPIAwareInt


frxSetThreadDpiAwarenessContext(FRX_DPI_AWARENESS_CONTEXT) Method

Summary

Represents method frxSetThreadDpiAwarenessContext(FRX_DPI_AWARENESS_CONTEXT).

Namespace: frxDPIAwareInt
Syntax
Delphi
function frxSetThreadDpiAwarenessContext(value: FRX_DPI_AWARENESS_CONTEXT): LongBool;

Parameters

value
Type: FRX_DPI_AWARENESS_CONTEXT

Return Value

Type: LongBool

See Also

Reference

  • frxDPIAwareInt


frxDsgnIntf Namespace

Summary

Represents namespace frxDsgnIntf.

Classes
Name | Description
TfrxCharProperty | The standard editor of properties of type Char.
TfrxClassNameProperty | The standard editor of properties of type TClass.
TfrxClassProperty | The standard editor of properties of type TObject.
TfrxColorProperty | The standard editor of properties of type TColor.
TfrxComponentEditor | The TfrxComponentEditor class is the base class for all component editors.
TfrxComponentEditorCollection | The TfrxComponentEditorCollection class represents a list of component editors registered in the FastReport. frxComponentEditors global object contains an instance of this class.
TfrxComponentEditorItem | Represents type TfrxComponentEditorItem.
TfrxComponentProperty | The standard editor of properties of type TComponent.
TfrxCursorProperty | The standard editor of properties of type TCursor.
TfrxDateProperty | Represents type TfrxDateProperty.
TfrxDateTimeProperty | Represents type TfrxDateTimeProperty.
TfrxEnumProperty | The standard editor of properties of type Enum.
TfrxExportFilterCollection | The TfrxExportFilterCollection class represents a list of export filters registered in the FastReport. frxExportFilters global object contains an instance of this class.
TfrxExportFilterItem | Represents type TfrxExportFilterItem.
TfrxFloatProperty | The standard editor of properties of type Extended.
TfrxFontCharsetProperty | The standard editor of properties of type TFont.Charset.
TfrxFontNameProperty | The standard editor of properties of type TFont.Name.
TfrxFontProperty | The standard editor of properties of type TFont.
TfrxIntegerProperty | The standard editor of properties of type Integer.
TfrxModalResultProperty | The standard editor of properties of type TModalResult.
TfrxNameProperty | The standard editor of properties of type TComponentName.
TfrxObjectCollection | The TfrxObjectCollection class represents list of objects registered in the FastReport. frxObjects global object contains an instance of this class.
TfrxObjectItem | Represents type TfrxObjectItem.
TfrxPropertyEditor | The TfrxPropertyEditor class is the base class for all property editors.
TfrxPropertyEditorCollection | The TfrxPropertyEditorCollection class represents a list of property editors registered in the FastReport. frxPropertyEditors global object contains an instance of this class.
TfrxPropertyEditorItem | Represents type TfrxPropertyEditorItem.
TfrxPropertyItem | Represents type TfrxPropertyItem.
TfrxPropertyList | Represents type TfrxPropertyList.
TfrxSaveFilterItem | Represents type TfrxSaveFilterItem.
TfrxSaveFiltersCollection | Represents type TfrxSaveFiltersCollection.
TfrxSetElementProperty | The standard editor of properties of type Set element.
TfrxSetProperty | The standard editor of properties of type Set.
TfrxShortCutProperty | The standard editor of properties of type TShortCut.
TfrxStringProperty | The standard editor of properties of type String.
TfrxTimeProperty | Represents type TfrxTimeProperty.
TfrxWizardCollection | The TfrxWizardCollection class represents a list of wizards registered in the FastReport. frxWizards global object contains an instance of this class.
TfrxWizardItem | Represents type TfrxWizardItem.
Top
Enumerations
Name | Description
TfrxObjectCategory | Represents type TfrxObjectCategory.
TfrxPropertyAttribute | Property editor attributes.
Top
Types
Name | Description
TfrxComponentEditorClass | Represents type TfrxComponentEditorClass.
TfrxObjectCategories | Represents type TfrxObjectCategories.
TfrxPropertyAttributes | Property editor attributes.
TfrxPropertyEditorClass | Represents type TfrxPropertyEditorClass.
Top
Routines
Name | Description
frxComponentEditors | List of component editors registered in the FastReport.
frxCreatePropertyList(TList,TfrxCustomDesigner,String) | Represents method frxCreatePropertyList(TList,TfrxCustomDesigner,String).
frxExportFilters | List of export filters registered in the FastReport.
frxHideProperties(TClass,String) | Represents method frxHideProperties(TClass,String).
frxObjects | List of add-in objects registered in the FastReport.
frxPropertyEditors | List of property editors registered in the FastReport.
frxWizards | List of wizards registered in the FastReport.
Top


frxDsgnIntf Classes

Classes
Name | Description
TfrxCharProperty | The standard editor of properties of type Char.
TfrxClassNameProperty | The standard editor of properties of type TClass.
TfrxClassProperty | The standard editor of properties of type TObject.
TfrxColorProperty | The standard editor of properties of type TColor.
TfrxComponentEditor | The TfrxComponentEditor class is the base class for all component editors.
TfrxComponentEditorCollection | The TfrxComponentEditorCollection class represents a list of component editors registered in the FastReport. frxComponentEditors global object contains an instance of this class.
TfrxComponentEditorItem | Represents type TfrxComponentEditorItem.
TfrxComponentProperty | The standard editor of properties of type TComponent.
TfrxCursorProperty | The standard editor of properties of type TCursor.
TfrxDateProperty | Represents type TfrxDateProperty.
TfrxDateTimeProperty | Represents type TfrxDateTimeProperty.
TfrxEnumProperty | The standard editor of properties of type Enum.
TfrxExportFilterCollection | The TfrxExportFilterCollection class represents a list of export filters registered in the FastReport. frxExportFilters global object contains an instance of this class.
TfrxExportFilterItem | Represents type TfrxExportFilterItem.
TfrxFloatProperty | The standard editor of properties of type Extended.
TfrxFontCharsetProperty | The standard editor of properties of type TFont.Charset.
TfrxFontNameProperty | The standard editor of properties of type TFont.Name.
TfrxFontProperty | The standard editor of properties of type TFont.
TfrxIntegerProperty | The standard editor of properties of type Integer.
TfrxModalResultProperty | The standard editor of properties of type TModalResult.
TfrxNameProperty | The standard editor of properties of type TComponentName.
TfrxObjectCollection | The TfrxObjectCollection class represents list of objects registered in the FastReport. frxObjects global object contains an instance of this class.
TfrxObjectItem | Represents type TfrxObjectItem.
TfrxPropertyEditor | The TfrxPropertyEditor class is the base class for all property editors.
TfrxPropertyEditorCollection | The TfrxPropertyEditorCollection class represents a list of property editors registered in the FastReport. frxPropertyEditors global object contains an instance of this class.
TfrxPropertyEditorItem | Represents type TfrxPropertyEditorItem.
TfrxPropertyItem | Represents type TfrxPropertyItem.
TfrxPropertyList | Represents type TfrxPropertyList.
TfrxSaveFilterItem | Represents type TfrxSaveFilterItem.
TfrxSaveFiltersCollection | Represents type TfrxSaveFiltersCollection.
TfrxSetElementProperty | The standard editor of properties of type Set element.
TfrxSetProperty | The standard editor of properties of type Set.
TfrxShortCutProperty | The standard editor of properties of type TShortCut.
TfrxStringProperty | The standard editor of properties of type String.
TfrxTimeProperty | Represents type TfrxTimeProperty.
TfrxWizardCollection | The TfrxWizardCollection class represents a list of wizards registered in the FastReport. frxWizards global object contains an instance of this class.
TfrxWizardItem | Represents type TfrxWizardItem.
Top


TfrxCharProperty Class

Summary

The standard editor of properties of type Char.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxCharProperty
Syntax
Delphi
type
 TfrxCharProperty = class(TfrxPropertyEditor)
 end;

The TfrxCharProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Inherited from TfrxPropertyEditor.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Inherited from TfrxPropertyEditor.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxCharProperty Methods

Methods
Name | Description
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
Top


TfrxCharProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxCharProperty
  • frxDsgnIntf


TfrxCharProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxPropertyEditor.SetValue(String)
See Also

Reference

  • TfrxCharProperty
  • frxDsgnIntf


TfrxClassNameProperty Class

Summary

The standard editor of properties of type TClass.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxStringProperty
frxDsgnIntf.TfrxClassNameProperty
Syntax
Delphi
type
 TfrxClassNameProperty = class(TfrxStringProperty)
 end;

The TfrxClassNameProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxStringProperty.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxClassNameProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxStringProperty.SetValue(String).)
Top


TfrxClassNameProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxClassNameProperty
  • frxDsgnIntf


TfrxClassNameProperty.GetValues Method

Summary

The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure GetValues; override;

Overrides

TfrxPropertyEditor.GetValues
See Also

Reference

  • TfrxClassNameProperty
  • frxDsgnIntf


TfrxClassNameProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxStringProperty.SetValue(String)
See Also

Reference

  • TfrxClassNameProperty
  • frxDsgnIntf


TfrxClassProperty Class

Summary

The standard editor of properties of type TObject.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxClassProperty
frxDsgnIntf.TfrxFontProperty
Syntax
Delphi
type
 TfrxClassProperty = class(TfrxPropertyEditor)
 end;

The TfrxClassProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Inherited from TfrxPropertyEditor.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Inherited from TfrxPropertyEditor.)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxClassProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
Top


TfrxClassProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxClassProperty
  • frxDsgnIntf


TfrxClassProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxClassProperty
  • frxDsgnIntf


TfrxColorProperty Class

Summary

The standard editor of properties of type TColor.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxIntegerProperty
frxDsgnIntf.TfrxColorProperty
Syntax
Delphi
type
 TfrxColorProperty = class(TfrxIntegerProperty)
 end;

The TfrxColorProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Overrides TfrxPropertyEditor.Edit.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Overrides TfrxPropertyEditor.OnDrawItem(TCanvas,TRect).)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Overrides TfrxPropertyEditor.OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState).)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxColorProperty Methods

Methods
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Overrides TfrxPropertyEditor.Edit.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Overrides TfrxPropertyEditor.OnDrawItem(TCanvas,TRect).)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Overrides TfrxPropertyEditor.OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState).)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.SetValue(String).)
Top


TfrxColorProperty.Edit Method

Summary

Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function Edit: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxPropertyEditor.Edit
See Also

Reference

  • TfrxColorProperty
  • frxDsgnIntf


TfrxColorProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxColorProperty
  • frxDsgnIntf


TfrxColorProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxIntegerProperty.GetValue
See Also

Reference

  • TfrxColorProperty
  • frxDsgnIntf


TfrxColorProperty.GetValues Method

Summary

The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure GetValues; override;

Overrides

TfrxPropertyEditor.GetValues
See Also

Reference

  • TfrxColorProperty
  • frxDsgnIntf


TfrxColorProperty.OnDrawItem(TCanvas,TRect) Method

Summary

The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure OnDrawItem(Canvas: TCanvas; ARect: TRect); override;

Parameters

Canvas
Type: TCanvas

ARect
Type: TRect

Overrides

TfrxPropertyEditor.OnDrawItem(TCanvas,TRect)
See Also

Reference

  • TfrxColorProperty
  • frxDsgnIntf


TfrxColorProperty.OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) Method

Summary

The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure OnDrawLBItem(Control: TWinControl; Index: Integer;
 ARect: TRect; State: TOwnerDrawState); override;

Parameters

Control
Type: TWinControl

Index
Type: Integer

ARect
Type: TRect

State
Type: TOwnerDrawState

Overrides

TfrxPropertyEditor.OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState)
See Also

Reference

  • TfrxColorProperty
  • frxDsgnIntf


TfrxColorProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxIntegerProperty.SetValue(String)
See Also

Reference

  • TfrxColorProperty
  • frxDsgnIntf


TfrxComponentEditor Class

Summary

The TfrxComponentEditor class is the base class for all component editors.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxComponentEditor
frxCustomEditors.TfrxViewEditor
Syntax
Delphi
type
 TfrxComponentEditor = class(TObject)
 end;

The TfrxComponentEditor type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponent,TfrxCustomDesigner,TMenu) | The constructor.
Top
Properties
Show:
Name | Description
Component | Link to the edited component.
Designer | Link to the designer.
Top
Methods
Show:
Name | Description
AddItem(String,Integer,Boolean) | Adds a menu item to the context menu of the edited component.
Edit | Method should perform necessary actions (for example, display a dialogue box) and returns "True," if the component's state was modified.
Execute(Integer,Boolean) | Method is called, when you select one of your items in the component's menu; response to the selected menu item should be described here.
GetMenuItems | You should override this method if you need to add items in the component's context menu. Items should be added by AddItem method.
HasEditor | The "HasEditor" method should return "True" if your component has an editor. If it either returns "False" or you do not override this method, the editor will not be called.
Top
Fields
Show:
Name | Description
FComponent | Represents field FComponent.
FDesigner | Represents field FDesigner.
FMenu | Represents field FMenu.
Top
See Also

Reference

  • frxDsgnIntf


TfrxComponentEditor Constructors

Constructors
Name | Description
Create(TfrxComponent,TfrxCustomDesigner,TMenu) | The constructor.
Top


TfrxComponentEditor.Create(TfrxComponent,TfrxCustomDesigner,TMenu) Constructor

Summary

The constructor.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 constructor Create(Component: TfrxComponent; Designer: TfrxCustomDesigner;
 Menu: TMenu); virtual;

Parameters

Component
Type: TfrxComponent

Designer
Type: TfrxCustomDesigner

Menu
Type: TMenu

See Also

Reference

  • TfrxComponentEditor
  • frxDsgnIntf


TfrxComponentEditor Properties

Properties
Name | Description
Component | Link to the edited component.
Designer | Link to the designer.
Top


TfrxComponentEditor.Component Property

Summary

Link to the edited component.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Component: TfrxComponent read FComponent;

Property Value

Type: TfrxComponent

See Also

Reference

  • TfrxComponentEditor
  • frxDsgnIntf


TfrxComponentEditor.Designer Property

Summary

Link to the designer.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Designer: TfrxCustomDesigner read FDesigner;

Property Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxComponentEditor
  • frxDsgnIntf


TfrxComponentEditor Methods

Methods
Name | Description
AddItem(String,Integer,Boolean) | Adds a menu item to the context menu of the edited component.
Edit | Method should perform necessary actions (for example, display a dialogue box) and returns "True," if the component's state was modified.
Execute(Integer,Boolean) | Method is called, when you select one of your items in the component's menu; response to the selected menu item should be described here.
GetMenuItems | You should override this method if you need to add items in the component's context menu. Items should be added by AddItem method.
HasEditor | The "HasEditor" method should return "True" if your component has an editor. If it either returns "False" or you do not override this method, the editor will not be called.
Top


TfrxComponentEditor.AddItem(String,Integer,Boolean) Method

Summary

Adds a menu item to the context menu of the edited component.

Namespace: frxDsgnIntf
Syntax
Delphi
protected
 function AddItem(const Caption: String; Tag: Integer;
 Checked: Boolean = False): TMenuItem;

Parameters

Caption
Type: String

Tag
Type: Integer

Checked
Type: Boolean

Return Value

Type: TMenuItem

See Also

Reference

  • TfrxComponentEditor
  • frxDsgnIntf


TfrxComponentEditor.Edit Method

Summary

Method should perform necessary actions (for example, display a dialogue box) and returns "True," if the component's state was modified.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function Edit: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponentEditor
  • frxDsgnIntf


TfrxComponentEditor.Execute(Integer,Boolean) Method

Summary

Method is called, when you select one of your items in the component's menu; response to the selected menu item should be described here.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function Execute(Tag: Integer; Checked: Boolean): Boolean; virtual;

Parameters

Tag
Type: Integer

Checked
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponentEditor
  • frxDsgnIntf


TfrxComponentEditor.GetMenuItems Method

Summary

You should override this method if you need to add items in the component's context menu. Items should be added by AddItem method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure GetMenuItems; virtual;
See Also

Reference

  • TfrxComponentEditor
  • frxDsgnIntf


TfrxComponentEditor.HasEditor Method

Summary

The "HasEditor" method should return "True" if your component has an editor. If it either returns "False" or you do not override this method, the editor will not be called.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function HasEditor: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxComponentEditor
  • frxDsgnIntf


TfrxComponentEditor Fields

Fields
Name | Description
FComponent | Represents field FComponent.
FDesigner | Represents field FDesigner.
FMenu | Represents field FMenu.
Top


TfrxComponentEditor.FComponent Field

Summary

Represents field FComponent.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FComponent: TfrxComponent;

Field Value

Type: TfrxComponent

See Also

Reference

  • TfrxComponentEditor
  • frxDsgnIntf


TfrxComponentEditor.FDesigner Field

Summary

Represents field FDesigner.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FDesigner: TfrxCustomDesigner;

Field Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxComponentEditor
  • frxDsgnIntf


TfrxComponentEditor.FMenu Field

Summary

Represents field FMenu.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FMenu: TMenu;

Field Value

Type: TMenu

See Also

Reference

  • TfrxComponentEditor
  • frxDsgnIntf


TfrxComponentEditorCollection Class

Summary

The TfrxComponentEditorCollection class represents a list of component editors registered in the FastReport. frxComponentEditors global object contains an instance of this class.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollection
frxDsgnIntf.TfrxComponentEditorCollection
Syntax
Delphi
type
 TfrxComponentEditorCollection = class(TCollection)
 end;

The TfrxComponentEditorCollection type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxComponentEditorCollection class.
Top
Properties
Show:
Name | Description
Items[Integer] | List of registered component editors.
Top
Methods
Show:
Name | Description
GetComponentEditor(TfrxComponent,TfrxCustomDesigner,TMenu) | Creates new instance of component editor.
GetComponentEditorItem(Integer) | Represents method GetComponentEditorItem(Integer).
Register(TfrxComponentClass,TfrxComponentEditorClass) | Registers a component editor. The first parameter is the class' name, for which the editor is to be created. The second parameter is the name of the editor's class.
UnRegister(TfrxComponentEditorClass) | Remove editor class from registered list.
Top
See Also

Reference

  • frxDsgnIntf


TfrxComponentEditorCollection Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxComponentEditorCollection class.
Top


TfrxComponentEditorCollection.Create Constructor

Summary

Initializes a new instance of the TfrxComponentEditorCollection class.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxComponentEditorCollection
  • frxDsgnIntf


TfrxComponentEditorCollection Properties

Properties
Name | Description
Items[Integer] | List of registered component editors.
Top


TfrxComponentEditorCollection.Items[Integer] Property

Summary

List of registered component editors.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxComponentEditorItem
 read GetComponentEditorItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxComponentEditorItem

See Also

Reference

  • TfrxComponentEditorCollection
  • frxDsgnIntf


TfrxComponentEditorCollection Methods

Methods
Name | Description
GetComponentEditor(TfrxComponent,TfrxCustomDesigner,TMenu) | Creates new instance of component editor.
GetComponentEditorItem(Integer) | Represents method GetComponentEditorItem(Integer).
Register(TfrxComponentClass,TfrxComponentEditorClass) | Registers a component editor. The first parameter is the class' name, for which the editor is to be created. The second parameter is the name of the editor's class.
UnRegister(TfrxComponentEditorClass) | Remove editor class from registered list.
Top


TfrxComponentEditorCollection.GetComponentEditor(TfrxComponent,TfrxCustomDesigner,TMenu) Method

Summary

Creates new instance of component editor.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetComponentEditor(Component: TfrxComponent;
 Designer: TfrxCustomDesigner; Menu: TMenu): TfrxComponentEditor;

Parameters

Component
Type: TfrxComponent

Designer
Type: TfrxCustomDesigner

Menu
Type: TMenu

Return Value

Type: TfrxComponentEditor

See Also

Reference

  • TfrxComponentEditorCollection
  • frxDsgnIntf


TfrxComponentEditorCollection.GetComponentEditorItem(Integer) Method

Summary

Represents method GetComponentEditorItem(Integer).

Namespace: frxDsgnIntf
Syntax
Delphi
private
 function GetComponentEditorItem(Index: Integer): TfrxComponentEditorItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxComponentEditorItem

See Also

Reference

  • TfrxComponentEditorCollection
  • frxDsgnIntf


TfrxComponentEditorCollection.Register(TfrxComponentClass,TfrxComponentEditorClass) Method

Summary

Registers a component editor. The first parameter is the class' name, for which the editor is to be created. The second parameter is the name of the editor's class.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure Register(ComponentClass: TfrxComponentClass;
 ComponentEditor: TfrxComponentEditorClass);

Parameters

ComponentClass
Type: TfrxComponentClass

Component class reference.

ComponentEditor
Type: TfrxComponentEditorClass

Editor class reference.

See Also

Reference

  • TfrxComponentEditorCollection
  • frxDsgnIntf


TfrxComponentEditorCollection.UnRegister(TfrxComponentEditorClass) Method

Summary

Remove editor class from registered list.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure UnRegister(ComponentEditor: TfrxComponentEditorClass);

Parameters

ComponentEditor
Type: TfrxComponentEditorClass

See Also

Reference

  • TfrxComponentEditorCollection
  • frxDsgnIntf


TfrxComponentEditorItem Class

Summary

Represents type TfrxComponentEditorItem.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollectionItem
frxDsgnIntf.TfrxComponentEditorItem
Syntax
Delphi
type
 TfrxComponentEditorItem = class(TCollectionItem)
 end;

The TfrxComponentEditorItem type exposes the following members.

Fields
Show:
Name | Description
ComponentClass | Represents field ComponentClass.
ComponentEditor | Represents field ComponentEditor.
Top
See Also

Reference

  • frxDsgnIntf


TfrxComponentEditorItem Fields

Fields
Name | Description
ComponentClass | Represents field ComponentClass.
ComponentEditor | Represents field ComponentEditor.
Top


TfrxComponentEditorItem.ComponentClass Field

Summary

Represents field ComponentClass.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 ComponentClass: TfrxComponentClass;

Field Value

Type: TfrxComponentClass

See Also

Reference

  • TfrxComponentEditorItem
  • frxDsgnIntf


TfrxComponentEditorItem.ComponentEditor Field

Summary

Represents field ComponentEditor.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 ComponentEditor: TfrxComponentEditorClass;

Field Value

Type: TfrxComponentEditorClass

See Also

Reference

  • TfrxComponentEditorItem
  • frxDsgnIntf


TfrxComponentProperty Class

Summary

The standard editor of properties of type TComponent.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxComponentProperty
Syntax
Delphi
type
 TfrxComponentProperty = class(TfrxPropertyEditor)
 end;

The TfrxComponentProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxComponentProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
Top


TfrxComponentProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxComponentProperty
  • frxDsgnIntf


TfrxComponentProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxComponentProperty
  • frxDsgnIntf


TfrxComponentProperty.GetValues Method

Summary

The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure GetValues; override;

Overrides

TfrxPropertyEditor.GetValues
See Also

Reference

  • TfrxComponentProperty
  • frxDsgnIntf


TfrxComponentProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxPropertyEditor.SetValue(String)
See Also

Reference

  • TfrxComponentProperty
  • frxDsgnIntf


TfrxCursorProperty Class

Summary

The standard editor of properties of type TCursor.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxIntegerProperty
frxDsgnIntf.TfrxCursorProperty
Syntax
Delphi
type
 TfrxCursorProperty = class(TfrxIntegerProperty)
 end;

The TfrxCursorProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxCursorProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.SetValue(String).)
Top


TfrxCursorProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxCursorProperty
  • frxDsgnIntf


TfrxCursorProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxIntegerProperty.GetValue
See Also

Reference

  • TfrxCursorProperty
  • frxDsgnIntf


TfrxCursorProperty.GetValues Method

Summary

The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure GetValues; override;

Overrides

TfrxPropertyEditor.GetValues
See Also

Reference

  • TfrxCursorProperty
  • frxDsgnIntf


TfrxCursorProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxIntegerProperty.SetValue(String)
See Also

Reference

  • TfrxCursorProperty
  • frxDsgnIntf


TfrxDateProperty Class

Summary

Represents type TfrxDateProperty.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxDateProperty
Syntax
Delphi
type
 TfrxDateProperty = class(TfrxPropertyEditor)
 end;

The TfrxDateProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Inherited from TfrxPropertyEditor.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Inherited from TfrxPropertyEditor.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxDateProperty Methods

Methods
Name | Description
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
Top


TfrxDateProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxDateProperty
  • frxDsgnIntf


TfrxDateProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxPropertyEditor.SetValue(String)
See Also

Reference

  • TfrxDateProperty
  • frxDsgnIntf


TfrxDateTimeProperty Class

Summary

Represents type TfrxDateTimeProperty.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxDateTimeProperty
Syntax
Delphi
type
 TfrxDateTimeProperty = class(TfrxPropertyEditor)
 end;

The TfrxDateTimeProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Inherited from TfrxPropertyEditor.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Inherited from TfrxPropertyEditor.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxDateTimeProperty Methods

Methods
Name | Description
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
Top


TfrxDateTimeProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxDateTimeProperty
  • frxDsgnIntf


TfrxDateTimeProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxPropertyEditor.SetValue(String)
See Also

Reference

  • TfrxDateTimeProperty
  • frxDsgnIntf


TfrxEnumProperty Class

Summary

The standard editor of properties of type Enum.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxEnumProperty
Syntax
Delphi
type
 TfrxEnumProperty = class(TfrxPropertyEditor)
 end;

The TfrxEnumProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxEnumProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
Top


TfrxEnumProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxEnumProperty
  • frxDsgnIntf


TfrxEnumProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxEnumProperty
  • frxDsgnIntf


TfrxEnumProperty.GetValues Method

Summary

The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure GetValues; override;

Overrides

TfrxPropertyEditor.GetValues
See Also

Reference

  • TfrxEnumProperty
  • frxDsgnIntf


TfrxEnumProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxPropertyEditor.SetValue(String)
See Also

Reference

  • TfrxEnumProperty
  • frxDsgnIntf


TfrxExportFilterCollection Class

Summary

The TfrxExportFilterCollection class represents a list of export filters registered in the FastReport. frxExportFilters global object contains an instance of this class.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollection
frxDsgnIntf.TfrxExportFilterCollection
Syntax
Delphi
type
 TfrxExportFilterCollection = class(TCollection)
 end;

The TfrxExportFilterCollection type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxExportFilterCollection class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
GetExportFilterItem(Integer) | Represents method GetExportFilterItem(Integer).
Register(TfrxCustomExportFilter) | Registers an export filter.
Unregister(TfrxCustomExportFilter) | Deletes an export filter from the list of registered items.
Top
See Also

Reference

  • frxDsgnIntf


TfrxExportFilterCollection Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxExportFilterCollection class.
Top


TfrxExportFilterCollection.Create Constructor

Summary

Initializes a new instance of the TfrxExportFilterCollection class.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxExportFilterCollection
  • frxDsgnIntf


TfrxExportFilterCollection Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxExportFilterCollection.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxExportFilterItem
 read GetExportFilterItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxExportFilterItem

See Also

Reference

  • TfrxExportFilterCollection
  • frxDsgnIntf


TfrxExportFilterCollection Methods

Methods
Name | Description
GetExportFilterItem(Integer) | Represents method GetExportFilterItem(Integer).
Register(TfrxCustomExportFilter) | Registers an export filter.
Unregister(TfrxCustomExportFilter) | Deletes an export filter from the list of registered items.
Top


TfrxExportFilterCollection.GetExportFilterItem(Integer) Method

Summary

Represents method GetExportFilterItem(Integer).

Namespace: frxDsgnIntf
Syntax
Delphi
private
 function GetExportFilterItem(Index: Integer): TfrxExportFilterItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxExportFilterItem

See Also

Reference

  • TfrxExportFilterCollection
  • frxDsgnIntf


TfrxExportFilterCollection.Register(TfrxCustomExportFilter) Method

Summary

Registers an export filter.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure Register(Filter: TfrxCustomExportFilter);

Parameters

Filter
Type: TfrxCustomExportFilter

See Also

Reference

  • TfrxExportFilterCollection
  • frxDsgnIntf


TfrxExportFilterCollection.Unregister(TfrxCustomExportFilter) Method

Summary

Deletes an export filter from the list of registered items.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure Unregister(Filter: TfrxCustomExportFilter);

Parameters

Filter
Type: TfrxCustomExportFilter

See Also

Reference

  • TfrxExportFilterCollection
  • frxDsgnIntf


TfrxExportFilterItem Class

Summary

Represents type TfrxExportFilterItem.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollectionItem
frxDsgnIntf.TfrxExportFilterItem
Syntax
Delphi
type
 TfrxExportFilterItem = class(TCollectionItem)
 end;

The TfrxExportFilterItem type exposes the following members.

Fields
Show:
Name | Description
Filter | Represents field Filter.
Top
See Also

Reference

  • frxDsgnIntf


TfrxExportFilterItem Fields

Fields
Name | Description
Filter | Represents field Filter.
Top


TfrxExportFilterItem.Filter Field

Summary

Represents field Filter.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 Filter: TfrxCustomExportFilter;

Field Value

Type: TfrxCustomExportFilter

See Also

Reference

  • TfrxExportFilterItem
  • frxDsgnIntf


TfrxFloatProperty Class

Summary

The standard editor of properties of type Extended.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxFloatProperty
Syntax
Delphi
type
 TfrxFloatProperty = class(TfrxPropertyEditor)
 end;

The TfrxFloatProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Inherited from TfrxPropertyEditor.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Inherited from TfrxPropertyEditor.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxFloatProperty Methods

Methods
Name | Description
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
Top


TfrxFloatProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxFloatProperty
  • frxDsgnIntf


TfrxFloatProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxPropertyEditor.SetValue(String)
See Also

Reference

  • TfrxFloatProperty
  • frxDsgnIntf


TfrxFontCharsetProperty Class

Summary

The standard editor of properties of type TFont.Charset.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxIntegerProperty
frxDsgnIntf.TfrxFontCharsetProperty
Syntax
Delphi
type
 TfrxFontCharsetProperty = class(TfrxIntegerProperty)
 end;

The TfrxFontCharsetProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxFontCharsetProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.SetValue(String).)
Top


TfrxFontCharsetProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxFontCharsetProperty
  • frxDsgnIntf


TfrxFontCharsetProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxIntegerProperty.GetValue
See Also

Reference

  • TfrxFontCharsetProperty
  • frxDsgnIntf


TfrxFontCharsetProperty.GetValues Method

Summary

The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure GetValues; override;

Overrides

TfrxPropertyEditor.GetValues
See Also

Reference

  • TfrxFontCharsetProperty
  • frxDsgnIntf


TfrxFontCharsetProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxIntegerProperty.SetValue(String)
See Also

Reference

  • TfrxFontCharsetProperty
  • frxDsgnIntf


TfrxFontNameProperty Class

Summary

The standard editor of properties of type TFont.Name.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxStringProperty
frxDsgnIntf.TfrxFontNameProperty
Syntax
Delphi
type
 TfrxFontNameProperty = class(TfrxStringProperty)
 end;

The TfrxFontNameProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxFontNameProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
Top


TfrxFontNameProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxFontNameProperty
  • frxDsgnIntf


TfrxFontNameProperty.GetValues Method

Summary

The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure GetValues; override;

Overrides

TfrxPropertyEditor.GetValues
See Also

Reference

  • TfrxFontNameProperty
  • frxDsgnIntf


TfrxFontProperty Class

Summary

The standard editor of properties of type TFont.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxClassProperty
frxDsgnIntf.TfrxFontProperty
Syntax
Delphi
type
 TfrxFontProperty = class(TfrxClassProperty)
 end;

The TfrxFontProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Overrides TfrxPropertyEditor.Edit.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxClassProperty.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Inherited from TfrxPropertyEditor.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Inherited from TfrxPropertyEditor.)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxFontProperty Methods

Methods
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Overrides TfrxPropertyEditor.Edit.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxClassProperty.GetAttributes.)
Top


TfrxFontProperty.Edit Method

Summary

Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function Edit: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxPropertyEditor.Edit
See Also

Reference

  • TfrxFontProperty
  • frxDsgnIntf


TfrxFontProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxClassProperty.GetAttributes
See Also

Reference

  • TfrxFontProperty
  • frxDsgnIntf


TfrxIntegerProperty Class

Summary

The standard editor of properties of type Integer.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxIntegerProperty
frxDsgnIntf.TfrxColorProperty
frxDsgnIntf.TfrxCursorProperty
frxDsgnIntf.TfrxFontCharsetProperty
frxDsgnIntf.TfrxModalResultProperty
Syntax
Delphi
type
 TfrxIntegerProperty = class(TfrxPropertyEditor)
 end;

The TfrxIntegerProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Inherited from TfrxPropertyEditor.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Inherited from TfrxPropertyEditor.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxIntegerProperty Methods

Methods
Name | Description
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
Top


TfrxIntegerProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxIntegerProperty
  • frxDsgnIntf


TfrxIntegerProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxPropertyEditor.SetValue(String)
See Also

Reference

  • TfrxIntegerProperty
  • frxDsgnIntf


TfrxModalResultProperty Class

Summary

The standard editor of properties of type TModalResult.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxIntegerProperty
frxDsgnIntf.TfrxModalResultProperty
Syntax
Delphi
type
 TfrxModalResultProperty = class(TfrxIntegerProperty)
 end;

The TfrxModalResultProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxModalResultProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxIntegerProperty.SetValue(String).)
Top


TfrxModalResultProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxModalResultProperty
  • frxDsgnIntf


TfrxModalResultProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxIntegerProperty.GetValue
See Also

Reference

  • TfrxModalResultProperty
  • frxDsgnIntf


TfrxModalResultProperty.GetValues Method

Summary

The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure GetValues; override;

Overrides

TfrxPropertyEditor.GetValues
See Also

Reference

  • TfrxModalResultProperty
  • frxDsgnIntf


TfrxModalResultProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxIntegerProperty.SetValue(String)
See Also

Reference

  • TfrxModalResultProperty
  • frxDsgnIntf


TfrxNameProperty Class

Summary

The standard editor of properties of type TComponentName.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxStringProperty
frxDsgnIntf.TfrxNameProperty
Syntax
Delphi
type
 TfrxNameProperty = class(TfrxStringProperty)
 end;

The TfrxNameProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Inherited from TfrxPropertyEditor.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxNameProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
Top


TfrxNameProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxNameProperty
  • frxDsgnIntf


TfrxObjectCollection Class

Summary

The TfrxObjectCollection class represents list of objects registered in the FastReport. frxObjects global object contains an instance of this class.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollection
frxDsgnIntf.TfrxObjectCollection
Syntax
Delphi
type
 TfrxObjectCollection = class(TCollection)
 end;

The TfrxObjectCollection type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxObjectCollection class.
Top
Properties
Show:
Name | Description
Items[Integer] | list of registered components.
Top
Methods
Show:
Name | Description
GetObjectItem(Integer) | Represents method GetObjectItem(Integer).
RegisterCategory(String,TBitmap,String,Integer) | Registers a category.
RegisterObject(TfrxComponentClass,TBitmap,String) | Registers an add-in object. During registration, you should specify control class' name, its picture, and the name of a category, to which it should be placed. If the name of a category is not specified, the control is placed in the basic component palette. The ButtonBmp size should be 16x16 pixels.
RegisterObject1(TfrxComponentClass,TBitmap,String,String,Integer,Integer,TfrxObjectCategories) | Method is used for registration of internal FastReport objects.
Unregister(TfrxComponentClass) | Deletes the object from registered object's list.
Top
See Also

Reference

  • frxDsgnIntf


TfrxObjectCollection Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxObjectCollection class.
Top


TfrxObjectCollection.Create Constructor

Summary

Initializes a new instance of the TfrxObjectCollection class.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxObjectCollection
  • frxDsgnIntf


TfrxObjectCollection Properties

Properties
Name | Description
Items[Integer] | list of registered components.
Top


TfrxObjectCollection.Items[Integer] Property

Summary

list of registered components.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxObjectItem read GetObjectItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxObjectItem

See Also

Reference

  • TfrxObjectCollection
  • frxDsgnIntf


TfrxObjectCollection Methods

Methods
Name | Description
GetObjectItem(Integer) | Represents method GetObjectItem(Integer).
RegisterCategory(String,TBitmap,String,Integer) | Registers a category.
RegisterObject(TfrxComponentClass,TBitmap,String) | Registers an add-in object. During registration, you should specify control class' name, its picture, and the name of a category, to which it should be placed. If the name of a category is not specified, the control is placed in the basic component palette. The ButtonBmp size should be 16x16 pixels.
RegisterObject1(TfrxComponentClass,TBitmap,String,String,Integer,Integer,TfrxObjectCategories) | Method is used for registration of internal FastReport objects.
Unregister(TfrxComponentClass) | Deletes the object from registered object's list.
Top


TfrxObjectCollection.GetObjectItem(Integer) Method

Summary

Represents method GetObjectItem(Integer).

Namespace: frxDsgnIntf
Syntax
Delphi
private
 function GetObjectItem(Index: Integer): TfrxObjectItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxObjectItem

See Also

Reference

  • TfrxObjectCollection
  • frxDsgnIntf


TfrxObjectCollection.RegisterCategory(String,TBitmap,String,Integer) Method

Summary

Registers a category.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure RegisterCategory(const CategoryName: String; ButtonBmp: TBitmap;
 const ButtonHint: String; ImageIndex: Integer = -1);

Parameters

CategoryName
Type: String

Name of the category.This name is used for identification of the category only and does not appear anywhere else. It should also be used when calling the "frxObjects.RegisterObject" procedure, if you want to place the registered object inside the given category.

ButtonBmp
Type: TBitmap

Category bitmap of size 16x16.

ButtonHint
Type: String

Category hint. It is displayed as a hint, if the button with a category is selected by the cursor.

ImageIndex
Type: Integer

Index of the bitmap from standard set of bitmaps if the ButtonBmp parameter is nil.

See Also

Reference

  • TfrxObjectCollection
  • frxDsgnIntf


TfrxObjectCollection.RegisterObject(TfrxComponentClass,TBitmap,String) Method

Summary

Registers an add-in object. During registration, you should specify control class' name, its picture, and the name of a category, to which it should be placed. If the name of a category is not specified, the control is placed in the basic component palette. The ButtonBmp size should be 16x16 pixels.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure RegisterObject(ClassRef: TfrxComponentClass; ButtonBmp: TBitmap;
 const CategoryName: String = '');

Parameters

ClassRef
Type: TfrxComponentClass

Component class reference.

ButtonBmp
Type: TBitmap

Component image.

CategoryName
Type: String

Category name.

See Also

Reference

  • TfrxObjectCollection
  • frxDsgnIntf


TfrxObjectCollection.RegisterObject1(TfrxComponentClass,TBitmap,String,String,Integer,Integer,TfrxObjectCategories) Method

Summary

Method is used for registration of internal FastReport objects.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure RegisterObject1(ClassRef: TfrxComponentClass; ButtonBmp: TBitmap;
 const ButtonHint: String = ''; const CategoryName: String = '';
 Flags: Integer = 0; ImageIndex: Integer = -1;
 Category: TfrxObjectCategories = []);

Parameters

ClassRef
Type: TfrxComponentClass

ButtonBmp
Type: TBitmap

ButtonHint
Type: String

CategoryName
Type: String

Flags
Type: Integer

ImageIndex
Type: Integer

Category
Type: TfrxObjectCategories

See Also

Reference

  • TfrxObjectCollection
  • frxDsgnIntf


TfrxObjectCollection.Unregister(TfrxComponentClass) Method

Summary

Deletes the object from registered object's list.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure Unregister(ClassRef: TfrxComponentClass);

Parameters

ClassRef
Type: TfrxComponentClass

See Also

Reference

  • TfrxObjectCollection
  • frxDsgnIntf


TfrxObjectItem Class

Summary

Represents type TfrxObjectItem.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollectionItem
frxDsgnIntf.TfrxObjectItem
Syntax
Delphi
type
 TfrxObjectItem = class(TCollectionItem)
 end;

The TfrxObjectItem type exposes the following members.

Fields
Show:
Name | Description
ButtonBmp | Represents field ButtonBmp.
ButtonHint | Represents field ButtonHint.
ButtonImageIndex | Represents field ButtonImageIndex.
Category | Represents field Category.
CategoryName | Represents field CategoryName.
ClassRef | Represents field ClassRef.
Flags | Represents field Flags.
Top
See Also

Reference

  • frxDsgnIntf


TfrxObjectItem Fields

Fields
Name | Description
ButtonBmp | Represents field ButtonBmp.
ButtonHint | Represents field ButtonHint.
ButtonImageIndex | Represents field ButtonImageIndex.
Category | Represents field Category.
CategoryName | Represents field CategoryName.
ClassRef | Represents field ClassRef.
Flags | Represents field Flags.
Top


TfrxObjectItem.ButtonBmp Field

Summary

Represents field ButtonBmp.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 ButtonBmp: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxObjectItem
  • frxDsgnIntf


TfrxObjectItem.ButtonHint Field

Summary

Represents field ButtonHint.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 ButtonHint: String;

Field Value

Type: String

See Also

Reference

  • TfrxObjectItem
  • frxDsgnIntf


TfrxObjectItem.ButtonImageIndex Field

Summary

Represents field ButtonImageIndex.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 ButtonImageIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxObjectItem
  • frxDsgnIntf


TfrxObjectItem.Category Field

Summary

Represents field Category.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 Category: TfrxObjectCategories;

Field Value

Type: TfrxObjectCategories

See Also

Reference

  • TfrxObjectItem
  • frxDsgnIntf


TfrxObjectItem.CategoryName Field

Summary

Represents field CategoryName.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 CategoryName: String;

Field Value

Type: String

See Also

Reference

  • TfrxObjectItem
  • frxDsgnIntf


TfrxObjectItem.ClassRef Field

Summary

Represents field ClassRef.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 ClassRef: TfrxComponentClass;

Field Value

Type: TfrxComponentClass

See Also

Reference

  • TfrxObjectItem
  • frxDsgnIntf


TfrxObjectItem.Flags Field

Summary

Represents field Flags.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 Flags: Word;

Field Value

Type: Word

See Also

Reference

  • TfrxObjectItem
  • frxDsgnIntf


TfrxPropertyEditor Class

Summary

The TfrxPropertyEditor class is the base class for all property editors.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxCharProperty
frxDsgnIntf.TfrxClassProperty
frxDsgnIntf.TfrxComponentProperty
frxDsgnIntf.TfrxDateProperty
frxDsgnIntf.TfrxDateTimeProperty
frxDsgnIntf.TfrxEnumProperty
frxDsgnIntf.TfrxFloatProperty
frxDsgnIntf.TfrxIntegerProperty
frxDsgnIntf.TfrxSetElementProperty
frxDsgnIntf.TfrxSetProperty
frxDsgnIntf.TfrxShortCutProperty
frxDsgnIntf.TfrxStringProperty
frxDsgnIntf.TfrxTimeProperty
frxMapLayer.TfrxLabelColumnProperty
Syntax
Delphi
type
 TfrxPropertyEditor = class(TObject)
 end;

The TfrxPropertyEditor type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor.
Destroy | Represents the destructor of the TfrxPropertyEditor class.
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs.
Designer | Reference to the report's designer.
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases).
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods.
PropInfo | Link to the PPropInfo structure, which contains information about the edited property.
Value | Property's value displayed as a string.
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined.
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified.
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.
GetComponent | Represents method GetComponent.
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden.
GetFloatValue | Method get a property value of type Extended.
GetfrComponent | Represents method GetfrComponent.
GetName | Method returns the name of the property.
GetOrdValue | Method get a property value of type Integer.
GetPropInfo | Represents method GetPropInfo.
GetStrProc(String) | Represents method GetStrProc(String).
GetStrValue | Method get a property value of type String.
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.
GetVarValue | Method get a property value of type Variant.
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value.
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters.
SetFloatValue(Extended) | Method sets a property value of type Extended.
SetOrdValue(frxInteger) | Method sets a property value of type Integer.
SetStrValue(String) | Method sets a property value of type String.
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.
SetVarValue(Variant) | Method sets a property value of type Variant.
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList.
FDesigner | Represents field FDesigner.
FItemHeight | Represents field FItemHeight.
FPropList | Represents field FPropList.
FValues | Represents field FValues.
Top
See Also

Reference

  • frxDsgnIntf


TfrxPropertyEditor Constructors

Constructors
Name | Description
Create(TfrxCustomDesigner) | The constructor.
Destroy | Represents the destructor of the TfrxPropertyEditor class.
Top


TfrxPropertyEditor.Create(TfrxCustomDesigner) Constructor

Summary

The constructor.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 constructor Create(Designer: TfrxCustomDesigner); virtual;

Parameters

Designer
Type: TfrxCustomDesigner

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.Destroy Destructor

Summary

Represents the destructor of the TfrxPropertyEditor class.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor Properties

Properties
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs.
Designer | Reference to the report's designer.
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases).
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods.
PropInfo | Link to the PPropInfo structure, which contains information about the edited property.
Value | Property's value displayed as a string.
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined.
Top


TfrxPropertyEditor.Component Property

Summary

Reference to the parent component (not to the property itself!), to which the given property belongs.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Component: TPersistent read GetComponent;

Property Value

Type: TPersistent

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.Designer Property

Summary

Reference to the report's designer.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Designer: TfrxCustomDesigner read FDesigner;

Property Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.frComponent Property

Summary

Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases).

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property frComponent: TfrxComponent read GetfrComponent;

Property Value

Type: TfrxComponent

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.ItemHeight Property

Summary

Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property ItemHeight: Integer read FItemHeight write FItemHeight;

Property Value

Type: Integer

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.PropInfo Property

Summary

Link to the PPropInfo structure, which contains information about the edited property.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property PropInfo: PPropInfo read GetPropInfo;

Property Value

Type: PPropInfo

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.Value Property

Summary

Property's value displayed as a string.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Value: String read GetValue write SetValue;

Property Value

Type: String

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.Values Property

Summary

The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Values: TStrings read FValues;

Property Value

Type: TStrings

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor Methods

Methods
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified.
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.
GetComponent | Represents method GetComponent.
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden.
GetFloatValue | Method get a property value of type Extended.
GetfrComponent | Represents method GetfrComponent.
GetName | Method returns the name of the property.
GetOrdValue | Method get a property value of type Integer.
GetPropInfo | Represents method GetPropInfo.
GetStrProc(String) | Represents method GetStrProc(String).
GetStrValue | Method get a property value of type String.
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.
GetVarValue | Method get a property value of type Variant.
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value.
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters.
SetFloatValue(Extended) | Method sets a property value of type Extended.
SetOrdValue(frxInteger) | Method sets a property value of type Integer.
SetStrValue(String) | Method sets a property value of type String.
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.
SetVarValue(Variant) | Method sets a property value of type Variant.
Top


TfrxPropertyEditor.Edit Method

Summary

Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function Edit: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; virtual;

Return Value

Type: TfrxPropertyAttributes

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetComponent Method

Summary

Represents method GetComponent.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 function GetComponent: TPersistent;

Return Value

Type: TPersistent

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetExtraLBSize Method

Summary

The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetExtraLBSize: Integer; virtual;

Return Value

Type: Integer

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetFloatValue Method

Summary

Method get a property value of type Extended.

Namespace: frxDsgnIntf
Syntax
Delphi
protected
 function GetFloatValue: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetfrComponent Method

Summary

Represents method GetfrComponent.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 function GetfrComponent: TfrxComponent;

Return Value

Type: TfrxComponent

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetName Method

Summary

Method returns the name of the property.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetName: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetOrdValue Method

Summary

Method get a property value of type Integer.

Namespace: frxDsgnIntf
Syntax
Delphi
protected
 function GetOrdValue: frxInteger;

Return Value

Type: frxInteger

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetPropInfo Method

Summary

Represents method GetPropInfo.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 function GetPropInfo: PPropInfo;

Return Value

Type: PPropInfo

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetStrProc(String) Method

Summary

Represents method GetStrProc(String).

Namespace: frxDsgnIntf
Syntax
Delphi
protected
 procedure GetStrProc(const s: String);

Parameters

s
Type: String

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetStrValue Method

Summary

Method get a property value of type String.

Namespace: frxDsgnIntf
Syntax
Delphi
protected
 function GetStrValue: String;

Return Value

Type: String

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetValues Method

Summary

The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure GetValues; virtual;
See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.GetVarValue Method

Summary

Method get a property value of type Variant.

Namespace: frxDsgnIntf
Syntax
Delphi
protected
 function GetVarValue: Variant;

Return Value

Type: Variant

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.OnDrawItem(TCanvas,TRect) Method

Summary

The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure OnDrawItem(Canvas: TCanvas; ARect: TRect); virtual;

Parameters

Canvas
Type: TCanvas

ARect
Type: TRect

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) Method

Summary

The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure OnDrawLBItem(Control: TWinControl; Index: Integer;
 ARect: TRect; State: TOwnerDrawState); virtual;

Parameters

Control
Type: TWinControl

Index
Type: Integer

ARect
Type: TRect

State
Type: TOwnerDrawState

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.SetFloatValue(Extended) Method

Summary

Method sets a property value of type Extended.

Namespace: frxDsgnIntf
Syntax
Delphi
protected
 procedure SetFloatValue(Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.SetOrdValue(frxInteger) Method

Summary

Method sets a property value of type Integer.

Namespace: frxDsgnIntf
Syntax
Delphi
protected
 procedure SetOrdValue(Value: frxInteger);

Parameters

Value
Type: System.Void

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.SetStrValue(String) Method

Summary

Method sets a property value of type String.

Namespace: frxDsgnIntf
Syntax
Delphi
protected
 procedure SetStrValue(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); virtual;

Parameters

Value
Type: String

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.SetVarValue(Variant) Method

Summary

Method sets a property value of type Variant.

Namespace: frxDsgnIntf
Syntax
Delphi
protected
 procedure SetVarValue(Value: Variant);

Parameters

Value
Type: Variant

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor Fields

Fields
Name | Description
FCompList | Represents field FCompList.
FDesigner | Represents field FDesigner.
FItemHeight | Represents field FItemHeight.
FPropList | Represents field FPropList.
FValues | Represents field FValues.
Top


TfrxPropertyEditor.FCompList Field

Summary

Represents field FCompList.

Namespace: frxDsgnIntf
Syntax
Delphi
protected
 FCompList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.FDesigner Field

Summary

Represents field FDesigner.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FDesigner: TfrxCustomDesigner;

Field Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.FItemHeight Field

Summary

Represents field FItemHeight.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FItemHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.FPropList Field

Summary

Represents field FPropList.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FPropList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditor.FValues Field

Summary

Represents field FValues.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FValues: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxPropertyEditor
  • frxDsgnIntf


TfrxPropertyEditorCollection Class

Summary

The TfrxPropertyEditorCollection class represents a list of property editors registered in the FastReport. frxPropertyEditors global object contains an instance of this class.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollection
frxDsgnIntf.TfrxPropertyEditorCollection
Syntax
Delphi
type
 TfrxPropertyEditorCollection = class(TCollection)
 end;

The TfrxPropertyEditorCollection type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxPropertyEditorCollection class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
GetPropertyEditor(PTypeInfo,TPersistent,String) | Represents method GetPropertyEditor(PTypeInfo,TPersistent,String).
GetPropertyEditorItem(Integer) | Represents method GetPropertyEditorItem(Integer).
Register(PTypeInfo,TClass,String,TfrxPropertyEditorClass) | Registers a property editor.
RegisterEventEditor(TfrxPropertyEditorClass) | Represents method RegisterEventEditor(TfrxPropertyEditorClass).
UnRegister(TfrxPropertyEditorClass) | Represents method UnRegister(TfrxPropertyEditorClass).
Top
Fields
Show:
Name | Description
FEventEditorItem | Represents field FEventEditorItem.
Top
See Also

Reference

  • frxDsgnIntf


TfrxPropertyEditorCollection Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxPropertyEditorCollection class.
Top


TfrxPropertyEditorCollection.Create Constructor

Summary

Initializes a new instance of the TfrxPropertyEditorCollection class.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxPropertyEditorCollection
  • frxDsgnIntf


TfrxPropertyEditorCollection Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxPropertyEditorCollection.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxPropertyEditorItem
 read GetPropertyEditorItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxPropertyEditorItem

See Also

Reference

  • TfrxPropertyEditorCollection
  • frxDsgnIntf


TfrxPropertyEditorCollection Methods

Methods
Name | Description
GetPropertyEditor(PTypeInfo,TPersistent,String) | Represents method GetPropertyEditor(PTypeInfo,TPersistent,String).
GetPropertyEditorItem(Integer) | Represents method GetPropertyEditorItem(Integer).
Register(PTypeInfo,TClass,String,TfrxPropertyEditorClass) | Registers a property editor.
RegisterEventEditor(TfrxPropertyEditorClass) | Represents method RegisterEventEditor(TfrxPropertyEditorClass).
UnRegister(TfrxPropertyEditorClass) | Represents method UnRegister(TfrxPropertyEditorClass).
Top


TfrxPropertyEditorCollection.GetPropertyEditor(PTypeInfo,TPersistent,String) Method

Summary

Represents method GetPropertyEditor(PTypeInfo,TPersistent,String).

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetPropertyEditor(PropertyType: PTypeInfo; Component: TPersistent;
 PropertyName: String): Integer;

Parameters

PropertyType
Type: PTypeInfo

Component
Type: TPersistent

PropertyName
Type: String

Return Value

Type: Integer

See Also

Reference

  • TfrxPropertyEditorCollection
  • frxDsgnIntf


TfrxPropertyEditorCollection.GetPropertyEditorItem(Integer) Method

Summary

Represents method GetPropertyEditorItem(Integer).

Namespace: frxDsgnIntf
Syntax
Delphi
private
 function GetPropertyEditorItem(Index: Integer): TfrxPropertyEditorItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxPropertyEditorItem

See Also

Reference

  • TfrxPropertyEditorCollection
  • frxDsgnIntf


TfrxPropertyEditorCollection.Register(PTypeInfo,TClass,String,TfrxPropertyEditorClass) Method

Summary

Registers a property editor.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure Register(PropertyType: PTypeInfo; ComponentClass: TClass;
 const PropertyName: String; EditorClass: TfrxPropertyEditorClass);

Parameters

PropertyType
Type: PTypeInfo

Information about the property's type, transferred via the "TypeInfo" system function, for example TypeInfo(String).

ComponentClass
Type: TClass

Name of the component, the property of which you want to edit (may be nil).

PropertyName
Type: String

Name of the property you want to edit (may be a blank string).

EditorClass
Type: TfrxPropertyEditorClass

Name of the property's editor.

See Also

Reference

  • TfrxPropertyEditorCollection
  • frxDsgnIntf


TfrxPropertyEditorCollection.RegisterEventEditor(TfrxPropertyEditorClass) Method

Summary

Represents method RegisterEventEditor(TfrxPropertyEditorClass).

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure RegisterEventEditor(EditorClass: TfrxPropertyEditorClass);

Parameters

EditorClass
Type: TfrxPropertyEditorClass

See Also

Reference

  • TfrxPropertyEditorCollection
  • frxDsgnIntf


TfrxPropertyEditorCollection.UnRegister(TfrxPropertyEditorClass) Method

Summary

Represents method UnRegister(TfrxPropertyEditorClass).

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure UnRegister(EditorClass: TfrxPropertyEditorClass);

Parameters

EditorClass
Type: TfrxPropertyEditorClass

See Also

Reference

  • TfrxPropertyEditorCollection
  • frxDsgnIntf


TfrxPropertyEditorCollection Fields

Fields
Name | Description
FEventEditorItem | Represents field FEventEditorItem.
Top


TfrxPropertyEditorCollection.FEventEditorItem Field

Summary

Represents field FEventEditorItem.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FEventEditorItem: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPropertyEditorCollection
  • frxDsgnIntf


TfrxPropertyEditorItem Class

Summary

Represents type TfrxPropertyEditorItem.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollectionItem
frxDsgnIntf.TfrxPropertyEditorItem
Syntax
Delphi
type
 TfrxPropertyEditorItem = class(TCollectionItem)
 end;

The TfrxPropertyEditorItem type exposes the following members.

Fields
Show:
Name | Description
ComponentClass | Represents field ComponentClass.
EditorClass | Represents field EditorClass.
PropertyName | Represents field PropertyName.
PropertyType | Represents field PropertyType.
Top
See Also

Reference

  • frxDsgnIntf


TfrxPropertyEditorItem Fields

Fields
Name | Description
ComponentClass | Represents field ComponentClass.
EditorClass | Represents field EditorClass.
PropertyName | Represents field PropertyName.
PropertyType | Represents field PropertyType.
Top


TfrxPropertyEditorItem.ComponentClass Field

Summary

Represents field ComponentClass.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 ComponentClass: TClass;

Field Value

Type: TClass

See Also

Reference

  • TfrxPropertyEditorItem
  • frxDsgnIntf


TfrxPropertyEditorItem.EditorClass Field

Summary

Represents field EditorClass.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 EditorClass: TfrxPropertyEditorClass;

Field Value

Type: TfrxPropertyEditorClass

See Also

Reference

  • TfrxPropertyEditorItem
  • frxDsgnIntf


TfrxPropertyEditorItem.PropertyName Field

Summary

Represents field PropertyName.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 PropertyName: String;

Field Value

Type: String

See Also

Reference

  • TfrxPropertyEditorItem
  • frxDsgnIntf


TfrxPropertyEditorItem.PropertyType Field

Summary

Represents field PropertyType.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 PropertyType: PTypeInfo;

Field Value

Type: PTypeInfo

See Also

Reference

  • TfrxPropertyEditorItem
  • frxDsgnIntf


TfrxPropertyItem Class

Summary

Represents type TfrxPropertyItem.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollectionItem
frxDsgnIntf.TfrxPropertyItem
Syntax
Delphi
type
 TfrxPropertyItem = class(TCollectionItem)
 end;

The TfrxPropertyItem type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TfrxPropertyItem class.
Top
Properties
Show:
Name | Description
Editor | Represents property Editor.
Expanded | Represents property Expanded.
SubProperty | Represents property SubProperty.
Top
Fields
Show:
Name | Description
FEditor | Represents field FEditor.
FExpanded | Represents field FExpanded.
FSubProperty | Represents field FSubProperty.
Top
See Also

Reference

  • frxDsgnIntf


TfrxPropertyItem Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TfrxPropertyItem class.
Top


TfrxPropertyItem.Destroy Destructor

Summary

Represents the destructor of the TfrxPropertyItem class.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxPropertyItem
  • frxDsgnIntf


TfrxPropertyItem Properties

Properties
Name | Description
Editor | Represents property Editor.
Expanded | Represents property Expanded.
SubProperty | Represents property SubProperty.
Top


TfrxPropertyItem.Editor Property

Summary

Represents property Editor.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Editor: TfrxPropertyEditor read FEditor;

Property Value

Type: TfrxPropertyEditor

See Also

Reference

  • TfrxPropertyItem
  • frxDsgnIntf


TfrxPropertyItem.Expanded Property

Summary

Represents property Expanded.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Expanded: Boolean read FExpanded write FExpanded;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPropertyItem
  • frxDsgnIntf


TfrxPropertyItem.SubProperty Property

Summary

Represents property SubProperty.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property SubProperty: TfrxPropertyList read FSubProperty;

Property Value

Type: TfrxPropertyList

See Also

Reference

  • TfrxPropertyItem
  • frxDsgnIntf


TfrxPropertyItem Fields

Fields
Name | Description
FEditor | Represents field FEditor.
FExpanded | Represents field FExpanded.
FSubProperty | Represents field FSubProperty.
Top


TfrxPropertyItem.FEditor Field

Summary

Represents field FEditor.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FEditor: TfrxPropertyEditor;

Field Value

Type: TfrxPropertyEditor

See Also

Reference

  • TfrxPropertyItem
  • frxDsgnIntf


TfrxPropertyItem.FExpanded Field

Summary

Represents field FExpanded.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FExpanded: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPropertyItem
  • frxDsgnIntf


TfrxPropertyItem.FSubProperty Field

Summary

Represents field FSubProperty.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FSubProperty: TfrxPropertyList;

Field Value

Type: TfrxPropertyList

See Also

Reference

  • TfrxPropertyItem
  • frxDsgnIntf


TfrxPropertyList Class

Summary

Represents type TfrxPropertyList.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollection
frxDsgnIntf.TfrxPropertyList
Syntax
Delphi
type
 TfrxPropertyList = class(TCollection)
 end;

The TfrxPropertyList type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | Initializes a new instance of the TfrxPropertyList class.
Top
Properties
Show:
Name | Description
Component | Represents property Component.
Filter | Represents property Filter.
Items[Integer] | Represents property Items[Integer].
Parent | Represents property Parent.
Top
Methods
Show:
Name | Description
Add | Represents method Add.
AddProperties(TfrxPropertyList) | Represents method AddProperties(TfrxPropertyList).
FillCommonProperties(TfrxPropertyList) | Represents method FillCommonProperties(TfrxPropertyList).
FillProperties(TPersistent) | Represents method FillProperties(TPersistent).
GetPropertyItem(Integer) | Represents method GetPropertyItem(Integer).
SetComponent(TPersistent) | Represents method SetComponent(TPersistent).
SetFilter(String) | Represents method SetFilter(String).
Top
Fields
Show:
Name | Description
FComponent | Represents field FComponent.
FDesigner | Represents field FDesigner.
FFilter | Represents field FFilter.
FParent | Represents field FParent.
Top
See Also

Reference

  • frxDsgnIntf


TfrxPropertyList Constructors

Constructors
Name | Description
Create(TfrxCustomDesigner) | Initializes a new instance of the TfrxPropertyList class.
Top


TfrxPropertyList.Create(TfrxCustomDesigner) Constructor

Summary

Initializes a new instance of the TfrxPropertyList class.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 constructor Create(Designer: TfrxCustomDesigner);

Parameters

Designer
Type: TfrxCustomDesigner

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList Properties

Properties
Name | Description
Component | Represents property Component.
Filter | Represents property Filter.
Items[Integer] | Represents property Items[Integer].
Parent | Represents property Parent.
Top


TfrxPropertyList.Component Property

Summary

Represents property Component.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Component: TPersistent read FComponent write SetComponent;

Property Value

Type: TPersistent

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList.Filter Property

Summary

Represents property Filter.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Filter: String read FFilter write SetFilter;

Property Value

Type: String

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxPropertyItem read GetPropertyItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxPropertyItem

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList.Parent Property

Summary

Represents property Parent.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Parent: TfrxPropertyList read FParent;

Property Value

Type: TfrxPropertyList

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList Methods

Methods
Name | Description
Add | Represents method Add.
AddProperties(TfrxPropertyList) | Represents method AddProperties(TfrxPropertyList).
FillCommonProperties(TfrxPropertyList) | Represents method FillCommonProperties(TfrxPropertyList).
FillProperties(TPersistent) | Represents method FillProperties(TPersistent).
GetPropertyItem(Integer) | Represents method GetPropertyItem(Integer).
SetComponent(TPersistent) | Represents method SetComponent(TPersistent).
SetFilter(String) | Represents method SetFilter(String).
Top


TfrxPropertyList.Add Method

Summary

Represents method Add.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function Add: TfrxPropertyItem;

Return Value

Type: TfrxPropertyItem

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList.AddProperties(TfrxPropertyList) Method

Summary

Represents method AddProperties(TfrxPropertyList).

Namespace: frxDsgnIntf
Syntax
Delphi
private
 procedure AddProperties(PropertyList: TfrxPropertyList);

Parameters

PropertyList
Type: TfrxPropertyList

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList.FillCommonProperties(TfrxPropertyList) Method

Summary

Represents method FillCommonProperties(TfrxPropertyList).

Namespace: frxDsgnIntf
Syntax
Delphi
private
 procedure FillCommonProperties(PropertyList: TfrxPropertyList);

Parameters

PropertyList
Type: TfrxPropertyList

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList.FillProperties(TPersistent) Method

Summary

Represents method FillProperties(TPersistent).

Namespace: frxDsgnIntf
Syntax
Delphi
private
 procedure FillProperties(AClass: TPersistent);

Parameters

AClass
Type: TPersistent

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList.GetPropertyItem(Integer) Method

Summary

Represents method GetPropertyItem(Integer).

Namespace: frxDsgnIntf
Syntax
Delphi
private
 function GetPropertyItem(Index: Integer): TfrxPropertyItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxPropertyItem

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList.SetComponent(TPersistent) Method

Summary

Represents method SetComponent(TPersistent).

Namespace: frxDsgnIntf
Syntax
Delphi
private
 procedure SetComponent(Value: TPersistent);

Parameters

Value
Type: TPersistent

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList.SetFilter(String) Method

Summary

Represents method SetFilter(String).

Namespace: frxDsgnIntf
Syntax
Delphi
private
 procedure SetFilter(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList Fields

Fields
Name | Description
FComponent | Represents field FComponent.
FDesigner | Represents field FDesigner.
FFilter | Represents field FFilter.
FParent | Represents field FParent.
Top


TfrxPropertyList.FComponent Field

Summary

Represents field FComponent.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FComponent: TPersistent;

Field Value

Type: TPersistent

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList.FDesigner Field

Summary

Represents field FDesigner.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FDesigner: TfrxCustomDesigner;

Field Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList.FFilter Field

Summary

Represents field FFilter.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FFilter: String;

Field Value

Type: String

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxPropertyList.FParent Field

Summary

Represents field FParent.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FParent: TfrxPropertyList;

Field Value

Type: TfrxPropertyList

See Also

Reference

  • TfrxPropertyList
  • frxDsgnIntf


TfrxSaveFilterItem Class

Summary

Represents type TfrxSaveFilterItem.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollectionItem
frxDsgnIntf.TfrxSaveFilterItem
Syntax
Delphi
type
 TfrxSaveFilterItem = class(TCollectionItem)
 end;

The TfrxSaveFilterItem type exposes the following members.

Fields
Show:
Name | Description
SaveFilter | Represents field SaveFilter.
Top
See Also

Reference

  • frxDsgnIntf


TfrxSaveFilterItem Fields

Fields
Name | Description
SaveFilter | Represents field SaveFilter.
Top


TfrxSaveFilterItem.SaveFilter Field

Summary

Represents field SaveFilter.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 SaveFilter: TfrxCustomIOTransport;

Field Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxSaveFilterItem
  • frxDsgnIntf


TfrxSaveFiltersCollection Class

Summary

Represents type TfrxSaveFiltersCollection.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollection
frxDsgnIntf.TfrxSaveFiltersCollection
Syntax
Delphi
type
 TfrxSaveFiltersCollection = class(TCollection)
 end;

The TfrxSaveFiltersCollection type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxSaveFiltersCollection class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
GetSaveFilterItem(Integer) | Represents method GetSaveFilterItem(Integer).
Register(TfrxCustomIOTransport) | Represents method Register(TfrxCustomIOTransport).
Unregister(TfrxCustomIOTransport) | Represents method Unregister(TfrxCustomIOTransport).
Top
See Also

Reference

  • frxDsgnIntf


TfrxSaveFiltersCollection Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxSaveFiltersCollection class.
Top


TfrxSaveFiltersCollection.Create Constructor

Summary

Initializes a new instance of the TfrxSaveFiltersCollection class.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxSaveFiltersCollection
  • frxDsgnIntf


TfrxSaveFiltersCollection Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxSaveFiltersCollection.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxSaveFilterItem
 read GetSaveFilterItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxSaveFilterItem

See Also

Reference

  • TfrxSaveFiltersCollection
  • frxDsgnIntf


TfrxSaveFiltersCollection Methods

Methods
Name | Description
GetSaveFilterItem(Integer) | Represents method GetSaveFilterItem(Integer).
Register(TfrxCustomIOTransport) | Represents method Register(TfrxCustomIOTransport).
Unregister(TfrxCustomIOTransport) | Represents method Unregister(TfrxCustomIOTransport).
Top


TfrxSaveFiltersCollection.GetSaveFilterItem(Integer) Method

Summary

Represents method GetSaveFilterItem(Integer).

Namespace: frxDsgnIntf
Syntax
Delphi
private
 function GetSaveFilterItem(Index: Integer): TfrxSaveFilterItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxSaveFilterItem

See Also

Reference

  • TfrxSaveFiltersCollection
  • frxDsgnIntf


TfrxSaveFiltersCollection.Register(TfrxCustomIOTransport) Method

Summary

Represents method Register(TfrxCustomIOTransport).

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure Register(Filter: TfrxCustomIOTransport);

Parameters

Filter
Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxSaveFiltersCollection
  • frxDsgnIntf


TfrxSaveFiltersCollection.Unregister(TfrxCustomIOTransport) Method

Summary

Represents method Unregister(TfrxCustomIOTransport).

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure Unregister(Filter: TfrxCustomIOTransport);

Parameters

Filter
Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxSaveFiltersCollection
  • frxDsgnIntf


TfrxSetElementProperty Class

Summary

The standard editor of properties of type Set element.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxSetElementProperty
Syntax
Delphi
type
 TfrxSetElementProperty = class(TfrxPropertyEditor)
 end;

The TfrxSetElementProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Overrides TfrxPropertyEditor.GetName.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
FElement | Represents field FElement.
Top
See Also

Reference

  • frxDsgnIntf


TfrxSetElementProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetName | Method returns the name of the property. (Overrides TfrxPropertyEditor.GetName.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
Top


TfrxSetElementProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxSetElementProperty
  • frxDsgnIntf


TfrxSetElementProperty.GetName Method

Summary

Method returns the name of the property.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetName: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetName
See Also

Reference

  • TfrxSetElementProperty
  • frxDsgnIntf


TfrxSetElementProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxSetElementProperty
  • frxDsgnIntf


TfrxSetElementProperty.GetValues Method

Summary

The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure GetValues; override;

Overrides

TfrxPropertyEditor.GetValues
See Also

Reference

  • TfrxSetElementProperty
  • frxDsgnIntf


TfrxSetElementProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxPropertyEditor.SetValue(String)
See Also

Reference

  • TfrxSetElementProperty
  • frxDsgnIntf


TfrxSetElementProperty Fields

Fields
Name | Description
FElement | Represents field FElement.
Top


TfrxSetElementProperty.FElement Field

Summary

Represents field FElement.

Namespace: frxDsgnIntf
Syntax
Delphi
private
 FElement: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSetElementProperty
  • frxDsgnIntf


TfrxSetProperty Class

Summary

The standard editor of properties of type Set.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxSetProperty
Syntax
Delphi
type
 TfrxSetProperty = class(TfrxPropertyEditor)
 end;

The TfrxSetProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Inherited from TfrxPropertyEditor.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Inherited from TfrxPropertyEditor.)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxSetProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
Top


TfrxSetProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxSetProperty
  • frxDsgnIntf


TfrxSetProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxSetProperty
  • frxDsgnIntf


TfrxShortCutProperty Class

Summary

The standard editor of properties of type TShortCut.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxShortCutProperty
Syntax
Delphi
type
 TfrxShortCutProperty = class(TfrxPropertyEditor)
 end;

The TfrxShortCutProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxShortCutProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
Top


TfrxShortCutProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxShortCutProperty
  • frxDsgnIntf


TfrxShortCutProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxShortCutProperty
  • frxDsgnIntf


TfrxShortCutProperty.GetValues Method

Summary

The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure GetValues; override;

Overrides

TfrxPropertyEditor.GetValues
See Also

Reference

  • TfrxShortCutProperty
  • frxDsgnIntf


TfrxShortCutProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxPropertyEditor.SetValue(String)
See Also

Reference

  • TfrxShortCutProperty
  • frxDsgnIntf


TfrxStringProperty Class

Summary

The standard editor of properties of type String.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxStringProperty
frxDsgnIntf.TfrxClassNameProperty
frxDsgnIntf.TfrxFontNameProperty
frxDsgnIntf.TfrxNameProperty
Syntax
Delphi
type
 TfrxStringProperty = class(TfrxPropertyEditor)
 end;

The TfrxStringProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Inherited from TfrxPropertyEditor.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Inherited from TfrxPropertyEditor.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxStringProperty Methods

Methods
Name | Description
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
Top


TfrxStringProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxStringProperty
  • frxDsgnIntf


TfrxStringProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxPropertyEditor.SetValue(String)
See Also

Reference

  • TfrxStringProperty
  • frxDsgnIntf


TfrxTimeProperty Class

Summary

Represents type TfrxTimeProperty.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxDsgnIntf.TfrxTimeProperty
Syntax
Delphi
type
 TfrxTimeProperty = class(TfrxPropertyEditor)
 end;

The TfrxTimeProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Inherited from TfrxPropertyEditor.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Inherited from TfrxPropertyEditor.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxDsgnIntf


TfrxTimeProperty Methods

Methods
Name | Description
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
Top


TfrxTimeProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxTimeProperty
  • frxDsgnIntf


TfrxTimeProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxPropertyEditor.SetValue(String)
See Also

Reference

  • TfrxTimeProperty
  • frxDsgnIntf


TfrxWizardCollection Class

Summary

The TfrxWizardCollection class represents a list of wizards registered in the FastReport. frxWizards global object contains an instance of this class.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollection
frxDsgnIntf.TfrxWizardCollection
Syntax
Delphi
type
 TfrxWizardCollection = class(TCollection)
 end;

The TfrxWizardCollection type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxWizardCollection class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
GetWizardItem(Integer) | Represents method GetWizardItem(Integer).
Register(TfrxWizardClass,TBitmap,Boolean,TBitmap) | Registers a wizard. At registration, one enters the name of the wizard's class, its picture, and specifies if the wizard is placed in the "Wizards" toolbar. If the wizard should be placed in the toolbar, the ButtonBmp size must be either 16x16 pixels, or 32x32 pixels otherwise.
Register1(TfrxWizardClass,Integer) | Represents method Register1(TfrxWizardClass,Integer).
Unregister(TfrxWizardClass) | Deletes a wizard from the list of registered items.
Top
See Also

Reference

  • frxDsgnIntf


TfrxWizardCollection Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxWizardCollection class.
Top


TfrxWizardCollection.Create Constructor

Summary

Initializes a new instance of the TfrxWizardCollection class.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxWizardCollection
  • frxDsgnIntf


TfrxWizardCollection Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxWizardCollection.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxDsgnIntf
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxWizardItem read GetWizardItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxWizardItem

See Also

Reference

  • TfrxWizardCollection
  • frxDsgnIntf


TfrxWizardCollection Methods

Methods
Name | Description
GetWizardItem(Integer) | Represents method GetWizardItem(Integer).
Register(TfrxWizardClass,TBitmap,Boolean,TBitmap) | Registers a wizard. At registration, one enters the name of the wizard's class, its picture, and specifies if the wizard is placed in the "Wizards" toolbar. If the wizard should be placed in the toolbar, the ButtonBmp size must be either 16x16 pixels, or 32x32 pixels otherwise.
Register1(TfrxWizardClass,Integer) | Represents method Register1(TfrxWizardClass,Integer).
Unregister(TfrxWizardClass) | Deletes a wizard from the list of registered items.
Top


TfrxWizardCollection.GetWizardItem(Integer) Method

Summary

Represents method GetWizardItem(Integer).

Namespace: frxDsgnIntf
Syntax
Delphi
private
 function GetWizardItem(Index: Integer): TfrxWizardItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxWizardItem

See Also

Reference

  • TfrxWizardCollection
  • frxDsgnIntf


TfrxWizardCollection.Register(TfrxWizardClass,TBitmap,Boolean,TBitmap) Method

Summary

Registers a wizard. At registration, one enters the name of the wizard's class, its picture, and specifies if the wizard is placed in the "Wizards" toolbar. If the wizard should be placed in the toolbar, the ButtonBmp size must be either 16x16 pixels, or 32x32 pixels otherwise.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure Register(ClassRef: TfrxWizardClass; ButtonBmp: TBitmap;
 IsToolbarWizard: Boolean = False; Bmp32x32: TBitmap = nil);

Parameters

ClassRef
Type: TfrxWizardClass

ButtonBmp
Type: TBitmap

IsToolbarWizard
Type: Boolean

Bmp32x32
Type: TBitmap

See Also

Reference

  • TfrxWizardCollection
  • frxDsgnIntf


TfrxWizardCollection.Register1(TfrxWizardClass,Integer) Method

Summary

Represents method Register1(TfrxWizardClass,Integer).

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure Register1(ClassRef: TfrxWizardClass; ImageIndex: Integer);

Parameters

ClassRef
Type: TfrxWizardClass

ImageIndex
Type: Integer

See Also

Reference

  • TfrxWizardCollection
  • frxDsgnIntf


TfrxWizardCollection.Unregister(TfrxWizardClass) Method

Summary

Deletes a wizard from the list of registered items.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 procedure Unregister(ClassRef: TfrxWizardClass);

Parameters

ClassRef
Type: TfrxWizardClass

See Also

Reference

  • TfrxWizardCollection
  • frxDsgnIntf


TfrxWizardItem Class

Summary

Represents type TfrxWizardItem.

Namespace: frxDsgnIntf
Inheritance Hierarchy
TCollectionItem
frxDsgnIntf.TfrxWizardItem
Syntax
Delphi
type
 TfrxWizardItem = class(TCollectionItem)
 end;

The TfrxWizardItem type exposes the following members.

Fields
Show:
Name | Description
ButtonBmp | Represents field ButtonBmp.
ButtonImageIndex | Represents field ButtonImageIndex.
ClassRef | Represents field ClassRef.
IsToolbarWizard | Represents field IsToolbarWizard.
ToolBarButtonImageIndex | Represents field ToolBarButtonImageIndex.
WizardButtonBmp | Represents field WizardButtonBmp.
Top
See Also

Reference

  • frxDsgnIntf


TfrxWizardItem Fields

Fields
Name | Description
ButtonBmp | Represents field ButtonBmp.
ButtonImageIndex | Represents field ButtonImageIndex.
ClassRef | Represents field ClassRef.
IsToolbarWizard | Represents field IsToolbarWizard.
ToolBarButtonImageIndex | Represents field ToolBarButtonImageIndex.
WizardButtonBmp | Represents field WizardButtonBmp.
Top


TfrxWizardItem.ButtonBmp Field

Summary

Represents field ButtonBmp.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 ButtonBmp: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxWizardItem
  • frxDsgnIntf


TfrxWizardItem.ButtonImageIndex Field

Summary

Represents field ButtonImageIndex.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 ButtonImageIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxWizardItem
  • frxDsgnIntf


TfrxWizardItem.ClassRef Field

Summary

Represents field ClassRef.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 ClassRef: TfrxWizardClass;

Field Value

Type: TfrxWizardClass

See Also

Reference

  • TfrxWizardItem
  • frxDsgnIntf


TfrxWizardItem.IsToolbarWizard Field

Summary

Represents field IsToolbarWizard.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 IsToolbarWizard: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxWizardItem
  • frxDsgnIntf


TfrxWizardItem.ToolBarButtonImageIndex Field

Summary

Represents field ToolBarButtonImageIndex.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 ToolBarButtonImageIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxWizardItem
  • frxDsgnIntf


TfrxWizardItem.WizardButtonBmp Field

Summary

Represents field WizardButtonBmp.

Namespace: frxDsgnIntf
Syntax
Delphi
public
 WizardButtonBmp: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxWizardItem
  • frxDsgnIntf


frxDsgnIntf Enumerations

Enumerations
Name | Description
TfrxObjectCategory | Represents type TfrxObjectCategory.
TfrxPropertyAttribute | Property editor attributes.
Top


TfrxObjectCategory Enumeration

Summary

Represents type TfrxObjectCategory.

Namespace: frxDsgnIntf
Syntax
Delphi
type
 TfrxObjectCategory = (ctData, ctReport, ctDialog, ctDMP, ctNone);

The TfrxObjectCategory type exposes the following members.

Members
Show:
Name | Description
ctData | Represents constant ctData.
ctDialog | Represents constant ctDialog.
ctDMP | Represents constant ctDMP.
ctNone | Represents constant ctNone.
ctReport | Represents constant ctReport.
Top
See Also

Reference

  • frxDsgnIntf


TfrxPropertyAttribute Enumeration

Summary

Property editor attributes.

Namespace: frxDsgnIntf
Syntax
Delphi
type
 TfrxPropertyAttribute = (
 paValueList,
 paSortList,
 paDialog,
 paMultiSelect,
 paSubProperties,
 paReadOnly,
 paOwnerDraw);

The TfrxPropertyAttribute type exposes the following members.

Members
Show:
Name | Description
paDialog | The property has an editor. If this attribute is presented, the ... button is displayed in the right part of the editing line. The Edit method is called on by clicking on it.
paMultiSelect | Allow editing of the given property in some objects selected at the same time. Some properties (such as "Name", etc) do not have this attribute.
paOwnerDraw | Drawing of the property's value is performed via the "OnDrawItem" method. If the "paValueList" attribute is defined, then drawing of the drop-down list is performed via the OnDrawLBItem method.
paReadOnly | It is impossible to modify a value in the editor line. Some properties, being the "Class" or "Set" types, possess this attribute.
paSortList | Sorts the list's elements. It is used together with paValueList.
paSubProperties | The property is an object of the TPersistent type and has its own properties, which are also should be displayed. (This function is exemplified in the "Font" property)
paValueList | The property represents the dropdown list of values. (This function is exemplified in the "Color" property). If this attribute is presented, the "GetValues" method should be overridden.
Top
See Also

Reference

  • frxDsgnIntf


frxDsgnIntf Types

Types
Name | Description
TfrxComponentEditorClass | Represents type TfrxComponentEditorClass.
TfrxObjectCategories | Represents type TfrxObjectCategories.
TfrxPropertyAttributes | Property editor attributes.
TfrxPropertyEditorClass | Represents type TfrxPropertyEditorClass.
Top


TfrxComponentEditorClass Type

Summary

Represents type TfrxComponentEditorClass.

Namespace: frxDsgnIntf
Syntax
Delphi
type
 TfrxComponentEditorClass = class of TfrxComponentEditor;
See Also

Reference

  • frxDsgnIntf


TfrxObjectCategories Type

Summary

Represents type TfrxObjectCategories.

Namespace: frxDsgnIntf
Syntax
Delphi
type
 TfrxObjectCategories = set of TfrxObjectCategory;
See Also

Reference

  • frxDsgnIntf


TfrxPropertyAttributes Type

Summary

Property editor attributes.

Namespace: frxDsgnIntf
Syntax
Delphi
type
 TfrxPropertyAttributes = set of TfrxPropertyAttribute;
See Also

Reference

  • frxDsgnIntf


TfrxPropertyEditorClass Type

Summary

Represents type TfrxPropertyEditorClass.

Namespace: frxDsgnIntf
Syntax
Delphi
type
 TfrxPropertyEditorClass = class of TfrxPropertyEditor;
See Also

Reference

  • frxDsgnIntf


frxDsgnIntf Routines

Routines
Name | Description
frxComponentEditors | List of component editors registered in the FastReport.
frxCreatePropertyList(TList,TfrxCustomDesigner,String) | Represents method frxCreatePropertyList(TList,TfrxCustomDesigner,String).
frxExportFilters | List of export filters registered in the FastReport.
frxHideProperties(TClass,String) | Represents method frxHideProperties(TClass,String).
frxObjects | List of add-in objects registered in the FastReport.
frxPropertyEditors | List of property editors registered in the FastReport.
frxWizards | List of wizards registered in the FastReport.
Top


frxComponentEditors Method

Summary

List of component editors registered in the FastReport.

Namespace: frxDsgnIntf
Syntax
Delphi
function frxComponentEditors: TfrxComponentEditorCollection;

Return Value

Type: TfrxComponentEditorCollection

See Also

Reference

  • frxDsgnIntf


frxCreatePropertyList(TList,TfrxCustomDesigner,String) Method

Summary

Represents method frxCreatePropertyList(TList,TfrxCustomDesigner,String).

Namespace: frxDsgnIntf
Syntax
Delphi
function frxCreatePropertyList(ComponentList: TList; Designer: TfrxCustomDesigner; aFilter: String = ''): TfrxPropertyList;

Parameters

ComponentList
Type: TList

Designer
Type: TfrxCustomDesigner

aFilter
Type: String

Return Value

Type: TfrxPropertyList

See Also

Reference

  • frxDsgnIntf


frxExportFilters Method

Summary

List of export filters registered in the FastReport.

Namespace: frxDsgnIntf
Syntax
Delphi
function frxExportFilters: TfrxExportFilterCollection;

Return Value

Type: TfrxExportFilterCollection

See Also

Reference

  • frxDsgnIntf


frxHideProperties(TClass,String) Method

Summary

Represents method frxHideProperties(TClass,String).

Namespace: frxDsgnIntf
Syntax
Delphi
procedure frxHideProperties(ComponentClass: TClass; const Properties: String);

Parameters

ComponentClass
Type: TClass

Properties
Type: String

See Also

Reference

  • frxDsgnIntf


frxObjects Method

Summary

List of add-in objects registered in the FastReport.

Namespace: frxDsgnIntf
Syntax
Delphi
function frxObjects: TfrxObjectCollection;

Return Value

Type: TfrxObjectCollection

See Also

Reference

  • frxDsgnIntf


frxPropertyEditors Method

Summary

List of property editors registered in the FastReport.

Namespace: frxDsgnIntf
Syntax
Delphi
function frxPropertyEditors: TfrxPropertyEditorCollection;

Return Value

Type: TfrxPropertyEditorCollection

See Also

Reference

  • frxDsgnIntf


frxWizards Method

Summary

List of wizards registered in the FastReport.

Namespace: frxDsgnIntf
Syntax
Delphi
function frxWizards: TfrxWizardCollection;

Return Value

Type: TfrxWizardCollection

See Also

Reference

  • frxDsgnIntf


frxEngine Namespace

Summary

Represents namespace frxEngine.

Classes
Name | Description
TfrxEngine | Represents type TfrxEngine.
TfrxHeaderList | Represents type TfrxHeaderList.
TfrxHeaderListItem | Represents type TfrxHeaderListItem.
TfrxShiftEngine | Represents type TfrxShiftEngine.
Top


frxEngine Classes

Classes
Name | Description
TfrxEngine | Represents type TfrxEngine.
TfrxHeaderList | Represents type TfrxHeaderList.
TfrxHeaderListItem | Represents type TfrxHeaderListItem.
TfrxShiftEngine | Represents type TfrxShiftEngine.
Top


TfrxEngine Class

Summary

Represents type TfrxEngine.

Namespace: frxEngine
Inheritance Hierarchy
TPersistent
frxClass.TfrxCustomEngine
frxEngine.TfrxEngine
Syntax
Delphi
type
 TfrxEngine = class(TfrxCustomEngine)
 end;

The TfrxEngine type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport) | Initializes a new instance of the TfrxEngine class. (Overrides TfrxCustomEngine.Create(TfrxReport).)
Destroy | Represents the destructor of the TfrxEngine class. (Overrides TfrxCustomEngine.Destroy.)
Top
Properties
Show:
Name | Description
CurColumn | The number of the current column in a multi-columned report. A value can be assigned to this property. (Inherited from TfrxCustomEngine.)
CurLine | Current line number. (Inherited from TfrxCustomEngine.)
CurLineThrough | Current absolute line number (<Line#>). (Inherited from TfrxCustomEngine.)
CurTableColumn | Current column of the table. (Inherited from TfrxCustomEngine.)
CurTableRow | Current row of the table. (Inherited from TfrxCustomEngine.)
CurVColumn | The number of the current column in a cross-tab report. (Inherited from TfrxCustomEngine.)
CurX | The current shift of the coordinates on the X-axis. A value can be assigned to this property. (Inherited from TfrxCustomEngine.)
CurY | The current shift of the coordinates on the Y-axis. A value can be assigned to this property. (Inherited from TfrxCustomEngine.)
DoublePass | Equal to "True," if the report is a two-pass one. Analogous to Report.EngineOptions.DoublePass. (Inherited from TfrxCustomEngine.)
FinalPass | Equal to "True," if the last pass of the two-pass report is performed. (Inherited from TfrxCustomEngine.)
NotifyList | List with objects that receives a notifications from report engine. (Inherited from TfrxCustomEngine.)
PageHeight | Printable region's height, in pixels. (Inherited from TfrxCustomEngine.)
PageWidth | Printable region's width, in pixels. (Inherited from TfrxCustomEngine.)
PreviewPages | Reference to prepared report pages. (Inherited from TfrxCustomEngine.)
Report | Reference to a report component. (Inherited from TfrxCustomEngine.)
Running | True when dialog pages are running. (Inherited from TfrxCustomEngine.)
SecondScriptCall | Flag for the determination of repeat call of event (in some cases the event can be called repeatedly during grouping), if True then the script has already been operated. (Inherited from TfrxCustomEngine.)
StartDate | Time of report running. A counterpart of the <Date> system variable. (Inherited from TfrxCustomEngine.)
StartTime | Time of report running. A counterpart of the <Time> system variable. (Inherited from TfrxCustomEngine.)
TotalPages | A number of output pages in a report. A counterpart of the <TotalPages> system variable. The report should be a two-pass one, so that this variable can be used. (Inherited from TfrxCustomEngine.)
Top
Methods
Show:
Name | Description
AddBandOutline(TfrxBand) | Represents method AddBandOutline(TfrxBand).
AddColumn | Represents method AddColumn.
AddPage | Represents method AddPage.
AddPageOutline | Represents method AddPageOutline.
AddToHeaderList(TfrxBand) | Represents method AddToHeaderList(TfrxBand).
AddToVHeaderList(TfrxBand) | Represents method AddToVHeaderList(TfrxBand).
BreakAllKeep | Breaks any keep operation currently active. (Overrides TfrxCustomEngine.BreakAllKeep.)
CanShow(TObject,Boolean) | Represents method CanShow(TObject,Boolean).
CheckBandColumns(TfrxDataBand,Integer,Integer,Extended,Extended) | Represents method CheckBandColumns(TfrxDataBand,Integer,Integer,Extended,Extended).
CheckDrill(TfrxDataBand,TfrxGroupHeader) | Represents method CheckDrill(TfrxDataBand,TfrxGroupHeader).
CheckGroups(TfrxDataBand,TfrxGroupHeader,Integer,Extended) | Represents method CheckGroups(TfrxDataBand,TfrxGroupHeader,Integer,Extended).
CheckSubReports(TfrxBand) | Represents method CheckSubReports(TfrxBand).
CheckSuppress(TfrxBand) | Represents method CheckSuppress(TfrxBand).
DoProcessState(TfrxBand,TfrxProcessAtMode) | Represents method DoProcessState(TfrxBand,TfrxProcessAtMode).
DoShow(TfrxBand) | Represents method DoShow(TfrxBand).
DrawSplit(TfrxBand) | Represents method DrawSplit(TfrxBand).
EndColumn | Represents method EndColumn.
EndKeep(TfrxBand) | Represents method EndKeep(TfrxBand).
EndPage | Called when page printing is finished. (Overrides TfrxCustomEngine.EndPage.)
Finalize | Represents method Finalize.
FindBand(TfrxBandClass) | Represents method FindBand(TfrxBandClass).
FooterHeight | Returns height of the footers. (Overrides TfrxCustomEngine.FooterHeight.)
FreeSpace | Returns height value of white space left on a page, in pixels. (Overrides TfrxCustomEngine.FreeSpace.)
GetAggregateValue(String,String,TfrxBand,Integer) | Returns value of aggregate function for an expression. (Overrides TfrxCustomEngine.GetAggregateValue(String,String,TfrxBand,Integer).)
GetPageHeight | Represents method GetPageHeight. (Overrides TfrxCustomEngine.GetPageHeight.)
HeaderHeight(Boolean) | Represents method HeaderHeight(Boolean). (Overrides TfrxCustomEngine.HeaderHeight(Boolean).)
InitGroups(TfrxDataBand,TfrxGroupHeader,Integer,Boolean) | Represents method InitGroups(TfrxDataBand,TfrxGroupHeader,Integer,Boolean).
Initialize | Represents method Initialize.
InitPage | Represents method InitPage.
NewColumn | Creates a new column in a multicolumn report. After the last column, page break is automatically inserted. (Overrides TfrxCustomEngine.NewColumn.)
NewPage | Creates a new page (page break). (Overrides TfrxCustomEngine.NewPage.)
NotifyObjects(TfrxBand) | Represents method NotifyObjects(TfrxBand).
OutlineRoot | Represents method OutlineRoot.
OutlineUp(TfrxBand) | Represents method OutlineUp(TfrxBand).
PreparePage(TStrings,Boolean) | Represents method PreparePage(TStrings,Boolean).
PrepareShiftTree(TfrxReportComponent) | Builds a shift tree of child objects for current container. (Overrides TfrxCustomEngine.PrepareShiftTree(TfrxReportComponent).)
ProcessObject(TfrxView) | Processed GetData for passed object. Used with paCustom flag. (Overrides TfrxCustomEngine.ProcessObject(TfrxView).)
RemoveFromHeaderList(TfrxBand) | Represents method RemoveFromHeaderList(TfrxBand).
RemoveFromVHeaderList(TfrxBand) | Represents method RemoveFromVHeaderList(TfrxBand).
ResetSuppressValues(TfrxBand) | Represents method ResetSuppressValues(TfrxBand).
RestoreVBandsObjects | Represents method RestoreVBandsObjects.
Run(Boolean,Boolean,TfrxPage) | This method runs the report engine. (Overrides TfrxCustomEngine.Run(Boolean,Boolean,TfrxPage).)
RunDialogs | Represents method RunDialogs.
RunPage(TfrxReportPage) | Represents method RunPage(TfrxReportPage).
RunReportPages(TfrxReportPage) | Represents method RunReportPages(TfrxReportPage).
ShowBand(TfrxBand) | Overloaded. Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted. (Overrides TfrxCustomEngine.ShowBand(TfrxBand).)
ShowBand(TfrxBandClass) | Overloaded. Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted. (Overrides TfrxCustomEngine.ShowBand(TfrxBandClass).)
ShowBandByName(String) | Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted. (Inherited from TfrxCustomEngine.)
ShowGroupFooters(TfrxGroupHeader,Integer,TfrxDataBand) | Represents method ShowGroupFooters(TfrxGroupHeader,Integer,TfrxDataBand).
ShowVBands(TfrxBand) | Represents method ShowVBands(TfrxBand).
StartKeep(TfrxBand,Integer) | Represents method StartKeep(TfrxBand,Integer).
StopReport | Stops report preparation. (Inherited from TfrxCustomEngine.)
Stretch(TfrxReportComponent) | Performs stretch operation on passed container object. (Overrides TfrxCustomEngine.Stretch(TfrxReportComponent).)
UnStretch(TfrxReportComponent) | Returns back state of the container after stretch operation. (Overrides TfrxCustomEngine.UnStretch(TfrxReportComponent).)
Top
Events
Show:
Name | Description
OnRunDialog | Occurs when report dialog page is previewed. (Inherited from TfrxCustomEngine.)
Top
Fields
Show:
Name | Description
FAggregates | Represents field FAggregates.
FBreakShowBandTree | Represents field FBreakShowBandTree.
FCallFromAddPage | Represents field FCallFromAddPage.
FCallFromEndPage | Represents field FCallFromEndPage.
FCallFromPHeader | Represents field FCallFromPHeader.
FCurBand | Represents field FCurBand.
FCurX | Represents field FCurX. (Inherited from TfrxCustomEngine.)
FCurY | Represents field FCurY. (Inherited from TfrxCustomEngine.)
FDontShowHeaders | Represents field FDontShowHeaders.
FFirstColumnY | Represents field FFirstColumnY.
FFirstReportPage | Represents field FFirstReportPage.
FHBandNamesTree | Represents field FHBandNamesTree.
FHeaderList | Represents field FHeaderList.
FIsFirstBand | Represents field FIsFirstBand.
FIsFirstPage | Represents field FIsFirstPage.
FIsLastPage | Represents field FIsLastPage.
FKeepAnchor | Represents field FKeepAnchor.
FKeepBand | Represents field FKeepBand.
FKeepCurY | Represents field FKeepCurY.
FKeepFooter | Represents field FKeepFooter.
FKeepHeader | Represents field FKeepHeader.
FKeeping | Represents field FKeeping.
FKeepOutline | Represents field FKeepOutline.
FKeepPosition | Represents field FKeepPosition.
FLastBandOnPage | Represents field FLastBandOnPage.
FLockResetAggregates | Represents field FLockResetAggregates.
FOutputTo | Represents field FOutputTo.
FPage | Represents field FPage.
FPageCurX | Represents field FPageCurX.
FPrevFooterHeight | Represents field FPrevFooterHeight.
FShiftEngine | Represents field FShiftEngine.
FStartNewPageBand | Represents field FStartNewPageBand.
FSubSaveCurY | Represents field FSubSaveCurY.
FSubSavePageN | Represents field FSubSavePageN.
FTitlePrinted | Represents field FTitlePrinted.
FVHeaderList | Represents field FVHeaderList.
FVMasterBand | Represents field FVMasterBand.
FVPageList | Represents field FVPageList.
Top
See Also

Reference

  • frxEngine


TfrxEngine Constructors

Constructors
Name | Description
Create(TfrxReport) | Initializes a new instance of the TfrxEngine class. (Overrides TfrxCustomEngine.Create(TfrxReport).)
Destroy | Represents the destructor of the TfrxEngine class. (Overrides TfrxCustomEngine.Destroy.)
Top


TfrxEngine.Create(TfrxReport) Constructor

Summary

Initializes a new instance of the TfrxEngine class.

Namespace: frxEngine
Syntax
Delphi
public
 constructor Create(AReport: TfrxReport); override;

Parameters

AReport
Type: TfrxReport

Overrides

TfrxCustomEngine.Create(TfrxReport)
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.Destroy Destructor

Summary

Represents the destructor of the TfrxEngine class.

Namespace: frxEngine
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxCustomEngine.Destroy
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine Methods

Methods
Name | Description
AddBandOutline(TfrxBand) | Represents method AddBandOutline(TfrxBand).
AddColumn | Represents method AddColumn.
AddPage | Represents method AddPage.
AddPageOutline | Represents method AddPageOutline.
AddToHeaderList(TfrxBand) | Represents method AddToHeaderList(TfrxBand).
AddToVHeaderList(TfrxBand) | Represents method AddToVHeaderList(TfrxBand).
BreakAllKeep | Breaks any keep operation currently active. (Overrides TfrxCustomEngine.BreakAllKeep.)
CanShow(TObject,Boolean) | Represents method CanShow(TObject,Boolean).
CheckBandColumns(TfrxDataBand,Integer,Integer,Extended,Extended) | Represents method CheckBandColumns(TfrxDataBand,Integer,Integer,Extended,Extended).
CheckDrill(TfrxDataBand,TfrxGroupHeader) | Represents method CheckDrill(TfrxDataBand,TfrxGroupHeader).
CheckGroups(TfrxDataBand,TfrxGroupHeader,Integer,Extended) | Represents method CheckGroups(TfrxDataBand,TfrxGroupHeader,Integer,Extended).
CheckSubReports(TfrxBand) | Represents method CheckSubReports(TfrxBand).
CheckSuppress(TfrxBand) | Represents method CheckSuppress(TfrxBand).
DoProcessState(TfrxBand,TfrxProcessAtMode) | Represents method DoProcessState(TfrxBand,TfrxProcessAtMode).
DoShow(TfrxBand) | Represents method DoShow(TfrxBand).
DrawSplit(TfrxBand) | Represents method DrawSplit(TfrxBand).
EndColumn | Represents method EndColumn.
EndKeep(TfrxBand) | Represents method EndKeep(TfrxBand).
EndPage | Called when page printing is finished. (Overrides TfrxCustomEngine.EndPage.)
Finalize | Represents method Finalize.
FindBand(TfrxBandClass) | Represents method FindBand(TfrxBandClass).
FooterHeight | Returns height of the footers. (Overrides TfrxCustomEngine.FooterHeight.)
FreeSpace | Returns height value of white space left on a page, in pixels. (Overrides TfrxCustomEngine.FreeSpace.)
GetAggregateValue(String,String,TfrxBand,Integer) | Returns value of aggregate function for an expression. (Overrides TfrxCustomEngine.GetAggregateValue(String,String,TfrxBand,Integer).)
GetPageHeight | Represents method GetPageHeight. (Overrides TfrxCustomEngine.GetPageHeight.)
HeaderHeight(Boolean) | Represents method HeaderHeight(Boolean). (Overrides TfrxCustomEngine.HeaderHeight(Boolean).)
InitGroups(TfrxDataBand,TfrxGroupHeader,Integer,Boolean) | Represents method InitGroups(TfrxDataBand,TfrxGroupHeader,Integer,Boolean).
Initialize | Represents method Initialize.
InitPage | Represents method InitPage.
NewColumn | Creates a new column in a multicolumn report. After the last column, page break is automatically inserted. (Overrides TfrxCustomEngine.NewColumn.)
NewPage | Creates a new page (page break). (Overrides TfrxCustomEngine.NewPage.)
NotifyObjects(TfrxBand) | Represents method NotifyObjects(TfrxBand).
OutlineRoot | Represents method OutlineRoot.
OutlineUp(TfrxBand) | Represents method OutlineUp(TfrxBand).
PreparePage(TStrings,Boolean) | Represents method PreparePage(TStrings,Boolean).
PrepareShiftTree(TfrxReportComponent) | Builds a shift tree of child objects for current container. (Overrides TfrxCustomEngine.PrepareShiftTree(TfrxReportComponent).)
ProcessObject(TfrxView) | Processed GetData for passed object. Used with paCustom flag. (Overrides TfrxCustomEngine.ProcessObject(TfrxView).)
RemoveFromHeaderList(TfrxBand) | Represents method RemoveFromHeaderList(TfrxBand).
RemoveFromVHeaderList(TfrxBand) | Represents method RemoveFromVHeaderList(TfrxBand).
ResetSuppressValues(TfrxBand) | Represents method ResetSuppressValues(TfrxBand).
RestoreVBandsObjects | Represents method RestoreVBandsObjects.
Run(Boolean,Boolean,TfrxPage) | This method runs the report engine. (Overrides TfrxCustomEngine.Run(Boolean,Boolean,TfrxPage).)
RunDialogs | Represents method RunDialogs.
RunPage(TfrxReportPage) | Represents method RunPage(TfrxReportPage).
RunReportPages(TfrxReportPage) | Represents method RunReportPages(TfrxReportPage).
ShowBand(TfrxBand) | Overloaded. Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted. (Overrides TfrxCustomEngine.ShowBand(TfrxBand).)
ShowBand(TfrxBandClass) | Overloaded. Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted. (Overrides TfrxCustomEngine.ShowBand(TfrxBandClass).)
ShowGroupFooters(TfrxGroupHeader,Integer,TfrxDataBand) | Represents method ShowGroupFooters(TfrxGroupHeader,Integer,TfrxDataBand).
ShowVBands(TfrxBand) | Represents method ShowVBands(TfrxBand).
StartKeep(TfrxBand,Integer) | Represents method StartKeep(TfrxBand,Integer).
Stretch(TfrxReportComponent) | Performs stretch operation on passed container object. (Overrides TfrxCustomEngine.Stretch(TfrxReportComponent).)
UnStretch(TfrxReportComponent) | Returns back state of the container after stretch operation. (Overrides TfrxCustomEngine.UnStretch(TfrxReportComponent).)
Top


TfrxEngine.AddBandOutline(TfrxBand) Method

Summary

Represents method AddBandOutline(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure AddBandOutline(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.AddColumn Method

Summary

Represents method AddColumn.

Namespace: frxEngine
Syntax
Delphi
private
 procedure AddColumn;
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.AddPage Method

Summary

Represents method AddPage.

Namespace: frxEngine
Syntax
Delphi
private
 procedure AddPage;
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.AddPageOutline Method

Summary

Represents method AddPageOutline.

Namespace: frxEngine
Syntax
Delphi
private
 procedure AddPageOutline;
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.AddToHeaderList(TfrxBand) Method

Summary

Represents method AddToHeaderList(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure AddToHeaderList(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.AddToVHeaderList(TfrxBand) Method

Summary

Represents method AddToVHeaderList(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure AddToVHeaderList(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.BreakAllKeep Method

Summary

Breaks any keep operation currently active.

Namespace: frxEngine
Syntax
Delphi
public
 procedure BreakAllKeep; override;

Overrides

TfrxCustomEngine.BreakAllKeep
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.CanShow(TObject,Boolean) Method

Summary

Represents method CanShow(TObject,Boolean).

Namespace: frxEngine
Syntax
Delphi
private
 function CanShow(Obj: TObject; PrintIfDetailEmpty: Boolean): Boolean;

Parameters

Obj
Type: TObject

PrintIfDetailEmpty
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.CheckBandColumns(TfrxDataBand,Integer,Integer,Extended,Extended) Method

Summary

Represents method CheckBandColumns(TfrxDataBand,Integer,Integer,Extended,Extended).

Namespace: frxEngine
Syntax
Delphi
private
 procedure CheckBandColumns(Band: TfrxDataBand; ColumnKeepPos: Integer; var HeaderKeepPos: Integer;
 SaveCurY, SaveHeaderY: Extended);

Parameters

Band
Type: TfrxDataBand

ColumnKeepPos
Type: Integer

HeaderKeepPos
Type: Integer

SaveCurY
Type: Extended

SaveHeaderY
Type: Extended

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.CheckDrill(TfrxDataBand,TfrxGroupHeader) Method

Summary

Represents method CheckDrill(TfrxDataBand,TfrxGroupHeader).

Namespace: frxEngine
Syntax
Delphi
private
 procedure CheckDrill(Master: TfrxDataBand; Band: TfrxGroupHeader);

Parameters

Master
Type: TfrxDataBand

Band
Type: TfrxGroupHeader

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.CheckGroups(TfrxDataBand,TfrxGroupHeader,Integer,Extended) Method

Summary

Represents method CheckGroups(TfrxDataBand,TfrxGroupHeader,Integer,Extended).

Namespace: frxEngine
Syntax
Delphi
private
 procedure CheckGroups(Master: TfrxDataBand; Band: TfrxGroupHeader;
 ColumnKeepPos: Integer; SaveCurY: Extended);

Parameters

Master
Type: TfrxDataBand

Band
Type: TfrxGroupHeader

ColumnKeepPos
Type: Integer

SaveCurY
Type: Extended

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.CheckSubReports(TfrxBand) Method

Summary

Represents method CheckSubReports(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure CheckSubReports(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.CheckSuppress(TfrxBand) Method

Summary

Represents method CheckSuppress(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure CheckSuppress(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.DoProcessState(TfrxBand,TfrxProcessAtMode) Method

Summary

Represents method DoProcessState(TfrxBand,TfrxProcessAtMode).

Namespace: frxEngine
Syntax
Delphi
protected
 procedure DoProcessState(aBand: TfrxBand; aState: TfrxProcessAtMode);

Parameters

aBand
Type: TfrxBand

aState
Type: TfrxProcessAtMode

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.DoShow(TfrxBand) Method

Summary

Represents method DoShow(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure DoShow(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.DrawSplit(TfrxBand) Method

Summary

Represents method DrawSplit(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure DrawSplit(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.EndColumn Method

Summary

Represents method EndColumn.

Namespace: frxEngine
Syntax
Delphi
private
 procedure EndColumn;
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.EndKeep(TfrxBand) Method

Summary

Represents method EndKeep(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure EndKeep(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.EndPage Method

Summary

Called when page printing is finished.

Namespace: frxEngine
Syntax
Delphi
public
 procedure EndPage; override;

Overrides

TfrxCustomEngine.EndPage
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.Finalize Method

Summary

Represents method Finalize.

Namespace: frxEngine
Syntax
Delphi
public
 procedure Finalize;
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FindBand(TfrxBandClass) Method

Summary

Represents method FindBand(TfrxBandClass).

Namespace: frxEngine
Syntax
Delphi
private
 function FindBand(Band: TfrxBandClass): TfrxBand;

Parameters

Band
Type: TfrxBandClass

Return Value

Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FooterHeight Method

Summary

Returns height of the footers.

Namespace: frxEngine
Syntax
Delphi
public
 function FooterHeight: Extended; override;

Return Value

Type: Extended

Overrides

TfrxCustomEngine.FooterHeight
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FreeSpace Method

Summary

Returns height value of white space left on a page, in pixels.

Namespace: frxEngine
Syntax
Delphi
public
 function FreeSpace: Extended; override;

Return Value

Type: Extended

Overrides

TfrxCustomEngine.FreeSpace
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.GetAggregateValue(String,String,TfrxBand,Integer) Method

Summary

Returns value of aggregate function for an expression.

Namespace: frxEngine
Syntax
Delphi
public
 function GetAggregateValue(const Name, Expression: String;
 Band: TfrxBand; Flags: Integer): Variant; override;

Parameters

Name
Type: String

Method name (aggregate name).

Expression
Type: String

Expression.

Band
Type: TfrxBand

Band reference.

Flags
Type: Integer

Flag.

Return Value

Type: Variant

Overrides

TfrxCustomEngine.GetAggregateValue(String,String,TfrxBand,Integer)
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.GetPageHeight Method

Summary

Represents method GetPageHeight.

Namespace: frxEngine
Syntax
Delphi
protected
 function GetPageHeight: Extended; override;

Return Value

Type: Extended

Overrides

TfrxCustomEngine.GetPageHeight
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.HeaderHeight(Boolean) Method

Summary

Represents method HeaderHeight(Boolean).

Namespace: frxEngine
Syntax
Delphi
public
 function HeaderHeight(AddReprintOnNewPage: Boolean = False): Extended; override;

Parameters

AddReprintOnNewPage
Type: Boolean

Return Value

Type: Extended

Overrides

TfrxCustomEngine.HeaderHeight(Boolean)
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.InitGroups(TfrxDataBand,TfrxGroupHeader,Integer,Boolean) Method

Summary

Represents method InitGroups(TfrxDataBand,TfrxGroupHeader,Integer,Boolean).

Namespace: frxEngine
Syntax
Delphi
private
 procedure InitGroups(Master: TfrxDataBand; Band: TfrxGroupHeader;
 Index: Integer; ResetLineN: Boolean = False);

Parameters

Master
Type: TfrxDataBand

Band
Type: TfrxGroupHeader

Index
Type: Integer

ResetLineN
Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.Initialize Method

Summary

Represents method Initialize.

Namespace: frxEngine
Syntax
Delphi
public
 function Initialize: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.InitPage Method

Summary

Represents method InitPage.

Namespace: frxEngine
Syntax
Delphi
private
 procedure InitPage;
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.NewColumn Method

Summary

Creates a new column in a multicolumn report. After the last column, page break is automatically inserted.

Namespace: frxEngine
Syntax
Delphi
public
 procedure NewColumn; override;

Overrides

TfrxCustomEngine.NewColumn
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.NewPage Method

Summary

Creates a new page (page break).

Namespace: frxEngine
Syntax
Delphi
public
 procedure NewPage; override;

Overrides

TfrxCustomEngine.NewPage
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.NotifyObjects(TfrxBand) Method

Summary

Represents method NotifyObjects(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure NotifyObjects(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.OutlineRoot Method

Summary

Represents method OutlineRoot.

Namespace: frxEngine
Syntax
Delphi
private
 procedure OutlineRoot;
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.OutlineUp(TfrxBand) Method

Summary

Represents method OutlineUp(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure OutlineUp(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.PreparePage(TStrings,Boolean) Method

Summary

Represents method PreparePage(TStrings,Boolean).

Namespace: frxEngine
Syntax
Delphi
private
 procedure PreparePage(ErrorList: TStrings; PrepareVBands: Boolean);

Parameters

ErrorList
Type: TStrings

PrepareVBands
Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.PrepareShiftTree(TfrxReportComponent) Method

Summary

Builds a shift tree of child objects for current container.

Namespace: frxEngine
Syntax
Delphi
public
 procedure PrepareShiftTree(Container: TfrxReportComponent); override;

Parameters

Container
Type: TfrxReportComponent

Objects container.

Overrides

TfrxCustomEngine.PrepareShiftTree(TfrxReportComponent)
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.ProcessObject(TfrxView) Method

Summary

Processed GetData for passed object. Used with paCustom flag.

Namespace: frxEngine
Syntax
Delphi
public
 procedure ProcessObject(ReportObject: TfrxView); override;

Parameters

ReportObject
Type: TfrxView

Overrides

TfrxCustomEngine.ProcessObject(TfrxView)
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.RemoveFromHeaderList(TfrxBand) Method

Summary

Represents method RemoveFromHeaderList(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure RemoveFromHeaderList(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.RemoveFromVHeaderList(TfrxBand) Method

Summary

Represents method RemoveFromVHeaderList(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure RemoveFromVHeaderList(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.ResetSuppressValues(TfrxBand) Method

Summary

Represents method ResetSuppressValues(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure ResetSuppressValues(Band: TfrxBand);

Parameters

Band
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.RestoreVBandsObjects Method

Summary

Represents method RestoreVBandsObjects.

Namespace: frxEngine
Syntax
Delphi
private
 procedure RestoreVBandsObjects;
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.Run(Boolean,Boolean,TfrxPage) Method

Summary

This method runs the report engine.

Namespace: frxEngine
Syntax
Delphi
public
 function Run(ARunDialogs: Boolean; AClearLast: Boolean = False; APage: TfrxPage = nil): Boolean; override;

Parameters

ARunDialogs
Type: Boolean

If True, Processes report dialog pages.

AClearLast
Type: Boolean

Clears last result from prepared pages.

APage
Type: TfrxPage

Reference to a page(if nil, prepares all).

Return Value

Type: Boolean

Overrides

TfrxCustomEngine.Run(Boolean,Boolean,TfrxPage)
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.RunDialogs Method

Summary

Represents method RunDialogs.

Namespace: frxEngine
Syntax
Delphi
private
 function RunDialogs: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.RunPage(TfrxReportPage) Method

Summary

Represents method RunPage(TfrxReportPage).

Namespace: frxEngine
Syntax
Delphi
private
 procedure RunPage(Page: TfrxReportPage);

Parameters

Page
Type: TfrxReportPage

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.RunReportPages(TfrxReportPage) Method

Summary

Represents method RunReportPages(TfrxReportPage).

Namespace: frxEngine
Syntax
Delphi
private
 procedure RunReportPages(APage: TfrxReportPage);

Parameters

APage
Type: TfrxReportPage

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.ShowBand(TfrxBand) Method

Summary

Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted.

Namespace: frxEngine
Syntax
Delphi
public
 function ShowBand(Band: TfrxBand): TfrxBand; overload; override;

Parameters

Band
Type: TfrxBand

Return Value

Type: TfrxBand

Overrides

TfrxCustomEngine.ShowBand(TfrxBand)
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.ShowBand(TfrxBandClass) Method

Summary

Displays a band with a specified name. After displaying a band, the "CurY" position is automatically shifted.

Namespace: frxEngine
Syntax
Delphi
public
 procedure ShowBand(Band: TfrxBandClass); overload; override;

Parameters

Band
Type: TfrxBandClass

Overrides

TfrxCustomEngine.ShowBand(TfrxBandClass)
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.ShowGroupFooters(TfrxGroupHeader,Integer,TfrxDataBand) Method

Summary

Represents method ShowGroupFooters(TfrxGroupHeader,Integer,TfrxDataBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure ShowGroupFooters(Band: TfrxGroupHeader; Index: Integer; Master: TfrxDataBand);

Parameters

Band
Type: TfrxGroupHeader

Index
Type: Integer

Master
Type: TfrxDataBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.ShowVBands(TfrxBand) Method

Summary

Represents method ShowVBands(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
private
 procedure ShowVBands(HBand: TfrxBand);

Parameters

HBand
Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.StartKeep(TfrxBand,Integer) Method

Summary

Represents method StartKeep(TfrxBand,Integer).

Namespace: frxEngine
Syntax
Delphi
private
 procedure StartKeep(Band: TfrxBand; Position: Integer = 0);

Parameters

Band
Type: TfrxBand

Position
Type: Integer

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.Stretch(TfrxReportComponent) Method

Summary

Performs stretch operation on passed container object.

Namespace: frxEngine
Syntax
Delphi
public
 procedure Stretch(Container: TfrxReportComponent); override;

Parameters

Container
Type: TfrxReportComponent

Band

Container object.

Overrides

TfrxCustomEngine.Stretch(TfrxReportComponent)
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.UnStretch(TfrxReportComponent) Method

Summary

Returns back state of the container after stretch operation.

Namespace: frxEngine
Syntax
Delphi
public
 procedure UnStretch(Container: TfrxReportComponent); override;

Parameters

Container
Type: TfrxReportComponent

Band

Container object.

Overrides

TfrxCustomEngine.UnStretch(TfrxReportComponent)
See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine Fields

Fields
Name | Description
FAggregates | Represents field FAggregates.
FBreakShowBandTree | Represents field FBreakShowBandTree.
FCallFromAddPage | Represents field FCallFromAddPage.
FCallFromEndPage | Represents field FCallFromEndPage.
FCallFromPHeader | Represents field FCallFromPHeader.
FCurBand | Represents field FCurBand.
FDontShowHeaders | Represents field FDontShowHeaders.
FFirstColumnY | Represents field FFirstColumnY.
FFirstReportPage | Represents field FFirstReportPage.
FHBandNamesTree | Represents field FHBandNamesTree.
FHeaderList | Represents field FHeaderList.
FIsFirstBand | Represents field FIsFirstBand.
FIsFirstPage | Represents field FIsFirstPage.
FIsLastPage | Represents field FIsLastPage.
FKeepAnchor | Represents field FKeepAnchor.
FKeepBand | Represents field FKeepBand.
FKeepCurY | Represents field FKeepCurY.
FKeepFooter | Represents field FKeepFooter.
FKeepHeader | Represents field FKeepHeader.
FKeeping | Represents field FKeeping.
FKeepOutline | Represents field FKeepOutline.
FKeepPosition | Represents field FKeepPosition.
FLastBandOnPage | Represents field FLastBandOnPage.
FLockResetAggregates | Represents field FLockResetAggregates.
FOutputTo | Represents field FOutputTo.
FPage | Represents field FPage.
FPageCurX | Represents field FPageCurX.
FPrevFooterHeight | Represents field FPrevFooterHeight.
FShiftEngine | Represents field FShiftEngine.
FStartNewPageBand | Represents field FStartNewPageBand.
FSubSaveCurY | Represents field FSubSaveCurY.
FSubSavePageN | Represents field FSubSavePageN.
FTitlePrinted | Represents field FTitlePrinted.
FVHeaderList | Represents field FVHeaderList.
FVMasterBand | Represents field FVMasterBand.
FVPageList | Represents field FVPageList.
Top


TfrxEngine.FAggregates Field

Summary

Represents field FAggregates.

Namespace: frxEngine
Syntax
Delphi
private
 FAggregates: TfrxAggregateList;

Field Value

Type: TfrxAggregateList

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FBreakShowBandTree Field

Summary

Represents field FBreakShowBandTree.

Namespace: frxEngine
Syntax
Delphi
private
 FBreakShowBandTree: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FCallFromAddPage Field

Summary

Represents field FCallFromAddPage.

Namespace: frxEngine
Syntax
Delphi
private
 FCallFromAddPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FCallFromEndPage Field

Summary

Represents field FCallFromEndPage.

Namespace: frxEngine
Syntax
Delphi
private
 FCallFromEndPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FCallFromPHeader Field

Summary

Represents field FCallFromPHeader.

Namespace: frxEngine
Syntax
Delphi
private
 FCallFromPHeader: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FCurBand Field

Summary

Represents field FCurBand.

Namespace: frxEngine
Syntax
Delphi
private
 FCurBand: TfrxBand;

Field Value

Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FDontShowHeaders Field

Summary

Represents field FDontShowHeaders.

Namespace: frxEngine
Syntax
Delphi
private
 FDontShowHeaders: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FFirstColumnY Field

Summary

Represents field FFirstColumnY.

Namespace: frxEngine
Syntax
Delphi
private
 FFirstColumnY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FFirstReportPage Field

Summary

Represents field FFirstReportPage.

Namespace: frxEngine
Syntax
Delphi
private
 FFirstReportPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FHBandNamesTree Field

Summary

Represents field FHBandNamesTree.

Namespace: frxEngine
Syntax
Delphi
private
 FHBandNamesTree: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FHeaderList Field

Summary

Represents field FHeaderList.

Namespace: frxEngine
Syntax
Delphi
private
 FHeaderList: TfrxHeaderList;

Field Value

Type: TfrxHeaderList

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FIsFirstBand Field

Summary

Represents field FIsFirstBand.

Namespace: frxEngine
Syntax
Delphi
private
 FIsFirstBand: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FIsFirstPage Field

Summary

Represents field FIsFirstPage.

Namespace: frxEngine
Syntax
Delphi
private
 FIsFirstPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FIsLastPage Field

Summary

Represents field FIsLastPage.

Namespace: frxEngine
Syntax
Delphi
private
 FIsLastPage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FKeepAnchor Field

Summary

Represents field FKeepAnchor.

Namespace: frxEngine
Syntax
Delphi
private
 FKeepAnchor: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FKeepBand Field

Summary

Represents field FKeepBand.

Namespace: frxEngine
Syntax
Delphi
private
 FKeepBand: TfrxBand;

Field Value

Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FKeepCurY Field

Summary

Represents field FKeepCurY.

Namespace: frxEngine
Syntax
Delphi
private
 FKeepCurY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FKeepFooter Field

Summary

Represents field FKeepFooter.

Namespace: frxEngine
Syntax
Delphi
private
 FKeepFooter: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FKeepHeader Field

Summary

Represents field FKeepHeader.

Namespace: frxEngine
Syntax
Delphi
private
 FKeepHeader: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FKeeping Field

Summary

Represents field FKeeping.

Namespace: frxEngine
Syntax
Delphi
private
 FKeeping: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FKeepOutline Field

Summary

Represents field FKeepOutline.

Namespace: frxEngine
Syntax
Delphi
private
 FKeepOutline: TfrxXMLItem;

Field Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FKeepPosition Field

Summary

Represents field FKeepPosition.

Namespace: frxEngine
Syntax
Delphi
private
 FKeepPosition: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FLastBandOnPage Field

Summary

Represents field FLastBandOnPage.

Namespace: frxEngine
Syntax
Delphi
private
 FLastBandOnPage: TfrxBand;

Field Value

Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FLockResetAggregates Field

Summary

Represents field FLockResetAggregates.

Namespace: frxEngine
Syntax
Delphi
private
 FLockResetAggregates: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FOutputTo Field

Summary

Represents field FOutputTo.

Namespace: frxEngine
Syntax
Delphi
private
 FOutputTo: TfrxNullBand;

Field Value

Type: TfrxNullBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FPage Field

Summary

Represents field FPage.

Namespace: frxEngine
Syntax
Delphi
private
 FPage: TfrxReportPage;

Field Value

Type: TfrxReportPage

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FPageCurX Field

Summary

Represents field FPageCurX.

Namespace: frxEngine
Syntax
Delphi
private
 FPageCurX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FPrevFooterHeight Field

Summary

Represents field FPrevFooterHeight.

Namespace: frxEngine
Syntax
Delphi
private
 FPrevFooterHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FShiftEngine Field

Summary

Represents field FShiftEngine.

Namespace: frxEngine
Syntax
Delphi
private
 FShiftEngine: TfrxShiftEngine;

Field Value

Type: TfrxShiftEngine

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FStartNewPageBand Field

Summary

Represents field FStartNewPageBand.

Namespace: frxEngine
Syntax
Delphi
private
 FStartNewPageBand: TfrxBand;

Field Value

Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FSubSaveCurY Field

Summary

Represents field FSubSaveCurY.

Namespace: frxEngine
Syntax
Delphi
private
 FSubSaveCurY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FSubSavePageN Field

Summary

Represents field FSubSavePageN.

Namespace: frxEngine
Syntax
Delphi
private
 FSubSavePageN: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FTitlePrinted Field

Summary

Represents field FTitlePrinted.

Namespace: frxEngine
Syntax
Delphi
private
 FTitlePrinted: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FVHeaderList Field

Summary

Represents field FVHeaderList.

Namespace: frxEngine
Syntax
Delphi
private
 FVHeaderList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FVMasterBand Field

Summary

Represents field FVMasterBand.

Namespace: frxEngine
Syntax
Delphi
private
 FVMasterBand: TfrxBand;

Field Value

Type: TfrxBand

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxEngine.FVPageList Field

Summary

Represents field FVPageList.

Namespace: frxEngine
Syntax
Delphi
private
 FVPageList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxEngine
  • frxEngine


TfrxHeaderList Class

Summary

Represents type TfrxHeaderList.

Namespace: frxEngine
Inheritance Hierarchy
TObject
frxEngine.TfrxHeaderList
Syntax
Delphi
type
 TfrxHeaderList = class(TObject)
 end;

The TfrxHeaderList type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxHeaderList class.
Destroy | Represents the destructor of the TfrxHeaderList class.
Top
Properties
Show:
Name | Description
Count | Represents property Count.
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
AddItem(TfrxBand,Extended,Boolean) | Represents method AddItem(TfrxBand,Extended,Boolean).
Clear | Represents method Clear.
GetCount | Represents method GetCount.
GetItems(Integer) | Represents method GetItems(Integer).
RemoveItem(TfrxBand) | Represents method RemoveItem(TfrxBand).
Top
Fields
Show:
Name | Description
FList | Represents field FList.
Top
See Also

Reference

  • frxEngine


TfrxHeaderList Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxHeaderList class.
Destroy | Represents the destructor of the TfrxHeaderList class.
Top


TfrxHeaderList.Create Constructor

Summary

Initializes a new instance of the TfrxHeaderList class.

Namespace: frxEngine
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxHeaderList
  • frxEngine


TfrxHeaderList.Destroy Destructor

Summary

Represents the destructor of the TfrxHeaderList class.

Namespace: frxEngine
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxHeaderList
  • frxEngine


TfrxHeaderList Properties

Properties
Name | Description
Count | Represents property Count.
Items[Integer] | Represents property Items[Integer].
Top


TfrxHeaderList.Count Property

Summary

Represents property Count.

Namespace: frxEngine
Syntax
Delphi
public
 property Count: Integer read GetCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxHeaderList
  • frxEngine


TfrxHeaderList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxEngine
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxHeaderListItem read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxHeaderListItem

See Also

Reference

  • TfrxHeaderList
  • frxEngine


TfrxHeaderList Methods

Methods
Name | Description
AddItem(TfrxBand,Extended,Boolean) | Represents method AddItem(TfrxBand,Extended,Boolean).
Clear | Represents method Clear.
GetCount | Represents method GetCount.
GetItems(Integer) | Represents method GetItems(Integer).
RemoveItem(TfrxBand) | Represents method RemoveItem(TfrxBand).
Top


TfrxHeaderList.AddItem(TfrxBand,Extended,Boolean) Method

Summary

Represents method AddItem(TfrxBand,Extended,Boolean).

Namespace: frxEngine
Syntax
Delphi
public
 procedure AddItem(ABand: TfrxBand; ALeft: Extended; AInKeepList: Boolean);

Parameters

ABand
Type: TfrxBand

ALeft
Type: Extended

AInKeepList
Type: Boolean

See Also

Reference

  • TfrxHeaderList
  • frxEngine


TfrxHeaderList.Clear Method

Summary

Represents method Clear.

Namespace: frxEngine
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxHeaderList
  • frxEngine


TfrxHeaderList.GetCount Method

Summary

Represents method GetCount.

Namespace: frxEngine
Syntax
Delphi
private
 function GetCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxHeaderList
  • frxEngine


TfrxHeaderList.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxEngine
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxHeaderListItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxHeaderListItem

See Also

Reference

  • TfrxHeaderList
  • frxEngine


TfrxHeaderList.RemoveItem(TfrxBand) Method

Summary

Represents method RemoveItem(TfrxBand).

Namespace: frxEngine
Syntax
Delphi
public
 procedure RemoveItem(ABand: TfrxBand);

Parameters

ABand
Type: TfrxBand

See Also

Reference

  • TfrxHeaderList
  • frxEngine


TfrxHeaderList Fields

Fields
Name | Description
FList | Represents field FList.
Top


TfrxHeaderList.FList Field

Summary

Represents field FList.

Namespace: frxEngine
Syntax
Delphi
private
 FList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxHeaderList
  • frxEngine


TfrxHeaderListItem Class

Summary

Represents type TfrxHeaderListItem.

Namespace: frxEngine
Inheritance Hierarchy
TObject
frxEngine.TfrxHeaderListItem
Syntax
Delphi
type
 TfrxHeaderListItem = class(TObject)
 end;

The TfrxHeaderListItem type exposes the following members.

Fields
Show:
Name | Description
Band | Represents field Band.
IsInKeepList | Represents field IsInKeepList.
Left | Represents field Left.
Top
See Also

Reference

  • frxEngine


TfrxHeaderListItem Fields

Fields
Name | Description
Band | Represents field Band.
IsInKeepList | Represents field IsInKeepList.
Left | Represents field Left.
Top


TfrxHeaderListItem.Band Field

Summary

Represents field Band.

Namespace: frxEngine
Syntax
Delphi
public
 Band: TfrxBand;

Field Value

Type: TfrxBand

See Also

Reference

  • TfrxHeaderListItem
  • frxEngine


TfrxHeaderListItem.IsInKeepList Field

Summary

Represents field IsInKeepList.

Namespace: frxEngine
Syntax
Delphi
public
 IsInKeepList: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxHeaderListItem
  • frxEngine


TfrxHeaderListItem.Left Field

Summary

Represents field Left.

Namespace: frxEngine
Syntax
Delphi
public
 Left: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxHeaderListItem
  • frxEngine


TfrxShiftEngine Class

Summary

Represents type TfrxShiftEngine.

Namespace: frxEngine
Inheritance Hierarchy
TObject
frxEngine.TfrxShiftEngine
Syntax
Delphi
type
 TfrxShiftEngine = class(TObject)
 end;

The TfrxShiftEngine type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxShiftEngine class.
Destroy | Represents the destructor of the TfrxShiftEngine class.
Top
Methods
Show:
Name | Description
Clear | Represents method Clear.
ClearContainer(TfrxReportComponent) | Represents method ClearContainer(TfrxReportComponent).
ClearDestroyQueue | Represents method ClearDestroyQueue.
ContainerToDestroyQueue(TObject) | Represents method ContainerToDestroyQueue(TObject).
InitShiftAmount(TfrxReportComponent,Extended) | Represents method InitShiftAmount(TfrxReportComponent,Extended).
PrepareShiftTree(TfrxReportComponent) | Represents method PrepareShiftTree(TfrxReportComponent).
ShiftObjects(TfrxReportComponent) | Represents method ShiftObjects(TfrxReportComponent).
Top
Fields
Show:
Name | Description
FContainers | Represents field FContainers.
FDestroyQueue | Represents field FDestroyQueue.
Top
See Also

Reference

  • frxEngine


TfrxShiftEngine Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxShiftEngine class.
Destroy | Represents the destructor of the TfrxShiftEngine class.
Top


TfrxShiftEngine.Create Constructor

Summary

Initializes a new instance of the TfrxShiftEngine class.

Namespace: frxEngine
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxShiftEngine
  • frxEngine


TfrxShiftEngine.Destroy Destructor

Summary

Represents the destructor of the TfrxShiftEngine class.

Namespace: frxEngine
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxShiftEngine
  • frxEngine


TfrxShiftEngine Methods

Methods
Name | Description
Clear | Represents method Clear.
ClearContainer(TfrxReportComponent) | Represents method ClearContainer(TfrxReportComponent).
ClearDestroyQueue | Represents method ClearDestroyQueue.
ContainerToDestroyQueue(TObject) | Represents method ContainerToDestroyQueue(TObject).
InitShiftAmount(TfrxReportComponent,Extended) | Represents method InitShiftAmount(TfrxReportComponent,Extended).
PrepareShiftTree(TfrxReportComponent) | Represents method PrepareShiftTree(TfrxReportComponent).
ShiftObjects(TfrxReportComponent) | Represents method ShiftObjects(TfrxReportComponent).
Top


TfrxShiftEngine.Clear Method

Summary

Represents method Clear.

Namespace: frxEngine
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxShiftEngine
  • frxEngine


TfrxShiftEngine.ClearContainer(TfrxReportComponent) Method

Summary

Represents method ClearContainer(TfrxReportComponent).

Namespace: frxEngine
Syntax
Delphi
public
 procedure ClearContainer(Container: TfrxReportComponent);

Parameters

Container
Type: TfrxReportComponent

See Also

Reference

  • TfrxShiftEngine
  • frxEngine


TfrxShiftEngine.ClearDestroyQueue Method

Summary

Represents method ClearDestroyQueue.

Namespace: frxEngine
Syntax
Delphi
public
 procedure ClearDestroyQueue;
See Also

Reference

  • TfrxShiftEngine
  • frxEngine


TfrxShiftEngine.ContainerToDestroyQueue(TObject) Method

Summary

Represents method ContainerToDestroyQueue(TObject).

Namespace: frxEngine
Syntax
Delphi
public
 procedure ContainerToDestroyQueue(AContainer: TObject);

Parameters

AContainer
Type: TObject

See Also

Reference

  • TfrxShiftEngine
  • frxEngine


TfrxShiftEngine.InitShiftAmount(TfrxReportComponent,Extended) Method

Summary

Represents method InitShiftAmount(TfrxReportComponent,Extended).

Namespace: frxEngine
Syntax
Delphi
public
 procedure InitShiftAmount(AObject: TfrxReportComponent; ShiftAmount: Extended);

Parameters

AObject
Type: TfrxReportComponent

ShiftAmount
Type: Extended

See Also

Reference

  • TfrxShiftEngine
  • frxEngine


TfrxShiftEngine.PrepareShiftTree(TfrxReportComponent) Method

Summary

Represents method PrepareShiftTree(TfrxReportComponent).

Namespace: frxEngine
Syntax
Delphi
public
 procedure PrepareShiftTree(Container: TfrxReportComponent);

Parameters

Container
Type: TfrxReportComponent

See Also

Reference

  • TfrxShiftEngine
  • frxEngine


TfrxShiftEngine.ShiftObjects(TfrxReportComponent) Method

Summary

Represents method ShiftObjects(TfrxReportComponent).

Namespace: frxEngine
Syntax
Delphi
public
 procedure ShiftObjects(Container: TfrxReportComponent);

Parameters

Container
Type: TfrxReportComponent

See Also

Reference

  • TfrxShiftEngine
  • frxEngine


TfrxShiftEngine Fields

Fields
Name | Description
FContainers | Represents field FContainers.
FDestroyQueue | Represents field FDestroyQueue.
Top


TfrxShiftEngine.FContainers Field

Summary

Represents field FContainers.

Namespace: frxEngine
Syntax
Delphi
private
 FContainers: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxShiftEngine
  • frxEngine


TfrxShiftEngine.FDestroyQueue Field

Summary

Represents field FDestroyQueue.

Namespace: frxEngine
Syntax
Delphi
private
 FDestroyQueue: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxShiftEngine
  • frxEngine


frxERSIShapeDBFImport Namespace

Summary

Represents namespace frxERSIShapeDBFImport.

Classes
Name | Description
TERSIDBFFile | Represents type TERSIDBFFile.
TERSIDBFFileColumn | Represents type TERSIDBFFileColumn.
Top
Records
Name | Description
TERSIDBFFieldDescriptor | Represents type TERSIDBFFieldDescriptor.
TERSIDBFFileHeader | Represents type TERSIDBFFileHeader.
Top
Enumerations
Name | Description
TDBFFieldType | Represents type TDBFFieldType.
Top
Types
Name | Description
TAnsiCharSet | Represents type TAnsiCharSet.
Top


frxERSIShapeDBFImport Classes

Classes
Name | Description
TERSIDBFFile | Represents type TERSIDBFFile.
TERSIDBFFileColumn | Represents type TERSIDBFFileColumn.
Top


TERSIDBFFile Class

Summary

Represents type TERSIDBFFile.

Namespace: frxERSIShapeDBFImport
Inheritance Hierarchy
TObject
frxERSIShapeDBFImport.TERSIDBFFile
Syntax
Delphi
type
 TERSIDBFFile = class
 end;

The TERSIDBFFile type exposes the following members.

Constructors
Show:
Name | Description
Create(string,integer) | Initializes a new instance of the TERSIDBFFile class.
Destroy | Represents the destructor of the TERSIDBFFile class.
Top
Properties
Show:
Name | Description
CodePage | Represents property CodePage.
LegendByColumn[Integer,Integer] | Represents property LegendByColumn[Integer,Integer].
Legend[AnsiString,Integer] | Represents property Legend[AnsiString,Integer].
Top
Methods
Show:
Name | Description
GetCodePage | Represents method GetCodePage.
GetColumnList(TStrings) | Represents method GetColumnList(TStrings).
GetLegend(AnsiString,Integer) | Represents method GetLegend(AnsiString,Integer).
GetLegendByColumn(Integer,Integer) | Represents method GetLegendByColumn(Integer,Integer).
IsUTF8 | Represents method IsUTF8.
ReadFromStream(TStream,integer) | Represents method ReadFromStream(TStream,integer).
Top
Fields
Show:
Name | Description
FColumns | Represents field FColumns.
FCPG | Represents field FCPG.
FDBFFileHeader | Represents field FDBFFileHeader.
Top
See Also

Reference

  • frxERSIShapeDBFImport


TERSIDBFFile Constructors

Constructors
Name | Description
Create(string,integer) | Initializes a new instance of the TERSIDBFFile class.
Destroy | Represents the destructor of the TERSIDBFFile class.
Top


TERSIDBFFile.Create(string,integer) Constructor

Summary

Initializes a new instance of the TERSIDBFFile class.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 constructor Create(const FileName: string; RecordCount: integer);

Parameters

FileName
Type: string

RecordCount
Type: integer

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile.Destroy Destructor

Summary

Represents the destructor of the TERSIDBFFile class.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile Properties

Properties
Name | Description
CodePage | Represents property CodePage.
LegendByColumn[Integer,Integer] | Represents property LegendByColumn[Integer,Integer].
Legend[AnsiString,Integer] | Represents property Legend[AnsiString,Integer].
Top


TERSIDBFFile.CodePage Property

Summary

Represents property CodePage.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 property CodePage: integer read GetCodePage;

Property Value

Type: integer

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile.LegendByColumn[Integer,Integer] Property

Summary

Represents property LegendByColumn[Integer,Integer].

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 property LegendByColumn[iColumn, iRecord: Integer]: AnsiString read GetLegendByColumn;

Parameters

iColumn
Type: Integer

iRecord
Type: Integer

Property Value

Type: AnsiString

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile.Legend[AnsiString,Integer] Property

Summary

Represents property Legend[AnsiString,Integer].

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 property Legend[FieldName: AnsiString; iRecord: Integer]: AnsiString read GetLegend;

Parameters

FieldName
Type: AnsiString

iRecord
Type: Integer

Property Value

Type: AnsiString

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile Methods

Methods
Name | Description
GetCodePage | Represents method GetCodePage.
GetColumnList(TStrings) | Represents method GetColumnList(TStrings).
GetLegend(AnsiString,Integer) | Represents method GetLegend(AnsiString,Integer).
GetLegendByColumn(Integer,Integer) | Represents method GetLegendByColumn(Integer,Integer).
IsUTF8 | Represents method IsUTF8.
ReadFromStream(TStream,integer) | Represents method ReadFromStream(TStream,integer).
Top


TERSIDBFFile.GetCodePage Method

Summary

Represents method GetCodePage.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
private
 function GetCodePage: integer;

Return Value

Type: integer

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile.GetColumnList(TStrings) Method

Summary

Represents method GetColumnList(TStrings).

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 procedure GetColumnList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile.GetLegend(AnsiString,Integer) Method

Summary

Represents method GetLegend(AnsiString,Integer).

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
private
 function GetLegend(FieldName: AnsiString; iRecord: Integer): AnsiString;

Parameters

FieldName
Type: AnsiString

iRecord
Type: Integer

Return Value

Type: AnsiString

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile.GetLegendByColumn(Integer,Integer) Method

Summary

Represents method GetLegendByColumn(Integer,Integer).

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
private
 function GetLegendByColumn(iColumn, iRecord: Integer): AnsiString;

Parameters

iColumn
Type: Integer

iRecord
Type: Integer

Return Value

Type: AnsiString

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile.IsUTF8 Method

Summary

Represents method IsUTF8.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 function IsUTF8: boolean;

Return Value

Type: boolean

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile.ReadFromStream(TStream,integer) Method

Summary

Represents method ReadFromStream(TStream,integer).

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
protected
 procedure ReadFromStream(Stream: TStream; RecordCount: integer);

Parameters

Stream
Type: TStream

RecordCount
Type: integer

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile Fields

Fields
Name | Description
FColumns | Represents field FColumns.
FCPG | Represents field FCPG.
FDBFFileHeader | Represents field FDBFFileHeader.
Top


TERSIDBFFile.FColumns Field

Summary

Represents field FColumns.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
protected
 FColumns: array of TERSIDBFFileColumn;

Field Value

Type: array of TERSIDBFFileColumn

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile.FCPG Field

Summary

Represents field FCPG.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
protected
 FCPG: string;

Field Value

Type: string

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFile.FDBFFileHeader Field

Summary

Represents field FDBFFileHeader.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
protected
 FDBFFileHeader: TERSIDBFFileHeader;

Field Value

Type: TERSIDBFFileHeader

See Also

Reference

  • TERSIDBFFile
  • frxERSIShapeDBFImport


TERSIDBFFileColumn Class

Summary

Represents type TERSIDBFFileColumn.

Namespace: frxERSIShapeDBFImport
Inheritance Hierarchy
TObject
frxERSIShapeDBFImport.TERSIDBFFileColumn
Syntax
Delphi
type
 TERSIDBFFileColumn = class
 end;

The TERSIDBFFileColumn type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream,LongWord) | Initializes a new instance of the TERSIDBFFileColumn class.
Top
Properties
Show:
Name | Description
Data[integer] | Represents property Data[integer].
FieldLength | Represents property FieldLength.
FieldName | Represents property FieldName.
FieldType | Represents property FieldType.
Top
Methods
Show:
Name | Description
BufferToAnsiString(TAnsiCharSet,TAnsiCharSet) | Represents method BufferToAnsiString(TAnsiCharSet,TAnsiCharSet).
GetData(integer) | Represents method GetData(integer).
Read(TStream,integer) | Represents method Read(TStream,integer).
Top
Fields
Show:
Name | Description
FBuffer | Represents field FBuffer.
FData | Represents field FData.
FFieldLength | Represents field FFieldLength.
FFieldName | Represents field FFieldName.
FFieldType | Represents field FFieldType.
Top
See Also

Reference

  • frxERSIShapeDBFImport


TERSIDBFFileColumn Constructors

Constructors
Name | Description
Create(TStream,LongWord) | Initializes a new instance of the TERSIDBFFileColumn class.
Top


TERSIDBFFileColumn.Create(TStream,LongWord) Constructor

Summary

Initializes a new instance of the TERSIDBFFileColumn class.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 constructor Create(Stream: TStream; NumberOfRecords: LongWord);

Parameters

Stream
Type: TStream

NumberOfRecords
Type: LongWord

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


TERSIDBFFileColumn Properties

Properties
Name | Description
Data[integer] | Represents property Data[integer].
FieldLength | Represents property FieldLength.
FieldName | Represents property FieldName.
FieldType | Represents property FieldType.
Top


TERSIDBFFileColumn.Data[integer] Property

Summary

Represents property Data[integer].

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 property Data[iRecord: integer]: AnsiString read GetData;

Parameters

iRecord
Type: integer

Property Value

Type: AnsiString

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


TERSIDBFFileColumn.FieldLength Property

Summary

Represents property FieldLength.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 property FieldLength: Byte read FFieldLength;

Property Value

Type: Byte

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


TERSIDBFFileColumn.FieldName Property

Summary

Represents property FieldName.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 property FieldName: AnsiString read FFieldName;

Property Value

Type: AnsiString

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


TERSIDBFFileColumn.FieldType Property

Summary

Represents property FieldType.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 property FieldType: TDBFFieldType read FFieldType;

Property Value

Type: TDBFFieldType

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


TERSIDBFFileColumn Methods

Methods
Name | Description
BufferToAnsiString(TAnsiCharSet,TAnsiCharSet) | Represents method BufferToAnsiString(TAnsiCharSet,TAnsiCharSet).
GetData(integer) | Represents method GetData(integer).
Read(TStream,integer) | Represents method Read(TStream,integer).
Top


TERSIDBFFileColumn.BufferToAnsiString(TAnsiCharSet,TAnsiCharSet) Method

Summary

Represents method BufferToAnsiString(TAnsiCharSet,TAnsiCharSet).

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
protected
 function BufferToAnsiString(TrimLeft, TrimRight: TAnsiCharSet): AnsiString;

Parameters

TrimLeft
Type: TAnsiCharSet

TrimRight
Type: TAnsiCharSet

Return Value

Type: AnsiString

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


TERSIDBFFileColumn.GetData(integer) Method

Summary

Represents method GetData(integer).

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
private
 function GetData(iRecord: integer): AnsiString;

Parameters

iRecord
Type: integer

Return Value

Type: AnsiString

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


TERSIDBFFileColumn.Read(TStream,integer) Method

Summary

Represents method Read(TStream,integer).

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 procedure Read(Stream: TStream; CurrentRecord: integer);

Parameters

Stream
Type: TStream

CurrentRecord
Type: integer

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


TERSIDBFFileColumn Fields

Fields
Name | Description
FBuffer | Represents field FBuffer.
FData | Represents field FData.
FFieldLength | Represents field FFieldLength.
FFieldName | Represents field FFieldName.
FFieldType | Represents field FFieldType.
Top


TERSIDBFFileColumn.FBuffer Field

Summary

Represents field FBuffer.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
protected
 FBuffer: array of AnsiChar;

Field Value

Type: array of AnsiChar

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


TERSIDBFFileColumn.FData Field

Summary

Represents field FData.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
private
 FData: array of AnsiString;

Field Value

Type: array of AnsiString

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


TERSIDBFFileColumn.FFieldLength Field

Summary

Represents field FFieldLength.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
private
 FFieldLength: Byte;

Field Value

Type: Byte

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


TERSIDBFFileColumn.FFieldName Field

Summary

Represents field FFieldName.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
private
 FFieldName: AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


TERSIDBFFileColumn.FFieldType Field

Summary

Represents field FFieldType.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
private
 FFieldType: TDBFFieldType;

Field Value

Type: TDBFFieldType

See Also

Reference

  • TERSIDBFFileColumn
  • frxERSIShapeDBFImport


frxERSIShapeDBFImport Records

Records
Name | Description
TERSIDBFFieldDescriptor | Represents type TERSIDBFFieldDescriptor.
TERSIDBFFileHeader | Represents type TERSIDBFFileHeader.
Top


TERSIDBFFieldDescriptor Record

Summary

Represents type TERSIDBFFieldDescriptor.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
type
 TERSIDBFFieldDescriptor = packed record
 end;

The TERSIDBFFieldDescriptor type exposes the following members.

Fields
Show:
Name | Description
DecimalCount | Represents field DecimalCount.
FieldLength | Represents field FieldLength.
FieldName | Represents field FieldName.
FieldType | Represents field FieldType.
IndexFieldFlag | Represents field IndexFieldFlag.
Reserved0 | Represents field Reserved0.
Reserved1 | Represents field Reserved1.
Top
See Also

Reference

  • frxERSIShapeDBFImport


TERSIDBFFieldDescriptor Fields

Fields
Name | Description
DecimalCount | Represents field DecimalCount.
FieldLength | Represents field FieldLength.
FieldName | Represents field FieldName.
FieldType | Represents field FieldType.
IndexFieldFlag | Represents field IndexFieldFlag.
Reserved0 | Represents field Reserved0.
Reserved1 | Represents field Reserved1.
Top


TERSIDBFFieldDescriptor.DecimalCount Field

Summary

Represents field DecimalCount.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 DecimalCount: Byte;

Field Value

Type: Byte

See Also

Reference

  • TERSIDBFFieldDescriptor
  • frxERSIShapeDBFImport


TERSIDBFFieldDescriptor.FieldLength Field

Summary

Represents field FieldLength.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 FieldLength: Byte;

Field Value

Type: Byte

See Also

Reference

  • TERSIDBFFieldDescriptor
  • frxERSIShapeDBFImport


TERSIDBFFieldDescriptor.FieldName Field

Summary

Represents field FieldName.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 FieldName: array[0..10] of AnsiChar;

Field Value

Type: array[0..10] of AnsiChar

See Also

Reference

  • TERSIDBFFieldDescriptor
  • frxERSIShapeDBFImport


TERSIDBFFieldDescriptor.FieldType Field

Summary

Represents field FieldType.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 FieldType: AnsiChar;

Field Value

Type: AnsiChar

See Also

Reference

  • TERSIDBFFieldDescriptor
  • frxERSIShapeDBFImport


TERSIDBFFieldDescriptor.IndexFieldFlag Field

Summary

Represents field IndexFieldFlag.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 IndexFieldFlag: Byte;

Field Value

Type: Byte

See Also

Reference

  • TERSIDBFFieldDescriptor
  • frxERSIShapeDBFImport


TERSIDBFFieldDescriptor.Reserved0 Field

Summary

Represents field Reserved0.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 Reserved0: LongWord;

Field Value

Type: LongWord

See Also

Reference

  • TERSIDBFFieldDescriptor
  • frxERSIShapeDBFImport


TERSIDBFFieldDescriptor.Reserved1 Field

Summary

Represents field Reserved1.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 Reserved1: array[0..12] of Byte;

Field Value

Type: array[0..12] of Byte

See Also

Reference

  • TERSIDBFFieldDescriptor
  • frxERSIShapeDBFImport


TERSIDBFFileHeader Record

Summary

Represents type TERSIDBFFileHeader.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
type
 TERSIDBFFileHeader = packed record
 end;

The TERSIDBFFileHeader type exposes the following members.

Fields
Show:
Name | Description
DD | Represents field DD.
EncryptionFlag | Represents field EncryptionFlag.
FreeRecordThread | Represents field FreeRecordThread.
IncompleteTransaction | Represents field IncompleteTransaction.
LanguageDriver | Represents field LanguageDriver.
LengthOfEachRecord | Represents field LengthOfEachRecord.
LengthOfHeaderStructure | Represents field LengthOfHeaderStructure.
MDXFlag | Represents field MDXFlag.
MM | Represents field MM.
NumberOfRecords | Represents field NumberOfRecords.
Reserved0 | Represents field Reserved0.
Reserved1 | Represents field Reserved1.
ReservedForMultiUser | Represents field ReservedForMultiUser.
Signature | Represents field Signature.
YY | Represents field YY.
Top
See Also

Reference

  • frxERSIShapeDBFImport


TERSIDBFFileHeader Fields

Fields
Name | Description
DD | Represents field DD.
EncryptionFlag | Represents field EncryptionFlag.
FreeRecordThread | Represents field FreeRecordThread.
IncompleteTransaction | Represents field IncompleteTransaction.
LanguageDriver | Represents field LanguageDriver.
LengthOfEachRecord | Represents field LengthOfEachRecord.
LengthOfHeaderStructure | Represents field LengthOfHeaderStructure.
MDXFlag | Represents field MDXFlag.
MM | Represents field MM.
NumberOfRecords | Represents field NumberOfRecords.
Reserved0 | Represents field Reserved0.
Reserved1 | Represents field Reserved1.
ReservedForMultiUser | Represents field ReservedForMultiUser.
Signature | Represents field Signature.
YY | Represents field YY.
Top


TERSIDBFFileHeader.DD Field

Summary

Represents field DD.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 YY, MM, DD: Byte;

Field Value

Type: Byte

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.EncryptionFlag Field

Summary

Represents field EncryptionFlag.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 EncryptionFlag: Byte;

Field Value

Type: Byte

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.FreeRecordThread Field

Summary

Represents field FreeRecordThread.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 FreeRecordThread: LongWord;

Field Value

Type: LongWord

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.IncompleteTransaction Field

Summary

Represents field IncompleteTransaction.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 IncompleteTransaction: Byte;

Field Value

Type: Byte

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.LanguageDriver Field

Summary

Represents field LanguageDriver.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 LanguageDriver: byte;

Field Value

Type: byte

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.LengthOfEachRecord Field

Summary

Represents field LengthOfEachRecord.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 LengthOfEachRecord: Word;

Field Value

Type: Word

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.LengthOfHeaderStructure Field

Summary

Represents field LengthOfHeaderStructure.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 LengthOfHeaderStructure: Word;

Field Value

Type: Word

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.MDXFlag Field

Summary

Represents field MDXFlag.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 MDXFlag: byte;

Field Value

Type: byte

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.MM Field

Summary

Represents field MM.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 YY, MM, DD: Byte;

Field Value

Type: Byte

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.NumberOfRecords Field

Summary

Represents field NumberOfRecords.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 NumberOfRecords: LongWord;

Field Value

Type: LongWord

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.Reserved0 Field

Summary

Represents field Reserved0.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 Reserved0: Word;

Field Value

Type: Word

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.Reserved1 Field

Summary

Represents field Reserved1.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 Reserved1: Word;

Field Value

Type: Word

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.ReservedForMultiUser Field

Summary

Represents field ReservedForMultiUser.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 ReservedForMultiUser: array[0..7] of Byte;

Field Value

Type: array[0..7] of Byte

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.Signature Field

Summary

Represents field Signature.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 Signature: Byte;

Field Value

Type: Byte

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


TERSIDBFFileHeader.YY Field

Summary

Represents field YY.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
public
 YY, MM, DD: Byte;

Field Value

Type: Byte

See Also

Reference

  • TERSIDBFFileHeader
  • frxERSIShapeDBFImport


frxERSIShapeDBFImport Enumerations

Enumerations
Name | Description
TDBFFieldType | Represents type TDBFFieldType.
Top


TDBFFieldType Enumeration

Summary

Represents type TDBFFieldType.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
type
 TDBFFieldType = (dfUnhandled, dfChar, dfDate, dfNumeric, dfLogical);

The TDBFFieldType type exposes the following members.

Members
Show:
Name | Description
dfChar | Represents constant dfChar.
dfDate | Represents constant dfDate.
dfLogical | Represents constant dfLogical.
dfNumeric | Represents constant dfNumeric.
dfUnhandled | Represents constant dfUnhandled.
Top
See Also

Reference

  • frxERSIShapeDBFImport


frxERSIShapeDBFImport Types

Types
Name | Description
TAnsiCharSet | Represents type TAnsiCharSet.
Top


TAnsiCharSet Type

Summary

Represents type TAnsiCharSet.

Namespace: frxERSIShapeDBFImport
Syntax
Delphi
type
 TAnsiCharSet = set of AnsiChar;
See Also

Reference

  • frxERSIShapeDBFImport


frxERSIShapeFileFormat Namespace

Summary

Represents namespace frxERSIShapeFileFormat.

Classes
Name | Description
TERSIMultiPoint | Represents type TERSIMultiPoint.
TERSIMultiPointM | Represents type TERSIMultiPointM.
TERSIMultiPointZ | Represents type TERSIMultiPointZ.
TERSINull | Represents type TERSINull.
TERSIPoint | Represents type TERSIPoint.
TERSIPointM | Represents type TERSIPointM.
TERSIPointZ | Represents type TERSIPointZ.
TERSIPolygon | Represents type TERSIPolygon.
TERSIPolygonM | Represents type TERSIPolygonM.
TERSIPolygonZ | Represents type TERSIPolygonZ.
TERSIPolyLine | Represents type TERSIPolyLine.
TERSIPolyLineM | Represents type TERSIPolyLineM.
TERSIPolyLineZ | Represents type TERSIPolyLineZ.
TERSIShapeFile | Represents type TERSIShapeFile.
TMultiPath | Represents type TMultiPath.
Top
Records
Name | Description
TBox | Represents type TBox.
TDoublePointM | Represents type TDoublePointM.
TDoublePointZ | Represents type TDoublePointZ.
TERSIMainFileHeader | Represents type TERSIMainFileHeader.
TERSIMainFileRecordHeader | Represents type TERSIMainFileRecordHeader.
Top
Types
Name | Description
TDoublePointMArray | Represents an array of the TDoublePointM type.
TDoublePointZArray | Represents an array of the TDoublePointZ type.
TLongIntArray | Represents an array of the LongInt type.
Top
Constants
Name | Description
ERSI_MultiPatch | Represents constant ERSI_MultiPatch.
ERSI_MultiPoint | Represents constant ERSI_MultiPoint.
ERSI_MultiPointM | Represents constant ERSI_MultiPointM.
ERSI_MultiPointZ | Represents constant ERSI_MultiPointZ.
ERSI_Null | Represents constant ERSI_Null.
ERSI_Point | Represents constant ERSI_Point.
ERSI_PointM | Represents constant ERSI_PointM.
ERSI_PointZ | Represents constant ERSI_PointZ.
ERSI_Polygon | Represents constant ERSI_Polygon.
ERSI_PolygonM | Represents constant ERSI_PolygonM.
ERSI_PolygonZ | Represents constant ERSI_PolygonZ.
ERSI_PolyLine | Represents constant ERSI_PolyLine.
ERSI_PolyLineM | Represents constant ERSI_PolyLineM.
ERSI_PolyLineZ | Represents constant ERSI_PolyLineZ.
Top


frxERSIShapeFileFormat Classes

Classes
Name | Description
TERSIMultiPoint | Represents type TERSIMultiPoint.
TERSIMultiPointM | Represents type TERSIMultiPointM.
TERSIMultiPointZ | Represents type TERSIMultiPointZ.
TERSINull | Represents type TERSINull.
TERSIPoint | Represents type TERSIPoint.
TERSIPointM | Represents type TERSIPointM.
TERSIPointZ | Represents type TERSIPointZ.
TERSIPolygon | Represents type TERSIPolygon.
TERSIPolygonM | Represents type TERSIPolygonM.
TERSIPolygonZ | Represents type TERSIPolygonZ.
TERSIPolyLine | Represents type TERSIPolyLine.
TERSIPolyLineM | Represents type TERSIPolyLineM.
TERSIPolyLineZ | Represents type TERSIPolyLineZ.
TERSIShapeFile | Represents type TERSIShapeFile.
TMultiPath | Represents type TMultiPath.
Top


TERSIMultiPoint Class

Summary

Represents type TERSIMultiPoint.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIMultiPoint
frxERSIShapeFileFormat.TERSIMultiPointM
frxERSIShapeFileFormat.TERSIMultiPointZ
Syntax
Delphi
type
 TERSIMultiPoint = class(TERSINull)
 end;

The TERSIMultiPoint type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIMultiPoint class.
Top
Properties
Show:
Name | Description
Box | Represents property Box.
Header | Represents property Header. (Inherited from TERSINull.)
NumPoints | Represents property NumPoints.
Points | Represents property Points.
Top
Fields
Show:
Name | Description
FBox | Represents field FBox.
FNumPoints | Represents field FNumPoints.
FPoints | Represents field FPoints.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIMultiPoint Constructors

Constructors
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIMultiPoint class.
Top


TERSIMultiPoint.Create(TERSIMainFileRecordHeader,TStream) Constructor

Summary

Initializes a new instance of the TERSIMultiPoint class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 constructor Create(AHeader: TERSIMainFileRecordHeader; Stream: TStream);

Parameters

AHeader
Type: TERSIMainFileRecordHeader

Stream
Type: TStream

See Also

Reference

  • TERSIMultiPoint
  • frxERSIShapeFileFormat


TERSIMultiPoint Properties

Properties
Name | Description
Box | Represents property Box.
NumPoints | Represents property NumPoints.
Points | Represents property Points.
Top


TERSIMultiPoint.Box Property

Summary

Represents property Box.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Box: TBox read FBox;

Property Value

Type: TBox

See Also

Reference

  • TERSIMultiPoint
  • frxERSIShapeFileFormat


TERSIMultiPoint.NumPoints Property

Summary

Represents property NumPoints.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property NumPoints: LongInt read FNumPoints;

Property Value

Type: LongInt

See Also

Reference

  • TERSIMultiPoint
  • frxERSIShapeFileFormat


TERSIMultiPoint.Points Property

Summary

Represents property Points.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Points: TDoublePointArray read FPoints;

Property Value

Type: TDoublePointArray

See Also

Reference

  • TERSIMultiPoint
  • frxERSIShapeFileFormat


TERSIMultiPoint Fields

Fields
Name | Description
FBox | Represents field FBox.
FNumPoints | Represents field FNumPoints.
FPoints | Represents field FPoints.
Top


TERSIMultiPoint.FBox Field

Summary

Represents field FBox.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FBox: TBox;

Field Value

Type: TBox

See Also

Reference

  • TERSIMultiPoint
  • frxERSIShapeFileFormat


TERSIMultiPoint.FNumPoints Field

Summary

Represents field FNumPoints.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FNumPoints: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TERSIMultiPoint
  • frxERSIShapeFileFormat


TERSIMultiPoint.FPoints Field

Summary

Represents field FPoints.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPoints: TDoublePointArray;

Field Value

Type: TDoublePointArray

See Also

Reference

  • TERSIMultiPoint
  • frxERSIShapeFileFormat


TERSIMultiPointM Class

Summary

Represents type TERSIMultiPointM.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIMultiPoint
frxERSIShapeFileFormat.TERSIMultiPointM
Syntax
Delphi
type
 TERSIMultiPointM = class(TERSIMultiPoint)
 end;

The TERSIMultiPointM type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIMultiPointM class.
Top
Properties
Show:
Name | Description
Box | Represents property Box. (Inherited from TERSIMultiPoint.)
Header | Represents property Header. (Inherited from TERSINull.)
MMax | Represents property MMax.
MMin | Represents property MMin.
NumPoints | Represents property NumPoints. (Inherited from TERSIMultiPoint.)
Points | Represents property Points. (Inherited from TERSIMultiPoint.)
PointsM | Represents property PointsM.
Top
Fields
Show:
Name | Description
FMMax | Represents field FMMax.
FMMin | Represents field FMMin.
FPointsM | Represents field FPointsM.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIMultiPointM Constructors

Constructors
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIMultiPointM class.
Top


TERSIMultiPointM.Create(TERSIMainFileRecordHeader,TStream) Constructor

Summary

Initializes a new instance of the TERSIMultiPointM class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 constructor Create(AHeader: TERSIMainFileRecordHeader; Stream: TStream);

Parameters

AHeader
Type: TERSIMainFileRecordHeader

Stream
Type: TStream

See Also

Reference

  • TERSIMultiPointM
  • frxERSIShapeFileFormat


TERSIMultiPointM Properties

Properties
Name | Description
MMax | Represents property MMax.
MMin | Represents property MMin.
PointsM | Represents property PointsM.
Top


TERSIMultiPointM.MMax Property

Summary

Represents property MMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MMax: Double read FMMax;

Property Value

Type: Double

See Also

Reference

  • TERSIMultiPointM
  • frxERSIShapeFileFormat


TERSIMultiPointM.MMin Property

Summary

Represents property MMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MMin: Double read FMMin;

Property Value

Type: Double

See Also

Reference

  • TERSIMultiPointM
  • frxERSIShapeFileFormat


TERSIMultiPointM.PointsM Property

Summary

Represents property PointsM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PointsM: TDoubleArray read FPointsM;

Property Value

Type: TDoubleArray

See Also

Reference

  • TERSIMultiPointM
  • frxERSIShapeFileFormat


TERSIMultiPointM Fields

Fields
Name | Description
FMMax | Represents field FMMax.
FMMin | Represents field FMMin.
FPointsM | Represents field FPointsM.
Top


TERSIMultiPointM.FMMax Field

Summary

Represents field FMMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FMMax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMultiPointM
  • frxERSIShapeFileFormat


TERSIMultiPointM.FMMin Field

Summary

Represents field FMMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FMMin: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMultiPointM
  • frxERSIShapeFileFormat


TERSIMultiPointM.FPointsM Field

Summary

Represents field FPointsM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPointsM: TDoubleArray;

Field Value

Type: TDoubleArray

See Also

Reference

  • TERSIMultiPointM
  • frxERSIShapeFileFormat


TERSIMultiPointZ Class

Summary

Represents type TERSIMultiPointZ.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIMultiPoint
frxERSIShapeFileFormat.TERSIMultiPointZ
Syntax
Delphi
type
 TERSIMultiPointZ = class(TERSIMultiPoint)
 end;

The TERSIMultiPointZ type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIMultiPointZ class.
Top
Properties
Show:
Name | Description
Box | Represents property Box. (Inherited from TERSIMultiPoint.)
Header | Represents property Header. (Inherited from TERSINull.)
MMax | Represents property MMax.
MMin | Represents property MMin.
NumPoints | Represents property NumPoints. (Inherited from TERSIMultiPoint.)
Points | Represents property Points. (Inherited from TERSIMultiPoint.)
PointsM | Represents property PointsM.
PointsZ | Represents property PointsZ.
ZMax | Represents property ZMax.
ZMin | Represents property ZMin.
Top
Fields
Show:
Name | Description
FMMax | Represents field FMMax.
FMMin | Represents field FMMin.
FPointsM | Represents field FPointsM.
FPointsZ | Represents field FPointsZ.
FZMax | Represents field FZMax.
FZMin | Represents field FZMin.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIMultiPointZ Constructors

Constructors
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIMultiPointZ class.
Top


TERSIMultiPointZ.Create(TERSIMainFileRecordHeader,TStream) Constructor

Summary

Initializes a new instance of the TERSIMultiPointZ class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 constructor Create(AHeader: TERSIMainFileRecordHeader; Stream: TStream);

Parameters

AHeader
Type: TERSIMainFileRecordHeader

Stream
Type: TStream

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSIMultiPointZ Properties

Properties
Name | Description
MMax | Represents property MMax.
MMin | Represents property MMin.
PointsM | Represents property PointsM.
PointsZ | Represents property PointsZ.
ZMax | Represents property ZMax.
ZMin | Represents property ZMin.
Top


TERSIMultiPointZ.MMax Property

Summary

Represents property MMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MMax: Double read FMMax;

Property Value

Type: Double

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSIMultiPointZ.MMin Property

Summary

Represents property MMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MMin: Double read FMMin;

Property Value

Type: Double

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSIMultiPointZ.PointsM Property

Summary

Represents property PointsM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PointsM: TDoubleArray read FPointsM;

Property Value

Type: TDoubleArray

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSIMultiPointZ.PointsZ Property

Summary

Represents property PointsZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PointsZ: TDoubleArray read FPointsZ;

Property Value

Type: TDoubleArray

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSIMultiPointZ.ZMax Property

Summary

Represents property ZMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property ZMax: Double read FZMax;

Property Value

Type: Double

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSIMultiPointZ.ZMin Property

Summary

Represents property ZMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property ZMin: Double read FZMin;

Property Value

Type: Double

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSIMultiPointZ Fields

Fields
Name | Description
FMMax | Represents field FMMax.
FMMin | Represents field FMMin.
FPointsM | Represents field FPointsM.
FPointsZ | Represents field FPointsZ.
FZMax | Represents field FZMax.
FZMin | Represents field FZMin.
Top


TERSIMultiPointZ.FMMax Field

Summary

Represents field FMMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FMMax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSIMultiPointZ.FMMin Field

Summary

Represents field FMMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FMMin: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSIMultiPointZ.FPointsM Field

Summary

Represents field FPointsM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPointsM: TDoubleArray;

Field Value

Type: TDoubleArray

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSIMultiPointZ.FPointsZ Field

Summary

Represents field FPointsZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPointsZ: TDoubleArray;

Field Value

Type: TDoubleArray

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSIMultiPointZ.FZMax Field

Summary

Represents field FZMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FZMax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSIMultiPointZ.FZMin Field

Summary

Represents field FZMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FZMin: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMultiPointZ
  • frxERSIShapeFileFormat


TERSINull Class

Summary

Represents type TERSINull.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIMultiPoint
frxERSIShapeFileFormat.TERSIPoint
frxERSIShapeFileFormat.TERSIPointM
frxERSIShapeFileFormat.TERSIPointZ
frxERSIShapeFileFormat.TERSIPolyLine
frxERSIShapeFileFormat.TMultiPath
Syntax
Delphi
type
 TERSINull = class
 end;

The TERSINull type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader) | Initializes a new instance of the TERSINull class.
Top
Properties
Show:
Name | Description
Header | Represents property Header.
Top
Fields
Show:
Name | Description
FHeader | Represents field FHeader.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSINull Constructors

Constructors
Name | Description
Create(TERSIMainFileRecordHeader) | Initializes a new instance of the TERSINull class.
Top


TERSINull.Create(TERSIMainFileRecordHeader) Constructor

Summary

Initializes a new instance of the TERSINull class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 constructor Create(AHeader: TERSIMainFileRecordHeader);

Parameters

AHeader
Type: TERSIMainFileRecordHeader

See Also

Reference

  • TERSINull
  • frxERSIShapeFileFormat


TERSINull Properties

Properties
Name | Description
Header | Represents property Header.
Top


TERSINull.Header Property

Summary

Represents property Header.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Header: TERSIMainFileRecordHeader read FHeader;

Property Value

Type: TERSIMainFileRecordHeader

See Also

Reference

  • TERSINull
  • frxERSIShapeFileFormat


TERSINull Fields

Fields
Name | Description
FHeader | Represents field FHeader.
Top


TERSINull.FHeader Field

Summary

Represents field FHeader.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FHeader: TERSIMainFileRecordHeader;

Field Value

Type: TERSIMainFileRecordHeader

See Also

Reference

  • TERSINull
  • frxERSIShapeFileFormat


TERSIPoint Class

Summary

Represents type TERSIPoint.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIPoint
Syntax
Delphi
type
 TERSIPoint = class(TERSINull)
 end;

The TERSIPoint type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPoint class.
Top
Properties
Show:
Name | Description
Header | Represents property Header. (Inherited from TERSINull.)
Point | Represents property Point.
Top
Fields
Show:
Name | Description
FPoint | Represents field FPoint.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIPoint Constructors

Constructors
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPoint class.
Top


TERSIPoint.Create(TERSIMainFileRecordHeader,TStream) Constructor

Summary

Initializes a new instance of the TERSIPoint class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 constructor Create(AHeader: TERSIMainFileRecordHeader; Stream: TStream);

Parameters

AHeader
Type: TERSIMainFileRecordHeader

Stream
Type: TStream

See Also

Reference

  • TERSIPoint
  • frxERSIShapeFileFormat


TERSIPoint Properties

Properties
Name | Description
Point | Represents property Point.
Top


TERSIPoint.Point Property

Summary

Represents property Point.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Point: TDoublePoint read FPoint;

Property Value

Type: TDoublePoint

See Also

Reference

  • TERSIPoint
  • frxERSIShapeFileFormat


TERSIPoint Fields

Fields
Name | Description
FPoint | Represents field FPoint.
Top


TERSIPoint.FPoint Field

Summary

Represents field FPoint.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPoint: TDoublePoint;

Field Value

Type: TDoublePoint

See Also

Reference

  • TERSIPoint
  • frxERSIShapeFileFormat


TERSIPointM Class

Summary

Represents type TERSIPointM.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIPointM
Syntax
Delphi
type
 TERSIPointM = class(TERSINull)
 end;

The TERSIPointM type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPointM class.
Top
Properties
Show:
Name | Description
Header | Represents property Header. (Inherited from TERSINull.)
PointM | Represents property PointM.
Top
Fields
Show:
Name | Description
FPointM | Represents field FPointM.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIPointM Constructors

Constructors
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPointM class.
Top


TERSIPointM.Create(TERSIMainFileRecordHeader,TStream) Constructor

Summary

Initializes a new instance of the TERSIPointM class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 constructor Create(AHeader: TERSIMainFileRecordHeader; Stream: TStream);

Parameters

AHeader
Type: TERSIMainFileRecordHeader

Stream
Type: TStream

See Also

Reference

  • TERSIPointM
  • frxERSIShapeFileFormat


TERSIPointM Properties

Properties
Name | Description
PointM | Represents property PointM.
Top


TERSIPointM.PointM Property

Summary

Represents property PointM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PointM: TDoublePointM read FPointM;

Property Value

Type: TDoublePointM

See Also

Reference

  • TERSIPointM
  • frxERSIShapeFileFormat


TERSIPointM Fields

Fields
Name | Description
FPointM | Represents field FPointM.
Top


TERSIPointM.FPointM Field

Summary

Represents field FPointM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPointM: TDoublePointM;

Field Value

Type: TDoublePointM

See Also

Reference

  • TERSIPointM
  • frxERSIShapeFileFormat


TERSIPointZ Class

Summary

Represents type TERSIPointZ.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIPointZ
Syntax
Delphi
type
 TERSIPointZ = class(TERSINull)
 end;

The TERSIPointZ type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPointZ class.
Top
Properties
Show:
Name | Description
Header | Represents property Header. (Inherited from TERSINull.)
PointZ | Represents property PointZ.
Top
Fields
Show:
Name | Description
FPointZ | Represents field FPointZ.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIPointZ Constructors

Constructors
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPointZ class.
Top


TERSIPointZ.Create(TERSIMainFileRecordHeader,TStream) Constructor

Summary

Initializes a new instance of the TERSIPointZ class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 constructor Create(AHeader: TERSIMainFileRecordHeader; Stream: TStream);

Parameters

AHeader
Type: TERSIMainFileRecordHeader

Stream
Type: TStream

See Also

Reference

  • TERSIPointZ
  • frxERSIShapeFileFormat


TERSIPointZ Properties

Properties
Name | Description
PointZ | Represents property PointZ.
Top


TERSIPointZ.PointZ Property

Summary

Represents property PointZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PointZ: TDoublePointZ read FPointZ;

Property Value

Type: TDoublePointZ

See Also

Reference

  • TERSIPointZ
  • frxERSIShapeFileFormat


TERSIPointZ Fields

Fields
Name | Description
FPointZ | Represents field FPointZ.
Top


TERSIPointZ.FPointZ Field

Summary

Represents field FPointZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPointZ: TDoublePointZ;

Field Value

Type: TDoublePointZ

See Also

Reference

  • TERSIPointZ
  • frxERSIShapeFileFormat


TERSIPolygon Class

Summary

Represents type TERSIPolygon.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIPolyLine
frxERSIShapeFileFormat.TERSIPolygon
Syntax
Delphi
type
 TERSIPolygon = class(TERSIPolyLine);

The TERSIPolygon type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPolyLine class. (Inherited from TERSIPolyLine.)
Top
Properties
Show:
Name | Description
Box | Represents property Box. (Inherited from TERSIPolyLine.)
Header | Represents property Header. (Inherited from TERSINull.)
NumParts | Represents property NumParts. (Inherited from TERSIPolyLine.)
NumPoints | Represents property NumPoints. (Inherited from TERSIPolyLine.)
PartFirsPointIndex | Represents property PartFirsPointIndex. (Inherited from TERSIPolyLine.)
Points | Represents property Points. (Inherited from TERSIPolyLine.)
Top
Methods
Show:
Name | Description
PartCount(LongInt) | Represents method PartCount(LongInt). (Inherited from TERSIPolyLine.)
PartLastPointIndex(LongInt) | Represents method PartLastPointIndex(LongInt). (Inherited from TERSIPolyLine.)
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIPolygonM Class

Summary

Represents type TERSIPolygonM.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIPolyLine
frxERSIShapeFileFormat.TERSIPolyLineM
frxERSIShapeFileFormat.TERSIPolygonM
Syntax
Delphi
type
 TERSIPolygonM = class(TERSIPolyLineM);

The TERSIPolygonM type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPolyLineM class. (Inherited from TERSIPolyLineM.)
Top
Properties
Show:
Name | Description
Box | Represents property Box. (Inherited from TERSIPolyLine.)
Header | Represents property Header. (Inherited from TERSINull.)
MMax | Represents property MMax. (Inherited from TERSIPolyLineM.)
MMin | Represents property MMin. (Inherited from TERSIPolyLineM.)
NumParts | Represents property NumParts. (Inherited from TERSIPolyLine.)
NumPoints | Represents property NumPoints. (Inherited from TERSIPolyLine.)
PartFirsPointIndex | Represents property PartFirsPointIndex. (Inherited from TERSIPolyLine.)
Points | Represents property Points. (Inherited from TERSIPolyLine.)
PointsM | Represents property PointsM. (Inherited from TERSIPolyLineM.)
Top
Methods
Show:
Name | Description
PartCount(LongInt) | Represents method PartCount(LongInt). (Inherited from TERSIPolyLine.)
PartLastPointIndex(LongInt) | Represents method PartLastPointIndex(LongInt). (Inherited from TERSIPolyLine.)
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIPolygonZ Class

Summary

Represents type TERSIPolygonZ.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIPolyLine
frxERSIShapeFileFormat.TERSIPolyLineZ
frxERSIShapeFileFormat.TERSIPolygonZ
Syntax
Delphi
type
 TERSIPolygonZ = class(TERSIPolyLineZ);

The TERSIPolygonZ type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPolyLineZ class. (Inherited from TERSIPolyLineZ.)
Top
Properties
Show:
Name | Description
Box | Represents property Box. (Inherited from TERSIPolyLine.)
Header | Represents property Header. (Inherited from TERSINull.)
MMax | Represents property MMax. (Inherited from TERSIPolyLineZ.)
MMin | Represents property MMin. (Inherited from TERSIPolyLineZ.)
MZax | Represents property MZax. (Inherited from TERSIPolyLineZ.)
NumParts | Represents property NumParts. (Inherited from TERSIPolyLine.)
NumPoints | Represents property NumPoints. (Inherited from TERSIPolyLine.)
PartFirsPointIndex | Represents property PartFirsPointIndex. (Inherited from TERSIPolyLine.)
Points | Represents property Points. (Inherited from TERSIPolyLine.)
PointsM | Represents property PointsM. (Inherited from TERSIPolyLineZ.)
PointsZ | Represents property PointsZ. (Inherited from TERSIPolyLineZ.)
ZMin | Represents property ZMin. (Inherited from TERSIPolyLineZ.)
Top
Methods
Show:
Name | Description
PartCount(LongInt) | Represents method PartCount(LongInt). (Inherited from TERSIPolyLine.)
PartLastPointIndex(LongInt) | Represents method PartLastPointIndex(LongInt). (Inherited from TERSIPolyLine.)
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIPolyLine Class

Summary

Represents type TERSIPolyLine.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIPolyLine
frxERSIShapeFileFormat.TERSIPolygon
frxERSIShapeFileFormat.TERSIPolyLineM
frxERSIShapeFileFormat.TERSIPolyLineZ
Syntax
Delphi
type
 TERSIPolyLine = class(TERSINull)
 end;

The TERSIPolyLine type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPolyLine class.
Top
Properties
Show:
Name | Description
Box | Represents property Box.
Header | Represents property Header. (Inherited from TERSINull.)
NumParts | Represents property NumParts.
NumPoints | Represents property NumPoints.
PartFirsPointIndex | Represents property PartFirsPointIndex.
Points | Represents property Points.
Top
Methods
Show:
Name | Description
PartCount(LongInt) | Represents method PartCount(LongInt).
PartLastPointIndex(LongInt) | Represents method PartLastPointIndex(LongInt).
Top
Fields
Show:
Name | Description
FBox | Represents field FBox.
FNumParts | Represents field FNumParts.
FNumPoints | Represents field FNumPoints.
FPartFirsPointIndex | Represents field FPartFirsPointIndex.
FPoints | Represents field FPoints.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIPolyLine Constructors

Constructors
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPolyLine class.
Top


TERSIPolyLine.Create(TERSIMainFileRecordHeader,TStream) Constructor

Summary

Initializes a new instance of the TERSIPolyLine class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 constructor Create(AHeader: TERSIMainFileRecordHeader; Stream: TStream);

Parameters

AHeader
Type: TERSIMainFileRecordHeader

Stream
Type: TStream

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLine Properties

Properties
Name | Description
Box | Represents property Box.
NumParts | Represents property NumParts.
NumPoints | Represents property NumPoints.
PartFirsPointIndex | Represents property PartFirsPointIndex.
Points | Represents property Points.
Top


TERSIPolyLine.Box Property

Summary

Represents property Box.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Box: TBox read FBox;

Property Value

Type: TBox

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLine.NumParts Property

Summary

Represents property NumParts.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property NumParts: LongInt read FNumParts;

Property Value

Type: LongInt

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLine.NumPoints Property

Summary

Represents property NumPoints.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property NumPoints: LongInt read FNumPoints;

Property Value

Type: LongInt

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLine.PartFirsPointIndex Property

Summary

Represents property PartFirsPointIndex.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PartFirsPointIndex: TLongIntArray read FPartFirsPointIndex;

Property Value

Type: TLongIntArray

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLine.Points Property

Summary

Represents property Points.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Points: TDoublePointArray read FPoints;

Property Value

Type: TDoublePointArray

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLine Methods

Methods
Name | Description
PartCount(LongInt) | Represents method PartCount(LongInt).
PartLastPointIndex(LongInt) | Represents method PartLastPointIndex(LongInt).
Top


TERSIPolyLine.PartCount(LongInt) Method

Summary

Represents method PartCount(LongInt).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 function PartCount(PartNumber: LongInt): LongInt;

Parameters

PartNumber
Type: LongInt

Return Value

Type: LongInt

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLine.PartLastPointIndex(LongInt) Method

Summary

Represents method PartLastPointIndex(LongInt).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 function PartLastPointIndex(PartNumber: LongInt): LongInt;

Parameters

PartNumber
Type: LongInt

Return Value

Type: LongInt

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLine Fields

Fields
Name | Description
FBox | Represents field FBox.
FNumParts | Represents field FNumParts.
FNumPoints | Represents field FNumPoints.
FPartFirsPointIndex | Represents field FPartFirsPointIndex.
FPoints | Represents field FPoints.
Top


TERSIPolyLine.FBox Field

Summary

Represents field FBox.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FBox: TBox;

Field Value

Type: TBox

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLine.FNumParts Field

Summary

Represents field FNumParts.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FNumParts: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLine.FNumPoints Field

Summary

Represents field FNumPoints.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FNumPoints: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLine.FPartFirsPointIndex Field

Summary

Represents field FPartFirsPointIndex.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPartFirsPointIndex: TLongIntArray;

Field Value

Type: TLongIntArray

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLine.FPoints Field

Summary

Represents field FPoints.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPoints: TDoublePointArray;

Field Value

Type: TDoublePointArray

See Also

Reference

  • TERSIPolyLine
  • frxERSIShapeFileFormat


TERSIPolyLineM Class

Summary

Represents type TERSIPolyLineM.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIPolyLine
frxERSIShapeFileFormat.TERSIPolyLineM
frxERSIShapeFileFormat.TERSIPolygonM
Syntax
Delphi
type
 TERSIPolyLineM = class(TERSIPolyLine)
 end;

The TERSIPolyLineM type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPolyLineM class.
Top
Properties
Show:
Name | Description
Box | Represents property Box. (Inherited from TERSIPolyLine.)
Header | Represents property Header. (Inherited from TERSINull.)
MMax | Represents property MMax.
MMin | Represents property MMin.
NumParts | Represents property NumParts. (Inherited from TERSIPolyLine.)
NumPoints | Represents property NumPoints. (Inherited from TERSIPolyLine.)
PartFirsPointIndex | Represents property PartFirsPointIndex. (Inherited from TERSIPolyLine.)
Points | Represents property Points. (Inherited from TERSIPolyLine.)
PointsM | Represents property PointsM.
Top
Methods
Show:
Name | Description
PartCount(LongInt) | Represents method PartCount(LongInt). (Inherited from TERSIPolyLine.)
PartLastPointIndex(LongInt) | Represents method PartLastPointIndex(LongInt). (Inherited from TERSIPolyLine.)
Top
Fields
Show:
Name | Description
FMMax | Represents field FMMax.
FMMin | Represents field FMMin.
FPointsM | Represents field FPointsM.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIPolyLineM Constructors

Constructors
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPolyLineM class.
Top


TERSIPolyLineM.Create(TERSIMainFileRecordHeader,TStream) Constructor

Summary

Initializes a new instance of the TERSIPolyLineM class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 constructor Create(AHeader: TERSIMainFileRecordHeader; Stream: TStream);

Parameters

AHeader
Type: TERSIMainFileRecordHeader

Stream
Type: TStream

See Also

Reference

  • TERSIPolyLineM
  • frxERSIShapeFileFormat


TERSIPolyLineM Properties

Properties
Name | Description
MMax | Represents property MMax.
MMin | Represents property MMin.
PointsM | Represents property PointsM.
Top


TERSIPolyLineM.MMax Property

Summary

Represents property MMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MMax: Double read FMMax;

Property Value

Type: Double

See Also

Reference

  • TERSIPolyLineM
  • frxERSIShapeFileFormat


TERSIPolyLineM.MMin Property

Summary

Represents property MMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MMin: Double read FMMin;

Property Value

Type: Double

See Also

Reference

  • TERSIPolyLineM
  • frxERSIShapeFileFormat


TERSIPolyLineM.PointsM Property

Summary

Represents property PointsM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PointsM: TDoubleArray read FPointsM;

Property Value

Type: TDoubleArray

See Also

Reference

  • TERSIPolyLineM
  • frxERSIShapeFileFormat


TERSIPolyLineM Fields

Fields
Name | Description
FMMax | Represents field FMMax.
FMMin | Represents field FMMin.
FPointsM | Represents field FPointsM.
Top


TERSIPolyLineM.FMMax Field

Summary

Represents field FMMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FMMax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIPolyLineM
  • frxERSIShapeFileFormat


TERSIPolyLineM.FMMin Field

Summary

Represents field FMMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FMMin: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIPolyLineM
  • frxERSIShapeFileFormat


TERSIPolyLineM.FPointsM Field

Summary

Represents field FPointsM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPointsM: TDoubleArray;

Field Value

Type: TDoubleArray

See Also

Reference

  • TERSIPolyLineM
  • frxERSIShapeFileFormat


TERSIPolyLineZ Class

Summary

Represents type TERSIPolyLineZ.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TERSIPolyLine
frxERSIShapeFileFormat.TERSIPolyLineZ
frxERSIShapeFileFormat.TERSIPolygonZ
Syntax
Delphi
type
 TERSIPolyLineZ = class(TERSIPolyLine)
 end;

The TERSIPolyLineZ type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPolyLineZ class.
Top
Properties
Show:
Name | Description
Box | Represents property Box. (Inherited from TERSIPolyLine.)
Header | Represents property Header. (Inherited from TERSINull.)
MMax | Represents property MMax.
MMin | Represents property MMin.
MZax | Represents property MZax.
NumParts | Represents property NumParts. (Inherited from TERSIPolyLine.)
NumPoints | Represents property NumPoints. (Inherited from TERSIPolyLine.)
PartFirsPointIndex | Represents property PartFirsPointIndex. (Inherited from TERSIPolyLine.)
Points | Represents property Points. (Inherited from TERSIPolyLine.)
PointsM | Represents property PointsM.
PointsZ | Represents property PointsZ.
ZMin | Represents property ZMin.
Top
Methods
Show:
Name | Description
PartCount(LongInt) | Represents method PartCount(LongInt). (Inherited from TERSIPolyLine.)
PartLastPointIndex(LongInt) | Represents method PartLastPointIndex(LongInt). (Inherited from TERSIPolyLine.)
Top
Fields
Show:
Name | Description
FMMax | Represents field FMMax.
FMMin | Represents field FMMin.
FPointsM | Represents field FPointsM.
FPointsZ | Represents field FPointsZ.
FZMax | Represents field FZMax.
FZMin | Represents field FZMin.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIPolyLineZ Constructors

Constructors
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TERSIPolyLineZ class.
Top


TERSIPolyLineZ.Create(TERSIMainFileRecordHeader,TStream) Constructor

Summary

Initializes a new instance of the TERSIPolyLineZ class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 constructor Create(AHeader: TERSIMainFileRecordHeader; Stream: TStream);

Parameters

AHeader
Type: TERSIMainFileRecordHeader

Stream
Type: TStream

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIPolyLineZ Properties

Properties
Name | Description
MMax | Represents property MMax.
MMin | Represents property MMin.
MZax | Represents property MZax.
PointsM | Represents property PointsM.
PointsZ | Represents property PointsZ.
ZMin | Represents property ZMin.
Top


TERSIPolyLineZ.MMax Property

Summary

Represents property MMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MMax: Double read FMMax;

Property Value

Type: Double

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIPolyLineZ.MMin Property

Summary

Represents property MMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MMin: Double read FMMin;

Property Value

Type: Double

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIPolyLineZ.MZax Property

Summary

Represents property MZax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MZax: Double read FZMax;

Property Value

Type: Double

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIPolyLineZ.PointsM Property

Summary

Represents property PointsM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PointsM: TDoubleArray read FPointsM;

Property Value

Type: TDoubleArray

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIPolyLineZ.PointsZ Property

Summary

Represents property PointsZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PointsZ: TDoubleArray read FPointsZ;

Property Value

Type: TDoubleArray

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIPolyLineZ.ZMin Property

Summary

Represents property ZMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property ZMin: Double read FZMin;

Property Value

Type: Double

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIPolyLineZ Fields

Fields
Name | Description
FMMax | Represents field FMMax.
FMMin | Represents field FMMin.
FPointsM | Represents field FPointsM.
FPointsZ | Represents field FPointsZ.
FZMax | Represents field FZMax.
FZMin | Represents field FZMin.
Top


TERSIPolyLineZ.FMMax Field

Summary

Represents field FMMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FMMax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIPolyLineZ.FMMin Field

Summary

Represents field FMMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FMMin: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIPolyLineZ.FPointsM Field

Summary

Represents field FPointsM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPointsM: TDoubleArray;

Field Value

Type: TDoubleArray

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIPolyLineZ.FPointsZ Field

Summary

Represents field FPointsZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPointsZ: TDoubleArray;

Field Value

Type: TDoubleArray

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIPolyLineZ.FZMax Field

Summary

Represents field FZMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FZMax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIPolyLineZ.FZMin Field

Summary

Represents field FZMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FZMin: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIPolyLineZ
  • frxERSIShapeFileFormat


TERSIShapeFile Class

Summary

Represents type TERSIShapeFile.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSIShapeFile
Syntax
Delphi
type
 TERSIShapeFile = class
 end;

The TERSIShapeFile type exposes the following members.

Constructors
Show:
Name | Description
Create(string) | Initializes a new instance of the TERSIShapeFile class.
Destroy | Represents the destructor of the TERSIShapeFile class.
Top
Properties
Show:
Name | Description
ERSIShapeType[Integer] | Represents property ERSIShapeType[Integer].
LegendByColumn[Integer,Integer] | Represents property LegendByColumn[Integer,Integer].
LegendToString[Integer,Integer] | Represents property LegendToString[Integer,Integer].
Legend[AnsiString,Integer] | Represents property Legend[AnsiString,Integer].
MultiPointCount[Integer] | Represents property MultiPointCount[Integer].
MultiPoint[Integer,Integer] | Represents property MultiPoint[Integer,Integer].
Point[Integer] | Represents property Point[Integer].
PolyPartsCount[Integer] | Represents property PolyPartsCount[Integer].
PolyPointsCount[Integer,Integer] | Represents property PolyPointsCount[Integer,Integer].
PolyPoint[Integer,Integer,Integer] | Represents property PolyPoint[Integer,Integer,Integer].
RecordCount | Represents property RecordCount.
Xmax | Represents property Xmax.
Xmin | Represents property Xmin.
Ymax | Represents property Ymax.
Ymin | Represents property Ymin.
Top
Methods
Show:
Name | Description
GetColumnList(TStrings) | Represents method GetColumnList(TStrings).
GetERSIShapeType(Integer) | Represents method GetERSIShapeType(Integer).
GetLegend(AnsiString,Integer) | Represents method GetLegend(AnsiString,Integer).
GetLegendByColumn(Integer,Integer) | Represents method GetLegendByColumn(Integer,Integer).
GetLegendToString(Integer,Integer) | Represents method GetLegendToString(Integer,Integer).
GetMultiPoint(Integer,Integer) | Represents method GetMultiPoint(Integer,Integer).
GetMultiPointCount(Integer) | Represents method GetMultiPointCount(Integer).
GetPartPoints(TDoublePointArray,Integer,Integer) | Represents method GetPartPoints(TDoublePointArray,Integer,Integer).
GetPoint(Integer) | Represents method GetPoint(Integer).
GetPolyPartsCount(Integer) | Represents method GetPolyPartsCount(Integer).
GetPolyPoint(Integer,Integer,Integer) | Represents method GetPolyPoint(Integer,Integer,Integer).
GetPolyPointsCount(Integer,Integer) | Represents method GetPolyPointsCount(Integer,Integer).
GetRecordCount | Represents method GetRecordCount.
ReadFromStream(TStream) | Represents method ReadFromStream(TStream).
SwapEndianness(LongInt) | Represents method SwapEndianness(LongInt).
Top
Fields
Show:
Name | Description
FDBFFile | Represents field FDBFFile.
FList | Represents field FList.
FMainFileHeader | Represents field FMainFileHeader.
XRange | Represents field XRange.
YRange | Represents field YRange.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIShapeFile Constructors

Constructors
Name | Description
Create(string) | Initializes a new instance of the TERSIShapeFile class.
Destroy | Represents the destructor of the TERSIShapeFile class.
Top


TERSIShapeFile.Create(string) Constructor

Summary

Initializes a new instance of the TERSIShapeFile class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 constructor Create(const FileName: string);

Parameters

FileName
Type: string

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.Destroy Destructor

Summary

Represents the destructor of the TERSIShapeFile class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile Properties

Properties
Name | Description
ERSIShapeType[Integer] | Represents property ERSIShapeType[Integer].
LegendByColumn[Integer,Integer] | Represents property LegendByColumn[Integer,Integer].
LegendToString[Integer,Integer] | Represents property LegendToString[Integer,Integer].
Legend[AnsiString,Integer] | Represents property Legend[AnsiString,Integer].
MultiPointCount[Integer] | Represents property MultiPointCount[Integer].
MultiPoint[Integer,Integer] | Represents property MultiPoint[Integer,Integer].
Point[Integer] | Represents property Point[Integer].
PolyPartsCount[Integer] | Represents property PolyPartsCount[Integer].
PolyPointsCount[Integer,Integer] | Represents property PolyPointsCount[Integer,Integer].
PolyPoint[Integer,Integer,Integer] | Represents property PolyPoint[Integer,Integer,Integer].
RecordCount | Represents property RecordCount.
Xmax | Represents property Xmax.
Xmin | Represents property Xmin.
Ymax | Represents property Ymax.
Ymin | Represents property Ymin.
Top


TERSIShapeFile.ERSIShapeType[Integer] Property

Summary

Represents property ERSIShapeType[Integer].

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property ERSIShapeType[iRecord: Integer]: LongInt read GetERSIShapeType;

Parameters

iRecord
Type: Integer

Property Value

Type: LongInt

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.LegendByColumn[Integer,Integer] Property

Summary

Represents property LegendByColumn[Integer,Integer].

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property LegendByColumn[iColumn, iRecord: Integer]: AnsiString read GetLegendByColumn;

Parameters

iColumn
Type: Integer

iRecord
Type: Integer

Property Value

Type: AnsiString

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.LegendToString[Integer,Integer] Property

Summary

Represents property LegendToString[Integer,Integer].

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property LegendToString[iColumn, iRecord: Integer]: String read GetLegendToString;

Parameters

iColumn
Type: Integer

iRecord
Type: Integer

Property Value

Type: String

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.Legend[AnsiString,Integer] Property

Summary

Represents property Legend[AnsiString,Integer].

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Legend[FieldName: AnsiString; iRecord: Integer]: AnsiString read GetLegend;

Parameters

FieldName
Type: AnsiString

iRecord
Type: Integer

Property Value

Type: AnsiString

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.MultiPointCount[Integer] Property

Summary

Represents property MultiPointCount[Integer].

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MultiPointCount[iRecord: Integer]: Integer read GetMultiPointCount;

Parameters

iRecord
Type: Integer

Property Value

Type: Integer

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.MultiPoint[Integer,Integer] Property

Summary

Represents property MultiPoint[Integer,Integer].

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MultiPoint[iRecord, iPoint: Integer]: TDoublePoint read GetMultiPoint;

Parameters

iRecord
Type: Integer

iPoint
Type: Integer

Property Value

Type: TDoublePoint

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.Point[Integer] Property

Summary

Represents property Point[Integer].

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Point[iRecord: Integer]: TDoublePoint read GetPoint;

Parameters

iRecord
Type: Integer

Property Value

Type: TDoublePoint

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.PolyPartsCount[Integer] Property

Summary

Represents property PolyPartsCount[Integer].

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PolyPartsCount[iRecord: Integer]: Integer read GetPolyPartsCount;

Parameters

iRecord
Type: Integer

Property Value

Type: Integer

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.PolyPointsCount[Integer,Integer] Property

Summary

Represents property PolyPointsCount[Integer,Integer].

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PolyPointsCount[iRecord, iPart: Integer]: Integer read GetPolyPointsCount;

Parameters

iRecord
Type: Integer

iPart
Type: Integer

Property Value

Type: Integer

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.PolyPoint[Integer,Integer,Integer] Property

Summary

Represents property PolyPoint[Integer,Integer,Integer].

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PolyPoint[iRecord, iPart, iPoint: Integer]: TDoublePoint read GetPolyPoint;

Parameters

iRecord
Type: Integer

iPart
Type: Integer

iPoint
Type: Integer

Property Value

Type: TDoublePoint

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.RecordCount Property

Summary

Represents property RecordCount.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property RecordCount: Integer read GetRecordCount;

Property Value

Type: Integer

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.Xmax Property

Summary

Represents property Xmax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Xmax: Double read FMainFileHeader.Xmax;

Property Value

Type: Double

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.Xmin Property

Summary

Represents property Xmin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Xmin: Double read FMainFileHeader.Xmin;

Property Value

Type: Double

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.Ymax Property

Summary

Represents property Ymax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Ymax: Double read FMainFileHeader.Ymax;

Property Value

Type: Double

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.Ymin Property

Summary

Represents property Ymin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Ymin: Double read FMainFileHeader.Ymin;

Property Value

Type: Double

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile Methods

Methods
Name | Description
GetColumnList(TStrings) | Represents method GetColumnList(TStrings).
GetERSIShapeType(Integer) | Represents method GetERSIShapeType(Integer).
GetLegend(AnsiString,Integer) | Represents method GetLegend(AnsiString,Integer).
GetLegendByColumn(Integer,Integer) | Represents method GetLegendByColumn(Integer,Integer).
GetLegendToString(Integer,Integer) | Represents method GetLegendToString(Integer,Integer).
GetMultiPoint(Integer,Integer) | Represents method GetMultiPoint(Integer,Integer).
GetMultiPointCount(Integer) | Represents method GetMultiPointCount(Integer).
GetPartPoints(TDoublePointArray,Integer,Integer) | Represents method GetPartPoints(TDoublePointArray,Integer,Integer).
GetPoint(Integer) | Represents method GetPoint(Integer).
GetPolyPartsCount(Integer) | Represents method GetPolyPartsCount(Integer).
GetPolyPoint(Integer,Integer,Integer) | Represents method GetPolyPoint(Integer,Integer,Integer).
GetPolyPointsCount(Integer,Integer) | Represents method GetPolyPointsCount(Integer,Integer).
GetRecordCount | Represents method GetRecordCount.
ReadFromStream(TStream) | Represents method ReadFromStream(TStream).
SwapEndianness(LongInt) | Represents method SwapEndianness(LongInt).
Top


TERSIShapeFile.GetColumnList(TStrings) Method

Summary

Represents method GetColumnList(TStrings).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 procedure GetColumnList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.GetERSIShapeType(Integer) Method

Summary

Represents method GetERSIShapeType(Integer).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 function GetERSIShapeType(iRecord: Integer): LongInt;

Parameters

iRecord
Type: Integer

Return Value

Type: LongInt

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.GetLegend(AnsiString,Integer) Method

Summary

Represents method GetLegend(AnsiString,Integer).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 function GetLegend(FieldName: AnsiString; iRecord: Integer): AnsiString;

Parameters

FieldName
Type: AnsiString

iRecord
Type: Integer

Return Value

Type: AnsiString

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.GetLegendByColumn(Integer,Integer) Method

Summary

Represents method GetLegendByColumn(Integer,Integer).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 function GetLegendByColumn(iColumn, iRecord: Integer): AnsiString;

Parameters

iColumn
Type: Integer

iRecord
Type: Integer

Return Value

Type: AnsiString

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.GetLegendToString(Integer,Integer) Method

Summary

Represents method GetLegendToString(Integer,Integer).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 function GetLegendToString(iColumn, iRecord: Integer): String;

Parameters

iColumn
Type: Integer

iRecord
Type: Integer

Return Value

Type: String

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.GetMultiPoint(Integer,Integer) Method

Summary

Represents method GetMultiPoint(Integer,Integer).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 function GetMultiPoint(iRecord, iPoint: Integer): TDoublePoint;

Parameters

iRecord
Type: Integer

iPoint
Type: Integer

Return Value

Type: TDoublePoint

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.GetMultiPointCount(Integer) Method

Summary

Represents method GetMultiPointCount(Integer).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 function GetMultiPointCount(iRecord: Integer): Integer;

Parameters

iRecord
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.GetPartPoints(TDoublePointArray,Integer,Integer) Method

Summary

Represents method GetPartPoints(TDoublePointArray,Integer,Integer).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 procedure GetPartPoints(var PartPoints: TDoublePointArray; iRecord, iPart: Integer);

Parameters

PartPoints
Type: TDoublePointArray

iRecord
Type: Integer

iPart
Type: Integer

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.GetPoint(Integer) Method

Summary

Represents method GetPoint(Integer).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 function GetPoint(iRecord: Integer): TDoublePoint;

Parameters

iRecord
Type: Integer

Return Value

Type: TDoublePoint

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.GetPolyPartsCount(Integer) Method

Summary

Represents method GetPolyPartsCount(Integer).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 function GetPolyPartsCount(iRecord: Integer): Integer;

Parameters

iRecord
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.GetPolyPoint(Integer,Integer,Integer) Method

Summary

Represents method GetPolyPoint(Integer,Integer,Integer).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 function GetPolyPoint(iRecord, iPart, iPoint: Integer): TDoublePoint;

Parameters

iRecord
Type: Integer

iPart
Type: Integer

iPoint
Type: Integer

Return Value

Type: TDoublePoint

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.GetPolyPointsCount(Integer,Integer) Method

Summary

Represents method GetPolyPointsCount(Integer,Integer).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 function GetPolyPointsCount(iRecord, iPart: Integer): Integer;

Parameters

iRecord
Type: Integer

iPart
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.GetRecordCount Method

Summary

Represents method GetRecordCount.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 function GetRecordCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.ReadFromStream(TStream) Method

Summary

Represents method ReadFromStream(TStream).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
protected
 procedure ReadFromStream(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.SwapEndianness(LongInt) Method

Summary

Represents method SwapEndianness(LongInt).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
protected
 procedure SwapEndianness(var Value: LongInt);

Parameters

Value
Type: LongInt

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile Fields

Fields
Name | Description
FDBFFile | Represents field FDBFFile.
FList | Represents field FList.
FMainFileHeader | Represents field FMainFileHeader.
XRange | Represents field XRange.
YRange | Represents field YRange.
Top


TERSIShapeFile.FDBFFile Field

Summary

Represents field FDBFFile.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
protected
 FDBFFile: TERSIDBFFile;

Field Value

Type: TERSIDBFFile

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.FList Field

Summary

Represents field FList.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
protected
 FList: TObjectList;

Field Value

Type: TObjectList

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.FMainFileHeader Field

Summary

Represents field FMainFileHeader.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
protected
 FMainFileHeader: TERSIMainFileHeader;

Field Value

Type: TERSIMainFileHeader

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.XRange Field

Summary

Represents field XRange.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
protected
 XRange, YRange: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TERSIShapeFile.YRange Field

Summary

Represents field YRange.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
protected
 XRange, YRange: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIShapeFile
  • frxERSIShapeFileFormat


TMultiPath Class

Summary

Represents type TMultiPath.

Namespace: frxERSIShapeFileFormat
Inheritance Hierarchy
TObject
frxERSIShapeFileFormat.TERSINull
frxERSIShapeFileFormat.TMultiPath
Syntax
Delphi
type
 TMultiPath = class(TERSINull)
 end;

The TMultiPath type exposes the following members.

Constructors
Show:
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TMultiPath class.
Top
Properties
Show:
Name | Description
Box | Represents property Box.
Header | Represents property Header. (Inherited from TERSINull.)
MMax | Represents property MMax.
MMin | Represents property MMin.
MZax | Represents property MZax.
NumParts | Represents property NumParts.
NumPoints | Represents property NumPoints.
PartFirsPointIndex | Represents property PartFirsPointIndex.
PartTypes | Represents property PartTypes.
Points | Represents property Points.
PointsM | Represents property PointsM.
PointsZ | Represents property PointsZ.
ZMin | Represents property ZMin.
Top
Methods
Show:
Name | Description
PartCount(LongInt) | Represents method PartCount(LongInt).
PartLastPointIndex(LongInt) | Represents method PartLastPointIndex(LongInt).
Top
Fields
Show:
Name | Description
FBox | Represents field FBox.
FMMax | Represents field FMMax.
FMMin | Represents field FMMin.
FNumParts | Represents field FNumParts.
FNumPoints | Represents field FNumPoints.
FPartFirsPointIndex | Represents field FPartFirsPointIndex.
FPartTypes | Represents field FPartTypes.
FPoints | Represents field FPoints.
FPointsM | Represents field FPointsM.
FPointsZ | Represents field FPointsZ.
FZMax | Represents field FZMax.
FZMin | Represents field FZMin.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TMultiPath Constructors

Constructors
Name | Description
Create(TERSIMainFileRecordHeader,TStream) | Initializes a new instance of the TMultiPath class.
Top


TMultiPath.Create(TERSIMainFileRecordHeader,TStream) Constructor

Summary

Initializes a new instance of the TMultiPath class.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 constructor Create(AHeader: TERSIMainFileRecordHeader; Stream: TStream);

Parameters

AHeader
Type: TERSIMainFileRecordHeader

Stream
Type: TStream

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath Properties

Properties
Name | Description
Box | Represents property Box.
MMax | Represents property MMax.
MMin | Represents property MMin.
MZax | Represents property MZax.
NumParts | Represents property NumParts.
NumPoints | Represents property NumPoints.
PartFirsPointIndex | Represents property PartFirsPointIndex.
PartTypes | Represents property PartTypes.
Points | Represents property Points.
PointsM | Represents property PointsM.
PointsZ | Represents property PointsZ.
ZMin | Represents property ZMin.
Top


TMultiPath.Box Property

Summary

Represents property Box.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Box: TBox read FBox;

Property Value

Type: TBox

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.MMax Property

Summary

Represents property MMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MMax: Double read FMMax;

Property Value

Type: Double

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.MMin Property

Summary

Represents property MMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MMin: Double read FMMin;

Property Value

Type: Double

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.MZax Property

Summary

Represents property MZax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property MZax: Double read FZMax;

Property Value

Type: Double

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.NumParts Property

Summary

Represents property NumParts.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property NumParts: LongInt read FNumParts;

Property Value

Type: LongInt

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.NumPoints Property

Summary

Represents property NumPoints.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property NumPoints: LongInt read FNumPoints;

Property Value

Type: LongInt

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.PartFirsPointIndex Property

Summary

Represents property PartFirsPointIndex.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PartFirsPointIndex: TLongIntArray read FPartFirsPointIndex;

Property Value

Type: TLongIntArray

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.PartTypes Property

Summary

Represents property PartTypes.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PartTypes: TLongIntArray read FPartTypes;

Property Value

Type: TLongIntArray

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.Points Property

Summary

Represents property Points.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property Points: TDoublePointArray read FPoints;

Property Value

Type: TDoublePointArray

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.PointsM Property

Summary

Represents property PointsM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PointsM: TDoubleArray read FPointsM;

Property Value

Type: TDoubleArray

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.PointsZ Property

Summary

Represents property PointsZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property PointsZ: TDoubleArray read FPointsZ;

Property Value

Type: TDoubleArray

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.ZMin Property

Summary

Represents property ZMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 property ZMin: Double read FZMin;

Property Value

Type: Double

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath Methods

Methods
Name | Description
PartCount(LongInt) | Represents method PartCount(LongInt).
PartLastPointIndex(LongInt) | Represents method PartLastPointIndex(LongInt).
Top


TMultiPath.PartCount(LongInt) Method

Summary

Represents method PartCount(LongInt).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 function PartCount(PartNumber: LongInt): LongInt;

Parameters

PartNumber
Type: LongInt

Return Value

Type: LongInt

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.PartLastPointIndex(LongInt) Method

Summary

Represents method PartLastPointIndex(LongInt).

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 function PartLastPointIndex(PartNumber: LongInt): LongInt;

Parameters

PartNumber
Type: LongInt

Return Value

Type: LongInt

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath Fields

Fields
Name | Description
FBox | Represents field FBox.
FMMax | Represents field FMMax.
FMMin | Represents field FMMin.
FNumParts | Represents field FNumParts.
FNumPoints | Represents field FNumPoints.
FPartFirsPointIndex | Represents field FPartFirsPointIndex.
FPartTypes | Represents field FPartTypes.
FPoints | Represents field FPoints.
FPointsM | Represents field FPointsM.
FPointsZ | Represents field FPointsZ.
FZMax | Represents field FZMax.
FZMin | Represents field FZMin.
Top


TMultiPath.FBox Field

Summary

Represents field FBox.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FBox: TBox;

Field Value

Type: TBox

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.FMMax Field

Summary

Represents field FMMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FMMax: Double;

Field Value

Type: Double

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.FMMin Field

Summary

Represents field FMMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FMMin: Double;

Field Value

Type: Double

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.FNumParts Field

Summary

Represents field FNumParts.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FNumParts: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.FNumPoints Field

Summary

Represents field FNumPoints.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FNumPoints: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.FPartFirsPointIndex Field

Summary

Represents field FPartFirsPointIndex.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPartFirsPointIndex: TLongIntArray;

Field Value

Type: TLongIntArray

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.FPartTypes Field

Summary

Represents field FPartTypes.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPartTypes: TLongIntArray;

Field Value

Type: TLongIntArray

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.FPoints Field

Summary

Represents field FPoints.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPoints: TDoublePointArray;

Field Value

Type: TDoublePointArray

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.FPointsM Field

Summary

Represents field FPointsM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPointsM: TDoubleArray;

Field Value

Type: TDoubleArray

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.FPointsZ Field

Summary

Represents field FPointsZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FPointsZ: TDoubleArray;

Field Value

Type: TDoubleArray

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.FZMax Field

Summary

Represents field FZMax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FZMax: Double;

Field Value

Type: Double

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


TMultiPath.FZMin Field

Summary

Represents field FZMin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
private
 FZMin: Double;

Field Value

Type: Double

See Also

Reference

  • TMultiPath
  • frxERSIShapeFileFormat


frxERSIShapeFileFormat Records

Records
Name | Description
TBox | Represents type TBox.
TDoublePointM | Represents type TDoublePointM.
TDoublePointZ | Represents type TDoublePointZ.
TERSIMainFileHeader | Represents type TERSIMainFileHeader.
TERSIMainFileRecordHeader | Represents type TERSIMainFileRecordHeader.
Top


TBox Record

Summary

Represents type TBox.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
type
 TBox = record
 end;

The TBox type exposes the following members.

Fields
Show:
Name | Description
Xmax | Represents field Xmax.
Xmin | Represents field Xmin.
Ymax | Represents field Ymax.
Ymin | Represents field Ymin.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TBox Fields

Fields
Name | Description
Xmax | Represents field Xmax.
Xmin | Represents field Xmin.
Ymax | Represents field Ymax.
Ymin | Represents field Ymin.
Top


TBox.Xmax Field

Summary

Represents field Xmax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Xmin, Ymin, Xmax, Ymax: Double;

Field Value

Type: Double

See Also

Reference

  • TBox
  • frxERSIShapeFileFormat


TBox.Xmin Field

Summary

Represents field Xmin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Xmin, Ymin, Xmax, Ymax: Double;

Field Value

Type: Double

See Also

Reference

  • TBox
  • frxERSIShapeFileFormat


TBox.Ymax Field

Summary

Represents field Ymax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Xmin, Ymin, Xmax, Ymax: Double;

Field Value

Type: Double

See Also

Reference

  • TBox
  • frxERSIShapeFileFormat


TBox.Ymin Field

Summary

Represents field Ymin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Xmin, Ymin, Xmax, Ymax: Double;

Field Value

Type: Double

See Also

Reference

  • TBox
  • frxERSIShapeFileFormat


TDoublePointM Record

Summary

Represents type TDoublePointM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
type
 TDoublePointM = record
 end;

The TDoublePointM type exposes the following members.

Fields
Show:
Name | Description
M | Represents field M.
X | Represents field X.
Y | Represents field Y.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TDoublePointM Fields

Fields
Name | Description
M | Represents field M.
X | Represents field X.
Y | Represents field Y.
Top


TDoublePointM.M Field

Summary

Represents field M.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 X, Y, M: Double;

Field Value

Type: Double

See Also

Reference

  • TDoublePointM
  • frxERSIShapeFileFormat


TDoublePointM.X Field

Summary

Represents field X.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 X, Y, M: Double;

Field Value

Type: Double

See Also

Reference

  • TDoublePointM
  • frxERSIShapeFileFormat


TDoublePointM.Y Field

Summary

Represents field Y.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 X, Y, M: Double;

Field Value

Type: Double

See Also

Reference

  • TDoublePointM
  • frxERSIShapeFileFormat


TDoublePointZ Record

Summary

Represents type TDoublePointZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
type
 TDoublePointZ = record
 end;

The TDoublePointZ type exposes the following members.

Fields
Show:
Name | Description
M | Represents field M.
X | Represents field X.
Y | Represents field Y.
Z | Represents field Z.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TDoublePointZ Fields

Fields
Name | Description
M | Represents field M.
X | Represents field X.
Y | Represents field Y.
Z | Represents field Z.
Top


TDoublePointZ.M Field

Summary

Represents field M.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 X, Y, Z, M: Double;

Field Value

Type: Double

See Also

Reference

  • TDoublePointZ
  • frxERSIShapeFileFormat


TDoublePointZ.X Field

Summary

Represents field X.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 X, Y, Z, M: Double;

Field Value

Type: Double

See Also

Reference

  • TDoublePointZ
  • frxERSIShapeFileFormat


TDoublePointZ.Y Field

Summary

Represents field Y.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 X, Y, Z, M: Double;

Field Value

Type: Double

See Also

Reference

  • TDoublePointZ
  • frxERSIShapeFileFormat


TDoublePointZ.Z Field

Summary

Represents field Z.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 X, Y, Z, M: Double;

Field Value

Type: Double

See Also

Reference

  • TDoublePointZ
  • frxERSIShapeFileFormat


TERSIMainFileHeader Record

Summary

Represents type TERSIMainFileHeader.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
type
 TERSIMainFileHeader = packed record
 end;

The TERSIMainFileHeader type exposes the following members.

Fields
Show:
Name | Description
FileCode | Represents field FileCode.
FileLength | Represents field FileLength.
Mmax | Represents field Mmax.
Mmin | Represents field Mmin.
ShapeType | Represents field ShapeType.
Unused | Represents field Unused.
Version | Represents field Version.
Xmax | Represents field Xmax.
Xmin | Represents field Xmin.
Ymax | Represents field Ymax.
Ymin | Represents field Ymin.
Zmax | Represents field Zmax.
Zmin | Represents field Zmin.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIMainFileHeader Fields

Fields
Name | Description
FileCode | Represents field FileCode.
FileLength | Represents field FileLength.
Mmax | Represents field Mmax.
Mmin | Represents field Mmin.
ShapeType | Represents field ShapeType.
Unused | Represents field Unused.
Version | Represents field Version.
Xmax | Represents field Xmax.
Xmin | Represents field Xmin.
Ymax | Represents field Ymax.
Ymin | Represents field Ymin.
Zmax | Represents field Zmax.
Zmin | Represents field Zmin.
Top


TERSIMainFileHeader.FileCode Field

Summary

Represents field FileCode.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 FileCode: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileHeader.FileLength Field

Summary

Represents field FileLength.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 FileLength: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileHeader.Mmax Field

Summary

Represents field Mmax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Zmin, Zmax, Mmin, Mmax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileHeader.Mmin Field

Summary

Represents field Mmin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Zmin, Zmax, Mmin, Mmax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileHeader.ShapeType Field

Summary

Represents field ShapeType.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 ShapeType: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileHeader.Unused Field

Summary

Represents field Unused.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Unused: array[0..4] of LongInt;

Field Value

Type: array[0..4] of LongInt

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileHeader.Version Field

Summary

Represents field Version.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Version: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileHeader.Xmax Field

Summary

Represents field Xmax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Xmin, Ymin, Xmax, Ymax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileHeader.Xmin Field

Summary

Represents field Xmin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Xmin, Ymin, Xmax, Ymax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileHeader.Ymax Field

Summary

Represents field Ymax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Xmin, Ymin, Xmax, Ymax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileHeader.Ymin Field

Summary

Represents field Ymin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Xmin, Ymin, Xmax, Ymax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileHeader.Zmax Field

Summary

Represents field Zmax.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Zmin, Zmax, Mmin, Mmax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileHeader.Zmin Field

Summary

Represents field Zmin.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 Zmin, Zmax, Mmin, Mmax: Double;

Field Value

Type: Double

See Also

Reference

  • TERSIMainFileHeader
  • frxERSIShapeFileFormat


TERSIMainFileRecordHeader Record

Summary

Represents type TERSIMainFileRecordHeader.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
type
 TERSIMainFileRecordHeader = record
 end;

The TERSIMainFileRecordHeader type exposes the following members.

Fields
Show:
Name | Description
ContentLength | Represents field ContentLength.
RecordNumber | Represents field RecordNumber.
ShapeType | Represents field ShapeType.
Top
See Also

Reference

  • frxERSIShapeFileFormat


TERSIMainFileRecordHeader Fields

Fields
Name | Description
ContentLength | Represents field ContentLength.
RecordNumber | Represents field RecordNumber.
ShapeType | Represents field ShapeType.
Top


TERSIMainFileRecordHeader.ContentLength Field

Summary

Represents field ContentLength.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 ContentLength: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TERSIMainFileRecordHeader
  • frxERSIShapeFileFormat


TERSIMainFileRecordHeader.RecordNumber Field

Summary

Represents field RecordNumber.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 RecordNumber: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TERSIMainFileRecordHeader
  • frxERSIShapeFileFormat


TERSIMainFileRecordHeader.ShapeType Field

Summary

Represents field ShapeType.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
public
 ShapeType: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TERSIMainFileRecordHeader
  • frxERSIShapeFileFormat


frxERSIShapeFileFormat Types

Types
Name | Description
TDoublePointMArray | Represents an array of the TDoublePointM type.
TDoublePointZArray | Represents an array of the TDoublePointZ type.
TLongIntArray | Represents an array of the LongInt type.
Top


TDoublePointMArray Type

Summary

Represents an array of the TDoublePointM type.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
type
 TDoublePointMArray = array of TDoublePointM;
See Also

Reference

  • frxERSIShapeFileFormat


TDoublePointZArray Type

Summary

Represents an array of the TDoublePointZ type.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
type
 TDoublePointZArray = array of TDoublePointZ;
See Also

Reference

  • frxERSIShapeFileFormat


TLongIntArray Type

Summary

Represents an array of the LongInt type.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
type
 TLongIntArray = array of LongInt;
See Also

Reference

  • frxERSIShapeFileFormat


frxERSIShapeFileFormat Constants

Constants
Name | Description
ERSI_MultiPatch | Represents constant ERSI_MultiPatch.
ERSI_MultiPoint | Represents constant ERSI_MultiPoint.
ERSI_MultiPointM | Represents constant ERSI_MultiPointM.
ERSI_MultiPointZ | Represents constant ERSI_MultiPointZ.
ERSI_Null | Represents constant ERSI_Null.
ERSI_Point | Represents constant ERSI_Point.
ERSI_PointM | Represents constant ERSI_PointM.
ERSI_PointZ | Represents constant ERSI_PointZ.
ERSI_Polygon | Represents constant ERSI_Polygon.
ERSI_PolygonM | Represents constant ERSI_PolygonM.
ERSI_PolygonZ | Represents constant ERSI_PolygonZ.
ERSI_PolyLine | Represents constant ERSI_PolyLine.
ERSI_PolyLineM | Represents constant ERSI_PolyLineM.
ERSI_PolyLineZ | Represents constant ERSI_PolyLineZ.
Top


ERSI_MultiPatch Constant

Summary

Represents constant ERSI_MultiPatch.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_MultiPatch = 31;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_MultiPoint Constant

Summary

Represents constant ERSI_MultiPoint.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_MultiPoint = 8;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_MultiPointM Constant

Summary

Represents constant ERSI_MultiPointM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_MultiPointM = 28;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_MultiPointZ Constant

Summary

Represents constant ERSI_MultiPointZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_MultiPointZ = 18;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_Null Constant

Summary

Represents constant ERSI_Null.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_Null = 0;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_Point Constant

Summary

Represents constant ERSI_Point.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_Point = 1;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_PointM Constant

Summary

Represents constant ERSI_PointM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_PointM = 21;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_PointZ Constant

Summary

Represents constant ERSI_PointZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_PointZ = 11;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_Polygon Constant

Summary

Represents constant ERSI_Polygon.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_Polygon = 5;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_PolygonM Constant

Summary

Represents constant ERSI_PolygonM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_PolygonM = 25;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_PolygonZ Constant

Summary

Represents constant ERSI_PolygonZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_PolygonZ = 15;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_PolyLine Constant

Summary

Represents constant ERSI_PolyLine.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_PolyLine = 3;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_PolyLineM Constant

Summary

Represents constant ERSI_PolyLineM.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_PolyLineM = 23;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


ERSI_PolyLineZ Constant

Summary

Represents constant ERSI_PolyLineZ.

Namespace: frxERSIShapeFileFormat
Syntax
Delphi
 ERSI_PolyLineZ = 13;

Value

Type: ShortInt

See Also

Reference

  • frxERSIShapeFileFormat


frxFileUtils Namespace

Summary

Represents namespace frxFileUtils.

Routines
Name | Description
BrowseDialog(String,string) | Represents method BrowseDialog(String,string).
DeleteFolder(String) | Represents method DeleteFolder(String).
frxExpandRelativePath(string) | Represents method frxExpandRelativePath(string).
GetFileMIMEType(String) | Represents method GetFileMIMEType(String).
GetFileSize(String) | Represents method GetFileSize(String).
StreamSearch(TStream,Longint,AnsiString) | Represents method StreamSearch(TStream,Longint,AnsiString).
Top


frxFileUtils Routines

Routines
Name | Description
BrowseDialog(String,string) | Represents method BrowseDialog(String,string).
DeleteFolder(String) | Represents method DeleteFolder(String).
frxExpandRelativePath(string) | Represents method frxExpandRelativePath(string).
GetFileMIMEType(String) | Represents method GetFileMIMEType(String).
GetFileSize(String) | Represents method GetFileSize(String).
StreamSearch(TStream,Longint,AnsiString) | Represents method StreamSearch(TStream,Longint,AnsiString).
Top


BrowseDialog(String,string) Method

Summary

Represents method BrowseDialog(String,string).

Namespace: frxFileUtils
Syntax
Delphi
function BrowseDialog(const Path:String; const Title: string = ''): string;

Parameters

Path
Type: String

Title
Type: string

Return Value

Type: string

See Also

Reference

  • frxFileUtils


DeleteFolder(String) Method

Summary

Represents method DeleteFolder(String).

Namespace: frxFileUtils
Syntax
Delphi
procedure DeleteFolder(const DirName: String);

Parameters

DirName
Type: String

See Also

Reference

  • frxFileUtils


frxExpandRelativePath(string) Method

Summary

Represents method frxExpandRelativePath(string).

Namespace: frxFileUtils
Syntax
Delphi
function frxExpandRelativePath(const Path: string): string;

Parameters

Path
Type: string

Return Value

Type: string

See Also

Reference

  • frxFileUtils


GetFileMIMEType(String) Method

Summary

Represents method GetFileMIMEType(String).

Namespace: frxFileUtils
Syntax
Delphi
function GetFileMIMEType(const Extension: String): String;

Parameters

Extension
Type: String

Return Value

Type: String

See Also

Reference

  • frxFileUtils


GetFileSize(String) Method

Summary

Represents method GetFileSize(String).

Namespace: frxFileUtils
Syntax
Delphi
function GetFileSize(const FileName: String): Longint;

Parameters

FileName
Type: String

Return Value

Type: Longint

See Also

Reference

  • frxFileUtils


StreamSearch(TStream,Longint,AnsiString) Method

Summary

Represents method StreamSearch(TStream,Longint,AnsiString).

Namespace: frxFileUtils
Syntax
Delphi
function StreamSearch(Strm: TStream; const StartPos: Longint; const Value: AnsiString): Longint;

Parameters

Strm
Type: TStream

StartPos
Type: Longint

Value
Type: AnsiString

Return Value

Type: Longint

See Also

Reference

  • frxFileUtils


frxGauge Namespace

Summary

Represents namespace frxGauge.

Classes
Name | Description
TBandPointer | Represents type TBandPointer.
TBasePolygonPointer | Represents type TBasePolygonPointer.
TDiamondPointer | Represents type TDiamondPointer.
TfrxBaseGauge | Represents type TfrxBaseGauge.
TfrxGauge | Represents type TfrxGauge.
TfrxIntervalGauge | Represents type TfrxIntervalGauge.
TGaugeCoordinateConverter | Represents type TGaugeCoordinateConverter.
TGaugeMargin | Represents type TGaugeMargin.
TGaugePointer | Represents type TGaugePointer.
TGaugeScale | Represents type TGaugeScale.
TGaugeScaleTicks | Represents type TGaugeScaleTicks.
TPentagonPointer | Represents type TPentagonPointer.
TSegmentPointer | Represents type TSegmentPointer.
TTrianglePointer | Represents type TTrianglePointer.
Top
Records
Name | Description
TFloatPoint | Represents type TFloatPoint.
TRay | Represents type TRay.
Top
Enumerations
Name | Description
TGaugeKind | Represents type TGaugeKind.
TGaugePointerKind | Represents type TGaugePointerKind.
TSelectedPointer | Represents type TSelectedPointer.
Top
Delegates
Name | Description
TUpdateEvent | Represents type TUpdateEvent.
Top


frxGauge Classes

Classes
Name | Description
TBandPointer | Represents type TBandPointer.
TBasePolygonPointer | Represents type TBasePolygonPointer.
TDiamondPointer | Represents type TDiamondPointer.
TfrxBaseGauge | Represents type TfrxBaseGauge.
TfrxGauge | Represents type TfrxGauge.
TfrxIntervalGauge | Represents type TfrxIntervalGauge.
TGaugeCoordinateConverter | Represents type TGaugeCoordinateConverter.
TGaugeMargin | Represents type TGaugeMargin.
TGaugePointer | Represents type TGaugePointer.
TGaugeScale | Represents type TGaugeScale.
TGaugeScaleTicks | Represents type TGaugeScaleTicks.
TPentagonPointer | Represents type TPentagonPointer.
TSegmentPointer | Represents type TSegmentPointer.
TTrianglePointer | Represents type TTrianglePointer.
Top


TBandPointer Class

Summary

Represents type TBandPointer.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TGaugePointer
frxGauge.TBandPointer
Syntax
Delphi
type
 TBandPointer = class(TGaugePointer)
 end;

The TBandPointer type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugePointer class. (Inherited from TGaugePointer.)
Top
Properties
Show:
Name | Description
BorderColor | Represents property BorderColor. (Inherited from TGaugePointer.)
BorderWidth | Represents property BorderWidth. (Inherited from TGaugePointer.)
Color | Represents property Color.
Height | Represents property Height. (Inherited from TGaugePointer.)
Width | Represents property Width.
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent). (Inherited from TGaugePointer.)
fp(Extended,Extended) | Represents method fp(Extended,Extended). (Inherited from TGaugePointer.)
IsPublishedColor | Represents method IsPublishedColor. (Overrides TGaugePointer.IsPublishedColor.)
IsPublishedHeight | Represents method IsPublishedHeight. (Inherited from TGaugePointer.)
IsPublishedWidth | Represents method IsPublishedWidth. (Overrides TGaugePointer.IsPublishedWidth.)
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended). (Overrides TGaugePointer.Paint(TCanvas,Extended).)
PaintCircleBand(TCanvas,TRay,TRay) | Represents method PaintCircleBand(TCanvas,TRay,TRay).
PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]) | Represents method PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]). (Inherited from TGaugePointer.)
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended). (Overrides TGaugePointer.PaintPair(TCanvas,Extended,Extended).)
PaintRectBand(TCanvas,TRay,TRay) | Represents method PaintRectBand(TCanvas,TRay,TRay).
SetupCanvas(TCanvas) | Represents method SetupCanvas(TCanvas). (Inherited from TGaugePointer.)
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge. (Inherited from TGaugePointer.)
Top
See Also

Reference

  • frxGauge


TBandPointer Properties

Properties
Name | Description
Color | Represents property Color.
Width | Represents property Width.
Top


TBandPointer.Color Property

Summary

Represents property Color.

Namespace: frxGauge
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TBandPointer
  • frxGauge


TBandPointer.Width Property

Summary

Represents property Width.

Namespace: frxGauge
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TBandPointer
  • frxGauge


TBandPointer Methods

Methods
Name | Description
IsPublishedColor | Represents method IsPublishedColor. (Overrides TGaugePointer.IsPublishedColor.)
IsPublishedWidth | Represents method IsPublishedWidth. (Overrides TGaugePointer.IsPublishedWidth.)
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended). (Overrides TGaugePointer.Paint(TCanvas,Extended).)
PaintCircleBand(TCanvas,TRay,TRay) | Represents method PaintCircleBand(TCanvas,TRay,TRay).
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended). (Overrides TGaugePointer.PaintPair(TCanvas,Extended,Extended).)
PaintRectBand(TCanvas,TRay,TRay) | Represents method PaintRectBand(TCanvas,TRay,TRay).
Top


TBandPointer.IsPublishedColor Method

Summary

Represents method IsPublishedColor.

Namespace: frxGauge
Syntax
Delphi
public
 function IsPublishedColor: boolean; override;

Return Value

Type: boolean

Overrides

TGaugePointer.IsPublishedColor
See Also

Reference

  • TBandPointer
  • frxGauge


TBandPointer.IsPublishedWidth Method

Summary

Represents method IsPublishedWidth.

Namespace: frxGauge
Syntax
Delphi
public
 function IsPublishedWidth: boolean; override;

Return Value

Type: boolean

Overrides

TGaugePointer.IsPublishedWidth
See Also

Reference

  • TBandPointer
  • frxGauge


TBandPointer.Paint(TCanvas,Extended) Method

Summary

Represents method Paint(TCanvas,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure Paint(Canvas: TCanvas; Value: Extended); override;

Parameters

Canvas
Type: TCanvas

Value
Type: Extended

Overrides

TGaugePointer.Paint(TCanvas,Extended)
See Also

Reference

  • TBandPointer
  • frxGauge


TBandPointer.PaintCircleBand(TCanvas,TRay,TRay) Method

Summary

Represents method PaintCircleBand(TCanvas,TRay,TRay).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure PaintCircleBand(Canvas: TCanvas; Start, Current: TRay);

Parameters

Canvas
Type: TCanvas

Start
Type: TRay

Current
Type: TRay

See Also

Reference

  • TBandPointer
  • frxGauge


TBandPointer.PaintPair(TCanvas,Extended,Extended) Method

Summary

Represents method PaintPair(TCanvas,Extended,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure PaintPair(Canvas: TCanvas; StartValue, EndValue: Extended); override;

Parameters

Canvas
Type: TCanvas

StartValue
Type: Extended

EndValue
Type: Extended

Overrides

TGaugePointer.PaintPair(TCanvas,Extended,Extended)
See Also

Reference

  • TBandPointer
  • frxGauge


TBandPointer.PaintRectBand(TCanvas,TRay,TRay) Method

Summary

Represents method PaintRectBand(TCanvas,TRay,TRay).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure PaintRectBand(Canvas: TCanvas; Start, Current: TRay);

Parameters

Canvas
Type: TCanvas

Start
Type: TRay

Current
Type: TRay

See Also

Reference

  • TBandPointer
  • frxGauge


TBasePolygonPointer Class

Summary

Represents type TBasePolygonPointer.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TGaugePointer
frxGauge.TBasePolygonPointer
frxGauge.TDiamondPointer
frxGauge.TPentagonPointer
frxGauge.TTrianglePointer
Syntax
Delphi
type
 TBasePolygonPointer = class(TGaugePointer)
 end;

The TBasePolygonPointer type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugePointer class. (Inherited from TGaugePointer.)
Top
Properties
Show:
Name | Description
BorderColor | Represents property BorderColor. (Inherited from TGaugePointer.)
BorderWidth | Represents property BorderWidth. (Inherited from TGaugePointer.)
Color | Represents property Color.
Height | Represents property Height.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent). (Inherited from TGaugePointer.)
fp(Extended,Extended) | Represents method fp(Extended,Extended). (Inherited from TGaugePointer.)
IsPublishedColor | Represents method IsPublishedColor. (Overrides TGaugePointer.IsPublishedColor.)
IsPublishedHeight | Represents method IsPublishedHeight. (Overrides TGaugePointer.IsPublishedHeight.)
IsPublishedWidth | Represents method IsPublishedWidth. (Overrides TGaugePointer.IsPublishedWidth.)
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended). (Inherited from TGaugePointer.)
PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]) | Represents method PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]). (Inherited from TGaugePointer.)
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended). (Inherited from TGaugePointer.)
SetupCanvas(TCanvas) | Represents method SetupCanvas(TCanvas). (Inherited from TGaugePointer.)
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge. (Inherited from TGaugePointer.)
Top
See Also

Reference

  • frxGauge


TBasePolygonPointer Properties

Properties
Name | Description
Color | Represents property Color.
Height | Represents property Height.
Width | Represents property Width.
Top


TBasePolygonPointer.Color Property

Summary

Represents property Color.

Namespace: frxGauge
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TBasePolygonPointer
  • frxGauge


TBasePolygonPointer.Height Property

Summary

Represents property Height.

Namespace: frxGauge
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TBasePolygonPointer
  • frxGauge


TBasePolygonPointer.Width Property

Summary

Represents property Width.

Namespace: frxGauge
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TBasePolygonPointer
  • frxGauge


TBasePolygonPointer Methods

Methods
Name | Description
IsPublishedColor | Represents method IsPublishedColor. (Overrides TGaugePointer.IsPublishedColor.)
IsPublishedHeight | Represents method IsPublishedHeight. (Overrides TGaugePointer.IsPublishedHeight.)
IsPublishedWidth | Represents method IsPublishedWidth. (Overrides TGaugePointer.IsPublishedWidth.)
Top


TBasePolygonPointer.IsPublishedColor Method

Summary

Represents method IsPublishedColor.

Namespace: frxGauge
Syntax
Delphi
public
 function IsPublishedColor: boolean; override;

Return Value

Type: boolean

Overrides

TGaugePointer.IsPublishedColor
See Also

Reference

  • TBasePolygonPointer
  • frxGauge


TBasePolygonPointer.IsPublishedHeight Method

Summary

Represents method IsPublishedHeight.

Namespace: frxGauge
Syntax
Delphi
public
 function IsPublishedHeight: boolean; override;

Return Value

Type: boolean

Overrides

TGaugePointer.IsPublishedHeight
See Also

Reference

  • TBasePolygonPointer
  • frxGauge


TBasePolygonPointer.IsPublishedWidth Method

Summary

Represents method IsPublishedWidth.

Namespace: frxGauge
Syntax
Delphi
public
 function IsPublishedWidth: boolean; override;

Return Value

Type: boolean

Overrides

TGaugePointer.IsPublishedWidth
See Also

Reference

  • TBasePolygonPointer
  • frxGauge


TDiamondPointer Class

Summary

Represents type TDiamondPointer.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TGaugePointer
frxGauge.TBasePolygonPointer
frxGauge.TDiamondPointer
Syntax
Delphi
type
 TDiamondPointer = class(TBasePolygonPointer)
 end;

The TDiamondPointer type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugePointer class. (Inherited from TGaugePointer.)
Top
Properties
Show:
Name | Description
BorderColor | Represents property BorderColor. (Inherited from TGaugePointer.)
BorderWidth | Represents property BorderWidth. (Inherited from TGaugePointer.)
Color | Represents property Color. (Inherited from TBasePolygonPointer.)
Height | Represents property Height. (Inherited from TBasePolygonPointer.)
Width | Represents property Width. (Inherited from TBasePolygonPointer.)
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent). (Inherited from TGaugePointer.)
fp(Extended,Extended) | Represents method fp(Extended,Extended). (Inherited from TGaugePointer.)
IsPublishedColor | Represents method IsPublishedColor. (Overrides TGaugePointer.IsPublishedColor.)
IsPublishedHeight | Represents method IsPublishedHeight. (Overrides TGaugePointer.IsPublishedHeight.)
IsPublishedWidth | Represents method IsPublishedWidth. (Overrides TGaugePointer.IsPublishedWidth.)
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended). (Overrides TGaugePointer.Paint(TCanvas,Extended).)
PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]) | Represents method PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]). (Inherited from TGaugePointer.)
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended). (Overrides TGaugePointer.PaintPair(TCanvas,Extended,Extended).)
SetupCanvas(TCanvas) | Represents method SetupCanvas(TCanvas). (Inherited from TGaugePointer.)
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge. (Inherited from TGaugePointer.)
Top
See Also

Reference

  • frxGauge


TDiamondPointer Methods

Methods
Name | Description
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended). (Overrides TGaugePointer.Paint(TCanvas,Extended).)
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended). (Overrides TGaugePointer.PaintPair(TCanvas,Extended,Extended).)
Top


TDiamondPointer.Paint(TCanvas,Extended) Method

Summary

Represents method Paint(TCanvas,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure Paint(Canvas: TCanvas; Value: Extended); override;

Parameters

Canvas
Type: TCanvas

Value
Type: Extended

Overrides

TGaugePointer.Paint(TCanvas,Extended)
See Also

Reference

  • TDiamondPointer
  • frxGauge


TDiamondPointer.PaintPair(TCanvas,Extended,Extended) Method

Summary

Represents method PaintPair(TCanvas,Extended,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure PaintPair(Canvas: TCanvas; StartValue, EndValue: Extended); override;

Parameters

Canvas
Type: TCanvas

StartValue
Type: Extended

EndValue
Type: Extended

Overrides

TGaugePointer.PaintPair(TCanvas,Extended,Extended)
See Also

Reference

  • TDiamondPointer
  • frxGauge


TfrxBaseGauge Class

Summary

Represents type TfrxBaseGauge.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TfrxBaseGauge
frxGauge.TfrxGauge
frxGauge.TfrxIntervalGauge
Syntax
Delphi
type
 TfrxBaseGauge = class(TPersistent)
 end;

The TfrxBaseGauge type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxBaseGauge class.
Destroy | Represents the destructor of the TfrxBaseGauge class.
Top
Properties
Show:
Name | Description
Angle | Represents property Angle.
Kind | Represents property Kind.
MajorScale | Represents property MajorScale.
MajorStep | Represents property MajorStep.
Margin | Represents property Margin.
Maximum | Represents property Maximum.
Minimum | Represents property Minimum.
MinorScale | Represents property MinorScale.
MinorStep | Represents property MinorStep.
Pointer | Represents property Pointer.
PointerKind | Represents property PointerKind.
Scale | Represents property Scale.
ScaleX | Represents property ScaleX.
ScaleY | Represents property ScaleY.
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
CorrectByMaximum | Represents method CorrectByMaximum.
CorrectByMinimum | Represents method CorrectByMinimum.
CreatePointer(TGaugePointer,Boolean) | Represents method CreatePointer(TGaugePointer,Boolean).
DoMouseDown(Integer,Integer,TMouseButton,TShiftState) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState).
DoMouseMove(Integer,Integer,TShiftState) | Represents method DoMouseMove(Integer,Integer,TShiftState).
DoMouseUp(Integer,Integer,TMouseButton,TShiftState) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState).
DoMouseWheel(TShiftState,Integer,TPoint) | Represents method DoMouseWheel(TShiftState,Integer,TPoint).
Draw(TCanvas,TRect) | Represents method Draw(TCanvas,TRect).
DrawPointer(TCanvas) | Represents method DrawPointer(TCanvas).
MultiDigits | Represents method MultiDigits.
OneDigit(Tpoint) | Represents method OneDigit(Tpoint).
Radians | Represents method Radians.
Repaint | Represents method Repaint.
SetAngle(Integer) | Represents method SetAngle(Integer).
SetKind(TGaugeKind) | Represents method SetKind(TGaugeKind).
SetMajorScale(TGaugeScale) | Represents method SetMajorScale(TGaugeScale).
SetMajorStep(Extended) | Represents method SetMajorStep(Extended).
SetMargin(TGaugeMargin) | Represents method SetMargin(TGaugeMargin).
SetMaximum(Extended) | Represents method SetMaximum(Extended).
SetMinimum(Extended) | Represents method SetMinimum(Extended).
SetMinorScale(TGaugeScale) | Represents method SetMinorScale(TGaugeScale).
SetMinorStep(Extended) | Represents method SetMinorStep(Extended).
SetPointer(TGaugePointer) | Represents method SetPointer(TGaugePointer).
SetPointerKind(TGaugePointerKind) | Represents method SetPointerKind(TGaugePointerKind).
SetXYScales(Extended,Extended,Boolean) | Represents method SetXYScales(Extended,Extended,Boolean).
UpdateOI | Represents method UpdateOI.
Top
Events
Show:
Name | Description
OnRepaint | Represents property OnRepaint.
OnUpdateOI | Represents property OnUpdateOI.
Top
Fields
Show:
Name | Description
FAngle | Represents field FAngle.
FCC | Represents field FCC.
FIsPrinting | Represents field FIsPrinting.
FKind | Represents field FKind.
FLeftPressed | Represents field FLeftPressed.
FMajorScale | Represents field FMajorScale.
FMajorStep | Represents field FMajorStep.
FMargin | Represents field FMargin.
FMaximum | Represents field FMaximum.
FMinimum | Represents field FMinimum.
FMinorScale | Represents field FMinorScale.
FMinorStep | Represents field FMinorStep.
FOnRepaint | Represents field FOnRepaint.
FOnUpdateOI | Represents field FOnUpdateOI.
FPointer | Represents field FPointer.
FPointerKind | Represents field FPointerKind.
FScale | Represents field FScale.
FScaleX | Represents field FScaleX.
FScaleY | Represents field FScaleY.
Top
See Also

Reference

  • frxGauge


TfrxBaseGauge Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxBaseGauge class.
Destroy | Represents the destructor of the TfrxBaseGauge class.
Top


TfrxBaseGauge.Create Constructor

Summary

Initializes a new instance of the TfrxBaseGauge class.

Namespace: frxGauge
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.Destroy Destructor

Summary

Represents the destructor of the TfrxBaseGauge class.

Namespace: frxGauge
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge Properties

Properties
Name | Description
Angle | Represents property Angle.
Kind | Represents property Kind.
MajorScale | Represents property MajorScale.
MajorStep | Represents property MajorStep.
Margin | Represents property Margin.
Maximum | Represents property Maximum.
Minimum | Represents property Minimum.
MinorScale | Represents property MinorScale.
MinorStep | Represents property MinorStep.
Pointer | Represents property Pointer.
PointerKind | Represents property PointerKind.
Scale | Represents property Scale.
ScaleX | Represents property ScaleX.
ScaleY | Represents property ScaleY.
Top


TfrxBaseGauge.Angle Property

Summary

Represents property Angle.

Namespace: frxGauge
Syntax
Delphi
published
 property Angle: Integer read FAngle write SetAngle;

Property Value

Type: Integer

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.Kind Property

Summary

Represents property Kind.

Namespace: frxGauge
Syntax
Delphi
published
 property Kind: TGaugeKind read FKind write SetKind;

Property Value

Type: TGaugeKind

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.MajorScale Property

Summary

Represents property MajorScale.

Namespace: frxGauge
Syntax
Delphi
published
 property MajorScale: TGaugeScale read FMajorScale write SetMajorScale;

Property Value

Type: TGaugeScale

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.MajorStep Property

Summary

Represents property MajorStep.

Namespace: frxGauge
Syntax
Delphi
published
 property MajorStep: Extended read FMajorStep write SetMajorStep;

Property Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.Margin Property

Summary

Represents property Margin.

Namespace: frxGauge
Syntax
Delphi
published
 property Margin: TGaugeMargin read FMargin write SetMargin;

Property Value

Type: TGaugeMargin

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.Maximum Property

Summary

Represents property Maximum.

Namespace: frxGauge
Syntax
Delphi
public
 property Maximum: Extended read FMaximum write SetMaximum;

Property Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.Minimum Property

Summary

Represents property Minimum.

Namespace: frxGauge
Syntax
Delphi
public
 property Minimum: Extended read FMinimum write SetMinimum;

Property Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.MinorScale Property

Summary

Represents property MinorScale.

Namespace: frxGauge
Syntax
Delphi
published
 property MinorScale: TGaugeScale read FMinorScale write SetMinorScale;

Property Value

Type: TGaugeScale

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.MinorStep Property

Summary

Represents property MinorStep.

Namespace: frxGauge
Syntax
Delphi
published
 property MinorStep: Extended read FMinorStep write SetMinorStep;

Property Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.Pointer Property

Summary

Represents property Pointer.

Namespace: frxGauge
Syntax
Delphi
published
 property Pointer: TGaugePointer read FPointer write SetPointer;

Property Value

Type: TGaugePointer

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.PointerKind Property

Summary

Represents property PointerKind.

Namespace: frxGauge
Syntax
Delphi
published
 property PointerKind: TGaugePointerKind read FPointerKind write SetPointerKind;

Property Value

Type: TGaugePointerKind

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.Scale Property

Summary

Represents property Scale.

Namespace: frxGauge
Syntax
Delphi
public
 property Scale: Extended read FScale;

Property Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.ScaleX Property

Summary

Represents property ScaleX.

Namespace: frxGauge
Syntax
Delphi
public
 property ScaleX: Extended read FScaleX;

Property Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.ScaleY Property

Summary

Represents property ScaleY.

Namespace: frxGauge
Syntax
Delphi
public
 property ScaleY: Extended read FScaleY;

Property Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge Methods

Methods
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
CorrectByMaximum | Represents method CorrectByMaximum.
CorrectByMinimum | Represents method CorrectByMinimum.
CreatePointer(TGaugePointer,Boolean) | Represents method CreatePointer(TGaugePointer,Boolean).
DoMouseDown(Integer,Integer,TMouseButton,TShiftState) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState).
DoMouseMove(Integer,Integer,TShiftState) | Represents method DoMouseMove(Integer,Integer,TShiftState).
DoMouseUp(Integer,Integer,TMouseButton,TShiftState) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState).
DoMouseWheel(TShiftState,Integer,TPoint) | Represents method DoMouseWheel(TShiftState,Integer,TPoint).
Draw(TCanvas,TRect) | Represents method Draw(TCanvas,TRect).
DrawPointer(TCanvas) | Represents method DrawPointer(TCanvas).
MultiDigits | Represents method MultiDigits.
OneDigit(Tpoint) | Represents method OneDigit(Tpoint).
Radians | Represents method Radians.
Repaint | Represents method Repaint.
SetAngle(Integer) | Represents method SetAngle(Integer).
SetKind(TGaugeKind) | Represents method SetKind(TGaugeKind).
SetMajorScale(TGaugeScale) | Represents method SetMajorScale(TGaugeScale).
SetMajorStep(Extended) | Represents method SetMajorStep(Extended).
SetMargin(TGaugeMargin) | Represents method SetMargin(TGaugeMargin).
SetMaximum(Extended) | Represents method SetMaximum(Extended).
SetMinimum(Extended) | Represents method SetMinimum(Extended).
SetMinorScale(TGaugeScale) | Represents method SetMinorScale(TGaugeScale).
SetMinorStep(Extended) | Represents method SetMinorStep(Extended).
SetPointer(TGaugePointer) | Represents method SetPointer(TGaugePointer).
SetPointerKind(TGaugePointerKind) | Represents method SetPointerKind(TGaugePointerKind).
SetXYScales(Extended,Extended,Boolean) | Represents method SetXYScales(Extended,Extended,Boolean).
UpdateOI | Represents method UpdateOI.
Top


TfrxBaseGauge.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: frxGauge
Syntax
Delphi
public
 procedure AssignTo(Dest: TPersistent); override;

Parameters

Dest
Type: TPersistent

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.CorrectByMaximum Method

Summary

Represents method CorrectByMaximum.

Namespace: frxGauge
Syntax
Delphi
protected
 procedure CorrectByMaximum; virtual; abstract;
See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.CorrectByMinimum Method

Summary

Represents method CorrectByMinimum.

Namespace: frxGauge
Syntax
Delphi
protected
 procedure CorrectByMinimum; virtual; abstract;
See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.CreatePointer(TGaugePointer,Boolean) Method

Summary

Represents method CreatePointer(TGaugePointer,Boolean).

Namespace: frxGauge
Syntax
Delphi
protected
 function CreatePointer(Old: TGaugePointer = nil; DestroyOld: Boolean = False): TGaugePointer;

Parameters

Old
Type: TGaugePointer

DestroyOld
Type: Boolean

Return Value

Type: TGaugePointer

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.DoMouseDown(Integer,Integer,TMouseButton,TShiftState) Method

Summary

Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState).

Namespace: frxGauge
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState): Boolean;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

Return Value

Type: Boolean

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.DoMouseMove(Integer,Integer,TShiftState) Method

Summary

Represents method DoMouseMove(Integer,Integer,TShiftState).

Namespace: frxGauge
Syntax
Delphi
public
 function DoMouseMove(X, Y: Integer; Shift: TShiftState): Boolean;

Parameters

X
Type: Integer

Y
Type: Integer

Shift
Type: TShiftState

Return Value

Type: Boolean

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.DoMouseUp(Integer,Integer,TMouseButton,TShiftState) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState).

Namespace: frxGauge
Syntax
Delphi
public
 function DoMouseUp(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState): Boolean;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

Return Value

Type: Boolean

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.DoMouseWheel(TShiftState,Integer,TPoint) Method

Summary

Represents method DoMouseWheel(TShiftState,Integer,TPoint).

Namespace: frxGauge
Syntax
Delphi
public
 function DoMouseWheel(Shift: TShiftState; WheelDelta: Integer;
 MousePos: TPoint): Boolean; virtual; abstract;

Parameters

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

Return Value

Type: Boolean

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.Draw(TCanvas,TRect) Method

Summary

Represents method Draw(TCanvas,TRect).

Namespace: frxGauge
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ClientRect: TRect);

Parameters

Canvas
Type: TCanvas

ClientRect
Type: TRect

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.DrawPointer(TCanvas) Method

Summary

Represents method DrawPointer(TCanvas).

Namespace: frxGauge
Syntax
Delphi
public
 procedure DrawPointer(Canvas: TCanvas); virtual; abstract;

Parameters

Canvas
Type: TCanvas

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.MultiDigits Method

Summary

Represents method MultiDigits.

Namespace: frxGauge
Syntax
Delphi
protected
 procedure MultiDigits; virtual;
See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.OneDigit(Tpoint) Method

Summary

Represents method OneDigit(Tpoint).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure OneDigit(P: Tpoint); virtual; abstract;

Parameters

P
Type: Tpoint

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.Radians Method

Summary

Represents method Radians.

Namespace: frxGauge
Syntax
Delphi
public
 function Radians: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.Repaint Method

Summary

Represents method Repaint.

Namespace: frxGauge
Syntax
Delphi
protected
 procedure Repaint;
See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.SetAngle(Integer) Method

Summary

Represents method SetAngle(Integer).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetAngle(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.SetKind(TGaugeKind) Method

Summary

Represents method SetKind(TGaugeKind).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetKind(const Value: TGaugeKind);

Parameters

Value
Type: TGaugeKind

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.SetMajorScale(TGaugeScale) Method

Summary

Represents method SetMajorScale(TGaugeScale).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetMajorScale(const Value: TGaugeScale);

Parameters

Value
Type: TGaugeScale

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.SetMajorStep(Extended) Method

Summary

Represents method SetMajorStep(Extended).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetMajorStep(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.SetMargin(TGaugeMargin) Method

Summary

Represents method SetMargin(TGaugeMargin).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetMargin(const Value: TGaugeMargin);

Parameters

Value
Type: TGaugeMargin

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.SetMaximum(Extended) Method

Summary

Represents method SetMaximum(Extended).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetMaximum(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.SetMinimum(Extended) Method

Summary

Represents method SetMinimum(Extended).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetMinimum(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.SetMinorScale(TGaugeScale) Method

Summary

Represents method SetMinorScale(TGaugeScale).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetMinorScale(const Value: TGaugeScale);

Parameters

Value
Type: TGaugeScale

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.SetMinorStep(Extended) Method

Summary

Represents method SetMinorStep(Extended).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetMinorStep(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.SetPointer(TGaugePointer) Method

Summary

Represents method SetPointer(TGaugePointer).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetPointer(const Value: TGaugePointer);

Parameters

Value
Type: TGaugePointer

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.SetPointerKind(TGaugePointerKind) Method

Summary

Represents method SetPointerKind(TGaugePointerKind).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetPointerKind(const Value: TGaugePointerKind);

Parameters

Value
Type: TGaugePointerKind

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.SetXYScales(Extended,Extended,Boolean) Method

Summary

Represents method SetXYScales(Extended,Extended,Boolean).

Namespace: frxGauge
Syntax
Delphi
public
 procedure SetXYScales(AScaleX, AScaleY: Extended; IsPrinting: Boolean = False);

Parameters

AScaleX
Type: Extended

AScaleY
Type: Extended

IsPrinting
Type: Boolean

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.UpdateOI Method

Summary

Represents method UpdateOI.

Namespace: frxGauge
Syntax
Delphi
protected
 procedure UpdateOI;
See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge Events

Events
Name | Description
OnRepaint | Represents property OnRepaint.
OnUpdateOI | Represents property OnUpdateOI.
Top


TfrxBaseGauge.OnRepaint Event

Summary

Represents property OnRepaint.

Namespace: frxGauge
Syntax
Delphi
published
 property OnRepaint: TUpdateEvent read FOnRepaint write FOnRepaint;

Value

Type: TUpdateEvent

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.OnUpdateOI Event

Summary

Represents property OnUpdateOI.

Namespace: frxGauge
Syntax
Delphi
published
 property OnUpdateOI: TUpdateEvent read FOnUpdateOI write FOnUpdateOI;

Value

Type: TUpdateEvent

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge Fields

Fields
Name | Description
FAngle | Represents field FAngle.
FCC | Represents field FCC.
FIsPrinting | Represents field FIsPrinting.
FKind | Represents field FKind.
FLeftPressed | Represents field FLeftPressed.
FMajorScale | Represents field FMajorScale.
FMajorStep | Represents field FMajorStep.
FMargin | Represents field FMargin.
FMaximum | Represents field FMaximum.
FMinimum | Represents field FMinimum.
FMinorScale | Represents field FMinorScale.
FMinorStep | Represents field FMinorStep.
FOnRepaint | Represents field FOnRepaint.
FOnUpdateOI | Represents field FOnUpdateOI.
FPointer | Represents field FPointer.
FPointerKind | Represents field FPointerKind.
FScale | Represents field FScale.
FScaleX | Represents field FScaleX.
FScaleY | Represents field FScaleY.
Top


TfrxBaseGauge.FAngle Field

Summary

Represents field FAngle.

Namespace: frxGauge
Syntax
Delphi
private
 FAngle: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FCC Field

Summary

Represents field FCC.

Namespace: frxGauge
Syntax
Delphi
protected
 FCC: TGaugeCoordinateConverter;

Field Value

Type: TGaugeCoordinateConverter

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FIsPrinting Field

Summary

Represents field FIsPrinting.

Namespace: frxGauge
Syntax
Delphi
protected
 FIsPrinting: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FKind Field

Summary

Represents field FKind.

Namespace: frxGauge
Syntax
Delphi
private
 FKind: TGaugeKind;

Field Value

Type: TGaugeKind

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FLeftPressed Field

Summary

Represents field FLeftPressed.

Namespace: frxGauge
Syntax
Delphi
protected
 FLeftPressed: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FMajorScale Field

Summary

Represents field FMajorScale.

Namespace: frxGauge
Syntax
Delphi
private
 FMajorScale: TGaugeScale;

Field Value

Type: TGaugeScale

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FMajorStep Field

Summary

Represents field FMajorStep.

Namespace: frxGauge
Syntax
Delphi
private
 FMajorStep: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FMargin Field

Summary

Represents field FMargin.

Namespace: frxGauge
Syntax
Delphi
private
 FMargin: TGaugeMargin;

Field Value

Type: TGaugeMargin

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FMaximum Field

Summary

Represents field FMaximum.

Namespace: frxGauge
Syntax
Delphi
private
 FMaximum: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FMinimum Field

Summary

Represents field FMinimum.

Namespace: frxGauge
Syntax
Delphi
private
 FMinimum: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FMinorScale Field

Summary

Represents field FMinorScale.

Namespace: frxGauge
Syntax
Delphi
private
 FMinorScale: TGaugeScale;

Field Value

Type: TGaugeScale

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FMinorStep Field

Summary

Represents field FMinorStep.

Namespace: frxGauge
Syntax
Delphi
private
 FMinorStep: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FOnRepaint Field

Summary

Represents field FOnRepaint.

Namespace: frxGauge
Syntax
Delphi
private
 FOnRepaint: TUpdateEvent;

Field Value

Type: TUpdateEvent

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FOnUpdateOI Field

Summary

Represents field FOnUpdateOI.

Namespace: frxGauge
Syntax
Delphi
private
 FOnUpdateOI: TUpdateEvent;

Field Value

Type: TUpdateEvent

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FPointer Field

Summary

Represents field FPointer.

Namespace: frxGauge
Syntax
Delphi
private
 FPointer: TGaugePointer;

Field Value

Type: TGaugePointer

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FPointerKind Field

Summary

Represents field FPointerKind.

Namespace: frxGauge
Syntax
Delphi
private
 FPointerKind: TGaugePointerKind;

Field Value

Type: TGaugePointerKind

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FScale Field

Summary

Represents field FScale.

Namespace: frxGauge
Syntax
Delphi
protected
 FScaleX, FScaleY, FScale: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FScaleX Field

Summary

Represents field FScaleX.

Namespace: frxGauge
Syntax
Delphi
protected
 FScaleX, FScaleY, FScale: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxBaseGauge.FScaleY Field

Summary

Represents field FScaleY.

Namespace: frxGauge
Syntax
Delphi
protected
 FScaleX, FScaleY, FScale: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxBaseGauge
  • frxGauge


TfrxGauge Class

Summary

Represents type TfrxGauge.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TfrxBaseGauge
frxGauge.TfrxGauge
Syntax
Delphi
type
 TfrxGauge = class(TfrxBaseGauge)
 end;

The TfrxGauge type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxGauge class.
Top
Properties
Show:
Name | Description
Angle | Represents property Angle. (Inherited from TfrxBaseGauge.)
CurrentValue | Represents property CurrentValue.
Kind | Represents property Kind. (Inherited from TfrxBaseGauge.)
MajorScale | Represents property MajorScale. (Inherited from TfrxBaseGauge.)
MajorStep | Represents property MajorStep. (Inherited from TfrxBaseGauge.)
Margin | Represents property Margin. (Inherited from TfrxBaseGauge.)
Maximum | Represents property Maximum.
Minimum | Represents property Minimum.
MinorScale | Represents property MinorScale. (Inherited from TfrxBaseGauge.)
MinorStep | Represents property MinorStep. (Inherited from TfrxBaseGauge.)
Pointer | Represents property Pointer. (Inherited from TfrxBaseGauge.)
PointerKind | Represents property PointerKind. (Inherited from TfrxBaseGauge.)
Scale | Represents property Scale. (Inherited from TfrxBaseGauge.)
ScaleX | Represents property ScaleX. (Inherited from TfrxBaseGauge.)
ScaleY | Represents property ScaleY. (Inherited from TfrxBaseGauge.)
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent). (Overrides TfrxBaseGauge.AssignTo(TPersistent).)
CorrectByMaximum | Represents method CorrectByMaximum. (Overrides TfrxBaseGauge.CorrectByMaximum.)
CorrectByMinimum | Represents method CorrectByMinimum. (Overrides TfrxBaseGauge.CorrectByMinimum.)
CreatePointer(TGaugePointer,Boolean) | Represents method CreatePointer(TGaugePointer,Boolean). (Inherited from TfrxBaseGauge.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState). (Inherited from TfrxBaseGauge.)
DoMouseMove(Integer,Integer,TShiftState) | Represents method DoMouseMove(Integer,Integer,TShiftState). (Inherited from TfrxBaseGauge.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState). (Inherited from TfrxBaseGauge.)
DoMouseWheel(TShiftState,Integer,TPoint) | Represents method DoMouseWheel(TShiftState,Integer,TPoint). (Overrides TfrxBaseGauge.DoMouseWheel(TShiftState,Integer,TPoint).)
Draw(TCanvas,TRect) | Represents method Draw(TCanvas,TRect). (Inherited from TfrxBaseGauge.)
DrawPointer(TCanvas) | Represents method DrawPointer(TCanvas). (Overrides TfrxBaseGauge.DrawPointer(TCanvas).)
MultiDigits | Represents method MultiDigits. (Inherited from TfrxBaseGauge.)
OneDigit(Tpoint) | Represents method OneDigit(Tpoint). (Overrides TfrxBaseGauge.OneDigit(Tpoint).)
Radians | Represents method Radians. (Inherited from TfrxBaseGauge.)
Repaint | Represents method Repaint. (Inherited from TfrxBaseGauge.)
SetCurrentValue(Extended) | Represents method SetCurrentValue(Extended).
SetXYScales(Extended,Extended,Boolean) | Represents method SetXYScales(Extended,Extended,Boolean). (Inherited from TfrxBaseGauge.)
UpdateOI | Represents method UpdateOI. (Inherited from TfrxBaseGauge.)
Top
Events
Show:
Name | Description
OnRepaint | Represents property OnRepaint. (Inherited from TfrxBaseGauge.)
OnUpdateOI | Represents property OnUpdateOI. (Inherited from TfrxBaseGauge.)
Top
Fields
Show:
Name | Description
FCC | Represents field FCC. (Inherited from TfrxBaseGauge.)
FCurrentValue | Represents field FCurrentValue.
FIsPrinting | Represents field FIsPrinting. (Inherited from TfrxBaseGauge.)
FLeftPressed | Represents field FLeftPressed. (Inherited from TfrxBaseGauge.)
FScale | Represents field FScale. (Inherited from TfrxBaseGauge.)
FScaleX | Represents field FScaleX. (Inherited from TfrxBaseGauge.)
FScaleY | Represents field FScaleY. (Inherited from TfrxBaseGauge.)
Top
See Also

Reference

  • frxGauge


TfrxGauge Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxGauge class.
Top


TfrxGauge.Create Constructor

Summary

Initializes a new instance of the TfrxGauge class.

Namespace: frxGauge
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxGauge
  • frxGauge


TfrxGauge Properties

Properties
Name | Description
CurrentValue | Represents property CurrentValue.
Maximum | Represents property Maximum.
Minimum | Represents property Minimum.
Top


TfrxGauge.CurrentValue Property

Summary

Represents property CurrentValue.

Namespace: frxGauge
Syntax
Delphi
published
 property CurrentValue: Extended read FCurrentValue write SetCurrentValue;

Property Value

Type: Extended

See Also

Reference

  • TfrxGauge
  • frxGauge


TfrxGauge.Maximum Property

Summary

Represents property Maximum.

Namespace: frxGauge
Syntax
Delphi
published
 property Maximum;

Property Value

Type: Void

See Also

Reference

  • TfrxGauge
  • frxGauge


TfrxGauge.Minimum Property

Summary

Represents property Minimum.

Namespace: frxGauge
Syntax
Delphi
published
 property Minimum;

Property Value

Type: Void

See Also

Reference

  • TfrxGauge
  • frxGauge


TfrxGauge Methods

Methods
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent). (Overrides TfrxBaseGauge.AssignTo(TPersistent).)
CorrectByMaximum | Represents method CorrectByMaximum. (Overrides TfrxBaseGauge.CorrectByMaximum.)
CorrectByMinimum | Represents method CorrectByMinimum. (Overrides TfrxBaseGauge.CorrectByMinimum.)
DoMouseWheel(TShiftState,Integer,TPoint) | Represents method DoMouseWheel(TShiftState,Integer,TPoint). (Overrides TfrxBaseGauge.DoMouseWheel(TShiftState,Integer,TPoint).)
DrawPointer(TCanvas) | Represents method DrawPointer(TCanvas). (Overrides TfrxBaseGauge.DrawPointer(TCanvas).)
OneDigit(Tpoint) | Represents method OneDigit(Tpoint). (Overrides TfrxBaseGauge.OneDigit(Tpoint).)
SetCurrentValue(Extended) | Represents method SetCurrentValue(Extended).
Top


TfrxGauge.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: frxGauge
Syntax
Delphi
public
 procedure AssignTo(Dest: TPersistent); override;

Parameters

Dest
Type: TPersistent

Overrides

TfrxBaseGauge.AssignTo(TPersistent)
See Also

Reference

  • TfrxGauge
  • frxGauge


TfrxGauge.CorrectByMaximum Method

Summary

Represents method CorrectByMaximum.

Namespace: frxGauge
Syntax
Delphi
protected
 procedure CorrectByMaximum; override;

Overrides

TfrxBaseGauge.CorrectByMaximum
See Also

Reference

  • TfrxGauge
  • frxGauge


TfrxGauge.CorrectByMinimum Method

Summary

Represents method CorrectByMinimum.

Namespace: frxGauge
Syntax
Delphi
protected
 procedure CorrectByMinimum; override;

Overrides

TfrxBaseGauge.CorrectByMinimum
See Also

Reference

  • TfrxGauge
  • frxGauge


TfrxGauge.DoMouseWheel(TShiftState,Integer,TPoint) Method

Summary

Represents method DoMouseWheel(TShiftState,Integer,TPoint).

Namespace: frxGauge
Syntax
Delphi
public
 function DoMouseWheel(Shift: TShiftState; WheelDelta: Integer;
 MousePos: TPoint): Boolean; override;

Parameters

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

Return Value

Type: Boolean

Overrides

TfrxBaseGauge.DoMouseWheel(TShiftState,Integer,TPoint)
See Also

Reference

  • TfrxGauge
  • frxGauge


TfrxGauge.DrawPointer(TCanvas) Method

Summary

Represents method DrawPointer(TCanvas).

Namespace: frxGauge
Syntax
Delphi
public
 procedure DrawPointer(Canvas: TCanvas); override;

Parameters

Canvas
Type: TCanvas

Overrides

TfrxBaseGauge.DrawPointer(TCanvas)
See Also

Reference

  • TfrxGauge
  • frxGauge


TfrxGauge.OneDigit(Tpoint) Method

Summary

Represents method OneDigit(Tpoint).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure OneDigit(P: Tpoint); override;

Parameters

P
Type: Tpoint

Overrides

TfrxBaseGauge.OneDigit(Tpoint)
See Also

Reference

  • TfrxGauge
  • frxGauge


TfrxGauge.SetCurrentValue(Extended) Method

Summary

Represents method SetCurrentValue(Extended).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetCurrentValue(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxGauge
  • frxGauge


TfrxGauge Fields

Fields
Name | Description
FCurrentValue | Represents field FCurrentValue.
Top


TfrxGauge.FCurrentValue Field

Summary

Represents field FCurrentValue.

Namespace: frxGauge
Syntax
Delphi
private
 FCurrentValue: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxGauge
  • frxGauge


TfrxIntervalGauge Class

Summary

Represents type TfrxIntervalGauge.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TfrxBaseGauge
frxGauge.TfrxIntervalGauge
Syntax
Delphi
type
 TfrxIntervalGauge = class(TfrxBaseGauge)
 end;

The TfrxIntervalGauge type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxIntervalGauge class.
Top
Properties
Show:
Name | Description
Angle | Represents property Angle. (Inherited from TfrxBaseGauge.)
EndValue | Represents property EndValue.
Kind | Represents property Kind. (Inherited from TfrxBaseGauge.)
MajorScale | Represents property MajorScale. (Inherited from TfrxBaseGauge.)
MajorStep | Represents property MajorStep. (Inherited from TfrxBaseGauge.)
Margin | Represents property Margin. (Inherited from TfrxBaseGauge.)
Maximum | Represents property Maximum.
Minimum | Represents property Minimum.
MinorScale | Represents property MinorScale. (Inherited from TfrxBaseGauge.)
MinorStep | Represents property MinorStep. (Inherited from TfrxBaseGauge.)
Pointer | Represents property Pointer. (Inherited from TfrxBaseGauge.)
PointerKind | Represents property PointerKind. (Inherited from TfrxBaseGauge.)
Scale | Represents property Scale. (Inherited from TfrxBaseGauge.)
ScaleX | Represents property ScaleX. (Inherited from TfrxBaseGauge.)
ScaleY | Represents property ScaleY. (Inherited from TfrxBaseGauge.)
StartValue | Represents property StartValue.
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent). (Overrides TfrxBaseGauge.AssignTo(TPersistent).)
CorrectByMaximum | Represents method CorrectByMaximum. (Overrides TfrxBaseGauge.CorrectByMaximum.)
CorrectByMinimum | Represents method CorrectByMinimum. (Overrides TfrxBaseGauge.CorrectByMinimum.)
CreatePointer(TGaugePointer,Boolean) | Represents method CreatePointer(TGaugePointer,Boolean). (Inherited from TfrxBaseGauge.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState). (Inherited from TfrxBaseGauge.)
DoMouseMove(Integer,Integer,TShiftState) | Represents method DoMouseMove(Integer,Integer,TShiftState). (Inherited from TfrxBaseGauge.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState). (Inherited from TfrxBaseGauge.)
DoMouseWheel(TShiftState,Integer,TPoint) | Represents method DoMouseWheel(TShiftState,Integer,TPoint). (Overrides TfrxBaseGauge.DoMouseWheel(TShiftState,Integer,TPoint).)
Draw(TCanvas,TRect) | Represents method Draw(TCanvas,TRect). (Inherited from TfrxBaseGauge.)
DrawPointer(TCanvas) | Represents method DrawPointer(TCanvas). (Overrides TfrxBaseGauge.DrawPointer(TCanvas).)
MultiDigits | Represents method MultiDigits. (Overrides TfrxBaseGauge.MultiDigits.)
OneDigit(Tpoint) | Represents method OneDigit(Tpoint). (Overrides TfrxBaseGauge.OneDigit(Tpoint).)
Radians | Represents method Radians. (Inherited from TfrxBaseGauge.)
Repaint | Represents method Repaint. (Inherited from TfrxBaseGauge.)
SetEndValue(Extended) | Represents method SetEndValue(Extended).
SetStartValue(Extended) | Represents method SetStartValue(Extended).
SetXYScales(Extended,Extended,Boolean) | Represents method SetXYScales(Extended,Extended,Boolean). (Inherited from TfrxBaseGauge.)
UpdateOI | Represents method UpdateOI. (Inherited from TfrxBaseGauge.)
Top
Events
Show:
Name | Description
OnRepaint | Represents property OnRepaint. (Inherited from TfrxBaseGauge.)
OnUpdateOI | Represents property OnUpdateOI. (Inherited from TfrxBaseGauge.)
Top
Fields
Show:
Name | Description
FCC | Represents field FCC. (Inherited from TfrxBaseGauge.)
FEndValue | Represents field FEndValue.
FIsPrinting | Represents field FIsPrinting. (Inherited from TfrxBaseGauge.)
FLeftPressed | Represents field FLeftPressed. (Inherited from TfrxBaseGauge.)
FScale | Represents field FScale. (Inherited from TfrxBaseGauge.)
FScaleX | Represents field FScaleX. (Inherited from TfrxBaseGauge.)
FScaleY | Represents field FScaleY. (Inherited from TfrxBaseGauge.)
FSelectedPointer | Represents field FSelectedPointer.
FStartValue | Represents field FStartValue.
Top
See Also

Reference

  • frxGauge


TfrxIntervalGauge Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxIntervalGauge class.
Top


TfrxIntervalGauge.Create Constructor

Summary

Initializes a new instance of the TfrxIntervalGauge class.

Namespace: frxGauge
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge Properties

Properties
Name | Description
EndValue | Represents property EndValue.
Maximum | Represents property Maximum.
Minimum | Represents property Minimum.
StartValue | Represents property StartValue.
Top


TfrxIntervalGauge.EndValue Property

Summary

Represents property EndValue.

Namespace: frxGauge
Syntax
Delphi
published
 property EndValue: Extended read FEndValue write SetEndValue;

Property Value

Type: Extended

See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.Maximum Property

Summary

Represents property Maximum.

Namespace: frxGauge
Syntax
Delphi
published
 property Maximum;

Property Value

Type: Void

See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.Minimum Property

Summary

Represents property Minimum.

Namespace: frxGauge
Syntax
Delphi
published
 property Minimum;

Property Value

Type: Void

See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.StartValue Property

Summary

Represents property StartValue.

Namespace: frxGauge
Syntax
Delphi
published
 property StartValue: Extended read FStartValue write SetStartValue;

Property Value

Type: Extended

See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge Methods

Methods
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent). (Overrides TfrxBaseGauge.AssignTo(TPersistent).)
CorrectByMaximum | Represents method CorrectByMaximum. (Overrides TfrxBaseGauge.CorrectByMaximum.)
CorrectByMinimum | Represents method CorrectByMinimum. (Overrides TfrxBaseGauge.CorrectByMinimum.)
DoMouseWheel(TShiftState,Integer,TPoint) | Represents method DoMouseWheel(TShiftState,Integer,TPoint). (Overrides TfrxBaseGauge.DoMouseWheel(TShiftState,Integer,TPoint).)
DrawPointer(TCanvas) | Represents method DrawPointer(TCanvas). (Overrides TfrxBaseGauge.DrawPointer(TCanvas).)
MultiDigits | Represents method MultiDigits. (Overrides TfrxBaseGauge.MultiDigits.)
OneDigit(Tpoint) | Represents method OneDigit(Tpoint). (Overrides TfrxBaseGauge.OneDigit(Tpoint).)
SetEndValue(Extended) | Represents method SetEndValue(Extended).
SetStartValue(Extended) | Represents method SetStartValue(Extended).
Top


TfrxIntervalGauge.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: frxGauge
Syntax
Delphi
public
 procedure AssignTo(Dest: TPersistent); override;

Parameters

Dest
Type: TPersistent

Overrides

TfrxBaseGauge.AssignTo(TPersistent)
See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.CorrectByMaximum Method

Summary

Represents method CorrectByMaximum.

Namespace: frxGauge
Syntax
Delphi
protected
 procedure CorrectByMaximum; override;

Overrides

TfrxBaseGauge.CorrectByMaximum
See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.CorrectByMinimum Method

Summary

Represents method CorrectByMinimum.

Namespace: frxGauge
Syntax
Delphi
protected
 procedure CorrectByMinimum; override;

Overrides

TfrxBaseGauge.CorrectByMinimum
See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.DoMouseWheel(TShiftState,Integer,TPoint) Method

Summary

Represents method DoMouseWheel(TShiftState,Integer,TPoint).

Namespace: frxGauge
Syntax
Delphi
public
 function DoMouseWheel(Shift: TShiftState; WheelDelta: Integer;
 MousePos: TPoint): Boolean; override;

Parameters

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

Return Value

Type: Boolean

Overrides

TfrxBaseGauge.DoMouseWheel(TShiftState,Integer,TPoint)
See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.DrawPointer(TCanvas) Method

Summary

Represents method DrawPointer(TCanvas).

Namespace: frxGauge
Syntax
Delphi
public
 procedure DrawPointer(Canvas: TCanvas); override;

Parameters

Canvas
Type: TCanvas

Overrides

TfrxBaseGauge.DrawPointer(TCanvas)
See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.MultiDigits Method

Summary

Represents method MultiDigits.

Namespace: frxGauge
Syntax
Delphi
protected
 procedure MultiDigits; override;

Overrides

TfrxBaseGauge.MultiDigits
See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.OneDigit(Tpoint) Method

Summary

Represents method OneDigit(Tpoint).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure OneDigit(P: Tpoint); override;

Parameters

P
Type: Tpoint

Overrides

TfrxBaseGauge.OneDigit(Tpoint)
See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.SetEndValue(Extended) Method

Summary

Represents method SetEndValue(Extended).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetEndValue(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.SetStartValue(Extended) Method

Summary

Represents method SetStartValue(Extended).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetStartValue(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge Fields

Fields
Name | Description
FEndValue | Represents field FEndValue.
FSelectedPointer | Represents field FSelectedPointer.
FStartValue | Represents field FStartValue.
Top


TfrxIntervalGauge.FEndValue Field

Summary

Represents field FEndValue.

Namespace: frxGauge
Syntax
Delphi
private
 FEndValue: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.FSelectedPointer Field

Summary

Represents field FSelectedPointer.

Namespace: frxGauge
Syntax
Delphi
protected
 FSelectedPointer: TSelectedPointer;

Field Value

Type: TSelectedPointer

See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TfrxIntervalGauge.FStartValue Field

Summary

Represents field FStartValue.

Namespace: frxGauge
Syntax
Delphi
private
 FStartValue: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxIntervalGauge
  • frxGauge


TGaugeCoordinateConverter Class

Summary

Represents type TGaugeCoordinateConverter.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TGaugeCoordinateConverter
Syntax
Delphi
type
 TGaugeCoordinateConverter = class(TPersistent)
 end;

The TGaugeCoordinateConverter type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugeCoordinateConverter class.
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Init(TRect,TFloatPoint) | Represents method Init(TRect,TFloatPoint).
OutsideInside(TFloatPoint,TFloatPoint,TFloatPoint,TFloatPoint) | Represents method OutsideInside(TFloatPoint,TFloatPoint,TFloatPoint,TFloatPoint).
Part(Extended,Extended,Extended) | Represents method Part(Extended,Extended,Extended).
ScreenRay(Extended) | Represents method ScreenRay(Extended).
Value(TPoint) | Represents method Value(TPoint).
Top
Fields
Show:
Name | Description
FAngle | Represents field FAngle.
FBaseGauge | Represents field FBaseGauge.
FCenter | Represents field FCenter.
FHeight | Represents field FHeight.
FIndent | Represents field FIndent.
FRadius | Represents field FRadius.
FRange | Represents field FRange.
FRect | Represents field FRect.
FWidth | Represents field FWidth.
Top
See Also

Reference

  • frxGauge


TGaugeCoordinateConverter Constructors

Constructors
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugeCoordinateConverter class.
Top


TGaugeCoordinateConverter.Create(TfrxBaseGauge) Constructor

Summary

Initializes a new instance of the TGaugeCoordinateConverter class.

Namespace: frxGauge
Syntax
Delphi
public
 constructor Create(ABaseGauge: TfrxBaseGauge);

Parameters

ABaseGauge
Type: TfrxBaseGauge

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter Methods

Methods
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Init(TRect,TFloatPoint) | Represents method Init(TRect,TFloatPoint).
OutsideInside(TFloatPoint,TFloatPoint,TFloatPoint,TFloatPoint) | Represents method OutsideInside(TFloatPoint,TFloatPoint,TFloatPoint,TFloatPoint).
Part(Extended,Extended,Extended) | Represents method Part(Extended,Extended,Extended).
ScreenRay(Extended) | Represents method ScreenRay(Extended).
Value(TPoint) | Represents method Value(TPoint).
Top


TGaugeCoordinateConverter.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: frxGauge
Syntax
Delphi
public
 procedure AssignTo(Dest: TPersistent); override;

Parameters

Dest
Type: TPersistent

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.Init(TRect,TFloatPoint) Method

Summary

Represents method Init(TRect,TFloatPoint).

Namespace: frxGauge
Syntax
Delphi
public
 procedure Init(Rect: TRect; Indent: TFloatPoint);

Parameters

Rect
Type: TRect

Indent
Type: TFloatPoint

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.OutsideInside(TFloatPoint,TFloatPoint,TFloatPoint,TFloatPoint) Method

Summary

Represents method OutsideInside(TFloatPoint,TFloatPoint,TFloatPoint,TFloatPoint).

Namespace: frxGauge
Syntax
Delphi
public
 procedure OutsideInside(fp1, fp2: TFloatPoint;
 out Outside, Inside: TFloatPoint);

Parameters

fp1
Type: TFloatPoint

fp2
Type: TFloatPoint

Outside
Type: TFloatPoint

Inside
Type: TFloatPoint

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.Part(Extended,Extended,Extended) Method

Summary

Represents method Part(Extended,Extended,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 function Part(Minimum, Value, Maximum: Extended): Extended;

Parameters

Minimum
Type: Extended

Value
Type: Extended

Maximum
Type: Extended

Return Value

Type: Extended

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.ScreenRay(Extended) Method

Summary

Represents method ScreenRay(Extended).

Namespace: frxGauge
Syntax
Delphi
public
 function ScreenRay(Value: Extended): TRay;

Parameters

Value
Type: Extended

Return Value

Type: TRay

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.Value(TPoint) Method

Summary

Represents method Value(TPoint).

Namespace: frxGauge
Syntax
Delphi
public
 function Value(Point: TPoint): Extended;

Parameters

Point
Type: TPoint

Return Value

Type: Extended

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter Fields

Fields
Name | Description
FAngle | Represents field FAngle.
FBaseGauge | Represents field FBaseGauge.
FCenter | Represents field FCenter.
FHeight | Represents field FHeight.
FIndent | Represents field FIndent.
FRadius | Represents field FRadius.
FRange | Represents field FRange.
FRect | Represents field FRect.
FWidth | Represents field FWidth.
Top


TGaugeCoordinateConverter.FAngle Field

Summary

Represents field FAngle.

Namespace: frxGauge
Syntax
Delphi
protected
 FAngle: Extended;

Field Value

Type: Extended

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.FBaseGauge Field

Summary

Represents field FBaseGauge.

Namespace: frxGauge
Syntax
Delphi
protected
 FBaseGauge: TfrxBaseGauge;

Field Value

Type: TfrxBaseGauge

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.FCenter Field

Summary

Represents field FCenter.

Namespace: frxGauge
Syntax
Delphi
protected
 FCenter: TFloatPoint;

Field Value

Type: TFloatPoint

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.FHeight Field

Summary

Represents field FHeight.

Namespace: frxGauge
Syntax
Delphi
protected
 FHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.FIndent Field

Summary

Represents field FIndent.

Namespace: frxGauge
Syntax
Delphi
protected
 FIndent: TFloatPoint;

Field Value

Type: TFloatPoint

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.FRadius Field

Summary

Represents field FRadius.

Namespace: frxGauge
Syntax
Delphi
protected
 FRadius: Extended;

Field Value

Type: Extended

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.FRange Field

Summary

Represents field FRange.

Namespace: frxGauge
Syntax
Delphi
protected
 FRange: Extended;

Field Value

Type: Extended

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.FRect Field

Summary

Represents field FRect.

Namespace: frxGauge
Syntax
Delphi
protected
 FRect: TRect;

Field Value

Type: TRect

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeCoordinateConverter.FWidth Field

Summary

Represents field FWidth.

Namespace: frxGauge
Syntax
Delphi
protected
 FWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGaugeCoordinateConverter
  • frxGauge


TGaugeMargin Class

Summary

Represents type TGaugeMargin.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TGaugeMargin
Syntax
Delphi
type
 TGaugeMargin = class(TPersistent)
 end;

The TGaugeMargin type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugeMargin class.
Top
Properties
Show:
Name | Description
Bottom | Represents property Bottom.
Left | Represents property Left.
Right | Represents property Right.
Top | Represents property Top.
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Init(Integer,Integer,Integer,Integer) | Represents method Init(Integer,Integer,Integer,Integer).
SetBottom(Integer) | Represents method SetBottom(Integer).
SetLeft(Integer) | Represents method SetLeft(Integer).
SetRight(Integer) | Represents method SetRight(Integer).
SetTop(Integer) | Represents method SetTop(Integer).
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge.
FBottom | Represents field FBottom.
FLeft | Represents field FLeft.
FRight | Represents field FRight.
FTop | Represents field FTop.
Top
See Also

Reference

  • frxGauge


TGaugeMargin Constructors

Constructors
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugeMargin class.
Top


TGaugeMargin.Create(TfrxBaseGauge) Constructor

Summary

Initializes a new instance of the TGaugeMargin class.

Namespace: frxGauge
Syntax
Delphi
public
 constructor Create(ABaseGauge: TfrxBaseGauge);

Parameters

ABaseGauge
Type: TfrxBaseGauge

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin Properties

Properties
Name | Description
Bottom | Represents property Bottom.
Left | Represents property Left.
Right | Represents property Right.
Top | Represents property Top.
Top


TGaugeMargin.Bottom Property

Summary

Represents property Bottom.

Namespace: frxGauge
Syntax
Delphi
published
 property Bottom: Integer read FBottom write SetBottom;

Property Value

Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin.Left Property

Summary

Represents property Left.

Namespace: frxGauge
Syntax
Delphi
published
 property Left: Integer read FLeft write SetLeft;

Property Value

Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin.Right Property

Summary

Represents property Right.

Namespace: frxGauge
Syntax
Delphi
published
 property Right: Integer read FRight write SetRight;

Property Value

Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin.Top Property

Summary

Represents property Top.

Namespace: frxGauge
Syntax
Delphi
published
 property Top: Integer read FTop write SetTop;

Property Value

Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin Methods

Methods
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Init(Integer,Integer,Integer,Integer) | Represents method Init(Integer,Integer,Integer,Integer).
SetBottom(Integer) | Represents method SetBottom(Integer).
SetLeft(Integer) | Represents method SetLeft(Integer).
SetRight(Integer) | Represents method SetRight(Integer).
SetTop(Integer) | Represents method SetTop(Integer).
Top


TGaugeMargin.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: frxGauge
Syntax
Delphi
public
 procedure AssignTo(Dest: TPersistent); override;

Parameters

Dest
Type: TPersistent

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin.Init(Integer,Integer,Integer,Integer) Method

Summary

Represents method Init(Integer,Integer,Integer,Integer).

Namespace: frxGauge
Syntax
Delphi
public
 procedure Init(ALeft, ATop, ARight, ABottom: Integer);

Parameters

ALeft
Type: Integer

ATop
Type: Integer

ARight
Type: Integer

ABottom
Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin.SetBottom(Integer) Method

Summary

Represents method SetBottom(Integer).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetBottom(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin.SetLeft(Integer) Method

Summary

Represents method SetLeft(Integer).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetLeft(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin.SetRight(Integer) Method

Summary

Represents method SetRight(Integer).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetRight(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin.SetTop(Integer) Method

Summary

Represents method SetTop(Integer).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetTop(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin Fields

Fields
Name | Description
FBaseGauge | Represents field FBaseGauge.
FBottom | Represents field FBottom.
FLeft | Represents field FLeft.
FRight | Represents field FRight.
FTop | Represents field FTop.
Top


TGaugeMargin.FBaseGauge Field

Summary

Represents field FBaseGauge.

Namespace: frxGauge
Syntax
Delphi
protected
 FBaseGauge: TfrxBaseGauge;

Field Value

Type: TfrxBaseGauge

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin.FBottom Field

Summary

Represents field FBottom.

Namespace: frxGauge
Syntax
Delphi
private
 FBottom: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin.FLeft Field

Summary

Represents field FLeft.

Namespace: frxGauge
Syntax
Delphi
private
 FLeft: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin.FRight Field

Summary

Represents field FRight.

Namespace: frxGauge
Syntax
Delphi
private
 FRight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugeMargin.FTop Field

Summary

Represents field FTop.

Namespace: frxGauge
Syntax
Delphi
private
 FTop: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGaugeMargin
  • frxGauge


TGaugePointer Class

Summary

Represents type TGaugePointer.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TGaugePointer
frxGauge.TBandPointer
frxGauge.TBasePolygonPointer
frxGauge.TSegmentPointer
Syntax
Delphi
type
 TGaugePointer = class(TPersistent)
 end;

The TGaugePointer type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugePointer class.
Top
Properties
Show:
Name | Description
BorderColor | Represents property BorderColor.
BorderWidth | Represents property BorderWidth.
Color | Represents property Color.
Height | Represents property Height.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
fp(Extended,Extended) | Represents method fp(Extended,Extended).
IsPublishedColor | Represents method IsPublishedColor.
IsPublishedHeight | Represents method IsPublishedHeight.
IsPublishedWidth | Represents method IsPublishedWidth.
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended).
PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]) | Represents method PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]).
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended).
SetBorderColor(TColor) | Represents method SetBorderColor(TColor).
SetBorderWidth(Integer) | Represents method SetBorderWidth(Integer).
SetColor(TColor) | Represents method SetColor(TColor).
SetHeight(Integer) | Represents method SetHeight(Integer).
SetupCanvas(TCanvas) | Represents method SetupCanvas(TCanvas).
SetWidth(Integer) | Represents method SetWidth(Integer).
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge.
FBorderColor | Represents field FBorderColor.
FBorderWidth | Represents field FBorderWidth.
FColor | Represents field FColor.
FHeight | Represents field FHeight.
FWidth | Represents field FWidth.
Top
See Also

Reference

  • frxGauge


TGaugePointer Constructors

Constructors
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugePointer class.
Top


TGaugePointer.Create(TfrxBaseGauge) Constructor

Summary

Initializes a new instance of the TGaugePointer class.

Namespace: frxGauge
Syntax
Delphi
public
 constructor Create(ABaseGauge: TfrxBaseGauge);

Parameters

ABaseGauge
Type: TfrxBaseGauge

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer Properties

Properties
Name | Description
BorderColor | Represents property BorderColor.
BorderWidth | Represents property BorderWidth.
Color | Represents property Color.
Height | Represents property Height.
Width | Represents property Width.
Top


TGaugePointer.BorderColor Property

Summary

Represents property BorderColor.

Namespace: frxGauge
Syntax
Delphi
published
 property BorderColor: TColor read FBorderColor write SetBorderColor;

Property Value

Type: TColor

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.BorderWidth Property

Summary

Represents property BorderWidth.

Namespace: frxGauge
Syntax
Delphi
published
 property BorderWidth: Integer read FBorderWidth write SetBorderWidth;

Property Value

Type: Integer

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.Color Property

Summary

Represents property Color.

Namespace: frxGauge
Syntax
Delphi
public
 property Color: TColor read FColor write SetColor;

Property Value

Type: TColor

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.Height Property

Summary

Represents property Height.

Namespace: frxGauge
Syntax
Delphi
public
 property Height: Integer read FHeight write SetHeight;

Property Value

Type: Integer

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.Width Property

Summary

Represents property Width.

Namespace: frxGauge
Syntax
Delphi
public
 property Width: Integer read FWidth write SetWidth;

Property Value

Type: Integer

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer Methods

Methods
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
fp(Extended,Extended) | Represents method fp(Extended,Extended).
IsPublishedColor | Represents method IsPublishedColor.
IsPublishedHeight | Represents method IsPublishedHeight.
IsPublishedWidth | Represents method IsPublishedWidth.
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended).
PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]) | Represents method PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]).
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended).
SetBorderColor(TColor) | Represents method SetBorderColor(TColor).
SetBorderWidth(Integer) | Represents method SetBorderWidth(Integer).
SetColor(TColor) | Represents method SetColor(TColor).
SetHeight(Integer) | Represents method SetHeight(Integer).
SetupCanvas(TCanvas) | Represents method SetupCanvas(TCanvas).
SetWidth(Integer) | Represents method SetWidth(Integer).
Top


TGaugePointer.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: frxGauge
Syntax
Delphi
public
 procedure AssignTo(Dest: TPersistent); override;

Parameters

Dest
Type: TPersistent

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.fp(Extended,Extended) Method

Summary

Represents method fp(Extended,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 function fp(x, y: Extended): TFloatPoint;

Parameters

x
Type: Extended

y
Type: Extended

Return Value

Type: TFloatPoint

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.IsPublishedColor Method

Summary

Represents method IsPublishedColor.

Namespace: frxGauge
Syntax
Delphi
public
 function IsPublishedColor: boolean; virtual;

Return Value

Type: boolean

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.IsPublishedHeight Method

Summary

Represents method IsPublishedHeight.

Namespace: frxGauge
Syntax
Delphi
public
 function IsPublishedHeight: boolean; virtual;

Return Value

Type: boolean

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.IsPublishedWidth Method

Summary

Represents method IsPublishedWidth.

Namespace: frxGauge
Syntax
Delphi
public
 function IsPublishedWidth: boolean; virtual;

Return Value

Type: boolean

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.Paint(TCanvas,Extended) Method

Summary

Represents method Paint(TCanvas,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure Paint(Canvas: TCanvas; Value: Extended); virtual; abstract;

Parameters

Canvas
Type: TCanvas

Value
Type: Extended

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]) Method

Summary

Represents method PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure PaintFloatPolygon(Canvas: TCanvas; Value: Extended;
 const FPs: array of TFloatPoint);

Parameters

Canvas
Type: TCanvas

Value
Type: Extended

FPs
Type: array of TFloatPoint

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.PaintPair(TCanvas,Extended,Extended) Method

Summary

Represents method PaintPair(TCanvas,Extended,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure PaintPair(Canvas: TCanvas; StartValue, EndValue: Extended);
 virtual; abstract;

Parameters

Canvas
Type: TCanvas

StartValue
Type: Extended

EndValue
Type: Extended

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.SetBorderColor(TColor) Method

Summary

Represents method SetBorderColor(TColor).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetBorderColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.SetBorderWidth(Integer) Method

Summary

Represents method SetBorderWidth(Integer).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetBorderWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.SetHeight(Integer) Method

Summary

Represents method SetHeight(Integer).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetHeight(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.SetupCanvas(TCanvas) Method

Summary

Represents method SetupCanvas(TCanvas).

Namespace: frxGauge
Syntax
Delphi
public
 procedure SetupCanvas(Canvas: TCanvas);

Parameters

Canvas
Type: TCanvas

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.SetWidth(Integer) Method

Summary

Represents method SetWidth(Integer).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer Fields

Fields
Name | Description
FBaseGauge | Represents field FBaseGauge.
FBorderColor | Represents field FBorderColor.
FBorderWidth | Represents field FBorderWidth.
FColor | Represents field FColor.
FHeight | Represents field FHeight.
FWidth | Represents field FWidth.
Top


TGaugePointer.FBaseGauge Field

Summary

Represents field FBaseGauge.

Namespace: frxGauge
Syntax
Delphi
protected
 FBaseGauge: TfrxBaseGauge;

Field Value

Type: TfrxBaseGauge

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.FBorderColor Field

Summary

Represents field FBorderColor.

Namespace: frxGauge
Syntax
Delphi
private
 FBorderColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.FBorderWidth Field

Summary

Represents field FBorderWidth.

Namespace: frxGauge
Syntax
Delphi
private
 FBorderWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.FColor Field

Summary

Represents field FColor.

Namespace: frxGauge
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.FHeight Field

Summary

Represents field FHeight.

Namespace: frxGauge
Syntax
Delphi
private
 FHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugePointer.FWidth Field

Summary

Represents field FWidth.

Namespace: frxGauge
Syntax
Delphi
private
 FWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGaugePointer
  • frxGauge


TGaugeScale Class

Summary

Represents type TGaugeScale.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TGaugeScale
Syntax
Delphi
type
 TGaugeScale = class(TPersistent)
 end;

The TGaugeScale type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugeScale class.
Destroy | Represents the destructor of the TGaugeScale class.
Top
Properties
Show:
Name | Description
Bilateral | Represents property Bilateral.
Font | Represents property Font.
Ticks | Represents property Ticks.
ValueFormat | Represents property ValueFormat.
Visible | Represents property Visible.
VisibleDigits | Represents property VisibleDigits.
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Correction | Represents method Correction.
Draw(TCanvas,Extended) | Represents method Draw(TCanvas,Extended).
DrawDigits(TCanvas,TRay,Extended) | Represents method DrawDigits(TCanvas,TRay,Extended).
FontChanged(TObject) | Represents method FontChanged(TObject).
Indent | Represents method Indent.
MultiDigits | Represents method MultiDigits.
OneDigitAt(Extended) | Represents method OneDigitAt(Extended).
SetBilateral(Boolean) | Represents method SetBilateral(Boolean).
SetFont(TFont) | Represents method SetFont(TFont).
SetTicks(TGaugeScaleTicks) | Represents method SetTicks(TGaugeScaleTicks).
SetupCanvas(TCanvas) | Represents method SetupCanvas(TCanvas).
SetValueFormat(String) | Represents method SetValueFormat(String).
SetVisible(Boolean) | Represents method SetVisible(Boolean).
SetVisibleDigits(Boolean) | Represents method SetVisibleDigits(Boolean).
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge.
FBilateral | Represents field FBilateral.
FFont | Represents field FFont.
FOneDigit | Represents field FOneDigit.
FOneValue | Represents field FOneValue.
FTextSize | Represents field FTextSize.
FTicks | Represents field FTicks.
FValueFormat | Represents field FValueFormat.
FVisible | Represents field FVisible.
FVisibleDigits | Represents field FVisibleDigits.
Top
See Also

Reference

  • frxGauge


TGaugeScale Constructors

Constructors
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugeScale class.
Destroy | Represents the destructor of the TGaugeScale class.
Top


TGaugeScale.Create(TfrxBaseGauge) Constructor

Summary

Initializes a new instance of the TGaugeScale class.

Namespace: frxGauge
Syntax
Delphi
public
 constructor Create(ABaseGauge: TfrxBaseGauge);

Parameters

ABaseGauge
Type: TfrxBaseGauge

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.Destroy Destructor

Summary

Represents the destructor of the TGaugeScale class.

Namespace: frxGauge
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale Properties

Properties
Name | Description
Bilateral | Represents property Bilateral.
Font | Represents property Font.
Ticks | Represents property Ticks.
ValueFormat | Represents property ValueFormat.
Visible | Represents property Visible.
VisibleDigits | Represents property VisibleDigits.
Top


TGaugeScale.Bilateral Property

Summary

Represents property Bilateral.

Namespace: frxGauge
Syntax
Delphi
published
 property Bilateral: Boolean read FBilateral write SetBilateral;

Property Value

Type: Boolean

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.Font Property

Summary

Represents property Font.

Namespace: frxGauge
Syntax
Delphi
published
 property Font: TFont read FFont write SetFont;

Property Value

Type: TFont

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.Ticks Property

Summary

Represents property Ticks.

Namespace: frxGauge
Syntax
Delphi
published
 property Ticks: TGaugeScaleTicks read FTicks write SetTicks;

Property Value

Type: TGaugeScaleTicks

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.ValueFormat Property

Summary

Represents property ValueFormat.

Namespace: frxGauge
Syntax
Delphi
published
 property ValueFormat: String read FValueFormat write SetValueFormat;

Property Value

Type: String

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.Visible Property

Summary

Represents property Visible.

Namespace: frxGauge
Syntax
Delphi
published
 property Visible: Boolean read FVisible write SetVisible;

Property Value

Type: Boolean

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.VisibleDigits Property

Summary

Represents property VisibleDigits.

Namespace: frxGauge
Syntax
Delphi
published
 property VisibleDigits: Boolean read FVisibleDigits write SetVisibleDigits;

Property Value

Type: Boolean

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale Methods

Methods
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Correction | Represents method Correction.
Draw(TCanvas,Extended) | Represents method Draw(TCanvas,Extended).
DrawDigits(TCanvas,TRay,Extended) | Represents method DrawDigits(TCanvas,TRay,Extended).
FontChanged(TObject) | Represents method FontChanged(TObject).
Indent | Represents method Indent.
MultiDigits | Represents method MultiDigits.
OneDigitAt(Extended) | Represents method OneDigitAt(Extended).
SetBilateral(Boolean) | Represents method SetBilateral(Boolean).
SetFont(TFont) | Represents method SetFont(TFont).
SetTicks(TGaugeScaleTicks) | Represents method SetTicks(TGaugeScaleTicks).
SetupCanvas(TCanvas) | Represents method SetupCanvas(TCanvas).
SetValueFormat(String) | Represents method SetValueFormat(String).
SetVisible(Boolean) | Represents method SetVisible(Boolean).
SetVisibleDigits(Boolean) | Represents method SetVisibleDigits(Boolean).
Top


TGaugeScale.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: frxGauge
Syntax
Delphi
public
 procedure AssignTo(Dest: TPersistent); override;

Parameters

Dest
Type: TPersistent

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.Correction Method

Summary

Represents method Correction.

Namespace: frxGauge
Syntax
Delphi
protected
 function Correction: Integer;

Return Value

Type: Integer

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.Draw(TCanvas,Extended) Method

Summary

Represents method Draw(TCanvas,Extended).

Namespace: frxGauge
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ValueStep: Extended);

Parameters

Canvas
Type: TCanvas

ValueStep
Type: Extended

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.DrawDigits(TCanvas,TRay,Extended) Method

Summary

Represents method DrawDigits(TCanvas,TRay,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure DrawDigits(Canvas: TCanvas; Ray: TRay; Value: Extended);

Parameters

Canvas
Type: TCanvas

Ray
Type: TRay

Value
Type: Extended

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.FontChanged(TObject) Method

Summary

Represents method FontChanged(TObject).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure FontChanged(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.Indent Method

Summary

Represents method Indent.

Namespace: frxGauge
Syntax
Delphi
public
 function Indent: TFloatPoint;

Return Value

Type: TFloatPoint

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.MultiDigits Method

Summary

Represents method MultiDigits.

Namespace: frxGauge
Syntax
Delphi
public
 procedure MultiDigits;
See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.OneDigitAt(Extended) Method

Summary

Represents method OneDigitAt(Extended).

Namespace: frxGauge
Syntax
Delphi
public
 procedure OneDigitAt(Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.SetBilateral(Boolean) Method

Summary

Represents method SetBilateral(Boolean).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetBilateral(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.SetFont(TFont) Method

Summary

Represents method SetFont(TFont).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetFont(const Value: TFont);

Parameters

Value
Type: TFont

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.SetTicks(TGaugeScaleTicks) Method

Summary

Represents method SetTicks(TGaugeScaleTicks).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetTicks(const Value: TGaugeScaleTicks);

Parameters

Value
Type: TGaugeScaleTicks

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.SetupCanvas(TCanvas) Method

Summary

Represents method SetupCanvas(TCanvas).

Namespace: frxGauge
Syntax
Delphi
public
 procedure SetupCanvas(Canvas: TCanvas);

Parameters

Canvas
Type: TCanvas

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.SetValueFormat(String) Method

Summary

Represents method SetValueFormat(String).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetValueFormat(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.SetVisible(Boolean) Method

Summary

Represents method SetVisible(Boolean).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetVisible(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.SetVisibleDigits(Boolean) Method

Summary

Represents method SetVisibleDigits(Boolean).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetVisibleDigits(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale Fields

Fields
Name | Description
FBaseGauge | Represents field FBaseGauge.
FBilateral | Represents field FBilateral.
FFont | Represents field FFont.
FOneDigit | Represents field FOneDigit.
FOneValue | Represents field FOneValue.
FTextSize | Represents field FTextSize.
FTicks | Represents field FTicks.
FValueFormat | Represents field FValueFormat.
FVisible | Represents field FVisible.
FVisibleDigits | Represents field FVisibleDigits.
Top


TGaugeScale.FBaseGauge Field

Summary

Represents field FBaseGauge.

Namespace: frxGauge
Syntax
Delphi
protected
 FBaseGauge: TfrxBaseGauge;

Field Value

Type: TfrxBaseGauge

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.FBilateral Field

Summary

Represents field FBilateral.

Namespace: frxGauge
Syntax
Delphi
private
 FBilateral: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.FFont Field

Summary

Represents field FFont.

Namespace: frxGauge
Syntax
Delphi
private
 FFont: TFont;

Field Value

Type: TFont

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.FOneDigit Field

Summary

Represents field FOneDigit.

Namespace: frxGauge
Syntax
Delphi
protected
 FOneDigit: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.FOneValue Field

Summary

Represents field FOneValue.

Namespace: frxGauge
Syntax
Delphi
protected
 FOneValue: Extended;

Field Value

Type: Extended

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.FTextSize Field

Summary

Represents field FTextSize.

Namespace: frxGauge
Syntax
Delphi
protected
 FTextSize: TSize;

Field Value

Type: TSize

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.FTicks Field

Summary

Represents field FTicks.

Namespace: frxGauge
Syntax
Delphi
private
 FTicks: TGaugeScaleTicks;

Field Value

Type: TGaugeScaleTicks

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.FValueFormat Field

Summary

Represents field FValueFormat.

Namespace: frxGauge
Syntax
Delphi
private
 FValueFormat: String;

Field Value

Type: String

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.FVisible Field

Summary

Represents field FVisible.

Namespace: frxGauge
Syntax
Delphi
private
 FVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScale.FVisibleDigits Field

Summary

Represents field FVisibleDigits.

Namespace: frxGauge
Syntax
Delphi
private
 FVisibleDigits: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGaugeScale
  • frxGauge


TGaugeScaleTicks Class

Summary

Represents type TGaugeScaleTicks.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TGaugeScaleTicks
Syntax
Delphi
type
 TGaugeScaleTicks = class(TPersistent)
 end;

The TGaugeScaleTicks type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugeScaleTicks class.
Top
Properties
Show:
Name | Description
Color | Represents property Color.
Length | Represents property Length.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Draw(TCanvas,TRay) | Represents method Draw(TCanvas,TRay).
SetColor(TColor) | Represents method SetColor(TColor).
SetLength(Integer) | Represents method SetLength(Integer).
SetWidth(Integer) | Represents method SetWidth(Integer).
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge.
FColor | Represents field FColor.
FLength | Represents field FLength.
FWidth | Represents field FWidth.
Top
See Also

Reference

  • frxGauge


TGaugeScaleTicks Constructors

Constructors
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugeScaleTicks class.
Top


TGaugeScaleTicks.Create(TfrxBaseGauge) Constructor

Summary

Initializes a new instance of the TGaugeScaleTicks class.

Namespace: frxGauge
Syntax
Delphi
public
 constructor Create(ABaseGauge: TfrxBaseGauge);

Parameters

ABaseGauge
Type: TfrxBaseGauge

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TGaugeScaleTicks Properties

Properties
Name | Description
Color | Represents property Color.
Length | Represents property Length.
Width | Represents property Width.
Top


TGaugeScaleTicks.Color Property

Summary

Represents property Color.

Namespace: frxGauge
Syntax
Delphi
published
 property Color: TColor read FColor write SetColor;

Property Value

Type: TColor

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TGaugeScaleTicks.Length Property

Summary

Represents property Length.

Namespace: frxGauge
Syntax
Delphi
published
 property Length: Integer read FLength write SetLength;

Property Value

Type: Integer

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TGaugeScaleTicks.Width Property

Summary

Represents property Width.

Namespace: frxGauge
Syntax
Delphi
published
 property Width: Integer read FWidth write SetWidth;

Property Value

Type: Integer

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TGaugeScaleTicks Methods

Methods
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Draw(TCanvas,TRay) | Represents method Draw(TCanvas,TRay).
SetColor(TColor) | Represents method SetColor(TColor).
SetLength(Integer) | Represents method SetLength(Integer).
SetWidth(Integer) | Represents method SetWidth(Integer).
Top


TGaugeScaleTicks.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: frxGauge
Syntax
Delphi
public
 procedure AssignTo(Dest: TPersistent); override;

Parameters

Dest
Type: TPersistent

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TGaugeScaleTicks.Draw(TCanvas,TRay) Method

Summary

Represents method Draw(TCanvas,TRay).

Namespace: frxGauge
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; Ray: TRay);

Parameters

Canvas
Type: TCanvas

Ray
Type: TRay

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TGaugeScaleTicks.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TGaugeScaleTicks.SetLength(Integer) Method

Summary

Represents method SetLength(Integer).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetLength(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TGaugeScaleTicks.SetWidth(Integer) Method

Summary

Represents method SetWidth(Integer).

Namespace: frxGauge
Syntax
Delphi
private
 procedure SetWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TGaugeScaleTicks Fields

Fields
Name | Description
FBaseGauge | Represents field FBaseGauge.
FColor | Represents field FColor.
FLength | Represents field FLength.
FWidth | Represents field FWidth.
Top


TGaugeScaleTicks.FBaseGauge Field

Summary

Represents field FBaseGauge.

Namespace: frxGauge
Syntax
Delphi
protected
 FBaseGauge: TfrxBaseGauge;

Field Value

Type: TfrxBaseGauge

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TGaugeScaleTicks.FColor Field

Summary

Represents field FColor.

Namespace: frxGauge
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TGaugeScaleTicks.FLength Field

Summary

Represents field FLength.

Namespace: frxGauge
Syntax
Delphi
private
 FLength: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TGaugeScaleTicks.FWidth Field

Summary

Represents field FWidth.

Namespace: frxGauge
Syntax
Delphi
private
 FWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TGaugeScaleTicks
  • frxGauge


TPentagonPointer Class

Summary

Represents type TPentagonPointer.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TGaugePointer
frxGauge.TBasePolygonPointer
frxGauge.TPentagonPointer
Syntax
Delphi
type
 TPentagonPointer = class(TBasePolygonPointer)
 end;

The TPentagonPointer type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugePointer class. (Inherited from TGaugePointer.)
Top
Properties
Show:
Name | Description
BorderColor | Represents property BorderColor. (Inherited from TGaugePointer.)
BorderWidth | Represents property BorderWidth. (Inherited from TGaugePointer.)
Color | Represents property Color. (Inherited from TBasePolygonPointer.)
Height | Represents property Height. (Inherited from TBasePolygonPointer.)
Width | Represents property Width. (Inherited from TBasePolygonPointer.)
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent). (Inherited from TGaugePointer.)
fp(Extended,Extended) | Represents method fp(Extended,Extended). (Inherited from TGaugePointer.)
IsPublishedColor | Represents method IsPublishedColor. (Overrides TGaugePointer.IsPublishedColor.)
IsPublishedHeight | Represents method IsPublishedHeight. (Overrides TGaugePointer.IsPublishedHeight.)
IsPublishedWidth | Represents method IsPublishedWidth. (Overrides TGaugePointer.IsPublishedWidth.)
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended). (Overrides TGaugePointer.Paint(TCanvas,Extended).)
PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]) | Represents method PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]). (Inherited from TGaugePointer.)
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended). (Overrides TGaugePointer.PaintPair(TCanvas,Extended,Extended).)
SetupCanvas(TCanvas) | Represents method SetupCanvas(TCanvas). (Inherited from TGaugePointer.)
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge. (Inherited from TGaugePointer.)
Top
See Also

Reference

  • frxGauge


TPentagonPointer Methods

Methods
Name | Description
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended). (Overrides TGaugePointer.Paint(TCanvas,Extended).)
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended). (Overrides TGaugePointer.PaintPair(TCanvas,Extended,Extended).)
Top


TPentagonPointer.Paint(TCanvas,Extended) Method

Summary

Represents method Paint(TCanvas,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure Paint(Canvas: TCanvas; Value: Extended); override;

Parameters

Canvas
Type: TCanvas

Value
Type: Extended

Overrides

TGaugePointer.Paint(TCanvas,Extended)
See Also

Reference

  • TPentagonPointer
  • frxGauge


TPentagonPointer.PaintPair(TCanvas,Extended,Extended) Method

Summary

Represents method PaintPair(TCanvas,Extended,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure PaintPair(Canvas: TCanvas; StartValue, EndValue: Extended); override;

Parameters

Canvas
Type: TCanvas

StartValue
Type: Extended

EndValue
Type: Extended

Overrides

TGaugePointer.PaintPair(TCanvas,Extended,Extended)
See Also

Reference

  • TPentagonPointer
  • frxGauge


TSegmentPointer Class

Summary

Represents type TSegmentPointer.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TGaugePointer
frxGauge.TSegmentPointer
Syntax
Delphi
type
 TSegmentPointer = class(TGaugePointer)
 end;

The TSegmentPointer type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugePointer class. (Inherited from TGaugePointer.)
Top
Properties
Show:
Name | Description
BorderColor | Represents property BorderColor. (Inherited from TGaugePointer.)
BorderWidth | Represents property BorderWidth. (Inherited from TGaugePointer.)
Color | Represents property Color. (Inherited from TGaugePointer.)
Height | Represents property Height.
Width | Represents property Width. (Inherited from TGaugePointer.)
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent). (Inherited from TGaugePointer.)
fp(Extended,Extended) | Represents method fp(Extended,Extended). (Inherited from TGaugePointer.)
IsPublishedColor | Represents method IsPublishedColor. (Inherited from TGaugePointer.)
IsPublishedHeight | Represents method IsPublishedHeight. (Overrides TGaugePointer.IsPublishedHeight.)
IsPublishedWidth | Represents method IsPublishedWidth. (Inherited from TGaugePointer.)
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended). (Overrides TGaugePointer.Paint(TCanvas,Extended).)
PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]) | Represents method PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]). (Inherited from TGaugePointer.)
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended). (Overrides TGaugePointer.PaintPair(TCanvas,Extended,Extended).)
SetupCanvas(TCanvas) | Represents method SetupCanvas(TCanvas). (Inherited from TGaugePointer.)
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge. (Inherited from TGaugePointer.)
Top
See Also

Reference

  • frxGauge


TSegmentPointer Properties

Properties
Name | Description
Height | Represents property Height.
Top


TSegmentPointer.Height Property

Summary

Represents property Height.

Namespace: frxGauge
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TSegmentPointer
  • frxGauge


TSegmentPointer Methods

Methods
Name | Description
IsPublishedHeight | Represents method IsPublishedHeight. (Overrides TGaugePointer.IsPublishedHeight.)
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended). (Overrides TGaugePointer.Paint(TCanvas,Extended).)
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended). (Overrides TGaugePointer.PaintPair(TCanvas,Extended,Extended).)
Top


TSegmentPointer.IsPublishedHeight Method

Summary

Represents method IsPublishedHeight.

Namespace: frxGauge
Syntax
Delphi
public
 function IsPublishedHeight: boolean; override;

Return Value

Type: boolean

Overrides

TGaugePointer.IsPublishedHeight
See Also

Reference

  • TSegmentPointer
  • frxGauge


TSegmentPointer.Paint(TCanvas,Extended) Method

Summary

Represents method Paint(TCanvas,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure Paint(Canvas: TCanvas; Value: Extended); override;

Parameters

Canvas
Type: TCanvas

Value
Type: Extended

Overrides

TGaugePointer.Paint(TCanvas,Extended)
See Also

Reference

  • TSegmentPointer
  • frxGauge


TSegmentPointer.PaintPair(TCanvas,Extended,Extended) Method

Summary

Represents method PaintPair(TCanvas,Extended,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure PaintPair(Canvas: TCanvas; StartValue, EndValue: Extended); override;

Parameters

Canvas
Type: TCanvas

StartValue
Type: Extended

EndValue
Type: Extended

Overrides

TGaugePointer.PaintPair(TCanvas,Extended,Extended)
See Also

Reference

  • TSegmentPointer
  • frxGauge


TTrianglePointer Class

Summary

Represents type TTrianglePointer.

Namespace: frxGauge
Inheritance Hierarchy
TPersistent
frxGauge.TGaugePointer
frxGauge.TBasePolygonPointer
frxGauge.TTrianglePointer
Syntax
Delphi
type
 TTrianglePointer = class(TBasePolygonPointer)
 end;

The TTrianglePointer type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxBaseGauge) | Initializes a new instance of the TGaugePointer class. (Inherited from TGaugePointer.)
Top
Properties
Show:
Name | Description
BorderColor | Represents property BorderColor. (Inherited from TGaugePointer.)
BorderWidth | Represents property BorderWidth. (Inherited from TGaugePointer.)
Color | Represents property Color. (Inherited from TBasePolygonPointer.)
Height | Represents property Height. (Inherited from TBasePolygonPointer.)
Width | Represents property Width. (Inherited from TBasePolygonPointer.)
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent). (Inherited from TGaugePointer.)
fp(Extended,Extended) | Represents method fp(Extended,Extended). (Inherited from TGaugePointer.)
IsPublishedColor | Represents method IsPublishedColor. (Overrides TGaugePointer.IsPublishedColor.)
IsPublishedHeight | Represents method IsPublishedHeight. (Overrides TGaugePointer.IsPublishedHeight.)
IsPublishedWidth | Represents method IsPublishedWidth. (Overrides TGaugePointer.IsPublishedWidth.)
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended). (Overrides TGaugePointer.Paint(TCanvas,Extended).)
PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]) | Represents method PaintFloatPolygon(TCanvas,Extended,TFloatPoint[]). (Inherited from TGaugePointer.)
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended). (Overrides TGaugePointer.PaintPair(TCanvas,Extended,Extended).)
SetupCanvas(TCanvas) | Represents method SetupCanvas(TCanvas). (Inherited from TGaugePointer.)
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge. (Inherited from TGaugePointer.)
Top
See Also

Reference

  • frxGauge


TTrianglePointer Methods

Methods
Name | Description
Paint(TCanvas,Extended) | Represents method Paint(TCanvas,Extended). (Overrides TGaugePointer.Paint(TCanvas,Extended).)
PaintPair(TCanvas,Extended,Extended) | Represents method PaintPair(TCanvas,Extended,Extended). (Overrides TGaugePointer.PaintPair(TCanvas,Extended,Extended).)
Top


TTrianglePointer.Paint(TCanvas,Extended) Method

Summary

Represents method Paint(TCanvas,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure Paint(Canvas: TCanvas; Value: Extended); override;

Parameters

Canvas
Type: TCanvas

Value
Type: Extended

Overrides

TGaugePointer.Paint(TCanvas,Extended)
See Also

Reference

  • TTrianglePointer
  • frxGauge


TTrianglePointer.PaintPair(TCanvas,Extended,Extended) Method

Summary

Represents method PaintPair(TCanvas,Extended,Extended).

Namespace: frxGauge
Syntax
Delphi
protected
 procedure PaintPair(Canvas: TCanvas; StartValue, EndValue: Extended); override;

Parameters

Canvas
Type: TCanvas

StartValue
Type: Extended

EndValue
Type: Extended

Overrides

TGaugePointer.PaintPair(TCanvas,Extended,Extended)
See Also

Reference

  • TTrianglePointer
  • frxGauge


frxGauge Records

Records
Name | Description
TFloatPoint | Represents type TFloatPoint.
TRay | Represents type TRay.
Top


TFloatPoint Record

Summary

Represents type TFloatPoint.

Namespace: frxGauge
Syntax
Delphi
type
 TFloatPoint = record
 end;

The TFloatPoint type exposes the following members.

Fields
Show:
Name | Description
X | Represents field X.
Y | Represents field Y.
Top
See Also

Reference

  • frxGauge


TFloatPoint Fields

Fields
Name | Description
X | Represents field X.
Y | Represents field Y.
Top


TFloatPoint.X Field

Summary

Represents field X.

Namespace: frxGauge
Syntax
Delphi
public
 X, Y: Extended;

Field Value

Type: Extended

See Also

Reference

  • TFloatPoint
  • frxGauge


TFloatPoint.Y Field

Summary

Represents field Y.

Namespace: frxGauge
Syntax
Delphi
public
 X, Y: Extended;

Field Value

Type: Extended

See Also

Reference

  • TFloatPoint
  • frxGauge


TRay Record

Summary

Represents type TRay.

Namespace: frxGauge
Syntax
Delphi
type
 TRay = record
 end;

The TRay type exposes the following members.

Fields
Show:
Name | Description
Angle | Represents field Angle.
FP | Represents field FP.
Tangent | Represents field Tangent.
Top
See Also

Reference

  • frxGauge


TRay Fields

Fields
Name | Description
Angle | Represents field Angle.
FP | Represents field FP.
Tangent | Represents field Tangent.
Top


TRay.Angle Field

Summary

Represents field Angle.

Namespace: frxGauge
Syntax
Delphi
public
 Angle, Tangent: Extended;

Field Value

Type: Extended

See Also

Reference

  • TRay
  • frxGauge


TRay.FP Field

Summary

Represents field FP.

Namespace: frxGauge
Syntax
Delphi
public
 FP: TFloatPoint;

Field Value

Type: TFloatPoint

See Also

Reference

  • TRay
  • frxGauge


TRay.Tangent Field

Summary

Represents field Tangent.

Namespace: frxGauge
Syntax
Delphi
public
 Angle, Tangent: Extended;

Field Value

Type: Extended

See Also

Reference

  • TRay
  • frxGauge


frxGauge Enumerations

Enumerations
Name | Description
TGaugeKind | Represents type TGaugeKind.
TGaugePointerKind | Represents type TGaugePointerKind.
TSelectedPointer | Represents type TSelectedPointer.
Top


TGaugeKind Enumeration

Summary

Represents type TGaugeKind.

Namespace: frxGauge
Syntax
Delphi
type
 TGaugeKind = (gkHorizontal, gkVertical, gkCircle);

The TGaugeKind type exposes the following members.

Members
Show:
Name | Description
gkCircle | Represents constant gkCircle.
gkHorizontal | Represents constant gkHorizontal.
gkVertical | Represents constant gkVertical.
Top
See Also

Reference

  • frxGauge


TGaugePointerKind Enumeration

Summary

Represents type TGaugePointerKind.

Namespace: frxGauge
Syntax
Delphi
type
 TGaugePointerKind = (pkSegment, pkTriangle, pkDiamond, pkPentagon, pkBand);

The TGaugePointerKind type exposes the following members.

Members
Show:
Name | Description
pkBand | Represents constant pkBand.
pkDiamond | Represents constant pkDiamond.
pkPentagon | Represents constant pkPentagon.
pkSegment | Represents constant pkSegment.
pkTriangle | Represents constant pkTriangle.
Top
See Also

Reference

  • frxGauge


TSelectedPointer Enumeration

Summary

Represents type TSelectedPointer.

Namespace: frxGauge
Syntax
Delphi
type
 TSelectedPointer = (spNo, spStart, spEnd, spBoth);

The TSelectedPointer type exposes the following members.

Members
Show:
Name | Description
spBoth | Represents constant spBoth.
spEnd | Represents constant spEnd.
spNo | Represents constant spNo.
spStart | Represents constant spStart.
Top
See Also

Reference

  • frxGauge


frxGauge Delegates

Delegates
Name | Description
TUpdateEvent | Represents type TUpdateEvent.
Top


TUpdateEvent Delegate

Summary

Represents type TUpdateEvent.

Namespace: frxGauge
Syntax
Delphi
type
 TUpdateEvent = procedure of object;
See Also

Reference

  • frxGauge


frxGaugeDialogControl Namespace

Summary

Represents namespace frxGaugeDialogControl.

Classes
Name | Description
TfrxBaseGaugeControl | Represents type TfrxBaseGaugeControl.
TfrxGaugeControl | Represents type TfrxGaugeControl.
TfrxGaugeDialogControls | Represents type TfrxGaugeDialogControls.
TfrxIntervalGaugeControl | Represents type TfrxIntervalGaugeControl.
Top


frxGaugeDialogControl Classes

Classes
Name | Description
TfrxBaseGaugeControl | Represents type TfrxBaseGaugeControl.
TfrxGaugeControl | Represents type TfrxGaugeControl.
TfrxGaugeDialogControls | Represents type TfrxGaugeDialogControls.
TfrxIntervalGaugeControl | Represents type TfrxIntervalGaugeControl.
Top


TfrxBaseGaugeControl Class

Summary

Represents type TfrxBaseGaugeControl.

Namespace: frxGaugeDialogControl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxGaugeDialogControl.TfrxBaseGaugeControl
frxGaugeDialogControl.TfrxGaugeControl
frxGaugeDialogControl.TfrxIntervalGaugeControl
Syntax
Delphi
type
 TfrxBaseGaugeControl = class(TfrxDialogControl)
 end;

The TfrxBaseGaugeControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseGaugeControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
Color | Color of the control. (Inherited from TfrxDialogControl.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick.
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Determines if the user can tab to a control. (Inherited from TfrxDialogControl.)
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateGauge | Represents method CreateGauge.
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseGauge | Represents field FBaseGauge.
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxGaugeDialogControl


TfrxBaseGaugeControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseGaugeControl class. (Overrides TfrxDialogControl.Create(TComponent).)
Top


TfrxBaseGaugeControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxBaseGaugeControl class.

Namespace: frxGaugeDialogControl
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxDialogControl.Create(TComponent)
See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxBaseGaugeControl Properties

Properties
Name | Description
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
Top


TfrxBaseGaugeControl.OnClick Property

Summary

Represents property OnClick.

Namespace: frxGaugeDialogControl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxBaseGaugeControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxGaugeDialogControl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxBaseGaugeControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxGaugeDialogControl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxBaseGaugeControl.OnExit Property

Summary

Represents property OnExit.

Namespace: frxGaugeDialogControl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxBaseGaugeControl.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxGaugeDialogControl
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxBaseGaugeControl.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxGaugeDialogControl
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxBaseGaugeControl.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxGaugeDialogControl
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxBaseGaugeControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxGaugeDialogControl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxBaseGaugeControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxGaugeDialogControl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxBaseGaugeControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxGaugeDialogControl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxBaseGaugeControl Methods

Methods
Name | Description
CreateGauge | Represents method CreateGauge.
Top


TfrxBaseGaugeControl.CreateGauge Method

Summary

Represents method CreateGauge.

Namespace: frxGaugeDialogControl
Syntax
Delphi
protected
 procedure CreateGauge; virtual; abstract;
See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxBaseGaugeControl Fields

Fields
Name | Description
FBaseGauge | Represents field FBaseGauge.
Top


TfrxBaseGaugeControl.FBaseGauge Field

Summary

Represents field FBaseGauge.

Namespace: frxGaugeDialogControl
Syntax
Delphi
protected
 FBaseGauge: TfrxBaseGaugePanel;

Field Value

Type: TfrxBaseGaugePanel

See Also

Reference

  • TfrxBaseGaugeControl
  • frxGaugeDialogControl


TfrxGaugeControl Class

Summary

Represents type TfrxGaugeControl.

Namespace: frxGaugeDialogControl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxGaugeDialogControl.TfrxBaseGaugeControl
frxGaugeDialogControl.TfrxGaugeControl
Syntax
Delphi
type
 TfrxGaugeControl = class(TfrxBaseGaugeControl)
 end;

The TfrxGaugeControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseGaugeControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
Color | Color of the control. (Inherited from TfrxDialogControl.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
Gauge | Represents property Gauge.
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick. (Inherited from TfrxBaseGaugeControl.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick. (Inherited from TfrxBaseGaugeControl.)
OnEnter | Represents property OnEnter. (Inherited from TfrxBaseGaugeControl.)
OnExit | Represents property OnExit. (Inherited from TfrxBaseGaugeControl.)
OnKeyDown | Represents property OnKeyDown. (Inherited from TfrxBaseGaugeControl.)
OnKeyPress | Represents property OnKeyPress. (Inherited from TfrxBaseGaugeControl.)
OnKeyUp | Represents property OnKeyUp. (Inherited from TfrxBaseGaugeControl.)
OnMouseDown | Represents property OnMouseDown. (Inherited from TfrxBaseGaugeControl.)
OnMouseMove | Represents property OnMouseMove. (Inherited from TfrxBaseGaugeControl.)
OnMouseUp | Represents property OnMouseUp. (Inherited from TfrxBaseGaugeControl.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Determines if the user can tab to a control. (Inherited from TfrxDialogControl.)
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateGauge | Represents method CreateGauge. (Overrides TfrxBaseGaugeControl.CreateGauge.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGauge | Represents method GetGauge.
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseGauge | Represents field FBaseGauge. (Inherited from TfrxBaseGaugeControl.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxGaugeDialogControl


TfrxGaugeControl Properties

Properties
Name | Description
Gauge | Represents property Gauge.
Top


TfrxGaugeControl.Gauge Property

Summary

Represents property Gauge.

Namespace: frxGaugeDialogControl
Syntax
Delphi
published
 property Gauge: TfrxGauge read GetGauge;

Property Value

Type: TfrxGauge

See Also

Reference

  • TfrxGaugeControl
  • frxGaugeDialogControl


TfrxGaugeControl Methods

Methods
Name | Description
CreateGauge | Represents method CreateGauge. (Overrides TfrxBaseGaugeControl.CreateGauge.)
GetGauge | Represents method GetGauge.
Top


TfrxGaugeControl.CreateGauge Method

Summary

Represents method CreateGauge.

Namespace: frxGaugeDialogControl
Syntax
Delphi
protected
 procedure CreateGauge; override;

Overrides

TfrxBaseGaugeControl.CreateGauge
See Also

Reference

  • TfrxGaugeControl
  • frxGaugeDialogControl


TfrxGaugeControl.GetGauge Method

Summary

Represents method GetGauge.

Namespace: frxGaugeDialogControl
Syntax
Delphi
private
 function GetGauge: TfrxGauge;

Return Value

Type: TfrxGauge

See Also

Reference

  • TfrxGaugeControl
  • frxGaugeDialogControl


TfrxGaugeDialogControls Class

Summary

Represents type TfrxGaugeDialogControls.

Namespace: frxGaugeDialogControl
Inheritance Hierarchy
TComponent
frxGaugeDialogControl.TfrxGaugeDialogControls
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxGaugeDialogControls = class(TComponent)
 end;
See Also

Reference

  • frxGaugeDialogControl


TfrxIntervalGaugeControl Class

Summary

Represents type TfrxIntervalGaugeControl.

Namespace: frxGaugeDialogControl
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxDialogControl
frxGaugeDialogControl.TfrxBaseGaugeControl
frxGaugeDialogControl.TfrxIntervalGaugeControl
Syntax
Delphi
type
 TfrxIntervalGaugeControl = class(TfrxBaseGaugeControl)
 end;

The TfrxIntervalGaugeControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseGaugeControl class. (Overrides TfrxDialogControl.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxDialogControl.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
Caption | Caption of the control. (Inherited from TfrxDialogControl.)
Color | Color of the control. (Inherited from TfrxDialogControl.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Control | Link to the control itself. (Inherited from TfrxDialogControl.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
Enabled | Determines if the control is enabled. (Inherited from TfrxDialogControl.)
Font | Represents property Font. (Inherited from TfrxDialogControl.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
Gauge | Represents property Gauge.
GroupIndex | Represents property GroupIndex. (Inherited from TfrxDialogControl.)
Height | Represents property Height. (Inherited from TfrxDialogControl.)
Hint | Contains the text string that can appear when the user moves the mouse over the control. (Inherited from TfrxDialogControl.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxDialogControl.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnActivate | The name of the script routine that will be called if user activate control. (Inherited from TfrxDialogControl.)
OnAfterData | The name of the script routine that will be called after the object gets data. (Inherited from TfrxReportComponent.)
OnAfterPrint | The name of the script routine that will be called after the object is handled. (Inherited from TfrxReportComponent.)
OnBeforePrint | The name of the script routine that will be called before the object is handled. (Inherited from TfrxReportComponent.)
OnClick | Represents property OnClick. (Inherited from TfrxBaseGaugeControl.)
OnContentChanged | The name of the script routine that will be called if content of object was changes(for example text in "Text" object). (Inherited from TfrxReportComponent.)
OnDblClick | Represents property OnDblClick. (Inherited from TfrxBaseGaugeControl.)
OnEnter | Represents property OnEnter. (Inherited from TfrxBaseGaugeControl.)
OnExit | Represents property OnExit. (Inherited from TfrxBaseGaugeControl.)
OnKeyDown | Represents property OnKeyDown. (Inherited from TfrxBaseGaugeControl.)
OnKeyPress | Represents property OnKeyPress. (Inherited from TfrxBaseGaugeControl.)
OnKeyUp | Represents property OnKeyUp. (Inherited from TfrxBaseGaugeControl.)
OnMouseDown | Represents property OnMouseDown. (Inherited from TfrxBaseGaugeControl.)
OnMouseMove | Represents property OnMouseMove. (Inherited from TfrxBaseGaugeControl.)
OnMouseUp | Represents property OnMouseUp. (Inherited from TfrxBaseGaugeControl.)
OnPreviewClick | The name of the script routine that will be called if user clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
OnPreviewDblClick | The name of the script routine that will be called if user double clicks on the object in the preview window. (Inherited from TfrxReportComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont. (Inherited from TfrxDialogControl.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
ShowHint | Show/hide hint. (Inherited from TfrxDialogControl.)
TabStop | Determines if the user can tab to a control. (Inherited from TfrxDialogControl.)
Top | Represents property Top. (Inherited from TfrxDialogControl.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Represents property Visible. (Inherited from TfrxDialogControl.)
Width | Represents property Width. (Inherited from TfrxDialogControl.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Inherited from TfrxReportComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Inherited from TfrxReportComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectControlCoordinates | Represents method CorrectControlCoordinates. (Inherited from TfrxDialogControl.)
CreateGauge | Represents method CreateGauge. (Overrides TfrxBaseGaugeControl.CreateGauge.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Inherited from TfrxReportComponent.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Overrides TfrxComponent.FontChanged(TObject).)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetCoordinateOffset | Represents method GetCoordinateOffset. (Inherited from TfrxDialogControl.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Inherited from TfrxReportComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGauge | Represents method GetGauge.
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaledControlHeight | Represents method GetScaledControlHeight. (Inherited from TfrxDialogControl.)
GetScaledControlLeft | Represents method GetScaledControlLeft. (Inherited from TfrxDialogControl.)
GetScaledControlTop | Represents method GetScaledControlTop. (Inherited from TfrxDialogControl.)
GetScaledControlWidth | Represents method GetScaledControlWidth. (Inherited from TfrxDialogControl.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitControl(TControl) | Represents method InitControl(TControl). (Inherited from TfrxDialogControl.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Overrides TfrxComponent.IsAcceptControls.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Overrides TfrxComponent.SetAnchors(TfrxAnchors).)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Overrides TfrxComponent.SetName(TComponentName).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Overrides TfrxComponent.SetParentFont(Boolean).)
SetTop(Extended) | Represents method SetTop(Extended). (Overrides TfrxComponent.SetTop(Extended).)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateControlPPI(Integer) | Represents method UpdateControlPPI(Integer). (Inherited from TfrxDialogControl.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseGauge | Represents field FBaseGauge. (Inherited from TfrxBaseGaugeControl.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxDialogControl.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
Top
See Also

Reference

  • frxGaugeDialogControl


TfrxIntervalGaugeControl Properties

Properties
Name | Description
Gauge | Represents property Gauge.
Top


TfrxIntervalGaugeControl.Gauge Property

Summary

Represents property Gauge.

Namespace: frxGaugeDialogControl
Syntax
Delphi
published
 property Gauge: TfrxIntervalGauge read GetGauge;

Property Value

Type: TfrxIntervalGauge

See Also

Reference

  • TfrxIntervalGaugeControl
  • frxGaugeDialogControl


TfrxIntervalGaugeControl Methods

Methods
Name | Description
CreateGauge | Represents method CreateGauge. (Overrides TfrxBaseGaugeControl.CreateGauge.)
GetGauge | Represents method GetGauge.
Top


TfrxIntervalGaugeControl.CreateGauge Method

Summary

Represents method CreateGauge.

Namespace: frxGaugeDialogControl
Syntax
Delphi
protected
 procedure CreateGauge; override;

Overrides

TfrxBaseGaugeControl.CreateGauge
See Also

Reference

  • TfrxIntervalGaugeControl
  • frxGaugeDialogControl


TfrxIntervalGaugeControl.GetGauge Method

Summary

Represents method GetGauge.

Namespace: frxGaugeDialogControl
Syntax
Delphi
private
 function GetGauge: TfrxIntervalGauge;

Return Value

Type: TfrxIntervalGauge

See Also

Reference

  • TfrxIntervalGaugeControl
  • frxGaugeDialogControl


frxGaugePanel Namespace

Summary

Represents namespace frxGaugePanel.

Classes
Name | Description
TfrxBaseGaugePanel | Represents type TfrxBaseGaugePanel.
TfrxGaugePanel | Represents type TfrxGaugePanel.
TfrxIntervalGaugePanel | Represents type TfrxIntervalGaugePanel.
Top


frxGaugePanel Classes

Classes
Name | Description
TfrxBaseGaugePanel | Represents type TfrxBaseGaugePanel.
TfrxGaugePanel | Represents type TfrxGaugePanel.
TfrxIntervalGaugePanel | Represents type TfrxIntervalGaugePanel.
Top


TfrxBaseGaugePanel Class

Summary

Represents type TfrxBaseGaugePanel.

Namespace: frxGaugePanel
Inheritance Hierarchy
TPanel
frxGaugePanel.TfrxBaseGaugePanel
frxGaugePanel.TfrxGaugePanel
frxGaugePanel.TfrxIntervalGaugePanel
Syntax
Delphi
type
 TfrxBaseGaugePanel = class(TPanel)
 end;

The TfrxBaseGaugePanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseGaugePanel class.
Destroy | Represents the destructor of the TfrxBaseGaugePanel class.
Top
Methods
Show:
Name | Description
CreateGauge | Represents method CreateGauge.
DoMouseWheel(TShiftState,Integer,TPoint) | Represents method DoMouseWheel(TShiftState,Integer,TPoint).
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge.
Top
See Also

Reference

  • frxGaugePanel


TfrxBaseGaugePanel Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseGaugePanel class.
Destroy | Represents the destructor of the TfrxBaseGaugePanel class.
Top


TfrxBaseGaugePanel.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxBaseGaugePanel class.

Namespace: frxGaugePanel
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxBaseGaugePanel
  • frxGaugePanel


TfrxBaseGaugePanel.Destroy Destructor

Summary

Represents the destructor of the TfrxBaseGaugePanel class.

Namespace: frxGaugePanel
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxBaseGaugePanel
  • frxGaugePanel


TfrxBaseGaugePanel Methods

Methods
Name | Description
CreateGauge | Represents method CreateGauge.
DoMouseWheel(TShiftState,Integer,TPoint) | Represents method DoMouseWheel(TShiftState,Integer,TPoint).
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Paint | Represents method Paint.
Top


TfrxBaseGaugePanel.CreateGauge Method

Summary

Represents method CreateGauge.

Namespace: frxGaugePanel
Syntax
Delphi
protected
 procedure CreateGauge; virtual; abstract;
See Also

Reference

  • TfrxBaseGaugePanel
  • frxGaugePanel


TfrxBaseGaugePanel.DoMouseWheel(TShiftState,Integer,TPoint) Method

Summary

Represents method DoMouseWheel(TShiftState,Integer,TPoint).

Namespace: frxGaugePanel
Syntax
Delphi
protected
 function DoMouseWheel(Shift: TShiftState; WheelDelta: Integer;
 MousePos: TPoint): Boolean; override;

Parameters

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

Return Value

Type: Boolean

See Also

Reference

  • TfrxBaseGaugePanel
  • frxGaugePanel


TfrxBaseGaugePanel.MouseDown(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxGaugePanel
Syntax
Delphi
protected
 procedure MouseDown(Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxBaseGaugePanel
  • frxGaugePanel


TfrxBaseGaugePanel.MouseMove(TShiftState,Integer,Integer) Method

Summary

Represents method MouseMove(TShiftState,Integer,Integer).

Namespace: frxGaugePanel
Syntax
Delphi
protected
 procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;

Parameters

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxBaseGaugePanel
  • frxGaugePanel


TfrxBaseGaugePanel.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxGaugePanel
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxBaseGaugePanel
  • frxGaugePanel


TfrxBaseGaugePanel.Paint Method

Summary

Represents method Paint.

Namespace: frxGaugePanel
Syntax
Delphi
protected
 procedure Paint; override;
See Also

Reference

  • TfrxBaseGaugePanel
  • frxGaugePanel


TfrxBaseGaugePanel Fields

Fields
Name | Description
FBaseGauge | Represents field FBaseGauge.
Top


TfrxBaseGaugePanel.FBaseGauge Field

Summary

Represents field FBaseGauge.

Namespace: frxGaugePanel
Syntax
Delphi
protected
 FBaseGauge: TfrxBaseGauge;

Field Value

Type: TfrxBaseGauge

See Also

Reference

  • TfrxBaseGaugePanel
  • frxGaugePanel


TfrxGaugePanel Class

Summary

Represents type TfrxGaugePanel.

Namespace: frxGaugePanel
Inheritance Hierarchy
TPanel
frxGaugePanel.TfrxBaseGaugePanel
frxGaugePanel.TfrxGaugePanel
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxGaugePanel = class(TfrxBaseGaugePanel)
 end;

The TfrxGaugePanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseGaugePanel class. (Inherited from TfrxBaseGaugePanel.)
Top
Properties
Show:
Name | Description
Gauge | Represents property Gauge.
Top
Methods
Show:
Name | Description
CreateGauge | Represents method CreateGauge. (Overrides TfrxBaseGaugePanel.CreateGauge.)
DoMouseWheel(TShiftState,Integer,TPoint) | Represents method DoMouseWheel(TShiftState,Integer,TPoint). (Inherited from TfrxBaseGaugePanel.)
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer). (Inherited from TfrxBaseGaugePanel.)
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer). (Inherited from TfrxBaseGaugePanel.)
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer). (Inherited from TfrxBaseGaugePanel.)
Paint | Represents method Paint. (Inherited from TfrxBaseGaugePanel.)
SetGauge(TfrxGauge) | Represents method SetGauge(TfrxGauge).
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge. (Inherited from TfrxBaseGaugePanel.)
FGauge | Represents field FGauge.
Top
See Also

Reference

  • frxGaugePanel


TfrxGaugePanel Properties

Properties
Name | Description
Gauge | Represents property Gauge.
Top


TfrxGaugePanel.Gauge Property

Summary

Represents property Gauge.

Namespace: frxGaugePanel
Syntax
Delphi
published
 property Gauge: TfrxGauge read FGauge write SetGauge;

Property Value

Type: TfrxGauge

See Also

Reference

  • TfrxGaugePanel
  • frxGaugePanel


TfrxGaugePanel Methods

Methods
Name | Description
CreateGauge | Represents method CreateGauge. (Overrides TfrxBaseGaugePanel.CreateGauge.)
SetGauge(TfrxGauge) | Represents method SetGauge(TfrxGauge).
Top


TfrxGaugePanel.CreateGauge Method

Summary

Represents method CreateGauge.

Namespace: frxGaugePanel
Syntax
Delphi
protected
 procedure CreateGauge; override;

Overrides

TfrxBaseGaugePanel.CreateGauge
See Also

Reference

  • TfrxGaugePanel
  • frxGaugePanel


TfrxGaugePanel.SetGauge(TfrxGauge) Method

Summary

Represents method SetGauge(TfrxGauge).

Namespace: frxGaugePanel
Syntax
Delphi
private
 procedure SetGauge(const Value: TfrxGauge);

Parameters

Value
Type: TfrxGauge

See Also

Reference

  • TfrxGaugePanel
  • frxGaugePanel


TfrxGaugePanel Fields

Fields
Name | Description
FGauge | Represents field FGauge.
Top


TfrxGaugePanel.FGauge Field

Summary

Represents field FGauge.

Namespace: frxGaugePanel
Syntax
Delphi
private
 FGauge: TfrxGauge;

Field Value

Type: TfrxGauge

See Also

Reference

  • TfrxGaugePanel
  • frxGaugePanel


TfrxIntervalGaugePanel Class

Summary

Represents type TfrxIntervalGaugePanel.

Namespace: frxGaugePanel
Inheritance Hierarchy
TPanel
frxGaugePanel.TfrxBaseGaugePanel
frxGaugePanel.TfrxIntervalGaugePanel
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxIntervalGaugePanel = class(TfrxBaseGaugePanel)
 end;

The TfrxIntervalGaugePanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseGaugePanel class. (Inherited from TfrxBaseGaugePanel.)
Top
Properties
Show:
Name | Description
Gauge | Represents property Gauge.
Top
Methods
Show:
Name | Description
CreateGauge | Represents method CreateGauge. (Overrides TfrxBaseGaugePanel.CreateGauge.)
DoMouseWheel(TShiftState,Integer,TPoint) | Represents method DoMouseWheel(TShiftState,Integer,TPoint). (Inherited from TfrxBaseGaugePanel.)
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer). (Inherited from TfrxBaseGaugePanel.)
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer). (Inherited from TfrxBaseGaugePanel.)
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer). (Inherited from TfrxBaseGaugePanel.)
Paint | Represents method Paint. (Inherited from TfrxBaseGaugePanel.)
SetGauge(TfrxIntervalGauge) | Represents method SetGauge(TfrxIntervalGauge).
Top
Fields
Show:
Name | Description
FBaseGauge | Represents field FBaseGauge. (Inherited from TfrxBaseGaugePanel.)
FIntervalGauge | Represents field FIntervalGauge.
Top
See Also

Reference

  • frxGaugePanel


TfrxIntervalGaugePanel Properties

Properties
Name | Description
Gauge | Represents property Gauge.
Top


TfrxIntervalGaugePanel.Gauge Property

Summary

Represents property Gauge.

Namespace: frxGaugePanel
Syntax
Delphi
published
 property Gauge: TfrxIntervalGauge read FIntervalGauge write SetGauge;

Property Value

Type: TfrxIntervalGauge

See Also

Reference

  • TfrxIntervalGaugePanel
  • frxGaugePanel


TfrxIntervalGaugePanel Methods

Methods
Name | Description
CreateGauge | Represents method CreateGauge. (Overrides TfrxBaseGaugePanel.CreateGauge.)
SetGauge(TfrxIntervalGauge) | Represents method SetGauge(TfrxIntervalGauge).
Top


TfrxIntervalGaugePanel.CreateGauge Method

Summary

Represents method CreateGauge.

Namespace: frxGaugePanel
Syntax
Delphi
protected
 procedure CreateGauge; override;

Overrides

TfrxBaseGaugePanel.CreateGauge
See Also

Reference

  • TfrxIntervalGaugePanel
  • frxGaugePanel


TfrxIntervalGaugePanel.SetGauge(TfrxIntervalGauge) Method

Summary

Represents method SetGauge(TfrxIntervalGauge).

Namespace: frxGaugePanel
Syntax
Delphi
private
 procedure SetGauge(const Value: TfrxIntervalGauge);

Parameters

Value
Type: TfrxIntervalGauge

See Also

Reference

  • TfrxIntervalGaugePanel
  • frxGaugePanel


TfrxIntervalGaugePanel Fields

Fields
Name | Description
FIntervalGauge | Represents field FIntervalGauge.
Top


TfrxIntervalGaugePanel.FIntervalGauge Field

Summary

Represents field FIntervalGauge.

Namespace: frxGaugePanel
Syntax
Delphi
private
 FIntervalGauge: TfrxIntervalGauge;

Field Value

Type: TfrxIntervalGauge

See Also

Reference

  • TfrxIntervalGaugePanel
  • frxGaugePanel


frxGaugeView Namespace

Summary

Represents namespace frxGaugeView.

Classes
Name | Description
TfrxBaseGaugeView | Represents type TfrxBaseGaugeView.
TfrxGaugeObject | Represents type TfrxGaugeObject.
TfrxGaugeView | Represents type TfrxGaugeView.
TfrxIntervalGaugeView | Represents type TfrxIntervalGaugeView.
Top


frxGaugeView Classes

Classes
Name | Description
TfrxBaseGaugeView | Represents type TfrxBaseGaugeView.
TfrxGaugeObject | Represents type TfrxGaugeObject.
TfrxGaugeView | Represents type TfrxGaugeView.
TfrxIntervalGaugeView | Represents type TfrxIntervalGaugeView.
Top


TfrxBaseGaugeView Class

Summary

Represents type TfrxBaseGaugeView.

Namespace: frxGaugeView
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxGaugeView.TfrxBaseGaugeView
frxGaugeView.TfrxGaugeView
frxGaugeView.TfrxIntervalGaugeView
Syntax
Delphi
type
 TfrxBaseGaugeView = class(TfrxView)
 end;

The TfrxBaseGaugeView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseGaugeView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxBaseGaugeView class. (Overrides TfrxView.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseGauge | Represents property BaseGauge.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor.
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Represents property Fill.
FillType | Represents property FillType.
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
TagStr | Represents property TagStr.
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
ContentChanged(TObject) | Represents method ContentChanged(TObject).
CreateGauge | Represents method CreateGauge.
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxReportComponent.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InnerPoint(Integer,Integer) | Represents method InnerPoint(Integer,Integer).
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateInspector | Represents method UpdateInspector.
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseGauge | Represents field FBaseGauge.
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxGaugeView


TfrxBaseGaugeView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseGaugeView class. (Overrides TfrxView.Create(TComponent).)
Destroy | Represents the destructor of the TfrxBaseGaugeView class. (Overrides TfrxView.Destroy.)
Top


TfrxBaseGaugeView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxBaseGaugeView class.

Namespace: frxGaugeView
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxView.Create(TComponent)
See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.Destroy Destructor

Summary

Represents the destructor of the TfrxBaseGaugeView class.

Namespace: frxGaugeView
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxView.Destroy
See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView Properties

Properties
Name | Description
BaseGauge | Represents property BaseGauge.
Cursor | Represents property Cursor.
Fill | Represents property Fill.
FillType | Represents property FillType.
Frame | Represents property Frame.
TagStr | Represents property TagStr.
Top


TfrxBaseGaugeView.BaseGauge Property

Summary

Represents property BaseGauge.

Namespace: frxGaugeView
Syntax
Delphi
public
 property BaseGauge: TfrxBaseGauge read FBaseGauge;

Property Value

Type: TfrxBaseGauge

See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.Cursor Property

Summary

Represents property Cursor.

Namespace: frxGaugeView
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.Fill Property

Summary

Represents property Fill.

Namespace: frxGaugeView
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.FillType Property

Summary

Represents property FillType.

Namespace: frxGaugeView
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.Frame Property

Summary

Represents property Frame.

Namespace: frxGaugeView
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.TagStr Property

Summary

Represents property TagStr.

Namespace: frxGaugeView
Syntax
Delphi
published
 property TagStr;

Property Value

Type: Void

See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView Methods

Methods
Name | Description
ContentChanged(TObject) | Represents method ContentChanged(TObject).
CreateGauge | Represents method CreateGauge.
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
InnerPoint(Integer,Integer) | Represents method InnerPoint(Integer,Integer).
UpdateInspector | Represents method UpdateInspector.
Top


TfrxBaseGaugeView.ContentChanged(TObject) Method

Summary

Represents method ContentChanged(TObject).

Namespace: frxGaugeView
Syntax
Delphi
protected
 procedure ContentChanged(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.CreateGauge Method

Summary

Represents method CreateGauge.

Namespace: frxGaugeView
Syntax
Delphi
protected
 procedure CreateGauge; virtual; abstract;
See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxGaugeView
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxGaugeView
Syntax
Delphi
public
 procedure DoMouseMove(X, Y: Integer;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxGaugeView
Syntax
Delphi
public
 procedure DoMouseUp(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).

Namespace: frxGaugeView
Syntax
Delphi
public
 function DoMouseWheel(Shift: TShiftState;
 WheelDelta: Integer; MousePos: TPoint; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxGaugeView
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.InnerPoint(Integer,Integer) Method

Summary

Represents method InnerPoint(Integer,Integer).

Namespace: frxGaugeView
Syntax
Delphi
protected
 function InnerPoint(X, Y: Integer): TPoint;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TPoint

See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView.UpdateInspector Method

Summary

Represents method UpdateInspector.

Namespace: frxGaugeView
Syntax
Delphi
public
 procedure UpdateInspector;
See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxBaseGaugeView Fields

Fields
Name | Description
FBaseGauge | Represents field FBaseGauge.
Top


TfrxBaseGaugeView.FBaseGauge Field

Summary

Represents field FBaseGauge.

Namespace: frxGaugeView
Syntax
Delphi
private
 FBaseGauge: TfrxBaseGauge;

Field Value

Type: TfrxBaseGauge

See Also

Reference

  • TfrxBaseGaugeView
  • frxGaugeView


TfrxGaugeObject Class

Summary

Represents type TfrxGaugeObject.

Namespace: frxGaugeView
Inheritance Hierarchy
TComponent
frxGaugeView.TfrxGaugeObject
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxGaugeObject = class(TComponent)
 end;
See Also

Reference

  • frxGaugeView


TfrxGaugeView Class

Summary

Represents type TfrxGaugeView.

Namespace: frxGaugeView
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxGaugeView.TfrxBaseGaugeView
frxGaugeView.TfrxGaugeView
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxGaugeView = class(TfrxBaseGaugeView)
 end;

The TfrxGaugeView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseGaugeView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseGauge | Represents property BaseGauge. (Inherited from TfrxBaseGaugeView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor. (Inherited from TfrxBaseGaugeView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Expression | Represents property Expression.
Fill | Represents property Fill. (Inherited from TfrxBaseGaugeView.)
FillType | Represents property FillType. (Inherited from TfrxBaseGaugeView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Represents property Frame. (Inherited from TfrxBaseGaugeView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
Gauge | Represents property Gauge.
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Represents property Processing.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
TagStr | Represents property TagStr. (Inherited from TfrxBaseGaugeView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
ContentChanged(TObject) | Represents method ContentChanged(TObject). (Inherited from TfrxBaseGaugeView.)
CreateGauge | Represents method CreateGauge. (Overrides TfrxBaseGaugeView.CreateGauge.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InnerPoint(Integer,Integer) | Represents method InnerPoint(Integer,Integer). (Inherited from TfrxBaseGaugeView.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetGauge(TfrxGauge) | Represents method SetGauge(TfrxGauge).
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateInspector | Represents method UpdateInspector. (Inherited from TfrxBaseGaugeView.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FExpression | Represents field FExpression.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FGauge | Represents field FGauge.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FMacroLoaded | Represents field FMacroLoaded.
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxGaugeView


TfrxGaugeView Properties

Properties
Name | Description
Expression | Represents property Expression.
Gauge | Represents property Gauge.
Processing | Represents property Processing.
Top


TfrxGaugeView.Expression Property

Summary

Represents property Expression.

Namespace: frxGaugeView
Syntax
Delphi
published
 property Expression: String read FExpression write FExpression;

Property Value

Type: String

See Also

Reference

  • TfrxGaugeView
  • frxGaugeView


TfrxGaugeView.Gauge Property

Summary

Represents property Gauge.

Namespace: frxGaugeView
Syntax
Delphi
published
 property Gauge: TfrxGauge read FGauge write SetGauge;

Property Value

Type: TfrxGauge

See Also

Reference

  • TfrxGaugeView
  • frxGaugeView


TfrxGaugeView.Processing Property

Summary

Represents property Processing.

Namespace: frxGaugeView
Syntax
Delphi
published
 property Processing;

Property Value

Type: Void

See Also

Reference

  • TfrxGaugeView
  • frxGaugeView


TfrxGaugeView Methods

Methods
Name | Description
CreateGauge | Represents method CreateGauge. (Overrides TfrxBaseGaugeView.CreateGauge.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SetGauge(TfrxGauge) | Represents method SetGauge(TfrxGauge).
Top


TfrxGaugeView.CreateGauge Method

Summary

Represents method CreateGauge.

Namespace: frxGaugeView
Syntax
Delphi
protected
 procedure CreateGauge; override;

Overrides

TfrxBaseGaugeView.CreateGauge
See Also

Reference

  • TfrxGaugeView
  • frxGaugeView


TfrxGaugeView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxGaugeView
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxGaugeView
  • frxGaugeView


TfrxGaugeView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) Method

Summary

Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call.

Namespace: frxGaugeView
Syntax
Delphi
public
 function LoadContentFromDictionary(aReport: TfrxReport; aItem: TfrxMacrosItem): Boolean; override;

Parameters

aReport
Type: TfrxReport

Reference to the report object.

aItem
Type: TfrxMacrosItem

TfrxMacrosItem which stores processed data for current object.

Return Value

Type: Boolean

Overrides

TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem)
See Also

Reference

  • TfrxGaugeView
  • frxGaugeView


TfrxGaugeView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) Method

Summary

The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from
PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary.

Namespace: frxGaugeView
Syntax
Delphi
public
 procedure ProcessDictionary(aItem: TfrxMacrosItem; aReport: TfrxReport; PostProcessor: TfrxPostProcessor); override;

Parameters

aItem
Type: TfrxMacrosItem

aReport
Type: TfrxReport

PostProcessor
Type: TfrxPostProcessor

Overrides

TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor)
See Also

Reference

  • TfrxGaugeView
  • frxGaugeView


TfrxGaugeView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor) Method

Summary

This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object.

Namespace: frxGaugeView
Syntax
Delphi
public
 procedure SaveContentToDictionary(aReport: TfrxReport; PostProcessor: TfrxPostProcessor); override;

Parameters

aReport
Type: TfrxReport

Reference to the report object.

PostProcessor
Type: TfrxPostProcessor

Reference to TfrxPostProcessor instance of post processing manager.

Overrides

TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor)
See Also

Reference

  • TfrxGaugeView
  • frxGaugeView


TfrxGaugeView.SetGauge(TfrxGauge) Method

Summary

Represents method SetGauge(TfrxGauge).

Namespace: frxGaugeView
Syntax
Delphi
private
 procedure SetGauge(const Value: TfrxGauge);

Parameters

Value
Type: TfrxGauge

See Also

Reference

  • TfrxGaugeView
  • frxGaugeView


TfrxGaugeView Fields

Fields
Name | Description
FExpression | Represents field FExpression.
FGauge | Represents field FGauge.
FMacroLoaded | Represents field FMacroLoaded.
Top


TfrxGaugeView.FExpression Field

Summary

Represents field FExpression.

Namespace: frxGaugeView
Syntax
Delphi
private
 FExpression: String;

Field Value

Type: String

See Also

Reference

  • TfrxGaugeView
  • frxGaugeView


TfrxGaugeView.FGauge Field

Summary

Represents field FGauge.

Namespace: frxGaugeView
Syntax
Delphi
private
 FGauge: TfrxGauge;

Field Value

Type: TfrxGauge

See Also

Reference

  • TfrxGaugeView
  • frxGaugeView


TfrxGaugeView.FMacroLoaded Field

Summary

Represents field FMacroLoaded.

Namespace: frxGaugeView
Syntax
Delphi
private
 FMacroLoaded: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxGaugeView
  • frxGaugeView


TfrxIntervalGaugeView Class

Summary

Represents type TfrxIntervalGaugeView.

Namespace: frxGaugeView
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxGaugeView.TfrxBaseGaugeView
frxGaugeView.TfrxIntervalGaugeView
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxIntervalGaugeView = class(TfrxBaseGaugeView)
 end;

The TfrxIntervalGaugeView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseGaugeView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseGauge | Represents property BaseGauge. (Inherited from TfrxBaseGaugeView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor. (Inherited from TfrxBaseGaugeView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
EndExpression | Represents property EndExpression.
Fill | Represents property Fill. (Inherited from TfrxBaseGaugeView.)
FillType | Represents property FillType. (Inherited from TfrxBaseGaugeView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Represents property Frame. (Inherited from TfrxBaseGaugeView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IntervalGauge | Represents property IntervalGauge.
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StartExpression | Represents property StartExpression.
TagStr | Represents property TagStr. (Inherited from TfrxBaseGaugeView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
ContentChanged(TObject) | Represents method ContentChanged(TObject). (Inherited from TfrxBaseGaugeView.)
CreateGauge | Represents method CreateGauge. (Overrides TfrxBaseGaugeView.CreateGauge.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InnerPoint(Integer,Integer) | Represents method InnerPoint(Integer,Integer). (Inherited from TfrxBaseGaugeView.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIntervalGauge(TfrxIntervalGauge) | Represents method SetIntervalGauge(TfrxIntervalGauge).
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UpdateInspector | Represents method UpdateInspector. (Inherited from TfrxBaseGaugeView.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FEndExpression | Represents field FEndExpression.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FIntervalGauge | Represents field FIntervalGauge.
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStartExpression | Represents field FStartExpression.
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxGaugeView


TfrxIntervalGaugeView Properties

Properties
Name | Description
EndExpression | Represents property EndExpression.
IntervalGauge | Represents property IntervalGauge.
StartExpression | Represents property StartExpression.
Top


TfrxIntervalGaugeView.EndExpression Property

Summary

Represents property EndExpression.

Namespace: frxGaugeView
Syntax
Delphi
published
 property EndExpression: String read FEndExpression write FEndExpression;

Property Value

Type: String

See Also

Reference

  • TfrxIntervalGaugeView
  • frxGaugeView


TfrxIntervalGaugeView.IntervalGauge Property

Summary

Represents property IntervalGauge.

Namespace: frxGaugeView
Syntax
Delphi
published
 property IntervalGauge: TfrxIntervalGauge read FIntervalGauge write SetIntervalGauge;

Property Value

Type: TfrxIntervalGauge

See Also

Reference

  • TfrxIntervalGaugeView
  • frxGaugeView


TfrxIntervalGaugeView.StartExpression Property

Summary

Represents property StartExpression.

Namespace: frxGaugeView
Syntax
Delphi
published
 property StartExpression: String read FStartExpression write FStartExpression;

Property Value

Type: String

See Also

Reference

  • TfrxIntervalGaugeView
  • frxGaugeView


TfrxIntervalGaugeView Methods

Methods
Name | Description
CreateGauge | Represents method CreateGauge. (Overrides TfrxBaseGaugeView.CreateGauge.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
SetIntervalGauge(TfrxIntervalGauge) | Represents method SetIntervalGauge(TfrxIntervalGauge).
Top


TfrxIntervalGaugeView.CreateGauge Method

Summary

Represents method CreateGauge.

Namespace: frxGaugeView
Syntax
Delphi
protected
 procedure CreateGauge; override;

Overrides

TfrxBaseGaugeView.CreateGauge
See Also

Reference

  • TfrxIntervalGaugeView
  • frxGaugeView


TfrxIntervalGaugeView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxGaugeView
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxIntervalGaugeView
  • frxGaugeView


TfrxIntervalGaugeView.SetIntervalGauge(TfrxIntervalGauge) Method

Summary

Represents method SetIntervalGauge(TfrxIntervalGauge).

Namespace: frxGaugeView
Syntax
Delphi
private
 procedure SetIntervalGauge(const Value: TfrxIntervalGauge);

Parameters

Value
Type: TfrxIntervalGauge

See Also

Reference

  • TfrxIntervalGaugeView
  • frxGaugeView


TfrxIntervalGaugeView Fields

Fields
Name | Description
FEndExpression | Represents field FEndExpression.
FIntervalGauge | Represents field FIntervalGauge.
FStartExpression | Represents field FStartExpression.
Top


TfrxIntervalGaugeView.FEndExpression Field

Summary

Represents field FEndExpression.

Namespace: frxGaugeView
Syntax
Delphi
private
 FEndExpression: String;

Field Value

Type: String

See Also

Reference

  • TfrxIntervalGaugeView
  • frxGaugeView


TfrxIntervalGaugeView.FIntervalGauge Field

Summary

Represents field FIntervalGauge.

Namespace: frxGaugeView
Syntax
Delphi
private
 FIntervalGauge: TfrxIntervalGauge;

Field Value

Type: TfrxIntervalGauge

See Also

Reference

  • TfrxIntervalGaugeView
  • frxGaugeView


TfrxIntervalGaugeView.FStartExpression Field

Summary

Represents field FStartExpression.

Namespace: frxGaugeView
Syntax
Delphi
private
 FStartExpression: String;

Field Value

Type: String

See Also

Reference

  • TfrxIntervalGaugeView
  • frxGaugeView


frxGPXFileFormat Namespace

Summary

Represents namespace frxGPXFileFormat.

Classes
Name | Description
TGPXAnyPoint | Represents type TGPXAnyPoint.
TGPXFile | Represents type TGPXFile.
TGPXTrack | Represents type TGPXTrack.
TGPXTrackSegment | Represents type TGPXTrackSegment.
Top


frxGPXFileFormat Classes

Classes
Name | Description
TGPXAnyPoint | Represents type TGPXAnyPoint.
TGPXFile | Represents type TGPXFile.
TGPXTrack | Represents type TGPXTrack.
TGPXTrackSegment | Represents type TGPXTrackSegment.
Top


TGPXAnyPoint Class

Summary

Represents type TGPXAnyPoint.

Namespace: frxGPXFileFormat
Inheritance Hierarchy
TObject
frxMapHelpers.TTaggedElement
frxGPXFileFormat.TGPXAnyPoint
Syntax
Delphi
type
 TGPXAnyPoint = class(TTaggedElement)
 end;

The TGPXAnyPoint type exposes the following members.

Constructors
Show:
Name | Description
Create(Double,Double) | Initializes a new instance of the TGPXAnyPoint class.
Top
Properties
Show:
Name | Description
Latitude | Represents property Latitude.
Longitude | Represents property Longitude.
Tags | Represents property Tags. (Inherited from TTaggedElement.)
Top
Methods
Show:
Name | Description
AddTag(String,String) | Represents method AddTag(String,String). (Inherited from TTaggedElement.)
IsHaveAllTags(TStrings) | Represents method IsHaveAllTags(TStrings). (Inherited from TTaggedElement.)
IsHaveAnyTag(TStrings) | Represents method IsHaveAnyTag(TStrings). (Inherited from TTaggedElement.)
Top
Fields
Show:
Name | Description
FLatitude | Represents field FLatitude.
FLongitude | Represents field FLongitude.
FTags | Represents field FTags. (Inherited from TTaggedElement.)
Top
See Also

Reference

  • frxGPXFileFormat


TGPXAnyPoint Constructors

Constructors
Name | Description
Create(Double,Double) | Initializes a new instance of the TGPXAnyPoint class.
Top


TGPXAnyPoint.Create(Double,Double) Constructor

Summary

Initializes a new instance of the TGPXAnyPoint class.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 constructor Create(Lat, Lon: Double);

Parameters

Lat
Type: Double

Lon
Type: Double

See Also

Reference

  • TGPXAnyPoint
  • frxGPXFileFormat


TGPXAnyPoint Properties

Properties
Name | Description
Latitude | Represents property Latitude.
Longitude | Represents property Longitude.
Top


TGPXAnyPoint.Latitude Property

Summary

Represents property Latitude.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 property Latitude: Double read FLatitude;

Property Value

Type: Double

See Also

Reference

  • TGPXAnyPoint
  • frxGPXFileFormat


TGPXAnyPoint.Longitude Property

Summary

Represents property Longitude.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 property Longitude: Double read FLongitude;

Property Value

Type: Double

See Also

Reference

  • TGPXAnyPoint
  • frxGPXFileFormat


TGPXAnyPoint Fields

Fields
Name | Description
FLatitude | Represents field FLatitude.
FLongitude | Represents field FLongitude.
Top


TGPXAnyPoint.FLatitude Field

Summary

Represents field FLatitude.

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 FLatitude: Double;

Field Value

Type: Double

See Also

Reference

  • TGPXAnyPoint
  • frxGPXFileFormat


TGPXAnyPoint.FLongitude Field

Summary

Represents field FLongitude.

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 FLongitude: Double;

Field Value

Type: Double

See Also

Reference

  • TGPXAnyPoint
  • frxGPXFileFormat


TGPXFile Class

Summary

Represents type TGPXFile.

Namespace: frxGPXFileFormat
Inheritance Hierarchy
TObject
frxGPXFileFormat.TGPXFile
Syntax
Delphi
type
 TGPXFile = class
 end;

The TGPXFile type exposes the following members.

Constructors
Show:
Name | Description
Create(string) | Initializes a new instance of the TGPXFile class.
Destroy | Represents the destructor of the TGPXFile class.
Top
Properties
Show:
Name | Description
CountOfTracks | Represents property CountOfTracks.
CountOfWayPoints | Represents property CountOfWayPoints.
Tracks[integer] | Represents property Tracks[integer].
WayPoints[integer] | Represents property WayPoints[integer].
Xmax | Represents property Xmax.
Xmin | Represents property Xmin.
Ymax | Represents property Ymax.
Ymin | Represents property Ymin.
Top
Methods
Show:
Name | Description
fnLoadAnyPoint(TfrxXMLItem) | Represents method fnLoadAnyPoint(TfrxXMLItem).
fnLoadRoute(TfrxXMLItem) | Represents method fnLoadRoute(TfrxXMLItem).
fnLoadTrack(TfrxXMLItem) | Represents method fnLoadTrack(TfrxXMLItem).
fnLoadTrackSegment(TfrxXMLItem) | Represents method fnLoadTrackSegment(TfrxXMLItem).
GetCountOfTracks | Represents method GetCountOfTracks.
GetCountOfWayPoints | Represents method GetCountOfWayPoints.
GetTracks(integer) | Represents method GetTracks(integer).
GetWayPoints(integer) | Represents method GetWayPoints(integer).
IsValidBounds | Represents method IsValidBounds.
Load(string) | Represents method Load(string).
LoadBounds(TfrxXMLItem) | Represents method LoadBounds(TfrxXMLItem).
LoadMetadata(TfrxXMLItem) | Represents method LoadMetadata(TfrxXMLItem).
ParseItem(TfrxXMLItem) | Represents method ParseItem(TfrxXMLItem).
Top
Fields
Show:
Name | Description
FTracks | Represents field FTracks.
FValidBounds | Represents field FValidBounds.
FWayPoints | Represents field FWayPoints.
FXmax | Represents field FXmax.
FXmin | Represents field FXmin.
FYmax | Represents field FYmax.
FYmin | Represents field FYmin.
Top
See Also

Reference

  • frxGPXFileFormat


TGPXFile Constructors

Constructors
Name | Description
Create(string) | Initializes a new instance of the TGPXFile class.
Destroy | Represents the destructor of the TGPXFile class.
Top


TGPXFile.Create(string) Constructor

Summary

Initializes a new instance of the TGPXFile class.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 constructor Create(const FileName: string);

Parameters

FileName
Type: string

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.Destroy Destructor

Summary

Represents the destructor of the TGPXFile class.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile Properties

Properties
Name | Description
CountOfTracks | Represents property CountOfTracks.
CountOfWayPoints | Represents property CountOfWayPoints.
Tracks[integer] | Represents property Tracks[integer].
WayPoints[integer] | Represents property WayPoints[integer].
Xmax | Represents property Xmax.
Xmin | Represents property Xmin.
Ymax | Represents property Ymax.
Ymin | Represents property Ymin.
Top


TGPXFile.CountOfTracks Property

Summary

Represents property CountOfTracks.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 property CountOfTracks: Integer read GetCountOfTracks;

Property Value

Type: Integer

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.CountOfWayPoints Property

Summary

Represents property CountOfWayPoints.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 property CountOfWayPoints: Integer read GetCountOfWayPoints;

Property Value

Type: Integer

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.Tracks[integer] Property

Summary

Represents property Tracks[integer].

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 property Tracks[Index: integer]: TGPXTrack read GetTracks;

Parameters

Index
Type: integer

Property Value

Type: TGPXTrack

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.WayPoints[integer] Property

Summary

Represents property WayPoints[integer].

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 property WayPoints[Index: integer]: TGPXAnyPoint read GetWayPoints;

Parameters

Index
Type: integer

Property Value

Type: TGPXAnyPoint

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.Xmax Property

Summary

Represents property Xmax.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 property Xmax: Double read FXmax;

Property Value

Type: Double

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.Xmin Property

Summary

Represents property Xmin.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 property Xmin: Double read FXmin;

Property Value

Type: Double

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.Ymax Property

Summary

Represents property Ymax.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 property Ymax: Double read FYmax;

Property Value

Type: Double

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.Ymin Property

Summary

Represents property Ymin.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 property Ymin: Double read FYmin;

Property Value

Type: Double

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile Methods

Methods
Name | Description
fnLoadAnyPoint(TfrxXMLItem) | Represents method fnLoadAnyPoint(TfrxXMLItem).
fnLoadRoute(TfrxXMLItem) | Represents method fnLoadRoute(TfrxXMLItem).
fnLoadTrack(TfrxXMLItem) | Represents method fnLoadTrack(TfrxXMLItem).
fnLoadTrackSegment(TfrxXMLItem) | Represents method fnLoadTrackSegment(TfrxXMLItem).
GetCountOfTracks | Represents method GetCountOfTracks.
GetCountOfWayPoints | Represents method GetCountOfWayPoints.
GetTracks(integer) | Represents method GetTracks(integer).
GetWayPoints(integer) | Represents method GetWayPoints(integer).
IsValidBounds | Represents method IsValidBounds.
Load(string) | Represents method Load(string).
LoadBounds(TfrxXMLItem) | Represents method LoadBounds(TfrxXMLItem).
LoadMetadata(TfrxXMLItem) | Represents method LoadMetadata(TfrxXMLItem).
ParseItem(TfrxXMLItem) | Represents method ParseItem(TfrxXMLItem).
Top


TGPXFile.fnLoadAnyPoint(TfrxXMLItem) Method

Summary

Represents method fnLoadAnyPoint(TfrxXMLItem).

Namespace: frxGPXFileFormat
Syntax
Delphi
protected
 function fnLoadAnyPoint(XMLItem: TfrxXMLItem): TGPXAnyPoint;

Parameters

XMLItem
Type: TfrxXMLItem

Return Value

Type: TGPXAnyPoint

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.fnLoadRoute(TfrxXMLItem) Method

Summary

Represents method fnLoadRoute(TfrxXMLItem).

Namespace: frxGPXFileFormat
Syntax
Delphi
protected
 function fnLoadRoute(XMLItem: TfrxXMLItem): TGPXTrack;

Parameters

XMLItem
Type: TfrxXMLItem

Return Value

Type: TGPXTrack

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.fnLoadTrack(TfrxXMLItem) Method

Summary

Represents method fnLoadTrack(TfrxXMLItem).

Namespace: frxGPXFileFormat
Syntax
Delphi
protected
 function fnLoadTrack(XMLItem: TfrxXMLItem): TGPXTrack;

Parameters

XMLItem
Type: TfrxXMLItem

Return Value

Type: TGPXTrack

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.fnLoadTrackSegment(TfrxXMLItem) Method

Summary

Represents method fnLoadTrackSegment(TfrxXMLItem).

Namespace: frxGPXFileFormat
Syntax
Delphi
protected
 function fnLoadTrackSegment(XMLItem: TfrxXMLItem): TGPXTrackSegment;

Parameters

XMLItem
Type: TfrxXMLItem

Return Value

Type: TGPXTrackSegment

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.GetCountOfTracks Method

Summary

Represents method GetCountOfTracks.

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 function GetCountOfTracks: Integer;

Return Value

Type: Integer

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.GetCountOfWayPoints Method

Summary

Represents method GetCountOfWayPoints.

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 function GetCountOfWayPoints: Integer;

Return Value

Type: Integer

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.GetTracks(integer) Method

Summary

Represents method GetTracks(integer).

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 function GetTracks(Index: integer): TGPXTrack;

Parameters

Index
Type: integer

Return Value

Type: TGPXTrack

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.GetWayPoints(integer) Method

Summary

Represents method GetWayPoints(integer).

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 function GetWayPoints(Index: integer): TGPXAnyPoint;

Parameters

Index
Type: integer

Return Value

Type: TGPXAnyPoint

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.IsValidBounds Method

Summary

Represents method IsValidBounds.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 function IsValidBounds: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.Load(string) Method

Summary

Represents method Load(string).

Namespace: frxGPXFileFormat
Syntax
Delphi
protected
 procedure Load(const FileName: string);

Parameters

FileName
Type: string

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.LoadBounds(TfrxXMLItem) Method

Summary

Represents method LoadBounds(TfrxXMLItem).

Namespace: frxGPXFileFormat
Syntax
Delphi
protected
 procedure LoadBounds(XMLItem: TfrxXMLItem);

Parameters

XMLItem
Type: TfrxXMLItem

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.LoadMetadata(TfrxXMLItem) Method

Summary

Represents method LoadMetadata(TfrxXMLItem).

Namespace: frxGPXFileFormat
Syntax
Delphi
protected
 procedure LoadMetadata(XMLItem: TfrxXMLItem);

Parameters

XMLItem
Type: TfrxXMLItem

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.ParseItem(TfrxXMLItem) Method

Summary

Represents method ParseItem(TfrxXMLItem).

Namespace: frxGPXFileFormat
Syntax
Delphi
protected
 procedure ParseItem(XMLItem: TfrxXMLItem);

Parameters

XMLItem
Type: TfrxXMLItem

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile Fields

Fields
Name | Description
FTracks | Represents field FTracks.
FValidBounds | Represents field FValidBounds.
FWayPoints | Represents field FWayPoints.
FXmax | Represents field FXmax.
FXmin | Represents field FXmin.
FYmax | Represents field FYmax.
FYmin | Represents field FYmin.
Top


TGPXFile.FTracks Field

Summary

Represents field FTracks.

Namespace: frxGPXFileFormat
Syntax
Delphi
protected
 FTracks: TObjectList;

Field Value

Type: TObjectList

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.FValidBounds Field

Summary

Represents field FValidBounds.

Namespace: frxGPXFileFormat
Syntax
Delphi
protected
 FValidBounds: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.FWayPoints Field

Summary

Represents field FWayPoints.

Namespace: frxGPXFileFormat
Syntax
Delphi
protected
 FWayPoints: TObjectList;

Field Value

Type: TObjectList

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.FXmax Field

Summary

Represents field FXmax.

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 FXmax: Double;

Field Value

Type: Double

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.FXmin Field

Summary

Represents field FXmin.

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 FXmin: Double;

Field Value

Type: Double

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.FYmax Field

Summary

Represents field FYmax.

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 FYmax: Double;

Field Value

Type: Double

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXFile.FYmin Field

Summary

Represents field FYmin.

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 FYmin: Double;

Field Value

Type: Double

See Also

Reference

  • TGPXFile
  • frxGPXFileFormat


TGPXTrack Class

Summary

Represents type TGPXTrack.

Namespace: frxGPXFileFormat
Inheritance Hierarchy
TObject
frxMapHelpers.TTaggedElement
frxGPXFileFormat.TGPXTrack
Syntax
Delphi
type
 TGPXTrack = class(TTaggedElement)
 end;

The TGPXTrack type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TGPXTrack class.
Destroy | Represents the destructor of the TGPXTrack class. (Overrides TTaggedElement.Destroy.)
Top
Properties
Show:
Name | Description
Count | Represents property Count.
ShapeType | Represents property ShapeType.
Tags | Represents property Tags. (Inherited from TTaggedElement.)
Top
Methods
Show:
Name | Description
AddTag(String,String) | Represents method AddTag(String,String). (Inherited from TTaggedElement.)
GetCount | Represents method GetCount.
GetSegmentPoints(Integer,TDoublePointArray) | Represents method GetSegmentPoints(Integer,TDoublePointArray).
GetShapeType | Represents method GetShapeType.
IsHaveAllTags(TStrings) | Represents method IsHaveAllTags(TStrings). (Inherited from TTaggedElement.)
IsHaveAnyTag(TStrings) | Represents method IsHaveAnyTag(TStrings). (Inherited from TTaggedElement.)
Top
Fields
Show:
Name | Description
FTags | Represents field FTags. (Inherited from TTaggedElement.)
FTrackSegments | Represents field FTrackSegments.
Top
See Also

Reference

  • frxGPXFileFormat


TGPXTrack Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TGPXTrack class.
Destroy | Represents the destructor of the TGPXTrack class. (Overrides TTaggedElement.Destroy.)
Top


TGPXTrack.Create Constructor

Summary

Initializes a new instance of the TGPXTrack class.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TGPXTrack
  • frxGPXFileFormat


TGPXTrack.Destroy Destructor

Summary

Represents the destructor of the TGPXTrack class.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TTaggedElement.Destroy
See Also

Reference

  • TGPXTrack
  • frxGPXFileFormat


TGPXTrack Properties

Properties
Name | Description
Count | Represents property Count.
ShapeType | Represents property ShapeType.
Top


TGPXTrack.Count Property

Summary

Represents property Count.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 property Count: integer read GetCount;

Property Value

Type: integer

See Also

Reference

  • TGPXTrack
  • frxGPXFileFormat


TGPXTrack.ShapeType Property

Summary

Represents property ShapeType.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 property ShapeType: TShapeType read GetShapeType;

Property Value

Type: TShapeType

See Also

Reference

  • TGPXTrack
  • frxGPXFileFormat


TGPXTrack Methods

Methods
Name | Description
GetCount | Represents method GetCount.
GetSegmentPoints(Integer,TDoublePointArray) | Represents method GetSegmentPoints(Integer,TDoublePointArray).
GetShapeType | Represents method GetShapeType.
Top


TGPXTrack.GetCount Method

Summary

Represents method GetCount.

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 function GetCount: integer;

Return Value

Type: integer

See Also

Reference

  • TGPXTrack
  • frxGPXFileFormat


TGPXTrack.GetSegmentPoints(Integer,TDoublePointArray) Method

Summary

Represents method GetSegmentPoints(Integer,TDoublePointArray).

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 procedure GetSegmentPoints(iTrackSegment: Integer; out DPA: TDoublePointArray);

Parameters

iTrackSegment
Type: Integer

DPA
Type: TDoublePointArray

See Also

Reference

  • TGPXTrack
  • frxGPXFileFormat


TGPXTrack.GetShapeType Method

Summary

Represents method GetShapeType.

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 function GetShapeType: TShapeType;

Return Value

Type: TShapeType

See Also

Reference

  • TGPXTrack
  • frxGPXFileFormat


TGPXTrack Fields

Fields
Name | Description
FTrackSegments | Represents field FTrackSegments.
Top


TGPXTrack.FTrackSegments Field

Summary

Represents field FTrackSegments.

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 FTrackSegments: TObjectList;

Field Value

Type: TObjectList

See Also

Reference

  • TGPXTrack
  • frxGPXFileFormat


TGPXTrackSegment Class

Summary

Represents type TGPXTrackSegment.

Namespace: frxGPXFileFormat
Inheritance Hierarchy
TObject
frxMapHelpers.TTaggedElement
frxGPXFileFormat.TGPXTrackSegment
Syntax
Delphi
type
 TGPXTrackSegment = class(TTaggedElement)
 end;

The TGPXTrackSegment type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TGPXTrackSegment class.
Destroy | Represents the destructor of the TGPXTrackSegment class. (Overrides TTaggedElement.Destroy.)
Top
Properties
Show:
Name | Description
Tags | Represents property Tags. (Inherited from TTaggedElement.)
Top
Methods
Show:
Name | Description
AddTag(String,String) | Represents method AddTag(String,String). (Inherited from TTaggedElement.)
GetSegmentPoints(TDoublePointArray) | Represents method GetSegmentPoints(TDoublePointArray).
IsHaveAllTags(TStrings) | Represents method IsHaveAllTags(TStrings). (Inherited from TTaggedElement.)
IsHaveAnyTag(TStrings) | Represents method IsHaveAnyTag(TStrings). (Inherited from TTaggedElement.)
Top
Fields
Show:
Name | Description
FTags | Represents field FTags. (Inherited from TTaggedElement.)
FTrackPoints | Represents field FTrackPoints.
Top
See Also

Reference

  • frxGPXFileFormat


TGPXTrackSegment Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TGPXTrackSegment class.
Destroy | Represents the destructor of the TGPXTrackSegment class. (Overrides TTaggedElement.Destroy.)
Top


TGPXTrackSegment.Create Constructor

Summary

Initializes a new instance of the TGPXTrackSegment class.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TGPXTrackSegment
  • frxGPXFileFormat


TGPXTrackSegment.Destroy Destructor

Summary

Represents the destructor of the TGPXTrackSegment class.

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TTaggedElement.Destroy
See Also

Reference

  • TGPXTrackSegment
  • frxGPXFileFormat


TGPXTrackSegment Methods

Methods
Name | Description
GetSegmentPoints(TDoublePointArray) | Represents method GetSegmentPoints(TDoublePointArray).
Top


TGPXTrackSegment.GetSegmentPoints(TDoublePointArray) Method

Summary

Represents method GetSegmentPoints(TDoublePointArray).

Namespace: frxGPXFileFormat
Syntax
Delphi
public
 procedure GetSegmentPoints(out DPA: TDoublePointArray);

Parameters

DPA
Type: TDoublePointArray

See Also

Reference

  • TGPXTrackSegment
  • frxGPXFileFormat


TGPXTrackSegment Fields

Fields
Name | Description
FTrackPoints | Represents field FTrackPoints.
Top


TGPXTrackSegment.FTrackPoints Field

Summary

Represents field FTrackPoints.

Namespace: frxGPXFileFormat
Syntax
Delphi
private
 FTrackPoints: TObjectList;

Field Value

Type: TObjectList

See Also

Reference

  • TGPXTrackSegment
  • frxGPXFileFormat


frxGradient Namespace

Summary

Represents namespace frxGradient.

Classes
Name | Description
TfrxGradientObject | The TfrxGradientObject allows the use of the Gradient component in your report. TfrxGradientObject is an empty component. It is used to add the frxGradient.pas file to the "uses" list. The main component is TfrxGradientView.
TfrxGradientView | The TfrxGradientView component represents a gradient fill. Deprecated, use Object.Fill instead of TfrxGradientView.
Top


frxGradient Classes

Classes
Name | Description
TfrxGradientObject | The TfrxGradientObject allows the use of the Gradient component in your report. TfrxGradientObject is an empty component. It is used to add the frxGradient.pas file to the "uses" list. The main component is TfrxGradientView.
TfrxGradientView | The TfrxGradientView component represents a gradient fill. Deprecated, use Object.Fill instead of TfrxGradientView.
Top


TfrxGradientObject Class

Summary

The TfrxGradientObject allows the use of the Gradient component in your report. TfrxGradientObject is an empty component. It is used to add the frxGradient.pas file to the "uses" list. The main component is TfrxGradientView.

Namespace: frxGradient
Inheritance Hierarchy
TComponent
frxGradient.TfrxGradientObject
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxGradientObject = class(TComponent);
See Also

Reference

  • frxGradient


TfrxGradientView Class

Summary

The TfrxGradientView component represents a gradient fill. Deprecated, use Object.Fill instead of TfrxGradientView.

Namespace: frxGradient
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxGradient.TfrxGradientView
Syntax
Delphi
type
 TfrxGradientView = class(TfrxView)
 end;

The TfrxGradientView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxGradientView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BeginColor | Begin color of the gradient.
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Object's cursor (in the preview mode). (Inherited from TfrxView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
EndColor | End color of the gradient.
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
Style | Style of the gradient.
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawGradient(Integer,Integer,Integer,Integer) | Represents method DrawGradient(Integer,Integer,Integer,Integer).
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColor | Represents method GetColor.
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxReportComponent.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetColor(TColor) | Represents method SetColor(TColor).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FBeginColor | Represents field FBeginColor.
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FEndColor | Represents field FEndColor.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStyle | Represents field FStyle.
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxGradient


TfrxGradientView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxGradientView class. (Overrides TfrxView.Create(TComponent).)
Top


TfrxGradientView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxGradientView class.

Namespace: frxGradient
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxView.Create(TComponent)
See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView Properties

Properties
Name | Description
BeginColor | Begin color of the gradient.
Color | Represents property Color.
EndColor | End color of the gradient.
Frame | Represents property Frame.
Style | Style of the gradient.
Top


TfrxGradientView.BeginColor Property

Summary

Begin color of the gradient.

Namespace: frxGradient
Syntax
Delphi
published
 property BeginColor: TColor read FBeginColor write FBeginColor default clWhite;

Property Value

Type: TColor

See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView.Color Property

Summary

Represents property Color.

Namespace: frxGradient
Syntax
Delphi
published
 property Color: TColor read GetColor write SetColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView.EndColor Property

Summary

End color of the gradient.

Namespace: frxGradient
Syntax
Delphi
published
 property EndColor: TColor read FEndColor write FEndColor default clGray;

Property Value

Type: TColor

See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView.Frame Property

Summary

Represents property Frame.

Namespace: frxGradient
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView.Style Property

Summary

Style of the gradient.

Namespace: frxGradient
Syntax
Delphi
published
 property Style: TfrxGradientStyle read FStyle write FStyle;

Property Value

Type: TfrxGradientStyle

See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView Methods

Methods
Name | Description
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawGradient(Integer,Integer,Integer,Integer) | Represents method DrawGradient(Integer,Integer,Integer,Integer).
GetColor | Represents method GetColor.
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
SetColor(TColor) | Represents method SetColor(TColor).
Top


TfrxGradientView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxGradient
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView.DrawGradient(Integer,Integer,Integer,Integer) Method

Summary

Represents method DrawGradient(Integer,Integer,Integer,Integer).

Namespace: frxGradient
Syntax
Delphi
private
 procedure DrawGradient(X, Y, X1, Y1: Integer);

Parameters

X
Type: Integer

Y
Type: Integer

X1
Type: Integer

Y1
Type: Integer

See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView.GetColor Method

Summary

Represents method GetColor.

Namespace: frxGradient
Syntax
Delphi
private
 function GetColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxGradient
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxGradient
Syntax
Delphi
private
 procedure SetColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView Fields

Fields
Name | Description
FBeginColor | Represents field FBeginColor.
FEndColor | Represents field FEndColor.
FStyle | Represents field FStyle.
Top


TfrxGradientView.FBeginColor Field

Summary

Represents field FBeginColor.

Namespace: frxGradient
Syntax
Delphi
private
 FBeginColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView.FEndColor Field

Summary

Represents field FEndColor.

Namespace: frxGradient
Syntax
Delphi
private
 FEndColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxGradientView
  • frxGradient


TfrxGradientView.FStyle Field

Summary

Represents field FStyle.

Namespace: frxGradient
Syntax
Delphi
private
 FStyle: TfrxGradientStyle;

Field Value

Type: TfrxGradientStyle

See Also

Reference

  • TfrxGradientView
  • frxGradient


frxGraphicControls Namespace

Summary

Represents namespace frxGraphicControls.

Classes
Name | Description
TfrxSwitchButtonsPanel | Represents type TfrxSwitchButtonsPanel.
TfrxSwithcButton | Represents type TfrxSwithcButton.
Top
Enumerations
Name | Description
TfrxSwithcButtonStyle | Represents type TfrxSwithcButtonStyle.
Top


frxGraphicControls Classes

Classes
Name | Description
TfrxSwitchButtonsPanel | Represents type TfrxSwitchButtonsPanel.
TfrxSwithcButton | Represents type TfrxSwithcButton.
Top


TfrxSwitchButtonsPanel Class

Summary

Represents type TfrxSwitchButtonsPanel.

Namespace: frxGraphicControls
Inheritance Hierarchy
TObject
frxGraphicControls.TfrxSwitchButtonsPanel
Syntax
Delphi
type
 TfrxSwitchButtonsPanel = class
 end;

The TfrxSwitchButtonsPanel type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxSwitchButtonsPanel class.
Destroy | Represents the destructor of the TfrxSwitchButtonsPanel class.
Top
Properties
Show:
Name | Description
Button[Integer] | Represents property Button[Integer].
OnButtonClick | Represents property OnButtonClick.
ShowCaption | Represents property ShowCaption.
ShowColors | Represents property ShowColors.
Top
Methods
Show:
Name | Description
AddButton(String) | Represents method AddButton(String).
CalcHeight | Represents method CalcHeight.
CalcWidth | Represents method CalcWidth.
Clear | Represents method Clear.
Count | Represents method Count.
DoClick(Integer,Integer) | Represents method DoClick(Integer,Integer).
Draw(TCanvas,Integer,Integer) | Represents method Draw(TCanvas,Integer,Integer).
GetButton(Integer) | Represents method GetButton(Integer).
IsButtonClicked(Integer,Integer) | Represents method IsButtonClicked(Integer,Integer).
SetButtonsHeight(Integer) | Represents method SetButtonsHeight(Integer).
SetShowCaption(Boolean) | Represents method SetShowCaption(Boolean).
SetShowColors(Boolean) | Represents method SetShowColors(Boolean).
Top
Fields
Show:
Name | Description
FBackColor | Represents field FBackColor.
FButtonOffsetX | Represents field FButtonOffsetX.
FButtonOffsetY | Represents field FButtonOffsetY.
FButtons | Represents field FButtons.
FButtonsHeight | Represents field FButtonsHeight.
FColorRectGap | Represents field FColorRectGap.
FColorRectWidth | Represents field FColorRectWidth.
FFont | Represents field FFont.
FOnButtonClick | Represents field FOnButtonClick.
FShowCaption | Represents field FShowCaption.
FShowColors | Represents field FShowColors.
FSwitchOffStyle | Represents field FSwitchOffStyle.
FSwitchOnStyle | Represents field FSwitchOnStyle.
FTextWidth | Represents field FTextWidth.
Top
See Also

Reference

  • frxGraphicControls


TfrxSwitchButtonsPanel Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxSwitchButtonsPanel class.
Destroy | Represents the destructor of the TfrxSwitchButtonsPanel class.
Top


TfrxSwitchButtonsPanel.Create Constructor

Summary

Initializes a new instance of the TfrxSwitchButtonsPanel class.

Namespace: frxGraphicControls
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.Destroy Destructor

Summary

Represents the destructor of the TfrxSwitchButtonsPanel class.

Namespace: frxGraphicControls
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel Properties

Properties
Name | Description
Button[Integer] | Represents property Button[Integer].
OnButtonClick | Represents property OnButtonClick.
ShowCaption | Represents property ShowCaption.
ShowColors | Represents property ShowColors.
Top


TfrxSwitchButtonsPanel.Button[Integer] Property

Summary

Represents property Button[Integer].

Namespace: frxGraphicControls
Syntax
Delphi
public
 property Button[Index: Integer]: TfrxSwithcButton read GetButton; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxSwithcButton

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.OnButtonClick Property

Summary

Represents property OnButtonClick.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property OnButtonClick: TNotifyEvent read FOnButtonClick write FOnButtonClick;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.ShowCaption Property

Summary

Represents property ShowCaption.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property ShowCaption: Boolean read FShowCaption write SetShowCaption;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.ShowColors Property

Summary

Represents property ShowColors.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property ShowColors: Boolean read FShowColors write SetShowColors;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel Methods

Methods
Name | Description
AddButton(String) | Represents method AddButton(String).
CalcHeight | Represents method CalcHeight.
CalcWidth | Represents method CalcWidth.
Clear | Represents method Clear.
Count | Represents method Count.
DoClick(Integer,Integer) | Represents method DoClick(Integer,Integer).
Draw(TCanvas,Integer,Integer) | Represents method Draw(TCanvas,Integer,Integer).
GetButton(Integer) | Represents method GetButton(Integer).
IsButtonClicked(Integer,Integer) | Represents method IsButtonClicked(Integer,Integer).
SetButtonsHeight(Integer) | Represents method SetButtonsHeight(Integer).
SetShowCaption(Boolean) | Represents method SetShowCaption(Boolean).
SetShowColors(Boolean) | Represents method SetShowColors(Boolean).
Top


TfrxSwitchButtonsPanel.AddButton(String) Method

Summary

Represents method AddButton(String).

Namespace: frxGraphicControls
Syntax
Delphi
public
 function AddButton(sCaption: String): TfrxSwithcButton;

Parameters

sCaption
Type: String

Return Value

Type: TfrxSwithcButton

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.CalcHeight Method

Summary

Represents method CalcHeight.

Namespace: frxGraphicControls
Syntax
Delphi
public
 function CalcHeight: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.CalcWidth Method

Summary

Represents method CalcWidth.

Namespace: frxGraphicControls
Syntax
Delphi
public
 function CalcWidth: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.Clear Method

Summary

Represents method Clear.

Namespace: frxGraphicControls
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.Count Method

Summary

Represents method Count.

Namespace: frxGraphicControls
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.DoClick(Integer,Integer) Method

Summary

Represents method DoClick(Integer,Integer).

Namespace: frxGraphicControls
Syntax
Delphi
public
 function DoClick(X, Y: Integer): TfrxSwithcButton;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TfrxSwithcButton

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.Draw(TCanvas,Integer,Integer) Method

Summary

Represents method Draw(TCanvas,Integer,Integer).

Namespace: frxGraphicControls
Syntax
Delphi
public
 procedure Draw(aCanvas: TCanvas; aLeft, aTop: Integer);

Parameters

aCanvas
Type: TCanvas

aLeft
Type: Integer

aTop
Type: Integer

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.GetButton(Integer) Method

Summary

Represents method GetButton(Integer).

Namespace: frxGraphicControls
Syntax
Delphi
private
 function GetButton(Index: Integer): TfrxSwithcButton;

Parameters

Index
Type: Integer

Return Value

Type: TfrxSwithcButton

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.IsButtonClicked(Integer,Integer) Method

Summary

Represents method IsButtonClicked(Integer,Integer).

Namespace: frxGraphicControls
Syntax
Delphi
public
 function IsButtonClicked(X, Y: Integer): TfrxSwithcButton;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TfrxSwithcButton

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.SetButtonsHeight(Integer) Method

Summary

Represents method SetButtonsHeight(Integer).

Namespace: frxGraphicControls
Syntax
Delphi
public
 procedure SetButtonsHeight(Height: Integer);

Parameters

Height
Type: Integer

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.SetShowCaption(Boolean) Method

Summary

Represents method SetShowCaption(Boolean).

Namespace: frxGraphicControls
Syntax
Delphi
private
 procedure SetShowCaption(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.SetShowColors(Boolean) Method

Summary

Represents method SetShowColors(Boolean).

Namespace: frxGraphicControls
Syntax
Delphi
private
 procedure SetShowColors(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel Fields

Fields
Name | Description
FBackColor | Represents field FBackColor.
FButtonOffsetX | Represents field FButtonOffsetX.
FButtonOffsetY | Represents field FButtonOffsetY.
FButtons | Represents field FButtons.
FButtonsHeight | Represents field FButtonsHeight.
FColorRectGap | Represents field FColorRectGap.
FColorRectWidth | Represents field FColorRectWidth.
FFont | Represents field FFont.
FOnButtonClick | Represents field FOnButtonClick.
FShowCaption | Represents field FShowCaption.
FShowColors | Represents field FShowColors.
FSwitchOffStyle | Represents field FSwitchOffStyle.
FSwitchOnStyle | Represents field FSwitchOnStyle.
FTextWidth | Represents field FTextWidth.
Top


TfrxSwitchButtonsPanel.FBackColor Field

Summary

Represents field FBackColor.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FBackColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FButtonOffsetX Field

Summary

Represents field FButtonOffsetX.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FButtonOffsetX: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FButtonOffsetY Field

Summary

Represents field FButtonOffsetY.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FButtonOffsetY: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FButtons Field

Summary

Represents field FButtons.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FButtons: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FButtonsHeight Field

Summary

Represents field FButtonsHeight.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FButtonsHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FColorRectGap Field

Summary

Represents field FColorRectGap.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FColorRectGap: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FColorRectWidth Field

Summary

Represents field FColorRectWidth.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FColorRectWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FFont Field

Summary

Represents field FFont.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FFont: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FOnButtonClick Field

Summary

Represents field FOnButtonClick.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FOnButtonClick: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FShowCaption Field

Summary

Represents field FShowCaption.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FShowCaption: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FShowColors Field

Summary

Represents field FShowColors.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FShowColors: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FSwitchOffStyle Field

Summary

Represents field FSwitchOffStyle.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FSwitchOffStyle: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FSwitchOnStyle Field

Summary

Represents field FSwitchOnStyle.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FSwitchOnStyle: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwitchButtonsPanel.FTextWidth Field

Summary

Represents field FTextWidth.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FTextWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSwitchButtonsPanel
  • frxGraphicControls


TfrxSwithcButton Class

Summary

Represents type TfrxSwithcButton.

Namespace: frxGraphicControls
Inheritance Hierarchy
TObject
frxGraphicControls.TfrxSwithcButton
Syntax
Delphi
type
 TfrxSwithcButton = Class
 end;

The TfrxSwithcButton type exposes the following members.

Constructors
Show:
Name | Description
Create | Overloaded. Initializes a new instance of the TfrxSwithcButton class.
Create(TBitmap,TBitmap) | Overloaded. Initializes a new instance of the TfrxSwithcButton class.
Destroy | Represents the destructor of the TfrxSwithcButton class.
Top
Properties
Show:
Name | Description
BackColor | Represents property BackColor.
ButtonColor | Represents property ButtonColor.
ColorTag | Represents property ColorTag.
FillActivateColor | Represents property FillActivateColor.
FillDeactivateColor | Represents property FillDeactivateColor.
FrameColor | Represents property FrameColor.
Height | Represents property Height.
Switch | Represents property Switch.
Tag | Represents property Tag.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
Draw(TCanvas,Integer,Integer) | Represents method Draw(TCanvas,Integer,Integer).
SetBackColor(TColor) | Represents method SetBackColor(TColor).
SetFillActivateColor(TColor) | Represents method SetFillActivateColor(TColor).
SetFillDeactivateColor(TColor) | Represents method SetFillDeactivateColor(TColor).
SetFrameColor(TColor) | Represents method SetFrameColor(TColor).
SetOriginHeight(Integer) | Represents method SetOriginHeight(Integer).
SetSwitch(Boolean) | Represents method SetSwitch(Boolean).
Top
Fields
Show:
Name | Description
FBackColor | Represents field FBackColor.
FBitmap | Represents field FBitmap.
FButtonColor | Represents field FButtonColor.
FColorTag | Represents field FColorTag.
FFillActivateColor | Represents field FFillActivateColor.
FFillDeactivateColor | Represents field FFillDeactivateColor.
FFrameColor | Represents field FFrameColor.
FFrameWidth | Represents field FFrameWidth.
FHeight | Represents field FHeight.
FNeedUpdate | Represents field FNeedUpdate.
FOffStyleBitmap | Represents field FOffStyleBitmap.
FOnStyleBitmap | Represents field FOnStyleBitmap.
FOriginHeight | Represents field FOriginHeight.
FOriginWidth | Represents field FOriginWidth.
FSwitch | Represents field FSwitch.
FTag | Represents field FTag.
FWidth | Represents field FWidth.
Top
See Also

Reference

  • frxGraphicControls


TfrxSwithcButton Constructors

Constructors
Name | Description
Create | Overloaded. Initializes a new instance of the TfrxSwithcButton class.
Create(TBitmap,TBitmap) | Overloaded. Initializes a new instance of the TfrxSwithcButton class.
Destroy | Represents the destructor of the TfrxSwithcButton class.
Top


TfrxSwithcButton.Create Constructor

Summary

Initializes a new instance of the TfrxSwithcButton class.

Namespace: frxGraphicControls
Syntax
Delphi
public
 constructor Create; overload;
See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.Create(TBitmap,TBitmap) Constructor

Summary

Initializes a new instance of the TfrxSwithcButton class.

Namespace: frxGraphicControls
Syntax
Delphi
public
 constructor Create(aOnStyleBitmap: TBitmap; aOffStyleBitmap: TBitmap); overload;

Parameters

aOnStyleBitmap
Type: TBitmap

aOffStyleBitmap
Type: TBitmap

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.Destroy Destructor

Summary

Represents the destructor of the TfrxSwithcButton class.

Namespace: frxGraphicControls
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton Properties

Properties
Name | Description
BackColor | Represents property BackColor.
ButtonColor | Represents property ButtonColor.
ColorTag | Represents property ColorTag.
FillActivateColor | Represents property FillActivateColor.
FillDeactivateColor | Represents property FillDeactivateColor.
FrameColor | Represents property FrameColor.
Height | Represents property Height.
Switch | Represents property Switch.
Tag | Represents property Tag.
Width | Represents property Width.
Top


TfrxSwithcButton.BackColor Property

Summary

Represents property BackColor.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property BackColor: TColor read FBackColor write SetBackColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.ButtonColor Property

Summary

Represents property ButtonColor.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property ButtonColor: TColor read FButtonColor write FButtonColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.ColorTag Property

Summary

Represents property ColorTag.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property ColorTag: TColor read FColorTag write FColorTag;

Property Value

Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FillActivateColor Property

Summary

Represents property FillActivateColor.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property FillActivateColor: TColor read FFillActivateColor write SetFillActivateColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FillDeactivateColor Property

Summary

Represents property FillDeactivateColor.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property FillDeactivateColor: TColor read FFillDeactivateColor write SetFillDeactivateColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FrameColor Property

Summary

Represents property FrameColor.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property FrameColor: TColor read FFrameColor write SetFrameColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.Height Property

Summary

Represents property Height.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property Height: Integer read FOriginHeight write SetOriginHeight;

Property Value

Type: Integer

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.Switch Property

Summary

Represents property Switch.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property Switch: Boolean read FSwitch write SetSwitch;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.Tag Property

Summary

Represents property Tag.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property Tag: Integer read FTag write FTag;

Property Value

Type: Integer

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.Width Property

Summary

Represents property Width.

Namespace: frxGraphicControls
Syntax
Delphi
public
 property Width: Integer read FOriginWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton Methods

Methods
Name | Description
Draw(TCanvas,Integer,Integer) | Represents method Draw(TCanvas,Integer,Integer).
SetBackColor(TColor) | Represents method SetBackColor(TColor).
SetFillActivateColor(TColor) | Represents method SetFillActivateColor(TColor).
SetFillDeactivateColor(TColor) | Represents method SetFillDeactivateColor(TColor).
SetFrameColor(TColor) | Represents method SetFrameColor(TColor).
SetOriginHeight(Integer) | Represents method SetOriginHeight(Integer).
SetSwitch(Boolean) | Represents method SetSwitch(Boolean).
Top


TfrxSwithcButton.Draw(TCanvas,Integer,Integer) Method

Summary

Represents method Draw(TCanvas,Integer,Integer).

Namespace: frxGraphicControls
Syntax
Delphi
public
 procedure Draw(aCanvas: TCanvas; aLeft, aTop: Integer);

Parameters

aCanvas
Type: TCanvas

aLeft
Type: Integer

aTop
Type: Integer

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.SetBackColor(TColor) Method

Summary

Represents method SetBackColor(TColor).

Namespace: frxGraphicControls
Syntax
Delphi
private
 procedure SetBackColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.SetFillActivateColor(TColor) Method

Summary

Represents method SetFillActivateColor(TColor).

Namespace: frxGraphicControls
Syntax
Delphi
private
 procedure SetFillActivateColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.SetFillDeactivateColor(TColor) Method

Summary

Represents method SetFillDeactivateColor(TColor).

Namespace: frxGraphicControls
Syntax
Delphi
private
 procedure SetFillDeactivateColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.SetFrameColor(TColor) Method

Summary

Represents method SetFrameColor(TColor).

Namespace: frxGraphicControls
Syntax
Delphi
private
 procedure SetFrameColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.SetOriginHeight(Integer) Method

Summary

Represents method SetOriginHeight(Integer).

Namespace: frxGraphicControls
Syntax
Delphi
private
 procedure SetOriginHeight(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.SetSwitch(Boolean) Method

Summary

Represents method SetSwitch(Boolean).

Namespace: frxGraphicControls
Syntax
Delphi
private
 procedure SetSwitch(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton Fields

Fields
Name | Description
FBackColor | Represents field FBackColor.
FBitmap | Represents field FBitmap.
FButtonColor | Represents field FButtonColor.
FColorTag | Represents field FColorTag.
FFillActivateColor | Represents field FFillActivateColor.
FFillDeactivateColor | Represents field FFillDeactivateColor.
FFrameColor | Represents field FFrameColor.
FFrameWidth | Represents field FFrameWidth.
FHeight | Represents field FHeight.
FNeedUpdate | Represents field FNeedUpdate.
FOffStyleBitmap | Represents field FOffStyleBitmap.
FOnStyleBitmap | Represents field FOnStyleBitmap.
FOriginHeight | Represents field FOriginHeight.
FOriginWidth | Represents field FOriginWidth.
FSwitch | Represents field FSwitch.
FTag | Represents field FTag.
FWidth | Represents field FWidth.
Top


TfrxSwithcButton.FBackColor Field

Summary

Represents field FBackColor.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FBackColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FBitmap Field

Summary

Represents field FBitmap.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FBitmap: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FButtonColor Field

Summary

Represents field FButtonColor.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FButtonColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FColorTag Field

Summary

Represents field FColorTag.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FColorTag: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FFillActivateColor Field

Summary

Represents field FFillActivateColor.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FFillActivateColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FFillDeactivateColor Field

Summary

Represents field FFillDeactivateColor.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FFillDeactivateColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FFrameColor Field

Summary

Represents field FFrameColor.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FFrameColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FFrameWidth Field

Summary

Represents field FFrameWidth.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FFrameWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FHeight Field

Summary

Represents field FHeight.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FNeedUpdate Field

Summary

Represents field FNeedUpdate.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FNeedUpdate: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FOffStyleBitmap Field

Summary

Represents field FOffStyleBitmap.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FOffStyleBitmap: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FOnStyleBitmap Field

Summary

Represents field FOnStyleBitmap.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FOnStyleBitmap: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FOriginHeight Field

Summary

Represents field FOriginHeight.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FOriginHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FOriginWidth Field

Summary

Represents field FOriginWidth.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FOriginWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FSwitch Field

Summary

Represents field FSwitch.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FSwitch: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FTag Field

Summary

Represents field FTag.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FTag: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


TfrxSwithcButton.FWidth Field

Summary

Represents field FWidth.

Namespace: frxGraphicControls
Syntax
Delphi
private
 FWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSwithcButton
  • frxGraphicControls


frxGraphicControls Enumerations

Enumerations
Name | Description
TfrxSwithcButtonStyle | Represents type TfrxSwithcButtonStyle.
Top


TfrxSwithcButtonStyle Enumeration

Summary

Represents type TfrxSwithcButtonStyle.

Namespace: frxGraphicControls
Syntax
Delphi
type
 TfrxSwithcButtonStyle = (sbOn, sbOff);

The TfrxSwithcButtonStyle type exposes the following members.

Members
Show:
Name | Description
sbOff | Represents constant sbOff.
sbOn | Represents constant sbOn.
Top
See Also

Reference

  • frxGraphicControls


frxGraphicUtils Namespace

Summary

Represents namespace frxGraphicUtils.

Classes
Name | Description
TfrxDrawText | Represents type TfrxDrawText.
TfrxHTMLTag | Represents type TfrxHTMLTag.
TfrxHTMLTags | Represents type TfrxHTMLTags.
TfrxHTMLTagsList | Represents type TfrxHTMLTagsList.
Top
Enumerations
Name | Description
TSubStyle | Represents type TSubStyle.
Top
Types
Name | Description
PIntArray | Represents a pointer type to TIntArray.
TIntArray | Represents an array of the Integer type.
Top
Variables
Name | Description
frxDrawText | Represents variable frxDrawText.
Top
Routines
Name | Description
frxCreateRotatedFont(TFont,Integer) | Represents method frxCreateRotatedFont(TFont,Integer).
Top


frxGraphicUtils Classes

Classes
Name | Description
TfrxDrawText | Represents type TfrxDrawText.
TfrxHTMLTag | Represents type TfrxHTMLTag.
TfrxHTMLTags | Represents type TfrxHTMLTags.
TfrxHTMLTagsList | Represents type TfrxHTMLTagsList.
Top


TfrxDrawText Class

Summary

Represents type TfrxDrawText.

Namespace: frxGraphicUtils
Inheritance Hierarchy
TObject
frxGraphicUtils.TfrxDrawText
Syntax
Delphi
type
 TfrxDrawText = class(TObject)
 end;

The TfrxDrawText type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxDrawText class.
Destroy | Represents the destructor of the TfrxDrawText class.
Top
Properties
Show:
Name | Description
Canvas | Represents property Canvas.
DefPPI | Represents property DefPPI.
ScrPPI | Represents property ScrPPI.
Text | Represents property Text.
UseDefaultCharset | Represents property UseDefaultCharset.
UseMonoFont | Represents property UseMonoFont.
UseOldLineHeight | Represents property UseOldLineHeight.
VC | Represents property VC.
WrappedText | Represents property WrappedText.
Top
Methods
Show:
Name | Description
CalcHeight | Represents method CalcHeight.
CalcWidth | Represents method CalcWidth.
DeleteTags(WideString) | Represents method DeleteTags(WideString).
DrawText(TCanvas,TfrxHAlign,TfrxVAlign,TfrxUnderlinesTextMode) | Represents method DrawText(TCanvas,TfrxHAlign,TfrxVAlign,TfrxUnderlinesTextMode).
DrawTextLine(TCanvas,WideString,Integer,Integer,Integer,Integer,TfrxHAlign,HFont,HFont) | Represents method DrawTextLine(TCanvas,WideString,Integer,Integer,Integer,Integer,TfrxHAlign,HFont,HFont).
FreeTempArray | Represents method FreeTempArray.
GetFontHeight(TCanvas) | Represents method GetFontHeight(TCanvas).
GetFontHeightMetric(TCanvas) | Represents method GetFontHeightMetric(TCanvas).
GetInBoundsText | Represents method GetInBoundsText.
GetOutBoundsText(Boolean) | Represents method GetOutBoundsText(Boolean).
GetWrappedText | Represents method GetWrappedText.
IsPrinter(TCanvas) | Represents method IsPrinter(TCanvas).
LineHeight | Represents method LineHeight.
Lock | Represents method Lock.
LockCanvas | Represents method LockCanvas.
ReallocTempArray(Integer) | Represents method ReallocTempArray(Integer).
SetDimensions(Extended,Extended,Extended,TRect,TRect) | Represents method SetDimensions(Extended,Extended,Extended,TRect,TRect).
SetFont(TFont) | Represents method SetFont(TFont).
SetGaps(Extended,Extended,Extended) | Represents method SetGaps(Extended,Extended,Extended).
SetOptions(Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Integer) | Represents method SetOptions(Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Integer).
SetParaBreaks(Boolean,Boolean) | Represents method SetParaBreaks(Boolean,Boolean).
SetText(TWideStrings,Boolean) | Represents method SetText(TWideStrings,Boolean).
TextHeight | Represents method TextHeight.
Unlock | Represents method Unlock.
UnlockCanvas | Represents method UnlockCanvas.
UnusedSpace | Represents method UnusedSpace.
WrapTextLine(WideString,Integer,Integer,Integer) | Represents method WrapTextLine(WideString,Integer,Integer,Integer).
Top
Fields
Show:
Name | Description
FBMP | Represents field FBMP.
FCanvas | Represents field FCanvas.
FCharSpacing | Represents field FCharSpacing.
FDefPPI | Represents field FDefPPI.
FFontSize | Represents field FFontSize.
FHTMLTags | Represents field FHTMLTags.
FLineSpacing | Represents field FLineSpacing.
FMonoFont | Represents field FMonoFont.
FOptions | Represents field FOptions.
FOriginalRect | Represents field FOriginalRect.
FParagraphGap | Represents field FParagraphGap.
FPlainText | Represents field FPlainText.
FPrintScale | Represents field FPrintScale.
FRotation | Represents field FRotation.
FRTLReading | Represents field FRTLReading.
FScaledRect | Represents field FScaledRect.
FScaleX | Represents field FScaleX.
FScaleY | Represents field FScaleY.
FScrPPI | Represents field FScrPPI.
FTempArray | Represents field FTempArray.
FTempArraySize | Represents field FTempArraySize.
FText | Represents field FText.
FUseDefaultCharset | Represents field FUseDefaultCharset.
FUseOldLineHeight | Represents field FUseOldLineHeight.
FVC | Represents field FVC.
FWordBreak | Represents field FWordBreak.
FWordWrap | Represents field FWordWrap.
FWysiwyg | Represents field FWysiwyg.
Top
See Also

Reference

  • frxGraphicUtils


TfrxDrawText Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxDrawText class.
Destroy | Represents the destructor of the TfrxDrawText class.
Top


TfrxDrawText.Create Constructor

Summary

Initializes a new instance of the TfrxDrawText class.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.Destroy Destructor

Summary

Represents the destructor of the TfrxDrawText class.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText Properties

Properties
Name | Description
Canvas | Represents property Canvas.
DefPPI | Represents property DefPPI.
ScrPPI | Represents property ScrPPI.
Text | Represents property Text.
UseDefaultCharset | Represents property UseDefaultCharset.
UseMonoFont | Represents property UseMonoFont.
UseOldLineHeight | Represents property UseOldLineHeight.
VC | Represents property VC.
WrappedText | Represents property WrappedText.
Top


TfrxDrawText.Canvas Property

Summary

Represents property Canvas.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property Canvas: TCanvas read FCanvas;

Property Value

Type: TCanvas

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.DefPPI Property

Summary

Represents property DefPPI.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property DefPPI: Integer read FDefPPI;

Property Value

Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.ScrPPI Property

Summary

Represents property ScrPPI.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property ScrPPI: Integer read FScrPPI;

Property Value

Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.Text Property

Summary

Represents property Text.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property Text: TWideStrings read FText;

Property Value

Type: TWideStrings

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.UseDefaultCharset Property

Summary

Represents property UseDefaultCharset.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property UseDefaultCharset: Boolean read FUseDefaultCharset write FUseDefaultCharset;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.UseMonoFont Property

Summary

Represents property UseMonoFont.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property UseMonoFont: Boolean read FMonoFont write FMonoFont;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.UseOldLineHeight Property

Summary

Represents property UseOldLineHeight.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property UseOldLineHeight: Boolean read FUseOldLineHeight write FUseOldLineHeight;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.VC Property

Summary

Represents property VC.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property VC: TVectorCanvas read FVC write FVC;

Property Value

Type: TVectorCanvas

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.WrappedText Property

Summary

Represents property WrappedText.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property WrappedText: WideString read GetWrappedText;

Property Value

Type: WideString

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText Methods

Methods
Name | Description
CalcHeight | Represents method CalcHeight.
CalcWidth | Represents method CalcWidth.
DeleteTags(WideString) | Represents method DeleteTags(WideString).
DrawText(TCanvas,TfrxHAlign,TfrxVAlign,TfrxUnderlinesTextMode) | Represents method DrawText(TCanvas,TfrxHAlign,TfrxVAlign,TfrxUnderlinesTextMode).
DrawTextLine(TCanvas,WideString,Integer,Integer,Integer,Integer,TfrxHAlign,HFont,HFont) | Represents method DrawTextLine(TCanvas,WideString,Integer,Integer,Integer,Integer,TfrxHAlign,HFont,HFont).
FreeTempArray | Represents method FreeTempArray.
GetFontHeight(TCanvas) | Represents method GetFontHeight(TCanvas).
GetFontHeightMetric(TCanvas) | Represents method GetFontHeightMetric(TCanvas).
GetInBoundsText | Represents method GetInBoundsText.
GetOutBoundsText(Boolean) | Represents method GetOutBoundsText(Boolean).
GetWrappedText | Represents method GetWrappedText.
IsPrinter(TCanvas) | Represents method IsPrinter(TCanvas).
LineHeight | Represents method LineHeight.
Lock | Represents method Lock.
LockCanvas | Represents method LockCanvas.
ReallocTempArray(Integer) | Represents method ReallocTempArray(Integer).
SetDimensions(Extended,Extended,Extended,TRect,TRect) | Represents method SetDimensions(Extended,Extended,Extended,TRect,TRect).
SetFont(TFont) | Represents method SetFont(TFont).
SetGaps(Extended,Extended,Extended) | Represents method SetGaps(Extended,Extended,Extended).
SetOptions(Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Integer) | Represents method SetOptions(Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Integer).
SetParaBreaks(Boolean,Boolean) | Represents method SetParaBreaks(Boolean,Boolean).
SetText(TWideStrings,Boolean) | Represents method SetText(TWideStrings,Boolean).
TextHeight | Represents method TextHeight.
Unlock | Represents method Unlock.
UnlockCanvas | Represents method UnlockCanvas.
UnusedSpace | Represents method UnusedSpace.
WrapTextLine(WideString,Integer,Integer,Integer) | Represents method WrapTextLine(WideString,Integer,Integer,Integer).
Top


TfrxDrawText.CalcHeight Method

Summary

Represents method CalcHeight.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 function CalcHeight: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.CalcWidth Method

Summary

Represents method CalcWidth.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 function CalcWidth: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.DeleteTags(WideString) Method

Summary

Represents method DeleteTags(WideString).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 function DeleteTags(const Txt: WideString): WideString;

Parameters

Txt
Type: WideString

Return Value

Type: WideString

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.DrawText(TCanvas,TfrxHAlign,TfrxVAlign,TfrxUnderlinesTextMode) Method

Summary

Represents method DrawText(TCanvas,TfrxHAlign,TfrxVAlign,TfrxUnderlinesTextMode).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure DrawText(C: TCanvas; HAlign: TfrxHAlign; VAlign: TfrxVAlign; UnderlinesTextMode: TfrxUnderlinesTextMode = ulmNone);

Parameters

C
Type: TCanvas

HAlign
Type: TfrxHAlign

VAlign
Type: TfrxVAlign

UnderlinesTextMode
Type: TfrxUnderlinesTextMode

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.DrawTextLine(TCanvas,WideString,Integer,Integer,Integer,Integer,TfrxHAlign,HFont,HFont) Method

Summary

Represents method DrawTextLine(TCanvas,WideString,Integer,Integer,Integer,Integer,TfrxHAlign,HFont,HFont).

Namespace: frxGraphicUtils
Syntax
Delphi
private
 procedure DrawTextLine(C: TCanvas; const s: WideString;
 X, Y, DX, LineIndex: Integer; Align: TfrxHAlign; var fh, oldfh: HFont);

Parameters

C
Type: TCanvas

s
Type: WideString

X
Type: Integer

Y
Type: Integer

DX
Type: Integer

LineIndex
Type: Integer

Align
Type: TfrxHAlign

fh
Type: HFont

oldfh
Type: HFont

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FreeTempArray Method

Summary

Represents method FreeTempArray.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 procedure FreeTempArray;
See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.GetFontHeight(TCanvas) Method

Summary

Represents method GetFontHeight(TCanvas).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 function GetFontHeight(aCanvas: TCanvas): Integer;

Parameters

aCanvas
Type: TCanvas

Return Value

Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.GetFontHeightMetric(TCanvas) Method

Summary

Represents method GetFontHeightMetric(TCanvas).

Namespace: frxGraphicUtils
Syntax
Delphi
private
 function GetFontHeightMetric(aCanvas: TCanvas): Integer;

Parameters

aCanvas
Type: TCanvas

Return Value

Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.GetInBoundsText Method

Summary

Represents method GetInBoundsText.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 function GetInBoundsText: WideString;

Return Value

Type: WideString

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.GetOutBoundsText(Boolean) Method

Summary

Represents method GetOutBoundsText(Boolean).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 function GetOutBoundsText(var ParaBreak: Boolean): WideString;

Parameters

ParaBreak
Type: Boolean

Return Value

Type: WideString

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.GetWrappedText Method

Summary

Represents method GetWrappedText.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 function GetWrappedText: WideString;

Return Value

Type: WideString

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.IsPrinter(TCanvas) Method

Summary

Represents method IsPrinter(TCanvas).

Namespace: frxGraphicUtils
Syntax
Delphi
private
 function IsPrinter(C: TCanvas): Boolean;

Parameters

C
Type: TCanvas

Return Value

Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.LineHeight Method

Summary

Represents method LineHeight.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 function LineHeight: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.Lock Method

Summary

Represents method Lock.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure Lock;
See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.LockCanvas Method

Summary

Represents method LockCanvas.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure LockCanvas;
See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.ReallocTempArray(Integer) Method

Summary

Represents method ReallocTempArray(Integer).

Namespace: frxGraphicUtils
Syntax
Delphi
private
 procedure ReallocTempArray(ANewSize: Integer);

Parameters

ANewSize
Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.SetDimensions(Extended,Extended,Extended,TRect,TRect) Method

Summary

Represents method SetDimensions(Extended,Extended,Extended,TRect,TRect).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure SetDimensions(ScaleX, ScaleY, PrintScale: Extended;
 OriginalRect, ScaledRect: TRect);

Parameters

ScaleX
Type: Extended

ScaleY
Type: Extended

PrintScale
Type: Extended

OriginalRect
Type: TRect

ScaledRect
Type: TRect

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.SetFont(TFont) Method

Summary

Represents method SetFont(TFont).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure SetFont(Font: TFont);

Parameters

Font
Type: TFont

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.SetGaps(Extended,Extended,Extended) Method

Summary

Represents method SetGaps(Extended,Extended,Extended).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure SetGaps(ParagraphGap, CharSpacing, LineSpacing: Extended);

Parameters

ParagraphGap
Type: Extended

CharSpacing
Type: Extended

LineSpacing
Type: Extended

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.SetOptions(Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Integer) Method

Summary

Represents method SetOptions(Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Integer).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure SetOptions(WordWrap, HTMLTags, RTLReading, WordBreak,
 Clipped, Wysiwyg: Boolean; Rotation: Integer);

Parameters

WordWrap
Type: Boolean

HTMLTags
Type: Boolean

RTLReading
Type: Boolean

WordBreak
Type: Boolean

Clipped
Type: Boolean

Wysiwyg
Type: Boolean

Rotation
Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.SetParaBreaks(Boolean,Boolean) Method

Summary

Represents method SetParaBreaks(Boolean,Boolean).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure SetParaBreaks(FirstParaBreak, LastParaBreak: Boolean);

Parameters

FirstParaBreak
Type: Boolean

LastParaBreak
Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.SetText(TWideStrings,Boolean) Method

Summary

Represents method SetText(TWideStrings,Boolean).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure SetText(Text: TWideStrings; FirstParaBreak: Boolean = False);

Parameters

Text
Type: TWideStrings

FirstParaBreak
Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.TextHeight Method

Summary

Represents method TextHeight.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 function TextHeight: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.Unlock Method

Summary

Represents method Unlock.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure Unlock;
See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.UnlockCanvas Method

Summary

Represents method UnlockCanvas.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure UnlockCanvas;
See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.UnusedSpace Method

Summary

Represents method UnusedSpace.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 function UnusedSpace: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.WrapTextLine(WideString,Integer,Integer,Integer) Method

Summary

Represents method WrapTextLine(WideString,Integer,Integer,Integer).

Namespace: frxGraphicUtils
Syntax
Delphi
private
 procedure WrapTextLine(s: WideString; Width, FirstLineWidth,
 CharSpacing: Integer);

Parameters

s
Type: WideString

Width
Type: Integer

FirstLineWidth
Type: Integer

CharSpacing
Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText Fields

Fields
Name | Description
FBMP | Represents field FBMP.
FCanvas | Represents field FCanvas.
FCharSpacing | Represents field FCharSpacing.
FDefPPI | Represents field FDefPPI.
FFontSize | Represents field FFontSize.
FHTMLTags | Represents field FHTMLTags.
FLineSpacing | Represents field FLineSpacing.
FMonoFont | Represents field FMonoFont.
FOptions | Represents field FOptions.
FOriginalRect | Represents field FOriginalRect.
FParagraphGap | Represents field FParagraphGap.
FPlainText | Represents field FPlainText.
FPrintScale | Represents field FPrintScale.
FRotation | Represents field FRotation.
FRTLReading | Represents field FRTLReading.
FScaledRect | Represents field FScaledRect.
FScaleX | Represents field FScaleX.
FScaleY | Represents field FScaleY.
FScrPPI | Represents field FScrPPI.
FTempArray | Represents field FTempArray.
FTempArraySize | Represents field FTempArraySize.
FText | Represents field FText.
FUseDefaultCharset | Represents field FUseDefaultCharset.
FUseOldLineHeight | Represents field FUseOldLineHeight.
FVC | Represents field FVC.
FWordBreak | Represents field FWordBreak.
FWordWrap | Represents field FWordWrap.
FWysiwyg | Represents field FWysiwyg.
Top


TfrxDrawText.FBMP Field

Summary

Represents field FBMP.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FBMP: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FCanvas Field

Summary

Represents field FCanvas.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FCanvas: TCanvas;

Field Value

Type: TCanvas

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FCharSpacing Field

Summary

Represents field FCharSpacing.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FCharSpacing: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FDefPPI Field

Summary

Represents field FDefPPI.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FDefPPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FFontSize Field

Summary

Represents field FFontSize.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FFontSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FHTMLTags Field

Summary

Represents field FHTMLTags.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FHTMLTags: TfrxHTMLTagsList;

Field Value

Type: TfrxHTMLTagsList

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FLineSpacing Field

Summary

Represents field FLineSpacing.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FLineSpacing: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FMonoFont Field

Summary

Represents field FMonoFont.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FMonoFont: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FOptions Field

Summary

Represents field FOptions.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FOptions: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FOriginalRect Field

Summary

Represents field FOriginalRect.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FOriginalRect: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FParagraphGap Field

Summary

Represents field FParagraphGap.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FParagraphGap: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FPlainText Field

Summary

Represents field FPlainText.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FPlainText: WideString;

Field Value

Type: WideString

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FPrintScale Field

Summary

Represents field FPrintScale.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FPrintScale: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FRotation Field

Summary

Represents field FRotation.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FRotation: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FRTLReading Field

Summary

Represents field FRTLReading.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FRTLReading: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FScaledRect Field

Summary

Represents field FScaledRect.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FScaledRect: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FScaleX Field

Summary

Represents field FScaleX.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FScaleX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FScaleY Field

Summary

Represents field FScaleY.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FScaleY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FScrPPI Field

Summary

Represents field FScrPPI.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FScrPPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FTempArray Field

Summary

Represents field FTempArray.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FTempArray: PIntArray;

Field Value

Type: PIntArray

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FTempArraySize Field

Summary

Represents field FTempArraySize.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FTempArraySize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FText Field

Summary

Represents field FText.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FText: TWideStrings;

Field Value

Type: TWideStrings

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FUseDefaultCharset Field

Summary

Represents field FUseDefaultCharset.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FUseDefaultCharset: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FUseOldLineHeight Field

Summary

Represents field FUseOldLineHeight.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FUseOldLineHeight: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FVC Field

Summary

Represents field FVC.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FVC: TVectorCanvas;

Field Value

Type: TVectorCanvas

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FWordBreak Field

Summary

Represents field FWordBreak.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FWordBreak: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FWordWrap Field

Summary

Represents field FWordWrap.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FWordWrap: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxDrawText.FWysiwyg Field

Summary

Represents field FWysiwyg.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FWysiwyg: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDrawText
  • frxGraphicUtils


TfrxHTMLTag Class

Summary

Represents type TfrxHTMLTag.

Namespace: frxGraphicUtils
Inheritance Hierarchy
TObject
frxGraphicUtils.TfrxHTMLTag
Syntax
Delphi
type
 TfrxHTMLTag = class(TObject)
 end;

The TfrxHTMLTag type exposes the following members.

Methods
Show:
Name | Description
Assign(TfrxHTMLTag) | Represents method Assign(TfrxHTMLTag).
Top
Fields
Show:
Name | Description
AddY | Represents field AddY.
Color | Represents field Color.
Default | Represents field Default.
DontWRAP | Represents field DontWRAP.
Position | Represents field Position.
Size | Represents field Size.
Small | Represents field Small.
Style | Represents field Style.
SubType | Represents field SubType.
Top
See Also

Reference

  • frxGraphicUtils


TfrxHTMLTag Methods

Methods
Name | Description
Assign(TfrxHTMLTag) | Represents method Assign(TfrxHTMLTag).
Top


TfrxHTMLTag.Assign(TfrxHTMLTag) Method

Summary

Represents method Assign(TfrxHTMLTag).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure Assign(Tag: TfrxHTMLTag);

Parameters

Tag
Type: TfrxHTMLTag

See Also

Reference

  • TfrxHTMLTag
  • frxGraphicUtils


TfrxHTMLTag Fields

Fields
Name | Description
AddY | Represents field AddY.
Color | Represents field Color.
Default | Represents field Default.
DontWRAP | Represents field DontWRAP.
Position | Represents field Position.
Size | Represents field Size.
Small | Represents field Small.
Style | Represents field Style.
SubType | Represents field SubType.
Top


TfrxHTMLTag.AddY Field

Summary

Represents field AddY.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 AddY: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxHTMLTag
  • frxGraphicUtils


TfrxHTMLTag.Color Field

Summary

Represents field Color.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 Color: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxHTMLTag
  • frxGraphicUtils


TfrxHTMLTag.Default Field

Summary

Represents field Default.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 Default: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxHTMLTag
  • frxGraphicUtils


TfrxHTMLTag.DontWRAP Field

Summary

Represents field DontWRAP.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 DontWRAP: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxHTMLTag
  • frxGraphicUtils


TfrxHTMLTag.Position Field

Summary

Represents field Position.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 Position: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxHTMLTag
  • frxGraphicUtils


TfrxHTMLTag.Size Field

Summary

Represents field Size.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 Size: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxHTMLTag
  • frxGraphicUtils


TfrxHTMLTag.Small Field

Summary

Represents field Small.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 Small: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxHTMLTag
  • frxGraphicUtils


TfrxHTMLTag.Style Field

Summary

Represents field Style.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 Style: TFontStyles;

Field Value

Type: TFontStyles

See Also

Reference

  • TfrxHTMLTag
  • frxGraphicUtils


TfrxHTMLTag.SubType Field

Summary

Represents field SubType.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 SubType: TSubStyle;

Field Value

Type: TSubStyle

See Also

Reference

  • TfrxHTMLTag
  • frxGraphicUtils


TfrxHTMLTags Class

Summary

Represents type TfrxHTMLTags.

Namespace: frxGraphicUtils
Inheritance Hierarchy
TObject
frxGraphicUtils.TfrxHTMLTags
Syntax
Delphi
type
 TfrxHTMLTags = class(TObject)
 end;

The TfrxHTMLTags type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxHTMLTags class.
Destroy | Represents the destructor of the TfrxHTMLTags class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add(TfrxHTMLTag) | Represents method Add(TfrxHTMLTag).
Clear | Represents method Clear.
Count | Represents method Count.
GetItems(Integer) | Represents method GetItems(Integer).
Top
Fields
Show:
Name | Description
FItems | Represents field FItems.
Top
See Also

Reference

  • frxGraphicUtils


TfrxHTMLTags Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxHTMLTags class.
Destroy | Represents the destructor of the TfrxHTMLTags class.
Top


TfrxHTMLTags.Create Constructor

Summary

Initializes a new instance of the TfrxHTMLTags class.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxHTMLTags
  • frxGraphicUtils


TfrxHTMLTags.Destroy Destructor

Summary

Represents the destructor of the TfrxHTMLTags class.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxHTMLTags
  • frxGraphicUtils


TfrxHTMLTags Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxHTMLTags.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxHTMLTag read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxHTMLTag

See Also

Reference

  • TfrxHTMLTags
  • frxGraphicUtils


TfrxHTMLTags Methods

Methods
Name | Description
Add(TfrxHTMLTag) | Represents method Add(TfrxHTMLTag).
Clear | Represents method Clear.
Count | Represents method Count.
GetItems(Integer) | Represents method GetItems(Integer).
Top


TfrxHTMLTags.Add(TfrxHTMLTag) Method

Summary

Represents method Add(TfrxHTMLTag).

Namespace: frxGraphicUtils
Syntax
Delphi
private
 procedure Add(Tag: TfrxHTMLTag);

Parameters

Tag
Type: TfrxHTMLTag

See Also

Reference

  • TfrxHTMLTags
  • frxGraphicUtils


TfrxHTMLTags.Clear Method

Summary

Represents method Clear.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxHTMLTags
  • frxGraphicUtils


TfrxHTMLTags.Count Method

Summary

Represents method Count.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxHTMLTags
  • frxGraphicUtils


TfrxHTMLTags.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxGraphicUtils
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxHTMLTag;

Parameters

Index
Type: Integer

Return Value

Type: TfrxHTMLTag

See Also

Reference

  • TfrxHTMLTags
  • frxGraphicUtils


TfrxHTMLTags Fields

Fields
Name | Description
FItems | Represents field FItems.
Top


TfrxHTMLTags.FItems Field

Summary

Represents field FItems.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FItems: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxHTMLTags
  • frxGraphicUtils


TfrxHTMLTagsList Class

Summary

Represents type TfrxHTMLTagsList.

Namespace: frxGraphicUtils
Inheritance Hierarchy
TObject
frxGraphicUtils.TfrxHTMLTagsList
Syntax
Delphi
type
 TfrxHTMLTagsList = class(TObject)
 end;

The TfrxHTMLTagsList type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxHTMLTagsList class.
Destroy | Represents the destructor of the TfrxHTMLTagsList class.
Top
Properties
Show:
Name | Description
AllowTags | Represents property AllowTags.
Items[Integer] | Represents property Items[Integer].
Position | Represents property Position.
Top
Methods
Show:
Name | Description
Add | Represents method Add.
Clear | Represents method Clear.
Count | Represents method Count.
ExpandHTMLTags(WideString) | Represents method ExpandHTMLTags(WideString).
FillCharSpacingArray(PIntArray,WideString,TCanvas,Integer,Integer,Boolean,Boolean) | Represents method FillCharSpacingArray(PIntArray,WideString,TCanvas,Integer,Integer,Boolean,Boolean).
FreeTempArray | Represents method FreeTempArray.
GetItems(Integer) | Represents method GetItems(Integer).
GetPrevTag | Represents method GetPrevTag.
NewLine | Represents method NewLine.
ReallocTempArray(Integer) | Represents method ReallocTempArray(Integer).
SetDefaults(TColor,Integer,TFontStyles) | Represents method SetDefaults(TColor,Integer,TFontStyles).
Wrap(Integer,Boolean) | Represents method Wrap(Integer,Boolean).
Top
Fields
Show:
Name | Description
FAddY | Represents field FAddY.
FAllowTags | Represents field FAllowTags.
FColor | Represents field FColor.
FDefColor | Represents field FDefColor.
FDefSize | Represents field FDefSize.
FDefStyle | Represents field FDefStyle.
FDontWRAP | Represents field FDontWRAP.
FItems | Represents field FItems.
FPosition | Represents field FPosition.
FSize | Represents field FSize.
FStyle | Represents field FStyle.
FSubStyle | Represents field FSubStyle.
FTempArray | Represents field FTempArray.
FTempArraySize | Represents field FTempArraySize.
Top
See Also

Reference

  • frxGraphicUtils


TfrxHTMLTagsList Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxHTMLTagsList class.
Destroy | Represents the destructor of the TfrxHTMLTagsList class.
Top


TfrxHTMLTagsList.Create Constructor

Summary

Initializes a new instance of the TfrxHTMLTagsList class.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.Destroy Destructor

Summary

Represents the destructor of the TfrxHTMLTagsList class.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList Properties

Properties
Name | Description
AllowTags | Represents property AllowTags.
Items[Integer] | Represents property Items[Integer].
Position | Represents property Position.
Top


TfrxHTMLTagsList.AllowTags Property

Summary

Represents property AllowTags.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property AllowTags: Boolean read FAllowTags write FAllowTags;

Property Value

Type: Boolean

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxHTMLTags read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxHTMLTags

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.Position Property

Summary

Represents property Position.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 property Position: Integer read FPosition write FPosition;

Property Value

Type: Integer

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList Methods

Methods
Name | Description
Add | Represents method Add.
Clear | Represents method Clear.
Count | Represents method Count.
ExpandHTMLTags(WideString) | Represents method ExpandHTMLTags(WideString).
FillCharSpacingArray(PIntArray,WideString,TCanvas,Integer,Integer,Boolean,Boolean) | Represents method FillCharSpacingArray(PIntArray,WideString,TCanvas,Integer,Integer,Boolean,Boolean).
FreeTempArray | Represents method FreeTempArray.
GetItems(Integer) | Represents method GetItems(Integer).
GetPrevTag | Represents method GetPrevTag.
NewLine | Represents method NewLine.
ReallocTempArray(Integer) | Represents method ReallocTempArray(Integer).
SetDefaults(TColor,Integer,TFontStyles) | Represents method SetDefaults(TColor,Integer,TFontStyles).
Wrap(Integer,Boolean) | Represents method Wrap(Integer,Boolean).
Top


TfrxHTMLTagsList.Add Method

Summary

Represents method Add.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 function Add: TfrxHTMLTag;

Return Value

Type: TfrxHTMLTag

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.Clear Method

Summary

Represents method Clear.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.Count Method

Summary

Represents method Count.

Namespace: frxGraphicUtils
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.ExpandHTMLTags(WideString) Method

Summary

Represents method ExpandHTMLTags(WideString).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure ExpandHTMLTags(var s: WideString);

Parameters

s
Type: WideString

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FillCharSpacingArray(PIntArray,WideString,TCanvas,Integer,Integer,Boolean,Boolean) Method

Summary

Represents method FillCharSpacingArray(PIntArray,WideString,TCanvas,Integer,Integer,Boolean,Boolean).

Namespace: frxGraphicUtils
Syntax
Delphi
private
 function FillCharSpacingArray(var ar: PIntArray; const s: WideString;
 Canvas: TCanvas; LineIndex, Add: Integer; Convert: Boolean; DefCharset: Boolean): Integer;

Parameters

ar
Type: PIntArray

s
Type: WideString

Canvas
Type: TCanvas

LineIndex
Type: Integer

Add
Type: Integer

Convert
Type: Boolean

DefCharset
Type: Boolean

Return Value

Type: Integer

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FreeTempArray Method

Summary

Represents method FreeTempArray.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 procedure FreeTempArray;
See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxGraphicUtils
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxHTMLTags;

Parameters

Index
Type: Integer

Return Value

Type: TfrxHTMLTags

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.GetPrevTag Method

Summary

Represents method GetPrevTag.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 function GetPrevTag: TfrxHTMLTag;

Return Value

Type: TfrxHTMLTag

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.NewLine Method

Summary

Represents method NewLine.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 procedure NewLine;
See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.ReallocTempArray(Integer) Method

Summary

Represents method ReallocTempArray(Integer).

Namespace: frxGraphicUtils
Syntax
Delphi
private
 procedure ReallocTempArray(ANewSize: Integer);

Parameters

ANewSize
Type: Integer

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.SetDefaults(TColor,Integer,TFontStyles) Method

Summary

Represents method SetDefaults(TColor,Integer,TFontStyles).

Namespace: frxGraphicUtils
Syntax
Delphi
public
 procedure SetDefaults(DefColor: TColor; DefSize: Integer;
 DefStyle: TFontStyles);

Parameters

DefColor
Type: TColor

DefSize
Type: Integer

DefStyle
Type: TFontStyles

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.Wrap(Integer,Boolean) Method

Summary

Represents method Wrap(Integer,Boolean).

Namespace: frxGraphicUtils
Syntax
Delphi
private
 procedure Wrap(TagsCount: Integer; AddBreak: Boolean);

Parameters

TagsCount
Type: Integer

AddBreak
Type: Boolean

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList Fields

Fields
Name | Description
FAddY | Represents field FAddY.
FAllowTags | Represents field FAllowTags.
FColor | Represents field FColor.
FDefColor | Represents field FDefColor.
FDefSize | Represents field FDefSize.
FDefStyle | Represents field FDefStyle.
FDontWRAP | Represents field FDontWRAP.
FItems | Represents field FItems.
FPosition | Represents field FPosition.
FSize | Represents field FSize.
FStyle | Represents field FStyle.
FSubStyle | Represents field FSubStyle.
FTempArray | Represents field FTempArray.
FTempArraySize | Represents field FTempArraySize.
Top


TfrxHTMLTagsList.FAddY Field

Summary

Represents field FAddY.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FAddY: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FAllowTags Field

Summary

Represents field FAllowTags.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FAllowTags: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FColor Field

Summary

Represents field FColor.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FColor: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FDefColor Field

Summary

Represents field FDefColor.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FDefColor: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FDefSize Field

Summary

Represents field FDefSize.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FDefSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FDefStyle Field

Summary

Represents field FDefStyle.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FDefStyle: TFontStyles;

Field Value

Type: TFontStyles

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FDontWRAP Field

Summary

Represents field FDontWRAP.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FDontWRAP: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FItems Field

Summary

Represents field FItems.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FItems: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FPosition Field

Summary

Represents field FPosition.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FPosition: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FSize Field

Summary

Represents field FSize.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FStyle Field

Summary

Represents field FStyle.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FStyle: TFontStyles;

Field Value

Type: TFontStyles

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FSubStyle Field

Summary

Represents field FSubStyle.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FSubStyle: TSubStyle;

Field Value

Type: TSubStyle

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FTempArray Field

Summary

Represents field FTempArray.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FTempArray: PIntArray;

Field Value

Type: PIntArray

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


TfrxHTMLTagsList.FTempArraySize Field

Summary

Represents field FTempArraySize.

Namespace: frxGraphicUtils
Syntax
Delphi
private
 FTempArraySize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxHTMLTagsList
  • frxGraphicUtils


frxGraphicUtils Enumerations

Enumerations
Name | Description
TSubStyle | Represents type TSubStyle.
Top


TSubStyle Enumeration

Summary

Represents type TSubStyle.

Namespace: frxGraphicUtils
Syntax
Delphi
type
 TSubStyle = (ssNormal, ssSubscript, ssSuperscript);

The TSubStyle type exposes the following members.

Members
Show:
Name | Description
ssNormal | Represents constant ssNormal.
ssSubscript | Represents constant ssSubscript.
ssSuperscript | Represents constant ssSuperscript.
Top
See Also

Reference

  • frxGraphicUtils


frxGraphicUtils Types

Types
Name | Description
PIntArray | Represents a pointer type to TIntArray.
TIntArray | Represents an array of the Integer type.
Top


PIntArray Type

Summary

Represents a pointer type to TIntArray.

Namespace: frxGraphicUtils
Syntax
Delphi
type
 PIntArray = ^TIntArray;
See Also

Reference

  • frxGraphicUtils


TIntArray Type

Summary

Represents an array of the Integer type.

Namespace: frxGraphicUtils
Syntax
Delphi
type
 TIntArray = array[0..MaxInt div 4 - 1] of Integer;
See Also

Reference

  • frxGraphicUtils


frxGraphicUtils Variables

Variables
Name | Description
frxDrawText | Represents variable frxDrawText.
Top


frxDrawText Variable

Summary

Represents variable frxDrawText.

Namespace: frxGraphicUtils
Syntax
Delphi
frxDrawText: TfrxDrawText;

Value

Type: TfrxDrawText

See Also

Reference

  • frxGraphicUtils


frxGraphicUtils Routines

Routines
Name | Description
frxCreateRotatedFont(TFont,Integer) | Represents method frxCreateRotatedFont(TFont,Integer).
Top


frxCreateRotatedFont(TFont,Integer) Method

Summary

Represents method frxCreateRotatedFont(TFont,Integer).

Namespace: frxGraphicUtils
Syntax
Delphi
 function frxCreateRotatedFont(Font: TFont; Rotation: Integer): HFont;

Parameters

Font
Type: TFont

Rotation
Type: Integer

Return Value

Type: HFont

See Also

Reference

  • frxGraphicUtils


frxGS1Databar Namespace

Summary

Represents namespace frxGS1Databar.

Classes
Name | Description
TfrxGS1Databar | Represents type TfrxGS1Databar.
TfrxGS1DatabarE | Represents type TfrxGS1DatabarE.
TfrxGS1DatabarES | Represents type TfrxGS1DatabarES.
Top


frxGS1Databar Classes

Classes
Name | Description
TfrxGS1Databar | Represents type TfrxGS1Databar.
TfrxGS1DatabarE | Represents type TfrxGS1DatabarE.
TfrxGS1DatabarES | Represents type TfrxGS1DatabarES.
Top


TfrxGS1Databar Class

Summary

Represents type TfrxGS1Databar.

Namespace: frxGS1Databar
Inheritance Hierarchy
TObject
frxBarcode2DBase.TfrxBarcode2DBase
frxBarcode2DBase.TfrxBarcode2DBaseWithUnion
frxGS1Databar.TfrxGS1Databar
frxGS1Databar.TfrxGS1DatabarE
frxGS1Databar.TfrxGS1DatabarES
Syntax
Delphi
type
 TfrxGS1Databar = class(TfrxBarcode2DBaseWithUnion)
 end;

The TfrxGS1Databar type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxGS1Databar class. (Overrides TfrxBarcode2DBaseWithUnion.Create.)
Destroy | Represents the destructor of the TfrxGS1Databar class. (Overrides TfrxBarcode2DBaseWithUnion.Destroy.)
Top
Properties
Show:
Name | Description
Color | Represents property Color. (Inherited from TfrxBarcode2DBase.)
ColorBar | Represents property ColorBar. (Inherited from TfrxBarcode2DBase.)
ErrorText | Represents property ErrorText. (Inherited from TfrxBarcode2DBase.)
Font | Represents property Font. (Inherited from TfrxBarcode2DBase.)
FontScaled | Represents property FontScaled. (Inherited from TfrxBarcode2DBase.)
Height | Represents property Height. (Inherited from TfrxBarcode2DBase.)
PixelHeight | Represents property PixelHeight. (Inherited from TfrxBarcode2DBase.)
PixelWidth | Represents property PixelWidth. (Inherited from TfrxBarcode2DBase.)
QuietZone | Represents property QuietZone. (Inherited from TfrxBarcode2DBase.)
Rotation | Represents property Rotation. (Inherited from TfrxBarcode2DBase.)
ShowText | Represents property ShowText. (Inherited from TfrxBarcode2DBase.)
Text | Represents property Text. (Inherited from TfrxBarcode2DBase.)
Width | Represents property Width. (Inherited from TfrxBarcode2DBase.)
Zoom | Represents property Zoom. (Inherited from TfrxBarcode2DBase.)
Top
Methods
Show:
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
ClearFigures | Represents method ClearFigures. (Inherited from TfrxBarcode2DBaseWithUnion.)
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer). (Inherited from TfrxBarcode2DBase.)
FillRect(TCanvas,TRect) | Represents method FillRect(TCanvas,TRect). (Inherited from TfrxBarcode2DBase.)
FVectorPrimitivesAdd(Integer,Integer,Integer,Integer) | Represents method FVectorPrimitivesAdd(Integer,Integer,Integer,Integer). (Inherited from TfrxBarcode2DBaseWithUnion.)
Generate(string,Boolean) | Represents method Generate(string,Boolean).
GetFooterHeight | Represents method GetFooterHeight. (Inherited from TfrxBarcode2DBase.)
GetHeight | Represents method GetHeight. (Overrides TfrxBarcode2DBase.GetHeight.)
GetWidth | Represents method GetWidth. (Inherited from TfrxBarcode2DBase.)
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended). (Overrides TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).)
IsScaled | Represents method IsScaled. (Overrides TfrxBarcode2DBase.IsScaled.)
RePaint | Represents method RePaint.
SetColor(TColor) | Represents method SetColor(TColor). (Inherited from TfrxBarcode2DBase.)
SetColorBar(TColor) | Represents method SetColorBar(TColor). (Inherited from TfrxBarcode2DBase.)
SetErrorText(String) | Represents method SetErrorText(String). (Inherited from TfrxBarcode2DBase.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxBarcode2DBase.)
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean). (Inherited from TfrxBarcode2DBase.)
SetHeight(Integer) | Represents method SetHeight(Integer). (Overrides TfrxBarcode2DBase.SetHeight(Integer).)
SetRotation(Integer) | Represents method SetRotation(Integer). (Inherited from TfrxBarcode2DBase.)
SetShowText(Boolean) | Represents method SetShowText(Boolean). (Inherited from TfrxBarcode2DBase.)
SetText(String) | Represents method SetText(String). (Inherited from TfrxBarcode2DBase.)
SetZoom(Extended) | Represents method SetZoom(Extended). (Inherited from TfrxBarcode2DBase.)
T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte) | Represents method T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte). (Inherited from TfrxBarcode2DBaseWithUnion.)
Top
Fields
Show:
Name | Description
base | Represents field base.
DotsL | Represents field DotsL. (Inherited from TfrxBarcode2DBaseWithUnion.)
DotsR | Represents field DotsR. (Inherited from TfrxBarcode2DBaseWithUnion.)
FColor | Represents field FColor. (Inherited from TfrxBarcode2DBase.)
FColorBar | Represents field FColorBar. (Inherited from TfrxBarcode2DBase.)
FErrorText | Represents field FErrorText. (Inherited from TfrxBarcode2DBase.)
FFont | Represents field FFont. (Inherited from TfrxBarcode2DBase.)
FFontScaled | Represents field FFontScaled. (Inherited from TfrxBarcode2DBase.)
FHeight | Represents field FHeight. (Inherited from TfrxBarcode2DBase.)
FOriginalHeight | Represents field FOriginalHeight.
FPixelHeight | Represents field FPixelHeight. (Inherited from TfrxBarcode2DBase.)
FPixelWidth | Represents field FPixelWidth. (Inherited from TfrxBarcode2DBase.)
FQuietZone | Represents field FQuietZone. (Inherited from TfrxBarcode2DBase.)
FRotation | Represents field FRotation. (Inherited from TfrxBarcode2DBase.)
FShowText | Represents field FShowText. (Inherited from TfrxBarcode2DBase.)
FText | Represents field FText. (Inherited from TfrxBarcode2DBase.)
FVectorPrimitives | Represents field FVectorPrimitives. (Inherited from TfrxBarcode2DBaseWithUnion.)
FWidth | Represents field FWidth. (Inherited from TfrxBarcode2DBase.)
FZoom | Represents field FZoom. (Inherited from TfrxBarcode2DBase.)
Top
See Also

Reference

  • frxGS1Databar


TfrxGS1Databar Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxGS1Databar class. (Overrides TfrxBarcode2DBaseWithUnion.Create.)
Destroy | Represents the destructor of the TfrxGS1Databar class. (Overrides TfrxBarcode2DBaseWithUnion.Destroy.)
Top


TfrxGS1Databar.Create Constructor

Summary

Initializes a new instance of the TfrxGS1Databar class.

Namespace: frxGS1Databar
Syntax
Delphi
public
 constructor Create; override;

Overrides

TfrxBarcode2DBaseWithUnion.Create
See Also

Reference

  • TfrxGS1Databar
  • frxGS1Databar


TfrxGS1Databar.Destroy Destructor

Summary

Represents the destructor of the TfrxGS1Databar class.

Namespace: frxGS1Databar
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxBarcode2DBaseWithUnion.Destroy
See Also

Reference

  • TfrxGS1Databar
  • frxGS1Databar


TfrxGS1Databar Methods

Methods
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
Generate(string,Boolean) | Represents method Generate(string,Boolean).
GetHeight | Represents method GetHeight. (Overrides TfrxBarcode2DBase.GetHeight.)
IsScaled | Represents method IsScaled. (Overrides TfrxBarcode2DBase.IsScaled.)
RePaint | Represents method RePaint.
SetHeight(Integer) | Represents method SetHeight(Integer). (Overrides TfrxBarcode2DBase.SetHeight(Integer).)
Top


TfrxGS1Databar.Assign(TfrxBarcode2DBase) Method

Summary

Represents method Assign(TfrxBarcode2DBase).

Namespace: frxGS1Databar
Syntax
Delphi
public
 procedure Assign(src: TfrxBarcode2DBase); override;

Parameters

src
Type: TfrxBarcode2DBase

Overrides

TfrxBarcode2DBase.Assign(TfrxBarcode2DBase)
See Also

Reference

  • TfrxGS1Databar
  • frxGS1Databar


TfrxGS1Databar.Generate(string,Boolean) Method

Summary

Represents method Generate(string,Boolean).

Namespace: frxGS1Databar
Syntax
Delphi
protected
 function Generate(Text: string; rebase: Boolean = True): Integer; Virtual; Abstract;

Parameters

Text
Type: string

rebase
Type: Boolean

Return Value

Type: Integer

See Also

Reference

  • TfrxGS1Databar
  • frxGS1Databar


TfrxGS1Databar.GetHeight Method

Summary

Represents method GetHeight.

Namespace: frxGS1Databar
Syntax
Delphi
protected
 function GetHeight: Integer; override;

Return Value

Type: Integer

Overrides

TfrxBarcode2DBase.GetHeight
See Also

Reference

  • TfrxGS1Databar
  • frxGS1Databar


TfrxGS1Databar.IsScaled Method

Summary

Represents method IsScaled.

Namespace: frxGS1Databar
Syntax
Delphi
public
 function IsScaled: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxBarcode2DBase.IsScaled
See Also

Reference

  • TfrxGS1Databar
  • frxGS1Databar


TfrxGS1Databar.RePaint Method

Summary

Represents method RePaint.

Namespace: frxGS1Databar
Syntax
Delphi
public
 procedure RePaint();
See Also

Reference

  • TfrxGS1Databar
  • frxGS1Databar


TfrxGS1Databar.SetHeight(Integer) Method

Summary

Represents method SetHeight(Integer).

Namespace: frxGS1Databar
Syntax
Delphi
protected
 procedure SetHeight(const Value: Integer); override;

Parameters

Value
Type: Integer

Overrides

TfrxBarcode2DBase.SetHeight(Integer)
See Also

Reference

  • TfrxGS1Databar
  • frxGS1Databar


TfrxGS1Databar Fields

Fields
Name | Description
base | Represents field base.
FOriginalHeight | Represents field FOriginalHeight.
Top


TfrxGS1Databar.base Field

Summary

Represents field base.

Namespace: frxGS1Databar
Syntax
Delphi
private
 base: TBaseDatabar;

Field Value

Type: TBaseDatabar

See Also

Reference

  • TfrxGS1Databar
  • frxGS1Databar


TfrxGS1Databar.FOriginalHeight Field

Summary

Represents field FOriginalHeight.

Namespace: frxGS1Databar
Syntax
Delphi
private
 FOriginalHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxGS1Databar
  • frxGS1Databar


TfrxGS1DatabarE Class

Summary

Represents type TfrxGS1DatabarE.

Namespace: frxGS1Databar
Inheritance Hierarchy
TObject
frxBarcode2DBase.TfrxBarcode2DBase
frxBarcode2DBase.TfrxBarcode2DBaseWithUnion
frxGS1Databar.TfrxGS1Databar
frxGS1Databar.TfrxGS1DatabarE
Syntax
Delphi
type
 TfrxGS1DatabarE = class(TfrxGS1Databar)
 end;

The TfrxGS1DatabarE type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxGS1DatabarE class. (Overrides TfrxGS1Databar.Create.)
Top
Properties
Show:
Name | Description
Color | Represents property Color. (Inherited from TfrxBarcode2DBase.)
ColorBar | Represents property ColorBar. (Inherited from TfrxBarcode2DBase.)
ErrorText | Represents property ErrorText. (Inherited from TfrxBarcode2DBase.)
Font | Represents property Font. (Inherited from TfrxBarcode2DBase.)
FontScaled | Represents property FontScaled. (Inherited from TfrxBarcode2DBase.)
Height | Represents property Height. (Inherited from TfrxBarcode2DBase.)
PixelHeight | Represents property PixelHeight. (Inherited from TfrxBarcode2DBase.)
PixelWidth | Represents property PixelWidth. (Inherited from TfrxBarcode2DBase.)
QuietZone | Represents property QuietZone. (Inherited from TfrxBarcode2DBase.)
Rotation | Represents property Rotation. (Inherited from TfrxBarcode2DBase.)
ShowText | Represents property ShowText. (Inherited from TfrxBarcode2DBase.)
Text | Represents property Text. (Inherited from TfrxBarcode2DBase.)
Width | Represents property Width. (Inherited from TfrxBarcode2DBase.)
Zoom | Represents property Zoom. (Inherited from TfrxBarcode2DBase.)
Top
Methods
Show:
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
ClearFigures | Represents method ClearFigures. (Inherited from TfrxBarcode2DBaseWithUnion.)
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer). (Inherited from TfrxBarcode2DBase.)
FillRect(TCanvas,TRect) | Represents method FillRect(TCanvas,TRect). (Inherited from TfrxBarcode2DBase.)
FVectorPrimitivesAdd(Integer,Integer,Integer,Integer) | Represents method FVectorPrimitivesAdd(Integer,Integer,Integer,Integer). (Inherited from TfrxBarcode2DBaseWithUnion.)
Generate(string,Boolean) | Represents method Generate(string,Boolean). (Overrides TfrxGS1Databar.Generate(string,Boolean).)
GetFooterHeight | Represents method GetFooterHeight. (Inherited from TfrxBarcode2DBase.)
GetHeight | Represents method GetHeight. (Overrides TfrxBarcode2DBase.GetHeight.)
GetWidth | Represents method GetWidth. (Inherited from TfrxBarcode2DBase.)
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended). (Overrides TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).)
IsScaled | Represents method IsScaled. (Overrides TfrxBarcode2DBase.IsScaled.)
RePaint | Represents method RePaint. (Inherited from TfrxGS1Databar.)
SetColor(TColor) | Represents method SetColor(TColor). (Inherited from TfrxBarcode2DBase.)
SetColorBar(TColor) | Represents method SetColorBar(TColor). (Inherited from TfrxBarcode2DBase.)
SetErrorText(String) | Represents method SetErrorText(String). (Inherited from TfrxBarcode2DBase.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxBarcode2DBase.)
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean). (Inherited from TfrxBarcode2DBase.)
SetHeight(Integer) | Represents method SetHeight(Integer). (Overrides TfrxBarcode2DBase.SetHeight(Integer).)
SetRotation(Integer) | Represents method SetRotation(Integer). (Inherited from TfrxBarcode2DBase.)
SetShowText(Boolean) | Represents method SetShowText(Boolean). (Inherited from TfrxBarcode2DBase.)
SetText(string) | Represents method SetText(string). (Overrides TfrxBarcode2DBase.SetText(String).)
SetZoom(Extended) | Represents method SetZoom(Extended). (Inherited from TfrxBarcode2DBase.)
T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte) | Represents method T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte). (Inherited from TfrxBarcode2DBaseWithUnion.)
Top
Fields
Show:
Name | Description
DotsL | Represents field DotsL. (Inherited from TfrxBarcode2DBaseWithUnion.)
DotsR | Represents field DotsR. (Inherited from TfrxBarcode2DBaseWithUnion.)
FColor | Represents field FColor. (Inherited from TfrxBarcode2DBase.)
FColorBar | Represents field FColorBar. (Inherited from TfrxBarcode2DBase.)
FErrorText | Represents field FErrorText. (Inherited from TfrxBarcode2DBase.)
FFont | Represents field FFont. (Inherited from TfrxBarcode2DBase.)
FFontScaled | Represents field FFontScaled. (Inherited from TfrxBarcode2DBase.)
FHeight | Represents field FHeight. (Inherited from TfrxBarcode2DBase.)
FPixelHeight | Represents field FPixelHeight. (Inherited from TfrxBarcode2DBase.)
FPixelWidth | Represents field FPixelWidth. (Inherited from TfrxBarcode2DBase.)
FQuietZone | Represents field FQuietZone. (Inherited from TfrxBarcode2DBase.)
FRotation | Represents field FRotation. (Inherited from TfrxBarcode2DBase.)
FShowText | Represents field FShowText. (Inherited from TfrxBarcode2DBase.)
FText | Represents field FText. (Inherited from TfrxBarcode2DBase.)
FVectorPrimitives | Represents field FVectorPrimitives. (Inherited from TfrxBarcode2DBaseWithUnion.)
FWidth | Represents field FWidth. (Inherited from TfrxBarcode2DBase.)
FZoom | Represents field FZoom. (Inherited from TfrxBarcode2DBase.)
Top
See Also

Reference

  • frxGS1Databar


TfrxGS1DatabarE Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxGS1DatabarE class. (Overrides TfrxGS1Databar.Create.)
Top


TfrxGS1DatabarE.Create Constructor

Summary

Initializes a new instance of the TfrxGS1DatabarE class.

Namespace: frxGS1Databar
Syntax
Delphi
public
 constructor Create; override;

Overrides

TfrxGS1Databar.Create
See Also

Reference

  • TfrxGS1DatabarE
  • frxGS1Databar


TfrxGS1DatabarE Methods

Methods
Name | Description
Generate(string,Boolean) | Represents method Generate(string,Boolean). (Overrides TfrxGS1Databar.Generate(string,Boolean).)
SetText(string) | Represents method SetText(string). (Overrides TfrxBarcode2DBase.SetText(String).)
Top


TfrxGS1DatabarE.Generate(string,Boolean) Method

Summary

Represents method Generate(string,Boolean).

Namespace: frxGS1Databar
Syntax
Delphi
protected
 function Generate(Text: string; rebase: Boolean = True): Integer; override;

Parameters

Text
Type: string

rebase
Type: Boolean

Return Value

Type: Integer

Overrides

TfrxGS1Databar.Generate(string,Boolean)
See Also

Reference

  • TfrxGS1DatabarE
  • frxGS1Databar


TfrxGS1DatabarE.SetText(string) Method

Summary

Represents method SetText(string).

Namespace: frxGS1Databar
Syntax
Delphi
public
 procedure SetText(v: string); override;

Parameters

v
Type: string

Overrides

TfrxBarcode2DBase.SetText(String)
See Also

Reference

  • TfrxGS1DatabarE
  • frxGS1Databar


TfrxGS1DatabarES Class

Summary

Represents type TfrxGS1DatabarES.

Namespace: frxGS1Databar
Inheritance Hierarchy
TObject
frxBarcode2DBase.TfrxBarcode2DBase
frxBarcode2DBase.TfrxBarcode2DBaseWithUnion
frxGS1Databar.TfrxGS1Databar
frxGS1Databar.TfrxGS1DatabarES
Syntax
Delphi
type
 TfrxGS1DatabarES = class(TfrxGS1Databar)
 end;

The TfrxGS1DatabarES type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxGS1DatabarES class. (Overrides TfrxGS1Databar.Create.)
Top
Properties
Show:
Name | Description
Color | Represents property Color. (Inherited from TfrxBarcode2DBase.)
ColorBar | Represents property ColorBar. (Inherited from TfrxBarcode2DBase.)
Columns | Represents property Columns.
ErrorText | Represents property ErrorText. (Inherited from TfrxBarcode2DBase.)
Font | Represents property Font. (Inherited from TfrxBarcode2DBase.)
FontScaled | Represents property FontScaled. (Inherited from TfrxBarcode2DBase.)
Height | Represents property Height. (Inherited from TfrxBarcode2DBase.)
PixelHeight | Represents property PixelHeight. (Inherited from TfrxBarcode2DBase.)
PixelWidth | Represents property PixelWidth. (Inherited from TfrxBarcode2DBase.)
QuietZone | Represents property QuietZone. (Inherited from TfrxBarcode2DBase.)
Rotation | Represents property Rotation. (Inherited from TfrxBarcode2DBase.)
ShowText | Represents property ShowText. (Inherited from TfrxBarcode2DBase.)
Text | Represents property Text. (Inherited from TfrxBarcode2DBase.)
Width | Represents property Width. (Inherited from TfrxBarcode2DBase.)
Zoom | Represents property Zoom. (Inherited from TfrxBarcode2DBase.)
Top
Methods
Show:
Name | Description
Assign(TfrxBarcode2DBase) | Represents method Assign(TfrxBarcode2DBase). (Overrides TfrxBarcode2DBase.Assign(TfrxBarcode2DBase).)
ClearFigures | Represents method ClearFigures. (Inherited from TfrxBarcode2DBaseWithUnion.)
Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer) | Represents method Draw2DBarcode(TCanvas,Extended,Extended,Integer,Integer). (Inherited from TfrxBarcode2DBase.)
FillRect(TCanvas,TRect) | Represents method FillRect(TCanvas,TRect). (Inherited from TfrxBarcode2DBase.)
FVectorPrimitivesAdd(Integer,Integer,Integer,Integer) | Represents method FVectorPrimitivesAdd(Integer,Integer,Integer,Integer). (Inherited from TfrxBarcode2DBaseWithUnion.)
Generate(string,Boolean) | Represents method Generate(string,Boolean). (Overrides TfrxGS1Databar.Generate(string,Boolean).)
GetFooterHeight | Represents method GetFooterHeight. (Inherited from TfrxBarcode2DBase.)
GetHeight | Represents method GetHeight. (Overrides TfrxBarcode2DBase.GetHeight.)
GetWidth | Represents method GetWidth. (Inherited from TfrxBarcode2DBase.)
InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended) | Represents method InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended). (Overrides TfrxBarcode2DBase.InternalDraw(TCanvas,Extended,Extended,Integer,Integer,Integer,Integer,Integer,Integer,Integer,Extended,Extended).)
IsScaled | Represents method IsScaled. (Overrides TfrxBarcode2DBase.IsScaled.)
RePaint | Represents method RePaint. (Inherited from TfrxGS1Databar.)
SetColor(TColor) | Represents method SetColor(TColor). (Inherited from TfrxBarcode2DBase.)
SetColorBar(TColor) | Represents method SetColorBar(TColor). (Inherited from TfrxBarcode2DBase.)
SetColumns(Integer) | Represents method SetColumns(Integer).
SetErrorText(String) | Represents method SetErrorText(String). (Inherited from TfrxBarcode2DBase.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxBarcode2DBase.)
SetFontScaled(Boolean) | Represents method SetFontScaled(Boolean). (Inherited from TfrxBarcode2DBase.)
SetHeight(Integer) | Represents method SetHeight(Integer). (Overrides TfrxBarcode2DBase.SetHeight(Integer).)
SetRotation(Integer) | Represents method SetRotation(Integer). (Inherited from TfrxBarcode2DBase.)
SetShowText(Boolean) | Represents method SetShowText(Boolean). (Inherited from TfrxBarcode2DBase.)
SetText(string) | Represents method SetText(string). (Overrides TfrxBarcode2DBase.SetText(String).)
SetZoom(Extended) | Represents method SetZoom(Extended). (Inherited from TfrxBarcode2DBase.)
T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte) | Represents method T2DBooleanArrayToVectorPrimitives(T2DBooleanArray,Byte,Byte,Byte). (Inherited from TfrxBarcode2DBaseWithUnion.)
Top
Fields
Show:
Name | Description
DotsL | Represents field DotsL. (Inherited from TfrxBarcode2DBaseWithUnion.)
DotsR | Represents field DotsR. (Inherited from TfrxBarcode2DBaseWithUnion.)
FColor | Represents field FColor. (Inherited from TfrxBarcode2DBase.)
FColorBar | Represents field FColorBar. (Inherited from TfrxBarcode2DBase.)
FColumns | Represents field FColumns.
FErrorText | Represents field FErrorText. (Inherited from TfrxBarcode2DBase.)
FFont | Represents field FFont. (Inherited from TfrxBarcode2DBase.)
FFontScaled | Represents field FFontScaled. (Inherited from TfrxBarcode2DBase.)
FHeight | Represents field FHeight. (Inherited from TfrxBarcode2DBase.)
FPixelHeight | Represents field FPixelHeight. (Inherited from TfrxBarcode2DBase.)
FPixelWidth | Represents field FPixelWidth. (Inherited from TfrxBarcode2DBase.)
FQuietZone | Represents field FQuietZone. (Inherited from TfrxBarcode2DBase.)
FRotation | Represents field FRotation. (Inherited from TfrxBarcode2DBase.)
FShowText | Represents field FShowText. (Inherited from TfrxBarcode2DBase.)
FText | Represents field FText. (Inherited from TfrxBarcode2DBase.)
FVectorPrimitives | Represents field FVectorPrimitives. (Inherited from TfrxBarcode2DBaseWithUnion.)
FWidth | Represents field FWidth. (Inherited from TfrxBarcode2DBase.)
FZoom | Represents field FZoom. (Inherited from TfrxBarcode2DBase.)
Top
See Also

Reference

  • frxGS1Databar


TfrxGS1DatabarES Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxGS1DatabarES class. (Overrides TfrxGS1Databar.Create.)
Top


TfrxGS1DatabarES.Create Constructor

Summary

Initializes a new instance of the TfrxGS1DatabarES class.

Namespace: frxGS1Databar
Syntax
Delphi
public
 constructor Create; override;

Overrides

TfrxGS1Databar.Create
See Also

Reference

  • TfrxGS1DatabarES
  • frxGS1Databar


TfrxGS1DatabarES Properties

Properties
Name | Description
Columns | Represents property Columns.
Top


TfrxGS1DatabarES.Columns Property

Summary

Represents property Columns.

Namespace: frxGS1Databar
Syntax
Delphi
public
 property Columns: Integer read FColumns write SetColumns;

Property Value

Type: Integer

See Also

Reference

  • TfrxGS1DatabarES
  • frxGS1Databar


TfrxGS1DatabarES Methods

Methods
Name | Description
Generate(string,Boolean) | Represents method Generate(string,Boolean). (Overrides TfrxGS1Databar.Generate(string,Boolean).)
SetColumns(Integer) | Represents method SetColumns(Integer).
SetText(string) | Represents method SetText(string). (Overrides TfrxBarcode2DBase.SetText(String).)
Top


TfrxGS1DatabarES.Generate(string,Boolean) Method

Summary

Represents method Generate(string,Boolean).

Namespace: frxGS1Databar
Syntax
Delphi
protected
 function Generate(Text: string; rebase: Boolean = True): Integer; override;

Parameters

Text
Type: string

rebase
Type: Boolean

Return Value

Type: Integer

Overrides

TfrxGS1Databar.Generate(string,Boolean)
See Also

Reference

  • TfrxGS1DatabarES
  • frxGS1Databar


TfrxGS1DatabarES.SetColumns(Integer) Method

Summary

Represents method SetColumns(Integer).

Namespace: frxGS1Databar
Syntax
Delphi
protected
 procedure SetColumns(Col: Integer);

Parameters

Col
Type: Integer

See Also

Reference

  • TfrxGS1DatabarES
  • frxGS1Databar


TfrxGS1DatabarES.SetText(string) Method

Summary

Represents method SetText(string).

Namespace: frxGS1Databar
Syntax
Delphi
public
 procedure SetText(v: string); override;

Parameters

v
Type: string

Overrides

TfrxBarcode2DBase.SetText(String)
See Also

Reference

  • TfrxGS1DatabarES
  • frxGS1Databar


TfrxGS1DatabarES Fields

Fields
Name | Description
FColumns | Represents field FColumns.
Top


TfrxGS1DatabarES.FColumns Field

Summary

Represents field FColumns.

Namespace: frxGS1Databar
Syntax
Delphi
protected
 FColumns: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxGS1DatabarES
  • frxGS1Databar


frxGS1Databar_Helper Namespace

Summary

Represents namespace frxGS1Databar_Helper.

Classes
Name | Description
TBaseDatabar | Represents type TBaseDatabar.
Top
Types
Name | Description
TArrayOfByte | Represents an array of the Byte type.
TArrayOfChar | Represents an array of the Char type.
TArrayOfInteger | Represents an array of the Integer type.
TEncoded_Data | Represents an array of the type.
Top
Constants
Name | Description
ALPHA | Represents constant ALPHA.
ALPHA_OR_ISO | Represents constant ALPHA_OR_ISO.
ANY_ENC | Represents constant ANY_ENC.
checksum_weight_exp | Represents constant checksum_weight_exp.
COLS_MAX | Represents constant COLS_MAX.
finder_pattern_exp | Represents constant finder_pattern_exp.
finder_sequence | Represents constant finder_sequence.
g_sum_exp | Represents constant g_sum_exp.
INVALID_CHAR | Represents constant INVALID_CHAR.
ISOIEC | Represents constant ISOIEC.
modules_even_exp | Represents constant modules_even_exp.
modules_odd_exp | Represents constant modules_odd_exp.
NUMERIC | Represents constant NUMERIC.
t_even_exp | Represents constant t_even_exp.
weight_rows | Represents constant weight_rows.
widest_even_exp | Represents constant widest_even_exp.
widest_odd_exp | Represents constant widest_odd_exp.
Top
Routines
Name | Description
ArrayCopy(TArrayOfByte,TArrayOfChar,Integer) | Overloaded. Represents method ArrayCopy(TArrayOfByte,TArrayOfChar,Integer).
ArrayCopy(TArrayOfChar,TArrayOfByte,Integer) | Overloaded. Represents method ArrayCopy(TArrayOfChar,TArrayOfByte,Integer).
ArrayOfCharToString(TArrayOfChar) | Represents method ArrayOfCharToString(TArrayOfChar).
CalcSumArrayOfInteger(TArrayOfInteger) | Represents method CalcSumArrayOfInteger(TArrayOfInteger).
Code_DBEorES(String,Boolean,Integer) | Represents method Code_DBEorES(String,Boolean,Integer).
combins(Integer,Integer) | Represents method combins(Integer,Integer).
concat(TArrayOfChar,String) | Overloaded. Represents method concat(TArrayOfChar,String).
concat(TArrayOfChar,TArrayOfChar) | Overloaded. Represents method concat(TArrayOfChar,TArrayOfChar).
ctoi(Char) | Represents method ctoi(Char).
general_rules(TArrayOfChar,TArrayOfChar) | Represents method general_rules(TArrayOfChar,TArrayOfChar).
getRSSwidths(Integer,Integer,Integer,Integer,Integer,TArrayOfInteger) | Represents method getRSSwidths(Integer,Integer,Integer,Integer,Integer,TArrayOfInteger).
itoc(Integer) | Represents method itoc(Integer).
module_is_set(TEncoded_Data,Integer,Integer) | Represents method module_is_set(TEncoded_Data,Integer,Integer).
set_module(TEncoded_Data,Integer,Integer) | Represents method set_module(TEncoded_Data,Integer,Integer).
strcpy(TArrayOfChar,String) | Overloaded. Represents method strcpy(TArrayOfChar,String).
strcpy(TArrayOfChar,TArrayOfChar) | Overloaded. Represents method strcpy(TArrayOfChar,TArrayOfChar).
strlen(TArrayOfChar) | Represents method strlen(TArrayOfChar).
StrToArrayOfByte(string) | Represents method StrToArrayOfByte(string).
StrToArrayOfChar(String) | Represents method StrToArrayOfChar(String).
unset_module(TEncoded_Data,Integer,Integer) | Represents method unset_module(TEncoded_Data,Integer,Integer).
ustrlen(TArrayOfByte) | Represents method ustrlen(TArrayOfByte).
Top


frxGS1Databar_Helper Classes

Classes
Name | Description
TBaseDatabar | Represents type TBaseDatabar.
Top


TBaseDatabar Class

Summary

Represents type TBaseDatabar.

Namespace: frxGS1Databar_Helper
Inheritance Hierarchy
TObject
frxGS1Databar_Helper.TBaseDatabar
Syntax
Delphi
type
 TBaseDatabar = class
 end;

The TBaseDatabar type exposes the following members.

Fields
Show:
Name | Description
data_chars | Represents field data_chars.
elements | Represents field elements.
rows | Represents field rows.
row_height | Represents field row_height.
sub_elements | Represents field sub_elements.
symbol | Represents field symbol.
width | Represents field width.
Top
See Also

Reference

  • frxGS1Databar_Helper


TBaseDatabar Fields

Fields
Name | Description
data_chars | Represents field data_chars.
elements | Represents field elements.
rows | Represents field rows.
row_height | Represents field row_height.
sub_elements | Represents field sub_elements.
symbol | Represents field symbol.
width | Represents field width.
Top


TBaseDatabar.data_chars Field

Summary

Represents field data_chars.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
public
 rows, width, data_chars: Integer;

Field Value

Type: Integer

See Also

Reference

  • TBaseDatabar
  • frxGS1Databar_Helper


TBaseDatabar.elements Field

Summary

Represents field elements.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
public
 elements : TArrayOfInteger;

Field Value

Type: TArrayOfInteger

See Also

Reference

  • TBaseDatabar
  • frxGS1Databar_Helper


TBaseDatabar.rows Field

Summary

Represents field rows.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
public
 rows, width, data_chars: Integer;

Field Value

Type: Integer

See Also

Reference

  • TBaseDatabar
  • frxGS1Databar_Helper


TBaseDatabar.row_height Field

Summary

Represents field row_height.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
public
 row_height : array of Integer;

Field Value

Type: array of Integer

See Also

Reference

  • TBaseDatabar
  • frxGS1Databar_Helper


TBaseDatabar.sub_elements Field

Summary

Represents field sub_elements.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
public
 sub_elements : TArrayOfInteger;

Field Value

Type: TArrayOfInteger

See Also

Reference

  • TBaseDatabar
  • frxGS1Databar_Helper


TBaseDatabar.symbol Field

Summary

Represents field symbol.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
public
 symbol : TEncoded_Data;

Field Value

Type: TEncoded_Data

See Also

Reference

  • TBaseDatabar
  • frxGS1Databar_Helper


TBaseDatabar.width Field

Summary

Represents field width.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
public
 rows, width, data_chars: Integer;

Field Value

Type: Integer

See Also

Reference

  • TBaseDatabar
  • frxGS1Databar_Helper


frxGS1Databar_Helper Types

Types
Name | Description
TArrayOfByte | Represents an array of the Byte type.
TArrayOfChar | Represents an array of the Char type.
TArrayOfInteger | Represents an array of the Integer type.
TEncoded_Data | Represents an array of the type.
Top


TArrayOfByte Type

Summary

Represents an array of the Byte type.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
type
 TArrayOfByte = array of Byte;
See Also

Reference

  • frxGS1Databar_Helper


TArrayOfChar Type

Summary

Represents an array of the Char type.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
type
 TArrayOfChar = array of Char;
See Also

Reference

  • frxGS1Databar_Helper


TArrayOfInteger Type

Summary

Represents an array of the Integer type.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
type
 TArrayOfInteger = array of Integer;
See Also

Reference

  • frxGS1Databar_Helper


TEncoded_Data Type

Summary

Represents an array of the type.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
type
 TEncoded_Data = array of array of Boolean;
See Also

Reference

  • frxGS1Databar_Helper


frxGS1Databar_Helper Constants

Constants
Name | Description
ALPHA | Represents constant ALPHA.
ALPHA_OR_ISO | Represents constant ALPHA_OR_ISO.
ANY_ENC | Represents constant ANY_ENC.
checksum_weight_exp | Represents constant checksum_weight_exp.
COLS_MAX | Represents constant COLS_MAX.
finder_pattern_exp | Represents constant finder_pattern_exp.
finder_sequence | Represents constant finder_sequence.
g_sum_exp | Represents constant g_sum_exp.
INVALID_CHAR | Represents constant INVALID_CHAR.
ISOIEC | Represents constant ISOIEC.
modules_even_exp | Represents constant modules_even_exp.
modules_odd_exp | Represents constant modules_odd_exp.
NUMERIC | Represents constant NUMERIC.
t_even_exp | Represents constant t_even_exp.
weight_rows | Represents constant weight_rows.
widest_even_exp | Represents constant widest_even_exp.
widest_odd_exp | Represents constant widest_odd_exp.
Top


ALPHA Constant

Summary

Represents constant ALPHA.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 ALPHA = 97;

Value

Type: ShortInt

See Also

Reference

  • frxGS1Databar_Helper


ALPHA_OR_ISO Constant

Summary

Represents constant ALPHA_OR_ISO.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 ALPHA_OR_ISO = 121;

Value

Type: ShortInt

See Also

Reference

  • frxGS1Databar_Helper


ANY_ENC Constant

Summary

Represents constant ANY_ENC.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 ANY_ENC = 120;

Value

Type: ShortInt

See Also

Reference

  • frxGS1Databar_Helper


checksum_weight_exp Constant

Summary

Represents constant checksum_weight_exp.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 checksum_weight_exp : array[0..183] of Integer = (
 1, 3, 9, 27, 81, 32, 96, 77,
 20, 60, 180, 118, 143, 7, 21, 63,
 189, 145, 13, 39, 117, 140, 209, 205,
 193, 157, 49, 147, 19, 57, 171, 91,
 62, 186, 136, 197, 169, 85, 44, 132,
 185, 133, 188, 142, 4, 12, 36, 108,
 113, 128, 173, 97, 80, 29, 87, 50,
 150, 28, 84, 41, 123, 158, 52, 156,
 46, 138, 203, 187, 139, 206, 196, 166,
 76, 17, 51, 153, 37, 111, 122, 155,
 43, 129, 176, 106, 107, 110, 119, 146,
 16, 48, 144, 10, 30, 90, 59, 177,
 109, 116, 137, 200, 178, 112, 125, 164,
 70, 210, 208, 202, 184, 130, 179, 115,
 134, 191, 151, 31, 93, 68, 204, 190,
 148, 22, 66, 198, 172, 94, 71, 2,
 6, 18, 54, 162, 64, 192, 154, 40,
 120, 149, 25, 75, 14, 42, 126, 167,
 79, 26, 78, 23, 69, 207, 199, 175,
 103, 98, 83, 38, 114, 131, 182, 124,
 161, 61, 183, 127, 170, 88, 53, 159,
 55, 165, 73, 8, 24, 72, 5, 15,
 45, 135, 194, 160, 58, 174, 100, 89
);

Value

Type: array[0..183] of Integer

See Also

Reference

  • frxGS1Databar_Helper


COLS_MAX Constant

Summary

Represents constant COLS_MAX.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 COLS_MAX = 102;

Value

Type: ShortInt

See Also

Reference

  • frxGS1Databar_Helper


finder_pattern_exp Constant

Summary

Represents constant finder_pattern_exp.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 finder_pattern_exp : array[0..59] of Integer = (
 1, 8, 4, 1, 1,
 1, 1, 4, 8, 1,
 3, 6, 4, 1, 1,
 1, 1, 4, 6, 3,
 3, 4, 6, 1, 1,
 1, 1, 6, 4, 3,
 3, 2, 8, 1, 1,
 1, 1, 8, 2, 3,
 2, 6, 5, 1, 1,
 1, 1, 5, 6, 2,
 2, 2, 9, 1, 1,
 1, 1, 9, 2, 2
);

Value

Type: array[0..59] of Integer

See Also

Reference

  • frxGS1Databar_Helper


finder_sequence Constant

Summary

Represents constant finder_sequence.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 finder_sequence : array[0..109] of Integer = (
 1, 2, 0, 0, 0, 0, 0, 0, 0, 0, 0,
 1, 4, 3, 0, 0, 0, 0, 0, 0, 0, 0,
 1, 6, 3, 8, 0, 0, 0, 0, 0, 0, 0,
 1, 10, 3, 8, 5, 0, 0, 0, 0, 0, 0,
 1, 10, 3, 8, 7, 12, 0, 0, 0, 0, 0,
 1, 10, 3, 8, 9, 12, 11, 0, 0, 0, 0,
 1, 2, 3, 4, 5, 6, 7, 8, 0, 0, 0,
 1, 2, 3, 4, 5, 6, 7, 10, 9, 0, 0,
 1, 2, 3, 4, 5, 6, 7, 10, 11, 12, 0,
 1, 2, 3, 4, 5, 8, 7, 10, 9, 12, 11
);

Value

Type: array[0..109] of Integer

See Also

Reference

  • frxGS1Databar_Helper


g_sum_exp Constant

Summary

Represents constant g_sum_exp.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 g_sum_exp : array[0..4] of Integer = ( 0, 348, 1388, 2948, 3988 );

Value

Type: array[0..4] of Integer

See Also

Reference

  • frxGS1Databar_Helper


INVALID_CHAR Constant

Summary

Represents constant INVALID_CHAR.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 INVALID_CHAR = 100;

Value

Type: ShortInt

See Also

Reference

  • frxGS1Databar_Helper


ISOIEC Constant

Summary

Represents constant ISOIEC.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 ISOIEC = 105;

Value

Type: ShortInt

See Also

Reference

  • frxGS1Databar_Helper


modules_even_exp Constant

Summary

Represents constant modules_even_exp.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 modules_even_exp : array[0..4] of Integer = ( 5, 7, 9, 11, 13 );

Value

Type: array[0..4] of Integer

See Also

Reference

  • frxGS1Databar_Helper


modules_odd_exp Constant

Summary

Represents constant modules_odd_exp.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 modules_odd_exp : array[0..4] of Integer = ( 12, 10, 8, 6, 4 );

Value

Type: array[0..4] of Integer

See Also

Reference

  • frxGS1Databar_Helper


NUMERIC Constant

Summary

Represents constant NUMERIC.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 NUMERIC = 110;

Value

Type: ShortInt

See Also

Reference

  • frxGS1Databar_Helper


t_even_exp Constant

Summary

Represents constant t_even_exp.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 t_even_exp : array[0..4] of Integer = ( 4, 20, 52, 104, 204 );

Value

Type: array[0..4] of Integer

See Also

Reference

  • frxGS1Databar_Helper


weight_rows Constant

Summary

Represents constant weight_rows.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 weight_rows : array[0..209] of Integer = (
 0, 1, 2, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
 0, 5, 6, 3, 4, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
 0, 9, 10, 3, 4, 13, 14, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
 0, 17, 18, 3, 4, 13, 14, 7, 8, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
 0, 17, 18, 3, 4, 13, 14, 11, 12, 21, 22, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0,
 0, 17, 18, 3, 4, 13, 14, 15, 16, 21, 22, 19, 20, 0, 0, 0, 0, 0, 0, 0, 0,
 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 0, 0, 0, 0, 0, 0,
 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 17, 18, 15, 16, 0, 0, 0, 0,
 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 17, 18, 19, 20, 21, 22, 0, 0,
 0, 1, 2, 3, 4, 5, 6, 7, 8, 13, 14, 11, 12, 17, 18, 15, 16, 21, 22, 19, 20
);

Value

Type: array[0..209] of Integer

See Also

Reference

  • frxGS1Databar_Helper


widest_even_exp Constant

Summary

Represents constant widest_even_exp.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 widest_even_exp : array[0..4] of Integer = ( 2, 4, 5, 6, 8 );

Value

Type: array[0..4] of Integer

See Also

Reference

  • frxGS1Databar_Helper


widest_odd_exp Constant

Summary

Represents constant widest_odd_exp.

Namespace: frxGS1Databar_Helper
Syntax
Delphi
 widest_odd_exp : array[0..4] of Integer = ( 7, 5, 4, 3, 1 );

Value

Type: array[0..4] of Integer

See Also

Reference

  • frxGS1Databar_Helper


frxGS1Databar_Helper Routines

Routines
Name | Description
ArrayCopy(TArrayOfByte,TArrayOfChar,Integer) | Overloaded. Represents method ArrayCopy(TArrayOfByte,TArrayOfChar,Integer).
ArrayCopy(TArrayOfChar,TArrayOfByte,Integer) | Overloaded. Represents method ArrayCopy(TArrayOfChar,TArrayOfByte,Integer).
ArrayOfCharToString(TArrayOfChar) | Represents method ArrayOfCharToString(TArrayOfChar).
CalcSumArrayOfInteger(TArrayOfInteger) | Represents method CalcSumArrayOfInteger(TArrayOfInteger).
Code_DBEorES(String,Boolean,Integer) | Represents method Code_DBEorES(String,Boolean,Integer).
combins(Integer,Integer) | Represents method combins(Integer,Integer).
concat(TArrayOfChar,String) | Overloaded. Represents method concat(TArrayOfChar,String).
concat(TArrayOfChar,TArrayOfChar) | Overloaded. Represents method concat(TArrayOfChar,TArrayOfChar).
ctoi(Char) | Represents method ctoi(Char).
general_rules(TArrayOfChar,TArrayOfChar) | Represents method general_rules(TArrayOfChar,TArrayOfChar).
getRSSwidths(Integer,Integer,Integer,Integer,Integer,TArrayOfInteger) | Represents method getRSSwidths(Integer,Integer,Integer,Integer,Integer,TArrayOfInteger).
itoc(Integer) | Represents method itoc(Integer).
module_is_set(TEncoded_Data,Integer,Integer) | Represents method module_is_set(TEncoded_Data,Integer,Integer).
set_module(TEncoded_Data,Integer,Integer) | Represents method set_module(TEncoded_Data,Integer,Integer).
strcpy(TArrayOfChar,String) | Overloaded. Represents method strcpy(TArrayOfChar,String).
strcpy(TArrayOfChar,TArrayOfChar) | Overloaded. Represents method strcpy(TArrayOfChar,TArrayOfChar).
strlen(TArrayOfChar) | Represents method strlen(TArrayOfChar).
StrToArrayOfByte(string) | Represents method StrToArrayOfByte(string).
StrToArrayOfChar(String) | Represents method StrToArrayOfChar(String).
unset_module(TEncoded_Data,Integer,Integer) | Represents method unset_module(TEncoded_Data,Integer,Integer).
ustrlen(TArrayOfByte) | Represents method ustrlen(TArrayOfByte).
Top


ArrayCopy(TArrayOfByte,TArrayOfChar,Integer) Method

Summary

Represents method ArrayCopy(TArrayOfByte,TArrayOfChar,Integer).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
procedure ArrayCopy(var ADestination : TArrayOfByte; const ASource : TArrayOfChar; ACount : Integer = MaxInt); overload;

Parameters

ADestination
Type: TArrayOfByte

ASource
Type: TArrayOfChar

ACount
Type: Integer

See Also

Reference

  • frxGS1Databar_Helper


ArrayCopy(TArrayOfChar,TArrayOfByte,Integer) Method

Summary

Represents method ArrayCopy(TArrayOfChar,TArrayOfByte,Integer).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
procedure ArrayCopy(var ADestination : TArrayOfChar; const ASource : TArrayOfByte; ACount : Integer = MaxInt); overload;

Parameters

ADestination
Type: TArrayOfChar

ASource
Type: TArrayOfByte

ACount
Type: Integer

See Also

Reference

  • frxGS1Databar_Helper


ArrayOfCharToString(TArrayOfChar) Method

Summary

Represents method ArrayOfCharToString(TArrayOfChar).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
function ArrayOfCharToString(const AArray : TArrayOfChar) : String;

Parameters

AArray
Type: TArrayOfChar

Return Value

Type: String

See Also

Reference

  • frxGS1Databar_Helper


CalcSumArrayOfInteger(TArrayOfInteger) Method

Summary

Represents method CalcSumArrayOfInteger(TArrayOfInteger).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
function CalcSumArrayOfInteger(arr: TArrayOfInteger): Integer;

Parameters

arr
Type: TArrayOfInteger

Return Value

Type: Integer

See Also

Reference

  • frxGS1Databar_Helper


Code_DBEorES(String,Boolean,Integer) Method

Summary

Represents method Code_DBEorES(String,Boolean,Integer).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
function Code_DBEorES(const FText: String; Stacked: Boolean; option_2: Integer = 2): TBaseDatabar;

Parameters

FText
Type: String

Stacked
Type: Boolean

option_2
Type: Integer

Return Value

Type: TBaseDatabar

See Also

Reference

  • frxGS1Databar_Helper


combins(Integer,Integer) Method

Summary

Represents method combins(Integer,Integer).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
function combins(n : Integer; r : Integer) : Integer;

Parameters

n
Type: Integer

r
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • frxGS1Databar_Helper


concat(TArrayOfChar,String) Method

Summary

Represents method concat(TArrayOfChar,String).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
procedure concat(var ADest: TArrayOfChar; const ASource: String); overload;

Parameters

ADest
Type: TArrayOfChar

ASource
Type: String

See Also

Reference

  • frxGS1Databar_Helper


concat(TArrayOfChar,TArrayOfChar) Method

Summary

Represents method concat(TArrayOfChar,TArrayOfChar).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
procedure concat(var dest : TArrayOfChar; const source : TArrayOfChar); overload;

Parameters

dest
Type: TArrayOfChar

source
Type: TArrayOfChar

See Also

Reference

  • frxGS1Databar_Helper


ctoi(Char) Method

Summary

Represents method ctoi(Char).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
function ctoi(source : Char) : Integer;

Parameters

source
Type: Char

Return Value

Type: Integer

See Also

Reference

  • frxGS1Databar_Helper


general_rules(TArrayOfChar,TArrayOfChar) Method

Summary

Represents method general_rules(TArrayOfChar,TArrayOfChar).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
function general_rules(field : TArrayOfChar; _type: TArrayOfChar) : Integer;

Parameters

field
Type: TArrayOfChar

_type
Type: TArrayOfChar

Return Value

Type: Integer

See Also

Reference

  • frxGS1Databar_Helper


getRSSwidths(Integer,Integer,Integer,Integer,Integer,TArrayOfInteger) Method

Summary

Represents method getRSSwidths(Integer,Integer,Integer,Integer,Integer,TArrayOfInteger).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
procedure getRSSwidths(val, n, elements, maxWidth, noNarrow : Integer; out widths : TArrayOfInteger);

Parameters

val
Type: Integer

n
Type: Integer

elements
Type: Integer

maxWidth
Type: Integer

noNarrow
Type: Integer

widths
Type: TArrayOfInteger

See Also

Reference

  • frxGS1Databar_Helper


itoc(Integer) Method

Summary

Represents method itoc(Integer).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
function itoc(source : Integer) : Char;

Parameters

source
Type: Integer

Return Value

Type: Char

See Also

Reference

  • frxGS1Databar_Helper


module_is_set(TEncoded_Data,Integer,Integer) Method

Summary

Represents method module_is_set(TEncoded_Data,Integer,Integer).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
function module_is_set(symbol : TEncoded_Data; y_coord : Integer; x_coord : Integer) : Boolean;

Parameters

symbol
Type: TEncoded_Data

y_coord
Type: Integer

x_coord
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • frxGS1Databar_Helper


set_module(TEncoded_Data,Integer,Integer) Method

Summary

Represents method set_module(TEncoded_Data,Integer,Integer).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
procedure set_module(var symbol : TEncoded_Data; y_coord : Integer; x_coord : Integer);

Parameters

symbol
Type: TEncoded_Data

y_coord
Type: Integer

x_coord
Type: Integer

See Also

Reference

  • frxGS1Databar_Helper


strcpy(TArrayOfChar,String) Method

Summary

Represents method strcpy(TArrayOfChar,String).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
procedure strcpy(var ATarget : TArrayOfChar; const ASource : String); overload;

Parameters

ATarget
Type: TArrayOfChar

ASource
Type: String

See Also

Reference

  • frxGS1Databar_Helper


strcpy(TArrayOfChar,TArrayOfChar) Method

Summary

Represents method strcpy(TArrayOfChar,TArrayOfChar).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
procedure strcpy(var target : TArrayOfChar; const source : TArrayOfChar); overload;

Parameters

target
Type: TArrayOfChar

source
Type: TArrayOfChar

See Also

Reference

  • frxGS1Databar_Helper


strlen(TArrayOfChar) Method

Summary

Represents method strlen(TArrayOfChar).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
function strlen(const AString : TArrayOfChar) : Integer;

Parameters

AString
Type: TArrayOfChar

Return Value

Type: Integer

See Also

Reference

  • frxGS1Databar_Helper


StrToArrayOfByte(string) Method

Summary

Represents method StrToArrayOfByte(string).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
function StrToArrayOfByte(const AString : string) : TArrayOfByte;

Parameters

AString
Type: string

Return Value

Type: TArrayOfByte

See Also

Reference

  • frxGS1Databar_Helper


StrToArrayOfChar(String) Method

Summary

Represents method StrToArrayOfChar(String).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
function StrToArrayOfChar(const AString : String) : TArrayOfChar;

Parameters

AString
Type: String

Return Value

Type: TArrayOfChar

See Also

Reference

  • frxGS1Databar_Helper


unset_module(TEncoded_Data,Integer,Integer) Method

Summary

Represents method unset_module(TEncoded_Data,Integer,Integer).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
procedure unset_module(var symbol : TEncoded_Data; y_coord : Integer; x_coord : Integer);

Parameters

symbol
Type: TEncoded_Data

y_coord
Type: Integer

x_coord
Type: Integer

See Also

Reference

  • frxGS1Databar_Helper


ustrlen(TArrayOfByte) Method

Summary

Represents method ustrlen(TArrayOfByte).

Namespace: frxGS1Databar_Helper
Syntax
Delphi
function ustrlen(const data : TArrayOfByte) : Integer;

Parameters

data
Type: TArrayOfByte

Return Value

Type: Integer

See Also

Reference

  • frxGS1Databar_Helper


frxGS1Helper Namespace

Summary

Represents namespace frxGS1Helper.

Routines
Name | Description
ParseGS1(AnsiString) | Represents method ParseGS1(AnsiString).
Top


frxGS1Helper Routines

Routines
Name | Description
ParseGS1(AnsiString) | Represents method ParseGS1(AnsiString).
Top


ParseGS1(AnsiString) Method

Summary

Represents method ParseGS1(AnsiString).

Namespace: frxGS1Helper
Syntax
Delphi
function ParseGS1(code: AnsiString): AnsiString;

Parameters

code
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • frxGS1Helper


frxGZip Namespace

Summary

Represents namespace frxGZip.

Classes
Name | Description
TfrxGZipCompressor | The TfrxGZipCompressor component lets you compress/decompress FastReport files (.FR3 and .FP3). gzip algorithm is used for compression.
Top
Enumerations
Name | Description
TfrxCompressionLevel | The compression level.
Top
Routines
Name | Description
frxCompressStream(TStream,TStream,TfrxCompressionLevel,String) | Method compresses the Source stream and saves compressed data to the Dest stream. gzip algorithm is used for compression. Optional parameter FileName is used to store the file name into gzip header.
frxDecompressStream(TStream,TStream) | Method decompresses the Source stream and saves uncompressed data to the Dest stream. It returns the file name from gzip header.
frxDeflateStream(TStream,TStream,TfrxCompressionLevel) | Method compresses the Source stream and saves compressed data to the Dest stream. Deflate algorithm is used for compression.
frxInflateStream(TStream,TStream) | Method decompresses the Source stream and saves uncompressed data to the Dest stream. Inflate algorithm is used for decompression.
Top


frxGZip Classes

Classes
Name | Description
TfrxGZipCompressor | The TfrxGZipCompressor component lets you compress/decompress FastReport files (.FR3 and .FP3). gzip algorithm is used for compression.
Top


TfrxGZipCompressor Class

Summary

The TfrxGZipCompressor component lets you compress/decompress FastReport files (.FR3 and .FP3). gzip algorithm is used for compression.

Namespace: frxGZip
Inheritance Hierarchy
TComponent
frxClass.TfrxCustomCompressor
frxGZip.TfrxGZipCompressor
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxGZipCompressor = class(TfrxCustomCompressor)
 end;

The TfrxGZipCompressor type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomCompressor class. (Inherited from TfrxCustomCompressor.)
Top
Properties
Show:
Name | Description
IsFR3File | Determines if there is compressed data is the FR3 file. FR3 file can be compressed using maximum compression. (Inherited from TfrxCustomCompressor.)
Report | Reference to a report. (Inherited from TfrxCustomCompressor.)
Stream | Stream used by compressing/decompressing operations. (Inherited from TfrxCustomCompressor.)
Top
Methods
Show:
Name | Description
Compress(TStream) | Method will compress the data from the Stream property and save resulting data to a Dest stream. (Overrides TfrxCustomCompressor.Compress(TStream).)
CreateStream | Represents method CreateStream. (Inherited from TfrxCustomCompressor.)
Decompress(TStream) | Method will decompress the data from a Source parameter and save resulting data to a stream defined in the Stream property. (Overrides TfrxCustomCompressor.Decompress(TStream).)
Top
See Also

Reference

  • frxGZip


TfrxGZipCompressor Methods

Methods
Name | Description
Compress(TStream) | Method will compress the data from the Stream property and save resulting data to a Dest stream. (Overrides TfrxCustomCompressor.Compress(TStream).)
Decompress(TStream) | Method will decompress the data from a Source parameter and save resulting data to a stream defined in the Stream property. (Overrides TfrxCustomCompressor.Decompress(TStream).)
Top


TfrxGZipCompressor.Compress(TStream) Method

Summary

Method will compress the data from the Stream property and save resulting data to a Dest stream.

Namespace: frxGZip
Syntax
Delphi
public
 procedure Compress(Dest: TStream); override;

Parameters

Dest
Type: TStream

Overrides

TfrxCustomCompressor.Compress(TStream)
See Also

Reference

  • TfrxGZipCompressor
  • frxGZip


TfrxGZipCompressor.Decompress(TStream) Method

Summary

Method will decompress the data from a Source parameter and save resulting data to a stream defined in the Stream property.

Namespace: frxGZip
Syntax
Delphi
public
 function Decompress(Source: TStream): Boolean; override;

Parameters

Source
Type: TStream

Return Value

Type: Boolean

Overrides

TfrxCustomCompressor.Decompress(TStream)
See Also

Reference

  • TfrxGZipCompressor
  • frxGZip


frxGZip Enumerations

Enumerations
Name | Description
TfrxCompressionLevel | The compression level.
Top


TfrxCompressionLevel Enumeration

Summary

The compression level.

Namespace: frxGZip
Syntax
Delphi
type
 TfrxCompressionLevel = (gzNone, gzFastest, gzDefault, gzMax);

The TfrxCompressionLevel type exposes the following members.

Members
Show:
Name | Description
gzDefault | Represents constant gzDefault.
gzFastest | Represents constant gzFastest.
gzMax | Represents constant gzMax.
gzNone | Represents constant gzNone.
Top
See Also

Reference

  • frxGZip


frxGZip Routines

Routines
Name | Description
frxCompressStream(TStream,TStream,TfrxCompressionLevel,String) | Method compresses the Source stream and saves compressed data to the Dest stream. gzip algorithm is used for compression. Optional parameter FileName is used to store the file name into gzip header.
frxDecompressStream(TStream,TStream) | Method decompresses the Source stream and saves uncompressed data to the Dest stream. It returns the file name from gzip header.
frxDeflateStream(TStream,TStream,TfrxCompressionLevel) | Method compresses the Source stream and saves compressed data to the Dest stream. Deflate algorithm is used for compression.
frxInflateStream(TStream,TStream) | Method decompresses the Source stream and saves uncompressed data to the Dest stream. Inflate algorithm is used for decompression.
Top


frxCompressStream(TStream,TStream,TfrxCompressionLevel,String) Method

Summary

Method compresses the Source stream and saves compressed data to the Dest stream. gzip algorithm is used for compression. Optional parameter FileName is used to store the file name into gzip header.

Namespace: frxGZip
Syntax
Delphi
procedure frxCompressStream(Source, Dest: TStream;
 Compression: TfrxCompressionLevel = gzDefault; FileNameW: String = '');

Parameters

Source
Type: TStream

Source stream

Dest
Type: TStream

Destination stream

Compression
Type: TfrxCompressionLevel

Compression level

FileNameW
Type: String

Used to store the file name into gzip header

See Also

Reference

  • frxGZip


frxDecompressStream(TStream,TStream) Method

Summary

Method decompresses the Source stream and saves uncompressed data to the Dest stream. It returns the file name from gzip header.

Namespace: frxGZip
Syntax
Delphi
function frxDecompressStream(Source, Dest: TStream): AnsiString;

Parameters

Source
Type: TStream

Source stream

Dest
Type: TStream

Destination stream

Return Value

Type: AnsiString

See Also

Reference

  • frxGZip


frxDeflateStream(TStream,TStream,TfrxCompressionLevel) Method

Summary

Method compresses the Source stream and saves compressed data to the Dest stream. Deflate algorithm is used for compression.

Namespace: frxGZip
Syntax
Delphi
procedure frxDeflateStream(Source, Dest: TStream;
 Compression: TfrxCompressionLevel = gzDefault);

Parameters

Source
Type: TStream

Source stream

Dest
Type: TStream

Destination stream

Compression
Type: TfrxCompressionLevel

Compression level

See Also

Reference

  • frxGZip


frxInflateStream(TStream,TStream) Method

Summary

Method decompresses the Source stream and saves uncompressed data to the Dest stream. Inflate algorithm is used for decompression.

Namespace: frxGZip
Syntax
Delphi
procedure frxInflateStream(Source, Dest: TStream);

Parameters

Source
Type: TStream

Source stream

Dest
Type: TStream

Destination stream

See Also

Reference

  • frxGZip


frxInPlaceClipboards Namespace

Summary

Represents namespace frxInPlaceClipboards.

Classes
Name | Description
TfrxInPlaceBaseCopyPasteEditor | Represents type TfrxInPlaceBaseCopyPasteEditor.
TfrxInPlaceMemoCopyPasteEditor | Represents type TfrxInPlaceMemoCopyPasteEditor.
TfrxInPlacePictureCopyPasteEditor | Represents type TfrxInPlacePictureCopyPasteEditor.
Top


frxInPlaceClipboards Classes

Classes
Name | Description
TfrxInPlaceBaseCopyPasteEditor | Represents type TfrxInPlaceBaseCopyPasteEditor.
TfrxInPlaceMemoCopyPasteEditor | Represents type TfrxInPlaceMemoCopyPasteEditor.
TfrxInPlacePictureCopyPasteEditor | Represents type TfrxInPlacePictureCopyPasteEditor.
Top


TfrxInPlaceBaseCopyPasteEditor Class

Summary

Represents type TfrxInPlaceBaseCopyPasteEditor.

Namespace: frxInPlaceClipboards
Inheritance Hierarchy
TObject
frxClass.TfrxInPlaceEditor
frxInPlaceClipboards.TfrxInPlaceBaseCopyPasteEditor
frxInPlaceClipboards.TfrxInPlaceMemoCopyPasteEditor
Syntax
Delphi
type
 TfrxInPlaceBaseCopyPasteEditor = class(TfrxInPlaceEditor)
 end;

The TfrxInPlaceBaseCopyPasteEditor type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponentClass,TWinControl) | Default constructor. (Inherited from TfrxInPlaceEditor.)
Top
Properties
Show:
Name | Description
ClipboardObject | Reference to a clipboard object. (Inherited from TfrxInPlaceEditor.)
Component | Reference to edited component. (Inherited from TfrxInPlaceEditor.)
Editors | Child editors for current editor class. (Inherited from TfrxInPlaceEditor.)
Locked | Editor is locked. (Inherited from TfrxInPlaceEditor.)
ParentComponent | Reference to a parent component. (Inherited from TfrxInPlaceEditor.)
Top
Methods
Show:
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter. (Overrides TfrxInPlaceEditor.CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
DefaultContentType | Returns default content type supported by InPlcae editor. (Inherited from TfrxInPlaceEditor.)
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoFinishInPlace(TObject,Boolean,Boolean) | Calls OnFinishInPlace event handler. (Inherited from TfrxInPlaceEditor.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DrawCustomEditor(TCanvas,TRect) | Draws object editor over object canvas. (Inherited from TfrxInPlaceEditor.)
EditInPlace(TComponent,TRect) | Represents method EditInPlace(TComponent,TRect). (Inherited from TfrxInPlaceEditor.)
EditInPlaceDone | This method should close in place editor and apply changes to edited object. (Inherited from TfrxInPlaceEditor.)
FillData | Not used. (Inherited from TfrxInPlaceEditor.)
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves. (Inherited from TfrxInPlaceEditor.)
GetActiveRect | Returns active work area of the editor. (Inherited from TfrxInPlaceEditor.)
HasCustomEditor | Not used. (Inherited from TfrxInPlaceEditor.)
HasInPlaceEditor | Not used. (Inherited from TfrxInPlaceEditor.)
InitializeUI(TfrxInteractiveEventsParams) | Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves. (Inherited from TfrxInPlaceEditor.)
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
SetComponent(TfrxComponent) | Represents method SetComponent(TfrxComponent). (Inherited from TfrxInPlaceEditor.)
SetOffset(Extended,Extended,Extended) | Sets parameters used by the report preview or the report designer. (Inherited from TfrxInPlaceEditor.)
SortObjets(TList,TStringList) | Represents method SortObjets(TList,TStringList).
Top
Events
Show:
Name | Description
OnFinishInPlace | An event used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor. (Inherited from TfrxInPlaceEditor.)
Top
Fields
Show:
Name | Description
FClassRef | Represents field FClassRef. (Inherited from TfrxInPlaceEditor.)
FClipboardObject | Represents field FClipboardObject. (Inherited from TfrxInPlaceEditor.)
FComponent | Represents field FComponent. (Inherited from TfrxInPlaceEditor.)
FComponents | Represents field FComponents. (Inherited from TfrxInPlaceEditor.)
FDevicePPI | Represents field FDevicePPI. (Inherited from TfrxInPlaceEditor.)
FEditors | Represents field FEditors. (Inherited from TfrxInPlaceEditor.)
FLocked | Represents field FLocked. (Inherited from TfrxInPlaceEditor.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxInPlaceEditor.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxInPlaceEditor.)
FOnFinishInPlace | Represents field FOnFinishInPlace. (Inherited from TfrxInPlaceEditor.)
FOwner | Represents field FOwner. (Inherited from TfrxInPlaceEditor.)
FParentComponent | Represents field FParentComponent. (Inherited from TfrxInPlaceEditor.)
FScale | Represents field FScale. (Inherited from TfrxInPlaceEditor.)
Top
See Also

Reference

  • frxInPlaceClipboards


TfrxInPlaceBaseCopyPasteEditor Methods

Methods
Name | Description
CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter. (Overrides TfrxInPlaceEditor.CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
SortObjets(TList,TStringList) | Represents method SortObjets(TList,TStringList).
Top


TfrxInPlaceBaseCopyPasteEditor.CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) Method

Summary

This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter.

Namespace: frxInPlaceClipboards
Syntax
Delphi
public
 procedure CopyGoupContent(CopyFrom: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; Buffer: TStream; CopyAs: TfrxCopyPasteType = cptDefault); override;

Parameters

CopyFrom
Type: TfrxComponent

Reference to an object used to copy from.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Buffer
Type: TStream

Temporary buffer for copy.

CopyAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

Overrides

TfrxInPlaceEditor.CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType)
See Also

Reference

  • TfrxInPlaceBaseCopyPasteEditor
  • frxInPlaceClipboards


TfrxInPlaceBaseCopyPasteEditor.PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) Method

Namespace: frxInPlaceClipboards
Syntax
Delphi
public
 procedure PasteGoupContent(PasteTo: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; Buffer: TStream; PasteAs: TfrxCopyPasteType = cptDefault); override;

Parameters

PasteTo
Type: TfrxComponent

Reference to an object used to paste data.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Buffer
Type: TStream

Temporary buffer for copy.

PasteAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

Overrides

TfrxInPlaceEditor.PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType)
See Also

Reference

  • TfrxInPlaceBaseCopyPasteEditor
  • frxInPlaceClipboards


TfrxInPlaceBaseCopyPasteEditor.SortObjets(TList,TStringList) Method

Summary

Represents method SortObjets(TList,TStringList).

Namespace: frxInPlaceClipboards
Syntax
Delphi
private
 procedure SortObjets(ObjList: TList; SortedList: TStringList);

Parameters

ObjList
Type: TList

SortedList
Type: TStringList

See Also

Reference

  • TfrxInPlaceBaseCopyPasteEditor
  • frxInPlaceClipboards


TfrxInPlaceMemoCopyPasteEditor Class

Summary

Represents type TfrxInPlaceMemoCopyPasteEditor.

Namespace: frxInPlaceClipboards
Inheritance Hierarchy
TObject
frxClass.TfrxInPlaceEditor
frxInPlaceClipboards.TfrxInPlaceBaseCopyPasteEditor
frxInPlaceClipboards.TfrxInPlaceMemoCopyPasteEditor
Syntax
Delphi
type
 TfrxInPlaceMemoCopyPasteEditor = class(TfrxInPlaceBaseCopyPasteEditor)
 end;

The TfrxInPlaceMemoCopyPasteEditor type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponentClass,TWinControl) | Default constructor. (Inherited from TfrxInPlaceEditor.)
Top
Properties
Show:
Name | Description
ClipboardObject | Reference to a clipboard object. (Inherited from TfrxInPlaceEditor.)
Component | Reference to edited component. (Inherited from TfrxInPlaceEditor.)
Editors | Child editors for current editor class. (Inherited from TfrxInPlaceEditor.)
Locked | Editor is locked. (Inherited from TfrxInPlaceEditor.)
ParentComponent | Reference to a parent component. (Inherited from TfrxInPlaceEditor.)
Top
Methods
Show:
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter. (Overrides TfrxInPlaceEditor.CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
DefaultContentType | Returns default content type supported by InPlcae editor. (Overrides TfrxInPlaceEditor.DefaultContentType.)
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoFinishInPlace(TObject,Boolean,Boolean) | Calls OnFinishInPlace event handler. (Inherited from TfrxInPlaceEditor.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DrawCustomEditor(TCanvas,TRect) | Draws object editor over object canvas. (Inherited from TfrxInPlaceEditor.)
EditInPlace(TComponent,TRect) | Represents method EditInPlace(TComponent,TRect). (Inherited from TfrxInPlaceEditor.)
EditInPlaceDone | This method should close in place editor and apply changes to edited object. (Inherited from TfrxInPlaceEditor.)
FillData | Not used. (Inherited from TfrxInPlaceEditor.)
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves. (Inherited from TfrxInPlaceEditor.)
GetActiveRect | Returns active work area of the editor. (Inherited from TfrxInPlaceEditor.)
HasCustomEditor | Not used. (Inherited from TfrxInPlaceEditor.)
HasInPlaceEditor | Not used. (Inherited from TfrxInPlaceEditor.)
InitializeUI(TfrxInteractiveEventsParams) | Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves. (Inherited from TfrxInPlaceEditor.)
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType).)
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
SetComponent(TfrxComponent) | Represents method SetComponent(TfrxComponent). (Inherited from TfrxInPlaceEditor.)
SetOffset(Extended,Extended,Extended) | Sets parameters used by the report preview or the report designer. (Inherited from TfrxInPlaceEditor.)
Top
Events
Show:
Name | Description
OnFinishInPlace | An event used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor. (Inherited from TfrxInPlaceEditor.)
Top
Fields
Show:
Name | Description
FClassRef | Represents field FClassRef. (Inherited from TfrxInPlaceEditor.)
FClipboardObject | Represents field FClipboardObject. (Inherited from TfrxInPlaceEditor.)
FComponent | Represents field FComponent. (Inherited from TfrxInPlaceEditor.)
FComponents | Represents field FComponents. (Inherited from TfrxInPlaceEditor.)
FDevicePPI | Represents field FDevicePPI. (Inherited from TfrxInPlaceEditor.)
FEditors | Represents field FEditors. (Inherited from TfrxInPlaceEditor.)
FLocked | Represents field FLocked. (Inherited from TfrxInPlaceEditor.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxInPlaceEditor.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxInPlaceEditor.)
FOnFinishInPlace | Represents field FOnFinishInPlace. (Inherited from TfrxInPlaceEditor.)
FOwner | Represents field FOwner. (Inherited from TfrxInPlaceEditor.)
FParentComponent | Represents field FParentComponent. (Inherited from TfrxInPlaceEditor.)
FScale | Represents field FScale. (Inherited from TfrxInPlaceEditor.)
Top
See Also

Reference

  • frxInPlaceClipboards


TfrxInPlaceMemoCopyPasteEditor Methods

Methods
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
DefaultContentType | Returns default content type supported by InPlcae editor. (Overrides TfrxInPlaceEditor.DefaultContentType.)
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType).)
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
Top


TfrxInPlaceMemoCopyPasteEditor.CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) Method

Namespace: frxInPlaceClipboards
Syntax
Delphi
public
 procedure CopyContent(CopyFrom: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; Buffer: TStream; CopyAs: TfrxCopyPasteType = cptDefault); override;

Parameters

CopyFrom
Type: TfrxComponent

Reference to an object used to copy from.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Buffer
Type: TStream

Temporary buffer for copy.

CopyAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

Overrides

TfrxInPlaceEditor.CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType)
See Also

Reference

  • TfrxInPlaceMemoCopyPasteEditor
  • frxInPlaceClipboards


TfrxInPlaceMemoCopyPasteEditor.DefaultContentType Method

Summary

Returns default content type supported by InPlcae editor.

Namespace: frxInPlaceClipboards
Syntax
Delphi
public
 function DefaultContentType: TfrxCopyPasteType; override;

Return Value

Type: TfrxCopyPasteType

Overrides

TfrxInPlaceEditor.DefaultContentType
See Also

Reference

  • TfrxInPlaceMemoCopyPasteEditor
  • frxInPlaceClipboards


TfrxInPlaceMemoCopyPasteEditor.IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) Method

Namespace: frxInPlaceClipboards
Syntax
Delphi
public
 function IsPasteAvailable(PasteTo: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; PasteAs: TfrxCopyPasteType = cptDefault): Boolean; override;

Parameters

PasteTo
Type: TfrxComponent

Reference to an object used to paste data.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

PasteAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

Return Value

Type: Boolean

Overrides

TfrxInPlaceEditor.IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType)
See Also

Reference

  • TfrxInPlaceMemoCopyPasteEditor
  • frxInPlaceClipboards


TfrxInPlaceMemoCopyPasteEditor.PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) Method

Namespace: frxInPlaceClipboards
Syntax
Delphi
public
 procedure PasteContent(PasteTo: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; Buffer: TStream; PasteAs: TfrxCopyPasteType = cptDefault); override;

Parameters

PasteTo
Type: TfrxComponent

Reference to an object used to paste data.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Buffer
Type: TStream

Temporary buffer for copy.

PasteAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

Overrides

TfrxInPlaceEditor.PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType)
See Also

Reference

  • TfrxInPlaceMemoCopyPasteEditor
  • frxInPlaceClipboards


TfrxInPlacePictureCopyPasteEditor Class

Summary

Represents type TfrxInPlacePictureCopyPasteEditor.

Namespace: frxInPlaceClipboards
Inheritance Hierarchy
TObject
frxClass.TfrxInPlaceEditor
frxInPlaceClipboards.TfrxInPlacePictureCopyPasteEditor
Syntax
Delphi
type
 TfrxInPlacePictureCopyPasteEditor = class(TfrxInPlaceEditor)
 end;

The TfrxInPlacePictureCopyPasteEditor type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponentClass,TWinControl) | Default constructor. (Inherited from TfrxInPlaceEditor.)
Top
Properties
Show:
Name | Description
ClipboardObject | Reference to a clipboard object. (Inherited from TfrxInPlaceEditor.)
Component | Reference to edited component. (Inherited from TfrxInPlaceEditor.)
Editors | Child editors for current editor class. (Inherited from TfrxInPlaceEditor.)
Locked | Editor is locked. (Inherited from TfrxInPlaceEditor.)
ParentComponent | Reference to a parent component. (Inherited from TfrxInPlaceEditor.)
Top
Methods
Show:
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter. (Inherited from TfrxInPlaceEditor.)
DefaultContentType | Returns default content type supported by InPlcae editor. (Inherited from TfrxInPlaceEditor.)
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoFinishInPlace(TObject,Boolean,Boolean) | Calls OnFinishInPlace event handler. (Inherited from TfrxInPlaceEditor.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DrawCustomEditor(TCanvas,TRect) | Draws object editor over object canvas. (Inherited from TfrxInPlaceEditor.)
EditInPlace(TComponent,TRect) | Represents method EditInPlace(TComponent,TRect). (Inherited from TfrxInPlaceEditor.)
EditInPlaceDone | This method should close in place editor and apply changes to edited object. (Inherited from TfrxInPlaceEditor.)
FillData | Not used. (Inherited from TfrxInPlaceEditor.)
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves. (Inherited from TfrxInPlaceEditor.)
GetActiveRect | Returns active work area of the editor. (Inherited from TfrxInPlaceEditor.)
HasCustomEditor | Not used. (Inherited from TfrxInPlaceEditor.)
HasInPlaceEditor | Not used. (Inherited from TfrxInPlaceEditor.)
InitializeUI(TfrxInteractiveEventsParams) | Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves. (Inherited from TfrxInPlaceEditor.)
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType).)
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
SetComponent(TfrxComponent) | Represents method SetComponent(TfrxComponent). (Inherited from TfrxInPlaceEditor.)
SetOffset(Extended,Extended,Extended) | Sets parameters used by the report preview or the report designer. (Inherited from TfrxInPlaceEditor.)
Top
Events
Show:
Name | Description
OnFinishInPlace | An event used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor. (Inherited from TfrxInPlaceEditor.)
Top
Fields
Show:
Name | Description
FClassRef | Represents field FClassRef. (Inherited from TfrxInPlaceEditor.)
FClipboardObject | Represents field FClipboardObject. (Inherited from TfrxInPlaceEditor.)
FComponent | Represents field FComponent. (Inherited from TfrxInPlaceEditor.)
FComponents | Represents field FComponents. (Inherited from TfrxInPlaceEditor.)
FDevicePPI | Represents field FDevicePPI. (Inherited from TfrxInPlaceEditor.)
FEditors | Represents field FEditors. (Inherited from TfrxInPlaceEditor.)
FLocked | Represents field FLocked. (Inherited from TfrxInPlaceEditor.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxInPlaceEditor.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxInPlaceEditor.)
FOnFinishInPlace | Represents field FOnFinishInPlace. (Inherited from TfrxInPlaceEditor.)
FOwner | Represents field FOwner. (Inherited from TfrxInPlaceEditor.)
FParentComponent | Represents field FParentComponent. (Inherited from TfrxInPlaceEditor.)
FScale | Represents field FScale. (Inherited from TfrxInPlaceEditor.)
Top
See Also

Reference

  • frxInPlaceClipboards


TfrxInPlacePictureCopyPasteEditor Methods

Methods
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType).)
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Overrides TfrxInPlaceEditor.PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType).)
Top


TfrxInPlacePictureCopyPasteEditor.CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) Method

Namespace: frxInPlaceClipboards
Syntax
Delphi
public
 procedure CopyContent(CopyFrom: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; Buffer: TStream; CopyAs: TfrxCopyPasteType = cptDefault); override;

Parameters

CopyFrom
Type: TfrxComponent

Reference to an object used to copy from.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Buffer
Type: TStream

Temporary buffer for copy.

CopyAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

Overrides

TfrxInPlaceEditor.CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType)
See Also

Reference

  • TfrxInPlacePictureCopyPasteEditor
  • frxInPlaceClipboards


TfrxInPlacePictureCopyPasteEditor.IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) Method

Namespace: frxInPlaceClipboards
Syntax
Delphi
public
 function IsPasteAvailable(PasteTo: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; PasteAs: TfrxCopyPasteType = cptDefault): Boolean; override;

Parameters

PasteTo
Type: TfrxComponent

Reference to an object used to paste data.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

PasteAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

Return Value

Type: Boolean

Overrides

TfrxInPlaceEditor.IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType)
See Also

Reference

  • TfrxInPlacePictureCopyPasteEditor
  • frxInPlaceClipboards


TfrxInPlacePictureCopyPasteEditor.PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) Method

Namespace: frxInPlaceClipboards
Syntax
Delphi
public
 procedure PasteContent(PasteTo: TfrxComponent; var EventParams: TfrxInteractiveEventsParams; Buffer: TStream; PasteAs: TfrxCopyPasteType = cptDefault); override;

Parameters

PasteTo
Type: TfrxComponent

Reference to an object used to paste data.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Buffer
Type: TStream

Temporary buffer for copy.

PasteAs
Type: TfrxCopyPasteType

This flag determines kind of object data.

Overrides

TfrxInPlaceEditor.PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType)
See Also

Reference

  • TfrxInPlacePictureCopyPasteEditor
  • frxInPlaceClipboards


frxInPlaceEditors Namespace

Summary

Represents namespace frxInPlaceEditors.

Classes
Name | Description
TfrxInPlaceBasePanelEditor | Represents type TfrxInPlaceBasePanelEditor.
TfrxInPlaceDataFiledEditor | Represents type TfrxInPlaceDataFiledEditor.
TfrxInPlaceMemoEditor | Represents type TfrxInPlaceMemoEditor.
TfrxInPlaceMemoEditorBase | Represents type TfrxInPlaceMemoEditorBase.
TfrxInPlaceTextEditorBase | Represents type TfrxInPlaceTextEditorBase.
Top


frxInPlaceEditors Classes

Classes
Name | Description
TfrxInPlaceBasePanelEditor | Represents type TfrxInPlaceBasePanelEditor.
TfrxInPlaceDataFiledEditor | Represents type TfrxInPlaceDataFiledEditor.
TfrxInPlaceMemoEditor | Represents type TfrxInPlaceMemoEditor.
TfrxInPlaceMemoEditorBase | Represents type TfrxInPlaceMemoEditorBase.
TfrxInPlaceTextEditorBase | Represents type TfrxInPlaceTextEditorBase.
Top


TfrxInPlaceBasePanelEditor Class

Summary

Represents type TfrxInPlaceBasePanelEditor.

Namespace: frxInPlaceEditors
Inheritance Hierarchy
TObject
frxClass.TfrxInPlaceEditor
frxInPlaceEditors.TfrxInPlaceBasePanelEditor
Syntax
Delphi
type
 TfrxInPlaceBasePanelEditor = class(TfrxInPlaceEditor)
 end;

The TfrxInPlaceBasePanelEditor type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponentClass,TWinControl) | Default constructor. (Inherited from TfrxInPlaceEditor.)
Destroy | Represents the destructor of the TfrxInPlaceBasePanelEditor class. (Overrides TfrxInPlaceEditor.Destroy.)
Top
Properties
Show:
Name | Description
ClipboardObject | Reference to a clipboard object. (Inherited from TfrxInPlaceEditor.)
Component | Reference to edited component. (Inherited from TfrxInPlaceEditor.)
Editors | Child editors for current editor class. (Inherited from TfrxInPlaceEditor.)
Item[Integer] | Represents property Item[Integer].
Locked | Editor is locked. (Inherited from TfrxInPlaceEditor.)
ParentComponent | Reference to a parent component. (Inherited from TfrxInPlaceEditor.)
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction.
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter. (Inherited from TfrxInPlaceEditor.)
Count | Represents method Count.
DefaultContentType | Returns default content type supported by InPlcae editor. (Inherited from TfrxInPlaceEditor.)
DestroyPanel | Represents method DestroyPanel.
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoFinishInPlace(TObject,Boolean,Boolean) | Calls OnFinishInPlace event handler. (Inherited from TfrxInPlaceEditor.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DrawCustomEditor(TCanvas,TRect) | Draws object editor over object canvas. (Overrides TfrxInPlaceEditor.DrawCustomEditor(TCanvas,TRect).)
EditInPlace(TComponent,TRect) | Represents method EditInPlace(TComponent,TRect). (Inherited from TfrxInPlaceEditor.)
EditInPlaceDone | This method should close in place editor and apply changes to edited object. (Inherited from TfrxInPlaceEditor.)
FillData | Not used. (Inherited from TfrxInPlaceEditor.)
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves. (Overrides TfrxInPlaceEditor.FinalizeUI(TfrxInteractiveEventsParams).)
GetActiveRect | Returns active work area of the editor. (Overrides TfrxInPlaceEditor.GetActiveRect.)
GetColor(Integer) | Represents method GetColor(Integer).
GetItem(Integer) | Represents method GetItem(Integer).
GetName(Integer) | Represents method GetName(Integer).
HasCustomEditor | Not used. (Inherited from TfrxInPlaceEditor.)
HasInPlaceEditor | Not used. (Inherited from TfrxInPlaceEditor.)
InitializeUI(TfrxInteractiveEventsParams) | Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves. (Overrides TfrxInPlaceEditor.InitializeUI(TfrxInteractiveEventsParams).)
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
SetComponent(TfrxComponent) | Represents method SetComponent(TfrxComponent). (Inherited from TfrxInPlaceEditor.)
SetItem(Integer,Boolean) | Represents method SetItem(Integer,Boolean).
SetOffset(Extended,Extended,Extended) | Sets parameters used by the report preview or the report designer. (Inherited from TfrxInPlaceEditor.)
Top
Events
Show:
Name | Description
OnFinishInPlace | An event used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor. (Inherited from TfrxInPlaceEditor.)
Top
Fields
Show:
Name | Description
FButtonsPanel | Represents field FButtonsPanel.
FClassRef | Represents field FClassRef. (Inherited from TfrxInPlaceEditor.)
FClipboardObject | Represents field FClipboardObject. (Inherited from TfrxInPlaceEditor.)
FComponent | Represents field FComponent. (Inherited from TfrxInPlaceEditor.)
FComponents | Represents field FComponents. (Inherited from TfrxInPlaceEditor.)
FDevicePPI | Represents field FDevicePPI. (Inherited from TfrxInPlaceEditor.)
FEditors | Represents field FEditors. (Inherited from TfrxInPlaceEditor.)
FLocked | Represents field FLocked. (Inherited from TfrxInPlaceEditor.)
FMouseDown | Represents field FMouseDown.
FOffsetX | Represents field FOffsetX. (Inherited from TfrxInPlaceEditor.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxInPlaceEditor.)
FOnFinishInPlace | Represents field FOnFinishInPlace. (Inherited from TfrxInPlaceEditor.)
FOwner | Represents field FOwner. (Inherited from TfrxInPlaceEditor.)
FParentComponent | Represents field FParentComponent. (Inherited from TfrxInPlaceEditor.)
FPosition | Represents field FPosition.
FScale | Represents field FScale. (Inherited from TfrxInPlaceEditor.)
FSwitchMode | Represents field FSwitchMode.
Top
See Also

Reference

  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TfrxInPlaceBasePanelEditor class. (Overrides TfrxInPlaceEditor.Destroy.)
Top


TfrxInPlaceBasePanelEditor.Destroy Destructor

Summary

Represents the destructor of the TfrxInPlaceBasePanelEditor class.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxInPlaceEditor.Destroy
See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor Properties

Properties
Name | Description
Item[Integer] | Represents property Item[Integer].
Top


TfrxInPlaceBasePanelEditor.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 property Item[Index: Integer]: Boolean read GetItem write SetItem;

Parameters

Index
Type: Integer

Property Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor Methods

Methods
Name | Description
AfterConstruction | Represents method AfterConstruction.
Count | Represents method Count.
DestroyPanel | Represents method DestroyPanel.
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DrawCustomEditor(TCanvas,TRect) | Draws object editor over object canvas. (Overrides TfrxInPlaceEditor.DrawCustomEditor(TCanvas,TRect).)
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves. (Overrides TfrxInPlaceEditor.FinalizeUI(TfrxInteractiveEventsParams).)
GetActiveRect | Returns active work area of the editor. (Overrides TfrxInPlaceEditor.GetActiveRect.)
GetColor(Integer) | Represents method GetColor(Integer).
GetItem(Integer) | Represents method GetItem(Integer).
GetName(Integer) | Represents method GetName(Integer).
InitializeUI(TfrxInteractiveEventsParams) | Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves. (Overrides TfrxInPlaceEditor.InitializeUI(TfrxInteractiveEventsParams).)
SetItem(Integer,Boolean) | Represents method SetItem(Integer,Boolean).
Top


TfrxInPlaceBasePanelEditor.AfterConstruction Method

Summary

Represents method AfterConstruction.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 procedure AfterConstruction; override;
See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.Count Method

Summary

Represents method Count.

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 function Count: Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.DestroyPanel Method

Summary

Represents method DestroyPanel.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 function DestroyPanel: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

X
Type: Integer

Current mouse x coordinate.

Y
Type: Integer

Current mouse y coordinate.

Button
Type: TMouseButton

Mouse button.

Shift
Type: TShiftState

Shift buttons states.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

Overrides

TfrxInPlaceEditor.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class InPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 function DoMouseUp(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

X
Type: Integer

Current mouse x coordinate.

Y
Type: Integer

Current mouse y coordinate.

Button
Type: TMouseButton

Mouse button.

Shift
Type: TShiftState

Shift buttons states.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

Overrides

TfrxInPlaceEditor.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.DrawCustomEditor(TCanvas,TRect) Method

Summary

Draws object editor over object canvas.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 procedure DrawCustomEditor(aCanvas: TCanvas; aRect: TRect); override;

Parameters

aCanvas
Type: TCanvas

Destination Canvas.

aRect
Type: TRect

Draw area.

Overrides

TfrxInPlaceEditor.DrawCustomEditor(TCanvas,TRect)
See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.FinalizeUI(TfrxInteractiveEventsParams) Method

Summary

Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 procedure FinalizeUI(var EventParams: TfrxInteractiveEventsParams); override;

Parameters

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Overrides

TfrxInPlaceEditor.FinalizeUI(TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.GetActiveRect Method

Summary

Returns active work area of the editor.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 function GetActiveRect: TRect; override;

Return Value

Type: TRect

Overrides

TfrxInPlaceEditor.GetActiveRect
See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.GetColor(Integer) Method

Summary

Represents method GetColor(Integer).

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 function GetColor(Index: Integer): TColor; virtual; abstract;

Parameters

Index
Type: Integer

Return Value

Type: TColor

See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 function GetItem(Index: Integer): Boolean; virtual; abstract;

Parameters

Index
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.GetName(Integer) Method

Summary

Represents method GetName(Integer).

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 function GetName(Index: Integer): String; virtual; abstract;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.InitializeUI(TfrxInteractiveEventsParams) Method

Summary

Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 procedure InitializeUI(var EventParams: TfrxInteractiveEventsParams); override;

Parameters

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Overrides

TfrxInPlaceEditor.InitializeUI(TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.SetItem(Integer,Boolean) Method

Summary

Represents method SetItem(Integer,Boolean).

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 procedure SetItem(Index: Integer; const Value: Boolean); virtual; abstract;

Parameters

Index
Type: Integer

Value
Type: Boolean

See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor Fields

Fields
Name | Description
FButtonsPanel | Represents field FButtonsPanel.
FMouseDown | Represents field FMouseDown.
FPosition | Represents field FPosition.
FSwitchMode | Represents field FSwitchMode.
Top


TfrxInPlaceBasePanelEditor.FButtonsPanel Field

Summary

Represents field FButtonsPanel.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 FButtonsPanel: TfrxSwitchButtonsPanel;

Field Value

Type: TfrxSwitchButtonsPanel

See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.FMouseDown Field

Summary

Represents field FMouseDown.

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 FMouseDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.FPosition Field

Summary

Represents field FPosition.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 FPosition: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceBasePanelEditor.FSwitchMode Field

Summary

Represents field FSwitchMode.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 FSwitchMode: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceBasePanelEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor Class

Summary

Represents type TfrxInPlaceDataFiledEditor.

Namespace: frxInPlaceEditors
Inheritance Hierarchy
TObject
frxClass.TfrxInPlaceEditor
frxInPlaceEditors.TfrxInPlaceDataFiledEditor
Syntax
Delphi
type
 TfrxInPlaceDataFiledEditor = class(TfrxInPlaceEditor)
 end;

The TfrxInPlaceDataFiledEditor type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponentClass,TWinControl) | Default constructor. (Inherited from TfrxInPlaceEditor.)
Top
Properties
Show:
Name | Description
ClipboardObject | Reference to a clipboard object. (Inherited from TfrxInPlaceEditor.)
Component | Reference to edited component. (Inherited from TfrxInPlaceEditor.)
Editors | Child editors for current editor class. (Inherited from TfrxInPlaceEditor.)
Locked | Editor is locked. (Inherited from TfrxInPlaceEditor.)
ParentComponent | Reference to a parent component. (Inherited from TfrxInPlaceEditor.)
Top
Methods
Show:
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter. (Inherited from TfrxInPlaceEditor.)
DefaultContentType | Returns default content type supported by InPlcae editor. (Inherited from TfrxInPlaceEditor.)
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).)
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).)
DoFinishInPlace(TObject,Boolean,Boolean) | Calls OnFinishInPlace event handler. (Inherited from TfrxInPlaceEditor.)
DoLBClick(TObject) | Represents method DoLBClick(TObject).
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoPopupHide(TObject) | Represents method DoPopupHide(TObject).
DrawCustomEditor(TCanvas,TRect) | Draws object editor over object canvas. (Overrides TfrxInPlaceEditor.DrawCustomEditor(TCanvas,TRect).)
EditInPlace(TComponent,TRect) | Represents method EditInPlace(TComponent,TRect). (Inherited from TfrxInPlaceEditor.)
EditInPlaceDone | This method should close in place editor and apply changes to edited object. (Inherited from TfrxInPlaceEditor.)
FillData | Not used. (Inherited from TfrxInPlaceEditor.)
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves. (Overrides TfrxInPlaceEditor.FinalizeUI(TfrxInteractiveEventsParams).)
GetActiveRect | Returns active work area of the editor. (Inherited from TfrxInPlaceEditor.)
GetButtonSize | Represents method GetButtonSize.
GetParentDS | Represents method GetParentDS.
HasCustomEditor | Not used. (Inherited from TfrxInPlaceEditor.)
HasInPlaceEditor | Not used. (Inherited from TfrxInPlaceEditor.)
InitializeUI(TfrxInteractiveEventsParams) | Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves. (Overrides TfrxInPlaceEditor.InitializeUI(TfrxInteractiveEventsParams).)
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
LBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) | Represents method LBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
SetComponent(TfrxComponent) | Represents method SetComponent(TfrxComponent). (Inherited from TfrxInPlaceEditor.)
SetOffset(Extended,Extended,Extended) | Sets parameters used by the report preview or the report designer. (Inherited from TfrxInPlaceEditor.)
ShowPopup(TComponent,TRect,Integer,Integer) | Represents method ShowPopup(TComponent,TRect,Integer,Integer).
UpdateRect | Represents method UpdateRect.
Top
Events
Show:
Name | Description
OnFinishInPlace | An event used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor. (Inherited from TfrxInPlaceEditor.)
Top
Fields
Show:
Name | Description
FClassRef | Represents field FClassRef. (Inherited from TfrxInPlaceEditor.)
FClipboardObject | Represents field FClipboardObject. (Inherited from TfrxInPlaceEditor.)
FComponent | Represents field FComponent. (Inherited from TfrxInPlaceEditor.)
FComponents | Represents field FComponents. (Inherited from TfrxInPlaceEditor.)
FDevicePPI | Represents field FDevicePPI. (Inherited from TfrxInPlaceEditor.)
FDrawButton | Represents field FDrawButton.
FDRawDragDrop | Represents field FDRawDragDrop.
FDrawDropDown | Represents field FDrawDropDown.
FEditors | Represents field FEditors. (Inherited from TfrxInPlaceEditor.)
FListBox | Represents field FListBox.
FLocked | Represents field FLocked. (Inherited from TfrxInPlaceEditor.)
FModified | Represents field FModified.
FOffsetX | Represents field FOffsetX. (Inherited from TfrxInPlaceEditor.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxInPlaceEditor.)
FOnFinishInPlace | Represents field FOnFinishInPlace. (Inherited from TfrxInPlaceEditor.)
FOwner | Represents field FOwner. (Inherited from TfrxInPlaceEditor.)
FParentComponent | Represents field FParentComponent. (Inherited from TfrxInPlaceEditor.)
FPopupForm | Represents field FPopupForm.
FRect | Represents field FRect.
FScale | Represents field FScale. (Inherited from TfrxInPlaceEditor.)
Top
See Also

Reference

  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor Methods

Methods
Name | Description
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams).)
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).)
DoLBClick(TObject) | Represents method DoLBClick(TObject).
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoPopupHide(TObject) | Represents method DoPopupHide(TObject).
DrawCustomEditor(TCanvas,TRect) | Draws object editor over object canvas. (Overrides TfrxInPlaceEditor.DrawCustomEditor(TCanvas,TRect).)
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves. (Overrides TfrxInPlaceEditor.FinalizeUI(TfrxInteractiveEventsParams).)
GetButtonSize | Represents method GetButtonSize.
GetParentDS | Represents method GetParentDS.
InitializeUI(TfrxInteractiveEventsParams) | Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves. (Overrides TfrxInPlaceEditor.InitializeUI(TfrxInteractiveEventsParams).)
LBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) | Represents method LBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).
ShowPopup(TComponent,TRect,Integer,Integer) | Represents method ShowPopup(TComponent,TRect,Integer,Integer).
UpdateRect | Represents method UpdateRect.
Top


TfrxInPlaceDataFiledEditor.DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 function DoCustomDragDrop(Source: TObject; X, Y: Integer; var EventParams: TfrxInteractiveEventsParams): Boolean;
 override;

Parameters

Source
Type: TObject

Source object.

X
Type: Integer

Current mouse x coordinate.

Y
Type: Integer

Current mouse y coordinate.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

Overrides

TfrxInPlaceEditor.DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 function DoCustomDragOver(Source: TObject; X, Y: Integer; State: TDragState;
 var Accept: Boolean; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

Source
Type: TObject

Source object.

X
Type: Integer

Current mouse x coordinate.

Y
Type: Integer

Current mouse y coordinate.

State
Type: TDragState

State of drag and drop operation.

Accept
Type: Boolean

Should return true when editor accepts drag and drop for current object.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

Overrides

TfrxInPlaceEditor.DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.DoLBClick(TObject) Method

Summary

Represents method DoLBClick(TObject).

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 procedure DoLBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

X
Type: Integer

Current mouse x coordinate.

Y
Type: Integer

Current mouse y coordinate.

Button
Type: TMouseButton

Mouse button.

Shift
Type: TShiftState

Shift buttons states.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

Overrides

TfrxInPlaceEditor.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 function DoMouseMove(X, Y: Integer; Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

X
Type: Integer

Current mouse x coordinate.

Y
Type: Integer

Current mouse y coordinate.

Shift
Type: TShiftState

Shift buttons states.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

Overrides

TfrxInPlaceEditor.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.DoPopupHide(TObject) Method

Summary

Represents method DoPopupHide(TObject).

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 procedure DoPopupHide(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.DrawCustomEditor(TCanvas,TRect) Method

Summary

Draws object editor over object canvas.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 procedure DrawCustomEditor(aCanvas: TCanvas; aRect: TRect); override;

Parameters

aCanvas
Type: TCanvas

Destination Canvas.

aRect
Type: TRect

Draw area.

Overrides

TfrxInPlaceEditor.DrawCustomEditor(TCanvas,TRect)
See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.FinalizeUI(TfrxInteractiveEventsParams) Method

Summary

Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 procedure FinalizeUI(var EventParams: TfrxInteractiveEventsParams); override;

Parameters

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Overrides

TfrxInPlaceEditor.FinalizeUI(TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.GetButtonSize Method

Summary

Represents method GetButtonSize.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 function GetButtonSize: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.GetParentDS Method

Summary

Represents method GetParentDS.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 function GetParentDS: TfrxDataSet;

Return Value

Type: TfrxDataSet

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.InitializeUI(TfrxInteractiveEventsParams) Method

Summary

Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 procedure InitializeUI(var EventParams: TfrxInteractiveEventsParams); override;

Parameters

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Overrides

TfrxInPlaceEditor.InitializeUI(TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.LBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) Method

Summary

Represents method LBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 procedure LBDrawItem(Control: TWinControl; Index: Integer; aRect: TRect;
 State: TOwnerDrawState);

Parameters

Control
Type: TWinControl

Index
Type: Integer

aRect
Type: TRect

State
Type: TOwnerDrawState

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.ShowPopup(TComponent,TRect,Integer,Integer) Method

Summary

Represents method ShowPopup(TComponent,TRect,Integer,Integer).

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 function ShowPopup(aParent: TComponent; aRect: TRect; X, Y: Integer)
 : Boolean;

Parameters

aParent
Type: TComponent

aRect
Type: TRect

X
Type: Integer

Y
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.UpdateRect Method

Summary

Represents method UpdateRect.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 procedure UpdateRect;
See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor Fields

Fields
Name | Description
FDrawButton | Represents field FDrawButton.
FDRawDragDrop | Represents field FDRawDragDrop.
FDrawDropDown | Represents field FDrawDropDown.
FListBox | Represents field FListBox.
FModified | Represents field FModified.
FPopupForm | Represents field FPopupForm.
FRect | Represents field FRect.
Top


TfrxInPlaceDataFiledEditor.FDrawButton Field

Summary

Represents field FDrawButton.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 FDrawButton: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.FDRawDragDrop Field

Summary

Represents field FDRawDragDrop.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 FDRawDragDrop: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.FDrawDropDown Field

Summary

Represents field FDrawDropDown.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 FDrawDropDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.FListBox Field

Summary

Represents field FListBox.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 FListBox: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.FModified Field

Summary

Represents field FModified.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 FModified: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.FPopupForm Field

Summary

Represents field FPopupForm.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 FPopupForm: TfrxPopupForm;

Field Value

Type: TfrxPopupForm

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceDataFiledEditor.FRect Field

Summary

Represents field FRect.

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 FRect: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxInPlaceDataFiledEditor
  • frxInPlaceEditors


TfrxInPlaceMemoEditor Class

Summary

Represents type TfrxInPlaceMemoEditor.

Namespace: frxInPlaceEditors
Inheritance Hierarchy
TObject
frxClass.TfrxInPlaceEditor
frxInPlaceEditors.TfrxInPlaceMemoEditorBase
frxInPlaceEditors.TfrxInPlaceTextEditorBase
frxInPlaceEditors.TfrxInPlaceMemoEditor
Syntax
Delphi
type
 TfrxInPlaceMemoEditor = class(TfrxInPlaceTextEditorBase)
 end;

The TfrxInPlaceMemoEditor type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponentClass,TWinControl) | Default constructor. (Overrides TfrxInPlaceEditor.Create(TfrxComponentClass,TWinControl).)
Top
Properties
Show:
Name | Description
ClipboardObject | Reference to a clipboard object. (Inherited from TfrxInPlaceEditor.)
Component | Reference to edited component. (Inherited from TfrxInPlaceEditor.)
Editors | Child editors for current editor class. (Inherited from TfrxInPlaceEditor.)
Locked | Editor is locked. (Inherited from TfrxInPlaceEditor.)
ParentComponent | Reference to a parent component. (Inherited from TfrxInPlaceEditor.)
Top
Methods
Show:
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter. (Inherited from TfrxInPlaceEditor.)
CreateMemo | Represents method CreateMemo. (Overrides TfrxInPlaceMemoEditorBase.CreateMemo.)
DefaultContentType | Returns default content type supported by InPlcae editor. (Inherited from TfrxInPlaceEditor.)
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoFinishInPlace(TObject,Boolean,Boolean) | Calls OnFinishInPlace event handler. (Inherited from TfrxInPlaceEditor.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
DrawCustomEditor(TCanvas,TRect) | Draws object editor over object canvas. (Inherited from TfrxInPlaceEditor.)
EditDone | Represents method EditDone. (Inherited from TfrxInPlaceMemoEditorBase.)
EditInPlace(TComponent,TRect) | Represents method EditInPlace(TComponent,TRect). (Overrides TfrxInPlaceEditor.EditInPlace(TComponent,TRect).)
EditInPlaceDone | This method should close in place editor and apply changes to edited object. (Overrides TfrxInPlaceEditor.EditInPlaceDone.)
FillData | Not used. (Inherited from TfrxInPlaceEditor.)
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves. (Overrides TfrxInPlaceEditor.FinalizeUI(TfrxInteractiveEventsParams).)
GetActiveRect | Returns active work area of the editor. (Inherited from TfrxInPlaceEditor.)
HasCustomEditor | Not used. (Overrides TfrxInPlaceEditor.HasCustomEditor.)
HasInPlaceEditor | Not used. (Inherited from TfrxInPlaceEditor.)
InitComponentFromControl | Represents method InitComponentFromControl. (Overrides TfrxInPlaceMemoEditorBase.InitComponentFromControl.)
InitControlFromComponent | Represents method InitControlFromComponent. (Overrides TfrxInPlaceMemoEditorBase.InitControlFromComponent.)
InitializeUI(TfrxInteractiveEventsParams) | Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves. (Inherited from TfrxInPlaceEditor.)
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
SetComponent(TfrxComponent) | Represents method SetComponent(TfrxComponent). (Inherited from TfrxInPlaceEditor.)
SetOffset(Extended,Extended,Extended) | Sets parameters used by the report preview or the report designer. (Inherited from TfrxInPlaceEditor.)
Top
Events
Show:
Name | Description
OnFinishInPlace | An event used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor. (Inherited from TfrxInPlaceEditor.)
Top
Fields
Show:
Name | Description
FClassRef | Represents field FClassRef. (Inherited from TfrxInPlaceEditor.)
FClipboardObject | Represents field FClipboardObject. (Inherited from TfrxInPlaceEditor.)
FComponent | Represents field FComponent. (Inherited from TfrxInPlaceEditor.)
FComponents | Represents field FComponents. (Inherited from TfrxInPlaceEditor.)
FDevicePPI | Represents field FDevicePPI. (Inherited from TfrxInPlaceEditor.)
FEdited | Represents field FEdited. (Inherited from TfrxInPlaceMemoEditorBase.)
FEditors | Represents field FEditors. (Inherited from TfrxInPlaceEditor.)
FInPlaceMemo | Represents field FInPlaceMemo. (Inherited from TfrxInPlaceMemoEditorBase.)
FLocked | Represents field FLocked. (Inherited from TfrxInPlaceEditor.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxInPlaceEditor.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxInPlaceEditor.)
FOnFinishInPlace | Represents field FOnFinishInPlace. (Inherited from TfrxInPlaceEditor.)
FOwner | Represents field FOwner. (Inherited from TfrxInPlaceEditor.)
FParentComponent | Represents field FParentComponent. (Inherited from TfrxInPlaceEditor.)
FScale | Represents field FScale. (Inherited from TfrxInPlaceEditor.)
Top
See Also

Reference

  • frxInPlaceEditors


TfrxInPlaceMemoEditor Methods

Methods
Name | Description
InitComponentFromControl | Represents method InitComponentFromControl. (Overrides TfrxInPlaceMemoEditorBase.InitComponentFromControl.)
InitControlFromComponent | Represents method InitControlFromComponent. (Overrides TfrxInPlaceMemoEditorBase.InitControlFromComponent.)
Top


TfrxInPlaceMemoEditor.InitComponentFromControl Method

Summary

Represents method InitComponentFromControl.

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 procedure InitComponentFromControl; override;

Overrides

TfrxInPlaceMemoEditorBase.InitComponentFromControl
See Also

Reference

  • TfrxInPlaceMemoEditor
  • frxInPlaceEditors


TfrxInPlaceMemoEditor.InitControlFromComponent Method

Summary

Represents method InitControlFromComponent.

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 procedure InitControlFromComponent; override;

Overrides

TfrxInPlaceMemoEditorBase.InitControlFromComponent
See Also

Reference

  • TfrxInPlaceMemoEditor
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase Class

Summary

Represents type TfrxInPlaceMemoEditorBase.

Namespace: frxInPlaceEditors
Inheritance Hierarchy
TObject
frxClass.TfrxInPlaceEditor
frxInPlaceEditors.TfrxInPlaceMemoEditorBase
frxInPlaceEditors.TfrxInPlaceTextEditorBase
Syntax
Delphi
type
 TfrxInPlaceMemoEditorBase = class(TfrxInPlaceEditor)
 end;

The TfrxInPlaceMemoEditorBase type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponentClass,TWinControl) | Default constructor. (Overrides TfrxInPlaceEditor.Create(TfrxComponentClass,TWinControl).)
Destroy | Represents the destructor of the TfrxInPlaceMemoEditorBase class. (Overrides TfrxInPlaceEditor.Destroy.)
Top
Properties
Show:
Name | Description
ClipboardObject | Reference to a clipboard object. (Inherited from TfrxInPlaceEditor.)
Component | Reference to edited component. (Inherited from TfrxInPlaceEditor.)
Editors | Child editors for current editor class. (Inherited from TfrxInPlaceEditor.)
Locked | Editor is locked. (Inherited from TfrxInPlaceEditor.)
ParentComponent | Reference to a parent component. (Inherited from TfrxInPlaceEditor.)
Top
Methods
Show:
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter. (Inherited from TfrxInPlaceEditor.)
CreateMemo | Represents method CreateMemo.
DefaultContentType | Returns default content type supported by InPlcae editor. (Inherited from TfrxInPlaceEditor.)
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoExit(TObject) | Represents method DoExit(TObject).
DoFinishInPlace(TObject,Boolean,Boolean) | Calls OnFinishInPlace event handler. (Inherited from TfrxInPlaceEditor.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
DrawCustomEditor(TCanvas,TRect) | Draws object editor over object canvas. (Inherited from TfrxInPlaceEditor.)
EditDone | Represents method EditDone.
EditInPlace(TComponent,TRect) | Represents method EditInPlace(TComponent,TRect). (Overrides TfrxInPlaceEditor.EditInPlace(TComponent,TRect).)
EditInPlaceDone | This method should close in place editor and apply changes to edited object. (Overrides TfrxInPlaceEditor.EditInPlaceDone.)
FillData | Not used. (Inherited from TfrxInPlaceEditor.)
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves. (Overrides TfrxInPlaceEditor.FinalizeUI(TfrxInteractiveEventsParams).)
GetActiveRect | Returns active work area of the editor. (Inherited from TfrxInPlaceEditor.)
HasCustomEditor | Not used. (Overrides TfrxInPlaceEditor.HasCustomEditor.)
HasInPlaceEditor | Not used. (Inherited from TfrxInPlaceEditor.)
InitComponentFromControl | Represents method InitComponentFromControl.
InitControlFromComponent | Represents method InitControlFromComponent.
InitializeUI(TfrxInteractiveEventsParams) | Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves. (Inherited from TfrxInPlaceEditor.)
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
LinesChange(TObject) | Represents method LinesChange(TObject).
MemoKeyDown(TObject,Word,TShiftState) | Represents method MemoKeyDown(TObject,Word,TShiftState).
MemoKeyPress(TObject,Char) | Represents method MemoKeyPress(TObject,Char).
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
SetComponent(TfrxComponent) | Represents method SetComponent(TfrxComponent). (Inherited from TfrxInPlaceEditor.)
SetOffset(Extended,Extended,Extended) | Sets parameters used by the report preview or the report designer. (Inherited from TfrxInPlaceEditor.)
Top
Events
Show:
Name | Description
OnFinishInPlace | An event used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor. (Inherited from TfrxInPlaceEditor.)
Top
Fields
Show:
Name | Description
FClassRef | Represents field FClassRef. (Inherited from TfrxInPlaceEditor.)
FClipboardObject | Represents field FClipboardObject. (Inherited from TfrxInPlaceEditor.)
FComponent | Represents field FComponent. (Inherited from TfrxInPlaceEditor.)
FComponents | Represents field FComponents. (Inherited from TfrxInPlaceEditor.)
FDevicePPI | Represents field FDevicePPI. (Inherited from TfrxInPlaceEditor.)
FEdited | Represents field FEdited.
FEditors | Represents field FEditors. (Inherited from TfrxInPlaceEditor.)
FInPlaceMemo | Represents field FInPlaceMemo.
FLocked | Represents field FLocked. (Inherited from TfrxInPlaceEditor.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxInPlaceEditor.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxInPlaceEditor.)
FOnFinishInPlace | Represents field FOnFinishInPlace. (Inherited from TfrxInPlaceEditor.)
FOwner | Represents field FOwner. (Inherited from TfrxInPlaceEditor.)
FParentComponent | Represents field FParentComponent. (Inherited from TfrxInPlaceEditor.)
FScale | Represents field FScale. (Inherited from TfrxInPlaceEditor.)
Top
See Also

Reference

  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase Constructors

Constructors
Name | Description
Create(TfrxComponentClass,TWinControl) | Default constructor. (Overrides TfrxInPlaceEditor.Create(TfrxComponentClass,TWinControl).)
Destroy | Represents the destructor of the TfrxInPlaceMemoEditorBase class. (Overrides TfrxInPlaceEditor.Destroy.)
Top


TfrxInPlaceMemoEditorBase.Create(TfrxComponentClass,TWinControl) Constructor

Summary

Default constructor.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 constructor Create(aClassRef: TfrxComponentClass;
 aOwner: TWinControl); override;

Parameters

aClassRef
Type: TfrxComponentClass

Class reference of report component used in the editor.

aOwner
Type: TWinControl

Widow control which owns editor(designer or preview).

Overrides

TfrxInPlaceEditor.Create(TfrxComponentClass,TWinControl)
See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.Destroy Destructor

Summary

Represents the destructor of the TfrxInPlaceMemoEditorBase class.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxInPlaceEditor.Destroy
See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase Methods

Methods
Name | Description
CreateMemo | Represents method CreateMemo.
DoExit(TObject) | Represents method DoExit(TObject).
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
EditDone | Represents method EditDone.
EditInPlace(TComponent,TRect) | Represents method EditInPlace(TComponent,TRect). (Overrides TfrxInPlaceEditor.EditInPlace(TComponent,TRect).)
EditInPlaceDone | This method should close in place editor and apply changes to edited object. (Overrides TfrxInPlaceEditor.EditInPlaceDone.)
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves. (Overrides TfrxInPlaceEditor.FinalizeUI(TfrxInteractiveEventsParams).)
HasCustomEditor | Not used. (Overrides TfrxInPlaceEditor.HasCustomEditor.)
InitComponentFromControl | Represents method InitComponentFromControl.
InitControlFromComponent | Represents method InitControlFromComponent.
LinesChange(TObject) | Represents method LinesChange(TObject).
MemoKeyDown(TObject,Word,TShiftState) | Represents method MemoKeyDown(TObject,Word,TShiftState).
MemoKeyPress(TObject,Char) | Represents method MemoKeyPress(TObject,Char).
Top


TfrxInPlaceMemoEditorBase.CreateMemo Method

Summary

Represents method CreateMemo.

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 procedure CreateMemo; virtual; abstract;
See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.DoExit(TObject) Method

Summary

Represents method DoExit(TObject).

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 procedure DoExit(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class InPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 function DoMouseUp(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

X
Type: Integer

Current mouse x coordinate.

Y
Type: Integer

Current mouse y coordinate.

Button
Type: TMouseButton

Mouse button.

Shift
Type: TShiftState

Shift buttons states.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

Overrides

TfrxInPlaceEditor.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) Method

Summary

The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 function DoMouseWheel(Shift: TShiftState;
 WheelDelta: Integer; MousePos: TPoint; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

Shift
Type: TShiftState

Shift buttons states.

WheelDelta
Type: Integer

Mouse wheel delta.

MousePos
Type: TPoint

Cursor position when event were fired.

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Return Value

Type: Boolean

Overrides

TfrxInPlaceEditor.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.EditDone Method

Summary

Represents method EditDone.

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 procedure EditDone;
See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.EditInPlace(TComponent,TRect) Method

Summary

Represents method EditInPlace(TComponent,TRect).

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 procedure EditInPlace(aParent: TComponent; aRect: TRect); override;

Parameters

aParent
Type: TComponent

aRect
Type: TRect

Overrides

TfrxInPlaceEditor.EditInPlace(TComponent,TRect)
See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.EditInPlaceDone Method

Summary

This method should close in place editor and apply changes to edited object.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 function EditInPlaceDone: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxInPlaceEditor.EditInPlaceDone
See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.FinalizeUI(TfrxInteractiveEventsParams) Method

Summary

Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 procedure FinalizeUI(var EventParams: TfrxInteractiveEventsParams); override;

Parameters

EventParams
Type: TfrxInteractiveEventsParams

Structure with parameters of interactive events.

Overrides

TfrxInPlaceEditor.FinalizeUI(TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.HasCustomEditor Method

Summary

Not used.

Namespace: frxInPlaceEditors
Syntax
Delphi
public
 function HasCustomEditor: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxInPlaceEditor.HasCustomEditor
See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.InitComponentFromControl Method

Summary

Represents method InitComponentFromControl.

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 procedure InitComponentFromControl; virtual;
See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.InitControlFromComponent Method

Summary

Represents method InitControlFromComponent.

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 procedure InitControlFromComponent; virtual;
See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.LinesChange(TObject) Method

Summary

Represents method LinesChange(TObject).

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 procedure LinesChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.MemoKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method MemoKeyDown(TObject,Word,TShiftState).

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 procedure MemoKeyDown(Sender: TObject; var Key: Word;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.MemoKeyPress(TObject,Char) Method

Summary

Represents method MemoKeyPress(TObject,Char).

Namespace: frxInPlaceEditors
Syntax
Delphi
private
 procedure MemoKeyPress(Sender: TObject; var Key: Char);

Parameters

Sender
Type: TObject

Key
Type: Char

See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase Fields

Fields
Name | Description
FEdited | Represents field FEdited.
FInPlaceMemo | Represents field FInPlaceMemo.
Top


TfrxInPlaceMemoEditorBase.FEdited Field

Summary

Represents field FEdited.

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 FEdited: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceMemoEditorBase.FInPlaceMemo Field

Summary

Represents field FInPlaceMemo.

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 FInPlaceMemo: TCustomMemo;

Field Value

Type: TCustomMemo

See Also

Reference

  • TfrxInPlaceMemoEditorBase
  • frxInPlaceEditors


TfrxInPlaceTextEditorBase Class

Summary

Represents type TfrxInPlaceTextEditorBase.

Namespace: frxInPlaceEditors
Inheritance Hierarchy
TObject
frxClass.TfrxInPlaceEditor
frxInPlaceEditors.TfrxInPlaceMemoEditorBase
frxInPlaceEditors.TfrxInPlaceTextEditorBase
frxInPlaceEditors.TfrxInPlaceMemoEditor
Syntax
Delphi
type
 TfrxInPlaceTextEditorBase = class(TfrxInPlaceMemoEditorBase)
 end;

The TfrxInPlaceTextEditorBase type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxComponentClass,TWinControl) | Default constructor. (Overrides TfrxInPlaceEditor.Create(TfrxComponentClass,TWinControl).)
Top
Properties
Show:
Name | Description
ClipboardObject | Reference to a clipboard object. (Inherited from TfrxInPlaceEditor.)
Component | Reference to edited component. (Inherited from TfrxInPlaceEditor.)
Editors | Child editors for current editor class. (Inherited from TfrxInPlaceEditor.)
Locked | Editor is locked. (Inherited from TfrxInPlaceEditor.)
ParentComponent | Reference to a parent component. (Inherited from TfrxInPlaceEditor.)
Top
Methods
Show:
Name | Description
CopyContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
CopyGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | This method serves copy behaviour for the group of objects. The object selection passed in EventParams.SelectionList parameter. (Inherited from TfrxInPlaceEditor.)
CreateMemo | Represents method CreateMemo. (Overrides TfrxInPlaceMemoEditorBase.CreateMemo.)
DefaultContentType | Returns default content type supported by InPlcae editor. (Inherited from TfrxInPlaceEditor.)
DoCustomDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoCustomDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoFinishInPlace(TObject,Boolean,Boolean) | Calls OnFinishInPlace event handler. (Inherited from TfrxInPlaceEditor.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Inherited from TfrxInPlaceEditor.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | The report engine calls it when DragOver operation is active over the object with class that InPlace editor serves. (Overrides TfrxInPlaceEditor.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
DrawCustomEditor(TCanvas,TRect) | Draws object editor over object canvas. (Inherited from TfrxInPlaceEditor.)
EditDone | Represents method EditDone. (Inherited from TfrxInPlaceMemoEditorBase.)
EditInPlace(TComponent,TRect) | Represents method EditInPlace(TComponent,TRect). (Overrides TfrxInPlaceEditor.EditInPlace(TComponent,TRect).)
EditInPlaceDone | This method should close in place editor and apply changes to edited object. (Overrides TfrxInPlaceEditor.EditInPlaceDone.)
FillData | Not used. (Inherited from TfrxInPlaceEditor.)
FinalizeUI(TfrxInteractiveEventsParams) | Finalize UI of in place editor when mouse cursor leaves area which inPlace editor serves. (Overrides TfrxInPlaceEditor.FinalizeUI(TfrxInteractiveEventsParams).)
GetActiveRect | Returns active work area of the editor. (Inherited from TfrxInPlaceEditor.)
HasCustomEditor | Not used. (Overrides TfrxInPlaceEditor.HasCustomEditor.)
HasInPlaceEditor | Not used. (Inherited from TfrxInPlaceEditor.)
InitComponentFromControl | Represents method InitComponentFromControl. (Inherited from TfrxInPlaceMemoEditorBase.)
InitControlFromComponent | Represents method InitControlFromComponent. (Inherited from TfrxInPlaceMemoEditorBase.)
InitializeUI(TfrxInteractiveEventsParams) | Initialize UI of in place editor when mouse cursor enters area which inPlace editor serves. (Inherited from TfrxInPlaceEditor.)
IsPasteAvailable(TfrxComponent,TfrxInteractiveEventsParams,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
PasteContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
PasteGoupContent(TfrxComponent,TfrxInteractiveEventsParams,TStream,TfrxCopyPasteType) | (Inherited from TfrxInPlaceEditor.)
SetComponent(TfrxComponent) | Represents method SetComponent(TfrxComponent). (Inherited from TfrxInPlaceEditor.)
SetOffset(Extended,Extended,Extended) | Sets parameters used by the report preview or the report designer. (Inherited from TfrxInPlaceEditor.)
Top
Events
Show:
Name | Description
OnFinishInPlace | An event used in InPlace editors. Event fires when the report designer or the report preview close InPlace editor. (Inherited from TfrxInPlaceEditor.)
Top
Fields
Show:
Name | Description
FClassRef | Represents field FClassRef. (Inherited from TfrxInPlaceEditor.)
FClipboardObject | Represents field FClipboardObject. (Inherited from TfrxInPlaceEditor.)
FComponent | Represents field FComponent. (Inherited from TfrxInPlaceEditor.)
FComponents | Represents field FComponents. (Inherited from TfrxInPlaceEditor.)
FDevicePPI | Represents field FDevicePPI. (Inherited from TfrxInPlaceEditor.)
FEdited | Represents field FEdited. (Inherited from TfrxInPlaceMemoEditorBase.)
FEditors | Represents field FEditors. (Inherited from TfrxInPlaceEditor.)
FInPlaceMemo | Represents field FInPlaceMemo. (Inherited from TfrxInPlaceMemoEditorBase.)
FLocked | Represents field FLocked. (Inherited from TfrxInPlaceEditor.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxInPlaceEditor.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxInPlaceEditor.)
FOnFinishInPlace | Represents field FOnFinishInPlace. (Inherited from TfrxInPlaceEditor.)
FOwner | Represents field FOwner. (Inherited from TfrxInPlaceEditor.)
FParentComponent | Represents field FParentComponent. (Inherited from TfrxInPlaceEditor.)
FScale | Represents field FScale. (Inherited from TfrxInPlaceEditor.)
Top
See Also

Reference

  • frxInPlaceEditors


TfrxInPlaceTextEditorBase Methods

Methods
Name | Description
CreateMemo | Represents method CreateMemo. (Overrides TfrxInPlaceMemoEditorBase.CreateMemo.)
Top


TfrxInPlaceTextEditorBase.CreateMemo Method

Summary

Represents method CreateMemo.

Namespace: frxInPlaceEditors
Syntax
Delphi
protected
 procedure CreateMemo; override;

Overrides

TfrxInPlaceMemoEditorBase.CreateMemo
See Also

Reference

  • TfrxInPlaceTextEditorBase
  • frxInPlaceEditors


frxInsp Namespace

Summary

Represents namespace frxInsp.

Classes
Name | Description
TfrxObjectInspector | Represents type TfrxObjectInspector.
Top


frxInsp Classes

Classes
Name | Description
TfrxObjectInspector | Represents type TfrxObjectInspector.
Top


TfrxObjectInspector Class

Summary

Represents type TfrxObjectInspector.

Namespace: frxInsp
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxInsp.TfrxObjectInspector
Syntax
Delphi
type
 TfrxObjectInspector = class(TfrxBaseForm)
 end;

The TfrxObjectInspector type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxObjectInspector class. (Overrides TfrxBaseForm.Create(TComponent).)
Destroy | Represents the destructor of the TfrxObjectInspector class.
Top
Properties
Show:
Name | Description
CurrentFormPPI | Returns current PPI value of the form. (Inherited from TfrxBaseForm.)
FileterMaxWidth | Represents property FileterMaxWidth.
FileterMinWidth | Represents property FileterMinWidth.
Filter | Represents property Filter.
IsPPIChanging | Represents property IsPPIChanging. (Inherited from TfrxBaseForm.)
ItemIndex | Represents property ItemIndex.
Objects | Represents property Objects.
OnModify | Represents property OnModify.
OnSelectionChanged | Represents property OnSelectionChanged.
SelectedObjects | Represents property SelectedObjects.
Splitter1Pos | Represents property Splitter1Pos.
SplitterPos | Represents property SplitterPos.
Top
Methods
Show:
Name | Description
AdjustControls | Represents method AdjustControls.
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseForm.)
AfterPPIChange | Represents method AfterPPIChange. (Inherited from TfrxBaseForm.)
AfterPPIMessage | Represents method AfterPPIMessage. (Inherited from TfrxBaseForm.)
BeforeDestruction | Represents method BeforeDestruction. (Inherited from TfrxBaseForm.)
BeforePPIChange | Represents method BeforePPIChange. (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer). (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean). (Inherited from TfrxBaseForm.)
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage).
ComboBtnClick(TObject) | Represents method ComboBtnClick(TObject).
ComboBtnMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method ComboBtnMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
Count | Represents method Count.
DisableUpdate | Represents method DisableUpdate.
DoClose(TCloseAction) | Represents method DoClose(TCloseAction). (Inherited from TfrxBaseForm.)
DoModify | Represents method DoModify.
DoShow | Represents method DoShow. (Inherited from TfrxBaseForm.)
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer). (Inherited from TfrxBaseForm.)
DrawOneLine(Integer,Boolean) | Represents method DrawOneLine(Integer,Boolean).
Edit1KeyDown(TObject,Word,TShiftState) | Represents method Edit1KeyDown(TObject,Word,TShiftState).
Edit1KeyPress(TObject,Char) | Represents method Edit1KeyPress(TObject,Char).
Edit1MouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method Edit1MouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
EditBtnClick(TObject) | Represents method EditBtnClick(TObject).
EnableUpdate | Represents method EnableUpdate.
FilterChange(TObject) | Represents method FilterChange(TObject).
FormDeactivate(TObject) | Represents method FormDeactivate(TObject).
FormEndDock(TObject,TObject,Integer,Integer) | Represents method FormEndDock(TObject,TObject,Integer,Integer).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
FormMouseWheelDown(TObject,TShiftState,TPoint,Boolean) | Represents method FormMouseWheelDown(TObject,TShiftState,TPoint,Boolean).
FormMouseWheelUp(TObject,TShiftState,TPoint,Boolean) | Represents method FormMouseWheelUp(TObject,TShiftState,TPoint,Boolean).
FormResize(TObject) | Represents method FormResize(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
FormShowAfterLoad | Represents method FormShowAfterLoad. (Inherited from TfrxBaseForm.)
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Inherited from TfrxBaseForm.)
GetAvailablePreferences | Represents method GetAvailablePreferences. (Inherited from TfrxBaseForm.)
GetFormSectionName | Represents method GetFormSectionName. (Inherited from TfrxBaseForm.)
GetItem(Integer) | Represents method GetItem(Integer).
GetName(Integer) | Represents method GetName(Integer).
GetOffset(Integer) | Represents method GetOffset(Integer).
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Inherited from TfrxBaseForm.)
GetSplitter1Pos | Represents method GetSplitter1Pos.
GetType(Integer) | Represents method GetType(Integer).
GetValue(Integer) | Represents method GetValue(Integer).
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Inherited from TfrxBaseForm.)
Inspect(TPersistent[]) | Represents method Inspect(TPersistent[]).
LBClick(TObject) | Represents method LBClick(TObject).
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.LoadFormPreferences(TObject,TObject).)
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
N11Click(TObject) | Represents method N11Click(TObject).
N21Click(TObject) | Represents method N21Click(TObject).
N31Click(TObject) | Represents method N31Click(TObject).
ObjectsCBClick(TObject) | Represents method ObjectsCBClick(TObject).
ObjectsCBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) | Represents method ObjectsCBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).
ObjectsCBDropDown(TObject) | Represents method ObjectsCBDropDown(TObject).
PBDblClick(TObject) | Represents method PBDblClick(TObject).
PBMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method PBMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
PBMouseMove(TObject,TShiftState,Integer,Integer) | Represents method PBMouseMove(TObject,TShiftState,Integer,Integer).
PBMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method PBMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer).
PBOnDragDrop(TObject,TObject,Integer,Integer) | Represents method PBOnDragDrop(TObject,TObject,Integer,Integer).
PBOnDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method PBOnDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
PBPaint(TObject) | Represents method PBPaint(TObject).
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter. (Inherited from TfrxBaseForm.)
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Inherited from TfrxBaseForm.)
RestorePosition | Represents method RestorePosition.
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.SaveFormPreferences(TObject,TObject).)
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
SavePosition | Represents method SavePosition.
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxBaseForm.)
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms. (Inherited from TfrxBaseForm.)
SetColor(TColor) | Represents method SetColor(TColor).
SetFileterMaxWidth(Integer) | Represents method SetFileterMaxWidth(Integer).
SetFileterMinWidth(Integer) | Represents method SetFileterMinWidth(Integer).
SetFilter(String) | Represents method SetFilter(String).
SetItemIndex(Integer) | Represents method SetItemIndex(Integer).
SetObjects(TList) | Represents method SetObjects(TList).
SetSelectedObjects(TfrxSelectedObjectsList) | Represents method SetSelectedObjects(TfrxSelectedObjectsList).
SetSplitter1Pos(Integer) | Represents method SetSplitter1Pos(Integer).
SetValue(Integer,String) | Represents method SetValue(Integer,String).
TabChange(TObject) | Represents method TabChange(TObject).
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form. (Inherited from TfrxBaseForm.)
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Overrides TfrxBaseForm.UpdateFormPPI(Integer).)
UpdateProperties | Represents method UpdateProperties.
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Inherited from TfrxBaseForm.)
Top
Fields
Show:
Name | Description
BackPanel | Represents field BackPanel.
Box | Represents field Box.
ComboBtn | Represents field ComboBtn.
ComboPanel | Represents field ComboPanel.
DescrL | Represents field DescrL.
Edit1 | Represents field Edit1.
EditBtn | Represents field EditBtn.
EditPanel | Represents field EditPanel.
FColor | Represents field FColor.
FComboBtnGlyph | Represents field FComboBtnGlyph.
FDesigner | Represents field FDesigner.
FDisableDblClick | Represents field FDisableDblClick.
FDisableUpdate | Represents field FDisableUpdate.
FDown | Represents field FDown.
FEditBtnGlyph | Represents field FEditBtnGlyph.
FEventList | Represents field FEventList.
FFileterMaxWidth | Represents field FFileterMaxWidth.
FFileterMinWidth | Represents field FFileterMinWidth.
FFilter | Represents field FFilter.
FFilterEdit | Represents field FFilterEdit.
FHintWindow | Represents field FHintWindow.
FHostedControls | Represents field FHostedControls. (Inherited from TfrxBaseForm.)
FItemIndex | Represents field FItemIndex.
FLastPosition | Represents field FLastPosition.
FList | Represents field FList.
FMaxSavedPos | Represents field FMaxSavedPos.
FOnModify | Represents field FOnModify.
FOnSelectionChanged | Represents field FOnSelectionChanged.
FPanel | Represents field FPanel.
FPopupForm | Represents field FPopupForm.
FPopupLB | Represents field FPopupLB.
FPopupLBVisible | Represents field FPopupLBVisible.
FPrefEvent | Represents field FPrefEvent. (Inherited from TfrxBaseForm.)
FPropertyList | Represents field FPropertyList.
FRowHeight | Represents field FRowHeight.
FSavedPositions | Represents field FSavedPositions.
FSavePosLocked | Represents field FSavePosLocked.
FSelectedObjects | Represents field FSelectedObjects.
FSplitterPos | Represents field FSplitterPos.
FTabs | Represents field FTabs.
FTempBMP | Represents field FTempBMP.
FTempList | Represents field FTempList.
FTickCount | Represents field FTickCount.
FUpdatingObjectsCB | Represents field FUpdatingObjectsCB.
FUpdatingPB | Represents field FUpdatingPB.
HintPanel | Represents field HintPanel.
N11 | Represents field N11.
N21 | Represents field N21.
N31 | Represents field N31.
N41 | Represents field N41.
N51 | Represents field N51.
N61 | Represents field N61.
ObjectsCB | Represents field ObjectsCB.
PB | Represents field PB.
PopupMenu1 | Represents field PopupMenu1.
PropL | Represents field PropL.
Splitter1 | Represents field Splitter1.
Top
See Also

Reference

  • frxInsp


TfrxObjectInspector Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxObjectInspector class. (Overrides TfrxBaseForm.Create(TComponent).)
Destroy | Represents the destructor of the TfrxObjectInspector class.
Top


TfrxObjectInspector.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxObjectInspector class.

Namespace: frxInsp
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxBaseForm.Create(TComponent)
See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.Destroy Destructor

Summary

Represents the destructor of the TfrxObjectInspector class.

Namespace: frxInsp
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector Properties

Properties
Name | Description
FileterMaxWidth | Represents property FileterMaxWidth.
FileterMinWidth | Represents property FileterMinWidth.
Filter | Represents property Filter.
ItemIndex | Represents property ItemIndex.
Objects | Represents property Objects.
OnModify | Represents property OnModify.
OnSelectionChanged | Represents property OnSelectionChanged.
SelectedObjects | Represents property SelectedObjects.
Splitter1Pos | Represents property Splitter1Pos.
SplitterPos | Represents property SplitterPos.
Top


TfrxObjectInspector.FileterMaxWidth Property

Summary

Represents property FileterMaxWidth.

Namespace: frxInsp
Syntax
Delphi
public
 property FileterMaxWidth: Integer read FFileterMaxWidth write SetFileterMaxWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FileterMinWidth Property

Summary

Represents property FileterMinWidth.

Namespace: frxInsp
Syntax
Delphi
public
 property FileterMinWidth: Integer read FFileterMinWidth write SetFileterMinWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.Filter Property

Summary

Represents property Filter.

Namespace: frxInsp
Syntax
Delphi
public
 property Filter: String read FFilter write SetFilter;

Property Value

Type: String

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.ItemIndex Property

Summary

Represents property ItemIndex.

Namespace: frxInsp
Syntax
Delphi
public
 property ItemIndex: Integer read FItemIndex write SetItemIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.Objects Property

Summary

Represents property Objects.

Namespace: frxInsp
Syntax
Delphi
public
 property Objects: TList write SetObjects;

Property Value

Type: TList

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.OnModify Property

Summary

Represents property OnModify.

Namespace: frxInsp
Syntax
Delphi
public
 property OnModify: TNotifyEvent read FOnModify write FOnModify;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.OnSelectionChanged Property

Summary

Represents property OnSelectionChanged.

Namespace: frxInsp
Syntax
Delphi
public
 property OnSelectionChanged: TNotifyEvent read FOnSelectionChanged write FOnSelectionChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SelectedObjects Property

Summary

Represents property SelectedObjects.

Namespace: frxInsp
Syntax
Delphi
public
 property SelectedObjects: TfrxSelectedObjectsList read FSelectedObjects write SetSelectedObjects;

Property Value

Type: TfrxSelectedObjectsList

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.Splitter1Pos Property

Summary

Represents property Splitter1Pos.

Namespace: frxInsp
Syntax
Delphi
public
 property Splitter1Pos: Integer read GetSplitter1Pos write SetSplitter1Pos;

Property Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SplitterPos Property

Summary

Represents property SplitterPos.

Namespace: frxInsp
Syntax
Delphi
public
 property SplitterPos: Integer read FSplitterPos write FSplitterPos;

Property Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector Methods

Methods
Name | Description
AdjustControls | Represents method AdjustControls.
CMMouseLeave(TMessage) | Represents method CMMouseLeave(TMessage).
ComboBtnClick(TObject) | Represents method ComboBtnClick(TObject).
ComboBtnMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method ComboBtnMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
Count | Represents method Count.
DisableUpdate | Represents method DisableUpdate.
DoModify | Represents method DoModify.
DrawOneLine(Integer,Boolean) | Represents method DrawOneLine(Integer,Boolean).
Edit1KeyDown(TObject,Word,TShiftState) | Represents method Edit1KeyDown(TObject,Word,TShiftState).
Edit1KeyPress(TObject,Char) | Represents method Edit1KeyPress(TObject,Char).
Edit1MouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method Edit1MouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
EditBtnClick(TObject) | Represents method EditBtnClick(TObject).
EnableUpdate | Represents method EnableUpdate.
FilterChange(TObject) | Represents method FilterChange(TObject).
FormDeactivate(TObject) | Represents method FormDeactivate(TObject).
FormEndDock(TObject,TObject,Integer,Integer) | Represents method FormEndDock(TObject,TObject,Integer,Integer).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
FormMouseWheelDown(TObject,TShiftState,TPoint,Boolean) | Represents method FormMouseWheelDown(TObject,TShiftState,TPoint,Boolean).
FormMouseWheelUp(TObject,TShiftState,TPoint,Boolean) | Represents method FormMouseWheelUp(TObject,TShiftState,TPoint,Boolean).
FormResize(TObject) | Represents method FormResize(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
GetItem(Integer) | Represents method GetItem(Integer).
GetName(Integer) | Represents method GetName(Integer).
GetOffset(Integer) | Represents method GetOffset(Integer).
GetSplitter1Pos | Represents method GetSplitter1Pos.
GetType(Integer) | Represents method GetType(Integer).
GetValue(Integer) | Represents method GetValue(Integer).
Inspect(TPersistent[]) | Represents method Inspect(TPersistent[]).
LBClick(TObject) | Represents method LBClick(TObject).
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.LoadFormPreferences(TObject,TObject).)
N11Click(TObject) | Represents method N11Click(TObject).
N21Click(TObject) | Represents method N21Click(TObject).
N31Click(TObject) | Represents method N31Click(TObject).
ObjectsCBClick(TObject) | Represents method ObjectsCBClick(TObject).
ObjectsCBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) | Represents method ObjectsCBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).
ObjectsCBDropDown(TObject) | Represents method ObjectsCBDropDown(TObject).
PBDblClick(TObject) | Represents method PBDblClick(TObject).
PBMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method PBMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
PBMouseMove(TObject,TShiftState,Integer,Integer) | Represents method PBMouseMove(TObject,TShiftState,Integer,Integer).
PBMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method PBMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer).
PBOnDragDrop(TObject,TObject,Integer,Integer) | Represents method PBOnDragDrop(TObject,TObject,Integer,Integer).
PBOnDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method PBOnDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
PBPaint(TObject) | Represents method PBPaint(TObject).
RestorePosition | Represents method RestorePosition.
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.SaveFormPreferences(TObject,TObject).)
SavePosition | Represents method SavePosition.
SetColor(TColor) | Represents method SetColor(TColor).
SetFileterMaxWidth(Integer) | Represents method SetFileterMaxWidth(Integer).
SetFileterMinWidth(Integer) | Represents method SetFileterMinWidth(Integer).
SetFilter(String) | Represents method SetFilter(String).
SetItemIndex(Integer) | Represents method SetItemIndex(Integer).
SetObjects(TList) | Represents method SetObjects(TList).
SetSelectedObjects(TfrxSelectedObjectsList) | Represents method SetSelectedObjects(TfrxSelectedObjectsList).
SetSplitter1Pos(Integer) | Represents method SetSplitter1Pos(Integer).
SetValue(Integer,String) | Represents method SetValue(Integer,String).
TabChange(TObject) | Represents method TabChange(TObject).
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Overrides TfrxBaseForm.UpdateFormPPI(Integer).)
UpdateProperties | Represents method UpdateProperties.
Top


TfrxObjectInspector.AdjustControls Method

Summary

Represents method AdjustControls.

Namespace: frxInsp
Syntax
Delphi
private
 procedure AdjustControls;
See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.CMMouseLeave(TMessage) Method

Summary

Represents method CMMouseLeave(TMessage).

Namespace: frxInsp
Syntax
Delphi
private
 procedure CMMouseLeave(var Msg: TMessage); message CM_MouseLeave;

Parameters

Msg
Type: TMessage

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.ComboBtnClick(TObject) Method

Summary

Represents method ComboBtnClick(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure ComboBtnClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.ComboBtnMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method ComboBtnMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).

Namespace: frxInsp
Syntax
Delphi
published
 procedure ComboBtnMouseDown(Sender: TObject; Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.Count Method

Summary

Represents method Count.

Namespace: frxInsp
Syntax
Delphi
private
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.DisableUpdate Method

Summary

Represents method DisableUpdate.

Namespace: frxInsp
Syntax
Delphi
public
 procedure DisableUpdate;
See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.DoModify Method

Summary

Represents method DoModify.

Namespace: frxInsp
Syntax
Delphi
private
 procedure DoModify;
See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.DrawOneLine(Integer,Boolean) Method

Summary

Represents method DrawOneLine(Integer,Boolean).

Namespace: frxInsp
Syntax
Delphi
private
 procedure DrawOneLine(
 i: Integer; Selected: Boolean);

Parameters

i
Type: Integer

Selected
Type: Boolean

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.Edit1KeyDown(TObject,Word,TShiftState) Method

Summary

Represents method Edit1KeyDown(TObject,Word,TShiftState).

Namespace: frxInsp
Syntax
Delphi
published
 procedure Edit1KeyDown(Sender: TObject; var Key: Word;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.Edit1KeyPress(TObject,Char) Method

Summary

Represents method Edit1KeyPress(TObject,Char).

Namespace: frxInsp
Syntax
Delphi
published
 procedure Edit1KeyPress(Sender: TObject; var Key: Char);

Parameters

Sender
Type: TObject

Key
Type: Char

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.Edit1MouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method Edit1MouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).

Namespace: frxInsp
Syntax
Delphi
published
 procedure Edit1MouseDown(Sender: TObject; Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.EditBtnClick(TObject) Method

Summary

Represents method EditBtnClick(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure EditBtnClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.EnableUpdate Method

Summary

Represents method EnableUpdate.

Namespace: frxInsp
Syntax
Delphi
public
 procedure EnableUpdate;
See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FilterChange(TObject) Method

Summary

Represents method FilterChange(TObject).

Namespace: frxInsp
Syntax
Delphi
private
 procedure FilterChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FormDeactivate(TObject) Method

Summary

Represents method FormDeactivate(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure FormDeactivate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FormEndDock(TObject,TObject,Integer,Integer) Method

Summary

Represents method FormEndDock(TObject,TObject,Integer,Integer).

Namespace: frxInsp
Syntax
Delphi
published
 procedure FormEndDock(Sender, Target: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Target
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FormKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method FormKeyDown(TObject,Word,TShiftState).

Namespace: frxInsp
Syntax
Delphi
published
 procedure FormKeyDown(Sender: TObject; var Key: Word;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FormMouseWheelDown(TObject,TShiftState,TPoint,Boolean) Method

Summary

Represents method FormMouseWheelDown(TObject,TShiftState,TPoint,Boolean).

Namespace: frxInsp
Syntax
Delphi
published
 procedure FormMouseWheelDown(Sender: TObject; Shift: TShiftState;
 MousePos: TPoint; var Handled: Boolean);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

MousePos
Type: TPoint

Handled
Type: Boolean

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FormMouseWheelUp(TObject,TShiftState,TPoint,Boolean) Method

Summary

Represents method FormMouseWheelUp(TObject,TShiftState,TPoint,Boolean).

Namespace: frxInsp
Syntax
Delphi
published
 procedure FormMouseWheelUp(Sender: TObject; Shift: TShiftState;
 MousePos: TPoint; var Handled: Boolean);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

MousePos
Type: TPoint

Handled
Type: Boolean

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FormResize(TObject) Method

Summary

Represents method FormResize(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure FormResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxInsp
Syntax
Delphi
private
 function GetItem(Index: Integer): TfrxPropertyItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxPropertyItem

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.GetName(Integer) Method

Summary

Represents method GetName(Integer).

Namespace: frxInsp
Syntax
Delphi
private
 function GetName(Index: Integer): String;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.GetOffset(Integer) Method

Summary

Represents method GetOffset(Integer).

Namespace: frxInsp
Syntax
Delphi
private
 function GetOffset(Index: Integer): Integer;

Parameters

Index
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.GetSplitter1Pos Method

Summary

Represents method GetSplitter1Pos.

Namespace: frxInsp
Syntax
Delphi
private
 function GetSplitter1Pos: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.GetType(Integer) Method

Summary

Represents method GetType(Integer).

Namespace: frxInsp
Syntax
Delphi
private
 function GetType(Index: Integer): TfrxPropertyAttributes;

Parameters

Index
Type: Integer

Return Value

Type: TfrxPropertyAttributes

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.GetValue(Integer) Method

Summary

Represents method GetValue(Integer).

Namespace: frxInsp
Syntax
Delphi
private
 function GetValue(Index: Integer): String;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.Inspect(TPersistent[]) Method

Summary

Represents method Inspect(TPersistent[]).

Namespace: frxInsp
Syntax
Delphi
public
 procedure Inspect(AObjects: array of TPersistent);

Parameters

AObjects
Type: array of TPersistent

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.LBClick(TObject) Method

Summary

Represents method LBClick(TObject).

Namespace: frxInsp
Syntax
Delphi
private
 procedure LBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.LoadFormPreferences(TObject,TObject) Method

Summary

Represents method LoadFormPreferences(TObject,TObject).

Namespace: frxInsp
Syntax
Delphi
protected
 procedure LoadFormPreferences(PreferencesStorage: TObject; DefPreferencesStorage: TObject); override;

Parameters

PreferencesStorage
Type: TObject

DefPreferencesStorage
Type: TObject

Overrides

TfrxBaseForm.LoadFormPreferences(TObject,TObject)
See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.N11Click(TObject) Method

Summary

Represents method N11Click(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure N11Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.N21Click(TObject) Method

Summary

Represents method N21Click(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure N21Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.N31Click(TObject) Method

Summary

Represents method N31Click(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure N31Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.ObjectsCBClick(TObject) Method

Summary

Represents method ObjectsCBClick(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure ObjectsCBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.ObjectsCBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) Method

Summary

Represents method ObjectsCBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).

Namespace: frxInsp
Syntax
Delphi
published
 procedure ObjectsCBDrawItem(Control: TWinControl; Index: Integer;
 Rect: TRect; State: TOwnerDrawState);

Parameters

Control
Type: TWinControl

Index
Type: Integer

Rect
Type: TRect

State
Type: TOwnerDrawState

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.ObjectsCBDropDown(TObject) Method

Summary

Represents method ObjectsCBDropDown(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure ObjectsCBDropDown(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.PBDblClick(TObject) Method

Summary

Represents method PBDblClick(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure PBDblClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.PBMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method PBMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).

Namespace: frxInsp
Syntax
Delphi
published
 procedure PBMouseDown(Sender: TObject; Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.PBMouseMove(TObject,TShiftState,Integer,Integer) Method

Summary

Represents method PBMouseMove(TObject,TShiftState,Integer,Integer).

Namespace: frxInsp
Syntax
Delphi
published
 procedure PBMouseMove(Sender: TObject; Shift: TShiftState; X,
 Y: Integer);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.PBMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method PBMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer).

Namespace: frxInsp
Syntax
Delphi
published
 procedure PBMouseUp(Sender: TObject; Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.PBOnDragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method PBOnDragDrop(TObject,TObject,Integer,Integer).

Namespace: frxInsp
Syntax
Delphi
private
 procedure PBOnDragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.PBOnDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method PBOnDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: frxInsp
Syntax
Delphi
private
 procedure PBOnDragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.PBPaint(TObject) Method

Summary

Represents method PBPaint(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure PBPaint(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.RestorePosition Method

Summary

Represents method RestorePosition.

Namespace: frxInsp
Syntax
Delphi
private
 procedure RestorePosition;
See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SaveFormPreferences(TObject,TObject) Method

Summary

Represents method SaveFormPreferences(TObject,TObject).

Namespace: frxInsp
Syntax
Delphi
protected
 procedure SaveFormPreferences(PreferencesStorage: TObject; DefPreferencesStorage: TObject); override;

Parameters

PreferencesStorage
Type: TObject

DefPreferencesStorage
Type: TObject

Overrides

TfrxBaseForm.SaveFormPreferences(TObject,TObject)
See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SavePosition Method

Summary

Represents method SavePosition.

Namespace: frxInsp
Syntax
Delphi
private
 procedure SavePosition;
See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxInsp
Syntax
Delphi
public
 procedure SetColor(Color: TColor);

Parameters

Color
Type: TColor

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SetFileterMaxWidth(Integer) Method

Summary

Represents method SetFileterMaxWidth(Integer).

Namespace: frxInsp
Syntax
Delphi
private
 procedure SetFileterMaxWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SetFileterMinWidth(Integer) Method

Summary

Represents method SetFileterMinWidth(Integer).

Namespace: frxInsp
Syntax
Delphi
private
 procedure SetFileterMinWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SetFilter(String) Method

Summary

Represents method SetFilter(String).

Namespace: frxInsp
Syntax
Delphi
private
 procedure SetFilter(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SetItemIndex(Integer) Method

Summary

Represents method SetItemIndex(Integer).

Namespace: frxInsp
Syntax
Delphi
private
 procedure SetItemIndex(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SetObjects(TList) Method

Summary

Represents method SetObjects(TList).

Namespace: frxInsp
Syntax
Delphi
private
 procedure SetObjects(Value: TList);

Parameters

Value
Type: TList

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SetSelectedObjects(TfrxSelectedObjectsList) Method

Summary

Represents method SetSelectedObjects(TfrxSelectedObjectsList).

Namespace: frxInsp
Syntax
Delphi
private
 procedure SetSelectedObjects(Value: TfrxSelectedObjectsList);

Parameters

Value
Type: TfrxSelectedObjectsList

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SetSplitter1Pos(Integer) Method

Summary

Represents method SetSplitter1Pos(Integer).

Namespace: frxInsp
Syntax
Delphi
private
 procedure SetSplitter1Pos(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.SetValue(Integer,String) Method

Summary

Represents method SetValue(Integer,String).

Namespace: frxInsp
Syntax
Delphi
private
 procedure SetValue(Index: Integer; Value: String);

Parameters

Index
Type: Integer

Value
Type: String

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.TabChange(TObject) Method

Summary

Represents method TabChange(TObject).

Namespace: frxInsp
Syntax
Delphi
published
 procedure TabChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.UpdateFormPPI(Integer) Method

Summary

Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method.

Namespace: frxInsp
Syntax
Delphi
public
 procedure UpdateFormPPI(aNewPPI: Integer); override;

Parameters

aNewPPI
Type: Integer

New PPI value.

Overrides

TfrxBaseForm.UpdateFormPPI(Integer)
See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.UpdateProperties Method

Summary

Represents method UpdateProperties.

Namespace: frxInsp
Syntax
Delphi
public
 procedure UpdateProperties;
See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector Fields

Fields
Name | Description
BackPanel | Represents field BackPanel.
Box | Represents field Box.
ComboBtn | Represents field ComboBtn.
ComboPanel | Represents field ComboPanel.
DescrL | Represents field DescrL.
Edit1 | Represents field Edit1.
EditBtn | Represents field EditBtn.
EditPanel | Represents field EditPanel.
FColor | Represents field FColor.
FComboBtnGlyph | Represents field FComboBtnGlyph.
FDesigner | Represents field FDesigner.
FDisableDblClick | Represents field FDisableDblClick.
FDisableUpdate | Represents field FDisableUpdate.
FDown | Represents field FDown.
FEditBtnGlyph | Represents field FEditBtnGlyph.
FEventList | Represents field FEventList.
FFileterMaxWidth | Represents field FFileterMaxWidth.
FFileterMinWidth | Represents field FFileterMinWidth.
FFilter | Represents field FFilter.
FFilterEdit | Represents field FFilterEdit.
FHintWindow | Represents field FHintWindow.
FItemIndex | Represents field FItemIndex.
FLastPosition | Represents field FLastPosition.
FList | Represents field FList.
FMaxSavedPos | Represents field FMaxSavedPos.
FOnModify | Represents field FOnModify.
FOnSelectionChanged | Represents field FOnSelectionChanged.
FPanel | Represents field FPanel.
FPopupForm | Represents field FPopupForm.
FPopupLB | Represents field FPopupLB.
FPopupLBVisible | Represents field FPopupLBVisible.
FPropertyList | Represents field FPropertyList.
FRowHeight | Represents field FRowHeight.
FSavedPositions | Represents field FSavedPositions.
FSavePosLocked | Represents field FSavePosLocked.
FSelectedObjects | Represents field FSelectedObjects.
FSplitterPos | Represents field FSplitterPos.
FTabs | Represents field FTabs.
FTempBMP | Represents field FTempBMP.
FTempList | Represents field FTempList.
FTickCount | Represents field FTickCount.
FUpdatingObjectsCB | Represents field FUpdatingObjectsCB.
FUpdatingPB | Represents field FUpdatingPB.
HintPanel | Represents field HintPanel.
N11 | Represents field N11.
N21 | Represents field N21.
N31 | Represents field N31.
N41 | Represents field N41.
N51 | Represents field N51.
N61 | Represents field N61.
ObjectsCB | Represents field ObjectsCB.
PB | Represents field PB.
PopupMenu1 | Represents field PopupMenu1.
PropL | Represents field PropL.
Splitter1 | Represents field Splitter1.
Top


TfrxObjectInspector.BackPanel Field

Summary

Represents field BackPanel.

Namespace: frxInsp
Syntax
Delphi
published
 BackPanel: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.Box Field

Summary

Represents field Box.

Namespace: frxInsp
Syntax
Delphi
published
 Box: TScrollBox;

Field Value

Type: TScrollBox

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.ComboBtn Field

Summary

Represents field ComboBtn.

Namespace: frxInsp
Syntax
Delphi
published
 ComboBtn: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.ComboPanel Field

Summary

Represents field ComboPanel.

Namespace: frxInsp
Syntax
Delphi
published
 ComboPanel: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.DescrL Field

Summary

Represents field DescrL.

Namespace: frxInsp
Syntax
Delphi
published
 DescrL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.Edit1 Field

Summary

Represents field Edit1.

Namespace: frxInsp
Syntax
Delphi
published
 Edit1: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.EditBtn Field

Summary

Represents field EditBtn.

Namespace: frxInsp
Syntax
Delphi
published
 EditBtn: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.EditPanel Field

Summary

Represents field EditPanel.

Namespace: frxInsp
Syntax
Delphi
published
 EditPanel: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FColor Field

Summary

Represents field FColor.

Namespace: frxInsp
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FComboBtnGlyph Field

Summary

Represents field FComboBtnGlyph.

Namespace: frxInsp
Syntax
Delphi
private
 FComboBtnGlyph: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FDesigner Field

Summary

Represents field FDesigner.

Namespace: frxInsp
Syntax
Delphi
private
 FDesigner: TfrxCustomDesigner;

Field Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FDisableDblClick Field

Summary

Represents field FDisableDblClick.

Namespace: frxInsp
Syntax
Delphi
private
 FDisableDblClick: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FDisableUpdate Field

Summary

Represents field FDisableUpdate.

Namespace: frxInsp
Syntax
Delphi
private
 FDisableUpdate: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FDown Field

Summary

Represents field FDown.

Namespace: frxInsp
Syntax
Delphi
private
 FDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FEditBtnGlyph Field

Summary

Represents field FEditBtnGlyph.

Namespace: frxInsp
Syntax
Delphi
private
 FEditBtnGlyph: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FEventList Field

Summary

Represents field FEventList.

Namespace: frxInsp
Syntax
Delphi
private
 FEventList: TfrxPropertyList;

Field Value

Type: TfrxPropertyList

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FFileterMaxWidth Field

Summary

Represents field FFileterMaxWidth.

Namespace: frxInsp
Syntax
Delphi
private
 FFileterMaxWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FFileterMinWidth Field

Summary

Represents field FFileterMinWidth.

Namespace: frxInsp
Syntax
Delphi
private
 FFileterMinWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FFilter Field

Summary

Represents field FFilter.

Namespace: frxInsp
Syntax
Delphi
private
 FFilter: String;

Field Value

Type: String

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FFilterEdit Field

Summary

Represents field FFilterEdit.

Namespace: frxInsp
Syntax
Delphi
private
 FFilterEdit: TfrxFilterEdit;

Field Value

Type: TfrxFilterEdit

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FHintWindow Field

Summary

Represents field FHintWindow.

Namespace: frxInsp
Syntax
Delphi
private
 FHintWindow: THintWindow;

Field Value

Type: THintWindow

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FItemIndex Field

Summary

Represents field FItemIndex.

Namespace: frxInsp
Syntax
Delphi
private
 FItemIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FLastPosition Field

Summary

Represents field FLastPosition.

Namespace: frxInsp
Syntax
Delphi
private
 FLastPosition: String;

Field Value

Type: String

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FList Field

Summary

Represents field FList.

Namespace: frxInsp
Syntax
Delphi
private
 FList: TfrxPropertyList;

Field Value

Type: TfrxPropertyList

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FMaxSavedPos Field

Summary

Represents field FMaxSavedPos.

Namespace: frxInsp
Syntax
Delphi
private
 FMaxSavedPos: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FOnModify Field

Summary

Represents field FOnModify.

Namespace: frxInsp
Syntax
Delphi
private
 FOnModify: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FOnSelectionChanged Field

Summary

Represents field FOnSelectionChanged.

Namespace: frxInsp
Syntax
Delphi
private
 FOnSelectionChanged: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FPanel Field

Summary

Represents field FPanel.

Namespace: frxInsp
Syntax
Delphi
private
 FPanel: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FPopupForm Field

Summary

Represents field FPopupForm.

Namespace: frxInsp
Syntax
Delphi
private
 FPopupForm: TfrxPopupForm;

Field Value

Type: TfrxPopupForm

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FPopupLB Field

Summary

Represents field FPopupLB.

Namespace: frxInsp
Syntax
Delphi
private
 FPopupLB: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FPopupLBVisible Field

Summary

Represents field FPopupLBVisible.

Namespace: frxInsp
Syntax
Delphi
private
 FPopupLBVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FPropertyList Field

Summary

Represents field FPropertyList.

Namespace: frxInsp
Syntax
Delphi
private
 FPropertyList: TfrxPropertyList;

Field Value

Type: TfrxPropertyList

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FRowHeight Field

Summary

Represents field FRowHeight.

Namespace: frxInsp
Syntax
Delphi
private
 FRowHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FSavedPositions Field

Summary

Represents field FSavedPositions.

Namespace: frxInsp
Syntax
Delphi
private
 FSavedPositions: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FSavePosLocked Field

Summary

Represents field FSavePosLocked.

Namespace: frxInsp
Syntax
Delphi
private
 FSavePosLocked: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FSelectedObjects Field

Summary

Represents field FSelectedObjects.

Namespace: frxInsp
Syntax
Delphi
private
 FSelectedObjects: TfrxSelectedObjectsList;

Field Value

Type: TfrxSelectedObjectsList

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FSplitterPos Field

Summary

Represents field FSplitterPos.

Namespace: frxInsp
Syntax
Delphi
private
 FSplitterPos: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FTabs Field

Summary

Represents field FTabs.

Namespace: frxInsp
Syntax
Delphi
private
 FTabs: TTabSet;

Field Value

Type: TTabSet

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FTempBMP Field

Summary

Represents field FTempBMP.

Namespace: frxInsp
Syntax
Delphi
private
 FTempBMP: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FTempList Field

Summary

Represents field FTempList.

Namespace: frxInsp
Syntax
Delphi
private
 FTempList: TfrxSelectedObjectsList;

Field Value

Type: TfrxSelectedObjectsList

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FTickCount Field

Summary

Represents field FTickCount.

Namespace: frxInsp
Syntax
Delphi
private
 FTickCount: UInt;

Field Value

Type: UInt

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FUpdatingObjectsCB Field

Summary

Represents field FUpdatingObjectsCB.

Namespace: frxInsp
Syntax
Delphi
private
 FUpdatingObjectsCB: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.FUpdatingPB Field

Summary

Represents field FUpdatingPB.

Namespace: frxInsp
Syntax
Delphi
private
 FUpdatingPB: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.HintPanel Field

Summary

Represents field HintPanel.

Namespace: frxInsp
Syntax
Delphi
published
 HintPanel: TScrollBox;

Field Value

Type: TScrollBox

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.N11 Field

Summary

Represents field N11.

Namespace: frxInsp
Syntax
Delphi
published
 N11: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.N21 Field

Summary

Represents field N21.

Namespace: frxInsp
Syntax
Delphi
published
 N21: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.N31 Field

Summary

Represents field N31.

Namespace: frxInsp
Syntax
Delphi
published
 N31: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.N41 Field

Summary

Represents field N41.

Namespace: frxInsp
Syntax
Delphi
published
 N41: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.N51 Field

Summary

Represents field N51.

Namespace: frxInsp
Syntax
Delphi
published
 N51: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.N61 Field

Summary

Represents field N61.

Namespace: frxInsp
Syntax
Delphi
published
 N61: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.ObjectsCB Field

Summary

Represents field ObjectsCB.

Namespace: frxInsp
Syntax
Delphi
published
 ObjectsCB: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.PB Field

Summary

Represents field PB.

Namespace: frxInsp
Syntax
Delphi
published
 PB: TPaintBox;

Field Value

Type: TPaintBox

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.PopupMenu1 Field

Summary

Represents field PopupMenu1.

Namespace: frxInsp
Syntax
Delphi
published
 PopupMenu1: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.PropL Field

Summary

Represents field PropL.

Namespace: frxInsp
Syntax
Delphi
published
 PropL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


TfrxObjectInspector.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: frxInsp
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TfrxObjectInspector
  • frxInsp


frxIOTransportDialog Namespace

Summary

Represents namespace frxIOTransportDialog.

Classes
Name | Description
TfrxIOTransportFileDialog | Represents type TfrxIOTransportFileDialog.
Top


frxIOTransportDialog Classes

Classes
Name | Description
TfrxIOTransportFileDialog | Represents type TfrxIOTransportFileDialog.
Top


TfrxIOTransportFileDialog Class

Summary

Represents type TfrxIOTransportFileDialog.

Namespace: frxIOTransportDialog
Inheritance Hierarchy
TComponent
frxClass.TfrxCustomIOTransport
frxClass.TfrxIOTransportFile
frxIOTransportDialog.TfrxIOTransportFileDialog
Syntax
Delphi
type
 TfrxIOTransportFileDialog = class(TfrxIOTransportFile)
 end;

The TfrxIOTransportFileDialog type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxIOTransportFile class. (Overrides TfrxCustomIOTransport.Create(TComponent).)
CreateNoRegister | This constructor creates component without registration in global list so the filter will be hidden for preview or report designer. (Inherited from TfrxCustomIOTransport.)
Top
Properties
Show:
Name | Description
BasePath | Base path used in transport filter. (Inherited from TfrxCustomIOTransport.)
CreatedFrom | This flag shows where the current instance of the filter was created from. (Inherited from TfrxCustomIOTransport.)
CurrentContainer | Name of the current container. (Inherited from TfrxCustomIOTransport.)
DefaultExt | Default extension used in transport filter. (Inherited from TfrxCustomIOTransport.)
DefaultPath | Default path used in transport filter. (Inherited from TfrxCustomIOTransport.)
ExtDescription | Description for default extension used in transport filter. (Inherited from TfrxCustomIOTransport.)
FileName | File name for current filter. (Inherited from TfrxCustomIOTransport.)
FilterAccess | Access type of IO filter. (Inherited from TfrxCustomIOTransport.)
FilterString | Description of filter instance. (Inherited from TfrxCustomIOTransport.)
InternalFilter | Represents property InternalFilter. (Inherited from TfrxCustomIOTransport.)
OverwritePrompt | Represents property OverwritePrompt. (Inherited from TfrxCustomIOTransport.)
Report | Reference to a report component. (Inherited from TfrxCustomIOTransport.)
RootNode | Root node of the filter. (Inherited from TfrxCustomIOTransport.)
ShowDialog | Whether to display a print dialogue. Default value is True. (Inherited from TfrxCustomIOTransport.)
SupportedStreams | Supported stream type for current IO transport filter. (Inherited from TfrxCustomIOTransport.)
TempFilter | Returns reference to transport filter instance for temporary operations. (Inherited from TfrxCustomIOTransport.)
Visibility | These flags used in IO transports to define visibility of IO transport filter. By default each transport filter component registers in global list and these flags helps to sort items of the global list. (Inherited from TfrxCustomIOTransport.)
Top
Methods
Show:
Name | Description
AddContainer(TfrxNode) | Represents method AddContainer(TfrxNode). (Overrides TfrxCustomIOTransport.AddContainer(TfrxNode).)
AllInOneContainer | Returns true when physically all stream belongs to one container(zip archive). (Inherited from TfrxCustomIOTransport.)
AssignFilter(TfrxCustomIOTransport) | This method assigns properties of other transport filter to current. (Inherited from TfrxCustomIOTransport.)
AssignSharedProperties(TfrxCustomIOTransport) | This method assigns shared properties(like tokens) of other transport filter to current. (Inherited from TfrxCustomIOTransport.)
CloseAllStreams | The method closes all opened streams. (Inherited from TfrxCustomIOTransport.)
CloseFilter | This method can be called to close a filter. It uses to make finalization like close connection and streams. (Overrides TfrxIOTransportFile.CloseFilter.)
CopyStreamsNames(TStrings,Boolean) | It copies names of steams in current transport to TStrings passed as a parameter. (Inherited from TfrxCustomIOTransport.)
CreateContainer(String,Boolean) | Creates a structure node represents a container or directory. (Inherited from TfrxCustomIOTransport.)
CreateFilterClone(TfrxFilterVisibleState) | Copy constructor. (Inherited from TfrxCustomIOTransport.)
CreateTempContainer | Creates a structure node represents a temporary container or directory. (Overrides TfrxCustomIOTransport.CreateTempContainer.)
DeleteContainer(String) | Deletes a structure node represents a container or directory. (Inherited from TfrxCustomIOTransport.)
DeleteFiles | Represents method DeleteFiles. (Inherited from TfrxIOTransportFile.)
DoCreateStream(String,String) | Represents method DoCreateStream(String,String). (Overrides TfrxCustomIOTransport.DoCreateStream(String,String).)
DoFilterProcessStream(TStream,TObject) | This method call before loading from stream is started. Can be used to make a preparation of stream data before loading. (Overrides TfrxCustomIOTransport.DoFilterProcessStream(TStream,TObject).)
FreeStream(TStream,String) | Closes an opened stream by reference or name. (Overrides TfrxCustomIOTransport.FreeStream(TStream,String).)
FreeTempContainer | Destroy a structure node represents a temporary container or directory. (Overrides TfrxCustomIOTransport.FreeTempContainer.)
GetDescription | Represents method GetDescription. (Overrides TfrxIOTransportFile.GetDescription.)
GetFileNode | Returns nearest file node in current container. (Inherited from TfrxCustomIOTransport.)
GetFilterString | Represents method GetFilterString. (Inherited from TfrxCustomIOTransport.)
GetNodeFromPath(String,Boolean,Boolean) | Represents method GetNodeFromPath(String,Boolean,Boolean). (Inherited from TfrxCustomIOTransport.)
GetStream(String) | Returns stream by name of a node or a file. (Overrides TfrxCustomIOTransport.GetStream(String).)
GetVisibility | Represents method GetVisibility. (Inherited from TfrxCustomIOTransport.)
InitFromExport(TfrxCustomExportFilter) | Initialization of transport filter based on export filter settings(like file name and file extension). (Inherited from TfrxCustomIOTransport.)
LoadClosedStreams | Reloads all closed streams and open them again. (Inherited from TfrxCustomIOTransport.)
LoadStreamsList(TStrings) | Loads and opens steams from the list. (Inherited from TfrxCustomIOTransport.)
OpenFilter | This method can be called to open filter. It uses to make preparation like set connection or show user dialogs. It returns true when initialization was processed. (Overrides TfrxIOTransportFile.OpenFilter.)
RemoveContainer(TfrxNode) | Represents method RemoveContainer(TfrxNode). (Inherited from TfrxCustomIOTransport.)
SetVisibility(TfrxFilterVisibility) | Represents method SetVisibility(TfrxFilterVisibility). (Overrides TfrxIOTransportFile.SetVisibility(TfrxFilterVisibility).)
Top
Fields
Show:
Name | Description
FClosedLoadLock | Represents field FClosedLoadLock. (Inherited from TfrxCustomIOTransport.)
FCreatedFrom | Represents field FCreatedFrom. (Inherited from TfrxCustomIOTransport.)
FDirTree | Represents field FDirTree. (Inherited from TfrxCustomIOTransport.)
FFilter | Represents field FFilter.
FFreeStream | Represents field FFreeStream. (Inherited from TfrxCustomIOTransport.)
FInternalFilter | Represents field FInternalFilter. (Inherited from TfrxCustomIOTransport.)
FNoRegister | Represents field FNoRegister. (Inherited from TfrxCustomIOTransport.)
FOriginalCopy | Represents field FOriginalCopy. (Inherited from TfrxCustomIOTransport.)
FSaveDialog | Represents field FSaveDialog.
FSupportedStreams | Represents field FSupportedStreams. (Inherited from TfrxCustomIOTransport.)
FVisibility | Represents field FVisibility. (Inherited from TfrxCustomIOTransport.)
Top
See Also

Reference

  • frxIOTransportDialog


TfrxIOTransportFileDialog Methods

Methods
Name | Description
CloseFilter | This method can be called to close a filter. It uses to make finalization like close connection and streams. (Overrides TfrxIOTransportFile.CloseFilter.)
DoFilterProcessStream(TStream,TObject) | This method call before loading from stream is started. Can be used to make a preparation of stream data before loading. (Overrides TfrxCustomIOTransport.DoFilterProcessStream(TStream,TObject).)
FreeStream(TStream,String) | Closes an opened stream by reference or name. (Overrides TfrxCustomIOTransport.FreeStream(TStream,String).)
GetDescription | Represents method GetDescription. (Overrides TfrxIOTransportFile.GetDescription.)
GetStream(String) | Returns stream by name of a node or a file. (Overrides TfrxCustomIOTransport.GetStream(String).)
OpenFilter | This method can be called to open filter. It uses to make preparation like set connection or show user dialogs. It returns true when initialization was processed. (Overrides TfrxIOTransportFile.OpenFilter.)
SetVisibility(TfrxFilterVisibility) | Represents method SetVisibility(TfrxFilterVisibility). (Overrides TfrxIOTransportFile.SetVisibility(TfrxFilterVisibility).)
Top


TfrxIOTransportFileDialog.CloseFilter Method

Summary

This method can be called to close a filter. It uses to make finalization like close connection and streams.

Namespace: frxIOTransportDialog
Syntax
Delphi
public
 procedure CloseFilter; override;

Overrides

TfrxIOTransportFile.CloseFilter
See Also

Reference

  • TfrxIOTransportFileDialog
  • frxIOTransportDialog


TfrxIOTransportFileDialog.DoFilterProcessStream(TStream,TObject) Method

Summary

This method call before loading from stream is started. Can be used to make a preparation of stream data before loading.

Namespace: frxIOTransportDialog
Syntax
Delphi
public
 function DoFilterProcessStream(aStream: TStream; ProcesssingObject: TObject): Boolean; override;

Parameters

aStream
Type: TStream

ProcesssingObject
Type: TObject

Return Value

Type: Boolean

Overrides

TfrxCustomIOTransport.DoFilterProcessStream(TStream,TObject)
See Also

Reference

  • TfrxIOTransportFileDialog
  • frxIOTransportDialog


TfrxIOTransportFileDialog.FreeStream(TStream,String) Method

Summary

Closes an opened stream by reference or name.

Namespace: frxIOTransportDialog
Syntax
Delphi
public
 procedure FreeStream(aStream: TStream; const aFileName: String = ''); override;

Parameters

aStream
Type: TStream

Reference to opened stream.

aFileName
Type: String

Stream or file name.

Overrides

TfrxCustomIOTransport.FreeStream(TStream,String)
See Also

Reference

  • TfrxIOTransportFileDialog
  • frxIOTransportDialog


TfrxIOTransportFileDialog.GetDescription Method

Summary

Represents method GetDescription.

Namespace: frxIOTransportDialog
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxIOTransportFile.GetDescription
See Also

Reference

  • TfrxIOTransportFileDialog
  • frxIOTransportDialog


TfrxIOTransportFileDialog.GetStream(String) Method

Summary

Returns stream by name of a node or a file.

Namespace: frxIOTransportDialog
Syntax
Delphi
public
 function GetStream(aFileName: String = ''): TStream; override;

Parameters

aFileName
Type: String

File or node name.

Return Value

Type: TStream

Overrides

TfrxCustomIOTransport.GetStream(String)
See Also

Reference

  • TfrxIOTransportFileDialog
  • frxIOTransportDialog


TfrxIOTransportFileDialog.OpenFilter Method

Summary

This method can be called to open filter. It uses to make preparation like set connection or show user dialogs. It returns true when initialization was processed.

Namespace: frxIOTransportDialog
Syntax
Delphi
public
 function OpenFilter: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxIOTransportFile.OpenFilter
See Also

Reference

  • TfrxIOTransportFileDialog
  • frxIOTransportDialog


TfrxIOTransportFileDialog.SetVisibility(TfrxFilterVisibility) Method

Summary

Represents method SetVisibility(TfrxFilterVisibility).

Namespace: frxIOTransportDialog
Syntax
Delphi
protected
 procedure SetVisibility(const Value: TfrxFilterVisibility); override;

Parameters

Value
Type: TfrxFilterVisibility

Overrides

TfrxIOTransportFile.SetVisibility(TfrxFilterVisibility)
See Also

Reference

  • TfrxIOTransportFileDialog
  • frxIOTransportDialog


TfrxIOTransportFileDialog Fields

Fields
Name | Description
FFilter | Represents field FFilter.
FSaveDialog | Represents field FSaveDialog.
Top


TfrxIOTransportFileDialog.FFilter Field

Summary

Represents field FFilter.

Namespace: frxIOTransportDialog
Syntax
Delphi
private
 FFilter: TfrxCustomIOTransport;

Field Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxIOTransportFileDialog
  • frxIOTransportDialog


TfrxIOTransportFileDialog.FSaveDialog Field

Summary

Represents field FSaveDialog.

Namespace: frxIOTransportDialog
Syntax
Delphi
private
 FSaveDialog: TOpenDialog;

Field Value

Type: TOpenDialog

See Also

Reference

  • TfrxIOTransportFileDialog
  • frxIOTransportDialog


frxIOTransportIntf Namespace

Summary

Represents namespace frxIOTransportIntf.

Classes
Name | Description
TfrxIOTransportItem | Represents type TfrxIOTransportItem.
TfrxIOTransportsCollection | Represents type TfrxIOTransportsCollection.
Top
Routines
Name | Description
FillItemsList(TStrings,TfrxFilterVisibleState) | Represents method FillItemsList(TStrings,TfrxFilterVisibleState).
frxIOTransports | Represents method frxIOTransports.
GetFilterDialogVisibility(TfrxFilterVisibleState) | Represents method GetFilterDialogVisibility(TfrxFilterVisibleState).
Top


frxIOTransportIntf Classes

Classes
Name | Description
TfrxIOTransportItem | Represents type TfrxIOTransportItem.
TfrxIOTransportsCollection | Represents type TfrxIOTransportsCollection.
Top


TfrxIOTransportItem Class

Summary

Represents type TfrxIOTransportItem.

Namespace: frxIOTransportIntf
Inheritance Hierarchy
TCollectionItem
frxIOTransportIntf.TfrxIOTransportItem
Syntax
Delphi
type
 TfrxIOTransportItem = class(TCollectionItem)
 end;

The TfrxIOTransportItem type exposes the following members.

Fields
Show:
Name | Description
IOTransport | Represents field IOTransport.
Top
See Also

Reference

  • frxIOTransportIntf


TfrxIOTransportItem Fields

Fields
Name | Description
IOTransport | Represents field IOTransport.
Top


TfrxIOTransportItem.IOTransport Field

Summary

Represents field IOTransport.

Namespace: frxIOTransportIntf
Syntax
Delphi
public
 IOTransport: TfrxCustomIOTransport;

Field Value

Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxIOTransportItem
  • frxIOTransportIntf


TfrxIOTransportsCollection Class

Summary

Represents type TfrxIOTransportsCollection.

Namespace: frxIOTransportIntf
Inheritance Hierarchy
TCollection
frxIOTransportIntf.TfrxIOTransportsCollection
Syntax
Delphi
type
 TfrxIOTransportsCollection = class(TCollection)
 end;

The TfrxIOTransportsCollection type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxIOTransportsCollection class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
GetIOTransportItem(Integer) | Represents method GetIOTransportItem(Integer).
Register(TfrxCustomIOTransport) | Represents method Register(TfrxCustomIOTransport).
Unregister(TfrxCustomIOTransport) | Represents method Unregister(TfrxCustomIOTransport).
Top
See Also

Reference

  • frxIOTransportIntf


TfrxIOTransportsCollection Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxIOTransportsCollection class.
Top


TfrxIOTransportsCollection.Create Constructor

Summary

Initializes a new instance of the TfrxIOTransportsCollection class.

Namespace: frxIOTransportIntf
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxIOTransportsCollection
  • frxIOTransportIntf


TfrxIOTransportsCollection Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxIOTransportsCollection.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxIOTransportIntf
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxIOTransportItem
 read GetIOTransportItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxIOTransportItem

See Also

Reference

  • TfrxIOTransportsCollection
  • frxIOTransportIntf


TfrxIOTransportsCollection Methods

Methods
Name | Description
GetIOTransportItem(Integer) | Represents method GetIOTransportItem(Integer).
Register(TfrxCustomIOTransport) | Represents method Register(TfrxCustomIOTransport).
Unregister(TfrxCustomIOTransport) | Represents method Unregister(TfrxCustomIOTransport).
Top


TfrxIOTransportsCollection.GetIOTransportItem(Integer) Method

Summary

Represents method GetIOTransportItem(Integer).

Namespace: frxIOTransportIntf
Syntax
Delphi
private
 function GetIOTransportItem(Index: Integer): TfrxIOTransportItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxIOTransportItem

See Also

Reference

  • TfrxIOTransportsCollection
  • frxIOTransportIntf


TfrxIOTransportsCollection.Register(TfrxCustomIOTransport) Method

Summary

Represents method Register(TfrxCustomIOTransport).

Namespace: frxIOTransportIntf
Syntax
Delphi
public
 procedure Register(Filter: TfrxCustomIOTransport);

Parameters

Filter
Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxIOTransportsCollection
  • frxIOTransportIntf


TfrxIOTransportsCollection.Unregister(TfrxCustomIOTransport) Method

Summary

Represents method Unregister(TfrxCustomIOTransport).

Namespace: frxIOTransportIntf
Syntax
Delphi
public
 procedure Unregister(Filter: TfrxCustomIOTransport);

Parameters

Filter
Type: TfrxCustomIOTransport

See Also

Reference

  • TfrxIOTransportsCollection
  • frxIOTransportIntf


frxIOTransportIntf Routines

Routines
Name | Description
FillItemsList(TStrings,TfrxFilterVisibleState) | Represents method FillItemsList(TStrings,TfrxFilterVisibleState).
frxIOTransports | Represents method frxIOTransports.
GetFilterDialogVisibility(TfrxFilterVisibleState) | Represents method GetFilterDialogVisibility(TfrxFilterVisibleState).
Top


FillItemsList(TStrings,TfrxFilterVisibleState) Method

Summary

Represents method FillItemsList(TStrings,TfrxFilterVisibleState).

Namespace: frxIOTransportIntf
Syntax
Delphi
procedure FillItemsList(Items: TStrings; VisibleAt: TfrxFilterVisibleState);

Parameters

Items
Type: TStrings

VisibleAt
Type: TfrxFilterVisibleState

See Also

Reference

  • frxIOTransportIntf


frxIOTransports Method

Summary

Represents method frxIOTransports.

Namespace: frxIOTransportIntf
Syntax
Delphi
function frxIOTransports: TfrxIOTransportsCollection;

Return Value

Type: TfrxIOTransportsCollection

See Also

Reference

  • frxIOTransportIntf


GetFilterDialogVisibility(TfrxFilterVisibleState) Method

Summary

Represents method GetFilterDialogVisibility(TfrxFilterVisibleState).

Namespace: frxIOTransportIntf
Syntax
Delphi
function GetFilterDialogVisibility(CreatedFrom: TfrxFilterVisibleState): TfrxFilterVisibleState;

Parameters

CreatedFrom
Type: TfrxFilterVisibleState

Return Value

Type: TfrxFilterVisibleState

See Also

Reference

  • frxIOTransportIntf


frxMap Namespace

Summary

Represents namespace frxMap.

Classes
Name | Description
TfrxMapObject | Represents type TfrxMapObject.
TfrxMapView | Represents type TfrxMapView.
Top


frxMap Classes

Classes
Name | Description
TfrxMapObject | Represents type TfrxMapObject.
TfrxMapView | Represents type TfrxMapView.
Top


TfrxMapObject Class

Summary

Represents type TfrxMapObject.

Namespace: frxMap
Inheritance Hierarchy
TComponent
frxMap.TfrxMapObject
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxMapObject = class(TComponent)
 end;
See Also

Reference

  • frxMap


TfrxMapView Class

Summary

Represents type TfrxMapView.

Namespace: frxMap
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxMap.TfrxMapView
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxMapView = class(TfrxView)
 end;

The TfrxMapView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxMapView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxMapView class. (Overrides TfrxView.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
ClipMap | Represents property ClipMap.
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ColorScale | Represents property ColorScale.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Converter | Represents property Converter.
Cursor | Represents property Cursor.
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Represents property Fill.
FillType | Represents property FillType.
Font | Represents property Font.
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
KeepAspectRatio | Represents property KeepAspectRatio.
Layers | Represents property Layers.
Left | Represents property Left. (Inherited from TfrxView.)
MaxZoom | Represents property MaxZoom.
MercatorProjection | Represents property MercatorProjection.
MinZoom | Represents property MinZoom.
NeedBuildVector | Represents property NeedBuildVector.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OffsetX | Represents property OffsetX.
OffsetY | Represents property OffsetY.
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
OSMFileList | Represents property OSMFileList.
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
SelectedShapeName | Represents property SelectedShapeName.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
SizeScale | Represents property SizeScale.
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Zoom | Represents property Zoom.
Top
Methods
Show:
Name | Description
AddLayer(TLayerType,Boolean,string,TfrxReport) | Represents method AddLayer(TLayerType,Boolean,string,TfrxReport).
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
CanvasSize | Represents method CanvasSize.
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DisableSupportedHyperlink | Represents method DisableSupportedHyperlink.
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Overrides TfrxView.DrawClipped(TCanvas,Extended,Extended,Extended,Extended).)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawMap(TCanvas,Extended,Extended) | Represents method DrawMap(TCanvas,Extended,Extended).
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
EnableSupportedHyperlink | Represents method EnableSupportedHyperlink.
ExpandVar(String) | Represents method ExpandVar(String).
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GeometryChange(Extended,Extended,Extended,Extended) | Represents method GeometryChange(Extended,Extended,Extended,Extended).
GeometryRestore | Represents method GeometryRestore.
GeometrySave | Represents method GeometrySave.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Overrides TfrxComponent.GetContainerObjects.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetSelectedShapeName | Represents method GetSelectedShapeName.
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitConverter | Represents method InitConverter.
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsAlignByZoomPolygon | Represents method IsAlignByZoomPolygon.
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsMoveArrowArea(Extended,Extended) | Represents method IsMoveArrowArea(Extended,Extended).
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetMaxZoom(Extended) | Represents method SetMaxZoom(Extended).
SetMercatorProjection(Boolean) | Represents method SetMercatorProjection(Boolean).
SetMinZoom(Extended) | Represents method SetMinZoom(Extended).
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
SetZoom(Extended) | Represents method SetZoom(Extended).
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ShowMoveArrow | Represents method ShowMoveArrow.
SwapConverter(TfrxMapView) | Represents method SwapConverter(TfrxMapView).
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
ZoomByFactor(Extended) | Represents method ZoomByFactor(Extended).
ZoomByRect(TfrxRect) | Represents method ZoomByRect(TfrxRect).
ZoomRecenter(Extended,Extended,Extended) | Represents method ZoomRecenter(Extended,Extended,Extended).
Top
Fields
Show:
Name | Description
FAddingLayer | Represents field FAddingLayer.
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FClipMap | Represents field FClipMap.
FColorScale | Represents field FColorScale.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FConverter | Represents field FConverter.
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFirstDraw | Represents field FFirstDraw.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHasPreviousOffset | Represents field FHasPreviousOffset.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FKeepAspectRatio | Represents field FKeepAspectRatio.
FLayers | Represents field FLayers.
FMapOffsetX | Represents field FMapOffsetX.
FMapOffsetY | Represents field FMapOffsetY.
FMaxZoom | Represents field FMaxZoom.
FMercatorProjection | Represents field FMercatorProjection.
FMinZoom | Represents field FMinZoom.
FModified | Represents field FModified.
FNeedBuildVector | Represents field FNeedBuildVector.
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FOSMFileList | Represents field FOSMFileList.
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPreviousHyperlinkKind | Represents field FPreviousHyperlinkKind.
FPreviousOffset | Represents field FPreviousOffset.
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FShowMoveArrow | Represents field FShowMoveArrow.
FSizeScale | Represents field FSizeScale.
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
FZoom | Represents field FZoom.
oldHeight | Represents field oldHeight.
oldLeft | Represents field oldLeft.
oldOffsetX | Represents field oldOffsetX.
oldOffsetY | Represents field oldOffsetY.
oldTop | Represents field oldTop.
oldWidth | Represents field oldWidth.
oldZoom | Represents field oldZoom.
Top
See Also

Reference

  • frxMap


TfrxMapView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxMapView class. (Overrides TfrxView.Create(TComponent).)
Destroy | Represents the destructor of the TfrxMapView class. (Overrides TfrxView.Destroy.)
Top


TfrxMapView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxMapView class.

Namespace: frxMap
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxView.Create(TComponent)
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.Destroy Destructor

Summary

Represents the destructor of the TfrxMapView class.

Namespace: frxMap
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxView.Destroy
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView Properties

Properties
Name | Description
ClipMap | Represents property ClipMap.
ColorScale | Represents property ColorScale.
Converter | Represents property Converter.
Cursor | Represents property Cursor.
Fill | Represents property Fill.
FillType | Represents property FillType.
Font | Represents property Font.
Frame | Represents property Frame.
KeepAspectRatio | Represents property KeepAspectRatio.
Layers | Represents property Layers.
MaxZoom | Represents property MaxZoom.
MercatorProjection | Represents property MercatorProjection.
MinZoom | Represents property MinZoom.
NeedBuildVector | Represents property NeedBuildVector.
OffsetX | Represents property OffsetX.
OffsetY | Represents property OffsetY.
OSMFileList | Represents property OSMFileList.
SelectedShapeName | Represents property SelectedShapeName.
SizeScale | Represents property SizeScale.
Zoom | Represents property Zoom.
Top


TfrxMapView.ClipMap Property

Summary

Represents property ClipMap.

Namespace: frxMap
Syntax
Delphi
public
 property ClipMap: Boolean read FClipMap write FClipMap;

Property Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.ColorScale Property

Summary

Represents property ColorScale.

Namespace: frxMap
Syntax
Delphi
published
 property ColorScale: TMapScale read FColorScale;

Property Value

Type: TMapScale

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.Converter Property

Summary

Represents property Converter.

Namespace: frxMap
Syntax
Delphi
public
 property Converter: TMapToCanvasCoordinateConverter read FConverter;

Property Value

Type: TMapToCanvasCoordinateConverter

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.Cursor Property

Summary

Represents property Cursor.

Namespace: frxMap
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.Fill Property

Summary

Represents property Fill.

Namespace: frxMap
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FillType Property

Summary

Represents property FillType.

Namespace: frxMap
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.Font Property

Summary

Represents property Font.

Namespace: frxMap
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.Frame Property

Summary

Represents property Frame.

Namespace: frxMap
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.KeepAspectRatio Property

Summary

Represents property KeepAspectRatio.

Namespace: frxMap
Syntax
Delphi
published
 property KeepAspectRatio: Boolean read FKeepAspectRatio write FKeepAspectRatio;

Property Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.Layers Property

Summary

Represents property Layers.

Namespace: frxMap
Syntax
Delphi
public
 property Layers: TMapLayerList read FLayers;

Property Value

Type: TMapLayerList

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.MaxZoom Property

Summary

Represents property MaxZoom.

Namespace: frxMap
Syntax
Delphi
published
 property MaxZoom: Extended read FMaxZoom write SetMaxZoom;

Property Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.MercatorProjection Property

Summary

Represents property MercatorProjection.

Namespace: frxMap
Syntax
Delphi
published
 property MercatorProjection: Boolean read FMercatorProjection write SetMercatorProjection;

Property Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.MinZoom Property

Summary

Represents property MinZoom.

Namespace: frxMap
Syntax
Delphi
published
 property MinZoom: Extended read FMinZoom write SetMinZoom;

Property Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.NeedBuildVector Property

Summary

Represents property NeedBuildVector.

Namespace: frxMap
Syntax
Delphi
public
 property NeedBuildVector: Boolean read FNeedBuildVector write FNeedBuildVector;

Property Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.OffsetX Property

Summary

Represents property OffsetX.

Namespace: frxMap
Syntax
Delphi
published
 property OffsetX: Extended read FMapOffsetX write FMapOffsetX;

Property Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.OffsetY Property

Summary

Represents property OffsetY.

Namespace: frxMap
Syntax
Delphi
published
 property OffsetY: Extended read FMapOffsetY write FMapOffsetY;

Property Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.OSMFileList Property

Summary

Represents property OSMFileList.

Namespace: frxMap
Syntax
Delphi
public
 property OSMFileList: TOSMFileList read FOSMFileList;

Property Value

Type: TOSMFileList

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.SelectedShapeName Property

Summary

Represents property SelectedShapeName.

Namespace: frxMap
Syntax
Delphi
public
 property SelectedShapeName: String read GetSelectedShapeName;

Property Value

Type: String

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.SizeScale Property

Summary

Represents property SizeScale.

Namespace: frxMap
Syntax
Delphi
published
 property SizeScale: TMapScale read FSizeScale;

Property Value

Type: TMapScale

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.Zoom Property

Summary

Represents property Zoom.

Namespace: frxMap
Syntax
Delphi
published
 property Zoom: Extended read FZoom write SetZoom;

Property Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView Methods

Methods
Name | Description
AddLayer(TLayerType,Boolean,string,TfrxReport) | Represents method AddLayer(TLayerType,Boolean,string,TfrxReport).
CanvasSize | Represents method CanvasSize.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DisableSupportedHyperlink | Represents method DisableSupportedHyperlink.
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Overrides TfrxView.DrawClipped(TCanvas,Extended,Extended,Extended,Extended).)
DrawMap(TCanvas,Extended,Extended) | Represents method DrawMap(TCanvas,Extended,Extended).
EnableSupportedHyperlink | Represents method EnableSupportedHyperlink.
ExpandVar(String) | Represents method ExpandVar(String).
GeometryChange(Extended,Extended,Extended,Extended) | Represents method GeometryChange(Extended,Extended,Extended,Extended).
GeometryRestore | Represents method GeometryRestore.
GeometrySave | Represents method GeometrySave.
GetContainerObjects | Represents method GetContainerObjects. (Overrides TfrxComponent.GetContainerObjects.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetSelectedShapeName | Represents method GetSelectedShapeName.
InitConverter | Represents method InitConverter.
IsAlignByZoomPolygon | Represents method IsAlignByZoomPolygon.
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsMoveArrowArea(Extended,Extended) | Represents method IsMoveArrowArea(Extended,Extended).
SetMaxZoom(Extended) | Represents method SetMaxZoom(Extended).
SetMercatorProjection(Boolean) | Represents method SetMercatorProjection(Boolean).
SetMinZoom(Extended) | Represents method SetMinZoom(Extended).
SetZoom(Extended) | Represents method SetZoom(Extended).
ShowMoveArrow | Represents method ShowMoveArrow.
SwapConverter(TfrxMapView) | Represents method SwapConverter(TfrxMapView).
ZoomByFactor(Extended) | Represents method ZoomByFactor(Extended).
ZoomByRect(TfrxRect) | Represents method ZoomByRect(TfrxRect).
ZoomRecenter(Extended,Extended,Extended) | Represents method ZoomRecenter(Extended,Extended,Extended).
Top


TfrxMapView.AddLayer(TLayerType,Boolean,string,TfrxReport) Method

Summary

Represents method AddLayer(TLayerType,Boolean,string,TfrxReport).

Namespace: frxMap
Syntax
Delphi
public
 procedure AddLayer(LayerType: TLayerType; IsEmbed: Boolean; AMapFileName: string; DefaultReport: TfrxReport = nil);

Parameters

LayerType
Type: TLayerType

IsEmbed
Type: Boolean

AMapFileName
Type: string

DefaultReport
Type: TfrxReport

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.CanvasSize Method

Summary

Represents method CanvasSize.

Namespace: frxMap
Syntax
Delphi
protected
 function CanvasSize: TfrxPoint;

Return Value

Type: TfrxPoint

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxMap
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.DisableSupportedHyperlink Method

Summary

Represents method DisableSupportedHyperlink.

Namespace: frxMap
Syntax
Delphi
protected
 procedure DisableSupportedHyperlink;
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxMap
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton; Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).

Namespace: frxMap
Syntax
Delphi
public
 procedure DoMouseEnter(aPreviousObject: TfrxComponent; var EventParams: TfrxInteractiveEventsParams); override;

Parameters

aPreviousObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).

Namespace: frxMap
Syntax
Delphi
public
 procedure DoMouseLeave(aNextObject: TfrxComponent; var EventParams: TfrxInteractiveEventsParams); override;

Parameters

aNextObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxMap
Syntax
Delphi
public
 procedure DoMouseMove(X, Y: Integer; Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxMap
Syntax
Delphi
public
 procedure DoMouseUp(X, Y: Integer; Button: TMouseButton; Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).

Namespace: frxMap
Syntax
Delphi
public
 function DoMouseWheel(Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxMap
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.DrawClipped(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects.

Namespace: frxMap
Syntax
Delphi
public
 procedure DrawClipped(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

ScaleX
Type: Extended

ScaleY
Type: Extended

OffsetX
Type: Extended

OffsetY
Type: Extended

Overrides

TfrxView.DrawClipped(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.DrawMap(TCanvas,Extended,Extended) Method

Summary

Represents method DrawMap(TCanvas,Extended,Extended).

Namespace: frxMap
Syntax
Delphi
protected
 procedure DrawMap(Canvas: TCanvas; ScaleX, ScaleY: Extended);

Parameters

Canvas
Type: TCanvas

ScaleX
Type: Extended

ScaleY
Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.EnableSupportedHyperlink Method

Summary

Represents method EnableSupportedHyperlink.

Namespace: frxMap
Syntax
Delphi
protected
 procedure EnableSupportedHyperlink;
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.ExpandVar(String) Method

Summary

Represents method ExpandVar(String).

Namespace: frxMap
Syntax
Delphi
public
 procedure ExpandVar(var Expr: String);

Parameters

Expr
Type: String

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.GeometryChange(Extended,Extended,Extended,Extended) Method

Summary

Represents method GeometryChange(Extended,Extended,Extended,Extended).

Namespace: frxMap
Syntax
Delphi
public
 procedure GeometryChange(ALeft, ATop, AWidth, AHeight: Extended);

Parameters

ALeft
Type: Extended

ATop
Type: Extended

AWidth
Type: Extended

AHeight
Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.GeometryRestore Method

Summary

Represents method GeometryRestore.

Namespace: frxMap
Syntax
Delphi
public
 procedure GeometryRestore;
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.GeometrySave Method

Summary

Represents method GeometrySave.

Namespace: frxMap
Syntax
Delphi
public
 procedure GeometrySave;
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.GetContainerObjects Method

Summary

Represents method GetContainerObjects.

Namespace: frxMap
Syntax
Delphi
public
 function GetContainerObjects: TList; override;

Return Value

Type: TList

Overrides

TfrxComponent.GetContainerObjects
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxMap
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.GetSelectedShapeName Method

Summary

Represents method GetSelectedShapeName.

Namespace: frxMap
Syntax
Delphi
private
 function GetSelectedShapeName: String;

Return Value

Type: String

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.InitConverter Method

Summary

Represents method InitConverter.

Namespace: frxMap
Syntax
Delphi
protected
 procedure InitConverter;
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.IsAlignByZoomPolygon Method

Summary

Represents method IsAlignByZoomPolygon.

Namespace: frxMap
Syntax
Delphi
protected
 function IsAlignByZoomPolygon: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.IsContain(Extended,Extended) Method

Summary

Detects if point is inside an object coordinates.

Namespace: frxMap
Syntax
Delphi
public
 function IsContain(X, Y: Extended): Boolean; override;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

Overrides

TfrxComponent.IsContain(Extended,Extended)
See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.IsMoveArrowArea(Extended,Extended) Method

Summary

Represents method IsMoveArrowArea(Extended,Extended).

Namespace: frxMap
Syntax
Delphi
protected
 function IsMoveArrowArea(X, Y: Extended): Boolean;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.SetMaxZoom(Extended) Method

Summary

Represents method SetMaxZoom(Extended).

Namespace: frxMap
Syntax
Delphi
private
 procedure SetMaxZoom(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.SetMercatorProjection(Boolean) Method

Summary

Represents method SetMercatorProjection(Boolean).

Namespace: frxMap
Syntax
Delphi
private
 procedure SetMercatorProjection(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.SetMinZoom(Extended) Method

Summary

Represents method SetMinZoom(Extended).

Namespace: frxMap
Syntax
Delphi
private
 procedure SetMinZoom(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.SetZoom(Extended) Method

Summary

Represents method SetZoom(Extended).

Namespace: frxMap
Syntax
Delphi
private
 procedure SetZoom(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.ShowMoveArrow Method

Summary

Represents method ShowMoveArrow.

Namespace: frxMap
Syntax
Delphi
protected
 function ShowMoveArrow: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.SwapConverter(TfrxMapView) Method

Summary

Represents method SwapConverter(TfrxMapView).

Namespace: frxMap
Syntax
Delphi
public
 procedure SwapConverter(EditedMap: TfrxMapView);

Parameters

EditedMap
Type: TfrxMapView

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.ZoomByFactor(Extended) Method

Summary

Represents method ZoomByFactor(Extended).

Namespace: frxMap
Syntax
Delphi
public
 procedure ZoomByFactor(Factor: Extended);

Parameters

Factor
Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.ZoomByRect(TfrxRect) Method

Summary

Represents method ZoomByRect(TfrxRect).

Namespace: frxMap
Syntax
Delphi
public
 procedure ZoomByRect(ZoomRect: TfrxRect);

Parameters

ZoomRect
Type: TfrxRect

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.ZoomRecenter(Extended,Extended,Extended) Method

Summary

Represents method ZoomRecenter(Extended,Extended,Extended).

Namespace: frxMap
Syntax
Delphi
protected
 procedure ZoomRecenter(CenterX, CenterY, Factor: Extended);

Parameters

CenterX
Type: Extended

CenterY
Type: Extended

Factor
Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView Fields

Fields
Name | Description
FAddingLayer | Represents field FAddingLayer.
FClipMap | Represents field FClipMap.
FColorScale | Represents field FColorScale.
FConverter | Represents field FConverter.
FFirstDraw | Represents field FFirstDraw.
FHasPreviousOffset | Represents field FHasPreviousOffset.
FKeepAspectRatio | Represents field FKeepAspectRatio.
FLayers | Represents field FLayers.
FMapOffsetX | Represents field FMapOffsetX.
FMapOffsetY | Represents field FMapOffsetY.
FMaxZoom | Represents field FMaxZoom.
FMercatorProjection | Represents field FMercatorProjection.
FMinZoom | Represents field FMinZoom.
FModified | Represents field FModified.
FNeedBuildVector | Represents field FNeedBuildVector.
FOSMFileList | Represents field FOSMFileList.
FPreviousHyperlinkKind | Represents field FPreviousHyperlinkKind.
FPreviousOffset | Represents field FPreviousOffset.
FShowMoveArrow | Represents field FShowMoveArrow.
FSizeScale | Represents field FSizeScale.
FZoom | Represents field FZoom.
oldHeight | Represents field oldHeight.
oldLeft | Represents field oldLeft.
oldOffsetX | Represents field oldOffsetX.
oldOffsetY | Represents field oldOffsetY.
oldTop | Represents field oldTop.
oldWidth | Represents field oldWidth.
oldZoom | Represents field oldZoom.
Top


TfrxMapView.FAddingLayer Field

Summary

Represents field FAddingLayer.

Namespace: frxMap
Syntax
Delphi
protected
 FAddingLayer: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FClipMap Field

Summary

Represents field FClipMap.

Namespace: frxMap
Syntax
Delphi
protected
 FClipMap: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FColorScale Field

Summary

Represents field FColorScale.

Namespace: frxMap
Syntax
Delphi
protected
 FColorScale: TMapScale;

Field Value

Type: TMapScale

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FConverter Field

Summary

Represents field FConverter.

Namespace: frxMap
Syntax
Delphi
protected
 FConverter: TMapToCanvasCoordinateConverter;

Field Value

Type: TMapToCanvasCoordinateConverter

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FFirstDraw Field

Summary

Represents field FFirstDraw.

Namespace: frxMap
Syntax
Delphi
protected
 FFirstDraw: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FHasPreviousOffset Field

Summary

Represents field FHasPreviousOffset.

Namespace: frxMap
Syntax
Delphi
protected
 FHasPreviousOffset: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FKeepAspectRatio Field

Summary

Represents field FKeepAspectRatio.

Namespace: frxMap
Syntax
Delphi
private
 FKeepAspectRatio: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FLayers Field

Summary

Represents field FLayers.

Namespace: frxMap
Syntax
Delphi
protected
 FLayers: TMapLayerList;

Field Value

Type: TMapLayerList

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FMapOffsetX Field

Summary

Represents field FMapOffsetX.

Namespace: frxMap
Syntax
Delphi
private
 FMapOffsetX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FMapOffsetY Field

Summary

Represents field FMapOffsetY.

Namespace: frxMap
Syntax
Delphi
private
 FMapOffsetY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FMaxZoom Field

Summary

Represents field FMaxZoom.

Namespace: frxMap
Syntax
Delphi
private
 FMaxZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FMercatorProjection Field

Summary

Represents field FMercatorProjection.

Namespace: frxMap
Syntax
Delphi
private
 FMercatorProjection: boolean;

Field Value

Type: boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FMinZoom Field

Summary

Represents field FMinZoom.

Namespace: frxMap
Syntax
Delphi
private
 FMinZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FModified Field

Summary

Represents field FModified.

Namespace: frxMap
Syntax
Delphi
protected
 FModified: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FNeedBuildVector Field

Summary

Represents field FNeedBuildVector.

Namespace: frxMap
Syntax
Delphi
protected
 FNeedBuildVector: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FOSMFileList Field

Summary

Represents field FOSMFileList.

Namespace: frxMap
Syntax
Delphi
protected
 FOSMFileList: TOSMFileList;

Field Value

Type: TOSMFileList

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FPreviousHyperlinkKind Field

Summary

Represents field FPreviousHyperlinkKind.

Namespace: frxMap
Syntax
Delphi
protected
 FPreviousHyperlinkKind: TfrxHyperlinkKind;

Field Value

Type: TfrxHyperlinkKind

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FPreviousOffset Field

Summary

Represents field FPreviousOffset.

Namespace: frxMap
Syntax
Delphi
protected
 FPreviousOffset: TfrxPoint;

Field Value

Type: TfrxPoint

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FShowMoveArrow Field

Summary

Represents field FShowMoveArrow.

Namespace: frxMap
Syntax
Delphi
protected
 FShowMoveArrow: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FSizeScale Field

Summary

Represents field FSizeScale.

Namespace: frxMap
Syntax
Delphi
protected
 FSizeScale: TMapScale;

Field Value

Type: TMapScale

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.FZoom Field

Summary

Represents field FZoom.

Namespace: frxMap
Syntax
Delphi
private
 FZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.oldHeight Field

Summary

Represents field oldHeight.

Namespace: frxMap
Syntax
Delphi
protected
 oldLeft, oldTop, oldWidth, oldHeight, oldOffsetX, oldOffsetY, oldZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.oldLeft Field

Summary

Represents field oldLeft.

Namespace: frxMap
Syntax
Delphi
protected
 oldLeft, oldTop, oldWidth, oldHeight, oldOffsetX, oldOffsetY, oldZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.oldOffsetX Field

Summary

Represents field oldOffsetX.

Namespace: frxMap
Syntax
Delphi
protected
 oldLeft, oldTop, oldWidth, oldHeight, oldOffsetX, oldOffsetY, oldZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.oldOffsetY Field

Summary

Represents field oldOffsetY.

Namespace: frxMap
Syntax
Delphi
protected
 oldLeft, oldTop, oldWidth, oldHeight, oldOffsetX, oldOffsetY, oldZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.oldTop Field

Summary

Represents field oldTop.

Namespace: frxMap
Syntax
Delphi
protected
 oldLeft, oldTop, oldWidth, oldHeight, oldOffsetX, oldOffsetY, oldZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.oldWidth Field

Summary

Represents field oldWidth.

Namespace: frxMap
Syntax
Delphi
protected
 oldLeft, oldTop, oldWidth, oldHeight, oldOffsetX, oldOffsetY, oldZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


TfrxMapView.oldZoom Field

Summary

Represents field oldZoom.

Namespace: frxMap
Syntax
Delphi
protected
 oldLeft, oldTop, oldWidth, oldHeight, oldOffsetX, oldOffsetY, oldZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxMapView
  • frxMap


frxMapGeodataLayer Namespace

Summary

Represents namespace frxMapGeodataLayer.

Classes
Name | Description
TfrxMapGeodataLayer | Represents type TfrxMapGeodataLayer.
Top
Enumerations
Name | Description
TGeoDataKind | Represents type TGeoDataKind.
Top


frxMapGeodataLayer Classes

Classes
Name | Description
TfrxMapGeodataLayer | Represents type TfrxMapGeodataLayer.
Top


TfrxMapGeodataLayer Class

Summary

Represents type TfrxMapGeodataLayer.

Namespace: frxMapGeodataLayer
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxMapLayer.TfrxCustomLayer
frxMapGeodataLayer.TfrxMapGeodataLayer
Syntax
Delphi
type
 TfrxMapGeodataLayer = class (TfrxCustomLayer)
 end;

The TfrxMapGeodataLayer type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxMapGeodataLayer class. (Overrides TfrxCustomLayer.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Active | Represents property Active. (Inherited from TfrxCustomLayer.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AnalyticalValue | Represents property AnalyticalValue. (Inherited from TfrxCustomLayer.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BorderColorColumn | Represents property BorderColorColumn.
ClippingRect | Represents property ClippingRect. (Inherited from TfrxCustomLayer.)
ColorRanges | Represents property ColorRanges. (Inherited from TfrxCustomLayer.)
ColorRangesData | Represents property ColorRangesData. (Inherited from TfrxCustomLayer.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
DataColumn | Represents property DataColumn.
DataSet | Represents property DataSet. (Inherited from TfrxCustomLayer.)
DefaultShapeStyle | Represents property DefaultShapeStyle. (Inherited from TfrxCustomLayer.)
Description | Object's description. (Inherited from TfrxComponent.)
FillColorColumn | Represents property FillColorColumn.
Filter | Represents property Filter. (Inherited from TfrxCustomLayer.)
Font | Represents property Font. (Inherited from TfrxCustomLayer.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GeoDataKind | Represents property GeoDataKind.
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
HighlightColor | Represents property HighlightColor. (Inherited from TfrxCustomLayer.)
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LabelColumn | Represents property LabelColumn.
LabelKind | Represents property LabelKind. (Inherited from TfrxCustomLayer.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
MapAccuracy | Represents property MapAccuracy.
MapDataSet | Represents property MapDataSet.
MapPalette | Represents property MapPalette. (Inherited from TfrxCustomLayer.)
MapView | Represents property MapView. (Inherited from TfrxCustomLayer.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
Operation | Represents property Operation. (Inherited from TfrxCustomLayer.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PixelAccuracy | Represents property PixelAccuracy.
PointLabelsVisibleAtZoom | Represents property PointLabelsVisibleAtZoom. (Inherited from TfrxCustomLayer.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
SelectedShape | Represents property SelectedShape. (Inherited from TfrxCustomLayer.)
SelectedShapeIndex | Represents property SelectedShapeIndex. (Inherited from TfrxCustomLayer.)
SelectedShapeName | Represents property SelectedShapeName. (Inherited from TfrxCustomLayer.)
SelectedShapeValue | Represents property SelectedShapeValue. (Inherited from TfrxCustomLayer.)
ShowLines | Represents property ShowLines.
ShowPoints | Represents property ShowPoints.
ShowPolygons | Represents property ShowPolygons.
SizeRanges | Represents property SizeRanges. (Inherited from TfrxCustomLayer.)
SizeRangesData | Represents property SizeRangesData. (Inherited from TfrxCustomLayer.)
SpatialColumn | Represents property SpatialColumn.
SpatialValue | Represents property SpatialValue.
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
ValueFormat | Represents property ValueFormat. (Inherited from TfrxCustomLayer.)
VectorGraphic | Represents property VectorGraphic. (Inherited from TfrxCustomLayer.)
Visible | Represents property Visible. (Inherited from TfrxCustomLayer.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AddValueList(Variant) | Represents method AddValueList(Variant). (Overrides TfrxCustomLayer.AddValueList(Variant).)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BuildGraphic(TfrxPoint,Boolean) | Represents method BuildGraphic(TfrxPoint,Boolean). (Inherited from TfrxCustomLayer.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ClearSelectedShape | Represents method ClearSelectedShape. (Inherited from TfrxCustomLayer.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CopyDatasets(TfrxCustomLayer) | Represents method CopyDatasets(TfrxCustomLayer). (Overrides TfrxCustomLayer.CopyDatasets(TfrxCustomLayer).)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefinePrimeProperties(TFiler) | Represents method DefinePrimeProperties(TFiler). (Inherited from TfrxCustomLayer.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxCustomLayer.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas) | Represents method Draw(TCanvas). (Inherited from TfrxCustomLayer.)
DrawClippedPoint(TCanvas,Extended,Extended,Extended) | Represents method DrawClippedPoint(TCanvas,Extended,Extended,Extended). (Inherited from TfrxCustomLayer.)
DrawDiamond(TCanvas,Integer) | Represents method DrawDiamond(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawEllipse(TCanvas,Integer) | Represents method DrawEllipse(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawHighlightFrame(TCanvas,Integer) | Represents method DrawHighlightFrame(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawLegend(TCanvas,Integer) | Represents method DrawLegend(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawMultiPoint(TCanvas,Integer) | Represents method DrawMultiPoint(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawOn(TCanvas,Boolean,TfrxRect) | Represents method DrawOn(TCanvas,Boolean,TfrxRect). (Inherited from TfrxCustomLayer.)
DrawPicture(TCanvas,Integer) | Represents method DrawPicture(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPoint(TCanvas,Integer) | Represents method DrawPoint(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPointLegend(TCanvas,Integer) | Represents method DrawPointLegend(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPolygon(TCanvas,Integer) | Represents method DrawPolygon(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPolyLegend(TCanvas,Integer) | Represents method DrawPolyLegend(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPolyLine(TCanvas,Integer) | Represents method DrawPolyLine(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawRect(TCanvas,Integer) | Represents method DrawRect(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawTemplate(TCanvas,Integer) | Represents method DrawTemplate(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
ExpandVariables | Represents method ExpandVariables. (Inherited from TfrxCustomLayer.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FillRanges(TDoubleArray) | Represents method FillRanges(TDoubleArray). (Inherited from TfrxCustomLayer.)
FinaliseData | Represents method FinaliseData. (Inherited from TfrxCustomLayer.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColumnList(TStrings) | Represents method GetColumnList(TStrings). (Overrides TfrxCustomLayer.GetColumnList(TStrings).)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | Represents method GetData. (Inherited from TfrxCustomLayer.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDesigningData | Represents method GetDesigningData. (Inherited from TfrxCustomLayer.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetMetaFile(TfrxPoint,Boolean) | Represents method GetMetaFile(TfrxPoint,Boolean). (Inherited from TfrxCustomLayer.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSelectedShapeName | Represents method GetSelectedShapeName. (Overrides TfrxCustomLayer.GetSelectedShapeName.)
GetSelectedShapeValue | Represents method GetSelectedShapeValue. (Overrides TfrxCustomLayer.GetSelectedShapeValue.)
GetShapeLegeng(String,Integer) | Represents method GetShapeLegeng(String,Integer). (Inherited from TfrxCustomLayer.)
GetShapeName(String,Integer) | Represents method GetShapeName(String,Integer). (Inherited from TfrxCustomLayer.)
GetShapeValue(Integer) | Represents method GetShapeValue(Integer). (Inherited from TfrxCustomLayer.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitialiseData | Represents method InitialiseData. (Overrides TfrxCustomLayer.InitialiseData.)
InitTransform(Integer) | Represents method InitTransform(Integer). (Inherited from TfrxCustomLayer.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsCanGetData | Represents method IsCanGetData. (Overrides TfrxCustomLayer.IsCanGetData.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHasMapRect(TfrxRect) | Represents method IsHasMapRect(TfrxRect). (Inherited from TfrxCustomLayer.)
IsHasZoomRect(TfrxRect) | Represents method IsHasZoomRect(TfrxRect). (Inherited from TfrxCustomLayer.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsHiddenShape(Integer) | Represents method IsHiddenShape(Integer). (Inherited from TfrxCustomLayer.)
IsHighlightSelectedShape | Represents method IsHighlightSelectedShape. (Inherited from TfrxCustomLayer.)
IsInclude(TfrxPoint) | Represents method IsInclude(TfrxPoint). (Inherited from TfrxCustomLayer.)
IsIncludeAsRegion(TfrxPoint) | Represents method IsIncludeAsRegion(TfrxPoint). (Inherited from TfrxCustomLayer.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsMercatorSuitable | Represents method IsMercatorSuitable. (Inherited from TfrxCustomLayer.)
IsSelectedShapeChanded | Represents method IsSelectedShapeChanded. (Inherited from TfrxCustomLayer.)
IsSpecialBorderColor(Integer,TColor) | Represents method IsSpecialBorderColor(Integer,TColor). (Overrides TfrxCustomLayer.IsSpecialBorderColor(Integer,TColor).)
IsSpecialFillColor(Integer,TColor) | Represents method IsSpecialFillColor(Integer,TColor). (Overrides TfrxCustomLayer.IsSpecialFillColor(Integer,TColor).)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWideText | Represents method IsWideText.
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LoadGeoData(TMemoryStream,TStringList) | Represents method LoadGeoData(TMemoryStream,TStringList).
LoadShapes | Represents method LoadShapes.
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
SwapShapes(TfrxCustomLayer) | Represents method SwapShapes(TfrxCustomLayer). (Inherited from TfrxCustomLayer.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
TuneBrush(TBrush,Integer) | Represents method TuneBrush(TBrush,Integer). (Inherited from TfrxCustomLayer.)
TunePen(TPen,Integer) | Represents method TunePen(TPen,Integer). (Inherited from TfrxCustomLayer.)
TunePoint(TCanvas,Integer,Extended) | Represents method TunePoint(TCanvas,Integer,Extended). (Inherited from TfrxCustomLayer.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FActiveHyperlink | Represents field FActiveHyperlink. (Inherited from TfrxCustomLayer.)
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FBorderColorColumn | Represents field FBorderColorColumn.
FClippingRect | Represents field FClippingRect. (Inherited from TfrxCustomLayer.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FConverter | Represents field FConverter. (Inherited from TfrxCustomLayer.)
FDataColumn | Represents field FDataColumn.
FFillColorColumn | Represents field FFillColorColumn.
FGeoDataKind | Represents field FGeoDataKind.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLabelColumn | Represents field FLabelColumn. (Inherited from TfrxCustomLayer.)
FMapAccuracy | Represents field FMapAccuracy. (Inherited from TfrxCustomLayer.)
FMapDataSet | Represents field FMapDataSet.
FMapView | Represents field FMapView. (Inherited from TfrxCustomLayer.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPixelAccuracy | Represents field FPixelAccuracy. (Inherited from TfrxCustomLayer.)
FPreviousSelectedShapeIndex | Represents field FPreviousSelectedShapeIndex. (Inherited from TfrxCustomLayer.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShapes | Represents field FShapes. (Inherited from TfrxCustomLayer.)
FSpatialColumn | Represents field FSpatialColumn. (Inherited from TfrxCustomLayer.)
FValuesList | Represents field FValuesList. (Inherited from TfrxCustomLayer.)
FVectorGraphic | Represents field FVectorGraphic. (Inherited from TfrxCustomLayer.)
Top
See Also

Reference

  • frxMapGeodataLayer


TfrxMapGeodataLayer Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxMapGeodataLayer class. (Overrides TfrxCustomLayer.Create(TComponent).)
Top


TfrxMapGeodataLayer.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxMapGeodataLayer class.

Namespace: frxMapGeodataLayer
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomLayer.Create(TComponent)
See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer Properties

Properties
Name | Description
BorderColorColumn | Represents property BorderColorColumn.
DataColumn | Represents property DataColumn.
FillColorColumn | Represents property FillColorColumn.
GeoDataKind | Represents property GeoDataKind.
LabelColumn | Represents property LabelColumn.
MapAccuracy | Represents property MapAccuracy.
MapDataSet | Represents property MapDataSet.
PixelAccuracy | Represents property PixelAccuracy.
ShowLines | Represents property ShowLines.
ShowPoints | Represents property ShowPoints.
ShowPolygons | Represents property ShowPolygons.
SpatialColumn | Represents property SpatialColumn.
SpatialValue | Represents property SpatialValue.
Top


TfrxMapGeodataLayer.BorderColorColumn Property

Summary

Represents property BorderColorColumn.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property BorderColorColumn: String read FBorderColorColumn write FBorderColorColumn;

Property Value

Type: String

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.DataColumn Property

Summary

Represents property DataColumn.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property DataColumn: String read FDataColumn write FDataColumn;

Property Value

Type: String

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.FillColorColumn Property

Summary

Represents property FillColorColumn.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property FillColorColumn: String read FFillColorColumn write FFillColorColumn;

Property Value

Type: String

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.GeoDataKind Property

Summary

Represents property GeoDataKind.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property GeoDataKind: TGeoDataKind read FGeoDataKind write FGeoDataKind;

Property Value

Type: TGeoDataKind

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.LabelColumn Property

Summary

Represents property LabelColumn.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property LabelColumn;

Property Value

Type: Void

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.MapAccuracy Property

Summary

Represents property MapAccuracy.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property MapAccuracy;

Property Value

Type: Void

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.MapDataSet Property

Summary

Represents property MapDataSet.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property MapDataSet: TfrxDataSet read FMapDataSet write FMapDataSet;

Property Value

Type: TfrxDataSet

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.PixelAccuracy Property

Summary

Represents property PixelAccuracy.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property PixelAccuracy;

Property Value

Type: Void

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.ShowLines Property

Summary

Represents property ShowLines.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property ShowLines;

Property Value

Type: Void

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.ShowPoints Property

Summary

Represents property ShowPoints.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property ShowPoints;

Property Value

Type: Void

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.ShowPolygons Property

Summary

Represents property ShowPolygons.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property ShowPolygons;

Property Value

Type: Void

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.SpatialColumn Property

Summary

Represents property SpatialColumn.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property SpatialColumn;

Property Value

Type: Void

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.SpatialValue Property

Summary

Represents property SpatialValue.

Namespace: frxMapGeodataLayer
Syntax
Delphi
published
 property SpatialValue;

Property Value

Type: Void

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer Methods

Methods
Name | Description
AddValueList(Variant) | Represents method AddValueList(Variant). (Overrides TfrxCustomLayer.AddValueList(Variant).)
CopyDatasets(TfrxCustomLayer) | Represents method CopyDatasets(TfrxCustomLayer). (Overrides TfrxCustomLayer.CopyDatasets(TfrxCustomLayer).)
GetColumnList(TStrings) | Represents method GetColumnList(TStrings). (Overrides TfrxCustomLayer.GetColumnList(TStrings).)
GetSelectedShapeName | Represents method GetSelectedShapeName. (Overrides TfrxCustomLayer.GetSelectedShapeName.)
GetSelectedShapeValue | Represents method GetSelectedShapeValue. (Overrides TfrxCustomLayer.GetSelectedShapeValue.)
InitialiseData | Represents method InitialiseData. (Overrides TfrxCustomLayer.InitialiseData.)
IsCanGetData | Represents method IsCanGetData. (Overrides TfrxCustomLayer.IsCanGetData.)
IsSpecialBorderColor(Integer,TColor) | Represents method IsSpecialBorderColor(Integer,TColor). (Overrides TfrxCustomLayer.IsSpecialBorderColor(Integer,TColor).)
IsSpecialFillColor(Integer,TColor) | Represents method IsSpecialFillColor(Integer,TColor). (Overrides TfrxCustomLayer.IsSpecialFillColor(Integer,TColor).)
IsWideText | Represents method IsWideText.
LoadGeoData(TMemoryStream,TStringList) | Represents method LoadGeoData(TMemoryStream,TStringList).
LoadShapes | Represents method LoadShapes.
Top


TfrxMapGeodataLayer.AddValueList(Variant) Method

Summary

Represents method AddValueList(Variant).

Namespace: frxMapGeodataLayer
Syntax
Delphi
protected
 procedure AddValueList(vaAnalyticalValue: Variant); override;

Parameters

vaAnalyticalValue
Type: Variant

Overrides

TfrxCustomLayer.AddValueList(Variant)
See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.CopyDatasets(TfrxCustomLayer) Method

Summary

Represents method CopyDatasets(TfrxCustomLayer).

Namespace: frxMapGeodataLayer
Syntax
Delphi
public
 procedure CopyDatasets(CustomLayer: TfrxCustomLayer); override;

Parameters

CustomLayer
Type: TfrxCustomLayer

Overrides

TfrxCustomLayer.CopyDatasets(TfrxCustomLayer)
See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.GetColumnList(TStrings) Method

Summary

Represents method GetColumnList(TStrings).

Namespace: frxMapGeodataLayer
Syntax
Delphi
public
 procedure GetColumnList(List: TStrings); override;

Parameters

List
Type: TStrings

Overrides

TfrxCustomLayer.GetColumnList(TStrings)
See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.GetSelectedShapeName Method

Summary

Represents method GetSelectedShapeName.

Namespace: frxMapGeodataLayer
Syntax
Delphi
protected
 function GetSelectedShapeName: String; override;

Return Value

Type: String

Overrides

TfrxCustomLayer.GetSelectedShapeName
See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.GetSelectedShapeValue Method

Summary

Represents method GetSelectedShapeValue.

Namespace: frxMapGeodataLayer
Syntax
Delphi
protected
 function GetSelectedShapeValue: String; override;

Return Value

Type: String

Overrides

TfrxCustomLayer.GetSelectedShapeValue
See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.InitialiseData Method

Summary

Represents method InitialiseData.

Namespace: frxMapGeodataLayer
Syntax
Delphi
protected
 procedure InitialiseData; override;

Overrides

TfrxCustomLayer.InitialiseData
See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.IsCanGetData Method

Summary

Represents method IsCanGetData.

Namespace: frxMapGeodataLayer
Syntax
Delphi
protected
 function IsCanGetData: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCustomLayer.IsCanGetData
See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.IsSpecialBorderColor(Integer,TColor) Method

Summary

Represents method IsSpecialBorderColor(Integer,TColor).

Namespace: frxMapGeodataLayer
Syntax
Delphi
protected
 function IsSpecialBorderColor(iRecord: Integer; out SpecialColor: TColor): Boolean; override;

Parameters

iRecord
Type: Integer

SpecialColor
Type: TColor

Return Value

Type: Boolean

Overrides

TfrxCustomLayer.IsSpecialBorderColor(Integer,TColor)
See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.IsSpecialFillColor(Integer,TColor) Method

Summary

Represents method IsSpecialFillColor(Integer,TColor).

Namespace: frxMapGeodataLayer
Syntax
Delphi
protected
 function IsSpecialFillColor(iRecord: Integer; out SpecialColor: TColor): Boolean; override;

Parameters

iRecord
Type: Integer

SpecialColor
Type: TColor

Return Value

Type: Boolean

Overrides

TfrxCustomLayer.IsSpecialFillColor(Integer,TColor)
See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.IsWideText Method

Summary

Represents method IsWideText.

Namespace: frxMapGeodataLayer
Syntax
Delphi
protected
 function IsWideText: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.LoadGeoData(TMemoryStream,TStringList) Method

Summary

Represents method LoadGeoData(TMemoryStream,TStringList).

Namespace: frxMapGeodataLayer
Syntax
Delphi
protected
 procedure LoadGeoData(MemoryStream: TMemoryStream; Tags: TStringList);

Parameters

MemoryStream
Type: TMemoryStream

Tags
Type: TStringList

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.LoadShapes Method

Summary

Represents method LoadShapes.

Namespace: frxMapGeodataLayer
Syntax
Delphi
protected
 procedure LoadShapes;
See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer Fields

Fields
Name | Description
FBorderColorColumn | Represents field FBorderColorColumn.
FDataColumn | Represents field FDataColumn.
FFillColorColumn | Represents field FFillColorColumn.
FGeoDataKind | Represents field FGeoDataKind.
FMapDataSet | Represents field FMapDataSet.
Top


TfrxMapGeodataLayer.FBorderColorColumn Field

Summary

Represents field FBorderColorColumn.

Namespace: frxMapGeodataLayer
Syntax
Delphi
private
 FBorderColorColumn: String;

Field Value

Type: String

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.FDataColumn Field

Summary

Represents field FDataColumn.

Namespace: frxMapGeodataLayer
Syntax
Delphi
private
 FDataColumn: String;

Field Value

Type: String

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.FFillColorColumn Field

Summary

Represents field FFillColorColumn.

Namespace: frxMapGeodataLayer
Syntax
Delphi
private
 FFillColorColumn: String;

Field Value

Type: String

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.FGeoDataKind Field

Summary

Represents field FGeoDataKind.

Namespace: frxMapGeodataLayer
Syntax
Delphi
private
 FGeoDataKind: TGeoDataKind;

Field Value

Type: TGeoDataKind

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


TfrxMapGeodataLayer.FMapDataSet Field

Summary

Represents field FMapDataSet.

Namespace: frxMapGeodataLayer
Syntax
Delphi
private
 FMapDataSet: TfrxDataSet;

Field Value

Type: TfrxDataSet

See Also

Reference

  • TfrxMapGeodataLayer
  • frxMapGeodataLayer


frxMapGeodataLayer Enumerations

Enumerations
Name | Description
TGeoDataKind | Represents type TGeoDataKind.
Top


TGeoDataKind Enumeration

Summary

Represents type TGeoDataKind.

Namespace: frxMapGeodataLayer
Syntax
Delphi
type
 TGeoDataKind = (gdWKT, gdWKB);

The TGeoDataKind type exposes the following members.

Members
Show:
Name | Description
gdWKB | Represents constant gdWKB.
gdWKT | Represents constant gdWKT.
Top
See Also

Reference

  • frxMapGeodataLayer


frxMapHelpers Namespace

Summary

Represents namespace frxMapHelpers.

Classes
Name | Description
TfrxClippingRect | Represents type TfrxClippingRect.
TfrxMapXMLDocument | Represents type TfrxMapXMLDocument.
TfrxMapXMLReader | Represents type TfrxMapXMLReader.
TfrxSumStringList | Represents type TfrxSumStringList.
TMapToCanvasCoordinateConverter | Represents type TMapToCanvasCoordinateConverter.
TShapeData | Represents type TShapeData.
TTaggedElement | Represents type TTaggedElement.
Top
Enumerations
Name | Description
TLayerType | Represents type TLayerType.
TShapeType | Represents type TShapeType.
TValueDlm | Represents type TValueDlm.
Top
Constants
Name | Description
Bitmap32BF | Represents constant Bitmap32BF.
Top
Routines
Name | Description
IsCanPngToTransparentBitmap32(TPngObject,TBitmap) | Represents method IsCanPngToTransparentBitmap32(TPngObject,TBitmap).
IsMercatorLatitude(Extended,Extended) | Represents method IsMercatorLatitude(Extended,Extended).
Log(String) | Overloaded. Represents method Log(String).
Log(TStream) | Overloaded. Represents method Log(TStream).
Log(TStrings) | Overloaded. Represents method Log(TStrings).
PlatformFileName(string) | Represents method PlatformFileName(string).
SafeFileName(String) | Represents method SafeFileName(String).
Simplify(TDoublePointArray,Extended,Integer) | Represents method Simplify(TDoublePointArray,Extended,Integer).
ToHex(Byte) | Represents method ToHex(Byte).
Translate(TWinControl) | Represents method Translate(TWinControl).
TranslateMenu(TMenu) | Represents method TranslateMenu(TMenu).
Top


frxMapHelpers Classes

Classes
Name | Description
TfrxClippingRect | Represents type TfrxClippingRect.
TfrxMapXMLDocument | Represents type TfrxMapXMLDocument.
TfrxMapXMLReader | Represents type TfrxMapXMLReader.
TfrxSumStringList | Represents type TfrxSumStringList.
TMapToCanvasCoordinateConverter | Represents type TMapToCanvasCoordinateConverter.
TShapeData | Represents type TShapeData.
TTaggedElement | Represents type TTaggedElement.
Top


TfrxClippingRect Class

Summary

Represents type TfrxClippingRect.

Namespace: frxMapHelpers
Inheritance Hierarchy
TObject
frxMapHelpers.TfrxClippingRect
Syntax
Delphi
type
 TfrxClippingRect = class
 end;

The TfrxClippingRect type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxClippingRect class.
Top
Methods
Show:
Name | Description
Init(Boolean,TfrxRect) | Represents method Init(Boolean,TfrxRect).
IsCircleInside(TCircle) | Represents method IsCircleInside(TCircle).
IsDiamondInside(TRect) | Represents method IsDiamondInside(TRect).
IsPointInside(TfrxPoint) | Represents method IsPointInside(TfrxPoint).
IsPolygonCover(TDoublePointArray) | Overloaded. Represents method IsPolygonCover(TDoublePointArray).
IsPolygonCover(TPointArray) | Overloaded. Represents method IsPolygonCover(TPointArray).
IsPolygonCover(TShapeData,Integer) | Overloaded. Represents method IsPolygonCover(TShapeData,Integer).
IsPolygonInside(TDoublePointArray) | Overloaded. Represents method IsPolygonInside(TDoublePointArray).
IsPolygonInside(TPointArray) | Overloaded. Represents method IsPolygonInside(TPointArray).
IsPolygonInside(TShapeData,Integer) | Overloaded. Represents method IsPolygonInside(TShapeData,Integer).
IsPolyLineInside(TDoublePointArray) | Overloaded. Represents method IsPolyLineInside(TDoublePointArray).
IsPolyLineInside(TPointArray) | Overloaded. Represents method IsPolyLineInside(TPointArray).
IsPolyLineInside(TShapeData,Integer) | Overloaded. Represents method IsPolyLineInside(TShapeData,Integer).
IsRectInside(TRect) | Represents method IsRectInside(TRect).
IsSegmentInside(TSegment) | Represents method IsSegmentInside(TSegment).
Top
Fields
Show:
Name | Description
FActive | Represents field FActive.
FR | Represents field FR.
Top
See Also

Reference

  • frxMapHelpers


TfrxClippingRect Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxClippingRect class.
Top


TfrxClippingRect.Create Constructor

Summary

Initializes a new instance of the TfrxClippingRect class.

Namespace: frxMapHelpers
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect Methods

Methods
Name | Description
Init(Boolean,TfrxRect) | Represents method Init(Boolean,TfrxRect).
IsCircleInside(TCircle) | Represents method IsCircleInside(TCircle).
IsDiamondInside(TRect) | Represents method IsDiamondInside(TRect).
IsPointInside(TfrxPoint) | Represents method IsPointInside(TfrxPoint).
IsPolygonCover(TDoublePointArray) | Overloaded. Represents method IsPolygonCover(TDoublePointArray).
IsPolygonCover(TPointArray) | Overloaded. Represents method IsPolygonCover(TPointArray).
IsPolygonCover(TShapeData,Integer) | Overloaded. Represents method IsPolygonCover(TShapeData,Integer).
IsPolygonInside(TDoublePointArray) | Overloaded. Represents method IsPolygonInside(TDoublePointArray).
IsPolygonInside(TPointArray) | Overloaded. Represents method IsPolygonInside(TPointArray).
IsPolygonInside(TShapeData,Integer) | Overloaded. Represents method IsPolygonInside(TShapeData,Integer).
IsPolyLineInside(TDoublePointArray) | Overloaded. Represents method IsPolyLineInside(TDoublePointArray).
IsPolyLineInside(TPointArray) | Overloaded. Represents method IsPolyLineInside(TPointArray).
IsPolyLineInside(TShapeData,Integer) | Overloaded. Represents method IsPolyLineInside(TShapeData,Integer).
IsRectInside(TRect) | Represents method IsRectInside(TRect).
IsSegmentInside(TSegment) | Represents method IsSegmentInside(TSegment).
Top


TfrxClippingRect.Init(Boolean,TfrxRect) Method

Summary

Represents method Init(Boolean,TfrxRect).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure Init(Active: Boolean; R: TfrxRect);

Parameters

Active
Type: Boolean

R
Type: TfrxRect

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsCircleInside(TCircle) Method

Summary

Represents method IsCircleInside(TCircle).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsCircleInside(Circle: TCircle): Boolean;

Parameters

Circle
Type: TCircle

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsDiamondInside(TRect) Method

Summary

Represents method IsDiamondInside(TRect).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsDiamondInside(Rect: TRect): Boolean;

Parameters

Rect
Type: TRect

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsPointInside(TfrxPoint) Method

Summary

Represents method IsPointInside(TfrxPoint).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsPointInside(P: TfrxPoint): Boolean;

Parameters

P
Type: TfrxPoint

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsPolygonCover(TDoublePointArray) Method

Summary

Represents method IsPolygonCover(TDoublePointArray).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsPolygonCover(PolyPoints: TDoublePointArray): Boolean; overload;

Parameters

PolyPoints
Type: TDoublePointArray

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsPolygonCover(TPointArray) Method

Summary

Represents method IsPolygonCover(TPointArray).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsPolygonCover(PolyPoints: TPointArray): Boolean; overload;

Parameters

PolyPoints
Type: TPointArray

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsPolygonCover(TShapeData,Integer) Method

Summary

Represents method IsPolygonCover(TShapeData,Integer).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsPolygonCover(ShapeData: TShapeData; iPart: Integer): Boolean; overload;

Parameters

ShapeData
Type: TShapeData

iPart
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsPolygonInside(TDoublePointArray) Method

Summary

Represents method IsPolygonInside(TDoublePointArray).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsPolygonInside(PolyPoints: TDoublePointArray): Boolean; overload;

Parameters

PolyPoints
Type: TDoublePointArray

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsPolygonInside(TPointArray) Method

Summary

Represents method IsPolygonInside(TPointArray).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsPolygonInside(PolyPoints: TPointArray): Boolean; overload;

Parameters

PolyPoints
Type: TPointArray

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsPolygonInside(TShapeData,Integer) Method

Summary

Represents method IsPolygonInside(TShapeData,Integer).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsPolygonInside(ShapeData: TShapeData; iPart: Integer): Boolean; overload;

Parameters

ShapeData
Type: TShapeData

iPart
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsPolyLineInside(TDoublePointArray) Method

Summary

Represents method IsPolyLineInside(TDoublePointArray).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsPolyLineInside(PolyPoints: TDoublePointArray): Boolean; overload;

Parameters

PolyPoints
Type: TDoublePointArray

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsPolyLineInside(TPointArray) Method

Summary

Represents method IsPolyLineInside(TPointArray).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsPolyLineInside(PolyPoints: TPointArray): Boolean; overload;

Parameters

PolyPoints
Type: TPointArray

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsPolyLineInside(TShapeData,Integer) Method

Summary

Represents method IsPolyLineInside(TShapeData,Integer).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsPolyLineInside(ShapeData: TShapeData; iPart: Integer): Boolean; overload;

Parameters

ShapeData
Type: TShapeData

iPart
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsRectInside(TRect) Method

Summary

Represents method IsRectInside(TRect).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsRectInside(Rect: TRect): Boolean;

Parameters

Rect
Type: TRect

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.IsSegmentInside(TSegment) Method

Summary

Represents method IsSegmentInside(TSegment).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsSegmentInside(S: TSegment): Boolean;

Parameters

S
Type: TSegment

Return Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect Fields

Fields
Name | Description
FActive | Represents field FActive.
FR | Represents field FR.
Top


TfrxClippingRect.FActive Field

Summary

Represents field FActive.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FActive: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxClippingRect.FR Field

Summary

Represents field FR.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FR: TfrxRect;

Field Value

Type: TfrxRect

See Also

Reference

  • TfrxClippingRect
  • frxMapHelpers


TfrxMapXMLDocument Class

Summary

Represents type TfrxMapXMLDocument.

Namespace: frxMapHelpers
Inheritance Hierarchy
TObject
frxXML.TfrxXMLDocument
frxMapHelpers.TfrxMapXMLDocument
Syntax
Delphi
type
 TfrxMapXMLDocument = class(TfrxXMLDocument)
 end;

The TfrxMapXMLDocument type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxXMLDocument class. (Inherited from TfrxXMLDocument.)
Top
Properties
Show:
Name | Description
AutoIndent | Represents property AutoIndent. (Inherited from TfrxXMLDocument.)
OldVersion | Represents property OldVersion. (Inherited from TfrxXMLDocument.)
Root | Represents property Root. (Inherited from TfrxXMLDocument.)
TempDir | Represents property TempDir. (Inherited from TfrxXMLDocument.)
Top
Methods
Show:
Name | Description
Clear | Represents method Clear. (Inherited from TfrxXMLDocument.)
DeleteTempFile | Represents method DeleteTempFile. (Inherited from TfrxXMLDocument.)
DoneMapXMLFile | Represents method DoneMapXMLFile.
InitMapXMLFile(String) | Represents method InitMapXMLFile(String).
IsReadItem(TfrxXMLItem) | Represents method IsReadItem(TfrxXMLItem).
LoadFromFile(String) | Represents method LoadFromFile(String). (Inherited from TfrxXMLDocument.)
LoadFromStream(TStream,Boolean) | Represents method LoadFromStream(TStream,Boolean). (Inherited from TfrxXMLDocument.)
LoadItem(TfrxXMLItem) | Represents method LoadItem(TfrxXMLItem). (Inherited from TfrxXMLDocument.)
SaveToFile(String) | Represents method SaveToFile(String). (Inherited from TfrxXMLDocument.)
SaveToStream(TStream) | Represents method SaveToStream(TStream). (Inherited from TfrxXMLDocument.)
UnloadItem(TfrxXMLItem) | Represents method UnloadItem(TfrxXMLItem). (Inherited from TfrxXMLDocument.)
Top
Fields
Show:
Name | Description
FMapXMLStream | Represents field FMapXMLStream.
FMapXMLStreamReader | Represents field FMapXMLStreamReader.
FOldVersion | Represents field FOldVersion. (Inherited from TfrxXMLDocument.)
FTempStream | Represents field FTempStream. (Inherited from TfrxXMLDocument.)
Top
See Also

Reference

  • frxMapHelpers


TfrxMapXMLDocument Methods

Methods
Name | Description
DoneMapXMLFile | Represents method DoneMapXMLFile.
InitMapXMLFile(String) | Represents method InitMapXMLFile(String).
IsReadItem(TfrxXMLItem) | Represents method IsReadItem(TfrxXMLItem).
Top


TfrxMapXMLDocument.DoneMapXMLFile Method

Summary

Represents method DoneMapXMLFile.

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure DoneMapXMLFile;
See Also

Reference

  • TfrxMapXMLDocument
  • frxMapHelpers


TfrxMapXMLDocument.InitMapXMLFile(String) Method

Summary

Represents method InitMapXMLFile(String).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure InitMapXMLFile(const FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TfrxMapXMLDocument
  • frxMapHelpers


TfrxMapXMLDocument.IsReadItem(TfrxXMLItem) Method

Summary

Represents method IsReadItem(TfrxXMLItem).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsReadItem(Item: TfrxXMLItem): Boolean;

Parameters

Item
Type: TfrxXMLItem

Return Value

Type: Boolean

See Also

Reference

  • TfrxMapXMLDocument
  • frxMapHelpers


TfrxMapXMLDocument Fields

Fields
Name | Description
FMapXMLStream | Represents field FMapXMLStream.
FMapXMLStreamReader | Represents field FMapXMLStreamReader.
Top


TfrxMapXMLDocument.FMapXMLStream Field

Summary

Represents field FMapXMLStream.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FMapXMLStream: TFileStream;

Field Value

Type: TFileStream

See Also

Reference

  • TfrxMapXMLDocument
  • frxMapHelpers


TfrxMapXMLDocument.FMapXMLStreamReader Field

Summary

Represents field FMapXMLStreamReader.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FMapXMLStreamReader: TfrxMapXMLReader;

Field Value

Type: TfrxMapXMLReader

See Also

Reference

  • TfrxMapXMLDocument
  • frxMapHelpers


TfrxMapXMLReader Class

Summary

Represents type TfrxMapXMLReader.

Namespace: frxMapHelpers
Inheritance Hierarchy
TObject
frxXML.TfrxXMLReader
frxMapHelpers.TfrxMapXMLReader
Syntax
Delphi
type
 TfrxMapXMLReader = class(TfrxXMLReader)
 end;

The TfrxMapXMLReader type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream) | Initializes a new instance of the TfrxMapXMLReader class.
Top
Properties
Show:
Name | Description
OldFormat | Represents property OldFormat. (Inherited from TfrxXMLReader.)
Position | Represents property Position. (Inherited from TfrxXMLReader.)
Size | Represents property Size. (Inherited from TfrxXMLReader.)
Top
Methods
Show:
Name | Description
ChangeValueDlm(String) | Represents method ChangeValueDlm(String).
DefineValueDlm(String) | Represents method DefineValueDlm(String).
EndOfStream | Represents method EndOfStream. (Inherited from TfrxXMLReader.)
IsFirstSlash(String) | Represents method IsFirstSlash(String).
IsLastSlash(String) | Represents method IsLastSlash(String).
IsReadMapXMLItem(TfrxXMLItem) | Represents method IsReadMapXMLItem(TfrxXMLItem).
IsReadMapXMLRootItem(TfrxXMLItem) | Represents method IsReadMapXMLRootItem(TfrxXMLItem).
RaiseException | Represents method RaiseException. (Inherited from TfrxXMLReader.)
ReadFromBuffer | Represents method ReadFromBuffer. (Inherited from TfrxXMLReader.)
ReadHeader | Represents method ReadHeader. (Inherited from TfrxXMLReader.)
ReadItem(String,String) | Represents method ReadItem(String,String). (Inherited from TfrxXMLReader.)
ReadRootItem(TfrxXMLItem,Boolean) | Represents method ReadRootItem(TfrxXMLItem,Boolean). (Inherited from TfrxXMLReader.)
ReadValuedItem(String,String,String) | Represents method ReadValuedItem(String,String,String).
Top
Fields
Show:
Name | Description
FValueDlm | Represents field FValueDlm.
Top
See Also

Reference

  • frxMapHelpers


TfrxMapXMLReader Constructors

Constructors
Name | Description
Create(TStream) | Initializes a new instance of the TfrxMapXMLReader class.
Top


TfrxMapXMLReader.Create(TStream) Constructor

Summary

Initializes a new instance of the TfrxMapXMLReader class.

Namespace: frxMapHelpers
Syntax
Delphi
public
 constructor Create(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxMapXMLReader
  • frxMapHelpers


TfrxMapXMLReader Methods

Methods
Name | Description
ChangeValueDlm(String) | Represents method ChangeValueDlm(String).
DefineValueDlm(String) | Represents method DefineValueDlm(String).
IsFirstSlash(String) | Represents method IsFirstSlash(String).
IsLastSlash(String) | Represents method IsLastSlash(String).
IsReadMapXMLItem(TfrxXMLItem) | Represents method IsReadMapXMLItem(TfrxXMLItem).
IsReadMapXMLRootItem(TfrxXMLItem) | Represents method IsReadMapXMLRootItem(TfrxXMLItem).
ReadValuedItem(String,String,String) | Represents method ReadValuedItem(String,String,String).
Top


TfrxMapXMLReader.ChangeValueDlm(String) Method

Summary

Represents method ChangeValueDlm(String).

Namespace: frxMapHelpers
Syntax
Delphi
protected
 procedure ChangeValueDlm(var Text: String);

Parameters

Text
Type: String

See Also

Reference

  • TfrxMapXMLReader
  • frxMapHelpers


TfrxMapXMLReader.DefineValueDlm(String) Method

Summary

Represents method DefineValueDlm(String).

Namespace: frxMapHelpers
Syntax
Delphi
protected
 procedure DefineValueDlm(Text: String);

Parameters

Text
Type: String

See Also

Reference

  • TfrxMapXMLReader
  • frxMapHelpers


TfrxMapXMLReader.IsFirstSlash(String) Method

Summary

Represents method IsFirstSlash(String).

Namespace: frxMapHelpers
Syntax
Delphi
protected
 function IsFirstSlash(const InSt: String): Boolean;

Parameters

InSt
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TfrxMapXMLReader
  • frxMapHelpers


TfrxMapXMLReader.IsLastSlash(String) Method

Summary

Represents method IsLastSlash(String).

Namespace: frxMapHelpers
Syntax
Delphi
protected
 function IsLastSlash(const InSt: String): Boolean;

Parameters

InSt
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TfrxMapXMLReader
  • frxMapHelpers


TfrxMapXMLReader.IsReadMapXMLItem(TfrxXMLItem) Method

Summary

Represents method IsReadMapXMLItem(TfrxXMLItem).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsReadMapXMLItem(Item: TfrxXMLItem): Boolean;

Parameters

Item
Type: TfrxXMLItem

Return Value

Type: Boolean

See Also

Reference

  • TfrxMapXMLReader
  • frxMapHelpers


TfrxMapXMLReader.IsReadMapXMLRootItem(TfrxXMLItem) Method

Summary

Represents method IsReadMapXMLRootItem(TfrxXMLItem).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsReadMapXMLRootItem(Item: TfrxXMLItem): Boolean;

Parameters

Item
Type: TfrxXMLItem

Return Value

Type: Boolean

See Also

Reference

  • TfrxMapXMLReader
  • frxMapHelpers


TfrxMapXMLReader.ReadValuedItem(String,String,String) Method

Summary

Represents method ReadValuedItem(String,String,String).

Namespace: frxMapHelpers
Syntax
Delphi
protected
 procedure ReadValuedItem(var NameS, ValueS, Text: String);

Parameters

NameS
Type: String

ValueS
Type: String

Text
Type: String

See Also

Reference

  • TfrxMapXMLReader
  • frxMapHelpers


TfrxMapXMLReader Fields

Fields
Name | Description
FValueDlm | Represents field FValueDlm.
Top


TfrxMapXMLReader.FValueDlm Field

Summary

Represents field FValueDlm.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FValueDlm: TValueDlm;

Field Value

Type: TValueDlm

See Also

Reference

  • TfrxMapXMLReader
  • frxMapHelpers


TfrxSumStringList Class

Summary

Represents type TfrxSumStringList.

Namespace: frxMapHelpers
Inheritance Hierarchy
TStringList
frxMapHelpers.TfrxSumStringList
Syntax
Delphi
type
 TfrxSumStringList = class (TStringList)
 end;

The TfrxSumStringList type exposes the following members.

Properties
Show:
Name | Description
Sum[Integer] | Represents property Sum[Integer].
Top
Methods
Show:
Name | Description
AddSum(String) | Represents method AddSum(String).
GetSum(Integer) | Represents method GetSum(Integer).
SetSum(Integer,Integer) | Represents method SetSum(Integer,Integer).
SortSum | Represents method SortSum.
Top
See Also

Reference

  • frxMapHelpers


TfrxSumStringList Properties

Properties
Name | Description
Sum[Integer] | Represents property Sum[Integer].
Top


TfrxSumStringList.Sum[Integer] Property

Summary

Represents property Sum[Integer].

Namespace: frxMapHelpers
Syntax
Delphi
public
 property Sum[i: Integer]: Integer read GetSum write SetSum;

Parameters

i
Type: Integer

Property Value

Type: Integer

See Also

Reference

  • TfrxSumStringList
  • frxMapHelpers


TfrxSumStringList Methods

Methods
Name | Description
AddSum(String) | Represents method AddSum(String).
GetSum(Integer) | Represents method GetSum(Integer).
SetSum(Integer,Integer) | Represents method SetSum(Integer,Integer).
SortSum | Represents method SortSum.
Top


TfrxSumStringList.AddSum(String) Method

Summary

Represents method AddSum(String).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure AddSum(st: String);

Parameters

st
Type: String

See Also

Reference

  • TfrxSumStringList
  • frxMapHelpers


TfrxSumStringList.GetSum(Integer) Method

Summary

Represents method GetSum(Integer).

Namespace: frxMapHelpers
Syntax
Delphi
private
 function GetSum(i: Integer): Integer;

Parameters

i
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TfrxSumStringList
  • frxMapHelpers


TfrxSumStringList.SetSum(Integer,Integer) Method

Summary

Represents method SetSum(Integer,Integer).

Namespace: frxMapHelpers
Syntax
Delphi
private
 procedure SetSum(i: Integer; const Value: Integer);

Parameters

i
Type: Integer

Value
Type: Integer

See Also

Reference

  • TfrxSumStringList
  • frxMapHelpers


TfrxSumStringList.SortSum Method

Summary

Represents method SortSum.

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure SortSum;
See Also

Reference

  • TfrxSumStringList
  • frxMapHelpers


TMapToCanvasCoordinateConverter Class

Summary

Represents type TMapToCanvasCoordinateConverter.

Namespace: frxMapHelpers
Inheritance Hierarchy
TObject
frxMapHelpers.TMapToCanvasCoordinateConverter
Syntax
Delphi
type
 TMapToCanvasCoordinateConverter = class
 end;

The TMapToCanvasCoordinateConverter type exposes the following members.

Properties
Show:
Name | Description
IsHasData | Represents property IsHasData.
MercatorProjection | Represents property MercatorProjection.
UseOffset | Represents property UseOffset.
Top
Methods
Show:
Name | Description
AspectRatio | Represents method AspectRatio.
CanvasToMap(TfrxPoint) | Represents method CanvasToMap(TfrxPoint).
ConvertMercator(Extended) | Represents method ConvertMercator(Extended).
IgnoreShape | Represents method IgnoreShape.
IncludeRect(TfrxRect) | Represents method IncludeRect(TfrxRect).
Init | Represents method Init.
InitShape(Extended,Extended,Extended,TfrxPoint) | Represents method InitShape(Extended,Extended,Extended,TfrxPoint).
MapTransform(Extended,Extended) | Overloaded. Represents method MapTransform(Extended,Extended).
MapTransform(TfrxPoint) | Overloaded. Represents method MapTransform(TfrxPoint).
Read(TReader) | Represents method Read(TReader).
ReadDFM(TStream) | Represents method ReadDFM(TStream).
SetCanvasSize(TfrxPoint) | Represents method SetCanvasSize(TfrxPoint).
SetMercatorProjection(Boolean) | Represents method SetMercatorProjection(Boolean).
SetOffset(Extended,Extended) | Represents method SetOffset(Extended,Extended).
ShapeTransform(TfrxPoint) | Represents method ShapeTransform(TfrxPoint).
Transform(Extended,Extended) | Overloaded. Represents method Transform(Extended,Extended).
Transform(TDoublePoint) | Overloaded. Represents method Transform(TDoublePoint).
Transform(TfrxPoint) | Overloaded. Represents method Transform(TfrxPoint).
TransformOffset(TfrxPoint) | Overloaded. Represents method TransformOffset(TfrxPoint).
TransformRect(TfrxRect) | Represents method TransformRect(TfrxRect).
Write(TWriter) | Represents method Write(TWriter).
WriteDFM(TStream) | Represents method WriteDFM(TStream).
YTransform(Extended) | Represents method YTransform(Extended).
Top
Fields
Show:
Name | Description
FHeight | Represents field FHeight.
FIsHasData | Represents field FIsHasData.
FMercatorProjection | Represents field FMercatorProjection.
FOffsetX | Represents field FOffsetX.
FOffsetY | Represents field FOffsetY.
FShapeActive | Represents field FShapeActive.
FShapeCenter | Represents field FShapeCenter.
FShapeOffset | Represents field FShapeOffset.
FShapeZoom | Represents field FShapeZoom.
FUseOffset | Represents field FUseOffset.
FWidth | Represents field FWidth.
FXmax | Represents field FXmax.
FXmin | Represents field FXmin.
FXRange | Represents field FXRange.
FYmax | Represents field FYmax.
FYmaxTransformed | Represents field FYmaxTransformed.
FYmin | Represents field FYmin.
FYRange | Represents field FYRange.
Top
See Also

Reference

  • frxMapHelpers


TMapToCanvasCoordinateConverter Properties

Properties
Name | Description
IsHasData | Represents property IsHasData.
MercatorProjection | Represents property MercatorProjection.
UseOffset | Represents property UseOffset.
Top


TMapToCanvasCoordinateConverter.IsHasData Property

Summary

Represents property IsHasData.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property IsHasData: Boolean read FIsHasData;

Property Value

Type: Boolean

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.MercatorProjection Property

Summary

Represents property MercatorProjection.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property MercatorProjection: Boolean read FMercatorProjection write SetMercatorProjection;

Property Value

Type: Boolean

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.UseOffset Property

Summary

Represents property UseOffset.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property UseOffset: Boolean read FUseOffset write FUseOffset;

Property Value

Type: Boolean

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter Methods

Methods
Name | Description
AspectRatio | Represents method AspectRatio.
CanvasToMap(TfrxPoint) | Represents method CanvasToMap(TfrxPoint).
ConvertMercator(Extended) | Represents method ConvertMercator(Extended).
IgnoreShape | Represents method IgnoreShape.
IncludeRect(TfrxRect) | Represents method IncludeRect(TfrxRect).
Init | Represents method Init.
InitShape(Extended,Extended,Extended,TfrxPoint) | Represents method InitShape(Extended,Extended,Extended,TfrxPoint).
MapTransform(Extended,Extended) | Overloaded. Represents method MapTransform(Extended,Extended).
MapTransform(TfrxPoint) | Overloaded. Represents method MapTransform(TfrxPoint).
Read(TReader) | Represents method Read(TReader).
ReadDFM(TStream) | Represents method ReadDFM(TStream).
SetCanvasSize(TfrxPoint) | Represents method SetCanvasSize(TfrxPoint).
SetMercatorProjection(Boolean) | Represents method SetMercatorProjection(Boolean).
SetOffset(Extended,Extended) | Represents method SetOffset(Extended,Extended).
ShapeTransform(TfrxPoint) | Represents method ShapeTransform(TfrxPoint).
Transform(Extended,Extended) | Overloaded. Represents method Transform(Extended,Extended).
Transform(TDoublePoint) | Overloaded. Represents method Transform(TDoublePoint).
Transform(TfrxPoint) | Overloaded. Represents method Transform(TfrxPoint).
TransformOffset(TfrxPoint) | Overloaded. Represents method TransformOffset(TfrxPoint).
TransformRect(TfrxRect) | Represents method TransformRect(TfrxRect).
Write(TWriter) | Represents method Write(TWriter).
WriteDFM(TStream) | Represents method WriteDFM(TStream).
YTransform(Extended) | Represents method YTransform(Extended).
Top


TMapToCanvasCoordinateConverter.AspectRatio Method

Summary

Represents method AspectRatio.

Namespace: frxMapHelpers
Syntax
Delphi
public
 function AspectRatio: Extended;

Return Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.CanvasToMap(TfrxPoint) Method

Summary

Represents method CanvasToMap(TfrxPoint).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function CanvasToMap(Canvas: TfrxPoint): TfrxPoint;

Parameters

Canvas
Type: TfrxPoint

Return Value

Type: TfrxPoint

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.ConvertMercator(Extended) Method

Summary

Represents method ConvertMercator(Extended).

Namespace: frxMapHelpers
Syntax
Delphi
protected
 function ConvertMercator(Y: Extended): Extended;

Parameters

Y
Type: Extended

Return Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.IgnoreShape Method

Summary

Represents method IgnoreShape.

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure IgnoreShape;
See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.IncludeRect(TfrxRect) Method

Summary

Represents method IncludeRect(TfrxRect).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure IncludeRect(LayerRect: TfrxRect);

Parameters

LayerRect
Type: TfrxRect

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.Init Method

Summary

Represents method Init.

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure Init;
See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.InitShape(Extended,Extended,Extended,TfrxPoint) Method

Summary

Represents method InitShape(Extended,Extended,Extended,TfrxPoint).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure InitShape(AOffsetX, AOffsetY, AZoom: Extended; AShapeCenter: TfrxPoint);

Parameters

AOffsetX
Type: Extended

AOffsetY
Type: Extended

AZoom
Type: Extended

AShapeCenter
Type: TfrxPoint

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.MapTransform(Extended,Extended) Method

Summary

Represents method MapTransform(Extended,Extended).

Namespace: frxMapHelpers
Syntax
Delphi
protected
 function MapTransform(X, Y: Extended): TfrxPoint; overload;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: TfrxPoint

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.MapTransform(TfrxPoint) Method

Summary

Represents method MapTransform(TfrxPoint).

Namespace: frxMapHelpers
Syntax
Delphi
protected
 function MapTransform(P: TfrxPoint): TfrxPoint; overload;

Parameters

P
Type: TfrxPoint

Return Value

Type: TfrxPoint

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.Read(TReader) Method

Summary

Represents method Read(TReader).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure Read(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.ReadDFM(TStream) Method

Summary

Represents method ReadDFM(TStream).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure ReadDFM(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.SetCanvasSize(TfrxPoint) Method

Summary

Represents method SetCanvasSize(TfrxPoint).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure SetCanvasSize(CanvasSize: TfrxPoint);

Parameters

CanvasSize
Type: TfrxPoint

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.SetMercatorProjection(Boolean) Method

Summary

Represents method SetMercatorProjection(Boolean).

Namespace: frxMapHelpers
Syntax
Delphi
private
 procedure SetMercatorProjection(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.SetOffset(Extended,Extended) Method

Summary

Represents method SetOffset(Extended,Extended).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure SetOffset(OffsetX, OffsetY: Extended);

Parameters

OffsetX
Type: Extended

OffsetY
Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.ShapeTransform(TfrxPoint) Method

Summary

Represents method ShapeTransform(TfrxPoint).

Namespace: frxMapHelpers
Syntax
Delphi
protected
 function ShapeTransform(P: TfrxPoint): TfrxPoint;

Parameters

P
Type: TfrxPoint

Return Value

Type: TfrxPoint

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.Transform(Extended,Extended) Method

Summary

Represents method Transform(Extended,Extended).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function Transform(X, Y: Extended): TfrxPoint; overload;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: TfrxPoint

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.Transform(TDoublePoint) Method

Summary

Represents method Transform(TDoublePoint).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function Transform(DoublePoint: TDoublePoint): TfrxPoint; overload;

Parameters

DoublePoint
Type: TDoublePoint

Return Value

Type: TfrxPoint

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.Transform(TfrxPoint) Method

Summary

Represents method Transform(TfrxPoint).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function Transform(frxPoint: TfrxPoint): TfrxPoint; overload;

Parameters

frxPoint
Type: TfrxPoint

Return Value

Type: TfrxPoint

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.TransformOffset(TfrxPoint) Method

Summary

Represents method TransformOffset(TfrxPoint).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function TransformOffset(frxPoint: TfrxPoint): TfrxPoint; overload;

Parameters

frxPoint
Type: TfrxPoint

Return Value

Type: TfrxPoint

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.TransformRect(TfrxRect) Method

Summary

Represents method TransformRect(TfrxRect).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function TransformRect(R: TfrxRect): TfrxRect;

Parameters

R
Type: TfrxRect

Return Value

Type: TfrxRect

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.Write(TWriter) Method

Summary

Represents method Write(TWriter).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure Write(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.WriteDFM(TStream) Method

Summary

Represents method WriteDFM(TStream).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure WriteDFM(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.YTransform(Extended) Method

Summary

Represents method YTransform(Extended).

Namespace: frxMapHelpers
Syntax
Delphi
protected
 function YTransform(Y: Extended): Extended;

Parameters

Y
Type: Extended

Return Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter Fields

Fields
Name | Description
FHeight | Represents field FHeight.
FIsHasData | Represents field FIsHasData.
FMercatorProjection | Represents field FMercatorProjection.
FOffsetX | Represents field FOffsetX.
FOffsetY | Represents field FOffsetY.
FShapeActive | Represents field FShapeActive.
FShapeCenter | Represents field FShapeCenter.
FShapeOffset | Represents field FShapeOffset.
FShapeZoom | Represents field FShapeZoom.
FUseOffset | Represents field FUseOffset.
FWidth | Represents field FWidth.
FXmax | Represents field FXmax.
FXmin | Represents field FXmin.
FXRange | Represents field FXRange.
FYmax | Represents field FYmax.
FYmaxTransformed | Represents field FYmaxTransformed.
FYmin | Represents field FYmin.
FYRange | Represents field FYRange.
Top


TMapToCanvasCoordinateConverter.FHeight Field

Summary

Represents field FHeight.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FWidth, FHeight, FOffsetX, FOffsetY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FIsHasData Field

Summary

Represents field FIsHasData.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FIsHasData: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FMercatorProjection Field

Summary

Represents field FMercatorProjection.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FMercatorProjection: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FOffsetX Field

Summary

Represents field FOffsetX.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FWidth, FHeight, FOffsetX, FOffsetY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FOffsetY Field

Summary

Represents field FOffsetY.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FWidth, FHeight, FOffsetX, FOffsetY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FShapeActive Field

Summary

Represents field FShapeActive.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FShapeActive: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FShapeCenter Field

Summary

Represents field FShapeCenter.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FShapeOffset, FShapeCenter: TfrxPoint;

Field Value

Type: TfrxPoint

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FShapeOffset Field

Summary

Represents field FShapeOffset.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FShapeOffset, FShapeCenter: TfrxPoint;

Field Value

Type: TfrxPoint

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FShapeZoom Field

Summary

Represents field FShapeZoom.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FShapeZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FUseOffset Field

Summary

Represents field FUseOffset.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FUseOffset: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FWidth Field

Summary

Represents field FWidth.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FWidth, FHeight, FOffsetX, FOffsetY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FXmax Field

Summary

Represents field FXmax.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FXmin, FYmin, FXmax, FYmax: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FXmin Field

Summary

Represents field FXmin.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FXmin, FYmin, FXmax, FYmax: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FXRange Field

Summary

Represents field FXRange.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FXRange, FYRange, FYmaxTransformed: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FYmax Field

Summary

Represents field FYmax.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FXmin, FYmin, FXmax, FYmax: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FYmaxTransformed Field

Summary

Represents field FYmaxTransformed.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FXRange, FYRange, FYmaxTransformed: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FYmin Field

Summary

Represents field FYmin.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FXmin, FYmin, FXmax, FYmax: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TMapToCanvasCoordinateConverter.FYRange Field

Summary

Represents field FYRange.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FXRange, FYRange, FYmaxTransformed: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapToCanvasCoordinateConverter
  • frxMapHelpers


TShapeData Class

Summary

Represents type TShapeData.

Namespace: frxMapHelpers
Inheritance Hierarchy
TObject
frxMapHelpers.TShapeData
Syntax
Delphi
type
 TShapeData = class
 end;

The TShapeData type exposes the following members.

Constructors
Show:
Name | Description
CreateEmpty(TShapeType,TStrings) | Initializes a new instance of the TShapeData class.
CreateFull(Integer,TShapeType,TStrings) | Initializes a new instance of the TShapeData class.
CreatePoint(TStrings,Double,Double) | Initializes a new instance of the TShapeData class.
CreatePoly(TShapeType,TStrings,Integer) | Initializes a new instance of the TShapeData class.
CreateRect(TStrings,TShapeType,TDoubleRect) | Initializes a new instance of the TShapeData class.
Destroy | Represents the destructor of the TShapeData class.
Top
Properties
Show:
Name | Description
ConstrainProportions | Represents property ConstrainProportions.
Font | Represents property Font.
LegendText | Represents property LegendText.
Legend[String] | Represents property Legend[String].
MultiLineCount[Integer] | Represents property MultiLineCount[Integer].
MultiLine[Integer,Integer] | Represents property MultiLine[Integer,Integer].
MultiPointCount | Represents property MultiPointCount.
MultiPoint[Integer] | Represents property MultiPoint[Integer].
PartCount | Represents property PartCount.
Picture | Represents property Picture.
Point | Represents property Point.
Rect | Represents property Rect.
ShapeCenter | Represents property ShapeCenter.
ShapeType | Represents property ShapeType.
Tags | Represents property Tags.
TemplateName | Represents property TemplateName.
WidestPartBounds | Represents property WidestPartBounds.
Top
Methods
Show:
Name | Description
AddPart(Integer) | Represents method AddPart(Integer).
CalcBounds | Represents method CalcBounds.
GetLegend(String) | Represents method GetLegend(String).
GetMultiLine(Integer,Integer) | Represents method GetMultiLine(Integer,Integer).
GetMultiLineCount(Integer) | Represents method GetMultiLineCount(Integer).
GetMultiPoint(Integer) | Represents method GetMultiPoint(Integer).
GetMultiPointCount | Represents method GetMultiPointCount.
GetPartCount | Represents method GetPartCount.
GetPoint | Represents method GetPoint.
GetPolyPoints(TDoublePointArray,Integer) | Represents method GetPolyPoints(TDoublePointArray,Integer).
GetRect | Represents method GetRect.
IsClosed | Represents method IsClosed.
IsGetColumnList(TStrings) | Represents method IsGetColumnList(TStrings).
IsMercatorSuitable | Represents method IsMercatorSuitable.
ReadData(TReader) | Represents method ReadData(TReader).
ReadFont(TReader) | Represents method ReadFont(TReader).
ReadPicture(TReader) | Represents method ReadPicture(TReader).
ReadStringList(TStringList,TReader) | Represents method ReadStringList(TStringList,TReader).
ReadTags(TReader) | Represents method ReadTags(TReader).
SetMultiLine(Integer,Integer,TDoublePoint) | Represents method SetMultiLine(Integer,Integer,TDoublePoint).
SetMultiLineCount(Integer,Integer) | Represents method SetMultiLineCount(Integer,Integer).
SetMultiPoint(Integer,TDoublePoint) | Represents method SetMultiPoint(Integer,TDoublePoint).
SetMultiPointCount(Integer) | Represents method SetMultiPointCount(Integer).
SetPartCount(Integer) | Represents method SetPartCount(Integer).
SetPoint(TDoublePoint) | Represents method SetPoint(TDoublePoint).
SetRect(TDoubleRect) | Represents method SetRect(TDoubleRect).
WriteData(TWriter) | Represents method WriteData(TWriter).
WriteFont(TWriter) | Represents method WriteFont(TWriter).
WritePicture(TWriter) | Represents method WritePicture(TWriter).
WriteStringList(TStringList,TWriter) | Represents method WriteStringList(TStringList,TWriter).
WriteTags(TWriter) | Represents method WriteTags(TWriter).
Top
Fields
Show:
Name | Description
FConstrainProportions | Represents field FConstrainProportions.
FData | Represents field FData.
FFont | Represents field FFont.
FLegendText | Represents field FLegendText.
FPicture | Represents field FPicture.
FShapeCenter | Represents field FShapeCenter.
FShapeType | Represents field FShapeType.
FTags | Represents field FTags.
FTemplateName | Represents field FTemplateName.
FWidestPartBounds | Represents field FWidestPartBounds.
Top
See Also

Reference

  • frxMapHelpers


TShapeData Constructors

Constructors
Name | Description
CreateEmpty(TShapeType,TStrings) | Initializes a new instance of the TShapeData class.
CreateFull(Integer,TShapeType,TStrings) | Initializes a new instance of the TShapeData class.
CreatePoint(TStrings,Double,Double) | Initializes a new instance of the TShapeData class.
CreatePoly(TShapeType,TStrings,Integer) | Initializes a new instance of the TShapeData class.
CreateRect(TStrings,TShapeType,TDoubleRect) | Initializes a new instance of the TShapeData class.
Destroy | Represents the destructor of the TShapeData class.
Top


TShapeData.CreateEmpty(TShapeType,TStrings) Constructor

Summary

Initializes a new instance of the TShapeData class.

Namespace: frxMapHelpers
Syntax
Delphi
public
 constructor CreateEmpty(AShapeType: TShapeType; ATags: TStrings);

Parameters

AShapeType
Type: TShapeType

ATags
Type: TStrings

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.CreateFull(Integer,TShapeType,TStrings) Constructor

Summary

Initializes a new instance of the TShapeData class.

Namespace: frxMapHelpers
Syntax
Delphi
public
 constructor CreateFull(iParts: Integer; AShapeType: TShapeType; ATags: TStrings);

Parameters

iParts
Type: Integer

AShapeType
Type: TShapeType

ATags
Type: TStrings

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.CreatePoint(TStrings,Double,Double) Constructor

Summary

Initializes a new instance of the TShapeData class.

Namespace: frxMapHelpers
Syntax
Delphi
public
 constructor CreatePoint(ATags: TStrings; X, Y: Double);

Parameters

ATags
Type: TStrings

X
Type: Double

Y
Type: Double

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.CreatePoly(TShapeType,TStrings,Integer) Constructor

Summary

Initializes a new instance of the TShapeData class.

Namespace: frxMapHelpers
Syntax
Delphi
public
 constructor CreatePoly(AShapeType: TShapeType; ATags: TStrings; iPoints: Integer);

Parameters

AShapeType
Type: TShapeType

ATags
Type: TStrings

iPoints
Type: Integer

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.CreateRect(TStrings,TShapeType,TDoubleRect) Constructor

Summary

Initializes a new instance of the TShapeData class.

Namespace: frxMapHelpers
Syntax
Delphi
public
 constructor CreateRect(ATags: TStrings; AShapeType: TShapeType; DR: TDoubleRect);

Parameters

ATags
Type: TStrings

AShapeType
Type: TShapeType

DR
Type: TDoubleRect

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.Destroy Destructor

Summary

Represents the destructor of the TShapeData class.

Namespace: frxMapHelpers
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData Properties

Properties
Name | Description
ConstrainProportions | Represents property ConstrainProportions.
Font | Represents property Font.
LegendText | Represents property LegendText.
Legend[String] | Represents property Legend[String].
MultiLineCount[Integer] | Represents property MultiLineCount[Integer].
MultiLine[Integer,Integer] | Represents property MultiLine[Integer,Integer].
MultiPointCount | Represents property MultiPointCount.
MultiPoint[Integer] | Represents property MultiPoint[Integer].
PartCount | Represents property PartCount.
Picture | Represents property Picture.
Point | Represents property Point.
Rect | Represents property Rect.
ShapeCenter | Represents property ShapeCenter.
ShapeType | Represents property ShapeType.
Tags | Represents property Tags.
TemplateName | Represents property TemplateName.
WidestPartBounds | Represents property WidestPartBounds.
Top


TShapeData.ConstrainProportions Property

Summary

Represents property ConstrainProportions.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property ConstrainProportions: Boolean read FConstrainProportions write FConstrainProportions;

Property Value

Type: Boolean

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.Font Property

Summary

Represents property Font.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property Font: TFont read FFont;

Property Value

Type: TFont

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.LegendText Property

Summary

Represents property LegendText.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property LegendText: TStringList read FLegendText;

Property Value

Type: TStringList

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.Legend[String] Property

Summary

Represents property Legend[String].

Namespace: frxMapHelpers
Syntax
Delphi
public
 property Legend[const Name: String]: String read GetLegend;

Parameters

Name
Type: String

Property Value

Type: String

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.MultiLineCount[Integer] Property

Summary

Represents property MultiLineCount[Integer].

Namespace: frxMapHelpers
Syntax
Delphi
public
 property MultiLineCount[iPart: Integer]: Integer read GetMultiLineCount write SetMultiLineCount;

Parameters

iPart
Type: Integer

Property Value

Type: Integer

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.MultiLine[Integer,Integer] Property

Summary

Represents property MultiLine[Integer,Integer].

Namespace: frxMapHelpers
Syntax
Delphi
public
 property MultiLine[iPart, iPoint: Integer]: TDoublePoint read GetMultiLine write SetMultiLine;

Parameters

iPart
Type: Integer

iPoint
Type: Integer

Property Value

Type: TDoublePoint

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.MultiPointCount Property

Summary

Represents property MultiPointCount.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property MultiPointCount: Integer read GetMultiPointCount write SetMultiPointCount;

Property Value

Type: Integer

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.MultiPoint[Integer] Property

Summary

Represents property MultiPoint[Integer].

Namespace: frxMapHelpers
Syntax
Delphi
public
 property MultiPoint[iPoint: Integer]: TDoublePoint read GetMultiPoint write SetMultiPoint;

Parameters

iPoint
Type: Integer

Property Value

Type: TDoublePoint

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.PartCount Property

Summary

Represents property PartCount.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property PartCount: Integer read GetPartCount write SetPartCount;

Property Value

Type: Integer

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.Picture Property

Summary

Represents property Picture.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property Picture: TPicture read FPicture;

Property Value

Type: TPicture

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.Point Property

Summary

Represents property Point.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property Point: TDoublePoint read GetPoint write SetPoint;

Property Value

Type: TDoublePoint

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.Rect Property

Summary

Represents property Rect.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property Rect: TDoubleRect read GetRect write SetRect;

Property Value

Type: TDoubleRect

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.ShapeCenter Property

Summary

Represents property ShapeCenter.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property ShapeCenter: TfrxPoint read FShapeCenter;

Property Value

Type: TfrxPoint

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.ShapeType Property

Summary

Represents property ShapeType.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property ShapeType: TShapeType read FShapeType;

Property Value

Type: TShapeType

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.Tags Property

Summary

Represents property Tags.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property Tags: TStringList read FTags;

Property Value

Type: TStringList

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.TemplateName Property

Summary

Represents property TemplateName.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property TemplateName: String read FTemplateName write FTemplateName;

Property Value

Type: String

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.WidestPartBounds Property

Summary

Represents property WidestPartBounds.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property WidestPartBounds: TfrxRect read FWidestPartBounds;

Property Value

Type: TfrxRect

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData Methods

Methods
Name | Description
AddPart(Integer) | Represents method AddPart(Integer).
CalcBounds | Represents method CalcBounds.
GetLegend(String) | Represents method GetLegend(String).
GetMultiLine(Integer,Integer) | Represents method GetMultiLine(Integer,Integer).
GetMultiLineCount(Integer) | Represents method GetMultiLineCount(Integer).
GetMultiPoint(Integer) | Represents method GetMultiPoint(Integer).
GetMultiPointCount | Represents method GetMultiPointCount.
GetPartCount | Represents method GetPartCount.
GetPoint | Represents method GetPoint.
GetPolyPoints(TDoublePointArray,Integer) | Represents method GetPolyPoints(TDoublePointArray,Integer).
GetRect | Represents method GetRect.
IsClosed | Represents method IsClosed.
IsGetColumnList(TStrings) | Represents method IsGetColumnList(TStrings).
IsMercatorSuitable | Represents method IsMercatorSuitable.
ReadData(TReader) | Represents method ReadData(TReader).
ReadFont(TReader) | Represents method ReadFont(TReader).
ReadPicture(TReader) | Represents method ReadPicture(TReader).
ReadStringList(TStringList,TReader) | Represents method ReadStringList(TStringList,TReader).
ReadTags(TReader) | Represents method ReadTags(TReader).
SetMultiLine(Integer,Integer,TDoublePoint) | Represents method SetMultiLine(Integer,Integer,TDoublePoint).
SetMultiLineCount(Integer,Integer) | Represents method SetMultiLineCount(Integer,Integer).
SetMultiPoint(Integer,TDoublePoint) | Represents method SetMultiPoint(Integer,TDoublePoint).
SetMultiPointCount(Integer) | Represents method SetMultiPointCount(Integer).
SetPartCount(Integer) | Represents method SetPartCount(Integer).
SetPoint(TDoublePoint) | Represents method SetPoint(TDoublePoint).
SetRect(TDoubleRect) | Represents method SetRect(TDoubleRect).
WriteData(TWriter) | Represents method WriteData(TWriter).
WriteFont(TWriter) | Represents method WriteFont(TWriter).
WritePicture(TWriter) | Represents method WritePicture(TWriter).
WriteStringList(TStringList,TWriter) | Represents method WriteStringList(TStringList,TWriter).
WriteTags(TWriter) | Represents method WriteTags(TWriter).
Top


TShapeData.AddPart(Integer) Method

Summary

Represents method AddPart(Integer).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure AddPart(iPoints: Integer);

Parameters

iPoints
Type: Integer

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.CalcBounds Method

Summary

Represents method CalcBounds.

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure CalcBounds;
See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.GetLegend(String) Method

Summary

Represents method GetLegend(String).

Namespace: frxMapHelpers
Syntax
Delphi
private
 function GetLegend(const Name: String): String;

Parameters

Name
Type: String

Return Value

Type: String

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.GetMultiLine(Integer,Integer) Method

Summary

Represents method GetMultiLine(Integer,Integer).

Namespace: frxMapHelpers
Syntax
Delphi
private
 function GetMultiLine(iPart, iPoint: Integer): TDoublePoint;

Parameters

iPart
Type: Integer

iPoint
Type: Integer

Return Value

Type: TDoublePoint

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.GetMultiLineCount(Integer) Method

Summary

Represents method GetMultiLineCount(Integer).

Namespace: frxMapHelpers
Syntax
Delphi
private
 function GetMultiLineCount(iPart: Integer): Integer;

Parameters

iPart
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.GetMultiPoint(Integer) Method

Summary

Represents method GetMultiPoint(Integer).

Namespace: frxMapHelpers
Syntax
Delphi
private
 function GetMultiPoint(iPoint: Integer): TDoublePoint;

Parameters

iPoint
Type: Integer

Return Value

Type: TDoublePoint

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.GetMultiPointCount Method

Summary

Represents method GetMultiPointCount.

Namespace: frxMapHelpers
Syntax
Delphi
private
 function GetMultiPointCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.GetPartCount Method

Summary

Represents method GetPartCount.

Namespace: frxMapHelpers
Syntax
Delphi
private
 function GetPartCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.GetPoint Method

Summary

Represents method GetPoint.

Namespace: frxMapHelpers
Syntax
Delphi
private
 function GetPoint: TDoublePoint;

Return Value

Type: TDoublePoint

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.GetPolyPoints(TDoublePointArray,Integer) Method

Summary

Represents method GetPolyPoints(TDoublePointArray,Integer).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure GetPolyPoints(var Points: TDoublePointArray; iPart: Integer);

Parameters

Points
Type: TDoublePointArray

iPart
Type: Integer

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.GetRect Method

Summary

Represents method GetRect.

Namespace: frxMapHelpers
Syntax
Delphi
private
 function GetRect: TDoubleRect;

Return Value

Type: TDoubleRect

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.IsClosed Method

Summary

Represents method IsClosed.

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsClosed: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.IsGetColumnList(TStrings) Method

Summary

Represents method IsGetColumnList(TStrings).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsGetColumnList(List: TStrings): Boolean;

Parameters

List
Type: TStrings

Return Value

Type: Boolean

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.IsMercatorSuitable Method

Summary

Represents method IsMercatorSuitable.

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsMercatorSuitable: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.ReadData(TReader) Method

Summary

Represents method ReadData(TReader).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure ReadData(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.ReadFont(TReader) Method

Summary

Represents method ReadFont(TReader).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure ReadFont(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.ReadPicture(TReader) Method

Summary

Represents method ReadPicture(TReader).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure ReadPicture(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.ReadStringList(TStringList,TReader) Method

Summary

Represents method ReadStringList(TStringList,TReader).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure ReadStringList(var SL: TStringList; Reader: TReader);

Parameters

SL
Type: TStringList

Reader
Type: TReader

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.ReadTags(TReader) Method

Summary

Represents method ReadTags(TReader).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure ReadTags(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.SetMultiLine(Integer,Integer,TDoublePoint) Method

Summary

Represents method SetMultiLine(Integer,Integer,TDoublePoint).

Namespace: frxMapHelpers
Syntax
Delphi
private
 procedure SetMultiLine(iPart, iPoint: Integer; const Value: TDoublePoint);

Parameters

iPart
Type: Integer

iPoint
Type: Integer

Value
Type: TDoublePoint

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.SetMultiLineCount(Integer,Integer) Method

Summary

Represents method SetMultiLineCount(Integer,Integer).

Namespace: frxMapHelpers
Syntax
Delphi
private
 procedure SetMultiLineCount(iPart: Integer; const Value: Integer);

Parameters

iPart
Type: Integer

Value
Type: Integer

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.SetMultiPoint(Integer,TDoublePoint) Method

Summary

Represents method SetMultiPoint(Integer,TDoublePoint).

Namespace: frxMapHelpers
Syntax
Delphi
private
 procedure SetMultiPoint(iPoint: Integer; const Value: TDoublePoint);

Parameters

iPoint
Type: Integer

Value
Type: TDoublePoint

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.SetMultiPointCount(Integer) Method

Summary

Represents method SetMultiPointCount(Integer).

Namespace: frxMapHelpers
Syntax
Delphi
private
 procedure SetMultiPointCount(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.SetPartCount(Integer) Method

Summary

Represents method SetPartCount(Integer).

Namespace: frxMapHelpers
Syntax
Delphi
private
 procedure SetPartCount(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.SetPoint(TDoublePoint) Method

Summary

Represents method SetPoint(TDoublePoint).

Namespace: frxMapHelpers
Syntax
Delphi
private
 procedure SetPoint(const Value: TDoublePoint);

Parameters

Value
Type: TDoublePoint

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.SetRect(TDoubleRect) Method

Summary

Represents method SetRect(TDoubleRect).

Namespace: frxMapHelpers
Syntax
Delphi
private
 procedure SetRect(const Value: TDoubleRect);

Parameters

Value
Type: TDoubleRect

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.WriteData(TWriter) Method

Summary

Represents method WriteData(TWriter).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure WriteData(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.WriteFont(TWriter) Method

Summary

Represents method WriteFont(TWriter).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure WriteFont(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.WritePicture(TWriter) Method

Summary

Represents method WritePicture(TWriter).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure WritePicture(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.WriteStringList(TStringList,TWriter) Method

Summary

Represents method WriteStringList(TStringList,TWriter).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure WriteStringList(SL: TStringList; Writer: TWriter);

Parameters

SL
Type: TStringList

Writer
Type: TWriter

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.WriteTags(TWriter) Method

Summary

Represents method WriteTags(TWriter).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure WriteTags(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData Fields

Fields
Name | Description
FConstrainProportions | Represents field FConstrainProportions.
FData | Represents field FData.
FFont | Represents field FFont.
FLegendText | Represents field FLegendText.
FPicture | Represents field FPicture.
FShapeCenter | Represents field FShapeCenter.
FShapeType | Represents field FShapeType.
FTags | Represents field FTags.
FTemplateName | Represents field FTemplateName.
FWidestPartBounds | Represents field FWidestPartBounds.
Top


TShapeData.FConstrainProportions Field

Summary

Represents field FConstrainProportions.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FConstrainProportions: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.FData Field

Summary

Represents field FData.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FData: TDoublePointMatrix;

Field Value

Type: TDoublePointMatrix

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.FFont Field

Summary

Represents field FFont.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FFont: TFont;

Field Value

Type: TFont

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.FLegendText Field

Summary

Represents field FLegendText.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FLegendText: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.FPicture Field

Summary

Represents field FPicture.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FPicture: TPicture;

Field Value

Type: TPicture

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.FShapeCenter Field

Summary

Represents field FShapeCenter.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FShapeCenter: TfrxPoint;

Field Value

Type: TfrxPoint

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.FShapeType Field

Summary

Represents field FShapeType.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FShapeType: TShapeType;

Field Value

Type: TShapeType

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.FTags Field

Summary

Represents field FTags.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FTags: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.FTemplateName Field

Summary

Represents field FTemplateName.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FTemplateName: String;

Field Value

Type: String

See Also

Reference

  • TShapeData
  • frxMapHelpers


TShapeData.FWidestPartBounds Field

Summary

Represents field FWidestPartBounds.

Namespace: frxMapHelpers
Syntax
Delphi
private
 FWidestPartBounds: TfrxRect;

Field Value

Type: TfrxRect

See Also

Reference

  • TShapeData
  • frxMapHelpers


TTaggedElement Class

Summary

Represents type TTaggedElement.

Namespace: frxMapHelpers
Inheritance Hierarchy
TObject
frxMapHelpers.TTaggedElement
frxGPXFileFormat.TGPXAnyPoint
frxGPXFileFormat.TGPXTrack
frxGPXFileFormat.TGPXTrackSegment
frxOSMFileFormat.TOSMNode
frxOSMFileFormat.TOSMWay
Syntax
Delphi
type
 TTaggedElement = class
 end;

The TTaggedElement type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TTaggedElement class.
Destroy | Represents the destructor of the TTaggedElement class.
Top
Properties
Show:
Name | Description
Tags | Represents property Tags.
Top
Methods
Show:
Name | Description
AddTag(String,String) | Represents method AddTag(String,String).
IsHaveAllTags(TStrings) | Represents method IsHaveAllTags(TStrings).
IsHaveAnyTag(TStrings) | Represents method IsHaveAnyTag(TStrings).
Top
Fields
Show:
Name | Description
FTags | Represents field FTags.
Top
See Also

Reference

  • frxMapHelpers


TTaggedElement Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TTaggedElement class.
Destroy | Represents the destructor of the TTaggedElement class.
Top


TTaggedElement.Create Constructor

Summary

Initializes a new instance of the TTaggedElement class.

Namespace: frxMapHelpers
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TTaggedElement
  • frxMapHelpers


TTaggedElement.Destroy Destructor

Summary

Represents the destructor of the TTaggedElement class.

Namespace: frxMapHelpers
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TTaggedElement
  • frxMapHelpers


TTaggedElement Properties

Properties
Name | Description
Tags | Represents property Tags.
Top


TTaggedElement.Tags Property

Summary

Represents property Tags.

Namespace: frxMapHelpers
Syntax
Delphi
public
 property Tags: TStringList read FTags;

Property Value

Type: TStringList

See Also

Reference

  • TTaggedElement
  • frxMapHelpers


TTaggedElement Methods

Methods
Name | Description
AddTag(String,String) | Represents method AddTag(String,String).
IsHaveAllTags(TStrings) | Represents method IsHaveAllTags(TStrings).
IsHaveAnyTag(TStrings) | Represents method IsHaveAnyTag(TStrings).
Top


TTaggedElement.AddTag(String,String) Method

Summary

Represents method AddTag(String,String).

Namespace: frxMapHelpers
Syntax
Delphi
public
 procedure AddTag(const stName, stValue: String);

Parameters

stName
Type: String

stValue
Type: String

See Also

Reference

  • TTaggedElement
  • frxMapHelpers


TTaggedElement.IsHaveAllTags(TStrings) Method

Summary

Represents method IsHaveAllTags(TStrings).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsHaveAllTags(LayerTags: TStrings): Boolean;

Parameters

LayerTags
Type: TStrings

Return Value

Type: Boolean

See Also

Reference

  • TTaggedElement
  • frxMapHelpers


TTaggedElement.IsHaveAnyTag(TStrings) Method

Summary

Represents method IsHaveAnyTag(TStrings).

Namespace: frxMapHelpers
Syntax
Delphi
public
 function IsHaveAnyTag(LayerTags: TStrings): Boolean;

Parameters

LayerTags
Type: TStrings

Return Value

Type: Boolean

See Also

Reference

  • TTaggedElement
  • frxMapHelpers


TTaggedElement Fields

Fields
Name | Description
FTags | Represents field FTags.
Top


TTaggedElement.FTags Field

Summary

Represents field FTags.

Namespace: frxMapHelpers
Syntax
Delphi
protected
 FTags: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TTaggedElement
  • frxMapHelpers


frxMapHelpers Enumerations

Enumerations
Name | Description
TLayerType | Represents type TLayerType.
TShapeType | Represents type TShapeType.
TValueDlm | Represents type TValueDlm.
Top


TLayerType Enumeration

Summary

Represents type TLayerType.

Namespace: frxMapHelpers
Syntax
Delphi
type
 TLayerType = (ltMapFile, ltApplication, ltInteractive, ltGeodata);

The TLayerType type exposes the following members.

Members
Show:
Name | Description
ltApplication | Represents constant ltApplication.
ltGeodata | Represents constant ltGeodata.
ltInteractive | Represents constant ltInteractive.
ltMapFile | Represents constant ltMapFile.
Top
See Also

Reference

  • frxMapHelpers


TShapeType Enumeration

Summary

Represents type TShapeType.

Namespace: frxMapHelpers
Syntax
Delphi
type
 TShapeType = (stNone, stPoint, stPolyLine, stPolygon,
 stRect, stDiamond, stEllipse, stPicture, stLegend, stTemplate,
 stMultiPoint, stMultiPolyLine, stMultiPolygon);

The TShapeType type exposes the following members.

Members
Show:
Name | Description
stDiamond | Represents constant stDiamond.
stEllipse | Represents constant stEllipse.
stLegend | Represents constant stLegend.
stMultiPoint | Represents constant stMultiPoint.
stMultiPolygon | Represents constant stMultiPolygon.
stMultiPolyLine | Represents constant stMultiPolyLine.
stNone | Represents constant stNone.
stPicture | Represents constant stPicture.
stPoint | Represents constant stPoint.
stPolygon | Represents constant stPolygon.
stPolyLine | Represents constant stPolyLine.
stRect | Represents constant stRect.
stTemplate | Represents constant stTemplate.
Top
See Also

Reference

  • frxMapHelpers


TValueDlm Enumeration

Summary

Represents type TValueDlm.

Namespace: frxMapHelpers
Syntax
Delphi
type
 TValueDlm = (vdUnknown, vdApostrophe, vdQuote);

The TValueDlm type exposes the following members.

Members
Show:
Name | Description
vdApostrophe | Represents constant vdApostrophe.
vdQuote | Represents constant vdQuote.
vdUnknown | Represents constant vdUnknown.
Top
See Also

Reference

  • frxMapHelpers


frxMapHelpers Constants

Constants
Name | Description
Bitmap32BF | Represents constant Bitmap32BF.
Top


Bitmap32BF Constant

Summary

Represents constant Bitmap32BF.

Namespace: frxMapHelpers
Syntax
Delphi
 Bitmap32BF: TBlendFunction = ( BlendOp: AC_SRC_OVER; BlendFlags: 0;
 SourceConstantAlpha: 255; AlphaFormat: AC_SRC_ALPHA );

Value

Type: TBlendFunction

See Also

Reference

  • frxMapHelpers


frxMapHelpers Routines

Routines
Name | Description
IsCanPngToTransparentBitmap32(TPngObject,TBitmap) | Represents method IsCanPngToTransparentBitmap32(TPngObject,TBitmap).
IsMercatorLatitude(Extended,Extended) | Represents method IsMercatorLatitude(Extended,Extended).
Log(String) | Overloaded. Represents method Log(String).
Log(TStream) | Overloaded. Represents method Log(TStream).
Log(TStrings) | Overloaded. Represents method Log(TStrings).
PlatformFileName(string) | Represents method PlatformFileName(string).
SafeFileName(String) | Represents method SafeFileName(String).
Simplify(TDoublePointArray,Extended,Integer) | Represents method Simplify(TDoublePointArray,Extended,Integer).
ToHex(Byte) | Represents method ToHex(Byte).
Translate(TWinControl) | Represents method Translate(TWinControl).
TranslateMenu(TMenu) | Represents method TranslateMenu(TMenu).
Top


IsCanPngToTransparentBitmap32(TPngObject,TBitmap) Method

Summary

Represents method IsCanPngToTransparentBitmap32(TPngObject,TBitmap).

Namespace: frxMapHelpers
Syntax
Delphi
function IsCanPngToTransparentBitmap32(PNG: TPngObject; out Bitmap: TBitmap): boolean;

Parameters

PNG
Type: TPngObject

Bitmap
Type: TBitmap

Return Value

Type: boolean

See Also

Reference

  • frxMapHelpers


IsMercatorLatitude(Extended,Extended) Method

Summary

Represents method IsMercatorLatitude(Extended,Extended).

Namespace: frxMapHelpers
Syntax
Delphi
function IsMercatorLatitude(YMin, YMax: Extended): Boolean;

Parameters

YMin
Type: Extended

YMax
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • frxMapHelpers


Log(String) Method

Summary

Represents method Log(String).

Namespace: frxMapHelpers
Syntax
Delphi
procedure Log(Text: String); overload;

Parameters

Text
Type: String

See Also

Reference

  • frxMapHelpers


Log(TStream) Method

Summary

Represents method Log(TStream).

Namespace: frxMapHelpers
Syntax
Delphi
procedure Log(Stream: TStream); overload;

Parameters

Stream
Type: TStream

See Also

Reference

  • frxMapHelpers


Log(TStrings) Method

Summary

Represents method Log(TStrings).

Namespace: frxMapHelpers
Syntax
Delphi
procedure Log(Strings: TStrings); overload;

Parameters

Strings
Type: TStrings

See Also

Reference

  • frxMapHelpers


PlatformFileName(string) Method

Summary

Represents method PlatformFileName(string).

Namespace: frxMapHelpers
Syntax
Delphi
function PlatformFileName(const FileName: string): string;

Parameters

FileName
Type: string

Return Value

Type: string

See Also

Reference

  • frxMapHelpers


SafeFileName(String) Method

Summary

Represents method SafeFileName(String).

Namespace: frxMapHelpers
Syntax
Delphi
function SafeFileName(FileName: String): String;

Parameters

FileName
Type: String

Return Value

Type: String

See Also

Reference

  • frxMapHelpers


Simplify(TDoublePointArray,Extended,Integer) Method

Summary

Represents method Simplify(TDoublePointArray,Extended,Integer).

Namespace: frxMapHelpers
Syntax
Delphi
procedure Simplify(Points: TDoublePointArray; Accuracy: Extended; var UsedCount: Integer);

Parameters

Points
Type: TDoublePointArray

Accuracy
Type: Extended

UsedCount
Type: Integer

See Also

Reference

  • frxMapHelpers


ToHex(Byte) Method

Summary

Represents method ToHex(Byte).

Namespace: frxMapHelpers
Syntax
Delphi
function ToHex(b: Byte): string;

Parameters

b
Type: Byte

Return Value

Type: string

See Also

Reference

  • frxMapHelpers


Translate(TWinControl) Method

Summary

Represents method Translate(TWinControl).

Namespace: frxMapHelpers
Syntax
Delphi
procedure Translate(WinControl: TWinControl);

Parameters

WinControl
Type: TWinControl

See Also

Reference

  • frxMapHelpers


TranslateMenu(TMenu) Method

Summary

Represents method TranslateMenu(TMenu).

Namespace: frxMapHelpers
Syntax
Delphi
procedure TranslateMenu(Menu: TMenu);

Parameters

Menu
Type: TMenu

See Also

Reference

  • frxMapHelpers


frxMapInteractiveLayer Namespace

Summary

Represents namespace frxMapInteractiveLayer.

Classes
Name | Description
TfrxMapInteractiveLayer | Represents type TfrxMapInteractiveLayer.
Top


frxMapInteractiveLayer Classes

Classes
Name | Description
TfrxMapInteractiveLayer | Represents type TfrxMapInteractiveLayer.
Top


TfrxMapInteractiveLayer Class

Summary

Represents type TfrxMapInteractiveLayer.

Namespace: frxMapInteractiveLayer
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxMapLayer.TfrxCustomLayer
frxMapInteractiveLayer.TfrxMapInteractiveLayer
Syntax
Delphi
type
 TfrxMapInteractiveLayer = class (TfrxCustomLayer)
 end;

The TfrxMapInteractiveLayer type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxMapInteractiveLayer class. (Overrides TfrxCustomLayer.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Active | Represents property Active. (Inherited from TfrxCustomLayer.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AnalyticalValue | Represents property AnalyticalValue. (Inherited from TfrxCustomLayer.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
ClippingRect | Represents property ClippingRect. (Inherited from TfrxCustomLayer.)
ColorRanges | Represents property ColorRanges. (Inherited from TfrxCustomLayer.)
ColorRangesData | Represents property ColorRangesData. (Inherited from TfrxCustomLayer.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
DataSet | Represents property DataSet. (Inherited from TfrxCustomLayer.)
DefaultShapeStyle | Represents property DefaultShapeStyle. (Inherited from TfrxCustomLayer.)
Description | Object's description. (Inherited from TfrxComponent.)
EditedShape | Represents property EditedShape.
Filter | Represents property Filter. (Inherited from TfrxCustomLayer.)
Font | Represents property Font. (Inherited from TfrxCustomLayer.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
HighlightColor | Represents property HighlightColor. (Inherited from TfrxCustomLayer.)
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LabelColumn | Represents property LabelColumn.
LabelKind | Represents property LabelKind. (Inherited from TfrxCustomLayer.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
MapAccuracy | Represents property MapAccuracy. (Inherited from TfrxCustomLayer.)
MapPalette | Represents property MapPalette. (Inherited from TfrxCustomLayer.)
MapView | Represents property MapView. (Inherited from TfrxCustomLayer.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
Operation | Represents property Operation. (Inherited from TfrxCustomLayer.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PixelAccuracy | Represents property PixelAccuracy. (Inherited from TfrxCustomLayer.)
PointLabelsVisibleAtZoom | Represents property PointLabelsVisibleAtZoom. (Inherited from TfrxCustomLayer.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
SelectedShape | Represents property SelectedShape. (Inherited from TfrxCustomLayer.)
SelectedShapeIndex | Represents property SelectedShapeIndex. (Inherited from TfrxCustomLayer.)
SelectedShapeName | Represents property SelectedShapeName. (Inherited from TfrxCustomLayer.)
SelectedShapeValue | Represents property SelectedShapeValue. (Inherited from TfrxCustomLayer.)
ShowLines | Represents property ShowLines. (Inherited from TfrxCustomLayer.)
ShowPoints | Represents property ShowPoints. (Inherited from TfrxCustomLayer.)
ShowPolygons | Represents property ShowPolygons. (Inherited from TfrxCustomLayer.)
SizeRanges | Represents property SizeRanges. (Inherited from TfrxCustomLayer.)
SizeRangesData | Represents property SizeRangesData. (Inherited from TfrxCustomLayer.)
SpatialColumn | Represents property SpatialColumn. (Inherited from TfrxCustomLayer.)
SpatialValue | Represents property SpatialValue. (Inherited from TfrxCustomLayer.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
ValueFormat | Represents property ValueFormat. (Inherited from TfrxCustomLayer.)
VectorGraphic | Represents property VectorGraphic. (Inherited from TfrxCustomLayer.)
Visible | Represents property Visible. (Inherited from TfrxCustomLayer.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddShape(TShapeData) | Represents method AddShape(TShapeData).
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AddValueList(Variant) | Represents method AddValueList(Variant). (Overrides TfrxCustomLayer.AddValueList(Variant).)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BuildGraphic(TfrxPoint,Boolean) | Represents method BuildGraphic(TfrxPoint,Boolean). (Inherited from TfrxCustomLayer.)
CancelEditedShape(Boolean) | Represents method CancelEditedShape(Boolean).
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ClearSelectedShape | Represents method ClearSelectedShape. (Inherited from TfrxCustomLayer.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CopyDatasets(TfrxCustomLayer) | Represents method CopyDatasets(TfrxCustomLayer). (Inherited from TfrxCustomLayer.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefinePrimeProperties(TFiler) | Represents method DefinePrimeProperties(TFiler). (Inherited from TfrxCustomLayer.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxCustomLayer.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas) | Represents method Draw(TCanvas). (Inherited from TfrxCustomLayer.)
DrawClippedPoint(TCanvas,Extended,Extended,Extended) | Represents method DrawClippedPoint(TCanvas,Extended,Extended,Extended). (Inherited from TfrxCustomLayer.)
DrawDiamond(TCanvas,Integer) | Represents method DrawDiamond(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawEllipse(TCanvas,Integer) | Represents method DrawEllipse(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawHighlightFrame(TCanvas,Integer) | Represents method DrawHighlightFrame(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawLegend(TCanvas,Integer) | Represents method DrawLegend(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawMultiPoint(TCanvas,Integer) | Represents method DrawMultiPoint(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawOn(TCanvas,Boolean,TfrxRect) | Represents method DrawOn(TCanvas,Boolean,TfrxRect). (Inherited from TfrxCustomLayer.)
DrawPicture(TCanvas,Integer) | Represents method DrawPicture(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPoint(TCanvas,Integer) | Represents method DrawPoint(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPointLegend(TCanvas,Integer) | Represents method DrawPointLegend(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPolygon(TCanvas,Integer) | Represents method DrawPolygon(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPolyLegend(TCanvas,Integer) | Represents method DrawPolyLegend(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPolyLine(TCanvas,Integer) | Represents method DrawPolyLine(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawRect(TCanvas,Integer) | Represents method DrawRect(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawTemplate(TCanvas,Integer) | Represents method DrawTemplate(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
ExpandVariables | Represents method ExpandVariables. (Inherited from TfrxCustomLayer.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FillRanges(TDoubleArray) | Represents method FillRanges(TDoubleArray). (Inherited from TfrxCustomLayer.)
FinaliseData | Represents method FinaliseData. (Inherited from TfrxCustomLayer.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColumnList(TStrings) | Represents method GetColumnList(TStrings). (Inherited from TfrxCustomLayer.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | Represents method GetData. (Inherited from TfrxCustomLayer.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDesigningData | Represents method GetDesigningData. (Inherited from TfrxCustomLayer.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetMetaFile(TfrxPoint,Boolean) | Represents method GetMetaFile(TfrxPoint,Boolean). (Inherited from TfrxCustomLayer.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSelectedShapeName | Represents method GetSelectedShapeName. (Inherited from TfrxCustomLayer.)
GetSelectedShapeValue | Represents method GetSelectedShapeValue. (Inherited from TfrxCustomLayer.)
GetShapeLegeng(String,Integer) | Represents method GetShapeLegeng(String,Integer). (Inherited from TfrxCustomLayer.)
GetShapeName(String,Integer) | Represents method GetShapeName(String,Integer). (Inherited from TfrxCustomLayer.)
GetShapeValue(Integer) | Represents method GetShapeValue(Integer). (Inherited from TfrxCustomLayer.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitialiseData | Represents method InitialiseData. (Inherited from TfrxCustomLayer.)
InitTransform(Integer) | Represents method InitTransform(Integer). (Inherited from TfrxCustomLayer.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsCanGetData | Represents method IsCanGetData. (Inherited from TfrxCustomLayer.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsEditing | Represents method IsEditing.
IsHasMapRect(TfrxRect) | Represents method IsHasMapRect(TfrxRect). (Inherited from TfrxCustomLayer.)
IsHasZoomRect(TfrxRect) | Represents method IsHasZoomRect(TfrxRect). (Inherited from TfrxCustomLayer.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsHiddenShape(Integer) | Represents method IsHiddenShape(Integer). (Overrides TfrxCustomLayer.IsHiddenShape(Integer).)
IsHighlightSelectedShape | Represents method IsHighlightSelectedShape. (Overrides TfrxCustomLayer.IsHighlightSelectedShape.)
IsInclude(TfrxPoint) | Represents method IsInclude(TfrxPoint). (Inherited from TfrxCustomLayer.)
IsIncludeAsRegion(TfrxPoint) | Represents method IsIncludeAsRegion(TfrxPoint). (Inherited from TfrxCustomLayer.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsMercatorSuitable | Represents method IsMercatorSuitable. (Inherited from TfrxCustomLayer.)
IsSelectEditedShape(TfrxPoint,Extended) | Represents method IsSelectEditedShape(TfrxPoint,Extended).
IsSelectedShapeChanded | Represents method IsSelectedShapeChanded. (Inherited from TfrxCustomLayer.)
IsSpecialBorderColor(Integer,TColor) | Represents method IsSpecialBorderColor(Integer,TColor). (Inherited from TfrxCustomLayer.)
IsSpecialFillColor(Integer,TColor) | Represents method IsSpecialFillColor(Integer,TColor). (Inherited from TfrxCustomLayer.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
RemoveEditedShape | Represents method RemoveEditedShape.
ReplaceShape(TShapeData) | Represents method ReplaceShape(TShapeData).
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
SwapShapes(TfrxCustomLayer) | Represents method SwapShapes(TfrxCustomLayer). (Inherited from TfrxCustomLayer.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
TuneBrush(TBrush,Integer) | Represents method TuneBrush(TBrush,Integer). (Inherited from TfrxCustomLayer.)
TunePen(TPen,Integer) | Represents method TunePen(TPen,Integer). (Inherited from TfrxCustomLayer.)
TunePoint(TCanvas,Integer,Extended) | Represents method TunePoint(TCanvas,Integer,Extended). (Inherited from TfrxCustomLayer.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FActiveHyperlink | Represents field FActiveHyperlink. (Inherited from TfrxCustomLayer.)
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FClippingRect | Represents field FClippingRect. (Inherited from TfrxCustomLayer.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FConverter | Represents field FConverter. (Inherited from TfrxCustomLayer.)
FEditedShape | Represents field FEditedShape.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLabelColumn | Represents field FLabelColumn. (Inherited from TfrxCustomLayer.)
FMapAccuracy | Represents field FMapAccuracy. (Inherited from TfrxCustomLayer.)
FMapView | Represents field FMapView. (Inherited from TfrxCustomLayer.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPixelAccuracy | Represents field FPixelAccuracy. (Inherited from TfrxCustomLayer.)
FPreviousSelectedShapeIndex | Represents field FPreviousSelectedShapeIndex. (Inherited from TfrxCustomLayer.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShapes | Represents field FShapes. (Inherited from TfrxCustomLayer.)
FSpatialColumn | Represents field FSpatialColumn. (Inherited from TfrxCustomLayer.)
FValuesList | Represents field FValuesList. (Inherited from TfrxCustomLayer.)
FVectorGraphic | Represents field FVectorGraphic. (Inherited from TfrxCustomLayer.)
Top
See Also

Reference

  • frxMapInteractiveLayer


TfrxMapInteractiveLayer Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxMapInteractiveLayer class. (Overrides TfrxCustomLayer.Create(TComponent).)
Top


TfrxMapInteractiveLayer.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxMapInteractiveLayer class.

Namespace: frxMapInteractiveLayer
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomLayer.Create(TComponent)
See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


TfrxMapInteractiveLayer Properties

Properties
Name | Description
EditedShape | Represents property EditedShape.
LabelColumn | Represents property LabelColumn.
Top


TfrxMapInteractiveLayer.EditedShape Property

Summary

Represents property EditedShape.

Namespace: frxMapInteractiveLayer
Syntax
Delphi
public
 property EditedShape: TShape read FEditedShape;

Property Value

Type: TShape

See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


TfrxMapInteractiveLayer.LabelColumn Property

Summary

Represents property LabelColumn.

Namespace: frxMapInteractiveLayer
Syntax
Delphi
published
 property LabelColumn;

Property Value

Type: Void

See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


TfrxMapInteractiveLayer Methods

Methods
Name | Description
AddShape(TShapeData) | Represents method AddShape(TShapeData).
AddValueList(Variant) | Represents method AddValueList(Variant). (Overrides TfrxCustomLayer.AddValueList(Variant).)
CancelEditedShape(Boolean) | Represents method CancelEditedShape(Boolean).
IsEditing | Represents method IsEditing.
IsHiddenShape(Integer) | Represents method IsHiddenShape(Integer). (Overrides TfrxCustomLayer.IsHiddenShape(Integer).)
IsHighlightSelectedShape | Represents method IsHighlightSelectedShape. (Overrides TfrxCustomLayer.IsHighlightSelectedShape.)
IsSelectEditedShape(TfrxPoint,Extended) | Represents method IsSelectEditedShape(TfrxPoint,Extended).
RemoveEditedShape | Represents method RemoveEditedShape.
ReplaceShape(TShapeData) | Represents method ReplaceShape(TShapeData).
Top


TfrxMapInteractiveLayer.AddShape(TShapeData) Method

Summary

Represents method AddShape(TShapeData).

Namespace: frxMapInteractiveLayer
Syntax
Delphi
public
 procedure AddShape(const ShapeData: TShapeData);

Parameters

ShapeData
Type: TShapeData

See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


TfrxMapInteractiveLayer.AddValueList(Variant) Method

Summary

Represents method AddValueList(Variant).

Namespace: frxMapInteractiveLayer
Syntax
Delphi
protected
 procedure AddValueList(vaAnalyticalValue: Variant); override;

Parameters

vaAnalyticalValue
Type: Variant

Overrides

TfrxCustomLayer.AddValueList(Variant)
See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


TfrxMapInteractiveLayer.CancelEditedShape(Boolean) Method

Summary

Represents method CancelEditedShape(Boolean).

Namespace: frxMapInteractiveLayer
Syntax
Delphi
public
 procedure CancelEditedShape(NeedRebuild: Boolean = True);

Parameters

NeedRebuild
Type: Boolean

See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


TfrxMapInteractiveLayer.IsEditing Method

Summary

Represents method IsEditing.

Namespace: frxMapInteractiveLayer
Syntax
Delphi
public
 function IsEditing: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


TfrxMapInteractiveLayer.IsHiddenShape(Integer) Method

Summary

Represents method IsHiddenShape(Integer).

Namespace: frxMapInteractiveLayer
Syntax
Delphi
public
 function IsHiddenShape(iRecord: Integer): Boolean; override;

Parameters

iRecord
Type: Integer

Return Value

Type: Boolean

Overrides

TfrxCustomLayer.IsHiddenShape(Integer)
See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


TfrxMapInteractiveLayer.IsHighlightSelectedShape Method

Summary

Represents method IsHighlightSelectedShape.

Namespace: frxMapInteractiveLayer
Syntax
Delphi
public
 function IsHighlightSelectedShape: boolean; override;

Return Value

Type: boolean

Overrides

TfrxCustomLayer.IsHighlightSelectedShape
See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


TfrxMapInteractiveLayer.IsSelectEditedShape(TfrxPoint,Extended) Method

Summary

Represents method IsSelectEditedShape(TfrxPoint,Extended).

Namespace: frxMapInteractiveLayer
Syntax
Delphi
public
 function IsSelectEditedShape(P: TfrxPoint; Threshold: Extended): Boolean;

Parameters

P
Type: TfrxPoint

Threshold
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


TfrxMapInteractiveLayer.RemoveEditedShape Method

Summary

Represents method RemoveEditedShape.

Namespace: frxMapInteractiveLayer
Syntax
Delphi
public
 procedure RemoveEditedShape;
See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


TfrxMapInteractiveLayer.ReplaceShape(TShapeData) Method

Summary

Represents method ReplaceShape(TShapeData).

Namespace: frxMapInteractiveLayer
Syntax
Delphi
public
 procedure ReplaceShape(const ShapeData: TShapeData);

Parameters

ShapeData
Type: TShapeData

See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


TfrxMapInteractiveLayer Fields

Fields
Name | Description
FEditedShape | Represents field FEditedShape.
Top


TfrxMapInteractiveLayer.FEditedShape Field

Summary

Represents field FEditedShape.

Namespace: frxMapInteractiveLayer
Syntax
Delphi
private
 FEditedShape: TShape;

Field Value

Type: TShape

See Also

Reference

  • TfrxMapInteractiveLayer
  • frxMapInteractiveLayer


frxMapLayer Namespace

Summary

Represents namespace frxMapLayer.

Classes
Name | Description
TfrxApplicationLayer | Represents type TfrxApplicationLayer.
TfrxCustomLayer | Represents type TfrxCustomLayer.
TfrxLabelColumnProperty | Represents type TfrxLabelColumnProperty.
TfrxMapFileLayer | Represents type TfrxMapFileLayer.
TMapLayerList | Represents type TMapLayerList.
TOperationCalculator | Represents type TOperationCalculator.
TValuesList | Represents type TValuesList.
Top
Enumerations
Name | Description
TMapLabelKind | Represents type TMapLabelKind.
TMapOperation | Represents type TMapOperation.
TMapPalette | Represents type TMapPalette.
Top
Routines
Name | Description
GeoDataKindList(TStrings) | Represents method GeoDataKindList(TStrings).
MapLabelKindGetList(TStrings) | Represents method MapLabelKindGetList(TStrings).
OperationGetList(TStrings) | Represents method OperationGetList(TStrings).
PaletteGetList(TStrings) | Represents method PaletteGetList(TStrings).
PenStyleGetList(TStrings) | Represents method PenStyleGetList(TStrings).
Top


frxMapLayer Classes

Classes
Name | Description
TfrxApplicationLayer | Represents type TfrxApplicationLayer.
TfrxCustomLayer | Represents type TfrxCustomLayer.
TfrxLabelColumnProperty | Represents type TfrxLabelColumnProperty.
TfrxMapFileLayer | Represents type TfrxMapFileLayer.
TMapLayerList | Represents type TMapLayerList.
TOperationCalculator | Represents type TOperationCalculator.
TValuesList | Represents type TValuesList.
Top


TfrxApplicationLayer Class

Summary

Represents type TfrxApplicationLayer.

Namespace: frxMapLayer
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxMapLayer.TfrxCustomLayer
frxMapLayer.TfrxApplicationLayer
Syntax
Delphi
type
 TfrxApplicationLayer = class(TfrxCustomLayer)
 end;

The TfrxApplicationLayer type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxApplicationLayer class. (Overrides TfrxCustomLayer.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Active | Represents property Active. (Inherited from TfrxCustomLayer.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AnalyticalValue | Represents property AnalyticalValue. (Inherited from TfrxCustomLayer.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
ClippingRect | Represents property ClippingRect. (Inherited from TfrxCustomLayer.)
ColorRanges | Represents property ColorRanges. (Inherited from TfrxCustomLayer.)
ColorRangesData | Represents property ColorRangesData. (Inherited from TfrxCustomLayer.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
DataSet | Represents property DataSet. (Inherited from TfrxCustomLayer.)
DefaultShapeStyle | Represents property DefaultShapeStyle. (Inherited from TfrxCustomLayer.)
Description | Object's description. (Inherited from TfrxComponent.)
Filter | Represents property Filter. (Inherited from TfrxCustomLayer.)
Font | Represents property Font. (Inherited from TfrxCustomLayer.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
HighlightColor | Represents property HighlightColor. (Inherited from TfrxCustomLayer.)
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LabelColumn | Represents property LabelColumn. (Inherited from TfrxCustomLayer.)
LabelKind | Represents property LabelKind. (Inherited from TfrxCustomLayer.)
LabelValue | Represents property LabelValue.
LatitudeValue | Represents property LatitudeValue.
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
LongitudeValue | Represents property LongitudeValue.
MapAccuracy | Represents property MapAccuracy. (Inherited from TfrxCustomLayer.)
MapPalette | Represents property MapPalette. (Inherited from TfrxCustomLayer.)
MapView | Represents property MapView. (Inherited from TfrxCustomLayer.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
Operation | Represents property Operation. (Inherited from TfrxCustomLayer.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PixelAccuracy | Represents property PixelAccuracy. (Inherited from TfrxCustomLayer.)
PointLabelsVisibleAtZoom | Represents property PointLabelsVisibleAtZoom. (Inherited from TfrxCustomLayer.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
SelectedShape | Represents property SelectedShape. (Inherited from TfrxCustomLayer.)
SelectedShapeIndex | Represents property SelectedShapeIndex. (Inherited from TfrxCustomLayer.)
SelectedShapeName | Represents property SelectedShapeName. (Inherited from TfrxCustomLayer.)
SelectedShapeValue | Represents property SelectedShapeValue. (Inherited from TfrxCustomLayer.)
ShowLines | Represents property ShowLines. (Inherited from TfrxCustomLayer.)
ShowPoints | Represents property ShowPoints. (Inherited from TfrxCustomLayer.)
ShowPolygons | Represents property ShowPolygons. (Inherited from TfrxCustomLayer.)
SizeRanges | Represents property SizeRanges. (Inherited from TfrxCustomLayer.)
SizeRangesData | Represents property SizeRangesData. (Inherited from TfrxCustomLayer.)
SpatialColumn | Represents property SpatialColumn. (Inherited from TfrxCustomLayer.)
SpatialValue | Represents property SpatialValue. (Inherited from TfrxCustomLayer.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
ValueFormat | Represents property ValueFormat. (Inherited from TfrxCustomLayer.)
VectorGraphic | Represents property VectorGraphic. (Inherited from TfrxCustomLayer.)
Visible | Represents property Visible. (Inherited from TfrxCustomLayer.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AddValueList(Variant) | Represents method AddValueList(Variant). (Overrides TfrxCustomLayer.AddValueList(Variant).)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
ApplicationShapeData(Extended,Extended,String,String) | Represents method ApplicationShapeData(Extended,Extended,String,String).
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BuildGraphic(TfrxPoint,Boolean) | Represents method BuildGraphic(TfrxPoint,Boolean). (Inherited from TfrxCustomLayer.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ClearSelectedShape | Represents method ClearSelectedShape. (Inherited from TfrxCustomLayer.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CopyDatasets(TfrxCustomLayer) | Represents method CopyDatasets(TfrxCustomLayer). (Inherited from TfrxCustomLayer.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefinePrimeProperties(TFiler) | Represents method DefinePrimeProperties(TFiler). (Inherited from TfrxCustomLayer.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxCustomLayer.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas) | Represents method Draw(TCanvas). (Inherited from TfrxCustomLayer.)
DrawClippedPoint(TCanvas,Extended,Extended,Extended) | Represents method DrawClippedPoint(TCanvas,Extended,Extended,Extended). (Inherited from TfrxCustomLayer.)
DrawDiamond(TCanvas,Integer) | Represents method DrawDiamond(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawEllipse(TCanvas,Integer) | Represents method DrawEllipse(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawHighlightFrame(TCanvas,Integer) | Represents method DrawHighlightFrame(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawLegend(TCanvas,Integer) | Represents method DrawLegend(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawMultiPoint(TCanvas,Integer) | Represents method DrawMultiPoint(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawOn(TCanvas,Boolean,TfrxRect) | Represents method DrawOn(TCanvas,Boolean,TfrxRect). (Inherited from TfrxCustomLayer.)
DrawPicture(TCanvas,Integer) | Represents method DrawPicture(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPoint(TCanvas,Integer) | Represents method DrawPoint(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPointLegend(TCanvas,Integer) | Represents method DrawPointLegend(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPolygon(TCanvas,Integer) | Represents method DrawPolygon(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPolyLegend(TCanvas,Integer) | Represents method DrawPolyLegend(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPolyLine(TCanvas,Integer) | Represents method DrawPolyLine(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawRect(TCanvas,Integer) | Represents method DrawRect(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawTemplate(TCanvas,Integer) | Represents method DrawTemplate(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
ExpandVariables | Represents method ExpandVariables. (Overrides TfrxCustomLayer.ExpandVariables.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FillRanges(TDoubleArray) | Represents method FillRanges(TDoubleArray). (Inherited from TfrxCustomLayer.)
FinaliseData | Represents method FinaliseData. (Inherited from TfrxCustomLayer.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColumnList(TStrings) | Represents method GetColumnList(TStrings). (Inherited from TfrxCustomLayer.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | Represents method GetData. (Inherited from TfrxCustomLayer.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDesigningData | Represents method GetDesigningData. (Inherited from TfrxCustomLayer.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetMetaFile(TfrxPoint,Boolean) | Represents method GetMetaFile(TfrxPoint,Boolean). (Inherited from TfrxCustomLayer.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSelectedShapeName | Represents method GetSelectedShapeName. (Inherited from TfrxCustomLayer.)
GetSelectedShapeValue | Represents method GetSelectedShapeValue. (Inherited from TfrxCustomLayer.)
GetShapeLegeng(String,Integer) | Represents method GetShapeLegeng(String,Integer). (Inherited from TfrxCustomLayer.)
GetShapeName(String,Integer) | Represents method GetShapeName(String,Integer). (Inherited from TfrxCustomLayer.)
GetShapeValue(Integer) | Represents method GetShapeValue(Integer). (Inherited from TfrxCustomLayer.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitialiseData | Represents method InitialiseData. (Overrides TfrxCustomLayer.InitialiseData.)
InitTransform(Integer) | Represents method InitTransform(Integer). (Inherited from TfrxCustomLayer.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsCanGetData | Represents method IsCanGetData. (Overrides TfrxCustomLayer.IsCanGetData.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHasMapRect(TfrxRect) | Represents method IsHasMapRect(TfrxRect). (Inherited from TfrxCustomLayer.)
IsHasZoomRect(TfrxRect) | Represents method IsHasZoomRect(TfrxRect). (Inherited from TfrxCustomLayer.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsHiddenShape(Integer) | Represents method IsHiddenShape(Integer). (Inherited from TfrxCustomLayer.)
IsHighlightSelectedShape | Represents method IsHighlightSelectedShape. (Inherited from TfrxCustomLayer.)
IsInclude(TfrxPoint) | Represents method IsInclude(TfrxPoint). (Overrides TfrxCustomLayer.IsInclude(TfrxPoint).)
IsIncludeAsRegion(TfrxPoint) | Represents method IsIncludeAsRegion(TfrxPoint). (Inherited from TfrxCustomLayer.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsMercatorSuitable | Represents method IsMercatorSuitable. (Inherited from TfrxCustomLayer.)
IsSelectedShapeChanded | Represents method IsSelectedShapeChanded. (Inherited from TfrxCustomLayer.)
IsSpecialBorderColor(Integer,TColor) | Represents method IsSpecialBorderColor(Integer,TColor). (Inherited from TfrxCustomLayer.)
IsSpecialFillColor(Integer,TColor) | Represents method IsSpecialFillColor(Integer,TColor). (Inherited from TfrxCustomLayer.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
SwapShapes(TfrxCustomLayer) | Represents method SwapShapes(TfrxCustomLayer). (Inherited from TfrxCustomLayer.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
TuneBrush(TBrush,Integer) | Represents method TuneBrush(TBrush,Integer). (Inherited from TfrxCustomLayer.)
TunePen(TPen,Integer) | Represents method TunePen(TPen,Integer). (Inherited from TfrxCustomLayer.)
TunePoint(TCanvas,Integer,Extended) | Represents method TunePoint(TCanvas,Integer,Extended). (Inherited from TfrxCustomLayer.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FActiveHyperlink | Represents field FActiveHyperlink. (Inherited from TfrxCustomLayer.)
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FClippingRect | Represents field FClippingRect. (Inherited from TfrxCustomLayer.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FConverter | Represents field FConverter. (Inherited from TfrxCustomLayer.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLabelColumn | Represents field FLabelColumn. (Inherited from TfrxCustomLayer.)
FLabelValue | Represents field FLabelValue.
FLatitudeValue | Represents field FLatitudeValue.
FLongitudeValue | Represents field FLongitudeValue.
FMapAccuracy | Represents field FMapAccuracy. (Inherited from TfrxCustomLayer.)
FMapView | Represents field FMapView. (Inherited from TfrxCustomLayer.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPixelAccuracy | Represents field FPixelAccuracy. (Inherited from TfrxCustomLayer.)
FPreviousSelectedShapeIndex | Represents field FPreviousSelectedShapeIndex. (Inherited from TfrxCustomLayer.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShapes | Represents field FShapes. (Inherited from TfrxCustomLayer.)
FSpatialColumn | Represents field FSpatialColumn. (Inherited from TfrxCustomLayer.)
FValuesList | Represents field FValuesList. (Inherited from TfrxCustomLayer.)
FVectorGraphic | Represents field FVectorGraphic. (Inherited from TfrxCustomLayer.)
Top
See Also

Reference

  • frxMapLayer


TfrxApplicationLayer Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxApplicationLayer class. (Overrides TfrxCustomLayer.Create(TComponent).)
Top


TfrxApplicationLayer.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxApplicationLayer class.

Namespace: frxMapLayer
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomLayer.Create(TComponent)
See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxApplicationLayer Properties

Properties
Name | Description
LabelValue | Represents property LabelValue.
LatitudeValue | Represents property LatitudeValue.
LongitudeValue | Represents property LongitudeValue.
Top


TfrxApplicationLayer.LabelValue Property

Summary

Represents property LabelValue.

Namespace: frxMapLayer
Syntax
Delphi
published
 property LabelValue: String read FLabelValue write FLabelValue;

Property Value

Type: String

See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxApplicationLayer.LatitudeValue Property

Summary

Represents property LatitudeValue.

Namespace: frxMapLayer
Syntax
Delphi
published
 property LatitudeValue: String read FLatitudeValue write FLatitudeValue;

Property Value

Type: String

See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxApplicationLayer.LongitudeValue Property

Summary

Represents property LongitudeValue.

Namespace: frxMapLayer
Syntax
Delphi
published
 property LongitudeValue: String read FLongitudeValue write FLongitudeValue;

Property Value

Type: String

See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxApplicationLayer Methods

Methods
Name | Description
AddValueList(Variant) | Represents method AddValueList(Variant). (Overrides TfrxCustomLayer.AddValueList(Variant).)
ApplicationShapeData(Extended,Extended,String,String) | Represents method ApplicationShapeData(Extended,Extended,String,String).
ExpandVariables | Represents method ExpandVariables. (Overrides TfrxCustomLayer.ExpandVariables.)
InitialiseData | Represents method InitialiseData. (Overrides TfrxCustomLayer.InitialiseData.)
IsCanGetData | Represents method IsCanGetData. (Overrides TfrxCustomLayer.IsCanGetData.)
IsInclude(TfrxPoint) | Represents method IsInclude(TfrxPoint). (Overrides TfrxCustomLayer.IsInclude(TfrxPoint).)
Top


TfrxApplicationLayer.AddValueList(Variant) Method

Summary

Represents method AddValueList(Variant).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure AddValueList(vaAnalyticalValue: Variant); override;

Parameters

vaAnalyticalValue
Type: Variant

Overrides

TfrxCustomLayer.AddValueList(Variant)
See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxApplicationLayer.ApplicationShapeData(Extended,Extended,String,String) Method

Summary

Represents method ApplicationShapeData(Extended,Extended,String,String).

Namespace: frxMapLayer
Syntax
Delphi
protected
 function ApplicationShapeData(X, Y: Extended; Name, Location: String): TShapeData;

Parameters

X
Type: Extended

Y
Type: Extended

Name
Type: String

Location
Type: String

Return Value

Type: TShapeData

See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxApplicationLayer.ExpandVariables Method

Summary

Represents method ExpandVariables.

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure ExpandVariables; override;

Overrides

TfrxCustomLayer.ExpandVariables
See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxApplicationLayer.InitialiseData Method

Summary

Represents method InitialiseData.

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure InitialiseData; override;

Overrides

TfrxCustomLayer.InitialiseData
See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxApplicationLayer.IsCanGetData Method

Summary

Represents method IsCanGetData.

Namespace: frxMapLayer
Syntax
Delphi
protected
 function IsCanGetData: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCustomLayer.IsCanGetData
See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxApplicationLayer.IsInclude(TfrxPoint) Method

Summary

Represents method IsInclude(TfrxPoint).

Namespace: frxMapLayer
Syntax
Delphi
public
 function IsInclude(P: TfrxPoint): Boolean; override;

Parameters

P
Type: TfrxPoint

Return Value

Type: Boolean

Overrides

TfrxCustomLayer.IsInclude(TfrxPoint)
See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxApplicationLayer Fields

Fields
Name | Description
FLabelValue | Represents field FLabelValue.
FLatitudeValue | Represents field FLatitudeValue.
FLongitudeValue | Represents field FLongitudeValue.
Top


TfrxApplicationLayer.FLabelValue Field

Summary

Represents field FLabelValue.

Namespace: frxMapLayer
Syntax
Delphi
private
 FLabelValue: String;

Field Value

Type: String

See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxApplicationLayer.FLatitudeValue Field

Summary

Represents field FLatitudeValue.

Namespace: frxMapLayer
Syntax
Delphi
private
 FLatitudeValue: String;

Field Value

Type: String

See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxApplicationLayer.FLongitudeValue Field

Summary

Represents field FLongitudeValue.

Namespace: frxMapLayer
Syntax
Delphi
private
 FLongitudeValue: String;

Field Value

Type: String

See Also

Reference

  • TfrxApplicationLayer
  • frxMapLayer


TfrxCustomLayer Class

Summary

Represents type TfrxCustomLayer.

Namespace: frxMapLayer
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxMapLayer.TfrxCustomLayer
frxMapGeodataLayer.TfrxMapGeodataLayer
frxMapInteractiveLayer.TfrxMapInteractiveLayer
frxMapLayer.TfrxApplicationLayer
frxMapLayer.TfrxMapFileLayer
Syntax
Delphi
type
 TfrxCustomLayer = class(TfrxComponent)
 end;

The TfrxCustomLayer type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomLayer class. (Overrides TfrxComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxCustomLayer class. (Overrides TfrxComponent.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Active | Represents property Active.
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AnalyticalValue | Represents property AnalyticalValue.
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
ClippingRect | Represents property ClippingRect.
ColorRanges | Represents property ColorRanges.
ColorRangesData | Represents property ColorRangesData.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
DataSet | Represents property DataSet.
DefaultShapeStyle | Represents property DefaultShapeStyle.
Description | Object's description. (Inherited from TfrxComponent.)
Filter | Represents property Filter.
Font | Represents property Font.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
HighlightColor | Represents property HighlightColor.
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LabelColumn | Represents property LabelColumn.
LabelKind | Represents property LabelKind.
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
MapAccuracy | Represents property MapAccuracy.
MapPalette | Represents property MapPalette.
MapView | Represents property MapView.
Objects | The list of child objects. (Inherited from TfrxComponent.)
Operation | Represents property Operation.
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PixelAccuracy | Represents property PixelAccuracy.
PointLabelsVisibleAtZoom | Represents property PointLabelsVisibleAtZoom.
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
SelectedShape | Represents property SelectedShape.
SelectedShapeIndex | Represents property SelectedShapeIndex.
SelectedShapeName | Represents property SelectedShapeName.
SelectedShapeValue | Represents property SelectedShapeValue.
ShowLines | Represents property ShowLines.
ShowPoints | Represents property ShowPoints.
ShowPolygons | Represents property ShowPolygons.
SizeRanges | Represents property SizeRanges.
SizeRangesData | Represents property SizeRangesData.
SpatialColumn | Represents property SpatialColumn.
SpatialValue | Represents property SpatialValue.
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
ValueFormat | Represents property ValueFormat.
VectorGraphic | Represents property VectorGraphic.
Visible | Represents property Visible.
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AddValueList(Variant) | Represents method AddValueList(Variant).
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BuildGraphic(TfrxPoint,Boolean) | Represents method BuildGraphic(TfrxPoint,Boolean).
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ClearSelectedShape | Represents method ClearSelectedShape.
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CopyDatasets(TfrxCustomLayer) | Represents method CopyDatasets(TfrxCustomLayer).
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefinePrimeProperties(TFiler) | Represents method DefinePrimeProperties(TFiler).
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas) | Represents method Draw(TCanvas).
DrawClippedPoint(TCanvas,Extended,Extended,Extended) | Represents method DrawClippedPoint(TCanvas,Extended,Extended,Extended).
DrawDiamond(TCanvas,Integer) | Represents method DrawDiamond(TCanvas,Integer).
DrawEllipse(TCanvas,Integer) | Represents method DrawEllipse(TCanvas,Integer).
DrawHighlightFrame(TCanvas,Integer) | Represents method DrawHighlightFrame(TCanvas,Integer).
DrawLegend(TCanvas,Integer) | Represents method DrawLegend(TCanvas,Integer).
DrawMultiPoint(TCanvas,Integer) | Represents method DrawMultiPoint(TCanvas,Integer).
DrawOn(TCanvas,Boolean,TfrxRect) | Represents method DrawOn(TCanvas,Boolean,TfrxRect).
DrawPicture(TCanvas,Integer) | Represents method DrawPicture(TCanvas,Integer).
DrawPoint(TCanvas,Integer) | Represents method DrawPoint(TCanvas,Integer).
DrawPointLegend(TCanvas,Integer) | Represents method DrawPointLegend(TCanvas,Integer).
DrawPolygon(TCanvas,Integer) | Represents method DrawPolygon(TCanvas,Integer).
DrawPolyLegend(TCanvas,Integer) | Represents method DrawPolyLegend(TCanvas,Integer).
DrawPolyLine(TCanvas,Integer) | Represents method DrawPolyLine(TCanvas,Integer).
DrawRect(TCanvas,Integer) | Represents method DrawRect(TCanvas,Integer).
DrawTemplate(TCanvas,Integer) | Represents method DrawTemplate(TCanvas,Integer).
ExpandVariables | Represents method ExpandVariables.
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FillRanges(TDoubleArray) | Represents method FillRanges(TDoubleArray).
FinaliseData | Represents method FinaliseData.
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColorRangeData | Represents method GetColorRangeData.
GetColumnList(TStrings) | Represents method GetColumnList(TStrings).
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | Represents method GetData.
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDesigningData | Represents method GetDesigningData.
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetMetaFile(TfrxPoint,Boolean) | Represents method GetMetaFile(TfrxPoint,Boolean).
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSelectedShape | Represents method GetSelectedShape.
GetSelectedShapeName | Represents method GetSelectedShapeName.
GetSelectedShapeValue | Represents method GetSelectedShapeValue.
GetShapeLegeng(String,Integer) | Represents method GetShapeLegeng(String,Integer).
GetShapeName(String,Integer) | Represents method GetShapeName(String,Integer).
GetShapeValue(Integer) | Represents method GetShapeValue(Integer).
GetSizeRangeData | Represents method GetSizeRangeData.
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitialiseData | Represents method InitialiseData.
InitTransform(Integer) | Represents method InitTransform(Integer).
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsCanGetData | Represents method IsCanGetData.
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHasMapRect(TfrxRect) | Represents method IsHasMapRect(TfrxRect).
IsHasZoomRect(TfrxRect) | Represents method IsHasZoomRect(TfrxRect).
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsHiddenShape(Integer) | Represents method IsHiddenShape(Integer).
IsHighlightSelectedShape | Represents method IsHighlightSelectedShape.
IsInclude(TfrxPoint) | Represents method IsInclude(TfrxPoint).
IsIncludeAsRegion(TfrxPoint) | Represents method IsIncludeAsRegion(TfrxPoint).
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsMercatorSuitable | Represents method IsMercatorSuitable.
IsSelectedShapeChanded | Represents method IsSelectedShapeChanded.
IsSpecialBorderColor(Integer,TColor) | Represents method IsSpecialBorderColor(Integer,TColor).
IsSpecialFillColor(Integer,TColor) | Represents method IsSpecialFillColor(Integer,TColor).
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
SwapShapes(TfrxCustomLayer) | Represents method SwapShapes(TfrxCustomLayer).
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
TuneBrush(TBrush,Integer) | Represents method TuneBrush(TBrush,Integer).
TunePen(TPen,Integer) | Represents method TunePen(TPen,Integer).
TunePoint(TCanvas,Integer,Extended) | Represents method TunePoint(TCanvas,Integer,Extended).
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FActive | Represents field FActive.
FActiveHyperlink | Represents field FActiveHyperlink.
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAnalyticalValue | Represents field FAnalyticalValue.
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FClippingRect | Represents field FClippingRect.
FColorRanges | Represents field FColorRanges.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FConverter | Represents field FConverter.
FDataSet | Represents field FDataSet.
FDefaultShapeStyle | Represents field FDefaultShapeStyle.
FFilter | Represents field FFilter.
FHighlightColor | Represents field FHighlightColor.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLabelColumn | Represents field FLabelColumn.
FLabelKind | Represents field FLabelKind.
FMapAccuracy | Represents field FMapAccuracy.
FMapPalette | Represents field FMapPalette.
FMapView | Represents field FMapView.
FOperation | Represents field FOperation.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPixelAccuracy | Represents field FPixelAccuracy.
FPointLabelsVisibleAtZoom | Represents field FPointLabelsVisibleAtZoom.
FPreviousSelectedShapeIndex | Represents field FPreviousSelectedShapeIndex.
FSelectedShapeIndex | Represents field FSelectedShapeIndex.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShapes | Represents field FShapes.
FShowLines | Represents field FShowLines.
FShowPoints | Represents field FShowPoints.
FShowPolygons | Represents field FShowPolygons.
FSizeRanges | Represents field FSizeRanges.
FSpatialColumn | Represents field FSpatialColumn.
FSpatialValue | Represents field FSpatialValue.
FValueFormat | Represents field FValueFormat.
FValuesList | Represents field FValuesList.
FVectorGraphic | Represents field FVectorGraphic.
Top
See Also

Reference

  • frxMapLayer


TfrxCustomLayer Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomLayer class. (Overrides TfrxComponent.Create(TComponent).)
Destroy | Represents the destructor of the TfrxCustomLayer class. (Overrides TfrxComponent.Destroy.)
Top


TfrxCustomLayer.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomLayer class.

Namespace: frxMapLayer
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxComponent.Create(TComponent)
See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomLayer class.

Namespace: frxMapLayer
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxComponent.Destroy
See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer Properties

Properties
Name | Description
Active | Represents property Active.
AnalyticalValue | Represents property AnalyticalValue.
ClippingRect | Represents property ClippingRect.
ColorRanges | Represents property ColorRanges.
ColorRangesData | Represents property ColorRangesData.
DataSet | Represents property DataSet.
DefaultShapeStyle | Represents property DefaultShapeStyle.
Filter | Represents property Filter.
Font | Represents property Font.
HighlightColor | Represents property HighlightColor.
LabelColumn | Represents property LabelColumn.
LabelKind | Represents property LabelKind.
MapAccuracy | Represents property MapAccuracy.
MapPalette | Represents property MapPalette.
MapView | Represents property MapView.
Operation | Represents property Operation.
PixelAccuracy | Represents property PixelAccuracy.
PointLabelsVisibleAtZoom | Represents property PointLabelsVisibleAtZoom.
SelectedShape | Represents property SelectedShape.
SelectedShapeIndex | Represents property SelectedShapeIndex.
SelectedShapeName | Represents property SelectedShapeName.
SelectedShapeValue | Represents property SelectedShapeValue.
ShowLines | Represents property ShowLines.
ShowPoints | Represents property ShowPoints.
ShowPolygons | Represents property ShowPolygons.
SizeRanges | Represents property SizeRanges.
SizeRangesData | Represents property SizeRangesData.
SpatialColumn | Represents property SpatialColumn.
SpatialValue | Represents property SpatialValue.
ValueFormat | Represents property ValueFormat.
VectorGraphic | Represents property VectorGraphic.
Visible | Represents property Visible.
Top


TfrxCustomLayer.Active Property

Summary

Represents property Active.

Namespace: frxMapLayer
Syntax
Delphi
published
 property Active: Boolean read FActive write FActive;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.AnalyticalValue Property

Summary

Represents property AnalyticalValue.

Namespace: frxMapLayer
Syntax
Delphi
published
 property AnalyticalValue: String read FAnalyticalValue write FAnalyticalValue;

Property Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.ClippingRect Property

Summary

Represents property ClippingRect.

Namespace: frxMapLayer
Syntax
Delphi
public
 property ClippingRect: TfrxClippingRect read FClippingRect;

Property Value

Type: TfrxClippingRect

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.ColorRanges Property

Summary

Represents property ColorRanges.

Namespace: frxMapLayer
Syntax
Delphi
published
 property ColorRanges: TfrxColorRanges read FColorRanges;

Property Value

Type: TfrxColorRanges

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.ColorRangesData Property

Summary

Represents property ColorRangesData.

Namespace: frxMapLayer
Syntax
Delphi
published
 property ColorRangesData: TColorRangeCollection read GetColorRangeData;

Property Value

Type: TColorRangeCollection

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DataSet Property

Summary

Represents property DataSet.

Namespace: frxMapLayer
Syntax
Delphi
published
 property DataSet: TfrxDataSet read FDataSet write FDataSet;

Property Value

Type: TfrxDataSet

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DefaultShapeStyle Property

Summary

Represents property DefaultShapeStyle.

Namespace: frxMapLayer
Syntax
Delphi
published
 property DefaultShapeStyle: TShapeStyle read FDefaultShapeStyle;

Property Value

Type: TShapeStyle

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.Filter Property

Summary

Represents property Filter.

Namespace: frxMapLayer
Syntax
Delphi
published
 property Filter: String read FFilter write FFilter;

Property Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.Font Property

Summary

Represents property Font.

Namespace: frxMapLayer
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.HighlightColor Property

Summary

Represents property HighlightColor.

Namespace: frxMapLayer
Syntax
Delphi
published
 property HighlightColor: TColor read FHighlightColor write FHighlightColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.LabelColumn Property

Summary

Represents property LabelColumn.

Namespace: frxMapLayer
Syntax
Delphi
public
 property LabelColumn: String read FLabelColumn write FLabelColumn;

Property Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.LabelKind Property

Summary

Represents property LabelKind.

Namespace: frxMapLayer
Syntax
Delphi
published
 property LabelKind: TMapLabelKind read FLabelKind write FLabelKind;

Property Value

Type: TMapLabelKind

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.MapAccuracy Property

Summary

Represents property MapAccuracy.

Namespace: frxMapLayer
Syntax
Delphi
protected
 property MapAccuracy: Extended read FMapAccuracy write FMapAccuracy;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.MapPalette Property

Summary

Represents property MapPalette.

Namespace: frxMapLayer
Syntax
Delphi
published
 property MapPalette: TMapPalette read FMapPalette write FMapPalette;

Property Value

Type: TMapPalette

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.MapView Property

Summary

Represents property MapView.

Namespace: frxMapLayer
Syntax
Delphi
public
 property MapView: TComponent read FMapView;

Property Value

Type: TComponent

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.Operation Property

Summary

Represents property Operation.

Namespace: frxMapLayer
Syntax
Delphi
published
 property Operation: TMapOperation read FOperation write FOperation;

Property Value

Type: TMapOperation

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.PixelAccuracy Property

Summary

Represents property PixelAccuracy.

Namespace: frxMapLayer
Syntax
Delphi
protected
 property PixelAccuracy: Extended read FPixelAccuracy write FPixelAccuracy;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.PointLabelsVisibleAtZoom Property

Summary

Represents property PointLabelsVisibleAtZoom.

Namespace: frxMapLayer
Syntax
Delphi
published
 property PointLabelsVisibleAtZoom: Extended read FPointLabelsVisibleAtZoom write FPointLabelsVisibleAtZoom;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.SelectedShape Property

Summary

Represents property SelectedShape.

Namespace: frxMapLayer
Syntax
Delphi
public
 property SelectedShape: TShape read GetSelectedShape;

Property Value

Type: TShape

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.SelectedShapeIndex Property

Summary

Represents property SelectedShapeIndex.

Namespace: frxMapLayer
Syntax
Delphi
protected
 property SelectedShapeIndex: Integer read FSelectedShapeIndex write FSelectedShapeIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.SelectedShapeName Property

Summary

Represents property SelectedShapeName.

Namespace: frxMapLayer
Syntax
Delphi
public
 property SelectedShapeName: String read GetSelectedShapeName;

Property Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.SelectedShapeValue Property

Summary

Represents property SelectedShapeValue.

Namespace: frxMapLayer
Syntax
Delphi
public
 property SelectedShapeValue: String read GetSelectedShapeValue;

Property Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.ShowLines Property

Summary

Represents property ShowLines.

Namespace: frxMapLayer
Syntax
Delphi
public
 property ShowLines: Boolean read FShowLines write FShowLines default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.ShowPoints Property

Summary

Represents property ShowPoints.

Namespace: frxMapLayer
Syntax
Delphi
public
 property ShowPoints: Boolean read FShowPoints write FShowPoints default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.ShowPolygons Property

Summary

Represents property ShowPolygons.

Namespace: frxMapLayer
Syntax
Delphi
public
 property ShowPolygons: Boolean read FShowPolygons write FShowPolygons default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.SizeRanges Property

Summary

Represents property SizeRanges.

Namespace: frxMapLayer
Syntax
Delphi
published
 property SizeRanges: TfrxSizeRanges read FSizeRanges;

Property Value

Type: TfrxSizeRanges

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.SizeRangesData Property

Summary

Represents property SizeRangesData.

Namespace: frxMapLayer
Syntax
Delphi
published
 property SizeRangesData: TSizeRangeCollection read GetSizeRangeData;

Property Value

Type: TSizeRangeCollection

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.SpatialColumn Property

Summary

Represents property SpatialColumn.

Namespace: frxMapLayer
Syntax
Delphi
public
 property SpatialColumn: String read FSpatialColumn write FSpatialColumn;

Property Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.SpatialValue Property

Summary

Represents property SpatialValue.

Namespace: frxMapLayer
Syntax
Delphi
public
 property SpatialValue: String read FSpatialValue write FSpatialValue;

Property Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.ValueFormat Property

Summary

Represents property ValueFormat.

Namespace: frxMapLayer
Syntax
Delphi
published
 property ValueFormat: String read FValueFormat write FValueFormat;

Property Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.VectorGraphic Property

Summary

Represents property VectorGraphic.

Namespace: frxMapLayer
Syntax
Delphi
public
 property VectorGraphic: TGraphic read FVectorGraphic;

Property Value

Type: TGraphic

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.Visible Property

Summary

Represents property Visible.

Namespace: frxMapLayer
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer Methods

Methods
Name | Description
AddValueList(Variant) | Represents method AddValueList(Variant).
BuildGraphic(TfrxPoint,Boolean) | Represents method BuildGraphic(TfrxPoint,Boolean).
ClearSelectedShape | Represents method ClearSelectedShape.
CopyDatasets(TfrxCustomLayer) | Represents method CopyDatasets(TfrxCustomLayer).
DefinePrimeProperties(TFiler) | Represents method DefinePrimeProperties(TFiler).
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Draw(TCanvas) | Represents method Draw(TCanvas).
DrawClippedPoint(TCanvas,Extended,Extended,Extended) | Represents method DrawClippedPoint(TCanvas,Extended,Extended,Extended).
DrawDiamond(TCanvas,Integer) | Represents method DrawDiamond(TCanvas,Integer).
DrawEllipse(TCanvas,Integer) | Represents method DrawEllipse(TCanvas,Integer).
DrawHighlightFrame(TCanvas,Integer) | Represents method DrawHighlightFrame(TCanvas,Integer).
DrawLegend(TCanvas,Integer) | Represents method DrawLegend(TCanvas,Integer).
DrawMultiPoint(TCanvas,Integer) | Represents method DrawMultiPoint(TCanvas,Integer).
DrawOn(TCanvas,Boolean,TfrxRect) | Represents method DrawOn(TCanvas,Boolean,TfrxRect).
DrawPicture(TCanvas,Integer) | Represents method DrawPicture(TCanvas,Integer).
DrawPoint(TCanvas,Integer) | Represents method DrawPoint(TCanvas,Integer).
DrawPointLegend(TCanvas,Integer) | Represents method DrawPointLegend(TCanvas,Integer).
DrawPolygon(TCanvas,Integer) | Represents method DrawPolygon(TCanvas,Integer).
DrawPolyLegend(TCanvas,Integer) | Represents method DrawPolyLegend(TCanvas,Integer).
DrawPolyLine(TCanvas,Integer) | Represents method DrawPolyLine(TCanvas,Integer).
DrawRect(TCanvas,Integer) | Represents method DrawRect(TCanvas,Integer).
DrawTemplate(TCanvas,Integer) | Represents method DrawTemplate(TCanvas,Integer).
ExpandVariables | Represents method ExpandVariables.
FillRanges(TDoubleArray) | Represents method FillRanges(TDoubleArray).
FinaliseData | Represents method FinaliseData.
GetColorRangeData | Represents method GetColorRangeData.
GetColumnList(TStrings) | Represents method GetColumnList(TStrings).
GetData | Represents method GetData.
GetDesigningData | Represents method GetDesigningData.
GetMetaFile(TfrxPoint,Boolean) | Represents method GetMetaFile(TfrxPoint,Boolean).
GetSelectedShape | Represents method GetSelectedShape.
GetSelectedShapeName | Represents method GetSelectedShapeName.
GetSelectedShapeValue | Represents method GetSelectedShapeValue.
GetShapeLegeng(String,Integer) | Represents method GetShapeLegeng(String,Integer).
GetShapeName(String,Integer) | Represents method GetShapeName(String,Integer).
GetShapeValue(Integer) | Represents method GetShapeValue(Integer).
GetSizeRangeData | Represents method GetSizeRangeData.
InitialiseData | Represents method InitialiseData.
InitTransform(Integer) | Represents method InitTransform(Integer).
IsCanGetData | Represents method IsCanGetData.
IsHasMapRect(TfrxRect) | Represents method IsHasMapRect(TfrxRect).
IsHasZoomRect(TfrxRect) | Represents method IsHasZoomRect(TfrxRect).
IsHiddenShape(Integer) | Represents method IsHiddenShape(Integer).
IsHighlightSelectedShape | Represents method IsHighlightSelectedShape.
IsInclude(TfrxPoint) | Represents method IsInclude(TfrxPoint).
IsIncludeAsRegion(TfrxPoint) | Represents method IsIncludeAsRegion(TfrxPoint).
IsMercatorSuitable | Represents method IsMercatorSuitable.
IsSelectedShapeChanded | Represents method IsSelectedShapeChanded.
IsSpecialBorderColor(Integer,TColor) | Represents method IsSpecialBorderColor(Integer,TColor).
IsSpecialFillColor(Integer,TColor) | Represents method IsSpecialFillColor(Integer,TColor).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SwapShapes(TfrxCustomLayer) | Represents method SwapShapes(TfrxCustomLayer).
TuneBrush(TBrush,Integer) | Represents method TuneBrush(TBrush,Integer).
TunePen(TPen,Integer) | Represents method TunePen(TPen,Integer).
TunePoint(TCanvas,Integer,Extended) | Represents method TunePoint(TCanvas,Integer,Extended).
Top


TfrxCustomLayer.AddValueList(Variant) Method

Summary

Represents method AddValueList(Variant).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure AddValueList(vaAnalyticalValue: Variant); virtual; abstract;

Parameters

vaAnalyticalValue
Type: Variant

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.BuildGraphic(TfrxPoint,Boolean) Method

Summary

Represents method BuildGraphic(TfrxPoint,Boolean).

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure BuildGraphic(CanvasSize: TfrxPoint; ActiveHyperlink: Boolean);

Parameters

CanvasSize
Type: TfrxPoint

ActiveHyperlink
Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.ClearSelectedShape Method

Summary

Represents method ClearSelectedShape.

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure ClearSelectedShape;
See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.CopyDatasets(TfrxCustomLayer) Method

Summary

Represents method CopyDatasets(TfrxCustomLayer).

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure CopyDatasets(CustomLayer: TfrxCustomLayer); virtual;

Parameters

CustomLayer
Type: TfrxCustomLayer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DefinePrimeProperties(TFiler) Method

Summary

Represents method DefinePrimeProperties(TFiler).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DefinePrimeProperties(Filer: TFiler); virtual;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.Draw(TCanvas) Method

Summary

Represents method Draw(TCanvas).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure Draw(Canvas: TCanvas);

Parameters

Canvas
Type: TCanvas

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawClippedPoint(TCanvas,Extended,Extended,Extended) Method

Summary

Represents method DrawClippedPoint(TCanvas,Extended,Extended,Extended).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawClippedPoint(Canvas: TCanvas; X, Y, Radius: Extended);

Parameters

Canvas
Type: TCanvas

X
Type: Extended

Y
Type: Extended

Radius
Type: Extended

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawDiamond(TCanvas,Integer) Method

Summary

Represents method DrawDiamond(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawDiamond(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawEllipse(TCanvas,Integer) Method

Summary

Represents method DrawEllipse(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawEllipse(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawHighlightFrame(TCanvas,Integer) Method

Summary

Represents method DrawHighlightFrame(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawHighlightFrame(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawLegend(TCanvas,Integer) Method

Summary

Represents method DrawLegend(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawLegend(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawMultiPoint(TCanvas,Integer) Method

Summary

Represents method DrawMultiPoint(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawMultiPoint(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawOn(TCanvas,Boolean,TfrxRect) Method

Summary

Represents method DrawOn(TCanvas,Boolean,TfrxRect).

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure DrawOn(Canvas: TCanvas; ActiveHyperlink: Boolean; aClipRect: TfrxRect);

Parameters

Canvas
Type: TCanvas

ActiveHyperlink
Type: Boolean

aClipRect
Type: TfrxRect

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawPicture(TCanvas,Integer) Method

Summary

Represents method DrawPicture(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawPicture(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawPoint(TCanvas,Integer) Method

Summary

Represents method DrawPoint(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawPoint(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawPointLegend(TCanvas,Integer) Method

Summary

Represents method DrawPointLegend(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawPointLegend(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawPolygon(TCanvas,Integer) Method

Summary

Represents method DrawPolygon(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawPolygon(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawPolyLegend(TCanvas,Integer) Method

Summary

Represents method DrawPolyLegend(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawPolyLegend(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawPolyLine(TCanvas,Integer) Method

Summary

Represents method DrawPolyLine(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawPolyLine(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawRect(TCanvas,Integer) Method

Summary

Represents method DrawRect(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawRect(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.DrawTemplate(TCanvas,Integer) Method

Summary

Represents method DrawTemplate(TCanvas,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure DrawTemplate(Canvas: TCanvas; iRecord: Integer);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.ExpandVariables Method

Summary

Represents method ExpandVariables.

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure ExpandVariables; virtual;
See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FillRanges(TDoubleArray) Method

Summary

Represents method FillRanges(TDoubleArray).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure FillRanges(const Values: TDoubleArray);

Parameters

Values
Type: TDoubleArray

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FinaliseData Method

Summary

Represents method FinaliseData.

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure FinaliseData;
See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.GetColorRangeData Method

Summary

Represents method GetColorRangeData.

Namespace: frxMapLayer
Syntax
Delphi
private
 function GetColorRangeData: TColorRangeCollection;

Return Value

Type: TColorRangeCollection

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.GetColumnList(TStrings) Method

Summary

Represents method GetColumnList(TStrings).

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure GetColumnList(List: TStrings); virtual;

Parameters

List
Type: TStrings

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.GetData Method

Summary

Represents method GetData.

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure GetData;
See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.GetDesigningData Method

Summary

Represents method GetDesigningData.

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure GetDesigningData;
See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.GetMetaFile(TfrxPoint,Boolean) Method

Summary

Represents method GetMetaFile(TfrxPoint,Boolean).

Namespace: frxMapLayer
Syntax
Delphi
protected
 function GetMetaFile(CanvasSize: TfrxPoint; ActiveHyperlink: Boolean): TMetaFile;

Parameters

CanvasSize
Type: TfrxPoint

ActiveHyperlink
Type: Boolean

Return Value

Type: TMetaFile

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.GetSelectedShape Method

Summary

Represents method GetSelectedShape.

Namespace: frxMapLayer
Syntax
Delphi
private
 function GetSelectedShape: TShape;

Return Value

Type: TShape

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.GetSelectedShapeName Method

Summary

Represents method GetSelectedShapeName.

Namespace: frxMapLayer
Syntax
Delphi
protected
 function GetSelectedShapeName: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.GetSelectedShapeValue Method

Summary

Represents method GetSelectedShapeValue.

Namespace: frxMapLayer
Syntax
Delphi
protected
 function GetSelectedShapeValue: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.GetShapeLegeng(String,Integer) Method

Summary

Represents method GetShapeLegeng(String,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 function GetShapeLegeng(FieldName: String; iRecord: Integer): String;

Parameters

FieldName
Type: String

iRecord
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.GetShapeName(String,Integer) Method

Summary

Represents method GetShapeName(String,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 function GetShapeName(FieldName: String; iRecord: Integer): String;

Parameters

FieldName
Type: String

iRecord
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.GetShapeValue(Integer) Method

Summary

Represents method GetShapeValue(Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 function GetShapeValue(iRecord: Integer): String;

Parameters

iRecord
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.GetSizeRangeData Method

Summary

Represents method GetSizeRangeData.

Namespace: frxMapLayer
Syntax
Delphi
private
 function GetSizeRangeData: TSizeRangeCollection;

Return Value

Type: TSizeRangeCollection

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.InitialiseData Method

Summary

Represents method InitialiseData.

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure InitialiseData; virtual;
See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.InitTransform(Integer) Method

Summary

Represents method InitTransform(Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure InitTransform(iRecord: Integer); virtual;

Parameters

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.IsCanGetData Method

Summary

Represents method IsCanGetData.

Namespace: frxMapLayer
Syntax
Delphi
protected
 function IsCanGetData: Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.IsHasMapRect(TfrxRect) Method

Summary

Represents method IsHasMapRect(TfrxRect).

Namespace: frxMapLayer
Syntax
Delphi
public
 function IsHasMapRect(out MapRect: TfrxRect): boolean;

Parameters

MapRect
Type: TfrxRect

Return Value

Type: boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.IsHasZoomRect(TfrxRect) Method

Summary

Represents method IsHasZoomRect(TfrxRect).

Namespace: frxMapLayer
Syntax
Delphi
public
 function IsHasZoomRect(out ZoomRect: TfrxRect): boolean; virtual;

Parameters

ZoomRect
Type: TfrxRect

Return Value

Type: boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.IsHiddenShape(Integer) Method

Summary

Represents method IsHiddenShape(Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 function IsHiddenShape(iRecord: Integer): Boolean; virtual;

Parameters

iRecord
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.IsHighlightSelectedShape Method

Summary

Represents method IsHighlightSelectedShape.

Namespace: frxMapLayer
Syntax
Delphi
protected
 function IsHighlightSelectedShape: boolean; virtual;

Return Value

Type: boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.IsInclude(TfrxPoint) Method

Summary

Represents method IsInclude(TfrxPoint).

Namespace: frxMapLayer
Syntax
Delphi
public
 function IsInclude(P: TfrxPoint): Boolean; virtual;

Parameters

P
Type: TfrxPoint

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.IsIncludeAsRegion(TfrxPoint) Method

Summary

Represents method IsIncludeAsRegion(TfrxPoint).

Namespace: frxMapLayer
Syntax
Delphi
protected
 function IsIncludeAsRegion(P: TfrxPoint): Boolean; virtual;

Parameters

P
Type: TfrxPoint

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.IsMercatorSuitable Method

Summary

Represents method IsMercatorSuitable.

Namespace: frxMapLayer
Syntax
Delphi
public
 function IsMercatorSuitable: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.IsSelectedShapeChanded Method

Summary

Represents method IsSelectedShapeChanded.

Namespace: frxMapLayer
Syntax
Delphi
public
 function IsSelectedShapeChanded: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.IsSpecialBorderColor(Integer,TColor) Method

Summary

Represents method IsSpecialBorderColor(Integer,TColor).

Namespace: frxMapLayer
Syntax
Delphi
protected
 function IsSpecialBorderColor(iRecord: Integer; out SpecialColor: TColor): Boolean; virtual;

Parameters

iRecord
Type: Integer

SpecialColor
Type: TColor

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.IsSpecialFillColor(Integer,TColor) Method

Summary

Represents method IsSpecialFillColor(Integer,TColor).

Namespace: frxMapLayer
Syntax
Delphi
protected
 function IsSpecialFillColor(iRecord: Integer; out SpecialColor: TColor): Boolean; virtual;

Parameters

iRecord
Type: Integer

SpecialColor
Type: TColor

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.SetParent(TfrxComponent) Method

Summary

Represents method SetParent(TfrxComponent).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure SetParent(AParent: TfrxComponent); override;

Parameters

AParent
Type: TfrxComponent

Overrides

TfrxComponent.SetParent(TfrxComponent)
See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.SwapShapes(TfrxCustomLayer) Method

Summary

Represents method SwapShapes(TfrxCustomLayer).

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure SwapShapes(EditedLayer: TfrxCustomLayer);

Parameters

EditedLayer
Type: TfrxCustomLayer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.TuneBrush(TBrush,Integer) Method

Summary

Represents method TuneBrush(TBrush,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure TuneBrush(Brush: TBrush; iRecord: Integer);

Parameters

Brush
Type: TBrush

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.TunePen(TPen,Integer) Method

Summary

Represents method TunePen(TPen,Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure TunePen(Pen: TPen; iRecord: Integer);

Parameters

Pen
Type: TPen

iRecord
Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.TunePoint(TCanvas,Integer,Extended) Method

Summary

Represents method TunePoint(TCanvas,Integer,Extended).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure TunePoint(Canvas: TCanvas; iRecord: Integer; out Radius: Extended);

Parameters

Canvas
Type: TCanvas

iRecord
Type: Integer

Radius
Type: Extended

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer Fields

Fields
Name | Description
FActive | Represents field FActive.
FActiveHyperlink | Represents field FActiveHyperlink.
FAnalyticalValue | Represents field FAnalyticalValue.
FClippingRect | Represents field FClippingRect.
FColorRanges | Represents field FColorRanges.
FConverter | Represents field FConverter.
FDataSet | Represents field FDataSet.
FDefaultShapeStyle | Represents field FDefaultShapeStyle.
FFilter | Represents field FFilter.
FHighlightColor | Represents field FHighlightColor.
FLabelColumn | Represents field FLabelColumn.
FLabelKind | Represents field FLabelKind.
FMapAccuracy | Represents field FMapAccuracy.
FMapPalette | Represents field FMapPalette.
FMapView | Represents field FMapView.
FOperation | Represents field FOperation.
FPixelAccuracy | Represents field FPixelAccuracy.
FPointLabelsVisibleAtZoom | Represents field FPointLabelsVisibleAtZoom.
FPreviousSelectedShapeIndex | Represents field FPreviousSelectedShapeIndex.
FSelectedShapeIndex | Represents field FSelectedShapeIndex.
FShapes | Represents field FShapes.
FShowLines | Represents field FShowLines.
FShowPoints | Represents field FShowPoints.
FShowPolygons | Represents field FShowPolygons.
FSizeRanges | Represents field FSizeRanges.
FSpatialColumn | Represents field FSpatialColumn.
FSpatialValue | Represents field FSpatialValue.
FValueFormat | Represents field FValueFormat.
FValuesList | Represents field FValuesList.
FVectorGraphic | Represents field FVectorGraphic.
Top


TfrxCustomLayer.FActive Field

Summary

Represents field FActive.

Namespace: frxMapLayer
Syntax
Delphi
private
 FActive: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FActiveHyperlink Field

Summary

Represents field FActiveHyperlink.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FActiveHyperlink: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FAnalyticalValue Field

Summary

Represents field FAnalyticalValue.

Namespace: frxMapLayer
Syntax
Delphi
private
 FAnalyticalValue: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FClippingRect Field

Summary

Represents field FClippingRect.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FClippingRect: TfrxClippingRect;

Field Value

Type: TfrxClippingRect

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FColorRanges Field

Summary

Represents field FColorRanges.

Namespace: frxMapLayer
Syntax
Delphi
private
 FColorRanges: TfrxColorRanges;

Field Value

Type: TfrxColorRanges

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FConverter Field

Summary

Represents field FConverter.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FConverter: TMapToCanvasCoordinateConverter;

Field Value

Type: TMapToCanvasCoordinateConverter

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FDataSet Field

Summary

Represents field FDataSet.

Namespace: frxMapLayer
Syntax
Delphi
private
 FDataSet: TfrxDataSet;

Field Value

Type: TfrxDataSet

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FDefaultShapeStyle Field

Summary

Represents field FDefaultShapeStyle.

Namespace: frxMapLayer
Syntax
Delphi
private
 FDefaultShapeStyle: TShapeStyle;

Field Value

Type: TShapeStyle

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FFilter Field

Summary

Represents field FFilter.

Namespace: frxMapLayer
Syntax
Delphi
private
 FFilter: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FHighlightColor Field

Summary

Represents field FHighlightColor.

Namespace: frxMapLayer
Syntax
Delphi
private
 FHighlightColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FLabelColumn Field

Summary

Represents field FLabelColumn.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FLabelColumn: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FLabelKind Field

Summary

Represents field FLabelKind.

Namespace: frxMapLayer
Syntax
Delphi
private
 FLabelKind: TMapLabelKind;

Field Value

Type: TMapLabelKind

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FMapAccuracy Field

Summary

Represents field FMapAccuracy.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FMapAccuracy: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FMapPalette Field

Summary

Represents field FMapPalette.

Namespace: frxMapLayer
Syntax
Delphi
private
 FMapPalette: TMapPalette;

Field Value

Type: TMapPalette

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FMapView Field

Summary

Represents field FMapView.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FMapView: TComponent;

Field Value

Type: TComponent

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FOperation Field

Summary

Represents field FOperation.

Namespace: frxMapLayer
Syntax
Delphi
private
 FOperation: TMapOperation;

Field Value

Type: TMapOperation

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FPixelAccuracy Field

Summary

Represents field FPixelAccuracy.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FPixelAccuracy: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FPointLabelsVisibleAtZoom Field

Summary

Represents field FPointLabelsVisibleAtZoom.

Namespace: frxMapLayer
Syntax
Delphi
private
 FPointLabelsVisibleAtZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FPreviousSelectedShapeIndex Field

Summary

Represents field FPreviousSelectedShapeIndex.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FPreviousSelectedShapeIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FSelectedShapeIndex Field

Summary

Represents field FSelectedShapeIndex.

Namespace: frxMapLayer
Syntax
Delphi
private
 FSelectedShapeIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FShapes Field

Summary

Represents field FShapes.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FShapes: TShapeList;

Field Value

Type: TShapeList

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FShowLines Field

Summary

Represents field FShowLines.

Namespace: frxMapLayer
Syntax
Delphi
private
 FShowLines: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FShowPoints Field

Summary

Represents field FShowPoints.

Namespace: frxMapLayer
Syntax
Delphi
private
 FShowPoints: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FShowPolygons Field

Summary

Represents field FShowPolygons.

Namespace: frxMapLayer
Syntax
Delphi
private
 FShowPolygons: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FSizeRanges Field

Summary

Represents field FSizeRanges.

Namespace: frxMapLayer
Syntax
Delphi
private
 FSizeRanges: TfrxSizeRanges;

Field Value

Type: TfrxSizeRanges

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FSpatialColumn Field

Summary

Represents field FSpatialColumn.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FSpatialColumn: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FSpatialValue Field

Summary

Represents field FSpatialValue.

Namespace: frxMapLayer
Syntax
Delphi
private
 FSpatialValue: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FValueFormat Field

Summary

Represents field FValueFormat.

Namespace: frxMapLayer
Syntax
Delphi
private
 FValueFormat: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FValuesList Field

Summary

Represents field FValuesList.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FValuesList: TValuesList;

Field Value

Type: TValuesList

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxCustomLayer.FVectorGraphic Field

Summary

Represents field FVectorGraphic.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FVectorGraphic: TGraphic;

Field Value

Type: TGraphic

See Also

Reference

  • TfrxCustomLayer
  • frxMapLayer


TfrxLabelColumnProperty Class

Summary

Represents type TfrxLabelColumnProperty.

Namespace: frxMapLayer
Inheritance Hierarchy
TObject
frxDsgnIntf.TfrxPropertyEditor
frxMapLayer.TfrxLabelColumnProperty
Syntax
Delphi
type
 TfrxLabelColumnProperty = class(TfrxPropertyEditor)
 end;

The TfrxLabelColumnProperty type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomDesigner) | The constructor. (Inherited from TfrxPropertyEditor.)
Top
Properties
Show:
Name | Description
Component | Reference to the parent component (not to the property itself!), to which the given property belongs. (Inherited from TfrxPropertyEditor.)
Designer | Reference to the report's designer. (Inherited from TfrxPropertyEditor.)
frComponent | Reference to the parent component (not to the property itself!), to which the given property belongs. Cast to the TfrxComponent type (for convenience of use in some cases). (Inherited from TfrxPropertyEditor.)
ItemHeight | Height of the item, in which the property is displayed. It can be useful in the OnDrawXXX methods. (Inherited from TfrxPropertyEditor.)
PropInfo | Link to the PPropInfo structure, which contains information about the edited property. (Inherited from TfrxPropertyEditor.)
Value | Property's value displayed as a string. (Inherited from TfrxPropertyEditor.)
Values | The list of values. This property is to be filled in the "GetValue" method, if the "paValueList" attribute is defined. (Inherited from TfrxPropertyEditor.)
Top
Methods
Show:
Name | Description
Edit | Method is called in two cases: either by selecting a property, by double-clicking its value, or (if a property has the paDialog attribute) by clicking the ... button. The method should return "True," if the property's value was modified. (Inherited from TfrxPropertyEditor.)
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetExtraLBSize | The "GetExtraLBSize" method is called in case you defined the "paValueList" attribute. The method returns the number of pixels, by which the width of the drop-down list should be adjusted in order to find room for the displayed picture. By default, this method returns the value corresponding to the cell's height for property's enveloping. If you need to deduce a picture, width of which is larger than its height, the given method should be overridden. (Inherited from TfrxPropertyEditor.)
GetFloatValue | Method get a property value of type Extended. (Inherited from TfrxPropertyEditor.)
GetName | Method returns the name of the property. (Inherited from TfrxPropertyEditor.)
GetOrdValue | Method get a property value of type Integer. (Inherited from TfrxPropertyEditor.)
GetStrProc(String) | Represents method GetStrProc(String). (Inherited from TfrxPropertyEditor.)
GetStrValue | Method get a property value of type String. (Inherited from TfrxPropertyEditor.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
GetVarValue | Method get a property value of type Variant. (Inherited from TfrxPropertyEditor.)
OnDrawItem(TCanvas,TRect) | The "OnDrawItem" method is called when drawing the property's value in the object inspector (when the property is not selected; otherwise its value is simply displayed in the editing line). For example, the Color property's editor draws a rectangle, filled with the color according to the value, at the left of the property's value. (Inherited from TfrxPropertyEditor.)
OnDrawLBItem(TWinControl,Integer,TRect,TOwnerDrawState) | The "OnDrawLBItem" method is called when drawing a string in the drop-down list, if you defined the paValueList attribute. In fact, this method is the TListBox.OnDrawItem event's handler and has the same set of parameters. (Inherited from TfrxPropertyEditor.)
SetFloatValue(Extended) | Method sets a property value of type Extended. (Inherited from TfrxPropertyEditor.)
SetOrdValue(frxInteger) | Method sets a property value of type Integer. (Inherited from TfrxPropertyEditor.)
SetStrValue(String) | Method sets a property value of type String. (Inherited from TfrxPropertyEditor.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
SetVarValue(Variant) | Method sets a property value of type Variant. (Inherited from TfrxPropertyEditor.)
Top
Fields
Show:
Name | Description
FCompList | Represents field FCompList. (Inherited from TfrxPropertyEditor.)
Top
See Also

Reference

  • frxMapLayer


TfrxLabelColumnProperty Methods

Methods
Name | Description
GetAttributes | The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases. (Overrides TfrxPropertyEditor.GetAttributes.)
GetValue | The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.GetValue.)
GetValues | The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values. (Overrides TfrxPropertyEditor.GetValues.)
SetValue(String) | The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method. (Overrides TfrxPropertyEditor.SetValue(String).)
Top


TfrxLabelColumnProperty.GetAttributes Method

Summary

The "GetAttributes" method is to return a set of the property's attributes. You should override this method in most cases.

Namespace: frxMapLayer
Syntax
Delphi
public
 function GetAttributes: TfrxPropertyAttributes; override;

Return Value

Type: TfrxPropertyAttributes

Overrides

TfrxPropertyEditor.GetAttributes
See Also

Reference

  • TfrxLabelColumnProperty
  • frxMapLayer


TfrxLabelColumnProperty.GetValue Method

Summary

The "GetValue" method should return the property's value as a string (it will be displayed in the object inspector). If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxMapLayer
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

Overrides

TfrxPropertyEditor.GetValue
See Also

Reference

  • TfrxLabelColumnProperty
  • frxMapLayer


TfrxLabelColumnProperty.GetValues Method

Summary

The "GetValues" method should be overridden in case you defined the "paValueList" attribute. This method should fill the "Values" property with values.

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure GetValues; override;

Overrides

TfrxPropertyEditor.GetValues
See Also

Reference

  • TfrxLabelColumnProperty
  • frxMapLayer


TfrxLabelColumnProperty.SetValue(String) Method

Summary

The "SetValue" method is to set the property's value transferred as a string. If you inherit from the TfrxPropertyEditor basic class, it is necessary to override the method.

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure SetValue(const Value: String); override;

Parameters

Value
Type: String

Overrides

TfrxPropertyEditor.SetValue(String)
See Also

Reference

  • TfrxLabelColumnProperty
  • frxMapLayer


TfrxMapFileLayer Class

Summary

Represents type TfrxMapFileLayer.

Namespace: frxMapLayer
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxMapLayer.TfrxCustomLayer
frxMapLayer.TfrxMapFileLayer
Syntax
Delphi
type
 TfrxMapFileLayer = class(TfrxCustomLayer)
 end;

The TfrxMapFileLayer type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxMapFileLayer class. (Overrides TfrxCustomLayer.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxMapFileLayer class. (Overrides TfrxCustomLayer.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Active | Represents property Active. (Inherited from TfrxCustomLayer.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AnalyticalValue | Represents property AnalyticalValue. (Inherited from TfrxCustomLayer.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
ClippingRect | Represents property ClippingRect. (Inherited from TfrxCustomLayer.)
ColorRanges | Represents property ColorRanges. (Inherited from TfrxCustomLayer.)
ColorRangesData | Represents property ColorRangesData. (Inherited from TfrxCustomLayer.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
DataSet | Represents property DataSet. (Inherited from TfrxCustomLayer.)
DefaultShapeStyle | Represents property DefaultShapeStyle. (Inherited from TfrxCustomLayer.)
Description | Object's description. (Inherited from TfrxComponent.)
FileTags | Represents property FileTags.
Filter | Represents property Filter. (Inherited from TfrxCustomLayer.)
Font | Represents property Font. (Inherited from TfrxCustomLayer.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
HighlightColor | Represents property HighlightColor. (Inherited from TfrxCustomLayer.)
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LabelColumn | Represents property LabelColumn.
LabelKind | Represents property LabelKind. (Inherited from TfrxCustomLayer.)
LayerTags | Represents property LayerTags.
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
MapAccuracy | Represents property MapAccuracy.
MapFileName | Represents property MapFileName.
MapPalette | Represents property MapPalette. (Inherited from TfrxCustomLayer.)
MapView | Represents property MapView. (Inherited from TfrxCustomLayer.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
Operation | Represents property Operation. (Inherited from TfrxCustomLayer.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PixelAccuracy | Represents property PixelAccuracy.
PointLabelsVisibleAtZoom | Represents property PointLabelsVisibleAtZoom. (Inherited from TfrxCustomLayer.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
SelectedShape | Represents property SelectedShape. (Inherited from TfrxCustomLayer.)
SelectedShapeIndex | Represents property SelectedShapeIndex. (Inherited from TfrxCustomLayer.)
SelectedShapeName | Represents property SelectedShapeName. (Inherited from TfrxCustomLayer.)
SelectedShapeValue | Represents property SelectedShapeValue. (Inherited from TfrxCustomLayer.)
ShowLines | Represents property ShowLines.
ShowPoints | Represents property ShowPoints.
ShowPolygons | Represents property ShowPolygons.
SizeRanges | Represents property SizeRanges. (Inherited from TfrxCustomLayer.)
SizeRangesData | Represents property SizeRangesData. (Inherited from TfrxCustomLayer.)
SpatialColumn | Represents property SpatialColumn.
SpatialValue | Represents property SpatialValue.
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
ValueFormat | Represents property ValueFormat. (Inherited from TfrxCustomLayer.)
VectorGraphic | Represents property VectorGraphic. (Inherited from TfrxCustomLayer.)
Visible | Represents property Visible. (Inherited from TfrxCustomLayer.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
ZoomPolygon | Represents property ZoomPolygon.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AddValueList(Variant) | Represents method AddValueList(Variant). (Overrides TfrxCustomLayer.AddValueList(Variant).)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BuildGraphic(TfrxPoint,Boolean) | Represents method BuildGraphic(TfrxPoint,Boolean). (Inherited from TfrxCustomLayer.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ClearSelectedShape | Represents method ClearSelectedShape. (Inherited from TfrxCustomLayer.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CopyDatasets(TfrxCustomLayer) | Represents method CopyDatasets(TfrxCustomLayer). (Inherited from TfrxCustomLayer.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefinePrimeProperties(TFiler) | Represents method DefinePrimeProperties(TFiler). (Inherited from TfrxCustomLayer.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxCustomLayer.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas) | Represents method Draw(TCanvas). (Inherited from TfrxCustomLayer.)
DrawClippedPoint(TCanvas,Extended,Extended,Extended) | Represents method DrawClippedPoint(TCanvas,Extended,Extended,Extended). (Inherited from TfrxCustomLayer.)
DrawDiamond(TCanvas,Integer) | Represents method DrawDiamond(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawEllipse(TCanvas,Integer) | Represents method DrawEllipse(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawHighlightFrame(TCanvas,Integer) | Represents method DrawHighlightFrame(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawLegend(TCanvas,Integer) | Represents method DrawLegend(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawMultiPoint(TCanvas,Integer) | Represents method DrawMultiPoint(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawOn(TCanvas,Boolean,TfrxRect) | Represents method DrawOn(TCanvas,Boolean,TfrxRect). (Inherited from TfrxCustomLayer.)
DrawPicture(TCanvas,Integer) | Represents method DrawPicture(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPoint(TCanvas,Integer) | Represents method DrawPoint(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPointLegend(TCanvas,Integer) | Represents method DrawPointLegend(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPolygon(TCanvas,Integer) | Represents method DrawPolygon(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPolyLegend(TCanvas,Integer) | Represents method DrawPolyLegend(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawPolyLine(TCanvas,Integer) | Represents method DrawPolyLine(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawRect(TCanvas,Integer) | Represents method DrawRect(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
DrawTemplate(TCanvas,Integer) | Represents method DrawTemplate(TCanvas,Integer). (Inherited from TfrxCustomLayer.)
Embed | Represents method Embed.
ExpandVariables | Represents method ExpandVariables. (Overrides TfrxCustomLayer.ExpandVariables.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FillRanges(TDoubleArray) | Represents method FillRanges(TDoubleArray). (Inherited from TfrxCustomLayer.)
FinaliseData | Represents method FinaliseData. (Inherited from TfrxCustomLayer.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColumnList(TStrings) | Represents method GetColumnList(TStrings). (Inherited from TfrxCustomLayer.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | Represents method GetData. (Inherited from TfrxCustomLayer.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDesigningData | Represents method GetDesigningData. (Inherited from TfrxCustomLayer.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetFileExtension | Represents method GetFileExtension.
GetFileTags | Represents method GetFileTags.
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetMetaFile(TfrxPoint,Boolean) | Represents method GetMetaFile(TfrxPoint,Boolean). (Inherited from TfrxCustomLayer.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSelectedShapeName | Represents method GetSelectedShapeName. (Overrides TfrxCustomLayer.GetSelectedShapeName.)
GetSelectedShapeValue | Represents method GetSelectedShapeValue. (Overrides TfrxCustomLayer.GetSelectedShapeValue.)
GetShapeLegeng(String,Integer) | Represents method GetShapeLegeng(String,Integer). (Inherited from TfrxCustomLayer.)
GetShapeName(String,Integer) | Represents method GetShapeName(String,Integer). (Inherited from TfrxCustomLayer.)
GetShapeValue(Integer) | Represents method GetShapeValue(Integer). (Inherited from TfrxCustomLayer.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitialiseData | Represents method InitialiseData. (Overrides TfrxCustomLayer.InitialiseData.)
InitTransform(Integer) | Represents method InitTransform(Integer). (Overrides TfrxCustomLayer.InitTransform(Integer).)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsCanGetData | Represents method IsCanGetData. (Overrides TfrxCustomLayer.IsCanGetData.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHasMapRect(TfrxRect) | Represents method IsHasMapRect(TfrxRect). (Inherited from TfrxCustomLayer.)
IsHasZoomRect(TfrxRect) | Represents method IsHasZoomRect(TfrxRect). (Overrides TfrxCustomLayer.IsHasZoomRect(TfrxRect).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsHiddenShape(Integer) | Represents method IsHiddenShape(Integer). (Inherited from TfrxCustomLayer.)
IsHighlightSelectedShape | Represents method IsHighlightSelectedShape. (Overrides TfrxCustomLayer.IsHighlightSelectedShape.)
IsInclude(TfrxPoint) | Represents method IsInclude(TfrxPoint). (Inherited from TfrxCustomLayer.)
IsIncludeAsRegion(TfrxPoint) | Represents method IsIncludeAsRegion(TfrxPoint). (Inherited from TfrxCustomLayer.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsMercatorSuitable | Represents method IsMercatorSuitable. (Inherited from TfrxCustomLayer.)
IsSelectedShapeChanded | Represents method IsSelectedShapeChanded. (Inherited from TfrxCustomLayer.)
IsSpecialBorderColor(Integer,TColor) | Represents method IsSpecialBorderColor(Integer,TColor). (Inherited from TfrxCustomLayer.)
IsSpecialFillColor(Integer,TColor) | Represents method IsSpecialFillColor(Integer,TColor). (Inherited from TfrxCustomLayer.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
JustAdded | Represents method JustAdded.
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
ReRead | Represents method ReRead.
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLayerTags(TStringList) | Represents method SetLayerTags(TStringList).
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetMapFileName(String) | Represents method SetMapFileName(String).
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
SwapShapes(TfrxCustomLayer) | Represents method SwapShapes(TfrxCustomLayer). (Inherited from TfrxCustomLayer.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
TuneBrush(TBrush,Integer) | Represents method TuneBrush(TBrush,Integer). (Inherited from TfrxCustomLayer.)
TunePen(TPen,Integer) | Represents method TunePen(TPen,Integer). (Inherited from TfrxCustomLayer.)
TunePoint(TCanvas,Integer,Extended) | Represents method TunePoint(TCanvas,Integer,Extended). (Inherited from TfrxCustomLayer.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FActiveHyperlink | Represents field FActiveHyperlink. (Inherited from TfrxCustomLayer.)
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FClippingRect | Represents field FClippingRect. (Inherited from TfrxCustomLayer.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FConverter | Represents field FConverter. (Inherited from TfrxCustomLayer.)
FFirstReading | Represents field FFirstReading.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLabelColumn | Represents field FLabelColumn. (Inherited from TfrxCustomLayer.)
FLayerTags | Represents field FLayerTags.
FMapAccuracy | Represents field FMapAccuracy. (Inherited from TfrxCustomLayer.)
FMapFileName | Represents field FMapFileName.
FMapView | Represents field FMapView. (Inherited from TfrxCustomLayer.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPixelAccuracy | Represents field FPixelAccuracy. (Inherited from TfrxCustomLayer.)
FPreviousSelectedShapeIndex | Represents field FPreviousSelectedShapeIndex. (Inherited from TfrxCustomLayer.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShapes | Represents field FShapes. (Inherited from TfrxCustomLayer.)
FSpatialColumn | Represents field FSpatialColumn. (Inherited from TfrxCustomLayer.)
FValuesList | Represents field FValuesList. (Inherited from TfrxCustomLayer.)
FVectorGraphic | Represents field FVectorGraphic. (Inherited from TfrxCustomLayer.)
FZoomPolygon | Represents field FZoomPolygon.
Top
See Also

Reference

  • frxMapLayer


TfrxMapFileLayer Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxMapFileLayer class. (Overrides TfrxCustomLayer.Create(TComponent).)
Destroy | Represents the destructor of the TfrxMapFileLayer class. (Overrides TfrxCustomLayer.Destroy.)
Top


TfrxMapFileLayer.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxMapFileLayer class.

Namespace: frxMapLayer
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomLayer.Create(TComponent)
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.Destroy Destructor

Summary

Represents the destructor of the TfrxMapFileLayer class.

Namespace: frxMapLayer
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxCustomLayer.Destroy
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer Properties

Properties
Name | Description
FileTags | Represents property FileTags.
LabelColumn | Represents property LabelColumn.
LayerTags | Represents property LayerTags.
MapAccuracy | Represents property MapAccuracy.
MapFileName | Represents property MapFileName.
PixelAccuracy | Represents property PixelAccuracy.
ShowLines | Represents property ShowLines.
ShowPoints | Represents property ShowPoints.
ShowPolygons | Represents property ShowPolygons.
SpatialColumn | Represents property SpatialColumn.
SpatialValue | Represents property SpatialValue.
ZoomPolygon | Represents property ZoomPolygon.
Top


TfrxMapFileLayer.FileTags Property

Summary

Represents property FileTags.

Namespace: frxMapLayer
Syntax
Delphi
public
 property FileTags: TfrxSumStringList read GetFileTags;

Property Value

Type: TfrxSumStringList

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.LabelColumn Property

Summary

Represents property LabelColumn.

Namespace: frxMapLayer
Syntax
Delphi
published
 property LabelColumn;

Property Value

Type: Void

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.LayerTags Property

Summary

Represents property LayerTags.

Namespace: frxMapLayer
Syntax
Delphi
published
 property LayerTags: TStringList read FLayerTags write SetLayerTags;

Property Value

Type: TStringList

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.MapAccuracy Property

Summary

Represents property MapAccuracy.

Namespace: frxMapLayer
Syntax
Delphi
published
 property MapAccuracy;

Property Value

Type: Void

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.MapFileName Property

Summary

Represents property MapFileName.

Namespace: frxMapLayer
Syntax
Delphi
published
 property MapFileName: String read FMapFileName write SetMapFileName;

Property Value

Type: String

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.PixelAccuracy Property

Summary

Represents property PixelAccuracy.

Namespace: frxMapLayer
Syntax
Delphi
published
 property PixelAccuracy;

Property Value

Type: Void

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.ShowLines Property

Summary

Represents property ShowLines.

Namespace: frxMapLayer
Syntax
Delphi
published
 property ShowLines;

Property Value

Type: Void

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.ShowPoints Property

Summary

Represents property ShowPoints.

Namespace: frxMapLayer
Syntax
Delphi
published
 property ShowPoints;

Property Value

Type: Void

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.ShowPolygons Property

Summary

Represents property ShowPolygons.

Namespace: frxMapLayer
Syntax
Delphi
published
 property ShowPolygons;

Property Value

Type: Void

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.SpatialColumn Property

Summary

Represents property SpatialColumn.

Namespace: frxMapLayer
Syntax
Delphi
published
 property SpatialColumn;

Property Value

Type: Void

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.SpatialValue Property

Summary

Represents property SpatialValue.

Namespace: frxMapLayer
Syntax
Delphi
published
 property SpatialValue;

Property Value

Type: Void

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.ZoomPolygon Property

Summary

Represents property ZoomPolygon.

Namespace: frxMapLayer
Syntax
Delphi
published
 property ZoomPolygon: String read FZoomPolygon write FZoomPolygon;

Property Value

Type: String

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer Methods

Methods
Name | Description
AddValueList(Variant) | Represents method AddValueList(Variant). (Overrides TfrxCustomLayer.AddValueList(Variant).)
Embed | Represents method Embed.
ExpandVariables | Represents method ExpandVariables. (Overrides TfrxCustomLayer.ExpandVariables.)
GetFileExtension | Represents method GetFileExtension.
GetFileTags | Represents method GetFileTags.
GetSelectedShapeName | Represents method GetSelectedShapeName. (Overrides TfrxCustomLayer.GetSelectedShapeName.)
GetSelectedShapeValue | Represents method GetSelectedShapeValue. (Overrides TfrxCustomLayer.GetSelectedShapeValue.)
InitialiseData | Represents method InitialiseData. (Overrides TfrxCustomLayer.InitialiseData.)
InitTransform(Integer) | Represents method InitTransform(Integer). (Overrides TfrxCustomLayer.InitTransform(Integer).)
IsCanGetData | Represents method IsCanGetData. (Overrides TfrxCustomLayer.IsCanGetData.)
IsHasZoomRect(TfrxRect) | Represents method IsHasZoomRect(TfrxRect). (Overrides TfrxCustomLayer.IsHasZoomRect(TfrxRect).)
IsHighlightSelectedShape | Represents method IsHighlightSelectedShape. (Overrides TfrxCustomLayer.IsHighlightSelectedShape.)
JustAdded | Represents method JustAdded.
ReRead | Represents method ReRead.
SetLayerTags(TStringList) | Represents method SetLayerTags(TStringList).
SetMapFileName(String) | Represents method SetMapFileName(String).
Top


TfrxMapFileLayer.AddValueList(Variant) Method

Summary

Represents method AddValueList(Variant).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure AddValueList(vaAnalyticalValue: Variant); override;

Parameters

vaAnalyticalValue
Type: Variant

Overrides

TfrxCustomLayer.AddValueList(Variant)
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.Embed Method

Summary

Represents method Embed.

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure Embed;
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.ExpandVariables Method

Summary

Represents method ExpandVariables.

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure ExpandVariables; override;

Overrides

TfrxCustomLayer.ExpandVariables
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.GetFileExtension Method

Summary

Represents method GetFileExtension.

Namespace: frxMapLayer
Syntax
Delphi
protected
 function GetFileExtension: string;

Return Value

Type: string

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.GetFileTags Method

Summary

Represents method GetFileTags.

Namespace: frxMapLayer
Syntax
Delphi
private
 function GetFileTags: TfrxSumStringList;

Return Value

Type: TfrxSumStringList

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.GetSelectedShapeName Method

Summary

Represents method GetSelectedShapeName.

Namespace: frxMapLayer
Syntax
Delphi
protected
 function GetSelectedShapeName: String; override;

Return Value

Type: String

Overrides

TfrxCustomLayer.GetSelectedShapeName
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.GetSelectedShapeValue Method

Summary

Represents method GetSelectedShapeValue.

Namespace: frxMapLayer
Syntax
Delphi
protected
 function GetSelectedShapeValue: String; override;

Return Value

Type: String

Overrides

TfrxCustomLayer.GetSelectedShapeValue
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.InitialiseData Method

Summary

Represents method InitialiseData.

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure InitialiseData; override;

Overrides

TfrxCustomLayer.InitialiseData
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.InitTransform(Integer) Method

Summary

Represents method InitTransform(Integer).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure InitTransform(iRecord: Integer); override;

Parameters

iRecord
Type: Integer

Overrides

TfrxCustomLayer.InitTransform(Integer)
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.IsCanGetData Method

Summary

Represents method IsCanGetData.

Namespace: frxMapLayer
Syntax
Delphi
protected
 function IsCanGetData: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCustomLayer.IsCanGetData
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.IsHasZoomRect(TfrxRect) Method

Summary

Represents method IsHasZoomRect(TfrxRect).

Namespace: frxMapLayer
Syntax
Delphi
public
 function IsHasZoomRect(out ZoomRect: TfrxRect): boolean; override;

Parameters

ZoomRect
Type: TfrxRect

Return Value

Type: boolean

Overrides

TfrxCustomLayer.IsHasZoomRect(TfrxRect)
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.IsHighlightSelectedShape Method

Summary

Represents method IsHighlightSelectedShape.

Namespace: frxMapLayer
Syntax
Delphi
protected
 function IsHighlightSelectedShape: boolean; override;

Return Value

Type: boolean

Overrides

TfrxCustomLayer.IsHighlightSelectedShape
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.JustAdded Method

Summary

Represents method JustAdded.

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure JustAdded;
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.ReRead Method

Summary

Represents method ReRead.

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure ReRead;
See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.SetLayerTags(TStringList) Method

Summary

Represents method SetLayerTags(TStringList).

Namespace: frxMapLayer
Syntax
Delphi
private
 procedure SetLayerTags(const Value: TStringList);

Parameters

Value
Type: TStringList

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.SetMapFileName(String) Method

Summary

Represents method SetMapFileName(String).

Namespace: frxMapLayer
Syntax
Delphi
protected
 procedure SetMapFileName(AMapFileName: String);

Parameters

AMapFileName
Type: String

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer Fields

Fields
Name | Description
FFirstReading | Represents field FFirstReading.
FLayerTags | Represents field FLayerTags.
FMapFileName | Represents field FMapFileName.
FZoomPolygon | Represents field FZoomPolygon.
Top


TfrxMapFileLayer.FFirstReading Field

Summary

Represents field FFirstReading.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FFirstReading: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.FLayerTags Field

Summary

Represents field FLayerTags.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FLayerTags: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.FMapFileName Field

Summary

Represents field FMapFileName.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FMapFileName: String;

Field Value

Type: String

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TfrxMapFileLayer.FZoomPolygon Field

Summary

Represents field FZoomPolygon.

Namespace: frxMapLayer
Syntax
Delphi
private
 FZoomPolygon: String;

Field Value

Type: String

See Also

Reference

  • TfrxMapFileLayer
  • frxMapLayer


TMapLayerList Class

Summary

Represents type TMapLayerList.

Namespace: frxMapLayer
Inheritance Hierarchy
TObject
frxMapLayer.TMapLayerList
Syntax
Delphi
type
 TMapLayerList = class
 end;

The TMapLayerList type exposes the following members.

Constructors
Show:
Name | Description
Create(TList) | Initializes a new instance of the TMapLayerList class.
Top
Properties
Show:
Name | Description
Count | Represents property Count.
Items[Integer] | Represents property Items[Integer].
SelectedLayer | Represents property SelectedLayer.
Top
Methods
Show:
Name | Description
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
GetCount | Represents method GetCount.
GetData | Represents method GetData.
GetLayer(Integer) | Represents method GetLayer(Integer).
GetSelectedLayer | Represents method GetSelectedLayer.
IndexOf(Pointer) | Represents method IndexOf(Pointer).
IsInclude(TfrxPoint) | Represents method IsInclude(TfrxPoint).
IsMercatorSuitable | Represents method IsMercatorSuitable.
IsSelectedShapeChanded | Represents method IsSelectedShapeChanded.
Top
Fields
Show:
Name | Description
FObjects | Represents field FObjects.
FPreviousSelectedLayerIndex | Represents field FPreviousSelectedLayerIndex.
FSelectedLayerIndex | Represents field FSelectedLayerIndex.
Top
See Also

Reference

  • frxMapLayer


TMapLayerList Constructors

Constructors
Name | Description
Create(TList) | Initializes a new instance of the TMapLayerList class.
Top


TMapLayerList.Create(TList) Constructor

Summary

Initializes a new instance of the TMapLayerList class.

Namespace: frxMapLayer
Syntax
Delphi
public
 constructor Create(AObjects: TList);

Parameters

AObjects
Type: TList

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList Properties

Properties
Name | Description
Count | Represents property Count.
Items[Integer] | Represents property Items[Integer].
SelectedLayer | Represents property SelectedLayer.
Top


TMapLayerList.Count Property

Summary

Represents property Count.

Namespace: frxMapLayer
Syntax
Delphi
public
 property Count: Integer read GetCount;

Property Value

Type: Integer

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxMapLayer
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxCustomLayer read GetLayer; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCustomLayer

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList.SelectedLayer Property

Summary

Represents property SelectedLayer.

Namespace: frxMapLayer
Syntax
Delphi
public
 property SelectedLayer: TfrxCustomLayer read GetSelectedLayer;

Property Value

Type: TfrxCustomLayer

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList Methods

Methods
Name | Description
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
GetCount | Represents method GetCount.
GetData | Represents method GetData.
GetLayer(Integer) | Represents method GetLayer(Integer).
GetSelectedLayer | Represents method GetSelectedLayer.
IndexOf(Pointer) | Represents method IndexOf(Pointer).
IsInclude(TfrxPoint) | Represents method IsInclude(TfrxPoint).
IsMercatorSuitable | Represents method IsMercatorSuitable.
IsSelectedShapeChanded | Represents method IsSelectedShapeChanded.
Top


TMapLayerList.Exchange(Integer,Integer) Method

Summary

Represents method Exchange(Integer,Integer).

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure Exchange(Index1, Index2: Integer);

Parameters

Index1
Type: Integer

Index2
Type: Integer

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList.GetCount Method

Summary

Represents method GetCount.

Namespace: frxMapLayer
Syntax
Delphi
private
 function GetCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList.GetData Method

Summary

Represents method GetData.

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure GetData;
See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList.GetLayer(Integer) Method

Summary

Represents method GetLayer(Integer).

Namespace: frxMapLayer
Syntax
Delphi
private
 function GetLayer(Index: Integer): TfrxCustomLayer;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCustomLayer

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList.GetSelectedLayer Method

Summary

Represents method GetSelectedLayer.

Namespace: frxMapLayer
Syntax
Delphi
private
 function GetSelectedLayer: TfrxCustomLayer;

Return Value

Type: TfrxCustomLayer

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList.IndexOf(Pointer) Method

Summary

Represents method IndexOf(Pointer).

Namespace: frxMapLayer
Syntax
Delphi
public
 function IndexOf(Item: Pointer): Integer;

Parameters

Item
Type: Pointer

Return Value

Type: Integer

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList.IsInclude(TfrxPoint) Method

Summary

Represents method IsInclude(TfrxPoint).

Namespace: frxMapLayer
Syntax
Delphi
public
 function IsInclude(P: TfrxPoint): Boolean;

Parameters

P
Type: TfrxPoint

Return Value

Type: Boolean

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList.IsMercatorSuitable Method

Summary

Represents method IsMercatorSuitable.

Namespace: frxMapLayer
Syntax
Delphi
public
 function IsMercatorSuitable: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList.IsSelectedShapeChanded Method

Summary

Represents method IsSelectedShapeChanded.

Namespace: frxMapLayer
Syntax
Delphi
public
 function IsSelectedShapeChanded: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList Fields

Fields
Name | Description
FObjects | Represents field FObjects.
FPreviousSelectedLayerIndex | Represents field FPreviousSelectedLayerIndex.
FSelectedLayerIndex | Represents field FSelectedLayerIndex.
Top


TMapLayerList.FObjects Field

Summary

Represents field FObjects.

Namespace: frxMapLayer
Syntax
Delphi
private
 FObjects: TList;

Field Value

Type: TList

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList.FPreviousSelectedLayerIndex Field

Summary

Represents field FPreviousSelectedLayerIndex.

Namespace: frxMapLayer
Syntax
Delphi
protected
 FPreviousSelectedLayerIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TMapLayerList.FSelectedLayerIndex Field

Summary

Represents field FSelectedLayerIndex.

Namespace: frxMapLayer
Syntax
Delphi
private
 FSelectedLayerIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TMapLayerList
  • frxMapLayer


TOperationCalculator Class

Summary

Represents type TOperationCalculator.

Namespace: frxMapLayer
Inheritance Hierarchy
TObject
frxMapLayer.TOperationCalculator
Syntax
Delphi
type
 TOperationCalculator = class
 end;

The TOperationCalculator type exposes the following members.

Constructors
Show:
Name | Description
Create(TMapOperation) | Initializes a new instance of the TOperationCalculator class.
Top
Methods
Show:
Name | Description
Add(Extended) | Represents method Add(Extended).
Get | Represents method Get.
Top
Fields
Show:
Name | Description
FCount | Represents field FCount.
FOperation | Represents field FOperation.
FValue | Represents field FValue.
Top
See Also

Reference

  • frxMapLayer


TOperationCalculator Constructors

Constructors
Name | Description
Create(TMapOperation) | Initializes a new instance of the TOperationCalculator class.
Top


TOperationCalculator.Create(TMapOperation) Constructor

Summary

Initializes a new instance of the TOperationCalculator class.

Namespace: frxMapLayer
Syntax
Delphi
public
 constructor Create(AOperation: TMapOperation); reintroduce;

Parameters

AOperation
Type: TMapOperation

See Also

Reference

  • TOperationCalculator
  • frxMapLayer


TOperationCalculator Methods

Methods
Name | Description
Add(Extended) | Represents method Add(Extended).
Get | Represents method Get.
Top


TOperationCalculator.Add(Extended) Method

Summary

Represents method Add(Extended).

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure Add(AValue: Extended);

Parameters

AValue
Type: Extended

See Also

Reference

  • TOperationCalculator
  • frxMapLayer


TOperationCalculator.Get Method

Summary

Represents method Get.

Namespace: frxMapLayer
Syntax
Delphi
public
 function Get: Extended;

Return Value

Type: Extended

See Also

Reference

  • TOperationCalculator
  • frxMapLayer


TOperationCalculator Fields

Fields
Name | Description
FCount | Represents field FCount.
FOperation | Represents field FOperation.
FValue | Represents field FValue.
Top


TOperationCalculator.FCount Field

Summary

Represents field FCount.

Namespace: frxMapLayer
Syntax
Delphi
private
 FCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TOperationCalculator
  • frxMapLayer


TOperationCalculator.FOperation Field

Summary

Represents field FOperation.

Namespace: frxMapLayer
Syntax
Delphi
private
 FOperation: TMapOperation;

Field Value

Type: TMapOperation

See Also

Reference

  • TOperationCalculator
  • frxMapLayer


TOperationCalculator.FValue Field

Summary

Represents field FValue.

Namespace: frxMapLayer
Syntax
Delphi
private
 FValue: Extended;

Field Value

Type: Extended

See Also

Reference

  • TOperationCalculator
  • frxMapLayer


TValuesList Class

Summary

Represents type TValuesList.

Namespace: frxMapLayer
Inheritance Hierarchy
TStringList
frxMapLayer.TValuesList
Syntax
Delphi
type
 TValuesList = class(TStringList)
 end;

The TValuesList type exposes the following members.

Constructors
Show:
Name | Description
Create(TMapOperation) | Initializes a new instance of the TValuesList class.
Destroy | Represents the destructor of the TValuesList class.
Top
Properties
Show:
Name | Description
OperationCalculator[integer] | Represents property OperationCalculator[integer].
Top
Methods
Show:
Name | Description
AddValue(String,Extended) | Represents method AddValue(String,Extended).
GetOperationCalculator(integer) | Represents method GetOperationCalculator(integer).
MaxValue | Represents method MaxValue.
MinValue | Represents method MinValue.
Top
Fields
Show:
Name | Description
FOperation | Represents field FOperation.
Top
See Also

Reference

  • frxMapLayer


TValuesList Constructors

Constructors
Name | Description
Create(TMapOperation) | Initializes a new instance of the TValuesList class.
Destroy | Represents the destructor of the TValuesList class.
Top


TValuesList.Create(TMapOperation) Constructor

Summary

Initializes a new instance of the TValuesList class.

Namespace: frxMapLayer
Syntax
Delphi
public
 constructor Create(AOperation: TMapOperation); reintroduce;

Parameters

AOperation
Type: TMapOperation

See Also

Reference

  • TValuesList
  • frxMapLayer


TValuesList.Destroy Destructor

Summary

Represents the destructor of the TValuesList class.

Namespace: frxMapLayer
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TValuesList
  • frxMapLayer


TValuesList Properties

Properties
Name | Description
OperationCalculator[integer] | Represents property OperationCalculator[integer].
Top


TValuesList.OperationCalculator[integer] Property

Summary

Represents property OperationCalculator[integer].

Namespace: frxMapLayer
Syntax
Delphi
public
 property OperationCalculator[Index: integer]: TOperationCalculator read GetOperationCalculator;

Parameters

Index
Type: integer

Property Value

Type: TOperationCalculator

See Also

Reference

  • TValuesList
  • frxMapLayer


TValuesList Methods

Methods
Name | Description
AddValue(String,Extended) | Represents method AddValue(String,Extended).
GetOperationCalculator(integer) | Represents method GetOperationCalculator(integer).
MaxValue | Represents method MaxValue.
MinValue | Represents method MinValue.
Top


TValuesList.AddValue(String,Extended) Method

Summary

Represents method AddValue(String,Extended).

Namespace: frxMapLayer
Syntax
Delphi
public
 procedure AddValue(SpatialValue: String; AnalyticalValue: Extended);

Parameters

SpatialValue
Type: String

AnalyticalValue
Type: Extended

See Also

Reference

  • TValuesList
  • frxMapLayer


TValuesList.GetOperationCalculator(integer) Method

Summary

Represents method GetOperationCalculator(integer).

Namespace: frxMapLayer
Syntax
Delphi
private
 function GetOperationCalculator(Index: integer): TOperationCalculator;

Parameters

Index
Type: integer

Return Value

Type: TOperationCalculator

See Also

Reference

  • TValuesList
  • frxMapLayer


TValuesList.MaxValue Method

Summary

Represents method MaxValue.

Namespace: frxMapLayer
Syntax
Delphi
public
 function MaxValue: Extended;

Return Value

Type: Extended

See Also

Reference

  • TValuesList
  • frxMapLayer


TValuesList.MinValue Method

Summary

Represents method MinValue.

Namespace: frxMapLayer
Syntax
Delphi
public
 function MinValue: Extended;

Return Value

Type: Extended

See Also

Reference

  • TValuesList
  • frxMapLayer


TValuesList Fields

Fields
Name | Description
FOperation | Represents field FOperation.
Top


TValuesList.FOperation Field

Summary

Represents field FOperation.

Namespace: frxMapLayer
Syntax
Delphi
private
 FOperation: TMapOperation;

Field Value

Type: TMapOperation

See Also

Reference

  • TValuesList
  • frxMapLayer


frxMapLayer Enumerations

Enumerations
Name | Description
TMapLabelKind | Represents type TMapLabelKind.
TMapOperation | Represents type TMapOperation.
TMapPalette | Represents type TMapPalette.
Top


TMapLabelKind Enumeration

Summary

Represents type TMapLabelKind.

Namespace: frxMapLayer
Syntax
Delphi
type
 TMapLabelKind = (mlNone, mlName, mlValue, mlNameAndValue);

The TMapLabelKind type exposes the following members.

Members
Show:
Name | Description
mlName | Represents constant mlName.
mlNameAndValue | Represents constant mlNameAndValue.
mlNone | Represents constant mlNone.
mlValue | Represents constant mlValue.
Top
See Also

Reference

  • frxMapLayer


TMapOperation Enumeration

Summary

Represents type TMapOperation.

Namespace: frxMapLayer
Syntax
Delphi
type
 TMapOperation = (opSum, opAverage, opMin, opMax, opCount);

The TMapOperation type exposes the following members.

Members
Show:
Name | Description
opAverage | Represents constant opAverage.
opCount | Represents constant opCount.
opMax | Represents constant opMax.
opMin | Represents constant opMin.
opSum | Represents constant opSum.
Top
See Also

Reference

  • frxMapLayer


TMapPalette Enumeration

Summary

Represents type TMapPalette.

Namespace: frxMapLayer
Syntax
Delphi
type
 TMapPalette = (mpNone, mpLight, mpPastel, mpGrayScale, mpEarth, mpSea, mpBrightPastel);

The TMapPalette type exposes the following members.

Members
Show:
Name | Description
mpBrightPastel | Represents constant mpBrightPastel.
mpEarth | Represents constant mpEarth.
mpGrayScale | Represents constant mpGrayScale.
mpLight | Represents constant mpLight.
mpNone | Represents constant mpNone.
mpPastel | Represents constant mpPastel.
mpSea | Represents constant mpSea.
Top
See Also

Reference

  • frxMapLayer


frxMapLayer Routines

Routines
Name | Description
GeoDataKindList(TStrings) | Represents method GeoDataKindList(TStrings).
MapLabelKindGetList(TStrings) | Represents method MapLabelKindGetList(TStrings).
OperationGetList(TStrings) | Represents method OperationGetList(TStrings).
PaletteGetList(TStrings) | Represents method PaletteGetList(TStrings).
PenStyleGetList(TStrings) | Represents method PenStyleGetList(TStrings).
Top


GeoDataKindList(TStrings) Method

Summary

Represents method GeoDataKindList(TStrings).

Namespace: frxMapLayer
Syntax
Delphi
 procedure GeoDataKindList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • frxMapLayer


MapLabelKindGetList(TStrings) Method

Summary

Represents method MapLabelKindGetList(TStrings).

Namespace: frxMapLayer
Syntax
Delphi
 procedure MapLabelKindGetList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • frxMapLayer


OperationGetList(TStrings) Method

Summary

Represents method OperationGetList(TStrings).

Namespace: frxMapLayer
Syntax
Delphi
 procedure OperationGetList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • frxMapLayer


PaletteGetList(TStrings) Method

Summary

Represents method PaletteGetList(TStrings).

Namespace: frxMapLayer
Syntax
Delphi
 procedure PaletteGetList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • frxMapLayer


PenStyleGetList(TStrings) Method

Summary

Represents method PenStyleGetList(TStrings).

Namespace: frxMapLayer
Syntax
Delphi
 procedure PenStyleGetList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • frxMapLayer


frxMapLayerTags Namespace

Summary

Represents namespace frxMapLayerTags.

Classes
Name | Description
TMapLayerTagsForm | Represents type TMapLayerTagsForm.
Top
Routines
Name | Description
EditLayerTags(TfrxSumStringList,TStringList,TComponent) | Represents method EditLayerTags(TfrxSumStringList,TStringList,TComponent).
Top


frxMapLayerTags Classes

Classes
Name | Description
TMapLayerTagsForm | Represents type TMapLayerTagsForm.
Top


TMapLayerTagsForm Class

Summary

Represents type TMapLayerTagsForm.

Namespace: frxMapLayerTags
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxMapLayerTags.TMapLayerTagsForm
Syntax
Delphi
type
 TMapLayerTagsForm = class(TfrxBaseForm)
 end;

The TMapLayerTagsForm type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseForm class. (Inherited from TfrxBaseForm.)
Top
Properties
Show:
Name | Description
CurrentFormPPI | Returns current PPI value of the form. (Inherited from TfrxBaseForm.)
IsPPIChanging | Represents property IsPPIChanging. (Inherited from TfrxBaseForm.)
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseForm.)
AfterPPIChange | Represents method AfterPPIChange. (Inherited from TfrxBaseForm.)
AfterPPIMessage | Represents method AfterPPIMessage. (Inherited from TfrxBaseForm.)
BeforeDestruction | Represents method BeforeDestruction. (Inherited from TfrxBaseForm.)
BeforePPIChange | Represents method BeforePPIChange. (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer). (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean). (Inherited from TfrxBaseForm.)
DoClose(TCloseAction) | Represents method DoClose(TCloseAction). (Inherited from TfrxBaseForm.)
DoShow | Represents method DoShow. (Inherited from TfrxBaseForm.)
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer). (Inherited from TfrxBaseForm.)
FileTagsListViewColumnClick(TObject,TListColumn) | Represents method FileTagsListViewColumnClick(TObject,TListColumn).
FillFileTags | Represents method FillFileTags.
FilterEditChange(TObject) | Represents method FilterEditChange(TObject).
FilterEditKeyPress(TObject,Char) | Represents method FilterEditKeyPress(TObject,Char).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
FormShowAfterLoad | Represents method FormShowAfterLoad. (Inherited from TfrxBaseForm.)
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Inherited from TfrxBaseForm.)
GetAvailablePreferences | Represents method GetAvailablePreferences. (Inherited from TfrxBaseForm.)
GetFormSectionName | Represents method GetFormSectionName. (Inherited from TfrxBaseForm.)
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Inherited from TfrxBaseForm.)
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Inherited from TfrxBaseForm.)
IsEditFilter(String) | Represents method IsEditFilter(String).
IsInLayerTags(String) | Represents method IsInLayerTags(String).
LayerAddButtonClick(TObject) | Represents method LayerAddButtonClick(TObject).
LayerDeleteButtonClick(TObject) | Represents method LayerDeleteButtonClick(TObject).
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter. (Inherited from TfrxBaseForm.)
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Inherited from TfrxBaseForm.)
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxBaseForm.)
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms. (Inherited from TfrxBaseForm.)
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form. (Inherited from TfrxBaseForm.)
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Inherited from TfrxBaseForm.)
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Inherited from TfrxBaseForm.)
Top
Fields
Show:
Name | Description
CancelB | Represents field CancelB.
FHostedControls | Represents field FHostedControls. (Inherited from TfrxBaseForm.)
FileTagsLabel | Represents field FileTagsLabel.
FileTagsListView | Represents field FileTagsListView.
FilterEdit | Represents field FilterEdit.
FilterLabel | Represents field FilterLabel.
FPrefEvent | Represents field FPrefEvent. (Inherited from TfrxBaseForm.)
FSumTags | Represents field FSumTags.
FTagId | Represents field FTagId.
LayerAddButton | Represents field LayerAddButton.
LayerDeleteButton | Represents field LayerDeleteButton.
LayerTagsLabel | Represents field LayerTagsLabel.
LayerTagsListBox | Represents field LayerTagsListBox.
OkB | Represents field OkB.
Top
See Also

Reference

  • frxMapLayerTags


TMapLayerTagsForm Methods

Methods
Name | Description
FileTagsListViewColumnClick(TObject,TListColumn) | Represents method FileTagsListViewColumnClick(TObject,TListColumn).
FillFileTags | Represents method FillFileTags.
FilterEditChange(TObject) | Represents method FilterEditChange(TObject).
FilterEditKeyPress(TObject,Char) | Represents method FilterEditKeyPress(TObject,Char).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
IsEditFilter(String) | Represents method IsEditFilter(String).
IsInLayerTags(String) | Represents method IsInLayerTags(String).
LayerAddButtonClick(TObject) | Represents method LayerAddButtonClick(TObject).
LayerDeleteButtonClick(TObject) | Represents method LayerDeleteButtonClick(TObject).
Top


TMapLayerTagsForm.FileTagsListViewColumnClick(TObject,TListColumn) Method

Summary

Represents method FileTagsListViewColumnClick(TObject,TListColumn).

Namespace: frxMapLayerTags
Syntax
Delphi
published
 procedure FileTagsListViewColumnClick(Sender: TObject; Column: TListColumn);

Parameters

Sender
Type: TObject

Column
Type: TListColumn

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.FillFileTags Method

Summary

Represents method FillFileTags.

Namespace: frxMapLayerTags
Syntax
Delphi
protected
 procedure FillFileTags;
See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.FilterEditChange(TObject) Method

Summary

Represents method FilterEditChange(TObject).

Namespace: frxMapLayerTags
Syntax
Delphi
published
 procedure FilterEditChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.FilterEditKeyPress(TObject,Char) Method

Summary

Represents method FilterEditKeyPress(TObject,Char).

Namespace: frxMapLayerTags
Syntax
Delphi
published
 procedure FilterEditKeyPress(Sender: TObject; var Key: Char);

Parameters

Sender
Type: TObject

Key
Type: Char

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: frxMapLayerTags
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.FormKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method FormKeyDown(TObject,Word,TShiftState).

Namespace: frxMapLayerTags
Syntax
Delphi
published
 procedure FormKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.IsEditFilter(String) Method

Summary

Represents method IsEditFilter(String).

Namespace: frxMapLayerTags
Syntax
Delphi
protected
 function IsEditFilter(st: String): Boolean;

Parameters

st
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.IsInLayerTags(String) Method

Summary

Represents method IsInLayerTags(String).

Namespace: frxMapLayerTags
Syntax
Delphi
protected
 function IsInLayerTags(st: String): Boolean;

Parameters

st
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.LayerAddButtonClick(TObject) Method

Summary

Represents method LayerAddButtonClick(TObject).

Namespace: frxMapLayerTags
Syntax
Delphi
published
 procedure LayerAddButtonClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.LayerDeleteButtonClick(TObject) Method

Summary

Represents method LayerDeleteButtonClick(TObject).

Namespace: frxMapLayerTags
Syntax
Delphi
published
 procedure LayerDeleteButtonClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm Fields

Fields
Name | Description
CancelB | Represents field CancelB.
FileTagsLabel | Represents field FileTagsLabel.
FileTagsListView | Represents field FileTagsListView.
FilterEdit | Represents field FilterEdit.
FilterLabel | Represents field FilterLabel.
FSumTags | Represents field FSumTags.
FTagId | Represents field FTagId.
LayerAddButton | Represents field LayerAddButton.
LayerDeleteButton | Represents field LayerDeleteButton.
LayerTagsLabel | Represents field LayerTagsLabel.
LayerTagsListBox | Represents field LayerTagsListBox.
OkB | Represents field OkB.
Top


TMapLayerTagsForm.CancelB Field

Summary

Represents field CancelB.

Namespace: frxMapLayerTags
Syntax
Delphi
published
 CancelB: TButton;

Field Value

Type: TButton

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.FileTagsLabel Field

Summary

Represents field FileTagsLabel.

Namespace: frxMapLayerTags
Syntax
Delphi
published
 FileTagsLabel: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.FileTagsListView Field

Summary

Represents field FileTagsListView.

Namespace: frxMapLayerTags
Syntax
Delphi
published
 FileTagsListView: TListView;

Field Value

Type: TListView

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.FilterEdit Field

Summary

Represents field FilterEdit.

Namespace: frxMapLayerTags
Syntax
Delphi
published
 FilterEdit: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.FilterLabel Field

Summary

Represents field FilterLabel.

Namespace: frxMapLayerTags
Syntax
Delphi
published
 FilterLabel: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.FSumTags Field

Summary

Represents field FSumTags.

Namespace: frxMapLayerTags
Syntax
Delphi
protected
 FSumTags: TfrxSumStringList;

Field Value

Type: TfrxSumStringList

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.FTagId Field

Summary

Represents field FTagId.

Namespace: frxMapLayerTags
Syntax
Delphi
protected
 FTagId: Integer;

Field Value

Type: Integer

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.LayerAddButton Field

Summary

Represents field LayerAddButton.

Namespace: frxMapLayerTags
Syntax
Delphi
published
 LayerAddButton: TButton;

Field Value

Type: TButton

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.LayerDeleteButton Field

Summary

Represents field LayerDeleteButton.

Namespace: frxMapLayerTags
Syntax
Delphi
published
 LayerDeleteButton: TButton;

Field Value

Type: TButton

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.LayerTagsLabel Field

Summary

Represents field LayerTagsLabel.

Namespace: frxMapLayerTags
Syntax
Delphi
published
 LayerTagsLabel: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.LayerTagsListBox Field

Summary

Represents field LayerTagsListBox.

Namespace: frxMapLayerTags
Syntax
Delphi
published
 LayerTagsListBox: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


TMapLayerTagsForm.OkB Field

Summary

Represents field OkB.

Namespace: frxMapLayerTags
Syntax
Delphi
published
 OkB: TButton;

Field Value

Type: TButton

See Also

Reference

  • TMapLayerTagsForm
  • frxMapLayerTags


frxMapLayerTags Routines

Routines
Name | Description
EditLayerTags(TfrxSumStringList,TStringList,TComponent) | Represents method EditLayerTags(TfrxSumStringList,TStringList,TComponent).
Top


EditLayerTags(TfrxSumStringList,TStringList,TComponent) Method

Summary

Represents method EditLayerTags(TfrxSumStringList,TStringList,TComponent).

Namespace: frxMapLayerTags
Syntax
Delphi
function EditLayerTags(FileTags: TfrxSumStringList; LayerTags: TStringList;
 Owner: TComponent = nil): boolean;

Parameters

FileTags
Type: TfrxSumStringList

LayerTags
Type: TStringList

Owner
Type: TComponent

Return Value

Type: boolean

See Also

Reference

  • frxMapLayerTags


frxMapRanges Namespace

Summary

Represents namespace frxMapRanges.

Classes
Name | Description
TMapRangeCollection | Represents type TMapRangeCollection.
TMapRangeItem | Represents type TMapRangeItem.
TMapRanges | Represents type TMapRanges.
TMapScale | Represents type TMapScale.
Top
Enumerations
Name | Description
TRangeFactor | Represents type TRangeFactor.
TScaleDock | Represents type TScaleDock.
Top
Routines
Name | Description
IsValidFloat(Boolean,String,Boolean) | Represents method IsValidFloat(Boolean,String,Boolean).
RangeFactorGetList(TStrings) | Represents method RangeFactorGetList(TStrings).
Top


frxMapRanges Classes

Classes
Name | Description
TMapRangeCollection | Represents type TMapRangeCollection.
TMapRangeItem | Represents type TMapRangeItem.
TMapRanges | Represents type TMapRanges.
TMapScale | Represents type TMapScale.
Top


TMapRangeCollection Class

Summary

Represents type TMapRangeCollection.

Namespace: frxMapRanges
Inheritance Hierarchy
TCollection
frxMapRanges.TMapRangeCollection
Syntax
Delphi
type
 TMapRangeCollection = class(TCollection)
 end;

The TMapRangeCollection type exposes the following members.

Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
FillRangeValues(TDoubleArray,TRangeFactor) | Represents method FillRangeValues(TDoubleArray,TRangeFactor).
GetItem(Integer) | Represents method GetItem(Integer).
MedianValue | Represents method MedianValue.
Part(Extended) | Represents method Part(Extended).
Ranges(TDoubleArray,TRangeFactor) | Represents method Ranges(TDoubleArray,TRangeFactor).
RangesByAutoCLuster(TDoubleArray) | Represents method RangesByAutoCLuster(TDoubleArray).
RangesByCLuster(TDoubleArray) | Represents method RangesByCLuster(TDoubleArray).
RangesByPercentile(TDoubleArray) | Represents method RangesByPercentile(TDoubleArray).
RangesByValue(TDoubleArray) | Represents method RangesByValue(TDoubleArray).
Read(TReader) | Represents method Read(TReader).
ReadDFM(TStream) | Represents method ReadDFM(TStream).
SetItem(Integer,TMapRangeItem) | Represents method SetItem(Integer,TMapRangeItem).
Swap(Integer,Integer) | Represents method Swap(Integer,Integer).
Write(TWriter) | Represents method Write(TWriter).
WriteDFM(TStream) | Represents method WriteDFM(TStream).
Top
Fields
Show:
Name | Description
FMaxValue | Represents field FMaxValue.
FMinValue | Represents field FMinValue.
FRangeFactor | Represents field FRangeFactor.
FValues | Represents field FValues.
Top
See Also

Reference

  • frxMapRanges


TMapRangeCollection Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TMapRangeCollection.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxMapRanges
Syntax
Delphi
public
 property Items[Index: Integer]: TMapRangeItem read GetItem write SetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TMapRangeItem

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection Methods

Methods
Name | Description
FillRangeValues(TDoubleArray,TRangeFactor) | Represents method FillRangeValues(TDoubleArray,TRangeFactor).
GetItem(Integer) | Represents method GetItem(Integer).
MedianValue | Represents method MedianValue.
Part(Extended) | Represents method Part(Extended).
Ranges(TDoubleArray,TRangeFactor) | Represents method Ranges(TDoubleArray,TRangeFactor).
RangesByAutoCLuster(TDoubleArray) | Represents method RangesByAutoCLuster(TDoubleArray).
RangesByCLuster(TDoubleArray) | Represents method RangesByCLuster(TDoubleArray).
RangesByPercentile(TDoubleArray) | Represents method RangesByPercentile(TDoubleArray).
RangesByValue(TDoubleArray) | Represents method RangesByValue(TDoubleArray).
Read(TReader) | Represents method Read(TReader).
ReadDFM(TStream) | Represents method ReadDFM(TStream).
SetItem(Integer,TMapRangeItem) | Represents method SetItem(Integer,TMapRangeItem).
Swap(Integer,Integer) | Represents method Swap(Integer,Integer).
Write(TWriter) | Represents method Write(TWriter).
WriteDFM(TStream) | Represents method WriteDFM(TStream).
Top


TMapRangeCollection.FillRangeValues(TDoubleArray,TRangeFactor) Method

Summary

Represents method FillRangeValues(TDoubleArray,TRangeFactor).

Namespace: frxMapRanges
Syntax
Delphi
public
 procedure FillRangeValues(const Values: TDoubleArray; RangeFactor: TRangeFactor);

Parameters

Values
Type: TDoubleArray

RangeFactor
Type: TRangeFactor

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxMapRanges
Syntax
Delphi
protected
 function GetItem(Index: Integer): TMapRangeItem;

Parameters

Index
Type: Integer

Return Value

Type: TMapRangeItem

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.MedianValue Method

Summary

Represents method MedianValue.

Namespace: frxMapRanges
Syntax
Delphi
protected
 function MedianValue: Double;

Return Value

Type: Double

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.Part(Extended) Method

Summary

Represents method Part(Extended).

Namespace: frxMapRanges
Syntax
Delphi
protected
 function Part(Value: Extended): Extended;

Parameters

Value
Type: Extended

Return Value

Type: Extended

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.Ranges(TDoubleArray,TRangeFactor) Method

Summary

Represents method Ranges(TDoubleArray,TRangeFactor).

Namespace: frxMapRanges
Syntax
Delphi
protected
 function Ranges(const Values: TDoubleArray; RangeFactor: TRangeFactor): TDoubleArray;

Parameters

Values
Type: TDoubleArray

RangeFactor
Type: TRangeFactor

Return Value

Type: TDoubleArray

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.RangesByAutoCLuster(TDoubleArray) Method

Summary

Represents method RangesByAutoCLuster(TDoubleArray).

Namespace: frxMapRanges
Syntax
Delphi
protected
 function RangesByAutoCLuster(const Values: TDoubleArray): TDoubleArray;

Parameters

Values
Type: TDoubleArray

Return Value

Type: TDoubleArray

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.RangesByCLuster(TDoubleArray) Method

Summary

Represents method RangesByCLuster(TDoubleArray).

Namespace: frxMapRanges
Syntax
Delphi
protected
 function RangesByCLuster(const Values: TDoubleArray): TDoubleArray;

Parameters

Values
Type: TDoubleArray

Return Value

Type: TDoubleArray

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.RangesByPercentile(TDoubleArray) Method

Summary

Represents method RangesByPercentile(TDoubleArray).

Namespace: frxMapRanges
Syntax
Delphi
protected
 function RangesByPercentile(const Values: TDoubleArray): TDoubleArray;

Parameters

Values
Type: TDoubleArray

Return Value

Type: TDoubleArray

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.RangesByValue(TDoubleArray) Method

Summary

Represents method RangesByValue(TDoubleArray).

Namespace: frxMapRanges
Syntax
Delphi
protected
 function RangesByValue(const Values: TDoubleArray): TDoubleArray;

Parameters

Values
Type: TDoubleArray

Return Value

Type: TDoubleArray

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.Read(TReader) Method

Summary

Represents method Read(TReader).

Namespace: frxMapRanges
Syntax
Delphi
public
 procedure Read(Reader: TReader); virtual;

Parameters

Reader
Type: TReader

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.ReadDFM(TStream) Method

Summary

Represents method ReadDFM(TStream).

Namespace: frxMapRanges
Syntax
Delphi
public
 procedure ReadDFM(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.SetItem(Integer,TMapRangeItem) Method

Summary

Represents method SetItem(Integer,TMapRangeItem).

Namespace: frxMapRanges
Syntax
Delphi
protected
 procedure SetItem(Index: Integer; const Value: TMapRangeItem);

Parameters

Index
Type: Integer

Value
Type: TMapRangeItem

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.Swap(Integer,Integer) Method

Summary

Represents method Swap(Integer,Integer).

Namespace: frxMapRanges
Syntax
Delphi
public
 procedure Swap(Index1, Index2: Integer);

Parameters

Index1
Type: Integer

Index2
Type: Integer

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.Write(TWriter) Method

Summary

Represents method Write(TWriter).

Namespace: frxMapRanges
Syntax
Delphi
public
 procedure Write(Writer: TWriter); virtual;

Parameters

Writer
Type: TWriter

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.WriteDFM(TStream) Method

Summary

Represents method WriteDFM(TStream).

Namespace: frxMapRanges
Syntax
Delphi
public
 procedure WriteDFM(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection Fields

Fields
Name | Description
FMaxValue | Represents field FMaxValue.
FMinValue | Represents field FMinValue.
FRangeFactor | Represents field FRangeFactor.
FValues | Represents field FValues.
Top


TMapRangeCollection.FMaxValue Field

Summary

Represents field FMaxValue.

Namespace: frxMapRanges
Syntax
Delphi
private
 FMinValue, FMaxValue: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.FMinValue Field

Summary

Represents field FMinValue.

Namespace: frxMapRanges
Syntax
Delphi
private
 FMinValue, FMaxValue: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.FRangeFactor Field

Summary

Represents field FRangeFactor.

Namespace: frxMapRanges
Syntax
Delphi
protected
 FRangeFactor: TRangeFactor;

Field Value

Type: TRangeFactor

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeCollection.FValues Field

Summary

Represents field FValues.

Namespace: frxMapRanges
Syntax
Delphi
protected
 FValues: TDoubleArray;

Field Value

Type: TDoubleArray

See Also

Reference

  • TMapRangeCollection
  • frxMapRanges


TMapRangeItem Class

Summary

Represents type TMapRangeItem.

Namespace: frxMapRanges
Inheritance Hierarchy
TCollectionItem
frxMapRanges.TMapRangeItem
Syntax
Delphi
type
 TMapRangeItem = class(TCollectionItem)
 end;

The TMapRangeItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TMapRangeItem class.
Top
Properties
Show:
Name | Description
AutoEnd | Represents property AutoEnd.
AutoStart | Represents property AutoStart.
EndValue | Represents property EndValue.
EndValueByForce | Represents property EndValueByForce.
StartValue | Represents property StartValue.
StartValueByForce | Represents property StartValueByForce.
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
AsString(String) | Represents method AsString(String).
IsInside(Extended) | Represents method IsInside(Extended).
Read(TReader) | Represents method Read(TReader).
SetEndValue(Extended) | Represents method SetEndValue(Extended).
SetEndValueByForce(Extended) | Represents method SetEndValueByForce(Extended).
SetStartValue(Extended) | Represents method SetStartValue(Extended).
SetStartValueByForce(Extended) | Represents method SetStartValueByForce(Extended).
Write(TWriter) | Represents method Write(TWriter).
Top
Fields
Show:
Name | Description
FAutoEnd | Represents field FAutoEnd.
FAutoStart | Represents field FAutoStart.
FEndValue | Represents field FEndValue.
FStartValue | Represents field FStartValue.
Top
See Also

Reference

  • frxMapRanges


TMapRangeItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TMapRangeItem class.
Top


TMapRangeItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TMapRangeItem class.

Namespace: frxMapRanges
Syntax
Delphi
public
 constructor Create(Collection: TCollection); override;

Parameters

Collection
Type: TCollection

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem Properties

Properties
Name | Description
AutoEnd | Represents property AutoEnd.
AutoStart | Represents property AutoStart.
EndValue | Represents property EndValue.
EndValueByForce | Represents property EndValueByForce.
StartValue | Represents property StartValue.
StartValueByForce | Represents property StartValueByForce.
Top


TMapRangeItem.AutoEnd Property

Summary

Represents property AutoEnd.

Namespace: frxMapRanges
Syntax
Delphi
published
 property AutoEnd: Boolean read FAutoEnd write FAutoEnd;

Property Value

Type: Boolean

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.AutoStart Property

Summary

Represents property AutoStart.

Namespace: frxMapRanges
Syntax
Delphi
published
 property AutoStart: Boolean read FAutoStart write FAutoStart;

Property Value

Type: Boolean

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.EndValue Property

Summary

Represents property EndValue.

Namespace: frxMapRanges
Syntax
Delphi
published
 property EndValue: Extended read FEndValue write SetEndValue;

Property Value

Type: Extended

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.EndValueByForce Property

Summary

Represents property EndValueByForce.

Namespace: frxMapRanges
Syntax
Delphi
published
 property EndValueByForce: Extended read FEndValue write SetEndValueByForce;

Property Value

Type: Extended

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.StartValue Property

Summary

Represents property StartValue.

Namespace: frxMapRanges
Syntax
Delphi
published
 property StartValue: Extended read FStartValue write SetStartValue;

Property Value

Type: Extended

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.StartValueByForce Property

Summary

Represents property StartValueByForce.

Namespace: frxMapRanges
Syntax
Delphi
published
 property StartValueByForce: Extended read FStartValue write SetStartValueByForce;

Property Value

Type: Extended

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem Methods

Methods
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
AsString(String) | Represents method AsString(String).
IsInside(Extended) | Represents method IsInside(Extended).
Read(TReader) | Represents method Read(TReader).
SetEndValue(Extended) | Represents method SetEndValue(Extended).
SetEndValueByForce(Extended) | Represents method SetEndValueByForce(Extended).
SetStartValue(Extended) | Represents method SetStartValue(Extended).
SetStartValueByForce(Extended) | Represents method SetStartValueByForce(Extended).
Write(TWriter) | Represents method Write(TWriter).
Top


TMapRangeItem.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: frxMapRanges
Syntax
Delphi
protected
 procedure AssignTo(Dest: TPersistent); override;

Parameters

Dest
Type: TPersistent

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.AsString(String) Method

Summary

Represents method AsString(String).

Namespace: frxMapRanges
Syntax
Delphi
public
 function AsString(FValueFormat: String): String; virtual;

Parameters

FValueFormat
Type: String

Return Value

Type: String

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.IsInside(Extended) Method

Summary

Represents method IsInside(Extended).

Namespace: frxMapRanges
Syntax
Delphi
protected
 function IsInside(Value: Extended): Boolean;

Parameters

Value
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.Read(TReader) Method

Summary

Represents method Read(TReader).

Namespace: frxMapRanges
Syntax
Delphi
public
 procedure Read(Reader: TReader); virtual;

Parameters

Reader
Type: TReader

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.SetEndValue(Extended) Method

Summary

Represents method SetEndValue(Extended).

Namespace: frxMapRanges
Syntax
Delphi
private
 procedure SetEndValue(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.SetEndValueByForce(Extended) Method

Summary

Represents method SetEndValueByForce(Extended).

Namespace: frxMapRanges
Syntax
Delphi
private
 procedure SetEndValueByForce(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.SetStartValue(Extended) Method

Summary

Represents method SetStartValue(Extended).

Namespace: frxMapRanges
Syntax
Delphi
private
 procedure SetStartValue(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.SetStartValueByForce(Extended) Method

Summary

Represents method SetStartValueByForce(Extended).

Namespace: frxMapRanges
Syntax
Delphi
private
 procedure SetStartValueByForce(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.Write(TWriter) Method

Summary

Represents method Write(TWriter).

Namespace: frxMapRanges
Syntax
Delphi
public
 procedure Write(Writer: TWriter); virtual;

Parameters

Writer
Type: TWriter

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem Fields

Fields
Name | Description
FAutoEnd | Represents field FAutoEnd.
FAutoStart | Represents field FAutoStart.
FEndValue | Represents field FEndValue.
FStartValue | Represents field FStartValue.
Top


TMapRangeItem.FAutoEnd Field

Summary

Represents field FAutoEnd.

Namespace: frxMapRanges
Syntax
Delphi
private
 FAutoEnd: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.FAutoStart Field

Summary

Represents field FAutoStart.

Namespace: frxMapRanges
Syntax
Delphi
private
 FAutoStart: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.FEndValue Field

Summary

Represents field FEndValue.

Namespace: frxMapRanges
Syntax
Delphi
private
 FEndValue: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRangeItem.FStartValue Field

Summary

Represents field FStartValue.

Namespace: frxMapRanges
Syntax
Delphi
private
 FStartValue: Extended;

Field Value

Type: Extended

See Also

Reference

  • TMapRangeItem
  • frxMapRanges


TMapRanges Class

Summary

Represents type TMapRanges.

Namespace: frxMapRanges
Inheritance Hierarchy
TPersistent
frxMapRanges.TMapRanges
Syntax
Delphi
type
 TMapRanges = class(TPersistent)
 end;

The TMapRanges type exposes the following members.

Constructors
Show:
Name | Description
Create(TMapScale) | Initializes a new instance of the TMapRanges class.
Destroy | Represents the destructor of the TMapRanges class.
Top
Properties
Show:
Name | Description
ContentHeight | Represents property ContentHeight.
Height | Represents property Height.
MapScale | Represents property MapScale.
RangeCount | Represents property RangeCount.
RangeFactor | Represents property RangeFactor.
SpaceWidth | Represents property SpaceWidth.
StepWidth | Represents property StepWidth.
TitleHeight | Represents property TitleHeight.
ValuesHeight | Represents property ValuesHeight.
Visible | Represents property Visible.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
CalcTextHeight(TFont,String) | Represents method CalcTextHeight(TFont,String).
Draw(TCanvas) | Represents method Draw(TCanvas).
DrawContent(TCanvas) | Represents method DrawContent(TCanvas).
DrawValues(TCanvas) | Represents method DrawValues(TCanvas).
GetContentHeight | Represents method GetContentHeight.
GetGraphic | Represents method GetGraphic.
GetHeight | Represents method GetHeight.
GetRangeCount | Represents method GetRangeCount.
GetSpaceWidth | Represents method GetSpaceWidth.
GetStepWidth | Represents method GetStepWidth.
GetTitleHeight | Represents method GetTitleHeight.
GetValuesHeight | Represents method GetValuesHeight.
GetWidth | Represents method GetWidth.
SetRangeCount(Integer) | Represents method SetRangeCount(Integer).
Top
Fields
Show:
Name | Description
FMapRangeCollection | Represents field FMapRangeCollection.
FMapScale | Represents field FMapScale.
FRangeFactor | Represents field FRangeFactor.
FVisible | Represents field FVisible.
Top
See Also

Reference

  • frxMapRanges


TMapRanges Constructors

Constructors
Name | Description
Create(TMapScale) | Initializes a new instance of the TMapRanges class.
Destroy | Represents the destructor of the TMapRanges class.
Top


TMapRanges.Create(TMapScale) Constructor

Summary

Initializes a new instance of the TMapRanges class.

Namespace: frxMapRanges
Syntax
Delphi
public
 constructor Create(MapScale: TMapScale);

Parameters

MapScale
Type: TMapScale

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.Destroy Destructor

Summary

Represents the destructor of the TMapRanges class.

Namespace: frxMapRanges
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges Properties

Properties
Name | Description
ContentHeight | Represents property ContentHeight.
Height | Represents property Height.
MapScale | Represents property MapScale.
RangeCount | Represents property RangeCount.
RangeFactor | Represents property RangeFactor.
SpaceWidth | Represents property SpaceWidth.
StepWidth | Represents property StepWidth.
TitleHeight | Represents property TitleHeight.
ValuesHeight | Represents property ValuesHeight.
Visible | Represents property Visible.
Width | Represents property Width.
Top


TMapRanges.ContentHeight Property

Summary

Represents property ContentHeight.

Namespace: frxMapRanges
Syntax
Delphi
protected
 property ContentHeight: Integer read GetContentHeight;

Property Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.Height Property

Summary

Represents property Height.

Namespace: frxMapRanges
Syntax
Delphi
public
 property Height: Integer read GetHeight;

Property Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.MapScale Property

Summary

Represents property MapScale.

Namespace: frxMapRanges
Syntax
Delphi
public
 property MapScale: TMapScale read FMapScale;

Property Value

Type: TMapScale

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.RangeCount Property

Summary

Represents property RangeCount.

Namespace: frxMapRanges
Syntax
Delphi
published
 property RangeCount: Integer read GetRangeCount write SetRangeCount;

Property Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.RangeFactor Property

Summary

Represents property RangeFactor.

Namespace: frxMapRanges
Syntax
Delphi
published
 property RangeFactor: TRangeFactor read FRangeFactor write FRangeFactor;

Property Value

Type: TRangeFactor

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.SpaceWidth Property

Summary

Represents property SpaceWidth.

Namespace: frxMapRanges
Syntax
Delphi
protected
 property SpaceWidth: Integer read GetSpaceWidth;

Property Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.StepWidth Property

Summary

Represents property StepWidth.

Namespace: frxMapRanges
Syntax
Delphi
protected
 property StepWidth: Integer read GetStepWidth;

Property Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.TitleHeight Property

Summary

Represents property TitleHeight.

Namespace: frxMapRanges
Syntax
Delphi
protected
 property TitleHeight: Integer read GetTitleHeight;

Property Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.ValuesHeight Property

Summary

Represents property ValuesHeight.

Namespace: frxMapRanges
Syntax
Delphi
protected
 property ValuesHeight: Integer read GetValuesHeight;

Property Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.Visible Property

Summary

Represents property Visible.

Namespace: frxMapRanges
Syntax
Delphi
published
 property Visible: Boolean read FVisible write FVisible;

Property Value

Type: Boolean

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.Width Property

Summary

Represents property Width.

Namespace: frxMapRanges
Syntax
Delphi
public
 property Width: Integer read GetWidth;

Property Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges Methods

Methods
Name | Description
CalcTextHeight(TFont,String) | Represents method CalcTextHeight(TFont,String).
Draw(TCanvas) | Represents method Draw(TCanvas).
DrawContent(TCanvas) | Represents method DrawContent(TCanvas).
DrawValues(TCanvas) | Represents method DrawValues(TCanvas).
GetContentHeight | Represents method GetContentHeight.
GetGraphic | Represents method GetGraphic.
GetHeight | Represents method GetHeight.
GetRangeCount | Represents method GetRangeCount.
GetSpaceWidth | Represents method GetSpaceWidth.
GetStepWidth | Represents method GetStepWidth.
GetTitleHeight | Represents method GetTitleHeight.
GetValuesHeight | Represents method GetValuesHeight.
GetWidth | Represents method GetWidth.
SetRangeCount(Integer) | Represents method SetRangeCount(Integer).
Top


TMapRanges.CalcTextHeight(TFont,String) Method

Summary

Represents method CalcTextHeight(TFont,String).

Namespace: frxMapRanges
Syntax
Delphi
protected
 function CalcTextHeight(Font: TFont; Text: String): Integer;

Parameters

Font
Type: TFont

Text
Type: String

Return Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.Draw(TCanvas) Method

Summary

Represents method Draw(TCanvas).

Namespace: frxMapRanges
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas);

Parameters

Canvas
Type: TCanvas

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.DrawContent(TCanvas) Method

Summary

Represents method DrawContent(TCanvas).

Namespace: frxMapRanges
Syntax
Delphi
protected
 procedure DrawContent(Canvas: TCanvas); virtual; abstract;

Parameters

Canvas
Type: TCanvas

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.DrawValues(TCanvas) Method

Summary

Represents method DrawValues(TCanvas).

Namespace: frxMapRanges
Syntax
Delphi
protected
 procedure DrawValues(Canvas: TCanvas);

Parameters

Canvas
Type: TCanvas

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.GetContentHeight Method

Summary

Represents method GetContentHeight.

Namespace: frxMapRanges
Syntax
Delphi
protected
 function GetContentHeight: Integer; virtual;

Return Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.GetGraphic Method

Summary

Represents method GetGraphic.

Namespace: frxMapRanges
Syntax
Delphi
public
 function GetGraphic: TGraphic;

Return Value

Type: TGraphic

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.GetHeight Method

Summary

Represents method GetHeight.

Namespace: frxMapRanges
Syntax
Delphi
private
 function GetHeight: Integer;

Return Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.GetRangeCount Method

Summary

Represents method GetRangeCount.

Namespace: frxMapRanges
Syntax
Delphi
private
 function GetRangeCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.GetSpaceWidth Method

Summary

Represents method GetSpaceWidth.

Namespace: frxMapRanges
Syntax
Delphi
protected
 function GetSpaceWidth: Integer; virtual;

Return Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.GetStepWidth Method

Summary

Represents method GetStepWidth.

Namespace: frxMapRanges
Syntax
Delphi
protected
 function GetStepWidth: Integer; virtual;

Return Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.GetTitleHeight Method

Summary

Represents method GetTitleHeight.

Namespace: frxMapRanges
Syntax
Delphi
private
 function GetTitleHeight: Integer;

Return Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.GetValuesHeight Method

Summary

Represents method GetValuesHeight.

Namespace: frxMapRanges
Syntax
Delphi
private
 function GetValuesHeight: Integer;

Return Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.GetWidth Method

Summary

Represents method GetWidth.

Namespace: frxMapRanges
Syntax
Delphi
private
 function GetWidth: Integer;

Return Value

Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.SetRangeCount(Integer) Method

Summary

Represents method SetRangeCount(Integer).

Namespace: frxMapRanges
Syntax
Delphi
private
 procedure SetRangeCount(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges Fields

Fields
Name | Description
FMapRangeCollection | Represents field FMapRangeCollection.
FMapScale | Represents field FMapScale.
FRangeFactor | Represents field FRangeFactor.
FVisible | Represents field FVisible.
Top


TMapRanges.FMapRangeCollection Field

Summary

Represents field FMapRangeCollection.

Namespace: frxMapRanges
Syntax
Delphi
protected
 FMapRangeCollection: TMapRangeCollection;

Field Value

Type: TMapRangeCollection

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.FMapScale Field

Summary

Represents field FMapScale.

Namespace: frxMapRanges
Syntax
Delphi
protected
 FMapScale: TMapScale;

Field Value

Type: TMapScale

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.FRangeFactor Field

Summary

Represents field FRangeFactor.

Namespace: frxMapRanges
Syntax
Delphi
protected
 FRangeFactor: TRangeFactor;

Field Value

Type: TRangeFactor

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapRanges.FVisible Field

Summary

Represents field FVisible.

Namespace: frxMapRanges
Syntax
Delphi
private
 FVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TMapRanges
  • frxMapRanges


TMapScale Class

Summary

Represents type TMapScale.

Namespace: frxMapRanges
Inheritance Hierarchy
TPersistent
frxMapRanges.TMapScale
Syntax
Delphi
type
 TMapScale = class(TPersistent)
 end;

The TMapScale type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TMapScale class.
Destroy | Represents the destructor of the TMapScale class.
Top
Properties
Show:
Name | Description
BorderColor | Represents property BorderColor.
BorderWidth | Represents property BorderWidth.
Dock | Represents property Dock.
FillColor | Represents property FillColor.
Font | Represents property Font.
TitleFont | Represents property TitleFont.
TitleText | Represents property TitleText.
ValueFormat | Represents property ValueFormat.
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
LeftTopPoint(TRect) | Represents method LeftTopPoint(TRect).
Top
Fields
Show:
Name | Description
FBorderColor | Represents field FBorderColor.
FBorderWidth | Represents field FBorderWidth.
FDock | Represents field FDock.
FFillColor | Represents field FFillColor.
FFont | Represents field FFont.
FTitleFont | Represents field FTitleFont.
FTitleText | Represents field FTitleText.
FValueFormat | Represents field FValueFormat.
FVisible | Represents field FVisible.
Top
See Also

Reference

  • frxMapRanges


TMapScale Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TMapScale class.
Destroy | Represents the destructor of the TMapScale class.
Top


TMapScale.Create Constructor

Summary

Initializes a new instance of the TMapScale class.

Namespace: frxMapRanges
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.Destroy Destructor

Summary

Represents the destructor of the TMapScale class.

Namespace: frxMapRanges
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale Properties

Properties
Name | Description
BorderColor | Represents property BorderColor.
BorderWidth | Represents property BorderWidth.
Dock | Represents property Dock.
FillColor | Represents property FillColor.
Font | Represents property Font.
TitleFont | Represents property TitleFont.
TitleText | Represents property TitleText.
ValueFormat | Represents property ValueFormat.
Visible | Represents property Visible.
Top


TMapScale.BorderColor Property

Summary

Represents property BorderColor.

Namespace: frxMapRanges
Syntax
Delphi
published
 property BorderColor: TColor read FBorderColor write FBorderColor;

Property Value

Type: TColor

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.BorderWidth Property

Summary

Represents property BorderWidth.

Namespace: frxMapRanges
Syntax
Delphi
published
 property BorderWidth: Integer read FBorderWidth write FBorderWidth;

Property Value

Type: Integer

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.Dock Property

Summary

Represents property Dock.

Namespace: frxMapRanges
Syntax
Delphi
published
 property Dock: TScaleDock read FDock write FDock;

Property Value

Type: TScaleDock

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.FillColor Property

Summary

Represents property FillColor.

Namespace: frxMapRanges
Syntax
Delphi
published
 property FillColor: TColor read FFillColor write FFillColor;

Property Value

Type: TColor

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.Font Property

Summary

Represents property Font.

Namespace: frxMapRanges
Syntax
Delphi
published
 property Font: TFont read FFont;

Property Value

Type: TFont

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.TitleFont Property

Summary

Represents property TitleFont.

Namespace: frxMapRanges
Syntax
Delphi
published
 property TitleFont: TFont read FTitleFont;

Property Value

Type: TFont

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.TitleText Property

Summary

Represents property TitleText.

Namespace: frxMapRanges
Syntax
Delphi
published
 property TitleText: String read FTitleText write FTitleText;

Property Value

Type: String

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.ValueFormat Property

Summary

Represents property ValueFormat.

Namespace: frxMapRanges
Syntax
Delphi
published
 property ValueFormat: String read FValueFormat write FValueFormat;

Property Value

Type: String

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.Visible Property

Summary

Represents property Visible.

Namespace: frxMapRanges
Syntax
Delphi
published
 property Visible: Boolean read FVisible write FVisible;

Property Value

Type: Boolean

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale Methods

Methods
Name | Description
LeftTopPoint(TRect) | Represents method LeftTopPoint(TRect).
Top


TMapScale.LeftTopPoint(TRect) Method

Summary

Represents method LeftTopPoint(TRect).

Namespace: frxMapRanges
Syntax
Delphi
public
 function LeftTopPoint(ConstrivtedParentRect: TRect): TPoint;

Parameters

ConstrivtedParentRect
Type: TRect

Return Value

Type: TPoint

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale Fields

Fields
Name | Description
FBorderColor | Represents field FBorderColor.
FBorderWidth | Represents field FBorderWidth.
FDock | Represents field FDock.
FFillColor | Represents field FFillColor.
FFont | Represents field FFont.
FTitleFont | Represents field FTitleFont.
FTitleText | Represents field FTitleText.
FValueFormat | Represents field FValueFormat.
FVisible | Represents field FVisible.
Top


TMapScale.FBorderColor Field

Summary

Represents field FBorderColor.

Namespace: frxMapRanges
Syntax
Delphi
private
 FBorderColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.FBorderWidth Field

Summary

Represents field FBorderWidth.

Namespace: frxMapRanges
Syntax
Delphi
private
 FBorderWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.FDock Field

Summary

Represents field FDock.

Namespace: frxMapRanges
Syntax
Delphi
private
 FDock: TScaleDock;

Field Value

Type: TScaleDock

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.FFillColor Field

Summary

Represents field FFillColor.

Namespace: frxMapRanges
Syntax
Delphi
private
 FFillColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.FFont Field

Summary

Represents field FFont.

Namespace: frxMapRanges
Syntax
Delphi
private
 FFont: TFont;

Field Value

Type: TFont

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.FTitleFont Field

Summary

Represents field FTitleFont.

Namespace: frxMapRanges
Syntax
Delphi
private
 FTitleFont: TFont;

Field Value

Type: TFont

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.FTitleText Field

Summary

Represents field FTitleText.

Namespace: frxMapRanges
Syntax
Delphi
private
 FTitleText: String;

Field Value

Type: String

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.FValueFormat Field

Summary

Represents field FValueFormat.

Namespace: frxMapRanges
Syntax
Delphi
private
 FValueFormat: String;

Field Value

Type: String

See Also

Reference

  • TMapScale
  • frxMapRanges


TMapScale.FVisible Field

Summary

Represents field FVisible.

Namespace: frxMapRanges
Syntax
Delphi
private
 FVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TMapScale
  • frxMapRanges


frxMapRanges Enumerations

Enumerations
Name | Description
TRangeFactor | Represents type TRangeFactor.
TScaleDock | Represents type TScaleDock.
Top


TRangeFactor Enumeration

Summary

Represents type TRangeFactor.

Namespace: frxMapRanges
Syntax
Delphi
type
 TRangeFactor = (rfValue, rfPercentile, rfCluster, rfAutoCluster);

The TRangeFactor type exposes the following members.

Members
Show:
Name | Description
rfAutoCluster | Represents constant rfAutoCluster.
rfCluster | Represents constant rfCluster.
rfPercentile | Represents constant rfPercentile.
rfValue | Represents constant rfValue.
Top
See Also

Reference

  • frxMapRanges


TScaleDock Enumeration

Summary

Represents type TScaleDock.

Namespace: frxMapRanges
Syntax
Delphi
type
 TScaleDock = (sdTopLeft, sdTopCenter, sdTopRight, sdMiddleLeft, sdMiddleRight,
 sdBottomLeft, sdBottomCenter, sdBottomRight, sdMiddleCenter);

The TScaleDock type exposes the following members.

Members
Show:
Name | Description
sdBottomCenter | Represents constant sdBottomCenter.
sdBottomLeft | Represents constant sdBottomLeft.
sdBottomRight | Represents constant sdBottomRight.
sdMiddleCenter | Represents constant sdMiddleCenter.
sdMiddleLeft | Represents constant sdMiddleLeft.
sdMiddleRight | Represents constant sdMiddleRight.
sdTopCenter | Represents constant sdTopCenter.
sdTopLeft | Represents constant sdTopLeft.
sdTopRight | Represents constant sdTopRight.
Top
See Also

Reference

  • frxMapRanges


frxMapRanges Routines

Routines
Name | Description
IsValidFloat(Boolean,String,Boolean) | Represents method IsValidFloat(Boolean,String,Boolean).
RangeFactorGetList(TStrings) | Represents method RangeFactorGetList(TStrings).
Top


IsValidFloat(Boolean,String,Boolean) Method

Summary

Represents method IsValidFloat(Boolean,String,Boolean).

Namespace: frxMapRanges
Syntax
Delphi
 function IsValidFloat(NeedTest: Boolean; stFloat: String; Quiet: Boolean = False): Boolean;

Parameters

NeedTest
Type: Boolean

stFloat
Type: String

Quiet
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • frxMapRanges


RangeFactorGetList(TStrings) Method

Summary

Represents method RangeFactorGetList(TStrings).

Namespace: frxMapRanges
Syntax
Delphi
 procedure RangeFactorGetList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • frxMapRanges


frxMapShape Namespace

Summary

Represents namespace frxMapShape.

Classes
Name | Description
TAdjustableShape | Represents type TAdjustableShape.
TERSIShapeList | Represents type TERSIShapeList.
TGPXShapeList | Represents type TGPXShapeList.
TOSMFileList | Represents type TOSMFileList.
TOSMShapeList | Represents type TOSMShapeList.
TShape | Represents type TShape.
TShapeList | Represents type TShapeList.
TShapeStyle | Represents type TShapeStyle.
Top


frxMapShape Classes

Classes
Name | Description
TAdjustableShape | Represents type TAdjustableShape.
TERSIShapeList | Represents type TERSIShapeList.
TGPXShapeList | Represents type TGPXShapeList.
TOSMFileList | Represents type TOSMFileList.
TOSMShapeList | Represents type TOSMShapeList.
TShape | Represents type TShape.
TShapeList | Represents type TShapeList.
TShapeStyle | Represents type TShapeStyle.
Top


TAdjustableShape Class

Summary

Represents type TAdjustableShape.

Namespace: frxMapShape
Inheritance Hierarchy
TPersistent
frxMapShape.TShape
frxMapShape.TAdjustableShape
Syntax
Delphi
type
 TAdjustableShape = class(TShape)
 end;

The TAdjustableShape type exposes the following members.

Constructors
Show:
Name | Description
CreateClear | Initializes a new instance of the TShape class. (Inherited from TShape.)
Top
Properties
Show:
Name | Description
CenterOffsetX | Represents property CenterOffsetX. (Inherited from TShape.)
CenterOffsetY | Represents property CenterOffsetY. (Inherited from TShape.)
Legend[String] | Represents property Legend[String]. (Inherited from TShape.)
OffsetX | Represents property OffsetX.
OffsetY | Represents property OffsetY.
PartCount | Represents property PartCount. (Inherited from TShape.)
ShapeCenter | Represents property ShapeCenter. (Inherited from TShape.)
ShapeData | Represents property ShapeData. (Inherited from TShape.)
ShapeTags | Represents property ShapeTags. (Inherited from TShape.)
ShapeType | Represents property ShapeType. (Inherited from TShape.)
Value | Represents property Value. (Inherited from TShape.)
Zoom | Represents property Zoom.
Top
Methods
Show:
Name | Description
Clear | Represents method Clear. (Inherited from TShape.)
IsMercatorSuitable | Represents method IsMercatorSuitable. (Inherited from TShape.)
IsValueEmpty | Represents method IsValueEmpty. (Inherited from TShape.)
Read(TReader) | Represents method Read(TReader). (Inherited from TShape.)
ReadData(TReader) | Represents method ReadData(TReader). (Inherited from TShape.)
Write(TWriter) | Represents method Write(TWriter). (Inherited from TShape.)
WriteData(TWriter) | Represents method WriteData(TWriter). (Inherited from TShape.)
Top
Fields
Show:
Name | Description
FShapeData | Represents field FShapeData. (Inherited from TShape.)
Top
See Also

Reference

  • frxMapShape


TAdjustableShape Properties

Properties
Name | Description
OffsetX | Represents property OffsetX.
OffsetY | Represents property OffsetY.
Zoom | Represents property Zoom.
Top


TAdjustableShape.OffsetX Property

Summary

Represents property OffsetX.

Namespace: frxMapShape
Syntax
Delphi
published
 property OffsetX;

Property Value

Type: Void

See Also

Reference

  • TAdjustableShape
  • frxMapShape


TAdjustableShape.OffsetY Property

Summary

Represents property OffsetY.

Namespace: frxMapShape
Syntax
Delphi
published
 property OffsetY;

Property Value

Type: Void

See Also

Reference

  • TAdjustableShape
  • frxMapShape


TAdjustableShape.Zoom Property

Summary

Represents property Zoom.

Namespace: frxMapShape
Syntax
Delphi
published
 property Zoom;

Property Value

Type: Void

See Also

Reference

  • TAdjustableShape
  • frxMapShape


TERSIShapeList Class

Summary

Represents type TERSIShapeList.

Namespace: frxMapShape
Inheritance Hierarchy
TObjectList
frxMapShape.TShapeList
frxMapShape.TERSIShapeList
Syntax
Delphi
type
 TERSIShapeList = class (TShapeList)
 end;

The TERSIShapeList type exposes the following members.

Constructors
Show:
Name | Description
Create(TMapToCanvasCoordinateConverter) | Initializes a new instance of the TShapeList class. (Inherited from TShapeList.)
CreateFromFile(String,TMapToCanvasCoordinateConverter) | Initializes a new instance of the TERSIShapeList class.
Top
Properties
Show:
Name | Description
AdjustableShape | Represents property AdjustableShape. (Inherited from TShapeList.)
EmbeddedData | Represents property EmbeddedData. (Inherited from TShapeList.)
Items[Integer] | Represents property Items[Integer]. (Inherited from TShapeList.)
Top
Methods
Show:
Name | Description
AddShapeData(TShapeData) | Represents method AddShapeData(TShapeData). (Inherited from TShapeList.)
CanvasDistance(Integer,TfrxPoint) | Represents method CanvasDistance(Integer,TfrxPoint). (Inherited from TShapeList.)
CanvasMatrix(Integer) | Represents method CanvasMatrix(Integer). (Inherited from TShapeList.)
CanvasPoint(Integer) | Represents method CanvasPoint(Integer). (Inherited from TShapeList.)
CanvasPoly(Integer) | Represents method CanvasPoly(Integer). (Inherited from TShapeList.)
CanvasRect(Integer) | Represents method CanvasRect(Integer). (Inherited from TShapeList.)
CanvasWidestPartBounds(Integer) | Represents method CanvasWidestPartBounds(Integer). (Inherited from TShapeList.)
ClearValues | Represents method ClearValues. (Inherited from TShapeList.)
Data(Integer,Integer,Integer) | Represents method Data(Integer,Integer,Integer). (Inherited from TShapeList.)
GetColumnList(TStrings) | Represents method GetColumnList(TStrings). (Inherited from TShapeList.)
IsCanvasPolyPoints(Integer,Integer,Extended,Extended,TPointArray) | Represents method IsCanvasPolyPoints(Integer,Integer,Extended,Extended,TPointArray). (Inherited from TShapeList.)
IsGetValues(TDoubleArray) | Represents method IsGetValues(TDoubleArray). (Inherited from TShapeList.)
IsHasLegend(String,String,Integer) | Represents method IsHasLegend(String,String,Integer). (Inherited from TShapeList.)
IsInside(Integer,TfrxPoint) | Represents method IsInside(Integer,TfrxPoint). (Inherited from TShapeList.)
IsMercatorSuitable | Represents method IsMercatorSuitable. (Inherited from TShapeList.)
IsValidMapRect(TfrxRect) | Represents method IsValidMapRect(TfrxRect). (Inherited from TShapeList.)
LoadData(TERSIShapeFile) | Represents method LoadData(TERSIShapeFile).
Read(TReader) | Represents method Read(TReader). (Inherited from TShapeList.)
ReadDFM(TStream) | Represents method ReadDFM(TStream). (Inherited from TShapeList.)
ReplaceShapeData(Integer,TShapeData) | Represents method ReplaceShapeData(Integer,TShapeData). (Inherited from TShapeList.)
SaveToTextFile(String) | Represents method SaveToTextFile(String). (Inherited from TShapeList.)
SetMapRect(Extended,Extended,Extended,Extended) | Represents method SetMapRect(Extended,Extended,Extended,Extended). (Inherited from TShapeList.)
SetMapRectByData | Represents method SetMapRectByData. (Inherited from TShapeList.)
Write(TWriter) | Represents method Write(TWriter). (Inherited from TShapeList.)
WriteDFM(TStream) | Represents method WriteDFM(TStream). (Inherited from TShapeList.)
Top
Fields
Show:
Name | Description
FConverter | Represents field FConverter. (Inherited from TShapeList.)
FValidMapRect | Represents field FValidMapRect. (Inherited from TShapeList.)
FXMax | Represents field FXMax. (Inherited from TShapeList.)
FXMin | Represents field FXMin. (Inherited from TShapeList.)
FYMax | Represents field FYMax. (Inherited from TShapeList.)
FYMin | Represents field FYMin. (Inherited from TShapeList.)
Top
See Also

Reference

  • frxMapShape


TERSIShapeList Constructors

Constructors
Name | Description
CreateFromFile(String,TMapToCanvasCoordinateConverter) | Initializes a new instance of the TERSIShapeList class.
Top


TERSIShapeList.CreateFromFile(String,TMapToCanvasCoordinateConverter) Constructor

Summary

Initializes a new instance of the TERSIShapeList class.

Namespace: frxMapShape
Syntax
Delphi
public
 constructor CreateFromFile(FileName: String; Converter: TMapToCanvasCoordinateConverter);

Parameters

FileName
Type: String

Converter
Type: TMapToCanvasCoordinateConverter

See Also

Reference

  • TERSIShapeList
  • frxMapShape


TERSIShapeList Methods

Methods
Name | Description
LoadData(TERSIShapeFile) | Represents method LoadData(TERSIShapeFile).
Top


TERSIShapeList.LoadData(TERSIShapeFile) Method

Summary

Represents method LoadData(TERSIShapeFile).

Namespace: frxMapShape
Syntax
Delphi
protected
 procedure LoadData(ERSIFile: TERSIShapeFile);

Parameters

ERSIFile
Type: TERSIShapeFile

See Also

Reference

  • TERSIShapeList
  • frxMapShape


TGPXShapeList Class

Summary

Represents type TGPXShapeList.

Namespace: frxMapShape
Inheritance Hierarchy
TObjectList
frxMapShape.TShapeList
frxMapShape.TGPXShapeList
Syntax
Delphi
type
 TGPXShapeList = class (TShapeList)
 end;

The TGPXShapeList type exposes the following members.

Constructors
Show:
Name | Description
Create(TMapToCanvasCoordinateConverter) | Initializes a new instance of the TShapeList class. (Inherited from TShapeList.)
CreateFromFile(String,TMapToCanvasCoordinateConverter) | Initializes a new instance of the TGPXShapeList class.
Top
Properties
Show:
Name | Description
AdjustableShape | Represents property AdjustableShape. (Inherited from TShapeList.)
EmbeddedData | Represents property EmbeddedData. (Inherited from TShapeList.)
Items[Integer] | Represents property Items[Integer]. (Inherited from TShapeList.)
Top
Methods
Show:
Name | Description
AddShapeData(TShapeData) | Represents method AddShapeData(TShapeData). (Inherited from TShapeList.)
CanvasDistance(Integer,TfrxPoint) | Represents method CanvasDistance(Integer,TfrxPoint). (Inherited from TShapeList.)
CanvasMatrix(Integer) | Represents method CanvasMatrix(Integer). (Inherited from TShapeList.)
CanvasPoint(Integer) | Represents method CanvasPoint(Integer). (Inherited from TShapeList.)
CanvasPoly(Integer) | Represents method CanvasPoly(Integer). (Inherited from TShapeList.)
CanvasRect(Integer) | Represents method CanvasRect(Integer). (Inherited from TShapeList.)
CanvasWidestPartBounds(Integer) | Represents method CanvasWidestPartBounds(Integer). (Inherited from TShapeList.)
ClearValues | Represents method ClearValues. (Inherited from TShapeList.)
Data(Integer,Integer,Integer) | Represents method Data(Integer,Integer,Integer). (Inherited from TShapeList.)
GetColumnList(TStrings) | Represents method GetColumnList(TStrings). (Inherited from TShapeList.)
IsCanvasPolyPoints(Integer,Integer,Extended,Extended,TPointArray) | Represents method IsCanvasPolyPoints(Integer,Integer,Extended,Extended,TPointArray). (Inherited from TShapeList.)
IsGetValues(TDoubleArray) | Represents method IsGetValues(TDoubleArray). (Inherited from TShapeList.)
IsHasLegend(String,String,Integer) | Represents method IsHasLegend(String,String,Integer). (Inherited from TShapeList.)
IsInside(Integer,TfrxPoint) | Represents method IsInside(Integer,TfrxPoint). (Inherited from TShapeList.)
IsMercatorSuitable | Represents method IsMercatorSuitable. (Inherited from TShapeList.)
IsValidMapRect(TfrxRect) | Represents method IsValidMapRect(TfrxRect). (Inherited from TShapeList.)
LoadData(TGPXFile) | Represents method LoadData(TGPXFile).
Read(TReader) | Represents method Read(TReader). (Inherited from TShapeList.)
ReadDFM(TStream) | Represents method ReadDFM(TStream). (Inherited from TShapeList.)
ReplaceShapeData(Integer,TShapeData) | Represents method ReplaceShapeData(Integer,TShapeData). (Inherited from TShapeList.)
SaveToTextFile(String) | Represents method SaveToTextFile(String). (Inherited from TShapeList.)
SetMapRect(Extended,Extended,Extended,Extended) | Represents method SetMapRect(Extended,Extended,Extended,Extended). (Inherited from TShapeList.)
SetMapRectByData | Represents method SetMapRectByData. (Inherited from TShapeList.)
Write(TWriter) | Represents method Write(TWriter). (Inherited from TShapeList.)
WriteDFM(TStream) | Represents method WriteDFM(TStream). (Inherited from TShapeList.)
Top
Fields
Show:
Name | Description
FConverter | Represents field FConverter. (Inherited from TShapeList.)
FValidMapRect | Represents field FValidMapRect. (Inherited from TShapeList.)
FXMax | Represents field FXMax. (Inherited from TShapeList.)
FXMin | Represents field FXMin. (Inherited from TShapeList.)
FYMax | Represents field FYMax. (Inherited from TShapeList.)
FYMin | Represents field FYMin. (Inherited from TShapeList.)
Top
See Also

Reference

  • frxMapShape


TGPXShapeList Constructors

Constructors
Name | Description
CreateFromFile(String,TMapToCanvasCoordinateConverter) | Initializes a new instance of the TGPXShapeList class.
Top


TGPXShapeList.CreateFromFile(String,TMapToCanvasCoordinateConverter) Constructor

Summary

Initializes a new instance of the TGPXShapeList class.

Namespace: frxMapShape
Syntax
Delphi
public
 constructor CreateFromFile(FileName: String; Converter: TMapToCanvasCoordinateConverter);

Parameters

FileName
Type: String

Converter
Type: TMapToCanvasCoordinateConverter

See Also

Reference

  • TGPXShapeList
  • frxMapShape


TGPXShapeList Methods

Methods
Name | Description
LoadData(TGPXFile) | Represents method LoadData(TGPXFile).
Top


TGPXShapeList.LoadData(TGPXFile) Method

Summary

Represents method LoadData(TGPXFile).

Namespace: frxMapShape
Syntax
Delphi
protected
 procedure LoadData(GPXFile: TGPXFile);

Parameters

GPXFile
Type: TGPXFile

See Also

Reference

  • TGPXShapeList
  • frxMapShape


TOSMFileList Class

Summary

Represents type TOSMFileList.

Namespace: frxMapShape
Inheritance Hierarchy
TStringList
frxMapShape.TOSMFileList
Syntax
Delphi
type
 TOSMFileList = class (TStringList)
 end;

The TOSMFileList type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TOSMFileList class.
Destroy | Represents the destructor of the TOSMFileList class.
Top
Methods
Show:
Name | Description
AddFile(String) | Represents method AddFile(String).
FileByName(String) | Represents method FileByName(String).
Top
See Also

Reference

  • frxMapShape


TOSMFileList Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TOSMFileList class.
Destroy | Represents the destructor of the TOSMFileList class.
Top


TOSMFileList.Create Constructor

Summary

Initializes a new instance of the TOSMFileList class.

Namespace: frxMapShape
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TOSMFileList
  • frxMapShape


TOSMFileList.Destroy Destructor

Summary

Represents the destructor of the TOSMFileList class.

Namespace: frxMapShape
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TOSMFileList
  • frxMapShape


TOSMFileList Methods

Methods
Name | Description
AddFile(String) | Represents method AddFile(String).
FileByName(String) | Represents method FileByName(String).
Top


TOSMFileList.AddFile(String) Method

Summary

Represents method AddFile(String).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure AddFile(FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TOSMFileList
  • frxMapShape


TOSMFileList.FileByName(String) Method

Summary

Represents method FileByName(String).

Namespace: frxMapShape
Syntax
Delphi
public
 function FileByName(FileName: String): TOSMFile;

Parameters

FileName
Type: String

Return Value

Type: TOSMFile

See Also

Reference

  • TOSMFileList
  • frxMapShape


TOSMShapeList Class

Summary

Represents type TOSMShapeList.

Namespace: frxMapShape
Inheritance Hierarchy
TObjectList
frxMapShape.TShapeList
frxMapShape.TOSMShapeList
Syntax
Delphi
type
 TOSMShapeList = class (TShapeList)
 end;

The TOSMShapeList type exposes the following members.

Constructors
Show:
Name | Description
Create(TMapToCanvasCoordinateConverter) | Initializes a new instance of the TShapeList class. (Inherited from TShapeList.)
CreateFromFile(String,TMapToCanvasCoordinateConverter,TOSMFileList,TStrings) | Initializes a new instance of the TOSMShapeList class.
Top
Properties
Show:
Name | Description
AdjustableShape | Represents property AdjustableShape. (Inherited from TShapeList.)
EmbeddedData | Represents property EmbeddedData. (Inherited from TShapeList.)
Items[Integer] | Represents property Items[Integer]. (Inherited from TShapeList.)
Top
Methods
Show:
Name | Description
AddShapeData(TShapeData) | Represents method AddShapeData(TShapeData). (Inherited from TShapeList.)
CanvasDistance(Integer,TfrxPoint) | Represents method CanvasDistance(Integer,TfrxPoint). (Inherited from TShapeList.)
CanvasMatrix(Integer) | Represents method CanvasMatrix(Integer). (Inherited from TShapeList.)
CanvasPoint(Integer) | Represents method CanvasPoint(Integer). (Inherited from TShapeList.)
CanvasPoly(Integer) | Represents method CanvasPoly(Integer). (Inherited from TShapeList.)
CanvasRect(Integer) | Represents method CanvasRect(Integer). (Inherited from TShapeList.)
CanvasWidestPartBounds(Integer) | Represents method CanvasWidestPartBounds(Integer). (Inherited from TShapeList.)
ClearValues | Represents method ClearValues. (Inherited from TShapeList.)
Data(Integer,Integer,Integer) | Represents method Data(Integer,Integer,Integer). (Inherited from TShapeList.)
GetColumnList(TStrings) | Represents method GetColumnList(TStrings). (Inherited from TShapeList.)
IsCanvasPolyPoints(Integer,Integer,Extended,Extended,TPointArray) | Represents method IsCanvasPolyPoints(Integer,Integer,Extended,Extended,TPointArray). (Inherited from TShapeList.)
IsGetValues(TDoubleArray) | Represents method IsGetValues(TDoubleArray). (Inherited from TShapeList.)
IsHasLegend(String,String,Integer) | Represents method IsHasLegend(String,String,Integer). (Inherited from TShapeList.)
IsInside(Integer,TfrxPoint) | Represents method IsInside(Integer,TfrxPoint). (Inherited from TShapeList.)
IsMercatorSuitable | Represents method IsMercatorSuitable. (Inherited from TShapeList.)
IsValidMapRect(TfrxRect) | Represents method IsValidMapRect(TfrxRect). (Inherited from TShapeList.)
LoadData(TOSMFile,TStrings) | Represents method LoadData(TOSMFile,TStrings).
Read(TReader) | Represents method Read(TReader). (Inherited from TShapeList.)
ReadDFM(TStream) | Represents method ReadDFM(TStream). (Inherited from TShapeList.)
ReplaceShapeData(Integer,TShapeData) | Represents method ReplaceShapeData(Integer,TShapeData). (Inherited from TShapeList.)
SaveToTextFile(String) | Represents method SaveToTextFile(String). (Inherited from TShapeList.)
SetMapRect(Extended,Extended,Extended,Extended) | Represents method SetMapRect(Extended,Extended,Extended,Extended). (Inherited from TShapeList.)
SetMapRectByData | Represents method SetMapRectByData. (Inherited from TShapeList.)
Write(TWriter) | Represents method Write(TWriter). (Inherited from TShapeList.)
WriteDFM(TStream) | Represents method WriteDFM(TStream). (Inherited from TShapeList.)
Top
Fields
Show:
Name | Description
FConverter | Represents field FConverter. (Inherited from TShapeList.)
FValidMapRect | Represents field FValidMapRect. (Inherited from TShapeList.)
FXMax | Represents field FXMax. (Inherited from TShapeList.)
FXMin | Represents field FXMin. (Inherited from TShapeList.)
FYMax | Represents field FYMax. (Inherited from TShapeList.)
FYMin | Represents field FYMin. (Inherited from TShapeList.)
Top
See Also

Reference

  • frxMapShape


TOSMShapeList Constructors

Constructors
Name | Description
CreateFromFile(String,TMapToCanvasCoordinateConverter,TOSMFileList,TStrings) | Initializes a new instance of the TOSMShapeList class.
Top


TOSMShapeList.CreateFromFile(String,TMapToCanvasCoordinateConverter,TOSMFileList,TStrings) Constructor

Summary

Initializes a new instance of the TOSMShapeList class.

Namespace: frxMapShape
Syntax
Delphi
public
 constructor CreateFromFile(FileName: String; Converter: TMapToCanvasCoordinateConverter;
 FileList: TOSMFileList; LayerTags: TStrings);

Parameters

FileName
Type: String

Converter
Type: TMapToCanvasCoordinateConverter

FileList
Type: TOSMFileList

LayerTags
Type: TStrings

See Also

Reference

  • TOSMShapeList
  • frxMapShape


TOSMShapeList Methods

Methods
Name | Description
LoadData(TOSMFile,TStrings) | Represents method LoadData(TOSMFile,TStrings).
Top


TOSMShapeList.LoadData(TOSMFile,TStrings) Method

Summary

Represents method LoadData(TOSMFile,TStrings).

Namespace: frxMapShape
Syntax
Delphi
protected
 procedure LoadData(OSMFile: TOSMFile; LayerTags: TStrings);

Parameters

OSMFile
Type: TOSMFile

LayerTags
Type: TStrings

See Also

Reference

  • TOSMShapeList
  • frxMapShape


TShape Class

Summary

Represents type TShape.

Namespace: frxMapShape
Inheritance Hierarchy
TPersistent
frxMapShape.TShape
frxMapShape.TAdjustableShape
Syntax
Delphi
type
 TShape = class(TPersistent)
 end;

The TShape type exposes the following members.

Constructors
Show:
Name | Description
CreateClear | Initializes a new instance of the TShape class.
Destroy | Represents the destructor of the TShape class.
Top
Properties
Show:
Name | Description
CenterOffsetX | Represents property CenterOffsetX.
CenterOffsetY | Represents property CenterOffsetY.
Legend[String] | Represents property Legend[String].
OffsetX | Represents property OffsetX.
OffsetY | Represents property OffsetY.
PartCount | Represents property PartCount.
ShapeCenter | Represents property ShapeCenter.
ShapeData | Represents property ShapeData.
ShapeTags | Represents property ShapeTags.
ShapeType | Represents property ShapeType.
Value | Represents property Value.
Zoom | Represents property Zoom.
Top
Methods
Show:
Name | Description
Clear | Represents method Clear.
GetLegend(String) | Represents method GetLegend(String).
GetPartCount | Represents method GetPartCount.
GetShapeCenter | Represents method GetShapeCenter.
GetShapeTags | Represents method GetShapeTags.
GetShapeType | Represents method GetShapeType.
IsMercatorSuitable | Represents method IsMercatorSuitable.
IsValueEmpty | Represents method IsValueEmpty.
Read(TReader) | Represents method Read(TReader).
ReadData(TReader) | Represents method ReadData(TReader).
Write(TWriter) | Represents method Write(TWriter).
WriteData(TWriter) | Represents method WriteData(TWriter).
Top
Fields
Show:
Name | Description
FCenterOffsetX | Represents field FCenterOffsetX.
FCenterOffsetY | Represents field FCenterOffsetY.
FOffsetX | Represents field FOffsetX.
FOffsetY | Represents field FOffsetY.
FShapeData | Represents field FShapeData.
FValue | Represents field FValue.
FZoom | Represents field FZoom.
Top
See Also

Reference

  • frxMapShape


TShape Constructors

Constructors
Name | Description
CreateClear | Initializes a new instance of the TShape class.
Destroy | Represents the destructor of the TShape class.
Top


TShape.CreateClear Constructor

Summary

Initializes a new instance of the TShape class.

Namespace: frxMapShape
Syntax
Delphi
public
 constructor CreateClear;
See Also

Reference

  • TShape
  • frxMapShape


TShape.Destroy Destructor

Summary

Represents the destructor of the TShape class.

Namespace: frxMapShape
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TShape
  • frxMapShape


TShape Properties

Properties
Name | Description
CenterOffsetX | Represents property CenterOffsetX.
CenterOffsetY | Represents property CenterOffsetY.
Legend[String] | Represents property Legend[String].
OffsetX | Represents property OffsetX.
OffsetY | Represents property OffsetY.
PartCount | Represents property PartCount.
ShapeCenter | Represents property ShapeCenter.
ShapeData | Represents property ShapeData.
ShapeTags | Represents property ShapeTags.
ShapeType | Represents property ShapeType.
Value | Represents property Value.
Zoom | Represents property Zoom.
Top


TShape.CenterOffsetX Property

Summary

Represents property CenterOffsetX.

Namespace: frxMapShape
Syntax
Delphi
published
 property CenterOffsetX: Extended read FCenterOffsetX write FCenterOffsetX;

Property Value

Type: Extended

See Also

Reference

  • TShape
  • frxMapShape


TShape.CenterOffsetY Property

Summary

Represents property CenterOffsetY.

Namespace: frxMapShape
Syntax
Delphi
published
 property CenterOffsetY: Extended read FCenterOffsetY write FCenterOffsetY;

Property Value

Type: Extended

See Also

Reference

  • TShape
  • frxMapShape


TShape.Legend[String] Property

Summary

Represents property Legend[String].

Namespace: frxMapShape
Syntax
Delphi
public
 property Legend[const Name: String]: String read GetLegend;

Parameters

Name
Type: String

Property Value

Type: String

See Also

Reference

  • TShape
  • frxMapShape


TShape.OffsetX Property

Summary

Represents property OffsetX.

Namespace: frxMapShape
Syntax
Delphi
public
 property OffsetX: Extended read FOffsetX write FOffsetX;

Property Value

Type: Extended

See Also

Reference

  • TShape
  • frxMapShape


TShape.OffsetY Property

Summary

Represents property OffsetY.

Namespace: frxMapShape
Syntax
Delphi
public
 property OffsetY: Extended read FOffsetY write FOffsetY;

Property Value

Type: Extended

See Also

Reference

  • TShape
  • frxMapShape


TShape.PartCount Property

Summary

Represents property PartCount.

Namespace: frxMapShape
Syntax
Delphi
public
 property PartCount: integer read GetPartCount;

Property Value

Type: integer

See Also

Reference

  • TShape
  • frxMapShape


TShape.ShapeCenter Property

Summary

Represents property ShapeCenter.

Namespace: frxMapShape
Syntax
Delphi
public
 property ShapeCenter: TfrxPoint read GetShapeCenter;

Property Value

Type: TfrxPoint

See Also

Reference

  • TShape
  • frxMapShape


TShape.ShapeData Property

Summary

Represents property ShapeData.

Namespace: frxMapShape
Syntax
Delphi
public
 property ShapeData: TShapeData read FShapeData;

Property Value

Type: TShapeData

See Also

Reference

  • TShape
  • frxMapShape


TShape.ShapeTags Property

Summary

Represents property ShapeTags.

Namespace: frxMapShape
Syntax
Delphi
published
 property ShapeTags: TStringList read GetShapeTags;

Property Value

Type: TStringList

See Also

Reference

  • TShape
  • frxMapShape


TShape.ShapeType Property

Summary

Represents property ShapeType.

Namespace: frxMapShape
Syntax
Delphi
public
 property ShapeType: TShapeType read GetShapeType;

Property Value

Type: TShapeType

See Also

Reference

  • TShape
  • frxMapShape


TShape.Value Property

Summary

Represents property Value.

Namespace: frxMapShape
Syntax
Delphi
public
 property Value: Extended read FValue write FValue;

Property Value

Type: Extended

See Also

Reference

  • TShape
  • frxMapShape


TShape.Zoom Property

Summary

Represents property Zoom.

Namespace: frxMapShape
Syntax
Delphi
public
 property Zoom: Extended read FZoom write FZoom;

Property Value

Type: Extended

See Also

Reference

  • TShape
  • frxMapShape


TShape Methods

Methods
Name | Description
Clear | Represents method Clear.
GetLegend(String) | Represents method GetLegend(String).
GetPartCount | Represents method GetPartCount.
GetShapeCenter | Represents method GetShapeCenter.
GetShapeTags | Represents method GetShapeTags.
GetShapeType | Represents method GetShapeType.
IsMercatorSuitable | Represents method IsMercatorSuitable.
IsValueEmpty | Represents method IsValueEmpty.
Read(TReader) | Represents method Read(TReader).
ReadData(TReader) | Represents method ReadData(TReader).
Write(TWriter) | Represents method Write(TWriter).
WriteData(TWriter) | Represents method WriteData(TWriter).
Top


TShape.Clear Method

Summary

Represents method Clear.

Namespace: frxMapShape
Syntax
Delphi
protected
 procedure Clear; virtual;
See Also

Reference

  • TShape
  • frxMapShape


TShape.GetLegend(String) Method

Summary

Represents method GetLegend(String).

Namespace: frxMapShape
Syntax
Delphi
private
 function GetLegend(const Name: String): String;

Parameters

Name
Type: String

Return Value

Type: String

See Also

Reference

  • TShape
  • frxMapShape


TShape.GetPartCount Method

Summary

Represents method GetPartCount.

Namespace: frxMapShape
Syntax
Delphi
private
 function GetPartCount: integer;

Return Value

Type: integer

See Also

Reference

  • TShape
  • frxMapShape


TShape.GetShapeCenter Method

Summary

Represents method GetShapeCenter.

Namespace: frxMapShape
Syntax
Delphi
private
 function GetShapeCenter: TfrxPoint;

Return Value

Type: TfrxPoint

See Also

Reference

  • TShape
  • frxMapShape


TShape.GetShapeTags Method

Summary

Represents method GetShapeTags.

Namespace: frxMapShape
Syntax
Delphi
private
 function GetShapeTags: TStringList;

Return Value

Type: TStringList

See Also

Reference

  • TShape
  • frxMapShape


TShape.GetShapeType Method

Summary

Represents method GetShapeType.

Namespace: frxMapShape
Syntax
Delphi
private
 function GetShapeType: TShapeType;

Return Value

Type: TShapeType

See Also

Reference

  • TShape
  • frxMapShape


TShape.IsMercatorSuitable Method

Summary

Represents method IsMercatorSuitable.

Namespace: frxMapShape
Syntax
Delphi
public
 function IsMercatorSuitable: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TShape
  • frxMapShape


TShape.IsValueEmpty Method

Summary

Represents method IsValueEmpty.

Namespace: frxMapShape
Syntax
Delphi
public
 function IsValueEmpty: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TShape
  • frxMapShape


TShape.Read(TReader) Method

Summary

Represents method Read(TReader).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure Read(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TShape
  • frxMapShape


TShape.ReadData(TReader) Method

Summary

Represents method ReadData(TReader).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure ReadData(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TShape
  • frxMapShape


TShape.Write(TWriter) Method

Summary

Represents method Write(TWriter).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure Write(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TShape
  • frxMapShape


TShape.WriteData(TWriter) Method

Summary

Represents method WriteData(TWriter).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure WriteData(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TShape
  • frxMapShape


TShape Fields

Fields
Name | Description
FCenterOffsetX | Represents field FCenterOffsetX.
FCenterOffsetY | Represents field FCenterOffsetY.
FOffsetX | Represents field FOffsetX.
FOffsetY | Represents field FOffsetY.
FShapeData | Represents field FShapeData.
FValue | Represents field FValue.
FZoom | Represents field FZoom.
Top


TShape.FCenterOffsetX Field

Summary

Represents field FCenterOffsetX.

Namespace: frxMapShape
Syntax
Delphi
private
 FCenterOffsetX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TShape
  • frxMapShape


TShape.FCenterOffsetY Field

Summary

Represents field FCenterOffsetY.

Namespace: frxMapShape
Syntax
Delphi
private
 FCenterOffsetY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TShape
  • frxMapShape


TShape.FOffsetX Field

Summary

Represents field FOffsetX.

Namespace: frxMapShape
Syntax
Delphi
private
 FOffsetX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TShape
  • frxMapShape


TShape.FOffsetY Field

Summary

Represents field FOffsetY.

Namespace: frxMapShape
Syntax
Delphi
private
 FOffsetY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TShape
  • frxMapShape


TShape.FShapeData Field

Summary

Represents field FShapeData.

Namespace: frxMapShape
Syntax
Delphi
protected
 FShapeData: TShapeData;

Field Value

Type: TShapeData

See Also

Reference

  • TShape
  • frxMapShape


TShape.FValue Field

Summary

Represents field FValue.

Namespace: frxMapShape
Syntax
Delphi
private
 FValue: Extended;

Field Value

Type: Extended

See Also

Reference

  • TShape
  • frxMapShape


TShape.FZoom Field

Summary

Represents field FZoom.

Namespace: frxMapShape
Syntax
Delphi
private
 FZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TShape
  • frxMapShape


TShapeList Class

Summary

Represents type TShapeList.

Namespace: frxMapShape
Inheritance Hierarchy
TObjectList
frxMapShape.TShapeList
frxMapShape.TERSIShapeList
frxMapShape.TGPXShapeList
frxMapShape.TOSMShapeList
Syntax
Delphi
type
 TShapeList = class(TObjectList)
 end;

The TShapeList type exposes the following members.

Constructors
Show:
Name | Description
Create(TMapToCanvasCoordinateConverter) | Initializes a new instance of the TShapeList class.
Top
Properties
Show:
Name | Description
AdjustableShape | Represents property AdjustableShape.
EmbeddedData | Represents property EmbeddedData.
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
AddShapeData(TShapeData) | Represents method AddShapeData(TShapeData).
CanvasDistance(Integer,TfrxPoint) | Represents method CanvasDistance(Integer,TfrxPoint).
CanvasMatrix(Integer) | Represents method CanvasMatrix(Integer).
CanvasPoint(Integer) | Represents method CanvasPoint(Integer).
CanvasPoly(Integer) | Represents method CanvasPoly(Integer).
CanvasRect(Integer) | Represents method CanvasRect(Integer).
CanvasWidestPartBounds(Integer) | Represents method CanvasWidestPartBounds(Integer).
ClearValues | Represents method ClearValues.
Data(Integer,Integer,Integer) | Represents method Data(Integer,Integer,Integer).
GetColumnList(TStrings) | Represents method GetColumnList(TStrings).
GetShape(Integer) | Represents method GetShape(Integer).
IsCanvasPolyPoints(Integer,Integer,Extended,Extended,TPointArray) | Represents method IsCanvasPolyPoints(Integer,Integer,Extended,Extended,TPointArray).
IsGetValues(TDoubleArray) | Represents method IsGetValues(TDoubleArray).
IsHasLegend(String,String,Integer) | Represents method IsHasLegend(String,String,Integer).
IsInside(Integer,TfrxPoint) | Represents method IsInside(Integer,TfrxPoint).
IsMercatorSuitable | Represents method IsMercatorSuitable.
IsValidMapRect(TfrxRect) | Represents method IsValidMapRect(TfrxRect).
Read(TReader) | Represents method Read(TReader).
ReadDFM(TStream) | Represents method ReadDFM(TStream).
ReplaceShapeData(Integer,TShapeData) | Represents method ReplaceShapeData(Integer,TShapeData).
SaveToTextFile(String) | Represents method SaveToTextFile(String).
SetMapRect(Extended,Extended,Extended,Extended) | Represents method SetMapRect(Extended,Extended,Extended,Extended).
SetMapRectByData | Represents method SetMapRectByData.
SetShape(Integer,TShape) | Represents method SetShape(Integer,TShape).
Write(TWriter) | Represents method Write(TWriter).
WriteDFM(TStream) | Represents method WriteDFM(TStream).
Top
Fields
Show:
Name | Description
FAdjustableShape | Represents field FAdjustableShape.
FConverter | Represents field FConverter.
FEmbeddedData | Represents field FEmbeddedData.
FValidMapRect | Represents field FValidMapRect.
FXMax | Represents field FXMax.
FXMin | Represents field FXMin.
FYMax | Represents field FYMax.
FYMin | Represents field FYMin.
Top
See Also

Reference

  • frxMapShape


TShapeList Constructors

Constructors
Name | Description
Create(TMapToCanvasCoordinateConverter) | Initializes a new instance of the TShapeList class.
Top


TShapeList.Create(TMapToCanvasCoordinateConverter) Constructor

Summary

Initializes a new instance of the TShapeList class.

Namespace: frxMapShape
Syntax
Delphi
public
 constructor Create(Converter: TMapToCanvasCoordinateConverter);

Parameters

Converter
Type: TMapToCanvasCoordinateConverter

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList Properties

Properties
Name | Description
AdjustableShape | Represents property AdjustableShape.
EmbeddedData | Represents property EmbeddedData.
Items[Integer] | Represents property Items[Integer].
Top


TShapeList.AdjustableShape Property

Summary

Represents property AdjustableShape.

Namespace: frxMapShape
Syntax
Delphi
public
 property AdjustableShape: Boolean read FAdjustableShape write FAdjustableShape;

Property Value

Type: Boolean

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.EmbeddedData Property

Summary

Represents property EmbeddedData.

Namespace: frxMapShape
Syntax
Delphi
public
 property EmbeddedData: Boolean read FEmbeddedData write FEmbeddedData;

Property Value

Type: Boolean

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxMapShape
Syntax
Delphi
public
 property Items[Index: Integer]: TShape read GetShape write SetShape; default;

Parameters

Index
Type: Integer

Property Value

Type: TShape

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList Methods

Methods
Name | Description
AddShapeData(TShapeData) | Represents method AddShapeData(TShapeData).
CanvasDistance(Integer,TfrxPoint) | Represents method CanvasDistance(Integer,TfrxPoint).
CanvasMatrix(Integer) | Represents method CanvasMatrix(Integer).
CanvasPoint(Integer) | Represents method CanvasPoint(Integer).
CanvasPoly(Integer) | Represents method CanvasPoly(Integer).
CanvasRect(Integer) | Represents method CanvasRect(Integer).
CanvasWidestPartBounds(Integer) | Represents method CanvasWidestPartBounds(Integer).
ClearValues | Represents method ClearValues.
Data(Integer,Integer,Integer) | Represents method Data(Integer,Integer,Integer).
GetColumnList(TStrings) | Represents method GetColumnList(TStrings).
GetShape(Integer) | Represents method GetShape(Integer).
IsCanvasPolyPoints(Integer,Integer,Extended,Extended,TPointArray) | Represents method IsCanvasPolyPoints(Integer,Integer,Extended,Extended,TPointArray).
IsGetValues(TDoubleArray) | Represents method IsGetValues(TDoubleArray).
IsHasLegend(String,String,Integer) | Represents method IsHasLegend(String,String,Integer).
IsInside(Integer,TfrxPoint) | Represents method IsInside(Integer,TfrxPoint).
IsMercatorSuitable | Represents method IsMercatorSuitable.
IsValidMapRect(TfrxRect) | Represents method IsValidMapRect(TfrxRect).
Read(TReader) | Represents method Read(TReader).
ReadDFM(TStream) | Represents method ReadDFM(TStream).
ReplaceShapeData(Integer,TShapeData) | Represents method ReplaceShapeData(Integer,TShapeData).
SaveToTextFile(String) | Represents method SaveToTextFile(String).
SetMapRect(Extended,Extended,Extended,Extended) | Represents method SetMapRect(Extended,Extended,Extended,Extended).
SetMapRectByData | Represents method SetMapRectByData.
SetShape(Integer,TShape) | Represents method SetShape(Integer,TShape).
Write(TWriter) | Represents method Write(TWriter).
WriteDFM(TStream) | Represents method WriteDFM(TStream).
Top


TShapeList.AddShapeData(TShapeData) Method

Summary

Represents method AddShapeData(TShapeData).

Namespace: frxMapShape
Syntax
Delphi
public
 function AddShapeData(const AShapeData: TShapeData): integer;

Parameters

AShapeData
Type: TShapeData

Return Value

Type: integer

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.CanvasDistance(Integer,TfrxPoint) Method

Summary

Represents method CanvasDistance(Integer,TfrxPoint).

Namespace: frxMapShape
Syntax
Delphi
public
 function CanvasDistance(iRecord: Integer; P: TfrxPoint): Extended;

Parameters

iRecord
Type: Integer

P
Type: TfrxPoint

Return Value

Type: Extended

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.CanvasMatrix(Integer) Method

Summary

Represents method CanvasMatrix(Integer).

Namespace: frxMapShape
Syntax
Delphi
public
 function CanvasMatrix(iRecord: Integer): TDoublePointMatrix;

Parameters

iRecord
Type: Integer

Return Value

Type: TDoublePointMatrix

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.CanvasPoint(Integer) Method

Summary

Represents method CanvasPoint(Integer).

Namespace: frxMapShape
Syntax
Delphi
public
 function CanvasPoint(iRecord: Integer): TfrxPoint;

Parameters

iRecord
Type: Integer

Return Value

Type: TfrxPoint

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.CanvasPoly(Integer) Method

Summary

Represents method CanvasPoly(Integer).

Namespace: frxMapShape
Syntax
Delphi
public
 function CanvasPoly(iRecord: Integer): TDoublePointArray;

Parameters

iRecord
Type: Integer

Return Value

Type: TDoublePointArray

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.CanvasRect(Integer) Method

Summary

Represents method CanvasRect(Integer).

Namespace: frxMapShape
Syntax
Delphi
public
 function CanvasRect(iRecord: Integer): TDoubleRect;

Parameters

iRecord
Type: Integer

Return Value

Type: TDoubleRect

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.CanvasWidestPartBounds(Integer) Method

Summary

Represents method CanvasWidestPartBounds(Integer).

Namespace: frxMapShape
Syntax
Delphi
public
 function CanvasWidestPartBounds(iRecord: Integer): TfrxRect;

Parameters

iRecord
Type: Integer

Return Value

Type: TfrxRect

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.ClearValues Method

Summary

Represents method ClearValues.

Namespace: frxMapShape
Syntax
Delphi
public
 procedure ClearValues;
See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.Data(Integer,Integer,Integer) Method

Summary

Represents method Data(Integer,Integer,Integer).

Namespace: frxMapShape
Syntax
Delphi
protected
 function Data(iRecord, iPart, iPoint: Integer): TDoublePoint;

Parameters

iRecord
Type: Integer

iPart
Type: Integer

iPoint
Type: Integer

Return Value

Type: TDoublePoint

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.GetColumnList(TStrings) Method

Summary

Represents method GetColumnList(TStrings).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure GetColumnList(List: TStrings);

Parameters

List
Type: TStrings

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.GetShape(Integer) Method

Summary

Represents method GetShape(Integer).

Namespace: frxMapShape
Syntax
Delphi
private
 function GetShape(Index: Integer): TShape;

Parameters

Index
Type: Integer

Return Value

Type: TShape

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.IsCanvasPolyPoints(Integer,Integer,Extended,Extended,TPointArray) Method

Summary

Represents method IsCanvasPolyPoints(Integer,Integer,Extended,Extended,TPointArray).

Namespace: frxMapShape
Syntax
Delphi
public
 function IsCanvasPolyPoints(iRecord, iPart: Integer; MapAccuracy, PixelAccuracy: Extended; var PolyPoints: TPointArray): boolean;

Parameters

iRecord
Type: Integer

iPart
Type: Integer

MapAccuracy
Type: Extended

PixelAccuracy
Type: Extended

PolyPoints
Type: TPointArray

Return Value

Type: boolean

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.IsGetValues(TDoubleArray) Method

Summary

Represents method IsGetValues(TDoubleArray).

Namespace: frxMapShape
Syntax
Delphi
public
 function IsGetValues(var Values: TDoubleArray): boolean;

Parameters

Values
Type: TDoubleArray

Return Value

Type: boolean

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.IsHasLegend(String,String,Integer) Method

Summary

Represents method IsHasLegend(String,String,Integer).

Namespace: frxMapShape
Syntax
Delphi
public
 function IsHasLegend(FieldName: String; Legend: String; out iRecord: Integer): boolean;

Parameters

FieldName
Type: String

Legend
Type: String

iRecord
Type: Integer

Return Value

Type: boolean

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.IsInside(Integer,TfrxPoint) Method

Summary

Represents method IsInside(Integer,TfrxPoint).

Namespace: frxMapShape
Syntax
Delphi
public
 function IsInside(iRecord: Integer; P: TfrxPoint): Boolean;

Parameters

iRecord
Type: Integer

P
Type: TfrxPoint

Return Value

Type: Boolean

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.IsMercatorSuitable Method

Summary

Represents method IsMercatorSuitable.

Namespace: frxMapShape
Syntax
Delphi
public
 function IsMercatorSuitable: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.IsValidMapRect(TfrxRect) Method

Summary

Represents method IsValidMapRect(TfrxRect).

Namespace: frxMapShape
Syntax
Delphi
public
 function IsValidMapRect(out MapRect: TfrxRect): boolean;

Parameters

MapRect
Type: TfrxRect

Return Value

Type: boolean

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.Read(TReader) Method

Summary

Represents method Read(TReader).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure Read(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.ReadDFM(TStream) Method

Summary

Represents method ReadDFM(TStream).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure ReadDFM(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.ReplaceShapeData(Integer,TShapeData) Method

Summary

Represents method ReplaceShapeData(Integer,TShapeData).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure ReplaceShapeData(iRecord: Integer; const AShapeData: TShapeData);

Parameters

iRecord
Type: Integer

AShapeData
Type: TShapeData

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.SaveToTextFile(String) Method

Summary

Represents method SaveToTextFile(String).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure SaveToTextFile(FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.SetMapRect(Extended,Extended,Extended,Extended) Method

Summary

Represents method SetMapRect(Extended,Extended,Extended,Extended).

Namespace: frxMapShape
Syntax
Delphi
protected
 procedure SetMapRect(XMin, XMax, YMin, YMax: Extended);

Parameters

XMin
Type: Extended

XMax
Type: Extended

YMin
Type: Extended

YMax
Type: Extended

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.SetMapRectByData Method

Summary

Represents method SetMapRectByData.

Namespace: frxMapShape
Syntax
Delphi
public
 procedure SetMapRectByData;
See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.SetShape(Integer,TShape) Method

Summary

Represents method SetShape(Integer,TShape).

Namespace: frxMapShape
Syntax
Delphi
private
 procedure SetShape(Index: Integer; const AShape: TShape);

Parameters

Index
Type: Integer

AShape
Type: TShape

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.Write(TWriter) Method

Summary

Represents method Write(TWriter).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure Write(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.WriteDFM(TStream) Method

Summary

Represents method WriteDFM(TStream).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure WriteDFM(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList Fields

Fields
Name | Description
FAdjustableShape | Represents field FAdjustableShape.
FConverter | Represents field FConverter.
FEmbeddedData | Represents field FEmbeddedData.
FValidMapRect | Represents field FValidMapRect.
FXMax | Represents field FXMax.
FXMin | Represents field FXMin.
FYMax | Represents field FYMax.
FYMin | Represents field FYMin.
Top


TShapeList.FAdjustableShape Field

Summary

Represents field FAdjustableShape.

Namespace: frxMapShape
Syntax
Delphi
private
 FAdjustableShape: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.FConverter Field

Summary

Represents field FConverter.

Namespace: frxMapShape
Syntax
Delphi
protected
 FConverter: TMapToCanvasCoordinateConverter;

Field Value

Type: TMapToCanvasCoordinateConverter

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.FEmbeddedData Field

Summary

Represents field FEmbeddedData.

Namespace: frxMapShape
Syntax
Delphi
private
 FEmbeddedData: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.FValidMapRect Field

Summary

Represents field FValidMapRect.

Namespace: frxMapShape
Syntax
Delphi
protected
 FValidMapRect: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.FXMax Field

Summary

Represents field FXMax.

Namespace: frxMapShape
Syntax
Delphi
protected
 FXMin, FXMax, FYMin, FYMax: Extended;

Field Value

Type: Extended

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.FXMin Field

Summary

Represents field FXMin.

Namespace: frxMapShape
Syntax
Delphi
protected
 FXMin, FXMax, FYMin, FYMax: Extended;

Field Value

Type: Extended

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.FYMax Field

Summary

Represents field FYMax.

Namespace: frxMapShape
Syntax
Delphi
protected
 FXMin, FXMax, FYMin, FYMax: Extended;

Field Value

Type: Extended

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeList.FYMin Field

Summary

Represents field FYMin.

Namespace: frxMapShape
Syntax
Delphi
protected
 FXMin, FXMax, FYMin, FYMax: Extended;

Field Value

Type: Extended

See Also

Reference

  • TShapeList
  • frxMapShape


TShapeStyle Class

Summary

Represents type TShapeStyle.

Namespace: frxMapShape
Inheritance Hierarchy
TPersistent
frxMapShape.TShapeStyle
Syntax
Delphi
type
 TShapeStyle = class(TPersistent)
 end;

The TShapeStyle type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TShapeStyle class.
Top
Properties
Show:
Name | Description
BorderColor | Represents property BorderColor.
BorderStyle | Represents property BorderStyle.
BorderWidth | Represents property BorderWidth.
FillColor | Represents property FillColor.
PointSize | Represents property PointSize.
Top
Methods
Show:
Name | Description
TunePen(TPen) | Represents method TunePen(TPen).
Top
Fields
Show:
Name | Description
FBorderColor | Represents field FBorderColor.
FBorderStyle | Represents field FBorderStyle.
FBorderWidth | Represents field FBorderWidth.
FFillColor | Represents field FFillColor.
FPointSize | Represents field FPointSize.
Top
See Also

Reference

  • frxMapShape


TShapeStyle Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TShapeStyle class.
Top


TShapeStyle.Create Constructor

Summary

Initializes a new instance of the TShapeStyle class.

Namespace: frxMapShape
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TShapeStyle
  • frxMapShape


TShapeStyle Properties

Properties
Name | Description
BorderColor | Represents property BorderColor.
BorderStyle | Represents property BorderStyle.
BorderWidth | Represents property BorderWidth.
FillColor | Represents property FillColor.
PointSize | Represents property PointSize.
Top


TShapeStyle.BorderColor Property

Summary

Represents property BorderColor.

Namespace: frxMapShape
Syntax
Delphi
published
 property BorderColor: TColor read FBorderColor write FBorderColor;

Property Value

Type: TColor

See Also

Reference

  • TShapeStyle
  • frxMapShape


TShapeStyle.BorderStyle Property

Summary

Represents property BorderStyle.

Namespace: frxMapShape
Syntax
Delphi
published
 property BorderStyle: TPenStyle read FBorderStyle write FBorderStyle;

Property Value

Type: TPenStyle

See Also

Reference

  • TShapeStyle
  • frxMapShape


TShapeStyle.BorderWidth Property

Summary

Represents property BorderWidth.

Namespace: frxMapShape
Syntax
Delphi
published
 property BorderWidth: Integer read FBorderWidth write FBorderWidth;

Property Value

Type: Integer

See Also

Reference

  • TShapeStyle
  • frxMapShape


TShapeStyle.FillColor Property

Summary

Represents property FillColor.

Namespace: frxMapShape
Syntax
Delphi
published
 property FillColor: TColor read FFillColor write FFillColor;

Property Value

Type: TColor

See Also

Reference

  • TShapeStyle
  • frxMapShape


TShapeStyle.PointSize Property

Summary

Represents property PointSize.

Namespace: frxMapShape
Syntax
Delphi
published
 property PointSize: Extended read FPointSize write FPointSize;

Property Value

Type: Extended

See Also

Reference

  • TShapeStyle
  • frxMapShape


TShapeStyle Methods

Methods
Name | Description
TunePen(TPen) | Represents method TunePen(TPen).
Top


TShapeStyle.TunePen(TPen) Method

Summary

Represents method TunePen(TPen).

Namespace: frxMapShape
Syntax
Delphi
public
 procedure TunePen(Pen: TPen);

Parameters

Pen
Type: TPen

See Also

Reference

  • TShapeStyle
  • frxMapShape


TShapeStyle Fields

Fields
Name | Description
FBorderColor | Represents field FBorderColor.
FBorderStyle | Represents field FBorderStyle.
FBorderWidth | Represents field FBorderWidth.
FFillColor | Represents field FFillColor.
FPointSize | Represents field FPointSize.
Top


TShapeStyle.FBorderColor Field

Summary

Represents field FBorderColor.

Namespace: frxMapShape
Syntax
Delphi
private
 FBorderColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TShapeStyle
  • frxMapShape


TShapeStyle.FBorderStyle Field

Summary

Represents field FBorderStyle.

Namespace: frxMapShape
Syntax
Delphi
private
 FBorderStyle: TPenStyle;

Field Value

Type: TPenStyle

See Also

Reference

  • TShapeStyle
  • frxMapShape


TShapeStyle.FBorderWidth Field

Summary

Represents field FBorderWidth.

Namespace: frxMapShape
Syntax
Delphi
private
 FBorderWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TShapeStyle
  • frxMapShape


TShapeStyle.FFillColor Field

Summary

Represents field FFillColor.

Namespace: frxMapShape
Syntax
Delphi
private
 FFillColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TShapeStyle
  • frxMapShape


TShapeStyle.FPointSize Field

Summary

Represents field FPointSize.

Namespace: frxMapShape
Syntax
Delphi
private
 FPointSize: Extended;

Field Value

Type: Extended

See Also

Reference

  • TShapeStyle
  • frxMapShape


frxMapShapeTags Namespace

Summary

Represents namespace frxMapShapeTags.

Classes
Name | Description
TMapShapeTagsForm | Represents type TMapShapeTagsForm.
Top


frxMapShapeTags Classes

Classes
Name | Description
TMapShapeTagsForm | Represents type TMapShapeTagsForm.
Top


TMapShapeTagsForm Class

Summary

Represents type TMapShapeTagsForm.

Namespace: frxMapShapeTags
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxMapShapeTags.TMapShapeTagsForm
Syntax
Delphi
type
 TMapShapeTagsForm = class(TfrxBaseForm)
 end;

The TMapShapeTagsForm type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseForm class. (Inherited from TfrxBaseForm.)
Top
Properties
Show:
Name | Description
CurrentFormPPI | Returns current PPI value of the form. (Inherited from TfrxBaseForm.)
IsPPIChanging | Represents property IsPPIChanging. (Inherited from TfrxBaseForm.)
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseForm.)
AfterPPIChange | Represents method AfterPPIChange. (Inherited from TfrxBaseForm.)
AfterPPIMessage | Represents method AfterPPIMessage. (Inherited from TfrxBaseForm.)
BeforeDestruction | Represents method BeforeDestruction. (Inherited from TfrxBaseForm.)
BeforePPIChange | Represents method BeforePPIChange. (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer). (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean). (Inherited from TfrxBaseForm.)
DoClose(TCloseAction) | Represents method DoClose(TCloseAction). (Inherited from TfrxBaseForm.)
DoShow | Represents method DoShow. (Inherited from TfrxBaseForm.)
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer). (Inherited from TfrxBaseForm.)
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
FormShowAfterLoad | Represents method FormShowAfterLoad. (Inherited from TfrxBaseForm.)
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Inherited from TfrxBaseForm.)
GetAvailablePreferences | Represents method GetAvailablePreferences. (Inherited from TfrxBaseForm.)
GetFormSectionName | Represents method GetFormSectionName. (Inherited from TfrxBaseForm.)
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Inherited from TfrxBaseForm.)
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Inherited from TfrxBaseForm.)
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter. (Inherited from TfrxBaseForm.)
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Inherited from TfrxBaseForm.)
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxBaseForm.)
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms. (Inherited from TfrxBaseForm.)
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form. (Inherited from TfrxBaseForm.)
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Inherited from TfrxBaseForm.)
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Overrides TfrxBaseForm.UpdateResouces.)
Top
Fields
Show:
Name | Description
CancelB | Represents field CancelB.
FHostedControls | Represents field FHostedControls. (Inherited from TfrxBaseForm.)
FPrefEvent | Represents field FPrefEvent. (Inherited from TfrxBaseForm.)
Memo | Represents field Memo.
OkB | Represents field OkB.
Top
See Also

Reference

  • frxMapShapeTags


TMapShapeTagsForm Methods

Methods
Name | Description
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Overrides TfrxBaseForm.UpdateResouces.)
Top


TMapShapeTagsForm.FormKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method FormKeyDown(TObject,Word,TShiftState).

Namespace: frxMapShapeTags
Syntax
Delphi
published
 procedure FormKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TMapShapeTagsForm
  • frxMapShapeTags


TMapShapeTagsForm.UpdateResouces Method

Summary

Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources.

Namespace: frxMapShapeTags
Syntax
Delphi
public
 procedure UpdateResouces; override;

Overrides

TfrxBaseForm.UpdateResouces
See Also

Reference

  • TMapShapeTagsForm
  • frxMapShapeTags


TMapShapeTagsForm Fields

Fields
Name | Description
CancelB | Represents field CancelB.
Memo | Represents field Memo.
OkB | Represents field OkB.
Top


TMapShapeTagsForm.CancelB Field

Summary

Represents field CancelB.

Namespace: frxMapShapeTags
Syntax
Delphi
published
 CancelB: TButton;

Field Value

Type: TButton

See Also

Reference

  • TMapShapeTagsForm
  • frxMapShapeTags


TMapShapeTagsForm.Memo Field

Summary

Represents field Memo.

Namespace: frxMapShapeTags
Syntax
Delphi
published
 Memo: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TMapShapeTagsForm
  • frxMapShapeTags


TMapShapeTagsForm.OkB Field

Summary

Represents field OkB.

Namespace: frxMapShapeTags
Syntax
Delphi
published
 OkB: TButton;

Field Value

Type: TButton

See Also

Reference

  • TMapShapeTagsForm
  • frxMapShapeTags


frxmd5 Namespace

Classes
Name | Description
TfrxMD5 | Represents type TfrxMD5.
Top
Types
Name | Description
Puchar | Represents a pointer type to uchar.
Puint4 | Represents a pointer type to uint4.
uchar | Represents an alias of the byte type.
uint4 | Represents an alias of the longword type.
Top
Constants
Name | Description
MD5_INIT_STATE_0 | Represents constant MD5_INIT_STATE_0.
MD5_INIT_STATE_1 | Represents constant MD5_INIT_STATE_1.
MD5_INIT_STATE_2 | Represents constant MD5_INIT_STATE_2.
MD5_INIT_STATE_3 | Represents constant MD5_INIT_STATE_3.
MD5_S11 | Represents constant MD5_S11.
MD5_S12 | Represents constant MD5_S12.
MD5_S13 | Represents constant MD5_S13.
MD5_S14 | Represents constant MD5_S14.
MD5_S21 | Represents constant MD5_S21.
MD5_S22 | Represents constant MD5_S22.
MD5_S23 | Represents constant MD5_S23.
MD5_S24 | Represents constant MD5_S24.
MD5_S31 | Represents constant MD5_S31.
MD5_S32 | Represents constant MD5_S32.
MD5_S33 | Represents constant MD5_S33.
MD5_S34 | Represents constant MD5_S34.
MD5_S41 | Represents constant MD5_S41.
MD5_S42 | Represents constant MD5_S42.
MD5_S43 | Represents constant MD5_S43.
MD5_S44 | Represents constant MD5_S44.
MD5_T01 | Represents constant MD5_T01.
MD5_T02 | Represents constant MD5_T02.
MD5_T03 | Represents constant MD5_T03.
MD5_T04 | Represents constant MD5_T04.
MD5_T05 | Represents constant MD5_T05.
MD5_T06 | Represents constant MD5_T06.
MD5_T07 | Represents constant MD5_T07.
MD5_T08 | Represents constant MD5_T08.
MD5_T09 | Represents constant MD5_T09.
MD5_T10 | Represents constant MD5_T10.
MD5_T11 | Represents constant MD5_T11.
MD5_T12 | Represents constant MD5_T12.
MD5_T13 | Represents constant MD5_T13.
MD5_T14 | Represents constant MD5_T14.
MD5_T15 | Represents constant MD5_T15.
MD5_T16 | Represents constant MD5_T16.
MD5_T17 | Represents constant MD5_T17.
MD5_T18 | Represents constant MD5_T18.
MD5_T19 | Represents constant MD5_T19.
MD5_T20 | Represents constant MD5_T20.
MD5_T21 | Represents constant MD5_T21.
MD5_T22 | Represents constant MD5_T22.
MD5_T23 | Represents constant MD5_T23.
MD5_T24 | Represents constant MD5_T24.
MD5_T25 | Represents constant MD5_T25.
MD5_T26 | Represents constant MD5_T26.
MD5_T27 | Represents constant MD5_T27.
MD5_T28 | Represents constant MD5_T28.
MD5_T29 | Represents constant MD5_T29.
MD5_T30 | Represents constant MD5_T30.
MD5_T31 | Represents constant MD5_T31.
MD5_T32 | Represents constant MD5_T32.
MD5_T33 | Represents constant MD5_T33.
MD5_T34 | Represents constant MD5_T34.
MD5_T35 | Represents constant MD5_T35.
MD5_T36 | Represents constant MD5_T36.
MD5_T37 | Represents constant MD5_T37.
MD5_T38 | Represents constant MD5_T38.
MD5_T39 | Represents constant MD5_T39.
MD5_T40 | Represents constant MD5_T40.
MD5_T41 | Represents constant MD5_T41.
MD5_T42 | Represents constant MD5_T42.
MD5_T43 | Represents constant MD5_T43.
MD5_T44 | Represents constant MD5_T44.
MD5_T45 | Represents constant MD5_T45.
MD5_T46 | Represents constant MD5_T46.
MD5_T47 | Represents constant MD5_T47.
MD5_T48 | Represents constant MD5_T48.
MD5_T49 | Represents constant MD5_T49.
MD5_T50 | Represents constant MD5_T50.
MD5_T51 | Represents constant MD5_T51.
MD5_T52 | Represents constant MD5_T52.
MD5_T53 | Represents constant MD5_T53.
MD5_T54 | Represents constant MD5_T54.
MD5_T55 | Represents constant MD5_T55.
MD5_T56 | Represents constant MD5_T56.
MD5_T57 | Represents constant MD5_T57.
MD5_T58 | Represents constant MD5_T58.
MD5_T59 | Represents constant MD5_T59.
MD5_T60 | Represents constant MD5_T60.
MD5_T61 | Represents constant MD5_T61.
MD5_T62 | Represents constant MD5_T62.
MD5_T63 | Represents constant MD5_T63.
MD5_T64 | Represents constant MD5_T64.
PADDING | Represents constant PADDING.
Top
Routines
Name | Description
MD5Buf(Pointer,Integer,Pointer) | Represents method MD5Buf(Pointer,Integer,Pointer).
MD5File(String) | Represents method MD5File(String).
MD5Stream(TStream) | Represents method MD5Stream(TStream).
MD5String(AnsiString) | Represents method MD5String(AnsiString).
PrintMD5(Puchar) | Represents method PrintMD5(Puchar).
Top


frxMD5 Classes

Classes
Name | Description
TfrxMD5 | Represents type TfrxMD5.
Top


TfrxMD5 Class

Summary

Represents type TfrxMD5.

Namespace: frxmd5
Inheritance Hierarchy
TObject
frxmd5.TfrxMD5
Syntax
Delphi
type
 TfrxMD5 = class (TObject)
 end;

The TfrxMD5 type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxMD5 class.
Top
Methods
Show:
Name | Description
Decode(Puint4,Puchar,uint4) | Represents method Decode(Puint4,Puchar,uint4).
Digest | Represents method Digest.
Encode(Puchar,Puint4,uint4) | Represents method Encode(Puchar,Puint4,uint4).
FF(uint4,uint4,uint4,uint4,uint4,uint4,uint4) | Represents method FF(uint4,uint4,uint4,uint4,uint4,uint4,uint4).
Finalize | Represents method Finalize.
GG(uint4,uint4,uint4,uint4,uint4,uint4,uint4) | Represents method GG(uint4,uint4,uint4,uint4,uint4,uint4,uint4).
HH(uint4,uint4,uint4,uint4,uint4,uint4,uint4) | Represents method HH(uint4,uint4,uint4,uint4,uint4,uint4,uint4).
II(uint4,uint4,uint4,uint4,uint4,uint4,uint4) | Represents method II(uint4,uint4,uint4,uint4,uint4,uint4,uint4).
Init | Represents method Init.
RotateLeft(uint4,uint4) | Represents method RotateLeft(uint4,uint4).
Transform(Puchar) | Represents method Transform(Puchar).
Update(Puchar,uint4) | Represents method Update(Puchar,uint4).
Top
Fields
Show:
Name | Description
m_Buffer | Represents field m_Buffer.
m_Count | Represents field m_Count.
m_Digest | Represents field m_Digest.
m_State | Represents field m_State.
Top
See Also

Reference

  • frxmd5


TfrxMD5 Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxMD5 class.
Top


TfrxMD5.Create Constructor

Summary

Initializes a new instance of the TfrxMD5 class.

Namespace: frxmd5
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5 Methods

Methods
Name | Description
Decode(Puint4,Puchar,uint4) | Represents method Decode(Puint4,Puchar,uint4).
Digest | Represents method Digest.
Encode(Puchar,Puint4,uint4) | Represents method Encode(Puchar,Puint4,uint4).
FF(uint4,uint4,uint4,uint4,uint4,uint4,uint4) | Represents method FF(uint4,uint4,uint4,uint4,uint4,uint4,uint4).
Finalize | Represents method Finalize.
GG(uint4,uint4,uint4,uint4,uint4,uint4,uint4) | Represents method GG(uint4,uint4,uint4,uint4,uint4,uint4,uint4).
HH(uint4,uint4,uint4,uint4,uint4,uint4,uint4) | Represents method HH(uint4,uint4,uint4,uint4,uint4,uint4,uint4).
II(uint4,uint4,uint4,uint4,uint4,uint4,uint4) | Represents method II(uint4,uint4,uint4,uint4,uint4,uint4,uint4).
Init | Represents method Init.
RotateLeft(uint4,uint4) | Represents method RotateLeft(uint4,uint4).
Transform(Puchar) | Represents method Transform(Puchar).
Update(Puchar,uint4) | Represents method Update(Puchar,uint4).
Top


TfrxMD5.Decode(Puint4,Puchar,uint4) Method

Summary

Represents method Decode(Puint4,Puchar,uint4).

Namespace: frxmd5
Syntax
Delphi
private
 procedure Decode(dest: Puint4; src: Puchar; nLength: uint4);

Parameters

dest
Type: Puint4

src
Type: Puchar

nLength
Type: System.Void

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.Digest Method

Summary

Represents method Digest.

Namespace: frxmd5
Syntax
Delphi
public
 function Digest: Puchar;

Return Value

Type: Puchar

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.Encode(Puchar,Puint4,uint4) Method

Summary

Represents method Encode(Puchar,Puint4,uint4).

Namespace: frxmd5
Syntax
Delphi
private
 procedure Encode(dest: Puchar; src: Puint4; nLength: uint4);

Parameters

dest
Type: Puchar

src
Type: Puint4

nLength
Type: System.Void

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.FF(uint4,uint4,uint4,uint4,uint4,uint4,uint4) Method

Summary

Represents method FF(uint4,uint4,uint4,uint4,uint4,uint4,uint4).

Namespace: frxmd5
Syntax
Delphi
private
 procedure FF(var a: uint4; b: uint4; c: uint4; d: uint4; x: uint4; s: uint4; ac: uint4);

Parameters

a
Type: System.Void

b
Type: System.Void

c
Type: System.Void

d
Type: System.Void

x
Type: System.Void

s
Type: System.Void

ac
Type: System.Void

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.Finalize Method

Summary

Represents method Finalize.

Namespace: frxmd5
Syntax
Delphi
public
 procedure Finalize;
See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.GG(uint4,uint4,uint4,uint4,uint4,uint4,uint4) Method

Summary

Represents method GG(uint4,uint4,uint4,uint4,uint4,uint4,uint4).

Namespace: frxmd5
Syntax
Delphi
private
 procedure GG(var a: uint4; b: uint4; c: uint4; d: uint4; x: uint4; s: uint4; ac: uint4);

Parameters

a
Type: System.Void

b
Type: System.Void

c
Type: System.Void

d
Type: System.Void

x
Type: System.Void

s
Type: System.Void

ac
Type: System.Void

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.HH(uint4,uint4,uint4,uint4,uint4,uint4,uint4) Method

Summary

Represents method HH(uint4,uint4,uint4,uint4,uint4,uint4,uint4).

Namespace: frxmd5
Syntax
Delphi
private
 procedure HH(var a: uint4; b: uint4; c: uint4; d: uint4; x: uint4; s: uint4; ac: uint4);

Parameters

a
Type: System.Void

b
Type: System.Void

c
Type: System.Void

d
Type: System.Void

x
Type: System.Void

s
Type: System.Void

ac
Type: System.Void

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.II(uint4,uint4,uint4,uint4,uint4,uint4,uint4) Method

Summary

Represents method II(uint4,uint4,uint4,uint4,uint4,uint4,uint4).

Namespace: frxmd5
Syntax
Delphi
private
 procedure II(var a: uint4; b: uint4; c: uint4; d: uint4; x: uint4; s: uint4; ac: uint4);

Parameters

a
Type: System.Void

b
Type: System.Void

c
Type: System.Void

d
Type: System.Void

x
Type: System.Void

s
Type: System.Void

ac
Type: System.Void

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.Init Method

Summary

Represents method Init.

Namespace: frxmd5
Syntax
Delphi
public
 procedure Init;
See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.RotateLeft(uint4,uint4) Method

Summary

Represents method RotateLeft(uint4,uint4).

Namespace: frxmd5
Syntax
Delphi
private
 function RotateLeft(x: uint4; n: uint4): uint4;

Parameters

x
Type: System.Void

n
Type: System.Void

Return Value

Type: uint4

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.Transform(Puchar) Method

Summary

Represents method Transform(Puchar).

Namespace: frxmd5
Syntax
Delphi
private
 procedure Transform(block: Puchar);

Parameters

block
Type: Puchar

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.Update(Puchar,uint4) Method

Summary

Represents method Update(Puchar,uint4).

Namespace: frxmd5
Syntax
Delphi
public
 procedure Update(chInput: Puchar; nInputLen: uint4);

Parameters

chInput
Type: Puchar

nInputLen
Type: System.Void

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5 Fields

Fields
Name | Description
m_Buffer | Represents field m_Buffer.
m_Count | Represents field m_Count.
m_Digest | Represents field m_Digest.
m_State | Represents field m_State.
Top


TfrxMD5.m_Buffer Field

Summary

Represents field m_Buffer.

Namespace: frxmd5
Syntax
Delphi
private
 m_Buffer: array [0..63] of uchar;

Field Value

Type: array [0..63] of uchar

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.m_Count Field

Summary

Represents field m_Count.

Namespace: frxmd5
Syntax
Delphi
private
 m_Count: array [0..1] of uint4;

Field Value

Type: array [0..1] of uint4

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.m_Digest Field

Summary

Represents field m_Digest.

Namespace: frxmd5
Syntax
Delphi
private
 m_Digest: array [0..15] of uchar;

Field Value

Type: array [0..15] of uchar

See Also

Reference

  • TfrxMD5
  • frxmd5


TfrxMD5.m_State Field

Summary

Represents field m_State.

Namespace: frxmd5
Syntax
Delphi
private
 m_State: array [0..3] of uint4;

Field Value

Type: array [0..3] of uint4

See Also

Reference

  • TfrxMD5
  • frxmd5


frxMD5 Types

Types
Name | Description
Puchar | Represents a pointer type to uchar.
Puint4 | Represents a pointer type to uint4.
uchar | Represents an alias of the byte type.
uint4 | Represents an alias of the longword type.
Top


Puchar Type

Summary

Represents a pointer type to uchar.

Namespace: frxmd5
Syntax
Delphi
type
 Puchar = ^uchar;
See Also

Reference

  • frxmd5


Puint4 Type

Summary

Represents a pointer type to uint4.

Namespace: frxmd5
Syntax
Delphi
type
 Puint4 = ^uint4;
See Also

Reference

  • frxmd5


uchar Type

Summary

Represents an alias of the byte type.

Namespace: frxmd5
Syntax
Delphi
type
 uchar = byte;
See Also

Reference

  • frxmd5


uint4 Type

Summary

Represents an alias of the longword type.

Namespace: frxmd5
Syntax
Delphi
type
 uint4 = longword;
See Also

Reference

  • frxmd5


frxMD5 Constants

Constants
Name | Description
MD5_INIT_STATE_0 | Represents constant MD5_INIT_STATE_0.
MD5_INIT_STATE_1 | Represents constant MD5_INIT_STATE_1.
MD5_INIT_STATE_2 | Represents constant MD5_INIT_STATE_2.
MD5_INIT_STATE_3 | Represents constant MD5_INIT_STATE_3.
MD5_S11 | Represents constant MD5_S11.
MD5_S12 | Represents constant MD5_S12.
MD5_S13 | Represents constant MD5_S13.
MD5_S14 | Represents constant MD5_S14.
MD5_S21 | Represents constant MD5_S21.
MD5_S22 | Represents constant MD5_S22.
MD5_S23 | Represents constant MD5_S23.
MD5_S24 | Represents constant MD5_S24.
MD5_S31 | Represents constant MD5_S31.
MD5_S32 | Represents constant MD5_S32.
MD5_S33 | Represents constant MD5_S33.
MD5_S34 | Represents constant MD5_S34.
MD5_S41 | Represents constant MD5_S41.
MD5_S42 | Represents constant MD5_S42.
MD5_S43 | Represents constant MD5_S43.
MD5_S44 | Represents constant MD5_S44.
MD5_T01 | Represents constant MD5_T01.
MD5_T02 | Represents constant MD5_T02.
MD5_T03 | Represents constant MD5_T03.
MD5_T04 | Represents constant MD5_T04.
MD5_T05 | Represents constant MD5_T05.
MD5_T06 | Represents constant MD5_T06.
MD5_T07 | Represents constant MD5_T07.
MD5_T08 | Represents constant MD5_T08.
MD5_T09 | Represents constant MD5_T09.
MD5_T10 | Represents constant MD5_T10.
MD5_T11 | Represents constant MD5_T11.
MD5_T12 | Represents constant MD5_T12.
MD5_T13 | Represents constant MD5_T13.
MD5_T14 | Represents constant MD5_T14.
MD5_T15 | Represents constant MD5_T15.
MD5_T16 | Represents constant MD5_T16.
MD5_T17 | Represents constant MD5_T17.
MD5_T18 | Represents constant MD5_T18.
MD5_T19 | Represents constant MD5_T19.
MD5_T20 | Represents constant MD5_T20.
MD5_T21 | Represents constant MD5_T21.
MD5_T22 | Represents constant MD5_T22.
MD5_T23 | Represents constant MD5_T23.
MD5_T24 | Represents constant MD5_T24.
MD5_T25 | Represents constant MD5_T25.
MD5_T26 | Represents constant MD5_T26.
MD5_T27 | Represents constant MD5_T27.
MD5_T28 | Represents constant MD5_T28.
MD5_T29 | Represents constant MD5_T29.
MD5_T30 | Represents constant MD5_T30.
MD5_T31 | Represents constant MD5_T31.
MD5_T32 | Represents constant MD5_T32.
MD5_T33 | Represents constant MD5_T33.
MD5_T34 | Represents constant MD5_T34.
MD5_T35 | Represents constant MD5_T35.
MD5_T36 | Represents constant MD5_T36.
MD5_T37 | Represents constant MD5_T37.
MD5_T38 | Represents constant MD5_T38.
MD5_T39 | Represents constant MD5_T39.
MD5_T40 | Represents constant MD5_T40.
MD5_T41 | Represents constant MD5_T41.
MD5_T42 | Represents constant MD5_T42.
MD5_T43 | Represents constant MD5_T43.
MD5_T44 | Represents constant MD5_T44.
MD5_T45 | Represents constant MD5_T45.
MD5_T46 | Represents constant MD5_T46.
MD5_T47 | Represents constant MD5_T47.
MD5_T48 | Represents constant MD5_T48.
MD5_T49 | Represents constant MD5_T49.
MD5_T50 | Represents constant MD5_T50.
MD5_T51 | Represents constant MD5_T51.
MD5_T52 | Represents constant MD5_T52.
MD5_T53 | Represents constant MD5_T53.
MD5_T54 | Represents constant MD5_T54.
MD5_T55 | Represents constant MD5_T55.
MD5_T56 | Represents constant MD5_T56.
MD5_T57 | Represents constant MD5_T57.
MD5_T58 | Represents constant MD5_T58.
MD5_T59 | Represents constant MD5_T59.
MD5_T60 | Represents constant MD5_T60.
MD5_T61 | Represents constant MD5_T61.
MD5_T62 | Represents constant MD5_T62.
MD5_T63 | Represents constant MD5_T63.
MD5_T64 | Represents constant MD5_T64.
PADDING | Represents constant PADDING.
Top


MD5_INIT_STATE_0 Constant

Summary

Represents constant MD5_INIT_STATE_0.

Namespace: frxmd5
Syntax
Delphi
 MD5_INIT_STATE_0 = $67452301;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_INIT_STATE_1 Constant

Summary

Represents constant MD5_INIT_STATE_1.

Namespace: frxmd5
Syntax
Delphi
 MD5_INIT_STATE_1 = $efcdab89;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_INIT_STATE_2 Constant

Summary

Represents constant MD5_INIT_STATE_2.

Namespace: frxmd5
Syntax
Delphi
 MD5_INIT_STATE_2 = $98badcfe;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_INIT_STATE_3 Constant

Summary

Represents constant MD5_INIT_STATE_3.

Namespace: frxmd5
Syntax
Delphi
 MD5_INIT_STATE_3 = $10325476;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_S11 Constant

Summary

Represents constant MD5_S11.

Namespace: frxmd5
Syntax
Delphi
 MD5_S11 = 7;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S12 Constant

Summary

Represents constant MD5_S12.

Namespace: frxmd5
Syntax
Delphi
 MD5_S12 = 12;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S13 Constant

Summary

Represents constant MD5_S13.

Namespace: frxmd5
Syntax
Delphi
 MD5_S13 = 17;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S14 Constant

Summary

Represents constant MD5_S14.

Namespace: frxmd5
Syntax
Delphi
 MD5_S14 = 22;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S21 Constant

Summary

Represents constant MD5_S21.

Namespace: frxmd5
Syntax
Delphi
 MD5_S21 = 5;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S22 Constant

Summary

Represents constant MD5_S22.

Namespace: frxmd5
Syntax
Delphi
 MD5_S22 = 9;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S23 Constant

Summary

Represents constant MD5_S23.

Namespace: frxmd5
Syntax
Delphi
 MD5_S23 = 14;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S24 Constant

Summary

Represents constant MD5_S24.

Namespace: frxmd5
Syntax
Delphi
 MD5_S24 = 20;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S31 Constant

Summary

Represents constant MD5_S31.

Namespace: frxmd5
Syntax
Delphi
 MD5_S31 = 4;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S32 Constant

Summary

Represents constant MD5_S32.

Namespace: frxmd5
Syntax
Delphi
 MD5_S32 = 11;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S33 Constant

Summary

Represents constant MD5_S33.

Namespace: frxmd5
Syntax
Delphi
 MD5_S33 = 16;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S34 Constant

Summary

Represents constant MD5_S34.

Namespace: frxmd5
Syntax
Delphi
 MD5_S34 = 23;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S41 Constant

Summary

Represents constant MD5_S41.

Namespace: frxmd5
Syntax
Delphi
 MD5_S41 = 6;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S42 Constant

Summary

Represents constant MD5_S42.

Namespace: frxmd5
Syntax
Delphi
 MD5_S42 = 10;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S43 Constant

Summary

Represents constant MD5_S43.

Namespace: frxmd5
Syntax
Delphi
 MD5_S43 = 15;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_S44 Constant

Summary

Represents constant MD5_S44.

Namespace: frxmd5
Syntax
Delphi
 MD5_S44 = 21;

Value

Type: ShortInt

See Also

Reference

  • frxmd5


MD5_T01 Constant

Summary

Represents constant MD5_T01.

Namespace: frxmd5
Syntax
Delphi
 MD5_T01 = $d76aa478;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T02 Constant

Summary

Represents constant MD5_T02.

Namespace: frxmd5
Syntax
Delphi
 MD5_T02 = $e8c7b756;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T03 Constant

Summary

Represents constant MD5_T03.

Namespace: frxmd5
Syntax
Delphi
 MD5_T03 = $242070db;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T04 Constant

Summary

Represents constant MD5_T04.

Namespace: frxmd5
Syntax
Delphi
 MD5_T04 = $c1bdceee;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T05 Constant

Summary

Represents constant MD5_T05.

Namespace: frxmd5
Syntax
Delphi
 MD5_T05 = $f57c0faf;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T06 Constant

Summary

Represents constant MD5_T06.

Namespace: frxmd5
Syntax
Delphi
 MD5_T06 = $4787c62a;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T07 Constant

Summary

Represents constant MD5_T07.

Namespace: frxmd5
Syntax
Delphi
 MD5_T07 = $a8304613;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T08 Constant

Summary

Represents constant MD5_T08.

Namespace: frxmd5
Syntax
Delphi
 MD5_T08 = $fd469501;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T09 Constant

Summary

Represents constant MD5_T09.

Namespace: frxmd5
Syntax
Delphi
 MD5_T09 = $698098d8;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T10 Constant

Summary

Represents constant MD5_T10.

Namespace: frxmd5
Syntax
Delphi
 MD5_T10 = $8b44f7af;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T11 Constant

Summary

Represents constant MD5_T11.

Namespace: frxmd5
Syntax
Delphi
 MD5_T11 = $ffff5bb1;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T12 Constant

Summary

Represents constant MD5_T12.

Namespace: frxmd5
Syntax
Delphi
 MD5_T12 = $895cd7be;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T13 Constant

Summary

Represents constant MD5_T13.

Namespace: frxmd5
Syntax
Delphi
 MD5_T13 = $6b901122;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T14 Constant

Summary

Represents constant MD5_T14.

Namespace: frxmd5
Syntax
Delphi
 MD5_T14 = $fd987193;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T15 Constant

Summary

Represents constant MD5_T15.

Namespace: frxmd5
Syntax
Delphi
 MD5_T15 = $a679438e;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T16 Constant

Summary

Represents constant MD5_T16.

Namespace: frxmd5
Syntax
Delphi
 MD5_T16 = $49b40821;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T17 Constant

Summary

Represents constant MD5_T17.

Namespace: frxmd5
Syntax
Delphi
 MD5_T17 = $f61e2562;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T18 Constant

Summary

Represents constant MD5_T18.

Namespace: frxmd5
Syntax
Delphi
 MD5_T18 = $c040b340;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T19 Constant

Summary

Represents constant MD5_T19.

Namespace: frxmd5
Syntax
Delphi
 MD5_T19 = $265e5a51;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T20 Constant

Summary

Represents constant MD5_T20.

Namespace: frxmd5
Syntax
Delphi
 MD5_T20 = $e9b6c7aa;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T21 Constant

Summary

Represents constant MD5_T21.

Namespace: frxmd5
Syntax
Delphi
 MD5_T21 = $d62f105d;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T22 Constant

Summary

Represents constant MD5_T22.

Namespace: frxmd5
Syntax
Delphi
 MD5_T22 = $02441453;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T23 Constant

Summary

Represents constant MD5_T23.

Namespace: frxmd5
Syntax
Delphi
 MD5_T23 = $d8a1e681;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T24 Constant

Summary

Represents constant MD5_T24.

Namespace: frxmd5
Syntax
Delphi
 MD5_T24 = $e7d3fbc8;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T25 Constant

Summary

Represents constant MD5_T25.

Namespace: frxmd5
Syntax
Delphi
 MD5_T25 = $21e1cde6;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T26 Constant

Summary

Represents constant MD5_T26.

Namespace: frxmd5
Syntax
Delphi
 MD5_T26 = $c33707d6;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T27 Constant

Summary

Represents constant MD5_T27.

Namespace: frxmd5
Syntax
Delphi
 MD5_T27 = $f4d50d87;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T28 Constant

Summary

Represents constant MD5_T28.

Namespace: frxmd5
Syntax
Delphi
 MD5_T28 = $455a14ed;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T29 Constant

Summary

Represents constant MD5_T29.

Namespace: frxmd5
Syntax
Delphi
 MD5_T29 = $a9e3e905;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T30 Constant

Summary

Represents constant MD5_T30.

Namespace: frxmd5
Syntax
Delphi
 MD5_T30 = $fcefa3f8;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T31 Constant

Summary

Represents constant MD5_T31.

Namespace: frxmd5
Syntax
Delphi
 MD5_T31 = $676f02d9;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T32 Constant

Summary

Represents constant MD5_T32.

Namespace: frxmd5
Syntax
Delphi
 MD5_T32 = $8d2a4c8a;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T33 Constant

Summary

Represents constant MD5_T33.

Namespace: frxmd5
Syntax
Delphi
 MD5_T33 = $fffa3942;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T34 Constant

Summary

Represents constant MD5_T34.

Namespace: frxmd5
Syntax
Delphi
 MD5_T34 = $8771f681;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T35 Constant

Summary

Represents constant MD5_T35.

Namespace: frxmd5
Syntax
Delphi
 MD5_T35 = $6d9d6122;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T36 Constant

Summary

Represents constant MD5_T36.

Namespace: frxmd5
Syntax
Delphi
 MD5_T36 = $fde5380c;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T37 Constant

Summary

Represents constant MD5_T37.

Namespace: frxmd5
Syntax
Delphi
 MD5_T37 = $a4beea44;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T38 Constant

Summary

Represents constant MD5_T38.

Namespace: frxmd5
Syntax
Delphi
 MD5_T38 = $4bdecfa9;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T39 Constant

Summary

Represents constant MD5_T39.

Namespace: frxmd5
Syntax
Delphi
 MD5_T39 = $f6bb4b60;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T40 Constant

Summary

Represents constant MD5_T40.

Namespace: frxmd5
Syntax
Delphi
 MD5_T40 = $bebfbc70;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T41 Constant

Summary

Represents constant MD5_T41.

Namespace: frxmd5
Syntax
Delphi
 MD5_T41 = $289b7ec6;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T42 Constant

Summary

Represents constant MD5_T42.

Namespace: frxmd5
Syntax
Delphi
 MD5_T42 = $eaa127fa;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T43 Constant

Summary

Represents constant MD5_T43.

Namespace: frxmd5
Syntax
Delphi
 MD5_T43 = $d4ef3085;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T44 Constant

Summary

Represents constant MD5_T44.

Namespace: frxmd5
Syntax
Delphi
 MD5_T44 = $04881d05;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T45 Constant

Summary

Represents constant MD5_T45.

Namespace: frxmd5
Syntax
Delphi
 MD5_T45 = $d9d4d039;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T46 Constant

Summary

Represents constant MD5_T46.

Namespace: frxmd5
Syntax
Delphi
 MD5_T46 = $e6db99e5;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T47 Constant

Summary

Represents constant MD5_T47.

Namespace: frxmd5
Syntax
Delphi
 MD5_T47 = $1fa27cf8;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T48 Constant

Summary

Represents constant MD5_T48.

Namespace: frxmd5
Syntax
Delphi
 MD5_T48 = $c4ac5665;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T49 Constant

Summary

Represents constant MD5_T49.

Namespace: frxmd5
Syntax
Delphi
 MD5_T49 = $f4292244;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T50 Constant

Summary

Represents constant MD5_T50.

Namespace: frxmd5
Syntax
Delphi
 MD5_T50 = $432aff97;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T51 Constant

Summary

Represents constant MD5_T51.

Namespace: frxmd5
Syntax
Delphi
 MD5_T51 = $ab9423a7;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T52 Constant

Summary

Represents constant MD5_T52.

Namespace: frxmd5
Syntax
Delphi
 MD5_T52 = $fc93a039;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T53 Constant

Summary

Represents constant MD5_T53.

Namespace: frxmd5
Syntax
Delphi
 MD5_T53 = $655b59c3;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T54 Constant

Summary

Represents constant MD5_T54.

Namespace: frxmd5
Syntax
Delphi
 MD5_T54 = $8f0ccc92;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T55 Constant

Summary

Represents constant MD5_T55.

Namespace: frxmd5
Syntax
Delphi
 MD5_T55 = $ffeff47d;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T56 Constant

Summary

Represents constant MD5_T56.

Namespace: frxmd5
Syntax
Delphi
 MD5_T56 = $85845dd1;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T57 Constant

Summary

Represents constant MD5_T57.

Namespace: frxmd5
Syntax
Delphi
 MD5_T57 = $6fa87e4f;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T58 Constant

Summary

Represents constant MD5_T58.

Namespace: frxmd5
Syntax
Delphi
 MD5_T58 = $fe2ce6e0;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T59 Constant

Summary

Represents constant MD5_T59.

Namespace: frxmd5
Syntax
Delphi
 MD5_T59 = $a3014314;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T60 Constant

Summary

Represents constant MD5_T60.

Namespace: frxmd5
Syntax
Delphi
 MD5_T60 = $4e0811a1;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T61 Constant

Summary

Represents constant MD5_T61.

Namespace: frxmd5
Syntax
Delphi
 MD5_T61 = $f7537e82;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T62 Constant

Summary

Represents constant MD5_T62.

Namespace: frxmd5
Syntax
Delphi
 MD5_T62 = $bd3af235;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


MD5_T63 Constant

Summary

Represents constant MD5_T63.

Namespace: frxmd5
Syntax
Delphi
 MD5_T63 = $2ad7d2bb;

Value

Type: Integer

See Also

Reference

  • frxmd5


MD5_T64 Constant

Summary

Represents constant MD5_T64.

Namespace: frxmd5
Syntax
Delphi
 MD5_T64 = $eb86d391;

Value

Type: Cardinal

See Also

Reference

  • frxmd5


PADDING Constant

Summary

Represents constant PADDING.

Namespace: frxmd5
Syntax
Delphi
 PADDING: array [0..63] of byte =
( $80, 0, 0, 0, 0, 0, 0, 0,
 0, 0, 0, 0, 0, 0, 0, 0,
 0, 0, 0, 0, 0, 0, 0, 0,
 0, 0, 0, 0, 0, 0, 0, 0,
 0, 0, 0, 0, 0, 0, 0, 0,
 0, 0, 0, 0, 0, 0, 0, 0,
 0, 0, 0, 0, 0, 0, 0, 0,
 0, 0, 0, 0, 0, 0, 0, 0);

Value

Type: array [0..63] of byte

See Also

Reference

  • frxmd5


frxMD5 Routines

Routines
Name | Description
MD5Buf(Pointer,Integer,Pointer) | Represents method MD5Buf(Pointer,Integer,Pointer).
MD5File(String) | Represents method MD5File(String).
MD5Stream(TStream) | Represents method MD5Stream(TStream).
MD5String(AnsiString) | Represents method MD5String(AnsiString).
PrintMD5(Puchar) | Represents method PrintMD5(Puchar).
Top


MD5Buf(Pointer,Integer,Pointer) Method

Summary

Represents method MD5Buf(Pointer,Integer,Pointer).

Namespace: frxmd5
Syntax
Delphi
procedure MD5Buf(Buf: Pointer; const Len: Integer; Digest: Pointer);

Parameters

Buf
Type: Pointer

Len
Type: Integer

Digest
Type: Pointer

See Also

Reference

  • frxmd5


MD5File(String) Method

Summary

Represents method MD5File(String).

Namespace: frxmd5
Syntax
Delphi
function MD5File(szFilename: String): AnsiString;

Parameters

szFilename
Type: String

Return Value

Type: AnsiString

See Also

Reference

  • frxmd5


MD5Stream(TStream) Method

Summary

Represents method MD5Stream(TStream).

Namespace: frxmd5
Syntax
Delphi
function MD5Stream(Stream: TStream): AnsiString;

Parameters

Stream
Type: TStream

Return Value

Type: AnsiString

See Also

Reference

  • frxmd5


MD5String(AnsiString) Method

Summary

Represents method MD5String(AnsiString).

Namespace: frxmd5
Syntax
Delphi
function MD5String(szString: AnsiString): AnsiString;

Parameters

szString
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • frxmd5


PrintMD5(Puchar) Method

Summary

Represents method PrintMD5(Puchar).

Namespace: frxmd5
Syntax
Delphi
function PrintMD5(md5Digest: Puchar): AnsiString;

Parameters

md5Digest
Type: Puchar

Return Value

Type: AnsiString

See Also

Reference

  • frxmd5


frxNetUtils Namespace

Summary

Represents namespace frxNetUtils.

Routines
Name | Description
Base64Decode(AnsiString) | Represents method Base64Decode(AnsiString).
Base64Encode(AnsiString) | Represents method Base64Encode(AnsiString).
DateTimeToRFCDateTime(TDateTime) | Represents method DateTimeToRFCDateTime(TDateTime).
GetFileMIMEType(String) | Represents method GetFileMIMEType(String).
GetSocketErrorText(integer) | Represents method GetSocketErrorText(integer).
GMTDateTimeToRFCDateTime(TDateTime) | Represents method GMTDateTimeToRFCDateTime(TDateTime).
PadLeft(String,Char,Integer) | Represents method PadLeft(String,Char,Integer).
PadRight(String,Char,Integer) | Represents method PadRight(String,Char,Integer).
ParseHeaderField(AnsiString,AnsiString) | Represents method ParseHeaderField(AnsiString,AnsiString).
PMessages | Represents method PMessages.
UpdateCookies(String,String) | Represents method UpdateCookies(String,String).
Top


frxNetUtils Routines

Routines
Name | Description
Base64Decode(AnsiString) | Represents method Base64Decode(AnsiString).
Base64Encode(AnsiString) | Represents method Base64Encode(AnsiString).
DateTimeToRFCDateTime(TDateTime) | Represents method DateTimeToRFCDateTime(TDateTime).
GetFileMIMEType(String) | Represents method GetFileMIMEType(String).
GetSocketErrorText(integer) | Represents method GetSocketErrorText(integer).
GMTDateTimeToRFCDateTime(TDateTime) | Represents method GMTDateTimeToRFCDateTime(TDateTime).
PadLeft(String,Char,Integer) | Represents method PadLeft(String,Char,Integer).
PadRight(String,Char,Integer) | Represents method PadRight(String,Char,Integer).
ParseHeaderField(AnsiString,AnsiString) | Represents method ParseHeaderField(AnsiString,AnsiString).
PMessages | Represents method PMessages.
UpdateCookies(String,String) | Represents method UpdateCookies(String,String).
Top


Base64Decode(AnsiString) Method

Summary

Represents method Base64Decode(AnsiString).

Namespace: frxNetUtils
Syntax
Delphi
function Base64Decode(const S: AnsiString): AnsiString;

Parameters

S
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • frxNetUtils


Base64Encode(AnsiString) Method

Summary

Represents method Base64Encode(AnsiString).

Namespace: frxNetUtils
Syntax
Delphi
function Base64Encode(const S: AnsiString): AnsiString;

Parameters

S
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • frxNetUtils


DateTimeToRFCDateTime(TDateTime) Method

Summary

Represents method DateTimeToRFCDateTime(TDateTime).

Namespace: frxNetUtils
Syntax
Delphi
function DateTimeToRFCDateTime(const D: TDateTime): String;

Parameters

D
Type: TDateTime

Return Value

Type: String

See Also

Reference

  • frxNetUtils


GetFileMIMEType(String) Method

Summary

Represents method GetFileMIMEType(String).

Namespace: frxNetUtils
Syntax
Delphi
function GetFileMIMEType(const FileName: String): String;

Parameters

FileName
Type: String

Return Value

Type: String

See Also

Reference

  • frxNetUtils


GetSocketErrorText(integer) Method

Summary

Represents method GetSocketErrorText(integer).

Namespace: frxNetUtils
Syntax
Delphi
function GetSocketErrorText(const ErrorCode: integer):string;

Parameters

ErrorCode
Type: integer

Return Value

Type: string

See Also

Reference

  • frxNetUtils


GMTDateTimeToRFCDateTime(TDateTime) Method

Summary

Represents method GMTDateTimeToRFCDateTime(TDateTime).

Namespace: frxNetUtils
Syntax
Delphi
function GMTDateTimeToRFCDateTime(const D: TDateTime): String;

Parameters

D
Type: TDateTime

Return Value

Type: String

See Also

Reference

  • frxNetUtils


PadLeft(String,Char,Integer) Method

Summary

Represents method PadLeft(String,Char,Integer).

Namespace: frxNetUtils
Syntax
Delphi
function PadLeft(const S: String; const PadChar: Char; const Len: Integer): String;

Parameters

S
Type: String

PadChar
Type: Char

Len
Type: Integer

Return Value

Type: String

See Also

Reference

  • frxNetUtils


PadRight(String,Char,Integer) Method

Summary

Represents method PadRight(String,Char,Integer).

Namespace: frxNetUtils
Syntax
Delphi
function PadRight(const S: String; const PadChar: Char; const Len: Integer): String;

Parameters

S
Type: String

PadChar
Type: Char

Len
Type: Integer

Return Value

Type: String

See Also

Reference

  • frxNetUtils


ParseHeaderField(AnsiString,AnsiString) Method

Summary

Represents method ParseHeaderField(AnsiString,AnsiString).

Namespace: frxNetUtils
Syntax
Delphi
function ParseHeaderField(const Field: AnsiString; const Header: AnsiString): AnsiString;

Parameters

Field
Type: AnsiString

Header
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • frxNetUtils


PMessages Method

Summary

Represents method PMessages.

Namespace: frxNetUtils
Syntax
Delphi
procedure PMessages;
See Also

Reference

  • frxNetUtils


UpdateCookies(String,String) Method

Summary

Represents method UpdateCookies(String,String).

Namespace: frxNetUtils
Syntax
Delphi
function UpdateCookies(const Header: String; const Cookies: String): String;

Parameters

Header
Type: String

Cookies
Type: String

Return Value

Type: String

See Also

Reference

  • frxNetUtils


frxOLE Namespace

Summary

Represents namespace frxOLE.

Classes
Name | Description
TfrxOLEObject | The TfrxOLEObject allows the use of OLE objects in your report. TfrxOLEObject is an empty component. It is used to add thefrxOLE.pas file to the "uses" list. The main component is TfrxOLEView.
TfrxOLEView | The TfrxOLEView component represents an OLE object. Component can show an OLE object from the DB field (you should set DataSet, DataField properties).
Top
Enumerations
Name | Description
TfrxSizeMode | Represents type TfrxSizeMode.
Top
Routines
Name | Description
frxAssignOle(TOleContainer,TOleContainer) | This method copies the contents from ContFrom to ContTo OLE container.
Top


frxOLE Classes

Classes
Name | Description
TfrxOLEObject | The TfrxOLEObject allows the use of OLE objects in your report. TfrxOLEObject is an empty component. It is used to add thefrxOLE.pas file to the "uses" list. The main component is TfrxOLEView.
TfrxOLEView | The TfrxOLEView component represents an OLE object. Component can show an OLE object from the DB field (you should set DataSet, DataField properties).
Top


TfrxOLEObject Class

Summary

The TfrxOLEObject allows the use of OLE objects in your report. TfrxOLEObject is an empty component. It is used to add thefrxOLE.pas file to the "uses" list. The main component is TfrxOLEView.

Namespace: frxOLE
Inheritance Hierarchy
TComponent
frxOLE.TfrxOLEObject
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxOLEObject = class(TComponent)
 end;
See Also

Reference

  • frxOLE


TfrxOLEView Class

Summary

The TfrxOLEView component represents an OLE object. Component can show an OLE object from the DB field (you should set DataSet, DataField properties).

Namespace: frxOLE
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxOLE.TfrxOLEView
Syntax
Delphi
type
 TfrxOLEView = class(TfrxView)
 end;

The TfrxOLEView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxOLEView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxOLEView class. (Overrides TfrxView.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Represents property BrushStyle.
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Represents property Fill.
FillType | Represents property FillType.
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OleContainer | Reference to internal TOleContainer object.
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
SizeMode | Represents property SizeMode.
Stretched | Determines if it is necessary to stretch an OLE object to the area occupied by the object in a report. It may be useful for showing MS Excel objects.
TagStr | Represents property TagStr.
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Represents property URL.
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Overrides TfrxView.IsEMFExportable.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadData(TStream) | Represents method ReadData(TStream).
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetStretched(Boolean) | Represents method SetStretched(Boolean).
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteData(TStream) | Represents method WriteData(TStream).
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOleContainer | Represents field FOleContainer.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FSizeMode | Represents field FSizeMode.
FStretched | Represents field FStretched.
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxOLE


TfrxOLEView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxOLEView class. (Overrides TfrxView.Create(TComponent).)
Destroy | Represents the destructor of the TfrxOLEView class. (Overrides TfrxView.Destroy.)
Top


TfrxOLEView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxOLEView class.

Namespace: frxOLE
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxView.Create(TComponent)
See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.Destroy Destructor

Summary

Represents the destructor of the TfrxOLEView class.

Namespace: frxOLE
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxView.Destroy
See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView Properties

Properties
Name | Description
BrushStyle | Represents property BrushStyle.
Color | Represents property Color.
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Fill | Represents property Fill.
FillType | Represents property FillType.
Frame | Represents property Frame.
OleContainer | Reference to internal TOleContainer object.
SizeMode | Represents property SizeMode.
Stretched | Determines if it is necessary to stretch an OLE object to the area occupied by the object in a report. It may be useful for showing MS Excel objects.
TagStr | Represents property TagStr.
URL | Represents property URL.
Top


TfrxOLEView.BrushStyle Property

Summary

Represents property BrushStyle.

Namespace: frxOLE
Syntax
Delphi
published
 property BrushStyle;

Property Value

Type: Void

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.Color Property

Summary

Represents property Color.

Namespace: frxOLE
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.Cursor Property

Summary

Represents property Cursor.

Namespace: frxOLE
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.DataField Property

Summary

Represents property DataField.

Namespace: frxOLE
Syntax
Delphi
published
 property DataField;

Property Value

Type: Void

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.DataSet Property

Summary

Represents property DataSet.

Namespace: frxOLE
Syntax
Delphi
published
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxOLE
Syntax
Delphi
published
 property DataSetName;

Property Value

Type: Void

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.Fill Property

Summary

Represents property Fill.

Namespace: frxOLE
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.FillType Property

Summary

Represents property FillType.

Namespace: frxOLE
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.Frame Property

Summary

Represents property Frame.

Namespace: frxOLE
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.OleContainer Property

Summary

Reference to internal TOleContainer object.

Namespace: frxOLE
Syntax
Delphi
public
 property OleContainer: TOleContainer read FOleContainer;

Property Value

Type: TOleContainer

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.SizeMode Property

Summary

Represents property SizeMode.

Namespace: frxOLE
Syntax
Delphi
published
 property SizeMode: TfrxSizeMode read FSizeMode write FSizeMode default fsmClip;

Property Value

Type: TfrxSizeMode

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.Stretched Property

Summary

Determines if it is necessary to stretch an OLE object to the area occupied by the object in a report. It may be useful for showing MS Excel objects.

Namespace: frxOLE
Syntax
Delphi
published
 property Stretched: Boolean read FStretched write SetStretched default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.TagStr Property

Summary

Represents property TagStr.

Namespace: frxOLE
Syntax
Delphi
published
 property TagStr;

Property Value

Type: Void

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.URL Property

Summary

Represents property URL.

Namespace: frxOLE
Syntax
Delphi
published
 property URL;

Property Value

Type: Void

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView Methods

Methods
Name | Description
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Overrides TfrxView.IsEMFExportable.)
ReadData(TStream) | Represents method ReadData(TStream).
SetStretched(Boolean) | Represents method SetStretched(Boolean).
WriteData(TStream) | Represents method WriteData(TStream).
Top


TfrxOLEView.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxOLE
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxOLE
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxOLE
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxOLE
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.IsEMFExportable Method

Summary

Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported).

Namespace: frxOLE
Syntax
Delphi
public
 function IsEMFExportable: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxView.IsEMFExportable
See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.ReadData(TStream) Method

Summary

Represents method ReadData(TStream).

Namespace: frxOLE
Syntax
Delphi
private
 procedure ReadData(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.SetStretched(Boolean) Method

Summary

Represents method SetStretched(Boolean).

Namespace: frxOLE
Syntax
Delphi
private
 procedure SetStretched(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.WriteData(TStream) Method

Summary

Represents method WriteData(TStream).

Namespace: frxOLE
Syntax
Delphi
private
 procedure WriteData(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView Fields

Fields
Name | Description
FOleContainer | Represents field FOleContainer.
FSizeMode | Represents field FSizeMode.
FStretched | Represents field FStretched.
Top


TfrxOLEView.FOleContainer Field

Summary

Represents field FOleContainer.

Namespace: frxOLE
Syntax
Delphi
private
 FOleContainer: TOleContainer;

Field Value

Type: TOleContainer

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.FSizeMode Field

Summary

Represents field FSizeMode.

Namespace: frxOLE
Syntax
Delphi
private
 FSizeMode: TfrxSizeMode;

Field Value

Type: TfrxSizeMode

See Also

Reference

  • TfrxOLEView
  • frxOLE


TfrxOLEView.FStretched Field

Summary

Represents field FStretched.

Namespace: frxOLE
Syntax
Delphi
private
 FStretched: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxOLEView
  • frxOLE


frxOLE Enumerations

Enumerations
Name | Description
TfrxSizeMode | Represents type TfrxSizeMode.
Top


TfrxSizeMode Enumeration

Summary

Represents type TfrxSizeMode.

Namespace: frxOLE
Syntax
Delphi
type
 TfrxSizeMode = (fsmClip, fsmScale);

The TfrxSizeMode type exposes the following members.

Members
Show:
Name | Description
fsmClip | Represents constant fsmClip.
fsmScale | Represents constant fsmScale.
Top
See Also

Reference

  • frxOLE


frxOLE Routines

Routines
Name | Description
frxAssignOle(TOleContainer,TOleContainer) | This method copies the contents from ContFrom to ContTo OLE container.
Top


frxAssignOle(TOleContainer,TOleContainer) Method

Summary

This method copies the contents from ContFrom to ContTo OLE container.

Namespace: frxOLE
Syntax
Delphi
procedure frxAssignOle(ContFrom, ContTo: TOleContainer);

Parameters

ContFrom
Type: TOleContainer

ContTo
Type: TOleContainer

See Also

Reference

  • frxOLE


frxOSMFileFormat Namespace

Summary

Represents namespace frxOSMFileFormat.

Classes
Name | Description
TOSMFile | Represents type TOSMFile.
TOSMNode | Represents type TOSMNode.
TOSMWay | Represents type TOSMWay.
Top


frxOSMFileFormat Classes

Classes
Name | Description
TOSMFile | Represents type TOSMFile.
TOSMNode | Represents type TOSMNode.
TOSMWay | Represents type TOSMWay.
Top


TOSMFile Class

Summary

Represents type TOSMFile.

Namespace: frxOSMFileFormat
Inheritance Hierarchy
TObject
frxOSMFileFormat.TOSMFile
Syntax
Delphi
type
 TOSMFile = class
 end;

The TOSMFile type exposes the following members.

Constructors
Show:
Name | Description
Create(string) | Initializes a new instance of the TOSMFile class.
Destroy | Represents the destructor of the TOSMFile class.
Top
Properties
Show:
Name | Description
CountOfNodes | Represents property CountOfNodes.
CountOfWays | Represents property CountOfWays.
Nodes[integer] | Represents property Nodes[integer].
SumTags | Represents property SumTags.
Ways[integer] | Represents property Ways[integer].
Xmax | Represents property Xmax.
Xmin | Represents property Xmin.
Ymax | Represents property Ymax.
Ymin | Represents property Ymin.
Top
Methods
Show:
Name | Description
GetCountOfNodes | Represents method GetCountOfNodes.
GetCountOfWays | Represents method GetCountOfWays.
GetNodes(integer) | Represents method GetNodes(integer).
GetWays(integer) | Represents method GetWays(integer).
IsGetNodeAsPoint(integer,integer,TDoublePoint) | Represents method IsGetNodeAsPoint(integer,integer,TDoublePoint).
IsValidBounds | Represents method IsValidBounds.
Load(string) | Represents method Load(string).
LoadBounds(TfrxXMLItem) | Represents method LoadBounds(TfrxXMLItem).
LoadNode(TfrxXMLItem) | Represents method LoadNode(TfrxXMLItem).
LoadWay(TfrxXMLItem) | Represents method LoadWay(TfrxXMLItem).
ParseItem(TfrxXMLItem) | Represents method ParseItem(TfrxXMLItem).
ValidUTF8(String) | Represents method ValidUTF8(String).
Top
Fields
Show:
Name | Description
FOSMNodes | Represents field FOSMNodes.
FOSMWays | Represents field FOSMWays.
FSumTags | Represents field FSumTags.
FValidBounds | Represents field FValidBounds.
FXmax | Represents field FXmax.
FXmin | Represents field FXmin.
FYmax | Represents field FYmax.
FYmin | Represents field FYmin.
Top
See Also

Reference

  • frxOSMFileFormat


TOSMFile Constructors

Constructors
Name | Description
Create(string) | Initializes a new instance of the TOSMFile class.
Destroy | Represents the destructor of the TOSMFile class.
Top


TOSMFile.Create(string) Constructor

Summary

Initializes a new instance of the TOSMFile class.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 constructor Create(const FileName: string);

Parameters

FileName
Type: string

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.Destroy Destructor

Summary

Represents the destructor of the TOSMFile class.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile Properties

Properties
Name | Description
CountOfNodes | Represents property CountOfNodes.
CountOfWays | Represents property CountOfWays.
Nodes[integer] | Represents property Nodes[integer].
SumTags | Represents property SumTags.
Ways[integer] | Represents property Ways[integer].
Xmax | Represents property Xmax.
Xmin | Represents property Xmin.
Ymax | Represents property Ymax.
Ymin | Represents property Ymin.
Top


TOSMFile.CountOfNodes Property

Summary

Represents property CountOfNodes.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property CountOfNodes: Integer read GetCountOfNodes;

Property Value

Type: Integer

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.CountOfWays Property

Summary

Represents property CountOfWays.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property CountOfWays: Integer read GetCountOfWays;

Property Value

Type: Integer

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.Nodes[integer] Property

Summary

Represents property Nodes[integer].

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property Nodes[Index: integer]: TOSMNode read GetNodes;

Parameters

Index
Type: integer

Property Value

Type: TOSMNode

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.SumTags Property

Summary

Represents property SumTags.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property SumTags: TfrxSumStringList read FSumTags;

Property Value

Type: TfrxSumStringList

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.Ways[integer] Property

Summary

Represents property Ways[integer].

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property Ways[Index: integer]: TOSMWay read GetWays;

Parameters

Index
Type: integer

Property Value

Type: TOSMWay

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.Xmax Property

Summary

Represents property Xmax.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property Xmax: Double read FXmax;

Property Value

Type: Double

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.Xmin Property

Summary

Represents property Xmin.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property Xmin: Double read FXmin;

Property Value

Type: Double

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.Ymax Property

Summary

Represents property Ymax.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property Ymax: Double read FYmax;

Property Value

Type: Double

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.Ymin Property

Summary

Represents property Ymin.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property Ymin: Double read FYmin;

Property Value

Type: Double

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile Methods

Methods
Name | Description
GetCountOfNodes | Represents method GetCountOfNodes.
GetCountOfWays | Represents method GetCountOfWays.
GetNodes(integer) | Represents method GetNodes(integer).
GetWays(integer) | Represents method GetWays(integer).
IsGetNodeAsPoint(integer,integer,TDoublePoint) | Represents method IsGetNodeAsPoint(integer,integer,TDoublePoint).
IsValidBounds | Represents method IsValidBounds.
Load(string) | Represents method Load(string).
LoadBounds(TfrxXMLItem) | Represents method LoadBounds(TfrxXMLItem).
LoadNode(TfrxXMLItem) | Represents method LoadNode(TfrxXMLItem).
LoadWay(TfrxXMLItem) | Represents method LoadWay(TfrxXMLItem).
ParseItem(TfrxXMLItem) | Represents method ParseItem(TfrxXMLItem).
ValidUTF8(String) | Represents method ValidUTF8(String).
Top


TOSMFile.GetCountOfNodes Method

Summary

Represents method GetCountOfNodes.

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 function GetCountOfNodes: Integer;

Return Value

Type: Integer

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.GetCountOfWays Method

Summary

Represents method GetCountOfWays.

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 function GetCountOfWays: Integer;

Return Value

Type: Integer

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.GetNodes(integer) Method

Summary

Represents method GetNodes(integer).

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 function GetNodes(Index: integer): TOSMNode;

Parameters

Index
Type: integer

Return Value

Type: TOSMNode

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.GetWays(integer) Method

Summary

Represents method GetWays(integer).

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 function GetWays(Index: integer): TOSMWay;

Parameters

Index
Type: integer

Return Value

Type: TOSMWay

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.IsGetNodeAsPoint(integer,integer,TDoublePoint) Method

Summary

Represents method IsGetNodeAsPoint(integer,integer,TDoublePoint).

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 function IsGetNodeAsPoint(const iWay, iNode: integer; out DP: TDoublePoint): boolean;

Parameters

iWay
Type: integer

iNode
Type: integer

DP
Type: TDoublePoint

Return Value

Type: boolean

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.IsValidBounds Method

Summary

Represents method IsValidBounds.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 function IsValidBounds: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.Load(string) Method

Summary

Represents method Load(string).

Namespace: frxOSMFileFormat
Syntax
Delphi
protected
 procedure Load(const FileName: string);

Parameters

FileName
Type: string

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.LoadBounds(TfrxXMLItem) Method

Summary

Represents method LoadBounds(TfrxXMLItem).

Namespace: frxOSMFileFormat
Syntax
Delphi
protected
 procedure LoadBounds(XMLItem: TfrxXMLItem);

Parameters

XMLItem
Type: TfrxXMLItem

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.LoadNode(TfrxXMLItem) Method

Summary

Represents method LoadNode(TfrxXMLItem).

Namespace: frxOSMFileFormat
Syntax
Delphi
protected
 procedure LoadNode(XMLItem: TfrxXMLItem);

Parameters

XMLItem
Type: TfrxXMLItem

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.LoadWay(TfrxXMLItem) Method

Summary

Represents method LoadWay(TfrxXMLItem).

Namespace: frxOSMFileFormat
Syntax
Delphi
protected
 procedure LoadWay(XMLItem: TfrxXMLItem);

Parameters

XMLItem
Type: TfrxXMLItem

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.ParseItem(TfrxXMLItem) Method

Summary

Represents method ParseItem(TfrxXMLItem).

Namespace: frxOSMFileFormat
Syntax
Delphi
protected
 procedure ParseItem(XMLItem: TfrxXMLItem);

Parameters

XMLItem
Type: TfrxXMLItem

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.ValidUTF8(String) Method

Summary

Represents method ValidUTF8(String).

Namespace: frxOSMFileFormat
Syntax
Delphi
protected
 function ValidUTF8(st: String): String;

Parameters

st
Type: String

Return Value

Type: String

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile Fields

Fields
Name | Description
FOSMNodes | Represents field FOSMNodes.
FOSMWays | Represents field FOSMWays.
FSumTags | Represents field FSumTags.
FValidBounds | Represents field FValidBounds.
FXmax | Represents field FXmax.
FXmin | Represents field FXmin.
FYmax | Represents field FYmax.
FYmin | Represents field FYmin.
Top


TOSMFile.FOSMNodes Field

Summary

Represents field FOSMNodes.

Namespace: frxOSMFileFormat
Syntax
Delphi
protected
 FOSMNodes: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.FOSMWays Field

Summary

Represents field FOSMWays.

Namespace: frxOSMFileFormat
Syntax
Delphi
protected
 FOSMWays: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.FSumTags Field

Summary

Represents field FSumTags.

Namespace: frxOSMFileFormat
Syntax
Delphi
protected
 FSumTags: TfrxSumStringList;

Field Value

Type: TfrxSumStringList

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.FValidBounds Field

Summary

Represents field FValidBounds.

Namespace: frxOSMFileFormat
Syntax
Delphi
protected
 FValidBounds: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.FXmax Field

Summary

Represents field FXmax.

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 FXmax: Double;

Field Value

Type: Double

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.FXmin Field

Summary

Represents field FXmin.

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 FXmin: Double;

Field Value

Type: Double

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.FYmax Field

Summary

Represents field FYmax.

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 FYmax: Double;

Field Value

Type: Double

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMFile.FYmin Field

Summary

Represents field FYmin.

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 FYmin: Double;

Field Value

Type: Double

See Also

Reference

  • TOSMFile
  • frxOSMFileFormat


TOSMNode Class

Summary

Represents type TOSMNode.

Namespace: frxOSMFileFormat
Inheritance Hierarchy
TObject
frxMapHelpers.TTaggedElement
frxOSMFileFormat.TOSMNode
Syntax
Delphi
type
 TOSMNode = class(TTaggedElement)
 end;

The TOSMNode type exposes the following members.

Constructors
Show:
Name | Description
Create(Double,Double) | Initializes a new instance of the TOSMNode class.
Top
Properties
Show:
Name | Description
Latitude | Represents property Latitude.
Longitude | Represents property Longitude.
Tags | Represents property Tags. (Inherited from TTaggedElement.)
Top
Methods
Show:
Name | Description
AddTag(String,String) | Represents method AddTag(String,String). (Inherited from TTaggedElement.)
IsHaveAllTags(TStrings) | Represents method IsHaveAllTags(TStrings). (Inherited from TTaggedElement.)
IsHaveAnyTag(TStrings) | Represents method IsHaveAnyTag(TStrings). (Inherited from TTaggedElement.)
Top
Fields
Show:
Name | Description
FLatitude | Represents field FLatitude.
FLongitude | Represents field FLongitude.
FTags | Represents field FTags. (Inherited from TTaggedElement.)
Top
See Also

Reference

  • frxOSMFileFormat


TOSMNode Constructors

Constructors
Name | Description
Create(Double,Double) | Initializes a new instance of the TOSMNode class.
Top


TOSMNode.Create(Double,Double) Constructor

Summary

Initializes a new instance of the TOSMNode class.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 constructor Create(Lat, Lon: Double);

Parameters

Lat
Type: Double

Lon
Type: Double

See Also

Reference

  • TOSMNode
  • frxOSMFileFormat


TOSMNode Properties

Properties
Name | Description
Latitude | Represents property Latitude.
Longitude | Represents property Longitude.
Top


TOSMNode.Latitude Property

Summary

Represents property Latitude.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property Latitude: Double read FLatitude;

Property Value

Type: Double

See Also

Reference

  • TOSMNode
  • frxOSMFileFormat


TOSMNode.Longitude Property

Summary

Represents property Longitude.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property Longitude: Double read FLongitude;

Property Value

Type: Double

See Also

Reference

  • TOSMNode
  • frxOSMFileFormat


TOSMNode Fields

Fields
Name | Description
FLatitude | Represents field FLatitude.
FLongitude | Represents field FLongitude.
Top


TOSMNode.FLatitude Field

Summary

Represents field FLatitude.

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 FLatitude: Double;

Field Value

Type: Double

See Also

Reference

  • TOSMNode
  • frxOSMFileFormat


TOSMNode.FLongitude Field

Summary

Represents field FLongitude.

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 FLongitude: Double;

Field Value

Type: Double

See Also

Reference

  • TOSMNode
  • frxOSMFileFormat


TOSMWay Class

Summary

Represents type TOSMWay.

Namespace: frxOSMFileFormat
Inheritance Hierarchy
TObject
frxMapHelpers.TTaggedElement
frxOSMFileFormat.TOSMWay
Syntax
Delphi
type
 TOSMWay = class(TTaggedElement)
 end;

The TOSMWay type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TOSMWay class.
Destroy | Represents the destructor of the TOSMWay class. (Overrides TTaggedElement.Destroy.)
Top
Properties
Show:
Name | Description
Count | Represents property Count.
NodeRefs[Integer] | Represents property NodeRefs[Integer].
ShapeType | Represents property ShapeType.
Tags | Represents property Tags. (Inherited from TTaggedElement.)
Top
Methods
Show:
Name | Description
AddNodeRef(String) | Represents method AddNodeRef(String).
AddTag(String,String) | Represents method AddTag(String,String). (Inherited from TTaggedElement.)
GetCount | Represents method GetCount.
GetNodes(Integer) | Represents method GetNodes(Integer).
GetShapeType | Represents method GetShapeType.
IsHaveAllTags(TStrings) | Represents method IsHaveAllTags(TStrings). (Inherited from TTaggedElement.)
IsHaveAnyTag(TStrings) | Represents method IsHaveAnyTag(TStrings). (Inherited from TTaggedElement.)
Top
Fields
Show:
Name | Description
FNodeRefs | Represents field FNodeRefs.
FTags | Represents field FTags. (Inherited from TTaggedElement.)
Top
See Also

Reference

  • frxOSMFileFormat


TOSMWay Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TOSMWay class.
Destroy | Represents the destructor of the TOSMWay class. (Overrides TTaggedElement.Destroy.)
Top


TOSMWay.Create Constructor

Summary

Initializes a new instance of the TOSMWay class.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TOSMWay
  • frxOSMFileFormat


TOSMWay.Destroy Destructor

Summary

Represents the destructor of the TOSMWay class.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TTaggedElement.Destroy
See Also

Reference

  • TOSMWay
  • frxOSMFileFormat


TOSMWay Properties

Properties
Name | Description
Count | Represents property Count.
NodeRefs[Integer] | Represents property NodeRefs[Integer].
ShapeType | Represents property ShapeType.
Top


TOSMWay.Count Property

Summary

Represents property Count.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property Count: integer read GetCount;

Property Value

Type: integer

See Also

Reference

  • TOSMWay
  • frxOSMFileFormat


TOSMWay.NodeRefs[Integer] Property

Summary

Represents property NodeRefs[Integer].

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property NodeRefs[Index: Integer]: String read GetNodes;

Parameters

Index
Type: Integer

Property Value

Type: String

See Also

Reference

  • TOSMWay
  • frxOSMFileFormat


TOSMWay.ShapeType Property

Summary

Represents property ShapeType.

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 property ShapeType: TShapeType read GetShapeType;

Property Value

Type: TShapeType

See Also

Reference

  • TOSMWay
  • frxOSMFileFormat


TOSMWay Methods

Methods
Name | Description
AddNodeRef(String) | Represents method AddNodeRef(String).
GetCount | Represents method GetCount.
GetNodes(Integer) | Represents method GetNodes(Integer).
GetShapeType | Represents method GetShapeType.
Top


TOSMWay.AddNodeRef(String) Method

Summary

Represents method AddNodeRef(String).

Namespace: frxOSMFileFormat
Syntax
Delphi
public
 procedure AddNodeRef(const stNodeRef: String);

Parameters

stNodeRef
Type: String

See Also

Reference

  • TOSMWay
  • frxOSMFileFormat


TOSMWay.GetCount Method

Summary

Represents method GetCount.

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 function GetCount: integer;

Return Value

Type: integer

See Also

Reference

  • TOSMWay
  • frxOSMFileFormat


TOSMWay.GetNodes(Integer) Method

Summary

Represents method GetNodes(Integer).

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 function GetNodes(Index: Integer): String;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TOSMWay
  • frxOSMFileFormat


TOSMWay.GetShapeType Method

Summary

Represents method GetShapeType.

Namespace: frxOSMFileFormat
Syntax
Delphi
private
 function GetShapeType: TShapeType;

Return Value

Type: TShapeType

See Also

Reference

  • TOSMWay
  • frxOSMFileFormat


TOSMWay Fields

Fields
Name | Description
FNodeRefs | Represents field FNodeRefs.
Top


TOSMWay.FNodeRefs Field

Summary

Represents field FNodeRefs.

Namespace: frxOSMFileFormat
Syntax
Delphi
protected
 FNodeRefs: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TOSMWay
  • frxOSMFileFormat


frxPictureCache Namespace

Summary

Represents namespace frxPictureCache.

Classes
Name | Description
TfrxCacheList | Represents type TfrxCacheList.
TfrxFileStream | Represents type TfrxFileStream.
TfrxMemoryStream | Represents type TfrxMemoryStream.
TfrxPictureCache | Represents type TfrxPictureCache.
Top
Records
Name | Description
TfrxCacheItem | Represents type TfrxCacheItem.
Top
Types
Name | Description
PfrxCacheItem | Represents a pointer type to TfrxCacheItem.
Top


frxPictureCache Classes

Classes
Name | Description
TfrxCacheList | Represents type TfrxCacheList.
TfrxFileStream | Represents type TfrxFileStream.
TfrxMemoryStream | Represents type TfrxMemoryStream.
TfrxPictureCache | Represents type TfrxPictureCache.
Top


TfrxCacheList Class

Summary

Represents type TfrxCacheList.

Namespace: frxPictureCache
Inheritance Hierarchy
TObject
frxPictureCache.TfrxCacheList
Syntax
Delphi
type
 TfrxCacheList = class(TObject)
 end;

The TfrxCacheList type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxCacheList class.
Destroy | Represents the destructor of the TfrxCacheList class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add | Represents method Add.
Clear | Represents method Clear.
Count | Represents method Count.
Get(Integer) | Represents method Get(Integer).
Top
Fields
Show:
Name | Description
FItems | Represents field FItems.
Top
See Also

Reference

  • frxPictureCache


TfrxCacheList Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxCacheList class.
Destroy | Represents the destructor of the TfrxCacheList class.
Top


TfrxCacheList.Create Constructor

Summary

Initializes a new instance of the TfrxCacheList class.

Namespace: frxPictureCache
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxCacheList
  • frxPictureCache


TfrxCacheList.Destroy Destructor

Summary

Represents the destructor of the TfrxCacheList class.

Namespace: frxPictureCache
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCacheList
  • frxPictureCache


TfrxCacheList Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxCacheList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxPictureCache
Syntax
Delphi
public
 property Items[Index: Integer]: PfrxCacheItem read Get; default;

Parameters

Index
Type: Integer

Property Value

Type: PfrxCacheItem

See Also

Reference

  • TfrxCacheList
  • frxPictureCache


TfrxCacheList Methods

Methods
Name | Description
Add | Represents method Add.
Clear | Represents method Clear.
Count | Represents method Count.
Get(Integer) | Represents method Get(Integer).
Top


TfrxCacheList.Add Method

Summary

Represents method Add.

Namespace: frxPictureCache
Syntax
Delphi
public
 function Add: PfrxCacheItem;

Return Value

Type: PfrxCacheItem

See Also

Reference

  • TfrxCacheList
  • frxPictureCache


TfrxCacheList.Clear Method

Summary

Represents method Clear.

Namespace: frxPictureCache
Syntax
Delphi
protected
 procedure Clear;
See Also

Reference

  • TfrxCacheList
  • frxPictureCache


TfrxCacheList.Count Method

Summary

Represents method Count.

Namespace: frxPictureCache
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxCacheList
  • frxPictureCache


TfrxCacheList.Get(Integer) Method

Summary

Represents method Get(Integer).

Namespace: frxPictureCache
Syntax
Delphi
private
 function Get(Index: Integer): PfrxCacheItem;

Parameters

Index
Type: Integer

Return Value

Type: PfrxCacheItem

See Also

Reference

  • TfrxCacheList
  • frxPictureCache


TfrxCacheList Fields

Fields
Name | Description
FItems | Represents field FItems.
Top


TfrxCacheList.FItems Field

Summary

Represents field FItems.

Namespace: frxPictureCache
Syntax
Delphi
protected
 FItems: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxCacheList
  • frxPictureCache


TfrxFileStream Class

Summary

Represents type TfrxFileStream.

Namespace: frxPictureCache
Inheritance Hierarchy
TFileStream
frxPictureCache.TfrxFileStream
Syntax
Delphi
type
 TfrxFileStream = class(TFileStream)
 end;

The TfrxFileStream type exposes the following members.

Methods
Show:
Name | Description
Seek(Int64,TSeekOrigin) | Represents method Seek(Int64,TSeekOrigin).
Seek(Longint,Word) | Represents method Seek(Longint,Word).
Top
Fields
Show:
Name | Description
FSz | Represents field FSz.
Top
See Also

Reference

  • frxPictureCache


TfrxFileStream Methods

Methods
Name | Description
Seek(Int64,TSeekOrigin) | Represents method Seek(Int64,TSeekOrigin).
Seek(Longint,Word) | Represents method Seek(Longint,Word).
Top


TfrxFileStream.Seek(Longint,Word) Method

Summary

Represents method Seek(Longint,Word).

Namespace: frxPictureCache
Syntax
Delphi
public
 function Seek(Offset: Longint; Origin: Word): Longint; override;

Parameters

Offset
Type: Longint

Origin
Type: Word

Return Value

Type: Longint

See Also

Reference

  • TfrxFileStream
  • frxPictureCache


TfrxFileStream Fields

Fields
Name | Description
FSz | Represents field FSz.
Top


TfrxFileStream.FSz Field

Summary

Represents field FSz.

Namespace: frxPictureCache
Syntax
Delphi
private
 FSz: LongWord;

Field Value

Type: LongWord

See Also

Reference

  • TfrxFileStream
  • frxPictureCache


TfrxMemoryStream Class

Summary

Represents type TfrxMemoryStream.

Namespace: frxPictureCache
Inheritance Hierarchy
TMemoryStream
frxPictureCache.TfrxMemoryStream
Syntax
Delphi
type
 TfrxMemoryStream = class(TMemoryStream)
 end;

The TfrxMemoryStream type exposes the following members.

Methods
Show:
Name | Description
Seek(Int64,TSeekOrigin) | Represents method Seek(Int64,TSeekOrigin).
Seek(Longint,Word) | Represents method Seek(Longint,Word).
Top
Fields
Show:
Name | Description
FSz | Represents field FSz.
Top
See Also

Reference

  • frxPictureCache


TfrxMemoryStream Methods

Methods
Name | Description
Seek(Int64,TSeekOrigin) | Represents method Seek(Int64,TSeekOrigin).
Seek(Longint,Word) | Represents method Seek(Longint,Word).
Top


TfrxMemoryStream.Seek(Longint,Word) Method

Summary

Represents method Seek(Longint,Word).

Namespace: frxPictureCache
Syntax
Delphi
public
 function Seek(Offset: Longint; Origin: Word): Longint; override;

Parameters

Offset
Type: Longint

Origin
Type: Word

Return Value

Type: Longint

See Also

Reference

  • TfrxMemoryStream
  • frxPictureCache


TfrxMemoryStream Fields

Fields
Name | Description
FSz | Represents field FSz.
Top


TfrxMemoryStream.FSz Field

Summary

Represents field FSz.

Namespace: frxPictureCache
Syntax
Delphi
private
 FSz: LongWord;

Field Value

Type: LongWord

See Also

Reference

  • TfrxMemoryStream
  • frxPictureCache


TfrxPictureCache Class

Summary

Represents type TfrxPictureCache.

Namespace: frxPictureCache
Inheritance Hierarchy
TObject
frxPictureCache.TfrxPictureCache
Syntax
Delphi
type
 TfrxPictureCache = class(TObject)
 end;

The TfrxPictureCache type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxPictureCache class.
Destroy | Represents the destructor of the TfrxPictureCache class.
Top
Properties
Show:
Name | Description
TempDir | Represents property TempDir.
UseFileCache | Represents property UseFileCache.
Top
Methods
Show:
Name | Description
Add | Represents method Add.
AddPicture(TfrxPictureView) | Overloaded. Represents method AddPicture(TfrxPictureView).
AddPicture(TGraphic,Integer) | Overloaded. Represents method AddPicture(TGraphic,Integer).
AddSegment | Represents method AddSegment.
Clear | Represents method Clear.
GetPicture(TfrxPictureView) | Overloaded. Represents method GetPicture(TfrxPictureView).
GetPicture(TGraphic,Integer) | Overloaded. Represents method GetPicture(TGraphic,Integer).
LoadFromXML(TfrxXMLItem) | Represents method LoadFromXML(TfrxXMLItem).
SaveToXML(TfrxXMLItem) | Represents method SaveToXML(TfrxXMLItem).
SetTempDir(String) | Represents method SetTempDir(String).
SetUseFileCache(Boolean) | Represents method SetUseFileCache(Boolean).
Top
Fields
Show:
Name | Description
FCacheStreamList | Represents field FCacheStreamList.
FItems | Represents field FItems.
FTempDir | Represents field FTempDir.
FTempFile | Represents field FTempFile.
FUseFileCache | Represents field FUseFileCache.
Top
See Also

Reference

  • frxPictureCache


TfrxPictureCache Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxPictureCache class.
Destroy | Represents the destructor of the TfrxPictureCache class.
Top


TfrxPictureCache.Create Constructor

Summary

Initializes a new instance of the TfrxPictureCache class.

Namespace: frxPictureCache
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.Destroy Destructor

Summary

Represents the destructor of the TfrxPictureCache class.

Namespace: frxPictureCache
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache Properties

Properties
Name | Description
TempDir | Represents property TempDir.
UseFileCache | Represents property UseFileCache.
Top


TfrxPictureCache.TempDir Property

Summary

Represents property TempDir.

Namespace: frxPictureCache
Syntax
Delphi
public
 property TempDir: String read FTempDir write SetTempDir;

Property Value

Type: String

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.UseFileCache Property

Summary

Represents property UseFileCache.

Namespace: frxPictureCache
Syntax
Delphi
public
 property UseFileCache: Boolean read FUseFileCache write SetUseFileCache;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache Methods

Methods
Name | Description
Add | Represents method Add.
AddPicture(TfrxPictureView) | Overloaded. Represents method AddPicture(TfrxPictureView).
AddPicture(TGraphic,Integer) | Overloaded. Represents method AddPicture(TGraphic,Integer).
AddSegment | Represents method AddSegment.
Clear | Represents method Clear.
GetPicture(TfrxPictureView) | Overloaded. Represents method GetPicture(TfrxPictureView).
GetPicture(TGraphic,Integer) | Overloaded. Represents method GetPicture(TGraphic,Integer).
LoadFromXML(TfrxXMLItem) | Represents method LoadFromXML(TfrxXMLItem).
SaveToXML(TfrxXMLItem) | Represents method SaveToXML(TfrxXMLItem).
SetTempDir(String) | Represents method SetTempDir(String).
SetUseFileCache(Boolean) | Represents method SetUseFileCache(Boolean).
Top


TfrxPictureCache.Add Method

Summary

Represents method Add.

Namespace: frxPictureCache
Syntax
Delphi
private
 procedure Add;
See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.AddPicture(TfrxPictureView) Method

Summary

Represents method AddPicture(TfrxPictureView).

Namespace: frxPictureCache
Syntax
Delphi
public
 procedure AddPicture(Picture: TfrxPictureView); overload;

Parameters

Picture
Type: TfrxPictureView

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.AddPicture(TGraphic,Integer) Method

Summary

Represents method AddPicture(TGraphic,Integer).

Namespace: frxPictureCache
Syntax
Delphi
public
 procedure AddPicture(aGraphic: TGraphic; var ImageIndex: Integer); overload;

Parameters

aGraphic
Type: TGraphic

ImageIndex
Type: Integer

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.AddSegment Method

Summary

Represents method AddSegment.

Namespace: frxPictureCache
Syntax
Delphi
public
 procedure AddSegment;
See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.Clear Method

Summary

Represents method Clear.

Namespace: frxPictureCache
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.GetPicture(TfrxPictureView) Method

Summary

Represents method GetPicture(TfrxPictureView).

Namespace: frxPictureCache
Syntax
Delphi
public
 procedure GetPicture(Picture: TfrxPictureView); overload;

Parameters

Picture
Type: TfrxPictureView

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.GetPicture(TGraphic,Integer) Method

Summary

Represents method GetPicture(TGraphic,Integer).

Namespace: frxPictureCache
Syntax
Delphi
public
 procedure GetPicture(aGraphic: TGraphic; ImageIndex: Integer); overload;

Parameters

aGraphic
Type: TGraphic

ImageIndex
Type: Integer

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.LoadFromXML(TfrxXMLItem) Method

Summary

Represents method LoadFromXML(TfrxXMLItem).

Namespace: frxPictureCache
Syntax
Delphi
public
 procedure LoadFromXML(Item: TfrxXMLItem);

Parameters

Item
Type: TfrxXMLItem

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.SaveToXML(TfrxXMLItem) Method

Summary

Represents method SaveToXML(TfrxXMLItem).

Namespace: frxPictureCache
Syntax
Delphi
public
 procedure SaveToXML(Item: TfrxXMLItem);

Parameters

Item
Type: TfrxXMLItem

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.SetTempDir(String) Method

Summary

Represents method SetTempDir(String).

Namespace: frxPictureCache
Syntax
Delphi
private
 procedure SetTempDir(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.SetUseFileCache(Boolean) Method

Summary

Represents method SetUseFileCache(Boolean).

Namespace: frxPictureCache
Syntax
Delphi
private
 procedure SetUseFileCache(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache Fields

Fields
Name | Description
FCacheStreamList | Represents field FCacheStreamList.
FItems | Represents field FItems.
FTempDir | Represents field FTempDir.
FTempFile | Represents field FTempFile.
FUseFileCache | Represents field FUseFileCache.
Top


TfrxPictureCache.FCacheStreamList Field

Summary

Represents field FCacheStreamList.

Namespace: frxPictureCache
Syntax
Delphi
private
 FCacheStreamList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.FItems Field

Summary

Represents field FItems.

Namespace: frxPictureCache
Syntax
Delphi
private
 FItems: TfrxCacheList;

Field Value

Type: TfrxCacheList

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.FTempDir Field

Summary

Represents field FTempDir.

Namespace: frxPictureCache
Syntax
Delphi
private
 FTempDir: String;

Field Value

Type: String

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.FTempFile Field

Summary

Represents field FTempFile.

Namespace: frxPictureCache
Syntax
Delphi
private
 FTempFile: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


TfrxPictureCache.FUseFileCache Field

Summary

Represents field FUseFileCache.

Namespace: frxPictureCache
Syntax
Delphi
private
 FUseFileCache: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPictureCache
  • frxPictureCache


frxPictureCache Records

Records
Name | Description
TfrxCacheItem | Represents type TfrxCacheItem.
Top


TfrxCacheItem Record

Summary

Represents type TfrxCacheItem.

Namespace: frxPictureCache
Syntax
Delphi
type
 TfrxCacheItem = packed record
 end;

The TfrxCacheItem type exposes the following members.

Fields
Show:
Name | Description
Offset | Represents field Offset.
Segment | Represents field Segment.
Top
See Also

Reference

  • frxPictureCache


TfrxCacheItem Fields

Fields
Name | Description
Offset | Represents field Offset.
Segment | Represents field Segment.
Top


TfrxCacheItem.Offset Field

Summary

Represents field Offset.

Namespace: frxPictureCache
Syntax
Delphi
public
 Offset: Longint;

Field Value

Type: Longint

See Also

Reference

  • TfrxCacheItem
  • frxPictureCache


TfrxCacheItem.Segment Field

Summary

Represents field Segment.

Namespace: frxPictureCache
Syntax
Delphi
public
 Segment: Longint;

Field Value

Type: Longint

See Also

Reference

  • TfrxCacheItem
  • frxPictureCache


frxPictureCache Types

Types
Name | Description
PfrxCacheItem | Represents a pointer type to TfrxCacheItem.
Top


PfrxCacheItem Type

Summary

Represents a pointer type to TfrxCacheItem.

Namespace: frxPictureCache
Syntax
Delphi
type
 PfrxCacheItem = ^TfrxCacheItem;
See Also

Reference

  • frxPictureCache


frxPlatformServices Namespace

Summary

Represents namespace frxPlatformServices.

Types
Name | Description
frxInteger | Represents an alias of the NativeInt type.
Top
Constants
Name | Description
LineBreak | Represents constant LineBreak.
Top
Routines
Name | Description
frxCopy(string,frxInteger,frxInteger) | Represents method frxCopy(string,frxInteger,frxInteger).
frxDelete(string,frxInteger,frxInteger) | Overloaded. Represents method frxDelete(string,frxInteger,frxInteger).
frxDelete(WideString,frxInteger,frxInteger) | Overloaded. Represents method frxDelete(WideString,frxInteger,frxInteger).
frxGetSymbol(String,frxInteger) | Overloaded. Represents method frxGetSymbol(String,frxInteger).
frxGetSymbol(WideString,frxInteger) | Overloaded. Represents method frxGetSymbol(WideString,frxInteger).
frxInsert(string,string,frxInteger) | Overloaded. Represents method frxInsert(string,string,frxInteger).
frxInsert(Widestring,Widestring,frxInteger) | Overloaded. Represents method frxInsert(Widestring,Widestring,frxInteger).
frxLength(string) | Overloaded. Represents method frxLength(string).
frxLength(Widestring) | Overloaded. Represents method frxLength(Widestring).
frxPos(string,string) | Represents method frxPos(string,string).
frxUpperCase(string) | Overloaded. Represents method frxUpperCase(string).
frxUpperCase(Widestring) | Overloaded. Represents method frxUpperCase(Widestring).
Top


frxPlatformServices Types

Types
Name | Description
frxInteger | Represents an alias of the NativeInt type.
Top


frxInteger Type

Summary

Represents an alias of the NativeInt type.

Namespace: frxPlatformServices
Syntax
Delphi
type
 frxInteger = NativeInt;
See Also

Reference

  • frxPlatformServices


frxPlatformServices Constants

Constants
Name | Description
LineBreak | Represents constant LineBreak.
Top


LineBreak Constant

Summary

Represents constant LineBreak.

Namespace: frxPlatformServices
Syntax
Delphi
 LineBreak = #$0D#$0A;

Value

Type: string

See Also

Reference

  • frxPlatformServices


frxPlatformServices Routines

Routines
Name | Description
frxCopy(string,frxInteger,frxInteger) | Represents method frxCopy(string,frxInteger,frxInteger).
frxDelete(string,frxInteger,frxInteger) | Overloaded. Represents method frxDelete(string,frxInteger,frxInteger).
frxDelete(WideString,frxInteger,frxInteger) | Overloaded. Represents method frxDelete(WideString,frxInteger,frxInteger).
frxGetSymbol(String,frxInteger) | Overloaded. Represents method frxGetSymbol(String,frxInteger).
frxGetSymbol(WideString,frxInteger) | Overloaded. Represents method frxGetSymbol(WideString,frxInteger).
frxInsert(string,string,frxInteger) | Overloaded. Represents method frxInsert(string,string,frxInteger).
frxInsert(Widestring,Widestring,frxInteger) | Overloaded. Represents method frxInsert(Widestring,Widestring,frxInteger).
frxLength(string) | Overloaded. Represents method frxLength(string).
frxLength(Widestring) | Overloaded. Represents method frxLength(Widestring).
frxPos(string,string) | Represents method frxPos(string,string).
frxUpperCase(string) | Overloaded. Represents method frxUpperCase(string).
frxUpperCase(Widestring) | Overloaded. Represents method frxUpperCase(Widestring).
Top


frxCopy(string,frxInteger,frxInteger) Method

Summary

Represents method frxCopy(string,frxInteger,frxInteger).

Namespace: frxPlatformServices
Syntax
Delphi
function frxCopy(const s: string; Index, Count: frxInteger): string; inline;

Parameters

s
Type: string

Index
Type: System.Void

Count
Type: System.Void

Return Value

Type: string

See Also

Reference

  • frxPlatformServices


frxDelete(string,frxInteger,frxInteger) Method

Summary

Represents method frxDelete(string,frxInteger,frxInteger).

Namespace: frxPlatformServices
Syntax
Delphi
procedure frxDelete(var s: string; Index, Count: frxInteger);overload; inline;

Parameters

s
Type: string

Index
Type: System.Void

Count
Type: System.Void

See Also

Reference

  • frxPlatformServices


frxDelete(WideString,frxInteger,frxInteger) Method

Summary

Represents method frxDelete(WideString,frxInteger,frxInteger).

Namespace: frxPlatformServices
Syntax
Delphi
procedure frxDelete(var s: WideString; Index, Count: frxInteger); overload; inline;

Parameters

s
Type: WideString

Index
Type: System.Void

Count
Type: System.Void

See Also

Reference

  • frxPlatformServices


frxGetSymbol(String,frxInteger) Method

Summary

Represents method frxGetSymbol(String,frxInteger).

Namespace: frxPlatformServices
Syntax
Delphi
function frxGetSymbol(const str: String; Index: frxInteger): Char; overload; inline;

Parameters

str
Type: String

Index
Type: System.Void

Return Value

Type: Char

See Also

Reference

  • frxPlatformServices


frxGetSymbol(WideString,frxInteger) Method

Summary

Represents method frxGetSymbol(WideString,frxInteger).

Namespace: frxPlatformServices
Syntax
Delphi
function frxGetSymbol(const str: WideString; Index: frxInteger): WideChar; overload; inline;

Parameters

str
Type: WideString

Index
Type: System.Void

Return Value

Type: WideChar

See Also

Reference

  • frxPlatformServices


frxInsert(string,string,frxInteger) Method

Summary

Represents method frxInsert(string,string,frxInteger).

Namespace: frxPlatformServices
Syntax
Delphi
procedure frxInsert(const source: string; var s: string; Index: frxInteger); overload; inline;

Parameters

source
Type: string

s
Type: string

Index
Type: System.Void

See Also

Reference

  • frxPlatformServices


frxInsert(Widestring,Widestring,frxInteger) Method

Summary

Represents method frxInsert(Widestring,Widestring,frxInteger).

Namespace: frxPlatformServices
Syntax
Delphi
procedure frxInsert(const source: Widestring; var s: Widestring; Index: frxInteger); overload; inline;

Parameters

source
Type: Widestring

s
Type: Widestring

Index
Type: System.Void

See Also

Reference

  • frxPlatformServices


frxLength(string) Method

Summary

Represents method frxLength(string).

Namespace: frxPlatformServices
Syntax
Delphi
 function frxLength(s: string): frxInteger;overload; inline;

Parameters

s
Type: string

Return Value

Type: frxInteger

See Also

Reference

  • frxPlatformServices


frxLength(Widestring) Method

Summary

Represents method frxLength(Widestring).

Namespace: frxPlatformServices
Syntax
Delphi
function frxLength(s: Widestring): frxInteger; overload; inline;

Parameters

s
Type: Widestring

Return Value

Type: frxInteger

See Also

Reference

  • frxPlatformServices


frxPos(string,string) Method

Summary

Represents method frxPos(string,string).

Namespace: frxPlatformServices
Syntax
Delphi
function frxPos(const substr, s: string): frxInteger; inline;

Parameters

substr
Type: string

s
Type: string

Return Value

Type: frxInteger

See Also

Reference

  • frxPlatformServices


frxUpperCase(string) Method

Summary

Represents method frxUpperCase(string).

Namespace: frxPlatformServices
Syntax
Delphi
function frxUpperCase(const s: string): string; overload; inline;

Parameters

s
Type: string

Return Value

Type: string

See Also

Reference

  • frxPlatformServices


frxUpperCase(Widestring) Method

Summary

Represents method frxUpperCase(Widestring).

Namespace: frxPlatformServices
Syntax
Delphi
function frxUpperCase(const s: Widestring): Widestring; overload; inline;

Parameters

s
Type: Widestring

Return Value

Type: Widestring

See Also

Reference

  • frxPlatformServices


frxPolygonTemplate Namespace

Summary

Represents namespace frxPolygonTemplate.

Classes
Name | Description
TAbstractTemplateComponent | Represents type TAbstractTemplateComponent.
TfrxPolygonTemplate | Represents type TfrxPolygonTemplate.
TfrxPolygonTemplateList | Represents type TfrxPolygonTemplateList.
TPointIndexByName | Represents type TPointIndexByName.
TTemplateComponentList | Represents type TTemplateComponentList.
Top
Variables
Name | Description
PolygonTemplateList | Represents variable PolygonTemplateList.
Top


frxPolygonTemplate Classes

Classes
Name | Description
TAbstractTemplateComponent | Represents type TAbstractTemplateComponent.
TfrxPolygonTemplate | Represents type TfrxPolygonTemplate.
TfrxPolygonTemplateList | Represents type TfrxPolygonTemplateList.
TPointIndexByName | Represents type TPointIndexByName.
TTemplateComponentList | Represents type TTemplateComponentList.
Top


TAbstractTemplateComponent Class

Summary

Represents type TAbstractTemplateComponent.

Namespace: frxPolygonTemplate
Inheritance Hierarchy
TObject
frxPolygonTemplate.TAbstractTemplateComponent
Syntax
Delphi
type
 TAbstractTemplateComponent = class
 end;

The TAbstractTemplateComponent type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxJSON,TPointIndexByName) | Initializes a new instance of the TAbstractTemplateComponent class.
Top
Methods
Show:
Name | Description
Draw(TCanvas,TPointArray) | Represents method Draw(TCanvas,TPointArray).
Top
Fields
Show:
Name | Description
FPointIndex | Represents field FPointIndex.
FPointIndexByName | Represents field FPointIndexByName.
Top
See Also

Reference

  • frxPolygonTemplate


TAbstractTemplateComponent Constructors

Constructors
Name | Description
Create(TfrxJSON,TPointIndexByName) | Initializes a new instance of the TAbstractTemplateComponent class.
Top


TAbstractTemplateComponent.Create(TfrxJSON,TPointIndexByName) Constructor

Summary

Initializes a new instance of the TAbstractTemplateComponent class.

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 constructor Create(JSON: TfrxJSON; PointIndexByName: TPointIndexByName);

Parameters

JSON
Type: TfrxJSON

PointIndexByName
Type: TPointIndexByName

See Also

Reference

  • TAbstractTemplateComponent
  • frxPolygonTemplate


TAbstractTemplateComponent Methods

Methods
Name | Description
Draw(TCanvas,TPointArray) | Represents method Draw(TCanvas,TPointArray).
Top


TAbstractTemplateComponent.Draw(TCanvas,TPointArray) Method

Summary

Represents method Draw(TCanvas,TPointArray).

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; Points: TPointArray); virtual; abstract;

Parameters

Canvas
Type: TCanvas

Points
Type: TPointArray

See Also

Reference

  • TAbstractTemplateComponent
  • frxPolygonTemplate


TAbstractTemplateComponent Fields

Fields
Name | Description
FPointIndex | Represents field FPointIndex.
FPointIndexByName | Represents field FPointIndexByName.
Top


TAbstractTemplateComponent.FPointIndex Field

Summary

Represents field FPointIndex.

Namespace: frxPolygonTemplate
Syntax
Delphi
protected
 FPointIndex: array of Integer;

Field Value

Type: array of Integer

See Also

Reference

  • TAbstractTemplateComponent
  • frxPolygonTemplate


TAbstractTemplateComponent.FPointIndexByName Field

Summary

Represents field FPointIndexByName.

Namespace: frxPolygonTemplate
Syntax
Delphi
protected
 FPointIndexByName: TPointIndexByName;

Field Value

Type: TPointIndexByName

See Also

Reference

  • TAbstractTemplateComponent
  • frxPolygonTemplate


TfrxPolygonTemplate Class

Summary

Represents type TfrxPolygonTemplate.

Namespace: frxPolygonTemplate
Inheritance Hierarchy
TObject
frxPolygonTemplate.TfrxPolygonTemplate
Syntax
Delphi
type
 TfrxPolygonTemplate = class
 end;

The TfrxPolygonTemplate type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxJSON) | Initializes a new instance of the TfrxPolygonTemplate class.
Destroy | Represents the destructor of the TfrxPolygonTemplate class.
Top
Properties
Show:
Name | Description
Count | Represents property Count.
Name | Represents property Name.
Top
Methods
Show:
Name | Description
Draw(TCanvas,TPointArray,Boolean) | Represents method Draw(TCanvas,TPointArray,Boolean).
DrawWithNames(TCanvas,TPointArray) | Represents method DrawWithNames(TCanvas,TPointArray).
LoadArray(TfrxJSON,String) | Represents method LoadArray(TfrxJSON,String).
Top
Fields
Show:
Name | Description
FCount | Represents field FCount.
FName | Represents field FName.
FPointIndexByName | Represents field FPointIndexByName.
FTemplateComponentList | Represents field FTemplateComponentList.
Top
See Also

Reference

  • frxPolygonTemplate


TfrxPolygonTemplate Constructors

Constructors
Name | Description
Create(TfrxJSON) | Initializes a new instance of the TfrxPolygonTemplate class.
Destroy | Represents the destructor of the TfrxPolygonTemplate class.
Top


TfrxPolygonTemplate.Create(TfrxJSON) Constructor

Summary

Initializes a new instance of the TfrxPolygonTemplate class.

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 constructor Create(JSON: TfrxJSON);

Parameters

JSON
Type: TfrxJSON

See Also

Reference

  • TfrxPolygonTemplate
  • frxPolygonTemplate


TfrxPolygonTemplate.Destroy Destructor

Summary

Represents the destructor of the TfrxPolygonTemplate class.

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxPolygonTemplate
  • frxPolygonTemplate


TfrxPolygonTemplate Properties

Properties
Name | Description
Count | Represents property Count.
Name | Represents property Name.
Top


TfrxPolygonTemplate.Count Property

Summary

Represents property Count.

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 property Count: Integer read FCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxPolygonTemplate
  • frxPolygonTemplate


TfrxPolygonTemplate.Name Property

Summary

Represents property Name.

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 property Name: String read FName;

Property Value

Type: String

See Also

Reference

  • TfrxPolygonTemplate
  • frxPolygonTemplate


TfrxPolygonTemplate Methods

Methods
Name | Description
Draw(TCanvas,TPointArray,Boolean) | Represents method Draw(TCanvas,TPointArray,Boolean).
DrawWithNames(TCanvas,TPointArray) | Represents method DrawWithNames(TCanvas,TPointArray).
LoadArray(TfrxJSON,String) | Represents method LoadArray(TfrxJSON,String).
Top


TfrxPolygonTemplate.Draw(TCanvas,TPointArray,Boolean) Method

Summary

Represents method Draw(TCanvas,TPointArray,Boolean).

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; Points: TPointArray; DrawNames: Boolean = False);

Parameters

Canvas
Type: TCanvas

Points
Type: TPointArray

DrawNames
Type: Boolean

See Also

Reference

  • TfrxPolygonTemplate
  • frxPolygonTemplate


TfrxPolygonTemplate.DrawWithNames(TCanvas,TPointArray) Method

Summary

Represents method DrawWithNames(TCanvas,TPointArray).

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 procedure DrawWithNames(Canvas: TCanvas; Points: TPointArray);

Parameters

Canvas
Type: TCanvas

Points
Type: TPointArray

See Also

Reference

  • TfrxPolygonTemplate
  • frxPolygonTemplate


TfrxPolygonTemplate.LoadArray(TfrxJSON,String) Method

Summary

Represents method LoadArray(TfrxJSON,String).

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 procedure LoadArray(JSON: TfrxJSON; nm: String);

Parameters

JSON
Type: TfrxJSON

nm
Type: String

See Also

Reference

  • TfrxPolygonTemplate
  • frxPolygonTemplate


TfrxPolygonTemplate Fields

Fields
Name | Description
FCount | Represents field FCount.
FName | Represents field FName.
FPointIndexByName | Represents field FPointIndexByName.
FTemplateComponentList | Represents field FTemplateComponentList.
Top


TfrxPolygonTemplate.FCount Field

Summary

Represents field FCount.

Namespace: frxPolygonTemplate
Syntax
Delphi
private
 FCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPolygonTemplate
  • frxPolygonTemplate


TfrxPolygonTemplate.FName Field

Summary

Represents field FName.

Namespace: frxPolygonTemplate
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxPolygonTemplate
  • frxPolygonTemplate


TfrxPolygonTemplate.FPointIndexByName Field

Summary

Represents field FPointIndexByName.

Namespace: frxPolygonTemplate
Syntax
Delphi
protected
 FPointIndexByName: TPointIndexByName;

Field Value

Type: TPointIndexByName

See Also

Reference

  • TfrxPolygonTemplate
  • frxPolygonTemplate


TfrxPolygonTemplate.FTemplateComponentList Field

Summary

Represents field FTemplateComponentList.

Namespace: frxPolygonTemplate
Syntax
Delphi
protected
 FTemplateComponentList: TTemplateComponentList;

Field Value

Type: TTemplateComponentList

See Also

Reference

  • TfrxPolygonTemplate
  • frxPolygonTemplate


TfrxPolygonTemplateList Class

Summary

Represents type TfrxPolygonTemplateList.

Namespace: frxPolygonTemplate
Inheritance Hierarchy
TObjectList
frxPolygonTemplate.TfrxPolygonTemplateList
Syntax
Delphi
type
 TfrxPolygonTemplateList = class(TObjectList)
 end;

The TfrxPolygonTemplateList type exposes the following members.

Constructors
Show:
Name | Description
Create(TFileName) | Initializes a new instance of the TfrxPolygonTemplateList class.
Top
Properties
Show:
Name | Description
ItemsByName[String] | Represents property ItemsByName[String].
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
GetItemsByName(String) | Represents method GetItemsByName(String).
GetTemplate(Integer) | Represents method GetTemplate(Integer).
SetTemplate(Integer,TfrxPolygonTemplate) | Represents method SetTemplate(Integer,TfrxPolygonTemplate).
Top
Fields
Show:
Name | Description
FVersion | Represents field FVersion.
Top
See Also

Reference

  • frxPolygonTemplate


TfrxPolygonTemplateList Constructors

Constructors
Name | Description
Create(TFileName) | Initializes a new instance of the TfrxPolygonTemplateList class.
Top


TfrxPolygonTemplateList.Create(TFileName) Constructor

Summary

Initializes a new instance of the TfrxPolygonTemplateList class.

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 constructor Create(FileName: TFileName);

Parameters

FileName
Type: TFileName

See Also

Reference

  • TfrxPolygonTemplateList
  • frxPolygonTemplate


TfrxPolygonTemplateList Properties

Properties
Name | Description
ItemsByName[String] | Represents property ItemsByName[String].
Items[Integer] | Represents property Items[Integer].
Top


TfrxPolygonTemplateList.ItemsByName[String] Property

Summary

Represents property ItemsByName[String].

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 property ItemsByName[Name: String]: TfrxPolygonTemplate read GetItemsByName;

Parameters

Name
Type: String

Property Value

Type: TfrxPolygonTemplate

See Also

Reference

  • TfrxPolygonTemplateList
  • frxPolygonTemplate


TfrxPolygonTemplateList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxPolygonTemplate read GetTemplate write SetTemplate; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxPolygonTemplate

See Also

Reference

  • TfrxPolygonTemplateList
  • frxPolygonTemplate


TfrxPolygonTemplateList Methods

Methods
Name | Description
GetItemsByName(String) | Represents method GetItemsByName(String).
GetTemplate(Integer) | Represents method GetTemplate(Integer).
SetTemplate(Integer,TfrxPolygonTemplate) | Represents method SetTemplate(Integer,TfrxPolygonTemplate).
Top


TfrxPolygonTemplateList.GetItemsByName(String) Method

Summary

Represents method GetItemsByName(String).

Namespace: frxPolygonTemplate
Syntax
Delphi
private
 function GetItemsByName(Name: String): TfrxPolygonTemplate;

Parameters

Name
Type: String

Return Value

Type: TfrxPolygonTemplate

See Also

Reference

  • TfrxPolygonTemplateList
  • frxPolygonTemplate


TfrxPolygonTemplateList.GetTemplate(Integer) Method

Summary

Represents method GetTemplate(Integer).

Namespace: frxPolygonTemplate
Syntax
Delphi
private
 function GetTemplate(Index: Integer): TfrxPolygonTemplate;

Parameters

Index
Type: Integer

Return Value

Type: TfrxPolygonTemplate

See Also

Reference

  • TfrxPolygonTemplateList
  • frxPolygonTemplate


TfrxPolygonTemplateList.SetTemplate(Integer,TfrxPolygonTemplate) Method

Summary

Represents method SetTemplate(Integer,TfrxPolygonTemplate).

Namespace: frxPolygonTemplate
Syntax
Delphi
private
 procedure SetTemplate(Index: Integer; const Value: TfrxPolygonTemplate);

Parameters

Index
Type: Integer

Value
Type: TfrxPolygonTemplate

See Also

Reference

  • TfrxPolygonTemplateList
  • frxPolygonTemplate


TfrxPolygonTemplateList Fields

Fields
Name | Description
FVersion | Represents field FVersion.
Top


TfrxPolygonTemplateList.FVersion Field

Summary

Represents field FVersion.

Namespace: frxPolygonTemplate
Syntax
Delphi
protected
 FVersion: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPolygonTemplateList
  • frxPolygonTemplate


TPointIndexByName Class

Summary

Represents type TPointIndexByName.

Namespace: frxPolygonTemplate
Inheritance Hierarchy
TObject
frxPolygonTemplate.TPointIndexByName
Syntax
Delphi
type
 TPointIndexByName = class
 end;

The TPointIndexByName type exposes the following members.

Constructors
Show:
Name | Description
Create(TObject) | Initializes a new instance of the TPointIndexByName class.
Destroy | Represents the destructor of the TPointIndexByName class.
Top
Properties
Show:
Name | Description
IndexByName[String] | Represents property IndexByName[String].
NameBitmap[Integer] | Represents property NameBitmap[Integer].
Top
Methods
Show:
Name | Description
Count | Represents method Count.
GetIndexByName(String) | Represents method GetIndexByName(String).
GetNameBitmap(Integer) | Represents method GetNameBitmap(Integer).
Top
Fields
Show:
Name | Description
FNameBitmap | Represents field FNameBitmap.
FPointName | Represents field FPointName.
Top
See Also

Reference

  • frxPolygonTemplate


TPointIndexByName Constructors

Constructors
Name | Description
Create(TObject) | Initializes a new instance of the TPointIndexByName class.
Destroy | Represents the destructor of the TPointIndexByName class.
Top


TPointIndexByName.Create(TObject) Constructor

Summary

Initializes a new instance of the TPointIndexByName class.

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 constructor Create(JSON: TObject);

Parameters

JSON
Type: TObject

See Also

Reference

  • TPointIndexByName
  • frxPolygonTemplate


TPointIndexByName.Destroy Destructor

Summary

Represents the destructor of the TPointIndexByName class.

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TPointIndexByName
  • frxPolygonTemplate


TPointIndexByName Properties

Properties
Name | Description
IndexByName[String] | Represents property IndexByName[String].
NameBitmap[Integer] | Represents property NameBitmap[Integer].
Top


TPointIndexByName.IndexByName[String] Property

Summary

Represents property IndexByName[String].

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 property IndexByName[Name: String]: Integer read GetIndexByName;

Parameters

Name
Type: String

Property Value

Type: Integer

See Also

Reference

  • TPointIndexByName
  • frxPolygonTemplate


TPointIndexByName.NameBitmap[Integer] Property

Summary

Represents property NameBitmap[Integer].

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 property NameBitmap[Index: Integer]: TBitmap read GetNameBitmap;

Parameters

Index
Type: Integer

Property Value

Type: TBitmap

See Also

Reference

  • TPointIndexByName
  • frxPolygonTemplate


TPointIndexByName Methods

Methods
Name | Description
Count | Represents method Count.
GetIndexByName(String) | Represents method GetIndexByName(String).
GetNameBitmap(Integer) | Represents method GetNameBitmap(Integer).
Top


TPointIndexByName.Count Method

Summary

Represents method Count.

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TPointIndexByName
  • frxPolygonTemplate


TPointIndexByName.GetIndexByName(String) Method

Summary

Represents method GetIndexByName(String).

Namespace: frxPolygonTemplate
Syntax
Delphi
private
 function GetIndexByName(Name: String): Integer;

Parameters

Name
Type: String

Return Value

Type: Integer

See Also

Reference

  • TPointIndexByName
  • frxPolygonTemplate


TPointIndexByName.GetNameBitmap(Integer) Method

Summary

Represents method GetNameBitmap(Integer).

Namespace: frxPolygonTemplate
Syntax
Delphi
private
 function GetNameBitmap(Index: Integer): TBitmap;

Parameters

Index
Type: Integer

Return Value

Type: TBitmap

See Also

Reference

  • TPointIndexByName
  • frxPolygonTemplate


TPointIndexByName Fields

Fields
Name | Description
FNameBitmap | Represents field FNameBitmap.
FPointName | Represents field FPointName.
Top


TPointIndexByName.FNameBitmap Field

Summary

Represents field FNameBitmap.

Namespace: frxPolygonTemplate
Syntax
Delphi
protected
 FNameBitmap: array of TBitmap;

Field Value

Type: array of TBitmap

See Also

Reference

  • TPointIndexByName
  • frxPolygonTemplate


TPointIndexByName.FPointName Field

Summary

Represents field FPointName.

Namespace: frxPolygonTemplate
Syntax
Delphi
protected
 FPointName: array of String;

Field Value

Type: array of String

See Also

Reference

  • TPointIndexByName
  • frxPolygonTemplate


TTemplateComponentList Class

Summary

Represents type TTemplateComponentList.

Namespace: frxPolygonTemplate
Inheritance Hierarchy
TObjectList
frxPolygonTemplate.TTemplateComponentList
Syntax
Delphi
type
 TTemplateComponentList = class(TObjectList)
 end;

The TTemplateComponentList type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TTemplateComponentList class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
GetItems(Integer) | Represents method GetItems(Integer).
SetItems(Integer,TAbstractTemplateComponent) | Represents method SetItems(Integer,TAbstractTemplateComponent).
Top
See Also

Reference

  • frxPolygonTemplate


TTemplateComponentList Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TTemplateComponentList class.
Top


TTemplateComponentList.Create Constructor

Summary

Initializes a new instance of the TTemplateComponentList class.

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TTemplateComponentList
  • frxPolygonTemplate


TTemplateComponentList Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TTemplateComponentList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxPolygonTemplate
Syntax
Delphi
public
 property Items[Index: Integer]: TAbstractTemplateComponent read GetItems write SetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TAbstractTemplateComponent

See Also

Reference

  • TTemplateComponentList
  • frxPolygonTemplate


TTemplateComponentList Methods

Methods
Name | Description
GetItems(Integer) | Represents method GetItems(Integer).
SetItems(Integer,TAbstractTemplateComponent) | Represents method SetItems(Integer,TAbstractTemplateComponent).
Top


TTemplateComponentList.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxPolygonTemplate
Syntax
Delphi
private
 function GetItems(Index: Integer): TAbstractTemplateComponent;

Parameters

Index
Type: Integer

Return Value

Type: TAbstractTemplateComponent

See Also

Reference

  • TTemplateComponentList
  • frxPolygonTemplate


TTemplateComponentList.SetItems(Integer,TAbstractTemplateComponent) Method

Summary

Represents method SetItems(Integer,TAbstractTemplateComponent).

Namespace: frxPolygonTemplate
Syntax
Delphi
private
 procedure SetItems(Index: Integer; const Value: TAbstractTemplateComponent);

Parameters

Index
Type: Integer

Value
Type: TAbstractTemplateComponent

See Also

Reference

  • TTemplateComponentList
  • frxPolygonTemplate


frxPolygonTemplate Variables

Variables
Name | Description
PolygonTemplateList | Represents variable PolygonTemplateList.
Top


PolygonTemplateList Variable

Summary

Represents variable PolygonTemplateList.

Namespace: frxPolygonTemplate
Syntax
Delphi
PolygonTemplateList: TfrxPolygonTemplateList;

Value

Type: TfrxPolygonTemplateList

See Also

Reference

  • frxPolygonTemplate


frxPopupForm Namespace

Summary

Represents namespace frxPopupForm.

Classes
Name | Description
TfrxPopupForm | Represents type TfrxPopupForm.
Top
Variables
Name | Description
frxPopupFormCloseTime | Represents variable frxPopupFormCloseTime.
Top


frxPopupForm Classes

Classes
Name | Description
TfrxPopupForm | Represents type TfrxPopupForm.
Top


TfrxPopupForm Class

Summary

Represents type TfrxPopupForm.

Namespace: frxPopupForm
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxPopupForm.TfrxPopupForm
Syntax
Delphi
type
 TfrxPopupForm = class(TfrxBaseForm)
 end;

The TfrxPopupForm type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseForm class. (Inherited from TfrxBaseForm.)
Top
Properties
Show:
Name | Description
CurrentFormPPI | Returns current PPI value of the form. (Inherited from TfrxBaseForm.)
IsPPIChanging | Represents property IsPPIChanging. (Inherited from TfrxBaseForm.)
Resizable | Represents property Resizable.
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseForm.)
AfterPPIChange | Represents method AfterPPIChange. (Inherited from TfrxBaseForm.)
AfterPPIMessage | Represents method AfterPPIMessage. (Inherited from TfrxBaseForm.)
BeforeDestruction | Represents method BeforeDestruction. (Inherited from TfrxBaseForm.)
BeforePPIChange | Represents method BeforePPIChange. (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer). (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean). (Inherited from TfrxBaseForm.)
DoClose(TCloseAction) | Represents method DoClose(TCloseAction). (Inherited from TfrxBaseForm.)
DoShow | Represents method DoShow. (Inherited from TfrxBaseForm.)
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer). (Inherited from TfrxBaseForm.)
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormDeactivate(TObject) | Represents method FormDeactivate(TObject).
FormShowAfterLoad | Represents method FormShowAfterLoad. (Inherited from TfrxBaseForm.)
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Inherited from TfrxBaseForm.)
GetAvailablePreferences | Represents method GetAvailablePreferences. (Inherited from TfrxBaseForm.)
GetFormSectionName | Represents method GetFormSectionName. (Inherited from TfrxBaseForm.)
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Inherited from TfrxBaseForm.)
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Inherited from TfrxBaseForm.)
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter. (Inherited from TfrxBaseForm.)
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Inherited from TfrxBaseForm.)
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxBaseForm.)
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms. (Inherited from TfrxBaseForm.)
SetResizable(Boolean) | Represents method SetResizable(Boolean).
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form. (Inherited from TfrxBaseForm.)
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Inherited from TfrxBaseForm.)
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Inherited from TfrxBaseForm.)
WMNCHitTest(TWMNCHitTest) | Represents method WMNCHitTest(TWMNCHitTest).
Top
Fields
Show:
Name | Description
FHostedControls | Represents field FHostedControls. (Inherited from TfrxBaseForm.)
FPrefEvent | Represents field FPrefEvent. (Inherited from TfrxBaseForm.)
FResizable | Represents field FResizable.
Top
See Also

Reference

  • frxPopupForm


TfrxPopupForm Properties

Properties
Name | Description
Resizable | Represents property Resizable.
Top


TfrxPopupForm.Resizable Property

Summary

Represents property Resizable.

Namespace: frxPopupForm
Syntax
Delphi
public
 property Resizable: Boolean read FResizable write SetResizable;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPopupForm
  • frxPopupForm


TfrxPopupForm Methods

Methods
Name | Description
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormDeactivate(TObject) | Represents method FormDeactivate(TObject).
SetResizable(Boolean) | Represents method SetResizable(Boolean).
WMNCHitTest(TWMNCHitTest) | Represents method WMNCHitTest(TWMNCHitTest).
Top


TfrxPopupForm.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: frxPopupForm
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var CloseAction: TCloseAction);

Parameters

Sender
Type: TObject

CloseAction
Type: TCloseAction

See Also

Reference

  • TfrxPopupForm
  • frxPopupForm


TfrxPopupForm.FormDeactivate(TObject) Method

Summary

Represents method FormDeactivate(TObject).

Namespace: frxPopupForm
Syntax
Delphi
published
 procedure FormDeactivate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPopupForm
  • frxPopupForm


TfrxPopupForm.SetResizable(Boolean) Method

Summary

Represents method SetResizable(Boolean).

Namespace: frxPopupForm
Syntax
Delphi
private
 procedure SetResizable(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPopupForm
  • frxPopupForm


TfrxPopupForm.WMNCHitTest(TWMNCHitTest) Method

Summary

Represents method WMNCHitTest(TWMNCHitTest).

Namespace: frxPopupForm
Syntax
Delphi
private
 procedure WMNCHitTest(var Message: TWMNCHitTest); message WM_NCHITTEST;

Parameters

Message
Type: TWMNCHitTest

See Also

Reference

  • TfrxPopupForm
  • frxPopupForm


TfrxPopupForm Fields

Fields
Name | Description
FResizable | Represents field FResizable.
Top


TfrxPopupForm.FResizable Field

Summary

Represents field FResizable.

Namespace: frxPopupForm
Syntax
Delphi
private
 FResizable: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPopupForm
  • frxPopupForm


frxPopupForm Variables

Variables
Name | Description
frxPopupFormCloseTime | Represents variable frxPopupFormCloseTime.
Top


frxPopupFormCloseTime Variable

Summary

Represents variable frxPopupFormCloseTime.

Namespace: frxPopupForm
Syntax
Delphi
frxPopupFormCloseTime: UInt = 0;

Value

Type: UInt

See Also

Reference

  • frxPopupForm


frxPreview Namespace

Summary

Represents namespace frxPreview.

Classes
Name | Description
TfrxPageItem | Represents type TfrxPageItem.
TfrxPageList | Represents type TfrxPageList.
TfrxPreview | The TfrxPreview component is designed for creation of custom preview windows. To display a report, the link to this component should be assigned to the "TfrxReport.Preview" property.
TfrxPreviewForm | Represents type TfrxPreviewForm.
TfrxPreviewTabItem | Represents type TfrxPreviewTabItem.
TfrxPreviewTabs | Represents type TfrxPreviewTabs.
TfrxPreviewWorkspace | Represents type TfrxPreviewWorkspace.
Top
Records
Name | Description
TfrxFindAllTextItem | Represents type TfrxFindAllTextItem.
TfrxTrvData | Represents type TfrxTrvData.
Top
Enumerations
Name | Description
TfrxPreviewTool | Represents type TfrxPreviewTool.
Top
Delegates
Name | Description
TfrxFindAllTextCallbackFunc | Represents type TfrxFindAllTextCallbackFunc.
TfrxPageChangedEvent | This event is generated when the current page is being changed.
Top
Types
Name | Description
PfrxTrvData | Represents a pointer type to TfrxTrvData.
Top
Constants
Name | Description
WM_UPDATEZOOM | Represents constant WM_UPDATEZOOM.
Top


frxPreview Classes

Classes
Name | Description
TfrxPageItem | Represents type TfrxPageItem.
TfrxPageList | Represents type TfrxPageList.
TfrxPreview | The TfrxPreview component is designed for creation of custom preview windows. To display a report, the link to this component should be assigned to the "TfrxReport.Preview" property.
TfrxPreviewForm | Represents type TfrxPreviewForm.
TfrxPreviewTabItem | Represents type TfrxPreviewTabItem.
TfrxPreviewTabs | Represents type TfrxPreviewTabs.
TfrxPreviewWorkspace | Represents type TfrxPreviewWorkspace.
Top


TfrxPageItem Class

Summary

Represents type TfrxPageItem.

Namespace: frxPreview
Inheritance Hierarchy
TCollectionItem
frxPreview.TfrxPageItem
Syntax
Delphi
type
 TfrxPageItem = class(TCollectionItem)
 end;

The TfrxPageItem type exposes the following members.

Fields
Show:
Name | Description
Height | Represents field Height.
OffsetX | Represents field OffsetX.
OffsetY | Represents field OffsetY.
Width | Represents field Width.
Top
See Also

Reference

  • frxPreview


TfrxPageItem Fields

Fields
Name | Description
Height | Represents field Height.
OffsetX | Represents field OffsetX.
OffsetY | Represents field OffsetY.
Width | Represents field Width.
Top


TfrxPageItem.Height Field

Summary

Represents field Height.

Namespace: frxPreview
Syntax
Delphi
public
 Height: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPageItem
  • frxPreview


TfrxPageItem.OffsetX Field

Summary

Represents field OffsetX.

Namespace: frxPreview
Syntax
Delphi
public
 OffsetX: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPageItem
  • frxPreview


TfrxPageItem.OffsetY Field

Summary

Represents field OffsetY.

Namespace: frxPreview
Syntax
Delphi
public
 OffsetY: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPageItem
  • frxPreview


TfrxPageItem.Width Field

Summary

Represents field Width.

Namespace: frxPreview
Syntax
Delphi
public
 Width: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPageItem
  • frxPreview


TfrxPageList Class

Summary

Represents type TfrxPageList.

Namespace: frxPreview
Inheritance Hierarchy
TCollection
frxPreview.TfrxPageList
Syntax
Delphi
type
 TfrxPageList = class(TCollection)
 end;

The TfrxPageList type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxPageList class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
AddPage(Integer,Integer,Extended) | Represents method AddPage(Integer,Integer,Extended).
CalcBounds(Integer) | Represents method CalcBounds(Integer).
FindPage(Integer,Integer) | Represents method FindPage(Integer,Integer).
GetItems(Integer) | Represents method GetItems(Integer).
GetMaxBounds | Represents method GetMaxBounds.
GetPageBounds(Integer,Integer,Extended,Boolean) | Represents method GetPageBounds(Integer,Integer,Extended,Boolean).
Top
Fields
Show:
Name | Description
FMaxWidth | Represents field FMaxWidth.
Top
See Also

Reference

  • frxPreview


TfrxPageList Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxPageList class.
Top


TfrxPageList.Create Constructor

Summary

Initializes a new instance of the TfrxPageList class.

Namespace: frxPreview
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxPageList
  • frxPreview


TfrxPageList Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxPageList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxPreview
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxPageItem read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxPageItem

See Also

Reference

  • TfrxPageList
  • frxPreview


TfrxPageList Methods

Methods
Name | Description
AddPage(Integer,Integer,Extended) | Represents method AddPage(Integer,Integer,Extended).
CalcBounds(Integer) | Represents method CalcBounds(Integer).
FindPage(Integer,Integer) | Represents method FindPage(Integer,Integer).
GetItems(Integer) | Represents method GetItems(Integer).
GetMaxBounds | Represents method GetMaxBounds.
GetPageBounds(Integer,Integer,Extended,Boolean) | Represents method GetPageBounds(Integer,Integer,Extended,Boolean).
Top


TfrxPageList.AddPage(Integer,Integer,Extended) Method

Summary

Represents method AddPage(Integer,Integer,Extended).

Namespace: frxPreview
Syntax
Delphi
public
 procedure AddPage(AWidth, AHeight: Integer; Zoom: Extended);

Parameters

AWidth
Type: Integer

AHeight
Type: Integer

Zoom
Type: Extended

See Also

Reference

  • TfrxPageList
  • frxPreview


TfrxPageList.CalcBounds(Integer) Method

Summary

Represents method CalcBounds(Integer).

Namespace: frxPreview
Syntax
Delphi
public
 procedure CalcBounds(ClientWidth: Integer);

Parameters

ClientWidth
Type: Integer

See Also

Reference

  • TfrxPageList
  • frxPreview


TfrxPageList.FindPage(Integer,Integer) Method

Summary

Represents method FindPage(Integer,Integer).

Namespace: frxPreview
Syntax
Delphi
public
 function FindPage(OffsetY: Integer; OffsetX: Integer = 0): Integer;

Parameters

OffsetY
Type: Integer

OffsetX
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TfrxPageList
  • frxPreview


TfrxPageList.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxPreview
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxPageItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxPageItem

See Also

Reference

  • TfrxPageList
  • frxPreview


TfrxPageList.GetMaxBounds Method

Summary

Represents method GetMaxBounds.

Namespace: frxPreview
Syntax
Delphi
public
 function GetMaxBounds: TPoint;

Return Value

Type: TPoint

See Also

Reference

  • TfrxPageList
  • frxPreview


TfrxPageList.GetPageBounds(Integer,Integer,Extended,Boolean) Method

Summary

Represents method GetPageBounds(Integer,Integer,Extended,Boolean).

Namespace: frxPreview
Syntax
Delphi
public
 function GetPageBounds(Index, ClientWidth: Integer; Scale: Extended; RTL: Boolean): TRect;

Parameters

Index
Type: Integer

ClientWidth
Type: Integer

Scale
Type: Extended

RTL
Type: Boolean

Return Value

Type: TRect

See Also

Reference

  • TfrxPageList
  • frxPreview


TfrxPageList Fields

Fields
Name | Description
FMaxWidth | Represents field FMaxWidth.
Top


TfrxPageList.FMaxWidth Field

Summary

Represents field FMaxWidth.

Namespace: frxPreview
Syntax
Delphi
private
 FMaxWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPageList
  • frxPreview


TfrxPreview Class

Summary

The TfrxPreview component is designed for creation of custom preview windows. To display a report, the link to this component should be assigned to the "TfrxReport.Preview" property.

Namespace: frxPreview
Inheritance Hierarchy
TCustomControl
frxClass.TfrxCustomPreview
frxPreview.TfrxPreview
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxPreview = class(TfrxCustomPreview)
 end;

The TfrxPreview type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPreview class. (Overrides TfrxCustomPreview.Create(TComponent).)
Destroy | Represents the destructor of the TfrxPreview class. (Overrides TfrxCustomPreview.Destroy.)
Top
Properties
Show:
Name Description
ActiveFrameColor

The color of active page frame.

Align

Represents property Align.

Anchors

Represents property Anchors.

BackColor

The workspace color.

BevelEdges

Represents property BevelEdges.

BevelInner

Represents property BevelInner.

BevelKind

Represents property BevelKind.

BevelOuter

Represents property BevelOuter.

BorderStyle

Represents property BorderStyle.

BorderWidth

Represents property BorderWidth.

Constraints

Represents property Constraints.

EachReportInTab

Represents property EachReportInTab.

Enabled

Represents property Enabled.

FindFmVisible

Represents property FindFmVisible.

FindSplitter

Represents property FindSplitter.

FrameColor

The page frame color.

HideScrolls

Represents property HideScrolls.

HighlightEditable

Represents property HighlightEditable.

Locked

Flag returns state of window blocking.

OnClick

Represents property OnClick.

OnDblClick

Represents property OnDblClick.

OnMouseDown

Represents property OnMouseDown.

OutlineColor

Represents property OutlineColor.

OutlineTree

Reference to Outline Tree window.

OutlineVisible

Report tree visibility.

OutlineWidth

Represents property OutlineWidth.

PageCount

Number of pages in a report.

PageNo

The current page number (starts from 1). To move to a required page, assign a value to this property.

PopupMenu

Represents property PopupMenu.

PreviewPages

Reference to an active preview pages object. (Inherited from TfrxCustomPreview.)

Report

Reference to an active report object. (Inherited from TfrxCustomPreview.)

SearchFrm

Represents property SearchFrm.

Splitter

Reference to spliter object

TabItems

Represents property TabItems.

Thumbnail

Reference to Thumbnail window object.

ThumbnailVisible

Thumbnails visibility.

Tool

Represents property Tool.

UseReportHints

Represents property UseReportHints.

Visible

Represents property Visible.

Workspace

Reference to preview Workspace object.

Zoom

The scaling factor. "1" conforms 100% scale.

ZoomMode

Zoom mode. The following values are available:
zmDefault - scale can be set with the help of the "Zoom" property;
zmWholePage - the whole page fits;
zmPageWidth - the page fits by width;
zmManyPages - two pages fit.

Top
Methods
Show:
Name Description
AddCloseBtnToImageList

Represents method AddCloseBtnToImageList.

AddPage

Adds a blank page to the end of the report.

AddPreviewTab(TfrxReport,String,String,Boolean,String)

Creates a new tab in the preview window linked with passed report object. (Overrides TfrxCustomPreview.AddPreviewTab(TfrxReport,String,String,Boolean,String).)

AddPreviewTabOrSwitch(TfrxReport,String,String,Boolean,String)

Creates or switch to a new tab in the preview window linked with passed report object. (Overrides TfrxCustomPreview.AddPreviewTabOrSwitch(TfrxReport,String,String,Boolean,String).)

Cancel

Aborts a report constructing.

Clear

Clears a report.

ClearAllTabs

Represents method ClearAllTabs.

ClearPageList

Represents method ClearPageList.

CreateParams(TCreateParams)

Represents method CreateParams(TCreateParams).

DeletePage

Deletes the current page.

DoFinishInPlace(TObject,Boolean,Boolean)

Represents method DoFinishInPlace(TObject,Boolean,Boolean). (Overrides TfrxCustomPreview.DoFinishInPlace(TObject,Boolean,Boolean).)

Edit

Loads the current page for editing to the designer.

EditTemplate

Represents method EditTemplate.

Export(TfrxCustomExportFilter)

Exports the report using the specified export filter.

Find

Displays the text searching dialogue.

FindNext

Continues searching the text.

FindText(String,Boolean,Boolean)

Represents method FindText(String,Boolean,Boolean).

FindTextClear

Represents method FindTextClear.

FindTextFound

Represents method FindTextFound.

First

Moves to the first page.

GetActiveFrameColor

Represents method GetActiveFrameColor.

GetBackColor

Represents method GetBackColor.

GetFindFmVisible

Represents method GetFindFmVisible.

GetFrameColor

Represents method GetFrameColor.

GetHideScrolls

Represents method GetHideScrolls.

GetHighlightEditable

Represents method GetHighlightEditable.

GetLocked

Represents method GetLocked.

GetOnMouseDown

Represents method GetOnMouseDown.

GetOnScrollMaxChange

Represents method GetOnScrollMaxChange.

GetOnScrollPosChange

Represents method GetOnScrollPosChange.

GetOutlineVisible

Represents method GetOutlineVisible.

GetOutlineWidth

Represents method GetOutlineWidth.

GetPageCount

Represents method GetPageCount.

GetPreviewPages

Represents method GetPreviewPages. (Overrides TfrxCustomPreview.GetPreviewPages.)

GetReport

Represents method GetReport. (Overrides TfrxCustomPreview.GetReport.)

GetThumbnailVisible

Represents method GetThumbnailVisible.

GetTopPosition

Return position on the current page.

HasTab(String)

Overloaded. Checks if preview has Tab with giving name. (Overrides TfrxCustomPreview.HasTab(String).)

HasTab(TfrxReport)

Overloaded. Checks if preview has Tab with giving report object. (Overrides TfrxCustomPreview.HasTab(TfrxReport).)

HasVisibleTabs

Returns True when report preview has visible tabs. (Overrides TfrxCustomPreview.HasVisibleTabs.)

HideMessage

Represents method HideMessage.

Init(TfrxReport,TfrxCustomPreviewPages)

Initializes report preview with giving report and preview pages. (Overrides TfrxCustomPreview.Init(TfrxReport,TfrxCustomPreviewPages).)

InternalCopy

Copies content for selected objects to clipboard. This method uses InPlace editors to process copy behaviour of the selected objects. (Inherited from TfrxCustomPreview.)

InternalIsPasteAvailable

This method checks if paste is available for selected objects from clipboard. It uses InPlace editors to process copy-paste behaviour of the selected objects. (Inherited from TfrxCustomPreview.)

InternalOnProgress(TfrxReport,TfrxProgressType,Integer)

The report engine calls this method to update action progress at current report(preparation, export, print). (Overrides TfrxCustomPreview.InternalOnProgress(TfrxReport,TfrxProgressType,Integer).)

InternalOnProgressStart(TfrxReport,TfrxProgressType,Integer)

The report engine calls this method when starts some action at current report(preparation, export, print). (Overrides TfrxCustomPreview.InternalOnProgressStart(TfrxReport,TfrxProgressType,Integer).)

InternalOnProgressStop(TfrxReport,TfrxProgressType,Integer)

The report engine calls this method when stops some action at current report(preparation, export, print). (Overrides TfrxCustomPreview.InternalOnProgressStop(TfrxReport,TfrxProgressType,Integer).)

InternalPaste

Pastes content to selected objects from clipboard. This method uses InPlace editors to process paste behaviour of the selected objects. (Inherited from TfrxCustomPreview.)

KeyDown(Word,TShiftState)

Represents method KeyDown(Word,TShiftState).

Last

Moves to the last page.

LoadFromFile

Overloaded. Displays the file loading dialogue.

LoadFromFile(String)

Overloaded. Loads a file without displaying the dialogue.

Lock

Locks report preview for any update and draw operations. (Overrides TfrxCustomPreview.Lock.)

MouseWheelScroll(Integer,TShiftState,TPoint,Boolean)

Scrolls the preview window. This method is used for Form.OnMouseWheel event handler:

Delphi
procedure TForm1.FormMouseWheel(Sender: TObject;   Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint;    var Handled: Boolean);    begin      frxPreview1.MouseWheelScroll(WheelDelta);    end;
Next

Moves to the next page.

OnCancel(TObject)

Represents method OnCancel(TObject).

OnChangeTab(TObject)

Represents method OnChangeTab(TObject).

OnCollapseClick(TObject)

Represents method OnCollapseClick(TObject).

OnExpandClick(TObject)

Represents method OnExpandClick(TObject).

OnFindClick(TObject)

Represents method OnFindClick(TObject).

OnMoveSplitter(TObject)

Represents method OnMoveSplitter(TObject).

OnOutlineClick(TObject)

Represents method OnOutlineClick(TObject).

OnTabMouseUP(TObject,TMouseButton,TShiftState,Integer,Integer)

Represents method OnTabMouseUP(TObject,TMouseButton,TShiftState,Integer,Integer).

OnTrvFindChange(TObject,TTreeNode)

Represents method OnTrvFindChange(TObject,TTreeNode).

PageSetupDialog

Displays the page setting dialogue.

PageSetupDlg

Displays the page setting dialogue.

PreviewPagesChanged

Called when active preview pages was changed. (Overrides TfrxCustomPreview.PreviewPagesChanged.)

Print

Prints a report.

Prior

Moves to the previous page.

RefreshReport

Rebuilds a report for current active preview pages. (Overrides TfrxCustomPreview.RefreshReport.)

RemoveTab(Integer)

Closes and removes Tab from report preview. (Overrides TfrxCustomPreview.RemoveTab(Integer).)

RemoveTabs(TfrxReport)

Represents method RemoveTabs(TfrxReport).

Resize

Represents method Resize.

SaveToFile

Overloaded. Displays the file saving dialogue.

SaveToFile(String)

Overloaded. Saves a file without displaying the dialogue.

SetActiveFrameColor(TColor)

Represents method SetActiveFrameColor(TColor).

SetActivePage(Integer)

Represents method SetActivePage(Integer).

SetBackColor(TColor)

Represents method SetBackColor(TColor).

SetBorderStyle(TBorderStyle)

Represents method SetBorderStyle(TBorderStyle).

SetDefaultEventParams(TfrxInteractiveEventsParams)

This method initialize TfrxInteractiveEventsParams structure with default values. (Inherited from TfrxCustomPreview.)

SetFindFmVisible(Boolean)

Represents method SetFindFmVisible(Boolean).

SetFrameColor(TColor)

Represents method SetFrameColor(TColor).

SetHideScrolls(Boolean)

Represents method SetHideScrolls(Boolean).

SetHighlightEditable(Boolean)

Represents method SetHighlightEditable(Boolean).

SetOnMouseDown(TMouseEvent)

Represents method SetOnMouseDown(TMouseEvent).

SetOnScrollMaxChange(TfrxScrollMaxChangeEvent)

Represents method SetOnScrollMaxChange(TfrxScrollMaxChangeEvent).

SetOnScrollPosChange(TfrxScrollPosChangeEvent)

Represents method SetOnScrollPosChange(TfrxScrollPosChangeEvent).

SetOutlineColor(TColor)

Represents method SetOutlineColor(TColor).

SetOutlineVisible(Boolean)

Represents method SetOutlineVisible(Boolean).

SetOutlineWidth(Integer)

Represents method SetOutlineWidth(Integer).

SetPageNo(Integer)

Represents method SetPageNo(Integer).

SetPosition(Integer,Integer)

Moves to the page PageN and top position Top on the page.

SetThumbnailVisible(Boolean)

Represents method SetThumbnailVisible(Boolean).

SetZoom(Extended)

Represents method SetZoom(Extended).

SetZoomMode(TfrxZoomMode)

Represents method SetZoomMode(TfrxZoomMode).

ShowMessage(String)

Represents method ShowMessage(String).

SwitchToTab(String)

Overloaded. Switches to Tab by giving name. (Overrides TfrxCustomPreview.SwitchToTab(String).)

SwitchToTab(TfrxReport)

Overloaded. Switches to Tab by giving report. (Overrides TfrxCustomPreview.SwitchToTab(TfrxReport).)

UnInit(TfrxReport)

Uninitializes report preview for passed report component.
(Overrides TfrxCustomPreview.UnInit(TfrxReport).)

Unlock(Boolean)

Unlock report preview. (Overrides TfrxCustomPreview.Unlock(Boolean).)

UpdateOutline

Represents method UpdateOutline.

UpdatePageNumbers

Represents method UpdatePageNumbers.

UpdatePages

Represents method UpdatePages.

WMEraseBackground(TMessage)

Represents method WMEraseBackground(TMessage).

WMGetDlgCode(TWMGetDlgCode)

Represents method WMGetDlgCode(TWMGetDlgCode).

Top
Events
Show:
Name | Description
OnPageChanged | This event is generated when the current page is being changed.
OnScrollMaxChange | Represents property OnScrollMaxChange.
OnScrollPosChange | Represents property OnScrollPosChange.
Top
Fields
Show:
Name | Description
DesignerFSearchFrmVisible | Represents field DesignerFSearchFrmVisible.
FAllowF3 | Represents field FAllowF3.
FBorderStyle | Represents field FBorderStyle.
FCalledFromPreview | Represents field FCalledFromPreview.
FCancelButton | Represents field FCancelButton.
FEachReportInTab | Represents field FEachReportInTab.
FFindSplitter | Represents field FFindSplitter.
FInitialized | Represents field FInitialized.
FInPlaceditorsList | Represents field FInPlaceditorsList. (Inherited from TfrxCustomPreview.)
FLocks | Represents field FLocks.
FMessageLabel | Represents field FMessageLabel.
FMessagePanel | Represents field FMessagePanel.
FOnPageChanged | Represents field FOnPageChanged.
FOutline | Represents field FOutline.
FOutlineColor | Represents field FOutlineColor.
FOutlinePopup | Represents field FOutlinePopup.
FPageNo | Represents field FPageNo.
FPreviewForm | Represents field FPreviewForm. (Inherited from TfrxCustomPreview.)
FRefreshing | Represents field FRefreshing.
FRunning | Represents field FRunning.
FSavedPageNo | Represents field FSavedPageNo.
FScrollBars | Represents field FScrollBars.
FSearchFrm | Represents field FSearchFrm.
FSelectionList | Represents field FSelectionList. (Inherited from TfrxCustomPreview.)
FSplitter | Represents field FSplitter.
FTabImgList | Represents field FTabImgList.
FTabItems | Represents field FTabItems.
FTabs | Represents field FTabs.
FThumbnail | Represents field FThumbnail.
FTick | Represents field FTick.
FTool | Represents field FTool.
FWorkspace | Represents field FWorkspace.
FZoom | Represents field FZoom.
FZoomMode | Represents field FZoomMode.
Top
See Also

Reference

  • frxPreview


TfrxPreview Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPreview class. (Overrides TfrxCustomPreview.Create(TComponent).)
Destroy | Represents the destructor of the TfrxPreview class. (Overrides TfrxCustomPreview.Destroy.)
Top


TfrxPreview.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxPreview class.

Namespace: frxPreview
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomPreview.Create(TComponent)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Destroy Destructor

Summary

Represents the destructor of the TfrxPreview class.

Namespace: frxPreview
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxCustomPreview.Destroy
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview Properties

Properties
Name Description
ActiveFrameColor

The color of active page frame.

Align

Represents property Align.

Anchors

Represents property Anchors.

BackColor

The workspace color.

BevelEdges

Represents property BevelEdges.

BevelInner

Represents property BevelInner.

BevelKind

Represents property BevelKind.

BevelOuter

Represents property BevelOuter.

BorderStyle

Represents property BorderStyle.

BorderWidth

Represents property BorderWidth.

Constraints

Represents property Constraints.

EachReportInTab

Represents property EachReportInTab.

Enabled

Represents property Enabled.

FindFmVisible

Represents property FindFmVisible.

FindSplitter

Represents property FindSplitter.

FrameColor

The page frame color.

HideScrolls

Represents property HideScrolls.

HighlightEditable

Represents property HighlightEditable.

Locked

Flag returns state of window blocking.

OnClick

Represents property OnClick.

OnDblClick

Represents property OnDblClick.

OnMouseDown

Represents property OnMouseDown.

OutlineColor

Represents property OutlineColor.

OutlineTree

Reference to Outline Tree window.

OutlineVisible

Report tree visibility.

OutlineWidth

Represents property OutlineWidth.

PageCount

Number of pages in a report.

PageNo

The current page number (starts from 1). To move to a required page, assign a value to this property.

PopupMenu

Represents property PopupMenu.

SearchFrm

Represents property SearchFrm.

Splitter

Reference to spliter object

TabItems

Represents property TabItems.

Thumbnail

Reference to Thumbnail window object.

ThumbnailVisible

Thumbnails visibility.

Tool

Represents property Tool.

UseReportHints

Represents property UseReportHints.

Visible

Represents property Visible.

Workspace

Reference to preview Workspace object.

Zoom

The scaling factor. "1" conforms 100% scale.

ZoomMode

Zoom mode. The following values are available:
zmDefault - scale can be set with the help of the "Zoom" property;
zmWholePage - the whole page fits;
zmPageWidth - the page fits by width;
zmManyPages - two pages fit.

Top


TfrxPreview.ActiveFrameColor Property

Summary

The color of active page frame.

Namespace: frxPreview
Syntax
Delphi
published
 property ActiveFrameColor: TColor read GetActiveFrameColor write SetActiveFrameColor default $3CC7FF;

Property Value

Type: TColor

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Align Property

Summary

Represents property Align.

Namespace: frxPreview
Syntax
Delphi
published
 property Align;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Anchors Property

Summary

Represents property Anchors.

Namespace: frxPreview
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.BackColor Property

Summary

The workspace color.

Namespace: frxPreview
Syntax
Delphi
published
 property BackColor: TColor read GetBackColor write SetBackColor default clGray;

Property Value

Type: TColor

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.BevelEdges Property

Summary

Represents property BevelEdges.

Namespace: frxPreview
Syntax
Delphi
published
 property BevelEdges;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.BevelInner Property

Summary

Represents property BevelInner.

Namespace: frxPreview
Syntax
Delphi
published
 property BevelInner;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.BevelKind Property

Summary

Represents property BevelKind.

Namespace: frxPreview
Syntax
Delphi
published
 property BevelKind;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.BevelOuter Property

Summary

Represents property BevelOuter.

Namespace: frxPreview
Syntax
Delphi
published
 property BevelOuter;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.BorderStyle Property

Summary

Represents property BorderStyle.

Namespace: frxPreview
Syntax
Delphi
published
 property BorderStyle: TBorderStyle read FBorderStyle write SetBorderStyle default bsSingle;

Property Value

Type: TBorderStyle

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.BorderWidth Property

Summary

Represents property BorderWidth.

Namespace: frxPreview
Syntax
Delphi
published
 property BorderWidth;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Constraints Property

Summary

Represents property Constraints.

Namespace: frxPreview
Syntax
Delphi
published
 property Constraints;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.EachReportInTab Property

Summary

Represents property EachReportInTab.

Namespace: frxPreview
Syntax
Delphi
published
 property EachReportInTab: Boolean read FEachReportInTab write FEachReportInTab default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Enabled Property

Summary

Represents property Enabled.

Namespace: frxPreview
Syntax
Delphi
published
 property Enabled;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FindFmVisible Property

Summary

Represents property FindFmVisible.

Namespace: frxPreview
Syntax
Delphi
published
 property FindFmVisible: Boolean read GetFindFmVisible write SetFindFmVisible;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FindSplitter Property

Summary

Represents property FindSplitter.

Namespace: frxPreview
Syntax
Delphi
public
 property FindSplitter: TSplitter read FFindSplitter;

Property Value

Type: TSplitter

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FrameColor Property

Summary

The page frame color.

Namespace: frxPreview
Syntax
Delphi
published
 property FrameColor: TColor read GetFrameColor write SetFrameColor default $606060;

Property Value

Type: TColor

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.HideScrolls Property

Summary

Represents property HideScrolls.

Namespace: frxPreview
Syntax
Delphi
published
 property HideScrolls: Boolean read GetHideScrolls write SetHideScrolls;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.HighlightEditable Property

Summary

Represents property HighlightEditable.

Namespace: frxPreview
Syntax
Delphi
public
 property HighlightEditable: Boolean read GetHighlightEditable write SetHighlightEditable;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Locked Property

Summary

Flag returns state of window blocking.

Namespace: frxPreview
Syntax
Delphi
public
 property Locked: Boolean read GetLocked;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnClick Property

Summary

Represents property OnClick.

Namespace: frxPreview
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxPreview
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxPreview
Syntax
Delphi
published
 property OnMouseDown: TMouseEvent read GetOnMouseDown write SetOnMouseDown;

Property Value

Type: TMouseEvent

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OutlineColor Property

Summary

Represents property OutlineColor.

Namespace: frxPreview
Syntax
Delphi
published
 property OutlineColor: TColor read FOutlineColor write SetOutlineColor default clWindow;

Property Value

Type: TColor

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OutlineTree Property

Summary

Reference to Outline Tree window.

Namespace: frxPreview
Syntax
Delphi
public
 property OutlineTree: TTreeView read FOutline;

Property Value

Type: TTreeView

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OutlineVisible Property

Summary

Report tree visibility.

Namespace: frxPreview
Syntax
Delphi
published
 property OutlineVisible: Boolean read GetOutlineVisible write SetOutlineVisible;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OutlineWidth Property

Summary

Represents property OutlineWidth.

Namespace: frxPreview
Syntax
Delphi
published
 property OutlineWidth: Integer read GetOutlineWidth write SetOutlineWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.PageCount Property

Summary

Number of pages in a report.

Namespace: frxPreview
Syntax
Delphi
public
 property PageCount: Integer read GetPageCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.PageNo Property

Summary

The current page number (starts from 1). To move to a required page, assign a value to this property.

Namespace: frxPreview
Syntax
Delphi
public
 property PageNo: Integer read FPageNo write SetPageNo;

Property Value

Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: frxPreview
Syntax
Delphi
published
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SearchFrm Property

Summary

Represents property SearchFrm.

Namespace: frxPreview
Syntax
Delphi
public
 property SearchFrm: TfrxSearchForm read FSearchFrm;

Property Value

Type: TfrxSearchForm

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Splitter Property

Summary

Reference to spliter object

Namespace: frxPreview
Syntax
Delphi
public
 property Splitter: TSplitter read FSplitter;

Property Value

Type: TSplitter

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.TabItems Property

Summary

Represents property TabItems.

Namespace: frxPreview
Syntax
Delphi
public
 property TabItems: TfrxPreviewTabs read FTabItems;

Property Value

Type: TfrxPreviewTabs

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Thumbnail Property

Summary

Reference to Thumbnail window object.

Namespace: frxPreview
Syntax
Delphi
public
 property Thumbnail: TfrxPreviewWorkspace read FThumbnail;

Property Value

Type: TfrxPreviewWorkspace

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.ThumbnailVisible Property

Summary

Thumbnails visibility.

Namespace: frxPreview
Syntax
Delphi
published
 property ThumbnailVisible: Boolean read GetThumbnailVisible write SetThumbnailVisible;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Tool Property

Summary

Represents property Tool.

Namespace: frxPreview
Syntax
Delphi
public
 property Tool: TfrxPreviewTool read FTool write FTool;

Property Value

Type: TfrxPreviewTool

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.UseReportHints Property

Summary

Represents property UseReportHints.

Namespace: frxPreview
Syntax
Delphi
published
 property UseReportHints;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Visible Property

Summary

Represents property Visible.

Namespace: frxPreview
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Workspace Property

Summary

Reference to preview Workspace object.

Namespace: frxPreview
Syntax
Delphi
public
 property Workspace: TfrxPreviewWorkspace read FWorkspace;

Property Value

Type: TfrxPreviewWorkspace

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Zoom Property

Summary

The scaling factor. "1" conforms 100% scale.

Namespace: frxPreview
Syntax
Delphi
public
 property Zoom: Extended read FZoom write SetZoom;

Property Value

Type: Extended

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.ZoomMode Property

Summary

Zoom mode. The following values are available:
zmDefault - scale can be set with the help of the "Zoom" property;
zmWholePage - the whole page fits;
zmPageWidth - the page fits by width;
zmManyPages - two pages fit.

Namespace: frxPreview
Syntax
Delphi
public
 property ZoomMode: TfrxZoomMode read FZoomMode write SetZoomMode;

Property Value

Type: TfrxZoomMode

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview Methods

Methods
Name Description
AddCloseBtnToImageList

Represents method AddCloseBtnToImageList.

AddPage

Adds a blank page to the end of the report.

AddPreviewTab(TfrxReport,String,String,Boolean,String)

Creates a new tab in the preview window linked with passed report object. (Overrides TfrxCustomPreview.AddPreviewTab(TfrxReport,String,String,Boolean,String).)

AddPreviewTabOrSwitch(TfrxReport,String,String,Boolean,String)

Creates or switch to a new tab in the preview window linked with passed report object. (Overrides TfrxCustomPreview.AddPreviewTabOrSwitch(TfrxReport,String,String,Boolean,String).)

Cancel

Aborts a report constructing.

Clear

Clears a report.

ClearAllTabs

Represents method ClearAllTabs.

ClearPageList

Represents method ClearPageList.

CreateParams(TCreateParams)

Represents method CreateParams(TCreateParams).

DeletePage

Deletes the current page.

DoFinishInPlace(TObject,Boolean,Boolean)

Represents method DoFinishInPlace(TObject,Boolean,Boolean). (Overrides TfrxCustomPreview.DoFinishInPlace(TObject,Boolean,Boolean).)

Edit

Loads the current page for editing to the designer.

EditTemplate

Represents method EditTemplate.

Export(TfrxCustomExportFilter)

Exports the report using the specified export filter.

Find

Displays the text searching dialogue.

FindNext

Continues searching the text.

FindText(String,Boolean,Boolean)

Represents method FindText(String,Boolean,Boolean).

FindTextClear

Represents method FindTextClear.

FindTextFound

Represents method FindTextFound.

First

Moves to the first page.

GetActiveFrameColor

Represents method GetActiveFrameColor.

GetBackColor

Represents method GetBackColor.

GetFindFmVisible

Represents method GetFindFmVisible.

GetFrameColor

Represents method GetFrameColor.

GetHideScrolls

Represents method GetHideScrolls.

GetHighlightEditable

Represents method GetHighlightEditable.

GetLocked

Represents method GetLocked.

GetOnMouseDown

Represents method GetOnMouseDown.

GetOnScrollMaxChange

Represents method GetOnScrollMaxChange.

GetOnScrollPosChange

Represents method GetOnScrollPosChange.

GetOutlineVisible

Represents method GetOutlineVisible.

GetOutlineWidth

Represents method GetOutlineWidth.

GetPageCount

Represents method GetPageCount.

GetPreviewPages

Represents method GetPreviewPages. (Overrides TfrxCustomPreview.GetPreviewPages.)

GetReport

Represents method GetReport. (Overrides TfrxCustomPreview.GetReport.)

GetThumbnailVisible

Represents method GetThumbnailVisible.

GetTopPosition

Return position on the current page.

HasTab(String)

Overloaded. Checks if preview has Tab with giving name. (Overrides TfrxCustomPreview.HasTab(String).)

HasTab(TfrxReport)

Overloaded. Checks if preview has Tab with giving report object. (Overrides TfrxCustomPreview.HasTab(TfrxReport).)

HasVisibleTabs

Returns True when report preview has visible tabs. (Overrides TfrxCustomPreview.HasVisibleTabs.)

HideMessage

Represents method HideMessage.

Init(TfrxReport,TfrxCustomPreviewPages)

Initializes report preview with giving report and preview pages. (Overrides TfrxCustomPreview.Init(TfrxReport,TfrxCustomPreviewPages).)

InternalOnProgress(TfrxReport,TfrxProgressType,Integer)

The report engine calls this method to update action progress at current report(preparation, export, print). (Overrides TfrxCustomPreview.InternalOnProgress(TfrxReport,TfrxProgressType,Integer).)

InternalOnProgressStart(TfrxReport,TfrxProgressType,Integer)

The report engine calls this method when starts some action at current report(preparation, export, print). (Overrides TfrxCustomPreview.InternalOnProgressStart(TfrxReport,TfrxProgressType,Integer).)

InternalOnProgressStop(TfrxReport,TfrxProgressType,Integer)

The report engine calls this method when stops some action at current report(preparation, export, print). (Overrides TfrxCustomPreview.InternalOnProgressStop(TfrxReport,TfrxProgressType,Integer).)

KeyDown(Word,TShiftState)

Represents method KeyDown(Word,TShiftState).

Last

Moves to the last page.

LoadFromFile

Overloaded. Displays the file loading dialogue.

LoadFromFile(String)

Overloaded. Loads a file without displaying the dialogue.

Lock

Locks report preview for any update and draw operations. (Overrides TfrxCustomPreview.Lock.)

MouseWheelScroll(Integer,TShiftState,TPoint,Boolean)

Scrolls the preview window. This method is used for Form.OnMouseWheel event handler:

Delphi
procedure TForm1.FormMouseWheel(Sender: TObject;   Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint;    var Handled: Boolean);    begin      frxPreview1.MouseWheelScroll(WheelDelta);    end;
Next

Moves to the next page.

OnCancel(TObject)

Represents method OnCancel(TObject).

OnChangeTab(TObject)

Represents method OnChangeTab(TObject).

OnCollapseClick(TObject)

Represents method OnCollapseClick(TObject).

OnExpandClick(TObject)

Represents method OnExpandClick(TObject).

OnFindClick(TObject)

Represents method OnFindClick(TObject).

OnMoveSplitter(TObject)

Represents method OnMoveSplitter(TObject).

OnOutlineClick(TObject)

Represents method OnOutlineClick(TObject).

OnTabMouseUP(TObject,TMouseButton,TShiftState,Integer,Integer)

Represents method OnTabMouseUP(TObject,TMouseButton,TShiftState,Integer,Integer).

OnTrvFindChange(TObject,TTreeNode)

Represents method OnTrvFindChange(TObject,TTreeNode).

PageSetupDialog

Displays the page setting dialogue.

PageSetupDlg

Displays the page setting dialogue.

PreviewPagesChanged

Called when active preview pages was changed. (Overrides TfrxCustomPreview.PreviewPagesChanged.)

Print

Prints a report.

Prior

Moves to the previous page.

RefreshReport

Rebuilds a report for current active preview pages. (Overrides TfrxCustomPreview.RefreshReport.)

RemoveTab(Integer)

Closes and removes Tab from report preview. (Overrides TfrxCustomPreview.RemoveTab(Integer).)

RemoveTabs(TfrxReport)

Represents method RemoveTabs(TfrxReport).

Resize

Represents method Resize.

SaveToFile

Overloaded. Displays the file saving dialogue.

SaveToFile(String)

Overloaded. Saves a file without displaying the dialogue.

SetActiveFrameColor(TColor)

Represents method SetActiveFrameColor(TColor).

SetActivePage(Integer)

Represents method SetActivePage(Integer).

SetBackColor(TColor)

Represents method SetBackColor(TColor).

SetBorderStyle(TBorderStyle)

Represents method SetBorderStyle(TBorderStyle).

SetFindFmVisible(Boolean)

Represents method SetFindFmVisible(Boolean).

SetFrameColor(TColor)

Represents method SetFrameColor(TColor).

SetHideScrolls(Boolean)

Represents method SetHideScrolls(Boolean).

SetHighlightEditable(Boolean)

Represents method SetHighlightEditable(Boolean).

SetOnMouseDown(TMouseEvent)

Represents method SetOnMouseDown(TMouseEvent).

SetOnScrollMaxChange(TfrxScrollMaxChangeEvent)

Represents method SetOnScrollMaxChange(TfrxScrollMaxChangeEvent).

SetOnScrollPosChange(TfrxScrollPosChangeEvent)

Represents method SetOnScrollPosChange(TfrxScrollPosChangeEvent).

SetOutlineColor(TColor)

Represents method SetOutlineColor(TColor).

SetOutlineVisible(Boolean)

Represents method SetOutlineVisible(Boolean).

SetOutlineWidth(Integer)

Represents method SetOutlineWidth(Integer).

SetPageNo(Integer)

Represents method SetPageNo(Integer).

SetPosition(Integer,Integer)

Moves to the page PageN and top position Top on the page.

SetThumbnailVisible(Boolean)

Represents method SetThumbnailVisible(Boolean).

SetZoom(Extended)

Represents method SetZoom(Extended).

SetZoomMode(TfrxZoomMode)

Represents method SetZoomMode(TfrxZoomMode).

ShowMessage(String)

Represents method ShowMessage(String).

SwitchToTab(String)

Overloaded. Switches to Tab by giving name. (Overrides TfrxCustomPreview.SwitchToTab(String).)

SwitchToTab(TfrxReport)

Overloaded. Switches to Tab by giving report. (Overrides TfrxCustomPreview.SwitchToTab(TfrxReport).)

UnInit(TfrxReport)

Uninitializes report preview for passed report component.
(Overrides TfrxCustomPreview.UnInit(TfrxReport).)

Unlock(Boolean)

Unlock report preview. (Overrides TfrxCustomPreview.Unlock(Boolean).)

UpdateOutline

Represents method UpdateOutline.

UpdatePageNumbers

Represents method UpdatePageNumbers.

UpdatePages

Represents method UpdatePages.

WMEraseBackground(TMessage)

Represents method WMEraseBackground(TMessage).

WMGetDlgCode(TWMGetDlgCode)

Represents method WMGetDlgCode(TWMGetDlgCode).

Top


TfrxPreview.AddCloseBtnToImageList Method

Summary

Represents method AddCloseBtnToImageList.

Namespace: frxPreview
Syntax
Delphi
private
 procedure AddCloseBtnToImageList;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.AddPage Method

Summary

Adds a blank page to the end of the report.

Namespace: frxPreview
Syntax
Delphi
public
 procedure AddPage;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.AddPreviewTab(TfrxReport,String,String,Boolean,String) Method

Summary

Creates a new tab in the preview window linked with passed report object.

Namespace: frxPreview
Syntax
Delphi
public
 procedure AddPreviewTab(AReport: TfrxReport; const TabName: String; const TabCaption: String = ''; FreeObjects: Boolean = True; aDetailPage: String = ''); override;

Parameters

AReport
Type: TfrxReport

Reference to a report component.

TabName
Type: String

Name of the Tab.

TabCaption
Type: String

Caption of the Tab.

FreeObjects
Type: Boolean

If True, report object which is belong to the Tab object will be freed.

aDetailPage
Type: String

Name of Detail page.

Overrides

TfrxCustomPreview.AddPreviewTab(TfrxReport,String,String,Boolean,String)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.AddPreviewTabOrSwitch(TfrxReport,String,String,Boolean,String) Method

Summary

Creates or switch to a new tab in the preview window linked with passed report object.

Namespace: frxPreview
Syntax
Delphi
public
 procedure AddPreviewTabOrSwitch(AReport: TfrxReport; const TabName: String; const TabCaption: String = ''; FreeObjects: Boolean = True; aDetailPage: String = ''); override;

Parameters

AReport
Type: TfrxReport

Reference to a report component.

TabName
Type: String

Name of the Tab.

TabCaption
Type: String

Caption of the Tab.

FreeObjects
Type: Boolean

Creates a new tab in the preview window linked with passed report object.

aDetailPage
Type: String

Name of Detail page.

Overrides

TfrxCustomPreview.AddPreviewTabOrSwitch(TfrxReport,String,String,Boolean,String)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Cancel Method

Summary

Aborts a report constructing.

Namespace: frxPreview
Syntax
Delphi
public
 procedure Cancel;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Clear Method

Summary

Clears a report.

Namespace: frxPreview
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.ClearAllTabs Method

Summary

Represents method ClearAllTabs.

Namespace: frxPreview
Syntax
Delphi
public
 procedure ClearAllTabs;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.ClearPageList Method

Summary

Represents method ClearPageList.

Namespace: frxPreview
Syntax
Delphi
private
 procedure ClearPageList;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.CreateParams(TCreateParams) Method

Summary

Represents method CreateParams(TCreateParams).

Namespace: frxPreview
Syntax
Delphi
protected
 procedure CreateParams(var Params: TCreateParams); override;

Parameters

Params
Type: TCreateParams

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.DeletePage Method

Summary

Deletes the current page.

Namespace: frxPreview
Syntax
Delphi
public
 procedure DeletePage;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.DoFinishInPlace(TObject,Boolean,Boolean) Method

Summary

Represents method DoFinishInPlace(TObject,Boolean,Boolean).

Namespace: frxPreview
Syntax
Delphi
protected
 procedure DoFinishInPlace(Sender: TObject; Refresh, Modified: Boolean); override;

Parameters

Sender
Type: TObject

Refresh
Type: Boolean

Modified
Type: Boolean

Overrides

TfrxCustomPreview.DoFinishInPlace(TObject,Boolean,Boolean)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Edit Method

Summary

Loads the current page for editing to the designer.

Namespace: frxPreview
Syntax
Delphi
public
 procedure Edit;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.EditTemplate Method

Summary

Represents method EditTemplate.

Namespace: frxPreview
Syntax
Delphi
private
 procedure EditTemplate;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Export(TfrxCustomExportFilter) Method

Summary

Exports the report using the specified export filter.

Namespace: frxPreview
Syntax
Delphi
public
 procedure Export(Filter: TfrxCustomExportFilter);

Parameters

Filter
Type: TfrxCustomExportFilter

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Find Method

Summary

Displays the text searching dialogue.

Namespace: frxPreview
Syntax
Delphi
public
 procedure Find;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FindNext Method

Summary

Continues searching the text.

Namespace: frxPreview
Syntax
Delphi
public
 procedure FindNext;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FindText(String,Boolean,Boolean) Method

Summary

Represents method FindText(String,Boolean,Boolean).

Namespace: frxPreview
Syntax
Delphi
public
 function FindText(SearchString: String; FromTop, IsCaseSensitive: Boolean): Boolean;

Parameters

SearchString
Type: String

FromTop
Type: Boolean

IsCaseSensitive
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FindTextClear Method

Summary

Represents method FindTextClear.

Namespace: frxPreview
Syntax
Delphi
public
 procedure FindTextClear;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FindTextFound Method

Summary

Represents method FindTextFound.

Namespace: frxPreview
Syntax
Delphi
public
 function FindTextFound: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.First Method

Summary

Moves to the first page.

Namespace: frxPreview
Syntax
Delphi
public
 procedure First;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetActiveFrameColor Method

Summary

Represents method GetActiveFrameColor.

Namespace: frxPreview
Syntax
Delphi
private
 function GetActiveFrameColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetBackColor Method

Summary

Represents method GetBackColor.

Namespace: frxPreview
Syntax
Delphi
private
 function GetBackColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetFindFmVisible Method

Summary

Represents method GetFindFmVisible.

Namespace: frxPreview
Syntax
Delphi
private
 function GetFindFmVisible: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetFrameColor Method

Summary

Represents method GetFrameColor.

Namespace: frxPreview
Syntax
Delphi
private
 function GetFrameColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetHideScrolls Method

Summary

Represents method GetHideScrolls.

Namespace: frxPreview
Syntax
Delphi
private
 function GetHideScrolls: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetHighlightEditable Method

Summary

Represents method GetHighlightEditable.

Namespace: frxPreview
Syntax
Delphi
private
 function GetHighlightEditable: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetLocked Method

Summary

Represents method GetLocked.

Namespace: frxPreview
Syntax
Delphi
private
 function GetLocked: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetOnMouseDown Method

Summary

Represents method GetOnMouseDown.

Namespace: frxPreview
Syntax
Delphi
private
 function GetOnMouseDown: TMouseEvent;

Return Value

Type: TMouseEvent

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetOnScrollMaxChange Method

Summary

Represents method GetOnScrollMaxChange.

Namespace: frxPreview
Syntax
Delphi
private
 function GetOnScrollMaxChange: TfrxScrollMaxChangeEvent;

Return Value

Type: TfrxScrollMaxChangeEvent

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetOnScrollPosChange Method

Summary

Represents method GetOnScrollPosChange.

Namespace: frxPreview
Syntax
Delphi
private
 function GetOnScrollPosChange: TfrxScrollPosChangeEvent;

Return Value

Type: TfrxScrollPosChangeEvent

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetOutlineVisible Method

Summary

Represents method GetOutlineVisible.

Namespace: frxPreview
Syntax
Delphi
private
 function GetOutlineVisible: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetOutlineWidth Method

Summary

Represents method GetOutlineWidth.

Namespace: frxPreview
Syntax
Delphi
private
 function GetOutlineWidth: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetPageCount Method

Summary

Represents method GetPageCount.

Namespace: frxPreview
Syntax
Delphi
private
 function GetPageCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetPreviewPages Method

Summary

Represents method GetPreviewPages.

Namespace: frxPreview
Syntax
Delphi
protected
 function GetPreviewPages: TfrxCustomPreviewPages; override;

Return Value

Type: TfrxCustomPreviewPages

Overrides

TfrxCustomPreview.GetPreviewPages
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetReport Method

Summary

Represents method GetReport.

Namespace: frxPreview
Syntax
Delphi
protected
 function GetReport: TfrxReport; override;

Return Value

Type: TfrxReport

Overrides

TfrxCustomPreview.GetReport
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetThumbnailVisible Method

Summary

Represents method GetThumbnailVisible.

Namespace: frxPreview
Syntax
Delphi
private
 function GetThumbnailVisible: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.GetTopPosition Method

Summary

Return position on the current page.

Namespace: frxPreview
Syntax
Delphi
public
 function GetTopPosition: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.HasTab(String) Method

Summary

Checks if preview has Tab with giving name.

Namespace: frxPreview
Syntax
Delphi
public
 function HasTab(const TabName: String): Boolean; overload; override;

Parameters

TabName
Type: String

Name of the Tab.

Return Value

Type: Boolean

Overrides

TfrxCustomPreview.HasTab(String)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.HasTab(TfrxReport) Method

Summary

Checks if preview has Tab with giving report object.

Namespace: frxPreview
Syntax
Delphi
public
 function HasTab(const aReport: TfrxReport): Boolean; overload; override;

Parameters

aReport
Type: TfrxReport

Reference to a report component.

Return Value

Type: Boolean

Overrides

TfrxCustomPreview.HasTab(TfrxReport)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.HasVisibleTabs Method

Summary

Returns True when report preview has visible tabs.

Namespace: frxPreview
Syntax
Delphi
public
 function HasVisibleTabs: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCustomPreview.HasVisibleTabs
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.HideMessage Method

Summary

Represents method HideMessage.

Namespace: frxPreview
Syntax
Delphi
public
 procedure HideMessage;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Init(TfrxReport,TfrxCustomPreviewPages) Method

Summary

Initializes report preview with giving report and preview pages.

Namespace: frxPreview
Syntax
Delphi
public
 function Init(aReport: TfrxReport; aPrevPages: TfrxCustomPreviewPages): Boolean; override;

Parameters

aReport
Type: TfrxReport

Reference to a report component.

aPrevPages
Type: TfrxCustomPreviewPages

Reference to preview pages object.

Return Value

Type: Boolean

Overrides

TfrxCustomPreview.Init(TfrxReport,TfrxCustomPreviewPages)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.InternalOnProgress(TfrxReport,TfrxProgressType,Integer) Method

Summary

The report engine calls this method to update action progress at current report(preparation, export, print).

Namespace: frxPreview
Syntax
Delphi
public
 procedure InternalOnProgress(Sender: TfrxReport;
 ProgressType: TfrxProgressType; Progress: Integer); override;

Parameters

Sender
Type: TfrxReport

Sender object.

ProgressType
Type: TfrxProgressType

Type of progress

Progress
Type: Integer

Progress value.

Overrides

TfrxCustomPreview.InternalOnProgress(TfrxReport,TfrxProgressType,Integer)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.InternalOnProgressStart(TfrxReport,TfrxProgressType,Integer) Method

Summary

The report engine calls this method when starts some action at current report(preparation, export, print).

Namespace: frxPreview
Syntax
Delphi
public
 procedure InternalOnProgressStart(Sender: TfrxReport;
 ProgressType: TfrxProgressType; Progress: Integer); override;

Parameters

Sender
Type: TfrxReport

Sender object.

ProgressType
Type: TfrxProgressType

Type of progress.

Progress
Type: Integer

Progress value.

Overrides

TfrxCustomPreview.InternalOnProgressStart(TfrxReport,TfrxProgressType,Integer)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.InternalOnProgressStop(TfrxReport,TfrxProgressType,Integer) Method

Summary

The report engine calls this method when stops some action at current report(preparation, export, print).

Namespace: frxPreview
Syntax
Delphi
public
 procedure InternalOnProgressStop(Sender: TfrxReport;
 ProgressType: TfrxProgressType; Progress: Integer); override;

Parameters

Sender
Type: TfrxReport

Sender object.

ProgressType
Type: TfrxProgressType

Type of progress

Progress
Type: Integer

Progress value.

Overrides

TfrxCustomPreview.InternalOnProgressStop(TfrxReport,TfrxProgressType,Integer)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.KeyDown(Word,TShiftState) Method

Summary

Represents method KeyDown(Word,TShiftState).

Namespace: frxPreview
Syntax
Delphi
protected
 procedure KeyDown(var Key: Word; Shift: TShiftState); override;

Parameters

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Last Method

Summary

Moves to the last page.

Namespace: frxPreview
Syntax
Delphi
public
 procedure Last;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.LoadFromFile Method

Summary

Displays the file loading dialogue.

Namespace: frxPreview
Syntax
Delphi
public
 procedure LoadFromFile; overload;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.LoadFromFile(String) Method

Summary

Loads a file without displaying the dialogue.

Namespace: frxPreview
Syntax
Delphi
public
 procedure LoadFromFile(FileName: String); overload;

Parameters

FileName
Type: String

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Lock Method

Summary

Locks report preview for any update and draw operations.

Namespace: frxPreview
Syntax
Delphi
public
 function Lock: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCustomPreview.Lock
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.MouseWheelScroll(Integer,TShiftState,TPoint,Boolean) Method

Summary

Scrolls the preview window. This method is used for Form.OnMouseWheel event handler:

Delphi
procedure TForm1.FormMouseWheel(Sender: TObject;
  Shift: TShiftState; WheelDelta: Integer; MousePos: TPoint;
   var Handled: Boolean);
   begin
     frxPreview1.MouseWheelScroll(WheelDelta);
   end;
Namespace: frxPreview
Syntax
Delphi
public
 procedure MouseWheelScroll(Delta: Integer; Shift: TShiftState; MousePos: TPoint; Horz: Boolean = False);

Parameters

Delta
Type: Integer

Shift
Type: TShiftState

MousePos
Type: TPoint

Horz
Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Next Method

Summary

Moves to the next page.

Namespace: frxPreview
Syntax
Delphi
public
 procedure Next;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnCancel(TObject) Method

Summary

Represents method OnCancel(TObject).

Namespace: frxPreview
Syntax
Delphi
private
 procedure OnCancel(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnChangeTab(TObject) Method

Summary

Represents method OnChangeTab(TObject).

Namespace: frxPreview
Syntax
Delphi
private
 procedure OnChangeTab(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnCollapseClick(TObject) Method

Summary

Represents method OnCollapseClick(TObject).

Namespace: frxPreview
Syntax
Delphi
private
 procedure OnCollapseClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnExpandClick(TObject) Method

Summary

Represents method OnExpandClick(TObject).

Namespace: frxPreview
Syntax
Delphi
private
 procedure OnExpandClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnFindClick(TObject) Method

Summary

Represents method OnFindClick(TObject).

Namespace: frxPreview
Syntax
Delphi
private
 procedure OnFindClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnMoveSplitter(TObject) Method

Summary

Represents method OnMoveSplitter(TObject).

Namespace: frxPreview
Syntax
Delphi
private
 procedure OnMoveSplitter(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnOutlineClick(TObject) Method

Summary

Represents method OnOutlineClick(TObject).

Namespace: frxPreview
Syntax
Delphi
private
 procedure OnOutlineClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnTabMouseUP(TObject,TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method OnTabMouseUP(TObject,TMouseButton,TShiftState,Integer,Integer).

Namespace: frxPreview
Syntax
Delphi
private
 procedure OnTabMouseUP(Sender: TObject; Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnTrvFindChange(TObject,TTreeNode) Method

Summary

Represents method OnTrvFindChange(TObject,TTreeNode).

Namespace: frxPreview
Syntax
Delphi
private
 procedure OnTrvFindChange(Sender: TObject; Node: TTreeNode);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.PageSetupDialog Method

Summary

Displays the page setting dialogue.

Namespace: frxPreview
Syntax
Delphi
public
 procedure PageSetupDialog;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.PageSetupDlg Method

Summary

Displays the page setting dialogue.

Namespace: frxPreview
Syntax
Delphi
public
 procedure PageSetupDlg;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.PreviewPagesChanged Method

Summary

Called when active preview pages was changed.

Namespace: frxPreview
Syntax
Delphi
public
 procedure PreviewPagesChanged; override;

Overrides

TfrxCustomPreview.PreviewPagesChanged
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Print Method

Summary

Prints a report.

Namespace: frxPreview
Syntax
Delphi
public
 procedure Print;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Prior Method

Summary

Moves to the previous page.

Namespace: frxPreview
Syntax
Delphi
public
 procedure Prior;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.RefreshReport Method

Summary

Rebuilds a report for current active preview pages.

Namespace: frxPreview
Syntax
Delphi
public
 procedure RefreshReport; override;

Overrides

TfrxCustomPreview.RefreshReport
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.RemoveTab(Integer) Method

Summary

Closes and removes Tab from report preview.

Namespace: frxPreview
Syntax
Delphi
public
 procedure RemoveTab(TabIndex: Integer); override;

Parameters

TabIndex
Type: Integer

Index of the Tab.

Overrides

TfrxCustomPreview.RemoveTab(Integer)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.RemoveTabs(TfrxReport) Method

Summary

Represents method RemoveTabs(TfrxReport).

Namespace: frxPreview
Syntax
Delphi
protected
 procedure RemoveTabs(aReport: TfrxReport);

Parameters

aReport
Type: TfrxReport

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Resize Method

Summary

Represents method Resize.

Namespace: frxPreview
Syntax
Delphi
protected
 procedure Resize; override;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SaveToFile Method

Summary

Displays the file saving dialogue.

Namespace: frxPreview
Syntax
Delphi
public
 procedure SaveToFile; overload;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SaveToFile(String) Method

Summary

Saves a file without displaying the dialogue.

Namespace: frxPreview
Syntax
Delphi
public
 procedure SaveToFile(FileName: String); overload;

Parameters

FileName
Type: String

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetActiveFrameColor(TColor) Method

Summary

Represents method SetActiveFrameColor(TColor).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetActiveFrameColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetActivePage(Integer) Method

Summary

Represents method SetActivePage(Integer).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetActivePage(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetBackColor(TColor) Method

Summary

Represents method SetBackColor(TColor).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetBackColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetBorderStyle(TBorderStyle) Method

Summary

Represents method SetBorderStyle(TBorderStyle).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetBorderStyle(Value: TBorderStyle);

Parameters

Value
Type: TBorderStyle

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetFindFmVisible(Boolean) Method

Summary

Represents method SetFindFmVisible(Boolean).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetFindFmVisible(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetFrameColor(TColor) Method

Summary

Represents method SetFrameColor(TColor).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetFrameColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetHideScrolls(Boolean) Method

Summary

Represents method SetHideScrolls(Boolean).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetHideScrolls(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetHighlightEditable(Boolean) Method

Summary

Represents method SetHighlightEditable(Boolean).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetHighlightEditable(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetOnMouseDown(TMouseEvent) Method

Summary

Represents method SetOnMouseDown(TMouseEvent).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetOnMouseDown(const Value: TMouseEvent);

Parameters

Value
Type: TMouseEvent

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetOnScrollMaxChange(TfrxScrollMaxChangeEvent) Method

Summary

Represents method SetOnScrollMaxChange(TfrxScrollMaxChangeEvent).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetOnScrollMaxChange(const Value: TfrxScrollMaxChangeEvent);

Parameters

Value
Type: TfrxScrollMaxChangeEvent

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetOnScrollPosChange(TfrxScrollPosChangeEvent) Method

Summary

Represents method SetOnScrollPosChange(TfrxScrollPosChangeEvent).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetOnScrollPosChange(const Value: TfrxScrollPosChangeEvent);

Parameters

Value
Type: TfrxScrollPosChangeEvent

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetOutlineColor(TColor) Method

Summary

Represents method SetOutlineColor(TColor).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetOutlineColor(const Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetOutlineVisible(Boolean) Method

Summary

Represents method SetOutlineVisible(Boolean).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetOutlineVisible(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetOutlineWidth(Integer) Method

Summary

Represents method SetOutlineWidth(Integer).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetOutlineWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetPageNo(Integer) Method

Summary

Represents method SetPageNo(Integer).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetPageNo(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetPosition(Integer,Integer) Method

Summary

Moves to the page PageN and top position Top on the page.

Namespace: frxPreview
Syntax
Delphi
public
 procedure SetPosition(PageN, Top: Integer);

Parameters

PageN
Type: Integer

Top
Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetThumbnailVisible(Boolean) Method

Summary

Represents method SetThumbnailVisible(Boolean).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetThumbnailVisible(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetZoom(Extended) Method

Summary

Represents method SetZoom(Extended).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetZoom(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SetZoomMode(TfrxZoomMode) Method

Summary

Represents method SetZoomMode(TfrxZoomMode).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetZoomMode(const Value: TfrxZoomMode);

Parameters

Value
Type: TfrxZoomMode

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.ShowMessage(String) Method

Summary

Represents method ShowMessage(String).

Namespace: frxPreview
Syntax
Delphi
public
 procedure ShowMessage(const s: String);

Parameters

s
Type: String

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SwitchToTab(String) Method

Summary

Switches to Tab by giving name.

Namespace: frxPreview
Syntax
Delphi
public
 procedure SwitchToTab(const TabName: String); overload; override;

Parameters

TabName
Type: String

Name of the Tab.

Overrides

TfrxCustomPreview.SwitchToTab(String)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.SwitchToTab(TfrxReport) Method

Summary

Switches to Tab by giving report.

Namespace: frxPreview
Syntax
Delphi
public
 procedure SwitchToTab(const aReport: TfrxReport); overload; override;

Parameters

aReport
Type: TfrxReport

Reference to a report component.

Overrides

TfrxCustomPreview.SwitchToTab(TfrxReport)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.UnInit(TfrxReport) Method

Summary

Uninitializes report preview for passed report component.

Namespace: frxPreview
Syntax
Delphi
public
 procedure UnInit(aReport: TfrxReport); override;

Parameters

aReport
Type: TfrxReport

Reference to a report component.

Overrides

TfrxCustomPreview.UnInit(TfrxReport)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.Unlock(Boolean) Method

Summary

Unlock report preview.

Namespace: frxPreview
Syntax
Delphi
public
 procedure Unlock(DoUpdate: Boolean = True); override;

Parameters

DoUpdate
Type: Boolean

Refresh after unlock.

Overrides

TfrxCustomPreview.Unlock(Boolean)
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.UpdateOutline Method

Summary

Represents method UpdateOutline.

Namespace: frxPreview
Syntax
Delphi
private
 procedure UpdateOutline;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.UpdatePageNumbers Method

Summary

Represents method UpdatePageNumbers.

Namespace: frxPreview
Syntax
Delphi
private
 procedure UpdatePageNumbers;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.UpdatePages Method

Summary

Represents method UpdatePages.

Namespace: frxPreview
Syntax
Delphi
private
 procedure UpdatePages;
See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.WMEraseBackground(TMessage) Method

Summary

Represents method WMEraseBackground(TMessage).

Namespace: frxPreview
Syntax
Delphi
private
 procedure WMEraseBackground(var Message: TMessage); message WM_ERASEBKGND;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.WMGetDlgCode(TWMGetDlgCode) Method

Summary

Represents method WMGetDlgCode(TWMGetDlgCode).

Namespace: frxPreview
Syntax
Delphi
private
 procedure WMGetDlgCode(var Message: TWMGetDlgCode); message WM_GETDLGCODE;

Parameters

Message
Type: TWMGetDlgCode

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview Events

Events
Name | Description
OnPageChanged | This event is generated when the current page is being changed.
OnScrollMaxChange | Represents property OnScrollMaxChange.
OnScrollPosChange | Represents property OnScrollPosChange.
Top


TfrxPreview.OnPageChanged Event

Summary

This event is generated when the current page is being changed.

Namespace: frxPreview
Syntax
Delphi
published
 property OnPageChanged: TfrxPageChangedEvent read FOnPageChanged write FOnPageChanged;

Value

Type: TfrxPageChangedEvent

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnScrollMaxChange Event

Summary

Represents property OnScrollMaxChange.

Namespace: frxPreview
Syntax
Delphi
published
 property OnScrollMaxChange: TfrxScrollMaxChangeEvent read GetOnScrollMaxChange write SetOnScrollMaxChange;

Value

Type: TfrxScrollMaxChangeEvent

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.OnScrollPosChange Event

Summary

Represents property OnScrollPosChange.

Namespace: frxPreview
Syntax
Delphi
published
 property OnScrollPosChange: TfrxScrollPosChangeEvent read GetOnScrollPosChange write SetOnScrollPosChange;

Value

Type: TfrxScrollPosChangeEvent

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview Fields

Fields
Name | Description
DesignerFSearchFrmVisible | Represents field DesignerFSearchFrmVisible.
FAllowF3 | Represents field FAllowF3.
FBorderStyle | Represents field FBorderStyle.
FCalledFromPreview | Represents field FCalledFromPreview.
FCancelButton | Represents field FCancelButton.
FEachReportInTab | Represents field FEachReportInTab.
FFindSplitter | Represents field FFindSplitter.
FInitialized | Represents field FInitialized.
FLocks | Represents field FLocks.
FMessageLabel | Represents field FMessageLabel.
FMessagePanel | Represents field FMessagePanel.
FOnPageChanged | Represents field FOnPageChanged.
FOutline | Represents field FOutline.
FOutlineColor | Represents field FOutlineColor.
FOutlinePopup | Represents field FOutlinePopup.
FPageNo | Represents field FPageNo.
FRefreshing | Represents field FRefreshing.
FRunning | Represents field FRunning.
FSavedPageNo | Represents field FSavedPageNo.
FScrollBars | Represents field FScrollBars.
FSearchFrm | Represents field FSearchFrm.
FSplitter | Represents field FSplitter.
FTabImgList | Represents field FTabImgList.
FTabItems | Represents field FTabItems.
FTabs | Represents field FTabs.
FThumbnail | Represents field FThumbnail.
FTick | Represents field FTick.
FTool | Represents field FTool.
FWorkspace | Represents field FWorkspace.
FZoom | Represents field FZoom.
FZoomMode | Represents field FZoomMode.
Top


TfrxPreview.DesignerFSearchFrmVisible Field

Summary

Represents field DesignerFSearchFrmVisible.

Namespace: frxPreview
Syntax
Delphi
private
 DesignerFSearchFrmVisible: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FAllowF3 Field

Summary

Represents field FAllowF3.

Namespace: frxPreview
Syntax
Delphi
private
 FAllowF3: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FBorderStyle Field

Summary

Represents field FBorderStyle.

Namespace: frxPreview
Syntax
Delphi
private
 FBorderStyle: TBorderStyle;

Field Value

Type: TBorderStyle

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FCalledFromPreview Field

Summary

Represents field FCalledFromPreview.

Namespace: frxPreview
Syntax
Delphi
private
 FCalledFromPreview: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FCancelButton Field

Summary

Represents field FCancelButton.

Namespace: frxPreview
Syntax
Delphi
private
 FCancelButton: TButton;

Field Value

Type: TButton

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FEachReportInTab Field

Summary

Represents field FEachReportInTab.

Namespace: frxPreview
Syntax
Delphi
private
 FEachReportInTab: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FFindSplitter Field

Summary

Represents field FFindSplitter.

Namespace: frxPreview
Syntax
Delphi
private
 FFindSplitter: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FInitialized Field

Summary

Represents field FInitialized.

Namespace: frxPreview
Syntax
Delphi
private
 FInitialized: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FLocks Field

Summary

Represents field FLocks.

Namespace: frxPreview
Syntax
Delphi
private
 FLocks: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FMessageLabel Field

Summary

Represents field FMessageLabel.

Namespace: frxPreview
Syntax
Delphi
private
 FMessageLabel: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FMessagePanel Field

Summary

Represents field FMessagePanel.

Namespace: frxPreview
Syntax
Delphi
private
 FMessagePanel: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FOnPageChanged Field

Summary

Represents field FOnPageChanged.

Namespace: frxPreview
Syntax
Delphi
private
 FOnPageChanged: TfrxPageChangedEvent;

Field Value

Type: TfrxPageChangedEvent

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FOutline Field

Summary

Represents field FOutline.

Namespace: frxPreview
Syntax
Delphi
private
 FOutline: TTreeView;

Field Value

Type: TTreeView

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FOutlineColor Field

Summary

Represents field FOutlineColor.

Namespace: frxPreview
Syntax
Delphi
private
 FOutlineColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FOutlinePopup Field

Summary

Represents field FOutlinePopup.

Namespace: frxPreview
Syntax
Delphi
private
 FOutlinePopup: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FPageNo Field

Summary

Represents field FPageNo.

Namespace: frxPreview
Syntax
Delphi
private
 FPageNo: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FRefreshing Field

Summary

Represents field FRefreshing.

Namespace: frxPreview
Syntax
Delphi
private
 FRefreshing: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FRunning Field

Summary

Represents field FRunning.

Namespace: frxPreview
Syntax
Delphi
private
 FRunning: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FSavedPageNo Field

Summary

Represents field FSavedPageNo.

Namespace: frxPreview
Syntax
Delphi
private
 FSavedPageNo: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FScrollBars Field

Summary

Represents field FScrollBars.

Namespace: frxPreview
Syntax
Delphi
private
 FScrollBars: TScrollStyle;

Field Value

Type: TScrollStyle

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FSearchFrm Field

Summary

Represents field FSearchFrm.

Namespace: frxPreview
Syntax
Delphi
private
 FSearchFrm: TfrxSearchForm;

Field Value

Type: TfrxSearchForm

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FSplitter Field

Summary

Represents field FSplitter.

Namespace: frxPreview
Syntax
Delphi
private
 FSplitter: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FTabImgList Field

Summary

Represents field FTabImgList.

Namespace: frxPreview
Syntax
Delphi
private
 FTabImgList: TImageList;

Field Value

Type: TImageList

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FTabItems Field

Summary

Represents field FTabItems.

Namespace: frxPreview
Syntax
Delphi
private
 FTabItems: TfrxPreviewTabs;

Field Value

Type: TfrxPreviewTabs

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FTabs Field

Summary

Represents field FTabs.

Namespace: frxPreview
Syntax
Delphi
private
 FTabs: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FThumbnail Field

Summary

Represents field FThumbnail.

Namespace: frxPreview
Syntax
Delphi
private
 FThumbnail: TfrxPreviewWorkspace;

Field Value

Type: TfrxPreviewWorkspace

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FTick Field

Summary

Represents field FTick.

Namespace: frxPreview
Syntax
Delphi
private
 FTick: Cardinal;

Field Value

Type: Cardinal

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FTool Field

Summary

Represents field FTool.

Namespace: frxPreview
Syntax
Delphi
private
 FTool: TfrxPreviewTool;

Field Value

Type: TfrxPreviewTool

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FWorkspace Field

Summary

Represents field FWorkspace.

Namespace: frxPreview
Syntax
Delphi
private
 FWorkspace: TfrxPreviewWorkspace;

Field Value

Type: TfrxPreviewWorkspace

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FZoom Field

Summary

Represents field FZoom.

Namespace: frxPreview
Syntax
Delphi
private
 FZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreview.FZoomMode Field

Summary

Represents field FZoomMode.

Namespace: frxPreview
Syntax
Delphi
private
 FZoomMode: TfrxZoomMode;

Field Value

Type: TfrxZoomMode

See Also

Reference

  • TfrxPreview
  • frxPreview


TfrxPreviewForm Class

Summary

Represents type TfrxPreviewForm.

Namespace: frxPreview
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxPreview.TfrxPreviewForm
Syntax
Delphi
type
 TfrxPreviewForm = class(TfrxBaseForm)
 end;

The TfrxPreviewForm type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPreviewForm class. (Overrides TfrxBaseForm.Create(TComponent).)
Destroy | Represents the destructor of the TfrxPreviewForm class.
Top
Properties
Show:
Name | Description
CurrentFormPPI | Returns current PPI value of the form. (Inherited from TfrxBaseForm.)
FreeOnClose | Represents property FreeOnClose.
IsClosing | Represents property IsClosing.
IsPPIChanging | Represents property IsPPIChanging. (Inherited from TfrxBaseForm.)
Preview | Represents property Preview.
Report | Represents property Report.
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseForm.)
AfterPPIChange | Represents method AfterPPIChange. (Inherited from TfrxBaseForm.)
AfterPPIMessage | Represents method AfterPPIMessage. (Inherited from TfrxBaseForm.)
BeforeDestruction | Represents method BeforeDestruction. (Inherited from TfrxBaseForm.)
BeforePPIChange | Represents method BeforePPIChange. (Inherited from TfrxBaseForm.)
CancelBClick(TObject) | Represents method CancelBClick(TObject).
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer). (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean). (Inherited from TfrxBaseForm.)
CollapseAllClick(TObject) | Represents method CollapseAllClick(TObject).
CopyCmdExecute(TObject) | Represents method CopyCmdExecute(TObject).
CreateExportMenu | Represents method CreateExportMenu.
DelPageBClick(TObject) | Represents method DelPageBClick(TObject).
DesignerBClick(TObject) | Represents method DesignerBClick(TObject).
DesignerBMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method DesignerBMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer).
DoClose(TCloseAction) | Represents method DoClose(TCloseAction). (Inherited from TfrxBaseForm.)
DoShow | Represents method DoShow. (Inherited from TfrxBaseForm.)
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer). (Inherited from TfrxBaseForm.)
EmailBClick(TObject) | Represents method EmailBClick(TObject).
ExpandAllClick(TObject) | Represents method ExpandAllClick(TObject).
ExportMIClick(TObject) | Represents method ExportMIClick(TObject).
FindBClick(TObject) | Represents method FindBClick(TObject).
FirstBClick(TObject) | Represents method FirstBClick(TObject).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCloseQuery(TObject,Boolean) | Represents method FormCloseQuery(TObject,Boolean).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
FormKeyPress(TObject,Char) | Represents method FormKeyPress(TObject,Char).
FormMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean) | Represents method FormMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean).
FormResize(TObject) | Represents method FormResize(TObject).
FormShowAfterLoad | Represents method FormShowAfterLoad. (Inherited from TfrxBaseForm.)
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Inherited from TfrxBaseForm.)
FullScreenBtnClick(TObject) | Represents method FullScreenBtnClick(TObject).
GetAvailablePreferences | Represents method GetAvailablePreferences. (Inherited from TfrxBaseForm.)
GetFormSectionName | Represents method GetFormSectionName. (Inherited from TfrxBaseForm.)
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Inherited from TfrxBaseForm.)
GetReport | Represents method GetReport.
HighlightEditableTBClick(TObject) | Represents method HighlightEditableTBClick(TObject).
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Inherited from TfrxBaseForm.)
Init | Represents method Init.
LastBClick(TObject) | Represents method LastBClick(TObject).
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
NewPageBClick(TObject) | Represents method NewPageBClick(TObject).
NextBClick(TObject) | Represents method NextBClick(TObject).
OnPageChanged(TfrxPreview,Integer) | Represents method OnPageChanged(TfrxPreview,Integer).
OnPreviewDblClick(TObject) | Represents method OnPreviewDblClick(TObject).
OnSaveFilterExecute(TObject) | Represents method OnSaveFilterExecute(TObject).
OpenBClick(TObject) | Represents method OpenBClick(TObject).
OutlineBClick(TObject) | Represents method OutlineBClick(TObject).
PageEClick(TObject) | Represents method PageEClick(TObject).
PageSettingsBClick(TObject) | Represents method PageSettingsBClick(TObject).
PasteCmdExecute(TObject) | Represents method PasteCmdExecute(TObject).
PdfBClick(TObject) | Represents method PdfBClick(TObject).
PrintBClick(TObject) | Represents method PrintBClick(TObject).
PriorBClick(TObject) | Represents method PriorBClick(TObject).
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter. (Inherited from TfrxBaseForm.)
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Inherited from TfrxBaseForm.)
RightMenuPopup(TObject) | Represents method RightMenuPopup(TObject).
SaveBClick(TObject) | Represents method SaveBClick(TObject).
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxBaseForm.)
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms. (Inherited from TfrxBaseForm.)
SetMessageText(String,Boolean) | Represents method SetMessageText(String,Boolean).
Showtemplate1Click(TObject) | Represents method Showtemplate1Click(TObject).
StatusBarWndProc(TMessage) | Represents method StatusBarWndProc(TMessage).
SwitchToFullScreen | Represents method SwitchToFullScreen.
ThumbBClick(TObject) | Represents method ThumbBClick(TObject).
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form. (Inherited from TfrxBaseForm.)
UpdateControls | Represents method UpdateControls.
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Overrides TfrxBaseForm.UpdateFormPPI(Integer).)
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Overrides TfrxBaseForm.UpdateResouces.)
UpdateZoom | Represents method UpdateZoom.
WMActivateApp(TWMActivateApp) | Represents method WMActivateApp(TWMActivateApp).
WMSysCommand(TWMSysCommand) | Represents method WMSysCommand(TWMSysCommand).
WMUpdateZoom(TMessage) | Represents method WMUpdateZoom(TMessage).
ZoomCBClick(TObject) | Represents method ZoomCBClick(TObject).
ZoomCBKeyPress(TObject,Char) | Represents method ZoomCBKeyPress(TObject,Char).
ZoomMinusBClick(TObject) | Represents method ZoomMinusBClick(TObject).
ZoomPlusBClick(TObject) | Represents method ZoomPlusBClick(TObject).
Top
Fields
Show:
Name | Description
CancelB | Represents field CancelB.
CollapseMI | Represents field CollapseMI.
CopyCmd | Represents field CopyCmd.
CopyCmd1 | Represents field CopyCmd1.
DesignerB | Represents field DesignerB.
EmailB | Represents field EmailB.
ExpandMI | Represents field ExpandMI.
ExportPopup | Represents field ExportPopup.
FEmailExport | Represents field FEmailExport.
FFilterList | Represents field FFilterList.
FFreeOnClose | Represents field FFreeOnClose.
FFullScreen | Represents field FFullScreen.
FHostedControls | Represents field FHostedControls. (Inherited from TfrxBaseForm.)
FindB | Represents field FindB.
FirstB | Represents field FirstB.
FIsClosing | Represents field FIsClosing.
FOldBS | Represents field FOldBS.
FOldState | Represents field FOldState.
FPDFExport | Represents field FPDFExport.
FPrefEvent | Represents field FPrefEvent. (Inherited from TfrxBaseForm.)
FPreview | Represents field FPreview.
frTBPanel1 | Represents field frTBPanel1.
FStatusBarOldWindowProc | Represents field FStatusBarOldWindowProc.
FullScreenBtn | Represents field FullScreenBtn.
HiddenMenu | Represents field HiddenMenu.
HighlightEditableTB | Represents field HighlightEditableTB.
LastB | Represents field LastB.
N1 | Represents field N1.
NextB | Represents field NextB.
OfNL | Represents field OfNL.
OpenB | Represents field OpenB.
OutlineB | Represents field OutlineB.
PageE | Represents field PageE.
PageSettingsB | Represents field PageSettingsB.
PasteCmd | Represents field PasteCmd.
PasteCmd1 | Represents field PasteCmd1.
PdfB | Represents field PdfB.
PreviewActionList | Represents field PreviewActionList.
PrintB | Represents field PrintB.
PriorB | Represents field PriorB.
RightMenu | Represents field RightMenu.
SaveB | Represents field SaveB.
Sep1 | Represents field Sep1.
Sep2 | Represents field Sep2.
Sep3 | Represents field Sep3.
Sep4 | Represents field Sep4.
Sep5 | Represents field Sep5.
Showtemplate1 | Represents field Showtemplate1.
StatusBar | Represents field StatusBar.
ThumbB | Represents field ThumbB.
ToolBar | Represents field ToolBar.
ZoomCB | Represents field ZoomCB.
ZoomMinusB | Represents field ZoomMinusB.
ZoomPlusB | Represents field ZoomPlusB.
Top
See Also

Reference

  • frxPreview


TfrxPreviewForm Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPreviewForm class. (Overrides TfrxBaseForm.Create(TComponent).)
Destroy | Represents the destructor of the TfrxPreviewForm class.
Top


TfrxPreviewForm.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxPreviewForm class.

Namespace: frxPreview
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxBaseForm.Create(TComponent)
See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.Destroy Destructor

Summary

Represents the destructor of the TfrxPreviewForm class.

Namespace: frxPreview
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm Properties

Properties
Name | Description
FreeOnClose | Represents property FreeOnClose.
IsClosing | Represents property IsClosing.
Preview | Represents property Preview.
Report | Represents property Report.
Top


TfrxPreviewForm.FreeOnClose Property

Summary

Represents property FreeOnClose.

Namespace: frxPreview
Syntax
Delphi
public
 property FreeOnClose: Boolean read FFreeOnClose write FFreeOnClose;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.IsClosing Property

Summary

Represents property IsClosing.

Namespace: frxPreview
Syntax
Delphi
public
 property IsClosing: Boolean read FIsClosing write FIsClosing;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.Preview Property

Summary

Represents property Preview.

Namespace: frxPreview
Syntax
Delphi
public
 property Preview: TfrxPreview read FPreview;

Property Value

Type: TfrxPreview

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.Report Property

Summary

Represents property Report.

Namespace: frxPreview
Syntax
Delphi
public
 property Report: TfrxReport read GetReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm Methods

Methods
Name | Description
CancelBClick(TObject) | Represents method CancelBClick(TObject).
CollapseAllClick(TObject) | Represents method CollapseAllClick(TObject).
CopyCmdExecute(TObject) | Represents method CopyCmdExecute(TObject).
CreateExportMenu | Represents method CreateExportMenu.
DelPageBClick(TObject) | Represents method DelPageBClick(TObject).
DesignerBClick(TObject) | Represents method DesignerBClick(TObject).
DesignerBMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method DesignerBMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer).
EmailBClick(TObject) | Represents method EmailBClick(TObject).
ExpandAllClick(TObject) | Represents method ExpandAllClick(TObject).
ExportMIClick(TObject) | Represents method ExportMIClick(TObject).
FindBClick(TObject) | Represents method FindBClick(TObject).
FirstBClick(TObject) | Represents method FirstBClick(TObject).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCloseQuery(TObject,Boolean) | Represents method FormCloseQuery(TObject,Boolean).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
FormKeyPress(TObject,Char) | Represents method FormKeyPress(TObject,Char).
FormMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean) | Represents method FormMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean).
FormResize(TObject) | Represents method FormResize(TObject).
FullScreenBtnClick(TObject) | Represents method FullScreenBtnClick(TObject).
GetReport | Represents method GetReport.
HighlightEditableTBClick(TObject) | Represents method HighlightEditableTBClick(TObject).
Init | Represents method Init.
LastBClick(TObject) | Represents method LastBClick(TObject).
NewPageBClick(TObject) | Represents method NewPageBClick(TObject).
NextBClick(TObject) | Represents method NextBClick(TObject).
OnPageChanged(TfrxPreview,Integer) | Represents method OnPageChanged(TfrxPreview,Integer).
OnPreviewDblClick(TObject) | Represents method OnPreviewDblClick(TObject).
OnSaveFilterExecute(TObject) | Represents method OnSaveFilterExecute(TObject).
OpenBClick(TObject) | Represents method OpenBClick(TObject).
OutlineBClick(TObject) | Represents method OutlineBClick(TObject).
PageEClick(TObject) | Represents method PageEClick(TObject).
PageSettingsBClick(TObject) | Represents method PageSettingsBClick(TObject).
PasteCmdExecute(TObject) | Represents method PasteCmdExecute(TObject).
PdfBClick(TObject) | Represents method PdfBClick(TObject).
PrintBClick(TObject) | Represents method PrintBClick(TObject).
PriorBClick(TObject) | Represents method PriorBClick(TObject).
RightMenuPopup(TObject) | Represents method RightMenuPopup(TObject).
SaveBClick(TObject) | Represents method SaveBClick(TObject).
SetMessageText(String,Boolean) | Represents method SetMessageText(String,Boolean).
Showtemplate1Click(TObject) | Represents method Showtemplate1Click(TObject).
StatusBarWndProc(TMessage) | Represents method StatusBarWndProc(TMessage).
SwitchToFullScreen | Represents method SwitchToFullScreen.
ThumbBClick(TObject) | Represents method ThumbBClick(TObject).
UpdateControls | Represents method UpdateControls.
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Overrides TfrxBaseForm.UpdateFormPPI(Integer).)
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Overrides TfrxBaseForm.UpdateResouces.)
UpdateZoom | Represents method UpdateZoom.
WMActivateApp(TWMActivateApp) | Represents method WMActivateApp(TWMActivateApp).
WMSysCommand(TWMSysCommand) | Represents method WMSysCommand(TWMSysCommand).
WMUpdateZoom(TMessage) | Represents method WMUpdateZoom(TMessage).
ZoomCBClick(TObject) | Represents method ZoomCBClick(TObject).
ZoomCBKeyPress(TObject,Char) | Represents method ZoomCBKeyPress(TObject,Char).
ZoomMinusBClick(TObject) | Represents method ZoomMinusBClick(TObject).
ZoomPlusBClick(TObject) | Represents method ZoomPlusBClick(TObject).
Top


TfrxPreviewForm.CancelBClick(TObject) Method

Summary

Represents method CancelBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure CancelBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.CollapseAllClick(TObject) Method

Summary

Represents method CollapseAllClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure CollapseAllClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.CopyCmdExecute(TObject) Method

Summary

Represents method CopyCmdExecute(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure CopyCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.CreateExportMenu Method

Summary

Represents method CreateExportMenu.

Namespace: frxPreview
Syntax
Delphi
private
 procedure CreateExportMenu;
See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.DelPageBClick(TObject) Method

Summary

Represents method DelPageBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure DelPageBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.DesignerBClick(TObject) Method

Summary

Represents method DesignerBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure DesignerBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.DesignerBMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method DesignerBMouseUp(TObject,TMouseButton,TShiftState,Integer,Integer).

Namespace: frxPreview
Syntax
Delphi
published
 procedure DesignerBMouseUp(Sender: TObject; Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.EmailBClick(TObject) Method

Summary

Represents method EmailBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure EmailBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ExpandAllClick(TObject) Method

Summary

Represents method ExpandAllClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure ExpandAllClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ExportMIClick(TObject) Method

Summary

Represents method ExportMIClick(TObject).

Namespace: frxPreview
Syntax
Delphi
private
 procedure ExportMIClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FindBClick(TObject) Method

Summary

Represents method FindBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure FindBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FirstBClick(TObject) Method

Summary

Represents method FirstBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure FirstBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: frxPreview
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FormCloseQuery(TObject,Boolean) Method

Summary

Represents method FormCloseQuery(TObject,Boolean).

Namespace: frxPreview
Syntax
Delphi
published
 procedure FormCloseQuery(Sender: TObject; var CanClose: Boolean);

Parameters

Sender
Type: TObject

CanClose
Type: Boolean

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FormKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method FormKeyDown(TObject,Word,TShiftState).

Namespace: frxPreview
Syntax
Delphi
published
 procedure FormKeyDown(Sender: TObject; var Key: Word;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FormKeyPress(TObject,Char) Method

Summary

Represents method FormKeyPress(TObject,Char).

Namespace: frxPreview
Syntax
Delphi
published
 procedure FormKeyPress(Sender: TObject; var Key: Char);

Parameters

Sender
Type: TObject

Key
Type: Char

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FormMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean) Method

Summary

Represents method FormMouseWheel(TObject,TShiftState,Integer,TPoint,Boolean).

Namespace: frxPreview
Syntax
Delphi
published
 procedure FormMouseWheel(Sender: TObject; Shift: TShiftState;
 WheelDelta: Integer; MousePos: TPoint; var Handled: Boolean);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

Handled
Type: Boolean

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FormResize(TObject) Method

Summary

Represents method FormResize(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure FormResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FullScreenBtnClick(TObject) Method

Summary

Represents method FullScreenBtnClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure FullScreenBtnClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.GetReport Method

Summary

Represents method GetReport.

Namespace: frxPreview
Syntax
Delphi
private
 function GetReport: TfrxReport;

Return Value

Type: TfrxReport

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.HighlightEditableTBClick(TObject) Method

Summary

Represents method HighlightEditableTBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure HighlightEditableTBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.Init Method

Summary

Represents method Init.

Namespace: frxPreview
Syntax
Delphi
public
 procedure Init;
See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.LastBClick(TObject) Method

Summary

Represents method LastBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure LastBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.NewPageBClick(TObject) Method

Summary

Represents method NewPageBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure NewPageBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.NextBClick(TObject) Method

Summary

Represents method NextBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure NextBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.OnPageChanged(TfrxPreview,Integer) Method

Summary

Represents method OnPageChanged(TfrxPreview,Integer).

Namespace: frxPreview
Syntax
Delphi
private
 procedure OnPageChanged(Sender: TfrxPreview; PageNo: Integer);

Parameters

Sender
Type: TfrxPreview

PageNo
Type: Integer

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.OnPreviewDblClick(TObject) Method

Summary

Represents method OnPreviewDblClick(TObject).

Namespace: frxPreview
Syntax
Delphi
private
 procedure OnPreviewDblClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.OnSaveFilterExecute(TObject) Method

Summary

Represents method OnSaveFilterExecute(TObject).

Namespace: frxPreview
Syntax
Delphi
private
 procedure OnSaveFilterExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.OpenBClick(TObject) Method

Summary

Represents method OpenBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure OpenBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.OutlineBClick(TObject) Method

Summary

Represents method OutlineBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure OutlineBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PageEClick(TObject) Method

Summary

Represents method PageEClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure PageEClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PageSettingsBClick(TObject) Method

Summary

Represents method PageSettingsBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure PageSettingsBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PasteCmdExecute(TObject) Method

Summary

Represents method PasteCmdExecute(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure PasteCmdExecute(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PdfBClick(TObject) Method

Summary

Represents method PdfBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure PdfBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PrintBClick(TObject) Method

Summary

Represents method PrintBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure PrintBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PriorBClick(TObject) Method

Summary

Represents method PriorBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure PriorBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.RightMenuPopup(TObject) Method

Summary

Represents method RightMenuPopup(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure RightMenuPopup(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.SaveBClick(TObject) Method

Summary

Represents method SaveBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure SaveBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.SetMessageText(String,Boolean) Method

Summary

Represents method SetMessageText(String,Boolean).

Namespace: frxPreview
Syntax
Delphi
public
 procedure SetMessageText(const Value: String; IsHint: Boolean = False);

Parameters

Value
Type: String

IsHint
Type: Boolean

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.Showtemplate1Click(TObject) Method

Summary

Represents method Showtemplate1Click(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure Showtemplate1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.StatusBarWndProc(TMessage) Method

Summary

Represents method StatusBarWndProc(TMessage).

Namespace: frxPreview
Syntax
Delphi
private
 procedure StatusBarWndProc(var Message: TMessage);

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.SwitchToFullScreen Method

Summary

Represents method SwitchToFullScreen.

Namespace: frxPreview
Syntax
Delphi
public
 procedure SwitchToFullScreen;
See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ThumbBClick(TObject) Method

Summary

Represents method ThumbBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure ThumbBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.UpdateControls Method

Summary

Represents method UpdateControls.

Namespace: frxPreview
Syntax
Delphi
private
 procedure UpdateControls;
See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.UpdateFormPPI(Integer) Method

Summary

Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method.

Namespace: frxPreview
Syntax
Delphi
public
 procedure UpdateFormPPI(aNewPPI: Integer); override;

Parameters

aNewPPI
Type: Integer

New PPI value.

Overrides

TfrxBaseForm.UpdateFormPPI(Integer)
See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.UpdateResouces Method

Summary

Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources.

Namespace: frxPreview
Syntax
Delphi
public
 procedure UpdateResouces; override;

Overrides

TfrxBaseForm.UpdateResouces
See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.UpdateZoom Method

Summary

Represents method UpdateZoom.

Namespace: frxPreview
Syntax
Delphi
private
 procedure UpdateZoom;
See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.WMActivateApp(TWMActivateApp) Method

Summary

Represents method WMActivateApp(TWMActivateApp).

Namespace: frxPreview
Syntax
Delphi
private
 procedure WMActivateApp(var Msg: TWMActivateApp); message WM_ACTIVATEAPP;

Parameters

Msg
Type: TWMActivateApp

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.WMSysCommand(TWMSysCommand) Method

Summary

Represents method WMSysCommand(TWMSysCommand).

Namespace: frxPreview
Syntax
Delphi
private
 procedure WMSysCommand(var Msg: TWMSysCommand); message WM_SYSCOMMAND;

Parameters

Msg
Type: TWMSysCommand

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.WMUpdateZoom(TMessage) Method

Summary

Represents method WMUpdateZoom(TMessage).

Namespace: frxPreview
Syntax
Delphi
private
 procedure WMUpdateZoom(var Message: TMessage); message WM_UPDATEZOOM;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ZoomCBClick(TObject) Method

Summary

Represents method ZoomCBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure ZoomCBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ZoomCBKeyPress(TObject,Char) Method

Summary

Represents method ZoomCBKeyPress(TObject,Char).

Namespace: frxPreview
Syntax
Delphi
published
 procedure ZoomCBKeyPress(Sender: TObject; var Key: Char);

Parameters

Sender
Type: TObject

Key
Type: Char

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ZoomMinusBClick(TObject) Method

Summary

Represents method ZoomMinusBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure ZoomMinusBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ZoomPlusBClick(TObject) Method

Summary

Represents method ZoomPlusBClick(TObject).

Namespace: frxPreview
Syntax
Delphi
published
 procedure ZoomPlusBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm Fields

Fields
Name | Description
CancelB | Represents field CancelB.
CollapseMI | Represents field CollapseMI.
CopyCmd | Represents field CopyCmd.
CopyCmd1 | Represents field CopyCmd1.
DesignerB | Represents field DesignerB.
EmailB | Represents field EmailB.
ExpandMI | Represents field ExpandMI.
ExportPopup | Represents field ExportPopup.
FEmailExport | Represents field FEmailExport.
FFilterList | Represents field FFilterList.
FFreeOnClose | Represents field FFreeOnClose.
FFullScreen | Represents field FFullScreen.
FindB | Represents field FindB.
FirstB | Represents field FirstB.
FIsClosing | Represents field FIsClosing.
FOldBS | Represents field FOldBS.
FOldState | Represents field FOldState.
FPDFExport | Represents field FPDFExport.
FPreview | Represents field FPreview.
frTBPanel1 | Represents field frTBPanel1.
FStatusBarOldWindowProc | Represents field FStatusBarOldWindowProc.
FullScreenBtn | Represents field FullScreenBtn.
HiddenMenu | Represents field HiddenMenu.
HighlightEditableTB | Represents field HighlightEditableTB.
LastB | Represents field LastB.
N1 | Represents field N1.
NextB | Represents field NextB.
OfNL | Represents field OfNL.
OpenB | Represents field OpenB.
OutlineB | Represents field OutlineB.
PageE | Represents field PageE.
PageSettingsB | Represents field PageSettingsB.
PasteCmd | Represents field PasteCmd.
PasteCmd1 | Represents field PasteCmd1.
PdfB | Represents field PdfB.
PreviewActionList | Represents field PreviewActionList.
PrintB | Represents field PrintB.
PriorB | Represents field PriorB.
RightMenu | Represents field RightMenu.
SaveB | Represents field SaveB.
Sep1 | Represents field Sep1.
Sep2 | Represents field Sep2.
Sep3 | Represents field Sep3.
Sep4 | Represents field Sep4.
Sep5 | Represents field Sep5.
Showtemplate1 | Represents field Showtemplate1.
StatusBar | Represents field StatusBar.
ThumbB | Represents field ThumbB.
ToolBar | Represents field ToolBar.
ZoomCB | Represents field ZoomCB.
ZoomMinusB | Represents field ZoomMinusB.
ZoomPlusB | Represents field ZoomPlusB.
Top


TfrxPreviewForm.CancelB Field

Summary

Represents field CancelB.

Namespace: frxPreview
Syntax
Delphi
published
 CancelB: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.CollapseMI Field

Summary

Represents field CollapseMI.

Namespace: frxPreview
Syntax
Delphi
published
 CollapseMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.CopyCmd Field

Summary

Represents field CopyCmd.

Namespace: frxPreview
Syntax
Delphi
published
 CopyCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.CopyCmd1 Field

Summary

Represents field CopyCmd1.

Namespace: frxPreview
Syntax
Delphi
published
 CopyCmd1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.DesignerB Field

Summary

Represents field DesignerB.

Namespace: frxPreview
Syntax
Delphi
published
 DesignerB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.EmailB Field

Summary

Represents field EmailB.

Namespace: frxPreview
Syntax
Delphi
published
 EmailB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ExpandMI Field

Summary

Represents field ExpandMI.

Namespace: frxPreview
Syntax
Delphi
published
 ExpandMI: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ExportPopup Field

Summary

Represents field ExportPopup.

Namespace: frxPreview
Syntax
Delphi
published
 ExportPopup: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FEmailExport Field

Summary

Represents field FEmailExport.

Namespace: frxPreview
Syntax
Delphi
private
 FEmailExport: TfrxCustomExportFilter;

Field Value

Type: TfrxCustomExportFilter

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FFilterList Field

Summary

Represents field FFilterList.

Namespace: frxPreview
Syntax
Delphi
private
 FFilterList: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FFreeOnClose Field

Summary

Represents field FFreeOnClose.

Namespace: frxPreview
Syntax
Delphi
private
 FFreeOnClose: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FFullScreen Field

Summary

Represents field FFullScreen.

Namespace: frxPreview
Syntax
Delphi
private
 FFullScreen: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FindB Field

Summary

Represents field FindB.

Namespace: frxPreview
Syntax
Delphi
published
 FindB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FirstB Field

Summary

Represents field FirstB.

Namespace: frxPreview
Syntax
Delphi
published
 FirstB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FIsClosing Field

Summary

Represents field FIsClosing.

Namespace: frxPreview
Syntax
Delphi
private
 FIsClosing: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FOldBS Field

Summary

Represents field FOldBS.

Namespace: frxPreview
Syntax
Delphi
private
 FOldBS: TFormBorderStyle;

Field Value

Type: TFormBorderStyle

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FOldState Field

Summary

Represents field FOldState.

Namespace: frxPreview
Syntax
Delphi
private
 FOldState: TWindowState;

Field Value

Type: TWindowState

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FPDFExport Field

Summary

Represents field FPDFExport.

Namespace: frxPreview
Syntax
Delphi
private
 FPDFExport: TfrxCustomExportFilter;

Field Value

Type: TfrxCustomExportFilter

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FPreview Field

Summary

Represents field FPreview.

Namespace: frxPreview
Syntax
Delphi
private
 FPreview: TfrxPreview;

Field Value

Type: TfrxPreview

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.frTBPanel1 Field

Summary

Represents field frTBPanel1.

Namespace: frxPreview
Syntax
Delphi
published
 frTBPanel1: TfrxTBPanel;

Field Value

Type: TfrxTBPanel

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FStatusBarOldWindowProc Field

Summary

Represents field FStatusBarOldWindowProc.

Namespace: frxPreview
Syntax
Delphi
private
 FStatusBarOldWindowProc: TWndMethod;

Field Value

Type: TWndMethod

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.FullScreenBtn Field

Summary

Represents field FullScreenBtn.

Namespace: frxPreview
Syntax
Delphi
published
 FullScreenBtn: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.HiddenMenu Field

Summary

Represents field HiddenMenu.

Namespace: frxPreview
Syntax
Delphi
published
 HiddenMenu: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.HighlightEditableTB Field

Summary

Represents field HighlightEditableTB.

Namespace: frxPreview
Syntax
Delphi
published
 HighlightEditableTB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.LastB Field

Summary

Represents field LastB.

Namespace: frxPreview
Syntax
Delphi
published
 LastB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.N1 Field

Summary

Represents field N1.

Namespace: frxPreview
Syntax
Delphi
published
 N1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.NextB Field

Summary

Represents field NextB.

Namespace: frxPreview
Syntax
Delphi
published
 NextB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.OfNL Field

Summary

Represents field OfNL.

Namespace: frxPreview
Syntax
Delphi
published
 OfNL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.OpenB Field

Summary

Represents field OpenB.

Namespace: frxPreview
Syntax
Delphi
published
 OpenB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.OutlineB Field

Summary

Represents field OutlineB.

Namespace: frxPreview
Syntax
Delphi
published
 OutlineB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PageE Field

Summary

Represents field PageE.

Namespace: frxPreview
Syntax
Delphi
published
 PageE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PageSettingsB Field

Summary

Represents field PageSettingsB.

Namespace: frxPreview
Syntax
Delphi
published
 PageSettingsB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PasteCmd Field

Summary

Represents field PasteCmd.

Namespace: frxPreview
Syntax
Delphi
published
 PasteCmd: TAction;

Field Value

Type: TAction

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PasteCmd1 Field

Summary

Represents field PasteCmd1.

Namespace: frxPreview
Syntax
Delphi
published
 PasteCmd1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PdfB Field

Summary

Represents field PdfB.

Namespace: frxPreview
Syntax
Delphi
published
 PdfB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PreviewActionList Field

Summary

Represents field PreviewActionList.

Namespace: frxPreview
Syntax
Delphi
published
 PreviewActionList: TActionList;

Field Value

Type: TActionList

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PrintB Field

Summary

Represents field PrintB.

Namespace: frxPreview
Syntax
Delphi
published
 PrintB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.PriorB Field

Summary

Represents field PriorB.

Namespace: frxPreview
Syntax
Delphi
published
 PriorB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.RightMenu Field

Summary

Represents field RightMenu.

Namespace: frxPreview
Syntax
Delphi
published
 RightMenu: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.SaveB Field

Summary

Represents field SaveB.

Namespace: frxPreview
Syntax
Delphi
published
 SaveB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.Sep1 Field

Summary

Represents field Sep1.

Namespace: frxPreview
Syntax
Delphi
published
 Sep1: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.Sep2 Field

Summary

Represents field Sep2.

Namespace: frxPreview
Syntax
Delphi
published
 Sep2: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.Sep3 Field

Summary

Represents field Sep3.

Namespace: frxPreview
Syntax
Delphi
published
 Sep3: TfrxTBPanel;

Field Value

Type: TfrxTBPanel

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.Sep4 Field

Summary

Represents field Sep4.

Namespace: frxPreview
Syntax
Delphi
published
 Sep4: TfrxTBPanel;

Field Value

Type: TfrxTBPanel

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.Sep5 Field

Summary

Represents field Sep5.

Namespace: frxPreview
Syntax
Delphi
published
 Sep5: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.Showtemplate1 Field

Summary

Represents field Showtemplate1.

Namespace: frxPreview
Syntax
Delphi
published
 Showtemplate1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.StatusBar Field

Summary

Represents field StatusBar.

Namespace: frxPreview
Syntax
Delphi
published
 StatusBar: TStatusBar;

Field Value

Type: TStatusBar

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ThumbB Field

Summary

Represents field ThumbB.

Namespace: frxPreview
Syntax
Delphi
published
 ThumbB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ToolBar Field

Summary

Represents field ToolBar.

Namespace: frxPreview
Syntax
Delphi
published
 ToolBar: TToolBar;

Field Value

Type: TToolBar

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ZoomCB Field

Summary

Represents field ZoomCB.

Namespace: frxPreview
Syntax
Delphi
published
 ZoomCB: TfrxComboBox;

Field Value

Type: TfrxComboBox

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ZoomMinusB Field

Summary

Represents field ZoomMinusB.

Namespace: frxPreview
Syntax
Delphi
published
 ZoomMinusB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewForm.ZoomPlusB Field

Summary

Represents field ZoomPlusB.

Namespace: frxPreview
Syntax
Delphi
published
 ZoomPlusB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxPreviewForm
  • frxPreview


TfrxPreviewTabItem Class

Summary

Represents type TfrxPreviewTabItem.

Namespace: frxPreview
Inheritance Hierarchy
TCollectionItem
frxPreview.TfrxPreviewTabItem
Syntax
Delphi
type
 TfrxPreviewTabItem = class(TCollectionItem)
 end;

The TfrxPreviewTabItem type exposes the following members.

Properties
Show:
Name | Description
DetailPage | Represents property DetailPage.
FreeObjects | Represents property FreeObjects.
Left | Represents property Left.
Name | Represents property Name.
OutlineItem | Represents property OutlineItem.
PageNo | Represents property PageNo.
PreviewPages | Represents property PreviewPages.
Report | Represents property Report.
ThumbTop | Represents property ThumbTop.
Top | Represents property Top.
Zoom | Represents property Zoom.
ZoomMode | Represents property ZoomMode.
Top
Fields
Show:
Name | Description
FDetailPage | Represents field FDetailPage.
FFreeObjects | Represents field FFreeObjects.
FLeft | Represents field FLeft.
FName | Represents field FName.
FOutlineItem | Represents field FOutlineItem.
FPageNo | Represents field FPageNo.
FPreviewPages | Represents field FPreviewPages.
FReport | Represents field FReport.
FThumbTop | Represents field FThumbTop.
FTop | Represents field FTop.
FZoom | Represents field FZoom.
FZoomMode | Represents field FZoomMode.
Top
See Also

Reference

  • frxPreview


TfrxPreviewTabItem Properties

Properties
Name | Description
DetailPage | Represents property DetailPage.
FreeObjects | Represents property FreeObjects.
Left | Represents property Left.
Name | Represents property Name.
OutlineItem | Represents property OutlineItem.
PageNo | Represents property PageNo.
PreviewPages | Represents property PreviewPages.
Report | Represents property Report.
ThumbTop | Represents property ThumbTop.
Top | Represents property Top.
Zoom | Represents property Zoom.
ZoomMode | Represents property ZoomMode.
Top


TfrxPreviewTabItem.DetailPage Property

Summary

Represents property DetailPage.

Namespace: frxPreview
Syntax
Delphi
public
 property DetailPage: String read FDetailPage write FDetailPage;

Property Value

Type: String

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.FreeObjects Property

Summary

Represents property FreeObjects.

Namespace: frxPreview
Syntax
Delphi
public
 property FreeObjects: Boolean read FFreeObjects write FFreeObjects;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.Left Property

Summary

Represents property Left.

Namespace: frxPreview
Syntax
Delphi
public
 property Left: Integer read FLeft write FLeft;

Property Value

Type: Integer

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.Name Property

Summary

Represents property Name.

Namespace: frxPreview
Syntax
Delphi
public
 property Name: String read FName write FName;

Property Value

Type: String

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.OutlineItem Property

Summary

Represents property OutlineItem.

Namespace: frxPreview
Syntax
Delphi
public
 property OutlineItem: Integer read FOutlineItem write FOutlineItem;

Property Value

Type: Integer

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.PageNo Property

Summary

Represents property PageNo.

Namespace: frxPreview
Syntax
Delphi
public
 property PageNo: Integer read FPageNo write FPageNo;

Property Value

Type: Integer

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.PreviewPages Property

Summary

Represents property PreviewPages.

Namespace: frxPreview
Syntax
Delphi
public
 property PreviewPages: TfrxCustomPreviewPages read FPreviewPages write FPreviewPages;

Property Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.Report Property

Summary

Represents property Report.

Namespace: frxPreview
Syntax
Delphi
public
 property Report: TfrxReport read FReport write FReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.ThumbTop Property

Summary

Represents property ThumbTop.

Namespace: frxPreview
Syntax
Delphi
public
 property ThumbTop: Integer read FThumbTop write FThumbTop;

Property Value

Type: Integer

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.Top Property

Summary

Represents property Top.

Namespace: frxPreview
Syntax
Delphi
public
 property Top: Integer read FTop write FTop;

Property Value

Type: Integer

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.Zoom Property

Summary

Represents property Zoom.

Namespace: frxPreview
Syntax
Delphi
public
 property Zoom: Extended read FZoom write FZoom;

Property Value

Type: Extended

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.ZoomMode Property

Summary

Represents property ZoomMode.

Namespace: frxPreview
Syntax
Delphi
public
 property ZoomMode: TfrxZoomMode read FZoomMode write FZoomMode;

Property Value

Type: TfrxZoomMode

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem Fields

Fields
Name | Description
FDetailPage | Represents field FDetailPage.
FFreeObjects | Represents field FFreeObjects.
FLeft | Represents field FLeft.
FName | Represents field FName.
FOutlineItem | Represents field FOutlineItem.
FPageNo | Represents field FPageNo.
FPreviewPages | Represents field FPreviewPages.
FReport | Represents field FReport.
FThumbTop | Represents field FThumbTop.
FTop | Represents field FTop.
FZoom | Represents field FZoom.
FZoomMode | Represents field FZoomMode.
Top


TfrxPreviewTabItem.FDetailPage Field

Summary

Represents field FDetailPage.

Namespace: frxPreview
Syntax
Delphi
private
 FDetailPage: String;

Field Value

Type: String

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.FFreeObjects Field

Summary

Represents field FFreeObjects.

Namespace: frxPreview
Syntax
Delphi
private
 FFreeObjects: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.FLeft Field

Summary

Represents field FLeft.

Namespace: frxPreview
Syntax
Delphi
private
 FLeft: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.FName Field

Summary

Represents field FName.

Namespace: frxPreview
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.FOutlineItem Field

Summary

Represents field FOutlineItem.

Namespace: frxPreview
Syntax
Delphi
private
 FOutlineItem: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.FPageNo Field

Summary

Represents field FPageNo.

Namespace: frxPreview
Syntax
Delphi
private
 FPageNo: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.FPreviewPages Field

Summary

Represents field FPreviewPages.

Namespace: frxPreview
Syntax
Delphi
private
 FPreviewPages: TfrxCustomPreviewPages;

Field Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.FReport Field

Summary

Represents field FReport.

Namespace: frxPreview
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.FThumbTop Field

Summary

Represents field FThumbTop.

Namespace: frxPreview
Syntax
Delphi
private
 FThumbTop: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.FTop Field

Summary

Represents field FTop.

Namespace: frxPreview
Syntax
Delphi
private
 FTop: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.FZoom Field

Summary

Represents field FZoom.

Namespace: frxPreview
Syntax
Delphi
private
 FZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabItem.FZoomMode Field

Summary

Represents field FZoomMode.

Namespace: frxPreview
Syntax
Delphi
private
 FZoomMode: TfrxZoomMode;

Field Value

Type: TfrxZoomMode

See Also

Reference

  • TfrxPreviewTabItem
  • frxPreview


TfrxPreviewTabs Class

Summary

Represents type TfrxPreviewTabs.

Namespace: frxPreview
Inheritance Hierarchy
TCollection
frxPreview.TfrxPreviewTabs
Syntax
Delphi
type
 TfrxPreviewTabs = class(TCollection)
 end;

The TfrxPreviewTabs type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxPreview) | Initializes a new instance of the TfrxPreviewTabs class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
AddTab(TfrxReport,String,String,Boolean) | Represents method AddTab(TfrxReport,String,String,Boolean).
ClearItems | Represents method ClearItems.
DeleteTab(Integer) | Represents method DeleteTab(Integer).
GetItems(Integer) | Represents method GetItems(Integer).
SetCurrentTab(Integer) | Represents method SetCurrentTab(Integer).
Top
Fields
Show:
Name | Description
FCurTab | Represents field FCurTab.
FPreview | Represents field FPreview.
FThumbnail | Represents field FThumbnail.
FWorkspace | Represents field FWorkspace.
Top
See Also

Reference

  • frxPreview


TfrxPreviewTabs Constructors

Constructors
Name | Description
Create(TfrxPreview) | Initializes a new instance of the TfrxPreviewTabs class.
Top


TfrxPreviewTabs.Create(TfrxPreview) Constructor

Summary

Initializes a new instance of the TfrxPreviewTabs class.

Namespace: frxPreview
Syntax
Delphi
public
 constructor Create(APreview: TfrxPreview);

Parameters

APreview
Type: TfrxPreview

See Also

Reference

  • TfrxPreviewTabs
  • frxPreview


TfrxPreviewTabs Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxPreviewTabs.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxPreview
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxPreviewTabItem read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxPreviewTabItem

See Also

Reference

  • TfrxPreviewTabs
  • frxPreview


TfrxPreviewTabs Methods

Methods
Name | Description
AddTab(TfrxReport,String,String,Boolean) | Represents method AddTab(TfrxReport,String,String,Boolean).
ClearItems | Represents method ClearItems.
DeleteTab(Integer) | Represents method DeleteTab(Integer).
GetItems(Integer) | Represents method GetItems(Integer).
SetCurrentTab(Integer) | Represents method SetCurrentTab(Integer).
Top


TfrxPreviewTabs.AddTab(TfrxReport,String,String,Boolean) Method

Summary

Represents method AddTab(TfrxReport,String,String,Boolean).

Namespace: frxPreview
Syntax
Delphi
public
 procedure AddTab(AReport: TfrxReport; aDetailPage: String; const TabName: String; AFreeObjects: Boolean);

Parameters

AReport
Type: TfrxReport

aDetailPage
Type: String

TabName
Type: String

AFreeObjects
Type: Boolean

See Also

Reference

  • TfrxPreviewTabs
  • frxPreview


TfrxPreviewTabs.ClearItems Method

Summary

Represents method ClearItems.

Namespace: frxPreview
Syntax
Delphi
public
 procedure ClearItems;
See Also

Reference

  • TfrxPreviewTabs
  • frxPreview


TfrxPreviewTabs.DeleteTab(Integer) Method

Summary

Represents method DeleteTab(Integer).

Namespace: frxPreview
Syntax
Delphi
public
 procedure DeleteTab(Index: Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TfrxPreviewTabs
  • frxPreview


TfrxPreviewTabs.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxPreview
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxPreviewTabItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxPreviewTabItem

See Also

Reference

  • TfrxPreviewTabs
  • frxPreview


TfrxPreviewTabs.SetCurrentTab(Integer) Method

Summary

Represents method SetCurrentTab(Integer).

Namespace: frxPreview
Syntax
Delphi
public
 procedure SetCurrentTab(Index: Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TfrxPreviewTabs
  • frxPreview


TfrxPreviewTabs Fields

Fields
Name | Description
FCurTab | Represents field FCurTab.
FPreview | Represents field FPreview.
FThumbnail | Represents field FThumbnail.
FWorkspace | Represents field FWorkspace.
Top


TfrxPreviewTabs.FCurTab Field

Summary

Represents field FCurTab.

Namespace: frxPreview
Syntax
Delphi
private
 FCurTab: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewTabs
  • frxPreview


TfrxPreviewTabs.FPreview Field

Summary

Represents field FPreview.

Namespace: frxPreview
Syntax
Delphi
private
 FPreview: TfrxPreview;

Field Value

Type: TfrxPreview

See Also

Reference

  • TfrxPreviewTabs
  • frxPreview


TfrxPreviewTabs.FThumbnail Field

Summary

Represents field FThumbnail.

Namespace: frxPreview
Syntax
Delphi
private
 FThumbnail: TfrxPreviewWorkspace;

Field Value

Type: TfrxPreviewWorkspace

See Also

Reference

  • TfrxPreviewTabs
  • frxPreview


TfrxPreviewTabs.FWorkspace Field

Summary

Represents field FWorkspace.

Namespace: frxPreview
Syntax
Delphi
private
 FWorkspace: TfrxPreviewWorkspace;

Field Value

Type: TfrxPreviewWorkspace

See Also

Reference

  • TfrxPreviewTabs
  • frxPreview


TfrxPreviewWorkspace Class

Summary

Represents type TfrxPreviewWorkspace.

Namespace: frxPreview
Inheritance Hierarchy
TCustomControl
frxCtrls.TfrxScrollWin
frxPreview.TfrxPreviewWorkspace
Syntax
Delphi
type
 TfrxPreviewWorkspace = class(TfrxScrollWin)
 end;

The TfrxPreviewWorkspace type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPreviewWorkspace class. (Overrides TfrxScrollWin.Create(TComponent).)
Destroy | Represents the destructor of the TfrxPreviewWorkspace class.
Top
Properties
Show:
Name | Description
ActiveFrameColor | Represents property ActiveFrameColor.
BackColor | Represents property BackColor.
BevelKind | Represents property BevelKind. (Inherited from TfrxScrollWin.)
BorderStyle | Represents property BorderStyle. (Inherited from TfrxScrollWin.)
FrameColor | Represents property FrameColor.
HideScrolls | Represents property HideScrolls. (Inherited from TfrxScrollWin.)
HighlightEditable | Represents property HighlightEditable.
HorzPage | Represents property HorzPage. (Inherited from TfrxScrollWin.)
HorzPosition | Represents property HorzPosition. (Inherited from TfrxScrollWin.)
HorzRange | Represents property HorzRange. (Inherited from TfrxScrollWin.)
IsThumbnail | Represents property IsThumbnail.
LargeChange | Represents property LargeChange. (Inherited from TfrxScrollWin.)
Locked | Represents property Locked.
OnDblClick | Represents property OnDblClick.
PageNo | Represents property PageNo.
Preview | Represents property Preview.
PreviewPages | Represents property PreviewPages.
RTLLanguage | Represents property RTLLanguage.
SmallChange | Represents property SmallChange. (Inherited from TfrxScrollWin.)
VertPage | Represents property VertPage. (Inherited from TfrxScrollWin.)
VertPosition | Represents property VertPosition. (Inherited from TfrxScrollWin.)
VertRange | Represents property VertRange. (Inherited from TfrxScrollWin.)
Zoom | Represents property Zoom.
Top
Methods
Show:
Name | Description
AddPage(Integer,Integer) | Represents method AddPage(Integer,Integer).
CalcPageBounds(Integer) | Represents method CalcPageBounds(Integer).
CallIteractiveEvent(TMouseButton,TShiftState,Integer,Integer,TfrxPreviewIntEventParams) | Represents method CallIteractiveEvent(TMouseButton,TShiftState,Integer,Integer,TfrxPreviewIntEventParams).
ClearPageList | Represents method ClearPageList.
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams). (Inherited from TfrxScrollWin.)
DoMouseWheel(TShiftState,Integer,TPoint) | Represents method DoMouseWheel(TShiftState,Integer,TPoint).
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Inherited from TfrxScrollWin.)
DrawPages(Boolean) | Represents method DrawPages(Boolean).
FindText | Represents method FindText.
GetPreviewPages | Represents method GetPreviewPages.
GetScale | Represents method GetScale. (Inherited from TfrxScrollWin.)
GetScaledFontSize | Represents method GetScaledFontSize. (Inherited from TfrxScrollWin.)
GetTopPosition | Represents method GetTopPosition.
HighlightText | Represents method HighlightText.
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
OnHScrollChange(TObject) | Represents method OnHScrollChange(TObject). (Overrides TfrxScrollWin.OnHScrollChange(TObject).)
OnVScrollChange(TObject) | Represents method OnVScrollChange(TObject). (Overrides TfrxScrollWin.OnVScrollChange(TObject).)
Paint | Represents method Paint. (Overrides TfrxScrollWin.Paint.)
PrevDblClick(TObject) | Represents method PrevDblClick(TObject).
Resize | Represents method Resize.
ScaleRect(TRect,Extended,Extended,Extended) | Represents method ScaleRect(TRect,Extended,Extended,Extended).
SetEditMode(TfrxPreviewIntEventParams) | Represents method SetEditMode(TfrxPreviewIntEventParams).
SetLocked(Boolean) | Represents method SetLocked(Boolean).
SetPosition(Integer,Integer) | Represents method SetPosition(Integer,Integer).
SetScaledFontSize(Integer) | Represents method SetScaledFontSize(Integer). (Inherited from TfrxScrollWin.)
SetToPageNo(Integer) | Represents method SetToPageNo(Integer).
UpdateScrollBars | Represents method UpdateScrollBars.
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage). (Inherited from TfrxScrollWin.)
Top
Events
Show:
Name | Description
OnScrollMaxChange | Represents property OnScrollMaxChange. (Inherited from TfrxScrollWin.)
OnScrollPosChange | Represents property OnScrollPosChange. (Inherited from TfrxScrollWin.)
Top
Fields
Show:
Name | Description
FActiveFrameColor | Represents field FActiveFrameColor.
FBackColor | Represents field FBackColor.
FCachedView | Represents field FCachedView.
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxScrollWin.)
FDefaultCursor | Represents field FDefaultCursor.
FDisableUpdate | Represents field FDisableUpdate.
FDown | Represents field FDown.
FEMFImage | Represents field FEMFImage.
FEMFImagePage | Represents field FEMFImagePage.
FFrameColor | Represents field FFrameColor.
FHighlightEditable | Represents field FHighlightEditable.
FIsThumbnail | Represents field FIsThumbnail.
FLastFoundPage | Represents field FLastFoundPage.
FLastPoint | Represents field FLastPoint.
FLocked | Represents field FLocked.
FOffset | Represents field FOffset.
FPageList | Represents field FPageList.
FPageNo | Represents field FPageNo.
FPreview | Represents field FPreview.
FRTLLanguage | Represents field FRTLLanguage.
FSelectRect | Represents field FSelectRect.
FTimeOffset | Represents field FTimeOffset.
FZoom | Represents field FZoom.
Top
See Also

Reference

  • frxPreview


TfrxPreviewWorkspace Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxPreviewWorkspace class. (Overrides TfrxScrollWin.Create(TComponent).)
Destroy | Represents the destructor of the TfrxPreviewWorkspace class.
Top


TfrxPreviewWorkspace.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxPreviewWorkspace class.

Namespace: frxPreview
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxScrollWin.Create(TComponent)
See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.Destroy Destructor

Summary

Represents the destructor of the TfrxPreviewWorkspace class.

Namespace: frxPreview
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace Properties

Properties
Name | Description
ActiveFrameColor | Represents property ActiveFrameColor.
BackColor | Represents property BackColor.
FrameColor | Represents property FrameColor.
HighlightEditable | Represents property HighlightEditable.
IsThumbnail | Represents property IsThumbnail.
Locked | Represents property Locked.
OnDblClick | Represents property OnDblClick.
PageNo | Represents property PageNo.
Preview | Represents property Preview.
PreviewPages | Represents property PreviewPages.
RTLLanguage | Represents property RTLLanguage.
Zoom | Represents property Zoom.
Top


TfrxPreviewWorkspace.ActiveFrameColor Property

Summary

Represents property ActiveFrameColor.

Namespace: frxPreview
Syntax
Delphi
public
 property ActiveFrameColor: TColor read FActiveFrameColor write FActiveFrameColor default $804020;

Property Value

Type: TColor

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.BackColor Property

Summary

Represents property BackColor.

Namespace: frxPreview
Syntax
Delphi
public
 property BackColor: TColor read FBackColor write FBackColor default clGray;

Property Value

Type: TColor

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FrameColor Property

Summary

Represents property FrameColor.

Namespace: frxPreview
Syntax
Delphi
public
 property FrameColor: TColor read FFrameColor write FFrameColor default clBlack;

Property Value

Type: TColor

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.HighlightEditable Property

Summary

Represents property HighlightEditable.

Namespace: frxPreview
Syntax
Delphi
public
 property HighlightEditable: Boolean read FHighlightEditable write FHighlightEditable;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.IsThumbnail Property

Summary

Represents property IsThumbnail.

Namespace: frxPreview
Syntax
Delphi
public
 property IsThumbnail: Boolean read FIsThumbnail write FIsThumbnail;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.Locked Property

Summary

Represents property Locked.

Namespace: frxPreview
Syntax
Delphi
public
 property Locked: Boolean read FLocked write SetLocked;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxPreview
Syntax
Delphi
public
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.PageNo Property

Summary

Represents property PageNo.

Namespace: frxPreview
Syntax
Delphi
public
 property PageNo: Integer read FPageNo write FPageNo;

Property Value

Type: Integer

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.Preview Property

Summary

Represents property Preview.

Namespace: frxPreview
Syntax
Delphi
public
 property Preview: TfrxPreview read FPreview write FPreview;

Property Value

Type: TfrxPreview

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.PreviewPages Property

Summary

Represents property PreviewPages.

Namespace: frxPreview
Syntax
Delphi
public
 property PreviewPages: TfrxCustomPreviewPages read GetPreviewPages;

Property Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.RTLLanguage Property

Summary

Represents property RTLLanguage.

Namespace: frxPreview
Syntax
Delphi
public
 property RTLLanguage: Boolean read FRTLLanguage write FRTLLanguage;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.Zoom Property

Summary

Represents property Zoom.

Namespace: frxPreview
Syntax
Delphi
public
 property Zoom: Extended read FZoom write FZoom;

Property Value

Type: Extended

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace Methods

Methods
Name | Description
AddPage(Integer,Integer) | Represents method AddPage(Integer,Integer).
CalcPageBounds(Integer) | Represents method CalcPageBounds(Integer).
CallIteractiveEvent(TMouseButton,TShiftState,Integer,Integer,TfrxPreviewIntEventParams) | Represents method CallIteractiveEvent(TMouseButton,TShiftState,Integer,Integer,TfrxPreviewIntEventParams).
ClearPageList | Represents method ClearPageList.
DoMouseWheel(TShiftState,Integer,TPoint) | Represents method DoMouseWheel(TShiftState,Integer,TPoint).
DrawPages(Boolean) | Represents method DrawPages(Boolean).
FindText | Represents method FindText.
GetPreviewPages | Represents method GetPreviewPages.
GetTopPosition | Represents method GetTopPosition.
HighlightText | Represents method HighlightText.
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
OnHScrollChange(TObject) | Represents method OnHScrollChange(TObject). (Overrides TfrxScrollWin.OnHScrollChange(TObject).)
OnVScrollChange(TObject) | Represents method OnVScrollChange(TObject). (Overrides TfrxScrollWin.OnVScrollChange(TObject).)
Paint | Represents method Paint. (Overrides TfrxScrollWin.Paint.)
PrevDblClick(TObject) | Represents method PrevDblClick(TObject).
Resize | Represents method Resize.
ScaleRect(TRect,Extended,Extended,Extended) | Represents method ScaleRect(TRect,Extended,Extended,Extended).
SetEditMode(TfrxPreviewIntEventParams) | Represents method SetEditMode(TfrxPreviewIntEventParams).
SetLocked(Boolean) | Represents method SetLocked(Boolean).
SetPosition(Integer,Integer) | Represents method SetPosition(Integer,Integer).
SetToPageNo(Integer) | Represents method SetToPageNo(Integer).
UpdateScrollBars | Represents method UpdateScrollBars.
Top


TfrxPreviewWorkspace.AddPage(Integer,Integer) Method

Summary

Represents method AddPage(Integer,Integer).

Namespace: frxPreview
Syntax
Delphi
public
 procedure AddPage(AWidth, AHeight: Integer);

Parameters

AWidth
Type: Integer

AHeight
Type: Integer

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.CalcPageBounds(Integer) Method

Summary

Represents method CalcPageBounds(Integer).

Namespace: frxPreview
Syntax
Delphi
public
 procedure CalcPageBounds(ClientWidth: Integer);

Parameters

ClientWidth
Type: Integer

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.CallIteractiveEvent(TMouseButton,TShiftState,Integer,Integer,TfrxPreviewIntEventParams) Method

Summary

Represents method CallIteractiveEvent(TMouseButton,TShiftState,Integer,Integer,TfrxPreviewIntEventParams).

Namespace: frxPreview
Syntax
Delphi
protected
 procedure CallIteractiveEvent(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer; var aEvent: TfrxPreviewIntEventParams);

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

aEvent
Type: TfrxPreviewIntEventParams

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.ClearPageList Method

Summary

Represents method ClearPageList.

Namespace: frxPreview
Syntax
Delphi
public
 procedure ClearPageList;
See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.DoMouseWheel(TShiftState,Integer,TPoint) Method

Summary

Represents method DoMouseWheel(TShiftState,Integer,TPoint).

Namespace: frxPreview
Syntax
Delphi
protected
 function DoMouseWheel(Shift: TShiftState; WheelDelta: Integer;
 MousePos: TPoint): Boolean; override;

Parameters

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

Return Value

Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.DrawPages(Boolean) Method

Summary

Represents method DrawPages(Boolean).

Namespace: frxPreview
Syntax
Delphi
private
 procedure DrawPages(BorderOnly: Boolean);

Parameters

BorderOnly
Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FindText Method

Summary

Represents method FindText.

Namespace: frxPreview
Syntax
Delphi
private
 procedure FindText;
See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.GetPreviewPages Method

Summary

Represents method GetPreviewPages.

Namespace: frxPreview
Syntax
Delphi
private
 function GetPreviewPages: TfrxCustomPreviewPages;

Return Value

Type: TfrxCustomPreviewPages

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.GetTopPosition Method

Summary

Represents method GetTopPosition.

Namespace: frxPreview
Syntax
Delphi
public
 function GetTopPosition: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.HighlightText Method

Summary

Represents method HighlightText.

Namespace: frxPreview
Syntax
Delphi
private
 procedure HighlightText;
See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.MouseDown(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxPreview
Syntax
Delphi
protected
 procedure MouseDown(Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.MouseMove(TShiftState,Integer,Integer) Method

Summary

Represents method MouseMove(TShiftState,Integer,Integer).

Namespace: frxPreview
Syntax
Delphi
protected
 procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;

Parameters

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxPreview
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.OnHScrollChange(TObject) Method

Summary

Represents method OnHScrollChange(TObject).

Namespace: frxPreview
Syntax
Delphi
protected
 procedure OnHScrollChange(Sender: TObject); override;

Parameters

Sender
Type: TObject

Overrides

TfrxScrollWin.OnHScrollChange(TObject)
See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.OnVScrollChange(TObject) Method

Summary

Represents method OnVScrollChange(TObject).

Namespace: frxPreview
Syntax
Delphi
protected
 procedure OnVScrollChange(Sender: TObject); override;

Parameters

Sender
Type: TObject

Overrides

TfrxScrollWin.OnVScrollChange(TObject)
See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.Paint Method

Summary

Represents method Paint.

Namespace: frxPreview
Syntax
Delphi
public
 procedure Paint; override;

Overrides

TfrxScrollWin.Paint
See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.PrevDblClick(TObject) Method

Summary

Represents method PrevDblClick(TObject).

Namespace: frxPreview
Syntax
Delphi
protected
 procedure PrevDblClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.Resize Method

Summary

Represents method Resize.

Namespace: frxPreview
Syntax
Delphi
protected
 procedure Resize; override;
See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.ScaleRect(TRect,Extended,Extended,Extended) Method

Summary

Represents method ScaleRect(TRect,Extended,Extended,Extended).

Namespace: frxPreview
Syntax
Delphi
protected
 function ScaleRect(const aRect: TRect; Scale, aOffsetX, aOffsetY: Extended): TfrxRect;

Parameters

aRect
Type: TRect

Scale
Type: Extended

aOffsetX
Type: Extended

aOffsetY
Type: Extended

Return Value

Type: TfrxRect

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.SetEditMode(TfrxPreviewIntEventParams) Method

Summary

Represents method SetEditMode(TfrxPreviewIntEventParams).

Namespace: frxPreview
Syntax
Delphi
protected
 procedure SetEditMode(var aEvent: TfrxPreviewIntEventParams);

Parameters

aEvent
Type: TfrxPreviewIntEventParams

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.SetLocked(Boolean) Method

Summary

Represents method SetLocked(Boolean).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetLocked(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.SetPosition(Integer,Integer) Method

Summary

Represents method SetPosition(Integer,Integer).

Namespace: frxPreview
Syntax
Delphi
public
 procedure SetPosition(PageN, Top: Integer);

Parameters

PageN
Type: Integer

Top
Type: Integer

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.SetToPageNo(Integer) Method

Summary

Represents method SetToPageNo(Integer).

Namespace: frxPreview
Syntax
Delphi
private
 procedure SetToPageNo(PageNo: Integer);

Parameters

PageNo
Type: Integer

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.UpdateScrollBars Method

Summary

Represents method UpdateScrollBars.

Namespace: frxPreview
Syntax
Delphi
private
 procedure UpdateScrollBars;
See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace Fields

Fields
Name | Description
FActiveFrameColor | Represents field FActiveFrameColor.
FBackColor | Represents field FBackColor.
FCachedView | Represents field FCachedView.
FDefaultCursor | Represents field FDefaultCursor.
FDisableUpdate | Represents field FDisableUpdate.
FDown | Represents field FDown.
FEMFImage | Represents field FEMFImage.
FEMFImagePage | Represents field FEMFImagePage.
FFrameColor | Represents field FFrameColor.
FHighlightEditable | Represents field FHighlightEditable.
FIsThumbnail | Represents field FIsThumbnail.
FLastFoundPage | Represents field FLastFoundPage.
FLastPoint | Represents field FLastPoint.
FLocked | Represents field FLocked.
FOffset | Represents field FOffset.
FPageList | Represents field FPageList.
FPageNo | Represents field FPageNo.
FPreview | Represents field FPreview.
FRTLLanguage | Represents field FRTLLanguage.
FSelectRect | Represents field FSelectRect.
FTimeOffset | Represents field FTimeOffset.
FZoom | Represents field FZoom.
Top


TfrxPreviewWorkspace.FActiveFrameColor Field

Summary

Represents field FActiveFrameColor.

Namespace: frxPreview
Syntax
Delphi
private
 FActiveFrameColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FBackColor Field

Summary

Represents field FBackColor.

Namespace: frxPreview
Syntax
Delphi
private
 FBackColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FCachedView Field

Summary

Represents field FCachedView.

Namespace: frxPreview
Syntax
Delphi
private
 FCachedView: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FDefaultCursor Field

Summary

Represents field FDefaultCursor.

Namespace: frxPreview
Syntax
Delphi
private
 FDefaultCursor: TCursor;

Field Value

Type: TCursor

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FDisableUpdate Field

Summary

Represents field FDisableUpdate.

Namespace: frxPreview
Syntax
Delphi
private
 FDisableUpdate: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FDown Field

Summary

Represents field FDown.

Namespace: frxPreview
Syntax
Delphi
private
 FDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FEMFImage Field

Summary

Represents field FEMFImage.

Namespace: frxPreview
Syntax
Delphi
private
 FEMFImage: TMetafile;

Field Value

Type: TMetafile

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FEMFImagePage Field

Summary

Represents field FEMFImagePage.

Namespace: frxPreview
Syntax
Delphi
private
 FEMFImagePage: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FFrameColor Field

Summary

Represents field FFrameColor.

Namespace: frxPreview
Syntax
Delphi
private
 FFrameColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FHighlightEditable Field

Summary

Represents field FHighlightEditable.

Namespace: frxPreview
Syntax
Delphi
private
 FHighlightEditable: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FIsThumbnail Field

Summary

Represents field FIsThumbnail.

Namespace: frxPreview
Syntax
Delphi
private
 FIsThumbnail: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FLastFoundPage Field

Summary

Represents field FLastFoundPage.

Namespace: frxPreview
Syntax
Delphi
private
 FLastFoundPage: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FLastPoint Field

Summary

Represents field FLastPoint.

Namespace: frxPreview
Syntax
Delphi
private
 FLastPoint: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FLocked Field

Summary

Represents field FLocked.

Namespace: frxPreview
Syntax
Delphi
private
 FLocked: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FOffset Field

Summary

Represents field FOffset.

Namespace: frxPreview
Syntax
Delphi
private
 FOffset: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FPageList Field

Summary

Represents field FPageList.

Namespace: frxPreview
Syntax
Delphi
private
 FPageList: TfrxPageList;

Field Value

Type: TfrxPageList

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FPageNo Field

Summary

Represents field FPageNo.

Namespace: frxPreview
Syntax
Delphi
private
 FPageNo: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FPreview Field

Summary

Represents field FPreview.

Namespace: frxPreview
Syntax
Delphi
private
 FPreview: TfrxPreview;

Field Value

Type: TfrxPreview

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FRTLLanguage Field

Summary

Represents field FRTLLanguage.

Namespace: frxPreview
Syntax
Delphi
private
 FRTLLanguage: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FSelectRect Field

Summary

Represents field FSelectRect.

Namespace: frxPreview
Syntax
Delphi
private
 FSelectRect: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FTimeOffset Field

Summary

Represents field FTimeOffset.

Namespace: frxPreview
Syntax
Delphi
private
 FTimeOffset: Cardinal;

Field Value

Type: Cardinal

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


TfrxPreviewWorkspace.FZoom Field

Summary

Represents field FZoom.

Namespace: frxPreview
Syntax
Delphi
private
 FZoom: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxPreviewWorkspace
  • frxPreview


frxPreview Records

Records
Name | Description
TfrxFindAllTextItem | Represents type TfrxFindAllTextItem.
TfrxTrvData | Represents type TfrxTrvData.
Top


TfrxFindAllTextItem Record

Summary

Represents type TfrxFindAllTextItem.

Namespace: frxPreview
Syntax
Delphi
type
 TfrxFindAllTextItem = record
 end;

The TfrxFindAllTextItem type exposes the following members.

Fields
Show:
Name | Description
Bounds | Represents field Bounds.
PageNo | Represents field PageNo.
Top
See Also

Reference

  • frxPreview


TfrxFindAllTextItem Fields

Fields
Name | Description
Bounds | Represents field Bounds.
PageNo | Represents field PageNo.
Top


TfrxFindAllTextItem.Bounds Field

Summary

Represents field Bounds.

Namespace: frxPreview
Syntax
Delphi
public
 Bounds: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxFindAllTextItem
  • frxPreview


TfrxFindAllTextItem.PageNo Field

Summary

Represents field PageNo.

Namespace: frxPreview
Syntax
Delphi
public
 PageNo: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxFindAllTextItem
  • frxPreview


TfrxTrvData Record

Summary

Represents type TfrxTrvData.

Namespace: frxPreview
Syntax
Delphi
type
 TfrxTrvData = record
 end;

The TfrxTrvData type exposes the following members.

Fields
Show:
Name | Description
PageNo | Represents field PageNo.
TextBnd | Represents field TextBnd.
Top
See Also

Reference

  • frxPreview


TfrxTrvData Fields

Fields
Name | Description
PageNo | Represents field PageNo.
TextBnd | Represents field TextBnd.
Top


TfrxTrvData.PageNo Field

Summary

Represents field PageNo.

Namespace: frxPreview
Syntax
Delphi
public
 PageNo: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTrvData
  • frxPreview


TfrxTrvData.TextBnd Field

Summary

Represents field TextBnd.

Namespace: frxPreview
Syntax
Delphi
public
 TextBnd: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxTrvData
  • frxPreview


frxPreview Enumerations

Enumerations
Name | Description
TfrxPreviewTool | Represents type TfrxPreviewTool.
Top


TfrxPreviewTool Enumeration

Summary

Represents type TfrxPreviewTool.

Namespace: frxPreview
Syntax
Delphi
type
 TfrxPreviewTool = (ptHand, ptZoom);

The TfrxPreviewTool type exposes the following members.

Members
Show:
Name | Description
ptHand | Represents constant ptHand.
ptZoom | Represents constant ptZoom.
Top
See Also

Reference

  • frxPreview


frxPreview Delegates

Delegates
Name | Description
TfrxFindAllTextCallbackFunc | Represents type TfrxFindAllTextCallbackFunc.
TfrxPageChangedEvent | This event is generated when the current page is being changed.
Top


TfrxFindAllTextCallbackFunc Delegate

Summary

Represents type TfrxFindAllTextCallbackFunc.

Namespace: frxPreview
Syntax
Delphi
type
 TfrxFindAllTextCallbackFunc = function (Item: TfrxFindAllTextItem; Text: String; Data: Pointer): Boolean;
See Also

Reference

  • frxPreview


TfrxPageChangedEvent Delegate

Summary

This event is generated when the current page is being changed.

Namespace: frxPreview
Syntax
Delphi
type
 TfrxPageChangedEvent = procedure(Sender: TfrxPreview; PageNo: Integer) of object;
See Also

Reference

  • frxPreview


frxPreview Types

Types
Name | Description
PfrxTrvData | Represents a pointer type to TfrxTrvData.
Top


PfrxTrvData Type

Summary

Represents a pointer type to TfrxTrvData.

Namespace: frxPreview
Syntax
Delphi
type
 PfrxTrvData = ^TfrxTrvData;
See Also

Reference

  • frxPreview


frxPreview Constants

Constants
Name | Description
WM_UPDATEZOOM | Represents constant WM_UPDATEZOOM.
Top


WM_UPDATEZOOM Constant

Summary

Represents constant WM_UPDATEZOOM.

Namespace: frxPreview
Syntax
Delphi
 WM_UPDATEZOOM = WM_USER + 1;

Value

Type: Void

See Also

Reference

  • frxPreview


frxPreviewPages Namespace

Summary

Represents namespace frxPreviewPages.

Classes
Name | Description
TfrxDictionary | Represents type TfrxDictionary.
TfrxOutline | Represents type TfrxOutline.
TfrxPreviewPages | Represents type TfrxPreviewPages.
Top


frxPreviewPages Classes

Classes
Name | Description
TfrxDictionary | Represents type TfrxDictionary.
TfrxOutline | Represents type TfrxOutline.
TfrxPreviewPages | Represents type TfrxPreviewPages.
Top


TfrxDictionary Class

Summary

Represents type TfrxDictionary.

Namespace: frxPreviewPages
Inheritance Hierarchy
TObject
frxPreviewPages.TfrxDictionary
Syntax
Delphi
type
 TfrxDictionary = class(TObject)
 end;

The TfrxDictionary type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxDictionary class.
Destroy | Represents the destructor of the TfrxDictionary class.
Top
Properties
Show:
Name | Description
Names | Represents property Names.
SourceNames | Represents property SourceNames.
Top
Methods
Show:
Name | Description
Add(String,String,TObject) | Represents method Add(String,String,TObject).
AddUnique(String,String,TObject) | Represents method AddUnique(String,String,TObject).
Clear | Represents method Clear.
CreateUniqueName(String) | Represents method CreateUniqueName(String).
GetObject(String) | Represents method GetObject(String).
GetSourceName(String) | Represents method GetSourceName(String).
Top
Fields
Show:
Name | Description
FNames | Represents field FNames.
FSourceNames | Represents field FSourceNames.
Top
See Also

Reference

  • frxPreviewPages


TfrxDictionary Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxDictionary class.
Destroy | Represents the destructor of the TfrxDictionary class.
Top


TfrxDictionary.Create Constructor

Summary

Initializes a new instance of the TfrxDictionary class.

Namespace: frxPreviewPages
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxDictionary
  • frxPreviewPages


TfrxDictionary.Destroy Destructor

Summary

Represents the destructor of the TfrxDictionary class.

Namespace: frxPreviewPages
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxDictionary
  • frxPreviewPages


TfrxDictionary Properties

Properties
Name | Description
Names | Represents property Names.
SourceNames | Represents property SourceNames.
Top


TfrxDictionary.Names Property

Summary

Represents property Names.

Namespace: frxPreviewPages
Syntax
Delphi
public
 property Names: TStringList read FNames;

Property Value

Type: TStringList

See Also

Reference

  • TfrxDictionary
  • frxPreviewPages


TfrxDictionary.SourceNames Property

Summary

Represents property SourceNames.

Namespace: frxPreviewPages
Syntax
Delphi
public
 property SourceNames: TStringList read FSourceNames;

Property Value

Type: TStringList

See Also

Reference

  • TfrxDictionary
  • frxPreviewPages


TfrxDictionary Methods

Methods
Name | Description
Add(String,String,TObject) | Represents method Add(String,String,TObject).
AddUnique(String,String,TObject) | Represents method AddUnique(String,String,TObject).
Clear | Represents method Clear.
CreateUniqueName(String) | Represents method CreateUniqueName(String).
GetObject(String) | Represents method GetObject(String).
GetSourceName(String) | Represents method GetSourceName(String).
Top


TfrxDictionary.Add(String,String,TObject) Method

Summary

Represents method Add(String,String,TObject).

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure Add(const Name, SourceName: String; Obj: TObject);

Parameters

Name
Type: String

SourceName
Type: String

Obj
Type: TObject

See Also

Reference

  • TfrxDictionary
  • frxPreviewPages


TfrxDictionary.AddUnique(String,String,TObject) Method

Summary

Represents method AddUnique(String,String,TObject).

Namespace: frxPreviewPages
Syntax
Delphi
public
 function AddUnique(const Base, SourceName: String; Obj: TObject): String;

Parameters

Base
Type: String

SourceName
Type: String

Obj
Type: TObject

Return Value

Type: String

See Also

Reference

  • TfrxDictionary
  • frxPreviewPages


TfrxDictionary.Clear Method

Summary

Represents method Clear.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxDictionary
  • frxPreviewPages


TfrxDictionary.CreateUniqueName(String) Method

Summary

Represents method CreateUniqueName(String).

Namespace: frxPreviewPages
Syntax
Delphi
public
 function CreateUniqueName(const Base: String): String;

Parameters

Base
Type: String

Return Value

Type: String

See Also

Reference

  • TfrxDictionary
  • frxPreviewPages


TfrxDictionary.GetObject(String) Method

Summary

Represents method GetObject(String).

Namespace: frxPreviewPages
Syntax
Delphi
public
 function GetObject(const Name: String): TObject;

Parameters

Name
Type: String

Return Value

Type: TObject

See Also

Reference

  • TfrxDictionary
  • frxPreviewPages


TfrxDictionary.GetSourceName(String) Method

Summary

Represents method GetSourceName(String).

Namespace: frxPreviewPages
Syntax
Delphi
public
 function GetSourceName(const Name: String): String;

Parameters

Name
Type: String

Return Value

Type: String

See Also

Reference

  • TfrxDictionary
  • frxPreviewPages


TfrxDictionary Fields

Fields
Name | Description
FNames | Represents field FNames.
FSourceNames | Represents field FSourceNames.
Top


TfrxDictionary.FNames Field

Summary

Represents field FNames.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FNames: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxDictionary
  • frxPreviewPages


TfrxDictionary.FSourceNames Field

Summary

Represents field FSourceNames.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FSourceNames: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxDictionary
  • frxPreviewPages


TfrxOutline Class

Summary

Represents type TfrxOutline.

Namespace: frxPreviewPages
Inheritance Hierarchy
TPersistent
frxClass.TfrxCustomOutline
frxPreviewPages.TfrxOutline
Syntax
Delphi
type
 TfrxOutline = class(TfrxCustomOutline)
 end;

The TfrxOutline type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxCustomPreviewPages) | Initializes a new instance of the TfrxCustomOutline class. (Inherited from TfrxCustomOutline.)
Top
Properties
Show:
Name | Description
Count | Represents property Count. (Inherited from TfrxCustomOutline.)
CurItem | Represents property CurItem. (Inherited from TfrxCustomOutline.)
PreviewPages | Represents property PreviewPages. (Inherited from TfrxCustomOutline.)
Top
Methods
Show:
Name | Description
AddItem(String,Integer) | Adds an element with the "Text" name to the current tree position. The current report's page and the Top position on the page are associated with the element. (Overrides TfrxCustomOutline.AddItem(String,Integer).)
DeleteItems(TfrxXMLItem) | Represents method DeleteItems(TfrxXMLItem). (Overrides TfrxCustomOutline.DeleteItems(TfrxXMLItem).)
Engine | Represents method Engine. (Inherited from TfrxCustomOutline.)
GetCount | Represents method GetCount. (Overrides TfrxCustomOutline.GetCount.)
GetCurPosition | Represents method GetCurPosition. (Overrides TfrxCustomOutline.GetCurPosition.)
GetItem(Integer,String,Integer,Integer) | Represents method GetItem(Integer,String,Integer,Integer). (Overrides TfrxCustomOutline.GetItem(Integer,String,Integer,Integer).)
LevelDown(Integer) | Represents method LevelDown(Integer). (Overrides TfrxCustomOutline.LevelDown(Integer).)
LevelRoot | Shifts the current position in the tree to the root level. (Overrides TfrxCustomOutline.LevelRoot.)
LevelUp | Shifts the current position in the tree on one level up. (Overrides TfrxCustomOutline.LevelUp.)
Root | Represents method Root.
ShiftItems(TfrxXMLItem,Integer) | Represents method ShiftItems(TfrxXMLItem,Integer). (Overrides TfrxCustomOutline.ShiftItems(TfrxXMLItem,Integer).)
Top
See Also

Reference

  • frxPreviewPages


TfrxOutline Methods

Methods
Name | Description
AddItem(String,Integer) | Adds an element with the "Text" name to the current tree position. The current report's page and the Top position on the page are associated with the element. (Overrides TfrxCustomOutline.AddItem(String,Integer).)
DeleteItems(TfrxXMLItem) | Represents method DeleteItems(TfrxXMLItem). (Overrides TfrxCustomOutline.DeleteItems(TfrxXMLItem).)
GetCount | Represents method GetCount. (Overrides TfrxCustomOutline.GetCount.)
GetCurPosition | Represents method GetCurPosition. (Overrides TfrxCustomOutline.GetCurPosition.)
GetItem(Integer,String,Integer,Integer) | Represents method GetItem(Integer,String,Integer,Integer). (Overrides TfrxCustomOutline.GetItem(Integer,String,Integer,Integer).)
LevelDown(Integer) | Represents method LevelDown(Integer). (Overrides TfrxCustomOutline.LevelDown(Integer).)
LevelRoot | Shifts the current position in the tree to the root level. (Overrides TfrxCustomOutline.LevelRoot.)
LevelUp | Shifts the current position in the tree on one level up. (Overrides TfrxCustomOutline.LevelUp.)
Root | Represents method Root.
ShiftItems(TfrxXMLItem,Integer) | Represents method ShiftItems(TfrxXMLItem,Integer). (Overrides TfrxCustomOutline.ShiftItems(TfrxXMLItem,Integer).)
Top


TfrxOutline.AddItem(String,Integer) Method

Summary

Adds an element with the "Text" name to the current tree position. The current report's page and the Top position on the page are associated with the element.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure AddItem(const Text: String; Top: Integer); override;

Parameters

Text
Type: String

Top
Type: Integer

Overrides

TfrxCustomOutline.AddItem(String,Integer)
See Also

Reference

  • TfrxOutline
  • frxPreviewPages


TfrxOutline.DeleteItems(TfrxXMLItem) Method

Summary

Represents method DeleteItems(TfrxXMLItem).

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure DeleteItems(From: TfrxXMLItem); override;

Parameters

From
Type: TfrxXMLItem

Overrides

TfrxCustomOutline.DeleteItems(TfrxXMLItem)
See Also

Reference

  • TfrxOutline
  • frxPreviewPages


TfrxOutline.GetCount Method

Summary

Represents method GetCount.

Namespace: frxPreviewPages
Syntax
Delphi
protected
 function GetCount: Integer; override;

Return Value

Type: Integer

Overrides

TfrxCustomOutline.GetCount
See Also

Reference

  • TfrxOutline
  • frxPreviewPages


TfrxOutline.GetCurPosition Method

Summary

Represents method GetCurPosition.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function GetCurPosition: TfrxXMLItem; override;

Return Value

Type: TfrxXMLItem

Overrides

TfrxCustomOutline.GetCurPosition
See Also

Reference

  • TfrxOutline
  • frxPreviewPages


TfrxOutline.GetItem(Integer,String,Integer,Integer) Method

Summary

Represents method GetItem(Integer,String,Integer,Integer).

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure GetItem(Index: Integer; var Text: String;
 var Page, Top: Integer); override;

Parameters

Index
Type: Integer

Text
Type: String

Page
Type: Integer

Top
Type: Integer

Overrides

TfrxCustomOutline.GetItem(Integer,String,Integer,Integer)
See Also

Reference

  • TfrxOutline
  • frxPreviewPages


TfrxOutline.LevelDown(Integer) Method

Summary

Represents method LevelDown(Integer).

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure LevelDown(Index: Integer); override;

Parameters

Index
Type: Integer

Overrides

TfrxCustomOutline.LevelDown(Integer)
See Also

Reference

  • TfrxOutline
  • frxPreviewPages


TfrxOutline.LevelRoot Method

Summary

Shifts the current position in the tree to the root level.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure LevelRoot; override;

Overrides

TfrxCustomOutline.LevelRoot
See Also

Reference

  • TfrxOutline
  • frxPreviewPages


TfrxOutline.LevelUp Method

Summary

Shifts the current position in the tree on one level up.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure LevelUp; override;

Overrides

TfrxCustomOutline.LevelUp
See Also

Reference

  • TfrxOutline
  • frxPreviewPages


TfrxOutline.Root Method

Summary

Represents method Root.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function Root: TfrxXMLItem;

Return Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxOutline
  • frxPreviewPages


TfrxOutline.ShiftItems(TfrxXMLItem,Integer) Method

Summary

Represents method ShiftItems(TfrxXMLItem,Integer).

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure ShiftItems(From: TfrxXMLItem; NewTop: Integer); override;

Parameters

From
Type: TfrxXMLItem

NewTop
Type: Integer

Overrides

TfrxCustomOutline.ShiftItems(TfrxXMLItem,Integer)
See Also

Reference

  • TfrxOutline
  • frxPreviewPages


TfrxPreviewPages Class

Summary

Represents type TfrxPreviewPages.

Namespace: frxPreviewPages
Inheritance Hierarchy
TObject
frxClass.TfrxCustomPreviewPages
frxPreviewPages.TfrxPreviewPages
Syntax
Delphi
type
 TfrxPreviewPages = class(TfrxCustomPreviewPages)
 end;

The TfrxPreviewPages type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport) | Default constructor. (Overrides TfrxCustomPreviewPages.Create(TfrxReport).)
Destroy | Represents the destructor of the TfrxPreviewPages class. (Overrides TfrxCustomPreviewPages.Destroy.)
Top
Properties
Show:
Name | Description
AddPageAction | This flag used by AddPage method. apWriteOver - writes over current page if it isn't last page (in case it's last page a new page will be added). apWriteOver - always adds new page. (Inherited from TfrxCustomPreviewPages.)
Count | Number of pages in the prepared report. (Inherited from TfrxCustomPreviewPages.)
CurPage | Current page number. (Inherited from TfrxCustomPreviewPages.)
CurPreviewPage | Current previewed page number. (Inherited from TfrxCustomPreviewPages.)
Engine | Reference to the report engine object. (Inherited from TfrxCustomPreviewPages.)
FirstPage | First page number in composite report. (Inherited from TfrxCustomPreviewPages.)
Outline | Link to the "Report outline" class. (Inherited from TfrxCustomPreviewPages.)
PageSize[Integer] | List of page sizes in the prepared report. (Inherited from TfrxCustomPreviewPages.)
Page[Integer] | List of pages in the prepared report. (Inherited from TfrxCustomPreviewPages.)
PostProcessor | Post-process data dictionary object. (Inherited from TfrxCustomPreviewPages.)
PrintCopyNo | Number of printed copy. (Inherited from TfrxCustomPreviewPages.)
PrintScale | Scale for print output. (Inherited from TfrxCustomPreviewPages.)
Report | Reference to a report object. (Inherited from TfrxCustomPreviewPages.)
SourcePages | Represents property SourcePages.
Top
Methods
Show:
Name | Description
AddAnchor(String) | Represents method AddAnchor(String).
AddEmptyPage(Integer) | Inserts an empty preview page at given position. (Overrides TfrxCustomPreviewPages.AddEmptyPage(Integer).)
AddFrom(TfrxReport) | Creates a composite prepared report through concatenation of preview pages in to current preview pages. (Overrides TfrxCustomPreviewPages.AddFrom(TfrxReport).)
AddObject(TfrxComponent) | This method adds an object to current preview page. (Overrides TfrxCustomPreviewPages.AddObject(TfrxComponent).)
AddPage(TfrxReportPage) | This method adds new preview page or increases number of current preview page by 1 depends on AddPageAction flag. (Overrides TfrxCustomPreviewPages.AddPage(TfrxReportPage).)
AddPicture(TfrxPictureView) | Adds picture object to preview pages picture cache. (Overrides TfrxCustomPreviewPages.AddPicture(TfrxPictureView).)
AddSourcePage(TfrxReportPage) | This method adds report template page to preview page objects dictionary. (Overrides TfrxCustomPreviewPages.AddSourcePage(TfrxReportPage).)
AddToSourcePage(TfrxComponent) | This method adds report template object to preview page objects dictionary. (Overrides TfrxCustomPreviewPages.AddToSourcePage(TfrxComponent).)
AfterLoad | Represents method AfterLoad.
BandExists(TfrxBand) | Checks if band exist on current preview page. (Overrides TfrxCustomPreviewPages.BandExists(TfrxBand).)
BeforeSave | Represents method BeforeSave.
BeginPass | The report engine call this method when start first pass of double pass report. (Overrides TfrxCustomPreviewPages.BeginPass.)
Clear | Clears a prepared report. (Overrides TfrxCustomPreviewPages.Clear.)
ClearFirstPassPages | Clears results of the first pass. (Overrides TfrxCustomPreviewPages.ClearFirstPassPages.)
ClearPageCache | Represents method ClearPageCache.
ClearSourcePages | Represents method ClearSourcePages.
CurXMLPage | Represents method CurXMLPage.
CutObjects(Integer) | Cuts objects from current serialized XML page by given XML node position to temporary cut-buffer. (Overrides TfrxCustomPreviewPages.CutObjects(Integer).)
DeleteAnchors(Integer) | Deletes all preview pages anchors starts at given position. (Overrides TfrxCustomPreviewPages.DeleteAnchors(Integer).)
DeleteObjects(Integer) | Deletes serialized XML objects at given XML node position from current serialized preview page. (Overrides TfrxCustomPreviewPages.DeleteObjects(Integer).)
DeletePage(Integer) | Deletes preview page at given position. (Overrides TfrxCustomPreviewPages.DeletePage(Integer).)
DoLoadFromStream | Represents method DoLoadFromStream.
DoSaveToStream | Represents method DoSaveToStream.
DrawPage(Integer,TCanvas,Extended,Extended,Extended,Extended,Boolean) | Draws prepared page on Canvas. (Overrides TfrxCustomPreviewPages.DrawPage(Integer,TCanvas,Extended,Extended,Extended,Extended,Boolean).)
Export(TfrxCustomExportFilter) | Exports a report. (Overrides TfrxCustomPreviewPages.Export(TfrxCustomExportFilter).)
FindAnchor(String) | Represents method FindAnchor(String).
FindAnchorRoot | Represents method FindAnchorRoot.
Finish | Called by the report engine when report preparation finished. (Overrides TfrxCustomPreviewPages.Finish.)
FireMouseLeave | Fires mouse leave behaviour for preview pages objects. (Overrides TfrxCustomPreviewPages.FireMouseLeave.)
GetAnchorCurPosition | Returns current anchor item position. (Overrides TfrxCustomPreviewPages.GetAnchorCurPosition.)
GetAnchorPage(String) | Represents method GetAnchorPage(String).
GetCount | Represents method GetCount. (Overrides TfrxCustomPreviewPages.GetCount.)
GetCurPosition | Returns current XML node position in serialized preview page. (Overrides TfrxCustomPreviewPages.GetCurPosition.)
GetLastColumnPos(Integer,Extended) | Represents method GetLastColumnPos(Integer,Extended).
GetLastY(Extended) | Returns last Y position on preview page which is not occupied by band objects. (Overrides TfrxCustomPreviewPages.GetLastY(Extended).)
GetLogicalPageNo | Returns logical page number for current page. (Overrides TfrxCustomPreviewPages.GetLogicalPageNo.)
GetLogicalTotalPages | Returns logical total pages count. (Overrides TfrxCustomPreviewPages.GetLogicalTotalPages.)
GetObject(String) | Represents method GetObject(String).
GetPage(Integer) | Represents method GetPage(Integer). (Overrides TfrxCustomPreviewPages.GetPage(Integer).)
GetPageSize(Integer) | Represents method GetPageSize(Integer). (Overrides TfrxCustomPreviewPages.GetPageSize(Integer).)
IncLogicalPageNumber | Updates logical page number variable. (Overrides TfrxCustomPreviewPages.IncLogicalPageNumber.)
Initialize | Initializes preview pages. (Overrides TfrxCustomPreviewPages.Initialize.)
LoadFromFile(String,Boolean) | Loads a prepared report from a file. (Overrides TfrxCustomPreviewPages.LoadFromFile(String,Boolean).)
LoadFromStream(TStream,Boolean) | Loads a prepared report from a stream. The AllowPartialLoading parameter allows to load large files partially for saving memory. (Overrides TfrxCustomPreviewPages.LoadFromStream(TStream,Boolean).)
LockPage | Represents method LockPage.
ModifyObject(TfrxComponent) | This method writes changes of report object on prepared report page to XML node with using objects data dictionary. Use this method to save changes made on object of prepared report. This method uses data dictionary and works much faster than ModifyPage method. (Overrides TfrxCustomPreviewPages.ModifyObject(TfrxComponent).)
ModifyPage(Integer,TfrxReportPage) | This method writes changes of prepared page with all objects to serialized XML. Use this method to save all changes made on prepared page. (Overrides TfrxCustomPreviewPages.ModifyPage(Integer,TfrxReportPage).)
ObjectOver(Integer,Integer,Integer,TMouseButton,TShiftState,Extended,Extended,Extended,TfrxPreviewIntEventParams) | This method sends an interactive message to preview page or/and objects on that page. (Overrides TfrxCustomPreviewPages.ObjectOver(Integer,Integer,Integer,TMouseButton,TShiftState,Extended,Extended,Extended,TfrxPreviewIntEventParams).)
PasteObjects(Extended,Extended) | Pastes cut objects from temporary buffer to current serialized XML page at given X, Y position on the preview page. (Overrides TfrxCustomPreviewPages.PasteObjects(Extended,Extended).)
Print | Prints a report. (Overrides TfrxCustomPreviewPages.Print.)
ProcessHyperlink(TfrxHyperlink) | Represents method ProcessHyperlink(TfrxHyperlink).
ResetLogicalPageNumber | Resets logical page number variable. (Overrides TfrxCustomPreviewPages.ResetLogicalPageNumber.)
SaveToFile(String) | Saves a prepared report to a file. (Overrides TfrxCustomPreviewPages.SaveToFile(String).)
SaveToFilter(TfrxCustomIOTransport,String) | Saves a prepared report by using IO transport class to get stream for a prepared pages. (Overrides TfrxCustomPreviewPages.SaveToFilter(TfrxCustomIOTransport,String).)
SaveToStream(TStream) | Saves a prepared report to a stream. (Overrides TfrxCustomPreviewPages.SaveToStream(TStream).)
ShiftAnchors(Integer,Integer) | Shifts all preview pages anchors starts at given position by new top position. (Overrides TfrxCustomPreviewPages.ShiftAnchors(Integer,Integer).)
UnlockPage | Represents method UnlockPage.
UpdatePageDimension(Integer,Extended,Extended,TPrinterOrientation) | Represents method UpdatePageDimension(Integer,Extended,Extended,TPrinterOrientation).
UpdatePageDimensions(TfrxReportPage,Extended,Extended) | Represents method UpdatePageDimensions(TfrxReportPage,Extended,Extended).
UpdatePageLastColumn(Integer,Extended,Boolean) | Represents method UpdatePageLastColumn(Integer,Extended,Boolean).
Top
Fields
Show:
Name | Description
FAllowPartialLoading | Represents field FAllowPartialLoading.
FCopyNo | Represents field FCopyNo. (Inherited from TfrxCustomPreviewPages.)
FDictionary | Represents field FDictionary.
FFirstObjectIndex | Represents field FFirstObjectIndex.
FFirstOutlineIndex | Represents field FFirstOutlineIndex.
FFirstPageIndex | Represents field FFirstPageIndex.
FLastDrill | Represents field FLastDrill.
FLastObjectOver | Represents field FLastObjectOver.
FLastY | Represents field FLastY.
FLockedPage | Represents field FLockedPage.
FLogicalPageN | Represents field FLogicalPageN.
FPageCache | Represents field FPageCache.
FPagesItem | Represents field FPagesItem.
FPictureCache | Represents field FPictureCache.
FPostProcessor | Represents field FPostProcessor. (Inherited from TfrxCustomPreviewPages.)
FPrintScale | Represents field FPrintScale. (Inherited from TfrxCustomPreviewPages.)
FSourcePages | Represents field FSourcePages.
FTempStream | Represents field FTempStream.
FXMLDoc | Represents field FXMLDoc.
FXMLSize | Represents field FXMLSize.
Top
See Also

Reference

  • frxPreviewPages


TfrxPreviewPages Constructors

Constructors
Name | Description
Create(TfrxReport) | Default constructor. (Overrides TfrxCustomPreviewPages.Create(TfrxReport).)
Destroy | Represents the destructor of the TfrxPreviewPages class. (Overrides TfrxCustomPreviewPages.Destroy.)
Top


TfrxPreviewPages.Create(TfrxReport) Constructor

Summary

Default constructor.

Namespace: frxPreviewPages
Syntax
Delphi
public
 constructor Create(AReport: TfrxReport); override;

Parameters

AReport
Type: TfrxReport

Reference to an owner report component.

Overrides

TfrxCustomPreviewPages.Create(TfrxReport)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.Destroy Destructor

Summary

Represents the destructor of the TfrxPreviewPages class.

Namespace: frxPreviewPages
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxCustomPreviewPages.Destroy
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages Properties

Properties
Name | Description
SourcePages | Represents property SourcePages.
Top


TfrxPreviewPages.SourcePages Property

Summary

Represents property SourcePages.

Namespace: frxPreviewPages
Syntax
Delphi
public
 property SourcePages: TList read FSourcePages;

Property Value

Type: TList

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages Methods

Methods
Name | Description
AddAnchor(String) | Represents method AddAnchor(String).
AddEmptyPage(Integer) | Inserts an empty preview page at given position. (Overrides TfrxCustomPreviewPages.AddEmptyPage(Integer).)
AddFrom(TfrxReport) | Creates a composite prepared report through concatenation of preview pages in to current preview pages. (Overrides TfrxCustomPreviewPages.AddFrom(TfrxReport).)
AddObject(TfrxComponent) | This method adds an object to current preview page. (Overrides TfrxCustomPreviewPages.AddObject(TfrxComponent).)
AddPage(TfrxReportPage) | This method adds new preview page or increases number of current preview page by 1 depends on AddPageAction flag. (Overrides TfrxCustomPreviewPages.AddPage(TfrxReportPage).)
AddPicture(TfrxPictureView) | Adds picture object to preview pages picture cache. (Overrides TfrxCustomPreviewPages.AddPicture(TfrxPictureView).)
AddSourcePage(TfrxReportPage) | This method adds report template page to preview page objects dictionary. (Overrides TfrxCustomPreviewPages.AddSourcePage(TfrxReportPage).)
AddToSourcePage(TfrxComponent) | This method adds report template object to preview page objects dictionary. (Overrides TfrxCustomPreviewPages.AddToSourcePage(TfrxComponent).)
AfterLoad | Represents method AfterLoad.
BandExists(TfrxBand) | Checks if band exist on current preview page. (Overrides TfrxCustomPreviewPages.BandExists(TfrxBand).)
BeforeSave | Represents method BeforeSave.
BeginPass | The report engine call this method when start first pass of double pass report. (Overrides TfrxCustomPreviewPages.BeginPass.)
Clear | Clears a prepared report. (Overrides TfrxCustomPreviewPages.Clear.)
ClearFirstPassPages | Clears results of the first pass. (Overrides TfrxCustomPreviewPages.ClearFirstPassPages.)
ClearPageCache | Represents method ClearPageCache.
ClearSourcePages | Represents method ClearSourcePages.
CurXMLPage | Represents method CurXMLPage.
CutObjects(Integer) | Cuts objects from current serialized XML page by given XML node position to temporary cut-buffer. (Overrides TfrxCustomPreviewPages.CutObjects(Integer).)
DeleteAnchors(Integer) | Deletes all preview pages anchors starts at given position. (Overrides TfrxCustomPreviewPages.DeleteAnchors(Integer).)
DeleteObjects(Integer) | Deletes serialized XML objects at given XML node position from current serialized preview page. (Overrides TfrxCustomPreviewPages.DeleteObjects(Integer).)
DeletePage(Integer) | Deletes preview page at given position. (Overrides TfrxCustomPreviewPages.DeletePage(Integer).)
DoLoadFromStream | Represents method DoLoadFromStream.
DoSaveToStream | Represents method DoSaveToStream.
DrawPage(Integer,TCanvas,Extended,Extended,Extended,Extended,Boolean) | Draws prepared page on Canvas. (Overrides TfrxCustomPreviewPages.DrawPage(Integer,TCanvas,Extended,Extended,Extended,Extended,Boolean).)
Export(TfrxCustomExportFilter) | Exports a report. (Overrides TfrxCustomPreviewPages.Export(TfrxCustomExportFilter).)
FindAnchor(String) | Represents method FindAnchor(String).
FindAnchorRoot | Represents method FindAnchorRoot.
Finish | Called by the report engine when report preparation finished. (Overrides TfrxCustomPreviewPages.Finish.)
FireMouseLeave | Fires mouse leave behaviour for preview pages objects. (Overrides TfrxCustomPreviewPages.FireMouseLeave.)
GetAnchorCurPosition | Returns current anchor item position. (Overrides TfrxCustomPreviewPages.GetAnchorCurPosition.)
GetAnchorPage(String) | Represents method GetAnchorPage(String).
GetCount | Represents method GetCount. (Overrides TfrxCustomPreviewPages.GetCount.)
GetCurPosition | Returns current XML node position in serialized preview page. (Overrides TfrxCustomPreviewPages.GetCurPosition.)
GetLastColumnPos(Integer,Extended) | Represents method GetLastColumnPos(Integer,Extended).
GetLastY(Extended) | Returns last Y position on preview page which is not occupied by band objects. (Overrides TfrxCustomPreviewPages.GetLastY(Extended).)
GetLogicalPageNo | Returns logical page number for current page. (Overrides TfrxCustomPreviewPages.GetLogicalPageNo.)
GetLogicalTotalPages | Returns logical total pages count. (Overrides TfrxCustomPreviewPages.GetLogicalTotalPages.)
GetObject(String) | Represents method GetObject(String).
GetPage(Integer) | Represents method GetPage(Integer). (Overrides TfrxCustomPreviewPages.GetPage(Integer).)
GetPageSize(Integer) | Represents method GetPageSize(Integer). (Overrides TfrxCustomPreviewPages.GetPageSize(Integer).)
IncLogicalPageNumber | Updates logical page number variable. (Overrides TfrxCustomPreviewPages.IncLogicalPageNumber.)
Initialize | Initializes preview pages. (Overrides TfrxCustomPreviewPages.Initialize.)
LoadFromFile(String,Boolean) | Loads a prepared report from a file. (Overrides TfrxCustomPreviewPages.LoadFromFile(String,Boolean).)
LoadFromStream(TStream,Boolean) | Loads a prepared report from a stream. The AllowPartialLoading parameter allows to load large files partially for saving memory. (Overrides TfrxCustomPreviewPages.LoadFromStream(TStream,Boolean).)
LockPage | Represents method LockPage.
ModifyObject(TfrxComponent) | This method writes changes of report object on prepared report page to XML node with using objects data dictionary. Use this method to save changes made on object of prepared report. This method uses data dictionary and works much faster than ModifyPage method. (Overrides TfrxCustomPreviewPages.ModifyObject(TfrxComponent).)
ModifyPage(Integer,TfrxReportPage) | This method writes changes of prepared page with all objects to serialized XML. Use this method to save all changes made on prepared page. (Overrides TfrxCustomPreviewPages.ModifyPage(Integer,TfrxReportPage).)
ObjectOver(Integer,Integer,Integer,TMouseButton,TShiftState,Extended,Extended,Extended,TfrxPreviewIntEventParams) | This method sends an interactive message to preview page or/and objects on that page. (Overrides TfrxCustomPreviewPages.ObjectOver(Integer,Integer,Integer,TMouseButton,TShiftState,Extended,Extended,Extended,TfrxPreviewIntEventParams).)
PasteObjects(Extended,Extended) | Pastes cut objects from temporary buffer to current serialized XML page at given X, Y position on the preview page. (Overrides TfrxCustomPreviewPages.PasteObjects(Extended,Extended).)
Print | Prints a report. (Overrides TfrxCustomPreviewPages.Print.)
ProcessHyperlink(TfrxHyperlink) | Represents method ProcessHyperlink(TfrxHyperlink).
ResetLogicalPageNumber | Resets logical page number variable. (Overrides TfrxCustomPreviewPages.ResetLogicalPageNumber.)
SaveToFile(String) | Saves a prepared report to a file. (Overrides TfrxCustomPreviewPages.SaveToFile(String).)
SaveToFilter(TfrxCustomIOTransport,String) | Saves a prepared report by using IO transport class to get stream for a prepared pages. (Overrides TfrxCustomPreviewPages.SaveToFilter(TfrxCustomIOTransport,String).)
SaveToStream(TStream) | Saves a prepared report to a stream. (Overrides TfrxCustomPreviewPages.SaveToStream(TStream).)
ShiftAnchors(Integer,Integer) | Shifts all preview pages anchors starts at given position by new top position. (Overrides TfrxCustomPreviewPages.ShiftAnchors(Integer,Integer).)
UnlockPage | Represents method UnlockPage.
UpdatePageDimension(Integer,Extended,Extended,TPrinterOrientation) | Represents method UpdatePageDimension(Integer,Extended,Extended,TPrinterOrientation).
UpdatePageDimensions(TfrxReportPage,Extended,Extended) | Represents method UpdatePageDimensions(TfrxReportPage,Extended,Extended).
UpdatePageLastColumn(Integer,Extended,Boolean) | Represents method UpdatePageLastColumn(Integer,Extended,Boolean).
Top


TfrxPreviewPages.AddAnchor(String) Method

Summary

Represents method AddAnchor(String).

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure AddAnchor(const Text: String);

Parameters

Text
Type: String

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.AddEmptyPage(Integer) Method

Summary

Inserts an empty preview page at given position.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure AddEmptyPage(Index: Integer); override;

Parameters

Index
Type: Integer

Page index.

Overrides

TfrxCustomPreviewPages.AddEmptyPage(Integer)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.AddFrom(TfrxReport) Method

Summary

Creates a composite prepared report through concatenation of preview pages in to current preview pages.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure AddFrom(Report: TfrxReport); override;

Parameters

Report
Type: TfrxReport

Source report.

Overrides

TfrxCustomPreviewPages.AddFrom(TfrxReport)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.AddObject(TfrxComponent) Method

Summary

This method adds an object to current preview page.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure AddObject(Obj: TfrxComponent); override;

Parameters

Obj
Type: TfrxComponent

Reference to report object.

Overrides

TfrxCustomPreviewPages.AddObject(TfrxComponent)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.AddPage(TfrxReportPage) Method

Summary

This method adds new preview page or increases number of current preview page by 1 depends on AddPageAction flag.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure AddPage(Page: TfrxReportPage); override;

Parameters

Page
Type: TfrxReportPage

Reference to report page.

Overrides

TfrxCustomPreviewPages.AddPage(TfrxReportPage)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.AddPicture(TfrxPictureView) Method

Summary

Adds picture object to preview pages picture cache.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure AddPicture(Picture: TfrxPictureView); override;

Parameters

Picture
Type: TfrxPictureView

Overrides

TfrxCustomPreviewPages.AddPicture(TfrxPictureView)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.AddSourcePage(TfrxReportPage) Method

Summary

This method adds report template page to preview page objects dictionary.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure AddSourcePage(Page: TfrxReportPage); override;

Parameters

Page
Type: TfrxReportPage

Reference to report template page.

Overrides

TfrxCustomPreviewPages.AddSourcePage(TfrxReportPage)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.AddToSourcePage(TfrxComponent) Method

Summary

This method adds report template object to preview page objects dictionary.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure AddToSourcePage(Obj: TfrxComponent); override;

Parameters

Obj
Type: TfrxComponent

Report object.

Overrides

TfrxCustomPreviewPages.AddToSourcePage(TfrxComponent)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.AfterLoad Method

Summary

Represents method AfterLoad.

Namespace: frxPreviewPages
Syntax
Delphi
private
 procedure AfterLoad;
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.BandExists(TfrxBand) Method

Summary

Checks if band exist on current preview page.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function BandExists(Band: TfrxBand): Boolean; override;

Parameters

Band
Type: TfrxBand

Reference to Band in a report template.

Return Value

Type: Boolean

Overrides

TfrxCustomPreviewPages.BandExists(TfrxBand)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.BeforeSave Method

Summary

Represents method BeforeSave.

Namespace: frxPreviewPages
Syntax
Delphi
private
 procedure BeforeSave;
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.BeginPass Method

Summary

The report engine call this method when start first pass of double pass report.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure BeginPass; override;

Overrides

TfrxCustomPreviewPages.BeginPass
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.Clear Method

Summary

Clears a prepared report.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TfrxCustomPreviewPages.Clear
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.ClearFirstPassPages Method

Summary

Clears results of the first pass.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure ClearFirstPassPages; override;

Overrides

TfrxCustomPreviewPages.ClearFirstPassPages
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.ClearPageCache Method

Summary

Represents method ClearPageCache.

Namespace: frxPreviewPages
Syntax
Delphi
private
 procedure ClearPageCache;
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.ClearSourcePages Method

Summary

Represents method ClearSourcePages.

Namespace: frxPreviewPages
Syntax
Delphi
private
 procedure ClearSourcePages;
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.CurXMLPage Method

Summary

Represents method CurXMLPage.

Namespace: frxPreviewPages
Syntax
Delphi
private
 function CurXMLPage: TfrxXMLItem;

Return Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.CutObjects(Integer) Method

Summary

Cuts objects from current serialized XML page by given XML node position to temporary cut-buffer.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure CutObjects(APosition: Integer); override;

Parameters

APosition
Type: Integer

Index of XML node in serialized preview page XML node.

Overrides

TfrxCustomPreviewPages.CutObjects(Integer)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.DeleteAnchors(Integer) Method

Summary

Deletes all preview pages anchors starts at given position.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure DeleteAnchors(From: Integer); override;

Parameters

From
Type: Integer

Start item position.

Overrides

TfrxCustomPreviewPages.DeleteAnchors(Integer)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.DeleteObjects(Integer) Method

Summary

Deletes serialized XML objects at given XML node position from current serialized preview page.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure DeleteObjects(APosition: Integer); override;

Parameters

APosition
Type: Integer

XML node position.

Overrides

TfrxCustomPreviewPages.DeleteObjects(Integer)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.DeletePage(Integer) Method

Summary

Deletes preview page at given position.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure DeletePage(Index: Integer); override;

Parameters

Index
Type: Integer

Page index.

Overrides

TfrxCustomPreviewPages.DeletePage(Integer)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.DoLoadFromStream Method

Summary

Represents method DoLoadFromStream.

Namespace: frxPreviewPages
Syntax
Delphi
private
 procedure DoLoadFromStream;
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.DoSaveToStream Method

Summary

Represents method DoSaveToStream.

Namespace: frxPreviewPages
Syntax
Delphi
private
 procedure DoSaveToStream;
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.DrawPage(Integer,TCanvas,Extended,Extended,Extended,Extended,Boolean) Method

Summary

Draws prepared page on Canvas.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure DrawPage(Index: Integer; Canvas: TCanvas; ScaleX, ScaleY,
 OffsetX, OffsetY: Extended; bHighlightEditable: Boolean = False); override;

Parameters

Index
Type: Integer

Index of page to draw.

Canvas
Type: TCanvas

Destination Canvas.

ScaleX
Type: Extended

Scale X.

ScaleY
Type: Extended

Scale Y.

OffsetX
Type: Extended

X offset.

OffsetY
Type: Extended

Y offset.

bHighlightEditable
Type: Boolean

Draws with highlight of editable objects.

Overrides

TfrxCustomPreviewPages.DrawPage(Integer,TCanvas,Extended,Extended,Extended,Extended,Boolean)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.Export(TfrxCustomExportFilter) Method

Summary

Exports a report.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function Export(Filter: TfrxCustomExportFilter): Boolean; override;

Parameters

Filter
Type: TfrxCustomExportFilter

Return Value

Type: Boolean

Overrides

TfrxCustomPreviewPages.Export(TfrxCustomExportFilter)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FindAnchor(String) Method

Summary

Represents method FindAnchor(String).

Namespace: frxPreviewPages
Syntax
Delphi
public
 function FindAnchor(const Text: String): TfrxXMLItem;

Parameters

Text
Type: String

Return Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FindAnchorRoot Method

Summary

Represents method FindAnchorRoot.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function FindAnchorRoot: TfrxXMLItem;

Return Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.Finish Method

Summary

Called by the report engine when report preparation finished.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure Finish; override;

Overrides

TfrxCustomPreviewPages.Finish
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FireMouseLeave Method

Summary

Fires mouse leave behaviour for preview pages objects.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure FireMouseLeave; override;

Overrides

TfrxCustomPreviewPages.FireMouseLeave
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.GetAnchorCurPosition Method

Summary

Returns current anchor item position.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function GetAnchorCurPosition: Integer; override;

Return Value

Type: Integer

Overrides

TfrxCustomPreviewPages.GetAnchorCurPosition
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.GetAnchorPage(String) Method

Summary

Represents method GetAnchorPage(String).

Namespace: frxPreviewPages
Syntax
Delphi
public
 function GetAnchorPage(const Text: String): Integer;

Parameters

Text
Type: String

Return Value

Type: Integer

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.GetCount Method

Summary

Represents method GetCount.

Namespace: frxPreviewPages
Syntax
Delphi
protected
 function GetCount: Integer; override;

Return Value

Type: Integer

Overrides

TfrxCustomPreviewPages.GetCount
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.GetCurPosition Method

Summary

Returns current XML node position in serialized preview page.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function GetCurPosition: Integer; override;

Return Value

Type: Integer

Overrides

TfrxCustomPreviewPages.GetCurPosition
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.GetLastColumnPos(Integer,Extended) Method

Summary

Represents method GetLastColumnPos(Integer,Extended).

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure GetLastColumnPos(var aColumn: Integer; var ColumnPos: Extended);

Parameters

aColumn
Type: Integer

ColumnPos
Type: Extended

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.GetLastY(Extended) Method

Summary

Returns last Y position on preview page which is not occupied by band objects.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function GetLastY(ColumnPosition: Extended = 0): Extended; override;

Parameters

ColumnPosition
Type: Extended

Column X position.

Return Value

Type: Extended

Overrides

TfrxCustomPreviewPages.GetLastY(Extended)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.GetLogicalPageNo Method

Summary

Returns logical page number for current page.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function GetLogicalPageNo: Integer; override;

Return Value

Type: Integer

Overrides

TfrxCustomPreviewPages.GetLogicalPageNo
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.GetLogicalTotalPages Method

Summary

Returns logical total pages count.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function GetLogicalTotalPages: Integer; override;

Return Value

Type: Integer

Overrides

TfrxCustomPreviewPages.GetLogicalTotalPages
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.GetObject(String) Method

Summary

Represents method GetObject(String).

Namespace: frxPreviewPages
Syntax
Delphi
private
 function GetObject(const Name: String): TfrxComponent;

Parameters

Name
Type: String

Return Value

Type: TfrxComponent

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.GetPage(Integer) Method

Summary

Represents method GetPage(Integer).

Namespace: frxPreviewPages
Syntax
Delphi
protected
 function GetPage(Index: Integer): TfrxReportPage; override;

Parameters

Index
Type: Integer

Return Value

Type: TfrxReportPage

Overrides

TfrxCustomPreviewPages.GetPage(Integer)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.GetPageSize(Integer) Method

Summary

Represents method GetPageSize(Integer).

Namespace: frxPreviewPages
Syntax
Delphi
protected
 function GetPageSize(Index: Integer): TPoint; override;

Parameters

Index
Type: Integer

Return Value

Type: TPoint

Overrides

TfrxCustomPreviewPages.GetPageSize(Integer)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.IncLogicalPageNumber Method

Summary

Updates logical page number variable.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure IncLogicalPageNumber; override;

Overrides

TfrxCustomPreviewPages.IncLogicalPageNumber
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.Initialize Method

Summary

Initializes preview pages.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure Initialize; override;

Overrides

TfrxCustomPreviewPages.Initialize
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.LoadFromFile(String,Boolean) Method

Summary

Loads a prepared report from a file.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function LoadFromFile(const FileName: String;
 ExceptionIfNotFound: Boolean = False): Boolean; override;

Parameters

FileName
Type: String

ExceptionIfNotFound
Type: Boolean

Return Value

Type: Boolean

Overrides

TfrxCustomPreviewPages.LoadFromFile(String,Boolean)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.LoadFromStream(TStream,Boolean) Method

Summary

Loads a prepared report from a stream. The AllowPartialLoading parameter allows to load large files partially for saving memory.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure LoadFromStream(Stream: TStream;
 AllowPartialLoading: Boolean = False); override;

Parameters

Stream
Type: TStream

AllowPartialLoading
Type: Boolean

Overrides

TfrxCustomPreviewPages.LoadFromStream(TStream,Boolean)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.LockPage Method

Summary

Represents method LockPage.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure LockPage;
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.ModifyObject(TfrxComponent) Method

Summary

This method writes changes of report object on prepared report page to XML node with using objects data dictionary. Use this method to save changes made on object of prepared report. This method uses data dictionary and works much faster than ModifyPage method.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure ModifyObject(Component: TfrxComponent); override;

Parameters

Component
Type: TfrxComponent

Reference to modified prepared report object.

Overrides

TfrxCustomPreviewPages.ModifyObject(TfrxComponent)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.ModifyPage(Integer,TfrxReportPage) Method

Summary

This method writes changes of prepared page with all objects to serialized XML. Use this method to save all changes made on prepared page.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure ModifyPage(Index: Integer; Page: TfrxReportPage); override;

Parameters

Index
Type: Integer

Page index in prepared report.

Page
Type: TfrxReportPage

Reference to modified page object.

Overrides

TfrxCustomPreviewPages.ModifyPage(Integer,TfrxReportPage)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.ObjectOver(Integer,Integer,Integer,TMouseButton,TShiftState,Extended,Extended,Extended,TfrxPreviewIntEventParams) Method

Summary

This method sends an interactive message to preview page or/and objects on that page.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure ObjectOver(Index: Integer; X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; Scale, OffsetX, OffsetY: Extended; var aEventParams: TfrxPreviewIntEventParams); override;

Parameters

Index
Type: Integer

Page index of the page.

X
Type: Integer

X coordinate relative to parent preview workspace view(mouse coordinates).

Y
Type: Integer

Y coordinate relative to parent preview workspace view(mouse coordinates).

Button
Type: TMouseButton

Mouse button.

Shift
Type: TShiftState

Shift button.

Scale
Type: Extended

Current scale of preview window.

OffsetX
Type: Extended

Horizontal offset (start of draw area based on horizontal scroll).

OffsetY
Type: Extended

Vertical offset (start of draw area based on vertical scroll).

aEventParams
Type: TfrxPreviewIntEventParams

EventParams

Structure used for additional event parameters (like event type). Also stores return value.

Overrides

TfrxCustomPreviewPages.ObjectOver(Integer,Integer,Integer,TMouseButton,TShiftState,Extended,Extended,Extended,TfrxPreviewIntEventParams)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.PasteObjects(Extended,Extended) Method

Summary

Pastes cut objects from temporary buffer to current serialized XML page at given X, Y position on the preview page.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure PasteObjects(X, Y: Extended); override;

Parameters

X
Type: Extended

X coordinate (column position).

Y
Type: Extended

Y coordinate (band position).

Overrides

TfrxCustomPreviewPages.PasteObjects(Extended,Extended)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.Print Method

Summary

Prints a report.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function Print: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCustomPreviewPages.Print
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.ProcessHyperlink(TfrxHyperlink) Method

Summary

Represents method ProcessHyperlink(TfrxHyperlink).

Namespace: frxPreviewPages
Syntax
Delphi
private
 function ProcessHyperlink(Hyperlink: TfrxHyperlink): Boolean;

Parameters

Hyperlink
Type: TfrxHyperlink

Return Value

Type: Boolean

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.ResetLogicalPageNumber Method

Summary

Resets logical page number variable.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure ResetLogicalPageNumber; override;

Overrides

TfrxCustomPreviewPages.ResetLogicalPageNumber
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.SaveToFile(String) Method

Summary

Saves a prepared report to a file.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure SaveToFile(const FileName: String); override;

Parameters

FileName
Type: String

Overrides

TfrxCustomPreviewPages.SaveToFile(String)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.SaveToFilter(TfrxCustomIOTransport,String) Method

Summary

Saves a prepared report by using IO transport class to get stream for a prepared pages.

Namespace: frxPreviewPages
Syntax
Delphi
public
 function SaveToFilter(Filter: TfrxCustomIOTransport; const FileName: String): Boolean; override;

Parameters

Filter
Type: TfrxCustomIOTransport

IO transport filter instance.

FileName
Type: String

Name of the prepared file.

Return Value

Type: Boolean

Overrides

TfrxCustomPreviewPages.SaveToFilter(TfrxCustomIOTransport,String)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.SaveToStream(TStream) Method

Summary

Saves a prepared report to a stream.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure SaveToStream(Stream: TStream); override;

Parameters

Stream
Type: TStream

Overrides

TfrxCustomPreviewPages.SaveToStream(TStream)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.ShiftAnchors(Integer,Integer) Method

Summary

Shifts all preview pages anchors starts at given position by new top position.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure ShiftAnchors(From, NewTop: Integer); override;

Parameters

From
Type: Integer

Start item position.

NewTop
Type: Integer

New top position.

Overrides

TfrxCustomPreviewPages.ShiftAnchors(Integer,Integer)
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.UnlockPage Method

Summary

Represents method UnlockPage.

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure UnlockPage;
See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.UpdatePageDimension(Integer,Extended,Extended,TPrinterOrientation) Method

Summary

Represents method UpdatePageDimension(Integer,Extended,Extended,TPrinterOrientation).

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure UpdatePageDimension(Index: Integer; Width, Height: Extended; AOrientation: TPrinterOrientation);

Parameters

Index
Type: Integer

Width
Type: Extended

Height
Type: Extended

AOrientation
Type: TPrinterOrientation

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.UpdatePageDimensions(TfrxReportPage,Extended,Extended) Method

Summary

Represents method UpdatePageDimensions(TfrxReportPage,Extended,Extended).

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure UpdatePageDimensions(Page: TfrxReportPage; Width, Height: Extended);

Parameters

Page
Type: TfrxReportPage

Width
Type: Extended

Height
Type: Extended

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.UpdatePageLastColumn(Integer,Extended,Boolean) Method

Summary

Represents method UpdatePageLastColumn(Integer,Extended,Boolean).

Namespace: frxPreviewPages
Syntax
Delphi
public
 procedure UpdatePageLastColumn(aColumn: Integer; aColumnPos: Extended; aReset: Boolean = False);

Parameters

aColumn
Type: Integer

aColumnPos
Type: Extended

aReset
Type: Boolean

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages Fields

Fields
Name | Description
FAllowPartialLoading | Represents field FAllowPartialLoading.
FDictionary | Represents field FDictionary.
FFirstObjectIndex | Represents field FFirstObjectIndex.
FFirstOutlineIndex | Represents field FFirstOutlineIndex.
FFirstPageIndex | Represents field FFirstPageIndex.
FLastDrill | Represents field FLastDrill.
FLastObjectOver | Represents field FLastObjectOver.
FLastY | Represents field FLastY.
FLockedPage | Represents field FLockedPage.
FLogicalPageN | Represents field FLogicalPageN.
FPageCache | Represents field FPageCache.
FPagesItem | Represents field FPagesItem.
FPictureCache | Represents field FPictureCache.
FSourcePages | Represents field FSourcePages.
FTempStream | Represents field FTempStream.
FXMLDoc | Represents field FXMLDoc.
FXMLSize | Represents field FXMLSize.
Top


TfrxPreviewPages.FAllowPartialLoading Field

Summary

Represents field FAllowPartialLoading.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FAllowPartialLoading: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FDictionary Field

Summary

Represents field FDictionary.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FDictionary: TfrxDictionary;

Field Value

Type: TfrxDictionary

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FFirstObjectIndex Field

Summary

Represents field FFirstObjectIndex.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FFirstObjectIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FFirstOutlineIndex Field

Summary

Represents field FFirstOutlineIndex.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FFirstOutlineIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FFirstPageIndex Field

Summary

Represents field FFirstPageIndex.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FFirstPageIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FLastDrill Field

Summary

Represents field FLastDrill.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FLastDrill: TfrxGroupHeader;

Field Value

Type: TfrxGroupHeader

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FLastObjectOver Field

Summary

Represents field FLastObjectOver.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FLastObjectOver: TfrxView;

Field Value

Type: TfrxView

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FLastY Field

Summary

Represents field FLastY.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FLastY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FLockedPage Field

Summary

Represents field FLockedPage.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FLockedPage: TfrxReportPage;

Field Value

Type: TfrxReportPage

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FLogicalPageN Field

Summary

Represents field FLogicalPageN.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FLogicalPageN: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FPageCache Field

Summary

Represents field FPageCache.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FPageCache: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FPagesItem Field

Summary

Represents field FPagesItem.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FPagesItem: TfrxXMLItem;

Field Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FPictureCache Field

Summary

Represents field FPictureCache.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FPictureCache: TfrxPictureCache;

Field Value

Type: TfrxPictureCache

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FSourcePages Field

Summary

Represents field FSourcePages.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FSourcePages: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FTempStream Field

Summary

Represents field FTempStream.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FTempStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FXMLDoc Field

Summary

Represents field FXMLDoc.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FXMLDoc: TfrxXMLDocument;

Field Value

Type: TfrxXMLDocument

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


TfrxPreviewPages.FXMLSize Field

Summary

Represents field FXMLSize.

Namespace: frxPreviewPages
Syntax
Delphi
private
 FXMLSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPreviewPages
  • frxPreviewPages


frxPreviewPageSettings Namespace

Summary

Represents namespace frxPreviewPageSettings.

Classes
Name | Description
TfrxPageSettingsForm | Represents type TfrxPageSettingsForm.
Top
Enumerations
Name | Description
TfrxDesignerUnits | Represents type TfrxDesignerUnits.
Top


frxPreviewPageSettings Classes

Classes
Name | Description
TfrxPageSettingsForm | Represents type TfrxPageSettingsForm.
Top


TfrxPageSettingsForm Class

Summary

Represents type TfrxPageSettingsForm.

Namespace: frxPreviewPageSettings
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxPreviewPageSettings.TfrxPageSettingsForm
Syntax
Delphi
type
 TfrxPageSettingsForm = class(TfrxBaseForm)
 end;

The TfrxPageSettingsForm type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxBaseForm class. (Inherited from TfrxBaseForm.)
Top
Properties
Show:
Name | Description
CurrentFormPPI | Returns current PPI value of the form. (Inherited from TfrxBaseForm.)
IsPPIChanging | Represents property IsPPIChanging. (Inherited from TfrxBaseForm.)
NeedRebuild | Represents property NeedRebuild.
Page | Represents property Page.
Report | Represents property Report.
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseForm.)
AfterPPIChange | Represents method AfterPPIChange. (Inherited from TfrxBaseForm.)
AfterPPIMessage | Represents method AfterPPIMessage. (Inherited from TfrxBaseForm.)
BeforeDestruction | Represents method BeforeDestruction. (Inherited from TfrxBaseForm.)
BeforePPIChange | Represents method BeforePPIChange. (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer). (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean). (Inherited from TfrxBaseForm.)
DoClose(TCloseAction) | Represents method DoClose(TCloseAction). (Inherited from TfrxBaseForm.)
DoShow | Represents method DoShow. (Inherited from TfrxBaseForm.)
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer). (Inherited from TfrxBaseForm.)
EditorKeyPress(TObject,Char) | Represents method EditorKeyPress(TObject,Char).
FormHide(TObject) | Represents method FormHide(TObject).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
FormShow(TObject) | Represents method FormShow(TObject).
FormShowAfterLoad | Represents method FormShowAfterLoad. (Inherited from TfrxBaseForm.)
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Inherited from TfrxBaseForm.)
GetAvailablePreferences | Represents method GetAvailablePreferences. (Overrides TfrxBaseForm.GetAvailablePreferences.)
GetFormSectionName | Represents method GetFormSectionName. (Inherited from TfrxBaseForm.)
GetNeedRebuild | Represents method GetNeedRebuild.
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Inherited from TfrxBaseForm.)
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Inherited from TfrxBaseForm.)
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.LoadFormPreferences(TObject,TObject).)
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
mmToUnits(Extended) | Represents method mmToUnits(Extended).
PortraitRBClick(TObject) | Represents method PortraitRBClick(TObject).
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter. (Inherited from TfrxBaseForm.)
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Inherited from TfrxBaseForm.)
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Inherited from TfrxBaseForm.)
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxBaseForm.)
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms. (Inherited from TfrxBaseForm.)
SizeCBClick(TObject) | Represents method SizeCBClick(TObject).
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form. (Inherited from TfrxBaseForm.)
UnitsTomm(Extended) | Represents method UnitsTomm(Extended).
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Inherited from TfrxBaseForm.)
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Overrides TfrxBaseForm.UpdateResouces.)
WidthEChange(TObject) | Represents method WidthEChange(TObject).
Top
Fields
Show:
Name | Description
ApplyToAllRB | Represents field ApplyToAllRB.
ApplyToCurRB | Represents field ApplyToCurRB.
BottomL | Represents field BottomL.
CancelB | Represents field CancelB.
FHostedControls | Represents field FHostedControls. (Inherited from TfrxBaseForm.)
FPage | Represents field FPage.
FPrefEvent | Represents field FPrefEvent. (Inherited from TfrxBaseForm.)
FReport | Represents field FReport.
FUnits | Represents field FUnits.
FUpdating | Represents field FUpdating.
HeightE | Represents field HeightE.
HeightL | Represents field HeightL.
LandscapeImg | Represents field LandscapeImg.
LandscapeRB | Represents field LandscapeRB.
LeftL | Represents field LeftL.
MarginBottomE | Represents field MarginBottomE.
MarginLeftE | Represents field MarginLeftE.
MarginRightE | Represents field MarginRightE.
MarginsL | Represents field MarginsL.
MarginTopE | Represents field MarginTopE.
OKB | Represents field OKB.
OrientationL | Represents field OrientationL.
OtherL | Represents field OtherL.
PortraitImg | Represents field PortraitImg.
PortraitRB | Represents field PortraitRB.
RightL | Represents field RightL.
SizeCB | Represents field SizeCB.
SizeL | Represents field SizeL.
TopL | Represents field TopL.
UnitL1 | Represents field UnitL1.
UnitL2 | Represents field UnitL2.
UnitL3 | Represents field UnitL3.
UnitL4 | Represents field UnitL4.
UnitL5 | Represents field UnitL5.
UnitL6 | Represents field UnitL6.
WidthE | Represents field WidthE.
WidthL | Represents field WidthL.
Top
See Also

Reference

  • frxPreviewPageSettings


TfrxPageSettingsForm Properties

Properties
Name | Description
NeedRebuild | Represents property NeedRebuild.
Page | Represents property Page.
Report | Represents property Report.
Top


TfrxPageSettingsForm.NeedRebuild Property

Summary

Represents property NeedRebuild.

Namespace: frxPreviewPageSettings
Syntax
Delphi
public
 property NeedRebuild: Boolean read GetNeedRebuild;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.Page Property

Summary

Represents property Page.

Namespace: frxPreviewPageSettings
Syntax
Delphi
public
 property Page: TfrxReportPage read FPage write FPage;

Property Value

Type: TfrxReportPage

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.Report Property

Summary

Represents property Report.

Namespace: frxPreviewPageSettings
Syntax
Delphi
public
 property Report: TfrxReport read FReport write FReport;

Property Value

Type: TfrxReport

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm Methods

Methods
Name | Description
EditorKeyPress(TObject,Char) | Represents method EditorKeyPress(TObject,Char).
FormHide(TObject) | Represents method FormHide(TObject).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
FormShow(TObject) | Represents method FormShow(TObject).
GetAvailablePreferences | Represents method GetAvailablePreferences. (Overrides TfrxBaseForm.GetAvailablePreferences.)
GetNeedRebuild | Represents method GetNeedRebuild.
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.LoadFormPreferences(TObject,TObject).)
mmToUnits(Extended) | Represents method mmToUnits(Extended).
PortraitRBClick(TObject) | Represents method PortraitRBClick(TObject).
SizeCBClick(TObject) | Represents method SizeCBClick(TObject).
UnitsTomm(Extended) | Represents method UnitsTomm(Extended).
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Overrides TfrxBaseForm.UpdateResouces.)
WidthEChange(TObject) | Represents method WidthEChange(TObject).
Top


TfrxPageSettingsForm.EditorKeyPress(TObject,Char) Method

Summary

Represents method EditorKeyPress(TObject,Char).

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 procedure EditorKeyPress(Sender: TObject; var Key: Char);

Parameters

Sender
Type: TObject

Key
Type: Char

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.FormHide(TObject) Method

Summary

Represents method FormHide(TObject).

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 procedure FormHide(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.FormKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method FormKeyDown(TObject,Word,TShiftState).

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 procedure FormKeyDown(Sender: TObject; var Key: Word;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.GetAvailablePreferences Method

Summary

Represents method GetAvailablePreferences.

Namespace: frxPreviewPageSettings
Syntax
Delphi
protected
 function GetAvailablePreferences: TfrxPreferencesTypes; override;

Return Value

Type: TfrxPreferencesTypes

Overrides

TfrxBaseForm.GetAvailablePreferences
See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.GetNeedRebuild Method

Summary

Represents method GetNeedRebuild.

Namespace: frxPreviewPageSettings
Syntax
Delphi
protected
 function GetNeedRebuild: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.LoadFormPreferences(TObject,TObject) Method

Summary

Represents method LoadFormPreferences(TObject,TObject).

Namespace: frxPreviewPageSettings
Syntax
Delphi
protected
 procedure LoadFormPreferences(PreferencesStorage: TObject; DefPreferencesStorage: TObject); override;

Parameters

PreferencesStorage
Type: TObject

DefPreferencesStorage
Type: TObject

Overrides

TfrxBaseForm.LoadFormPreferences(TObject,TObject)
See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.mmToUnits(Extended) Method

Summary

Represents method mmToUnits(Extended).

Namespace: frxPreviewPageSettings
Syntax
Delphi
protected
 function mmToUnits(mm: Extended): Extended;

Parameters

mm
Type: Extended

Return Value

Type: Extended

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.PortraitRBClick(TObject) Method

Summary

Represents method PortraitRBClick(TObject).

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 procedure PortraitRBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.SizeCBClick(TObject) Method

Summary

Represents method SizeCBClick(TObject).

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 procedure SizeCBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.UnitsTomm(Extended) Method

Summary

Represents method UnitsTomm(Extended).

Namespace: frxPreviewPageSettings
Syntax
Delphi
protected
 function UnitsTomm(mm: Extended): Extended;

Parameters

mm
Type: Extended

Return Value

Type: Extended

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.UpdateResouces Method

Summary

Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources.

Namespace: frxPreviewPageSettings
Syntax
Delphi
public
 procedure UpdateResouces; override;

Overrides

TfrxBaseForm.UpdateResouces
See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.WidthEChange(TObject) Method

Summary

Represents method WidthEChange(TObject).

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 procedure WidthEChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm Fields

Fields
Name | Description
ApplyToAllRB | Represents field ApplyToAllRB.
ApplyToCurRB | Represents field ApplyToCurRB.
BottomL | Represents field BottomL.
CancelB | Represents field CancelB.
FPage | Represents field FPage.
FReport | Represents field FReport.
FUnits | Represents field FUnits.
FUpdating | Represents field FUpdating.
HeightE | Represents field HeightE.
HeightL | Represents field HeightL.
LandscapeImg | Represents field LandscapeImg.
LandscapeRB | Represents field LandscapeRB.
LeftL | Represents field LeftL.
MarginBottomE | Represents field MarginBottomE.
MarginLeftE | Represents field MarginLeftE.
MarginRightE | Represents field MarginRightE.
MarginsL | Represents field MarginsL.
MarginTopE | Represents field MarginTopE.
OKB | Represents field OKB.
OrientationL | Represents field OrientationL.
OtherL | Represents field OtherL.
PortraitImg | Represents field PortraitImg.
PortraitRB | Represents field PortraitRB.
RightL | Represents field RightL.
SizeCB | Represents field SizeCB.
SizeL | Represents field SizeL.
TopL | Represents field TopL.
UnitL1 | Represents field UnitL1.
UnitL2 | Represents field UnitL2.
UnitL3 | Represents field UnitL3.
UnitL4 | Represents field UnitL4.
UnitL5 | Represents field UnitL5.
UnitL6 | Represents field UnitL6.
WidthE | Represents field WidthE.
WidthL | Represents field WidthL.
Top


TfrxPageSettingsForm.ApplyToAllRB Field

Summary

Represents field ApplyToAllRB.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 ApplyToAllRB: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.ApplyToCurRB Field

Summary

Represents field ApplyToCurRB.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 ApplyToCurRB: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.BottomL Field

Summary

Represents field BottomL.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 BottomL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.CancelB Field

Summary

Represents field CancelB.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 CancelB: TButton;

Field Value

Type: TButton

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.FPage Field

Summary

Represents field FPage.

Namespace: frxPreviewPageSettings
Syntax
Delphi
protected
 FPage: TfrxReportPage;

Field Value

Type: TfrxReportPage

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.FReport Field

Summary

Represents field FReport.

Namespace: frxPreviewPageSettings
Syntax
Delphi
protected
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.FUnits Field

Summary

Represents field FUnits.

Namespace: frxPreviewPageSettings
Syntax
Delphi
protected
 FUnits: TfrxDesignerUnits;

Field Value

Type: TfrxDesignerUnits

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.FUpdating Field

Summary

Represents field FUpdating.

Namespace: frxPreviewPageSettings
Syntax
Delphi
protected
 FUpdating: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.HeightE Field

Summary

Represents field HeightE.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 HeightE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.HeightL Field

Summary

Represents field HeightL.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 HeightL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.LandscapeImg Field

Summary

Represents field LandscapeImg.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 LandscapeImg: TImage;

Field Value

Type: TImage

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.LandscapeRB Field

Summary

Represents field LandscapeRB.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 LandscapeRB: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.LeftL Field

Summary

Represents field LeftL.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 LeftL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.MarginBottomE Field

Summary

Represents field MarginBottomE.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 MarginBottomE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.MarginLeftE Field

Summary

Represents field MarginLeftE.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 MarginLeftE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.MarginRightE Field

Summary

Represents field MarginRightE.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 MarginRightE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.MarginsL Field

Summary

Represents field MarginsL.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 MarginsL: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.MarginTopE Field

Summary

Represents field MarginTopE.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 MarginTopE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.OKB Field

Summary

Represents field OKB.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 OKB: TButton;

Field Value

Type: TButton

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.OrientationL Field

Summary

Represents field OrientationL.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 OrientationL: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.OtherL Field

Summary

Represents field OtherL.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 OtherL: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.PortraitImg Field

Summary

Represents field PortraitImg.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 PortraitImg: TImage;

Field Value

Type: TImage

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.PortraitRB Field

Summary

Represents field PortraitRB.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 PortraitRB: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.RightL Field

Summary

Represents field RightL.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 RightL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.SizeCB Field

Summary

Represents field SizeCB.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 SizeCB: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.SizeL Field

Summary

Represents field SizeL.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 SizeL: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.TopL Field

Summary

Represents field TopL.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 TopL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.UnitL1 Field

Summary

Represents field UnitL1.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 UnitL1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.UnitL2 Field

Summary

Represents field UnitL2.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 UnitL2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.UnitL3 Field

Summary

Represents field UnitL3.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 UnitL3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.UnitL4 Field

Summary

Represents field UnitL4.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 UnitL4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.UnitL5 Field

Summary

Represents field UnitL5.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 UnitL5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.UnitL6 Field

Summary

Represents field UnitL6.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 UnitL6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.WidthE Field

Summary

Represents field WidthE.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 WidthE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


TfrxPageSettingsForm.WidthL Field

Summary

Represents field WidthL.

Namespace: frxPreviewPageSettings
Syntax
Delphi
published
 WidthL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxPageSettingsForm
  • frxPreviewPageSettings


frxPreviewPageSettings Enumerations

Enumerations
Name | Description
TfrxDesignerUnits | Represents type TfrxDesignerUnits.
Top


TfrxDesignerUnits Enumeration

Summary

Represents type TfrxDesignerUnits.

Namespace: frxPreviewPageSettings
Syntax
Delphi
type
 TfrxDesignerUnits = (duCM, duInches, duPixels, duChars);

The TfrxDesignerUnits type exposes the following members.

Members
Show:
Name | Description
duChars | Represents constant duChars.
duCM | Represents constant duCM.
duInches | Represents constant duInches.
duPixels | Represents constant duPixels.
Top
See Also

Reference

  • frxPreviewPageSettings


frxPrinter Namespace

Summary

Represents namespace frxPrinter.

Classes
Name | Description
TfrxCustomPrinter | Represents type TfrxCustomPrinter.
TfrxPrinter | Represents type TfrxPrinter.
TfrxPrinterCanvas | Represents type TfrxPrinterCanvas.
TfrxPrinters | Represents type TfrxPrinters.
TfrxVirtualPrinter | Represents type TfrxVirtualPrinter.
Top
Routines
Name | Description
frxGetPaperDimensions(Integer,Extended,Extended) | Represents method frxGetPaperDimensions(Integer,Extended,Extended).
frxPrinters | Represents method frxPrinters.
Top


frxPrinter Classes

Classes
Name | Description
TfrxCustomPrinter | Represents type TfrxCustomPrinter.
TfrxPrinter | Represents type TfrxPrinter.
TfrxPrinterCanvas | Represents type TfrxPrinterCanvas.
TfrxPrinters | Represents type TfrxPrinters.
TfrxVirtualPrinter | Represents type TfrxVirtualPrinter.
Top


TfrxCustomPrinter Class

Summary

Represents type TfrxCustomPrinter.

Namespace: frxPrinter
Inheritance Hierarchy
TObject
frxPrinter.TfrxCustomPrinter
frxPrinter.TfrxPrinter
frxPrinter.TfrxVirtualPrinter
Syntax
Delphi
type
 TfrxCustomPrinter = class(TObject)
 end;

The TfrxCustomPrinter type exposes the following members.

Constructors
Show:
Name | Description
Create(String,String) | Initializes a new instance of the TfrxCustomPrinter class.
Destroy | Represents the destructor of the TfrxCustomPrinter class.
Top
Properties
Show:
Name | Description
Bin | Represents property Bin.
Bins | Represents property Bins.
BottomMargin | Represents property BottomMargin.
Canvas | Represents property Canvas.
DefBin | Represents property DefBin.
DefDuplex | Represents property DefDuplex.
DefOrientation | Represents property DefOrientation.
DefPaper | Represents property DefPaper.
DefPaperHeight | Represents property DefPaperHeight.
DefPaperWidth | Represents property DefPaperWidth.
DPI | Represents property DPI.
Duplex | Represents property Duplex.
FileName | Represents property FileName.
Handle | Represents property Handle.
Initialized | Represents property Initialized.
LeftMargin | Represents property LeftMargin.
Name | Represents property Name.
Orientation | Represents property Orientation.
Paper | Represents property Paper.
PaperHeight | Represents property PaperHeight.
Papers | Represents property Papers.
PaperWidth | Represents property PaperWidth.
Port | Represents property Port.
RightMargin | Represents property RightMargin.
Title | Represents property Title.
TopMargin | Represents property TopMargin.
Top
Methods
Show:
Name | Description
Abort | Represents method Abort.
BeginDoc | Represents method BeginDoc.
BeginPage | Represents method BeginPage.
BeginRAWDoc | Represents method BeginRAWDoc.
BinIndex(Integer) | Represents method BinIndex(Integer).
BinNameToNumber(String) | Represents method BinNameToNumber(String).
EndDoc | Represents method EndDoc.
EndPage | Represents method EndPage.
EndRAWDoc | Represents method EndRAWDoc.
Init | Represents method Init.
PaperIndex(Integer) | Represents method PaperIndex(Integer).
PaperNameToNumber(String) | Represents method PaperNameToNumber(String).
PropertiesDlg | Represents method PropertiesDlg.
SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer) | Represents method SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer).
SetViewParams(Integer,Extended,Extended,TPrinterOrientation) | Represents method SetViewParams(Integer,Extended,Extended,TPrinterOrientation).
WriteRAWDoc(AnsiString) | Represents method WriteRAWDoc(AnsiString).
Top
Fields
Show:
Name | Description
FBin | Represents field FBin.
FBins | Represents field FBins.
FBottomMargin | Represents field FBottomMargin.
FCanvas | Represents field FCanvas.
FDefBin | Represents field FDefBin.
FDefDuplex | Represents field FDefDuplex.
FDefOrientation | Represents field FDefOrientation.
FDefPaper | Represents field FDefPaper.
FDefPaperHeight | Represents field FDefPaperHeight.
FDefPaperWidth | Represents field FDefPaperWidth.
FDPI | Represents field FDPI.
FDuplex | Represents field FDuplex.
FFileName | Represents field FFileName.
FHandle | Represents field FHandle.
FInitialized | Represents field FInitialized.
FLeftMargin | Represents field FLeftMargin.
FName | Represents field FName.
FOrientation | Represents field FOrientation.
FPaper | Represents field FPaper.
FPaperHeight | Represents field FPaperHeight.
FPapers | Represents field FPapers.
FPaperWidth | Represents field FPaperWidth.
FPort | Represents field FPort.
FPrinting | Represents field FPrinting.
FRightMargin | Represents field FRightMargin.
FTitle | Represents field FTitle.
FTopMargin | Represents field FTopMargin.
Top
See Also

Reference

  • frxPrinter


TfrxCustomPrinter Constructors

Constructors
Name | Description
Create(String,String) | Initializes a new instance of the TfrxCustomPrinter class.
Destroy | Represents the destructor of the TfrxCustomPrinter class.
Top


TfrxCustomPrinter.Create(String,String) Constructor

Summary

Initializes a new instance of the TfrxCustomPrinter class.

Namespace: frxPrinter
Syntax
Delphi
public
 constructor Create(const AName, APort: String); virtual;

Parameters

AName
Type: String

APort
Type: String

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomPrinter class.

Namespace: frxPrinter
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter Properties

Properties
Name | Description
Bin | Represents property Bin.
Bins | Represents property Bins.
BottomMargin | Represents property BottomMargin.
Canvas | Represents property Canvas.
DefBin | Represents property DefBin.
DefDuplex | Represents property DefDuplex.
DefOrientation | Represents property DefOrientation.
DefPaper | Represents property DefPaper.
DefPaperHeight | Represents property DefPaperHeight.
DefPaperWidth | Represents property DefPaperWidth.
DPI | Represents property DPI.
Duplex | Represents property Duplex.
FileName | Represents property FileName.
Handle | Represents property Handle.
Initialized | Represents property Initialized.
LeftMargin | Represents property LeftMargin.
Name | Represents property Name.
Orientation | Represents property Orientation.
Paper | Represents property Paper.
PaperHeight | Represents property PaperHeight.
Papers | Represents property Papers.
PaperWidth | Represents property PaperWidth.
Port | Represents property Port.
RightMargin | Represents property RightMargin.
Title | Represents property Title.
TopMargin | Represents property TopMargin.
Top


TfrxCustomPrinter.Bin Property

Summary

Represents property Bin.

Namespace: frxPrinter
Syntax
Delphi
public
 property Bin: Integer read FBin write FBin;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Bins Property

Summary

Represents property Bins.

Namespace: frxPrinter
Syntax
Delphi
public
 property Bins: TStrings read FBins;

Property Value

Type: TStrings

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.BottomMargin Property

Summary

Represents property BottomMargin.

Namespace: frxPrinter
Syntax
Delphi
public
 property BottomMargin: Extended read FBottomMargin;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Canvas Property

Summary

Represents property Canvas.

Namespace: frxPrinter
Syntax
Delphi
public
 property Canvas: TfrxPrinterCanvas read FCanvas;

Property Value

Type: TfrxPrinterCanvas

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.DefBin Property

Summary

Represents property DefBin.

Namespace: frxPrinter
Syntax
Delphi
public
 property DefBin: Integer read FDefBin;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.DefDuplex Property

Summary

Represents property DefDuplex.

Namespace: frxPrinter
Syntax
Delphi
public
 property DefDuplex: Integer read FDefDuplex;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.DefOrientation Property

Summary

Represents property DefOrientation.

Namespace: frxPrinter
Syntax
Delphi
public
 property DefOrientation: TPrinterOrientation read FDefOrientation;

Property Value

Type: TPrinterOrientation

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.DefPaper Property

Summary

Represents property DefPaper.

Namespace: frxPrinter
Syntax
Delphi
public
 property DefPaper: Integer read FDefPaper;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.DefPaperHeight Property

Summary

Represents property DefPaperHeight.

Namespace: frxPrinter
Syntax
Delphi
public
 property DefPaperHeight: Extended read FDefPaperHeight;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.DefPaperWidth Property

Summary

Represents property DefPaperWidth.

Namespace: frxPrinter
Syntax
Delphi
public
 property DefPaperWidth: Extended read FDefPaperWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.DPI Property

Summary

Represents property DPI.

Namespace: frxPrinter
Syntax
Delphi
public
 property DPI: TPoint read FDPI;

Property Value

Type: TPoint

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Duplex Property

Summary

Represents property Duplex.

Namespace: frxPrinter
Syntax
Delphi
public
 property Duplex: Integer read FDuplex;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FileName Property

Summary

Represents property FileName.

Namespace: frxPrinter
Syntax
Delphi
public
 property FileName: String read FFileName write FFileName;

Property Value

Type: String

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Handle Property

Summary

Represents property Handle.

Namespace: frxPrinter
Syntax
Delphi
public
 property Handle: THandle read FHandle;

Property Value

Type: THandle

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Initialized Property

Summary

Represents property Initialized.

Namespace: frxPrinter
Syntax
Delphi
public
 property Initialized: Boolean read FInitialized;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.LeftMargin Property

Summary

Represents property LeftMargin.

Namespace: frxPrinter
Syntax
Delphi
public
 property LeftMargin: Extended read FLeftMargin;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Name Property

Summary

Represents property Name.

Namespace: frxPrinter
Syntax
Delphi
public
 property Name: String read FName;

Property Value

Type: String

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Orientation Property

Summary

Represents property Orientation.

Namespace: frxPrinter
Syntax
Delphi
public
 property Orientation: TPrinterOrientation read FOrientation;

Property Value

Type: TPrinterOrientation

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Paper Property

Summary

Represents property Paper.

Namespace: frxPrinter
Syntax
Delphi
public
 property Paper: Integer read FPaper;

Property Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.PaperHeight Property

Summary

Represents property PaperHeight.

Namespace: frxPrinter
Syntax
Delphi
public
 property PaperHeight: Extended read FPaperHeight;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Papers Property

Summary

Represents property Papers.

Namespace: frxPrinter
Syntax
Delphi
public
 property Papers: TStrings read FPapers;

Property Value

Type: TStrings

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.PaperWidth Property

Summary

Represents property PaperWidth.

Namespace: frxPrinter
Syntax
Delphi
public
 property PaperWidth: Extended read FPaperWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Port Property

Summary

Represents property Port.

Namespace: frxPrinter
Syntax
Delphi
public
 property Port: String read FPort;

Property Value

Type: String

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.RightMargin Property

Summary

Represents property RightMargin.

Namespace: frxPrinter
Syntax
Delphi
public
 property RightMargin: Extended read FRightMargin;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Title Property

Summary

Represents property Title.

Namespace: frxPrinter
Syntax
Delphi
public
 property Title: String read FTitle write FTitle;

Property Value

Type: String

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.TopMargin Property

Summary

Represents property TopMargin.

Namespace: frxPrinter
Syntax
Delphi
public
 property TopMargin: Extended read FTopMargin;

Property Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter Methods

Methods
Name | Description
Abort | Represents method Abort.
BeginDoc | Represents method BeginDoc.
BeginPage | Represents method BeginPage.
BeginRAWDoc | Represents method BeginRAWDoc.
BinIndex(Integer) | Represents method BinIndex(Integer).
BinNameToNumber(String) | Represents method BinNameToNumber(String).
EndDoc | Represents method EndDoc.
EndPage | Represents method EndPage.
EndRAWDoc | Represents method EndRAWDoc.
Init | Represents method Init.
PaperIndex(Integer) | Represents method PaperIndex(Integer).
PaperNameToNumber(String) | Represents method PaperNameToNumber(String).
PropertiesDlg | Represents method PropertiesDlg.
SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer) | Represents method SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer).
SetViewParams(Integer,Extended,Extended,TPrinterOrientation) | Represents method SetViewParams(Integer,Extended,Extended,TPrinterOrientation).
WriteRAWDoc(AnsiString) | Represents method WriteRAWDoc(AnsiString).
Top


TfrxCustomPrinter.Abort Method

Summary

Represents method Abort.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure Abort; virtual; abstract;
See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.BeginDoc Method

Summary

Represents method BeginDoc.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure BeginDoc; virtual; abstract;
See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.BeginPage Method

Summary

Represents method BeginPage.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure BeginPage; virtual; abstract;
See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.BeginRAWDoc Method

Summary

Represents method BeginRAWDoc.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure BeginRAWDoc; virtual; abstract;
See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.BinIndex(Integer) Method

Summary

Represents method BinIndex(Integer).

Namespace: frxPrinter
Syntax
Delphi
public
 function BinIndex(ABin: Integer): Integer;

Parameters

ABin
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.BinNameToNumber(String) Method

Summary

Represents method BinNameToNumber(String).

Namespace: frxPrinter
Syntax
Delphi
public
 function BinNameToNumber(const ABin: String): Integer;

Parameters

ABin
Type: String

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.EndDoc Method

Summary

Represents method EndDoc.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure EndDoc; virtual; abstract;
See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.EndPage Method

Summary

Represents method EndPage.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure EndPage; virtual; abstract;
See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.EndRAWDoc Method

Summary

Represents method EndRAWDoc.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure EndRAWDoc; virtual; abstract;
See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.Init Method

Summary

Represents method Init.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure Init; virtual; abstract;
See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.PaperIndex(Integer) Method

Summary

Represents method PaperIndex(Integer).

Namespace: frxPrinter
Syntax
Delphi
public
 function PaperIndex(APaper: Integer): Integer;

Parameters

APaper
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.PaperNameToNumber(String) Method

Summary

Represents method PaperNameToNumber(String).

Namespace: frxPrinter
Syntax
Delphi
public
 function PaperNameToNumber(const APaper: String): Integer;

Parameters

APaper
Type: String

Return Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.PropertiesDlg Method

Summary

Represents method PropertiesDlg.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure PropertiesDlg; virtual; abstract;
See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer) Method

Summary

Represents method SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer).

Namespace: frxPrinter
Syntax
Delphi
public
 procedure SetPrintParams(APaperSize: Integer;
 APaperWidth, APaperHeight: Extended; AOrientation: TPrinterOrientation;
 ABin, ADuplex, ACopies: Integer); virtual; abstract;

Parameters

APaperSize
Type: Integer

APaperWidth
Type: Extended

APaperHeight
Type: Extended

AOrientation
Type: TPrinterOrientation

ABin
Type: Integer

ADuplex
Type: Integer

ACopies
Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.SetViewParams(Integer,Extended,Extended,TPrinterOrientation) Method

Summary

Represents method SetViewParams(Integer,Extended,Extended,TPrinterOrientation).

Namespace: frxPrinter
Syntax
Delphi
public
 procedure SetViewParams(APaperSize: Integer;
 APaperWidth, APaperHeight: Extended;
 AOrientation: TPrinterOrientation); virtual; abstract;

Parameters

APaperSize
Type: Integer

APaperWidth
Type: Extended

APaperHeight
Type: Extended

AOrientation
Type: TPrinterOrientation

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.WriteRAWDoc(AnsiString) Method

Summary

Represents method WriteRAWDoc(AnsiString).

Namespace: frxPrinter
Syntax
Delphi
public
 procedure WriteRAWDoc(const buf: AnsiString); virtual; abstract;

Parameters

buf
Type: AnsiString

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter Fields

Fields
Name | Description
FBin | Represents field FBin.
FBins | Represents field FBins.
FBottomMargin | Represents field FBottomMargin.
FCanvas | Represents field FCanvas.
FDefBin | Represents field FDefBin.
FDefDuplex | Represents field FDefDuplex.
FDefOrientation | Represents field FDefOrientation.
FDefPaper | Represents field FDefPaper.
FDefPaperHeight | Represents field FDefPaperHeight.
FDefPaperWidth | Represents field FDefPaperWidth.
FDPI | Represents field FDPI.
FDuplex | Represents field FDuplex.
FFileName | Represents field FFileName.
FHandle | Represents field FHandle.
FInitialized | Represents field FInitialized.
FLeftMargin | Represents field FLeftMargin.
FName | Represents field FName.
FOrientation | Represents field FOrientation.
FPaper | Represents field FPaper.
FPaperHeight | Represents field FPaperHeight.
FPapers | Represents field FPapers.
FPaperWidth | Represents field FPaperWidth.
FPort | Represents field FPort.
FPrinting | Represents field FPrinting.
FRightMargin | Represents field FRightMargin.
FTitle | Represents field FTitle.
FTopMargin | Represents field FTopMargin.
Top


TfrxCustomPrinter.FBin Field

Summary

Represents field FBin.

Namespace: frxPrinter
Syntax
Delphi
private
 FBin: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FBins Field

Summary

Represents field FBins.

Namespace: frxPrinter
Syntax
Delphi
private
 FBins: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FBottomMargin Field

Summary

Represents field FBottomMargin.

Namespace: frxPrinter
Syntax
Delphi
private
 FBottomMargin: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FCanvas Field

Summary

Represents field FCanvas.

Namespace: frxPrinter
Syntax
Delphi
private
 FCanvas: TfrxPrinterCanvas;

Field Value

Type: TfrxPrinterCanvas

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FDefBin Field

Summary

Represents field FDefBin.

Namespace: frxPrinter
Syntax
Delphi
private
 FDefBin: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FDefDuplex Field

Summary

Represents field FDefDuplex.

Namespace: frxPrinter
Syntax
Delphi
private
 FDefDuplex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FDefOrientation Field

Summary

Represents field FDefOrientation.

Namespace: frxPrinter
Syntax
Delphi
private
 FDefOrientation: TPrinterOrientation;

Field Value

Type: TPrinterOrientation

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FDefPaper Field

Summary

Represents field FDefPaper.

Namespace: frxPrinter
Syntax
Delphi
private
 FDefPaper: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FDefPaperHeight Field

Summary

Represents field FDefPaperHeight.

Namespace: frxPrinter
Syntax
Delphi
private
 FDefPaperHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FDefPaperWidth Field

Summary

Represents field FDefPaperWidth.

Namespace: frxPrinter
Syntax
Delphi
private
 FDefPaperWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FDPI Field

Summary

Represents field FDPI.

Namespace: frxPrinter
Syntax
Delphi
private
 FDPI: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FDuplex Field

Summary

Represents field FDuplex.

Namespace: frxPrinter
Syntax
Delphi
private
 FDuplex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FFileName Field

Summary

Represents field FFileName.

Namespace: frxPrinter
Syntax
Delphi
private
 FFileName: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FHandle Field

Summary

Represents field FHandle.

Namespace: frxPrinter
Syntax
Delphi
private
 FHandle: THandle;

Field Value

Type: THandle

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FInitialized Field

Summary

Represents field FInitialized.

Namespace: frxPrinter
Syntax
Delphi
private
 FInitialized: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FLeftMargin Field

Summary

Represents field FLeftMargin.

Namespace: frxPrinter
Syntax
Delphi
private
 FLeftMargin: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FName Field

Summary

Represents field FName.

Namespace: frxPrinter
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FOrientation Field

Summary

Represents field FOrientation.

Namespace: frxPrinter
Syntax
Delphi
private
 FOrientation: TPrinterOrientation;

Field Value

Type: TPrinterOrientation

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FPaper Field

Summary

Represents field FPaper.

Namespace: frxPrinter
Syntax
Delphi
private
 FPaper: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FPaperHeight Field

Summary

Represents field FPaperHeight.

Namespace: frxPrinter
Syntax
Delphi
private
 FPaperHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FPapers Field

Summary

Represents field FPapers.

Namespace: frxPrinter
Syntax
Delphi
private
 FPapers: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FPaperWidth Field

Summary

Represents field FPaperWidth.

Namespace: frxPrinter
Syntax
Delphi
private
 FPaperWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FPort Field

Summary

Represents field FPort.

Namespace: frxPrinter
Syntax
Delphi
private
 FPort: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FPrinting Field

Summary

Represents field FPrinting.

Namespace: frxPrinter
Syntax
Delphi
private
 FPrinting: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FRightMargin Field

Summary

Represents field FRightMargin.

Namespace: frxPrinter
Syntax
Delphi
private
 FRightMargin: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FTitle Field

Summary

Represents field FTitle.

Namespace: frxPrinter
Syntax
Delphi
private
 FTitle: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxCustomPrinter.FTopMargin Field

Summary

Represents field FTopMargin.

Namespace: frxPrinter
Syntax
Delphi
private
 FTopMargin: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxCustomPrinter
  • frxPrinter


TfrxPrinter Class

Summary

Represents type TfrxPrinter.

Namespace: frxPrinter
Inheritance Hierarchy
TObject
frxPrinter.TfrxCustomPrinter
frxPrinter.TfrxPrinter
Syntax
Delphi
type
 TfrxPrinter = class(TfrxCustomPrinter)
 end;

The TfrxPrinter type exposes the following members.

Constructors
Show:
Name | Description
Create(String,String) | Initializes a new instance of the TfrxCustomPrinter class. (Inherited from TfrxCustomPrinter.)
Destroy | Represents the destructor of the TfrxPrinter class. (Overrides TfrxCustomPrinter.Destroy.)
Top
Properties
Show:
Name | Description
Bin | Represents property Bin. (Inherited from TfrxCustomPrinter.)
Bins | Represents property Bins. (Inherited from TfrxCustomPrinter.)
BottomMargin | Represents property BottomMargin. (Inherited from TfrxCustomPrinter.)
Canvas | Represents property Canvas. (Inherited from TfrxCustomPrinter.)
DefBin | Represents property DefBin. (Inherited from TfrxCustomPrinter.)
DefDuplex | Represents property DefDuplex. (Inherited from TfrxCustomPrinter.)
DefOrientation | Represents property DefOrientation. (Inherited from TfrxCustomPrinter.)
DefPaper | Represents property DefPaper. (Inherited from TfrxCustomPrinter.)
DefPaperHeight | Represents property DefPaperHeight. (Inherited from TfrxCustomPrinter.)
DefPaperWidth | Represents property DefPaperWidth. (Inherited from TfrxCustomPrinter.)
DeviceMode | Represents property DeviceMode.
DPI | Represents property DPI. (Inherited from TfrxCustomPrinter.)
Duplex | Represents property Duplex. (Inherited from TfrxCustomPrinter.)
FileName | Represents property FileName. (Inherited from TfrxCustomPrinter.)
Handle | Represents property Handle. (Inherited from TfrxCustomPrinter.)
Initialized | Represents property Initialized. (Inherited from TfrxCustomPrinter.)
LeftMargin | Represents property LeftMargin. (Inherited from TfrxCustomPrinter.)
Name | Represents property Name. (Inherited from TfrxCustomPrinter.)
Orientation | Represents property Orientation. (Inherited from TfrxCustomPrinter.)
Paper | Represents property Paper. (Inherited from TfrxCustomPrinter.)
PaperHeight | Represents property PaperHeight. (Inherited from TfrxCustomPrinter.)
Papers | Represents property Papers. (Inherited from TfrxCustomPrinter.)
PaperWidth | Represents property PaperWidth. (Inherited from TfrxCustomPrinter.)
Port | Represents property Port. (Inherited from TfrxCustomPrinter.)
RightMargin | Represents property RightMargin. (Inherited from TfrxCustomPrinter.)
Title | Represents property Title. (Inherited from TfrxCustomPrinter.)
TopMargin | Represents property TopMargin. (Inherited from TfrxCustomPrinter.)
Top
Methods
Show:
Name | Description
Abort | Represents method Abort. (Overrides TfrxCustomPrinter.Abort.)
BeginDoc | Represents method BeginDoc. (Overrides TfrxCustomPrinter.BeginDoc.)
BeginPage | Represents method BeginPage. (Overrides TfrxCustomPrinter.BeginPage.)
BeginRAWDoc | Represents method BeginRAWDoc. (Overrides TfrxCustomPrinter.BeginRAWDoc.)
BinIndex(Integer) | Represents method BinIndex(Integer). (Inherited from TfrxCustomPrinter.)
BinNameToNumber(String) | Represents method BinNameToNumber(String). (Inherited from TfrxCustomPrinter.)
CreateDevMode | Represents method CreateDevMode.
EndDoc | Represents method EndDoc. (Overrides TfrxCustomPrinter.EndDoc.)
EndPage | Represents method EndPage. (Overrides TfrxCustomPrinter.EndPage.)
EndRAWDoc | Represents method EndRAWDoc. (Overrides TfrxCustomPrinter.EndRAWDoc.)
FreeDevMode | Represents method FreeDevMode.
GetDC | Represents method GetDC.
Init | Represents method Init. (Overrides TfrxCustomPrinter.Init.)
PaperIndex(Integer) | Represents method PaperIndex(Integer). (Inherited from TfrxCustomPrinter.)
PaperNameToNumber(String) | Represents method PaperNameToNumber(String). (Inherited from TfrxCustomPrinter.)
PropertiesDlg | Represents method PropertiesDlg. (Overrides TfrxCustomPrinter.PropertiesDlg.)
RecreateDC | Represents method RecreateDC.
SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer) | Represents method SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer). (Overrides TfrxCustomPrinter.SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer).)
SetViewParams(Integer,Extended,Extended,TPrinterOrientation) | Represents method SetViewParams(Integer,Extended,Extended,TPrinterOrientation). (Overrides TfrxCustomPrinter.SetViewParams(Integer,Extended,Extended,TPrinterOrientation).)
UpdateDeviceCaps | Represents method UpdateDeviceCaps.
WriteRAWDoc(AnsiString) | Represents method WriteRAWDoc(AnsiString). (Overrides TfrxCustomPrinter.WriteRAWDoc(AnsiString).)
Top
Fields
Show:
Name | Description
FDC | Represents field FDC.
FDeviceMode | Represents field FDeviceMode.
FDriver | Represents field FDriver.
FMode | Represents field FMode.
Top
See Also

Reference

  • frxPrinter


TfrxPrinter Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TfrxPrinter class. (Overrides TfrxCustomPrinter.Destroy.)
Top


TfrxPrinter.Destroy Destructor

Summary

Represents the destructor of the TfrxPrinter class.

Namespace: frxPrinter
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxCustomPrinter.Destroy
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter Properties

Properties
Name | Description
DeviceMode | Represents property DeviceMode.
Top


TfrxPrinter.DeviceMode Property

Summary

Represents property DeviceMode.

Namespace: frxPrinter
Syntax
Delphi
public
 property DeviceMode: PDeviceMode read FMode;

Property Value

Type: PDeviceMode

See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter Methods

Methods
Name | Description
Abort | Represents method Abort. (Overrides TfrxCustomPrinter.Abort.)
BeginDoc | Represents method BeginDoc. (Overrides TfrxCustomPrinter.BeginDoc.)
BeginPage | Represents method BeginPage. (Overrides TfrxCustomPrinter.BeginPage.)
BeginRAWDoc | Represents method BeginRAWDoc. (Overrides TfrxCustomPrinter.BeginRAWDoc.)
CreateDevMode | Represents method CreateDevMode.
EndDoc | Represents method EndDoc. (Overrides TfrxCustomPrinter.EndDoc.)
EndPage | Represents method EndPage. (Overrides TfrxCustomPrinter.EndPage.)
EndRAWDoc | Represents method EndRAWDoc. (Overrides TfrxCustomPrinter.EndRAWDoc.)
FreeDevMode | Represents method FreeDevMode.
GetDC | Represents method GetDC.
Init | Represents method Init. (Overrides TfrxCustomPrinter.Init.)
PropertiesDlg | Represents method PropertiesDlg. (Overrides TfrxCustomPrinter.PropertiesDlg.)
RecreateDC | Represents method RecreateDC.
SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer) | Represents method SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer). (Overrides TfrxCustomPrinter.SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer).)
SetViewParams(Integer,Extended,Extended,TPrinterOrientation) | Represents method SetViewParams(Integer,Extended,Extended,TPrinterOrientation). (Overrides TfrxCustomPrinter.SetViewParams(Integer,Extended,Extended,TPrinterOrientation).)
UpdateDeviceCaps | Represents method UpdateDeviceCaps.
WriteRAWDoc(AnsiString) | Represents method WriteRAWDoc(AnsiString). (Overrides TfrxCustomPrinter.WriteRAWDoc(AnsiString).)
Top


TfrxPrinter.Abort Method

Summary

Represents method Abort.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure Abort; override;

Overrides

TfrxCustomPrinter.Abort
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.BeginDoc Method

Summary

Represents method BeginDoc.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure BeginDoc; override;

Overrides

TfrxCustomPrinter.BeginDoc
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.BeginPage Method

Summary

Represents method BeginPage.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure BeginPage; override;

Overrides

TfrxCustomPrinter.BeginPage
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.BeginRAWDoc Method

Summary

Represents method BeginRAWDoc.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure BeginRAWDoc; override;

Overrides

TfrxCustomPrinter.BeginRAWDoc
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.CreateDevMode Method

Summary

Represents method CreateDevMode.

Namespace: frxPrinter
Syntax
Delphi
private
 procedure CreateDevMode;
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.EndDoc Method

Summary

Represents method EndDoc.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure EndDoc; override;

Overrides

TfrxCustomPrinter.EndDoc
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.EndPage Method

Summary

Represents method EndPage.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure EndPage; override;

Overrides

TfrxCustomPrinter.EndPage
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.EndRAWDoc Method

Summary

Represents method EndRAWDoc.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure EndRAWDoc; override;

Overrides

TfrxCustomPrinter.EndRAWDoc
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.FreeDevMode Method

Summary

Represents method FreeDevMode.

Namespace: frxPrinter
Syntax
Delphi
private
 procedure FreeDevMode;
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.GetDC Method

Summary

Represents method GetDC.

Namespace: frxPrinter
Syntax
Delphi
private
 procedure GetDC;
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.Init Method

Summary

Represents method Init.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure Init; override;

Overrides

TfrxCustomPrinter.Init
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.PropertiesDlg Method

Summary

Represents method PropertiesDlg.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure PropertiesDlg; override;

Overrides

TfrxCustomPrinter.PropertiesDlg
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.RecreateDC Method

Summary

Represents method RecreateDC.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure RecreateDC;
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer) Method

Summary

Represents method SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer).

Namespace: frxPrinter
Syntax
Delphi
public
 procedure SetPrintParams(APaperSize: Integer;
 APaperWidth, APaperHeight: Extended; AOrientation: TPrinterOrientation;
 ABin, ADuplex, ACopies: Integer); override;

Parameters

APaperSize
Type: Integer

APaperWidth
Type: Extended

APaperHeight
Type: Extended

AOrientation
Type: TPrinterOrientation

ABin
Type: Integer

ADuplex
Type: Integer

ACopies
Type: Integer

Overrides

TfrxCustomPrinter.SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer)
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.SetViewParams(Integer,Extended,Extended,TPrinterOrientation) Method

Summary

Represents method SetViewParams(Integer,Extended,Extended,TPrinterOrientation).

Namespace: frxPrinter
Syntax
Delphi
public
 procedure SetViewParams(APaperSize: Integer;
 APaperWidth, APaperHeight: Extended;
 AOrientation: TPrinterOrientation); override;

Parameters

APaperSize
Type: Integer

APaperWidth
Type: Extended

APaperHeight
Type: Extended

AOrientation
Type: TPrinterOrientation

Overrides

TfrxCustomPrinter.SetViewParams(Integer,Extended,Extended,TPrinterOrientation)
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.UpdateDeviceCaps Method

Summary

Represents method UpdateDeviceCaps.

Namespace: frxPrinter
Syntax
Delphi
public
 function UpdateDeviceCaps: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.WriteRAWDoc(AnsiString) Method

Summary

Represents method WriteRAWDoc(AnsiString).

Namespace: frxPrinter
Syntax
Delphi
public
 procedure WriteRAWDoc(const buf: AnsiString); override;

Parameters

buf
Type: AnsiString

Overrides

TfrxCustomPrinter.WriteRAWDoc(AnsiString)
See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter Fields

Fields
Name | Description
FDC | Represents field FDC.
FDeviceMode | Represents field FDeviceMode.
FDriver | Represents field FDriver.
FMode | Represents field FMode.
Top


TfrxPrinter.FDC Field

Summary

Represents field FDC.

Namespace: frxPrinter
Syntax
Delphi
private
 FDC: HDC;

Field Value

Type: HDC

See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.FDeviceMode Field

Summary

Represents field FDeviceMode.

Namespace: frxPrinter
Syntax
Delphi
private
 FDeviceMode: THandle;

Field Value

Type: THandle

See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.FDriver Field

Summary

Represents field FDriver.

Namespace: frxPrinter
Syntax
Delphi
private
 FDriver: String;

Field Value

Type: String

See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinter.FMode Field

Summary

Represents field FMode.

Namespace: frxPrinter
Syntax
Delphi
private
 FMode: PDeviceMode;

Field Value

Type: PDeviceMode

See Also

Reference

  • TfrxPrinter
  • frxPrinter


TfrxPrinterCanvas Class

Summary

Represents type TfrxPrinterCanvas.

Namespace: frxPrinter
Inheritance Hierarchy
TCanvas
frxPrinter.TfrxPrinterCanvas
Syntax
Delphi
type
 TfrxPrinterCanvas = class(TCanvas)
 end;

The TfrxPrinterCanvas type exposes the following members.

Methods
Show:
Name | Description
Changing | Represents method Changing.
UpdateFont | Represents method UpdateFont.
Top
Fields
Show:
Name | Description
FPrinter | Represents field FPrinter.
Top
See Also

Reference

  • frxPrinter


TfrxPrinterCanvas Methods

Methods
Name | Description
Changing | Represents method Changing.
UpdateFont | Represents method UpdateFont.
Top


TfrxPrinterCanvas.Changing Method

Summary

Represents method Changing.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure Changing; override;
See Also

Reference

  • TfrxPrinterCanvas
  • frxPrinter


TfrxPrinterCanvas.UpdateFont Method

Summary

Represents method UpdateFont.

Namespace: frxPrinter
Syntax
Delphi
private
 procedure UpdateFont;
See Also

Reference

  • TfrxPrinterCanvas
  • frxPrinter


TfrxPrinterCanvas Fields

Fields
Name | Description
FPrinter | Represents field FPrinter.
Top


TfrxPrinterCanvas.FPrinter Field

Summary

Represents field FPrinter.

Namespace: frxPrinter
Syntax
Delphi
private
 FPrinter: TfrxCustomPrinter;

Field Value

Type: TfrxCustomPrinter

See Also

Reference

  • TfrxPrinterCanvas
  • frxPrinter


TfrxPrinters Class

Summary

Represents type TfrxPrinters.

Namespace: frxPrinter
Inheritance Hierarchy
TObject
frxPrinter.TfrxPrinters
Syntax
Delphi
type
 TfrxPrinters = class(TObject)
 end;

The TfrxPrinters type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxPrinters class.
Destroy | Represents the destructor of the TfrxPrinters class.
Top
Properties
Show:
Name | Description
HasPhysicalPrinters | Represents property HasPhysicalPrinters.
Items[Integer] | Represents property Items[Integer].
Printer | Represents property Printer.
PrinterIndex | Represents property PrinterIndex.
Printers | Represents property Printers.
Top
Methods
Show:
Name | Description
Clear | Represents method Clear.
FillPrinters | Represents method FillPrinters.
GetCurrentPrinter | Represents method GetCurrentPrinter.
GetDefaultPrinter | Represents method GetDefaultPrinter.
GetItem(Integer) | Represents method GetItem(Integer).
IndexOf(String) | Represents method IndexOf(String).
SetPrinterIndex(Integer) | Represents method SetPrinterIndex(Integer).
Top
Fields
Show:
Name | Description
FHasPhysicalPrinters | Represents field FHasPhysicalPrinters.
FPrinterIndex | Represents field FPrinterIndex.
FPrinterList | Represents field FPrinterList.
FPrinters | Represents field FPrinters.
Top
See Also

Reference

  • frxPrinter


TfrxPrinters Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxPrinters class.
Destroy | Represents the destructor of the TfrxPrinters class.
Top


TfrxPrinters.Create Constructor

Summary

Initializes a new instance of the TfrxPrinters class.

Namespace: frxPrinter
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.Destroy Destructor

Summary

Represents the destructor of the TfrxPrinters class.

Namespace: frxPrinter
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters Properties

Properties
Name | Description
HasPhysicalPrinters | Represents property HasPhysicalPrinters.
Items[Integer] | Represents property Items[Integer].
Printer | Represents property Printer.
PrinterIndex | Represents property PrinterIndex.
Printers | Represents property Printers.
Top


TfrxPrinters.HasPhysicalPrinters Property

Summary

Represents property HasPhysicalPrinters.

Namespace: frxPrinter
Syntax
Delphi
public
 property HasPhysicalPrinters: Boolean read FHasPhysicalPrinters;

Property Value

Type: Boolean

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxPrinter
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxCustomPrinter read GetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCustomPrinter

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.Printer Property

Summary

Represents property Printer.

Namespace: frxPrinter
Syntax
Delphi
public
 property Printer: TfrxCustomPrinter read GetCurrentPrinter;

Property Value

Type: TfrxCustomPrinter

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.PrinterIndex Property

Summary

Represents property PrinterIndex.

Namespace: frxPrinter
Syntax
Delphi
public
 property PrinterIndex: Integer read FPrinterIndex write SetPrinterIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.Printers Property

Summary

Represents property Printers.

Namespace: frxPrinter
Syntax
Delphi
public
 property Printers: TStrings read FPrinters;

Property Value

Type: TStrings

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters Methods

Methods
Name | Description
Clear | Represents method Clear.
FillPrinters | Represents method FillPrinters.
GetCurrentPrinter | Represents method GetCurrentPrinter.
GetDefaultPrinter | Represents method GetDefaultPrinter.
GetItem(Integer) | Represents method GetItem(Integer).
IndexOf(String) | Represents method IndexOf(String).
SetPrinterIndex(Integer) | Represents method SetPrinterIndex(Integer).
Top


TfrxPrinters.Clear Method

Summary

Represents method Clear.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.FillPrinters Method

Summary

Represents method FillPrinters.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure FillPrinters;
See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.GetCurrentPrinter Method

Summary

Represents method GetCurrentPrinter.

Namespace: frxPrinter
Syntax
Delphi
private
 function GetCurrentPrinter: TfrxCustomPrinter;

Return Value

Type: TfrxCustomPrinter

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.GetDefaultPrinter Method

Summary

Represents method GetDefaultPrinter.

Namespace: frxPrinter
Syntax
Delphi
private
 function GetDefaultPrinter: String;

Return Value

Type: String

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxPrinter
Syntax
Delphi
private
 function GetItem(Index: Integer): TfrxCustomPrinter;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCustomPrinter

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.IndexOf(String) Method

Summary

Represents method IndexOf(String).

Namespace: frxPrinter
Syntax
Delphi
public
 function IndexOf(AName: String): Integer;

Parameters

AName
Type: String

Return Value

Type: Integer

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.SetPrinterIndex(Integer) Method

Summary

Represents method SetPrinterIndex(Integer).

Namespace: frxPrinter
Syntax
Delphi
private
 procedure SetPrinterIndex(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters Fields

Fields
Name | Description
FHasPhysicalPrinters | Represents field FHasPhysicalPrinters.
FPrinterIndex | Represents field FPrinterIndex.
FPrinterList | Represents field FPrinterList.
FPrinters | Represents field FPrinters.
Top


TfrxPrinters.FHasPhysicalPrinters Field

Summary

Represents field FHasPhysicalPrinters.

Namespace: frxPrinter
Syntax
Delphi
private
 FHasPhysicalPrinters: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.FPrinterIndex Field

Summary

Represents field FPrinterIndex.

Namespace: frxPrinter
Syntax
Delphi
private
 FPrinterIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.FPrinterList Field

Summary

Represents field FPrinterList.

Namespace: frxPrinter
Syntax
Delphi
private
 FPrinterList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxPrinters.FPrinters Field

Summary

Represents field FPrinters.

Namespace: frxPrinter
Syntax
Delphi
private
 FPrinters: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxPrinters
  • frxPrinter


TfrxVirtualPrinter Class

Summary

Represents type TfrxVirtualPrinter.

Namespace: frxPrinter
Inheritance Hierarchy
TObject
frxPrinter.TfrxCustomPrinter
frxPrinter.TfrxVirtualPrinter
Syntax
Delphi
type
 TfrxVirtualPrinter = class(TfrxCustomPrinter)
 end;

The TfrxVirtualPrinter type exposes the following members.

Constructors
Show:
Name | Description
Create(String,String) | Initializes a new instance of the TfrxCustomPrinter class. (Inherited from TfrxCustomPrinter.)
Top
Properties
Show:
Name | Description
Bin | Represents property Bin. (Inherited from TfrxCustomPrinter.)
Bins | Represents property Bins. (Inherited from TfrxCustomPrinter.)
BottomMargin | Represents property BottomMargin. (Inherited from TfrxCustomPrinter.)
Canvas | Represents property Canvas. (Inherited from TfrxCustomPrinter.)
DefBin | Represents property DefBin. (Inherited from TfrxCustomPrinter.)
DefDuplex | Represents property DefDuplex. (Inherited from TfrxCustomPrinter.)
DefOrientation | Represents property DefOrientation. (Inherited from TfrxCustomPrinter.)
DefPaper | Represents property DefPaper. (Inherited from TfrxCustomPrinter.)
DefPaperHeight | Represents property DefPaperHeight. (Inherited from TfrxCustomPrinter.)
DefPaperWidth | Represents property DefPaperWidth. (Inherited from TfrxCustomPrinter.)
DPI | Represents property DPI. (Inherited from TfrxCustomPrinter.)
Duplex | Represents property Duplex. (Inherited from TfrxCustomPrinter.)
FileName | Represents property FileName. (Inherited from TfrxCustomPrinter.)
Handle | Represents property Handle. (Inherited from TfrxCustomPrinter.)
Initialized | Represents property Initialized. (Inherited from TfrxCustomPrinter.)
LeftMargin | Represents property LeftMargin. (Inherited from TfrxCustomPrinter.)
Name | Represents property Name. (Inherited from TfrxCustomPrinter.)
Orientation | Represents property Orientation. (Inherited from TfrxCustomPrinter.)
Paper | Represents property Paper. (Inherited from TfrxCustomPrinter.)
PaperHeight | Represents property PaperHeight. (Inherited from TfrxCustomPrinter.)
Papers | Represents property Papers. (Inherited from TfrxCustomPrinter.)
PaperWidth | Represents property PaperWidth. (Inherited from TfrxCustomPrinter.)
Port | Represents property Port. (Inherited from TfrxCustomPrinter.)
RightMargin | Represents property RightMargin. (Inherited from TfrxCustomPrinter.)
Title | Represents property Title. (Inherited from TfrxCustomPrinter.)
TopMargin | Represents property TopMargin. (Inherited from TfrxCustomPrinter.)
Top
Methods
Show:
Name | Description
Abort | Represents method Abort. (Overrides TfrxCustomPrinter.Abort.)
BeginDoc | Represents method BeginDoc. (Overrides TfrxCustomPrinter.BeginDoc.)
BeginPage | Represents method BeginPage. (Overrides TfrxCustomPrinter.BeginPage.)
BeginRAWDoc | Represents method BeginRAWDoc. (Overrides TfrxCustomPrinter.BeginRAWDoc.)
BinIndex(Integer) | Represents method BinIndex(Integer). (Inherited from TfrxCustomPrinter.)
BinNameToNumber(String) | Represents method BinNameToNumber(String). (Inherited from TfrxCustomPrinter.)
EndDoc | Represents method EndDoc. (Overrides TfrxCustomPrinter.EndDoc.)
EndPage | Represents method EndPage. (Overrides TfrxCustomPrinter.EndPage.)
EndRAWDoc | Represents method EndRAWDoc. (Overrides TfrxCustomPrinter.EndRAWDoc.)
Init | Represents method Init. (Overrides TfrxCustomPrinter.Init.)
PaperIndex(Integer) | Represents method PaperIndex(Integer). (Inherited from TfrxCustomPrinter.)
PaperNameToNumber(String) | Represents method PaperNameToNumber(String). (Inherited from TfrxCustomPrinter.)
PropertiesDlg | Represents method PropertiesDlg. (Overrides TfrxCustomPrinter.PropertiesDlg.)
SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer) | Represents method SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer). (Overrides TfrxCustomPrinter.SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer).)
SetViewParams(Integer,Extended,Extended,TPrinterOrientation) | Represents method SetViewParams(Integer,Extended,Extended,TPrinterOrientation). (Overrides TfrxCustomPrinter.SetViewParams(Integer,Extended,Extended,TPrinterOrientation).)
WriteRAWDoc(AnsiString) | Represents method WriteRAWDoc(AnsiString). (Overrides TfrxCustomPrinter.WriteRAWDoc(AnsiString).)
Top
See Also

Reference

  • frxPrinter


TfrxVirtualPrinter Methods

Methods
Name | Description
Abort | Represents method Abort. (Overrides TfrxCustomPrinter.Abort.)
BeginDoc | Represents method BeginDoc. (Overrides TfrxCustomPrinter.BeginDoc.)
BeginPage | Represents method BeginPage. (Overrides TfrxCustomPrinter.BeginPage.)
BeginRAWDoc | Represents method BeginRAWDoc. (Overrides TfrxCustomPrinter.BeginRAWDoc.)
EndDoc | Represents method EndDoc. (Overrides TfrxCustomPrinter.EndDoc.)
EndPage | Represents method EndPage. (Overrides TfrxCustomPrinter.EndPage.)
EndRAWDoc | Represents method EndRAWDoc. (Overrides TfrxCustomPrinter.EndRAWDoc.)
Init | Represents method Init. (Overrides TfrxCustomPrinter.Init.)
PropertiesDlg | Represents method PropertiesDlg. (Overrides TfrxCustomPrinter.PropertiesDlg.)
SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer) | Represents method SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer). (Overrides TfrxCustomPrinter.SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer).)
SetViewParams(Integer,Extended,Extended,TPrinterOrientation) | Represents method SetViewParams(Integer,Extended,Extended,TPrinterOrientation). (Overrides TfrxCustomPrinter.SetViewParams(Integer,Extended,Extended,TPrinterOrientation).)
WriteRAWDoc(AnsiString) | Represents method WriteRAWDoc(AnsiString). (Overrides TfrxCustomPrinter.WriteRAWDoc(AnsiString).)
Top


TfrxVirtualPrinter.Abort Method

Summary

Represents method Abort.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure Abort; override;

Overrides

TfrxCustomPrinter.Abort
See Also

Reference

  • TfrxVirtualPrinter
  • frxPrinter


TfrxVirtualPrinter.BeginDoc Method

Summary

Represents method BeginDoc.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure BeginDoc; override;

Overrides

TfrxCustomPrinter.BeginDoc
See Also

Reference

  • TfrxVirtualPrinter
  • frxPrinter


TfrxVirtualPrinter.BeginPage Method

Summary

Represents method BeginPage.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure BeginPage; override;

Overrides

TfrxCustomPrinter.BeginPage
See Also

Reference

  • TfrxVirtualPrinter
  • frxPrinter


TfrxVirtualPrinter.BeginRAWDoc Method

Summary

Represents method BeginRAWDoc.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure BeginRAWDoc; override;

Overrides

TfrxCustomPrinter.BeginRAWDoc
See Also

Reference

  • TfrxVirtualPrinter
  • frxPrinter


TfrxVirtualPrinter.EndDoc Method

Summary

Represents method EndDoc.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure EndDoc; override;

Overrides

TfrxCustomPrinter.EndDoc
See Also

Reference

  • TfrxVirtualPrinter
  • frxPrinter


TfrxVirtualPrinter.EndPage Method

Summary

Represents method EndPage.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure EndPage; override;

Overrides

TfrxCustomPrinter.EndPage
See Also

Reference

  • TfrxVirtualPrinter
  • frxPrinter


TfrxVirtualPrinter.EndRAWDoc Method

Summary

Represents method EndRAWDoc.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure EndRAWDoc; override;

Overrides

TfrxCustomPrinter.EndRAWDoc
See Also

Reference

  • TfrxVirtualPrinter
  • frxPrinter


TfrxVirtualPrinter.Init Method

Summary

Represents method Init.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure Init; override;

Overrides

TfrxCustomPrinter.Init
See Also

Reference

  • TfrxVirtualPrinter
  • frxPrinter


TfrxVirtualPrinter.PropertiesDlg Method

Summary

Represents method PropertiesDlg.

Namespace: frxPrinter
Syntax
Delphi
public
 procedure PropertiesDlg; override;

Overrides

TfrxCustomPrinter.PropertiesDlg
See Also

Reference

  • TfrxVirtualPrinter
  • frxPrinter


TfrxVirtualPrinter.SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer) Method

Summary

Represents method SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer).

Namespace: frxPrinter
Syntax
Delphi
public
 procedure SetPrintParams(APaperSize: Integer;
 APaperWidth, APaperHeight: Extended; AOrientation: TPrinterOrientation;
 ABin, ADuplex, ACopies: Integer); override;

Parameters

APaperSize
Type: Integer

APaperWidth
Type: Extended

APaperHeight
Type: Extended

AOrientation
Type: TPrinterOrientation

ABin
Type: Integer

ADuplex
Type: Integer

ACopies
Type: Integer

Overrides

TfrxCustomPrinter.SetPrintParams(Integer,Extended,Extended,TPrinterOrientation,Integer,Integer,Integer)
See Also

Reference

  • TfrxVirtualPrinter
  • frxPrinter


TfrxVirtualPrinter.SetViewParams(Integer,Extended,Extended,TPrinterOrientation) Method

Summary

Represents method SetViewParams(Integer,Extended,Extended,TPrinterOrientation).

Namespace: frxPrinter
Syntax
Delphi
public
 procedure SetViewParams(APaperSize: Integer;
 APaperWidth, APaperHeight: Extended;
 AOrientation: TPrinterOrientation); override;

Parameters

APaperSize
Type: Integer

APaperWidth
Type: Extended

APaperHeight
Type: Extended

AOrientation
Type: TPrinterOrientation

Overrides

TfrxCustomPrinter.SetViewParams(Integer,Extended,Extended,TPrinterOrientation)
See Also

Reference

  • TfrxVirtualPrinter
  • frxPrinter


TfrxVirtualPrinter.WriteRAWDoc(AnsiString) Method

Summary

Represents method WriteRAWDoc(AnsiString).

Namespace: frxPrinter
Syntax
Delphi
public
 procedure WriteRAWDoc(const buf: AnsiString); override;

Parameters

buf
Type: AnsiString

Overrides

TfrxCustomPrinter.WriteRAWDoc(AnsiString)
See Also

Reference

  • TfrxVirtualPrinter
  • frxPrinter


frxPrinter Routines

Routines
Name | Description
frxGetPaperDimensions(Integer,Extended,Extended) | Represents method frxGetPaperDimensions(Integer,Extended,Extended).
frxPrinters | Represents method frxPrinters.
Top


frxGetPaperDimensions(Integer,Extended,Extended) Method

Summary

Represents method frxGetPaperDimensions(Integer,Extended,Extended).

Namespace: frxPrinter
Syntax
Delphi
function frxGetPaperDimensions(PaperSize: Integer; var Width, Height: Extended): Boolean;

Parameters

PaperSize
Type: Integer

Width
Type: Extended

Height
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • frxPrinter


frxPrinters Method

Summary

Represents method frxPrinters.

Namespace: frxPrinter
Syntax
Delphi
function frxPrinters: TfrxPrinters;

Return Value

Type: TfrxPrinters

See Also

Reference

  • frxPrinter


frxQRCodeSwissPreset Namespace

Summary

Represents namespace frxQRCodeSwissPreset.

Classes
Name | Description
TfrxCustomPresetAttr | Represents type TfrxCustomPresetAttr.
TfrxSPAdditionalInformation | Represents type TfrxSPAdditionalInformation.
TfrxSPAlternativeSchemes | Represents type TfrxSPAlternativeSchemes.
TfrxSPCreditor | Represents type TfrxSPCreditor.
TfrxSPCreditorInformation | Represents type TfrxSPCreditorInformation.
TfrxSPPaymentAmountInfo | Represents type TfrxSPPaymentAmountInfo.
TfrxSPPaymentReference | Represents type TfrxSPPaymentReference.
TfrxSPPersonInfo | Represents type TfrxSPPersonInfo.
TfrxSPUltimateCreditor | Represents type TfrxSPUltimateCreditor.
TfrxSPUltimateDebtor | Represents type TfrxSPUltimateDebtor.
TfrxSPUltimateInfo | Represents type TfrxSPUltimateInfo.
TfrxSwissPaymentPreset | Represents type TfrxSwissPaymentPreset.
Top
Enumerations
Name | Description
TfrxSPAddressType | Represents type TfrxSPAddressType.
TfrxSPReferenceType | Represents type TfrxSPReferenceType.
Top


frxQRCodeSwissPreset Classes

Classes
Name | Description
TfrxCustomPresetAttr | Represents type TfrxCustomPresetAttr.
TfrxSPAdditionalInformation | Represents type TfrxSPAdditionalInformation.
TfrxSPAlternativeSchemes | Represents type TfrxSPAlternativeSchemes.
TfrxSPCreditor | Represents type TfrxSPCreditor.
TfrxSPCreditorInformation | Represents type TfrxSPCreditorInformation.
TfrxSPPaymentAmountInfo | Represents type TfrxSPPaymentAmountInfo.
TfrxSPPaymentReference | Represents type TfrxSPPaymentReference.
TfrxSPPersonInfo | Represents type TfrxSPPersonInfo.
TfrxSPUltimateCreditor | Represents type TfrxSPUltimateCreditor.
TfrxSPUltimateDebtor | Represents type TfrxSPUltimateDebtor.
TfrxSPUltimateInfo | Represents type TfrxSPUltimateInfo.
TfrxSwissPaymentPreset | Represents type TfrxSwissPaymentPreset.
Top


TfrxCustomPresetAttr Class

Summary

Represents type TfrxCustomPresetAttr.

Namespace: frxQRCodeSwissPreset
Inheritance Hierarchy
TPersistent
frxQRCodeSwissPreset.TfrxCustomPresetAttr
frxQRCodeSwissPreset.TfrxSPAdditionalInformation
frxQRCodeSwissPreset.TfrxSPAlternativeSchemes
frxQRCodeSwissPreset.TfrxSPCreditorInformation
frxQRCodeSwissPreset.TfrxSPPaymentAmountInfo
frxQRCodeSwissPreset.TfrxSPPaymentReference
frxQRCodeSwissPreset.TfrxSPPersonInfo
Syntax
Delphi
type
 TfrxCustomPresetAttr = class(TPersistent)
 end;

The TfrxCustomPresetAttr type exposes the following members.

Methods
Show:
Name | Description
GetData(TfrxReport) | Represents method GetData(TfrxReport).
GetValue(TfrxReport,String) | Represents method GetValue(TfrxReport,String).
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxCustomPresetAttr Methods

Methods
Name | Description
GetData(TfrxReport) | Represents method GetData(TfrxReport).
GetValue(TfrxReport,String) | Represents method GetValue(TfrxReport,String).
Top


TfrxCustomPresetAttr.GetData(TfrxReport) Method

Summary

Represents method GetData(TfrxReport).

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 function GetData(aReport: TfrxReport): String; virtual; abstract;

Parameters

aReport
Type: TfrxReport

Return Value

Type: String

See Also

Reference

  • TfrxCustomPresetAttr
  • frxQRCodeSwissPreset


TfrxCustomPresetAttr.GetValue(TfrxReport,String) Method

Summary

Represents method GetValue(TfrxReport,String).

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 function GetValue(aReport: TfrxReport; const aFileld: String): String;

Parameters

aReport
Type: TfrxReport

aFileld
Type: String

Return Value

Type: String

See Also

Reference

  • TfrxCustomPresetAttr
  • frxQRCodeSwissPreset


TfrxSPAdditionalInformation Class

Summary

Represents type TfrxSPAdditionalInformation.

Namespace: frxQRCodeSwissPreset
Inheritance Hierarchy
TPersistent
frxQRCodeSwissPreset.TfrxCustomPresetAttr
frxQRCodeSwissPreset.TfrxSPAdditionalInformation
Syntax
Delphi
type
 TfrxSPAdditionalInformation = class(TfrxCustomPresetAttr)
 end;

The TfrxSPAdditionalInformation type exposes the following members.

Properties
Show:
Name | Description
BillInformation | Represents property BillInformation.
UnstructuredMessage | Represents property UnstructuredMessage.
Top
Methods
Show:
Name | Description
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top
Fields
Show:
Name | Description
FBillInformation | Represents field FBillInformation.
FUnstructuredMessage | Represents field FUnstructuredMessage.
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxSPAdditionalInformation Properties

Properties
Name | Description
BillInformation | Represents property BillInformation.
UnstructuredMessage | Represents property UnstructuredMessage.
Top


TfrxSPAdditionalInformation.BillInformation Property

Summary

Represents property BillInformation.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property BillInformation: String read FBillInformation write FBillInformation;

Property Value

Type: String

See Also

Reference

  • TfrxSPAdditionalInformation
  • frxQRCodeSwissPreset


TfrxSPAdditionalInformation.UnstructuredMessage Property

Summary

Represents property UnstructuredMessage.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property UnstructuredMessage: String read FUnstructuredMessage write FUnstructuredMessage;

Property Value

Type: String

See Also

Reference

  • TfrxSPAdditionalInformation
  • frxQRCodeSwissPreset


TfrxSPAdditionalInformation Methods

Methods
Name | Description
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top


TfrxSPAdditionalInformation.GetData(TfrxReport) Method

Summary

Represents method GetData(TfrxReport).

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 function GetData(aReport: TfrxReport): String; override;

Parameters

aReport
Type: TfrxReport

Return Value

Type: String

Overrides

TfrxCustomPresetAttr.GetData(TfrxReport)
See Also

Reference

  • TfrxSPAdditionalInformation
  • frxQRCodeSwissPreset


TfrxSPAdditionalInformation Fields

Fields
Name | Description
FBillInformation | Represents field FBillInformation.
FUnstructuredMessage | Represents field FUnstructuredMessage.
Top


TfrxSPAdditionalInformation.FBillInformation Field

Summary

Represents field FBillInformation.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FBillInformation: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPAdditionalInformation
  • frxQRCodeSwissPreset


TfrxSPAdditionalInformation.FUnstructuredMessage Field

Summary

Represents field FUnstructuredMessage.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FUnstructuredMessage: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPAdditionalInformation
  • frxQRCodeSwissPreset


TfrxSPAlternativeSchemes Class

Summary

Represents type TfrxSPAlternativeSchemes.

Namespace: frxQRCodeSwissPreset
Inheritance Hierarchy
TPersistent
frxQRCodeSwissPreset.TfrxCustomPresetAttr
frxQRCodeSwissPreset.TfrxSPAlternativeSchemes
Syntax
Delphi
type
 TfrxSPAlternativeSchemes = class(TfrxCustomPresetAttr)
 end;

The TfrxSPAlternativeSchemes type exposes the following members.

Properties
Show:
Name | Description
SchemeParameterOne | Represents property SchemeParameterOne.
SchemeParameterTwo | Represents property SchemeParameterTwo.
Top
Methods
Show:
Name | Description
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top
Fields
Show:
Name | Description
FSchemeParameterOne | Represents field FSchemeParameterOne.
FSchemeParameterTwo | Represents field FSchemeParameterTwo.
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxSPAlternativeSchemes Properties

Properties
Name | Description
SchemeParameterOne | Represents property SchemeParameterOne.
SchemeParameterTwo | Represents property SchemeParameterTwo.
Top


TfrxSPAlternativeSchemes.SchemeParameterOne Property

Summary

Represents property SchemeParameterOne.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property SchemeParameterOne: String read FSchemeParameterOne write FSchemeParameterOne;

Property Value

Type: String

See Also

Reference

  • TfrxSPAlternativeSchemes
  • frxQRCodeSwissPreset


TfrxSPAlternativeSchemes.SchemeParameterTwo Property

Summary

Represents property SchemeParameterTwo.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property SchemeParameterTwo: String read FSchemeParameterTwo write FSchemeParameterTwo;

Property Value

Type: String

See Also

Reference

  • TfrxSPAlternativeSchemes
  • frxQRCodeSwissPreset


TfrxSPAlternativeSchemes Methods

Methods
Name | Description
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top


TfrxSPAlternativeSchemes.GetData(TfrxReport) Method

Summary

Represents method GetData(TfrxReport).

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 function GetData(aReport: TfrxReport): String; override;

Parameters

aReport
Type: TfrxReport

Return Value

Type: String

Overrides

TfrxCustomPresetAttr.GetData(TfrxReport)
See Also

Reference

  • TfrxSPAlternativeSchemes
  • frxQRCodeSwissPreset


TfrxSPAlternativeSchemes Fields

Fields
Name | Description
FSchemeParameterOne | Represents field FSchemeParameterOne.
FSchemeParameterTwo | Represents field FSchemeParameterTwo.
Top


TfrxSPAlternativeSchemes.FSchemeParameterOne Field

Summary

Represents field FSchemeParameterOne.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FSchemeParameterOne: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPAlternativeSchemes
  • frxQRCodeSwissPreset


TfrxSPAlternativeSchemes.FSchemeParameterTwo Field

Summary

Represents field FSchemeParameterTwo.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FSchemeParameterTwo: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPAlternativeSchemes
  • frxQRCodeSwissPreset


TfrxSPCreditor Class

Summary

Represents type TfrxSPCreditor.

Namespace: frxQRCodeSwissPreset
Inheritance Hierarchy
TPersistent
frxQRCodeSwissPreset.TfrxCustomPresetAttr
frxQRCodeSwissPreset.TfrxSPPersonInfo
frxQRCodeSwissPreset.TfrxSPCreditor
Syntax
Delphi
type
 TfrxSPCreditor = class(TfrxSPPersonInfo)
 end;

The TfrxSPCreditor type exposes the following members.

Properties
Show:
Name | Description
AddressLine1 | Represents property AddressLine1.
AddressLine2 | Represents property AddressLine2.
AddressType | Represents property AddressType.
AddressTypeExp | Represents property AddressTypeExp.
Country | Represents property Country.
Name | Represents property Name.
PostalCode | Represents property PostalCode.
Town | Represents property Town.
Top
Methods
Show:
Name | Description
GetAddrType(TfrxReport) | Represents method GetAddrType(TfrxReport). (Inherited from TfrxSPPersonInfo.)
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxSPCreditor Properties

Properties
Name | Description
AddressLine1 | Represents property AddressLine1.
AddressLine2 | Represents property AddressLine2.
AddressType | Represents property AddressType.
AddressTypeExp | Represents property AddressTypeExp.
Country | Represents property Country.
Name | Represents property Name.
PostalCode | Represents property PostalCode.
Town | Represents property Town.
Top


TfrxSPCreditor.AddressLine1 Property

Summary

Represents property AddressLine1.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AddressLine1;

Property Value

Type: Void

See Also

Reference

  • TfrxSPCreditor
  • frxQRCodeSwissPreset


TfrxSPCreditor.AddressLine2 Property

Summary

Represents property AddressLine2.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AddressLine2;

Property Value

Type: Void

See Also

Reference

  • TfrxSPCreditor
  • frxQRCodeSwissPreset


TfrxSPCreditor.AddressType Property

Summary

Represents property AddressType.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AddressType;

Property Value

Type: Void

See Also

Reference

  • TfrxSPCreditor
  • frxQRCodeSwissPreset


TfrxSPCreditor.AddressTypeExp Property

Summary

Represents property AddressTypeExp.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AddressTypeExp;

Property Value

Type: Void

See Also

Reference

  • TfrxSPCreditor
  • frxQRCodeSwissPreset


TfrxSPCreditor.Country Property

Summary

Represents property Country.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Country;

Property Value

Type: Void

See Also

Reference

  • TfrxSPCreditor
  • frxQRCodeSwissPreset


TfrxSPCreditor.Name Property

Summary

Represents property Name.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Name;

Property Value

Type: Void

See Also

Reference

  • TfrxSPCreditor
  • frxQRCodeSwissPreset


TfrxSPCreditor.PostalCode Property

Summary

Represents property PostalCode.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property PostalCode;

Property Value

Type: Void

See Also

Reference

  • TfrxSPCreditor
  • frxQRCodeSwissPreset


TfrxSPCreditor.Town Property

Summary

Represents property Town.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Town;

Property Value

Type: Void

See Also

Reference

  • TfrxSPCreditor
  • frxQRCodeSwissPreset


TfrxSPCreditorInformation Class

Summary

Represents type TfrxSPCreditorInformation.

Namespace: frxQRCodeSwissPreset
Inheritance Hierarchy
TPersistent
frxQRCodeSwissPreset.TfrxCustomPresetAttr
frxQRCodeSwissPreset.TfrxSPCreditorInformation
Syntax
Delphi
type
 TfrxSPCreditorInformation = class(TfrxCustomPresetAttr)
 end;

The TfrxSPCreditorInformation type exposes the following members.

Properties
Show:
Name | Description
IBAN | Represents property IBAN.
Top
Methods
Show:
Name | Description
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top
Fields
Show:
Name | Description
FIBAN | Represents field FIBAN.
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxSPCreditorInformation Properties

Properties
Name | Description
IBAN | Represents property IBAN.
Top


TfrxSPCreditorInformation.IBAN Property

Summary

Represents property IBAN.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property IBAN: String read FIBAN write FIBAN;

Property Value

Type: String

See Also

Reference

  • TfrxSPCreditorInformation
  • frxQRCodeSwissPreset


TfrxSPCreditorInformation Methods

Methods
Name | Description
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top


TfrxSPCreditorInformation.GetData(TfrxReport) Method

Summary

Represents method GetData(TfrxReport).

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 function GetData(aReport: TfrxReport): String; override;

Parameters

aReport
Type: TfrxReport

Return Value

Type: String

Overrides

TfrxCustomPresetAttr.GetData(TfrxReport)
See Also

Reference

  • TfrxSPCreditorInformation
  • frxQRCodeSwissPreset


TfrxSPCreditorInformation Fields

Fields
Name | Description
FIBAN | Represents field FIBAN.
Top


TfrxSPCreditorInformation.FIBAN Field

Summary

Represents field FIBAN.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FIBAN: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPCreditorInformation
  • frxQRCodeSwissPreset


TfrxSPPaymentAmountInfo Class

Summary

Represents type TfrxSPPaymentAmountInfo.

Namespace: frxQRCodeSwissPreset
Inheritance Hierarchy
TPersistent
frxQRCodeSwissPreset.TfrxCustomPresetAttr
frxQRCodeSwissPreset.TfrxSPPaymentAmountInfo
Syntax
Delphi
type
 TfrxSPPaymentAmountInfo = class(TfrxCustomPresetAttr)
 end;

The TfrxSPPaymentAmountInfo type exposes the following members.

Properties
Show:
Name | Description
Amount | Represents property Amount.
Currency | Represents property Currency.
Top
Methods
Show:
Name | Description
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top
Fields
Show:
Name | Description
FAmount | Represents field FAmount.
FCurrency | Represents field FCurrency.
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxSPPaymentAmountInfo Properties

Properties
Name | Description
Amount | Represents property Amount.
Currency | Represents property Currency.
Top


TfrxSPPaymentAmountInfo.Amount Property

Summary

Represents property Amount.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Amount: String read FAmount write FAmount;

Property Value

Type: String

See Also

Reference

  • TfrxSPPaymentAmountInfo
  • frxQRCodeSwissPreset


TfrxSPPaymentAmountInfo.Currency Property

Summary

Represents property Currency.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Currency: String read FCurrency write FCurrency;

Property Value

Type: String

See Also

Reference

  • TfrxSPPaymentAmountInfo
  • frxQRCodeSwissPreset


TfrxSPPaymentAmountInfo Methods

Methods
Name | Description
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top


TfrxSPPaymentAmountInfo.GetData(TfrxReport) Method

Summary

Represents method GetData(TfrxReport).

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 function GetData(aReport: TfrxReport): String; override;

Parameters

aReport
Type: TfrxReport

Return Value

Type: String

Overrides

TfrxCustomPresetAttr.GetData(TfrxReport)
See Also

Reference

  • TfrxSPPaymentAmountInfo
  • frxQRCodeSwissPreset


TfrxSPPaymentAmountInfo Fields

Fields
Name | Description
FAmount | Represents field FAmount.
FCurrency | Represents field FCurrency.
Top


TfrxSPPaymentAmountInfo.FAmount Field

Summary

Represents field FAmount.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FAmount: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPPaymentAmountInfo
  • frxQRCodeSwissPreset


TfrxSPPaymentAmountInfo.FCurrency Field

Summary

Represents field FCurrency.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FCurrency: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPPaymentAmountInfo
  • frxQRCodeSwissPreset


TfrxSPPaymentReference Class

Summary

Represents type TfrxSPPaymentReference.

Namespace: frxQRCodeSwissPreset
Inheritance Hierarchy
TPersistent
frxQRCodeSwissPreset.TfrxCustomPresetAttr
frxQRCodeSwissPreset.TfrxSPPaymentReference
Syntax
Delphi
type
 TfrxSPPaymentReference = class(TfrxCustomPresetAttr)
 end;

The TfrxSPPaymentReference type exposes the following members.

Properties
Show:
Name | Description
Reference | Represents property Reference.
ReferenceTyp | Represents property ReferenceTyp.
ReferenceTypExp | Represents property ReferenceTypExp.
Top
Methods
Show:
Name | Description
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top
Fields
Show:
Name | Description
FReference | Represents field FReference.
FReferenceTyp | Represents field FReferenceTyp.
FReferenceTypExp | Represents field FReferenceTypExp.
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxSPPaymentReference Properties

Properties
Name | Description
Reference | Represents property Reference.
ReferenceTyp | Represents property ReferenceTyp.
ReferenceTypExp | Represents property ReferenceTypExp.
Top


TfrxSPPaymentReference.Reference Property

Summary

Represents property Reference.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Reference: String read FReference write FReference;

Property Value

Type: String

See Also

Reference

  • TfrxSPPaymentReference
  • frxQRCodeSwissPreset


TfrxSPPaymentReference.ReferenceTyp Property

Summary

Represents property ReferenceTyp.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property ReferenceTyp: TfrxSPReferenceType read FReferenceTyp write FReferenceTyp;

Property Value

Type: TfrxSPReferenceType

See Also

Reference

  • TfrxSPPaymentReference
  • frxQRCodeSwissPreset


TfrxSPPaymentReference.ReferenceTypExp Property

Summary

Represents property ReferenceTypExp.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property ReferenceTypExp: String read FReferenceTypExp write FReferenceTypExp;

Property Value

Type: String

See Also

Reference

  • TfrxSPPaymentReference
  • frxQRCodeSwissPreset


TfrxSPPaymentReference Methods

Methods
Name | Description
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top


TfrxSPPaymentReference.GetData(TfrxReport) Method

Summary

Represents method GetData(TfrxReport).

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 function GetData(aReport: TfrxReport): String; override;

Parameters

aReport
Type: TfrxReport

Return Value

Type: String

Overrides

TfrxCustomPresetAttr.GetData(TfrxReport)
See Also

Reference

  • TfrxSPPaymentReference
  • frxQRCodeSwissPreset


TfrxSPPaymentReference Fields

Fields
Name | Description
FReference | Represents field FReference.
FReferenceTyp | Represents field FReferenceTyp.
FReferenceTypExp | Represents field FReferenceTypExp.
Top


TfrxSPPaymentReference.FReference Field

Summary

Represents field FReference.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FReference: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPPaymentReference
  • frxQRCodeSwissPreset


TfrxSPPaymentReference.FReferenceTyp Field

Summary

Represents field FReferenceTyp.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FReferenceTyp: TfrxSPReferenceType;

Field Value

Type: TfrxSPReferenceType

See Also

Reference

  • TfrxSPPaymentReference
  • frxQRCodeSwissPreset


TfrxSPPaymentReference.FReferenceTypExp Field

Summary

Represents field FReferenceTypExp.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FReferenceTypExp: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPPaymentReference
  • frxQRCodeSwissPreset


TfrxSPPersonInfo Class

Summary

Represents type TfrxSPPersonInfo.

Namespace: frxQRCodeSwissPreset
Inheritance Hierarchy
TPersistent
frxQRCodeSwissPreset.TfrxCustomPresetAttr
frxQRCodeSwissPreset.TfrxSPPersonInfo
frxQRCodeSwissPreset.TfrxSPCreditor
frxQRCodeSwissPreset.TfrxSPUltimateInfo
Syntax
Delphi
type
 TfrxSPPersonInfo = class(TfrxCustomPresetAttr)
 end;

The TfrxSPPersonInfo type exposes the following members.

Properties
Show:
Name | Description
AddressLine1 | Represents property AddressLine1.
AddressLine2 | Represents property AddressLine2.
AddressType | Represents property AddressType.
AddressTypeExp | Represents property AddressTypeExp.
Country | Represents property Country.
Name | Represents property Name.
PostalCode | Represents property PostalCode.
Town | Represents property Town.
Top
Methods
Show:
Name | Description
GetAddrType(TfrxReport) | Represents method GetAddrType(TfrxReport).
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top
Fields
Show:
Name | Description
FAddressLine1 | Represents field FAddressLine1.
FAddressLine2 | Represents field FAddressLine2.
FAddressType | Represents field FAddressType.
FAddressTypeExp | Represents field FAddressTypeExp.
FCountry | Represents field FCountry.
FName | Represents field FName.
FPostalCode | Represents field FPostalCode.
FTown | Represents field FTown.
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxSPPersonInfo Properties

Properties
Name | Description
AddressLine1 | Represents property AddressLine1.
AddressLine2 | Represents property AddressLine2.
AddressType | Represents property AddressType.
AddressTypeExp | Represents property AddressTypeExp.
Country | Represents property Country.
Name | Represents property Name.
PostalCode | Represents property PostalCode.
Town | Represents property Town.
Top


TfrxSPPersonInfo.AddressLine1 Property

Summary

Represents property AddressLine1.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 property AddressLine1: String read FAddressLine1 write FAddressLine1;

Property Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.AddressLine2 Property

Summary

Represents property AddressLine2.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 property AddressLine2: String read FAddressLine2 write FAddressLine2;

Property Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.AddressType Property

Summary

Represents property AddressType.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 property AddressType: TfrxSPAddressType read FAddressType write FAddressType;

Property Value

Type: TfrxSPAddressType

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.AddressTypeExp Property

Summary

Represents property AddressTypeExp.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 property AddressTypeExp: String read FAddressTypeExp write FAddressTypeExp;

Property Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.Country Property

Summary

Represents property Country.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 property Country: String read FCountry write FCountry;

Property Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.Name Property

Summary

Represents property Name.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 property Name: String read FName write FName;

Property Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.PostalCode Property

Summary

Represents property PostalCode.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 property PostalCode: String read FPostalCode write FPostalCode;

Property Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.Town Property

Summary

Represents property Town.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 property Town: String read FTown write FTown;

Property Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo Methods

Methods
Name | Description
GetAddrType(TfrxReport) | Represents method GetAddrType(TfrxReport).
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top


TfrxSPPersonInfo.GetAddrType(TfrxReport) Method

Summary

Represents method GetAddrType(TfrxReport).

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
protected
 function GetAddrType(aReport: TfrxReport): String; virtual;

Parameters

aReport
Type: TfrxReport

Return Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.GetData(TfrxReport) Method

Summary

Represents method GetData(TfrxReport).

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 function GetData(aReport: TfrxReport): String; override;

Parameters

aReport
Type: TfrxReport

Return Value

Type: String

Overrides

TfrxCustomPresetAttr.GetData(TfrxReport)
See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo Fields

Fields
Name | Description
FAddressLine1 | Represents field FAddressLine1.
FAddressLine2 | Represents field FAddressLine2.
FAddressType | Represents field FAddressType.
FAddressTypeExp | Represents field FAddressTypeExp.
FCountry | Represents field FCountry.
FName | Represents field FName.
FPostalCode | Represents field FPostalCode.
FTown | Represents field FTown.
Top


TfrxSPPersonInfo.FAddressLine1 Field

Summary

Represents field FAddressLine1.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FAddressLine1: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.FAddressLine2 Field

Summary

Represents field FAddressLine2.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FAddressLine2: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.FAddressType Field

Summary

Represents field FAddressType.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FAddressType: TfrxSPAddressType;

Field Value

Type: TfrxSPAddressType

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.FAddressTypeExp Field

Summary

Represents field FAddressTypeExp.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FAddressTypeExp: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.FCountry Field

Summary

Represents field FCountry.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FCountry: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.FName Field

Summary

Represents field FName.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.FPostalCode Field

Summary

Represents field FPostalCode.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FPostalCode: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPPersonInfo.FTown Field

Summary

Represents field FTown.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FTown: String;

Field Value

Type: String

See Also

Reference

  • TfrxSPPersonInfo
  • frxQRCodeSwissPreset


TfrxSPUltimateCreditor Class

Summary

Represents type TfrxSPUltimateCreditor.

Namespace: frxQRCodeSwissPreset
Inheritance Hierarchy
TPersistent
frxQRCodeSwissPreset.TfrxCustomPresetAttr
frxQRCodeSwissPreset.TfrxSPPersonInfo
frxQRCodeSwissPreset.TfrxSPUltimateInfo
frxQRCodeSwissPreset.TfrxSPUltimateCreditor
Syntax
Delphi
type
 TfrxSPUltimateCreditor = class(TfrxSPUltimateInfo)
 end;

The TfrxSPUltimateCreditor type exposes the following members.

Properties
Show:
Name | Description
AddressLine1 | Represents property AddressLine1.
AddressLine2 | Represents property AddressLine2.
AddressType | Represents property AddressType.
AddressTypeExp | Represents property AddressTypeExp.
Country | Represents property Country.
Name | Represents property Name.
PostalCode | Represents property PostalCode.
Town | Represents property Town.
Top
Methods
Show:
Name | Description
GetAddrType(TfrxReport) | Represents method GetAddrType(TfrxReport). (Overrides TfrxSPPersonInfo.GetAddrType(TfrxReport).)
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxSPUltimateCreditor Properties

Properties
Name | Description
AddressLine1 | Represents property AddressLine1.
AddressLine2 | Represents property AddressLine2.
AddressType | Represents property AddressType.
AddressTypeExp | Represents property AddressTypeExp.
Country | Represents property Country.
Name | Represents property Name.
PostalCode | Represents property PostalCode.
Town | Represents property Town.
Top


TfrxSPUltimateCreditor.AddressLine1 Property

Summary

Represents property AddressLine1.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AddressLine1;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateCreditor
  • frxQRCodeSwissPreset


TfrxSPUltimateCreditor.AddressLine2 Property

Summary

Represents property AddressLine2.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AddressLine2;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateCreditor
  • frxQRCodeSwissPreset


TfrxSPUltimateCreditor.AddressType Property

Summary

Represents property AddressType.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AddressType;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateCreditor
  • frxQRCodeSwissPreset


TfrxSPUltimateCreditor.AddressTypeExp Property

Summary

Represents property AddressTypeExp.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AddressTypeExp;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateCreditor
  • frxQRCodeSwissPreset


TfrxSPUltimateCreditor.Country Property

Summary

Represents property Country.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Country;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateCreditor
  • frxQRCodeSwissPreset


TfrxSPUltimateCreditor.Name Property

Summary

Represents property Name.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Name;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateCreditor
  • frxQRCodeSwissPreset


TfrxSPUltimateCreditor.PostalCode Property

Summary

Represents property PostalCode.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property PostalCode;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateCreditor
  • frxQRCodeSwissPreset


TfrxSPUltimateCreditor.Town Property

Summary

Represents property Town.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Town;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateCreditor
  • frxQRCodeSwissPreset


TfrxSPUltimateDebtor Class

Summary

Represents type TfrxSPUltimateDebtor.

Namespace: frxQRCodeSwissPreset
Inheritance Hierarchy
TPersistent
frxQRCodeSwissPreset.TfrxCustomPresetAttr
frxQRCodeSwissPreset.TfrxSPPersonInfo
frxQRCodeSwissPreset.TfrxSPUltimateInfo
frxQRCodeSwissPreset.TfrxSPUltimateDebtor
Syntax
Delphi
type
 TfrxSPUltimateDebtor = class(TfrxSPUltimateInfo)
 end;

The TfrxSPUltimateDebtor type exposes the following members.

Properties
Show:
Name | Description
AddressLine1 | Represents property AddressLine1.
AddressLine2 | Represents property AddressLine2.
AddressType | Represents property AddressType.
AddressTypeExp | Represents property AddressTypeExp.
Country | Represents property Country.
Name | Represents property Name.
PostalCode | Represents property PostalCode.
Town | Represents property Town.
Top
Methods
Show:
Name | Description
GetAddrType(TfrxReport) | Represents method GetAddrType(TfrxReport). (Overrides TfrxSPPersonInfo.GetAddrType(TfrxReport).)
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxSPUltimateDebtor Properties

Properties
Name | Description
AddressLine1 | Represents property AddressLine1.
AddressLine2 | Represents property AddressLine2.
AddressType | Represents property AddressType.
AddressTypeExp | Represents property AddressTypeExp.
Country | Represents property Country.
Name | Represents property Name.
PostalCode | Represents property PostalCode.
Town | Represents property Town.
Top


TfrxSPUltimateDebtor.AddressLine1 Property

Summary

Represents property AddressLine1.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AddressLine1;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateDebtor
  • frxQRCodeSwissPreset


TfrxSPUltimateDebtor.AddressLine2 Property

Summary

Represents property AddressLine2.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AddressLine2;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateDebtor
  • frxQRCodeSwissPreset


TfrxSPUltimateDebtor.AddressType Property

Summary

Represents property AddressType.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AddressType;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateDebtor
  • frxQRCodeSwissPreset


TfrxSPUltimateDebtor.AddressTypeExp Property

Summary

Represents property AddressTypeExp.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AddressTypeExp;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateDebtor
  • frxQRCodeSwissPreset


TfrxSPUltimateDebtor.Country Property

Summary

Represents property Country.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Country;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateDebtor
  • frxQRCodeSwissPreset


TfrxSPUltimateDebtor.Name Property

Summary

Represents property Name.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Name;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateDebtor
  • frxQRCodeSwissPreset


TfrxSPUltimateDebtor.PostalCode Property

Summary

Represents property PostalCode.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property PostalCode;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateDebtor
  • frxQRCodeSwissPreset


TfrxSPUltimateDebtor.Town Property

Summary

Represents property Town.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Town;

Property Value

Type: Void

See Also

Reference

  • TfrxSPUltimateDebtor
  • frxQRCodeSwissPreset


TfrxSPUltimateInfo Class

Summary

Represents type TfrxSPUltimateInfo.

Namespace: frxQRCodeSwissPreset
Inheritance Hierarchy
TPersistent
frxQRCodeSwissPreset.TfrxCustomPresetAttr
frxQRCodeSwissPreset.TfrxSPPersonInfo
frxQRCodeSwissPreset.TfrxSPUltimateInfo
frxQRCodeSwissPreset.TfrxSPUltimateCreditor
frxQRCodeSwissPreset.TfrxSPUltimateDebtor
Syntax
Delphi
type
 TfrxSPUltimateInfo = class(TfrxSPPersonInfo)
 end;

The TfrxSPUltimateInfo type exposes the following members.

Properties
Show:
Name | Description
AddressLine1 | Represents property AddressLine1. (Inherited from TfrxSPPersonInfo.)
AddressLine2 | Represents property AddressLine2. (Inherited from TfrxSPPersonInfo.)
AddressType | Represents property AddressType. (Inherited from TfrxSPPersonInfo.)
AddressTypeExp | Represents property AddressTypeExp. (Inherited from TfrxSPPersonInfo.)
Country | Represents property Country. (Inherited from TfrxSPPersonInfo.)
Name | Represents property Name. (Inherited from TfrxSPPersonInfo.)
PostalCode | Represents property PostalCode. (Inherited from TfrxSPPersonInfo.)
Town | Represents property Town. (Inherited from TfrxSPPersonInfo.)
Top
Methods
Show:
Name | Description
GetAddrType(TfrxReport) | Represents method GetAddrType(TfrxReport). (Overrides TfrxSPPersonInfo.GetAddrType(TfrxReport).)
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomPresetAttr.GetData(TfrxReport).)
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxSPUltimateInfo Methods

Methods
Name | Description
GetAddrType(TfrxReport) | Represents method GetAddrType(TfrxReport). (Overrides TfrxSPPersonInfo.GetAddrType(TfrxReport).)
Top


TfrxSPUltimateInfo.GetAddrType(TfrxReport) Method

Summary

Represents method GetAddrType(TfrxReport).

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
protected
 function GetAddrType(aReport: TfrxReport): String; override;

Parameters

aReport
Type: TfrxReport

Return Value

Type: String

Overrides

TfrxSPPersonInfo.GetAddrType(TfrxReport)
See Also

Reference

  • TfrxSPUltimateInfo
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset Class

Summary

Represents type TfrxSwissPaymentPreset.

Namespace: frxQRCodeSwissPreset
Inheritance Hierarchy
TPersistent
frxClass.TfrxCustomObjectPreset
frxQRCodeSwissPreset.TfrxSwissPaymentPreset
Syntax
Delphi
type
 TfrxSwissPaymentPreset = class(TfrxCustomObjectPreset)
 end;

The TfrxSwissPaymentPreset type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxSwissPaymentPreset class. (Overrides TfrxCustomObjectPreset.Create.)
Destroy | Represents the destructor of the TfrxSwissPaymentPreset class.
Top
Properties
Show:
Name | Description
AdditionalInformation | Represents property AdditionalInformation.
AlternativeSchemes | Represents property AlternativeSchemes.
Creditor | Represents property Creditor.
CreditorInformation | Represents property CreditorInformation.
PaymentAmountInfo | Represents property PaymentAmountInfo.
PaymentReference | Represents property PaymentReference.
UltimateCreditor | Represents property UltimateCreditor.
UltimateDebtor | Represents property UltimateDebtor.
Top
Methods
Show:
Name | Description
ApplySettings(TfrxComponent) | Represents method ApplySettings(TfrxComponent). (Overrides TfrxCustomObjectPreset.ApplySettings(TfrxComponent).)
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomObjectPreset.GetData(TfrxReport).)
Top
Fields
Show:
Name | Description
FAdditionalInformation | Represents field FAdditionalInformation.
FAlternativeSchemes | Represents field FAlternativeSchemes.
FCreditor | Represents field FCreditor.
FCreditorInformation | Represents field FCreditorInformation.
FPaymentAmountInfo | Represents field FPaymentAmountInfo.
FPaymentReference | Represents field FPaymentReference.
FUltimateCreditor | Represents field FUltimateCreditor.
FUltimateDebtor | Represents field FUltimateDebtor.
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxSwissPaymentPreset class. (Overrides TfrxCustomObjectPreset.Create.)
Destroy | Represents the destructor of the TfrxSwissPaymentPreset class.
Top


TfrxSwissPaymentPreset.Create Constructor

Summary

Initializes a new instance of the TfrxSwissPaymentPreset class.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 constructor Create; override;

Overrides

TfrxCustomObjectPreset.Create
See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.Destroy Destructor

Summary

Represents the destructor of the TfrxSwissPaymentPreset class.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset Properties

Properties
Name | Description
AdditionalInformation | Represents property AdditionalInformation.
AlternativeSchemes | Represents property AlternativeSchemes.
Creditor | Represents property Creditor.
CreditorInformation | Represents property CreditorInformation.
PaymentAmountInfo | Represents property PaymentAmountInfo.
PaymentReference | Represents property PaymentReference.
UltimateCreditor | Represents property UltimateCreditor.
UltimateDebtor | Represents property UltimateDebtor.
Top


TfrxSwissPaymentPreset.AdditionalInformation Property

Summary

Represents property AdditionalInformation.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AdditionalInformation: TfrxSPAdditionalInformation read FAdditionalInformation;

Property Value

Type: TfrxSPAdditionalInformation

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.AlternativeSchemes Property

Summary

Represents property AlternativeSchemes.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property AlternativeSchemes: TfrxSPAlternativeSchemes read FAlternativeSchemes;

Property Value

Type: TfrxSPAlternativeSchemes

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.Creditor Property

Summary

Represents property Creditor.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property Creditor: TfrxSPCreditor read FCreditor;

Property Value

Type: TfrxSPCreditor

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.CreditorInformation Property

Summary

Represents property CreditorInformation.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property CreditorInformation: TfrxSPCreditorInformation read FCreditorInformation;

Property Value

Type: TfrxSPCreditorInformation

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.PaymentAmountInfo Property

Summary

Represents property PaymentAmountInfo.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property PaymentAmountInfo: TfrxSPPaymentAmountInfo read FPaymentAmountInfo;

Property Value

Type: TfrxSPPaymentAmountInfo

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.PaymentReference Property

Summary

Represents property PaymentReference.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property PaymentReference: TfrxSPPaymentReference read FPaymentReference;

Property Value

Type: TfrxSPPaymentReference

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.UltimateCreditor Property

Summary

Represents property UltimateCreditor.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property UltimateCreditor: TfrxSPUltimateCreditor read FUltimateCreditor;

Property Value

Type: TfrxSPUltimateCreditor

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.UltimateDebtor Property

Summary

Represents property UltimateDebtor.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
published
 property UltimateDebtor: TfrxSPUltimateDebtor read FUltimateDebtor;

Property Value

Type: TfrxSPUltimateDebtor

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset Methods

Methods
Name | Description
ApplySettings(TfrxComponent) | Represents method ApplySettings(TfrxComponent). (Overrides TfrxCustomObjectPreset.ApplySettings(TfrxComponent).)
GetData(TfrxReport) | Represents method GetData(TfrxReport). (Overrides TfrxCustomObjectPreset.GetData(TfrxReport).)
Top


TfrxSwissPaymentPreset.ApplySettings(TfrxComponent) Method

Summary

Represents method ApplySettings(TfrxComponent).

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 procedure ApplySettings(aComponent: TfrxComponent); override;

Parameters

aComponent
Type: TfrxComponent

Overrides

TfrxCustomObjectPreset.ApplySettings(TfrxComponent)
See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.GetData(TfrxReport) Method

Summary

Represents method GetData(TfrxReport).

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
public
 function GetData(aReport: TfrxReport): String; override;

Parameters

aReport
Type: TfrxReport

Return Value

Type: String

Overrides

TfrxCustomObjectPreset.GetData(TfrxReport)
See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset Fields

Fields
Name | Description
FAdditionalInformation | Represents field FAdditionalInformation.
FAlternativeSchemes | Represents field FAlternativeSchemes.
FCreditor | Represents field FCreditor.
FCreditorInformation | Represents field FCreditorInformation.
FPaymentAmountInfo | Represents field FPaymentAmountInfo.
FPaymentReference | Represents field FPaymentReference.
FUltimateCreditor | Represents field FUltimateCreditor.
FUltimateDebtor | Represents field FUltimateDebtor.
Top


TfrxSwissPaymentPreset.FAdditionalInformation Field

Summary

Represents field FAdditionalInformation.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FAdditionalInformation: TfrxSPAdditionalInformation;

Field Value

Type: TfrxSPAdditionalInformation

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.FAlternativeSchemes Field

Summary

Represents field FAlternativeSchemes.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FAlternativeSchemes: TfrxSPAlternativeSchemes;

Field Value

Type: TfrxSPAlternativeSchemes

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.FCreditor Field

Summary

Represents field FCreditor.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FCreditor: TfrxSPCreditor;

Field Value

Type: TfrxSPCreditor

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.FCreditorInformation Field

Summary

Represents field FCreditorInformation.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FCreditorInformation: TfrxSPCreditorInformation;

Field Value

Type: TfrxSPCreditorInformation

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.FPaymentAmountInfo Field

Summary

Represents field FPaymentAmountInfo.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FPaymentAmountInfo: TfrxSPPaymentAmountInfo;

Field Value

Type: TfrxSPPaymentAmountInfo

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.FPaymentReference Field

Summary

Represents field FPaymentReference.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FPaymentReference: TfrxSPPaymentReference;

Field Value

Type: TfrxSPPaymentReference

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.FUltimateCreditor Field

Summary

Represents field FUltimateCreditor.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FUltimateCreditor: TfrxSPUltimateCreditor;

Field Value

Type: TfrxSPUltimateCreditor

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


TfrxSwissPaymentPreset.FUltimateDebtor Field

Summary

Represents field FUltimateDebtor.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
private
 FUltimateDebtor: TfrxSPUltimateDebtor;

Field Value

Type: TfrxSPUltimateDebtor

See Also

Reference

  • TfrxSwissPaymentPreset
  • frxQRCodeSwissPreset


frxQRCodeSwissPreset Enumerations

Enumerations
Name | Description
TfrxSPAddressType | Represents type TfrxSPAddressType.
TfrxSPReferenceType | Represents type TfrxSPReferenceType.
Top


TfrxSPAddressType Enumeration

Summary

Represents type TfrxSPAddressType.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
type
 TfrxSPAddressType = (frAddT_S, frAddT_K);

The TfrxSPAddressType type exposes the following members.

Members
Show:
Name | Description
frAddT_K | Represents constant frAddT_K.
frAddT_S | Represents constant frAddT_S.
Top
See Also

Reference

  • frxQRCodeSwissPreset


TfrxSPReferenceType Enumeration

Summary

Represents type TfrxSPReferenceType.

Namespace: frxQRCodeSwissPreset
Syntax
Delphi
type
 TfrxSPReferenceType = (frRT_QRR, frRT_SCOR, frRT_NON);

The TfrxSPReferenceType type exposes the following members.

Members
Show:
Name | Description
frRT_NON | Represents constant frRT_NON.
frRT_QRR | Represents constant frRT_QRR.
frRT_SCOR | Represents constant frRT_SCOR.
Top
See Also

Reference

  • frxQRCodeSwissPreset


frxReportTree Namespace

Summary

Represents namespace frxReportTree.

Classes
Name | Description
TfrxReportTreeForm | Represents type TfrxReportTreeForm.
Top


frxReportTree Classes

Classes
Name | Description
TfrxReportTreeForm | Represents type TfrxReportTreeForm.
Top


TfrxReportTreeForm Class

Summary

Represents type TfrxReportTreeForm.

Namespace: frxReportTree
Inheritance Hierarchy
TForm
frxBaseForm.TfrxBaseForm
frxReportTree.TfrxReportTreeForm
Syntax
Delphi
type
 TfrxReportTreeForm = class(TfrxBaseForm)
 end;

The TfrxReportTreeForm type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxReportTreeForm class. (Overrides TfrxBaseForm.Create(TComponent).)
Destroy | Represents the destructor of the TfrxReportTreeForm class.
Top
Properties
Show:
Name | Description
CurrentFormPPI | Returns current PPI value of the form. (Inherited from TfrxBaseForm.)
IsPPIChanging | Represents property IsPPIChanging. (Inherited from TfrxBaseForm.)
OnSelectionChanged | Represents property OnSelectionChanged.
Top
Methods
Show:
Name | Description
AfterConstruction | Represents method AfterConstruction. (Inherited from TfrxBaseForm.)
AfterPPIChange | Represents method AfterPPIChange. (Inherited from TfrxBaseForm.)
AfterPPIMessage | Represents method AfterPPIMessage. (Inherited from TfrxBaseForm.)
BeforeDestruction | Represents method BeforeDestruction. (Inherited from TfrxBaseForm.)
BeforePPIChange | Represents method BeforePPIChange. (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer) | Overloaded. Represents method ChangeScale(Integer,Integer). (Inherited from TfrxBaseForm.)
ChangeScale(Integer,Integer,Boolean) | Overloaded. Represents method ChangeScale(Integer,Integer,Boolean). (Inherited from TfrxBaseForm.)
DoClose(TCloseAction) | Represents method DoClose(TCloseAction). (Inherited from TfrxBaseForm.)
DoShow | Represents method DoShow. (Inherited from TfrxBaseForm.)
DoUpdateFormPPI(Integer) | Represents method DoUpdateFormPPI(Integer). (Inherited from TfrxBaseForm.)
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
FormShowAfterLoad | Represents method FormShowAfterLoad. (Inherited from TfrxBaseForm.)
FormShowBeforeLoad | Represents method FormShowBeforeLoad. (Inherited from TfrxBaseForm.)
GetAvailablePreferences | Represents method GetAvailablePreferences. (Inherited from TfrxBaseForm.)
GetFormSectionName | Represents method GetFormSectionName. (Inherited from TfrxBaseForm.)
GetPreferencesStorage(Boolean) | This method should return reference to an object used to save preference. By default it's a registry or an ini file object. The top most window should mage this object. In FastReport tthe report designer and the report preview return this object. (Inherited from TfrxBaseForm.)
HostControls(TWinControl) | Moves controls from current form to host control. Each form should fill the list with control it can move by filling FHostedControls array. (Inherited from TfrxBaseForm.)
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.LoadFormPreferences(TObject,TObject).)
LoadFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Loads form settings from storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction) | Overloaded. This method used to process preference action(load/save/restore) with default type for current form. (Inherited from TfrxBaseForm.)
ProcessPreferences(TfrxPreferencesAction,TfrxPreferencesTypes) | Overloaded. This method used to process preference action(load/save/restore) with non-default type which passed as a parameter. (Inherited from TfrxBaseForm.)
ResetFormPreferences(TObject) | Represents method ResetFormPreferences(TObject). (Inherited from TfrxBaseForm.)
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.SaveFormPreferences(TObject,TObject).)
SaveFormPrefType(TObject,TObject,TfrxPreferencesTypes) | Saves form settings to storage object with using preference type parameter. (Inherited from TfrxBaseForm.)
ScaleForPPI(Integer) | Represents method ScaleForPPI(Integer). (Inherited from TfrxBaseForm.)
SendPPIMessage(TWinControl,Integer) | Sends PPI message to a form or a control and all child dock forms. (Inherited from TfrxBaseForm.)
SetColor_(TColor) | Represents method SetColor_(TColor).
TreeChange(TObject,TTreeNode) | Represents method TreeChange(TObject,TTreeNode).
TreeDragDrop(TObject,TObject,Integer,Integer) | Represents method TreeDragDrop(TObject,TObject,Integer,Integer).
TreeDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method TreeDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
TreeKeyDown(TObject,Word,TShiftState) | Represents method TreeKeyDown(TObject,Word,TShiftState).
TreeMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method TreeMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
UnhostControls(TModalResult) | Returns back all moved by HostControls function controls back to owner form and pass modal result to the form. (Inherited from TfrxBaseForm.)
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Overrides TfrxBaseForm.UpdateFormPPI(Integer).)
UpdateItems | Represents method UpdateItems.
UpdateResouces | Called when window receive message for localization. Updates form resource. Each form should override this method for custom resources. (Inherited from TfrxBaseForm.)
UpdateSelection | Represents method UpdateSelection.
Top
Fields
Show:
Name | Description
FComponents | Represents field FComponents.
FDesigner | Represents field FDesigner.
FHostedControls | Represents field FHostedControls. (Inherited from TfrxBaseForm.)
FNodes | Represents field FNodes.
FOnSelectionChanged | Represents field FOnSelectionChanged.
FPrefEvent | Represents field FPrefEvent. (Inherited from TfrxBaseForm.)
FReport | Represents field FReport.
FSelectedNodeList | Represents field FSelectedNodeList.
FTree | Represents field FTree.
FTreePanel | Represents field FTreePanel.
FUpdating | Represents field FUpdating.
Top
See Also

Reference

  • frxReportTree


TfrxReportTreeForm Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxReportTreeForm class. (Overrides TfrxBaseForm.Create(TComponent).)
Destroy | Represents the destructor of the TfrxReportTreeForm class.
Top


TfrxReportTreeForm.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxReportTreeForm class.

Namespace: frxReportTree
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxBaseForm.Create(TComponent)
See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.Destroy Destructor

Summary

Represents the destructor of the TfrxReportTreeForm class.

Namespace: frxReportTree
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm Properties

Properties
Name | Description
OnSelectionChanged | Represents property OnSelectionChanged.
Top


TfrxReportTreeForm.OnSelectionChanged Property

Summary

Represents property OnSelectionChanged.

Namespace: frxReportTree
Syntax
Delphi
public
 property OnSelectionChanged: TNotifyEvent read FOnSelectionChanged
 write FOnSelectionChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm Methods

Methods
Name | Description
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LoadFormPreferences(TObject,TObject) | Represents method LoadFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.LoadFormPreferences(TObject,TObject).)
SaveFormPreferences(TObject,TObject) | Represents method SaveFormPreferences(TObject,TObject). (Overrides TfrxBaseForm.SaveFormPreferences(TObject,TObject).)
SetColor_(TColor) | Represents method SetColor_(TColor).
TreeChange(TObject,TTreeNode) | Represents method TreeChange(TObject,TTreeNode).
TreeDragDrop(TObject,TObject,Integer,Integer) | Represents method TreeDragDrop(TObject,TObject,Integer,Integer).
TreeDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method TreeDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
TreeKeyDown(TObject,Word,TShiftState) | Represents method TreeKeyDown(TObject,Word,TShiftState).
TreeMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) | Represents method TreeMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).
UpdateFormPPI(Integer) | Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method. (Overrides TfrxBaseForm.UpdateFormPPI(Integer).)
UpdateItems | Represents method UpdateItems.
UpdateSelection | Represents method UpdateSelection.
Top


TfrxReportTreeForm.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: frxReportTree
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: frxReportTree
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.LoadFormPreferences(TObject,TObject) Method

Summary

Represents method LoadFormPreferences(TObject,TObject).

Namespace: frxReportTree
Syntax
Delphi
public
 procedure LoadFormPreferences(PreferencesStorage: TObject; DefPreferencesStorage: TObject); override;

Parameters

PreferencesStorage
Type: TObject

DefPreferencesStorage
Type: TObject

Overrides

TfrxBaseForm.LoadFormPreferences(TObject,TObject)
See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.SaveFormPreferences(TObject,TObject) Method

Summary

Represents method SaveFormPreferences(TObject,TObject).

Namespace: frxReportTree
Syntax
Delphi
public
 procedure SaveFormPreferences(PreferencesStorage: TObject; DefPreferencesStorage: TObject); override;

Parameters

PreferencesStorage
Type: TObject

DefPreferencesStorage
Type: TObject

Overrides

TfrxBaseForm.SaveFormPreferences(TObject,TObject)
See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.SetColor_(TColor) Method

Summary

Represents method SetColor_(TColor).

Namespace: frxReportTree
Syntax
Delphi
public
 procedure SetColor_(Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.TreeChange(TObject,TTreeNode) Method

Summary

Represents method TreeChange(TObject,TTreeNode).

Namespace: frxReportTree
Syntax
Delphi
published
 procedure TreeChange(Sender: TObject; Node: TTreeNode);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.TreeDragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method TreeDragDrop(TObject,TObject,Integer,Integer).

Namespace: frxReportTree
Syntax
Delphi
published
 procedure TreeDragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.TreeDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method TreeDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: frxReportTree
Syntax
Delphi
published
 procedure TreeDragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.TreeKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method TreeKeyDown(TObject,Word,TShiftState).

Namespace: frxReportTree
Syntax
Delphi
published
 procedure TreeKeyDown(Sender: TObject; var Key: Word;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.TreeMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method TreeMouseDown(TObject,TMouseButton,TShiftState,Integer,Integer).

Namespace: frxReportTree
Syntax
Delphi
published
 procedure TreeMouseDown(Sender: TObject; Button: TMouseButton;
 Shift: TShiftState; X, Y: Integer);

Parameters

Sender
Type: TObject

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.UpdateFormPPI(Integer) Method

Summary

Form calls this method when receives messages that current PPI was changed. If Form has controls that doesn't support automatic scaling, those controls should be corrected in this method.

Namespace: frxReportTree
Syntax
Delphi
public
 procedure UpdateFormPPI(aNewPPI: Integer); override;

Parameters

aNewPPI
Type: Integer

New PPI value.

Overrides

TfrxBaseForm.UpdateFormPPI(Integer)
See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.UpdateItems Method

Summary

Represents method UpdateItems.

Namespace: frxReportTree
Syntax
Delphi
public
 procedure UpdateItems;
See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.UpdateSelection Method

Summary

Represents method UpdateSelection.

Namespace: frxReportTree
Syntax
Delphi
public
 procedure UpdateSelection;
See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm Fields

Fields
Name | Description
FComponents | Represents field FComponents.
FDesigner | Represents field FDesigner.
FNodes | Represents field FNodes.
FOnSelectionChanged | Represents field FOnSelectionChanged.
FReport | Represents field FReport.
FSelectedNodeList | Represents field FSelectedNodeList.
FTree | Represents field FTree.
FTreePanel | Represents field FTreePanel.
FUpdating | Represents field FUpdating.
Top


TfrxReportTreeForm.FComponents Field

Summary

Represents field FComponents.

Namespace: frxReportTree
Syntax
Delphi
private
 FComponents: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.FDesigner Field

Summary

Represents field FDesigner.

Namespace: frxReportTree
Syntax
Delphi
private
 FDesigner: TfrxCustomDesigner;

Field Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.FNodes Field

Summary

Represents field FNodes.

Namespace: frxReportTree
Syntax
Delphi
private
 FNodes: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.FOnSelectionChanged Field

Summary

Represents field FOnSelectionChanged.

Namespace: frxReportTree
Syntax
Delphi
private
 FOnSelectionChanged: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.FReport Field

Summary

Represents field FReport.

Namespace: frxReportTree
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.FSelectedNodeList Field

Summary

Represents field FSelectedNodeList.

Namespace: frxReportTree
Syntax
Delphi
private
 FSelectedNodeList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.FTree Field

Summary

Represents field FTree.

Namespace: frxReportTree
Syntax
Delphi
private
 FTree: TfrxTreeView;

Field Value

Type: TfrxTreeView

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.FTreePanel Field

Summary

Represents field FTreePanel.

Namespace: frxReportTree
Syntax
Delphi
private
 FTreePanel: TfrxTreePanel;

Field Value

Type: TfrxTreePanel

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


TfrxReportTreeForm.FUpdating Field

Summary

Represents field FUpdating.

Namespace: frxReportTree
Syntax
Delphi
private
 FUpdating: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxReportTreeForm
  • frxReportTree


frxRes Namespace

Summary

Represents namespace frxRes.

Classes
Name | Description
TfrxResources | Represents type TfrxResources.
Top
Constants
Name | Description
frxDefToolImageHeight | Represents constant frxDefToolImageHeight.
frxDefToolImageWidth | Represents constant frxDefToolImageWidth.
Top
Routines
Name | Description
frxGet(Integer) | Represents method frxGet(Integer).
frxResources | Represents method frxResources.
Top


frxRes Classes

Classes
Name | Description
TfrxResources | Represents type TfrxResources.
Top


TfrxResources Class

Summary

Represents type TfrxResources.

Namespace: frxRes
Inheritance Hierarchy
TObject
frxRes.TfrxResources
Syntax
Delphi
type
 TfrxResources = class(TObject)
 end;

The TfrxResources type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxResources class.
Destroy | Represents the destructor of the TfrxResources class.
Top
Properties
Show:
Name | Description
DisabledButtonImages | Represents property DisabledButtonImages.
HelpFile | Represents property HelpFile.
ImagesPPI | Represents property ImagesPPI.
Languages | Represents property Languages.
MainButtonImages | Represents property MainButtonImages.
ObjectImages | Represents property ObjectImages.
PreviewButtonImages | Represents property PreviewButtonImages.
WizardImages | Represents property WizardImages.
Top
Methods
Show:
Name | Description
Add(String,String) | Represents method Add(String,String).
AddStrings(String) | Represents method AddStrings(String).
AddW(String,WideString) | Represents method AddW(String,WideString).
AddXML(AnsiString) | Represents method AddXML(AnsiString).
AssignImages(TBitmap,Integer,Integer,TImageList,TImageList) | Represents method AssignImages(TBitmap,Integer,Integer,TImageList,TImageList).
BuildLanguagesList | Represents method BuildLanguagesList.
Clear | Represents method Clear.
Get(String) | Represents method Get(String).
GetDisabledButtonImages | Represents method GetDisabledButtonImages.
GetImages(String,Integer,Integer,Integer) | Represents method GetImages(String,Integer,Integer,Integer).
GetMainButtonImages | Represents method GetMainButtonImages.
GetObjectImages | Represents method GetObjectImages.
GetPreviewButtonImages | Represents method GetPreviewButtonImages.
GetWizardImages | Represents method GetWizardImages.
Help(TObject) | Overloaded. Represents method Help(TObject).
LoadFromFile(String) | Represents method LoadFromFile(String).
LoadFromStream(TStream) | Represents method LoadFromStream(TStream).
ResizeImages | Represents method ResizeImages.
SetButtonImages(TBitmap,Boolean) | Represents method SetButtonImages(TBitmap,Boolean).
SetGlyph(TSpeedButton,Integer) | Represents method SetGlyph(TSpeedButton,Integer).
SetImagesPPI(Integer) | Represents method SetImagesPPI(Integer).
SetObjectImages(TBitmap,Boolean) | Represents method SetObjectImages(TBitmap,Boolean).
SetPreviewButtonImages(TBitmap,Boolean) | Represents method SetPreviewButtonImages(TBitmap,Boolean).
SetWizardImages(TBitmap,Boolean) | Represents method SetWizardImages(TBitmap,Boolean).
UpdateFSResources | Represents method UpdateFSResources.
Top
Fields
Show:
Name | Description
FCP | Represents field FCP.
FDisabledButtonImages | Represents field FDisabledButtonImages.
FHelpFile | Represents field FHelpFile.
FImagesList | Represents field FImagesList.
FImagesPPI | Represents field FImagesPPI.
FLanguages | Represents field FLanguages.
FMainButtonImages | Represents field FMainButtonImages.
FNames | Represents field FNames.
FObjectImages | Represents field FObjectImages.
FPreviewButtonImages | Represents field FPreviewButtonImages.
FValues | Represents field FValues.
FWizardImages | Represents field FWizardImages.
Top
See Also

Reference

  • frxRes


TfrxResources Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxResources class.
Destroy | Represents the destructor of the TfrxResources class.
Top


TfrxResources.Create Constructor

Summary

Initializes a new instance of the TfrxResources class.

Namespace: frxRes
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.Destroy Destructor

Summary

Represents the destructor of the TfrxResources class.

Namespace: frxRes
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources Properties

Properties
Name | Description
DisabledButtonImages | Represents property DisabledButtonImages.
HelpFile | Represents property HelpFile.
ImagesPPI | Represents property ImagesPPI.
Languages | Represents property Languages.
MainButtonImages | Represents property MainButtonImages.
ObjectImages | Represents property ObjectImages.
PreviewButtonImages | Represents property PreviewButtonImages.
WizardImages | Represents property WizardImages.
Top


TfrxResources.DisabledButtonImages Property

Summary

Represents property DisabledButtonImages.

Namespace: frxRes
Syntax
Delphi
public
 property DisabledButtonImages: TImageList read GetDisabledButtonImages;

Property Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.HelpFile Property

Summary

Represents property HelpFile.

Namespace: frxRes
Syntax
Delphi
public
 property HelpFile: String read FHelpFile write FHelpFile;

Property Value

Type: String

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.ImagesPPI Property

Summary

Represents property ImagesPPI.

Namespace: frxRes
Syntax
Delphi
public
 property ImagesPPI: Integer read FImagesPPI write SetImagesPPI;

Property Value

Type: Integer

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.Languages Property

Summary

Represents property Languages.

Namespace: frxRes
Syntax
Delphi
public
 property Languages: TStringList read FLanguages;

Property Value

Type: TStringList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.MainButtonImages Property

Summary

Represents property MainButtonImages.

Namespace: frxRes
Syntax
Delphi
public
 property MainButtonImages: TImageList read GetMainButtonImages;

Property Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.ObjectImages Property

Summary

Represents property ObjectImages.

Namespace: frxRes
Syntax
Delphi
public
 property ObjectImages: TImageList read GetObjectImages;

Property Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.PreviewButtonImages Property

Summary

Represents property PreviewButtonImages.

Namespace: frxRes
Syntax
Delphi
public
 property PreviewButtonImages: TImageList read GetPreviewButtonImages;

Property Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.WizardImages Property

Summary

Represents property WizardImages.

Namespace: frxRes
Syntax
Delphi
public
 property WizardImages: TImageList read GetWizardImages;

Property Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources Methods

Methods
Name | Description
Add(String,String) | Represents method Add(String,String).
AddStrings(String) | Represents method AddStrings(String).
AddW(String,WideString) | Represents method AddW(String,WideString).
AddXML(AnsiString) | Represents method AddXML(AnsiString).
AssignImages(TBitmap,Integer,Integer,TImageList,TImageList) | Represents method AssignImages(TBitmap,Integer,Integer,TImageList,TImageList).
BuildLanguagesList | Represents method BuildLanguagesList.
Clear | Represents method Clear.
Get(String) | Represents method Get(String).
GetDisabledButtonImages | Represents method GetDisabledButtonImages.
GetImages(String,Integer,Integer,Integer) | Represents method GetImages(String,Integer,Integer,Integer).
GetMainButtonImages | Represents method GetMainButtonImages.
GetObjectImages | Represents method GetObjectImages.
GetPreviewButtonImages | Represents method GetPreviewButtonImages.
GetWizardImages | Represents method GetWizardImages.
Help(TObject) | Overloaded. Represents method Help(TObject).
LoadFromFile(String) | Represents method LoadFromFile(String).
LoadFromStream(TStream) | Represents method LoadFromStream(TStream).
ResizeImages | Represents method ResizeImages.
SetButtonImages(TBitmap,Boolean) | Represents method SetButtonImages(TBitmap,Boolean).
SetGlyph(TSpeedButton,Integer) | Represents method SetGlyph(TSpeedButton,Integer).
SetImagesPPI(Integer) | Represents method SetImagesPPI(Integer).
SetObjectImages(TBitmap,Boolean) | Represents method SetObjectImages(TBitmap,Boolean).
SetPreviewButtonImages(TBitmap,Boolean) | Represents method SetPreviewButtonImages(TBitmap,Boolean).
SetWizardImages(TBitmap,Boolean) | Represents method SetWizardImages(TBitmap,Boolean).
UpdateFSResources | Represents method UpdateFSResources.
Top


TfrxResources.Add(String,String) Method

Summary

Represents method Add(String,String).

Namespace: frxRes
Syntax
Delphi
public
 procedure Add(const Ref, Str: String);

Parameters

Ref
Type: String

Str
Type: String

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.AddStrings(String) Method

Summary

Represents method AddStrings(String).

Namespace: frxRes
Syntax
Delphi
public
 procedure AddStrings(const Str: String);

Parameters

Str
Type: String

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.AddW(String,WideString) Method

Summary

Represents method AddW(String,WideString).

Namespace: frxRes
Syntax
Delphi
public
 procedure AddW(const Ref: String; Str: WideString);

Parameters

Ref
Type: String

Str
Type: WideString

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.AddXML(AnsiString) Method

Summary

Represents method AddXML(AnsiString).

Namespace: frxRes
Syntax
Delphi
public
 procedure AddXML(const Str: AnsiString);

Parameters

Str
Type: AnsiString

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.AssignImages(TBitmap,Integer,Integer,TImageList,TImageList) Method

Summary

Represents method AssignImages(TBitmap,Integer,Integer,TImageList,TImageList).

Namespace: frxRes
Syntax
Delphi
private
 procedure AssignImages(Bitmap: TBitmap; dx, dy: Integer; ImgList1: TImageList; ImgList2: TImageList = nil);

Parameters

Bitmap
Type: TBitmap

dx
Type: Integer

dy
Type: Integer

ImgList1
Type: TImageList

ImgList2
Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.BuildLanguagesList Method

Summary

Represents method BuildLanguagesList.

Namespace: frxRes
Syntax
Delphi
private
 procedure BuildLanguagesList;
See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.Clear Method

Summary

Represents method Clear.

Namespace: frxRes
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.Get(String) Method

Summary

Represents method Get(String).

Namespace: frxRes
Syntax
Delphi
public
 function Get(const StrName: String): String;

Parameters

StrName
Type: String

Return Value

Type: String

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.GetDisabledButtonImages Method

Summary

Represents method GetDisabledButtonImages.

Namespace: frxRes
Syntax
Delphi
private
 function GetDisabledButtonImages: TImageList;

Return Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.GetImages(String,Integer,Integer,Integer) Method

Summary

Represents method GetImages(String,Integer,Integer,Integer).

Namespace: frxRes
Syntax
Delphi
private
 function GetImages(const aName: String; aPPIScale: Integer; aImageWidth: Integer = frxDefToolImageWidth; aImageHeight: Integer = frxDefToolImageHeight): TImageList;

Parameters

aName
Type: String

aPPIScale
Type: Integer

aImageWidth
Type: Integer

aImageHeight
Type: Integer

Return Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.GetMainButtonImages Method

Summary

Represents method GetMainButtonImages.

Namespace: frxRes
Syntax
Delphi
private
 function GetMainButtonImages: TImageList;

Return Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.GetObjectImages Method

Summary

Represents method GetObjectImages.

Namespace: frxRes
Syntax
Delphi
private
 function GetObjectImages: TImageList;

Return Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.GetPreviewButtonImages Method

Summary

Represents method GetPreviewButtonImages.

Namespace: frxRes
Syntax
Delphi
private
 function GetPreviewButtonImages: TImageList;

Return Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.GetWizardImages Method

Summary

Represents method GetWizardImages.

Namespace: frxRes
Syntax
Delphi
private
 function GetWizardImages: TImageList;

Return Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.Help(TObject) Method

Summary

Represents method Help(TObject).

Namespace: frxRes
Syntax
Delphi
public
 procedure Help(Sender: TObject); overload;

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.LoadFromFile(String) Method

Summary

Represents method LoadFromFile(String).

Namespace: frxRes
Syntax
Delphi
public
 procedure LoadFromFile(const FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.LoadFromStream(TStream) Method

Summary

Represents method LoadFromStream(TStream).

Namespace: frxRes
Syntax
Delphi
public
 procedure LoadFromStream(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.ResizeImages Method

Summary

Represents method ResizeImages.

Namespace: frxRes
Syntax
Delphi
private
 procedure ResizeImages;
See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.SetButtonImages(TBitmap,Boolean) Method

Summary

Represents method SetButtonImages(TBitmap,Boolean).

Namespace: frxRes
Syntax
Delphi
public
 procedure SetButtonImages(Images: TBitmap; Clear: Boolean = False);

Parameters

Images
Type: TBitmap

Clear
Type: Boolean

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.SetGlyph(TSpeedButton,Integer) Method

Summary

Represents method SetGlyph(TSpeedButton,Integer).

Namespace: frxRes
Syntax
Delphi
public
 procedure SetGlyph(Button: TSpeedButton; Index: Integer);

Parameters

Button
Type: TSpeedButton

Index
Type: Integer

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.SetImagesPPI(Integer) Method

Summary

Represents method SetImagesPPI(Integer).

Namespace: frxRes
Syntax
Delphi
private
 procedure SetImagesPPI(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.SetObjectImages(TBitmap,Boolean) Method

Summary

Represents method SetObjectImages(TBitmap,Boolean).

Namespace: frxRes
Syntax
Delphi
public
 procedure SetObjectImages(Images: TBitmap; Clear: Boolean = False);

Parameters

Images
Type: TBitmap

Clear
Type: Boolean

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.SetPreviewButtonImages(TBitmap,Boolean) Method

Summary

Represents method SetPreviewButtonImages(TBitmap,Boolean).

Namespace: frxRes
Syntax
Delphi
public
 procedure SetPreviewButtonImages(Images: TBitmap; Clear: Boolean = False);

Parameters

Images
Type: TBitmap

Clear
Type: Boolean

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.SetWizardImages(TBitmap,Boolean) Method

Summary

Represents method SetWizardImages(TBitmap,Boolean).

Namespace: frxRes
Syntax
Delphi
public
 procedure SetWizardImages(Images: TBitmap; Clear: Boolean = False);

Parameters

Images
Type: TBitmap

Clear
Type: Boolean

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.UpdateFSResources Method

Summary

Represents method UpdateFSResources.

Namespace: frxRes
Syntax
Delphi
public
 procedure UpdateFSResources;
See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources Fields

Fields
Name | Description
FCP | Represents field FCP.
FDisabledButtonImages | Represents field FDisabledButtonImages.
FHelpFile | Represents field FHelpFile.
FImagesList | Represents field FImagesList.
FImagesPPI | Represents field FImagesPPI.
FLanguages | Represents field FLanguages.
FMainButtonImages | Represents field FMainButtonImages.
FNames | Represents field FNames.
FObjectImages | Represents field FObjectImages.
FPreviewButtonImages | Represents field FPreviewButtonImages.
FValues | Represents field FValues.
FWizardImages | Represents field FWizardImages.
Top


TfrxResources.FCP Field

Summary

Represents field FCP.

Namespace: frxRes
Syntax
Delphi
private
 FCP: Cardinal;

Field Value

Type: Cardinal

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.FDisabledButtonImages Field

Summary

Represents field FDisabledButtonImages.

Namespace: frxRes
Syntax
Delphi
private
 FDisabledButtonImages: TImageList;

Field Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.FHelpFile Field

Summary

Represents field FHelpFile.

Namespace: frxRes
Syntax
Delphi
private
 FHelpFile: String;

Field Value

Type: String

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.FImagesList Field

Summary

Represents field FImagesList.

Namespace: frxRes
Syntax
Delphi
private
 FImagesList: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.FImagesPPI Field

Summary

Represents field FImagesPPI.

Namespace: frxRes
Syntax
Delphi
private
 FImagesPPI: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.FLanguages Field

Summary

Represents field FLanguages.

Namespace: frxRes
Syntax
Delphi
private
 FLanguages: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.FMainButtonImages Field

Summary

Represents field FMainButtonImages.

Namespace: frxRes
Syntax
Delphi
private
 FMainButtonImages: TImageList;

Field Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.FNames Field

Summary

Represents field FNames.

Namespace: frxRes
Syntax
Delphi
private
 FNames: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.FObjectImages Field

Summary

Represents field FObjectImages.

Namespace: frxRes
Syntax
Delphi
private
 FObjectImages: TImageList;

Field Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.FPreviewButtonImages Field

Summary

Represents field FPreviewButtonImages.

Namespace: frxRes
Syntax
Delphi
private
 FPreviewButtonImages: TImageList;

Field Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.FValues Field

Summary

Represents field FValues.

Namespace: frxRes
Syntax
Delphi
private
 FValues: TWideStrings;

Field Value

Type: TWideStrings

See Also

Reference

  • TfrxResources
  • frxRes


TfrxResources.FWizardImages Field

Summary

Represents field FWizardImages.

Namespace: frxRes
Syntax
Delphi
private
 FWizardImages: TImageList;

Field Value

Type: TImageList

See Also

Reference

  • TfrxResources
  • frxRes


frxRes Constants

Constants
Name | Description
frxDefToolImageHeight | Represents constant frxDefToolImageHeight.
frxDefToolImageWidth | Represents constant frxDefToolImageWidth.
Top


frxDefToolImageHeight Constant

Summary

Represents constant frxDefToolImageHeight.

Namespace: frxRes
Syntax
Delphi
 frxDefToolImageHeight = 16;

Value

Type: ShortInt

See Also

Reference

  • frxRes


frxDefToolImageWidth Constant

Summary

Represents constant frxDefToolImageWidth.

Namespace: frxRes
Syntax
Delphi
 frxDefToolImageWidth = 16;

Value

Type: ShortInt

See Also

Reference

  • frxRes


frxRes Routines

Routines
Name | Description
frxGet(Integer) | Represents method frxGet(Integer).
frxResources | Represents method frxResources.
Top


frxGet(Integer) Method

Summary

Represents method frxGet(Integer).

Namespace: frxRes
Syntax
Delphi
function frxGet(ID: Integer): String;

Parameters

ID
Type: Integer

Return Value

Type: String

See Also

Reference

  • frxRes


frxResources Method

Summary

Represents method frxResources.

Namespace: frxRes
Syntax
Delphi
function frxResources: TfrxResources;

Return Value

Type: TfrxResources

See Also

Reference

  • frxRes


frxRich Namespace

Summary

Represents namespace frxRich.

Classes
Name | Description
TfrxRichObject | The TfrxRichObject allows the use of thee RichText component in your report. TfrxRichObject is an empty component. It is used to add the frxRich.pas file to the "uses" list. The main component is TfrxRichView.
TfrxRichView | The TfrxRichView component represents a RichText object. Component uses the RX RichEdit and allows RTF 4.1 text. You can also show RTF text contained in the DB field (you should set DataSet, DataField properties). RTF text may contain expressions.
Top
Routines
Name | Description
frxAssignRich(TRxRichEdit,TRxRichEdit) | Method copies the RichFrom to RichTo RichEdit object.
Top


frxRich Classes

Classes
Name | Description
TfrxRichObject | The TfrxRichObject allows the use of thee RichText component in your report. TfrxRichObject is an empty component. It is used to add the frxRich.pas file to the "uses" list. The main component is TfrxRichView.
TfrxRichView | The TfrxRichView component represents a RichText object. Component uses the RX RichEdit and allows RTF 4.1 text. You can also show RTF text contained in the DB field (you should set DataSet, DataField properties). RTF text may contain expressions.
Top


TfrxRichObject Class

Summary

The TfrxRichObject allows the use of thee RichText component in your report. TfrxRichObject is an empty component. It is used to add the frxRich.pas file to the "uses" list. The main component is TfrxRichView.

Namespace: frxRich
Inheritance Hierarchy
TComponent
frxRich.TfrxRichObject
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxRichObject = class(TComponent)
 end;
See Also

Reference

  • frxRich


TfrxRichView Class

Summary

The TfrxRichView component represents a RichText object. Component uses the RX RichEdit and allows RTF 4.1 text. You can also show RTF text contained in the DB field (you should set DataSet, DataField properties). RTF text may contain expressions.

Namespace: frxRich
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxRich.TfrxRichView
Syntax
Delphi
type
 TfrxRichView = class(TfrxStretcheable)
 end;

The TfrxRichView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxRichView class. (Overrides TfrxStretcheable.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxRichView class. (Overrides TfrxView.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowExpressions | Determines if the RTF text may contain expressions.
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Represents property BrushStyle.
CanShrink | True if object can shrink height base on its content. (Inherited from TfrxStretcheable.)
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
ExpressionDelimiters | Set of symbols, designating the expression. Default value is '[,]'. You can use several symbols, for example '<%,%>'. The opening and closing symbols cannot be similar, so '%,%' will not work.
FileLink | Represents property FileLink.
Fill | Represents property Fill.
FillType | Represents property FillType.
FlowTo | Link to the Rich object that will show the text that not fit in this object.
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GapX | The left indent of the text, in pixels.
GapY | The top indent of the text, in pixels.
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
RichEdit | Reference to internal TrxRichEdit object.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StretchMode | Object's stretch mode. (Inherited from TfrxStretcheable.)
TagStr | Represents property TagStr.
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Represents property URL.
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Wysiwyg | Determines if the object should use the printer canvas to format the text. A printer should be installed and ready.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxView.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxStretcheable.CalcHeight.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateMetafile | Represents method CreateMetafile.
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxStretcheable.DrawPart.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Overrides TfrxReportComponent.GetComponentText.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Overrides TfrxStretcheable.HasNextDataPart(Extended).)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object. (Overrides TfrxStretcheable.InitPart.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Overrides TfrxView.IsEMFExportable.)
IsExprDelimitersStored | Represents method IsExprDelimitersStored.
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadData(TStream) | Represents method ReadData(TStream).
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
UsePrinterCanvas | Represents method UsePrinterCanvas.
WriteData(TStream) | Represents method WriteData(TStream).
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAllowExpressions | Represents field FAllowExpressions.
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FExpressionDelimiters | Represents field FExpressionDelimiters.
FFileLink | Represents field FFileLink.
FFlowTo | Represents field FFlowTo.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FGapX | Represents field FGapX.
FGapY | Represents field FGapY.
FHasNextDataPart | Represents field FHasNextDataPart.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FLastChar | Represents field FLastChar.
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParaBreak | Represents field FParaBreak.
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FRichEdit | Represents field FRichEdit.
FSavedTop | Internal use only. Stores original top during shift operation. (Inherited from TfrxStretcheable.)
FSaveHeight | Internal use only. Stores object Height during stretch operation. (Inherited from TfrxStretcheable.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FStopSplit | Represents field FStopSplit.
FTempStream | Represents field FTempStream.
FTempStream1 | Represents field FTempStream1.
FVC | Represents field FVC. (Inherited from TfrxView.)
FWysiwyg | Represents field FWysiwyg.
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxRich


TfrxRichView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxRichView class. (Overrides TfrxStretcheable.Create(TComponent).)
Destroy | Represents the destructor of the TfrxRichView class. (Overrides TfrxView.Destroy.)
Top


TfrxRichView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxRichView class.

Namespace: frxRich
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxStretcheable.Create(TComponent)
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.Destroy Destructor

Summary

Represents the destructor of the TfrxRichView class.

Namespace: frxRich
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxView.Destroy
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView Properties

Properties
Name | Description
AllowExpressions | Determines if the RTF text may contain expressions.
BrushStyle | Represents property BrushStyle.
Color | Represents property Color.
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
ExpressionDelimiters | Set of symbols, designating the expression. Default value is '[,]'. You can use several symbols, for example '<%,%>'. The opening and closing symbols cannot be similar, so '%,%' will not work.
FileLink | Represents property FileLink.
Fill | Represents property Fill.
FillType | Represents property FillType.
FlowTo | Link to the Rich object that will show the text that not fit in this object.
Frame | Represents property Frame.
GapX | The left indent of the text, in pixels.
GapY | The top indent of the text, in pixels.
RichEdit | Reference to internal TrxRichEdit object.
TagStr | Represents property TagStr.
URL | Represents property URL.
Wysiwyg | Determines if the object should use the printer canvas to format the text. A printer should be installed and ready.
Top


TfrxRichView.AllowExpressions Property

Summary

Determines if the RTF text may contain expressions.

Namespace: frxRich
Syntax
Delphi
published
 property AllowExpressions: Boolean read FAllowExpressions
 write FAllowExpressions default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.BrushStyle Property

Summary

Represents property BrushStyle.

Namespace: frxRich
Syntax
Delphi
published
 property BrushStyle;

Property Value

Type: Void

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.Color Property

Summary

Represents property Color.

Namespace: frxRich
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.Cursor Property

Summary

Represents property Cursor.

Namespace: frxRich
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.DataField Property

Summary

Represents property DataField.

Namespace: frxRich
Syntax
Delphi
published
 property DataField;

Property Value

Type: Void

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.DataSet Property

Summary

Represents property DataSet.

Namespace: frxRich
Syntax
Delphi
published
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxRich
Syntax
Delphi
published
 property DataSetName;

Property Value

Type: Void

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.ExpressionDelimiters Property

Summary

Set of symbols, designating the expression. Default value is '[,]'. You can use several symbols, for example '<%,%>'. The opening and closing symbols cannot be similar, so '%,%' will not work.

Namespace: frxRich
Syntax
Delphi
published
 property ExpressionDelimiters: String read FExpressionDelimiters
 write FExpressionDelimiters stored IsExprDelimitersStored;

Property Value

Type: String

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FileLink Property

Summary

Represents property FileLink.

Namespace: frxRich
Syntax
Delphi
published
 property FileLink: String read FFileLink write FFileLink;

Property Value

Type: String

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.Fill Property

Summary

Represents property Fill.

Namespace: frxRich
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FillType Property

Summary

Represents property FillType.

Namespace: frxRich
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FlowTo Property

Summary

Link to the Rich object that will show the text that not fit in this object.

Namespace: frxRich
Syntax
Delphi
published
 property FlowTo: TfrxRichView read FFlowTo write FFlowTo;

Property Value

Type: TfrxRichView

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.Frame Property

Summary

Represents property Frame.

Namespace: frxRich
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.GapX Property

Summary

The left indent of the text, in pixels.

Namespace: frxRich
Syntax
Delphi
published
 property GapX: Extended read FGapX write FGapX;

Property Value

Type: Extended

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.GapY Property

Summary

The top indent of the text, in pixels.

Namespace: frxRich
Syntax
Delphi
published
 property GapY: Extended read FGapY write FGapY;

Property Value

Type: Extended

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.RichEdit Property

Summary

Reference to internal TrxRichEdit object.

Namespace: frxRich
Syntax
Delphi
public
 property RichEdit: TrxRichEdit read FRichEdit;

Property Value

Type: TrxRichEdit

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.TagStr Property

Summary

Represents property TagStr.

Namespace: frxRich
Syntax
Delphi
published
 property TagStr;

Property Value

Type: Void

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.URL Property

Summary

Represents property URL.

Namespace: frxRich
Syntax
Delphi
published
 property URL;

Property Value

Type: Void

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.Wysiwyg Property

Summary

Determines if the object should use the printer canvas to format the text. A printer should be installed and ready.

Namespace: frxRich
Syntax
Delphi
published
 property Wysiwyg: Boolean read FWysiwyg write FWysiwyg default True;

Property Value

Type: Boolean

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView Methods

Methods
Name | Description
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxView.AfterPrint.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxStretcheable.CalcHeight.)
CreateMetafile | Represents method CreateMetafile.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxStretcheable.DrawPart.)
GetComponentText | Returns text of the report object. Used in export filters. (Overrides TfrxReportComponent.GetComponentText.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Overrides TfrxStretcheable.HasNextDataPart(Extended).)
InitPart | Initialize part of Splittable object. (Overrides TfrxStretcheable.InitPart.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Overrides TfrxView.IsEMFExportable.)
IsExprDelimitersStored | Represents method IsExprDelimitersStored.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ReadData(TStream) | Represents method ReadData(TStream).
UsePrinterCanvas | Represents method UsePrinterCanvas.
WriteData(TStream) | Represents method WriteData(TStream).
Top


TfrxRichView.AfterPrint Method

Summary

The report engine calls this method after object was prepared and placed to preview pages.

Namespace: frxRich
Syntax
Delphi
public
 procedure AfterPrint; override;

Overrides

TfrxView.AfterPrint
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.BeforePrint Method

Summary

The report engine calls this method before prepare object and place it to preview pages.

Namespace: frxRich
Syntax
Delphi
public
 procedure BeforePrint; override;

Overrides

TfrxView.BeforePrint
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.CalcHeight Method

Summary

Calculates and returns the object's height according to the data placed in it.

Namespace: frxRich
Syntax
Delphi
public
 function CalcHeight: Extended; override;

Return Value

Type: Extended

Overrides

TfrxStretcheable.CalcHeight
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.CreateMetafile Method

Summary

Represents method CreateMetafile.

Namespace: frxRich
Syntax
Delphi
private
 function CreateMetafile: TMetafile;

Return Value

Type: TMetafile

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxRich
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxRich
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.DrawPart Method

Summary

Objects part drawing function , if the object is splittable.

Namespace: frxRich
Syntax
Delphi
public
 function DrawPart: Extended; override;

Return Value

Type: Extended

Overrides

TfrxStretcheable.DrawPart
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.GetComponentText Method

Summary

Returns text of the report object. Used in export filters.

Namespace: frxRich
Syntax
Delphi
public
 function GetComponentText: String; override;

Return Value

Type: String

Overrides

TfrxReportComponent.GetComponentText
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxRich
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxRich
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.HasNextDataPart(Extended) Method

Summary

Returns True if object has a part to draw on a new page.

Namespace: frxRich
Syntax
Delphi
public
 function HasNextDataPart(aFreeSpace: Extended): Boolean; override;

Parameters

aFreeSpace
Type: Extended

Free space on current page.

Return Value

Type: Boolean

Overrides

TfrxStretcheable.HasNextDataPart(Extended)
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.InitPart Method

Summary

Initialize part of Splittable object.

Namespace: frxRich
Syntax
Delphi
public
 procedure InitPart; override;

Overrides

TfrxStretcheable.InitPart
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.IsEMFExportable Method

Summary

Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported).

Namespace: frxRich
Syntax
Delphi
public
 function IsEMFExportable: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxView.IsEMFExportable
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.IsExprDelimitersStored Method

Summary

Represents method IsExprDelimitersStored.

Namespace: frxRich
Syntax
Delphi
private
 function IsExprDelimitersStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: frxRich
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

Overrides

TfrxView.Notification(TComponent,TOperation)
See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.ReadData(TStream) Method

Summary

Represents method ReadData(TStream).

Namespace: frxRich
Syntax
Delphi
private
 procedure ReadData(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.UsePrinterCanvas Method

Summary

Represents method UsePrinterCanvas.

Namespace: frxRich
Syntax
Delphi
private
 function UsePrinterCanvas: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.WriteData(TStream) Method

Summary

Represents method WriteData(TStream).

Namespace: frxRich
Syntax
Delphi
private
 procedure WriteData(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView Fields

Fields
Name | Description
FAllowExpressions | Represents field FAllowExpressions.
FExpressionDelimiters | Represents field FExpressionDelimiters.
FFileLink | Represents field FFileLink.
FFlowTo | Represents field FFlowTo.
FGapX | Represents field FGapX.
FGapY | Represents field FGapY.
FHasNextDataPart | Represents field FHasNextDataPart.
FLastChar | Represents field FLastChar.
FParaBreak | Represents field FParaBreak.
FRichEdit | Represents field FRichEdit.
FStopSplit | Represents field FStopSplit.
FTempStream | Represents field FTempStream.
FTempStream1 | Represents field FTempStream1.
FWysiwyg | Represents field FWysiwyg.
Top


TfrxRichView.FAllowExpressions Field

Summary

Represents field FAllowExpressions.

Namespace: frxRich
Syntax
Delphi
private
 FAllowExpressions: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FExpressionDelimiters Field

Summary

Represents field FExpressionDelimiters.

Namespace: frxRich
Syntax
Delphi
private
 FExpressionDelimiters: String;

Field Value

Type: String

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FFileLink Field

Summary

Represents field FFileLink.

Namespace: frxRich
Syntax
Delphi
private
 FFileLink: String;

Field Value

Type: String

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FFlowTo Field

Summary

Represents field FFlowTo.

Namespace: frxRich
Syntax
Delphi
private
 FFlowTo: TfrxRichView;

Field Value

Type: TfrxRichView

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FGapX Field

Summary

Represents field FGapX.

Namespace: frxRich
Syntax
Delphi
private
 FGapX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FGapY Field

Summary

Represents field FGapY.

Namespace: frxRich
Syntax
Delphi
private
 FGapY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FHasNextDataPart Field

Summary

Represents field FHasNextDataPart.

Namespace: frxRich
Syntax
Delphi
private
 FHasNextDataPart: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FLastChar Field

Summary

Represents field FLastChar.

Namespace: frxRich
Syntax
Delphi
private
 FLastChar: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FParaBreak Field

Summary

Represents field FParaBreak.

Namespace: frxRich
Syntax
Delphi
private
 FParaBreak: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FRichEdit Field

Summary

Represents field FRichEdit.

Namespace: frxRich
Syntax
Delphi
private
 FRichEdit: TrxRichEdit;

Field Value

Type: TrxRichEdit

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FStopSplit Field

Summary

Represents field FStopSplit.

Namespace: frxRich
Syntax
Delphi
private
 FStopSplit: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FTempStream Field

Summary

Represents field FTempStream.

Namespace: frxRich
Syntax
Delphi
private
 FTempStream: TMemoryStream;

Field Value

Type: TMemoryStream

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FTempStream1 Field

Summary

Represents field FTempStream1.

Namespace: frxRich
Syntax
Delphi
private
 FTempStream1: TMemoryStream;

Field Value

Type: TMemoryStream

See Also

Reference

  • TfrxRichView
  • frxRich


TfrxRichView.FWysiwyg Field

Summary

Represents field FWysiwyg.

Namespace: frxRich
Syntax
Delphi
private
 FWysiwyg: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxRichView
  • frxRich


frxRich Routines

Routines
Name | Description
frxAssignRich(TRxRichEdit,TRxRichEdit) | Method copies the RichFrom to RichTo RichEdit object.
Top


frxAssignRich(TRxRichEdit,TRxRichEdit) Method

Summary

Method copies the RichFrom to RichTo RichEdit object.

Namespace: frxRich
Syntax
Delphi
 procedure frxAssignRich(RichFrom, RichTo: TrxRichEdit);

Parameters

RichFrom
Type: TrxRichEdit

RichTo
Type: TrxRichEdit

See Also

Reference

  • frxRich


frxRichEdit Namespace

Summary

Represents namespace frxRichEdit.

Classes
Name | Description
TOEMConversion | Represents type TOEMConversion.
TRxCustomRichEdit | Represents type TRxCustomRichEdit.
TRxParaAttributes | Represents type TRxParaAttributes.
TRxRichEdit | Represents type TRxRichEdit.
TRxTextAttributes | Represents type TRxTextAttributes.
Top
Records
Name | Description
TCharFormat2A | Represents type TCharFormat2A.
TParaFormat2 | Represents type TParaFormat2.
TRichConversionFormat | Represents type TRichConversionFormat.
Top
Enumerations
Name | Description
TLineSpacingRule | Represents type TLineSpacingRule.
TParaAlignment | Represents type TParaAlignment.
TParaTableStyle | Represents type TParaTableStyle.
TRichLangOption | Represents type TRichLangOption.
TRichSearchType | Represents type TRichSearchType.
TRichSelection | Represents type TRichSelection.
TRichStreamFormat | Represents type TRichStreamFormat.
TRichStreamMode | Represents type TRichStreamMode.
TRxAttributeType | Represents type TRxAttributeType.
TRxConsistentAttribute | Represents type TRxConsistentAttribute.
TRxNumbering | Represents type TRxNumbering.
TRxNumberingStyle | Represents type TRxNumberingStyle.
TSubscriptStyle | Represents type TSubscriptStyle.
TUnderlineType | Represents type TUnderlineType.
TUndoName | Represents type TUndoName.
Top
Delegates
Name | Description
TRichEditFindCloseEvent | Represents type TRichEditFindCloseEvent.
TRichEditFindErrorEvent | Represents type TRichEditFindErrorEvent.
TRichEditProtectChangeEx | Represents type TRichEditProtectChangeEx.
TRichEditURLClickEvent | Represents type TRichEditURLClickEvent.
Top
Types
Name | Description
frxInteger | Represents an alias of the NativeInt type.
PRichConversionFormat | Represents a pointer type to TRichConversionFormat.
TCharFormat2 | Represents an alias of the TCharFormat2A type.
THeadingStyle | Represents type THeadingStyle.
TRichEditVersion | Represents type TRichEditVersion.
TRichLangOptions | Represents type TRichLangOptions.
TRichSearchTypes | Represents type TRichSearchTypes.
TRichSelectionType | Represents type TRichSelectionType.
TRichStreamModes | Represents type TRichStreamModes.
TRxConsistentAttributes | Represents type TRxConsistentAttributes.
Top
Variables
Name | Description
IsWin10 | Represents variable IsWin10.
IsWin8 | Represents variable IsWin8.
RichEditVersion | Represents variable RichEditVersion.
Top


frxRichEdit Classes

Classes
Name | Description
TOEMConversion | Represents type TOEMConversion.
TRxCustomRichEdit | Represents type TRxCustomRichEdit.
TRxParaAttributes | Represents type TRxParaAttributes.
TRxRichEdit | Represents type TRxRichEdit.
TRxTextAttributes | Represents type TRxTextAttributes.
Top


TOEMConversion Class

Summary

Represents type TOEMConversion.

Namespace: frxRichEdit
Inheritance Hierarchy
TConversion
frxRichEdit.TOEMConversion
Syntax
Delphi
type
 TOEMConversion = class(TConversion)
 end;

The TOEMConversion type exposes the following members.

Methods
Show:
Name | Description
ConvertReadStream(TStream,TBytes,Integer) | Represents method ConvertReadStream(TStream,TBytes,Integer).
ConvertWriteStream(TStream,TBytes,Integer) | Represents method ConvertWriteStream(TStream,TBytes,Integer).
Top
See Also

Reference

  • frxRichEdit


TOEMConversion Methods

Methods
Name | Description
ConvertReadStream(TStream,TBytes,Integer) | Represents method ConvertReadStream(TStream,TBytes,Integer).
ConvertWriteStream(TStream,TBytes,Integer) | Represents method ConvertWriteStream(TStream,TBytes,Integer).
Top


TOEMConversion.ConvertReadStream(TStream,TBytes,Integer) Method

Summary

Represents method ConvertReadStream(TStream,TBytes,Integer).

Namespace: frxRichEdit
Syntax
Delphi
public
 function ConvertReadStream(Stream: TStream; Buffer: TBytes; BufSize: Integer): Integer; override;

Parameters

Stream
Type: TStream

Buffer
Type: TBytes

BufSize
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TOEMConversion
  • frxRichEdit


TOEMConversion.ConvertWriteStream(TStream,TBytes,Integer) Method

Summary

Represents method ConvertWriteStream(TStream,TBytes,Integer).

Namespace: frxRichEdit
Syntax
Delphi
public
 function ConvertWriteStream(Stream: TStream; Buffer: TBytes; BufSize: Integer): Integer; override;

Parameters

Stream
Type: TStream

Buffer
Type: TBytes

BufSize
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TOEMConversion
  • frxRichEdit


TRxCustomRichEdit Class

Summary

Represents type TRxCustomRichEdit.

Namespace: frxRichEdit
Inheritance Hierarchy
TCustomMemo
frxRichEdit.TRxCustomRichEdit
frxRichEdit.TRxRichEdit
Syntax
Delphi
type
 TRxCustomRichEdit = class(TCustomMemo)
 end;

The TRxCustomRichEdit type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TRxCustomRichEdit class.
Destroy | Represents the destructor of the TRxCustomRichEdit class.
Top
Properties
Show:
Name | Description
AllowInPlace | Represents property AllowInPlace.
AllowObjects | Represents property AllowObjects.
AutoURLDetect | Represents property AutoURLDetect.
AutoVerbMenu | Represents property AutoVerbMenu.
CanFindNext | Represents property CanFindNext.
CanPaste | Represents property CanPaste.
CanRedo | Represents property CanRedo.
DefAttributes | Represents property DefAttributes.
DefaultConverter | Represents property DefaultConverter.
HideScrollBars | Represents property HideScrollBars.
HideSelection | Represents property HideSelection.
LangOptions | Represents property LangOptions.
Lines | Represents property Lines.
OnProtectChange | Represents property OnProtectChange.
OnResizeRequest | Represents property OnResizeRequest.
OnSaveClipboard | Represents property OnSaveClipboard.
OnSelectionChange | Represents property OnSelectionChange.
PageRect | Represents property PageRect.
Paragraph | Represents property Paragraph.
PlainText | Represents property PlainText.
RedoName | Represents property RedoName.
ScrollBars | Represents property ScrollBars.
SelAttributes | Represents property SelAttributes.
SelectionBar | Represents property SelectionBar.
SelectionType | Represents property SelectionType.
StreamFormat | Represents property StreamFormat.
StreamMode | Represents property StreamMode.
TabStop | Represents property TabStop.
Title | Represents property Title.
UndoLimit | Represents property UndoLimit.
UndoName | Represents property UndoName.
WordAttributes | Represents property WordAttributes.
WordSelection | Represents property WordSelection.
Top
Methods
Show:
Name | Description
AdjustFindDialogPosition(TFindDialog) | Represents method AdjustFindDialogPosition(TFindDialog).
Clear | Represents method Clear.
ClearUndo | Represents method ClearUndo.
CloseFindDialog(TFindDialog) | Represents method CloseFindDialog(TFindDialog).
CloseObjects | Represents method CloseObjects.
CMBiDiModeChanged(TMessage) | Represents method CMBiDiModeChanged(TMessage).
CMColorChanged(TMessage) | Represents method CMColorChanged(TMessage).
CMDocWindowActivate(TMessage) | Represents method CMDocWindowActivate(TMessage).
CMFontChanged(TMessage) | Represents method CMFontChanged(TMessage).
CMUIDeactivate(TMessage) | Represents method CMUIDeactivate(TMessage).
CNNotify(TWMNotify) | Represents method CNNotify(TWMNotify).
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams).
CreateWindowHandle(TCreateParams) | Represents method CreateWindowHandle(TCreateParams).
CreateWnd | Represents method CreateWnd.
DestroyWnd | Represents method DestroyWnd.
DoPerformSynchMessage | Represents method DoPerformSynchMessage.
DoSendSynchMessage | Represents method DoSendSynchMessage.
DoSetMaxLength(Integer) | Represents method DoSetMaxLength(Integer).
EMReplaceSel(TMessage) | Represents method EMReplaceSel(TMessage).
FindDialog(string) | Represents method FindDialog(string).
FindDialogClose(TObject) | Represents method FindDialogClose(TObject).
FindDialogFind(TObject) | Represents method FindDialogFind(TObject).
FindEditText(TFindDialog,Boolean,Boolean) | Represents method FindEditText(TFindDialog,Boolean,Boolean).
FindNext | Represents method FindNext.
FindText(string,Integer,Integer,TRichSearchTypes) | Represents method FindText(string,Integer,Integer,TRichSearchTypes).
GetAutoURLDetect | Represents method GetAutoURLDetect.
GetCanFindNext | Represents method GetCanFindNext.
GetCanPaste | Represents method GetCanPaste.
GetCanRedo | Represents method GetCanRedo.
GetCaretPos | Represents method GetCaretPos.
GetCharPos(Integer) | Represents method GetCharPos(Integer).
GetLangOptions | Represents method GetLangOptions.
GetLineIndex(Integer) | Represents method GetLineIndex(Integer).
GetLineLength(Integer) | Represents method GetLineLength(Integer).
GetPopupMenu | Represents method GetPopupMenu.
GetRedoName | Represents method GetRedoName.
GetSelection | Represents method GetSelection.
GetSelectionType | Represents method GetSelectionType.
GetSelLength | Represents method GetSelLength.
GetSelStart | Represents method GetSelStart.
GetSelText | Represents method GetSelText.
GetSelTextBuf(PChar,Integer) | Represents method GetSelTextBuf(PChar,Integer).
GetStreamFormat | Represents method GetStreamFormat.
GetStreamMode | Represents method GetStreamMode.
GetTextLen | Represents method GetTextLen.
GetTextRange(Longint,Longint) | Represents method GetTextRange(Longint,Longint).
GetUndoName | Represents method GetUndoName.
GetWordSelection | Represents method GetWordSelection.
InsertObjectDialog | Represents method InsertObjectDialog.
LineFromChar(Integer) | Represents method LineFromChar(Integer).
ObjectPropertiesDialog | Represents method ObjectPropertiesDialog.
ObjectPropsClick(TObject) | Represents method ObjectPropsClick(TObject).
PasteSpecialDialog | Represents method PasteSpecialDialog.
PopupVerbClick(TObject) | Represents method PopupVerbClick(TObject).
Print(string) | Represents method Print(string).
ProtectChange(TMessage,Integer,Integer) | Represents method ProtectChange(TMessage,Integer,Integer).
Redo | Represents method Redo.
RegisterConversionFormat(string,Boolean,TConversionClass) | Represents method RegisterConversionFormat(string,Boolean,TConversionClass).
ReplaceDialog(string,string) | Represents method ReplaceDialog(string,string).
ReplaceDialogReplace(TObject) | Represents method ReplaceDialogReplace(TObject).
RequestSize(TRect) | Represents method RequestSize(TRect).
SaveClipboard(Integer,Integer) | Represents method SaveClipboard(Integer,Integer).
SelectionChange | Represents method SelectionChange.
SendSynchMessage(UINT,WPARAM,LPARAM,Boolean) | Represents method SendSynchMessage(UINT,WPARAM,LPARAM,Boolean).
SetAllowObjects(Boolean) | Represents method SetAllowObjects(Boolean).
SetAutoURLDetect(Boolean) | Represents method SetAutoURLDetect(Boolean).
SetDefAttributes(TRxTextAttributes) | Represents method SetDefAttributes(TRxTextAttributes).
SetHideScrollBars(Boolean) | Represents method SetHideScrollBars(Boolean).
SetHideSelection(Boolean) | Represents method SetHideSelection(Boolean).
SetLangOptions(TRichLangOptions) | Represents method SetLangOptions(TRichLangOptions).
SetPlainText(Boolean) | Represents method SetPlainText(Boolean).
SetRichEditStrings(TStrings) | Represents method SetRichEditStrings(TStrings).
SetSelAttributes(TRxTextAttributes) | Represents method SetSelAttributes(TRxTextAttributes).
SetSelection(Longint,Longint,Boolean) | Represents method SetSelection(Longint,Longint,Boolean).
SetSelectionBar(Boolean) | Represents method SetSelectionBar(Boolean).
SetSelLength(Integer) | Represents method SetSelLength(Integer).
SetSelStart(Integer) | Represents method SetSelStart(Integer).
SetStreamFormat(TRichStreamFormat) | Represents method SetStreamFormat(TRichStreamFormat).
SetStreamMode(TRichStreamModes) | Represents method SetStreamMode(TRichStreamModes).
SetTitle(string) | Represents method SetTitle(string).
SetUIActive(Boolean) | Represents method SetUIActive(Boolean).
SetUndoLimit(Integer) | Represents method SetUndoLimit(Integer).
SetupFindDialog(TFindDialog,string,string) | Represents method SetupFindDialog(TFindDialog,string,string).
SetWordAttributes(TRxTextAttributes) | Represents method SetWordAttributes(TRxTextAttributes).
SetWordSelection(Boolean) | Represents method SetWordSelection(Boolean).
StopGroupTyping | Represents method StopGroupTyping.
TextNotFound(TFindDialog) | Represents method TextNotFound(TFindDialog).
UpdateHostNames | Represents method UpdateHostNames.
UpdateTextModes(Boolean) | Represents method UpdateTextModes(Boolean).
URLClick(string,TMouseButton) | Represents method URLClick(string,TMouseButton).
WMDestroy(TWMDestroy) | Represents method WMDestroy(TWMDestroy).
WMMouseMove(TMessage) | Represents method WMMouseMove(TMessage).
WMPaint(TWMPaint) | Represents method WMPaint(TWMPaint).
WMRButtonUp(TMessage) | Represents method WMRButtonUp(TMessage).
WMSetCursor(TWMSetCursor) | Represents method WMSetCursor(TWMSetCursor).
WMSetFont(TWMSetFont) | Represents method WMSetFont(TWMSetFont).
WordAtCursor | Represents method WordAtCursor.
Top
Events
Show:
Name | Description
OnCloseFindDialog | Represents property OnCloseFindDialog.
OnProtectChangeEx | Represents property OnProtectChangeEx.
OnTextNotFound | Represents property OnTextNotFound.
OnURLClick | Represents property OnURLClick.
Top
Fields
Show:
Name | Description
FAllowInPlace | Represents field FAllowInPlace.
FAllowObjects | Represents field FAllowObjects.
FAutoURLDetect | Represents field FAutoURLDetect.
FAutoVerbMenu | Represents field FAutoVerbMenu.
FCallback | Represents field FCallback.
FClickBtn | Represents field FClickBtn.
FClickRange | Represents field FClickRange.
FDefAttributes | Represents field FDefAttributes.
FDefaultConverter | Represents field FDefaultConverter.
FFindDialog | Represents field FFindDialog.
FHideScrollBars | Represents field FHideScrollBars.
FHideSelection | Represents field FHideSelection.
FLangOptions | Represents field FLangOptions.
FLastFind | Represents field FLastFind.
FLinesUpdating | Represents field FLinesUpdating.
FLparam | Represents field FLparam.
FLResult | Represents field FLResult.
FMemStream | Represents field FMemStream.
FModified | Represents field FModified.
FMsg | Represents field FMsg.
FNotMainThread | Represents field FNotMainThread.
FOldParaAlignment | Represents field FOldParaAlignment.
FOnCloseFindDialog | Represents field FOnCloseFindDialog.
FOnProtectChange | Represents field FOnProtectChange.
FOnProtectChangeEx | Represents field FOnProtectChangeEx.
FOnResizeRequest | Represents field FOnResizeRequest.
FOnSaveClipboard | Represents field FOnSaveClipboard.
FOnSelChange | Represents field FOnSelChange.
FOnTextNotFound | Represents field FOnTextNotFound.
FOnURLClick | Represents field FOnURLClick.
FPageRect | Represents field FPageRect.
FParagraph | Represents field FParagraph.
FPlainText | Represents field FPlainText.
FPopupVerbMenu | Represents field FPopupVerbMenu.
FReplaceDialog | Represents field FReplaceDialog.
FRichEditOle | Represents field FRichEditOle.
FRichEditStrings | Represents field FRichEditStrings.
FScreenLogPixels | Represents field FScreenLogPixels.
FSelAttributes | Represents field FSelAttributes.
FSelectionBar | Represents field FSelectionBar.
FTitle | Represents field FTitle.
FUndoLimit | Represents field FUndoLimit.
FWordAttributes | Represents field FWordAttributes.
FWordSelection | Represents field FWordSelection.
FWparam | Represents field FWparam.
Top
See Also

Reference

  • frxRichEdit


TRxCustomRichEdit Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TRxCustomRichEdit class.
Destroy | Represents the destructor of the TRxCustomRichEdit class.
Top


TRxCustomRichEdit.Create(TComponent) Constructor

Summary

Initializes a new instance of the TRxCustomRichEdit class.

Namespace: frxRichEdit
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.Destroy Destructor

Summary

Represents the destructor of the TRxCustomRichEdit class.

Namespace: frxRichEdit
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit Properties

Properties
Name | Description
AllowInPlace | Represents property AllowInPlace.
AllowObjects | Represents property AllowObjects.
AutoURLDetect | Represents property AutoURLDetect.
AutoVerbMenu | Represents property AutoVerbMenu.
CanFindNext | Represents property CanFindNext.
CanPaste | Represents property CanPaste.
CanRedo | Represents property CanRedo.
DefAttributes | Represents property DefAttributes.
DefaultConverter | Represents property DefaultConverter.
HideScrollBars | Represents property HideScrollBars.
HideSelection | Represents property HideSelection.
LangOptions | Represents property LangOptions.
Lines | Represents property Lines.
OnProtectChange | Represents property OnProtectChange.
OnResizeRequest | Represents property OnResizeRequest.
OnSaveClipboard | Represents property OnSaveClipboard.
OnSelectionChange | Represents property OnSelectionChange.
PageRect | Represents property PageRect.
Paragraph | Represents property Paragraph.
PlainText | Represents property PlainText.
RedoName | Represents property RedoName.
ScrollBars | Represents property ScrollBars.
SelAttributes | Represents property SelAttributes.
SelectionBar | Represents property SelectionBar.
SelectionType | Represents property SelectionType.
StreamFormat | Represents property StreamFormat.
StreamMode | Represents property StreamMode.
TabStop | Represents property TabStop.
Title | Represents property Title.
UndoLimit | Represents property UndoLimit.
UndoName | Represents property UndoName.
WordAttributes | Represents property WordAttributes.
WordSelection | Represents property WordSelection.
Top


TRxCustomRichEdit.AllowInPlace Property

Summary

Represents property AllowInPlace.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property AllowInPlace: Boolean read FAllowInPlace write FAllowInPlace default True;

Property Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.AllowObjects Property

Summary

Represents property AllowObjects.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property AllowObjects: Boolean read FAllowObjects write SetAllowObjects default True;

Property Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.AutoURLDetect Property

Summary

Represents property AutoURLDetect.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property AutoURLDetect: Boolean read GetAutoURLDetect write SetAutoURLDetect default True;

Property Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.AutoVerbMenu Property

Summary

Represents property AutoVerbMenu.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property AutoVerbMenu: Boolean read FAutoVerbMenu write FAutoVerbMenu default True;

Property Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CanFindNext Property

Summary

Represents property CanFindNext.

Namespace: frxRichEdit
Syntax
Delphi
public
 property CanFindNext: Boolean read GetCanFindNext;

Property Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CanPaste Property

Summary

Represents property CanPaste.

Namespace: frxRichEdit
Syntax
Delphi
public
 property CanPaste: Boolean read GetCanPaste;

Property Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CanRedo Property

Summary

Represents property CanRedo.

Namespace: frxRichEdit
Syntax
Delphi
public
 property CanRedo: Boolean read GetCanRedo;

Property Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.DefAttributes Property

Summary

Represents property DefAttributes.

Namespace: frxRichEdit
Syntax
Delphi
public
 property DefAttributes: TRxTextAttributes read FDefAttributes write SetDefAttributes;

Property Value

Type: TRxTextAttributes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.DefaultConverter Property

Summary

Represents property DefaultConverter.

Namespace: frxRichEdit
Syntax
Delphi
public
 property DefaultConverter: TConversionClass read FDefaultConverter
 write FDefaultConverter;

Property Value

Type: TConversionClass

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.HideScrollBars Property

Summary

Represents property HideScrollBars.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property HideScrollBars: Boolean read FHideScrollBars
 write SetHideScrollBars default True;

Property Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.HideSelection Property

Summary

Represents property HideSelection.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property HideSelection: Boolean read FHideSelection write SetHideSelection default True;

Property Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.LangOptions Property

Summary

Represents property LangOptions.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property LangOptions: TRichLangOptions read GetLangOptions write SetLangOptions default [rlAutoFont];

Property Value

Type: TRichLangOptions

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.Lines Property

Summary

Represents property Lines.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property Lines: TStrings read FRichEditStrings write SetRichEditStrings;

Property Value

Type: TStrings

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.OnProtectChange Property

Summary

Represents property OnProtectChange.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property OnProtectChange: TRichEditProtectChange read FOnProtectChange
 write FOnProtectChange;

Property Value

Type: TRichEditProtectChange

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.OnResizeRequest Property

Summary

Represents property OnResizeRequest.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property OnResizeRequest: TRichEditResizeEvent read FOnResizeRequest
 write FOnResizeRequest;

Property Value

Type: TRichEditResizeEvent

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.OnSaveClipboard Property

Summary

Represents property OnSaveClipboard.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property OnSaveClipboard: TRichEditSaveClipboard read FOnSaveClipboard
 write FOnSaveClipboard;

Property Value

Type: TRichEditSaveClipboard

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.OnSelectionChange Property

Summary

Represents property OnSelectionChange.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property OnSelectionChange: TNotifyEvent read FOnSelChange write FOnSelChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.PageRect Property

Summary

Represents property PageRect.

Namespace: frxRichEdit
Syntax
Delphi
public
 property PageRect: TRect read FPageRect write FPageRect;

Property Value

Type: TRect

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.Paragraph Property

Summary

Represents property Paragraph.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Paragraph: TRxParaAttributes read FParagraph;

Property Value

Type: TRxParaAttributes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.PlainText Property

Summary

Represents property PlainText.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property PlainText: Boolean read FPlainText write SetPlainText default False;

Property Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.RedoName Property

Summary

Represents property RedoName.

Namespace: frxRichEdit
Syntax
Delphi
public
 property RedoName: TUndoName read GetRedoName;

Property Value

Type: TUndoName

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.ScrollBars Property

Summary

Represents property ScrollBars.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property ScrollBars default ssBoth;

Property Value

Type: Void

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SelAttributes Property

Summary

Represents property SelAttributes.

Namespace: frxRichEdit
Syntax
Delphi
public
 property SelAttributes: TRxTextAttributes read FSelAttributes write SetSelAttributes;

Property Value

Type: TRxTextAttributes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SelectionBar Property

Summary

Represents property SelectionBar.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property SelectionBar: Boolean read FSelectionBar write SetSelectionBar default True;

Property Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SelectionType Property

Summary

Represents property SelectionType.

Namespace: frxRichEdit
Syntax
Delphi
public
 property SelectionType: TRichSelectionType read GetSelectionType;

Property Value

Type: TRichSelectionType

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.StreamFormat Property

Summary

Represents property StreamFormat.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property StreamFormat: TRichStreamFormat read GetStreamFormat write SetStreamFormat default sfDefault;

Property Value

Type: TRichStreamFormat

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.StreamMode Property

Summary

Represents property StreamMode.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property StreamMode: TRichStreamModes read GetStreamMode write SetStreamMode default [];

Property Value

Type: TRichStreamModes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.TabStop Property

Summary

Represents property TabStop.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property TabStop default True;

Property Value

Type: Void

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.Title Property

Summary

Represents property Title.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property Title: string read FTitle write SetTitle;

Property Value

Type: string

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.UndoLimit Property

Summary

Represents property UndoLimit.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property UndoLimit: Integer read FUndoLimit write SetUndoLimit default 100;

Property Value

Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.UndoName Property

Summary

Represents property UndoName.

Namespace: frxRichEdit
Syntax
Delphi
public
 property UndoName: TUndoName read GetUndoName;

Property Value

Type: TUndoName

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.WordAttributes Property

Summary

Represents property WordAttributes.

Namespace: frxRichEdit
Syntax
Delphi
public
 property WordAttributes: TRxTextAttributes read FWordAttributes write SetWordAttributes;

Property Value

Type: TRxTextAttributes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.WordSelection Property

Summary

Represents property WordSelection.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property WordSelection: Boolean read GetWordSelection write SetWordSelection default True;

Property Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit Methods

Methods
Name | Description
AdjustFindDialogPosition(TFindDialog) | Represents method AdjustFindDialogPosition(TFindDialog).
Clear | Represents method Clear.
ClearUndo | Represents method ClearUndo.
CloseFindDialog(TFindDialog) | Represents method CloseFindDialog(TFindDialog).
CloseObjects | Represents method CloseObjects.
CMBiDiModeChanged(TMessage) | Represents method CMBiDiModeChanged(TMessage).
CMColorChanged(TMessage) | Represents method CMColorChanged(TMessage).
CMDocWindowActivate(TMessage) | Represents method CMDocWindowActivate(TMessage).
CMFontChanged(TMessage) | Represents method CMFontChanged(TMessage).
CMUIDeactivate(TMessage) | Represents method CMUIDeactivate(TMessage).
CNNotify(TWMNotify) | Represents method CNNotify(TWMNotify).
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams).
CreateWindowHandle(TCreateParams) | Represents method CreateWindowHandle(TCreateParams).
CreateWnd | Represents method CreateWnd.
DestroyWnd | Represents method DestroyWnd.
DoPerformSynchMessage | Represents method DoPerformSynchMessage.
DoSendSynchMessage | Represents method DoSendSynchMessage.
DoSetMaxLength(Integer) | Represents method DoSetMaxLength(Integer).
EMReplaceSel(TMessage) | Represents method EMReplaceSel(TMessage).
FindDialog(string) | Represents method FindDialog(string).
FindDialogClose(TObject) | Represents method FindDialogClose(TObject).
FindDialogFind(TObject) | Represents method FindDialogFind(TObject).
FindEditText(TFindDialog,Boolean,Boolean) | Represents method FindEditText(TFindDialog,Boolean,Boolean).
FindNext | Represents method FindNext.
FindText(string,Integer,Integer,TRichSearchTypes) | Represents method FindText(string,Integer,Integer,TRichSearchTypes).
GetAutoURLDetect | Represents method GetAutoURLDetect.
GetCanFindNext | Represents method GetCanFindNext.
GetCanPaste | Represents method GetCanPaste.
GetCanRedo | Represents method GetCanRedo.
GetCaretPos | Represents method GetCaretPos.
GetCharPos(Integer) | Represents method GetCharPos(Integer).
GetLangOptions | Represents method GetLangOptions.
GetLineIndex(Integer) | Represents method GetLineIndex(Integer).
GetLineLength(Integer) | Represents method GetLineLength(Integer).
GetPopupMenu | Represents method GetPopupMenu.
GetRedoName | Represents method GetRedoName.
GetSelection | Represents method GetSelection.
GetSelectionType | Represents method GetSelectionType.
GetSelLength | Represents method GetSelLength.
GetSelStart | Represents method GetSelStart.
GetSelText | Represents method GetSelText.
GetSelTextBuf(PChar,Integer) | Represents method GetSelTextBuf(PChar,Integer).
GetStreamFormat | Represents method GetStreamFormat.
GetStreamMode | Represents method GetStreamMode.
GetTextLen | Represents method GetTextLen.
GetTextRange(Longint,Longint) | Represents method GetTextRange(Longint,Longint).
GetUndoName | Represents method GetUndoName.
GetWordSelection | Represents method GetWordSelection.
InsertObjectDialog | Represents method InsertObjectDialog.
LineFromChar(Integer) | Represents method LineFromChar(Integer).
ObjectPropertiesDialog | Represents method ObjectPropertiesDialog.
ObjectPropsClick(TObject) | Represents method ObjectPropsClick(TObject).
PasteSpecialDialog | Represents method PasteSpecialDialog.
PopupVerbClick(TObject) | Represents method PopupVerbClick(TObject).
Print(string) | Represents method Print(string).
ProtectChange(TMessage,Integer,Integer) | Represents method ProtectChange(TMessage,Integer,Integer).
Redo | Represents method Redo.
RegisterConversionFormat(string,Boolean,TConversionClass) | Represents method RegisterConversionFormat(string,Boolean,TConversionClass).
ReplaceDialog(string,string) | Represents method ReplaceDialog(string,string).
ReplaceDialogReplace(TObject) | Represents method ReplaceDialogReplace(TObject).
RequestSize(TRect) | Represents method RequestSize(TRect).
SaveClipboard(Integer,Integer) | Represents method SaveClipboard(Integer,Integer).
SelectionChange | Represents method SelectionChange.
SendSynchMessage(UINT,WPARAM,LPARAM,Boolean) | Represents method SendSynchMessage(UINT,WPARAM,LPARAM,Boolean).
SetAllowObjects(Boolean) | Represents method SetAllowObjects(Boolean).
SetAutoURLDetect(Boolean) | Represents method SetAutoURLDetect(Boolean).
SetDefAttributes(TRxTextAttributes) | Represents method SetDefAttributes(TRxTextAttributes).
SetHideScrollBars(Boolean) | Represents method SetHideScrollBars(Boolean).
SetHideSelection(Boolean) | Represents method SetHideSelection(Boolean).
SetLangOptions(TRichLangOptions) | Represents method SetLangOptions(TRichLangOptions).
SetPlainText(Boolean) | Represents method SetPlainText(Boolean).
SetRichEditStrings(TStrings) | Represents method SetRichEditStrings(TStrings).
SetSelAttributes(TRxTextAttributes) | Represents method SetSelAttributes(TRxTextAttributes).
SetSelection(Longint,Longint,Boolean) | Represents method SetSelection(Longint,Longint,Boolean).
SetSelectionBar(Boolean) | Represents method SetSelectionBar(Boolean).
SetSelLength(Integer) | Represents method SetSelLength(Integer).
SetSelStart(Integer) | Represents method SetSelStart(Integer).
SetStreamFormat(TRichStreamFormat) | Represents method SetStreamFormat(TRichStreamFormat).
SetStreamMode(TRichStreamModes) | Represents method SetStreamMode(TRichStreamModes).
SetTitle(string) | Represents method SetTitle(string).
SetUIActive(Boolean) | Represents method SetUIActive(Boolean).
SetUndoLimit(Integer) | Represents method SetUndoLimit(Integer).
SetupFindDialog(TFindDialog,string,string) | Represents method SetupFindDialog(TFindDialog,string,string).
SetWordAttributes(TRxTextAttributes) | Represents method SetWordAttributes(TRxTextAttributes).
SetWordSelection(Boolean) | Represents method SetWordSelection(Boolean).
StopGroupTyping | Represents method StopGroupTyping.
TextNotFound(TFindDialog) | Represents method TextNotFound(TFindDialog).
UpdateHostNames | Represents method UpdateHostNames.
UpdateTextModes(Boolean) | Represents method UpdateTextModes(Boolean).
URLClick(string,TMouseButton) | Represents method URLClick(string,TMouseButton).
WMDestroy(TWMDestroy) | Represents method WMDestroy(TWMDestroy).
WMMouseMove(TMessage) | Represents method WMMouseMove(TMessage).
WMPaint(TWMPaint) | Represents method WMPaint(TWMPaint).
WMRButtonUp(TMessage) | Represents method WMRButtonUp(TMessage).
WMSetCursor(TWMSetCursor) | Represents method WMSetCursor(TWMSetCursor).
WMSetFont(TWMSetFont) | Represents method WMSetFont(TWMSetFont).
WordAtCursor | Represents method WordAtCursor.
Top


TRxCustomRichEdit.AdjustFindDialogPosition(TFindDialog) Method

Summary

Represents method AdjustFindDialogPosition(TFindDialog).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure AdjustFindDialogPosition(Dialog: TFindDialog);

Parameters

Dialog
Type: TFindDialog

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.Clear Method

Summary

Represents method Clear.

Namespace: frxRichEdit
Syntax
Delphi
public
 procedure Clear; override;
See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.ClearUndo Method

Summary

Represents method ClearUndo.

Namespace: frxRichEdit
Syntax
Delphi
public
 procedure ClearUndo;
See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CloseFindDialog(TFindDialog) Method

Summary

Represents method CloseFindDialog(TFindDialog).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure CloseFindDialog(Dialog: TFindDialog); virtual;

Parameters

Dialog
Type: TFindDialog

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CloseObjects Method

Summary

Represents method CloseObjects.

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure CloseObjects;
See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CMBiDiModeChanged(TMessage) Method

Summary

Represents method CMBiDiModeChanged(TMessage).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure CMBiDiModeChanged(var Message: TMessage); message CM_BIDIMODECHANGED;

Parameters

Message
Type: TMessage

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CMColorChanged(TMessage) Method

Summary

Represents method CMColorChanged(TMessage).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure CMColorChanged(var Message: TMessage); message CM_COLORCHANGED;

Parameters

Message
Type: TMessage

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CMDocWindowActivate(TMessage) Method

Summary

Represents method CMDocWindowActivate(TMessage).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure CMDocWindowActivate(var Message: TMessage); message CM_DOCWINDOWACTIVATE;

Parameters

Message
Type: TMessage

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CMFontChanged(TMessage) Method

Summary

Represents method CMFontChanged(TMessage).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure CMFontChanged(var Message: TMessage); message CM_FONTCHANGED;

Parameters

Message
Type: TMessage

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CMUIDeactivate(TMessage) Method

Summary

Represents method CMUIDeactivate(TMessage).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure CMUIDeactivate(var Message: TMessage); message CM_UIDEACTIVATE;

Parameters

Message
Type: TMessage

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CNNotify(TWMNotify) Method

Summary

Represents method CNNotify(TWMNotify).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure CNNotify(var Message: TWMNotify); message CN_NOTIFY;

Parameters

Message
Type: TWMNotify

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CreateParams(TCreateParams) Method

Summary

Represents method CreateParams(TCreateParams).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure CreateParams(var Params: TCreateParams); override;

Parameters

Params
Type: TCreateParams

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CreateWindowHandle(TCreateParams) Method

Summary

Represents method CreateWindowHandle(TCreateParams).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure CreateWindowHandle(const Params: TCreateParams); override;

Parameters

Params
Type: TCreateParams

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.CreateWnd Method

Summary

Represents method CreateWnd.

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure CreateWnd; override;
See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.DestroyWnd Method

Summary

Represents method DestroyWnd.

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure DestroyWnd; override;
See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.DoPerformSynchMessage Method

Summary

Represents method DoPerformSynchMessage.

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure DoPerformSynchMessage;
See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.DoSendSynchMessage Method

Summary

Represents method DoSendSynchMessage.

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure DoSendSynchMessage;
See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.DoSetMaxLength(Integer) Method

Summary

Represents method DoSetMaxLength(Integer).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure DoSetMaxLength(Value: Integer); override;

Parameters

Value
Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.EMReplaceSel(TMessage) Method

Summary

Represents method EMReplaceSel(TMessage).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure EMReplaceSel(var Message: TMessage); message EM_REPLACESEL;

Parameters

Message
Type: TMessage

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FindDialog(string) Method

Summary

Represents method FindDialog(string).

Namespace: frxRichEdit
Syntax
Delphi
public
 function FindDialog(const SearchStr: string): TFindDialog;

Parameters

SearchStr
Type: string

Return Value

Type: TFindDialog

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FindDialogClose(TObject) Method

Summary

Represents method FindDialogClose(TObject).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure FindDialogClose(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FindDialogFind(TObject) Method

Summary

Represents method FindDialogFind(TObject).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure FindDialogFind(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FindEditText(TFindDialog,Boolean,Boolean) Method

Summary

Represents method FindEditText(TFindDialog,Boolean,Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 function FindEditText(Dialog: TFindDialog; AdjustPos, Events: Boolean): Boolean;

Parameters

Dialog
Type: TFindDialog

AdjustPos
Type: Boolean

Events
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FindNext Method

Summary

Represents method FindNext.

Namespace: frxRichEdit
Syntax
Delphi
public
 function FindNext: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FindText(string,Integer,Integer,TRichSearchTypes) Method

Summary

Represents method FindText(string,Integer,Integer,TRichSearchTypes).

Namespace: frxRichEdit
Syntax
Delphi
public
 function FindText(const SearchStr: string;
 StartPos, Length: Integer; Options: TRichSearchTypes): Integer;

Parameters

SearchStr
Type: string

StartPos
Type: Integer

Length
Type: Integer

Options
Type: TRichSearchTypes

Return Value

Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetAutoURLDetect Method

Summary

Represents method GetAutoURLDetect.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetAutoURLDetect: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetCanFindNext Method

Summary

Represents method GetCanFindNext.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetCanFindNext: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetCanPaste Method

Summary

Represents method GetCanPaste.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetCanPaste: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetCanRedo Method

Summary

Represents method GetCanRedo.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetCanRedo: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetCaretPos Method

Summary

Represents method GetCaretPos.

Namespace: frxRichEdit
Syntax
Delphi
public
 function GetCaretPos: TPoint; override;

Return Value

Type: TPoint

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetCharPos(Integer) Method

Summary

Represents method GetCharPos(Integer).

Namespace: frxRichEdit
Syntax
Delphi
public
 function GetCharPos(CharIndex: Integer): TPoint;

Parameters

CharIndex
Type: Integer

Return Value

Type: TPoint

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetLangOptions Method

Summary

Represents method GetLangOptions.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetLangOptions: TRichLangOptions;

Return Value

Type: TRichLangOptions

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetLineIndex(Integer) Method

Summary

Represents method GetLineIndex(Integer).

Namespace: frxRichEdit
Syntax
Delphi
public
 function GetLineIndex(LineNo: Integer): Integer;

Parameters

LineNo
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetLineLength(Integer) Method

Summary

Represents method GetLineLength(Integer).

Namespace: frxRichEdit
Syntax
Delphi
public
 function GetLineLength(CharIndex: Integer): Integer;

Parameters

CharIndex
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetPopupMenu Method

Summary

Represents method GetPopupMenu.

Namespace: frxRichEdit
Syntax
Delphi
protected
 function GetPopupMenu: TPopupMenu; override;

Return Value

Type: TPopupMenu

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetRedoName Method

Summary

Represents method GetRedoName.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetRedoName: TUndoName;

Return Value

Type: TUndoName

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetSelection Method

Summary

Represents method GetSelection.

Namespace: frxRichEdit
Syntax
Delphi
public
 function GetSelection: TCharRange;

Return Value

Type: TCharRange

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetSelectionType Method

Summary

Represents method GetSelectionType.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetSelectionType: TRichSelectionType;

Return Value

Type: TRichSelectionType

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetSelLength Method

Summary

Represents method GetSelLength.

Namespace: frxRichEdit
Syntax
Delphi
protected
 function GetSelLength: Integer; override;

Return Value

Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetSelStart Method

Summary

Represents method GetSelStart.

Namespace: frxRichEdit
Syntax
Delphi
protected
 function GetSelStart: Integer; override;

Return Value

Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetSelText Method

Summary

Represents method GetSelText.

Namespace: frxRichEdit
Syntax
Delphi
protected
 function GetSelText: string; override;

Return Value

Type: string

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetSelTextBuf(PChar,Integer) Method

Summary

Represents method GetSelTextBuf(PChar,Integer).

Namespace: frxRichEdit
Syntax
Delphi
public
 function GetSelTextBuf(Buffer: PChar; BufSize: Integer): Integer; override;

Parameters

Buffer
Type: PChar

BufSize
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetStreamFormat Method

Summary

Represents method GetStreamFormat.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetStreamFormat: TRichStreamFormat;

Return Value

Type: TRichStreamFormat

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetStreamMode Method

Summary

Represents method GetStreamMode.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetStreamMode: TRichStreamModes;

Return Value

Type: TRichStreamModes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetTextLen Method

Summary

Represents method GetTextLen.

Namespace: frxRichEdit
Syntax
Delphi
public
 function GetTextLen: Integer; reintroduce;

Return Value

Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetTextRange(Longint,Longint) Method

Summary

Represents method GetTextRange(Longint,Longint).

Namespace: frxRichEdit
Syntax
Delphi
public
 function GetTextRange(StartPos, EndPos: Longint): string;

Parameters

StartPos
Type: Longint

EndPos
Type: Longint

Return Value

Type: string

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetUndoName Method

Summary

Represents method GetUndoName.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetUndoName: TUndoName;

Return Value

Type: TUndoName

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.GetWordSelection Method

Summary

Represents method GetWordSelection.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetWordSelection: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.InsertObjectDialog Method

Summary

Represents method InsertObjectDialog.

Namespace: frxRichEdit
Syntax
Delphi
public
 function InsertObjectDialog: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.LineFromChar(Integer) Method

Summary

Represents method LineFromChar(Integer).

Namespace: frxRichEdit
Syntax
Delphi
public
 function LineFromChar(CharIndex: Integer): Integer;

Parameters

CharIndex
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.ObjectPropertiesDialog Method

Summary

Represents method ObjectPropertiesDialog.

Namespace: frxRichEdit
Syntax
Delphi
public
 function ObjectPropertiesDialog: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.ObjectPropsClick(TObject) Method

Summary

Represents method ObjectPropsClick(TObject).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure ObjectPropsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.PasteSpecialDialog Method

Summary

Represents method PasteSpecialDialog.

Namespace: frxRichEdit
Syntax
Delphi
public
 function PasteSpecialDialog: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.PopupVerbClick(TObject) Method

Summary

Represents method PopupVerbClick(TObject).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure PopupVerbClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.Print(string) Method

Summary

Represents method Print(string).

Namespace: frxRichEdit
Syntax
Delphi
public
 procedure Print(const Caption: string); virtual;

Parameters

Caption
Type: string

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.ProtectChange(TMessage,Integer,Integer) Method

Summary

Represents method ProtectChange(TMessage,Integer,Integer).

Namespace: frxRichEdit
Syntax
Delphi
protected
 function ProtectChange(const Message: TMessage; StartPos,
 EndPos: Integer): Boolean; dynamic;

Parameters

Message
Type: TMessage

StartPos
Type: Integer

EndPos
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.Redo Method

Summary

Represents method Redo.

Namespace: frxRichEdit
Syntax
Delphi
public
 procedure Redo;
See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.RegisterConversionFormat(string,Boolean,TConversionClass) Method

Summary

Represents method RegisterConversionFormat(string,Boolean,TConversionClass).

Namespace: frxRichEdit
Syntax
Delphi
public
 class procedure RegisterConversionFormat(const AExtension: string;
 APlainText: Boolean; AConversionClass: TConversionClass);

Parameters

AExtension
Type: string

APlainText
Type: Boolean

AConversionClass
Type: TConversionClass

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.ReplaceDialog(string,string) Method

Summary

Represents method ReplaceDialog(string,string).

Namespace: frxRichEdit
Syntax
Delphi
public
 function ReplaceDialog(const SearchStr, ReplaceStr: string): TReplaceDialog;

Parameters

SearchStr
Type: string

ReplaceStr
Type: string

Return Value

Type: TReplaceDialog

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.ReplaceDialogReplace(TObject) Method

Summary

Represents method ReplaceDialogReplace(TObject).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure ReplaceDialogReplace(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.RequestSize(TRect) Method

Summary

Represents method RequestSize(TRect).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure RequestSize(const Rect: TRect); virtual;

Parameters

Rect
Type: TRect

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SaveClipboard(Integer,Integer) Method

Summary

Represents method SaveClipboard(Integer,Integer).

Namespace: frxRichEdit
Syntax
Delphi
protected
 function SaveClipboard(NumObj, NumChars: Integer): Boolean; dynamic;

Parameters

NumObj
Type: Integer

NumChars
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SelectionChange Method

Summary

Represents method SelectionChange.

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure SelectionChange; dynamic;
See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SendSynchMessage(UINT,WPARAM,LPARAM,Boolean) Method

Summary

Represents method SendSynchMessage(UINT,WPARAM,LPARAM,Boolean).

Namespace: frxRichEdit
Syntax
Delphi
public
 function SendSynchMessage(Msg: UINT; wPar: WPARAM; lPar: LPARAM; DoPerform: Boolean = False): LRESULT;

Parameters

Msg
Type: UINT

wPar
Type: WPARAM

lPar
Type: LPARAM

DoPerform
Type: Boolean

Return Value

Type: LRESULT

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetAllowObjects(Boolean) Method

Summary

Represents method SetAllowObjects(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetAllowObjects(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetAutoURLDetect(Boolean) Method

Summary

Represents method SetAutoURLDetect(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetAutoURLDetect(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetDefAttributes(TRxTextAttributes) Method

Summary

Represents method SetDefAttributes(TRxTextAttributes).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetDefAttributes(Value: TRxTextAttributes);

Parameters

Value
Type: TRxTextAttributes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetHideScrollBars(Boolean) Method

Summary

Represents method SetHideScrollBars(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetHideScrollBars(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetHideSelection(Boolean) Method

Summary

Represents method SetHideSelection(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetHideSelection(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetLangOptions(TRichLangOptions) Method

Summary

Represents method SetLangOptions(TRichLangOptions).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetLangOptions(Value: TRichLangOptions);

Parameters

Value
Type: TRichLangOptions

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetPlainText(Boolean) Method

Summary

Represents method SetPlainText(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure SetPlainText(Value: Boolean); virtual;

Parameters

Value
Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetRichEditStrings(TStrings) Method

Summary

Represents method SetRichEditStrings(TStrings).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetRichEditStrings(Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetSelAttributes(TRxTextAttributes) Method

Summary

Represents method SetSelAttributes(TRxTextAttributes).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetSelAttributes(Value: TRxTextAttributes);

Parameters

Value
Type: TRxTextAttributes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetSelection(Longint,Longint,Boolean) Method

Summary

Represents method SetSelection(Longint,Longint,Boolean).

Namespace: frxRichEdit
Syntax
Delphi
public
 procedure SetSelection(StartPos, EndPos: Longint; ScrollCaret: Boolean);

Parameters

StartPos
Type: Longint

EndPos
Type: Longint

ScrollCaret
Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetSelectionBar(Boolean) Method

Summary

Represents method SetSelectionBar(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetSelectionBar(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetSelLength(Integer) Method

Summary

Represents method SetSelLength(Integer).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure SetSelLength(Value: Integer); override;

Parameters

Value
Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetSelStart(Integer) Method

Summary

Represents method SetSelStart(Integer).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure SetSelStart(Value: Integer); override;

Parameters

Value
Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetStreamFormat(TRichStreamFormat) Method

Summary

Represents method SetStreamFormat(TRichStreamFormat).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetStreamFormat(Value: TRichStreamFormat);

Parameters

Value
Type: TRichStreamFormat

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetStreamMode(TRichStreamModes) Method

Summary

Represents method SetStreamMode(TRichStreamModes).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetStreamMode(Value: TRichStreamModes);

Parameters

Value
Type: TRichStreamModes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetTitle(string) Method

Summary

Represents method SetTitle(string).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetTitle(const Value: string);

Parameters

Value
Type: string

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetUIActive(Boolean) Method

Summary

Represents method SetUIActive(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetUIActive(Active: Boolean);

Parameters

Active
Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetUndoLimit(Integer) Method

Summary

Represents method SetUndoLimit(Integer).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetUndoLimit(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetupFindDialog(TFindDialog,string,string) Method

Summary

Represents method SetupFindDialog(TFindDialog,string,string).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetupFindDialog(Dialog: TFindDialog; const SearchStr,
 ReplaceStr: string);

Parameters

Dialog
Type: TFindDialog

SearchStr
Type: string

ReplaceStr
Type: string

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetWordAttributes(TRxTextAttributes) Method

Summary

Represents method SetWordAttributes(TRxTextAttributes).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetWordAttributes(Value: TRxTextAttributes);

Parameters

Value
Type: TRxTextAttributes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.SetWordSelection(Boolean) Method

Summary

Represents method SetWordSelection(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetWordSelection(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.StopGroupTyping Method

Summary

Represents method StopGroupTyping.

Namespace: frxRichEdit
Syntax
Delphi
public
 procedure StopGroupTyping;
See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.TextNotFound(TFindDialog) Method

Summary

Represents method TextNotFound(TFindDialog).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure TextNotFound(Dialog: TFindDialog); virtual;

Parameters

Dialog
Type: TFindDialog

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.UpdateHostNames Method

Summary

Represents method UpdateHostNames.

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure UpdateHostNames;
See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.UpdateTextModes(Boolean) Method

Summary

Represents method UpdateTextModes(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure UpdateTextModes(Plain: Boolean);

Parameters

Plain
Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.URLClick(string,TMouseButton) Method

Summary

Represents method URLClick(string,TMouseButton).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure URLClick(const URLText: string; Button: TMouseButton); dynamic;

Parameters

URLText
Type: string

Button
Type: TMouseButton

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.WMDestroy(TWMDestroy) Method

Summary

Represents method WMDestroy(TWMDestroy).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure WMDestroy(var Msg: TWMDestroy); message WM_DESTROY;

Parameters

Msg
Type: TWMDestroy

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.WMMouseMove(TMessage) Method

Summary

Represents method WMMouseMove(TMessage).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure WMMouseMove(var Message: TMessage); message WM_MOUSEMOVE;

Parameters

Message
Type: TMessage

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.WMPaint(TWMPaint) Method

Summary

Represents method WMPaint(TWMPaint).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure WMPaint(var Message: TWMPaint); message WM_PAINT;

Parameters

Message
Type: TWMPaint

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.WMRButtonUp(TMessage) Method

Summary

Represents method WMRButtonUp(TMessage).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure WMRButtonUp(var Message: TMessage); message WM_RBUTTONUP;

Parameters

Message
Type: TMessage

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.WMSetCursor(TWMSetCursor) Method

Summary

Represents method WMSetCursor(TWMSetCursor).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure WMSetCursor(var Message: TWMSetCursor); message WM_SETCURSOR;

Parameters

Message
Type: TWMSetCursor

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.WMSetFont(TWMSetFont) Method

Summary

Represents method WMSetFont(TWMSetFont).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure WMSetFont(var Message: TWMSetFont); message WM_SETFONT;

Parameters

Message
Type: TWMSetFont

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.WordAtCursor Method

Summary

Represents method WordAtCursor.

Namespace: frxRichEdit
Syntax
Delphi
public
 function WordAtCursor: string;

Return Value

Type: string

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit Events

Events
Name | Description
OnCloseFindDialog | Represents property OnCloseFindDialog.
OnProtectChangeEx | Represents property OnProtectChangeEx.
OnTextNotFound | Represents property OnTextNotFound.
OnURLClick | Represents property OnURLClick.
Top


TRxCustomRichEdit.OnCloseFindDialog Event

Summary

Represents property OnCloseFindDialog.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property OnCloseFindDialog: TRichEditFindCloseEvent read FOnCloseFindDialog
 write FOnCloseFindDialog;

Value

Type: TRichEditFindCloseEvent

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.OnProtectChangeEx Event

Summary

Represents property OnProtectChangeEx.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property OnProtectChangeEx: TRichEditProtectChangeEx read FOnProtectChangeEx
 write FOnProtectChangeEx;

Value

Type: TRichEditProtectChangeEx

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.OnTextNotFound Event

Summary

Represents property OnTextNotFound.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property OnTextNotFound: TRichEditFindErrorEvent read FOnTextNotFound write FOnTextNotFound;

Value

Type: TRichEditFindErrorEvent

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.OnURLClick Event

Summary

Represents property OnURLClick.

Namespace: frxRichEdit
Syntax
Delphi
protected
 property OnURLClick: TRichEditURLClickEvent read FOnURLClick write FOnURLClick;

Value

Type: TRichEditURLClickEvent

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit Fields

Fields
Name | Description
FAllowInPlace | Represents field FAllowInPlace.
FAllowObjects | Represents field FAllowObjects.
FAutoURLDetect | Represents field FAutoURLDetect.
FAutoVerbMenu | Represents field FAutoVerbMenu.
FCallback | Represents field FCallback.
FClickBtn | Represents field FClickBtn.
FClickRange | Represents field FClickRange.
FDefAttributes | Represents field FDefAttributes.
FDefaultConverter | Represents field FDefaultConverter.
FFindDialog | Represents field FFindDialog.
FHideScrollBars | Represents field FHideScrollBars.
FHideSelection | Represents field FHideSelection.
FLangOptions | Represents field FLangOptions.
FLastFind | Represents field FLastFind.
FLinesUpdating | Represents field FLinesUpdating.
FLparam | Represents field FLparam.
FLResult | Represents field FLResult.
FMemStream | Represents field FMemStream.
FModified | Represents field FModified.
FMsg | Represents field FMsg.
FNotMainThread | Represents field FNotMainThread.
FOldParaAlignment | Represents field FOldParaAlignment.
FOnCloseFindDialog | Represents field FOnCloseFindDialog.
FOnProtectChange | Represents field FOnProtectChange.
FOnProtectChangeEx | Represents field FOnProtectChangeEx.
FOnResizeRequest | Represents field FOnResizeRequest.
FOnSaveClipboard | Represents field FOnSaveClipboard.
FOnSelChange | Represents field FOnSelChange.
FOnTextNotFound | Represents field FOnTextNotFound.
FOnURLClick | Represents field FOnURLClick.
FPageRect | Represents field FPageRect.
FParagraph | Represents field FParagraph.
FPlainText | Represents field FPlainText.
FPopupVerbMenu | Represents field FPopupVerbMenu.
FReplaceDialog | Represents field FReplaceDialog.
FRichEditOle | Represents field FRichEditOle.
FRichEditStrings | Represents field FRichEditStrings.
FScreenLogPixels | Represents field FScreenLogPixels.
FSelAttributes | Represents field FSelAttributes.
FSelectionBar | Represents field FSelectionBar.
FTitle | Represents field FTitle.
FUndoLimit | Represents field FUndoLimit.
FWordAttributes | Represents field FWordAttributes.
FWordSelection | Represents field FWordSelection.
FWparam | Represents field FWparam.
Top


TRxCustomRichEdit.FAllowInPlace Field

Summary

Represents field FAllowInPlace.

Namespace: frxRichEdit
Syntax
Delphi
private
 FAllowInPlace: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FAllowObjects Field

Summary

Represents field FAllowObjects.

Namespace: frxRichEdit
Syntax
Delphi
private
 FAllowObjects: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FAutoURLDetect Field

Summary

Represents field FAutoURLDetect.

Namespace: frxRichEdit
Syntax
Delphi
private
 FAutoURLDetect: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FAutoVerbMenu Field

Summary

Represents field FAutoVerbMenu.

Namespace: frxRichEdit
Syntax
Delphi
private
 FAutoVerbMenu: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FCallback Field

Summary

Represents field FCallback.

Namespace: frxRichEdit
Syntax
Delphi
private
 FCallback: TObject;

Field Value

Type: TObject

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FClickBtn Field

Summary

Represents field FClickBtn.

Namespace: frxRichEdit
Syntax
Delphi
private
 FClickBtn: TMouseButton;

Field Value

Type: TMouseButton

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FClickRange Field

Summary

Represents field FClickRange.

Namespace: frxRichEdit
Syntax
Delphi
private
 FClickRange: TCharRange;

Field Value

Type: TCharRange

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FDefAttributes Field

Summary

Represents field FDefAttributes.

Namespace: frxRichEdit
Syntax
Delphi
private
 FDefAttributes: TRxTextAttributes;

Field Value

Type: TRxTextAttributes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FDefaultConverter Field

Summary

Represents field FDefaultConverter.

Namespace: frxRichEdit
Syntax
Delphi
private
 FDefaultConverter: TConversionClass;

Field Value

Type: TConversionClass

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FFindDialog Field

Summary

Represents field FFindDialog.

Namespace: frxRichEdit
Syntax
Delphi
private
 FFindDialog: TFindDialog;

Field Value

Type: TFindDialog

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FHideScrollBars Field

Summary

Represents field FHideScrollBars.

Namespace: frxRichEdit
Syntax
Delphi
private
 FHideScrollBars: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FHideSelection Field

Summary

Represents field FHideSelection.

Namespace: frxRichEdit
Syntax
Delphi
private
 FHideSelection: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FLangOptions Field

Summary

Represents field FLangOptions.

Namespace: frxRichEdit
Syntax
Delphi
private
 FLangOptions: TRichLangOptions;

Field Value

Type: TRichLangOptions

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FLastFind Field

Summary

Represents field FLastFind.

Namespace: frxRichEdit
Syntax
Delphi
private
 FLastFind: TFindDialog;

Field Value

Type: TFindDialog

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FLinesUpdating Field

Summary

Represents field FLinesUpdating.

Namespace: frxRichEdit
Syntax
Delphi
private
 FLinesUpdating: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FLparam Field

Summary

Represents field FLparam.

Namespace: frxRichEdit
Syntax
Delphi
private
 FLparam: WPARAM;

Field Value

Type: WPARAM

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FLResult Field

Summary

Represents field FLResult.

Namespace: frxRichEdit
Syntax
Delphi
private
 FLResult: LRESULT;

Field Value

Type: LRESULT

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FMemStream Field

Summary

Represents field FMemStream.

Namespace: frxRichEdit
Syntax
Delphi
private
 FMemStream: TMemoryStream;

Field Value

Type: TMemoryStream

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FModified Field

Summary

Represents field FModified.

Namespace: frxRichEdit
Syntax
Delphi
private
 FModified: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FMsg Field

Summary

Represents field FMsg.

Namespace: frxRichEdit
Syntax
Delphi
private
 FMsg: UINT;

Field Value

Type: UINT

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FNotMainThread Field

Summary

Represents field FNotMainThread.

Namespace: frxRichEdit
Syntax
Delphi
private
 FNotMainThread: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FOldParaAlignment Field

Summary

Represents field FOldParaAlignment.

Namespace: frxRichEdit
Syntax
Delphi
private
 FOldParaAlignment: TParaAlignment;

Field Value

Type: TParaAlignment

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FOnCloseFindDialog Field

Summary

Represents field FOnCloseFindDialog.

Namespace: frxRichEdit
Syntax
Delphi
private
 FOnCloseFindDialog: TRichEditFindCloseEvent;

Field Value

Type: TRichEditFindCloseEvent

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FOnProtectChange Field

Summary

Represents field FOnProtectChange.

Namespace: frxRichEdit
Syntax
Delphi
private
 FOnProtectChange: TRichEditProtectChange;

Field Value

Type: TRichEditProtectChange

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FOnProtectChangeEx Field

Summary

Represents field FOnProtectChangeEx.

Namespace: frxRichEdit
Syntax
Delphi
private
 FOnProtectChangeEx: TRichEditProtectChangeEx;

Field Value

Type: TRichEditProtectChangeEx

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FOnResizeRequest Field

Summary

Represents field FOnResizeRequest.

Namespace: frxRichEdit
Syntax
Delphi
private
 FOnResizeRequest: TRichEditResizeEvent;

Field Value

Type: TRichEditResizeEvent

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FOnSaveClipboard Field

Summary

Represents field FOnSaveClipboard.

Namespace: frxRichEdit
Syntax
Delphi
private
 FOnSaveClipboard: TRichEditSaveClipboard;

Field Value

Type: TRichEditSaveClipboard

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FOnSelChange Field

Summary

Represents field FOnSelChange.

Namespace: frxRichEdit
Syntax
Delphi
private
 FOnSelChange: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FOnTextNotFound Field

Summary

Represents field FOnTextNotFound.

Namespace: frxRichEdit
Syntax
Delphi
private
 FOnTextNotFound: TRichEditFindErrorEvent;

Field Value

Type: TRichEditFindErrorEvent

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FOnURLClick Field

Summary

Represents field FOnURLClick.

Namespace: frxRichEdit
Syntax
Delphi
private
 FOnURLClick: TRichEditURLClickEvent;

Field Value

Type: TRichEditURLClickEvent

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FPageRect Field

Summary

Represents field FPageRect.

Namespace: frxRichEdit
Syntax
Delphi
private
 FPageRect: TRect;

Field Value

Type: TRect

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FParagraph Field

Summary

Represents field FParagraph.

Namespace: frxRichEdit
Syntax
Delphi
private
 FParagraph: TRxParaAttributes;

Field Value

Type: TRxParaAttributes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FPlainText Field

Summary

Represents field FPlainText.

Namespace: frxRichEdit
Syntax
Delphi
private
 FPlainText: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FPopupVerbMenu Field

Summary

Represents field FPopupVerbMenu.

Namespace: frxRichEdit
Syntax
Delphi
private
 FPopupVerbMenu: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FReplaceDialog Field

Summary

Represents field FReplaceDialog.

Namespace: frxRichEdit
Syntax
Delphi
private
 FReplaceDialog: TReplaceDialog;

Field Value

Type: TReplaceDialog

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FRichEditOle Field

Summary

Represents field FRichEditOle.

Namespace: frxRichEdit
Syntax
Delphi
private
 FRichEditOle: IUnknown;

Field Value

Type: IUnknown

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FRichEditStrings Field

Summary

Represents field FRichEditStrings.

Namespace: frxRichEdit
Syntax
Delphi
private
 FRichEditStrings: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FScreenLogPixels Field

Summary

Represents field FScreenLogPixels.

Namespace: frxRichEdit
Syntax
Delphi
private
 FScreenLogPixels: Integer;

Field Value

Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FSelAttributes Field

Summary

Represents field FSelAttributes.

Namespace: frxRichEdit
Syntax
Delphi
private
 FSelAttributes: TRxTextAttributes;

Field Value

Type: TRxTextAttributes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FSelectionBar Field

Summary

Represents field FSelectionBar.

Namespace: frxRichEdit
Syntax
Delphi
private
 FSelectionBar: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FTitle Field

Summary

Represents field FTitle.

Namespace: frxRichEdit
Syntax
Delphi
private
 FTitle: string;

Field Value

Type: string

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FUndoLimit Field

Summary

Represents field FUndoLimit.

Namespace: frxRichEdit
Syntax
Delphi
private
 FUndoLimit: Integer;

Field Value

Type: Integer

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FWordAttributes Field

Summary

Represents field FWordAttributes.

Namespace: frxRichEdit
Syntax
Delphi
private
 FWordAttributes: TRxTextAttributes;

Field Value

Type: TRxTextAttributes

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FWordSelection Field

Summary

Represents field FWordSelection.

Namespace: frxRichEdit
Syntax
Delphi
private
 FWordSelection: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxCustomRichEdit.FWparam Field

Summary

Represents field FWparam.

Namespace: frxRichEdit
Syntax
Delphi
private
 FWparam: WPARAM;

Field Value

Type: WPARAM

See Also

Reference

  • TRxCustomRichEdit
  • frxRichEdit


TRxParaAttributes Class

Summary

Represents type TRxParaAttributes.

Namespace: frxRichEdit
Inheritance Hierarchy
TPersistent
frxRichEdit.TRxParaAttributes
Syntax
Delphi
type
 TRxParaAttributes = class(TPersistent)
 end;

The TRxParaAttributes type exposes the following members.

Constructors
Show:
Name | Description
Create(TRxCustomRichEdit) | Initializes a new instance of the TRxParaAttributes class.
Top
Properties
Show:
Name | Description
Alignment | Represents property Alignment.
FirstIndent | Represents property FirstIndent.
HeadingStyle | Represents property HeadingStyle.
LeftIndent | Represents property LeftIndent.
LineSpacing | Represents property LineSpacing.
LineSpacingRule | Represents property LineSpacingRule.
Numbering | Represents property Numbering.
NumberingStyle | Represents property NumberingStyle.
NumberingTab | Represents property NumberingTab.
RightIndent | Represents property RightIndent.
SpaceAfter | Represents property SpaceAfter.
SpaceBefore | Represents property SpaceBefore.
TabCount | Represents property TabCount.
TableStyle | Represents property TableStyle.
Tab[Byte] | Represents property Tab[Byte].
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
GetAlignment | Represents method GetAlignment.
GetAttributes(TParaFormat2) | Represents method GetAttributes(TParaFormat2).
GetFirstIndent | Represents method GetFirstIndent.
GetHeadingStyle | Represents method GetHeadingStyle.
GetLeftIndent | Represents method GetLeftIndent.
GetLineSpacing | Represents method GetLineSpacing.
GetLineSpacingRule | Represents method GetLineSpacingRule.
GetNumbering | Represents method GetNumbering.
GetNumberingStyle | Represents method GetNumberingStyle.
GetNumberingTab | Represents method GetNumberingTab.
GetRightIndent | Represents method GetRightIndent.
GetSpaceAfter | Represents method GetSpaceAfter.
GetSpaceBefore | Represents method GetSpaceBefore.
GetTab(Byte) | Represents method GetTab(Byte).
GetTabCount | Represents method GetTabCount.
GetTableStyle | Represents method GetTableStyle.
InitPara(TParaFormat2) | Represents method InitPara(TParaFormat2).
SetAlignment(TParaAlignment) | Represents method SetAlignment(TParaAlignment).
SetAttributes(TParaFormat2) | Represents method SetAttributes(TParaFormat2).
SetFirstIndent(Longint) | Represents method SetFirstIndent(Longint).
SetHeadingStyle(THeadingStyle) | Represents method SetHeadingStyle(THeadingStyle).
SetLeftIndent(Longint) | Represents method SetLeftIndent(Longint).
SetLineSpacing(Longint) | Represents method SetLineSpacing(Longint).
SetLineSpacingRule(TLineSpacingRule) | Represents method SetLineSpacingRule(TLineSpacingRule).
SetNumbering(TRxNumbering) | Represents method SetNumbering(TRxNumbering).
SetNumberingStyle(TRxNumberingStyle) | Represents method SetNumberingStyle(TRxNumberingStyle).
SetNumberingTab(Word) | Represents method SetNumberingTab(Word).
SetRightIndent(Longint) | Represents method SetRightIndent(Longint).
SetSpaceAfter(Longint) | Represents method SetSpaceAfter(Longint).
SetSpaceBefore(Longint) | Represents method SetSpaceBefore(Longint).
SetTab(Byte,Longint) | Represents method SetTab(Byte,Longint).
SetTabCount(Integer) | Represents method SetTabCount(Integer).
SetTableStyle(TParaTableStyle) | Represents method SetTableStyle(TParaTableStyle).
Top
Fields
Show:
Name | Description
RichEdit | Represents field RichEdit.
Top
See Also

Reference

  • frxRichEdit


TRxParaAttributes Constructors

Constructors
Name | Description
Create(TRxCustomRichEdit) | Initializes a new instance of the TRxParaAttributes class.
Top


TRxParaAttributes.Create(TRxCustomRichEdit) Constructor

Summary

Initializes a new instance of the TRxParaAttributes class.

Namespace: frxRichEdit
Syntax
Delphi
public
 constructor Create(AOwner: TRxCustomRichEdit);

Parameters

AOwner
Type: TRxCustomRichEdit

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes Properties

Properties
Name | Description
Alignment | Represents property Alignment.
FirstIndent | Represents property FirstIndent.
HeadingStyle | Represents property HeadingStyle.
LeftIndent | Represents property LeftIndent.
LineSpacing | Represents property LineSpacing.
LineSpacingRule | Represents property LineSpacingRule.
Numbering | Represents property Numbering.
NumberingStyle | Represents property NumberingStyle.
NumberingTab | Represents property NumberingTab.
RightIndent | Represents property RightIndent.
SpaceAfter | Represents property SpaceAfter.
SpaceBefore | Represents property SpaceBefore.
TabCount | Represents property TabCount.
TableStyle | Represents property TableStyle.
Tab[Byte] | Represents property Tab[Byte].
Top


TRxParaAttributes.Alignment Property

Summary

Represents property Alignment.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Alignment: TParaAlignment read GetAlignment write SetAlignment;

Property Value

Type: TParaAlignment

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.FirstIndent Property

Summary

Represents property FirstIndent.

Namespace: frxRichEdit
Syntax
Delphi
public
 property FirstIndent: Longint read GetFirstIndent write SetFirstIndent;

Property Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.HeadingStyle Property

Summary

Represents property HeadingStyle.

Namespace: frxRichEdit
Syntax
Delphi
public
 property HeadingStyle: THeadingStyle read GetHeadingStyle write SetHeadingStyle;

Property Value

Type: THeadingStyle

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.LeftIndent Property

Summary

Represents property LeftIndent.

Namespace: frxRichEdit
Syntax
Delphi
public
 property LeftIndent: Longint read GetLeftIndent write SetLeftIndent;

Property Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.LineSpacing Property

Summary

Represents property LineSpacing.

Namespace: frxRichEdit
Syntax
Delphi
public
 property LineSpacing: Longint read GetLineSpacing write SetLineSpacing;

Property Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.LineSpacingRule Property

Summary

Represents property LineSpacingRule.

Namespace: frxRichEdit
Syntax
Delphi
public
 property LineSpacingRule: TLineSpacingRule read GetLineSpacingRule write SetLineSpacingRule;

Property Value

Type: TLineSpacingRule

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.Numbering Property

Summary

Represents property Numbering.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Numbering: TRxNumbering read GetNumbering write SetNumbering;

Property Value

Type: TRxNumbering

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.NumberingStyle Property

Summary

Represents property NumberingStyle.

Namespace: frxRichEdit
Syntax
Delphi
public
 property NumberingStyle: TRxNumberingStyle read GetNumberingStyle write SetNumberingStyle;

Property Value

Type: TRxNumberingStyle

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.NumberingTab Property

Summary

Represents property NumberingTab.

Namespace: frxRichEdit
Syntax
Delphi
public
 property NumberingTab: Word read GetNumberingTab write SetNumberingTab;

Property Value

Type: Word

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.RightIndent Property

Summary

Represents property RightIndent.

Namespace: frxRichEdit
Syntax
Delphi
public
 property RightIndent: Longint read GetRightIndent write SetRightIndent;

Property Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SpaceAfter Property

Summary

Represents property SpaceAfter.

Namespace: frxRichEdit
Syntax
Delphi
public
 property SpaceAfter: Longint read GetSpaceAfter write SetSpaceAfter;

Property Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SpaceBefore Property

Summary

Represents property SpaceBefore.

Namespace: frxRichEdit
Syntax
Delphi
public
 property SpaceBefore: Longint read GetSpaceBefore write SetSpaceBefore;

Property Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.TabCount Property

Summary

Represents property TabCount.

Namespace: frxRichEdit
Syntax
Delphi
public
 property TabCount: Integer read GetTabCount write SetTabCount;

Property Value

Type: Integer

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.TableStyle Property

Summary

Represents property TableStyle.

Namespace: frxRichEdit
Syntax
Delphi
public
 property TableStyle: TParaTableStyle read GetTableStyle write SetTableStyle;

Property Value

Type: TParaTableStyle

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.Tab[Byte] Property

Summary

Represents property Tab[Byte].

Namespace: frxRichEdit
Syntax
Delphi
public
 property Tab[Index: Byte]: Longint read GetTab write SetTab;

Parameters

Index
Type: Byte

Property Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
GetAlignment | Represents method GetAlignment.
GetAttributes(TParaFormat2) | Represents method GetAttributes(TParaFormat2).
GetFirstIndent | Represents method GetFirstIndent.
GetHeadingStyle | Represents method GetHeadingStyle.
GetLeftIndent | Represents method GetLeftIndent.
GetLineSpacing | Represents method GetLineSpacing.
GetLineSpacingRule | Represents method GetLineSpacingRule.
GetNumbering | Represents method GetNumbering.
GetNumberingStyle | Represents method GetNumberingStyle.
GetNumberingTab | Represents method GetNumberingTab.
GetRightIndent | Represents method GetRightIndent.
GetSpaceAfter | Represents method GetSpaceAfter.
GetSpaceBefore | Represents method GetSpaceBefore.
GetTab(Byte) | Represents method GetTab(Byte).
GetTabCount | Represents method GetTabCount.
GetTableStyle | Represents method GetTableStyle.
InitPara(TParaFormat2) | Represents method InitPara(TParaFormat2).
SetAlignment(TParaAlignment) | Represents method SetAlignment(TParaAlignment).
SetAttributes(TParaFormat2) | Represents method SetAttributes(TParaFormat2).
SetFirstIndent(Longint) | Represents method SetFirstIndent(Longint).
SetHeadingStyle(THeadingStyle) | Represents method SetHeadingStyle(THeadingStyle).
SetLeftIndent(Longint) | Represents method SetLeftIndent(Longint).
SetLineSpacing(Longint) | Represents method SetLineSpacing(Longint).
SetLineSpacingRule(TLineSpacingRule) | Represents method SetLineSpacingRule(TLineSpacingRule).
SetNumbering(TRxNumbering) | Represents method SetNumbering(TRxNumbering).
SetNumberingStyle(TRxNumberingStyle) | Represents method SetNumberingStyle(TRxNumberingStyle).
SetNumberingTab(Word) | Represents method SetNumberingTab(Word).
SetRightIndent(Longint) | Represents method SetRightIndent(Longint).
SetSpaceAfter(Longint) | Represents method SetSpaceAfter(Longint).
SetSpaceBefore(Longint) | Represents method SetSpaceBefore(Longint).
SetTab(Byte,Longint) | Represents method SetTab(Byte,Longint).
SetTabCount(Integer) | Represents method SetTabCount(Integer).
SetTableStyle(TParaTableStyle) | Represents method SetTableStyle(TParaTableStyle).
Top


TRxParaAttributes.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxRichEdit
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure AssignTo(Dest: TPersistent); override;

Parameters

Dest
Type: TPersistent

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetAlignment Method

Summary

Represents method GetAlignment.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetAlignment: TParaAlignment;

Return Value

Type: TParaAlignment

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetAttributes(TParaFormat2) Method

Summary

Represents method GetAttributes(TParaFormat2).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure GetAttributes(var Paragraph: TParaFormat2);

Parameters

Paragraph
Type: TParaFormat2

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetFirstIndent Method

Summary

Represents method GetFirstIndent.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetFirstIndent: Longint;

Return Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetHeadingStyle Method

Summary

Represents method GetHeadingStyle.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetHeadingStyle: THeadingStyle;

Return Value

Type: THeadingStyle

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetLeftIndent Method

Summary

Represents method GetLeftIndent.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetLeftIndent: Longint;

Return Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetLineSpacing Method

Summary

Represents method GetLineSpacing.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetLineSpacing: Longint;

Return Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetLineSpacingRule Method

Summary

Represents method GetLineSpacingRule.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetLineSpacingRule: TLineSpacingRule;

Return Value

Type: TLineSpacingRule

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetNumbering Method

Summary

Represents method GetNumbering.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetNumbering: TRxNumbering;

Return Value

Type: TRxNumbering

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetNumberingStyle Method

Summary

Represents method GetNumberingStyle.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetNumberingStyle: TRxNumberingStyle;

Return Value

Type: TRxNumberingStyle

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetNumberingTab Method

Summary

Represents method GetNumberingTab.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetNumberingTab: Word;

Return Value

Type: Word

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetRightIndent Method

Summary

Represents method GetRightIndent.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetRightIndent: Longint;

Return Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetSpaceAfter Method

Summary

Represents method GetSpaceAfter.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetSpaceAfter: Longint;

Return Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetSpaceBefore Method

Summary

Represents method GetSpaceBefore.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetSpaceBefore: Longint;

Return Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetTab(Byte) Method

Summary

Represents method GetTab(Byte).

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetTab(Index: Byte): Longint;

Parameters

Index
Type: Byte

Return Value

Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetTabCount Method

Summary

Represents method GetTabCount.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetTabCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.GetTableStyle Method

Summary

Represents method GetTableStyle.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetTableStyle: TParaTableStyle;

Return Value

Type: TParaTableStyle

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.InitPara(TParaFormat2) Method

Summary

Represents method InitPara(TParaFormat2).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure InitPara(var Paragraph: TParaFormat2);

Parameters

Paragraph
Type: TParaFormat2

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetAlignment(TParaAlignment) Method

Summary

Represents method SetAlignment(TParaAlignment).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetAlignment(Value: TParaAlignment);

Parameters

Value
Type: TParaAlignment

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetAttributes(TParaFormat2) Method

Summary

Represents method SetAttributes(TParaFormat2).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetAttributes(var Paragraph: TParaFormat2);

Parameters

Paragraph
Type: TParaFormat2

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetFirstIndent(Longint) Method

Summary

Represents method SetFirstIndent(Longint).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetFirstIndent(Value: Longint);

Parameters

Value
Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetHeadingStyle(THeadingStyle) Method

Summary

Represents method SetHeadingStyle(THeadingStyle).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetHeadingStyle(Value: THeadingStyle);

Parameters

Value
Type: THeadingStyle

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetLeftIndent(Longint) Method

Summary

Represents method SetLeftIndent(Longint).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetLeftIndent(Value: Longint);

Parameters

Value
Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetLineSpacing(Longint) Method

Summary

Represents method SetLineSpacing(Longint).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetLineSpacing(Value: Longint);

Parameters

Value
Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetLineSpacingRule(TLineSpacingRule) Method

Summary

Represents method SetLineSpacingRule(TLineSpacingRule).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetLineSpacingRule(Value: TLineSpacingRule);

Parameters

Value
Type: TLineSpacingRule

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetNumbering(TRxNumbering) Method

Summary

Represents method SetNumbering(TRxNumbering).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetNumbering(Value: TRxNumbering);

Parameters

Value
Type: TRxNumbering

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetNumberingStyle(TRxNumberingStyle) Method

Summary

Represents method SetNumberingStyle(TRxNumberingStyle).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetNumberingStyle(Value: TRxNumberingStyle);

Parameters

Value
Type: TRxNumberingStyle

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetNumberingTab(Word) Method

Summary

Represents method SetNumberingTab(Word).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetNumberingTab(Value: Word);

Parameters

Value
Type: Word

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetRightIndent(Longint) Method

Summary

Represents method SetRightIndent(Longint).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetRightIndent(Value: Longint);

Parameters

Value
Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetSpaceAfter(Longint) Method

Summary

Represents method SetSpaceAfter(Longint).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetSpaceAfter(Value: Longint);

Parameters

Value
Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetSpaceBefore(Longint) Method

Summary

Represents method SetSpaceBefore(Longint).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetSpaceBefore(Value: Longint);

Parameters

Value
Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetTab(Byte,Longint) Method

Summary

Represents method SetTab(Byte,Longint).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetTab(Index: Byte; Value: Longint);

Parameters

Index
Type: Byte

Value
Type: Longint

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetTabCount(Integer) Method

Summary

Represents method SetTabCount(Integer).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetTabCount(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes.SetTableStyle(TParaTableStyle) Method

Summary

Represents method SetTableStyle(TParaTableStyle).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetTableStyle(Value: TParaTableStyle);

Parameters

Value
Type: TParaTableStyle

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxParaAttributes Fields

Fields
Name | Description
RichEdit | Represents field RichEdit.
Top


TRxParaAttributes.RichEdit Field

Summary

Represents field RichEdit.

Namespace: frxRichEdit
Syntax
Delphi
private
 RichEdit: TRxCustomRichEdit;

Field Value

Type: TRxCustomRichEdit

See Also

Reference

  • TRxParaAttributes
  • frxRichEdit


TRxRichEdit Class

Summary

Represents type TRxRichEdit.

Namespace: frxRichEdit
Inheritance Hierarchy
TCustomMemo
frxRichEdit.TRxCustomRichEdit
frxRichEdit.TRxRichEdit
frxUnicodeCtrls.TRxUnicodeRichEdit
Syntax
Delphi
type
 TRxRichEdit = class(TRxCustomRichEdit)
 end;

The TRxRichEdit type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TRxCustomRichEdit class. (Inherited from TRxCustomRichEdit.)
Top
Properties
Show:
Name | Description
Align | Represents property Align.
Alignment | Represents property Alignment.
AllowInPlace | Represents property AllowInPlace.
AllowObjects | Represents property AllowObjects.
Anchors | Represents property Anchors.
AutoURLDetect | Represents property AutoURLDetect.
AutoVerbMenu | Represents property AutoVerbMenu.
BiDiMode | Represents property BiDiMode.
BorderStyle | Represents property BorderStyle.
BorderWidth | Represents property BorderWidth.
CanFindNext | Represents property CanFindNext. (Inherited from TRxCustomRichEdit.)
CanPaste | Represents property CanPaste. (Inherited from TRxCustomRichEdit.)
CanRedo | Represents property CanRedo. (Inherited from TRxCustomRichEdit.)
Color | Represents property Color.
Constraints | Represents property Constraints.
Ctl3D | Represents property Ctl3D.
DefAttributes | Represents property DefAttributes. (Inherited from TRxCustomRichEdit.)
DefaultConverter | Represents property DefaultConverter. (Inherited from TRxCustomRichEdit.)
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
Enabled | Represents property Enabled.
Font | Represents property Font.
HideScrollBars | Represents property HideScrollBars.
HideSelection | Represents property HideSelection.
ImeMode | Represents property ImeMode.
ImeName | Represents property ImeName.
LangOptions | Represents property LangOptions.
Lines | Represents property Lines.
MaxLength | Represents property MaxLength.
OnChange | Represents property OnChange.
OnCloseFindDialog | Represents property OnCloseFindDialog.
OnContextPopup | Represents property OnContextPopup.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnMouseWheel | Represents property OnMouseWheel.
OnMouseWheelDown | Represents property OnMouseWheelDown.
OnMouseWheelUp | Represents property OnMouseWheelUp.
OnProtectChange | Represents property OnProtectChange.
OnProtectChangeEx | Represents property OnProtectChangeEx.
OnResizeRequest | Represents property OnResizeRequest.
OnSaveClipboard | Represents property OnSaveClipboard.
OnSelectionChange | Represents property OnSelectionChange.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
OnTextNotFound | Represents property OnTextNotFound.
OnURLClick | Represents property OnURLClick.
PageRect | Represents property PageRect. (Inherited from TRxCustomRichEdit.)
Paragraph | Represents property Paragraph. (Inherited from TRxCustomRichEdit.)
ParentBiDiMode | Represents property ParentBiDiMode.
ParentColor | Represents property ParentColor.
ParentCtl3D | Represents property ParentCtl3D.
ParentFont | Represents property ParentFont.
ParentShowHint | Represents property ParentShowHint.
PlainText | Represents property PlainText.
PopupMenu | Represents property PopupMenu.
ReadOnly | Represents property ReadOnly.
RedoName | Represents property RedoName. (Inherited from TRxCustomRichEdit.)
ScrollBars | Represents property ScrollBars.
SelAttributes | Represents property SelAttributes. (Inherited from TRxCustomRichEdit.)
SelectionBar | Represents property SelectionBar.
SelectionType | Represents property SelectionType. (Inherited from TRxCustomRichEdit.)
ShowHint | Represents property ShowHint.
StreamFormat | Represents property StreamFormat.
StreamMode | Represents property StreamMode.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Title | Represents property Title.
UndoLimit | Represents property UndoLimit.
UndoName | Represents property UndoName. (Inherited from TRxCustomRichEdit.)
Visible | Represents property Visible.
WantReturns | Represents property WantReturns.
WantTabs | Represents property WantTabs.
WordAttributes | Represents property WordAttributes. (Inherited from TRxCustomRichEdit.)
WordSelection | Represents property WordSelection.
WordWrap | Represents property WordWrap.
Top
Methods
Show:
Name | Description
Clear | Represents method Clear. (Inherited from TRxCustomRichEdit.)
ClearUndo | Represents method ClearUndo. (Inherited from TRxCustomRichEdit.)
CloseFindDialog(TFindDialog) | Represents method CloseFindDialog(TFindDialog). (Inherited from TRxCustomRichEdit.)
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams). (Inherited from TRxCustomRichEdit.)
CreateWindowHandle(TCreateParams) | Represents method CreateWindowHandle(TCreateParams). (Inherited from TRxCustomRichEdit.)
CreateWnd | Represents method CreateWnd. (Inherited from TRxCustomRichEdit.)
DestroyWnd | Represents method DestroyWnd. (Inherited from TRxCustomRichEdit.)
DoSetMaxLength(Integer) | Represents method DoSetMaxLength(Integer). (Inherited from TRxCustomRichEdit.)
FindDialog(string) | Represents method FindDialog(string). (Inherited from TRxCustomRichEdit.)
FindNext | Represents method FindNext. (Inherited from TRxCustomRichEdit.)
FindText(string,Integer,Integer,TRichSearchTypes) | Represents method FindText(string,Integer,Integer,TRichSearchTypes). (Inherited from TRxCustomRichEdit.)
GetCaretPos | Represents method GetCaretPos. (Inherited from TRxCustomRichEdit.)
GetCharPos(Integer) | Represents method GetCharPos(Integer). (Inherited from TRxCustomRichEdit.)
GetLineIndex(Integer) | Represents method GetLineIndex(Integer). (Inherited from TRxCustomRichEdit.)
GetLineLength(Integer) | Represents method GetLineLength(Integer). (Inherited from TRxCustomRichEdit.)
GetPopupMenu | Represents method GetPopupMenu. (Inherited from TRxCustomRichEdit.)
GetSelection | Represents method GetSelection. (Inherited from TRxCustomRichEdit.)
GetSelLength | Represents method GetSelLength. (Inherited from TRxCustomRichEdit.)
GetSelStart | Represents method GetSelStart. (Inherited from TRxCustomRichEdit.)
GetSelText | Represents method GetSelText. (Inherited from TRxCustomRichEdit.)
GetSelTextBuf(PChar,Integer) | Represents method GetSelTextBuf(PChar,Integer). (Inherited from TRxCustomRichEdit.)
GetTextLen | Represents method GetTextLen. (Inherited from TRxCustomRichEdit.)
GetTextRange(Longint,Longint) | Represents method GetTextRange(Longint,Longint). (Inherited from TRxCustomRichEdit.)
InsertObjectDialog | Represents method InsertObjectDialog. (Inherited from TRxCustomRichEdit.)
LineFromChar(Integer) | Represents method LineFromChar(Integer). (Inherited from TRxCustomRichEdit.)
ObjectPropertiesDialog | Represents method ObjectPropertiesDialog. (Inherited from TRxCustomRichEdit.)
PasteSpecialDialog | Represents method PasteSpecialDialog. (Inherited from TRxCustomRichEdit.)
Print(string) | Represents method Print(string). (Inherited from TRxCustomRichEdit.)
ProtectChange(TMessage,Integer,Integer) | Represents method ProtectChange(TMessage,Integer,Integer). (Inherited from TRxCustomRichEdit.)
Redo | Represents method Redo. (Inherited from TRxCustomRichEdit.)
RegisterConversionFormat(string,Boolean,TConversionClass) | Represents method RegisterConversionFormat(string,Boolean,TConversionClass). (Inherited from TRxCustomRichEdit.)
ReplaceDialog(string,string) | Represents method ReplaceDialog(string,string). (Inherited from TRxCustomRichEdit.)
RequestSize(TRect) | Represents method RequestSize(TRect). (Inherited from TRxCustomRichEdit.)
SaveClipboard(Integer,Integer) | Represents method SaveClipboard(Integer,Integer). (Inherited from TRxCustomRichEdit.)
SelectionChange | Represents method SelectionChange. (Inherited from TRxCustomRichEdit.)
SendSynchMessage(UINT,WPARAM,LPARAM,Boolean) | Represents method SendSynchMessage(UINT,WPARAM,LPARAM,Boolean). (Inherited from TRxCustomRichEdit.)
SetPlainText(Boolean) | Represents method SetPlainText(Boolean). (Inherited from TRxCustomRichEdit.)
SetSelection(Longint,Longint,Boolean) | Represents method SetSelection(Longint,Longint,Boolean). (Inherited from TRxCustomRichEdit.)
SetSelLength(Integer) | Represents method SetSelLength(Integer). (Inherited from TRxCustomRichEdit.)
SetSelStart(Integer) | Represents method SetSelStart(Integer). (Inherited from TRxCustomRichEdit.)
StopGroupTyping | Represents method StopGroupTyping. (Inherited from TRxCustomRichEdit.)
TextNotFound(TFindDialog) | Represents method TextNotFound(TFindDialog). (Inherited from TRxCustomRichEdit.)
URLClick(string,TMouseButton) | Represents method URLClick(string,TMouseButton). (Inherited from TRxCustomRichEdit.)
WordAtCursor | Represents method WordAtCursor. (Inherited from TRxCustomRichEdit.)
Top
See Also

Reference

  • frxRichEdit


TRxRichEdit Properties

Properties
Name | Description
Align | Represents property Align.
Alignment | Represents property Alignment.
AllowInPlace | Represents property AllowInPlace.
AllowObjects | Represents property AllowObjects.
Anchors | Represents property Anchors.
AutoURLDetect | Represents property AutoURLDetect.
AutoVerbMenu | Represents property AutoVerbMenu.
BiDiMode | Represents property BiDiMode.
BorderStyle | Represents property BorderStyle.
BorderWidth | Represents property BorderWidth.
Color | Represents property Color.
Constraints | Represents property Constraints.
Ctl3D | Represents property Ctl3D.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
Enabled | Represents property Enabled.
Font | Represents property Font.
HideScrollBars | Represents property HideScrollBars.
HideSelection | Represents property HideSelection.
ImeMode | Represents property ImeMode.
ImeName | Represents property ImeName.
LangOptions | Represents property LangOptions.
Lines | Represents property Lines.
MaxLength | Represents property MaxLength.
OnChange | Represents property OnChange.
OnCloseFindDialog | Represents property OnCloseFindDialog.
OnContextPopup | Represents property OnContextPopup.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnMouseWheel | Represents property OnMouseWheel.
OnMouseWheelDown | Represents property OnMouseWheelDown.
OnMouseWheelUp | Represents property OnMouseWheelUp.
OnProtectChange | Represents property OnProtectChange.
OnProtectChangeEx | Represents property OnProtectChangeEx.
OnResizeRequest | Represents property OnResizeRequest.
OnSaveClipboard | Represents property OnSaveClipboard.
OnSelectionChange | Represents property OnSelectionChange.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
OnTextNotFound | Represents property OnTextNotFound.
OnURLClick | Represents property OnURLClick.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentColor | Represents property ParentColor.
ParentCtl3D | Represents property ParentCtl3D.
ParentFont | Represents property ParentFont.
ParentShowHint | Represents property ParentShowHint.
PlainText | Represents property PlainText.
PopupMenu | Represents property PopupMenu.
ReadOnly | Represents property ReadOnly.
ScrollBars | Represents property ScrollBars.
SelectionBar | Represents property SelectionBar.
ShowHint | Represents property ShowHint.
StreamFormat | Represents property StreamFormat.
StreamMode | Represents property StreamMode.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Title | Represents property Title.
UndoLimit | Represents property UndoLimit.
Visible | Represents property Visible.
WantReturns | Represents property WantReturns.
WantTabs | Represents property WantTabs.
WordSelection | Represents property WordSelection.
WordWrap | Represents property WordWrap.
Top


TRxRichEdit.Align Property

Summary

Represents property Align.

Namespace: frxRichEdit
Syntax
Delphi
published
 property Align;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.Alignment Property

Summary

Represents property Alignment.

Namespace: frxRichEdit
Syntax
Delphi
published
 property Alignment;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.AllowInPlace Property

Summary

Represents property AllowInPlace.

Namespace: frxRichEdit
Syntax
Delphi
published
 property AllowInPlace;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.AllowObjects Property

Summary

Represents property AllowObjects.

Namespace: frxRichEdit
Syntax
Delphi
published
 property AllowObjects;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.Anchors Property

Summary

Represents property Anchors.

Namespace: frxRichEdit
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.AutoURLDetect Property

Summary

Represents property AutoURLDetect.

Namespace: frxRichEdit
Syntax
Delphi
published
 property AutoURLDetect;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.AutoVerbMenu Property

Summary

Represents property AutoVerbMenu.

Namespace: frxRichEdit
Syntax
Delphi
published
 property AutoVerbMenu;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.BiDiMode Property

Summary

Represents property BiDiMode.

Namespace: frxRichEdit
Syntax
Delphi
published
 property BiDiMode;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.BorderStyle Property

Summary

Represents property BorderStyle.

Namespace: frxRichEdit
Syntax
Delphi
published
 property BorderStyle;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.BorderWidth Property

Summary

Represents property BorderWidth.

Namespace: frxRichEdit
Syntax
Delphi
published
 property BorderWidth;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.Color Property

Summary

Represents property Color.

Namespace: frxRichEdit
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.Constraints Property

Summary

Represents property Constraints.

Namespace: frxRichEdit
Syntax
Delphi
published
 property Constraints;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.Ctl3D Property

Summary

Represents property Ctl3D.

Namespace: frxRichEdit
Syntax
Delphi
published
 property Ctl3D;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.DragCursor Property

Summary

Represents property DragCursor.

Namespace: frxRichEdit
Syntax
Delphi
published
 property DragCursor;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.DragKind Property

Summary

Represents property DragKind.

Namespace: frxRichEdit
Syntax
Delphi
published
 property DragKind;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.DragMode Property

Summary

Represents property DragMode.

Namespace: frxRichEdit
Syntax
Delphi
published
 property DragMode;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.Enabled Property

Summary

Represents property Enabled.

Namespace: frxRichEdit
Syntax
Delphi
published
 property Enabled;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.Font Property

Summary

Represents property Font.

Namespace: frxRichEdit
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.HideScrollBars Property

Summary

Represents property HideScrollBars.

Namespace: frxRichEdit
Syntax
Delphi
published
 property HideScrollBars;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.HideSelection Property

Summary

Represents property HideSelection.

Namespace: frxRichEdit
Syntax
Delphi
published
 property HideSelection;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.ImeMode Property

Summary

Represents property ImeMode.

Namespace: frxRichEdit
Syntax
Delphi
published
 property ImeMode;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.ImeName Property

Summary

Represents property ImeName.

Namespace: frxRichEdit
Syntax
Delphi
published
 property ImeName;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.LangOptions Property

Summary

Represents property LangOptions.

Namespace: frxRichEdit
Syntax
Delphi
published
 property LangOptions;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.Lines Property

Summary

Represents property Lines.

Namespace: frxRichEdit
Syntax
Delphi
published
 property Lines;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.MaxLength Property

Summary

Represents property MaxLength.

Namespace: frxRichEdit
Syntax
Delphi
published
 property MaxLength;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnChange Property

Summary

Represents property OnChange.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnChange;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnCloseFindDialog Property

Summary

Represents property OnCloseFindDialog.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnCloseFindDialog;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnContextPopup Property

Summary

Represents property OnContextPopup.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnContextPopup;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnDragDrop Property

Summary

Represents property OnDragDrop.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnDragDrop;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnDragOver Property

Summary

Represents property OnDragOver.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnDragOver;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnEndDock Property

Summary

Represents property OnEndDock.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnEndDock;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnEndDrag Property

Summary

Represents property OnEndDrag.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnEndDrag;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnExit Property

Summary

Represents property OnExit.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnMouseWheel Property

Summary

Represents property OnMouseWheel.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnMouseWheel;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnMouseWheelDown Property

Summary

Represents property OnMouseWheelDown.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnMouseWheelDown;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnMouseWheelUp Property

Summary

Represents property OnMouseWheelUp.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnMouseWheelUp;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnProtectChange Property

Summary

Represents property OnProtectChange.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnProtectChange;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnProtectChangeEx Property

Summary

Represents property OnProtectChangeEx.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnProtectChangeEx;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnResizeRequest Property

Summary

Represents property OnResizeRequest.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnResizeRequest;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnSaveClipboard Property

Summary

Represents property OnSaveClipboard.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnSaveClipboard;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnSelectionChange Property

Summary

Represents property OnSelectionChange.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnSelectionChange;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnStartDock Property

Summary

Represents property OnStartDock.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnStartDock;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnStartDrag Property

Summary

Represents property OnStartDrag.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnStartDrag;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnTextNotFound Property

Summary

Represents property OnTextNotFound.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnTextNotFound;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.OnURLClick Property

Summary

Represents property OnURLClick.

Namespace: frxRichEdit
Syntax
Delphi
published
 property OnURLClick;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.ParentBiDiMode Property

Summary

Represents property ParentBiDiMode.

Namespace: frxRichEdit
Syntax
Delphi
published
 property ParentBiDiMode;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.ParentColor Property

Summary

Represents property ParentColor.

Namespace: frxRichEdit
Syntax
Delphi
published
 property ParentColor;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.ParentCtl3D Property

Summary

Represents property ParentCtl3D.

Namespace: frxRichEdit
Syntax
Delphi
published
 property ParentCtl3D;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.ParentFont Property

Summary

Represents property ParentFont.

Namespace: frxRichEdit
Syntax
Delphi
published
 property ParentFont;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.ParentShowHint Property

Summary

Represents property ParentShowHint.

Namespace: frxRichEdit
Syntax
Delphi
published
 property ParentShowHint;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.PlainText Property

Summary

Represents property PlainText.

Namespace: frxRichEdit
Syntax
Delphi
published
 property PlainText;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: frxRichEdit
Syntax
Delphi
published
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: frxRichEdit
Syntax
Delphi
published
 property ReadOnly;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.ScrollBars Property

Summary

Represents property ScrollBars.

Namespace: frxRichEdit
Syntax
Delphi
published
 property ScrollBars;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.SelectionBar Property

Summary

Represents property SelectionBar.

Namespace: frxRichEdit
Syntax
Delphi
published
 property SelectionBar;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.ShowHint Property

Summary

Represents property ShowHint.

Namespace: frxRichEdit
Syntax
Delphi
published
 property ShowHint;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.StreamFormat Property

Summary

Represents property StreamFormat.

Namespace: frxRichEdit
Syntax
Delphi
published
 property StreamFormat;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.StreamMode Property

Summary

Represents property StreamMode.

Namespace: frxRichEdit
Syntax
Delphi
published
 property StreamMode;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.TabOrder Property

Summary

Represents property TabOrder.

Namespace: frxRichEdit
Syntax
Delphi
published
 property TabOrder;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.TabStop Property

Summary

Represents property TabStop.

Namespace: frxRichEdit
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.Title Property

Summary

Represents property Title.

Namespace: frxRichEdit
Syntax
Delphi
published
 property Title;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.UndoLimit Property

Summary

Represents property UndoLimit.

Namespace: frxRichEdit
Syntax
Delphi
published
 property UndoLimit;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.Visible Property

Summary

Represents property Visible.

Namespace: frxRichEdit
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.WantReturns Property

Summary

Represents property WantReturns.

Namespace: frxRichEdit
Syntax
Delphi
published
 property WantReturns;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.WantTabs Property

Summary

Represents property WantTabs.

Namespace: frxRichEdit
Syntax
Delphi
published
 property WantTabs;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.WordSelection Property

Summary

Represents property WordSelection.

Namespace: frxRichEdit
Syntax
Delphi
published
 property WordSelection;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxRichEdit.WordWrap Property

Summary

Represents property WordWrap.

Namespace: frxRichEdit
Syntax
Delphi
published
 property WordWrap;

Property Value

Type: Void

See Also

Reference

  • TRxRichEdit
  • frxRichEdit


TRxTextAttributes Class

Summary

Represents type TRxTextAttributes.

Namespace: frxRichEdit
Inheritance Hierarchy
TPersistent
frxRichEdit.TRxTextAttributes
Syntax
Delphi
type
 TRxTextAttributes = class(TPersistent)
 end;

The TRxTextAttributes type exposes the following members.

Constructors
Show:
Name | Description
Create(TRxCustomRichEdit,TRxAttributeType) | Initializes a new instance of the TRxTextAttributes class.
Top
Properties
Show:
Name | Description
BackColor | Represents property BackColor.
Charset | Represents property Charset.
Color | Represents property Color.
ConsistentAttributes | Represents property ConsistentAttributes.
Disabled | Represents property Disabled.
Height | Represents property Height.
Hidden | Represents property Hidden.
Link | Represents property Link.
Name | Represents property Name.
Offset | Represents property Offset.
Pitch | Represents property Pitch.
Protected | Represents property Protected.
RevAuthorIndex | Represents property RevAuthorIndex.
Size | Represents property Size.
Style | Represents property Style.
SubscriptStyle | Represents property SubscriptStyle.
UnderlineType | Represents property UnderlineType.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
AssignFont(TFont) | Represents method AssignFont(TFont).
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
GetAttributes(TCharFormat2) | Represents method GetAttributes(TCharFormat2).
GetBackColor | Represents method GetBackColor.
GetCharset | Represents method GetCharset.
GetColor | Represents method GetColor.
GetConsistentAttributes | Represents method GetConsistentAttributes.
GetDisabled | Represents method GetDisabled.
GetHeight | Represents method GetHeight.
GetHidden | Represents method GetHidden.
GetLink | Represents method GetLink.
GetName | Represents method GetName.
GetOffset | Represents method GetOffset.
GetPitch | Represents method GetPitch.
GetProtected | Represents method GetProtected.
GetRevAuthorIndex | Represents method GetRevAuthorIndex.
GetSize | Represents method GetSize.
GetStyle | Represents method GetStyle.
GetSubscriptStyle | Represents method GetSubscriptStyle.
GetUnderlineType | Represents method GetUnderlineType.
InitFormat(TCharFormat2) | Represents method InitFormat(TCharFormat2).
SetAttributes(TCharFormat2) | Represents method SetAttributes(TCharFormat2).
SetBackColor(TColor) | Represents method SetBackColor(TColor).
SetCharset(TFontCharset) | Represents method SetCharset(TFontCharset).
SetColor(TColor) | Represents method SetColor(TColor).
SetDisabled(Boolean) | Represents method SetDisabled(Boolean).
SetHeight(Integer) | Represents method SetHeight(Integer).
SetHidden(Boolean) | Represents method SetHidden(Boolean).
SetLink(Boolean) | Represents method SetLink(Boolean).
SetName(TFontName) | Represents method SetName(TFontName).
SetOffset(Integer) | Represents method SetOffset(Integer).
SetPitch(TFontPitch) | Represents method SetPitch(TFontPitch).
SetProtected(Boolean) | Represents method SetProtected(Boolean).
SetRevAuthorIndex(Byte) | Represents method SetRevAuthorIndex(Byte).
SetSize(Integer) | Represents method SetSize(Integer).
SetStyle(TFontStyles) | Represents method SetStyle(TFontStyles).
SetSubscriptStyle(TSubscriptStyle) | Represents method SetSubscriptStyle(TSubscriptStyle).
SetUnderlineType(TUnderlineType) | Represents method SetUnderlineType(TUnderlineType).
Top
Fields
Show:
Name | Description
FType | Represents field FType.
RichEdit | Represents field RichEdit.
Top
See Also

Reference

  • frxRichEdit


TRxTextAttributes Constructors

Constructors
Name | Description
Create(TRxCustomRichEdit,TRxAttributeType) | Initializes a new instance of the TRxTextAttributes class.
Top


TRxTextAttributes.Create(TRxCustomRichEdit,TRxAttributeType) Constructor

Summary

Initializes a new instance of the TRxTextAttributes class.

Namespace: frxRichEdit
Syntax
Delphi
public
 constructor Create(AOwner: TRxCustomRichEdit; AttributeType: TRxAttributeType);

Parameters

AOwner
Type: TRxCustomRichEdit

AttributeType
Type: TRxAttributeType

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes Properties

Properties
Name | Description
BackColor | Represents property BackColor.
Charset | Represents property Charset.
Color | Represents property Color.
ConsistentAttributes | Represents property ConsistentAttributes.
Disabled | Represents property Disabled.
Height | Represents property Height.
Hidden | Represents property Hidden.
Link | Represents property Link.
Name | Represents property Name.
Offset | Represents property Offset.
Pitch | Represents property Pitch.
Protected | Represents property Protected.
RevAuthorIndex | Represents property RevAuthorIndex.
Size | Represents property Size.
Style | Represents property Style.
SubscriptStyle | Represents property SubscriptStyle.
UnderlineType | Represents property UnderlineType.
Top


TRxTextAttributes.BackColor Property

Summary

Represents property BackColor.

Namespace: frxRichEdit
Syntax
Delphi
public
 property BackColor: TColor read GetBackColor write SetBackColor;

Property Value

Type: TColor

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.Charset Property

Summary

Represents property Charset.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Charset: TFontCharset read GetCharset write SetCharset;

Property Value

Type: TFontCharset

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.Color Property

Summary

Represents property Color.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Color: TColor read GetColor write SetColor;

Property Value

Type: TColor

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.ConsistentAttributes Property

Summary

Represents property ConsistentAttributes.

Namespace: frxRichEdit
Syntax
Delphi
public
 property ConsistentAttributes: TRxConsistentAttributes read GetConsistentAttributes;

Property Value

Type: TRxConsistentAttributes

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.Disabled Property

Summary

Represents property Disabled.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Disabled: Boolean read GetDisabled write SetDisabled;

Property Value

Type: Boolean

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.Height Property

Summary

Represents property Height.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Height: Integer read GetHeight write SetHeight;

Property Value

Type: Integer

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.Hidden Property

Summary

Represents property Hidden.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Hidden: Boolean read GetHidden write SetHidden;

Property Value

Type: Boolean

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.Link Property

Summary

Represents property Link.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Link: Boolean read GetLink write SetLink;

Property Value

Type: Boolean

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.Name Property

Summary

Represents property Name.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Name: TFontName read GetName write SetName;

Property Value

Type: TFontName

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.Offset Property

Summary

Represents property Offset.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Offset: Integer read GetOffset write SetOffset;

Property Value

Type: Integer

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.Pitch Property

Summary

Represents property Pitch.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Pitch: TFontPitch read GetPitch write SetPitch;

Property Value

Type: TFontPitch

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.Protected Property

Summary

Represents property Protected.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Protected: Boolean read GetProtected write SetProtected;

Property Value

Type: Boolean

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.RevAuthorIndex Property

Summary

Represents property RevAuthorIndex.

Namespace: frxRichEdit
Syntax
Delphi
public
 property RevAuthorIndex: Byte read GetRevAuthorIndex write SetRevAuthorIndex;

Property Value

Type: Byte

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.Size Property

Summary

Represents property Size.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Size: Integer read GetSize write SetSize;

Property Value

Type: Integer

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.Style Property

Summary

Represents property Style.

Namespace: frxRichEdit
Syntax
Delphi
public
 property Style: TFontStyles read GetStyle write SetStyle;

Property Value

Type: TFontStyles

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SubscriptStyle Property

Summary

Represents property SubscriptStyle.

Namespace: frxRichEdit
Syntax
Delphi
public
 property SubscriptStyle: TSubscriptStyle read GetSubscriptStyle write SetSubscriptStyle;

Property Value

Type: TSubscriptStyle

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.UnderlineType Property

Summary

Represents property UnderlineType.

Namespace: frxRichEdit
Syntax
Delphi
public
 property UnderlineType: TUnderlineType read GetUnderlineType write SetUnderlineType;

Property Value

Type: TUnderlineType

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
AssignFont(TFont) | Represents method AssignFont(TFont).
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
GetAttributes(TCharFormat2) | Represents method GetAttributes(TCharFormat2).
GetBackColor | Represents method GetBackColor.
GetCharset | Represents method GetCharset.
GetColor | Represents method GetColor.
GetConsistentAttributes | Represents method GetConsistentAttributes.
GetDisabled | Represents method GetDisabled.
GetHeight | Represents method GetHeight.
GetHidden | Represents method GetHidden.
GetLink | Represents method GetLink.
GetName | Represents method GetName.
GetOffset | Represents method GetOffset.
GetPitch | Represents method GetPitch.
GetProtected | Represents method GetProtected.
GetRevAuthorIndex | Represents method GetRevAuthorIndex.
GetSize | Represents method GetSize.
GetStyle | Represents method GetStyle.
GetSubscriptStyle | Represents method GetSubscriptStyle.
GetUnderlineType | Represents method GetUnderlineType.
InitFormat(TCharFormat2) | Represents method InitFormat(TCharFormat2).
SetAttributes(TCharFormat2) | Represents method SetAttributes(TCharFormat2).
SetBackColor(TColor) | Represents method SetBackColor(TColor).
SetCharset(TFontCharset) | Represents method SetCharset(TFontCharset).
SetColor(TColor) | Represents method SetColor(TColor).
SetDisabled(Boolean) | Represents method SetDisabled(Boolean).
SetHeight(Integer) | Represents method SetHeight(Integer).
SetHidden(Boolean) | Represents method SetHidden(Boolean).
SetLink(Boolean) | Represents method SetLink(Boolean).
SetName(TFontName) | Represents method SetName(TFontName).
SetOffset(Integer) | Represents method SetOffset(Integer).
SetPitch(TFontPitch) | Represents method SetPitch(TFontPitch).
SetProtected(Boolean) | Represents method SetProtected(Boolean).
SetRevAuthorIndex(Byte) | Represents method SetRevAuthorIndex(Byte).
SetSize(Integer) | Represents method SetSize(Integer).
SetStyle(TFontStyles) | Represents method SetStyle(TFontStyles).
SetSubscriptStyle(TSubscriptStyle) | Represents method SetSubscriptStyle(TSubscriptStyle).
SetUnderlineType(TUnderlineType) | Represents method SetUnderlineType(TUnderlineType).
Top


TRxTextAttributes.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxRichEdit
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.AssignFont(TFont) Method

Summary

Represents method AssignFont(TFont).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure AssignFont(Font: TFont);

Parameters

Font
Type: TFont

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure AssignTo(Dest: TPersistent); override;

Parameters

Dest
Type: TPersistent

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetAttributes(TCharFormat2) Method

Summary

Represents method GetAttributes(TCharFormat2).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure GetAttributes(var Format: TCharFormat2);

Parameters

Format
Type: System.Void

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetBackColor Method

Summary

Represents method GetBackColor.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetBackColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetCharset Method

Summary

Represents method GetCharset.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetCharset: TFontCharset;

Return Value

Type: TFontCharset

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetColor Method

Summary

Represents method GetColor.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetColor: TColor;

Return Value

Type: TColor

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetConsistentAttributes Method

Summary

Represents method GetConsistentAttributes.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetConsistentAttributes: TRxConsistentAttributes;

Return Value

Type: TRxConsistentAttributes

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetDisabled Method

Summary

Represents method GetDisabled.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetDisabled: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetHeight Method

Summary

Represents method GetHeight.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetHeight: Integer;

Return Value

Type: Integer

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetHidden Method

Summary

Represents method GetHidden.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetHidden: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetLink Method

Summary

Represents method GetLink.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetLink: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetName Method

Summary

Represents method GetName.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetName: TFontName;

Return Value

Type: TFontName

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetOffset Method

Summary

Represents method GetOffset.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetOffset: Integer;

Return Value

Type: Integer

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetPitch Method

Summary

Represents method GetPitch.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetPitch: TFontPitch;

Return Value

Type: TFontPitch

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetProtected Method

Summary

Represents method GetProtected.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetProtected: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetRevAuthorIndex Method

Summary

Represents method GetRevAuthorIndex.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetRevAuthorIndex: Byte;

Return Value

Type: Byte

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetSize Method

Summary

Represents method GetSize.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetSize: Integer;

Return Value

Type: Integer

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetStyle Method

Summary

Represents method GetStyle.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetStyle: TFontStyles;

Return Value

Type: TFontStyles

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetSubscriptStyle Method

Summary

Represents method GetSubscriptStyle.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetSubscriptStyle: TSubscriptStyle;

Return Value

Type: TSubscriptStyle

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.GetUnderlineType Method

Summary

Represents method GetUnderlineType.

Namespace: frxRichEdit
Syntax
Delphi
private
 function GetUnderlineType: TUnderlineType;

Return Value

Type: TUnderlineType

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.InitFormat(TCharFormat2) Method

Summary

Represents method InitFormat(TCharFormat2).

Namespace: frxRichEdit
Syntax
Delphi
protected
 procedure InitFormat(var Format: TCharFormat2);

Parameters

Format
Type: System.Void

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetAttributes(TCharFormat2) Method

Summary

Represents method SetAttributes(TCharFormat2).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetAttributes(var Format: TCharFormat2);

Parameters

Format
Type: System.Void

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetBackColor(TColor) Method

Summary

Represents method SetBackColor(TColor).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetBackColor(Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetCharset(TFontCharset) Method

Summary

Represents method SetCharset(TFontCharset).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetCharset(Value: TFontCharset);

Parameters

Value
Type: TFontCharset

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetColor(TColor) Method

Summary

Represents method SetColor(TColor).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetColor(Value: TColor);

Parameters

Value
Type: TColor

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetDisabled(Boolean) Method

Summary

Represents method SetDisabled(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetDisabled(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetHeight(Integer) Method

Summary

Represents method SetHeight(Integer).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetHeight(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetHidden(Boolean) Method

Summary

Represents method SetHidden(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetHidden(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetLink(Boolean) Method

Summary

Represents method SetLink(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetLink(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetName(TFontName) Method

Summary

Represents method SetName(TFontName).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetName(Value: TFontName);

Parameters

Value
Type: TFontName

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetOffset(Integer) Method

Summary

Represents method SetOffset(Integer).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetOffset(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetPitch(TFontPitch) Method

Summary

Represents method SetPitch(TFontPitch).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetPitch(Value: TFontPitch);

Parameters

Value
Type: TFontPitch

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetProtected(Boolean) Method

Summary

Represents method SetProtected(Boolean).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetProtected(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetRevAuthorIndex(Byte) Method

Summary

Represents method SetRevAuthorIndex(Byte).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetRevAuthorIndex(Value: Byte);

Parameters

Value
Type: Byte

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetSize(Integer) Method

Summary

Represents method SetSize(Integer).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetSize(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetStyle(TFontStyles) Method

Summary

Represents method SetStyle(TFontStyles).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetStyle(Value: TFontStyles);

Parameters

Value
Type: TFontStyles

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetSubscriptStyle(TSubscriptStyle) Method

Summary

Represents method SetSubscriptStyle(TSubscriptStyle).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetSubscriptStyle(Value: TSubscriptStyle);

Parameters

Value
Type: TSubscriptStyle

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.SetUnderlineType(TUnderlineType) Method

Summary

Represents method SetUnderlineType(TUnderlineType).

Namespace: frxRichEdit
Syntax
Delphi
private
 procedure SetUnderlineType(Value: TUnderlineType);

Parameters

Value
Type: TUnderlineType

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes Fields

Fields
Name | Description
FType | Represents field FType.
RichEdit | Represents field RichEdit.
Top


TRxTextAttributes.FType Field

Summary

Represents field FType.

Namespace: frxRichEdit
Syntax
Delphi
private
 FType: TRxAttributeType;

Field Value

Type: TRxAttributeType

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


TRxTextAttributes.RichEdit Field

Summary

Represents field RichEdit.

Namespace: frxRichEdit
Syntax
Delphi
private
 RichEdit: TRxCustomRichEdit;

Field Value

Type: TRxCustomRichEdit

See Also

Reference

  • TRxTextAttributes
  • frxRichEdit


frxRichEdit Records

Records
Name | Description
TCharFormat2A | Represents type TCharFormat2A.
TParaFormat2 | Represents type TParaFormat2.
TRichConversionFormat | Represents type TRichConversionFormat.
Top


TCharFormat2A Record

Summary

Represents type TCharFormat2A.

Namespace: frxRichEdit
Syntax
Delphi
type
 TCharFormat2A = record
 end;

The TCharFormat2A type exposes the following members.

Fields
Show:
Name | Description
bAnimation | Represents field bAnimation.
bCharSet | Represents field bCharSet.
bPitchAndFamily | Represents field bPitchAndFamily.
bReserved1 | Represents field bReserved1.
bRevAuthor | Represents field bRevAuthor.
bUnderlineType | Represents field bUnderlineType.
cbSize | Represents field cbSize.
crBackColor | Represents field crBackColor.
crTextColor | Represents field crTextColor.
dwEffects | Represents field dwEffects.
dwMask | Represents field dwMask.
dwReserved | Represents field dwReserved.
lid | Represents field lid.
sSpacing | Represents field sSpacing.
sStyle | Represents field sStyle.
szFaceName | Represents field szFaceName.
wKerning | Represents field wKerning.
wWeight | Represents field wWeight.
yHeight | Represents field yHeight.
yOffset | Represents field yOffset.
Top
See Also

Reference

  • frxRichEdit


TCharFormat2A Fields

Fields
Name | Description
bAnimation | Represents field bAnimation.
bCharSet | Represents field bCharSet.
bPitchAndFamily | Represents field bPitchAndFamily.
bReserved1 | Represents field bReserved1.
bRevAuthor | Represents field bRevAuthor.
bUnderlineType | Represents field bUnderlineType.
cbSize | Represents field cbSize.
crBackColor | Represents field crBackColor.
crTextColor | Represents field crTextColor.
dwEffects | Represents field dwEffects.
dwMask | Represents field dwMask.
dwReserved | Represents field dwReserved.
lid | Represents field lid.
sSpacing | Represents field sSpacing.
sStyle | Represents field sStyle.
szFaceName | Represents field szFaceName.
wKerning | Represents field wKerning.
wWeight | Represents field wWeight.
yHeight | Represents field yHeight.
yOffset | Represents field yOffset.
Top


TCharFormat2A.bAnimation Field

Summary

Represents field bAnimation.

Namespace: frxRichEdit
Syntax
Delphi
public
 bAnimation: Byte;

Field Value

Type: Byte

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.bCharSet Field

Summary

Represents field bCharSet.

Namespace: frxRichEdit
Syntax
Delphi
public
 bCharSet: Byte;

Field Value

Type: Byte

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.bPitchAndFamily Field

Summary

Represents field bPitchAndFamily.

Namespace: frxRichEdit
Syntax
Delphi
public
 bPitchAndFamily: Byte;

Field Value

Type: Byte

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.bReserved1 Field

Summary

Represents field bReserved1.

Namespace: frxRichEdit
Syntax
Delphi
public
 bReserved1: Byte;

Field Value

Type: Byte

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.bRevAuthor Field

Summary

Represents field bRevAuthor.

Namespace: frxRichEdit
Syntax
Delphi
public
 bRevAuthor: Byte;

Field Value

Type: Byte

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.bUnderlineType Field

Summary

Represents field bUnderlineType.

Namespace: frxRichEdit
Syntax
Delphi
public
 bUnderlineType: Byte;

Field Value

Type: Byte

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.cbSize Field

Summary

Represents field cbSize.

Namespace: frxRichEdit
Syntax
Delphi
public
 cbSize: UINT;

Field Value

Type: UINT

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.crBackColor Field

Summary

Represents field crBackColor.

Namespace: frxRichEdit
Syntax
Delphi
public
 crBackColor: TColorRef;

Field Value

Type: TColorRef

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.crTextColor Field

Summary

Represents field crTextColor.

Namespace: frxRichEdit
Syntax
Delphi
public
 crTextColor: TColorRef;

Field Value

Type: TColorRef

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.dwEffects Field

Summary

Represents field dwEffects.

Namespace: frxRichEdit
Syntax
Delphi
public
 dwEffects: DWORD;

Field Value

Type: DWORD

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.dwMask Field

Summary

Represents field dwMask.

Namespace: frxRichEdit
Syntax
Delphi
public
 dwMask: DWORD;

Field Value

Type: DWORD

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.dwReserved Field

Summary

Represents field dwReserved.

Namespace: frxRichEdit
Syntax
Delphi
public
 dwReserved: DWORD;

Field Value

Type: DWORD

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.lid Field

Summary

Represents field lid.

Namespace: frxRichEdit
Syntax
Delphi
public
 lid: LCID;

Field Value

Type: LCID

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.sSpacing Field

Summary

Represents field sSpacing.

Namespace: frxRichEdit
Syntax
Delphi
public
 sSpacing: Smallint;

Field Value

Type: Smallint

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.sStyle Field

Summary

Represents field sStyle.

Namespace: frxRichEdit
Syntax
Delphi
public
 sStyle: Smallint;

Field Value

Type: Smallint

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.szFaceName Field

Summary

Represents field szFaceName.

Namespace: frxRichEdit
Syntax
Delphi
public
 szFaceName: array[0..LF_FACESIZE - 1] of Char;

Field Value

Type: array[0..LF_FACESIZE - 1] of Char

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.wKerning Field

Summary

Represents field wKerning.

Namespace: frxRichEdit
Syntax
Delphi
public
 wKerning: Word;

Field Value

Type: Word

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.wWeight Field

Summary

Represents field wWeight.

Namespace: frxRichEdit
Syntax
Delphi
public
 wWeight: Word;

Field Value

Type: Word

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.yHeight Field

Summary

Represents field yHeight.

Namespace: frxRichEdit
Syntax
Delphi
public
 yHeight: Longint;

Field Value

Type: Longint

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TCharFormat2A.yOffset Field

Summary

Represents field yOffset.

Namespace: frxRichEdit
Syntax
Delphi
public
 yOffset: Longint;

Field Value

Type: Longint

See Also

Reference

  • TCharFormat2A
  • frxRichEdit


TParaFormat2 Record

Summary

Represents type TParaFormat2.

Namespace: frxRichEdit
Syntax
Delphi
type
 TParaFormat2 = record
 end;

The TParaFormat2 type exposes the following members.

Fields
Show:
Name | Description
bCRC | Represents field bCRC.
bLineSpacingRule | Represents field bLineSpacingRule.
cbSize | Represents field cbSize.
cTabCount | Represents field cTabCount.
dwMask | Represents field dwMask.
dxOffset | Represents field dxOffset.
dxRightIndent | Represents field dxRightIndent.
dxStartIndent | Represents field dxStartIndent.
dyLineSpacing | Represents field dyLineSpacing.
dySpaceAfter | Represents field dySpaceAfter.
dySpaceBefore | Represents field dySpaceBefore.
rgxTabs | Represents field rgxTabs.
sStyle | Represents field sStyle.
wAlignment | Represents field wAlignment.
wBorders | Represents field wBorders.
wBorderSpace | Represents field wBorderSpace.
wBorderWidth | Represents field wBorderWidth.
wNumbering | Represents field wNumbering.
wNumberingStart | Represents field wNumberingStart.
wNumberingStyle | Represents field wNumberingStyle.
wNumberingTab | Represents field wNumberingTab.
wReserved | Represents field wReserved.
wShadingStyle | Represents field wShadingStyle.
wShadingWeight | Represents field wShadingWeight.
Top
See Also

Reference

  • frxRichEdit


TParaFormat2 Fields

Fields
Name | Description
bCRC | Represents field bCRC.
bLineSpacingRule | Represents field bLineSpacingRule.
cbSize | Represents field cbSize.
cTabCount | Represents field cTabCount.
dwMask | Represents field dwMask.
dxOffset | Represents field dxOffset.
dxRightIndent | Represents field dxRightIndent.
dxStartIndent | Represents field dxStartIndent.
dyLineSpacing | Represents field dyLineSpacing.
dySpaceAfter | Represents field dySpaceAfter.
dySpaceBefore | Represents field dySpaceBefore.
rgxTabs | Represents field rgxTabs.
sStyle | Represents field sStyle.
wAlignment | Represents field wAlignment.
wBorders | Represents field wBorders.
wBorderSpace | Represents field wBorderSpace.
wBorderWidth | Represents field wBorderWidth.
wNumbering | Represents field wNumbering.
wNumberingStart | Represents field wNumberingStart.
wNumberingStyle | Represents field wNumberingStyle.
wNumberingTab | Represents field wNumberingTab.
wReserved | Represents field wReserved.
wShadingStyle | Represents field wShadingStyle.
wShadingWeight | Represents field wShadingWeight.
Top


TParaFormat2.bCRC Field

Summary

Represents field bCRC.

Namespace: frxRichEdit
Syntax
Delphi
public
 bCRC: Byte;

Field Value

Type: Byte

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.bLineSpacingRule Field

Summary

Represents field bLineSpacingRule.

Namespace: frxRichEdit
Syntax
Delphi
public
 bLineSpacingRule: Byte;

Field Value

Type: Byte

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.cbSize Field

Summary

Represents field cbSize.

Namespace: frxRichEdit
Syntax
Delphi
public
 cbSize: UINT;

Field Value

Type: UINT

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.cTabCount Field

Summary

Represents field cTabCount.

Namespace: frxRichEdit
Syntax
Delphi
public
 cTabCount: Smallint;

Field Value

Type: Smallint

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.dwMask Field

Summary

Represents field dwMask.

Namespace: frxRichEdit
Syntax
Delphi
public
 dwMask: DWORD;

Field Value

Type: DWORD

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.dxOffset Field

Summary

Represents field dxOffset.

Namespace: frxRichEdit
Syntax
Delphi
public
 dxOffset: Longint;

Field Value

Type: Longint

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.dxRightIndent Field

Summary

Represents field dxRightIndent.

Namespace: frxRichEdit
Syntax
Delphi
public
 dxRightIndent: Longint;

Field Value

Type: Longint

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.dxStartIndent Field

Summary

Represents field dxStartIndent.

Namespace: frxRichEdit
Syntax
Delphi
public
 dxStartIndent: Longint;

Field Value

Type: Longint

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.dyLineSpacing Field

Summary

Represents field dyLineSpacing.

Namespace: frxRichEdit
Syntax
Delphi
public
 dyLineSpacing: Longint;

Field Value

Type: Longint

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.dySpaceAfter Field

Summary

Represents field dySpaceAfter.

Namespace: frxRichEdit
Syntax
Delphi
public
 dySpaceAfter: Longint;

Field Value

Type: Longint

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.dySpaceBefore Field

Summary

Represents field dySpaceBefore.

Namespace: frxRichEdit
Syntax
Delphi
public
 dySpaceBefore: Longint;

Field Value

Type: Longint

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.rgxTabs Field

Summary

Represents field rgxTabs.

Namespace: frxRichEdit
Syntax
Delphi
public
 rgxTabs: array [0..MAX_TAB_STOPS - 1] of Longint;

Field Value

Type: array [0..MAX_TAB_STOPS - 1] of Longint

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.sStyle Field

Summary

Represents field sStyle.

Namespace: frxRichEdit
Syntax
Delphi
public
 sStyle: Smallint;

Field Value

Type: Smallint

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.wAlignment Field

Summary

Represents field wAlignment.

Namespace: frxRichEdit
Syntax
Delphi
public
 wAlignment: Word;

Field Value

Type: Word

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.wBorders Field

Summary

Represents field wBorders.

Namespace: frxRichEdit
Syntax
Delphi
public
 wBorders: Word;

Field Value

Type: Word

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.wBorderSpace Field

Summary

Represents field wBorderSpace.

Namespace: frxRichEdit
Syntax
Delphi
public
 wBorderSpace: Word;

Field Value

Type: Word

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.wBorderWidth Field

Summary

Represents field wBorderWidth.

Namespace: frxRichEdit
Syntax
Delphi
public
 wBorderWidth: Word;

Field Value

Type: Word

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.wNumbering Field

Summary

Represents field wNumbering.

Namespace: frxRichEdit
Syntax
Delphi
public
 wNumbering: Word;

Field Value

Type: Word

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.wNumberingStart Field

Summary

Represents field wNumberingStart.

Namespace: frxRichEdit
Syntax
Delphi
public
 wNumberingStart: Word;

Field Value

Type: Word

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.wNumberingStyle Field

Summary

Represents field wNumberingStyle.

Namespace: frxRichEdit
Syntax
Delphi
public
 wNumberingStyle: Word;

Field Value

Type: Word

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.wNumberingTab Field

Summary

Represents field wNumberingTab.

Namespace: frxRichEdit
Syntax
Delphi
public
 wNumberingTab: Word;

Field Value

Type: Word

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.wReserved Field

Summary

Represents field wReserved.

Namespace: frxRichEdit
Syntax
Delphi
public
 wReserved: Word;

Field Value

Type: Word

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.wShadingStyle Field

Summary

Represents field wShadingStyle.

Namespace: frxRichEdit
Syntax
Delphi
public
 wShadingStyle: Word;

Field Value

Type: Word

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TParaFormat2.wShadingWeight Field

Summary

Represents field wShadingWeight.

Namespace: frxRichEdit
Syntax
Delphi
public
 wShadingWeight: Word;

Field Value

Type: Word

See Also

Reference

  • TParaFormat2
  • frxRichEdit


TRichConversionFormat Record

Summary

Represents type TRichConversionFormat.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichConversionFormat = record
 end;

The TRichConversionFormat type exposes the following members.

Fields
Show:
Name | Description
ConversionClass | Represents field ConversionClass.
Extension | Represents field Extension.
Next | Represents field Next.
PlainText | Represents field PlainText.
Top
See Also

Reference

  • frxRichEdit


TRichConversionFormat Fields

Fields
Name | Description
ConversionClass | Represents field ConversionClass.
Extension | Represents field Extension.
Next | Represents field Next.
PlainText | Represents field PlainText.
Top


TRichConversionFormat.ConversionClass Field

Summary

Represents field ConversionClass.

Namespace: frxRichEdit
Syntax
Delphi
public
 ConversionClass: TConversionClass;

Field Value

Type: TConversionClass

See Also

Reference

  • TRichConversionFormat
  • frxRichEdit


TRichConversionFormat.Extension Field

Summary

Represents field Extension.

Namespace: frxRichEdit
Syntax
Delphi
public
 Extension: string;

Field Value

Type: string

See Also

Reference

  • TRichConversionFormat
  • frxRichEdit


TRichConversionFormat.Next Field

Summary

Represents field Next.

Namespace: frxRichEdit
Syntax
Delphi
public
 Next: PRichConversionFormat;

Field Value

Type: PRichConversionFormat

See Also

Reference

  • TRichConversionFormat
  • frxRichEdit


TRichConversionFormat.PlainText Field

Summary

Represents field PlainText.

Namespace: frxRichEdit
Syntax
Delphi
public
 PlainText: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRichConversionFormat
  • frxRichEdit


frxRichEdit Enumerations

Enumerations
Name | Description
TLineSpacingRule | Represents type TLineSpacingRule.
TParaAlignment | Represents type TParaAlignment.
TParaTableStyle | Represents type TParaTableStyle.
TRichLangOption | Represents type TRichLangOption.
TRichSearchType | Represents type TRichSearchType.
TRichSelection | Represents type TRichSelection.
TRichStreamFormat | Represents type TRichStreamFormat.
TRichStreamMode | Represents type TRichStreamMode.
TRxAttributeType | Represents type TRxAttributeType.
TRxConsistentAttribute | Represents type TRxConsistentAttribute.
TRxNumbering | Represents type TRxNumbering.
TRxNumberingStyle | Represents type TRxNumberingStyle.
TSubscriptStyle | Represents type TSubscriptStyle.
TUnderlineType | Represents type TUnderlineType.
TUndoName | Represents type TUndoName.
Top


TLineSpacingRule Enumeration

Summary

Represents type TLineSpacingRule.

Namespace: frxRichEdit
Syntax
Delphi
type
 TLineSpacingRule = (lsSingle, lsOneAndHalf, lsDouble, lsSpecifiedOrMore,
 lsSpecified, lsMultiple);

The TLineSpacingRule type exposes the following members.

Members
Show:
Name | Description
lsDouble | Represents constant lsDouble.
lsMultiple | Represents constant lsMultiple.
lsOneAndHalf | Represents constant lsOneAndHalf.
lsSingle | Represents constant lsSingle.
lsSpecified | Represents constant lsSpecified.
lsSpecifiedOrMore | Represents constant lsSpecifiedOrMore.
Top
See Also

Reference

  • frxRichEdit


TParaAlignment Enumeration

Summary

Represents type TParaAlignment.

Namespace: frxRichEdit
Syntax
Delphi
type
 TParaAlignment = (paLeftJustify, paRightJustify, paCenter, paJustify);

The TParaAlignment type exposes the following members.

Members
Show:
Name | Description
paCenter | Represents constant paCenter.
paJustify | Represents constant paJustify.
paLeftJustify | Represents constant paLeftJustify.
paRightJustify | Represents constant paRightJustify.
Top
See Also

Reference

  • frxRichEdit


TParaTableStyle Enumeration

Summary

Represents type TParaTableStyle.

Namespace: frxRichEdit
Syntax
Delphi
type
 TParaTableStyle = (tsNone, tsTableRow, tsTableCellEnd, tsTableCell);

The TParaTableStyle type exposes the following members.

Members
Show:
Name | Description
tsNone | Represents constant tsNone.
tsTableCell | Represents constant tsTableCell.
tsTableCellEnd | Represents constant tsTableCellEnd.
tsTableRow | Represents constant tsTableRow.
Top
See Also

Reference

  • frxRichEdit


TRichLangOption Enumeration

Summary

Represents type TRichLangOption.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichLangOption = (rlAutoKeyboard, rlAutoFont, rlImeCancelComplete,
 rlImeAlwaysSendNotify);

The TRichLangOption type exposes the following members.

Members
Show:
Name | Description
rlAutoFont | Represents constant rlAutoFont.
rlAutoKeyboard | Represents constant rlAutoKeyboard.
rlImeAlwaysSendNotify | Represents constant rlImeAlwaysSendNotify.
rlImeCancelComplete | Represents constant rlImeCancelComplete.
Top
See Also

Reference

  • frxRichEdit


TRichSearchType Enumeration

Summary

Represents type TRichSearchType.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichSearchType = (stWholeWord, stMatchCase, stBackward, stSetSelection);

The TRichSearchType type exposes the following members.

Members
Show:
Name | Description
stBackward | Represents constant stBackward.
stMatchCase | Represents constant stMatchCase.
stSetSelection | Represents constant stSetSelection.
stWholeWord | Represents constant stWholeWord.
Top
See Also

Reference

  • frxRichEdit


TRichSelection Enumeration

Summary

Represents type TRichSelection.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichSelection = (stText, stObject, stMultiChar, stMultiObject);

The TRichSelection type exposes the following members.

Members
Show:
Name | Description
stMultiChar | Represents constant stMultiChar.
stMultiObject | Represents constant stMultiObject.
stObject | Represents constant stObject.
stText | Represents constant stText.
Top
See Also

Reference

  • frxRichEdit


TRichStreamFormat Enumeration

Summary

Represents type TRichStreamFormat.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichStreamFormat = (sfDefault, sfRichText, sfPlainText);

The TRichStreamFormat type exposes the following members.

Members
Show:
Name | Description
sfDefault | Represents constant sfDefault.
sfPlainText | Represents constant sfPlainText.
sfRichText | Represents constant sfRichText.
Top
See Also

Reference

  • frxRichEdit


TRichStreamMode Enumeration

Summary

Represents type TRichStreamMode.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichStreamMode = (smSelection, smPlainRtf, smNoObjects, smUnicode);

The TRichStreamMode type exposes the following members.

Members
Show:
Name | Description
smNoObjects | Represents constant smNoObjects.
smPlainRtf | Represents constant smPlainRtf.
smSelection | Represents constant smSelection.
smUnicode | Represents constant smUnicode.
Top
See Also

Reference

  • frxRichEdit


TRxAttributeType Enumeration

Summary

Represents type TRxAttributeType.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRxAttributeType = (atDefaultText, atSelected, atWord);

The TRxAttributeType type exposes the following members.

Members
Show:
Name | Description
atDefaultText | Represents constant atDefaultText.
atSelected | Represents constant atSelected.
atWord | Represents constant atWord.
Top
See Also

Reference

  • frxRichEdit


TRxConsistentAttribute Enumeration

Summary

Represents type TRxConsistentAttribute.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRxConsistentAttribute = (caBold, caColor, caFace, caItalic, caSize,
 caStrikeOut, caUnderline, caProtected, caOffset, caHidden, caLink,
 caBackColor, caDisabled, caWeight, caSubscript, caRevAuthor);

The TRxConsistentAttribute type exposes the following members.

Members
Show:
Name | Description
caBackColor | Represents constant caBackColor.
caBold | Represents constant caBold.
caColor | Represents constant caColor.
caDisabled | Represents constant caDisabled.
caFace | Represents constant caFace.
caHidden | Represents constant caHidden.
caItalic | Represents constant caItalic.
caLink | Represents constant caLink.
caOffset | Represents constant caOffset.
caProtected | Represents constant caProtected.
caRevAuthor | Represents constant caRevAuthor.
caSize | Represents constant caSize.
caStrikeOut | Represents constant caStrikeOut.
caSubscript | Represents constant caSubscript.
caUnderline | Represents constant caUnderline.
caWeight | Represents constant caWeight.
Top
See Also

Reference

  • frxRichEdit


TRxNumbering Enumeration

Summary

Represents type TRxNumbering.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRxNumbering = (nsNone, nsBullet, nsArabicNumbers, nsLoCaseLetter,
 nsUpCaseLetter, nsLoCaseRoman, nsUpCaseRoman);

The TRxNumbering type exposes the following members.

Members
Show:
Name | Description
nsArabicNumbers | Represents constant nsArabicNumbers.
nsBullet | Represents constant nsBullet.
nsLoCaseLetter | Represents constant nsLoCaseLetter.
nsLoCaseRoman | Represents constant nsLoCaseRoman.
nsNone | Represents constant nsNone.
nsUpCaseLetter | Represents constant nsUpCaseLetter.
nsUpCaseRoman | Represents constant nsUpCaseRoman.
Top
See Also

Reference

  • frxRichEdit


TRxNumberingStyle Enumeration

Summary

Represents type TRxNumberingStyle.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRxNumberingStyle = (nsParenthesis, nsPeriod, nsEnclosed, nsSimple);

The TRxNumberingStyle type exposes the following members.

Members
Show:
Name | Description
nsEnclosed | Represents constant nsEnclosed.
nsParenthesis | Represents constant nsParenthesis.
nsPeriod | Represents constant nsPeriod.
nsSimple | Represents constant nsSimple.
Top
See Also

Reference

  • frxRichEdit


TSubscriptStyle Enumeration

Summary

Represents type TSubscriptStyle.

Namespace: frxRichEdit
Syntax
Delphi
type
 TSubscriptStyle = (ssNone, ssSubscript, ssSuperscript);

The TSubscriptStyle type exposes the following members.

Members
Show:
Name | Description
ssNone | Represents constant ssNone.
ssSubscript | Represents constant ssSubscript.
ssSuperscript | Represents constant ssSuperscript.
Top
See Also

Reference

  • frxRichEdit


TUnderlineType Enumeration

Summary

Represents type TUnderlineType.

Namespace: frxRichEdit
Syntax
Delphi
type
 TUnderlineType = (utNone, utSolid, utWord, utDouble, utDotted, utWave);

The TUnderlineType type exposes the following members.

Members
Show:
Name | Description
utDotted | Represents constant utDotted.
utDouble | Represents constant utDouble.
utNone | Represents constant utNone.
utSolid | Represents constant utSolid.
utWave | Represents constant utWave.
utWord | Represents constant utWord.
Top
See Also

Reference

  • frxRichEdit


TUndoName Enumeration

Summary

Represents type TUndoName.

Namespace: frxRichEdit
Syntax
Delphi
type
 TUndoName = (unUnknown, unTyping, unDelete, unDragDrop, unCut, unPaste);

The TUndoName type exposes the following members.

Members
Show:
Name | Description
unCut | Represents constant unCut.
unDelete | Represents constant unDelete.
unDragDrop | Represents constant unDragDrop.
unPaste | Represents constant unPaste.
unTyping | Represents constant unTyping.
unUnknown | Represents constant unUnknown.
Top
See Also

Reference

  • frxRichEdit


frxRichEdit Delegates

Delegates
Name | Description
TRichEditFindCloseEvent | Represents type TRichEditFindCloseEvent.
TRichEditFindErrorEvent | Represents type TRichEditFindErrorEvent.
TRichEditProtectChangeEx | Represents type TRichEditProtectChangeEx.
TRichEditURLClickEvent | Represents type TRichEditURLClickEvent.
Top


TRichEditFindCloseEvent Delegate

Summary

Represents type TRichEditFindCloseEvent.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichEditFindCloseEvent = procedure(Sender: TObject; Dialog: TFindDialog) of object;
See Also

Reference

  • frxRichEdit


TRichEditFindErrorEvent Delegate

Summary

Represents type TRichEditFindErrorEvent.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichEditFindErrorEvent = procedure(Sender: TObject; const FindText: string) of object;
See Also

Reference

  • frxRichEdit


TRichEditProtectChangeEx Delegate

Summary

Represents type TRichEditProtectChangeEx.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichEditProtectChangeEx = procedure(Sender: TObject; const Message: TMessage;
 StartPos, EndPos: Integer; var AllowChange: Boolean) of object;
See Also

Reference

  • frxRichEdit


TRichEditURLClickEvent Delegate

Summary

Represents type TRichEditURLClickEvent.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichEditURLClickEvent = procedure(Sender: TObject; const URLText: string;
 Button: TMouseButton) of object;
See Also

Reference

  • frxRichEdit


frxRichEdit Types

Types
Name | Description
frxInteger | Represents an alias of the NativeInt type.
PRichConversionFormat | Represents a pointer type to TRichConversionFormat.
TCharFormat2 | Represents an alias of the TCharFormat2A type.
THeadingStyle | Represents type THeadingStyle.
TRichEditVersion | Represents type TRichEditVersion.
TRichLangOptions | Represents type TRichLangOptions.
TRichSearchTypes | Represents type TRichSearchTypes.
TRichSelectionType | Represents type TRichSelectionType.
TRichStreamModes | Represents type TRichStreamModes.
TRxConsistentAttributes | Represents type TRxConsistentAttributes.
Top


frxInteger Type

Summary

Represents an alias of the NativeInt type.

Namespace: frxRichEdit
Syntax
Delphi
type
 frxInteger = NativeInt;
See Also

Reference

  • frxRichEdit


PRichConversionFormat Type

Summary

Represents a pointer type to TRichConversionFormat.

Namespace: frxRichEdit
Syntax
Delphi
type
 PRichConversionFormat = ^TRichConversionFormat;
See Also

Reference

  • frxRichEdit


TCharFormat2 Type

Summary

Represents an alias of the TCharFormat2A type.

Namespace: frxRichEdit
Syntax
Delphi
type
 TCharFormat2 = TCharFormat2A;
See Also

Reference

  • frxRichEdit


THeadingStyle Type

Summary

Represents type THeadingStyle.

Namespace: frxRichEdit
Syntax
Delphi
type
 THeadingStyle = 0..9;
See Also

Reference

  • frxRichEdit


TRichEditVersion Type

Summary

Represents type TRichEditVersion.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichEditVersion = 1..4;
See Also

Reference

  • frxRichEdit


TRichLangOptions Type

Summary

Represents type TRichLangOptions.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichLangOptions = set of TRichLangOption;
See Also

Reference

  • frxRichEdit


TRichSearchTypes Type

Summary

Represents type TRichSearchTypes.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichSearchTypes = set of TRichSearchType;
See Also

Reference

  • frxRichEdit


TRichSelectionType Type

Summary

Represents type TRichSelectionType.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichSelectionType = set of TRichSelection;
See Also

Reference

  • frxRichEdit


TRichStreamModes Type

Summary

Represents type TRichStreamModes.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRichStreamModes = set of TRichStreamMode;
See Also

Reference

  • frxRichEdit


TRxConsistentAttributes Type

Summary

Represents type TRxConsistentAttributes.

Namespace: frxRichEdit
Syntax
Delphi
type
 TRxConsistentAttributes = set of TRxConsistentAttribute;
See Also

Reference

  • frxRichEdit


frxRichEdit Variables

Variables
Name | Description
IsWin10 | Represents variable IsWin10.
IsWin8 | Represents variable IsWin8.
RichEditVersion | Represents variable RichEditVersion.
Top


IsWin10 Variable

Summary

Represents variable IsWin10.

Namespace: frxRichEdit
Syntax
Delphi
IsWin10: Boolean;

Value

Type: Boolean

See Also

Reference

  • frxRichEdit


IsWin8 Variable

Summary

Represents variable IsWin8.

Namespace: frxRichEdit
Syntax
Delphi
IsWin8: Boolean;

Value

Type: Boolean

See Also

Reference

  • frxRichEdit


RichEditVersion Variable

Summary

Represents variable RichEditVersion.

Namespace: frxRichEdit
Syntax
Delphi
RichEditVersion: TRichEditVersion;

Value

Type: TRichEditVersion

See Also

Reference

  • frxRichEdit


frxServerUtils Namespace

Summary

Represents namespace frxServerUtils.

Enumerations
Name | Description
TfrxHTTPQueryType | Represents type TfrxHTTPQueryType.
TfrxServerFormat | Represents type TfrxServerFormat.
Top
Types
Name | Description
TfrxServerOutputFormats | Represents type TfrxServerOutputFormats.
Top
Routines
Name | Description
Byte2Hex(byte) | Represents method Byte2Hex(byte).
CopyFile(String,String) | Represents method CopyFile(String,String).
CopyFiles(String,String,String,String,Boolean) | Represents method CopyFiles(String,String,String,String,Boolean).
CopyFilesF(String,String,String,String) | Represents method CopyFilesF(String,String,String,String).
frxGetAbsPath(String) | Represents method frxGetAbsPath(String).
frxGetAbsPathDir(String,String) | Represents method frxGetAbsPathDir(String,String).
frxGetRelPath(String) | Represents method frxGetRelPath(String).
frxGetRelPathDir(String,String) | Represents method frxGetRelPathDir(String,String).
frxTouchDir(String) | Represents method frxTouchDir(String).
GetEnvVar(String) | Represents method GetEnvVar(String).
GetHTTPErrorText(integer) | Represents method GetHTTPErrorText(integer).
GetUniqueFileName(String,String) | Represents method GetUniqueFileName(String,String).
HexToStr(AnsiString) | Represents method HexToStr(AnsiString).
HTML2Str(AnsiString) | Represents method HTML2Str(AnsiString).
MakeSessionId | Represents method MakeSessionId.
NormalDir(string) | Represents method NormalDir(string).
SetCommaText(String,TStrings,Char) | Represents method SetCommaText(String,TStrings,Char).
Str2HTML(AnsiString) | Overloaded. Represents method Str2HTML(AnsiString).
Str2HTML(WideString) | Overloaded. Represents method Str2HTML(WideString).
StrToHex(AnsiString) | Represents method StrToHex(AnsiString).
UnQuoteStr(AnsiString) | Represents method UnQuoteStr(AnsiString).
Top


frxServerUtils Enumerations

Enumerations
Name | Description
TfrxHTTPQueryType | Represents type TfrxHTTPQueryType.
TfrxServerFormat | Represents type TfrxServerFormat.
Top


TfrxHTTPQueryType Enumeration

Summary

Represents type TfrxHTTPQueryType.

Namespace: frxServerUtils
Syntax
Delphi
type
 TfrxHTTPQueryType = (qtGet, qtPost, qtHead);

The TfrxHTTPQueryType type exposes the following members.

Members
Show:
Name | Description
qtGet | Represents constant qtGet.
qtHead | Represents constant qtHead.
qtPost | Represents constant qtPost.
Top
See Also

Reference

  • frxServerUtils


TfrxServerFormat Enumeration

Summary

Represents type TfrxServerFormat.

Namespace: frxServerUtils
Syntax
Delphi
type
 TfrxServerFormat = (sfHTM, sfXML, sfXLS, sfRTF, sfCSV, sfTXT, sfPDF, sfJPG, sfBMP, sfTIFF, sfGIF, sfFRP, sfODS, sfODT, sfHTMD);

The TfrxServerFormat type exposes the following members.

Members
Show:
Name | Description
sfBMP | Represents constant sfBMP.
sfCSV | Represents constant sfCSV.
sfFRP | Represents constant sfFRP.
sfGIF | Represents constant sfGIF.
sfHTM | Represents constant sfHTM.
sfHTMD | Represents constant sfHTMD.
sfJPG | Represents constant sfJPG.
sfODS | Represents constant sfODS.
sfODT | Represents constant sfODT.
sfPDF | Represents constant sfPDF.
sfRTF | Represents constant sfRTF.
sfTIFF | Represents constant sfTIFF.
sfTXT | Represents constant sfTXT.
sfXLS | Represents constant sfXLS.
sfXML | Represents constant sfXML.
Top
See Also

Reference

  • frxServerUtils


frxServerUtils Types

Types
Name | Description
TfrxServerOutputFormats | Represents type TfrxServerOutputFormats.
Top


TfrxServerOutputFormats Type

Summary

Represents type TfrxServerOutputFormats.

Namespace: frxServerUtils
Syntax
Delphi
type
 TfrxServerOutputFormats = set of TfrxServerFormat;
See Also

Reference

  • frxServerUtils


frxServerUtils Routines

Routines
Name | Description
Byte2Hex(byte) | Represents method Byte2Hex(byte).
CopyFile(String,String) | Represents method CopyFile(String,String).
CopyFiles(String,String,String,String,Boolean) | Represents method CopyFiles(String,String,String,String,Boolean).
CopyFilesF(String,String,String,String) | Represents method CopyFilesF(String,String,String,String).
frxGetAbsPath(String) | Represents method frxGetAbsPath(String).
frxGetAbsPathDir(String,String) | Represents method frxGetAbsPathDir(String,String).
frxGetRelPath(String) | Represents method frxGetRelPath(String).
frxGetRelPathDir(String,String) | Represents method frxGetRelPathDir(String,String).
frxTouchDir(String) | Represents method frxTouchDir(String).
GetEnvVar(String) | Represents method GetEnvVar(String).
GetHTTPErrorText(integer) | Represents method GetHTTPErrorText(integer).
GetUniqueFileName(String,String) | Represents method GetUniqueFileName(String,String).
HexToStr(AnsiString) | Represents method HexToStr(AnsiString).
HTML2Str(AnsiString) | Represents method HTML2Str(AnsiString).
MakeSessionId | Represents method MakeSessionId.
NormalDir(string) | Represents method NormalDir(string).
SetCommaText(String,TStrings,Char) | Represents method SetCommaText(String,TStrings,Char).
Str2HTML(AnsiString) | Overloaded. Represents method Str2HTML(AnsiString).
Str2HTML(WideString) | Overloaded. Represents method Str2HTML(WideString).
StrToHex(AnsiString) | Represents method StrToHex(AnsiString).
UnQuoteStr(AnsiString) | Represents method UnQuoteStr(AnsiString).
Top


Byte2Hex(byte) Method

Summary

Represents method Byte2Hex(byte).

Namespace: frxServerUtils
Syntax
Delphi
function Byte2Hex(const b: byte): AnsiString;

Parameters

b
Type: byte

Return Value

Type: AnsiString

See Also

Reference

  • frxServerUtils


CopyFile(String,String) Method

Summary

Represents method CopyFile(String,String).

Namespace: frxServerUtils
Syntax
Delphi
procedure CopyFile(const fFrom, fTo: String);

Parameters

fFrom
Type: String

fTo
Type: String

See Also

Reference

  • frxServerUtils


CopyFiles(String,String,String,String,Boolean) Method

Summary

Represents method CopyFiles(String,String,String,String,Boolean).

Namespace: frxServerUtils
Syntax
Delphi
procedure CopyFiles(const sFrom, sTo, sNames, sExcept: String; const Recursive: Boolean);

Parameters

sFrom
Type: String

sTo
Type: String

sNames
Type: String

sExcept
Type: String

Recursive
Type: Boolean

See Also

Reference

  • frxServerUtils


CopyFilesF(String,String,String,String) Method

Summary

Represents method CopyFilesF(String,String,String,String).

Namespace: frxServerUtils
Syntax
Delphi
procedure CopyFilesF(const sFrom, sTo, sNames, sExcept: String);

Parameters

sFrom
Type: String

sTo
Type: String

sNames
Type: String

sExcept
Type: String

See Also

Reference

  • frxServerUtils


frxGetAbsPath(String) Method

Summary

Represents method frxGetAbsPath(String).

Namespace: frxServerUtils
Syntax
Delphi
function frxGetAbsPath(const Path: String): String;

Parameters

Path
Type: String

Return Value

Type: String

See Also

Reference

  • frxServerUtils


frxGetAbsPathDir(String,String) Method

Summary

Represents method frxGetAbsPathDir(String,String).

Namespace: frxServerUtils
Syntax
Delphi
function frxGetAbsPathDir(const Path: String; const Dir: String): String;

Parameters

Path
Type: String

Dir
Type: String

Return Value

Type: String

See Also

Reference

  • frxServerUtils


frxGetRelPath(String) Method

Summary

Represents method frxGetRelPath(String).

Namespace: frxServerUtils
Syntax
Delphi
function frxGetRelPath(const Path: String): String;

Parameters

Path
Type: String

Return Value

Type: String

See Also

Reference

  • frxServerUtils


frxGetRelPathDir(String,String) Method

Summary

Represents method frxGetRelPathDir(String,String).

Namespace: frxServerUtils
Syntax
Delphi
function frxGetRelPathDir(const Path: String; const Dir: String): String;

Parameters

Path
Type: String

Dir
Type: String

Return Value

Type: String

See Also

Reference

  • frxServerUtils


frxTouchDir(String) Method

Summary

Represents method frxTouchDir(String).

Namespace: frxServerUtils
Syntax
Delphi
procedure frxTouchDir(const Path: String);

Parameters

Path
Type: String

See Also

Reference

  • frxServerUtils


GetEnvVar(String) Method

Summary

Represents method GetEnvVar(String).

Namespace: frxServerUtils
Syntax
Delphi
function GetEnvVar(const VarName: String): String;

Parameters

VarName
Type: String

Return Value

Type: String

See Also

Reference

  • frxServerUtils


GetHTTPErrorText(integer) Method

Summary

Represents method GetHTTPErrorText(integer).

Namespace: frxServerUtils
Syntax
Delphi
function GetHTTPErrorText(const ErrorCode: integer):AnsiString;

Parameters

ErrorCode
Type: integer

Return Value

Type: AnsiString

See Also

Reference

  • frxServerUtils


GetUniqueFileName(String,String) Method

Summary

Represents method GetUniqueFileName(String,String).

Namespace: frxServerUtils
Syntax
Delphi
function GetUniqueFileName(const Path: String; const Prefix: String): String;

Parameters

Path
Type: String

Prefix
Type: String

Return Value

Type: String

See Also

Reference

  • frxServerUtils


HexToStr(AnsiString) Method

Summary

Represents method HexToStr(AnsiString).

Namespace: frxServerUtils
Syntax
Delphi
function HexToStr(const s : AnsiString) : AnsiString;

Parameters

s
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • frxServerUtils


HTML2Str(AnsiString) Method

Summary

Represents method HTML2Str(AnsiString).

Namespace: frxServerUtils
Syntax
Delphi
function HTML2Str(const Line: AnsiString): AnsiString;

Parameters

Line
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • frxServerUtils


MakeSessionId Method

Summary

Represents method MakeSessionId.

Namespace: frxServerUtils
Syntax
Delphi
function MakeSessionId: AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • frxServerUtils


NormalDir(string) Method

Summary

Represents method NormalDir(string).

Namespace: frxServerUtils
Syntax
Delphi
function NormalDir(const DirName: string): string;

Parameters

DirName
Type: string

Return Value

Type: string

See Also

Reference

  • frxServerUtils


SetCommaText(String,TStrings,Char) Method

Summary

Represents method SetCommaText(String,TStrings,Char).

Namespace: frxServerUtils
Syntax
Delphi
procedure SetCommaText(const Text: String; sl: TStrings; Comma: Char = ';');

Parameters

Text
Type: String

sl
Type: TStrings

Comma
Type: Char

See Also

Reference

  • frxServerUtils


Str2HTML(AnsiString) Method

Summary

Represents method Str2HTML(AnsiString).

Namespace: frxServerUtils
Syntax
Delphi
function Str2HTML(const Str: AnsiString): AnsiString; overload;

Parameters

Str
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • frxServerUtils


Str2HTML(WideString) Method

Summary

Represents method Str2HTML(WideString).

Namespace: frxServerUtils
Syntax
Delphi
function Str2HTML(const Str: WideString): AnsiString; overload;

Parameters

Str
Type: WideString

Return Value

Type: AnsiString

See Also

Reference

  • frxServerUtils


StrToHex(AnsiString) Method

Summary

Represents method StrToHex(AnsiString).

Namespace: frxServerUtils
Syntax
Delphi
function StrToHex(const s: AnsiString): AnsiString;

Parameters

s
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • frxServerUtils


UnQuoteStr(AnsiString) Method

Summary

Represents method UnQuoteStr(AnsiString).

Namespace: frxServerUtils
Syntax
Delphi
function UnQuoteStr(const s: AnsiString): AnsiString;

Parameters

s
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • frxServerUtils


frxStorage Namespace

Summary

Represents namespace frxStorage.

Classes
Name | Description
ENotImplemented | Represents type ENotImplemented.
ENotSupportedException | Represents type ENotSupportedException.
TAVLTree | Represents type TAVLTree.
TAVLTreeNode | Represents type TAVLTreeNode.
TBase64Encoder | Represents type TBase64Encoder.
TBitArray | Represents type TBitArray.
TBlockStream | Represents type TBlockStream.
TBTree | Represents type TBTree.
TBTreeNode | Represents type TBTreeNode.
TCachedStream | Represents type TCachedStream.
TDataBlock | Represents type TDataBlock.
TFmtStream | Represents type TFmtStream.
TfrxArray | Represents type TfrxArray.
TfrxBaseArray | Represents type TfrxBaseArray.
TfrxCachedArray | Represents type TfrxCachedArray.
TfrxCachedExtArray | Represents type TfrxCachedExtArray.
TfrxCachedIntArray | Represents type TfrxCachedIntArray.
TfrxExtArray | Represents type TfrxExtArray.
TfrxExtArrayBase | Represents type TfrxExtArrayBase.
TfrxExtendedObjectList | Represents type TfrxExtendedObjectList.
TfrxIntArray | Represents type TfrxIntArray.
TfrxIntArrayBase | Represents type TfrxIntArrayBase.
THashTable | Represents type THashTable.
THexEncoder | Represents type THexEncoder.
TLineSplitter | Represents type TLineSplitter.
TListBaseHashTable | Represents type TListBaseHashTable.
TListCache | Represents type TListCache.
TListHashTable | Represents type TListHashTable.
TListStreamHashTable | Represents type TListStreamHashTable.
TListStringHashTable | Represents type TListStringHashTable.
TMap | Represents type TMap.
TObjList | Represents type TObjList.
TOrderedMap | Represents type TOrderedMap.
TProxyStream | Represents type TProxyStream.
TStreamRW | Represents type TStreamRW.
Top
Records
Name | Description
TLcCreateParams | Represents type TLcCreateParams.
TLcLoadedObject | Represents type TLcLoadedObject.
TLcObject | Represents type TLcObject.
TLhtEntry | Represents type TLhtEntry.
Top
Delegates
Name | Description
TLcReadObj | Represents type TLcReadObj.
TLcWriteObj | Represents type TLcWriteObj.
TSimpleCompareFunction | Represents type TSimpleCompareFunction.
Top
Types
Name | Description
PLhtEntry | Represents a pointer type to TLhtEntry.
Top
Routines
Name | Description
DbRead(TStream) | Represents method DbRead(TStream).
DbWrite(TStream,TObject) | Represents method DbWrite(TStream,TObject).
LhtFindEntry(PLhtEntry,Integer) | Represents method LhtFindEntry(PLhtEntry,Integer).
LhtGetEntry(Pointer,Integer) | Represents method LhtGetEntry(Pointer,Integer).
LhtSetEntry(Pointer,Integer,PLhtEntry) | Represents method LhtSetEntry(Pointer,Integer,PLhtEntry).
Top


frxStorage Classes

Classes
Name | Description
ENotImplemented | Represents type ENotImplemented.
ENotSupportedException | Represents type ENotSupportedException.
TAVLTree | Represents type TAVLTree.
TAVLTreeNode | Represents type TAVLTreeNode.
TBase64Encoder | Represents type TBase64Encoder.
TBitArray | Represents type TBitArray.
TBlockStream | Represents type TBlockStream.
TBTree | Represents type TBTree.
TBTreeNode | Represents type TBTreeNode.
TCachedStream | Represents type TCachedStream.
TDataBlock | Represents type TDataBlock.
TFmtStream | Represents type TFmtStream.
TfrxArray | Represents type TfrxArray.
TfrxBaseArray | Represents type TfrxBaseArray.
TfrxCachedArray | Represents type TfrxCachedArray.
TfrxCachedExtArray | Represents type TfrxCachedExtArray.
TfrxCachedIntArray | Represents type TfrxCachedIntArray.
TfrxExtArray | Represents type TfrxExtArray.
TfrxExtArrayBase | Represents type TfrxExtArrayBase.
TfrxExtendedObjectList | Represents type TfrxExtendedObjectList.
TfrxIntArray | Represents type TfrxIntArray.
TfrxIntArrayBase | Represents type TfrxIntArrayBase.
THashTable | Represents type THashTable.
THexEncoder | Represents type THexEncoder.
TLineSplitter | Represents type TLineSplitter.
TListBaseHashTable | Represents type TListBaseHashTable.
TListCache | Represents type TListCache.
TListHashTable | Represents type TListHashTable.
TListStreamHashTable | Represents type TListStreamHashTable.
TListStringHashTable | Represents type TListStringHashTable.
TMap | Represents type TMap.
TObjList | Represents type TObjList.
TOrderedMap | Represents type TOrderedMap.
TProxyStream | Represents type TProxyStream.
TStreamRW | Represents type TStreamRW.
Top


ENotImplemented Class

Summary

Represents type ENotImplemented.

Namespace: frxStorage
Inheritance Hierarchy
Exception
frxStorage.ENotImplemented
Syntax
Delphi
type
 ENotImplemented = class(Exception);
See Also

Reference

  • frxStorage


ENotSupportedException Class

Summary

Represents type ENotSupportedException.

Namespace: frxStorage
Inheritance Hierarchy
Exception
frxStorage.ENotSupportedException
Syntax
Delphi
type
 ENotSupportedException = class(Exception);
See Also

Reference

  • frxStorage


TAVLTree Class

Summary

Represents type TAVLTree.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TMap
frxStorage.TAVLTree
Syntax
Delphi
type
 TAVLTree = class(TMap)
 end;

The TAVLTree type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TAVLTree class.
Top
Properties
Show:
Name | Description
Exists[Pointer] | Represents property Exists[Pointer]. (Inherited from TMap.)
Items[Pointer] | Represents property Items[Pointer]. (Inherited from TMap.)
Root | Represents property Root.
Top
Methods
Show:
Name | Description
FindKey(Pointer,TAVLTreeNode) | Represents method FindKey(Pointer,TAVLTreeNode).
GetItem(Pointer) | Represents method GetItem(Pointer). (Overrides TMap.GetItem(Pointer).)
Insert(TAVLTreeNode,TAVLTreeNode,Pointer,Pointer) | Represents method Insert(TAVLTreeNode,TAVLTreeNode,Pointer,Pointer).
ItemExists(Pointer) | Represents method ItemExists(Pointer). (Overrides TMap.ItemExists(Pointer).)
LiftChild(TAVLTreeNode,TAVLTreeNode,Boolean) | Represents method LiftChild(TAVLTreeNode,TAVLTreeNode,Boolean).
SetItem(Pointer,Pointer) | Represents method SetItem(Pointer,Pointer). (Overrides TMap.SetItem(Pointer,Pointer).)
SetItemExistence(Pointer,Boolean) | Represents method SetItemExistence(Pointer,Boolean). (Overrides TMap.SetItemExistence(Pointer,Boolean).)
Top
Fields
Show:
Name | Description
FRoot | Represents field FRoot.
Top
See Also

Reference

  • frxStorage


TAVLTree Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TAVLTree class.
Top


TAVLTree.Destroy Destructor

Summary

Represents the destructor of the TAVLTree class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TAVLTree
  • frxStorage


TAVLTree Properties

Properties
Name | Description
Root | Represents property Root.
Top


TAVLTree.Root Property

Summary

Represents property Root.

Namespace: frxStorage
Syntax
Delphi
protected
 property Root: TAVLTreeNode read FRoot;

Property Value

Type: TAVLTreeNode

See Also

Reference

  • TAVLTree
  • frxStorage


TAVLTree Methods

Methods
Name | Description
FindKey(Pointer,TAVLTreeNode) | Represents method FindKey(Pointer,TAVLTreeNode).
GetItem(Pointer) | Represents method GetItem(Pointer). (Overrides TMap.GetItem(Pointer).)
Insert(TAVLTreeNode,TAVLTreeNode,Pointer,Pointer) | Represents method Insert(TAVLTreeNode,TAVLTreeNode,Pointer,Pointer).
ItemExists(Pointer) | Represents method ItemExists(Pointer). (Overrides TMap.ItemExists(Pointer).)
LiftChild(TAVLTreeNode,TAVLTreeNode,Boolean) | Represents method LiftChild(TAVLTreeNode,TAVLTreeNode,Boolean).
SetItem(Pointer,Pointer) | Represents method SetItem(Pointer,Pointer). (Overrides TMap.SetItem(Pointer,Pointer).)
SetItemExistence(Pointer,Boolean) | Represents method SetItemExistence(Pointer,Boolean). (Overrides TMap.SetItemExistence(Pointer,Boolean).)
Top


TAVLTree.FindKey(Pointer,TAVLTreeNode) Method

Summary

Represents method FindKey(Pointer,TAVLTreeNode).

Namespace: frxStorage
Syntax
Delphi
private
 function FindKey(Key: Pointer; out Node: TAVLTreeNode): Boolean;

Parameters

Key
Type: Pointer

Node
Type: TAVLTreeNode

Return Value

Type: Boolean

See Also

Reference

  • TAVLTree
  • frxStorage


TAVLTree.GetItem(Pointer) Method

Summary

Represents method GetItem(Pointer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItem(Key: Pointer): Pointer; override;

Parameters

Key
Type: Pointer

Return Value

Type: Pointer

Overrides

TMap.GetItem(Pointer)
See Also

Reference

  • TAVLTree
  • frxStorage


TAVLTree.Insert(TAVLTreeNode,TAVLTreeNode,Pointer,Pointer) Method

Summary

Represents method Insert(TAVLTreeNode,TAVLTreeNode,Pointer,Pointer).

Namespace: frxStorage
Syntax
Delphi
private
 procedure Insert(Parent, Node: TAVLTreeNode; Key, Value: Pointer);

Parameters

Parent
Type: TAVLTreeNode

Node
Type: TAVLTreeNode

Key
Type: Pointer

Value
Type: Pointer

See Also

Reference

  • TAVLTree
  • frxStorage


TAVLTree.ItemExists(Pointer) Method

Summary

Represents method ItemExists(Pointer).

Namespace: frxStorage
Syntax
Delphi
protected
 function ItemExists(Key: Pointer): Boolean; override;

Parameters

Key
Type: Pointer

Return Value

Type: Boolean

Overrides

TMap.ItemExists(Pointer)
See Also

Reference

  • TAVLTree
  • frxStorage


TAVLTree.LiftChild(TAVLTreeNode,TAVLTreeNode,Boolean) Method

Summary

Represents method LiftChild(TAVLTreeNode,TAVLTreeNode,Boolean).

Namespace: frxStorage
Syntax
Delphi
private
 procedure LiftChild(R, N: TAVLTreeNode; Leaf: Boolean);

Parameters

R
Type: TAVLTreeNode

N
Type: TAVLTreeNode

Leaf
Type: Boolean

See Also

Reference

  • TAVLTree
  • frxStorage


TAVLTree.SetItem(Pointer,Pointer) Method

Summary

Represents method SetItem(Pointer,Pointer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItem(Key: Pointer; Value: Pointer); override;

Parameters

Key
Type: Pointer

Value
Type: Pointer

Overrides

TMap.SetItem(Pointer,Pointer)
See Also

Reference

  • TAVLTree
  • frxStorage


TAVLTree.SetItemExistence(Pointer,Boolean) Method

Summary

Represents method SetItemExistence(Pointer,Boolean).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItemExistence(Key: Pointer; b: Boolean); override;

Parameters

Key
Type: Pointer

b
Type: Boolean

Overrides

TMap.SetItemExistence(Pointer,Boolean)
See Also

Reference

  • TAVLTree
  • frxStorage


TAVLTree Fields

Fields
Name | Description
FRoot | Represents field FRoot.
Top


TAVLTree.FRoot Field

Summary

Represents field FRoot.

Namespace: frxStorage
Syntax
Delphi
private
 FRoot: TAVLTreeNode;

Field Value

Type: TAVLTreeNode

See Also

Reference

  • TAVLTree
  • frxStorage


TAVLTreeNode Class

Summary

Represents type TAVLTreeNode.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TAVLTreeNode
Syntax
Delphi
type
 TAVLTreeNode = class
 end;

The TAVLTreeNode type exposes the following members.

Constructors
Show:
Name | Description
Create(Pointer,Pointer) | Initializes a new instance of the TAVLTreeNode class.
Destroy | Represents the destructor of the TAVLTreeNode class.
Top
Properties
Show:
Name | Description
Child[Boolean] | Represents property Child[Boolean].
Height | Represents property Height.
Key | Represents property Key.
Value | Represents property Value.
Top
Methods
Show:
Name | Description
GetChild(Boolean) | Represents method GetChild(Boolean).
GetHeight | Represents method GetHeight.
SetChild(Boolean,TAVLTreeNode) | Represents method SetChild(Boolean,TAVLTreeNode).
UpdateHeight | Represents method UpdateHeight.
Top
Fields
Show:
Name | Description
FHeight | Represents field FHeight.
FKey | Represents field FKey.
FLeafs | Represents field FLeafs.
FValue | Represents field FValue.
Top
See Also

Reference

  • frxStorage


TAVLTreeNode Constructors

Constructors
Name | Description
Create(Pointer,Pointer) | Initializes a new instance of the TAVLTreeNode class.
Destroy | Represents the destructor of the TAVLTreeNode class.
Top


TAVLTreeNode.Create(Pointer,Pointer) Constructor

Summary

Initializes a new instance of the TAVLTreeNode class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(Key, Value: Pointer);

Parameters

Key
Type: Pointer

Value
Type: Pointer

See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode.Destroy Destructor

Summary

Represents the destructor of the TAVLTreeNode class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode Properties

Properties
Name | Description
Child[Boolean] | Represents property Child[Boolean].
Height | Represents property Height.
Key | Represents property Key.
Value | Represents property Value.
Top


TAVLTreeNode.Child[Boolean] Property

Summary

Represents property Child[Boolean].

Namespace: frxStorage
Syntax
Delphi
public
 property Child[Leaf: Boolean]: TAVLTreeNode read GetChild write SetChild; default;

Parameters

Leaf
Type: Boolean

Property Value

Type: TAVLTreeNode

See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode.Height Property

Summary

Represents property Height.

Namespace: frxStorage
Syntax
Delphi
public
 property Height: Byte read GetHeight write FHeight;

Property Value

Type: Byte

See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode.Key Property

Summary

Represents property Key.

Namespace: frxStorage
Syntax
Delphi
public
 property Key: Pointer read FKey;

Property Value

Type: Pointer

See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode.Value Property

Summary

Represents property Value.

Namespace: frxStorage
Syntax
Delphi
public
 property Value: Pointer read FValue write FValue;

Property Value

Type: Pointer

See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode Methods

Methods
Name | Description
GetChild(Boolean) | Represents method GetChild(Boolean).
GetHeight | Represents method GetHeight.
SetChild(Boolean,TAVLTreeNode) | Represents method SetChild(Boolean,TAVLTreeNode).
UpdateHeight | Represents method UpdateHeight.
Top


TAVLTreeNode.GetChild(Boolean) Method

Summary

Represents method GetChild(Boolean).

Namespace: frxStorage
Syntax
Delphi
private
 function GetChild(Leaf: Boolean): TAVLTreeNode;

Parameters

Leaf
Type: Boolean

Return Value

Type: TAVLTreeNode

See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode.GetHeight Method

Summary

Represents method GetHeight.

Namespace: frxStorage
Syntax
Delphi
private
 function GetHeight: Byte;

Return Value

Type: Byte

See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode.SetChild(Boolean,TAVLTreeNode) Method

Summary

Represents method SetChild(Boolean,TAVLTreeNode).

Namespace: frxStorage
Syntax
Delphi
private
 procedure SetChild(Leaf: Boolean; Node: TAVLTreeNode);

Parameters

Leaf
Type: Boolean

Node
Type: TAVLTreeNode

See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode.UpdateHeight Method

Summary

Represents method UpdateHeight.

Namespace: frxStorage
Syntax
Delphi
public
 procedure UpdateHeight;
See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode Fields

Fields
Name | Description
FHeight | Represents field FHeight.
FKey | Represents field FKey.
FLeafs | Represents field FLeafs.
FValue | Represents field FValue.
Top


TAVLTreeNode.FHeight Field

Summary

Represents field FHeight.

Namespace: frxStorage
Syntax
Delphi
private
 FHeight: Byte;

Field Value

Type: Byte

See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode.FKey Field

Summary

Represents field FKey.

Namespace: frxStorage
Syntax
Delphi
private
 FKey, FValue: Pointer;

Field Value

Type: Pointer

See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode.FLeafs Field

Summary

Represents field FLeafs.

Namespace: frxStorage
Syntax
Delphi
private
 FLeafs: array[Boolean] of TAVLTreeNode;

Field Value

Type: array[Boolean] of TAVLTreeNode

See Also

Reference

  • TAVLTreeNode
  • frxStorage


TAVLTreeNode.FValue Field

Summary

Represents field FValue.

Namespace: frxStorage
Syntax
Delphi
private
 FKey, FValue: Pointer;

Field Value

Type: Pointer

See Also

Reference

  • TAVLTreeNode
  • frxStorage


TBase64Encoder Class

Summary

Represents type TBase64Encoder.

Namespace: frxStorage
Inheritance Hierarchy
TStream
frxStorage.TBase64Encoder
Syntax
Delphi
type
 TBase64Encoder = class(TStream)
 end;

The TBase64Encoder type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream) | Initializes a new instance of the TBase64Encoder class.
Destroy | Represents the destructor of the TBase64Encoder class.
Top
Methods
Show:
Name | Description
Encode(Integer,Integer) | Represents method Encode(Integer,Integer).
Finalise | Represents method Finalise.
InitMap | Represents method InitMap.
Read(Void,Longint) | Represents method Read(Void,Longint).
This | Represents method This.
Write(Void,Longint) | Represents method Write(Void,Longint).
Top
Fields
Show:
Name | Description
FCache | Represents field FCache.
FMap | Represents field FMap.
FOutput | Represents field FOutput.
FUsed | Represents field FUsed.
Top
See Also

Reference

  • frxStorage


TBase64Encoder Constructors

Constructors
Name | Description
Create(TStream) | Initializes a new instance of the TBase64Encoder class.
Destroy | Represents the destructor of the TBase64Encoder class.
Top


TBase64Encoder.Create(TStream) Constructor

Summary

Initializes a new instance of the TBase64Encoder class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(Output: TStream);

Parameters

Output
Type: TStream

See Also

Reference

  • TBase64Encoder
  • frxStorage


TBase64Encoder.Destroy Destructor

Summary

Represents the destructor of the TBase64Encoder class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TBase64Encoder
  • frxStorage


TBase64Encoder Methods

Methods
Name | Description
Encode(Integer,Integer) | Represents method Encode(Integer,Integer).
Finalise | Represents method Finalise.
InitMap | Represents method InitMap.
Read(Void,Longint) | Represents method Read(Void,Longint).
This | Represents method This.
Write(Void,Longint) | Represents method Write(Void,Longint).
Top


TBase64Encoder.Encode(Integer,Integer) Method

Summary

Represents method Encode(Integer,Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure Encode(a, n: Integer);

Parameters

a
Type: Integer

n
Type: Integer

See Also

Reference

  • TBase64Encoder
  • frxStorage


TBase64Encoder.Finalise Method

Summary

Represents method Finalise.

Namespace: frxStorage
Syntax
Delphi
protected
 procedure Finalise;
See Also

Reference

  • TBase64Encoder
  • frxStorage


TBase64Encoder.InitMap Method

Summary

Represents method InitMap.

Namespace: frxStorage
Syntax
Delphi
protected
 procedure InitMap;
See Also

Reference

  • TBase64Encoder
  • frxStorage


TBase64Encoder.Read(Void,Longint) Method

Summary

Represents method Read(Void,Longint).

Namespace: frxStorage
Syntax
Delphi
public
 function Read(var Buffer; Count: Longint): Longint; override;

Parameters

Buffer
Type: System.Void

Count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TBase64Encoder
  • frxStorage


TBase64Encoder.This Method

Summary

Represents method This.

Namespace: frxStorage
Syntax
Delphi
public
 function This: TBase64Encoder;

Return Value

Type: TBase64Encoder

See Also

Reference

  • TBase64Encoder
  • frxStorage


TBase64Encoder.Write(Void,Longint) Method

Summary

Represents method Write(Void,Longint).

Namespace: frxStorage
Syntax
Delphi
public
 function Write(const Buffer; Count: Longint): Longint; override;

Parameters

Buffer
Type: System.Void

Count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TBase64Encoder
  • frxStorage


TBase64Encoder Fields

Fields
Name | Description
FCache | Represents field FCache.
FMap | Represents field FMap.
FOutput | Represents field FOutput.
FUsed | Represents field FUsed.
Top


TBase64Encoder.FCache Field

Summary

Represents field FCache.

Namespace: frxStorage
Syntax
Delphi
private
 FCache, FUsed: Integer;

Field Value

Type: Integer

See Also

Reference

  • TBase64Encoder
  • frxStorage


TBase64Encoder.FMap Field

Summary

Represents field FMap.

Namespace: frxStorage
Syntax
Delphi
private
 FMap: array[0..63] of Byte;

Field Value

Type: array[0..63] of Byte

See Also

Reference

  • TBase64Encoder
  • frxStorage


TBase64Encoder.FOutput Field

Summary

Represents field FOutput.

Namespace: frxStorage
Syntax
Delphi
private
 FOutput: TStream;

Field Value

Type: TStream

See Also

Reference

  • TBase64Encoder
  • frxStorage


TBase64Encoder.FUsed Field

Summary

Represents field FUsed.

Namespace: frxStorage
Syntax
Delphi
private
 FCache, FUsed: Integer;

Field Value

Type: Integer

See Also

Reference

  • TBase64Encoder
  • frxStorage


TBitArray Class

Summary

Represents type TBitArray.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TBitArray
Syntax
Delphi
type
 TBitArray = class
 end;

The TBitArray type exposes the following members.

Properties
Show:
Name | Description
Bits[Integer] | Represents property Bits[Integer].
Length | Represents property Length.
Top
Methods
Show:
Name | Description
BitAnd(TBitArray) | Represents method BitAnd(TBitArray).
BitOr(TBitArray) | Represents method BitOr(TBitArray).
BitXor(TBitArray) | Represents method BitXor(TBitArray).
Clone | Represents method Clone.
GetBit(Integer) | Represents method GetBit(Integer).
GetNumOfSetBits | Represents method GetNumOfSetBits.
GetRightmostBitIndex | Represents method GetRightmostBitIndex.
ResetBits | Represents method ResetBits.
SaveToStream(TStream) | Represents method SaveToStream(TStream).
SetBit(Integer,Boolean) | Represents method SetBit(Integer,Boolean).
SetBits | Represents method SetBits.
SetBitsLength(Integer) | Represents method SetBitsLength(Integer).
Trunc | Represents method Trunc.
Top
Fields
Show:
Name | Description
FData | Represents field FData.
FLength | Represents field FLength.
Top
See Also

Reference

  • frxStorage


TBitArray Properties

Properties
Name | Description
Bits[Integer] | Represents property Bits[Integer].
Length | Represents property Length.
Top


TBitArray.Bits[Integer] Property

Summary

Represents property Bits[Integer].

Namespace: frxStorage
Syntax
Delphi
public
 property Bits[Index: Integer]: Boolean read GetBit write SetBit; default;

Parameters

Index
Type: Integer

Property Value

Type: Boolean

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.Length Property

Summary

Represents property Length.

Namespace: frxStorage
Syntax
Delphi
public
 property Length: Integer read FLength write SetBitsLength;

Property Value

Type: Integer

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray Methods

Methods
Name | Description
BitAnd(TBitArray) | Represents method BitAnd(TBitArray).
BitOr(TBitArray) | Represents method BitOr(TBitArray).
BitXor(TBitArray) | Represents method BitXor(TBitArray).
Clone | Represents method Clone.
GetBit(Integer) | Represents method GetBit(Integer).
GetNumOfSetBits | Represents method GetNumOfSetBits.
GetRightmostBitIndex | Represents method GetRightmostBitIndex.
ResetBits | Represents method ResetBits.
SaveToStream(TStream) | Represents method SaveToStream(TStream).
SetBit(Integer,Boolean) | Represents method SetBit(Integer,Boolean).
SetBits | Represents method SetBits.
SetBitsLength(Integer) | Represents method SetBitsLength(Integer).
Trunc | Represents method Trunc.
Top


TBitArray.BitAnd(TBitArray) Method

Summary

Represents method BitAnd(TBitArray).

Namespace: frxStorage
Syntax
Delphi
public
 procedure BitAnd(Src: TBitArray);

Parameters

Src
Type: TBitArray

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.BitOr(TBitArray) Method

Summary

Represents method BitOr(TBitArray).

Namespace: frxStorage
Syntax
Delphi
public
 procedure BitOr(Src: TBitArray);

Parameters

Src
Type: TBitArray

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.BitXor(TBitArray) Method

Summary

Represents method BitXor(TBitArray).

Namespace: frxStorage
Syntax
Delphi
public
 procedure BitXor(Src: TBitArray);

Parameters

Src
Type: TBitArray

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.Clone Method

Summary

Represents method Clone.

Namespace: frxStorage
Syntax
Delphi
public
 function Clone: TBitArray;

Return Value

Type: TBitArray

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.GetBit(Integer) Method

Summary

Represents method GetBit(Integer).

Namespace: frxStorage
Syntax
Delphi
private
 function GetBit(Index: Integer): Boolean;

Parameters

Index
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.GetNumOfSetBits Method

Summary

Represents method GetNumOfSetBits.

Namespace: frxStorage
Syntax
Delphi
public
 function GetNumOfSetBits: Integer;

Return Value

Type: Integer

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.GetRightmostBitIndex Method

Summary

Represents method GetRightmostBitIndex.

Namespace: frxStorage
Syntax
Delphi
public
 function GetRightmostBitIndex: Integer;

Return Value

Type: Integer

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.ResetBits Method

Summary

Represents method ResetBits.

Namespace: frxStorage
Syntax
Delphi
public
 procedure ResetBits;
See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.SaveToStream(TStream) Method

Summary

Represents method SaveToStream(TStream).

Namespace: frxStorage
Syntax
Delphi
public
 procedure SaveToStream(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.SetBit(Integer,Boolean) Method

Summary

Represents method SetBit(Integer,Boolean).

Namespace: frxStorage
Syntax
Delphi
private
 procedure SetBit(Index: Integer; Value: Boolean);

Parameters

Index
Type: Integer

Value
Type: Boolean

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.SetBits Method

Summary

Represents method SetBits.

Namespace: frxStorage
Syntax
Delphi
public
 procedure SetBits;
See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.SetBitsLength(Integer) Method

Summary

Represents method SetBitsLength(Integer).

Namespace: frxStorage
Syntax
Delphi
private
 procedure SetBitsLength(NewLength: Integer);

Parameters

NewLength
Type: Integer

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.Trunc Method

Summary

Represents method Trunc.

Namespace: frxStorage
Syntax
Delphi
private
 procedure Trunc;
See Also

Reference

  • TBitArray
  • frxStorage


TBitArray Fields

Fields
Name | Description
FData | Represents field FData.
FLength | Represents field FLength.
Top


TBitArray.FData Field

Summary

Represents field FData.

Namespace: frxStorage
Syntax
Delphi
private
 FData: array of Byte;

Field Value

Type: array of Byte

See Also

Reference

  • TBitArray
  • frxStorage


TBitArray.FLength Field

Summary

Represents field FLength.

Namespace: frxStorage
Syntax
Delphi
private
 FLength: Integer;

Field Value

Type: Integer

See Also

Reference

  • TBitArray
  • frxStorage


TBlockStream Class

Summary

Represents type TBlockStream.

Namespace: frxStorage
Inheritance Hierarchy
TMemoryStream
frxStorage.TBlockStream
Syntax
Delphi
type
 TBlockStream = class(TMemoryStream)
 end;

The TBlockStream type exposes the following members.

Constructors
Show:
Name | Description
Create(LongInt) | Initializes a new instance of the TBlockStream class.
Top
Properties
Show:
Name | Description
BlockData[LongInt] | Represents property BlockData[LongInt].
BlocksCount | Represents property BlocksCount.
BlockShift | Represents property BlockShift.
BlockSize[LongInt] | Represents property BlockSize[LongInt].
CurrentBlock | Represents property CurrentBlock.
Top
Methods
Show:
Name | Description
EndBlock(Byte) | Represents method EndBlock(Byte).
Fill(Byte,LongInt) | Represents method Fill(Byte,LongInt).
GetBlockData(LongInt) | Represents method GetBlockData(LongInt).
GetBlocksCount | Represents method GetBlocksCount.
GetBlockSize(LongInt) | Represents method GetBlockSize(LongInt).
GetCurrentBlock | Represents method GetCurrentBlock.
Imm(LongInt,LongInt) | Represents method Imm(LongInt,LongInt).
Top
Fields
Show:
Name | Description
FBlockShift | Represents field FBlockShift.
Top
See Also

Reference

  • frxStorage


TBlockStream Constructors

Constructors
Name | Description
Create(LongInt) | Initializes a new instance of the TBlockStream class.
Top


TBlockStream.Create(LongInt) Constructor

Summary

Initializes a new instance of the TBlockStream class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(BlockSizeShift: LongInt = 4);

Parameters

BlockSizeShift
Type: LongInt

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream Properties

Properties
Name | Description
BlockData[LongInt] | Represents property BlockData[LongInt].
BlocksCount | Represents property BlocksCount.
BlockShift | Represents property BlockShift.
BlockSize[LongInt] | Represents property BlockSize[LongInt].
CurrentBlock | Represents property CurrentBlock.
Top


TBlockStream.BlockData[LongInt] Property

Summary

Represents property BlockData[LongInt].

Namespace: frxStorage
Syntax
Delphi
public
 property BlockData[i: LongInt]: Pointer read GetBlockData;

Parameters

i
Type: LongInt

Property Value

Type: Pointer

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream.BlocksCount Property

Summary

Represents property BlocksCount.

Namespace: frxStorage
Syntax
Delphi
public
 property BlocksCount: LongInt read GetBlocksCount;

Property Value

Type: LongInt

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream.BlockShift Property

Summary

Represents property BlockShift.

Namespace: frxStorage
Syntax
Delphi
public
 property BlockShift: LongInt read FBlockShift;

Property Value

Type: LongInt

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream.BlockSize[LongInt] Property

Summary

Represents property BlockSize[LongInt].

Namespace: frxStorage
Syntax
Delphi
public
 property BlockSize[i: LongInt]: LongInt read GetBlockSize;

Parameters

i
Type: LongInt

Property Value

Type: LongInt

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream.CurrentBlock Property

Summary

Represents property CurrentBlock.

Namespace: frxStorage
Syntax
Delphi
public
 property CurrentBlock: LongInt read GetCurrentBlock;

Property Value

Type: LongInt

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream Methods

Methods
Name | Description
EndBlock(Byte) | Represents method EndBlock(Byte).
Fill(Byte,LongInt) | Represents method Fill(Byte,LongInt).
GetBlockData(LongInt) | Represents method GetBlockData(LongInt).
GetBlocksCount | Represents method GetBlocksCount.
GetBlockSize(LongInt) | Represents method GetBlockSize(LongInt).
GetCurrentBlock | Represents method GetCurrentBlock.
Imm(LongInt,LongInt) | Represents method Imm(LongInt,LongInt).
Top


TBlockStream.EndBlock(Byte) Method

Summary

Represents method EndBlock(Byte).

Namespace: frxStorage
Syntax
Delphi
public
 procedure EndBlock(Value: Byte);

Parameters

Value
Type: Byte

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream.Fill(Byte,LongInt) Method

Summary

Represents method Fill(Byte,LongInt).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Fill(Value: Byte; Count: LongInt);

Parameters

Value
Type: Byte

Count
Type: LongInt

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream.GetBlockData(LongInt) Method

Summary

Represents method GetBlockData(LongInt).

Namespace: frxStorage
Syntax
Delphi
private
 function GetBlockData(i: LongInt): Pointer;

Parameters

i
Type: LongInt

Return Value

Type: Pointer

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream.GetBlocksCount Method

Summary

Represents method GetBlocksCount.

Namespace: frxStorage
Syntax
Delphi
private
 function GetBlocksCount: LongInt;

Return Value

Type: LongInt

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream.GetBlockSize(LongInt) Method

Summary

Represents method GetBlockSize(LongInt).

Namespace: frxStorage
Syntax
Delphi
private
 function GetBlockSize(i: LongInt): LongInt;

Parameters

i
Type: LongInt

Return Value

Type: LongInt

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream.GetCurrentBlock Method

Summary

Represents method GetCurrentBlock.

Namespace: frxStorage
Syntax
Delphi
private
 function GetCurrentBlock: LongInt;

Return Value

Type: LongInt

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream.Imm(LongInt,LongInt) Method

Summary

Represents method Imm(LongInt,LongInt).

Namespace: frxStorage
Syntax
Delphi
public
 function Imm(Value, Count: LongInt): Pointer;

Parameters

Value
Type: LongInt

Count
Type: LongInt

Return Value

Type: Pointer

See Also

Reference

  • TBlockStream
  • frxStorage


TBlockStream Fields

Fields
Name | Description
FBlockShift | Represents field FBlockShift.
Top


TBlockStream.FBlockShift Field

Summary

Represents field FBlockShift.

Namespace: frxStorage
Syntax
Delphi
private
 FBlockShift: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • TBlockStream
  • frxStorage


TBTree Class

Summary

Represents type TBTree.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TMap
frxStorage.TOrderedMap
frxStorage.TBTree
Syntax
Delphi
type
 TBTree = class(TOrderedMap)
 end;

The TBTree type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer) | Initializes a new instance of the TBTree class.
Destroy | Represents the destructor of the TBTree class.
Top
Properties
Show:
Name | Description
Exists[Pointer] | Represents property Exists[Pointer]. (Inherited from TMap.)
Height | Represents property Height.
Items[Pointer] | Represents property Items[Pointer]. (Inherited from TMap.)
KeysCount | Represents property KeysCount.
Order | Represents property Order.
Root | Represents property Root.
Top
Methods
Show:
Name | Description
CreateNode(TBTreeNode) | Represents method CreateNode(TBTreeNode).
FindIndex(TBTreeNode,Pointer) | Represents method FindIndex(TBTreeNode,Pointer).
FindKey(Pointer,Integer) | Represents method FindKey(Pointer,Integer).
GetHeight | Represents method GetHeight.
GetItem(Pointer) | Represents method GetItem(Pointer). (Overrides TMap.GetItem(Pointer).)
GetKeysAndValues(TList,TList) | Represents method GetKeysAndValues(TList,TList). (Overrides TOrderedMap.GetKeysAndValues(TList,TList).)
GetKeysCount | Represents method GetKeysCount.
Insert(Pointer,Pointer) | Represents method Insert(Pointer,Pointer).
InsertKey(TBTreeNode,Integer,Pointer,Pointer,TBTreeNode,TBTreeNode) | Represents method InsertKey(TBTreeNode,Integer,Pointer,Pointer,TBTreeNode,TBTreeNode).
IsFull(TBTreeNode) | Represents method IsFull(TBTreeNode).
ItemExists(Pointer) | Represents method ItemExists(Pointer). (Overrides TMap.ItemExists(Pointer).)
SetItem(Pointer,Pointer) | Represents method SetItem(Pointer,Pointer). (Overrides TMap.SetItem(Pointer,Pointer).)
SetItemExistence(Pointer,Boolean) | Represents method SetItemExistence(Pointer,Boolean). (Overrides TMap.SetItemExistence(Pointer,Boolean).)
SplitTree(TBTreeNode,Integer) | Represents method SplitTree(TBTreeNode,Integer).
Top
Fields
Show:
Name | Description
FOrder | Represents field FOrder.
FRoot | Represents field FRoot.
Top
See Also

Reference

  • frxStorage


TBTree Constructors

Constructors
Name | Description
Create(Integer) | Initializes a new instance of the TBTree class.
Destroy | Represents the destructor of the TBTree class.
Top


TBTree.Create(Integer) Constructor

Summary

Initializes a new instance of the TBTree class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(Order: Integer = 4);

Parameters

Order
Type: Integer

See Also

Reference

  • TBTree
  • frxStorage


TBTree.Destroy Destructor

Summary

Represents the destructor of the TBTree class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TBTree
  • frxStorage


TBTree Properties

Properties
Name | Description
Height | Represents property Height.
KeysCount | Represents property KeysCount.
Order | Represents property Order.
Root | Represents property Root.
Top


TBTree.Height Property

Summary

Represents property Height.

Namespace: frxStorage
Syntax
Delphi
protected
 property Height: Integer read GetHeight;

Property Value

Type: Integer

See Also

Reference

  • TBTree
  • frxStorage


TBTree.KeysCount Property

Summary

Represents property KeysCount.

Namespace: frxStorage
Syntax
Delphi
protected
 property KeysCount: Integer read GetKeysCount;

Property Value

Type: Integer

See Also

Reference

  • TBTree
  • frxStorage


TBTree.Order Property

Summary

Represents property Order.

Namespace: frxStorage
Syntax
Delphi
protected
 property Order: Integer read FOrder;

Property Value

Type: Integer

See Also

Reference

  • TBTree
  • frxStorage


TBTree.Root Property

Summary

Represents property Root.

Namespace: frxStorage
Syntax
Delphi
protected
 property Root: TBTreeNode read FRoot;

Property Value

Type: TBTreeNode

See Also

Reference

  • TBTree
  • frxStorage


TBTree Methods

Methods
Name | Description
CreateNode(TBTreeNode) | Represents method CreateNode(TBTreeNode).
FindIndex(TBTreeNode,Pointer) | Represents method FindIndex(TBTreeNode,Pointer).
FindKey(Pointer,Integer) | Represents method FindKey(Pointer,Integer).
GetHeight | Represents method GetHeight.
GetItem(Pointer) | Represents method GetItem(Pointer). (Overrides TMap.GetItem(Pointer).)
GetKeysAndValues(TList,TList) | Represents method GetKeysAndValues(TList,TList). (Overrides TOrderedMap.GetKeysAndValues(TList,TList).)
GetKeysCount | Represents method GetKeysCount.
Insert(Pointer,Pointer) | Represents method Insert(Pointer,Pointer).
InsertKey(TBTreeNode,Integer,Pointer,Pointer,TBTreeNode,TBTreeNode) | Represents method InsertKey(TBTreeNode,Integer,Pointer,Pointer,TBTreeNode,TBTreeNode).
IsFull(TBTreeNode) | Represents method IsFull(TBTreeNode).
ItemExists(Pointer) | Represents method ItemExists(Pointer). (Overrides TMap.ItemExists(Pointer).)
SetItem(Pointer,Pointer) | Represents method SetItem(Pointer,Pointer). (Overrides TMap.SetItem(Pointer,Pointer).)
SetItemExistence(Pointer,Boolean) | Represents method SetItemExistence(Pointer,Boolean). (Overrides TMap.SetItemExistence(Pointer,Boolean).)
SplitTree(TBTreeNode,Integer) | Represents method SplitTree(TBTreeNode,Integer).
Top


TBTree.CreateNode(TBTreeNode) Method

Summary

Represents method CreateNode(TBTreeNode).

Namespace: frxStorage
Syntax
Delphi
private
 function CreateNode(LNode: TBTreeNode = nil): TBTreeNode;

Parameters

LNode
Type: TBTreeNode

Return Value

Type: TBTreeNode

See Also

Reference

  • TBTree
  • frxStorage


TBTree.FindIndex(TBTreeNode,Pointer) Method

Summary

Represents method FindIndex(TBTreeNode,Pointer).

Namespace: frxStorage
Syntax
Delphi
private
 function FindIndex(Node: TBTreeNode; Key: Pointer): Integer;

Parameters

Node
Type: TBTreeNode

Key
Type: Pointer

Return Value

Type: Integer

See Also

Reference

  • TBTree
  • frxStorage


TBTree.FindKey(Pointer,Integer) Method

Summary

Represents method FindKey(Pointer,Integer).

Namespace: frxStorage
Syntax
Delphi
private
 function FindKey(Key: Pointer; out KeyIndex: Integer): TBTreeNode;

Parameters

Key
Type: Pointer

KeyIndex
Type: Integer

Return Value

Type: TBTreeNode

See Also

Reference

  • TBTree
  • frxStorage


TBTree.GetHeight Method

Summary

Represents method GetHeight.

Namespace: frxStorage
Syntax
Delphi
private
 function GetHeight: Integer;

Return Value

Type: Integer

See Also

Reference

  • TBTree
  • frxStorage


TBTree.GetItem(Pointer) Method

Summary

Represents method GetItem(Pointer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItem(Key: Pointer): Pointer; override;

Parameters

Key
Type: Pointer

Return Value

Type: Pointer

Overrides

TMap.GetItem(Pointer)
See Also

Reference

  • TBTree
  • frxStorage


TBTree.GetKeysAndValues(TList,TList) Method

Summary

Represents method GetKeysAndValues(TList,TList).

Namespace: frxStorage
Syntax
Delphi
public
 procedure GetKeysAndValues(Keys, Values: TList); override;

Parameters

Keys
Type: TList

Values
Type: TList

Overrides

TOrderedMap.GetKeysAndValues(TList,TList)
See Also

Reference

  • TBTree
  • frxStorage


TBTree.GetKeysCount Method

Summary

Represents method GetKeysCount.

Namespace: frxStorage
Syntax
Delphi
private
 function GetKeysCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TBTree
  • frxStorage


TBTree.Insert(Pointer,Pointer) Method

Summary

Represents method Insert(Pointer,Pointer).

Namespace: frxStorage
Syntax
Delphi
protected
 function Insert(Key: Pointer; Value: Pointer): Boolean;

Parameters

Key
Type: Pointer

Value
Type: Pointer

Return Value

Type: Boolean

See Also

Reference

  • TBTree
  • frxStorage


TBTree.InsertKey(TBTreeNode,Integer,Pointer,Pointer,TBTreeNode,TBTreeNode) Method

Summary

Represents method InsertKey(TBTreeNode,Integer,Pointer,Pointer,TBTreeNode,TBTreeNode).

Namespace: frxStorage
Syntax
Delphi
private
 procedure InsertKey(Node: TBTreeNode; i: Integer; Key, Value: Pointer; LNode, RNode: TBTreeNode);

Parameters

Node
Type: TBTreeNode

i
Type: Integer

Key
Type: Pointer

Value
Type: Pointer

LNode
Type: TBTreeNode

RNode
Type: TBTreeNode

See Also

Reference

  • TBTree
  • frxStorage


TBTree.IsFull(TBTreeNode) Method

Summary

Represents method IsFull(TBTreeNode).

Namespace: frxStorage
Syntax
Delphi
private
 function IsFull(Node: TBTreeNode): Boolean;

Parameters

Node
Type: TBTreeNode

Return Value

Type: Boolean

See Also

Reference

  • TBTree
  • frxStorage


TBTree.ItemExists(Pointer) Method

Summary

Represents method ItemExists(Pointer).

Namespace: frxStorage
Syntax
Delphi
protected
 function ItemExists(Key: Pointer): Boolean; override;

Parameters

Key
Type: Pointer

Return Value

Type: Boolean

Overrides

TMap.ItemExists(Pointer)
See Also

Reference

  • TBTree
  • frxStorage


TBTree.SetItem(Pointer,Pointer) Method

Summary

Represents method SetItem(Pointer,Pointer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItem(Key: Pointer; Value: Pointer); override;

Parameters

Key
Type: Pointer

Value
Type: Pointer

Overrides

TMap.SetItem(Pointer,Pointer)
See Also

Reference

  • TBTree
  • frxStorage


TBTree.SetItemExistence(Pointer,Boolean) Method

Summary

Represents method SetItemExistence(Pointer,Boolean).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItemExistence(Key: Pointer; b: Boolean); override;

Parameters

Key
Type: Pointer

b
Type: Boolean

Overrides

TMap.SetItemExistence(Pointer,Boolean)
See Also

Reference

  • TBTree
  • frxStorage


TBTree.SplitTree(TBTreeNode,Integer) Method

Summary

Represents method SplitTree(TBTreeNode,Integer).

Namespace: frxStorage
Syntax
Delphi
private
 procedure SplitTree(Node: TBTreeNode; i: Integer);

Parameters

Node
Type: TBTreeNode

i
Type: Integer

See Also

Reference

  • TBTree
  • frxStorage


TBTree Fields

Fields
Name | Description
FOrder | Represents field FOrder.
FRoot | Represents field FRoot.
Top


TBTree.FOrder Field

Summary

Represents field FOrder.

Namespace: frxStorage
Syntax
Delphi
private
 FOrder: Integer;

Field Value

Type: Integer

See Also

Reference

  • TBTree
  • frxStorage


TBTree.FRoot Field

Summary

Represents field FRoot.

Namespace: frxStorage
Syntax
Delphi
private
 FRoot: TBTreeNode;

Field Value

Type: TBTreeNode

See Also

Reference

  • TBTree
  • frxStorage


TBTreeNode Class

Summary

Represents type TBTreeNode.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TBTreeNode
Syntax
Delphi
type
 TBTreeNode = class
 end;

The TBTreeNode type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer) | Initializes a new instance of the TBTreeNode class.
Top
Properties
Show:
Name | Description
Keys[Integer] | Represents property Keys[Integer].
Len | Represents property Len.
Refs[Integer] | Represents property Refs[Integer].
Vals[Integer] | Represents property Vals[Integer].
Top
Methods
Show:
Name | Description
GetKey(Integer) | Represents method GetKey(Integer).
GetRef(Integer) | Represents method GetRef(Integer).
GetVal(Integer) | Represents method GetVal(Integer).
SetKey(Integer,Pointer) | Represents method SetKey(Integer,Pointer).
SetLen(Integer) | Represents method SetLen(Integer).
SetRef(Integer,TBTreeNode) | Represents method SetRef(Integer,TBTreeNode).
SetVal(Integer,Pointer) | Represents method SetVal(Integer,Pointer).
Top
Fields
Show:
Name | Description
FKeys | Represents field FKeys.
FLen | Represents field FLen.
FRefs | Represents field FRefs.
FVals | Represents field FVals.
Top
See Also

Reference

  • frxStorage


TBTreeNode Constructors

Constructors
Name | Description
Create(Integer) | Initializes a new instance of the TBTreeNode class.
Top


TBTreeNode.Create(Integer) Constructor

Summary

Initializes a new instance of the TBTreeNode class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(MaxLen: Integer);

Parameters

MaxLen
Type: Integer

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode Properties

Properties
Name | Description
Keys[Integer] | Represents property Keys[Integer].
Len | Represents property Len.
Refs[Integer] | Represents property Refs[Integer].
Vals[Integer] | Represents property Vals[Integer].
Top


TBTreeNode.Keys[Integer] Property

Summary

Represents property Keys[Integer].

Namespace: frxStorage
Syntax
Delphi
public
 property Keys[i: Integer]: Pointer read GetKey write SetKey;

Parameters

i
Type: Integer

Property Value

Type: Pointer

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode.Len Property

Summary

Represents property Len.

Namespace: frxStorage
Syntax
Delphi
public
 property Len: Integer read FLen write SetLen;

Property Value

Type: Integer

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode.Refs[Integer] Property

Summary

Represents property Refs[Integer].

Namespace: frxStorage
Syntax
Delphi
public
 property Refs[i: Integer]: TBTreeNode read GetRef write SetRef;

Parameters

i
Type: Integer

Property Value

Type: TBTreeNode

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode.Vals[Integer] Property

Summary

Represents property Vals[Integer].

Namespace: frxStorage
Syntax
Delphi
public
 property Vals[i: Integer]: Pointer read GetVal write SetVal;

Parameters

i
Type: Integer

Property Value

Type: Pointer

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode Methods

Methods
Name | Description
GetKey(Integer) | Represents method GetKey(Integer).
GetRef(Integer) | Represents method GetRef(Integer).
GetVal(Integer) | Represents method GetVal(Integer).
SetKey(Integer,Pointer) | Represents method SetKey(Integer,Pointer).
SetLen(Integer) | Represents method SetLen(Integer).
SetRef(Integer,TBTreeNode) | Represents method SetRef(Integer,TBTreeNode).
SetVal(Integer,Pointer) | Represents method SetVal(Integer,Pointer).
Top


TBTreeNode.GetKey(Integer) Method

Summary

Represents method GetKey(Integer).

Namespace: frxStorage
Syntax
Delphi
private
 function GetKey(i: Integer): Pointer;

Parameters

i
Type: Integer

Return Value

Type: Pointer

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode.GetRef(Integer) Method

Summary

Represents method GetRef(Integer).

Namespace: frxStorage
Syntax
Delphi
private
 function GetRef(i: Integer): TBTreeNode;

Parameters

i
Type: Integer

Return Value

Type: TBTreeNode

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode.GetVal(Integer) Method

Summary

Represents method GetVal(Integer).

Namespace: frxStorage
Syntax
Delphi
private
 function GetVal(i: Integer): Pointer;

Parameters

i
Type: Integer

Return Value

Type: Pointer

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode.SetKey(Integer,Pointer) Method

Summary

Represents method SetKey(Integer,Pointer).

Namespace: frxStorage
Syntax
Delphi
private
 procedure SetKey(i: Integer; k: Pointer);

Parameters

i
Type: Integer

k
Type: Pointer

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode.SetLen(Integer) Method

Summary

Represents method SetLen(Integer).

Namespace: frxStorage
Syntax
Delphi
private
 procedure SetLen(n: Integer);

Parameters

n
Type: Integer

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode.SetRef(Integer,TBTreeNode) Method

Summary

Represents method SetRef(Integer,TBTreeNode).

Namespace: frxStorage
Syntax
Delphi
private
 procedure SetRef(i: Integer; r: TBTreeNode);

Parameters

i
Type: Integer

r
Type: TBTreeNode

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode.SetVal(Integer,Pointer) Method

Summary

Represents method SetVal(Integer,Pointer).

Namespace: frxStorage
Syntax
Delphi
private
 procedure SetVal(i: Integer; v: Pointer);

Parameters

i
Type: Integer

v
Type: Pointer

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode Fields

Fields
Name | Description
FKeys | Represents field FKeys.
FLen | Represents field FLen.
FRefs | Represents field FRefs.
FVals | Represents field FVals.
Top


TBTreeNode.FKeys Field

Summary

Represents field FKeys.

Namespace: frxStorage
Syntax
Delphi
private
 FKeys: array of Pointer;

Field Value

Type: array of Pointer

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode.FLen Field

Summary

Represents field FLen.

Namespace: frxStorage
Syntax
Delphi
private
 FLen: Integer;

Field Value

Type: Integer

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode.FRefs Field

Summary

Represents field FRefs.

Namespace: frxStorage
Syntax
Delphi
private
 FRefs: array of TBTreeNode;

Field Value

Type: array of TBTreeNode

See Also

Reference

  • TBTreeNode
  • frxStorage


TBTreeNode.FVals Field

Summary

Represents field FVals.

Namespace: frxStorage
Syntax
Delphi
private
 FVals: array of Pointer;

Field Value

Type: array of Pointer

See Also

Reference

  • TBTreeNode
  • frxStorage


TCachedStream Class

Summary

Represents type TCachedStream.

Namespace: frxStorage
Inheritance Hierarchy
TStream
frxStorage.TCachedStream
Syntax
Delphi
type
 TCachedStream = class(TStream)
 end;

The TCachedStream type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream,Boolean) | Initializes a new instance of the TCachedStream class.
Destroy | Represents the destructor of the TCachedStream class.
Top
Properties
Show:
Name | Description
CacheSize | Represents property CacheSize.
Top
Methods
Show:
Name | Description
FlushCache | Represents method FlushCache.
GetCacheSize | Represents method GetCacheSize.
Read(Void,Longint) | Represents method Read(Void,Longint).
Seek(Longint,Word) | Represents method Seek(Longint,Word).
SetCacheSize(Integer) | Represents method SetCacheSize(Integer).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top
Fields
Show:
Name | Description
FChunk | Represents field FChunk.
FDeleteOnDestroy | Represents field FDeleteOnDestroy.
FStream | Represents field FStream.
FUsed | Represents field FUsed.
Top
See Also

Reference

  • frxStorage


TCachedStream Constructors

Constructors
Name | Description
Create(TStream,Boolean) | Initializes a new instance of the TCachedStream class.
Destroy | Represents the destructor of the TCachedStream class.
Top


TCachedStream.Create(TStream,Boolean) Constructor

Summary

Initializes a new instance of the TCachedStream class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(Stream: TStream; DeleteOnDestroy: Boolean);

Parameters

Stream
Type: TStream

DeleteOnDestroy
Type: Boolean

See Also

Reference

  • TCachedStream
  • frxStorage


TCachedStream.Destroy Destructor

Summary

Represents the destructor of the TCachedStream class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TCachedStream
  • frxStorage


TCachedStream Properties

Properties
Name | Description
CacheSize | Represents property CacheSize.
Top


TCachedStream.CacheSize Property

Summary

Represents property CacheSize.

Namespace: frxStorage
Syntax
Delphi
public
 property CacheSize: Integer read GetCacheSize write SetCacheSize;

Property Value

Type: Integer

See Also

Reference

  • TCachedStream
  • frxStorage


TCachedStream Methods

Methods
Name | Description
FlushCache | Represents method FlushCache.
GetCacheSize | Represents method GetCacheSize.
Read(Void,Longint) | Represents method Read(Void,Longint).
Seek(Longint,Word) | Represents method Seek(Longint,Word).
SetCacheSize(Integer) | Represents method SetCacheSize(Integer).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top


TCachedStream.FlushCache Method

Summary

Represents method FlushCache.

Namespace: frxStorage
Syntax
Delphi
protected
 procedure FlushCache;
See Also

Reference

  • TCachedStream
  • frxStorage


TCachedStream.GetCacheSize Method

Summary

Represents method GetCacheSize.

Namespace: frxStorage
Syntax
Delphi
private
 function GetCacheSize: Integer;

Return Value

Type: Integer

See Also

Reference

  • TCachedStream
  • frxStorage


TCachedStream.Read(Void,Longint) Method

Summary

Represents method Read(Void,Longint).

Namespace: frxStorage
Syntax
Delphi
public
 function Read(var Buffer; Count: Longint): Longint; override;

Parameters

Buffer
Type: System.Void

Count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TCachedStream
  • frxStorage


TCachedStream.Seek(Longint,Word) Method

Summary

Represents method Seek(Longint,Word).

Namespace: frxStorage
Syntax
Delphi
public
 function Seek(Offset: Longint; Origin: Word): Longint; override;

Parameters

Offset
Type: Longint

Origin
Type: Word

Return Value

Type: Longint

See Also

Reference

  • TCachedStream
  • frxStorage


TCachedStream.SetCacheSize(Integer) Method

Summary

Represents method SetCacheSize(Integer).

Namespace: frxStorage
Syntax
Delphi
private
 procedure SetCacheSize(Size: Integer);

Parameters

Size
Type: Integer

See Also

Reference

  • TCachedStream
  • frxStorage


TCachedStream.Write(Void,Longint) Method

Summary

Represents method Write(Void,Longint).

Namespace: frxStorage
Syntax
Delphi
public
 function Write(const Buffer; Count: Longint): Longint; override;

Parameters

Buffer
Type: System.Void

Count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TCachedStream
  • frxStorage


TCachedStream Fields

Fields
Name | Description
FChunk | Represents field FChunk.
FDeleteOnDestroy | Represents field FDeleteOnDestroy.
FStream | Represents field FStream.
FUsed | Represents field FUsed.
Top


TCachedStream.FChunk Field

Summary

Represents field FChunk.

Namespace: frxStorage
Syntax
Delphi
private
 FChunk: array of Byte;

Field Value

Type: array of Byte

See Also

Reference

  • TCachedStream
  • frxStorage


TCachedStream.FDeleteOnDestroy Field

Summary

Represents field FDeleteOnDestroy.

Namespace: frxStorage
Syntax
Delphi
private
 FDeleteOnDestroy: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TCachedStream
  • frxStorage


TCachedStream.FStream Field

Summary

Represents field FStream.

Namespace: frxStorage
Syntax
Delphi
private
 FStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TCachedStream
  • frxStorage


TCachedStream.FUsed Field

Summary

Represents field FUsed.

Namespace: frxStorage
Syntax
Delphi
private
 FUsed: Integer;

Field Value

Type: Integer

See Also

Reference

  • TCachedStream
  • frxStorage


TDataBlock Class

Summary

Represents type TDataBlock.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TDataBlock
Syntax
Delphi
type
 TDataBlock = class
 end;

The TDataBlock type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer,Boolean) | Initializes a new instance of the TDataBlock class.
Destroy | Represents the destructor of the TDataBlock class.
Top
Fields
Show:
Name | Description
Data | Represents field Data.
Size | Represents field Size.
Top
See Also

Reference

  • frxStorage


TDataBlock Constructors

Constructors
Name | Description
Create(Integer,Boolean) | Initializes a new instance of the TDataBlock class.
Destroy | Represents the destructor of the TDataBlock class.
Top


TDataBlock.Create(Integer,Boolean) Constructor

Summary

Initializes a new instance of the TDataBlock class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(Size: Integer; Zero: Boolean = True);

Parameters

Size
Type: Integer

Zero
Type: Boolean

See Also

Reference

  • TDataBlock
  • frxStorage


TDataBlock.Destroy Destructor

Summary

Represents the destructor of the TDataBlock class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TDataBlock
  • frxStorage


TDataBlock Fields

Fields
Name | Description
Data | Represents field Data.
Size | Represents field Size.
Top


TDataBlock.Data Field

Summary

Represents field Data.

Namespace: frxStorage
Syntax
Delphi
public
 Data: Pointer;

Field Value

Type: Pointer

See Also

Reference

  • TDataBlock
  • frxStorage


TDataBlock.Size Field

Summary

Represents field Size.

Namespace: frxStorage
Syntax
Delphi
public
 Size: Integer;

Field Value

Type: Integer

See Also

Reference

  • TDataBlock
  • frxStorage


TFmtStream Class

Summary

Represents type TFmtStream.

Namespace: frxStorage
Inheritance Hierarchy
TStream
frxStorage.TFmtStream
Syntax
Delphi
type
 TFmtStream = class(TStream)
 end;

The TFmtStream type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream,Boolean) | Initializes a new instance of the TFmtStream class.
Destroy | Represents the destructor of the TFmtStream class.
Top
Properties
Show:
Name | Description
Formatted | Represents property Formatted.
Indent | Represents property Indent.
Top
Methods
Show:
Name | Description
IncIndent(Integer) | Represents method IncIndent(Integer).
Puts(string) | Overloaded. Represents method Puts(string).
Puts(string,TVarRec[]) | Overloaded. Represents method Puts(string,TVarRec[]).
PutsA(AnsiString) | Overloaded. Represents method PutsA(AnsiString).
PutsA(AnsiString,TVarRec[]) | Overloaded. Represents method PutsA(AnsiString,TVarRec[]).
PutsRaw(string) | Overloaded. Represents method PutsRaw(string).
PutsRaw(string,TVarRec[]) | Overloaded. Represents method PutsRaw(string,TVarRec[]).
PutsRawA(AnsiString) | Overloaded. Represents method PutsRawA(AnsiString).
PutsRawA(AnsiString,TVarRec[]) | Overloaded. Represents method PutsRawA(AnsiString,TVarRec[]).
Read(Void,Longint) | Represents method Read(Void,Longint).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top
Fields
Show:
Name | Description
FFormatted | Represents field FFormatted.
FIndent | Represents field FIndent.
FOutput | Represents field FOutput.
FOwn | Represents field FOwn.
Top
See Also

Reference

  • frxStorage


TFmtStream Constructors

Constructors
Name | Description
Create(TStream,Boolean) | Initializes a new instance of the TFmtStream class.
Destroy | Represents the destructor of the TFmtStream class.
Top


TFmtStream.Create(TStream,Boolean) Constructor

Summary

Initializes a new instance of the TFmtStream class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(Output: TStream; Own: Boolean);

Parameters

Output
Type: TStream

Own
Type: Boolean

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.Destroy Destructor

Summary

Represents the destructor of the TFmtStream class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream Properties

Properties
Name | Description
Formatted | Represents property Formatted.
Indent | Represents property Indent.
Top


TFmtStream.Formatted Property

Summary

Represents property Formatted.

Namespace: frxStorage
Syntax
Delphi
public
 property Formatted: Boolean read FFormatted write FFormatted;

Property Value

Type: Boolean

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.Indent Property

Summary

Represents property Indent.

Namespace: frxStorage
Syntax
Delphi
public
 property Indent: Integer read FIndent write FIndent;

Property Value

Type: Integer

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream Methods

Methods
Name | Description
IncIndent(Integer) | Represents method IncIndent(Integer).
Puts(string) | Overloaded. Represents method Puts(string).
Puts(string,TVarRec[]) | Overloaded. Represents method Puts(string,TVarRec[]).
PutsA(AnsiString) | Overloaded. Represents method PutsA(AnsiString).
PutsA(AnsiString,TVarRec[]) | Overloaded. Represents method PutsA(AnsiString,TVarRec[]).
PutsRaw(string) | Overloaded. Represents method PutsRaw(string).
PutsRaw(string,TVarRec[]) | Overloaded. Represents method PutsRaw(string,TVarRec[]).
PutsRawA(AnsiString) | Overloaded. Represents method PutsRawA(AnsiString).
PutsRawA(AnsiString,TVarRec[]) | Overloaded. Represents method PutsRawA(AnsiString,TVarRec[]).
Read(Void,Longint) | Represents method Read(Void,Longint).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top


TFmtStream.IncIndent(Integer) Method

Summary

Represents method IncIndent(Integer).

Namespace: frxStorage
Syntax
Delphi
public
 procedure IncIndent(Step: Integer);

Parameters

Step
Type: Integer

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.Puts(string) Method

Summary

Represents method Puts(string).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Puts(const s: string = ''); overload;

Parameters

s
Type: string

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.Puts(string,TVarRec[]) Method

Summary

Represents method Puts(string,TVarRec[]).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Puts(const Fmt: string; const Args: array of const); overload;

Parameters

Fmt
Type: string

Args
Type: array of const

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.PutsA(AnsiString) Method

Summary

Represents method PutsA(AnsiString).

Namespace: frxStorage
Syntax
Delphi
public
 procedure PutsA(const s: AnsiString); overload;

Parameters

s
Type: AnsiString

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.PutsA(AnsiString,TVarRec[]) Method

Summary

Represents method PutsA(AnsiString,TVarRec[]).

Namespace: frxStorage
Syntax
Delphi
public
 procedure PutsA(const Fmt: AnsiString; const Args: array of const); overload;

Parameters

Fmt
Type: AnsiString

Args
Type: array of const

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.PutsRaw(string) Method

Summary

Represents method PutsRaw(string).

Namespace: frxStorage
Syntax
Delphi
public
 procedure PutsRaw(const s: string); overload;

Parameters

s
Type: string

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.PutsRaw(string,TVarRec[]) Method

Summary

Represents method PutsRaw(string,TVarRec[]).

Namespace: frxStorage
Syntax
Delphi
public
 procedure PutsRaw(const Fmt: string; const Args: array of const); overload;

Parameters

Fmt
Type: string

Args
Type: array of const

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.PutsRawA(AnsiString) Method

Summary

Represents method PutsRawA(AnsiString).

Namespace: frxStorage
Syntax
Delphi
public
 procedure PutsRawA(const s: AnsiString); overload;

Parameters

s
Type: AnsiString

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.PutsRawA(AnsiString,TVarRec[]) Method

Summary

Represents method PutsRawA(AnsiString,TVarRec[]).

Namespace: frxStorage
Syntax
Delphi
public
 procedure PutsRawA(const Fmt: AnsiString; const Args: array of const); overload;

Parameters

Fmt
Type: AnsiString

Args
Type: array of const

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.Read(Void,Longint) Method

Summary

Represents method Read(Void,Longint).

Namespace: frxStorage
Syntax
Delphi
public
 function Read(var Buffer; Count: Longint): Longint; override;

Parameters

Buffer
Type: System.Void

Count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.Write(Void,Longint) Method

Summary

Represents method Write(Void,Longint).

Namespace: frxStorage
Syntax
Delphi
public
 function Write(const Buffer; Count: Longint): Longint; override;

Parameters

Buffer
Type: System.Void

Count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream Fields

Fields
Name | Description
FFormatted | Represents field FFormatted.
FIndent | Represents field FIndent.
FOutput | Represents field FOutput.
FOwn | Represents field FOwn.
Top


TFmtStream.FFormatted Field

Summary

Represents field FFormatted.

Namespace: frxStorage
Syntax
Delphi
private
 FFormatted: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.FIndent Field

Summary

Represents field FIndent.

Namespace: frxStorage
Syntax
Delphi
private
 FIndent: Integer;

Field Value

Type: Integer

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.FOutput Field

Summary

Represents field FOutput.

Namespace: frxStorage
Syntax
Delphi
private
 FOutput: TStream;

Field Value

Type: TStream

See Also

Reference

  • TFmtStream
  • frxStorage


TFmtStream.FOwn Field

Summary

Represents field FOwn.

Namespace: frxStorage
Syntax
Delphi
private
 FOwn: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TFmtStream
  • frxStorage


TfrxArray Class

Summary

Represents type TfrxArray.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TfrxArray
frxStorage.TfrxBaseArray
frxStorage.TfrxCachedArray
Syntax
Delphi
type
 TfrxArray = class
 end;

The TfrxArray type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TfrxArray class.
Top
Properties
Show:
Name | Description
Count | Represents property Count.
ItemData[Integer] | Represents property ItemData[Integer].
ItemSize | Represents property ItemSize.
Zero | Represents property Zero.
Top
Methods
Show:
Name | Description
Append(Void) | Represents method Append(Void).
Clear | Represents method Clear.
Delete(Integer) | Represents method Delete(Integer).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
GetCount | Represents method GetCount.
GetItem(Integer,Void) | Represents method GetItem(Integer,Void).
GetItemData(Integer) | Represents method GetItemData(Integer).
GetItemSize | Represents method GetItemSize.
GetZero | Represents method GetZero.
Insert(Integer,Void) | Represents method Insert(Integer,Void).
ResetItems(Integer,Integer) | Represents method ResetItems(Integer,Integer).
SetCount(Integer) | Represents method SetCount(Integer).
SetItem(Integer,Void) | Represents method SetItem(Integer,Void).
SetZero(Boolean) | Represents method SetZero(Boolean).
Sort(TSimpleCompareFunction,Integer,Integer) | Represents method Sort(TSimpleCompareFunction,Integer,Integer).
VerifyIndex(Integer) | Represents method VerifyIndex(Integer).
Top
See Also

Reference

  • frxStorage


TfrxArray Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TfrxArray class.
Top


TfrxArray.Destroy Destructor

Summary

Represents the destructor of the TfrxArray class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray Properties

Properties
Name | Description
Count | Represents property Count.
ItemData[Integer] | Represents property ItemData[Integer].
ItemSize | Represents property ItemSize.
Zero | Represents property Zero.
Top


TfrxArray.Count Property

Summary

Represents property Count.

Namespace: frxStorage
Syntax
Delphi
public
 property Count: Integer read GetCount write SetCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.ItemData[Integer] Property

Summary

Represents property ItemData[Integer].

Namespace: frxStorage
Syntax
Delphi
protected
 property ItemData[Index: Integer]: Pointer read GetItemData;

Parameters

Index
Type: Integer

Property Value

Type: Pointer

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.ItemSize Property

Summary

Represents property ItemSize.

Namespace: frxStorage
Syntax
Delphi
protected
 property ItemSize: Integer read GetItemSize;

Property Value

Type: Integer

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.Zero Property

Summary

Represents property Zero.

Namespace: frxStorage
Syntax
Delphi
public
 property Zero: Boolean read GetZero write SetZero;

Property Value

Type: Boolean

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray Methods

Methods
Name | Description
Append(Void) | Represents method Append(Void).
Clear | Represents method Clear.
Delete(Integer) | Represents method Delete(Integer).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
GetCount | Represents method GetCount.
GetItem(Integer,Void) | Represents method GetItem(Integer,Void).
GetItemData(Integer) | Represents method GetItemData(Integer).
GetItemSize | Represents method GetItemSize.
GetZero | Represents method GetZero.
Insert(Integer,Void) | Represents method Insert(Integer,Void).
ResetItems(Integer,Integer) | Represents method ResetItems(Integer,Integer).
SetCount(Integer) | Represents method SetCount(Integer).
SetItem(Integer,Void) | Represents method SetItem(Integer,Void).
SetZero(Boolean) | Represents method SetZero(Boolean).
Sort(TSimpleCompareFunction,Integer,Integer) | Represents method Sort(TSimpleCompareFunction,Integer,Integer).
VerifyIndex(Integer) | Represents method VerifyIndex(Integer).
Top


TfrxArray.Append(Void) Method

Summary

Represents method Append(Void).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure Append(const Value);

Parameters

Value
Type: System.Void

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.Clear Method

Summary

Represents method Clear.

Namespace: frxStorage
Syntax
Delphi
public
 procedure Clear; virtual;
See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Delete(Index: Integer); virtual;

Parameters

Index
Type: Integer

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.Exchange(Integer,Integer) Method

Summary

Represents method Exchange(Integer,Integer).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Exchange(Index1, Index2: Integer); virtual;

Parameters

Index1
Type: Integer

Index2
Type: Integer

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.GetCount Method

Summary

Represents method GetCount.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetCount: Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.GetItem(Integer,Void) Method

Summary

Represents method GetItem(Integer,Void).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure GetItem(Index: Integer; var Item);

Parameters

Index
Type: Integer

Item
Type: System.Void

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.GetItemData(Integer) Method

Summary

Represents method GetItemData(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItemData(Index: Integer): Pointer; virtual; abstract;

Parameters

Index
Type: Integer

Return Value

Type: Pointer

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.GetItemSize Method

Summary

Represents method GetItemSize.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItemSize: Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.GetZero Method

Summary

Represents method GetZero.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetZero: Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.Insert(Integer,Void) Method

Summary

Represents method Insert(Integer,Void).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure Insert(Index: Integer; const Value);

Parameters

Index
Type: Integer

Value
Type: System.Void

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.ResetItems(Integer,Integer) Method

Summary

Represents method ResetItems(Integer,Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure ResetItems(Min, Max: Integer);

Parameters

Min
Type: Integer

Max
Type: Integer

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.SetCount(Integer) Method

Summary

Represents method SetCount(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetCount(Value: Integer); virtual; abstract;

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.SetItem(Integer,Void) Method

Summary

Represents method SetItem(Integer,Void).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItem(Index: Integer; const Item);

Parameters

Index
Type: Integer

Item
Type: System.Void

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.SetZero(Boolean) Method

Summary

Represents method SetZero(Boolean).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetZero(f: Boolean); virtual; abstract;

Parameters

f
Type: Boolean

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.Sort(TSimpleCompareFunction,Integer,Integer) Method

Summary

Represents method Sort(TSimpleCompareFunction,Integer,Integer).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Sort(Compare: TSimpleCompareFunction; Min, Max: Integer); virtual;

Parameters

Compare
Type: TSimpleCompareFunction

Min
Type: Integer

Max
Type: Integer

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxArray.VerifyIndex(Integer) Method

Summary

Represents method VerifyIndex(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure VerifyIndex(Index: Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TfrxArray
  • frxStorage


TfrxBaseArray Class

Summary

Represents type TfrxBaseArray.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TfrxArray
frxStorage.TfrxBaseArray
frxStorage.TfrxExtArrayBase
frxStorage.TfrxIntArrayBase
Syntax
Delphi
type
 TfrxBaseArray = class(TfrxArray)
 end;

The TfrxBaseArray type exposes the following members.

Properties
Show:
Name | Description
Count | Represents property Count. (Inherited from TfrxArray.)
ItemData[Integer] | Represents property ItemData[Integer]. (Inherited from TfrxArray.)
ItemSize | Represents property ItemSize. (Inherited from TfrxArray.)
Zero | Represents property Zero. (Inherited from TfrxArray.)
Top
Methods
Show:
Name | Description
Append(Void) | Represents method Append(Void). (Inherited from TfrxArray.)
Clear | Represents method Clear. (Overrides TfrxArray.Clear.)
Delete(Integer) | Represents method Delete(Integer). (Inherited from TfrxArray.)
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer). (Inherited from TfrxArray.)
GetCount | Represents method GetCount. (Overrides TfrxArray.GetCount.)
GetItem(Integer,Void) | Represents method GetItem(Integer,Void). (Inherited from TfrxArray.)
GetItemData(Integer) | Represents method GetItemData(Integer). (Inherited from TfrxArray.)
GetItemSize | Represents method GetItemSize. (Inherited from TfrxArray.)
GetZero | Represents method GetZero. (Inherited from TfrxArray.)
Grow | Represents method Grow.
Insert(Integer,Void) | Represents method Insert(Integer,Void). (Inherited from TfrxArray.)
ResetItems(Integer,Integer) | Represents method ResetItems(Integer,Integer). (Inherited from TfrxArray.)
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxArray.SetCount(Integer).)
SetItem(Integer,Void) | Represents method SetItem(Integer,Void). (Inherited from TfrxArray.)
SetNewCapacity(Integer) | Represents method SetNewCapacity(Integer).
SetZero(Boolean) | Represents method SetZero(Boolean). (Inherited from TfrxArray.)
Sort(TSimpleCompareFunction,Integer,Integer) | Represents method Sort(TSimpleCompareFunction,Integer,Integer). (Inherited from TfrxArray.)
VerifyIndex(Integer) | Represents method VerifyIndex(Integer). (Inherited from TfrxArray.)
Top
Fields
Show:
Name | Description
FCapacity | Represents field FCapacity.
FCount | Represents field FCount.
FSorted | Represents field FSorted.
Top
See Also

Reference

  • frxStorage


TfrxBaseArray Methods

Methods
Name | Description
Clear | Represents method Clear. (Overrides TfrxArray.Clear.)
GetCount | Represents method GetCount. (Overrides TfrxArray.GetCount.)
Grow | Represents method Grow.
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxArray.SetCount(Integer).)
SetNewCapacity(Integer) | Represents method SetNewCapacity(Integer).
Top


TfrxBaseArray.Clear Method

Summary

Represents method Clear.

Namespace: frxStorage
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TfrxArray.Clear
See Also

Reference

  • TfrxBaseArray
  • frxStorage


TfrxBaseArray.GetCount Method

Summary

Represents method GetCount.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetCount: Integer; override;

Return Value

Type: Integer

Overrides

TfrxArray.GetCount
See Also

Reference

  • TfrxBaseArray
  • frxStorage


TfrxBaseArray.Grow Method

Summary

Represents method Grow.

Namespace: frxStorage
Syntax
Delphi
protected
 procedure Grow; virtual;
See Also

Reference

  • TfrxBaseArray
  • frxStorage


TfrxBaseArray.SetCount(Integer) Method

Summary

Represents method SetCount(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetCount(Value: Integer); override;

Parameters

Value
Type: Integer

Overrides

TfrxArray.SetCount(Integer)
See Also

Reference

  • TfrxBaseArray
  • frxStorage


TfrxBaseArray.SetNewCapacity(Integer) Method

Summary

Represents method SetNewCapacity(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetNewCapacity(Value: Integer); virtual;

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxBaseArray
  • frxStorage


TfrxBaseArray Fields

Fields
Name | Description
FCapacity | Represents field FCapacity.
FCount | Represents field FCount.
FSorted | Represents field FSorted.
Top


TfrxBaseArray.FCapacity Field

Summary

Represents field FCapacity.

Namespace: frxStorage
Syntax
Delphi
protected
 FCapacity: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBaseArray
  • frxStorage


TfrxBaseArray.FCount Field

Summary

Represents field FCount.

Namespace: frxStorage
Syntax
Delphi
protected
 FCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBaseArray
  • frxStorage


TfrxBaseArray.FSorted Field

Summary

Represents field FSorted.

Namespace: frxStorage
Syntax
Delphi
protected
 FSorted: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBaseArray
  • frxStorage


TfrxCachedArray Class

Summary

Represents type TfrxCachedArray.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TfrxArray
frxStorage.TfrxCachedArray
Syntax
Delphi
type
 TfrxCachedArray = class(TfrxArray)
 end;

The TfrxCachedArray type exposes the following members.

Constructors
Show:
Name | Description
Create(string,string,Integer,Integer) | Overloaded. Initializes a new instance of the TfrxCachedArray class.
Create(TStream,TStream,Integer,Integer) | Overloaded. Initializes a new instance of the TfrxCachedArray class.
Destroy | Represents the destructor of the TfrxCachedArray class. (Overrides TfrxArray.Destroy.)
Top
Properties
Show:
Name | Description
Count | Represents property Count. (Inherited from TfrxArray.)
ItemData[Integer] | Represents property ItemData[Integer]. (Inherited from TfrxArray.)
ItemSize | Represents property ItemSize. (Inherited from TfrxArray.)
Zero | Represents property Zero. (Inherited from TfrxArray.)
Top
Methods
Show:
Name | Description
Append(Void) | Represents method Append(Void). (Inherited from TfrxArray.)
Clear | Represents method Clear. (Inherited from TfrxArray.)
CreateBlock | Represents method CreateBlock.
Delete(Integer) | Represents method Delete(Integer). (Inherited from TfrxArray.)
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer). (Inherited from TfrxArray.)
GetCount | Represents method GetCount. (Overrides TfrxArray.GetCount.)
GetItem(Integer,Void) | Represents method GetItem(Integer,Void). (Inherited from TfrxArray.)
GetItemData(Integer) | Represents method GetItemData(Integer). (Overrides TfrxArray.GetItemData(Integer).)
GetItemSize | Represents method GetItemSize. (Overrides TfrxArray.GetItemSize.)
GetZero | Represents method GetZero. (Overrides TfrxArray.GetZero.)
Initialize | Represents method Initialize.
Insert(Integer,Void) | Represents method Insert(Integer,Void). (Inherited from TfrxArray.)
ResetItems(Integer,Integer) | Represents method ResetItems(Integer,Integer). (Inherited from TfrxArray.)
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxArray.SetCount(Integer).)
SetItem(Integer,Void) | Represents method SetItem(Integer,Void). (Inherited from TfrxArray.)
SetZero(Boolean) | Represents method SetZero(Boolean). (Overrides TfrxArray.SetZero(Boolean).)
Sort(TSimpleCompareFunction,Integer,Integer) | Represents method Sort(TSimpleCompareFunction,Integer,Integer). (Overrides TfrxArray.Sort(TSimpleCompareFunction,Integer,Integer).)
VerifyIndex(Integer) | Represents method VerifyIndex(Integer). (Inherited from TfrxArray.)
Top
Fields
Show:
Name | Description
FBlock | Represents field FBlock.
FCount | Represents field FCount.
FItemSize | Represents field FItemSize.
FStorage | Represents field FStorage.
FZero | Represents field FZero.
Top
See Also

Reference

  • frxStorage


TfrxCachedArray Constructors

Constructors
Name | Description
Create(string,string,Integer,Integer) | Overloaded. Initializes a new instance of the TfrxCachedArray class.
Create(TStream,TStream,Integer,Integer) | Overloaded. Initializes a new instance of the TfrxCachedArray class.
Destroy | Represents the destructor of the TfrxCachedArray class. (Overrides TfrxArray.Destroy.)
Top


TfrxCachedArray.Create(string,string,Integer,Integer) Constructor

Summary

Initializes a new instance of the TfrxCachedArray class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(DataFile, ServFile: string; Block, ItemSize: Integer); overload;

Parameters

DataFile
Type: string

ServFile
Type: string

Block
Type: Integer

ItemSize
Type: Integer

See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.Create(TStream,TStream,Integer,Integer) Constructor

Summary

Initializes a new instance of the TfrxCachedArray class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(DataStream, ServStream: TStream; Block, ItemSize: Integer); overload;

Parameters

DataStream
Type: TStream

ServStream
Type: TStream

Block
Type: Integer

ItemSize
Type: Integer

See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.Destroy Destructor

Summary

Represents the destructor of the TfrxCachedArray class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxArray.Destroy
See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray Methods

Methods
Name | Description
CreateBlock | Represents method CreateBlock.
GetCount | Represents method GetCount. (Overrides TfrxArray.GetCount.)
GetItemData(Integer) | Represents method GetItemData(Integer). (Overrides TfrxArray.GetItemData(Integer).)
GetItemSize | Represents method GetItemSize. (Overrides TfrxArray.GetItemSize.)
GetZero | Represents method GetZero. (Overrides TfrxArray.GetZero.)
Initialize | Represents method Initialize.
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxArray.SetCount(Integer).)
SetZero(Boolean) | Represents method SetZero(Boolean). (Overrides TfrxArray.SetZero(Boolean).)
Sort(TSimpleCompareFunction,Integer,Integer) | Represents method Sort(TSimpleCompareFunction,Integer,Integer). (Overrides TfrxArray.Sort(TSimpleCompareFunction,Integer,Integer).)
Top


TfrxCachedArray.CreateBlock Method

Summary

Represents method CreateBlock.

Namespace: frxStorage
Syntax
Delphi
private
 function CreateBlock: TDataBlock;

Return Value

Type: TDataBlock

See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.GetCount Method

Summary

Represents method GetCount.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetCount: Integer; override;

Return Value

Type: Integer

Overrides

TfrxArray.GetCount
See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.GetItemData(Integer) Method

Summary

Represents method GetItemData(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItemData(Index: Integer): Pointer; override;

Parameters

Index
Type: Integer

Return Value

Type: Pointer

Overrides

TfrxArray.GetItemData(Integer)
See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.GetItemSize Method

Summary

Represents method GetItemSize.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItemSize: Integer; override;

Return Value

Type: Integer

Overrides

TfrxArray.GetItemSize
See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.GetZero Method

Summary

Represents method GetZero.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetZero: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxArray.GetZero
See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.Initialize Method

Summary

Represents method Initialize.

Namespace: frxStorage
Syntax
Delphi
private
 procedure Initialize;
See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.SetCount(Integer) Method

Summary

Represents method SetCount(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetCount(Value: Integer); override;

Parameters

Value
Type: Integer

Overrides

TfrxArray.SetCount(Integer)
See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.SetZero(Boolean) Method

Summary

Represents method SetZero(Boolean).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetZero(f: Boolean); override;

Parameters

f
Type: Boolean

Overrides

TfrxArray.SetZero(Boolean)
See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.Sort(TSimpleCompareFunction,Integer,Integer) Method

Summary

Represents method Sort(TSimpleCompareFunction,Integer,Integer).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Sort(Compare: TSimpleCompareFunction; Min, Max: Integer); override;

Parameters

Compare
Type: TSimpleCompareFunction

Min
Type: Integer

Max
Type: Integer

Overrides

TfrxArray.Sort(TSimpleCompareFunction,Integer,Integer)
See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray Fields

Fields
Name | Description
FBlock | Represents field FBlock.
FCount | Represents field FCount.
FItemSize | Represents field FItemSize.
FStorage | Represents field FStorage.
FZero | Represents field FZero.
Top


TfrxCachedArray.FBlock Field

Summary

Represents field FBlock.

Namespace: frxStorage
Syntax
Delphi
private
 FBlock: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.FCount Field

Summary

Represents field FCount.

Namespace: frxStorage
Syntax
Delphi
private
 FCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.FItemSize Field

Summary

Represents field FItemSize.

Namespace: frxStorage
Syntax
Delphi
private
 FItemSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.FStorage Field

Summary

Represents field FStorage.

Namespace: frxStorage
Syntax
Delphi
private
 FStorage: TListCache;

Field Value

Type: TListCache

See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedArray.FZero Field

Summary

Represents field FZero.

Namespace: frxStorage
Syntax
Delphi
private
 FZero: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCachedArray
  • frxStorage


TfrxCachedExtArray Class

Summary

Represents type TfrxCachedExtArray.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TfrxArray
frxStorage.TfrxBaseArray
frxStorage.TfrxExtArrayBase
frxStorage.TfrxCachedExtArray
Syntax
Delphi
type
 TfrxCachedExtArray = class(TfrxExtArrayBase)
 end;

The TfrxCachedExtArray type exposes the following members.

Constructors
Show:
Name | Description
Create(string,string,Integer) | Overloaded. Initializes a new instance of the TfrxCachedExtArray class.
Create(TStream,TStream,Integer) | Overloaded. Initializes a new instance of the TfrxCachedExtArray class.
Destroy | Represents the destructor of the TfrxCachedExtArray class. (Overrides TfrxArray.Destroy.)
Top
Properties
Show:
Name | Description
Count | Represents property Count. (Inherited from TfrxArray.)
ItemData[Integer] | Represents property ItemData[Integer]. (Inherited from TfrxArray.)
ItemSize | Represents property ItemSize. (Inherited from TfrxArray.)
Items[Integer] | Represents property Items[Integer]. (Inherited from TfrxExtArrayBase.)
Zero | Represents property Zero. (Inherited from TfrxArray.)
Top
Methods
Show:
Name | Description
Append(Extended) | Represents method Append(Extended). (Inherited from TfrxExtArrayBase.)
Clear | Represents method Clear. (Overrides TfrxArray.Clear.)
Delete(Integer) | Represents method Delete(Integer). (Inherited from TfrxArray.)
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer). (Inherited from TfrxArray.)
GetCount | Represents method GetCount. (Overrides TfrxBaseArray.GetCount.)
GetItem(Integer) | Represents method GetItem(Integer). (Overrides TfrxExtArrayBase.GetItem(Integer).)
GetItemData(Integer) | Represents method GetItemData(Integer). (Overrides TfrxArray.GetItemData(Integer).)
GetItemSize | Represents method GetItemSize. (Overrides TfrxArray.GetItemSize.)
GetZero | Represents method GetZero. (Overrides TfrxArray.GetZero.)
Grow | Represents method Grow. (Inherited from TfrxBaseArray.)
Insert(Integer,Extended) | Represents method Insert(Integer,Extended). (Inherited from TfrxExtArrayBase.)
ResetItems(Integer,Integer) | Represents method ResetItems(Integer,Integer). (Inherited from TfrxArray.)
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxBaseArray.SetCount(Integer).)
SetItem(Integer,Extended) | Represents method SetItem(Integer,Extended). (Overrides TfrxExtArrayBase.SetItem(Integer,Extended).)
SetNewCapacity(Integer) | Represents method SetNewCapacity(Integer). (Inherited from TfrxBaseArray.)
SetZero(Boolean) | Represents method SetZero(Boolean). (Overrides TfrxArray.SetZero(Boolean).)
Sort(TSimpleCompareFunction,Integer,Integer) | Represents method Sort(TSimpleCompareFunction,Integer,Integer). (Inherited from TfrxArray.)
VerifyIndex(Integer) | Represents method VerifyIndex(Integer). (Inherited from TfrxArray.)
Top
Fields
Show:
Name | Description
FArray | Represents field FArray.
FCapacity | Represents field FCapacity. (Inherited from TfrxBaseArray.)
FCount | Represents field FCount. (Inherited from TfrxBaseArray.)
FSorted | Represents field FSorted. (Inherited from TfrxBaseArray.)
Top
See Also

Reference

  • frxStorage


TfrxCachedExtArray Constructors

Constructors
Name | Description
Create(string,string,Integer) | Overloaded. Initializes a new instance of the TfrxCachedExtArray class.
Create(TStream,TStream,Integer) | Overloaded. Initializes a new instance of the TfrxCachedExtArray class.
Destroy | Represents the destructor of the TfrxCachedExtArray class. (Overrides TfrxArray.Destroy.)
Top


TfrxCachedExtArray.Create(string,string,Integer) Constructor

Summary

Initializes a new instance of the TfrxCachedExtArray class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(DataFile, ServFile: string; Block: Integer); overload;

Parameters

DataFile
Type: string

ServFile
Type: string

Block
Type: Integer

See Also

Reference

  • TfrxCachedExtArray
  • frxStorage


TfrxCachedExtArray.Create(TStream,TStream,Integer) Constructor

Summary

Initializes a new instance of the TfrxCachedExtArray class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(DataStream, ServStream: TStream; Block: Integer); overload;

Parameters

DataStream
Type: TStream

ServStream
Type: TStream

Block
Type: Integer

See Also

Reference

  • TfrxCachedExtArray
  • frxStorage


TfrxCachedExtArray.Destroy Destructor

Summary

Represents the destructor of the TfrxCachedExtArray class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxArray.Destroy
See Also

Reference

  • TfrxCachedExtArray
  • frxStorage


TfrxCachedExtArray Methods

Methods
Name | Description
GetCount | Represents method GetCount. (Overrides TfrxBaseArray.GetCount.)
GetItem(Integer) | Represents method GetItem(Integer). (Overrides TfrxExtArrayBase.GetItem(Integer).)
GetItemData(Integer) | Represents method GetItemData(Integer). (Overrides TfrxArray.GetItemData(Integer).)
GetZero | Represents method GetZero. (Overrides TfrxArray.GetZero.)
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxBaseArray.SetCount(Integer).)
SetItem(Integer,Extended) | Represents method SetItem(Integer,Extended). (Overrides TfrxExtArrayBase.SetItem(Integer,Extended).)
SetZero(Boolean) | Represents method SetZero(Boolean). (Overrides TfrxArray.SetZero(Boolean).)
Top


TfrxCachedExtArray.GetCount Method

Summary

Represents method GetCount.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetCount: Integer; override;

Return Value

Type: Integer

Overrides

TfrxBaseArray.GetCount
See Also

Reference

  • TfrxCachedExtArray
  • frxStorage


TfrxCachedExtArray.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItem(Index: Integer): Extended; override;

Parameters

Index
Type: Integer

Return Value

Type: Extended

Overrides

TfrxExtArrayBase.GetItem(Integer)
See Also

Reference

  • TfrxCachedExtArray
  • frxStorage


TfrxCachedExtArray.GetItemData(Integer) Method

Summary

Represents method GetItemData(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItemData(Index: Integer): Pointer; override;

Parameters

Index
Type: Integer

Return Value

Type: Pointer

Overrides

TfrxArray.GetItemData(Integer)
See Also

Reference

  • TfrxCachedExtArray
  • frxStorage


TfrxCachedExtArray.GetZero Method

Summary

Represents method GetZero.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetZero: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxArray.GetZero
See Also

Reference

  • TfrxCachedExtArray
  • frxStorage


TfrxCachedExtArray.SetCount(Integer) Method

Summary

Represents method SetCount(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetCount(Value: Integer); override;

Parameters

Value
Type: Integer

Overrides

TfrxBaseArray.SetCount(Integer)
See Also

Reference

  • TfrxCachedExtArray
  • frxStorage


TfrxCachedExtArray.SetItem(Integer,Extended) Method

Summary

Represents method SetItem(Integer,Extended).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItem(Index: Integer; Value: Extended); override;

Parameters

Index
Type: Integer

Value
Type: Extended

Overrides

TfrxExtArrayBase.SetItem(Integer,Extended)
See Also

Reference

  • TfrxCachedExtArray
  • frxStorage


TfrxCachedExtArray.SetZero(Boolean) Method

Summary

Represents method SetZero(Boolean).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetZero(f: Boolean); override;

Parameters

f
Type: Boolean

Overrides

TfrxArray.SetZero(Boolean)
See Also

Reference

  • TfrxCachedExtArray
  • frxStorage


TfrxCachedExtArray Fields

Fields
Name | Description
FArray | Represents field FArray.
Top


TfrxCachedExtArray.FArray Field

Summary

Represents field FArray.

Namespace: frxStorage
Syntax
Delphi
private
 FArray: TfrxCachedArray;

Field Value

Type: TfrxCachedArray

See Also

Reference

  • TfrxCachedExtArray
  • frxStorage


TfrxCachedIntArray Class

Summary

Represents type TfrxCachedIntArray.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TfrxArray
frxStorage.TfrxBaseArray
frxStorage.TfrxIntArrayBase
frxStorage.TfrxCachedIntArray
Syntax
Delphi
type
 TfrxCachedIntArray = class(TfrxIntArrayBase)
 end;

The TfrxCachedIntArray type exposes the following members.

Constructors
Show:
Name | Description
Create(string,string,Integer) | Overloaded. Initializes a new instance of the TfrxCachedIntArray class.
Create(TStream,TStream,Integer) | Overloaded. Initializes a new instance of the TfrxCachedIntArray class.
Destroy | Represents the destructor of the TfrxCachedIntArray class. (Overrides TfrxArray.Destroy.)
Top
Properties
Show:
Name | Description
Count | Represents property Count. (Inherited from TfrxArray.)
ItemData[Integer] | Represents property ItemData[Integer]. (Inherited from TfrxArray.)
ItemSize | Represents property ItemSize. (Inherited from TfrxArray.)
Items[Integer] | Represents property Items[Integer]. (Inherited from TfrxIntArrayBase.)
Zero | Represents property Zero. (Inherited from TfrxArray.)
Top
Methods
Show:
Name | Description
Append(Integer) | Represents method Append(Integer). (Inherited from TfrxIntArrayBase.)
Clear | Represents method Clear. (Overrides TfrxArray.Clear.)
Delete(Integer) | Represents method Delete(Integer). (Inherited from TfrxArray.)
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer). (Inherited from TfrxArray.)
GetCount | Represents method GetCount. (Overrides TfrxBaseArray.GetCount.)
GetItem(Integer) | Represents method GetItem(Integer). (Overrides TfrxIntArrayBase.GetItem(Integer).)
GetItemData(Integer) | Represents method GetItemData(Integer). (Overrides TfrxArray.GetItemData(Integer).)
GetItemSize | Represents method GetItemSize. (Overrides TfrxArray.GetItemSize.)
GetZero | Represents method GetZero. (Overrides TfrxArray.GetZero.)
Grow | Represents method Grow. (Inherited from TfrxBaseArray.)
Insert(Integer,Integer) | Represents method Insert(Integer,Integer). (Inherited from TfrxIntArrayBase.)
ResetItems(Integer,Integer) | Represents method ResetItems(Integer,Integer). (Inherited from TfrxArray.)
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxBaseArray.SetCount(Integer).)
SetItem(Integer,Integer) | Represents method SetItem(Integer,Integer). (Overrides TfrxIntArrayBase.SetItem(Integer,Integer).)
SetNewCapacity(Integer) | Represents method SetNewCapacity(Integer). (Inherited from TfrxBaseArray.)
SetZero(Boolean) | Represents method SetZero(Boolean). (Overrides TfrxArray.SetZero(Boolean).)
Sort(TSimpleCompareFunction,Integer,Integer) | Represents method Sort(TSimpleCompareFunction,Integer,Integer). (Inherited from TfrxArray.)
VerifyIndex(Integer) | Represents method VerifyIndex(Integer). (Inherited from TfrxArray.)
Top
Fields
Show:
Name | Description
FArray | Represents field FArray.
FCapacity | Represents field FCapacity. (Inherited from TfrxBaseArray.)
FCount | Represents field FCount. (Inherited from TfrxBaseArray.)
FSorted | Represents field FSorted. (Inherited from TfrxBaseArray.)
Top
See Also

Reference

  • frxStorage


TfrxCachedIntArray Constructors

Constructors
Name | Description
Create(string,string,Integer) | Overloaded. Initializes a new instance of the TfrxCachedIntArray class.
Create(TStream,TStream,Integer) | Overloaded. Initializes a new instance of the TfrxCachedIntArray class.
Destroy | Represents the destructor of the TfrxCachedIntArray class. (Overrides TfrxArray.Destroy.)
Top


TfrxCachedIntArray.Create(string,string,Integer) Constructor

Summary

Initializes a new instance of the TfrxCachedIntArray class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(DataFile, ServFile: string; Block: Integer); overload;

Parameters

DataFile
Type: string

ServFile
Type: string

Block
Type: Integer

See Also

Reference

  • TfrxCachedIntArray
  • frxStorage


TfrxCachedIntArray.Create(TStream,TStream,Integer) Constructor

Summary

Initializes a new instance of the TfrxCachedIntArray class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(DataStream, ServStream: TStream; Block: Integer); overload;

Parameters

DataStream
Type: TStream

ServStream
Type: TStream

Block
Type: Integer

See Also

Reference

  • TfrxCachedIntArray
  • frxStorage


TfrxCachedIntArray.Destroy Destructor

Summary

Represents the destructor of the TfrxCachedIntArray class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxArray.Destroy
See Also

Reference

  • TfrxCachedIntArray
  • frxStorage


TfrxCachedIntArray Methods

Methods
Name | Description
GetCount | Represents method GetCount. (Overrides TfrxBaseArray.GetCount.)
GetItem(Integer) | Represents method GetItem(Integer). (Overrides TfrxIntArrayBase.GetItem(Integer).)
GetItemData(Integer) | Represents method GetItemData(Integer). (Overrides TfrxArray.GetItemData(Integer).)
GetZero | Represents method GetZero. (Overrides TfrxArray.GetZero.)
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxBaseArray.SetCount(Integer).)
SetItem(Integer,Integer) | Represents method SetItem(Integer,Integer). (Overrides TfrxIntArrayBase.SetItem(Integer,Integer).)
SetZero(Boolean) | Represents method SetZero(Boolean). (Overrides TfrxArray.SetZero(Boolean).)
Top


TfrxCachedIntArray.GetCount Method

Summary

Represents method GetCount.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetCount: Integer; override;

Return Value

Type: Integer

Overrides

TfrxBaseArray.GetCount
See Also

Reference

  • TfrxCachedIntArray
  • frxStorage


TfrxCachedIntArray.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItem(Index: Integer): Integer; override;

Parameters

Index
Type: Integer

Return Value

Type: Integer

Overrides

TfrxIntArrayBase.GetItem(Integer)
See Also

Reference

  • TfrxCachedIntArray
  • frxStorage


TfrxCachedIntArray.GetItemData(Integer) Method

Summary

Represents method GetItemData(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItemData(Index: Integer): Pointer; override;

Parameters

Index
Type: Integer

Return Value

Type: Pointer

Overrides

TfrxArray.GetItemData(Integer)
See Also

Reference

  • TfrxCachedIntArray
  • frxStorage


TfrxCachedIntArray.GetZero Method

Summary

Represents method GetZero.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetZero: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxArray.GetZero
See Also

Reference

  • TfrxCachedIntArray
  • frxStorage


TfrxCachedIntArray.SetCount(Integer) Method

Summary

Represents method SetCount(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetCount(Value: Integer); override;

Parameters

Value
Type: Integer

Overrides

TfrxBaseArray.SetCount(Integer)
See Also

Reference

  • TfrxCachedIntArray
  • frxStorage


TfrxCachedIntArray.SetItem(Integer,Integer) Method

Summary

Represents method SetItem(Integer,Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItem(Index: Integer; Value: Integer); override;

Parameters

Index
Type: Integer

Value
Type: Integer

Overrides

TfrxIntArrayBase.SetItem(Integer,Integer)
See Also

Reference

  • TfrxCachedIntArray
  • frxStorage


TfrxCachedIntArray.SetZero(Boolean) Method

Summary

Represents method SetZero(Boolean).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetZero(f: Boolean); override;

Parameters

f
Type: Boolean

Overrides

TfrxArray.SetZero(Boolean)
See Also

Reference

  • TfrxCachedIntArray
  • frxStorage


TfrxCachedIntArray Fields

Fields
Name | Description
FArray | Represents field FArray.
Top


TfrxCachedIntArray.FArray Field

Summary

Represents field FArray.

Namespace: frxStorage
Syntax
Delphi
private
 FArray: TfrxCachedArray;

Field Value

Type: TfrxCachedArray

See Also

Reference

  • TfrxCachedIntArray
  • frxStorage


TfrxExtArray Class

Summary

Represents type TfrxExtArray.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TfrxArray
frxStorage.TfrxBaseArray
frxStorage.TfrxExtArrayBase
frxStorage.TfrxExtArray
frxStorage.TfrxExtendedObjectList
Syntax
Delphi
type
 TfrxExtArray = class(TfrxExtArrayBase)
 end;

The TfrxExtArray type exposes the following members.

Properties
Show:
Name | Description
Count | Represents property Count. (Inherited from TfrxArray.)
ItemData[Integer] | Represents property ItemData[Integer]. (Inherited from TfrxArray.)
ItemSize | Represents property ItemSize. (Inherited from TfrxArray.)
Items[Integer] | Represents property Items[Integer]. (Inherited from TfrxExtArrayBase.)
Zero | Represents property Zero. (Inherited from TfrxArray.)
Top
Methods
Show:
Name | Description
Append(Extended) | Represents method Append(Extended). (Inherited from TfrxExtArrayBase.)
Clear | Represents method Clear. (Overrides TfrxArray.Clear.)
Delete(Integer) | Represents method Delete(Integer). (Inherited from TfrxArray.)
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer). (Inherited from TfrxArray.)
GetCount | Represents method GetCount. (Overrides TfrxArray.GetCount.)
GetItem(Integer) | Represents method GetItem(Integer). (Overrides TfrxExtArrayBase.GetItem(Integer).)
GetItemData(Integer) | Represents method GetItemData(Integer). (Overrides TfrxArray.GetItemData(Integer).)
GetItemSize | Represents method GetItemSize. (Overrides TfrxArray.GetItemSize.)
GetZero | Represents method GetZero. (Overrides TfrxArray.GetZero.)
Grow | Represents method Grow. (Inherited from TfrxBaseArray.)
Insert(Integer,Extended) | Represents method Insert(Integer,Extended). (Inherited from TfrxExtArrayBase.)
ResetItems(Integer,Integer) | Represents method ResetItems(Integer,Integer). (Inherited from TfrxArray.)
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxArray.SetCount(Integer).)
SetItem(Integer,Extended) | Represents method SetItem(Integer,Extended). (Overrides TfrxExtArrayBase.SetItem(Integer,Extended).)
SetNewCapacity(Integer) | Represents method SetNewCapacity(Integer). (Overrides TfrxBaseArray.SetNewCapacity(Integer).)
SetZero(Boolean) | Represents method SetZero(Boolean). (Overrides TfrxArray.SetZero(Boolean).)
Sort(TSimpleCompareFunction,Integer,Integer) | Represents method Sort(TSimpleCompareFunction,Integer,Integer). (Inherited from TfrxArray.)
VerifyIndex(Integer) | Represents method VerifyIndex(Integer). (Inherited from TfrxArray.)
Top
Fields
Show:
Name | Description
FArray | Represents field FArray.
FCapacity | Represents field FCapacity. (Inherited from TfrxBaseArray.)
FCount | Represents field FCount. (Inherited from TfrxBaseArray.)
FSorted | Represents field FSorted. (Inherited from TfrxBaseArray.)
FZero | Represents field FZero.
Top
See Also

Reference

  • frxStorage


TfrxExtArray Methods

Methods
Name | Description
GetItem(Integer) | Represents method GetItem(Integer). (Overrides TfrxExtArrayBase.GetItem(Integer).)
GetItemData(Integer) | Represents method GetItemData(Integer). (Overrides TfrxArray.GetItemData(Integer).)
GetZero | Represents method GetZero. (Overrides TfrxArray.GetZero.)
SetItem(Integer,Extended) | Represents method SetItem(Integer,Extended). (Overrides TfrxExtArrayBase.SetItem(Integer,Extended).)
SetNewCapacity(Integer) | Represents method SetNewCapacity(Integer). (Overrides TfrxBaseArray.SetNewCapacity(Integer).)
SetZero(Boolean) | Represents method SetZero(Boolean). (Overrides TfrxArray.SetZero(Boolean).)
Top


TfrxExtArray.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItem(Index: Integer): Extended; override;

Parameters

Index
Type: Integer

Return Value

Type: Extended

Overrides

TfrxExtArrayBase.GetItem(Integer)
See Also

Reference

  • TfrxExtArray
  • frxStorage


TfrxExtArray.GetItemData(Integer) Method

Summary

Represents method GetItemData(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItemData(Index: Integer): Pointer; override;

Parameters

Index
Type: Integer

Return Value

Type: Pointer

Overrides

TfrxArray.GetItemData(Integer)
See Also

Reference

  • TfrxExtArray
  • frxStorage


TfrxExtArray.GetZero Method

Summary

Represents method GetZero.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetZero: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxArray.GetZero
See Also

Reference

  • TfrxExtArray
  • frxStorage


TfrxExtArray.SetItem(Integer,Extended) Method

Summary

Represents method SetItem(Integer,Extended).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItem(Index: Integer; Value: Extended); override;

Parameters

Index
Type: Integer

Value
Type: Extended

Overrides

TfrxExtArrayBase.SetItem(Integer,Extended)
See Also

Reference

  • TfrxExtArray
  • frxStorage


TfrxExtArray.SetNewCapacity(Integer) Method

Summary

Represents method SetNewCapacity(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetNewCapacity(Value: Integer); override;

Parameters

Value
Type: Integer

Overrides

TfrxBaseArray.SetNewCapacity(Integer)
See Also

Reference

  • TfrxExtArray
  • frxStorage


TfrxExtArray.SetZero(Boolean) Method

Summary

Represents method SetZero(Boolean).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetZero(f: Boolean); override;

Parameters

f
Type: Boolean

Overrides

TfrxArray.SetZero(Boolean)
See Also

Reference

  • TfrxExtArray
  • frxStorage


TfrxExtArray Fields

Fields
Name | Description
FArray | Represents field FArray.
FZero | Represents field FZero.
Top


TfrxExtArray.FArray Field

Summary

Represents field FArray.

Namespace: frxStorage
Syntax
Delphi
private
 FArray: array of Extended;

Field Value

Type: array of Extended

See Also

Reference

  • TfrxExtArray
  • frxStorage


TfrxExtArray.FZero Field

Summary

Represents field FZero.

Namespace: frxStorage
Syntax
Delphi
private
 FZero: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxExtArray
  • frxStorage


TfrxExtArrayBase Class

Summary

Represents type TfrxExtArrayBase.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TfrxArray
frxStorage.TfrxBaseArray
frxStorage.TfrxExtArrayBase
frxStorage.TfrxCachedExtArray
frxStorage.TfrxExtArray
Syntax
Delphi
type
 TfrxExtArrayBase = class(TfrxBaseArray)
 end;

The TfrxExtArrayBase type exposes the following members.

Properties
Show:
Name | Description
Count | Represents property Count. (Inherited from TfrxArray.)
ItemData[Integer] | Represents property ItemData[Integer]. (Inherited from TfrxArray.)
ItemSize | Represents property ItemSize. (Inherited from TfrxArray.)
Items[Integer] | Represents property Items[Integer].
Zero | Represents property Zero. (Inherited from TfrxArray.)
Top
Methods
Show:
Name | Description
Append(Extended) | Represents method Append(Extended).
Clear | Represents method Clear. (Overrides TfrxArray.Clear.)
Delete(Integer) | Represents method Delete(Integer). (Inherited from TfrxArray.)
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer). (Inherited from TfrxArray.)
GetCount | Represents method GetCount. (Overrides TfrxArray.GetCount.)
GetItem(Integer) | Represents method GetItem(Integer).
GetItemData(Integer) | Represents method GetItemData(Integer). (Inherited from TfrxArray.)
GetItemSize | Represents method GetItemSize. (Overrides TfrxArray.GetItemSize.)
GetZero | Represents method GetZero. (Inherited from TfrxArray.)
Grow | Represents method Grow. (Inherited from TfrxBaseArray.)
Insert(Integer,Extended) | Represents method Insert(Integer,Extended).
ResetItems(Integer,Integer) | Represents method ResetItems(Integer,Integer). (Inherited from TfrxArray.)
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxArray.SetCount(Integer).)
SetItem(Integer,Extended) | Represents method SetItem(Integer,Extended).
SetNewCapacity(Integer) | Represents method SetNewCapacity(Integer). (Inherited from TfrxBaseArray.)
SetZero(Boolean) | Represents method SetZero(Boolean). (Inherited from TfrxArray.)
Sort(TSimpleCompareFunction,Integer,Integer) | Represents method Sort(TSimpleCompareFunction,Integer,Integer). (Inherited from TfrxArray.)
VerifyIndex(Integer) | Represents method VerifyIndex(Integer). (Inherited from TfrxArray.)
Top
Fields
Show:
Name | Description
FCapacity | Represents field FCapacity. (Inherited from TfrxBaseArray.)
FCount | Represents field FCount. (Inherited from TfrxBaseArray.)
FSorted | Represents field FSorted. (Inherited from TfrxBaseArray.)
Top
See Also

Reference

  • frxStorage


TfrxExtArrayBase Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxExtArrayBase.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxStorage
Syntax
Delphi
public
 property Items[Index: Integer]: Extended read GetItem write SetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: Extended

See Also

Reference

  • TfrxExtArrayBase
  • frxStorage


TfrxExtArrayBase Methods

Methods
Name | Description
Append(Extended) | Represents method Append(Extended).
GetItem(Integer) | Represents method GetItem(Integer).
GetItemSize | Represents method GetItemSize. (Overrides TfrxArray.GetItemSize.)
Insert(Integer,Extended) | Represents method Insert(Integer,Extended).
SetItem(Integer,Extended) | Represents method SetItem(Integer,Extended).
Top


TfrxExtArrayBase.Append(Extended) Method

Summary

Represents method Append(Extended).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Append(Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxExtArrayBase
  • frxStorage


TfrxExtArrayBase.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItem(Index: Integer): Extended; virtual; abstract;

Parameters

Index
Type: Integer

Return Value

Type: Extended

See Also

Reference

  • TfrxExtArrayBase
  • frxStorage


TfrxExtArrayBase.GetItemSize Method

Summary

Represents method GetItemSize.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItemSize: Integer; override;

Return Value

Type: Integer

Overrides

TfrxArray.GetItemSize
See Also

Reference

  • TfrxExtArrayBase
  • frxStorage


TfrxExtArrayBase.Insert(Integer,Extended) Method

Summary

Represents method Insert(Integer,Extended).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Insert(Index: Integer; Value: Extended);

Parameters

Index
Type: Integer

Value
Type: Extended

See Also

Reference

  • TfrxExtArrayBase
  • frxStorage


TfrxExtArrayBase.SetItem(Integer,Extended) Method

Summary

Represents method SetItem(Integer,Extended).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItem(Index: Integer; Value: Extended); virtual; abstract;

Parameters

Index
Type: Integer

Value
Type: Extended

See Also

Reference

  • TfrxExtArrayBase
  • frxStorage


TfrxExtendedObjectList Class

Summary

Represents type TfrxExtendedObjectList.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TfrxArray
frxStorage.TfrxBaseArray
frxStorage.TfrxExtArrayBase
frxStorage.TfrxExtArray
frxStorage.TfrxExtendedObjectList
Syntax
Delphi
type
 TfrxExtendedObjectList = class(TfrxExtArray)
 end;

The TfrxExtendedObjectList type exposes the following members.

Properties
Show:
Name | Description
Count | Represents property Count. (Inherited from TfrxArray.)
FreeObjects | Represents property FreeObjects.
ItemData[Integer] | Represents property ItemData[Integer]. (Inherited from TfrxArray.)
ItemSize | Represents property ItemSize. (Inherited from TfrxArray.)
Items[Integer] | Represents property Items[Integer]. (Inherited from TfrxExtArrayBase.)
Objects[Integer] | Represents property Objects[Integer].
Zero | Represents property Zero. (Inherited from TfrxArray.)
Top
Methods
Show:
Name | Description
Append(Extended) | Represents method Append(Extended). (Inherited from TfrxExtArrayBase.)
AppendObject(Extended,TObject) | Represents method AppendObject(Extended,TObject).
Clear | Represents method Clear. (Overrides TfrxBaseArray.Clear.)
Delete(Integer) | Represents method Delete(Integer). (Overrides TfrxArray.Delete(Integer).)
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer). (Overrides TfrxArray.Exchange(Integer,Integer).)
GetCount | Represents method GetCount. (Overrides TfrxArray.GetCount.)
GetItem(Integer) | Represents method GetItem(Integer). (Overrides TfrxExtArrayBase.GetItem(Integer).)
GetItemData(Integer) | Represents method GetItemData(Integer). (Overrides TfrxArray.GetItemData(Integer).)
GetItemSize | Represents method GetItemSize. (Overrides TfrxArray.GetItemSize.)
GetObject(Integer) | Represents method GetObject(Integer).
GetZero | Represents method GetZero. (Overrides TfrxArray.GetZero.)
Grow | Represents method Grow. (Inherited from TfrxBaseArray.)
Insert(Integer,Extended) | Represents method Insert(Integer,Extended). (Inherited from TfrxExtArrayBase.)
InsertObject(Integer,Extended,TObject) | Represents method InsertObject(Integer,Extended,TObject).
ResetItems(Integer,Integer) | Represents method ResetItems(Integer,Integer). (Inherited from TfrxArray.)
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxArray.SetCount(Integer).)
SetItem(Integer,Extended) | Represents method SetItem(Integer,Extended). (Overrides TfrxExtArrayBase.SetItem(Integer,Extended).)
SetNewCapacity(Integer) | Represents method SetNewCapacity(Integer). (Overrides TfrxExtArray.SetNewCapacity(Integer).)
SetObject(Integer,TObject) | Represents method SetObject(Integer,TObject).
SetZero(Boolean) | Represents method SetZero(Boolean). (Overrides TfrxArray.SetZero(Boolean).)
Sort(TSimpleCompareFunction,Integer,Integer) | Represents method Sort(TSimpleCompareFunction,Integer,Integer). (Inherited from TfrxArray.)
SortList | Represents method SortList.
VerifyIndex(Integer) | Represents method VerifyIndex(Integer). (Inherited from TfrxArray.)
Top
Fields
Show:
Name | Description
FCapacity | Represents field FCapacity. (Inherited from TfrxBaseArray.)
FCount | Represents field FCount. (Inherited from TfrxBaseArray.)
FFreeObjects | Represents field FFreeObjects.
FObjectList | Represents field FObjectList.
FSorted | Represents field FSorted. (Inherited from TfrxBaseArray.)
Top
See Also

Reference

  • frxStorage


TfrxExtendedObjectList Properties

Properties
Name | Description
FreeObjects | Represents property FreeObjects.
Objects[Integer] | Represents property Objects[Integer].
Top


TfrxExtendedObjectList.FreeObjects Property

Summary

Represents property FreeObjects.

Namespace: frxStorage
Syntax
Delphi
public
 property FreeObjects: Boolean read FFreeObjects write FFreeObjects;

Property Value

Type: Boolean

See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxExtendedObjectList.Objects[Integer] Property

Summary

Represents property Objects[Integer].

Namespace: frxStorage
Syntax
Delphi
public
 property Objects[Index: Integer]: TObject read GetObject write SetObject;

Parameters

Index
Type: Integer

Property Value

Type: TObject

See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxExtendedObjectList Methods

Methods
Name | Description
AppendObject(Extended,TObject) | Represents method AppendObject(Extended,TObject).
Clear | Represents method Clear. (Overrides TfrxBaseArray.Clear.)
Delete(Integer) | Represents method Delete(Integer). (Overrides TfrxArray.Delete(Integer).)
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer). (Overrides TfrxArray.Exchange(Integer,Integer).)
GetObject(Integer) | Represents method GetObject(Integer).
InsertObject(Integer,Extended,TObject) | Represents method InsertObject(Integer,Extended,TObject).
SetNewCapacity(Integer) | Represents method SetNewCapacity(Integer). (Overrides TfrxExtArray.SetNewCapacity(Integer).)
SetObject(Integer,TObject) | Represents method SetObject(Integer,TObject).
SortList | Represents method SortList.
Top


TfrxExtendedObjectList.AppendObject(Extended,TObject) Method

Summary

Represents method AppendObject(Extended,TObject).

Namespace: frxStorage
Syntax
Delphi
public
 procedure AppendObject(Value: Extended; aObject: TObject);

Parameters

Value
Type: Extended

aObject
Type: TObject

See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxExtendedObjectList.Clear Method

Summary

Represents method Clear.

Namespace: frxStorage
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TfrxBaseArray.Clear
See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxExtendedObjectList.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Delete(Index: Integer); override;

Parameters

Index
Type: Integer

Overrides

TfrxArray.Delete(Integer)
See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxExtendedObjectList.Exchange(Integer,Integer) Method

Summary

Represents method Exchange(Integer,Integer).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Exchange(Index1, Index2: Integer); override;

Parameters

Index1
Type: Integer

Index2
Type: Integer

Overrides

TfrxArray.Exchange(Integer,Integer)
See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxExtendedObjectList.GetObject(Integer) Method

Summary

Represents method GetObject(Integer).

Namespace: frxStorage
Syntax
Delphi
private
 function GetObject(Index: Integer): TObject;

Parameters

Index
Type: Integer

Return Value

Type: TObject

See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxExtendedObjectList.InsertObject(Integer,Extended,TObject) Method

Summary

Represents method InsertObject(Integer,Extended,TObject).

Namespace: frxStorage
Syntax
Delphi
public
 procedure InsertObject(Index: Integer; Value: Extended; aObject: TObject);

Parameters

Index
Type: Integer

Value
Type: Extended

aObject
Type: TObject

See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxExtendedObjectList.SetNewCapacity(Integer) Method

Summary

Represents method SetNewCapacity(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetNewCapacity(Value: Integer); override;

Parameters

Value
Type: Integer

Overrides

TfrxExtArray.SetNewCapacity(Integer)
See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxExtendedObjectList.SetObject(Integer,TObject) Method

Summary

Represents method SetObject(Integer,TObject).

Namespace: frxStorage
Syntax
Delphi
private
 procedure SetObject(Index: Integer; const Value: TObject);

Parameters

Index
Type: Integer

Value
Type: TObject

See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxExtendedObjectList.SortList Method

Summary

Represents method SortList.

Namespace: frxStorage
Syntax
Delphi
public
 procedure SortList;
See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxExtendedObjectList Fields

Fields
Name | Description
FFreeObjects | Represents field FFreeObjects.
FObjectList | Represents field FObjectList.
Top


TfrxExtendedObjectList.FFreeObjects Field

Summary

Represents field FFreeObjects.

Namespace: frxStorage
Syntax
Delphi
private
 FFreeObjects: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxExtendedObjectList.FObjectList Field

Summary

Represents field FObjectList.

Namespace: frxStorage
Syntax
Delphi
private
 FObjectList: array of TObject;

Field Value

Type: array of TObject

See Also

Reference

  • TfrxExtendedObjectList
  • frxStorage


TfrxIntArray Class

Summary

Represents type TfrxIntArray.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TfrxArray
frxStorage.TfrxBaseArray
frxStorage.TfrxIntArrayBase
frxStorage.TfrxIntArray
Syntax
Delphi
type
 TfrxIntArray = class(TfrxIntArrayBase)
 end;

The TfrxIntArray type exposes the following members.

Properties
Show:
Name | Description
Count | Represents property Count. (Inherited from TfrxArray.)
ItemData[Integer] | Represents property ItemData[Integer]. (Inherited from TfrxArray.)
ItemSize | Represents property ItemSize. (Inherited from TfrxArray.)
Items[Integer] | Represents property Items[Integer]. (Inherited from TfrxIntArrayBase.)
Zero | Represents property Zero. (Inherited from TfrxArray.)
Top
Methods
Show:
Name | Description
Append(Integer) | Represents method Append(Integer). (Inherited from TfrxIntArrayBase.)
Clear | Represents method Clear. (Overrides TfrxArray.Clear.)
Delete(Integer) | Represents method Delete(Integer). (Inherited from TfrxArray.)
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer). (Inherited from TfrxArray.)
GetCount | Represents method GetCount. (Overrides TfrxArray.GetCount.)
GetItem(Integer) | Represents method GetItem(Integer). (Overrides TfrxIntArrayBase.GetItem(Integer).)
GetItemData(Integer) | Represents method GetItemData(Integer). (Overrides TfrxArray.GetItemData(Integer).)
GetItemSize | Represents method GetItemSize. (Overrides TfrxArray.GetItemSize.)
GetZero | Represents method GetZero. (Overrides TfrxArray.GetZero.)
Grow | Represents method Grow. (Inherited from TfrxBaseArray.)
Insert(Integer,Integer) | Represents method Insert(Integer,Integer). (Inherited from TfrxIntArrayBase.)
ResetItems(Integer,Integer) | Represents method ResetItems(Integer,Integer). (Inherited from TfrxArray.)
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxArray.SetCount(Integer).)
SetItem(Integer,Integer) | Represents method SetItem(Integer,Integer). (Overrides TfrxIntArrayBase.SetItem(Integer,Integer).)
SetNewCapacity(Integer) | Represents method SetNewCapacity(Integer). (Overrides TfrxBaseArray.SetNewCapacity(Integer).)
SetZero(Boolean) | Represents method SetZero(Boolean). (Overrides TfrxArray.SetZero(Boolean).)
Sort(TSimpleCompareFunction,Integer,Integer) | Represents method Sort(TSimpleCompareFunction,Integer,Integer). (Inherited from TfrxArray.)
VerifyIndex(Integer) | Represents method VerifyIndex(Integer). (Inherited from TfrxArray.)
Top
Fields
Show:
Name | Description
FArray | Represents field FArray.
FCapacity | Represents field FCapacity. (Inherited from TfrxBaseArray.)
FCount | Represents field FCount. (Inherited from TfrxBaseArray.)
FSorted | Represents field FSorted. (Inherited from TfrxBaseArray.)
FZero | Represents field FZero.
Top
See Also

Reference

  • frxStorage


TfrxIntArray Methods

Methods
Name | Description
GetItem(Integer) | Represents method GetItem(Integer). (Overrides TfrxIntArrayBase.GetItem(Integer).)
GetItemData(Integer) | Represents method GetItemData(Integer). (Overrides TfrxArray.GetItemData(Integer).)
GetZero | Represents method GetZero. (Overrides TfrxArray.GetZero.)
SetItem(Integer,Integer) | Represents method SetItem(Integer,Integer). (Overrides TfrxIntArrayBase.SetItem(Integer,Integer).)
SetNewCapacity(Integer) | Represents method SetNewCapacity(Integer). (Overrides TfrxBaseArray.SetNewCapacity(Integer).)
SetZero(Boolean) | Represents method SetZero(Boolean). (Overrides TfrxArray.SetZero(Boolean).)
Top


TfrxIntArray.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItem(Index: Integer): Integer; override;

Parameters

Index
Type: Integer

Return Value

Type: Integer

Overrides

TfrxIntArrayBase.GetItem(Integer)
See Also

Reference

  • TfrxIntArray
  • frxStorage


TfrxIntArray.GetItemData(Integer) Method

Summary

Represents method GetItemData(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItemData(Index: Integer): Pointer; override;

Parameters

Index
Type: Integer

Return Value

Type: Pointer

Overrides

TfrxArray.GetItemData(Integer)
See Also

Reference

  • TfrxIntArray
  • frxStorage


TfrxIntArray.GetZero Method

Summary

Represents method GetZero.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetZero: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxArray.GetZero
See Also

Reference

  • TfrxIntArray
  • frxStorage


TfrxIntArray.SetItem(Integer,Integer) Method

Summary

Represents method SetItem(Integer,Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItem(Index: Integer; Value: Integer); override;

Parameters

Index
Type: Integer

Value
Type: Integer

Overrides

TfrxIntArrayBase.SetItem(Integer,Integer)
See Also

Reference

  • TfrxIntArray
  • frxStorage


TfrxIntArray.SetNewCapacity(Integer) Method

Summary

Represents method SetNewCapacity(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetNewCapacity(Value: Integer); override;

Parameters

Value
Type: Integer

Overrides

TfrxBaseArray.SetNewCapacity(Integer)
See Also

Reference

  • TfrxIntArray
  • frxStorage


TfrxIntArray.SetZero(Boolean) Method

Summary

Represents method SetZero(Boolean).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetZero(f: Boolean); override;

Parameters

f
Type: Boolean

Overrides

TfrxArray.SetZero(Boolean)
See Also

Reference

  • TfrxIntArray
  • frxStorage


TfrxIntArray Fields

Fields
Name | Description
FArray | Represents field FArray.
FZero | Represents field FZero.
Top


TfrxIntArray.FArray Field

Summary

Represents field FArray.

Namespace: frxStorage
Syntax
Delphi
private
 FArray: array of Integer;

Field Value

Type: array of Integer

See Also

Reference

  • TfrxIntArray
  • frxStorage


TfrxIntArray.FZero Field

Summary

Represents field FZero.

Namespace: frxStorage
Syntax
Delphi
private
 FZero: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxIntArray
  • frxStorage


TfrxIntArrayBase Class

Summary

Represents type TfrxIntArrayBase.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TfrxArray
frxStorage.TfrxBaseArray
frxStorage.TfrxIntArrayBase
frxStorage.TfrxCachedIntArray
frxStorage.TfrxIntArray
Syntax
Delphi
type
 TfrxIntArrayBase = class(TfrxBaseArray)
 end;

The TfrxIntArrayBase type exposes the following members.

Properties
Show:
Name | Description
Count | Represents property Count. (Inherited from TfrxArray.)
ItemData[Integer] | Represents property ItemData[Integer]. (Inherited from TfrxArray.)
ItemSize | Represents property ItemSize. (Inherited from TfrxArray.)
Items[Integer] | Represents property Items[Integer].
Zero | Represents property Zero. (Inherited from TfrxArray.)
Top
Methods
Show:
Name | Description
Append(Integer) | Represents method Append(Integer).
Clear | Represents method Clear. (Overrides TfrxArray.Clear.)
Delete(Integer) | Represents method Delete(Integer). (Inherited from TfrxArray.)
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer). (Inherited from TfrxArray.)
GetCount | Represents method GetCount. (Overrides TfrxArray.GetCount.)
GetItem(Integer) | Represents method GetItem(Integer).
GetItemData(Integer) | Represents method GetItemData(Integer). (Inherited from TfrxArray.)
GetItemSize | Represents method GetItemSize. (Overrides TfrxArray.GetItemSize.)
GetZero | Represents method GetZero. (Inherited from TfrxArray.)
Grow | Represents method Grow. (Inherited from TfrxBaseArray.)
Insert(Integer,Integer) | Represents method Insert(Integer,Integer).
ResetItems(Integer,Integer) | Represents method ResetItems(Integer,Integer). (Inherited from TfrxArray.)
SetCount(Integer) | Represents method SetCount(Integer). (Overrides TfrxArray.SetCount(Integer).)
SetItem(Integer,Integer) | Represents method SetItem(Integer,Integer).
SetNewCapacity(Integer) | Represents method SetNewCapacity(Integer). (Inherited from TfrxBaseArray.)
SetZero(Boolean) | Represents method SetZero(Boolean). (Inherited from TfrxArray.)
Sort(TSimpleCompareFunction,Integer,Integer) | Represents method Sort(TSimpleCompareFunction,Integer,Integer). (Inherited from TfrxArray.)
VerifyIndex(Integer) | Represents method VerifyIndex(Integer). (Inherited from TfrxArray.)
Top
Fields
Show:
Name | Description
FCapacity | Represents field FCapacity. (Inherited from TfrxBaseArray.)
FCount | Represents field FCount. (Inherited from TfrxBaseArray.)
FSorted | Represents field FSorted. (Inherited from TfrxBaseArray.)
Top
See Also

Reference

  • frxStorage


TfrxIntArrayBase Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxIntArrayBase.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxStorage
Syntax
Delphi
public
 property Items[Index: Integer]: Integer read GetItem write SetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: Integer

See Also

Reference

  • TfrxIntArrayBase
  • frxStorage


TfrxIntArrayBase Methods

Methods
Name | Description
Append(Integer) | Represents method Append(Integer).
GetItem(Integer) | Represents method GetItem(Integer).
GetItemSize | Represents method GetItemSize. (Overrides TfrxArray.GetItemSize.)
Insert(Integer,Integer) | Represents method Insert(Integer,Integer).
SetItem(Integer,Integer) | Represents method SetItem(Integer,Integer).
Top


TfrxIntArrayBase.Append(Integer) Method

Summary

Represents method Append(Integer).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Append(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxIntArrayBase
  • frxStorage


TfrxIntArrayBase.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItem(Index: Integer): Integer; virtual; abstract;

Parameters

Index
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TfrxIntArrayBase
  • frxStorage


TfrxIntArrayBase.GetItemSize Method

Summary

Represents method GetItemSize.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItemSize: Integer; override;

Return Value

Type: Integer

Overrides

TfrxArray.GetItemSize
See Also

Reference

  • TfrxIntArrayBase
  • frxStorage


TfrxIntArrayBase.Insert(Integer,Integer) Method

Summary

Represents method Insert(Integer,Integer).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Insert(Index: Integer; Value: Integer);

Parameters

Index
Type: Integer

Value
Type: Integer

See Also

Reference

  • TfrxIntArrayBase
  • frxStorage


TfrxIntArrayBase.SetItem(Integer,Integer) Method

Summary

Represents method SetItem(Integer,Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItem(Index: Integer; Value: Integer); virtual; abstract;

Parameters

Index
Type: Integer

Value
Type: Integer

See Also

Reference

  • TfrxIntArrayBase
  • frxStorage


THashTable Class

Summary

Represents type THashTable.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.THashTable
frxStorage.TListHashTable
Syntax
Delphi
type
 THashTable = class
 end;

The THashTable type exposes the following members.

Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
GetValue(Integer) | Represents method GetValue(Integer).
SelfTest(Integer,Integer) | Represents method SelfTest(Integer,Integer).
SetValue(Integer,Pointer) | Represents method SetValue(Integer,Pointer).
SetValueInternal(Integer,Pointer) | Represents method SetValueInternal(Integer,Pointer).
Top
See Also

Reference

  • frxStorage


THashTable Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


THashTable.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxStorage
Syntax
Delphi
public
 property Items[Key: Integer]: Pointer read GetValue write SetValueInternal; default;

Parameters

Key
Type: Integer

Property Value

Type: Pointer

See Also

Reference

  • THashTable
  • frxStorage


THashTable Methods

Methods
Name | Description
GetValue(Integer) | Represents method GetValue(Integer).
SelfTest(Integer,Integer) | Represents method SelfTest(Integer,Integer).
SetValue(Integer,Pointer) | Represents method SetValue(Integer,Pointer).
SetValueInternal(Integer,Pointer) | Represents method SetValueInternal(Integer,Pointer).
Top


THashTable.GetValue(Integer) Method

Summary

Represents method GetValue(Integer).

Namespace: frxStorage
Syntax
Delphi
public
 function GetValue(Key: Integer): Pointer; virtual; abstract;

Parameters

Key
Type: Integer

Return Value

Type: Pointer

See Also

Reference

  • THashTable
  • frxStorage


THashTable.SelfTest(Integer,Integer) Method

Summary

Represents method SelfTest(Integer,Integer).

Namespace: frxStorage
Syntax
Delphi
public
 function SelfTest(RS, n: Integer): Boolean;

Parameters

RS
Type: Integer

n
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • THashTable
  • frxStorage


THashTable.SetValue(Integer,Pointer) Method

Summary

Represents method SetValue(Integer,Pointer).

Namespace: frxStorage
Syntax
Delphi
public
 function SetValue(Key: Integer; Value: Pointer): Pointer; virtual; abstract;

Parameters

Key
Type: Integer

Value
Type: Pointer

Return Value

Type: Pointer

See Also

Reference

  • THashTable
  • frxStorage


THashTable.SetValueInternal(Integer,Pointer) Method

Summary

Represents method SetValueInternal(Integer,Pointer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetValueInternal(Key:Integer; Value: Pointer);

Parameters

Key
Type: Integer

Value
Type: Pointer

See Also

Reference

  • THashTable
  • frxStorage


THexEncoder Class

Summary

Represents type THexEncoder.

Namespace: frxStorage
Inheritance Hierarchy
TStream
frxStorage.THexEncoder
Syntax
Delphi
type
 THexEncoder = class(TStream)
 end;

The THexEncoder type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream) | Initializes a new instance of the THexEncoder class.
Top
Methods
Show:
Name | Description
Read(Void,Longint) | Represents method Read(Void,Longint).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top
Fields
Show:
Name | Description
FOutput | Represents field FOutput.
Top
See Also

Reference

  • frxStorage


THexEncoder Constructors

Constructors
Name | Description
Create(TStream) | Initializes a new instance of the THexEncoder class.
Top


THexEncoder.Create(TStream) Constructor

Summary

Initializes a new instance of the THexEncoder class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(Output: TStream);

Parameters

Output
Type: TStream

See Also

Reference

  • THexEncoder
  • frxStorage


THexEncoder Methods

Methods
Name | Description
Read(Void,Longint) | Represents method Read(Void,Longint).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top


THexEncoder.Read(Void,Longint) Method

Summary

Represents method Read(Void,Longint).

Namespace: frxStorage
Syntax
Delphi
public
 function Read(var Buffer; Count: Longint): Longint; override;

Parameters

Buffer
Type: System.Void

Count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • THexEncoder
  • frxStorage


THexEncoder.Write(Void,Longint) Method

Summary

Represents method Write(Void,Longint).

Namespace: frxStorage
Syntax
Delphi
public
 function Write(const Buffer; Count: Longint): Longint; override;

Parameters

Buffer
Type: System.Void

Count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • THexEncoder
  • frxStorage


THexEncoder Fields

Fields
Name | Description
FOutput | Represents field FOutput.
Top


THexEncoder.FOutput Field

Summary

Represents field FOutput.

Namespace: frxStorage
Syntax
Delphi
private
 FOutput: TStream;

Field Value

Type: TStream

See Also

Reference

  • THexEncoder
  • frxStorage


TLineSplitter Class

Summary

Represents type TLineSplitter.

Namespace: frxStorage
Inheritance Hierarchy
TStream
frxStorage.TLineSplitter
Syntax
Delphi
type
 TLineSplitter = class(TStream)
 end;

The TLineSplitter type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream,Integer,AnsiString) | Initializes a new instance of the TLineSplitter class.
Top
Methods
Show:
Name | Description
Read(Void,Longint) | Represents method Read(Void,Longint).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top
Fields
Show:
Name | Description
FLength | Represents field FLength.
FOutput | Represents field FOutput.
FSep | Represents field FSep.
FWritten | Represents field FWritten.
Top
See Also

Reference

  • frxStorage


TLineSplitter Constructors

Constructors
Name | Description
Create(TStream,Integer,AnsiString) | Initializes a new instance of the TLineSplitter class.
Top


TLineSplitter.Create(TStream,Integer,AnsiString) Constructor

Summary

Initializes a new instance of the TLineSplitter class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(Output: TStream; Length: Integer; Sep: AnsiString = #13#10);

Parameters

Output
Type: TStream

Length
Type: Integer

Sep
Type: AnsiString

See Also

Reference

  • TLineSplitter
  • frxStorage


TLineSplitter Methods

Methods
Name | Description
Read(Void,Longint) | Represents method Read(Void,Longint).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top


TLineSplitter.Read(Void,Longint) Method

Summary

Represents method Read(Void,Longint).

Namespace: frxStorage
Syntax
Delphi
public
 function Read(var Buffer; Count: Longint): Longint; override;

Parameters

Buffer
Type: System.Void

Count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TLineSplitter
  • frxStorage


TLineSplitter.Write(Void,Longint) Method

Summary

Represents method Write(Void,Longint).

Namespace: frxStorage
Syntax
Delphi
public
 function Write(const Buffer; Count: Longint): Longint; override;

Parameters

Buffer
Type: System.Void

Count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TLineSplitter
  • frxStorage


TLineSplitter Fields

Fields
Name | Description
FLength | Represents field FLength.
FOutput | Represents field FOutput.
FSep | Represents field FSep.
FWritten | Represents field FWritten.
Top


TLineSplitter.FLength Field

Summary

Represents field FLength.

Namespace: frxStorage
Syntax
Delphi
private
 FLength: Integer;

Field Value

Type: Integer

See Also

Reference

  • TLineSplitter
  • frxStorage


TLineSplitter.FOutput Field

Summary

Represents field FOutput.

Namespace: frxStorage
Syntax
Delphi
private
 FOutput: TStream;

Field Value

Type: TStream

See Also

Reference

  • TLineSplitter
  • frxStorage


TLineSplitter.FSep Field

Summary

Represents field FSep.

Namespace: frxStorage
Syntax
Delphi
private
 FSep: AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TLineSplitter
  • frxStorage


TLineSplitter.FWritten Field

Summary

Represents field FWritten.

Namespace: frxStorage
Syntax
Delphi
private
 FWritten: Integer;

Field Value

Type: Integer

See Also

Reference

  • TLineSplitter
  • frxStorage


TListBaseHashTable Class

Summary

Represents type TListBaseHashTable.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TListBaseHashTable
frxStorage.TListStreamHashTable
frxStorage.TListStringHashTable
Syntax
Delphi
type
 TListBaseHashTable = class
 end;

The TListBaseHashTable type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TListBaseHashTable class.
Destroy | Represents the destructor of the TListBaseHashTable class.
Top
Fields
Show:
Name | Description
ListKeys | Represents field ListKeys.
Top
See Also

Reference

  • frxStorage


TListBaseHashTable Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TListBaseHashTable class.
Destroy | Represents the destructor of the TListBaseHashTable class.
Top


TListBaseHashTable.Create Constructor

Summary

Initializes a new instance of the TListBaseHashTable class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TListBaseHashTable
  • frxStorage


TListBaseHashTable.Destroy Destructor

Summary

Represents the destructor of the TListBaseHashTable class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TListBaseHashTable
  • frxStorage


TListBaseHashTable Fields

Fields
Name | Description
ListKeys | Represents field ListKeys.
Top


TListBaseHashTable.ListKeys Field

Summary

Represents field ListKeys.

Namespace: frxStorage
Syntax
Delphi
public
 ListKeys: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TListBaseHashTable
  • frxStorage


TListCache Class

Summary

Represents type TListCache.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TListCache
Syntax
Delphi
type
 TListCache = class
 end;

The TListCache type exposes the following members.

Constructors
Show:
Name | Description
Create | Overloaded. Initializes a new instance of the TListCache class.
Create(string,string,Integer) | Overloaded. Initializes a new instance of the TListCache class.
Create(TLcCreateParams) | Overloaded. Initializes a new instance of the TListCache class.
Destroy | Represents the destructor of the TListCache class.
Top
Properties
Show:
Name | Description
Count | Represents property Count.
Objects[Integer] | Represents property Objects[Integer].
Protect | Represents property Protect.
StaticSize | Represents property StaticSize.
UpdateWhenUnload | Represents property UpdateWhenUnload.
Top
Methods
Show:
Name | Description
Add(TObject) | Represents method Add(TObject).
Clear | Represents method Clear.
ClearQueue | Represents method ClearQueue.
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
First | Represents method First.
GetObject(Integer) | Represents method GetObject(Integer).
GetObjectsCount | Represents method GetObjectsCount.
Initialize(TLcCreateParams) | Represents method Initialize(TLcCreateParams).
IsCaching | Represents method IsCaching.
Last | Represents method Last.
PushObject(TObject,Integer) | Represents method PushObject(TObject,Integer).
SetObject(Integer,TObject) | Represents method SetObject(Integer,TObject).
SetObjectsCount(Integer) | Represents method SetObjectsCount(Integer).
UnloadObject(TObject,Integer) | Represents method UnloadObject(TObject,Integer).
Top
Fields
Show:
Name | Description
FCacheFile | Represents field FCacheFile.
FCacheQueue | Represents field FCacheQueue.
FCacheStream | Represents field FCacheStream.
FObjects | Represents field FObjects.
FObjectsStream | Represents field FObjectsStream.
FObjFile | Represents field FObjFile.
FProtect | Represents field FProtect.
FStaticSize | Represents field FStaticSize.
FUpdate | Represents field FUpdate.
ReadObj | Represents field ReadObj.
WriteObj | Represents field WriteObj.
Top
See Also

Reference

  • frxStorage


TListCache Constructors

Constructors
Name | Description
Create | Overloaded. Initializes a new instance of the TListCache class.
Create(string,string,Integer) | Overloaded. Initializes a new instance of the TListCache class.
Create(TLcCreateParams) | Overloaded. Initializes a new instance of the TListCache class.
Destroy | Represents the destructor of the TListCache class.
Top


TListCache.Create Constructor

Summary

Initializes a new instance of the TListCache class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create; overload;
See Also

Reference

  • TListCache
  • frxStorage


TListCache.Create(string,string,Integer) Constructor

Summary

Initializes a new instance of the TListCache class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(CacheFile, ObjFile: string; QueueSize: Integer = 4); overload;

Parameters

CacheFile
Type: string

ObjFile
Type: string

QueueSize
Type: Integer

See Also

Reference

  • TListCache
  • frxStorage


TListCache.Create(TLcCreateParams) Constructor

Summary

Initializes a new instance of the TListCache class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(Params: TLcCreateParams); overload;

Parameters

Params
Type: TLcCreateParams

See Also

Reference

  • TListCache
  • frxStorage


TListCache.Destroy Destructor

Summary

Represents the destructor of the TListCache class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TListCache
  • frxStorage


TListCache Properties

Properties
Name | Description
Count | Represents property Count.
Objects[Integer] | Represents property Objects[Integer].
Protect | Represents property Protect.
StaticSize | Represents property StaticSize.
UpdateWhenUnload | Represents property UpdateWhenUnload.
Top


TListCache.Count Property

Summary

Represents property Count.

Namespace: frxStorage
Syntax
Delphi
public
 property Count: Integer read GetObjectsCount write SetObjectsCount;

Property Value

Type: Integer

See Also

Reference

  • TListCache
  • frxStorage


TListCache.Objects[Integer] Property

Summary

Represents property Objects[Integer].

Namespace: frxStorage
Syntax
Delphi
public
 property Objects[Index: Integer]: TObject read GetObject write SetObject; default;

Parameters

Index
Type: Integer

Property Value

Type: TObject

See Also

Reference

  • TListCache
  • frxStorage


TListCache.Protect Property

Summary

Represents property Protect.

Namespace: frxStorage
Syntax
Delphi
public
 property Protect: Boolean read FProtect write FProtect;

Property Value

Type: Boolean

See Also

Reference

  • TListCache
  • frxStorage


TListCache.StaticSize Property

Summary

Represents property StaticSize.

Namespace: frxStorage
Syntax
Delphi
public
 property StaticSize: Boolean read FStaticSize write FStaticSize;

Property Value

Type: Boolean

See Also

Reference

  • TListCache
  • frxStorage


TListCache.UpdateWhenUnload Property

Summary

Represents property UpdateWhenUnload.

Namespace: frxStorage
Syntax
Delphi
public
 property UpdateWhenUnload: Boolean read FUpdate write FUpdate;

Property Value

Type: Boolean

See Also

Reference

  • TListCache
  • frxStorage


TListCache Methods

Methods
Name | Description
Add(TObject) | Represents method Add(TObject).
Clear | Represents method Clear.
ClearQueue | Represents method ClearQueue.
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
First | Represents method First.
GetObject(Integer) | Represents method GetObject(Integer).
GetObjectsCount | Represents method GetObjectsCount.
Initialize(TLcCreateParams) | Represents method Initialize(TLcCreateParams).
IsCaching | Represents method IsCaching.
Last | Represents method Last.
PushObject(TObject,Integer) | Represents method PushObject(TObject,Integer).
SetObject(Integer,TObject) | Represents method SetObject(Integer,TObject).
SetObjectsCount(Integer) | Represents method SetObjectsCount(Integer).
UnloadObject(TObject,Integer) | Represents method UnloadObject(TObject,Integer).
Top


TListCache.Add(TObject) Method

Summary

Represents method Add(TObject).

Namespace: frxStorage
Syntax
Delphi
public
 function Add(Obj: TObject): Integer;

Parameters

Obj
Type: TObject

Return Value

Type: Integer

See Also

Reference

  • TListCache
  • frxStorage


TListCache.Clear Method

Summary

Represents method Clear.

Namespace: frxStorage
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TListCache
  • frxStorage


TListCache.ClearQueue Method

Summary

Represents method ClearQueue.

Namespace: frxStorage
Syntax
Delphi
protected
 procedure ClearQueue;
See Also

Reference

  • TListCache
  • frxStorage


TListCache.Exchange(Integer,Integer) Method

Summary

Represents method Exchange(Integer,Integer).

Namespace: frxStorage
Syntax
Delphi
public
 procedure Exchange(Index1, Index2: Integer);

Parameters

Index1
Type: Integer

Index2
Type: Integer

See Also

Reference

  • TListCache
  • frxStorage


TListCache.First Method

Summary

Represents method First.

Namespace: frxStorage
Syntax
Delphi
public
 function First: TObject;

Return Value

Type: TObject

See Also

Reference

  • TListCache
  • frxStorage


TListCache.GetObject(Integer) Method

Summary

Represents method GetObject(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetObject(Index: Integer): TObject;

Parameters

Index
Type: Integer

Return Value

Type: TObject

See Also

Reference

  • TListCache
  • frxStorage


TListCache.GetObjectsCount Method

Summary

Represents method GetObjectsCount.

Namespace: frxStorage
Syntax
Delphi
protected
 function GetObjectsCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TListCache
  • frxStorage


TListCache.Initialize(TLcCreateParams) Method

Summary

Represents method Initialize(TLcCreateParams).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure Initialize(Params: TLcCreateParams);

Parameters

Params
Type: TLcCreateParams

See Also

Reference

  • TListCache
  • frxStorage


TListCache.IsCaching Method

Summary

Represents method IsCaching.

Namespace: frxStorage
Syntax
Delphi
protected
 function IsCaching: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TListCache
  • frxStorage


TListCache.Last Method

Summary

Represents method Last.

Namespace: frxStorage
Syntax
Delphi
public
 function Last: TObject;

Return Value

Type: TObject

See Also

Reference

  • TListCache
  • frxStorage


TListCache.PushObject(TObject,Integer) Method

Summary

Represents method PushObject(TObject,Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure PushObject(Obj: TObject; Index: Integer);

Parameters

Obj
Type: TObject

Index
Type: Integer

See Also

Reference

  • TListCache
  • frxStorage


TListCache.SetObject(Integer,TObject) Method

Summary

Represents method SetObject(Integer,TObject).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetObject(Index: Integer; Obj: TObject);

Parameters

Index
Type: Integer

Obj
Type: TObject

See Also

Reference

  • TListCache
  • frxStorage


TListCache.SetObjectsCount(Integer) Method

Summary

Represents method SetObjectsCount(Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetObjectsCount(NewCount: Integer);

Parameters

NewCount
Type: Integer

See Also

Reference

  • TListCache
  • frxStorage


TListCache.UnloadObject(TObject,Integer) Method

Summary

Represents method UnloadObject(TObject,Integer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure UnloadObject(Obj: TObject; Index: Integer);

Parameters

Obj
Type: TObject

Index
Type: Integer

See Also

Reference

  • TListCache
  • frxStorage


TListCache Fields

Fields
Name | Description
FCacheFile | Represents field FCacheFile.
FCacheQueue | Represents field FCacheQueue.
FCacheStream | Represents field FCacheStream.
FObjects | Represents field FObjects.
FObjectsStream | Represents field FObjectsStream.
FObjFile | Represents field FObjFile.
FProtect | Represents field FProtect.
FStaticSize | Represents field FStaticSize.
FUpdate | Represents field FUpdate.
ReadObj | Represents field ReadObj.
WriteObj | Represents field WriteObj.
Top


TListCache.FCacheFile Field

Summary

Represents field FCacheFile.

Namespace: frxStorage
Syntax
Delphi
private
 FCacheFile: string;

Field Value

Type: string

See Also

Reference

  • TListCache
  • frxStorage


TListCache.FCacheQueue Field

Summary

Represents field FCacheQueue.

Namespace: frxStorage
Syntax
Delphi
private
 FCacheQueue: array of TLcLoadedObject;

Field Value

Type: array of TLcLoadedObject

See Also

Reference

  • TListCache
  • frxStorage


TListCache.FCacheStream Field

Summary

Represents field FCacheStream.

Namespace: frxStorage
Syntax
Delphi
private
 FCacheStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TListCache
  • frxStorage


TListCache.FObjects Field

Summary

Represents field FObjects.

Namespace: frxStorage
Syntax
Delphi
private
 FObjects: TObjList;

Field Value

Type: TObjList

See Also

Reference

  • TListCache
  • frxStorage


TListCache.FObjectsStream Field

Summary

Represents field FObjectsStream.

Namespace: frxStorage
Syntax
Delphi
private
 FObjectsStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TListCache
  • frxStorage


TListCache.FObjFile Field

Summary

Represents field FObjFile.

Namespace: frxStorage
Syntax
Delphi
private
 FObjFile: string;

Field Value

Type: string

See Also

Reference

  • TListCache
  • frxStorage


TListCache.FProtect Field

Summary

Represents field FProtect.

Namespace: frxStorage
Syntax
Delphi
private
 FProtect: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TListCache
  • frxStorage


TListCache.FStaticSize Field

Summary

Represents field FStaticSize.

Namespace: frxStorage
Syntax
Delphi
private
 FStaticSize: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TListCache
  • frxStorage


TListCache.FUpdate Field

Summary

Represents field FUpdate.

Namespace: frxStorage
Syntax
Delphi
private
 FUpdate: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TListCache
  • frxStorage


TListCache.ReadObj Field

Summary

Represents field ReadObj.

Namespace: frxStorage
Syntax
Delphi
public
 ReadObj: TLcReadObj;

Field Value

Type: TLcReadObj

See Also

Reference

  • TListCache
  • frxStorage


TListCache.WriteObj Field

Summary

Represents field WriteObj.

Namespace: frxStorage
Syntax
Delphi
public
 WriteObj: TLcWriteObj;

Field Value

Type: TLcWriteObj

See Also

Reference

  • TListCache
  • frxStorage


TListHashTable Class

Summary

Represents type TListHashTable.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.THashTable
frxStorage.TListHashTable
Syntax
Delphi
type
 TListHashTable = class(THashTable)
 end;

The TListHashTable type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TListHashTable class.
Destroy | Represents the destructor of the TListHashTable class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer]. (Inherited from THashTable.)
Top
Methods
Show:
Name | Description
CreateEntry(Integer) | Represents method CreateEntry(Integer).
GetValue(Integer) | Represents method GetValue(Integer). (Overrides THashTable.GetValue(Integer).)
SelfTest(Integer,Integer) | Represents method SelfTest(Integer,Integer). (Inherited from THashTable.)
SetValue(Integer,Pointer) | Represents method SetValue(Integer,Pointer). (Overrides THashTable.SetValue(Integer,Pointer).)
SetValueInternal(Integer,Pointer) | Represents method SetValueInternal(Integer,Pointer). (Inherited from THashTable.)
Top
Fields
Show:
Name | Description
FBushes | Represents field FBushes.
FHeap | Represents field FHeap.
Top
See Also

Reference

  • frxStorage


TListHashTable Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TListHashTable class.
Destroy | Represents the destructor of the TListHashTable class.
Top


TListHashTable.Create Constructor

Summary

Initializes a new instance of the TListHashTable class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TListHashTable
  • frxStorage


TListHashTable.Destroy Destructor

Summary

Represents the destructor of the TListHashTable class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TListHashTable
  • frxStorage


TListHashTable Methods

Methods
Name | Description
CreateEntry(Integer) | Represents method CreateEntry(Integer).
GetValue(Integer) | Represents method GetValue(Integer). (Overrides THashTable.GetValue(Integer).)
SetValue(Integer,Pointer) | Represents method SetValue(Integer,Pointer). (Overrides THashTable.SetValue(Integer,Pointer).)
Top


TListHashTable.CreateEntry(Integer) Method

Summary

Represents method CreateEntry(Integer).

Namespace: frxStorage
Syntax
Delphi
private
 function CreateEntry(Key: Integer): PLhtEntry;

Parameters

Key
Type: Integer

Return Value

Type: PLhtEntry

See Also

Reference

  • TListHashTable
  • frxStorage


TListHashTable.GetValue(Integer) Method

Summary

Represents method GetValue(Integer).

Namespace: frxStorage
Syntax
Delphi
public
 function GetValue(Key: Integer): Pointer; override;

Parameters

Key
Type: Integer

Return Value

Type: Pointer

Overrides

THashTable.GetValue(Integer)
See Also

Reference

  • TListHashTable
  • frxStorage


TListHashTable.SetValue(Integer,Pointer) Method

Summary

Represents method SetValue(Integer,Pointer).

Namespace: frxStorage
Syntax
Delphi
public
 function SetValue(Key: Integer; Value: Pointer): Pointer; override;

Parameters

Key
Type: Integer

Value
Type: Pointer

Return Value

Type: Pointer

Overrides

THashTable.SetValue(Integer,Pointer)
See Also

Reference

  • TListHashTable
  • frxStorage


TListHashTable Fields

Fields
Name | Description
FBushes | Represents field FBushes.
FHeap | Represents field FHeap.
Top


TListHashTable.FBushes Field

Summary

Represents field FBushes.

Namespace: frxStorage
Syntax
Delphi
private
 FBushes: Pointer;

Field Value

Type: Pointer

See Also

Reference

  • TListHashTable
  • frxStorage


TListHashTable.FHeap Field

Summary

Represents field FHeap.

Namespace: frxStorage
Syntax
Delphi
private
 FHeap: THandle;

Field Value

Type: THandle

See Also

Reference

  • TListHashTable
  • frxStorage


TListStreamHashTable Class

Summary

Represents type TListStreamHashTable.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TListBaseHashTable
frxStorage.TListStreamHashTable
Syntax
Delphi
type
 TListStreamHashTable = class(TListBaseHashTable)
 end;

The TListStreamHashTable type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TListStreamHashTable class.
Destroy | Represents the destructor of the TListStreamHashTable class. (Overrides TListBaseHashTable.Destroy.)
Top
Methods
Show:
Name | Description
Clear | Represents method Clear.
GetValue(String) | Represents method GetValue(String).
SetValue(String,TStream) | Represents method SetValue(String,TStream).
Top
Fields
Show:
Name | Description
ListKeys | Represents field ListKeys. (Inherited from TListBaseHashTable.)
ListValues | Represents field ListValues.
Top
See Also

Reference

  • frxStorage


TListStreamHashTable Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TListStreamHashTable class.
Destroy | Represents the destructor of the TListStreamHashTable class. (Overrides TListBaseHashTable.Destroy.)
Top


TListStreamHashTable.Create Constructor

Summary

Initializes a new instance of the TListStreamHashTable class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TListStreamHashTable
  • frxStorage


TListStreamHashTable.Destroy Destructor

Summary

Represents the destructor of the TListStreamHashTable class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TListBaseHashTable.Destroy
See Also

Reference

  • TListStreamHashTable
  • frxStorage


TListStreamHashTable Methods

Methods
Name | Description
Clear | Represents method Clear.
GetValue(String) | Represents method GetValue(String).
SetValue(String,TStream) | Represents method SetValue(String,TStream).
Top


TListStreamHashTable.Clear Method

Summary

Represents method Clear.

Namespace: frxStorage
Syntax
Delphi
public
 procedure Clear();
See Also

Reference

  • TListStreamHashTable
  • frxStorage


TListStreamHashTable.GetValue(String) Method

Summary

Represents method GetValue(String).

Namespace: frxStorage
Syntax
Delphi
public
 function GetValue(Key: String): TStream;

Parameters

Key
Type: String

Return Value

Type: TStream

See Also

Reference

  • TListStreamHashTable
  • frxStorage


TListStreamHashTable.SetValue(String,TStream) Method

Summary

Represents method SetValue(String,TStream).

Namespace: frxStorage
Syntax
Delphi
public
 procedure SetValue(Key: String; Value: TStream);

Parameters

Key
Type: String

Value
Type: TStream

See Also

Reference

  • TListStreamHashTable
  • frxStorage


TListStreamHashTable Fields

Fields
Name | Description
ListValues | Represents field ListValues.
Top


TListStreamHashTable.ListValues Field

Summary

Represents field ListValues.

Namespace: frxStorage
Syntax
Delphi
public
 ListValues :array of TStream;

Field Value

Type: array of TStream

See Also

Reference

  • TListStreamHashTable
  • frxStorage


TListStringHashTable Class

Summary

Represents type TListStringHashTable.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TListBaseHashTable
frxStorage.TListStringHashTable
Syntax
Delphi
type
 TListStringHashTable = class(TListBaseHashTable)
 end;

The TListStringHashTable type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TListStringHashTable class.
Destroy | Represents the destructor of the TListStringHashTable class. (Overrides TListBaseHashTable.Destroy.)
Top
Methods
Show:
Name | Description
Clear | Represents method Clear.
GetValue(String) | Represents method GetValue(String).
SetValue(String,String) | Represents method SetValue(String,String).
Top
Fields
Show:
Name | Description
ListKeys | Represents field ListKeys. (Inherited from TListBaseHashTable.)
ListValues | Represents field ListValues.
Top
See Also

Reference

  • frxStorage


TListStringHashTable Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TListStringHashTable class.
Destroy | Represents the destructor of the TListStringHashTable class. (Overrides TListBaseHashTable.Destroy.)
Top


TListStringHashTable.Create Constructor

Summary

Initializes a new instance of the TListStringHashTable class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TListStringHashTable
  • frxStorage


TListStringHashTable.Destroy Destructor

Summary

Represents the destructor of the TListStringHashTable class.

Namespace: frxStorage
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TListBaseHashTable.Destroy
See Also

Reference

  • TListStringHashTable
  • frxStorage


TListStringHashTable Methods

Methods
Name | Description
Clear | Represents method Clear.
GetValue(String) | Represents method GetValue(String).
SetValue(String,String) | Represents method SetValue(String,String).
Top


TListStringHashTable.Clear Method

Summary

Represents method Clear.

Namespace: frxStorage
Syntax
Delphi
public
 procedure Clear();
See Also

Reference

  • TListStringHashTable
  • frxStorage


TListStringHashTable.GetValue(String) Method

Summary

Represents method GetValue(String).

Namespace: frxStorage
Syntax
Delphi
public
 function GetValue(Key: String): String;

Parameters

Key
Type: String

Return Value

Type: String

See Also

Reference

  • TListStringHashTable
  • frxStorage


TListStringHashTable.SetValue(String,String) Method

Summary

Represents method SetValue(String,String).

Namespace: frxStorage
Syntax
Delphi
public
 procedure SetValue(Key: String; Value: String);

Parameters

Key
Type: String

Value
Type: String

See Also

Reference

  • TListStringHashTable
  • frxStorage


TListStringHashTable Fields

Fields
Name | Description
ListValues | Represents field ListValues.
Top


TListStringHashTable.ListValues Field

Summary

Represents field ListValues.

Namespace: frxStorage
Syntax
Delphi
public
 ListValues :TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TListStringHashTable
  • frxStorage


TMap Class

Summary

Represents type TMap.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TMap
frxStorage.TAVLTree
frxStorage.TOrderedMap
Syntax
Delphi
type
 TMap = class
 end;

The TMap type exposes the following members.

Properties
Show:
Name | Description
Exists[Pointer] | Represents property Exists[Pointer].
Items[Pointer] | Represents property Items[Pointer].
Top
Methods
Show:
Name | Description
GetItem(Pointer) | Represents method GetItem(Pointer).
ItemExists(Pointer) | Represents method ItemExists(Pointer).
SetItem(Pointer,Pointer) | Represents method SetItem(Pointer,Pointer).
SetItemExistence(Pointer,Boolean) | Represents method SetItemExistence(Pointer,Boolean).
Top
See Also

Reference

  • frxStorage


TMap Properties

Properties
Name | Description
Exists[Pointer] | Represents property Exists[Pointer].
Items[Pointer] | Represents property Items[Pointer].
Top


TMap.Exists[Pointer] Property

Summary

Represents property Exists[Pointer].

Namespace: frxStorage
Syntax
Delphi
public
 property Exists[Key: Pointer]: Boolean read ItemExists write SetItemExistence;

Parameters

Key
Type: Pointer

Property Value

Type: Boolean

See Also

Reference

  • TMap
  • frxStorage


TMap.Items[Pointer] Property

Summary

Represents property Items[Pointer].

Namespace: frxStorage
Syntax
Delphi
public
 property Items[Key: Pointer]: Pointer read GetItem write SetItem; default;

Parameters

Key
Type: Pointer

Property Value

Type: Pointer

See Also

Reference

  • TMap
  • frxStorage


TMap Methods

Methods
Name | Description
GetItem(Pointer) | Represents method GetItem(Pointer).
ItemExists(Pointer) | Represents method ItemExists(Pointer).
SetItem(Pointer,Pointer) | Represents method SetItem(Pointer,Pointer).
SetItemExistence(Pointer,Boolean) | Represents method SetItemExistence(Pointer,Boolean).
Top


TMap.GetItem(Pointer) Method

Summary

Represents method GetItem(Pointer).

Namespace: frxStorage
Syntax
Delphi
protected
 function GetItem(Key: Pointer): Pointer; virtual; abstract;

Parameters

Key
Type: Pointer

Return Value

Type: Pointer

See Also

Reference

  • TMap
  • frxStorage


TMap.ItemExists(Pointer) Method

Summary

Represents method ItemExists(Pointer).

Namespace: frxStorage
Syntax
Delphi
protected
 function ItemExists(Key: Pointer): Boolean; virtual; abstract;

Parameters

Key
Type: Pointer

Return Value

Type: Boolean

See Also

Reference

  • TMap
  • frxStorage


TMap.SetItem(Pointer,Pointer) Method

Summary

Represents method SetItem(Pointer,Pointer).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItem(Key: Pointer; Value: Pointer); virtual; abstract;

Parameters

Key
Type: Pointer

Value
Type: Pointer

See Also

Reference

  • TMap
  • frxStorage


TMap.SetItemExistence(Pointer,Boolean) Method

Summary

Represents method SetItemExistence(Pointer,Boolean).

Namespace: frxStorage
Syntax
Delphi
protected
 procedure SetItemExistence(Key: Pointer; b: Boolean); virtual; abstract;

Parameters

Key
Type: Pointer

b
Type: Boolean

See Also

Reference

  • TMap
  • frxStorage


TObjList Class

Summary

Represents type TObjList.

Namespace: frxStorage
Inheritance Hierarchy
TList
frxStorage.TObjList
Syntax
Delphi
type
 TObjList = class(TList)
 end;

The TObjList type exposes the following members.

Methods
Show:
Name | Description
Clear | Represents method Clear.
Top
See Also

Reference

  • frxStorage


TObjList Methods

Methods
Name | Description
Clear | Represents method Clear.
Top


TObjList.Clear Method

Summary

Represents method Clear.

Namespace: frxStorage
Syntax
Delphi
published
 procedure Clear; override;
See Also

Reference

  • TObjList
  • frxStorage


TOrderedMap Class

Summary

Represents type TOrderedMap.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TMap
frxStorage.TOrderedMap
frxStorage.TBTree
Syntax
Delphi
type
 TOrderedMap = class(TMap)
 end;

The TOrderedMap type exposes the following members.

Properties
Show:
Name | Description
Exists[Pointer] | Represents property Exists[Pointer]. (Inherited from TMap.)
Items[Pointer] | Represents property Items[Pointer]. (Inherited from TMap.)
Top
Methods
Show:
Name | Description
GetItem(Pointer) | Represents method GetItem(Pointer). (Inherited from TMap.)
GetKeysAndValues(TList,TList) | Represents method GetKeysAndValues(TList,TList).
ItemExists(Pointer) | Represents method ItemExists(Pointer). (Inherited from TMap.)
SetItem(Pointer,Pointer) | Represents method SetItem(Pointer,Pointer). (Inherited from TMap.)
SetItemExistence(Pointer,Boolean) | Represents method SetItemExistence(Pointer,Boolean). (Inherited from TMap.)
Top
See Also

Reference

  • frxStorage


TOrderedMap Methods

Methods
Name | Description
GetKeysAndValues(TList,TList) | Represents method GetKeysAndValues(TList,TList).
Top


TOrderedMap.GetKeysAndValues(TList,TList) Method

Summary

Represents method GetKeysAndValues(TList,TList).

Namespace: frxStorage
Syntax
Delphi
public
 procedure GetKeysAndValues(Keys, Values: TList); virtual; abstract;

Parameters

Keys
Type: TList

Values
Type: TList

See Also

Reference

  • TOrderedMap
  • frxStorage


TProxyStream Class

Summary

Represents type TProxyStream.

Namespace: frxStorage
Inheritance Hierarchy
TStream
frxStorage.TProxyStream
Syntax
Delphi
type
 TProxyStream = class(TStream)
 end;

The TProxyStream type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream,Longint,Longint) | Initializes a new instance of the TProxyStream class.
Top
Properties
Show:
Name | Description
BaseStream | Represents property BaseStream.
Offset | Represents property Offset.
Top
Methods
Show:
Name | Description
AdjustRange(Integer) | Represents method AdjustRange(Integer).
Init(TStream,Longint,Longint) | Represents method Init(TStream,Longint,Longint).
Read(Void,Longint) | Represents method Read(Void,Longint).
Seek(Longint,Word) | Represents method Seek(Longint,Word).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top
Fields
Show:
Name | Description
FOffset | Represents field FOffset.
FPos | Represents field FPos.
FSize | Represents field FSize.
FStream | Represents field FStream.
Top
See Also

Reference

  • frxStorage


TProxyStream Constructors

Constructors
Name | Description
Create(TStream,Longint,Longint) | Initializes a new instance of the TProxyStream class.
Top


TProxyStream.Create(TStream,Longint,Longint) Constructor

Summary

Initializes a new instance of the TProxyStream class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(Stream: TStream; Offset, Size: Longint);

Parameters

Stream
Type: TStream

Offset
Type: Longint

Size
Type: Longint

See Also

Reference

  • TProxyStream
  • frxStorage


TProxyStream Properties

Properties
Name | Description
BaseStream | Represents property BaseStream.
Offset | Represents property Offset.
Top


TProxyStream.BaseStream Property

Summary

Represents property BaseStream.

Namespace: frxStorage
Syntax
Delphi
public
 property BaseStream: TStream read FStream;

Property Value

Type: TStream

See Also

Reference

  • TProxyStream
  • frxStorage


TProxyStream.Offset Property

Summary

Represents property Offset.

Namespace: frxStorage
Syntax
Delphi
public
 property Offset: Longint read FOffset;

Property Value

Type: Longint

See Also

Reference

  • TProxyStream
  • frxStorage


TProxyStream Methods

Methods
Name | Description
AdjustRange(Integer) | Represents method AdjustRange(Integer).
Init(TStream,Longint,Longint) | Represents method Init(TStream,Longint,Longint).
Read(Void,Longint) | Represents method Read(Void,Longint).
Seek(Longint,Word) | Represents method Seek(Longint,Word).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top


TProxyStream.AdjustRange(Integer) Method

Summary

Represents method AdjustRange(Integer).

Namespace: frxStorage
Syntax
Delphi
private
 function AdjustRange(var Len: Integer): Boolean;

Parameters

Len
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TProxyStream
  • frxStorage


TProxyStream.Init(TStream,Longint,Longint) Method

Summary

Represents method Init(TStream,Longint,Longint).

Namespace: frxStorage
Syntax
Delphi
private
 procedure Init(Stream: TStream; Offset, Size: Longint);

Parameters

Stream
Type: TStream

Offset
Type: Longint

Size
Type: Longint

See Also

Reference

  • TProxyStream
  • frxStorage


TProxyStream.Read(Void,Longint) Method

Summary

Represents method Read(Void,Longint).

Namespace: frxStorage
Syntax
Delphi
public
 function Read(var Buffer; Count: Longint): Longint; override;

Parameters

Buffer
Type: System.Void

Count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TProxyStream
  • frxStorage


TProxyStream.Seek(Longint,Word) Method

Summary

Represents method Seek(Longint,Word).

Namespace: frxStorage
Syntax
Delphi
public
 function Seek(Offset: Longint; Origin: Word): Longint; override;

Parameters

Offset
Type: Longint

Origin
Type: Word

Return Value

Type: Longint

See Also

Reference

  • TProxyStream
  • frxStorage


TProxyStream.Write(Void,Longint) Method

Summary

Represents method Write(Void,Longint).

Namespace: frxStorage
Syntax
Delphi
public
 function Write(const Buffer; Count: Longint): Longint; override;

Parameters

Buffer
Type: System.Void

Count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TProxyStream
  • frxStorage


TProxyStream Fields

Fields
Name | Description
FOffset | Represents field FOffset.
FPos | Represents field FPos.
FSize | Represents field FSize.
FStream | Represents field FStream.
Top


TProxyStream.FOffset Field

Summary

Represents field FOffset.

Namespace: frxStorage
Syntax
Delphi
private
 FOffset: Longint;

Field Value

Type: Longint

See Also

Reference

  • TProxyStream
  • frxStorage


TProxyStream.FPos Field

Summary

Represents field FPos.

Namespace: frxStorage
Syntax
Delphi
private
 FPos: Longint;

Field Value

Type: Longint

See Also

Reference

  • TProxyStream
  • frxStorage


TProxyStream.FSize Field

Summary

Represents field FSize.

Namespace: frxStorage
Syntax
Delphi
private
 FSize: Longint;

Field Value

Type: Longint

See Also

Reference

  • TProxyStream
  • frxStorage


TProxyStream.FStream Field

Summary

Represents field FStream.

Namespace: frxStorage
Syntax
Delphi
private
 FStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TProxyStream
  • frxStorage


TStreamRW Class

Summary

Represents type TStreamRW.

Namespace: frxStorage
Inheritance Hierarchy
TObject
frxStorage.TStreamRW
Syntax
Delphi
type
 TStreamRW = class
 end;

The TStreamRW type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream,Boolean) | Initializes a new instance of the TStreamRW class.
Top
Methods
Show:
Name | Description
GetBoolType | Represents method GetBoolType.
GetExtType | Represents method GetExtType.
GetIntType | Represents method GetIntType.
GetStrType | Represents method GetStrType.
ReadBool | Represents method ReadBool.
ReadExt | Represents method ReadExt.
ReadInt | Represents method ReadInt.
ReadStr | Represents method ReadStr.
ReadType(Integer) | Represents method ReadType(Integer).
WriteBool(Boolean) | Represents method WriteBool(Boolean).
WriteExt(Extended) | Represents method WriteExt(Extended).
WriteInt(Integer) | Represents method WriteInt(Integer).
WriteStr(WideString) | Represents method WriteStr(WideString).
WriteType(Integer) | Represents method WriteType(Integer).
Top
Fields
Show:
Name | Description
FSecure | Represents field FSecure.
FStream | Represents field FStream.
Top
See Also

Reference

  • frxStorage


TStreamRW Constructors

Constructors
Name | Description
Create(TStream,Boolean) | Initializes a new instance of the TStreamRW class.
Top


TStreamRW.Create(TStream,Boolean) Constructor

Summary

Initializes a new instance of the TStreamRW class.

Namespace: frxStorage
Syntax
Delphi
public
 constructor Create(Stream: TStream; Secure: Boolean = False);

Parameters

Stream
Type: TStream

Secure
Type: Boolean

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW Methods

Methods
Name | Description
GetBoolType | Represents method GetBoolType.
GetExtType | Represents method GetExtType.
GetIntType | Represents method GetIntType.
GetStrType | Represents method GetStrType.
ReadBool | Represents method ReadBool.
ReadExt | Represents method ReadExt.
ReadInt | Represents method ReadInt.
ReadStr | Represents method ReadStr.
ReadType(Integer) | Represents method ReadType(Integer).
WriteBool(Boolean) | Represents method WriteBool(Boolean).
WriteExt(Extended) | Represents method WriteExt(Extended).
WriteInt(Integer) | Represents method WriteInt(Integer).
WriteStr(WideString) | Represents method WriteStr(WideString).
WriteType(Integer) | Represents method WriteType(Integer).
Top


TStreamRW.GetBoolType Method

Summary

Represents method GetBoolType.

Namespace: frxStorage
Syntax
Delphi
private
 function GetBoolType: Integer;

Return Value

Type: Integer

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.GetExtType Method

Summary

Represents method GetExtType.

Namespace: frxStorage
Syntax
Delphi
private
 function GetExtType: Integer;

Return Value

Type: Integer

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.GetIntType Method

Summary

Represents method GetIntType.

Namespace: frxStorage
Syntax
Delphi
private
 function GetIntType: Integer;

Return Value

Type: Integer

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.GetStrType Method

Summary

Represents method GetStrType.

Namespace: frxStorage
Syntax
Delphi
private
 function GetStrType: Integer;

Return Value

Type: Integer

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.ReadBool Method

Summary

Represents method ReadBool.

Namespace: frxStorage
Syntax
Delphi
public
 function ReadBool: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.ReadExt Method

Summary

Represents method ReadExt.

Namespace: frxStorage
Syntax
Delphi
public
 function ReadExt: Extended;

Return Value

Type: Extended

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.ReadInt Method

Summary

Represents method ReadInt.

Namespace: frxStorage
Syntax
Delphi
public
 function ReadInt: Integer;

Return Value

Type: Integer

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.ReadStr Method

Summary

Represents method ReadStr.

Namespace: frxStorage
Syntax
Delphi
public
 function ReadStr: WideString;

Return Value

Type: WideString

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.ReadType(Integer) Method

Summary

Represents method ReadType(Integer).

Namespace: frxStorage
Syntax
Delphi
private
 procedure ReadType(t: Integer);

Parameters

t
Type: Integer

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.WriteBool(Boolean) Method

Summary

Represents method WriteBool(Boolean).

Namespace: frxStorage
Syntax
Delphi
public
 procedure WriteBool(x: Boolean);

Parameters

x
Type: Boolean

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.WriteExt(Extended) Method

Summary

Represents method WriteExt(Extended).

Namespace: frxStorage
Syntax
Delphi
public
 procedure WriteExt(x: Extended);

Parameters

x
Type: Extended

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.WriteInt(Integer) Method

Summary

Represents method WriteInt(Integer).

Namespace: frxStorage
Syntax
Delphi
public
 procedure WriteInt(x: Integer);

Parameters

x
Type: Integer

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.WriteStr(WideString) Method

Summary

Represents method WriteStr(WideString).

Namespace: frxStorage
Syntax
Delphi
public
 procedure WriteStr(x: WideString);

Parameters

x
Type: WideString

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.WriteType(Integer) Method

Summary

Represents method WriteType(Integer).

Namespace: frxStorage
Syntax
Delphi
private
 procedure WriteType(t: Integer);

Parameters

t
Type: Integer

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW Fields

Fields
Name | Description
FSecure | Represents field FSecure.
FStream | Represents field FStream.
Top


TStreamRW.FSecure Field

Summary

Represents field FSecure.

Namespace: frxStorage
Syntax
Delphi
private
 FSecure: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TStreamRW
  • frxStorage


TStreamRW.FStream Field

Summary

Represents field FStream.

Namespace: frxStorage
Syntax
Delphi
private
 FStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TStreamRW
  • frxStorage


frxStorage Records

Records
Name | Description
TLcCreateParams | Represents type TLcCreateParams.
TLcLoadedObject | Represents type TLcLoadedObject.
TLcObject | Represents type TLcObject.
TLhtEntry | Represents type TLhtEntry.
Top


TLcCreateParams Record

Summary

Represents type TLcCreateParams.

Namespace: frxStorage
Syntax
Delphi
type
 TLcCreateParams = record
 end;

The TLcCreateParams type exposes the following members.

Fields
Show:
Name | Description
CacheStream | Represents field CacheStream.
ObjectsStream | Represents field ObjectsStream.
QueueSize | Represents field QueueSize.
Top
See Also

Reference

  • frxStorage


TLcCreateParams Fields

Fields
Name | Description
CacheStream | Represents field CacheStream.
ObjectsStream | Represents field ObjectsStream.
QueueSize | Represents field QueueSize.
Top


TLcCreateParams.CacheStream Field

Summary

Represents field CacheStream.

Namespace: frxStorage
Syntax
Delphi
public
 CacheStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TLcCreateParams
  • frxStorage


TLcCreateParams.ObjectsStream Field

Summary

Represents field ObjectsStream.

Namespace: frxStorage
Syntax
Delphi
public
 ObjectsStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TLcCreateParams
  • frxStorage


TLcCreateParams.QueueSize Field

Summary

Represents field QueueSize.

Namespace: frxStorage
Syntax
Delphi
public
 QueueSize: Integer;

Field Value

Type: Integer

See Also

Reference

  • TLcCreateParams
  • frxStorage


TLcLoadedObject Record

Summary

Represents type TLcLoadedObject.

Namespace: frxStorage
Syntax
Delphi
type
 TLcLoadedObject = record
 end;

The TLcLoadedObject type exposes the following members.

Fields
Show:
Name | Description
Index | Represents field Index.
Reference | Represents field Reference.
Top
See Also

Reference

  • frxStorage


TLcLoadedObject Fields

Fields
Name | Description
Index | Represents field Index.
Reference | Represents field Reference.
Top


TLcLoadedObject.Index Field

Summary

Represents field Index.

Namespace: frxStorage
Syntax
Delphi
public
 Index: Integer;

Field Value

Type: Integer

See Also

Reference

  • TLcLoadedObject
  • frxStorage


TLcLoadedObject.Reference Field

Summary

Represents field Reference.

Namespace: frxStorage
Syntax
Delphi
public
 Reference: TObject;

Field Value

Type: TObject

See Also

Reference

  • TLcLoadedObject
  • frxStorage


TLcObject Record

Summary

Represents type TLcObject.

Namespace: frxStorage
Syntax
Delphi
type
 TLcObject = record
 end;

The TLcObject type exposes the following members.

Fields
Show:
Name | Description
Offset | Represents field Offset.
Size | Represents field Size.
Top
See Also

Reference

  • frxStorage


TLcObject Fields

Fields
Name | Description
Offset | Represents field Offset.
Size | Represents field Size.
Top


TLcObject.Offset Field

Summary

Represents field Offset.

Namespace: frxStorage
Syntax
Delphi
public
 Offset: Int64;

Field Value

Type: Int64

See Also

Reference

  • TLcObject
  • frxStorage


TLcObject.Size Field

Summary

Represents field Size.

Namespace: frxStorage
Syntax
Delphi
public
 Size: Int64;

Field Value

Type: Int64

See Also

Reference

  • TLcObject
  • frxStorage


TLhtEntry Record

Summary

Represents type TLhtEntry.

Namespace: frxStorage
Syntax
Delphi
type
 TLhtEntry = packed record
 end;

The TLhtEntry type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Key | Represents field Key.
Next | Represents field Next.
Top
See Also

Reference

  • frxStorage


TLhtEntry Fields

Fields
Name | Description
Data | Represents field Data.
Key | Represents field Key.
Next | Represents field Next.
Top


TLhtEntry.Data Field

Summary

Represents field Data.

Namespace: frxStorage
Syntax
Delphi
public
 Data: Pointer;

Field Value

Type: Pointer

See Also

Reference

  • TLhtEntry
  • frxStorage


TLhtEntry.Key Field

Summary

Represents field Key.

Namespace: frxStorage
Syntax
Delphi
public
 Key: Integer;

Field Value

Type: Integer

See Also

Reference

  • TLhtEntry
  • frxStorage


TLhtEntry.Next Field

Summary

Represents field Next.

Namespace: frxStorage
Syntax
Delphi
public
 Next: Pointer;

Field Value

Type: Pointer

See Also

Reference

  • TLhtEntry
  • frxStorage


frxStorage Delegates

Delegates
Name | Description
TLcReadObj | Represents type TLcReadObj.
TLcWriteObj | Represents type TLcWriteObj.
TSimpleCompareFunction | Represents type TSimpleCompareFunction.
Top


TLcReadObj Delegate

Summary

Represents type TLcReadObj.

Namespace: frxStorage
Syntax
Delphi
type
 TLcReadObj = function(Stream: TStream): TObject;
See Also

Reference

  • frxStorage


TLcWriteObj Delegate

Summary

Represents type TLcWriteObj.

Namespace: frxStorage
Syntax
Delphi
type
 TLcWriteObj = procedure(Stream: TStream; Obj: TObject);
See Also

Reference

  • frxStorage


TSimpleCompareFunction Delegate

Summary

Represents type TSimpleCompareFunction.

Namespace: frxStorage
Syntax
Delphi
type
 TSimpleCompareFunction = function(const x, y: Pointer): Integer;
See Also

Reference

  • frxStorage


frxStorage Types

Types
Name | Description
PLhtEntry | Represents a pointer type to TLhtEntry.
Top


PLhtEntry Type

Summary

Represents a pointer type to TLhtEntry.

Namespace: frxStorage
Syntax
Delphi
type
 PLhtEntry = ^TLhtEntry;
See Also

Reference

  • frxStorage


frxStorage Routines

Routines
Name | Description
DbRead(TStream) | Represents method DbRead(TStream).
DbWrite(TStream,TObject) | Represents method DbWrite(TStream,TObject).
LhtFindEntry(PLhtEntry,Integer) | Represents method LhtFindEntry(PLhtEntry,Integer).
LhtGetEntry(Pointer,Integer) | Represents method LhtGetEntry(Pointer,Integer).
LhtSetEntry(Pointer,Integer,PLhtEntry) | Represents method LhtSetEntry(Pointer,Integer,PLhtEntry).
Top


DbRead(TStream) Method

Summary

Represents method DbRead(TStream).

Namespace: frxStorage
Syntax
Delphi
function DbRead(Stream: TStream): TObject;

Parameters

Stream
Type: TStream

Return Value

Type: TObject

See Also

Reference

  • frxStorage


DbWrite(TStream,TObject) Method

Summary

Represents method DbWrite(TStream,TObject).

Namespace: frxStorage
Syntax
Delphi
procedure DbWrite(Stream: TStream; Block: TObject);

Parameters

Stream
Type: TStream

Block
Type: TObject

See Also

Reference

  • frxStorage


LhtFindEntry(PLhtEntry,Integer) Method

Summary

Represents method LhtFindEntry(PLhtEntry,Integer).

Namespace: frxStorage
Syntax
Delphi
function LhtFindEntry(e: PLhtEntry; Key: Integer): PLhtEntry; cdecl;

Parameters

e
Type: PLhtEntry

Key
Type: Integer

Return Value

Type: PLhtEntry

See Also

Reference

  • frxStorage


LhtGetEntry(Pointer,Integer) Method

Summary

Represents method LhtGetEntry(Pointer,Integer).

Namespace: frxStorage
Syntax
Delphi
function LhtGetEntry(Base: Pointer; Index: Integer): PLhtEntry; cdecl;

Parameters

Base
Type: Pointer

Index
Type: Integer

Return Value

Type: PLhtEntry

See Also

Reference

  • frxStorage


LhtSetEntry(Pointer,Integer,PLhtEntry) Method

Summary

Represents method LhtSetEntry(Pointer,Integer,PLhtEntry).

Namespace: frxStorage
Syntax
Delphi
procedure LhtSetEntry(Base: Pointer; Index: Integer; Entry: PLhtEntry); cdecl;

Parameters

Base
Type: Pointer

Index
Type: Integer

Entry
Type: PLhtEntry

See Also

Reference

  • frxStorage


frxSynMemo Namespace

Summary

Represents namespace frxSynMemo.

Classes
Name | Description
TfrxAttributeStyle | Represents type TfrxAttributeStyle.
TfrxAttributeStyles | Represents type TfrxAttributeStyles.
TfrxBreakPoint | Represents type TfrxBreakPoint.
TfrxCodeCompletionThread | Represents type TfrxCodeCompletionThread.
TfrxCompletionItem | Represents type TfrxCompletionItem.
TfrxCompletionList | Represents type TfrxCompletionList.
TfrxSynAttributes | Represents type TfrxSynAttributes.
TfrxSynDialectStyle | Represents type TfrxSynDialectStyle.
TfrxSynDialectStyles | Represents type TfrxSynDialectStyles.
TfrxSyntaxMemo | Represents type TfrxSyntaxMemo.
Top
Records
Name | Description
TfrxCharAttributes | Represents type TfrxCharAttributes.
Top
Enumerations
Name | Description
TCharAttr | Represents type TCharAttr.
TfrxCompletionListType | Represents type TfrxCompletionListType.
TfrxItemType | Represents type TfrxItemType.
Top
Delegates
Name | Description
TfrxCodeCompletionEvent | Represents type TfrxCodeCompletionEvent.
Top
Types
Name | Description
TfrxByteArr | Represents an array of the Byte type.
TfrxCompletionListTypes | Represents type TfrxCompletionListTypes.
TfrxItemTypes | Represents type TfrxItemTypes.
Top
Constants
Name | Description
WM_FRX_FILL_CODE_COMPLETION | Represents constant WM_FRX_FILL_CODE_COMPLETION.
WM_FRX_SYNC_SCRIPT | Represents constant WM_FRX_SYNC_SCRIPT.
WM_FRX_UPDATE_CODE | Represents constant WM_FRX_UPDATE_CODE.
Top


frxSynMemo Classes

Classes
Name | Description
TfrxAttributeStyle | Represents type TfrxAttributeStyle.
TfrxAttributeStyles | Represents type TfrxAttributeStyles.
TfrxBreakPoint | Represents type TfrxBreakPoint.
TfrxCodeCompletionThread | Represents type TfrxCodeCompletionThread.
TfrxCompletionItem | Represents type TfrxCompletionItem.
TfrxCompletionList | Represents type TfrxCompletionList.
TfrxSynAttributes | Represents type TfrxSynAttributes.
TfrxSynDialectStyle | Represents type TfrxSynDialectStyle.
TfrxSynDialectStyles | Represents type TfrxSynDialectStyles.
TfrxSyntaxMemo | Represents type TfrxSyntaxMemo.
Top


TfrxAttributeStyle Class

Summary

Represents type TfrxAttributeStyle.

Namespace: frxSynMemo
Inheritance Hierarchy
TCollectionItem
frxSynMemo.TfrxAttributeStyle
Syntax
Delphi
type
 TfrxAttributeStyle = class(TCollectionItem)
 end;

The TfrxAttributeStyle type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxAttributeStyle class.
Destroy | Represents the destructor of the TfrxAttributeStyle class.
Top
Properties
Show:
Name | Description
AttrType | Represents property AttrType.
FontColor | Represents property FontColor.
FontStyle | Represents property FontStyle.
Keywords | Represents property Keywords.
StyleID | Represents property StyleID.
Top
Methods
Show:
Name | Description
SetCollection(TCollection) | Represents method SetCollection(TCollection).
Top
Fields
Show:
Name | Description
FAttrType | Represents field FAttrType.
FFontColor | Represents field FFontColor.
FFontStyle | Represents field FFontStyle.
FKeywords | Represents field FKeywords.
FStyleID | Represents field FStyleID.
Top
See Also

Reference

  • frxSynMemo


TfrxAttributeStyle Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxAttributeStyle class.
Destroy | Represents the destructor of the TfrxAttributeStyle class.
Top


TfrxAttributeStyle.Create(TCollection) Constructor

Summary

Initializes a new instance of the TfrxAttributeStyle class.

Namespace: frxSynMemo
Syntax
Delphi
public
 constructor Create(Collection: TCollection); override;

Parameters

Collection
Type: TCollection

See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyle.Destroy Destructor

Summary

Represents the destructor of the TfrxAttributeStyle class.

Namespace: frxSynMemo
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyle Properties

Properties
Name | Description
AttrType | Represents property AttrType.
FontColor | Represents property FontColor.
FontStyle | Represents property FontStyle.
Keywords | Represents property Keywords.
StyleID | Represents property StyleID.
Top


TfrxAttributeStyle.AttrType Property

Summary

Represents property AttrType.

Namespace: frxSynMemo
Syntax
Delphi
published
 property AttrType: TCharAttr read FAttrType write FAttrType;

Property Value

Type: TCharAttr

See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyle.FontColor Property

Summary

Represents property FontColor.

Namespace: frxSynMemo
Syntax
Delphi
published
 property FontColor: TColor read FFontColor write FFontColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyle.FontStyle Property

Summary

Represents property FontStyle.

Namespace: frxSynMemo
Syntax
Delphi
published
 property FontStyle: TFontStyles read FFontStyle write FFontStyle;

Property Value

Type: TFontStyles

See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyle.Keywords Property

Summary

Represents property Keywords.

Namespace: frxSynMemo
Syntax
Delphi
published
 property Keywords: TStrings read FKeywords;

Property Value

Type: TStrings

See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyle.StyleID Property

Summary

Represents property StyleID.

Namespace: frxSynMemo
Syntax
Delphi
public
 property StyleID: Byte read FStyleID;

Property Value

Type: Byte

See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyle Methods

Methods
Name | Description
SetCollection(TCollection) | Represents method SetCollection(TCollection).
Top


TfrxAttributeStyle.SetCollection(TCollection) Method

Summary

Represents method SetCollection(TCollection).

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure SetCollection(Value: TCollection); override;

Parameters

Value
Type: TCollection

See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyle Fields

Fields
Name | Description
FAttrType | Represents field FAttrType.
FFontColor | Represents field FFontColor.
FFontStyle | Represents field FFontStyle.
FKeywords | Represents field FKeywords.
FStyleID | Represents field FStyleID.
Top


TfrxAttributeStyle.FAttrType Field

Summary

Represents field FAttrType.

Namespace: frxSynMemo
Syntax
Delphi
private
 FAttrType: TCharAttr;

Field Value

Type: TCharAttr

See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyle.FFontColor Field

Summary

Represents field FFontColor.

Namespace: frxSynMemo
Syntax
Delphi
private
 FFontColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyle.FFontStyle Field

Summary

Represents field FFontStyle.

Namespace: frxSynMemo
Syntax
Delphi
private
 FFontStyle: TFontStyles;

Field Value

Type: TFontStyles

See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyle.FKeywords Field

Summary

Represents field FKeywords.

Namespace: frxSynMemo
Syntax
Delphi
private
 FKeywords: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyle.FStyleID Field

Summary

Represents field FStyleID.

Namespace: frxSynMemo
Syntax
Delphi
private
 FStyleID: Byte;

Field Value

Type: Byte

See Also

Reference

  • TfrxAttributeStyle
  • frxSynMemo


TfrxAttributeStyles Class

Summary

Represents type TfrxAttributeStyles.

Namespace: frxSynMemo
Inheritance Hierarchy
TCollection
frxSynMemo.TfrxAttributeStyles
Syntax
Delphi
type
 TfrxAttributeStyles = class(TCollection)
 end;

The TfrxAttributeStyles type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxAttributeStyles class.
Destroy | Represents the destructor of the TfrxAttributeStyles class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add | Represents method Add.
AssignStyle(TfrxAttributeStyle,TFont) | Represents method AssignStyle(TfrxAttributeStyle,TFont).
AssignStyleByID(Byte,TFont) | Represents method AssignStyleByID(Byte,TFont).
FindStyleIDByKeyword(String,TCharAttr) | Represents method FindStyleIDByKeyword(String,TCharAttr).
GetItem(Integer) | Represents method GetItem(Integer).
GetStyleByID(Byte) | Represents method GetStyleByID(Byte).
GetUniqueID | Represents method GetUniqueID.
Top
Fields
Show:
Name | Description
FDefaultAttribute | Represents field FDefaultAttribute.
FIndexedList | Represents field FIndexedList.
Top
See Also

Reference

  • frxSynMemo


TfrxAttributeStyles Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxAttributeStyles class.
Destroy | Represents the destructor of the TfrxAttributeStyles class.
Top


TfrxAttributeStyles.Create Constructor

Summary

Initializes a new instance of the TfrxAttributeStyles class.

Namespace: frxSynMemo
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxAttributeStyles
  • frxSynMemo


TfrxAttributeStyles.Destroy Destructor

Summary

Represents the destructor of the TfrxAttributeStyles class.

Namespace: frxSynMemo
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxAttributeStyles
  • frxSynMemo


TfrxAttributeStyles Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TfrxAttributeStyles.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxSynMemo
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxAttributeStyle read GetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxAttributeStyle

See Also

Reference

  • TfrxAttributeStyles
  • frxSynMemo


TfrxAttributeStyles Methods

Methods
Name | Description
Add | Represents method Add.
AssignStyle(TfrxAttributeStyle,TFont) | Represents method AssignStyle(TfrxAttributeStyle,TFont).
AssignStyleByID(Byte,TFont) | Represents method AssignStyleByID(Byte,TFont).
FindStyleIDByKeyword(String,TCharAttr) | Represents method FindStyleIDByKeyword(String,TCharAttr).
GetItem(Integer) | Represents method GetItem(Integer).
GetStyleByID(Byte) | Represents method GetStyleByID(Byte).
GetUniqueID | Represents method GetUniqueID.
Top


TfrxAttributeStyles.Add Method

Summary

Represents method Add.

Namespace: frxSynMemo
Syntax
Delphi
public
 function Add: TfrxAttributeStyle;

Return Value

Type: TfrxAttributeStyle

See Also

Reference

  • TfrxAttributeStyles
  • frxSynMemo


TfrxAttributeStyles.AssignStyle(TfrxAttributeStyle,TFont) Method

Summary

Represents method AssignStyle(TfrxAttributeStyle,TFont).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure AssignStyle(aStyle: TfrxAttributeStyle; aFont: TFont);

Parameters

aStyle
Type: TfrxAttributeStyle

aFont
Type: TFont

See Also

Reference

  • TfrxAttributeStyles
  • frxSynMemo


TfrxAttributeStyles.AssignStyleByID(Byte,TFont) Method

Summary

Represents method AssignStyleByID(Byte,TFont).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure AssignStyleByID(ID: Byte; aFont: TFont);

Parameters

ID
Type: Byte

aFont
Type: TFont

See Also

Reference

  • TfrxAttributeStyles
  • frxSynMemo


TfrxAttributeStyles.FindStyleIDByKeyword(String,TCharAttr) Method

Summary

Represents method FindStyleIDByKeyword(String,TCharAttr).

Namespace: frxSynMemo
Syntax
Delphi
public
 function FindStyleIDByKeyword(const Name: String; AttrType: TCharAttr): Byte;

Parameters

Name
Type: String

AttrType
Type: TCharAttr

Return Value

Type: Byte

See Also

Reference

  • TfrxAttributeStyles
  • frxSynMemo


TfrxAttributeStyles.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetItem(Index: Integer): TfrxAttributeStyle;

Parameters

Index
Type: Integer

Return Value

Type: TfrxAttributeStyle

See Also

Reference

  • TfrxAttributeStyles
  • frxSynMemo


TfrxAttributeStyles.GetStyleByID(Byte) Method

Summary

Represents method GetStyleByID(Byte).

Namespace: frxSynMemo
Syntax
Delphi
public
 function GetStyleByID(ID: Byte): TfrxAttributeStyle;

Parameters

ID
Type: Byte

Return Value

Type: TfrxAttributeStyle

See Also

Reference

  • TfrxAttributeStyles
  • frxSynMemo


TfrxAttributeStyles.GetUniqueID Method

Summary

Represents method GetUniqueID.

Namespace: frxSynMemo
Syntax
Delphi
public
 function GetUniqueID: Byte;

Return Value

Type: Byte

See Also

Reference

  • TfrxAttributeStyles
  • frxSynMemo


TfrxAttributeStyles Fields

Fields
Name | Description
FDefaultAttribute | Represents field FDefaultAttribute.
FIndexedList | Represents field FIndexedList.
Top


TfrxAttributeStyles.FDefaultAttribute Field

Summary

Represents field FDefaultAttribute.

Namespace: frxSynMemo
Syntax
Delphi
private
 FDefaultAttribute: TfrxAttributeStyle;

Field Value

Type: TfrxAttributeStyle

See Also

Reference

  • TfrxAttributeStyles
  • frxSynMemo


TfrxAttributeStyles.FIndexedList Field

Summary

Represents field FIndexedList.

Namespace: frxSynMemo
Syntax
Delphi
private
 FIndexedList: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxAttributeStyles
  • frxSynMemo


TfrxBreakPoint Class

Summary

Represents type TfrxBreakPoint.

Namespace: frxSynMemo
Inheritance Hierarchy
TObject
frxSynMemo.TfrxBreakPoint
Syntax
Delphi
type
 TfrxBreakPoint = class
 end;

The TfrxBreakPoint type exposes the following members.

Properties
Show:
Name | Description
Condition | Represents property Condition.
Enabled | Represents property Enabled.
Line | Represents property Line.
SpecialCondition | Represents property SpecialCondition.
Top
Fields
Show:
Name | Description
FCondition | Represents field FCondition.
FEnabled | Represents field FEnabled.
FLine | Represents field FLine.
FSpecialCondition | Represents field FSpecialCondition.
Top
See Also

Reference

  • frxSynMemo


TfrxBreakPoint Properties

Properties
Name | Description
Condition | Represents property Condition.
Enabled | Represents property Enabled.
Line | Represents property Line.
SpecialCondition | Represents property SpecialCondition.
Top


TfrxBreakPoint.Condition Property

Summary

Represents property Condition.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Condition: String read FCondition write FCondition;

Property Value

Type: String

See Also

Reference

  • TfrxBreakPoint
  • frxSynMemo


TfrxBreakPoint.Enabled Property

Summary

Represents property Enabled.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Enabled: Boolean read FEnabled write FEnabled;

Property Value

Type: Boolean

See Also

Reference

  • TfrxBreakPoint
  • frxSynMemo


TfrxBreakPoint.Line Property

Summary

Represents property Line.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Line: Integer read FLine write FLine;

Property Value

Type: Integer

See Also

Reference

  • TfrxBreakPoint
  • frxSynMemo


TfrxBreakPoint.SpecialCondition Property

Summary

Represents property SpecialCondition.

Namespace: frxSynMemo
Syntax
Delphi
public
 property SpecialCondition: String read FSpecialCondition write FSpecialCondition;

Property Value

Type: String

See Also

Reference

  • TfrxBreakPoint
  • frxSynMemo


TfrxBreakPoint Fields

Fields
Name | Description
FCondition | Represents field FCondition.
FEnabled | Represents field FEnabled.
FLine | Represents field FLine.
FSpecialCondition | Represents field FSpecialCondition.
Top


TfrxBreakPoint.FCondition Field

Summary

Represents field FCondition.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCondition: String;

Field Value

Type: String

See Also

Reference

  • TfrxBreakPoint
  • frxSynMemo


TfrxBreakPoint.FEnabled Field

Summary

Represents field FEnabled.

Namespace: frxSynMemo
Syntax
Delphi
private
 FEnabled: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxBreakPoint
  • frxSynMemo


TfrxBreakPoint.FLine Field

Summary

Represents field FLine.

Namespace: frxSynMemo
Syntax
Delphi
private
 FLine: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxBreakPoint
  • frxSynMemo


TfrxBreakPoint.FSpecialCondition Field

Summary

Represents field FSpecialCondition.

Namespace: frxSynMemo
Syntax
Delphi
private
 FSpecialCondition: String;

Field Value

Type: String

See Also

Reference

  • TfrxBreakPoint
  • frxSynMemo


TfrxCodeCompletionThread Class

Summary

Represents type TfrxCodeCompletionThread.

Namespace: frxSynMemo
Inheritance Hierarchy
TThread
frxSynMemo.TfrxCodeCompletionThread
Syntax
Delphi
type
 TfrxCodeCompletionThread = class(TThread)
 end;

The TfrxCodeCompletionThread type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TfrxCodeCompletionThread class.
Top
Properties
Show:
Name | Description
Script | Represents property Script.
Top
Methods
Show:
Name | Description
Execute | Represents method Execute.
FillCodeCompletion | Represents method FillCodeCompletion.
FreeScript | Represents method FreeScript.
SyncScript | Represents method SyncScript.
UpdateCode | Represents method UpdateCode.
Top
Fields
Show:
Name | Description
FCompletionList | Represents field FCompletionList.
FILCode | Represents field FILCode.
FMemoHandle | Represents field FMemoHandle.
FOriginalScript | Represents field FOriginalScript.
FScript | Represents field FScript.
FSyntaxType | Represents field FSyntaxType.
FText | Represents field FText.
FXML | Represents field FXML.
Top
See Also

Reference

  • frxSynMemo


TfrxCodeCompletionThread Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TfrxCodeCompletionThread class.
Top


TfrxCodeCompletionThread.Destroy Destructor

Summary

Represents the destructor of the TfrxCodeCompletionThread class.

Namespace: frxSynMemo
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread Properties

Properties
Name | Description
Script | Represents property Script.
Top


TfrxCodeCompletionThread.Script Property

Summary

Represents property Script.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Script: TfsScript read FOriginalScript write FOriginalScript;

Property Value

Type: TfsScript

See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread Methods

Methods
Name | Description
Execute | Represents method Execute.
FillCodeCompletion | Represents method FillCodeCompletion.
FreeScript | Represents method FreeScript.
SyncScript | Represents method SyncScript.
UpdateCode | Represents method UpdateCode.
Top


TfrxCodeCompletionThread.Execute Method

Summary

Represents method Execute.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure Execute; override;
See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread.FillCodeCompletion Method

Summary

Represents method FillCodeCompletion.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure FillCodeCompletion;
See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread.FreeScript Method

Summary

Represents method FreeScript.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure FreeScript;
See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread.SyncScript Method

Summary

Represents method SyncScript.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SyncScript;
See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread.UpdateCode Method

Summary

Represents method UpdateCode.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure UpdateCode;
See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread Fields

Fields
Name | Description
FCompletionList | Represents field FCompletionList.
FILCode | Represents field FILCode.
FMemoHandle | Represents field FMemoHandle.
FOriginalScript | Represents field FOriginalScript.
FScript | Represents field FScript.
FSyntaxType | Represents field FSyntaxType.
FText | Represents field FText.
FXML | Represents field FXML.
Top


TfrxCodeCompletionThread.FCompletionList Field

Summary

Represents field FCompletionList.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCompletionList: TfrxCompletionList;

Field Value

Type: TfrxCompletionList

See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread.FILCode Field

Summary

Represents field FILCode.

Namespace: frxSynMemo
Syntax
Delphi
private
 FILCode: TStream;

Field Value

Type: TStream

See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread.FMemoHandle Field

Summary

Represents field FMemoHandle.

Namespace: frxSynMemo
Syntax
Delphi
private
 FMemoHandle: HWND;

Field Value

Type: HWND

See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread.FOriginalScript Field

Summary

Represents field FOriginalScript.

Namespace: frxSynMemo
Syntax
Delphi
private
 FOriginalScript: TfsScript;

Field Value

Type: TfsScript

See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread.FScript Field

Summary

Represents field FScript.

Namespace: frxSynMemo
Syntax
Delphi
private
 FScript: TfsScript;

Field Value

Type: TfsScript

See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread.FSyntaxType Field

Summary

Represents field FSyntaxType.

Namespace: frxSynMemo
Syntax
Delphi
private
 FSyntaxType: String;

Field Value

Type: String

See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread.FText Field

Summary

Represents field FText.

Namespace: frxSynMemo
Syntax
Delphi
private
 FText: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCodeCompletionThread.FXML Field

Summary

Represents field FXML.

Namespace: frxSynMemo
Syntax
Delphi
private
 FXML: TfsXMLDocument;

Field Value

Type: TfsXMLDocument

See Also

Reference

  • TfrxCodeCompletionThread
  • frxSynMemo


TfrxCompletionItem Class

Summary

Represents type TfrxCompletionItem.

Namespace: frxSynMemo
Inheritance Hierarchy
TObject
frxSynMemo.TfrxCompletionItem
Syntax
Delphi
type
 TfrxCompletionItem = class
 end;

The TfrxCompletionItem type exposes the following members.

Properties
Show:
Name | Description
ItemType | Represents property ItemType.
Name | Represents property Name.
Params | Represents property Params.
Typ | Represents property Typ.
Top
Fields
Show:
Name | Description
FEndVisible | Represents field FEndVisible.
FItemType | Represents field FItemType.
FName | Represents field FName.
FParams | Represents field FParams.
FParent | Represents field FParent.
FStartVisible | Represents field FStartVisible.
FType | Represents field FType.
Top
See Also

Reference

  • frxSynMemo


TfrxCompletionItem Properties

Properties
Name | Description
ItemType | Represents property ItemType.
Name | Represents property Name.
Params | Represents property Params.
Typ | Represents property Typ.
Top


TfrxCompletionItem.ItemType Property

Summary

Represents property ItemType.

Namespace: frxSynMemo
Syntax
Delphi
public
 property ItemType: TfrxItemType read FItemType;

Property Value

Type: TfrxItemType

See Also

Reference

  • TfrxCompletionItem
  • frxSynMemo


TfrxCompletionItem.Name Property

Summary

Represents property Name.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Name: String read FName;

Property Value

Type: String

See Also

Reference

  • TfrxCompletionItem
  • frxSynMemo


TfrxCompletionItem.Params Property

Summary

Represents property Params.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Params: String read FParams;

Property Value

Type: String

See Also

Reference

  • TfrxCompletionItem
  • frxSynMemo


TfrxCompletionItem.Typ Property

Summary

Represents property Typ.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Typ: String read FType;

Property Value

Type: String

See Also

Reference

  • TfrxCompletionItem
  • frxSynMemo


TfrxCompletionItem Fields

Fields
Name | Description
FEndVisible | Represents field FEndVisible.
FItemType | Represents field FItemType.
FName | Represents field FName.
FParams | Represents field FParams.
FParent | Represents field FParent.
FStartVisible | Represents field FStartVisible.
FType | Represents field FType.
Top


TfrxCompletionItem.FEndVisible Field

Summary

Represents field FEndVisible.

Namespace: frxSynMemo
Syntax
Delphi
private
 FEndVisible: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCompletionItem
  • frxSynMemo


TfrxCompletionItem.FItemType Field

Summary

Represents field FItemType.

Namespace: frxSynMemo
Syntax
Delphi
private
 FItemType: TfrxItemType;

Field Value

Type: TfrxItemType

See Also

Reference

  • TfrxCompletionItem
  • frxSynMemo


TfrxCompletionItem.FName Field

Summary

Represents field FName.

Namespace: frxSynMemo
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxCompletionItem
  • frxSynMemo


TfrxCompletionItem.FParams Field

Summary

Represents field FParams.

Namespace: frxSynMemo
Syntax
Delphi
private
 FParams: String;

Field Value

Type: String

See Also

Reference

  • TfrxCompletionItem
  • frxSynMemo


TfrxCompletionItem.FParent Field

Summary

Represents field FParent.

Namespace: frxSynMemo
Syntax
Delphi
private
 FParent: TfrxCompletionItem;

Field Value

Type: TfrxCompletionItem

See Also

Reference

  • TfrxCompletionItem
  • frxSynMemo


TfrxCompletionItem.FStartVisible Field

Summary

Represents field FStartVisible.

Namespace: frxSynMemo
Syntax
Delphi
private
 FStartVisible: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxCompletionItem
  • frxSynMemo


TfrxCompletionItem.FType Field

Summary

Represents field FType.

Namespace: frxSynMemo
Syntax
Delphi
private
 FType: String;

Field Value

Type: String

See Also

Reference

  • TfrxCompletionItem
  • frxSynMemo


TfrxCompletionList Class

Summary

Represents type TfrxCompletionList.

Namespace: frxSynMemo
Inheritance Hierarchy
TObject
frxSynMemo.TfrxCompletionList
Syntax
Delphi
type
 TfrxCompletionList = class
 end;

The TfrxCompletionList type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxCompletionList class.
Destroy | Represents the destructor of the TfrxCompletionList class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Locked | Represents property Locked.
Top
Methods
Show:
Name | Description
AddBaseVar(TStrings,String,String,Integer,Integer,String) | Represents method AddBaseVar(TStrings,String,String,Integer,Integer,String).
AddClass(String,String,Integer,Integer,String) | Represents method AddClass(String,String,Integer,Integer,String).
AddConstant(String,String,Integer,Integer,String) | Represents method AddConstant(String,String,Integer,Integer,String).
AddFunction(String,String,String,Integer,Integer,String) | Represents method AddFunction(String,String,String,Integer,Integer,String).
AddVariable(String,String,Integer,Integer,String) | Represents method AddVariable(String,String,Integer,Integer,String).
Count | Represents method Count.
DestroyItems | Represents method DestroyItems.
Find(String) | Represents method Find(String).
GetItem(Integer) | Represents method GetItem(Integer).
Top
Fields
Show:
Name | Description
FClasses | Represents field FClasses.
FConstants | Represents field FConstants.
FFunctions | Represents field FFunctions.
FLocked | Represents field FLocked.
FVariables | Represents field FVariables.
Top
See Also

Reference

  • frxSynMemo


TfrxCompletionList Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxCompletionList class.
Destroy | Represents the destructor of the TfrxCompletionList class.
Top


TfrxCompletionList.Create Constructor

Summary

Initializes a new instance of the TfrxCompletionList class.

Namespace: frxSynMemo
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.Destroy Destructor

Summary

Represents the destructor of the TfrxCompletionList class.

Namespace: frxSynMemo
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Locked | Represents property Locked.
Top


TfrxCompletionList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxSynMemo
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxCompletionItem read GetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxCompletionItem

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.Locked Property

Summary

Represents property Locked.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Locked: Boolean read FLocked write FLocked;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList Methods

Methods
Name | Description
AddBaseVar(TStrings,String,String,Integer,Integer,String) | Represents method AddBaseVar(TStrings,String,String,Integer,Integer,String).
AddClass(String,String,Integer,Integer,String) | Represents method AddClass(String,String,Integer,Integer,String).
AddConstant(String,String,Integer,Integer,String) | Represents method AddConstant(String,String,Integer,Integer,String).
AddFunction(String,String,String,Integer,Integer,String) | Represents method AddFunction(String,String,String,Integer,Integer,String).
AddVariable(String,String,Integer,Integer,String) | Represents method AddVariable(String,String,Integer,Integer,String).
Count | Represents method Count.
DestroyItems | Represents method DestroyItems.
Find(String) | Represents method Find(String).
GetItem(Integer) | Represents method GetItem(Integer).
Top


TfrxCompletionList.AddBaseVar(TStrings,String,String,Integer,Integer,String) Method

Summary

Represents method AddBaseVar(TStrings,String,String,Integer,Integer,String).

Namespace: frxSynMemo
Syntax
Delphi
private
 function AddBaseVar(varList: TStrings; const Name, sType: String; VisibleStart: Integer = 0; VisibleEnd: Integer = -1; const ParentFunc: String = ''): TfrxCompletionItem;

Parameters

varList
Type: TStrings

Name
Type: String

sType
Type: String

VisibleStart
Type: Integer

VisibleEnd
Type: Integer

ParentFunc
Type: String

Return Value

Type: TfrxCompletionItem

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.AddClass(String,String,Integer,Integer,String) Method

Summary

Represents method AddClass(String,String,Integer,Integer,String).

Namespace: frxSynMemo
Syntax
Delphi
public
 function AddClass(const Name, sType: String; VisibleStart: Integer = 0; VisibleEnd: Integer = -1; const ParentFunc: String = ''): TfrxCompletionItem;

Parameters

Name
Type: String

sType
Type: String

VisibleStart
Type: Integer

VisibleEnd
Type: Integer

ParentFunc
Type: String

Return Value

Type: TfrxCompletionItem

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.AddConstant(String,String,Integer,Integer,String) Method

Summary

Represents method AddConstant(String,String,Integer,Integer,String).

Namespace: frxSynMemo
Syntax
Delphi
public
 function AddConstant(const Name, sType: String; VisibleStart: Integer = 0; VisibleEnd: Integer = -1; const ParentFunc: String = ''): TfrxCompletionItem;

Parameters

Name
Type: String

sType
Type: String

VisibleStart
Type: Integer

VisibleEnd
Type: Integer

ParentFunc
Type: String

Return Value

Type: TfrxCompletionItem

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.AddFunction(String,String,String,Integer,Integer,String) Method

Summary

Represents method AddFunction(String,String,String,Integer,Integer,String).

Namespace: frxSynMemo
Syntax
Delphi
public
 function AddFunction(const Name, sType, Params: String; VisibleStart: Integer = 0; VisibleEnd: Integer = -1; const ParentFunc: String = ''): TfrxCompletionItem;

Parameters

Name
Type: String

sType
Type: String

Params
Type: String

VisibleStart
Type: Integer

VisibleEnd
Type: Integer

ParentFunc
Type: String

Return Value

Type: TfrxCompletionItem

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.AddVariable(String,String,Integer,Integer,String) Method

Summary

Represents method AddVariable(String,String,Integer,Integer,String).

Namespace: frxSynMemo
Syntax
Delphi
public
 function AddVariable(const Name, sType: String; VisibleStart: Integer = 0; VisibleEnd: Integer = -1; const ParentFunc: String = ''): TfrxCompletionItem;

Parameters

Name
Type: String

sType
Type: String

VisibleStart
Type: Integer

VisibleEnd
Type: Integer

ParentFunc
Type: String

Return Value

Type: TfrxCompletionItem

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.Count Method

Summary

Represents method Count.

Namespace: frxSynMemo
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.DestroyItems Method

Summary

Represents method DestroyItems.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure DestroyItems;
See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.Find(String) Method

Summary

Represents method Find(String).

Namespace: frxSynMemo
Syntax
Delphi
public
 function Find(const Name: String): TfrxCompletionItem;

Parameters

Name
Type: String

Return Value

Type: TfrxCompletionItem

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetItem(Index: Integer): TfrxCompletionItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxCompletionItem

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList Fields

Fields
Name | Description
FClasses | Represents field FClasses.
FConstants | Represents field FConstants.
FFunctions | Represents field FFunctions.
FLocked | Represents field FLocked.
FVariables | Represents field FVariables.
Top


TfrxCompletionList.FClasses Field

Summary

Represents field FClasses.

Namespace: frxSynMemo
Syntax
Delphi
private
 FClasses: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.FConstants Field

Summary

Represents field FConstants.

Namespace: frxSynMemo
Syntax
Delphi
private
 FConstants: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.FFunctions Field

Summary

Represents field FFunctions.

Namespace: frxSynMemo
Syntax
Delphi
private
 FFunctions: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.FLocked Field

Summary

Represents field FLocked.

Namespace: frxSynMemo
Syntax
Delphi
private
 FLocked: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxCompletionList.FVariables Field

Summary

Represents field FVariables.

Namespace: frxSynMemo
Syntax
Delphi
private
 FVariables: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxCompletionList
  • frxSynMemo


TfrxSynAttributes Class

Summary

Represents type TfrxSynAttributes.

Namespace: frxSynMemo
Inheritance Hierarchy
TObject
frxSynMemo.TfrxSynAttributes
Syntax
Delphi
type
 TfrxSynAttributes = class
 end;

The TfrxSynAttributes type exposes the following members.

Constructors
Show:
Name | Description
Create(TfsParser,TfrxSynDialectStyles) | Initializes a new instance of the TfrxSynAttributes class.
Top
Properties
Show:
Name | Description
Count | Represents property Count.
Line[Integer] | Represents property Line[Integer].
Updating | Represents property Updating.
Top
Methods
Show:
Name | Description
ActiveChanged(TObject) | Represents method ActiveChanged(TObject).
Delete(Integer) | Represents method Delete(Integer).
GetAllAttributes | Represents method GetAllAttributes.
GetLine(Integer) | Represents method GetLine(Integer).
PutLine(Integer,TfrxByteArr) | Represents method PutLine(Integer,TfrxByteArr).
SetAllAttributes(TfrxByteArr) | Represents method SetAllAttributes(TfrxByteArr).
SetCapacity(Integer) | Represents method SetCapacity(Integer).
SetCount(Integer) | Represents method SetCount(Integer).
SetLineLen(Integer,Integer) | Represents method SetLineLen(Integer,Integer).
UpdateSyntax(Integer,TStringList) | Represents method UpdateSyntax(Integer,TStringList).
UpdateSyntaxDialect | Represents method UpdateSyntaxDialect.
Top
Fields
Show:
Name | Description
FArray | Represents field FArray.
FCapacity | Represents field FCapacity.
FCount | Represents field FCount.
FDialectStyles | Represents field FDialectStyles.
FParser | Represents field FParser.
FUpdating | Represents field FUpdating.
Top
See Also

Reference

  • frxSynMemo


TfrxSynAttributes Constructors

Constructors
Name | Description
Create(TfsParser,TfrxSynDialectStyles) | Initializes a new instance of the TfrxSynAttributes class.
Top


TfrxSynAttributes.Create(TfsParser,TfrxSynDialectStyles) Constructor

Summary

Initializes a new instance of the TfrxSynAttributes class.

Namespace: frxSynMemo
Syntax
Delphi
public
 constructor Create(Parser: TfsParser; DialectStyles: TfrxSynDialectStyles);

Parameters

Parser
Type: TfsParser

DialectStyles
Type: TfrxSynDialectStyles

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes Properties

Properties
Name | Description
Count | Represents property Count.
Line[Integer] | Represents property Line[Integer].
Updating | Represents property Updating.
Top


TfrxSynAttributes.Count Property

Summary

Represents property Count.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Count: Integer read FCount write SetCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.Line[Integer] Property

Summary

Represents property Line[Integer].

Namespace: frxSynMemo
Syntax
Delphi
public
 property Line[Index: Integer]: TfrxByteArr read GetLine write PutLine; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxByteArr

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.Updating Property

Summary

Represents property Updating.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Updating: Boolean read FUpdating;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes Methods

Methods
Name | Description
ActiveChanged(TObject) | Represents method ActiveChanged(TObject).
Delete(Integer) | Represents method Delete(Integer).
GetAllAttributes | Represents method GetAllAttributes.
GetLine(Integer) | Represents method GetLine(Integer).
PutLine(Integer,TfrxByteArr) | Represents method PutLine(Integer,TfrxByteArr).
SetAllAttributes(TfrxByteArr) | Represents method SetAllAttributes(TfrxByteArr).
SetCapacity(Integer) | Represents method SetCapacity(Integer).
SetCount(Integer) | Represents method SetCount(Integer).
SetLineLen(Integer,Integer) | Represents method SetLineLen(Integer,Integer).
UpdateSyntax(Integer,TStringList) | Represents method UpdateSyntax(Integer,TStringList).
UpdateSyntaxDialect | Represents method UpdateSyntaxDialect.
Top


TfrxSynAttributes.ActiveChanged(TObject) Method

Summary

Represents method ActiveChanged(TObject).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure ActiveChanged(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure Delete(Index: Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.GetAllAttributes Method

Summary

Represents method GetAllAttributes.

Namespace: frxSynMemo
Syntax
Delphi
public
 function GetAllAttributes: TfrxByteArr;

Return Value

Type: TfrxByteArr

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.GetLine(Integer) Method

Summary

Represents method GetLine(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetLine(Index: Integer): TfrxByteArr;

Parameters

Index
Type: Integer

Return Value

Type: TfrxByteArr

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.PutLine(Integer,TfrxByteArr) Method

Summary

Represents method PutLine(Integer,TfrxByteArr).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure PutLine(Index: Integer; const Value: TfrxByteArr);

Parameters

Index
Type: Integer

Value
Type: TfrxByteArr

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.SetAllAttributes(TfrxByteArr) Method

Summary

Represents method SetAllAttributes(TfrxByteArr).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure SetAllAttributes(Attr: TfrxByteArr);

Parameters

Attr
Type: TfrxByteArr

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.SetCapacity(Integer) Method

Summary

Represents method SetCapacity(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetCapacity(NewCapacity: Integer);

Parameters

NewCapacity
Type: Integer

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.SetCount(Integer) Method

Summary

Represents method SetCount(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetCount(NewCount: Integer);

Parameters

NewCount
Type: Integer

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.SetLineLen(Integer,Integer) Method

Summary

Represents method SetLineLen(Integer,Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure SetLineLen(Index: Integer; NewLen: Integer);

Parameters

Index
Type: Integer

NewLen
Type: Integer

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.UpdateSyntax(Integer,TStringList) Method

Summary

Represents method UpdateSyntax(Integer,TStringList).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure UpdateSyntax(EndLine: Integer; Text: TStringList);

Parameters

EndLine
Type: Integer

Text
Type: TStringList

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.UpdateSyntaxDialect Method

Summary

Represents method UpdateSyntaxDialect.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure UpdateSyntaxDialect;
See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes Fields

Fields
Name | Description
FArray | Represents field FArray.
FCapacity | Represents field FCapacity.
FCount | Represents field FCount.
FDialectStyles | Represents field FDialectStyles.
FParser | Represents field FParser.
FUpdating | Represents field FUpdating.
Top


TfrxSynAttributes.FArray Field

Summary

Represents field FArray.

Namespace: frxSynMemo
Syntax
Delphi
private
 FArray: array of TfrxByteArr;

Field Value

Type: array of TfrxByteArr

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.FCapacity Field

Summary

Represents field FCapacity.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCapacity: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.FCount Field

Summary

Represents field FCount.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.FDialectStyles Field

Summary

Represents field FDialectStyles.

Namespace: frxSynMemo
Syntax
Delphi
private
 FDialectStyles: TfrxSynDialectStyles;

Field Value

Type: TfrxSynDialectStyles

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.FParser Field

Summary

Represents field FParser.

Namespace: frxSynMemo
Syntax
Delphi
private
 FParser: TfsParser;

Field Value

Type: TfsParser

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynAttributes.FUpdating Field

Summary

Represents field FUpdating.

Namespace: frxSynMemo
Syntax
Delphi
private
 FUpdating: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSynAttributes
  • frxSynMemo


TfrxSynDialectStyle Class

Summary

Represents type TfrxSynDialectStyle.

Namespace: frxSynMemo
Inheritance Hierarchy
TPersistent
frxSynMemo.TfrxSynDialectStyle
Syntax
Delphi
type
 TfrxSynDialectStyle = class(TPersistent)
 end;

The TfrxSynDialectStyle type exposes the following members.

Constructors
Show:
Name | Description
Create(TObject) | Initializes a new instance of the TfrxSynDialectStyle class.
Destroy | Represents the destructor of the TfrxSynDialectStyle class.
Top
Properties
Show:
Name | Description
AttributeStyles | Represents property AttributeStyles.
CommentBlock1 | Represents property CommentBlock1.
CommentBlock2 | Represents property CommentBlock2.
CommentLine1 | Represents property CommentLine1.
CommentLine2 | Represents property CommentLine2.
HexSequence | Represents property HexSequence.
Keywords | Represents property Keywords.
Name | Represents property Name.
StringQuotes | Represents property StringQuotes.
Top
Methods
Show:
Name | Description
LoadFrom(String,TObject) | Represents method LoadFrom(String,TObject).
SaveTo(String,TObject) | Represents method SaveTo(String,TObject).
SetName(String) | Represents method SetName(String).
Top
Fields
Show:
Name | Description
FAttributeStyles | Represents field FAttributeStyles.
FCommentBlock1 | Represents field FCommentBlock1.
FCommentBlock2 | Represents field FCommentBlock2.
FCommentLine1 | Represents field FCommentLine1.
FCommentLine2 | Represents field FCommentLine2.
FHexSequence | Represents field FHexSequence.
FKeywords | Represents field FKeywords.
FName | Represents field FName.
FOwner | Represents field FOwner.
FStringQuotes | Represents field FStringQuotes.
Top
See Also

Reference

  • frxSynMemo


TfrxSynDialectStyle Constructors

Constructors
Name | Description
Create(TObject) | Initializes a new instance of the TfrxSynDialectStyle class.
Destroy | Represents the destructor of the TfrxSynDialectStyle class.
Top


TfrxSynDialectStyle.Create(TObject) Constructor

Summary

Initializes a new instance of the TfrxSynDialectStyle class.

Namespace: frxSynMemo
Syntax
Delphi
public
 constructor Create(AOwner: TObject);

Parameters

AOwner
Type: TObject

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.Destroy Destructor

Summary

Represents the destructor of the TfrxSynDialectStyle class.

Namespace: frxSynMemo
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle Properties

Properties
Name | Description
AttributeStyles | Represents property AttributeStyles.
CommentBlock1 | Represents property CommentBlock1.
CommentBlock2 | Represents property CommentBlock2.
CommentLine1 | Represents property CommentLine1.
CommentLine2 | Represents property CommentLine2.
HexSequence | Represents property HexSequence.
Keywords | Represents property Keywords.
Name | Represents property Name.
StringQuotes | Represents property StringQuotes.
Top


TfrxSynDialectStyle.AttributeStyles Property

Summary

Represents property AttributeStyles.

Namespace: frxSynMemo
Syntax
Delphi
public
 property AttributeStyles: TfrxAttributeStyles read FAttributeStyles;

Property Value

Type: TfrxAttributeStyles

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.CommentBlock1 Property

Summary

Represents property CommentBlock1.

Namespace: frxSynMemo
Syntax
Delphi
published
 property CommentBlock1: String read FCommentBlock1 write FCommentBlock1;

Property Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.CommentBlock2 Property

Summary

Represents property CommentBlock2.

Namespace: frxSynMemo
Syntax
Delphi
published
 property CommentBlock2: String read FCommentBlock2 write FCommentBlock2;

Property Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.CommentLine1 Property

Summary

Represents property CommentLine1.

Namespace: frxSynMemo
Syntax
Delphi
published
 property CommentLine1: String read FCommentLine1 write FCommentLine1;

Property Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.CommentLine2 Property

Summary

Represents property CommentLine2.

Namespace: frxSynMemo
Syntax
Delphi
published
 property CommentLine2: String read FCommentLine2 write FCommentLine2;

Property Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.HexSequence Property

Summary

Represents property HexSequence.

Namespace: frxSynMemo
Syntax
Delphi
published
 property HexSequence: String read FHexSequence write FHexSequence;

Property Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.Keywords Property

Summary

Represents property Keywords.

Namespace: frxSynMemo
Syntax
Delphi
published
 property Keywords: String read FKeywords write FKeywords;

Property Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.Name Property

Summary

Represents property Name.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Name: String read FName write SetName;

Property Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.StringQuotes Property

Summary

Represents property StringQuotes.

Namespace: frxSynMemo
Syntax
Delphi
published
 property StringQuotes: String read FStringQuotes write FStringQuotes;

Property Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle Methods

Methods
Name | Description
LoadFrom(String,TObject) | Represents method LoadFrom(String,TObject).
SaveTo(String,TObject) | Represents method SaveTo(String,TObject).
SetName(String) | Represents method SetName(String).
Top


TfrxSynDialectStyle.LoadFrom(String,TObject) Method

Summary

Represents method LoadFrom(String,TObject).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure LoadFrom(const Section: String; Ini: TObject);

Parameters

Section
Type: String

Ini
Type: TObject

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.SaveTo(String,TObject) Method

Summary

Represents method SaveTo(String,TObject).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure SaveTo(const Section: String; Ini: TObject);

Parameters

Section
Type: String

Ini
Type: TObject

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.SetName(String) Method

Summary

Represents method SetName(String).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle Fields

Fields
Name | Description
FAttributeStyles | Represents field FAttributeStyles.
FCommentBlock1 | Represents field FCommentBlock1.
FCommentBlock2 | Represents field FCommentBlock2.
FCommentLine1 | Represents field FCommentLine1.
FCommentLine2 | Represents field FCommentLine2.
FHexSequence | Represents field FHexSequence.
FKeywords | Represents field FKeywords.
FName | Represents field FName.
FOwner | Represents field FOwner.
FStringQuotes | Represents field FStringQuotes.
Top


TfrxSynDialectStyle.FAttributeStyles Field

Summary

Represents field FAttributeStyles.

Namespace: frxSynMemo
Syntax
Delphi
private
 FAttributeStyles: TfrxAttributeStyles;

Field Value

Type: TfrxAttributeStyles

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.FCommentBlock1 Field

Summary

Represents field FCommentBlock1.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCommentBlock1: String;

Field Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.FCommentBlock2 Field

Summary

Represents field FCommentBlock2.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCommentBlock2: String;

Field Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.FCommentLine1 Field

Summary

Represents field FCommentLine1.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCommentLine1: String;

Field Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.FCommentLine2 Field

Summary

Represents field FCommentLine2.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCommentLine2: String;

Field Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.FHexSequence Field

Summary

Represents field FHexSequence.

Namespace: frxSynMemo
Syntax
Delphi
private
 FHexSequence: String;

Field Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.FKeywords Field

Summary

Represents field FKeywords.

Namespace: frxSynMemo
Syntax
Delphi
private
 FKeywords: String;

Field Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.FName Field

Summary

Represents field FName.

Namespace: frxSynMemo
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.FOwner Field

Summary

Represents field FOwner.

Namespace: frxSynMemo
Syntax
Delphi
private
 FOwner: TObject;

Field Value

Type: TObject

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyle.FStringQuotes Field

Summary

Represents field FStringQuotes.

Namespace: frxSynMemo
Syntax
Delphi
private
 FStringQuotes: String;

Field Value

Type: String

See Also

Reference

  • TfrxSynDialectStyle
  • frxSynMemo


TfrxSynDialectStyles Class

Summary

Represents type TfrxSynDialectStyles.

Namespace: frxSynMemo
Inheritance Hierarchy
TObject
frxSynMemo.TfrxSynDialectStyles
Syntax
Delphi
type
 TfrxSynDialectStyles = class(TObject)
 end;

The TfrxSynDialectStyles type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxSynDialectStyles class.
Destroy | Represents the destructor of the TfrxSynDialectStyles class.
Top
Properties
Show:
Name | Description
ActiveDialicet | Represents property ActiveDialicet.
ActiveIndex | Represents property ActiveIndex.
ActiveStyles | Represents property ActiveStyles.
Items[Integer] | Represents property Items[Integer].
OnActiveChanged | Represents property OnActiveChanged.
Top
Methods
Show:
Name | Description
Add | Represents method Add.
Clear | Represents method Clear.
Count | Represents method Count.
GetActiveDialicet | Represents method GetActiveDialicet.
GetActiveStyles | Represents method GetActiveStyles.
GetItem(Integer) | Represents method GetItem(Integer).
LoadFrom(String,TObject) | Represents method LoadFrom(String,TObject).
SaveTo(String,TObject) | Represents method SaveTo(String,TObject).
SetActiveIndex(Integer) | Represents method SetActiveIndex(Integer).
Top
Fields
Show:
Name | Description
FActiveChanged | Represents field FActiveChanged.
FActiveIndex | Represents field FActiveIndex.
FDefSynDialectStyle | Represents field FDefSynDialectStyle.
FLIst | Represents field FLIst.
Top
See Also

Reference

  • frxSynMemo


TfrxSynDialectStyles Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxSynDialectStyles class.
Destroy | Represents the destructor of the TfrxSynDialectStyles class.
Top


TfrxSynDialectStyles.Create Constructor

Summary

Initializes a new instance of the TfrxSynDialectStyles class.

Namespace: frxSynMemo
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.Destroy Destructor

Summary

Represents the destructor of the TfrxSynDialectStyles class.

Namespace: frxSynMemo
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles Properties

Properties
Name | Description
ActiveDialicet | Represents property ActiveDialicet.
ActiveIndex | Represents property ActiveIndex.
ActiveStyles | Represents property ActiveStyles.
Items[Integer] | Represents property Items[Integer].
OnActiveChanged | Represents property OnActiveChanged.
Top


TfrxSynDialectStyles.ActiveDialicet Property

Summary

Represents property ActiveDialicet.

Namespace: frxSynMemo
Syntax
Delphi
public
 property ActiveDialicet: TfrxSynDialectStyle read GetActiveDialicet;

Property Value

Type: TfrxSynDialectStyle

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.ActiveIndex Property

Summary

Represents property ActiveIndex.

Namespace: frxSynMemo
Syntax
Delphi
public
 property ActiveIndex: Integer read FActiveIndex write SetActiveIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.ActiveStyles Property

Summary

Represents property ActiveStyles.

Namespace: frxSynMemo
Syntax
Delphi
public
 property ActiveStyles: TfrxAttributeStyles read GetActiveStyles;

Property Value

Type: TfrxAttributeStyles

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxSynMemo
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxSynDialectStyle read GetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxSynDialectStyle

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.OnActiveChanged Property

Summary

Represents property OnActiveChanged.

Namespace: frxSynMemo
Syntax
Delphi
public
 property OnActiveChanged: TNotifyEvent read FActiveChanged write FActiveChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles Methods

Methods
Name | Description
Add | Represents method Add.
Clear | Represents method Clear.
Count | Represents method Count.
GetActiveDialicet | Represents method GetActiveDialicet.
GetActiveStyles | Represents method GetActiveStyles.
GetItem(Integer) | Represents method GetItem(Integer).
LoadFrom(String,TObject) | Represents method LoadFrom(String,TObject).
SaveTo(String,TObject) | Represents method SaveTo(String,TObject).
SetActiveIndex(Integer) | Represents method SetActiveIndex(Integer).
Top


TfrxSynDialectStyles.Add Method

Summary

Represents method Add.

Namespace: frxSynMemo
Syntax
Delphi
public
 function Add: TfrxSynDialectStyle;

Return Value

Type: TfrxSynDialectStyle

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.Clear Method

Summary

Represents method Clear.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.Count Method

Summary

Represents method Count.

Namespace: frxSynMemo
Syntax
Delphi
public
 function Count: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.GetActiveDialicet Method

Summary

Represents method GetActiveDialicet.

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetActiveDialicet: TfrxSynDialectStyle;

Return Value

Type: TfrxSynDialectStyle

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.GetActiveStyles Method

Summary

Represents method GetActiveStyles.

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetActiveStyles: TfrxAttributeStyles;

Return Value

Type: TfrxAttributeStyles

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetItem(Index: Integer): TfrxSynDialectStyle;

Parameters

Index
Type: Integer

Return Value

Type: TfrxSynDialectStyle

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.LoadFrom(String,TObject) Method

Summary

Represents method LoadFrom(String,TObject).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure LoadFrom(const Section: String; Ini: TObject);

Parameters

Section
Type: String

Ini
Type: TObject

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.SaveTo(String,TObject) Method

Summary

Represents method SaveTo(String,TObject).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure SaveTo(const Section: String; Ini: TObject);

Parameters

Section
Type: String

Ini
Type: TObject

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.SetActiveIndex(Integer) Method

Summary

Represents method SetActiveIndex(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetActiveIndex(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles Fields

Fields
Name | Description
FActiveChanged | Represents field FActiveChanged.
FActiveIndex | Represents field FActiveIndex.
FDefSynDialectStyle | Represents field FDefSynDialectStyle.
FLIst | Represents field FLIst.
Top


TfrxSynDialectStyles.FActiveChanged Field

Summary

Represents field FActiveChanged.

Namespace: frxSynMemo
Syntax
Delphi
private
 FActiveChanged: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.FActiveIndex Field

Summary

Represents field FActiveIndex.

Namespace: frxSynMemo
Syntax
Delphi
private
 FActiveIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.FDefSynDialectStyle Field

Summary

Represents field FDefSynDialectStyle.

Namespace: frxSynMemo
Syntax
Delphi
private
 FDefSynDialectStyle: TfrxSynDialectStyle;

Field Value

Type: TfrxSynDialectStyle

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSynDialectStyles.FLIst Field

Summary

Represents field FLIst.

Namespace: frxSynMemo
Syntax
Delphi
private
 FLIst: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxSynDialectStyles
  • frxSynMemo


TfrxSyntaxMemo Class

Summary

Represents type TfrxSyntaxMemo.

Namespace: frxSynMemo
Inheritance Hierarchy
TCustomControl
frxCtrls.TfrxScrollWin
frxSynMemo.TfrxSyntaxMemo
Syntax
Delphi
type
 TfrxSyntaxMemo = class(TfrxScrollWin)
 end;

The TfrxSyntaxMemo type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxSyntaxMemo class. (Overrides TfrxScrollWin.Create(TComponent).)
Destroy | Represents the destructor of the TfrxSyntaxMemo class.
Top
Properties
Show:
Name | Description
ActiveLine | Represents property ActiveLine.
AttributeStyles | Represents property AttributeStyles.
BevelKind | Represents property BevelKind. (Inherited from TfrxScrollWin.)
BlockColor | Represents property BlockColor.
BlockFontColor | Represents property BlockFontColor.
BorderStyle | Represents property BorderStyle. (Inherited from TfrxScrollWin.)
BreakPoints | Represents property BreakPoints.
CodeCompletionHeight | Represents property CodeCompletionHeight.
CodeCompletionMinHeight | Represents property CodeCompletionMinHeight.
CodeCompletionMinWidth | Represents property CodeCompletionMinWidth.
CodeCompletionThread | Represents property CodeCompletionThread.
CodeCompletionWidth | Represents property CodeCompletionWidth.
CodeComplitionFilter | Represents property CodeComplitionFilter.
Color | Represents property Color.
CommentAttr | Represents property CommentAttr.
Font | Represents property Font.
GutterWidth | Represents property GutterWidth.
HideScrolls | Represents property HideScrolls. (Inherited from TfrxScrollWin.)
HorzPage | Represents property HorzPage. (Inherited from TfrxScrollWin.)
HorzPosition | Represents property HorzPosition. (Inherited from TfrxScrollWin.)
HorzRange | Represents property HorzRange. (Inherited from TfrxScrollWin.)
ImeMode | Represents property ImeMode.
ImeName | Represents property ImeName.
KeywordAttr | Represents property KeywordAttr.
LargeChange | Represents property LargeChange. (Inherited from TfrxScrollWin.)
Lines | Represents property Lines.
Modified | Represents property Modified.
MultiByteLang | Represents property MultiByteLang.
NumberAttr | Represents property NumberAttr.
OnChangePos | Represents property OnChangePos.
OnChangeText | Represents property OnChangeText.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnKeyDown | Represents property OnKeyDown.
PopupMenu | Represents property PopupMenu.
RunLine[Integer] | Represents property RunLine[Integer].
Script | Represents property Script.
ScriptRTTIXML | Represents property ScriptRTTIXML.
SelText | Represents property SelText.
ShowGutter | Represents property ShowGutter.
ShowInCodeComplition | Represents property ShowInCodeComplition.
ShowLineNumber | Represents property ShowLineNumber.
SmallChange | Represents property SmallChange. (Inherited from TfrxScrollWin.)
StringAttr | Represents property StringAttr.
SynDialectStyles | Represents property SynDialectStyles.
Syntax | Represents property Syntax.
TabStops | Represents property TabStops.
TextAttr | Represents property TextAttr.
TextSelected | Represents property TextSelected.
VertPage | Represents property VertPage. (Inherited from TfrxScrollWin.)
VertPosition | Represents property VertPosition. (Inherited from TfrxScrollWin.)
VertRange | Represents property VertRange. (Inherited from TfrxScrollWin.)
Top
Methods
Show:
Name | Description
AddBookmark(Integer,Integer) | Represents method AddBookmark(Integer,Integer).
AddBreakPoint(Integer,String,String) | Represents method AddBreakPoint(Integer,String,String).
AddNewBreakPoint | Represents method AddNewBreakPoint.
AddSel | Represents method AddSel.
AddUndo | Represents method AddUndo.
BuildCClist(String) | Represents method BuildCClist(String).
ClearBreakPoints | Represents method ClearBreakPoints.
ClearSel | Represents method ClearSel.
ClearSyntax(Integer) | Represents method ClearSyntax(Integer).
CMFontChanged(TMessage) | Represents method CMFontChanged(TMessage).
CompletionClose | Represents method CompletionClose.
CompletionFormClose(TObject,TCloseAction) | Represents method CompletionFormClose(TObject,TCloseAction).
CompletionLBDblClick(TObject) | Represents method CompletionLBDblClick(TObject).
CompletionLBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) | Represents method CompletionLBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).
CompletionLBKeyDown(TObject,Word,TShiftState) | Represents method CompletionLBKeyDown(TObject,Word,TShiftState).
CompletionLBKeyPress(TObject,Char) | Represents method CompletionLBKeyPress(TObject,Char).
CopyToClipboard | Represents method CopyToClipboard.
CorrectBookmark(Integer,Integer) | Represents method CorrectBookmark(Integer,Integer).
CorrectBreakPoints(Integer,Integer) | Represents method CorrectBreakPoints(Integer,Integer).
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams). (Inherited from TfrxScrollWin.)
CreateSynArray(Integer) | Represents method CreateSynArray(Integer).
CutToClipboard | Represents method CutToClipboard.
DblClick | Represents method DblClick.
DeleteBookmark(Integer) | Represents method DeleteBookmark(Integer).
DeleteBreakPoint(Integer) | Represents method DeleteBreakPoint(Integer).
DeleteF4BreakPoints | Represents method DeleteF4BreakPoints.
DoBackspace | Represents method DoBackspace.
DoChange | Represents method DoChange.
DoChar(Char) | Represents method DoChar(Char).
DoCodeCompletion | Represents method DoCodeCompletion.
DoCtrlI | Represents method DoCtrlI.
DoCtrlL | Represents method DoCtrlL.
DoCtrlR | Represents method DoCtrlR.
DoCtrlU | Represents method DoCtrlU.
DoDel | Represents method DoDel.
DoDown | Represents method DoDown.
DoEnd(Boolean) | Represents method DoEnd(Boolean).
DoHome(Boolean) | Represents method DoHome(Boolean).
DoLeft | Represents method DoLeft.
DoPgDn | Represents method DoPgDn.
DoPgUp | Represents method DoPgUp.
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Overrides TfrxScrollWin.DoPPIChanged(Integer).)
DoReturn | Represents method DoReturn.
DoRight | Represents method DoRight.
DoTimer(TObject) | Represents method DoTimer(TObject).
DoUp | Represents method DoUp.
EnterIndent | Represents method EnterIndent.
FillRtti | Represents method FillRtti.
Find(String,Boolean,Integer) | Represents method Find(String,Boolean,Integer).
GetAttributeStyles | Represents method GetAttributeStyles.
GetBreakPointCondition(Integer) | Represents method GetBreakPointCondition(Integer).
GetBreakPointSpecialCondition(Integer) | Represents method GetBreakPointSpecialCondition(Integer).
GetCharAttr(TPoint) | Represents method GetCharAttr(TPoint).
GetCharWidth(String) | Represents method GetCharWidth(String).
GetCharXPos(Integer) | Represents method GetCharXPos(Integer).
GetCompletionString | Represents method GetCompletionString.
GetFilter(String) | Represents method GetFilter(String).
GetIdentEnd(Integer) | Represents method GetIdentEnd(Integer).
GetLineBegin(Integer) | Represents method GetLineBegin(Integer).
GetPlainPos | Represents method GetPlainPos.
GetPlainTextPos(TPoint) | Represents method GetPlainTextPos(TPoint).
GetPos | Represents method GetPos.
GetPosPlainText(Integer) | Represents method GetPosPlainText(Integer).
GetRunLine(Integer) | Represents method GetRunLine(Integer).
GetScale | Represents method GetScale. (Inherited from TfrxScrollWin.)
GetScaledFontSize | Represents method GetScaledFontSize. (Inherited from TfrxScrollWin.)
GetSelText | Represents method GetSelText.
GetText | Represents method GetText.
GetTextSelected | Represents method GetTextSelected.
GotoBookmark(Integer) | Represents method GotoBookmark(Integer).
IsActiveBreakPoint(Integer) | Represents method IsActiveBreakPoint(Integer).
IsBookmark(Integer) | Represents method IsBookmark(Integer).
IsBreakPoint(Integer) | Represents method IsBreakPoint(Integer).
IsCursorInStringBlock | Represents method IsCursorInStringBlock.
KeyDown(Word,TShiftState) | Represents method KeyDown(Word,TShiftState).
KeyPress(Char) | Represents method KeyPress(Char).
LineAt(Integer,Boolean) | Represents method LineAt(Integer,Boolean).
LineLength(Integer) | Represents method LineLength(Integer).
LinesChange(TObject) | Represents method LinesChange(TObject).
LoadFromIni(String,String,String) | Represents method LoadFromIni(String,String,String).
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
MouseWheelDown(TObject,TShiftState,TPoint,Boolean) | Represents method MouseWheelDown(TObject,TShiftState,TPoint,Boolean).
MouseWheelUp(TObject,TShiftState,TPoint,Boolean) | Represents method MouseWheelUp(TObject,TShiftState,TPoint,Boolean).
OnHScrollChange(TObject) | Represents method OnHScrollChange(TObject). (Overrides TfrxScrollWin.OnHScrollChange(TObject).)
OnVScrollChange(TObject) | Represents method OnVScrollChange(TObject). (Overrides TfrxScrollWin.OnVScrollChange(TObject).)
Pad(Integer) | Represents method Pad(Integer).
Paint | Represents method Paint. (Overrides TfrxScrollWin.Paint.)
PasteFromClipboard | Represents method PasteFromClipboard.
PopCopy(TObject) | Represents method PopCopy(TObject).
PopCut(TObject) | Represents method PopCut(TObject).
PopDelete(TObject) | Represents method PopDelete(TObject).
PopPaste(TObject) | Represents method PopPaste(TObject).
PopSelectAll(TObject) | Represents method PopSelectAll(TObject).
Resize | Represents method Resize.
SaveToIni(String,String,String) | Represents method SaveToIni(String,String,String).
SelectAll | Represents method SelectAll.
SetActiveLine(Integer) | Represents method SetActiveLine(Integer).
SetCodeCompletionHeight(Integer) | Represents method SetCodeCompletionHeight(Integer).
SetCodeCompletionMinHeight(Integer) | Represents method SetCodeCompletionMinHeight(Integer).
SetCodeCompletionMinWidth(Integer) | Represents method SetCodeCompletionMinWidth(Integer).
SetCodeCompletionWidth(Integer) | Represents method SetCodeCompletionWidth(Integer).
SetCommentAttr(TFont) | Represents method SetCommentAttr(TFont).
SetGutterWidth(Integer) | Represents method SetGutterWidth(Integer).
SetKeywordAttr(TFont) | Represents method SetKeywordAttr(TFont).
SetNumberAttr(TFont) | Represents method SetNumberAttr(TFont).
SetPos(Integer,Integer) | Represents method SetPos(Integer,Integer).
SetPosByCoords(Integer,Integer) | Represents method SetPosByCoords(Integer,Integer).
SetRunLine(Integer,Boolean) | Represents method SetRunLine(Integer,Boolean).
SetScaledFontSize(Integer) | Represents method SetScaledFontSize(Integer). (Inherited from TfrxScrollWin.)
SetSelText(String) | Represents method SetSelText(String).
SetShowGutter(Boolean) | Represents method SetShowGutter(Boolean).
SetShowInCodeComplition(TfrxCompletionListTypes) | Represents method SetShowInCodeComplition(TfrxCompletionListTypes).
SetStringAttr(TFont) | Represents method SetStringAttr(TFont).
SetSyntax(String) | Represents method SetSyntax(String).
SetText(TStrings) | Represents method SetText(TStrings).
SetTextAttr(TFont) | Represents method SetTextAttr(TFont).
ShiftSelected(Boolean) | Represents method ShiftSelected(Boolean).
ShowCaretPos | Represents method ShowCaretPos.
ShowMessage(String) | Represents method ShowMessage(String).
TabIndent | Represents method TabIndent.
ToggleBreakPoint(Integer,String) | Represents method ToggleBreakPoint(Integer,String).
Undo | Represents method Undo.
UnIndent | Represents method UnIndent.
UpdateScrollBar | Represents method UpdateScrollBar.
UpdateView | Represents method UpdateView.
WMDpiChanged(TMessage) | Represents method WMDpiChanged(TMessage). (Inherited from TfrxScrollWin.)
WMFRXFillCodeCompletion(TMessage) | Represents method WMFRXFillCodeCompletion(TMessage).
WMFRXSyncScript(TMessage) | Represents method WMFRXSyncScript(TMessage).
WMFRXUpdateCode(TMessage) | Represents method WMFRXUpdateCode(TMessage).
WMIMECOMPOSITION(TMessage) | Represents method WMIMECOMPOSITION(TMessage).
WMIMEEndComp(TMessage) | Represents method WMIMEEndComp(TMessage).
WMIMEStartComp(TMessage) | Represents method WMIMEStartComp(TMessage).
WMKillFocus(TWMKillFocus) | Represents method WMKillFocus(TWMKillFocus).
WMSetFocus(TWMSetFocus) | Represents method WMSetFocus(TWMSetFocus).
Top
Events
Show:
Name | Description
OnCodeCompletion | Represents property OnCodeCompletion.
OnScrollMaxChange | Represents property OnScrollMaxChange. (Inherited from TfrxScrollWin.)
OnScrollPosChange | Represents property OnScrollPosChange. (Inherited from TfrxScrollWin.)
Top
Fields
Show:
Name | Description
FActiveLine | Represents field FActiveLine.
FAddonCompletionList | Represents field FAddonCompletionList.
FAllowLinesChange | Represents field FAllowLinesChange.
FBlockColor | Represents field FBlockColor.
FBlockFontColor | Represents field FBlockFontColor.
FBookmarks | Represents field FBookmarks.
FBreakPoints | Represents field FBreakPoints.
FCharHeight | Represents field FCharHeight.
FCharWidth | Represents field FCharWidth.
FClassCompletionList | Represents field FClassCompletionList.
FCodeCompletionHeight | Represents field FCodeCompletionHeight.
FCodeCompletionMinHeight | Represents field FCodeCompletionMinHeight.
FCodeCompletionMinWidth | Represents field FCodeCompletionMinWidth.
FCodeCompletionThread | Represents field FCodeCompletionThread.
FCodeCompletionWidth | Represents field FCodeCompletionWidth.
FCodeCompList | Represents field FCodeCompList.
FCodeComplitionFilter | Represents field FCodeComplitionFilter.
FCommentAttr | Represents field FCommentAttr.
FCompleationFilter | Represents field FCompleationFilter.
FCompletionForm | Represents field FCompletionForm.
FCompletionLB | Represents field FCompletionLB.
FCompSelEnd | Represents field FCompSelEnd.
FCompSelStart | Represents field FCompSelStart.
FCurrentPPI | Represents field FCurrentPPI. (Inherited from TfrxScrollWin.)
FDoubleClicked | Represents field FDoubleClicked.
FDown | Represents field FDown.
FGutterWidth | Represents field FGutterWidth.
FIsMonoType | Represents field FIsMonoType.
FKeywordAttr | Represents field FKeywordAttr.
FMaxLength | Represents field FMaxLength.
FMessage | Represents field FMessage.
FModified | Represents field FModified.
FMoved | Represents field FMoved.
FMultiByteLang | Represents field FMultiByteLang.
FNumberAttr | Represents field FNumberAttr.
FOffset | Represents field FOffset.
FOnChangePos | Represents field FOnChangePos.
FOnChangeText | Represents field FOnChangeText.
FOnCodeCompletion | Represents field FOnCodeCompletion.
FParser | Represents field FParser.
FPos | Represents field FPos.
FRttiCompletionList | Represents field FRttiCompletionList.
FScript | Represents field FScript.
FScriptCompletionList | Represents field FScriptCompletionList.
FScriptRTTIXML | Represents field FScriptRTTIXML.
FSelEnd | Represents field FSelEnd.
FSelStart | Represents field FSelStart.
FShowGutter | Represents field FShowGutter.
FShowInCodeComplition | Represents field FShowInCodeComplition.
FShowLineNumber | Represents field FShowLineNumber.
FStartCodeCompPos | Represents field FStartCodeCompPos.
FStringAttr | Represents field FStringAttr.
FSynAttributes | Represents field FSynAttributes.
FSynDialectStyles | Represents field FSynDialectStyles.
FSyntax | Represents field FSyntax.
FTabStops | Represents field FTabStops.
FTempPos | Represents field FTempPos.
FText | Represents field FText.
FTextAttr | Represents field FTextAttr.
FTimer | Represents field FTimer.
FTmpCanvas | Represents field FTmpCanvas.
FToggleBreakPointDown | Represents field FToggleBreakPointDown.
FUndo | Represents field FUndo.
FWindowSize | Represents field FWindowSize.
Top
See Also

Reference

  • frxSynMemo


TfrxSyntaxMemo Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxSyntaxMemo class. (Overrides TfrxScrollWin.Create(TComponent).)
Destroy | Represents the destructor of the TfrxSyntaxMemo class.
Top


TfrxSyntaxMemo.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxSyntaxMemo class.

Namespace: frxSynMemo
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxScrollWin.Create(TComponent)
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.Destroy Destructor

Summary

Represents the destructor of the TfrxSyntaxMemo class.

Namespace: frxSynMemo
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo Properties

Properties
Name | Description
ActiveLine | Represents property ActiveLine.
AttributeStyles | Represents property AttributeStyles.
BlockColor | Represents property BlockColor.
BlockFontColor | Represents property BlockFontColor.
BreakPoints | Represents property BreakPoints.
CodeCompletionHeight | Represents property CodeCompletionHeight.
CodeCompletionMinHeight | Represents property CodeCompletionMinHeight.
CodeCompletionMinWidth | Represents property CodeCompletionMinWidth.
CodeCompletionThread | Represents property CodeCompletionThread.
CodeCompletionWidth | Represents property CodeCompletionWidth.
CodeComplitionFilter | Represents property CodeComplitionFilter.
Color | Represents property Color.
CommentAttr | Represents property CommentAttr.
Font | Represents property Font.
GutterWidth | Represents property GutterWidth.
ImeMode | Represents property ImeMode.
ImeName | Represents property ImeName.
KeywordAttr | Represents property KeywordAttr.
Lines | Represents property Lines.
Modified | Represents property Modified.
MultiByteLang | Represents property MultiByteLang.
NumberAttr | Represents property NumberAttr.
OnChangePos | Represents property OnChangePos.
OnChangeText | Represents property OnChangeText.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnKeyDown | Represents property OnKeyDown.
PopupMenu | Represents property PopupMenu.
RunLine[Integer] | Represents property RunLine[Integer].
Script | Represents property Script.
ScriptRTTIXML | Represents property ScriptRTTIXML.
SelText | Represents property SelText.
ShowGutter | Represents property ShowGutter.
ShowInCodeComplition | Represents property ShowInCodeComplition.
ShowLineNumber | Represents property ShowLineNumber.
StringAttr | Represents property StringAttr.
SynDialectStyles | Represents property SynDialectStyles.
Syntax | Represents property Syntax.
TabStops | Represents property TabStops.
TextAttr | Represents property TextAttr.
TextSelected | Represents property TextSelected.
Top


TfrxSyntaxMemo.ActiveLine Property

Summary

Represents property ActiveLine.

Namespace: frxSynMemo
Syntax
Delphi
public
 property ActiveLine: Integer read FActiveLine write SetActiveLine;

Property Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.AttributeStyles Property

Summary

Represents property AttributeStyles.

Namespace: frxSynMemo
Syntax
Delphi
public
 property AttributeStyles: TfrxAttributeStyles read GetAttributeStyles;

Property Value

Type: TfrxAttributeStyles

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.BlockColor Property

Summary

Represents property BlockColor.

Namespace: frxSynMemo
Syntax
Delphi
public
 property BlockColor: TColor read FBlockColor write FBlockColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.BlockFontColor Property

Summary

Represents property BlockFontColor.

Namespace: frxSynMemo
Syntax
Delphi
public
 property BlockFontColor: TColor read FBlockFontColor write FBlockFontColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.BreakPoints Property

Summary

Represents property BreakPoints.

Namespace: frxSynMemo
Syntax
Delphi
public
 property BreakPoints:TStringList read FBreakPoints;

Property Value

Type: TStringList

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CodeCompletionHeight Property

Summary

Represents property CodeCompletionHeight.

Namespace: frxSynMemo
Syntax
Delphi
public
 property CodeCompletionHeight: Integer read FCodeCompletionHeight write SetCodeCompletionHeight default 100;

Property Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CodeCompletionMinHeight Property

Summary

Represents property CodeCompletionMinHeight.

Namespace: frxSynMemo
Syntax
Delphi
public
 property CodeCompletionMinHeight: Integer read FCodeCompletionMinHeight write SetCodeCompletionMinHeight default 100;

Property Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CodeCompletionMinWidth Property

Summary

Represents property CodeCompletionMinWidth.

Namespace: frxSynMemo
Syntax
Delphi
public
 property CodeCompletionMinWidth: Integer read FCodeCompletionMinWidth write SetCodeCompletionMinWidth default 300;

Property Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CodeCompletionThread Property

Summary

Represents property CodeCompletionThread.

Namespace: frxSynMemo
Syntax
Delphi
public
 property CodeCompletionThread: TfrxCodeCompletionThread read FCodeCompletionThread;

Property Value

Type: TfrxCodeCompletionThread

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CodeCompletionWidth Property

Summary

Represents property CodeCompletionWidth.

Namespace: frxSynMemo
Syntax
Delphi
public
 property CodeCompletionWidth: Integer read FCodeCompletionWidth write SetCodeCompletionWidth default 300;

Property Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CodeComplitionFilter Property

Summary

Represents property CodeComplitionFilter.

Namespace: frxSynMemo
Syntax
Delphi
public
 property CodeComplitionFilter: TfrxItemTypes read FCodeComplitionFilter write FCodeComplitionFilter;

Property Value

Type: TfrxItemTypes

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.Color Property

Summary

Represents property Color.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CommentAttr Property

Summary

Represents property CommentAttr.

Namespace: frxSynMemo
Syntax
Delphi
public
 property CommentAttr: TFont read FCommentAttr write SetCommentAttr;

Property Value

Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.Font Property

Summary

Represents property Font.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GutterWidth Property

Summary

Represents property GutterWidth.

Namespace: frxSynMemo
Syntax
Delphi
public
 property GutterWidth: Integer read FGutterWidth write SetGutterWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ImeMode Property

Summary

Represents property ImeMode.

Namespace: frxSynMemo
Syntax
Delphi
public
 property ImeMode;

Property Value

Type: Void

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ImeName Property

Summary

Represents property ImeName.

Namespace: frxSynMemo
Syntax
Delphi
public
 property ImeName;

Property Value

Type: Void

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.KeywordAttr Property

Summary

Represents property KeywordAttr.

Namespace: frxSynMemo
Syntax
Delphi
public
 property KeywordAttr: TFont read FKeywordAttr write SetKeywordAttr;

Property Value

Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.Lines Property

Summary

Represents property Lines.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Lines: TStrings read GetText write SetText;

Property Value

Type: TStrings

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.Modified Property

Summary

Represents property Modified.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Modified: Boolean read FModified write FModified;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.MultiByteLang Property

Summary

Represents property MultiByteLang.

Namespace: frxSynMemo
Syntax
Delphi
public
 property MultiByteLang: Boolean read FMultiByteLang write FMultiByteLang;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.NumberAttr Property

Summary

Represents property NumberAttr.

Namespace: frxSynMemo
Syntax
Delphi
public
 property NumberAttr: TFont read FNumberAttr write SetNumberAttr;

Property Value

Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.OnChangePos Property

Summary

Represents property OnChangePos.

Namespace: frxSynMemo
Syntax
Delphi
public
 property OnChangePos: TNotifyEvent read FOnChangePos write FOnChangePos;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.OnChangeText Property

Summary

Represents property OnChangeText.

Namespace: frxSynMemo
Syntax
Delphi
public
 property OnChangeText: TNotifyEvent read FOnChangeText write FOnChangeText;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.OnDragDrop Property

Summary

Represents property OnDragDrop.

Namespace: frxSynMemo
Syntax
Delphi
public
 property OnDragDrop;

Property Value

Type: Void

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.OnDragOver Property

Summary

Represents property OnDragOver.

Namespace: frxSynMemo
Syntax
Delphi
public
 property OnDragOver;

Property Value

Type: Void

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxSynMemo
Syntax
Delphi
public
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: frxSynMemo
Syntax
Delphi
public
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.RunLine[Integer] Property

Summary

Represents property RunLine[Integer].

Namespace: frxSynMemo
Syntax
Delphi
public
 property RunLine[Index: Integer]: Boolean read GetRunLine write SetRunLine;

Parameters

Index
Type: Integer

Property Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.Script Property

Summary

Represents property Script.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Script: TfsScript read FScript write FScript;

Property Value

Type: TfsScript

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ScriptRTTIXML Property

Summary

Represents property ScriptRTTIXML.

Namespace: frxSynMemo
Syntax
Delphi
public
 property ScriptRTTIXML: TfsXMLDocument read FScriptRTTIXML;

Property Value

Type: TfsXMLDocument

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SelText Property

Summary

Represents property SelText.

Namespace: frxSynMemo
Syntax
Delphi
public
 property SelText: String read GetSelText write SetSelText;

Property Value

Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ShowGutter Property

Summary

Represents property ShowGutter.

Namespace: frxSynMemo
Syntax
Delphi
public
 property ShowGutter: Boolean read FShowGutter write SetShowGutter;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ShowInCodeComplition Property

Summary

Represents property ShowInCodeComplition.

Namespace: frxSynMemo
Syntax
Delphi
public
 property ShowInCodeComplition: TfrxCompletionListTypes read FShowInCodeComplition write SetShowInCodeComplition;

Property Value

Type: TfrxCompletionListTypes

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ShowLineNumber Property

Summary

Represents property ShowLineNumber.

Namespace: frxSynMemo
Syntax
Delphi
public
 property ShowLineNumber: Boolean read FShowLineNumber write FShowLineNumber;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.StringAttr Property

Summary

Represents property StringAttr.

Namespace: frxSynMemo
Syntax
Delphi
public
 property StringAttr: TFont read FStringAttr write SetStringAttr;

Property Value

Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SynDialectStyles Property

Summary

Represents property SynDialectStyles.

Namespace: frxSynMemo
Syntax
Delphi
public
 property SynDialectStyles: TfrxSynDialectStyles read FSynDialectStyles;

Property Value

Type: TfrxSynDialectStyles

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.Syntax Property

Summary

Represents property Syntax.

Namespace: frxSynMemo
Syntax
Delphi
public
 property Syntax: String read FSyntax write SetSyntax;

Property Value

Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.TabStops Property

Summary

Represents property TabStops.

Namespace: frxSynMemo
Syntax
Delphi
public
 property TabStops: Integer read FTabStops write FTabStops;

Property Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.TextAttr Property

Summary

Represents property TextAttr.

Namespace: frxSynMemo
Syntax
Delphi
public
 property TextAttr: TFont read FTextAttr write SetTextAttr;

Property Value

Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.TextSelected Property

Summary

Represents property TextSelected.

Namespace: frxSynMemo
Syntax
Delphi
public
 property TextSelected: Boolean read GetTextSelected;

Property Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo Methods

Methods
Name | Description
AddBookmark(Integer,Integer) | Represents method AddBookmark(Integer,Integer).
AddBreakPoint(Integer,String,String) | Represents method AddBreakPoint(Integer,String,String).
AddNewBreakPoint | Represents method AddNewBreakPoint.
AddSel | Represents method AddSel.
AddUndo | Represents method AddUndo.
BuildCClist(String) | Represents method BuildCClist(String).
ClearBreakPoints | Represents method ClearBreakPoints.
ClearSel | Represents method ClearSel.
ClearSyntax(Integer) | Represents method ClearSyntax(Integer).
CMFontChanged(TMessage) | Represents method CMFontChanged(TMessage).
CompletionClose | Represents method CompletionClose.
CompletionFormClose(TObject,TCloseAction) | Represents method CompletionFormClose(TObject,TCloseAction).
CompletionLBDblClick(TObject) | Represents method CompletionLBDblClick(TObject).
CompletionLBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) | Represents method CompletionLBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).
CompletionLBKeyDown(TObject,Word,TShiftState) | Represents method CompletionLBKeyDown(TObject,Word,TShiftState).
CompletionLBKeyPress(TObject,Char) | Represents method CompletionLBKeyPress(TObject,Char).
CopyToClipboard | Represents method CopyToClipboard.
CorrectBookmark(Integer,Integer) | Represents method CorrectBookmark(Integer,Integer).
CorrectBreakPoints(Integer,Integer) | Represents method CorrectBreakPoints(Integer,Integer).
CreateSynArray(Integer) | Represents method CreateSynArray(Integer).
CutToClipboard | Represents method CutToClipboard.
DblClick | Represents method DblClick.
DeleteBookmark(Integer) | Represents method DeleteBookmark(Integer).
DeleteBreakPoint(Integer) | Represents method DeleteBreakPoint(Integer).
DeleteF4BreakPoints | Represents method DeleteF4BreakPoints.
DoBackspace | Represents method DoBackspace.
DoChange | Represents method DoChange.
DoChar(Char) | Represents method DoChar(Char).
DoCodeCompletion | Represents method DoCodeCompletion.
DoCtrlI | Represents method DoCtrlI.
DoCtrlL | Represents method DoCtrlL.
DoCtrlR | Represents method DoCtrlR.
DoCtrlU | Represents method DoCtrlU.
DoDel | Represents method DoDel.
DoDown | Represents method DoDown.
DoEnd(Boolean) | Represents method DoEnd(Boolean).
DoHome(Boolean) | Represents method DoHome(Boolean).
DoLeft | Represents method DoLeft.
DoPgDn | Represents method DoPgDn.
DoPgUp | Represents method DoPgUp.
DoPPIChanged(Integer) | Represents method DoPPIChanged(Integer). (Overrides TfrxScrollWin.DoPPIChanged(Integer).)
DoReturn | Represents method DoReturn.
DoRight | Represents method DoRight.
DoTimer(TObject) | Represents method DoTimer(TObject).
DoUp | Represents method DoUp.
EnterIndent | Represents method EnterIndent.
FillRtti | Represents method FillRtti.
Find(String,Boolean,Integer) | Represents method Find(String,Boolean,Integer).
GetAttributeStyles | Represents method GetAttributeStyles.
GetBreakPointCondition(Integer) | Represents method GetBreakPointCondition(Integer).
GetBreakPointSpecialCondition(Integer) | Represents method GetBreakPointSpecialCondition(Integer).
GetCharAttr(TPoint) | Represents method GetCharAttr(TPoint).
GetCharWidth(String) | Represents method GetCharWidth(String).
GetCharXPos(Integer) | Represents method GetCharXPos(Integer).
GetCompletionString | Represents method GetCompletionString.
GetFilter(String) | Represents method GetFilter(String).
GetIdentEnd(Integer) | Represents method GetIdentEnd(Integer).
GetLineBegin(Integer) | Represents method GetLineBegin(Integer).
GetPlainPos | Represents method GetPlainPos.
GetPlainTextPos(TPoint) | Represents method GetPlainTextPos(TPoint).
GetPos | Represents method GetPos.
GetPosPlainText(Integer) | Represents method GetPosPlainText(Integer).
GetRunLine(Integer) | Represents method GetRunLine(Integer).
GetSelText | Represents method GetSelText.
GetText | Represents method GetText.
GetTextSelected | Represents method GetTextSelected.
GotoBookmark(Integer) | Represents method GotoBookmark(Integer).
IsActiveBreakPoint(Integer) | Represents method IsActiveBreakPoint(Integer).
IsBookmark(Integer) | Represents method IsBookmark(Integer).
IsBreakPoint(Integer) | Represents method IsBreakPoint(Integer).
IsCursorInStringBlock | Represents method IsCursorInStringBlock.
KeyDown(Word,TShiftState) | Represents method KeyDown(Word,TShiftState).
KeyPress(Char) | Represents method KeyPress(Char).
LineAt(Integer,Boolean) | Represents method LineAt(Integer,Boolean).
LineLength(Integer) | Represents method LineLength(Integer).
LinesChange(TObject) | Represents method LinesChange(TObject).
LoadFromIni(String,String,String) | Represents method LoadFromIni(String,String,String).
MouseDown(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
MouseWheelDown(TObject,TShiftState,TPoint,Boolean) | Represents method MouseWheelDown(TObject,TShiftState,TPoint,Boolean).
MouseWheelUp(TObject,TShiftState,TPoint,Boolean) | Represents method MouseWheelUp(TObject,TShiftState,TPoint,Boolean).
OnHScrollChange(TObject) | Represents method OnHScrollChange(TObject). (Overrides TfrxScrollWin.OnHScrollChange(TObject).)
OnVScrollChange(TObject) | Represents method OnVScrollChange(TObject). (Overrides TfrxScrollWin.OnVScrollChange(TObject).)
Pad(Integer) | Represents method Pad(Integer).
Paint | Represents method Paint. (Overrides TfrxScrollWin.Paint.)
PasteFromClipboard | Represents method PasteFromClipboard.
PopCopy(TObject) | Represents method PopCopy(TObject).
PopCut(TObject) | Represents method PopCut(TObject).
PopDelete(TObject) | Represents method PopDelete(TObject).
PopPaste(TObject) | Represents method PopPaste(TObject).
PopSelectAll(TObject) | Represents method PopSelectAll(TObject).
Resize | Represents method Resize.
SaveToIni(String,String,String) | Represents method SaveToIni(String,String,String).
SelectAll | Represents method SelectAll.
SetActiveLine(Integer) | Represents method SetActiveLine(Integer).
SetCodeCompletionHeight(Integer) | Represents method SetCodeCompletionHeight(Integer).
SetCodeCompletionMinHeight(Integer) | Represents method SetCodeCompletionMinHeight(Integer).
SetCodeCompletionMinWidth(Integer) | Represents method SetCodeCompletionMinWidth(Integer).
SetCodeCompletionWidth(Integer) | Represents method SetCodeCompletionWidth(Integer).
SetCommentAttr(TFont) | Represents method SetCommentAttr(TFont).
SetGutterWidth(Integer) | Represents method SetGutterWidth(Integer).
SetKeywordAttr(TFont) | Represents method SetKeywordAttr(TFont).
SetNumberAttr(TFont) | Represents method SetNumberAttr(TFont).
SetPos(Integer,Integer) | Represents method SetPos(Integer,Integer).
SetPosByCoords(Integer,Integer) | Represents method SetPosByCoords(Integer,Integer).
SetRunLine(Integer,Boolean) | Represents method SetRunLine(Integer,Boolean).
SetSelText(String) | Represents method SetSelText(String).
SetShowGutter(Boolean) | Represents method SetShowGutter(Boolean).
SetShowInCodeComplition(TfrxCompletionListTypes) | Represents method SetShowInCodeComplition(TfrxCompletionListTypes).
SetStringAttr(TFont) | Represents method SetStringAttr(TFont).
SetSyntax(String) | Represents method SetSyntax(String).
SetText(TStrings) | Represents method SetText(TStrings).
SetTextAttr(TFont) | Represents method SetTextAttr(TFont).
ShiftSelected(Boolean) | Represents method ShiftSelected(Boolean).
ShowCaretPos | Represents method ShowCaretPos.
ShowMessage(String) | Represents method ShowMessage(String).
TabIndent | Represents method TabIndent.
ToggleBreakPoint(Integer,String) | Represents method ToggleBreakPoint(Integer,String).
Undo | Represents method Undo.
UnIndent | Represents method UnIndent.
UpdateScrollBar | Represents method UpdateScrollBar.
UpdateView | Represents method UpdateView.
WMFRXFillCodeCompletion(TMessage) | Represents method WMFRXFillCodeCompletion(TMessage).
WMFRXSyncScript(TMessage) | Represents method WMFRXSyncScript(TMessage).
WMFRXUpdateCode(TMessage) | Represents method WMFRXUpdateCode(TMessage).
WMIMECOMPOSITION(TMessage) | Represents method WMIMECOMPOSITION(TMessage).
WMIMEEndComp(TMessage) | Represents method WMIMEEndComp(TMessage).
WMIMEStartComp(TMessage) | Represents method WMIMEStartComp(TMessage).
WMKillFocus(TWMKillFocus) | Represents method WMKillFocus(TWMKillFocus).
WMSetFocus(TWMSetFocus) | Represents method WMSetFocus(TWMSetFocus).
Top


TfrxSyntaxMemo.AddBookmark(Integer,Integer) Method

Summary

Represents method AddBookmark(Integer,Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure AddBookmark(Line, Number: Integer);

Parameters

Line
Type: Integer

Number
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.AddBreakPoint(Integer,String,String) Method

Summary

Represents method AddBreakPoint(Integer,String,String).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure AddBreakPoint(Number: Integer; const Condition: String; const Special: String);

Parameters

Number
Type: Integer

Condition
Type: String

Special
Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.AddNewBreakPoint Method

Summary

Represents method AddNewBreakPoint.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure AddNewBreakPoint;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.AddSel Method

Summary

Represents method AddSel.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure AddSel;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.AddUndo Method

Summary

Represents method AddUndo.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure AddUndo;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.BuildCClist(String) Method

Summary

Represents method BuildCClist(String).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure BuildCClist(const sName: String);

Parameters

sName
Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ClearBreakPoints Method

Summary

Represents method ClearBreakPoints.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure ClearBreakPoints;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ClearSel Method

Summary

Represents method ClearSel.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure ClearSel;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ClearSyntax(Integer) Method

Summary

Represents method ClearSyntax(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure ClearSyntax(ClearFrom: Integer);

Parameters

ClearFrom
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CMFontChanged(TMessage) Method

Summary

Represents method CMFontChanged(TMessage).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure CMFontChanged(var Message: TMessage); message CM_FONTCHANGED;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CompletionClose Method

Summary

Represents method CompletionClose.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure CompletionClose;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CompletionFormClose(TObject,TCloseAction) Method

Summary

Represents method CompletionFormClose(TObject,TCloseAction).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure CompletionFormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CompletionLBDblClick(TObject) Method

Summary

Represents method CompletionLBDblClick(TObject).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure CompletionLBDblClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CompletionLBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) Method

Summary

Represents method CompletionLBDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure CompletionLBDrawItem(Control: TWinControl; Index: Integer;
 ARect: TRect; State: TOwnerDrawState);

Parameters

Control
Type: TWinControl

Index
Type: Integer

ARect
Type: TRect

State
Type: TOwnerDrawState

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CompletionLBKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method CompletionLBKeyDown(TObject,Word,TShiftState).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure CompletionLBKeyDown(Sender: TObject; var Key: Word; Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CompletionLBKeyPress(TObject,Char) Method

Summary

Represents method CompletionLBKeyPress(TObject,Char).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure CompletionLBKeyPress(Sender: TObject; var Key: Char);

Parameters

Sender
Type: TObject

Key
Type: Char

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CopyToClipboard Method

Summary

Represents method CopyToClipboard.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure CopyToClipboard;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CorrectBookmark(Integer,Integer) Method

Summary

Represents method CorrectBookmark(Integer,Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure CorrectBookmark(Line, Delta: Integer);

Parameters

Line
Type: Integer

Delta
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CorrectBreakPoints(Integer,Integer) Method

Summary

Represents method CorrectBreakPoints(Integer,Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure CorrectBreakPoints(Line, Delta: Integer);

Parameters

Line
Type: Integer

Delta
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CreateSynArray(Integer) Method

Summary

Represents method CreateSynArray(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure CreateSynArray(EndLine: Integer);

Parameters

EndLine
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.CutToClipboard Method

Summary

Represents method CutToClipboard.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure CutToClipboard;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DblClick Method

Summary

Represents method DblClick.

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure DblClick; override;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DeleteBookmark(Integer) Method

Summary

Represents method DeleteBookmark(Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure DeleteBookmark(Number: Integer);

Parameters

Number
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DeleteBreakPoint(Integer) Method

Summary

Represents method DeleteBreakPoint(Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure DeleteBreakPoint(Number: Integer);

Parameters

Number
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DeleteF4BreakPoints Method

Summary

Represents method DeleteF4BreakPoints.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure DeleteF4BreakPoints;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoBackspace Method

Summary

Represents method DoBackspace.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoBackspace;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoChange Method

Summary

Represents method DoChange.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoChange;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoChar(Char) Method

Summary

Represents method DoChar(Char).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoChar(Ch: Char);

Parameters

Ch
Type: Char

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoCodeCompletion Method

Summary

Represents method DoCodeCompletion.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoCodeCompletion;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoCtrlI Method

Summary

Represents method DoCtrlI.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoCtrlI;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoCtrlL Method

Summary

Represents method DoCtrlL.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoCtrlL;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoCtrlR Method

Summary

Represents method DoCtrlR.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoCtrlR;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoCtrlU Method

Summary

Represents method DoCtrlU.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoCtrlU;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoDel Method

Summary

Represents method DoDel.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoDel;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoDown Method

Summary

Represents method DoDown.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoDown;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoEnd(Boolean) Method

Summary

Represents method DoEnd(Boolean).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoEnd(Ctrl: Boolean);

Parameters

Ctrl
Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoHome(Boolean) Method

Summary

Represents method DoHome(Boolean).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoHome(Ctrl: Boolean);

Parameters

Ctrl
Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoLeft Method

Summary

Represents method DoLeft.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoLeft;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoPgDn Method

Summary

Represents method DoPgDn.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoPgDn;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoPgUp Method

Summary

Represents method DoPgUp.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoPgUp;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoPPIChanged(Integer) Method

Summary

Represents method DoPPIChanged(Integer).

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure DoPPIChanged(aNewPPI: Integer); override;

Parameters

aNewPPI
Type: Integer

Overrides

TfrxScrollWin.DoPPIChanged(Integer)
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoReturn Method

Summary

Represents method DoReturn.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoReturn;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoRight Method

Summary

Represents method DoRight.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoRight;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoTimer(TObject) Method

Summary

Represents method DoTimer(TObject).

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure DoTimer(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.DoUp Method

Summary

Represents method DoUp.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure DoUp;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.EnterIndent Method

Summary

Represents method EnterIndent.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure EnterIndent;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FillRtti Method

Summary

Represents method FillRtti.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure FillRtti;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.Find(String,Boolean,Integer) Method

Summary

Represents method Find(String,Boolean,Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 function Find(const SearchText: String; CaseSensitive: Boolean;
 var SearchFrom: Integer): Boolean;

Parameters

SearchText
Type: String

CaseSensitive
Type: Boolean

SearchFrom
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetAttributeStyles Method

Summary

Represents method GetAttributeStyles.

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetAttributeStyles: TfrxAttributeStyles;

Return Value

Type: TfrxAttributeStyles

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetBreakPointCondition(Integer) Method

Summary

Represents method GetBreakPointCondition(Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 function GetBreakPointCondition(Number: Integer): String;

Parameters

Number
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetBreakPointSpecialCondition(Integer) Method

Summary

Represents method GetBreakPointSpecialCondition(Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 function GetBreakPointSpecialCondition(Number: Integer): String;

Parameters

Number
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetCharAttr(TPoint) Method

Summary

Represents method GetCharAttr(TPoint).

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetCharAttr(Pos: TPoint): TfrxCharAttributes;

Parameters

Pos
Type: TPoint

Return Value

Type: TfrxCharAttributes

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetCharWidth(String) Method

Summary

Represents method GetCharWidth(String).

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetCharWidth(const Str: String): Integer;

Parameters

Str
Type: String

Return Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetCharXPos(Integer) Method

Summary

Represents method GetCharXPos(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetCharXPos(X: Integer): Integer;

Parameters

X
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetCompletionString Method

Summary

Represents method GetCompletionString.

Namespace: frxSynMemo
Syntax
Delphi
protected
 function GetCompletionString: String;

Return Value

Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetFilter(String) Method

Summary

Represents method GetFilter(String).

Namespace: frxSynMemo
Syntax
Delphi
protected
 function GetFilter(aStr: String): String;

Parameters

aStr
Type: String

Return Value

Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetIdentEnd(Integer) Method

Summary

Represents method GetIdentEnd(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetIdentEnd(aPos: Integer): Integer;

Parameters

aPos
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetLineBegin(Integer) Method

Summary

Represents method GetLineBegin(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetLineBegin(Index: Integer): Integer;

Parameters

Index
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetPlainPos Method

Summary

Represents method GetPlainPos.

Namespace: frxSynMemo
Syntax
Delphi
public
 function GetPlainPos: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetPlainTextPos(TPoint) Method

Summary

Represents method GetPlainTextPos(TPoint).

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetPlainTextPos(Pos: TPoint): Integer;

Parameters

Pos
Type: TPoint

Return Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetPos Method

Summary

Represents method GetPos.

Namespace: frxSynMemo
Syntax
Delphi
public
 function GetPos: TPoint;

Return Value

Type: TPoint

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetPosPlainText(Integer) Method

Summary

Represents method GetPosPlainText(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetPosPlainText(Pos: Integer): TPoint;

Parameters

Pos
Type: Integer

Return Value

Type: TPoint

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetRunLine(Integer) Method

Summary

Represents method GetRunLine(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetRunLine(Index: Integer): Boolean;

Parameters

Index
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetSelText Method

Summary

Represents method GetSelText.

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetSelText: String;

Return Value

Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetText Method

Summary

Represents method GetText.

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetText: TStrings;

Return Value

Type: TStrings

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GetTextSelected Method

Summary

Represents method GetTextSelected.

Namespace: frxSynMemo
Syntax
Delphi
private
 function GetTextSelected: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.GotoBookmark(Integer) Method

Summary

Represents method GotoBookmark(Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure GotoBookmark(Number: Integer);

Parameters

Number
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.IsActiveBreakPoint(Integer) Method

Summary

Represents method IsActiveBreakPoint(Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 function IsActiveBreakPoint(Number: Integer): Boolean;

Parameters

Number
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.IsBookmark(Integer) Method

Summary

Represents method IsBookmark(Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 function IsBookmark(Line: Integer): Integer;

Parameters

Line
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.IsBreakPoint(Integer) Method

Summary

Represents method IsBreakPoint(Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 function IsBreakPoint(Number: Integer): Boolean;

Parameters

Number
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.IsCursorInStringBlock Method

Summary

Represents method IsCursorInStringBlock.

Namespace: frxSynMemo
Syntax
Delphi
private
 function IsCursorInStringBlock: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.KeyDown(Word,TShiftState) Method

Summary

Represents method KeyDown(Word,TShiftState).

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure KeyDown(var Key: Word; Shift: TShiftState); override;

Parameters

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.KeyPress(Char) Method

Summary

Represents method KeyPress(Char).

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure KeyPress(var Key: Char); override;

Parameters

Key
Type: Char

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.LineAt(Integer,Boolean) Method

Summary

Represents method LineAt(Integer,Boolean).

Namespace: frxSynMemo
Syntax
Delphi
private
 function LineAt(Index: Integer; UseTrim: Boolean = True): String;

Parameters

Index
Type: Integer

UseTrim
Type: Boolean

Return Value

Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.LineLength(Integer) Method

Summary

Represents method LineLength(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 function LineLength(Index: Integer): Integer;

Parameters

Index
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.LinesChange(TObject) Method

Summary

Represents method LinesChange(TObject).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure LinesChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.LoadFromIni(String,String,String) Method

Summary

Represents method LoadFromIni(String,String,String).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure LoadFromIni(const IniPath: String; const Section: String; const FileName: String);

Parameters

IniPath
Type: String

Section
Type: String

FileName
Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.MouseDown(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseDown(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure MouseDown(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.MouseMove(TShiftState,Integer,Integer) Method

Summary

Represents method MouseMove(TShiftState,Integer,Integer).

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;

Parameters

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState;
 X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.MouseWheelDown(TObject,TShiftState,TPoint,Boolean) Method

Summary

Represents method MouseWheelDown(TObject,TShiftState,TPoint,Boolean).

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure MouseWheelDown(Sender: TObject; Shift: TShiftState;
 MousePos: TPoint; var Handled: Boolean);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

MousePos
Type: TPoint

Handled
Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.MouseWheelUp(TObject,TShiftState,TPoint,Boolean) Method

Summary

Represents method MouseWheelUp(TObject,TShiftState,TPoint,Boolean).

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure MouseWheelUp(Sender: TObject; Shift: TShiftState;
 MousePos: TPoint; var Handled: Boolean);

Parameters

Sender
Type: TObject

Shift
Type: TShiftState

MousePos
Type: TPoint

Handled
Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.OnHScrollChange(TObject) Method

Summary

Represents method OnHScrollChange(TObject).

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure OnHScrollChange(Sender: TObject); override;

Parameters

Sender
Type: TObject

Overrides

TfrxScrollWin.OnHScrollChange(TObject)
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.OnVScrollChange(TObject) Method

Summary

Represents method OnVScrollChange(TObject).

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure OnVScrollChange(Sender: TObject); override;

Parameters

Sender
Type: TObject

Overrides

TfrxScrollWin.OnVScrollChange(TObject)
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.Pad(Integer) Method

Summary

Represents method Pad(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 function Pad(n: Integer): String;

Parameters

n
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.Paint Method

Summary

Represents method Paint.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure Paint; override;

Overrides

TfrxScrollWin.Paint
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.PasteFromClipboard Method

Summary

Represents method PasteFromClipboard.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure PasteFromClipboard;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.PopCopy(TObject) Method

Summary

Represents method PopCopy(TObject).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure PopCopy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.PopCut(TObject) Method

Summary

Represents method PopCut(TObject).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure PopCut(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.PopDelete(TObject) Method

Summary

Represents method PopDelete(TObject).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure PopDelete(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.PopPaste(TObject) Method

Summary

Represents method PopPaste(TObject).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure PopPaste(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.PopSelectAll(TObject) Method

Summary

Represents method PopSelectAll(TObject).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure PopSelectAll(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.Resize Method

Summary

Represents method Resize.

Namespace: frxSynMemo
Syntax
Delphi
protected
 procedure Resize; override;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SaveToIni(String,String,String) Method

Summary

Represents method SaveToIni(String,String,String).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure SaveToIni(const IniPath: String; const Section: String; const FileName: String);

Parameters

IniPath
Type: String

Section
Type: String

FileName
Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SelectAll Method

Summary

Represents method SelectAll.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure SelectAll;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetActiveLine(Integer) Method

Summary

Represents method SetActiveLine(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetActiveLine(Line: Integer);

Parameters

Line
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetCodeCompletionHeight(Integer) Method

Summary

Represents method SetCodeCompletionHeight(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetCodeCompletionHeight(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetCodeCompletionMinHeight(Integer) Method

Summary

Represents method SetCodeCompletionMinHeight(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetCodeCompletionMinHeight(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetCodeCompletionMinWidth(Integer) Method

Summary

Represents method SetCodeCompletionMinWidth(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetCodeCompletionMinWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetCodeCompletionWidth(Integer) Method

Summary

Represents method SetCodeCompletionWidth(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetCodeCompletionWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetCommentAttr(TFont) Method

Summary

Represents method SetCommentAttr(TFont).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetCommentAttr(Value: TFont);

Parameters

Value
Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetGutterWidth(Integer) Method

Summary

Represents method SetGutterWidth(Integer).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetGutterWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetKeywordAttr(TFont) Method

Summary

Represents method SetKeywordAttr(TFont).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetKeywordAttr(Value: TFont);

Parameters

Value
Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetNumberAttr(TFont) Method

Summary

Represents method SetNumberAttr(TFont).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetNumberAttr(const Value: TFont);

Parameters

Value
Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetPos(Integer,Integer) Method

Summary

Represents method SetPos(Integer,Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure SetPos(x, y: Integer);

Parameters

x
Type: Integer

y
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetPosByCoords(Integer,Integer) Method

Summary

Represents method SetPosByCoords(Integer,Integer).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure SetPosByCoords(X, Y: Integer);

Parameters

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetRunLine(Integer,Boolean) Method

Summary

Represents method SetRunLine(Integer,Boolean).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetRunLine(Index: Integer; const Value: Boolean);

Parameters

Index
Type: Integer

Value
Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetSelText(String) Method

Summary

Represents method SetSelText(String).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetSelText(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetShowGutter(Boolean) Method

Summary

Represents method SetShowGutter(Boolean).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetShowGutter(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetShowInCodeComplition(TfrxCompletionListTypes) Method

Summary

Represents method SetShowInCodeComplition(TfrxCompletionListTypes).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetShowInCodeComplition(const Value: TfrxCompletionListTypes);

Parameters

Value
Type: TfrxCompletionListTypes

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetStringAttr(TFont) Method

Summary

Represents method SetStringAttr(TFont).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetStringAttr(Value: TFont);

Parameters

Value
Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetSyntax(String) Method

Summary

Represents method SetSyntax(String).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetSyntax(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetText(TStrings) Method

Summary

Represents method SetText(TStrings).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetText(Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.SetTextAttr(TFont) Method

Summary

Represents method SetTextAttr(TFont).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure SetTextAttr(Value: TFont);

Parameters

Value
Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ShiftSelected(Boolean) Method

Summary

Represents method ShiftSelected(Boolean).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure ShiftSelected(ShiftRight: Boolean);

Parameters

ShiftRight
Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ShowCaretPos Method

Summary

Represents method ShowCaretPos.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure ShowCaretPos;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ShowMessage(String) Method

Summary

Represents method ShowMessage(String).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure ShowMessage(const s: String);

Parameters

s
Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.TabIndent Method

Summary

Represents method TabIndent.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure TabIndent;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.ToggleBreakPoint(Integer,String) Method

Summary

Represents method ToggleBreakPoint(Integer,String).

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure ToggleBreakPoint(Number: Integer; const Condition: String);

Parameters

Number
Type: Integer

Condition
Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.Undo Method

Summary

Represents method Undo.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure Undo;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.UnIndent Method

Summary

Represents method UnIndent.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure UnIndent;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.UpdateScrollBar Method

Summary

Represents method UpdateScrollBar.

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure UpdateScrollBar;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.UpdateView Method

Summary

Represents method UpdateView.

Namespace: frxSynMemo
Syntax
Delphi
public
 procedure UpdateView;
See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.WMFRXFillCodeCompletion(TMessage) Method

Summary

Represents method WMFRXFillCodeCompletion(TMessage).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure WMFRXFillCodeCompletion(var Message: TMessage); message WM_FRX_FILL_CODE_COMPLETION;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.WMFRXSyncScript(TMessage) Method

Summary

Represents method WMFRXSyncScript(TMessage).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure WMFRXSyncScript(var Message: TMessage); message WM_FRX_SYNC_SCRIPT;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.WMFRXUpdateCode(TMessage) Method

Summary

Represents method WMFRXUpdateCode(TMessage).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure WMFRXUpdateCode(var Message: TMessage); message WM_FRX_UPDATE_CODE;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.WMIMECOMPOSITION(TMessage) Method

Summary

Represents method WMIMECOMPOSITION(TMessage).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure WMIMECOMPOSITION (var Message: TMessage); message WM_IME_COMPOSITION ;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.WMIMEEndComp(TMessage) Method

Summary

Represents method WMIMEEndComp(TMessage).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure WMIMEEndComp(var Message: TMessage); message WM_IME_ENDCOMPOSITION;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.WMIMEStartComp(TMessage) Method

Summary

Represents method WMIMEStartComp(TMessage).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure WMIMEStartComp(var Message: TMessage); message WM_IME_STARTCOMPOSITION;

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.WMKillFocus(TWMKillFocus) Method

Summary

Represents method WMKillFocus(TWMKillFocus).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure WMKillFocus(var Msg: TWMKillFocus); message WM_KILLFOCUS;

Parameters

Msg
Type: TWMKillFocus

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.WMSetFocus(TWMSetFocus) Method

Summary

Represents method WMSetFocus(TWMSetFocus).

Namespace: frxSynMemo
Syntax
Delphi
private
 procedure WMSetFocus(var Msg: TWMSetFocus); message WM_SETFOCUS;

Parameters

Msg
Type: TWMSetFocus

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo Events

Events
Name | Description
OnCodeCompletion | Represents property OnCodeCompletion.
Top


TfrxSyntaxMemo.OnCodeCompletion Event

Summary

Represents property OnCodeCompletion.

Namespace: frxSynMemo
Syntax
Delphi
public
 property OnCodeCompletion: TfrxCodeCompletionEvent read FOnCodeCompletion
 write FOnCodeCompletion;

Value

Type: TfrxCodeCompletionEvent

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo Fields

Fields
Name | Description
FActiveLine | Represents field FActiveLine.
FAddonCompletionList | Represents field FAddonCompletionList.
FAllowLinesChange | Represents field FAllowLinesChange.
FBlockColor | Represents field FBlockColor.
FBlockFontColor | Represents field FBlockFontColor.
FBookmarks | Represents field FBookmarks.
FBreakPoints | Represents field FBreakPoints.
FCharHeight | Represents field FCharHeight.
FCharWidth | Represents field FCharWidth.
FClassCompletionList | Represents field FClassCompletionList.
FCodeCompletionHeight | Represents field FCodeCompletionHeight.
FCodeCompletionMinHeight | Represents field FCodeCompletionMinHeight.
FCodeCompletionMinWidth | Represents field FCodeCompletionMinWidth.
FCodeCompletionThread | Represents field FCodeCompletionThread.
FCodeCompletionWidth | Represents field FCodeCompletionWidth.
FCodeCompList | Represents field FCodeCompList.
FCodeComplitionFilter | Represents field FCodeComplitionFilter.
FCommentAttr | Represents field FCommentAttr.
FCompleationFilter | Represents field FCompleationFilter.
FCompletionForm | Represents field FCompletionForm.
FCompletionLB | Represents field FCompletionLB.
FCompSelEnd | Represents field FCompSelEnd.
FCompSelStart | Represents field FCompSelStart.
FDoubleClicked | Represents field FDoubleClicked.
FDown | Represents field FDown.
FGutterWidth | Represents field FGutterWidth.
FIsMonoType | Represents field FIsMonoType.
FKeywordAttr | Represents field FKeywordAttr.
FMaxLength | Represents field FMaxLength.
FMessage | Represents field FMessage.
FModified | Represents field FModified.
FMoved | Represents field FMoved.
FMultiByteLang | Represents field FMultiByteLang.
FNumberAttr | Represents field FNumberAttr.
FOffset | Represents field FOffset.
FOnChangePos | Represents field FOnChangePos.
FOnChangeText | Represents field FOnChangeText.
FOnCodeCompletion | Represents field FOnCodeCompletion.
FParser | Represents field FParser.
FPos | Represents field FPos.
FRttiCompletionList | Represents field FRttiCompletionList.
FScript | Represents field FScript.
FScriptCompletionList | Represents field FScriptCompletionList.
FScriptRTTIXML | Represents field FScriptRTTIXML.
FSelEnd | Represents field FSelEnd.
FSelStart | Represents field FSelStart.
FShowGutter | Represents field FShowGutter.
FShowInCodeComplition | Represents field FShowInCodeComplition.
FShowLineNumber | Represents field FShowLineNumber.
FStartCodeCompPos | Represents field FStartCodeCompPos.
FStringAttr | Represents field FStringAttr.
FSynAttributes | Represents field FSynAttributes.
FSynDialectStyles | Represents field FSynDialectStyles.
FSyntax | Represents field FSyntax.
FTabStops | Represents field FTabStops.
FTempPos | Represents field FTempPos.
FText | Represents field FText.
FTextAttr | Represents field FTextAttr.
FTimer | Represents field FTimer.
FTmpCanvas | Represents field FTmpCanvas.
FToggleBreakPointDown | Represents field FToggleBreakPointDown.
FUndo | Represents field FUndo.
FWindowSize | Represents field FWindowSize.
Top


TfrxSyntaxMemo.FActiveLine Field

Summary

Represents field FActiveLine.

Namespace: frxSynMemo
Syntax
Delphi
private
 FActiveLine: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FAddonCompletionList Field

Summary

Represents field FAddonCompletionList.

Namespace: frxSynMemo
Syntax
Delphi
private
 FAddonCompletionList: TfrxCompletionList;

Field Value

Type: TfrxCompletionList

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FAllowLinesChange Field

Summary

Represents field FAllowLinesChange.

Namespace: frxSynMemo
Syntax
Delphi
private
 FAllowLinesChange: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FBlockColor Field

Summary

Represents field FBlockColor.

Namespace: frxSynMemo
Syntax
Delphi
private
 FBlockColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FBlockFontColor Field

Summary

Represents field FBlockFontColor.

Namespace: frxSynMemo
Syntax
Delphi
private
 FBlockFontColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FBookmarks Field

Summary

Represents field FBookmarks.

Namespace: frxSynMemo
Syntax
Delphi
private
 FBookmarks: array[0..9] of Integer;

Field Value

Type: array[0..9] of Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FBreakPoints Field

Summary

Represents field FBreakPoints.

Namespace: frxSynMemo
Syntax
Delphi
private
 FBreakPoints: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCharHeight Field

Summary

Represents field FCharHeight.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCharHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCharWidth Field

Summary

Represents field FCharWidth.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCharWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FClassCompletionList Field

Summary

Represents field FClassCompletionList.

Namespace: frxSynMemo
Syntax
Delphi
private
 FClassCompletionList: TfrxCompletionList;

Field Value

Type: TfrxCompletionList

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCodeCompletionHeight Field

Summary

Represents field FCodeCompletionHeight.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCodeCompletionHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCodeCompletionMinHeight Field

Summary

Represents field FCodeCompletionMinHeight.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCodeCompletionMinHeight: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCodeCompletionMinWidth Field

Summary

Represents field FCodeCompletionMinWidth.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCodeCompletionMinWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCodeCompletionThread Field

Summary

Represents field FCodeCompletionThread.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCodeCompletionThread: TfrxCodeCompletionThread;

Field Value

Type: TfrxCodeCompletionThread

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCodeCompletionWidth Field

Summary

Represents field FCodeCompletionWidth.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCodeCompletionWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCodeCompList Field

Summary

Represents field FCodeCompList.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCodeCompList: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCodeComplitionFilter Field

Summary

Represents field FCodeComplitionFilter.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCodeComplitionFilter: TfrxItemTypes;

Field Value

Type: TfrxItemTypes

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCommentAttr Field

Summary

Represents field FCommentAttr.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCommentAttr: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCompleationFilter Field

Summary

Represents field FCompleationFilter.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCompleationFilter: String;

Field Value

Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCompletionForm Field

Summary

Represents field FCompletionForm.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCompletionForm: TfrxPopupForm;

Field Value

Type: TfrxPopupForm

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCompletionLB Field

Summary

Represents field FCompletionLB.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCompletionLB: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCompSelEnd Field

Summary

Represents field FCompSelEnd.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCompSelEnd: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FCompSelStart Field

Summary

Represents field FCompSelStart.

Namespace: frxSynMemo
Syntax
Delphi
private
 FCompSelStart: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FDoubleClicked Field

Summary

Represents field FDoubleClicked.

Namespace: frxSynMemo
Syntax
Delphi
private
 FDoubleClicked: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FDown Field

Summary

Represents field FDown.

Namespace: frxSynMemo
Syntax
Delphi
private
 FDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FGutterWidth Field

Summary

Represents field FGutterWidth.

Namespace: frxSynMemo
Syntax
Delphi
private
 FGutterWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FIsMonoType Field

Summary

Represents field FIsMonoType.

Namespace: frxSynMemo
Syntax
Delphi
private
 FIsMonoType: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FKeywordAttr Field

Summary

Represents field FKeywordAttr.

Namespace: frxSynMemo
Syntax
Delphi
private
 FKeywordAttr: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FMaxLength Field

Summary

Represents field FMaxLength.

Namespace: frxSynMemo
Syntax
Delphi
private
 FMaxLength: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FMessage Field

Summary

Represents field FMessage.

Namespace: frxSynMemo
Syntax
Delphi
private
 FMessage: String;

Field Value

Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FModified Field

Summary

Represents field FModified.

Namespace: frxSynMemo
Syntax
Delphi
private
 FModified: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FMoved Field

Summary

Represents field FMoved.

Namespace: frxSynMemo
Syntax
Delphi
private
 FMoved: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FMultiByteLang Field

Summary

Represents field FMultiByteLang.

Namespace: frxSynMemo
Syntax
Delphi
private
 FMultiByteLang: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FNumberAttr Field

Summary

Represents field FNumberAttr.

Namespace: frxSynMemo
Syntax
Delphi
private
 FNumberAttr: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FOffset Field

Summary

Represents field FOffset.

Namespace: frxSynMemo
Syntax
Delphi
private
 FOffset: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FOnChangePos Field

Summary

Represents field FOnChangePos.

Namespace: frxSynMemo
Syntax
Delphi
private
 FOnChangePos: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FOnChangeText Field

Summary

Represents field FOnChangeText.

Namespace: frxSynMemo
Syntax
Delphi
private
 FOnChangeText: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FOnCodeCompletion Field

Summary

Represents field FOnCodeCompletion.

Namespace: frxSynMemo
Syntax
Delphi
private
 FOnCodeCompletion: TfrxCodeCompletionEvent;

Field Value

Type: TfrxCodeCompletionEvent

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FParser Field

Summary

Represents field FParser.

Namespace: frxSynMemo
Syntax
Delphi
private
 FParser: TfsParser;

Field Value

Type: TfsParser

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FPos Field

Summary

Represents field FPos.

Namespace: frxSynMemo
Syntax
Delphi
private
 FPos: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FRttiCompletionList Field

Summary

Represents field FRttiCompletionList.

Namespace: frxSynMemo
Syntax
Delphi
private
 FRttiCompletionList: TfrxCompletionList;

Field Value

Type: TfrxCompletionList

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FScript Field

Summary

Represents field FScript.

Namespace: frxSynMemo
Syntax
Delphi
private
 FScript: TfsScript;

Field Value

Type: TfsScript

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FScriptCompletionList Field

Summary

Represents field FScriptCompletionList.

Namespace: frxSynMemo
Syntax
Delphi
private
 FScriptCompletionList: TfrxCompletionList;

Field Value

Type: TfrxCompletionList

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FScriptRTTIXML Field

Summary

Represents field FScriptRTTIXML.

Namespace: frxSynMemo
Syntax
Delphi
private
 FScriptRTTIXML: TfsXMLDocument;

Field Value

Type: TfsXMLDocument

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FSelEnd Field

Summary

Represents field FSelEnd.

Namespace: frxSynMemo
Syntax
Delphi
private
 FSelEnd: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FSelStart Field

Summary

Represents field FSelStart.

Namespace: frxSynMemo
Syntax
Delphi
private
 FSelStart: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FShowGutter Field

Summary

Represents field FShowGutter.

Namespace: frxSynMemo
Syntax
Delphi
private
 FShowGutter: boolean;

Field Value

Type: boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FShowInCodeComplition Field

Summary

Represents field FShowInCodeComplition.

Namespace: frxSynMemo
Syntax
Delphi
private
 FShowInCodeComplition: TfrxCompletionListTypes;

Field Value

Type: TfrxCompletionListTypes

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FShowLineNumber Field

Summary

Represents field FShowLineNumber.

Namespace: frxSynMemo
Syntax
Delphi
private
 FShowLineNumber: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FStartCodeCompPos Field

Summary

Represents field FStartCodeCompPos.

Namespace: frxSynMemo
Syntax
Delphi
private
 FStartCodeCompPos: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FStringAttr Field

Summary

Represents field FStringAttr.

Namespace: frxSynMemo
Syntax
Delphi
private
 FStringAttr: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FSynAttributes Field

Summary

Represents field FSynAttributes.

Namespace: frxSynMemo
Syntax
Delphi
private
 FSynAttributes: TfrxSynAttributes;

Field Value

Type: TfrxSynAttributes

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FSynDialectStyles Field

Summary

Represents field FSynDialectStyles.

Namespace: frxSynMemo
Syntax
Delphi
private
 FSynDialectStyles: TfrxSynDialectStyles;

Field Value

Type: TfrxSynDialectStyles

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FSyntax Field

Summary

Represents field FSyntax.

Namespace: frxSynMemo
Syntax
Delphi
private
 FSyntax: String;

Field Value

Type: String

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FTabStops Field

Summary

Represents field FTabStops.

Namespace: frxSynMemo
Syntax
Delphi
private
 FTabStops: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FTempPos Field

Summary

Represents field FTempPos.

Namespace: frxSynMemo
Syntax
Delphi
private
 FTempPos: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FText Field

Summary

Represents field FText.

Namespace: frxSynMemo
Syntax
Delphi
private
 FText: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FTextAttr Field

Summary

Represents field FTextAttr.

Namespace: frxSynMemo
Syntax
Delphi
private
 FTextAttr: TFont;

Field Value

Type: TFont

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FTimer Field

Summary

Represents field FTimer.

Namespace: frxSynMemo
Syntax
Delphi
private
 FTimer: TTimer;

Field Value

Type: TTimer

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FTmpCanvas Field

Summary

Represents field FTmpCanvas.

Namespace: frxSynMemo
Syntax
Delphi
private
 FTmpCanvas: TBitmap;

Field Value

Type: TBitmap

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FToggleBreakPointDown Field

Summary

Represents field FToggleBreakPointDown.

Namespace: frxSynMemo
Syntax
Delphi
private
 FToggleBreakPointDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FUndo Field

Summary

Represents field FUndo.

Namespace: frxSynMemo
Syntax
Delphi
private
 FUndo: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


TfrxSyntaxMemo.FWindowSize Field

Summary

Represents field FWindowSize.

Namespace: frxSynMemo
Syntax
Delphi
private
 FWindowSize: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxSyntaxMemo
  • frxSynMemo


frxSynMemo Records

Records
Name | Description
TfrxCharAttributes | Represents type TfrxCharAttributes.
Top


TfrxCharAttributes Record

Summary

Represents type TfrxCharAttributes.

Namespace: frxSynMemo
Syntax
Delphi
type
 TfrxCharAttributes = record
 end;

The TfrxCharAttributes type exposes the following members.

Fields
Show:
Name | Description
IsSelBlock | Represents field IsSelBlock.
StyleIndex | Represents field StyleIndex.
Top
See Also

Reference

  • frxSynMemo


TfrxCharAttributes Fields

Fields
Name | Description
IsSelBlock | Represents field IsSelBlock.
StyleIndex | Represents field StyleIndex.
Top


TfrxCharAttributes.IsSelBlock Field

Summary

Represents field IsSelBlock.

Namespace: frxSynMemo
Syntax
Delphi
public
 IsSelBlock: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCharAttributes
  • frxSynMemo


TfrxCharAttributes.StyleIndex Field

Summary

Represents field StyleIndex.

Namespace: frxSynMemo
Syntax
Delphi
public
 StyleIndex: Byte;

Field Value

Type: Byte

See Also

Reference

  • TfrxCharAttributes
  • frxSynMemo


frxSynMemo Enumerations

Enumerations
Name | Description
TCharAttr | Represents type TCharAttr.
TfrxCompletionListType | Represents type TfrxCompletionListType.
TfrxItemType | Represents type TfrxItemType.
Top


TCharAttr Enumeration

Summary

Represents type TCharAttr.

Namespace: frxSynMemo
Syntax
Delphi
type
 TCharAttr = (caNo, caText, caComment, caKeyword, caString,
 caNumber);

The TCharAttr type exposes the following members.

Members
Show:
Name | Description
caComment | Represents constant caComment.
caKeyword | Represents constant caKeyword.
caNo | Represents constant caNo.
caNumber | Represents constant caNumber.
caString | Represents constant caString.
caText | Represents constant caText.
Top
See Also

Reference

  • frxSynMemo


TfrxCompletionListType Enumeration

Summary

Represents type TfrxCompletionListType.

Namespace: frxSynMemo
Syntax
Delphi
type
 TfrxCompletionListType = (cltRtti, cltScript, cltAddon);

The TfrxCompletionListType type exposes the following members.

Members
Show:
Name | Description
cltAddon | Represents constant cltAddon.
cltRtti | Represents constant cltRtti.
cltScript | Represents constant cltScript.
Top
See Also

Reference

  • frxSynMemo


TfrxItemType Enumeration

Summary

Represents type TfrxItemType.

Namespace: frxSynMemo
Syntax
Delphi
type
 TfrxItemType = (itVar, itProcedure, itFunction, itProperty, itIndex, itConstant, itConstructor, itType, itEvent);

The TfrxItemType type exposes the following members.

Members
Show:
Name | Description
itConstant | Represents constant itConstant.
itConstructor | Represents constant itConstructor.
itEvent | Represents constant itEvent.
itFunction | Represents constant itFunction.
itIndex | Represents constant itIndex.
itProcedure | Represents constant itProcedure.
itProperty | Represents constant itProperty.
itType | Represents constant itType.
itVar | Represents constant itVar.
Top
See Also

Reference

  • frxSynMemo


frxSynMemo Delegates

Delegates
Name | Description
TfrxCodeCompletionEvent | Represents type TfrxCodeCompletionEvent.
Top


TfrxCodeCompletionEvent Delegate

Summary

Represents type TfrxCodeCompletionEvent.

Namespace: frxSynMemo
Syntax
Delphi
type
 TfrxCodeCompletionEvent = procedure(const Name: String; List: TfrxCompletionList) of object;
See Also

Reference

  • frxSynMemo


frxSynMemo Types

Types
Name | Description
TfrxByteArr | Represents an array of the Byte type.
TfrxCompletionListTypes | Represents type TfrxCompletionListTypes.
TfrxItemTypes | Represents type TfrxItemTypes.
Top


TfrxByteArr Type

Summary

Represents an array of the Byte type.

Namespace: frxSynMemo
Syntax
Delphi
type
 TfrxByteArr = array of Byte;
See Also

Reference

  • frxSynMemo


TfrxCompletionListTypes Type

Summary

Represents type TfrxCompletionListTypes.

Namespace: frxSynMemo
Syntax
Delphi
type
 TfrxCompletionListTypes = set of TfrxCompletionListType;
See Also

Reference

  • frxSynMemo


TfrxItemTypes Type

Summary

Represents type TfrxItemTypes.

Namespace: frxSynMemo
Syntax
Delphi
type
 TfrxItemTypes = set of TfrxItemType;
See Also

Reference

  • frxSynMemo


frxSynMemo Constants

Constants
Name | Description
WM_FRX_FILL_CODE_COMPLETION | Represents constant WM_FRX_FILL_CODE_COMPLETION.
WM_FRX_SYNC_SCRIPT | Represents constant WM_FRX_SYNC_SCRIPT.
WM_FRX_UPDATE_CODE | Represents constant WM_FRX_UPDATE_CODE.
Top


WM_FRX_FILL_CODE_COMPLETION Constant

Summary

Represents constant WM_FRX_FILL_CODE_COMPLETION.

Namespace: frxSynMemo
Syntax
Delphi
 WM_FRX_FILL_CODE_COMPLETION = WM_USER + 102;

Value

Type: Void

See Also

Reference

  • frxSynMemo


WM_FRX_SYNC_SCRIPT Constant

Summary

Represents constant WM_FRX_SYNC_SCRIPT.

Namespace: frxSynMemo
Syntax
Delphi
 WM_FRX_SYNC_SCRIPT = WM_USER + 100;

Value

Type: Void

See Also

Reference

  • frxSynMemo


WM_FRX_UPDATE_CODE Constant

Summary

Represents constant WM_FRX_UPDATE_CODE.

Namespace: frxSynMemo
Syntax
Delphi
 WM_FRX_UPDATE_CODE = WM_USER + 101;

Value

Type: Void

See Also

Reference

  • frxSynMemo


frxTableObject Namespace

Summary

This unit contains classes of Table report object.

Classes
Name | Description
TfrxContainerPadding | The class represents padding data of table container (cell).
TfrxHackView | Represents type TfrxHackView.
TfrxReportTableObject | The TfrxReportTableObject allows use of the Table component in a report. TfrxReportTableObject is an empty component. It is used to add table unit to uses clause of an application.
TfrxTableCell | This class represent a table cell. The table call can be used as a container for other component or as Text object. It inherits most of the properties from "Text" object.
TfrxTableColumn | Represents Table column.
TfrxTableObject | The TfrxTableObject component represents a Table object. The table object used to group report data or object in one big tabular structure. With table object it's more easy to change appearance of the tabular based reports. Table may grow in size based on content inside cells. The table cells can contain other objects. The table size controls by rows and column count.
TfrxTableRow | Represents Table Row.
TfrxTableRowColumnBase | The base class for Table rows and columns.
Top
Constants
Name | Description
DefaultColumnWidth | Default column width for new table.
DefaultRowHeight | Default row height for new table.
Top


frxTableObject Classes

Classes
Name | Description
TfrxContainerPadding | The class represents padding data of table container (cell).
TfrxHackView | Represents type TfrxHackView.
TfrxReportTableObject | The TfrxReportTableObject allows use of the Table component in a report. TfrxReportTableObject is an empty component. It is used to add table unit to uses clause of an application.
TfrxTableCell | This class represent a table cell. The table call can be used as a container for other component or as Text object. It inherits most of the properties from "Text" object.
TfrxTableColumn | Represents Table column.
TfrxTableObject | The TfrxTableObject component represents a Table object. The table object used to group report data or object in one big tabular structure. With table object it's more easy to change appearance of the tabular based reports. Table may grow in size based on content inside cells. The table cells can contain other objects. The table size controls by rows and column count.
TfrxTableRow | Represents Table Row.
TfrxTableRowColumnBase | The base class for Table rows and columns.
Top


TfrxContainerPadding Class

Summary

The class represents padding data of table container (cell).

Namespace: frxTableObject
Inheritance Hierarchy
TPersistent
frxTableObject.TfrxContainerPadding
Syntax
Delphi
type
 TfrxContainerPadding = class(TPersistent)
 end;

The TfrxContainerPadding type exposes the following members.

Properties
Show:
Name | Description
BottomPading | Bottom padding value.
LeftPading | Left padding value.
RightPading | Right padding value.
TopPading | Top padding value.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
Fields
Show:
Name | Description
FBottomPading | Represents field FBottomPading.
FLeftPading | Represents field FLeftPading.
FRightPading | Represents field FRightPading.
FTopPading | Represents field FTopPading.
Top
See Also

Reference

  • frxTableObject


TfrxContainerPadding Properties

Properties
Name | Description
BottomPading | Bottom padding value.
LeftPading | Left padding value.
RightPading | Right padding value.
TopPading | Top padding value.
Top


TfrxContainerPadding.BottomPading Property

Summary

Bottom padding value.

Namespace: frxTableObject
Syntax
Delphi
published
 property BottomPading: Extended read FBottomPading write FBottomPading;

Property Value

Type: Extended

See Also

Reference

  • TfrxContainerPadding
  • frxTableObject


TfrxContainerPadding.LeftPading Property

Summary

Left padding value.

Namespace: frxTableObject
Syntax
Delphi
published
 property LeftPading: Extended read FLeftPading write FLeftPading;

Property Value

Type: Extended

See Also

Reference

  • TfrxContainerPadding
  • frxTableObject


TfrxContainerPadding.RightPading Property

Summary

Right padding value.

Namespace: frxTableObject
Syntax
Delphi
published
 property RightPading: Extended read FRightPading write FRightPading;

Property Value

Type: Extended

See Also

Reference

  • TfrxContainerPadding
  • frxTableObject


TfrxContainerPadding.TopPading Property

Summary

Top padding value.

Namespace: frxTableObject
Syntax
Delphi
published
 property TopPading: Extended read FTopPading write FTopPading;

Property Value

Type: Extended

See Also

Reference

  • TfrxContainerPadding
  • frxTableObject


TfrxContainerPadding Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TfrxContainerPadding.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxTableObject
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxContainerPadding
  • frxTableObject


TfrxContainerPadding Fields

Fields
Name | Description
FBottomPading | Represents field FBottomPading.
FLeftPading | Represents field FLeftPading.
FRightPading | Represents field FRightPading.
FTopPading | Represents field FTopPading.
Top


TfrxContainerPadding.FBottomPading Field

Summary

Represents field FBottomPading.

Namespace: frxTableObject
Syntax
Delphi
private
 FBottomPading: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxContainerPadding
  • frxTableObject


TfrxContainerPadding.FLeftPading Field

Summary

Represents field FLeftPading.

Namespace: frxTableObject
Syntax
Delphi
private
 FLeftPading: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxContainerPadding
  • frxTableObject


TfrxContainerPadding.FRightPading Field

Summary

Represents field FRightPading.

Namespace: frxTableObject
Syntax
Delphi
private
 FRightPading: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxContainerPadding
  • frxTableObject


TfrxContainerPadding.FTopPading Field

Summary

Represents field FTopPading.

Namespace: frxTableObject
Syntax
Delphi
private
 FTopPading: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxContainerPadding
  • frxTableObject


TfrxHackView Class

Summary

Represents type TfrxHackView.

Namespace: frxTableObject
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxTableObject.TfrxHackView
Syntax
Delphi
type
 TfrxHackView = class(TfrxView);

The TfrxHackView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxView class. (Overrides TfrxReportComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Object's cursor (in the preview mode). (Inherited from TfrxView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Object's frame. (Inherited from TfrxView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxReportComponent.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxReportComponent.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxTableObject


TfrxReportTableObject Class

Summary

The TfrxReportTableObject allows use of the Table component in a report. TfrxReportTableObject is an empty component. It is used to add table unit to uses clause of an application.

Namespace: frxTableObject
Inheritance Hierarchy
TComponent
frxTableObject.TfrxReportTableObject
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxReportTableObject = class(TComponent)
 end;
See Also

Reference

  • frxTableObject


TfrxTableCell Class

Summary

This class represent a table cell. The table call can be used as a container for other component or as Text object. It inherits most of the properties from "Text" object.

Namespace: frxTableObject
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxClass.TfrxCustomMemoView
frxTableObject.TfrxTableCell
Syntax
Delphi
type
 TfrxTableCell = class(TfrxCustomMemoView)
 end;

The TfrxTableCell type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTableCell class. (Overrides TfrxCustomMemoView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxTableCell class. (Overrides TfrxCustomMemoView.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowExpressions | Represents property AllowExpressions.
AllowHTMLTags | Represents property AllowHTMLTags.
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
AnsiText | Text of the object in ANSI format based on current Locale settings. (Inherited from TfrxCustomMemoView.)
AutoWidth | Determines if the text object should handle its width automatically. (Inherited from TfrxCustomMemoView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Represents property BrushStyle.
CanShrink | True if object can shrink height base on its content. (Inherited from TfrxStretcheable.)
CharSpacing | Represents property CharSpacing.
Clipped | Represents property Clipped.
Color | Represents property Color.
ColSpan | Count of column spans for current cell.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
ContainerPadding | Composite padding object which stores values for padding inside Table cell used for inner objects align.
Cursor | Represents property Cursor. (Inherited from TfrxCustomMemoView.)
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DisplayFormat | Represents property DisplayFormat.
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Duplicates | Determines how to process repeated values. Default value is dmShow. (Inherited from TfrxCustomMemoView.)
ExpressionDelimiters | Represents property ExpressionDelimiters.
Fill | Represents property Fill.
FillType | Represents property FillType.
FirstParaBreak | Internal use. Determines first paragraph break if object where split. (Inherited from TfrxCustomMemoView.)
FlowTo | Represents property FlowTo.
Font | Represents property Font.
Formats | Collection of Formats. The object can hold several formats for each expression inside an object. (Inherited from TfrxCustomMemoView.)
Frame | Represents property Frame.
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GapX | Represents property GapX.
GapY | Represents property GapY.
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
HAlign | Represents property HAlign.
Height | Represents property Height. (Inherited from TfrxView.)
HideZeros | Represents property HideZeros.
Highlight | Represents property Highlight.
Highlights | Collection of Highlights. The object can hold several highlights which serves different conditions. (Inherited from TfrxCustomMemoView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
LastParaBreak | Internal use. Determines last paragraph break if object where split. (Inherited from TfrxCustomMemoView.)
Left | Represents property Left. (Inherited from TfrxView.)
Lines | Text lines of the object. (Inherited from TfrxCustomMemoView.)
LineSpacing | Represents property LineSpacing.
Memo | Represents property Memo.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
ParagraphGap | Represents property ParagraphGap.
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | Represents property ParentFont.
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
Rotation | Represents property Rotation.
RowSpan | Count of row spans for current cell.
RTLReading | Represents property RTLReading.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StretchMode | Object's stretch mode. (Inherited from TfrxStretcheable.)
Style | Represents property Style.
SuppressRepeated | Represents property SuppressRepeated.
TagStr | Represents property TagStr. (Inherited from TfrxCustomMemoView.)
Text | Text of the object. (Inherited from TfrxCustomMemoView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Underlines | Represents property Underlines.
UnderlinesTextMode | Determines how to show underlines in text object. Default value is ulmNone. (Inherited from TfrxCustomMemoView.)
URL | Represents property URL. (Inherited from TfrxCustomMemoView.)
UseDefaultCharset | Represents property UseDefaultCharset.
VAlign | Represents property VAlign.
Value | Stores value of Format operation(for single expression or DataSet only) with respect of its type. (Inherited from TfrxCustomMemoView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
WordBreak | Represents property WordBreak.
WordWrap | Represents property WordWrap.
Wysiwyg | Represents property Wysiwyg.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxCustomMemoView.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
ApplyHighlight(TfrxHighlight) | Apply Highlight to object. (Inherited from TfrxCustomMemoView.)
ApplyPreviewHighlight | Apply active highlight for object in prepared report. (Inherited from TfrxCustomMemoView.)
ApplyStyle(TfrxStyleItem) | Applies the given style to the object. (Inherited from TfrxCustomMemoView.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxCustomMemoView.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Overrides TfrxView.BeginDraw(TCanvas,Extended,Extended,Extended,Extended).)
CalcAndFormat(WideString,TfrxFormat) | Represents method CalcAndFormat(WideString,TfrxFormat). (Inherited from TfrxCustomMemoView.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxCustomMemoView.CalcHeight.)
CalcTextRect(Extended,Extended,Extended,Extended) | Represents method CalcTextRect(Extended,Extended,Extended,Extended). (Inherited from TfrxCustomMemoView.)
CalcWidth | Calculates and returns the object's width, in pixels. (Inherited from TfrxCustomMemoView.)
CellHeight | Represents method CellHeight.
CellWidth | Represents method CellWidth.
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Inherited from TfrxCustomMemoView.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxCustomMemoView.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxCustomMemoView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxStretcheable.DrawPart.)
DrawSelected(TColor) | Draws cell selection area.
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Overrides TfrxReportComponent.DrawSizeBox(TCanvas,Extended,Boolean).)
DrawText | Represents method DrawText. (Inherited from TfrxCustomMemoView.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
ExtractMacros(TfrxPostProcessor) | Extract macros from the object text and replaces them with values. (Inherited from TfrxCustomMemoView.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
FormatData(Variant,TfrxFormat) | Formats the value passed in the "Value" parameter and returns the result as a string. This method is used format settings stored in the DisplayFormat property. If AFormat parameter is set, it is used for formatting instead of DisplayFormat property. (Inherited from TfrxCustomMemoView.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Overrides TfrxComponent.GetClientArea.)
GetComponentText | Returns text of the report object. Used in export filters. (Overrides TfrxReportComponent.GetComponentText.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxCustomMemoView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Overrides TfrxComponent.GetRestrictions.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Inherited from TfrxStretcheable.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object. (Overrides TfrxStretcheable.InitPart.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Overrides TfrxComponent.IsAcceptControl(TfrxComponent).)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Overrides TfrxComponent.IsHeightStored.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Overrides TfrxComponent.IsLeftStored.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsPaddingStored | Represents method IsPaddingStored.
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Overrides TfrxView.IsPostProcessAllowed.)
IsTopStored | Represents method IsTopStored. (Overrides TfrxComponent.IsTopStored.)
IsWidthStored | Represents method IsWidthStored. (Overrides TfrxComponent.IsWidthStored.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Overrides TfrxView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).)
Loaded | Represents method Loaded. (Inherited from TfrxCustomMemoView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxView.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxView.Notification(TComponent,TOperation).)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ParentRow | Returns reference to a parent "Row" object.
ParentTable | Returns reference to a parent "Table" object.
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Overrides TfrxView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.ReadNestedProperty(TfrxXMLItem).)
ReducedAngle | Normalize angle to 360 degrees. (Inherited from TfrxCustomMemoView.)
ResetSuppress | Deprecated. Reset suppressed values. (Inherited from TfrxCustomMemoView.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Overrides TfrxView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor).)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetColSpan(Integer) | Represents method SetColSpan(Integer).
SetContainerPadding(TfrxContainerPadding) | Represents method SetContainerPadding(TfrxContainerPadding).
SetDrawParams(TCanvas,Extended,Extended,Extended,Extended) | Represents method SetDrawParams(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxCustomMemoView.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Overrides TfrxComponent.SetIsSelected(Boolean).)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetRowSpan(Integer) | Represents method SetRowSpan(Integer).
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WrapText(Boolean,TWideStrings) | Breaks the text so all strings would fit in the object's width, and returns the resulting text. (Inherited from TfrxCustomMemoView.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Overrides TfrxComponent.WriteNestedProperties(TfrxXMLItem,TPersistent).)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FColSpan | Represents field FColSpan.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FContainerPadding | Represents field FContainerPadding.
FCopyNo | Represents field FCopyNo. (Inherited from TfrxCustomMemoView.)
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHidden | Represents field FHidden.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FIndex | Represents field FIndex.
FLastValue | Represents field FLastValue. (Inherited from TfrxCustomMemoView.)
FMacroIndex | Represents field FMacroIndex. (Inherited from TfrxCustomMemoView.)
FMacroLine | Represents field FMacroLine. (Inherited from TfrxCustomMemoView.)
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FPrintScale | Represents field FPrintScale. (Inherited from TfrxCustomMemoView.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FRowSpan | Represents field FRowSpan.
FSavedTop | Internal use only. Stores original top during shift operation. (Inherited from TfrxStretcheable.)
FSaveHeight | Internal use only. Stores object Height during stretch operation. (Inherited from TfrxStretcheable.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FTextRect | Represents field FTextRect. (Inherited from TfrxCustomMemoView.)
FTotalPages | Represents field FTotalPages. (Inherited from TfrxCustomMemoView.)
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxTableObject


TfrxTableCell Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTableCell class. (Overrides TfrxCustomMemoView.Create(TComponent).)
Destroy | Represents the destructor of the TfrxTableCell class. (Overrides TfrxCustomMemoView.Destroy.)
Top


TfrxTableCell.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxTableCell class.

Namespace: frxTableObject
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomMemoView.Create(TComponent)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Destroy Destructor

Summary

Represents the destructor of the TfrxTableCell class.

Namespace: frxTableObject
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxCustomMemoView.Destroy
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell Properties

Properties
Name | Description
AllowExpressions | Represents property AllowExpressions.
AllowHTMLTags | Represents property AllowHTMLTags.
BrushStyle | Represents property BrushStyle.
CharSpacing | Represents property CharSpacing.
Clipped | Represents property Clipped.
Color | Represents property Color.
ColSpan | Count of column spans for current cell.
ContainerPadding | Composite padding object which stores values for padding inside Table cell used for inner objects align.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
DisplayFormat | Represents property DisplayFormat.
ExpressionDelimiters | Represents property ExpressionDelimiters.
Fill | Represents property Fill.
FillType | Represents property FillType.
FlowTo | Represents property FlowTo.
Font | Represents property Font.
Frame | Represents property Frame.
GapX | Represents property GapX.
GapY | Represents property GapY.
HAlign | Represents property HAlign.
HideZeros | Represents property HideZeros.
Highlight | Represents property Highlight.
LineSpacing | Represents property LineSpacing.
Memo | Represents property Memo.
ParagraphGap | Represents property ParagraphGap.
ParentFont | Represents property ParentFont.
Rotation | Represents property Rotation.
RowSpan | Count of row spans for current cell.
RTLReading | Represents property RTLReading.
Style | Represents property Style.
SuppressRepeated | Represents property SuppressRepeated.
Underlines | Represents property Underlines.
UseDefaultCharset | Represents property UseDefaultCharset.
VAlign | Represents property VAlign.
WordBreak | Represents property WordBreak.
WordWrap | Represents property WordWrap.
Wysiwyg | Represents property Wysiwyg.
Top


TfrxTableCell.AllowExpressions Property

Summary

Represents property AllowExpressions.

Namespace: frxTableObject
Syntax
Delphi
published
 property AllowExpressions;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.AllowHTMLTags Property

Summary

Represents property AllowHTMLTags.

Namespace: frxTableObject
Syntax
Delphi
published
 property AllowHTMLTags;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.BrushStyle Property

Summary

Represents property BrushStyle.

Namespace: frxTableObject
Syntax
Delphi
published
 property BrushStyle;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.CharSpacing Property

Summary

Represents property CharSpacing.

Namespace: frxTableObject
Syntax
Delphi
published
 property CharSpacing;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Clipped Property

Summary

Represents property Clipped.

Namespace: frxTableObject
Syntax
Delphi
published
 property Clipped;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Color Property

Summary

Represents property Color.

Namespace: frxTableObject
Syntax
Delphi
published
 property Color;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.ColSpan Property

Summary

Count of column spans for current cell.

Namespace: frxTableObject
Syntax
Delphi
published
 property ColSpan: Integer read FColSpan write SetColSpan default 1;

Property Value

Type: Integer

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.ContainerPadding Property

Summary

Composite padding object which stores values for padding inside Table cell used for inner objects align.

Namespace: frxTableObject
Syntax
Delphi
published
 property ContainerPadding: TfrxContainerPadding read FContainerPadding write SetContainerPadding stored IsPaddingStored;

Property Value

Type: TfrxContainerPadding

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.DataField Property

Summary

Represents property DataField.

Namespace: frxTableObject
Syntax
Delphi
published
 property DataField;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.DataSet Property

Summary

Represents property DataSet.

Namespace: frxTableObject
Syntax
Delphi
published
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxTableObject
Syntax
Delphi
published
 property DataSetName;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.DisplayFormat Property

Summary

Represents property DisplayFormat.

Namespace: frxTableObject
Syntax
Delphi
published
 property DisplayFormat;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.ExpressionDelimiters Property

Summary

Represents property ExpressionDelimiters.

Namespace: frxTableObject
Syntax
Delphi
published
 property ExpressionDelimiters;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Fill Property

Summary

Represents property Fill.

Namespace: frxTableObject
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.FillType Property

Summary

Represents property FillType.

Namespace: frxTableObject
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.FlowTo Property

Summary

Represents property FlowTo.

Namespace: frxTableObject
Syntax
Delphi
published
 property FlowTo;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Font Property

Summary

Represents property Font.

Namespace: frxTableObject
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Frame Property

Summary

Represents property Frame.

Namespace: frxTableObject
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.GapX Property

Summary

Represents property GapX.

Namespace: frxTableObject
Syntax
Delphi
published
 property GapX;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.GapY Property

Summary

Represents property GapY.

Namespace: frxTableObject
Syntax
Delphi
published
 property GapY;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.HAlign Property

Summary

Represents property HAlign.

Namespace: frxTableObject
Syntax
Delphi
published
 property HAlign;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.HideZeros Property

Summary

Represents property HideZeros.

Namespace: frxTableObject
Syntax
Delphi
published
 property HideZeros;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Highlight Property

Summary

Represents property Highlight.

Namespace: frxTableObject
Syntax
Delphi
published
 property Highlight;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.LineSpacing Property

Summary

Represents property LineSpacing.

Namespace: frxTableObject
Syntax
Delphi
published
 property LineSpacing;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Memo Property

Summary

Represents property Memo.

Namespace: frxTableObject
Syntax
Delphi
published
 property Memo;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.ParagraphGap Property

Summary

Represents property ParagraphGap.

Namespace: frxTableObject
Syntax
Delphi
published
 property ParagraphGap;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.ParentFont Property

Summary

Represents property ParentFont.

Namespace: frxTableObject
Syntax
Delphi
published
 property ParentFont;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Rotation Property

Summary

Represents property Rotation.

Namespace: frxTableObject
Syntax
Delphi
published
 property Rotation;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.RowSpan Property

Summary

Count of row spans for current cell.

Namespace: frxTableObject
Syntax
Delphi
published
 property RowSpan: Integer read FRowSpan write SetRowSpan default 1;

Property Value

Type: Integer

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.RTLReading Property

Summary

Represents property RTLReading.

Namespace: frxTableObject
Syntax
Delphi
published
 property RTLReading;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Style Property

Summary

Represents property Style.

Namespace: frxTableObject
Syntax
Delphi
published
 property Style;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.SuppressRepeated Property

Summary

Represents property SuppressRepeated.

Namespace: frxTableObject
Syntax
Delphi
published
 property SuppressRepeated;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Underlines Property

Summary

Represents property Underlines.

Namespace: frxTableObject
Syntax
Delphi
published
 property Underlines;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.UseDefaultCharset Property

Summary

Represents property UseDefaultCharset.

Namespace: frxTableObject
Syntax
Delphi
published
 property UseDefaultCharset;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.VAlign Property

Summary

Represents property VAlign.

Namespace: frxTableObject
Syntax
Delphi
published
 property VAlign;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.WordBreak Property

Summary

Represents property WordBreak.

Namespace: frxTableObject
Syntax
Delphi
published
 property WordBreak;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.WordWrap Property

Summary

Represents property WordWrap.

Namespace: frxTableObject
Syntax
Delphi
published
 property WordWrap;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Wysiwyg Property

Summary

Represents property Wysiwyg.

Namespace: frxTableObject
Syntax
Delphi
published
 property Wysiwyg;

Property Value

Type: Void

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell Methods

Methods
Name | Description
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxCustomMemoView.AfterPrint.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxCustomMemoView.BeforePrint.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxCustomMemoView.CalcHeight.)
CellHeight | Represents method CellHeight.
CellWidth | Represents method CellWidth.
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxCustomMemoView.Diff(TfrxComponent).)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxCustomMemoView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawSelected(TColor) | Draws cell selection area.
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Overrides TfrxReportComponent.DrawSizeBox(TCanvas,Extended,Boolean).)
GetClientArea | Return client area of object. (Overrides TfrxComponent.GetClientArea.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxCustomMemoView.GetData.)
GetRestrictions | Represents method GetRestrictions. (Overrides TfrxComponent.GetRestrictions.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Overrides TfrxComponent.IsAcceptControl(TfrxComponent).)
IsHeightStored | Represents method IsHeightStored. (Overrides TfrxComponent.IsHeightStored.)
IsLeftStored | Represents method IsLeftStored. (Overrides TfrxComponent.IsLeftStored.)
IsOwnerDraw | Returns True when parent container should draw child. (Overrides TfrxReportComponent.IsOwnerDraw.)
IsPaddingStored | Represents method IsPaddingStored.
IsTopStored | Represents method IsTopStored. (Overrides TfrxComponent.IsTopStored.)
IsWidthStored | Represents method IsWidthStored. (Overrides TfrxComponent.IsWidthStored.)
ParentRow | Returns reference to a parent "Row" object.
ParentTable | Returns reference to a parent "Table" object.
SetColSpan(Integer) | Represents method SetColSpan(Integer).
SetContainerPadding(TfrxContainerPadding) | Represents method SetContainerPadding(TfrxContainerPadding).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Overrides TfrxComponent.SetIsSelected(Boolean).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetRowSpan(Integer) | Represents method SetRowSpan(Integer).
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Overrides TfrxComponent.SetVisible(Boolean).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
Top


TfrxTableCell.AfterPrint Method

Summary

The report engine calls this method after object was prepared and placed to preview pages.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure AfterPrint; override;

Overrides

TfrxCustomMemoView.AfterPrint
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.BeforePrint Method

Summary

The report engine calls this method before prepare object and place it to preview pages.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure BeforePrint; override;

Overrides

TfrxCustomMemoView.BeforePrint
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.CalcHeight Method

Summary

Calculates and returns the object's height according to the data placed in it.

Namespace: frxTableObject
Syntax
Delphi
public
 function CalcHeight: Extended; override;

Return Value

Type: Extended

Overrides

TfrxCustomMemoView.CalcHeight
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.CellHeight Method

Summary

Represents method CellHeight.

Namespace: frxTableObject
Syntax
Delphi
private
 function CellHeight: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.CellWidth Method

Summary

Represents method CellWidth.

Namespace: frxTableObject
Syntax
Delphi
private
 function CellWidth: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Diff(TfrxComponent) Method

Summary

Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set.

Namespace: frxTableObject
Syntax
Delphi
public
 function Diff(AComponent: TfrxComponent): String; override;

Parameters

AComponent
Type: TfrxComponent

Return Value

Type: String

Overrides

TfrxCustomMemoView.Diff(TfrxComponent)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) Method

Summary

Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 function DoDragOver(Source: TObject; X, Y: Integer; State: TDragState;
 var Accept: Boolean; var EventParams: TfrxInteractiveEventsParams)
 : Boolean; override;

Parameters

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams)
 : Boolean; override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DoMouseMove(X, Y: Integer; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DoMouseUp(X, Y: Integer; Button: TMouseButton; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxCustomMemoView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.DrawSelected(TColor) Method

Summary

Draws cell selection area.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DrawSelected(Color: TColor = clSkyBlue);

Parameters

Color
Type: TColor

Selection color.

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.DrawSizeBox(TCanvas,Extended,Boolean) Method

Summary

Draws size boxes around report objects in the report designer.

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure DrawSizeBox(aCanvas: TCanvas; aScale: Extended; bForceDraw: Boolean = False); override;

Parameters

aCanvas
Type: TCanvas

aScale
Type: Extended

bForceDraw
Type: Boolean

Overrides

TfrxReportComponent.DrawSizeBox(TCanvas,Extended,Boolean)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.GetClientArea Method

Summary

Return client area of object.

Namespace: frxTableObject
Syntax
Delphi
public
 function GetClientArea: TfrxRect; override;

Return Value

Type: TfrxRect

Overrides

TfrxComponent.GetClientArea
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxCustomMemoView.GetData
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.GetRestrictions Method

Summary

Represents method GetRestrictions.

Namespace: frxTableObject
Syntax
Delphi
protected
 function GetRestrictions: TfrxRestrictions; override;

Return Value

Type: TfrxRestrictions

Overrides

TfrxComponent.GetRestrictions
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.IsAcceptControl(TfrxComponent) Method

Summary

Returns true when component can accept component in aControl as child.

Namespace: frxTableObject
Syntax
Delphi
public
 function IsAcceptControl(aControl: TfrxComponent): Boolean; override;

Parameters

aControl
Type: TfrxComponent

Component that supposedly should become a child.

Return Value

Type: Boolean

Overrides

TfrxComponent.IsAcceptControl(TfrxComponent)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.IsHeightStored Method

Summary

Represents method IsHeightStored.

Namespace: frxTableObject
Syntax
Delphi
protected
 function IsHeightStored: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxComponent.IsHeightStored
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.IsLeftStored Method

Summary

Represents method IsLeftStored.

Namespace: frxTableObject
Syntax
Delphi
protected
 function IsLeftStored: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxComponent.IsLeftStored
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.IsOwnerDraw Method

Summary

Returns True when parent container should draw child.

Namespace: frxTableObject
Syntax
Delphi
public
 function IsOwnerDraw: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxReportComponent.IsOwnerDraw
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.IsPaddingStored Method

Summary

Represents method IsPaddingStored.

Namespace: frxTableObject
Syntax
Delphi
private
 function IsPaddingStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.IsTopStored Method

Summary

Represents method IsTopStored.

Namespace: frxTableObject
Syntax
Delphi
protected
 function IsTopStored: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxComponent.IsTopStored
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.IsWidthStored Method

Summary

Represents method IsWidthStored.

Namespace: frxTableObject
Syntax
Delphi
protected
 function IsWidthStored: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxComponent.IsWidthStored
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.ParentRow Method

Summary

Returns reference to a parent "Row" object.

Namespace: frxTableObject
Syntax
Delphi
public
 function ParentRow: TfrxTableRow;

Return Value

Type: TfrxTableRow

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.ParentTable Method

Summary

Returns reference to a parent "Table" object.

Namespace: frxTableObject
Syntax
Delphi
public
 function ParentTable: TfrxTableObject;

Return Value

Type: TfrxTableObject

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.SetColSpan(Integer) Method

Summary

Represents method SetColSpan(Integer).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure SetColSpan(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.SetContainerPadding(TfrxContainerPadding) Method

Summary

Represents method SetContainerPadding(TfrxContainerPadding).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure SetContainerPadding(const Value: TfrxContainerPadding);

Parameters

Value
Type: TfrxContainerPadding

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.SetHeight(Extended) Method

Summary

Represents method SetHeight(Extended).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure SetHeight(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetHeight(Extended)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.SetIsSelected(Boolean) Method

Summary

Represents method SetIsSelected(Boolean).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure SetIsSelected(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TfrxComponent.SetIsSelected(Boolean)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.SetParent(TfrxComponent) Method

Summary

Represents method SetParent(TfrxComponent).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure SetParent(AParent: TfrxComponent); override;

Parameters

AParent
Type: TfrxComponent

Overrides

TfrxComponent.SetParent(TfrxComponent)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.SetRowSpan(Integer) Method

Summary

Represents method SetRowSpan(Integer).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure SetRowSpan(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.SetVisible(Boolean) Method

Summary

Represents method SetVisible(Boolean).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure SetVisible(Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TfrxComponent.SetVisible(Boolean)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.SetWidth(Extended) Method

Summary

Represents method SetWidth(Extended).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure SetWidth(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetWidth(Extended)
See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell Fields

Fields
Name | Description
FColSpan | Represents field FColSpan.
FContainerPadding | Represents field FContainerPadding.
FHidden | Represents field FHidden.
FIndex | Represents field FIndex.
FRowSpan | Represents field FRowSpan.
Top


TfrxTableCell.FColSpan Field

Summary

Represents field FColSpan.

Namespace: frxTableObject
Syntax
Delphi
private
 FColSpan: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.FContainerPadding Field

Summary

Represents field FContainerPadding.

Namespace: frxTableObject
Syntax
Delphi
private
 FContainerPadding: TfrxContainerPadding;

Field Value

Type: TfrxContainerPadding

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.FHidden Field

Summary

Represents field FHidden.

Namespace: frxTableObject
Syntax
Delphi
private
 FHidden: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.FIndex Field

Summary

Represents field FIndex.

Namespace: frxTableObject
Syntax
Delphi
protected
 FIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableCell.FRowSpan Field

Summary

Represents field FRowSpan.

Namespace: frxTableObject
Syntax
Delphi
private
 FRowSpan: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableCell
  • frxTableObject


TfrxTableColumn Class

Summary

Represents Table column.

Namespace: frxTableObject
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxTableObject.TfrxTableRowColumnBase
frxTableObject.TfrxTableColumn
Syntax
Delphi
type
 TfrxTableColumn = class(TfrxTableRowColumnBase)
 end;

The TfrxTableColumn type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTableColumn class. (Overrides TfrxComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxTableColumn class. (Overrides TfrxTableRowColumnBase.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
AutoSize | When this property is set, Table object automatically calculates width of column or height of row based on content inside cells. (Inherited from TfrxTableRowColumnBase.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Object's description. (Inherited from TfrxComponent.)
Font | Object's font. (Inherited from TfrxComponent.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
Index | Index of current row or column. (Inherited from TfrxTableRowColumnBase.)
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
MaxWidth | Maximum width of current column. Column width can not be grater than this value when AutoSize is turned on.
MinWidth | Minimal width of current column. Column width can not be less than this value when AutoSize is turned on.
Objects | The list of child objects. (Inherited from TfrxComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Global visibility of the object in the result report. (Inherited from TfrxComponent.)
Width | Represents property Width.
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxTableRowColumnBase.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Overrides TfrxComponent.IsHeightStored.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Overrides TfrxComponent.IsLeftStored.)
IsTopStored | Represents method IsTopStored. (Overrides TfrxComponent.IsTopStored.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ParentTable | Returns reference to a parent "Table" object. (Inherited from TfrxTableRowColumnBase.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Overrides TfrxComponent.SetIsSelected(Boolean).)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FIndex | Represents field FIndex. (Inherited from TfrxTableRowColumnBase.)
FMaxWidth | Represents field FMaxWidth.
FMinWidth | Represents field FMinWidth.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
Top
See Also

Reference

  • frxTableObject


TfrxTableColumn Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTableColumn class. (Overrides TfrxComponent.Create(TComponent).)
Destroy | Represents the destructor of the TfrxTableColumn class. (Overrides TfrxTableRowColumnBase.Destroy.)
Top


TfrxTableColumn.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxTableColumn class.

Namespace: frxTableObject
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxComponent.Create(TComponent)
See Also

Reference

  • TfrxTableColumn
  • frxTableObject


TfrxTableColumn.Destroy Destructor

Summary

Represents the destructor of the TfrxTableColumn class.

Namespace: frxTableObject
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxTableRowColumnBase.Destroy
See Also

Reference

  • TfrxTableColumn
  • frxTableObject


TfrxTableColumn Properties

Properties
Name | Description
MaxWidth | Maximum width of current column. Column width can not be grater than this value when AutoSize is turned on.
MinWidth | Minimal width of current column. Column width can not be less than this value when AutoSize is turned on.
Width | Represents property Width.
Top


TfrxTableColumn.MaxWidth Property

Summary

Maximum width of current column. Column width can not be grater than this value when AutoSize is turned on.

Namespace: frxTableObject
Syntax
Delphi
published
 property MaxWidth: Extended read FMaxWidth write FMaxWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxTableColumn
  • frxTableObject


TfrxTableColumn.MinWidth Property

Summary

Minimal width of current column. Column width can not be less than this value when AutoSize is turned on.

Namespace: frxTableObject
Syntax
Delphi
published
 property MinWidth: Extended read FMinWidth write FMinWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxTableColumn
  • frxTableObject


TfrxTableColumn.Width Property

Summary

Represents property Width.

Namespace: frxTableObject
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TfrxTableColumn
  • frxTableObject


TfrxTableColumn Methods

Methods
Name | Description
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxTableRowColumnBase.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Overrides TfrxComponent.IsHeightStored.)
Top


TfrxTableColumn.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DoMouseUp(X, Y: Integer; Button: TMouseButton; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxTableRowColumnBase.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableColumn
  • frxTableObject


TfrxTableColumn.IsContain(Extended,Extended) Method

Summary

Detects if point is inside an object coordinates.

Namespace: frxTableObject
Syntax
Delphi
published
 function IsContain(X, Y: Extended): Boolean; override;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

Overrides

TfrxComponent.IsContain(Extended,Extended)
See Also

Reference

  • TfrxTableColumn
  • frxTableObject


TfrxTableColumn.IsHeightStored Method

Summary

Represents method IsHeightStored.

Namespace: frxTableObject
Syntax
Delphi
protected
 function IsHeightStored: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxComponent.IsHeightStored
See Also

Reference

  • TfrxTableColumn
  • frxTableObject


TfrxTableColumn Fields

Fields
Name | Description
FMaxWidth | Represents field FMaxWidth.
FMinWidth | Represents field FMinWidth.
Top


TfrxTableColumn.FMaxWidth Field

Summary

Represents field FMaxWidth.

Namespace: frxTableObject
Syntax
Delphi
private
 FMaxWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxTableColumn
  • frxTableObject


TfrxTableColumn.FMinWidth Field

Summary

Represents field FMinWidth.

Namespace: frxTableObject
Syntax
Delphi
private
 FMinWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxTableColumn
  • frxTableObject


TfrxTableObject Class

Summary

The TfrxTableObject component represents a Table object. The table object used to group report data or object in one big tabular structure. With table object it's more easy to change appearance of the tabular based reports. Table may grow in size based on content inside cells. The table cells can contain other objects. The table size controls by rows and column count.

Namespace: frxTableObject
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxClass.TfrxStretcheable
frxTableObject.TfrxTableObject
Syntax
Delphi
type
 TfrxTableObject = class(TfrxStretcheable)
 end;

The TfrxTableObject type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTableObject class. (Overrides TfrxStretcheable.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Overrides TfrxComponent.DesignCreate(TComponent,Word).)
Destroy | Represents the destructor of the TfrxTableObject class. (Overrides TfrxView.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
CanShrink | True if object can shrink height base on its content. (Inherited from TfrxStretcheable.)
Cells[Integer,Integer] | Matrix of cell objects.
Color | Object's filling color (deprecated check Fill property). (Inherited from TfrxView.)
ColumnCount | Count of columns in the table object.
Columns[Integer] | List of table columns.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Object's cursor (in the preview mode). (Inherited from TfrxView.)
DataField | Data field's name, which the object is connected to. (Inherited from TfrxView.)
DataSet | Data source, which the object is connected to. (Inherited from TfrxView.)
DataSetName | Name of data source, which the object is connected to. This property duplicates the DataSet property. (Inherited from TfrxView.)
DefaultCellHeight | Default cell height used during creation of new row or column.
DefaultCellWidth | Default cell width used during creation of new row or column.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Fill | Reference to fill instance based on FillType. (Inherited from TfrxView.)
FillType | Object fill type. (Inherited from TfrxView.)
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Object's frame. (Inherited from TfrxView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Represents property Left. (Inherited from TfrxView.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
RowCount | Count of rows in the table object.
Rows[Integer] | List of table rows.
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowHint | Show/hide hint. (Inherited from TfrxView.)
StretchMode | Object's stretch mode. (Inherited from TfrxStretcheable.)
TableHeight | Height of the table object.
TableWidth | Width of the table object
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddColumn(TfrxTableColumn) | Adds column by it reference to the end of the table.
AddRow(TfrxTableRow) | Adds row by it reference to the end of the table.
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxView.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Overrides TfrxComponent.AlignChildren(Boolean,TfrxMirrorControlModes).)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
AssignCellAppearance(TfrxTableCell,TfrxTableCell) | Represents method AssignCellAppearance(TfrxTableCell,TfrxTableCell).
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxStretcheable.CalcHeight.)
CalcHeightInternal | Represents method CalcHeightInternal.
CalcWidthInternal | Represents method CalcWidthInternal.
CheckColumnSelector(Extended,Extended) | Represents method CheckColumnSelector(Extended,Extended).
CheckMoveArrow(Extended,Extended) | Represents method CheckMoveArrow(Extended,Extended).
CheckRowSelector(Extended,Extended) | Represents method CheckRowSelector(Extended,Extended).
CheckSizeArrow(Extended,Extended) | Represents method CheckSizeArrow(Extended,Extended).
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectSpansOnColumnChange(Integer,Integer) | Represents method CorrectSpansOnColumnChange(Integer,Integer).
CorrectSpansOnRowChange(Integer,Integer) | Represents method CorrectSpansOnRowChange(Integer,Integer).
CreateNewColumn(Integer) | Helper method used to create new column and insert it by given index into current table object.
CreateNewRow(Integer) | Helper method used to create new row and insert it by given index into current table object.
CreateTableColumn | Represents method CreateTableColumn.
CreateTableRow | Represents method CreateTableRow.
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
DeleteColumn(Integer) | Deletes column from the table.
DeleteRow(Integer) | Deletes row from the table.
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Overrides TfrxComponent.DoMirror(TfrxMirrorControlModes).)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxStretcheable.DrawPart.)
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawTable(Boolean) | Represents method DrawTable(Boolean).
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Overrides TfrxComponent.ExportInternal(TfrxCustomExportFilter).)
FillSpanList(TfrxRectArray) | Represents method FillSpanList(TfrxRectArray).
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetCell(Integer,Integer) | Represents method GetCell(Integer,Integer).
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetColumn(Integer) | Represents method GetColumn(Integer).
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetRow(Integer) | Represents method GetRow(Integer).
GetRowColumnByClass(TClass,Integer) | Represents method GetRowColumnByClass(TClass,Integer).
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Overrides TfrxReportComponent.GetSaveToComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetTableHeight | Represents method GetTableHeight.
GetTableWidth | Represents method GetTableWidth.
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Overrides TfrxStretcheable.HasNextDataPart(Extended).)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitPart | Initialize part of Splittable object. (Overrides TfrxStretcheable.InitPart.)
InsertColumn(Integer,TfrxTableColumn) | Inserts column by it reference to given position.
InsertRow(Integer,TfrxTableRow) | Inserts row by it reference to given position.
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxView.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Overrides TfrxComponent.IsHeightStored.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsInsideSpan(TfrxRectArray,TPoint) | Represents method IsInsideSpan(TfrxRectArray,TPoint).
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTableActive | Represents method IsTableActive.
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Overrides TfrxComponent.IsWidthStored.)
JoinSelection(Integer,Integer,Integer,Integer) | Joins selected cells to one big by setting ColSpan and RowSpan properties.
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
Loaded | Represents method Loaded.
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
MoveColumn(Integer,Integer) | Moves culumn of the table from one position to another.
NormalizeObjectsList | Represents method NormalizeObjectsList.
NormalizeSpans | Represents method NormalizeSpans.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Overrides TfrxComponent.ObjectListNotify(Pointer,TListNotification).)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
ResetSpanList | Represents method ResetSpanList.
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetColumnCount(Integer) | Represents method SetColumnCount(Integer).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetRowCount(Integer) | Represents method SetRowCount(Integer).
SetTableHeight(Extended) | Represents method SetTableHeight(Extended).
SetTableWidth(Extended) | Represents method SetTableWidth(Extended).
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
SplitCell(TfrxTableCell) | Splits cell by reset ColSpan and RowSpan properties.
SplitSelected | Splits selected cells by reset ColSpan and RowSpan properties.
SwapRows(Integer,Integer) | Swaps positions of two rows in the table.
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Overrides TfrxComponent.UpdateBounds.)
UpdateCellDimensions(TfrxTableCell) | Represents method UpdateCellDimensions(TfrxTableCell).
UpdateDesigner | Represents method UpdateDesigner.
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FBoundsUpdating | Represents field FBoundsUpdating.
FBrakeTo | Represents field FBrakeTo.
FBreakRowIndex | Represents field FBreakRowIndex.
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FCellsSelection | Represents field FCellsSelection.
FColumnCount | Represents field FColumnCount.
FColumnSelection | Represents field FColumnSelection.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FCopyAppearance | Represents field FCopyAppearance.
FDefaultCellHeight | Represents field FDefaultCellHeight.
FDefaultCellWidth | Represents field FDefaultCellWidth.
FDragDropActive | Represents field FDragDropActive.
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FHorzSplitter | Represents field FHorzSplitter.
FLastMousePos | Represents field FLastMousePos.
FLockCorrectSpans | Represents field FLockCorrectSpans.
FLockObjectsUpdate | Represents field FLockObjectsUpdate.
FModified | Represents field FModified.
FNewColumnDim | Represents field FNewColumnDim.
FNewRowDim | Represents field FNewRowDim.
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FResizeActive | Represents field FResizeActive.
FRowCount | Represents field FRowCount.
FRowSelection | Represents field FRowSelection.
FSavedTop | Internal use only. Stores original top during shift operation. (Inherited from TfrxStretcheable.)
FSaveHeight | Internal use only. Stores object Height during stretch operation. (Inherited from TfrxStretcheable.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSelectedGridCol | Represents field FSelectedGridCol.
FSelectedGridRow | Represents field FSelectedGridRow.
FSelectedRowCol | Represents field FSelectedRowCol.
FSelectedRowColCount | Represents field FSelectedRowColCount.
FSelectionEnd | Represents field FSelectionEnd.
FSelectionFill | Represents field FSelectionFill.
FSelectionStart | Represents field FSelectionStart.
FSelectorPoint | Represents field FSelectorPoint.
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FTableActive | Represents field FTableActive.
FVC | Represents field FVC. (Inherited from TfrxView.)
FVertSplitter | Represents field FVertSplitter.
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxTableObject


TfrxTableObject Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTableObject class. (Overrides TfrxStretcheable.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Overrides TfrxComponent.DesignCreate(TComponent,Word).)
Destroy | Represents the destructor of the TfrxTableObject class. (Overrides TfrxView.Destroy.)
Top


TfrxTableObject.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxTableObject class.

Namespace: frxTableObject
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxStretcheable.Create(TComponent)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DesignCreate(TComponent,Word) Constructor

Summary

Constructor uses by the report designer when create new report object.

Namespace: frxTableObject
Syntax
Delphi
public
 constructor DesignCreate(AOwner: TComponent; Flags: Word); override;

Parameters

AOwner
Type: TComponent

Component owner.

Flags
Type: Word

Addition creation parameter depends on component class.

Overrides

TfrxComponent.DesignCreate(TComponent,Word)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.Destroy Destructor

Summary

Represents the destructor of the TfrxTableObject class.

Namespace: frxTableObject
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxView.Destroy
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject Properties

Properties
Name | Description
Cells[Integer,Integer] | Matrix of cell objects.
ColumnCount | Count of columns in the table object.
Columns[Integer] | List of table columns.
DefaultCellHeight | Default cell height used during creation of new row or column.
DefaultCellWidth | Default cell width used during creation of new row or column.
RowCount | Count of rows in the table object.
Rows[Integer] | List of table rows.
TableHeight | Height of the table object.
TableWidth | Width of the table object
Top


TfrxTableObject.Cells[Integer,Integer] Property

Summary

Matrix of cell objects.

Namespace: frxTableObject
Syntax
Delphi
public
 property Cells[X, Y: Integer]: TfrxTableCell read GetCell;

Parameters

X
Type: Integer

Column index.

Y
Type: Integer

Row index.

Property Value

Type: TfrxTableCell

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.ColumnCount Property

Summary

Count of columns in the table object.

Namespace: frxTableObject
Syntax
Delphi
published
 property ColumnCount: Integer read FColumnCount write SetColumnCount stored False;

Property Value

Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.Columns[Integer] Property

Summary

List of table columns.

Namespace: frxTableObject
Syntax
Delphi
public
 property Columns[Index: Integer]: TfrxTableColumn read GetColumn;

Parameters

Index
Type: Integer

Column index.

Property Value

Type: TfrxTableColumn

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DefaultCellHeight Property

Summary

Default cell height used during creation of new row or column.

Namespace: frxTableObject
Syntax
Delphi
public
 property DefaultCellHeight: Extended read FDefaultCellHeight write FDefaultCellHeight;

Property Value

Type: Extended

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DefaultCellWidth Property

Summary

Default cell width used during creation of new row or column.

Namespace: frxTableObject
Syntax
Delphi
public
 property DefaultCellWidth: Extended read FDefaultCellWidth write FDefaultCellWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.RowCount Property

Summary

Count of rows in the table object.

Namespace: frxTableObject
Syntax
Delphi
published
 property RowCount: Integer read FRowCount write SetRowCount stored False;

Property Value

Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.Rows[Integer] Property

Summary

List of table rows.

Namespace: frxTableObject
Syntax
Delphi
public
 property Rows[Index: Integer]: TfrxTableRow read GetRow;

Parameters

Index
Type: Integer

Row index.

Property Value

Type: TfrxTableRow

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.TableHeight Property

Summary

Height of the table object.

Namespace: frxTableObject
Syntax
Delphi
public
 property TableHeight: Extended read GetTableHeight write SetTableHeight;

Property Value

Type: Extended

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.TableWidth Property

Summary

Width of the table object

Namespace: frxTableObject
Syntax
Delphi
public
 property TableWidth: Extended read GetTableWidth write SetTableWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject Methods

Methods
Name | Description
AddColumn(TfrxTableColumn) | Adds column by it reference to the end of the table.
AddRow(TfrxTableRow) | Adds row by it reference to the end of the table.
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxView.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Overrides TfrxComponent.AlignChildren(Boolean,TfrxMirrorControlModes).)
AssignCellAppearance(TfrxTableCell,TfrxTableCell) | Represents method AssignCellAppearance(TfrxTableCell,TfrxTableCell).
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxView.BeforePrint.)
CalcHeight | Calculates and returns the object's height according to the data placed in it. (Overrides TfrxStretcheable.CalcHeight.)
CalcHeightInternal | Represents method CalcHeightInternal.
CalcWidthInternal | Represents method CalcWidthInternal.
CheckColumnSelector(Extended,Extended) | Represents method CheckColumnSelector(Extended,Extended).
CheckMoveArrow(Extended,Extended) | Represents method CheckMoveArrow(Extended,Extended).
CheckRowSelector(Extended,Extended) | Represents method CheckRowSelector(Extended,Extended).
CheckSizeArrow(Extended,Extended) | Represents method CheckSizeArrow(Extended,Extended).
CorrectSpansOnColumnChange(Integer,Integer) | Represents method CorrectSpansOnColumnChange(Integer,Integer).
CorrectSpansOnRowChange(Integer,Integer) | Represents method CorrectSpansOnRowChange(Integer,Integer).
CreateNewColumn(Integer) | Helper method used to create new column and insert it by given index into current table object.
CreateNewRow(Integer) | Helper method used to create new row and insert it by given index into current table object.
CreateTableColumn | Represents method CreateTableColumn.
CreateTableRow | Represents method CreateTableRow.
DeleteColumn(Integer) | Deletes column from the table.
DeleteRow(Integer) | Deletes row from the table.
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Overrides TfrxComponent.DoMirror(TfrxMirrorControlModes).)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawPart | Objects part drawing function , if the object is splittable. (Overrides TfrxStretcheable.DrawPart.)
DrawTable(Boolean) | Represents method DrawTable(Boolean).
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Overrides TfrxComponent.ExportInternal(TfrxCustomExportFilter).)
FillSpanList(TfrxRectArray) | Represents method FillSpanList(TfrxRectArray).
GetCell(Integer,Integer) | Represents method GetCell(Integer,Integer).
GetColumn(Integer) | Represents method GetColumn(Integer).
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Overrides TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent).)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Overrides TfrxComponent.GetDescription.)
GetRow(Integer) | Represents method GetRow(Integer).
GetRowColumnByClass(TClass,Integer) | Represents method GetRowColumnByClass(TClass,Integer).
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Overrides TfrxReportComponent.GetSaveToComponent.)
GetTableHeight | Represents method GetTableHeight.
GetTableWidth | Represents method GetTableWidth.
HasNextDataPart(Extended) | Returns True if object has a part to draw on a new page. (Overrides TfrxStretcheable.HasNextDataPart(Extended).)
InitPart | Initialize part of Splittable object. (Overrides TfrxStretcheable.InitPart.)
InsertColumn(Integer,TfrxTableColumn) | Inserts column by it reference to given position.
InsertRow(Integer,TfrxTableRow) | Inserts row by it reference to given position.
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxView.IsAcceptAsChild(TfrxComponent).)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Overrides TfrxComponent.IsHeightStored.)
IsInsideSpan(TfrxRectArray,TPoint) | Represents method IsInsideSpan(TfrxRectArray,TPoint).
IsTableActive | Represents method IsTableActive.
IsWidthStored | Represents method IsWidthStored. (Overrides TfrxComponent.IsWidthStored.)
JoinSelection(Integer,Integer,Integer,Integer) | Joins selected cells to one big by setting ColSpan and RowSpan properties.
Loaded | Represents method Loaded.
MoveColumn(Integer,Integer) | Moves culumn of the table from one position to another.
NormalizeObjectsList | Represents method NormalizeObjectsList.
NormalizeSpans | Represents method NormalizeSpans.
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Overrides TfrxComponent.ObjectListNotify(Pointer,TListNotification).)
ResetSpanList | Represents method ResetSpanList.
SetColumnCount(Integer) | Represents method SetColumnCount(Integer).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetRowCount(Integer) | Represents method SetRowCount(Integer).
SetTableHeight(Extended) | Represents method SetTableHeight(Extended).
SetTableWidth(Extended) | Represents method SetTableWidth(Extended).
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
SplitCell(TfrxTableCell) | Splits cell by reset ColSpan and RowSpan properties.
SplitSelected | Splits selected cells by reset ColSpan and RowSpan properties.
SwapRows(Integer,Integer) | Swaps positions of two rows in the table.
UpdateBounds | Used to validate object real bounds. (Overrides TfrxComponent.UpdateBounds.)
UpdateCellDimensions(TfrxTableCell) | Represents method UpdateCellDimensions(TfrxTableCell).
UpdateDesigner | Represents method UpdateDesigner.
Top


TfrxTableObject.AddColumn(TfrxTableColumn) Method

Summary

Adds column by it reference to the end of the table.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure AddColumn(Value: TfrxTableColumn);

Parameters

Value
Type: TfrxTableColumn

Reference to a column object.

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.AddRow(TfrxTableRow) Method

Summary

Adds row by it reference to the end of the table.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure AddRow(Value: TfrxTableRow);

Parameters

Value
Type: TfrxTableRow

Reference to a row object.

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.AfterPrint Method

Summary

The report engine calls this method after object was prepared and placed to preview pages.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure AfterPrint; override;

Overrides

TfrxView.AfterPrint
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.AlignChildren(Boolean,TfrxMirrorControlModes) Method

Summary

Align all child objects relative to the container based on mirror control modes and child objects Align's.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure AlignChildren(IgnoreInvisible: Boolean = False; MirrorModes: TfrxMirrorControlModes = []); override;

Parameters

IgnoreInvisible
Type: Boolean

Ignore objects which's Visible property set to false.

MirrorModes
Type: TfrxMirrorControlModes

Mirror modes of top container.

Overrides

TfrxComponent.AlignChildren(Boolean,TfrxMirrorControlModes)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.AssignCellAppearance(TfrxTableCell,TfrxTableCell) Method

Summary

Represents method AssignCellAppearance(TfrxTableCell,TfrxTableCell).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure AssignCellAppearance(FromCell, ToCell: TfrxTableCell);

Parameters

FromCell
Type: TfrxTableCell

ToCell
Type: TfrxTableCell

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.BeforePrint Method

Summary

The report engine calls this method before prepare object and place it to preview pages.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure BeforePrint; override;

Overrides

TfrxView.BeforePrint
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CalcHeight Method

Summary

Calculates and returns the object's height according to the data placed in it.

Namespace: frxTableObject
Syntax
Delphi
public
 function CalcHeight: Extended; override;

Return Value

Type: Extended

Overrides

TfrxStretcheable.CalcHeight
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CalcHeightInternal Method

Summary

Represents method CalcHeightInternal.

Namespace: frxTableObject
Syntax
Delphi
private
 procedure CalcHeightInternal;
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CalcWidthInternal Method

Summary

Represents method CalcWidthInternal.

Namespace: frxTableObject
Syntax
Delphi
private
 procedure CalcWidthInternal;
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CheckColumnSelector(Extended,Extended) Method

Summary

Represents method CheckColumnSelector(Extended,Extended).

Namespace: frxTableObject
Syntax
Delphi
protected
 function CheckColumnSelector(X, Y: Extended): Boolean;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CheckMoveArrow(Extended,Extended) Method

Summary

Represents method CheckMoveArrow(Extended,Extended).

Namespace: frxTableObject
Syntax
Delphi
protected
 function CheckMoveArrow(X, Y: Extended): Boolean;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CheckRowSelector(Extended,Extended) Method

Summary

Represents method CheckRowSelector(Extended,Extended).

Namespace: frxTableObject
Syntax
Delphi
protected
 function CheckRowSelector(X, Y: Extended): Boolean;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CheckSizeArrow(Extended,Extended) Method

Summary

Represents method CheckSizeArrow(Extended,Extended).

Namespace: frxTableObject
Syntax
Delphi
protected
 function CheckSizeArrow(X, Y: Extended): Boolean;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CorrectSpansOnColumnChange(Integer,Integer) Method

Summary

Represents method CorrectSpansOnColumnChange(Integer,Integer).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure CorrectSpansOnColumnChange(ColumnIndex, Correct: Integer);

Parameters

ColumnIndex
Type: Integer

Correct
Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CorrectSpansOnRowChange(Integer,Integer) Method

Summary

Represents method CorrectSpansOnRowChange(Integer,Integer).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure CorrectSpansOnRowChange(RowIndex, Correct: Integer);

Parameters

RowIndex
Type: Integer

Correct
Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CreateNewColumn(Integer) Method

Summary

Helper method used to create new column and insert it by given index into current table object.

Namespace: frxTableObject
Syntax
Delphi
public
 function CreateNewColumn(Index: Integer): TfrxTableColumn;

Parameters

Index
Type: Integer

Column index.

Return Value

Type: TfrxTableColumn

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CreateNewRow(Integer) Method

Summary

Helper method used to create new row and insert it by given index into current table object.

Namespace: frxTableObject
Syntax
Delphi
public
 function CreateNewRow(Index: Integer): TfrxTableRow;

Parameters

Index
Type: Integer

Row index.

Return Value

Type: TfrxTableRow

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CreateTableColumn Method

Summary

Represents method CreateTableColumn.

Namespace: frxTableObject
Syntax
Delphi
protected
 function CreateTableColumn: TfrxTableColumn; virtual;

Return Value

Type: TfrxTableColumn

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.CreateTableRow Method

Summary

Represents method CreateTableRow.

Namespace: frxTableObject
Syntax
Delphi
protected
 function CreateTableRow: TfrxTableRow; virtual;

Return Value

Type: TfrxTableRow

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DeleteColumn(Integer) Method

Summary

Deletes column from the table.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DeleteColumn(Index: Integer);

Parameters

Index
Type: Integer

Column index.

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DeleteRow(Integer) Method

Summary

Deletes row from the table.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DeleteRow(Index: Integer);

Parameters

Index
Type: Integer

Row index to delete.

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DoMirror(TfrxMirrorControlModes) Method

Summary

Represents method DoMirror(TfrxMirrorControlModes).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure DoMirror(MirrorModes: TfrxMirrorControlModes); override;

Parameters

MirrorModes
Type: TfrxMirrorControlModes

Overrides

TfrxComponent.DoMirror(TfrxMirrorControlModes)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams)
 : Boolean; override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DoMouseEnter(aPreviousObject: TfrxComponent;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

aPreviousObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DoMouseLeave(aPreviousObject: TfrxComponent;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

aPreviousObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DoMouseMove(X, Y: Integer; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DoMouseUp(X, Y: Integer; Button: TMouseButton; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DrawPart Method

Summary

Objects part drawing function , if the object is splittable.

Namespace: frxTableObject
Syntax
Delphi
public
 function DrawPart: Extended; override;

Return Value

Type: Extended

Overrides

TfrxStretcheable.DrawPart
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.DrawTable(Boolean) Method

Summary

Represents method DrawTable(Boolean).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure DrawTable(Highlighted: Boolean = False);

Parameters

Highlighted
Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.ExportInternal(TfrxCustomExportFilter) Method

Summary

Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call.

Namespace: frxTableObject
Syntax
Delphi
public
 function ExportInternal(Filter: TfrxCustomExportFilter): Boolean; override;

Parameters

Filter
Type: TfrxCustomExportFilter

Return Value

Type: Boolean

Overrides

TfrxComponent.ExportInternal(TfrxCustomExportFilter)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FillSpanList(TfrxRectArray) Method

Summary

Represents method FillSpanList(TfrxRectArray).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure FillSpanList(var SpanList: TfrxRectArray);

Parameters

SpanList
Type: TfrxRectArray

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.GetCell(Integer,Integer) Method

Summary

Represents method GetCell(Integer,Integer).

Namespace: frxTableObject
Syntax
Delphi
private
 function GetCell(X, Y: Integer): TfrxTableCell;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TfrxTableCell

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.GetColumn(Integer) Method

Summary

Represents method GetColumn(Integer).

Namespace: frxTableObject
Syntax
Delphi
private
 function GetColumn(Index: Integer): TfrxTableColumn;

Parameters

Index
Type: Integer

Return Value

Type: TfrxTableColumn

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.GetContainedComponent(Extended,Extended,TfrxComponent) Method

Summary

Returns top-most object which contain point at passed coordinates

Namespace: frxTableObject
Syntax
Delphi
public
 function GetContainedComponent(X, Y: Extended; IsCanContain: TfrxComponent = nil): TfrxComponent; override;

Parameters

X
Type: Extended

X coordinate.

Y
Type: Extended

Y coordinate.

IsCanContain
Type: TfrxComponent

Child Component. If IsCanContain = nil - returns top-most object, otherwise IsCanContain <> nil - return top-most object which can accept IsCanContain component as child.

Return Value

Type: TfrxComponent

Found component or nil.

Overrides

TfrxComponent.GetContainedComponent(Extended,Extended,TfrxComponent)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.GetDescription Method

Summary

Get description of the report component. By default returns class name.

Namespace: frxTableObject
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

Overrides

TfrxComponent.GetDescription
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.GetRow(Integer) Method

Summary

Represents method GetRow(Integer).

Namespace: frxTableObject
Syntax
Delphi
private
 function GetRow(Index: Integer): TfrxTableRow;

Parameters

Index
Type: Integer

Return Value

Type: TfrxTableRow

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.GetRowColumnByClass(TClass,Integer) Method

Summary

Represents method GetRowColumnByClass(TClass,Integer).

Namespace: frxTableObject
Syntax
Delphi
protected
 function GetRowColumnByClass(aClass: TClass; Index: Integer): TfrxTableRowColumnBase;

Parameters

aClass
Type: TClass

Index
Type: Integer

Return Value

Type: TfrxTableRowColumnBase

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.GetSaveToComponent Method

Summary

Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages.

Namespace: frxTableObject
Syntax
Delphi
public
 function GetSaveToComponent: TfrxReportComponent; override;

Return Value

Type: TfrxReportComponent

Overrides

TfrxReportComponent.GetSaveToComponent
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.GetTableHeight Method

Summary

Represents method GetTableHeight.

Namespace: frxTableObject
Syntax
Delphi
private
 function GetTableHeight: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.GetTableWidth Method

Summary

Represents method GetTableWidth.

Namespace: frxTableObject
Syntax
Delphi
private
 function GetTableWidth: Extended;

Return Value

Type: Extended

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.HasNextDataPart(Extended) Method

Summary

Returns True if object has a part to draw on a new page.

Namespace: frxTableObject
Syntax
Delphi
public
 function HasNextDataPart(aFreeSpace: Extended): Boolean; override;

Parameters

aFreeSpace
Type: Extended

Free space on current page.

Return Value

Type: Boolean

Overrides

TfrxStretcheable.HasNextDataPart(Extended)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.InitPart Method

Summary

Initialize part of Splittable object.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure InitPart; override;

Overrides

TfrxStretcheable.InitPart
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.InsertColumn(Integer,TfrxTableColumn) Method

Summary

Inserts column by it reference to given position.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure InsertColumn(Index: Integer; Value: TfrxTableColumn);

Parameters

Index
Type: Integer

Column index.

Value
Type: TfrxTableColumn

Reference to a column object.

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.InsertRow(Integer,TfrxTableRow) Method

Summary

Inserts row by it reference to given position.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure InsertRow(Index: Integer; Value: TfrxTableRow);

Parameters

Index
Type: Integer

Index of the row.

Value
Type: TfrxTableRow

Reference to a row object.

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.IsAcceptAsChild(TfrxComponent) Method

Summary

Returns true when component in aParent can be accepted as parent for current.

Namespace: frxTableObject
Syntax
Delphi
public
 function IsAcceptAsChild(aParent: TfrxComponent): Boolean; override;

Parameters

aParent
Type: TfrxComponent

Component that supposedly should become a parent for current.

Return Value

Type: Boolean

Overrides

TfrxView.IsAcceptAsChild(TfrxComponent)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.IsContain(Extended,Extended) Method

Summary

Detects if point is inside an object coordinates.

Namespace: frxTableObject
Syntax
Delphi
public
 function IsContain(X, Y: Extended): Boolean; override;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

Overrides

TfrxComponent.IsContain(Extended,Extended)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.IsHeightStored Method

Summary

Represents method IsHeightStored.

Namespace: frxTableObject
Syntax
Delphi
protected
 function IsHeightStored: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxComponent.IsHeightStored
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.IsInsideSpan(TfrxRectArray,TPoint) Method

Summary

Represents method IsInsideSpan(TfrxRectArray,TPoint).

Namespace: frxTableObject
Syntax
Delphi
protected
 function IsInsideSpan(SpanList: TfrxRectArray; p: TPoint): Boolean;

Parameters

SpanList
Type: TfrxRectArray

p
Type: TPoint

Return Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.IsTableActive Method

Summary

Represents method IsTableActive.

Namespace: frxTableObject
Syntax
Delphi
protected
 function IsTableActive: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.IsWidthStored Method

Summary

Represents method IsWidthStored.

Namespace: frxTableObject
Syntax
Delphi
protected
 function IsWidthStored: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxComponent.IsWidthStored
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.JoinSelection(Integer,Integer,Integer,Integer) Method

Summary

Joins selected cells to one big by setting ColSpan and RowSpan properties.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure JoinSelection(TopX: Integer = MaxInt; TopY: Integer = MaxInt; BottomX: Integer = -1; BottomY: Integer = -1);

Parameters

TopX
Type: Integer

Top column position of selection.

TopY
Type: Integer

Top row position of selection.

BottomX
Type: Integer

Bottom column position of selection.

BottomY
Type: Integer

Bottom row position of selection.

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.Loaded Method

Summary

Represents method Loaded.

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.MoveColumn(Integer,Integer) Method

Summary

Moves culumn of the table from one position to another.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure MoveColumn(Index, NewIndex: Integer);

Parameters

Index
Type: Integer

Index of column to move.

NewIndex
Type: Integer

New position of the column.

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.NormalizeObjectsList Method

Summary

Represents method NormalizeObjectsList.

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure NormalizeObjectsList;
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.NormalizeSpans Method

Summary

Represents method NormalizeSpans.

Namespace: frxTableObject
Syntax
Delphi
private
 procedure NormalizeSpans;
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.ObjectListNotify(Pointer,TListNotification) Method

Summary

Represents method ObjectListNotify(Pointer,TListNotification).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure ObjectListNotify(Ptr: Pointer; Action: TListNotification); override;

Parameters

Ptr
Type: Pointer

Action
Type: TListNotification

Overrides

TfrxComponent.ObjectListNotify(Pointer,TListNotification)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.ResetSpanList Method

Summary

Represents method ResetSpanList.

Namespace: frxTableObject
Syntax
Delphi
private
 procedure ResetSpanList;
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.SetColumnCount(Integer) Method

Summary

Represents method SetColumnCount(Integer).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure SetColumnCount(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.SetHeight(Extended) Method

Summary

Represents method SetHeight(Extended).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure SetHeight(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetHeight(Extended)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.SetRowCount(Integer) Method

Summary

Represents method SetRowCount(Integer).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure SetRowCount(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.SetTableHeight(Extended) Method

Summary

Represents method SetTableHeight(Extended).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure SetTableHeight(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.SetTableWidth(Extended) Method

Summary

Represents method SetTableWidth(Extended).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure SetTableWidth(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.SetWidth(Extended) Method

Summary

Represents method SetWidth(Extended).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure SetWidth(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetWidth(Extended)
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.SplitCell(TfrxTableCell) Method

Summary

Splits cell by reset ColSpan and RowSpan properties.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure SplitCell(aCell: TfrxTableCell);

Parameters

aCell
Type: TfrxTableCell

Reference to a cell object to split.

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.SplitSelected Method

Summary

Splits selected cells by reset ColSpan and RowSpan properties.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure SplitSelected;
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.SwapRows(Integer,Integer) Method

Summary

Swaps positions of two rows in the table.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure SwapRows(Row1, Row2: Integer);

Parameters

Row1
Type: Integer

Index of first row.

Row2
Type: Integer

index of second row.

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.UpdateBounds Method

Summary

Used to validate object real bounds.

Namespace: frxTableObject
Syntax
Delphi
public
 procedure UpdateBounds; override;

Overrides

TfrxComponent.UpdateBounds
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.UpdateCellDimensions(TfrxTableCell) Method

Summary

Represents method UpdateCellDimensions(TfrxTableCell).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure UpdateCellDimensions(cell: TfrxTableCell);

Parameters

cell
Type: TfrxTableCell

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.UpdateDesigner Method

Summary

Represents method UpdateDesigner.

Namespace: frxTableObject
Syntax
Delphi
private
 procedure UpdateDesigner;
See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject Fields

Fields
Name | Description
FBoundsUpdating | Represents field FBoundsUpdating.
FBrakeTo | Represents field FBrakeTo.
FBreakRowIndex | Represents field FBreakRowIndex.
FCellsSelection | Represents field FCellsSelection.
FColumnCount | Represents field FColumnCount.
FColumnSelection | Represents field FColumnSelection.
FCopyAppearance | Represents field FCopyAppearance.
FDefaultCellHeight | Represents field FDefaultCellHeight.
FDefaultCellWidth | Represents field FDefaultCellWidth.
FDragDropActive | Represents field FDragDropActive.
FHorzSplitter | Represents field FHorzSplitter.
FLastMousePos | Represents field FLastMousePos.
FLockCorrectSpans | Represents field FLockCorrectSpans.
FLockObjectsUpdate | Represents field FLockObjectsUpdate.
FModified | Represents field FModified.
FNewColumnDim | Represents field FNewColumnDim.
FNewRowDim | Represents field FNewRowDim.
FResizeActive | Represents field FResizeActive.
FRowCount | Represents field FRowCount.
FRowSelection | Represents field FRowSelection.
FSelectedGridCol | Represents field FSelectedGridCol.
FSelectedGridRow | Represents field FSelectedGridRow.
FSelectedRowCol | Represents field FSelectedRowCol.
FSelectedRowColCount | Represents field FSelectedRowColCount.
FSelectionEnd | Represents field FSelectionEnd.
FSelectionFill | Represents field FSelectionFill.
FSelectionStart | Represents field FSelectionStart.
FSelectorPoint | Represents field FSelectorPoint.
FTableActive | Represents field FTableActive.
FVertSplitter | Represents field FVertSplitter.
Top


TfrxTableObject.FBoundsUpdating Field

Summary

Represents field FBoundsUpdating.

Namespace: frxTableObject
Syntax
Delphi
private
 FBoundsUpdating: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FBrakeTo Field

Summary

Represents field FBrakeTo.

Namespace: frxTableObject
Syntax
Delphi
private
 FBrakeTo: TfrxTableObject;

Field Value

Type: TfrxTableObject

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FBreakRowIndex Field

Summary

Represents field FBreakRowIndex.

Namespace: frxTableObject
Syntax
Delphi
private
 FBreakRowIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FCellsSelection Field

Summary

Represents field FCellsSelection.

Namespace: frxTableObject
Syntax
Delphi
private
 FCellsSelection: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FColumnCount Field

Summary

Represents field FColumnCount.

Namespace: frxTableObject
Syntax
Delphi
private
 FColumnCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FColumnSelection Field

Summary

Represents field FColumnSelection.

Namespace: frxTableObject
Syntax
Delphi
private
 FColumnSelection: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FCopyAppearance Field

Summary

Represents field FCopyAppearance.

Namespace: frxTableObject
Syntax
Delphi
private
 FCopyAppearance: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FDefaultCellHeight Field

Summary

Represents field FDefaultCellHeight.

Namespace: frxTableObject
Syntax
Delphi
private
 FDefaultCellHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FDefaultCellWidth Field

Summary

Represents field FDefaultCellWidth.

Namespace: frxTableObject
Syntax
Delphi
private
 FDefaultCellWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FDragDropActive Field

Summary

Represents field FDragDropActive.

Namespace: frxTableObject
Syntax
Delphi
private
 FDragDropActive: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FHorzSplitter Field

Summary

Represents field FHorzSplitter.

Namespace: frxTableObject
Syntax
Delphi
private
 FHorzSplitter: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FLastMousePos Field

Summary

Represents field FLastMousePos.

Namespace: frxTableObject
Syntax
Delphi
private
 FLastMousePos: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FLockCorrectSpans Field

Summary

Represents field FLockCorrectSpans.

Namespace: frxTableObject
Syntax
Delphi
private
 FLockCorrectSpans: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FLockObjectsUpdate Field

Summary

Represents field FLockObjectsUpdate.

Namespace: frxTableObject
Syntax
Delphi
private
 FLockObjectsUpdate: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FModified Field

Summary

Represents field FModified.

Namespace: frxTableObject
Syntax
Delphi
private
 FModified: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FNewColumnDim Field

Summary

Represents field FNewColumnDim.

Namespace: frxTableObject
Syntax
Delphi
private
 FNewColumnDim: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FNewRowDim Field

Summary

Represents field FNewRowDim.

Namespace: frxTableObject
Syntax
Delphi
private
 FNewRowDim: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FResizeActive Field

Summary

Represents field FResizeActive.

Namespace: frxTableObject
Syntax
Delphi
private
 FResizeActive: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FRowCount Field

Summary

Represents field FRowCount.

Namespace: frxTableObject
Syntax
Delphi
private
 FRowCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FRowSelection Field

Summary

Represents field FRowSelection.

Namespace: frxTableObject
Syntax
Delphi
private
 FRowSelection: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FSelectedGridCol Field

Summary

Represents field FSelectedGridCol.

Namespace: frxTableObject
Syntax
Delphi
private
 FSelectedGridCol: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FSelectedGridRow Field

Summary

Represents field FSelectedGridRow.

Namespace: frxTableObject
Syntax
Delphi
private
 FSelectedGridRow: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FSelectedRowCol Field

Summary

Represents field FSelectedRowCol.

Namespace: frxTableObject
Syntax
Delphi
protected
 FSelectedRowCol: TfrxTableRowColumnBase;

Field Value

Type: TfrxTableRowColumnBase

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FSelectedRowColCount Field

Summary

Represents field FSelectedRowColCount.

Namespace: frxTableObject
Syntax
Delphi
protected
 FSelectedRowColCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FSelectionEnd Field

Summary

Represents field FSelectionEnd.

Namespace: frxTableObject
Syntax
Delphi
private
 FSelectionEnd: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FSelectionFill Field

Summary

Represents field FSelectionFill.

Namespace: frxTableObject
Syntax
Delphi
private
 FSelectionFill: TfrxCustomFill;

Field Value

Type: TfrxCustomFill

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FSelectionStart Field

Summary

Represents field FSelectionStart.

Namespace: frxTableObject
Syntax
Delphi
private
 FSelectionStart: TRect;

Field Value

Type: TRect

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FSelectorPoint Field

Summary

Represents field FSelectorPoint.

Namespace: frxTableObject
Syntax
Delphi
private
 FSelectorPoint: TPoint;

Field Value

Type: TPoint

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FTableActive Field

Summary

Represents field FTableActive.

Namespace: frxTableObject
Syntax
Delphi
private
 FTableActive: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableObject.FVertSplitter Field

Summary

Represents field FVertSplitter.

Namespace: frxTableObject
Syntax
Delphi
private
 FVertSplitter: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableObject
  • frxTableObject


TfrxTableRow Class

Summary

Represents Table Row.

Namespace: frxTableObject
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxTableObject.TfrxTableRowColumnBase
frxTableObject.TfrxTableRow
Syntax
Delphi
type
 TfrxTableRow = class(TfrxTableRowColumnBase)
 end;

The TfrxTableRow type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTableRow class. (Overrides TfrxComponent.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxTableRow class. (Overrides TfrxTableRowColumnBase.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
AutoSize | When this property is set, Table object automatically calculates width of column or height of row based on content inside cells. (Inherited from TfrxTableRowColumnBase.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
CellCount | Returns count of cell in current row.
Cells[Integer] | List of the cell in current row.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Object's description. (Inherited from TfrxComponent.)
Font | Object's font. (Inherited from TfrxComponent.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Represents property Height.
Index | Index of current row or column. (Inherited from TfrxTableRowColumnBase.)
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
MaxHeight | Maximum height of current row. Row height can not be greater than this value when AutoSize is turned on.
MinHeight | Minimal height of current row. Row height can not be less than this value when AutoSize is turned on.
Objects | The list of child objects. (Inherited from TfrxComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Global visibility of the object in the result report. (Inherited from TfrxComponent.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CorrectCellsOnColumnChange(Integer,Integer) | Represents method CorrectCellsOnColumnChange(Integer,Integer).
CreateTableCell(Integer) | Represents method CreateTableCell(Integer).
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxTableRowColumnBase.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetCell(Integer) | Represents method GetCell(Integer).
GetCellCount | Represents method GetCellCount.
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InitCells(Integer) | Represents method InitCells(Integer).
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Overrides TfrxComponent.IsLeftStored.)
IsTopStored | Represents method IsTopStored. (Overrides TfrxComponent.IsTopStored.)
IsWidthStored | Represents method IsWidthStored. (Overrides TfrxComponent.IsWidthStored.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ParentTable | Returns reference to a parent "Table" object. (Inherited from TfrxTableRowColumnBase.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Overrides TfrxComponent.SetIsSelected(Boolean).)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FIndex | Represents field FIndex. (Inherited from TfrxTableRowColumnBase.)
FMaxHeight | Represents field FMaxHeight.
FMinHeight | Represents field FMinHeight.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
Top
See Also

Reference

  • frxTableObject


TfrxTableRow Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxTableRow class. (Overrides TfrxComponent.Create(TComponent).)
Destroy | Represents the destructor of the TfrxTableRow class. (Overrides TfrxTableRowColumnBase.Destroy.)
Top


TfrxTableRow.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxTableRow class.

Namespace: frxTableObject
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxComponent.Create(TComponent)
See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.Destroy Destructor

Summary

Represents the destructor of the TfrxTableRow class.

Namespace: frxTableObject
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxTableRowColumnBase.Destroy
See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow Properties

Properties
Name | Description
CellCount | Returns count of cell in current row.
Cells[Integer] | List of the cell in current row.
Height | Represents property Height.
MaxHeight | Maximum height of current row. Row height can not be greater than this value when AutoSize is turned on.
MinHeight | Minimal height of current row. Row height can not be less than this value when AutoSize is turned on.
Top


TfrxTableRow.CellCount Property

Summary

Returns count of cell in current row.

Namespace: frxTableObject
Syntax
Delphi
public
 property CellCount: Integer read GetCellCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.Cells[Integer] Property

Summary

List of the cell in current row.

Namespace: frxTableObject
Syntax
Delphi
public
 property Cells[Index: Integer]: TfrxTableCell read GetCell;

Parameters

Index
Type: Integer

Column index.

Property Value

Type: TfrxTableCell

See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.Height Property

Summary

Represents property Height.

Namespace: frxTableObject
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.MaxHeight Property

Summary

Maximum height of current row. Row height can not be greater than this value when AutoSize is turned on.

Namespace: frxTableObject
Syntax
Delphi
published
 property MaxHeight: Extended read FMaxHeight write FMaxHeight;

Property Value

Type: Extended

See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.MinHeight Property

Summary

Minimal height of current row. Row height can not be less than this value when AutoSize is turned on.

Namespace: frxTableObject
Syntax
Delphi
published
 property MinHeight: Extended read FMinHeight write FMinHeight;

Property Value

Type: Extended

See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow Methods

Methods
Name | Description
CorrectCellsOnColumnChange(Integer,Integer) | Represents method CorrectCellsOnColumnChange(Integer,Integer).
CreateTableCell(Integer) | Represents method CreateTableCell(Integer).
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxTableRowColumnBase.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
GetCell(Integer) | Represents method GetCell(Integer).
GetCellCount | Represents method GetCellCount.
InitCells(Integer) | Represents method InitCells(Integer).
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Overrides TfrxComponent.IsContain(Extended,Extended).)
IsWidthStored | Represents method IsWidthStored. (Overrides TfrxComponent.IsWidthStored.)
SetLeft(Extended) | Represents method SetLeft(Extended). (Overrides TfrxComponent.SetLeft(Extended).)
Top


TfrxTableRow.CorrectCellsOnColumnChange(Integer,Integer) Method

Summary

Represents method CorrectCellsOnColumnChange(Integer,Integer).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure CorrectCellsOnColumnChange(Index, Correct: Integer);

Parameters

Index
Type: Integer

Correct
Type: Integer

See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.CreateTableCell(Integer) Method

Summary

Represents method CreateTableCell(Integer).

Namespace: frxTableObject
Syntax
Delphi
protected
 function CreateTableCell(Index: Integer): TfrxTableCell; virtual;

Parameters

Index
Type: Integer

Return Value

Type: TfrxTableCell

See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DoMouseUp(X, Y: Integer; Button: TMouseButton; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxTableRowColumnBase.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.GetCell(Integer) Method

Summary

Represents method GetCell(Integer).

Namespace: frxTableObject
Syntax
Delphi
private
 function GetCell(Index: Integer): TfrxTableCell;

Parameters

Index
Type: Integer

Return Value

Type: TfrxTableCell

See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.GetCellCount Method

Summary

Represents method GetCellCount.

Namespace: frxTableObject
Syntax
Delphi
private
 function GetCellCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.InitCells(Integer) Method

Summary

Represents method InitCells(Integer).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure InitCells(Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.IsContain(Extended,Extended) Method

Summary

Detects if point is inside an object coordinates.

Namespace: frxTableObject
Syntax
Delphi
public
 function IsContain(X, Y: Extended): Boolean; override;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

Overrides

TfrxComponent.IsContain(Extended,Extended)
See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.IsWidthStored Method

Summary

Represents method IsWidthStored.

Namespace: frxTableObject
Syntax
Delphi
protected
 function IsWidthStored: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxComponent.IsWidthStored
See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.SetLeft(Extended) Method

Summary

Represents method SetLeft(Extended).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure SetLeft(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetLeft(Extended)
See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow Fields

Fields
Name | Description
FMaxHeight | Represents field FMaxHeight.
FMinHeight | Represents field FMinHeight.
Top


TfrxTableRow.FMaxHeight Field

Summary

Represents field FMaxHeight.

Namespace: frxTableObject
Syntax
Delphi
private
 FMaxHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRow.FMinHeight Field

Summary

Represents field FMinHeight.

Namespace: frxTableObject
Syntax
Delphi
private
 FMinHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxTableRow
  • frxTableObject


TfrxTableRowColumnBase Class

Summary

The base class for Table rows and columns.

Namespace: frxTableObject
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxTableObject.TfrxTableRowColumnBase
frxTableObject.TfrxTableColumn
frxTableObject.TfrxTableRow
Syntax
Delphi
type
 TfrxTableRowColumnBase = class(TfrxComponent)
 end;

The TfrxTableRowColumnBase type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxComponent class. (Inherited from TfrxComponent.)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Destroy | Represents the destructor of the TfrxTableRowColumnBase class. (Overrides TfrxComponent.Destroy.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Used with TfrxMirrorControlModes when mcmOnlyAllowed set on parent container. It marks report object follows TfrxMirrorControlModes rules. (Inherited from TfrxComponent.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Anchors relative to parent container (Default left, top). (Inherited from TfrxComponent.)
AutoSize | When this property is set, Table object automatically calculates width of column or height of row based on content inside cells.
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Description | Object's description. (Inherited from TfrxComponent.)
Font | Object's font. (Inherited from TfrxComponent.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxComponent.)
Height | Object's height, in pixels. (Inherited from TfrxComponent.)
Index | Index of current row or column.
IndexTag | Not used. (Inherited from TfrxComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Left | Object's X coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
Objects | The list of child objects. (Inherited from TfrxComponent.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Set of flags, which restrict some object operations. (Inherited from TfrxComponent.)
Top | Object's Y coordinate (relatively to a parent, in pixels). (Inherited from TfrxComponent.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
Visible | Global visibility of the object in the result report. (Inherited from TfrxComponent.)
Width | Object's width, in pixels. (Inherited from TfrxComponent.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Inherited from TfrxComponent.)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Inherited from TfrxComponent.)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Overrides TfrxComponent.IsLeftStored.)
IsTopStored | Represents method IsTopStored. (Overrides TfrxComponent.IsTopStored.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
ParentTable | Returns reference to a parent "Table" object.
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetAutoSize(Boolean) | Represents method SetAutoSize(Boolean).
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Overrides TfrxComponent.SetIsSelected(Boolean).)
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FAutoSize | Represents field FAutoSize.
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FIndex | Represents field FIndex.
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
Top
See Also

Reference

  • frxTableObject


TfrxTableRowColumnBase Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TfrxTableRowColumnBase class. (Overrides TfrxComponent.Destroy.)
Top


TfrxTableRowColumnBase.Destroy Destructor

Summary

Represents the destructor of the TfrxTableRowColumnBase class.

Namespace: frxTableObject
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxComponent.Destroy
See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase Properties

Properties
Name | Description
AutoSize | When this property is set, Table object automatically calculates width of column or height of row based on content inside cells.
Index | Index of current row or column.
Top


TfrxTableRowColumnBase.AutoSize Property

Summary

When this property is set, Table object automatically calculates width of column or height of row based on content inside cells.

Namespace: frxTableObject
Syntax
Delphi
published
 property AutoSize: Boolean read FAutoSize write SetAutoSize default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase.Index Property

Summary

Index of current row or column.

Namespace: frxTableObject
Syntax
Delphi
public
 property Index: Integer read FIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase Methods

Methods
Name | Description
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Overrides TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).)
IsLeftStored | Represents method IsLeftStored. (Overrides TfrxComponent.IsLeftStored.)
IsTopStored | Represents method IsTopStored. (Overrides TfrxComponent.IsTopStored.)
ParentTable | Returns reference to a parent "Table" object.
SetAutoSize(Boolean) | Represents method SetAutoSize(Boolean).
SetHeight(Extended) | Represents method SetHeight(Extended). (Overrides TfrxComponent.SetHeight(Extended).)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Overrides TfrxComponent.SetIsSelected(Boolean).)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Overrides TfrxComponent.SetParent(TfrxComponent).)
SetWidth(Extended) | Represents method SetWidth(Extended). (Overrides TfrxComponent.SetWidth(Extended).)
Top


TfrxTableRowColumnBase.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams)
 : Boolean; override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

Overrides

TfrxComponent.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DoMouseMove(X, Y: Integer; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxTableObject
Syntax
Delphi
public
 procedure DoMouseUp(X, Y: Integer; Button: TMouseButton; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Overrides

TfrxComponent.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams)
See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase.IsLeftStored Method

Summary

Represents method IsLeftStored.

Namespace: frxTableObject
Syntax
Delphi
protected
 function IsLeftStored: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxComponent.IsLeftStored
See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase.IsTopStored Method

Summary

Represents method IsTopStored.

Namespace: frxTableObject
Syntax
Delphi
protected
 function IsTopStored: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxComponent.IsTopStored
See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase.ParentTable Method

Summary

Returns reference to a parent "Table" object.

Namespace: frxTableObject
Syntax
Delphi
public
 function ParentTable: TfrxTableObject;

Return Value

Type: TfrxTableObject

See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase.SetAutoSize(Boolean) Method

Summary

Represents method SetAutoSize(Boolean).

Namespace: frxTableObject
Syntax
Delphi
private
 procedure SetAutoSize(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase.SetHeight(Extended) Method

Summary

Represents method SetHeight(Extended).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure SetHeight(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetHeight(Extended)
See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase.SetIsSelected(Boolean) Method

Summary

Represents method SetIsSelected(Boolean).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure SetIsSelected(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TfrxComponent.SetIsSelected(Boolean)
See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase.SetParent(TfrxComponent) Method

Summary

Represents method SetParent(TfrxComponent).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure SetParent(AParent: TfrxComponent); override;

Parameters

AParent
Type: TfrxComponent

Overrides

TfrxComponent.SetParent(TfrxComponent)
See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase.SetWidth(Extended) Method

Summary

Represents method SetWidth(Extended).

Namespace: frxTableObject
Syntax
Delphi
protected
 procedure SetWidth(Value: Extended); override;

Parameters

Value
Type: Extended

Overrides

TfrxComponent.SetWidth(Extended)
See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase Fields

Fields
Name | Description
FAutoSize | Represents field FAutoSize.
FIndex | Represents field FIndex.
Top


TfrxTableRowColumnBase.FAutoSize Field

Summary

Represents field FAutoSize.

Namespace: frxTableObject
Syntax
Delphi
private
 FAutoSize: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


TfrxTableRowColumnBase.FIndex Field

Summary

Represents field FIndex.

Namespace: frxTableObject
Syntax
Delphi
protected
 FIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxTableRowColumnBase
  • frxTableObject


frxTableObject Constants

Constants
Name | Description
DefaultColumnWidth | Default column width for new table.
DefaultRowHeight | Default row height for new table.
Top


DefaultColumnWidth Constant

Summary

Default column width for new table.

Namespace: frxTableObject
Syntax
Delphi
 DefaultColumnWidth: Extended = 37.7953 * 2;

Value

Type: Extended

See Also

Reference

  • frxTableObject


DefaultRowHeight Constant

Summary

Default row height for new table.

Namespace: frxTableObject
Syntax
Delphi
 DefaultRowHeight: Extended = 37.7953 * 0.5;

Value

Type: Extended

See Also

Reference

  • frxTableObject


frxThreading Namespace

Summary

Represents namespace frxThreading.

Classes
Name | Description
TfrxGuiThread | Represents type TfrxGuiThread.
TfrxThreadSynchronizer | Represents type TfrxThreadSynchronizer.
Top
Variables
Name | Description
frxDisableThreadSynchronizer | Represents variable frxDisableThreadSynchronizer.
Top
Constants
Name | Description
WM_FRX_SYNC_MESSAGE | Represents constant WM_FRX_SYNC_MESSAGE.
WM_FRX_SYNC_THREAD | Represents constant WM_FRX_SYNC_THREAD.
Top
Routines
Name | Description
frxSynchSendMessage(HWND,UINT,WPARAM,LPARAM) | Represents method frxSynchSendMessage(HWND,UINT,WPARAM,LPARAM).
frxThreadSynchronize(TThreadMethod) | Represents method frxThreadSynchronize(TThreadMethod).
GetThreadSynchronizer | Represents method GetThreadSynchronizer.
IsThreadSynchronizerActive | Represents method IsThreadSynchronizerActive.
Top


frxThreading Classes

Classes
Name | Description
TfrxGuiThread | Represents type TfrxGuiThread.
TfrxThreadSynchronizer | Represents type TfrxThreadSynchronizer.
Top


TfrxGuiThread Class

Summary

Represents type TfrxGuiThread.

Namespace: frxThreading
Inheritance Hierarchy
TThread
frxThreading.TfrxGuiThread
Syntax
Delphi
type
 TfrxGuiThread = class(TThread)
 end;

The TfrxGuiThread type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxGuiThread class.
Destroy | Represents the destructor of the TfrxGuiThread class.
Top
Methods
Show:
Name | Description
Execute | Represents method Execute.
Top
See Also

Reference

  • frxThreading


TfrxGuiThread Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxGuiThread class.
Destroy | Represents the destructor of the TfrxGuiThread class.
Top


TfrxGuiThread.Create Constructor

Summary

Initializes a new instance of the TfrxGuiThread class.

Namespace: frxThreading
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxGuiThread
  • frxThreading


TfrxGuiThread.Destroy Destructor

Summary

Represents the destructor of the TfrxGuiThread class.

Namespace: frxThreading
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxGuiThread
  • frxThreading


TfrxGuiThread Methods

Methods
Name | Description
Execute | Represents method Execute.
Top


TfrxGuiThread.Execute Method

Summary

Represents method Execute.

Namespace: frxThreading
Syntax
Delphi
protected
 procedure Execute; override;
See Also

Reference

  • TfrxGuiThread
  • frxThreading


TfrxThreadSynchronizer Class

Summary

Represents type TfrxThreadSynchronizer.

Namespace: frxThreading
Inheritance Hierarchy
TObject
frxThreading.TfrxThreadSynchronizer
Syntax
Delphi
type
 TfrxThreadSynchronizer = class
 end;

The TfrxThreadSynchronizer type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxThreadSynchronizer class.
Destroy | Represents the destructor of the TfrxThreadSynchronizer class.
Top
Properties
Show:
Name | Description
WindowHandle | Represents property WindowHandle.
Top
Methods
Show:
Name | Description
WndProc(TMessage) | Represents method WndProc(TMessage).
Top
Fields
Show:
Name | Description
FIsMain | Represents field FIsMain.
FWindowHandle | Represents field FWindowHandle.
Top
See Also

Reference

  • frxThreading


TfrxThreadSynchronizer Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxThreadSynchronizer class.
Destroy | Represents the destructor of the TfrxThreadSynchronizer class.
Top


TfrxThreadSynchronizer.Create Constructor

Summary

Initializes a new instance of the TfrxThreadSynchronizer class.

Namespace: frxThreading
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxThreadSynchronizer
  • frxThreading


TfrxThreadSynchronizer.Destroy Destructor

Summary

Represents the destructor of the TfrxThreadSynchronizer class.

Namespace: frxThreading
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxThreadSynchronizer
  • frxThreading


TfrxThreadSynchronizer Properties

Properties
Name | Description
WindowHandle | Represents property WindowHandle.
Top


TfrxThreadSynchronizer.WindowHandle Property

Summary

Represents property WindowHandle.

Namespace: frxThreading
Syntax
Delphi
public
 property WindowHandle: HWND read FWindowHandle;

Property Value

Type: HWND

See Also

Reference

  • TfrxThreadSynchronizer
  • frxThreading


TfrxThreadSynchronizer Methods

Methods
Name | Description
WndProc(TMessage) | Represents method WndProc(TMessage).
Top


TfrxThreadSynchronizer.WndProc(TMessage) Method

Summary

Represents method WndProc(TMessage).

Namespace: frxThreading
Syntax
Delphi
private
 procedure WndProc(var Message: TMessage);

Parameters

Message
Type: TMessage

See Also

Reference

  • TfrxThreadSynchronizer
  • frxThreading


TfrxThreadSynchronizer Fields

Fields
Name | Description
FIsMain | Represents field FIsMain.
FWindowHandle | Represents field FWindowHandle.
Top


TfrxThreadSynchronizer.FIsMain Field

Summary

Represents field FIsMain.

Namespace: frxThreading
Syntax
Delphi
private
 FIsMain: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxThreadSynchronizer
  • frxThreading


TfrxThreadSynchronizer.FWindowHandle Field

Summary

Represents field FWindowHandle.

Namespace: frxThreading
Syntax
Delphi
private
 FWindowHandle: HWND;

Field Value

Type: HWND

See Also

Reference

  • TfrxThreadSynchronizer
  • frxThreading


frxThreading Variables

Variables
Name | Description
frxDisableThreadSynchronizer | Represents variable frxDisableThreadSynchronizer.
Top


frxDisableThreadSynchronizer Variable

Summary

Represents variable frxDisableThreadSynchronizer.

Namespace: frxThreading
Syntax
Delphi
frxDisableThreadSynchronizer: Boolean;

Value

Type: Boolean

See Also

Reference

  • frxThreading


frxThreading Constants

Constants
Name | Description
WM_FRX_SYNC_MESSAGE | Represents constant WM_FRX_SYNC_MESSAGE.
WM_FRX_SYNC_THREAD | Represents constant WM_FRX_SYNC_THREAD.
Top


WM_FRX_SYNC_MESSAGE Constant

Summary

Represents constant WM_FRX_SYNC_MESSAGE.

Namespace: frxThreading
Syntax
Delphi
 WM_FRX_SYNC_MESSAGE = WM_USER + 251;

Value

Type: Void

See Also

Reference

  • frxThreading


WM_FRX_SYNC_THREAD Constant

Summary

Represents constant WM_FRX_SYNC_THREAD.

Namespace: frxThreading
Syntax
Delphi
 WM_FRX_SYNC_THREAD = WM_USER + 250;

Value

Type: Void

See Also

Reference

  • frxThreading


frxThreading Routines

Routines
Name | Description
frxSynchSendMessage(HWND,UINT,WPARAM,LPARAM) | Represents method frxSynchSendMessage(HWND,UINT,WPARAM,LPARAM).
frxThreadSynchronize(TThreadMethod) | Represents method frxThreadSynchronize(TThreadMethod).
GetThreadSynchronizer | Represents method GetThreadSynchronizer.
IsThreadSynchronizerActive | Represents method IsThreadSynchronizerActive.
Top


frxSynchSendMessage(HWND,UINT,WPARAM,LPARAM) Method

Summary

Represents method frxSynchSendMessage(HWND,UINT,WPARAM,LPARAM).

Namespace: frxThreading
Syntax
Delphi
 function frxSynchSendMessage(hWnd: HWND; Msg: UINT; wParam: WPARAM; lParam: LPARAM): LRESULT;

Parameters

hWnd
Type: HWND

Msg
Type: UINT

wParam
Type: WPARAM

lParam
Type: LPARAM

Return Value

Type: LRESULT

See Also

Reference

  • frxThreading


frxThreadSynchronize(TThreadMethod) Method

Summary

Represents method frxThreadSynchronize(TThreadMethod).

Namespace: frxThreading
Syntax
Delphi
 procedure frxThreadSynchronize(Method: TThreadMethod);

Parameters

Method
Type: TThreadMethod

See Also

Reference

  • frxThreading


GetThreadSynchronizer Method

Summary

Represents method GetThreadSynchronizer.

Namespace: frxThreading
Syntax
Delphi
 function GetThreadSynchronizer: TfrxThreadSynchronizer;

Return Value

Type: TfrxThreadSynchronizer

See Also

Reference

  • frxThreading


IsThreadSynchronizerActive Method

Summary

Represents method IsThreadSynchronizerActive.

Namespace: frxThreading
Syntax
Delphi
 function IsThreadSynchronizerActive: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • frxThreading


frxUnicodeCtrls Namespace

Summary

Represents namespace frxUnicodeCtrls.

Classes
Name | Description
TRxUnicodeRichEdit | Represents type TRxUnicodeRichEdit.
TUnicodeEdit | Represents type TUnicodeEdit.
TUnicodeMemo | Represents type TUnicodeMemo.
Top


frxUnicodeCtrls Classes

Classes
Name | Description
TRxUnicodeRichEdit | Represents type TRxUnicodeRichEdit.
TUnicodeEdit | Represents type TUnicodeEdit.
TUnicodeMemo | Represents type TUnicodeMemo.
Top


TRxUnicodeRichEdit Class

Summary

Represents type TRxUnicodeRichEdit.

Namespace: frxUnicodeCtrls
Inheritance Hierarchy
TCustomMemo
frxRichEdit.TRxCustomRichEdit
frxRichEdit.TRxRichEdit
frxUnicodeCtrls.TRxUnicodeRichEdit
Syntax
Delphi
type
 TRxUnicodeRichEdit = class(TRxRichEdit)
 ;

The TRxUnicodeRichEdit type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TRxCustomRichEdit class. (Inherited from TRxCustomRichEdit.)
Top
Properties
Show:
Name | Description
Align | Represents property Align. (Inherited from TRxRichEdit.)
Alignment | Represents property Alignment. (Inherited from TRxRichEdit.)
AllowInPlace | Represents property AllowInPlace. (Inherited from TRxRichEdit.)
AllowObjects | Represents property AllowObjects. (Inherited from TRxRichEdit.)
Anchors | Represents property Anchors. (Inherited from TRxRichEdit.)
AutoURLDetect | Represents property AutoURLDetect. (Inherited from TRxRichEdit.)
AutoVerbMenu | Represents property AutoVerbMenu. (Inherited from TRxRichEdit.)
BiDiMode | Represents property BiDiMode. (Inherited from TRxRichEdit.)
BorderStyle | Represents property BorderStyle. (Inherited from TRxRichEdit.)
BorderWidth | Represents property BorderWidth. (Inherited from TRxRichEdit.)
CanFindNext | Represents property CanFindNext. (Inherited from TRxCustomRichEdit.)
CanPaste | Represents property CanPaste. (Inherited from TRxCustomRichEdit.)
CanRedo | Represents property CanRedo. (Inherited from TRxCustomRichEdit.)
Color | Represents property Color. (Inherited from TRxRichEdit.)
Constraints | Represents property Constraints. (Inherited from TRxRichEdit.)
Ctl3D | Represents property Ctl3D. (Inherited from TRxRichEdit.)
DefAttributes | Represents property DefAttributes. (Inherited from TRxCustomRichEdit.)
DefaultConverter | Represents property DefaultConverter. (Inherited from TRxCustomRichEdit.)
DragCursor | Represents property DragCursor. (Inherited from TRxRichEdit.)
DragKind | Represents property DragKind. (Inherited from TRxRichEdit.)
DragMode | Represents property DragMode. (Inherited from TRxRichEdit.)
Enabled | Represents property Enabled. (Inherited from TRxRichEdit.)
Font | Represents property Font. (Inherited from TRxRichEdit.)
HideScrollBars | Represents property HideScrollBars. (Inherited from TRxRichEdit.)
HideSelection | Represents property HideSelection. (Inherited from TRxRichEdit.)
ImeMode | Represents property ImeMode. (Inherited from TRxRichEdit.)
ImeName | Represents property ImeName. (Inherited from TRxRichEdit.)
LangOptions | Represents property LangOptions. (Inherited from TRxRichEdit.)
Lines | Represents property Lines. (Inherited from TRxRichEdit.)
MaxLength | Represents property MaxLength. (Inherited from TRxRichEdit.)
OnChange | Represents property OnChange. (Inherited from TRxRichEdit.)
OnCloseFindDialog | Represents property OnCloseFindDialog. (Inherited from TRxRichEdit.)
OnContextPopup | Represents property OnContextPopup. (Inherited from TRxRichEdit.)
OnDblClick | Represents property OnDblClick. (Inherited from TRxRichEdit.)
OnDragDrop | Represents property OnDragDrop. (Inherited from TRxRichEdit.)
OnDragOver | Represents property OnDragOver. (Inherited from TRxRichEdit.)
OnEndDock | Represents property OnEndDock. (Inherited from TRxRichEdit.)
OnEndDrag | Represents property OnEndDrag. (Inherited from TRxRichEdit.)
OnEnter | Represents property OnEnter. (Inherited from TRxRichEdit.)
OnExit | Represents property OnExit. (Inherited from TRxRichEdit.)
OnKeyDown | Represents property OnKeyDown. (Inherited from TRxRichEdit.)
OnKeyPress | Represents property OnKeyPress. (Inherited from TRxRichEdit.)
OnKeyUp | Represents property OnKeyUp. (Inherited from TRxRichEdit.)
OnMouseDown | Represents property OnMouseDown. (Inherited from TRxRichEdit.)
OnMouseMove | Represents property OnMouseMove. (Inherited from TRxRichEdit.)
OnMouseUp | Represents property OnMouseUp. (Inherited from TRxRichEdit.)
OnMouseWheel | Represents property OnMouseWheel. (Inherited from TRxRichEdit.)
OnMouseWheelDown | Represents property OnMouseWheelDown. (Inherited from TRxRichEdit.)
OnMouseWheelUp | Represents property OnMouseWheelUp. (Inherited from TRxRichEdit.)
OnProtectChange | Represents property OnProtectChange. (Inherited from TRxRichEdit.)
OnProtectChangeEx | Represents property OnProtectChangeEx. (Inherited from TRxRichEdit.)
OnResizeRequest | Represents property OnResizeRequest. (Inherited from TRxRichEdit.)
OnSaveClipboard | Represents property OnSaveClipboard. (Inherited from TRxRichEdit.)
OnSelectionChange | Represents property OnSelectionChange. (Inherited from TRxRichEdit.)
OnStartDock | Represents property OnStartDock. (Inherited from TRxRichEdit.)
OnStartDrag | Represents property OnStartDrag. (Inherited from TRxRichEdit.)
OnTextNotFound | Represents property OnTextNotFound. (Inherited from TRxRichEdit.)
OnURLClick | Represents property OnURLClick. (Inherited from TRxRichEdit.)
PageRect | Represents property PageRect. (Inherited from TRxCustomRichEdit.)
Paragraph | Represents property Paragraph. (Inherited from TRxCustomRichEdit.)
ParentBiDiMode | Represents property ParentBiDiMode. (Inherited from TRxRichEdit.)
ParentColor | Represents property ParentColor. (Inherited from TRxRichEdit.)
ParentCtl3D | Represents property ParentCtl3D. (Inherited from TRxRichEdit.)
ParentFont | Represents property ParentFont. (Inherited from TRxRichEdit.)
ParentShowHint | Represents property ParentShowHint. (Inherited from TRxRichEdit.)
PlainText | Represents property PlainText. (Inherited from TRxRichEdit.)
PopupMenu | Represents property PopupMenu. (Inherited from TRxRichEdit.)
ReadOnly | Represents property ReadOnly. (Inherited from TRxRichEdit.)
RedoName | Represents property RedoName. (Inherited from TRxCustomRichEdit.)
ScrollBars | Represents property ScrollBars. (Inherited from TRxRichEdit.)
SelAttributes | Represents property SelAttributes. (Inherited from TRxCustomRichEdit.)
SelectionBar | Represents property SelectionBar. (Inherited from TRxRichEdit.)
SelectionType | Represents property SelectionType. (Inherited from TRxCustomRichEdit.)
ShowHint | Represents property ShowHint. (Inherited from TRxRichEdit.)
StreamFormat | Represents property StreamFormat. (Inherited from TRxRichEdit.)
StreamMode | Represents property StreamMode. (Inherited from TRxRichEdit.)
TabOrder | Represents property TabOrder. (Inherited from TRxRichEdit.)
TabStop | Represents property TabStop. (Inherited from TRxRichEdit.)
Title | Represents property Title. (Inherited from TRxRichEdit.)
UndoLimit | Represents property UndoLimit. (Inherited from TRxRichEdit.)
UndoName | Represents property UndoName. (Inherited from TRxCustomRichEdit.)
Visible | Represents property Visible. (Inherited from TRxRichEdit.)
WantReturns | Represents property WantReturns. (Inherited from TRxRichEdit.)
WantTabs | Represents property WantTabs. (Inherited from TRxRichEdit.)
WordAttributes | Represents property WordAttributes. (Inherited from TRxCustomRichEdit.)
WordSelection | Represents property WordSelection. (Inherited from TRxRichEdit.)
WordWrap | Represents property WordWrap. (Inherited from TRxRichEdit.)
Top
Methods
Show:
Name | Description
Clear | Represents method Clear. (Inherited from TRxCustomRichEdit.)
ClearUndo | Represents method ClearUndo. (Inherited from TRxCustomRichEdit.)
CloseFindDialog(TFindDialog) | Represents method CloseFindDialog(TFindDialog). (Inherited from TRxCustomRichEdit.)
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams). (Inherited from TRxCustomRichEdit.)
CreateWindowHandle(TCreateParams) | Represents method CreateWindowHandle(TCreateParams). (Inherited from TRxCustomRichEdit.)
CreateWnd | Represents method CreateWnd. (Inherited from TRxCustomRichEdit.)
DestroyWnd | Represents method DestroyWnd. (Inherited from TRxCustomRichEdit.)
DoSetMaxLength(Integer) | Represents method DoSetMaxLength(Integer). (Inherited from TRxCustomRichEdit.)
FindDialog(string) | Represents method FindDialog(string). (Inherited from TRxCustomRichEdit.)
FindNext | Represents method FindNext. (Inherited from TRxCustomRichEdit.)
FindText(string,Integer,Integer,TRichSearchTypes) | Represents method FindText(string,Integer,Integer,TRichSearchTypes). (Inherited from TRxCustomRichEdit.)
GetCaretPos | Represents method GetCaretPos. (Inherited from TRxCustomRichEdit.)
GetCharPos(Integer) | Represents method GetCharPos(Integer). (Inherited from TRxCustomRichEdit.)
GetLineIndex(Integer) | Represents method GetLineIndex(Integer). (Inherited from TRxCustomRichEdit.)
GetLineLength(Integer) | Represents method GetLineLength(Integer). (Inherited from TRxCustomRichEdit.)
GetPopupMenu | Represents method GetPopupMenu. (Inherited from TRxCustomRichEdit.)
GetSelection | Represents method GetSelection. (Inherited from TRxCustomRichEdit.)
GetSelLength | Represents method GetSelLength. (Inherited from TRxCustomRichEdit.)
GetSelStart | Represents method GetSelStart. (Inherited from TRxCustomRichEdit.)
GetSelText | Represents method GetSelText. (Inherited from TRxCustomRichEdit.)
GetSelTextBuf(PChar,Integer) | Represents method GetSelTextBuf(PChar,Integer). (Inherited from TRxCustomRichEdit.)
GetTextLen | Represents method GetTextLen. (Inherited from TRxCustomRichEdit.)
GetTextRange(Longint,Longint) | Represents method GetTextRange(Longint,Longint). (Inherited from TRxCustomRichEdit.)
InsertObjectDialog | Represents method InsertObjectDialog. (Inherited from TRxCustomRichEdit.)
LineFromChar(Integer) | Represents method LineFromChar(Integer). (Inherited from TRxCustomRichEdit.)
ObjectPropertiesDialog | Represents method ObjectPropertiesDialog. (Inherited from TRxCustomRichEdit.)
PasteSpecialDialog | Represents method PasteSpecialDialog. (Inherited from TRxCustomRichEdit.)
Print(string) | Represents method Print(string). (Inherited from TRxCustomRichEdit.)
ProtectChange(TMessage,Integer,Integer) | Represents method ProtectChange(TMessage,Integer,Integer). (Inherited from TRxCustomRichEdit.)
Redo | Represents method Redo. (Inherited from TRxCustomRichEdit.)
RegisterConversionFormat(string,Boolean,TConversionClass) | Represents method RegisterConversionFormat(string,Boolean,TConversionClass). (Inherited from TRxCustomRichEdit.)
ReplaceDialog(string,string) | Represents method ReplaceDialog(string,string). (Inherited from TRxCustomRichEdit.)
RequestSize(TRect) | Represents method RequestSize(TRect). (Inherited from TRxCustomRichEdit.)
SaveClipboard(Integer,Integer) | Represents method SaveClipboard(Integer,Integer). (Inherited from TRxCustomRichEdit.)
SelectionChange | Represents method SelectionChange. (Inherited from TRxCustomRichEdit.)
SendSynchMessage(UINT,WPARAM,LPARAM,Boolean) | Represents method SendSynchMessage(UINT,WPARAM,LPARAM,Boolean). (Inherited from TRxCustomRichEdit.)
SetPlainText(Boolean) | Represents method SetPlainText(Boolean). (Inherited from TRxCustomRichEdit.)
SetSelection(Longint,Longint,Boolean) | Represents method SetSelection(Longint,Longint,Boolean). (Inherited from TRxCustomRichEdit.)
SetSelLength(Integer) | Represents method SetSelLength(Integer). (Inherited from TRxCustomRichEdit.)
SetSelStart(Integer) | Represents method SetSelStart(Integer). (Inherited from TRxCustomRichEdit.)
StopGroupTyping | Represents method StopGroupTyping. (Inherited from TRxCustomRichEdit.)
TextNotFound(TFindDialog) | Represents method TextNotFound(TFindDialog). (Inherited from TRxCustomRichEdit.)
URLClick(string,TMouseButton) | Represents method URLClick(string,TMouseButton). (Inherited from TRxCustomRichEdit.)
WordAtCursor | Represents method WordAtCursor. (Inherited from TRxCustomRichEdit.)
Top
See Also

Reference

  • frxUnicodeCtrls


TUnicodeEdit Class

Summary

Represents type TUnicodeEdit.

Namespace: frxUnicodeCtrls
Inheritance Hierarchy
TEdit
frxUnicodeCtrls.TUnicodeEdit
Syntax
Delphi
type
 TUnicodeEdit = class(TEdit)
 end;

The TUnicodeEdit type exposes the following members.

Properties
Show:
Name | Description
SelText | Represents property SelText.
Text | Represents property Text.
Top
Methods
Show:
Name | Description
CreateWindowHandle(TCreateParams) | Represents method CreateWindowHandle(TCreateParams).
GetSelText | Represents method GetSelText.
GetText | Represents method GetText.
SetSelText(WideString) | Represents method SetSelText(WideString).
SetText(WideString) | Represents method SetText(WideString).
Top
See Also

Reference

  • frxUnicodeCtrls


TUnicodeEdit Properties

Properties
Name | Description
SelText | Represents property SelText.
Text | Represents property Text.
Top


TUnicodeEdit.SelText Property

Summary

Represents property SelText.

Namespace: frxUnicodeCtrls
Syntax
Delphi
public
 property SelText: WideString read GetSelText write SetSelText;

Property Value

Type: WideString

See Also

Reference

  • TUnicodeEdit
  • frxUnicodeCtrls


TUnicodeEdit.Text Property

Summary

Represents property Text.

Namespace: frxUnicodeCtrls
Syntax
Delphi
public
 property Text: WideString read GetText write SetText;

Property Value

Type: WideString

See Also

Reference

  • TUnicodeEdit
  • frxUnicodeCtrls


TUnicodeEdit Methods

Methods
Name | Description
CreateWindowHandle(TCreateParams) | Represents method CreateWindowHandle(TCreateParams).
GetSelText | Represents method GetSelText.
GetText | Represents method GetText.
SetSelText(WideString) | Represents method SetSelText(WideString).
SetText(WideString) | Represents method SetText(WideString).
Top


TUnicodeEdit.CreateWindowHandle(TCreateParams) Method

Summary

Represents method CreateWindowHandle(TCreateParams).

Namespace: frxUnicodeCtrls
Syntax
Delphi
protected
 procedure CreateWindowHandle(const Params: TCreateParams); override;

Parameters

Params
Type: TCreateParams

See Also

Reference

  • TUnicodeEdit
  • frxUnicodeCtrls


TUnicodeEdit.GetSelText Method

Summary

Represents method GetSelText.

Namespace: frxUnicodeCtrls
Syntax
Delphi
protected
 function GetSelText: WideString; reintroduce;

Return Value

Type: WideString

See Also

Reference

  • TUnicodeEdit
  • frxUnicodeCtrls


TUnicodeEdit.GetText Method

Summary

Represents method GetText.

Namespace: frxUnicodeCtrls
Syntax
Delphi
private
 function GetText: WideString;

Return Value

Type: WideString

See Also

Reference

  • TUnicodeEdit
  • frxUnicodeCtrls


TUnicodeEdit.SetSelText(WideString) Method

Summary

Represents method SetSelText(WideString).

Namespace: frxUnicodeCtrls
Syntax
Delphi
private
 procedure SetSelText(const Value: WideString);

Parameters

Value
Type: WideString

See Also

Reference

  • TUnicodeEdit
  • frxUnicodeCtrls


TUnicodeEdit.SetText(WideString) Method

Summary

Represents method SetText(WideString).

Namespace: frxUnicodeCtrls
Syntax
Delphi
private
 procedure SetText(const Value: WideString);

Parameters

Value
Type: WideString

See Also

Reference

  • TUnicodeEdit
  • frxUnicodeCtrls


TUnicodeMemo Class

Summary

Represents type TUnicodeMemo.

Namespace: frxUnicodeCtrls
Inheritance Hierarchy
TMemo
frxUnicodeCtrls.TUnicodeMemo
Syntax
Delphi
type
 TUnicodeMemo = class(TMemo)
 end;
See Also

Reference

  • frxUnicodeCtrls


frxUnicodeUtils Namespace

Summary

Represents namespace frxUnicodeUtils.

Classes
Name | Description
TfrxWideStrings | Represents type TfrxWideStrings.
Top
Records
Name | Description
TWString | Represents type TWString.
Top
Routines
Name | Description
AnsiToUnicode(AnsiString,UINT,Integer) | Represents method AnsiToUnicode(AnsiString,UINT,Integer).
CharSetToCodePage(DWORD) | Represents method CharSetToCodePage(DWORD).
GetLocalByCharSet(UINT) | Represents method GetLocalByCharSet(UINT).
OemToStr(AnsiString) | Represents method OemToStr(AnsiString).
_UnicodeToAnsi(WideString,UINT,Integer) | Represents method _UnicodeToAnsi(WideString,UINT,Integer).
Top


frxUnicodeUtils Classes

Classes
Name | Description
TfrxWideStrings | Represents type TfrxWideStrings.
Top


TfrxWideStrings Class

Summary

Represents type TfrxWideStrings.

Namespace: frxUnicodeUtils
Inheritance Hierarchy
TWideStrings
frxUnicodeUtils.TfrxWideStrings
Syntax
Delphi
type
 TfrxWideStrings = class(TWideStrings)
 end;

The TfrxWideStrings type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxWideStrings class.
Destroy | Represents the destructor of the TfrxWideStrings class.
Top
Properties
Show:
Name | Description
Objects[Integer] | Represents property Objects[Integer].
Strings[Integer] | Represents property Strings[Integer].
Text | Represents property Text.
Top
Methods
Show:
Name | Description
Add(WideString) | Represents method Add(WideString).
AddObject(WideString,TObject) | Represents method AddObject(WideString,TObject).
AddStrings(TWideStrings) | Represents method AddStrings(TWideStrings).
Assign(TPersistent) | Represents method Assign(TPersistent).
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Clear | Represents method Clear.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Delete(Integer) | Represents method Delete(Integer).
Get(Integer) | Represents method Get(Integer).
GetCount | Represents method GetCount.
GetObject(Integer) | Represents method GetObject(Integer).
GetTextStr | Represents method GetTextStr.
IndexOf(WideString) | Represents method IndexOf(WideString).
Insert(Integer,WideString) | Represents method Insert(Integer,WideString).
LoadFromFile(WideString) | Represents method LoadFromFile(WideString).
LoadFromStream(TStream) | Represents method LoadFromStream(TStream).
LoadFromWStream(TStream) | Represents method LoadFromWStream(TStream).
Put(Integer,WideString) | Represents method Put(Integer,WideString).
PutObject(Integer,TObject) | Represents method PutObject(Integer,TObject).
ReadData(TReader) | Represents method ReadData(TReader).
ReadDataW(TReader) | Represents method ReadDataW(TReader).
ReadDataWOld(TReader) | Represents method ReadDataWOld(TReader).
SaveToFile(WideString) | Represents method SaveToFile(WideString).
SaveToStream(TStream) | Represents method SaveToStream(TStream).
SetTextStr(WideString) | Represents method SetTextStr(WideString).
WriteDataW(TWriter) | Represents method WriteDataW(TWriter).
Top
Fields
Show:
Name | Description
FWideStringList | Represents field FWideStringList.
Top
See Also

Reference

  • frxUnicodeUtils


TfrxWideStrings Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxWideStrings class.
Destroy | Represents the destructor of the TfrxWideStrings class.
Top


TfrxWideStrings.Create Constructor

Summary

Initializes a new instance of the TfrxWideStrings class.

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.Destroy Destructor

Summary

Represents the destructor of the TfrxWideStrings class.

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings Properties

Properties
Name | Description
Objects[Integer] | Represents property Objects[Integer].
Strings[Integer] | Represents property Strings[Integer].
Text | Represents property Text.
Top


TfrxWideStrings.Objects[Integer] Property

Summary

Represents property Objects[Integer].

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 property Objects[Index: Integer]: TObject read GetObject write PutObject;

Parameters

Index
Type: Integer

Property Value

Type: TObject

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.Strings[Integer] Property

Summary

Represents property Strings[Integer].

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 property Strings[Index: Integer]: WideString read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: WideString

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.Text Property

Summary

Represents property Text.

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 property Text: WideString read GetTextStr write SetTextStr;

Property Value

Type: WideString

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings Methods

Methods
Name | Description
Add(WideString) | Represents method Add(WideString).
AddObject(WideString,TObject) | Represents method AddObject(WideString,TObject).
AddStrings(TWideStrings) | Represents method AddStrings(TWideStrings).
Assign(TPersistent) | Represents method Assign(TPersistent).
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Clear | Represents method Clear.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Delete(Integer) | Represents method Delete(Integer).
Get(Integer) | Represents method Get(Integer).
GetCount | Represents method GetCount.
GetObject(Integer) | Represents method GetObject(Integer).
GetTextStr | Represents method GetTextStr.
IndexOf(WideString) | Represents method IndexOf(WideString).
Insert(Integer,WideString) | Represents method Insert(Integer,WideString).
LoadFromFile(WideString) | Represents method LoadFromFile(WideString).
LoadFromStream(TStream) | Represents method LoadFromStream(TStream).
LoadFromWStream(TStream) | Represents method LoadFromWStream(TStream).
Put(Integer,WideString) | Represents method Put(Integer,WideString).
PutObject(Integer,TObject) | Represents method PutObject(Integer,TObject).
ReadData(TReader) | Represents method ReadData(TReader).
ReadDataW(TReader) | Represents method ReadDataW(TReader).
ReadDataWOld(TReader) | Represents method ReadDataWOld(TReader).
SaveToFile(WideString) | Represents method SaveToFile(WideString).
SaveToStream(TStream) | Represents method SaveToStream(TStream).
SetTextStr(WideString) | Represents method SetTextStr(WideString).
WriteDataW(TWriter) | Represents method WriteDataW(TWriter).
Top


TfrxWideStrings.Add(WideString) Method

Summary

Represents method Add(WideString).

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 function Add(const S: WideString): Integer; override;

Parameters

S
Type: WideString

Return Value

Type: Integer

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.AddObject(WideString,TObject) Method

Summary

Represents method AddObject(WideString,TObject).

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 function AddObject(const S: WideString; AObject: TObject): Integer; override;

Parameters

S
Type: WideString

AObject
Type: TObject

Return Value

Type: Integer

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.AddStrings(TWideStrings) Method

Summary

Represents method AddStrings(TWideStrings).

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 procedure AddStrings(Strings: TWideStrings); override;

Parameters

Strings
Type: TWideStrings

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: frxUnicodeUtils
Syntax
Delphi
protected
 procedure AssignTo(Dest: TPersistent); override;

Parameters

Dest
Type: TPersistent

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.Clear Method

Summary

Represents method Clear.

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 procedure Clear; override;
See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxUnicodeUtils
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 procedure Delete(Index: Integer); override;

Parameters

Index
Type: Integer

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.Get(Integer) Method

Summary

Represents method Get(Integer).

Namespace: frxUnicodeUtils
Syntax
Delphi
protected
 function Get(Index: Integer): WideString; override;

Parameters

Index
Type: Integer

Return Value

Type: WideString

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.GetCount Method

Summary

Represents method GetCount.

Namespace: frxUnicodeUtils
Syntax
Delphi
protected
 function GetCount: Integer; override;

Return Value

Type: Integer

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.GetObject(Integer) Method

Summary

Represents method GetObject(Integer).

Namespace: frxUnicodeUtils
Syntax
Delphi
protected
 function GetObject(Index: Integer): TObject; override;

Parameters

Index
Type: Integer

Return Value

Type: TObject

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.GetTextStr Method

Summary

Represents method GetTextStr.

Namespace: frxUnicodeUtils
Syntax
Delphi
protected
 function GetTextStr: WideString; override;

Return Value

Type: WideString

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.IndexOf(WideString) Method

Summary

Represents method IndexOf(WideString).

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 function IndexOf(const S: WideString): Integer; override;

Parameters

S
Type: WideString

Return Value

Type: Integer

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.Insert(Integer,WideString) Method

Summary

Represents method Insert(Integer,WideString).

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 procedure Insert(Index: Integer; const S: WideString); override;

Parameters

Index
Type: Integer

S
Type: WideString

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.LoadFromFile(WideString) Method

Summary

Represents method LoadFromFile(WideString).

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 procedure LoadFromFile(const FileName: WideString); override;

Parameters

FileName
Type: WideString

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.LoadFromStream(TStream) Method

Summary

Represents method LoadFromStream(TStream).

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 procedure LoadFromStream(Stream: TStream); override;

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.LoadFromWStream(TStream) Method

Summary

Represents method LoadFromWStream(TStream).

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 procedure LoadFromWStream(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.Put(Integer,WideString) Method

Summary

Represents method Put(Integer,WideString).

Namespace: frxUnicodeUtils
Syntax
Delphi
protected
 procedure Put(Index: Integer; const S: WideString); override;

Parameters

Index
Type: Integer

S
Type: WideString

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.PutObject(Integer,TObject) Method

Summary

Represents method PutObject(Integer,TObject).

Namespace: frxUnicodeUtils
Syntax
Delphi
protected
 procedure PutObject(Index: Integer; Value: TObject); override;

Parameters

Index
Type: Integer

Value
Type: TObject

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.ReadData(TReader) Method

Summary

Represents method ReadData(TReader).

Namespace: frxUnicodeUtils
Syntax
Delphi
private
 procedure ReadData(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.ReadDataW(TReader) Method

Summary

Represents method ReadDataW(TReader).

Namespace: frxUnicodeUtils
Syntax
Delphi
private
 procedure ReadDataW(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.ReadDataWOld(TReader) Method

Summary

Represents method ReadDataWOld(TReader).

Namespace: frxUnicodeUtils
Syntax
Delphi
private
 procedure ReadDataWOld(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.SaveToFile(WideString) Method

Summary

Represents method SaveToFile(WideString).

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 procedure SaveToFile(const FileName: WideString); override;

Parameters

FileName
Type: WideString

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.SaveToStream(TStream) Method

Summary

Represents method SaveToStream(TStream).

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 procedure SaveToStream(Stream: TStream); override;

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.SetTextStr(WideString) Method

Summary

Represents method SetTextStr(WideString).

Namespace: frxUnicodeUtils
Syntax
Delphi
protected
 procedure SetTextStr(const Value: WideString); override;

Parameters

Value
Type: WideString

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings.WriteDataW(TWriter) Method

Summary

Represents method WriteDataW(TWriter).

Namespace: frxUnicodeUtils
Syntax
Delphi
private
 procedure WriteDataW(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


TfrxWideStrings Fields

Fields
Name | Description
FWideStringList | Represents field FWideStringList.
Top


TfrxWideStrings.FWideStringList Field

Summary

Represents field FWideStringList.

Namespace: frxUnicodeUtils
Syntax
Delphi
private
 FWideStringList: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxWideStrings
  • frxUnicodeUtils


frxUnicodeUtils Records

Records
Name | Description
TWString | Represents type TWString.
Top


TWString Record

Summary

Represents type TWString.

Namespace: frxUnicodeUtils
Syntax
Delphi
type
 TWString = record
 end;

The TWString type exposes the following members.

Fields
Show:
Name | Description
Obj | Represents field Obj.
WString | Represents field WString.
Top
See Also

Reference

  • frxUnicodeUtils


TWString Fields

Fields
Name | Description
Obj | Represents field Obj.
WString | Represents field WString.
Top


TWString.Obj Field

Summary

Represents field Obj.

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 Obj: TObject;

Field Value

Type: TObject

See Also

Reference

  • TWString
  • frxUnicodeUtils


TWString.WString Field

Summary

Represents field WString.

Namespace: frxUnicodeUtils
Syntax
Delphi
public
 WString: WideString;

Field Value

Type: WideString

See Also

Reference

  • TWString
  • frxUnicodeUtils


frxUnicodeUtils Routines

Routines
Name | Description
AnsiToUnicode(AnsiString,UINT,Integer) | Represents method AnsiToUnicode(AnsiString,UINT,Integer).
CharSetToCodePage(DWORD) | Represents method CharSetToCodePage(DWORD).
GetLocalByCharSet(UINT) | Represents method GetLocalByCharSet(UINT).
OemToStr(AnsiString) | Represents method OemToStr(AnsiString).
_UnicodeToAnsi(WideString,UINT,Integer) | Represents method _UnicodeToAnsi(WideString,UINT,Integer).
Top


AnsiToUnicode(AnsiString,UINT,Integer) Method

Summary

Represents method AnsiToUnicode(AnsiString,UINT,Integer).

Namespace: frxUnicodeUtils
Syntax
Delphi
function AnsiToUnicode(const s: AnsiString; Charset: UINT; CodePage: Integer = 0): WideString;

Parameters

s
Type: AnsiString

Charset
Type: UINT

CodePage
Type: Integer

Return Value

Type: WideString

See Also

Reference

  • frxUnicodeUtils


CharSetToCodePage(DWORD) Method

Summary

Represents method CharSetToCodePage(DWORD).

Namespace: frxUnicodeUtils
Syntax
Delphi
function CharSetToCodePage(ciCharset: DWORD): Cardinal;

Parameters

ciCharset
Type: DWORD

Return Value

Type: Cardinal

See Also

Reference

  • frxUnicodeUtils


GetLocalByCharSet(UINT) Method

Summary

Represents method GetLocalByCharSet(UINT).

Namespace: frxUnicodeUtils
Syntax
Delphi
function GetLocalByCharSet(Charset: UINT): Cardinal;

Parameters

Charset
Type: UINT

Return Value

Type: Cardinal

See Also

Reference

  • frxUnicodeUtils


OemToStr(AnsiString) Method

Summary

Represents method OemToStr(AnsiString).

Namespace: frxUnicodeUtils
Syntax
Delphi
function OemToStr(const AnsiStr: AnsiString): AnsiString;

Parameters

AnsiStr
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • frxUnicodeUtils


_UnicodeToAnsi(WideString,UINT,Integer) Method

Summary

Represents method _UnicodeToAnsi(WideString,UINT,Integer).

Namespace: frxUnicodeUtils
Syntax
Delphi
function _UnicodeToAnsi(const WS: WideString; Charset: UINT; CodePage: Integer = 0): Ansistring;

Parameters

WS
Type: WideString

Charset
Type: UINT

CodePage
Type: Integer

Return Value

Type: Ansistring

See Also

Reference

  • frxUnicodeUtils


frxUtils Namespace

Summary

The unit contains additional helper function used by other FastReports units like type conversions, CRC calculation, image draw and others.

Classes
Name | Description
TfrxMetafile | This class used to override standard behaviour of metafile draw function. By default metafile size includes bottom and right bounds, so the real size of metafile is increased by 1. Default draw function in VCL tries to compensate it and decreases right and bottom bounds by 1 in draw method. This doesn't work because PlayEnhMetaFile stretches output. As a result output may lose 1 pixel in width and that's very critical for outputs like barcodes lines.
TfrxRectArea | Represents type TfrxRectArea.
Top
Types
Name | Description
TByteDinArray | Represents an array of the Byte type.
TIntegerDinArray | Represents an array of the Integer type.
TLongWordDinArray | Represents an array of the LongWord type.
TWordDinArray | Represents an array of the Word type.
Top
Constants
Name | Description
PageBGName | Represents constant PageBGName.
Top
Routines
Name | Description
ChangeGlyphColor(Integer,TColor) | Represents method ChangeGlyphColor(Integer,TColor).
DisplayPNGInfo(TPNGObject) | Represents method DisplayPNGInfo(TPNGObject).
frFloat2Str(Extended,Integer,Char) | Represents method frFloat2Str(Extended,Integer,Char).
frxAssignImages(TBitmap,Integer,Integer,TImageList,TImageList) | Represents method frxAssignImages(TBitmap,Integer,Integer,TImageList,TImageList).
frxCommonErrorHandler(TfrxReport,String) | Represents method frxCommonErrorHandler(TfrxReport,String).
frxConfirmMsg(String,Integer) | Represents method frxConfirmMsg(String,Integer).
frxCreateTempFile(String) | Represents method frxCreateTempFile(String).
frxDecToBinBytes(Longint) | Represents method frxDecToBinBytes(Longint).
frxDrawArrow(TCanvas,TRect,TColor,Boolean,Boolean) | Represents method frxDrawArrow(TCanvas,TRect,TColor,Boolean,Boolean).
frxDrawArrows(TCanvas,TRect,TColor,Boolean,Boolean,Integer,Integer,Integer,Integer) | Represents method frxDrawArrows(TCanvas,TRect,TColor,Boolean,Boolean,Integer,Integer,Integer,Integer).
frxDrawCheckBox(TCanvas,TRect,TColor,TColor,Boolean) | Represents method frxDrawCheckBox(TCanvas,TRect,TColor,TColor,Boolean).
frxDrawGraphic(TCanvas,TRect,TGraphic,Boolean,Boolean,Boolean,TColor) | Represents method frxDrawGraphic(TCanvas,TRect,TGraphic,Boolean,Boolean,Boolean,TColor).
frxDrawIcon(TCustomImageList,TBitmap,Integer,TColor) | Represents method frxDrawIcon(TCustomImageList,TBitmap,Integer,TColor).
frxDrawTransparent(TCanvas,Integer,Integer,TBitmap) | Represents method frxDrawTransparent(TCanvas,Integer,Integer,TBitmap).
frxErrorMsg(String) | Represents method frxErrorMsg(String).
frxFindComponent(TComponent,String) | Searches for a component on owner by name.
frxFloatDiff(Extended,Extended) | Represents method frxFloatDiff(Extended,Extended).
frxFloatToStr(Extended) | Represents method frxFloatToStr(Extended).
frxGetBrackedVariable(AnsiString,AnsiString,AnsiString,Integer,Integer) | Represents method frxGetBrackedVariable(AnsiString,AnsiString,AnsiString,Integer,Integer).
frxGetBrackedVariableW(WideString,WideString,WideString,Integer,Integer) | Represents method frxGetBrackedVariableW(WideString,WideString,WideString,Integer,Integer).
frxGetComponents(TComponent,TClass,TStrings,TComponent) | Fills list with all found component in application with class type specified in ClassRef parameter.
frxGetFullName(TComponent,TComponent) | Returns full name of the component includes full sequences of owners delimired by '.' sign.
frxHexToString(String) | Represents method frxHexToString(String).
frxInfoMsg(String) | Represents method frxInfoMsg(String).
frxIsValidFloat(string) | Represents method frxIsValidFloat(string).
frxParseDilimitedText(TStrings,String,Char) | Represents method frxParseDilimitedText(TStrings,String,Char).
frxParsePageNumbers(String,TStrings,Integer) | Represents method frxParsePageNumbers(String,TStrings,Integer).
frxPoint(Extended,Extended) | Represents method frxPoint(Extended,Extended).
frxReadCollection(TCollection,TfrxXMLItem,TfrxComponent,TfrxCollection) | Overloaded. Represents method frxReadCollection(TCollection,TfrxXMLItem,TfrxComponent,TfrxCollection).
frxReadCollection(TCollection,TReader,TfrxComponent) | Overloaded. Represents method frxReadCollection(TCollection,TReader,TfrxComponent).
frxReadProperties(TPersistent,TReader,TfrxComponent) | Represents method frxReadProperties(TPersistent,TReader,TfrxComponent).
frxRect(Extended,Extended,Extended,Extended) | Represents method frxRect(Extended,Extended,Extended,Extended).
frxRemoveQuotes(String) | Represents method frxRemoveQuotes(String).
frxReverseString(string) | Represents method frxReverseString(string).
frxSetBkMode(TCanvas,Integer) | Represents method frxSetBkMode(TCanvas,Integer).
frxSetCommaText(String,TStrings,Char) | Represents method frxSetCommaText(String,TStrings,Char).
frxStreamCRC32(TStream) | Represents method frxStreamCRC32(TStream).
frxStreamToString(TStream) | Converts stream bytes to hex string representation.
frxStringToHex(WideString) | Represents method frxStringToHex(WideString).
frxStringToStream(String,TStream) | Converts hex string representation to stream bytes and writes them to stream.
frxStrToFloat(String) | Represents method frxStrToFloat(String).
frxUnixPath2WinPath(string) | Represents method frxUnixPath2WinPath(string).
frxUpdateControl(TWinControl,Boolean) | Represents method frxUpdateControl(TWinControl,Boolean).
frxWriteCollection(TCollection,String,TfrxXMLItem,TfrxComponent,TfrxCollection) | Overloaded. Represents method frxWriteCollection(TCollection,String,TfrxXMLItem,TfrxComponent,TfrxCollection).
frxWriteCollection(TCollection,TWriter,TfrxComponent) | Overloaded. Represents method frxWriteCollection(TCollection,TWriter,TfrxComponent).
frxWriteProperties(TPersistent,TWriter,TfrxComponent) | Represents method frxWriteProperties(TPersistent,TWriter,TfrxComponent).
GetAppFileName | Represents method GetAppFileName.
GetAppPath | Represents method GetAppPath.
GetDisplayScale(THandle,Boolean,Extended,Extended) | Represents method GetDisplayScale(THandle,Boolean,Extended,Extended).
GetStr(string) | Represents method GetStr(string).
GetTempFile | Represents method GetTempFile.
GetTemporaryFolder | Represents method GetTemporaryFolder.
HTMLRGBColor(TColor) | Represents method HTMLRGBColor(TColor).
IfColor(Boolean,TColor,TColor) | Represents method IfColor(Boolean,TColor,TColor).
IfInt(Boolean,integer,integer) | Represents method IfInt(Boolean,integer,integer).
IfReal(Boolean,Extended,Extended) | Represents method IfReal(Boolean,Extended,Extended).
IfStr(Boolean,string,string) | Represents method IfStr(Boolean,string,string).
IsPageBG(TfrxComponent) | Represents method IsPageBG(TfrxComponent).
PNGToPNGA(TPngObject) | Represents method PNGToPNGA(TPngObject).
ScaleBitmap(TBitmap,Integer) | Represents method ScaleBitmap(TBitmap,Integer).
TransparentFillRect(HDC,Integer,Integer,Integer,Integer,TColor) | Represents method TransparentFillRect(HDC,Integer,Integer,Integer,Integer,TColor).
Top


frxUtils Classes

Classes
Name | Description
TfrxMetafile | This class used to override standard behaviour of metafile draw function. By default metafile size includes bottom and right bounds, so the real size of metafile is increased by 1. Default draw function in VCL tries to compensate it and decreases right and bottom bounds by 1 in draw method. This doesn't work because PlayEnhMetaFile stretches output. As a result output may lose 1 pixel in width and that's very critical for outputs like barcodes lines.
TfrxRectArea | Represents type TfrxRectArea.
Top


TfrxMetafile Class

Summary

This class used to override standard behaviour of metafile draw function. By default metafile size includes bottom and right bounds, so the real size of metafile is increased by 1. Default draw function in VCL tries to compensate it and decreases right and bottom bounds by 1 in draw method. This doesn't work because PlayEnhMetaFile stretches output. As a result output may lose 1 pixel in width and that's very critical for outputs like barcodes lines.

Namespace: frxUtils
Inheritance Hierarchy
TMetafile
frxUtils.TfrxMetafile
Syntax
Delphi
type
 TfrxMetafile = class(TMetafile)
 end;

The TfrxMetafile type exposes the following members.

Methods
Show:
Name | Description
Draw(TCanvas,TRect) | Represents method Draw(TCanvas,TRect).
Top
See Also

Reference

  • frxUtils


TfrxMetafile Methods

Methods
Name | Description
Draw(TCanvas,TRect) | Represents method Draw(TCanvas,TRect).
Top


TfrxMetafile.Draw(TCanvas,TRect) Method

Summary

Represents method Draw(TCanvas,TRect).

Namespace: frxUtils
Syntax
Delphi
protected
 procedure Draw(ACanvas: TCanvas; const Rect: TRect); override;

Parameters

ACanvas
Type: TCanvas

Rect
Type: TRect

See Also

Reference

  • TfrxMetafile
  • frxUtils


TfrxRectArea Class

Summary

Represents type TfrxRectArea.

Namespace: frxUtils
Inheritance Hierarchy
TObject
frxUtils.TfrxRectArea
Syntax
Delphi
type
 TfrxRectArea = class
 end;

The TfrxRectArea type exposes the following members.

Constructors
Show:
Name | Description
Create(Extended,Extended,Extended,Extended) | Overloaded. Initializes a new instance of the TfrxRectArea class.
Create(TfrxComponent) | Overloaded. Initializes a new instance of the TfrxRectArea class.
Top
Methods
Show:
Name | Description
InterceptsX(TfrxRectArea) | Represents method InterceptsX(TfrxRectArea).
InterceptsY(TfrxRectArea) | Represents method InterceptsY(TfrxRectArea).
InterceptX(TfrxRectArea) | Represents method InterceptX(TfrxRectArea).
InterceptY(TfrxRectArea) | Represents method InterceptY(TfrxRectArea).
Max(Extended,Extended) | Represents method Max(Extended,Extended).
Min(Extended,Extended) | Represents method Min(Extended,Extended).
Top
Fields
Show:
Name | Description
X | Represents field X.
X1 | Represents field X1.
Y | Represents field Y.
Y1 | Represents field Y1.
Top
See Also

Reference

  • frxUtils


TfrxRectArea Constructors

Constructors
Name | Description
Create(Extended,Extended,Extended,Extended) | Overloaded. Initializes a new instance of the TfrxRectArea class.
Create(TfrxComponent) | Overloaded. Initializes a new instance of the TfrxRectArea class.
Top


TfrxRectArea.Create(Extended,Extended,Extended,Extended) Constructor

Summary

Initializes a new instance of the TfrxRectArea class.

Namespace: frxUtils
Syntax
Delphi
public
 constructor Create(Left, Top, Right, Bottom: Extended); overload;

Parameters

Left
Type: Extended

Top
Type: Extended

Right
Type: Extended

Bottom
Type: Extended

See Also

Reference

  • TfrxRectArea
  • frxUtils


TfrxRectArea.Create(TfrxComponent) Constructor

Summary

Initializes a new instance of the TfrxRectArea class.

Namespace: frxUtils
Syntax
Delphi
public
 constructor Create(c: TfrxComponent); overload;

Parameters

c
Type: TfrxComponent

See Also

Reference

  • TfrxRectArea
  • frxUtils


TfrxRectArea Methods

Methods
Name | Description
InterceptsX(TfrxRectArea) | Represents method InterceptsX(TfrxRectArea).
InterceptsY(TfrxRectArea) | Represents method InterceptsY(TfrxRectArea).
InterceptX(TfrxRectArea) | Represents method InterceptX(TfrxRectArea).
InterceptY(TfrxRectArea) | Represents method InterceptY(TfrxRectArea).
Max(Extended,Extended) | Represents method Max(Extended,Extended).
Min(Extended,Extended) | Represents method Min(Extended,Extended).
Top


TfrxRectArea.InterceptsX(TfrxRectArea) Method

Summary

Represents method InterceptsX(TfrxRectArea).

Namespace: frxUtils
Syntax
Delphi
public
 function InterceptsX(a: TfrxRectArea): Boolean;

Parameters

a
Type: TfrxRectArea

Return Value

Type: Boolean

See Also

Reference

  • TfrxRectArea
  • frxUtils


TfrxRectArea.InterceptsY(TfrxRectArea) Method

Summary

Represents method InterceptsY(TfrxRectArea).

Namespace: frxUtils
Syntax
Delphi
public
 function InterceptsY(a: TfrxRectArea): Boolean;

Parameters

a
Type: TfrxRectArea

Return Value

Type: Boolean

See Also

Reference

  • TfrxRectArea
  • frxUtils


TfrxRectArea.InterceptX(TfrxRectArea) Method

Summary

Represents method InterceptX(TfrxRectArea).

Namespace: frxUtils
Syntax
Delphi
public
 function InterceptX(a: TfrxRectArea): TfrxRectArea;

Parameters

a
Type: TfrxRectArea

Return Value

Type: TfrxRectArea

See Also

Reference

  • TfrxRectArea
  • frxUtils


TfrxRectArea.InterceptY(TfrxRectArea) Method

Summary

Represents method InterceptY(TfrxRectArea).

Namespace: frxUtils
Syntax
Delphi
public
 function InterceptY(a: TfrxRectArea): TfrxRectArea;

Parameters

a
Type: TfrxRectArea

Return Value

Type: TfrxRectArea

See Also

Reference

  • TfrxRectArea
  • frxUtils


TfrxRectArea.Max(Extended,Extended) Method

Summary

Represents method Max(Extended,Extended).

Namespace: frxUtils
Syntax
Delphi
public
 function Max(x1, x2: Extended): Extended;

Parameters

x1
Type: Extended

x2
Type: Extended

Return Value

Type: Extended

See Also

Reference

  • TfrxRectArea
  • frxUtils


TfrxRectArea.Min(Extended,Extended) Method

Summary

Represents method Min(Extended,Extended).

Namespace: frxUtils
Syntax
Delphi
public
 function Min(x1, x2: Extended): Extended;

Parameters

x1
Type: Extended

x2
Type: Extended

Return Value

Type: Extended

See Also

Reference

  • TfrxRectArea
  • frxUtils


TfrxRectArea Fields

Fields
Name | Description
X | Represents field X.
X1 | Represents field X1.
Y | Represents field Y.
Y1 | Represents field Y1.
Top


TfrxRectArea.X Field

Summary

Represents field X.

Namespace: frxUtils
Syntax
Delphi
public
 X, Y, X1, Y1: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRectArea
  • frxUtils


TfrxRectArea.X1 Field

Summary

Represents field X1.

Namespace: frxUtils
Syntax
Delphi
public
 X, Y, X1, Y1: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRectArea
  • frxUtils


TfrxRectArea.Y Field

Summary

Represents field Y.

Namespace: frxUtils
Syntax
Delphi
public
 X, Y, X1, Y1: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRectArea
  • frxUtils


TfrxRectArea.Y1 Field

Summary

Represents field Y1.

Namespace: frxUtils
Syntax
Delphi
public
 X, Y, X1, Y1: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxRectArea
  • frxUtils


frxUtils Types

Types
Name | Description
TByteDinArray | Represents an array of the Byte type.
TIntegerDinArray | Represents an array of the Integer type.
TLongWordDinArray | Represents an array of the LongWord type.
TWordDinArray | Represents an array of the Word type.
Top


TByteDinArray Type

Summary

Represents an array of the Byte type.

Namespace: frxUtils
Syntax
Delphi
type
 TByteDinArray = array of Byte;
See Also

Reference

  • frxUtils


TIntegerDinArray Type

Summary

Represents an array of the Integer type.

Namespace: frxUtils
Syntax
Delphi
type
 TIntegerDinArray = array of Integer;
See Also

Reference

  • frxUtils


TLongWordDinArray Type

Summary

Represents an array of the LongWord type.

Namespace: frxUtils
Syntax
Delphi
type
 TLongWordDinArray = array of LongWord;
See Also

Reference

  • frxUtils


TWordDinArray Type

Summary

Represents an array of the Word type.

Namespace: frxUtils
Syntax
Delphi
type
 TWordDinArray = array of Word;
See Also

Reference

  • frxUtils


frxUtils Constants

Constants
Name | Description
PageBGName | Represents constant PageBGName.
Top


PageBGName Constant

Summary

Represents constant PageBGName.

Namespace: frxUtils
Syntax
Delphi
 PageBGName = '_pagebackground';

Value

Type: string

See Also

Reference

  • frxUtils


frxUtils Routines

Routines
Name | Description
ChangeGlyphColor(Integer,TColor) | Represents method ChangeGlyphColor(Integer,TColor).
DisplayPNGInfo(TPNGObject) | Represents method DisplayPNGInfo(TPNGObject).
frFloat2Str(Extended,Integer,Char) | Represents method frFloat2Str(Extended,Integer,Char).
frxAssignImages(TBitmap,Integer,Integer,TImageList,TImageList) | Represents method frxAssignImages(TBitmap,Integer,Integer,TImageList,TImageList).
frxCommonErrorHandler(TfrxReport,String) | Represents method frxCommonErrorHandler(TfrxReport,String).
frxConfirmMsg(String,Integer) | Represents method frxConfirmMsg(String,Integer).
frxCreateTempFile(String) | Represents method frxCreateTempFile(String).
frxDecToBinBytes(Longint) | Represents method frxDecToBinBytes(Longint).
frxDrawArrow(TCanvas,TRect,TColor,Boolean,Boolean) | Represents method frxDrawArrow(TCanvas,TRect,TColor,Boolean,Boolean).
frxDrawArrows(TCanvas,TRect,TColor,Boolean,Boolean,Integer,Integer,Integer,Integer) | Represents method frxDrawArrows(TCanvas,TRect,TColor,Boolean,Boolean,Integer,Integer,Integer,Integer).
frxDrawCheckBox(TCanvas,TRect,TColor,TColor,Boolean) | Represents method frxDrawCheckBox(TCanvas,TRect,TColor,TColor,Boolean).
frxDrawGraphic(TCanvas,TRect,TGraphic,Boolean,Boolean,Boolean,TColor) | Represents method frxDrawGraphic(TCanvas,TRect,TGraphic,Boolean,Boolean,Boolean,TColor).
frxDrawIcon(TCustomImageList,TBitmap,Integer,TColor) | Represents method frxDrawIcon(TCustomImageList,TBitmap,Integer,TColor).
frxDrawTransparent(TCanvas,Integer,Integer,TBitmap) | Represents method frxDrawTransparent(TCanvas,Integer,Integer,TBitmap).
frxErrorMsg(String) | Represents method frxErrorMsg(String).
frxFindComponent(TComponent,String) | Searches for a component on owner by name.
frxFloatDiff(Extended,Extended) | Represents method frxFloatDiff(Extended,Extended).
frxFloatToStr(Extended) | Represents method frxFloatToStr(Extended).
frxGetBrackedVariable(AnsiString,AnsiString,AnsiString,Integer,Integer) | Represents method frxGetBrackedVariable(AnsiString,AnsiString,AnsiString,Integer,Integer).
frxGetBrackedVariableW(WideString,WideString,WideString,Integer,Integer) | Represents method frxGetBrackedVariableW(WideString,WideString,WideString,Integer,Integer).
frxGetComponents(TComponent,TClass,TStrings,TComponent) | Fills list with all found component in application with class type specified in ClassRef parameter.
frxGetFullName(TComponent,TComponent) | Returns full name of the component includes full sequences of owners delimired by '.' sign.
frxHexToString(String) | Represents method frxHexToString(String).
frxInfoMsg(String) | Represents method frxInfoMsg(String).
frxIsValidFloat(string) | Represents method frxIsValidFloat(string).
frxParseDilimitedText(TStrings,String,Char) | Represents method frxParseDilimitedText(TStrings,String,Char).
frxParsePageNumbers(String,TStrings,Integer) | Represents method frxParsePageNumbers(String,TStrings,Integer).
frxPoint(Extended,Extended) | Represents method frxPoint(Extended,Extended).
frxReadCollection(TCollection,TfrxXMLItem,TfrxComponent,TfrxCollection) | Overloaded. Represents method frxReadCollection(TCollection,TfrxXMLItem,TfrxComponent,TfrxCollection).
frxReadCollection(TCollection,TReader,TfrxComponent) | Overloaded. Represents method frxReadCollection(TCollection,TReader,TfrxComponent).
frxReadProperties(TPersistent,TReader,TfrxComponent) | Represents method frxReadProperties(TPersistent,TReader,TfrxComponent).
frxRect(Extended,Extended,Extended,Extended) | Represents method frxRect(Extended,Extended,Extended,Extended).
frxRemoveQuotes(String) | Represents method frxRemoveQuotes(String).
frxReverseString(string) | Represents method frxReverseString(string).
frxSetBkMode(TCanvas,Integer) | Represents method frxSetBkMode(TCanvas,Integer).
frxSetCommaText(String,TStrings,Char) | Represents method frxSetCommaText(String,TStrings,Char).
frxStreamCRC32(TStream) | Represents method frxStreamCRC32(TStream).
frxStreamToString(TStream) | Converts stream bytes to hex string representation.
frxStringToHex(WideString) | Represents method frxStringToHex(WideString).
frxStringToStream(String,TStream) | Converts hex string representation to stream bytes and writes them to stream.
frxStrToFloat(String) | Represents method frxStrToFloat(String).
frxUnixPath2WinPath(string) | Represents method frxUnixPath2WinPath(string).
frxUpdateControl(TWinControl,Boolean) | Represents method frxUpdateControl(TWinControl,Boolean).
frxWriteCollection(TCollection,String,TfrxXMLItem,TfrxComponent,TfrxCollection) | Overloaded. Represents method frxWriteCollection(TCollection,String,TfrxXMLItem,TfrxComponent,TfrxCollection).
frxWriteCollection(TCollection,TWriter,TfrxComponent) | Overloaded. Represents method frxWriteCollection(TCollection,TWriter,TfrxComponent).
frxWriteProperties(TPersistent,TWriter,TfrxComponent) | Represents method frxWriteProperties(TPersistent,TWriter,TfrxComponent).
GetAppFileName | Represents method GetAppFileName.
GetAppPath | Represents method GetAppPath.
GetDisplayScale(THandle,Boolean,Extended,Extended) | Represents method GetDisplayScale(THandle,Boolean,Extended,Extended).
GetStr(string) | Represents method GetStr(string).
GetTempFile | Represents method GetTempFile.
GetTemporaryFolder | Represents method GetTemporaryFolder.
HTMLRGBColor(TColor) | Represents method HTMLRGBColor(TColor).
IfColor(Boolean,TColor,TColor) | Represents method IfColor(Boolean,TColor,TColor).
IfInt(Boolean,integer,integer) | Represents method IfInt(Boolean,integer,integer).
IfReal(Boolean,Extended,Extended) | Represents method IfReal(Boolean,Extended,Extended).
IfStr(Boolean,string,string) | Represents method IfStr(Boolean,string,string).
IsPageBG(TfrxComponent) | Represents method IsPageBG(TfrxComponent).
PNGToPNGA(TPngObject) | Represents method PNGToPNGA(TPngObject).
ScaleBitmap(TBitmap,Integer) | Represents method ScaleBitmap(TBitmap,Integer).
TransparentFillRect(HDC,Integer,Integer,Integer,Integer,TColor) | Represents method TransparentFillRect(HDC,Integer,Integer,Integer,Integer,TColor).
Top


ChangeGlyphColor(Integer,TColor) Method

Summary

Represents method ChangeGlyphColor(Integer,TColor).

Namespace: frxUtils
Syntax
Delphi
procedure ChangeGlyphColor(Index: Integer; Color: TColor);

Parameters

Index
Type: Integer

Color
Type: TColor

See Also

Reference

  • frxUtils


DisplayPNGInfo(TPNGObject) Method

Summary

Represents method DisplayPNGInfo(TPNGObject).

Namespace: frxUtils
Syntax
Delphi
procedure DisplayPNGInfo(const PNG: TPNGObject);

Parameters

PNG
Type: TPNGObject

See Also

Reference

  • frxUtils


frFloat2Str(Extended,Integer,Char) Method

Summary

Represents method frFloat2Str(Extended,Integer,Char).

Namespace: frxUtils
Syntax
Delphi
function frFloat2Str(const Value: Extended; const Prec: Integer = 2; const Sep: Char = '.'): String;

Parameters

Value
Type: Extended

Prec
Type: Integer

Sep
Type: Char

Return Value

Type: String

See Also

Reference

  • frxUtils


frxAssignImages(TBitmap,Integer,Integer,TImageList,TImageList) Method

Summary

Represents method frxAssignImages(TBitmap,Integer,Integer,TImageList,TImageList).

Namespace: frxUtils
Syntax
Delphi
procedure frxAssignImages(Bitmap: TBitmap; dx, dy: Integer;
 ImgList1: TImageList; ImgList2: TImageList = nil);

Parameters

Bitmap
Type: TBitmap

dx
Type: Integer

dy
Type: Integer

ImgList1
Type: TImageList

ImgList2
Type: TImageList

See Also

Reference

  • frxUtils


frxCommonErrorHandler(TfrxReport,String) Method

Summary

Represents method frxCommonErrorHandler(TfrxReport,String).

Namespace: frxUtils
Syntax
Delphi
procedure frxCommonErrorHandler(Report: TfrxReport; const Text: String);

Parameters

Report
Type: TfrxReport

Text
Type: String

See Also

Reference

  • frxUtils


frxConfirmMsg(String,Integer) Method

Summary

Represents method frxConfirmMsg(String,Integer).

Namespace: frxUtils
Syntax
Delphi
function frxConfirmMsg(const Text: String; Buttons: Integer): Integer;

Parameters

Text
Type: String

Buttons
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • frxUtils


frxCreateTempFile(String) Method

Summary

Represents method frxCreateTempFile(String).

Namespace: frxUtils
Syntax
Delphi
function frxCreateTempFile(const TempDir: String): String;

Parameters

TempDir
Type: String

Return Value

Type: String

See Also

Reference

  • frxUtils


frxDecToBinBytes(Longint) Method

Summary

Represents method frxDecToBinBytes(Longint).

Namespace: frxUtils
Syntax
Delphi
function frxDecToBinBytes(d: Longint): string;

Parameters

d
Type: Longint

Return Value

Type: string

See Also

Reference

  • frxUtils


frxDrawArrow(TCanvas,TRect,TColor,Boolean,Boolean) Method

Summary

Represents method frxDrawArrow(TCanvas,TRect,TColor,Boolean,Boolean).

Namespace: frxUtils
Syntax
Delphi
procedure frxDrawArrow(Canvas: TCanvas; aRect: TRect; aColor: TColor; bVertical: Boolean = True; bMirrored: Boolean = False);

Parameters

Canvas
Type: TCanvas

aRect
Type: TRect

aColor
Type: TColor

bVertical
Type: Boolean

bMirrored
Type: Boolean

See Also

Reference

  • frxUtils


frxDrawArrows(TCanvas,TRect,TColor,Boolean,Boolean,Integer,Integer,Integer,Integer) Method

Summary

Represents method frxDrawArrows(TCanvas,TRect,TColor,Boolean,Boolean,Integer,Integer,Integer,Integer).

Namespace: frxUtils
Syntax
Delphi
procedure frxDrawArrows(Canvas: TCanvas; aRect: TRect; aColor: TColor; bVertical: Boolean = True; bMirrored: Boolean = False; LineWidth: Integer = 2; LineGap: Integer = 2; Gap: Integer = 3; Count: Integer = 2);

Parameters

Canvas
Type: TCanvas

aRect
Type: TRect

aColor
Type: TColor

bVertical
Type: Boolean

bMirrored
Type: Boolean

LineWidth
Type: Integer

LineGap
Type: Integer

Gap
Type: Integer

Count
Type: Integer

See Also

Reference

  • frxUtils


frxDrawCheckBox(TCanvas,TRect,TColor,TColor,Boolean) Method

Summary

Represents method frxDrawCheckBox(TCanvas,TRect,TColor,TColor,Boolean).

Namespace: frxUtils
Syntax
Delphi
procedure frxDrawCheckBox(Canvas: TCanvas; ARect: TRect; aCheckColor: TColor; aFrameColor: TColor; bIsChecked: Boolean);

Parameters

Canvas
Type: TCanvas

ARect
Type: TRect

aCheckColor
Type: TColor

aFrameColor
Type: TColor

bIsChecked
Type: Boolean

See Also

Reference

  • frxUtils


frxDrawGraphic(TCanvas,TRect,TGraphic,Boolean,Boolean,Boolean,TColor) Method

Summary

Represents method frxDrawGraphic(TCanvas,TRect,TGraphic,Boolean,Boolean,Boolean,TColor).

Namespace: frxUtils
Syntax
Delphi
procedure frxDrawGraphic(Canvas: TCanvas; DestRect: TRect; aGraph: TGraphic;
 IsPrinting, Smooth, Transparent: Boolean; TransparentColor: TColor);

Parameters

Canvas
Type: TCanvas

DestRect
Type: TRect

aGraph
Type: TGraphic

IsPrinting
Type: Boolean

Smooth
Type: Boolean

Transparent
Type: Boolean

TransparentColor
Type: TColor

See Also

Reference

  • frxUtils


frxDrawIcon(TCustomImageList,TBitmap,Integer,TColor) Method

Summary

Represents method frxDrawIcon(TCustomImageList,TBitmap,Integer,TColor).

Namespace: frxUtils
Syntax
Delphi
procedure frxDrawIcon(ImgList: TCustomImageList; aBitmap: TBitmap; IconIndex: Integer; BgColor: TColor = clNone);

Parameters

ImgList
Type: TCustomImageList

aBitmap
Type: TBitmap

IconIndex
Type: Integer

BgColor
Type: TColor

See Also

Reference

  • frxUtils


frxDrawTransparent(TCanvas,Integer,Integer,TBitmap) Method

Summary

Represents method frxDrawTransparent(TCanvas,Integer,Integer,TBitmap).

Namespace: frxUtils
Syntax
Delphi
procedure frxDrawTransparent(Canvas: TCanvas; x, y: Integer; bmp: TBitmap);

Parameters

Canvas
Type: TCanvas

x
Type: Integer

y
Type: Integer

bmp
Type: TBitmap

See Also

Reference

  • frxUtils


frxErrorMsg(String) Method

Summary

Represents method frxErrorMsg(String).

Namespace: frxUtils
Syntax
Delphi
procedure frxErrorMsg(const Text: String);

Parameters

Text
Type: String

See Also

Reference

  • frxUtils


frxFindComponent(TComponent,String) Method

Summary

Searches for a component on owner by name.

Namespace: frxUtils
Syntax
Delphi
function frxFindComponent(Owner: TComponent; const Name: String): TComponent;

Parameters

Owner
Type: TComponent

Owner component.

Name
Type: String

Name of the searched component.

Return Value

Type: TComponent

See Also

Reference

  • frxUtils


frxFloatDiff(Extended,Extended) Method

Summary

Represents method frxFloatDiff(Extended,Extended).

Namespace: frxUtils
Syntax
Delphi
function frxFloatDiff(const Val1, Val2: Extended): Boolean;

Parameters

Val1
Type: Extended

Val2
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • frxUtils


frxFloatToStr(Extended) Method

Summary

Represents method frxFloatToStr(Extended).

Namespace: frxUtils
Syntax
Delphi
function frxFloatToStr(d: Extended): String;

Parameters

d
Type: Extended

Return Value

Type: String

See Also

Reference

  • frxUtils


frxGetBrackedVariable(AnsiString,AnsiString,AnsiString,Integer,Integer) Method

Summary

Represents method frxGetBrackedVariable(AnsiString,AnsiString,AnsiString,Integer,Integer).

Namespace: frxUtils
Syntax
Delphi
function frxGetBrackedVariable(const Str, OpenBracket, CloseBracket: AnsiString;
 var i, j: Integer): AnsiString;

Parameters

Str
Type: AnsiString

OpenBracket
Type: AnsiString

CloseBracket
Type: AnsiString

i
Type: Integer

j
Type: Integer

Return Value

Type: AnsiString

See Also

Reference

  • frxUtils


frxGetBrackedVariableW(WideString,WideString,WideString,Integer,Integer) Method

Summary

Represents method frxGetBrackedVariableW(WideString,WideString,WideString,Integer,Integer).

Namespace: frxUtils
Syntax
Delphi
function frxGetBrackedVariableW(const Str, OpenBracket, CloseBracket: WideString;
 var i, j: Integer): WideString;

Parameters

Str
Type: WideString

OpenBracket
Type: WideString

CloseBracket
Type: WideString

i
Type: Integer

j
Type: Integer

Return Value

Type: WideString

See Also

Reference

  • frxUtils


frxGetComponents(TComponent,TClass,TStrings,TComponent) Method

Summary

Fills list with all found component in application with class type specified in ClassRef parameter.

Namespace: frxUtils
Syntax
Delphi
procedure frxGetComponents(Owner: TComponent; ClassRef: TClass;
 List: TStrings; Skip: TComponent);

Parameters

Owner
Type: TComponent

Components owner.

ClassRef
Type: TClass

Class reference to search for.

List
Type: TStrings

Out list parameter.

Skip
Type: TComponent

Component to skip.

See Also

Reference

  • frxUtils


frxGetFullName(TComponent,TComponent) Method

Summary

Returns full name of the component includes full sequences of owners delimired by '.' sign.

Namespace: frxUtils
Syntax
Delphi
function frxGetFullName(Owner: TComponent; c: TComponent): String;

Parameters

Owner
Type: TComponent

Owner component.

c
Type: TComponent

Component reference.

Return Value

Type: String

See Also

Reference

  • frxUtils


frxHexToString(String) Method

Summary

Represents method frxHexToString(String).

Namespace: frxUtils
Syntax
Delphi
function frxHexToString(const Buffer: String): WideString;

Parameters

Buffer
Type: String

Return Value

Type: WideString

See Also

Reference

  • frxUtils


frxInfoMsg(String) Method

Summary

Represents method frxInfoMsg(String).

Namespace: frxUtils
Syntax
Delphi
procedure frxInfoMsg(const Text: String);

Parameters

Text
Type: String

See Also

Reference

  • frxUtils


frxIsValidFloat(string) Method

Summary

Represents method frxIsValidFloat(string).

Namespace: frxUtils
Syntax
Delphi
function frxIsValidFloat(const Value: string): Boolean;

Parameters

Value
Type: string

Return Value

Type: Boolean

See Also

Reference

  • frxUtils


frxParseDilimitedText(TStrings,String,Char) Method

Summary

Represents method frxParseDilimitedText(TStrings,String,Char).

Namespace: frxUtils
Syntax
Delphi
procedure frxParseDilimitedText(aList: TStrings; aText: String; aDelimiter: Char);

Parameters

aList
Type: TStrings

aText
Type: String

aDelimiter
Type: Char

See Also

Reference

  • frxUtils


frxParsePageNumbers(String,TStrings,Integer) Method

Summary

Represents method frxParsePageNumbers(String,TStrings,Integer).

Namespace: frxUtils
Syntax
Delphi
procedure frxParsePageNumbers(const PageNumbers: String; List: TStrings;
 Total: Integer);

Parameters

PageNumbers
Type: String

List
Type: TStrings

Total
Type: Integer

See Also

Reference

  • frxUtils


frxPoint(Extended,Extended) Method

Summary

Represents method frxPoint(Extended,Extended).

Namespace: frxUtils
Syntax
Delphi
function frxPoint(X, Y: Extended): TfrxPoint;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: TfrxPoint

See Also

Reference

  • frxUtils


frxReadCollection(TCollection,TfrxXMLItem,TfrxComponent,TfrxCollection) Method

Summary

Represents method frxReadCollection(TCollection,TfrxXMLItem,TfrxComponent,TfrxCollection).

Namespace: frxUtils
Syntax
Delphi
procedure frxReadCollection(Collection: TCollection; Item: TfrxXmlItem; Owner: TfrxComponent; aAncestor: TfrxCollection); overload;

Parameters

Collection
Type: TCollection

Item
Type: TfrxXmlItem

Owner
Type: TfrxComponent

aAncestor
Type: TfrxCollection

See Also

Reference

  • frxUtils


frxReadCollection(TCollection,TReader,TfrxComponent) Method

Summary

Represents method frxReadCollection(TCollection,TReader,TfrxComponent).

Namespace: frxUtils
Syntax
Delphi
procedure frxReadCollection(Collection: TCollection; Reader: TReader; Owner: TfrxComponent); overload;

Parameters

Collection
Type: TCollection

Reader
Type: TReader

Owner
Type: TfrxComponent

See Also

Reference

  • frxUtils


frxReadProperties(TPersistent,TReader,TfrxComponent) Method

Summary

Represents method frxReadProperties(TPersistent,TReader,TfrxComponent).

Namespace: frxUtils
Syntax
Delphi
procedure frxReadProperties(Instance: TPersistent; Reader: TReader; Owner: TfrxComponent);

Parameters

Instance
Type: TPersistent

Reader
Type: TReader

Owner
Type: TfrxComponent

See Also

Reference

  • frxUtils


frxRect(Extended,Extended,Extended,Extended) Method

Summary

Represents method frxRect(Extended,Extended,Extended,Extended).

Namespace: frxUtils
Syntax
Delphi
function frxRect(ALeft, ATop, ARight, ABottom: Extended): TfrxRect;

Parameters

ALeft
Type: Extended

ATop
Type: Extended

ARight
Type: Extended

ABottom
Type: Extended

Return Value

Type: TfrxRect

See Also

Reference

  • frxUtils


frxRemoveQuotes(String) Method

Summary

Represents method frxRemoveQuotes(String).

Namespace: frxUtils
Syntax
Delphi
function frxRemoveQuotes(const s: String): String;

Parameters

s
Type: String

Return Value

Type: String

See Also

Reference

  • frxUtils


frxReverseString(string) Method

Summary

Represents method frxReverseString(string).

Namespace: frxUtils
Syntax
Delphi
function frxReverseString(const AText: string): string;

Parameters

AText
Type: string

Return Value

Type: string

See Also

Reference

  • frxUtils


frxSetBkMode(TCanvas,Integer) Method

Summary

Represents method frxSetBkMode(TCanvas,Integer).

Namespace: frxUtils
Syntax
Delphi
function frxSetBkMode(C: TCanvas; bkMode : Integer): Integer;

Parameters

C
Type: TCanvas

bkMode
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • frxUtils


frxSetCommaText(String,TStrings,Char) Method

Summary

Represents method frxSetCommaText(String,TStrings,Char).

Namespace: frxUtils
Syntax
Delphi
procedure frxSetCommaText(const Text: String; sl: TStrings; Comma: Char = ';');

Parameters

Text
Type: String

sl
Type: TStrings

Comma
Type: Char

See Also

Reference

  • frxUtils


frxStreamCRC32(TStream) Method

Summary

Represents method frxStreamCRC32(TStream).

Namespace: frxUtils
Syntax
Delphi
function frxStreamCRC32(Stream: TStream): Cardinal;

Parameters

Stream
Type: TStream

Return Value

Type: Cardinal

See Also

Reference

  • frxUtils


frxStreamToString(TStream) Method

Summary

Converts stream bytes to hex string representation.

Namespace: frxUtils
Syntax
Delphi
function frxStreamToString(Stream: TStream): String;

Parameters

Stream
Type: TStream

Reference to stream.

Return Value

Type: String

Hex string.

See Also

Reference

  • frxUtils


frxStringToHex(WideString) Method

Summary

Represents method frxStringToHex(WideString).

Namespace: frxUtils
Syntax
Delphi
function frxStringToHex(const Buffer: WideString): String;

Parameters

Buffer
Type: WideString

Return Value

Type: String

See Also

Reference

  • frxUtils


frxStringToStream(String,TStream) Method

Summary

Converts hex string representation to stream bytes and writes them to stream.

Namespace: frxUtils
Syntax
Delphi
procedure frxStringToStream(const s: String; Stream: TStream);

Parameters

s
Type: String

String with hex representation of bytes.

Stream
Type: TStream

Destination stream.

See Also

Reference

  • frxUtils


frxStrToFloat(String) Method

Summary

Represents method frxStrToFloat(String).

Namespace: frxUtils
Syntax
Delphi
function frxStrToFloat(s: String): Extended;

Parameters

s
Type: String

Return Value

Type: Extended

See Also

Reference

  • frxUtils


frxUnixPath2WinPath(string) Method

Summary

Represents method frxUnixPath2WinPath(string).

Namespace: frxUtils
Syntax
Delphi
function frxUnixPath2WinPath(const Path: string): string;

Parameters

Path
Type: string

Return Value

Type: string

See Also

Reference

  • frxUtils


frxUpdateControl(TWinControl,Boolean) Method

Summary

Represents method frxUpdateControl(TWinControl,Boolean).

Namespace: frxUtils
Syntax
Delphi
procedure frxUpdateControl(AControl: TWinControl;
 const ARepaint: Boolean = True);

Parameters

AControl
Type: TWinControl

ARepaint
Type: Boolean

See Also

Reference

  • frxUtils


frxWriteCollection(TCollection,String,TfrxXMLItem,TfrxComponent,TfrxCollection) Method

Summary

Represents method frxWriteCollection(TCollection,String,TfrxXMLItem,TfrxComponent,TfrxCollection).

Namespace: frxUtils
Syntax
Delphi
procedure frxWriteCollection(Collection: TCollection; const Name: String; Item: TfrxXmlItem; Owner: TfrxComponent; aAncestor: TfrxCollection); overload;

Parameters

Collection
Type: TCollection

Name
Type: String

Item
Type: TfrxXmlItem

Owner
Type: TfrxComponent

aAncestor
Type: TfrxCollection

See Also

Reference

  • frxUtils


frxWriteCollection(TCollection,TWriter,TfrxComponent) Method

Summary

Represents method frxWriteCollection(TCollection,TWriter,TfrxComponent).

Namespace: frxUtils
Syntax
Delphi
procedure frxWriteCollection(Collection: TCollection; Writer: TWriter; Owner: TfrxComponent); overload;

Parameters

Collection
Type: TCollection

Writer
Type: TWriter

Owner
Type: TfrxComponent

See Also

Reference

  • frxUtils


frxWriteProperties(TPersistent,TWriter,TfrxComponent) Method

Summary

Represents method frxWriteProperties(TPersistent,TWriter,TfrxComponent).

Namespace: frxUtils
Syntax
Delphi
procedure frxWriteProperties(Instance: TPersistent; Writer: TWriter; Owner: TfrxComponent);

Parameters

Instance
Type: TPersistent

Writer
Type: TWriter

Owner
Type: TfrxComponent

See Also

Reference

  • frxUtils


GetAppFileName Method

Summary

Represents method GetAppFileName.

Namespace: frxUtils
Syntax
Delphi
function GetAppFileName: String;

Return Value

Type: String

See Also

Reference

  • frxUtils


GetAppPath Method

Summary

Represents method GetAppPath.

Namespace: frxUtils
Syntax
Delphi
function GetAppPath: String;

Return Value

Type: String

See Also

Reference

  • frxUtils


GetDisplayScale(THandle,Boolean,Extended,Extended) Method

Summary

Represents method GetDisplayScale(THandle,Boolean,Extended,Extended).

Namespace: frxUtils
Syntax
Delphi
procedure GetDisplayScale(DevHandle: THandle; IsPrinterHandle: Boolean; var aScaleX, aScaleY: Extended);

Parameters

DevHandle
Type: THandle

IsPrinterHandle
Type: Boolean

aScaleX
Type: Extended

aScaleY
Type: Extended

See Also

Reference

  • frxUtils


GetStr(string) Method

Summary

Represents method GetStr(string).

Namespace: frxUtils
Syntax
Delphi
function GetStr(const Id: string): string;

Parameters

Id
Type: string

Return Value

Type: string

See Also

Reference

  • frxUtils


GetTempFile Method

Summary

Represents method GetTempFile.

Namespace: frxUtils
Syntax
Delphi
function GetTempFile: String;

Return Value

Type: String

See Also

Reference

  • frxUtils


GetTemporaryFolder Method

Summary

Represents method GetTemporaryFolder.

Namespace: frxUtils
Syntax
Delphi
function GetTemporaryFolder: String;

Return Value

Type: String

See Also

Reference

  • frxUtils


HTMLRGBColor(TColor) Method

Summary

Represents method HTMLRGBColor(TColor).

Namespace: frxUtils
Syntax
Delphi
function HTMLRGBColor(Color: TColor): string;

Parameters

Color
Type: TColor

Return Value

Type: string

See Also

Reference

  • frxUtils


IfColor(Boolean,TColor,TColor) Method

Summary

Represents method IfColor(Boolean,TColor,TColor).

Namespace: frxUtils
Syntax
Delphi
function IfColor(Flag: Boolean; const cTrue: TColor; cFalse: TColor = clNone): TColor;

Parameters

Flag
Type: Boolean

cTrue
Type: TColor

cFalse
Type: TColor

Return Value

Type: TColor

See Also

Reference

  • frxUtils


IfInt(Boolean,integer,integer) Method

Summary

Represents method IfInt(Boolean,integer,integer).

Namespace: frxUtils
Syntax
Delphi
function IfInt(Flag: Boolean; const iTrue: integer; iFalse: integer = 0): integer;

Parameters

Flag
Type: Boolean

iTrue
Type: integer

iFalse
Type: integer

Return Value

Type: integer

See Also

Reference

  • frxUtils


IfReal(Boolean,Extended,Extended) Method

Summary

Represents method IfReal(Boolean,Extended,Extended).

Namespace: frxUtils
Syntax
Delphi
function IfReal(Flag: Boolean; const rTrue: Extended; rFalse: Extended = 0.0): Extended;

Parameters

Flag
Type: Boolean

rTrue
Type: Extended

rFalse
Type: Extended

Return Value

Type: Extended

See Also

Reference

  • frxUtils


IfStr(Boolean,string,string) Method

Summary

Represents method IfStr(Boolean,string,string).

Namespace: frxUtils
Syntax
Delphi
function IfStr(Flag: Boolean; const sTrue: string; sFalse: string = ''): string;

Parameters

Flag
Type: Boolean

sTrue
Type: string

sFalse
Type: string

Return Value

Type: string

See Also

Reference

  • frxUtils


IsPageBG(TfrxComponent) Method

Summary

Represents method IsPageBG(TfrxComponent).

Namespace: frxUtils
Syntax
Delphi
function IsPageBG(Obj: TfrxComponent): Boolean;

Parameters

Obj
Type: TfrxComponent

Return Value

Type: Boolean

See Also

Reference

  • frxUtils


PNGToPNGA(TPngObject) Method

Summary

Represents method PNGToPNGA(TPngObject).

Namespace: frxUtils
Syntax
Delphi
function PNGToPNGA(PNG: TPngObject): TPngObject;

Parameters

PNG
Type: TPngObject

Return Value

Type: TPngObject

See Also

Reference

  • frxUtils


ScaleBitmap(TBitmap,Integer) Method

Summary

Represents method ScaleBitmap(TBitmap,Integer).

Namespace: frxUtils
Syntax
Delphi
procedure ScaleBitmap(aBitmap: TBitmap; aScreenPPI: Integer);

Parameters

aBitmap
Type: TBitmap

aScreenPPI
Type: Integer

See Also

Reference

  • frxUtils


TransparentFillRect(HDC,Integer,Integer,Integer,Integer,TColor) Method

Summary

Represents method TransparentFillRect(HDC,Integer,Integer,Integer,Integer,TColor).

Namespace: frxUtils
Syntax
Delphi
procedure TransparentFillRect(aDC: HDC; Left, Top, Right, Bottom: Integer;
 Color: TColor);

Parameters

aDC
Type: HDC

Left
Type: Integer

Top
Type: Integer

Right
Type: Integer

Bottom
Type: Integer

Color
Type: TColor

See Also

Reference

  • frxUtils


frxVariables Namespace

Summary

Represents namespace frxVariables.

Classes
Name | Description
TfrxArray | Represents type TfrxArray.
TfrxVariable | The TfrxVariable class represents a variable.
TfrxVariables | The TfrxVariables class represents a list of variables. It contains all methods necessary for working with the list. TfrxReport.Variables property contains a link to the instance of this class.
Top


frxVariables Classes

Classes
Name | Description
TfrxArray | Represents type TfrxArray.
TfrxVariable | The TfrxVariable class represents a variable.
TfrxVariables | The TfrxVariables class represents a list of variables. It contains all methods necessary for working with the list. TfrxReport.Variables property contains a link to the instance of this class.
Top


TfrxArray Class

Summary

Represents type TfrxArray.

Namespace: frxVariables
Inheritance Hierarchy
TCollection
frxVariables.TfrxArray
Syntax
Delphi
type
 TfrxArray = class(TCollection)
 end;

The TfrxArray type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxArray class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Variables[Variant] | Represents property Variables[Variant].
Top
Methods
Show:
Name | Description
GetItems(Integer) | Represents method GetItems(Integer).
GetVariable(Variant) | Represents method GetVariable(Variant).
IndexOf(Variant) | Represents method IndexOf(Variant).
SetVariable(Variant,Variant) | Represents method SetVariable(Variant,Variant).
Top
See Also

Reference

  • frxVariables


TfrxArray Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxArray class.
Top


TfrxArray.Create Constructor

Summary

Initializes a new instance of the TfrxArray class.

Namespace: frxVariables
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxArray
  • frxVariables


TfrxArray Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Variables[Variant] | Represents property Variables[Variant].
Top


TfrxArray.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxVariables
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxVariable read GetItems;

Parameters

Index
Type: Integer

Property Value

Type: TfrxVariable

See Also

Reference

  • TfrxArray
  • frxVariables


TfrxArray.Variables[Variant] Property

Summary

Represents property Variables[Variant].

Namespace: frxVariables
Syntax
Delphi
public
 property Variables[Index: Variant]: Variant read GetVariable
 write SetVariable; default;

Parameters

Index
Type: Variant

Property Value

Type: Variant

See Also

Reference

  • TfrxArray
  • frxVariables


TfrxArray Methods

Methods
Name | Description
GetItems(Integer) | Represents method GetItems(Integer).
GetVariable(Variant) | Represents method GetVariable(Variant).
IndexOf(Variant) | Represents method IndexOf(Variant).
SetVariable(Variant,Variant) | Represents method SetVariable(Variant,Variant).
Top


TfrxArray.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxVariables
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxVariable;

Parameters

Index
Type: Integer

Return Value

Type: TfrxVariable

See Also

Reference

  • TfrxArray
  • frxVariables


TfrxArray.GetVariable(Variant) Method

Summary

Represents method GetVariable(Variant).

Namespace: frxVariables
Syntax
Delphi
private
 function GetVariable(Index: Variant): Variant;

Parameters

Index
Type: Variant

Return Value

Type: Variant

See Also

Reference

  • TfrxArray
  • frxVariables


TfrxArray.IndexOf(Variant) Method

Summary

Represents method IndexOf(Variant).

Namespace: frxVariables
Syntax
Delphi
public
 function IndexOf(const Name: Variant): Integer;

Parameters

Name
Type: Variant

Return Value

Type: Integer

See Also

Reference

  • TfrxArray
  • frxVariables


TfrxArray.SetVariable(Variant,Variant) Method

Summary

Represents method SetVariable(Variant,Variant).

Namespace: frxVariables
Syntax
Delphi
private
 procedure SetVariable(Index: Variant; const Value: Variant);

Parameters

Index
Type: Variant

Value
Type: Variant

See Also

Reference

  • TfrxArray
  • frxVariables


TfrxVariable Class

Summary

The TfrxVariable class represents a variable.

Namespace: frxVariables
Inheritance Hierarchy
TCollectionItem
frxCollections.TfrxCollectionItem
frxVariables.TfrxVariable
Syntax
Delphi
type
 TfrxVariable = class(TfrxCollectionItem)
 end;

The TfrxVariable type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxVariable class. (Overrides TfrxCollectionItem.Create(TCollection).)
Top
Properties
Show:
Name | Description
InheritedName | Represents property InheritedName. (Inherited from TfrxCollectionItem.)
IsInherited | Represents property IsInherited. (Inherited from TfrxCollectionItem.)
Name | Name of a variable. must be unique.
UniqueIndex | Represents property UniqueIndex. (Inherited from TfrxCollectionItem.)
Value | Value of a variable.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
CreateUniqueIName(TCollection) | Represents method CreateUniqueIName(TCollection). (Inherited from TfrxCollectionItem.)
GetInheritedName | Represents method GetInheritedName. (Overrides TfrxCollectionItem.GetInheritedName.)
IsUniqueNameStored | Represents method IsUniqueNameStored. (Overrides TfrxCollectionItem.IsUniqueNameStored.)
SetInheritedName(String) | Represents method SetInheritedName(String). (Inherited from TfrxCollectionItem.)
Top
Fields
Show:
Name | Description
FIsInherited | Represents field FIsInherited. (Inherited from TfrxCollectionItem.)
FName | Represents field FName.
FUniqueIndex | Represents field FUniqueIndex. (Inherited from TfrxCollectionItem.)
FValue | Represents field FValue.
Top
See Also

Reference

  • frxVariables


TfrxVariable Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxVariable class. (Overrides TfrxCollectionItem.Create(TCollection).)
Top


TfrxVariable.Create(TCollection) Constructor

Summary

Initializes a new instance of the TfrxVariable class.

Namespace: frxVariables
Syntax
Delphi
public
 constructor Create(ACollection: TCollection); override;

Parameters

ACollection
Type: TCollection

Overrides

TfrxCollectionItem.Create(TCollection)
See Also

Reference

  • TfrxVariable
  • frxVariables


TfrxVariable Properties

Properties
Name | Description
Name | Name of a variable. must be unique.
Value | Value of a variable.
Top


TfrxVariable.Name Property

Summary

Name of a variable. must be unique.

Namespace: frxVariables
Syntax
Delphi
published
 property Name: String read FName write FName;

Property Value

Type: String

See Also

Reference

  • TfrxVariable
  • frxVariables


TfrxVariable.Value Property

Summary

Value of a variable.

Namespace: frxVariables
Syntax
Delphi
published
 property Value: Variant read FValue write FValue;

Property Value

Type: Variant

See Also

Reference

  • TfrxVariable
  • frxVariables


TfrxVariable Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
GetInheritedName | Represents method GetInheritedName. (Overrides TfrxCollectionItem.GetInheritedName.)
IsUniqueNameStored | Represents method IsUniqueNameStored. (Overrides TfrxCollectionItem.IsUniqueNameStored.)
Top


TfrxVariable.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxVariables
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxVariable
  • frxVariables


TfrxVariable.GetInheritedName Method

Summary

Represents method GetInheritedName.

Namespace: frxVariables
Syntax
Delphi
protected
 function GetInheritedName: String; override;

Return Value

Type: String

Overrides

TfrxCollectionItem.GetInheritedName
See Also

Reference

  • TfrxVariable
  • frxVariables


TfrxVariable.IsUniqueNameStored Method

Summary

Represents method IsUniqueNameStored.

Namespace: frxVariables
Syntax
Delphi
public
 function IsUniqueNameStored: Boolean; override;

Return Value

Type: Boolean

Overrides

TfrxCollectionItem.IsUniqueNameStored
See Also

Reference

  • TfrxVariable
  • frxVariables


TfrxVariable Fields

Fields
Name | Description
FName | Represents field FName.
FValue | Represents field FValue.
Top


TfrxVariable.FName Field

Summary

Represents field FName.

Namespace: frxVariables
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxVariable
  • frxVariables


TfrxVariable.FValue Field

Summary

Represents field FValue.

Namespace: frxVariables
Syntax
Delphi
private
 FValue: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxVariable
  • frxVariables


TfrxVariables Class

Summary

The TfrxVariables class represents a list of variables. It contains all methods necessary for working with the list. TfrxReport.Variables property contains a link to the instance of this class.

Namespace: frxVariables
Inheritance Hierarchy
TCollection
frxCollections.TfrxCollection
frxVariables.TfrxVariables
Syntax
Delphi
type
 TfrxVariables = class(TfrxCollection)
 end;

The TfrxVariables type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxVariables class.
Top
Properties
Show:
Name | Description
Items[Integer] | The list of variables.
Variables[String] | Values of variables.
Top
Methods
Show:
Name | Description
Add | Adds a variable to the end of the list.
AddVariable(String,String,Variant) | Adds a variable to the specified category.
DeleteCategory(String) | Deletes a category and all its variables.
DeleteVariable(String) | Deletes a variable.
DeserializeProperties(String,TObject,TfrxCollection) | Represents method DeserializeProperties(String,TObject,TfrxCollection). (Inherited from TfrxCollection.)
FindByName(String) | Represents method FindByName(String). (Inherited from TfrxCollection.)
GetCategoriesList(TStrings,Boolean) | Returns the list of categories.
GetItems(Integer) | Represents method GetItems(Integer).
GetVariable(String) | Represents method GetVariable(String).
GetVariablesList(String,TStrings) | Returns the list of variables in the specified category.
IndexOf(String) | Returns the index of a variable with the given name.
Insert(Integer) | Adds a variable to the given position of the list.
LoadFromFile(String) | Loads the list of variables from file.
LoadFromStream(TStream) | Loads the list of variables from stream.
LoadFromXMLItem(TfrxXMLItem,Boolean) | Loads the list of variables from XML node.
SaveToFile(String) | Saves the list of variables to file.
SaveToStream(TStream) | Saves the list of variables to stream.
SaveToXMLItem(TfrxXMLItem) | Saves the list of variables to XML node.
SerializeProperties(TObject,TfrxCollection,TComponent) | Represents method SerializeProperties(TObject,TfrxCollection,TComponent). (Inherited from TfrxCollection.)
SetVariable(String,Variant) | Represents method SetVariable(String,Variant).
Top
See Also

Reference

  • frxVariables


TfrxVariables Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxVariables class.
Top


TfrxVariables.Create Constructor

Summary

Initializes a new instance of the TfrxVariables class.

Namespace: frxVariables
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables Properties

Properties
Name | Description
Items[Integer] | The list of variables.
Variables[String] | Values of variables.
Top


TfrxVariables.Items[Integer] Property

Summary

The list of variables.

Namespace: frxVariables
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxVariable read GetItems;

Parameters

Index
Type: Integer

Property Value

Type: TfrxVariable

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.Variables[String] Property

Summary

Values of variables.

Namespace: frxVariables
Syntax
Delphi
public
 property Variables[Index: String]: Variant read GetVariable
 write SetVariable; default;

Parameters

Index
Type: String

Property Value

Type: Variant

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables Methods

Methods
Name | Description
Add | Adds a variable to the end of the list.
AddVariable(String,String,Variant) | Adds a variable to the specified category.
DeleteCategory(String) | Deletes a category and all its variables.
DeleteVariable(String) | Deletes a variable.
GetCategoriesList(TStrings,Boolean) | Returns the list of categories.
GetItems(Integer) | Represents method GetItems(Integer).
GetVariable(String) | Represents method GetVariable(String).
GetVariablesList(String,TStrings) | Returns the list of variables in the specified category.
IndexOf(String) | Returns the index of a variable with the given name.
Insert(Integer) | Adds a variable to the given position of the list.
LoadFromFile(String) | Loads the list of variables from file.
LoadFromStream(TStream) | Loads the list of variables from stream.
LoadFromXMLItem(TfrxXMLItem,Boolean) | Loads the list of variables from XML node.
SaveToFile(String) | Saves the list of variables to file.
SaveToStream(TStream) | Saves the list of variables to stream.
SaveToXMLItem(TfrxXMLItem) | Saves the list of variables to XML node.
SetVariable(String,Variant) | Represents method SetVariable(String,Variant).
Top


TfrxVariables.Add Method

Summary

Adds a variable to the end of the list.

Namespace: frxVariables
Syntax
Delphi
public
 function Add: TfrxVariable;

Return Value

Type: TfrxVariable

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.AddVariable(String,String,Variant) Method

Summary

Adds a variable to the specified category.

Namespace: frxVariables
Syntax
Delphi
public
 procedure AddVariable(const ACategory, AName: String; const AValue: Variant);

Parameters

ACategory
Type: String

AName
Type: String

AValue
Type: Variant

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.DeleteCategory(String) Method

Summary

Deletes a category and all its variables.

Namespace: frxVariables
Syntax
Delphi
public
 procedure DeleteCategory(const Name: String);

Parameters

Name
Type: String

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.DeleteVariable(String) Method

Summary

Deletes a variable.

Namespace: frxVariables
Syntax
Delphi
public
 procedure DeleteVariable(const Name: String);

Parameters

Name
Type: String

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.GetCategoriesList(TStrings,Boolean) Method

Summary

Returns the list of categories.

Namespace: frxVariables
Syntax
Delphi
public
 procedure GetCategoriesList(List: TStrings; ClearList: Boolean = True);

Parameters

List
Type: TStrings

ClearList
Type: Boolean

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxVariables
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxVariable;

Parameters

Index
Type: Integer

Return Value

Type: TfrxVariable

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.GetVariable(String) Method

Summary

Represents method GetVariable(String).

Namespace: frxVariables
Syntax
Delphi
private
 function GetVariable(Index: String): Variant;

Parameters

Index
Type: String

Return Value

Type: Variant

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.GetVariablesList(String,TStrings) Method

Summary

Returns the list of variables in the specified category.

Namespace: frxVariables
Syntax
Delphi
public
 procedure GetVariablesList(const Category: String; List: TStrings);

Parameters

Category
Type: String

List
Type: TStrings

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.IndexOf(String) Method

Summary

Returns the index of a variable with the given name.

Namespace: frxVariables
Syntax
Delphi
public
 function IndexOf(const Name: String): Integer;

Parameters

Name
Type: String

Return Value

Type: Integer

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.Insert(Integer) Method

Summary

Adds a variable to the given position of the list.

Namespace: frxVariables
Syntax
Delphi
public
 function Insert(Index: Integer): TfrxVariable;

Parameters

Index
Type: Integer

Return Value

Type: TfrxVariable

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.LoadFromFile(String) Method

Summary

Loads the list of variables from file.

Namespace: frxVariables
Syntax
Delphi
public
 procedure LoadFromFile(const FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.LoadFromStream(TStream) Method

Summary

Loads the list of variables from stream.

Namespace: frxVariables
Syntax
Delphi
public
 procedure LoadFromStream(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.LoadFromXMLItem(TfrxXMLItem,Boolean) Method

Summary

Loads the list of variables from XML node.

Namespace: frxVariables
Syntax
Delphi
public
 procedure LoadFromXMLItem(Item: TfrxXMLItem; OldXMLFormat: Boolean = True);

Parameters

Item
Type: TfrxXMLItem

OldXMLFormat
Type: Boolean

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.SaveToFile(String) Method

Summary

Saves the list of variables to file.

Namespace: frxVariables
Syntax
Delphi
public
 procedure SaveToFile(const FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.SaveToStream(TStream) Method

Summary

Saves the list of variables to stream.

Namespace: frxVariables
Syntax
Delphi
public
 procedure SaveToStream(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.SaveToXMLItem(TfrxXMLItem) Method

Summary

Saves the list of variables to XML node.

Namespace: frxVariables
Syntax
Delphi
public
 procedure SaveToXMLItem(Item: TfrxXMLItem);

Parameters

Item
Type: TfrxXMLItem

See Also

Reference

  • TfrxVariables
  • frxVariables


TfrxVariables.SetVariable(String,Variant) Method

Summary

Represents method SetVariable(String,Variant).

Namespace: frxVariables
Syntax
Delphi
private
 procedure SetVariable(Index: String; const Value: Variant);

Parameters

Index
Type: String

Value
Type: Variant

See Also

Reference

  • TfrxVariables
  • frxVariables


frxVectorCanvas Namespace

Summary

Represents namespace frxVectorCanvas.

Classes
Name | Description
TVectorCanvas | Represents type TVectorCanvas.
TVector_ExtTextOut | Represents type TVector_ExtTextOut.
TVector_ExtTextOutA | Represents type TVector_ExtTextOutA.
TVector_ExtTextOutW | Represents type TVector_ExtTextOutW.
Top
Types
Name | Description
TCharacterDistance | Represents an array of the Integer type.
Top


frxVectorCanvas Classes

Classes
Name | Description
TVectorCanvas | Represents type TVectorCanvas.
TVector_ExtTextOut | Represents type TVector_ExtTextOut.
TVector_ExtTextOutA | Represents type TVector_ExtTextOutA.
TVector_ExtTextOutW | Represents type TVector_ExtTextOutW.
Top


TVectorCanvas Class

Summary

Represents type TVectorCanvas.

Namespace: frxVectorCanvas
Inheritance Hierarchy
TObjectList
frxVectorCanvas.TVectorCanvas
Syntax
Delphi
type
 TVectorCanvas = class(TObjectList)
 end;

The TVectorCanvas type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TVectorCanvas class.
Top
Methods
Show:
Name | Description
ExtTextOutA(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger) | Represents method ExtTextOutA(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger).
ExtTextOutW(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger) | Represents method ExtTextOutW(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger).
Top
See Also

Reference

  • frxVectorCanvas


TVectorCanvas Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TVectorCanvas class.
Top


TVectorCanvas.Create Constructor

Summary

Initializes a new instance of the TVectorCanvas class.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TVectorCanvas
  • frxVectorCanvas


TVectorCanvas Methods

Methods
Name | Description
ExtTextOutA(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger) | Represents method ExtTextOutA(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger).
ExtTextOutW(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger) | Represents method ExtTextOutW(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger).
Top


TVectorCanvas.ExtTextOutA(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger) Method

Summary

Represents method ExtTextOutA(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger).

Namespace: frxVectorCanvas
Syntax
Delphi
public
 procedure ExtTextOutA(X, Y: Integer; Options: Longint; Rect: PRect;
 Str: Pointer ; aCount: Longint; Dx: PInteger);

Parameters

X
Type: Integer

Y
Type: Integer

Options
Type: Longint

Rect
Type: PRect

Str
Type: Pointer

aCount
Type: Longint

Dx
Type: PInteger

See Also

Reference

  • TVectorCanvas
  • frxVectorCanvas


TVectorCanvas.ExtTextOutW(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger) Method

Summary

Represents method ExtTextOutW(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger).

Namespace: frxVectorCanvas
Syntax
Delphi
public
 procedure ExtTextOutW(X, Y: Integer; Options: Longint; Rect: PRect;
 Str: Pointer ; aCount: Longint; Dx: PInteger);

Parameters

X
Type: Integer

Y
Type: Integer

Options
Type: Longint

Rect
Type: PRect

Str
Type: Pointer

aCount
Type: Longint

Dx
Type: PInteger

See Also

Reference

  • TVectorCanvas
  • frxVectorCanvas


TVector_ExtTextOut Class

Summary

Represents type TVector_ExtTextOut.

Namespace: frxVectorCanvas
Inheritance Hierarchy
TObject
frxVectorCanvas.TVector_ExtTextOut
frxVectorCanvas.TVector_ExtTextOutA
frxVectorCanvas.TVector_ExtTextOutW
Syntax
Delphi
type
 TVector_ExtTextOut = class
 end;

The TVector_ExtTextOut type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer,Integer,Longint,PRect,Longint,PInteger) | Initializes a new instance of the TVector_ExtTextOut class.
Destroy | Represents the destructor of the TVector_ExtTextOut class.
Top
Properties
Show:
Name | Description
Dx | Represents property Dx.
Options | Represents property Options.
Rect | Represents property Rect.
Str | Represents property Str.
X | Represents property X.
Y | Represents property Y.
Top
Methods
Show:
Name | Description
AsString | Represents method AsString.
TextLength | Represents method TextLength.
Top
Fields
Show:
Name | Description
FDx | Represents field FDx.
FOptions | Represents field FOptions.
FRect | Represents field FRect.
FStr | Represents field FStr.
FX | Represents field FX.
FY | Represents field FY.
Top
See Also

Reference

  • frxVectorCanvas


TVector_ExtTextOut Constructors

Constructors
Name | Description
Create(Integer,Integer,Longint,PRect,Longint,PInteger) | Initializes a new instance of the TVector_ExtTextOut class.
Destroy | Represents the destructor of the TVector_ExtTextOut class.
Top


TVector_ExtTextOut.Create(Integer,Integer,Longint,PRect,Longint,PInteger) Constructor

Summary

Initializes a new instance of the TVector_ExtTextOut class.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 constructor Create(AX, AY: Integer; AOptions: Longint; ARect: PRect;
 ACount: Longint; ADx: PInteger);

Parameters

AX
Type: Integer

AY
Type: Integer

AOptions
Type: Longint

ARect
Type: PRect

ACount
Type: Longint

ADx
Type: PInteger

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut.Destroy Destructor

Summary

Represents the destructor of the TVector_ExtTextOut class.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut Properties

Properties
Name | Description
Dx | Represents property Dx.
Options | Represents property Options.
Rect | Represents property Rect.
Str | Represents property Str.
X | Represents property X.
Y | Represents property Y.
Top


TVector_ExtTextOut.Dx Property

Summary

Represents property Dx.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 property Dx: TCharacterDistance read FDx;

Property Value

Type: TCharacterDistance

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut.Options Property

Summary

Represents property Options.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 property Options: Longint read FOptions;

Property Value

Type: Longint

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut.Rect Property

Summary

Represents property Rect.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 property Rect: TRect read FRect;

Property Value

Type: TRect

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut.Str Property

Summary

Represents property Str.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 property Str: WideString read FStr;

Property Value

Type: WideString

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut.X Property

Summary

Represents property X.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 property X: Integer read FX;

Property Value

Type: Integer

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut.Y Property

Summary

Represents property Y.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 property Y: Integer read FY;

Property Value

Type: Integer

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut Methods

Methods
Name | Description
AsString | Represents method AsString.
TextLength | Represents method TextLength.
Top


TVector_ExtTextOut.AsString Method

Summary

Represents method AsString.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 function AsString: String;

Return Value

Type: String

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut.TextLength Method

Summary

Represents method TextLength.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 function TextLength: Integer;

Return Value

Type: Integer

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut Fields

Fields
Name | Description
FDx | Represents field FDx.
FOptions | Represents field FOptions.
FRect | Represents field FRect.
FStr | Represents field FStr.
FX | Represents field FX.
FY | Represents field FY.
Top


TVector_ExtTextOut.FDx Field

Summary

Represents field FDx.

Namespace: frxVectorCanvas
Syntax
Delphi
private
 FDx: TCharacterDistance;

Field Value

Type: TCharacterDistance

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut.FOptions Field

Summary

Represents field FOptions.

Namespace: frxVectorCanvas
Syntax
Delphi
private
 FOptions: Longint;

Field Value

Type: Longint

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut.FRect Field

Summary

Represents field FRect.

Namespace: frxVectorCanvas
Syntax
Delphi
private
 FRect: TRect;

Field Value

Type: TRect

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut.FStr Field

Summary

Represents field FStr.

Namespace: frxVectorCanvas
Syntax
Delphi
private
 FStr: WideString;

Field Value

Type: WideString

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut.FX Field

Summary

Represents field FX.

Namespace: frxVectorCanvas
Syntax
Delphi
private
 FX: Integer;

Field Value

Type: Integer

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOut.FY Field

Summary

Represents field FY.

Namespace: frxVectorCanvas
Syntax
Delphi
private
 FY: Integer;

Field Value

Type: Integer

See Also

Reference

  • TVector_ExtTextOut
  • frxVectorCanvas


TVector_ExtTextOutA Class

Summary

Represents type TVector_ExtTextOutA.

Namespace: frxVectorCanvas
Inheritance Hierarchy
TObject
frxVectorCanvas.TVector_ExtTextOut
frxVectorCanvas.TVector_ExtTextOutA
Syntax
Delphi
type
 TVector_ExtTextOutA = class (TVector_ExtTextOut)
 end;

The TVector_ExtTextOutA type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger) | Initializes a new instance of the TVector_ExtTextOutA class.
Top
Properties
Show:
Name | Description
Dx | Represents property Dx. (Inherited from TVector_ExtTextOut.)
Options | Represents property Options. (Inherited from TVector_ExtTextOut.)
Rect | Represents property Rect. (Inherited from TVector_ExtTextOut.)
Str | Represents property Str. (Inherited from TVector_ExtTextOut.)
X | Represents property X. (Inherited from TVector_ExtTextOut.)
Y | Represents property Y. (Inherited from TVector_ExtTextOut.)
Top
Methods
Show:
Name | Description
AsString | Represents method AsString. (Inherited from TVector_ExtTextOut.)
TextLength | Represents method TextLength. (Inherited from TVector_ExtTextOut.)
Top
See Also

Reference

  • frxVectorCanvas


TVector_ExtTextOutA Constructors

Constructors
Name | Description
Create(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger) | Initializes a new instance of the TVector_ExtTextOutA class.
Top


TVector_ExtTextOutA.Create(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger) Constructor

Summary

Initializes a new instance of the TVector_ExtTextOutA class.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 constructor Create(AX, AY: Integer; AOptions: Longint; ARect: PRect;
 AStr: Pointer ; ACount: Longint; ADx: PInteger);

Parameters

AX
Type: Integer

AY
Type: Integer

AOptions
Type: Longint

ARect
Type: PRect

AStr
Type: Pointer

ACount
Type: Longint

ADx
Type: PInteger

See Also

Reference

  • TVector_ExtTextOutA
  • frxVectorCanvas


TVector_ExtTextOutW Class

Summary

Represents type TVector_ExtTextOutW.

Namespace: frxVectorCanvas
Inheritance Hierarchy
TObject
frxVectorCanvas.TVector_ExtTextOut
frxVectorCanvas.TVector_ExtTextOutW
Syntax
Delphi
type
 TVector_ExtTextOutW = class (TVector_ExtTextOut)
 end;

The TVector_ExtTextOutW type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger) | Initializes a new instance of the TVector_ExtTextOutW class.
Top
Properties
Show:
Name | Description
Dx | Represents property Dx. (Inherited from TVector_ExtTextOut.)
Options | Represents property Options. (Inherited from TVector_ExtTextOut.)
Rect | Represents property Rect. (Inherited from TVector_ExtTextOut.)
Str | Represents property Str. (Inherited from TVector_ExtTextOut.)
X | Represents property X. (Inherited from TVector_ExtTextOut.)
Y | Represents property Y. (Inherited from TVector_ExtTextOut.)
Top
Methods
Show:
Name | Description
AsString | Represents method AsString. (Inherited from TVector_ExtTextOut.)
TextLength | Represents method TextLength. (Inherited from TVector_ExtTextOut.)
Top
See Also

Reference

  • frxVectorCanvas


TVector_ExtTextOutW Constructors

Constructors
Name | Description
Create(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger) | Initializes a new instance of the TVector_ExtTextOutW class.
Top


TVector_ExtTextOutW.Create(Integer,Integer,Longint,PRect,Pointer,Longint,PInteger) Constructor

Summary

Initializes a new instance of the TVector_ExtTextOutW class.

Namespace: frxVectorCanvas
Syntax
Delphi
public
 constructor Create(AX, AY: Integer; AOptions: Longint; ARect: PRect;
 AStr: Pointer ; ACount: Longint; ADx: PInteger);

Parameters

AX
Type: Integer

AY
Type: Integer

AOptions
Type: Longint

ARect
Type: PRect

AStr
Type: Pointer

ACount
Type: Longint

ADx
Type: PInteger

See Also

Reference

  • TVector_ExtTextOutW
  • frxVectorCanvas


frxVectorCanvas Types

Types
Name | Description
TCharacterDistance | Represents an array of the Integer type.
Top


TCharacterDistance Type

Summary

Represents an array of the Integer type.

Namespace: frxVectorCanvas
Syntax
Delphi
type
 TCharacterDistance = array of Integer;
See Also

Reference

  • frxVectorCanvas


frxXML Namespace

Summary

Represents namespace frxXML.

Classes
Name | Description
TfrxInvalidXMLException | Represents type TfrxInvalidXMLException.
TfrxXMLDocument | Represents type TfrxXMLDocument.
TfrxXMLItem | Represents type TfrxXMLItem.
TfrxXMLReader | Represents type TfrxXMLReader.
TfrxXMLWriter | Represents type TfrxXMLWriter.
Top
Routines
Name | Description
frxStrToXML(String) | Represents method frxStrToXML(String).
frxValueToXML(Variant) | Represents method frxValueToXML(Variant).
frxXMLToStr(String) | Represents method frxXMLToStr(String).
Top


frxXML Classes

Classes
Name | Description
TfrxInvalidXMLException | Represents type TfrxInvalidXMLException.
TfrxXMLDocument | Represents type TfrxXMLDocument.
TfrxXMLItem | Represents type TfrxXMLItem.
TfrxXMLReader | Represents type TfrxXMLReader.
TfrxXMLWriter | Represents type TfrxXMLWriter.
Top


TfrxInvalidXMLException Class

Summary

Represents type TfrxInvalidXMLException.

Namespace: frxXML
Inheritance Hierarchy
Exception
frxXML.TfrxInvalidXMLException
Syntax
Delphi
type
 TfrxInvalidXMLException = class(Exception);
See Also

Reference

  • frxXML


TfrxXMLDocument Class

Summary

Represents type TfrxXMLDocument.

Namespace: frxXML
Inheritance Hierarchy
TObject
frxXML.TfrxXMLDocument
frxMapHelpers.TfrxMapXMLDocument
Syntax
Delphi
type
 TfrxXMLDocument = class(TObject)
 end;

The TfrxXMLDocument type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxXMLDocument class.
Destroy | Represents the destructor of the TfrxXMLDocument class.
Top
Properties
Show:
Name | Description
AutoIndent | Represents property AutoIndent.
OldVersion | Represents property OldVersion.
Root | Represents property Root.
TempDir | Represents property TempDir.
Top
Methods
Show:
Name | Description
Clear | Represents method Clear.
CreateTempFile | Represents method CreateTempFile.
DeleteTempFile | Represents method DeleteTempFile.
LoadFromFile(String) | Represents method LoadFromFile(String).
LoadFromStream(TStream,Boolean) | Represents method LoadFromStream(TStream,Boolean).
LoadItem(TfrxXMLItem) | Represents method LoadItem(TfrxXMLItem).
SaveToFile(String) | Represents method SaveToFile(String).
SaveToStream(TStream) | Represents method SaveToStream(TStream).
UnloadItem(TfrxXMLItem) | Represents method UnloadItem(TfrxXMLItem).
Top
Fields
Show:
Name | Description
FAutoIndent | Represents field FAutoIndent.
FOldVersion | Represents field FOldVersion.
FRoot | Represents field FRoot.
FTempDir | Represents field FTempDir.
FTempFile | Represents field FTempFile.
FTempFileCreated | Represents field FTempFileCreated.
FTempStream | Represents field FTempStream.
Top
See Also

Reference

  • frxXML


TfrxXMLDocument Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxXMLDocument class.
Destroy | Represents the destructor of the TfrxXMLDocument class.
Top


TfrxXMLDocument.Create Constructor

Summary

Initializes a new instance of the TfrxXMLDocument class.

Namespace: frxXML
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.Destroy Destructor

Summary

Represents the destructor of the TfrxXMLDocument class.

Namespace: frxXML
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument Properties

Properties
Name | Description
AutoIndent | Represents property AutoIndent.
OldVersion | Represents property OldVersion.
Root | Represents property Root.
TempDir | Represents property TempDir.
Top


TfrxXMLDocument.AutoIndent Property

Summary

Represents property AutoIndent.

Namespace: frxXML
Syntax
Delphi
public
 property AutoIndent: Boolean read FAutoIndent write FAutoIndent;

Property Value

Type: Boolean

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.OldVersion Property

Summary

Represents property OldVersion.

Namespace: frxXML
Syntax
Delphi
public
 property OldVersion: Boolean read FOldVersion;

Property Value

Type: Boolean

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.Root Property

Summary

Represents property Root.

Namespace: frxXML
Syntax
Delphi
public
 property Root: TfrxXMLItem read FRoot;

Property Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.TempDir Property

Summary

Represents property TempDir.

Namespace: frxXML
Syntax
Delphi
public
 property TempDir: String read FTempDir write FTempDir;

Property Value

Type: String

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument Methods

Methods
Name | Description
Clear | Represents method Clear.
CreateTempFile | Represents method CreateTempFile.
DeleteTempFile | Represents method DeleteTempFile.
LoadFromFile(String) | Represents method LoadFromFile(String).
LoadFromStream(TStream,Boolean) | Represents method LoadFromStream(TStream,Boolean).
LoadItem(TfrxXMLItem) | Represents method LoadItem(TfrxXMLItem).
SaveToFile(String) | Represents method SaveToFile(String).
SaveToStream(TStream) | Represents method SaveToStream(TStream).
UnloadItem(TfrxXMLItem) | Represents method UnloadItem(TfrxXMLItem).
Top


TfrxXMLDocument.Clear Method

Summary

Represents method Clear.

Namespace: frxXML
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.CreateTempFile Method

Summary

Represents method CreateTempFile.

Namespace: frxXML
Syntax
Delphi
private
 procedure CreateTempFile;
See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.DeleteTempFile Method

Summary

Represents method DeleteTempFile.

Namespace: frxXML
Syntax
Delphi
protected
 procedure DeleteTempFile;
See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.LoadFromFile(String) Method

Summary

Represents method LoadFromFile(String).

Namespace: frxXML
Syntax
Delphi
public
 procedure LoadFromFile(const FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.LoadFromStream(TStream,Boolean) Method

Summary

Represents method LoadFromStream(TStream,Boolean).

Namespace: frxXML
Syntax
Delphi
public
 procedure LoadFromStream(Stream: TStream; AllowPartialLoading: Boolean = False);

Parameters

Stream
Type: TStream

AllowPartialLoading
Type: Boolean

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.LoadItem(TfrxXMLItem) Method

Summary

Represents method LoadItem(TfrxXMLItem).

Namespace: frxXML
Syntax
Delphi
public
 procedure LoadItem(Item: TfrxXMLItem);

Parameters

Item
Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.SaveToFile(String) Method

Summary

Represents method SaveToFile(String).

Namespace: frxXML
Syntax
Delphi
public
 procedure SaveToFile(const FileName: String);

Parameters

FileName
Type: String

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.SaveToStream(TStream) Method

Summary

Represents method SaveToStream(TStream).

Namespace: frxXML
Syntax
Delphi
public
 procedure SaveToStream(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.UnloadItem(TfrxXMLItem) Method

Summary

Represents method UnloadItem(TfrxXMLItem).

Namespace: frxXML
Syntax
Delphi
public
 procedure UnloadItem(Item: TfrxXMLItem);

Parameters

Item
Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument Fields

Fields
Name | Description
FAutoIndent | Represents field FAutoIndent.
FOldVersion | Represents field FOldVersion.
FRoot | Represents field FRoot.
FTempDir | Represents field FTempDir.
FTempFile | Represents field FTempFile.
FTempFileCreated | Represents field FTempFileCreated.
FTempStream | Represents field FTempStream.
Top


TfrxXMLDocument.FAutoIndent Field

Summary

Represents field FAutoIndent.

Namespace: frxXML
Syntax
Delphi
private
 FAutoIndent: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.FOldVersion Field

Summary

Represents field FOldVersion.

Namespace: frxXML
Syntax
Delphi
protected
 FOldVersion: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.FRoot Field

Summary

Represents field FRoot.

Namespace: frxXML
Syntax
Delphi
private
 FRoot: TfrxXMLItem;

Field Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.FTempDir Field

Summary

Represents field FTempDir.

Namespace: frxXML
Syntax
Delphi
private
 FTempDir: String;

Field Value

Type: String

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.FTempFile Field

Summary

Represents field FTempFile.

Namespace: frxXML
Syntax
Delphi
private
 FTempFile: String;

Field Value

Type: String

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.FTempFileCreated Field

Summary

Represents field FTempFileCreated.

Namespace: frxXML
Syntax
Delphi
private
 FTempFileCreated: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLDocument.FTempStream Field

Summary

Represents field FTempStream.

Namespace: frxXML
Syntax
Delphi
protected
 FTempStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TfrxXMLDocument
  • frxXML


TfrxXMLItem Class

Summary

Represents type TfrxXMLItem.

Namespace: frxXML
Inheritance Hierarchy
TObject
frxXML.TfrxXMLItem
Syntax
Delphi
type
 TfrxXMLItem = class(TObject)
 end;

The TfrxXMLItem type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxXMLItem class.
Destroy | Represents the destructor of the TfrxXMLItem class.
Top
Properties
Show:
Name | Description
Count | Represents property Count.
Data | Represents property Data.
Items[Integer] | Represents property Items[Integer].
Loaded | Represents property Loaded.
Modified | Represents property Modified.
Name | Represents property Name.
Offset | Represents property Offset.
Parent | Represents property Parent.
Prop[String] | Represents property Prop[String].
Text | Represents property Text.
Unloadable | Represents property Unloadable.
Value | Represents property Value.
Top
Methods
Show:
Name | Description
Add | Overloaded. Represents method Add.
Add(string) | Overloaded. Represents method Add(string).
AddItem(TfrxXMLItem) | Represents method AddItem(TfrxXMLItem).
Clear | Represents method Clear.
DeleteProp(String) | Represents method DeleteProp(String).
Find(String) | Represents method Find(String).
FindItem(String) | Represents method FindItem(String).
GetCount | Represents method GetCount.
GetItems(Integer) | Represents method GetItems(Integer).
GetOffset | Represents method GetOffset.
GetProp(String) | Represents method GetProp(String).
IndexOf(TfrxXMLItem) | Represents method IndexOf(TfrxXMLItem).
InsertItem(Integer,TfrxXMLItem) | Represents method InsertItem(Integer,TfrxXMLItem).
PropExists(String) | Represents method PropExists(String).
Root | Represents method Root.
SetOffset(Int64) | Represents method SetOffset(Int64).
SetProp(String,String) | Represents method SetProp(String,String).
Top
Fields
Show:
Name | Description
FData | Represents field FData.
FItems | Represents field FItems.
FLoaded | Represents field FLoaded.
FModified | Represents field FModified.
FName | Represents field FName.
FOffset | Represents field FOffset.
FParent | Represents field FParent.
FText | Represents field FText.
FUnloadable | Represents field FUnloadable.
FValue | Represents field FValue.
Top
See Also

Reference

  • frxXML


TfrxXMLItem Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxXMLItem class.
Destroy | Represents the destructor of the TfrxXMLItem class.
Top


TfrxXMLItem.Create Constructor

Summary

Initializes a new instance of the TfrxXMLItem class.

Namespace: frxXML
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Destroy Destructor

Summary

Represents the destructor of the TfrxXMLItem class.

Namespace: frxXML
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem Properties

Properties
Name | Description
Count | Represents property Count.
Data | Represents property Data.
Items[Integer] | Represents property Items[Integer].
Loaded | Represents property Loaded.
Modified | Represents property Modified.
Name | Represents property Name.
Offset | Represents property Offset.
Parent | Represents property Parent.
Prop[String] | Represents property Prop[String].
Text | Represents property Text.
Unloadable | Represents property Unloadable.
Value | Represents property Value.
Top


TfrxXMLItem.Count Property

Summary

Represents property Count.

Namespace: frxXML
Syntax
Delphi
public
 property Count: Integer read GetCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Data Property

Summary

Represents property Data.

Namespace: frxXML
Syntax
Delphi
public
 property Data: Pointer read FData write FData;

Property Value

Type: Pointer

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: frxXML
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxXMLItem read GetItems; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Loaded Property

Summary

Represents property Loaded.

Namespace: frxXML
Syntax
Delphi
public
 property Loaded: Boolean read FLoaded;

Property Value

Type: Boolean

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Modified Property

Summary

Represents property Modified.

Namespace: frxXML
Syntax
Delphi
public
 property Modified: Boolean read FModified write FModified;

Property Value

Type: Boolean

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Name Property

Summary

Represents property Name.

Namespace: frxXML
Syntax
Delphi
public
 property Name: String read FName write FName;

Property Value

Type: String

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Offset Property

Summary

Represents property Offset.

Namespace: frxXML
Syntax
Delphi
public
 property Offset: Int64 read GetOffset write SetOffset;

Property Value

Type: Int64

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Parent Property

Summary

Represents property Parent.

Namespace: frxXML
Syntax
Delphi
public
 property Parent: TfrxXMLItem read FParent;

Property Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Prop[String] Property

Summary

Represents property Prop[String].

Namespace: frxXML
Syntax
Delphi
public
 property Prop[Index: String]: String read GetProp write SetProp;

Parameters

Index
Type: String

Property Value

Type: String

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Text Property

Summary

Represents property Text.

Namespace: frxXML
Syntax
Delphi
public
 property Text: String read FText write FText;

Property Value

Type: String

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Unloadable Property

Summary

Represents property Unloadable.

Namespace: frxXML
Syntax
Delphi
public
 property Unloadable: Boolean read FUnloadable write FUnloadable;

Property Value

Type: Boolean

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Value Property

Summary

Represents property Value.

Namespace: frxXML
Syntax
Delphi
public
 property Value: String read FValue write FValue;

Property Value

Type: String

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem Methods

Methods
Name | Description
Add | Overloaded. Represents method Add.
Add(string) | Overloaded. Represents method Add(string).
AddItem(TfrxXMLItem) | Represents method AddItem(TfrxXMLItem).
Clear | Represents method Clear.
DeleteProp(String) | Represents method DeleteProp(String).
Find(String) | Represents method Find(String).
FindItem(String) | Represents method FindItem(String).
GetCount | Represents method GetCount.
GetItems(Integer) | Represents method GetItems(Integer).
GetOffset | Represents method GetOffset.
GetProp(String) | Represents method GetProp(String).
IndexOf(TfrxXMLItem) | Represents method IndexOf(TfrxXMLItem).
InsertItem(Integer,TfrxXMLItem) | Represents method InsertItem(Integer,TfrxXMLItem).
PropExists(String) | Represents method PropExists(String).
Root | Represents method Root.
SetOffset(Int64) | Represents method SetOffset(Int64).
SetProp(String,String) | Represents method SetProp(String,String).
Top


TfrxXMLItem.Add Method

Summary

Represents method Add.

Namespace: frxXML
Syntax
Delphi
public
 function Add: TfrxXMLItem; overload;

Return Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Add(string) Method

Summary

Represents method Add(string).

Namespace: frxXML
Syntax
Delphi
public
 function Add(Name: string): TfrxXMLItem; overload;

Parameters

Name
Type: string

Return Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.AddItem(TfrxXMLItem) Method

Summary

Represents method AddItem(TfrxXMLItem).

Namespace: frxXML
Syntax
Delphi
public
 procedure AddItem(Item: TfrxXMLItem);

Parameters

Item
Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Clear Method

Summary

Represents method Clear.

Namespace: frxXML
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.DeleteProp(String) Method

Summary

Represents method DeleteProp(String).

Namespace: frxXML
Syntax
Delphi
public
 procedure DeleteProp(const Index: String);

Parameters

Index
Type: String

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Find(String) Method

Summary

Represents method Find(String).

Namespace: frxXML
Syntax
Delphi
public
 function Find(const Name: String): Integer;

Parameters

Name
Type: String

Return Value

Type: Integer

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.FindItem(String) Method

Summary

Represents method FindItem(String).

Namespace: frxXML
Syntax
Delphi
public
 function FindItem(const Name: String): TfrxXMLItem;

Parameters

Name
Type: String

Return Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.GetCount Method

Summary

Represents method GetCount.

Namespace: frxXML
Syntax
Delphi
private
 function GetCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.GetItems(Integer) Method

Summary

Represents method GetItems(Integer).

Namespace: frxXML
Syntax
Delphi
private
 function GetItems(Index: Integer): TfrxXMLItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.GetOffset Method

Summary

Represents method GetOffset.

Namespace: frxXML
Syntax
Delphi
private
 function GetOffset: Int64;

Return Value

Type: Int64

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.GetProp(String) Method

Summary

Represents method GetProp(String).

Namespace: frxXML
Syntax
Delphi
private
 function GetProp(Index: String): String;

Parameters

Index
Type: String

Return Value

Type: String

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.IndexOf(TfrxXMLItem) Method

Summary

Represents method IndexOf(TfrxXMLItem).

Namespace: frxXML
Syntax
Delphi
public
 function IndexOf(Item: TfrxXMLItem): Integer;

Parameters

Item
Type: TfrxXMLItem

Return Value

Type: Integer

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.InsertItem(Integer,TfrxXMLItem) Method

Summary

Represents method InsertItem(Integer,TfrxXMLItem).

Namespace: frxXML
Syntax
Delphi
public
 procedure InsertItem(Index: Integer; Item: TfrxXMLItem);

Parameters

Index
Type: Integer

Item
Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.PropExists(String) Method

Summary

Represents method PropExists(String).

Namespace: frxXML
Syntax
Delphi
public
 function PropExists(const Index: String): Boolean;

Parameters

Index
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.Root Method

Summary

Represents method Root.

Namespace: frxXML
Syntax
Delphi
public
 function Root: TfrxXMLItem;

Return Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.SetOffset(Int64) Method

Summary

Represents method SetOffset(Int64).

Namespace: frxXML
Syntax
Delphi
private
 procedure SetOffset(const Value: Int64);

Parameters

Value
Type: Int64

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.SetProp(String,String) Method

Summary

Represents method SetProp(String,String).

Namespace: frxXML
Syntax
Delphi
private
 procedure SetProp(Index: String; const Value: String);

Parameters

Index
Type: String

Value
Type: String

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem Fields

Fields
Name | Description
FData | Represents field FData.
FItems | Represents field FItems.
FLoaded | Represents field FLoaded.
FModified | Represents field FModified.
FName | Represents field FName.
FOffset | Represents field FOffset.
FParent | Represents field FParent.
FText | Represents field FText.
FUnloadable | Represents field FUnloadable.
FValue | Represents field FValue.
Top


TfrxXMLItem.FData Field

Summary

Represents field FData.

Namespace: frxXML
Syntax
Delphi
private
 FData: Pointer;

Field Value

Type: Pointer

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.FItems Field

Summary

Represents field FItems.

Namespace: frxXML
Syntax
Delphi
private
 FItems: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.FLoaded Field

Summary

Represents field FLoaded.

Namespace: frxXML
Syntax
Delphi
private
 FLoaded: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.FModified Field

Summary

Represents field FModified.

Namespace: frxXML
Syntax
Delphi
private
 FModified: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.FName Field

Summary

Represents field FName.

Namespace: frxXML
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.FOffset Field

Summary

Represents field FOffset.

Namespace: frxXML
Syntax
Delphi
private
 FOffset: Int64;

Field Value

Type: Int64

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.FParent Field

Summary

Represents field FParent.

Namespace: frxXML
Syntax
Delphi
private
 FParent: TfrxXMLItem;

Field Value

Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.FText Field

Summary

Represents field FText.

Namespace: frxXML
Syntax
Delphi
private
 FText: String;

Field Value

Type: String

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.FUnloadable Field

Summary

Represents field FUnloadable.

Namespace: frxXML
Syntax
Delphi
private
 FUnloadable: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLItem.FValue Field

Summary

Represents field FValue.

Namespace: frxXML
Syntax
Delphi
private
 FValue: String;

Field Value

Type: String

See Also

Reference

  • TfrxXMLItem
  • frxXML


TfrxXMLReader Class

Summary

Represents type TfrxXMLReader.

Namespace: frxXML
Inheritance Hierarchy
TObject
frxXML.TfrxXMLReader
frxMapHelpers.TfrxMapXMLReader
Syntax
Delphi
type
 TfrxXMLReader = class(TObject)
 end;

The TfrxXMLReader type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream) | Initializes a new instance of the TfrxXMLReader class.
Destroy | Represents the destructor of the TfrxXMLReader class.
Top
Properties
Show:
Name | Description
OldFormat | Represents property OldFormat.
Position | Represents property Position.
Size | Represents property Size.
Top
Methods
Show:
Name | Description
EndOfStream | Represents method EndOfStream.
RaiseException | Represents method RaiseException.
ReadBuffer | Represents method ReadBuffer.
ReadFromBuffer | Represents method ReadFromBuffer.
ReadHeader | Represents method ReadHeader.
ReadItem(String,String) | Represents method ReadItem(String,String).
ReadRootItem(TfrxXMLItem,Boolean) | Represents method ReadRootItem(TfrxXMLItem,Boolean).
SetPosition(Int64) | Represents method SetPosition(Int64).
Top
Fields
Show:
Name | Description
FBufEnd | Represents field FBufEnd.
FBuffer | Represents field FBuffer.
FBufPos | Represents field FBufPos.
FOldFormat | Represents field FOldFormat.
FPosition | Represents field FPosition.
FSize | Represents field FSize.
FStream | Represents field FStream.
Top
See Also

Reference

  • frxXML


TfrxXMLReader Constructors

Constructors
Name | Description
Create(TStream) | Initializes a new instance of the TfrxXMLReader class.
Destroy | Represents the destructor of the TfrxXMLReader class.
Top


TfrxXMLReader.Create(TStream) Constructor

Summary

Initializes a new instance of the TfrxXMLReader class.

Namespace: frxXML
Syntax
Delphi
public
 constructor Create(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.Destroy Destructor

Summary

Represents the destructor of the TfrxXMLReader class.

Namespace: frxXML
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader Properties

Properties
Name | Description
OldFormat | Represents property OldFormat.
Position | Represents property Position.
Size | Represents property Size.
Top


TfrxXMLReader.OldFormat Property

Summary

Represents property OldFormat.

Namespace: frxXML
Syntax
Delphi
public
 property OldFormat: Boolean read FOldFormat;

Property Value

Type: Boolean

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.Position Property

Summary

Represents property Position.

Namespace: frxXML
Syntax
Delphi
public
 property Position: Int64 read FPosition write SetPosition;

Property Value

Type: Int64

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.Size Property

Summary

Represents property Size.

Namespace: frxXML
Syntax
Delphi
public
 property Size: Int64 read FSize;

Property Value

Type: Int64

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader Methods

Methods
Name | Description
EndOfStream | Represents method EndOfStream.
RaiseException | Represents method RaiseException.
ReadBuffer | Represents method ReadBuffer.
ReadFromBuffer | Represents method ReadFromBuffer.
ReadHeader | Represents method ReadHeader.
ReadItem(String,String) | Represents method ReadItem(String,String).
ReadRootItem(TfrxXMLItem,Boolean) | Represents method ReadRootItem(TfrxXMLItem,Boolean).
SetPosition(Int64) | Represents method SetPosition(Int64).
Top


TfrxXMLReader.EndOfStream Method

Summary

Represents method EndOfStream.

Namespace: frxXML
Syntax
Delphi
protected
 function EndOfStream: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.RaiseException Method

Summary

Represents method RaiseException.

Namespace: frxXML
Syntax
Delphi
public
 procedure RaiseException;
See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.ReadBuffer Method

Summary

Represents method ReadBuffer.

Namespace: frxXML
Syntax
Delphi
private
 procedure ReadBuffer;
See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.ReadFromBuffer Method

Summary

Represents method ReadFromBuffer.

Namespace: frxXML
Syntax
Delphi
protected
 function ReadFromBuffer: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.ReadHeader Method

Summary

Represents method ReadHeader.

Namespace: frxXML
Syntax
Delphi
public
 procedure ReadHeader;
See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.ReadItem(String,String) Method

Summary

Represents method ReadItem(String,String).

Namespace: frxXML
Syntax
Delphi
protected
 procedure ReadItem(var NameS, Text: String);

Parameters

NameS
Type: String

Text
Type: String

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.ReadRootItem(TfrxXMLItem,Boolean) Method

Summary

Represents method ReadRootItem(TfrxXMLItem,Boolean).

Namespace: frxXML
Syntax
Delphi
public
 procedure ReadRootItem(Item: TfrxXMLItem; ReadChildren: Boolean = True);

Parameters

Item
Type: TfrxXMLItem

ReadChildren
Type: Boolean

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.SetPosition(Int64) Method

Summary

Represents method SetPosition(Int64).

Namespace: frxXML
Syntax
Delphi
private
 procedure SetPosition(const Value: Int64);

Parameters

Value
Type: Int64

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader Fields

Fields
Name | Description
FBufEnd | Represents field FBufEnd.
FBuffer | Represents field FBuffer.
FBufPos | Represents field FBufPos.
FOldFormat | Represents field FOldFormat.
FPosition | Represents field FPosition.
FSize | Represents field FSize.
FStream | Represents field FStream.
Top


TfrxXMLReader.FBufEnd Field

Summary

Represents field FBufEnd.

Namespace: frxXML
Syntax
Delphi
private
 FBufEnd: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.FBuffer Field

Summary

Represents field FBuffer.

Namespace: frxXML
Syntax
Delphi
private
 FBuffer: PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.FBufPos Field

Summary

Represents field FBufPos.

Namespace: frxXML
Syntax
Delphi
private
 FBufPos: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.FOldFormat Field

Summary

Represents field FOldFormat.

Namespace: frxXML
Syntax
Delphi
private
 FOldFormat: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.FPosition Field

Summary

Represents field FPosition.

Namespace: frxXML
Syntax
Delphi
private
 FPosition: Int64;

Field Value

Type: Int64

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.FSize Field

Summary

Represents field FSize.

Namespace: frxXML
Syntax
Delphi
private
 FSize: Int64;

Field Value

Type: Int64

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLReader.FStream Field

Summary

Represents field FStream.

Namespace: frxXML
Syntax
Delphi
private
 FStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TfrxXMLReader
  • frxXML


TfrxXMLWriter Class

Summary

Represents type TfrxXMLWriter.

Namespace: frxXML
Inheritance Hierarchy
TObject
frxXML.TfrxXMLWriter
Syntax
Delphi
type
 TfrxXMLWriter = class(TObject)
 end;

The TfrxXMLWriter type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream) | Initializes a new instance of the TfrxXMLWriter class.
Top
Properties
Show:
Name | Description
AutoIndent | Represents property AutoIndent.
TempStream | Represents property TempStream.
Top
Methods
Show:
Name | Description
FlushBuffer | Represents method FlushBuffer.
WriteHeader | Represents method WriteHeader.
WriteItem(TfrxXMLItem,Integer) | Represents method WriteItem(TfrxXMLItem,Integer).
WriteLn(AnsiString) | Represents method WriteLn(AnsiString).
WriteRootItem(TfrxXMLItem) | Represents method WriteRootItem(TfrxXMLItem).
Top
Fields
Show:
Name | Description
FAutoIndent | Represents field FAutoIndent.
FBuffer | Represents field FBuffer.
FStream | Represents field FStream.
FTempStream | Represents field FTempStream.
Top
See Also

Reference

  • frxXML


TfrxXMLWriter Constructors

Constructors
Name | Description
Create(TStream) | Initializes a new instance of the TfrxXMLWriter class.
Top


TfrxXMLWriter.Create(TStream) Constructor

Summary

Initializes a new instance of the TfrxXMLWriter class.

Namespace: frxXML
Syntax
Delphi
public
 constructor Create(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxXMLWriter
  • frxXML


TfrxXMLWriter Properties

Properties
Name | Description
AutoIndent | Represents property AutoIndent.
TempStream | Represents property TempStream.
Top


TfrxXMLWriter.AutoIndent Property

Summary

Represents property AutoIndent.

Namespace: frxXML
Syntax
Delphi
public
 property AutoIndent: Boolean read FAutoIndent write FAutoIndent;

Property Value

Type: Boolean

See Also

Reference

  • TfrxXMLWriter
  • frxXML


TfrxXMLWriter.TempStream Property

Summary

Represents property TempStream.

Namespace: frxXML
Syntax
Delphi
public
 property TempStream: TStream read FTempStream write FTempStream;

Property Value

Type: TStream

See Also

Reference

  • TfrxXMLWriter
  • frxXML


TfrxXMLWriter Methods

Methods
Name | Description
FlushBuffer | Represents method FlushBuffer.
WriteHeader | Represents method WriteHeader.
WriteItem(TfrxXMLItem,Integer) | Represents method WriteItem(TfrxXMLItem,Integer).
WriteLn(AnsiString) | Represents method WriteLn(AnsiString).
WriteRootItem(TfrxXMLItem) | Represents method WriteRootItem(TfrxXMLItem).
Top


TfrxXMLWriter.FlushBuffer Method

Summary

Represents method FlushBuffer.

Namespace: frxXML
Syntax
Delphi
private
 procedure FlushBuffer;
See Also

Reference

  • TfrxXMLWriter
  • frxXML


TfrxXMLWriter.WriteHeader Method

Summary

Represents method WriteHeader.

Namespace: frxXML
Syntax
Delphi
public
 procedure WriteHeader;
See Also

Reference

  • TfrxXMLWriter
  • frxXML


TfrxXMLWriter.WriteItem(TfrxXMLItem,Integer) Method

Summary

Represents method WriteItem(TfrxXMLItem,Integer).

Namespace: frxXML
Syntax
Delphi
private
 procedure WriteItem(Item: TfrxXMLItem; Level: Integer = 0);

Parameters

Item
Type: TfrxXMLItem

Level
Type: Integer

See Also

Reference

  • TfrxXMLWriter
  • frxXML


TfrxXMLWriter.WriteLn(AnsiString) Method

Summary

Represents method WriteLn(AnsiString).

Namespace: frxXML
Syntax
Delphi
private
 procedure WriteLn(const s: AnsiString);

Parameters

s
Type: AnsiString

See Also

Reference

  • TfrxXMLWriter
  • frxXML


TfrxXMLWriter.WriteRootItem(TfrxXMLItem) Method

Summary

Represents method WriteRootItem(TfrxXMLItem).

Namespace: frxXML
Syntax
Delphi
public
 procedure WriteRootItem(RootItem: TfrxXMLItem);

Parameters

RootItem
Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLWriter
  • frxXML


TfrxXMLWriter Fields

Fields
Name | Description
FAutoIndent | Represents field FAutoIndent.
FBuffer | Represents field FBuffer.
FStream | Represents field FStream.
FTempStream | Represents field FTempStream.
Top


TfrxXMLWriter.FAutoIndent Field

Summary

Represents field FAutoIndent.

Namespace: frxXML
Syntax
Delphi
private
 FAutoIndent: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLWriter
  • frxXML


TfrxXMLWriter.FBuffer Field

Summary

Represents field FBuffer.

Namespace: frxXML
Syntax
Delphi
private
 FBuffer: AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TfrxXMLWriter
  • frxXML


TfrxXMLWriter.FStream Field

Summary

Represents field FStream.

Namespace: frxXML
Syntax
Delphi
private
 FStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TfrxXMLWriter
  • frxXML


TfrxXMLWriter.FTempStream Field

Summary

Represents field FTempStream.

Namespace: frxXML
Syntax
Delphi
private
 FTempStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TfrxXMLWriter
  • frxXML


frxXML Routines

Routines
Name | Description
frxStrToXML(String) | Represents method frxStrToXML(String).
frxValueToXML(Variant) | Represents method frxValueToXML(Variant).
frxXMLToStr(String) | Represents method frxXMLToStr(String).
Top


frxStrToXML(String) Method

Summary

Represents method frxStrToXML(String).

Namespace: frxXML
Syntax
Delphi
function frxStrToXML(const s: String): String;

Parameters

s
Type: String

Return Value

Type: String

See Also

Reference

  • frxXML


frxValueToXML(Variant) Method

Summary

Represents method frxValueToXML(Variant).

Namespace: frxXML
Syntax
Delphi
function frxValueToXML(const Value: Variant): String;

Parameters

Value
Type: Variant

Return Value

Type: String

See Also

Reference

  • frxXML


frxXMLToStr(String) Method

Summary

Represents method frxXMLToStr(String).

Namespace: frxXML
Syntax
Delphi
function frxXMLToStr(const s: String): String;

Parameters

s
Type: String

Return Value

Type: String

See Also

Reference

  • frxXML


frxXMLSerializer Namespace

Summary

Represents namespace frxXMLSerializer.

Classes
Name | Description
TfrxFixupItem | Represents type TfrxFixupItem.
TfrxXMLSerializer | Represents type TfrxXMLSerializer.
Top
Delegates
Name | Description
TfrxGetAncestorEvent | Represents type TfrxGetAncestorEvent.
Top


frxXMLSerializer Classes

Classes
Name | Description
TfrxFixupItem | Represents type TfrxFixupItem.
TfrxXMLSerializer | Represents type TfrxXMLSerializer.
Top


TfrxFixupItem Class

Summary

Represents type TfrxFixupItem.

Namespace: frxXMLSerializer
Inheritance Hierarchy
TObject
frxXMLSerializer.TfrxFixupItem
Syntax
Delphi
type
 TfrxFixupItem = class(TObject)
 end;

The TfrxFixupItem type exposes the following members.

Fields
Show:
Name | Description
Obj | Represents field Obj.
PropInfo | Represents field PropInfo.
Value | Represents field Value.
Top
See Also

Reference

  • frxXMLSerializer


TfrxFixupItem Fields

Fields
Name | Description
Obj | Represents field Obj.
PropInfo | Represents field PropInfo.
Value | Represents field Value.
Top


TfrxFixupItem.Obj Field

Summary

Represents field Obj.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 Obj: TPersistent;

Field Value

Type: TPersistent

See Also

Reference

  • TfrxFixupItem
  • frxXMLSerializer


TfrxFixupItem.PropInfo Field

Summary

Represents field PropInfo.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 PropInfo: PPropInfo;

Field Value

Type: PPropInfo

See Also

Reference

  • TfrxFixupItem
  • frxXMLSerializer


TfrxFixupItem.Value Field

Summary

Represents field Value.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 Value: String;

Field Value

Type: String

See Also

Reference

  • TfrxFixupItem
  • frxXMLSerializer


TfrxXMLSerializer Class

Summary

Represents type TfrxXMLSerializer.

Namespace: frxXMLSerializer
Inheritance Hierarchy
TObject
frxXMLSerializer.TfrxXMLSerializer
Syntax
Delphi
type
 TfrxXMLSerializer = class(TObject)
 end;

The TfrxXMLSerializer type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream) | Initializes a new instance of the TfrxXMLSerializer class.
Destroy | Represents the destructor of the TfrxXMLSerializer class.
Top
Properties
Show:
Name | Description
Errors | Represents property Errors.
Fixups | Represents property Fixups.
HandleNestedProperties | Represents property HandleNestedProperties.
IgnoreName | Represents property IgnoreName.
OldFormat | Represents property OldFormat.
Owner | Represents property Owner.
SaveAncestorOnly | Represents property SaveAncestorOnly.
SerializeDefaultValues | Represents property SerializeDefaultValues.
Stream | Represents property Stream.
Top
Methods
Show:
Name | Description
AddFixup(TPersistent,PPropInfo,String) | Represents method AddFixup(TPersistent,PPropInfo,String).
ClearFixups | Represents method ClearFixups.
CopyFixupList(TList) | Represents method CopyFixupList(TList).
FixupReferences | Represents method FixupReferences.
ObjToXML(TPersistent,String,TPersistent) | Represents method ObjToXML(TPersistent,String,TPersistent).
ReadComponent(TfrxComponent) | Represents method ReadComponent(TfrxComponent).
ReadComponentStr(TfrxComponent,String,Boolean) | Represents method ReadComponentStr(TfrxComponent,String,Boolean).
ReadPersistentStr(TComponent,TPersistent,String) | Represents method ReadPersistentStr(TComponent,TPersistent,String).
ReadRootComponent(TfrxComponent,TfrxXMLItem) | Represents method ReadRootComponent(TfrxComponent,TfrxXMLItem).
WriteComponent(TfrxComponent,TPersistent) | Represents method WriteComponent(TfrxComponent,TPersistent).
WriteComponentStr(TfrxComponent,TPersistent) | Represents method WriteComponentStr(TfrxComponent,TPersistent).
WriteRootComponent(TfrxComponent,Boolean,TfrxXMLItem) | Represents method WriteRootComponent(TfrxComponent,Boolean,TfrxXMLItem).
XMLToObj(String,TPersistent) | Represents method XMLToObj(String,TPersistent).
Top
Events
Show:
Name | Description
OnGetAncestor | Represents property OnGetAncestor.
OnGetCustomDataEvent | Represents property OnGetCustomDataEvent.
OnSaveCustomDataEvent | Represents property OnSaveCustomDataEvent.
Top
Fields
Show:
Name | Description
FErrors | Represents field FErrors.
FFixups | Represents field FFixups.
FGetCustomDataEvent | Represents field FGetCustomDataEvent.
FHandleNestedProperties | Represents field FHandleNestedProperties.
FIgnoreName | Represents field FIgnoreName.
FOldFormat | Represents field FOldFormat.
FOnGetAncestor | Represents field FOnGetAncestor.
FOnSaveCustomDataEvent | Represents field FOnSaveCustomDataEvent.
FOwner | Represents field FOwner.
FReader | Represents field FReader.
FReaderStream | Represents field FReaderStream.
FSaveAncestorOnly | Represents field FSaveAncestorOnly.
FSerializeDefaultValues | Represents field FSerializeDefaultValues.
FStream | Represents field FStream.
Top
See Also

Reference

  • frxXMLSerializer


TfrxXMLSerializer Constructors

Constructors
Name | Description
Create(TStream) | Initializes a new instance of the TfrxXMLSerializer class.
Destroy | Represents the destructor of the TfrxXMLSerializer class.
Top


TfrxXMLSerializer.Create(TStream) Constructor

Summary

Initializes a new instance of the TfrxXMLSerializer class.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 constructor Create(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.Destroy Destructor

Summary

Represents the destructor of the TfrxXMLSerializer class.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer Properties

Properties
Name | Description
Errors | Represents property Errors.
Fixups | Represents property Fixups.
HandleNestedProperties | Represents property HandleNestedProperties.
IgnoreName | Represents property IgnoreName.
OldFormat | Represents property OldFormat.
Owner | Represents property Owner.
SaveAncestorOnly | Represents property SaveAncestorOnly.
SerializeDefaultValues | Represents property SerializeDefaultValues.
Stream | Represents property Stream.
Top


TfrxXMLSerializer.Errors Property

Summary

Represents property Errors.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 property Errors: TStringList read FErrors;

Property Value

Type: TStringList

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.Fixups Property

Summary

Represents property Fixups.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 property Fixups: TList read FFixups;

Property Value

Type: TList

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.HandleNestedProperties Property

Summary

Represents property HandleNestedProperties.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 property HandleNestedProperties: Boolean read FHandleNestedProperties write FHandleNestedProperties;

Property Value

Type: Boolean

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.IgnoreName Property

Summary

Represents property IgnoreName.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 property IgnoreName: Boolean read FIgnoreName write FIgnoreName;

Property Value

Type: Boolean

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.OldFormat Property

Summary

Represents property OldFormat.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 property OldFormat: Boolean read FOldFormat write FOldFormat;

Property Value

Type: Boolean

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.Owner Property

Summary

Represents property Owner.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 property Owner: TfrxComponent read FOwner write FOwner;

Property Value

Type: TfrxComponent

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.SaveAncestorOnly Property

Summary

Represents property SaveAncestorOnly.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 property SaveAncestorOnly: Boolean read FSaveAncestorOnly write FSaveAncestorOnly;

Property Value

Type: Boolean

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.SerializeDefaultValues Property

Summary

Represents property SerializeDefaultValues.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 property SerializeDefaultValues: Boolean read FSerializeDefaultValues
 write FSerializeDefaultValues;

Property Value

Type: Boolean

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.Stream Property

Summary

Represents property Stream.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 property Stream: TStream read FStream;

Property Value

Type: TStream

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer Methods

Methods
Name | Description
AddFixup(TPersistent,PPropInfo,String) | Represents method AddFixup(TPersistent,PPropInfo,String).
ClearFixups | Represents method ClearFixups.
CopyFixupList(TList) | Represents method CopyFixupList(TList).
FixupReferences | Represents method FixupReferences.
ObjToXML(TPersistent,String,TPersistent) | Represents method ObjToXML(TPersistent,String,TPersistent).
ReadComponent(TfrxComponent) | Represents method ReadComponent(TfrxComponent).
ReadComponentStr(TfrxComponent,String,Boolean) | Represents method ReadComponentStr(TfrxComponent,String,Boolean).
ReadPersistentStr(TComponent,TPersistent,String) | Represents method ReadPersistentStr(TComponent,TPersistent,String).
ReadRootComponent(TfrxComponent,TfrxXMLItem) | Represents method ReadRootComponent(TfrxComponent,TfrxXMLItem).
WriteComponent(TfrxComponent,TPersistent) | Represents method WriteComponent(TfrxComponent,TPersistent).
WriteComponentStr(TfrxComponent,TPersistent) | Represents method WriteComponentStr(TfrxComponent,TPersistent).
WriteRootComponent(TfrxComponent,Boolean,TfrxXMLItem) | Represents method WriteRootComponent(TfrxComponent,Boolean,TfrxXMLItem).
XMLToObj(String,TPersistent) | Represents method XMLToObj(String,TPersistent).
Top


TfrxXMLSerializer.AddFixup(TPersistent,PPropInfo,String) Method

Summary

Represents method AddFixup(TPersistent,PPropInfo,String).

Namespace: frxXMLSerializer
Syntax
Delphi
private
 procedure AddFixup(Obj: TPersistent; p: PPropInfo; Value: String);

Parameters

Obj
Type: TPersistent

p
Type: PPropInfo

Value
Type: String

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.ClearFixups Method

Summary

Represents method ClearFixups.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 procedure ClearFixups;
See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.CopyFixupList(TList) Method

Summary

Represents method CopyFixupList(TList).

Namespace: frxXMLSerializer
Syntax
Delphi
public
 procedure CopyFixupList(FixList: TList);

Parameters

FixList
Type: TList

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FixupReferences Method

Summary

Represents method FixupReferences.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 procedure FixupReferences;
See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.ObjToXML(TPersistent,String,TPersistent) Method

Summary

Represents method ObjToXML(TPersistent,String,TPersistent).

Namespace: frxXMLSerializer
Syntax
Delphi
public
 function ObjToXML(Obj: TPersistent; const Add: String = ''; Ancestor: TPersistent = nil): String;

Parameters

Obj
Type: TPersistent

Add
Type: String

Ancestor
Type: TPersistent

Return Value

Type: String

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.ReadComponent(TfrxComponent) Method

Summary

Represents method ReadComponent(TfrxComponent).

Namespace: frxXMLSerializer
Syntax
Delphi
public
 function ReadComponent(Root: TfrxComponent): TfrxComponent;

Parameters

Root
Type: TfrxComponent

Return Value

Type: TfrxComponent

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.ReadComponentStr(TfrxComponent,String,Boolean) Method

Summary

Represents method ReadComponentStr(TfrxComponent,String,Boolean).

Namespace: frxXMLSerializer
Syntax
Delphi
public
 function ReadComponentStr(Root: TfrxComponent; s: String; DontFixup: Boolean = False): TfrxComponent;

Parameters

Root
Type: TfrxComponent

s
Type: String

DontFixup
Type: Boolean

Return Value

Type: TfrxComponent

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.ReadPersistentStr(TComponent,TPersistent,String) Method

Summary

Represents method ReadPersistentStr(TComponent,TPersistent,String).

Namespace: frxXMLSerializer
Syntax
Delphi
public
 procedure ReadPersistentStr(Root: TComponent; Obj: TPersistent; const s: String);

Parameters

Root
Type: TComponent

Obj
Type: TPersistent

s
Type: String

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.ReadRootComponent(TfrxComponent,TfrxXMLItem) Method

Summary

Represents method ReadRootComponent(TfrxComponent,TfrxXMLItem).

Namespace: frxXMLSerializer
Syntax
Delphi
public
 procedure ReadRootComponent(Root: TfrxComponent; XMLItem: TfrxXMLItem = nil);

Parameters

Root
Type: TfrxComponent

XMLItem
Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.WriteComponent(TfrxComponent,TPersistent) Method

Summary

Represents method WriteComponent(TfrxComponent,TPersistent).

Namespace: frxXMLSerializer
Syntax
Delphi
public
 procedure WriteComponent(c: TfrxComponent; Ancestor: TPersistent = nil);

Parameters

c
Type: TfrxComponent

Ancestor
Type: TPersistent

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.WriteComponentStr(TfrxComponent,TPersistent) Method

Summary

Represents method WriteComponentStr(TfrxComponent,TPersistent).

Namespace: frxXMLSerializer
Syntax
Delphi
public
 function WriteComponentStr(c: TfrxComponent; Ancestor: TPersistent = nil): String;

Parameters

c
Type: TfrxComponent

Ancestor
Type: TPersistent

Return Value

Type: String

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.WriteRootComponent(TfrxComponent,Boolean,TfrxXMLItem) Method

Summary

Represents method WriteRootComponent(TfrxComponent,Boolean,TfrxXMLItem).

Namespace: frxXMLSerializer
Syntax
Delphi
public
 procedure WriteRootComponent(Root: TfrxComponent; SaveChildren: Boolean = True;
 XMLItem: TfrxXMLItem = nil);

Parameters

Root
Type: TfrxComponent

SaveChildren
Type: Boolean

XMLItem
Type: TfrxXMLItem

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.XMLToObj(String,TPersistent) Method

Summary

Represents method XMLToObj(String,TPersistent).

Namespace: frxXMLSerializer
Syntax
Delphi
public
 procedure XMLToObj(const s: String; Obj: TPersistent);

Parameters

s
Type: String

Obj
Type: TPersistent

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer Events

Events
Name | Description
OnGetAncestor | Represents property OnGetAncestor.
OnGetCustomDataEvent | Represents property OnGetCustomDataEvent.
OnSaveCustomDataEvent | Represents property OnSaveCustomDataEvent.
Top


TfrxXMLSerializer.OnGetAncestor Event

Summary

Represents property OnGetAncestor.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 property OnGetAncestor: TfrxGetAncestorEvent read FOnGetAncestor write FOnGetAncestor;

Value

Type: TfrxGetAncestorEvent

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.OnGetCustomDataEvent Event

Summary

Represents property OnGetCustomDataEvent.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 property OnGetCustomDataEvent: TfrxGetCustomDataEvent read FGetCustomDataEvent write FGetCustomDataEvent;

Value

Type: TfrxGetCustomDataEvent

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.OnSaveCustomDataEvent Event

Summary

Represents property OnSaveCustomDataEvent.

Namespace: frxXMLSerializer
Syntax
Delphi
public
 property OnSaveCustomDataEvent: TfrxSaveCustomDataEvent read FOnSaveCustomDataEvent write FOnSaveCustomDataEvent;

Value

Type: TfrxSaveCustomDataEvent

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer Fields

Fields
Name | Description
FErrors | Represents field FErrors.
FFixups | Represents field FFixups.
FGetCustomDataEvent | Represents field FGetCustomDataEvent.
FHandleNestedProperties | Represents field FHandleNestedProperties.
FIgnoreName | Represents field FIgnoreName.
FOldFormat | Represents field FOldFormat.
FOnGetAncestor | Represents field FOnGetAncestor.
FOnSaveCustomDataEvent | Represents field FOnSaveCustomDataEvent.
FOwner | Represents field FOwner.
FReader | Represents field FReader.
FReaderStream | Represents field FReaderStream.
FSaveAncestorOnly | Represents field FSaveAncestorOnly.
FSerializeDefaultValues | Represents field FSerializeDefaultValues.
FStream | Represents field FStream.
Top


TfrxXMLSerializer.FErrors Field

Summary

Represents field FErrors.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FErrors: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FFixups Field

Summary

Represents field FFixups.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FFixups: TList;

Field Value

Type: TList

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FGetCustomDataEvent Field

Summary

Represents field FGetCustomDataEvent.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FGetCustomDataEvent: TfrxGetCustomDataEvent;

Field Value

Type: TfrxGetCustomDataEvent

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FHandleNestedProperties Field

Summary

Represents field FHandleNestedProperties.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FHandleNestedProperties: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FIgnoreName Field

Summary

Represents field FIgnoreName.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FIgnoreName: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FOldFormat Field

Summary

Represents field FOldFormat.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FOldFormat: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FOnGetAncestor Field

Summary

Represents field FOnGetAncestor.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FOnGetAncestor: TfrxGetAncestorEvent;

Field Value

Type: TfrxGetAncestorEvent

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FOnSaveCustomDataEvent Field

Summary

Represents field FOnSaveCustomDataEvent.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FOnSaveCustomDataEvent: TfrxSaveCustomDataEvent;

Field Value

Type: TfrxSaveCustomDataEvent

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FOwner Field

Summary

Represents field FOwner.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FOwner: TfrxComponent;

Field Value

Type: TfrxComponent

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FReader Field

Summary

Represents field FReader.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FReader: TReader;

Field Value

Type: TReader

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FReaderStream Field

Summary

Represents field FReaderStream.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FReaderStream: TMemoryStream;

Field Value

Type: TMemoryStream

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FSaveAncestorOnly Field

Summary

Represents field FSaveAncestorOnly.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FSaveAncestorOnly: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FSerializeDefaultValues Field

Summary

Represents field FSerializeDefaultValues.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FSerializeDefaultValues: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


TfrxXMLSerializer.FStream Field

Summary

Represents field FStream.

Namespace: frxXMLSerializer
Syntax
Delphi
private
 FStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TfrxXMLSerializer
  • frxXMLSerializer


frxXMLSerializer Delegates

Delegates
Name | Description
TfrxGetAncestorEvent | Represents type TfrxGetAncestorEvent.
Top


TfrxGetAncestorEvent Delegate

Summary

Represents type TfrxGetAncestorEvent.

Namespace: frxXMLSerializer
Syntax
Delphi
type
 TfrxGetAncestorEvent = procedure(const ComponentName: String;
 var Ancestor: TPersistent) of object;
See Also

Reference

  • frxXMLSerializer


frxZipCode Namespace

Summary

Represents namespace frxZipCode.

Classes
Name | Description
TfrxZipCodeObject | Represents type TfrxZipCodeObject.
TfrxZipCodeView | Represents type TfrxZipCodeView.
Top
Enumerations
Name | Description
TZipCodeKind | Represents type TZipCodeKind.
Top


frxZipCode Classes

Classes
Name | Description
TfrxZipCodeObject | Represents type TfrxZipCodeObject.
TfrxZipCodeView | Represents type TfrxZipCodeView.
Top


TfrxZipCodeObject Class

Summary

Represents type TfrxZipCodeObject.

Namespace: frxZipCode
Inheritance Hierarchy
TComponent
frxZipCode.TfrxZipCodeObject
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxZipCodeObject = class(TComponent);
See Also

Reference

  • frxZipCode


TfrxZipCodeView Class

Summary

Represents type TfrxZipCodeView.

Namespace: frxZipCode
Inheritance Hierarchy
TComponent
frxClass.TfrxComponent
frxClass.TfrxReportComponent
frxClass.TfrxView
frxZipCode.TfrxZipCodeView
Syntax
Delphi
type
 TfrxZipCodeView = class(TfrxView)
 end;

The TfrxZipCodeView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxZipCodeView class. (Overrides TfrxView.Create(TComponent).)
DesignCreate(TComponent,Word) | Constructor uses by the report designer when create new report object. (Inherited from TfrxComponent.)
Top
Properties
Show:
Name | Description
AbsLeft | Object's X absolute coordinate, in pixels. (Inherited from TfrxComponent.)
AbsTop | Object's Y absolute coordinate, in pixels. (Inherited from TfrxComponent.)
Align | Object's aligning relatively to its parent. (Inherited from TfrxView.)
AllObjects | The list of all subordinate objects. (Inherited from TfrxComponent.)
AllowMirrorMode | Represents property AllowMirrorMode. (Inherited from TfrxView.)
AllowVectorExport | This object can be exported through vector graphic processor(meta file) if object and export filter supports it. (Inherited from TfrxView.)
AncestorOnlyStream | Used when save object to XML. If this property set to true only values of ancestor object will be serialized. (Inherited from TfrxComponent.)
Anchors | Represents property Anchors. (Inherited from TfrxView.)
BaseName | Base name of the report object. Used for generation of unique names. (Inherited from TfrxComponent.)
BrushStyle | Object's filling style (deprecated check Fill property). (Inherited from TfrxView.)
Color | Represents property Color.
ContainerObjects | Deprecated. Used to support old cross tab behaviour. (Inherited from TfrxComponent.)
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
Description | Represents property Description. (Inherited from TfrxReportComponent.)
DigitCount | Represents property DigitCount.
DrawAsMask | Internal use. The export engine uses it to generate transparency mask of object. (Inherited from TfrxView.)
Expression | Represents property Expression.
Fill | Represents property Fill.
FillType | Represents property FillType.
Font | Object's font. (Inherited from TfrxComponent.)
Frame | Object's frame. (Inherited from TfrxView.)
frComponentStyle | Report object component styles. (Inherited from TfrxComponent.)
GroupIndex | Represents property GroupIndex. (Inherited from TfrxView.)
Height | Represents property Height. (Inherited from TfrxView.)
Hint | The hint, shows when hold mouse pointer at object. (Inherited from TfrxView.)
Hyperlink | The report object hyperlink property which can be used to: change location inside a report, open HTTP link, open and build detailed report or detailed report page. (Inherited from TfrxView.)
IndexTag | Represents property IndexTag. (Inherited from TfrxReportComponent.)
IsAncestor | Returns True when object has an ancestor. (Inherited from TfrxComponent.)
IsDesigning | The object in designing mode. (Inherited from TfrxComponent.)
IsLoading | Object is loading. (Inherited from TfrxComponent.)
IsPrinting | Object is printing. (Inherited from TfrxComponent.)
IsSelected | Object selected in the report designer or report preview. (Inherited from TfrxComponent.)
IsWriting | Object is in serialization state. (Inherited from TfrxComponent.)
Kind | Represents property Kind.
Left | Represents property Left. (Inherited from TfrxView.)
mmDigitHeight | Represents property mmDigitHeight.
mmDigitWidth | Represents property mmDigitWidth.
mmLineWidth | Represents property mmLineWidth.
mmSpacing | Represents property mmSpacing.
Objects | The list of child objects. (Inherited from TfrxComponent.)
OnAfterData | Represents property OnAfterData. (Inherited from TfrxView.)
OnAfterPrint | Represents property OnAfterPrint. (Inherited from TfrxView.)
OnBeforePrint | Represents property OnBeforePrint. (Inherited from TfrxView.)
OnContentChanged | Represents property OnContentChanged. (Inherited from TfrxView.)
OnMouseDown | The name of the script routine that will be called when user push mouse button in the report preview on current object. (Inherited from TfrxView.)
OnMouseEnter | The name of the script routine that will be called when mouse cursor in the report preview enters object area. (Inherited from TfrxView.)
OnMouseLeave | The name of the script routine that will be called when mouse cursor in the report preview leaves object area. (Inherited from TfrxView.)
OnMouseMove | The name of the script routine that will be called when user move mouse pointer in the report preview over current object. (Inherited from TfrxView.)
OnMouseUp | The name of the script routine that will be called when user release mouse button in the report preview on current object. (Inherited from TfrxView.)
OnPreviewClick | Represents property OnPreviewClick. (Inherited from TfrxView.)
OnPreviewDblClick | Represents property OnPreviewDblClick. (Inherited from TfrxView.)
Page | Link to the report page, which the object belongs to. (Inherited from TfrxComponent.)
Parent | Link to the parent object. (Inherited from TfrxComponent.)
ParentFont | If "True", then uses the parent object font settings. (Inherited from TfrxComponent.)
PlainText | Used in export matrix to get a plain text of object. (Inherited from TfrxView.)
Printable | Defines whether the given object should be printed out (Deprecated check Visibility property). (Inherited from TfrxView.)
PrintOn | Reserved for future use. (Inherited from TfrxReportComponent.)
Processing | Defines how the report engine should process all expressions and GetData calls for current object. It controls post processing of expressions inside objects. (Inherited from TfrxView.)
Report | Link to the report, which the object belongs to. (Inherited from TfrxComponent.)
Restrictions | Represents property Restrictions. (Inherited from TfrxView.)
ShiftMode | The mode of object's shifting in cases when a stretchable object is placed over the given one (Inherited from TfrxView.)
ShowGrid | Represents property ShowGrid.
ShowHint | Show/hide hint. (Inherited from TfrxView.)
ShowMarkers | Represents property ShowMarkers.
TagStr | The field for storing different information. This property can contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Text | Represents property Text.
Top | Represents property Top. (Inherited from TfrxView.)
TopParent | Returns topmost parent of the object. (Inherited from TfrxComponent.)
URL | Object's URL (Deprecated check HyperLink property). Determines what action will occur when a user clicks this object in the preview window. The property may contain string like: - '@number' - jumps to specified page number;/n - '#name' - jumps to specified anchor;/n - 'mailto:', 'htpp:', 'ftp:' - execute shell command./n/n The property may contain an expression in square brakets which will be calculated when report runs. (Inherited from TfrxView.)
Visibility | Visibility of object in the result report. (Inherited from TfrxView.)
Visible | Represents property Visible. (Inherited from TfrxView.)
Width | Represents property Width. (Inherited from TfrxView.)
Top
Methods
Show:
Name | Description
AddSourceObjects | Deprecated. Used only for cross tab object for saving nested objects to source object dictionary. (Inherited from TfrxComponent.)
AfterPrint | The report engine calls this method after object was prepared and placed to preview pages. (Overrides TfrxReportComponent.AfterPrint.)
AlignChildren(Boolean,TfrxMirrorControlModes) | Align all child objects relative to the container based on mirror control modes and child objects Align's. (Inherited from TfrxComponent.)
AllDiff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Used to generate object dictionary when csDefaultDiff flag is set. (Inherited from TfrxComponent.)
Assign(TPersistent) | Copies the state of Source object (ignores all child objects). (Inherited from TfrxComponent.)
AssignAll(TfrxComponent,Boolean) | Copies the state of Source object with all child objects. (Inherited from TfrxComponent.)
AssignAllWithOriginals(TfrxComponent,Boolean) | Internal use only. Copies the state of Source object with all child objects. Also assign all original components (FOriginalComponent) used for prepared report object dictionary. (Inherited from TfrxComponent.)
BeforePrint | The report engine calls this method before prepare object and place it to preview pages. (Overrides TfrxReportComponent.BeforePrint.)
BeforeStartReport | Report engine call this method before start report preparation. Used to prepare objects before build. (Inherited from TfrxComponent.)
BeginDraw(TCanvas,Extended,Extended,Extended,Extended) | Represents method BeginDraw(TCanvas,Extended,Extended,Extended,Extended). (Inherited from TfrxView.)
Clear | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
ContainerAdd(TfrxComponent) | Deprecated. Used only for cross tab component. Adds internal child objects for cross cells. (Inherited from TfrxComponent.)
CreateUniqueName(TfrxReport) | Creates a unique name for an object placed into the report. (Inherited from TfrxComponent.)
Diff(TfrxComponent) | Generates serialized object XML string based on comparison of current object with AComponent (Diff between two objects). Light version of AllDiff function used to generate object dictionary when csDefaultDiff flag is NOT set. (Overrides TfrxComponent.Diff(TfrxComponent).)
DiffFont(TFont,TFont,String) | Represents method DiffFont(TFont,TFont,String). (Inherited from TfrxComponent.)
DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Represents method DoDragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Represents method DoDragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMirror(TfrxMirrorControlModes) | Represents method DoMirror(TfrxMirrorControlModes). (Inherited from TfrxComponent.)
DoMouseClick(Boolean,TfrxInteractiveEventsParams) | Represents method DoMouseClick(Boolean,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
DragDrop(TObject,Integer,Integer,TfrxInteractiveEventsParams) | Generates drag drop event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
DragOver(TObject,Integer,Integer,TDragState,Boolean,TfrxInteractiveEventsParams) | Generates drag over event for report object when drag and drop initialized. (Inherited from TfrxComponent.)
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawBackground | Represents method DrawBackground. (Inherited from TfrxView.)
DrawChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
DrawClipped(TCanvas,Extended,Extended,Extended,Extended) | Draw object with clip bounds on. Any output behind bounds cuts off. By default just calls standard Draw method. Used for some objects. (Inherited from TfrxView.)
DrawFrame | Represents method DrawFrame. (Inherited from TfrxView.)
DrawFrameEdges | Represents method DrawFrameEdges. (Inherited from TfrxView.)
DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor) | Draws selection highlight. (Overrides TfrxReportComponent.DrawHighlight(TCanvas,Extended,Extended,Extended,Extended,TColor).)
DrawLine(Integer,Integer,Integer,Integer,Integer) | Represents method DrawLine(Integer,Integer,Integer,Integer,Integer). (Inherited from TfrxView.)
DrawSegment(TCanvas,Integer) | Represents method DrawSegment(TCanvas,Integer).
DrawSizeBox(TCanvas,Extended,Boolean) | Draws size boxes around report objects in the report designer. (Inherited from TfrxReportComponent.)
DrawWithChilds(TCanvas,Extended,Extended,Extended,Extended,Boolean,Boolean) | Reserved. Not implemented. (Inherited from TfrxReportComponent.)
ExpandVariables(String) | Represents method ExpandVariables(String). (Inherited from TfrxView.)
ExportInternal(TfrxCustomExportFilter) | Export engine calls this method before process object inside export filter. If this method returns true, object processed by itself and default method will not call. (Inherited from TfrxComponent.)
FindDataSet(TfrxDataSet,String) | Looking for data set with filename specified. The result of search depends on flag state Tfrxreport Engine options .Use Grobal data set list. If the flag is installed in True ,then search is realized in Grobal data set list , otherwuise in TfrxReport list . Enabled data sets. (Inherited from TfrxComponent.)
FindObject(String) | Searches for an object with specified name among the child objects. (Inherited from TfrxComponent.)
FontChanged(TObject) | Represents method FontChanged(TObject). (Inherited from TfrxComponent.)
GetChildOwner | Represents method GetChildOwner. (Inherited from TfrxComponent.)
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent). (Inherited from TfrxComponent.)
GetClientArea | Return client area of object. (Inherited from TfrxComponent.)
GetComponentText | Returns text of the report object. Used in export filters. (Inherited from TfrxReportComponent.)
GetContainedComponent(Extended,Extended,TfrxComponent) | Returns top-most object which contain point at passed coordinates (Inherited from TfrxComponent.)
GetContainedComponents(TfrxRect,TClass,TList,Boolean) | Returns objects inside rectangle area with class type inherit from specified class type. (Inherited from TfrxComponent.)
GetContainerObjects | Represents method GetContainerObjects. (Inherited from TfrxComponent.)
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
GetDescription | Get description of the report component. By default returns class name. (Inherited from TfrxComponent.)
GetDrawTextObject | Returns object used to draw and calculate text bounds. For objects with report components it returns object owned by report. otherwise global frxDrawText. (Inherited from TfrxComponent.)
GetExportBounds | Returns object bounds for export filtes. (Inherited from TfrxView.)
GetGlobalReport | Method returns topmost report component for prepared report or report template (preview pages are not owned by report object and 'Report' property returns nil for them). (Inherited from TfrxComponent.)
GetRealBounds | Deprecated. Returns real size of object. (Inherited from TfrxReportComponent.)
GetRestrictions | Represents method GetRestrictions. (Inherited from TfrxComponent.)
GetSaveToComponent | Returns component with part of the data of the current (by default returns Self). Used in split mechanism when one object breaks to several parts. The component should be prepared by DrawPart method. Engine adds this object to preview pages. (Inherited from TfrxReportComponent.)
GetScaleFactor(Extended,Extended) | Deprecated. Used to get scale factor of object content for export filters. (Inherited from TfrxView.)
GetScreenScale(Extended,Extended) | Represents method GetScreenScale(Extended,Extended). (Inherited from TfrxView.)
GetVectorCanvas | Returns TVectorCanvas used for export engine. (Inherited from TfrxView.)
GetVectorGraphic(Boolean) | Returns vector graphic image derived from TGraphic (Currently supports meta file) with object output on it. (Inherited from TfrxView.)
InintComponentInPlaceEditor(TfrxInteractiveEventsParams) | Represents method InintComponentInPlaceEditor(TfrxInteractiveEventsParams). (Inherited from TfrxComponent.)
InteractiveDraw(TCanvas,Extended,Extended,Extended,Extended,Boolean,TColor) | Used from the report designer and preview calls Draw/DrawHighlight. (Inherited from TfrxReportComponent.)
InternalDiff(TfrxComponent) | Represents method InternalDiff(TfrxComponent). (Inherited from TfrxComponent.)
IsAcceptAsChild(TfrxComponent) | Returns true when component in aParent can be accepted as parent for current. (Overrides TfrxComponent.IsAcceptAsChild(TfrxComponent).)
IsAcceptControl(TfrxComponent) | Returns true when component can accept component in aControl as child. (Inherited from TfrxComponent.)
IsAcceptControls | Represents method IsAcceptControls. (Inherited from TfrxComponent.)
IsContain(Extended,Extended) | Detects if point is inside an object coordinates. (Inherited from TfrxComponent.)
IsDataField | Returns True when report object has assigned DataSet and DataField. (Inherited from TfrxView.)
IsEMFExportable | Through this method objects tell the export engine that it allows export via meta file output. When function returns False object will be exported as picture or via native processing(if supported). (Inherited from TfrxView.)
IsHeightStored | Represents method IsHeightStored. (Inherited from TfrxComponent.)
IsIndexTagStored | Represents method IsIndexTagStored. (Inherited from TfrxComponent.)
IsInRect(TfrxRect) | Returns True if part of object bounds is inside source rectangle. (Inherited from TfrxComponent.)
IsLeftStored | Represents method IsLeftStored. (Inherited from TfrxComponent.)
IsOwnerDraw | Returns True when parent container should draw child. (Inherited from TfrxReportComponent.)
IsPostProcessAllowed | Return True when post processing for current object is enabled (Default ProcessAt <> paDefault). (Inherited from TfrxView.)
IsTopStored | Represents method IsTopStored. (Inherited from TfrxComponent.)
IsWidthStored | Represents method IsWidthStored. (Inherited from TfrxComponent.)
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Method loads data from post-processor item (aItem) to current object based on index stored before during SaveContentToDictionary function call. (Inherited from TfrxView.)
LoadFromStream(TStream) | Loads object contents and all its child objects from the stream. (Inherited from TfrxComponent.)
LockAnchorsUpdate | Represents method LockAnchorsUpdate. (Inherited from TfrxComponent.)
MirrorContent(TfrxMirrorControlModes) | Represents method MirrorContent(TfrxMirrorControlModes). (Overrides TfrxComponent.MirrorContent(TfrxMirrorControlModes).)
MouseClick(Boolean,TfrxInteractiveEventsParams) | Generates mouse click event for report object. (Inherited from TfrxComponent.)
MouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse down event for report object. (Inherited from TfrxComponent.)
MouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse enter event for report object. (Inherited from TfrxComponent.)
MouseLeave(Integer,Integer,TfrxComponent,TfrxInteractiveEventsParams) | Generates mouse leave event for report object. (Inherited from TfrxComponent.)
MouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Generates mouse move event for report object. (Inherited from TfrxComponent.)
MouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Generates mouse up event for report object. (Inherited from TfrxComponent.)
MouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Generates mouse wheel event for report object. (Inherited from TfrxComponent.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Inherited from TfrxView.)
ObjectListNotify(Pointer,TListNotification) | Represents method ObjectListNotify(Pointer,TListNotification). (Inherited from TfrxComponent.)
OnNotify(TObject) | The report engine notifies all objects after show band. Used only for Chart object with dtBandData type. (Inherited from TfrxComponent.)
OnPaste | Object receives message when users paste report object in the report designer. Old method. (Inherited from TfrxComponent.)
PaintPolyline(TCanvas,TPoint[]) | Represents method PaintPolyline(TCanvas,TPoint[]).
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | The report engine call this method when event specified in Processing.ProcessAt occurs. It retrieves saved expression from PostProcessor by index saved during SaveContentToDictionary call and calculates expression(calls to GetData). The result saves back to PostProcessor for future use in LoadContentFromDictionary. (Inherited from TfrxView.)
ReadNestedProperty(TfrxXMLItem) | The serializer calls this method when read nested(composite) non published object. Used with csHandlesNestedProperties flag to read XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | This method used by the report engine when adds object to preview pages when object has post-processing enabled. It should save expression from current object in PostProcessor instance and save returned index in current object. (Inherited from TfrxView.)
SaveToStream(TStream,Boolean,Boolean,Boolean) | Saves an object to the stream. The SaveChildren parameter defines,whether state of all child objects should also be saved. TheSaveDefaultValues parameter defines, whether to save properties thathave default values. (Inherited from TfrxComponent.)
SetAnchors(TfrxAnchors) | Represents method SetAnchors(TfrxAnchors). (Inherited from TfrxComponent.)
SetBounds(Extended,Extended,Extended,Extended) | Sets coordinates and size of an object. (Inherited from TfrxComponent.)
SetDigitCount(Integer) | Represents method SetDigitCount(Integer).
SetFont(TFont) | Represents method SetFont(TFont). (Inherited from TfrxComponent.)
SetHeight(Extended) | Represents method SetHeight(Extended). (Inherited from TfrxComponent.)
SetIsSelected(Boolean) | Represents method SetIsSelected(Boolean). (Inherited from TfrxComponent.)
SetKind(TZipCodeKind) | Represents method SetKind(TZipCodeKind).
SetLeft(Extended) | Represents method SetLeft(Extended). (Inherited from TfrxComponent.)
SetmmDigitHeight(Extended) | Represents method SetmmDigitHeight(Extended).
SetmmDigitWidth(Extended) | Represents method SetmmDigitWidth(Extended).
SetmmLineWidth(Extended) | Represents method SetmmLineWidth(Extended).
SetmmSpacing(Extended) | Represents method SetmmSpacing(Extended).
SetName(TComponentName) | Represents method SetName(TComponentName). (Inherited from TfrxComponent.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxComponent.)
SetParentFont(Boolean) | Represents method SetParentFont(Boolean). (Inherited from TfrxComponent.)
SetShowGrid(Boolean) | Represents method SetShowGrid(Boolean).
SetShowMarkers(Boolean) | Represents method SetShowMarkers(Boolean).
SetText(String) | Represents method SetText(String).
SetTop(Extended) | Represents method SetTop(Extended). (Inherited from TfrxComponent.)
SetVisible(Boolean) | Represents method SetVisible(Boolean). (Inherited from TfrxComponent.)
SetWidth(Extended) | Represents method SetWidth(Extended). (Inherited from TfrxComponent.)
ShadowSize | Calculates size of dropped shadows. (Inherited from TfrxView.)
ThreadSynchronize(TThreadMethod) | Represents method ThreadSynchronize(TThreadMethod). (Inherited from TfrxComponent.)
UnlockAnchorsUpdate | Represents method UnlockAnchorsUpdate. (Inherited from TfrxComponent.)
UpdateAnchors(Extended,Extended) | Represents method UpdateAnchors(Extended,Extended). (Inherited from TfrxComponent.)
UpdateBounds | Used to validate object real bounds. (Inherited from TfrxComponent.)
WriteNestedProperties(TfrxXMLItem,TPersistent) | The serializer calls this method when write nested(composite) non published object. Used with csHandlesNestedProperties flag to write XML representation of an object instead of binary stream(PropData). (Inherited from TfrxComponent.)
Top
Fields
Show:
Name | Description
F1mm | Represents field F1mm.
FAliasName | Represents field FAliasName. (Inherited from TfrxComponent.)
FAncestor | Represents field FAncestor. (Inherited from TfrxComponent.)
FBaseName | Represents field FBaseName. (Inherited from TfrxComponent.)
FCanvas | Represents field FCanvas. (Inherited from TfrxView.)
FColor | Represents field FColor.
FComponentEditors | Represents field FComponentEditors. (Inherited from TfrxComponent.)
FDigitCount | Represents field FDigitCount.
FDigitHeight | Represents field FDigitHeight.
FDigitLeftTop | Represents field FDigitLeftTop.
FDigitPenThickness | Represents field FDigitPenThickness.
FDigitWidth | Represents field FDigitWidth.
FDrawFillOnMetaFile | Represents field FDrawFillOnMetaFile. (Inherited from TfrxView.)
FDX | Represents field FDX. (Inherited from TfrxView.)
FDY | Represents field FDY. (Inherited from TfrxView.)
FExpression | Represents field FExpression.
FFrameWidth | Represents field FFrameWidth. (Inherited from TfrxView.)
FGridPoint | Represents field FGridPoint.
FGridStep | Represents field FGridStep.
FHighlighted | Represents field FHighlighted. (Inherited from TfrxComponent.)
FKind | Represents field FKind.
FMarker | Represents field FMarker.
FMarkerHeight | Represents field FMarkerHeight.
FMarkerWidth | Represents field FMarkerWidth.
FmmDigitHeight | Represents field FmmDigitHeight.
FmmDigitWidth | Represents field FmmDigitWidth.
FmmLineWidth | Represents field FmmLineWidth.
FmmSpacing | Represents field FmmSpacing.
FObjAsMetafile | Represents field FObjAsMetafile. (Inherited from TfrxView.)
FOffsetX | Represents field FOffsetX. (Inherited from TfrxView.)
FOffsetY | Represents field FOffsetY. (Inherited from TfrxView.)
FOriginalBand | Represents field FOriginalBand. (Inherited from TfrxComponent.)
FOriginalComponent | Represents field FOriginalComponent. (Inherited from TfrxComponent.)
FOriginalObjectsCount | Used for TfrxSubReport.PrintOnParent. Internal use only. (Inherited from TfrxReportComponent.)
FOriginalRect | Represents field FOriginalRect. (Inherited from TfrxComponent.)
FParent | Represents field FParent. (Inherited from TfrxComponent.)
FProcessing | Represents field FProcessing. (Inherited from TfrxView.)
FScaleX | Represents field FScaleX. (Inherited from TfrxView.)
FScaleY | Represents field FScaleY. (Inherited from TfrxView.)
FSerializedItem | Represents field FSerializedItem. (Inherited from TfrxComponent.)
FShiftObject | Used in new shift mechanism, stores shift tree or list. Internal use only. (Inherited from TfrxReportComponent.)
FShowGrid | Represents field FShowGrid.
FShowMarkers | Represents field FShowMarkers.
FSpacing | Represents field FSpacing.
FText | Represents field FText.
FVC | Represents field FVC. (Inherited from TfrxView.)
FX | Represents field FX. (Inherited from TfrxView.)
FX1 | Represents field FX1. (Inherited from TfrxView.)
FY | Represents field FY. (Inherited from TfrxView.)
FY1 | Represents field FY1. (Inherited from TfrxView.)
Top
See Also

Reference

  • frxZipCode


TfrxZipCodeView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxZipCodeView class. (Overrides TfrxView.Create(TComponent).)
Top


TfrxZipCodeView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxZipCodeView class.

Namespace: frxZipCode
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxView.Create(TComponent)
See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView Properties

Properties
Name | Description
Color | Represents property Color.
Cursor | Represents property Cursor.
DataField | Represents property DataField.
DataSet | Represents property DataSet.
DataSetName | Represents property DataSetName.
DigitCount | Represents property DigitCount.
Expression | Represents property Expression.
Fill | Represents property Fill.
FillType | Represents property FillType.
Kind | Represents property Kind.
mmDigitHeight | Represents property mmDigitHeight.
mmDigitWidth | Represents property mmDigitWidth.
mmLineWidth | Represents property mmLineWidth.
mmSpacing | Represents property mmSpacing.
ShowGrid | Represents property ShowGrid.
ShowMarkers | Represents property ShowMarkers.
Text | Represents property Text.
Top


TfrxZipCodeView.Color Property

Summary

Represents property Color.

Namespace: frxZipCode
Syntax
Delphi
published
 property Color: TColor read FColor write FColor;

Property Value

Type: TColor

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.Cursor Property

Summary

Represents property Cursor.

Namespace: frxZipCode
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.DataField Property

Summary

Represents property DataField.

Namespace: frxZipCode
Syntax
Delphi
published
 property DataField;

Property Value

Type: Void

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.DataSet Property

Summary

Represents property DataSet.

Namespace: frxZipCode
Syntax
Delphi
published
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxZipCode
Syntax
Delphi
published
 property DataSetName;

Property Value

Type: Void

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.DigitCount Property

Summary

Represents property DigitCount.

Namespace: frxZipCode
Syntax
Delphi
published
 property DigitCount: Integer read FDigitCount write SetDigitCount;

Property Value

Type: Integer

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.Expression Property

Summary

Represents property Expression.

Namespace: frxZipCode
Syntax
Delphi
published
 property Expression: String read FExpression write FExpression;

Property Value

Type: String

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.Fill Property

Summary

Represents property Fill.

Namespace: frxZipCode
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FillType Property

Summary

Represents property FillType.

Namespace: frxZipCode
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.Kind Property

Summary

Represents property Kind.

Namespace: frxZipCode
Syntax
Delphi
published
 property Kind: TZipCodeKind read FKind write SetKind;

Property Value

Type: TZipCodeKind

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.mmDigitHeight Property

Summary

Represents property mmDigitHeight.

Namespace: frxZipCode
Syntax
Delphi
published
 property mmDigitHeight: Extended read FmmDigitHeight write SetmmDigitHeight;

Property Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.mmDigitWidth Property

Summary

Represents property mmDigitWidth.

Namespace: frxZipCode
Syntax
Delphi
published
 property mmDigitWidth: Extended read FmmDigitWidth write SetmmDigitWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.mmLineWidth Property

Summary

Represents property mmLineWidth.

Namespace: frxZipCode
Syntax
Delphi
published
 property mmLineWidth: Extended read FmmLineWidth write SetmmLineWidth;

Property Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.mmSpacing Property

Summary

Represents property mmSpacing.

Namespace: frxZipCode
Syntax
Delphi
published
 property mmSpacing: Extended read FmmSpacing write SetmmSpacing;

Property Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.ShowGrid Property

Summary

Represents property ShowGrid.

Namespace: frxZipCode
Syntax
Delphi
published
 property ShowGrid: Boolean read FShowGrid write SetShowGrid;

Property Value

Type: Boolean

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.ShowMarkers Property

Summary

Represents property ShowMarkers.

Namespace: frxZipCode
Syntax
Delphi
published
 property ShowMarkers: Boolean read FShowMarkers write SetShowMarkers;

Property Value

Type: Boolean

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.Text Property

Summary

Represents property Text.

Namespace: frxZipCode
Syntax
Delphi
published
 property Text: String read FText write SetText;

Property Value

Type: String

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView Methods

Methods
Name | Description
Draw(TCanvas,Extended,Extended,Extended,Extended) | The Draw method is called when painting an object. (Overrides TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended).)
DrawSegment(TCanvas,Integer) | Represents method DrawSegment(TCanvas,Integer).
GetData | The report engine calls this method to get Data inside object or calculate expressions. (Overrides TfrxView.GetData.)
PaintPolyline(TCanvas,TPoint[]) | Represents method PaintPolyline(TCanvas,TPoint[]).
SetDigitCount(Integer) | Represents method SetDigitCount(Integer).
SetKind(TZipCodeKind) | Represents method SetKind(TZipCodeKind).
SetmmDigitHeight(Extended) | Represents method SetmmDigitHeight(Extended).
SetmmDigitWidth(Extended) | Represents method SetmmDigitWidth(Extended).
SetmmLineWidth(Extended) | Represents method SetmmLineWidth(Extended).
SetmmSpacing(Extended) | Represents method SetmmSpacing(Extended).
SetShowGrid(Boolean) | Represents method SetShowGrid(Boolean).
SetShowMarkers(Boolean) | Represents method SetShowMarkers(Boolean).
SetText(String) | Represents method SetText(String).
Top


TfrxZipCodeView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

The Draw method is called when painting an object.

Namespace: frxZipCode
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

Canvas

ScaleX
Type: Extended

Zoom by X-axis.

ScaleY
Type: Extended

Zoom by Y-axis.

OffsetX
Type: Extended

X offset relatively to the edges of the canvas.

OffsetY
Type: Extended

Y offset relatively to the edges of the canvas.

Overrides

TfrxView.Draw(TCanvas,Extended,Extended,Extended,Extended)
See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.DrawSegment(TCanvas,Integer) Method

Summary

Represents method DrawSegment(TCanvas,Integer).

Namespace: frxZipCode
Syntax
Delphi
protected
 procedure DrawSegment(Canvas: TCanvas; Number: Integer);

Parameters

Canvas
Type: TCanvas

Number
Type: Integer

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.GetData Method

Summary

The report engine calls this method to get Data inside object or calculate expressions.

Namespace: frxZipCode
Syntax
Delphi
public
 procedure GetData; override;

Overrides

TfrxView.GetData
See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.PaintPolyline(TCanvas,TPoint[]) Method

Summary

Represents method PaintPolyline(TCanvas,TPoint[]).

Namespace: frxZipCode
Syntax
Delphi
protected
 procedure PaintPolyline(Canvas: TCanvas; const Ps: array of TPoint);

Parameters

Canvas
Type: TCanvas

Ps
Type: array of TPoint

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.SetDigitCount(Integer) Method

Summary

Represents method SetDigitCount(Integer).

Namespace: frxZipCode
Syntax
Delphi
private
 procedure SetDigitCount(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.SetKind(TZipCodeKind) Method

Summary

Represents method SetKind(TZipCodeKind).

Namespace: frxZipCode
Syntax
Delphi
private
 procedure SetKind(const Value: TZipCodeKind);

Parameters

Value
Type: TZipCodeKind

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.SetmmDigitHeight(Extended) Method

Summary

Represents method SetmmDigitHeight(Extended).

Namespace: frxZipCode
Syntax
Delphi
private
 procedure SetmmDigitHeight(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.SetmmDigitWidth(Extended) Method

Summary

Represents method SetmmDigitWidth(Extended).

Namespace: frxZipCode
Syntax
Delphi
private
 procedure SetmmDigitWidth(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.SetmmLineWidth(Extended) Method

Summary

Represents method SetmmLineWidth(Extended).

Namespace: frxZipCode
Syntax
Delphi
private
 procedure SetmmLineWidth(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.SetmmSpacing(Extended) Method

Summary

Represents method SetmmSpacing(Extended).

Namespace: frxZipCode
Syntax
Delphi
private
 procedure SetmmSpacing(const Value: Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.SetShowGrid(Boolean) Method

Summary

Represents method SetShowGrid(Boolean).

Namespace: frxZipCode
Syntax
Delphi
private
 procedure SetShowGrid(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.SetShowMarkers(Boolean) Method

Summary

Represents method SetShowMarkers(Boolean).

Namespace: frxZipCode
Syntax
Delphi
private
 procedure SetShowMarkers(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.SetText(String) Method

Summary

Represents method SetText(String).

Namespace: frxZipCode
Syntax
Delphi
private
 procedure SetText(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView Fields

Fields
Name | Description
F1mm | Represents field F1mm.
FColor | Represents field FColor.
FDigitCount | Represents field FDigitCount.
FDigitHeight | Represents field FDigitHeight.
FDigitLeftTop | Represents field FDigitLeftTop.
FDigitPenThickness | Represents field FDigitPenThickness.
FDigitWidth | Represents field FDigitWidth.
FExpression | Represents field FExpression.
FGridPoint | Represents field FGridPoint.
FGridStep | Represents field FGridStep.
FKind | Represents field FKind.
FMarker | Represents field FMarker.
FMarkerHeight | Represents field FMarkerHeight.
FMarkerWidth | Represents field FMarkerWidth.
FmmDigitHeight | Represents field FmmDigitHeight.
FmmDigitWidth | Represents field FmmDigitWidth.
FmmLineWidth | Represents field FmmLineWidth.
FmmSpacing | Represents field FmmSpacing.
FShowGrid | Represents field FShowGrid.
FShowMarkers | Represents field FShowMarkers.
FSpacing | Represents field FSpacing.
FText | Represents field FText.
Top


TfrxZipCodeView.F1mm Field

Summary

Represents field F1mm.

Namespace: frxZipCode
Syntax
Delphi
protected
 F1mm: TfrxPoint;

Field Value

Type: TfrxPoint

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FColor Field

Summary

Represents field FColor.

Namespace: frxZipCode
Syntax
Delphi
private
 FColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FDigitCount Field

Summary

Represents field FDigitCount.

Namespace: frxZipCode
Syntax
Delphi
private
 FDigitCount: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FDigitHeight Field

Summary

Represents field FDigitHeight.

Namespace: frxZipCode
Syntax
Delphi
protected
 FDigitHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FDigitLeftTop Field

Summary

Represents field FDigitLeftTop.

Namespace: frxZipCode
Syntax
Delphi
protected
 FDigitLeftTop: TfrxPoint;

Field Value

Type: TfrxPoint

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FDigitPenThickness Field

Summary

Represents field FDigitPenThickness.

Namespace: frxZipCode
Syntax
Delphi
protected
 FDigitPenThickness: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FDigitWidth Field

Summary

Represents field FDigitWidth.

Namespace: frxZipCode
Syntax
Delphi
protected
 FDigitWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FExpression Field

Summary

Represents field FExpression.

Namespace: frxZipCode
Syntax
Delphi
private
 FExpression: String;

Field Value

Type: String

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FGridPoint Field

Summary

Represents field FGridPoint.

Namespace: frxZipCode
Syntax
Delphi
protected
 FGridPoint: TfrxPoint;

Field Value

Type: TfrxPoint

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FGridStep Field

Summary

Represents field FGridStep.

Namespace: frxZipCode
Syntax
Delphi
protected
 FGridStep: TfrxPoint;

Field Value

Type: TfrxPoint

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FKind Field

Summary

Represents field FKind.

Namespace: frxZipCode
Syntax
Delphi
private
 FKind: TZipCodeKind;

Field Value

Type: TZipCodeKind

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FMarker Field

Summary

Represents field FMarker.

Namespace: frxZipCode
Syntax
Delphi
protected
 FMarker: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FMarkerHeight Field

Summary

Represents field FMarkerHeight.

Namespace: frxZipCode
Syntax
Delphi
protected
 FMarkerHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FMarkerWidth Field

Summary

Represents field FMarkerWidth.

Namespace: frxZipCode
Syntax
Delphi
protected
 FMarkerWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FmmDigitHeight Field

Summary

Represents field FmmDigitHeight.

Namespace: frxZipCode
Syntax
Delphi
private
 FmmDigitHeight: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FmmDigitWidth Field

Summary

Represents field FmmDigitWidth.

Namespace: frxZipCode
Syntax
Delphi
private
 FmmDigitWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FmmLineWidth Field

Summary

Represents field FmmLineWidth.

Namespace: frxZipCode
Syntax
Delphi
private
 FmmLineWidth: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FmmSpacing Field

Summary

Represents field FmmSpacing.

Namespace: frxZipCode
Syntax
Delphi
private
 FmmSpacing: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FShowGrid Field

Summary

Represents field FShowGrid.

Namespace: frxZipCode
Syntax
Delphi
private
 FShowGrid: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FShowMarkers Field

Summary

Represents field FShowMarkers.

Namespace: frxZipCode
Syntax
Delphi
private
 FShowMarkers: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FSpacing Field

Summary

Represents field FSpacing.

Namespace: frxZipCode
Syntax
Delphi
protected
 FSpacing: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


TfrxZipCodeView.FText Field

Summary

Represents field FText.

Namespace: frxZipCode
Syntax
Delphi
private
 FText: String;

Field Value

Type: String

See Also

Reference

  • TfrxZipCodeView
  • frxZipCode


frxZipCode Enumerations

Enumerations
Name | Description
TZipCodeKind | Represents type TZipCodeKind.
Top


TZipCodeKind Enumeration

Summary

Represents type TZipCodeKind.

Namespace: frxZipCode
Syntax
Delphi
type
 TZipCodeKind = (zcCustom, zcInternational, zcRF, zcSample);

The TZipCodeKind type exposes the following members.

Members
Show:
Name | Description
zcCustom | Represents constant zcCustom.
zcInternational | Represents constant zcInternational.
zcRF | Represents constant zcRF.
zcSample | Represents constant zcSample.
Top
See Also

Reference

  • frxZipCode


frxZLib Namespace

Summary

Represents namespace frxZLib.

Classes
Name | Description
EZCompressionError | Represents type EZCompressionError.
EZDecompressionError | Represents type EZDecompressionError.
EZLibError | Represents type EZLibError.
TCustomZStream | Represents type TCustomZStream.
TZCompressionStream | Represents type TZCompressionStream.
TZDecompressionStream | Represents type TZDecompressionStream.
Top
Records
Name | Description
TZStreamRec | Represents type TZStreamRec.
Top
Enumerations
Name | Description
TZCompressionLevel | Represents type TZCompressionLevel.
Top
Delegates
Name | Description
TZAlloc | Represents type TZAlloc.
TZFree | Represents type TZFree.
Top
Constants
Name | Description
ZLIB_VERSIONS | Represents constant ZLIB_VERSIONS.
Top
Routines
Name | Description
adler32(LongInt,PAnsiChar,Integer) | Represents method adler32(LongInt,PAnsiChar,Integer).
compressBound(LongInt) | Represents method compressBound(LongInt).
crc32(LongInt,PAnsiChar,Integer) | Represents method crc32(LongInt,PAnsiChar,Integer).
deflate(TZStreamRec,Integer) | Represents method deflate(TZStreamRec,Integer).
deflateEnd(TZStreamRec) | Represents method deflateEnd(TZStreamRec).
deflateInit_(TZStreamRec,Integer,PAnsiChar,Integer) | Represents method deflateInit_(TZStreamRec,Integer,PAnsiChar,Integer).
inflate(TZStreamRec,Integer) | Represents method inflate(TZStreamRec,Integer).
inflateEnd(TZStreamRec) | Represents method inflateEnd(TZStreamRec).
inflateInit_(TZStreamRec,PAnsiChar,Integer) | Represents method inflateInit_(TZStreamRec,PAnsiChar,Integer).
ZCompress(Pointer,Integer,Pointer,Integer,TZCompressionLevel) | Represents method ZCompress(Pointer,Integer,Pointer,Integer,TZCompressionLevel).
ZDecompress(Pointer,Integer,Pointer,Integer,Integer) | Represents method ZDecompress(Pointer,Integer,Pointer,Integer,Integer).
Top


frxZLib Classes

Classes
Name | Description
EZCompressionError | Represents type EZCompressionError.
EZDecompressionError | Represents type EZDecompressionError.
EZLibError | Represents type EZLibError.
TCustomZStream | Represents type TCustomZStream.
TZCompressionStream | Represents type TZCompressionStream.
TZDecompressionStream | Represents type TZDecompressionStream.
Top


EZCompressionError Class

Summary

Represents type EZCompressionError.

Namespace: frxZLib
Inheritance Hierarchy
Exception
frxZLib.EZLibError
frxZLib.EZCompressionError
Syntax
Delphi
type
 EZCompressionError = class(EZLibError);
See Also

Reference

  • frxZLib


EZDecompressionError Class

Summary

Represents type EZDecompressionError.

Namespace: frxZLib
Inheritance Hierarchy
Exception
frxZLib.EZLibError
frxZLib.EZDecompressionError
Syntax
Delphi
type
 EZDecompressionError = class(EZLibError);
See Also

Reference

  • frxZLib


EZLibError Class

Summary

Represents type EZLibError.

Namespace: frxZLib
Inheritance Hierarchy
Exception
frxZLib.EZLibError
frxZLib.EZCompressionError
frxZLib.EZDecompressionError
Syntax
Delphi
type
 EZLibError = class(Exception);
See Also

Reference

  • frxZLib


TCustomZStream Class

Summary

Represents type TCustomZStream.

Namespace: frxZLib
Inheritance Hierarchy
TStream
frxZLib.TCustomZStream
frxZLib.TZCompressionStream
frxZLib.TZDecompressionStream
Syntax
Delphi
type
 TCustomZStream = class(TStream)
 end;

The TCustomZStream type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream) | Initializes a new instance of the TCustomZStream class.
Top
Properties
Show:
Name | Description
OnProgress | Represents property OnProgress.
Top
Methods
Show:
Name | Description
DoProgress | Represents method DoProgress.
Top
Fields
Show:
Name | Description
FBuffer | Represents field FBuffer.
FOnProgress | Represents field FOnProgress.
FStream | Represents field FStream.
FStreamPos | Represents field FStreamPos.
FZStream | Represents field FZStream.
Top
See Also

Reference

  • frxZLib


TCustomZStream Constructors

Constructors
Name | Description
Create(TStream) | Initializes a new instance of the TCustomZStream class.
Top


TCustomZStream.Create(TStream) Constructor

Summary

Initializes a new instance of the TCustomZStream class.

Namespace: frxZLib
Syntax
Delphi
protected
 constructor Create(stream: TStream);

Parameters

stream
Type: TStream

See Also

Reference

  • TCustomZStream
  • frxZLib


TCustomZStream Properties

Properties
Name | Description
OnProgress | Represents property OnProgress.
Top


TCustomZStream.OnProgress Property

Summary

Represents property OnProgress.

Namespace: frxZLib
Syntax
Delphi
protected
 property OnProgress: TNotifyEvent read FOnProgress write FOnProgress;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TCustomZStream
  • frxZLib


TCustomZStream Methods

Methods
Name | Description
DoProgress | Represents method DoProgress.
Top


TCustomZStream.DoProgress Method

Summary

Represents method DoProgress.

Namespace: frxZLib
Syntax
Delphi
protected
 procedure DoProgress; dynamic;
See Also

Reference

  • TCustomZStream
  • frxZLib


TCustomZStream Fields

Fields
Name | Description
FBuffer | Represents field FBuffer.
FOnProgress | Represents field FOnProgress.
FStream | Represents field FStream.
FStreamPos | Represents field FStreamPos.
FZStream | Represents field FZStream.
Top


TCustomZStream.FBuffer Field

Summary

Represents field FBuffer.

Namespace: frxZLib
Syntax
Delphi
private
 FBuffer: array[Word] of Byte;

Field Value

Type: array[Word] of Byte

See Also

Reference

  • TCustomZStream
  • frxZLib


TCustomZStream.FOnProgress Field

Summary

Represents field FOnProgress.

Namespace: frxZLib
Syntax
Delphi
private
 FOnProgress: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TCustomZStream
  • frxZLib


TCustomZStream.FStream Field

Summary

Represents field FStream.

Namespace: frxZLib
Syntax
Delphi
private
 FStream: TStream;

Field Value

Type: TStream

See Also

Reference

  • TCustomZStream
  • frxZLib


TCustomZStream.FStreamPos Field

Summary

Represents field FStreamPos.

Namespace: frxZLib
Syntax
Delphi
private
 FStreamPos: Integer;

Field Value

Type: Integer

See Also

Reference

  • TCustomZStream
  • frxZLib


TCustomZStream.FZStream Field

Summary

Represents field FZStream.

Namespace: frxZLib
Syntax
Delphi
private
 FZStream: TZStreamRec;

Field Value

Type: TZStreamRec

See Also

Reference

  • TCustomZStream
  • frxZLib


TZCompressionStream Class

Summary

Represents type TZCompressionStream.

Namespace: frxZLib
Inheritance Hierarchy
TStream
frxZLib.TCustomZStream
frxZLib.TZCompressionStream
Syntax
Delphi
type
 TZCompressionStream = class(TCustomZStream)
 end;

The TZCompressionStream type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream,TZCompressionLevel) | Initializes a new instance of the TZCompressionStream class.
Destroy | Represents the destructor of the TZCompressionStream class.
Top
Properties
Show:
Name | Description
CompressionRate | Represents property CompressionRate.
OnProgress | Represents property OnProgress.
Top
Methods
Show:
Name | Description
DoProgress | Represents method DoProgress. (Inherited from TCustomZStream.)
GetCompressionRate | Represents method GetCompressionRate.
Read(Void,Longint) | Represents method Read(Void,Longint).
Seek(Longint,Word) | Represents method Seek(Longint,Word).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top
See Also

Reference

  • frxZLib


TZCompressionStream Constructors

Constructors
Name | Description
Create(TStream,TZCompressionLevel) | Initializes a new instance of the TZCompressionStream class.
Destroy | Represents the destructor of the TZCompressionStream class.
Top


TZCompressionStream.Create(TStream,TZCompressionLevel) Constructor

Summary

Initializes a new instance of the TZCompressionStream class.

Namespace: frxZLib
Syntax
Delphi
public
 constructor Create(dest: TStream; compressionLevel: TZCompressionLevel = zcDefault);

Parameters

dest
Type: TStream

compressionLevel
Type: TZCompressionLevel

See Also

Reference

  • TZCompressionStream
  • frxZLib


TZCompressionStream.Destroy Destructor

Summary

Represents the destructor of the TZCompressionStream class.

Namespace: frxZLib
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TZCompressionStream
  • frxZLib


TZCompressionStream Properties

Properties
Name | Description
CompressionRate | Represents property CompressionRate.
OnProgress | Represents property OnProgress.
Top


TZCompressionStream.CompressionRate Property

Summary

Represents property CompressionRate.

Namespace: frxZLib
Syntax
Delphi
public
 property CompressionRate: Single read GetCompressionRate;

Property Value

Type: Single

See Also

Reference

  • TZCompressionStream
  • frxZLib


TZCompressionStream.OnProgress Property

Summary

Represents property OnProgress.

Namespace: frxZLib
Syntax
Delphi
public
 property OnProgress;

Property Value

Type: Void

See Also

Reference

  • TZCompressionStream
  • frxZLib


TZCompressionStream Methods

Methods
Name | Description
GetCompressionRate | Represents method GetCompressionRate.
Read(Void,Longint) | Represents method Read(Void,Longint).
Seek(Longint,Word) | Represents method Seek(Longint,Word).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top


TZCompressionStream.GetCompressionRate Method

Summary

Represents method GetCompressionRate.

Namespace: frxZLib
Syntax
Delphi
private
 function GetCompressionRate: Single;

Return Value

Type: Single

See Also

Reference

  • TZCompressionStream
  • frxZLib


TZCompressionStream.Read(Void,Longint) Method

Summary

Represents method Read(Void,Longint).

Namespace: frxZLib
Syntax
Delphi
public
 function Read(var buffer; count: Longint): Longint; override;

Parameters

buffer
Type: System.Void

count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TZCompressionStream
  • frxZLib


TZCompressionStream.Seek(Longint,Word) Method

Summary

Represents method Seek(Longint,Word).

Namespace: frxZLib
Syntax
Delphi
public
 function Seek(offset: Longint; origin: Word): Longint; override;

Parameters

offset
Type: Longint

origin
Type: Word

Return Value

Type: Longint

See Also

Reference

  • TZCompressionStream
  • frxZLib


TZCompressionStream.Write(Void,Longint) Method

Summary

Represents method Write(Void,Longint).

Namespace: frxZLib
Syntax
Delphi
public
 function Write(const buffer; count: Longint): Longint; override;

Parameters

buffer
Type: System.Void

count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TZCompressionStream
  • frxZLib


TZDecompressionStream Class

Summary

Represents type TZDecompressionStream.

Namespace: frxZLib
Inheritance Hierarchy
TStream
frxZLib.TCustomZStream
frxZLib.TZDecompressionStream
Syntax
Delphi
type
 TZDecompressionStream = class(TCustomZStream)
 end;

The TZDecompressionStream type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream) | Initializes a new instance of the TZDecompressionStream class.
Destroy | Represents the destructor of the TZDecompressionStream class.
Top
Properties
Show:
Name | Description
OnProgress | Represents property OnProgress.
Top
Methods
Show:
Name | Description
DoProgress | Represents method DoProgress. (Inherited from TCustomZStream.)
Read(Void,Longint) | Represents method Read(Void,Longint).
Seek(Longint,Word) | Represents method Seek(Longint,Word).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top
See Also

Reference

  • frxZLib


TZDecompressionStream Constructors

Constructors
Name | Description
Create(TStream) | Initializes a new instance of the TZDecompressionStream class.
Destroy | Represents the destructor of the TZDecompressionStream class.
Top


TZDecompressionStream.Create(TStream) Constructor

Summary

Initializes a new instance of the TZDecompressionStream class.

Namespace: frxZLib
Syntax
Delphi
public
 constructor Create(source: TStream);

Parameters

source
Type: TStream

See Also

Reference

  • TZDecompressionStream
  • frxZLib


TZDecompressionStream.Destroy Destructor

Summary

Represents the destructor of the TZDecompressionStream class.

Namespace: frxZLib
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TZDecompressionStream
  • frxZLib


TZDecompressionStream Properties

Properties
Name | Description
OnProgress | Represents property OnProgress.
Top


TZDecompressionStream.OnProgress Property

Summary

Represents property OnProgress.

Namespace: frxZLib
Syntax
Delphi
public
 property OnProgress;

Property Value

Type: Void

See Also

Reference

  • TZDecompressionStream
  • frxZLib


TZDecompressionStream Methods

Methods
Name | Description
Read(Void,Longint) | Represents method Read(Void,Longint).
Seek(Longint,Word) | Represents method Seek(Longint,Word).
Write(Void,Longint) | Represents method Write(Void,Longint).
Top


TZDecompressionStream.Read(Void,Longint) Method

Summary

Represents method Read(Void,Longint).

Namespace: frxZLib
Syntax
Delphi
public
 function Read(var buffer; count: Longint): Longint; override;

Parameters

buffer
Type: System.Void

count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TZDecompressionStream
  • frxZLib


TZDecompressionStream.Seek(Longint,Word) Method

Summary

Represents method Seek(Longint,Word).

Namespace: frxZLib
Syntax
Delphi
public
 function Seek(offset: Longint; origin: Word): Longint; override;

Parameters

offset
Type: Longint

origin
Type: Word

Return Value

Type: Longint

See Also

Reference

  • TZDecompressionStream
  • frxZLib


TZDecompressionStream.Write(Void,Longint) Method

Summary

Represents method Write(Void,Longint).

Namespace: frxZLib
Syntax
Delphi
public
 function Write(const buffer; count: Longint): Longint; override;

Parameters

buffer
Type: System.Void

count
Type: Longint

Return Value

Type: Longint

See Also

Reference

  • TZDecompressionStream
  • frxZLib


frxZLib Records

Records
Name | Description
TZStreamRec | Represents type TZStreamRec.
Top


TZStreamRec Record

Summary

Represents type TZStreamRec.

Namespace: frxZLib
Syntax
Delphi
type
 TZStreamRec = packed record
 end;

The TZStreamRec type exposes the following members.

Fields
Show:
Name | Description
adler | Represents field adler.
avail_in | Represents field avail_in.
avail_out | Represents field avail_out.
data_type | Represents field data_type.
msg | Represents field msg.
next_in | Represents field next_in.
next_out | Represents field next_out.
opaque | Represents field opaque.
reserved | Represents field reserved.
state | Represents field state.
total_in | Represents field total_in.
total_out | Represents field total_out.
zalloc | Represents field zalloc.
zfree | Represents field zfree.
Top
See Also

Reference

  • frxZLib


TZStreamRec Fields

Fields
Name | Description
adler | Represents field adler.
avail_in | Represents field avail_in.
avail_out | Represents field avail_out.
data_type | Represents field data_type.
msg | Represents field msg.
next_in | Represents field next_in.
next_out | Represents field next_out.
opaque | Represents field opaque.
reserved | Represents field reserved.
state | Represents field state.
total_in | Represents field total_in.
total_out | Represents field total_out.
zalloc | Represents field zalloc.
zfree | Represents field zfree.
Top


TZStreamRec.adler Field

Summary

Represents field adler.

Namespace: frxZLib
Syntax
Delphi
public
 adler: Longint;

Field Value

Type: Longint

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.avail_in Field

Summary

Represents field avail_in.

Namespace: frxZLib
Syntax
Delphi
public
 avail_in: Longint;

Field Value

Type: Longint

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.avail_out Field

Summary

Represents field avail_out.

Namespace: frxZLib
Syntax
Delphi
public
 avail_out: Longint;

Field Value

Type: Longint

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.data_type Field

Summary

Represents field data_type.

Namespace: frxZLib
Syntax
Delphi
public
 data_type: Integer;

Field Value

Type: Integer

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.msg Field

Summary

Represents field msg.

Namespace: frxZLib
Syntax
Delphi
public
 msg: PByte;

Field Value

Type: PByte

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.next_in Field

Summary

Represents field next_in.

Namespace: frxZLib
Syntax
Delphi
public
 next_in: PByte;

Field Value

Type: PByte

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.next_out Field

Summary

Represents field next_out.

Namespace: frxZLib
Syntax
Delphi
public
 next_out: PByte;

Field Value

Type: PByte

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.opaque Field

Summary

Represents field opaque.

Namespace: frxZLib
Syntax
Delphi
public
 opaque: Pointer;

Field Value

Type: Pointer

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.reserved Field

Summary

Represents field reserved.

Namespace: frxZLib
Syntax
Delphi
public
 reserved: Longint;

Field Value

Type: Longint

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.state Field

Summary

Represents field state.

Namespace: frxZLib
Syntax
Delphi
public
 state: Pointer;

Field Value

Type: Pointer

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.total_in Field

Summary

Represents field total_in.

Namespace: frxZLib
Syntax
Delphi
public
 total_in: Longint;

Field Value

Type: Longint

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.total_out Field

Summary

Represents field total_out.

Namespace: frxZLib
Syntax
Delphi
public
 total_out: Longint;

Field Value

Type: Longint

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.zalloc Field

Summary

Represents field zalloc.

Namespace: frxZLib
Syntax
Delphi
public
 zalloc: TZAlloc;

Field Value

Type: TZAlloc

See Also

Reference

  • TZStreamRec
  • frxZLib


TZStreamRec.zfree Field

Summary

Represents field zfree.

Namespace: frxZLib
Syntax
Delphi
public
 zfree: TZFree;

Field Value

Type: TZFree

See Also

Reference

  • TZStreamRec
  • frxZLib


frxZLib Enumerations

Enumerations
Name | Description
TZCompressionLevel | Represents type TZCompressionLevel.
Top


TZCompressionLevel Enumeration

Summary

Represents type TZCompressionLevel.

Namespace: frxZLib
Syntax
Delphi
type
 TZCompressionLevel = (zcNone, zcFastest, zcDefault, zcMax);

The TZCompressionLevel type exposes the following members.

Members
Show:
Name | Description
zcDefault | Represents constant zcDefault.
zcFastest | Represents constant zcFastest.
zcMax | Represents constant zcMax.
zcNone | Represents constant zcNone.
Top
See Also

Reference

  • frxZLib


frxZLib Delegates

Delegates
Name | Description
TZAlloc | Represents type TZAlloc.
TZFree | Represents type TZFree.
Top


TZAlloc Delegate

Summary

Represents type TZAlloc.

Namespace: frxZLib
Syntax
Delphi
type
 TZAlloc = function(opaque: Pointer; items, size: Integer): Pointer;
See Also

Reference

  • frxZLib


TZFree Delegate

Summary

Represents type TZFree.

Namespace: frxZLib
Syntax
Delphi
type
 TZFree = procedure(opaque, block: Pointer);
See Also

Reference

  • frxZLib


frxZLib Constants

Constants
Name | Description
ZLIB_VERSIONS | Represents constant ZLIB_VERSIONS.
Top


ZLIB_VERSIONS Constant

Summary

Represents constant ZLIB_VERSIONS.

Namespace: frxZLib
Syntax
Delphi
 ZLIB_VERSIONS = '1.2.1';

Value

Type: string

See Also

Reference

  • frxZLib


frxZLib Routines

Routines
Name | Description
adler32(LongInt,PAnsiChar,Integer) | Represents method adler32(LongInt,PAnsiChar,Integer).
compressBound(LongInt) | Represents method compressBound(LongInt).
crc32(LongInt,PAnsiChar,Integer) | Represents method crc32(LongInt,PAnsiChar,Integer).
deflate(TZStreamRec,Integer) | Represents method deflate(TZStreamRec,Integer).
deflateEnd(TZStreamRec) | Represents method deflateEnd(TZStreamRec).
deflateInit_(TZStreamRec,Integer,PAnsiChar,Integer) | Represents method deflateInit_(TZStreamRec,Integer,PAnsiChar,Integer).
inflate(TZStreamRec,Integer) | Represents method inflate(TZStreamRec,Integer).
inflateEnd(TZStreamRec) | Represents method inflateEnd(TZStreamRec).
inflateInit_(TZStreamRec,PAnsiChar,Integer) | Represents method inflateInit_(TZStreamRec,PAnsiChar,Integer).
ZCompress(Pointer,Integer,Pointer,Integer,TZCompressionLevel) | Represents method ZCompress(Pointer,Integer,Pointer,Integer,TZCompressionLevel).
ZDecompress(Pointer,Integer,Pointer,Integer,Integer) | Represents method ZDecompress(Pointer,Integer,Pointer,Integer,Integer).
Top


adler32(LongInt,PAnsiChar,Integer) Method

Summary

Represents method adler32(LongInt,PAnsiChar,Integer).

Namespace: frxZLib
Syntax
Delphi
function adler32(adler: LongInt; const buf: PAnsiChar; len: Integer): LongInt;

Parameters

adler
Type: LongInt

buf
Type: PAnsiChar

len
Type: Integer

Return Value

Type: LongInt

See Also

Reference

  • frxZLib


compressBound(LongInt) Method

Summary

Represents method compressBound(LongInt).

Namespace: frxZLib
Syntax
Delphi
function compressBound(sourceLen: LongInt): LongInt;

Parameters

sourceLen
Type: LongInt

Return Value

Type: LongInt

See Also

Reference

  • frxZLib


crc32(LongInt,PAnsiChar,Integer) Method

Summary

Represents method crc32(LongInt,PAnsiChar,Integer).

Namespace: frxZLib
Syntax
Delphi
function crc32(crc: LongInt; const buf: PAnsiChar; len: Integer): LongInt;

Parameters

crc
Type: LongInt

buf
Type: PAnsiChar

len
Type: Integer

Return Value

Type: LongInt

See Also

Reference

  • frxZLib


deflate(TZStreamRec,Integer) Method

Summary

Represents method deflate(TZStreamRec,Integer).

Namespace: frxZLib
Syntax
Delphi
function deflate(var strm: TZStreamRec; flush: Integer): Integer; forward;

Parameters

strm
Type: TZStreamRec

flush
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • frxZLib


deflateEnd(TZStreamRec) Method

Summary

Represents method deflateEnd(TZStreamRec).

Namespace: frxZLib
Syntax
Delphi
function deflateEnd(var strm: TZStreamRec): Integer; forward;

Parameters

strm
Type: TZStreamRec

Return Value

Type: Integer

See Also

Reference

  • frxZLib


deflateInit_(TZStreamRec,Integer,PAnsiChar,Integer) Method

Summary

Represents method deflateInit_(TZStreamRec,Integer,PAnsiChar,Integer).

Namespace: frxZLib
Syntax
Delphi
function deflateInit_(var strm: TZStreamRec; level: Integer; version: PAnsiChar;
 recsize: Integer): Integer; forward;

Parameters

strm
Type: TZStreamRec

level
Type: Integer

version
Type: PAnsiChar

recsize
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • frxZLib


inflate(TZStreamRec,Integer) Method

Summary

Represents method inflate(TZStreamRec,Integer).

Namespace: frxZLib
Syntax
Delphi
function inflate(var strm: TZStreamRec; flush: Integer): Integer;forward;

Parameters

strm
Type: TZStreamRec

flush
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • frxZLib


inflateEnd(TZStreamRec) Method

Summary

Represents method inflateEnd(TZStreamRec).

Namespace: frxZLib
Syntax
Delphi
function inflateEnd(var strm: TZStreamRec): Integer; forward;

Parameters

strm
Type: TZStreamRec

Return Value

Type: Integer

See Also

Reference

  • frxZLib


inflateInit_(TZStreamRec,PAnsiChar,Integer) Method

Summary

Represents method inflateInit_(TZStreamRec,PAnsiChar,Integer).

Namespace: frxZLib
Syntax
Delphi
function inflateInit_(var strm: TZStreamRec; version: PAnsiChar;
 recsize: Integer): Integer; forward;

Parameters

strm
Type: TZStreamRec

version
Type: PAnsiChar

recsize
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • frxZLib


ZCompress(Pointer,Integer,Pointer,Integer,TZCompressionLevel) Method

Summary

Represents method ZCompress(Pointer,Integer,Pointer,Integer,TZCompressionLevel).

Namespace: frxZLib
Syntax
Delphi
procedure ZCompress(const inBuffer: Pointer; inSize: Integer;
 out outBuffer: Pointer; out outSize: Integer;
 level: TZCompressionLevel = zcDefault);

Parameters

inBuffer
Type: Pointer

inSize
Type: Integer

outBuffer
Type: Pointer

outSize
Type: Integer

level
Type: TZCompressionLevel

See Also

Reference

  • frxZLib


ZDecompress(Pointer,Integer,Pointer,Integer,Integer) Method

Summary

Represents method ZDecompress(Pointer,Integer,Pointer,Integer,Integer).

Namespace: frxZLib
Syntax
Delphi
procedure ZDecompress(const inBuffer: Pointer; inSize: Integer;
 out outBuffer: Pointer; out outSize: Integer; outEstimate: Integer = 0);

Parameters

inBuffer
Type: Pointer

inSize
Type: Integer

outBuffer
Type: Pointer

outSize
Type: Integer

outEstimate
Type: Integer

See Also

Reference

  • frxZLib


frxDBXX

Namespaces
Name | Description
frxConnWizard | Represents namespace frxConnWizard.
frxCustomDB | Represents namespace frxCustomDB.
frxDBSet | Represents namespace frxDBSet.
Top


frxConnWizard Namespace

Summary

Represents namespace frxConnWizard.

Classes
Name | Description
TfrxConnectionWizardForm | Represents type TfrxConnectionWizardForm.
TfrxDBConnWizard | Represents type TfrxDBConnWizard.
TfrxDBQueryWizard | Represents type TfrxDBQueryWizard.
TfrxDBTableWizard | Represents type TfrxDBTableWizard.
Top


frxConnWizard Classes

Classes
Name | Description
TfrxConnectionWizardForm | Represents type TfrxConnectionWizardForm.
TfrxDBConnWizard | Represents type TfrxDBConnWizard.
TfrxDBQueryWizard | Represents type TfrxDBQueryWizard.
TfrxDBTableWizard | Represents type TfrxDBTableWizard.
Top


TfrxConnectionWizardForm Class

Summary

Represents type TfrxConnectionWizardForm.

Namespace: frxConnWizard
Inheritance Hierarchy
TfrxBaseForm
frxConnWizard.TfrxConnectionWizardForm
Syntax
Delphi
type
 TfrxConnectionWizardForm = class(TfrxBaseForm)
 end;

The TfrxConnectionWizardForm type exposes the following members.

Methods
Show:
Name | Description
BuildSQLBClick(TObject) | Represents method BuildSQLBClick(TObject).
ChooseBClick(TObject) | Represents method ChooseBClick(TObject).
ConnCB1Click(TObject) | Represents method ConnCB1Click(TObject).
ConnCB2Click(TObject) | Represents method ConnCB2Click(TObject).
ConnCBClick(TObject) | Represents method ConnCBClick(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormHide(TObject) | Represents method FormHide(TObject).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
FormShow(TObject) | Represents method FormShow(TObject).
OKBClick(TObject) | Represents method OKBClick(TObject).
ParamsBClick(TObject) | Represents method ParamsBClick(TObject).
UpdateFormPPI(Integer) | Represents method UpdateFormPPI(Integer).
UpdateResouces | Represents method UpdateResouces.
Top
Fields
Show:
Name | Description
BuildSQLB | Represents field BuildSQLB.
CancelB | Represents field CancelB.
ChooseB | Represents field ChooseB.
ConnCB | Represents field ConnCB.
ConnCB1 | Represents field ConnCB1.
ConnCB2 | Represents field ConnCB2.
ConnL1 | Represents field ConnL1.
ConnL2 | Represents field ConnL2.
ConnL3 | Represents field ConnL3.
ConnTS | Represents field ConnTS.
DatabaseE | Represents field DatabaseE.
DBL | Represents field DBL.
FComponent | Represents field FComponent.
FDatabase | Represents field FDatabase.
FDesigner | Represents field FDesigner.
FilterCB | Represents field FilterCB.
FilterE | Represents field FilterE.
FItem | Represents field FItem.
FItemIndex | Represents field FItemIndex.
FMemo | Represents field FMemo.
FOldItem | Represents field FOldItem.
FPage | Represents field FPage.
FQuery | Represents field FQuery.
FReport | Represents field FReport.
FTable | Represents field FTable.
LoginE | Represents field LoginE.
LoginL | Represents field LoginL.
LoginRB | Represents field LoginRB.
OKB | Represents field OKB.
PageControl1 | Represents field PageControl1.
ParamsB | Represents field ParamsB.
PasswordE | Represents field PasswordE.
PasswordL | Represents field PasswordL.
PromptRB | Represents field PromptRB.
QueryL | Represents field QueryL.
QueryTS | Represents field QueryTS.
TableCB | Represents field TableCB.
TableL | Represents field TableL.
TableTS | Represents field TableTS.
ToolBar1 | Represents field ToolBar1.
Top
See Also

Reference

  • frxConnWizard


TfrxConnectionWizardForm Methods

Methods
Name | Description
BuildSQLBClick(TObject) | Represents method BuildSQLBClick(TObject).
ChooseBClick(TObject) | Represents method ChooseBClick(TObject).
ConnCB1Click(TObject) | Represents method ConnCB1Click(TObject).
ConnCB2Click(TObject) | Represents method ConnCB2Click(TObject).
ConnCBClick(TObject) | Represents method ConnCBClick(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormHide(TObject) | Represents method FormHide(TObject).
FormKeyDown(TObject,Word,TShiftState) | Represents method FormKeyDown(TObject,Word,TShiftState).
FormShow(TObject) | Represents method FormShow(TObject).
OKBClick(TObject) | Represents method OKBClick(TObject).
ParamsBClick(TObject) | Represents method ParamsBClick(TObject).
UpdateFormPPI(Integer) | Represents method UpdateFormPPI(Integer).
UpdateResouces | Represents method UpdateResouces.
Top


TfrxConnectionWizardForm.BuildSQLBClick(TObject) Method

Summary

Represents method BuildSQLBClick(TObject).

Namespace: frxConnWizard
Syntax
Delphi
published
 procedure BuildSQLBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ChooseBClick(TObject) Method

Summary

Represents method ChooseBClick(TObject).

Namespace: frxConnWizard
Syntax
Delphi
published
 procedure ChooseBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ConnCB1Click(TObject) Method

Summary

Represents method ConnCB1Click(TObject).

Namespace: frxConnWizard
Syntax
Delphi
published
 procedure ConnCB1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ConnCB2Click(TObject) Method

Summary

Represents method ConnCB2Click(TObject).

Namespace: frxConnWizard
Syntax
Delphi
published
 procedure ConnCB2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ConnCBClick(TObject) Method

Summary

Represents method ConnCBClick(TObject).

Namespace: frxConnWizard
Syntax
Delphi
published
 procedure ConnCBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: frxConnWizard
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FormHide(TObject) Method

Summary

Represents method FormHide(TObject).

Namespace: frxConnWizard
Syntax
Delphi
published
 procedure FormHide(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FormKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method FormKeyDown(TObject,Word,TShiftState).

Namespace: frxConnWizard
Syntax
Delphi
published
 procedure FormKeyDown(Sender: TObject; var Key: Word;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: frxConnWizard
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.OKBClick(TObject) Method

Summary

Represents method OKBClick(TObject).

Namespace: frxConnWizard
Syntax
Delphi
published
 procedure OKBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ParamsBClick(TObject) Method

Summary

Represents method ParamsBClick(TObject).

Namespace: frxConnWizard
Syntax
Delphi
published
 procedure ParamsBClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.UpdateFormPPI(Integer) Method

Summary

Represents method UpdateFormPPI(Integer).

Namespace: frxConnWizard
Syntax
Delphi
public
 procedure UpdateFormPPI(aNewPPI: Integer); override;

Parameters

aNewPPI
Type: Integer

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.UpdateResouces Method

Summary

Represents method UpdateResouces.

Namespace: frxConnWizard
Syntax
Delphi
public
 procedure UpdateResouces; override;
See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm Fields

Fields
Name | Description
BuildSQLB | Represents field BuildSQLB.
CancelB | Represents field CancelB.
ChooseB | Represents field ChooseB.
ConnCB | Represents field ConnCB.
ConnCB1 | Represents field ConnCB1.
ConnCB2 | Represents field ConnCB2.
ConnL1 | Represents field ConnL1.
ConnL2 | Represents field ConnL2.
ConnL3 | Represents field ConnL3.
ConnTS | Represents field ConnTS.
DatabaseE | Represents field DatabaseE.
DBL | Represents field DBL.
FComponent | Represents field FComponent.
FDatabase | Represents field FDatabase.
FDesigner | Represents field FDesigner.
FilterCB | Represents field FilterCB.
FilterE | Represents field FilterE.
FItem | Represents field FItem.
FItemIndex | Represents field FItemIndex.
FMemo | Represents field FMemo.
FOldItem | Represents field FOldItem.
FPage | Represents field FPage.
FQuery | Represents field FQuery.
FReport | Represents field FReport.
FTable | Represents field FTable.
LoginE | Represents field LoginE.
LoginL | Represents field LoginL.
LoginRB | Represents field LoginRB.
OKB | Represents field OKB.
PageControl1 | Represents field PageControl1.
ParamsB | Represents field ParamsB.
PasswordE | Represents field PasswordE.
PasswordL | Represents field PasswordL.
PromptRB | Represents field PromptRB.
QueryL | Represents field QueryL.
QueryTS | Represents field QueryTS.
TableCB | Represents field TableCB.
TableL | Represents field TableL.
TableTS | Represents field TableTS.
ToolBar1 | Represents field ToolBar1.
Top


TfrxConnectionWizardForm.BuildSQLB Field

Summary

Represents field BuildSQLB.

Namespace: frxConnWizard
Syntax
Delphi
published
 BuildSQLB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.CancelB Field

Summary

Represents field CancelB.

Namespace: frxConnWizard
Syntax
Delphi
published
 CancelB: TButton;

Field Value

Type: TButton

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ChooseB Field

Summary

Represents field ChooseB.

Namespace: frxConnWizard
Syntax
Delphi
published
 ChooseB: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ConnCB Field

Summary

Represents field ConnCB.

Namespace: frxConnWizard
Syntax
Delphi
published
 ConnCB: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ConnCB1 Field

Summary

Represents field ConnCB1.

Namespace: frxConnWizard
Syntax
Delphi
published
 ConnCB1: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ConnCB2 Field

Summary

Represents field ConnCB2.

Namespace: frxConnWizard
Syntax
Delphi
published
 ConnCB2: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ConnL1 Field

Summary

Represents field ConnL1.

Namespace: frxConnWizard
Syntax
Delphi
published
 ConnL1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ConnL2 Field

Summary

Represents field ConnL2.

Namespace: frxConnWizard
Syntax
Delphi
published
 ConnL2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ConnL3 Field

Summary

Represents field ConnL3.

Namespace: frxConnWizard
Syntax
Delphi
published
 ConnL3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ConnTS Field

Summary

Represents field ConnTS.

Namespace: frxConnWizard
Syntax
Delphi
published
 ConnTS: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.DatabaseE Field

Summary

Represents field DatabaseE.

Namespace: frxConnWizard
Syntax
Delphi
published
 DatabaseE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.DBL Field

Summary

Represents field DBL.

Namespace: frxConnWizard
Syntax
Delphi
published
 DBL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FComponent Field

Summary

Represents field FComponent.

Namespace: frxConnWizard
Syntax
Delphi
private
 FComponent: TfrxComponent;

Field Value

Type: TfrxComponent

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FDatabase Field

Summary

Represents field FDatabase.

Namespace: frxConnWizard
Syntax
Delphi
private
 FDatabase: TfrxCustomDatabase;

Field Value

Type: TfrxCustomDatabase

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FDesigner Field

Summary

Represents field FDesigner.

Namespace: frxConnWizard
Syntax
Delphi
private
 FDesigner: TfrxCustomDesigner;

Field Value

Type: TfrxCustomDesigner

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FilterCB Field

Summary

Represents field FilterCB.

Namespace: frxConnWizard
Syntax
Delphi
published
 FilterCB: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FilterE Field

Summary

Represents field FilterE.

Namespace: frxConnWizard
Syntax
Delphi
published
 FilterE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FItem Field

Summary

Represents field FItem.

Namespace: frxConnWizard
Syntax
Delphi
private
 FItem: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FItemIndex Field

Summary

Represents field FItemIndex.

Namespace: frxConnWizard
Syntax
Delphi
private
 FItemIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FMemo Field

Summary

Represents field FMemo.

Namespace: frxConnWizard
Syntax
Delphi
private
 FMemo: TfrxSyntaxMemo;

Field Value

Type: TfrxSyntaxMemo

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FOldItem Field

Summary

Represents field FOldItem.

Namespace: frxConnWizard
Syntax
Delphi
private
 FOldItem: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FPage Field

Summary

Represents field FPage.

Namespace: frxConnWizard
Syntax
Delphi
private
 FPage: TfrxPage;

Field Value

Type: TfrxPage

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FQuery Field

Summary

Represents field FQuery.

Namespace: frxConnWizard
Syntax
Delphi
private
 FQuery: TfrxCustomQuery;

Field Value

Type: TfrxCustomQuery

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FReport Field

Summary

Represents field FReport.

Namespace: frxConnWizard
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.FTable Field

Summary

Represents field FTable.

Namespace: frxConnWizard
Syntax
Delphi
private
 FTable: TfrxCustomTable;

Field Value

Type: TfrxCustomTable

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.LoginE Field

Summary

Represents field LoginE.

Namespace: frxConnWizard
Syntax
Delphi
published
 LoginE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.LoginL Field

Summary

Represents field LoginL.

Namespace: frxConnWizard
Syntax
Delphi
published
 LoginL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.LoginRB Field

Summary

Represents field LoginRB.

Namespace: frxConnWizard
Syntax
Delphi
published
 LoginRB: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.OKB Field

Summary

Represents field OKB.

Namespace: frxConnWizard
Syntax
Delphi
published
 OKB: TButton;

Field Value

Type: TButton

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: frxConnWizard
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ParamsB Field

Summary

Represents field ParamsB.

Namespace: frxConnWizard
Syntax
Delphi
published
 ParamsB: TToolButton;

Field Value

Type: TToolButton

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.PasswordE Field

Summary

Represents field PasswordE.

Namespace: frxConnWizard
Syntax
Delphi
published
 PasswordE: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.PasswordL Field

Summary

Represents field PasswordL.

Namespace: frxConnWizard
Syntax
Delphi
published
 PasswordL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.PromptRB Field

Summary

Represents field PromptRB.

Namespace: frxConnWizard
Syntax
Delphi
published
 PromptRB: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.QueryL Field

Summary

Represents field QueryL.

Namespace: frxConnWizard
Syntax
Delphi
published
 QueryL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.QueryTS Field

Summary

Represents field QueryTS.

Namespace: frxConnWizard
Syntax
Delphi
published
 QueryTS: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.TableCB Field

Summary

Represents field TableCB.

Namespace: frxConnWizard
Syntax
Delphi
published
 TableCB: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.TableL Field

Summary

Represents field TableL.

Namespace: frxConnWizard
Syntax
Delphi
published
 TableL: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.TableTS Field

Summary

Represents field TableTS.

Namespace: frxConnWizard
Syntax
Delphi
published
 TableTS: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxConnectionWizardForm.ToolBar1 Field

Summary

Represents field ToolBar1.

Namespace: frxConnWizard
Syntax
Delphi
published
 ToolBar1: TToolBar;

Field Value

Type: TToolBar

See Also

Reference

  • TfrxConnectionWizardForm
  • frxConnWizard


TfrxDBConnWizard Class

Summary

Represents type TfrxDBConnWizard.

Namespace: frxConnWizard
Inheritance Hierarchy
TfrxCustomWizard
frxConnWizard.TfrxDBConnWizard
Syntax
Delphi
type
 TfrxDBConnWizard = class(TfrxCustomWizard)
 end;

The TfrxDBConnWizard type exposes the following members.

Properties
Show:
Name | Description
Database | Represents property Database.
Top
Methods
Show:
Name | Description
Execute | Represents method Execute.
GetDescription | Represents method GetDescription.
Top
Fields
Show:
Name | Description
FDatabase | Represents field FDatabase.
Top
See Also

Reference

  • frxConnWizard


TfrxDBConnWizard Properties

Properties
Name | Description
Database | Represents property Database.
Top


TfrxDBConnWizard.Database Property

Summary

Represents property Database.

Namespace: frxConnWizard
Syntax
Delphi
public
 property Database: TfrxCustomDatabase read FDatabase write FDatabase;

Property Value

Type: TfrxCustomDatabase

See Also

Reference

  • TfrxDBConnWizard
  • frxConnWizard


TfrxDBConnWizard Methods

Methods
Name | Description
Execute | Represents method Execute.
GetDescription | Represents method GetDescription.
Top


TfrxDBConnWizard.Execute Method

Summary

Represents method Execute.

Namespace: frxConnWizard
Syntax
Delphi
public
 function Execute: Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDBConnWizard
  • frxConnWizard


TfrxDBConnWizard.GetDescription Method

Summary

Represents method GetDescription.

Namespace: frxConnWizard
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

See Also

Reference

  • TfrxDBConnWizard
  • frxConnWizard


TfrxDBConnWizard Fields

Fields
Name | Description
FDatabase | Represents field FDatabase.
Top


TfrxDBConnWizard.FDatabase Field

Summary

Represents field FDatabase.

Namespace: frxConnWizard
Syntax
Delphi
private
 FDatabase: TfrxCustomDatabase;

Field Value

Type: TfrxCustomDatabase

See Also

Reference

  • TfrxDBConnWizard
  • frxConnWizard


TfrxDBQueryWizard Class

Summary

Represents type TfrxDBQueryWizard.

Namespace: frxConnWizard
Inheritance Hierarchy
TfrxCustomWizard
frxConnWizard.TfrxDBQueryWizard
Syntax
Delphi
type
 TfrxDBQueryWizard = class(TfrxCustomWizard)
 end;

The TfrxDBQueryWizard type exposes the following members.

Methods
Show:
Name | Description
Execute | Represents method Execute.
GetDescription | Represents method GetDescription.
Top
See Also

Reference

  • frxConnWizard


TfrxDBQueryWizard Methods

Methods
Name | Description
Execute | Represents method Execute.
GetDescription | Represents method GetDescription.
Top


TfrxDBQueryWizard.Execute Method

Summary

Represents method Execute.

Namespace: frxConnWizard
Syntax
Delphi
public
 function Execute: Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDBQueryWizard
  • frxConnWizard


TfrxDBQueryWizard.GetDescription Method

Summary

Represents method GetDescription.

Namespace: frxConnWizard
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

See Also

Reference

  • TfrxDBQueryWizard
  • frxConnWizard


TfrxDBTableWizard Class

Summary

Represents type TfrxDBTableWizard.

Namespace: frxConnWizard
Inheritance Hierarchy
TfrxCustomWizard
frxConnWizard.TfrxDBTableWizard
Syntax
Delphi
type
 TfrxDBTableWizard = class(TfrxCustomWizard)
 end;

The TfrxDBTableWizard type exposes the following members.

Methods
Show:
Name | Description
Execute | Represents method Execute.
GetDescription | Represents method GetDescription.
Top
See Also

Reference

  • frxConnWizard


TfrxDBTableWizard Methods

Methods
Name | Description
Execute | Represents method Execute.
GetDescription | Represents method GetDescription.
Top


TfrxDBTableWizard.Execute Method

Summary

Represents method Execute.

Namespace: frxConnWizard
Syntax
Delphi
public
 function Execute: Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDBTableWizard
  • frxConnWizard


TfrxDBTableWizard.GetDescription Method

Summary

Represents method GetDescription.

Namespace: frxConnWizard
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

See Also

Reference

  • TfrxDBTableWizard
  • frxConnWizard


frxCustomDB Namespace

Summary

Represents namespace frxCustomDB.

Classes
Name | Description
TfrxCustomDataset | The TfrxCustomDataset class is the base class for DB engine components such as TfrxBDETable, based on TDataSet.
TfrxCustomQuery | The TfrxCustomQuery class is the base class for query components of the DB engine.
TfrxCustomTable | The TfrxCustomTable is a base class for table components of a DB engine.
TfrxDBLookupComboBox | The TfrxDBLookupComboBox control represents TDBLookupComboBox control adapter.
TfrxParamItem | The TfrxParamItem represents one query parameter.
TfrxParams | The TfrxParams represents a list of query parameters.
Top
Routines
Name | Description
frxParamsToTParams(TfrxCustomQuery,TParams) | Represents method frxParamsToTParams(TfrxCustomQuery,TParams).
Top


frxCustomDB Classes

Classes
Name | Description
TfrxCustomDataset | The TfrxCustomDataset class is the base class for DB engine components such as TfrxBDETable, based on TDataSet.
TfrxCustomQuery | The TfrxCustomQuery class is the base class for query components of the DB engine.
TfrxCustomTable | The TfrxCustomTable is a base class for table components of a DB engine.
TfrxDBLookupComboBox | The TfrxDBLookupComboBox control represents TDBLookupComboBox control adapter.
TfrxParamItem | The TfrxParamItem represents one query parameter.
TfrxParams | The TfrxParams represents a list of query parameters.
Top


TfrxCustomDataset Class

Summary

The TfrxCustomDataset class is the base class for DB engine components such as TfrxBDETable, based on TDataSet.

Namespace: frxCustomDB
Inheritance Hierarchy
TfrxCustomDBDataset
frxDBSet.TfrxDBDataset
frxCustomDB.TfrxCustomDataset
frxCustomDB.TfrxCustomQuery
frxCustomDB.TfrxCustomTable
Syntax
Delphi
type
 TfrxCustomDataset = class(TfrxDBDataSet)
 end;

The TfrxCustomDataset type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomDataset class.
Destroy | Represents the destructor of the TfrxCustomDataset class.
Top
Properties
Show:
Name | Description
Active | Determines whether the dataset is active.
BCDToCurrency | Converts fields of type BCD to Currency if set to True. (Inherited from TfrxDBDataset.)
DataSet | Represents property DataSet.
DataSource | The data source - TDataSource -> TDataSet. (Inherited from TfrxDBDataset.)
DBConnected | Determines whether the dataset is connected to a Database component.
Fields | Reference to internal TDataSet.Fields.
Filter | The expression used for filtering records in a dataset. It is equivalent to TDataSet.Filter.
Filtered | Determines whether to filter dataset records. It is equivalent to TDataSet.Filtered.
Master | Reference to master dataset (used for master-detail relationships). You also should set up the MasterFields property.
MasterFields | List of linked fields (used for master-detail relationship). List has a form: DetailField=MasterField;...
Top
Methods
Show:
Name | Description
AssignBlobTo(String,TObject) | Represents method AssignBlobTo(String,TObject). (Inherited from TfrxDBDataset.)
Close | Represents method Close. (Inherited from TfrxDBDataset.)
Eof | Represents method Eof. (Inherited from TfrxDBDataset.)
Finalize | Represents method Finalize. (Inherited from TfrxDBDataset.)
First | Represents method First. (Inherited from TfrxDBDataset.)
GetActive | Represents method GetActive.
GetDataSet | Represents method GetDataSet. (Inherited from TfrxDBDataset.)
GetDisplayText(String) | Represents method GetDisplayText(String). (Inherited from TfrxDBDataset.)
GetDisplayWidth(String) | Represents method GetDisplayWidth(String). (Inherited from TfrxDBDataset.)
GetFieldList(TStrings) | Represents method GetFieldList(TStrings). (Inherited from TfrxDBDataset.)
GetFields | Represents method GetFields.
GetFieldType(String) | Represents method GetFieldType(String). (Inherited from TfrxDBDataset.)
GetFilter | Represents method GetFilter.
GetFiltered | Represents method GetFiltered.
GetValue(String) | Represents method GetValue(String). (Inherited from TfrxDBDataset.)
Initialize | Represents method Initialize. (Inherited from TfrxDBDataset.)
InternalSetMaster(TfrxDBDataset) | Represents method InternalSetMaster(TfrxDBDataset).
InternalSetMasterFields(String) | Represents method InternalSetMasterFields(String).
IsBlobField(String) | Represents method IsBlobField(String). (Inherited from TfrxDBDataset.)
IsHasMaster | Represents method IsHasMaster. (Inherited from TfrxDBDataset.)
IsWideMemoBlobField(String) | Represents method IsWideMemoBlobField(String). (Inherited from TfrxDBDataset.)
Next | Represents method Next. (Inherited from TfrxDBDataset.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxDBDataset.Notification(TComponent,TOperation).)
OnPaste | Represents method OnPaste.
Open | Represents method Open. (Inherited from TfrxDBDataset.)
Prior | Represents method Prior. (Inherited from TfrxDBDataset.)
RecordCount | Represents method RecordCount. (Inherited from TfrxDBDataset.)
SetActive(Boolean) | Represents method SetActive(Boolean).
SetFilter(String) | Represents method SetFilter(String).
SetFiltered(Boolean) | Represents method SetFiltered(Boolean).
SetMaster(TDataSource) | Represents method SetMaster(TDataSource).
SetMasterFields(String) | Represents method SetMasterFields(String).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent).
SetUserName(String) | Represents method SetUserName(String).
Top
Fields
Show:
Name | Description
FDataSource | Represents field FDataSource.
FDBConnected | Represents field FDBConnected.
FMaster | Represents field FMaster.
FMasterFields | Represents field FMasterFields.
Top
See Also

Reference

  • frxCustomDB


TfrxCustomDataset Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomDataset class.
Destroy | Represents the destructor of the TfrxCustomDataset class.
Top


TfrxCustomDataset.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomDataset class.

Namespace: frxCustomDB
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomDataset class.

Namespace: frxCustomDB
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset Properties

Properties
Name | Description
Active | Determines whether the dataset is active.
DataSet | Represents property DataSet.
DBConnected | Determines whether the dataset is connected to a Database component.
Fields | Reference to internal TDataSet.Fields.
Filter | The expression used for filtering records in a dataset. It is equivalent to TDataSet.Filter.
Filtered | Determines whether to filter dataset records. It is equivalent to TDataSet.Filtered.
Master | Reference to master dataset (used for master-detail relationships). You also should set up the MasterFields property.
MasterFields | List of linked fields (used for master-detail relationship). List has a form: DetailField=MasterField;...
Top


TfrxCustomDataset.Active Property

Summary

Determines whether the dataset is active.

Namespace: frxCustomDB
Syntax
Delphi
public
 property Active: Boolean read GetActive write SetActive default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.DataSet Property

Summary

Represents property DataSet.

Namespace: frxCustomDB
Syntax
Delphi
protected
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.DBConnected Property

Summary

Determines whether the dataset is connected to a Database component.

Namespace: frxCustomDB
Syntax
Delphi
public
 property DBConnected: Boolean read FDBConnected write FDBConnected;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.Fields Property

Summary

Reference to internal TDataSet.Fields.

Namespace: frxCustomDB
Syntax
Delphi
public
 property Fields: TFields read GetFields;

Property Value

Type: TFields

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.Filter Property

Summary

The expression used for filtering records in a dataset. It is equivalent to TDataSet.Filter.

Namespace: frxCustomDB
Syntax
Delphi
published
 property Filter: String read GetFilter write SetFilter;

Property Value

Type: String

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.Filtered Property

Summary

Determines whether to filter dataset records. It is equivalent to TDataSet.Filtered.

Namespace: frxCustomDB
Syntax
Delphi
published
 property Filtered: Boolean read GetFiltered write SetFiltered default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.Master Property

Summary

Reference to master dataset (used for master-detail relationships). You also should set up the MasterFields property.

Namespace: frxCustomDB
Syntax
Delphi
published
 property Master: TfrxDBDataset read FMaster write InternalSetMaster;

Property Value

Type: TfrxDBDataset

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.MasterFields Property

Summary

List of linked fields (used for master-detail relationship). List has a form: DetailField=MasterField;...

Namespace: frxCustomDB
Syntax
Delphi
public
 property MasterFields: String read FMasterFields write InternalSetMasterFields;

Property Value

Type: String

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset Methods

Methods
Name | Description
GetActive | Represents method GetActive.
GetFields | Represents method GetFields.
GetFilter | Represents method GetFilter.
GetFiltered | Represents method GetFiltered.
InternalSetMaster(TfrxDBDataset) | Represents method InternalSetMaster(TfrxDBDataset).
InternalSetMasterFields(String) | Represents method InternalSetMasterFields(String).
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxDBDataset.Notification(TComponent,TOperation).)
OnPaste | Represents method OnPaste.
SetActive(Boolean) | Represents method SetActive(Boolean).
SetFilter(String) | Represents method SetFilter(String).
SetFiltered(Boolean) | Represents method SetFiltered(Boolean).
SetMaster(TDataSource) | Represents method SetMaster(TDataSource).
SetMasterFields(String) | Represents method SetMasterFields(String).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent).
SetUserName(String) | Represents method SetUserName(String).
Top


TfrxCustomDataset.GetActive Method

Summary

Represents method GetActive.

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetActive: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.GetFields Method

Summary

Represents method GetFields.

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetFields: TFields;

Return Value

Type: TFields

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.GetFilter Method

Summary

Represents method GetFilter.

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetFilter: String;

Return Value

Type: String

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.GetFiltered Method

Summary

Represents method GetFiltered.

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetFiltered: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.InternalSetMaster(TfrxDBDataset) Method

Summary

Represents method InternalSetMaster(TfrxDBDataset).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure InternalSetMaster(const Value: TfrxDBDataSet);

Parameters

Value
Type: TfrxDBDataSet

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.InternalSetMasterFields(String) Method

Summary

Represents method InternalSetMasterFields(String).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure InternalSetMasterFields(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

Overrides

TfrxDBDataset.Notification(TComponent,TOperation)
See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.OnPaste Method

Summary

Represents method OnPaste.

Namespace: frxCustomDB
Syntax
Delphi
public
 procedure OnPaste; override;
See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.SetActive(Boolean) Method

Summary

Represents method SetActive(Boolean).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure SetActive(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.SetFilter(String) Method

Summary

Represents method SetFilter(String).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure SetFilter(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.SetFiltered(Boolean) Method

Summary

Represents method SetFiltered(Boolean).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure SetFiltered(Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.SetMaster(TDataSource) Method

Summary

Represents method SetMaster(TDataSource).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure SetMaster(const Value: TDataSource); virtual;

Parameters

Value
Type: TDataSource

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.SetMasterFields(String) Method

Summary

Represents method SetMasterFields(String).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure SetMasterFields(const Value: String); virtual;

Parameters

Value
Type: String

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.SetParent(TfrxComponent) Method

Summary

Represents method SetParent(TfrxComponent).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure SetParent(AParent: TfrxComponent); override;

Parameters

AParent
Type: TfrxComponent

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.SetUserName(String) Method

Summary

Represents method SetUserName(String).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure SetUserName(const Value: String); override;

Parameters

Value
Type: String

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset Fields

Fields
Name | Description
FDataSource | Represents field FDataSource.
FDBConnected | Represents field FDBConnected.
FMaster | Represents field FMaster.
FMasterFields | Represents field FMasterFields.
Top


TfrxCustomDataset.FDataSource Field

Summary

Represents field FDataSource.

Namespace: frxCustomDB
Syntax
Delphi
private
 FDataSource: TDataSource;

Field Value

Type: TDataSource

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.FDBConnected Field

Summary

Represents field FDBConnected.

Namespace: frxCustomDB
Syntax
Delphi
private
 FDBConnected: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.FMaster Field

Summary

Represents field FMaster.

Namespace: frxCustomDB
Syntax
Delphi
private
 FMaster: TfrxDBDataSet;

Field Value

Type: TfrxDBDataSet

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomDataset.FMasterFields Field

Summary

Represents field FMasterFields.

Namespace: frxCustomDB
Syntax
Delphi
private
 FMasterFields: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomDataset
  • frxCustomDB


TfrxCustomQuery Class

Summary

The TfrxCustomQuery class is the base class for query components of the DB engine.

Namespace: frxCustomDB
Inheritance Hierarchy
TfrxCustomDBDataset
frxDBSet.TfrxDBDataset
frxCustomDB.TfrxCustomDataset
frxCustomDB.TfrxCustomQuery
Syntax
Delphi
type
 TfrxCustomQuery = class(TfrxCustomDataset)
 end;

The TfrxCustomQuery type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomQuery class. (Overrides TfrxCustomDataset.Create(TComponent).)
Destroy | Represents the destructor of the TfrxCustomQuery class. (Overrides TfrxCustomDataset.Destroy.)
Top
Properties
Show:
Name | Description
Active | Determines whether the dataset is active. (Inherited from TfrxCustomDataset.)
BCDToCurrency | Converts fields of type BCD to Currency if set to True. (Inherited from TfrxDBDataset.)
DataSet | Represents property DataSet. (Inherited from TfrxCustomDataset.)
DataSource | The data source - TDataSource -> TDataSet. (Inherited from TfrxDBDataset.)
DBConnected | Determines whether the dataset is connected to a Database component. (Inherited from TfrxCustomDataset.)
Fields | Reference to internal TDataSet.Fields. (Inherited from TfrxCustomDataset.)
Filter | The expression used for filtering records in a dataset. It is equivalent to TDataSet.Filter. (Inherited from TfrxCustomDataset.)
Filtered | Determines whether to filter dataset records. It is equivalent to TDataSet.Filtered. (Inherited from TfrxCustomDataset.)
IgnoreDupParams | If a property set to True, then parameters with similar names are ignored.
Master | Reference to master dataset (used for master-detail relationships). You also should set up the MasterFields property. (Inherited from TfrxCustomDataset.)
MasterFields | List of linked fields (used for master-detail relationship). List has a form: DetailField=MasterField;... (Inherited from TfrxCustomDataset.)
Params | List of query parameters. List of parameters rebuilds automatically when changing SQL query.
SQL | Text of SQL query.
SQLSchema | The SQL schema used in the FastQueryBuilder.
Top
Methods
Show:
Name | Description
AssignBlobTo(String,TObject) | Represents method AssignBlobTo(String,TObject). (Inherited from TfrxDBDataset.)
Close | Represents method Close. (Inherited from TfrxDBDataset.)
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Eof | Represents method Eof. (Inherited from TfrxDBDataset.)
Finalize | Represents method Finalize. (Inherited from TfrxDBDataset.)
First | Represents method First. (Inherited from TfrxDBDataset.)
GetDataSet | Represents method GetDataSet. (Inherited from TfrxDBDataset.)
GetDisplayText(String) | Represents method GetDisplayText(String). (Inherited from TfrxDBDataset.)
GetDisplayWidth(String) | Represents method GetDisplayWidth(String). (Inherited from TfrxDBDataset.)
GetFieldList(TStrings) | Represents method GetFieldList(TStrings). (Inherited from TfrxDBDataset.)
GetFieldType(String) | Represents method GetFieldType(String). (Inherited from TfrxDBDataset.)
GetIgnoreDupParams | Represents method GetIgnoreDupParams.
GetSQL | Represents method GetSQL.
GetValue(String) | Represents method GetValue(String). (Inherited from TfrxDBDataset.)
Initialize | Represents method Initialize. (Inherited from TfrxDBDataset.)
IsBlobField(String) | Represents method IsBlobField(String). (Inherited from TfrxDBDataset.)
IsHasMaster | Represents method IsHasMaster. (Inherited from TfrxDBDataset.)
IsWideMemoBlobField(String) | Represents method IsWideMemoBlobField(String). (Inherited from TfrxDBDataset.)
Next | Represents method Next. (Inherited from TfrxDBDataset.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxDBDataset.Notification(TComponent,TOperation).)
OnBeforeOpen(TDataSet) | Represents method OnBeforeOpen(TDataSet).
OnBeforeRefresh(TDataSet) | Represents method OnBeforeRefresh(TDataSet).
OnChangeSQL(TObject) | Represents method OnChangeSQL(TObject).
OnPaste | Represents method OnPaste. (Inherited from TfrxCustomDataset.)
Open | Represents method Open. (Inherited from TfrxDBDataset.)
ParamByName(String) | Finds a parameter with specified name.
Prior | Represents method Prior. (Inherited from TfrxDBDataset.)
ReadData(TReader) | Represents method ReadData(TReader).
RecordCount | Represents method RecordCount. (Inherited from TfrxDBDataset.)
SetIgnoreDupParams(Boolean) | Represents method SetIgnoreDupParams(Boolean).
SetMaster(TDataSource) | Represents method SetMaster(TDataSource). (Inherited from TfrxCustomDataset.)
SetMasterFields(String) | Represents method SetMasterFields(String). (Inherited from TfrxCustomDataset.)
SetParams(TfrxParams) | Represents method SetParams(TfrxParams).
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxCustomDataset.)
SetSQL(TStrings) | Represents method SetSQL(TStrings).
SetUserName(String) | Represents method SetUserName(String). (Inherited from TfrxCustomDataset.)
UpdateParams | Represents method UpdateParams.
WriteData(TWriter) | Represents method WriteData(TWriter).
Top
Fields
Show:
Name | Description
FParams | Represents field FParams.
FSaveOnBeforeOpen | Represents field FSaveOnBeforeOpen.
FSaveOnBeforeRefresh | Represents field FSaveOnBeforeRefresh.
FSaveOnChange | Represents field FSaveOnChange.
FSQLSchema | Represents field FSQLSchema.
Top
See Also

Reference

  • frxCustomDB


TfrxCustomQuery Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomQuery class. (Overrides TfrxCustomDataset.Create(TComponent).)
Destroy | Represents the destructor of the TfrxCustomQuery class. (Overrides TfrxCustomDataset.Destroy.)
Top


TfrxCustomQuery.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxCustomQuery class.

Namespace: frxCustomDB
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TfrxCustomDataset.Create(TComponent)
See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.Destroy Destructor

Summary

Represents the destructor of the TfrxCustomQuery class.

Namespace: frxCustomDB
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TfrxCustomDataset.Destroy
See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery Properties

Properties
Name | Description
IgnoreDupParams | If a property set to True, then parameters with similar names are ignored.
Params | List of query parameters. List of parameters rebuilds automatically when changing SQL query.
SQL | Text of SQL query.
SQLSchema | The SQL schema used in the FastQueryBuilder.
Top


TfrxCustomQuery.IgnoreDupParams Property

Summary

If a property set to True, then parameters with similar names are ignored.

Namespace: frxCustomDB
Syntax
Delphi
published
 property IgnoreDupParams: Boolean read GetIgnoreDupParams write SetIgnoreDupParams;

Property Value

Type: Boolean

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.Params Property

Summary

List of query parameters. List of parameters rebuilds automatically when changing SQL query.

Namespace: frxCustomDB
Syntax
Delphi
published
 property Params: TfrxParams read FParams write SetParams;

Property Value

Type: TfrxParams

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.SQL Property

Summary

Text of SQL query.

Namespace: frxCustomDB
Syntax
Delphi
published
 property SQL: TStrings read GetSQL write SetSQL;

Property Value

Type: TStrings

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.SQLSchema Property

Summary

The SQL schema used in the FastQueryBuilder.

Namespace: frxCustomDB
Syntax
Delphi
published
 property SQLSchema: String read FSQLSchema write FSQLSchema;

Property Value

Type: String

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery Methods

Methods
Name | Description
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
GetIgnoreDupParams | Represents method GetIgnoreDupParams.
GetSQL | Represents method GetSQL.
OnBeforeOpen(TDataSet) | Represents method OnBeforeOpen(TDataSet).
OnBeforeRefresh(TDataSet) | Represents method OnBeforeRefresh(TDataSet).
OnChangeSQL(TObject) | Represents method OnChangeSQL(TObject).
ParamByName(String) | Finds a parameter with specified name.
ReadData(TReader) | Represents method ReadData(TReader).
SetIgnoreDupParams(Boolean) | Represents method SetIgnoreDupParams(Boolean).
SetParams(TfrxParams) | Represents method SetParams(TfrxParams).
SetSQL(TStrings) | Represents method SetSQL(TStrings).
UpdateParams | Represents method UpdateParams.
WriteData(TWriter) | Represents method WriteData(TWriter).
Top


TfrxCustomQuery.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.GetIgnoreDupParams Method

Summary

Represents method GetIgnoreDupParams.

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetIgnoreDupParams: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.GetSQL Method

Summary

Represents method GetSQL.

Namespace: frxCustomDB
Syntax
Delphi
protected
 function GetSQL: TStrings; virtual;

Return Value

Type: TStrings

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.OnBeforeOpen(TDataSet) Method

Summary

Represents method OnBeforeOpen(TDataSet).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure OnBeforeOpen(DataSet: TDataSet); virtual;

Parameters

DataSet
Type: TDataSet

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.OnBeforeRefresh(TDataSet) Method

Summary

Represents method OnBeforeRefresh(TDataSet).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure OnBeforeRefresh(DataSet: TDataSet); virtual;

Parameters

DataSet
Type: TDataSet

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.OnChangeSQL(TObject) Method

Summary

Represents method OnChangeSQL(TObject).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure OnChangeSQL(Sender: TObject); virtual;

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.ParamByName(String) Method

Summary

Finds a parameter with specified name.

Namespace: frxCustomDB
Syntax
Delphi
public
 function ParamByName(const Value: String): TfrxParamItem;

Parameters

Value
Type: String

Return Value

Type: TfrxParamItem

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.ReadData(TReader) Method

Summary

Represents method ReadData(TReader).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure ReadData(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.SetIgnoreDupParams(Boolean) Method

Summary

Represents method SetIgnoreDupParams(Boolean).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure SetIgnoreDupParams(const Value: Boolean);

Parameters

Value
Type: Boolean

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.SetParams(TfrxParams) Method

Summary

Represents method SetParams(TfrxParams).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure SetParams(Value: TfrxParams);

Parameters

Value
Type: TfrxParams

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.SetSQL(TStrings) Method

Summary

Represents method SetSQL(TStrings).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure SetSQL(Value: TStrings); virtual;

Parameters

Value
Type: TStrings

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.UpdateParams Method

Summary

Represents method UpdateParams.

Namespace: frxCustomDB
Syntax
Delphi
public
 procedure UpdateParams; virtual;
See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.WriteData(TWriter) Method

Summary

Represents method WriteData(TWriter).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure WriteData(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery Fields

Fields
Name | Description
FParams | Represents field FParams.
FSaveOnBeforeOpen | Represents field FSaveOnBeforeOpen.
FSaveOnBeforeRefresh | Represents field FSaveOnBeforeRefresh.
FSaveOnChange | Represents field FSaveOnChange.
FSQLSchema | Represents field FSQLSchema.
Top


TfrxCustomQuery.FParams Field

Summary

Represents field FParams.

Namespace: frxCustomDB
Syntax
Delphi
private
 FParams: TfrxParams;

Field Value

Type: TfrxParams

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.FSaveOnBeforeOpen Field

Summary

Represents field FSaveOnBeforeOpen.

Namespace: frxCustomDB
Syntax
Delphi
private
 FSaveOnBeforeOpen: TDataSetNotifyEvent;

Field Value

Type: TDataSetNotifyEvent

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.FSaveOnBeforeRefresh Field

Summary

Represents field FSaveOnBeforeRefresh.

Namespace: frxCustomDB
Syntax
Delphi
protected
 FSaveOnBeforeRefresh: TDataSetNotifyEvent;

Field Value

Type: TDataSetNotifyEvent

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.FSaveOnChange Field

Summary

Represents field FSaveOnChange.

Namespace: frxCustomDB
Syntax
Delphi
private
 FSaveOnChange: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomQuery.FSQLSchema Field

Summary

Represents field FSQLSchema.

Namespace: frxCustomDB
Syntax
Delphi
private
 FSQLSchema: String;

Field Value

Type: String

See Also

Reference

  • TfrxCustomQuery
  • frxCustomDB


TfrxCustomTable Class

Summary

The TfrxCustomTable is a base class for table components of a DB engine.

Namespace: frxCustomDB
Inheritance Hierarchy
TfrxCustomDBDataset
frxDBSet.TfrxDBDataset
frxCustomDB.TfrxCustomDataset
frxCustomDB.TfrxCustomTable
Syntax
Delphi
type
 TfrxCustomTable = class(TfrxCustomDataset)
 end;

The TfrxCustomTable type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxCustomDataset class. (Inherited from TfrxCustomDataset.)
Top
Properties
Show:
Name | Description
Active | Determines whether the dataset is active. (Inherited from TfrxCustomDataset.)
BCDToCurrency | Converts fields of type BCD to Currency if set to True. (Inherited from TfrxDBDataset.)
DataSet | Represents property DataSet.
DataSource | The data source - TDataSource -> TDataSet. (Inherited from TfrxDBDataset.)
DBConnected | Determines whether the dataset is connected to a Database component. (Inherited from TfrxCustomDataset.)
Fields | Reference to internal TDataSet.Fields. (Inherited from TfrxCustomDataset.)
Filter | The expression used for filtering records in a dataset. It is equivalent to TDataSet.Filter. (Inherited from TfrxCustomDataset.)
Filtered | Determines whether to filter dataset records. It is equivalent to TDataSet.Filtered. (Inherited from TfrxCustomDataset.)
IndexFieldNames | Use IndexFieldNames as an alternative method of specifying the index to use for a table. In IndexFieldNames, specify the name of each column to use as an index for a table. Ordering of column names is significant. Separate names with semicolon.
IndexName | The index name, used for sorting data records.
Master | Reference to master dataset (used for master-detail relationships). You also should set up the MasterFields property. (Inherited from TfrxCustomDataset.)
MasterFields | Represents property MasterFields.
TableName | The table name.
Top
Methods
Show:
Name | Description
AssignBlobTo(String,TObject) | Represents method AssignBlobTo(String,TObject). (Inherited from TfrxDBDataset.)
Close | Represents method Close. (Inherited from TfrxDBDataset.)
Eof | Represents method Eof. (Inherited from TfrxDBDataset.)
Finalize | Represents method Finalize. (Inherited from TfrxDBDataset.)
First | Represents method First. (Inherited from TfrxDBDataset.)
GetDataSet | Represents method GetDataSet. (Inherited from TfrxDBDataset.)
GetDisplayText(String) | Represents method GetDisplayText(String). (Inherited from TfrxDBDataset.)
GetDisplayWidth(String) | Represents method GetDisplayWidth(String). (Inherited from TfrxDBDataset.)
GetFieldList(TStrings) | Represents method GetFieldList(TStrings). (Inherited from TfrxDBDataset.)
GetFieldType(String) | Represents method GetFieldType(String). (Inherited from TfrxDBDataset.)
GetIndexFieldNames | Represents method GetIndexFieldNames.
GetIndexName | Represents method GetIndexName.
GetTableName | Represents method GetTableName.
GetValue(String) | Represents method GetValue(String). (Inherited from TfrxDBDataset.)
Initialize | Represents method Initialize. (Inherited from TfrxDBDataset.)
IsBlobField(String) | Represents method IsBlobField(String). (Inherited from TfrxDBDataset.)
IsHasMaster | Represents method IsHasMaster. (Inherited from TfrxDBDataset.)
IsWideMemoBlobField(String) | Represents method IsWideMemoBlobField(String). (Inherited from TfrxDBDataset.)
Next | Represents method Next. (Inherited from TfrxDBDataset.)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TfrxDBDataset.Notification(TComponent,TOperation).)
OnPaste | Represents method OnPaste. (Inherited from TfrxCustomDataset.)
Open | Represents method Open. (Inherited from TfrxDBDataset.)
Prior | Represents method Prior. (Inherited from TfrxDBDataset.)
RecordCount | Represents method RecordCount. (Inherited from TfrxDBDataset.)
SetIndexFieldNames(String) | Represents method SetIndexFieldNames(String).
SetIndexName(String) | Represents method SetIndexName(String).
SetMaster(TDataSource) | Represents method SetMaster(TDataSource). (Inherited from TfrxCustomDataset.)
SetMasterFields(String) | Represents method SetMasterFields(String). (Inherited from TfrxCustomDataset.)
SetParent(TfrxComponent) | Represents method SetParent(TfrxComponent). (Inherited from TfrxCustomDataset.)
SetTableName(String) | Represents method SetTableName(String).
SetUserName(String) | Represents method SetUserName(String). (Inherited from TfrxCustomDataset.)
Top
See Also

Reference

  • frxCustomDB


TfrxCustomTable Properties

Properties
Name | Description
DataSet | Represents property DataSet.
IndexFieldNames | Use IndexFieldNames as an alternative method of specifying the index to use for a table. In IndexFieldNames, specify the name of each column to use as an index for a table. Ordering of column names is significant. Separate names with semicolon.
IndexName | The index name, used for sorting data records.
MasterFields | Represents property MasterFields.
TableName | The table name.
Top


TfrxCustomTable.DataSet Property

Summary

Represents property DataSet.

Namespace: frxCustomDB
Syntax
Delphi
protected
 property DataSet;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomTable
  • frxCustomDB


TfrxCustomTable.IndexFieldNames Property

Summary

Use IndexFieldNames as an alternative method of specifying the index to use for a table. In IndexFieldNames, specify the name of each column to use as an index for a table. Ordering of column names is significant. Separate names with semicolon.

Namespace: frxCustomDB
Syntax
Delphi
published
 property IndexFieldNames: String read GetIndexFieldNames write SetIndexFieldNames;

Property Value

Type: String

See Also

Reference

  • TfrxCustomTable
  • frxCustomDB


TfrxCustomTable.IndexName Property

Summary

The index name, used for sorting data records.

Namespace: frxCustomDB
Syntax
Delphi
published
 property IndexName: String read GetIndexName write SetIndexName;

Property Value

Type: String

See Also

Reference

  • TfrxCustomTable
  • frxCustomDB


TfrxCustomTable.MasterFields Property

Summary

Represents property MasterFields.

Namespace: frxCustomDB
Syntax
Delphi
published
 property MasterFields;

Property Value

Type: Void

See Also

Reference

  • TfrxCustomTable
  • frxCustomDB


TfrxCustomTable.TableName Property

Summary

The table name.

Namespace: frxCustomDB
Syntax
Delphi
published
 property TableName: String read GetTableName write SetTableName;

Property Value

Type: String

See Also

Reference

  • TfrxCustomTable
  • frxCustomDB


TfrxCustomTable Methods

Methods
Name | Description
GetIndexFieldNames | Represents method GetIndexFieldNames.
GetIndexName | Represents method GetIndexName.
GetTableName | Represents method GetTableName.
SetIndexFieldNames(String) | Represents method SetIndexFieldNames(String).
SetIndexName(String) | Represents method SetIndexName(String).
SetTableName(String) | Represents method SetTableName(String).
Top


TfrxCustomTable.GetIndexFieldNames Method

Summary

Represents method GetIndexFieldNames.

Namespace: frxCustomDB
Syntax
Delphi
protected
 function GetIndexFieldNames: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxCustomTable
  • frxCustomDB


TfrxCustomTable.GetIndexName Method

Summary

Represents method GetIndexName.

Namespace: frxCustomDB
Syntax
Delphi
protected
 function GetIndexName: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxCustomTable
  • frxCustomDB


TfrxCustomTable.GetTableName Method

Summary

Represents method GetTableName.

Namespace: frxCustomDB
Syntax
Delphi
protected
 function GetTableName: String; virtual;

Return Value

Type: String

See Also

Reference

  • TfrxCustomTable
  • frxCustomDB


TfrxCustomTable.SetIndexFieldNames(String) Method

Summary

Represents method SetIndexFieldNames(String).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure SetIndexFieldNames(const Value: String); virtual;

Parameters

Value
Type: String

See Also

Reference

  • TfrxCustomTable
  • frxCustomDB


TfrxCustomTable.SetIndexName(String) Method

Summary

Represents method SetIndexName(String).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure SetIndexName(const Value: String); virtual;

Parameters

Value
Type: String

See Also

Reference

  • TfrxCustomTable
  • frxCustomDB


TfrxCustomTable.SetTableName(String) Method

Summary

Represents method SetTableName(String).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure SetTableName(const Value: String); virtual;

Parameters

Value
Type: String

See Also

Reference

  • TfrxCustomTable
  • frxCustomDB


TfrxDBLookupComboBox Class

Summary

The TfrxDBLookupComboBox control represents TDBLookupComboBox control adapter.

Namespace: frxCustomDB
Inheritance Hierarchy
TfrxDialogControl
frxCustomDB.TfrxDBLookupComboBox
Syntax
Delphi
type
 TfrxDBLookupComboBox = class(TfrxDialogControl)
 end;

The TfrxDBLookupComboBox type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDBLookupComboBox class.
Destroy | Represents the destructor of the TfrxDBLookupComboBox class.
Top
Properties
Show:
Name | Description
AutoOpenDataSet | If a property is set to True , then during execution FastReport will try to open the attached data source.
DataSet | Dataset which the control is connected to.
DataSetName | Name of dataset, which the control is connected to. This property duplicates the DataSet property.
DBLookupComboBox | Reference to internal TDBLookupComboBox object.
DropDownRows | Represents property DropDownRows.
DropDownWidth | Represents property DropDownWidth.
KeyField | Name of DB field that will represent the key field.
KeyValue | Value of key field that was selected in the control.
ListField | Name of DB field that will be shown in the control.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
Text | Value of list field that was selected in the control.
Top
Methods
Show:
Name | Description
BeforeStartReport | Represents method BeforeStartReport.
GetDataSetName | Represents method GetDataSetName.
GetDescription | Represents method GetDescription.
GetDropDownRows | Represents method GetDropDownRows.
GetDropDownWidth | Represents method GetDropDownWidth.
GetKeyField | Represents method GetKeyField.
GetKeyValue | Represents method GetKeyValue.
GetListField | Represents method GetListField.
GetText | Represents method GetText.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
OnOpenDS(TObject) | Represents method OnOpenDS(TObject).
SetDataSet(TfrxDBDataset) | Represents method SetDataSet(TfrxDBDataset).
SetDataSetName(String) | Represents method SetDataSetName(String).
SetDropDownRows(Integer) | Represents method SetDropDownRows(Integer).
SetDropDownWidth(Integer) | Represents method SetDropDownWidth(Integer).
SetKeyField(String) | Represents method SetKeyField(String).
SetKeyValue(Variant) | Represents method SetKeyValue(Variant).
SetListField(String) | Represents method SetListField(String).
UpdateDataSet | Represents method UpdateDataSet.
Top
Fields
Show:
Name | Description
FAutoOpenDataSet | Represents field FAutoOpenDataSet.
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
FDataSource | Represents field FDataSource.
FDBLookupComboBox | Represents field FDBLookupComboBox.
Top
See Also

Reference

  • frxCustomDB


TfrxDBLookupComboBox Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxDBLookupComboBox class.
Destroy | Represents the destructor of the TfrxDBLookupComboBox class.
Top


TfrxDBLookupComboBox.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxDBLookupComboBox class.

Namespace: frxCustomDB
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.Destroy Destructor

Summary

Represents the destructor of the TfrxDBLookupComboBox class.

Namespace: frxCustomDB
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox Properties

Properties
Name | Description
AutoOpenDataSet | If a property is set to True , then during execution FastReport will try to open the attached data source.
DataSet | Dataset which the control is connected to.
DataSetName | Name of dataset, which the control is connected to. This property duplicates the DataSet property.
DBLookupComboBox | Reference to internal TDBLookupComboBox object.
DropDownRows | Represents property DropDownRows.
DropDownWidth | Represents property DropDownWidth.
KeyField | Name of DB field that will represent the key field.
KeyValue | Value of key field that was selected in the control.
ListField | Name of DB field that will be shown in the control.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnKeyDown | Represents property OnKeyDown.
OnKeyPress | Represents property OnKeyPress.
OnKeyUp | Represents property OnKeyUp.
OnMouseDown | Represents property OnMouseDown.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
Text | Value of list field that was selected in the control.
Top


TfrxDBLookupComboBox.AutoOpenDataSet Property

Summary

If a property is set to True , then during execution FastReport will try to open the attached data source.

Namespace: frxCustomDB
Syntax
Delphi
published
 property AutoOpenDataSet: Boolean read FAutoOpenDataSet write FAutoOpenDataSet default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.DataSet Property

Summary

Dataset which the control is connected to.

Namespace: frxCustomDB
Syntax
Delphi
published
 property DataSet: TfrxDBDataset read FDataSet write SetDataSet;

Property Value

Type: TfrxDBDataset

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.DataSetName Property

Summary

Name of dataset, which the control is connected to. This property duplicates the DataSet property.

Namespace: frxCustomDB
Syntax
Delphi
published
 property DataSetName: String read GetDataSetName write SetDataSetName;

Property Value

Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.DBLookupComboBox Property

Summary

Reference to internal TDBLookupComboBox object.

Namespace: frxCustomDB
Syntax
Delphi
public
 property DBLookupComboBox: TDBLookupComboBox read FDBLookupComboBox;

Property Value

Type: TDBLookupComboBox

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.DropDownRows Property

Summary

Represents property DropDownRows.

Namespace: frxCustomDB
Syntax
Delphi
published
 property DropDownRows: Integer read GetDropDownRows write SetDropDownRows;

Property Value

Type: Integer

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.DropDownWidth Property

Summary

Represents property DropDownWidth.

Namespace: frxCustomDB
Syntax
Delphi
published
 property DropDownWidth: Integer read GetDropDownWidth write SetDropDownWidth;

Property Value

Type: Integer

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.KeyField Property

Summary

Name of DB field that will represent the key field.

Namespace: frxCustomDB
Syntax
Delphi
published
 property KeyField: String read GetKeyField write SetKeyField;

Property Value

Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.KeyValue Property

Summary

Value of key field that was selected in the control.

Namespace: frxCustomDB
Syntax
Delphi
public
 property KeyValue: Variant read GetKeyValue write SetKeyValue;

Property Value

Type: Variant

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.ListField Property

Summary

Name of DB field that will be shown in the control.

Namespace: frxCustomDB
Syntax
Delphi
published
 property ListField: String read GetListField write SetListField;

Property Value

Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.OnClick Property

Summary

Represents property OnClick.

Namespace: frxCustomDB
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: frxCustomDB
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.OnEnter Property

Summary

Represents property OnEnter.

Namespace: frxCustomDB
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.OnExit Property

Summary

Represents property OnExit.

Namespace: frxCustomDB
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.OnKeyDown Property

Summary

Represents property OnKeyDown.

Namespace: frxCustomDB
Syntax
Delphi
published
 property OnKeyDown;

Property Value

Type: Void

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.OnKeyPress Property

Summary

Represents property OnKeyPress.

Namespace: frxCustomDB
Syntax
Delphi
published
 property OnKeyPress;

Property Value

Type: Void

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.OnKeyUp Property

Summary

Represents property OnKeyUp.

Namespace: frxCustomDB
Syntax
Delphi
published
 property OnKeyUp;

Property Value

Type: Void

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: frxCustomDB
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: frxCustomDB
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: frxCustomDB
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.Text Property

Summary

Value of list field that was selected in the control.

Namespace: frxCustomDB
Syntax
Delphi
public
 property Text: String read GetText;

Property Value

Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox Methods

Methods
Name | Description
BeforeStartReport | Represents method BeforeStartReport.
GetDataSetName | Represents method GetDataSetName.
GetDescription | Represents method GetDescription.
GetDropDownRows | Represents method GetDropDownRows.
GetDropDownWidth | Represents method GetDropDownWidth.
GetKeyField | Represents method GetKeyField.
GetKeyValue | Represents method GetKeyValue.
GetListField | Represents method GetListField.
GetText | Represents method GetText.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
OnOpenDS(TObject) | Represents method OnOpenDS(TObject).
SetDataSet(TfrxDBDataset) | Represents method SetDataSet(TfrxDBDataset).
SetDataSetName(String) | Represents method SetDataSetName(String).
SetDropDownRows(Integer) | Represents method SetDropDownRows(Integer).
SetDropDownWidth(Integer) | Represents method SetDropDownWidth(Integer).
SetKeyField(String) | Represents method SetKeyField(String).
SetKeyValue(Variant) | Represents method SetKeyValue(Variant).
SetListField(String) | Represents method SetListField(String).
UpdateDataSet | Represents method UpdateDataSet.
Top


TfrxDBLookupComboBox.BeforeStartReport Method

Summary

Represents method BeforeStartReport.

Namespace: frxCustomDB
Syntax
Delphi
public
 procedure BeforeStartReport; override;
See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.GetDataSetName Method

Summary

Represents method GetDataSetName.

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetDataSetName: String;

Return Value

Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.GetDescription Method

Summary

Represents method GetDescription.

Namespace: frxCustomDB
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.GetDropDownRows Method

Summary

Represents method GetDropDownRows.

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetDropDownRows: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.GetDropDownWidth Method

Summary

Represents method GetDropDownWidth.

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetDropDownWidth: Integer;

Return Value

Type: Integer

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.GetKeyField Method

Summary

Represents method GetKeyField.

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetKeyField: String;

Return Value

Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.GetKeyValue Method

Summary

Represents method GetKeyValue.

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetKeyValue: Variant;

Return Value

Type: Variant

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.GetListField Method

Summary

Represents method GetListField.

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetListField: String;

Return Value

Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.GetText Method

Summary

Represents method GetText.

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetText: String;

Return Value

Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: frxCustomDB
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.OnOpenDS(TObject) Method

Summary

Represents method OnOpenDS(TObject).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure OnOpenDS(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.SetDataSet(TfrxDBDataset) Method

Summary

Represents method SetDataSet(TfrxDBDataset).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure SetDataSet(const Value: TfrxDBDataSet);

Parameters

Value
Type: TfrxDBDataSet

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.SetDataSetName(String) Method

Summary

Represents method SetDataSetName(String).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure SetDataSetName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.SetDropDownRows(Integer) Method

Summary

Represents method SetDropDownRows(Integer).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure SetDropDownRows(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.SetDropDownWidth(Integer) Method

Summary

Represents method SetDropDownWidth(Integer).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure SetDropDownWidth(const Value: Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.SetKeyField(String) Method

Summary

Represents method SetKeyField(String).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure SetKeyField(Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.SetKeyValue(Variant) Method

Summary

Represents method SetKeyValue(Variant).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure SetKeyValue(const Value: Variant);

Parameters

Value
Type: Variant

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.SetListField(String) Method

Summary

Represents method SetListField(String).

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure SetListField(Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.UpdateDataSet Method

Summary

Represents method UpdateDataSet.

Namespace: frxCustomDB
Syntax
Delphi
private
 procedure UpdateDataSet;
See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox Fields

Fields
Name | Description
FAutoOpenDataSet | Represents field FAutoOpenDataSet.
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
FDataSource | Represents field FDataSource.
FDBLookupComboBox | Represents field FDBLookupComboBox.
Top


TfrxDBLookupComboBox.FAutoOpenDataSet Field

Summary

Represents field FAutoOpenDataSet.

Namespace: frxCustomDB
Syntax
Delphi
private
 FAutoOpenDataSet: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.FDataSet Field

Summary

Represents field FDataSet.

Namespace: frxCustomDB
Syntax
Delphi
private
 FDataSet: TfrxDBDataSet;

Field Value

Type: TfrxDBDataSet

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.FDataSetName Field

Summary

Represents field FDataSetName.

Namespace: frxCustomDB
Syntax
Delphi
private
 FDataSetName: String;

Field Value

Type: String

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.FDataSource Field

Summary

Represents field FDataSource.

Namespace: frxCustomDB
Syntax
Delphi
private
 FDataSource: TDataSource;

Field Value

Type: TDataSource

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxDBLookupComboBox.FDBLookupComboBox Field

Summary

Represents field FDBLookupComboBox.

Namespace: frxCustomDB
Syntax
Delphi
private
 FDBLookupComboBox: TDBLookupComboBox;

Field Value

Type: TDBLookupComboBox

See Also

Reference

  • TfrxDBLookupComboBox
  • frxCustomDB


TfrxParamItem Class

Summary

The TfrxParamItem represents one query parameter.

Namespace: frxCustomDB
Inheritance Hierarchy
TCollectionItem
frxCustomDB.TfrxParamItem
Syntax
Delphi
type
 TfrxParamItem = class(TCollectionItem)
 end;

The TfrxParamItem type exposes the following members.

Properties
Show:
Name | Description
DataType | Type of the parameter.
Expression | Value of the parameter - expression that will be calculated when opening a query.
Name | Name of parameter. Don't change this property directly, because the list of parameters rebuilds automatically when changing SQL query.
Value | Value of the parameter. This property is used if Expression property is empty.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
Fields
Show:
Name | Description
FDataType | Represents field FDataType.
FExpression | Represents field FExpression.
FName | Represents field FName.
FValue | Represents field FValue.
Top
See Also

Reference

  • frxCustomDB


TfrxParamItem Properties

Properties
Name | Description
DataType | Type of the parameter.
Expression | Value of the parameter - expression that will be calculated when opening a query.
Name | Name of parameter. Don't change this property directly, because the list of parameters rebuilds automatically when changing SQL query.
Value | Value of the parameter. This property is used if Expression property is empty.
Top


TfrxParamItem.DataType Property

Summary

Type of the parameter.

Namespace: frxCustomDB
Syntax
Delphi
published
 property DataType: TFieldType read FDataType write FDataType;

Property Value

Type: TFieldType

See Also

Reference

  • TfrxParamItem
  • frxCustomDB


TfrxParamItem.Expression Property

Summary

Value of the parameter - expression that will be calculated when opening a query.

Namespace: frxCustomDB
Syntax
Delphi
published
 property Expression: String read FExpression write FExpression;

Property Value

Type: String

See Also

Reference

  • TfrxParamItem
  • frxCustomDB


TfrxParamItem.Name Property

Summary

Name of parameter. Don't change this property directly, because the list of parameters rebuilds automatically when changing SQL query.

Namespace: frxCustomDB
Syntax
Delphi
published
 property Name: String read FName write FName;

Property Value

Type: String

See Also

Reference

  • TfrxParamItem
  • frxCustomDB


TfrxParamItem.Value Property

Summary

Value of the parameter. This property is used if Expression property is empty.

Namespace: frxCustomDB
Syntax
Delphi
public
 property Value: Variant read FValue write FValue;

Property Value

Type: Variant

See Also

Reference

  • TfrxParamItem
  • frxCustomDB


TfrxParamItem Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TfrxParamItem.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: frxCustomDB
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TfrxParamItem
  • frxCustomDB


TfrxParamItem Fields

Fields
Name | Description
FDataType | Represents field FDataType.
FExpression | Represents field FExpression.
FName | Represents field FName.
FValue | Represents field FValue.
Top


TfrxParamItem.FDataType Field

Summary

Represents field FDataType.

Namespace: frxCustomDB
Syntax
Delphi
private
 FDataType: TFieldType;

Field Value

Type: TFieldType

See Also

Reference

  • TfrxParamItem
  • frxCustomDB


TfrxParamItem.FExpression Field

Summary

Represents field FExpression.

Namespace: frxCustomDB
Syntax
Delphi
private
 FExpression: String;

Field Value

Type: String

See Also

Reference

  • TfrxParamItem
  • frxCustomDB


TfrxParamItem.FName Field

Summary

Represents field FName.

Namespace: frxCustomDB
Syntax
Delphi
private
 FName: String;

Field Value

Type: String

See Also

Reference

  • TfrxParamItem
  • frxCustomDB


TfrxParamItem.FValue Field

Summary

Represents field FValue.

Namespace: frxCustomDB
Syntax
Delphi
private
 FValue: Variant;

Field Value

Type: Variant

See Also

Reference

  • TfrxParamItem
  • frxCustomDB


TfrxParams Class

Summary

The TfrxParams represents a list of query parameters.

Namespace: frxCustomDB
Inheritance Hierarchy
TCollection
frxCustomDB.TfrxParams
Syntax
Delphi
type
 TfrxParams = class(TCollection)
 end;

The TfrxParams type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TfrxParams class.
Top
Properties
Show:
Name | Description
IgnoreDuplicates | If a property set to True, then parameters with similar names are ignored.
Items[Integer] | List of parameters.
Top
Methods
Show:
Name | Description
Add | Adds a parameter. Don't use this method directly, because the list of parameters rebuilds automatically when changing SQL query.
Find(String) | Finds a parameter with specified name.
GetParam(Integer) | Represents method GetParam(Integer).
IndexOf(String) | Returns index of a parameter with specified name, or -1 if such parameter not exists.
UpdateParams(String) | Represents method UpdateParams(String).
Top
Fields
Show:
Name | Description
FIgnoreDuplicates | Represents field FIgnoreDuplicates.
Top
See Also

Reference

  • frxCustomDB


TfrxParams Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TfrxParams class.
Top


TfrxParams.Create Constructor

Summary

Initializes a new instance of the TfrxParams class.

Namespace: frxCustomDB
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TfrxParams
  • frxCustomDB


TfrxParams Properties

Properties
Name | Description
IgnoreDuplicates | If a property set to True, then parameters with similar names are ignored.
Items[Integer] | List of parameters.
Top


TfrxParams.IgnoreDuplicates Property

Summary

If a property set to True, then parameters with similar names are ignored.

Namespace: frxCustomDB
Syntax
Delphi
public
 property IgnoreDuplicates: Boolean read FIgnoreDuplicates write FIgnoreDuplicates;

Property Value

Type: Boolean

See Also

Reference

  • TfrxParams
  • frxCustomDB


TfrxParams.Items[Integer] Property

Summary

List of parameters.

Namespace: frxCustomDB
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxParamItem read GetParam; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxParamItem

See Also

Reference

  • TfrxParams
  • frxCustomDB


TfrxParams Methods

Methods
Name | Description
Add | Adds a parameter. Don't use this method directly, because the list of parameters rebuilds automatically when changing SQL query.
Find(String) | Finds a parameter with specified name.
GetParam(Integer) | Represents method GetParam(Integer).
IndexOf(String) | Returns index of a parameter with specified name, or -1 if such parameter not exists.
UpdateParams(String) | Represents method UpdateParams(String).
Top


TfrxParams.Add Method

Summary

Adds a parameter. Don't use this method directly, because the list of parameters rebuilds automatically when changing SQL query.

Namespace: frxCustomDB
Syntax
Delphi
public
 function Add: TfrxParamItem;

Return Value

Type: TfrxParamItem

See Also

Reference

  • TfrxParams
  • frxCustomDB


TfrxParams.Find(String) Method

Summary

Finds a parameter with specified name.

Namespace: frxCustomDB
Syntax
Delphi
public
 function Find(const Name: String): TfrxParamItem;

Parameters

Name
Type: String

Return Value

Type: TfrxParamItem

See Also

Reference

  • TfrxParams
  • frxCustomDB


TfrxParams.GetParam(Integer) Method

Summary

Represents method GetParam(Integer).

Namespace: frxCustomDB
Syntax
Delphi
private
 function GetParam(Index: Integer): TfrxParamItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxParamItem

See Also

Reference

  • TfrxParams
  • frxCustomDB


TfrxParams.IndexOf(String) Method

Summary

Returns index of a parameter with specified name, or -1 if such parameter not exists.

Namespace: frxCustomDB
Syntax
Delphi
public
 function IndexOf(const Name: String): Integer;

Parameters

Name
Type: String

Return Value

Type: Integer

See Also

Reference

  • TfrxParams
  • frxCustomDB


TfrxParams.UpdateParams(String) Method

Summary

Represents method UpdateParams(String).

Namespace: frxCustomDB
Syntax
Delphi
public
 procedure UpdateParams(const SQL: String);

Parameters

SQL
Type: String

See Also

Reference

  • TfrxParams
  • frxCustomDB


TfrxParams Fields

Fields
Name | Description
FIgnoreDuplicates | Represents field FIgnoreDuplicates.
Top


TfrxParams.FIgnoreDuplicates Field

Summary

Represents field FIgnoreDuplicates.

Namespace: frxCustomDB
Syntax
Delphi
private
 FIgnoreDuplicates: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxParams
  • frxCustomDB


frxCustomDB Routines

Routines
Name | Description
frxParamsToTParams(TfrxCustomQuery,TParams) | Represents method frxParamsToTParams(TfrxCustomQuery,TParams).
Top


frxParamsToTParams(TfrxCustomQuery,TParams) Method

Summary

Represents method frxParamsToTParams(TfrxCustomQuery,TParams).

Namespace: frxCustomDB
Syntax
Delphi
procedure frxParamsToTParams(Query: TfrxCustomQuery; Params: TParams);

Parameters

Query
Type: TfrxCustomQuery

Params
Type: TParams

See Also

Reference

  • frxCustomDB


frxDBSet Namespace

Summary

Represents namespace frxDBSet.

Classes
Name | Description
TfrxDBDataset | The TfrxDBDataSet component is designed for connecting to the DB components, which are based on TDataSet, such as "TTable" and "TQuery". Use DataSource or DataSet properties to connect to the data.
Top


frxDBSet Classes

Classes
Name | Description
TfrxDBDataset | The TfrxDBDataSet component is designed for connecting to the DB components, which are based on TDataSet, such as "TTable" and "TQuery". Use DataSource or DataSet properties to connect to the data.
Top


TfrxDBDataset Class

Summary

The TfrxDBDataSet component is designed for connecting to the DB components, which are based on TDataSet, such as "TTable" and "TQuery". Use DataSource or DataSet properties to connect to the data.

Namespace: frxDBSet
Inheritance Hierarchy
TfrxCustomDBDataset
frxDBSet.TfrxDBDataset
frxCustomDB.TfrxCustomDataset
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxDBDataset = class(TfrxCustomDBDataset)
 end;

The TfrxDBDataset type exposes the following members.

Properties
Show:
Name | Description
BCDToCurrency | Converts fields of type BCD to Currency if set to True.
DataSet | The data set - any TDataSet descendant.
DataSource | The data source - TDataSource -> TDataSet.
Top
Methods
Show:
Name | Description
AfterOpenEvent(TDataset) | Represents method AfterOpenEvent(TDataset).
AfterRefresh(TDataset) | Represents method AfterRefresh(TDataset).
AssignBlobTo(String,TObject) | Represents method AssignBlobTo(String,TObject).
BeforeClose(TDataSet) | Represents method BeforeClose(TDataSet).
Close | Represents method Close.
DataSetActive | Represents method DataSetActive.
Eof | Represents method Eof.
FieldsChanged(TObject) | Represents method FieldsChanged(TObject).
Finalize | Represents method Finalize.
First | Represents method First.
GetDataSet | Represents method GetDataSet.
GetDisplayText(String) | Represents method GetDisplayText(String).
GetDisplayWidth(String) | Represents method GetDisplayWidth(String).
GetFieldList(TStrings) | Represents method GetFieldList(TStrings).
GetFieldType(String) | Represents method GetFieldType(String).
GetValue(String) | Represents method GetValue(String).
Initialize | Represents method Initialize.
IsBlobField(String) | Represents method IsBlobField(String).
IsDataSetStored | Represents method IsDataSetStored.
IsHasMaster | Represents method IsHasMaster.
IsWideMemoBlobField(String) | Represents method IsWideMemoBlobField(String).
Next | Represents method Next.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Open | Represents method Open.
Prior | Represents method Prior.
RecordCount | Represents method RecordCount.
SetDataSet(TDataSet) | Represents method SetDataSet(TDataSet).
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource).
UpdateFields | Represents method UpdateFields.
Top
Fields
Show:
Name | Description
FBCDToCurrency | Represents field FBCDToCurrency.
FBookmark | Represents field FBookmark.
FDataSet | Represents field FDataSet.
FDataSource | Represents field FDataSource.
FDS | Represents field FDS.
FEof | Represents field FEof.
FNeedFieldsUpdate | Represents field FNeedFieldsUpdate.
FSaveAfterRefresh | Represents field FSaveAfterRefresh.
FSaveCloseEvent | Represents field FSaveCloseEvent.
FSaveFiedsChange | Represents field FSaveFiedsChange.
FSaveOpenEvent | Represents field FSaveOpenEvent.
Top
See Also

Reference

  • frxDBSet


TfrxDBDataset Properties

Properties
Name | Description
BCDToCurrency | Converts fields of type BCD to Currency if set to True.
DataSet | The data set - any TDataSet descendant.
DataSource | The data source - TDataSource -> TDataSet.
Top


TfrxDBDataset.BCDToCurrency Property

Summary

Converts fields of type BCD to Currency if set to True.

Namespace: frxDBSet
Syntax
Delphi
published
 property BCDToCurrency: Boolean read FBCDToCurrency write FBCDToCurrency;

Property Value

Type: Boolean

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.DataSet Property

Summary

The data set - any TDataSet descendant.

Namespace: frxDBSet
Syntax
Delphi
published
 property DataSet: TDataSet read FDataSet write SetDataSet stored IsDataSetStored;

Property Value

Type: TDataSet

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.DataSource Property

Summary

The data source - TDataSource -> TDataSet.

Namespace: frxDBSet
Syntax
Delphi
published
 property DataSource: TDataSource read FDataSource write SetDataSource stored IsDataSetStored;

Property Value

Type: TDataSource

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset Methods

Methods
Name | Description
AfterOpenEvent(TDataset) | Represents method AfterOpenEvent(TDataset).
AfterRefresh(TDataset) | Represents method AfterRefresh(TDataset).
AssignBlobTo(String,TObject) | Represents method AssignBlobTo(String,TObject).
BeforeClose(TDataSet) | Represents method BeforeClose(TDataSet).
Close | Represents method Close.
DataSetActive | Represents method DataSetActive.
Eof | Represents method Eof.
FieldsChanged(TObject) | Represents method FieldsChanged(TObject).
Finalize | Represents method Finalize.
First | Represents method First.
GetDataSet | Represents method GetDataSet.
GetDisplayText(String) | Represents method GetDisplayText(String).
GetDisplayWidth(String) | Represents method GetDisplayWidth(String).
GetFieldList(TStrings) | Represents method GetFieldList(TStrings).
GetFieldType(String) | Represents method GetFieldType(String).
GetValue(String) | Represents method GetValue(String).
Initialize | Represents method Initialize.
IsBlobField(String) | Represents method IsBlobField(String).
IsDataSetStored | Represents method IsDataSetStored.
IsHasMaster | Represents method IsHasMaster.
IsWideMemoBlobField(String) | Represents method IsWideMemoBlobField(String).
Next | Represents method Next.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Open | Represents method Open.
Prior | Represents method Prior.
RecordCount | Represents method RecordCount.
SetDataSet(TDataSet) | Represents method SetDataSet(TDataSet).
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource).
UpdateFields | Represents method UpdateFields.
Top


TfrxDBDataset.AfterOpenEvent(TDataset) Method

Summary

Represents method AfterOpenEvent(TDataset).

Namespace: frxDBSet
Syntax
Delphi
private
 procedure AfterOpenEvent(Sender: TDataset);

Parameters

Sender
Type: TDataset

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.AfterRefresh(TDataset) Method

Summary

Represents method AfterRefresh(TDataset).

Namespace: frxDBSet
Syntax
Delphi
private
 procedure AfterRefresh(Sender: TDataset);

Parameters

Sender
Type: TDataset

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.AssignBlobTo(String,TObject) Method

Summary

Represents method AssignBlobTo(String,TObject).

Namespace: frxDBSet
Syntax
Delphi
public
 procedure AssignBlobTo(const fName: String; Obj: TObject); override;

Parameters

fName
Type: String

Obj
Type: TObject

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.BeforeClose(TDataSet) Method

Summary

Represents method BeforeClose(TDataSet).

Namespace: frxDBSet
Syntax
Delphi
private
 procedure BeforeClose(Sender: TDataSet);

Parameters

Sender
Type: TDataSet

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.Close Method

Summary

Represents method Close.

Namespace: frxDBSet
Syntax
Delphi
public
 procedure Close; override;
See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.DataSetActive Method

Summary

Represents method DataSetActive.

Namespace: frxDBSet
Syntax
Delphi
private
 function DataSetActive: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.Eof Method

Summary

Represents method Eof.

Namespace: frxDBSet
Syntax
Delphi
public
 function Eof: Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.FieldsChanged(TObject) Method

Summary

Represents method FieldsChanged(TObject).

Namespace: frxDBSet
Syntax
Delphi
private
 procedure FieldsChanged(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.Finalize Method

Summary

Represents method Finalize.

Namespace: frxDBSet
Syntax
Delphi
public
 procedure Finalize; override;
See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.First Method

Summary

Represents method First.

Namespace: frxDBSet
Syntax
Delphi
public
 procedure First; override;
See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.GetDataSet Method

Summary

Represents method GetDataSet.

Namespace: frxDBSet
Syntax
Delphi
public
 function GetDataSet: TDataSet;

Return Value

Type: TDataSet

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.GetDisplayText(String) Method

Summary

Represents method GetDisplayText(String).

Namespace: frxDBSet
Syntax
Delphi
protected
 function GetDisplayText(Index: String): WideString; override;

Parameters

Index
Type: String

Return Value

Type: WideString

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.GetDisplayWidth(String) Method

Summary

Represents method GetDisplayWidth(String).

Namespace: frxDBSet
Syntax
Delphi
protected
 function GetDisplayWidth(Index: String): Integer; override;

Parameters

Index
Type: String

Return Value

Type: Integer

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.GetFieldList(TStrings) Method

Summary

Represents method GetFieldList(TStrings).

Namespace: frxDBSet
Syntax
Delphi
public
 procedure GetFieldList(List: TStrings); override;

Parameters

List
Type: TStrings

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.GetFieldType(String) Method

Summary

Represents method GetFieldType(String).

Namespace: frxDBSet
Syntax
Delphi
protected
 function GetFieldType(Index: String): TfrxFieldType; override;

Parameters

Index
Type: String

Return Value

Type: TfrxFieldType

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.GetValue(String) Method

Summary

Represents method GetValue(String).

Namespace: frxDBSet
Syntax
Delphi
protected
 function GetValue(Index: String): Variant; override;

Parameters

Index
Type: String

Return Value

Type: Variant

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.Initialize Method

Summary

Represents method Initialize.

Namespace: frxDBSet
Syntax
Delphi
public
 procedure Initialize; override;
See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.IsBlobField(String) Method

Summary

Represents method IsBlobField(String).

Namespace: frxDBSet
Syntax
Delphi
public
 function IsBlobField(const fName: String): Boolean; override;

Parameters

fName
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.IsDataSetStored Method

Summary

Represents method IsDataSetStored.

Namespace: frxDBSet
Syntax
Delphi
private
 function IsDataSetStored: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.IsHasMaster Method

Summary

Represents method IsHasMaster.

Namespace: frxDBSet
Syntax
Delphi
public
 function IsHasMaster: Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.IsWideMemoBlobField(String) Method

Summary

Represents method IsWideMemoBlobField(String).

Namespace: frxDBSet
Syntax
Delphi
public
 function IsWideMemoBlobField(const fName: String): Boolean; override;

Parameters

fName
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.Next Method

Summary

Represents method Next.

Namespace: frxDBSet
Syntax
Delphi
public
 procedure Next; override;
See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: frxDBSet
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.Open Method

Summary

Represents method Open.

Namespace: frxDBSet
Syntax
Delphi
public
 procedure Open; override;
See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.Prior Method

Summary

Represents method Prior.

Namespace: frxDBSet
Syntax
Delphi
public
 procedure Prior; override;
See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.RecordCount Method

Summary

Represents method RecordCount.

Namespace: frxDBSet
Syntax
Delphi
public
 function RecordCount: Integer; override;

Return Value

Type: Integer

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.SetDataSet(TDataSet) Method

Summary

Represents method SetDataSet(TDataSet).

Namespace: frxDBSet
Syntax
Delphi
private
 procedure SetDataSet(Value: TDataSet);

Parameters

Value
Type: TDataSet

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.SetDataSource(TDataSource) Method

Summary

Represents method SetDataSource(TDataSource).

Namespace: frxDBSet
Syntax
Delphi
private
 procedure SetDataSource(Value: TDataSource);

Parameters

Value
Type: TDataSource

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.UpdateFields Method

Summary

Represents method UpdateFields.

Namespace: frxDBSet
Syntax
Delphi
private
 procedure UpdateFields;
See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset Fields

Fields
Name | Description
FBCDToCurrency | Represents field FBCDToCurrency.
FBookmark | Represents field FBookmark.
FDataSet | Represents field FDataSet.
FDataSource | Represents field FDataSource.
FDS | Represents field FDS.
FEof | Represents field FEof.
FNeedFieldsUpdate | Represents field FNeedFieldsUpdate.
FSaveAfterRefresh | Represents field FSaveAfterRefresh.
FSaveCloseEvent | Represents field FSaveCloseEvent.
FSaveFiedsChange | Represents field FSaveFiedsChange.
FSaveOpenEvent | Represents field FSaveOpenEvent.
Top


TfrxDBDataset.FBCDToCurrency Field

Summary

Represents field FBCDToCurrency.

Namespace: frxDBSet
Syntax
Delphi
private
 FBCDToCurrency: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.FBookmark Field

Summary

Represents field FBookmark.

Namespace: frxDBSet
Syntax
Delphi
private
 FBookmark: TBookmark;

Field Value

Type: TBookmark

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.FDataSet Field

Summary

Represents field FDataSet.

Namespace: frxDBSet
Syntax
Delphi
private
 FDataSet: TDataSet;

Field Value

Type: TDataSet

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.FDataSource Field

Summary

Represents field FDataSource.

Namespace: frxDBSet
Syntax
Delphi
private
 FDataSource: TDataSource;

Field Value

Type: TDataSource

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.FDS Field

Summary

Represents field FDS.

Namespace: frxDBSet
Syntax
Delphi
private
 FDS: TDataSet;

Field Value

Type: TDataSet

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.FEof Field

Summary

Represents field FEof.

Namespace: frxDBSet
Syntax
Delphi
private
 FEof: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.FNeedFieldsUpdate Field

Summary

Represents field FNeedFieldsUpdate.

Namespace: frxDBSet
Syntax
Delphi
private
 FNeedFieldsUpdate: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.FSaveAfterRefresh Field

Summary

Represents field FSaveAfterRefresh.

Namespace: frxDBSet
Syntax
Delphi
private
 FSaveAfterRefresh: TDatasetNotifyEvent;

Field Value

Type: TDatasetNotifyEvent

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.FSaveCloseEvent Field

Summary

Represents field FSaveCloseEvent.

Namespace: frxDBSet
Syntax
Delphi
private
 FSaveCloseEvent: TDatasetNotifyEvent;

Field Value

Type: TDatasetNotifyEvent

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.FSaveFiedsChange Field

Summary

Represents field FSaveFiedsChange.

Namespace: frxDBSet
Syntax
Delphi
private
 FSaveFiedsChange: TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


TfrxDBDataset.FSaveOpenEvent Field

Summary

Represents field FSaveOpenEvent.

Namespace: frxDBSet
Syntax
Delphi
private
 FSaveOpenEvent: TDatasetNotifyEvent;

Field Value

Type: TDatasetNotifyEvent

See Also

Reference

  • TfrxDBDataset
  • frxDBSet


frxTeeXX

Namespaces
Name | Description
frxChart | Represents namespace frxChart.
frxChartClipboard | Represents namespace frxChartClipboard.
frxChartHelpers | Represents namespace frxChartHelpers.
frxChartInPlaceEditor | Represents namespace frxChartInPlaceEditor.
Top


frxChart Namespace

Summary

Represents namespace frxChart.

Classes
Name | Description
TfrxChartObject | The TfrxChartBoxObject lets you use the Chart component in your report. TfrxChartObject is an empty component. It is used to add the frxChart.pas file to the "uses" list. The main component is TfrxChartView.
TfrxChartView | The TfrxChartView component represents a chart. The component uses TeeChart library to render charts. It may show several series on one chart. The series settings are stored in the SeriesData collection.
TfrxSeriesData | The TfrxSeriesData class represents collection of series.
TfrxSeriesItem | The TfrxSeriesItem class represents one series.
Top
Enumerations
Name | Description
TfrxChartSeries | Series types.
TfrxSeriesDataType | Data type of the series: DB data, band data or fixed data.
TfrxSeriesSortOrder | Sort type of the series data.
TfrxSeriesXType | The X-axis data type: text, numeric, date.
Top
Types
Name | Description
TChartClass | Represents type TChartClass.
TSeriesClass | Represents type TSeriesClass.
Top


frxChart Classes

Classes
Name | Description
TfrxChartObject | The TfrxChartBoxObject lets you use the Chart component in your report. TfrxChartObject is an empty component. It is used to add the frxChart.pas file to the "uses" list. The main component is TfrxChartView.
TfrxChartView | The TfrxChartView component represents a chart. The component uses TeeChart library to render charts. It may show several series on one chart. The series settings are stored in the SeriesData collection.
TfrxSeriesData | The TfrxSeriesData class represents collection of series.
TfrxSeriesItem | The TfrxSeriesItem class represents one series.
Top


TfrxChartObject Class

Summary

The TfrxChartBoxObject lets you use the Chart component in your report. TfrxChartObject is an empty component. It is used to add the frxChart.pas file to the "uses" list. The main component is TfrxChartView.

Namespace: frxChart
Inheritance Hierarchy
TComponent
frxChart.TfrxChartObject
Syntax
Delphi
type
[ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TfrxChartObject = class(TComponent);
See Also

Reference

  • frxChart


TfrxChartView Class

Summary

The TfrxChartView component represents a chart. The component uses TeeChart library to render charts. It may show several series on one chart. The series settings are stored in the SeriesData collection.

Namespace: frxChart
Inheritance Hierarchy
TfrxView
frxChart.TfrxChartView
Syntax
Delphi
type
 TfrxChartView = class(TfrxView)
 end;

The TfrxChartView type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxChartView class.
Destroy | Represents the destructor of the TfrxChartView class.
Top
Properties
Show:
Name | Description
Chart | Reference to internal TChart object.
ClickedVal1 | Represents property ClickedVal1.
ClickedVal10 | Represents property ClickedVal10.
ClickedVal2 | Represents property ClickedVal2.
ClickedVal3 | Represents property ClickedVal3.
ClickedVal4 | Represents property ClickedVal4.
ClickedVal5 | Represents property ClickedVal5.
ClickedVal6 | Represents property ClickedVal6.
ClickedVal7 | Represents property ClickedVal7.
ClickedVal8 | Represents property ClickedVal8.
ClickedVal9 | Represents property ClickedVal9.
Cursor | Represents property Cursor.
Fill | Represents property Fill.
FillType | Represents property FillType.
Frame | Represents property Frame.
HighlightColor | Represents property HighlightColor.
HighlightIndex | Represents property HighlightIndex.
IgnoreNulls | Represents property IgnoreNulls.
Processing | Represents property Processing.
SeriesData | Settings of the series.
TagStr | Represents property TagStr.
URL | Represents property URL.
Top
Methods
Show:
Name | Description
AddSeries(TfrxChartSeries) | Represents method AddSeries(TfrxChartSeries).
AfterPrint | Represents method AfterPrint.
BeforeStartReport | Represents method BeforeStartReport.
CheckMoveSelector(Extended,Extended) | Represents method CheckMoveSelector(Extended,Extended).
ClearSeries | Represents method ClearSeries.
CreateChart | Represents method CreateChart.
CreateMetafile | Represents method CreateMetafile.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).
Draw(TCanvas,Extended,Extended,Extended,Extended) | Represents method Draw(TCanvas,Extended,Extended,Extended,Extended).
DrawOnMetaFile | Represents method DrawOnMetaFile.
FillChart | Represents method FillChart.
GetChartClass | Represents method GetChartClass.
GetData | Represents method GetData.
GetDescription | Represents method GetDescription.
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Represents method LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
OnNotify(TObject) | Represents method OnNotify(TObject).
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | Represents method ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).
ReadData(TStream) | Represents method ReadData(TStream).
ReadData1(TReader) | Represents method ReadData1(TReader).
ReadData2(TReader) | Represents method ReadData2(TReader).
ResetClickedValues | Represents method ResetClickedValues.
ResetHighlightSelection | Represents method ResetHighlightSelection.
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | Represents method SaveContentToDictionary(TfrxReport,TfrxPostProcessor).
UpdateSeriesData | Represents method UpdateSeriesData.
WriteData(TStream) | Represents method WriteData(TStream).
WriteData1(TWriter) | Represents method WriteData1(TWriter).
WriteData2(TWriter) | Represents method WriteData2(TWriter).
Top
Fields
Show:
Name | Description
FChart | Represents field FChart.
FClickedVal1 | Represents field FClickedVal1.
FClickedVal10 | Represents field FClickedVal10.
FClickedVal2 | Represents field FClickedVal2.
FClickedVal3 | Represents field FClickedVal3.
FClickedVal4 | Represents field FClickedVal4.
FClickedVal5 | Represents field FClickedVal5.
FClickedVal6 | Represents field FClickedVal6.
FClickedVal7 | Represents field FClickedVal7.
FClickedVal8 | Represents field FClickedVal8.
FClickedVal9 | Represents field FClickedVal9.
FEMF | Represents field FEMF.
FHighlightColor | Represents field FHighlightColor.
FHlIndex | Represents field FHlIndex.
FIgnoreNulls | Represents field FIgnoreNulls.
FLockFillSeries | Represents field FLockFillSeries.
FMacroLoaded | Represents field FMacroLoaded.
FMouseDown | Represents field FMouseDown.
FMouseOffsetX | Represents field FMouseOffsetX.
FMouseOffsetY | Represents field FMouseOffsetY.
FPenStyle | Represents field FPenStyle.
FPenWidth | Represents field FPenWidth.
FSavedColor | Represents field FSavedColor.
FSeriesData | Represents field FSeriesData.
FSeriesFilled | Represents field FSeriesFilled.
FSeriesIndex | Represents field FSeriesIndex.
Top
See Also

Reference

  • frxChart


TfrxChartView Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TfrxChartView class.
Destroy | Represents the destructor of the TfrxChartView class.
Top


TfrxChartView.Create(TComponent) Constructor

Summary

Initializes a new instance of the TfrxChartView class.

Namespace: frxChart
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.Destroy Destructor

Summary

Represents the destructor of the TfrxChartView class.

Namespace: frxChart
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView Properties

Properties
Name | Description
Chart | Reference to internal TChart object.
ClickedVal1 | Represents property ClickedVal1.
ClickedVal10 | Represents property ClickedVal10.
ClickedVal2 | Represents property ClickedVal2.
ClickedVal3 | Represents property ClickedVal3.
ClickedVal4 | Represents property ClickedVal4.
ClickedVal5 | Represents property ClickedVal5.
ClickedVal6 | Represents property ClickedVal6.
ClickedVal7 | Represents property ClickedVal7.
ClickedVal8 | Represents property ClickedVal8.
ClickedVal9 | Represents property ClickedVal9.
Cursor | Represents property Cursor.
Fill | Represents property Fill.
FillType | Represents property FillType.
Frame | Represents property Frame.
HighlightColor | Represents property HighlightColor.
HighlightIndex | Represents property HighlightIndex.
IgnoreNulls | Represents property IgnoreNulls.
Processing | Represents property Processing.
SeriesData | Settings of the series.
TagStr | Represents property TagStr.
URL | Represents property URL.
Top


TfrxChartView.Chart Property

Summary

Reference to internal TChart object.

Namespace: frxChart
Syntax
Delphi
public
 property Chart: TCustomChart read FChart;

Property Value

Type: TCustomChart

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ClickedVal1 Property

Summary

Represents property ClickedVal1.

Namespace: frxChart
Syntax
Delphi
public
 property ClickedVal1: String read FClickedVal1;

Property Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ClickedVal10 Property

Summary

Represents property ClickedVal10.

Namespace: frxChart
Syntax
Delphi
public
 property ClickedVal10: String read FClickedVal10;

Property Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ClickedVal2 Property

Summary

Represents property ClickedVal2.

Namespace: frxChart
Syntax
Delphi
public
 property ClickedVal2: String read FClickedVal2;

Property Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ClickedVal3 Property

Summary

Represents property ClickedVal3.

Namespace: frxChart
Syntax
Delphi
public
 property ClickedVal3: String read FClickedVal3;

Property Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ClickedVal4 Property

Summary

Represents property ClickedVal4.

Namespace: frxChart
Syntax
Delphi
public
 property ClickedVal4: String read FClickedVal4;

Property Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ClickedVal5 Property

Summary

Represents property ClickedVal5.

Namespace: frxChart
Syntax
Delphi
public
 property ClickedVal5: String read FClickedVal5;

Property Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ClickedVal6 Property

Summary

Represents property ClickedVal6.

Namespace: frxChart
Syntax
Delphi
public
 property ClickedVal6: String read FClickedVal6;

Property Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ClickedVal7 Property

Summary

Represents property ClickedVal7.

Namespace: frxChart
Syntax
Delphi
public
 property ClickedVal7: String read FClickedVal7;

Property Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ClickedVal8 Property

Summary

Represents property ClickedVal8.

Namespace: frxChart
Syntax
Delphi
public
 property ClickedVal8: String read FClickedVal8;

Property Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ClickedVal9 Property

Summary

Represents property ClickedVal9.

Namespace: frxChart
Syntax
Delphi
public
 property ClickedVal9: String read FClickedVal9;

Property Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.Cursor Property

Summary

Represents property Cursor.

Namespace: frxChart
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.Fill Property

Summary

Represents property Fill.

Namespace: frxChart
Syntax
Delphi
published
 property Fill;

Property Value

Type: Void

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FillType Property

Summary

Represents property FillType.

Namespace: frxChart
Syntax
Delphi
published
 property FillType;

Property Value

Type: Void

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.Frame Property

Summary

Represents property Frame.

Namespace: frxChart
Syntax
Delphi
published
 property Frame;

Property Value

Type: Void

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.HighlightColor Property

Summary

Represents property HighlightColor.

Namespace: frxChart
Syntax
Delphi
published
 property HighlightColor: TColor read FHighlightColor write FHighlightColor default clHotLight;

Property Value

Type: TColor

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.HighlightIndex Property

Summary

Represents property HighlightIndex.

Namespace: frxChart
Syntax
Delphi
public
 property HighlightIndex: Integer read FHLIndex;

Property Value

Type: Integer

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.IgnoreNulls Property

Summary

Represents property IgnoreNulls.

Namespace: frxChart
Syntax
Delphi
published
 property IgnoreNulls: Boolean read FIgnoreNulls write FIgnoreNulls default False;

Property Value

Type: Boolean

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.Processing Property

Summary

Represents property Processing.

Namespace: frxChart
Syntax
Delphi
published
 property Processing;

Property Value

Type: Void

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.SeriesData Property

Summary

Settings of the series.

Namespace: frxChart
Syntax
Delphi
public
 property SeriesData: TfrxSeriesData read FSeriesData;

Property Value

Type: TfrxSeriesData

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.TagStr Property

Summary

Represents property TagStr.

Namespace: frxChart
Syntax
Delphi
published
 property TagStr;

Property Value

Type: Void

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.URL Property

Summary

Represents property URL.

Namespace: frxChart
Syntax
Delphi
published
 property URL;

Property Value

Type: Void

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView Methods

Methods
Name | Description
AddSeries(TfrxChartSeries) | Represents method AddSeries(TfrxChartSeries).
AfterPrint | Represents method AfterPrint.
BeforeStartReport | Represents method BeforeStartReport.
CheckMoveSelector(Extended,Extended) | Represents method CheckMoveSelector(Extended,Extended).
ClearSeries | Represents method ClearSeries.
CreateChart | Represents method CreateChart.
CreateMetafile | Represents method CreateMetafile.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).
DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) | Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).
DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) | Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).
Draw(TCanvas,Extended,Extended,Extended,Extended) | Represents method Draw(TCanvas,Extended,Extended,Extended,Extended).
DrawOnMetaFile | Represents method DrawOnMetaFile.
FillChart | Represents method FillChart.
GetChartClass | Represents method GetChartClass.
GetData | Represents method GetData.
GetDescription | Represents method GetDescription.
LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) | Represents method LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
OnNotify(TObject) | Represents method OnNotify(TObject).
ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) | Represents method ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).
ReadData(TStream) | Represents method ReadData(TStream).
ReadData1(TReader) | Represents method ReadData1(TReader).
ReadData2(TReader) | Represents method ReadData2(TReader).
ResetClickedValues | Represents method ResetClickedValues.
ResetHighlightSelection | Represents method ResetHighlightSelection.
SaveContentToDictionary(TfrxReport,TfrxPostProcessor) | Represents method SaveContentToDictionary(TfrxReport,TfrxPostProcessor).
UpdateSeriesData | Represents method UpdateSeriesData.
WriteData(TStream) | Represents method WriteData(TStream).
WriteData1(TWriter) | Represents method WriteData1(TWriter).
WriteData2(TWriter) | Represents method WriteData2(TWriter).
Top


TfrxChartView.AddSeries(TfrxChartSeries) Method

Summary

Represents method AddSeries(TfrxChartSeries).

Namespace: frxChart
Syntax
Delphi
public
 procedure AddSeries(Series: TfrxChartSeries);

Parameters

Series
Type: TfrxChartSeries

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.AfterPrint Method

Summary

Represents method AfterPrint.

Namespace: frxChart
Syntax
Delphi
public
 procedure AfterPrint; override;
See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.BeforeStartReport Method

Summary

Represents method BeforeStartReport.

Namespace: frxChart
Syntax
Delphi
public
 procedure BeforeStartReport; override;
See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.CheckMoveSelector(Extended,Extended) Method

Summary

Represents method CheckMoveSelector(Extended,Extended).

Namespace: frxChart
Syntax
Delphi
protected
 function CheckMoveSelector(X, Y: Extended): Boolean;

Parameters

X
Type: Extended

Y
Type: Extended

Return Value

Type: Boolean

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ClearSeries Method

Summary

Represents method ClearSeries.

Namespace: frxChart
Syntax
Delphi
public
 procedure ClearSeries;
See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.CreateChart Method

Summary

Represents method CreateChart.

Namespace: frxChart
Syntax
Delphi
protected
 procedure CreateChart; virtual;
See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.CreateMetafile Method

Summary

Represents method CreateMetafile.

Namespace: frxChart
Syntax
Delphi
private
 function CreateMetafile: TMetafile;

Return Value

Type: TMetafile

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: frxChart
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseDown(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxChart
Syntax
Delphi
public
 function DoMouseDown(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams)
 : Boolean; override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseEnter(TfrxComponent,TfrxInteractiveEventsParams).

Namespace: frxChart
Syntax
Delphi
public
 procedure DoMouseEnter(aPreviousObject: TfrxComponent;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

aPreviousObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseLeave(TfrxComponent,TfrxInteractiveEventsParams).

Namespace: frxChart
Syntax
Delphi
public
 procedure DoMouseLeave(aNextObject: TfrxComponent;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

aNextObject
Type: TfrxComponent

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseMove(Integer,Integer,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxChart
Syntax
Delphi
public
 procedure DoMouseMove(X, Y: Integer; Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxChart
Syntax
Delphi
public
 procedure DoMouseUp(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState;
 var EventParams: TfrxInteractiveEventsParams); override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseWheel(TShiftState,Integer,TPoint,TfrxInteractiveEventsParams).

Namespace: frxChart
Syntax
Delphi
public
 function DoMouseWheel(Shift: TShiftState;
 WheelDelta: Integer; MousePos: TPoint;
 var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

Shift
Type: TShiftState

WheelDelta
Type: Integer

MousePos
Type: TPoint

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.Draw(TCanvas,Extended,Extended,Extended,Extended) Method

Summary

Represents method Draw(TCanvas,Extended,Extended,Extended,Extended).

Namespace: frxChart
Syntax
Delphi
public
 procedure Draw(Canvas: TCanvas; ScaleX, ScaleY, OffsetX, OffsetY: Extended); override;

Parameters

Canvas
Type: TCanvas

ScaleX
Type: Extended

ScaleY
Type: Extended

OffsetX
Type: Extended

OffsetY
Type: Extended

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.DrawOnMetaFile Method

Summary

Represents method DrawOnMetaFile.

Namespace: frxChart
Syntax
Delphi
private
 procedure DrawOnMetaFile;
See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FillChart Method

Summary

Represents method FillChart.

Namespace: frxChart
Syntax
Delphi
private
 procedure FillChart;
See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.GetChartClass Method

Summary

Represents method GetChartClass.

Namespace: frxChart
Syntax
Delphi
protected
 class function GetChartClass: TChartClass; virtual;

Return Value

Type: TChartClass

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.GetData Method

Summary

Represents method GetData.

Namespace: frxChart
Syntax
Delphi
public
 procedure GetData; override;
See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.GetDescription Method

Summary

Represents method GetDescription.

Namespace: frxChart
Syntax
Delphi
public
 class function GetDescription: String; override;

Return Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.LoadContentFromDictionary(TfrxReport,TfrxMacrosItem) Method

Summary

Represents method LoadContentFromDictionary(TfrxReport,TfrxMacrosItem).

Namespace: frxChart
Syntax
Delphi
public
 function LoadContentFromDictionary(aReport: TfrxReport; aItem: TfrxMacrosItem): Boolean; override;

Parameters

aReport
Type: TfrxReport

aItem
Type: TfrxMacrosItem

Return Value

Type: Boolean

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: frxChart
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.OnNotify(TObject) Method

Summary

Represents method OnNotify(TObject).

Namespace: frxChart
Syntax
Delphi
public
 procedure OnNotify(Sender: TObject); override;

Parameters

Sender
Type: TObject

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor) Method

Summary

Represents method ProcessDictionary(TfrxMacrosItem,TfrxReport,TfrxPostProcessor).

Namespace: frxChart
Syntax
Delphi
public
 procedure ProcessDictionary(aItem: TfrxMacrosItem; aReport: TfrxReport; PostProcessor: TfrxPostProcessor); override;

Parameters

aItem
Type: TfrxMacrosItem

aReport
Type: TfrxReport

PostProcessor
Type: TfrxPostProcessor

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ReadData(TStream) Method

Summary

Represents method ReadData(TStream).

Namespace: frxChart
Syntax
Delphi
private
 procedure ReadData(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ReadData1(TReader) Method

Summary

Represents method ReadData1(TReader).

Namespace: frxChart
Syntax
Delphi
private
 procedure ReadData1(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ReadData2(TReader) Method

Summary

Represents method ReadData2(TReader).

Namespace: frxChart
Syntax
Delphi
private
 procedure ReadData2(Reader: TReader);

Parameters

Reader
Type: TReader

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ResetClickedValues Method

Summary

Represents method ResetClickedValues.

Namespace: frxChart
Syntax
Delphi
private
 procedure ResetClickedValues;
See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.ResetHighlightSelection Method

Summary

Represents method ResetHighlightSelection.

Namespace: frxChart
Syntax
Delphi
private
 function ResetHighlightSelection: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.SaveContentToDictionary(TfrxReport,TfrxPostProcessor) Method

Summary

Represents method SaveContentToDictionary(TfrxReport,TfrxPostProcessor).

Namespace: frxChart
Syntax
Delphi
public
 procedure SaveContentToDictionary(aReport: TfrxReport; PostProcessor: TfrxPostProcessor); override;

Parameters

aReport
Type: TfrxReport

PostProcessor
Type: TfrxPostProcessor

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.UpdateSeriesData Method

Summary

Represents method UpdateSeriesData.

Namespace: frxChart
Syntax
Delphi
public
 procedure UpdateSeriesData;
See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.WriteData(TStream) Method

Summary

Represents method WriteData(TStream).

Namespace: frxChart
Syntax
Delphi
private
 procedure WriteData(Stream: TStream);

Parameters

Stream
Type: TStream

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.WriteData1(TWriter) Method

Summary

Represents method WriteData1(TWriter).

Namespace: frxChart
Syntax
Delphi
private
 procedure WriteData1(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.WriteData2(TWriter) Method

Summary

Represents method WriteData2(TWriter).

Namespace: frxChart
Syntax
Delphi
private
 procedure WriteData2(Writer: TWriter);

Parameters

Writer
Type: TWriter

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView Fields

Fields
Name | Description
FChart | Represents field FChart.
FClickedVal1 | Represents field FClickedVal1.
FClickedVal10 | Represents field FClickedVal10.
FClickedVal2 | Represents field FClickedVal2.
FClickedVal3 | Represents field FClickedVal3.
FClickedVal4 | Represents field FClickedVal4.
FClickedVal5 | Represents field FClickedVal5.
FClickedVal6 | Represents field FClickedVal6.
FClickedVal7 | Represents field FClickedVal7.
FClickedVal8 | Represents field FClickedVal8.
FClickedVal9 | Represents field FClickedVal9.
FEMF | Represents field FEMF.
FHighlightColor | Represents field FHighlightColor.
FHlIndex | Represents field FHlIndex.
FIgnoreNulls | Represents field FIgnoreNulls.
FLockFillSeries | Represents field FLockFillSeries.
FMacroLoaded | Represents field FMacroLoaded.
FMouseDown | Represents field FMouseDown.
FMouseOffsetX | Represents field FMouseOffsetX.
FMouseOffsetY | Represents field FMouseOffsetY.
FPenStyle | Represents field FPenStyle.
FPenWidth | Represents field FPenWidth.
FSavedColor | Represents field FSavedColor.
FSeriesData | Represents field FSeriesData.
FSeriesFilled | Represents field FSeriesFilled.
FSeriesIndex | Represents field FSeriesIndex.
Top


TfrxChartView.FChart Field

Summary

Represents field FChart.

Namespace: frxChart
Syntax
Delphi
private
 FChart: TCustomChart;

Field Value

Type: TCustomChart

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FClickedVal1 Field

Summary

Represents field FClickedVal1.

Namespace: frxChart
Syntax
Delphi
private
 FClickedVal1: String;

Field Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FClickedVal10 Field

Summary

Represents field FClickedVal10.

Namespace: frxChart
Syntax
Delphi
private
 FClickedVal10: String;

Field Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FClickedVal2 Field

Summary

Represents field FClickedVal2.

Namespace: frxChart
Syntax
Delphi
private
 FClickedVal2: String;

Field Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FClickedVal3 Field

Summary

Represents field FClickedVal3.

Namespace: frxChart
Syntax
Delphi
private
 FClickedVal3: String;

Field Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FClickedVal4 Field

Summary

Represents field FClickedVal4.

Namespace: frxChart
Syntax
Delphi
private
 FClickedVal4: String;

Field Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FClickedVal5 Field

Summary

Represents field FClickedVal5.

Namespace: frxChart
Syntax
Delphi
private
 FClickedVal5: String;

Field Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FClickedVal6 Field

Summary

Represents field FClickedVal6.

Namespace: frxChart
Syntax
Delphi
private
 FClickedVal6: String;

Field Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FClickedVal7 Field

Summary

Represents field FClickedVal7.

Namespace: frxChart
Syntax
Delphi
private
 FClickedVal7: String;

Field Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FClickedVal8 Field

Summary

Represents field FClickedVal8.

Namespace: frxChart
Syntax
Delphi
private
 FClickedVal8: String;

Field Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FClickedVal9 Field

Summary

Represents field FClickedVal9.

Namespace: frxChart
Syntax
Delphi
private
 FClickedVal9: String;

Field Value

Type: String

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FEMF Field

Summary

Represents field FEMF.

Namespace: frxChart
Syntax
Delphi
private
 FEMF: TMetafile;

Field Value

Type: TMetafile

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FHighlightColor Field

Summary

Represents field FHighlightColor.

Namespace: frxChart
Syntax
Delphi
private
 FHighlightColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FHlIndex Field

Summary

Represents field FHlIndex.

Namespace: frxChart
Syntax
Delphi
private
 FHlIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FIgnoreNulls Field

Summary

Represents field FIgnoreNulls.

Namespace: frxChart
Syntax
Delphi
private
 FIgnoreNulls: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FLockFillSeries Field

Summary

Represents field FLockFillSeries.

Namespace: frxChart
Syntax
Delphi
private
 FLockFillSeries: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FMacroLoaded Field

Summary

Represents field FMacroLoaded.

Namespace: frxChart
Syntax
Delphi
private
 FMacroLoaded: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FMouseDown Field

Summary

Represents field FMouseDown.

Namespace: frxChart
Syntax
Delphi
private
 FMouseDown: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FMouseOffsetX Field

Summary

Represents field FMouseOffsetX.

Namespace: frxChart
Syntax
Delphi
private
 FMouseOffsetX: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FMouseOffsetY Field

Summary

Represents field FMouseOffsetY.

Namespace: frxChart
Syntax
Delphi
private
 FMouseOffsetY: Extended;

Field Value

Type: Extended

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FPenStyle Field

Summary

Represents field FPenStyle.

Namespace: frxChart
Syntax
Delphi
private
 FPenStyle: TPenStyle;

Field Value

Type: TPenStyle

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FPenWidth Field

Summary

Represents field FPenWidth.

Namespace: frxChart
Syntax
Delphi
private
 FPenWidth: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FSavedColor Field

Summary

Represents field FSavedColor.

Namespace: frxChart
Syntax
Delphi
private
 FSavedColor: TColor;

Field Value

Type: TColor

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FSeriesData Field

Summary

Represents field FSeriesData.

Namespace: frxChart
Syntax
Delphi
private
 FSeriesData: TfrxSeriesData;

Field Value

Type: TfrxSeriesData

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FSeriesFilled Field

Summary

Represents field FSeriesFilled.

Namespace: frxChart
Syntax
Delphi
private
 FSeriesFilled: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxChartView.FSeriesIndex Field

Summary

Represents field FSeriesIndex.

Namespace: frxChart
Syntax
Delphi
private
 FSeriesIndex: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxChartView
  • frxChart


TfrxSeriesData Class

Summary

The TfrxSeriesData class represents collection of series.

Namespace: frxChart
Inheritance Hierarchy
TfrxCollection
frxChart.TfrxSeriesData
Syntax
Delphi
type
 TfrxSeriesData = class(TfrxCollection)
 end;

The TfrxSeriesData type exposes the following members.

Constructors
Show:
Name | Description
Create(TfrxReport) | Initializes a new instance of the TfrxSeriesData class.
Top
Properties
Show:
Name | Description
Items[Integer] | List of series.
Top
Methods
Show:
Name | Description
Add | Adds a new item to the collection.
GetSeries(Integer) | Represents method GetSeries(Integer).
Top
Fields
Show:
Name | Description
FReport | Represents field FReport.
Top
See Also

Reference

  • frxChart


TfrxSeriesData Constructors

Constructors
Name | Description
Create(TfrxReport) | Initializes a new instance of the TfrxSeriesData class.
Top


TfrxSeriesData.Create(TfrxReport) Constructor

Summary

Initializes a new instance of the TfrxSeriesData class.

Namespace: frxChart
Syntax
Delphi
public
 constructor Create(Report: TfrxReport);

Parameters

Report
Type: TfrxReport

See Also

Reference

  • TfrxSeriesData
  • frxChart


TfrxSeriesData Properties

Properties
Name | Description
Items[Integer] | List of series.
Top


TfrxSeriesData.Items[Integer] Property

Summary

List of series.

Namespace: frxChart
Syntax
Delphi
public
 property Items[Index: Integer]: TfrxSeriesItem read GetSeries; default;

Parameters

Index
Type: Integer

Property Value

Type: TfrxSeriesItem

See Also

Reference

  • TfrxSeriesData
  • frxChart


TfrxSeriesData Methods

Methods
Name | Description
Add | Adds a new item to the collection.
GetSeries(Integer) | Represents method GetSeries(Integer).
Top


TfrxSeriesData.Add Method

Summary

Adds a new item to the collection.

Namespace: frxChart
Syntax
Delphi
public
 function Add: TfrxSeriesItem;

Return Value

Type: TfrxSeriesItem

See Also

Reference

  • TfrxSeriesData
  • frxChart


TfrxSeriesData.GetSeries(Integer) Method

Summary

Represents method GetSeries(Integer).

Namespace: frxChart
Syntax
Delphi
private
 function GetSeries(Index: Integer): TfrxSeriesItem;

Parameters

Index
Type: Integer

Return Value

Type: TfrxSeriesItem

See Also

Reference

  • TfrxSeriesData
  • frxChart


TfrxSeriesData Fields

Fields
Name | Description
FReport | Represents field FReport.
Top


TfrxSeriesData.FReport Field

Summary

Represents field FReport.

Namespace: frxChart
Syntax
Delphi
private
 FReport: TfrxReport;

Field Value

Type: TfrxReport

See Also

Reference

  • TfrxSeriesData
  • frxChart


TfrxSeriesItem Class

Summary

The TfrxSeriesItem class represents one series.

Namespace: frxChart
Inheritance Hierarchy
TfrxCollectionItem
frxChart.TfrxSeriesItem
Syntax
Delphi
type
 TfrxSeriesItem = class(TfrxCollectionItem)
 end;

The TfrxSeriesItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxSeriesItem class.
Destroy | Represents the destructor of the TfrxSeriesItem class.
Top
Properties
Show:
Name | Description
DataBand | Band which the series is connected to. Used if DataType = dtBandData.
DataSet | Dataset which is series connected to. This property is used if property DataType = dtDBData.
DataSetName | Represents property DataSetName.
DataType | Type of series data.
InheritedName | Represents property InheritedName.
SortOrder | Sort order of series data.
Source1 | Datasource1 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source10 | Datasource10 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source2 | Datasource2 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source3 | Datasource3 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source4 | Datasource4 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source5 | Datasource5 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source6 | Datasource6 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source7 | Datasource7 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source8 | Datasource8 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source9 | Datasource9 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
TopN | Show TopN values. Sum of other values shows as a separate value with caption set in the TopNCaption property.
TopNCaption | Show TopN values. Sum of other values shows as a separate value with caption set in the TopNCaption property.
Values1 | Represents property Values1.
Values10 | Represents property Values10.
Values2 | Represents property Values2.
Values3 | Represents property Values3.
Values4 | Represents property Values4.
Values5 | Represents property Values5.
Values6 | Represents property Values6.
Values7 | Represents property Values7.
Values8 | Represents property Values8.
Values9 | Represents property Values9.
XSource | Represents property XSource.
XType | The X-axis data type: text, numeric, date.
XValues | Represents property XValues.
YSource | Represents property YSource.
YValues | Represents property YValues.
Top
Methods
Show:
Name | Description
FillSeries(TChartSeries) | Represents method FillSeries(TChartSeries).
GetDataSetName | Represents method GetDataSetName.
IsUniqueNameStored | Represents method IsUniqueNameStored.
SetDataSet(TfrxDataSet) | Represents method SetDataSet(TfrxDataSet).
SetDataSetName(String) | Represents method SetDataSetName(String).
Top
Fields
Show:
Name | Description
FDataBand | Represents field FDataBand.
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
FDataType | Represents field FDataType.
Fsl1 | Represents field Fsl1.
Fsl10 | Represents field Fsl10.
Fsl2 | Represents field Fsl2.
Fsl3 | Represents field Fsl3.
Fsl4 | Represents field Fsl4.
Fsl5 | Represents field Fsl5.
Fsl6 | Represents field Fsl6.
Fsl7 | Represents field Fsl7.
Fsl8 | Represents field Fsl8.
Fsl9 | Represents field Fsl9.
FSortOrder | Represents field FSortOrder.
FSource1 | Represents field FSource1.
FSource10 | Represents field FSource10.
FSource2 | Represents field FSource2.
FSource3 | Represents field FSource3.
FSource4 | Represents field FSource4.
FSource5 | Represents field FSource5.
FSource6 | Represents field FSource6.
FSource7 | Represents field FSource7.
FSource8 | Represents field FSource8.
FSource9 | Represents field FSource9.
FTopN | Represents field FTopN.
FTopNCaption | Represents field FTopNCaption.
FValueIndex1 | Represents field FValueIndex1.
FValueIndex10 | Represents field FValueIndex10.
FValueIndex2 | Represents field FValueIndex2.
FValueIndex3 | Represents field FValueIndex3.
FValueIndex4 | Represents field FValueIndex4.
FValueIndex5 | Represents field FValueIndex5.
FValueIndex6 | Represents field FValueIndex6.
FValueIndex7 | Represents field FValueIndex7.
FValueIndex8 | Represents field FValueIndex8.
FValueIndex9 | Represents field FValueIndex9.
FValues1 | Represents field FValues1.
FValues10 | Represents field FValues10.
FValues2 | Represents field FValues2.
FValues3 | Represents field FValues3.
FValues4 | Represents field FValues4.
FValues5 | Represents field FValues5.
FValues6 | Represents field FValues6.
FValues7 | Represents field FValues7.
FValues8 | Represents field FValues8.
FValues9 | Represents field FValues9.
FXType | Represents field FXType.
Top
See Also

Reference

  • frxChart


TfrxSeriesItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TfrxSeriesItem class.
Destroy | Represents the destructor of the TfrxSeriesItem class.
Top


TfrxSeriesItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TfrxSeriesItem class.

Namespace: frxChart
Syntax
Delphi
public
 constructor Create(Collection: TCollection); override;

Parameters

Collection
Type: TCollection

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Destroy Destructor

Summary

Represents the destructor of the TfrxSeriesItem class.

Namespace: frxChart
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem Properties

Properties
Name | Description
DataBand | Band which the series is connected to. Used if DataType = dtBandData.
DataSet | Dataset which is series connected to. This property is used if property DataType = dtDBData.
DataSetName | Represents property DataSetName.
DataType | Type of series data.
InheritedName | Represents property InheritedName.
SortOrder | Sort order of series data.
Source1 | Datasource1 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source10 | Datasource10 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source2 | Datasource2 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source3 | Datasource3 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source4 | Datasource4 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source5 | Datasource5 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source6 | Datasource6 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source7 | Datasource7 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source8 | Datasource8 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
Source9 | Datasource9 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).
TopN | Show TopN values. Sum of other values shows as a separate value with caption set in the TopNCaption property.
TopNCaption | Show TopN values. Sum of other values shows as a separate value with caption set in the TopNCaption property.
Values1 | Represents property Values1.
Values10 | Represents property Values10.
Values2 | Represents property Values2.
Values3 | Represents property Values3.
Values4 | Represents property Values4.
Values5 | Represents property Values5.
Values6 | Represents property Values6.
Values7 | Represents property Values7.
Values8 | Represents property Values8.
Values9 | Represents property Values9.
XSource | Represents property XSource.
XType | The X-axis data type: text, numeric, date.
XValues | Represents property XValues.
YSource | Represents property YSource.
YValues | Represents property YValues.
Top


TfrxSeriesItem.DataBand Property

Summary

Band which the series is connected to. Used if DataType = dtBandData.

Namespace: frxChart
Syntax
Delphi
published
 property DataBand: TfrxDataBand read FDataBand write FDataBand;

Property Value

Type: TfrxDataBand

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.DataSet Property

Summary

Dataset which is series connected to. This property is used if property DataType = dtDBData.

Namespace: frxChart
Syntax
Delphi
published
 property DataSet: TfrxDataSet read FDataSet write SetDataSet;

Property Value

Type: TfrxDataSet

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.DataSetName Property

Summary

Represents property DataSetName.

Namespace: frxChart
Syntax
Delphi
published
 property DataSetName: String read GetDataSetName write SetDataSetName;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.DataType Property

Summary

Type of series data.

Namespace: frxChart
Syntax
Delphi
published
 property DataType: TfrxSeriesDataType read FDataType write FDataType;

Property Value

Type: TfrxSeriesDataType

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.InheritedName Property

Summary

Represents property InheritedName.

Namespace: frxChart
Syntax
Delphi
published
 property InheritedName: String read GetInheritedName write SetInheritedName stored False;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.SortOrder Property

Summary

Sort order of series data.

Namespace: frxChart
Syntax
Delphi
published
 property SortOrder: TfrxSeriesSortOrder read FSortOrder write FSortOrder;

Property Value

Type: TfrxSeriesSortOrder

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Source1 Property

Summary

Datasource1 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).

Namespace: frxChart
Syntax
Delphi
published
 property Source1: String read FSource1 write FSource1;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Source10 Property

Summary

Datasource10 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).

Namespace: frxChart
Syntax
Delphi
published
 property Source10: String read FSource10 write FSource10;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Source2 Property

Summary

Datasource2 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).

Namespace: frxChart
Syntax
Delphi
published
 property Source2: String read FSource2 write FSource2;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Source3 Property

Summary

Datasource3 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).

Namespace: frxChart
Syntax
Delphi
published
 property Source3: String read FSource3 write FSource3;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Source4 Property

Summary

Datasource4 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).

Namespace: frxChart
Syntax
Delphi
published
 property Source4: String read FSource4 write FSource4;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Source5 Property

Summary

Datasource5 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).

Namespace: frxChart
Syntax
Delphi
published
 property Source5: String read FSource5 write FSource5;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Source6 Property

Summary

Datasource6 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).

Namespace: frxChart
Syntax
Delphi
published
 property Source6: String read FSource6 write FSource6;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Source7 Property

Summary

Datasource7 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).

Namespace: frxChart
Syntax
Delphi
published
 property Source7: String read FSource7 write FSource7;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Source8 Property

Summary

Datasource8 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).

Namespace: frxChart
Syntax
Delphi
published
 property Source8: String read FSource8 write FSource8;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Source9 Property

Summary

Datasource9 for axis values. This property may contain an expression or list of fixed data (in case DataType property is dtFixedData).

Namespace: frxChart
Syntax
Delphi
published
 property Source9: String read FSource9 write FSource9;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.TopN Property

Summary

Show TopN values. Sum of other values shows as a separate value with caption set in the TopNCaption property.

Namespace: frxChart
Syntax
Delphi
published
 property TopN: Integer read FTopN write FTopN;

Property Value

Type: Integer

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.TopNCaption Property

Summary

Show TopN values. Sum of other values shows as a separate value with caption set in the TopNCaption property.

Namespace: frxChart
Syntax
Delphi
published
 property TopNCaption: String read FTopNCaption write FTopNCaption;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Values1 Property

Summary

Represents property Values1.

Namespace: frxChart
Syntax
Delphi
published
 property Values1: String read FValues1 write FValues1;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Values10 Property

Summary

Represents property Values10.

Namespace: frxChart
Syntax
Delphi
published
 property Values10: String read FValues10 write FValues10;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Values2 Property

Summary

Represents property Values2.

Namespace: frxChart
Syntax
Delphi
published
 property Values2: String read FValues2 write FValues2;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Values3 Property

Summary

Represents property Values3.

Namespace: frxChart
Syntax
Delphi
published
 property Values3: String read FValues3 write FValues3;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Values4 Property

Summary

Represents property Values4.

Namespace: frxChart
Syntax
Delphi
published
 property Values4: String read FValues4 write FValues4;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Values5 Property

Summary

Represents property Values5.

Namespace: frxChart
Syntax
Delphi
published
 property Values5: String read FValues5 write FValues5;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Values6 Property

Summary

Represents property Values6.

Namespace: frxChart
Syntax
Delphi
published
 property Values6: String read FValues6 write FValues6;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Values7 Property

Summary

Represents property Values7.

Namespace: frxChart
Syntax
Delphi
published
 property Values7: String read FValues7 write FValues7;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Values8 Property

Summary

Represents property Values8.

Namespace: frxChart
Syntax
Delphi
published
 property Values8: String read FValues8 write FValues8;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Values9 Property

Summary

Represents property Values9.

Namespace: frxChart
Syntax
Delphi
published
 property Values9: String read FValues9 write FValues9;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.XSource Property

Summary

Represents property XSource.

Namespace: frxChart
Syntax
Delphi
published
 property XSource: String read FSource1 write FSource1;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.XType Property

Summary

The X-axis data type: text, numeric, date.

Namespace: frxChart
Syntax
Delphi
published
 property XType: TfrxSeriesXType read FXType write FXType;

Property Value

Type: TfrxSeriesXType

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.XValues Property

Summary

Represents property XValues.

Namespace: frxChart
Syntax
Delphi
published
 property XValues: String read FValues1 write FValues1;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.YSource Property

Summary

Represents property YSource.

Namespace: frxChart
Syntax
Delphi
published
 property YSource: String read FSource2 write FSource2;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.YValues Property

Summary

Represents property YValues.

Namespace: frxChart
Syntax
Delphi
published
 property YValues: String read FValues2 write FValues2;

Property Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem Methods

Methods
Name | Description
FillSeries(TChartSeries) | Represents method FillSeries(TChartSeries).
GetDataSetName | Represents method GetDataSetName.
IsUniqueNameStored | Represents method IsUniqueNameStored.
SetDataSet(TfrxDataSet) | Represents method SetDataSet(TfrxDataSet).
SetDataSetName(String) | Represents method SetDataSetName(String).
Top


TfrxSeriesItem.FillSeries(TChartSeries) Method

Summary

Represents method FillSeries(TChartSeries).

Namespace: frxChart
Syntax
Delphi
private
 procedure FillSeries(Series: TChartSeries);

Parameters

Series
Type: TChartSeries

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.GetDataSetName Method

Summary

Represents method GetDataSetName.

Namespace: frxChart
Syntax
Delphi
private
 function GetDataSetName: String;

Return Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.IsUniqueNameStored Method

Summary

Represents method IsUniqueNameStored.

Namespace: frxChart
Syntax
Delphi
public
 function IsUniqueNameStored: Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.SetDataSet(TfrxDataSet) Method

Summary

Represents method SetDataSet(TfrxDataSet).

Namespace: frxChart
Syntax
Delphi
private
 procedure SetDataSet(const Value: TfrxDataSet);

Parameters

Value
Type: TfrxDataSet

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.SetDataSetName(String) Method

Summary

Represents method SetDataSetName(String).

Namespace: frxChart
Syntax
Delphi
private
 procedure SetDataSetName(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem Fields

Fields
Name | Description
FDataBand | Represents field FDataBand.
FDataSet | Represents field FDataSet.
FDataSetName | Represents field FDataSetName.
FDataType | Represents field FDataType.
Fsl1 | Represents field Fsl1.
Fsl10 | Represents field Fsl10.
Fsl2 | Represents field Fsl2.
Fsl3 | Represents field Fsl3.
Fsl4 | Represents field Fsl4.
Fsl5 | Represents field Fsl5.
Fsl6 | Represents field Fsl6.
Fsl7 | Represents field Fsl7.
Fsl8 | Represents field Fsl8.
Fsl9 | Represents field Fsl9.
FSortOrder | Represents field FSortOrder.
FSource1 | Represents field FSource1.
FSource10 | Represents field FSource10.
FSource2 | Represents field FSource2.
FSource3 | Represents field FSource3.
FSource4 | Represents field FSource4.
FSource5 | Represents field FSource5.
FSource6 | Represents field FSource6.
FSource7 | Represents field FSource7.
FSource8 | Represents field FSource8.
FSource9 | Represents field FSource9.
FTopN | Represents field FTopN.
FTopNCaption | Represents field FTopNCaption.
FValueIndex1 | Represents field FValueIndex1.
FValueIndex10 | Represents field FValueIndex10.
FValueIndex2 | Represents field FValueIndex2.
FValueIndex3 | Represents field FValueIndex3.
FValueIndex4 | Represents field FValueIndex4.
FValueIndex5 | Represents field FValueIndex5.
FValueIndex6 | Represents field FValueIndex6.
FValueIndex7 | Represents field FValueIndex7.
FValueIndex8 | Represents field FValueIndex8.
FValueIndex9 | Represents field FValueIndex9.
FValues1 | Represents field FValues1.
FValues10 | Represents field FValues10.
FValues2 | Represents field FValues2.
FValues3 | Represents field FValues3.
FValues4 | Represents field FValues4.
FValues5 | Represents field FValues5.
FValues6 | Represents field FValues6.
FValues7 | Represents field FValues7.
FValues8 | Represents field FValues8.
FValues9 | Represents field FValues9.
FXType | Represents field FXType.
Top


TfrxSeriesItem.FDataBand Field

Summary

Represents field FDataBand.

Namespace: frxChart
Syntax
Delphi
private
 FDataBand: TfrxDataBand;

Field Value

Type: TfrxDataBand

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FDataSet Field

Summary

Represents field FDataSet.

Namespace: frxChart
Syntax
Delphi
private
 FDataSet: TfrxDataSet;

Field Value

Type: TfrxDataSet

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FDataSetName Field

Summary

Represents field FDataSetName.

Namespace: frxChart
Syntax
Delphi
private
 FDataSetName: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FDataType Field

Summary

Represents field FDataType.

Namespace: frxChart
Syntax
Delphi
private
 FDataType: TfrxSeriesDataType;

Field Value

Type: TfrxSeriesDataType

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Fsl1 Field

Summary

Represents field Fsl1.

Namespace: frxChart
Syntax
Delphi
private
 Fsl1: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Fsl10 Field

Summary

Represents field Fsl10.

Namespace: frxChart
Syntax
Delphi
private
 Fsl10: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Fsl2 Field

Summary

Represents field Fsl2.

Namespace: frxChart
Syntax
Delphi
private
 Fsl2: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Fsl3 Field

Summary

Represents field Fsl3.

Namespace: frxChart
Syntax
Delphi
private
 Fsl3: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Fsl4 Field

Summary

Represents field Fsl4.

Namespace: frxChart
Syntax
Delphi
private
 Fsl4: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Fsl5 Field

Summary

Represents field Fsl5.

Namespace: frxChart
Syntax
Delphi
private
 Fsl5: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Fsl6 Field

Summary

Represents field Fsl6.

Namespace: frxChart
Syntax
Delphi
private
 Fsl6: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Fsl7 Field

Summary

Represents field Fsl7.

Namespace: frxChart
Syntax
Delphi
private
 Fsl7: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Fsl8 Field

Summary

Represents field Fsl8.

Namespace: frxChart
Syntax
Delphi
private
 Fsl8: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.Fsl9 Field

Summary

Represents field Fsl9.

Namespace: frxChart
Syntax
Delphi
private
 Fsl9: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FSortOrder Field

Summary

Represents field FSortOrder.

Namespace: frxChart
Syntax
Delphi
private
 FSortOrder: TfrxSeriesSortOrder;

Field Value

Type: TfrxSeriesSortOrder

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FSource1 Field

Summary

Represents field FSource1.

Namespace: frxChart
Syntax
Delphi
private
 FSource1: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FSource10 Field

Summary

Represents field FSource10.

Namespace: frxChart
Syntax
Delphi
private
 FSource10: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FSource2 Field

Summary

Represents field FSource2.

Namespace: frxChart
Syntax
Delphi
private
 FSource2: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FSource3 Field

Summary

Represents field FSource3.

Namespace: frxChart
Syntax
Delphi
private
 FSource3: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FSource4 Field

Summary

Represents field FSource4.

Namespace: frxChart
Syntax
Delphi
private
 FSource4: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FSource5 Field

Summary

Represents field FSource5.

Namespace: frxChart
Syntax
Delphi
private
 FSource5: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FSource6 Field

Summary

Represents field FSource6.

Namespace: frxChart
Syntax
Delphi
private
 FSource6: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FSource7 Field

Summary

Represents field FSource7.

Namespace: frxChart
Syntax
Delphi
private
 FSource7: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FSource8 Field

Summary

Represents field FSource8.

Namespace: frxChart
Syntax
Delphi
private
 FSource8: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FSource9 Field

Summary

Represents field FSource9.

Namespace: frxChart
Syntax
Delphi
private
 FSource9: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FTopN Field

Summary

Represents field FTopN.

Namespace: frxChart
Syntax
Delphi
private
 FTopN: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FTopNCaption Field

Summary

Represents field FTopNCaption.

Namespace: frxChart
Syntax
Delphi
private
 FTopNCaption: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValueIndex1 Field

Summary

Represents field FValueIndex1.

Namespace: frxChart
Syntax
Delphi
private
 FValueIndex1: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValueIndex10 Field

Summary

Represents field FValueIndex10.

Namespace: frxChart
Syntax
Delphi
private
 FValueIndex10: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValueIndex2 Field

Summary

Represents field FValueIndex2.

Namespace: frxChart
Syntax
Delphi
private
 FValueIndex2: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValueIndex3 Field

Summary

Represents field FValueIndex3.

Namespace: frxChart
Syntax
Delphi
private
 FValueIndex3: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValueIndex4 Field

Summary

Represents field FValueIndex4.

Namespace: frxChart
Syntax
Delphi
private
 FValueIndex4: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValueIndex5 Field

Summary

Represents field FValueIndex5.

Namespace: frxChart
Syntax
Delphi
private
 FValueIndex5: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValueIndex6 Field

Summary

Represents field FValueIndex6.

Namespace: frxChart
Syntax
Delphi
private
 FValueIndex6: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValueIndex7 Field

Summary

Represents field FValueIndex7.

Namespace: frxChart
Syntax
Delphi
private
 FValueIndex7: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValueIndex8 Field

Summary

Represents field FValueIndex8.

Namespace: frxChart
Syntax
Delphi
private
 FValueIndex8: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValueIndex9 Field

Summary

Represents field FValueIndex9.

Namespace: frxChart
Syntax
Delphi
private
 FValueIndex9: Integer;

Field Value

Type: Integer

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValues1 Field

Summary

Represents field FValues1.

Namespace: frxChart
Syntax
Delphi
private
 FValues1: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValues10 Field

Summary

Represents field FValues10.

Namespace: frxChart
Syntax
Delphi
private
 FValues10: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValues2 Field

Summary

Represents field FValues2.

Namespace: frxChart
Syntax
Delphi
private
 FValues2: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValues3 Field

Summary

Represents field FValues3.

Namespace: frxChart
Syntax
Delphi
private
 FValues3: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValues4 Field

Summary

Represents field FValues4.

Namespace: frxChart
Syntax
Delphi
private
 FValues4: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValues5 Field

Summary

Represents field FValues5.

Namespace: frxChart
Syntax
Delphi
private
 FValues5: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValues6 Field

Summary

Represents field FValues6.

Namespace: frxChart
Syntax
Delphi
private
 FValues6: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValues7 Field

Summary

Represents field FValues7.

Namespace: frxChart
Syntax
Delphi
private
 FValues7: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValues8 Field

Summary

Represents field FValues8.

Namespace: frxChart
Syntax
Delphi
private
 FValues8: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FValues9 Field

Summary

Represents field FValues9.

Namespace: frxChart
Syntax
Delphi
private
 FValues9: String;

Field Value

Type: String

See Also

Reference

  • TfrxSeriesItem
  • frxChart


TfrxSeriesItem.FXType Field

Summary

Represents field FXType.

Namespace: frxChart
Syntax
Delphi
private
 FXType: TfrxSeriesXType;

Field Value

Type: TfrxSeriesXType

See Also

Reference

  • TfrxSeriesItem
  • frxChart


frxChart Enumerations

Enumerations
Name | Description
TfrxChartSeries | Series types.
TfrxSeriesDataType | Data type of the series: DB data, band data or fixed data.
TfrxSeriesSortOrder | Sort type of the series data.
TfrxSeriesXType | The X-axis data type: text, numeric, date.
Top


TfrxChartSeries Enumeration

Summary

Series types.

Namespace: frxChart
Syntax
Delphi
type
 TfrxChartSeries = (csLine, csArea, csPoint, csBar, csHorizBar,
 csPie, csGantt, csFastLine, csArrow, csBubble, csChartShape, csHorizArea,
 csHorizLine, csPolar, csRadar, csPolarBar, csGauge, csSmith, csPyramid,
 csDonut, csBezier, csCandle, csVolume, csPointFigure, csHistogram,
 csHorizHistogram, csErrorBar, csError, csHighLow, csFunnel, csBox,
 csHorizBox, csSurface, csContour, csWaterFall, csColorGrid, csVector3D,
 csTower, csTriSurface, csPoint3D, csBubble3D, csMyPoint, csBarJoin, csBar3D,
 csPolarContourSeries, csEquiVolumeSeries, csCircularGauge, csClockGauge,
 csNumericGauge, csBigCandle, csDeltaPoint, TImageBar, TImagePoint,
 csWindRose, csErrorPoint3D, csErrorPoint, csEqualizer, csPolarGrid,
 csOrg, csKagi, csRenko, csTagCloud, csHighLowLine, csVolumePipe, csTreeMap,
 csKnobGauge, csRose, csTernary
 );

The TfrxChartSeries type exposes the following members.

Members
Show:
Name | Description
csArea | Represents constant csArea.
csArrow | Represents constant csArrow.
csBar | Represents constant csBar.
csBar3D | Represents constant csBar3D.
csBarJoin | Represents constant csBarJoin.
csBezier | Represents constant csBezier.
csBigCandle | Represents constant csBigCandle.
csBox | Represents constant csBox.
csBubble | Represents constant csBubble.
csBubble3D | Represents constant csBubble3D.
csCandle | Represents constant csCandle.
csChartShape | Represents constant csChartShape.
csCircularGauge | Represents constant csCircularGauge.
csClockGauge | Represents constant csClockGauge.
csColorGrid | Represents constant csColorGrid.
csContour | Represents constant csContour.
csDeltaPoint | Represents constant csDeltaPoint.
csDonut | Represents constant csDonut.
csEqualizer | Represents constant csEqualizer.
csEquiVolumeSeries | Represents constant csEquiVolumeSeries.
csError | Represents constant csError.
csErrorBar | Represents constant csErrorBar.
csErrorPoint | Represents constant csErrorPoint.
csErrorPoint3D | Represents constant csErrorPoint3D.
csFastLine | Represents constant csFastLine.
csFunnel | Represents constant csFunnel.
csGantt | Represents constant csGantt.
csGauge | Represents constant csGauge.
csHighLow | Represents constant csHighLow.
csHighLowLine | Represents constant csHighLowLine.
csHistogram | Represents constant csHistogram.
csHorizArea | Represents constant csHorizArea.
csHorizBar | Represents constant csHorizBar.
csHorizBox | Represents constant csHorizBox.
csHorizHistogram | Represents constant csHorizHistogram.
csHorizLine | Represents constant csHorizLine.
csKagi | Represents constant csKagi.
csKnobGauge | Represents constant csKnobGauge.
csLine | Represents constant csLine.
csMyPoint | Represents constant csMyPoint.
csNumericGauge | Represents constant csNumericGauge.
csOrg | Represents constant csOrg.
csPie | Represents constant csPie.
csPoint | Represents constant csPoint.
csPoint3D | Represents constant csPoint3D.
csPointFigure | Represents constant csPointFigure.
csPolar | Represents constant csPolar.
csPolarBar | Represents constant csPolarBar.
csPolarContourSeries | Represents constant csPolarContourSeries.
csPolarGrid | Represents constant csPolarGrid.
csPyramid | Represents constant csPyramid.
csRadar | Represents constant csRadar.
csRenko | Represents constant csRenko.
csRose | Represents constant csRose.
csSmith | Represents constant csSmith.
csSurface | Represents constant csSurface.
csTagCloud | Represents constant csTagCloud.
csTernary | Represents constant csTernary.
csTower | Represents constant csTower.
csTreeMap | Represents constant csTreeMap.
csTriSurface | Represents constant csTriSurface.
csVector3D | Represents constant csVector3D.
csVolume | Represents constant csVolume.
csVolumePipe | Represents constant csVolumePipe.
csWaterFall | Represents constant csWaterFall.
csWindRose | Represents constant csWindRose.
TImageBar | Represents constant TImageBar.
TImagePoint | Represents constant TImagePoint.
Top
See Also

Reference

  • frxChart


TfrxSeriesDataType Enumeration

Summary

Data type of the series: DB data, band data or fixed data.

Namespace: frxChart
Syntax
Delphi
type
 TfrxSeriesDataType = (dtDBData, dtBandData, dtFixedData);

The TfrxSeriesDataType type exposes the following members.

Members
Show:
Name | Description
dtBandData | Represents constant dtBandData.
dtDBData | Represents constant dtDBData.
dtFixedData | Represents constant dtFixedData.
Top
See Also

Reference

  • frxChart


TfrxSeriesSortOrder Enumeration

Summary

Sort type of the series data.

Namespace: frxChart
Syntax
Delphi
type
 TfrxSeriesSortOrder = (soNone, soAscending, soDescending);

The TfrxSeriesSortOrder type exposes the following members.

Members
Show:
Name | Description
soAscending | Represents constant soAscending.
soDescending | Represents constant soDescending.
soNone | Represents constant soNone.
Top
See Also

Reference

  • frxChart


TfrxSeriesXType Enumeration

Summary

The X-axis data type: text, numeric, date.

Namespace: frxChart
Syntax
Delphi
type
 TfrxSeriesXType = (xtText, xtNumber, xtDate);

The TfrxSeriesXType type exposes the following members.

Members
Show:
Name | Description
xtDate | Represents constant xtDate.
xtNumber | Represents constant xtNumber.
xtText | Represents constant xtText.
Top
See Also

Reference

  • frxChart


frxChart Types

Types
Name | Description
TChartClass | Represents type TChartClass.
TSeriesClass | Represents type TSeriesClass.
Top


TChartClass Type

Summary

Represents type TChartClass.

Namespace: frxChart
Syntax
Delphi
type
 TChartClass = class of TCustomChart;
See Also

Reference

  • frxChart


TSeriesClass Type

Summary

Represents type TSeriesClass.

Namespace: frxChart
Syntax
Delphi
type
 TSeriesClass = class of TChartSeries;
See Also

Reference

  • frxChart


frxChartClipboard Namespace

Summary

Represents namespace frxChartClipboard.


frxChartHelpers Namespace

Summary

Represents namespace frxChartHelpers.

Classes
Name | Description
TfrxArrowSeriesHelper | Represents type TfrxArrowSeriesHelper.
TfrxBubbleSeriesHelper | Represents type TfrxBubbleSeriesHelper.
TfrxGanttSeriesHelper | Represents type TfrxGanttSeriesHelper.
TfrxPieSeriesHelper | Represents type TfrxPieSeriesHelper.
TfrxSeriesHelper | Represents type TfrxSeriesHelper.
TfrxStdSeriesHelper | Represents type TfrxStdSeriesHelper.
Top
Types
Name | Description
TfrxSeriesHelperClass | Represents type TfrxSeriesHelperClass.
Top
Constants
Name | Description
frxChartSeries | Represents constant frxChartSeries.
frxNumSeries | Represents constant frxNumSeries.
frxSeriesHelpers | Represents constant frxSeriesHelpers.
Top
Routines
Name | Description
frxFindSeriesHelper(TChartSeries) | Represents method frxFindSeriesHelper(TChartSeries).
Top


frxChartHelpers Classes

Classes
Name | Description
TfrxArrowSeriesHelper | Represents type TfrxArrowSeriesHelper.
TfrxBubbleSeriesHelper | Represents type TfrxBubbleSeriesHelper.
TfrxGanttSeriesHelper | Represents type TfrxGanttSeriesHelper.
TfrxPieSeriesHelper | Represents type TfrxPieSeriesHelper.
TfrxSeriesHelper | Represents type TfrxSeriesHelper.
TfrxStdSeriesHelper | Represents type TfrxStdSeriesHelper.
Top


TfrxArrowSeriesHelper Class

Summary

Represents type TfrxArrowSeriesHelper.

Namespace: frxChartHelpers
Inheritance Hierarchy
TObject
frxChartHelpers.TfrxSeriesHelper
frxChartHelpers.TfrxArrowSeriesHelper
Syntax
Delphi
type
 TfrxArrowSeriesHelper = class(TfrxSeriesHelper)
 end;

The TfrxArrowSeriesHelper type exposes the following members.

Methods
Show:
Name | Description
AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType) | Overloaded. Represents method AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType). (Inherited from TfrxSeriesHelper.)
AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) | Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType). (Overrides TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).)
GetParamNames | Represents method GetParamNames. (Overrides TfrxSeriesHelper.GetParamNames.)
Top
See Also

Reference

  • frxChartHelpers


TfrxArrowSeriesHelper Methods

Methods
Name | Description
AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) | Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType). (Overrides TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).)
GetParamNames | Represents method GetParamNames. (Overrides TfrxSeriesHelper.GetParamNames.)
Top


TfrxArrowSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) Method

Summary

Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).

Namespace: frxChartHelpers
Syntax
Delphi
public
 procedure AddValues(Series: TChartSeries; const v1, v2, v3, v4, v5, v6: String;
 XType: TfrxSeriesXType); override;

Parameters

Series
Type: TChartSeries

v1
Type: String

v2
Type: String

v3
Type: String

v4
Type: String

v5
Type: String

v6
Type: String

XType
Type: TfrxSeriesXType

Overrides

TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType)
See Also

Reference

  • TfrxArrowSeriesHelper
  • frxChartHelpers


TfrxArrowSeriesHelper.GetParamNames Method

Summary

Represents method GetParamNames.

Namespace: frxChartHelpers
Syntax
Delphi
public
 function GetParamNames: String; override;

Return Value

Type: String

Overrides

TfrxSeriesHelper.GetParamNames
See Also

Reference

  • TfrxArrowSeriesHelper
  • frxChartHelpers


TfrxBubbleSeriesHelper Class

Summary

Represents type TfrxBubbleSeriesHelper.

Namespace: frxChartHelpers
Inheritance Hierarchy
TObject
frxChartHelpers.TfrxSeriesHelper
frxChartHelpers.TfrxBubbleSeriesHelper
Syntax
Delphi
type
 TfrxBubbleSeriesHelper = class(TfrxSeriesHelper)
 end;

The TfrxBubbleSeriesHelper type exposes the following members.

Methods
Show:
Name | Description
AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType) | Overloaded. Represents method AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType). (Inherited from TfrxSeriesHelper.)
AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) | Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType). (Overrides TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).)
GetParamNames | Represents method GetParamNames. (Overrides TfrxSeriesHelper.GetParamNames.)
Top
See Also

Reference

  • frxChartHelpers


TfrxBubbleSeriesHelper Methods

Methods
Name | Description
AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) | Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType). (Overrides TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).)
GetParamNames | Represents method GetParamNames. (Overrides TfrxSeriesHelper.GetParamNames.)
Top


TfrxBubbleSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) Method

Summary

Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).

Namespace: frxChartHelpers
Syntax
Delphi
public
 procedure AddValues(Series: TChartSeries; const v1, v2, v3, v4, v5, v6: String;
 XType: TfrxSeriesXType); override;

Parameters

Series
Type: TChartSeries

v1
Type: String

v2
Type: String

v3
Type: String

v4
Type: String

v5
Type: String

v6
Type: String

XType
Type: TfrxSeriesXType

Overrides

TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType)
See Also

Reference

  • TfrxBubbleSeriesHelper
  • frxChartHelpers


TfrxBubbleSeriesHelper.GetParamNames Method

Summary

Represents method GetParamNames.

Namespace: frxChartHelpers
Syntax
Delphi
public
 function GetParamNames: String; override;

Return Value

Type: String

Overrides

TfrxSeriesHelper.GetParamNames
See Also

Reference

  • TfrxBubbleSeriesHelper
  • frxChartHelpers


TfrxGanttSeriesHelper Class

Summary

Represents type TfrxGanttSeriesHelper.

Namespace: frxChartHelpers
Inheritance Hierarchy
TObject
frxChartHelpers.TfrxSeriesHelper
frxChartHelpers.TfrxGanttSeriesHelper
Syntax
Delphi
type
 TfrxGanttSeriesHelper = class(TfrxSeriesHelper)
 end;

The TfrxGanttSeriesHelper type exposes the following members.

Methods
Show:
Name | Description
AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType) | Overloaded. Represents method AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType). (Inherited from TfrxSeriesHelper.)
AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) | Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType). (Overrides TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).)
GetParamNames | Represents method GetParamNames. (Overrides TfrxSeriesHelper.GetParamNames.)
Top
See Also

Reference

  • frxChartHelpers


TfrxGanttSeriesHelper Methods

Methods
Name | Description
AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) | Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType). (Overrides TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).)
GetParamNames | Represents method GetParamNames. (Overrides TfrxSeriesHelper.GetParamNames.)
Top


TfrxGanttSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) Method

Summary

Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).

Namespace: frxChartHelpers
Syntax
Delphi
public
 procedure AddValues(Series: TChartSeries; const v1, v2, v3, v4, v5, v6: String;
 XType: TfrxSeriesXType); override;

Parameters

Series
Type: TChartSeries

v1
Type: String

v2
Type: String

v3
Type: String

v4
Type: String

v5
Type: String

v6
Type: String

XType
Type: TfrxSeriesXType

Overrides

TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType)
See Also

Reference

  • TfrxGanttSeriesHelper
  • frxChartHelpers


TfrxGanttSeriesHelper.GetParamNames Method

Summary

Represents method GetParamNames.

Namespace: frxChartHelpers
Syntax
Delphi
public
 function GetParamNames: String; override;

Return Value

Type: String

Overrides

TfrxSeriesHelper.GetParamNames
See Also

Reference

  • TfrxGanttSeriesHelper
  • frxChartHelpers


TfrxPieSeriesHelper Class

Summary

Represents type TfrxPieSeriesHelper.

Namespace: frxChartHelpers
Inheritance Hierarchy
TObject
frxChartHelpers.TfrxSeriesHelper
frxChartHelpers.TfrxPieSeriesHelper
Syntax
Delphi
type
 TfrxPieSeriesHelper = class(TfrxSeriesHelper)
 end;

The TfrxPieSeriesHelper type exposes the following members.

Methods
Show:
Name | Description
AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType) | Overloaded. Represents method AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType). (Inherited from TfrxSeriesHelper.)
AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) | Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType). (Overrides TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).)
GetParamNames | Represents method GetParamNames. (Overrides TfrxSeriesHelper.GetParamNames.)
Top
See Also

Reference

  • frxChartHelpers


TfrxPieSeriesHelper Methods

Methods
Name | Description
AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) | Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType). (Overrides TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).)
GetParamNames | Represents method GetParamNames. (Overrides TfrxSeriesHelper.GetParamNames.)
Top


TfrxPieSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) Method

Summary

Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).

Namespace: frxChartHelpers
Syntax
Delphi
public
 procedure AddValues(Series: TChartSeries; const v1, v2, v3, v4, v5, v6: String;
 XType: TfrxSeriesXType); override;

Parameters

Series
Type: TChartSeries

v1
Type: String

v2
Type: String

v3
Type: String

v4
Type: String

v5
Type: String

v6
Type: String

XType
Type: TfrxSeriesXType

Overrides

TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType)
See Also

Reference

  • TfrxPieSeriesHelper
  • frxChartHelpers


TfrxPieSeriesHelper.GetParamNames Method

Summary

Represents method GetParamNames.

Namespace: frxChartHelpers
Syntax
Delphi
public
 function GetParamNames: String; override;

Return Value

Type: String

Overrides

TfrxSeriesHelper.GetParamNames
See Also

Reference

  • TfrxPieSeriesHelper
  • frxChartHelpers


TfrxSeriesHelper Class

Summary

Represents type TfrxSeriesHelper.

Namespace: frxChartHelpers
Inheritance Hierarchy
TObject
frxChartHelpers.TfrxSeriesHelper
frxChartHelpers.TfrxArrowSeriesHelper
frxChartHelpers.TfrxBubbleSeriesHelper
frxChartHelpers.TfrxGanttSeriesHelper
frxChartHelpers.TfrxPieSeriesHelper
frxChartHelpers.TfrxStdSeriesHelper
Syntax
Delphi
type
 TfrxSeriesHelper = class(TObject)
 end;

The TfrxSeriesHelper type exposes the following members.

Methods
Show:
Name | Description
AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType) | Overloaded. Represents method AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType).
AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) | Overloaded. Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).
GetParamNames | Represents method GetParamNames.
Top
See Also

Reference

  • frxChartHelpers


TfrxSeriesHelper Methods

Methods
Name | Description
AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType) | Overloaded. Represents method AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType).
AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) | Overloaded. Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).
GetParamNames | Represents method GetParamNames.
Top


TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType) Method

Summary

Represents method AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType).

Namespace: frxChartHelpers
Syntax
Delphi
public
 procedure AddValues(Series: TChartSeries; const v1, v2, v3, v4, v5, v6, v7,
 v8, v9, v10: String; XType: TfrxSeriesXType); overload; virtual;

Parameters

Series
Type: TChartSeries

v1
Type: String

v2
Type: String

v3
Type: String

v4
Type: String

v5
Type: String

v6
Type: String

v7
Type: String

v8
Type: String

v9
Type: String

v10
Type: String

XType
Type: TfrxSeriesXType

See Also

Reference

  • TfrxSeriesHelper
  • frxChartHelpers


TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) Method

Summary

Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).

Namespace: frxChartHelpers
Syntax
Delphi
public
 procedure AddValues(Series: TChartSeries; const v1, v2, v3, v4, v5, v6: String;
 XType: TfrxSeriesXType); overload; virtual; abstract;

Parameters

Series
Type: TChartSeries

v1
Type: String

v2
Type: String

v3
Type: String

v4
Type: String

v5
Type: String

v6
Type: String

XType
Type: TfrxSeriesXType

See Also

Reference

  • TfrxSeriesHelper
  • frxChartHelpers


TfrxSeriesHelper.GetParamNames Method

Summary

Represents method GetParamNames.

Namespace: frxChartHelpers
Syntax
Delphi
public
 function GetParamNames: String; virtual; abstract;

Return Value

Type: String

See Also

Reference

  • TfrxSeriesHelper
  • frxChartHelpers


TfrxStdSeriesHelper Class

Summary

Represents type TfrxStdSeriesHelper.

Namespace: frxChartHelpers
Inheritance Hierarchy
TObject
frxChartHelpers.TfrxSeriesHelper
frxChartHelpers.TfrxStdSeriesHelper
Syntax
Delphi
type
 TfrxStdSeriesHelper = class(TfrxSeriesHelper)
 end;

The TfrxStdSeriesHelper type exposes the following members.

Methods
Show:
Name | Description
AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType) | Overloaded. Represents method AddValues(TChartSeries,String,String,String,String,String,String,String,String,String,String,TfrxSeriesXType). (Inherited from TfrxSeriesHelper.)
AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) | Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType). (Overrides TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).)
GetParamNames | Represents method GetParamNames. (Overrides TfrxSeriesHelper.GetParamNames.)
Top
See Also

Reference

  • frxChartHelpers


TfrxStdSeriesHelper Methods

Methods
Name | Description
AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) | Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType). (Overrides TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).)
GetParamNames | Represents method GetParamNames. (Overrides TfrxSeriesHelper.GetParamNames.)
Top


TfrxStdSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType) Method

Summary

Represents method AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType).

Namespace: frxChartHelpers
Syntax
Delphi
public
 procedure AddValues(Series: TChartSeries; const v1, v2, v3, v4, v5, v6: String;
 XType: TfrxSeriesXType); override;

Parameters

Series
Type: TChartSeries

v1
Type: String

v2
Type: String

v3
Type: String

v4
Type: String

v5
Type: String

v6
Type: String

XType
Type: TfrxSeriesXType

Overrides

TfrxSeriesHelper.AddValues(TChartSeries,String,String,String,String,String,String,TfrxSeriesXType)
See Also

Reference

  • TfrxStdSeriesHelper
  • frxChartHelpers


TfrxStdSeriesHelper.GetParamNames Method

Summary

Represents method GetParamNames.

Namespace: frxChartHelpers
Syntax
Delphi
public
 function GetParamNames: String; override;

Return Value

Type: String

Overrides

TfrxSeriesHelper.GetParamNames
See Also

Reference

  • TfrxStdSeriesHelper
  • frxChartHelpers


frxChartHelpers Types

Types
Name | Description
TfrxSeriesHelperClass | Represents type TfrxSeriesHelperClass.
Top


TfrxSeriesHelperClass Type

Summary

Represents type TfrxSeriesHelperClass.

Namespace: frxChartHelpers
Syntax
Delphi
type
 TfrxSeriesHelperClass = class of TfrxSeriesHelper;
See Also

Reference

  • frxChartHelpers


frxChartHelpers Constants

Constants
Name | Description
frxChartSeries | Represents constant frxChartSeries.
frxNumSeries | Represents constant frxNumSeries.
frxSeriesHelpers | Represents constant frxSeriesHelpers.
Top


frxChartSeries Constant

Summary

Represents constant frxChartSeries.

Namespace: frxChartHelpers
Syntax
Delphi
 frxChartSeries: array[0..frxNumSeries - 1] of TSeriesClass =
 (TLineSeries, TAreaSeries, TPointSeries,
 TBarSeries, THorizBarSeries, TPieSeries,
 TGanttSeries, TFastLineSeries, TArrowSeries,
 TBubbleSeries, TChartShape
 , THorizAreaSeries, THorizLineSeries
 );

Value

Type: array[0..frxNumSeries - 1] of TSeriesClass

See Also

Reference

  • frxChartHelpers


frxNumSeries Constant

Summary

Represents constant frxNumSeries.

Namespace: frxChartHelpers
Syntax
Delphi
 frxNumSeries = 13;

Value

Type: ShortInt

See Also

Reference

  • frxChartHelpers


frxSeriesHelpers Constant

Summary

Represents constant frxSeriesHelpers.

Namespace: frxChartHelpers
Syntax
Delphi
 frxSeriesHelpers: array[0..frxNumSeries - 1] of TfrxSeriesHelperClass =
 (TfrxStdSeriesHelper, TfrxStdSeriesHelper, TfrxStdSeriesHelper,
 TfrxStdSeriesHelper, TfrxStdSeriesHelper, TfrxPieSeriesHelper,
 TfrxGanttSeriesHelper, TfrxStdSeriesHelper, TfrxArrowSeriesHelper,
 TfrxBubbleSeriesHelper, TfrxStdSeriesHelper
 , TfrxStdSeriesHelper, TfrxStdSeriesHelper
 );

Value

Type: array[0..frxNumSeries - 1] of TfrxSeriesHelperClass

See Also

Reference

  • frxChartHelpers


frxChartHelpers Routines

Routines
Name | Description
frxFindSeriesHelper(TChartSeries) | Represents method frxFindSeriesHelper(TChartSeries).
Top


frxFindSeriesHelper(TChartSeries) Method

Summary

Represents method frxFindSeriesHelper(TChartSeries).

Namespace: frxChartHelpers
Syntax
Delphi
function frxFindSeriesHelper(Series: TChartSeries): TfrxSeriesHelper;

Parameters

Series
Type: TChartSeries

Return Value

Type: TfrxSeriesHelper

See Also

Reference

  • frxChartHelpers


frxChartInPlaceEditor Namespace

Summary

Represents namespace frxChartInPlaceEditor.

Classes
Name | Description
TfrxInPlaceChartEditor | Represents type TfrxInPlaceChartEditor.
Top


frxChartInPlaceEditor Classes

Classes
Name | Description
TfrxInPlaceChartEditor | Represents type TfrxInPlaceChartEditor.
Top


TfrxInPlaceChartEditor Class

Summary

Represents type TfrxInPlaceChartEditor.

Namespace: frxChartInPlaceEditor
Inheritance Hierarchy
TfrxInPlaceBasePanelEditor
frxChartInPlaceEditor.TfrxInPlaceChartEditor
Syntax
Delphi
type
 TfrxInPlaceChartEditor = class(TfrxInPlaceBasePanelEditor)
 end;

The TfrxInPlaceChartEditor type exposes the following members.

Methods
Show:
Name | Description
Count | Represents method Count.
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DrawCustomEditor(TCanvas,TRect) | Represents method DrawCustomEditor(TCanvas,TRect).
FinalizeUI(TfrxInteractiveEventsParams) | Represents method FinalizeUI(TfrxInteractiveEventsParams).
GetColor(Integer) | Represents method GetColor(Integer).
GetItem(Integer) | Represents method GetItem(Integer).
GetName(Integer) | Represents method GetName(Integer).
InitializeUI(TfrxInteractiveEventsParams) | Represents method InitializeUI(TfrxInteractiveEventsParams).
SetItem(Integer,Boolean) | Represents method SetItem(Integer,Boolean).
Top
Fields
Show:
Name | Description
F3DMode | Represents field F3DMode.
FDrawButton | Represents field FDrawButton.
Top
See Also

Reference

  • frxChartInPlaceEditor


TfrxInPlaceChartEditor Methods

Methods
Name | Description
Count | Represents method Count.
DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) | Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).
DrawCustomEditor(TCanvas,TRect) | Represents method DrawCustomEditor(TCanvas,TRect).
FinalizeUI(TfrxInteractiveEventsParams) | Represents method FinalizeUI(TfrxInteractiveEventsParams).
GetColor(Integer) | Represents method GetColor(Integer).
GetItem(Integer) | Represents method GetItem(Integer).
GetName(Integer) | Represents method GetName(Integer).
InitializeUI(TfrxInteractiveEventsParams) | Represents method InitializeUI(TfrxInteractiveEventsParams).
SetItem(Integer,Boolean) | Represents method SetItem(Integer,Boolean).
Top


TfrxInPlaceChartEditor.Count Method

Summary

Represents method Count.

Namespace: frxChartInPlaceEditor
Syntax
Delphi
protected
 function Count: Integer; override;

Return Value

Type: Integer

See Also

Reference

  • TfrxInPlaceChartEditor
  • frxChartInPlaceEditor


TfrxInPlaceChartEditor.DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams) Method

Summary

Represents method DoMouseUp(Integer,Integer,TMouseButton,TShiftState,TfrxInteractiveEventsParams).

Namespace: frxChartInPlaceEditor
Syntax
Delphi
public
 function DoMouseUp(X, Y: Integer; Button: TMouseButton;
 Shift: TShiftState; var EventParams: TfrxInteractiveEventsParams): Boolean; override;

Parameters

X
Type: Integer

Y
Type: Integer

Button
Type: TMouseButton

Shift
Type: TShiftState

EventParams
Type: TfrxInteractiveEventsParams

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceChartEditor
  • frxChartInPlaceEditor


TfrxInPlaceChartEditor.DrawCustomEditor(TCanvas,TRect) Method

Summary

Represents method DrawCustomEditor(TCanvas,TRect).

Namespace: frxChartInPlaceEditor
Syntax
Delphi
public
 procedure DrawCustomEditor(aCanvas: TCanvas; aRect: TRect); override;

Parameters

aCanvas
Type: TCanvas

aRect
Type: TRect

See Also

Reference

  • TfrxInPlaceChartEditor
  • frxChartInPlaceEditor


TfrxInPlaceChartEditor.FinalizeUI(TfrxInteractiveEventsParams) Method

Summary

Represents method FinalizeUI(TfrxInteractiveEventsParams).

Namespace: frxChartInPlaceEditor
Syntax
Delphi
public
 procedure FinalizeUI(var EventParams: TfrxInteractiveEventsParams); override;

Parameters

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxInPlaceChartEditor
  • frxChartInPlaceEditor


TfrxInPlaceChartEditor.GetColor(Integer) Method

Summary

Represents method GetColor(Integer).

Namespace: frxChartInPlaceEditor
Syntax
Delphi
protected
 function GetColor(Index: Integer): TColor; override;

Parameters

Index
Type: Integer

Return Value

Type: TColor

See Also

Reference

  • TfrxInPlaceChartEditor
  • frxChartInPlaceEditor


TfrxInPlaceChartEditor.GetItem(Integer) Method

Summary

Represents method GetItem(Integer).

Namespace: frxChartInPlaceEditor
Syntax
Delphi
protected
 function GetItem(Index: Integer): Boolean; override;

Parameters

Index
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceChartEditor
  • frxChartInPlaceEditor


TfrxInPlaceChartEditor.GetName(Integer) Method

Summary

Represents method GetName(Integer).

Namespace: frxChartInPlaceEditor
Syntax
Delphi
protected
 function GetName(Index: Integer): String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TfrxInPlaceChartEditor
  • frxChartInPlaceEditor


TfrxInPlaceChartEditor.InitializeUI(TfrxInteractiveEventsParams) Method

Summary

Represents method InitializeUI(TfrxInteractiveEventsParams).

Namespace: frxChartInPlaceEditor
Syntax
Delphi
public
 procedure InitializeUI(var EventParams: TfrxInteractiveEventsParams); override;

Parameters

EventParams
Type: TfrxInteractiveEventsParams

See Also

Reference

  • TfrxInPlaceChartEditor
  • frxChartInPlaceEditor


TfrxInPlaceChartEditor.SetItem(Integer,Boolean) Method

Summary

Represents method SetItem(Integer,Boolean).

Namespace: frxChartInPlaceEditor
Syntax
Delphi
protected
 procedure SetItem(Index: Integer; const Value: Boolean); override;

Parameters

Index
Type: Integer

Value
Type: Boolean

See Also

Reference

  • TfrxInPlaceChartEditor
  • frxChartInPlaceEditor


TfrxInPlaceChartEditor Fields

Fields
Name | Description
F3DMode | Represents field F3DMode.
FDrawButton | Represents field FDrawButton.
Top


TfrxInPlaceChartEditor.F3DMode Field

Summary

Represents field F3DMode.

Namespace: frxChartInPlaceEditor
Syntax
Delphi
protected
 F3DMode: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceChartEditor
  • frxChartInPlaceEditor


TfrxInPlaceChartEditor.FDrawButton Field

Summary

Represents field FDrawButton.

Namespace: frxChartInPlaceEditor
Syntax
Delphi
protected
 FDrawButton: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TfrxInPlaceChartEditor
  • frxChartInPlaceEditor